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Introduction 
The HP Adoption Readiness Tool (HP ART) is an innovative authoring tool that allows 
consultants and clients to create customized training, documentation, and support content, 
whether starting with HP prebuilt content or creating new material. As a single source, multiple 
output, object recognition technology, HP ART dramatically reduces content development time and 
improves software adoption. 

This guide contains high-level, step-by-step instructions to create the HP ART website. This guide is 
designed as a supplemental support document only and is not intended to be a replacement for 
training. 

For additional information about ART and ART Training and Services, contact your HPSW Sales 
Representative today or contact hpsoftware.art@hp.com for further information. 

This document is updated based on consumer feedback. Check the Software Support Online 
(SSO) HP Software to ensure that you have the current version. 

  

mailto:hpsoftware.art@hp.com
http://support.openview.hp.com/selfsolve/manuals
http://support.openview.hp.com/selfsolve/manuals
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HP ART Website Structure 
The HP ART website is organized into three levels, each represented by a separate web page—
the ART product launch page, the Course launch page, and the Module launch page. 
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ART Product Launch Page 

 

The top level of the ART website is the ART product. The ART product web page introduces you to 
ART. This page includes a short introduction to ART, as well as the prerequisites required to view 
ART content. You can access each HP Software ART course included in the website from the left 
navigation menu of the ART product launch page under the Select a Course heading. 

Important: When referring to the ART website, do not confuse the term course with the (.ulc) 
ART Developer Kit source file. The courses listed on the ART product launch page represent 
HP Software ART content, for example the Cloud Service Automation 3.1 ART course or the 
HP Service Manager 9.30 ART course. 
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Course Launch Page 

 
The second level of the ART website is the course web page. The course web page introduces the 
selected HP Software ART course. In the example above, a Service Manager course launch page 
is displayed. The course launch page includes an overview of the HP Software ART course, 
including the learning objectives. 

All HP Software ART courses consist of several modules. You can access the modules that are 
included in the selected course from the left navigation menu under the Select a Module heading. 
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Module Launch Page 

 

The Module launch page provides access to the ART content. You can either launch the e-learning 
course module directly by clicking the Launch Module button or, to quickly master a specific task, 
you can launch a simulation or job aid within the Launch Simulation or Launch Job Aid options. 
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Creating the ART Website 
When you purchase an HP Software ART course, the ART website output files are included in the 
content package within the output folder. 

To create your own ART website, or customize an existing website, you complete the following 
steps: 

1. Prepare the ART files. 
2. Create the website (.uws) file. 
3. Insert the source content files. 
4. Organize the website. 
5. Create the ART product launch page. 
6. Create the course launch page. 
7. Organize the website with the new launch pages. 
8. Batch publish source files. 
9. Publish the website. 

 

Step 1: Prepare the ART Files 
Before creating the ART website, you should organize the ART content into the following folder 
structure: 

ART_Project 

 source 

  module1 

   (folder containing the course and recording source files for module 1) 

  module2 

   (folder containing the course and recording source files for module 2) 

  … 

Below is a sample ART project folder for the HP Asset Manager 9.30 ART course: 
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For each module, the module folder contains the course (.ulc) and recording (.udc) source files: 

 
 

Step 2: Create the Website (.uws) File 
Select File → New… from the ART editor window. 

Within the New window, populate the following fields and click the OK button: 

File name Enter the name of the website (.uws) file. 

Type Select Website from the drop-down menu. 

Template Select the desired template. 

Language Select the desired language. 

Location Specify the location to store the website (.uws) file. 
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The ART editor displays the new website file. 

 
If this is the first time you are creating a website, select View → Configure from the ART editor. 
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Within the Choose Details… window, select PORTFOLIO, Product, and Module from the drop-
down lists and then click the OK button. This confirms that these columns will be displayed in the 
Links panel so that you can easily determine if the module properties are entered correctly. 

 

 

Step 3: Insert the Source Content Files 
To insert the source content files, select Insert → Multiple Links… from the editor menu. 

Navigate to the source folder of your project and click the OK button. 
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Note: All source files located within the source folder are imported into the website. 

 

A progress menu is displayed during the import process. 
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The Links window pane lists each file. Notice that each file is categorized by PORTFOLIO, 
Product, and Module. HP ART creates the website structure based on how you configure the 
properties for each file. For this reason, you must properly complete the properties for each file. 

 
Before continuing to build the website, you should validate the content loaded into the Links 
content pane. Under the Type column, all course module files (.ulc) are listed as Course and all 
recording files (.udc) are listed as Document. 

If you discover that a file is incorrect or missing the PORTFOLIO, Product, or Module information: 

1. Open the source files and correct the property information. 
2. Save the file. 
3. Refresh the .uws properties by right-clicking a document in the table, select Properties, 

and click OK. This forces a refresh of all file properties. 

Note: Use the View → Refresh option to ensure that all the files in the website are the 
current version. 
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Step 4: Organize the Website 
ART uses the Product and Module property values of each file to organize the structure of the 
website. 

Select Insert → Organize Website from the editor menu. 

A confirmation message is displayed. Click the Yes button. 

 

The new organization of the website is displayed within the Pages pane. The three organizational 
levels include: 

• The root .uws file 
• The HP Software ART course (Service Manager Sample in this example) 
• All modules within the ART course 
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The Pages task pane on the left is organized based on the defined product and module. This 
pane shows the order in which the course modules will appear on the final website. These titles 
appear in the breadcrumbs on the website. You can edit the names, if necessary. 

This is another opportunity to ensure that the module properties are accurate. The Organize 
Website function creates a page for each unique product and module. If there are typos or 
missing information, it will be obvious when reviewing this website tree. 

If desired, you can reorder the modules using drag and drop. If you use the best practice of 
naming your files starting with 01_*, 02_*, and so forth, they will display in the designed order. 

By default, the root page is given the same name as the .uws file. You should change the name 
to easily identify the course. 

 
To change the root page name, select File → Document Properties …. 
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Within the Properties window, edit the Title field with the desired name. 

 
 

Step 5: Create the ART Product Launch Page 
The ART product launch page is the first page you see when you launch the ART website. 
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The ART product launch page is a logical link, not a physical web page. You create a link and 
configure its properties with the information you want to display on the launch page. When you 
publish the course, HP ART pulls the property information and formats it to create the launch 
page. 

To create the ART product launch page, select Insert → Insert Link from the editor menu. 

Within the General section of the Insert Link window, populate the following fields as shown: 

Name ART Product Launch Page 

URL http://dummy 

 
Navigate to the Properties section of the Insert Link window. Enter the information you want to 
display on the ART product launch web page. 

You can use the following fields to populate the ART product launch web page. All fields are 
optional, with the exception of the InfoPage field. When you set the InfoPage field to True, ART 
recognizes the page as a launch page. 

Property Field Description 

BeginHere Instructions to learner on what to do after reading the 
product launch page contents. Appears last on the 
product launch page 

Description First paragraph that is displayed 

DescriptionBullet1 Description bullet list item 1 

DescriptionBullet2 Description bullet list item 2 

DescriptionBullet3 Description bullet list item 3 
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Property Field Description 

DescriptionBullet4 Description bullet list item 4 

Description2ndParagraph Second paragraph displayed after description bullets 

Objective1 Objective list item 1 

Objective2 Objective list item 2 

Objective3 Objective list item 3 

Objective4 Objective list item 4 

Objective5 Objective list item 5 

Audience Statement that describes the intended audience of the 
ART product 

Prerequisite1 Prerequisite 1 

Prerequisite2 Prerequisite 2 

Prerequisite3 Prerequisite 3 

InfoPage Must be set to True for all logical website launch pages 
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Click the OK button to save the properties. 

The following information is included on the launch page for all prebuilt ART courses: 
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Prebuilt ART Product Launch Page Properties 

BeginHere To begin, select a course from the left navigation menu. 

Description HP Adoption Readiness Tool (ART) is a learning and performance 
support solution accessible anytime, anywhere to help ensure your 
effective use of the software. 

Prerequisite1 High speed Internet connection 

Prerequisite2 Web Browser (IE 7.0+, Mozilla Firefox 17+, Google Chrome 24, or 
Safari 5.0) 

Prerequisite3 Adobe Acrobat Reader 9.x, 10.x, or XI  

InfoPage True 

 

You access the logical ART product page using the Page tab located on the upper left of the 
website (.uws) file. Notice that the page type is set to Link. To make changes to the virtual page 
properties, double-click the link to open the Properties window. 
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Step 6: Create the Course Launch Page 
The course launch page is displayed when you select an HP Software ART course from the ART 
product launch page. 

 
The process of creating the course launch web page is very similar to creating the ART product 
launch page. 

Select Insert → Insert Link from the editor menu. 

Within the General section of the Insert Link window, populate the following fields as shown: 

Name <name of ART course> Launch Page  

URL http://dummy 
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Navigate to the Properties section of the Insert Link window. Enter the desired information to be 
displayed on the course launch page.   

Below are the property values that are typically entered for the course launch page. 

Important: For the course launch page, you must select the product to ensure that the launch 
page is organized at the HP Software course level. 

Property Field Description 

Product Product (select from the drop-down menu – used to organize 
website) 

BeginHere Provide instructions to learner about how to begin the course 

Description High-level overview of the HP Software ART course 

Objective1 Course Objective 1 

Objective2 Course Objective 2 

Objective3 Course Objective 3 
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Property Field Description 

Objective4 Course Objective 4 

Objective5 Course Objective 5 

InfoPage True (required for all launch pages) 
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Click the OK button to save the properties. 



HP ART 5.2 Website Guide 

Page 23 of 38 

 Copyright 2014 – 2015 Hewlett-Packard Development Company, L.P. 

About the Module Launch Page 
You manage the Module launch page within the Properties window of the module course (.ulc) 
source file. Authors populate the properties of each file during the development cycle. 

 
Below are the property values that are typically entered for the Module launch web page:  

Module Properties 

PORTFOLIO PORTFOLIO of the HP Software Product. 

Product Product of the HP Software Product. 

Description High-level overview of the module. 

Build_num yyyy.mm that the file was last modified (not displayed on website, 
used for versioning only) 

Module Name of module. The Module field is used to organize the file 
during the website publishing process. Every file in the ART project 
must have the Module field populated. 
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Step 7: Organize the Website with the New Launch Pages 
After you create the Product and Course launch pages, organize the website to pick up the newly 
added pages. 

Select Insert → Organize Website from the editor menu. 
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The following shows the product launch page listed at the correct level: 

  
 

The following shows the course launch page listed at the correct level: 
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Step 8: Batch Publish Source Files 
Next, you are ready to publish the source files. Select File → Publish → Batch Publish from the 
ART editor menu. 
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Within the Batch Publish window, select the following options to be published: 

 
In the lower half of the Batch Publish window, populate the following fields and click the Publish 
button: 

Inbox Browse to the source folder. 

Outbox Create a new folder named output, under the project root folder. 
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The Batch Publish process takes several minutes, the exact time depending on the number of files 
in the website. A progress window will be displayed with notification of the status. 

 
When the batch publish process completes, the Publishing Summary window is displayed. Click 
the OK button. 
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Step 9: Publish the Website 
The batch publish process publishes the source files contained within the website. The final step is 
to publish the website file itself. Select → File → Publish → Publish Current ... to publish the 
website. 

 
Within the Publish window, select the xml checkbox. Ensure that the Outbox is directed to the 
output folder created during the batch publish. 
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When publishing is complete, click the Xml link to view the final website. 

 
Note: All output files are stored within the output folder specified within the Publish window. 
Click the index.htm file to launch the website. 
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Viewing the ART Website Locally 
When viewing the ART website locally, you must enable browser security settings. 

Mozilla FireFox 

1. Navigate to about:config within the FireFox browser. 
2. Change the security.fileuri.strict_origin_policy preference to false. 

 

Google Chrome 

1. Create a shortcut to Chrome. You can simply copy/paste the existing desktop shortcut, if 
you have one, or copy/paste the Chrome shortcut in the Start menu to your desktop. 

2. Right-click the shortcut and go to Properties. 
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3. In the target field, add the following line: 

--allow-file-access-from-files 
For example, the entire target field is displayed and looks similar to the following: 

C:\Users\UserName\AppData\Local\Google\Chrome\Application\chrome.
exe --allow-file-access-from-files 

4. Click OK. 
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Adding Related Documents to the HP ART Website 
You can add external documents to the HP ART website at the product, course, and/or module 
levels. After external documents are added to the website, they are embedded with the file and 
accessible to all users. 

To add a document to the website, perform the following steps: 

1. Open the website (.uws) file. 
2. Select Insert → Link from the ART editor menu. 
3. Within the General menu item: 

a. In the Name field, enter a title for the document to display on the website. 
b. Use the File field browse button to navigate to the source file. 
c. Select the Copy content to published website folder check box to ensure that the 

document is stored with the published website files. 
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4. The information required in the Properties menu item depends on where you would like the 
related document displayed on the website. 

 

a. To display the related document on the HP ART product launch page, leave all fields 
within the Properties window blank. 
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b. To display the related document at the Course level, select the PORTFOLIO, Product fields. 

 

c. To display the related document at the Module level, select the PORTFOLIO, Product fields, 
and the appropriate Module field. 
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Important: Whenever you change the website page properties, you must refresh the website 
organization using Insert → Organize Website. 
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