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Support
Visit the HP Software Support Online web site at:https://softwaresupport.hp.com

This web site provides contact information and details about the products, services, and support that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and efficient way to access interactive technical support tools
needed to manage your business. As a valued support customer, you can benefit by using the support web site to:

l Search for knowledge documents of interest
l Submit and track support cases and enhancement requests
l Download software patches
l Manage support contracts
l Look up HP support contacts
l Review information about available services
l Enter into discussions with other software customers
l Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a support contract. To register for an HP
Passport ID, go to:https://softwaresupport.hp.com and click Register.

To find more information about access levels, go to:https://softwaresupport.hp.com/web/softwaresupport/access-levels.

HP Software Solutions & Integrations and Best Practices
VisitHP Software Solutions Now athttps://h20230.www2.hp.com/sc/solutions/index.jsp to explore how the products in the HP
Software catalog work together, exchange information, and solve business needs.

Visit the Cross Portfolio Best Practices Library athttps://hpln.hp.com/group/best-practices-hpsw to access a wide variety of best
practice documents and materials.
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Welcome to the Run Results Viewer
User Guide
The HP Run Results Viewer User Guide explains how to use the Run Results Viewer to
interpret and use the test results from your GUI or API tests.

It is recommended to have some prior knowledge of UFT and its testing capabilities so
you can fully evaluate the test results.

Additional Online Resources
The following additional online resources are available:

Resource Description

HP Software
Support Online

The HP Software Support Web site
(www.hp.com/go/hpsoftwaresupport). To access, choose
Help > HP Software Support.

Note:Most of the support areas require that you register
as an HP Passport user and sign in. Many also require a
support contract. To register for an HP Passport user ID,
go to: http://h20229.www2.hp.com/passport-
registration.html

Testing Forums l API Testing: http://h30499.www3.hp.com/t5/Service-Test-
Support-and-News/bd-p/sws-Serv_TEST_SF

l BPT: http://h30499.www3.hp.com/t5/Business-Process-
Validation/bd-p/sws-BPT_SF
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Resource Description

UFT Product
Page

The HP Unified Functional Testing product page
(http://www8.hp.com/us/en/software-solutions/unified-
functional-testing-automated-testing/index.html), with
information and related links about UFT. To access, select
Help > Useful Links > Product Page.

Troubleshooting
& Knowledge
Base

The Troubleshooting page
(http://h20230.www2.hp.com/troubleshooting.jsp) on the HP
Software Support Web site where you can search the HP
Software Self-solve knowledge base. To access, select
Help > Knowledge Base or Help > Troubleshooting.

HP Software
Community

The HP IT Experts Community site
(http://h10124.www1.hp.com/campaigns/IT_
Experts/pages/home.html), where you can interact with other
HP software users, read articles and blogs on HP software
and access downloads of other software products.

HP Manuals Site The HP Software Product Manuals Web site
(http://support.openview.hp.com/selfsolve/manuals), to
search for the most up-to-date documentation for a selected
HP Software product. To access, select Help > Useful
Links > HP Manuals Site.

What's New The UFT What's New Help, describing the new features and
enhancements in this version of UFT.

Product Movies The UFT HPLN (HP Live Networks) page
(https://hpln.hp.com/page/uft-120-videos) with a list of all
product movies.

HP Software
Web site

The HP Software Web site (www.hp.com/go/software). This
site provides you with the most up-to-date information on HP
Software products. This includes new software releases,
seminars and trade shows, customer support, and more.
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Concepts

Run Results Viewer Overview
After running a test or component, you can view the run results in the HP Run Results
Viewer. The Run Results Viewer contains multiple panes, each of which displays specific
types of information. The "Run Results Tree Pane and Search Box" displays a
hierarchical representation of the run results. The remaining panes provide details
about a selected node or step, the data used for a particular step, optional screen
captures or images (UFT GUI testing only), optional system information (UFT GUI
testing only), and so on. For an overview of the various panes, see "Run Results Viewer
User Interface" on page 32.

By default, the Run Results Viewer opens automatically at the end of a run session. If
you want to change this behavior, in UFT, clear the View results when run session
ends check box in the Run Sessions pane of the Options dialog box (Tools > Options >
General tab > Run Sessions node).

The Run Results Viewer contains a description of the steps performed during the run
session.

l For a GUI component, or for a GUI test that does not contain Data Pane parameters,
the Run Results Viewer shows a single test iteration.

l For tests, if the test contains Data Pane parameters, and the test settings are
configured to run multiple iterations, the Run Results Viewer displays details for
each iteration of the test run. The results are grouped by the actions in the test.

l For an API test, the individual steps and checkpoints included in the test. If a test is
set to run multiple iterations, each iteration is displayed.

You set the test to run for one or all iterations in the Run pane of the Settings dialog
box. For details, see the section describing the Run pane in the HP Unified Functional
Testing User Guide.
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UFT GUI/UFT API Integration
If you run a UFT GUI test that contains a call to a UFT API or Service Test test, or vice
versa, you can view the results for all steps performed in the main test and in the
called test.

(Not relevant for business components)

Viewing Partial Results (UFT GUI Testing Only)
In addition to viewing the results for a run session after a run is complete (including
runs that crash prior to completion), you can view the results during a run session by
opening the results.xml file for that run. This enables you to view partial results (up
to the step for which the results are opened). For example, you may want to view the
results for a specific iteration before the run continues to the next iteration. One way
to do this is to insert a step that opens a message box, as this stops the run until you
close the message box. For example:

MsgBox "Open the following file:" & Reporter.ReportPath

Note: To view the partial results in the Run Results Viewer, you need to open the
results file from another computer.

Installing the Run Results Viewer
The Run Results Viewer is installed automatically with UFT.

You can also install the Run Results Viewer as a standalone application. This enables
you to share the results of your tests with business analysts and developers who do not
have UFT installed on their computers. For details, see "How to Install the Run Results
Viewer as a Standalone Application".

Run Results XML File
The results of each run session are saved in a single .xml file (called results.xml).
This .xml file stores information on each of the run result nodes in the display. The
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information in these nodes is used to dynamically create .htm files that are shown in
the Result Details pane in the Run Results Viewer.

Each node in the run results tree is an element in the results.xml file. In addition,
there are different elements that represent different types of information displayed in
the run results. You can take run result information from the .xml file and use XSL to
display the information you require in a customized format (either when printing from
within the Run Results Viewer, when displaying run results in your own customized
results viewer, or when exporting the run results to an .html file).

The diagram below for a GUI test, shows the correlation between some of the elements
in the .xml file and the items they represent in the run results. These elements are
similar for both tests and business components.

XSL provides you with the tools to describe exactly which run result information to
display and exactly where and how to display, print or export it. You can also modify
the .css file referenced by the .xsl file, to change the appearance of the report (for
example, fonts, colors, and so forth).
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For example, in the results.xml file, one element tag contains the name of an action
or a component, and another element tag contains information on the time at which the
run session is performed. Using XSL, you could tell your customized Run Results Viewer
that the action or component name should be displayed in a specific place on the page
and in a bold green font, and that the time information should not be displayed at all.

You may find it easier to modify the existing .xsl and .css files provided with the Run
Results Viewer application, instead of creating your own customized files from scratch.
The files are located in the HP\Run Results Viewer\dat folder, and are named as
follows:

l PShort.xsl. Specifies the content of the run results report printed, or exported to
an HTML file, when you select the Short option in the Print or Export to HTML File
dialog boxes.

l PDetails.xsl. Specifies the content of the run results report printed, or exported
to an HTML file, when you select the Detailed option in the Print or Export to HTML
File dialog boxes.

l PStringTable.xsl. Specifies the string constants to be used in the exported
document. For example, Iteration # may be used for the iteration number prefix.
If you select the User-defined XSL option in the Print or Export to HTML File dialog
boxes, the .xsl file you specify must contain an "include" call to this file. You can
localize the strings, if needed.

l PResults.css. Specifies the appearance of the run results print preview. This file
is referenced by the above .xsl files.

l Results.css. Specifies the styles, fonts, and colors of the various elements
displayed in the run results.

For more details on printing run results using a customized .xsl file, see "Print Dialog
Box (Run Results Viewer)" on page 87.

For more details on exporting the run results to a file using a customized .xsl file, see
"Export Run Results Dialog Box (Run Results Viewer)" on page 77.

UFT only: For details on the structure of the XML schema, and a description of the
elements and attributes you can use to customize the run results reports, see the HP
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Run Results Schema Reference (Help > HP UFT GUI Testing Automation and Schema
References Help > HP Run Results Schema Reference).

Run Results File Location
Depending on the type of test, run results can be stored in different locations.

GUI Tests
Tests saved in the file system. By default, the results of a GUI test saved in the file
system are stored in the test folder. When you run your test, you can specify a different
location to store the results, using the Results Location tab of the Run dialog box.
Specifying your own location for the results file can make it easier for you to locate the
results file in the file system.

Tests saved in ALM. Run results are stored in the test folder in ALM. You cannot change
the location of the run session results.

For details, see the section describing the Run dialog box in the HP Unified Functional
Testing User Guide.

GUI Components
By default, the results of a component run are stored in an ALM cache folder on your
computer.

When you run your test, you can specify a different location to store the results, using
the Results Location tab of the Run dialog box. Specifying your own location for the
results file can make it easier for you to locate the results file in the file system.

For details, see section describing the Run dialog box in the HP Unified Functional
Testing User Guide.

API Tests
Tests saved in the file system. By default, the results of API tests that are saved in the
file system, are stored in the test folder. When you run your test, you can specify a
different location to store the results, using the Results Location tab of the Run dialog
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box. Specifying your own location for the results file can make it easier for you to
locate the results file in the file system.

Tests saved in ALM. Run results are stored in your ALM project. You cannot change the
location of the run session results.

For details, see the HP Unified Functional Testing User Guide.

Custom Fields (UFT API Testing Only)
You can use the Report function to show custom information in the Run Results Viewer.
You can specify strings or existing arguments and display them in the viewer.

You add the Report function to the step's events. For details, see the section on
Custom Code and Events in the HP Unified Functional Testing User Guide.

The following example prints APR-12-2010_CYCLE_1 in the Value column for TestID.

args.Activity.Report("TestID","APR-12-2010_CYCLE_1");

The report displays the keyword and its value at the Activity level of the results. For
details, see "Captured Data Pane (Run Results Viewer) " on page 54.
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Accessing the UFT in Windows 8 Operating
Systems
By default, the Run Results Viewer is not displayed on the Start or Apps screen in
Windows 8.x.

You can add the Run Results Viewer to the Start screen by navigating to its location on
the file system or the Desktop screen and pinning it to the Start screen.

In addition, you can add other related files, including .exe files and documentation the
Start screen by pinning these items.

Note: By default, the Start and Apps screens on Windows 8 are set to open Internet
Explorer in Metro Mode. However, if User Account Control is turned off on your
computer, Windows 8 will not open Internet Explorer in Metro mode. Therefore, if
you try to open an HTML shortcut from the Start or Apps screen, such as the UFT
Help or Readme file, an error will be displayed.

To solve this, you can change the default behavior of Internet Explorer so that it
never opens in Metro mode. In the Internet Properties dialog box > Programs tab,
select Always in Internet Explorer on the desktop for the Choose how you open
links option. For more details, see http://support.microsoft.com/kb/2736601 and
http://blogs.msdn.com/b/ie/archive/2012/03/26/launch-options-for-internet-
explorer-10-on-windows-8.aspx.
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Tasks

How to Install the Run Results Viewer as a
Standalone Application
The Run Results Viewer is installed by default together with UFT. This task describes
how to install the Run Results Viewer as a standalone application. For example,
business analysts and developers that do not have UFT installed on their computers can
install the Run Results Viewer locally as a standalone application. You can then share
the results of your tests with them.

1. Install the prerequisite applications, if any.

Insert the UFT installation DVD into a DVD drive and browse to and double-click
RunResultsViewer\EN\setup.exe. Setup checks your computer for the
required prerequisites, and enables you to install them, if needed. Follow the on-
screen instructions. After the prerequisites are installed, you may need to restart
the computer.

2. Install the HP Run Results Viewer.

Insert the UFT installation DVD into a DVD drive and browse to and double-click
RunResultsViewer\EN\setup.exe. Follow the on-screen instructions.

The Run Results Viewer is installed and can be opened from Start > All Programs >
HP Software > HP Run Results Viewer > Run Results Viewer.

Note: For details on accessing UFT and UFT tools and files in Windows 8 and
Windows Server 2012, see "Accessing the UFT in Windows 8 Operating
Systems" on the previous page.
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How to Open Run Results
The following steps describe how to open specific run results in the Run Results Viewer:

l "Open the Run Results Viewer" below

l "Connect to your ALM project - optional" below

l "View saved results " below

Open the Run Results Viewer
Open the Run Results Viewer in one of the following ways:

l In UFT, select View > Last Run Results or click the Results button .

l From the Startmenu, select Start > All Programs >HP Software > HP Run Results
Viewer > Run Results Viewer.

l Run a test or component. By default, the results are displayed in the Run Results
Viewer at the end of the run session. (In UFT, you can change the default setting in
the Run Sessions pane of the Options dialog box. For details, see the HP Unified
Functional Testing User Guide.)

Note: This section describes how to open tests and components run in UFT. For
other types of tests, see your testing product's documentation.

Connect to your ALM project - optional
If your run results are saved in ALM, connect to your ALM project before opening the
results file. For details, see "HP ALM Connection Dialog Box (Run Results Viewer)" on
page 91.

View saved results
When you open the Run Results Viewer manually, the Open Run Results dialog box
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opens automatically, enabling you to select results to display.

If the Run Results Viewer opened automatically, click the Open button or select File >

Open . Browse to the relevant results. For details, see "Open Run Results Dialog
Box" on page 86.

How to Navigate the Run Results Tree
This task describes how to collapse or expand a branch in the run results tree to select
the level of detail that the tree displays.

When you open run results in the Run Results Viewer for the first time, the tree
expands one level at a time. If the child branches under a parent branch were
previously expanded, that state is maintained when you expand or collapse the parent
branch.

You can do the following to view the results:

l "Expand a specific branch" below

l "Expand a branch and all branches below it: " on the next page

l "Expand all of the branches in the run results tree: " on the next page

l "Collapse a specific node: " on the next page

l "Collapse all of the nodes in the tree: " on page 22

l "Move between previously selected nodes within the run results tree: " on page 22

l "Find specific steps within the Run Results: " on page 22

l "Filter the tree to display only nodes that match certain criteria: " on page 22

Expand a specific branch

l Double-click the branch.
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l Select the branch and click the arrow to the left of the branch icon.

l Press the plus key (+) on your keyboard number pad.

The tree displays the details for the branch, and the expand sign changes to collapse.

Expand a branch and all branches below it:

l Select the branch and press the asterisk (*) key on your keyboard number pad.

l Right-click a branch and select Expand All.

Expand all of the branches in the run results tree:

l Right-click the top level branch and select Expand All.

l Select View > Expand All.

l Click the Expand All button .

l Select the top level of the tree and press the asterisk (*) key on your keyboard
number pad.

Collapse a specific node:

l Double-click the node.

l Right-click a node and select Collapse All.

l Select it and click the arrow to the left of the node icon.

l Press the minus key (–) on your keyboard number pad.

The node's child nodes disappear from the tree.
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Collapse all of the nodes in the tree:

l Right-click the top level branch and select Collapse All.

l Select View > Collapse All.

l Click the Collapse All button .

Move between previously selected nodes within the run results
tree:

Click the Go to Previous Node or Go to Next Node buttons .

Find specific steps within the Run Results:
Use the Search box (located above the run results tree), for example:

You can search for text, status, and/or types of nodes. For details, see "Run Results
Tree Pane and Search Box" on page 42.

Filter the tree to display only nodes that match certain criteria:
Use the Filter dialog box (View > Filters). For details, see "Filter Dialog Box (Run
Results Viewer) " on page 82.

How to Customize the Run Results Viewer
The following steps describe how to customize the layout of the Run Results Viewer:

l "Move, float, and dock panes" on the next page

l "Show and hide panes" on the next page

l "Restore the default layout of the panes" on the next page
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Move, float, and dock panes
You can move the panes to suit your personal preferences by dragging the title bar or
tab of the pane you want to move and dropping it in the required location.

Docked panes are fixed in a set position relative to the rest of the application. For
example, when you move a pane to a position indicated by a marker, the pane is docked
in that position.

Floating panes are displayed on top of all other windows. They can be dragged to any
position on your screen, even outside of the Run Results Viewer.

Show and hide panes

l To close panes that are not needed: Click the X in the top-right corner of a pane.

l To show panes that are closed: Select View > <Name of pane>.

Restore the default layout of the panes
Select View > Restore Layout.

How to Jump to a Step in a GUI Test (UFT GUI
Tests Only)
You can view the step in UFT that corresponds to a node in the Run Results tree for any
node that has a corresponding step in a GUI test.

Note: This feature is disabled for a variety of settings. For details, see "Guidelines
for using the Jump to Step in Test command" on the next page, below.

To view the step in the test that corresponds to a node:

1. Make sure that UFT is open to the test whose results are displayed in the Run
Results Viewer.
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2. Select a node in the run results tree.

3. Perform one of the following:

a. Click the Jump to Step in Test button from the Run Results toolbar.

b. Right-click and select Jump to Step in Test from the context menu.

c. Select View >Jump to Step in Test.

4. The UFT window is activated and the step is highlighted.

Guidelines for using the Jump to Step in Test command

l The test must be saved before the run session.

l The run results must be from QuickTest Professional 10.00 or later.

This feature is disabled for:

l Any testing document other than a GUI test.

l The Action, Iteration, and Test Summary nodes.

l Any step that is part of an action that was run using the LoadAndRunAction
statement. For more details, see the Utility Objects section of the HP UFT Object
Model Reference for GUI Testing.

l Any step performed by a recovery scenario.

l Tests that were run in Fastmode. For details on this setting, see the section on the
Test Runs pane in the HP Unified Functional Testing User Guide.

l Any step run from the Watch or Console debug panes in UFT.

How to Manually Submit Defects to ALM
This task describes how to manually add defects to an ALM project, which enables you
to submit defects to your ALM project while viewing the run results.
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This task includes the following steps:

l "Prerequisites" below

l "Connect to an ALM project" below

l "Open the New Defect dialog box" below

l "Modify the defect information if needed and submit it" below

l "Results" on the next page

1. Prerequisites
Ensure that the ALM client is installed on your computer. (Enter the ALM Server
URL in a browser and ensure that the Login screen is displayed.)

2. Connect to an ALM project

Select Tools > ALM Connection or click the ALM Connection button and
connect to an ALM project. For details, see "HP ALM Connection Dialog Box (Run
Results Viewer)" on page 91.

Note: If you do not connect to an ALM project before proceeding to the next
step, you are prompted to connect before continuing.

3. Open the New Defect dialog box

Select Tools > Add Defect or click the Add Defect button to open the New
Defect dialog box in the specified ALM project. The New Defect dialog box opens.

4. Modify the defect information if needed and submit it
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Basic information on the test or component and any checkpoints (if applicable) is
included in the description, but you can modify the defect if needed:

Tip: You can attach movies (.fbr files) to defects in ALM. If you have the
Unified Functional Testing Add-in for ALM installed, you can view the movies
from ALM.

5. Results
The defect is added to the ALM project's defect database.

How to Automatically Submit Defects to an ALM
Project (UFT GUI Tests Only)
This task describes how to set the Run options in UFT to automatically submit defects
to your ALM project for each failed step in your GUI test, eliminating the need to
remember to submit these defects after a run session.

This task includes the following steps:

l "Prerequisites" below

l "Modify the Run settings in the Options dialog box" on the next page

l "Results" on the next page

1. Prerequisites
n In UFT, make sure you are connected to the relevant ALM project prior to the run

session (ALM > ALM Connection).
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n The run results must be stored in this ALM project.

2. Modify the Run settings in the Options dialog box
a. Select Tools > Options. The Options dialog box opens.

b. In the GUI Testing tab, click the Test Runs node.

c. Select the Submit a defect to ALM for each failed step check box.

d. Click OK to close the Options dialog box.

3. Results
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A sample of the information that is submitted to ALM for each defect is shown
below:

How to Export Run Results
This task describes how to export run results to a file. For details on what is included
when you export run results, see "Export Run Results Dialog Box (Run Results Viewer)"
on page 77.

This task includes the following steps:

l "Open the results in the Run Results Viewer" below

l "Specify the export settings" below

l "Save the file " on the next page

l "Results" on the next page

1. Open the results in the Run Results Viewer
For details, see "Open Run Results Dialog Box" on page 86.

2. Specify the export settings

User Guide
Chapter 1: Using the Run Results Viewer

HP Run Results Viewer (12.02) Page 28



Select File > Export To File. The Export Run Results dialog box opens. For details
on the various settings, see "Export Run Results Dialog Box (Run Results Viewer)"
on page 77.

3. Save the file
Click Export. The Save As dialog box opens. Specify the file name and path, and
select the required file type.

Report type Save as type

Step details n HTML (*.htm, *.html) (default)

n PDF (*.pdf)

n DOC (*.doc) (Available if Microsoft Word is
installed)

Data Table Excel (*.xls)

Log Tracking
(UFT GUI Testing
only)

XML (*.xml)

Screen Recorder
(UFT GUI Testing
only)

FlashBack (*.fbr)

System Monitor
(UFT GUI Testing
only)

n Text (*.csv, *.txt) (default)

n Excel (*.xls)

n XML (*.xml)

n HTML (*.htm, *.html)

Note:Only the system monitor data is exported,
not the graph.

4. Results
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When you click Save, the file is exported in the specified format to the designated
location.

Note: You can view .fbr files in the HP Micro Recorder (as described in
"Viewing Screen Recorder Movie Files in the HP Micro Player" on page 72). You
can also attach .fbr files to defects in ALM. If you have the Unified Functional
Testing Add-in for ALM installed, you can view the movies from ALM.

How to Play a Screen Recorder Movie in the HP
Micro Player (UFT GUI Testing Only)

Note: UFT must be installed on the computer on which you want to use the HP
Micro Player.

1. Perform one of the following:

n Double-click any .fbr file in Windows Explorer.

n Select Start > All Programs > HP Software > HP Unified Functional Testing >
Tools > HP Micro Player and then select File > Open in the Micro Player to
select any .fbr file.

n Open the program at <UFT installation folder\bin\Free_HPSR_
Player.exe.

The movie opens in the HP Micro Player and begins playing.

Note: For details on accessing UFT and UFT tools and files in Windows 8 and
Windows Server 2012, see "Accessing the UFT in Windows 8 Operating
Systems" on page 17.

2. Use the controls at the top of the window to access a particular location in the
movie or to modify the volume settings.
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How to Delete Run Results
This task describes how to use the "Run Results Deletion Tool (UFT Only)" on page 95
(described on page 95) to remove unwanted or obsolete run results from the file
system, according to specific criteria that you define. For example, you may want to
always delete run results older than a certain date or over a minimum file size. This
enables you to free up valuable disk space.

Prerequisites
To delete run results from an ALM project, you must first:

l Make sure that you have Delete Run permissions for this ALM project.

l Connect to the ALM project. For details see, "HP ALM Connection Dialog Box (Run
Results Viewer)" on page 91.

For details, see "Run Results Deletion Tool (UFT Only)" on page 95.

Delete run results using the Run Results Deletion Tool
For details, see "Run Results Deletion Tool (UFT Only)" on page 95.

Results
The selected run results are deleted from the file system and/or the ALM project.
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Reference

Run Results Viewer User Interface
This window enables you to view the results of a run session.

GUI Test. The following example shows the Executive Summary results of a test. Notice
that the results for a test are organized by the test's actions.
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In the Statistics area, you can see how many iterations passed, contained warnings, or
failed, and, when previous runs exist, you can compare the current results with the
previous results. You can also access the previous run results by clicking the Open
button.
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GUI Component. Below is an example of the run results for a component:

Note: In this example, the component failed due to a run error in a test object. If
the run error had not occurred, the Result would indicate Done.
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UFT API Test/ The following example shows an Executive Summary for an API test run:

To
access

Do one of the following:

l Select View > View Last Run Results from UFT.

l Select HP Software > HP Run Results Viewer > Run Results
Viewer from the StartMenu.

For details, see "How to Open Run Results" on page 19.
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By default, the left pane (dockable) contains the run results tree. The right side of the
window contains two rows of additional dockable panes. These user interface elements
are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

<Run Results
Viewer menu bar
and toolbar>

See "Run Results Viewer Commands" on page 38.

Executive
Summary Page

l A high-level results overview report (general information,
pass/fail status, statistics, link to previous run results (if
any), notes, and so on) displayed in the Result Details
pane when the topmost node is selected. For details, see
"Executive Summary Page" on page 51.

l ALM information for your test (if the test or component
was run from ALM, or if a test that is stored in ALM is run
from UFT and you choose to store the results in ALM).

"Run Results
Tree Pane and
Search Box" on
page 42

l A graphical representation of the results in an
expandable tree

l A search box

l Displays the test or component steps, specifying exactly
where application failures occurred

"Result Details
Pane (Run
Results Viewer) "
on page 49

Detailed explanations of each step and checkpoint pass or
failure, at each stage of the test or component.

"Captured Data
Pane (Run
Results Viewer) "
on page 54

l A still image of the state of your application at a particular
step

l For UFT, additional information, such as a bitmap
checkpoint image.

For details, see "Captured Data Pane (Run Results Viewer)
" on page 54.
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UI Elements Description

"Data Pane (Run
Results Viewer) "
on page 65

The data used in all iterations

"Screen
Recorder Pane
(Run Results
Viewer) (UFT GUI
Testing Only)"
on page 69

A movie clip of the state of your application at a particular
step or of the entire test or component

"System Monitor
Pane (Run
Results Viewer)
(UFT GUI Testing
Only)" on
page 73

Any system counters that were monitored for your test or
component

"Log Tracking
Pane (Run
Results Viewer)
(UFT GUI Tests
Only)" on
page 67

Any log messages that were received for your test or
component

<status bar> Displays:

l A description of any highlighted menu command
(Available only if the menu command is enabled)

l The status of the currently selected command

l Connection information (when connected to an ALM
project)

l A filter indication icon (when the results are filtered)
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Run Results Viewer Commands
The Run Results Viewer menu bar and toolbar contain commands to help you view run
session results.

Button Command Shortcut
Key

Description

File > Open CTRL+O Opens the Open Run Results dialog box,
enabling you to open saved run results from
the file system or from ALM.

For details, see "How to Open Run Results"
on page 19.

File > Print CTRL+P Opens the Print dialog box, enabling you to
print the results of the run session.

For details, see "Print Dialog Box (Run
Results Viewer)" on page 87.

-- File > Print
Preview

CTRL+F2 Opens the Print Preview dialog box,
enabling you to preview the results of the run
session prior to printing.

For details, see "Print Preview Dialog Box
(Run Results Viewer)" on page 89.

-- File >
Export To
File

-- Opens the Export Run Results dialog box,
enabling you to save various parts of the
results as external files.

For details, see "Export Run Results Dialog
Box (Run Results Viewer)" on page 77.

-- File >
Remove
Movie from
Results

-- (UFT GUI testing only) Enables you to
remove a stored movie from the results of a
test or component. This reduces the size of
the run results file.
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Button Command Shortcut
Key

Description

-- File >
Recent
Files

-- Lists the recently viewed files.

-- File > Exit -- Closes the Run Results Viewer session.

-- View > Run
Results
Viewer
Toolbar

-- Shows or hides the Run Results Viewer
toolbar.

-- View >
Status Bar

-- Shows or hides the status bar, which
indicates:

l A hint about the currently selected
command

l The status of the Run Results Viewer

l The ALM server name and project to
which the Run Results Viewer is
connected

l Whether the results are currently filtered
(displays a Filter icon when a filter is
applied)

-- View >
Result
Details

-- Opens the Results Details pane if it is closed
or brings it into focus. For details, see
"Result Details Pane (Run Results Viewer) "
on page 49.

-- View >
Screen
Recorder

-- (UFT GUI testing only) Opens the Screen
Recorder pane if it is closed or brings it into
focus. For details, see "Screen Recorder
Pane (Run Results Viewer) (UFT GUI
Testing Only)" on page 69.
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Button Command Shortcut
Key

Description

-- View >
System
Monitor

-- (UFT GUI testing only) Opens the System
Monitor pane if it is closed or brings it into
focus. For details, see "System Monitor Pane
(Run Results Viewer) (UFT GUI Testing
Only)" on page 73.

-- View >
Captured
Data

-- Opens the Captured Data pane if it is closed
or brings it into focus. For details, see
"Captured Data Pane (Run Results Viewer) "
on page 54.

-- View > Data -- Opens the Data pane if it is closed or brings
it into focus. For details, see "Data Pane
(Run Results Viewer) " on page 65.

-- View > Log
Tracking

-- (UFT GUI testing only) Opens the Log
Tracking pane if it is closed or brings it into
focus. For details, see "Log Tracking Pane
(Run Results Viewer) (UFT GUI Tests Only)"
on page 67.

-- View >
Restore
Layout

-- Restores the default layout of the Run
Results Viewer.

View >
Filters

CTRL+T Opens the Filters dialog box, enabling you to
filter the information displayed. For more
details, see "Filter Dialog Box (Run Results
Viewer) " on page 82.

View >
Collapse
All

-- Collapses all of the branches in the run
results tree.

Also available as a context menu option to
collapse all of the nodes under the selected
node.
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Button Command Shortcut
Key

Description

View >
Collapse
All

-- Collapses all of the branches in the run
results tree.

Also available as a context menu option to
collapse all of the nodes under the selected
node.

View > Go
to Previous
Node

-- Moves the cursor to the previously selected
node in the tree.

View > Go
to Next
Node

-- Moves the cursor to the node you selected in
the tree prior to clicking the Go to Previous
Node button.

View >
Jump to
Step in
Test

CTRL+J (UFT GUI tests only) Activates the UFT
window and highlights the step in the test
corresponding to the selected node in the
Run Results tree.

For details, see "How to Jump to a Step in a
GUI Test (UFT GUI Tests Only)" on page 23.

Note: Disabled for the Action, Iteration,
and Summary nodes.

Tools >
Add Defect

-- Enables you to add a defect to your ALM
project. If you are not currently connected to
ALM, opens the ALM Connection dialog box.
For more details, see "How to Manually
Submit Defects to ALM" on page 24.

Tools >
ALM
Connection

-- Opens the HP ALM Connection dialog box,
enabling you to connect to an ALM project.
For more details, see "HP ALM Connection
Dialog Box (Run Results Viewer)" on
page 91.
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Button Command Shortcut
Key

Description

Help > Help
Topics

-- Opens the HP Run Results Viewer Help.

-- Help >
About Run
Results
Viewer

-- Displays version information about the
HP Run Results Viewer.

Run Results Viewer Panes
This section includes:

l "Run Results Tree Pane and Search Box" below

l "Result Details Pane (Run Results Viewer) " on page 49

l "Captured Data Pane (Run Results Viewer) " on page 54

l "Test Flow Pane (Run Results Viewer) (UFT API Tests Only)" on page 63

l "Data Pane (Run Results Viewer) " on page 65

l "Log Tracking Pane (Run Results Viewer) (UFT GUI Tests Only)" on page 67

l "Screen Recorder Pane (Run Results Viewer) (UFT GUI Testing Only)" on page 69

l "System Monitor Pane (Run Results Viewer) (UFT GUI Testing Only)" on page 73

Run Results Tree Pane and Search Box

This pane displays the run results tree—a hierarchical or graphical representation of
the run session results. The Search box is located above the tree.
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The following example shows the run results tree for a GUI test. Similar results would
be displayed for a GUI component. For UFT API tests, the tree shows each of the
individual test steps and checkpoints.
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In the following example, eight instances of the searched for text, Welcome, were
found.

To access Open the Run Results Viewer, as described in "How to Open Run
Results" on page 19.

The Run Results Tree pane is displayed by default on the left side
of the Run Results Viewer. It cannot be hidden.

The Search box is located directly above the tree and can be

expanded by clicking the Expand button.

Important
information

l Click a node in the tree to view its details in the Result Details
pane. Other panes also display information for the test or
component or highlighted step, if available.

l You can collapse or expand a node in the run results tree to
change the level of detail that the tree displays.

l You can also use the "Filter Dialog Box (Run Results Viewer) "
on page 82 commands to control what is displayed in the run
results tree.
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Run Results Tree
Some of the Run Results Tree icons are described below:

UI
Elements

Description

Indicates a step that succeeded.

Note: If a test does not contain checkpoints, no icon is displayed.
For components, this icon is displayed only if the component
step contains one of the following:

l Verify operations (functions), such as VerifyProperty

l AddToRunResults (or its equivalent) with a micPass status

Indicates a step that failed. Failed steps cause all parent steps (up to
the root action, test, or component) to fail as well.

(UFT GUI tests only) Indicates an information step. This does not
affect the pass/fail status of the step.
(Relevant only for UFT GUI tests)

Indicates a warning, meaning that the step did not succeed, but it did
not cause the action, test, or component to fail.

Indicates a step that failed unexpectedly, such as when an object is
not found for a checkpoint.

(UFT GUI tests and components only) Indicates that the Smart
Identification mechanism successfully found the object.

(UFT GUI tests and components only) Indicates that a recovery
scenario was activated.

Indicates that the run session was stopped before it ended.
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UI
Elements

Description

(UFT GUI tests and components only) Square brackets around a test
object name indicate that the test object was created dynamically
during the run session. A dynamic test object is created either using
programmatic descriptions or by using an object returned by a
ChildObjects method, and is not saved in the object repository.

(UFT GUI tests and components only) Displays the Maintenance
Mode Update Result, which is a table that describes the Action
taken by Maintenance Run Wizard on a failed step and its Details.
Displayed only for tests or components run in Maintenance Run
Mode. For more details, see the section describing Maintenance
Run Mode in the HP Unified Functional Testing User Guide.

Search Box
The Search box user interface elements are described below:

UI
Elements

Description

Text box in which you can optionally enter text for which to search.

If the specified text is found in one or more tree nodes, the text area
indicates this, as shown below:

In this example, 1 of 6 indicates that there are six nodes displaying
the text, Welcome, and the first matching node is highlighted in the
tree.

Search. Finds the next instance that matches the criteria you
specified in the Search box. Click this button to jump to each node
that matches your search criteria.

Cancel. Clears the Search for text box.
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UI
Elements

Description

Expand or Collapse. Shows or hides the lower part of the Search
box.

Status The status to search for. (Optional)

Possible values:

l Passed. Searches for steps that passed and match your other
selection criteria.

l Failed. Searches for steps that failed and match your other
selection criteria.

l Done. Searches for steps with the status Done (steps that were
performed successfully but did not receive a pass, fail, or warning
status) that match your other selection criteria.

l Warning. Searches for steps with the statusWarning (steps that
did not pass, but did not cause the test to fail) that match your
other selection criteria.

Note: If the tree does not contain any steps that match a
particular status, that option is grayed out in the Search box.

User Guide
Chapter 1: Using the Run Results Viewer

HP Run Results Viewer (12.02) Page 47



UI
Elements

Description

Node
type

The type of node to search for (together with your other search
criteria). (Optional)

Possible values:

l Iteration. Searches for Iteration nodes that match your other
selection criteria.

l Action. Searches for action nodes that match your other selection
criteria.

l Step. Searches for steps that match your other selection criteria.

l Reporter. Searches for Reporter steps that match your other
selection criteria.

Note: This is not relevant for Reporter.ReportNote steps,
which are displayed in the Executive Summary page and not
in the run results tree.

l Checkpoint/Output Value. Searches for checkpoint and output
value steps that match your other selection criteria.

Note: If the tree does not contain a particular node type, that
option is grayed out in the Search box.

Direction The direction to search in the tree. Possible values:

l Up

l Down
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Result Details Pane (Run Results Viewer)

This pane displays the details for an individual iteration, action, or step that is currently
selected in the run results tree.

The Executive Summary is displayed when the topmost node in the run results tree is
selected.
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Result details are displayed when any node (other than the topmost node) is selected in
the run results tree.

To access Do the following:

1. Select a node in the run results tree:

n To open the Executive Summary page, select the topmost
node in the tree.

n To open the Result Details for a step, select the relevant
node in the tree.

2. Select the Result Details tab. (This assumes that the default
layout is displayed.)

Tip: If the Result Details pane is hidden, select View >
Result Details to show it.
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Important
information

By default, when the Run Results Viewer opens after a run
session, an Executive Summary is displayed in the Result Details
pane. This summary displays run session information about the
test or component. It also includes run Statistics and Notes (if any
were included).

For any other node, the details in the Result Details pane are
specific for the step selected in the run results tree. For example,
the details may include input or output parameters, or may indicate
that the session ran in Update Run Mode.

User interface elements are described below (unlabeled elements are shown in angle
brackets):

Executive Summary Page

UI
Elements

Description

Executive
Summary

Includes:

l the test or component name and result details, and
configuration details, if any

l time-related information for the run

l the product from which the test or component was run

l ALM server and project, if UFT was connected to an ALM
project during the run

Note: If a test or component that is stored in ALM is run from
UFT, but you choose to store the results in a temporary
location, the Test set and Test instance fields are not
displayed in the results.

l input and output parameters, if any

l additional information (for example, if the test ran in update
mode)
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UI
Elements

Description

Statistics Provides graphical, status-related statistics for the current run and
the previous run (if any). If the test or component was run
previously, you can click Open to open the previous run results in
a new Run Results Viewer window.

Notes Displays notes related to the run session, if any were added to the
results using the Reporter.ReportNote Utility statement. For
details, see the Utility Objects section of the HP UFT Object
Model Reference for GUI Testing.

Parameters Displays any test or component input and/or output parameters.
For details, see "Parameterized Values in the Run Results " on
page 127.

Result Details for Step

UI
Elements

Description

<step
name>

The name of the step.

User Guide
Chapter 1: Using the Run Results Viewer

HP Run Results Viewer (12.02) Page 52



UI
Elements

Description

<step
status>

The status of the step. Possible values:

l Done. Relevant for iterations, actions, and steps that ran
successfully, but do not contain checkpoints.

l Failed. Relevant for iterations, actions, and steps that contain
checkpoints.

l Passed. Relevant for iterations, actions, and steps that contain
checkpoints.

l Warning. Relevant for steps that were not successful, but did not
cause the test or component to stop running.

Note: A test, component, iteration, or action containing a step
markedWarning may still be labeled Passed or Done.
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UI
Elements

Description

<step
details>

Details about the step, such as the object on which the step was
performed, the timestamp, the step results, and so on. The
information in this area changes according to the type of step.

Example 1: Step performed on a Page test object

Example 2: Output value step

Captured Data Pane (Run Results Viewer)

This pane may display a still image of your application for the highlighted step, a
bitmap checkpoint image, a file content checkpoint comparison, or other data, for
example, if the step was performed for an UFT API Test step.
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The following image shows an example of the Captured Data pane with a still image of
an application taken during a GUI testing run session.

The following image shows the Captured Data pane with the Web Service Call properties
for a test step.

To access Select View > Captured Data or click the Captured Data tab.
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Important
information

l Screen captures for UFT GUI steps. By default, UFT saves a
still image of your application for failed steps. When you select
a failed step in the run results tree and select the Captured
Data pane, the pane displays a screen capture of your
application corresponding to the highlighted step in the run
results tree. If the highlighted step does not contain an error, no
screen capture is displayed.

In UFT, you instruct UFT to include still images of your
application in the run results by setting the Save still image
captures to results option in the Screen Capture pane (Tools
> Options > GUI Testing tab of the Options dialog box. For
details, see the section describing the Screen Capture pane in
the HP Unified Functional Testing User Guide.

l Captured Data pane for UFT API steps. The Captured Data
pane contains most of the information that is relevant for UFT
API steps. For details on the content that can be displayed in
this pane, see "Captured Data Pane Contents for UFT API
Steps" on the next page.

l Programmatically adding information to the results:

n In UFT GUI Testing. You can also programmatically add an
image to the Captured Data pane using the ReportEvent
method of the Reporter utility object. For details, see the
Utility Objects section of the HP UFT Object Model
Reference for GUI Testing.

n In UFT API Testing. You can programmatically add items to
the report. For details, see "Custom Fields (UFT API Testing
Only)" on page 16.

l Captured Data pane for file content checkpoint steps. The
captured data pane displays a side-by-side comparison of the
expected and actual lines from the file. For details, see "File
Content Checkpoint Results (UFT GUI Tests Only) " on
page 114.

Relevant
tasks

"How to Navigate the Run Results Tree" on page 20
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Captured Data Pane Contents for UFT API Steps

The contents of the Captured Data pane differ depending on the level you select in the
Run Results tree in the left pane.

l Start, End. General information about the Start and End activities.

l Test Flow/Loop. Information about the loop to which the test steps belong, such as
Test Flow.

l <Step Name>. Captured data from the selected step.

n For service type activities, this level shows the Request and Response data for
the operation or method.

n For the Report Message activity, this level displays the custom message
defined in the activity's properties.

l Checkpoints. Data about the checkpoints such as the Expected and Actual values,
the method of evaluation (Equals, Does Not Equal, and so on) and status.

Request and Response
The <Step Name> level contains a table showing the request and response messages.
The table shows both the HTTP header and message body. Clicking on the Request or
Response link in the table header, opens the SOAP in a separate browser window.
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The following example shows the Request and Response captured data for the
GetFlights operation from the sample Web Service.

Data Driven and Parameterized Properties
If you parameterized or applied data driving to an activity's properties, the viewer lists
the actual values used during the test run, per iteration.

For built-in activities, the Step Properties table shows the values used during the test
run.
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For service requests, you can observe the actual values in the Request/Response table.
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Array Checkpoints
When you select the Checkpoints node in the left pane, the Captured Data pane
provides a list of the checkpoints, their expected values, and actual results. In the case
of a checkpoint in the form of an array, the Captured Data pane provides a link to a
checkpoint report.

The checkpoint report opens in a separate browser window and provides details about
the checkpoints in each of the array elements. You can expand each checkpoint to see
what its expected and actual values were.

To view this table properly, you should enable active content in your browser in the
following way:

1. In Internet Explorer, select Tools > Options.

2. Select the Advanced tab.

3. Enable the option Allow active content to run in files on My Computer in the
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Security section.

4. Click OK and close the browser.

XML Comparison Report
The Compare XML activity provides its results in the Captured Data pane. It indicates
the changes in the XML, such as data changed, which element names changed and so
forth.
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In the upper part of the Captured Data pane, click the link Report File link to open the
complete comparison report in an external browser.

Converted Strings
The XML to String and JSON to String steps provide their results in the Captured Data
pane. The Step Properties table shows the resulting strings for the OutputString
entry.

Custom Messages
The Captured Data pane also shows custom messages that you sent to the output using
the Report function in an event handler.

For details, see the Coding Events section in the HP Unified Functional Testing User
Guide.
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The following example prints CYCLE_JULY_2012_B as a value for TestCycle.

this.ConcatenateStringsActivity5.Report("Test Cycle","CYCLE_JULY_2012_
B");

Test Flow Pane (Run Results Viewer) (UFT API Tests
Only)

This pane contains a snapshot of the canvas containing the test's steps . The snapshot
shows the order of the steps and the connections between them. You can scroll down,
zoom in, and set the displayed details level, as you would in the test's canvas.

If you select a node in the Run Results tree that represents a step in the Test Flow, it is
highlighted in this pane.
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In the following example, the Test Flow pane contains shows how two steps are
connected, and the test's internal loops.
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To access Open the Run Results Viewer, as described in "How to Open
Run Results" on page 19.

Select View > Test Flow.

Important
information

The Test Flow pane is not shown by default when the Run
Results Viewer opens.

User interface elements are described below (unlabeled elements are shown in angle
brackets):

UI Elements Description

Zoom Level
scroller

Enables you to control the magnification of the steps in the
canvas.

l Zoom Out (Ctrl -)

l Zoom In (Ctrl +)

Restore Default Zoom. Restores the canvas display to the
default view.

Details Level Enables you to select the detail level of the display:

l None

l Links only

l Links and linked parameters

l Links and all parameters

<display area> The test steps as displayed on the test's canvas.

Data Pane (Run Results Viewer)

This pane contains the runtime version of the data table associated with your test or
with your ALM configuration (relevant only for business process tests). It displays the
values used to run a test or configuration that contains Data Table parameters, as well
as any output values retrieved from a test or an ALM configuration during a run session.
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If you select a node in the run results tree that represents a step using data table
values, the relevant row is highlighted in this pane.

In the following example, the data table contains parameterized flight departure and
arrival values.

To access Open the Run Results Viewer, as described in "How to Open Run
Results" on page 19.

Select View > Data or click the Data tab.

Important
information

l This pane may display one data sheet or several data sheets
divided by tabs. For example, a UFT GUI test may use data
table parameters from the global sheet and individual action
sheets.

Note: Sheets that contain no data are not displayed in the
results.

l Use the context menu items to copy or export the data in the run
results.

See also For details on the run-time data table, see the section describing
the Data pane in the HP Unified Functional Testing User Guide.
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User interface elements are described below (unlabeled elements are shown in angle
brackets):

UI
Elements

Description

<Row> Represents the set of values that UFT submitted for the
parameterized arguments during a single iteration of the action
(UFT GUI tests only), test, or configuration.

<Column> Represents the list of values for a single parameterized argument.
The column header is the parameter name.

<context
menu>

l Copy. Copies the selected data to the clipboard.

l Export Sheet.Opens a dialog to select a location in which to
store an exported data sheet.

Log Tracking Pane (Run Results Viewer) (UFT GUI Tests
Only)

This pane displays a complete list of log messages that UFT received from your
application during the run session.

In addition to viewing the log messages, when you select a message, you can see its
details in the "Result Details Pane (Run Results Viewer) " on page 49 pane.

Tip: You can "Print Dialog Box (Run Results Viewer)" on page 87 or "Export Run
Results Dialog Box (Run Results Viewer)" on page 77 the log tracking details to a
file to show to a developer, or you can provide the developer with the standalone
Run Results Viewer installation so that the developer can view and analyze the
results directly on his or her own computer. For details, see "How to Install the Run
Results Viewer as a Standalone Application" on page 18.
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To access Open the Run Results Viewer, as described in "How to Open Run
Results" on page 19.

Select View > Log Tracking.

Important
information

l Japanese characters - known Log4Net issue. If a log
message contains Japanese characters, these characters are
displayed as question marks (?) in the Message column of the
Run Results Viewer's Log Tracking pane. This is due to a
known bug in log4net.Layout.XmlLayoutSchemaLog4j - version
1.2.10. For details, see
https://issues.apache.org/jira/browse/LOG4NET-229.

l Showing and hiding columns. You can show or hide columns
in the Log Tracking pane by right-clicking any column header
and selecting or clearing a menu option.

l Reordering columns. You can reorder the columns in the
pane by dragging and dropping a column header to a different
location.

See also l "Find Dialog Box (Log Tracking Pane - Run Results Viewer)
(UFT GUI Testing Only)" on page 80

l The Log Tracking section in the HP Unified Functional Testing
User Guide
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User interface elements are described below:

UI
Elements

Description

Find Opens the "Find Dialog Box (Log Tracking Pane - Run Results
Viewer) (UFT GUI Testing Only)" on page 80 dialog box, enabling
you to search the log messages by message, level, and character
case.

ID The message number.

Timestamp The date and time (in milliseconds).

Level The severity level for the log message. Possible level values:

l TRACE

l DEBUG

l INFO

l WARN

l ERROR

l FATAL

Logger The name of the logger.

Thread The thread that initiated the log request.

Message The text of the log message.

Screen Recorder Pane (Run Results Viewer) (UFT GUI
Testing Only)

This pane enables you to view a movie of a run session. You can view the entire movie,
or you can view a frame for particular segment (by selecting a node in the run results
tree or by clicking on a specific point in the slider).

User Guide
Chapter 1: Using the Run Results Viewer

HP Run Results Viewer (12.02) Page 69



To access Open the Run Results Viewer, as described in "How to Open Run
Results" on page 19.

Select View > Screen Recorder or click the Screen Recorder
tab.
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Important
information

l Use of multiple monitors: The Screen Recorder records a
movie of the operations performed on your primary monitor.
Therefore, if you are working with multiple monitors, make sure
that your application is fully visible on your primary monitor
when recording or running a test or component.

l Prevent UFT from obscuring your application. The Screen
Recorder saves a movie of your entire desktop. You can
prevent the UFT window from partially obscuring your
application while capturing the movie by minimizing UFT
during the run session. For details, see the section describing
the screen recorder in the HP Unified Functional Testing User
Guide.

l View full screen. You can double-click the Screen Recorder
pane to display the Screen Recorder in full-screen mode and
hide the run results tree. Double-clicking again restores the
Screen Recorder to its previous size and displays the run
results tree. When the Screen Recorder is expanded, the
playback controls at the top of the Screen Recorder
automatically hide after approximately three seconds with no
mouse activity, or when you click anywhere on the Screen
Recorder. They reappear when you move the mouse again.

User interface elements are described below:

UI
Elements

Description

First Frame. Click to view the first frame in the movie.

Play/Pause. Click to play or pause the movie. When you click
Pause, the relevant tree node is highlighted.

Stop. Click to stop the movie.

Last Frame. Click to view the last frame in the movie.
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UI
Elements

Description

Slider. Drag the bar to view a particular frame in the movie. When
you click the bar, the relevant node is highlighted in the tree. When
you play the movie, the slider automatically moves to the position of
the currently displayed frame.

Volume Control. Drag the bar to the right or left to control the movie
sound.

Mute. Click to turn off the movie sound, if any.

Setting Movie Recording Options
You can customize whether UFT captures movies and the criteria used to save them,
using the Save movies to results option in the Screen Capture pane (Tools > Options >
GUI Testing tab > Screen Capture node) of the Options dialog box. For details, see the
section describing the Screen Capture pane in the HP Unified Functional Testing User
Guide.

Exporting Movies of Your Run Session
You can export a captured Screen Recorder movie as an .fbr file. You can view .fbr
files in the HP Micro Recorder (as described in "Viewing Screen Recorder Movie Files in
the HP Micro Player" below).

You can also attach .fbr files to defects in ALM. If you have the Unified Functional
Testing Add-in for ALM installed, you can view the movies from ALM.

Viewing Screen Recorder Movie Files in the HP Micro Player
When you capture a movie of your run session using the Screen Recorder, the movie is
saved as an .fbr file in your run results folder. You can also view these .fbr files
without opening the Run Results Viewer, using the HP Micro Player. For details, see
"How to Play a Screen Recorder Movie in the HP Micro Player (UFT GUI Testing Only) "
on page 30.
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System Monitor Pane (Run Results Viewer) (UFT GUI
Testing Only)

This pane enables you to view the system counters that you monitored for a run
session in a line graph.

To access Open the Run Results Viewer, as described in "How to Open Run
Results" on page 19.

Select View > System Monitor or click the System Monitor tab.
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Important
information

You can export the data from the System Monitor tab to the
following file types: text (.csv or .txt), Excel (.xls), .xml, or
.html. (Graphs are not exported.)

For details, see "Export Run Results Dialog Box (Run Results
Viewer)" on page 77.

See also l For details on enabling local system monitoring, the HP Unified
Functional Testing User Guide.

l "Troubleshooting and Limitations - Viewing Run Results" on
page 98

User interface elements are described below:

UI
Elements

Description

Zoom In. Click this button and click anywhere on the graph to
zoom in. You can also click and drag over an area of the graph to
zoom in on that area.

Zoom Out. Click this button and click anywhere on the graph to
zoom out.

View Full Graph. Click this button to zoom out and view the entire
graph. This button is disabled when the graph is not zoomed in.

Move. Click this button and then click and drag on the graph to
scroll right and left. This button is disabled when the graph is not
zoomed in.

Arrow. Click this button and double-click anywhere on the graph
to select that point as the current step. The Current Step indicator
moves to the new location and the step is highlighted in the Run
Results tree. You can also hover over any point on a Counter
Line in the graph to see the value for the Counter Line at that
point.

Application
Name

The name of the application for which system counters were
monitored.
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UI
Elements

Description

System
Counters
List

The list of system counters monitored for the application.

Currently
Displayed
Counters

The list of counters currently displayed in the line graph. The
System Monitor tab displays a maximum of two counters at one
time. To change the counters being displayed, clear the check box
for one or both of the currently selected counters, and select the
check box for the desired counters.

Counter
Scale

The scale of measurement for the performance of that counter.

Maximum
Counter
Value

The maximum value the counter achieved during the run session.

Current
Step

The point in the graph representing the step that is currently
highlighted in the Run Results tree.

Counter
Limit Line

A visual representation of the limit for that counter, if set, as
defined in the Local System Monitor pane of the Test Settings
dialog box or the Additional Settings pane in the Application Area
(in UFT).

If set, a counter that exceeds this limit causes the step to fail. Only
the first step that exceeds the counter limit fails. Subsequent steps
that exceed the counter limit are not affected.

Counter
Limit Value

The numeric value of the limit for that counter, if set, as defined in
the Local System Monitor pane of the Test Settings dialog box or
the Additional Settings pane in the Application Area (in UFT).

If set, a counter that exceeds this limit causes the step to fail. Only
the first step that exceeds the counter limit fails. Subsequent steps
that exceed the counter limit are not affected.

Time Scale The scale of time in seconds, for the run session.
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Run Results Viewer Dialog Boxes
This section includes (in alphabetical order):

l "Export Run Results Dialog Box (Run Results Viewer)" on the next page

l "Find Dialog Box (Log Tracking Pane - Run Results Viewer) (UFT GUI Testing Only)"
on page 80

l "Filter Dialog Box (Run Results Viewer) " on page 82

l "Open Run Results Dialog Box" on page 86

l "Print Dialog Box (Run Results Viewer)" on page 87

l "Print Preview Dialog Box (Run Results Viewer)" on page 89

l "HP ALM Connection Dialog Box (Run Results Viewer)" on page 91
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Export Run Results Dialog Box (Run Results Viewer)

This dialog box enables you to export run results to a file so that you can view them
even if the Run Results Viewer is unavailable. For example, you can send the file
containing the run results in an e-mail to a third-party who does not have the Run
Results Viewer installed.

To access Open the Run Results Viewer, as described in "How to Open Run
Results" on page 19.

Select File > Export to File.
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Important
information

l The export time varies according to the size of the results
file and the file type you select.When selecting the file type,
consider the length of time it will take to generate different
document types, especially for a report with many images.
.Html files generate the fastest, followed by .pdf and .doc
When exporting a report with 100 or more images to a .doc file,
a dialog box is displayed reminding you that it may take a long
time to generate the file. The dialog box gives you the option to
continue exporting with images, continue exporting without
images, or to export to .pdf.

l Screen capture images are not exported for steps on Web-
based applications.When you export run results containing
steps on a Web application, any screen capture images for
those steps are not exported to the file. This is because for
Web-based applications, the Run Results Viewer displays the
.html corresponding to the relevant Web page (with
downloaded images) rather than a captured image and thus no
image is saved with the report.

l Exporting to a .doc file. Requires that a supported version of
Microsoft Word be installed on the Run Results Viewer
computer. For details, see the Product Availability Matrix,
available from the UFT help folder or the HP Support Matrix
page (requires an HP passport).

Relevant
tasks

"How to Export Run Results" on page 28

See also "Troubleshooting and Limitations - Viewing Run Results" on
page 98

User interface elements are described below:

UI
Elements

Description

Report
type

The type of report you want to export, for example, Step Details or
System Monitor.
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UI
Elements

Description

Export
range

Relevant only for Step Details report type.

l All nodes. Exports the results for the entire test or component.

l Selected node. Exports run result information for the selected
branch in the run results tree.

Export
format

Relevant only for Step Details report type.

l Short. Exports a summary line (when available) for each item in
the run results tree. The short report does not include still images
associated with the steps in your run results. This option is only
available if you selected All nodes in Export range.

l Detailed. Exports all available information for each item in the run
results tree, or for the selected branch, according to your Export
range selection. The detailed report includes still images
associated with the steps in your run results. (In the Run Results
Viewer, these images are displayed in the Captured Data pane.)
If a bitmap checkpoint step displays expected, actual, and
difference bitmaps, these are also included in the printed report.

l User-defined XSL. Enables you to browse to and select a
customized .xsl file. You can create a customized .xsl file that
specifies the information to be included in the exported report,
and the way it should appear.

If you decide to modify one of the existing .xsl files provided with
the Run Results Viewer, and you copy that file to a different
folder, make sure to copy over all of the .xsl files that are listed
in that .xsl file's "include" calls, as well as the .css files. For
details, see "Run Results XML File" on page 12.
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Find Dialog Box (Log Tracking Pane - Run Results
Viewer) (UFT GUI Testing Only)

This dialog box enables you to search for a log message by message text, level, and
case (upper-case/lower-case characters).

To access 1. Open the Run Results Viewer, as described in "How to Open
Run Results" on page 19.

2. Display the Log Tracking pane, as described in "Log Tracking
Pane (Run Results Viewer) (UFT GUI Tests Only)" on
page 67.

3. In the Log Tracking pane title bar, click Find.

Important
information

l This dialog box is relevant only for the Log Tracking pane. To
perform a search in the run results tree, use the "Search Box"
on page 46.

l To stop a search, press the Esc key on your keyboard.

User interface elements are described below:

UI
Elements

Description

Find Enter the text to find. This can be message text or a severity level.

Message Searches the Message column for the text specified in the Find box.

User Guide
Chapter 1: Using the Run Results Viewer

HP Run Results Viewer (12.02) Page 80



UI
Elements

Description

Level Searches the Level column for the text specified in the Find box.
Possible level values:

l TRACE

l DEBUG

l INFO

l WARN

l ERROR

l FATAL

Match
case

Displays only those occurrences that match the capitalization
(upper-case and lower-case characters) you specified for the text in
the Find box.

Next Jumps to the next instance that matches the selected criteria.

Previous Jumps to the previous instance that matches the selected criteria.
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Filter Dialog Box (Run Results Viewer)

This dialog box enables you to filter the results tree to display only those nodes that
match the conditions that you specify.

To access 1. Open the Run Results Viewer, as described in "How to Open
Run Results" on page 19.

2. Select View > Filters or click the Filter button  .
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Important
information

l When you apply a filter, a filter icon is displayed on the status
bar, and (Filtered) is appended to the Search box title bar.
These visual changes indicate that the run results tree is
currently displaying only those nodes that match your filter
criteria.

l (UFT GUI tests only) You can use Reporter.Filter
statements in the Editor to disable or enable the saving of
selected steps, or to save only steps with Failed orWarning
status. For more details on saving run session information, see
the HP Unified Functional Testing User Guide or the HP UFT
Object Model Reference for GUI Testing. The
Reporter.Filter statement differs from the Filters dialog box
described above. The Reporter.Filter statement
determines which steps are saved in the Run Results, while the
Filter dialog box determines which steps are displayed at any
time.

User interface elements are described below:

UI
Elements

Description

Filter
what

A text box in which you enter the text by which you want to filter.
(Optional)
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UI
Elements

Description

Status The status of the node by which to filter. (Optional)

Possible values:

l Passed. Displays the run results for the steps that passed and
match your filter criteria.

l Failed. Displays the run results for the steps that failed and match
your filter criteria.

l Done. Displays the run results for the steps with the status Done
(steps that were performed successfully but did not receive a
pass, fail, or warning status) that match your filter criteria.

l Warning. Displays the run results for the steps with the status
Warning (steps that did not pass, but did not cause the test to fail)
that match your filter criteria.
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UI
Elements

Description

Node
type

Displays all results that match your selection criteria based on:
(Optional)

l Iteration. Displays the run results in the run results tree for the
iterations specified in the Iterations area.

l Action. Displays the run results for all actions in the run results
tree that match your other selection criteria. (Not relevant for
components.)

l Step. Displays the run results for all steps in the run results tree
that match your other selection criteria.

l Reporter. Displays the run results for all Reporter steps in the run
results tree that match your other selection criteria.

Note: This is not relevant for Reporter.ReportNote steps,
which are displayed in the Notes area of the Executive
Summary page and not in the run results tree.

l Checkpoint/Output Value. Displays the run results for all
checkpoint and output value steps in the run results tree that
match your other selection criteria.

Iterations (This option is available only for tests.)

l All. Displays run results from all iterations.

l From iteration X to Y. Displays the run results from the specified
range of test iterations.
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Open Run Results Dialog Box

This dialog box enables you to open run results in the Run Results Viewer.

To access 1. Open the Run Results Viewer, as described in "How to Open
Run Results" on page 19.

2. Select File >Open or click the Open button .

Important
information
for UFT
tests

l To view results stored in ALM, you must first connect to your
ALM project. For details, see "HP ALM Connection Dialog Box
(Run Results Viewer)" on page 91.

l By default, results files for UFT tests are stored together with
the test, for example: C:\%HOMEPATH%\My
Documents\Unified Functional Testing\<Test
name>\<ResultName>

l To view result files for QuickTest Professional version 6.5 and
earlier, use the Test/Run Results Viewer in an earlier version
of QuickTest.

Relevant
tasks

"How to Open Run Results" on page 19
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User interface elements are described below:

UI
Elements

Description

Test
name

The name of the test for which you want to view results. The test can
be located in the file system or in an ALM project. If you select this
option, you must also specify the Run name.

Run
name

The results for a particular run.

The results are listed in the order of execution, with the most recent
results at the top of the drop-down list.

Results
XML file

The actual .xml results file. The file must be located in the file
system.

Print Dialog Box (Run Results Viewer)

This dialog box enables you to print run results from the Run Results Viewer. You can
select the type of report you want to print, and you can also create and print a
customized report.

User Guide
Chapter 1: Using the Run Results Viewer

HP Run Results Viewer (12.02) Page 87



To
access

1. Open the Run Results Viewer, as described in "How to Open Run
Results" on page 19.

2. Use one of the following:

o Select File > Print.

o Click the Print button .

User interface elements are described below:

UI
Elements

Description

Print
range

l All. Prints the run results for the entire test or component.

l Selection. Prints the run results information for the selected
branch in the run results tree.

Print
format

l Short. Prints a summary line (when available) for each item in the
run results tree. This option is only available if you selected All in
Print range.

l Detailed. Prints all available information for each item in the run
results tree, or for the selected branch, according to your selection
in Print range. The printed report includes still images associated
with the steps in your run results. If a bitmap checkpoint step
displays bitmaps, these are also included.

l User-defined XSL. Enables you to browse to and select a
customized .xsl file. You can create a customized .xsl file that
specifies the information to be included in the printed report, and
the way it should appear. For more details, see "Run Results
XML File" on page 12.

Note: The Print format options are available only for run results
last modified with QuickTest version 8.0 and later.

Print Opens the standard Windows Print dialog box, enabling you to send
the selected run results any installed printer.
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Print Preview Dialog Box (Run Results Viewer)

This dialog box enables you to preview run results on screen before you print them. You
can select the type and quantity of information you want to view, and you can also
display the information in a customized format.

To access 1. Open the Run Results Viewer, as described in "How to Open
Run Results" on page 19.

2. Select File > Print Preview.

Important
information

The Print Preview option is available only for run results last
modified with QuickTest version 8.0 and later.

User interface elements are described below:

UI
Elements

Description

Print
range

l All. Previews the run results for the entire test or component.

l Selection. Previews run results information for the selected
branch in the run results tree.
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UI
Elements

Description

Print
format

l Short. Previews a summary line (when available) for each item in
the run results tree. This option is only available if you selected
All in Print range.

l Detailed. Previews all available information for each item in the
run results tree, or for the selected branch, according to your
selection in Print range. The preview includes still images
associated with the steps in your run results. If a bitmap
checkpoint step displays bitmaps, these are also included.

l User-defined XSL. Enables you to browse to and select a
customized .xsl file. You can create a customized .xsl file that
specifies the information to be included in the preview, and the
way it should appear. For more details, see "Run Results XML
File" on page 12.

Preview Displays the run results on screen as they are displayed when
printed.

Tip: If some of the information is cut off in the preview, for
example, if checkpoint names are too long to fit in the display,

click the Page Setup button in the Print Preview window and
change the page orientation from Portrait to Landscape.
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HP ALM Connection Dialog Box (Run Results Viewer)

This dialog box enables you to connect to or disconnect from a project in any supported
version of ALM.

To access Use one of the following:

l Select Tools > ALM Connection.

l Click the ALM toolbar button .

Important
information

l 1st time connection. The first time you connect to an ALM
server, you must connect as a user with administrator privileges
on the computer on which you are connecting.

l Connecting to different versions of Quality Center or ALM.
You cannot connect to multiple versions of Quality Center or
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ALM in the same Run Results Viewer session. Close and
reopen Run Results Viewer to connect to a different version of
Quality Center or ALM.

l Ensure that the format you are using for the URL is the same as
the URL you use to access ALM via your browser. For
example, if you use the IP address to access the ALM server
via the browser, you should use the IP address to access ALM
via UFT.

l Windows 7, Windows Server 2008 R2, Windows 8, and
Windows Server 2012 Users. The security settings may
prevent you from connecting to an ALM project:

This can occur when the UAC (User Account Control) option is
set to ON, and you have never connected to an ALM project.

To connect to ALM for the first time, you must disable the UAC
option. After you successfully connect to ALM, you can turn the
UAC option on again. Thereafter, you should be able to
connect to ALM, as needed.

l Connect. The connection process has two steps. First, you
connect to a local or remote ALM server. This server handles
the connections between Run Results Viewer and the ALM
project. You must provide a user name and a password.

Next, you choose the project you want to access. The project
stores tests and run session information for the application you
are testing.

l Disconnect. You can disconnect from an ALM project or from
an ALM server.

n If you disconnect from an ALM server without first
disconnecting from a project, the Run Results Viewer
connection to that project database is automatically
disconnected.

l SSL Certificates. If you are attempting to connect to an ALM
project with a https:// prefix, but your computer does not
have a valid SSL certificate, the connection will fail.

User Guide
Chapter 1: Using the Run Results Viewer

HP Run Results Viewer (12.02) Page 92



l ALM servers using external authentication. To use an
ALM server using external authentication, you must have
your external certificate installed on both the computer running
ALM and the computer running Run Results Viewer. When you
log in to the ALM server using external authentication, a dialog
prompts you to select your certificate from the list of available
certificates.

l After running tests, from ALM, you can optionally automatically
upload your run results to ALM if you are running a test from
ALM. This option is set in ALM as a site parameter for your
project. For details, see the HP Application Lifecycle
Management Administrator Guide.

Relevant
tasks

To view the current connection:

l The icon on the status bar is labeled with the server name and
project to which the Run Results Viewer is connected.

User interface elements are described below:

UI Elements Description

Server URL The URL address of the Web server where ALM is
installed.

You can choose a server that is accessible via a Local
Area Network (LAN) or a Wide Area Network (WAN).

You can connect to any currently supported version of
ALM. For a list of supported versions, see the
HP Unified Functional Testing Product Availability
Matrix, available from the UFT help folder or the HP
Support Matrix page (requires an HP passport).

User Name Your ALM user name.

Note: If you are connecting to an ALM server using
external authentication, you do not need to enter a
user name. If you do enter a user name, Run
Results Viewer ignores the entered name when
connecting.
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UI Elements Description

Password Your ALM password.

Note:

To enter a password in any CJK (Chinese,
Japanese, Korean) language, copy/paste the
password into the edit box. (Windows does not
support typed CJK characters in password fields.)

If you are connecting to an ALM server using
external authentication, you do not need to enter a
password. If you do enter a password, Run Results
Viewer ignores the entered password when
connecting.

Connect / Disconnect Connects to or disconnects from the selected ALM
server.

Note: After you successfully connect to a server,
the button changes to Disconnect, and at the top of
the dialog box, the Disconnected icon
changes to a Connected icon .

Domain The domain that contains the ALM project.

Project The ALM project with which you want to work.

Note:Only those projects for which you are a
defined user are displayed.

Restore connection
on startup

Instructs Run Results Viewer to automatically
reconnect to the ALM server every time you open Run
Results Viewer.
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Run Results Deletion Tool (UFT Only)
This window enables you to view a list of all the run results in a specific location in your
file system or in an ALM project. You can then delete any run results that you no longer
require.

You can sort the run results by name, date, size, and so on, so that you can more easily
identify the results you want to delete.

To access In the Run Results Viewer, select Tools > Run Results
Deletion Tool or select the Run Results Deletion Tool button

in the toolbar.
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Important
information
for HP ALM
users

l To delete run results from an ALM project, connect the Run
Results Viewer to an ALM project before browsing or entering
the path. Specify the ALM test path in the standard ALM
format.

Example: [QC-TEST];;Subject\<folder
name>\<test name>;;

For details on connecting to ALM, see "HP ALM Connection
Dialog Box (Run Results Viewer)" on page 91.

l You can delete results from only one test at a time. Make sure
that you have Delete Run permission for this ALM project.

l For details on ALM project permissions, contact your ALM
administrator or see the section on permission settings in the
ALM administrator guide.

Relevant
tasks

"How to Delete Run Results" on page 31

User interface elements are described below:

UI
Elements

Description

Test or
folder

The path from which you want to delete run results. When working
with the file system, you can specify a test or a folder. When
working with ALM, you cannot specify folders.

Browse Enables you to browse to and select the folder or specific run
results that you want to delete. By default, clicking the Browse
button opens the Open Test dialog box. If you want to browse to a
folder, click the down arrow and select Folders to open the Open
Folder dialog box.

Include
run results
found in
subfolders

Adds all run results contained in subfolders of the specified folder
to the Run Results area of this dialog box.

(Relevant only for folders in the file system. This option is not
supported when working with tests in ALM.)
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UI
Elements

Description

Run
Results

Lists the run results that are stored in the specified test or folder,
together with descriptive information for each. You can click a
column's title to sort run results based on the entries in that column.

Delete Deletes the selected run results from the file system and/or the
ALM project. You can select multiple run results for deletion using
standard Windows selection techniques.

<status
bar>

Displays information regarding the displayed run results, including
the number of results selected, the total number of results in the
specified location and the size of the files.

Refresh Updates the list of tests in the Run Results area.
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Troubleshooting and Limitations - Viewing
Run Results
This section describes troubleshooting and limitations for viewing run results.

l Local system monitor. After you run a test or component with the local system
monitoring option activated when the test or component is either very short, or the
number of seconds entered for the Enable local system monitoring every: __
seconds option is high (a high percentage relative to the length of your entire test
run), then when you select one of the last steps in the Run Results tree, the Current
Step indicator in the System Monitor pane may jump to a position outside (to the
right) of the graph.

Workaround: Add a Wait statement to the end of the test or reduce the number of
seconds entered in the Enable local system monitoring every: __ seconds option.

l Run session errors. Errors during the run session produce more than one error node
in the run results.

l Exporting run results. When UAC is set to ON and you select to export the Run
Results to a system folder, the exported file is stored under Virtual Storage rather
than under the specified folder. (Relevant for Windows 7, Windows Server 2008 R2,
Windows 8, and Windows Server 2012)

l Viewing run results from ALM. If you installed the Run Results Viewer without
installing UFT, then after you run a BPT test from ALM, pressing Show Last Run
Resultsmight fail to display the results in the Run Results Viewer if the Visual C++
2005 redistributable is installed on your computer.

Workaround: Install the Unified Functional Testing Add-in for ALM from the ALM
Add-ins page.
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Chapter 2: Run Results - Understanding
Step Results
This chapter includes:
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Concepts

Smart Identification in the Run Results (UFT GUI
Testing Only)
If the learned description does not enable UFT to identify the specified object in a step,
and a Smart Identification definition is defined (and enabled) for the object, then UFT
tries to identify the object using the Smart Identification mechanism. The following
examples illustrate two possible scenarios.

l "Smart Identification - No Object Matches the Learned Description (UFT GUI Testing
Only)" on the next page

l "Smart Identification - Multiple Objects Match the Learned Description (UFT GUI
Testing Only)" on page 103
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Smart Identification - No Object Matches the Learned
Description (UFT GUI Testing Only)

If UFT successfully uses Smart Identification to find an object after no object matches
the learned description, the run results display a warning status and include the
following information:

In the
results tree

In the Result Details pane

A description
mismatch
icon for the
missing
object. For
example:

An indication that the object (for example, the userName
WebEdit object) was not found.

A Smart
Identification
icon for the
missing
object. For
example:

An indication that the Smart Identification mechanism
successfully found the object, and information on the properties
used to find the object. You can use this information to modify the
learned test object description, so that UFT can find the object
using the description in future run sessions.

The actual
step
performed.
For example:

Normal result details for the performed step.

For details on the Smart Identification mechanism, see the section describing Smart
Identification in the HP Unified Functional Testing User Guide.
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The image below shows the results for a test or component in which Smart
Identification was used to identify the userName WebEdit object after one of the
learned description property values changed.

Smart Identification - Multiple Objects Match the
Learned Description (UFT GUI Testing Only)

If UFT successfully uses Smart Identification to find an object after multiple objects are
found that match the learned description, UFT shows the Smart Identification
information in the Run Results Viewer. The step still receives a passed status, because
in most cases, if Smart Identification was not used, the test object description plus the
ordinal identifier could have potentially identified the object.
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In such a situation, the run results show the following information:

In the
results tree

In the Result Details pane

A Smart
Identification
icon for the
missing
object. For
example:

An indication that the Smart Identification mechanism
successfully found the object, and information on the properties
used to find the object. You can use this information to create a
unique object description for the object, so that UFT can find the
object using the description in future run sessions.

The actual
step
performed.
For
example:

Normal result details for the performed step.
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The image below shows the results for a test or component in which Smart
Identification was used to uniquely identify the Flight Confirmation: Mercury
object after the learned description resulted in multiple matches.

If the Smart Identification mechanism cannot successfully identify the object, the test
or component fails and a normal failed step is displayed in the run results.
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Checkpoint and Output Value Results (UFT GUI
Testing Only)
The information displayed in the Run Results Viewer and the available options are
determined by the type of checkpoint or output value step you select.

This section includes:

l "Accessibility Checkpoint Results (UFT GUI Tests Only) " below

l "Bitmap Checkpoint Results (UFT GUI Tests Only) " on page 112

l "File Content Checkpoint Results (UFT GUI Tests Only) " on page 114

l "Standard Checkpoint Results (UFT GUI Tests Only) " on page 117

l "Table and Database Checkpoint Results (UFT GUI Tests Only) " on page 119

l "Text and Text Area Checkpoint Results (UFT GUI Tests Only) " on page 121

l "XML Checkpoint Results (UFT GUI Tests Only) " on page 122

l "Output Value Results (UFT GUI Tests Only) " on page 124

l "XML Output Value Results (UFT GUI Tests Only) " on page 126

Accessibility Checkpoint Results (UFT GUI Tests Only)

When you include accessibility checkpoints in your test, the Run Results Viewer displays
the results of each accessibility option that you checked.
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The run results tree displays a separate step for each accessibility option that was
checked in each checkpoint. For example, if you selected all accessibility options, the
run results tree for an accessibility checkpoint may look something like this:

The run result details provide information that can help you pinpoint parts of your Web
site that may not conform to the W3C Web Content Accessibility Guidelines. The
information provided for each check is based on the W3C requirements.

Note: Some of the W3C Web Content Accessibility Guidelines that are relevant to
accessibility checkpoints are cited or summarized in the following sections. This
information is not comprehensive. When checking whether your Web site satisfies
the W3C Web Content Accessibility Guidelines, you should see the complete
document at: http://www.w3.org/TR/WAI-WEBCONTENT/.

For details on accessibility checkpoints, see the HP Unified Functional Testing User
Guide.
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ActiveX Check
Guideline 6 of the W3C Web Content Accessibility Guidelines requires you to ensure that
pages are accessible even when newer technologies are not supported or are turned off.
When you select the ActiveX check, UFT checks whether the selected page or frame
contains any ActiveX objects. If it does not contain any ActiveX objects, the checkpoint
passes. If the page or frame does contain ActiveX objects then the results display a
warning and a list of the ActiveX objects so that you can check the accessibility of these
pages on browsers without ActiveX support. For example:

Alt Property Check
Guideline 1.1 of the W3C Web Content Accessibility Guidelines requires you to provide a
text equivalent for every non-text element. The Alt property check checks whether
objects that require the Alt property under this guideline, do in fact have this attribute.
If the selected frame or page does not contain any such objects, or if all such objects
have the required attribute, the checkpoint passes. If one or more objects that require
the property do not have it, the test fails and the run result details display a list that
shows which objects are lacking the attribute. For example:

The Captured Data pane displays the captured page or frame, so that you can see the
objects listed in the Alt property check list.
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Applet Check
The Applet Check also helps you ensure that pages are accessible, even when newer
technologies are not supported or are turned off (Guideline 6 of the W3C Web Content
Accessibility Guidelines), by finding any Java applets or applications in the checked page
or frame. The checkpoint passes if the page or frame does not contain any Java applets
or applications. Otherwise, the results display a warning and a list of the Java applets
and applications. For example:

Frame Titles Check
Guideline 12.1 of the W3C Web Content Accessibility Guidelines requires you to title
each frame to facilitate frame identification and navigation. When you select the Frame
Titles check, UFT checks whether Frame and Page objects have the TITLE tag. If the
selected page or frame and all frames within it have titles, the checkpoint passes. If the
page, or one or more frames, do not have the tag, the test fails and the run result
details display a list that shows which objects are lacking the tag. For example:

The Captured Data pane displays the captured page or frame, so that you can see the
frames listed in the Frame Titles check list.

Multimedia Links Check
Guidelines 1.3 and 1.4 of the W3C Web Content Accessibility Guidelines require you to
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provide an auditory, synchronized description of the visual track of a multimedia
presentation. Guideline 6 requires you to ensure that pages are accessible, even when
newer technologies are not supported or are turned off. The Multimedia Links Check
identifies links to multimedia objects so that you can confirm that alternate links are
available where necessary. The checkpoint passes if the page or frame does not contain
any multimedia links. Otherwise, the results display a warning and a list of the
multimedia links.

Server-Side Image Check
Guideline 1.2 of the W3C Web Content Accessibility Guidelines requires you to provide
redundant text links for each active region of a server-side image map. Guideline 9.1
recommends that you provide client-side image maps instead of server-side image
maps except where the regions cannot be defined with an available geometric shape.
When you select the Server-side Image check, UFT checks whether the selected page or
frame contains any server-side images. If it does not, the checkpoint passes. If the page
or frame does contain server-side images, then the results display a warning and a list
of the server-side images so that you can confirm that each one answers the guideline
requirements. For example:

Tables Check
Guideline 5 of the W3C Web Content Accessibility Guidelines requires you to ensure that
tables have the necessary markup to be transformed by accessible browsers and other
user agents. It emphasizes that you should use tables primarily to display truly tabular
data and to avoid using tables for layout purposes unless the table still makes sense
when linearized. The TH, TD, THEAD, TFOOT, TBODY, COL, and COLGROUP tags are
recommended so that user agents can help users to navigate among table cells and
access header and other table cell information through auditory means, speech output,
or a Braille display.
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The Tables Check checks whether the selected page or frame contains any tables. If it
does not, the checkpoint passes. If the page or frame does contain tables, the results
display a warning and a visual representation of the tag structure of the table. For
example:
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Bitmap Checkpoint Results (UFT GUI Tests Only)

The Result Details pane displays the checkpoint step results, including its status
(Passed or Failed), the date and time the checkpoint was run and the portion of the
checkpoint timeout interval that was used (if any).

When Comparing Expected Bitmaps with Actual Bitmaps
The Captured Data pane shows the expected and actual bitmaps that were compared
during the run session, and a View Difference button. When you click the View
Difference button, UFT opens the Bitmap Checkpoint Results window, displaying an
image that represents the difference between the expected and actual bitmaps. This
image is a black-and-white bitmap that contains a black pixel for every pixel that is
different in the two images. Similar results would be displayed for a component.
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When Locating Specified Bitmaps in Actual Bitmaps
The Captured Data pane shows the actual bitmap of the runtime object in the
application and the source bitmap that UFT attempted to locate within the object. It
may also show the coordinates of a possible candidate that was found, and the image
similarity percentage used to find the candidate.

Note: By default, the information in the Captured Data pane is available only if the
bitmap checkpoint fails. You can change the conditions for when bitmaps are saved
in the run results, using the Save still image captures to results option in the
Screen Capture pane (Tools > Options > GUI Testing tab > Screen Capture node)
of the Options dialog box. For details, see the section describing the Screen Capture
pane in the HP Unified Functional Testing User Guide.

Considerations for Reviewing Bitmap Checkpoint Results

l When comparing bitmaps, if the checkpoint is defined to compare only specific areas
of the bitmap, the run results display the actual and expected bitmaps with the
selected area highlighted.

l When comparing bitmaps, if the dimensions of the actual and expected bitmaps are
different, UFT fails the checkpoint without comparing the bitmaps. In this case the
View Difference functionality is not available in the results.

l The View Difference functionality is not available when viewing results generated in
a version of QuickTest earlier than 10.00.
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l If the bitmap checkpoint is performed by a custom comparer:

n UFT passes the bitmaps to the custom comparer for comparison even if their
dimensions are different.

n The Result Details pane also displays the name of the custom comparer (as it
appears in the Comparer box in the Bitmap Checkpoint Properties dialog box), and
any additional information provided by the custom comparer.

n The difference bitmap is provided by the custom comparer.

For details on bitmap checkpoints and custom comparers, see the section describing
bitmap checkpoints in the HP Unified Functional Testing User Guide.

File Content Checkpoint Results (UFT GUI Tests Only)

The Result Details pane displays detailed results of the selected checkpoint, including
its status (Passed or Failed), and the date and time the checkpoint was run. It also
displays the number of lines that were checked, the number of changes found in the
checked lines, and the total number of changed lines found in the file (including both the
lines that were selected in the checkpoint and the lines that were not).

The details area also specifies whether the checkpoint includes the following options:
Match case, Ignore spaces, Verify page count, and Fail checkpoint for added or
removed lines

For failed steps, the Captured Data pane displays any differences found for all lines in
the actual file, regardless of whether they were selected for comparison in the
checkpoint. An asterisk (*) adjacent to the line number indicates that a regular
expression was selected for comparison against the actual file.

In the following example, the details of the failed checkpoint indicate that the expected
results and the current results do not match.

l The expected value in line 1 is not identical to the actual value.

l The asterisk (*) in line 1 indicates that a regular expression was selected for
comparison against the actual file and the lines in the expected and actual files are
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different.

l Lines that were selected for comparison are displayed in black.
Lines that were not selected for comparison are displayed in light grey.

l The last line exists in the source (expected) file but is missing from the actual file.
This line was not selected for comparison, so its textual content is displayed in grey
instead of black.

l No lines were added to the actual file.
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Captured Data Pane — Buttons

UI Elements Description

Color
Settings

Opens the "Color Settings Dialog Box (Captured Data Pane
- Run Results Viewer) (UFT GUI Tests Only) " on page 131
dialog box, enabling you to define the text and background
color for each filter type. For details, see the HP Unified
Functional Testing User Guide.

Next
Difference

Finds the next difference between the lines in the compared
versions.

Previous
Difference

Finds the previous difference between the lines in the
compared versions.

Filter Opens the "Filter Dialog Box (Captured Data Pane - Run
Results Viewer) (UFT GUI Tests Only) " on page 132 dialog
box, enabling you to show or hide the following types of filter
elements in the comparison window:

l Modified

l Deleted

l Added

l Identical

Tip: The legend in the top-right corner of the comparison
window indicates how many lines match each filter type.
The legend adjacent to a collapsed node indicates how
many sub-nodes match each filter type. For details, see
the HP Unified Functional Testing User Guide.

View
Horizontal
or
View
Vertical

View Horizontal. Displays the open documents one above
the other.

View Vertical. Displays the open documents side-by-side.
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For details, see the section describing file content checkpoints in the HP Unified
Functional Testing User Guide.

Standard Checkpoint Results (UFT GUI Tests Only)

The Result Details pane displays detailed results of the selected checkpoint, including
its status (Passed or Failed), the date and time the checkpoint was run, and the portion
of the checkpoint timeout interval that was used (if any). It also displays the values of
the object properties that are checked, and any differences between the expected and
actual property values.

The Captured Data pane displays the image capture for the checkpoint step (if
available).
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In the following example, the details of the failed checkpoint indicate that the expected
results and the current results do not match. The expected value of the flight departure
is Paris, but the actual value is Frankfurt.

For details, see the section describing standard checkpoints in the HP Unified
Functional Testing User Guide.
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Table and Database Checkpoint Results (UFT GUI Tests
Only)

The results displayed for table and database checkpoints are similar. The Result Details
pane displays the checkpoint step results, including its status (Passed or Failed), the
date and time the checkpoint was run, the verification settings you specified for the
checkpoint, and the number of individual table cells or database records that passed
and failed the checkpoint.

If the checkpoint failed, the Captured Data pane shows the table cells or database
records that were checked by the checkpoint. Cell values or records that were checked
are displayed in black; cell values or records that were not checked are displayed in
gray. Cells or records that failed the checkpoint are marked with a failed  icon.
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The following is an example of the results for a table checkpoint:

You can click the Next Mismatch button in the Captured Data pane to highlight the
next table cell or database record that failed the checkpoint.

You can click the Compare Values button in the Captured Data pane to display the
expected and actual values of the selected table cell or database record.

For details, see the sections describing table checkpoints and database checkpoints in
the HP Unified Functional Testing User Guide.
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Text and Text Area Checkpoint Results (UFT GUI Tests
Only)

The Result Details pane displays the checkpoint step results, including its status
(Passed or Failed), the date and time the checkpoint was run and the portion of the
checkpoint timeout interval that was used (if any). It also shows the expected text and
actual text that was checked, and the verification settings you specified for the
checkpoint.

The following is an example of the results for a text checkpoint:

For details, see the section describing text and text area checkpoints in the HP Unified
Functional Testing User Guide.
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XML Checkpoint Results (UFT GUI Tests Only)

The Result Details pane displays the checkpoint step results.

The Captured Data pane shows the details of the schema validation (if applicable) and a
summary of the checkpoint results. If the schema validation failed, the reasons for the
failure are also shown.

If the checkpoint failed, you can view details of each check performed in the checkpoint
by clicking View XML Checkpoint Results in the Captured Data pane. The XML
Checkpoint Results window opens, displaying details of the checkpoint's failure. For
details, see "XML Checkpoint Results Window (UFT GUI Tests Only) " on page 133.
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The following is an example of the results for an XML checkpoint:

Note: By default, if the checkpoint passes, the View XML Checkpoint Results
button is not available. The availability of these detailed results is dependent on the
Save still image captures to results setting in the Screen Capture pane (Tools >
Options > GUI Testing tab > Screen Capture node) of the Options dialog box. For
details, see the section describing the Screen Capture pane in the HP Unified
Functional Testing User Guide.
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Output Value Results (UFT GUI Tests Only)

The Result Details pane displays detailed results of the selected output value step,
including its status, and the date and time the output value step was run. It also
displays the details of the output value, including the value that was captured during
the run session, its type, and its name, as shown in the following example. Similar
results would be displayed for a component.

For details, see the section describing output values in the HP Unified Functional
Testing User Guide.

For details on XML output value steps, see "XML Output Value Results (UFT GUI Tests
Only) " on page 126.
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File Content Output Value Results (UFT GUI Tests Only)

The Result Details pane displays the results of the file content output value step,
including its status, the date and time the step was run, and details for the
parameterized file content output value. This pane also shows the configuration
settings (whether match case and ignore spaces were set), as shown in the following
example.

For details, see the section describing file content output values in the HP Unified
Functional Testing User Guide.
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XML Output Value Results (UFT GUI Tests Only)

The Result Details pane displays a summary of the output value results.

From the Captured Data pane, you can view detailed results by clicking View XML
Output Value Results to open the XML Output Value Results window. For details, see
"XML Output Value Results Window (UFT GUI Tests Only) " on page 142.

The following is an example of the results for an XML output value:

Note: By default, the View XML Output Value Results button is available only when
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an error occurs. The availability of these detailed results is dependent on the Save
still image captures to results setting in the Screen Capture pane (Tools >
Options > GUI Testing tab > Screen Capture node) of the Options dialog box. For
details, see the section describing the Screen Capture pane in the HP Unified
Functional Testing User Guide.

For details, see the section describing XML output values in the HP Unified Functional
Testing User Guide.

Parameterized Values in the Run Results
A parameter is a variable that is assigned a value from an external data source or
generator for a test, or from within a component. You can view the values for the
parameters defined in your test or component in the Run Results Viewer.

To view parameterized values, expand the nodes in the run results tree and click the
root node to view test or component input and output parameters, or click an action
node that contains parameterized values (tests only).

Test and component parameters are displayed in the Parameters section of the
Executive Summary area of the Results Details pane, which you display by clicking the
root node of the run results tree. The example below shows input test parameters. The
Parameters section would be identical for input component parameters.
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If output test or component parameters were defined, they would be displayed in this
pane beneath the input parameters.
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For action parameters, the name and value of the input and output parameters are
displayed in the Result Details pane. Similar results would be displayed for a
component.

The example above shows input parameters that were defined at the action level. If
output parameters were defined at this level, they would also be displayed in this pane.
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For details on defining and using parameters in your tests and components, see the
HP Unified Functional Testing User Guide.

GUI Tests Containing Calls to UFT API /Service
Test Tests (UFT GUI Tests Only)
If your test contains a call to a UFT API or Service Test test, you can view the results of
that test in the run results. The run results tree displays all of the GUI test-specific
nodes that preceded the call to the UFT API or Service Test test, all of the UFT API or
Service Test test-specific nodes from that test call, and all of the GUI test-specific
nodes that followed that call.

For details on what is displayed for UFT API or Service Test test steps, see the following
sections:

l "Custom Fields (UFT API Testing Only)" on page 16

l "Captured Data Pane (Run Results Viewer) " on page 54

l "Captured Data Pane Contents for UFT API Steps" on page 57
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Reference

Color Settings Dialog Box (Captured Data Pane -
Run Results Viewer) (UFT GUI Tests Only)
This dialog box enables you to modify the text and background colors for the various
filter elements in the Captured Data pane in the Run Results Viewer.

To access In the Captured Data pane, click the Color Settings toolbar button
.

Important
information

Availability: File content checkpoints only

If you change the background color for a filter type, the legend in
the top-right corner of the pane changes accordingly. These
changes remain in effect unless you change them again or restore
the default settings.
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User interface elements are described below:

UI Elements Description

Modified
Deleted
Added
Identical

Text color and background color for the relevant filter elements.

You can:

l Click a down arrow to select a color from the list of colors in
the Custom, Web, or System tabs.

l Enter an RGB value directly in the edit box.

Restore Restores the default color values for each of the filter elements.

Filter Dialog Box (Captured Data Pane - Run
Results Viewer) (UFT GUI Tests Only)
This dialog box enables you to show or hide lines in the pane according to filter criteria.

To access In the Captured Data pane, click the Filter toolbar
button .

Important information Availability: File content checkpoints
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User interface elements are described below:

UI
Elements

Description

Select
elements
to show

Select or clear a check box. The pane displays only those lines
that match the defined filter. You can show or hide the following
types of lines:

l Modified

l Deleted

l Added

l Identical

XML Checkpoint Results Window (UFT GUI Tests
Only)
This window displays the XML file hierarchy.

l Expected XML Tree pane. Displays the expected results—the elements, attributes,
and values, as stored in your XML checkpoint.

l Actual XML Tree pane. Displays the actual results—what the XML document
actually looked like during the run session.

l Checkpoint Summary pane. Displays results information for the check performed on
the selected item in the expected results pane.
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To access In the Captured Data pane of the Run Results Viewer, click the
View XML Checkpoint Results button.

Important
information

When you open the XML Checkpoint Results window, the
Checkpoint Summary pane displays the summary results for the
first checked item in the expected results pane.

Tip: You can double-click any element value in this window to
open the Element Value dialog box, which displays the value
in a multi-line edit control. For details, see "Element Value
Dialog Box (Run Results Viewer) (UFT GUI Tests Only)" on
page 141.

See also "XML Checkpoint Results (UFT GUI Tests Only) " on page 122
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User interface elements are described below:

UI
Elements

Description

View Checkpoint Summary. Displays the Checkpoint Summary
pane, which provides a detailed description of which parts of an
element passed or failed.

Menu option: View > Checkpoint Summary.

View Attribute Details. Displays the Expected Attributes and Actual
Attributes panes, for an element whose attributes were checked.

Menu option: View > Attribute Details.

Find Next Check. Jumps directly to the next checked item in the
XML Tree.

Menu option: View > Find Next Check

Find Previous Check. Jumps directly to the previous checked item
in the XML Tree.

Menu option: View > Find Previous Check

Find Next Error. Jumps directly to the next error in the XML Tree.

Menu option: View > Find Next Error

Find Previous Error. Jumps directly to the previous error in the XML
Tree.

Menu option: View > Find Previous Error

Scroll Trees Simultaneously. Synchronizes the scrolling of the
Expected and Actual XML Trees. If this option is selected, the
Expected and Actual XML Trees scroll simultaneously as you
navigate through either of the tree structures. If this option is not
selected, you can scroll only one tree at a time.

Menu option: View > Scroll Trees Simultaneously

Help Topics.Opens the help for the XML Checkpoint Results
window.

Menu option: View > Help Topics
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Sample XML Checkpoint Result Scenarios

Below are four sample XML checkpoint scenarios. Each example describes the changes
that occurred in the actual XML document, explains how you locate the cause of the
problem in the XML checkpoint results, and displays the corresponding XML Checkpoint
Results window.

Scenario 1
In the following example, the airline element tag was changed to airlines and the
XML checkpoint identified the change in the tag structure. The airline element's child
element check also failed because of the mismatch at the parent element level.

To view details of the failed element, select the airline tag from the Expected XML
Tree and select View > Checkpoint Summary to view the Checkpoint Summary in the
bottom pane in the XML Checkpoint Results window.
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The text "This element is missing" indicates that the airline element tag
changed in your XML document.

Scenario 2
In the following example, an attribute that is associated with the orders element tag
was changed from the original, expected value of orders1, to a new value of
orders2.

To view details of the failed attribute, select the failed element from the Expected XML
Tree and select View > Attribute Details. The Expected Attributes and Actual Attributes
panes are displayed at the bottom of the XML Checkpoint Results window.
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Using the Expected Attributes and Actual Attributes panes, you can identify which
attribute caused the error and which values were mismatched.

Scenario 3
In the following example, the actual value of the total element was changed between
execution runs, causing the checkpoint to fail.

To view details of the failed value, select the failed element from the Expected XML
Tree and select View > Checkpoint Summary to view the Checkpoint Summary in the
bottom pane in the XML Checkpoint Results window.
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Using the Checkpoint Summary pane, you can compare the expected and actual values
of the total element.

Scenario 4
In the following example, the value of the total element was parameterized and the
value's content caused the checkpoint to fail in this iteration.

The value icon is displayed with a pound symbol to indicate that the value was
parameterized.

To view details of the failed value, select the failed element from the Expected XML
Tree and select View > Checkpoint Summary to view the Checkpoint Summary in the
bottom pane in the XML Checkpoint Results window. The procedure for analyzing the
checkpoint results does not change even though the value was parameterized.
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Using the Checkpoint Summary pane, you can compare the expected and actual values
of the total element.
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Element Value Dialog Box (Run Results Viewer)
(UFT GUI Tests Only)
This dialog box enables you to view element values from the XML Checkpoint Results
window in a multi-line edit window. It also enables you to navigate between the values
in the Expected XML Tree or Actual XML Tree.

To access Double-click a value in the XML Checkpoint Results window.

See also "XML Checkpoint Results (UFT GUI Tests Only) " on page 122

User interface elements are described below (unlabeled elements are shown in angle
brackets):

UI
Elements

Description

Value x
of y

Indicates the ordinal position of the selected value within the
Expected XML Tree or Actual XML Tree.

<edit
window>

Displays the full value of the element or attribute in a multi-line
window.

<<
Previous
Value

Enables you to navigate backward through the element values in the
XML Checkpoint Results window. Clicking this button displays the
next value in the Expected XML Tree or Actual XML Tree.
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UI
Elements

Description

Next
Value >>

Enables you to navigate forward through the element values in the
XML Checkpoint Results window. Clicking this button displays the
next value in the Expected XML Tree or Actual XML Tree.

XML Output Value Results Window (UFT GUI Tests
Only)
This window displays the XML file hierarchy in the following panes.

l Data Table Names pane. Displays the XML output value settings—the structure of
the XML and the Data Table parameters (column names) you selected to output for
Data Table output values.

l Output Values pane. Displays the actual XML tree—what the XML document or file
actually looked like and the actual values that were output during the run.

This window also displays:

l Additional Details pane. Displays results information for the selected item.
(Available only if the Output Value Summary option is selected.)

l Expected Attributes pane. Displays each attribute name and its expected value or
output value name. (Available only if the Attribute Details option is selected.)

l Actual Attributes pane. Displays the attribute name and the actual value of each
attribute during the run session. (Available only if the Attribute Details option is
selected.)
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To
access

In the Captured Data pane of the Run Results Viewer, click the View
XML Output Value Results button.

See
also

"XML Output Value Results (UFT GUI Tests Only) "
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User interface elements are described below:

UI
Elements

Description

View Output Value Summary. Displays the Output Value Summary
pane, which provides information regarding the output value for the
element, attribute, or value currently selected in the XML tree.

Menu option: View > Output Value Summary.

View Attribute Details. Displays the Expected Attributes and Actual
Attributes panes containing the details of the attribute’s output value
for the selected element in the XML tree.

Menu option: View > Attribute Details.

Find Next Output Value. Jumps directly to the next output value in
the XML Tree.

Menu option: View > Find Next Output Value

Find Previous Output Value. Jumps directly to the previous output
value in the XML Tree.

Menu option: View > Find Previous Output Value

Find Next Error. Jumps directly to the next error in the XML Tree.

Menu option: View > Find Next Error

Find Previous Error. Jumps directly to the previous error in the XML
Tree.

Menu option: View > Find Previous Error

Scroll Trees Simultaneously. Synchronizes the scrolling of the
Data Table Names and Output Values trees. If this option is
selected, the Data Table Names and Output Values trees scroll
simultaneously as you navigate through either of the tree structures.
If this option is not selected, you can scroll only one tree at a time.

Menu option: View > Scroll Trees Simultaneously

Help Topics.Opens the help for the XML Output Value Results
window.

Menu option: View > Help Topics
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Send Us Feedback
Can we make this User Guide better?

Tell us how: sw-doc@hp.com
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