HP ALM Performance Center
Software Version: 12.20

Quick Start

Document Release Date: December 2014
Software Release Date: December 2014

Quick Start

Legal Notices
Warranty
The only warranties for HP products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be
construed as constituting an additional warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.
The information contained herein is subject to change without notice.

Restricted Rights Legend
Confidential computer software. Valid license from HP required for possession, use or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software,
Computer Software Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard commercial license.

Copyright Notice
© Copyright 2002 - 2014 Hewlett-Packard Development Company, L.P.

Trademark Notices
Adobe™ is a trademark of Adobe Systems Incorporated.
Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation.
UNIX® is a registered trademark of The Open Group.
This product includes an interface of the 'zlib' general purpose compression library, which is Copyright © 1995-2002 Jean-loup Gailly and Mark Adler.

Documentation Updates
The title page of this document contains the following identifying information:
l
l
l

Software Version number, which indicates the software version.
Document Release Date, which changes each time the document is updated.
Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a document, go to: http://h20230.www2.hp.com/selfsolve/manuals
This site requires that you register for an HP Passport and sign in. To register for an HP Passport ID, go to: http://h20229.www2.hp.com/passport-registration.html
Or click the New users - please register link on the HP Passport login page.
You will also receive updated or new editions if you subscribe to the appropriate product support service. Contact your HP sales representative for details.

Support
Visit the HP Software Support Online web site at: http://www.hp.com/go/hpsoftwaresupport
This web site provides contact information and details about the products, services, and support that HP Software offers.
HP Software online support provides customer self-solve capabilities. It provides a fast and efficient way to access interactive technical support tools needed to manage your
business. As a valued support customer, you can benefit by using the support web site to:
l
l
l
l
l
l
l
l

Search for knowledge documents of interest
Submit and track support cases and enhancement requests
Download software patches
Manage support contracts
Look up HP support contacts
Review information about available services
Enter into discussions with other software customers
Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a support contract. To register for an HP Passport ID, go to:
http://h20229.www2.hp.com/passport-registration.html
To find more information about access levels, go to:
http://h20230.www2.hp.com/new_access_levels.jsp

HP ALM Performance Center (12.20)

Page 2 of 48

Quick Start

HP Software Solutions Now accesses the HPSW Solution and Integration Portal Web site. This site enables you to explore HP Product Solutions to meet your business
needs, includes a full list of Integrations between HP Products, as well as a listing of ITIL Processes. The URL for this Web site is
http://h20230.www2.hp.com/sc/solutions/index.jsp

HP ALM Performance Center (12.20)

Page 3 of 48

Quick Start

Contents
Welcome to This Guide
How This Guide is Organized

7
7

Chapter 1: Introducing Performance Center

9

The ALM Performance Center Testing Process

9

What is the testing process?

9

Performance Testing Applications

10

Sample Application - HP Tours

10

Chapter 2: Creating Vuser Scripts
Recording Vuser Scripts

11
11

How do I start recording user activity?

11

How do I record a script?

12

How do I view my script?

15

How do I save the script?

18

Chapter 3: Creating and Designing Performance Tests

19

Logging in to Performance Center

19

Adding Vuser Scripts to Performance Center

21

How do I upload the Vuser Script?
Monitoring Performance Tests

21
22

What is a monitor profile?

23

How do I create a monitor profile?

23

Creating Performance Tests
How do I create a performance test?
Designing Performance Tests

23
24
24

How do I open the Performance Test Designer?

24

How do I design the performance test?

25

How do I add the monitor profile to the test?

28

Chapter 4: Running Performance Tests
Creating Test Sets

29
29

What is a test set?

29

How do I create a test set?

29

HP ALM Performance Center (12.20)

Page 4 of 48

Quick Start

Reserving Timeslots
How do I reserve a timeslot?
Running Performance Tests

30
30
31

How do I run the performance test?

32

What does the Performance Test Run page display?

32

Chapter 5: Post-Run Analysis and Trending
Analyzing Performance Test Run Results

35
35

How do I view Analysis information?

35

Did I reach my goals?

38

How can I view the graphs?

38

How can I compare data from different graphs?

40

How can I sort graph data?

41

How can I publish my findings?

42

Viewing Performance Improvements and Regressions
What steps are involved in working with trend reports?

42
42

Creating the Trend Report

43

Viewing Trend Report Data

44

Send Documentation Feedback

HP ALM Performance Center (12.20)

47

Page 5 of 48

Quick Start

HP ALM Performance Center (12.20)

Page 6 of 48

Welcome to This Guide
Welcome to the HP ALM Performance Center Quick Start. Performance Center is HP's Web-enabled
global performance testing tool, designed to streamline the testing process and increase the test
efficiency for multiple concurrent performance tests across multiple geographic locations.
This Quick Start is a self-paced guide designed to lead you through the process of creating, running,
and analyzing a performance test, and to introduce you to the Performance Center testing environment.
Note: This guide assumes that your Performance Center environment has been fully installed and
configured, and that a domain and project have been set up. For more information, contact your
Performance Center administrator.

How This Guide is Organized
This guide contains the following lessons:
Lesson

Description

"Introducing
Performance Center"
on page 9

Provides an overview of Performance Center and the performance
testing applications.

"Creating Vuser
Scripts" on page 11

Describes the steps involved in recording Vuser scripts using HP Virtual
User Generator.

"Creating and
Designing Performance
Tests" on page 19

Describes the steps involved in creating and designing performance
tests.

"Running Performance
Tests" on page 29

Describes the steps that are necessary before running a performance
test, and how to begin test execution.

"Post-Run Analysis
and Trending" on
page 35

Describes how to analyze test run data using HP LoadRunner Analysis,
and how to view performance improvements and regressions using the
Trend Reports feature.
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Chapter 1: Introducing Performance Center
This lesson provides a brief overview of Performance Center, and of the applications that are involved
in the testing process.
Notes:
l

l

The Quick Start describes how to run a performance test with a single host functioning as both
a load generator and a Controller (C+LG). However, due to possible heavy load on the
Controller and load generator hosts during a performance test, it is best practice to assign these
functions to separate host machines.
Ensure that the latest standalone versions of HP Virtual User Generator (VuGen) and
HP LoadRunner Analysis are installed on your system.

In this lesson you will learn about:
l

"The ALM Performance Center Testing Process" below

l

"Performance Testing Applications" on the next page

The ALM Performance Center Testing Process
Using ALM Performance Center, you create performance tests in which you define the events that
occur during a testing session. During a test, ALM Performance Center replaces human users at
physical machines with virtual users, or Vusers. These Vusers create load on your system by
emulating actions of typical users in a repeatable and predictable manner.
Suppose you are testing a Web-based travel agency application that enables users to book flights
online. Your goal as the performance tester is to determine how the application behaves when multiple
users try to perform the same transaction at the same time. Using ALM Performance Center, you can
run a test in which 1,000 Vusers, emulating 1,000 travel agents, would simultaneously try to book a
flight on the application.

What is the testing process?
The testing process consists of the following basic processes:
l

l

Creating the script. Capturing typical end-user business processes performed on your application.
Designing the performance test. Setting up the test environment by defining events that occur
during the testing session.
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l

l

l

Preparing to run the performance test. Adding the performance test to a test set and reserving a
timeslot for the test.
Running the performance test. Driving, managing, and monitoring the test.
Analyzing the results and viewing performance trends. Analyzing the performance data
generated during the test run, and viewing trending information which identifies performance
improvements and regressions over time.

These processes are explained in more detail in the lessons that follow.

Performance Testing Applications
Each step in the testing process is carried out by one of the HP load testing tool components. The
components are as follows:
Application

Description

HP Virtual User
Generator (VuGen)

Creates the script and generates virtual users, or Vusers. VuGen does this
by capturing actions that typical end-users would perform on your
application, and then records these actions into automated Vuser scripts.
These Vuser scripts form the foundation of a performance test.

HP ALM Performance Provides the central console from which you build, manage, and monitor a
Center
test.
HP Analysis

Analyzes the performance test and provides graphs and reports with indepth performance analysis information. Using these graphs and reports,
you can pinpoint and identify the bottlenecks in your application and
determine what changes need to be made to your system to improve its
performance.

Sample Application - HP Tours
To illustrate the testing process, this Quick Start uses a sample Web-based travel agency application
called HP Tours.
During the course of this Quick Start, you will go through the basic steps of creating, running, and
analyzing a performance test. The test will emulate 10 travel agents simultaneously connecting to the
HP Tours Web server and performing various flight reservation actions, for example logging on,
searching for flights, purchasing flights, checking itineraries, and logging off.
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This lesson explains the steps involved in recording Vuser scripts using HP Virtual User Generator.
In this lesson you will learn about:
l

"Recording Vuser Scripts" below

Recording Vuser Scripts
You record Vuser scripts using HP Virtual user Generator (VuGen). A Vuser script is a record of a
typical end-user business process. VuGen works on a record-and-playback principle. As you walk
through a business process on your application, VuGen records your actions into an automated script
which later forms the foundation of the performance test.
This section includes:
l

"How do I start recording user activity?" below

l

"How do I record a script?" on the next page

l

"How do I view my script?" on page 15

l

"How do I save the script?" on page 18

How do I start recording user activity?
You begin by opening Vugen and creating a blank script.
1. Start VuGen.

Double-click the Virtual User Generator

shortcut icon on your desktop.

2. Create a blank Web script.
a. On the VuGen Start Page, click the Add New Script button
dialog box opens.
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A protocol is the language that your client uses to communicate with the back end of the
system. HP Tours is a Web-based application, so you will create a Web virtual user script.
b. Make sure the Category type is Single Protocol. VuGen displays a list of the protocols that
are available for a single-protocol script.
c. From the list of available protocols, select Web - HTTP/HTML and click Create. VuGen
creates a blank Vuser script and displays the script in the VuGen Editor.

How do I record a script?
The next stage in creating user emulation is recording the events performed by a real user. In the
previous section, you created an empty Web script. In this section, you will track the events of one
passenger reserving a flight from Denver to Los Angeles and then check the itinerary.
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1. Start recording on the HP Web Tours site.

a. Click the Record button

on the VuGen toolbar. The Start Recording dialog box opens.

b. In the Record into action box, select Action.
c. In Record, select Web Browser.
d. In the URL address box, type http://localhost:1080/WebTours.
e. Keep all other default settings.
f. Click Start Recording. A new web browser opens and displays the HP Web Tours site.
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Note: If there is an error opening the site, make sure that the Web server is running. To
start the server, select Start > All Programs > HP LoadRunner > Samples > Web >
Start Web Server.
The floating Recording toolbar opens.

2. Log on to the HP Web Tours site.
a. On the HP Web Tours home page, type the user credentials:
o

For the Username type jojo.

o

For the Password type bean.

b. Click Login. A welcome page opens.
3. Enter flight details.
a. Click Flights. The Find Flight page opens.
b. Define the following flight criteria:
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o

Departure City: Denver (default)

o

Departure Date: Keep the default, current date

o

Arrival City: Los Angeles

o

Return Date: Keep the default, tomorrow's date

c. Keep the rest of the default settings and click Continue. The search results appear.
4. Select a flight.
Click Continue to accept the default flight selection. The Payment Details page opens.
5. Enter payment information and book flight.
a. In the Credit Card box enter 12345678.
b. In the Exp Date box enter 01/16 in the Exp Date box.
c. Click Continue. The Invoice page opens, displaying your invoice.
6. Check the itinerary.
In the left pane, click itinerary. The Itinerary page opens displaying the itinerary for flight you
booked above.
7. Log off the HP Web Tours Site
In the left pane, click Sign Off.
8. Stop recording.
Click the Stop

button on the floating toolbar to stop the recording process.

VuGen generates the required code and inserts the code into the Vuser script.
If the Design Studio opens, click Close to close the Design Studio.

How do I view my script?
You have now recorded a travel agent logging in, booking a flight, checking the itinerary, and logging
off. VuGen recorded your steps from the moment you clicked the Start Recording button to the
moment you clicked the Stop Recording button. You can now use VuGen to view the script.
1. Display the Solution Explorer tab.
On the left side pane, make sure the Solution Explorer tab is selected.
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This tab provides you structured access to the various parts of a Vuser script, as well as to a
number of files that are associated with the Vuser script.
2. Display the Step Navigator tab.
Click the Step Navigator tab.
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The Step Navigator displays an icon-based view of the script that lists the actions of the Vuser as
steps. For each action you performed during recording, VuGen generated a corresponding step in
the Step Navigator.
The Step Navigator displays a snapshot icon to indicate that a specific step contains a snapshot.
3. View a step in the VuGen Editor.
Double-click any step in the Step Navigator to display the corresponding function in the VuGen
Editor. The Editor displays a text-based view of the script.
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In the Editor, the actions of the Vuser are listed as API functions. VuGen uses color-coding to show
the functions and their argument values in the script. You can type C or API functions, as well as
control flow statements, directly into the script.

How do I save the script?
Select File > Save Script As and save the script locally on your desktop. For example, type Scripts.
The script file should be zipped. After you have created your performance test, you will upload the
script to ALM Performance Center.
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Tests
This lesson explains how to manage test assets in ALM, and the steps involved in creating and
designing a performance test.
In this lesson you will learn about:
l

"Logging in to Performance Center" below

l

"Adding Vuser Scripts to Performance Center" on page 21

l

"Monitoring Performance Tests" on page 22

l

"Creating Performance Tests" on page 23

l

"Designing Performance Tests" on page 24

Logging in to Performance Center
You log into Performance Center as follows:
1. Choose one of the following:
From Performance Center: Open your web browser and type the Performance Center Server
URL
http://<PCS server name>/loadtest.
Note: If more than one Performance Center server is installed in your system together with a
load balancer, you should access My Performance Center by entering the load balancer's
URL. Alternatively, you can also enter the server's defined internal URL.
From ALM: Open your Web browser and type your ALM URL
http://<ALM server name/IP address>[<:port number>]/qcbin. The HP Application
Lifecycle Management Options window opens. Click My Performance Center.
Note: Contact your system administrator if you do not have the correct URL.
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2. The My Performance Center Login window opens.

If Performance Center was configured for external authentication, the Login Name and
Password fields do not appear in this window. For more details on external authentication, see the
HP ALM External Authentication Configuration Guide
3. In the Login Name box, type your user name.
4. In the Password box, type the password assigned to you by your site administrator.
5. Select the Automatically log in to my last domain and project on this machine check box if
you want Performance Center to automatically log in to the last project in which you were working.
6. Click the Authenticate button. Performance Center verifies your user name and password and
determines which domains and projects you can access. If you specified automatic login,
Performance Center opens.
7. In the Domain list, select a domain. By default, the last domain in which you were working is
displayed.
8. In the Project list, select a project. By default, the last project in which you were working is
displayed.
9. Click Login. Performance Center opens.
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Adding Vuser Scripts to Performance Center
The first step in your test design process is to add your Vuser script to Performance Center. Adding the
script involves two steps: Creating a scripts folder, and uploading the script to the folder.

How do I upload the Vuser Script?
You upload the script from within Performance Center, as follows:
1. Make sure the script is saved locally and is zipped.
2. On the My Performance Center navigation bar, select Test Management > Test Plan.
3. Create a script folder.
a. Select Subject.
b. Click the New Folder

button, and specify a name for the folder, for example, Scripts.

c. Click OK to add the folder.
4. On the module toolbar, click the Upload Script
opens.
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5. In the Select Folder box, select the scripts folder you created above.
6. Click one of the Select buttons and navigate to the location of the zipped script file.
7. Click Upload to upload the script.

Monitoring Performance Tests
You monitor performance test execution using the ALM Performance Center online monitors.
For example, you use the System Resource monitors to monitor a machine's system resource usage
during a performance test and identify server performance bottlenecks.
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A primary factor in a transaction's response time is its system resource usage. Using the ALM
Performance Center resource monitors, you can monitor the Windows Resource usage on a machine
during a test run, and determine why a bottleneck occurred on a particular machine.

What is a monitor profile?
To monitor server resources during the test, you select the type of monitors to run and the servers
whose resources you want to monitor. You then add the measurements to monitor for each server.
These monitor settings can be saved as a monitor profile which can be used by any performance test in
your project.
The following section will show you how to create a monitor profile and how add a Windows Resource
Monitor to it.

How do I create a monitor profile?
You create and configure monitor profile as follows:
1. On the My Performance Center navigation bar, select Resources > Test Resources.
2. Create a folder for the monitor profile.
3. Select the folder, and click the New Monitor Profile
dialog box, enabling you to add a new monitor profile.

button. The Create New Monitor Profile

4. Enter the required information and click OK to add the monitor profile to the folder.
5. In the Monitor Profile page, click the Add Monitor button
opens, select the monitor that you want to run.

. In the Add New Monitor page that

6. Select Windows Resources. The Edit Monitor dialog box opens, enabling you to select the
Windows Resources counters you want to monitor.
7. Enter the desired information, and click Save. The monitor is added to your monitor profile.
You will add the monitor profile to the test as part of the test design process.

Creating Performance Tests
To create a test, you begin by creating a test folder, and then creating the test and adding it to the
folder. In the next section, you will learn how to design the test in the Test Designer.
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How do I create a performance test?
You create the test as follows:
1. On the My Performance Center navigation bar, select Test Management > Test Plan.
2. Select Subject. Click the New Folder button, and specify a name for the folder, for example,
Tests. Click OK to add the folder.

3. Select the folder, and click the New Test
box opens.

button. The Create New Performance Test dialog

4. Enter the test name and click OK. The Performance Test Designer opens.

Designing Performance Tests
You design your performance test in the Performance Test Designer.

How do I open the Performance Test Designer?
You open the test designer as follows:
1. On the My Performance Center navigation bar, select Test Management > Test Plan.
2. Select the test you created above, and click the Edit Test button on the toolbar. The Performance
Test Designer opens.
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How do I design the performance test?
From the Groups & Workload view in the Performance Test Designer, you perform the basic test
design steps. You design the test as follows:
1. Select a workload type for the test.
When the Performance Test Designer opens, you will be prompted to select a workload type for the
test. Accept the default, Basic Schedule, by test, by number.
2. Assign a Controller to the test.
a. Click the browse button adjacent to the Controller box. The Select Controller dialog box
opens.
b. Select Specific.
c. Select from the list the host machine that has been assigned the Controller and Load Generator
(C+LG) purpose.
3. Add Vuser scripts.
a. If the Scripts Tree pane is not displayed on the right, click the Select Scripts button on the
toolbar to open it. The Scripts Tree displays the script that you uploaded previously to
Performance Center.

b. In the Scripts Tree, select the script and click the left arrow to add it to the test. The script
appears in the Groups pane.

4. Add load generators.
a. On the Groups pane toolbar, in the LG Distribution box, click the arrow and select Assign
manually.
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b. In the Groups Pane, in the Load Generators column, click the Select load generators link.

The Select Load Generators dialog box opens.
c. Select the Specific tab, and from the list that appears, select the host machine that has been
assigned the Controller and load generator (C+LG) purpose.

5. Configure the schedule settings.
A schedule defines the actions of the Vusers for the performance test run, for example the behavior
of 10 Vusers emulating 10 travel agents simultaneously logging on to HP Tours, booking flights,
checking itineraries, and so on.
Because typical users do not perform the same action simultaneously, the Scheduler allows you to
schedule a performance test according to a more realistic portrayal of typical user behavior.
Define the schedule as follows:
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In the lower area of the Groups & Workload tab, in the Global Schedule pane, click in each of
the schedule actions in the Actions grid and define them as follows:
n

Initialize.

n

Start Vusers.

n

Duration.

n

Stop Vusers.

The schedule graph displays a graphical representation of the defined schedule. The lines in the
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graph correspond to the actions defined in the Actions grid.

How do I add the monitor profile to the test?
You add the monitor profile to the test as follows:
1. In the Performance Test Designer, select the Monitors view.
2. On the toolbar, click Add Monitor Profile. The Monitor Profiles pane opens on the right,
displaying the available monitor profiles.
3. In the Monitor Profiles Tree, select the monitor profile and click the left arrow to add it to the test.
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This lesson explains the steps that are necessary before you run the performance test, and how to
begin test execution.
In this lesson you will learn about:
l

"Creating Test Sets" below

l

"Reserving Timeslots" on the next page

l

"Running Performance Tests" on page 31

Creating Test Sets
The next step in the performance testing process is the creation of a performance test set.

What is a test set?
After you design the performance test in the Test Plan module, you organize the test execution by
creating a test set in the Test Lab module and adding an instance of the test to the test set. The
purpose of a test set is to enable you to group together tests that were created for similar goals.

How do I create a test set?
You create the test set and add the test to it as follows:
1. Create the test set.
a. On the My Performance Center navigation bar, select Test Management > Test Lab.

b. Click the
example, Test_set_folder.

button, and specify a name for the Test Set folder, for

c. Click OK to add the folder.
d. Select the folder you created above, and click the New Test Set
Performance Test Set dialog box opens.

button. The Create New

e. Enter the test set name. Click OK. The test name is added to the tree.
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f. Select the test set and click OK.

2. Assign the performance test to the test set.
a. Click the

button. The Assign Test to Test Set dialog box opens.

b. Select your test and click OK.

Reserving Timeslots
Before you run the test, you reserve a timeslot to ensure that the resources needed will be available for
the duration of the test.

How do I reserve a timeslot?
1. On the My Performance Center navigation bar, select Resources > Timeslots.
2. Click the New Timeslot

button. The Add New Timeslot dialog box opens.

3. Define the following information:
n

Start. Choose Manually as the method for executing tests. The timeslot reservation reserves
testing resources only.

n

Name. Enter a name for the timeslot.

n

Select a test instance. Navigate to the test set you created above, and select the test to link it
to the timeslot. The number of Vusers and hosts that were defined as part of the test design
process are automatically displayed.
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n

Duration. Set the start time, and enter a duration for the test.

n

Post-Run. Select Collate and Analyze.

4. Click Calculate Availability. The availability of the requested resources during the selected
timeslot is calculated. The results of this calculation are displayed in the Timeslot Status tab and
graphically on the time chart.

Note: If the timeslot cannot be reserved, reselect your resources or adjust the start time,
taking into account the reasons displayed in the Timeslot Status tab.
5. When you find a valid timeslot, click Submit to save the timeslot.

Running Performance Tests
Now that you have designed the performance test, added an instance of the test to a test set, and
reserved a timeslot for the test, you are ready to run the test and observe how your application performs
under load.
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How do I run the performance test?
You run the performance test as follows:
1. On the My Performance Center navigation bar, select Test Management > Test Lab.
2. Select your test from the Performance Test Set pane.
3. Click the

button. The Run Performance Test dialog box opens.

4. Click Run. The Initializing Run page displays the performance test initialization steps performed
by Performance Center, and the status for each step. If each step is completed successfully, the
performance test starts running and the Performance Test Run page opens. The Test Run page
enables you to manage and monitor the test as it runs.

What does the Performance Test Run page display?
The Performance Test Run page is the control center from which the test run is managed and
monitored.
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The Performance Test Run page displays the following:
Pane

Description

Performance The Performance Test Details Pane at the top of the page provides three views:
Test Details
l
Groups View. This is the view displayed in the above image. The Groups view
displays the statuses of the Vusers in each Vuser group in the performance test.
l

l

Transactions View. The Transactions view displays how many transactions
have been executed successfully or unsuccessfully.
Messages View. The Messages view displays error, warning, debug, and output
messages that are sent to the Controller by the Vusers and load generators
during a test run.

Summary

The Summary pane displays a synopsis of the running performance test.

Online
Graphs

The online monitor graphs display performance measurements for those resources
being monitored in the test. This enables you to monitor how the application under
test is performing in real time and identify where potential bottlenecks exist.

Topology

Displays any defined topologies for the test.
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This lesson explains how to analyze test run data using HP LoadRunner Analysis, and how to view
performance improvements and regressions using the Trend Report feature.
In this lesson you will learn about:
l

"Analyzing Performance Test Run Results" below

l

"Viewing Performance Improvements and Regressions" on page 42

Analyzing Performance Test Run Results
Now that you have completed running the performance test, you can use HP LoadRunner Analysis to
analyze the performance data generated during the test run. Analysis gathers the performance data into
detailed graphs and reports. Using these graphs and reports, you can pinpoint and identify the
bottlenecks in the application, and determine what changes need to be made to the system to improve
its performance.

How do I view Analysis information?
To provide for more interesting results, a sample analysis session is provided, which is based on a
performance test similar to the one you ran.
To open the sample Analysis session:

1. Double-click the Analysis shortcut icon

on your desktop.

2. Select File > Open. The Open Existing Analysis Session File dialog box opens.
3. Navigate to the <Analysis Standalone Installation>\Tutorial folder.
4. Select analysis_session and click Open. Analysis opens the session file in the Analysis window.
The data contained in this sample session is examined in more detail in the sections that follow.
To open the Analysis session for the test you ran:
To view Analysis data for your actual performance test, you perform the following steps:

HP ALM Performance Center (12.20)

Page 35 of 48

Quick Start
Chapter 5: Post-Run Analysis and Trending

1. Connect Analysis to ALM Performance Center.
a. In Analysis, select Tools > HP ALM Connection. The HP ALM Connection dialog box
opens.

b. Enter the ALM Platform URL, for example, http://server:8080/qcbin, and click Connect.
c. Under Step 2: Authenticate User Information, enter your ALM user credentials, and click
Authenticate.
d. Select your domain and project and click Login. The dialog box should look as follows:
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e. Click Close.
2. Open the Analysis session file for your performance test.
a. Select File > Open. The Open Analysis Session dialog box opens.
b. Select Test Lab. The test sets in the project are displayed.
c. Navigate to the Results.zip file for the instance of your performance test that you want to
analyze.
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d. Double-click the Results.zip file. The analysis session file is downloaded from Performance
Center and is opened in Analysis.

Did I reach my goals?
Analysis opens displaying the Summary Report. The Summary Report provides general information
about the performance test run. In the Statistics Summary of the report, you can see how many
Vusers ran in the test and view other statistics such as the total/average throughput, and the
total/average hits. The Transaction Summary of the report lists a summary of the behavior of each
transaction.

How can I view the graphs?
The graph tree in the left pane of the Analysis window shows the graphs that are open for viewing.
From the graph tree, you can choose to open new graphs and remove graphs that you no longer want to
view. The graphs are displayed in the graph viewing area in the right pane of the Analysis window.
You can view data from the selected graphs in the graph legend in the lower pane of the window.
As an example, we will now analyze the Average Transaction Response Time graph. Using this graph,
you can view the behavior of the problematic transactions during each second of the performance test
run. In this section, you view the behavior of the check_itinerary transaction.
To open and analyze the Average Transaction Response Time graph:
1. Click the Add New Graph button

. The Open a New Graph dialog box opens.

2. Under Transactions, select Average Transaction Response Time.
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3. Click Open Graph. The Average Transaction Response Time graph opens in the graph viewing
area.
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4. In the legend, click check_itinerary. The check_itinerary transaction is highlighted in the graph
and in the legend below the graph.
Notice how the average response time of the check_itinerary transaction fluctuates greatly
compared to the other transactions at the bottom of the graph, which follow a more or less stable
average response time.

How can I compare data from different graphs?
You can join two graphs together to see the effect of one graph's data upon another graph's data. This
is called correlating two graphs. For example, you can correlate the Running Vusers graph with the
Average Transaction Response Time graph to see the effect of a large number of Vusers on the
average response time of the transactions.
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1. Click the Add New Graph button

. The Open a New Graph dialog box opens.

2. Under Vusers, select Running Vusers.
3. Click Open Graph. The Running Vusers graph opens in the graph viewing area.
4. Select the Running Vusers graph and click the Merge Graphs button

.

5. From the Select graph to merge with list, select Average Transaction Response Time.
6. In the Select type of merge area, select Correlate, and click OK.
The Running Vusers and Average Transaction Response Time graphs are now represented by one
graph which opens in the graph viewing area.

Another Analysis tool, Auto Correlate, merges all graphs containing data that could have had an effect
on a given transaction. Correlations of the transaction with each element are displayed, allowing you to
deduce which elements had the greatest effect on the given transaction.

How can I sort graph data?
You can filter graph data to show fewer transactions for a specific segment of the performance test,
and you can sort graph data to show the data in more relevant ways. For example, you can filter the
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Average Transaction Response Time graph to display only the check_itinerary transaction.
1. Click Average Transaction Response Time in the graph tree to open the graph.
2. Select the graph and click the Set Filter/Group by button

.

3. In the Transaction Name value box, select check_itinerary and click OK.
The filtered graph displays only the check_itinerary transaction and hides all the other transactions.

How can I publish my findings?
You can publish the findings from your analysis session in an HTML or Microsoft Word report. The
HTML report can be opened and viewed in any browser. The Word report is more comprehensive than
the HTML report, enabling you to include general information about the performance test and to format
the report to include your company's name, logo, and the author's details.
For more information about analyzing performance test results, refer to the HP LoadRunner Analysis
User Guide.

Viewing Performance Improvements and Regressions
A trend report is an Performance Center feature that allows you to view changes in performance from
one performance test to another, or across several performance tests. By analyzing these changes,
you can easily identify improvements or regressions in the measurement's performance.
For example, if you would like to analyze the performance trend of the average transaction response
time measurement of Transaction X, then the trend report would display the changes in the response
time from one test to the next, clearly indicating whether this measurement improved (where the
response time decreased) or regressed (where it increased).

What steps are involved in working with trend reports?
The process of creating and viewing a trend report involves the following steps:
l

l

l

Step 1 - Creating the trend report. Creating the basic trend report by defining its name,
description and selecting a template.
Step 2 - Adding test runs to the trend report. Extracting test run data from Analysis to the trend
report.
Step 3 - Viewing trend report data. Opening the trend view and analyzing the trending
information.
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Creating the Trend Report
You create the trend report from the main Trend Reports page.
To create the trend report:
1. Open the main Performance Trending page.
On the My Performance Center navigation bar, select Runs & Analysis > Trending.
2. Open the Trend Report Creation page.
On the Performance Trending page, click the
Trend Report page opens.

button . The Create New

3. Define the General Details and Content and Layout settings.
a. In the Create New Trend Report page, define the following information:
o

In the General Details pane, enter a name and description for the trend report.

o

In the Contents and Layout pane, select the Transaction Trends template.
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b. Click Create to create the trend report. The Select Test Runs to Trend Report dialog box
superimposes on the Trend Overview tab.
4. Add Performance Test Runs to the Trend Report.
From the Project, Test Set and Test lists respectively, select the performance test that you want
to trend. All analyzed instances of the performance test appear in the table.

Select those analyzed instances of the test that you want to add to the trend report, and click Add.
Performance Center uploads the test runs from Analysis and adds them to the trend report. The
trend report opens displaying the Trend Overview tab.
Notes:
n

To add test runs to the trend report, there must be a data processor in your project's host
pool. For details, contact the Administrator.

n

The process whereby Performance Center extracts the performance test data from
Analysis is very labor intensive on the data processor and may take anywhere from several
minutes to over an hour. For best results, use a data processor dedicated for this purpose.

Viewing Trend Report Data
In the following section, we will look at trending information for the average transaction response time
measurement only.
To view trending information:
On the trend report, click the Performance tab.
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In the trend view that opens, you will see a table that displays the transactions that were present in the
test run, as well as the average transaction response times for each selected instance of the test run.
By comparing these average transaction response time figures, you can identify if the performance of
the transaction improved or regressed from one test run to the next.
The following example illustrates this point.

In the trend view shown above, four transactions (TRX_01, TRX_02, TRX_03, and TRX_04) are
displayed and their average Transaction Response Time measurement is being trended from four
performance test runs: 3, 4, 5, and 6.
Test run 3 has been automatically defined as the baseline run, (as indicated by the word Base in
brackets). This means that the average transaction response times contained in the other tests are
compared to test run 3 only.
In test run 3, the average transaction response time for TRX_01 was 2.045. The average transaction
response time for the same transaction in test run 4 was 4.073, which represents a slower response
time and therefore a regression in the performance of this measurement. The percentage difference
between the two figures is displayed in parenthesis, in this case +99.17%.
In test run 6, the average transaction response time for TRX_01 was 1.05, which represents a a faster
response time that test run 3, and therefore a performance improvement. The percentage difference
between the two figures is displayed in parenthesis, in this case -48.66%.
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Send Documentation Feedback
If you have comments about this document, you can contact the documentation team by email. If an email client is configured on this
system, click the link above and an email window opens with the following information in the subject line:
Feedback on Quick Start (ALM Performance Center 12.20)
Just add your feedback to the email and click send.
If no email client is available, copy the information above to a new message in a web mail client, and send your feedback to SWDoc@hp.com.
We appreciate your feedback!

