Browse Catalog for Service is missing in SRC.

  • KM01235496
  • 05-Nov-2014
  • 05-Nov-2014

Summary

After clicking on the Services tab within Service Request Catalog the Browse Catalog link is missing.

Error

04 Nov 2014 14:19:46,414  INFO [scheduler-2] (ProviderSessionManagerImpl.java:110) - [STALE SESSION CLEANUP]
04 Nov 2014 14:19:59,617  INFO [scheduler-4] (CatalogLifecycleManagerImpl.java:216) - [REFRESH] Starts refreshing catalog
04 Nov 2014 14:20:00,961 ERROR [scheduler-2] (CatalogAuthenticationProvider.java:271) - Exception occurs in providerAuthenticate
java.lang.NullPointerException

Cause

The user configured to connect to SRC is not configured for LDAP

Fix

Point the SRC user being used to a debugnode servlet.