Error: "Not enough quota is available to process this command" when uploading a script from VuGen to ALM PC

  • KM01198265
  • 07-Oct-2014
  • 07-Oct-2014

Summary

Uploading a script created by VuGen versions previous to VuGen 12.00 to ALM causes the VuGen to freeze. The script is not uploaded to ALM repository. After couple of minutes an error message “Not enough quota is available to process this command” appears.

Error

When uploading a script from VuGen to ALM PC 12.0x, VuGen freezes and does not complete the operation.
If all of the options are disabled in VuGen > Tools > Options > Scripting > Thumbnails the following error is displayed:
Not enough quota is available to process this command
image text
When debug mode is enabled, the "HP.LR.Vugen" log may contain errors as follows:
data\t12443.inf
14:00:48.032 [1] ERROR - A request was made for a ThumbnailFile that does on exists on storage

request:<ThumbnailRequest Id:829 for:C:\Users\administrator.PC\Desktop\script\DandM_release_1_2014_single3\data

\t12444.inf State:Failed Size:Small> ThumbnailFile:C:\Users\administrator.PC\Desktop\script

\DandM_release_1_2014_single3\data\t12444.inf
14:01:14.379 [1] ERROR - Could not copy file C:\Users\administrator.PC\Desktop\script

\DandM_release_1_2014_single3\DandM_release_1_2014_single3.prm because it does not exist

Cause

This issue may occur when uploading script developed with versions of VuGen prior to VuGen 11.50. Parsing improvements added to VuGen 11.50 as well as other "web_" functions changes may mean that an earlier script will not replay with a later version of the product. If this occurs, the business process should be recorded again using VuGen 11.50 or later.

Fix

A possible workaround for thie issue is as follows:
  1. Log On to the VuGen machine with PC System User
  2. Run VuGen as Administrator
  3. Open the problematic script
  4. Go to VuGen > Tools > Options > Scripting > Parser and uncheck all 
  5. Connect to ALM
  6. Save the script