Failed to upload config.prp error while configuring SHR remote collector

  • KM01194022
  • 02-Oct-2014
  • 02-Oct-2014

Summary

Failed to upload config.prp error while configuring SHR remote collector

Error

When adding remote collectors in Service Health Reporter (SHR) GUI, the following error is seen in <PMDB_HOME>/log/remotepoller.log:

[date] INFO, com.hp.bto.shr.utilis.collection.remotepoller.RemotePollerUtilities.checkpollerConnection , Successfully connected to collector [remote poller hostname]
[date] INFO, com.hp.bto.shr.utilis.collection.remotepoller.RemotePollerConfigHandler.acceptCertRequest , Running command ovcm -listpending -l
[date] INFO, com.hp.bto.shr.utilis.collection.remotepoller.RemotePollerUtilities.uploadFile , Uploading file /opt/HP/BSM/PMDB/data/config.prp from poller [remote poller hostname] to dir , Caller is not authorized to perform the requested operation./data/
[date] INFO, com.hp.bto.shr.utilis.collection.remotepoller.RemotePollerUtilities.uploadFile , Running ovdeploy command ovdeploy -upload -file /opt/HP/BSM/PMDB/data/config.prp -host [remote poller FQDN] -td Caller is not authorized to perform the requested operation./data/ -ovrg server
[date] ERROR, com.hp.bto.shr.utilis.collection.remotepoller.RemotePollerConfigHandler.pollerPostInstalConfiguration , Error while configuring remote collector [remote poller hostname] , Failed to upload config.prp to collector

Java stack trace is shown on the GUI.

Running "ovdeploy" command shwon on the file by hand gives "an unable to determine OS error" followed by an SSL error.

Cause

SHR is not able to communicate with Remote Collector, most of the times this is due to a certificate issue, if not it is most likely that there is an issue with the Agent on SHR server

Fix

Following steps can be executed to fix the communication between remote poller and SHR server:

1.  Login to SHR remote collector system and run command ovcoreid and make note of the core id of the collector.
 
2.  Login to SHR server and then run command ovcm -issue -file <file> -name <node name>  -coreid
 
               < node name> is the collector's FQDN 
               <coreid> is the core id of the collector system that was previously noted in step 1.
 
3. Copy the certificate <file> to the remote collector system
 
4. Login to the remote collector and once the file is copied, run the command, ovcert -importcert -file <file> to import the certificate on the collector.
 
5. Login to Admin GUI of SHR and then add the collector

If this does not solve the problem, Agent has to be checked (does it shutdown properly?  ovc commands respond in a timely fashion?, etc).