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Chapter 1: OMi Management Pack for
SAP Sybase ASE
TheOMi Management Pack for SAP Sybase ASE (OMi MP for SAP Sybase ASE) works with
Operations Manager i (OMi) and enables you tomonitor SAP Sybase ASE (Adaptive Server Enterprise)
Server environments and its underlying infrastructure using the Business ServiceManagement (BSM).
It includes Event Type Indicators (ETIs), Health Indicators (HIs), and Key Performance Indicators
(KPIs) that analyze the events that occur in the SAP Sybase ASE servers and report the health and
performance status. TheManagement Templates consist of a wide range of Aspects which enable the
monitoring the availability and performance of SAP Sybase ASE Servers, Replication Server, Backup
Server, and system infrastructure.

TheseManagement Templates can be deployed by administrators for monitoring SAP Sybase ASE
servers in an environment. The Subject Matter Experts (SMEs) and developers can easily customize
the SAP Sybase ASE Management Templates.

OMi MP for SAP Sybase ASE works with OMi and provides the following additional functionality to
support a unifiedmonitoring solution:

l SAP Sybase ASE server instance-based deployment and simplified configuration.

l Supports agent basedmonitoring of SAP Sybase ASE Server instances.
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Chapter 2: Getting Started
The following section provides information about the tasks required tomonitor SAP Sybase ASE
Servers using OMi MP for SAP Sybase ASE. You can also analyze the status and health of SAP
Sybase ASE Configuration Items (CIs) through event, health, and performance perspectives.

Task 1: Adding Nodes to BSM 9.2x or OMi 10.x

Console

Note: If the SAP Sybase ASE Server that you want to monitor is already beingmonitored by
Smart Plug-in (SPI) for Sybase Databases, then remove the SPI artifacts and data sources from
themanaged node hosting the SAP Sybase ASE Server before proceeding.

Note: If the node already exists in Run-time ServiceModel (RTSM), you can skip this step and
proceed to Task 2.

Before you beginmonitoring, you need to add the nodes by following these steps:

1. Open theMonitored Nodes pane from Administration:

On BSM 9.2x, click Admin > Operations Management > Setup > Monitored Nodes.

OnOMi 10.x, click Administration > Setup and Maintenance > Monitored Nodes.

2. In theNode Views pane, click Predefined Node Filters > Monitored Nodes, and then click
, and then click Computer > <select required OS type>. The Create New Monitored Nodes
dialog box opens.

3. Specify the Primary DNS Name and verify the IP Address.

4. Specify the Operating System and Processor Architecture of the node from the drop-down list, and
then click OK.

The newly created node is saved as a CI instance in RTSM.

Note: Youmust activate the node with Operations Agent onOMi Server and certificate must be
granted.
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Task 2: Enabling the Enrichment Rule

Youmust enable the following enrichment rules to populate the SAP Sybase ASE CI’s display label
with additional information about container or the hostname:

l SoftwareElementDisplayLabelForNewHost

l SoftwareElementDisplayLabelForExistingHost

l SoftwareElementDisplayLabelPopulator

To enable the Enrichment Rule, follow these steps:

1. Open the Enrichment manager:

On BSM 9.2x, click Admin > RTSM Administration > Modeling > Enrichment manager.

OnOMi 10.x, click Administration > RTSM Administration > Modeling > Enrichment
manager.

2. In the Enrichment Rules pane, select SoftwareElementDisplayLabelForNewHost from the list.

3. Right-click and select Properties. The Enrichment Rule Properties window appears.

4. Click Next.

5. Select Rule is Active.

6. Click Finish.

7. In the Enrichment Rules pane, click to save the changes.

8. Select SoftwareElementDisplayLabelForExistingHost and repeat steps 3 to 7.

9. Select SoftwareElementDisplayLabelPopulator and repeat steps 3 to 7.

Task 3: Deploying the SAP Sybase ASE Discovery

Aspect

Note: If SAP Sybase ASE CIs are already discovered, you can skip this step and proceed to Task
4.
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The SAP Sybase ASE Discovery Aspect enables you to discover SAP Sybase ASE Server instances
in the environment. To discover both SAP Sybase ASE CIs and SAP Sybase Replication Server CIs
on the addedmanaged nodes, youmust deploy the SAP Sybase ASE Discovery Aspect to a Computer
CI.

The SAP Sybase ASE Discovery Aspect deployment discovers the Configuration Item (CIs) of the
following CI types (CITs):

l Sybase (Both SAP Sybase ASE Server and SAP Sybase Replication Server are identified with
sameCI)

l Computer

To deploy the SAP Sybase ASE Discovery Aspect, follow these steps:

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:

Configuration Folders > Database Management > SAP Sybase ASE > Aspects.

3. Follow one of the below methods to assign and deploy the Aspect. In theManagement Templates
& Aspects pane:

o Select theSAP Sybase ASE DiscoveryAspect, and then click .

o Right-click theSAP Sybase ASE DiscoveryAspect, and then click Assign and Deploy
Item.

The Assign and Deploy Wizard appears.
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4. In theConfiguration Item tab, select the requiredmanaged node CI and then click Next.

5. (Optional). In theRequired Parameters tab, click Next.

Note: SAP Sybase ASE Discovery Aspects do not havemandatory parameters. You will get
a notification stating the followingmessage: There are no parameters that require
editing for this Assignment.

6. (Optional). In theAll Parameters tab on BSM 9.2x orParameter Summary tab onOMi 10.x,
click Next.

Note: SAP Sybase ASE Discovery Aspect do not have any parameters. You will get a
notification stating the followingmessage: There is no parameter available for this
assignment.

7. (Optional). If you do not want to enable the assignment immediately, perform the following:

On BSM 9.2x, clear theEnable Assigned Objects check box.

OnOMi 10.x, clear theEnable Assignment(s) check box.

You can then enable the assignment later using the Assignments & Tuning pane.

8. Click Finish.

Note: After the SAP Sybase ASE Aspect is deployed, the followingmessage appears:
Assignment and deployment jobs created. To check the status of the deployment job, go to
the following location:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Deployment Jobs.

OnOMi 10.x, click Administration > Monitoring > Deployment Jobs.

Task 4: Verifying Discovery

After you deploy theSAP Sybase ASE Discovery Aspect, you can verify if the CIs are populated in the
View Explorer.

To view the CIs discovered, follow these steps:

1. Open the Event Perspective pane:

On BSM 9.2x, click Applications > Operations Manager > Event Perspective.
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OnOMi 10.x, clickWorkspace > Operations Console > Event Perspective.

2. In theBrowse View tab, select theSAPSybaseASE_DeploymentView.

Task 5: Configuring OMi MP for SAP Sybase ASE for

Operations Agent running with non-root user

In addition to the tasks mentioned above, the following tasks have to be performed for UNIX nodes that
haveOperations Agent running with non-root users.

After deploying the SAP Sybase ASE Discovery Aspect, youmust follow these steps:

1. Run the following script as a root user under /var/opt/OV/bin/instrumentation:

# dbspisyb_perl dbspisyb_root.pl

The /var/opt/OV/conf/dbspisyb.su is created.

2. Edit the dbspisyb.su file as a root user by uncommenting the lines or adding new lines in the
following format: <user>:<commands>

root:<SYBINSTPATH>/startserver -f <SYBINSTPATH>/RUN_<SVRNAME>

where <SYBINSTPATH> is the SAP Sybase ASE install path.

Task 6: Deploying the SAP Sybase ASE Management

Templates or Aspects

This section provides information about For more information about deployingManagement Template,
go to Task 6a: Identifying and Deploying the SAP Sybase ASE Management Template and for more
information about deploying Aspects, go to Task 6b: Deploying the SAP Sybase ASE Aspects.

Management Pack Data Collection Process

The frequency (polling interval) at which each policy must bemonitored is predefined with a default
value in a specific frequency parameter. Frequency parameter is an expert parameter that is defined for
each of themetrics regardless of whether they are for generating events or logging data.
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Following are the four predefined frequency parameters:

Scheduler Frequency Default value

Very High 5mins

High 15mins

Medium 1 hour

Low 24 hours

After Management Templates and Aspects are deployed, collector is triggered based on the parameter
value in a specific policy. You canmodify the default value of the parameter at following two levels:

l During deployment of theManagement Template or Aspects using theManagement Templates &
Aspects pane.

l After deployment using the Assignments & Tuning pane.

For more information about how tomodify the parameter values, see the section Editing Parameters.

Required User Privilege

Tomonitor SAP Sybase ASE Servers, provide a user with credentials and the following privileges:
system administrator (sa).

Task 6a: Identifying and Deploying the SAP Sybase ASE

Management Template

Before deploying the SAP Sybase ASE Management Templates, youmust identify the SAP Sybase
ASE Management Template suitable for your environment by following these recommendations:

l If you want to monitor the key performance and availability metrics on an SAP Sybase ASE server,
you can deploy the Essential SAP Sybase ASE Management Template.

l If you want to monitor the advance features such as network packets, parallel processing, and so
on along with key performance and availability, you can deploy the Extensive SAP Sybase ASE
Management Template.
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To deploy the SAP Sybase ASE Management Templates to the SAP Sybase ASE CIs, follow these
steps:

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:

Configuration Folders > Database Management > SAP Sybase ASE > Management
Templates

3. In the SAP Sybase ASE Management Templates folder, select theManagement Template that

you want to deploy, and then click Assign and Deploy Item. The Assign and Deploy wizard

opens.

4. In theConfiguration Item tab, select the CI to which you want to assign theManagement
Template, and then click Next.

5. In theRequired Parameters tab, to enter the required parameters detail follow these steps:

a. Select theSAP Sybase ASE Instance Username parameter in the list, and then click .

The SAP Sybase ASE Instance Username dialog box opens.

b. Click Value and type the Username. Click OK.

c. Select theSAP Sybase ASE Instance Password parameter, and then click . The SAP

Sybase ASE Instance Password dialog box opens.

d. Click Value and type a value in thePassword field.

e. In theVerify Password field and type the same password and then click OK.

f. Click Next.

6. (Optional). In theAll Parameters tab on BSM 9.2x orParameter Summary tab onOMi 10.x, you
can change the default values of the parameters. To change the default values of the parameters,
follow these steps:

a. Select SAP Sybase ASE Instance Name parameter and then click . The Edit Instance

Parameter window appears.

b. Select the parameter from the list and then click . The Edit Parameter dialog box opens.

Click Value, specify the value, and then click OK.
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Note: In theAll Parameters tab on BSM 9.2x orParameter Summary tab onOMi 10.x,
you can override the default values of any parameter. You can specify a value for each
parameter at theManagement Template level. By default, parameters defined as expert

parameters are not displayed. To display expert parameters, click Show Expert
Parameters.

Note: Similarly, you can edit theSAP Sybase ASE Error Log Frequency parameter.

c. Click Next.

7. (Optional). In theConfigure Options tab, if you do not want to enable the assignment
immediately, perform the following:

On BSM 9.2x, clear theEnable Assigned Objects check box.

OnOMi 10.x, clear theEnable Assignment(s) check box.

You can then enable the assignment later using the Assignments & Tuning pane.

8. Click Finish.

Task 6b: Deploying the SAP Sybase ASE Aspects

To deploy SAP Sybase ASE Aspects to the SAP Sybase ASE CIs, follow these steps:

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:

Configuration Folders > Database Management > SAP Sybase ASE > Aspects

3. In theManagement Templates & Aspects folder, select the Aspect that you want to deploy, and

then click Assign and Deploy Item.

Alternately, you can right-click the SAP Sybase ASE Aspect that you want to deploy, and then
click Assign and Deploy Item to open the Assign and Deploy Wizard.

4. In theConfiguration Item tab, select theSybaseCI to deploy the Aspect and then click Next.
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Note: If you want to deploy Aspects to Node CIs, select Also show CIs of type Node
check box.

5. In theRequired Parameters tab, youmust specify themandatory parameters by following these
steps:

a. Select theSAP Sybase ASE Instance Name parameter in the list, and then click . The

SAP Sybase ASE Instance Name dialog box opens.

b. Specify the value, and then click OK.

c. Select theSAP Sybase ASE Instance Username parameter in the list, and then click .

The SAP Sybase ASE Instance Username dialog box opens.

d. Specify the value, and then click OK.

e. Select theSAP Sybase ASE Instance Password parameter in the list, and then click .

The SAP Sybase ASE Password dialog box opens.

f. Click Value and type a value in thePassword field.

g. In theVerify Password field and type the same password and then click OK.

h. Click Next.

6. (Optional). In theAll Parameters tab on BSM 9.2x orParameter Summary tab onOMi 10.x, you
can change the default values of the parameters. Else click Next.

To change the default values of the parameters, follow these steps:

a. Select theSAP Sybase ASE Instance Name parameter and then click . The Edit

Instance Parameter window appears.

b. Select the parameter from the list and then click . The Edit Parameter dialog box opens.

Click Value, specify the value, and then click OK.

Note: In theAll Parameters tab on BSM 9.2x orParameter Summary tab onOMi 10.x,
you can override the default values of any parameter. You can specify a value for each
parameter at theManagement Template level. By default, parameters defined as expert

parameters are not displayed. To display expert parameters, click Show Expert
Parameters.

Note: Similarly, you can edit theSAP Sybase ASE Error Log Frequency parameter.

c. Click Next.
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7. (Optional). In theConfigure Options tab, if you do not want to enable the assignment
immediately, perform the following:

On BSM 9.2x, clear theEnable Assigned Objects check box.

OnOMi 10.x, clear theEnable Assignment(s) check box.

You can then enable the assignment later using the Assignments & Tuning pane.

8. Click Finish.

Task 7: Verifying OMi MP for SAP Sybase ASE

Deployment

To verify the deployment of OMi MP for SAP Sybase ASE on themanaged node, follow these steps:

1. Open the Browse View pane:

On BSM 9.2x, click Application > Operations Management > View Explorer > Browse View.

OnOMi 10.x, clickWorkspaces > Operations Console > Event Perspective > View Explorer
> Browse View.

2. In theBrowse View pane, right-click a node and then click Launch Tool. The Select Tool page
opens.

3. Select theVerify SAP Sybase ASE Management Pack Deployment tool and then click Run
Tool.

Task 8: Configuring SAP Sybase ASE Error Log

Monitoring for non-root Agent User

By default, the non-root agent user does not have permission to read error log file of SAP Sybase ASE
Server. Set read permission to enable the error log file monitoring by following these steps:

1. To identify the SAP Sybase ASE server alert log to bemonitored, run the following command:

/var/opt/OV/bin/instrumentation/dbspicas -l
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The error log file name appears.

2. To provide read permission to the non-root user for error logmonitoring, run the following command
as a Sybase user:

chmod +r <Sybase-error-logfile>

Monitoring SAP Sybase ASE Environment

After you deploy Management Template and Aspects, you can analyze the status and health of the
SAP Sybase ASE CIs from the following perspectives:

l Event Perspective

l Health Perspective

l Performance Perspective

Event Perspective

After you deploy the SAP Sybase ASE Discovery Aspect and SAP Sybase ASE Management
Template(s), you can view the events of the SAP Sybase ASE CIs that aremonitored by OMi MP for
SAP Sybase ASE.

To view the Event Perspective of the SAP Sybase ASE CIs, follow these steps:

1. Open the Event Perspective pane:

On BSM 9.2x, click Applications > Operations Management > Event Perspective.

OnOMi 10.x, clickWorkspaces > Operations Console > Event Perspective.

The View Explorer pane appears.

2. In the View Explorer, select Browse Views tab.

3. From the drop-downmenu, select theSAPSybaseASE_DeploymentView. Alternatively, you
can useSearch tab to find a SAP Sybase ASE Server CIs .

A list of SAP Sybase ASE Server CIs monitored by OMi MP for SAP Sybase ASE appears.

4. Select the SAP Sybase ASE CI for which you want to view the Event Perspective. A list of events
for the selected SAP Sybase ASE CI appears on the Event Browser pane.

When you select an event from the Event Browser, the Event Details pane opens where you can
view following details:
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o General - Displays the detailed information about the selected event such as Severity,
Lifecycle State, Priority, Related CIs and so on.

o Additional Info - Displays more detailed information about the attributes of the selected event.

o Source Info - Displays an overview of the information available about the source of the
selected event.

o Actions - Displays the list of actions available for a selected event. There are two types of
possible actions: User Action and Automatic Action.

o Annotations - Displays a list of the annotations attached to the selected event.

o Custom Attributes - Displays a list of the attributes that either an administrator or a
responsible user manually configured and added to the selected event.

o Related Events - Displays an overview of all the events that are related to the event selected
in the Event Browser.

o History - Displays the history of the selected event.

o Resolver Hints - Displays the information used to identify the node and CI associated with an
event.

o Instructions - Displays instruction information designed to help operators handle the
associated event.

o Forwarding - Displays the transfer of ownership details if any, for the events.

Health Perspective

After you deploy the SAP Sybase ASE Discovery Aspect and SAP Sybase ASE Management
Template(s), you can view the events related to the health of the SAP Sybase ASE CIs that are
monitored by OMi MP for SAP Sybase ASE.

To view the Health Perspective of the SAP Sybase ASE CIs, follow these steps:

1. Open the Health Perspective pane:

On BSM 9.2x, click Applications > Operations Management > Health Perspective.

OnOMi 10.x, clickWorkspaces > Operations Console > Health Perspective.

The View Explorer pane appears.

2. In the View Explorer, select Browse Views tab.

3. From the drop-downmenu, select SAPSybaseASE_DeploymentView. Alternatively, you can
useSearch tab to find a SAP Sybase ASE Server CIs.

A list of SAP Sybase ASE Server CIs monitored by OMi MP for SAP Sybase ASE appears.

User Guide
Chapter 2: Getting Started

HPE OMi Management Pack for SAP Sybase ASE (1.00) Page 18 of 100



4. Select the SAP Sybase ASE CI for which you want to view the Health Perspective. A list of health
related events for the selected SAP Sybase ASE CI appears on the Event Browser pane.

When you select an event from the Event Browser pane, the following panes appear:

o Health Top View - Displays the health top view of the selected event.

o Health Indicators - Displays the Key Performance Indicators (KPIs) and HIs related to the CI
that you select from the Health Top View pane.

o Actions - Displays the list of actions available for a selected event.

Performance Perspective

Performance Perspective enables you to populate graphs from existing graph templates. You can also
plot customized graphs by selecting the requiredmetrics for a selected CI.

To view the Performance Perspective of SAP Sybase ASE CIs using graphs, follow these steps:

1. Open the Performance Perspective pane:

On BSM 9.2x, click Applications > Operations Management > Performance Perspective.

OnOMi 10.x, clickWorkspaces > Operations Console > Performance Perspective.

The View Explorer pane appears.

2. In theBrowse Views tab, select SAPSybaseASE_DeploymentView. Alternatively, you can
useSearch tab to find a SAP Sybase ASE Server CIs.

The performance pane appears, which lists the default graphs available for theSAPSybaseASE_
DeploymentView.

3. Click the graph you want to plot from theGraphs tab, and then click Draw Graphs. The
selected graph is plotted on the right pane.

Note: Formore information about managing events, health, and performance perspectives, see
theOperations Manager i Concepts Guide.
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Chapter 3: Components
TheOMi MP for SAP Sybase ASE includes the following components for monitoring SAP Sybase ASE
Servers in your environment:

l SAP Sybase ASE Management Templates

l SAP Sybase ASE Aspects

l Parameters

l Configuration Items (CIs) and Configuration Item Types (CITs)

l Real-time ServiceModel (RTSM) Views

l Health Indicators (HIs)

l Event Type Indicators (ETIs)

l Tools

l Graph Templates

SAP Sybase ASE Management Templates

TheManagement Templates consists of several Aspects which enables you tomonitor SAP Sybase
ASE Servers based on the criticality and type of the environment. By default, the OMi MP for SAP
Sybase ASE consists of out-of- the-box SAP Sybase ASE Management Templates. You can deploy
the out-of-the- box Management Template with the default parameters or you can customize the
Management Templates based on your requirements. In addition, you can also createManagement
Templates based on themonitoring requirements using the SAP Sybase ASE Aspects.

Overview

TheOMi MP for SAP Sybase ASE comprises the followingManagement Templates:

l Essential SAP Sybase ASE Management Template

l Extensive SAP Sybase ASE Management Template
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How to Access SAP Sybase ASE Management Template

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folder pane, click Configuration Folders > Database Management > SAP
Sybase ASE > Management Templates.

Tasks

How to Deploy SAP Sybase ASE Management Templates to the CIs

Formore information about deploying SAP Sybase ASE Management Templates, see Task 6:
Deploying the SAP Sybase ASE Management Templates or Aspects.

How to Automatically Assign SAP Sybase ASE Management Templates or SAP Sybase ASE
Aspects to the CIs

To automatically assign SAP Sybase ASE Management Templates or SAP Sybase ASE Aspects, you
must specify the required privileges. To automatically assign, follow these steps:

1. Open the Automatic Assignment Rules pane:

On BSM 9.2x, click Admin > Operations Manager > Monitoring > Automatic Assignment
Rules.

OnOMi 10.x, click Administration > Monitoring > Automatic Assignment Rules.

Automatic Assignment Rules consists of the Auto-Assignment Rules pane at the top, and a
Parameter pane at the bottom

2. In the Auto-Assignment Rules pane, click and select the appropriate option. The Create Auto-

Assignment Rules wizard opens.

3. In theSelect Target View tab, select the view for which you want to create automatic assignment
rules, and click Next.

4. In theSelect Item to Assign tab, click theManagement Template or Aspect that you want to
automatically assign to all the CIs, and then click Next.

5. In theRequired Parameters tab, youmust specify themandatory parameters by following these
steps:
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a. Select theSAP Sybase ASE Instance Name parameter in the list, and then click . The

SAP Sybase ASE Instance Name dialog box opens.

b. Specify the value, and then click OK.

c. Select theSAP Sybase ASE Instance Username parameter in the list, and then click .

The SAP Sybase ASE Instance Username dialog box opens.

d. Specify the value, and then click OK.

e. Select theSAP Sybase ASE Instance Password parameter in the list, and then click .

The SAP Sybase ASE Password dialog box opens.

f. Click Value and type a value in thePassword field.

g. In theVerify Password field and type the same password and then click OK.

h. Click Next.

6. In theAll Parameters tab on BSM 9.2x andParameter Summary tab onOMi 10.x , you can
change the default values of the parameters. To change the default values of the parameters,
follow these steps:

a. Select theSAP Sybase ASE Instance Name parameter and then click . The Edit

Instance Parameter dialog box appears.

i. Select the parameter from the list and then click . The Edit Parameter dialog box

opens. Click Value, specify the value, and then click OK.

Note: In theAll Parameters tab on BSM 9.2x andParameter Summary tab on
OMi 10.x, you can override the default values of any parameter. You can specify a
value for each parameter at theManagement Template level. By default,
parameters defined as expert parameters are not displayed. To display expert

parameters, click Show Expert Parameters.

b. Click Next.

7. (Optional). In theConfigure Options tab, if you do not want to enable the assignment
immediately, clear theActivate Auto-Assignment Rule check box. You can then enable the
assignment later using the Assignments & Tuning pane.

8. Click Finish.

The assignment rule is added to the list of auto-assignment rules.

An assignment may trigger an event to be sent to OMi if one of the following situations applies:
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l A deployment job fails.

l An auto-assignment fails.

l An auto-assignment succeeds. This behavior can be configured in the Infrastructure Settings.

How to Verify the Creation of Auto-assignment Rules

You can check if the automatic assignment rule successfully created the expected assignments as by
following these steps:

1. Open the Assignments & Tuning pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Assignments &
Tuning.

OnOMi 10.x, click Administration > Monitoring > Assignments & Tuning.

2. In theBrowse Views tab, select the view you identified while creating your automatic assignment
rule.

3. Expand the view, and select a node that corresponds to the root CI type of the assigned item.
Assignments created as a result of Automatic Assignment Rules are shown in the list of
assignments at the top of the right pane, and have the value Auto-Assignment in the column
Assigned By.

You can consider the following options for tuning the assignment:

l Use the Auto-Assignment Rules pane to tune the parameter values for all assignments triggered by
the automatic assignment rule.

l Use the Assignments & Tuning pane to tune, redeploy, delete, and enable or disable individual
assignments.

How to Display an Inventory Report for SAP Sybase ASE Management Template

The Inventory Report displays theManagement Templates, Aspects, and Policy Templates that are
available on a server. To display an Inventory Report for SAP Sybase ASE Management Template,
follow these steps:

1. Select theManagement Template for which you want to create a report.

2. Click Generate Assignment Report in theManagement Templates & Aspects pane.

The pre-configured Assignment Report appears.

You can display additional types of reports from the Assignments & Tuning pane.
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Note: The list shows only theManagement Templates that have a root CIT that appears in the
View that you selected or, if an Aspect is auto-assigned, only the compatible Aspects appear.

The latest version of theManagement Template or Aspect that you want to assign is selected by
default. If required, select a different version in column Version.

Essential SAP Sybase ASE Management Template

The Essential SAP Sybase ASE Management Template can be used tomonitor the basic features of
SAP Sybase ASE servers in an environment. The Essential SAP Sybase ASE Management Template
contains themost essential features for monitoring the availability and performance of SAP Sybase
ASE environment.

You have an SAP Sybase ASE server in your environment, and want to check the availability of the
SAP Sybase ASE servers andmonitor the basic functionality of SAP Sybase ASE features such as
availability, disk utilization, memory, performance along with Infrastructure areas of CPU, memory and
disk. In such a scenario, you can deploy Essential SAP Sybase ASE on all the SAP Sybase ASE
Server CIs. The Essential SAP Sybase ASE Management Template consists of specific Aspects to
monitor these features.

How to Access Essential SAP Sybase ASE Management Template

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folder pane, click Configuration Folders > Database Management > SAP
Sybase ASE > Management Templates.

3. In theManagement Templates & Aspects pane, click Essential SAP Sybase ASE Management
Template.
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User Interface Reference

Management Template - General

UI
Element Description

Name Essential SAP Sybase ASE Management Template.

Description Manages monitoring of the primary features of SAP Sybase ASE Server such as
availability, disk health, memory, object, cache performance and so on. In addition,
critical infrastructure areas such as resource bottleneck diagnosis and system fault are
alsomonitored.

ID A unique identifier for this version of the Essential SAP Sybase ASE Management
Template.

Version The current version of theManagement Template. In this instance, the version of the
Management Template is 1.0.

Change
Log

Text that describes what is new ormodified in this version of theManagement
Template.

Management Template - Topology View

UI
Element Description

Topology
View

SAPSybaseASE_Deployment is the Topology View for Essential SAP Sybase ASE
Management Template.

CI Type The type of configuration items that the Essential SAP Sybase ASE Management
Template enables you tomanage. This is the type of CI to which theManagement
Template can be assigned.

Essential Management Template - Aspects

The Essential SAP Sybase ASE Management Template contains the following Aspects:

l SAP Sybase ASE Aspects

o SAP Sybase ASE Application Performance

o SAP Sybase ASE Availability

o SAP Sybase ASE Base
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o SAP Sybase ASE Cache Performance

o SAP Sybase ASE CPU Utilization

o SAP Sybase ASE Database Space Utilization

o SAP Sybase ASE Discovery

o SAP Sybase ASE Disk Health

o SAP Sybase ASE Index Performance

o SAP Sybase ASE Lock Performance

o SAP Sybase ASE Memory Performance

o SAP Sybase ASE Objects Performance

o SAP Sybase ASE Process Activity

l Infrastructure Aspects

Resource Bottleneck Diagnosis

The Resource Bottleneck Diagnosis Aspect identifies congestions and bottleneck conditions for
system resources like the CPU, memory, network, and disk. CPU bottleneck monitoring is based
on global CPU utilization and load average (RunQueue Length) Memory bottleneck monitoring is
based onmemory utilization, freememory available, andmemory swap out rate. Filesystem
monitoring is based on space utilization level for busiest filesystem on the node. Network
monitoring is based on Packet collision rate, packet error rate, and outbound queue length.

System Fault Analysis

The System Fault Analysis Aspect monitors the kernel log file, boot log file, and event log file for
critical error conditions and instructions.

System Infrastructure Discovery

The System Infrastructure Discovery Aspect discovers and gathers information regarding the
system resources, operating system, and applications on amanaged node.

Extensive SAP Sybase ASE Management Template

The Extensive SAP Sybase ASE Management Template can be used for monitoring single instance
databases and high availability environments. This Management Template comprises complete set of
SAP Sybase ASE Aspects and Infrastructure Aspects to monitor the availability, status, and health of
the SAP Sybase ASE Server environments.
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Youwant to check the availability and performance of all the servers andmonitor the SAP Sybase ASE
advanced features - device performance, application performance, parallel processing and alsomonitor
the basic functionality of the SAP Sybase ASE features - query, memory, objects, transactions,
sessions, and locks. The advancedManagement Template comprises of specific Aspects for
monitoring these features.

How to Access Extensive SAP Sybase ASE Management Template

1. OpenManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folder pane, click Configuration Folders > Database Management > SAP
Sybase ASE > Management Templates.

3. In theManagement Templates & Aspects pane, click Extensive SAP Sybase ASE
Management Template.

User Interface Reference

Management Template - General

UI
Element Description

Name Extensive SAP Sybase ASE Management Template.

Description Manages monitoring of the primary and advanced features of SAP Sybase ASE such
as availability, CPU utilization, parallel processing, network packets and so on. In
addition, SAP Sybase ASE Servers performance areas such as device performance,
query performance and infrastructure areas such as CPU, memory, network, and disk
are alsomonitored.

Version ID A unique identifier for this version of the Extensive SAP Sybase ASE Management
Template.

Version The current version of theManagement Template. In this instance, the version of the
Management Template is 1.0.

Change
Log

Text that describes what is new ormodified in this version of theManagement
Template.
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Management Template - Topology View

UI
Element Description

Topology
View

SAPSybaseASE_Deployment is the Topology View for Extensive SAP Sybase ASE
Management Template.

CI Type The type of configuration items that the Extensive SAP Sybase ASE Management
Template enables you tomanage. This is the type of CI to which theManagement
Template can be assigned.

Extensive Management Template - Aspects

The Extensive SAP Sybase ASE Management Template contains the following Aspects:

l SAP Sybase ASE Aspects

o SAP Sybase ASE Application Performance

o SAP Sybase ASE Availability

o SAP Sybase ASE Base

o SAP Sybase ASE Cache Performance

o SAP Sybase ASE CPU Utilization

o SAP Sybase ASE Database Space Utilization

o SAP Sybase ASE Device Performance

o SAP Sybase ASE Discovery

o SAP Sybase ASE Disk Health

o SAP Sybase ASE Index Performance

o SAP Sybase ASE Lock Performance

o SAP Sybase ASE Memory Performance

o SAP Sybase ASE Network Packets

o SAP Sybase ASE Objects Performance

o SAP Sybase ASE Parallel Processing

o SAP Sybase ASE Process Activity

o SAP Sybase ASE Query Performance

l Infrastructure Aspects
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Memory and Swap Utilization

TheMemory and SwapUtilization Aspect monitors memory performance of the system. Memory
performancemonitoring is based onMemory utilization (in percentage), Swap space utilization (in
percentage), Freememory available (in MBs) and Free swap space available (in MBs).

CPU Performance

The CPU Performance Aspect monitors the overall CPU performance like the CPU utilization
percentage and spike in CPU usage. Individual CPU performancemonitoring is based on total CPU
utilization, CPU utilization in user mode, CPU utilization in systemmode and interrupt rate.

Space Availability and Disk IOPS

The Space Availability and Disk IOPS Aspect monitors the disk IO operations and space utilization
of the system.

Remote Disk Space Utilization

The Remote Disk Space Utilization Aspect monitors space utilization of remote disk.

Bandwidth Utilization and Network IOPS

The Bandwidth Utilization and Network IOPS Aspect monitors IO operations, and performance of
the systems in the network. It monitors the network IO operations and performance based on the
bandwidth used, outbound queue length and average bytes transferred per second.

System Infrastructure Discovery

The System Infrastructure Discovery Aspect discovers and gathers information regarding the
system resources, operating system, and applications on amanaged node.

SAP Sybase ASE Aspects

SAP Sybase ASE Aspects can be used tomonitor the building blocks or units of SAP Sybase ASE. A
SAP Sybase ASE Aspect comprises policy templates, instrumentation, and parameters for monitoring
the health and performance of SAP Sybase ASE.

How to Access SAP Sybase ASE Aspects

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.
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2. In the Configuration Folder pane, click Configuration Folders > Database Management > SAP
Sybase ASE > Aspects.

Tasks

How to Deploy SAP Sybase ASE Aspects

Formore information about deploying SAP Sybase ASE Aspects, see Task 6: Deploying the SAP
Sybase ASE Management Templates or Aspects.

How to Create SAP Sybase ASE Aspects

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects > Configuration Folders.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects >
Configuration Folders.

2. In the Configuration Folders pane, select the configuration folder in which you want to create the

new aspect. If you need to create a new configuration folder, click .

3. In the Configuration Folders pane, click Database Management > SAP Sybase ASE> Aspects.

4. In theManagement Templates & Aspects pane, click , and then click Create Aspect. The
Create Aspect wizard opens.

5. In theGeneral tab, type a uniqueName for the new aspect and then click Next.

6. In theCI type tab, follow these steps:

a. Each aspect enables you tomanage one feature or characteristic of one or more types of
configuration item. In theCI Types tab, select one or moreAvailable CI Type(s) to which

this Aspect can be assigned, and then click to add them to the list of assigned CI types.

(Press CTRL to select several CI types.)

b. If you need the aspect to be assignable to a node independent of its CI type, select Node
Compatible check box.

c. Click Next.
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7. In the Instrumentation tab, click to add instrumentation to the aspect. The Add

Instrumentation dialog box opens, that enables you to select the instrumentation that you want to
add. Select the instrumentation you want to add and then click OK. Click Next.

8. (Optional). In theAspects tab, click , and then click Add Existing Aspect. The Add

Existing Aspect dialog box opens, which enables you to select an existing aspect that you want to
nest within this aspect. Select an aspect, and then click OK. Click Next.

9. In thePolicy Templates tab, click Add Policy Templates on BSM 9.2x andAdd Policy
Templates From List onOMi 10.x. The Add New Policy Template to Aspect dialog box opens.
Select the policy templates that you want to add, and then click OK. Press CTRL orSHIFT to
select several policy templates.

10. If suitable Policy Templates do not exist, follow these steps to add a new Policy Template:

a. Click , and then click Add New Policy Template to create them from here. The Select

New Policy Template dialog box opens.

b. Select theMeasurement Threshold policy template from the Type drop-down list and click
OK. The Policy Related Information dialog box opens.

c. In the Policy Related Information dialog box, specify a unique policy Name and click OK. A
new Policy Template is added.

11. (Optional). In thePolicy Templates tab, select the Policy Template to which you want to add a

deployment condition, and then click Edit Deployment Condition. The Edit Deployment
Condition dialog box opens, that enables you to specify deployment conditions for the selected
policy template. Set the condition and then click OK.

12. In thePolicy Templates tab, click Next.

13. (Optional). In theParameters tab, you see a list of all the parameters from the policy templates
that you added to this Aspect.

To combine parameters:

a. Press CTRL and select parameters that you want to combine.

b. Click . The Edit/Combine Parameters dialog box opens.

c. Type a Name for the combined parameters.

d. Specify a Description, Default Value, and whether the combined parameter is ReadOnly, an
Expert Setting, or Hidden.
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Note: ReadOnly prevents changes to the parameter value when the aspect is assigned
to a configuration item. Hidden also prevents changes, but additionally makes the
parameter invisible. Users can choose whether to show expert settings when they make
an assignment.

e. You can set either a specific default value, or you can click From CI Attribute and then
browse for a CI attribute. When you specify a CI attribute, Operations Management sets the
parameter value automatically during deployment of the policy templates, using the actual
value of this attribute from the CI. You can also set conditional parameter values.

f. Click OK.

Note: You can also edit the parameters without combining them, to override the defaults in

the policy template. Click one parameter, and then click . The Edit/Combine Parameters

dialog box opens.

14. In the Create Aspect wizard, click Finish to save the aspect and close the wizard. The new
Aspect appears in theManagement Templates & Aspects pane.

Aspects

SAP Sybase ASE Aspects comprises policy templates, instrumentation, and parameters for
monitoring the health and performance of SAP Sybase ASE Servers. Each SAP Sybase ASE Aspect
can be used tomonitor individual units of SAP Sybase ASE server.

User Interface Reference

General Provides an overview of the general attributes of the SAP Sybase ASE Aspects.

CI Type The type of CIs that the Aspect can be assigned to. Sybase is the type of CI to
which the Aspects can be assigned.

Instrumentation Provides a single package which contains the binaries for discovery, collection,
and data logging.

Aspects Provides an overview of any Aspects that the SAP Sybase ASE Aspect contains.
You can expand each item in the list to seemore details about the nested aspect.
The SAP Sybase ASE Base Aspect is part of all the other Aspects.

Policy Provides an overview of the policy templates that the SAP Sybase ASE Aspect
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Templates contains. You can expand each item in the list to seemore details about the policy
template.

TheOMi MP for SAP Sybase ASE comprises the following SAP Sybase ASE Aspects:

SAP Sybase ASE Application Performance

This Aspect monitors the use of priority switches, blocked processes, about system resources used by
particular application and login tasks, or by all users of each application.

CI
Type Policy Template Indicator Description Policy Type

Sybas
e

SAPSybaseAS
E_2046

SAPSybaseASE_
HighPrioritySwitchesPct:High,
SAPSybaseASE_
HighPrioritySwitchesPct:Normal

This policy
monitors the
percentage
threshold of high
priority switches
used (S046_
HigPrioChngsPct)

Measuremen
t Threshold

Sybas
e

SAPSybaseAS
E_2047

SAPSybaseASE_
MediumPrioritySwitchesPct:High,
SAPSybaseASE_
MediumPrioritySwitchesPct:Norm
al

This policy
monitors the
percentage
threshold of
medium priority
switches (S047_
MedPrioChngsPc
t)

Measuremen
t Threshold

Sybas
e

SAPSybaseAS
E_2048

SAPSybaseASE_
LowPrioritySwitchesPct:High,
SAPSybaseASE_
LowPrioritySwitchesPct:Normal

This policy
monitors the
percentage
threshold of low
priority switches
(S048_
LowPrioChngsPc
t)

Measuremen
t Threshold

Sybas
e

SAPSybaseAS
E_2050

SAPSybaseASE_
CpuPctForAppOrLogin:High,
SAPSybaseASE_
CpuPctForAppOrLogin:Normal

This policy
monitors the
percentage
threshold of CPU
utilized by one or
more

Measuremen
t Threshold
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CI
Type Policy Template Indicator Description Policy Type

application/login
as percent of total
CPU (S050_
CPUAppLognPct)

Sybas
e

SAPSybaseAS
E_2051

SAPSybaseASE_
IOPctForAppOrLogin:High,
SAPSybaseASE_
IOPctForAppOrLogin:Normal

This policy
monitors the
percentage
threshold of I/O
application/login
for one or more
application/login
as percent of total
I/O (S051_
IOAppLognPct)

Measuremen
t Threshold

Sybas
e

SAPSybaseAS
E_2250

NA This policy
monitors the
percentage of
CPU utilized by a
specific
application/login
as percentage of
total - drill down
(S250_
CPUAppLognPct)

Measuremen
t Threshold

Sybas
e

SAPSybaseAS
E_2251

NA This policy
monitors the
percentage of I/O
for a specific
application/login
as percentage of
total - drill down
(S251_
IOAppLognPct)

Measuremen
t Threshold

SAP Sybase ASE Availability

This Aspect monitors SAP Sybase ASE connection status, processes, and so on.
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CI
Type Policy Template Indicator Description Policy Type

Sybas
e

SAPSybaseAS
E_2002

SAPSybaseASE_
DBServerConn:Down,
SAPSybaseASE_
DBServerConn:Up

This policy monitors the
availability of Sybase
database server (S002_
DatabaseServerMonito
r)

Measuremen
t Threshold

Sybas
e

SAPSybaseAS
E_2007

SAPSybaseASE_
UsrConnPct:High,
SAPSybaseASE_
UsrConnPct:Normal

This policy checks for
the percentage of
maximum users
connected to process
the database query
(S007_
ConnectUsersPct)

Measuremen
t Threshold

Sybas
e

SAPSybaseAS
E_2011

SAPSybaseASE_
DataSrvProcStatus:Down,
SAPSybaseASE_
DataSrvProcStatus:Up

This policy monitors the
Database process
(S011_ProcessStatus).
Checks whether the
critical processes are
running on a server.
This metric reports the
name of any missing
critical process.

Measuremen
t Threshold

Sybas
e

SAPSybaseAS
E_2012

SAPSybaseASE_
EnginesOfflineCnt:Down,
SAPSybaseASE_
EnginesOfflineCnt:Up

This policy check for
number of Engines
Offline (S012_
EnginesOffCnt)*

Measuremen
t Threshold

Sybas
e

SAPSybaseAS
E_2020

NA Monitors the Sybase
Backup Server
Connectivity (S020_
BackupServerStatus)

Measuremen
t Threshold

Sybas
e

SAPSybaseAS
E_2061

SAPSybaseASE_
ConnPerUserCnt:High,
SAPSybaseASE_
ConnPerUserCnt:Normal

This policy monitors the
average number of
connections per user
per login ID (S061_
ConectPerUsrCnt)

Measuremen
t Threshold

Sybas
e

SAPSybaseAS
E_2206

SAPSybaseASE_
DatabaseConn:Down,
SAPSybaseASE_
DatabaseConn:Up,
SAPSybaseASE_
DatabaseConn:DownStatu
s,

This policy checks the
database status and
connection (S206_
DatabaseStatus)

Measuremen
t Threshold
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CI
Type Policy Template Indicator Description Policy Type

Sybas
e

SAPSybaseAS
E_2225

NA SAP Sybase ASE
Availability: Generate
reports for the server
uptime information.

ConfigFile

Sybas
e

SAPSybaseAS
E_2306

NA This policy checks for
database status (S306_
DBUseCheck)

Measuremen
t Threshold

*Check maximum online engines configuration value. If necessary, use dbcc engine command to
bring an engine online.

SAP Sybase ASE Base

This Aspect is the Base Aspect for monitoring SAP Sybase ASE. It contains configuration, error log,
schedulers, and logger policies.

CI
Type Policy Template Indicator Description

Policy
Type

Sybase SAPSybaseASE_
Configuration

NA The Configuration policy is used to update
User configuration for establishing
connection with the SAP Sybase ASE
Server.

ConfigFile

Sybase SAPSybaseASE_
ErrorLog

NA This policy monitors the SAP Sybase ASE
entries into the error log file.

LogFile
Entry

Sybase SAPSybaseASE_
VeryHigh

NA By default, runs the SAPSybaseASE MP
collector/analyzer every 5minutes. The
schedule can bemodified as required in the
environment.

Scheduled
Task

Sybase SAPSybaseASE_
High

NA By default, runs the SAPSybaseASE MP
collector/analyzer every 15minutes.The
schedule can bemodified as required in the
environment.

Scheduled
Task

Sybase SAPSybaseASE_
Medium

NA By default, runs the SAPSybaseASE MP
collector/analyze every 1 hour.The schedule
can bemodified as required in the
environment.

Scheduled
Task
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CI
Type Policy Template Indicator Description

Policy
Type

Sybase SAPSybaseASE_
Low

NA By default, runs the SAPSybaseASE MP
collector/analyzer once in a day. The
schedule can bemodified as required in the
environment.

Scheduled
Task

Sybase SAPSybaseASE_
Logger

NA By default, runs SAP Sybase ASE Server
Logger Data Feed every 5minutes.

Scheduled
Task

Sybase SAPSybaseASE_
Messages

NA This policy intercept themessages
submitted by the OMi MP for SAP Sybase
ASE programs.

Open
Message
Interface

SAP Sybase ASE Cache Performance

This Aspect monitors the performance of data caches, procedure caches, resources, and so on.

CI
Type Policy Template Indicator Description Policy Type

Sybase SAPSybaseASE_
2031

SAPSybaseASE_
DataCachePct:Low,
SAPSybaseASE_
DataCachePct:Normal

This policy monitors
the percentage of
data cache as the
percent of total
memory (S031_
DataCachePct)

Measurement
Threshold

Sybase SAPSybaseASE_
2032

SAPSybaseASE_
ProcedureCachePct:High,
SAPSybaseASE_
ProcedureCachePct:Normal

This policy monitors
the percentage of
procedure cache
(being read) from the
disk (S032_
ProcdreCachePct)

Measurement
Threshold

Sybase SAPSybaseASE_
2033

SAPSybaseASE_
DataCacheMissPct:High,
SAPSybaseASE_
DataCacheMissPct:Normal

This policy monitors
the percentage of
data cachemisses
(S033_
DataCachMissPct)

Measurement
Threshold

Sybase SAPSybaseASE_
2035

SAPSybaseASE_
CacheUtilizationPct:High,
SAPSybaseASE_
CacheUtilizationPct:Normal

This policy monitors
the percentage of
cache utilization for

Measurement
Threshold
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CI
Type Policy Template Indicator Description Policy Type

one or more data
caches (S035_
CacheUtilztnPct)

Sybase SAPSybaseASE_
2036

SAPSybaseASE_
LargeIODeniedPct:High,
SAPSybaseASE_
LargeIODeniedPct:Normal

This policy monitors
the percentage of
large I/O denied for
the entire server
(S036_
LrgeIODeniedPct)

Measurement
Threshold

Sybase SAPSybaseASE_
2235

NA This policy monitors
the percentage of
cache utilization for
one specific data
cache (S235_
CacheUtilztnPct)

Measurement
Threshold

Sybase SAPSybaseASE_
2236

NA This policy monitors
the percentage of
large I/O denied for
the cache (S236_
LrgeIODeniedPct)

Measurement
Threshold

SAP Sybase ASE CPU Utilization

This Aspect monitors how busy Adaptive Server engines were during the time the CPU was available
to Adaptive Server, how often the CPU yielded to the operating system, and so on.

CI
Type Policy Template Indicator Description Policy Type

Sybase SAPSybaseASE_
2001

SAPSybaseASE_
SrvEngineCPUUtilPct:Critical,
SAPSybaseASE_
SrvEngineCPUUtilPct:Normal,
SAPSybaseASE_
SrvEngineCPUUtilPct:Warning,
SAPSybaseASE_
SrvEngineCPUUtilPct:Normal

This policy
monitors the
percentage of
time, Adaptive
Server Engines
uses the allotted
CPU time interval
(S001_
UtilByCPUPct)

Measurement
Threshold

User Guide
Chapter 3: Components

HPE OMi Management Pack for SAP Sybase ASE (1.00) Page 38 of 100



CI
Type Policy Template Indicator Description Policy Type

Sybase SAPSybaseASE_
2003

SAPSybaseASE_
TaskContextSwitchPct:High,
SAPSybaseASE_
TaskContextSwitchPct:Normal

This policy
monitors the
percentage of task
context switching
(S003_
ContextSwitch)

Measurement
Threshold

Sybase SAPSybaseASE_
2203

NA This policy
monitors the
percentage of task
context switch for
specific type
(S203_
ContextSwitch)

Measurement
Threshold

SAP Sybase ASE Database Space Utilization

This Aspect monitors the Database Space Utilization such as segments space, database size and so
on.

CI
Type Policy Template Indicator Description Policy Type

Sybase SAPSybaseAS
E_2004

SAPSybaseASE_
TransLogFreeSpacePct:Low,
SAPSybaseASE_
TransLogFreeSpacePct:Norma
l

This policy
monitors the
percentage of
space free in
transaction log for
one or more
databases (S004_
TransLogFullPct) *

Measuremen
t Threshold

Sybase SAPSybaseAS
E_2005

SAPSybaseASE_
DBSegmentFreeSpace:Low,
SAPSybaseASE_
DBSegmentFreeSpace:Normal

This policy
monitors the
percentage of
space free in one or
more database
segments (S005_
SegmentSpacePc
t)

Measuremen
t Threshold
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CI
Type Policy Template Indicator Description Policy Type

Sybase SAPSybaseAS
E_2204

NA This policy
monitors the
percentage of
space free in
transaction log for a
specific database
(S204_
TransLogFullPct)

Measuremen
t Threshold

Sybase SAPSybaseAS
E_2205

NA This policy
monitors the
percentage of
space remaining on
a specific database
segments (S205_
SegmentSpacePc
t)

Measuremen
t Threshold

Sybase SAPSybaseAS
E_2222

NA This policy
generates reports
for allocated and
free database size
in MB .

ConfigFile

Sybase SAPSybaseAS
E_2223

NA This policy
monitors the
allocated and free
table size in MB .

ConfigFile

* You need to periodically dump (truncate) the transaction log. If you do not truncate, the log will grow
unchecked until it fills up. You can either turn on the database option: sp_dboption database, 'trunc
log on chkpt' true, which is NOT recommended on a productionmachine, or you can dump the
transaction log, which cleans all completed transaction. You should automate cleaning the transaction
log on a periodic basis, before the threshold is reached. If you are cleaning the transaction log, but size
remains, you have a long-running transaction which is not complete, or youmay have an aborted
transaction in the database which has not beenmarked as complete in the log. As a last solution, you
can shut down and restart the server. This will mark the incomplete transaction as complete (and rolled
back). The automatic action for this metric generates a report showing database name and log
percentage for each database.
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SAP Sybase ASE Device Performance

This Aspect monitors the activities related to devices such as Mirror status and Virtual Devices space.

CI
Type Policy Template Indicator Description Policy Type

Sybas
e

SAPSybaseAS
E_2016

SAPSybaseASE_
VirtualDeviceSpaceUsed:Low,
SAPSybaseASE_
VirtualDeviceSpaceUsed:Norma
l

This policy
monitors the
percentage of
space used on
one or more virtual
device (S016_
SpacedUsedPct)

Measuremen
t Threshold

Sybas
e

SAPSybaseAS
E_2017

SAPSybaseASE_
MirrorDevicesNotActive:Down,
SAPSybaseASE_
MirrorDevicesNotActive:Up

This policy
monitors the
number of Mirror
Devices that are
not active (S017_
MirrDevNoActCn
t)

Measuremen
t Threshold

Sybas
e

SAPSybaseAS
E_2216

NA This policy
monitors the
percentage of
memory space
used on a specific
virtual device
(S216_
SpacedUsedPct)

Measuremen
t Threshold

Sybas
e

SAPSybaseAS
E_2224

NA SAP Sybase ASE
Virtual Device
Size: This policy
generates a report
for the virtual
device size that
are allocated in
MB.

ConfigFile
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SAP Sybase ASE Discovery

This Aspect discovers the SAP Sybase ASE Server and SAP Sybase Replication Server deployment
topologies and populates the corresponding CIs in the RTSM database.

CI Type Policy Template Indicator Description
Policy
Type

Computer SAPSybaseASE_
Discovery

NA SAP Sybase ASE Discovery policy. Service
Auto-
Discovery

Sybase SAPSybaseASE_
Messages

NA This policy intercept themessages
submitted by the OMi MP for SAP Sybase
ASE programs.

Open
Message
Interface

SAP Sybase ASE Disk Health

This Aspect monitors the disk IO activity for the server as a whole and reports on reads, and so on.

CI Type Policy Template Indicator Description Policy Type

Sybase SAPSybaseASE_
2013

SAPSybaseASE_
DiskIOPct:High,
SAPSybaseASE_
DiskIOPct:Normal

This policy
monitors the
percentage of total
I/O performed on
one or more disks
(S013_DiskIOPct)

Measurement
Threshold

Sybase SAPSybaseASE_
2075

SAPSybaseASE_
CompletDiskIOPct:Low,
SAPSybaseASE_
CompletDiskIOPct:Normal

This policy
monitors the
percentage of disk
I/O that are
completed (S075_
ComplteDskIOPct)

Measurement
Threshold

Sybase SAPSybaseASE_
2077

SAPSybaseASE_
PhysicalReadsRate:High,
SAPSybaseASE_
PhysicalReadsRate:Normal

This policy
monitors the
number of physical
reads per second
(S077_
PhysReadsRate)

Measurement
Threshold
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CI Type Policy Template Indicator Description Policy Type

Sybase SAPSybaseASE_
2078

SAPSybaseASE_
LogicalReadsRate:High,
SAPSybaseASE_
LogicalReadsRate:Normal

This policy
monitors the
number of logical
reads per sec
(S078_
LogicReadsRate)

Measurement
Threshold

Sybase SAPSybaseASE_
2213

NA This policy
monitors the
percentage of total
I/O performed by
specific disks - drill
down (S213_
DiskIOPct)

Measurement
Threshold

Sybase SAPSybaseASE_
2226

NA SAP Sybase ASE
Workload: This
policy is used to
configure the
number of physical
reads and writes to
the disk since the
last collection for
each tablespace.

ConfigFile

SAP Sybase ASE Index Performance

This Aspect monitors the index management activity, including non-clusteredmaintenance.

CI
Type

Policy
Template Indicator Description

Policy
Type

Syba
se

SAPSybaseA
SE_2015

SAPSybaseASE_OpenIndexesPct:Low,
SAPSybaseASE_
OpenIndexesPct:Normal

This policy
monitors the
percentage of
Open Indexes *
(S015_
OpenIndexPct)

Measurem
ent
Threshold

Syba
se

SAPSybaseA
SE_2070

SAPSybaseASE_HeapInsertsPct:High,
SAPSybaseASE_
HeapInsertsPct:Normal

This policy
monitors the
percentage of
heap inserts,

Measurem
ent
Threshold
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CI
Type

Policy
Template Indicator Description

Policy
Type

that is inserts
into the table
that do not have
clustered
indexes (S070_
HeapInsertPct)

Syba
se

SAPSybaseA
SE_2071

SAPSybaseASE_Non-
ClstIndexesMaintenanceForInsOrUpdts:
High,
SAPSybaseASE_Non-
ClstIndexesMaintenanceForInsOrUpdts:
Normal

This policy
monitors the
average number
of non-clustered
indexes (NCIs)
requiring
maintenance for
inserts/updates
on tables (S071_
NCIxReqMntIU
Pct)

Measurem
ent
Threshold

Syba
se

SAPSybaseA
SE_2072

SAPSybaseASE_Non-
ClstIndexesMaintenanceForDels:High,
SAPSybaseASE_Non-
ClstIndexesMaintenanceForDels:Norma
l

This policy
monitors the
average number
of NCIs
requiring
maintenance for
deletes on
tables (S072_
NCIxReqMntDl
Pct)

Measurem
ent
Threshold

* To determine optimal number of open indexes, run the following commands:

p_countmetadata 'open indexes'

sp_monitorconfig 'open indexes'

To configure number of open indexes, run the following command:

sp_configure 'number of open indexes'

SAP Sybase ASE Lock Performance

This Aspect monitors the information about locks that are held, deadlocks and those that have been
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requested, by any process or object.

CI
Type Policy Template Indicator Description Policy Type

Sybas
e

SAPSybaseAS
E_2029

SAPSybaseASE_
AvgLocksByProcessCnt:High,
SAPSybaseASE_
AvgLocksByProcessCnt:Norm
al

This policy
monitors the
average number of
locks per process
(S029_
AvgLksByProcCn
t)

Measuremen
t Threshold

Sybas
e

SAPSybaseAS
E_2053

SAPSybaseASE_
UsrLocksInUsePct:High,
SAPSybaseASE_
UsrLocksInUsePct:Normal

This policy
monitors the
percentage of
available locks in
use (active user
locks)(S053_
LocksUserPct)

Measuremen
t Threshold

Sybas
e

SAPSybaseAS
E_2057

SAPSybaseASE_
DeadLockCnt:Low,
SAPSybaseASE_
DeadLockCnt:Normal

This policy
monitors the
number of
deadlocks (S057_
DeadlockCnt)

Measuremen
t Threshold

SAP Sybase ASE Memory Performance

This Aspect monitors thememory of SAP Sybase ASE server such as Spin Lock contention, buffer,
cache flushes, and so on.

CI
Type

Policy
Template Indicator Description

Policy
Type

Sybas
e

SAPSybaseAS
E_2037

SAPSybaseASE_
LargeIOUtilizationPct:Low,
SAPSybaseASE_
LargeIOUtilizationPct:Normal

This policy monitors
the percentage of
large I/O utilization
(effectiveness) for
the entire server
(S037_LrgeIOUtilPct)

Measureme
nt Threshold

Sybas
e

SAPSybaseAS
E_2038

SAPSybaseASE_
APFDeniedPercentage:High,
SAPSybaseASE_

This policy monitors
the percentage of
asynchronous pre-

Measureme
nt Threshold
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CI
Type

Policy
Template Indicator Description

Policy
Type

APFDeniedPercentage:Normal fetch (APF) denied
for the server (S038_
APFDeniedPct)

Sybas
e

SAPSybaseAS
E_2073

SAPSybaseASE_
SpinLockContentionPct:High,
SAPSybaseASE_
SpinLockContentionPct:Normal

This policy monitors
the percentage of
spinlock contention
by cache for the
entire server (S073_
SpinLockContPct)

Measureme
nt Threshold

Sybas
e

SAPSybaseAS
E_2074

SAPSybaseASE_
BuffGrabbedDirtyPct:High,
SAPSybaseASE_
BuffGrabbedDirtyPct:Normal

This policy monitors
the percentage of
buffers being grabbed
dirty by cache and
pool (S074_
BuffGrabDrtyPct)

Measureme
nt Threshold

Sybas
e

SAPSybaseAS
E_2076

SAPSybaseASE_
CacheHitMissesPercentage:Hig
h,
SAPSybaseASE_
CacheHitMissesPercentage:Nor
mal

This policy monitors
the percentage of
data cachemisses
(S076_
CacheHitMissPct)

Measureme
nt Threshold

Sybas
e

SAPSybaseAS
E_2080

SAPSybaseASE_
BuffInWashAlreadyInIoPct:High,
SAPSybaseASE_
BuffInWashAlreadyInIoPct:Nor
mal

This policy monitors
the percentage of
buffers in wash
already in I/O (S080_
BferWashInIOPct)

Measureme
nt Threshold

Sybas
e

SAPSybaseAS
E_2081

SAPSybaseASE_
DirtyBuffWashedPct:High,
SAPSybaseASE_
DirtyBuffWashedPct:Normal

This policy monitors
the percentage of
buffer washed dirty
for one or more data
caches (S081_
BferWashDrtyPct)

Measureme
nt Threshold

Sybas
e

SAPSybaseAS
E_2237

NA This policy monitors
the percentage of
large I/O
utilization/effectivene
ss for a specific data
cache (S237_
LrgeIOUtilPct)

Measureme
nt Threshold
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CI
Type

Policy
Template Indicator Description

Policy
Type

Sybas
e

SAPSybaseAS
E_2273

NA This policy monitors
the percentage of
spinlock contention
by cache for a
specific data cache
(2273_
SpinLockContPct)

Measureme
nt Threshold

Sybas
e

SAPSybaseAS
E_2274

NA This policy monitors
the percentage of
buffers being grabbed
dirty by cache and
pool for a specific
cache or pool
combination (S274_
BuffGrabDrtyPct)

Measureme
nt Threshold

Sybas
e

SAPSybaseAS
E_2276

NA This policy monitors
the percentage of
cachemisses for a
specific data cache
(S276_
CacheHitMissPct)

Measureme
nt Threshold

Sybas
e

SAPSybaseAS
E_2280

NA This policy monitors
the percentage of
buffers in wash
already in I/O (S280_
BferWashInIOPct)

Measureme
nt Threshold

Sybas
e

SAPSybaseAS
E_2281

NA This policy monitors
the percentage of
buffer washed dirty
for a specific cache
(S281_
BferWashDrtyPct)

Measureme
nt Threshold

SAP Sybase ASE Network Packets

This Aspect monitors the network activities such as packet size sent and received.

User Guide
Chapter 3: Components

HPE OMi Management Pack for SAP Sybase ASE (1.00) Page 47 of 100



CI
Type Policy Template Indicator Description Policy Type

Sybas
e

SAPSybaseAS
E_2044

SAPSybaseASE_
AvgNWPckSizeSxInBytes:High,
SAPSybaseASE_
AvgNWPckSizeSxInBytes:Norm
al

This policy
monitors the
average network
packet size sent in
bytes (S044_
AvgPackSizeSnt)

Measuremen
t Threshold

Sybas
e

SAPSybaseAS
E_2045

SAPSybaseASE_
AvgNWPckSizeRxInBytes:High,
SAPSybaseASE_
AvgNWPckSizeRxInBytes:Norm
al

This policy
monitors the
average network
packet size
received in bytes
(S045_
AvgPackSizeRcv
d)

Measuremen
t Threshold

SAP Sybase ASE Objects Performance

This Aspect monitors the statistics for objects such as open database count and blocked objects
count.

CI
Type Policy Template Indicator Description Policy Type

Sybas
e

SAPSybaseAS
E_2014

SAPSybaseASE_
RemainingOpenedDBCnt:Low,
SAPSybaseASE_
RemainingOpenedDBCnt:Norm
al

This policy
monitors the
number of
remaining open
databases (S014_
OpenDbRemCnt)

Measuremen
t Threshold

Sybas
e

SAPSybaseAS
E_2049

SAPSybaseASE_
BlckdObjCnt:High,
SAPSybaseASE_
BlckdObjCnt:Normal

This policy
monitors the
number of blocked
objects (S049_
BlockedObjNum)

Measuremen
t Threshold

Sybas
e

SAPSybaseAS
E_2054

SAPSybaseASE_
OpenObjInUsePct:High,
SAPSybaseASE_
OpenObjInUsePct:Normal

This policy
monitors the
percentage of
open objects that
are used or

Measuremen
t Threshold
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CI
Type Policy Template Indicator Description Policy Type

available (S054_
OpnObjctsUsdPc
t)

SAP Sybase ASE Parallel Processing

This Aspect monitors the execution of parallel queries. It reports the parallel queries rate, the number of
times the number of worker processes that was adjusted at run-time, and so on.

CI
Type

Policy
Template Indicator Description Policy Type

Sybas
e

SAPSybaseAS
E_2064

SAPSybaseASE_
WorkerProcReqRate:High,
SAPSybaseASE_
WorkerProcReqRate:Normal

This policy
monitors the
worker process
requests per
second rate
(S064_
WorkrProcesRat
e)

Measureme
nt Threshold

Sybas
e

SAPSybaseAS
E_2065

SAPSybaseASE_
ParallelQueriesRate:High,
SAPSybaseASE_
ParallelQueriesRate:Normal

This policy
monitors the
parallel queries
per second rate
(S065_
ParallelQryRate)

Measureme
nt Threshold

Sybas
e

SAPSybaseAS
E_2066

SAPSybaseASE_
ESPRequestRate:High,
SAPSybaseASE_
ESPRequestRate:Normal

This policy
monitors the
extended stored
procedure (ESP)
requests per
second (S066_
ESQRequestRat
e)

Measureme
nt Threshold

Sybas
e

SAPSybaseAS
E_2067

SAPSybaseASE_
WorkerProcReqDeniedPct:High,
SAPSybaseASE_
WorkerProcReqDeniedPct:Normal

This policy
monitors the
percentage of
worker process
requests denied

Measureme
nt Threshold
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CI
Type

Policy
Template Indicator Description Policy Type

(S067_
WrkrPrcRqDenP
ct)

Sybas
e

SAPSybaseAS
E_2068

SAPSybaseASE_
WorkerProcMemReqFailedPct:Hig
h,
SAPSybaseASE_
WorkerProcMemReqFailedPct:Nor
mal

This policy
monitors the
percentage of
worker process
memory requests
failed (S068_
WrkrMmRqFailPc
t)

Measureme
nt Threshold

Sybas
e

SAPSybaseAS
E_2069

SAPSybaseASE_
ParallelQueryRuntimeAdjstPct:Hig
h,
SAPSybaseASE_
ParallelQueryRuntimeAdjstPct:Nor
mal

This policy
monitors the
percentage of
parallel query run-
time adjustments
(S069_
PQRunTAdjustPc
t)

Measureme
nt Threshold

SAP Sybase ASE Process Activity

This Aspect monitors the Process activities such as blocked processes, committed transactions, and
so on.

CI
Type Policy Template Indicator Description Policy Type

Sybas
e

SAPSybaseAS
E_2039

SAPSybaseASE_
FullUsrLogCacheFlushesPct:High,
SAPSybaseASE_
FullUsrLogCacheFlushesPct:Norm
al

This policy
monitors the
percentage of full
user log cache
flushes (ULC)
caused by full
ULC (S039_
FullULCFlushPc
t)

Measureme
nt Threshold

Sybas
e

SAPSybaseAS
E_2055

SAPSybaseASE_
BlckdPrcsCnt:High,

This policy Measureme
nt Threshold
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CI
Type Policy Template Indicator Description Policy Type

SAPSybaseASE_
BlckdPrcsCnt:Normal

monitors the
number of
blocked
processes
(S055_
BlockdProcesse
s)

Sybas
e

SAPSybaseAS
E_2062

SAPSybaseASE_
LogSemaphoresWaitPct:High,
SAPSybaseASE_
LogSemaphoresWaitPct:Normal

This policy
monitors the
percentage log
semaphores
waited for
Transaction Log
Semaphore
(S062_
LogSemaWaitPc
t)

Measureme
nt Threshold

Sybas
e

SAPSybaseAS
E_2079

SAPSybaseASE_
CommitTransCnt:High,
SAPSybaseASE_
CommitTransCnt:Normal

This policy
monitors the
number of
committed
transactions
(S079_
CommXactsCnt)

Measureme
nt Threshold

Sybas
e

SAPSybaseAS
E_2256

NA This policy
monitors the
blocked process
and its blocking
process (S256_
VictimBlocker)

Measureme
nt Threshold

SAP Sybase ASE Query Performance

This Aspect monitors the SQLQuery Performance and count.

CI
Type Policy Template Indicator Description Policy Type

Sybase SAPSybaseASE_ SAPSybaseASE_ This policy Measurement
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CI
Type Policy Template Indicator Description Policy Type

2027 ActiveCursorsCount:High,
SAPSybaseASE_
ActiveCursorsCount:Normal

monitors the
number of active
cursors (S027_
ActivCursorsCnt)

Threshold

Sybase SAPSybaseASE_
2043

SAPSybaseASE_
HeavySqlStatementsCnt:High,
SAPSybaseASE_
HeavySqlStatementsCnt:Normal

This policy
monitors the
number of heavy
SQL statements
(S043_
HeavySQLNum)

Measurement
Threshold

SAP Sybase ASE User Defined Aspect

This Aspect monitors User Defined Aspects for SAP Sybase ASE.

CI
Type Policy Template Indicator Description Policy Type

Sybase SAPSybaseASE_
UDM

NA Syntax to create SAP Sybase ASE MP
User DefinedMetrics.

ConfigFile

Sybase SAPSybaseASE_
27XX

NA UDMmonitor metric 27XX Measurement
Threshold

SAP Sybase Replication Server Base

This Aspect is the Base Aspect for monitoring SAP Sybase Replication Server. It contains
configuration, schedulers, message and logger policies.

CI
Type Policy Template Indicator Description

Policy
Type

Sybase SAPSybaseASE_
RepConfiguration

NA SAP Sybase Replication Server
Configuration policy to update User
configuration.

ConfigFile

Sybase SAPSybaseASE_
VeryHigh

NA Runs the SAPSybaseASE MP collector or
analyzer for every Very High schedule.

Scheduled
Task
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CI
Type Policy Template Indicator Description

Policy
Type

Sybase SAPSybaseASE_
High

NA Runs the SAPSybaseASE MP collector or
analyzer for every High schedule.

Scheduled
Task

Sybase SAPSybaseASE_
Medium

NA Runs the SAPSybaseASE MP collector or
analyzer for every Medium schedule.

Scheduled
Task

Sybase SAPSybaseASE_
Low

NA Runs the SAPSybaseASE MP collector or
analyzer for every Low schedule.

Scheduled
Task

Sybase SAPSybaseASE_
Logger

NA SAP Sybase ASE Logger Data Feed
(every 5minutes)

Scheduled
Task

Sybase SAPSybaseASE_
Messages

NA Interception of messages submitted by
SAPSybaseASE MP programs.

Open
Message
Interface

SAP Sybase Replication Server Availability

This Aspect monitors the Replication Server activities such as thread status and segments used for all
databases configured to use a Replication Server.

CI
Type Policy Template Indicator Description Policy Type

Sybase SAPSybaseASE_
2285

SAPRepServer_
ThreadStatus:Down,
SAPRepServer_
ThreadStatus:Up

This policy monitors the
Replication Server
thread status (S285_
RepThreadStatus)

Measurement
Threshold

Sybase SAPSybaseASE_
2286

SAPRepServer_
SegmentUsedPct:High,
SAPRepServer_
SegmentUsedPct:Normal

This policy monitors the
percentage of segments
used on the Replication
Server partitions (S286_
RepSegUsedPct)

Measurement
Threshold
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Parameters

Parameters are variables that are an integral component of SAP Sybase ASE Management Templates,
SAP Sybase ASE Aspects, and Policy Templates. Each parameter corresponds to a variable.
Parameters contain default values that are used for monitoring the different components of SAP
Sybase ASE Servers. You can alsomodify the values of the variables to suit your monitoring
requirements.

Types of Parameters

The parameters are grouped as follows:

l Instance Parameters - These parameters are essential for monitoring SAP Sybase ASE CIs.
For example, SAP Sybase ASE Server CI name is an Instance Parameter.

l Mandatory Parameters - These parameters contain the essential information required by policy
templates.
For example, SAP Sybase ASE password is amandatory parameter.

l Dependent Parameters - There are some parameters which are a subset of themandatory
parameters. Such parameters are referred to as dependent parameters.
For example, Frequency and Threshold are dependent parameters of SAP Sybase ASE Instance
Name.

l Expert Parameters - These parameters can be used by SMEs and Administrators.

SAP Sybase ASE Parameters

OMi MP for SAP Sybase ASE contains the following parameters:

Parameter Parameter Type Description
Default
Values

SAP Sybase ASE
Instance Name

Instance SAP Sybase ASE Instance
Name that must bemonitored.

CI
Name

SAP Sybase ASE
Instance Username

Dependent/Mandatory SAP Sybase ASE Server User
Namewith the required
privileges to collect data.

NA
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Parameter Parameter Type Description
Default
Values

SAP Sybase ASE
Instance Password

Dependent/Mandatory Password for SAP Sybase ASE
Server User Name.

Filter Expert/Dependent Filter themonitored components.
For example, SAP Sybase ASE
Server Segment Filter parameter
filters the segments for
monitoring.

SAP Sybase ASE
Instance Collection

Expert/Dependent Turn on or off collection for SAP
Sybase ASE Server Instance.

ON

SAP Sybase ASE
Instance Tracing

Expert/Dependent Enable Tracing on or off for trace
to be captured on node at
%ovdatadir%/dbspi/log/trace
.

OFF

Frequency of Very High
Scheduler

Expert Frequency for the scheduler
which is expected to run for very
high intervals (in minutes).

5

Frequency of High
Scheduler

Expert Frequency for the scheduler
which is expected to run for high
intervals (in minutes).

15

Frequency of Medium
Scheduler

Expert Frequency for the scheduler
which is expected to run for
medium intervals (in hours).

1

Frequency of Low
Scheduler

Expert Frequency for the scheduler
which is expected to run for short
intervals (in hours).

24

Frequency Dependent Frequency of monitoring by a
Policy Template. For example,
the frequency of monitoring SAP
Sybase ASE Server availability.

Note: When the value of
Frequency parameter is set
to NORUN, that specific
Policy Template,
Management Template, or
Aspect will not bemonitored
for the duration the
Frequency value is
NORUN.

NA
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Parameter Parameter Type Description
Default
Values

Threshold Dependent Threshold of a policy template.
For example, the threshold of
monitoring available database
nodes.

Severity Dependent Severity level of a policy
template. For example, the
severity of monitoring critical
database nodes count.

Tuning of Parameters

You can edit the parameters of the SAP Sybase ASE Management Templates or Aspects that are
already deployed to the CIs. To edit the parameters, follow these steps:

1. Open the Assignments & Tuning pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Assignments &
Tuning.

OnOMi 10.x, click Administration > Monitoring > Assignments & Tuning.

2. In theBrowse Views tab, select theSAPSybaseASE_DeploymentView that contains the CI for
which you want to tune parameters. Alternatively, you can use theSearch tab to find a CI.

3. In the list of SAP Sybase ASE Server CIs, select a CI. The Assignments pane shows details of
any existing Aspects assignments for the SAP Sybase ASE Server CI.

4. You canmodify the default parameter values by following one of the below methods:

o In the Assignments pane:

i. Select the Aspect for which you want to tune the parameters and then click . The

Tune Assignment pane shows the current parameter values.

ii. Select the parameter you want to tune and click . The Edit Parameters dialog box

opens.

o In the Assignment Details pane:
i. Double-click a parameter in the list. The Edit Parameter dialog box opens.

5. Change the value and click OK. The new parameter values are deployed to the relevant CIs.
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Configuration Item (CI) and Configuration Item

Types (CITs)

CIs are components that have to bemanaged in order to deliver an IT Service. CIs typically include IT
Services, hardware, and software. CIT describes the type of a CI and its attributes. The SAP Sybase
ASE CIs that are discovered in an environment are grouped together under the CITs.

TheOMi MP for SAP Sybase ASE consists the following CITs:

l Computer

l Sybase

Run-time Service Model (RTSM) Views

A view enables you to build and visualize a subset of the overall CI model that comprises SAP Sybase
ASE CITs related to specific area of interest.

How to Access RTSM Views

1. Open theModeling Studio pane:

On BSM 9.2x, click Admin > RTSM Administration > Modeling > Modeling Studio.

OnOMi 10.x, click Administration > RTSM Administration > Modeling > Modeling Studio >
Resources.

2. Click Resource Type as Views.

3. Click Operations Management > Databases from the list.

4. Double-click or you can drag-and-drop the Resource to themodeling canvas.

By default, OMi MP for SAP Sybase ASE includes the following views:

l SAPSybaseASE_Deployment: This view shows to the Sybase, Interface, and Computer CI type.
The following image shows the relationship among the CI types:
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l SAPSybaseReplicationServer_Deployment: This view refers to the Sybase (SAP Sybase
Replication Server), Interface, and Computer CI type. The following image shows the relationship
among the CI types:

Health Indicators (HIs)

Health Indicators (HIs) analyze the events that occur in OMi MP for SAP Sybase ASE CIs and report
the health of the OMi MP for SAP Sybase ASE CIs. The SAP Sybase ASE MP includes the following
HIs tomonitor the OMi MP for SAP Sybase ASE-related events:

How to Access HIs

1. Open the Indicators pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Indicators.
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OnOMi 10.x, click Administration > Service Health > CI Status Calculation > Health- and
Event Type Indicators.

2. In the CI Type pane, click InfrastructureElement > RunningSoftware > Database > Sybase.

CI
Type HI Description Value/Severity

Sybase SAP Sybase ASE Remaining
Opened Database Count

Indicates the number of
remaining open databases.

Normal/NORMAL,
Low/MAJOR

Sybase SAP Sybase ASE Data
Cache Percentage

Indicates the percentage of data
cache as percentage of total
memory.

Normal/NORMAL,
Low/WARNING

Sybase SAP Sybase ASEWorker
Process Memory Requests
Failed Percentage

Indicates the percentage of
worker process memory requests
failed.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE User Locks
in Use Percentage

Indicates the percentage of user
locks in use.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASEWorker
Process Requests Denied
Percentage

Indicates the percentage of
worker process requests denied.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE Blocked
Objects Count

Indicates the number of blocked
objects.

Normal/NORMAL,
High/WARNING

Sybase SAP Sybase ASE Database
Server Connection

Indicates the database server
connection.

Up/NORMAL,
Down/CRITICAL

Sybase SAP Sybase ASE
Asynchronous Pre-Fetch
(APF) Denied Percentage

Indicates the percentage of
asynchronous pre-fetch (APF)
denied for the server.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE Mirror
Devices Not Active

Indicates the number of Mirror
Devices not active.

Up/NORMAL,
Down/MAJOR

Sybase AP Sybase ASE Blocked
Processes Count

Indicates the number of blocked
processes.

Normal/NORMAL,
High/WARNING

Sybase SAP Sybase ASE Engines
Offline Count

Indicates the count of offline
engines.

Up/NORMAL,
Down/CRITICAL

Sybase SAP Sybase ASE Dead Lock
Count

Indicates the number of dead
lock.

Normal/NORMAL,
Low/MAJOR

Sybase SAP Sybase ASE Server
Engine CPU Utilization
Percentage

Indicates the Server Engine CPU
utilization percentage.

Normal/NORMAL,
Warning/WARNING,
Critical/CRITICAL
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CI
Type HI Description Value/Severity

Sybase SAP Sybase ASE Data
CacheMisses Percentage

Indicates the percentage of data
cachemisses for server.

Normal/NORMAL,
High/MAJOR

Event Type Indicators (ETIs)

ETIs are categorization of events based on the type of occurrence. The SAP Sybase ASE MP includes
the following ETIs tomonitor OMi Management Pack for SAP Sybase ASE -related events:

How to Access ETIs

1. Open the Indicators pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Indicators.

OnOMi 10.x, click Administration > Service Health > CI Status Calculation > Health- and
Event Type Indicators.

2. In the CI Type pane, click InfrastructureElement > RunningSoftware > Database > Sybase.

CI Type ETI Description Value/Severity

Sybase SAP Sybase ASE Logical
Reads Rate

Indicates the number of
logical reads per second.

Normal/NORMAL,
High/WARNING

Sybase SAP Sybase ASE Open
Indexes Percentage

Indicates the percentage of
open Indexes.

Normal/NORMAL,
Low/MAJOR

Sybase SAP Sybase ASE Input
Output Percentage for
Application or Login

Indicates the percentage of
Input/Output for one or more
applications as a percent of
total Input or Output.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE Physical
Reads Rate

Indicates the number of
physical reads per second.

Normal/NORMAL,
High/WARNING

Sybase SAP Sybase ASE Active
Cursors Count

Indicates the number of
active cursors.

Normal/NORMAL,
High/WARNING

Sybase SAP Sybase ASE Average
Network Packet Size Sent
In Bytes

Indicates the average
network packet size sent in
bytes.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE
Transaction Log Free Space

Indicates the percentage of
free space in transaction log

Normal/NORMAL,
Low/MAJOR
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CI Type ETI Description Value/Severity

Percentage for one or more databases.

Sybase SAP Sybase Replication
Server Segment Used
Percentage

Indicates the percentage of
segments used on a
specific disk partition.

Normal/NORMAL,
High/MINOR

Sybase SAP Sybase ASE
Connections Per User Count

Indicates the average
number of connections per
user.

Normal/NORMAL,
High/WARNING

Sybase SAP Sybase ASEWorker
Process Request Rate

Indicates the number of
worker process request per
second.

Normal/NORMAL,
High/MINOR

Sybase SAP Sybase ASE Low
Priority Switches
Percentage

Indicates the percentage of
low priority switches.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE Cache
Utilization Percentage

Indicates the percentage of
cache utilization.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE Buffers in
Wash Already in IO
Percentage

Indicates the percentage of
buffers in wash already in
Input Output for one or more
data caches.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE Medium
Priority Switches
Percentage

Indicates the percentage of
medium priority switches.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE
Completed Disk Input
Output Percentage

Indicates the percentage of
completed disk Input or
Output.

Normal/NORMAL,
Low/MAJOR

Sybase SAP Sybase ASE Full User
Log Cache Flushes
Percentage

Indicates the percentage of
full user log cache flushes
(ULC).

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE Database
Segment Free Space

Indicates the percentage of
free space for one or more
segments for database.

Normal/NORMAL,
Low/MAJOR

Sybase SAP Sybase ASE Virtual
Device Space Used

Indicates the percentage of
space used on Virtual
Device.

Normal/NORMAL,
Low/MAJOR

Sybase SAP Sybase ASE Cache Hit
Misses Percentage

Indicates the percentage of
data cachemisses for one
or more data caches.

Normal/NORMAL,
High/MAJOR
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CI Type ETI Description Value/Severity

Sybase SAP Sybase ASE Disk
Input Output Percentage

Indicates the percentage of
total Input Output performed
by specific disks.

Normal/NORMAL,
High/MINOR

Sybase SAP Sybase ASE
Procedure Cache
Percentage

Indicates the percentage of
procedure cache from disk.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE Database
Connection

Indicates the database
status and connection
check.

Up/NORMAL,
DownStatus/WARNING,
Down/MAJOR

Sybase SAP Sybase ASE Average
Locks By Process Count

Indicates the average
number of locks per
process.

Normal/NORMAL,
High/WARNING

Sybase SAP Sybase ASE Buffers
Grabbed Dirty Percentage

Indicates the percentage of
buffers grabbed dirty for one
or more cache or pool.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE Log
Semaphores Wait
Percentage

Indicates the percentage of
log semaphores wait.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE Users
Connected Percentage

Indicates the percentage of
maximum users connected.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE Extended
Stored Procedure (ESP)
Request Rate

Indicates the number of
Extended Stored Procedure
(ESP) request per second.

Normal/NORMAL,
High/MINOR

Sybase SAP Sybase ASE Spin Lock
Contention Percentage

Indicates the percentage of
spin lock contention for the
entire server.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE Large
Input Output Utilization
Percentage

Indicates the percentage of
large Input/Output
effectiveness (utilization) for
the entire server.

Normal/NORMAL,
Low/MAJOR

Sybase SAP Sybase ASE Non-
Clustered Indexes
Maintenance for Inserts or
Updates

Indicates the average
number of non-clustered
indexes (NCI) requiring
maintenance for inserts and
updates.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE Parallel
Query Runtime Adjustments
Percentage

Indicates the percentage of
worker process requests
that are being adjusted at

Normal/NORMAL,
High/MAJOR
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CI Type ETI Description Value/Severity

run-time.

Sybase SAP Sybase ASE Non-
Clustered Indexes
Maintenance for Deletes

Indicates the average
number of non-clustered
indexes (NCI) requiring
maintenance for deletes.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE
Committed Transactions
Count

Indicates the number of
committed transactions.

Normal/NORMAL,
High/WARNING

Sybase SAP Sybase ASE Parallel
Queries Rate

Indicates the number of
parallel queries per second.

Normal/NORMAL,
High/MINOR

Sybase SAP Sybase ASE Heavy
Sql Statements Count

Indicates the number of
heavy SQL statements.

Normal/NORMAL,
High/WARNING

Sybase SAP Sybase ASE Heap
Inserts Percentage

Indicates the percentage of
heap inserts.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE Large
Input Output Denied
Percentage

Indicates the percentage of
large Input Output denied.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE Dirty
Buffers Washed Percentage

Indicates the percentage of
buffers washed dirty for one
or more data caches.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE Open
Objects in Use Percentage

Indicates the percentage of
open objects used to
available.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE CPU
Percentage for Application or
Login

Indicates the percentage of
CPU for one or more
applications as a percent of
total CPU.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE Data
Server Process Status

Indicates the critical
processes running on a data
server.

Up/NORMAL,
Down/CRITICAL

Sybase SAP Sybase ASE Average
Network Packet Size
Received in Bytes

Indicates the average
network packet size
received in bytes.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE High
Priority Switches
Percentage

Indicates the percentage of
high priority switches.

Normal/NORMAL,
High/MAJOR

Sybase SAP Sybase ASE Task
Context Switch Percentage

Indicates the task context
switch percentage.

Normal/NORMAL,
High/WARNING
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Tools

OMi MP for SAP Sybase ASE uses different tools to view andmonitor the SAP Sybase ASE
environment. Tools enable operators to perform actions in the context of an event from the Event
Browser.

Types of Tools

Following are the different types of tools:

l Executable: Native commands that are launched locally on a host through a deployedOperations
Manager Agent.

l Scripts: Different kinds of scripts that are executed on a host through a deployedOperations
Manager Agent.

l URL: Launch a URL in a browser. For example, use this to cross launch a web-based tool for the
related CI of a selected event.

How to Access Tools

1. Open the Tools pane:

On BSM 9.2x, click Admin > Operations Management > Operations Console > Tools.

OnOMi 10.x, click Administration > Operations Console > Tools.

2. In the CI Types pane:

o For Operational tools, click InfrastructureElement > RunningSoftware > Database >
Sybase.

o For Administration tools, click InfrastructureElements > Node > Computer.
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Tool Categories

SAP Sybase ASE tools are grouped into two categories:

l SAP Sybase ASE Management Pack Administration Tools

CI Type Tool Description

Computer Enable SAP Sybase ASE
Management Pack
Monitoring

Enables SAP Sybase ASE Management Pack
collection and alert notification.

Computer Enable SAP Sybase ASE
Management Pack Trace

Turns ON SAP Sybase ASE Management Pack tracing.

Computer Data Capture Tool for
SAP Sybase ASE
Management Pack

Collects error and log information that can be sent to
HPE support to troubleshoot SAP Sybase ASE
Management Pack issues.

Computer Disable SAP Sybase
ASE Management Pack
Trace

Turns OFF SAP Sybase ASE Management Pack
tracing.

Computer Display SAP Sybase
ASE Management Pack
Error file

To view the contents of the SAP Sybase ASE
Management Pack error file.

Computer Disable SAP Sybase
ASE Management Pack
Monitoring

Disables SAP Sybase ASE Management Pack
collection and alert notification.

Computer Verify SAP Sybase ASE
Management Pack
Deployment

Shows SAP Sybase ASE MP deployed files, versions,
number of policies, defaults file, and performs a
connection check.

l SAP Sybase ASE Management Pack Operational Tools

CI Type Tool Name Description

Sybase SAP Sybase ASE Active
Cursors Count

Displays the number of active cursors for SAP
Sybase ASE.

Sybase SAP Sybase ASE
Asynchronous Pre-Fetch
(APF) Denied Percentage

Displays the percentage of asynchronous pre-
fetch (APF) denied for the SAP Sybase ASE.

Sybase SAP Sybase ASE Average
Locks By Process Count

Displays the average number of locks per
process for SAP Sybase ASE.
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CI Type Tool Name Description

Sybase SAP Sybase ASE Average
Packet Size Received

Displays the average network packet size
received in bytes for SAP Sybase ASE.

Sybase SAP Sybase ASE Average
Packet Size Sent

Displays the average network packet size sent
in bytes.

Sybase SAP Sybase ASE Blocked
Processes Count

Displays the number of blocked processes.

Sybase SAP Sybase ASE Buffer
Grabbed Dirty Percentage

Displays the percentage of buffers grabbed
dirty for one or more cache or pool.

Sybase SAP Sybase ASE Buffer
Wash Dirty Percentage

Displays the percentage of buffers washed dirty
for one or more data caches.

Sybase SAP Sybase ASE Buffer
Wash Input Output
Percentage

Displays the percentage of buffers in wash
already in Input Output for one or more data
caches.

Sybase SAP Sybase ASE Cache Hit
Miss Percentage

Displays the percentage of data cachemisses
for one or more data caches.

Sybase SAP Sybase ASE Cache
Utilization Percentage

Displays the percentage of cache utilization.

Sybase SAP Sybase ASE Check
Database Connection And
Status

Displays the database status and connection
check.

Sybase SAP Sybase ASE Connected
Maximum Users Percentage

Displays the percentage of maximum users
connected.

Sybase SAP Sybase ASE
Connections Per User Count

Displays the average number of connections
per user for SAP Sybase ASE.

Sybase SAP Sybase ASE Data Cache
Misses Percentage

Displays the percentage of data cachemisses.

Sybase SAP Sybase ASE Data Cache
Percentage

Displays the percentage of data cache as
percentage of total memory.

Sybase SAP Sybase ASE Free
Segment Space Percentage

Displays the percentage of free space for one or
more segments for a database.

Sybase SAP Sybase ASE Inactive
Mirror Device Count

Displays devices for whichmirroring is enabled,
but not active.

Sybase SAP Sybase ASE Large Input
Output Denied Percentage

Displays the percentage of large Input/Output
denied.
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CI Type Tool Name Description

Sybase SAP Sybase ASE List of
Databases

Displays the list of databases in the server.

Sybase SAP Sybase ASE List of
Tables

Displays the list of tables in the server.

Sybase SAP Sybase ASE Log Size
Usage

Displays log size details for the server.

Sybase SAP Sybase ASE Memory
Usage

Displays thememory usage for the server.

Sybase SAP Sybase ASE Network
Communication

Displays Network Communication details for
the server.

Sybase SAP Sybase ASE Offline
Engines Count

Check maximum online engines configuration
value and status of all engines.

Sybase SAP Sybase ASE Open
Objects Used Percentage

Displays the percentage of open objects used
to available.

Sybase SAP Sybase ASE Parallel
Query Run Time Adjustment
Percentage

Displays the percentage of worker process
requests that are being adjusted at run-time for
SAP Sybase ASE.

Sybase SAP Sybase ASE Procedure
Cache Percentage

Displays the percentage of procedure cache
from disk.

Sybase SAP Sybase ASE Physical
Resources

Displays the Physical Resources usage for the
server.

Sybase SAP Sybase ASE Server
Connection Check

Checks the connection of all SAP Sybase ASE
instances on themanaged node.

Sybase SAP Sybase ASE Spin Lock
Contention Percentage

Displays the percentage of spin-lock contention
for the entire SAP Sybase ASE.

Sybase SAP Sybase ASE SQLServer
Administration

Displays general administration configuration
details for the server.

Sybase SAP Sybase ASE Transaction
Log Full Percentage

Displays the percentage of free space in
transaction log for one or more databases.

Sybase SAP Sybase ASE User Locks
Percentage

Displays the percentage of user locks in use for
SAP Sybase ASE.

Sybase SAP Sybase ASE Victim Displays blocked process and its blocking
process.
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CI Type Tool Name Description

Sybase SAP Sybase ASE Virtual
Spaced Used Percentage

Displays the percentage of space used on
Virtual Device.

Sybase SAP Sybase ASEWorker
Process Memory Request
Failed Percentage

Displays the percentage of worker process
memory requests failed.

Sybase SAP Sybase ASEWorker
Process Requests Denied
Percentage

Displays the percentage of worker process
requests denied for SAP Sybase ASE.

Sybase SAP Sybase Replication
Server Connection Check

Checks the connection of all SAP Sybase
Replication Server instances on themanaged
node.

Sybase SAP Sybase Replication
Server Thread Status

Checks the status of Replication Server thread.

How to Launch a Tool

To launch a tool at the event level, follow the below steps:

1. Open the Tools pane:

On BSM 9.2x, click Application > Operations Management > Event Perspective > View
Explorer > Browse Views.

OnOMi 10.x, clickWorkspaces > Event Perspective > View Explorer > Browse Views.

2. To run a tool, follow one of the followingmethods:

a. In theBrowse Views tab, select a view and then inEvent Browser, select an event.

All the related Tools appear in the Action pane.

b. In the Actions pane, click CI orNode radio button.

c. Select the tool you want to launch.

Or

a. In theBrowse Views tab, select the view and then select an event.

b. Select an Event and then right-click, navigate to Launch > Tool > Select a tool.

3. The Preview Tool Execution dialog box opens.

4. Click Run Tool to launch the selected tool.
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To launch a tool at the CI or node level, follow the below steps:

1. Open the Tools pane:

On BSM 9.2x, click Application > Operations Management > Event Perspective > View
Explorer > Browse Views.

OnOMi 10.x, clickWorkspaces > Event Perspective > View Explorer > Browse Views.

2. In theBrowse Views tab, right-click a CI or node. The Select Tool page opens.

3. Select the tool that you want to launch and click Run Tool.

Note: Formore information about the description of the tools, see the section "Tool
Categories".

Graph Templates

Graphs represent pictorial representation of metrics. OMi MP for SAP Sybase ASE comprises the
following graphs:

How to Access Graph Templates

1. Open the PerformanceGraphMapping pane:

On BSM 9.2x, click Admin > Operations Management > Operation Console.

OnOMi 10.x, click Administration > Operations Console > Performance Graph Mappings.

2. In the CI Types pane, select InfrastructureElement > RunningSoftware > Database >
Sybase.

Graph
Templates Description Metric Name Table Name/Class Name

Cache This graph shows
SAP Sybase ASE
Management Pack
data cachemetrics.

S031_DATACACHEPCT

S032_
PROCDRECACHEPCT

S033_
DATACACHMISSPCT

S035_
CACHEUTILZTNPCT

S036_LRGEIODENIEDPCT

DBSPI_SYB_
GRAPH:DBSPI_SYB_
GRAPH
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Graph
Templates Description Metric Name Table Name/Class Name

Disk
Utilization

This graph shows
SAP Sybase ASE
Management Pack
disk utilization
metrics.

S016_SPACEDUSEDPCT

S029_
AVGLKSBYPROCCNT

DBSPI_SYB_
GRAPH:DBSPI_SYB_
GRAPH

Parallel Server
andQuery

This graph shows
SAP Sybase ASE
Management Pack
parallel server and
query metrics.

S064_
WORKRPROCESRATE

S065_
PARALLELQRYRATE

S066_ESQREQUESTRATE

S067_
WRKRPRCRQDENPCT

S068_
WRKRMMRQFAILPCT

S069_
PQRUNTADJUSTPCT

DBSPI_SYB_
GRAPH:DBSPI_SYB_
GRAPH

Memory
Statistics

This graph shows
SAP Sybase ASE
Management Pack
memory statistics
metrics.

S037_LRGEIOUTILPCT

S038_APFDENIEDPCT

S039_
FULLULCFLUSHPCT

S073_
SPINLOCKCONTPCT

S074_
BUFFGRABDRTYPCT

S075_
COMPLTEDSKIOPCT

S076_
CACHEHITMISSPCT

S080_
BFERWASHINIOPCT

S081_
BFERWASHDRTYPCT

DBSPI_SYB_
GRAPH:DBSPI_SYB_
GRAPH

Disk Index This graph shows
SAP Sybase ASE
Management Pack

S015_OPENINDEXPCT

S070_HEAPINSERTPCT

DBSPI_SYB_
GRAPH:DBSPI_SYB_
GRAPH

User Guide

HPE OMi Management Pack for SAP Sybase ASE (1.00) Page 70 of 100



Graph
Templates Description Metric Name Table Name/Class Name

disk index metrics S071_
NCIXREQMNTIUPCT

S072_
NCIXREQMNTDLPCT

CPU
Utilization

This graph shows
SAP Sybase ASE
Management Pack
CPU utilization
metrics.

S001_UTILBYCPUPCT

S003_
CONTXTSWITCHPCT

DBSPI_SYB_
GRAPH:DBSPI_SYB_
GRAPH

Process and
Application
Changes

This graph shows
SAP Sybase ASE
Management Pack
process and
application changes
metrics.

S046_
HIGPRIOCHNGSPCT

S047_
MEDPRIOCHNGSPCT

S048_
LOWPRIOCHNGSPCT

S050_CPUAPPLOGNPCT

S051_IOAPPLOGNPCT

DBSPI_SYB_
GRAPH:DBSPI_SYB_
GRAPH

Database
Status

This graph shows
SAP Sybase ASE
Management Pack
database status
metrics.

S004_
TRANSLOGFULLPCT

S007_
CONNECTUSERSPCT

DBSPI_SYB_
GRAPH:DBSPI_SYB_
GRAPH

Server Status This graph shows
SAP Sybase ASE
Management Pack
general server
metrics.

S027_
ACTIVCURSORSCNT

S053_LOCKSUSERPCT

S054_
OPNOBJCTSUSDPCT

S055_
BLOCKDPROCESSES

S057_DEADLOCKCNT

S061_
CONECTPERUSRCNT

S062_LOGSEMAWAITPCT

DBSPI_SYB_
GRAPH:DBSPI_SYB_
GRAPH

Network
Packets

This graph shows
SAP Sybase ASE
Management Pack

S044_AVGPACKSIZESNT

S045_

DBSPI_SYB_
GRAPH:DBSPI_SYB_
GRAPH
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Graph
Templates Description Metric Name Table Name/Class Name

network packets
metrics.

AVGPACKSIZERCVD

How to View Graphs

Performance Perspective enables you to populate graphs from existing graph templates. You can also
plot customized graphs by selecting the requiredmetrics for a selected CI.

To view the Performance Perspective of SAP Sybase ASE CIs using graphs, follow these steps:

1. Open the Performance Perspective pane:

On BSM 9.2x, click Applications > Operations Management > Performance Perspective.

OnOMi 10.x, clickWorkspaces > Operations Console > Performance Perspective.

The View Explorer pane appears.

2. In theBrowse Views tab, select theSAPSybaseASE_DeploymentView. The default graphs
available for theSAPSybaseASE_DeploymentView appears in the Performance pane.

3. In theGraphs tab, select the graph you want to plot, and then click Draw Graphs. The
selected graph is plotted on the right pane.

Note: Formore information about Managing Events, see theOperations Manager i Concepts
Guide.
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Chapter 4: Customizations Scenarios
OMi MP for SAP Sybase ASE can be customized to suit your monitoring requirements. You can edit
the existing SAP Sybase ASE Management Templates or create new SAP Sybase ASE Management
Templates tomonitor any database environment.

Customizing SAP Sybase ASE Management

Template before Deployment

You can customize OMi MP for SAP Sybase ASE to optimally and seamlessly monitor the SAP
Sybase ASE Servers in your environment. OMi MP for SAP Sybase ASE provides the following
customization scenarios:

l Creating SAP Sybase ASE Management Templates

l Editing SAP Sybase ASE Management Templates

l User DefinedMetrics (UDM)

Creating SAP Sybase ASE Management Templates

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:
Configuration Folders > Database Management > SAP Sybase ASE

3. Select the SAP Sybase ASE configuration folder and if you need to create a new configuration

folder, click . The Create Configuration Folder opens.

4. Type the name of the new configuration folder and the description. For example, you can type the
new configuration folder name as Test.
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5. Click OK. The new configuration folder is created.
Configuration Folders > Database Management > SAP Sybase ASE > Test

6. In theManagement Templates & Aspects pane, select the new configuration folder and click

Management Template. The CreateManagement Template wizard opens.

7. In theGeneral tab, type aName for the new SAP Sybase ASE Management Template. Click
Next.

8. A SAP Sybase ASE Management Template enables you tomanage SAP Sybase ASE
configuration items and all the related dependent CIs. Select SAPSybaseASE_Deployment from
the list as the Topology View. The SAPSybaseASE_Deployment shows the SAP Sybase ASE
CIs and all the related CI types.

9. Select an item in the topology map to select theCI Type of the configuration items that this
Management Template enables you tomanage. This is the type of CI to which theManagement
Template can be assigned. For example, you can select Sybase tomonitor SAP Sybase ASE
Servers.
Click Next.

10. In theAspects tab, add the Aspects to theManagement Template. Youmust add theSAP
Sybase ASE BaseAspect to the new Management Template. TheSAP Sybase ASE Base
Aspect contains the config file, openmessage interface, scheduled task, and log file policy
templates, which are essential for data collection.

To add an existing Aspect, follow these steps:

a. Select the Aspect you want to add from the Available Aspects matching the CI Types pane.
You can use CTRL or SHIFT key to select multiple Aspects.

b. Click to move the Aspect to the Selected Aspects pane. The Aspect is added to the

Management Template.

c. Click Next.

11. In theParameters tab, you see a list of all the parameters from the Aspects that you added to this
Management Template.

To combine parameters:

a. Press CTRL and click the parameters that you want to combine.

b. Click . The Edit/Combine Parameters dialog box opens.

c. Type a Name for the combined parameters.
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d. (Optional). Specify a Description, Default Value, and whether the combined parameter is
ReadOnly, an Expert Setting, or Hidden.
You can specify either a specific default value, or you can click From CI Attribute and then
browse for a CI attribute. When you specify a CI attribute, Operations Management sets the
parameter value automatically during the deployment of the underlying policy templates, using
the actual value of this attribute from the CI. You can also change values of conditional
parameters. (The conditions are read-only and cannot be changed at Management Template
level.)

ReadOnly prevents changes to the parameter value when theManagement Template is
assigned to a CI. Hidden also prevents changes, but additionally makes the parameter
invisible when theManagement Template is assigned, and during parameter tuning. Users
can choose whether to show expert settings when they make an assignment.

e. Click OK.

You can also edit the parameters without combining them, to override the defaults in the

Aspects or policy templates. Click one parameter, and then click . The Edit/Combine

Parameters dialog box opens.

12. In the CreateManagement Template wizard, click Finish to save theManagement Template and
close the wizard. The new Management Template appears in theManagement Templates &
Aspects pane.

Editing SAP Sybase ASE Management Templates

You can edit the SAP Sybase ASE Management Templates andmodify the following components:

l Editing Parameters

l Editing Aspects

Editing Parameters

Use Case: You are using Essential SAP Sybase ASE Management Template tomonitor database
space utilization in your environment. You aremonitoring the Transaction log free space with low free
space in the environment and want to modify the parameters corresponding to database space
utilization to closely monitor the free space available.
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To closely monitor database space utilization in your environment, youmust modify the Transaction log
free space parameters - Transaction log free space with low free space frequency, Transaction log free
space with low free space threshold and Transaction log free space with low free space severity.

To edit the parameters, follow these steps:

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:
Configuration Folders > Database Management > SAP Sybase ASE > Management
Templates > Essential SAP Sybase ASE Management Template

3. In theManagement Template & Aspect pane, select theEssential SAP Sybase ASE

Management Template from the list, and then click . The Edit Management Template dialog

box opens.

4. Click theParameters tab. The list of parameters appear.

5. Double-click the Transaction log free space parameter. The Edit/Combine Parameters window
appears.
In this instance, Transaction log free space parameter is Transaction log free space with low free
space frequency, threshold or severity.

6. You can change the default value by using the drop down text. For example, you can change the
value of the parameter Transaction log free space with low free space frequency to High from
Medium.

7. Click OK. The Edit Management Template dialog box opens.

8. Click OK. The version of the SAP Sybase ASE Management Template is incremented.

Note: The version number of the SAP Sybase ASE Management Template is incremented when
any customizations aremade to the SAP Sybase ASE Management Template.

Editing Aspects

Use Case: You are using Essential SAP Sybase ASE Management Template tomonitor the database
object in the SAP Sybase ASE environment. You want to use some Aspects which are part of the
Extensive SAP Sybase ASE Management Template.

To edit the Aspects, follow these steps:
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1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:
Configuration Folders > Database Management > SAP Sybase ASE > Management
Templates > Essential SAP Sybase ASE Management Template

3. In theManagement Template & Aspect pane, select theEssential SAP Sybase ASE

Management Template from the list, and then click . The Edit Management Template dialog

box opens.

4. Click theAspects tab. The list of Aspects appear.

5. In the Layout pane, select either Computer or Sybase CI.

6. Select the Aspect that you want to add from the list. For example, you want to add theSAP
Sybase ASE Object PerformanceAspect.

7. Click to add the selected Aspect. The SAP Sybase ASE Object Performance Aspect is added

to theSelected Aspects list.

8. Click OK. The version of the SAP Sybase ASE Management Template is incremented.

User Defined Metrics (UDM)

You can collect additional data from SAP Sybase ASE Server by creating User DefinedMetrics
(UDMs). TheOMi MP for SAP Sybase ASE enables you to define additional metrics andmechanisms
to collect thesemetric values with the help of SQL codes. You can associate the newly created UDMs
to ameasurement threshold. You can create reports and graphs from UDMs. By default, the
SAPSybaseASE_UDM is part of SAP Sybase ASE User Defined Aspects.

The SAP Sybase ASE User Defined Aspect includes the following policies:

l SAPSybaseASE_27XX -Measurement Threshold policy for monitoring UDM

l SAPSybaseASE_UDM - Config file policy template to create a UDM

User Guide
Chapter 4: Customizations Scenarios

HPE OMi Management Pack for SAP Sybase ASE (1.00) Page 77 of 100



Syntax for ConfigFile Policy Template

TheOMi MP for SAP Sybase ASE provides you with a UDM configuration file (sybaseaseudm.cfg).
You can add SQL codes to the template to define new metrics and themechanism to collect themetric
data.

The template uses the following syntax to definemetric name andmetric data collectionmechanism:

SYBASE
METRIC 27XX
COLLECT <OPTIONS> "<sqlcode>"
REPORT 1 "<sqlcode>"
METRIC 27YY

The following snippet of code defines themechanism to collect the SAP Sybase ASE metric 27XX:

SYBASE
METRIC 27XX
COLLECT <OPTIONS> "<sqlcode>"
REPORT 1 "<sqlcode>"

Where:

l METRIC 27XX is the newly definedmetric (you can type ametric name of your choice).

l COLLECT <OPTIONS> “<sqlcode>” is the syntax to definemetric data collectionmechanism from
managed server nodes.

o <OPTIONS> specifies themechanism to log and represent the collected data.

o “<sqlcode>” is the programming code written in SQL to collect metric data from database nodes.
It can be a direct stand-alone SQL statement.

o REPORT 1 “<sqlcode>” is the syntax to define themechanism to generate reports from the
collectedmetric data.

TheOMi MP for SAP Sybase ASE uses SQL utility to collect and report UDM data.

Database Metric COLLECT utility Metric REPORT utility

Sybase Transact-SQL isql
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The SQL codes that youmention in this file are used by the collector/analyzer/script on SAP Sybase
ASE Server managed nodes to collect metric data. In the SQL code, you can use the following host
variables to facilitate data collection process:

l :dbspi_error

l :dbspi_threshold

l :dbspi_value

Tasks

How to Create User Defined Aspects

To create user definedmetrics, follow these steps:

1. To define a new metric, youmust create a copy of themeasurement threshold template
SAPSybaseASE_27XX.

a. Open the Policy Template pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Policy Templates.

OnOMi 10.x, click Administration > Monitoring > Policy Templates.

b. In the Policy Templates Groups pane:

Click Templates grouped by type > Measurement Threshold.

c. In Policy Templates pane, click SAPSybaseASE_27XX.

d. To create a copy of theSAPSybaseASE_27XX policy, right-click and then click Copy Item.

Then click Paste Item. Alternately, you can select SAPSybaseASE_27XX, click Copy

Item and then click Paste Item.

e. Rename the policy as SAPSybaseASE_2700 and click OK.

Note: You can rename the SAPSybaseASE_27XX policy in the range from 2700 to 2797.

f. Tomodify parameter names, description, and values, follow these steps:

i. In the Policy Template pane, select theSAPSybaseASE_2700 policy template and

then click .

Note: Youmust edit the policy in raw mode.

ii. Click Policy Data > Policy Parameters.
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iii. In thePolicy Parameter tab, select the parameter from the list and then click . The

Edit Parameter dialog box opens.

iv. Edit the parameter name (Example, modify UDM Monitor Metric 27XX Severity to
UDM Monitor Metric 2700 Severity), description, and the values.

v. Click OK. The version of the policy template SAPSybaseASE_2700 increments by 0.1.

2. Define the UDM metric in the SPASybaseASE_UDM policy.

a. Open the Policy Template pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Policy Templates.

OnOMi 10.x, click Administration > Monitoring > Policy Templates.

b. In the Policy Templates Groups pane:

Templates grouped by type > ConfigFile Templates

c. In the Policy Template pane, select SAPSybaseASE_UDM policy.

d. In theSAPSybaseASE_UDM, select 1.0 and then click . Then click Edit Policy
Template (Raw Mode).

e. Click thePolicy Data tab. It contains details about defining a user definedmetric and a
sample example of a user definedmetric. You can edit the data and save the policy. The
version number of the UDM policy is incremented by 0.1.

3. To define new SAP Sybase ASE User Defined Aspect, include bothSAPSybaseASE_2700 and
latest version of SAPSybaseASE_UDM policies.

a. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

b. In the Configuration Folders pane:

Configuration Folders > Database Management > SAP Sybase ASE > Aspects

c. In theManagement Templates & Aspects pane, click theSAP Sybase ASE User Defined

Aspect and select latest version and then click . The Edit Aspect dialog box opens.

d. Click thePolicy Templates tab and select theSAP Sybase ASE_UDM policy template
(ConfigFile policy). In the Version column, select the latest version of the policy.

e. Select the SAPSybaseASE_27XX policy, and click to delete the generic policy.
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f. To add the policies, click Add Policy Template on BSM 9.2x andAdd Policy
Templates From List onOMi 10.x. The SAP Sybase ASE User Defined Aspect: Edit Aspect
window appears. Select the policies and click OK.

g. In theParameters tab, press CTRL and select all the instances of SAP Sybase ASE
Instance Name parameter and then click . Click OK.

h. Click OK

How to Deploy SAP Sybase ASE User Defined Aspect

Youmust deploy the new version of the SAP Sybase ASE User Defined Aspect for monitoring UDM.

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:

Configuration Folders > Database Management > SAP Sybase ASE > Aspects

3. In theManagement Templates & Aspects pane, click theSAP Sybase ASE User Defined

Aspect and then select the latest version 1.1 and then click Assign and Deploy Item.

Alternately, you can right-click theSAP Sybase ASE User Defined Aspect and then click
Assign and Deploy Item to open the Assign and Deploy Wizard.

4. In theConfiguration Item tab, select theSybaseCI to deploy the Aspect and then click Next.

Note: If you want to deploy Aspects to Node CIs, select Also show CIs of type Node
check box.

5. In theRequired Parameters tab, youmust specify themandatory parameters by following these
steps:

a. Select theSAP Sybase ASE Instance Name parameter in the list, and then click . The

SAP Sybase ASE Instance Name dialog box opens.

b. Specify the value, and then click OK.

c. Select theSAP Sybase ASE Instance Username parameter in the list, and then click .

The SAP Sybase ASE Instance Username dialog box opens.

d. Specify the value, and then click OK.
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e. Select theSAP Sybase ASE Instance Password parameter in the list, and then click .

The SAP Sybase ASE Password dialog box opens.

f. Click Value and type a value in thePassword field.

g. In theVerify Password field and type the same password and then click OK.

h. Click Next to go toParameter Summary.

6. (Optional). In theAll Parameters tab on BSM 9.2x andParameter Summary tab onOMi 10.x,
you can change the default values of the parameters. Else click Next.

To change the default values of the parameters, follow these steps:

a. Select theSAP Sybase ASE Instance Name parameter and then click . The Edit

Instance Parameter dialog box appears.

b. Select the parameter from the list and then click . The Edit Parameter dialog box opens.

Click Value, specify the value, and then click OK.

Note: In theAll Parameters tab on BSM 9.2x andParameter Summary tab onOMi
10.x, you can override the default values of any parameter. You can specify a value for
each parameter at theManagement Template level. By default, parameters defined as

expert parameters are not displayed. To display expert parameters, click Show
Expert Parameters.

c. Click Next.

7. (Optional). In theConfigure Options tab, if you do not want to enable the assignment
immediately, clear theEnable Assigned Objects check box on BSM 9.2x andEnable
Assignment(s) check box onOMi 10.x. You can then enable the assignment later using the
Assignments & Tuning pane.

8. Click Finish.
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Chapter 5: Deployment Scenarios
This section provides information about deploying OMi MP for SAP Sybase ASE for monitoring SAP
Sybase ASE servers.

SAP Sybase ASE Servers in a Standard Environment

SAP Sybase ASE Standard environment consists of standalone SAP Sybase ASE Servers monitored
by amanagement server. To deploy OMi MP for SAP Sybase ASE in a standard environment, follow
these steps:

1. Add the nodes you want to monitor to the OMi Console.

2. Deploy theSAP Sybase ASE DiscoveryAspect to discover both SAP Sybase ASE Server CIs
and SAP Sybase Replication Server CIs on themanaged nodes.

3. Identify and deploy SAP Sybase ASE Management Template as per your monitoring requirement.

For more information about deploying OMi MP for SAP Sybase ASE, see the section "Getting Started
"Getting Started.

The following figure shows a typical deployment scenario where the OMi MP for SAP Sybase ASE is
deployed on SAP Sybase ASE Servers in Standard environment:
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SAP Sybase in Replication Server Environment

Note: If you want to monitor the third-party Replication Server, youmust deploy SAP Sybase
ASE Discovery Aspect to discover them in OMi MP for SAP Sybase ASE.

To deploy OMi MP for SAP Sybase ASE in a replication environment, follow these steps:

1. Add the nodes you want to monitor to the OMi Console.

2. Deploy theSAP Sybase ASE DiscoveryAspect to discover both SAP Sybase ASE Server CIs
and SAP Sybase Replication Server CIs on themanaged nodes.

3. Deploy theSAP Sybase Replication Server AvailabilityAspect to monitor the SAP Sybase
Server for replication of databases.
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Chapter 6: Troubleshooting
The following section provides information about troubleshooting scenarios:

Licensing count is not updated

Problem: Licensing count is not updated on LicenseManagement

Solution: To resolve this problem, follow these steps:

1. After installing OMi MP for SAP Sybase ASE, make sure that the license is activated by following
these steps:
a. Open the LicenseManagement pane:

On BSM 9.2x, click Admin > Platform > Setup and Maintenance > License
Management.

OnOMi 10.x, click Administration > Setup and Maintenance > License Management.

b. Click and select the license.dat file. The license details appears in the License

Management window.

The LicenseManagement provides details about the name, license type, days left, expiration
date, capacity, and capacity details.

2. To check for the license usage on themanaged node, run the following command on themanaged
node:

For AIX: /usr/lpp/OV/bin/ovodetect –t

For UNIX (except AIX): /opt/OV/bin/ovodetect –t

ForWindows: ovodetect –t

If the output of the preceding command is mpinstance="1" then SAP Sybase ASE servers are
beingmonitored. If the output of the preceding command is mpinstance="0" then SAP Sybase
ASE servers are not beingmonitored.

3. If the license is still not updated in the LicenseManagement, restart agent on themanaged node
by running the following command:

For AIX: /usr/lpp/OV/bin/ovc –restart opcmsga
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For UNIX (except AIX): /opt/OV/bin/ovc –restart opcmsga

ForWindows: ovc –restart opcmsga

Management Templates and Aspects are not

deployed on the Managed Node

Problem: Management Templates and Aspects are not deployed on themanaged nodes.

Solution: To resolve this problem, follow these steps:

1. To check the deployment status, open Deployment Jobs pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Deployment Jobs.

OnOMi 10.x, click Administration > Monitoring > Deployment Jobs.

2. To check the assignment status, open Assignments & Tuning pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Assignments &
Tuning.

OnOMi 10.x, click Administration > Monitoring > Assignments & Tuning.

3. Check the following OMi log files:

On BSM < or = 9.25

Linux: /opt/HP/BSM/log/EJBContainer/opr-configserver.log

Windows: %TOPAZ_HOME%\log\EJBContainer\opr-configserver.log

OnBSM > or =9 .26 andOMi 10.x

Linux: /opt/HP/BSM/log/jboss/opr-webapp.log

Windows: %TOPAZ_HOME%\log\jboss\opr-webapp.log
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SAP Sybase ASE Server monitoring does not start

after deploying OMi MP for SAP Sybase ASE

Problem: SAP Sybase ASE Server monitoring is not starting after deployment.

Solution: To resolve this problem, follow these steps:

1. Run the following command to ensureSAPSybaseASE_Configuration policy is deployed on the
managed node:

%OvInstalldir%\bin\ovpolicy -polname "SAPSybaseASE_Configuration" -poltype
configfile –l

2. In case parameter values aremodified, follows the below steps to identify the policy ID:

a. Open the Policy Templates pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Policy Template.

OnOMi 10.x, click Administration > Monitoring > Policy Templates.

b. In the Policy Template Groups pane, click ConfigFile Templates.

c. In the Policy Templates pane, click SAPSybaseASE_Configuration Policy Template.

d. In the Details pane, note the ID value.

3. Navigate to below folder location on themanaged node and check if the parameter values are
updated in the <policy id>_params.xml file forSAPSybaseASE_Configuration Policy Template.

For UNIX: /var/opt/OV/datafiles/policies/configfiletmpl/

ForWindows:%OvDataDir%\datafiles\policies\configfiletmpl/

4. Perform similar steps to confirm if the configuration and deployment parameters of other policies
are updated.

5. Run the following command to verify MPSybCfg.pl has updated the configuration details:

dbspisybcfg -e

User Guide
Chapter 6: Troubleshooting

HPE OMi Management Pack for SAP Sybase ASE (1.00) Page 87 of 100



No Data for Performance Manager i (PMi) Graphs or

Reports

Problem 1: The information to create graphs or reports is not available from OMi MP for SAP Sybase
ASE.

Solution 1: To resolve this problem, follow these steps:

1. Run the following command to check if the graph data sources are created:

ovcodautil –obj

Verify the list of data sources and ensure DBSPI_SYB_GRAPH and DBSPI_SYB_REPORT data
sources are created.

2. If the data sources are not created, run the following command to create the data source:

dbspisybgre

3. The errors related to data source creation are logged in the Console of command prompt.

4. Make sure that the graph policies are deployed on the nodes and policies log data into the below
files:

For UNIX: /var/opt/OV/conf/SAPSybaseASE/dsi/<instance>.dat

ForWindows:%OvDataDir%\conf\SAPSybaseASE\dsi\<instance>.dat

Problem 2: In case you are reusing any of the old nodes with Operations Agent 11.x and PA DSI (Data
Source Integration) and if data sources are already created, this impacts data logging.

Solution 2: To resolve this problem, follow these steps:

1. To clean up and delete the old data, run the follow commands:

a. Clean the old data:

For UNIX: /var/opt/OV/bin/instrumentation/dbspisyb_mwclup

ForWindows: %OvDataDir%\bin\instrumentation\dbspisybmwi-cleanup

b. To restart data sources, run the command ovc –restart coda.

2. Create empty file:
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For UNIX: /var/opt/OV/conf/dsi2ddf/nocoda.opt

ForWindows: %OvDataDir%\conf\dsi2ddf\nocoda.opt

3. For creating new CODA data sources and logging data for PMi, run the following commands:

dbspisybgre

Problem 3: If themanaged node is monitored by Smart Plug-in for Sybase Database.

Solution 3: To resolve this problem, follow these steps:

1. You can backup the data of DBSPI_SYB_<data sources> to the HP Reporter or any other
Reporting solution that you are using.

Example: Run the following command to backup on HP Reporter, gathercoda –h <Sybase_
hostname>.

2. Uninstall the HP Operations Smart Plug-in for Sybase from themanaged node.

For more information about uninstalling HP Operations Smart Plug-in for Sybase frommanaged
node, seeHP Operations Smart Plug-in for Databases Installation and Configuration Guide.

3. To remove the data sources, run the following command:

For UNIX: dbspi_mwclup

ForWindows: dbspimwi -cleanup

Data Logging Policies Not Logging Data

Problem: MP for SAP Sybase ASE Server is not logging data into Report data sources.

Solution: To resolve this problem, follow these steps:

1. Run the following command to check if the report data sources are created:

ovcodautil –obj

2. If the data sources are not created, run the following command to create the data source:

For UNIX: dbspisyb_mw_int –osm

ForWindows: dbspisybmwi -osm

3. The errors related to data source creation are logged in the console of command prompt.
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4. Ensure that the report policies are deployed on the nodes. The report policies directly logs the data
for the reports into the data sources.

Server scheduling metrics fails to execute after

deploying

Problem: SAP Sybase ASEServer schedulingmetrics are not executing after deployment.

Solution: To resolve this problem, follow these steps:

1. Ensure the following four policies are deployed on themanaged node by following these steps:

a. Open the Policy Templates pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Policy Template.

OnOMi 10.x, click Administration > Monitoring > Policy Templates.

b. In the Policy Template Groups pane, click Scheduler Task Templates.

c. Check if theseSAPSybaseASE_High, SAPSybaseASE_Low, SAPSybaseASE_Medium
andSAPSybaseASE_Veryhigh are deployed.

2. Navigate to the following location to check if the respective policy files are valid:

o For UNIX: /var/opt/OV/conf/SAPSybaseASE/xml/

o ForWindows: %OvDataDir%\conf\SAPSybaseASE\xml\

3. The scheduler XML files are created using the instrumentation file:MPConfHandler.pl

Folder location of the instrumentation file:

o For UNIX: /var/opt/OV/bin/instrumentation/MPSybConfHandler.pl

o ForWindows:%OvDataDir%\bin\instrumentation\

4. To enable tracing, run theEnable SAP Sybase ASE Management Pack Trace tool.

For more information about launching a tool, see the section Tools.

5. The scheduler log file is created at the following paths, after enabling the tracing.

o For UNIX: /var/opt/OV/log/SAPSybaseASE/MPSybConfHandler.pl.log

o ForWindows:%OvDataDir%\log\SAPSybaseASE\MPSybConfHandler.pl.log

6. If you do not want to monitor specific metric, then set the Frequency parameter of that metric to

User Guide
Chapter 6: Troubleshooting

HPE OMi Management Pack for SAP Sybase ASE (1.00) Page 90 of 100



“NORUN” value.

For more information about editing the parameter value, see the section "Tuning of Parameters".

Collection failure does not generate alerts on the

Server

Problem: Whenever collector encounters an error, no alerts are generated on the Server.

Solution: To resolve this problem, follow these steps:

1. Enable tracing following one of below methods:

a. Tracing can be enabled through Assignment & Tuning pane by following steps:
i. Open the Assignments & Tuning pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring >
Assignments & Tuning.

OnOMi 10.x, click Administration > Monitoring > Assignments & Tuning.

ii. In theBrowse Views tab, select SAPSybaseASE_Deployment. Select the CI with the
problem.

iii. In the Assignment Item pane, select theSAP Sybase ASE BaseAspect.

iv. In the Assignment Details pane, click to view the expert parameters.

v. Double-click theSAP Sybase ASE Instance Tracing parameter.

The Edit Instance Parameter wizard opens.

vi. Click and then select SAP Sybase ASE Instance Tracing parameter and select

. Change the value toON and click OK.

vii. Click OK.

b. To enable tracing on all instances on the node in the Event Browser, follow these steps:
i. Open the Event Perspective pane:

On BSM 9.2x, click Applications > Operations Management > Event Perspective.

OnOMi 10.x, clickWorkspaces > Operations Console > Event Perspective.

ii. From theView Explorer, select a view and then select an event from theEvent
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Browser.

You can view the tools in the Action pane. 

iii. Double-click Enable SAP Sybase ASEManagement Pack Trace tool. The Run Tool
dialog box opens. 

Note: Retain the optional parameter blank.

iv. Click Run Tool.

2. Navigate to the following location and ensure files are deployed on the node.

ForWindows:%OvDataDir%\bin\instrumentation

For UNIX: /var/opt/OV/bin/instrumentation

3. The dbspicas is the collector, which is used to get the SAP Sybase ASE metrics.

a. To check the connection of the collector, run the command dpspicas -dpv.

b. To verify if the threshold value has exceeded the limit, run the command dpspicas -pv -m
<metric>.

Themetric values is printed on the CommandConsole.

4. If the threshold value has exceeded the limit, run the following command to generate Alarms:

dbspicas –m <metric> -i <Instance name>

-m = (metric) Specifies themetric numbers or number ranges on which to collect data.

-i = (instance) Specifies the database instance (optional)

5. Instrumentation log files for tracing are available at below location:

ForWindows:%OvDataDir%\log\SAPSybaseASE

Foe UNIX: /var/opt/OV/log/SAPSybaseASE

SAP Sybase Replication Server Thread Status tool

fails

Problem: TheSAP Sybase Replication Server Thread Status tool fails. The tool generates the
following error:

Msg 14125, Level 11, State 0:
Server 'SAMPLE_RS':
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Application 'isql' is using character set 'utf8', but the Replication Server is
using character set 'iso_1'. Because the character sets are different, character
set conversion problems may occur.

Solution: You need to ensure proper LANG setting is done based on the SAP Sybase Replication
Server or SAP Sybase ASE Server installed on themanaged node.

To resolve this problem, follow these steps:

1. Run the following command to change the agent LANG setting:

ovconfchg -ns ctrl.env -set LANG C

2. Run the following command to restart agent on themanaged node:

For AIX: /usr/lpp/OV/bin/ovc –restart opcmsga

For UNIX (except AIX): /opt/OV/bin/ovc –restart opcmsga

ForWindows: ovc –restart opcmsga

3. Run the following command to export the LANG setting onto the console:

export LANG=C

OMi MP for SAP Sybase ASE does not work with

Sybase 64-bit version

Problem: OMi MP for SAP Sybase ASE does not work with Sybase 64- bit version.

Solution: For OMi MP for SAP Sybase ASE to work with a 64-bit version of Sybase, youmust install
the Open Client 32-bit libraries from Sybase.

To resolve this problem, following these steps:

1. Obtain the Sybase product Open Client/Server product version <xx.y> for <platform>

where

<xx.y> is the version of Sybase (15.7, for example)

<platform> is themanaged node platform, either HP–UX 11, Solaris, or AIX.

2. Use theOpen Client/Server product installation instructions to install the 32-bit libraries in the
default library directory, usually:
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$SYBASE/$SYBASE_OCS/lib

For example, the pathmight be /home/sybase/OCS-15_0/lib for Sybase 15.7

Note: The 32-bit libraries do not conflict with already installed 64-bit libraries, since both have
different file names (For example, libintl.a is a 32-bit library; libintl64.a is the corresponding
64-bit library; libintl.sl is the 32-bit; libintl64.sl is the 64-bit, and so on).
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Appendix : Metrics and DataSources
Themetric data is logged into specific data sources for generating reports and graphs.

Generic Data Source

The generic data source reserves a column for the database instance name, labeled instance name.
This column also contains the information that differentiates the data collected for each instance. Other
column represents the graphingmetrics. The complete list of all the graphingmetrics is stored in the
dbspisybg.fm file located at:

Windows: %OvDataDir%\bin\instrumentation

UNIX: /var/opt/OV/bin/instrumentation

Graph Templates

Graphs represent pictorial representation of metrics. The graphs are generated from theDBSPI_SYB_
GRAPH data source/class name. For information about creating and viewing graphs, see the
PerformanceGraphing documentation. TheOMi MP for SAP Sybase ASE includes the SAP Sybase
ASE Server graph family, which is mapped to the SAP Sybase ASE Server CIT.

For more information about metrics for graph, see the section "Graph Templates"

Reports

The web based reports enable you to check the health and efficiency of specific SAP Sybase ASE
Servers. The reports are generated from theDBSPI_SYB_REPORT data source/class name. For
information about viewing and accessing reports, see theOperations Bridge Reporter (OBR)
documentation.

TheDBSPI_SYB_REPORT contains information about the following columns:
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l Instance Name

l Value ID

l Value

Metrics

The following table provides information about the Aspect relation with theMetrics and Policy
Templates.

Metrics Data Type: Real 64

Aspects
Policy Template /
Collection Name Metrics

Collection
Interval

SAP Sybase ASE
Application
Performance

SAPSybaseASE_
2046

S046_HIGPRIOCHNGSPCT 5mins

SAPSybaseASE_
2047

S047_MEDPRIOCHNGSPCT 5mins

SAPSybaseASE_
2048

S048_LOWPRIOCHNGSPCT 5mins

SAPSybaseASE_
2050

S050_CPUAPPLOGNPCT 5mins

SAPSybaseASE_
2051

S051_IOAPPLOGNPCT 5mins

SAP Sybase ASE
Availability

SAPSybaseASE_
2007

S007_CONNECTUSERSPCT 5mins

SAPSybaseASE_
2012

S012_ENGINESOFFCNT 5mins

SAPSybaseASE_
2020

S020_BKUPSRVRSTATUS NORUN

SAPSybaseASE_
2061

S061_CONECTPERUSRCNT 5mins

SAP Sybase ASE
CPU Utilization

SAPSybaseASE_
2001

S001_UTILBYCPUPCT 5mins

SAPSybaseASE_
2003

S003_CONTXTSWITCHPCT 5mins
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Aspects
Policy Template /
Collection Name Metrics

Collection
Interval

SAP Sybase ASE
Cache
Performance

SAPSybaseASE_
2031

S031_DATACACHEPCT 15mins

SAPSybaseASE_
2032

S032_PROCDRECACHEPCT 15mins

SAPSybaseASE_
2033

S033_DATACACHMISSPCT 15mins

SAPSybaseASE_
2035

S035_CACHEUTILZTNPCT 15mins

SAPSybaseASE_
2036

S036_LRGEIODENIEDPCT 15mins

SAP Sybase ASE
Database Space
Utilization

SAPSybaseASE_
2004

S004_TRANSLOGFULLPCT  15mins

SAP Sybase ASE
Device
Performance

SAPSybaseASE_
2016

S016_SPACEDUSEDPCT 1 hour

SAPSybaseASE_
2017

S017_MIRRDEVNOACTCNT 1 hour

SAP Sybase ASE
Disk Health

SAPSybaseASE_
2075

S075_COMPLTEDSKIOPCT 15mins

SAPSybaseASE_
2077

S077_PHYSREADSRATE 15mins

SAPSybaseASE_
2078

S078_LOGICREADSRATE 15mins

SAP Sybase ASE
Index Performance

SAPSybaseASE_
2015

S015_OPENINDEXPCT 15mins

SAPSybaseASE_
2070

S070_HEAPINSERTPCT 15mins

SAPSybaseASE_
2071

S071_NCIXREQMNTIUPCT 15mins

SAPSybaseASE_
2072

S072_NCIXREQMNTDLPCT 15mins

SAP Sybase ASE
Lock Performance

SAPSybaseASE_
2029

S029_AVGLKSBYPROCCNT 5mins

SAPSybaseASE_
2053

S053_LOCKSUSERPCT 5mins
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Aspects
Policy Template /
Collection Name Metrics

Collection
Interval

SAPSybaseASE_
2057

S057_DEADLOCKCNT 5mins

SAP Sybase ASE
Memory
Performance

SAPSybaseASE_
2037

S037_LRGEIOUTILPCT 15mins

SAPSybaseASE_
2038

S038_APFDENIEDPCT 15mins

SAPSybaseASE_
2073

S073_SPINLOCKCONTPCT 15mins

SAPSybaseASE_
2074

S074_BUFFGRABDRTYPCT 15mins

SAPSybaseASE_
2076

S076_CACHEHITMISSPCT 15mins

SAPSybaseASE_
2080

S080_BFERWASHINIOPCT 15mins

SAPSybaseASE_
2081

S081_BFERWASHDRTYPCT 15mins

SAP Sybase ASE
Network Packets

SAPSybaseASE_
2044

S044_AVGPACKSIZESNT 1 hour

SAPSybaseASE_
2045

S045_AVGPACKSIZERCVD 1 hour

SAP Sybase ASE
Objects
Performance

SAPSybaseASE_
2014

S014_OPENDBREMCNT 15mins

SAPSybaseASE_
2049

S049_BLOCKEDOBJNUM 15mins

SAPSybaseASE_
2054

S054_OPNOBJCTSUSDPCT 15mins

SAP Sybase ASE
Parallel Processing

SAPSybaseASE_
2064

S064_WORKRPROCESRATE 15mins

SAPSybaseASE_
2065

S065_PARALLELQRYRATE 15mins

SAPSybaseASE_
2066

S066_ESQREQUESTRATE 15mins

SAPSybaseASE_
2067

S067_WRKRPRCRQDENPCT 15mins
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Aspects
Policy Template /
Collection Name Metrics

Collection
Interval

SAPSybaseASE_
2068

S068_WRKRMMRQFAILPCT 15mins

SAPSybaseASE_
2069

S069_PQRUNTADJUSTPCT 15mins

SAP Sybase ASE
Process Activity

SAPSybaseASE_
2039

S039_FULLULCFLUSHPCT 15mins

SAPSybaseASE_
2055

S055_BLOCKDPROCESSES 15mins

SAPSybaseASE_
2062

S062_LOGSEMAWAITPCT 15mins

SAPSybaseASE_
2079

S079_COMMXACTSCNT 15mins

SAP Sybase ASE
Query
Performance

SAPSybaseASE_
2027

S027_ACTIVCURSORSCNT 15mins

SAPSybaseASE_
2043

S043_HEAVYSQLNUM NORUN
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Send documentation feedback
If you have comments about this document, you can contact the documentation team by email. If an
email client is configured on this system, click the link above and an email window opens with the
following information in the subject line:

Feedback on User Guide (OMi Management Pack for SAP Sybase ASE 1.00)

Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a webmail client, and
send your feedback to docfeedback@hpe.com.

We appreciate your feedback!
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