Unable to access ALM 11.52 in Windows XP with IE 8

  • KM01162643
  • 16-Sep-2014
  • 16-Sep-2014

This document has not been formally reviewed for accuracy and is provided "as is" for your convenience.

Summary

Below is the message we get when trying to access ALM11.52 on a XP machine which has IE 8.0 (with non-admin users only). "Initialization has failed. Contact your system administrator. For details, see the Loader log file". Failure details: https:///qcbin/setup_a.cab - This file has no digital signature or signature cannot be validated".

Error

"Initialization has failed. Contact your system administrator. For details, see the Loader log file".

Failure details:

https://<servername>/qcbin/setup_a.cab - This file has no digital signature or signature cannot be validated".

Cause

We found below error message from Loader log file:

 “The cryptographic operation failed due to a local security option setting”

Fix

Changed values of HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing to the value specified in below article, and deployment worked fine.

http://blogs.msdn.com/b/spatdsg/archive/2006/06/05/618082.aspx

The following information can give more details about ALM deployment:
- As part of ALM client deployment and execution, ALM will check digital signature of the downloaded files.
Actually it is two step procedure:
1. Verify digital signature of the file using standard Windows API function
2. Checking if the certificate is no revoked also using standard Windows API function.

Hence, ALM user should be allowed to perform both these actions.

Looking on the information from the article: the value of the key Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing contains the flag:
#define WTPF_ALLOWONLYPERTRUST      0x00040000  // allow only items in personal trust database

Customer should check if required certificates exists in that database for the non-admin user. If don't exits, customer can add it or change the value of the flag. Customer's IT/Security personal should check the issue.