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Chapter 1: Getting Started with HP Deployment 
Management
 l "Introduction to HP Deployment Management" below

 l "Overview of an HP Deployment Management Process" below

 l "Related Documents" on page 16

Introduction to HP Deployment Management
HP Deployment Management is an Project and Portfolio Management Center (PPM Center) product 
that automates the migration and deployment of software code, configurations, and content. HP 
Deployment Management groups these objects into packages and routes the packages along business 
processes modeled in HP's configurable workflow. The workflow automatically moves each package 
through required steps, which typically include system build, testing, quality assurance, staging, and 
final deployment. 

HP Deployment Management automatically deploys the application components (such as XML 
content, HTML files, Java™ programs, and Oracle  application configurations) that each package 
requires. For example, HP Deployment Management connects to the development environment, 
copies Java files from the version control repository, and transfers the files to the quality assurance 
environment. It then uses the Java compiler to compile and pack all of the files into a single Java 
program. The customer can use a built-in scheduler to schedule deployments. HP Deployment 
Management maintains an audit trail for all activities, including package information, application 
components altered, approvals obtained, and deployments performed. 

Overview of an HP Deployment Management Process
HP Deployment Management is an enterprise application designed to deploy and audit software 
changes to mission-critical applications. It does this by gathering all information required for a 
successful deployment (for example, information on environments and objects to be migrated) into a 
single logical unit called a package.  

The package is the fundamental work unit in HP Deployment Management. A package consists of the 
objects that are processed through a business workflow. This results in a successful, easy-to-track 
software change. 
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Figure 1-1.HP Deployment Management overview 

 

A package consists of a group of objects, each of which belongs to an object type. Each object type is 
associated with a set of parameters that defines the information the package requires, and any 
additional information it can accept.

For a more complete overview of packages, see "Understanding Packages" on page 17.

For example, the File Migration object is a standard object type that copies files (objects) from one 
environment to another.

Figure 1-2. A package

 

Although each package line can be acted upon separately, the group of package lines and objects 
represent a logical unit that is moved and tracked as a unit. The way a package is processed depends 
on the specific workflow applied to it. "Figure 1-3. Sample package in the Package window   " on the 
next page shows a sample package in the Package window of the Package Workbench.
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Figure 1-3. Sample package in the Package window 
 

 

A workflow represents the business process associated with the package. Workflows consist of a 
logical series of steps that define the path that the objects in a package follow. Some of those workflow 
steps might represent decision-making processes; for example, code reviews and management 
approvals. Usually, at least one workflow step represents, or actually performs, the migration of the 
objects from one environment to another environment. 

In "Figure 1-4. Package workflow" on the next page, the workflow step Migrate to Test represents the 
migration of package objects from one environment to another. The workflow steps Design Review and 
Evaluate represent business package-related decisions.
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Figure 1-4. Package workflow

 

HP Deployment Management Terms and Concepts

 l "Standard Interface, PPM Workbench, and HP Deployment Management " below

 l "Packages and Object Types " on the next page

 l "Workflows and Workflow Steps " on page 12

 l "Releases" on page 13

 l "HP Deployment Management Environments" on page 13

 l "Integrating HP Deployment Management" on page 15

Standard Interface, PPM Workbench, and HP Deployment 
Management 

HP Deployment Management provides two different interfaces for working with packages. In the 
standard interface, HP Deployment Management provides the package detail page. In the PPM 
Workbench, HP Deployment Management provides the Package Workbench. Although these two 
interfaces have common functionality, a package detail page does not have all of the functionality of 
the Package Workbench. 
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The key difference between the Package Workbench and the detail page for a package is that you can 
use the Package Workbench to add package lines and submit a package. You cannot add package 
lines and submit a package from a detail page. 

The Package Workbench is designed to allow engineers or developers to create and submit packages. 
Creating and submitting packages requires specialized knowledge. In some cases, it requires 
passwords to production servers. Some of this information is not available to the resources making 
decisions about a package. Additionally, not everyone who makes decisions about a package requires 
access to the PPM Workbench. 

Note: For instructions on how to create and submit packages to deploy software and application 
changes, see "Creating Packages" on page 37.

From a package detail page, and with the required permissions, you can process a package through its 
workflow. You can add notes and references to the package and make decisions about package 
status. However, you cannot change or delete a package from the detail page. 

Note: For information about the licenses and access grants required to work with packages in HP 
Deployment Management, see the Security Model Guide and Reference. For information on how 
to move packages through their associated workflows, see "Processing Packages" on page 70. 
For instructions on how to work with (copy, cancel, merge, and so on) packages, see "Managing 
Packages" on page 98.

Packages and Object Types 

Packages are the fundamental work units of HP Deployment Management. A package consists of the 
objects that are processed through a business workflow. 

While each package line can be acted upon separately, the group of package lines and objects 
represent a logical unit that should be moved and tracked together. The processing of a package and 
package lines can vary greatly depending upon the workflow specified for that package. "Figure 1-5. 
Sample package in the Package window " on the next page shows a sample package in the Package 
window.
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Figure 1-5. Sample package in the Package window 

 

Each object belongs to an object type. An object type can also have associated commands that 
determine its behavior as it moves from one environment to another. Commands are used to define 
what a migration means for each type of object. For example, a File Object Type might only require that 
a file be copied, while a Database Script Object Type might require the copying of a file and executing it 
against the destination database.

Object types are user-configurable. HP Deployment Management and its extensions also provide 
libraries of predefined object types, falling under one of the following categories:

 l Standard Objects. Standard objects are predefined object types that are shipped with HP 
Deployment Management or one of the HP Deployment Management Extensions. These object 
types encapsulate the basic functionality that manages crucial actions; for example, migrating and 
executing file system-level objects and operating system commands, or applying patches to an 
Oracle applications instance. A standard object type is the File Migration object, which copies a file 
from one environment to another. A more complex standard object type is the SQL Script, which not 
only copies the file but also runs the script against the destination database.

 l Custom Objects. Customers must often customize standard object types, or produce entirely new 
object types, in order to handle the requirements of their software environments and deployment 
management processes. A custom objects category is provided to help distinguish these 
customized object types from those that come with HP Deployment Management or its extensions. 
Such object types, designed by the customer or by consultants, are often used for integration with 
third-party tools or in-house products.

 l PPM Center Migrator Objects. PPM Center migrator objects are object types that contain 
functionality to export and import configuration information. You can use these for several purposes, 
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including: 

 n To transfer configuration information between distinct PPM Center instances

 n To extract information from a PPM Center database schema into an XML file

 n To load information from an XML file into a database schema 

This means that you can migrate configuration information using standard deployment 
management test practices, processing a package through a workflow.

Workflows and Workflow Steps 

A workflow consists of a logical series of steps that define the path to be followed by objects in a 
package. Workflow configuration and routing can be customized, and the workflow engine can handle 
virtually any business practice. This allows a department to generate workflows to automate existing 
processes, rather than forcing users to adopt a new set of processes to perform their work.

Workflow steps can range in usage from functional approvals to actual migrations. For example, 
migration steps automatically move specified objects from source environments to destination 
environments.

Workflow steps are events that are linked together to form a complete workflow. HP Deployment 
Management uses the following four types of workflow steps: 

 l Decision workflow steps. In decision workflow steps, you or group of users must indicate a result 
or outcome; for example, work is approved or a review is completed. 

 l Execution workflow steps. In execution workflow steps, the system performs an action, and then 
updates the step with its result. The action can be as simple as calculating the value for a token, or 
as complex as copying files, running programs, or updating Web pages. 

 l Condition workflow steps. Condition workflow steps are logic steps used for complex workflow 
processing; for example, allowing a workflow to proceed only after all prerequisite steps are 
completed.

 l Subworkflow workflow steps. Subworkflow workflow steps are entire workflows that have been 
enabled for use as subworkflows. Subworkflows are useful time savers in modeling business 
processes that include predefined procedures.

"Figure 1-6. Package workflow" on the next page shows a sample package workflow.
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Figure 1-6. Package workflow

 

Releases

In HP Deployment Management, you can configure releases to group packages and related requests 
that must be deployed together. For example, the software company XYZ Corporation has a product 
update release scheduled for five months from now. To ensure successful product delivery, they 
decide to use HP Deployment Management to create a release that lets them track all changes to their 
original code. 

As developers complete their packages, the packages are included in the release and processed 
together. Because every required change is grouped in the release, the company can quickly and easily 
assess the product status and progress toward delivery.

For detailed information about releases, and how to create and configure them, see the HP Deployment 
Management Configuration Guide.

HP Deployment Management Environments

An HP Deployment Management environment is composed of a unique combination of server, client, 
database, and file system data that represent one logical group. 
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Figure 1-7. HP Deployment Management environment

 

The environment server represents the main host machine for the environment. This machine may be 
of any platform type; for example, UNIX  or Windows . Typically, the server is a UNIX machine that 
also hosts the database for this environment.

The environment client represents a remote client machine that also serves to identify the specified 
environment. The client is typically defined if users are doing multiplatform development in a 
client/server environment, with some development done on UNIX, and some on Windows Server. The 
client can be a file server that stores client code accessed by users. Many programs, such as 
transactional forms, have both client and server components; for example, the user interface code and 
the database objects, respectively. "Figure 1-8. Sample environment" on the next page shows an 
example of information displayed in the Environment window. 
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Figure 1-8. Sample environment

 

Integrating HP Deployment Management

Integration with Version Control

HP Deployment Management provides complete integration with all standard version control systems, 
including RCS, SCCS, PVCS, ClearCase, CCC/Harvest, and Visual SourceSafe. The HP 
Deployment Management outbound API provides all check-in, check-out, and promotion functions 
during deployment.

File system objects can be deployed to new installations and updated in version control 
simultaneously. This synchronizes your version control repository, physical installations, and HP 
Deployment Management workflows.

Integration with HP Demand Management

HP Deployment Management manages the physical deployment of changes to your application 
environment, but equally important, it also gathers and analyzes issues (requests) related to system 
stability. To facilitate this request gathering, HP Deployment Management is integrated with HP 
Demand Management.

Like HP Deployment Management, HP Demand Management is a workflow-based system that 
features complete audit trail tracking of requests from submission to closure. The tight integration 
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between HP Demand Management and HP Deployment Management allows packages to be 
automatically generated from requests. 

The requests are then automatically updated upon package completion. This closed-loop integration 
ensures a coherent and consistent view of issue status and removes the need for redundant data 
across multiple applications.

Integration with Third-Party Applications through HP Deployment Management 
Extensions

HP Deployment Management Extensions are application-specific modules that automate the 
deployment and post-deployment steps of objects, files, and patches. Extensions are fully integrated 
with HP Deployment Management to provide a total solution for managing various enterprise 
applications. The following extensions are available:

 l HP Deployment Management Extension for Oracle E-Business Suite

 l HP Deployment Management Extension for Oracle Technology

 l HP Deployment Management Extension for SAP Solutions

Related Documents
You can find related information in the following documents:

 l HP Deployment Management Configuration Guide

 l Commands, Tokens, and Validations Guide and Reference

 l Reports Guide and Reference

 l Security Model Guide and Reference

 l HP-Supplied Entities Guide
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Chapter 2: Understanding Packages
 l "About Packages " below

 l "Packages in Standard Interface" on page 20

 l "Packages in PPM Workbench " on page 23

 l "Reference Relationships " on page 31

About Packages 
HP Deployment Management automates the migration and deployment of software code, 
configurations, and content. These objects are grouped into packages and are routed along business 
processes (workflows) using the PPM Workbench and the standard interface. Workflows automate the 
movement of each package through their required steps. 

For example, you want to copy an operating system patch from the development environment, Dev, to 
the test environment, Test. After the operating system patch is thoroughly tested, you can copy the 
patch to production environment, Prod. 

Figure 2-1. Package processing in HP Deployment Management

 

A package is the fundamental work unit of HP Deployment Management. Each package follows a 
workflow (business process). As with any business process, decisions are made and actions taken 
that affect the package. Each decision or action becomes a workflow step. 
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If a decision on a package is required, you must manually update a workflow step to reflect that 
decision. However, you can configure some actions (for example, migrating a file from one environment 
to another) to occur automatically. The basic components required to configure a workflow step to 
automatically migrate a file from one environment to another environment are as follows:

 l A package, which defines the file name, location, and type, and the workflow to apply. 

 l A workflow, which determines the conditions that trigger file migration (workflow step), and the 
source and destination environments for the file migration. 

When you create a package, you assign it a single workflow that defines the steps the package must 
take. "Figure 2-2. Package workflow and workflow steps " below shows a sample workflow, with the 
following steps:

 l Approve Package

 l Dev to Test (migration)

 l Test Package

 l Test to Prod (migration)

 l Exit 

Figure 2-2. Package workflow and workflow steps 

 

You must perform the Approve Package and Test Package workflow steps manually during the course 
of the workflow. You configure the Dev to Test and Test to Prod workflow steps to run automatically. 

  

Note: To assign a workflow to a package, you do not need to know how to configure a workflow 
step, or even a workflow. However, you do need to know how to access the information in a 
workflow, workflow step, and environment. 

In "Figure 2-3. How a package comes together " on the next page, the package displayed in the 
Package Workbench is associated with a workflow in the Workflow Workbench. The migration 
workflow steps are configured with source and destination environments. You access and configure 
environments using the Environment Workbench. 
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The package in "Figure 2-3. How a package comes together " below is configured with a single 
package line, and then configured with an object type. A package line can contain only one object type. 
The object type contains the information required to migrate a file (an object), including the file name, 
location, and type (ASCII or binary). Depending on the object type definition, additional information may 
be required. 

Figure 2-3. How a package comes together 
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Object types are defined in the Object Type Workbench. In the Object Type Workbench, you can open 
and access the command sequence used to migrate the object across environments. These command 
sequences include special commands defined in the Special Command Workbench. 

To create a package, you must know the following:

 l Workflow. Defined in the Workflow Workbench.

 l Environments.Specified in the workflow step and defined in the Environment Workbench.

 l Object type.Defined in the Object Type Workbench.

For information about the licenses and access grants required to work with packages in HP 
Deployment Management, see the Security Model Guide and Reference.

Packages in Standard Interface
You can use the package detail page in the standard interface to view information for a package, add 
notes and references to the package, and process the package through its workflow. When you add a 
new package as a reference to a request, you do not access the Package window in the PPM 
Workbench. Instead, you access a New Package page in the standard interface. 

Creating a new package using the New Package page does not create a complete package that you 
can submit. Instead, the New Package page opens and saves a package in the standard interface. 
Before you can submit the package, you must use the Package window in the PPM Workbench to add 
package lines to it. "Figure 2-4. Package detail page " on the next page shows the detail page for a 
package that was created from the standard interface as a reference to a request, and contains no lines 
yet. 
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Figure 2-4. Package detail page 

Package Detail Page, Header Section 
On the detail page for a package, the Header section displays general information such as who created 
the package, the date it was created, and its associated workflow. "Figure 2-5. Package detail page, 
Header section " belowshows a typical Header section.

Figure 2-5. Package detail page, Header section 

Package Detail Page, Status Section 
The Status section on a Package detail page displays the current package status. After a package is 
first created in the standard interface, the Status section does not exist. After the package is 
submitted, the Status section displays the package lines and all of the steps in the associated 
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workflow. "Figure 2-6. Package detail page, Status section " below shows the Status section on a 
package detail page. 

Figure 2-6. Package detail page, Status section 

Package Detail Page, Notes Section 
The Notes section on a package detail page contains fields that you can use to provide package 
information that you want to store. The Notes section is included in the package creation process and 
continues with package until it is closed.

"Figure 2-7. Package detail page, Notes section" below shows a typical Notes section. All Notes 
sections include the Add Notes subsection. The Existing Notes section is created after the first note 
is created for the request. 

Figure 2-7. Package detail page, Notes section

Package Detail Page, References Section 
A package's detail page References section contains additional information about the package. For 
example, you might add a URL to a package or delete an outdated document from a package. The 
References section is included in the package creation process and continues with the package until 
the package is closed. References can be added or deleted from the package.

Use the Reference Additions section to add a reference to the package. Saved references are 
organized by reference type; for example, all saved reference packages are saved in the Packages 
section. For some references, a functional dependency between the package the referenced entity can 
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be created. For more information about references and their functional dependencies, see "Reference 
Relationships " on page 31. 

"Figure 2-8. Package detail page, References section" below shows the References section on the 
Package detail page. 

Figure 2-8. Package detail page, References section

Packages in PPM Workbench 
You can use the Package Workbench to view existing packages. From a Package window, you can 
add notes and references to the package, and process the package through its workflow. From the 
Package window, you can create and submit a package, process it through its workflow, cancel it, or 
delete it. "Figure 2-9. Package window" on the next page shows the detail page for a package.
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Figure 2-9. Package window

 

Package Window, Package Information Section 
The Package Information section of the Package window displays general information about the 
package; for example, who created the package, the date, and the associated workflow. The Package 
Information section is included in the package creation process and stays with the package. 
Typically, when creating a package, you must complete some fields in this section. "Figure 2-10. 
Package window, Package Information section" on the next page shows a typical general information 
section. The information in a package's detail page Header section is found in the Package window's 
general information section. 
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Figure 2-10. Package window, Package Information section

 

Package Window, Package Lines Tab 
The Package Lines tab lists the package lines associated with a package. Package lines define the 
object migrating from one environment to another environment. Each package line defines one object 
(file). Typically, objects (files) are defined by their object type (for example, File Client > Client or File 
Migration), filename, location, and file type. You cannot define multiple objects on a single package 
line. "Figure 2-11. Package window, Package Lines tab " on the next page shows the Package Line 
tab with package lines displayed. 
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Figure 2-11. Package window, Package Lines tab 

 

Package Window, Status Tab 
The Status tab in the Package window displays the current package status. When a package is first 
created, the Status tab displays the package lines. After the package is saved or submitted, the Status 
tab displays the package lines and all of the workflow steps in the associated workflow. 

Use the Status tab to view:

 l All the possible actions that can be performed on the package

 l All the actions performed to date

 l Pending actions that must be performed to resolve the package 

After a package is submitted, you can use the Status tab to process it through the workflow. Each 
package line includes all of the steps in the workflow. If a workflow step is eligible for action, the Initial 
Approval field for that step displays the value Eligible ("Figure 2-12. Package window, Status tab " on 
the next page). 
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Figure 2-12. Package window, Status tab 

 

After a package is submitted, you can expand a package line to display any of the subworkflow steps 
defined in the workflow. To view the subworkflow steps, above the subworkflow step, click Expand.

To expand all subworkflows on the Status tab, click Expand All. To hide expanded subworkflow 
steps, above the subworkflow step, click Collapse. To hide all subworkflow steps, click Collapse All. 
Clicking Expand expands the package line horizontally to display all of the steps within the 
subworkflow. 

The header text for subworkflow steps is displayed in a different color than the header for workflow 
steps. The step numbering includes additional decimal places to indicate the level of the workflow. For 
example, if step 3 of a top-level workflow is a subworkflow, its steps are numbered as 3.1, 3.2, 3.3, and 
so on. Similarly, if the second step in that subworkflow is also a subworkflow step, its steps are 
numbered as 3.2.1, 3.2.2, 3.2.3, and so on. 

From the Status tab, you can access several log files, a graphical view of the workflow, transaction 
histories, and detail files related to the package. Use these files, views, and histories to help you as 
you process your package. 

Accessing Line Execution Log

You can select a package line and get the details of the execution of that particular line by viewing the 
line execution log. The line viewed is a subset of the overall execution batch log. 
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If the package line has been configured to migrate to multiple environments using an environment 
group, the execution log returns an execution summary and link for each destination environment. To 
view the detailed execution log for an environment, click the associated link.

Accessing Package Execution History

The Package Execution History displays the execution history of each package line. It displays the 
workflow step name, execution date, and outcome (Succeeded or Failed) of each execution step. 

If the package line has been configured to migrate to multiple environments using an environment 
group, the execution log returns an execution summary and link for each destination environment. Click 
the link to get the detailed execution logs for each environment.

Graphical View 

To view the workflow, select the Graphical View window ("Figure 2-13. Graphical View window for a 
package" below). Use the legend at the top of the window to determine which workflow steps have 
been visited and which steps are active. This image displays all of the workflow steps and 
subworkflows used in the workflow definition. 

To obtain a graphical view of a particular subworkflow, select the subworkflow name from the Show 
Subworkflow Step list at the bottom of the window. This opens a new window that displays the 
graphical view of that subworkflow.

Figure 2-13. Graphical View window for a package
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Viewing Line Permissions 

Workflow permissions are established during the initial workflow configuration. The Line Permissions 
view lists all users in security groups that have been enabled for the related workflow step. If you have 
questions regarding the permissions set for a particular workflow step, see your application 
administrator.

Viewing Line Transaction History 

You can view the transaction history of each package line. This provides detailed information on how 
the package line has proceeded through an HP Deployment Management workflow. Information; for 
example, as the date of the transaction event, the user linked to the workflow step, the workflow step 
name and number, status, and results are displayed. 

To display information on the subworkflow steps that have been traversed more than once by a single 
package line, select Full transaction history.  

Selecting Current transaction status displays only information on the most recent transaction up 
through that step.

Viewing Decision Detail 

The Decision Detail displays the decision history of each workflow step. It displays the date, resource, 
and decision of the decision workflow step. 

Viewing Workflow Step Information URL 

Workflow steps can be configured to include a URL that provides information regarding the workflow 
step. If you administrator has linked an informational URL to a workflow step, you can view the URL in 
the Workflow Step Information URL window.

Package Window, Notes Tab 
The Notes tab in the Package window ("Figure 2-14. Package window, Notes tab " on the next page) 
contains fields where notes on and information about the package can be entered and stored. The 
Notes section is included in the package creation process and continues with the package until it is 
closed. Typically, when creating a package, you do not need to add a note to the package. 
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Figure 2-14. Package window, Notes tab 

 

Package Window, References Tab
A package window's References tab ("Figure 2-15. Package window, References tab " on the next 
page) displays additional information about the package. For example, you might add a URL to a 
package or delete an outdated document from a package. The References tab is included in the 
package creation process and continues with the package until the package is closed. You can add 
references to or delete them from the package.

Use the Reference Addition section to add a reference to the package. Saved references are 
organized by reference type; for example, all saved reference packages are saved in the Packages 
section. For some references, a functional dependency between the package and the referenced entity 
can be created. For more information about references and their functional dependencies, see 
"Reference Relationships " on the next page. 
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Figure 2-15. Package window, References tab 

 

Reference Relationships 
For some references, you can create a functional dependency between the package and the referenced 
entity. For example, you can specify that a request is a predecessor to the package. This means the 
package cannot continue until the request is closed. 

 l Predecessor Relationships. Predecessor relationships dictate that action is not allowed on one 
entity until the referenced entity closes. For example, a package cannot complete any workflow 
action until the referenced task is closed (Completed, Bypassed, or Cancelled). The package 
status is Pending Task. After the task closes, the package can be acted upon after more. This 
does not stop other request fields from being edited. 

 l Successor Relationships. Successor relationships dictate that action is not allowed on the 
referenced entity until the entity closes. For example, a referenced task cannot change status until 
the original package is closed. The task status is Pending Request. When the package closes, 
the task can again be changed. This does not prevent other task fields from being edited. 
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 Table 2-1 lists the references, their definitions, and possible dependency relationships. 

Reference 

Reference

Description 

Possible

Relationships

Relationship

Description

Attachment Attach a file from a local machine to the current 
package. The attached file is copied to the 
server. 

Standard 
attachment 
interaction

(Informational) 
The attachment 
is related to this 
package.

Packages 
(Existing)

Reference an existing package. Duplicate 
package

(Informational) 
The referenced 
package is a 
duplicate of the 
package.

Run before 
this package in 
a release

(Informational) In 
a release, the 
selected 
package must be 
run before this 
package. 

Run after this 
package in a 
release

(Informational) In 
a release, the 
selected 
package must be 
run after this 
package. 

Predecessor (Blocking) Action 
is not allowed on 
the package until 
the referenced 
package closes.

Successor (Blocking) Action 
is not allowed on 
the referenced 
package until the 
package closes. 

Table 2-1. References and relationships
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Reference 

Reference

Description 

Possible

Relationships

Relationship

Description

Packages 
(New)

New packages can also be created from a 
package.

If configured as part of the workflow, you can 
spawn a package from a workflow step. When 
this happens, a reference to that package is 
automatically generated, establishing a two-way 
link between the packages. 

Run before 
this package in 
a release

(Informational) In 
a release, the 
selected 
package must be 
run before this 
package. 

Run after this 
package in a 
release

(Informational) In 
a release, the 
selected 
package must be 
run after this 
package. 

Predecessor (Blocking) Action 
is not allowed on 
the package until 
the referenced 
package closes.

Successor (Blocking) Action 
is not allowed on 
the referenced 
package until the 
package closes. 

Programs Reference a program in HP Program 
Management. 

Related to 
This program 

(Informational) 
Selected 
program is 
related to this 
package.

Projects Reference a project in HP Project Management. Related to 
This package 

(Informational) 
Selected project 
is related to this 
package.

Releases Reference a release in HP Deployment 
Management.

Contains this 
package

(Informational) 
The package is 
contained in the 
selected release.

Table 2-1. References and relationships, continued
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Reference 

Reference

Description 

Possible

Relationships

Relationship

Description

Request 
(Existing)

Reference an existing request. Parent of this 
package

(Informational) 
The referenced 
request is the 
parent of the 
package.

Related to this 
package

(Informational) 
Referenced 
request is related 
to this package. 

Predecessor (Blocking) Action 
not allowed on 
this package 
until the 
referenced 
request closes.

Successor (Blocking) Action 
not allowed on 
the referenced 
request until this 
package closes.

Table 2-1. References and relationships, continued
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Reference 

Reference

Description 

Possible

Relationships

Relationship

Description

Requests 
(New)

New packages can be created from existing 
packages.

Also, if configured as part of the workflow, you 
can spawn a package from a package. When this 
happens, a reference to that package is 
automatically generated, establishing a two-way 
link between the packages. 

Parent of this 
package

(Informational) 
The referenced 
request is the 
parent of the 
package.

Related to this 
package

(Informational) 
Referenced 
request is related 
to this package. 

Predecessor (Blocking) Action 
not allowed on 
this package 
until the 
referenced 
request closes.

Successor (Blocking) Action 
not allowed on 
the referenced 
request until this 
package closes.

Tasks Reference a task in HP Project Management. Related to this 
package

(Informational) 
The referenced 
task is related to 
this package.

URL Reference a Web address. Documents at the 
URL must be in MIME format. 

Standard URL 
interaction

(Informational) 
The URL is 
related to this 
package.

Table 2-1. References and relationships, continued

Predecessor Relationships 
Predecessor relationships dictate that action cannot be performed on one entity until the referenced 
entity closes. For example, a package cannot complete any workflow action until the referenced task is 
closed (Completed, Bypassed, or Cancelled). The package status is Pending Task. After the 
referenced task closes, the package can be acted on again. This does not prevent the editing of other 
request fields. 
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Successor Relationships 
Successor relationships dictate that action is not allowed on a referenced entity until the entity closes. 
For example, a referenced task cannot change its status until the original package is closed. The task 
status is Pending Request. After the package closes, the task can be acted on. This does not stop 
other task fields from being edited. 

HP Deployment Management User's Guide
Chapter 2: Understanding Packages

HP Project and Portfolio Management Center (9.30) Page 36 of 106



Chapter 3: Creating Packages
 l "Overview of Creating Packages" below

 l "Creating Packages" on page 43

 l "Entering General Information for Packages " on page 50

 l "Adding Lines to Packages " on page 50

 l "Adding Notes to Packages " on page 53

 l "Adding References to Packages from Package Workbench" on page 54

 l "Submitting Packages " on page 68

Overview of Creating Packages
This chapter provides instructions on how to create and submit packages to deploy software and 
application changes. Although you typically use the PPM Workbench to create packages, you can also 
create them by copying an existing package, or create them as referenced entities.

After you create a package, you must submit it to start the workflow (business process). For 
information on how to submit a package, see "Submitting Packages " on page 68.

Before You Create Packages
Before you create a package, make sure you understand the following:

 l Workflow. Defined in the Workflow Workbench.

 l Environments. Specified in the workflow step and defined in the Environment Workbench.

 l Object type. Defined in the Object Type Workbench.

Selecting Workflows 

Each package is processed through a predefined workflow. You must select a workflow to apply to 
each package you create. It is important that you route your packages through workflows that 
accurately model the appropriate business process.

To view the graphical layout of an HP Deployment Management workflow:
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 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Configuration > Workflows. 

The Workflow Workbench window opens.

 4. To display all of the workflows, in the Workflow Workbench, click List.  

Note: To restrict your search, you would specify one or more of the query parameters.

The Results tab lists all workflow records.

 5. Select a workflow for which the Workflow Scope column displays Packages, and then click 
Open.  

The Workflow <Workflow Name> window opens to the Layout tab, which displays a graphical 
representation of the workflow steps. 
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Check to ensure that the workflow follows the correct business process for your package. If it 
does not, open a different workflow. 

 6. Double-click a migration workflow step. For example, Migrate to Test or Migrate to Prod. 

The Workflow Step window for that step opens to the Properties tab.

 7. Verify that the source and destination environments listed on the tab are correct. 

 

 8. To view additional information in the Workflow Step window, click the following tabs:

 n Security. Use to define the security groups allowed to act on the selected step. All enabled 
security groups are displayed in either the Available Security Groups field or the Linked 
Security Groups field. Each user who belongs to a linked security group can perform the 
actions defined for that particular workflow step. 

 n Segregation of Duties. Use to specify workflow steps to be segregated from the selected 
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step in the workflow. This segregation prevents a given user from acting on both steps in the 
workflow. For example, you might use it to prevent the person who requests a change from 
then deploying that change to the production system without approval from a third party.

You can also use this tab to specify that the package creator cannot act on the selected 
workflow step. 

 n Notifications. Use to attach email notifications to the workflow step. Email messages can be 
sent whenever a particular event (for example, the step completes with a specific result) 
occurs at the step.

 n Timeout. This tab displays timeout intervals set for this workflow step.

 n User Data. This tab displays any custom fields for each workflow step.

 n Results. This tab lists all of the possible valid results for the step.

 9. Close the Workflow Step window. 

Verifying Environments 

Some workflow steps include specify source and destination environments. If you are not sure the 
specified environments are correct, you can open them in the Environment Workbench.

To access an environment:

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Environments > Environments. 

The Environment Workbench opens.

 4. To display all of the environments, click List.

To restrict the search, specify one or more query parameters.

The Results tab lists the environment records.

 5. Select one or more of the listed environments, and then click Open. 

The Environment <Environment Name> window opens.

 6. Check the settings for the server, client, and database. 

 7. Close the Environment window.
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Verifying Object Types 

When creating a package, the available object types are displayed in an auto-complete list. To view the 
available object types before you start to create a package, you can open an object type in the Object 
Type Workbench. "Table 3-1. Object types" below lists the HP-supplied object types.

Note: The HP Deployment Management Extensions provide additional object types. 

Object Type Description

File Client>Client File copy from client to client.

File Migration File copy from environment to environment.

PPM Data Source 
Migrator

Migrates a PPM Center data source migrator. 

PPM Module 
Migrator

Migrates a PPM Center module from one PPM Center environment to another 
PPM Center environment. 

PPM Object Type 
Migrator

Migrates a PPM Center object type from one PPM Center environment to 
another PPM Center environment. 

PPM Overview 
Page Section 
Migrator

Migrates a PPM Center overview page section from one PPM Center 
environment to another PPM Center environment. 

PPM Portlet 
Definition Migrator

Migrates a PPM Center portlet definition from one PPM Center environment to 
another PPM Center environment. 

PPM Project 
Template Migrator

Migrates a PPM Center project template from one PPM Center environment to 
another PPM Center environment. 

PPM Report Type 
Migrator

Migrates a PPM Center report type from one PPM Center environment to 
another PPM Center environment. 

PPM Request 
Header Type 
Migrator

Migrates a PPM Center request header type from one PPM Center 
environment to another PPM Center environment. 

PPM Request Type 
Migrator

Migrates a PPM Center request type from one PPM Center environment to 
another PPM Center environment. 

PPM Special 
Command Migrator

Migrates a PPM Center special command from one PPM Center environment 
to another PPM Center environment. 

PPM User Data 
Context Migrator

Migrates a PPM Center user data context from one PPM Center environment 
to another PPM Center environment. 

Table 3-1. Object types
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Object Type Description

PPM Validation 
Migrator

Migrates a PPM Center validation from one PPM Center environment to 
another PPM Center environment. 

PPM Workflow 
Migrator

Migrates a PPM Center workflow from one PPM Center environment to 
another PPM Center environment. 

OS/390 JCL 
Migration

Migrates an OS/390 JCL from a source environment to the destination 
environment. 

PVCS File 
Migration

Migrates an object from the PVCS archive to the destination environment. 

RCS File Migration This object manages the check out and distribution of code in RCS. 

RCS Server File Old file will be checked in on the destination environment. New file will be 
checked in and checked out Read-Only on the destination environment.

SourceSafe File 
Migration

Manages the check out and promotion of files from the SourceSafe version 
control archive. 

Table 3-1. Object types, continued

Opening an Object Type

To open an object type:

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Object Types. 

The Object Type Workbench window opens to the Query tab.

 4. To display all object types, click List.  

To restrict the search, specify one or more query parameters.

 5. Select one or more of the listed object types, and then click Open.  

The Object Type <Object Type Name> window opens.

 6. Click the Commands tab. 

 7. Check the commands that the object type calls.

 8. Close the Object Type <Object Type Name> window.
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Creating Packages
Although you typically use the PPM Workbench to create packages, you can also create one by 
copying an existing package, or by creating a new package as a referenced entity. This section 
provides information about how to use all three methods.

Creating Packages Using PPM Workbench
Packages are used to deploy software and application changes. This section covers how to define the 
contents of a package, including adding package lines and specifying the appropriate deployment 
workflow. For each instance of a software migration submission, a new package needs to be created. 

To create a package from the PPM Workbench: 

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens. 

 4. Click New Package.  
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The Package window opens. 

 

 5. In the Package Information section, complete the fields. 

For information on how to complete the fields in section, see "Entering General Information for 
Packages " on page 50. 

 6. On the Package Lines tab, add the package lines to the package. 

Package lines capture information specifically related to each object that you are migrating from 
one environment to another environment. For information on how to add package lines, see 
"Adding Lines to Packages " on page 50. 

 7. On the Notes tab, add any notes to the package. 

For information on how to add notes, see "Adding Notes to Packages " on page 53. 

 8. On the References tab, you can add references to the package. 

For information on how to add references, see "Adding References to Packages from Package 
Workbench" on page 54. 

 9. To save the package and close the Package window, click OK. To save the package and leave 
the Package window open, click Save.
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Creating Packages by Copying Existing Packages 
You can create a package by copying an existing package (either new or saved). You can specify 
which sections of the existing package you want to include in the new package. 

To create a package from an existing package: 

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

 4. On the Query tab, click List.  

The Package Workbench Results tab lists all existing packages. 

 5. On the Results tab, select a package, and then click Copy.  

The Copy Package window opens to the Options tab. "Table 3-2. Copy package options" on 
page 47 lists the options available on the tab.
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 6. Select the sections to include in the new package, and then click the Details tab.

 

The Details tab lists all of the package lines that were copied from the original package. By 
default, all of these lines are included in the new package.

 7. To exclude a listed package line from the new package:

 a. In the Package Lines to Copy table, select the line.

 b. At the bottom of the tab, click Exclude.

The Package window opens and displays the information you selected from the copied 
package.

 8. To view the parameters that describe a listed package line:

 a. In the Package Lines to Copy table, select the line.

 b. At the bottom of the tab, select the Show Parameters checkbox.

Additional columns in the Package Lines to Copy table display the package line parameters.

 c. To view all of the parameters, use the horizontal scroll bar.

 9. Click OK.
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Option Description

Copy 
Package 
Lines

Copies all of the package lines (with a status other than Closed or Cancel) in the 
existing package into the new package. The default is Yes.

Copy 
Closed 
Lines

Copies all of the closed package lines in the existing package into the new 
package. The default is Yes.

Copy 
Cancelled 
Lines

Copies all of the cancelled package lines in the existing package into the new 
package. The default is No.

Copy 
Header's 
Notes

Copies all of the notes attached to the existing package to the new package. 
Defaults to No.

Copy 
Header's 
User 
Data

If applicable, copy the user data from the existing package to the new package.

Submit 
New 
Package

After the package is copied, submit the package. The default is No. If you select 
No, your package is not submitted. To submit the package, you must open the 
copied package and click Submit.

Table 3-2. Copy package options

Creating Packages as References from Packages 
You can create a new package as part of referencing a new package to an entity such as a request or 
another package. 

To create a new package as a reference to an existing package:

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens to the Query tab.

 4. Use the available fields to provide your search criteria, and then click List.  

The Results tab lists the packages that match your search criteria. 
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 5. Double-click the row for the package you want to open.

The Package window opens.

 6. Click the References tab. 

 7. From the New Reference list at the bottom on the tab, select Package (New), and then click 
Add.

The New Reference - Package (New) window opens. 

 

 8. Under Select the Relationship that the selected Package has to Package # <Package 
Number>, select the option that describes the relationship that the new package is to have to the 
existing package, and then click Create.

A new Package window opens.

For descriptions of the possible relationships between referenced entities, see "Table 2-1. 
References and relationships" on page 32.

 9. Provide all required information, and any optional information you want to associate with the new 
package, and then click OK or Save.

 10. In the Package window that displays the original package, click OK.

Creating Packages as References from Requests 
You can create a package as a reference from a request. When creating a package from a request, you 
do not open the PPM Workbench, even if you have the correct permissions. Instead, you work in the 
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standard interface using the Create New Package and New Package pages. When you create a 
package as a reference from a request, you cannot add package lines, which means you cannot 
complete and submit the package. Adding package lines to a package and submitting a package 
requires using the Package Workbench. 

To create a package as a reference from a request: 

 1. Log on to PPM Center. 

 2. From the menu bar, select Open > Demand Management > Search Requests.

 3. Locate, and then open a request.

You can open an existing request or create a new request from the menu bar. For information 
about how to open an existing request or create a request, see the HP Demand Management 
User’s Guide. 

The detail page for the request opens. 

 4. In the request's detail page, scroll to the References section.

 5. From the New Reference list, select Package (New), and then click Add.

The Create New Package page opens.

 

 6. Select the relationship, and then click Create. 

The New Package page opens. 

 7. Select the workflow from the list. 

 8. Type any optional information that you want to keep as part of the record in the Notes tab, and 
then click Save.

 9. On the detail page for the request, click Save.
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Entering General Information for Packages 
To complete the general information section for packages: 

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

 4. From the Query tab, click New Package.  

The Package window opens. You use the Package window to define the package contents. The 
package number is assigned automatically. 

 5. Complete the required fields.

 6. Select the workflow from the auto-complete list.

 7. In the Package window, click OK or Save.

The package line is added to the package. 

Adding Lines to Packages 
Package lines define the object migrating from one environment to another environment. Each package 
line defines just one object (often a file). Typically, objects are defined by their object type (for example, 
File Client > Client or File Migration), name, location, and, in the case of files, file type. 

To add a line to package: 

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

 4. Open or create a new package. 

HP Deployment Management User's Guide
Chapter 3: Creating Packages

HP Project and Portfolio Management Center (9.30) Page 50 of 106



The Package window opens. 

 5. Click New Line.

The Add Line window opens.

 6. In the Object Type field, select the object type for the object (file) you plan to migrate using the 
auto-complete icon. 

Selecting an object type dynamically updates the fields in the Add Line window. 

 

 7. In the Add Line window, complete the associated fields, and then click OK.

In some cases, you can add multiple package lines from a single Add Line window. You can do 
this when you have multiple objects (files) to migrate that are in the same location. 

To add multiple lines from a single Add Line window, the following must be true: 

 n Package lines all follow the same workflow and use the same object type. 

 n The object type parameters include at least one auto-complete list field with an enabled Multi 
button.
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By selecting multiple files, you add multiple package lines to the package. Remember, you 
cannot define multiple objects on a single package line. 

 

The contents of the Add Line window are included in the Packages window as a package line. 
The Add Line window closes. In the Add Line window, clicking Add includes the package line 
in the Package window and the Add Line window remains open. 
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 8. In the Package window, click OK or Save.

The package line is added to the package. To start the package on its associated workflow, click 
Submit. Submitting the package to the workflow generates entries under the Status tab for each 
of the workflow steps defined for the workflow. As each step in the workflow is ready to be 
processed, the step shows an Eligible status. You can view the progress of each package line by 
clicking the Status tab. For information about how to submit a package, see "Submitting 
Packages " on page 68. 

Adding Notes to Packages 
In the Package window, the Notes tab ("Figure 3-1. Package window, Notes section " on the next 
page) displays additional package information. Notes are attached to the package, and not to individual 
package lines. If you have a note that is specific to a package line, you must include the package line 
reference as part of the note text. 
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Figure 3-1. Package window, Notes section 

 

You can add notes to existing packages, packages you are creating, and to submitted packages that 
have not been closed. You cannot add a note to a closed package. 

To add a note, open a package and click the Notes tab. In the New Notes field, type the text of the 
note, and then click Save. The note is added to the Existing Notes field. 

Adding References to Packages from Package 
Workbench
You can use the References section of the package detail page to add references of several types to a 
package. For example, you might want to add a document or URL to a package. You can add the 
following types of references to a package: 

 l Attachments

 l Packages (new and existing)

 l Projects

 l Releases

 l Requests (new and existing)
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 l Tasks

 l URLs

For some references (such as requests and other packages), you can create a functional dependency 
to the original package. For example, you can specify that a request is a predecessor to the package. 
This means the package cannot continue until the request is closed. For a list of the references and 
their possible dependency relationships, see "Reference Relationships " on page 31. 

This section provides details on how to use the Package Workbench to add the different entity types as 
package references. For information on how to add package references from the standard interface, 
see "Adding References to Packages from Standard Interface" on page 75.

Adding Attachments as Package References
This section provides the steps you use to add an attachment as a package reference.

To add an attachment as a package reference:

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

 4. Open a package. 

 5. In the Package window, click the References tab. 
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 6. From the New Reference list, select Attachment., and then click Add.  

The Add Document window opens. 

 

 7. Attach the file, complete the fields, and then click Add.  

The References tab lists the attachment.
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 8. Click OK or Save.  

Adding Existing Packages as Package References 
To add an existing package as a reference to a package:

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

 4. Open a package. 

 5. In the Package window, click the References tab. 

 6. From the New Reference list, select Package (Existing), and then click Add.  

The New Reference - Package (Existing) window opens. 

 

 7. Under Select the Relationship that the selected Package has to Package <Package 
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Number>, select the option that describes the relationship that the packages have to the open 
package.

 8. Select the existing packages from the Package No. auto-complete list. 

The Package No field displays the number of the package you selected.

 9. Under Select the Relationship that the selected Package has to Package <Package 
Number>, select the option that describes the relationship that the packages have to the open 
package, and then click OK.  

The References tab lists the selected packages.

 10. Click OK or Save.

Adding New Packages as Package References 
You can reference a new package to a package.

To create a package to add as a package reference:

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

 4. Open the package to which you want to add a reference. 

 5. In the Package window, click the References tab. 

 6. From the New Reference list, select Package (New), and then click Add.
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The New Reference - Package (New) window opens.

 

 7. Under Select the Relationship that the selected Package has to Package <Package 
Number>, select the option that describes the relationship that the new package is to have to the 
package you opened, and then click Create.  

A new Package window opens. 

 8. In the Workflow field, type the name of a workflow to apply to the new package.

 9. Type any other information you want to record in the Notes tab, modify any values that you want 
to change, and then click Save or OK.  

The References tab lists the new package reference. 

 10. Click Save to save the package.

Attaching Programs as Package References 
You can reference existing programs to a package. 

To reference an existing program:
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 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

 4. Open the package to which you want to add a reference. 

 5. In the Package window, click the References tab. 

 6. From the New Reference list, select Program, and then click Add.

The New Reference - Program window opens.

 

 7. In the Program Name field, select the program from the auto-complete list.

The Program Name field displays the program you selected.

 8. Under Select the Relationship that the selected Program has to Package <Package 
Number>, select the option that describes how the program is related to the package, and then 
click OK.
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The References tab displays the program name. 

 9. Click Save to save the package.

Attaching Projects as Package References 
To attach a project as a package reference:

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

 4. Open the package to which you want to add a reference. 

 5. In the Package window, click the References tab. 

 6. From the New Reference list, select Project, and then click Add.  

The New Reference - Project window opens. 
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 7. In the Project Name field, select a project name from the auto-complete list. 

 8. Under Select the Relationship that the selected Project has to Package <Package 
Number>, select the option that describes how the project is related to the package, and then 
click OK.  

The References tab lists the selected project. 

 9. Click Save to save the package.

Adding Releases as References 
You can reference existing releases to requests. 

To reference a release:

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

 4. Open the package to which you want to add a reference. 

 5. In the Package window, click the References tab. 

 6. From the New Reference list, select Release, and then click Add.  
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In the Status section, the New Reference - Release window opens. 

 

 7. To specify a release name in the Release Name field, use the auto-complete list. 

 8. Under Select the Relationship that the selected Release has to Package <Package 
Number>, select the option that describes how the release is related to the package, and then 
click OK.

The References tab lists the release.

 9. Click Save to save the package.

Adding Existing Requests as Package References 
You can reference existing requests to requests. 

To reference an existing request:

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.
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The Package Workbench opens.

 4. Open the package to which you want to add a reference. 

 5. In the Package window, click the References tab. 

 6. From the New Reference list, select Request (Existing), and then click Add.  

The New Reference - Request (Existing) window opens. 

 

 7. To specify the request name in the Request No field, use the auto-complete list. 

 8. Under Select the Relationship that the selected Request has to Package <Package 
Number>, select the option that describes how the request is related to the package, and then 
click OK.

The References tab lists the existing request. 

 9. Click Save to save the package.

Adding New Requests as Package References 
You can create new requests and add them as package references. 

To reference a new request:
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 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

 4. Open the package to which you want to add a reference. 

 5. In the Package window, click the References tab. 

 6. From the New Reference list, select Request (New), and then click Add.  

The New Reference - Request (New) window opens. 

 

 7. To specify the type of request you want to create in the Request Type field, use the auto-
complete list. 

 8. Under Select the Relationship that the Request has to Package <Package Number>, select 
the option that describes how the new request is related to the package, and then click Create.

The Create New Request page opens in a new browser window. 
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 9. Complete all required fields (marked with a red asterisk).

 10. In the optional fields and in the Notes tab, type any additional information about the request you 
want to make available to users.

 11. Click Submit.  

In the Package window, the References tab lists the new request. 

 12. Click Save to save the package. 

Adding Tasks as Package References 
You can add existing tasks as references to packages. 

To reference an existing task:

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

 4. Open the package to which you want to add a reference. 

 5. From the New Reference list, select Task, and then click Add. 
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The New Reference - Task window opens. 

 

 6. To specify a task in the Task Name field, use the auto-complete list.

 7. Under Select the Relationship that the selected task has to Package <Package Number>, 
select the option that describes how the task is related to the package, and then click OK.

In the Package window, the References tab lists the task. 

 8. Click Save to save the package. 

Adding URLs as Package References 
You can reference a URL to a package. 

To reference a URL:

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.
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The Package Workbench opens.

 4. Open the package to which you want to add a reference. 

 5. In the Package window, click the References tab. 

 6. From the New Reference list, select URL, and then click Add.  

The New Reference URL window opens. 

 

 7. In the URL field, type the URL address. 

 8. To test the URL you specified, to the right of the URL field, click U.

 9. In the Description field, you can type a description or an explanation of how the URL is related to 
the package, and then click OK.

In the Package window, the References tab displays the URLs. 

 10. Click Save to save the package.

Submitting Packages 
After you complete a package, you can submit it. A complete package must have the following:

 l A package number

 l An associated workflow

 l At least one package line 
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In the Package window, if a package is complete and eligible for submission, the Submit button is 
enabled in the bottom left corner. 

To submit a completed package, click Submit.
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Chapter 4: Processing Packages
 l "Overview of Processing Packages" below

 l "Using Standard Interface to Process Packages" on the next page

 l "Opening Packages from Standard Interface" on the next page

 l "Approving Packages in Standard Interface" on page 72

 l "Adding Notes to Packages in Standard Interface" on page 74

 l "Adding References to Packages from Standard Interface" on page 75

 l "Processing Packages Using PPM Workbench " on page 87

Overview of Processing Packages
In HP Deployment Management, after a package has been submitted, you can process and manage it. 
Processing packages refers to working with the package as the package progresses through its 
workflow. 

You can locate packages that require attention using one of the following methods: 

 l Use the Package Workbench. Use the Query tab in the Package Workbench to specify search 
criteria to find a package. After the package is found, highlight the package and click Open. The 
selected package opens in the Package window. 

 l Use Portlets in the Standard Interface. The quickest way to locate relevant packages is through 
the standard interface. When included on a PPM Dashboard page, the My Packages portlet 
displays all the packages you have created or that are assigned to you. Click a package number to 
open the package in the standard interface.

 l Use Searches in the Standard Interface.  Using search in the standard interface is another way 
to find a package. In the standard interface, on the menu bar, select Search > Packages. The 
Package Search page opens. In the Package Search page, complete the search criteria, and then 
click Search. The Package Search Results page opens. In the Package Search Results page, 
click a package number to open the package in the standard interface. 

 l Use Notifications.  As a package proceeds through its workflow, email notifications can be sent to 
alert you of pending actions. The notification might include a link to the package. Click the link to 
open the referenced package in the PPM Workbench. If you are not currently logged on to PPM 
Center, the Logon page opens. 

 l Generate a Report on Open Packages (Standard Interface). HP Deployment Management 
includes a predefined set of reports that generate HTML text and can be accessed by a Web 
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browser. Among these reports is the Packages Pending Report, which reports on open packages 
with pending activity.

For information about generating and viewing HP Deployment Management reports, see the 
Reports Guide and Reference.

For detailed information on how to process packages in the standard interface, see "Using Standard 
Interface to Process Packages" below. 

Using Standard Interface to Process Packages
You can use the package detail page in the standard interface to process a package through its entire 
workflow. You can add notes and references to the package, and make decisions about package 
status. For information on how to process packages from the PPM Workbench, see "Processing 
Packages Using PPM Workbench " on page 87. 

Opening Packages from Standard Interface
This section provides information on how to open packages from the standard interface using the 
Search Packages page, using portlets, or using the package links in email notifications.

Opening Packages from Search Packages Page
To open a package using the Search Packages page:

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Deployment Management > Search Packages.

The Search Packages page opens.

 3. Provide your search criteria, and then click Search.

The Package Search Results page lists the packages that match the criteria you specified.

 4. In the Pkg # column, click the package number for the package you want to open.

The detail page for that package opens.

Opening Packages from My Packages Portlet
If the My Packages portlet is not displayed on one of your PPM Dashboard pages, you can add it. For 
information on how to add portlets to PPM Dashboard pages, see the Creating Portlets and Modules 
guide.
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To use the My Packages portlet to open a package that you have created or a package that is assigned 
to you:

 1. Log on to PPM Center.

 2. From the menu bar, select Dashboard, and then select the name of a PPM Dashboard page that 
displays the My Packages portlet.

The My Packages portlet lists all of the packages that you have created.

 3. On the My Packages portlet, in the Pkg # column, select the number for the package you want to 
open.

The detail page for that package opens.

Opening Packages Using Notification Links
In some cases, as a package moves through the steps in its workflow, email notifications are sent to 
alert you of pending actions for a package. If the notification includes a link to the package, click the 
link to open the referenced package in the PPM Workbench. (If you are not logged on to PPM Center, 
the Logon page opens.) 

Approving Packages in Standard Interface
To approve a package using the standard interface:

 1. Log on to PPM Center.

 2. Open the package that you want to approve.

For information on how to open the details page, see "Opening Packages from Standard Interface" 
on the previous page.
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The Status section displays the package lines for the workflow.

 3. In the Status section, next to View Lines, do one of the following:

 n To display only the package lines that are eligible for action, click Pending Lines Only, and 
then click Refresh.

 n To display all of the package lines for the workflow, click All Lines, and then click Refresh.

 4. In the Status section,next to View Steps, do one of the following:

 n To display only workflow steps that await action, click Steps Waiting my Action, and then 
click Refresh.  

 n To display all workflow steps, click All Steps, and then click Refresh.
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Under the workflow name are the numbered steps that must be completed and approved to 
move the workflow to completion. To navigate forward or backward through the workflow steps, 
use the directional arrows.

 5. In the View Eligible Steps for <Workflow Name> section, select the option button that 
corresponds to the numbered workflow step that you want to approve (or not), and then select the 
Eligible checkbox for the specific line you want to approve (or not).

To select all of the steps, click Check All.

To clear all eligible checkboxes for the workflow step, click Clear All.

 6. If one or more package lines are selected for action, click Workflow Action.

The Package Workflow Action page opens.

 7. In the Action Required section, select the outcome of the step.

Because the outcome is configurable, it can be different for each workflow step, depending on the 
configuration at your site. In the above example, the possible actions are:

 n If the workflow step is ready for approval, select Approved.

 n If the workflow step is not ready for approval, select Not Approved.

 8. Click OK.

The package details page opens. Because you approved (or disapproved) the selected workflow 
steps, the workflow has moved on to the next step. This process continues until the package 
moves through all of its steps to resolution.

Adding Notes to Packages in Standard Interface
The Notes section contains fields in which you can provide supplementary package information. To 
add a note, in the Add Notes subsection, type the information. To save the note, save the package.

View existing notes in the Existing Notes section. Existing notes are listed in chronological order with 
the most recent note listed first. You can filter existing notes, using Show Only User Notes, Note 
Author, and Changed Fields.  

You cannot delete an existing note. 
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Figure 4-1. Notes section 

 

Adding References to Packages from Standard 
Interface
In some cases, it might be useful to reference a Web-accessible file, a document, or file from a local 
machine to the package. You can add such references to a package from the standard interface.

You can add the following entities as package references: 

 l Attachments

 l Packages (new or existing)

 l Projects

 l Releases

 l Requests (new or existing)

 l Tasks

 l URLs

For some reference types (such as requests and other packages), you can create a functional 
dependency to the reference. For example, you can specify that a request is a predecessor to the 
package. This means that the package cannot continue along its workflow until the referenced request 
closes. For more information about valid package references and the relationships they can have to 
packages, see "Reference Relationships " on page 31.

This section provides information on how to add various types of references to a package from the 
standard interface. For information on how to add package references from the PPM Workbench, see 
"Adding References to Packages from Package Workbench" on page 54.
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Adding Attachments as References 
To add an attachment as a package reference:

 1. Log on to PPM Center. 

 2. Open or create a package.

Note: For information on how to open a package, see "Opening Packages from Standard 
Interface" on page 71.

 3. Scroll to the References section.

 4. From the New Reference list, select Attachment, and then click Add.

The Add Document window opens.

 

 5. Next to the File field, click Browse, and then locate and select the document file you want to 
attach as a reference.

 6. In the Author field, you can replace the default value with the name of the attachment author.

 7. In the Description field, type a description of the attachment.

 8. Click Add. 
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On the Package page, the References to be added on Save field lists the referenced 
attachment. 

 9. Click Save.

The attachment is added as a request reference.

Adding Existing Packages as Package References 
You can reference existing packages to a package. 

To specify an existing package as a package reference:

 1. Log on to PPM Center. 

 2. Open or create a package.

For information on how to open a package, see "Opening Packages from Standard Interface" on 
page 71.

 3. Scroll to the References section.

 4. From the New Reference list, select Package (Existing), and then click Add.
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The Add References: Package window opens. 

 

 5. Provide your search criteria, and then click Search.

The Package Search Results section lists the packages that match your search criteria.

 6. Select the checkbox for the package that you want to add as a reference, and then click Add.

On the Package page, the References to be added on Save field lists the referenced package. 

 7. Click Save.

Adding New Packages as Package References 
You can reference a new package to a package. 

To add a new package as a package reference:
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 1. Log on to PPM Center. 

 2. Open a package.

For information on how to open a package, see "Opening Packages from Standard Interface" on 
page 71.

 3. Scroll to the References section.

 4. From the New Reference list, select Package (New), and then click Add.

The Create New Package window opens. 

 5. Under Relationship, select the option that describes the relationship that the new package has to 
the open package.

 6. Under Select which Relationship the new Package will have to Package #, select the option 
that describes the relationship that the new package has to the open package.

For information about the different types of reference relationships, see "Reference Relationships 
" on page 31.

 7. Click Create.

The New Package window opens.

 

 8. In the Workflow field, type the name of a workflow to apply to the new package.

 9. Type any optional information you want to save, and modify any values that you want to change, 
and then click Save.

On the Package page, the References to be added on Save field lists the new referenced 
package. 

 10. Click Save.
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Attaching Programs as Package References 
You can reference existing programs to a package. 

To specify a program as a package reference:

 1. Log on to PPM Center. 

 2. Open or create a package.

For information on how to open a package, see "Opening Packages from Standard Interface" on 
page 71.

 3. Scroll to the References section.

 4. From the New Reference list, select Program, and then click Add.

The Reference Program window opens. 

 

 5. To specify the name of the program to reference in the Program field, select the name from the 
auto-complete list, and then click Add.

On the Package page, the References to be added on Save field lists the program you selected. 

 6. Click Save.

Attaching Projects as Package References 
To specify a project as a package reference:

 1. Log on to PPM Center. 

 2. Open or create a package.
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For information on how to open a package, see "Opening Packages from Standard Interface" on 
page 71.

 3. Scroll to the References section.

 4. From the New Reference list, select Project, and then click Add.

The Add Reference: Project window opens.

 

 5. Provide your search criteria in one or more of the available fields, and then click Search.

The Add Reference: Project window lists the projects that match the search criteria you specified.

 6. In the Select Project to View section, select the checkbox for the project that you want to add as 
a package reference.

 7. Click Add.

On the Package page, the References to be added on Save field lists the referenced project. 

 8. Click Save.

Adding Releases as Package References 
You can add existing releases as package references.

To reference an existing release to a package:

 1. Log on to PPM Center. 

 2. Open or create a package.
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For information on how to open a package, see "Opening Packages from Standard Interface" on 
page 71.

 3. Scroll to the References section.

 4. From the New Reference list, select Release, and then click Add.

The Reference Release window opens.

 

 5. To specify the name of the release to reference in the Release field, select it from the auto-
complete list, and then click Add.

On the Package page, the References to be added on Save field lists the referenced release. 

 6. Click Save.

Adding Existing Requests as Package References 
You can reference existing requests to packages. 

To reference an existing request:

 1. Log on to PPM Center. 

 2. Open or create a package.

For information on how to open a package, see "Opening Packages from Standard Interface" on 
page 71.

 3. Scroll to the References section.

 4. From the New Reference list, select Request (Existing), and then click Add.

The Add Reference: Request window opens.

 5. Specify search criteria for the request, and then click Search.
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 6. Under Select which Relationship the selected Requests will have to Package #, select the 
option that describes the relationship that the new request has to the open package.

For information about the different types of reference relationships, see "Reference Relationships 
" on page 31.

 7. Select the checkbox for the request that you want to add as a package reference, and then click 
Add.

On the Package page, the References to be added on Save field lists the referenced request. 

 8. Click Save.
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Adding New Requests as Package References 
To reference a new request:

 1. Log on to PPM Center. 

 2. Open or create a package.

For information on how to open a package, see "Opening Packages from Standard Interface" on 
page 71.

 3. Scroll to the References section.

 4. From the New Reference list, select Request (New), and then click Add.

The Create New Request window opens.

 

 5. From the Request Type list, select the type of request you want to create as a reference to the 
open package.

 6. Under Relationship, select the option that describes the relationship that the new request has to 
the open package.

For a list of reference types, their definitions, and possible dependency relationships, see 
"Reference Relationships " on page 31.

 7. Click Create.

The Create New <Request Type> window opens.

 8. Provide data in all of the required fields (marked with a red asterisk), and any optional data about 
the new request that you want to record.
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 9. Click Submit.

On the Package page, the References to be added on Save field lists the new request. 

 10. Click Save.

Adding Tasks as Package References 
You can reference existing tasks to packages. 

To reference an existing task:

 1. Log on to PPM Center. 

 2. Open or create a package.

For information on how to open a package, see "Opening Packages from Standard Interface" on 
page 71.

 3. Scroll to the References section.

 4. From the New Reference list, select Task, and then click Add.

The Add Reference: Task window opens.

 5. Provide your search criteria in any of the available fields, and then click Search.

The Add Reference: Task window lists the tasks that match the search criteria you specified.
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 6. In the Select Task to View section, select the checkbox for the task you want to add as a 
reference to the open package, and then click Add.

On the Package page, the References to be added on Save field lists the task you selected. 

 7. Click Save.

Adding URLs as Package References 
You can reference an existing URL to a package.

To add a URL as a package reference:

 1. Log on to PPM Center. 

 2. Open or create a package.

For information on how to open a package, see "Opening Packages from Standard Interface" on 
page 71.

 3. Scroll to the References section.

 4. From the New Reference list, select URL, and then click Add.
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The Reference URL window opens.

 

 5. In the URL field, type the URL address. 

 6. To test the URL you specified in your default browser window, to the right of the URL field, click 
U.

 7. In the Description field, type a description or an explanation of how the URL is related to the 
package.

 8. Click OK.

On the Package page, the References to be added on Save field lists the URL you specified.

 9. Click Save.

Processing Packages Using PPM Workbench 
You can process submitted packages from the PPM Workbench using the Package window. You can 
use the Package window to process a submitted package through its workflow. You can add notes and 
references to the package, make decisions on package status, and run actions for the package. You 
can also change or delete a package from the Package window. 

Opening Packages from PPM Workbench 
To open a package from the PPM Workbench:

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages. 
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The Packages Workbench opens.

 4. To display all the existing packages, click List.  

To restrict the search, provide information in one or more of the search fields.

 5. Select a listed package, and then click Open.  

Checking Package Status
Each package line must follow the business process defined by its assigned workflow. You can view 
all the workflow and subworkflow steps for each line on the Status tab in the Package window. 

To view the status of a submitted package:

 1. Open a submitted package. 

For information on how to open a package, see "Opening Packages from PPM Workbench " on the 
previous page. 

The Package window opens.

 2. Click the Status tab.

 3. Review the status of the package.

You can now review the status of each package line. The result of each workflow step is recorded 
in the package line row, so that you can quickly get an idea of which lines have closed with 
success or closed with a failure. 

Although all the workflow steps are listed, a package line does not necessarily go through every 
step before it is resolved. For example, you might have a rework step that is only used if rework is 
required. For more information about the package, select one of the logs, views, or reports related 
to the package. For more information about the Status tab, see "Package Window, Status Tab " 
on page 26. 

Acting on Eligible Steps 
After a package is submitted, each package line has one or more workflow steps set to Eligible, as 
shown in "Figure 4-2. Status tab eligible steps" on the next page. This indicates that the execution or 
decision steps must be performed first in the resolution process for the package. If you have 
permission to act on the eligible step, the text in the Status column is displayed in bold text. 

If the eligible step is:

 l Execution workflow step, you must perform an action.

 l Decision workflow step, you must specify a decision. 
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After you perform the action or make the decision, HP Deployment Management displays the outcome.

Figure 4-2. Status tab eligible steps

 

Processing a Workflow Step

To process a workflow step:

 1. Open a submitted package. 

For information on how to open a package, see "Opening Packages from PPM Workbench " on 
page 87. 

The Package window opens.

 2. Click the Status tab.

 3. Select one or more package lines.

You can select a single step for a single package line, or multiple steps for multiple lines. To select 
all the steps on all the open package lines that are eligible for action, click Select All.

You cannot act on multiple workflow steps at one time. If you select cells for multiple workflow 
steps, the Action button remains disabled. If you have the security privileges to perform the given 
workflow step, the button is enabled. 
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After you select a workflow step for which you have the security permission to act on the workflow 
step, the label on the button at the bottom-right of the Status tab changes from Action to the 
workflow step name. 

 4. To perform an action or decision on a selected step, click Action.

A decision window or the execution window opens.

Each step is configured with a selection of valid results. 

 5. If a decision window is open, from the Result list, select a decision result. If an execution window 
is open, in the list, select Execute Now, Schedule Execution, or Bypass Execution. 

 6. In the Notes field, you can type any comments you want to save. 

For information about the decision window, see "Acting on Decision Workflow Steps " below. For 
information about the execution window, see "Acting on Execution Workflow Steps" on page 92.

 7. Click OK.

Whether the step is a decision or an execution, the result of the step is processed by the workflow 
engine and can lead to a number of changes. Based on the workflow definition (which can contain 
multiple workflow steps and subworkflows) the given workflow step result can cause additional 
workflow steps to become eligible, indicating the next actions to be performed in the package resolution 
process. 

When subsequent steps become eligible, those steps are completed sequentially, making eligible the 
next workflow steps in line. This process continues until the package reaches its final state and is 
resolved, usually at a close step. 

Acting on Decision Workflow Steps 
Decision workflow steps are steps for which you (or a group) must indicate the outcome. For example, 
Approve Migration is an example of a decision workflow step. You can either act on the decision step 
yourself or delegate the decision. 

To act on a decision workflow step:
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 1. In the Package window, select the Status tab.

 

 2. Select an eligible decision workflow step. 

For information on how to access the Status tab and select an eligible decision workflow step, see 
"Acting on Eligible Steps " on page 88. 

The Action button label changes, depending on the step selected. For example, if you click 
Eligible for QA Test, the Action button label changes to QA Test.

Note: If you cannot see the Action button on the Status tab, that means that a security group 
has not been assigned to the workflow step.

 3. Click the action button. For the example given in step 2, click QA Test.

The QA Test Package Decision window opens.

 4. In the list, select the applicable action needed (Decide Now or Delegate Decision).

 n If you select Decide Now, you must make a decision about the decision workflow step; for 
example, Approve. To make a decision regarding the decision workflow step:
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 i. From the Result list, select the result. 

 ii. In the Notes field, type helpful information about the decision you made, and then click 
OK.

The decision window closes. The decision results are added to the Status tab. 

 n If you select Delegate Decision, you must then assign the decision to someone. To delegate 
a decision:

 i. To select a resource, use the Delegate To auto-complete list. 

 ii. In the Notes field, type helpful information about the decision that needs to be made, and 
then click OK.

The decision window closes, and the results are listed on the Status tab.

 5. Click OK.

The decision is entered into the system. If the workflow step was configured so that more than one 
person must decide on the result, the package line may not move to the next step until all required 
decisions are made. If a decision workflow step requires that more than one person decide on the 
result, you can view the current decision results for the workflow step using the Decision Detail view. 

Acting on Execution Workflow Steps
Execution workflow steps are workflow steps where the HP Deployment Management system 
performs an action, and then updates the step with its result. These actions can be as simple as 
calculating the value for a token or as complex as copying files, running programs, or updating Web 
pages. 

To act on an execution workflow step:

 1. In the Package window, on the Status tab, select the eligible decision workflow step.

For information on how to access the Status tab and select an eligible decision workflow step, see 
"Acting on Eligible Steps " on page 88.

The Action button is enabled. Notice that the button label changes with the step selected. For the 
following example, the action button label changed to SAP_Export.
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 2. On the Status tab, click the action button, which for this example is SAP_Export.

The SAP_Export execution window opens. 

 3. In the list, select Execute Now, Schedule Execution, or Bypass Execution. 

 n If you select Execute Now and click OK, you run the workflow step. The Execution window 
closes. The result of the workflow step is displayed on the package line at the workflow step. 
This process could be a software migration, execution of a PL/SQL function, the closing of the 
package line, or other activity. The execution engine runs the step and sets the result 
accordingly.

 n If you select Schedule Execution,the Execution Date and Execution Time fields are visible. 
Select a date and time, and then click OK.The Execution window closes. The execution 
schedule is displayed on the package line at the workflow step. This process could be a 
software migration, execution of a PL/SQL function, the closing of the package line, or other 
activity. The execution engine runs the step and sets the results accordingly.

 n If you select Bypass Execution, the Execution Result field is visible. Select the results, and 
then click OK. The execution window closes and the selected result is displayed on the 
package line at the workflow step. 

 4. Click OK.

Adding Notes 
In the Package window, the Notes tab ("Figure 4-3. Notes tab in the Package window" on the next 
page) displays additional package information.
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Figure 4-3. Notes tab in the Package window

 

To add a note, type the text in the New Notes field, and then click Save. The note is added to the 
Existing Notes field. 

Adding, Updating, and Deleting References
You can add and update package references from the References tab of the Package window in the 
PPM Workbench. The following sections provide information about how to add, update, and delete 
references.

 l "Adding References " below

 l "Updating Reference Relationships" on the next page

 l "Deleting References " on page 96

Adding References 

The Package window References section contains additional package information. For example, you 
might add a document or URL as a reference to a package. You can add the following entities as 
package references: 
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 l Attachments

 l Packages (New and Existing)

 l Projects

 l Releases

 l Requests (New and Existing)

 l Tasks

 l URLs

For some references (such as requests and other packages), a functional dependency to the original 
package can be created. For example, you can specify that a request is a predecessor to the package. 
This means the package will not continue until the request is closed. For a list of the references and 
their possible dependency relationships, see "Reference Relationships " on page 31. 

For information on how to add a reference, see "Adding References to Packages from Package 
Workbench" on page 54 or "Adding References to Packages from Standard Interface" on page 75.

Updating Reference Relationships

To update an existing reference relationship from the PPM Workbench:

 1. Open a package.

For information on how to open a package, see "Opening Packages from PPM Workbench " on 
page 87.

 2. Click the References tab.

 3. Click the Relationship field for the referenced entity, and then select an item from the displayed 
list. 
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 4. Click OK or Save.

The change to the package is saved. 

Deleting References 

To delete a reference from the PPM Workbench:

 1. Open a package.

For information on how to open a package, see "Opening Packages from PPM Workbench " on 
page 87.

 2. Click the References tab.

 3. Select the reference, and then click Remove.

The reference is deleted.

 4. Click Save to confirm that you want to delete the reference(s).

 5. Click Cancel to back out of the reference and cancel removing (or deleting) any references.
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Adding a Package Line to an In-Progress Package 
You may want to add a package line to a package that is already submitted. You can add package lines 
to a package that has a status of In Progress. For information on how to do this, see "Adding Lines to 
Packages " on page 50.

A new package line is not submitted until you save the package. After you save the package, the new 
package line is submitted to the first step in the workflow, and the user can process it separately until it 
catches up with the other lines in the package. At submission, the new package line is not 
automatically assigned the same status as the other lines.
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Chapter 5: Managing Packages
 l "Managing Packages in HP Deployment Management" below

 l "Merging Packages" below

 l "Creating New Package Groups " on page 100

 l "Editing Package Groups" on page 102

 l "Deleting Packages " on page 103

 l "Cancelling Package Lines " on page 104

Managing Packages in HP Deployment Management
After a package is submitted in HP Deployment Management, it can be processed and managed. 
Package management involves copying, merging, grouping, editing, and deleting packages, modifying 
package groups, and cancelling package lines. The following sections address all of these tasks, 
except for copying packages. The procedure for copying packages is provided in "Creating Packages 
by Copying Existing Packages " on page 45. 

Merging Packages
You can generate a new package by merging two or more existing packages. This is useful if you want 
to generate a single package consisting of certain package lines contained in separate packages. 

To merge two packages:

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

 4. On the Query tab, click List.  

The Results tab lists all of the existing packages. 
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 5. Select the packages to merge.

To select nonadjacent rows, use the Ctrl key. To select adjacent rows, use the Shift key.

 

 6. On the Results tab, click Merge. 
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The Merge Package window opens to the Options tab.

 

 7. In the New Package Number field, you can either leave the generated package number, or type a 
different unique package number.

 8. In the Workflow field, you can leave the default workflow name, or select a different one in the 
auto-complete list.

 9. On the Options tab, select Yes or No for the listed options.

 10. Click OK.  

The Package Workbench prompts you to indicate whether you want to edit the new (merged) 
package. 

 11. To edit the package, click Yes. To save and close the package, click No.

Creating New Package Groups 
It is often useful to link a new package to a package group for tracking and reporting purposes. After 
you link packages to package groups, you can use the package group to search for packages or in 
building custom portlets. You create new package groups from the Package Workbench. 

To create a package group:
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 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

 4. From the Package menu, select New Package Group. 

 

The Validation: KNTA - Package and Request Groups window opens and displays the existing 
groups for packages and requests.

 

 5. Click New.  
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The Add Validation Value window opens to the Value Information tab.

 

 6. In the Code field, type the token name for the new Package Group list item.

 7. In the Meaning field, type the name to display for this item in the Package Group list.

 8. In the Desc field, type a short description of the package group.

 9. To disable the new list value, clear the Enable? checkbox.

 10. To make this value the default selection in the Package Grouplist, select the Default checkbox.

 11. Click OK.

Editing Package Groups
You can edit existing package groups from within the PPM Workbench. You can only change the 
KNTA Package and Request Groups Validation list if you have the required access grants and security 
privileges. For information about the licenses and access grants required to work with packages in HP 
Deployment Management, see the Security Model Guide and Reference.

Before you add or edit any package groups, consult your application administrator. Package groups are 
typically generated to adhere to specific business application standards.

To edit a package group:

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.
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The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

 4. Select Package > New Package Group.  

The Validation: KNTA - Package and Request Groups window opens and lists existing package 
groups.

 5. Select the package group you want to change, and then click Edit.

The Edit Validation Value window opens.

 

 6. Edit the field values, as necessary, and then click OK.

The new validations are added to the Validation: KNTA - Package and Request Groups window. 

 7. Click OK.

Deleting Packages 
You can delete packages from the Packages Workbench. 

To delete a package:
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 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

 4. To see a list of all the packages, on the Query tab, click List.

The Results tab displays the packages list.

 5. Select the packages you want to delete, and then click Delete.

Note: To select nonadjacent rows, press and hold the Ctrl key. To select adjacent rows, 
press and hold the Shift key.

The Packages Workbench prompts you to confirm that you want to delete the package. 

 6. Click Yes.

Cancelling Package Lines 
In some instances, you might want to cancel package lines because, for example, the files are out of 
date or are no longer required. You use the Package Workbench to cancel package line. 

To cancel a package line:

 1. Log on to PPM Center.

 2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

 3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

 4. To see a list of all of the packages, on the Query tab, click List.

The Results tab displays the list. 

 5. Select a package that contains lines you want to cancel, and then click Open.  

The Package window opens.
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 6. On the Package Line tab, select the package line to cancel.

 7. From the menu bar, select Package > Cancel Package Line.
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Send Documentation Feedback
If you have comments about this document, you can contact the documentation team by email. If an 
email client is configured on this system, click the link above and an email window opens with the 
following information in the subject line:

Feedback on HP Deployment Management User's Guide (Project and Portfolio Management 
Center 9.30)

Just add your feedback to the email and click send. 

If no email client is available, copy the information above to a new message in a web mail client, and 
send your feedback to HPSW-BTO-PPM-SHIE@hp.com.

We appreciate your feedback!
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