Slow performance when using ALM Explorer in Citrix environment (Internet is not accessible)

  • KM01158702
  • 11-Sep-2014
  • 11-Sep-2014

This document has not been formally reviewed for accuracy and is provided "as is" for your convenience.

Summary

Issue happens in Citrix environment (especially Internet is not accessible). The actual application launched quite fast, that is launching "C:\Program Files (x86)\Common Files\HP\HP ALM Explorer 11 \HP-ALM-Explorer.exe" brought up ALM Explorer in a few seconds, but if you then entered "http://:8080/qcbin" and hit enter, or you ran the full command line that passes that URL as a command line argument then the time it took to get through that process was what was in the 3 minute range.

Error

Issue happens in Citrix environment (especially where Internet is not accessible).

The actual application launched quite fast, that is launching "C:\Program Files (x86)\Common Files\HP\HP ALM Explorer 11 \HP-ALM-Explorer.exe" brought up ALM Explorer in a few seconds, but if you then entered "http://<ipaddress>:8080/qcbin" and hit enter, or you ran the full command line that passes that URL as a command line argument then the time it took to get through that process was what was in the 3 minutes range.

Cause

Using Sysinternals tool TCPview to watch the connections real time as I launched ALM Explorer and then attempted to connect to http://<ipaddress>:8080/qcbin.  This is what I saw:

What I'm seeing, is upon hitting enter to connect to the http://<ipaddress>:8080/qcbinlocal server, the ALM Explorer process also tries to reach out to a number of internet URLs with SYN packets.  The external domains I saw were mainly variants of the akamaitechnologies.com and above.net domains I have encircled above.

These Citrix servers however do not have internet access, so the program sits there waiting for the ACK packet response that will never come.  ALM Explorer seems to cycle through about 30 - 50 of these external servers (its hard to get an exact count in real time) and each one sits in queue for a few seconds before timing out and moving on to the next.  To the user, all that is presented is a "Not Responding"
application window.  After all of these server connections get done failing, which again takes about 3 minutes, the application loads the other files from the local store and presents the logon screen. That part takes about 4 seconds.  So we have a program launch process that takes a second to launch the application, and 4 seconds to complete the file load process (both totally acceptable) with a 3 minute period of failed connections sandwiched between them (not acceptable).

Fix

Uncheck below things in IE >> Internet options >>Advanced tab >> Security section:

  1. Check for publisher's certificate revocation
  2. Check for server certificate revocation
  3. Check for signatures on downloaded programs