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What's New in HP Service Virtualization
This What's New provides an overview of the features that were introduced or enhanced in HP Service
Virtualization.

This section includes:

l "What's New in Service Virtualization 3.61" below

l "What's New in Service Virtualization 3.60" on the next page

What's New in Service Virtualization 3.61

Service Virtualization Management Enhancements

l Virtual Service Statistics and Event Audit. New virtual servicemetrics and statistics are
accumulated during the virtual service deployment lifetime. The new metrics allow you to
understand virtual service utilization in the organization across a specific time span, help to
calculate Service Virtualization ROI, troubleshoot service problems, understand long terms trends
in usage, and optimize Service Virtualization performance.

Service Virtualization now also audits virtual service change events, such as a change of virtual
service state or simulationmodel, marking the change with a timestamp and the identity of the user
that performed the change. Each event also shows average virtual servicemetrics measured from
the previous virtual service event.

Virtual service statistics can be analyzed using charts available in the Virtual Service Details view
or exported into anMS Excel file for further processing and reporting.

l Service Virtualization Server Statistics. New Service Virtualization Server metrics show various
aspects of Service Virtualization Server utilization, performance, and health across all deployed
virtual services. The new server metrics help Service Virtualization Server administrators
understand hardware utilization and overall communication performance, identify and troubleshoot
server problems, and optimize Service Virtualization deployment based on real usage and demand.

Service Virtualization Server metrics can be analyzed per Service Virtualization Server node,
accessible overWindows performancemonitors and consumed by monitoring tools for alerting and
long term analysis. The top 5 Servers by hardware utilization are now visible on the Service
VirtualizationManagement Dashboard with an indication of server health.

l Virtual Service Portfolio Export. Export a list of virtual services deployed on a Service
Virtualization Server to an HTML report. The exported list includes details about each service, such
as service name, ID, mode, deployment state, and data and performancemodels. Reports can then
be saved and used for further processing.

For details, see the Service VirtualizationManagement help within the application.
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Protocol Enhancements

l WebMethods SAP Connector Virtualization. Virtualize IDOC document exchange between flow
services hosted inWebMethods Integration Server and SAP. The SAP system is not required
during simulation. For details on configuring the Service VirtualizationWebMethods SAP agent, see
"How to Configure theWebMethods SAP Agent" on page 57.

l MSMQ Virtualization. Virtualize binary and XMLmessages over Microsoft MessageQueuing
(MSMQ). For details on configuring the Service VirtualizationMSMQ agent, see "How to Configure
theMSMQAgent" on page 53.

l Fixed-Length Protocol Virtualization. Virtualize fixed-length field based communication defined
using a text based service description. This protocol is currently limited to TCP streams. For
details, see "How to Virtualize a Fixed-Length over TCP Protocol" on page 113.

Logging Enhancements

l Message Logging Improvements. View message logs for the Service Virtualization Server
directly from the Designer interface. It is also possible to savemessage logs to your local machine,
display XMLmessages in a structured view, and change log levels without a restart of Service
Virtualization Server or Designer. For details, see "Message Logging" on page 114.

l Data Logging. Logging of request and response data for a specific data element of a virtual service
is now possible inside a scripted rule. For details, see "How to Create a Scripted Rule" on page 345.

What's New in Service Virtualization 3.60

Protocol and Virtualization Enhancements

l Multiple Queue Managers. You can now configure up to four different WebSphereMQ agents per
virtual service. This enhancement enables you to configure, for example, the following typical
scenarios:

n Different Queue Managers for real/virtual requests and responses. Request processing
(virtual + real request queues) uses a different queuemanager than the queuemanager used for
response processing.

n Different Queue Managers for virtual and real MQ Endpoints. Virtual queues (request and
response) are hosted by a different MQ queuemanager than theMQ queuemanager used for the
real queues (real request and responseMQ queues).

For details, select WebSphereMQ on the "Service Properties Page" on page 122.

l Multiple JMS Providers. You can now configure up to four different JMS agents per virtual
service. This enhancement enables you to configure, for example, the following typical scenarios:
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n Different JNDI contexts for real/virtual requests and responses. Request processing
(virtual + real request endpoints) uses a different JNDI context than the JNDI context used for
response processing.

n Different JNDI contexts for virtual and real JMS endpoints. A lookup for virtual queues
(request and response) is performed within a JNDI context different than the JNDI context used
to lookup real (request and response) queues.

For details, select JMS on the "Service Properties Page" on page 122.

l MIME attachment support.With support added for MIME attachments, it is now possible to
virtualize HTTP based services (SOAP, XML, Binary, REST) with payload inmultipart format.

l SOAP RPC/Encoded. Service Virtualization SOAP capabilities are now enhanced by support for
RPC/Encoded based communication.

Virtual Service Modeling Enhancements

l Multiple SOAP service creation wizard. The Designer now enables you to createWSDL/SOAP
based services in bulk. Definemultiple services using a CVS file withWSDL files paths, or by
manually enter a list of WSDL file paths in the wizard. For details, see "CreateMultiple Virtual
Services Wizard" on page 140.

Service Virtualization Management Improvements

New Service VirtualizationManagement enhancements enable the decoupling of Service Virtualization
Agent administration, technical configuration of communication to Service Virtualization, and
deployment of virtual service data and behavior. Each part of the virtual service (simulationmodels and
agent configurations) can be provided by different teams and restricted by permissions.

This includes:

l Agent management. You can now perform complete agent management from the Service
VirtualizationManagement interface. You can create, duplicate, update, delete, and test agent
configurations. You can also import and export agent configurations, for use by other Service
VirtualizationServers.

l Access permissions for agents. Service Virtualization server administrators can define access
permissions for agents, to restrict themodification and configuration of agents.

l Virtual service deployment improvement.You can now deploy virtual services using existing
agent instances and configurations.

For details on working with Service VirtualizationManagement, see "Service Virtualization
Management" on page 179.
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Additional Improvements

l Agent sharing. The ability to import and export agent configurations is introduced. In addition to
sharing Service Virtualization projects, different user groups can now also share agent
configurations used in the project. You can import and export agent configurations using both the
Designer and Service VirtualizationManagement. For details, see "How to Configure Agents" on
page 45.
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Service Virtualization Overview
HP Service Virtualization software allows developers and testers access to limited or unavailable
services in a simulated environment. This helps application teams lower costs and reduce testing
times by finding defects earlier in the application life cycle when they are easier, faster, and less
expensive to fix. It helps improve quality by enabling quality assurance (QA) teams to test what
otherwise could not be tested. It also helps isolate problems that are based on dependencies between
services in composite applications. This helps significantly reduce delays andmanage the costs and
complexity of composite application development and testing.

Service Virtualization provides a framework for creating virtual services for use in testing your
applications under development. Service Virtualization places a virtual service between the client
application (application under test) and the real service to which you require access. Once you create
virtual services to simulate the real services that you require, you reconfigure your client applications to
use the virtual services, instead of the real services.

Service Virtualization also enables you to:

l Design virtual services. Add data to your virtual service by importingmessages, adding external
data sources, or by manually entering data.

l Learn service behavior. Record real service behavior to assist you in creating a virtual service to
mimic the behavior of the real service.

l Customize simulation models. You can create andmanipulate data and performancemodels for
use in your virtual services.

l Create visual models.Model composite applications by creating a visual map of the services and
the relationships between them.

l Integrate. Integrate with HP test automation tools.

Service Virtualization Components

Service Virtualization consists of the following applications:

l Designer. A client application enabling you to create virtual services, and run simulations of real
service behavior. The Service Virtualization Designer The Designer is used for design and
validation of virtual services within the same desktop environment, and includes an embedded
server for hosting virtual services.

l Server. (Optional.)A standalone server application which hosts the running of virtual services. The
Service Virtualization Server is optimized for performance, can contain many more services than
the Designer, and can be accessed by multiple Designers.
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For details on configuring the Service Virtualization Server, see theHP Service Virtualization
Installation Guide.

For details on working with the Service Virtualization Server, see "How toManage Service
Virtualization Servers" on page 25.

l Management Interface. (Optional.)A web application enabling you to view andmanage all
services from Service Virtualization configured servers, without opening the Designer or individual
projects. The Service VirtualizationManagement is installed by default when you install the Service
Virtualization Server.

For more details, see "Service VirtualizationManagement" on page 179.

For details on starting the Service Virtualization components, see "How to Start Service Virtualization"
on page 21.

Getting Started with Service Virtualization

Getting
started

When you start the Service Virtualization Designer, the application opens,
displaying the Start Page, with links to common procedures and sample projects.
For user interface details, see "Start Page" on page 28.

To get started working with Service Virtualization, see "How to Use Service
Virtualization" on page 23.

Main Service
Virtualization
view

When you open a virtualization project, themain Service Virtualization window
opens. For user interface details, see "Service VirtualizationMainWindow" on page
32.

Main menus For a description of themainmenu options available in Service Virtualization, see
"Service VirtualizationMainMenus" on page 33.

Service Virtualization Designer Licensing
The Service Virtualization Designer is installed with a 30-day trial license. To continue working with the
Designer, youmust install a license from HP.

You can obtain HP licenses through the HP Software Licensing Portal.

Tomigrate a license after installing a new version of the Service Virtualization Designer, visit the HP
Software LicenseManager.

Note: After the evaluation period, the Designer will no longer work, but your data is preserved.
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The following types of licenses are available:

l Evaluation license. A 30-day trial license that may be provided by HP.

l Seat license. For use for a single machine running the Service Virtualization Designer.

l Concurrent license.Multiple users share a pool of licenses managed by HP Autopass License
Server.

l Commuter license. A temporary license you obtain from the license server that enables the
Designer to work offline. You can then continue to work in the Designer when you have limited or no
access to the license server.

Note:

l Concurrent and commuter licenses require access to the HP Autopass License Server. For
details on installing the HP Autopass License Server, see theHP Service Virtualization
Installation Guide.

l For details on installing a license, see "How to Install a Service Virtualization Designer
License" on page 25.

Service Virtualization Functionality by Edition
HP Service Virtualization is available in several editions, which determine the functionality available to
you in the application.

l ThePremium Edition provides full Service Virtualization functionality.

l TheExpress Edition provides a subset of the full Service Virtualization functionality, as described
in this section.

Service Virtualization Designer Editions:

Service Virtualization Feature
Designer - Express

Edition
Designer - Premium

Edition

Connect to Express Edition Server

Connect to Premium Edition Server

Limited simulation throughput for the Designer's
embedded server

10
transactions per second

10
transactions per second

In-memory simulation for the Designer's
embedded server
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Service Virtualization Feature
Designer - Express

Edition
Designer - Premium

Edition

ALM integration

Service Virtualization Server Editions:

Service Virtualization Feature
Server -

Express Edition

Server -
Premium
Edition

Manage Express Edition Server

Manage Premium Edition Server

Maximum deployed services on the Service Virtualization
Server 100 Full functionality

Maximum concurrent users connected to Service
VirtualizationManagement 10 Full functionality

Maximummanaged Service Virtualization Servers in
Service VirtualizationManagement 1 Full functionality

Maximum CPU cores 8 Full functionality

Limited simulation throughput 10
transactions per second

Full functionality

In-memory simulation

ACL/Server access permission functionality

ALM integration

Additional information:

l The limits specified here are default settings for the editions. They may change according to your
license agreement.

l Upgrading your edition: Upgrade your edition by adding the appropriate license. You can backup
your server on one edition and restore it on a different edition.

l When you first install the Service Virtualization Designer or Server, a 30-day trial license is
installed. This license runs the Premium Edition.
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Service Virtualization Log Files
The Service Virtualization logs includemessages related to each of the Service Virtualization software
components. You can access the Service Virtualization logs from theWindows Start menu, under All
Programs > HP Software > HP Service Virtualization application group.

The logs are located in the following folders:

l Designer:

%APPDATA%\Hewlett-Packard\VirtualServiceDesigner\logs

l Server

%ALLUSERSPROFILE%\Hewlett-Packard\HP Service Virtualization Server\logs

Configure logging

Messages are written to the log files based on the log levels that are defined in the application
configuration files. Log levels includeWARN, DEBUG, INFO, and ERROR.

You can change log levels using the Service Virtualization configuration files:

l Service Virtualization Server configuration file:

%[INSTALLLOCATION]%\Server\bin\HP.SV.StandaloneServer.exe.config

l Designer configuration file:

%[INSTALLLOCATION]%\Designer\bin\VirtualServiceDesigner.exe.config

Changes made to the logging configuration are effective immediately, and do not require an application
restart. To disable the ability to make changes without restarting the application, locate the following
line in the configuration file and set the value to False:

<add key="log4net.Config.Watch" value="True"/>

Password Encryption
You can encrypt sensitive data stored in Service Virtualization, such as passwords stored in agent
configuration files or in the Service Virtualization Credential Store.

Service Virtualization encrypts data using a password that you provide. You can enable password
encryption by defining an encryption password for the following application components:
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l Service Virtualization Server encryption. During server installation, you can select the server
encryption option, and define a password to use for encryption. The password is stored for the
Windows system account user, and used for all server encryption.

l Designer/Embedded Server encryption. During Designer installation, or if you are running the
Designer for the first time, you can define a password for encrypting sensitive information stored in
the server. EachWindows user running the Designer can define an encryption password, used to
encrypt their own data and configuration information.

l Project encryption. You can define a password for encrypting virtualization projects. When you
export a virtualization project and a .vproja project archive file is created, the project is encrypted
using the encryption password. For other users to open the exported project, youmust provide them
with the encryption password.

For details on enabling project encryption, see "Projects and Solutions Page" on page 151.

For additional options for configuring password encryption in Service Virtualization, refer to theHP
Service Virtualization Installation Guide.

How to Start Service Virtualization
This section explains how to start the Service Virtualization applications. For more details on each
component, see "Service Virtualization Overview" on page 16.

Service
Virtualization
Designer

From theWindows Start menu, select All Programs > HP Software > HP
Service Virtualization > Designer 3.61 > HP Service Virtualization Designer.
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Service
Virtualization
Server

Do one of the following:

l Start the Server as aWindows service: From theWindows Start menu, select
All Programs > HP Software > HP Service Virtualization > Server 3.61 >
Start Services of HP Service Virtualization Server.

This option starts both the Service Virtualization Server service and the Service
VirtualizationManagement service.

l Start the Server as a standalone console application: From theWindows Start
menu, select All Programs > HP Software > HP Service Virtualization >
Server 3.61 > Service Virtualization Server.

For details on working with the Service Virtualization Server, see "How toManage
Service Virtualization Servers" on page 25.

Note: The Service Virtualization Server can be configured as either secured or
unsecured. To prevent unauthorized access, it may be configured as secured.
For additional details and configuration information on the Service Virtualization
Server, see the HP Service Virtualization Server section of theHP Service
Virtualization Installation Guide.

For details on accessing a secured Service Virtualization Server, see "How to
Access a Secured Service Virtualization Server" on page 27.
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Service
Virtualization
Management

To start the Service Virtualization Management service:

On the Service Virtualization Server machine, from theWindows Start menu, select
All Programs > HP Software > HP Service Virtualization > Server 3.61 >
Start Services of HP Service Virtualization Server.

This option starts both the Service Virtualization Server service and the Service
VirtualizationManagement service.

To access the Service Virtualization Management interface:

Open a browser window and enter one of the following URLs:

l The Service Virtualization Management URL:

https://<Service Virtualization Server IP or hostname>:<Service
VirtualizationManagement port>

By default, the Service VirtualizationManagement port is 6086.

l The Service Virtualization Server URL:

<Service Virtualization Server IP or hostname>:<HTTP/HTTPS port
number>/management

For more details on Service Virtualization network ports, see theHP Service
Virtualization Installation Guide.

For more details on Service VirtualizationManagement, see "Service Virtualization
Management Overview" on page 180.

How to Use Service Virtualization
This task describes the overall Service Virtualization workflow.

1. Start the Service Virtualization components

Service Virtualization includes a Designer with an embedded server, an optional standalone
server, and amanagement interface.

For details on these components, see "Service Virtualization Overview" on page 16.

For details on starting the components, see "How to Start Service Virtualization" on page 21.

2. Install a Service Virtualization Designer license

The Designer is installed with a 30-day evaluation license. To continue working with the Designer,
youmust obtain and install a valid license from HP.
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For details on installing the Designer license, see "How to Install a Service Virtualization Designer
License" on the next page.

3. Configure Service Virtualization agents

Configure the protocol-specific agents that handle communication between clients and real or
virtual services. For task details, see "How to Configure Agents" on page 45.

4. Optional: Model composite applications

Create a visual map of the services in your composite applications, and the relationships between
them. Group services into larger composites, mark service types, and display the service calls
between them. For task details, see "How toModel Composite Applications" on page 292.

5. Create virtual services

Create virtual services to simulate real services with limited access or that are unavailable. For
task details, see "How to Create a Virtual Service" on page 104.

6. Configure virtual services

Set up your virtual services to create a simulation for your testing purposes. Configure security,
logging, protocol, and server settings tomeet your needs. For task details, see "How to Configure
Virtual Services" on page 105.

7. Configure clients

Reconfigure your client applications to use the virtual services instead of the real services.
Service Virtualization enables you tomanipulate virtual services to get different results.

8. Learn service behavior

Record the behavior of the real service in order to learn its requests and responses. For task
details, see "How to Run Simulations" on page 168.

9. Run simulations

Use virtual services to simulate real services during your testing process. For task details, see
"How to Run Simulations" on page 168.

10. Review and monitor services

Monitor services during learning and simulation sessions. For details, see "How to Run
Simulations" on page 168.

11. Design and configure simulation models

Create and customize data and performancemodels to meet your needs. Learn real service
behavior, create customized rules for virtual service behavior, add service calls, and add external
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data sources. For task details, see "How toManage SimulationModels" on page 198.

12. Optional: Integrate with HP Test Automation tools

Integrate Service Virtualization with HP test automation tools. For details, see "HP Test
Automation Tools Integration" on page 319.

13. Manage virtual services

Deploy, undeploy, unlock, view, or change the runtimemode of virtual services on any Service
Virtualization Server.

For details, see:

n "How to Get Started Using Service VirtualizationManagement" on page 180

n "How toManage Virtual Services from the Command Line" on page 185

How to Install a Service Virtualization Designer
License
This task describes how to install a license for the Service Virtualization Designer.

To learnmore, see "Service Virtualization Designer Licensing" on page 17.

1. From the Helpmenu, select License Management.

2. Select a license type. For user interface details, see "Select License Type Page" on page 37.

3. Install the license. For user interface details, see "License InstallationWizard - Installation Pages"
on page 39.

How to Manage Service Virtualization Servers
This task describes how to use Service Virtualization Servers for your virtual services.

For details on starting a Service Virtualization Server, see "How to Start Service Virtualization" on
page 21.

View, add, or delete Servers

The Servers page displays all Service Virtualization Servers that are configured for your Designer.

From themainmenu, select Tools > Options. Click theServers tab.
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When you add a Server, it is added to the list of available Servers, enabling you to select this Server
when you create a new Service Virtualization project.

View Server status

The Servers page displays status information for each Service Virtualization Server configured for your
Designer.

From themainmenu, select Tools > Options. Click theServers tab.

Status indicators:

l Green - online.

l Red - not running.

l Yellow - indicates some connection problem, such as invalid credentials or amissing trusted
certificate.

Change Servers

Move the virtual services in the open project to a different server.

From themainmenu, select Project > Change Server.

Connect to a Server with a different user

If you are working with a secured Service Virtualization Server, your access may be limited based on
permissions assigned to your user. For details, see the "How to Access a Secured Service
Virtualization Server" on the next page.

To connect to a server with a different user, from themainmenu, select Tools > Options, and click the
Servers tab. Right-click a server and select Connect using different credentials.

For details on server authentication and user access permissions, see theHP Service Virtualization
Installation Guide.

Configure Service Virtualization agents

Service Virtualization agents handle communication between a client and a real or virtual service.
Agents are protocol specific. Youmust configure agents for each protocol your services are using, on
each Service Virtualization Server or the Designer's embedded server on which the services are
deployed.

You canmanage agents using both the Designer, and Service VirtualizationManagement.

In the Designer:Manage agents in the Agents page. For user-interface details, see "Agents Page" on
page 66.

Note: For details onmanaging agents in Service VirtualizationManagement, see the Service
VirtualizationManagement help within the application.
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How to Access a Secured Service Virtualization
Server
When the HP Service Virtualization Designer contacts a secured Service Virtualization Server for the
first time, it requests user input in order to establish a secured communication channel.

You can determine whether the Service Virtualization Server is secured based on its URL. The URL of
an unsecured server begins with http, whereas the URL of the secured server begins with https. For
example, the URL of a secured server might be https://mymachine.com:6085/management. In
addition, the port of the secured server is different from that of the unsecured server.

Note:

l When you are working with a secured Service Virtualization Server, the actions available to
you and the information displayed in the Service Virtualization Designer vary, based on your
user access permissions. For example, a user who is not assigned to any of the Service
Virtualization user groups cannot view any agent data or any services deployed on the server.

For details on the Service Virtualization user groups, see theHP Service Virtualization
Installation Guide.

l You can reconnect to a server with a different user. From themainmenu, select Tools >
Options, and click theServers tab. Right-click a server and select Connect using different
credentials.

To access a secured Service Virtualization Server:

1. When the HP Service Virtualization Designer contacts a secured Service Virtualization server for
the first time, a dialog box opens. You can review the certificate details, and select Trust the
certificate permanently to prevent the Designer from prompting you again. Click Yes to accept
the certificate.

2. Enter credentials to connect to the Service Virtualization Server. For details on credential
validation and user authentication, see theHP Service Virtualization Installation Guide.

Service Virtualization User Interface
This section includes:

Start Page 28

Service VirtualizationMainWindow 32

Service VirtualizationMainMenus 33
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License InstallationWizard 37

Start Page
This page includes links to your most recently opened projects, links to common procedures, and a tab
for the installed sample projects.

To access When you open Service Virtualization, the Start Page opens by default.

To open the pagemanually, from the View menu, select Start Page.

Relevant tasks "How to Create a Virtual Service" on page 104

See also l "Service Virtualization Overview" on page 16

l "Service VirtualizationMainWindow" on page 32

l "Service VirtualizationMainMenus" on page 33

General

UI Element Description

Recent Projects Displays links to themost recently opened projects.

Get Started page Displays links to common procedures. For details, seeGet Started Page
below.
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UI Element Description

Sample Projects
page

Displays links to the demo projects, installed with Service Virtualization. For
details, see Sample Projects Page below.

Close page after
project load

Closes the Start Page when you open a project.

Show page on
startup

Displays the Start Page each time you start Service Virtualization.

Get Started Page

This page provides links to several common procedures you perform in Service Virtualization.

UI Element Description

Learn Existing
Service

Enables you to virtualize an existing service and learn its behavior.

Creates new virtualization project and a virtual service, and then places the
new service in Learningmode.

For user interface details, see "Virtual Service Editor" on page 144.

Design Virtual
Service

Enables you to design a virtual service and define its behavior.

Creates new virtualization project and a virtual service, and opens the Data
Model Editor.

For user interface details, see "DataModel Editor" on page 240.

Discover
Services

Enables you to discover services suitable for virtualization in your application
under test.

Creates a new virtualization project, and opens the Service Discovery dialog
box, enabling you to find all services used by an application.

For user interface details, see "Service Discovery Dialog Box" on page 301.

Data Driven
Simulation

Enables you to virtualize a service and define its behavior using data from an
external source.

Creates a new virtualization project and a virtual service with an external data
rule, and then opens the DataModel Editor.

For user interface details, see "DataModel Editor" on page 240.
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UI Element Description

Composite
Application
Testing

Enables you to describe the topology of a composite application, and virtualize
services with limited access.

Creates a new virtualization project and a topology, and opens the Topology
editor.

For user interface details, see "Topology Editor" on page 296.

Service
Administration

Enables you to view all services from configured servers, without opening
individual projects.

For user interface details, see "Service Administration" on page 175.

Sample Projects Page

Service Virtualization application demos are installed as an option during the Service Virtualization
Designer installation process. Each sample project has an accompanying Readme file in PDF format,
which provides additional information on working with the sample project. The sample project folders
are located, by default, in <Your Documents folder>\HP Service Virtualization\Demos.

The following demos are included:

UI Element Description

Claim
Processing
JDBC Demo

This demo shows a composite application consisting of JDBC services.

Claim
Processing
Demo

This demo shows the simulation of a backend SOAP service with limited
accessibility in a simple composite application. The service can optionally use
HTTP authentication (see demo readme).

Claim
Processing
REST Demo

This demo shows a composite application consisting of 2 REST services using
JSON and XML data formats.

Claim
Processing
Faults Demo

The simulation of a backend SOAP service with limited accessibility in a simple
composite application. The simulated service returns either regular response or one
of 3 different SOAP faults.

Claim
Processing
Security
Demo

This demo shows a composite application consisting of 2 SOAP services. It allows
demonstrating how to record and simulate the behavior of one of the SOAP
services. Both services authenticate each other using X509 certificates.
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UI Element Description

Claim
Processing
Standalone
Server Demo

This demo shows a composite application consisting of 2 SOAP services. It allows
demonstrating how to record and simulate the behavior of one of the SOAP
services on a standalone server.

Claim
Approval
JMS Demo

This demo shows a composite application consisting of 3 SOAP services. It allows
demonstrating how to record and simulate the behavior of two SOAP services.
Demo is similar to the Claim processing service simulation demo. One XML over
JMS service (TIBCOEMS approval service) has been added to the topology here
and is being simulated, too.

Claim
Approval MS
MQ Demo

This demo shows a composite application consisting of 3 SOAP services. It allows
demonstrating how to record and simulate the behavior of two SOAP services. The
demo is similar to the Claim Processing service virtualization demo. One XML over
MS MQ service (MS MQ approval service) has been added to the topology here
and is being simulated, too.

Claim
Approval
WebSphere
MQ Demo

This demo shows a composite application consisting of 3 SOAP services. It allows
demonstrating how to record and simulate the behavior of two SOAP services. The
demo is similar to the Claim Processing service virtualization demo. One XML over
WebSphereMQ service (WebSphereMQ approval service) has been added to the
topology here, and is being simulated, too.

IBM IMS
Transaction
Manager
Phonebook
Demo

This demo shows virtualization of the Phonebook IMS TransactionManager
application. The client is using IBM IMS Connect API to communicate with IMS
TM over TCP/IP.

Request
Tracking
Service
Activity
Demo

This demo shows a composite application consisting of 4 SOAP services. It allows
demonstrating how to record and simulate the behavior of two SOAP services. In
addition, activity can be demonstrated by calling the third SOAP service from a
simulated service.

SAP IDoc
Demo

This demo shows the virtualization of a service that uses the SAP IDoc protocol. It
enables you to record and simulate asynchronous IDoc message transfer.

SAP RFC
Demo

This demo shows the virtualization of a service that uses the SAP RFC protocol. It
enables you to record and simulate a remote-enabled RFC functionmodule.

ShoppingCart
- No Sessions
Demo

This demo shows virtualization of stateful shopping cart service, where only one
client is using the stateful service.

ShoppingCart
- Sessions by
Clients Demo

This demo shows virtualization of stateful shopping cart service, wheremultiple
concurrent clients are using the stateful service and private session is generated
for each client.
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UI Element Description

ShoppingCart
- Sessions by
Orders Demo

This demo shows virtualization of stateful shopping cart service, wheremultiple
concurrent clients are using the stateful service and sessions are generated per
each shopping order. The checkout operation finishing shopping order destroys the
client session (the next operation creates a new one).

Test Data
Management -
Import Data
Demo

This demo shows the virtualization of a backend SOAP service with simulation
data imported from an external data file.

Test Data
Management -
Export Data
Demo

This demo shows the virtualization of a backend SOAP service with the export of
learned data to an external data file.

Service Virtualization Main Window

To access Use one of the following:

l From the File menu, select Open Project/Solution.

l From the Start Page, under Recent Projects, select a project to open.

Important
information

To display panes that are not displayed by default, click theViewmenu and
select a pane.

Relevant tasks "How to Use Service Virtualization" on page 23
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See also l "Service Virtualization Overview" on page 16

l "Service VirtualizationMainMenus" below

The Service Virtualization Designer window contains the following key elements (unlabeled elements
are shown in angle brackets):

UI Element Description

<main
display
pane>

Displays all open virtualization entities.

<lower
pane>

Displays the Problem List or the Runtime View. For details, see "Problem List" on
page 174 and "Runtime View" on page 173.

<side bar> Displays links to Virtualization Explorer, Project pane, and Tools pane, when they
are pinned.

<main
menus and
buttons>

For command and button descriptions, see "Service VirtualizationMainMenus"
below.

Virtualization
Explorer

Located in the left pane of the window, displays the virtualization entities in your
open project in a hierarchical tree structure. For details, see "Virtualization Explorer"
on page 142.

Project pane Located in the left pane of the window, displays the list of files included in your open
project.

To rename a project, right-click the project name and select Rename Project.

Tools pane Located in the left pane of the window, displays items that you can add to your
topology. For details, see "Topology Editor" on page 296.

Also used when editing an XML schema. For details, see "Service Description
Editor" on page 152.

Runtime
View

Located in the lower pane of the window, displays the virtual services included in
your open project. For details, see "Runtime View" on page 173.

Problem List Located in the lower pane of the window, displays problems that occur during the
application or server run. For details, see "Problem List" on page 174.

Service Virtualization Main Menus
This section describes themainmenu options available in Service Virtualization.

To access Themainmenu is available from all Service Virtualization views.
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Relevant tasks "How to Use Service Virtualization" on page 23

See also l "Service Virtualization Overview" on page 16

l "Service VirtualizationMainWindow" on page 32

User interface elements are described below.

UI Element Description

File > Checkout Enables you to check out a project or solution from SVN. For details, see
"Version Control Support" on page 332.

File > Close
File

Closes the currently active project window.

File > Close
Project/Solution

Closes the open project.

File > Export
Project

Enables you to save your project as a file in the file system. The file is saved
with the default file extension .vproja.

File > New
> Topology

Opens the Summary of New Topology dialog box, enabling you to create a new
topology. For details, see "Summary of New Topology Dialog Box" on page 296.

Note: Available in an open project.

File > New
> Virtual
Service

Launches the new virtual service wizard. For details, see "Create New Virtual
ServiceWizard" on page 119.

Note: Available in an open project.

File > New
> Multiple
Virtual Services

Createmultiple SOAP virtual services simultaneously.

Note: Available in an open project.

File > New
> Virtual
Service from
Template

Opens the Choose Template for Virtual Service dialog box, enabling you to
create a new virtual service based on an existing template. For details, see
"How to Create a Virtual Service" on page 104.

Note: Available in an open project.

File > New
> Virtualization
Project

Enables you to create a new virtualization project. For details, see "Summary of
Virtualization Project Dialog Box" on page 118.
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UI Element Description

File > Open
Project/Solution

Opens your file system browser, enabling you to select a virtualization project to
open.

File > Recent
Projects

Displays list of recently opened projects, enabling you to select a project to
open.

Select Clear recent project list to delete the list.

File > Reload
File

Not in use.

File > Reload
Solution

Reloads solution from file system.

File > Save Saves changes made in the editor window in which you are currently working.

File > Save All Saves changes made in all open editor windows.

File > Save
Project As

Makes a copy of the open project, and saves it with a new name.

View > Problem
List

Displays the Problem List in the bottom pane of the Service Virtualization
window. For details, see "Problem List" on page 174.

View > Projects Opens the Projects pane, displaying the files included in the open project.

View > Runtime
View

Displays the Runtime View in the bottom pane of the Service Virtualization
window. For details, see "Runtime View" on page 173.

View > Service
Administration

Displays the Service Administration window. For details, see "Service
Administration" on page 175.

View > Start
Page

Opens the Service Virtualization Start Page. For details, see "Start Page" on
page 28.

View > Task
List

Opens the Task List pane. For details, see "Topology Editor" on page 296.

View > Tools Opens the Tools pane, displaying a toolbox of items for the Topology editor, and
also for the XML and XML schema editor.

View > Tools
> Files

Opens the Files pane, displaying your local file system in a browser.

View > Tools
> Search
Results

Not in use.
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UI Element Description

View > Tools
> XPath Query

Not in use.

Project > Open
Folder in
Explorer

Opens the open project's folder in your file system browser, displaying the files
included in the project.

Project >
Change Server

Opens the Change Server for <open project> Project dialog box, enabling you to
redeploy virtual services in the current project to another server.

Tools > Clear
Project Cache

Clears project cache and reloads the project. If an error occurs, for example, if
you are unable to open one of the Service Virtualization editors, it is
recommended to try using this option.

Tools > Options Opens theOptions dialog box.

l To configure Service Virtualization agents, click theAgents tab.

l To view, add, or delete servers, click theServers tab.

Tools > Refresh
Sample
Projects

Opens the Refresh Sample Project dialog box, enabling you to delete the current
contents of the sample project folder and reload new copies of the sample
virtualization projects.

Note:When you refresh the sample project folder, all custom changes made in
this folder are lost.

ALM > ALM
Connection

Enables you to define settings for connecting to HP Application Lifecycle
Management (ALM). For details on integrating with HP ALM, see
"HP Application Lifecycle Management (ALM) Integration" on page 325.

ALM > Check
Out

Opens the Check Out dialog box, enabling you to check out a virtualization
project that is stored in an ALM version controlled project.

ALM > Undo
Check Out

Discards any changes youmade in the checked out project, and opens the last
checked in version in read-only mode.

ALM > Check In Opens the Check In dialog box, enabling you to check in your changes to ALM.

ALM > Version
History

Displays details of all versions of the open project.

Window >
Close All
Documents

Closes all open project windows.

Window > Next
Window

Moves to the next open window in your project.

Window >
Previous
Window

Moves to the previous open window in your project.
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License Installation Wizard
This section includes:

Select License Type Page 37

License InstallationWizard - Installation Pages 39

Select License Type Page

This wizard page enables you to:

l select a Service Virtualization Designer license to install

l view currently installed licenses

To access From the Helpmenu, select License Management.

Wizard map Select License Type Page > "License InstallationWizard - Installation
Pages" on page 39

Important
information

If you do not yet have a license, the wizard guides you how to obtain one.

Relevant tasks "How to Install a Service Virtualization Designer License" on page 25

See also "Service Virtualization Designer Licensing" on page 17

This section includes:

l "License Types" on the next page

l "Currently Installed Licenses " on the next page
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User interface elements are described below:

License Types

UI Element Description

Evaluation
License

Use a 30-day trial license that may have been provided to you by HP.

Displays remaining days until license expiration.

Concurrent
License

Obtain a license from the HP Autopass License Server.

Multiple users share a pool of licenses stored on a license server. The license is linked
to themachine's IP address.

Seat
License

Obtain and install a permanent license for your Designer machine.

For use for a single machine running the Service Virtualization Designer.

The license is linked to themachine's Host ID, a unique number generated by Service
Virtualization, and bound to themachine's hardware.

Commuter
License

A temporary license provided by the License Server that enables the Designer to work
offline.

Request a commuter license when you will have limited or no access to the license
server, and cannot check out a license. A commuter license is valid for 14 days.

Currently Installed Licenses

UI Element Description

Status l Invalid. The license has expired, or the license and host IDs do not
match.

l To be expired. The license will expire on the expiration date listed.

l Valid. The license is active.

Locked The license is linked to a specific client (Designer) machine.

Type Instant On. The temporary license that is installed when you install the Service
Virtualization Designer.

Evaluation. A 30-day trial license is installed.

Floating. A concurrent license is installed.

Permanent. A seat license is installed.

Commuter. A commuter license is installed.
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UI Element Description

Expiration
Date

Displays the date on which the license will expire.

Note:When a floating license expires, it is automatically renewed if you are
still working in the Designer.

Capacity Quantity of available licenses.

License Installation Wizard - Installation Pages

These wizard pages enable you to:

l request a floating or commuter license from the license server

l request a new seat license from HP

l install a license

l return a commuter license to the license server

Important
information

l See the relevant section below for the type of license you want to install.

l Concurrent and commuter licenses require access to the HP Autopass License
Server. For details on installing the HP Autopass License Server, see theHP
Service Virtualization Installation Guide.

Wizard
map

"Select License Type Page" on page 37 > License Installation Wizard -
Installation Page

Relevant
tasks

"How to Install a Service Virtualization Designer License" on page 25

See also "Service Virtualization Designer Licensing" on page 17

This section includes:

l "Concurrent License Installation" on the next page

l "Seat License Installation" on page 41

l "Commuter License Installation" on page 42

User interface elements are described below:

User Guide
Chapter 1: Service Virtualization at a Glance

HP Service Virtualization (3.61) Page 39 of 352



Concurrent License Installation

The concurrent license page includes the following options:

UI
Element Description

Host The host name or IP address of the HP Autopass License Server.

Port The communications port of the license server.

Default value: 5814

Change
Server

Enter the host and port details of a different server, and click Change Server to connect
to the new server.

Get
Floating
License

Retrieves a license from the license server. Concurrent licenses are valid for a period of
15minutes, after which they are automatically renewed.

If you are using a concurrent licensemodel and have access to a license server, a license
is automatically checked out each time you open the Designer. When you close the
Designer, the concurrent license is returned to the license server.

Return
Floating
License

If you no longer need the license, you can return it to the license server.

Alternatively, closing the Designer returns the license to the server.
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Seat License Installation

The seat license page includes the following options:

UI Element Description

Obtain a new Seat
license

Click theHP Licensing for Software link to connect to HP, and sign in to
request a license.

Host ID Record this detail. It is required when you submit a request for a new seat
license.

Click Copy to Clipboard to copy the Host ID.

Install your Seat
license

Select an installation option. Browse to select a license file, or enter a
license key.

Next Opens the License File Content page. Select a license to install.
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Commuter License Installation

The commuter license page includes the following options:

UI Element Description

Host The host name or IP address of the HP Autopass License Server.

Port The communications port of the license server.

Change Server Enter the host and port details of a different server, and click Change Server to
connect to the new server.

Online Operations: (For use when you have access to the license server)

Get Commuter
License

Request a license from the license server that you can use offline for a specific
number of days.

Recover
Commuter
License

Download a new copy of your commuter license if the license was lost.

Return
Commuter
License

Returns the commuter license to the license server when you no longer need it.

Offline Operations: (For use when you cannot access the license server.)

Create a File
to Get
Commuter
License

Generates a license input file used for requesting a new commuter license. You
can send the file to a user with access to the license server. A license server user
can then check out a license, and send it back to you.
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UI Element Description

Install
Commuter
License

Installs the license from the license file.

Create a File
to Return
Commuter
License

Generates a license file that contains the license information, in order to return a
commuter license to the license server. You can then send the file to a user with
access to the license server.
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Chapter 2: Service Virtualization Agents
This chapter includes:

Service Virtualization Agents Overview 45

How to Configure Agents 45

How to Forward HTTP Agent Communication Through an HTTP Proxy 65

Agents User Interface 65
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Service Virtualization Agents Overview
This chapter provides instructions on configuring Service Virtualization Agents. Agents handle
communication between a client and a real or virtual service. Each agent handles communication
specific to the transport andmessage protocols you are using. Youmust configure the Service
Virtualization agent for each protocol your services are using.

The Service Virtualization agents must be configured on each server (embedded or standalone) on
which the services are deployed. You can addmultiple instances of an agent to the same server,
configuring each one differently.

Note: Not all agents are installed by default. For details on installing an agent manually, see the
relevant help section on the agent you require.

For task details on configuring the Service Virtualization agents, see "How to Configure Agents" below.

How to Configure Agents
This task describes how to configure Service Virtualization agents. There are several pre-configured
agent instances with default configurations. You can use these instances, modify them, or define new
instances.

Note:

l This task is part of a higher-level task. For details, see
"How to Use Service Virtualization" on page 23.

l To learnmore about Service Virtualization Agents, see
"Service Virtualization Agents Overview" above.

See also:

l "How to Virtualize SAP IDoc
Communication" on page 112

l "How to Virtualize a Fixed-Length
over TCP Protocol" on page 113

To configure an agent:

1. From themainmenu, select Tools > Options and click theAgents page.

2. In the left pane, expand the server to display the available agents and configurations.

3. Select the agent you want to configure, and fill in the properties.

4. To add another configuration of an agent, choose one of the following:

n Click Add. A new configuration is added and you canmodify its settings.

n Click Import. Select an agent configuration file that was exported from a Service Virtualization
Server (embedded or standalone) and saved on the file system.

User Guide
Chapter 2: Service Virtualization Agents

HP Service Virtualization (3.61) Page 45 of 352



If the configuration file you are importing contains multiple configurations, you can select which
configurations you want to import.

If you choose to import an agent configuration that is identical to a configuration that already
exists on your server, you can choose to overwrite your existing configuration, or create a new,
additional configuration.

You can also delete, duplicate, and export agent configurations. For user interface details, see "Agents
Page" on page 66.

This section also includes:

How to Configure the HTTP/HTTPS Gateway Agents 47

How to Configure the HTTP(S) Proxy Agent 48

How to Configure the JDBC Agent 49

How to Configure the JMS Generic Agent 52

How to Configure theMSMQAgent 53

How to Configure the Oracle AQAgent 54

How to Configure the SAP Agent 56

How to Configure theWebMethods SAP Agent 57

How to Configure the IBM IMS TM Agent 60

How to Configure theWebSphereMQAgent 61

How to Configure the TIBCO EMS Non Intrusive Agent 63
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How to Configure the HTTP/HTTPS Gateway Agents
This task describes how to configure the Service Virtualization HTTP/HTTPS gateway agents.

The HTTP/HTTPS Gateway Agents serve to virtualize HTTP communication. A virtual HTTP endpoint
is created tomediate between a client and a real service HTTP endpoint. During the learning process,
real communication is forwarded to a real service HTTP endpoint and the communication is recorded.

1. Configure the agent settings

From themainmenu, select Tools > Options. On the Agents Page, select HTTP Gateway or
HTTPS Gateway. For user interface details, see "HTTP/HTTPS Gateway Agent Settings" on
page 66.

2. Forward unknown endpoint requests

If you are not able to reconfigure clients on a service basis (i.e. changing the endpoint of each
service to a virtual service), and all of your HTTP(S) services reside on a single host, you can use
the Forwarded to Host option on the Agents Page.

Example:

The client is calling several backend services:

http://esb.demo.hp.com:8080/BackendServices/MemberAccounts

http://esb.demo.hp.com:8080/BackendServices/ExchangeRate

http://esb.demo.hp.com:8080/BackendServices/Approval

You are only virtualizing theMemberAccounts service but are only able to reconfigure the
application to use another host for all services rather than changing the endpoint of just the
oneMemberAccounts service in the application.

You reconfigure your application to use the SV Server HTTP Gateway at:

http://svserver.hp.com:7200 instead of http://esb.demo.hp.com:8080

The application will access backend services at these endpoints:
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http://svserver.hp.com:7200/BackendServices/MemberAccounts

http://svserver.hp.com:7200/BackendServices/ExchangeRate

http://svserver.hp.com:7200/BackendServices/Approval

You create theMemberAccounts service so this functions but the other services would be
inaccessible for the application until you virtualized all of them.

To avoid the virtualization of all backend services set the DEFAULT TARGET HOST to

http://esb.demo.hp.com:8080

Now all requests to non-virtualized services are forwarded to the
http://esb.demo.hp.com:8080 host and are reaching the real services you do not intend to
virtualize now.

Note: The Forwarded to Host field can contain a base URL in several formats: the host,
optional port, and optional base path, i.e.: http://esb.demo.hp.com,
http://esb.demo.hp.com:8080

3. Configure a proxy agent

To set the proxy agent configuration properties, see "How to Configure the HTTP(S) Proxy Agent"
below.

How to Configure the HTTP(S) Proxy Agent
This task describes how to configure the Service Virtualization HTTP(S) proxy agent.

The HTTP(S) Proxy Agent serves to virtualize HTTP and HTTPS communication. No endpoint is
created, and an HTTP(S) proxy is used to receive and forward client communication to a real service
HTTP or HTTPS endpoint.

1. Configure the agent settings

The HTTP(S) proxy agent dynamically generates certificates for requested hosts on the fly. The
certificates are signed by the configured certificate authority (CA). Configure the CA certificate
and private key in the HTTP(S) Proxy agent configuration.

From themainmenu, select Tools > Options. On the Agents Page, select HTTP(S) Proxy. For
user interface details, see the "HTTP(S) Proxy Agent Settings" on page 69.

2. Configure the client

The client must trust certificates signed using a configured CA or the communicationmay fail due
to rejection by the client.
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How to Configure the JDBC Agent
This task describes how to configure the JDBC agent. The JDBC agent is used to virtualize both J2EE
and J2SE applications that are using JDBC™API to access persistent storage.

The JDBC agent consists of two components:

l JDBC agent. You configure the JDBC agent in Service Virtualization. The agent listens for
requests from the JDBC driver.

l JDBC driver. You install the JDBC driver in your application under test. The driver communicates
remotely with the JDBC agent in Service Virtualization. It intercepts each JDBC API call and
depending on the current servicemode, forwards the traffic accordingly. If the virtual service is in
either Standby or Learningmode, the driver forwards the traffic to the actual JDBC driver. If the
virtual service is in Simulatingmode, the virtual service simulates the API response.

The JDBC driver is uniquely generated according to the configuration of the JDBC agent and agent
host that you define in Service Virtualization. The driver is invoked only if either a virtualization
JDBC connection string is used (J2SE), or if the virtual data source is explicitly created and used by
the application (J2EE). If a non-virtualization connection string or data source is used, the
virtualization JDBC driver is inactive and has no impact on the application under test.

1. Prerequisites:

The following types of integration scenarios are supported:

n A J2SE application using JDBC 3.0 or 4.0/4.1 API.

n A Java™ based application deployed on a J2EE application server (J2EE version 1.4 or later).

2. Configure the agent settings:

From themain Service Virtualizationmenu, select Tools > Options. On the Agents Page, select
JDBC Agent. For user interface details, see the "JDBC Agent Settings" on page 72.

3. Reconfigure a standard J2SE or J2EE application:

n J2SE

n J2EE

Reconfigure a standard J2SE application

To reconfigure a typical Java Standard Edition (J2SE) application for JDBC API virtualization:
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a. Make sure you have configured the agent settings correctly.

b. Download the JDBC driver. On the Agents Page, click Download JDBC driver for this
configuration.

c. Deploy the driver in the application class path.

d. Create anSQL over JDBC virtual service, and use the actual JDBC connection string as the
Virtual Service Real Connection String.

e. Reconfigure the application under test to use virtual endpoint. If you are working with JDBC
version 3.0, youmust also update the JDBC driver class name to the virtualization driver
class name. The virtual driver class name is com.hp.sv.jdbc.agent.jdbc3.VirtualDriver.

Reconfigure a standard J2EE application

To reconfigure a typical Java Enterprise Edition (J2EE) application using JDBC data sources, for
JDBC API virtualization:

a. Make sure you have configured the agent settings correctly.

b. Download the JDBC driver. On the Agents Page, click Download JDBC driver for this
configuration.

c. Create an additional J2EE data source using the newly created virtual JDBC driver that you
downloaded from the Service Virtualization Agents page. See the J2EE application server
documentation for more details.

d. Reconfigure the application under test to use the newly created data source.

e. Create anSQL over JDBC virtual service, and use the name of the newly created data
source as the Real Connection String.

4. Configure your application server:

n WebLogic 12c

n WebSphere 8

n WebSphere 6

n WebMethods

Add a virtual data source to a WebLogic 12c application server

a. Place the JDBC driver that you downloaded from the Service Virtualization Agents page in
WL_HOME\server\lib.
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b. ModifyWEBLOGIC_CLASSPATH inWL_HOME\common\bin\commEnv.cmd (or
commEnv.sh), as described in theWebLogic documentation.

c. In theWebLogic Server Administration Console, create a new data source. Provide the JNDI
name of the real data source, using the RealDataSourceName property.

Alternatively, you can set up the JNDI virtual driver to use a direct connection to the database,
by specifying the realUrl property. For example:
realUrl=jdbc:oracle:thin:@database.host.com:1521:orcl.

d. Restart theWebLogic server.

Add a virtual data source to a WebSphere 8 application server

a. In theWebSphere administrative console, inResources > JDBC > JDBC Providers, add a
new virtual JDBC provider.

database type: user-defined

implementation class name: com.hp.sv.jdbc.agent.jdbc4.VirtualDataSource

classpath: enter the path to the downloaded virtual JDBC driver

b. Create a new data source using the newly created JDBC Provider. and enter custom
properties.

Provide the JNDI name of the real data source, using theRealDataSourceName property.

Alternatively, you can set up the JNDI virtual driver to use a direct connection to the database,
by specifying the realUrl property. For example:
realUrl=jdbc:oracle:thin:@database.host.com:1521:orcl.

You do not need to define properties for username and password if you use the JAAS - J2C
authentication data alias in the security settings for the virtual data source.

c. Run theWebSphere test connection operation on the virtual data source.

Add a virtual data source to a WebSphere 6 application server

a. In theWebSphere administrative console, inResources > JDBC > JDBC Providers, add a
new virtual JDBC provider.

database type: user-defined

implementation class name: com.hp.sv.jdbc.agent.jdbc3.VirtualDataSource

classpath: enter the path to the downloaded virtual JDBC driver

b. Create a new virtual data source using the newly created JDBC provider.

User Guide
Chapter 2: Service Virtualization Agents

HP Service Virtualization (3.61) Page 51 of 352



c. Disable statement caching. In theWebSphere Application Server data source properties, set
Statement Cache size to 0.

d. Define custom properties for the virtual data source:

Provide the JNDI name of the real data source, using theRealDataSourceName property.

Alternatively, you can set up the JNDI virtual driver to use a direct connection to the database,
by specifying the realUrl property. For example:
realUrl=jdbc:oracle:thin:@database.host.com:1521:orcl.

You do not need to define properties for username and password if you use the JAAS - J2C
authentication data alias in the security settings for the virtual data source.

e. Run theWebSphere test connection operation on the virtual data source.

Configure a WebMethods Integration Server

In theOther Properties field of the JDBC Adapter, use the realUrlproperty in place of
realDataSourceName, and enter the connection string to the real database. Use a semicolon (;) to
specify multiple properties, such as serverHost and serverPort.

For example:

realUrl=jdbc:oracle:thin:@database.host.com:1521:svdb2QA;serverHost=virtualization.com;ser
verPort=12345

Note: TheOther Properties field cannot contain spaces.

How to Configure the JMS Generic Agent
This task describes how to configure the Service Virtualization Generic JMS agent.

TheGeneric JMS Agent serves to virtualize JMS communication in any JMS provider (IBM®
WebSphere® MQ, Weblogic, JBoss, ...). It uses general JMS API and JNDI to lookup and work with
JMS resources (context factories, connection factories, queues, topics). It loads Java JVM (Java
Virtual Machine) with JMS provider libraries required for JMS communication in process.

Note: TheGeneric JMS Agent only supports JMS BytesMessage and TextMessage according to
the SOAP over JMS specifications.
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1. Prerequisites

TheGeneric JMS Agent uses a standard JMS API with JNDI lookups. Youmust first configure an
environment with JMS resources.

a. Configure JMS. Create virtual destination(s) in JMS server (WebpshereMQ, Weblogic,
JBoss, …)

i. Create a Virtual Request destination.

ii. If you want to use a permanent ReplyTo destination, create a Virtual Reply destination.
If not, a temporary ReplyTo destination is used.

b. Configure JNDI. Configure JNDI mapping for virtual destinations enable the agent to lookup
destinations in JNDI.

i. Configuremapping for the Virtual Request destination.

ii. If a permanent ReplyTo destination is used, configuremapping for the Virtual Reply
destination.

2. Configure the agent settings

From themainmenu, select Tools > Options. On the Agents Page, select JMS. For user
interface details, see the "JMS Generic Agent Settings" on page 74.

How to Configure the MSMQ Agent
This task describes how to configure theMicrosoft MessageQueuing (MSMQ) Agent.

1. Prerequisites

The followingWindows featuremust be installed on the Service Virtualizationmachine:
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Microsoft MessageQueue (MSMQ) Server > MSMQActive Directory Domain Services
Integration (for computers joined to a Domain)

For details, refer to Microsoft documentation.

2. Configure the agent settings

From themainmenu, select Tools > Options. On the Agents Page, selectMicrosoft MQ. For
user interface details, see the "MSMQAgent Settings" on page 77.

MSMQ Agent Limitations

Service Virtualization uses Direct Format Names. MSMQ queues and hosts defined in Service
Virtualization are converted, as in the following example:

Host: www.example.com

Queue: private$\request.virtual.queue

Result: DIRECT=OS:www.example.com\private$\request.virtual.queue

The following are not supported:

l Different authentication for different MSMQ queues. The same user is used for running the Service
Virtualization Server (embedded or standalone) and for authentication of all MSMQ queues defined
in virtual MSMQ services on the Service Virtualization Server.

l ActiveX messages over MSMQ

l MSMQ transactions

l MSMQ journaling

l MSMQextensions

l MSMQencryption

How to Configure the Oracle AQ Agent
This task describes how to configure the Service Virtualization Oracle AQ agent.

The Service Virtualization Oracle AQAgent serves to virtualize communication between applications
that are using Oracle AdvancedQueuing. It supports buffered and persistent multi-user queues with
UDT and XML payloads.

The Service Virtualization Oracle AQAgent requires:

l one AQ subscribing agent in the Oracle database assigned to virtualization for listening on the
request queue
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l optionally, a second AQ agent in the Oracle database for listening on the response queue when the
virtual service is in recording and stand-by mode, and for publishing responses when the virtual
service is in simulatingmode.

Requests and responses are correlated using a correlation identifier of the AQmessage. You can
combine UDT requests with XML responses and vice-versa. For more information onOracle Advanced
Queuing and correlation identifiers, see the Oracle documentation.

1. Prerequisites

a. Youmust install Oracle Data Provider for .NET 11g on the Service Virtualizationmachine
running the Service Virtualization Oracle AQ agent. TheOracle AQ agent requires Oracle Data
Provider for .NET 11g to access the Oracle database. Oracle Data Provider for .NET 11g is a
part of ODAC 11.2, which can be downloaded from theOracle download site.

b. Youmust create a subscribing agent in the Oracle database dedicated to virtualizing
messages coming to the request queue (SV Subscriber in the image above) and optionally a
second one dedicated to virtualizingmessages coming to the response queue (SV Publisher
in the image above).

2. Configure the agent settings

From themainmenu, select Tools > Options. On the Agents Page, select OracleAQ. For user
interface details, see the "Oracle AQAgent Settings" on page 79.
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How to Configure the SAP Agent
This task describes how to configure the SAP agent. The SAP agent handles SAP RFC or SAP IDOC
communication between a SAP®  or SAP NetWeaver® Process Integration (PI) system, and a real or
virtual SAP service.

1. Prerequisites

Make sure that the following are configured on each Service Virtualization Designer or Service
Virtualization standalone server machine on which you are using the SAP Agent:

a. SAP .Net Connector 3.0.10.0.

During installation of the connector, there is an option to install dlls to the GAC. You can
select this option, or you can choose to copy the dlls manually to the Service Virtualization
installation directory's \bin folder after installation.

b. SAP GUI.

Alternatively, if you do not have SAP GUI installed, you can do the following:

i. Update theWindows services file, located in%WinDir%\System32\drivers\etc.

Add the following two lines, replacing xx with your SAP system number:

sapdpxx 32xx/tcp

sapgwxx 33xx/tcp

ii. Copy the appropriate SAP librfc32.dll and librfc32u.dll files for your system into the
Windows folder, as follows:

On a 32-bit operating system:

If the Service Virtualization Designer or the 32-bit Service Virtualization Server are
installed, copy the 32-bit versions of librfc32.dll and librfc32u.dll into the
Windows\System32 folder.

On a 64-bit operating system, do both of the following:

Copy the 32-bit versions of librfc32.dll and librfc32u.dll into theWindows\SysWOW64
folder.

If the 64-bit Service Virtualization Server is installed, copy the 64-bit versions of
librfc32.dll and librfc32u.dll into theWindows\System32 folder.

2. Configure the agent settings

User Guide
Chapter 2: Service Virtualization Agents

HP Service Virtualization (3.61) Page 56 of 352



From themainmenu, select Tools > Options. On the Agents Page, select SAP. For user
interface details, see the "Agents Page" on page 66.

3. Reconfigure the client to point to the virtual service

For a SAP Server: If your source SAP system is a SAP Server, youmust reconfigure the SAP
RFC destination to point to the virtual service.

a. On the SAP server, navigate to transaction sm59. Locate and delete the original destination.

b. Under TCP/IP Connections, create a new destination and configure the following:

o RFC destination. Assign the same name as the original destination.

o Registered Server Program. Select this option, and enter theProgram ID. The value
you assign to Program ID must be identical to the Program ID entered in the virtual
service's properties in Service Virtualization.

o Gateway Options. Enter the SAP Gateway Host andGateway Service Name These
values must be identical to the values entered in the Service Virtualization Agents page.

c. Click Connection Test to test your configuration. Your virtual servicemust be deployed to
carry out this test.

For SAP PI : If your source SAP system is SAP PI, youmust reconfigure the communication
channel.

In SAP PI Integration Builder, navigate to the appropriate RFC receiver communication channel,
and configure the following:

n RFC Server Type. Select External RFC Server.

n Application Server (Gateway). Enter the SAP Gateway Host (the PI System). The value
must be identical to the value entered in the Service Virtualization Agents page.

n Application Server Service (Gateway). Enter the SAP Gateway Service Name. The value
must be identical to the values entered in the Service Virtualization Agents page.

n Program ID. The value you assignmust be identical to the Program ID entered in the virtual
service's properties in Service Virtualization.

How to Configure the WebMethods SAP Agent
This task describes the virtualization process, and how to configure the Service Virtualization
WebMethods SAP agent.

The agent enables you to virtualize IDOC document exchange between flow services hosted in
WebMethods Integration Server and a SAP system using JVM instrumentation.

The agent consists of two components:
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l Java instrumentation. Provides an instrumentation of theWebMethods Integration Server and
captures data exchanged between the service and the SAP system. Youmust configure the JVM of
theWebMethods Integration Server so that it can communicate with theWebMethods SAP agent
running on the Service Virtualization Server.

l WebMethods SAP agent. Provides an interface between the Java instrumentation component and
the Service Virtualization Server.

What do you want to do?

l Readmore about the virtualization process

l Configure the agent

The Virtualization Process

The scenario we want to virtualize is as follows:

l TheWebMethods Integration Server hosts flow services.

l The flow services use theWebMethods SAP Adapter to publish IDOCs to a remote SAP system.

l The remote SAP system publishes IDOC responses through theWebMethods SAP Adapter back
to the flow services hosted by theWebMethods Integration Server.

When the virtual service is in Learning or Standby mode, the SV Remote Agent on theWebMethods
Integration Server communicates with Service Virtualization to record or transmit data.
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During simulation, the Service VirtualizationWebMethods SAP agent completely simulates the
communication between theWebMethods SAP Adapter and the remote SAP system.

User Guide
Chapter 2: Service Virtualization Agents

HP Service Virtualization (3.61) Page 59 of 352



Configure the WebMethods SAP Agent:

1. Prerequisites

a. WebMethods Integration Server 8.2 with SAP Adapter 7.1.

b. In order for the virtual service to connect to the remote SAP server, theWebMethods
SAP Agent requires all prerequisites that are required for the SAP agent. For details, see
"How to Configure the SAP Agent" on page 56.

2. Configure the agent settings

From themainmenu, select Tools > Options. On the Agents Page, select WebMethods
SAP and click Add. Define settings for the new configuration. For user interface details, see the
"WebMethods SAP Agent Settings" on page 82.

3. Configure Java Instrumentation

a. Navigate to theWebMethods folder under the Service Virtualization installation directory. By
default:

For Service Virtualization Server: C:\Program Files\HP\HP Service Virtualization
Server\Tools\WebMethods

For the Designer: C:\Program Files (x86)\HP\HP Service Virtualization
Designer\Tools\WebMethods

b. Copy the following files into theWM_IS_HOME\lib\jars folder in the installation directory of
theWebMethods Integration Server, for exampleC:\SoftwareAG\IntegrationServer.

o HP.SV.JavaBcAgent.jar

o javassist.jar

o HP.SV.WmSapRemote.jar

c. Add the following to theWM_IS_HOME\bin\server.bat file:

set JAVA_AGENT=-javaagent:WM_IS_HOME\lib\jars\HP.SV.JavaBcAgent.jar

set JAVA_OPTS=%JAVA_AGENT%%JAVA_OPTS%

How to Configure the IBM IMS TM Agent
This task describes how to configure the IBM IMS TM agent. The IBM IMS TM Agent is used to
virtualize IBM IMS TransactionManager (TM) services that are exposed using the IMS Connect
protocol over a TCP/IP network.
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The IBM IMS TM agent is used as an IMS TM gateway. The clients communicate directly with the
agent. Then the agent either forwards the traffic to the actual IMS TM during pass-through (Standby
mode) or recording (Learningmode), or simulates the response. The communication is always
forwarded to IMS TM if it does not belong to any of the deployed services. For more details, see "How
to Create a Virtual Service" on page 104.

1. Prerequisites

The following types of integration scenarios are supported:

n A client using IMS Connect API.

n A client using IMS TMResource Adapter (managed and unmanaged).

2. Configure the agent settings

From themainmenu, select Tools > Options. On the Agents Page, select IBM IMS TM and click
Add. Define settings for the new configuration. For user interface details, see the "IBM IMS TM
Agent Settings" on page 84.

How to Configure the WebSphere MQ Agent
This task describes how to configure theWebSphereMQAgent.

TheWebSphereMQAgent uses the IBMWebSphereMQClient internally. This enables you to use all
diagnostic tools and logs provided by the client if you need to investigate any issues withWebSphere
MQ communication between HP Service Virtualization and the IBMWebSphereMQServer.

1. Prerequisites

TheWebSphereMQAgent is not installed by default. The agent is dependent on the IBM
WebSphereMQClient 7.0.1.6 or later (amqmdnet.dll library with version 1.0.0.3 and its
dependencies). The IBMWebSphereMQClient full installation places the required library in the
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Global Assembly Cache (GAC), making the agent available. If you install the client while the
Service Virtualization Server or Designer is running, youmust restart the application prior to
enabling the agent.

TheWebSphereMQAgent uses the IBMWebSphereMQClient internally. This enables you to
use all diagnostic tools and logs provided by the client if you need to investigate any issues with
WebSphereMQ communication between HP Service Virtualization and the IBMWebSphereMQ
Server.

To download theWebSphere MQ version 7.0 Client, see http://www-
01.ibm.com/support/docview.wss?uid=swg24019253.

To download theWebSphere MQ version 7.5 Client, see .http://www-
01.ibm.com/support/docview.wss?uid=swg24032744.

Note: An individual IBM ID is required for the downloads.

2. Configure the agent settings

From themainmenu, select Tools > Options. On the Agents Page, selectWebSphere MQ. For
user interface details, see the "WebSphereMQ Agent Settings" on page 86.

3. Optional: Perform additional global configuration

You can configure additional settings using the Service Virtualization configuration files.

a. Open the appropriate file:

o Standalone Server configuration file:

%[INSTALLLOCATION]%\Server\bin\HP.SV.StandaloneServer.exe.config

o Designer configuration file:

%[INSTALLLOCATION]%\Designer\bin\VirtualServiceDesigner.exe.config

b. You can define the following element in the appSettings section of the configuration files.
This configuration element sets up global behavior for processingWebSphereMQmessages.

o

<add key="MQAgent.DefaultCharacterSet" value="0"/>

Configures the default character set for simulated XML responses. Use this configuration
if the character set is not recorded as messagemetadata. If the value is set to 0 the
character set is not set.
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Agent limitations

l TheWebSphereMQAgent instance can only use queues from a single Queuemanager.

l TheWebSphereMQAgent instance can only use a single TCP channel to connect to the Queue
manager.

l CCSID configuration in theWebSphereMQAgent instance requires an application restart.

l CCSID configuration is global for whole the application. There cannot be two agents with different
CCSIDs.

How to Configure the TIBCO EMS Non Intrusive
Agent
The TIBCO EMS Non Intrusive Agent serves to virtualize JMS communication in TIBCOEnterprise
Message Service™ (TIBCOEMS). No endpoint is created and a client application does not require
reconfiguration. The agent listens to system topics where all communication can bemonitored. When
the service is switched to Simulatingmode, it manipulates the service JMS account permissions in the
JMS bus (EMS) to forbid a real service from receiving client communication. Administrator account
credentials in TIBCOEMS are required.
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1. Prerequisites

The TIBCOEMS Non Intrusive agent requires 2 DLL libraries that are not supplied with the
product: Tibco.EMS.dll and Tibco.EMS.Admin.dll. These libraries are supplied with the
installation of TIBCOEnterpriseMessage Service™ (EMS), located in the bin directory in the
EMS installation folder. The typical default location is c:\tibco\ems\6.0\bin\.

Note: The TIBCO dll libraries are available in both 32-bit and 64-bit versions. The dll version
must be the same version as the Service Virtualization Server.

Copy the 2 libraries to the bin folder of the Service Virtualization installation directory:

n If you are working with the Service Virtualization Server:By default, the Server
installation folder is located inC:\Program Files\HP\HP Service Virtualization
Server\Server\bin.

n If you are working with the Designer's embedded server:By default, the Designer
installation folder is located inC:\Program Files\HP (x86)\HP Service Virtualization
Designer\Designer\bin.
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Note: After copying the libraries to the directory, youmust restart Service Virtualization.

2. Configure the agent settings

From themainmenu, select Tools > Options. On the Agents Page, select TIBCO EMS Non
Intrusive. For user interface details, see the "TIBCO EMS Agent Settings" on page 92.

How to Forward HTTP Agent Communication
Through an HTTP Proxy
This task explains how to forward HTTP/HTTPS communication between the HTTP Gateway/HTTPS
Gateway/HTTP(S) Proxy agents and a real service through an additional proxy (proxy chaining).

To enable proxy chaining, perform following steps:

1. From themainmenu, select Tools > Options. On the Agents Page, select one of the following:

n HTTP Gateway

n HTTP(S) Proxy

n HTTPS Gateway

For user interface details, see the "Agents Page" on the next page.

2. Select theUse another proxy server to communicate with real services option, and click
Settings.

3. In the Proxy Settings Dialog Box, configure the settings. For user interface details, see "Proxy
Settings Dialog Box" on page 94.

Agents User Interface
This section includes:

Agents Page 66

Proxy Settings Dialog Box 94
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Agents Page
This section includes:

HTTP/HTTPS Gateway Agent Settings 66

HTTP(S) Proxy Agent Settings 69

JDBC Agent Settings 72

JMS Generic Agent Settings 74

MSMQAgent Settings 77

Oracle AQAgent Settings 79

SAP Agent Settings 81

WebMethods SAP Agent Settings 82

IBM IMS TM Agent Settings 84

WebSphereMQ Agent Settings 86

TIBCO EMS Agent Settings 92

HTTP/HTTPS Gateway Agent Settings

This dialog box enables you to configure the Service Virtualization HTTP/HTTPS Gateway Agent. The
agent handles communication between a client and a real or virtual service.

User Guide
Chapter 2: Service Virtualization Agents

HP Service Virtualization (3.61) Page 66 of 352



To access 1. From themainmenu, select Tools > Options.

2. Click Agents.

3. UnderHTTP(S) Gateway, select a configuration.

Important
information

l For additional important configuration information, see the task "How to
Configure the HTTP/HTTPS Gateway Agents" on page 47.

l You can definemultiple configurations for each agent.

Relevant
tasks

l "How to Configure Agents" on page 45

l "How to Forward HTTP Agent Communication Through an HTTP Proxy" on
page 65

See also "Service Virtualization Agents Overview" on page 45

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<left pane> Displays the server configured for your project.

Expand the server to display the available agents and configurations.

Add Enables you to define additional configurations of the agent.

Delete Deletes the selected configuration.

Duplicate Creates an additional configuration of the agent by copying the selected
configuration. You can thenmodify the configuration settings.

Note: By default, the configuration is created with a sequential
unoccupied port number.

Export Saves the selected agent configuration as a file. The file is saved in the .agce
file format, and can be imported to any Service Virtualization Server.

Export All Exports all agent configurations on the selected server. The file is saved in
the .agce file format, and can be imported to any Service Virtualization
Server.
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UI Element Description

Import Enables you to select an exported agent configuration file stored on the file
system. The file is saved in the .agce file format, and can be imported to any
Service Virtualization Server.

If the configuration file you are importing contains multiple configurations, you
can select which configurations you want to import.

If you choose to import an agent configuration that is identical to a
configuration that already exists on your server, you can choose to overwrite
your existing configuration, or create a new, additional configuration.

Agent State The current status of the agent. Values includeRunning, Not Running.

Test Configuration
link

Tests the configuration based on the settings you select. If Service
Virtualization identifies any problems in your configuration, the details are
displayed.

Is Enabled Turns the agent on and off.

Name Enter a name for the configuration or accept the default name.

Use SSL Enables SSL over TCP/IP. If enabled, youmust provide certificate file and
password details.

Certificate File The path to the server side certificate file, in P12 format, that is to be used by
the gateway agent during SSL authentication.

The certificate is used as the server certificate on the listening port if theUse
SSL option is enabled. It is bound to the port during startup of the agent.

Note:When remotely configuring a Service Virtualization Server's agent
from the Designer, make sure that the path to the certificate is valid on
the server machine on which the agent will run.

If theCertificate File field is left empty and theUse SSL option is selected,
then the agent will use the certificate bound to the specified port inWindows.

Certificate
Password

The password used to access the certificate file specified in theCertificate
File field.

Port The port of the Service Virtualization Server used by the agent to deploy
virtual services.

Timeout The period of time the agent waits before stopping attempts to communicate
with the real service.

External URI The URI under which the agent is visible to client applications. This is used,
for example when themachine is behind a firewall and the client can see only
the firewall which forwards all requests to the agent. It may be left empty.
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UI Element Description

Unknown Endpoint
Requests

Determines how to respond to requests when there is no service deployed
that matches the URL path provided.

Includes the following options:

l Return HTTP 404 Error.

l Forwarded to Host:Requests are forwarded to the specified URL path.

Use this option if you are not able to reconfigure clients on a service basis
(i.e. by changing the endpoint of each service to a virtual service), and all
of your HTTP(S) services reside on a single host.

Use another proxy
server to
communicate with
real services

Enables you to configure proxy chaining. You can forward the HTTP(S)
communication between the HTTP(S) Gateway agent and the real service
through an additional proxy. If it is not set, the system default proxy server is
used.

Click Settings to open the Proxy Settings dialog box. For details, see "Proxy
Settings Dialog Box" on page 94.

HTTP(S) Proxy Agent Settings

This dialog box enables you to configure the Service Virtualization HTTP(S) Proxy Agent. The agent
handles communication between a client and a real or virtual service.

To access 1. From themainmenu, select Tools > Options.

2. Click Agents.

3. UnderHTTP(S) Proxy, select a configuration.
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Important
information

l For additional important configuration information, see the task "How to Configure
the HTTP(S) Proxy Agent" on page 48.

l In case of Java based clients running on JDK 6 or later, and in the case of self-
signed certificates, it may be necessary to add the “-
Dsun.security.ssl.allowUnsafeRenegotiation=true” startup parameter or the client
may reject communication with the HTTPS Agent. For more details, see
http://java.sun.com/javase/javaseforbusiness/docs/TLSReadme.html.

l You can definemultiple configurations for each agent.

Relevant
tasks

l "How to Configure Agents" on page 45

l "How to Forward HTTP Agent Communication Through an HTTP Proxy" on page
65

See also "Service Virtualization Agents Overview" on page 45

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<left pane> Displays the server configured for your project.

Expand the server to display the available agents and configurations.

Add Enables you to define additional configurations of the agent.

Delete Deletes the selected configuration.

Duplicate Creates an additional configuration of the agent by copying the selected
configuration. You can thenmodify the configuration settings.

Note: By default, the configuration is created with a sequential
unoccupied port number.

Export Saves the selected agent configuration as a file. The file is saved in the
.agce file format, and can be imported to any Service Virtualization Server.

Export All Exports all agent configurations on the selected server. The file is saved in
the .agce file format, and can be imported to any Service Virtualization
Server.
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UI Element Description

Import Enables you to select an exported agent configuration file stored on the file
system. The file is saved in the .agce file format, and can be imported to
any Service Virtualization Server.

If the configuration file you are importing contains multiple configurations,
you can select which configurations you want to import.

If you choose to import an agent configuration that is identical to a
configuration that already exists on your server, you can choose to
overwrite your existing configuration, or create a new, additional
configuration.

Agent State The current status of the agent. Values includeRunning, Not Running.

Test Configuration
link

Tests the configuration based on the settings you select. If Service
Virtualization identifies any problems in your configuration, the details are
displayed.

Is Enabled Turns the agent on and off.

Name Enter a name for the configuration or accept the default name.

Host The name by which the agent is visible to client applications. It may be left
empty.

Timeout The period of time the agent waits before stopping attempts to
communicate with the real service.

HTTP Proxy
Settings

Port: the port for HTTP communication.

HTTPS Proxy
Settings

Port: the port for HTTPS communication.

CA Certificate File The Certification Authority certificate file used to generate host certificates.

Private Key The private key for the certificate file.

Password The password for the private key.

Select Show Password to display the password in this dialog box.

Use another proxy
server to
communicate with
real services

Enables you to configure proxy chaining. You can forward the HTTP(S)
communication between the HTTP(S) Proxy agent and the real service
through an additional proxy.

Click Settings to open the Proxy Settings dialog box. For details, see
"Proxy Settings Dialog Box" on page 94.
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JDBC Agent Settings

This dialog box enables you to configure the Service Virtualization JDBC Agent. The agent handles
communication between a client and a real or virtual service.

To access 1. From themainmenu, select Tools > Options.

2. Click Agents.

3. Under JDBC, select a configuration.

Important
information

l For additional important configuration information, see the task "How to
Configure the JDBC Agent" on page 49.

l You can definemultiple configurations for each agent.

Relevant tasks l "How to Configure Agents" on page 45

l "How to Forward HTTP Agent Communication Through an HTTP Proxy" on
page 65

See also "Service Virtualization Agents Overview" on page 45

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<left pane> Displays the server configured for your project.

Expand the server to display the available agents and configurations.

Add Enables you to define additional configurations of the agent.

Delete Deletes the selected configuration.
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UI Element Description

Duplicate Creates an additional configuration of the agent by copying the selected
configuration. You can thenmodify the configuration settings.

Note: By default, the configuration is created with a sequential unoccupied
port number.

Export Saves the selected agent configuration as a file. The file is saved in the .agce file
format, and can be imported to any Service Virtualization Server.

Export All Exports all agent configurations on the selected server. The file is saved in the
.agce file format, and can be imported to any Service Virtualization Server.

Import Enables you to select an exported agent configuration file stored on the file
system. The file is saved in the .agce file format, and can be imported to any
Service Virtualization Server.

If the configuration file you are importing contains multiple configurations, you can
select which configurations you want to import.

If you choose to import an agent configuration that is identical to a configuration
that already exists on your server, you can choose to overwrite your existing
configuration, or create a new, additional configuration.

Agent State The current status of the agent. Values includeRunning, Not Running.

Test
Configuration
link

Tests the configuration based on the settings you select. If Service Virtualization
identifies any problems in your configuration, the details are displayed.

Is Enabled Turns the selected configuration of the agent on and off.

Name Enter a name for the configuration or accept the default name.

Host/Port Themachine and port on which the JDBC agent is listening. Required for
communication with the JDBC driver installed on the application under test.

Actual
JDBC Driver
Class Name

The fully qualified class name of the actual driver used in the application under
test. Enter the name or select one from the list.

Available only when you select JDBC Version 3.0.

Deployment
Type

The environment in which your application under test is running.

l If your application under test is deployed on a J2EE application server, select
the appropriate version from the drop-down list.

l For a Java standard edition application, select J2SE.

User Guide
Chapter 2: Service Virtualization Agents

HP Service Virtualization (3.61) Page 73 of 352



UI Element Description

JDBC Version The JDBC version used by the application under test.

Available only when you select J2SE in theDeployment Type field.

Create
JDBC driver
for this
configuration

Creates the JDBC driver specific to your configuration. Specify a location for
saving the files.

If you change configuration settings, youmust create a new driver.

JMS Generic Agent Settings

This dialog box enables you to configure the Service Virtualization JMS Generic Agent. The agent
handles communication between a client and a real or virtual service.

To access 1. From themainmenu, select Tools > Options.

2. Click Agents.

3. Under JMS Generic, select a configuration.

Important
information

l For additional important configuration information, see the task "How to
Configure the JMS Generic Agent" on page 52.

l There are several instances of the JMS Generic agent pre-configured for
connecting to the JMS of common Java application servers.

l You can definemultiple configurations for each agent.

Relevant
tasks

l "How to Configure Agents" on page 45

l "How to Forward HTTP Agent Communication Through an HTTP Proxy" on
page 65

See also l "Service Virtualization Agents Overview" on page 45

l "Examples" on page 76

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<left pane> Displays the server configured for your project.

Expand the server to display the available agents and configurations.

Add Enables you to define additional configurations of the agent.

Delete Deletes the selected configuration.
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UI Element Description

Duplicate Creates an additional configuration of the agent by copying the selected
configuration. You can thenmodify the configuration settings.

Note: By default, the configuration is created with a sequential
unoccupied port number.

Export Saves the selected agent configuration as a file. The file is saved in the
.agce file format, and can be imported to any Service Virtualization Server.

Export All Exports all agent configurations on the selected server. The file is saved in
the .agce file format, and can be imported to any Service Virtualization
Server.

Import Enables you to select an exported agent configuration file stored on the file
system. The file is saved in the .agce file format, and can be imported to
any Service Virtualization Server.

If the configuration file you are importing contains multiple configurations,
you can select which configurations you want to import.

If you choose to import an agent configuration that is identical to a
configuration that already exists on your server, you can choose to
overwrite your existing configuration, or create a new, additional
configuration.

Agent State The current status of the agent. Values includeRunning, Not Running.

Test Configuration
link

Tests the configuration based on the settings you select. If Service
Virtualization identifies any problems in your configuration, the details are
displayed.

Is Enabled Turns the agent on and off.

Name Enter a name for the configuration or accept the default name.

JNDI URL The URLwhere the JNDI provider and the JNDI context with JMS
resources is located.

Context Factory The provider specific context factory.

Class Path The class path with all necessary JMS provider specific libraries for JMS
implementation.

Note: To ensuremaximum compatibility, use the same JMS/J2EE jar
libraries for the agent class path that are in use by the client application. If
not possible, follow your application server documentation for selection of
the correct J2EE/JMS libraries.
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UI Element Description

Username/Password Optional credentials for the JNDI provider/registry.

Select Show Password to display the password in this dialog box.

Trust Store File Enables mutual SSL authentication.

Enter the location of the JMS server's certificate, or certification authority
which issued the server's certificate. The certificate must be in a Java key
store (.jks) file.

Available for JMS on aWebLogic server only.

Key Store File Enables mutual SSL authentication.

Enter the location of the single certificate and corresponding private key to
use as the client certificate by Service Virtualization during communication.
The certificate must be in a Java key store (.jks) file.

Available for JMS on aWebLogic server only.

Examples

Agent configuration for WebLogic 10.3

l JNDI URL: t3://czvm58.devlab.ad:7001/

l Context Factory: weblogic.jndi.WLInitialContextFactory

l Class Path:

C:\Temp\WL103\wlthint3client.jar

Note: The above sample usedWebLogic Thin T3 Client. In case of issues, please use other
Weblogic Client libraries (e.g. “WebLogic Full Client” using “wlfullclient.jar”). See chapter 2 of
“Overview of Stand-alone Clients” in your “Oracle® FusionMiddleware Programming Stand-
alone Clients for OracleWebLogic Server 11g Release 1” documentation for more details.

Agent configuration for MQ-7.0.1.3 on WAS-6.1.0

l JNDI URL: corbaloc::czvm24.devlab.ad:2809/NameServiceServerRoot

l JNDI URL: corbaloc::czvm24.devlab.ad:2809/NameServiceServerRoot

l JNDI URL: corbaloc::czvm24.devlab.ad:2809/NameServiceServerRoot

C:\Temp\WAS6\com.ibm.mq.jar;

C:\Temp\WAS6\com.ibm.mq.jmqi.jar;
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C:\Temp\WAS6\com.ibm.mqjms.jar;

C:\Temp\WAS6\com.ibm.ws.admin.client_6.1.0.jar;

C:\Temp\WAS6\com.ibm.ws.runtime_6.1.0.jar;

C:\Temp\WAS6\connector.jar;

C:\Temp\WAS6\dhbcore.jar;

C:\Temp\WAS6\fscontext.jar;

C:\Temp\WAS6\ibmorb.jar;

C:\Temp\WAS6\jms.jar;

C:\Temp\WAS6\jndi.jar;

C:\Temp\WAS6\ldap.jar;

C:\Temp\WAS6\providerutil.jar

Agent configuration for JBoss 6.0

l JNDI URL: jnp://[machine-name]:1099/

l Context Factory: org.jnp.interfaces.NamingContextFactory

l Class Path:

C:\Temp\JBAS6\concurrent.jar;

C:\Temp\JBAS6\hornetq-core-client.jar;

C:\Temp\JBAS6\hornetq-jms-client.jar;

C:\Temp\JBAS6\jboss-client.jar;

C:\Temp\JBAS6\jboss-ejb3-core-client.jar;

C:\Temp\JBAS6\jboss-ejb3-ext-api.jar;

C:\Temp\JBAS6\jboss-jms-api_1.1_spec.jar;

C:\Temp\JBAS6\jboss-logging.jar;

C:\Temp\JBAS6\jnp-client.jar;

C:\Temp\JBAS6\netty.jar

MSMQ Agent Settings

This dialog box enables you to configure the Service VirtualizationMSMQAgent. The agent handles
communication between a client and a real or virtual service. You can virtualize binary and XML

User Guide
Chapter 2: Service Virtualization Agents

HP Service Virtualization (3.61) Page 77 of 352



messages over MSMQ.

To access 1. From themainmenu, select Tools > Options.

2. Click Agents.

3. UnderMS MQ, select a configuration.

Important
information

l For additional important configuration information, see the task "How to
Configure theMSMQAgent" on page 53.

l You can definemultiple configurations for each agent.

Relevant tasks "How to Configure Agents" on page 45

See also "Service Virtualization Agents Overview" on page 45

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<left pane> Displays the server configured for your project.

Expand the server to display the available agents and configurations.

Add Enables you to define additional configurations of the agent.

Delete Deletes the selected configuration.

Duplicate Creates an additional configuration of the agent by copying the selected
configuration. You can thenmodify the configuration settings.

Note: By default, the configuration is created with a sequential unoccupied
port number.

Export Saves the selected agent configuration as a file. The file is saved in the .agce file
format, and can be imported to any Service Virtualization Server.

Export All Exports all agent configurations on the selected server. The file is saved in the
.agce file format, and can be imported to any Service Virtualization Server.

Import Enables you to select an exported agent configuration file stored on the file system.
The file is saved in the .agce file format, and can be imported to any Service
Virtualization Server.

If the configuration file you are importing contains multiple configurations, you can
select which configurations you want to import.

If you choose to import an agent configuration that is identical to a configuration
that already exists on your server, you can choose to overwrite your existing
configuration, or create a new, additional configuration.
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UI Element Description

Agent State The current status of the agent. Values includeRunning, Not Running.

Test
Configuration
link

Tests the configuration based on the settings you select. If Service Virtualization
identifies any problems in your configuration, the details are displayed.

Is Enabled Turns the agent on and off.

Name Enter a name for the configuration or accept the default name.

Host TheMSMQ server machine. Use a period '.' to indicate the local machine.

Oracle AQ Agent Settings

This dialog box enables you to configure the Service Virtualization Oracle AQAgent. TheOracle agent
handles communication between applications that are using Oracle AdvancedQueuing.

To access 1. From themainmenu, select Tools > Options.

2. Click Agents.

3. Select OracleAQ and click Add to define a new configuration. Alternatively,
select an existing configuration.

Important
information

l For additional important configuration information, see the task "How to
Configure the Oracle AQAgent" on page 54.

l To connect to the Oracle database, you can specify either a connection string
or specific database connection properties.

l When specifying database connection properties, you can enter either the
database name or SID.

Relevant tasks "How to Configure Agents" on page 45
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See also "Service Virtualization Agents Overview" on page 45

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<left pane> Displays the server configured for your project.

Expand the server to display the available agents and configurations.

Add Enables you to define additional configurations of the agent.

Delete Deletes the selected configuration.

Duplicate Creates an additional configuration of the agent by copying the selected
configuration. You can thenmodify the configuration settings.

Note: By default, the configuration is created with a sequential
unoccupied port number.

Export Saves the selected agent configuration as a file. The file is saved in the
.agce file format, and can be imported to any Service Virtualization Server.

Export All Exports all agent configurations on the selected server. The file is saved in
the .agce file format, and can be imported to any Service Virtualization
Server.

Import Enables you to select an exported agent configuration file stored on the file
system. The file is saved in the .agce file format, and can be imported to
any Service Virtualization Server.

If the configuration file you are importing contains multiple configurations,
you can select which configurations you want to import.

If you choose to import an agent configuration that is identical to a
configuration that already exists on your server, you can choose to
overwrite your existing configuration, or create a new, additional
configuration.

Agent State The current status of the agent. Values includeRunning, Not Running.

Test Configuration
link

Tests the configuration based on the settings you select. If Service
Virtualization identifies any problems in your configuration, the details are
displayed.

Is Enabled Turns the selected configuration of the agent on and off.

Name Enter a name for the configuration or accept the default name.

Host/Port The host machine and port for the Oracle database.

Database Name The name of the Oracle database.
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UI Element Description

SID TheOracle system ID.

Connection String The connection string for connecting to the Oracle database.

Username/Password Enter credentials for a user with permissions to access the Oracle
database.

Although the connection stringmay contain a password, it is recommended
to specify the password in this password box.

SAP Agent Settings

This dialog box enables you to configure the Service Virtualization SAP Agent. The agent handles
SAP RFC or SAP IDOC communication between a SAP®  or SAP NetWeaver® Process Integration 
(PI) system, and a real or virtual SAP service.

To access 1. From themainmenu, select Tools > Options.

2. Click Agents.

3. UnderSAP, select a configuration.

Important
information

l For additional important configuration information, see the task "How to
Configure the SAP Agent" on page 56.

l You can definemultiple configurations for each agent.

Relevant tasks l "How to Configure Agents" on page 45

l "How to Forward HTTP Agent Communication Through an HTTP Proxy" on
page 65

l "How to Virtualize SAP IDoc Communication" on page 112

See also "Service Virtualization Agents Overview" on page 45

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<left pane> Displays the server configured for your project.

Expand the server to display the available agents and configurations.

Add Enables you to define additional configurations of the agent.

Delete Deletes the selected configuration.
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UI Element Description

Duplicate Creates an additional configuration of the agent by copying the selected
configuration. You can thenmodify the configuration settings.

Note: By default, the configuration is created with a sequential unoccupied
port number.

Export Saves the selected agent configuration as a file. The file is saved in the .agce file
format, and can be imported to any Service Virtualization Server.

Export All Exports all agent configurations on the selected server. The file is saved in the
.agce file format, and can be imported to any Service Virtualization Server.

Import Enables you to select an exported agent configuration file stored on the file system.
The file is saved in the .agce file format, and can be imported to any Service
Virtualization Server.

If the configuration file you are importing contains multiple configurations, you can
select which configurations you want to import.

If you choose to import an agent configuration that is identical to a configuration
that already exists on your server, you can choose to overwrite your existing
configuration, or create a new, additional configuration.

Agent State The current status of the agent. Values includeRunning, Not Running.

Test
Configuration
link

Tests the configuration based on the settings you select. If Service Virtualization
identifies any problems in your configuration, the details are displayed.

Is Enabled Turns the agent on and off. To enable the agent, the prerequisites must first bemet.

Name Enter a name for the configuration or accept the default name.

Gateway Host The IP address or host name of the SAP gateway.

Alternatively, youmay enter the SAP Router String for communication through the
SAP firewall.

Gateway
Service Name

The SAP gateway service name.

WebMethods SAP Agent Settings

This dialog box enables you to configure the Service VirtualizationWebMethods SAP Agent. The agent
enables you to virtualize IDOC document exchange between flow services hosted inWebMethods
Integration Server and a SAP system using JVM instrumentation.
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To access 1. From themainmenu, select Tools > Options.

2. Click Agents.

3. SelectWebMethods SAP and click Add to define a new configuration.
Alternatively, select an existing configuration.

Relevant
tasks

"How to Configure theWebMethods SAP Agent" on page 57

See also "Service Virtualization Agents Overview" on page 45

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<left pane> Displays the server configured for your project.

Expand the server to display the available agents and configurations.

Add Enables you to define additional configurations of the agent.

Delete Deletes the selected configuration.

Duplicate Creates an additional configuration of the agent by copying the selected
configuration. You can thenmodify the configuration settings.

Note: By default, the configuration is created with a sequential
unoccupied port number.

Export Saves the selected agent configuration as a file. The file is saved in the
.agce file format, and can be imported to any Service Virtualization Server.

Export All Exports all agent configurations on the selected server. The file is saved in
the .agce file format, and can be imported to any Service Virtualization
Server.

Import Enables you to select an exported agent configuration file stored on the file
system. The file is saved in the .agce file format, and can be imported to
any Service Virtualization Server.

If the configuration file you are importing contains multiple configurations,
you can select which configurations you want to import.

If you choose to import an agent configuration that is identical to a
configuration that already exists on your server, you can choose to
overwrite your existing configuration, or create a new, additional
configuration.

Agent State The current status of the agent. Values includeRunning, Not Running.
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UI Element Description

Test Configuration
link

Tests the configuration based on the settings you select. If Service
Virtualization identifies any problems in your configuration, the details are
displayed.

Is Enabled Turns the agent on and off.

Name Enter a name for the configuration or accept the default name.

Port The port on your local machine on which the agent is listening.

Host (optional) The hostname of the Service Virtualizationmachine on which the agent is
installed.

WebMethods IS
URL

The address of theWebMethods Integration Server.

Gateway Host The IP address or host name of the SAP gateway. Alternatively, youmay
enter the SAP Router String for communication through the SAP firewall.

Gateway Service
Name

The SAP gateway service name.

Client ID The SAP client ID, required to connect to the SAP system.

Unicode Indicates that the communication with the SAP system is encoded in
Unicode.

Username/Password Credentials used to connect to the SAP system.

Select Show Password to display the password in this dialog box.

IBM IMS TM Agent Settings

This dialog box enables you to configure the Service Virtualization IBM IMS TM Agent. The agent
handles communication between a client and a real or virtual service.
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To access 1. From themainmenu, select Tools > Options.

2. Click Agents.

3. Select IBM IMS TM and click Add to define a new configuration.
Alternatively, select an existing configuration.

Important
information

l For additional important configuration information, see the task "How to
Configure the IBM IMS TM Agent" on page 60.

l You can definemultiple configurations for each agent.

Relevant tasks l "How to Configure Agents" on page 45

l "How to Forward HTTP Agent Communication Through an HTTP Proxy" on
page 65

See also "Service Virtualization Agents Overview" on page 45

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<left pane> Displays the server configured for your project.

Expand the server to display the available agents and configurations.

Add Enables you to define additional configurations of the agent.

Delete Deletes the selected configuration.

Duplicate Creates an additional configuration of the agent by copying the selected
configuration. You can thenmodify the configuration settings.

Note: By default, the configuration is created with a sequential unoccupied
port number.

Export Saves the selected agent configuration as a file. The file is saved in the .agce file
format, and can be imported to any Service Virtualization Server.

Export All Exports all agent configurations on the selected server. The file is saved in the
.agce file format, and can be imported to any Service Virtualization Server.
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UI Element Description

Import Enables you to select an exported agent configuration file stored on the file system.
The file is saved in the .agce file format, and can be imported to any Service
Virtualization Server.

If the configuration file you are importing contains multiple configurations, you can
select which configurations you want to import.

If you choose to import an agent configuration that is identical to a configuration
that already exists on your server, you can choose to overwrite your existing
configuration, or create a new, additional configuration.

Agent State The current status of the agent. Values includeRunning, Not Running.

Test
Configuration
link

Tests the configuration based on the settings you select. If Service Virtualization
identifies any problems in your configuration, the details are displayed.

Is Enabled Turns the agent on and off.

Name Enter a name for the configuration or accept the default name.

Host The hostname of the interface on which the agent is listening.

Port The port on the local machine on which the agent is listening.

Remote Host The hostname or IP address of the IMS TM server.

Remote Port The remote port of the IMS TM server.

Code Page The character set as defined on the IMS TM server. Used to interpret both requests
and responses.

Use SSL Enables SSL over TCP/IP. If enabled, youmust provide certificate file and
password details.

Certificate
File

The server side P12/PFX certificate file used by the IBM IMS TM Agent during SSL
authentication.

Certificate
Password

The password used to access the certificate file specified above.

WebSphere MQ Agent Settings

This dialog box enables you to configure the Service VirtualizationWebSphereMQ Agent. The agent
handles communication between a client and a real or virtual service.
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To access 1. From themainmenu, select Tools > Options.

2. Click Agents.

3. UnderWebSphere MQ, select a configuration.

Important
information

l For additional important configuration information, see the task "How to Configure
theWebSphereMQAgent" on page 61.

l TheWebSphereMQAgent is not able to automatically reconnect when a TCP
connection to theWebSphereMQServer is lost. Each service using the agent
must be restarted. Alternately, restart the whole application.

l You can definemultiple configurations for each agent.

Relevant
tasks

l "How to Configure Agents" on page 45

l "How to Forward HTTP Agent Communication Through an HTTP Proxy" on page
65

See also "Service Virtualization Agents Overview" on page 45

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<left pane> Displays the server configured for your project.

Expand the server to display the available agents and configurations.

Add Enables you to define additional configurations of the agent.

Delete Deletes the selected configuration.
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UI Element Description

Duplicate Creates an additional configuration of the agent by copying the selected
configuration. You can thenmodify the configuration settings.

Note: By default, the configuration is created with a sequential
unoccupied port number.

Export Saves the selected agent configuration as a file. The file is saved in the
.agce file format, and can be imported to any Service Virtualization Server.

Export All Exports all agent configurations on the selected server. The file is saved in
the .agce file format, and can be imported to any Service Virtualization
Server.

Import Enables you to select an exported agent configuration file stored on the file
system. The file is saved in the .agce file format, and can be imported to
any Service Virtualization Server.

If the configuration file you are importing contains multiple configurations,
you can select which configurations you want to import.

If you choose to import an agent configuration that is identical to a
configuration that already exists on your server, you can choose to
overwrite your existing configuration, or create a new, additional
configuration.

Agent State The current status of the agent. Values includeRunning, Not Running.

Test Configuration
link

Tests the configuration based on the settings you select. If Service
Virtualization identifies any problems in your configuration, the details are
displayed.

Is Enabled Turns the agent on and off. To enable the agent, the prerequisites must first
bemet.

Name Enter a name for the configuration or accept the default name.

Queue Manager
Name

The name of the queuemanager for the agent to connect to.

Note: TheWebSphereMQAgent instance can only use queues from a
single Queuemanager.

Channel Name The name of the TCP channel for the agent to use to connect to the Queue
Manager.

Note: TheWebSphereMQAgent instance can only use a single TCP
channel to connect to the QueueManager.

Host The name of the server hosting the queuemanager.

Port The TCP port where the channel listens for client connections.
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UI Element Description

CCSID The character set used by the host.

Note:

l CCSID configuration in theWebSphereMQAgent instance requires
that you restart the application.

l CCSID configuration is global for the whole application. There cannot be
two agents with different CCSIDs.

Username/Password The username and password for connecting to the queuemanager.

Note:When you create a new virtual service, you can search
WebSphereMQ queues and select a destination, provided the
virtual agent has sufficient permissions.

To browseMQ destinations, the specified user must be able to
perform the following in theWebSphereMQ client:

l put and inq operations on the
SYSTEM.ADMIN.COMMAND.QUEUE

l get, inq, and dsp operations on the
SYSTEM.DEFAULT.MODEL.QUEUE

l dsp operations on queues to which the user has access
permissions

To create or delete a virtual destination, the specified user requires
additional permissions, such as administrator permissions.

For details, see "Browse Destinations Dialog Box" on page 137.

SSL

CipherSpec The algorithm used for secure SSL communication.

Enter a value or select a value from the list. The CipherSpec valuemust be
the same as the value specified in theWebSphereMQ channel
configuration.
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UI Element Description

Key Repository The path of theWebSphereMQSSL key repository, which contains the
WebSphereMQQueueManager certificate. If you are usingmutual
authentication, it also contains the certificate and private key of the Service
VirtualizationMQ agent.

Enter the path to theWebSphereMQ key database file (.kdb), but without
the file extension. This file is similar to the file specified in the key repository
parameter inWebSphereMQQueueManager configuration.

Thresholds

Max. Threads Themaximum number of threads allowed for handling requests received by
the agent. More threads enablemore requests to be processed
concurrently, but may affect performance.

Max. Connections Themaximum number of cached connections to QueueManager allowed
for sendingmessages. More connections enablemoremessages to be sent
concurrently.

Message ID Age
[ms]

The length of time, in milliseconds, that cached sent message IDs may be
stored inmemory. It is recommended to set this property to at least the
length of time as the longest request/response pair duration.

Message ID Count Themaximum number of cached sent message IDs that may be stored in
memory.

Advanced Settings

Message Context
Mode

Options for accessing theMQ queue.

l None.

l Set Identity. Corresponds to theMQC.MQOO_SET_IDENTITY_
CONTEXT property.

l Set All. Corresponds to theMQC.MQOO_SET_ALL_CONTEXT
property.

Strip
XML Declarations

Removes XML declarations (<?xml ...>) from text messages before
processing in Service Virtualization. Text messages are in Unicode.

Use UTF Methods Service Virtualization considers MQ text messages as created by the
WriteUTF() method instead of theWriteString() method.

When using an XML service, themessage can be either transferred as a
string (with a specified character set) or as binary data (UTF). By default,
the agent reads and writes messages as a string. Select this option to use
binary messages with UTF content instead.
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UI Element Description

Response Queue
Access Mode

Defines how Service Virtualization opens the response queue.

l Default. Legacy functionality according to Service Virtualization
versions earlier than 3.61. The Service Virtualization agent can access a
shared queue, and selects messages in the queue according to FIFO
methodology.

Caution: The response queue consumes messages regardless of
the correlationmechanism (defined in theRequest-Response
Matching Mode field below). This can be problematic if the queue
is shared. In this case, it is recommended to use theSharedmode.

l Exclusive. Opens the queue in theMQExclusive Queue Access mode.
Access is limited to Service Virtualization only, enabling the fastest
sequential picking from the queue.

l Shared. Opens the queue as anMQ shared queue and selects specific
responses according to the IDs used for request-responsematching
mode (request message ID, request correlation ID, or both). Enables
you to run several services with one response queue, or run a virtual
service with systems where the response queue is shared with other
applications.

Note: This mode is slower than the other modes, as it is selecting
specific responses from the queue and not simply the first
response.

Listening Timeout
(ms)

The length of time Service Virtualization listens for a specific request. When
the agent is usingSharedResponseQueue Access Mode, the timeout is
reset 3 times before stopping the listening process. When a response is
successfully retrieved, the failed attempts counter is reset to zero.

Maximum
Responses per
Request

Defines the number of responsemessages that are expected for each
request message. Relevant when the Service Virtualization agent is
configured to useSharedResponseQueue Access Mode only. When the
maximum responses per request are reached, Service Virtualization stops
the listening process.
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UI Element Description

Request-Response
Matching Mode

Defines themethod used tomatch a response to the correct request.

l Request Message ID -> Response Correlation ID. TheMessage ID
of the request is copied to the Correlation ID of the response. This is the
default behavior of WebSphereMQ.

l Request Correlation ID -> Response Correlation ID. The
Correlation ID of the request is copied to the Correlation ID of the
response.

TIBCO EMS Agent Settings

This dialog box enables you to configure the Service Virtualization TIBCO EMS Agent. The agent
handles communication between a client and a real or virtual service.

To access 1. From themainmenu, select Tools > Options.

2. Click Agents.

3. Under TIBCO EMS, select a configuration.

Important
information

l For additional important configuration information, see the task "How to
Configure the TIBCO EMS Non Intrusive Agent" on page 63.

l You can definemultiple configurations for each agent.

Relevant
tasks

l "How to Configure Agents" on page 45

l "How to Forward HTTP Agent Communication Through an HTTP Proxy" on
page 65

See also "Service Virtualization Agents Overview" on page 45

User interface elements are described below (unlabeled elements are shown in angle brackets):
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UI Element Description

<left pane> Displays the server configured for your project.

Expand the server to display the available agents and configurations.

Add Enables you to define additional configurations of the agent.

Delete Deletes the selected configuration.

Duplicate Creates an additional configuration of the agent by copying the selected
configuration. You can thenmodify the configuration settings.

Note: By default, the configuration is created with a sequential
unoccupied port number.

Export Saves the selected agent configuration as a file. The file is saved in the
.agce file format, and can be imported to any Service Virtualization Server.

Export All Exports all agent configurations on the selected server. The file is saved in
the .agce file format, and can be imported to any Service Virtualization
Server.

Import Enables you to select an exported agent configuration file stored on the file
system. The file is saved in the .agce file format, and can be imported to
any Service Virtualization Server.

If the configuration file you are importing contains multiple configurations,
you can select which configurations you want to import.

If you choose to import an agent configuration that is identical to a
configuration that already exists on your server, you can choose to
overwrite your existing configuration, or create a new, additional
configuration.

Agent State The current status of the agent. Values include: Running, Not Running.

Test Configuration
link

Tests the configuration based on the settings you select. If Service
Virtualization identifies any problems in your configuration, the details are
displayed.

Is Enabled Turns the agent on and off. To enable the agent, the prerequisites must first
bemet.

Name Enter a name for the configuration or accept the default name.

Host The host where EMS is running.

Server Port The server where EMS is running.

Username/Password The username and password for an EMS account with appropriate
privileges to change permissions on destinations and on the JMS server
(admin account required).
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Proxy Settings Dialog Box
This dialog box enables you to configure proxy chaining. You can forward HTTP/HTTPS
communication between the HTTP Gateway/HTTPS Gateway/HTTP(S) Proxy agents and a real
service through an additional proxy.

To access 1. From themainmenu, select Tools > Options. On the Agents Page, select one
of the following:

n HTTP Gateway

n HTTP(S) Proxy

n HTTPS Gateway

2. Select theUse another proxy server to communicate with real services
option, and click Settings.

Relevant
tasks

"How to Forward HTTP Agent Communication Through an HTTP Proxy" on page 65

User interface elements are described below:

UI Element Description

Proxy Host Address or hostname of proxy machine.

Port Port number on host machine.
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UI Element Description

Credentials Authentication credentials. Authentication is automatically detected,
and supports BASIC, DIGEST, NTLM, and Negotiate authentication
types.

Includes the following options:

l None. No username and password are used for proxy
authentication.

l Current User. The username and password of the current
Windows user are provided by Windows and integrated
authentication is used.

Note: Only NTLM andNegotiate authentication are supported.

l Custom Credentials. Enter a username and password to use for
authentication.

Do not use proxy server
for address beginning
with

The list of addresses for which the proxy will not be used.

Separate addresses with semicolons or place on new lines.

Bypass proxy server for
local addresses

The proxy is not used when accessing local addresses (IPv4 and IPv6
loopback and current machine hostname).
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Chapter 3: Virtual Services
This chapter includes:

Virtual Service Overview 97

How to Create a Virtual Service 104

How to Configure Virtual Services 105

How toManage Virtualization Projects 108

How to Edit a Service Description 109

How to Virtualize SAP IDoc Communication 112

How to Virtualize a Fixed-Length over TCP Protocol 113

Message Logging 114

Virtual Services User Interface 117
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Virtual Service Overview
Service Virtualization places a virtual service between the client application (application under test) and
the real service you want to simulate.

To simulate the behavior of the real service, you create a virtual service and configure it to meet your
needs. After you design your virtual service, you reconfigure your client application to use this virtual
service endpoint, in place of the real service.

You create virtual services by importing an existing service description document, or by creating a new
service based on one of the Service Virtualization supported protocols.

You can also create service templates. After creating a service, you can save it as a template in order
to reuse the service in multiple testing environments, or reuse the service's configuration, custom
functions, data, and views.

For task details, see "How to Create a Virtual Service" on page 104.

You configure your virtual service by designing data and performancemodels to simulate real service
behavior. You can record real service activity, and use it to create thesemodels, or manually
customize themodels. For task details, see "How to Configure Virtual Services" on page 105.

The basis of organizing your virtual service is the virtualization project. The virtualization project
includes your virtual services, the simulationmodels you use to simulate real service behavior, and
other configuration entities you can customize tomeet your needs. For details, see "Virtualization
Projects" on the next page.

After you create virtual services, youmanage them by manipulating virtual servicemodes. Themodes
include Learning, Standby, and Simulating. For details, see "Simulation" on page 167.

This section also includes:

Virtualization Projects 98

Virtual Service Types 99

Service Descriptions 102
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Virtualization Projects
The basis of organization within Service Virtualization is the virtualization project.

The virtualization project includes your virtual services, the simulationmodels you use to simulate real
service behavior, and other configuration entities you can customize tomeet your needs.

You view your project structure in the Virtualization Explorer. For details, see "Virtualization Explorer"
on page 142.

When you create a project, it is created within a solution. A solution is a container for one or more
projects that you want to maintain as a group. You can view your project and solution in theProjects
pane.

Update your projects

Projects created in earlier versions of HP Service Virtualization are fully compatible with Service
Virtualization 3.61. When you open a project created in a previous version of Service Virtualization, a
pop up window displays, informing you that the project contains resources in an older format. Click Yes
to confirm that you want to update your existing project.

Group related services

Youmay want to keep a group of related virtual services together in a single project. However, if there
are toomany services in a single project, they may be difficult to manage. The recommended limit is
approximately 20 virtual services per project. In this case, it is recommended to create an additional
project.

Add projects to a solution

You can add new or existing projects to an existing solution. One advantage to havingmultiple projects
within one solution is that you canmanage all the services within the Runtime view. The Runtime view
provides an overview of the communication through the virtual services during Learning or Simulation
sessions.

Export projects

You can save your project as an archive file in the file system.

Tip: For enhanced security, you can encrypt the project file. For more details on encryption, see
"Password Encryption" on page 20.

For task details, see "How toManage Virtualization Projects" on page 108.
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Virtual Service Types
When you create a new virtual service, you specify a transport protocol and amessage protocol that
the service will use.

l For the full list of supported protocols and versions, refer to the support matrix on the HP Software
Support site at: http://h20230.www2.hp.com/sc/support_matrices.jsp, or contact support.

l For details on creating virtual services, see "How to Create a Virtual Service" on page 104.

This section provides additional information required for the following service types:

l "XML Services" below

l "Binary Services" below

l "SOAP Services" below

l "REST Services" on the next page

l "IBM IMS TM Virtual Services" on the next page

l "COBOL over IBM CICS TS HTTP Services" on page 101

l "SQL Services" on page 101

l "SAP IDoc and SAP RFC Services" on page 101

l "Virtual Service Types" above

XML Services

In addition to creating an XMl virtual service to simulate a real XMl service, you can also create an XMl
virtual service to simulate a SOAP service. You can import an .xsd file when creating the virtual
service.

Binary Services

If the service is using an unknown transport protocol, creating a binary service is the best solution. If
Service Virtualization cannot understand themessage format, it can record it in binary format, although
it is not able to fully recognize the structure.

SOAP Services

You can create SOAP services in the following ways:

l Import WSDL documents directly into Service Virtualization to describe SOAP services. To later
update a SOAP service description, you can load a new service description document.
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l Import a schema from an .xsd file.

l Create a new service without importing a service description. You can then place the virtual service
in Learningmode to record real service behavior.

REST Services

REST services do not use imported service description documents in Service Virtualization. After you
create a REST service, you can record real service behavior to learn the structure of the service.

IBM IMS TM Virtual Services

Depending on the client transport andmessage level protocol, there aremultiple options for virtualizing
IBM® InformationManagement System TransactionManager (IMS™TM) services.

The following is an overview of protocols with full message structure parsing. Each requires a COBOL
copybook.

1. COBOL payload over IBM IMS TMResource Adapter

a. The client is J2EE application using IBM IMS TMResource Adapter to access IMS TM.

b. The payload are COBOLmessages based on knownCOBOL copybooks.

c. The virtual service is created based on one or more of the following: TPipe name, Client ID,
Datastore Name, Transaction Code.

2. COBOL payload over IBM IMS Connect API protocol

a. The client is J2SE application using IBM IMS Connect Java API to access IMS TM.

b. The payload are COBOLmessages based on knownCOBOL copybooks.

c. The virtual service is created based on one or more of the following: LTerm name, Client ID,
Datastore Name, Transaction Code.

If full message structure parsing is not required, or if the COBOL copybook is not available, the
following protocols provide the best alternatives. Note that the payload is a binary object and not
structured.

1. Binary messages over IMS

a. Any client type using IMS TM over a TCP/IP network.

b. Any payload type.

c. The virtual service is created based on one or more of the following: TPipe name, Client ID,
Datastore Name, Transaction Code.

2. Binary messages overWebSphereMQ
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a. The client is using IMS-MQ bridge to access IMS TM.

b. Any payload type.

COBOL over IBM CICS TS HTTP Services

If the client communicates with the service using COBOLmessages over HTTP transport, such as
IBM CICS Transaction Server web-aware applications for example, you can use the following
protocols for service simulation. Both HTTP Proxy and HTTP Gateway agent types are supported.

1. COBOLmessages over IBM CICS TS HTTP

a. The client is any application using COBOLmessages based on knownCOBOL copybook(s).

b. The virtual service is created based on HTTP URI path.

c. Themessage is fully structured.

2. Binary messages over HTTP

a. The client is any application using any messages (including COBOL).

b. The virtual service is created based on HTTP URI path.

c. Themessage is not structured. Only HTTP headers are shown.

COBOL services over IBM CICS TS HTTP transport usually use two encodings – one encoding for the
HTTP protocol and the other for the COBOLmessages. Service Virtualization expects the HTTP
transport to be encoded using US-ASCII. However, the exact COBOLmessage encodingmay be
selected during virtual service creation.

SQL Services

You can create virtual SQL services for working with JDBC. A virtual SQL service can simulate both
J2SE and J2EE client applications.

When you configure the Service Virtualization JDBC agent to work with JDBC services, you enter
parameters for the specific target environment in which you are working. Service Virtualization then
configures a unique agent for your system.

SAP IDoc and SAP RFC Services

You can import RFC functions or IDoc operations from a SAP server, or learn the functions and
operations by recording real service behavior.

Service Virtualization supports the following:

l SAP RFC or SAP IDOC communication between two SAP® servers or between a SAP server and
a SAP NetWeaver® Process Integration (PI) system.
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l TCP/IP SAP destination only.

l Only basic authentication for connection to a SAP system.

l Supported RFC communication includes synchronous, or any of the three asynchronous types
(Asynchronous, Transactional, or Queued). In the case of asynchronous types, requests are
collected and then processed in a batch.

Service Descriptions
In order to virtualize a service, Service Virtualization needs to know what the service does and what
endpoints it uses.

You can provide this information in several ways:

l Learning.When you place a virtual service in Learningmode, Service Virtualization learns about
the real service structure, and automatically updates the virtual service. If there are additional
changes that you want to make, you can then edit the service descriptionmanually. Service
description learning is available for XML, REST, SOAP, SQL, and SAP services.

l Import service description documents. Service Virtualization provides an import wizard that
analyzes the content of the document, and enables you to associate it with a particular virtualized
service.

l Configure a service description. You can the add operations and URI spaces, import and edit
XML schemas, and configure other components of your services. For example, REST services do
not use imported service description documents. After you create a REST service, you can record
real service behavior to learn the structure of the service. You can then edit the service description
in Service Virtualization.

Importing Service Description Documents

You can import the following service description document types into Service Virtualization:

l WSDL

Web-Service Definition Language documents are themost commonway to describe SOAP
services. They often contain references to otherWSDLs and XSDs that must be available in the
referenced locations in order to import them and correctly describe the services they define.

l XSD

XMLSchema documents may also describe XML services. They often contain references to
additional XML SchemaDefinitions (XSDs) that must be available in the referenced locations in
order to import them and correctly describe the services they define.

l COBOL Copybook
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COBOL copybook documents describe input and output message structure for legacy mainframe
applications.

For task details, see "How to Create a Virtual Service" on the next page.

Configuring Service Descriptions

You can edit a service description within Service Virtualization. You can configure the following
components:

Note: To update a SOAP service description, you can also load a new service description
document. You can edit HTTP metadata, and set session identifiers within Service Virtualization,
which are not part of the service's WSDL document.

l Operations and URI spaces. For an XML service, you can add new operations. For
REST services, you can createmore URI spaces in which to place the data. This enables you to
split your data into smaller groups according to the URI path of the resources.

l Metadata.Metadata are parameters that contain some protocol-specific information such as time
stamps, correlation information, or status codes. They are part of the protocol message, but
external to themessage body, such as URL parameters, or HTTP headers. You can edit this
metadata in Service Virtualization.

Some types of metadata, such as HTTP Headers, are not required for tested applications; they may
be important for the protocol, but the application does not require them and they are not learned for
purposes of virtualization. By default they are disabled in the request but it is possible to enable
them and edit the data for use in a simulation. Metadata such as URI Parameters are generally used
by tested applications and are enabled by default.

l XML schemas. For XML, REST, or SOAP services. You can add, edit, or remove XML schemas.

l Session identifiers. To perform stateful simulation, you need to be able to identify requests that
originate from the same source. For example, youmay want to identify all requests coming from a
single browser session. Service Virtualization uses this information to create different tracks based
on learned data, and uses the tracks to create different sessions during simulation. Service
Virtualization assigns default session identifiers based on the service's protocol, which you can
thenmodify.

l Data formats. You can add or remove request and response data formats. You add a new data
format to your service description by copying from an existing URI space (in a REST service), or by
creating a new format.

l Data masking. To hide sensitive data, you can scramble specific data elements. For example,
theremay be sensitive data that you are not permitted to store to disk. You can configure the
elements for datamasking, so that data recorded during Learning is masked and cannot be viewed
in the datamodel.

For task details, see "How to Edit a Service Description" on page 109.
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How to Create a Virtual Service
This task describes how to create a virtual service. For additional details on specific service types, see
"Virtual Service Types" on page 99.

l This task is part of a higher-level task. For details, see "How to Use Service Virtualization" on
page 23.

l To learnmore about virtual services, see "Virtual Service Overview" on page 97.

1. Optional: Create a new project

When you select a task from theGet Started page, these tasks first create a new virtualization
project and then a new virtual service. For user interface details, see "Start Page" on page 28.

For details on how tomanually create a new virtualization project, see "How toManage
Virtualization Projects" on page 108.

2. Open an existing project

Select one of the following:

n On the Start Page, underRecent Projects, select a project.

n From themainmenu, select File > Open Project/Solution.

Note: Projects created in earlier versions of HP Service Virtualization are fully compatible
with Service Virtualization 3.61.

When opening a project created in a previous version of Service Virtualization, a pop up
window displays, informing you that the project contains resources in an older format. Click
Yes to confirm that you want to update your existing project.

For more information on virtualization projects, see "Virtualization Projects" on page 98.

3. Create a virtual service

Do one of the following:

Create a virtual service

In an existing project, select one of the following to launch the new virtual service wizard:

User Guide
Chapter 3: Virtual Services

HP Service Virtualization (3.61) Page 104 of 352



n From themainmenu, select File > New > Virtual Service.

n In the Virtualization Explorer, right-click a virtualization entity and select Add > Virtual
Service.

For user interface details, see "Create New Virtual ServiceWizard" on page 119.

Create multiple virtual services in one step

Note: Available for SOAP over HTTP(S) services only.

You can createmultiple virtual services by specifying a list of .wsdl files, or by providing a .csv file
containing the paths to .wsdl files.

a. In an open project, select one of the following:

o From themainmenu, select File > New > Multiple Virtual Services.

o In the Virtualization Explorer, right-click a virtualization entity and select Add > Multiple
Virtual Services.

b. In the Import Real Service Description dialog box, enter a list of paths to your .wsdl files,
separated by semicolons.

For example,
C:\Services\ShoppingCart.wsdl;C:\Services\MemberAccounts.wsdl;C:\Services\ClaimProc
essing.wsdl

Alternatively, enter the path to a CSV file containing the paths to the .wsdl files.

c. Follow the on-screen instructions.

For user interface details, see "CreateMultiple Virtual Services Wizard" on page 140.

4. Optional: Create a template service

a. To save a service as a template: In the Virtualization Explorer, right-click the service and
select Save as Template.

b. To create a new service from a template: From themainmenu, select File > New > Virtual
Service from Template.

How to Configure Virtual Services
This task describes how to configure your virtual service tomeet your needs.
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l This task is part of a higher-level task. For details, see "How to Use Service Virtualization" on
page 23.

l To learnmore about configuring virtual services, see "Virtual Service Overview" on page 97.

This task includes the following steps:

l "Select simulationmodels" below

l "Configure virtual service endpoints" below

l "Configure Service Virtualization agents" below

l "Enablemessage logging" below

l "Disable schema learning" on the next page

l "Edit the service description" on the next page

l "Set security options" on the next page

l "Change servers" on the next page

Select simulation models

In the Virtual Service Editor, select existing data and performancemodels to use with your virtual
service, or add new models.

For task details on simulationmodels, see "How toManage SimulationModels" on page 198.

Configure virtual service endpoints

You canmodify real and virtual service endpoint information that you provided when creating the virtual
service, or in some cases, configure additional options.

In the Virtual Service Editor, under Service Configuration, click Edit to open the Edit Endpoints dialog
box.

In the Edit Endpoints dialog box, you can click Show Endpoint Topology to display a diagram of your
service endpoint configuration.

Configure Service Virtualization agents

You canmodify agent information that you selected when creating the virtual service. In the Virtual
Service Editor, under Service Configuration, click Configure. The Agents page opens.

For user interface details, see "Agents Page" on page 66.

Enable message logging

To enable logging, in the Virtual Service Editor, under Service Configuration, selectMessage
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Logging.

For more details, see "Message Logging" on page 114.

Disable schema learning

You can block changes to the service description during learning or message import.

This is useful, for example, when the service was created from an existingWSDL or schema, and you
want to ensure that messages with a different structure do not modify it.

For more details, see "Virtual Service Editor" on page 144.

Edit the service description

You canmodify the service description associated with your virtual service. Depending on the service
type, you can do the following:

l add/remove operations/URI spaces

l edit request/responsemetadata

l add/remove/edit XML schemas

l add/remove data formats

l define session identifiers

For task details, see "How to Edit a Service Description" on page 109.

For user interface details, see "Service Description Editor" on page 152.

Set security options

In the Virtual Service Editor, under Security Settings, define authentication credentials andmessage
security.

Note: This may be required before you can connect to the real service.

For task details, see "How to Set Security" on page 305.

Change servers

You can redeploy the virtual services in your project to a different server, if required.

From themainmenu, select Project > Change Server to open the Change Server for <current
project> Project dialog box.

Alternatively, in the Virtualization Explorer, right-click the project tree and select Change Server.
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How to Manage Virtualization Projects
This task describes how to create andmanage virtualization projects.

To learnmore about Service Virtualization projects, see "Virtualization Projects" on page 98.

Create a new project

Select one of the following:

l Select a task from theGet Started page. These tasks first create a new virtualization project and
then a new virtual service. For user interface details, see "Start Page" on page 28.

l Create a new virtualization project. From themainmenu, select File > New > Virtualization
Project. For user interface details, see "Summary of Virtualization Project Dialog Box" on page
118.

Add projects to an existing solution

You can add new or existing projects to a solution.

1. From themainmenu, select View > Projects to display the Projects pane.

2. Right-click the solution name and select one of the following:

a. Add > New Virtualization Project

b. Add > Existing Project

Open a project

To open a project, select one of the following:

l On the Start Page, underRecent Projects, select a project.

Tip: Hover over a project name to see the full path to the saved project.

l From themainmenu, select File > Open Project/Solution. By default, projects are stored in the
following location in the file system: <YourDocuments folder>\HP Service Virtualization\Projects.

Change the default project location

From themainmenu, select Tools > Options > General tab. Then select Projects and Solutions.
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Close a project

From themainmenu, select File > Close Project/Solution.

View server information

In the Virtualization Explorer, expand a project. The server is displayed as the last item in the tree.
Click the server to display its details in the lower pane.

Move virtual services to a different server

The virtual services in your project are deployed on the Service Virtualization server specified for the
project. To change the server, in the Virtualization Explorer, expand a project. Right-click the server
and select Change Server. Alternatively, from themainmenu, select Project > Change Server. For
user interface details, see "Change Server Dialog Box" on page 149.

Export a project

Save your project as an archive file in the file system. From themainmenu, select File > Export
Project. The file is saved with the default file extension .vproja.

Encrypt projects

You can encrypt your projects using a password you define.

1. From themainmenu, select Tools > Options.

2. On theGeneral page, click Projects and Solutions and enter a project encryption password.

For more details on encryption, see "Password Encryption" on page 20.

How to Edit a Service Description
This task describes how to edit a service description. This includes service editing and URI space
editing.

To learnmore about service descriptions, see "Service Descriptions" on page 102.

This task includes the following steps:

l "Open a service description" on the next page

l "Edit metadata" on the next page

l "Manage XML schemas" on the next page
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l "Add or remove an operation" below

l "Add or remove a URI space" below

l "Add or remove data formats" on the next page

l "Define session identifiers" on the next page

l "Hide data" on page 112

l "Update a SOAP service description" on page 112

Open a service description

In the Virtual Service Editor, under Service Description, click Edit. For user interface details, see
"Service Description Editor" on page 152.

Edit metadata

You can add, delete, enable, disable, and edit metadata.

In the Service Description Editor, under Request Metadata or ResponseMetadata, click Edit. For user
interface details, see "Edit Metadata Dialog Box" on page 164.

Manage XML schemas

In the Service Description Editor, under XML Schemas, select an option to add, edit, or remove
XML schemas. For user interface details, see "Service Description Editor" on page 152.

Add or remove an operation

You can add operations to your service.

In the Service Description Editor, in the bottom left of the Operations pane, click Add Operation.
Select input and output message types. Youmust assign each operation a unique input message type.

SAP services: For a SAP service, the AddOperation dialog box enables you to import RFC
functions or IDoc operations from a SAP server. For more details on SAP IDoc communication,
see "How to Virtualize SAP IDoc Communication" on page 112.

Add or remove a URI space

You can create additional URI spaces for your data.

In the Service Description Editor, in the bottom left of the Operations pane, click Add URI Space.
Enter a URI path.

Note:
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l Segments are separated with a '/' and the wildcard character '*' is used for several characters
or segments. For example, "Customer/*/Europe/*".

l Caution: If a URI Space that is in conflict with an existing URI Space and the new URI Space
is more specific, the conflicting URI Space is split to several new URI Spaces and data from
all associated rules aremoved to these new URI Spaces.

To delete a URI space, in the left pane of the Service Description Editor, select the URI space and
click Delete URI Space.

Add or remove data formats

Data formats can be added and removed from aURI space as either request or response data formats.

1. In the Service Description Editor, in the operations pane on the left side, select a URI space.

2. Under Data Formats > Request Data Formats or Response Data Formats, click Add.

For user interface details, see "Add Data Format Dialog Box" on page 166.

Define session identifiers

To simulate a stateful service, in which the order of requests can impact the responses that are
returned, you can configure the virtual service to create separate simulation sessions. For more
information, see "Stateful Simulation Overview" on page 276.

To enable stateful simulation, set session IDs to identify client requests that originate from the same
source.

1. Prerequisite: Service Virtualizationmust have information on themessage structure that the client
uses. The structure of request/responsemessages is stored in the service description. You
provide this information by doing one of the following:

n Placing the virtual service in Learningmode to record real service behavior. For example, for a
REST service.

n Importing a service description document, such as when creating a SOAP service using an
imported .wsdl service description document.

n Importingmessages into the virtual service's datamodel.

2. In the Service Description Editor, under Session IDs Definition, click Edit.

3. In the wizard pages that open, specify values for session identifiers, and click Finish. For user
interface details, see "Session ID DefinitionWizard" on page 155.

4. Learn data again. Service Virtualization uses the session IDs to create different tracks based on
the learned data, and uses the tracks to create different sessions during simulation.
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Hide data

Configure datamasking to protect sensitive data. Data recorded during Learning is masked and cannot
be viewed in the datamodel.

Do one of the following:

l In the Service Description Editor, under DataMasking, view the datamasking configuration for your
virtual service. To configure datamasking, click Edit.

l In the DataModel Editor, right-click a column header and selectMask.

For user interface details, see "DataMasking Dialog Box" on page 161.

Update a SOAP service description

Youmay need to update a SOAP service description after a virtual service is created. A service
commonly evolves over time, along with its WSDL, requiring an update of the virtual service.

You can update the service description in the following ways:

Automatically:

During Learning, Service Virtualization updates the SOAP service description automatically, based on
the data received.

Manually:

1. In the Virtual Service Editor, under Service Descriptions, click Update From File.

2. In the Update Service Description dialog box, enter the path or URL, or browse to enter a new file.

How to Virtualize SAP IDoc Communication
This task describes how to set up your systems to virtualize SAP IDoc message transfer. You can
record and simulate asynchronous IDoc message transfer between two SAP systems.

1. Prerequisites: Make sure you have configured the Service Virtualization SAP agent. For details,
see "How to Configure the SAP Agent" on page 56.

2. Configure your SAP systems:

n Configure the source SAP system for IDoc message processing.

n Configure the target SAP system for IDoc message processing.

For an example of setting up the SAP systems, see the SAP IDoc Demo readme file, located in
the sample project folder.

3. Create a SAP IDoc virtual service. For details, see "How to Create a Virtual Service" on page 104.
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4. If you have different sets of credentials for logging on to your source and target SAP systems, you
must edit the Service Virtualization credential store. For user interface details, see "Edit
Credential Store Dialog Box" on page 316.

5. Add a SAP IDoc operation, and select corresponding fields to use for request and (optionally)
responsemessages. In the Service Description Editor, in the bottom left of the Operations pane,
click Add Operation.

Note: The selected fields cannot be empty.

6. Optional: Import IDoc messages from SAP. In the datamodel, select an operation and expand a
rule. Right-click and select Import Message. Enter IDoc numbers to retrievemessages from the
SAP system.

7. Learn. If you have not imported IDoc messages, place the virtual service into Learningmode to
record the real service behavior - the destination SAP system responses.

a. On the SAP source system, create and send request messages.

b. On the SAP target system, create and send responsemessages.

8. Simulate. Place the virtual service into SimulatingmodeOn the SAP source system, create and
send request messages. The virtual service responds.

How to Virtualize a Fixed-Length over
TCP Protocol
This task describes how to virtualize fixed-length field based communication using a text-based
service description. You can create a virtual service based on the fixed-length service description files,
enabling the virtual service to learn and understand themessages andmessage structure. After
learning the new fixed-lengthmessages, they are displayed in the datamodel, structured according to
the service description files you provide.

1. Create and configure a new fixed-length TCP agent.

a. From themainmenu, select Tools > Options.

b. Click Agents.

c. Select Fixed Length TCP and click Add to add a new configuration.

d. Fill in the following parameters:

Port. The port of the virtual service using the agent.
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Remote Port. Port of the real TCP service.

Remote Host. Host of the real TCP service.

2. Build a service description for the fixed-length protocol.

n Use tab-separated files with .txt extension for message type definition.

n Eachmessage type requires a separate file with .txt extension.

n The structure of themessage definition file must be as follows:

The first line (header) is used to define columns for field definition. For example:

Name-->Offset-->Length-->Type-->Description-->Default Value-->Data-->Attributes

Each additional line defines one field of themessage. Define the field's column values using
tab-separated columns. For example:

Message number-->12-->4-->Numeric Unique-->Message identification number.-->-->-->

where (-->) indicates a tab, and an extra tabmarker (-->) indicates a columnwith no value. 

Example:

3. Create a new virtual service, and select the option to use a service description.

Select the .txt files you created to define the service description.

For details on creating a virtual service, see "How to Create a Virtual Service" on page 104.

Message Logging
You can log request and response data generated during learning, simulation, and standby
modes.
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Message logs enable you to:

l Check the logs and review themessages more closely to troubleshoot problems you
may have.

l Check the responses generated for specific requests.

l Save and share loggedmessages with other users.

l Examine protocol data that is not stored elsewhere.

What do you want to do?

l "(Prerequisite): Enable logging" below

l "View log files in the Designer message viewer" below

l "Access log files stored on the file system" below

l "Save logs to your local machine" on the next page

l "Set maximummessage read size" on the next page

(Prerequisite): Enable logging

Enablemessage logging for a virtual service.

In the Virtual Service Editor, under Service Configuration, selectMessage Logging.

View log files in the Designer message viewer

In the Virtual Service Editor, under Service Configuration, use the click here link to open themessage
viewer.

Filtering:Use the filter options to limit themessages displayed. By default, the viewer displays
messages from the current date, or the last date on whichmessages were logged.

Access log files stored on the file system

Log files are stored in the following locations:

l For a service running on the embedded server:Messages are stored in the Designer log folder
%APPDATA%\Hewlett-Packard\VirtualServiceDesigner\logs in the subfoldermessages\[Virtual
Service Name]-[Virtual Service ID], created when the first message is logged.

To open the Designer log folder, from theWindows Start menu, select Service Virtualization >
Designer > Designer Log Folder.

l For a service running on a Service Virtualization Server:Messages are stored in the Server
log folder%ALLUSERSPROFILE%\Hewlett-Packard\HP Service Virtualization Server\logs, in the
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subfoldermessages\[Virtual Service Name]-[Virtual Service ID], created when the first message is
logged.

To open the Server log folder, from theWindows Start menu, select Service Virtualization
> Server > Server Log Folder.

Eachmessage is stored in a single file namedmessage-[MessageOrder Number]-[Message Id].log.

Tip: If you do not have access to the Server machine directly, you can open the server logs in the
Designer message viewer, and save them to your local machine. For details, see "Message
Logging" on page 114.

Save logs to your local machine

1. In the Virtual Service Editor, under Service Configuration, use the click here link to open the
message viewer.

2. Click Save raw [request/response] data and selection a location.

Set maximummessage read size

To prevent loggedmessages that are too big to display, Service Virtualization configures amaximum
size limit for messages that can be viewed in the Designer message viewer. You canmodify the
message size limit using the application configuration files.

1. Navigate to the appropriate configuration file:

n Service Virtualization Server configuration file:HP.SV.StandaloneServer.exe.config,
located on the Service Virtualization Server machine in the server installation folder. By default,
C:\Program Files\HP\HP Service Virtualization Server\Server\bin.

n Designer configuration file:VSDesignerConfigurationTool.exe.config, located on the
Designer machine in the installation folder. By default, C:\Program Files (x86)\HP\HP Service
Virtualization Designer\Designer\bin\VirtualServiceDesigner.exe.config.

2. Modify the value in the following line:

<add key="MessageLogger.MaxReadMessageSize" value="20000"/>

The value is in kilobytes (kb).
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Virtual Services User Interface
This section includes:

Summary of Virtualization Project Dialog Box 118

Create New Virtual ServiceWizard 119

CreateMultiple Virtual Services Wizard 140

Endpoint Validation Dialog Box 141

Virtualization Explorer 142

Virtual Service Editor 144

Edit Endpoints Dialog Box 148

Change Server Dialog Box 149

Projects and Solutions Page 151

Service Description Editor 152

Session ID DefinitionWizard 155

DataMasking Dialog Box 161

Replace Algorithm Configuration Dialog Box 162

Edit Metadata Dialog Box 164

Add Data Format Dialog Box 166
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Summary of Virtualization Project Dialog Box
This dialog box enables you to create a new virtualization project.

To access From themainmenu, select File > New > Virtualization Project.

Relevant tasks "How to Use Service Virtualization" on page 23

See also "Service Virtualization Overview" on page 16

User interface elements are described below:

UI
Element Description

Project Displays the default name for the project you are creating.

Path Displays the default location in the file system where the project is created.

Server Displays the default server to be used with the new project.

All services in the project are deployed on this server.

Change Opens the Change Project dialog box, enabling you tomodify the following details:

l Project. Enter a name for the project or accept the default name.

l Path. Enter a path for the project or accept the default path.

l Server. Select the server on which to deploy the virtual service.

You can select the Designer's embedded server, or a standalone Service
Virtualization Server. For details on adding Service Virtualization Servers, see "How
toManage Service Virtualization Servers" on page 25.

Create Creates the new project according to your specified settings.
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Create New Virtual Service Wizard
This wizard enables you to create a new virtual service.

To access To launch the new virtual service wizard, in an existing project, select one of the
following:

l From themainmenu, select File > New > Virtual Service.

l In the Virtualization Explorer, right-click a virtualization entity and select Add >
Virtual Service.

Wizard
map

This wizard contains:

"Import Real Service Description Page" below > "Choose Service Protocol Page" on
the next page > "Service Properties Page" on page 122 > "Summary of Virtualization
Page" on page 139

Important
information

l If you are creating a new virtual service from theGet Started page, a new
virtualization project is created for the service.

l For additional details on specific service types, see "Virtual Service Types" on
page 99.

Relevant
tasks

"How to Create a Virtual Service" on page 104

See also l "Virtual Service Overview" on page 97

l "Service Descriptions" on page 102

Import Real Service Description Page

This wizard page enables you to import service description documents.
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Important
information

l General information about this wizard is available here: "Create New Virtual
ServiceWizard" on the previous page

l For additional details on specific service types, see "Virtual Service Types" on
page 99.

l This page also enables you to import a service description in order to add service
call activity in the DataModel.

Wizard
map

The create new virtual service wizard contains:

"Import Real Service Description Page" on the previous page > "Choose
Service Protocol Page" below > "Service Properties Page" on page 122 > "Summary
of Virtualization Page" on page 139

See also l "Virtual Service Overview" on page 97

l "Service Descriptions" on page 102

User interface elements are described below:

UI Element Description

Service
description

Enables you to import aWSDL, XML schema (XSD), or COBOL copybook document.

Enter the URL or path to your service description file, or click Browse to navigate to a
file location.

You can also import a service description file from an existing virtual service. In your
project directory, import a relevant .vsdsc file to create the new virtual service.

Note: If theWSDL describes multiple services or a single service specifying
multiple ports, select one from the list of available ports in the dialog box that
opens.

For connection to a secured web service, you are required to enter your access
credentials.

I don't
have a
service
description

Enables you to create a virtual service without using an existing service description.

REST services:Select this option when creating a REST service. REST
services do not use imported service description documents. After you
create a REST service, you can record real service behavior to learn the
structure of the service.

Choose Service Protocol Page

This wizard page enables you to select protocols for your new virtual service.
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Important
information

l General information about this wizard is available here: "Create New Virtual
ServiceWizard" on page 119

l For additional details on specific service types, see "Virtual Service Types" on
page 99.

Wizard
map

The create new virtual service wizard contains:

"Import Real Service Description Page" on page 119 > "Choose Service Protocol
Page" on the previous page > "Service Properties Page" on the next page >
"Summary of Virtualization Page" on page 139

See also "Virtual Service Overview" on page 97

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<filter text
box>

Enter text to filter the available protocols.

Filter by To filter the protocol list, select protocols from themessage and transport protocol
drop-down lists.

<list of
protocols>

Select a protocol configuration for your new virtual service.

Message Type Page

This wizard page enables you to define the structure of input and output messages, when working with
a COBOL copybook.
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Important
information

l General information about this wizard is available here: "Create New Virtual
ServiceWizard" on page 119

l This wizard page is available only if you chose to import a COBOL copybook for
the service description.

l For additional details on specific service types, see "Virtual Service Types" on
page 99.

Wizard
map

The create new virtual service wizard contains:

"Import Real Service Description Page" on page 119 > "Choose Service Protocol
Page" on page 120 > "Service Properties Page" below > "Summary of Virtualization
Page" on page 139

See also "Virtual Service Overview" on page 97

User interface elements are described below:

UI Element Description

Create messages
specifying input and
output elements

Displays themessage types available for input and output, as defined
in your COBOL copybook.

Only one COBOL structuremay be assigned as the input message,
and another as the output message.

Create multisegmented
messages

A multi-segmentedmessage is composed of multiple COBOL
structures. Each COBOL structuremay occur one or more times in a
segmentedmessage.

Note: Not all IMS protocols support this feature.

Service Properties Page

This wizard page enables you to define protocol-specific properties for your virtual service.
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Important
information

l General information about this wizard is available here: "Create New Virtual
ServiceWizard" on page 119

l The properties available on the page depend on the protocols you select for the
new service on the Choose Service Protocol page.

l After the virtual service is created, you can edit these properties. In the Virtual
Service Editor, under Service Configuration, click Edit to open the Edit Endpoints
dialog box.

l For additional details on specific service types, see "Virtual Service Types" on
page 99.

Wizard
map

The create new virtual service wizard contains:

"Import Real Service Description Page" on page 119 > "Choose Service Protocol
Page" on page 120 > "Service Properties Page" on the previous page >
"Summary of Virtualization Page" on page 139

See also "Virtual Service Overview" on page 97

This section includes:

l "General" on the next page

l "HTTP" on the next page

l "IBM IMS TM" on the next page

l "IBM CICS TS HTTP" on page 125

l "JDBC" on page 125

l "JMS" on page 125

l "MSMQ" on page 128
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l "ORACLE AQ" on page 131

l "SAP RFC" on page 131

l "SAP IDOC" on page 132

l "WebMethods IS SAP IDOC" on page 133

l "TIBCO EMS" on page 133

l "WebSphereMQ" on page 133

User interface elements are described below:

General

Show Endpoint Topology Displays a diagram of your service endpoint configuration.

Test Endpoints Checks that the real service endpoints are accessible.

HTTP

Define the real service endpoints.

Property Description

Endpoints Enter the real service endpoint (URL).

To enter multiple endpoints, separate them by a space, comma, semicolon, or type
each endpoint on a new line.

Note:When using the HTTP or HTTPS Gateway agent, the virtual servicemay
have only one specified endpoint.

IBM IMS TM

Define the real service properties. Values are case-sensitive and should be provided by your
IMS TM System Administrator or Operator.

Property Description

Client ID Identification of the client for services with dedicated persistent socket connections.
For shareable persistent socket connections, leave this value undefined.

Transaction
Code

The alphanumeric code used to invoke IMS message processing program.
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Property Description

TPipe
Name

The transactional pipe (TPipe) value, used tomaintain a logical association between
client and service. TheOTMA TPipe name is similar to the IMS Connect logical
terminal (LTerm) name.

LTerm
Name

Logical Terminal Name. The IMS logical association between client and service.
Similar to OTMA TPipe name.

Datastore
ID

The service datastore name (IMS Destination ID).

Any value Clear this option to define a filter for the corresponding property. If you enter a specific
value for a property, only messages matching the specified value are processed
during Learning and Simulation sessions.

IBM CICS TS HTTP

Define virtual and real service properties.

Property Description

Virtual Service Parameters:

Path The relative URI  that defines on which URI path the virtual service is to be deployed.

Real Service Properties:

Endpoint The relative or absolute endpoint, depending on the agent type, that defines where the
actual COBOL service is listening. For details, see "Virtual Service Types" on page 99.

Encoding COBOL content encoding.

JDBC

Define the real service properties.

Property Description

Connection
String

Define one of the following:

l The JDBC Connection string used in the application under test. This is used
primary when working with J2SE applications.

l The JNDI datasource name used by the application under test. This is used only if
the application is deployed on a J2EE application server.

JMS

Define virtual and real service properties.
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Virtual Service Properties:

Multiple
Agents

Select Enable multiple JMS providers to enable the use of different JNDI contexts
for incoming/outgoingmessages or for request/response activities.

l You can define an agent configuration for each JNDI context you require. For
details, see "Agents Page" on page 66.

l Select agent configurations for your virtual service using theAgent andReply
Agent fields in this dialog box. A virtual service has virtual and real service
endpoints, and each endpoint has an input and an output agent, resulting in four
possible agent assignments.

Examples: The following use cases are examples only. You can configure the
agents in any combination tomeet your needs.

l Use one agent configuration (agent 'A') for handling communication for
request processing, and another agent configuration (agent 'B') for handling
communication for response processing.

l Use one agent configuration (agent 'A') for communication between your
client (AUT) and Service Virtualization, and another agent configuration
(agent 'B') for communication between Service Virtualization and the real
service.
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Server The Service Virtualization Server on which you want to deploy the virtual service.

Available when usingmultiple agents.

Agent Used for processing requests from the client to Service Virtualization.

Available when usingmultiple agents.

Destination
Name

The JNDI destination namewhere the virtual service expects to receive requests.

Connection
Factory

The JNDI name of the connection factory used for communication from the client to
Service Virtualization.

Reply
Agent

Used for processing responses sent from Service Virtualization to the client.

Available when usingmultiple agents.

Reply To The JNDI destination namewhere the virtual service will send responses.

l If the client provides a ReplyTo JMS property, you can leave this field empty.

l If you are usingmultiple agents, this field must not be left empty.

Reply
Connection
Factory

The JNDI name of the connection factory used for communication from Service
Virtualization to the client.

Available when usingmultiple agents.

Real Service Properties:

Agent Used for processing requests from Service Virtualization to the real service.

Available when usingmultiple agents.

Destination
Name

The JNDI destination namewhere the real service expects to receive requests.

Connection
Factory

The JNDI name of the connection factory used for communication from Service
Virtualization to the real service.

Reply
Agent

Used for processing responses sent from the real service to Service Virtualization.

Available when usingmultiple agents.

Reply To The JNDI destination namewhere the real service sends responses.

l If this field is left empty, Service Virtualization creates a temporary destination for
receiving responses from the real service, and sets the ReplyTo JMS property in
the request to point to that temporary destination.

l If you are usingmultiple agents, this field must not be left empty.
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Reply
Connection
Factory

The JNDI name of the connection factory used for communication from the real
service to Service Virtualization.

Available when usingmultiple agents.

MSMQ

Define virtual and real service properties.

Property Description

Authentication Select Use Authentication for any element to enable domain
authentication. Youmust use authentication when working in a domain
environment in which anMSMQ queue restricts access to
authenticated users only.

The user that is configured to run the Service Virtualization Server or
Designer is used for all authentication toMSMQ servers and
resources. Authorization is carried out by Windows Active Directory.

Virtual Service Properties:
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Property Description

Multiple
Agents

Select Enable multiple queue managers to enable the use of
different MQ queues for incoming/outgoingmessages or for
request/response activities.

l Youmust define an agent configuration for each queue you require.
For details, see "Agents Page" on page 66.

l Select agent configurations for your virtual service using theAgent
andReply Agent fields in this dialog box. A virtual service has
virtual and real service endpoints, and each endpoint has an input
and an output agent, resulting in four possible agent assignments.

Examples:

The following use cases are examples only. You can configure the
agents in any combination tomeet your needs.

l Use one agent configuration (agent 'A') for handling
communication for request processing, and another agent
configuration (agent 'B') for handling communication for
response processing.

l Use one agent configuration (agent 'A') for communication
between your client (AUT) and Service Virtualization, and
another agent configuration (agent 'B') for communication
between Service Virtualization and the real service.
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Property Description

Server The Service Virtualization Server on which you want to deploy the
virtual service.

Available when using different request/response agents.

Destination
Name

Name of queue where the virtual service expects requests.

Click Browse to select a destination.

Agent Used for processing requests from the client to Service Virtualization.

Available when using different request/response agents.

Reply To Name of queue where the virtual service will send responses. If the
client provides a ReplyToQueuemessage property, you can leave this
field empty.

Click Browse to select a destination.

Reply Agent Used for processing responses sent from Service Virtualization to the
client.

Available when using different request/response agents.

Real Service Properties:

Destination
Name

Name of queue where the real service expects requests.

Click Browse to select a destination.

Agent Used for processing requests from Service Virtualization to the real
service.

Available when using different request/response agents.
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Property Description

Reply To Name of queue where the real service sends responses. Click
Browse to select a destination.

Note: This field may not be left empty.

Reply Agent Used for processing responses sent from the real service to Service
Virtualization.

Available when using different request/response agents.

ORACLE AQ

Define the following properties for the request queue, and optionally, for the response queue.

Property Description

Subscription Agent
Name

The AQAgent name that Service Virtualization uses to consume
messages.

Queue Name The name of the AQ queue.

Dequeue Condition A condition you can define to limit messages consumed by Service
Virtualization.

SAP RFC

Define real and virtual service settings.

Property Description

Virtual Service Settings

Program ID The ID assigned to the RFC destination defined on the SAP or PI server.

Source SAP in
Unicode

Indicates that the RFC destination you are using is Unicode enabled.

Source SAP PI Indicates that you are working with a SAP PI RFC adapter.

Real Service Settings

Hostname The IP address or host name of the SAP server.

Alternatively, youmay enter the SAP Router String for communication
through the SAP firewall.

User Guide
Chapter 3: Virtual Services

HP Service Virtualization (3.61) Page 131 of 352



Property Description

Gateway The SAP Gateway.

The gateway is "sapgwXX", where XX is the SAP system number.

Client ID The SAP client ID.

Target SAP in
Unicode

Indicates that the destination SAP system is Unicode enabled.

SAP IDOC

Define real and virtual service settings.

Property Description

Virtual Service - Request Settings

Program ID The ID assigned to the RFC destination defined on the SAP or PI server.

Source SAP in
Unicode

Indicates that the RFC destination you are using is Unicode enabled.

Source SAP PI Indicates that you are working with a SAP PI RFC adapter.

Virtual Service - Response Settings (Optional)

Program ID The ID assigned to the RFC destination defined on the SAP or PI server. This
destination is used for responses.

Source SAP in
Unicode

Indicates that the RFC destination you are using is Unicode enabled.

Source SAP PI Indicates that you are working with a SAP PI RFC adapter.

Real Service - Request Settings

Hostname The IP address or host name of the SAP server.

Alternatively, youmay enter the SAP Router String for communication through
the SAP firewall.

Gateway The SAP Gateway.

The gateway is "sapgwXX", where XX is the SAP system number.

Client ID The SAP client ID.

Target SAP in
Unicode

Indicates that the destination SAP system is Unicode enabled.
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Property Description

Real Service - Response Settings (Optional)

Client ID The SAP client ID.

Target SAP in
Unicode

Indicates that the destination SAP system is Unicode enabled.

WebMethods IS SAP IDOC

Define the real service properties.

Property Description

Request Service Name TheWebMethods Integration Server flow service that publishes
requests.

Response Service
Name

TheWebMethods Integration Server flow service that processes
responses.

The request and response service names must be formatted using full names, as specified in the
WebMethods IS documentation. For example:

SAP_EC6.services:ReqFlowService

TIBCO EMS

Define the real service properties.

Since Service Virtualization records messages on TIBCOEMS non-intrusively, all parameters in the
configuration are related only to the real service. When the virtual servicemode is switched to
Simulatingmode, the real service is automatically disconnected from TIBCOEMS and is replaced by
Service Virtualization.

There is no response destination name as the response destination is always read from request
properties.

Property Description

Destination Name Name of destination where requests are sent.

Destination Type Type of destination where requests are sent.

WebSphere MQ

Define virtual and real service properties.
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Property Description

Virtual Service Properties:
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Property Description

Multiple
Agents

Select Enable multiple queue managers to enable the use of different
MQmanagers for incoming/outgoingmessages or for request/response
activities.

l Youmust define an agent configuration for each queuemanager you
require. For details, see "Agents Page" on page 66.

l Select agent configurations for your virtual service using theAgent
andReply Agent fields in this dialog box. A virtual service has virtual
and real service endpoints, and each endpoint has an input and an
output agent, resulting in four possible agent assignments.

Examples:

The following use cases are examples only. You can configure the
agents in any combination tomeet your needs.

l Use one agent configuration (agent 'A') for handling
communication for request processing, and another agent
configuration (agent 'B') for handling communication for response
processing.

l Use one agent configuration (agent 'A') for communication
between your client (AUT) and Service Virtualization, and another
agent configuration (agent 'B') for communication between
Service Virtualization and the real service.
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Property Description

Server The Service Virtualization Server on which you want to deploy the virtual
service.

Available when using different request/response agents.

Destination
Name

Name of queue where the virtual service expects requests.

Click Browse to select an actual destination or to virtualize a destination.

Agent Used for processing requests from the client to Service Virtualization.

Available when using different request/response agents.

Reply To Name of queue where the virtual service will send responses. If the client
provides a ReplyToQueuemessage property, you can leave this field
empty.

Click Browse to select an actual destination or to virtualize a destination.

Reply
Agent

Used for processing responses sent from Service Virtualization to the
client.

Available when using different request/response agents.

Real Service Properties:

Destination
Name

Name of queue where the real service expects requests.

Click Browse to select an actual destination or to virtualize a destination.

Agent Used for processing requests from Service Virtualization to the real
service.

Available when using different request/response agents.
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Property Description

Reply To Name of queue where the real service sends responses. Click Browse to
select an actual destination or to virtualize a destination.

Note: If this field is left empty, Service Virtualization creates a
temporary queue for receiving responses from the real service, and
sets the ReplyToQueuemessage property in the request to point to
that temporary destination.

If the field is left empty:

l WebSphereMQmust be configured so that Service Virtualization
has permission to create temporary queues.

l The real service request agent (theAgent field) and the real
service reply agent (theReply Agent field) must be the same.

Reply
Agent

Used for processing responses sent from the real service to Service
Virtualization.

Available when using different request/response agents.

Browse Destinations Dialog Box

This wizard page enables you to select and virtualize anMQ destination to use in your virtual service.
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Important
information

l General information about this wizard is available here: "Create New Virtual
ServiceWizard" on page 119

l For additional details on specific service types, see "Virtual Service Types" on
page 99.

l This dialog box opens when you click Browse for a destination in the Service
Properties dialog box.

Note: To view MQ destinations, the user defined for theWebSphereMQ
virtual agent must have sufficient permissions. For details, see "WebSphere
MQ Agent Settings" on page 86.

Wizard
map

The create new virtual service wizard contains:

"Import Real Service Description Page" on page 119 > "Choose Service Protocol
Page" on page 120 > "Service Properties Page" on page 122 > "Summary of
Virtualization Page" on the next page

See also l "Virtual Service Overview" on page 97

l "WebSphereMQ Agent Settings" on page 86

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<search box> Enter a destination name or part of a name to filter the list of destinations displayed.

Virtualized
Destinations
Only

Displays only the list of destinations that are virtualized.

Relevant
Agents

Displays only the list of destinations that youmay use.

For example, filters out any destinations for which the agent does not have
sufficient permissions to access, or agents that are not defined on the server with
which you are working.

<destinations
list>

List of available destinations. The destinations displayed are based on the
WebSphereMQ queuemanagers defined in theWebSphereMQService
Virtualization agent configurations.

Actual destinations.

Virtualized destinations.

Manage
Agents

Opens the Agents page, enabling you to add, delete, or reconfigure settings for
virtual service agents. For details, see "Agents Page" on page 66.
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UI Element Description

Virtualize
Selected

Select an actual destination and click Virtualize Selected. Creates a duplicate,
virtual destination that you can use for your virtual service.

In the dialog box that opens, accept the default name for the virtual destination, or
enter a different name.

Available for:WebSphereMQ

Unvirtualize
Selected

Deletes the virtual destination.

Available for:WebSphereMQ

Summary of Virtualization Page

This wizard page enables you to review your information. You can confirm or change details of the real
service, virtual service, or project.

Important
information

l General information about this wizard is available here: "Create New Virtual
ServiceWizard" on page 119.

l If you are creating a new virtual service from theGet Started page, a new
virtualization project is created for the service. Click Change to modify project
name, path, or agent.

l For additional details on specific service types, see "Virtual Service Types" on
page 99.

Wizard
map

The create new virtual service wizard contains:

"Import Real Service Description Page" on page 119 > "Choose Service Protocol
Page" on page 120 > "Service Properties Page" on page 122 > "Summary of
Virtualization Page" above

See also "Virtual Service Overview" on page 97
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User interface elements are described below:

UI
Element Description

Virtual
Service

Displays details of the virtual service you are creating.

Real
Service

Displays the parameters you defined for the real service.

Project If you are creating a new virtual service from theGet Started page, a new virtualization
project is created for the service. Click Change to modify the following details:

l Project. Enter a name for the project or accept the default name.

l Path. Enter a path for the project or accept the default path.

l Server. Select the server on which to deploy the virtual service.

You can select the Designer's embedded server, or a standalone Service
Virtualization Server. For details on server status indicators, or on adding additional
Service Virtualization Servers, see "How toManage Service Virtualization Servers"
on page 25.

Change Opens a dialog box for the selected component, enabling you tomodify settings for your
virtual service or real service.

When you are also creating a new project, you can also edit the project settings.

Note: It is recommended to run the endpoint test, located in theChange Virtual
Service dialog box.

Virtualize Creates a new virtual service.

Create Multiple Virtual Services Wizard
This wizard enables you to createmultiple SOAP virtual services based onWSDL documents.

Note: Available for SOAP over HTTP(S) services only.
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To access To launch theMultiple Virtual Services wizard, in an existing project, select one of the
following:

l From themainmenu, select File > New > Multiple Virtual Services.

l In the Virtualization Explorer, right-click a virtualization entity and select Add >
Multiple Virtual Services.

Relevant
tasks

"How to Create a Virtual Service" on page 104

See also l "Virtual Service Overview" on page 97

l "Service Descriptions" on page 102

Import Real Service Descriptions Page

Specify locations of service descriptions for real services. Enter a list of paths to .wsdl files, separated
by semicolons, or the path to a CSV file containing the paths to the .wsdl files.

If you are using a CSV file, each wsdl path/URLmust be in its own row, and optionally may contain
login credentials if they are required, separated by commas. For example,
http://server/service?wsdl,user,password.

Real Service Endpoints Page

This page displays the services and endpoints identified in the files you specified. Choose the services
and endpoints that you want to virtualize.

Agent Selection Page

Supported agent types are displayed. Select an agent configuration for each agent to use for your new
virtual services.

Summary of Virtualization Page

Displays a summary of how many services were created.

Endpoint Validation Dialog Box
This dialog box provides information in the event that endpoint validation fails.
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To access When creating a new virtual service, or editing the endpoints for an existing service,
this dialog box opens automatically if endpoint validation fails for any endpoint.

Important
information

The buttons displayed in this dialog box vary depending on the protocol you are using.

Relevant
tasks

"How to Create a Virtual Service" on page 104

See also For details on defining the protocol-specific properties for your endpoints, see
"Service Properties Page" on page 122.

User interface elements are described below:

UI
Element Description

Use
Suggested

Uses the address suggested by the Service Virtualization agent, displayed in the
dialog box.

Add New
Agent

Opens the Agents Page and creates a new configuration of the agent. For user
interface details, see "Agents Page" on page 66.

Virtualization Explorer
The Virtualization Explorer displays the logical structure of your virtualization projects. It shows the
virtualization entities in your project, such as services, models, and topologies, in their hierarchical
structure. It also displays information on the server associated with your project.
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To access The Virtualization Explorer is initially displayed, by default, on the sidebar or in the
left pane of the Service Virtualization window.

If not visible on the sidebar or in the left pane, from themainmenu, select View >
Virtualization Explorer.

Important
information

Right-click virtualization entities in the project tree to view additional options.

User interface elements are described below:

UI
Element Description

project
tree

Displays the virtualization entities in your open project.

l Select an entity in the tree to display its details in the lower pane.

l Double-click an entity to open it in themain display pane.

l Right-click an entity to view additional options.

Tip: Each virtualization entity is represented by a different icon. In addition, the icons
change to reflect current statuses. For example, a virtual service icon indicates the
service's current mode, such as Learning, and a server icon indicates the server's
current status, such as Online.
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Virtual Service Editor
The Virtual Service Editor enables you to control themode of the virtual service and themodels
currently in use, configure the endpoints, and configure security settings.

To access In the Virtualization Explorer, double-click the virtual service you want to
view or edit.

Important
information

Some changes youmake to the servicemay require that you restart the
service.

Relevant tasks "How to Configure Virtual Services" on page 105

See also l "Virtual Service Overview" on page 97

l "Service VirtualizationMainMenus" on page 33

User interface elements are described below (unlabeled elements are shown in angle brackets):
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General

UI Element Description

<virtual service
name and
description>

The name and description of the Virtual Service. Click to edit.

<status area> Located in the upper-left part of the window, indicates the following:

l The current mode of the service: Learning, Simulation, Standby or Offline.

l The data and performancemodels currently in use.

Puts the selected service into LearningMode. Any communication through the
Virtual Service is added to the SimulationModel in this mode.

Use the drop down arrow to select whichmodels to update:

l Data & Performance (default)

l DataModel

l PerformanceModel

Starts the simulation according to the simulationmodels selected in the
Virtual Service Editor.

If the service was in Learningmode, Service Virtualization first finishes the
learning session and adds any data learned in the session to the Simulation
Model.

Puts the service into Standby Mode with the option of maintaining or disposing
of learned data.

Opens the Runtime Report to display current information about the service.

Simulation Models area

Manage themodels associated with the virtual service.

UI Element Description

Data Model Select a datamodel to use with the service.

None. Enables you to pass messages to the real service and receive responses,
while still simulating performance according to the selected PerformanceModel.
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UI Element Description

Performance
Model

Select a performancemodel to use with the service.

None. Causes the virtual service to respond as quickly as possible.

Offline. Simulates the unavailability of the service.

Network
Model

The network model selected for the virtual service.

To select a different model, or to define a new model, click Manage Network
Models.

For details on network models, see "Network Virtualization Overview" on page 349.

Note: Network Virtualization is a Service Virtualization Labs feature. This field
is displayed only if you have enabled the feature. For details, see "Service
Virtualization Labs" on page 343.

Add Opens the Add New SimulationModel dialog box, enabling you to add a new data or
performancemodel.

Edit Opens the selected data or performancemodel in the relevant editor. For more
details, see "DataModel Editor" on page 240 or "PerformanceModel Editor" on page
286.

Delete Deletes the selectedmodel.

Duplicate Opens the Add New SimulationModel dialog box, enabling you to create a copy of
the selected data or performancemodel.

Hot Swap Enables you to select a different performancemodel when the virtual service is in
Simulatingmode, without redeploying virtual service data and restarting simulation.

Select themodel you want to switch to, and click Hot Swap.

Any unsent messages waiting to be processed according to the response time of the
current performancemodel are sent immediately. The new model is used for any
subsequent requests.

To switch the performancemodel during simulation:

l neither the current model or themodel you are selecting can be theOffline
performancemodel.

l you cannot switch to theMaximal Performancemodel if you want to also use
theReal Service datamodel.

Service Configuration area

View or edit details of the real and virtual services, protocol, and agent currently in use.
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UI Element Description

<service/agent
details>

l For details on Service Virtualization agent properties, see "Agents Page" on
page 66.

l For details on protocol-specific endpoint properties, see "Service Properties
Page" on page 122.

Edit Opens the Edit Endpoints dialog box, enabling you to edit real and virtual service
information. For details, see "Edit Endpoints Dialog Box" on the next page.

Configure Opens the Agents page in the Options dialog box, enabling you to configure the
agent used by the virtual service. For details, see "Agents Page" on page 66.

Message
Logging

Enables logging.

l To view loggedmessages in the Designer message viewer, use the click here
link.

l To open the Designer log folder, from theWindows Start menu, select Service
Virtualization > Designer > Designer Log Folder.

l To open the Server log folder, from theWindows Start menu, select Service
Virtualization > Server > Server Log Folder.

For more details, see "Message Logging" on page 114.

Disable
Schema
Learning

Blocks changes to the service description during learning or message import.

This is useful when the service was created from an existingWSDL or schema,
and you want to ensure that messages with a different structure do not modify it.

Service Description area

Displays the service description and any metadata associated with the service.

UI
Element Description

Edit Opens the Service Description Editor, enabling you to add new operations to the service,
or updatemetadata. For details, see "Service Description Editor" on page 152.

Note: Editing the service description is not supported for some protocols.

Update
From
File

Opens the Update Service Description dialog box, enabling you to replace the service
description file.

Note: Available only for SOAP services.
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Security Settings area

This area enables you to view and edit security settings.

UI
Element Description

Edit
Credential
Store

Opens the Edit Credential Store dialog box, enabling you to create and edit user
identities. For details, see "Edit Credential Store Dialog Box" on page 316.

Enabled Turns message security on or off.

Mode Default supportedmessage security modes. For details, see "How to Set Message
Security" on page 306.

Real
Service
Identity

The identity of the real service, its certificate, is stored in the Credential Store. This
setting is used if a service uses a certificate for message security. The public key of
the certificate is used to encrypt messages sent to the real service.

Virtual
Service
Identity

The identity of the virtual service, its certificate, is stored in the Credential Store.

l If the Real Service Identity contains the certificate with a private key, this setting
does not need to be configured. In this scenario, the Real Service Identity is also
used as the identity of the virtual service.

l If the Real Service Identity contains only a certificate without a private key, this
settingmust be configured to provide the identity of the virtual service. The
configured identity must contain a certificate with a private key, as the service
requires the private key to decrypt themessages coming from the client.

l Clients must trust the certificate used as the identity of the virtual service.

Security
Applied
To

Indicates on whichmessage parts security is applied - request elements, response
elements, or both.

Default:Request and response.

Advanced
Settings

Opens the AdvancedMessage Security Settings dialog box. For details, see
"AdvancedMessage Security Settings Dialog Box" on page 317.

Edit Endpoints Dialog Box
This dialog box enables you to edit the real and virtual service endpoints configured for your virtual
service.

To access In the Virtual Service Editor, under Service Configuration, click Edit.

User interface elements are described below:
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UI Element Description

Virtual/Real
Service

Virtual and real service information.

Note:

l For details on Service Virtualization agent properties, see "Agents Page"
on page 66.

l For details on protocol-specific endpoint properties, see "Service
Properties Page" on page 122.

Show Endpoint
Topology

Displays a diagram of your service endpoint configuration.

Test Endpoints Checks that your endpoint is configured correctly.

Advanced Settings - Available for SOAP services over HTTP, TIBCO EMS, and JMS

Ignore WS
Addressing

WS-Addressing headers are not processed by Service Virtualization.

Do Not Send
MTOM

By default, if anMTOMmessage is received when a virtual service is in Standby
or Learningmode, themessage is passed to the real service also as MTOM.
This option instructs Service Virtualization to pass themessage as a normal
XMLmessage with base64 content instead.

Write Schema
Types

By default, the xsi:type attribute is included only when necessary, according to
the XML specification. This option instructs Service Virtualization to always
include the xsi:type attribute for XML elements in a simulated response,
indicating the schema type of that element.

Use
'soapenc: Array'
as Array Type

In SOAP encoding, all arrays are derived from the soap-enc:Array type. By
default, when the xsi:type for an array element is written, the real array type is
used, such as ns:ArrayOfString. However, some SOAP clients may require the
base type instead (soap-enc:Array). This option instructs Service Virtualization
to emit soap-enc:Array to array elements instead of the real type.

Change Server Dialog Box
These pages enable you tomove the virtual services in a project to a different server.
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To access From themainmenu, select Project > Change Server.

Important
information

l For details on Service Virtualization agent properties, see "Agents Page"
on page 66.

l For details on protocol-specific endpoint properties, see "Service
Properties Page" on page 122.

User interface elements are described below:

UI Element Description

Runtime
Server

Select a server or enter the URL for a new server on which to deploy the virtual
services in the open project.

Note: The servers available in the drop-down list are the servers configured in
your project. To view, add, or delete servers, from themainmenu, select Tools
> Options, and click theServers tab.
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UI Element Description

Agent Select an agent for each service.

Manage
Agents

Opens the Agents page, enabling you to add, delete, or reconfigure settings for
virtual service agents. For details, see "Agents Page" on page 66.

Duplicate
Original
Configuration

Opens the Agents page, and copies the configuration on the current server to
create a configuration on the new server. You canmodify the settings of the new
configuration.

Projects and Solutions Page
The Projects and Solutions page enables you to:

l define the default location for saving projects in the file system

l set a password for project encryption

To access 1. From themainmenu, select Tools > Options.

2. On theGeneral page, click Projects and
Solutions.

Relevant tasks "How toManage Virtualization Projects" on page 108

See also l "Virtualization Projects" on page 98

l "Password Encryption" on page 20
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User interface elements are described below:

UI
Element Description

Default
project
location

Enter a location in the file system for storing virtualization projects.

Load
previous
solution
on startup

When you open the Designer, Service Virtualization opens the
solution in which you were previously working.

Project
encryption
password

Enter a password to encrypt sensitive project data.

For more details on encryption, see "Password Encryption" on page
20.

Show
password

Temporarily displays the project encryption password.

Service Description Editor
The Service Description Editor enables you to edit a virtual service description, including editing
metadata, managing XML schemas, adding and removing operations, and defining session identifiers.
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To access l In the Virtualization Explorer, expand a virtual service and double-click the
service description.

l In the Virtual Service Editor, under Service Description, click Edit.

l In the DataModel Editor, select one of the following:

n URI Spaces > Edit URI Spaces

n Operations > Edit Operations

Important
information

Not all editing operations are available for all protocols.

You can edit URI Spaces when working with the REST protocol, and edit
operations when working with XML protocols.

Relevant tasks "How to Edit a Service Description" on page 109

See also "Service Descriptions" on page 102

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<Operations pane> Located in the left pane of the editor. Displays a list of the operations or
URI spaces in the service.

Enter text in the filter box to filter for specific operations in the list.

Select an operation or URI space to display its details.

Add Operation Located at the bottom of the operations pane.

Opens the AddOperation dialog box, enabling you to select input and
output message types. Youmust assign each operation a unique input
message type. Available for XML services.

SAP RFC: Connects to the SAP Server and displays a list of available
operations that you can add to your virtual service.

SAP IDoc: Select fields to use for request and responsemessage pairing.
For more details, see "How to Virtualize SAP IDoc Communication" on
page 112.

Add URI Space Located at the bottom of the operations pane.

Opens the Add New URI Space dialog box, enabling you to create a new
URI space. Enter the URI path.

Available for REST services.

Delete
Operation/URI Space

Located at the bottom of the operations pane.

Deletes the selected operation/URI space.
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UI Element Description

IDoc Correlation
Settings

Enables you to edit settings for asynchronous IDoc message transfer
between two SAP systems.

For details, see "How to Virtualize SAP IDoc Communication" on page
112.

Available for a SAP IDoc service.

Session ID
Definition

Defines the elements used to identify requests coming from the same
source during a Learning session.

The following identifiers are configured by default:

l For HTTP: ClientAddress metadata

l ForMQ: UserID metadata

Other transport protocols (TibcoEMS, GenericJMS, JDBC) do not have
default session identifiers. Tracks are created after each Learning session.

Click Edit to modify the settings. For details, see "Session ID Definition
Wizard" on the next page.

Message Metadata Enables you to edit request and responsemetadata. Click Edit to open the
Edit Metadata dialog box. For details, see "Edit Metadata Dialog Box" on
page 164.

XML Schemas Lists all XML schema defined in the service description. You can add an
XML schema, or edit or remove schemas.

l Add. Opens the Import XML Schema dialog box, enabling you to enter
a file location for an existing schema (.xsd file), and add it to the service
description.

l Edit. Opens the schema in an XML editor, enabling you tomodify the
schema. Click the Tools pane to access tools for editing the schema.

l Delete. Removes the schema from the service description.

URI Space
Properties

Displays the URI space path.

Data Formats Lists the available request and response data formats.

Click Add to add a new data format. For details, see "Add Data Format
Dialog Box" on page 166.

Available for URI spaces.

Data Masking Enables you to hide specific data elements, to protect sensitive data. For
details, see "DataMasking Dialog Box" on page 161.
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Session ID Definition Wizard
This wizard enables you to specify whichmetadata or message elements to use to identify requests
coming from the same source. Service Virtualization uses this information to create different tracks
from learned data, and uses the tracks to create different sessions during simulation.

To access In the Service Description Editor, under Session ID Definition, click Edit.

Wizard
map

This wizard contains:

"Define Default Session IDs Page" below > "Select Session ID Page" on the next
page > "Define Operation Specific Session IDs Page" on page 157 > "Define Data
Format Session IDs Page" on page 158 > "Define Session IDs Summary Page" on
page 159

Important
information

l Service Virtualization defines default identifiers based on the protocol and agent
you define for the virtual service. This wizard enables you tomodify the default
selections.

l The following can be defined as session identifiers:

n message elements

n protocol metadata (headers)

n cookies

Relevant
tasks

l "How to Edit a Service Description" on page 109

l "How to Simulate a Stateful Service" on page 277

See also "Service Descriptions" on page 102

Define Default Session IDs Page

This wizard page enables you to define session identifiers at the service level.
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Important
information

General information about this wizard is available here: "Session ID Definition
Wizard" on the previous page

Wizard
map

The Session ID Definition wizard contains:

"Define Default Session IDs Page" on the previous page > "Select Session
ID Page" below > "Define Data Format Session IDs Page" on page 158 > "Define
Session IDs Summary Page" on page 159

User interface elements are described below:

UI Element Description

Request/Response Displays current settings for request and response elements.

Session ID Source The source for identifying sessions. Options include:

l Metadata. Enables you to define whichmetadata to use as a session
identifier. Select an option from the Data Key list.

l None. The data is not placed into tracks based onmetadata values.

Data Key Themetadata (protocol header) used to identify a unique session.

Available when you selectMetadata in the Session ID Source field.

Click Edit to change the selection.

Select Session ID Page

This wizard page enables you to select an element to use as a session identifier.

User Guide
Chapter 3: Virtual Services

HP Service Virtualization (3.61) Page 156 of 352



Important
information

General information about this wizard is available here: "Session ID Definition
Wizard" on page 155

Wizard
map

The Session ID Definition wizard contains:

"Define Default Session IDs Page" on page 155 > "Select Session ID Page" on the
previous page > "Define Operation Specific Session IDs Page" below > "Define
Data Format Session IDs Page" on the next page > "Define Session IDs Summary
Page" on page 159

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<Element tree> Expand the tree to display all message elements.

Search element Enter a search string to locate specific elements.

Define Operation Specific Session IDs Page

This wizard page enables you to define session identifiers at the operation level.
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Important
information

General information about this wizard is available here: "Session ID Definition
Wizard" on page 155

Wizard
map

The Session ID Definition wizard contains:

"Define Default Session IDs Page" on page 155 > "Select Session ID Page" on page
156 > "Define Operation Specific Session IDs Page" on the previous page >
"Define Data Format Session IDs Page" below > "Define Session IDs Summary
Page" on the next page

User interface elements are described below:

UI
Element Description

Operation The operations in the virtual service.

Session
ID Source

The source for identifying sessions. Options include:

l In Message. Enables you to define an element within themessage to use as a
session identifier. Select an option from the Data Key list.

l Inherited. Uses the setting that is defined at the service level.

l None. The data is not placed into tracks based on values at the operation level.

Data Key Themessage element used as the session identifier. The data key can be amessage
header or a field.

Available when you select In Message in the Session ID Source field.

Click Edit to change the selection.

Edit
Response

Enables you to select fields for response-specific data.

Delete
Response

Removes the response-specific session ID row.

Edit Data
Formats

Opens theDefine Data Format Session IDs page, enabling you to define session
identifiers per data format type. For details, see "Define Data Format Session IDs
Page" below.

Define Data Format Session IDs Page

This wizard page enables you to define session identifiers per data format type.
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Important
information

General information about this wizard is available here: "Session ID Definition
Wizard" on page 155

Wizard
map

The Session ID Definition wizard contains:

"Define Default Session IDs Page" on page 155 > "Select Session ID Page" on page
156 > "Define Operation Specific Session IDs Page" on page 157 > "Define Data
Format Session IDs Page" on the previous page > "Define Session IDs
Summary Page" below

User interface elements are described below:

UI Element
Description

Data
Format

The data formats available in the service.

Session
ID Source

The source for identifying sessions. Options include:

l In MessageEnables you to define an element within themessage to use as a
session identifier. Select an option from the Data Key list.

l Inherited. Uses the setting that is defined at the operation level.

l None. The data is not placed into tracks based on data format.

Data Key Themessage element used as the session identifier. Select a value.

Available when you select In Message in the Session ID Source field.

Click Edit to change the selection.

Define Session IDs Summary Page

This wizard page displays a summary of how Service Virtualization can organize your learned data into
tracks.
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Based on the session identifiers you have defined, Service Virtualization will create a separate track for
each unique session identifier value.

Note: Learned data is grouped into tracks after the next Learning session.

Important
information

l General information about this wizard is available here: "Session ID Definition
Wizard" on page 155

l In the event of an error, click Back to modify your settings.

Wizard
map

The Session ID Definition wizard contains:

"Define Default Session IDs Page" on page 155 > "Select Session ID Page" on page
156 > "Define Operation Specific Session IDs Page" on page 157 > "Define Data
Format Session IDs Page" on page 158 > "Define Session IDs Summary Page"
on the previous page

User interface elements are described below:

UI Element Description

Learned Data
pie chart

Displays the expected results based on current learned data.

Mapped The percentage of current learned data that can bemapped to a distinct session,
based on your session ID selections.

Not mapped The percentage of current learned data that cannot bemapped to a distinct
session, based on your session ID selections.

Finish Saves your selections. Learned data is grouped into tracks after the next Learning
session.
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Data Masking Dialog Box
This dialog box enables you to hide specific request and response data elements.

To access Use one of the following:

l In the Service Description Editor, under DataMasking, click Edit.

l In the DataModel Editor, right-click a column header and selectMask.

Important
information

l When you set or change datamasking settings, all data from associated
operations in all datamodels in the service are removed.

l In the DataModel Editor, columns that are configured for datamasking are
marked with a red hash sign (#) in the column header.

l Service Virtualizationmessage logs store raw message data that is not masked.
For details onmessage logging, see "Message Logging" on page 114.

Relevant
tasks

"How to Edit a Service Description" on page 109

See also "Service Descriptions" on page 102

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

Search
element

Search for a specific request or response element.
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UI Element Description

Algorithm Themasking option for the selected element.

None. Datamasking is not configured for the element.

Replace. Opens the Replace Algorithm Configuration dialog box, enabling you to
configure a custom algorithm for hiding the data. For details, see "Replace Algorithm
Configuration Dialog Box" below.

SHA1.Masks data using the secure hash algorithm SHA-1.

Note:When you configure a parent element, all child elements are automatically
configured with the same settings.

Parameters If you are using the Replace algorithm option, the parameters indicate thematch
pattern and replace value you defined.

To change the parameters, click the parameter link to open the Replace Algorithm
Configuration dialog box.

Tip: RIght-click in the parameter field and select Copy to copy/paste the
parameter definition to another element.

<operations
table>

Displays each operation in the service. Click to expand operations and drill down to
the specific request and response elements that you want to configure.

Replace Algorithm Configuration Dialog Box
This dialog box enables you to select or define an algorithm for replacing specified text in message
data.
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To access In the DataMasking dialog box, select a data element, and do one of the following:

l Under Algorithm, select Replace.

l For an element already configured to use the Replace function, click in the
Parameters column.

Important
information

When you set or change datamasking settings, all data from associated operations
in all datamodels in the service are removed.

Relevant
tasks

"How toModify Virtual Service Behavior" on page 210

See also "DataModel Overview" on page 201

User interface elements are described below:

UI Element Description

Replace using static value Enter a string to use to replace the strings that match your
specifications.

For example, youmight want to replace credit card data with the
following value: XXXX-XXXX-XXXX-XXXX

From File. Browse the file system to select a file. The data is
masked using the contents of the selected file.
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UI Element Description

Replace using regular
expression

Enables you to define a regular expression tomatch a particular
string of text.

You can use regular expressions in theMatch pattern andReplace
value fields.

For help on creating regular expressions, see "How to Configure
Regular Expressions" on page 231.

Match pattern Enter the string that you want to match, or click the drop-down
arrow to select a previously entered string.

Replace value The value you want to use to replace the data that matches your
Match pattern.

Enter the string that you want to use tomask the data you are
replacing.

Change all occurrences of
regular expression

Updates all elements in all datamodels in the service that are using
this regular expression for datamasking.

Test Input Enter a string to test your settings.

Test Output Displays themasked output based on the settings you defined.

Edit Metadata Dialog Box
The Edit Metadata dialog box enables you to edit metadata for the current service description.
Metadata are parameters that contain some protocol-specific information such as time stamps,
correlation information, or status codes. They are part of the protocol message, but external to the
message body, such as URL parameters, or HTTP headers.
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To access In the Service Description Editor, under Request Metadata or Response
Metadata, select Edit.

Important
information

Items displayed in gray are disabled.

Relevant tasks "How to Edit a Service Description" on page 109

See also "Service Descriptions" on page 102

User interface elements are described below:

UI
Element

Description

Enable Activate the selectedmetadata. This is the default status.

Disable Deactivate the selectedmetadata. Disabledmetatada are not available for viewing or
editing in the DataModel Editor, and values for disabledmetadata are not learned or
simulated.

Disabledmetadata are displayed in gray.

Add Opens the Add New Metadata dialog box. Enter a name and select a type for the new
metadata. The types available vary based on the protocol with which you are working.

Edit Enables you tomodify the selected item.

Delete Removes themetadata from all datamodels in the virtual service, and deletes the
metadata's related data.
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Add Data Format Dialog Box
This dialog box enables you to add a new data format to your service description. You can copy from an
existing URI space, or create a new format.

To access 1. In the Service Description Editor, in the operations pane on the left side, select
a URI space.

2. Under Request or Response Data Format, click Add.

Relevant
tasks

"How to Edit a Service Description" on page 109

See also "Service Descriptions" on page 102

"Service Description Editor" on page 152

User interface elements are described below.

UI
Element Description

URI Space Enter the path of the existing URI space you want to copy.

Data
Format

Lists supported data formats.

Type The data format types available in the schema.

Available for XML data format only.

External
File

Opens the Import XML Schema dialog box, enabling you to import a schema from an
external file.
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Simulation Overview
After a virtual service is created, you define simulation data. You can do this by manual design, or by
recording real service activity in order to learn about the requests and responses of the real service.
You can then use the recorded data to create data and performancemodels that define how the virtual
service should behave during simulation.

Before a simulation session, you can select which simulationmodels to use. You can simulate various
scenarios:

l Use both a datamodel and a performancemodel to simulate the real service. Both data and
performance are simulated, and the real service does not receive any communication.

l Turn off data simulation to let the real service respond. Only performance is simulated using one of
the performancemodels.

l Turn off performance simulation. Response times are not affected. Only data is simulated using one
of the datamodels.

l Simulate the unavailability of a service.

Youmanage the simulation process by manipulating virtual servicemodes:

l Learning mode. The virtual service works as a proxy to record and learn the behavior of a real
service. The virtual service forwards the real communication between a client and a service. In this
mode, any communication through the virtual service is added to the virtual service's simulation
models.

l Standby mode. The virtual service redirects requests to the real service, and redirects responses
from the real service back to the client. The virtual service is not learning, and not simulating.

l Simulating mode. The virtual service responds to client requests according to learned behavior.
This is themain use of the virtual service, and themode you use for testing purposes.

During learning or simulating sessions, you canmonitor service behavior.

For more details on how simulation works, see "The Simulation Process" on page 208.

For task details, see "How to Run Simulations" below.

How to Run Simulations
This task describes how to run simulations using your virtual services.

l This task is part of a higher-level task. For details, see "How to Use Service Virtualization" on
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page 23.

l To learnmore about virtual services, see "Simulation Overview" on the previous page.

l If a service is locked by another client, a message displays in the Virtual Service Editor. For
details, see "Service Locking" on page 171.

This task includes the following steps:

"Prerequisites" below

"Reconfigure clients" below

"Define simulation data" below

"Learn real service behavior" below

"Select simulationmodels" on the next page

"Simulate" on the next page

"Monitor all services" on the next page

"Review message logs" on page 171

"Optional: Adjust simulationmodels" on page 171

1. Prerequisites

Create and configure virtual services.

2. Reconfigure clients

Reconfigure your client to use the virtual service endpoints in place of the real service endpoints.
This is required in cases where Service Virtualization can only perform intrusive virtualization.

3. Define simulation data

You can define the data from scratch in the DataModel Editor. For task details, see "How to
Modify Virtual Service Behavior" on page 210.

Alternatively, you can define the data by recording real service behavior, as described in the next
step.

4. Learn real service behavior

Record the behavior of the real service in order to see the actual requests and responses.

Note: You can learn and simulate both one-way (request only) and two-way (request-
response) communication within a single operation in your datamodel. This functionality is
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available for messaging protocols IBM®WebSphere® MQ, Oracle® AQ, JMS, and
SAP IDoc.

a. In the Virtual Service Editor, click Learn to record real service activity. The information is
saved in the virtual service's data and performancemodels. For user interface details, see
"Virtual Service Editor" on page 144.

Alternatively, you can choose to save only some of the collected data. Click the Learn drop-
down arrow to select a simulationmodel to which you want to save recorded data.

b. Run the application communicating with the real service. Service calls are recorded.

c. To view the learned data after recording, open the DataModel Editor and click the Learned
Data rule. For user interface details, see "DataModel Editor" on page 240.

5. Select simulation models

In the Virtual Service Editor, select a datamodel and a performancemodel to use during
simulation.

To simulate the unavailability of a service, select theOffline performancemodel.

You can also choose to use just one of the simulationmodels, by selectingNone for either the
data or performancemodel.

n If you select a performancemodel only, the real service responds and only the performance is
simulated.

n If you select a datamodel only, response times are not affected, and only data is simulated.

6. Simulate

a. In the Virtual Service Editor, click Simulate to place the virtual service in Simulatingmode.
The virtual service is ready to respond to client requests . The real service does not receive
any communication.

b. Run your client application. The virtual service responds to requests, and returns responses
based on its associated simulationmodels.

c. When you want to complete the simulation session, click Stop to move the virtual service into
Standby mode. Client requests are then answered by the real service.

7. Monitor all services

You canmonitor virtual service activity in the following ways:

n Runtime View. View and control all of the virtual services in your project. During a learning or
simulation session, the Runtime View provides an overview of the communication through the
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virtual services. From themainmenu, select View > Runtime View.

n Problem List. View errors, warnings, and informational messages about events that occurred
during the application or server run. From themainmenu, select View > Problem List.

n Service Administration. View andmanage all services from configured servers, without
opening individual projects. On the Start Page, click Service Administration.

Alternatively, from themainmenu, select View > Service Administration.

n Service Virtualization Management. View andmanage services frommultiple Service
Virtualization projects and servers in a web browser, without opening the projects. For details,
see "Service VirtualizationManagement" on page 179.

8. Review message logs

To troubleshoot problems, view specific request and response data, or examine additional protocol
data, you can review themessage logs for your service. For detail, see "Message Logging" on
page 114.

9. Optional: Adjust simulation models

You canmake adjustments to the data and performancemodels associated with your virtual
services. For example, if you are simulating a service based on learned data, youmay need to
customize some aspect of the virtual service behavior that is not addressed. For details, see
"How toModify Virtual Service Behavior" on page 210 and "How toModify Virtual Service
Performance" on page 283.

Service Locking
If a service is locked by another client, the followingmessage displays in the Virtual Service Editor:

The Service Virtualization Designer or a test emanating from HP LoadRunner may need to know that
they own a virtual service, or that virtual service is available, in order to prevent conflicts. They may
also need to know who the present owner of a service is, as a service can be owned by only one client
at a time. If a service is locked by the owner, other clients can see who the owner is, as each client has
a unique “client ID”.

When a service is locked, its configuration and all of its data and performancemodels are also locked.
The owner of the service canmodify the service and its model, but other clients cannot. If a user tries to
modify the service or its model, a message displays indicating that the service is locked, and
specifying which client is the owner of the service. If a Designer or a test is the owner, then
modification is permitted.

To unlock a locked service:
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If a technical problem occurs or a test runs too long, you can force an unlock in the Service
Virtualization Designer. To unlock the service, from the Runtime View or Service Administration, under
More Actions, select Unlock.

Note: No changes are allowed to a service and its models during the learning process. This
process must be completed regardless of the owner of the virtual service. Unlock is not available
during this time.

Simulation User Interface
This section includes:

Runtime View 173

Problem List 174

Service Administration 175
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Runtime View
The Runtime View enables you to view and control all of the virtual services in your project. During a
learning or simulation session, the Runtime View provides an overview of the communication through
the virtual services.

To access From themainmenu, select View > Runtime View.

Important
information

The context menu enables you to show/hide data columns on the page. Right-
click to view.

Relevant tasks "How to Run Simulations" on page 168

See also "Virtual Service Overview" on page 97

User interface elements are described below.

UI Element Description

Puts the selected service into LearningMode. Any communication through the
Virtual Service is added to the SimulationModel in this mode.

Use the drop down arrow to select whichmodels to update:

l Data & Performance (default)

l DataModel

l PerformanceModel

Starts the simulation according to the simulationmodels selected in the Virtual
Service Editor.

If the service was in Learningmode, Service Virtualization first finishes the learning
session and adds any data learned in the session to the SimulationModel.

Puts the service into Standby Mode with the option of maintaining or disposing of
learned data.
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UI Element Description

Includes the following:

Info. Opens the Runtime Report to display current information about the service.

Unlock. Unlocks the selected service. For more details, see "Service Locking" on
page 171.

Undeploy. Undeploys the selected service.

All Enables you to filter the displayed services according to virtual servicemode.

Click the arrow to display the filter options.

Data Model The datamodel currently in use for the selected service.

Click the name link to open themodel in the DataModel Editor.

Endpoints The URL of the real service.

Info Located under theMore Actions menu. Opens the Runtime Report to display current
information about the service.

Messages
(Unique)

The number of messages and uniquemessages passed through the virtual service
during the current learning or simulation session.

Performance
Model

The performancemodel currently in use for the selected service.

Click the name link to open themodel in the PerformanceModel Editor.

Project The project to which the service belongs.

Server The server running the selected service.

Status The number of problems that occurred.

Undeploy Located under theMore Actions menu. Undeploys the selected service.

Unlock Located under theMore Actions menu. Unlocks the selected service. For more
details, see "Service Locking" on page 171.

Virtual
Service

Displays the list of all services from configured servers. Click on a service name to
open the service in the Virtual Service Editor.

Problem List
The Problem List displays errors, warnings, and informational messages about events that occurred
during the application or server run. The source of problems can be either runtime errors in the
application, or a problem occurring during a service lifecycle. For example, during deployment, or while
in Standby, Learning, or Simulatingmodes.
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To access From themainmenu, select View > Problem List.

Important
information

By default, the information displayed is automatically filtered according to the editor
that is open. For example, if you open the Virtual Service Editor, the Problem List
displays problems related to the service. If you open the DataModel Editor, problems
are filtered for issues related to the datamodel.

Relevant
tasks

"How to Run Simulations" on page 168

See also "Simulation Overview" on page 168

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<message
filter>

Enables you to filter themessages according to type: Errors,Warnings,
Information.

By default, only Errors andWarnings are displayed. Click the arrow to change the
filter options.

Type The problem category and number of occurrences.

Fix It If the problem can be resolved with user interaction, a link is displayed. The link
connects you to the part of the application that may be the source of the problem.

Source
Service
Filter

Enables you to filter for a specific service call or display All Sources.

Description A description of the problem.

Time Time and date that the problem occurred.

Service Administration
This page enables you to view andmanage all services from configured servers, without opening
individual projects. All virtual services are displayed with their statues, associatedmodels, and server
locations. You can change selections for simulationmodels in use, and view the server on which a
service is deployed.
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To access From the Start Page, click Service Administration.

Important
information

The context menu enables you to show/hide data columns on the page. Right-
click to view.

Relevant tasks "How to Run Simulations" on page 168

See also "Virtual Service Overview" on page 97

User interface elements are described below:

UI Element Description

Not enabled in Service Administration. To place services in Learningmode, you
must use the Virtual Service Editor in an open project.

Starts the simulation according to the selected simulationmodels. You can choose
different models using the DataModel and PerformanceModel columns.

If the service was in Learningmode, Service Virtualization first finishes the learning
session and adds any data learned in the session to the SimulationModel.

Puts the service into Standby Mode with the option of maintaining or disposing of
learned data.
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UI Element Description

Includes the following:

Manage Servers. Opens the Servers tab of the Options dialog box, enabling you to
add and delete servers.

Hot Swap Performance Model. Enables you to select a different performance
model when the virtual service is in Simulatingmode, without redeploying virtual
service data and restarting simulation. For more details, see "Virtual Service Editor"
on page 144.

Select themodel you want to switch to, and from the Actions menu, click Hot Swap
Performance Model.

Any unsent messages waiting to be processed according to the response time of the
current performancemodel are sent immediately. The new model is used for any
subsequent requests.

To switch the performancemodel during simulation:

l neither the current model or themodel you are selecting can be theOffline
performancemodel.

l you cannot switch to theMaximal Performancemodel if you want to also use
theReal Service datamodel.

Info. Opens the Runtime Report to display current information about the service.

Unlock. Unlocks the selected service. For more details, see "Service Locking" on
page 171.

Undeploy. Undeploys the selected service.

All Enables you to filter the displayed services according to virtual servicemode.

Click the arrow to display the filter options.

Data Model The datamodel currently in use for the selected service. Click the arrow to select a
different datamodel.

When you change amodel, an asterisk is displayed next to themodel name,
indicating that the change was not yet applied. To apply the new model, youmust
redeploy the relevant service by changing its mode to Standby or Simulate.

Endpoints The URL of the real service.

Info Located under theMore Actions menu. Opens the Runtime Report to display current
information about the service.

Manage
Servers

Located under theMore Actions menu. Opens the Servers tab of the Options dialog
box, enabling you to add and delete servers.
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UI Element Description

Messages
(Unique)

The number of messages and uniquemessages passed through the virtual service
during the current learning or simulation session.

Performance
Model

The performancemodel currently in use for the selected service. Click the arrow to
select a different performancemodel.

When you change amodel, an asterisk is displayed next to themodel name,
indicating that the change was not yet applied. To apply the new model, youmust
redeploy the relevant service by changing its mode to Standby or Simulate.

Project The project to which the service belongs.

Server The server running the selected service.

Status The number of problems that occurred. Click to display details in the Problems List.

Undeploy Located under theMore Actions menu. Undeploys the selected service.

Unlock Located under theMore Actions menu. Unlocks the selected service. For more
details, see "Service Locking" on page 171.

View Enables you to filter the displayed services according to server. Click the arrow to
display the filter options.

Virtual
Service

Displays the list of all services from configured servers. Click on a service name to
open the service in the Virtual Service Editor.
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Chapter 5: Service Virtualization
Management
This chapter includes:

Service VirtualizationManagement Overview 180

How to Get Started Using Service VirtualizationManagement 180
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Service Virtualization Management Overview
Service VirtualizationManagement enables you to view and control services frommultiple Service
Virtualization projects and servers in one location, without opening the projects. You can:

l View a summary of all service activity on a server.
l Start and stop simulations.
l Undeploy services.
l Deploy additional virtualization projects and services located in HP Application Lifecycle

Management (ALM) or in the file system.
l View server health and utilization statistics.

After you create and configure virtual services in the Service Virtualization Designer, the services can
be deployed on any Service Virtualization Server. Service VirtualizationManagement provides a
convenient method for allowing others to access andmanage virtual services deployed on any Service
Virtualization Server. For example, anyone performing testing can work with the virtual services from a
browser window, with no additional installation or configuration.
In addition, Service VirtualizationManagement enables you to consume virtual services that are stored
in a network location. You can download virtual services to your Service Virtualization Server, without
the need to install the Service Virtualization Designer.

Note:

l When you are working with a secured Service Virtualization Server, the actions available to
you and the information displayed vary, based on your user access permissions. For example,
a user who is not assigned to any of the Service Virtualization user groups cannot view any
agent data or any services deployed on the server. For details on the Service Virtualization user
groups, see theHP Service Virtualization Installation Guide.

l The Service Virtualization service, Server, andManagement versions must match. If the
service/project was created in an earlier version, open it in the Designer to upgrade the project
to the new version.

For task details, see "How to Get Started Using Service VirtualizationManagement" below.

How to Get Started Using Service Virtualization
Management
This task describes how to start working with the Service VirtualizationManagement interface.

To learnmore about Service VirtualizationManagement, see "Service VirtualizationManagement
Overview" above.
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This section includes:

l "Prerequisites" below

l "Start/stop the Service VirtualizationManagement service" below

l "Open Service VirtualizationManagement" on the next page

l "Manage virtual services in Service VirtualizationManagement" on the next page

l "Troubleshoot" on the next page

Prerequisites

l To log in to Service VirtualizationManagement, youmust be amember of theSVM Users group on
the Service Virtualization Server machine. For details on the Service Virtualization user groups, see
theHP Service Virtualization Installation Guide.

l Make sure you are using a supported browser:

n Microsoft Internet Explorer 8, 9, 10, and 11

n Mozilla Firefox

n Google Chrome

n Apple Safari

Note: For themost up-to-date list of supported browsers and versions, refer to the support
matrix on the HP Software Support site at: http://h20230.www2.hp.com/sc/support_
matrices.jsp, or contact support.

l Make sure that the Service Virtualization Server is running.

Start/stop the Service Virtualization Management service

1. On the Service Virtualization Server machine, from theWindows Start menu, select All
Programs > HP Software > HP Service Virtualization > Server 3.61 > Start Services of HP
Service Virtualization Server.

This option starts both the Service Virtualization Server service and the Service Virtualization
Management service.

2. To stop the service, from theWindows Start menu, select All Programs > HP Software > HP
Service Virtualization > Server 3.61 > Stop Services of HP Service Virtualization Server.
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This option stops both the Service Virtualization Server service and the Service Virtualization
Management service.

Open Service Virtualization Management

Open a browser window and enter one of the following URLs:

l The Service Virtualization Management URL:

https://<Service Virtualization Server IP or hostname>:<Service VirtualizationManagement
port>

By default, the Service VirtualizationManagement port is 6086.

l The Service Virtualization Server URL:

<Service Virtualization Server IP or hostname>:<HTTP/HTTPS port number>/management

For more details on Service Virtualization network ports, see theHP Service Virtualization Installation
Guide.

Manage virtual services in Service Virtualization Management

For details on working with Service VirtualizationManagement, see the online help inside Service
VirtualizationManagement. In the upper-right corner, click the down arrow and select Help.

Troubleshoot

If an issue arises, review the web server and proxy logs, located in%ProgramData%\Hewlett-
Packard\HP Service Virtualization Server\ManagementInterface\logs.
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Chapter 6: Command Line Virtual Service
Management
This chapter includes:

Command LineManagement Overview 184

How toManage Virtual Services from the Command Line 185
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Command Line Management Overview
You canmanage virtual services deployed on a Service Virtualization Server using the SVConfigurator
command line tool.

SVConfigurator is Java-based and can be used by bothWindows and Unix/Linux operating systems.

Working from a command prompt, you can:

l deploy virtual services to any Service Virtualization Server

l change the runtimemode of a virtual service

l view virtual service details, such as service name, ID, mode, deployment state, and data and
performancemodels

l switch the performancemodel during simulation

l list all deployed virtual services on s Service Virtualization Server

l list the services in a project

l unlock a virtual service locked by another user

l undeploy services

Note: You can also use SVConfigurator as an Apache Ant™ plugin. For details, refer to the
documentation, located in the following locations:

l <Service Virtualization installation folder>\Tools\SVConfigurator\doc\AntTasks\index.html

l In theHP.SV.SVConfigurator.jar file, located in the <Service Virtualization installation
folder>\Tools\SVConfigurator\bin folder.

By default, the Service Virtualization installation folder is located in:

l Server:C:\Program Files\HP\HP Service Virtualization Server

l Designer:C:\Program Files (x86)\HP\HP Service Virtualization Designer

For task details, see "How toManage Virtual Services from the Command Line" on the next page.
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How to Manage Virtual Services from the
Command Line
This task describes how tomanage virtual services deployed on a Service Virtualization Server from
the command line. You can list, view, deploy, unlock, or change themode of the services.

l To learnmore about managing virtual services from the command line, see "Command Line
Management Overview" on the previous page.

l Note: Parameter values may not include spaces. If a value includes spaces, youmust put it in
quotationmarks. For example, the path "C:\Users\Default\Documents\HP Service
Virtualization\Projects\ShoppingCart Virtualization Project\ShoppingCart Virtualization
Project\ShoppingCart Virtualization Project.vproj".

l Log file:When you run SVConfigurator, a log file is created in yourWindows user profile
directory.

This section includes:

l "Prerequisites" below

l "Deploy services" on the next page

l "Change servicemode" on page 187

l "Switch performancemodels during simulation" on page 189

l "View service details" on page 190

l "List deployed services" on page 192

l "List services in a project" on page 193

l "Unlock services" on page 194

l "Undeploy services" on page 195

Prerequisites

Towork with an encrypted project, youmust install Java Cryptography Extension (JCE) Unlimited
Strength Jurisdiction. Select one of the following, based on the Java version with which you are
working:

l For JDK 1.6: http://www.oracle.com/technetwork/java/javase/downloads/jce-6-download-
429243.html
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l For JDK 1.7: http://www.oracle.com/technetwork/java/javase/downloads/jce-7-download-
432124.html

Deploy services

Deploy or undeploy a virtualization project, or a single service from the project to the Service
Virtualization Server.

1. Do one of the following:

n On the Service Virtualization Server, open a command prompt. Navigate to the \bin folder under
the Service Virtualization Server installation folder. By default, C:\Program Files\HP\HP
Service Virtualization Server\Tools\SVConfigurator\bin\.

n On the Service Virtualization Designer machine, open a command prompt. Navigate to the \bin
folder under the Designer installation folder. By default, C:\Program Files (x86)\HP\HP Service
Virtualization Designer\Tools\SVConfigurator\bin\.

2. RunSVConfigurator.cmd DEPLOY [options] <project file> at the command line, using the
following options:

Note: For Linux, useSVConfigurator.sh.

Option Description

Required
parameters

<project file> Path to a project file (.vproj or .vproja) whose services you want to deploy on
the server.

Optional
parameters

-w
or
--project-
password

If the project is encrypted, specifies a password to decrypt the project
content.

-f
or
--force

Force mode. If the service to be deployed is locked, the command
automatically unlocks it. It is then automatically locked by SVConfigurator.
Use caution with this option as you can delete another user’s data.

-u
or
--undeploy

Undeploys the project or service from the server.
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Option Description

-s <svc>
or
--service
<svc>

Deploys only the specified service. You can specify a service by its name or
ID.

Tip:Use the List orView commands to find a service ID.

-url <url>
or
--mgmt-url
<url>

URL of the server’s management endpoint.

-usr <user>
or
--username
<user>

Username for the server’s management endpoint.

-pwd <pwd>
or
--password
<pwd>

Password for the server’s management endpoint.

Change service mode

Change the runtimemode of a service on the Service Virtualization Server to Learning, Simulating, or
StandBy mode.

1. Do one of the following:

n On the Service Virtualization Server, open a command prompt. Navigate to the \bin folder under
the Service Virtualization Server installation folder. By default, C:\Program Files\HP\HP
Service Virtualization Server\Tools\SVConfigurator\bin\.

n On the Service Virtualization Designer machine, open a command prompt. Navigate to the \bin
folder under the Designer installation folder. By default, C:\Program Files (x86)\HP\HP Service
Virtualization Designer\Tools\SVConfigurator\bin\.

2. RunSVConfigurator.cmd CHANGEMODE [options] <service identification> <service
mode> at the command line, using the following options:

Note: For Linux, useSVConfigurator.sh.

Option Description

Required
parameters
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Option Description

<service
identification>

Identification of the service you want to view. You can use either the name or
ID of the service.

If there is more than one service with the same name on the server, you have
to either specify the project file where the service is located (using the
optional –p parameter below), or identify the service by its ID.

Tip:Use the List command to find a service ID.

<service
mode>

Themode you want to switch the service to.

Available options: SIMULATING, STAND_BY

Optional
parameters

-f
or
--force

Force mode. If the service to be deployed is locked, the commandwill
automatically unlock it. It is then automatically locked by SVConfigurator.
Use caution with this option as you can delete another user’s data.

-dm <model>
or
--data-model
<model>

The datamodel to be used, specified by its name or ID.

Youmust specify this parameter for Learning and Simulationmodes.

Tip:Use theView command to find the service's datamodels.

-pm <model>
or
--perf-model
<model>

The performancemodel to use, specified by its name or ID.

Youmust specify this parameter for Learning and Simulationmodes.

Tip:Use theView command to see the service's performancemodels.

-p <source_
path>
or
--project
<source_path>

Project file (.vproj or .vproja). Specify the project file in order to differentiate
the services on the server. If there is more than one service with the same
name but in different projects, and you want to identify the service by name,
youmust specify the project file.

-w
or
--project-
password

If the project is encrypted, specifies a password to decrypt the project
content.
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Option Description

-url <url>
or
--mgmt-url
<url>

URL of the server’s management endpoint.

-usr <user>
or
--username
<user>

Username for the server’s management endpoint.

-pwd <pwd>
or
--password
<pwd>

Password for the server’s management endpoint.

Switch performance models during simulation

Select a different performancemodel when the virtual service is in Simulatingmode, without
redeploying virtual service data and restarting simulation. For more details on hotswap, see "Virtual
Service Editor" on page 144.

1. Do one of the following:

n On the Service Virtualization Server, open a command prompt. Navigate to the \bin folder under
the Service Virtualization Server installation folder. By default, C:\Program Files\HP\HP
Service Virtualization Server\Tools\SVConfigurator\bin\.

n On the Service Virtualization Designer machine, open a command prompt. Navigate to the \bin
folder under the Designer installation folder. By default, C:\Program Files (x86)\HP\HP Service
Virtualization Designer\Tools\SVConfigurator\bin\.

2. RunSVConfigurator.cmd HOTSWAP [options] <service identification> at the command line,
using the following options:

Note: For Linux, useSVConfigurator.sh.

Option Description

Required
parameters
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Option Description

<service
identification>

Identification of the service whose performancemodel you want to change.
You can use either the name or ID of the service.

If there is more than one service with the same name on the server, you have
to either specify the project file where the service is located (using the
optional –p parameter below), or identify the service by its ID.

Tip:Use the List command to find a service ID.

Optional
parameters

-f
or
--force

Force mode. If the service to be deployed is locked, the commandwill
automatically unlock it. It is then automatically locked by SVConfigurator.
Use caution with this option as you can delete another user’s data.

-pm <model>
or
--perf-model
<model>

The performancemodel to use, specified by its name or ID.

Youmust specify this parameter for Learning and Simulationmodes.

Tip:Use theView command to see the service's performancemodels.

-pwd <pwd>
or
--password
<pwd>

Password for the server’s management endpoint.

-url <url>
or
--mgmt-url
<url>

URL of the server’s management endpoint.

-usr <user>
or
--username
<user>

Username for the server’s management endpoint.

View service details

View information about a service deployed on the Service Virtualization Server, such as service name,
ID, mode, deployment state, and data and performancemodels.

1. Do one of the following:

n On the Service Virtualization Server, open a command prompt. Navigate to the \bin folder under
the Service Virtualization Server installation folder. By default, C:\Program Files\HP\HP
Service Virtualization Server\Tools\SVConfigurator\bin\.
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n On the Service Virtualization Designer machine, open a command prompt. Navigate to the \bin
folder under the Designer installation folder. By default, C:\Program Files (x86)\HP\HP Service
Virtualization Designer\Tools\SVConfigurator\bin\.

2. RunSVConfigurator.cmd VIEW [options] <service identification> at the command line, using
the following options:

Note: For Linux, useSVConfigurator.sh.

Option Description

Required
parameters

<service
identification>

Identification of the service you want to view. You can use either the name or
ID of the service.

If there is more than one service with the same name on the server, you have
to either specify the project file where the service is located (using the
optional –p parameter below), or identify the service by its ID.

Tip:Use the List command to find a service ID.

Optional
parameters

-r
or
--report

Displays the runtime report for the service.

-p <source_
path>
or
--project
<source_path>

Project file (.vproj or .vproja). Specify the project file in order to differentiate
the services on the server. If there is more than one service with the same
name but in different projects, and you want to identify the service by name,
youmust specify the project file.

-w
or
--project-
password

If the project is encrypted, specifies a password to decrypt the project
content.

-url <url>
or
--mgmt-url
<url>

URL of the server’s management endpoint.ser
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Option Description

-usr <user>
or
--username
<user>

Username for the server’s management endpoint.

-pwd <pwd>
or
--password
<pwd>

Password for the server’s management endpoint.

List deployed services

List the services deployed on the Service Virtualization Server, and view basic service information,
such as service name, mode (learning, simulating, standby, offline), and ID.

1. Do one of the following:

n On the Service Virtualization Server, open a command prompt. Navigate to the \bin folder under
the Service Virtualization Server installation folder. By default, C:\Program Files\HP\HP
Service Virtualization Server\Tools\SVConfigurator\bin\.

n On the Service Virtualization Designer machine, open a command prompt. Navigate to the \bin
folder under the Designer installation folder. By default, C:\Program Files (x86)\HP\HP Service
Virtualization Designer\Tools\SVConfigurator\bin\.

2. RunSVConfigurator.cmd LIST [options] at the command line, using the following optional
parameters:

Note: For Linux, useSVConfigurator.sh.

Option Description

-p <source_
path>
or
--project
<source_path>

Project file (.vproj or .vproja). Specify the project file in order to list only the
deployed services in the specified project.

-w
or
--project-
password

If the project is encrypted, specifies a password to decrypt the project
content.
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Option Description

-url <url>
or
--mgmt-url
<url>

URL of the server’s management endpoint.

-usr <user>
or
--username
<user>

Username for the server’s management endpoint.

-pwd <pwd>
or
--password
<pwd>

Password for the server’s management endpoint.

List services in a project

List the services in a project file.

1. Do one of the following:

n On the Service Virtualization Server, open a command prompt. Navigate to the \bin folder under
the Service Virtualization Server installation folder. By default, C:\Program Files\HP\HP
Service Virtualization Server\Tools\SVConfigurator\bin\.

n On the Service Virtualization Designer machine, open a command prompt. Navigate to the \bin
folder under the Designer installation folder. By default, C:\Program Files (x86)\HP\HP Service
Virtualization Designer\Tools\SVConfigurator\bin\.

2. RunSVConfigurator.cmd LISTPROJECT [options] <project file> at the command line, using
the following optional parameters:

Note: For Linux, useSVConfigurator.sh.

Option Description

Required
parameters

<project file> Path to a project file (.vproj or .vproja) whose contents you want to view.

Optional
parameters
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Option Description

-w
or
--project-
password

If the project is encrypted, specifies a password to decrypt the project
content.

Unlock services

Unlock a service deployed on the Service Virtualization Server that is locked by another user. You can
then lock it by your client.

1. Do one of the following:

n On the Service Virtualization Server, open a command prompt. Navigate to the \bin folder under
the Service Virtualization Server installation folder. By default, C:\Program Files\HP\HP
Service Virtualization Server\Tools\SVConfigurator\bin\.

n On the Service Virtualization Designer machine, open a command prompt. Navigate to the \bin
folder under the Designer installation folder. By default, C:\Program Files (x86)\HP\HP Service
Virtualization Designer\Tools\SVConfigurator\bin\.

2. RunSVConfigurator.cmd UNLOCK [options] <service_identification> at the command line,
using the following options:

Option Description

Required
parameters

<service
identification>

Identification of the service you want to unlock. You can use either the name
or ID of the service.

If there is more than one service with the same name on the server, you have
to either specify the project file where the service is located (using the
optional –p parameter below), or identify the service by its ID.

Tip:Use the List orView commands to find a service ID.

Optional
parameters
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Option Description

-p <source_
path>
or
--project
<source_path>

Project file (.vproj or .vproja). Specify the project file in order to differentiate
the services on the server. If there is more than one service with the same
name but in different projects, and you want to identify the service by name,
youmust specify the project file.

-l
or
--lock

Locks the service by your client lock immediately after unlocking.

-w
or
--project-
password

If the project is encrypted, specifies a password to decrypt the project
content.

-url <url>
or
--mgmt-url
<url>

URL of the server’s management endpoint.

-usr <user>
or
--username
<user>

Username for the server’s management endpoint.

-pwd <pwd>
or
--password
<pwd>

Password for the server’s management endpoint.

Undeploy services

Undeploy a virtual service or project from the Service Virtualization Server.

1. Do one of the following:

n On the Service Virtualization Server, open a command prompt. Navigate to the \bin folder under
the Service Virtualization Server installation folder. By default, C:\Program Files\HP\HP
Service Virtualization Server\Tools\SVConfigurator\bin\.

n On the Service Virtualization Designer machine, open a command prompt. Navigate to the \bin
folder under the Designer installation folder. By default, C:\Program Files (x86)\HP\HP Service
Virtualization Designer\Tools\SVConfigurator\bin\.

2. RunSVConfigurator.cmd UNDEPLOY [options] at the command line, using the following
optional parameters:
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Option Description

Optional
parameters

-f
or
--force

Force mode. If the service you want to undeploy is locked, the command
automatically unlocks it. It is then automatically locked by SVConfigurator.
Use caution with this option as you can delete another user’s data.

-p <source_
path>
or
--project
<source_path>

Project file (.vproj or .vproja). Specify the project file containing services
that you want to undeploy.

-pwd <pwd>
or
--password
<pwd>

Password for the server’s management endpoint.

-s <svc>
or
--service <svc>

Undeploys only the specified service. You can specify a service by its name
or ID.

Tip:Use the List orView commands to find a service ID.

-url <url>
or
--mgmt-url
<url>

URL of the server’s management endpoint.

-usr <user>
or
--username
<user>

Username for the server’s management endpoint.

-w
or
--project-
password

If the project is encrypted, specifies a password to decrypt the project
content.
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Chapter 7: Simulation Modeling
This chapter includes:
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How toManage SimulationModels 198
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Simulation Modeling Overview
Simulationmodels define the functional and performance behavior that the virtual service supplies
during simulation. You canmanually customize simulationmodels, or put the virtual service in Learning
mode to record real service behavior and performance. This learned data is then added to the virtual
service's models, for use during simulation.

When you create a virtual service, Service Virtualization creates a datamodel and a performance
model, and links them to the virtual service. Thesemodels serve as the default models for learning and
simulation sessions. You can associate each virtual service with multiple data and performance
models. Prior to a learning or simulation session, you can select which data and performancemodels to
use.

l Data Model

The DataModel enables you to record actual requests and responses for a real service and then
use this data for simulation using a virtual service. You can create and customize the datamodel to
meet your needs. You can use recorded data as a basis for your datamodel, and also add new
learned data, add service calls, andmodel stateful behavior to simulate a service where the order of
requests is important. You can also add custom data, or add data from an external data source. This
enables you tomodel the interaction between the service under test and the simulated service to
meet many integration test cases. For details, see "DataModel Overview" on page 201.

l Performance Model

The PerformanceModel enables you to record the performance for a real service and then use this
as amodel for a virtual service. You can customize the performance criteria of themodel to meet
many performance use cases. For details, see "PerformanceModel Overview" on page 282.

For task details, see "How toManage SimulationModels" below.

How to Manage Simulation Models
This task describes how tomanage simulationmodels in your virtualization project.

l This task is part of a higher-level task. For details, see "How to Use Service Virtualization" on
page 23.

l To learnmore about simulationmodels, see "SimulationModeling Overview" above.

Create a simulation model

By default, each virtual service is associated with one datamodel and one performancemodel, which
are created together with the virtual service. You can create additional models and associate them with
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a virtual service.

l To add a new simulationmodel, in the Virtual Service Editor, under SimulationModels, click Add.

l To create a new simulationmodel by copying an existingmodel, select amodel and click
Duplicate.

For user interface details, see "Virtual Service Editor" on page 144.

Edit a simulation model

In the Virtual Service Editor, under SimulationModels, select themodel you want to edit and click Edit,
or double-click themodel to open.

Alternatively, in the Virtualization Explorer, select amodel and double-click to open it in the relevant
editor.

For user interface details, see "DataModel Editor" on page 240 and "PerformanceModel Editor" on
page 286.

For task details, see "How toModify Virtual Service Behavior" on page 210 and "How toModify Virtual
Service Performance" on page 283.
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Chapter 8: Data Modeling
This chapter includes:

DataModel Overview 201

The Simulation Process 208

How toModify Virtual Service Behavior 210

DataModel User Interface 239

FAQs: DataModel Editor 272
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Data Model Overview
The datamodel enables you to customizemessage requests and responses tomanipulate the
simulated behavior of a virtual service. Each virtual service is associated with at least one datamodel
which can contain the recorded behavior of the service and also customized data for simulation. Each
datamodel contains a set of rules defining data behavior for each operation in the service, and tracks to
determine the order of stateful behavior.

When you create a virtual service, Service Virtualization creates a datamodel associated with it. The
datamodel can be customized to set specific data rules for its individual operations.

Each virtual service can havemultiple datamodels. Prior to a Learning session, in which real service
behavior is recorded, you can select the datamodel to which you want to save the learned behavior.
After recording, you can use this datamodel to mimic real service behavior during simulation.

Data Rules

The datamodel consists of a set of data rules for each operation in the service. You can configure the
model using the Service Virtualization default rules and functions, or create your own to customize
simulated behavior.

The following types of rules are available:

l Learned Data Rule

The Learned Rule stores the requests and responses from learning sessions. In general, you do not
customize this data but youmay want to set conditions to ignore parts of the requests and
responses and add service call activity.

l Default Response Rule

The Default Response provides a custom response for each response type or data format, to apply
in cases where there is no other data, or where you want to ignore specific parts of recorded
response data. The default responses are generated automatically, but you can edit them. The
Default Response is used if no other rule matches the response data.

l Custom Rules

Custom Rules enable you tomanipulate some aspect of the simulated behavior. You can set
custom responses and service call activity to specific requests enabling you to perform various
testing use cases.

There are two types of custom rules:

n Blank rules. New, empty rules enable you to customize any element of amessage. For
example, youmay find that your learned data rule is too specific, providing you with an
incomplete response. You can create a new rule to customize one element of themessage,
enabling you to continue to use learned data for other elements.
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n Data driven rules. Data driven rules are used to bind request and response data from an
external data source. The data can then be used by multiple applications or exported from
external applications, such as HP LoadRunner or HP Unified Functional Testing. The data
source can be edited by an external application and then refreshed in the datamodel.

Data Rule Configuration

You can configure rules in the following ways:

Rule Prioritization

You can set the priority of multiple rules to determine the order in which each rule is applied during
simulation. This enables you tomeet various simulation testing use cases. Generally, rules are applied
in the following order:

1. Custom rules or external data rules. Custom rules can be used, for example, for requests that
cannot be recorded or have not yet been recorded.

They can be placed before or after the Learned Data rule.

2. The Learned Data rule, to provide typical responses and service call activity of the real service.

3. The Default Response rule, to provide a single generic response or generic parts of response data
where other rules do not apply.

You can also temporarily disable a rule. A disabled rule is not applied during simulation.

Service Call Activity

In many cases, the simulated service can call another service to perform some particular operation or
to receive some additional data. Virtual services can simulate this behavior by adding service call
activity to an operation. You can define static request data for the service call activity for any row in the
rule or copy data from the virtual service request or from the response of another service call activity. If
a called service also has a response, you can copy some response data from a service call activity to a
virtual service response.

Tracks

Another main feature of the datamodel are tracks. Tracks determine the order of the simulated service
behavior.

In many test cases, the order of requests is important because a servicemay return different
responses for the same request depending on the current state of the service. Service Virtualization
enables you to simulate this stateful behavior using tracks. Tracks enable you to construct
sequences of requests and responses in the datamodel for the service. During a simulation session,
Service Virtualizationmoves along the tracks according to test requests that match the requests in the
track and returns the appropriate response. For example, if the simulated service can return an approve
or deny response which is determined by a particular state of the service, you can determine which
response to return by specifying the sequence of requests and responses in the track.
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Import Messages

New rows can be added to a rule by learning new data, by adding a new row andmanually editing its
cells, or by importingmessages.

Importingmessages is useful in the case when it is not possible or it is difficult to learn communication
between a tested application and a simulated service directly, but it is possible to listen to the
communication and log transportedmessages via another tool. It is possible to import a request and/or
response part of themessage in the same format as it is sent via communication protocol from a
clipboard or from a file. For example, youmay have an SDK that includes samplemessages which you
can copy. If a message is imported from a file, the file may contain only the request or response part of
onemessage.

Multi Response

In addition to the simple simulation of a request-response pattern, Service Virtualization can simulate a
request-response pattern where 0 to n responses are given per request. The number of responses can
vary based on the service state. An operationmay have a one-way pattern, such as clearing a shopping
cart, or may includemultiple responses. For example, as part of an order processing update, responses
could include “order received”, “order opened”, and “order shipped”.

Service Virtualization enables both the learning and editing of multiple responses, their types, and their
service states. For performance simulation, learning and simulation is limited to the response time of
the first response. If learned data includes multiple responses, Service Virtualization looks only at the
first response time. During simulation, all responses are sent at that first response time.

These features are available on both the Service Virtualization standalone server, and the embedded
server. The supported protocols are XML and binary services overWebSphereMQ and JMS.

To learnmore about how simulation works in Service Virtualization, see "The Simulation Process"
on page 208.

For task details, see "How toModify Virtual Service Behavior" on page 210.

To learnmore, see also:

l "Rule Functions" below

l "Data Driving" on page 207

l "Simulation Preview" on page 208

Rule Functions
The datamodel is made up of rules that define the behavior of the virtual service. The rules aremade up
of rows, in which each row represents a response/request pair. Rule functions are used to define the
behavior of the responses, in order to directly impact the simulation. Functions are set on a per column,
per operation basis.
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Each rule contains the following:

l Condition functions.Mainly used to evaluate data in request columns, to determine the
appropriate response.

l Action functions. Used tomanipulate data in response columns. Action functions cannot be used
in request columns.

When the simulation is in progress, the simulator engine walks through each rule according to rule
priorities, looking for a single row in each rule that most precisely conforms to the condition functions
used. When a single data row is selected, all the action functions are applied to that row.

Example:

Suppose your scenario is to retrieve credit card data according to customer name.

l The name data is your request, and you would define it with the Is condition function.

l The credit card data is your response, and you would define it with theSet action function.

So, if the customer name is Jane Doe and her credit card number is 1234-5678-1234-5678, one row
in your rule would be as follows:

The request data is Jane Doe, where the function used = Is.

The response data uses the functionSet, which sets the response to 1234-5678-1234-5678.

There are several categories of functions in Service Virtualization:

l "Basic default functions" below

l "Array functions" on the next page

l "Dynamic data functions" on page 206

l "Custom functions" on page 206

Basic default functions

l Default condition functions:

n Is. If the incomingmessage datamatches the value of this field, Service Virtualization performs
the response action defined in this row.

n Ignore. If the incomingmessage datamatches the value of this field, Service Virtualization
ignores the data. It does not impact the simulation.

l Default action functions:
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n Set. The simulation returns the response that is listed in this field.

n Copy from. The simulation takes the value of another field and returns it as the response.

Note:

l For the Learned Data rule, request columns are defined as Is, and response columns are
defined as Set.

l In a new, custom rule, the default function for all columns is Ignore. The data in the column
does not influence the simulation in any way.

l If you type a value in a cell, the function is automatically set to Is orSet.

Array functions

The following functions are available for use when themessage includes an array data structure:

l Condition functions:

n Compare ordered. This condition is met when items in an array match and are in the same
order.This is the default condition function for arrays.

n Compare unordered. This condition is met when items in an array match, but may be in a
different order.

l Action functions:

n Replace array. Sets the response to the relevant array values. Generates array items for the
response data according to the number of array items in the rule's matching row.

n Set array items count. Enables you to define a set number of array items for the action to
create in the response.

n Copy array items count. Generates the same number of array items as are in an array that you
select. (You select the source array the sameway you select a source element for the Copy
From function.)

n Array template. Does not generate any array items in the response, but fills existing array items
with values from array items in the rule's matching row. If the rule's matching row does not
contain enough array items to fill values in all existing array items in the response, this action
uses the value of the last array item as a template for all the remaining array items in the
response.

Example:
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You can create a rule with the highest priority in the datamodel, and use theSet Array Items
Count to create a specified number of empty array items. Assign an Ignore action to the array
items so that they remain empty and another rule can overwrite their values.

Then create a lower priority rule, using theArray Template action, with aSet action on the
array items to fill in the values in the response. You can also use one of the dynamic data
functions, such as the random number generator function, to fill the values of the array items
with meaningful response data.

Dynamic data functions

You can generate dynamic data in certain elements of the responses using the Service Virtualization
data generator functions.

There are several types of dynamic data functions:

l Sequential number generator. Generates a series of increasing/decreasing numbers in a
specified format. The number increases/decreases by a predefined value with each received
request.

l Set relative date/time. Generates a date and/or time that is relative to the time of the request
arrival. For example: time of request arrival plus 2 hours and 5minutes.

l Set date/time relative to. Generates a date and/or time that is relative to a date/time that is stored
in any element of the request. For example: time stored in a certain element minus 3 days and 5
hours.

l Random number generator. Generates a random sequence of integers.

l Substring. The simulation takes a substring of a value in another field that you select, and returns it
as the response.

Custom functions

You can define custom functions tomanagemore complex conditions. These are to be used by an
advanced user aware of the complete system structure. Complex conditions can be set with structured
query language.

There are two classes of variables:

l Input ($input_*). Input variables are those present in a processing row during simulation. A more
simplified explanation of Input variables is that they are data from requests.

l Data ($data_*). Data variables represent data written in the cell.

For task details, see "How to Define Rule Functions" on page 212.

User Guide
Chapter 8: DataModeling

HP Service Virtualization (3.61) Page 206 of 352



Data Driving
To facilitate data-driven testing, you can add external data sources to your virtual services.

When you associate an external data source with a virtual service, you need to createmappings
between the data columns in the external file, and the columns/headers in your data rule. You do this by
configuring binding in the datamodel.

Array Binding

You can also bind array data. When themessage structure contains an array that needs to be data-
driven, you need to work with a properly structured Excel file. The file must contain database-like
relationships, using primary and foreign keys, which allow themapping of one row tomany. You can
create the file manually, or by exporting learned data that is in the desired format to a new Excel file.

The following example shows the relationship between a search definition and the search result. A
record in theSearchworksheet is identified via its primary key ‘id’, and referenced from theSearch
Resultworksheet via the foreign key ‘searchId’. This enables the return of two rows for a search with
id 3, or zero rows for search of id 4.

Data Format Binding

When binding to an Excel worksheet columnwhere the response can contain different data formats
(such as for the REST protocol), different response types (such as for the SOAP protocol), or a
message structure which can be considered to contain different types, you can also configure binding
for this in your datamodel.

You can configuremappings between real types or formats and cell values, and provide a default value
that is used when no value from themapping table matches. You can configure a value for each
possible type or format.

For task details, see "How toWork With External Data Sources" on page 231.
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Simulation Preview
Simulation Preview enables you to view in real time how changes in the datamodel affect your
simulation.

You can:

l Test changes.Make changes to a data rule, or to data in a row, and examine the impact on the
simulated response.

l Assess change impact.Make a change in one part of the datamodel, and examine the impact on
the simulation.

l Troubleshoot. Determine why a learned request does not match any rules in your datamodel.

For task details, see "How to Assess Change Impact" on page 237.

For user interface details, see "Simulation Preview Pane" on page 250.

The Simulation Process
During simulation, a client, such as your AUT, sends a request, and the virtual servicemust respond.
As client requests come in, Service Virtualization creates simulation responses based on the data
model defined for the virtual service.

A virtual service contains at least one datamodel, which defines the functional behavior that the virtual
service supplies during simulation. You canmanually customize datamodels, or put the virtual service
in Learningmode to record real service behavior. This learned data is then added to the virtual service's
model, for use during simulation. For more details, see "DataModel Overview" on page 201.

The datamodel includes:

l operations, as described in the virtual service description
l rules within the operations, that define data behavior for each operation in the service
l conditions, that define the specific message data that must match the rule, and
l actions, that define the virtual service response for specific requests
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Service Virtualization creates a response based on the rules in the particular operation. All rules have
exactly the same structure (data columns) and are ordered by priority, with the highest priority rule at
the top.

Each rule contains a set of condition and action functions. Service Virtualization uses condition
functions to select a data row from every rule that matches the request. As a result, at most, one data
row is selected from each rule. You define the functions you want to use for each data column.

Then, Service Virtualization uses action functions frommatching rules to formulate the response,
resulting in a response that may be compiled from parts of different rules. One part of a responsemay
come from one rule, with other parts coming from other rules. If two rules want to write to the same
column, then the rule with the higher priority, that is higher in the list, determines the response.

Service Virtualization evaluates an incoming request as follows:
See additional details below.

Examine the first rule

Service Virtualization examines the first rule in the datamodel, the highest priority rule. If the request
datamatches the conditions of one of the rows in the rule, Service Virtualization starts to compile the
response.

Start compiling the response

Service Virtualization uses thematching row to start to compile the service response, by performing
the rule's Action functions, and executing Service Call Activity.
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Perform the rule's Action functions

When the request datamatches a row in the rule, the rule's Action functions are performed (such as Set
or CopyFrom). The parts of themessage that were not yet written to, or were written by a lower priority
rule only, are filled. Data written by a rule with a lower priority may be overwritten by a rule with a higher
priority.

Execute Service Call Activity

If Service Call Activity is defined in the datamodel, and was not yet executed, and its request is fully
defined, it is executed now. The response is stored in the Service Call Activity response column.

Are there more rules in the data model?

If there are additional, lower priority rules in the datamodel, Service Virtualization continues to the next
rule, and starts the evaluation process again.

After all the rules were processed, were changes made to the response?

If at least one of the rules modified a part of the response, Service Virtualization goes over the rules
again, starting with the first, highest priority rule. If something has changed, one of the rules whichmay
not havematched the request datamay now match. This can cause a change in the response.

Send the response to the client

When there are no additional rules to evaluate, and no changes weremade to the response on the last
pass through the rules, the response is complete. The virtual service returns the response to the client.

l To learnmore about customizing virtual service behavior to meet your needs, see "Data
Model Overview" on page 201.

l For task details, see "How toModify Virtual Service Behavior" below.

How to Modify Virtual Service Behavior
This task describes how you can edit a datamodel, and customize it to meet your needs.

To learnmore about datamodels, see "DataModel Overview" on page 201.

This task includes the following steps:

l "Add data" on the next page

l "Select columns to display" on the next page
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l "Create custom rules" below

l "Add external data sources" on the next page

l Call external services

l "Preview changes" on the next page

l "Apply changes" on the next page

l "Navigating the DataModel Editor" on the next page

Add data

You can add data to your datamodel in the following ways:

l Learn Data. Put the virtual service into Learningmode to record real service behavior. When you
are finished recording, the learned data is added to the datamodel. For user interface details, see
"Virtual Service Editor" on page 144.

l Import Messages. Import existingmessages from a file, or copy/pastemessage formats into the
datamodel. For user interface details, see "Import Request/ResponseMessage Dialog Box" on
page 255.

l Enter data manually.

Select columns to display

You can specify which columns are displayed in the data table of a rule. In the DataModel Editor,
select Columns > Change Columns, or right-click a column header and select Change Columns.
For user interface details, see "Change Columns Dialog Box" on page 264.

Create custom rules

If you need tomanipulate some aspect of the simulated behavior, create a new rule.

You can create your own customized rules tomodify the responses used during simulation. One typical
use case is when you want to use learned data for simulation, but want to modify some part of the
response.

Create one of the following:

l Blank rule. Create a new, empty rule. In the DataModel Editor, click New Rule > Blank Rule.

l Data driven rule. Create a new rule using an external file as a data source. See the next step on
adding external data sources.

For details on configuring the rules, see "How to Define Rule Functions" on the next page.
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Add external data sources

You can add additional data from external data sources to a datamodel for testing purposes. The
supported format for this data is Microsoft Excel documents (.xls, .xlsx).

In the DataModel Editor, click New Rule > Data Driven Rule. Fill in the details. For user interface
details, see "New Data Driven Rule Dialog Box" on page 258.

For more details on working with external data sources, see "How toWork With External Data
Sources" on page 231.

Call external services

You can configure a virtual service to call external services.

Note: Only SOAP and XML over HTTP service call activities are supported.

1. In the DataModel Editor, select the operation from which you want to call the external service.

2. Click Activity > Import Activities.

For details, see "How to Call External Services" on page 235.

Preview changes

You can view in real time how changes in the datamodel are affecting your simulation. In the Data
Model Editor, select a row, and then select View Options > Simulation Preview.

The Simulation Preview pane displays a simulation of amessage whose request matches the currently
selectedmessage in the DataModel Editor table. Themessage is passed to the simulation engine and
the result is displayed in the response section.

For user interface details, see "Simulation Preview Pane" on page 250.

Apply changes

To apply changes, youmust restart your simulation. In the DataModel Editor, click Restart
Simulation.

Navigating the Data Model Editor

Formore actions you can perform in the DataModel Editor, see "DataModel Editor Context Menus" on
page 246.

For additional tips on working in the DataModel Editor, see "FAQs: DataModel Editor" on page 272.

How to Define Rule Functions
This task describes how to define rule functions to impact virtual service behavior.
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To learnmore about functions, see "Rule Functions" on page 203.

This task includes the following:

l "Select a function" below

l "Create a new, custom function" on the next page

l "Preview your changes" on the next page

Select a function

1. In the DataModel Editor, expand a rule.

2. Click inside the function field (fx) for a column and select a function. If the function row is not
displayed, from the View Options menu, select Functions.

3. Dynamic Data Functions:
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a. Click inside the function field (fx) of a response column and select a function.

Note: Dynamic data functions are available for lowest level headers only. Complex
headers that include lower level headers under them are displayed in italic text (header).
To display lower level headers, double-click the column header.

b. Configure the output format for the function. For details on configuring dynamic data functions,
see "How to Configure Dynamic Data Functions" on the next page.

Create a new, custom function

1. In the DataModel Editor, expand a rule.

2. Click inside the function field (fx) for a column and select New f(x). For user interface details, see
"New/Edit Function Dialog Box" on page 263.

Custom Functions:Service Virtualization provides a number of pre-defined variables that you
can use when creating and configuring custom functions. For details, see "How to Define Custom
Functions" on page 230.

Preview your changes

Simulation Preview displays in real time how changes in the datamodel are affecting the simulation.

In the DataModel Editor, select View Options > Simulation Preview. The Simulation Preview pane
displays a simulation of amessage whose request matches the currently selectedmessage in the
DataModel Editor. Themessage is passed to the simulation engine and the result is displayed in the
response section.
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How to Configure Dynamic Data Functions
This task describes how to configure data generator functions.

Note: To learnmore about functions, see "Rule Functions" on page 203.

This section includes:

How to Configure the Sequential Number Generator Function 215

How to Configure the Random Number Generator Function 220

How to Configure the Date/Time Functions 224

How to Configure the Substring Function 228

How to Configure the Sequential Number Generator Function

This task describes how to configure the sequential number generator function.

To learnmore about functions, see "Rule Functions" on page 203.

This section includes:

l "Prerequisite: Select the function" below

l "Configure the function" on the next page

l "Format special sequences" on page 217

l "Examples" on page 218

Prerequisite: Select the function

1. In the DataModel Editor, expand a rule.

2. Click inside the function field (fx) of a response column and select Sequential number
generator. If the function row is not displayed, from the View Options menu, select Functions.
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Note: Dynamic data functions are available for lowest level headers only. Complex headers
that include lower level headers under them are displayed in italic text (header). To display
lower level headers, double-click the column header.

Configure the function

In each cell under this function, enter a value in the following format:

Offset;Increment;FormatString

where:

l Offset is an integer. Used as the starting point for generating the output of the sequential number
generator.

Note: To generate a sequence of numbers that differs for each request/response, each cell
with this generator function has an internal numerical counter. When the simulation starts, this
counter is always set to 0. Each time a generator function is called, the output value is
determined based on the offset and counter. After the output is determined, the value of the
counter is increased by the value of the increment, or decreased if the increment is a negative
number.

l Increment is a positive or negative integer. Indicates the change tomake from one number in the
sequence to the next.

l FormatString defines the format of the output of the sequential number generator.

The format string includes:
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n a regular text string

n (optional) one or more special sequences to define the format of the numerical output of the
generator

To determine the output of the number generator, Service Virtualization goes through the format
string and constructs an output string using specific rules, explained below.

Format special sequences

Special sequences enable you define the format of the numerical output of the function.

You construct special sequences as follows:

l Each special sequencemust start and end with the '#' character.

l Each special sequencemust contain one or more ‘D’ characters. These characters act like a digit
wildcard for a number that will be generated by this generator function. The number will always
occupy exactly the number of specified digits. If the number does not occupy all digits, zeros are
added before it so that it does.

For example, if:

- the special sequence is #DDDD#

- and the number generated by the function is 568

- the output is 0568.

l A special sequencemay also contain 'd' characters. These characters act as placeholders. If the
output of the generator function requires this space, then it will hold a number. If the generated
number does not occupy all digits, then the extra spaces are left empty, and not populated with
zeros. 'd' characters may only be placed before 'D' characters.

For example, if:

- the special sequence is #ddDDD#

- and the number generated by the function is 9857

- the output is 9857.

For the number 125:

- the sequence #DDDDD# outputs 00125

- the sequence #ddDDD# outputs 125
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- and the sequence ##dDDDD outputs 0125.

l You can construct a format string with multiple special sequences.

For example, you can enter a special sequence to resemble a credit card number format:

- if the special sequence is #DDDD#-#DDDD#-#DDDD#-#DDDD#

- and the number generated is 1234567812345678

- the output is 1234-5678-1234-5678

Service Virtualization defines the output of the generator according to the following additional
guidelines:

l If the number is greater than themaximal number that can be stored within the digits, it is truncated
so that it fits within (e.g. if the number was 3456 and the special sequence was #DDD#, the output
will be 456).

l If the number is negative, it is truncated the sameway as above. Then an additional offset is
applied. The value of this offset is based on the number of digits and is selected so that -1 becomes
the biggest number that fits within these digits. For example, if the special sequence was
#DDDDD#, -1 becomes 99999. If it was #DD#, -67813 becomes -13 which then becomes 87.

l For each empty special sequence (when there are two ‘#’ characters next to each other), a single ‘#’
character is inserted into the output string.

l The numerical output of the generator will be a number that has exactly as many digits as there are
'D' characters in all of the special sequences in the field combined.

l Any characters that are not part of a special sequence are copied to the output string.

Examples

Increasing sequence

The typical use case is generating strings that make use of an increasing number sequence.

Example: Your input, typed in the cell under the sequential number generator function:

0;1;Visitor###DDD#

will produce the sequence Visitor#000, Visitor#001, Visitor#002...

Decreasing sequence

In cases where remaining time or another resource that is being depletedmay identify some object,
the decreasing sequences are used to generate such identifiers.
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Example: The real servicemay be generating identifiers based on time remaining until some event
starts.

Your input, typed into cell under the sequential number generator function:

10000;-100;SnapshotTimeTMinus:#DDDDD#

This cell produces the output sequence: SnapshotTimeTMinus:10000,
SnapshotTimeTMinus:09900, SnapshotTimeTMinus:09800, etc.

Multiple independent sequences

When generating several classes of identifiers for various products, you want to maintain an
independent sequence of identifiers for each class. You can achieve that by creating a separate
rule for each class and use just one row in every rule. Use the Is function in the request to
distinguish classes from each other. Each rule has a separate counter for the sequential number
generator function, so that the sequences are independent.

Example: The 3 product lines have to have easily distinguishable ids. Class 1 has the „1“ set as the
first digit, class 2 has 2 etc.

Rule 1, Row 1, your input typed in the cell: 100000;1;codeNR-#DDDDDD#

Rule 2, Row 1, your input typed in the cell: 200000;1; codeNR-#DDDDDD#

Rule 3, Row 1, your input typed in the cell: 300000;1; codeNR-#DDDDDD#

If the service requests IDs in the following sequence {1,2,2,1,3,2,3,1}, the output results are as
follows:

codeNR100000-, codeNR-200000, codeNR-200001, codeNR-100001, codeNR-300000, codeNR-
200002, codeNR-300001, codeNR-100002

Multiple dependent sequences

Consider following the previous use case with just one rule containing all rows instead of separate
rules. In such a case, the internal counter is shared. Therefore, the sequences are not independent
and the output relies on the previous sequence of calls even though they were not triggering the
current row.

Example:

Rule 1,Row 1,your input typed in the cell: 10;10;X1-#DDD#

Rule 1,Row 2, your input typed in the cell: 100;100;X2-#DDD#

If we invoke the virtual service hitting the Row1, Row2, Row1, the output is „X1-010; X2-110; X1-
120“

If the two rows were in separate rules, the output would be: „X1-010; X2-100; X1-020“

Multiple number occurrences

It is possible to split the number that is being computed by SNG intomultiple parts in the output
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string. This is achieved by repeating the #DDD# sequence. Note that the 'Ds' sequences within a
single row may differ in length.

Example: A cell with the following format, such as a credit card number format:

1234567890123456;1;#DDDD#-#DDDD#-#DDDD#-#DDDD#

produces the following output sequence:

1234-5678-9012-3456

1234-5678-9012-3457

1234-5678-9012-3458

1234-5678-9012-3459

etc.

How to Configure the Random Number Generator Function

This task describes how to configure the random number generator function.

To learnmore about functions, see "Rule Functions" on page 203.

This section includes:

l "Prerequisite: Select the function" below

l "Configure the function" on the next page

l "Format special sequences" on page 222

l "Examples" on page 223

Prerequisite: Select the function

1. In the DataModel Editor, expand a rule.

2. Click inside the function field (fx) of a response column and select Random number generator.
If the function row is not displayed, from the View Options menu, select Functions.
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Note: Dynamic data functions are available for lowest level headers only. Complex headers
that include lower level headers under them are displayed in italic text (header). To display
lower level headers, double-click the column header.

Configure the function

In each cell under this function, enter a value in the following format:

Minimum_number;Maximum_number;FormatString

where:

l Minimum_number is the lowest possible number to be used in the output of the random number
generator.

l Maximum_number is the highest possible number to be used in the output of the random number
generator.

l FormatString defines the format of the output of the random number generator.

The format string includes:

l a regular text string

l (optional) one or more special sequences to define the format of the numerical output of the
generator

To determine the output of the number generator, Service Virtualization goes through the format string
and constructs an output string using specific rules, explained below.

User Guide
Chapter 8: DataModeling

HP Service Virtualization (3.61) Page 221 of 352



Format special sequences

Special sequences enable you define the format of the numerical output of the function.

You construct special sequences as follows:

l Each special sequencemust start and end with the '#' character.

l Each special sequencemust contain one or more ‘D’ characters. These characters act like a digit
wildcard for a number that will be generated by this generator function. The number will always
occupy exactly the number of specified digits. If the number does not occupy all digits, zeros are
added before it so that it does.

For example, if:

- the special sequence is #DDDD#

- and the number generated by the function is 568

- the output is 0568.

l A special sequencemay also contain 'd' characters. These characters act as placeholders. If the
output of the generator function requires this space, then it will hold a number. If the generated
number does not occupy all digits, then the extra spaces are left empty, and not populated with
zeros. 'd' characters may only be placed before 'D' characters.

For example, if:

- the special sequence is #ddDDD#

- and the number generated by the function is 9857

- the output is 9857.

For the number 125:

- the sequence #DDDDD# outputs 00125

- the sequence #ddDDD# outputs 125

- and the sequence ##dDDDD outputs 0125.

l You can construct a format string with multiple special sequences.

For example, you can enter a special sequence to resemble a credit card number format:

- if the special sequence is #DDDD#-#DDDD#-#DDDD#-#DDDD#
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- and the number generated is 1234567812345678

- the output is 1234-5678-1234-5678

Service Virtualization defines the output of the generator according to the following additional
guidelines:

l If the number is greater than themaximal number that can be stored within the digits, it is truncated
so that it fits within (e.g. if the number was 3456 and the special sequence was #DDD#, the output
will be 456).

l If the number is negative, it is truncated the sameway as above. Then an additional offset is
applied. The value of this offset is based on the number of digits and is selected so that -1 becomes
the biggest number that fits within these digits. For example, if the special sequence was
#DDDDD#, -1 becomes 99999. If it was #DD#, -67813 becomes -13 which then becomes 87.

l For each empty special sequence (when there are two ‘#’ characters next to each other), a single ‘#’
character is inserted into the output string.

l The numerical output of the generator will be a number that has exactly as many digits as there are
'D' characters in all of the special sequences in the field combined.

l Any characters that are not part of a special sequence are copied to the output string.

Examples

To generate a random number between 0 and 9999999, to be appended to the number 201, type the
following format into each cell under the random number generator function:

0;9999999;201#DDDDDDD#

where:

0 is theminimum number

9999999 is themaximum number

201 is a text string,

and #DDDDDDD# is a special sequence, indicating that the generated number can be up to 7-
digits in length

Result: The output is any number between 2010000000 and 2019999999.

Instead, you could format the cell as follows:

0;9999999;201#dddDDDD#

Result: The output is any number between 2010000 and 2019999999.
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How to Configure the Date/Time Functions

This task describes how to configure the Set Relative Date/Time and the Set Date/Time Relative to
functions.

To learnmore about functions, see "Rule Functions" on page 203.

This section includes:

l "Prerequisite: Select a date/time function" below

l "Configure the function" on the next page

l "Configure the offset" on the next page

l "Configure the date/time format" on page 226

Prerequisite: Select a date/time function

1. In the DataModel Editor, expand a rule.

2. Click inside the function field (fx) of a response column and select one of the following functions:

a. Set relative date/time. The date and/or time value is calculated by adjusting the date/time
when the request was received, using anOffset that you define.

b. Set date/time relative to. The date and/or time value is calculated by adjusting a specified
date/time, using anOffset that you define. This function requires you to select a source
column that contains the date/time to be adjusted.
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Note:

If the function row is not displayed, from the View Options menu, select Functions.

Dynamic data functions are available for lowest level headers only. Complex headers
that include lower level headers under them are displayed in italic text (header). To
display lower level headers, double-click the column header.

Configure the function

The output of the date/time function is configured as follows:

l Offset. Defines themodification that you want to make to the source date/time. Enter the offset into
each cell under the date/time function.

If the offset is not specified for a particular cell or is in an incorrect format, an offset of 0 seconds is
used.

l Format. Defines the format of the output. The resulting date/time that is output to themessage
response is formatted according to one of the following:

n The XSD type of the source column.

n The custom format that you define for the output of the function.

For example, -1:25:00#hh:mm indicates the following:

- an offset of -1 hours and 25minutes (1 hour 25minutes earlier than source time)

- a custom format for the output time, such as 07:15

For details on configuring the offset and custom formats, see below.

Configure the offset

TheOffset is formatted according to the following:

[-][d.]hh:mm:ss[.ff]

where:

l Items in square brackets ([ and ]) are optional

l Colons and periods (: and .) are literal characters

l "-" (optional) indicates a negative time (a time earlier than the source time)

l "d" optional days
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l "hh" mandatory hours, ranging from 0 to 23

l "mm" mandatory minutes, ranging from 0 to 59

l "ss" mandatory seconds, ranging from 0 to 59

l "ff" optional fractional seconds, consisting of 1 to 7 decimal digits

Examples:

l -54.12:00:59.1234567

l 0:00:00.001

l 365.0:00:00

Note: If you are using the set relative date/time function, the resulting date is generated
according to the UTC+0 time zone.

Examples:

You are located in UTC-8 and have created a function with an offset of +1 day.

At 20:00 (8:00 P.M.), the generated relative time will be 4:00 (4 A.M.) the day after tomorrow,
calculated as follows:

20:00(today) + 1 day (your requested offset) + 8 hours (to adjust for your time zone) = 4:00 (the day
after tomorrow)

To maintain the same date/time as your time zone, adjust for the difference using the
offset.

For example, if you are located in UTC-8 and you want to define +1 day offset, youmust also
subtract 8 hours, as follows:

16:00:00#dd-MM-yyyy# (where 16:00:00 represents 1 day - 8 hours)

For an offset of +1 day, if you are located in the UTC+2 time zone:

1:02:00:00#dd-MM-yyyy# (where 1:02:00:00 represents 1 day + 2 hours)

Configure the date/time format

Service Virtualization can set the format based on autodetection of the XSD type, or by a custom
format that you enter.

XSD Type

Service Virtualization can auto-detect the following XSD date/time types
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l xsi:date - "yyyy-MM-dd" (Example of output: 1984-11-28)

l xsi:time - "HH:mm:ss" (Example of output: 23:59:59)

l xsi:dateTime - "yyyy-MM-ddThh:mm:ss" (Example of output: 2001-12-13T10:15:33)

If detected, the format of the output of the date/time function is based on the XSD type, provided that
you have not defined a custom format.

No other formats, including JSON date/time formats, can be detected, as their internal type is
xsi:string. If the application cannot detect the format from the element's type, xsi:dateTime's format is
used by default. If you want to specify other output formats, you can define a custom format.

Custom Format

To configure a custom format, enter the following into each cell under the date/time function:

Offset#CustomFormat

You define a custom format using the following:

l "d" - The day of themonth, from 1 through 31.

l "dd" - The day of themonth, from 01 through 31.

l "f" .. "fffffff" - Fractions of a second, number of "f" characters specifies number of digits to print

l "h" - The hour, using a 12-hour clock from 1 to 12.

l "hh" - The hour, using a 12-hour clock from 01 to 12.

l "H" - The hour, using a 24-hour clock from 0 to 23.

l "HH" - The hour, using a 24-hour clock from 00 to 23.

l "m" - Theminute, from 0 through 59.

l "mm" - Theminute, from 00 through 59.

l "M" - Themonth, from 1 through 12.

l "MM" - Themonth, from 01 through 12.

l "s" - The second, from 0 through 59.

l "ss" - The second, from 00 through 59.

l "tt" - The AM/PM designator.

l "yyyy" - The year, four digit number.
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l regular characters (all characters except the ones mentioned above) - generated "as is". To
generate a character that has a special meaning (is part of one of the custom formats above, such
as “s”), place a '\' before it.

Examples:

If today's date is December 10, 2012:

l To generate yesterday's date: -1.00:00:00#yyyy-MM-dd

Result: The output is 2012-10-09.

l To generate today's date: : 0#MM/dd/yyyy

Result: The output is 12/10/2012.

l To generate the date 1 week from today: 7.00:00:00#MM/dd/yyyy

Result: The output is 12/17/2012.

How to Configure the Substring Function

This task describes how to configure the substring function. The substring function enables you to copy
part of a string in your datamodel from one column to another.

To learnmore about functions, see "Rule Functions" on page 203.

You configure the substring function in the Substring Dialog Box. For user interface details, see
"Substring Dialog Box" on page 253.

To configure the substring;

Create a format string to define which part of the data in the source column you want to copy.

The format string can consist of any combination of the following:

Format Description Example

{n} Copies the n-th
character from the
source string.

Format string: {3}

Source string: abcde

Substring result: c

{n+} Copies all characters
from the n-th character
to the end of the source
string.

Format string: {5+}

Source string: abcdefgh

Substring result: efgh
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Format Description Example

{n-m} where n is
located beforem in the
string

Copies all characters
from the n-th character
to them-th character
(inclusive).

Format string: {2-6}

Source string: abcdefgh

Substring result: bcdef

{m-n} where n is
located beforem in the
string

Copies all characters
from them-th
character, backwards
to the n-th character
(inclusive).

Format string: {6-2}

Source string: abcdefgh

Substring result: fedcb

{n:m} Copies m characters,
starting from the n-th
character.

If there are not enough
characters in the
source string, a space
is added for each
missing character.

Format string: {7:2)

Source string: abcdefgh

Substring result: gh

Regular text You can add additional
text The text you enter
is copied as is.

Limitation: You cannot
use the characters { }
or \. They are used to
mark special format
sequences.

Workaround: To use
the characters { } or \
as part of a text string
you enter, each of
these characters must
be preceded by the
backslash character \.
Placing a backslash
before one of these
special characters
overrides their special
meaning.

Format: Text with backslash \\ and curly
brackets \{ \}

Result: Text with backslash \ and curly
brackets { }

Example:

In the Format field of the Substring dialog box, you enter the following format string:
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All characters:{1+}. Only 6th and 8th characters: {6}{8}. Result of \{5:5\} is: {5:5}. First 13
characters reversed: {13-1}.

The source string is: 123456789ABCDEF

The result, output to the cell configured with the substring function is:

All characters:123456789ABCDEF. Only 6th and 8th characters: 68. Result of {5:5} is: 56789.
First 13 characters reversed: DCBA987654321.

How to Define Custom Functions
You can create new functions to use in a datamodel. For user interface details, see "New/Edit
Function Dialog Box" on page 263.

You can use the following variables to configure a new, custom function:

l $input_string The original string is automatically quoted in the place of usage.

l $input_string_unquoted The original string is not automatically quoted.

l $input_int The original string is converted to the int data type, for integer data. It contains NULL if
the input string is not of this data type.

l $input_float The original string is converted to the float data type, for floating point numeric data. It
contains NULL if the input string is not of this data type.

l $input_date The original string is converted to the date data type, to define a date. It contains NULL
if the input string is not of this data type.

l $data_string The actual data, converted to the string data type.

l $data_int The actual data, converted to the int data type.

l $data_float The actual data, converted to the float data type.

l $data_date The actual data, converted to the date data type.

Following are examples of custom functions:

l Match request data (cast to integer) smaller than actual value (cast to integer) found in the column
$input_int < $data_int

l Match request data (cast to integer) smaller than actual value (cast to float) found in the column
$input_int < $data_float

l Match actual value found in the column (cast to string) equal to 'cat' string $data_string = 'cat'

l Match request data (cast to string) equal to 'cat' string $input_string = 'cat'
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l Match request data (cast to string) equal to actual value (cast to string using an SQL 'LIKE'
operation) $input_string LIKE $data_string

l Match request data (cast to string) equal to any string starting with the actual value found in the
column $input_string LIKE $data_string + '%'

l Match request data (cast to string) containing a substring 'cat' $input_string LIKE '%cat%'

l Match request data (cast to date) smaller than actual data $input_date < $data_date

l Match request data smaller than actual data OR request data equal to 'dogs' string $input_date <
$data_date OR $input_string = 'dogs'

How to Configure Regular Expressions
This task describes how to configure regular expressions in Service Virtualization. Use regular
expressions tomatch a specific string in order to mask select data.

In the Replace Algorithm Configuration dialog box, you can enter a regular expression in theMatch
pattern andReplace value fields. (For user interface details, see "Replace Algorithm Configuration
Dialog Box" on page 162.)

In addition, when you use regular expressions in theReplace value field, the expression can reference
groups from the search pattern you entered in theMatch pattern field.

Examples:

Match pattern field Replace value field Sample input Sample output

\b(\w+)(\s)(\w+)\b $3$2$1 one two two one

\b(?<word1>\w+)(\s)(?<word2>\w+)\b ${word2} ${word1} one two two one

For information on creating regular expressions and some examples of their use, visit this site: Regular
Expression Language - Quick Reference.

How to Work With External Data Sources
This task describes how to work with an external data source. You can import or export data.

l This task is part of a higher-level task. For details, see "How toModify Virtual Service
Behavior" on page 210.

l To learnmore about external data sources, see "Data Driving" on page 207.

l For a use-case scenario related to this task, see "Working with External Data Sources - Use-
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case Example" on page 234.

This task includes the following steps:

"Add an external data file" below

"Bind the data" on the next page

"Bind array data" on the next page

"Bind other data" on page 234

"Configure import/export settings" on page 234

"Refresh the data" on page 234

"Change the path of the data source" on page 234

"Disconnect external data" on page 234

1. Add an external data file

You can associate a data rule with an external data file in order to import or export data.

In the DataModel Editor, select New Rule > Data Driven Rule. Select one of the following
options:

Create new data file. The Service Virtualization Designer creates a new Excel file, structured
according to the schema (message structure) associated with the virtual service. Rule columns
are automatically bound to the worksheet columns.

Use existing data file. Youmust thenmanually bind rule columns to worksheet columns. After
binding, the external data is imported to the DataModel.

For details, see "New Data Driven Rule Dialog Box" on page 258.

Result:A "preview" of your external data file displays within the rule.
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Note that the worksheets in the external file are displayed as tabs at the bottom of the data table.

2. Bind the data

If you selected an existing data file, youmust bind the data. You createmappings between the
data columns in the external file, and the columns/headers in your data rule.

a. In a column header, click bind data. If it is not visible, click View Options > Data Binding.

Headers must be expanded down to the lowest level in order to bind.

b. Click a column in the displayed external data source table to bind that column.

c. Repeat steps a and b for all columns you need to bind.

d. Click OK. The data is imported.

3. Bind array data

When themessage structure contains an array that needs to be data-driven, you need to work with
a properly structured Excel file. The file must contain database-like relationships, using primary
and foreign keys, which allow themapping of one row tomany.

When binding an array item, the Edit Sheet Relations dialog box opens automatically, enabling
you to define the relationships between worksheets that are required for array binding. . For user
interface details, see "Edit Sheet Relations Dialog Box" on page 266.
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Alternatively, right-click the rule or column header and select External Data Properties. See the
Sheet Relations area.

4. Bind other data

You can configure binding for working with different data formats (REST protocol), different
response types (SOAP protocol), or amessage structure containing different types.

When you start to bind to an Excel worksheet columnwhere the response can contain these types
of data, the relevant dialog box opens automatically (The Data Format, Response Type, or Choice
Data Binding dialog boxes). For user interface details, see "Data Format/Response Type/Choice
Binding Dialog Box" on page 268.

5. Configure import/export settings

You can configure rules to import or export data, or configure settings for rules already associated
with an external data file.

Learned Data rule: To export learned data, right-click the Learned Data rule and select Export
Data.

Blank/custom rule. To import data from or export data to an external data file, right-click the rule
and select Import Data orExport Data.

Data driven rule. For a rule already associated with an external file, you can change settings.
Right-click the rule and select External Data Properties.

6. Refresh the data

If you have selected the Data Synchronization option for your rule, the data is automatically re-
imported or exported.

Tomanually refresh data, right-click the rule and select Refresh Data. The data is imported or
exported, depending on how the rule is configured.

7. Change the path of the data source

To change the location of the external data file, right-click the rule and select External Data
Properties.

8. Disconnect external data

To disconnect a rule from an external data source and remove bindings, right-click the rule and
select Disconnect External Data.

Working with External Data Sources - Use-case Example

This section provides an example of working with an external data file.
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Note: For a task related to this example, see "How toWork With External Data Sources" on page
231.

It can be difficult to manually configure an Excel worksheet when your data has a particular complex
structure. As an alternative tomanually setting up a file and configuring binding in the DataModel, you
can create a new data driven rule, and have Service Virtualization create a new data file for you,
according to your message structure.

1. Create a virtual service.

2. In the DataModel, create a new data driven rule and select Create new data file. Service
Virtualization will create the new file according to your message structure, and bind the columns.

3. Select Data Synchronization to automatically re-import data in the new file before Simulation.

Alternatively, clear the Data Synchronization check box. You can choose to import at a later time.

4. After the new data file is created, you can add data to it. If you selected Data Synchronization,
when you place your virtual service into Simulatingmode, the external data is re-imported. If you
did not select Data Synchronization, you can choose to refresh the datamanually at any time, or
reconfigure the rule for data synchronization.

How to Call External Services
This task describes how to configure a virtual service to call external services.

l This task is part of a higher-level task. For details, see "How toModify Virtual Service
Behavior" on page 210.

l Only SOAP and XML over HTTP service call activities are supported.

1. In the DataModel Editor, select the operation from which you want to call the external service.

2. To select a service description that was already imported into the project, click Activity. Select
the activity to add, and choose whether to add it before or after the response.

3. To import a new service description, click Activity > Import Activities. Enter the path to the
WSDL for a SOAP service, or the path to the XML schema for an XML service.

Note: If you are importing an XML service that requires HTTP authentication, youmust add
the user name and password to the Service Virtualization credential store.

n The Identify Name you enter in the credential storemust beSCA:<name of called
activity>.
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n Alternatively, you can create a global Identity NameSCA which is used if no specific
identity exists in the credential store.

For user interface details, see "Edit Credential Store Dialog Box" on page 316.

4. For a SOAP service: In the Select Service Operation dialog box, select an activity to add, or
import the service description document for use at a later time. For user interface details, see
"Select Service Operation Dialog Box" on page 269.

5. For an XML over HTTP service: In the Service Properties dialog boxes:

a. Select message elements for input and output messages.

b. Enter the URL on which the real service runs.

6. To add service call activity at a later time, click Activity again and select an activity.

7. To edit properties for a service call activity, right-click the activity's column header and click
Activity Properties. For user interface details, see "Activity Properties Dialog Box" on page 271.

8. To remove the service call activity from a rule, right-click the column header and click Remove
Activity.

9. To enable/disable the service call for a rule, click the on/off icon in the rule's header.

10. To handle connection failure, define a response for the virtual service to return if the service call
activity cannot connect to the external service.

a. Prerequisite: A rule with service call activity enabled.

b. Create an additional rule with a lower priority than the rule that contains the enabled service
call activity.

c. In the new rule:

o Turn off the service call activity.

o Set the service call activity's response Type columnwith the Is function, and assign the
valueService Call Failure. The ServiceCallFailure column is displayed.

o In the ServiceCallFailure column, select a value for the response: UNKNOWN, HOST_
NOT_FOUND, CONNECTION_FAILED, CONNECTION_TIMEOUT. By default, the
connection timeout is 100 seconds.

Tip:
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l You can use theCopy from function on any service call request column, or virtual service
response column. Select theCopy from function. The columns that you can use as a source
are highlighted. Click the desired source column.

l Use the Row Detail dialog box for easier configuration of the service call activity. For details,
see "Row Detail Dialog Box" on page 250.

How to Assess Change Impact
This task describes how to test the impact that changes in the datamodel have on simulation.

To learnmore, see "Simulation Preview" on page 208.

This task includes the following:

l "Open the Simulation Preview pane" below

l "Test the impact of a change on the simulation" below

l "Troubleshoot" on the next page

Open the Simulation Preview pane

In the DataModel Editor, select View Options > Simulation Preview. For user interface details, see
"Simulation Preview Pane" on page 250.

Preview a simulated response

1. Open Simulation Preview.

2. Select a row in a data rule. The simulated response is displayed.

3. Edit the request data to view the impact on the response.

Test the impact of a change on the simulation

1. Open Simulation Preview.

2. Select a row in a data rule.

3. Click to pin the row to Simulation Preview.

4. Select an existing row in a data rule, or create a custom rule with a higher priority to view the
impact on the simulation.
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5. View the impact on themessage response in the pinned row in Simulation Preview.

Troubleshoot

If you have amessage request that is not matching any rule in your datamodel, you can compare it to
rows in the data rules to look for a problem in your rule definitions.

1. Open Simulation Preview.

2. Do one of the following:

a. Select an existing row in a data rule.

b. Right-click in Simulation Preview and select Import Request.

3. Click to pin the row to Simulation Preview.

4. Select another row in a data rule to compare the two rows.

5. Click Show Differences to highlight the differences in the DataModel Editor table.

Note: The columns displayed in the DataModel Editor table may change when you are
comparing rows. To restore the display the previously defined column settings, click Restore
Columns.
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Data Model User Interface
This section includes:

DataModel Editor 240

DataModel Editor Context Menus 246

DataModel Editor Options Page 249

Simulation Preview Pane 250

Row Detail Dialog Box 250

Substring Dialog Box 253

Import Request/ResponseMessage Dialog Box 255

Request/Response Pairing Dialog Box 257

New Data Driven Rule Dialog Box 258

Import/Export Data Dialog Box 260

External Data Properties Dialog Box 262

New/Edit Function Dialog Box 263

Change Columns Dialog Box 264

Edit Sheet Relations Dialog Box 266

Data Format/Response Type/Choice Binding Dialog Box 268

Select Service Operation Dialog Box 269

Service Properties for XML Service Call Activity 270

Activity Properties Dialog Box 271
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Data Model Editor
The DataModel Editor enables you to view and edit a datamodel. You can configure requests,
responses, and service activity calls for individual operations of a virtual service.

To access Use one of the following:

l In the Virtualization Explorer, double-click a datamodel.

l In the Virtual Service Editor, under DataModels, select a datamodel and click
Edit.

Important
information

l Many of the actions you can perform in the DataModel Editor are available only
from context menus. For details, see "DataModel Editor Context Menus" on page
246.

l Tip: To access the DataModel Editor menus, press theAlt key and press a
number from 1 - 6. For example, to open theView Optionsmenu, press Alt + 5.

l Service Virtualization supports MIME attachments for SOAP, binary, and XML
services over HTTP that are recorded during learning of the real service behavior.

Relevant
tasks

l "How toManage SimulationModels" on page 198

l "How toModify Virtual Service Behavior" on page 210

l "How to Define Rule Functions" on page 212

l "How toWork With External Data Sources" on page 231

l "How to Create a Scripted Rule" on page 345
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See also l "DataModel Overview" on page 201

l "DataModel Editor Context Menus" on page 246

l "Rule Functions" on page 203

l "FAQs: DataModel Editor" on page 272

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<data model name and
description>

The name and description of the datamodel. Click to edit.

<operations/URI Spaces
pane>

Operations pane. Located in the left pane of the editor. Displays a list
of the operations in the service associated with the selected data
model.

Enter text in the filter box to filter for specific operations in the list.

Select an operation from the list to display its details in themain pane of
the DataModel Editor.

Operation Displays the name of the currently selected virtual service, and lists the
operations in the virtual service. Select an operation from the list to
display its details in themain pane of the DataModel Editor.

Learned Data Learned Data rule. Created by default when you create a virtual
service. Displays the requests and responses recorded during a
learning session of a virtual service.

Default Response Default Response rule. Created by default when you create a virtual
service. The response that is provided when the data does not match
any other rule. The Default Response rule always has the lowest
priority.
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UI Element Description

<rule elements> Rules in the datamodel contain the following elements:

l Expand rule. Click the arrow before the rule number to expand a
rule.

For details on the functions used in rules, see "Rule Functions" on
page 203.

l Rule priority. The rule number indicates the order in which the rule
is applied during simulation.

Tomove a rule up or down in the list to change its priority, click the

up/down icon after the rule number.

Note: Not available for the Default Response rule.

l Rule name and description. Click to edit. Available only for
custom rules.

l Import/Export icons.When the rule is associated with an external
data file, one of the following icons is displayed:

The data was imported from an external file.

The data was imported from an external file and is configured
to automatically re-import before each Simulation session.

The data was exported to an external file.

The data was exported to an external file and is configured to
automatically re-export after each Learning session.

l x/x rows. Indicates the number of rows for this rule in this operation,
out of the total rows for this rule across all operations in this service.

Tip: Press Ctrl + the rule number to select a rule, or to
expand/collapse the selected rule.
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UI Element Description

Enables you to create a new custom rule. Custom rules apply to all
operations in the service. Includes the following options:

l Blank Rule. Enables you to create a new, custom rule with an
embedded data source, used tomodify some aspect of simulation,
such as to rewrite part of the response, add service call activity, or
addmore data.

The blank rule can be added before or after the default Learned Data
rule.

l Scripted Rule (Beta). Enables you to create a new, custom rule
with a script to access request data and set response data. For
details, see "Scripted Rules" on page 344.

Note: Scripted rules are a Service Virtualization Labs feature.
This field is displayed only if you have enabled the feature. For
details, see "Service Virtualization Labs" on page 343.

l Data Driven Rule. Opens the Use Existing Data Source dialog
box, enabling you to create a new rule using an external file as a
data source, such as an Excel file. A new read-only rule is created
for this data source.

Select the data source file, and assign a name to the data source.

Select First row contains names of columns to use the header
row of the source file for the rule's column names.

The data driven rule can be added before or after the default Learned
Data rule.

For more details on rules, see "Rule Functions" on page 203.
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UI Element Description

Depending on the virtual service, displays options for the operations or
URI spaces defined in the virtual service.

Includes the following options:

l Browse and Search Operations/URI Spaces. Opens the
Operations pane, displaying the list of operations included in the
service.

In the search box, enter a name or part of a name to search and filter
for specific operations in the list.

Select an operation from the list to display its details in themain
pane of the DataModel Editor.

l Edit Operations/URI Spaces. Opens the Service Description
Editor, enabling you tomodify the operations or URI spaces, their
data formats, andmetadata. For details, see "Service Description
Editor" on page 152.

Note: Available only for supported protocols.

l Recently Used Operations/URI Spaces. Lists your most recently
used operations or URI spaces, allowing you quick access.

Includes the following options:

l Change Columns. Opens the Change Columns dialog box,
enabling you to select the headers to display for the operation. For
details, see "Change Columns Dialog Box" on page 264.

l Flat/Structured Headers. Toggles between flat and structured
column headers.

Includes the following option:

Insert Path. Enables you to select a path to a Service Virtualization
element, and add it to a scripted rule.

Note: Scripted rules are a Service Virtualization Labs feature. This
field is displayed only if you have enabled the feature. For details,
see "Service Virtualization Labs" on page 343.
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UI Element Description

Enables you to configure the virtual service to call an external service:

l Import Activities. Opens the Import Real Service Description
dialog box, enabling you to import a service description of a service
whose operations you can use as service call activities.

Available for: SOAP and XML over HTTP.

Note: After import, the on/off icon displays in the activity column
header in the rule, enabling you to enable/disable the service call
for the rule.

Includes the following options:

l Functions. Displays the function row within rules, enabling you to
set conditions for data columns.

l Highlight Columns. Displays column headers in different colors
according to function type: Action, Condition, and Ignore.

Default value:Off.

To change the colors or restore the default color coding, from the
mainmenu, select Tools > Options, and click the Data Model
Editor tab. For details, see "DataModel Editor Options Page" on
page 249.

l Data Binding. Displays the data binding row within rules, enabling
you to configure binding. For more details, see "Data Driving" on
page 207.

l Time Stamp. Displays the time stamp columnwithin rules, which
shows the time of creation or last modification of the rule.

l Operations/URI Spaces Pane. Opens the Operations/URI Spaces
pane, displaying the list of operations/URI spaces included in the
service.

l Simulation Preview. Displays how changes in the datamodel are
affecting the simulation. For user interface details, see "Simulation
Preview Pane" on page 250.
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UI Element Description

Displays the Track Position columnwithin rules, and opens the track
pane on the right side of the editor. For details, see "Stateful Layout
View" on page 278.

For details on simulating stateful behavior, see "How to Simulate a
Stateful Service" on page 277.

Data Model Editor Context Menus
You can perform additional actions on rules in the DataModel Editor by accessing the context menus.

To access Right-click a rule and select an option.

See also l "DataModel Editor" on page 240

l "DataModel Overview" on page 201

Relevant tasks l "How toModify Virtual Service Behavior" on page
210

l "How to Create a Scripted Rule" on page 345

User interface elements are described below.

Rule actions

The following items are available when you right-click a rule.

UI Element Description

Delete
Rule

Deletes the selected rule.

Available for:Custom rules

Disable
Rule

Deactivates the selected rule. The rule is not applied during simulation.

To reactivate the rule, right-click and select Enable Rule.

Disconnect
External
Data

Disconnects the rule from the external data file with which it is synchronizing. This
discontinues any import/export actions.

Available for:Data driven rules
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UI Element Description

Export
Data

Opens the Export Data dialog box, enabling you to export data from an external data
file. For details, see "Import/Export Data Dialog Box" on page 260.

External
Data
Properties

Opens the External Data Properties dialog box, enabling you tomodify your
configuration for working with an external data source. For details, see "External Data
Properties Dialog Box" on page 262.

Available for:Data driven rules

Import
Data

Opens the Import Data dialog box, enabling you to import data from an external data
file. For details, see "Import/Export Data Dialog Box" on page 260.

Available for:Blank custom rule

New Rule Creates a new custom rule.

Open
External
Data

Inside the data table, displays the data from the external file with which your rule is
synchronized.

Available for:Data driven rules

Refresh
Data

Depending on whether your rule is configured for import or export to an external data
file, re-imports or re-exports the data.

Available for:Data driven rules

Column header actions

The following items are available when you expand a rule and right-click a column header.

UI Element Description

Activity
Properties

Opens the Activity Properties dialog box, enabling you tomodify properties for a
service call activity. For details, see "Activity Properties Dialog Box" on page 271.

Change
Columns

Opens the Change Columns dialog box, enabling you to specify which columns are
displayed in the data table of a rule. For details, see "Change Columns Dialog Box"
on page 264.

Import/Export
Data

Opens the Import/Export Data dialog box, enabling you to import/export data
from/to an external data file. For details, see "Import/Export Data Dialog Box" on
page 260.

Mask

Change
Masking

Opens the DataMasking dialog box, enabling you to hide specific request and
response data elements. For details, see "DataMasking Dialog Box" on page 161.
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UI Element Description

Remove
Activity

Removes the selected activity from the rule.

Reset
Column
Width

Resets default columnwidths.

Sort Sorts the rows within the rule.

Row actions

The following items are available when you right-click a row within a rule.

UI Element Description

Add Row Creates a new row in the data table.

Add to
Track

Opens the Stateful Layout view of the DataModel Editor, enabling you to order
request/response pairs to define the sequence in which they are used during a stateful
simulation. For details, see "Stateful Layout View" on page 278.

Binary
Data

Enables you to:

l import a binary file to the cell

l edit the file using the internal Service Virtualization editor or an external editor

l export the file

Copy/Paste
Cell

Copy the cell contents to the clipboard. Paste into another cell or outside of the
application.

Available for: Lowest level headers only.

Import
Message

Opens the Import Request/ResponseMessage dialog box, enabling you to import
messages from a file, by copying from the clipboard, or by manually entering text. For
details, see "Import Request/ResponseMessage Dialog Box" on page 255.

Number
Format

The type of numerical data in the row: binary, decimal, or hexadecimal.

Properties Displays additional options for configuring a scripted rule. For more details, see "How
to Create a Scripted Rule" on page 345.

Available for:Scripted rules.
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UI Element Description

Row Detail Opens the Row Detail dialog box, enabling you to view, enter, and edit data in the row.
For details, see "Row Detail Dialog Box" on the next page.

Tip: If your structure includes many columns, the Row Detail dialog box offers a
more user friendly format for viewing, entering, and editing datamanually.

Available for:Rows containing data.

Set Nil/Set
Null

Sets the value of the cell to nil or null.

The option available varies depending on the data type of the cell in which you are
working.

Set Not
Present

Clears any value from the cell.

When you add a new row, the cell values are initially defined as"Not Present".

Data Model Editor Options Page
The DataModel Editor options page enables you to set options for the DataModel Editor.

To access From themainmenu, select Tools > Options, and click theData Model Editor tab.

See also "DataModel Editor" on page 240

User interface elements are described below:

UI Element Description

Highlighting Change the colors or restore the default color coding used to highlight column
headers by function type in the DataModel Editor. For details on enabling
highlighting functionality, see "DataModel Editor" on page 240.
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Simulation Preview Pane
The Simulation Preview pane displays a simulation of themessage response based on the request
data in a row you select in the DataModel Editor.

To access In the DataModel Editor, select View Options > Simulation Preview.

Important
information

The columns displayed are based on the columns currently displayed in the Data
Model Editor table above.

Relevant tasks "How to Assess Change Impact" on page 237

"How toModify Virtual Service Behavior" on page 210

See also "Simulation Preview" on page 208

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element
Description

Pinned. Simulation Preview will continue to display on the selected row while
comparing it to the row selected in the DataModel Editor table. Select a different row
in the DataModel Editor table in order to compare the two rows.

Unpinned. Simulation Preview displays the row currently selected in the DataModel
Editor table. You can edit the request data in the Simulation Preview, and view the
impact on the response data.

<Request
columns>

Displays the request data for the selected row.

<Response
columns>

Displays the simulated response that is returned, based on the request data in the
row.

Show
Differences

Highlights the columns in the selected DataModel Editor row that are different from
the row that is pinned in the Simulation Preview. The columns that are displayed in the
DataModel Editor table may change as required to show the differences.

Click Hide Differences to clear the highlighting from the rows.

Restore
Columns

Returns the displayed columns in the DataModel Editor table to the settings that were
defined before you selectedShow Differences.

Row Detail Dialog Box
This dialog box enables you to view, enter, and edit data in the row.
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To access Use one of the following:

l In the DataModel Editor, right-click a row within a rule of an operation and
select Row Detail.

l Select a row and click Ctrl+D.

Important
information

l Changes youmake to functions in this dialog box, such as Is or Ignore, apply
to all rows in the rule.

l Changes youmake to data are immediately updated in the DataModel Editor
when youmove to a different field.

l To enter multi-line values, click Alt+Enter at the end of the line of text to add a
new line.

Relevant tasks "How toModify Virtual Service Behavior" on page 210

See also "DataModel Editor Context Menus" on page 246

User interface elements are described below (unlabeled elements are shown in angle brackets):
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UI Element Description

<Left and Right panes> The two panes in the dialog box display the same information,
providing you with a convenient interface for configuringmessage
requests and responses.

Example:You are working with service call activity and want to
copy data from the service call activity response to the virtual
service response:

1. In the left pane, select the service call activity response. (In
this example, theResponse - getClaim tab.)

2. In the right pane, click the tab for the virtual service response.

3. In the virtual service response tab, select theCopy from
function.

4. In the service call activity response tab, select the data to
copy.

Call <x> of <y> Indicates the row number (x) that is selected within the rule, which
contains (y) rows.

Add Call Adds a new row to the rule, enabling you to enter datamanually.

Delete Call Deletes the selected row.
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UI Element Description

Search Enter the text you want to find. The first matching text is
highlighted.

Click thePrevious andNext arrows in the Search box tomove to
other matching text.

Tip: You can also use Alt+Right and Alt+Left arrows to
navigate through the search results.

<search filter> Limits the search according to the criteria you select. Options
include:

l Message. Searches both request and response data.

l Request/Response/Service call activity request/Service
call activity responseSelect amessage part to limit the
search to that part of themessage.

Request/Response/Service
call activity Requests/Service
call activity Responses

The tables display the data for the selected row. You can view,
search, andmodify the data.

Move Array Item Moves an array in your datamodel.to a different location that you
specify.

Right-click an array item to access this option, and enter an array
index.

Duplicate Array Item Creates a copy directly below the selected item.

Right-click an array item to access this option.

Substring Dialog Box
This dialog box enables you to copy a part of a string from one data column to another. You can also
add additional text to the copied text.
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To
access

1. In the DataModel Editor, expand a rule.

2. Click inside the function field (fx) of a response column and select Substring.

Tip: If the function row is not displayed, from the View Options menu, select
Functions.

3. Select a column to be used as the source of the data from which to extract the
substring. The columns available for selection are highlighted.

Relevant
tasks

"How to Configure the Substring Function" on page 228

See also "Rule Functions" on page 203
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User interface elements are described below:

UI
Element Description

Source The substring is taken from the data in the source column you specify.

By default, the column you already selected is displayed. Click Change to select a
different column.

Format Defines which part of the string you want to copy from the source column, and any
additional text you want to add to the string. For details on how to define the format, see
"How to Configure the Substring Function" on page 228.

Preview Simulates an example of the substring result based on the settings you defined in the
Source and Format fields.

Change Enables you to select a source column for the substring of data to be copied.

More Opens the Service Virtualization help to assist you in defining the substring format.

Import Request/Response Message Dialog Box
This dialog box enables you to import messages from a file, by copying from the clipboard, or by
manually entering text. You can also import multiple files simultaneously.
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To access In the DataModel Editor, expand a rule.

l To import messages to a specific operation/URI space, select the
operation/URI space in the Operations/URI Spaces pane. Right-click inside the
rule and select Import Message.

l To import messages at the service level, select the service in the
Operations/URI Spaces pane. Right-click the rule and select Import Message.
(Available for SOAP and XML services only.)

Available for:Custom rules and the Learned Data rule.

Important
information

l Importing multiple messages at the service level: Themessages are placed
in the proper operations.

If a message contains a new schema/message structure that does not currently
exist in any operations in the service:

n For an XML service, a new operation is created.

n For a SOAP service, an error message displays.

l Importing multiple messages directly into a specific operation:

If a message contains a new schema/message structure that does not currently
exist in the operation:

n For a REST service, a new data format is created.

n For an XML or SOAP service, an error message displays.

Relevant
tasks

"How toModify Virtual Service Behavior" on page 210

See also "DataModel Overview" on page 201

User interface elements are described below:

UI Element Description

Expand/Collapse. Click to show/hidemessage content.

Request/Response
Message

Enter request and responsemessage content.

You can import request messages, responsemessages, or both.
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UI Element Description

From File Click to select a file from the file system. Each file may contain only the
request or response part of a single message.

To import multiple messages, select multiple files to import. Service
Virtualizationmatches pairs of request and responsemessages by file name,
according to one of the followingmethods:

l Files arematched according to any numerical index present within the file
name.

n The index can be located at the beginning or end of the file name, or as
a separate part of the file name, . For example: 5_req.xml, req5.xml,
req.5.xml

n The index must be in the same location in all files.

n Example: 9984_req1.xml and 9984_req2.xml. The files are compared
according to index numbers are 1 and 2 (not 9984).

l Files with the same name are paired.

File name extensions are ignored.

Tip: Place request and response files in separate folders to ease the
import process.

From Clipboard Pastes clipboard content into themessage box.

Request/Response Pairing Dialog Box
This dialog box enables you to review andmake changes to the request/responsemessage pairing
performed by Service Virtualization.
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To access Opens automatically when you select to import multiple messages in the Import
Request/ResponseMessage dialog box.

Important
information

l Service Virtualization pairs request and response files according to file names. For
additional details, see "Import Request/ResponseMessage Dialog Box" on page
255.

l A file that does not match another file is also imported. For example, if there is a
request file, but no corresponding response file, the request file is still imported.

Relevant
tasks

"How toModify Virtual Service Behavior" on page 210

See also "DataModel Overview" on page 201

User interface elements are described below:

UI Element Description

Request/Response
File

The request and response files to import.

Tomake changes to the request/response file pairing, select a request or
response file andmove it up or down in the list.

Create a Track Places the importedmessages into a separate track in the datamodel.

New Data Driven Rule Dialog Box
This dialog box enables you to create a new rule connected to an external data source.
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To access 1. In the DataModel Editor, select New Rule > Data Driven Rule.

2. Select one of the following:

n Create new data file.

n Use existing data file.

Important
information

Creating a new data file: The Service Virtualization Designer creates a new Excel
file, structured according to the schema (message structure) associated with the
virtual service. Rule columns are automatically bound to the worksheet columns.

Using an existing data file:After you create the rule youmust thenmanually bind
rule columns to worksheet columns. After binding, the external data is imported to the
DataModel.

Relevant
tasks

l "How toModify Virtual Service Behavior" on page 210

l "How toWork With External Data Sources" on page 231

See also "DataModel Overview" on page 201

User interface elements are described below:

UI Element Description

New/Existing
External Data
File

To use an existing data file:Select a file from the drop-down list, or click the
browse button to navigate to the file location.

To create a new data file: Type a name for the file and specify its path, or click
the browse button to navigate to the file location.

Column Names If you are adding an existing file, this option indicates that the first row of your file
is a header row, containing the names of each column.

Data
synchronization

The rule is configured to import data automatically from the external data file
before each simulation.
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UI Element Description

Service
Operations

The operations in your virtual service for which you want to import data.

By default, all of the virtual service's operations are selected for import. To
change this selection, click Change and edit the list of operations for import.

Import/Export Data Dialog Box
The Import Data dialog box enables you to import data from an external data file to your datamodel.

The Export Data dialog box enables you to export data from your datamodel to an external data file.

To access Import Data:Right-click a custom rule and select Import Data.

Export Data:Right-click a custom rule or the Learned Data rule and select Export
Data.
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Relevant
tasks

"How toWork With External Data Sources" on page 231

See also "DataModel Overview" on page 201

User interface elements are described below:

Import Data Dialog Box

UI Element Description

External Data
File

Specify the path to the external data file containing data to import, or click the
browse button to navigate to the file location.

Column Names Indicates that the first row of your file is a header row, containing the names of
each column.

Data
synchronization

Data is automatically re-imported from the external data file before each
Simulation session.

Note: After import, do not modify data directly in the DataModel Editor. The
next time that the data is re-imported from the external file your changes will
be lost.

Service
Operations

The operations in your virtual service for which you want to import data.

By default, all of the virtual service's operations are selected for import. To
change this selection, click Change and edit the list of operations.

Export Data Dialog Box

UI Element Description

External Data
File

Specify the path for the new external data file, or click the browse button to
navigate to the file location.

Data
synchronization

Data is automatically exported to the external data file after a virtual service
Learning session.

Note: After export, do not modify the external data file. Each time the data is
exported, the external file is deleted and recreated. Therefore any changes
youmake in the external file will be lost on the next automatic export.

Service
Operations

The operations in your virtual service for which you want to export data.

By default, all of the virtual service's operations are selected for export. To
change this selection, click Change and edit the list of operations.
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External Data Properties Dialog Box
This dialog box enables you to configure options for a data rule that is working with an external data file.

To access Right-click a rule or column header and select External Data Properties.

Available for a rule that is associated with an external data file for import or export.

Relevant tasks "How toWork With External Data Sources" on page 231

See also "Data Driving" on page 207

User interface elements are described below:

UI Element Description

Importing data
from external
data file

The rule is associated with an external file from which it has imported data.

Exporting data
to external data
file

The rule is associated with an external file to which it has exported data.

External Data
File

The path to the associated external data file .
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UI Element Description

Column Names Indicates that the first row of your file is a header row, containing the names of
each column.

Available for import only.

Data
Synchronization

For import: Data is automatically re-imported from the external data file before
each Simulation session.

For export: Data is automatically exported to the external data file after a virtual
service Learning session.

Service
Operations

The operations in your virtual service that are configured for import or export.

By default, all of the virtual service's operations are selected. To change this
selection, click Change and edit the list of operations.

Sheet Relations Binding configuration for working with array data. You can define the
relationships between worksheets that is required for array binding.

Primary/Foreign Key: The drop-down lists display the columns in the external
data file. The format of the keys is <worksheet_name>.<column_name>. Select
a value for each key to define the relationship.

Add Adds a row, enabling you to define an additional relationship between primary
and foreign keys.

Available when working with array data.

Delete Removes the selected row.

Available when working with array data.

Refresh Data on
Confirm

Updates the data according to your new settings. For example, if you changed
the setting from Import to Export, the data is exported to the external file when
you click Finish.

New/Edit Function Dialog Box
The New Function f(x) dialog box enables you to create a new function to use in your datamodel. You
can then edit functions from the Edit Function dialog box.
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To
access

New Function dialog box: Use one of the following:

l In the DataModel Editor, click inside the function field (fx) for a column and select
New f(x).

l In the Virtualization Explorer, under DataModels, right-click the Functions folder, and
select New f(x).

Edit Function dialog box: In the Virtualization Explorer, under DataModels, expand
the Functions folder. Double-click a function to edit.

Relevant
tasks

"How to Define Rule Functions" on page 212

See also "Rule Functions" on page 203

User interface elements are described below:

UI
Element Description

Function Enter a function. For details on the variables you can use to configure a new, custom
function, see "How to Define Custom Functions" on page 230.

Name Enter a name for the new function or accept the default.

More... Opens the online help on how to define rule functions.

Change Columns Dialog Box
The Change Columns dialog box enables you to specify which columns are displayed in the data table
of a rule.
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To access Use one of the following:

l In the DataModel Editor, select Columns > Change
Columns.

l Right-click a column header and select Change Columns.

Relevant tasks "How toModify Virtual Service Behavior" on page 210

User interface elements are described below.

UI Element Description

Filtering
columns in the
tree

Enter text in the search field to filter the columns displayed in this dialog box.

Default Filter
Options

Displays default filters you can apply to assist you in viewing the list of columns.
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UI Element Description

Columns tree Select the columns that you want to display in the data table.

l When you click on a column name, it is highlighted for you in the currently
openmodel.

l Select an option from the drop-down list to change the current view in the
openmodel.

l Right-click an item in the tree to display additional options for
showing/hiding branches/children.

Note: Selecting a header level checkbox does not select all child headers.

In this example, theRequest box is selected, indicating that you have
selected the Request header to display in the DataModel Editor.

The shaded box for the Request header indicates that one or more child
headers are selected.

OK/Cancel Saves/discards your selections.

Edit Sheet Relations Dialog Box
This dialog box enables you to configure binding for an array. You can define the relationships between
worksheets that are required for array binding.
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To access Use one of the following within the data rule:

l When binding an array item, this dialog box opens automatically.

l Right-click the rule or column header and select External Data Properties. See
theSheet Relations area.

Relevant
tasks

"How toWork With External Data Sources" on page 231

Important
information

When there is a 1 to 1 relationship, there will be exactly one item in the array for each
row. Items of the array can be located on the sameworksheet as other data, and the
relationship will be specified as the sameworksheet column for the Primary and
Foreign Key. This works only for a one level array. It cannot be used if the array is part
of another array.

See also "Data Driving" on page 207

User interface elements are described below:

UI Element Description

Primary/Foreign
Key

The drop-down lists display the columns in the external data file. The format of
the keys is <worksheet_name>.<column_name>.

Select a value for each key to define the relationship.

Add Adds a row, enabling you to define an additional relationship between primary
and foreign keys.

Delete Removes the selected row.
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Data Format/Response Type/Choice Binding Dialog
Box
This dialog box enables you configure binding for working with different data formats (REST protocol),
different response types (SOAP protocol), or amessage structure containing different types.

To access The dialog box opens automatically when you start to bind to an Excel worksheet
columnwhere the response can contain different data formats, different response
types, or amessage structure which can be considered to contain different types.

Relevant
tasks

"How toWork With External Data Sources" on page 231

Important
information

Map choices to cell values based on predefined cell values read from an external data
source or by setting custom values.

See also "Data Driving" on page 207

User interface elements are described below:

UI Element Description

Default Data Format/Response
Type/Choice Binding

Used when no value from themapping table matches.

Data Format/Response
Type/Choice

Themapping table lists the real formats or types based on the
data in your external data file.

Cell Value To configure a value for each possible real type or format,
select a value from the drop-down list.
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Select Service Operation Dialog Box
This dialog box enables you to configure a virtual service to call external services.

To access 1. In the DataModel Editor, select the operation from which you want to call
the external service.

2. Click Activity > Import Activities, enter the path to theWSDL schema,
and click Next.

Important
information

Only SOAP and XML over HTTP service call activities are supported.

Relevant tasks "How toModify Virtual Service Behavior" on page 210

See also "DataModel Overview" on page 201

User interface elements are described below:

UI Element Description

Service operation The list of operations available for the service call
activity.

Add the activity after response Runs the activity after the response is sent to the
client.

By default, the service call activity is added to the
rule before the response.

Do not add an activity now. Import the
service description for later use.

Imports the service description document. No
activity is added to the current rule.
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Service Properties for XML Service Call Activity
These dialog boxes enable you to configure an XML virtual service to call external services.

To access 1. In the DataModel Editor, select the operation from which you want to call the
external service.

2. Click Activity > Import Activities. Enter the path to the XML schema (.xsd
file), and click Next.

Relevant
tasks

"How toModify Virtual Service Behavior" on page 210 (See Add/Edit service call
activity.)

See also "DataModel Overview" on page 201

User interface elements are described below:
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UI Element Description

Input/Output Message
Type

Select message elements for input and output messages. Available types
are displayed.

Real Service Endpoint Enter the URL for the service you are calling.

Show Endpoint
Topology

Displays a diagram of the service endpoint configuration.

Test Endpoint Checks that the endpoint is configured correctly.

Activity Properties Dialog Box
This dialog box enables you tomodify properties for a service call activity.

To access 1. In the DataModel Editor, expand a rule.

2. Right-click the column header of a service call activity, and select Activity
Properties.

Relevant
tasks

"How toModify Virtual Service Behavior" on page 210

See also l "Select Service Operation Dialog Box" on page 269

l "DataModel Overview" on page 201

User interface elements are described below:
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UI Element Description

State Indicates if the service call activity is currently enabled or disabled for the rule.

Click the on/off icon to change the state.

Name The name of the activity.

By default, this is the name of the operation in the called service.

Tip: You can edit this field. If you addmultiple activities calling the same
operation in the same service, give each activity a different name.

URL The endpoint location of the called service.

Delay after
response

Indicates the amount of time, in milliseconds, to wait after sending a response to the
client, before running the activity.

Available only for a service call activity that is scheduled for after the response.

FAQs: Data Model Editor
This section provides tips on working in the DataModel Editor.

For task details, see "How toModify Virtual Service Behavior" on page 210.

I can't see all my columns. Can I configure what is displayed?

To show/hide columns, use the Change Columns dialog box. To access, click theColumns button,
and select Change Columns.

Alternatively, click the x in a column header to hide a specific column.

Can I view the entire header structure?

Double-click headers to drill downwithin the header structure.

Some column headers are in italic text (header). What does that mean?

These are complex headers that include lower level headers under them. Double-click the header to
display its lower level headers, or change your selections in theChange Columns dialog box.

How does the 'Copy from' function work?

When you select theCopy from function for a column and then scroll over the other columns, an
indicator displays to show whether a source column is compatible with the target column.

Indicates a column that you can use as a source.
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Indicates a column that you cannot use as a source.

Click the desired source column to select.

What's the best way to work with array data?

It is recommended to work directly in the data row within the rule.

It's hard to work with all the columns in my message data. Is there a better way?

If your structure includes many columns, the Row Detail dialog box offers amore user friendly format
for viewing, entering, and editing datamanually. Right-click a row and select Row Detail.

I want to move some array data in my data model. Is there an easy way to do that?

Yes. In the Row Detail dialog box, right-click an array item and select Move Array Item.

Can I search within a row?

The Row Detail dialog box enables you to search the row to find specific text. Right-click a row and
select Row Detail.

I exported data to an Excel file, but I can't find the file. Where is it?

Hover over the import/export icon in the data rule to see the location of your external data file.

You can also right-click the rule and select External Data Properties for more information on the
external file.

How can I update column bindings for a data-driven rule?

Do one of the following:

l Expand a rule, and click the bind icon . A "preview" of your external data file displays within the
rule.

l Right-click a rule and select Open External Data.

I see more columns than I need to. How can I hide some of them?

To show/hide columns, use the Change Columns dialog box. To access, click theColumns button,
and select Change Columns.

Why is part of the row gray, with no visible data?

The headers are showing a different message structure. Double-click on the grayed area to switch
header structure.
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How can I add data as a message?

Right-click a rule and select Import Message.

I see metadata, but no actual data. Why don't I see the data?

The columns (headers) that contain the data are hidden. Click theColumns button, and select select
Change Columns to change the display settings.

Some column headers are marked with a red hash sign (#). What does that mean?

These columns are configured for datamasking. For details, see "DataMasking Dialog Box" on page
161.
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Chapter 9: Stateful Simulation
This chapter includes:

Stateful Simulation Overview 276

How to Simulate a Stateful Service 277

Stateful Layout View 278

HP Service Virtualization (3.61) Page 275 of 352



Stateful Simulation Overview
When simulating a service, the order of requests is often important. A servicemay return different
responses to the same request depending on the current state of the service. Service Virtualization can
simulate this type of stateful behavior.

A virtual service uses tracks to simulate stateful behavior. Tracks enable you to order
request/response pairs in a virtual service’s datamodel, to define the sequence in which they are used
during simulation.

Service Virtualization creates tracks during learning. You can alsomanually create and edit tracks.

During simulation, Service Virtualization evaluates each request to determine which track it fits into,
and in which position in the track, and returns the appropriate response.

How are tracks created?

Service Virtualization creates tracks automatically based on learned data. During learning, tracks are
split according to client sessions. Each session, as identified by a unique session ID, is placed into a
separate track.

How are different client sessions identified?

Service Virtualization identifies client sessions according to a specific message element or metadata.
Depending on the transport protocol a virtual service is using,Service Virtualization assigns a default
session identifier to the service. To achieve the result you want, you canmodify the session identifier
that is used for a specific virtual service. For example, for SOAP services over HTTP, the default
session ID is the IP address of a client sending requests. In the case of a proxy server, requests from
several clients may appear to be coming from the same IP address, and will not be split into separate
tracks.

What happens during learning?

When you record real service behavior, Service Virtualization splits the learned data into separate
tracks according to the session ID. Each time you place the virtual service into Learningmode, new
tracks are added, and identical tracks are removed to ensure that each track is unique. If you are using
external data sources in your datamodel, one linear track is created for each data driven rule.

What happens during simulation?

During simulation, separate sessions are simulated for each unique session ID.

Service Virtualizationmatches incoming client requests to data in the datamodel according to the
session ID and the relevant operation in the virtual service, and returns the appropriate response.

If incoming requests do not match a track exactly, heuristic simulation is performed to determine the
most similar track, with newer tracks taking priority. Service Virtualization calculates the probabilities
of all track positions in all tracks simultaneously to determine where in the simulated scenario this
request most likely fits.
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For task details, see "How to Simulate a Stateful Service" below.

How to Simulate a Stateful Service
This task describes how to configure a virtual service to simulate stateful behavior.

To learnmore, see:

l "Stateful Simulation Overview" on the previous page

l Shopping cart session sample projects. For details, see "Start Page" on page 28.

This task includes the following:

l "Virtualize stateful behavior" below

l "Edit tracks" on the next page

l "Create stateful behavior manually" on the next page

Virtualize stateful behavior

1. Prerequisite:

Service Virtualizationmust have information on themessage structure that the client uses. The
structure of request/responsemessages is stored in the service description. You provide this
information by doing one of the following:

n Placing the virtual service in Learningmode to record real service behavior. For example, for a
REST service.

n Importing a service description document, such as when creating a SOAP service using an
imported .wsdl service description document.

n Importingmessages into the virtual service's datamodel.

2. Define session identifiers:

a. In the Service Description Editor, under Session IDs Definition, click Edit.

b. In the wizard pages that open, specify values for session identifiers, and click Finish.

Client-initiated sessions: For a service in which sessions are determined based on a client
request, you can select an element of the request data to use as a session identifier. For
example, a user ID.
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Server-initiated sessions: For a service in which sessions are determined based on a server
response, you can select an element of the response data to use as a session identifier. For
example, a client may send a login request, and the server returns a session ID that will
identify the client session.

For user interface details, see "Session ID DefinitionWizard" on page 155.

3. Learn data again:

Service Virtualization uses the session IDs to create different tracks based on the learned data,
and uses the tracks to create different sessions during simulation.

Edit tracks

View andmodify tracks using the Stateful Layout view of the DataModel Editor. For user interface
details, see "Stateful Layout View" below.

On the DataModel Editor toolbar, click Stateful Layout to display the track pane.

l Filter tracks. Select an option underCurrent Rule Tracks to display all tracks or tracks for current
rule only.

l Edit a track.

n Click inside a track name to edit.

n Drag and drop items within a track to reorder.

l Delete a track. Delete the track only, or also delete the rows that include track positions of the
selected track.

Create stateful behavior manually

1. In the DataModel Editor, create a blank rule and add data rows.

2. Create a new track. On the toolbar, click Stateful Layout to display the track pane.

3. Drag and drop rows from the data rule into the Stateful Layout track pane, in the order that you
want.

For user interface details, see "DataModel Editor" on page 240 and "Stateful Layout View" below.

Stateful Layout View
This view enables you to order request/response pairs to define the sequence in which they are used
during a stateful simulation.
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To access In the DataModel Editor, click theStateful Layout button.

Important
information

Service Virtualization creates tracks automatically based on learned data and
Session ID definition. For details, see "How to Edit a Service Description" on page
109.

Relevant
tasks

l "How to Simulate a Stateful Service" on page 277

l "How to Edit a Service Description" on page 109

l "How toModify Virtual Service Behavior" on page 210

See also "DataModel Editor" on page 240

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Element Description

Track
Position
column

Located in themain pane of the DataModel Editor, indicates the track and track position
of the selected row. If the row is a part of multiple tracks, each instance is highlighted in
the tracks pane.

Right-click in the Track Position column for a given row and click Add to Track to add
the call to the sequence of calls in the track. You can add the row again to the same
track, or to a different track.

<track
pane>

Located in the right pane, displays the sequence of calls in the track. The order reflects
how the calls are used in a stateful simulation.

Select a call to highlight its row in the rule.

<track
name>

Located at the top of the track pane. Click to edit.
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UI
Element Description

<track
filter>

List of tracks in the datamodel. Options include:

l Current Rule Tracks

l All Tracks

You can display all tracks or tracks for the currently selected rule only.

Tip: Select multiple tracks and expand the track pane to view several tracks side
by side.

New
Track

Creates a new track.

Delete Deletes the currently displayed track. You can choose to delete the track only, or also
delete the rows that include track positions of the selected track.
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Chapter 10: Performance Modeling
This chapter includes:

PerformanceModel Overview 282

How toModify Virtual Service Performance 283

PerformanceModel User Interface 285
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Performance Model Overview
The PerformanceModel enables you to customize the performance of a service during simulation.

When you create a Virtual Service, Service Virtualization creates a PerformanceModel associated
with it. This model is then available to learn the performance of the real service and can be customized
to set specific performance rules either for the whole service, or its individual operations.

Each virtual service can havemultiple performancemodels. Prior to a Learning session, in which real
service behavior is recorded, you can select the performancemodel to which you want to save the
learned behavior. Prior to simulation, you can select whichmodel to use tomimic real service behavior,
including non-customizable models to ignore the performance or simulate the unavailability of a
service. For details on working with simulationmodels, see "How toManage SimulationModels" on
page 198.

You can configure a performancemodel in the following ways:

Performance Metrics

You canmanipulate virtual service performance using the following performancemetrics:

Basic Performance Criteria

Set levels for the following performance criteria for specific operations of the service:

l Response Time [ms] - the time for the service to process a request and return a relevant response.

l Threshold [hits/s] - themaximum number of requests and responses the service can process
without any impact on performance.

l Throughput Limit [MB/s] - themaximum data capacity the service can process.

l Transaction Limit [transactions/s] - themaximum number of responses per second that the virtual
service can send.

Advanced Performance Criteria

In addition to the basic criteria, set levels for the following criteria for specific operations of the service:

l Tolerance [%] - the acceptable range of variation in performance for the operation.

l Maximum Hits per Second - themaximum number of requests and responses the operation is
allowed to process.

l Maximum Response Time - themaximum time for a response at peak performance levels.
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Boosters

There are a number of boosters available which you can use tomanipulate some aspect of the service
performance. Service Virtualization applies the selected boost to the relevant performance criteria
during simulation.

The boosters include:

l CPU. CPU powermultiplication factor. Impacts the response time of the service.

l Network. Network throughput multiplication factor. Impacts the throughput limit.

l Cluster. Scalability multiplication factor. Impacts all measures simultaneously - response time, hit
rate, threshold, and throughput limit.

l Expert.Multiplication factors for response time, hit rate, and throughput limit values. You can
change eachmeasure separately.

Batch Simulation/Message Scheduling

To simulate a real service in which responses are delayed or postponed, you can create a schedule to
determine whenmessage responses are generated and sent from the virtual service to the client.

For example, users of a banking applicationmay enter transactions during the day, but the transactions
are not actually processed until the night. Or a user of an online shopping site may make a purchase
where some part of order is out of stock. The applicationmust hold onto the request until the item is
available, and only then process the order.

To simulate the real service, consider these questions:

l When do you want to send the responses? At specific times?With a delay after requests are
received?

l How many responses should be returned at once?

l Do you want to continue sending responses periodically at set intervals, or at specific times?

You can configure amessage schedule to publish responses according to your answers.

For task details, see "How toModify Virtual Service Performance" below.

For user interface details, see "PerformanceModel Editor" on page 286.

How to Modify Virtual Service Performance
This task describes how to edit the performancemodel to manipulate simulation behavior.

To learnmore about performancemodels, see "PerformanceModel Overview" on the previous
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page.

Manipulate performance metrics

Service-level view

1. In the Virtualization Explorer, double-click a performancemodel to open the PerformanceModel
Editor.

2. In the left pane, select the service name.

3. In theBooster drop-down box, select a performance criteria. For details on the available criteria,
see "PerformanceModel Editor" on page 286.

4. Use the booster controls to set the boost level for the selected boosters.

5. UnderModel, select theBoost or Throughput Limit check boxes to apply the performance
changes to the service and all its operations.

Clear the boxes tomanually set boosters for individual operations.

Operation-level view

1. Click an operation name in the left pane or in the operations table to view operation level detail for
that operation.

2. Click a performance value to edit.

3. Click Show Measured Data to display any recorded performance data in the graph.

Schedule message publishing

1. Open the PerformanceModel Editor.

2. Under Batch Simulation, click the name of the operation you want to schedule.

3. Configure the schedule. For user interface details, see "PerformanceModel Editor" on page 286.

Note: Performancemetrics that are defined for the performancemodel are enforced
regardless of the selectedmessage publishing schedule.

4. Switch the virtual service into Simulationmode.
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Performance Model User Interface
This section includes:

PerformanceModel Editor 286
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Performance Model Editor
The PerformanceModel Editor enables you to configure performancemetrics for a virtual service to use
during simulation. You can configure the performance for the whole service or for its individual
operations.

To access Use one of the following:

l In the Virtualization Explorer, double-click a performancemodel.

l In the Virtual Service Editor, under PerformanceModels, select a
performancemodel and click Edit.

Important
information

Click a value to edit.

Relevant tasks l "How toManage SimulationModels" on page 198

l "How toModify Virtual Service Performance" on page 283

See also "PerformanceModel Overview" on page 282

User interface elements are described below (unlabeled elements are shown in angle brackets):

Common Areas

UI Element Description

<performance
model name and
description>

The name and description of the datamodel. Click to edit.

<operations> Located in the left pane of the editor. Displays a list of the operations in the
service associated with the selected performancemodel.

By default, the service name is selected, and a performance overview is
displayed in themain pane of the PerformanceModel Editor. For details, see
Service Level View.

Enter text in the filter box to filter for specific operations in the list.

Select an operation from the list to display its details in themain pane of the
PerformanceModel Editor. For details, seeOperation Level View.

Edit Service
Description

Opens the Service Description Editor. For details, see "Service Description
Editor" on page 152.
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Service Level View

UI Element Description

Booster A set of boosters to provide high-level control of the operations selected in the
operation table.

Available boosters include:

l CPU. CPU powermultiplication factor.

l Network. Network throughput multiplication factor.

l Cluster. Scalability multiplication factor.

l Expert.Multiplication factors forResponse Time, Hit Rate, and Throughput
Limit values.

l None. Turn off all boosters.

Note: Youmust restart the simulation to apply changes.

<booster
controls>

The sliding controls and inputs enable you to set the boost level for the selected
booster. The setting affects the various performance criteria displayed in the
operation table.

Performance
Metrics

Enables you to set more granular settings for individual performance criteria for
individual operations. You can set the following:

l Response Time [ms]. The time for the service to process a request and return a
relevant response.

l Threshold [hits/s]. Themaximum number of requests and responses the
service can process without any impact on performance.

l Throughput Limit [MB/s]. Themaximum data capacity the service can
process.

l Transaction Limit [transactions/s]. Themaximum number of responses that
the virtual service can send per second.

To apply the performance changes to the service and all of its operations, select the
Boost or Throughput Limit check boxes at the top of the table.

Alternatively, select options separately for the service and per operation.

Click an operation name to open the operation level view for the specific operation.
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UI Element Description

Batch
Simulation

Enables you to define a schedule for sending responses back to the client
application.

Click an operation name to open the operation level view for the specific operation.

For details, see "Batch Simulation" on the next page.

Operation Level View

Performance Metrics

UI Element Description

<performance
graph>

The graph displays the expected performance based on the criteria set for the
operation.

Select Show Measured Data to view any recorded performance data in the graph.
Note: This option is displayed only after data is recorded for the service.

The graph is interactive. Move the graph elements to show the effects on
performance.

<performance
criteria>

Displays the advanced performance criteria for the operation with the option to edit
them. The following additional criteria are available:

l Tolerance [%]. The acceptable range of variation in performance for the
operation.

l Maximum Hits per Second. Themaximum number of requests and
responses the operation is allowed to process.

l Maximum Response Time. Themaximum time for a response at peak
performance levels.

Click a value to edit.
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Batch Simulation

UI Element Description

Scheduling
Start

Defines when the virtual service will start publishingmessage responses.

l After simulation launch with delay <x>. Set the amount of time after the start
of simulation that you want the virtual service to begin sending response
messages.

l At <time x> of the simulation start day. Define a set time on the day that
simulation is started to begin sending responsemessages.

Send
Responses

Defines when or how often responsemessages are sent.

Note:Responses are created immediately before they are sent, and not at the time
the request is received. This is important, for example, when the virtual service
includes service call activity, or date/time generator functions.

Options include:

l Periodically. Sendmessages every <x> amount of time. All waiting responses
are sent.

l At defined times. Send <x> messages at the specified time period.

In the first row, define the number of messages to send when the schedule starts.

Click Add to add a new row.

Double-click the time or message boxes to edit. Define time periods and the
number of messages to send at each time period.

Each row represents the amount of time to wait, after the previous time period,
before additional messages are sent.

For the last time period in the schedule, theNumber of Messages field may not
be filled in. All remainingmessages are sent.
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UI Element Description

Example:

The schedule is set to start 4 hours after simulation starts.

l 1st row:When the schedule starts, 1000messages are sent.

l 2nd row:One hour later, 2000messages are sent. It is now 5 hours after the
simulation started.

l 3rd row: Two hours later, 3000messages are sent. It is now 7 hours after the
simulation started.

l 4th row: Three hours later, all remainingmessages are sent. It is now 10
hours after the simulation started.
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Topology Overview
The Topology Editor enables you tomodel composite applications by creating a visual map of services,
called a topology. You can group them into larger composites, mark their types, and display the
service calls between them.

For task details, see "How toModel Composite Applications" below.

How to Model Composite Applications
This task describes how to create and configure a topology tomodel and test your composite
application.

This task is part of a higher-level task. For details, see "How to Use Service Virtualization" on page
23.

This task includes the following steps:

"Optional: Discover services" below

"Create a topology" on the next page

"Configure the topology" on the next page

"Test your composite application" on the next page

"Virtualize services" on page 294

"Reconfigure clients" on page 294

"Learn service behavior" on page 294

"Simulate service behavior" on page 295

1. Optional: Discover services

You can use Service Discovery to find all the services used by an application via a proxy agent.

Note: Supported for SOAP services only.

a. On the Start Page, click Discover Services to create a new virtualization project and starts
the discovery process, enabling you to find all services used by an application.

Alternatively, you can discover services in an existing project. In the Topology Editor, right-
click and select Start Service Discovery.

b. In the Service Discovery dialog box, configure your client application to use the Service
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Virtualization proxies. Youmust configure the proxies before running Service Discovery. For
user interface details, see "Service Discovery Dialog Box" on page 301.

c. Run your client application under test .

d. When services are discovered, click Stop Discovery. The discovered services are stored in
a group calledDiscovered Services. You can use them in your topology.

2. Create a topology

From themainmenu, select File > New > Topology. For user interface details, see "Summary of
New Topology Dialog Box" on page 296.

The new topology opens in the Topology Editor. By default, Service Virtualization creates the new
topology with one service which calls another, limited access service.

3. Configure the topology

You configure your topology using the Topology Editor. Tomodel your composite application,
create a visual map of your services, their types, and the connections between them.

a. From the Tools pane in the Topology Editor, add items to the topology.

b. Connect services using service call connectors. Move the cursor to the right edge of the
calling service until the hand icon displays. Then click and drag the connector to the called
service.

c. Tomark additional services as limited or secure, right-click a service and select Set Limited
Access orSet Secured Access. For additional configuration options, right-click a service to
view the context menu.

For user interface details, see "Topology Editor" on page 296.

4. Test your composite application

The process of testing your composite application includes the following steps:

a. virtualize services

b. reconfigure clients

c. learn services

d. simulate services

To test a service, in the Topology Editor, right-click the service and select Test. Services with
limited access, or services that may require reconfiguration are indicated with unique icons in the
Topology Editor. When you select to test a service that calls other limited access services, the
Task List opens on the right side of the Topology Editor. The Task List provides step-by-step
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instructions to guide you through the process required to virtualize, learn, and simulate the limited
access service that your service under test calls.

For user interface details, see the Task List section of the "Topology Editor" on page 296.

In addition, you can add and virtualize individual components, as described in the subsequent
steps in this task.

5. Virtualize services

In the Topology Editor, right-click a service and select Create Virtual Service. You can select an
existing virtual service from a drop-down list, or choose to create a new virtual service.For user
interface details on creating a new virtual service, see "Create New Virtual ServiceWizard" on
page 119.

If a service is marked as secure and does not already have any associated authentication Service
Virtualization cannot access the service and prompts you to provide authentication. For details on
setting authentication credentials, see "How to Set Security" on page 305.

6. Reconfigure clients

When you virtualize services, the services that call themmay require reconfiguration to use the
new virtual service in place of the real service.

a. A service that requires reconfiguration is displayed in the Topology Editor with an exclamation
point icon. Click the icon to open the Reconfigure Service dialog box, and update endpoint
details for real and virtual services as required.

b. When you have reconfigured the calling component, click Mark Completed and close the
dialog box. The exclamation point icon is no longer displayed.

7. Learn service behavior

You can learn the behavior of individual services in the topology of a composite application.

a. Prerequisites: Edit the topology, marking limited and secured services, and import service
descriptions for the services you want to learn.

b. In the Topology Editor, right-click each service for which you want to record the real service
behavior and select Learn.

c. Run your test through the composite application using a client or test script. Service
Virtualization records the requests and responses for the virtualized services and creates
simulationmodels for each one.

As you run your test, the Runtime View, located in the lower pane of the window, displays
details for each virtual service.

d. When you have finished recording, right-click each service you are recording and select Stop
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Learning. The services are placed in SimulateMode.

Alternatively, select Simulate and the application stops the learning process and switches
directly to simulating.

8. Simulate service behavior

You can test your composite application using the virtual services in your topology to simulate the
behavior of the real services.

a. Prerequisites: Learn the behavior of the services you want to simulate.

b. In the Topology Editor, right-click each service that you want to simulate and select Simulate.
The service is placed in Simulatemode.

c. Run your test through the composite application using a client or test script. Service
Virtualization processes the requests to each virtualized service and returns responses based
on the simulationmodel for each.

As you run your test, the Runtime View, located in the lower pane of the window, displays
details for each virtual service.

Topology User Interface
This section includes:

Summary of New Topology Dialog Box 296

Topology Editor 296

Service Discovery Dialog Box 301
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Summary of New Topology Dialog Box
This dialog box enables you to create a new virtualization project.

To access From themainmenu, select File > New > Topology.

Important
information

By default, Service Virtualization creates the new topology with one service which
calls another, limited access service.

Relevant tasks "How toModel Composite Applications" on page 292

See also "Topology Overview" on page 292

User interface elements are described below:

UI Element Description

Topology Displays the default name for the topology you are creating.

Change Opens the Change Topology dialog box, enabling you to edit the name of the
topology.

Create Creates the new topology.

Topology Editor
The Topology Editor enables you tomodel composite applications.
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To access In the Virtualization Explorer, double-click the topology you want to view or edit.

Relevant tasks "How toModel Composite Applications" on page 292

See also "Topology Overview" on page 292

User interface elements are described below:

Tools Pane

Located on the left side of the editor, enables you to drag and drop the following items to add to your
topology:

Note: If the Tools pane is not displayed by default, from themainmenu, select View > Tools.

UI Element Description

Service A service with no particular notation.

Limited
Service

A servicemarked as having limited access. Access to such services may be limited
due to time or financial constraints.

Secured
Service

A servicemarked as requiring authentication.

Group A box enabling you to organize services into larger composites for purposes of visual
mapping.

Context menu

Note: To discover services, right-click inside the Topology Editor and select Start Service
Discovery. For details on service discovery, see "Service Discovery Dialog Box" on page 301.

Right-click a service in the Topology Editor to access the following commands:
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Menu
Item Description

Set/Unset
Limited
Access

Marks or unmarks the selected service as having limited access.

Set/Unset
Secured
Access

Marks or unmarks the selected service as requiring authentication. For details on
setting authentication credentials, see "How to Set Security" on page 305.

Test Marks the selected service, indicating that it is "under test".

Service Virtualization analyzes calls, suggests services to virtualize, and creates a
task in the Task List.

When you select this option for a service that uses other services with limited access,
the Task List opens, displaying step-by-step instructions for testing the composite
application. For details, see Task List.

Preview
Test
Impact

Enables/disables the Test Impact highlighting bar.Service Virtualization analyzes client
calls and highlights services that youmay want to virtualize.

Learn
and
Simulate

Enables you to create a new virtual service or import an existing service, and then
places the service in Learningmode.

Create
Virtual
Service

Enables you to create a new virtual service or import an existing service. If you choose
to create a new virtual service, launches the Create Virtual Service wizard. For details,
see "Create New Virtual ServiceWizard" on page 119.

Rename Enables you to rename the selected service.

Delete Removes the selected service from the topology.

Service Annotation

The annotation for each service varies depending on its settings and various stages of configuration.

Service
Diagram Description

An empty service.

A servicemarked as having limited access.
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Service
Diagram Description

A servicemarked as secure, requiring credentials to access.

A virtualized service.

A virtualized service in LearningMode. Service Virtualization records any requests and
responses through this service and adds them to the associated SimulationModel.

A virtualized service in SimulatingMode. Service Virtualizationmonitors any requests to
this service and returns responses based on the associated SimulationModel.

Indicates a service that is "under test".

A service suggested for virtualization.

A service requiring attention because it calls a virtualized service andmay require
reconfiguration to call the virtual service instead of the real one.

Click the exclamation point icon to open the Reconfigure Service dialog box.

Task List

When you select to test a service that calls other limited access services, the Task List opens on the
right side of the Topology Editor. The Task List guides you through the process of testing your
composite application.

Note: The options in a step become available only after you have completed all previous
(prerequisite) steps. When you pass or skip a step, the options in that step are automatically
disabled.
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UI Element Description

Virtualize
Services

Includes the following options:

l Virtualize Services. Enables you to define a new virtual service or import an
existing service. If you choose to create a new virtual service, launches the
Create Virtual Service wizard. For details, see "Create New Virtual Service
Wizard" on page 119.

This option enables you to virtualize all relevant services as indicated in the Task
List.

l Customize Virtualization of Services. Enables you to select the services that
you want to virtualize. Select the desired services and click Virtualize Selected
Service.

When all themissing information for each service in complete, Virtualize Services is
marked as complete and you proceed to Reconfigure Clients.

Service Virtualization adds the virtual services, any new service descriptions, and a
data and performancemodel for each service to the Virtualization Explorer.

Reconfigure
Clients

Reconfigure the client to use the endpoints of virtual services in place of the real
service endpoints. This is required in cases where Service Virtualization can only
perform intrusive virtualization.

Includes the following:

l View. Displays instructions for reconfiguring clients.

l Save As. Saves the instructions as a text file.

l Mark as Completed.Marks the service under test as complete when you have
reconfigured it to use the virtual services in place of real services.

Learn
Services

Includes the following options:

l Learn Services. Places the virtual services in your composite application in
Learningmode. For details on Learningmode, see "Virtual Service Overview" on
page 97.

Run your test through the composite application using a client or test script.
Service Virtualization records the request and responses for each virtualized
service and creates a simulationmodel for each. As you run your test, the
Runtime View, located in the lower pane of the window, displays details for each
virtual service.

l Skip to Simulate Services. Proceed to service simulation without recording any
additional service communication. Select this option if you already have
simulationmodels for your composite application.

User Guide
Chapter 11: Composite Application Topology

HP Service Virtualization (3.61) Page 300 of 352



UI Element Description

Simulate
Services

Places the virtual services in your composite application in Simulationmode,
enabling you to simulate the behavior of the real services without using them.

Run your test through the composite application using a client or test script. Service
Virtualization processes the requests from your service under test to each virtualized
service and returns responses based on the simulationmodel for each. As you run
your test, the Runtime View, located in the lower pane of the window, displays
details for each virtual service.

Service Discovery Dialog Box
This dialog box enables you to start Service Discovery to discover all the services used by an
application.

To access Do one of the following:

l On the Start Page, click Discover Services to create a new virtualization
project and start the discovery process.

l In an existing project, in the Topology Editor, right-click and select Start
Service Discovery.

Important
information

Supported for SOAP services only.

Relevant tasks "How toModel Composite Applications" on page 292

See also "Topology Overview" on page 292

User interface elements are described below:
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UI Element Description

Server Currently supported for the Service Virtualization embedded server only.

Service
Virtualization
proxies

Youmust configure your client application to use the Service Virtualization
proxies before running Service Discovery.
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Virtual Service Security Overview
This section describes how security is handled by Service Virtualization. Service Virtualization
supports virtualization of secured services using either HTTP transport level security or a subset of
SOAP message level security.

Security consists of four components:

l Confidentiality. The data is encrypted. Only an ultimate recipient can read the data.

Service Virtualizationmust be able to decrypt themessage passed to the virtual service in order to
learn the service. It must also be able to encrypt messages passed to the real service.

l Integrity. The data is signed. A recipient can validate that the data has not beenmodified during
transmissions.

Service Virtualizationmust be able to validate signatures in messages received from clients and
from the real service. It must also be able to signmessages sent to clients and the real service.

l Authentication. The identity of a client is transferred with themessage.

Service Virtualization does not validate received client credentials. In some scenarios, incoming
credentials are secured and are not directly readable. Therefore, the virtual servicemust have these
credentials (certificates with private keys or user names with passwords) defined in Service
Virtualization's Credential Store, to be able to compute the secured value and pass it to the real
service.

l Authorization. The service validates that an authenticated client can execute the required
operation.

Service Virtualization does not handle authorization. Authorization logic is left for the real service.

You can set the following levels of security in Service Virtualization:

l Transport Security. Transport level security is point-to-point. Security is ensured only on the
transport level connection between twomachines. Transport level integrity and confidentiality is
ensured through SSL / TLS (HTTP(s) Proxy agent or the HTTPS Gateway agent) and transport
level authentication is ensured with HTTP authenticationmechanisms.

Transport authentication in service virtualization is used only in Stand-By and Learningmodes to
access the real service. It is transparently managed by the HTTP Gateway or HTTP(S) proxy
agents. Transport authentication only requires that correctly configured credentials are available in
Service Virtualization's Credential Store.

l Message Security.Message level security is end-to-end. Security is ensured on themessage level
– security is part of message data which can be passed throughmany intermediaries (many
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connections) without revealing unsecuredmessage content.

Message security in Service Virtualization is used for Stand-By, Learning, and Simulationmodes.

l Mixed Security.Mixed security uses transport security to ensure confidentiality and integrity and
message security to pass client credentials (authentication). This security configuration requires
the use of the HTTPS agent andmessage security modes with names ending with OverTransport.

For task details, see "How to Set Security" below.

How to Set Security
This task describes how to set security for your virtual service.

l This task is part of a higher-level task. For details, see "How to Use Service Virtualization" on
page 23.

l To learnmore about Service Virtualization security, see "Virtual Service Security Overview" on
the previous page.

This task includes the following steps:

l "Set authentication credentials" below

l "Set message security" below

l "Set transport security" on the next page

Set authentication credentials

Some services may require client authentication on either the transport or message level. When
virtualizing these services, Service Virtualization needs to know the client credentials used to connect
to the real service. The only exception is a scenario wherein a real service with HTTP transport
authentication (Basic, Digest, NTLM) is virtualized through the HTTP(S) proxy agent. In this scenario,
authentication requests are forwarded. Service Virtualization does not need to have the credentials in
the service’s credential store.

In the Virtual Service Editor, expand Security Settings and click Edit Credential Store to configure the
required settings.

For user interface details, see "Edit Credential Store Dialog Box" on page 316.

Set message security

Set message security for your virtual service in the Virtual Service Editor. For task details, see "How to
Set Message Security" on the next page.
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Set transport security

Transport authentication in Service Virtualization is used in Standby and Learningmodes to access the
real service. It is transparently managed by the HTTP Gateway or HTTP(S) proxy agents. Transport
authentication only requires that correctly configured credentials are available in Service
Virtualization's Credential Store.

For task details, see "How to Set Transport Security" on page 312.

How to Set Message Security
This task describes how to configure settings for the default message security modes.

l This task is part of a higher-level task. For details, see "How to Set Security" on the previous
page.

l To learnmore about Service Virtualization security, see "Virtual Service Security Overview" on
page 304.

In the Virtual Service Editor, under Security Settings, configure one of the following security modes for
your virtual service:

l "Configure CertificateOverTransport mode" below

l "Configure UserNameOverTransport mode" on the next page

l "ConfigureMutualCertificate mode" on page 309

l "ConfigureMutualCertificateDuplex mode" on page 310

l "Configure SupportingCertificateOverTransport mode" on page 312

Configure CertificateOverTransport mode

Certificate over transport mode uses an endorsing supporting binary token over HTTPS:

l Transport security binding

n Algorithm suite: Basic256

n Layout: Strict

l Endorsing supporting token

n X509Token (WssX509V3Token10) always included to recipient

n Inclusion type: MustSupportRefThumbprint / RequireThumbprintReference
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To configure CertificateOverTransport mode:

1. Prerequisites:

a. Youmust have created a virtual service.

b. The Service Virtualization Credential Storemust contain an identity with each used client
certificate.

c. Certificates must contain a private key.

2. In the Virtual Service Editor, expand Security Settings. Under Message Security, select Enabled.

3. In theMode drop-down box, select CertificateOverTransport.

Note: Do not configureReal Service Identity orVirtual Service Identity

4. Click Advanced Settings to open the AdvancedMessage Security Settings dialog box, and
configure as follows:

n Protection Level. Tthis setting has no effect because encryption and signing are provided by
the transport level (HTTPS).

n Message Protection Order. This setting has no effect because encryption and signing are
provided by the transport level (HTTPS).

n Message Security Version. Oonly WS-Security 1.1 is supported because this configuration
mode requires thumbprint token inclusionmode which is not supported inWS-Security 1.0.

n Require Derived Keys. This setting should not be changed.

n Include Timestamp. This settingmust be checked because the endorsing supporting token
passed in the request must sign the timestamp header.

n Allow Serialized Signing Token on Reply. This setting has no effect.

Configure UserNameOverTransport mode

User name over transport mode uses a signed supporting user name token over HTTPS:

l Transport security binding

n Algorithm suite: Basic256

n Layout depends onWS-Security version configured inAdvanced settings:
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o WS-Security 1.0: Lax

o WS-Security 1.1: Strict

l Endorsing supporting token

n UserNameToken (WssUsernameToken10) always included to recipient.

Only PasswordText token type is supported.

To configure UserNameOverTransport mode:

1. Prerequisites:

a. Youmust have created a virtual service.

b. The Service Virtualization Credential Storemust contain an identity with each user and
password used for authentication to the real service.

2. In the Virtual Service Editor, expand Security Settings. Under Message Security, select Enabled.

3. In theMode drop-down box, select UserNameOverTransport.

Note: Do not configureReal Service Identity orVirtual Service Identity

4. Click Advanced Settings to open the AdvancedMessage Security Settings dialog box, and
configure as follows:

n Protection Level. This setting has no effect because encryption and signing are provided by
the transport level (HTTPS).

n Message Protection Order. This setting has no effect because encryption and signing are
provided by the transport level (HTTPS).

n Message Security Version. Layout used for security header:

o Message security versions usingWS-Security 1.0 use Lax layout for security header.

o Message security versions usingWS-Security 1.1 use Strict layout for security header.

n Require Derived Keys. This setting has no effect.

n Include Timestamp. This setting controls if requests and responses must contain a security
timestamp.

n Allow Serialized Signing Token on Reply. This setting has no effect.
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Configure MutualCertificate mode

MutualCertificate is amode with asymmetric security binding (WS-Security 1.0) which uses both client
and server certificates to securemessages over unsecured transport (HTTP):

l Assymetric security binding

n Initiator token: X509Token (WssX509V3Token10) always included to recipient.

n Recipient token: X509Token (WssX509V3Token10) never included.

n Algorithm suite: Basic256

n Layout: Strict

n Token inclusion type:

o MustSupportRefKeyIdentifier

o MustSupportRefIssueSerial

To configure MutualCertificate mode:

1. Prerequisites:

a. Youmust have created a virtual service.

b. The Service Virtualization Credential Storemust contain an identity with a real service
certificate.

If the certificate does not contain a private key, the Credential Storemust also contain an
identity for the virtual service, with a certificate containing a private key.

c. The Credential Storemust contain an identity with each used client certificate.

d. Client certificates must contain a private key.

2. In the Virtual Service Editor, expand Security Settings. Under Message Security, select Enabled.

3. In theMode drop-down box, selectMutualCertificate.

4. In theReal Service Identity drop-down box, select an identity configured in theCredential
Store.

If the identity for the real service does not contain a certificate with a private key, or if you want to
use separate identity for the virtual service, select an identity configured in the Credential Store for
Virtual Service Identity. This identity must contain a certificate with a private key.

5. Click Advanced Settings to open the AdvancedMessage Security Settings dialog box, and
configure as follows:
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n Protection Level. Configures the level of security applied to eachmessage.

n Message Protection Order. Configures the order of protection operations used to secure
messages.

n Message Security Version. Use only WS-Security 1.0.

n Require Derived Keys. This setting should not be changed.

n Include Timestamp. This setting controls if requests and responses must contain a security
timestamp.

n Allow Serialized Signing Token on Reply. This setting has no effect.

Configure MutualCertificateDuplex mode

MutualCertificateDuplex mode with asymmetric security binding (WS-Security 1.0 and 1.1) uses both
client and server certificates to securemessages over unsecured transport (HTTP). The difference
betweenMutualCertificate andMutualCertificateDuplex is that MutualCertificateDuplex security mode
also sends the recipient’s signing token back to the initiator.

l Assymetric security binding

n Initiator token: X509Token (WssX509V3Token10) always included to recipient.

n Recipient token: X509Token (WssX509V3Token10) always included to initiator.

n Algorithm suite: Basic256

n Layout: Strict

n Token inclusion type depends onWS-Security version configured in Advanced settings::

o WS-Security 1.0

l MustSupportRefKeyIdentifier

l MustSupportRefIssueSerial

o WS-Security 1.1

l MustSupportRefThumbprint / RequireThumbprintReference

To configure MutualCertificateDuplex mode:
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1. Prerequisites:

a. Youmust have created a virtual service.

b. The Service Virtualization Credential Storemust contain an identity with a real service
certificate.

If the certificate does not contain a private key, the Credential Storemust also contain an
identity for the virtual service, with a certificate containing a private key.

c. The Credential Storemust contain an identity with each used client certificate.

d. Client certificates must contain a private key.

2. In the Virtual Service Editor, expand Security Settings. Under Message Security, select Enabled.

3. In theMode drop-down box, selectMutualCertificateDuplex.

4. In theReal Service Identity drop-down box, select an identity configured in theCredential
Store.

If the identity for the real service does not contain a certificate with a private key, or if you want to
use separate identity for the virtual service, select an identity configured in theCredential Store
for Virtual Service Identity. This identity must contain a certificate with a private key.

5. Click Advanced Settings to open the AdvancedMessage Security Settings dialog box, and
configure as follows:

n Protection Level. Configures the level of security applied to eachmessage.

n Message Protection Order. Configures the order of protection operations used to secure
messages.

n Message Security Version. this setting defines how the binary token is referenced in the
request message.

o Message security versions usingWS-Security 1.0 requires either issuer serial number or
key identifier of the certificate.

o Message security versions usingWS-Security 1.1 requires thumbprint of the certificate.

n Require Derived Keys. This setting should not be changed.

n Include Timestamp. This setting controls if requests and responses must contain a security
timestamp.

n Allow Serialized Signing Token on Reply. Youmust select this setting because the
recipient’s signing token is always send back to an initiator.
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Configure SupportingCertificateOverTransport mode

Supporting certificate over transport mode uses a supporting binary token over HTTPS:

l Transport security binding

n Algorithm suite: Basic256

n Layout: Strict

l Endorsing supporting token

n X509Token (WssX509V3Token10) always included to recipient

n Inclusion type: MustSupportRefThumbprint / RequireThumbprintReference

To configureSupportingCertificateOverTransport mode:

1. Prerequisites:

a. Youmust have created a virtual service.

b. The Service Virtualization Credential Storemust contain an identity with each used client
certificate.

2. In the Virtual Service Editor, expand Security Settings. Under Message Security, select Enabled.

3. In theMode drop-down box, select SupportingCertificateOverTransport.

Note:

n Do not configureReal Service Identity orVirtual Service Identity.

n This mode does not support advanced configuration.

How to Set Transport Security
This task describes how to set transport security for your virtual service.

l This task is part of a higher-level task. For details, see "How to Set Security" on page 305.

l To learnmore about Service Virtualization security, see "Virtual Service Security Overview" on
page 304.

Transport level security is completely handled by the HTTP based agent. The virtual and real services
can use HTTP authentication to prevent unauthorized use. The service can use basic, digest, NTLM
authentication, or Mutual HTTPS.
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This task includes the following:

l "HTTPS andmutual authentication" below

l "HTTP authentication over HTTP(S) Proxy agent" on the next page

l "HTTP authentication over HTTP / HTTPS Gateway agent" on the next page

l "Windows accounts for HTTP authentication" on page 315

HTTPS and mutual authentication

Services secured with HTTPS are supported by either the HTTPS Gateway agent or the HTTP(S)
Proxy agent. Both agent types also support Mutual HTTPS where the client authenticates itself with a
client certificate. To useMutual HTTPS, the credential storemust contain a client certificate and its
private key for every client accessing the virtual service. For details on setting authentication
credentials, see "Edit Credential Store Dialog Box" on page 316

Themutual HTTPS authentication for the HTTPS Gateway agent is handled by the client operating
system. Therfore, the certificate of the certification authority that issued all client certificates in use
must be imported into the local computers’s Trusted Root Certificate Authorities store.

To import the Certification Authority's certificate into the local system's certificate store:

1. From the command line orWindows Start menu Search bar, typemmc to runMicrosoft
Management Console.

2. From the File menu, select Add/Remove Snap-in.

3. From the Available Snap-ins list, select Certificates and click Add. In the screens that follow,
select Computer account, and then Local Computer. Click Finish.

4. To import the certificates, expand the Certificates (Local Computer) node, as shown below. Under
Trusted Root Certification Authorities, right-click Certificates and select All Tasks > Import.

5. Follow the on-screen directions to import the certificates.
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HTTP authentication over HTTP(S) Proxy agent

When using a proxy agent and running the virtual service in Stand-By or Learningmode, the
authentication is fully transparent and the virtual service does not need any further configuration. The
entire security handshake is passed from the client to the real service through the proxy, and client
credentials are validated just by the real service.

HTTP authentication is not used when the service is in Simulatingmode.

HTTP authentication over HTTP / HTTPS Gateway agent

When using the gateway agent and running the virtual service in Stand-By or Learningmode, the client
authenticates to the virtual service and the virtual service authenticates to the real service. The virtual
servicemust be able to validate a client’s credentials and pass them to the real service, meaning that
the servicemust have all user names and passwords in the credential store.

There are several steps to set this authentication:

1. All users who are authenticating to your servicemust be present in theWindows system where
the virtual service is running. They can be added as local users of themachine or added to the
domain to which the computer belongs. The username and passwordmust be the same as the one
the client uses to authenticate to the real service.

Note: HTTP digest authentication only works with domain users, not local ones. The domainmust
have reversibly encrypted passwords. See IIS documentation for details.

2. To delegate requests to the real service (when learning or in stand-by mode), the username and
passwordmust be in the service's credential store.

a. In the Virtual Service Editor, expand Security Settings and click Edit Credential Store.

b. Click Add Identity.
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c. Enter Identity details and supply a certificate if required.

d. Click OK to add the identity andOK again to close the Credential Store.

Note: When using HTTP Basic authentication, credentials missing in the credential store are
automatically detected and can be simply added via the Fix It command in the Problem List.

HTTP authentication is not used when the service is in simulatingmode.

Windows accounts for HTTP authentication

Basic, digest and NTLM authentication in the HTTP / HTTPS Gateway agent is supported only with
Windows accounts:

1. If the computer running Service Virtualization is in the same domain as the service host, make
sure the domain users are able to log on to themachine the application is running on. Clients
authenticated on the real servicemust be able to authenticate on themachine running the virtual
service.

2. If machines cannot be placed in the same domain, create local windows or domain user accounts
(domain users still need to be able to log on themachine the application is running on) with the
same names that the client is using to authenticate to the service.

Note: If you would like to use the HTTP Digest authentication, use only domain user accounts as
local user accounts will not authenticate.

Security User Interface
This section includes:

Edit Credential Store Dialog Box 316

AdvancedMessage Security Settings Dialog Box 317
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Edit Credential Store Dialog Box
This dialog box enables you to add, modify, or delete the users or certificates in the credential store for
the selected service.

To access In the Virtual Service Editor, expand Security Settings and click Edit Credential
Store.

Important
information

When creating credentials for transport security over the HTTP(S) Gateway agent,
the user of the virtual servicemust be a validWindows account. This Windows
account can be one of the following:

l A domain account. This is supported automatically.

l A local account. If it does not already exist, youmust create a local Windows
account on themachine hosting the Service Virtualization Designer or standalone
server. Youmust use the same user name and password.

Relevant
tasks

"How to Set Security" on page 305

See also "Virtual Service Security Overview" on page 304

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Element Description

<user
grid>

Displays the users and credentials defined in the credential store for this service.
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UI
Element Description

Add
Identity

Opens the Add Identity dialog box, enabling you to define a new identity to add to the
credential store.

Enter a username and password. These credentials can represent either aWindows
account (for transport security - Basic, Digest, or NTLM) or other type of user credentials
used by the real service (for message security).

Click Show password to display the password.

Click the browse button to select a certificate to add. The following certificate types are
supported: .pfs, .p12, .cer, .der, .crt. Click OK. If the certificate's private key requires a
password, you are prompted to enter the password. You can also export an existing
certificate.

Edit Enables you tomodify user credentials, or export a certificate. Select an identity and click
Edit to open the Edit Identity dialog box.

Delete Enables you to remove user credentials. Select one or more identities in the grid and click
Delete.

Import Enables you to select identities to add to the service.

In the Import Identities dialog box, underServices, select the virtual service containing
the identity you want to import. Then under Identities, select the identity to import into
your virtual service.

Advanced Message Security Settings Dialog Box
This dialog box enables you to set advanced options for message security.

To
access

In the Virtual Service Editor, under Security Settings, configure basic message security
options and then click Advanced Settings.
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Relevant
tasks

"How to Set Message Security" on page 306

See also "Virtual Service Editor" on page 144

User interface elements are described below.

UI Element Description

Protection Level The level of security applied to eachmessage. This configuration has service
scope levels. All messages must have the same security requirements.
Options include:

l None.

l Sign.

l Encrypt and Sign.

Message
Protection Order

The order of protection operations used to securemessages. Options include:

l Sign before encrypt.

l Sign before encrypt and encrypt signature.

l Encrypt before sign.

Message
Security Version

The set of WS-* specifications used to establish security.

Require Derived
Keys

Supporting tokens must use derived keys.

Include
Timestamp

Messages must contain a security timestamp.

Allow Serialized
Token on Reply

Replies can contain a service token used to sign themessage. This setting is
used only for asymmetric security bindings.
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Chapter 13: HP Test Automation Tools
Integration
This chapter includes:

HP Test Automation Tools Integration Overview 320

Unified Functional Testing 320

Performance Center and Load Runner 320

Performance Counters 321
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HP Test Automation Tools Integration Overview
Service Virtualization can be integrated with HP test automation tools. The virtual services are
managed via the tests, and the performancemonitors exposed by the virtual services are used by the
performance testing tools.

Note: Virtual services must be deployed to the Service Virtualization Server for this integration.
Integration with virtual services deployed on the embedded server is not supported. For more
details on the HP Service Virtualization Server, see theHP Service Virtualization Installation
Guide.

Service Virtualization integrates with HP Unified Functional Testing, HP LoadRunner, and HP
Performance Center. For details on currently supported versions, see the Integrations Page on the
HP Software Support Online web site at: http://support.openview.hp.com/sc/solutions/index.jsp.

Unified Functional Testing
Service virtualization projects can be integrated with HP Unified Functional Testing (UFT). For details,
see the HP UFT documentation.

The virtual services are thenmanaged by the test after the integration.

l The simulation start is triggered by the test start. Make sure that the virtual services are already
deployed on the Service Virtualization Server.

l Particular data and performancemodels can be selected for the test.

l Simulating orStandby modes using the real service are chosen during the test.

Performance Center and Load Runner
Service virtualization projects can be integrated with the Performance Center or Load Runner
Scenarios. For details, see Performance Center or Load Runner Documentation.

The virtual services are thenmanaged by the test after the integration.

l The simulation start is triggered by the test start. Make sure that the virtual services are already
deployed on the Service Virtualization Server.

l Specific data and performancemodels can be selected for the test.

l Simulating orStandby modes using the real service are selected during the test.
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Performancemonitors exposed by virtual services are used immediately in the Performance Center or
Load Runner Controller. The performancemonitors exposed by Service Virtualization are named
Services andOperations.

l TheServices performance counter provides measurement data per virtual service.

l TheOperations performance counter provides data per virtual service and service operation.

For more details, see "Performance Counters" below.

Performance Counters
You canmonitor Service Virtualizationmessage processing using predefined performance counters.
The performance counters are created during installation of either the Service Virtualization Designer or
the Service Virtualization Server. You can then view the counters inWindows PerformanceMonitor.
You can also use the performance counters to monitor Service Virtualization that is running on a remote
machine. The uninstallation of both the Designer and Server delete the counters from theWindows
system.

This section includes:

l "Performance Counter Categories" below

l "Performance Counter Instances" on page 323

l "RemoteMonitoring" on page 323

Performance Counter Categories

There are several Service Virtualization performance counter categories added to theWindows
PerformanceMonitor:

HP Service Virtualization - Services: TheServices performance counters providemeasurement
data per virtual service. Both the Designer and the Server write their data to these same counters. For
details, see Services.

HP Service Virtualization - Operations: TheOperations performance counters provide data per
virtual service and service operation. Both the Designer and the Server write their data to these same
counters. For details, seeOperations.

HP Service Virtualization - Server Statistics: The Server Statistics performance counters provide
data for a standalone Service Virtualization Server, and for the services deployed on the server. Only
the Service Virtualization Server writes data to these counters. For details, see Server Statistics.
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TheServices performance counters include the following:

Counter Name Counter Description Units

Throughput The data capacity of the virtual service. MB/s

HitRate The number of requests and responses processed by
the virtual service.

hits/s

AverageResponseTime The average time for the virtual service to process a
request and return a relevant response.

ms

DataSimulationAccuracy The accuracy of datamodel emulation of the real
service by the virtual service.

%

PerformanceSimulationAccuracy The accuracy of performancemodel emulation of the
real service by the virtual service.

%

TheOperations performance counters include the following:

Counter Name Counter Description Units

Throughput The data capacity of the virtual service operation. MB/s

HitRate The number of requests and responses processed by the virtual
service operation.

hits/s

AverageResponseTime The average time for the virtual service to process a request and
return a relevant response for the operation.

ms

TheServer Statistics performance counters include the following:

Counter Name Counter Description

Connections The number of connections from clients to Service Virtualization agents.

DbResponseTime Communication latency between the Service Virtualization Server and
the database.

HitRate The number of requests and responses processed by all virtual services
running on the Service Virtualization Server.

MessageSize The averagemessage size for all services deployed on the Service
Virtualization Server.

Throughput The average data capacity for all services deployed on the Service
Virtualization Server.

TransactionsPerSecond The average value for all services deployed on the Service Virtualization
Server.
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Performance Counter Instances

Service Virtualization creates instances of all the performance counters for each virtual service that is
deployed locally, either on the Service Virtualization Designer's embedded server, or on the Service
Virtualization Server.

Instance names are created in the following format:

l For services: <service_name>

l For operations: <service_name>_<operation_name>

l For server statistics: server statistics. The instance is created during installation of the Service
Virtualization Server. Data is updated on the Server machine only, when the Server is running.

For example, for a locally deployed virtual service calledHelloWorldwhich has two operations named
Hello andBye, the performance counters in the local system have the following instances:

Counter
Category Counter Name

Counter Instance
Name

Helloworld Service

Services AverageResponseTime helloworld

HitRate helloworld

Throughput helloworld

DataSimulationAccuracy helloworld

PerformanceSimulationAccuracy helloworld

Hello
Operation

Bye
Operation

Operations AverageResponseTime helloworld_
hello

helloworld_
bye

HitRate helloworld_
hello

helloworld_
bye

Throughput helloworld_
hello

helloworld_
bye

Remote Monitoring

You can use the performance counters to monitor Service Virtualization that is running on a remote
machine.
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To remotely access the performance counters, youmust use aWindows user account with appropriate
privileges on the remotemachine. You can create this account in the following ways:

l Automatically. During installation of Service Virtualization, you have the option to create a user
account that is automatically configured with the proper privileges. For details, see theHP Service
Virtualization Installation Guide.

l Manually. If you create theWindows user account manually, youmust add this user to the default
Windows groupPerformance Monitor Users. InWindows XP, add the user to the
Administrators group.
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Chapter 14: HP Application Lifecycle
Management (ALM) Integration
This chapter includes:

HP ALM Integration Overview 326

How toWork with HP ALM 326

FAQs: ALM Integration 329
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HP ALM Integration Overview
The integration of Service Virtualization with HP Application Lifecycle Management (ALM) enables you
to store your Service Virtualization projects as test resources in ALM. This can facilitate the use of the
virtual services by other users, or by testing tools.

For details on currently supported versions of ALM, see the Integrations Page on the HP Software
Support Online web site at: http://support.openview.hp.com/sc/solutions/index.jsp.

The ALM integration enables you to:

l Save a virtualization project in ALM.When you save a virtualization project, you can save it in
the file system, or in the ALM repository . If you choose to save the virtualization project in ALM, it
is stored as a resource in the Test Resources module of the selected ALM project.

l Collaborate on virtual service design.Multiple users can work with a virtualization project that is
stored in ALM. ALM enables you to control this process by ensuring that changes aremade by only
one user at a time.

l Reuse a virtualization project. You can copy a project that is stored in ALM, and save it in either
ALM or in the file system.

Tip: You can also add a project to existing solutions. For more details on working with projects,
see "How toManage Virtualization Projects" on page 108.

For task details, see "How toWork with HP ALM" below.

How to Work with HP ALM
This task describes how to integrate Service Virtualization with HP Application Lifecycle Management
(ALM).

To learnmore about integrating with ALM, see "HP ALM Integration Overview" above.

This task includes the following:

"Prerequisite: Connect to ALM" on the next page

"Save a virtualization project in ALM" on the next page

"Open a virtualization project saved in ALM" on page 328

"Copy a virtualization project" on page 328

"Work with service templates" on page 328

"Work with an ALM version controlled project" on page 329

User Guide
Chapter 14: HP Application Lifecycle Management (ALM) Integration

HP Service Virtualization (3.61) Page 326 of 352

http://support.openview.hp.com/sc/solutions/index.jsp


Prerequisite: Connect to ALM

To perform any of the steps in this task, youmust first connect to ALM.

1. From themainmenu, select ALM > ALM Connection.

2. Enter the ALM URL, in the following format: <ALM server name or IP address>:<port
number>/qcbin.

3. Enter a username and password for connecting to the server. Click Connect.

4. Select an ALM domain and project, and click Login.

5. Select Restore Connection on Startup to automatically log in to ALM each time you start the
Service Virtualization Designer.

Save a virtualization project in ALM

You can save new and existing projects in ALM.

To create a new project and save it in ALM:

When you create a new virtualization project, you can choose to save the project in the file system, or
in ALM.

1. From themainmenu, select File > New > Virtualization Project. For more details on creating a
new project, see "How toManage Virtualization Projects" on page 108.

2. In the Summary of Virtualization Project dialog box, click Change to modify the Path field.

3. In the Change Project dialog box, click theBrowse button to select a place to save the new
project.

4. In the Browse dialog box, select ALM Resources to save the new project on the ALM server to
which you are connected.

Tip: Create a new folder underALM Resources for your virtualization project. All project files
and services will be saved under that folder.

To save an existing project in ALM:

1. In the Service Virtualization Designer, open a project that is saved in the file system.

Tip: On the Start Page, under Recent Projects, hover over a project name to see the full path
to the saved project.

2. From themainmenu, select File > Save Project As. In the Save dialog box, select
ALM Resources to save a copy of the project on the ALM server to which you are connected.
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Open a virtualization project saved in ALM

To open a project, do one of the following:

l From themainmenu, select File > Open Project/Solution. In the Open dialog box, select ALM
Resources, and select a project.

l On the Start Page, underRecent Projects, select a project.

Tip: Hover over a project name to see the full path to the saved project. Projects saved in ALM
are displayed with the [ALM-RESOURCE] prefix.

If you try to open a project that is already opened, you are notified that the project is locked by another
user. If you choose to open the project, it is opened in read-only mode.

Copy a virtualization project

You can copy a Service Virtualization project stored in ALM.

1. Open the project in Service Virtualization.

2. From themainmenu, select File > Save Project As. Select a location in ALM or in the file
system, and enter a name for the new project.

Work with service templates

You can save a service as a template in ALM, and create new services from templates saved in ALM.

To save a service as a template in ALM:

1. In the Virtualization Explorer, right-click the service and select Save as Template.

2. In the Save dialog box, select ALM Resources, and select a folder for saving the service
template.

To create a virtual service from a template saved in ALM:

1. Select one of the following:

a. From themainmenu, select File > New > Virtual Service From Template.

b. In the Virtualization Explorer, right-click a virtualization entity and select Add > Virtual
Service From Template.

2. In the Open dialog box, select ALM Resources, and select a template for creating the new virtual
service.
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Work with an ALM version controlled project

l Open a Service Virtualization project that is saved in ALM.

If the project is currently checked in, you are prompted to check it out.

If you do not want to check out the project, click No. The project is opened in read-only mode.

To check out the project at a later time, from themainmenu, select ALM > Check out.

l Check in your changes.

From themainmenu, select ALM > Check in.

Alternatively, in the Virtualization Explorer, right-click the project name and select Check In to
ALM.

l Save your changes without checking in.

From themainmenu, select File > Save. You are prompted to check in the project. If you choose
no, your changes are uploaded and saved in ALM in the checked out version.

l Discard your changes without saving.

From themainmenu, select ALM > Undo Check Out.

l View version history.

From themainmenu, select ALM > Version History.

For full details on working with version control in HP ALM, see theHP Application Lifecycle
Management User Guide.

FAQs: ALM Integration
This section provides tips on working with HP ALM.

My ALM connection was lost while I was in the middle of working. What now?

Any changes youmake are saved locally. When the connection to ALM is restored, your changes are
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automatically uploaded to ALM.

Can a Service Virtualization solution include projects saved both in the file system
and in ALM?

Yes. You can create a solution with projects that are saved both in the file system and in ALM. You can
also add a new project to your existing solution, and save it in ALM. For details on creating a new
project within an existing solution, see "How toManage Virtualization Projects" on page 108.

In the event that a project saved in ALM is unavailable when you open the solution, amessage
displays. After the connection to ALM is restored, you can reload the solution to work on the ALM
projects. From themainmenu, click File > Reload Solution.

Note: All virtualization projects within a solutionmust be saved in the same ALM project, as you
can connect to only one ALM project at a time.

Can I see my Service Virtualization projects from within ALM?

Yes. You can view the following details in your saved projects in the ALM Test Resources module:

l Resource type. Service Virtualization projects and services are created as the Test Resource
resource type.

l Resource description. In the resource Details tab, theDescription area lists the services
included in the project, and details on each service. For example, you can see the service
endpoints, which are required to reconfigure your application under test.

l Resource filename. Select a resource and click theResource Viewer tab. Service Virtualization
resources are identified as follows:

n Virtualization project: .vproj file extension.

n Virtual service: .vs file extension.

n Virtual service template: .vstz file extension.

l Relationships between virtualization projects and services. Select a resource and click the
Dependencies tab.

n For a virtualization project: displays the services in the project.

n For a virtual service: displays the virtualization project in which it is located.

Can I share my services?

You canmake your Service Virtualization projects and services available to others to download and
deploy to other Service Virtualization Servers. This functionality is enabled using the Service
VirtualizationManagement. For details, see "Service VirtualizationManagement" on page 179.
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I want to view a project in the Designer but not make any changes. What should I
do?

You can open the project in read-only mode. This prevents you from inadvertently making any changes.
It also allows another user to open the project for editing.

When opening a project that is saved in ALM, select Open in read-only mode in the Open dialog box.

Tip: After you close the project, the Recent Projects list on the Start Page indicates that you
previously opened it in read-only mode.

If you open the project again from the Recent Projects list, it is opened in read-only mode.
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Subversion (SVN) Support Overview
You canmanage the version control of your virtualization projects from within the Service Virtualization
Designer. Service Virtualization supports integration with Apache Subversion, using the TortoiseSVN
client.

When you open a virtualization project that is under version control, standard SVN options are available
in the Service Virtualization Designer. These options open the TortoiseSVN interface, enabling you to
manage versioning from within your virtualization project. For more details on specific SVN
functionality, see the TortoiseSVN documentation.

For task details, see "How toWork with SVN" below.

How to Work with SVN
This task describes how to work with virtualization projects that are under SVN version control.

To learnmore, see "Subversion (SVN) Support Overview" above.

This task includes the following steps:

l "Prerequisites" below

l "Check out a virtualization project" below

l "Open a version controlled project" on the next page

l "Manage version control" on the next page

l "View version status" on the next page

Prerequisites

1. Integration with SVN requires that TortoiseSVN version 1.7 is installed on the Service
Virtualization Designer machine. You can download TortoiseSVN from http://tortoisesvn.net.

2. Check in your virtualization project or solution using TortoiseSVN.

Check out a virtualization project

Your virtualization project must be committed to an SVN repository.

From themainmenu, select File > Checkout. This accesses the TortoiseSVN user interface, and you
can proceed to check out a project to the file system.
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Open a version controlled project

You can open a project or solution, or add a project to an existing solution.

1. Select one of the following:

n Open an existing project or solution. From themainmenu, select Open Project/Solution.

n Add an existing project to a solution. In the Projects pane, right-click a solution and select
Add > Existing Project.

2. Navigate to and select a checked out project located in the file system.

Manage version control

When a virtualization project is under version control, standard SVN actions are available in the Service
Virtualization Designer.

Select one of the following:

l In the Virtualization Explorer, right-click a project name and select an SVN action.

l From themainmenu, select View > Projects to display the Projects pane. Right-click a solution or
project and select an SVN action.

The following options are available:

l Commit. Commit your changes to the SVN repository.

l Revert. Undo changes youmade since the last update.

l Subversion. Opens a sub-menu with additional SVN actions you can perform.

The TortoiseSVN user interface opens, enabling you tomanage version control for the project. For
more details on SVN actions, see the TortoiseSVN documentation.

View version status

From themainmenu, select View > Projects to display the Projects pane. SVN icons indicate the
version control status of your project's files.
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Configuring HTTP Proxy on Clients 336

Setting HTTP Proxy in Designer 339

Slow Designer Responsiveness 342
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Runtime View Errors

Runtime view doesn't respect selected data model when changing mode.

Problem: User chooses a simulationmodel in the Service Editor and starts a new learning/simulation
from the Runtime View. Instead of using the new simulation, the simulationmodel from the previous
learning/simulation is used again.

Solution: Runtime View is used just to change servicemodes, not configurations. To change the
simulationmodel, open the Service Editor, select a new simulationmodel and start a new
learning/simulation from the Service Editor.

Cannot start learning service 'My Service'.

Problem: Real Datamodel or Performancemodel must be selected in service configuration.

Solution: This error may happen when all data and performancemodels are deleted from the service
configuration and the user tries to start a new learning/simulation session from the Runtime View. To
solve the problem, create a new Data/PerformanceModel and start a new learning/simulation session
from the Service Editor.

HTTPS Client Connection Aborted
Problem: The client connection to a virtualized service deployed on an HTTPS endpoint is aborted
with the error messageSSL_ERROR_RX_RECORD_TOO_LONGwhen Service Virtualization is
running on aWindows XP orWindows 2003machine. The client is normally able to connect to a real
service without any issue.

Solution: See http://support.microsoft.com/default.aspx?scid=kb;EN-US;933430 for a list of possible
solutions. ForWindows 2003, any workaroundmethod as described in the Knowledge Base article can
be used, however, only the first or secondmethods work withWindows XP.

Configuring HTTP Proxy on Clients
Problem: A virtual service is created on a proxy agent and the user is unable to recordmessages.

Solution:Configure the HTTP Proxy on clients.

All examples below of specific client configurations are using the proxy serverHTTP(S) Proxy Agent
listening on address hostnamewith port 6071.
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This section includes:

l "HTTP Proxy in .Net Client" below

l "HTTP Proxy in Java Client" on the next page

l "HTTP Proxy inWebLogic" on the next page

l "HTTP Proxy inWebSphere" on page 339

l "HTTP Proxy in JBoss" on page 339

HTTP Proxy in .Net Client

The .Net client can be configured to use a default proxy server or a specific proxy server.

If using the default proxy server, takeHTTP Proxy Agent settings to configure the default proxy server.
This is done inMSWindows or Internet Explorer in Internet Properties > Connections > LAN
settings > Proxy server. Youmust then configure the client to use the default proxy. This is set in the
application configuration file either for application in element <defaultProxy>:

<configuration>

<system.net>

<defaultProxy enabled="true">

<proxy usesystemdefault="true"/>

</defaultProxy>

</system.net>

</configuration>

, or for a specific binding in a binding element:

<configuration>

<system.serviceModel>

<bindings>

<basicHttpBinding>

<binding name="myHttpBinding" bypassProxyOnLocal="false" useDefaultWebProxy="true">

</binding>

</basicHttpBinding>

</bindings>

</system.serviceModel>

</configuration>
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The same configuration file can be used to set a specific proxy server. This is an example of client
configuration for application:

<configuration>

<system.net>

<defaultProxy enabled="true">

<proxy proxyaddress="http://hostname:6071"/>

</defaultProxy>

</system.net>

</configuration>

, or for specific binding:

<configuration>

<system.serviceModel>

<bindings>

<basicHttpBinding>

<binding name="myHttpBinding" bypassProxyOnLocal="false" useDefaultWebProxy="false" proxyAd
dress=" http://hostname:6071">

</binding>

</basicHttpBinding>

</bindings>

</system.serviceModel>

</configuration>

HTTP Proxy in Java Client

The proxy settings for Java client are given to the JVM via command line arguments. This is an
example of how to run the client from the command line with proxy configuration:

java -Dhttp.proxyHost=hostname -Dhttp.proxyPort=6071MyJavaClient

HTTP Proxy in WebLogic

Add the Java proxy parameters to Java options in JAVA_OPTIONS environment variable in the proper
section of script%WL_HOME%\common\bin\commEnv.cmd for MSWindows or in ${WL_HOME}
/common/bin/commEnv.sh for Unix/Linux. This is example of setting proxy configuration in file
commEnv.cmd (MSWindows):

set JAVA_OPTIONS=%JAVA_OPTIONS% -Dhttp.proxyHost=hostname -Dhttp.proxyPort=6071

, or in file commEnv.sh (Unix/Linux):

JAVA_OPTIONS="${JAVA_OPTIONS} -Dhttp.proxyHost=hostname -Dhttp.proxyPort=6071
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HTTP Proxy in WebSphere

The HTTP proxy on theWebSphere application server can be configured via setting transport
properties http.proxyHost and http.proxyPort. These HTTP transport properties can be set via:

1. Using wsadmin.

2. Using an assembly tool.

3. Using the JVM custom property panel in the administrative console.

To learnmore about (1) and (2), see theConfiguring additional HTTP transport properties
documentation inWebSphere. To configure the HTTP proxy properties using (3) use the administrative
console with the following steps:

1. Open the administrative console.

2. Click Servers > Application Servers > server > Java and Process Management > Process
definition > Java Virtual Machine > Custom Properties.

3. (Optional) If the property is not listed, create a new property name.

4. Enter the name http.proxyHost and value hostname.

5. Enter the name http.proxyPort and value 6071.

6. Restart the server.

HTTP Proxy in JBoss

Add the Java proxy parameters to Java options in JAVA_OPTS environment variable in the startup
script%JBOSS_HOME%\bin\run.bat or run.conf.bat for MSWindows or in ${JBOSS_HOME}
/bin/run.sh or run.conf for Unix/Linux. This is an example of setting the proxy configuration in JAVA_
OPTS environment variable in file run.conf.bat (MSWindows):

set "JAVA_OPTS=-Dhttp.proxyHost=hostname -Dhttp.proxyPort=6071

, or in file run.conf (Unix/Linux):

JAVA_OPTS="-Dhttp.proxyHost=hostname -Dhttp.proxyPort=6071

Setting HTTP Proxy in Designer
Problem:User is unable to access any remoteWSDL or Service Virtualization Server.

Solution:Proxy setting needs to be configured in Designer.
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This section includes:

l "How to Set HTTP Proxy in Designer" below

l "Setting HTTP Proxy in the Designer configuration file " below

l "System HTTP Proxy" below

l "Specific HTTP Proxy" on the next page

l "Setting Credentials for Authenticated HTTP Proxy" on the next page

How to Set HTTP Proxy in Designer

In some cases Service Virtualization Designer communicates with external services using the HTTP
protocol. The first case is the communication with Service Virtualization Server, where the service is
the server management API. The second case is the import of the a real serviceWSDL. In some
situations, the Designer’s HTTP communicationmust be forwarded through an external HTTP Proxy.
In that situation, the HTTP Proxy settings must be placed in the Designer’s configuration file.

Note: The setting of HTTP Proxy for agents is not done in the Designer configuration file. For details,
see "How to Forward HTTP Agent Communication Through an HTTP Proxy" on page 65.

Setting HTTP Proxy in the Designer configuration file

In order to use an external HTTP Proxy for the Designer HTTP communication with a server and the
import of aWSDL from real services, the Designer configuration file must bemodified. This file is
located at%[INSTALLLOCATION]%\Designer\bin\VirtualServiceDesigner.exe.config.

In the configuration file the element <defaultProxy> holds the HTTP Proxy configuration. This element
is located in the document in elements <configuration><system.net>. By default, HTTP Proxy is
disabled by <defaultProxy enabled="false"/>.

The Designer can be configured to use the system HTTP Proxy or to use a specific HTTP Proxy.
Detailed documentation can be found at http://msdn.microsoft.com/library/kd3cf2ex.aspx. The
Designer must be restarted in order to apply the changes in the configuration file.

System HTTP Proxy

If using the system HTTP Proxy, ensure that the HTTP Proxy is configured in the system. The settings
are available inWindows Internet Explorer® menu Internet Properties > Connections > LAN
settings > Proxy server. The Designer must be configured to use the same proxy in the configuration
file in the element <defaultProxy> like this:

<configuration>

<system.net>

<defaultProxy enabled="true">

<proxy usesystemdefault="true"/>

</defaultProxy>
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</system.net>

</configuration>

Specific HTTP Proxy

If using a specific HTTP Proxy other than the system one, follow this example of Designer
configuration:

<configuration>

<system.net>

<defaultProxy enabled="true">

<proxy proxyaddress="http://foo.com:8080"/>

</defaultProxy>

</system.net>

</configuration>

Setting Credentials for Authenticated HTTP Proxy

If the Designer is configured to use HTTP Proxy with authentication, some additional modifications
may be required in the Designer configuration file. This will allow the supplying of credentials for the
HTTP Proxy. Thesemodifications are required in the case of HTTP communication with the server
management API. In the case of WSDL imports, thesemodifications are only optional as the Designer
will prompt the user for credentials if needed.

In order to set credentials for authenticated HTTP Proxy in the Designer, this sectionmust be enabled
in the configuration fileVirtualServiceDesigner.exe.config:

<configuration>

<system.net>

<defaultProxy enabled="true" useDefaultCredentials="false">

<module type = "HP.SOAQ.ServiceVirtualization.ServerManagementClient.Remote.AuthenticatedPr
oxy, HP.SV.ServerManagementClient" />

</defaultProxy>

</system.net>

</configuration>

The credentials for the authenticated HTTP Proxy are set in application keys section. Example of
credential settings follows:

<configuration>

<appSettings>

<add key="proxyUserName" value="user1" />
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<add key="proxyPassword" value="pass1" />

<add key="proxyAddress" value="http://foo.com:8080" />

</appSettings>

</configuration>

Where keys are defined as:

proxyUserName User name for authenticated proxy credentials

proxyPassword Password for authenticated proxy credentials

proxyAddress Address of authenticated proxy (e.g. http://foo.com:8080). If this value is empty
then the Proxy Server address in the system proxy is used.

Once the credentials and the proxy settings are configured as described above then the Designer will
use them both for HTTP communication with the server management API andWSDL imports from real
services.

Slow Designer Responsiveness
Problem: After installing the new version of Service Virtualization, or making a change to your
computer, such as installing an update or new software, the Designer responds very slowly, especially
when working in the DataModel Editor.

Solution 1: This may be related to a knownMicrosoft issue. For details, see PoorWPF application
performance due to UI Automation on certain machines. You can install the following hotfix to address
the issue: Microsoft KB2484841.

Solution 2: Modify the Designer configuration file, VirtualServiceDesigner.exe.config, located in%
[INSTALLLOCATION]%\Designer\bin\. To edit the file, youmust have administrator privileges on the
machine.

Open the file in a text editor and change the value of SeV.Global.EnableAutomationFix from False to
True. If the Designer is open, close it and restart.

If this does not solve the problem, do the following:

1. Change the value of SeV.Global.EnableAutomationFix back to False.

2. Change the value of SeV.Global.ClearAutomationEvents from False to True.

3. If the Designer is open, close it and restart.
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Chapter 17: Service Virtualization Labs
Service Virtualization Labs enable you to try out new, experimental features.

Note: The features in this section are being delivered at “beta level”, and are subject to change.

l They may stop working at any time.

l They may be removed, temporarily or permanently, from future patches or versions.

l They may change when and if they are implemented as fully supported features.

Wewelcome your comments. Send feedback to Service.Virtualization@hp.com.

This chapter includes:

How to Enable Lab Features 344

Scripted Rules 344

Network Virtualization Integration 348

PCAP File Import 351
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How to Enable Lab Features
This task enables you to try out new, experimental features.

For more details on Lab Features, see "Service Virtualization Labs" on the previous page.

To enable a lab feature

1. From themainmenu, select Tools > Options.

2. Click the Labs tab.

3. In the left pane, select a feature and then select theEnable option to turn on the feature.

4. Click OK to save your selections and enable the features.

Troubleshooting lab features

If you encounter any problems while you have a Labs feature enabled, here are some steps you can
take:

l Disable the feature.

l Scripting feature - delete the rule using the script and restart simulation.

l Contact support.

Scripted Rules
This section includes:

Scripted Rules Overview 345

How to Create a Scripted Rule 345
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Scripted Rules Overview
Using a Service Virtualization scripted rule, you can create a script to access request data and set
response data.

Using a scripted rule, you can:

l define the script for different contexts, including for a server, service, operation, session, or service
call.

l use any JavaScript expression from ECMAScript5 strict mode, together with exposed Service
Virtualization objects.

l define logging in the script. Messages are logged to the Service Virtualization log file.

l create a custom log file to log request and response data for a specific data element.

For task details, see "How to Create a Scripted Rule" below.

How to Create a Scripted Rule
You can write a customized script inside a rule in the datamodel.

To learnmore about scripted rules, see "Scripted Rules Overview" above.

This task includes the following steps:

1. "Prerequisite: Enable the Scripting lab feature" below

2. "Prerequisite: Enable logging" below

3. "Create a new scripted rule" on the next page

4. "Define/edit the script" on the next page

5. "Set options for the scripted rule" on page 347

1. Prerequisite: Enable the Scripting lab feature

For details on Service Virtualization lab features, see "Service Virtualization Labs" on page 343.

2. Prerequisite: Enable logging

To enable your scripts to write to the Service Virtualization log file, add the following entry to the
log4net section of the configuration file for the Designer or Service Virtualization Server.
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<logger name="JavascriptLogger>"

<level value="XXX" />

</logger>

whereXXX is one of the following log levels: DEBUG, INFO, WARNING, ERROR.

By default, only log level ERROR is enabled.

For more information, consult the log4net documentation.

Note:

n Service Virtualization Server configuration file:HP.SV.StandaloneServer.exe.config,
located on the Service Virtualization Server machine in the server installation folder. By
default, C:\Program Files\HP\HP Service Virtualization Server\Server\bin.

n Designer configuration file:VSDesignerConfigurationTool.exe.config, located on the
Designer machine in the installation folder. By default, C:\Program Files (x86)\HP\HP
Service Virtualization Designer\Designer\bin\VirtualServiceDesigner.exe.config.

n For details on log file locations, see "Virtual Service Editor" on page 144.

3. Create a new scripted rule

In the DataModel Editor, click New Rule > Scripted Rule. Expand the newly created rule to
configure the script.

4. Define/edit the script

a. Select one of the following:

o Expand a rule to configure the script.

o Select Script > Edit in New Tab to edit the script in a separate tab. Scripted rule content
remains locked until you save your changes and close the tab.

b. Write the script content according to the following guidelines:

o Use any JavaScript expression from ECMAScript5 strict mode along with Service
Virtualization exposed objects.

o You can insert the path to a Service Virtualization object, instead of entering it manually.
Select a scripted rule, and from the DataModel EditorScriptmenu, select Insert Path.
Select a data element to add to the script.

o Access request data using hpsv.request.
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o Access response data using hpsv.response.

o Use hpsv.logger in the script, to logmessages in the Service Virtualization log files.

o To log request and response data for a specific data element, add the following line to the
scripted rule. Assign a name for the custom log file, and enter actual names for the request
and response operations, and data elements.

hpsv.dataLogger.log("<custom logfile name>.log", hpsv.request.<request operation
name>.<element1 name>.<element2 name>, hpsv.response.<response operation
name>.<element1 name>.<element2 name>)

Log are saved in the following locations:

For a service running on the embedded server:Messages are stored in the Designer
log folder%APPDATA%\Hewlett-Packard\VirtualServiceDesigner\logs\messages\
[Service Name]-[Service ID]\<custom logfile name>.log.

For a service running on a Service Virtualization Server:Messages are stored in the
Server log folder%ALLUSERSPROFILE%\Hewlett-Packard\HP Service Virtualization
Server\logs\messages\[Service Name]-[Service ID]\<custom logfile name>.log .

o Define a context for the script, using the following properties:

Context Property Description

Server hpsv.context.server The data is visible to all services on the server
that are simulating. Data is deleted when the
server restarts.

Service hpsv.context.service The data is visible only to the service for all
simulatedmessages. Data is deleted when the
service simulation ends.

Operation hpsv.context.operation The data is visible only to requests of the current
operation. Data is deleted when the service
simulation ends.

Session hpsv.context.session The data is visible only to requests coming from
the same user session. Data is deleted when the
user session ends.

Call hpsv.context.call The data is visible only to one service call (=
simulated request). Data is deleted when the
simulation of that request ends.

5. Set options for the scripted rule

By default, the scripted rule is executed during each pass through the rules. (For more details on
how simulation is performed, see "The Simulation Process" on page 208.)
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To change this default setting and reduce CPU time during simulation, configure the rule's
properties.

Right-click the scripted rule and select Properties to display the options.

n Skip the first simulation pass. Tomodify or complete data filled in by another rule, the
scripted rule must be have a higher priority than the rule you want to override. However, during
the first simulation pass, all the response data for the script has not yet been filled in by the
other rules. In this case, youmay want to skip the scripted rule during the first simulation pass.

n Execute the rule only once. As an example, youmay be using the script to add an item into
an array, such as assigning an ID to a user. Each time the script is run, the rule will modify the
response, causing the simulation process to continue repeatedly. In this case, use this option
to properly execute the simulation.

Network Virtualization Integration
This section includes:

Network Virtualization Overview 349

How to Virtualize Network Conditions 349
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Network Virtualization Overview
The Service Virtualization integration with HP Network Virtualization capabilities enables you to
simulate a real network to use together with your virtual services.

You can simulate real network communication between a client and server by setting origin and
destination locations, and by introducing network conditions such as latency, packet loss, and
bandwidth.

For task details, see "How to Virtualize Network Conditions" below.

How to Virtualize Network Conditions
This task describes how to define a virtual network environment for your virtual services to use.

To learnmore about virtualizing network conditions, see "Network Virtualization Overview" above.

This task includes the following steps:

l "Prerequisites" below

l "Configure network models" on the next page

l "Assign a network model to an agent configuration" on the next page

l "Edit network models" on page 351

1. Prerequisites

a. Enable the Network Virtualization lab feature.

For details on Service Virtualization lab features, see "Service Virtualization Labs" on page
343.

b. HP Network Virtualization and the Location Editor must be installed on the Service
Virtualization Server machine.

For information on supported versions, refer to the support matrix on the HP Software Support
site at: http://h20230.www2.hp.com/sc/support_matrices.jsp.

c. Configure the Service Virtualization Server to connect to Network Virtualization.

Navigate to theHP.SV.StandaloneServer.exe.config file, located on the Service Virtualization
Server machine in the server installation folder. By default, C:\Program Files\HP\HP Service
Virtualization Server\Server\bin.
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Configure the properties in the following sections according to your Network Virtualization
system definitions:

o Shunra Network Virtualization - NV Agent (Engine).

Edit the Host, Port, Protocol, UserName, and Password properties. The parameters
enable the Service Virtualization Server to access the Network Virtualization engine.

o Shunra Network Virtualization - Location Editor

Edit the Host, Port, Protocol, UserName, and Password properties. These connection
properties enable the Service Virtualization Designer to browse the Network Virtualization
Location EditorWeb Site.

2. Configure network models

Define a set of network characteristics to use with your virtual services.

a. From themainmenu, select Tools > Options and click theNetwork Virtualization page.

b. Click Add. The Network Virtualization interface for setting virtualization options opens.

Select one of the following:

o Import from library. Import an existing location.

o Custom. Define network settings manually.

o Advanced. Select a predefined .ntxx emulation file that was created in the Network
Virtualization Network Editor and saved in the file system.

o Copy an existing model. Select an existing network model and click Duplicate. A copy
is made of themodel you selected. You can edit the settings and save it as a new network
model.

3. Assign a network model to an agent configuration

Select a network model for an HTTP agent configuration. The network model is then used by all
virtual services that use the agent configuration.

a. From themainmenu, select Tools > Options and click theAgents page.

b. Select an existing HTTP agent configuration, or define a new one.

c. In the right pane, click theNetwork Virtualization tab.

d. Select a network model for the agent to use.

e. To configure network models, click Manage Network Models.
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4. Edit network models

Tomodify existing network models:

From themainmenu, select Tools > Options and click theNetwork Virtualization page.

For each network model, the right pane displays the Service Virtualization agents that are using
themodel. You can attach or detach an agent from the selected network model.

Click an agent name link to view details on the agent.

PCAP File Import
This section includes:

Packet Capture (pcap) Import Overview 352

How to Import .pcap Files 352
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Packet Capture (pcap) Import Overview
You can import .pcap files to use captured network traffic in your simulation.

For example, when you cannot use Service Virtualization learning to record real service behavior, you
may be able to use a packet analyzer (sniifer) to collect the data you need. After completing the packet
capture, you can import .pcap files into HP Service Virtualization.

Service Virtualization enables you to import all data streams in the file or select specific streams only.

For task details, see "How to Import .pcap Files" below.

How to Import .pcap Files
You can import .pcap files to use captured network traffic in your simulation.

l To learnmore about importing pcap files, see "Packet Capture (pcap) Import Overview" above.

l Pcap file import is available for services using HTTP transport only.

1. Prerequisite: Enable the Pcap lab feature. For details on Service Virtualization lab features, see
"Service Virtualization Labs" on page 343.

2. In the DataModel Editor, expand a rule.

3. In the Operations pane, make sure the virtual service name is selected, and not an individual
operation.

4. Right-click the data rule and select Import Pcap.

5. Select a .pcap file stored in the file system.

6. For REST services, select a specific URI space to import the data into.

7. In the Select Streams dialog box, select one or more streams to import.

The Select Streams dialog box displays all usable TCP streams in the .pcap file. Service
Virtualization discards TCP streams with gaps.

TheSize column displays the total number of bytes in the request and response streams.

Tip: Click a source or destination address to view the full source/destination path of the TCP
connection.
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