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Reporting and Auditing 

Overview 
This document describes the database views that you can use to run reports in HP Cloud Service 
Automation (HP CSA). Included is a database view that allows you to run a report showing contents of 
the HP CSA audit log.   This document also provides an example of how to install, configure, and use 
third-party reporting software (from Jaspersoft Corporation) to run HP CSA reports. 

Prerequisites 
HP CSA supports databases from Oracle, Microsoft SQL, and PostgreSQL for reports. Before you can 
run reports, you must create a read-only database user (and a role, if using Oracle) specifically for 
reporting purposes, and then you must specify its username and password during the HP CSA installation 
or upgrade. For instructions, see the HP Cloud Service Automation Installation Guide. 

Database Views for Standard Reports 
HP CSA provides some commonly-needed information for a sequence-based model through the (non-
materialized) database views for reporting. A read-only database user will have access to these views, 
which they can use to design reports. 

Note: For audit reports, see the section entitled “Database View for Audit Reports.” 

The following table lists each view and some filters (list of values) that read-only users can use in a report 
designer.  

Table 1. List of Database Views 

Number View name Filters (list of values) Description and comments 

1  RPT_RSC_CAPACITY_V  RPT_LOV_PROVIDER_V  
RPT_LOV_PROV_POOL_V  

Within each Pool, list Resource Type, 
Quantity Used, Quantity Remaining, and 
Units. 

2  RPT_USER_SUBSCRIPT
ION_V  

RPT_LOV_ORG_V  
RPT_LOV_ORG_USR_V  
RPT_LOV_CAT_OFFR_V  

Group by Organization and by User 
consuming the subscription (filter by 
organization, user, and offering). Group 
information must be fetched from the view. 
The group here is the 'Owned By' group. 

3  RPT_SUBSCR_RSC_V  RPT_LOV_PROVIDER_V 
RPT_LOV_PROV_POOL_V  

Group by Provider and by the Resource 
Pools defined within it (with subscription 
details). 

4  RPT_SUBSCR_OPTS_V  RPT_LOV_ORG_USR_V Show the options and option prices for 
subscriptions. 

5 RPT_RESOURCE_UTILI
ZATION_V  

RPT_LOV_PROVIDER_V 
RPT_LOV_PROV_POOL_V  

Provide information on resource utilization 
for subscriptions. 

1 RPT_PAY_PER_USE_M
ETER_V N/A 

List the maximum operating system 
instances (OSI) being used in HP CSA 
active subscription for each organization in 
the last 30 days. 

2 RPT_LICENSE_OSI_US
AGE_V N/A List the total OSI being using in HP CSA 

active subscription for the CSA instance. 
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RPT_RSC_CAPACITY_V View 

This view provides a list of providers and pools and their available capacity and utilization. 

Table 2. RPT_RSC_CAPACITY_V View 

Field name (in the view) Functional description 

PROVIDER_ID  Identifier of the resource provider. 
PROVIDER_NAME  Name of the resource provider. 
PROVIDER_TYPE  Type of resource provider. 
SERVICE_ACCESS_POINT  Access point URL for the provider. 
RESOURCE_POOL_ID  Identifier of the resource pool. 
RESOURCE_POOL_NAME  Name for the resource pool. 
KNOWN_TO_PROVIDER_AS  Name of the resource pool used by the provider. 
RESOURCE_TYPE  Type of resource (such as CPU or Storage). 
AVAILABILITY  Category to indicate if the resource is available. 
AVAILABLE_TO_CSA  Quantity of the resource that is available to HP CSA in the pool. 
USED_BY_CSA  Quantity of the resource that has been used by HP CSA from this 

pool. 

RPT_USER_SUBSCR_V View 

This view provides detailed information for subscriptions (excluding the Option selection and Pricing 
information). 

Table 3. RPT_USER_SUBSCR_V View 

Field name (in the view) Functional description 

SUBSCRIPTION_ID  Identifier of the subscription. 
SUBSCRIPTION_NAME  Name of the subscription as displayed. 
SUBSCRIPTION_START_DATE  Start date of the subscription. 
SUBSCRIPTION_END_DATE  End date of the subscription. 

SUBSCRIPTION_OWNER_GROUP  Name of the group that owns this subscription (applicable only for 
subscriptions owned by a group). 

SUBSCRIPTION_STATUS  Status of the subscription. 
REQUESTED_BY_USER_ID  Identifier of the user requesting the subscription. 
REQUESTED_BY_USER  Name of the user requesting the subscription. 
REQUESTED_BY_USER_EMAIL  Email address of the user requesting the subscription. 
ORGANIZATION_ID  Identifier of the organization to which this subscription belongs. 
ORGANIZATION_NAME  Name of the organization to which this subscription belongs. 
CATALOG_ID  Identifier of the catalog to which this subscription belongs. 
CATALOG_NAME  Name of the catalog to which this subscription is published. 

SERVICE_OFFERING_ID  Identifier of the service offering for which this subscription was 
submitted. 
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Field name (in the view) Functional description 

SERVICE_OFFERING_NAME  Name of the service offering for which this subscription was 
submitted. 

RPT_SUBSCR_RSC_V View 

This view provides information about the Resource Provider and Resource Pool used by a subscription. 

Table 4. RPT_SUBSCR_RSC_V View 

Field name (in the view) Functional description 

SUBSCRIPTION_ID  Identifier of the subscription. 
RESOURCE_PROVIDER_ID  Identifier of the resource provider. 
RESOURCE_PROVIDER_NAME  Name of the resource provider. 
PROVIDER_ACCESS_POINT_URI  Access point URI of the resource provider. 
RESOURCE_RPOVIDER_TYPE  Type of the resource provider. 
RESOURCE_POOL_ID  Identifier of the resource pool. 
RESOURCE_POOL_NAME  Name of the resource pool. 

RPT_SUBSCR_OPTS_V View 

This view provides the options and option prices for subscriptions. 

Table 5. RPT_SUBSCR_OPTS_V View 

Field name (in the view) Functional description 

SUBSCRIPTION_ID  Identifier of the service subscription. 
OPTION_MODEL_ID  Identifier of the option model. 
CURRENCY_DISPLAY_NAME  Display name of the currency used in the option model. 
RECURRING_PERIOD_DISPLAY_NAME  Display name of the recurring period used in the option model. 
L1_OPTION_SET_ID  Top-level option set ID. 
L1_OPTION_SET_NAME  Top-level option set name. 
L1_OPTION_SET_DISPLAY_NAME  Top-level option set display name. 
L1_OPTION_ID  Top-level option ID. 
L1_OPTION_NAME  Top-level option name. 
L1_OPTION_DISPLAY_NAME  Top-level option display name. 

L1_OPTION_SELECTED  'Y' if the top-level option is selected. 
'N' if the top-level option is not selected. 

L1_INITIAL_PRICE  Initial price of the top-level option. 
L1_RECURRING_PRICE  Recurring price of the top-level option. 
L2_OPTION_SET_ID  Child-level option set ID. 
L2_OPTION_SET_NAME  Child-level option set name. 
L2_OPTION_SET_DISPLAY_NAME  Child-level option set display name. 
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Field name (in the view) Functional description 

L2_OPTION_ID  Child-level option ID. 
L2_OPTION_NAME  Child-level option name. 
L2_OPTION_DISPLAY_NAME  Child-level option display name. 

L2_OPTION_SELECTED  'Y' if the child-level option is selected. 
'N' if the child-level option is not selected. 

L2_INITIAL_PRICE  Initial price of the child-level option. 
L2_RECURRING_PRICE  Recurring price of the child-level option. 
L3_OPTION_SET_ID  Grandchild-level option set ID. 
L3_OPTION_SET_NAME  Grandchild-level option set name. 
L3_OPTION_SET_DISPLAY_NAME  Grandchild-level option set display name. 
L3_OPTION_ID  Grandchild-level option ID. 
L3_OPTION_NAME  Grandchild-level option name. 
L3_OPTION_DISPLAY_NAME  Grandchild-level option display name. 

L3_OPTION_SELECTED  'Y' if the grandchild-level option is selected. 
'N' if the grandchild-level option is NOT selected. 

L3_INITIAL_PRICE  Initial price of the grandchild-level option. 
L3_RECURRING_PRICE  Recurring price of the grandchild-level option. 

RPT_R0ESOURCE_UTILIZATION_V View 

This view provides the information on resource utilization for subscriptions. 

Table 6. RPT_RESOURCE_UTILIZATION_V View 

Field name (in the view) Functional description 

SUBSCRIPTION_ID  Identifier of the subscription. 
SUBSCRIPTION_NAME  Name of the subscription. 
COMPONENT_ID  Identifier for the service component. 
COMPONENT_NAME  Name of the service component. 
RESOURCE_POOL_ID  Identifier of the resource pool. 
RESOURCE_POOL_NAME  Name of the resource pool. 
PROVIDER_ID  Identifier of the provider. 
PROVIDER_NAME  Name of the provider. 
MEASURABLE_PROPERTY_NAME  Name given to the measurable property. 
RESOURCE_TYPE  Type of resource for this measurable property. 
RESOURCE_UNIT  Measuring unit of this resource in the measurable property. 

UTILIZATION  Quantity of this resource that has been used by this subscription in 
this pool. 
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RPT_PAY_PER_USE_METER_V 

This view provides a list of the maximum operating system instances (OSI) being used in HP CSA active 
subscriptions for each organization in the last 30 days. 

Field name (in the view) Functional description  

START_DATE Start date from which the OSI usage is determined.  By default, this 
is 30 days prior to the current date. 

END_DATE End date to which the OSI usage is determined. By default, this is the 
current date. 

ORGANIZATION Name of the organization to which the OSI usage belongs. 

DEPLOYED_OSI_COUNT OSI count consumed by the organization. 

MAXIMUM_OSI_LIMIT Cumulative count of purchased OSI. 

RPT_LICENSE_OSI_USAGE_V 

This view provides a list of the total operating system instances (OSI) being used in HP CSA active 
subscriptions for the HP CSA instance. 

Field name (in the view) Functional description  

START_DATE Start date from which the OSI usage is determined. By default, this is 
30 days prior to the current date. 

END_DATE End date to which the OSI usage is determined. By default, this is the 
current date. 

DEPLOYED_OSI_COUNT OSI count consumed by the organization. 

MAXIMUM_OSI_LIMIT Cumulative count of purchased OSI. 
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Database View for Audit Reports 
HP CSA provides auditing capability by creating an audit event record in the HP CSA database for 
several important events that occur during the lifetime of a running instance of HP CSA.  Each audit event 
has a Classification Code and Operation Type attribute, as indicated below.  HP CSA captures audit log 
information for the following events: 

• User Authentication to HP CSA and the Market Place Portal 

For every successful login and unsuccessful login attempt, an audit event record is created. 

Classification Code - Authentication  
Operation Type - Login 

• User Authorization 

If an unauthorized user access is identified, an audit event record is created. 

Classification Code - Authorization  
Operation Type - Access 

• CSA Service Start and Stop 

An audit event record is created every time the CSA service is started and stopped. 

Classification Code – Server Management  
Operation Type – Server Start, Server Stop 

• Transactional Events Involving HP CSA Artifacts 

Whenever an HP CSA artifact is created, updated or deleted, an audit event record is created.  HP 
CSA artifacts include Service Design, Service Offering, Organization, Catalog, Service Request, 
Subscription, Approval Process, Service Instance, etc. 

Classification Code – ‘Create Update Delete’  
Operation Type – Create, Update, Delete 

• Change in Service Offering Price 

An audit event record is created when pricing for a service offering changes. 

Classification Code – ‘Create Update Delete’ 
Operation Type – Create, Update, Delete 

The audit information can be accessed using the following database view: 

• RPT_AUDIT_EVENT_V 

Like the other HP CSA reporting views, a read-only database user will have access to this view, which 
they can use to design audit reports in a report designer. 

Note: See the section entitled “Audit Report Examples” for example queries for audit reports. 

Note: Audit event data can be purged if desired by running the DB Purge tool.  Refer to the HP CSA 
documentation for more information. 

RPT_AUDIT_EVENT_V View 

This view provides information from the HP CSA audit log. 
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Table 7. RPT_AUDIT_EVENT_V View 

Field name (in the view) Functional description 

CREATED_ON Timestamp when the audit event was created. 

MODIFIED_BY_USERNAME User name of the user who accessed the HP CSA system at login, 
creating, modifying or deleting the HP CSA artifacts. 

USER_ORGANIZATION_NAME Organization to which the user accessing the HP CSA system 
belongs. 

ARTIFACT_ID Unique ID of the artifact being created, updated, or deleted. 

ARTIFACT_NAME Name of the artifact at the time the audit event was generated. 

ARTIFACT_TYPE Type of artifact being created, updated, or deleted. 

AUDIT_CLASSIFICATION Audit Classification Code.  See “Database View for Audit Reports” for 
possible values and how they are used. 

AUDIT_OPERATION Audit Operation Type. See “Database View for Audit Reports” for 
possible values and how they are used. 

ORIGINATING_SERVER Server name from where the logon attempt was made. This attribute 
is currently used only for the authentication event. 

SERVER_TYPE Currently used only for authentication event and set to ‘IDM’. 

DESCRIPTION Description of the audit event. 

Use Jaspersoft Software to Create and Deploy Reports 
This section uses Jaspersoft software as an example of how to install, configure, and use third-party 
reporting tools to create and deploy HP CSA reports.  

Install Jaspersoft iReport Designer and Create Reports 

iReport Designer is the report development tool for JasperReports and JasperReports Server. 

1. Install iReport Designer by following the instructions at 

 http://sourceforge.net/projects/ireport/ 

2. Start iReport Designer. 

 The New file dialog box appears. 
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3. Click to select a report template. 
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4. Click Open this Template. 

 The Name and location dialog box appears. 

  
  

5. Enter the report name into the Report name field.  

 The default location in the Location field is your desktop. You can click the Browse button to select 
another location to store the template. The .jrxml file is always saved to the same folder as the 
template. 

  

 
HP Cloud Service Automation 4.10 Page 11 of 34 



Reporting and Auditing 

6. Click Next. 

 The Query dialog box appears. 
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7. Do one of the following. 

• Select an existing data source from the Connections / Data Sources pull-down menu. 

• Click New to create a new connection/data source, if no connections/data sources are available. 

 If you clicked New, the Datasource dialog box appears. 

  
  

8. Select the Database JDBC connection data source type. 
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9. Click Next. 

The Database JDBC connection dialog box appears. 

 

 

10. Fill in the dialog box as follows: 

• Name 

• JDBC Driver  

 Select the correct driver for your database. 

• JDBC URL  

• Username  

• Password  
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 If the driver for your database is not available, it appears in red, which means that it is not in the 
classpath. 

  
  

11. If the driver is not available, select Tools → Options → Classpath → Add JAR from the menu 
bar. 
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12. Add the driver to the classpath as in the following dialog box. 
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13. Click Test to validate your username and password with the database.  

 A popup appears if the test is successful. 

  
  

14. Click OK. 
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15. Click Save. 

 The Query dialog box appears. 

  
  

16. Click Design query. 

17. Use the query editor to design a query and click OK. 

Note: See the section entitled “Audit Report Examples” for example queries for audit reports. 
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18. Click Next. 

 The Fields dialog box appears. 

  

 
  

19. Use the arrow buttons to select the fields to appear in the report. 

20. Click Finish. 

 The template appears in the Designer format.  

21. (Optional) Rearrange the order of the columns (fields) in the report and modify the formatting (such as 
right- or left-justified) for the title, field, and column names.  
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22. Preview the report by clicking the Preview tab. 

 Following is a preview of a report. 

  
  

Install and Configure JasperReports Server for Use with HP CSA 

1. Install JasperReports Server by following the instructions at 

 http://community-static.jaspersoft.com/sites/default/files/docs/jasperreports-server-install-
guide.pdf 

2. Go to the JasperReports Server login page at 

  http://localhost:8082/jasperserver/login.html 
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3. Enter the following login credentials: 

 User ID: jasperadmin 

 Password: jasperadmin 

 

 

4. Click View → Repository. 

  

 
HP Cloud Service Automation 4.10 Page 21 of 34 



Reporting and Auditing 

5. Right-click the root/Data Sources folder and select Add Resource → Data Source. 
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 The Add Data Source dialog box appears. 

 

 

6. Enter information into the following fields: 

• Type of data source  

 Select JDBC Data Source (this is required for the databases supported by HP CSA). 

• Name of your choice 

• Resource ID of your choice 
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• (Optional) Description 

• JDBC Driver of the installed database 

 If the driver is not in the list, you can add the Java archive (JAR) file by using the Edit Driver option. 

• Host where the database is installed 

 Enter localhost if the database is on your local system. 

 Enter the IP address of the system, if your database is installed on another system. (To find the 
hostname, log in to that system and enter the hostname command from a command prompt.) 

• Port number 

• Database name 

• URL 

 Using your hostname and database name, modify the URL as follows:  

 jdbc:postgresql://<host>:5432/<dbname> 

 By default, the URL is jdbc:postgresql://localhost:5432/dbname. 

• User Name 

 Enter the same username as for JasperReports Server. 

• Password 

 Enter the same password as for JasperReports Server. 

7. Click Save to save the data source. 
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Deploy a Report in JasperReports Using the iReport Designer 

In this procedure, you deploy a report to the server. First, you connect iReport to the repository. 

1. Select Window → JasperServer Repository. 
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 The Repository Navigator pane appears. 
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2. Click the  button to create a new server. 

 The JasperServer Plugin dialog box appears. 

 

 

3. Enter values into the following fields for your JasperReports Server: 

•  ID of the server 

 You can enter any name of your choice. Enter a name that is meaningful. 

• JasperReports Server URL 

 The default value for JasperReports Server URL is 

 http://localhost:8080/jasperserver/services/repository 

 If you are using the same URL for JasperReports, then keep the URL as is; otherwise, replace it. 

• Username 
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• Password 

4. Click Save. 

 Jaspersoft iReport Designer retrieves the information from the server. The Repository Navigator 
appears as follows. 

 

 

Define the Data Source for a Report 

You must define the data source for a report. For previewing, the local data source is used, but to display 
the report from the server, you must define a data source on the server as well. 

1. Select the Data Sources folder in the Repository Navigator pane. 
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2. Right-click Add → Data Source. 

 The Data Source dialog box appears. 

 

  

3. Enter values into the following fields for your data source:  

• ID  

 For example, JRServer. 

• Name 

 For example, SRServerDataSource. 

• (Optional) Description 
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4. Click the Data Source Details tab.  

 If you select a JDBC data source, you can click the Import from iReport button to help provide these 
details. Select the local data source that you specified during report design. 

 

 

5. Click Save. 

 The list of reports in the Repository Navigator pane corresponds to the list that appears on the 
webpage. 

6. Create a folder named CSA_Reports under the Reports folder. 

7. Right-click the CSA_Reports folder. 

8. Select Add → Report. 

9. Enter the name, label, and description for the report. 

10. Click Save. 
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11. Click Browse to browse to and select a .jrxml file (for example, ProviderSubscription.jrxml) 
and select it. 

 This is the JasperReports report template file that was generated when you created the template.  

 

 

 

12. Click Next. 
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13. Select a data source from the available data sources. 

 The following figure uses /datasources/CSA_Reports as an example data source. 
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14. Click Finish. 

 The report is now available from the website. 

 

 

 You can now preview the report.  
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Audit Report Examples 
This section includes some examples to see specific audit events by running queries on the 
RPT_AUDIT_EVENT_V database view. 

Login events 

The following query will return all successful and unsuccessful login attempts in order starting from the 
most recent: 

select * from rpt_audit_event_v where audit_classification = ’Authentication’ 
order by created_on desc ;  

Artifact creation, modification, and deletion 

The following query will retrieve the audit event records for a design created with the name “Good Test 
Design,” which was subsequently renamed and then deleted: 

select created_on, modified_by_username, user_organization_name,artifact_id, 
artifact_type, artifact_name, audit_classification, audit_operation,description 
from rpt_audit_event_v where artifact_id in (select artifact_id from 
rpt_audit_event_v where artifact_type='Service Blueprint'and artifact_name='Good 
Test Design') order by created_on asc;; 

The above query will return a result that is similar to the following example: 

created_on 

modified 
_by_ 
username 

user_ 
organization 
_name artifact_id 

artifact_ 
type 

Artifact
_ 
name 

audit_ 
classifi
cation 

Audit_ 
operation description 

02-MAY-14 
02.17.58.258 

gooduser CSA-Provider 297e87c045968b3f01
45becd045b01ea 

Service 
Blueprint 

Good 
Test 
Design 

Create 
Update 
Delete 

Create Artifact CUD 
Successful 

02-MAY-14 
02.20.16.597 

baduser CSA-Provider 297e87c045968b3f01
45becd045b01ea 

Service 
Blueprint 

Bad 
Test 
Design 

Create 
Update 
Delete 

Update Artifact CUD 
Successful 

02-MAY-14 
02.20.46.360 

baduser CSA-Provider 297e87c045968b3f01
45becd045b01ea 

Service 
Blueprint 

Bad 
Test 
Design 

Create 
Update 
Delete 

Delete Artifact CUD 
Successful 

Note: Audit event data can be purged if desired by running the DB Purge tool.  Refer to the HP CSA 
documentation for more information. 
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