Compliance page is blank after importing LNC Policies

  • KM01010315
  • 25-Jun-2014
  • 27-Jun-2014

Summary

Certain HPNA policies delivered via LNC (Live Network Connector) cause the NA (Netwotk Automation) User Interface Compliance Search functionality to break.

Error

From HPNA WebUI and you go to Reports -> Search For -> Compliance. The Complinace page is blank after importing LNC Policies.

Cause

The following 3 policies, which seem to be problematic due to a Line Feed in their names:

<ConfigPolicyName>Multiple Vulnerabilities in Cisco ASA Software
. (CVE-2013-1150)</ConfigPolicyName>
<CVE>CVE-2013-1150</CVE>
 
<ConfigPolicyName>Multiple Vulnerabilities in Cisco ASA Software
. (CVE-2013-5513)</ConfigPolicyName>
<CVE>CVE-2013-5513</CVE>
 
<ConfigPolicyName>Multiple Vulnerabilities in Cisco Firewall Services Module Software
. (CVE-2013-1155)</ConfigPolicyName>
<CVE>CVE-2013-1155</CVE>

Fix

One thing is really important:
 
DO NOT DELETE POLICIES IN ORDER TO WORK AROUND THIS ISSUE.
 
The correct workaround is as follows:
 
From the main menu of NA go to Policies -> Policy List and edit the following policies, taking the extra space out of the name between the end of the name and the first full stop.
 
i.e., edit:
Multiple Vulnerabilities in Cisco ASA Software . (CVE-2013-1150)
 
to
Multiple Vulnerabilities in Cisco ASA Software. (CVE-2013-1150)
 
Here are the policies that need to be edited:
 

Multiple Vulnerabilities in Cisco ASA Software . (CVE-2013-1150)
 

Multiple Vulnerabilities in Cisco ASA Software . (CVE-2013-5513)
 

Multiple Vulnerabilities in Cisco Firewall Services Module Software . (CVE-2013-1155)