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Welcome to This Guide
Welcome to the HP ALM Performance Center Quick Start. ALM Performance Center is HP's Web-
enabled global performance testing tool, designed to streamline the testing process and increase the
test efficiency for multiple concurrent performance tests across multiple geographic locations.

This Quick Start is a self-paced guide designed to lead you through the process of creating, running,
and analyzing a performance test, and to introduce you to the ALM Performance Center testing
environment.

Note:

l This guide assumes that your ALM Performance Center environment has been fully installed
and configured, and that a domain and project have been set up. For more information, contact
your Performance Center administrator.

l This Quick Start only describes how to work with the ALM features associated with
performance testing. For a comprehensive guide to working with ALM, refer to theHP
Application Lifecycle Management Tutorial.

How This Guide is Organized
This guide contains the following lessons:

Lesson Description

"Introducing ALM
Performance Center"
on page 9

Provides an overview of ALM Performance Center and the performance
testing applications.

"Creating Vuser
Scripts" on page 11

Describes the steps involved in recording Vuser scripts using HP Virtual
User Generator.

"Creating and
Designing Performance
Tests" on page 19

Describes the steps involved in creating and designing performance
tests.

"Running Performance
Tests" on page 33

Describes the steps that are necessary before running a performance
test, and how to begin test execution.

"Post-Run Analysis
and Trending" on
page 41

Describes how to analyze test run data using HP LoadRunner Analysis,
and how to view performance improvements and regressions using the
Trend Reports feature.

"Summary" on page 53 Provides a summary of the testing process phases that aremanaged
using ALM Performance Center.
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Chapter 1: Introducing ALM Performance
Center
This lesson provides a brief overview of HP ALM Performance Center, and of the applications that are
involved in the testing process.

Notes:

l TheQuick Start describes how to run a performance test with a single host functioning as both
a load generator and a Controller (C+LG). However, due to possible heavy load on the
Controller and load generator hosts during a performance test, it is best practice to assign these
functions to separate host machines.

l Ensure that the latest standalone versions of HP Virtual User Generator (VuGen) and
HP LoadRunner Analysis are installed on your system.

In this lesson you will learn about:

l "The ALM Performance Center Testing Process" below

l "Performance Testing Applications" on the next page

The ALM Performance Center Testing Process
Using ALM Performance Center, you create performance tests in which you define the events that
occur during a testing session. During a test, ALM Performance Center replaces human users at
physical machines with virtual users, orVusers. These Vusers create load on your system by
emulating actions of typical users in a repeatable and predictable manner.

Suppose you are testing aWeb-based travel agency application that enables users to book flights
online. Your goal as the performance tester is to determine how the application behaves whenmultiple
users try to perform the same transaction at the same time. Using ALM Performance Center, you can
run a test in which 1,000 Vusers, emulating 1,000 travel agents, would simultaneously try to book a
flight on the application.

What is the testing process?
The testing process consists of the following basic processes:

l Creating the script. Capturing typical end-user business processes performed on your application.

l Designing the performance test. Setting up the test environment by defining events that occur
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during the testing session.

l Preparing to run the performance test. Adding the performance test to a test set and reserving a
timeslot for the test.

l Running the performance test. Driving, managing, andmonitoring the test.

l Analyzing the results and viewing performance trends. Analyzing the performance data
generated during the test run, and viewing trending information which identifies performance
improvements and regressions over time.

These processes are explained inmore detail in the lessons that follow.

Performance Testing Applications
Each step in the testing process is carried out by one of the HP load testing tool components. The
components are as follows:

Application Description

HP Virtual User
Generator (VuGen)

Creates the script and generates virtual users, orVusers. VuGen does this
by capturing actions that typical end-users would perform on your
application, and then records these actions into automated Vuser scripts.
These Vuser scripts form the foundation of a performance test.

HP ALM Performance
Center

Provides the central console from which you build, manage, andmonitor a
test.

HP Analysis Analyzes the performance test and provides graphs and reports with in-
depth performance analysis information. Using these graphs and reports,
you can pinpoint and identify the bottlenecks in your application and
determine what changes need to bemade to your system to improve its
performance.

Sample Application - HP Tours
To illustrate the testing process, this Quick Start uses a sampleWeb-based travel agency application
called HP Tours.

During the course of this Quick Start, you will go through the basic steps of creating, running, and
analyzing a performance test. The test will emulate 10 travel agents simultaneously connecting to the
HP Tours Web server and performing various flight reservation actions, for example logging on,
searching for flights, purchasing flights, checking itineraries, and logging off.

Quick Start
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Chapter 2: Creating Vuser Scripts
This lesson explains the steps involved in recording Vuser scripts using HP Virtual User Generator.

In this lesson you will learn about:

l "Recording Vuser Scripts" below

Recording Vuser Scripts
You record Vuser scripts using HP Virtual user Generator (VuGen). A Vuser script is a record of a
typical end-user business process. VuGenworks on a record-and-playback principle. As you walk
through a business process on your application, VuGen records your actions into an automated script
which later forms the foundation of the performance test.

This section includes:

l "How do I start recording user activity?" below

l "How do I record a business process to create a script?" on the next page

l "How do I view my script?" on page 15

l "How do I save the script?" on page 18

How do I start recording user activity?
You begin by opening Vugen and creating a blank script.

1. Start VuGen.

Select Start > All Programs > HP Software > HP LoadRunner > Virtual User Generator or

double-click theVirtual User Generator shortcut icon on your desktop.

2. Create a blank Web script.

a. On the VuGen Start Page, click theAdd New Script button . TheCreate a New Script
dialog box opens.
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A protocol is the language that your client uses to communicate with the back end of the
system. HP Tours is aWeb-based application, so you will create aWeb virtual user script.

b. Make sure theCategory type is Single Protocol. VuGen displays a list of the protocols that
are available for a single-protocol script.

c. From the list of available protocols, selectWeb - HTTP/HTML and click Create. VuGen
creates a blank Vuser script and displays the script in the VuGen Editor.

How do I record a business process to create a
script?
The next stage in creating user emulation is recording the events performed by a real user. In the
previous section, you created an empty Web script. In this section, you will track the events of one
passenger reserving a flight from Denver to Los Angeles and then check the itinerary.

1. Start recording on the HP Web Tours site.

a. Click Record > Record or click theRecord button on the VuGen toolbar. The Start
Recording dialog box opens.

Quick Start
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b. In theRecord into action box, select Action.

c. InRecord, selectWeb Browser.

d. In theURL address box, type http://localhost:1080/WebTours.

e. Keep all other default settings.

f. Click Start Recording. A new web browser opens and displays the HPWeb Tours site.

Quick Start
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Note: If there is an error opening the site, make sure that theWeb server is running. To
start the server, select Start > All Programs > HP LoadRunner > Samples > Web >
Start Web Server.

The floating Recording toolbar opens.

2. Log on to the HP Web Tours site.

a. On the HPWeb Tours home page, type the user credentials:

o For theUsername type jojo.

o For thePassword type bean.

b. Click Login. A welcome page opens.

3. Enter flight details.

a. Click Flights. The Find Flight page opens.

b. Define the following flight criteria:
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o Departure City: Denver (default)

o Departure Date:Keep the default, current date

o Arrival City: Los Angeles

o Return Date: Keep the default, tomorrow's date

c. Keep the rest of the default settings and click Continue. The search results appear.

4. Select a flight.

Click Continue to accept the default flight selection. The Payment Details page opens.

5. Enter payment information and book flight.

a. In theCredit Card box enter 12345678.

b. In theExp Date box enter 01/14 in the Exp Date box.

c. Click Continue. The Invoice page opens, displaying your invoice.

6. Check the itinerary.

In the left pane, click itinerary. The Itinerary page opens displaying the itinerary for flight you
booked above.

7. Log off the HP Web Tours Site

In the left pane, click Sign Off.

8. Stop recording.

Click theStop button on the floating toolbar to stop the recording process.

VuGen generates the required code and inserts the code into the Vuser script.

If the Design Studio opens, click Close to close the Design Studio.

How do I view my script?
You have now recorded a travel agent logging in, booking a flight, checking the itinerary, and logging
off. VuGen recorded your steps from themoment you clicked theStart Recording button to the
moment you clicked theStop Recording button. You can now use VuGen to view the script.

1. Display the Solution Explorer tab.

On the left side pane, make sure theSolution Explorer tab is selected.
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This tab provides you structured access to the various parts of a Vuser script, as well as to a
number of files that are associated with the Vuser script.

2. Display the Step Navigator tab.

Click theStepNavigator tab.

Quick Start
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The Step Navigator displays an icon-based view of the script that lists the actions of the Vuser as
steps. For each action you performed during recording, VuGen generated a corresponding step in
the Step Navigator.

The Step Navigator displays a snapshot icon to indicate that a specific step contains a snapshot.

3. View a step in the VuGen Editor.

Double-click any step in the Step Navigator to display the corresponding function in the VuGen
Editor. The Editor displays a text-based view of the script.
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In the Editor, the actions of the Vuser are listed as API functions. VuGen uses color-coding to show
the functions and their argument values in the script. You can type C or API functions, as well as
control flow statements, directly into the script.

How do I save the script?
Select File > Save Script As and save the script locally on your desktop. For example, type Scripts.
The script file should be zipped. After you have created your performance test, you will upload the
script to ALM Performance Center.

Quick Start
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Chapter 3: Creating and Designing
Performance Tests
This lesson explains how tomanage test assets in ALM, and the steps involved in creating and
designing a performance test.

Note: Some steps in the following lesson can be performed from ALM or from Performance
Center. In this lesson, you will perform these steps from ALM. For more details, see the
"Personalizing Performance Center" section in theHP ALM Performance Center Guide.

In this lesson you will learn about:

l "Logging in to ALM" below

l "Adding Vuser Scripts to ALM" on the next page

l "Monitoring Performance Tests" on page 24

l "Creating Performance Tests" on page 25

l "Designing Performance Tests" on page 26

Logging in to ALM
You log into ALM as follows:
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1. In yourWeb browser, enter the ALM URL. the ALM Login window opens.

2. Type your username and password, and click Authenticate.

Note: If ALM was configured for external authentication, the Name and Password fields do
not appear in this window, so skip this step.

3. Select the requiredDomain andProject and click Login.

Adding Vuser Scripts to ALM
The first step in your test design process is to add your Vuser script to ALM. Adding the script involves
two steps: Creating a scripts folder, and uploading the script to the folder.

How do I upload the Vuser Script?
You can upload the Vuser script to from within ALM, or directly from VuGen.

Uploading scripts from within ALM

You upload the script from within ALM, from the Test Planmodule, as follows:
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1. Make sure the script is saved locally and is zipped.

2. On the ALM sidebar, under Testing, select Test Plan.

3. Create a script folder.

a. Select Subject.

b. Click theNew Folder button, and specify a name for the folder, for example, Scripts.

c. Click OK to add the folder.

4. On themodule toolbar, click theUpload Vugen Script button. The Upload VuGen Scripts dialog
box opens.

5. In theSelect Folder box, select the scripts folder you created above.
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6. Click one of theSelect buttons and navigate to the location of the zipped script file.

7. Click Upload to upload the script.

Uploading scripts directly from Vugen

You upload the script from within Vugen using the HP ALM Connection dialog box.

1. Create a folder for the script.

2. In VuGen, select ALM > HP ALM Connection. The HP ALM Connection dialog box opens.

3. Enter the ALM Performance Center URL, and click Connect.

4. Enter your ALM Performance Center username and password, then click Connect.
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5. Select your domain and project, then click Login.

6. Click Close.

7. In VuGen, select File > Save Script As. The Save Script dialog box opens.

8. Select ALM Test Plan, and then select your scripts folder as the location to save the script to.
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9. Click Save. The Upload Script dialog box opens.

10. Accept the default setting.

Monitoring Performance Tests
Youmonitor performance test execution using the ALM Performance Center onlinemonitors.

For example, you use the System Resourcemonitors to monitor amachine's system resource usage
during a performance test and identify server performance bottlenecks.

A primary factor in a transaction's response time is its system resource usage. Using the ALM
Performance Center resourcemonitors, you canmonitor theWindows Resource usage on amachine
during a test run, and determine why a bottleneck occurred on a particular machine.

What is a monitor profile?
Tomonitor server resources during the test, you select the type of monitors to run and the servers
whose resources you want to monitor. You then add themeasurements tomonitor for each server.
Thesemonitor settings can be saved as amonitor profile which can be used by any performance test in
your project.

The following section will show you how to create amonitor profile and how add aWindows Resource
Monitor to it.
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How do I create a monitor profile?
You create and configuremonitor profile as follows:

1. On the ALM sidebar, under Testing, select Test Resources.

2. Create a folder for themonitor profile.

3. Select the folder, and click theNew Resource button. The New Resource dialog box opens.

4. Enter the required information, andmake sure that in the Type box, you selectMonitor Profile.

5. Click OK to add themonitor profile to the folder. For example:

6. Select themonitor profile, and in the right pane, select theMonitors Configuration tab.

7. Click the Add Monitor button. The Add New Monitor dialog box opens.

8. Select Windows Resources. The Edit Monitor dialog box opens, enabling you to select the
Windows Resources counters you want to monitor.

9. Enter the desired information, and click Save. Themonitor is added to your monitor profile.

You will add themonitor profile to the test as part of the test design process.

Creating Performance Tests
To create a test, you begin by creating a test folder, and then creating the test and adding it to the
folder. In the next section, you will learn how to design the test in the Test Designer.

How do I create a performance test?
You create the test as follows:

1. On the ALM sidebar, under Testing, select Test Plan.

2. Select Subject. Click theNew Folder button, and specify a name for the folder, for example,
Tests. Click OK to add the folder.
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3. Select the folder, and click theNew Test button. The New Test dialog box opens.

4. Enter the required information, andmake sure that in the Type box, you select Performance Test.
For example:

5. Click OK to add the test to your test folder. For example:

Designing Performance Tests
You design your performance test in the Performance Test Designer.
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How do I open the Performance Test Designer?
You open the test designer as follows:

1. On the ALM sidebar, under Testing, select Test Plan.

2. Select the test you created above, and click theEdit Test button on the toolbar. The Test
Designer opens.

3. If a message box opens, click Show Test Designer to open the Test Designer.

How do I design the performance test?
From theWorkload tab in the Performance Test Designer, you perform the basic test design steps.
You design the test as follows:

1. Select a workload type for the test.

When the Performance Test Designer opens, you will be prompted to select a workload type for the
test. Accept the default, Basic Schedule, by test, by number.

2. Assign a Controller to the test.

a. Click the browse button adjacent to theController box. The Select Controller dialog box
opens.

b. Select Specific.

c. From the list that appears, select the host machine that has been assigned the Controller and
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load generator (C+LG) purpose.

3. Add Vuser scripts.

a. If the Scripts Tree pane is not displayed on the right, click the Select Scripts button on the
toolbar to open it. The Scripts Tree displays the script that you uploaded previously to ALM.

b. In the Scripts Tree, select the script and click the left arrow to add it to the test. The script
appears in the Groups pane.

4. Add load generators.
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a. On theGroups pane toolbar, in the LG Distribution box, click the arrow and select Assign
manually.

b. In the Groups Pane, in the Load Generators column, click theSelect load generators link.

The Select LoadGenerators dialog box opens.

c. Select theSpecific tab, and from the list that appears, select the host machine that has been
assigned the Controller and load generator (C+LG) purpose.

5. Configure the schedule settings.
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A schedule defines the actions of the Vusers for the performance test run, for example the behavior
of 10 Vusers emulating 10 travel agents simultaneously logging on to HP Tours, booking flights,
checking itineraries, and so on.

Because typical users do not perform the same action simultaneously, the Scheduler allows you to
schedule a performance test according to amore realistic portrayal of typical user behavior.

Define the schedule as follows:

In the lower area of theWorkload tab, in theGlobal Schedule pane, click in each of the schedule
actions in the Actions grid and define them as follows:

n Initialize.

n Start Vusers.

n Duration.

n Stop Vusers.

The schedule graph displays a graphical representation of the defined schedule. The lines in the
graph correspond to the actions defined in the Actions grid.
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How do I add the monitor profile to the test?
You add themonitor profile to the test as follows:

1. In the Performance Test Designer, select theMonitors tab.

2. On the toolbar, click Add Monitor Profile. TheMonitor Profiles pane opens on the right,
displaying the available monitor profiles.

3. In theMonitor Profiles Tree, select themonitor profile and click the left arrow to add it to the test.

How do I save the test?
Click Save at the bottom of the page to save the test settings. Then click Close to Close the
Performance Test Designer.
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Chapter 4: Running Performance Tests
This lesson explains the steps that are necessary before you run the performance test, and how to
begin test execution.

Note: Some steps in the following lesson can be performed from ALM or from Performance
Center. In this lesson, you will perform these steps from ALM. For more details, see the
"Personalizing Performance Center" section in theHP ALM Performance Center Guide.

In this lesson you will learn about:

l "Creating Test Sets" below

l "Reserving Timeslots" on page 36

l "Running Performance Tests" on page 37

Creating Test Sets
The next step in the performance testing process is the creation of a performance test set.

What is a test set?
After you design the performance test in the Test Planmodule, you organize the test execution by
creating a test set in the Test Labmodule and adding an instance of the test to the test set. The
purpose of a test set is to enable you to group together tests that were created for similar goals.

How do I create a test set?
You create the test set and add the test to it as follows:

1. Create the test set.

a. On the ALM sidebar, under Testing, select Test Lab.

b. Click theNew Folder button, and specify a name for the Test Set folder, for example, Test_
set_folder.

c. Click OK to add the folder.
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d. Select the folder you created above, and click theNew Test Set button. The New Test Set
dialog box opens.

e. Enter the required information, andmake sure that in the Type box, you select Performance.

f. Click OK. The test set is added to the Test Set Folder.
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2. Add the performance test to the test set.

a. Select the test set you just created, and in the right pane, click theExecution Grid tab.

b. Above the Execution Grid tab name, click theSelect Tests button. The Test Plan tree appears
on the right, enabling you to locate your Test Plan folder and performance test.

c. In the Test Plan Tree, select the script and click theAdd Test to Test Set button to add it to
the Execution Grid tab.

d. Click the close button to close the Test Plan Tree.
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Reserving Timeslots
Before you run the test, you reserve a timeslot to ensure that the resources needed will be available for
the duration of the test.

How do I reserve a timeslot?
You reserve a timeslot as follows:

1. On the ALM sidebar, under Testing, select Timeslots.

2. Click theNew Timeslot button. The Timeslot Reservation dialog box opens.

3. Define the following information:

n Run. Choose Performance Test.

n Start. ChooseManually as themethod for executing tests. The timeslot reservation reserves
testing resources only.

n Name. Enter a name for the timeslot.

n Select a test instance. Navigate to the test set you created above, and select the test to link it
to the timeslot. The number of Vusers and hosts that were defined as part of the test design
process are automatically displayed.

n Duration. Set the start time, and enter a duration for the test.

n Post-Run. Select Collate and Analyze.

4. Click Calculate Availability. The availability of the requested resources during the selected
timeslot is calculated. The results of this calculation are displayed in the Timeslot Status tab and
graphically on the time chart.
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Note: If the timeslot cannot be reserved, reselect your resources or adjust the start time,
taking into account the reasons displayed in the Timeslot Status tab.

5. When you find a valid timeslot, click Submit to save the timeslot.

Running Performance Tests
Now that you have designed the performance test, added an instance of the test to a test set, and
reserved a timeslot for the test, you are ready to run the test and observe how your application performs
under load.

How do I run the performance test?
You run the performance test as follows:

1. On the ALM sidebar, under Testing, select Test Lab.

2. Select your test in the left pane.

3. Click theExecution Grid tab.

4. Select the test in the Execution Grid tab, and click theRun Test button. The Run Performance
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Test dialog box opens, and the timeslot you created above is displayed in the select timeslot grid.

Note: If no timeslot was reserved from the Timeslots module, the Run Performance Test
dialog box lists alternative timeslots.

5. Select a timeslot in the grid, and click Run. ALM Performance Center begins the performance test
execution process, and the Performance Test Run page enabling you tomanage andmonitor the
test as it runs.

What does the Performance Test Run page display?
The Performance Test Run page is the control center from which the test run is managed and
monitored.

The Performance Test Run page displays the following:
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Pane Description

Performance
Test Details

The Performance Test Details Pane at the top of the page provides three views:

l Groups View. This is the view displayed in the above image. TheGroups view
displays the statuses of the Vusers in each Vuser group in the performance test.

l Transactions View. The Transactions view displays how many transactions
have been executed successfully or unsuccessfully.

l Messages View. TheMessages view displays error, warning, debug, and output
messages that are sent to the Controller by the Vusers and load generators
during a test run.

Summary The Summary pane displays a synopsis of the running performance test.

Online
Graphs

The onlinemonitor graphs display performancemeasurements for those resources
beingmonitored in the test. This enables you tomonitor how the application under
test is performing in real time and identify where potential bottlenecks exist.

Topology Displays any defined topologies for the test.
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Chapter 5: Post-Run Analysis and Trending
This lesson explains how to analyze test run data using HP LoadRunner Analysis, and how to view
performance improvements and regressions using the Trend Report feature.

In this lesson you will learn about:

l "Analyzing Performance Test Run Results" below

l "Viewing Performance Improvements and Regressions" on page 48

Analyzing Performance Test Run Results
Now that you have completed running the performance test, you use HP LoadRunner Analysis to
analyze the performance data generated during the test run. Analysis gathers the performance data into
detailed graphs and reports. Using these graphs and reports, you can pinpoint and identify the
bottlenecks in the application, and determine what changes need to bemade to the system to improve
its performance.

How do I view Analysis information?
To provide for more interesting results, a sample analysis session is provided, which is based on a
performance test similar to the one you ran.

To open the sample Analysis session:

1. Select Start > All Programs > HP Software > HP LoadRunner > Analysis or double-click the

Analysis shortcut icon on your desktop.

2. Select File > Open. TheOpen Existing Analysis Session File dialog box opens.

3. Navigate to the <Analysis Standalone Installation>\Tutorial folder.

4. Select analysis_session and click Open. Analysis opens the session file in the Analysis window.

The data contained in this sample session is examined inmore detail in the sections that follow.

To open the Analysis session for the test you ran:

To view Analysis data for your actual performance test, you perform the following steps:
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1. Connect Analysis to ALM Performance Center.

a. In Analysis, select Tools > HP ALM Connection. The HP ALM Connection dialog box
opens.

b. Enter the ALM Platform URL, for example, http://server:8080/qcbin, and click Connect.

c. Under Step 2: Authenticate User Information, enter your ALM user credentials, and click
Authenticate.

d. Select your domain and project and click Login. The dialog box should look as follows:
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e. Click Close.

2. Open the Analysis session file for your performance test.

a. Select File > Open. TheOpen Analysis Session dialog box opens.

b. Select Test Lab. The test sets in the project are displayed.

c. Navigate to theResults.zip file for the instance of your performance test that you want to
analyze.
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d. Double-click theResults.zip file. The analysis session file is downloaded from ALM
Performance Center and is opened in Analysis.

Did I reach my goals?
Analysis opens displaying the Summary Report. The Summary Report provides general information
about the performance test run. In theStatistics Summary of the report, you can see how many
Vusers ran in the test and view other statistics such as the total/average throughput, and the
total/average hits. The Transaction Summary of the report lists a summary of the behavior of each
transaction.

How can I view the graphs?
The graph tree in the left pane of the Analysis window shows the graphs that are open for viewing.
From the graph tree, you can choose to open new graphs and remove graphs that you no longer want to
view. The graphs are displayed in the graph viewing area in the right pane of the Analysis window.
You can view data from the selected graphs in the graph legend in the lower pane of the window.

As an example, we will now analyze the Average Transaction Response Time graph. Using this graph,
you can view the behavior of the problematic transactions during each second of the performance test
run. In this section, you view the behavior of the check_itinerary transaction.

To open and analyze the Average Transaction Response Time graph:

1. Click theAdd New Graph button . TheOpen a New Graph dialog box opens.

2. Under Transactions, select Average Transaction Response Time.
.
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3. Click Open Graph. The Average Transaction Response Time graph opens in the graph viewing
area.
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4. In the legend, click check_itinerary. The check_itinerary transaction is highlighted in the graph
and in the legend below the graph.

Notice how the average response time of the check_itinerary transaction fluctuates greatly
compared to the other transactions at the bottom of the graph, which follow amore or less stable
average response time.

How can I compare data from different graphs?
You can join two graphs together to see the effect of one graph's data upon another graph's data. This
is called correlating two graphs. For example, you can correlate the Running Vusers graph with the
Average Transaction Response Time graph to see the effect of a large number of Vusers on the
average response time of the transactions.
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1. Click theAdd New Graph button . TheOpen a New Graph dialog box opens.

2. UnderVusers, select Running Vusers.

3. Click Open Graph. The Running Vusers graph opens in the graph viewing area.

4. Select theRunning Vusers graph and click theMerge Graphs button .

5. From theSelect graph to merge with list, select Average Transaction Response Time.

6. In theSelect type of merge area, select Correlate, and click OK.

The Running Vusers and Average Transaction Response Time graphs are now represented by one
graph which opens in the graph viewing area.

Another Analysis tool, Auto Correlate, merges all graphs containing data that could have had an effect
on a given transaction. Correlations of the transaction with each element are displayed, allowing you to
deduce which elements had the greatest effect on the given transaction.

How can I sort graph data?
You can filter graph data to show fewer transactions for a specific segment of the performance test,
and you can sort graph data to show the data in more relevant ways. For example, you can filter the

Quick Start
Chapter 5: Post-Run Analysis and Trending

HP ALM Performance Center (12.01) Page 47 of 56



Average Transaction Response Time graph to display only the check_itinerary transaction.

1. Click Average Transaction Response Time in the graph tree to open the graph.

2. Select the graph and click theSet Filter/Group by button .

3. In the Transaction Name value box, select check_itinerary and click OK.

The filtered graph displays only the check_itinerary transaction and hides all the other transactions.

How can I publish my findings?
You can publish the findings from your analysis session in an HTML orMicrosoft Word report. The
HTML report can be opened and viewed in any browser. TheWord report is more comprehensive than
the HTML report, enabling you to include general information about the performance test and to format
the report to include your company's name, logo, and the author's details.

For more information about analyzing performance test results, refer to the HP LoadRunner Analysis
User Guide.

Viewing Performance Improvements and
Regressions
A trend report is an ALM Performance Center feature that allows you to view changes in performance
from one performance test to another, or across several performance tests. By analyzing these
changes, you can easily identify improvements or regressions in themeasurement's performance.

For example, if you would like to analyze the performance trend of the average transaction response
timemeasurement of Transaction X, then the trend report would display the changes in the response
time from one test to the next, clearly indicating whether this measurement improved (where the
response time decreased) or regressed (where it increased).

What steps are involved in working with trend
reports?
The process of creating and viewing a trend report involves the following steps:

l Step 1 - Creating the trend report. Creating the basic trend report by defining its name,
description and selecting a template.

l Step 2 - Adding test runs to the trend report. Extracting test run data from Analysis to the trend
report.
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l Step 3 - Viewing trend report data. Opening the trend view and analyzing the trending
information.

Wewill now discuss these steps in more detail.

Creating the Trend Report

You create the trend report from themain Trend Reports page.

Note: Some steps in the following lesson can be performed from ALM or from Performance
Center. In this lesson, you will perform these steps from ALM. For more details, see the
"Personalizing Performance Center" section in theHP ALM Performance Center Guide.

To create the trend report:

1. Open the main Performance Trending page.

a. On the ALM sidebar, under Testing, select Test Runs.

b. Click thePerformance Trending button. TheMy Performance Center application opens,
displaying the Performance Trending page.

2. Open the Trend Report Creation page.

On the Performance Trending page, click theNew Trend Report button . The Create New
Trend Report page opens.
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3. Define the General Details and Content and Layout settings.

a. In the Create New Trend Report page, define the following information:

o In theGeneral Details pane, enter a name and description for the trend report.

o In theContents and Layout pane, select the Transaction Trends template.

b. Click Create to create the trend report. The Select Test Runs to Trend Report dialog box
superimposes on the TrendOverview tab.

4. Add Performance Test Runs to the Trend Report.

From theProject, Test Set and Test lists respectively, select the performance test that you want
to trend. All analyzed instances of the performance test appear in the table.
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Select those analyzed instances of the test that you want to add to the trend report, and click Add.
Performance Center uploads the test runs from Analysis and adds them to the trend report. The
trend report opens displaying the TrendOverview tab.

Notes:

n To add test runs to the trend report, theremust be a data processor in your project's host
pool. For details, contact the Administrator.

n The process whereby ALM Performance Center extracts the performance test data from
Analysis is very labor intensive on the data processor andmay take anywhere from several
minutes to over an hour. We recommend that you use a data processor dedicated for this
purpose.

Viewing Trend Report Data

In the following section, we will look at trending information for the average transaction response time
measurement only.

To view trending information:

On the trend report, click thePerformance tab.

In the trend view that opens, you will see a table that displays the transactions that were present in the
test run, as well as the average transaction response times for each selected instance of the test run.

By comparing these average transaction response time figures, you can identify if the performance of
the transaction improved or regressed from one test run to the next.
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The following example illustrates this point.

In the trend view shown above, four transactions (TRX_01, TRX_02, TRX_03, and TRX_04) are
displayed and their average Transaction Response Timemeasurement is being trended from four
performance test runs: 3, 4, 5, and 6.

Test run 3 has been automatically defined as the baseline run, (as indicated by the wordBase in
brackets). This means that the average transaction response times contained in the other tests are
compared to test run 3 only.

In test run 3, the average transaction response time for TRX_01was 2.045. The average transaction
response time for the same transaction in test run 4was 4.073, which represents a slower response
time and therefore a regression in the performance of this measurement. The percentage difference
between the two figures is displayed in parenthesis, in this case +99.17%.

In test run 6, the average transaction response time for TRX_01was 1.05, which represents a a faster
response time that test run 3, and therefore a performance improvement. The percentage difference
between the two figures is displayed in parenthesis, in this case -48.66%.
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Chapter 6: Summary
ALM Performance Center enables you tomanage the following phases of the testing process: Creating
and designing performance tests, preparing to run performance tests, running performance tests, and
post-run analysis.
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Phase Description

Creating and Designing
Performance Tests

Setting up the test environment by defining events that occur
during the testing session.

Preparing to Run Performance
Tests

Adding the performance test to a test set and reserving a
timeslot for the test.

Running Performance Tests Driving, managing, andmonitoring the test.

Post-Run Analysis Analyzing the performance data generated during the test run.
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Send Documentation Feedback
If you have comments about this document, you can contact the documentation team by email. If an email client is configured on this
system, click the link above and an email window opens with the following information in the subject line:

Feedback on Quick Start (ALM Performance Center 12.01)

Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a webmail client, and send your feedback to SW-
Doc@hp.com.

We appreciate your feedback!

mailto:SW-Doc@hp.com?subject=Feedback on Quick Start (ALM Performance Center 12.01)
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