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Chapter 1: Introduction
This section introduces the Getting StartedWith BPM - Best Practices and includes the following
topics:

n "Scope andMotivation" below

n "Why Use BPM?" below

Scope and Motivation
Business Process Monitor (BPM) is one of the HP Business ServiceManagement (Business
ServiceManagement) data collectors. BPM proactively monitors enterprise applications in real
time, identifying performance and availability problems before users experience them. It enables
you tomonitor sites from various locations, emulating the end-user experience, and so assess site
performance from different client perspectives.

The purpose of this document is to provide BPM users with an understanding of how to deploy BPM
quickly and correctly, and how to realize value in a short time.

The target audience for this guide is customers who are new implementers of BPM, or HP partners
who already have Business ServiceManagement (Business ServiceManagement) knowledge, but
are new to BPM. While no deep networking/encryption knowledge is needed, you will need to know
the protocol and encryption used by themonitored application.

Why Use BPM?
BPM should be used to gather data during inactive hours of the users, so you will be able to detect
problems before a real user encounters them. In addition, BPM is the basic monitor for building
SLAs, because it has the same transactionmonitored at the same time intervals.
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Chapter 2: Installing BPM
The following provides instructions for installing BPM.

Before beginning the installation, verify that you have Java version 1.7 or above installed on your
computer. If not, download themost recent Java version from the Java website.

1. Download your BPM from the HP Software Support Online web site
(http://www.hp.com/go/hpsoftwaresupport). Go to Software Support Online > Downloads >
Software Patches and select Application Performance Management as the product. For
each version, check for Business Process Monitor as a sub-product.

2. Save the file under: C:\Temp.

3. Click the executable installation file: BPM_9.23_setup.exe. The BPM Setup wizard appears.

4. In the first screen, select your language and click OK.

5. In the Initialization screen, select Partial Installation and click Next.
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6. In the Product Customization screen, accept the defaults folders or browse to and select the
application and data folders and click Next.
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7. In the Product Requirements screen, verify that there is enough disk space for the installation
and click Next.
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8. In the Pre-Install Summary screen, verify that the application and data folder paths are correct
and click Install.
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The Installing screen appears.
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The BPMConfiguration wizard is automatically launched after the setup program installed the
BPM application.

9. In the Run as User screen of the BPMConfigurationWizard, configure the BPM data collection
to run as a system user, or as a specific user. Running it as a specific user limits access to
resources, settings, and applications located on the local machine. (This may not be true for
resources located on remotemachines, where a specific user may have different privileges
than the local system user.)

10. In the Server Authentication screen, select Use basic authentication and enter your BSM
user name and password in case your Business ServiceManagement gateway access is
protected by user name
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11. In the Instance Definition screen, select Define Instance and type your BSM details. The
Location name is used for script assignment, so give it a meaningful name (for example, New
York, Office).
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12. When the Finish screen appears, click Close.

13. InWindows, select Start > Programs > HP Business Process Monitor > Business
Process Monitor Admin (or in an internet browser, access http://localhost:2696/).

If an error message appears as shown below, it is probably due to your client Java version.
Make sure you have Java version 1.7, or above. You can download themost recent Java
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version from Java.com.

14. Verify that your instance connected successfully by checking the Health value in the General
Information page.
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Chapter 3: Connecting BPM to BSM
1. From your internet browser, access http://localhost:2696/. The BPM application appears.

2. Click the create new instance button . The Create New InstanceWizard appears.

3. In the Define Identification Parameters screen, define the identification parameters for the new
instance. All fields aremandatory. Make sure you can access the Fateway Server URL from
the BPMmachine. The Location name is used for script assignment, so give it a meaningful
name (for example, Boston, Office).

4. Click Finish.

5. Refresh your browser and verify that BPM successfully connected to your BSM.

6. If your Gateway Server URL is not accessible from your BPMmachine, or if you need a proxy,
an error message appears. If this occurs, click theConfiguration tab, reconfigure the details,
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and click Save.

If you successfully connected, the following status appears.
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Chapter 4: Creating Scripts in TruClient and
Defining Transactions

Note: If you are using script services from other teammembers or companies, you can
download the Business Process Template for BPM Scripting Requests from the HP Software
Support Online (SSO)Manuals site (http://www.hp.com/go/hpsoftwaresupport) to define you
script requirements.

1. Download and install VuGen from your DVD.

2. Click File > New Script and Solution.

3. Select the relevant protocol. For a web application , select TruClient Ajax Firefox.

4. Click the Develop Script button to start your recording. A Firefox window
appears.

5. Click the red circle button to start your recording.
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6. In the Firefox address bar, type the address of your web application. Each action you perform
is indicated by a recording event in the TruClient add-in.

7. After you finish recording your business transaction, open the Transaction Editor, and wrap the
relevant action in the transaction name. Make sure that you define a start point and end point
for each transaction, and click Apply.
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8. In the Transaction Editor, click the plus icon to addmore transactions.
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9. After defining your transactions, save your script.
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10. Close the Firefox window.

11. In the Vugen Editor, select File > Manage Zip Files > Export Zip Files to export your script
to a zip file.
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12. To be able to view and edit the script, select All files , and click OK.

13. Since the script size can be huge, export another copy of the script and select Runtime only
and upload this copy to Business ServiceManagement.
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Chapter 5: Creating Business Applications
1. Select Admin > End User Administration > Monitoring.

2. Right-click End User Management (default view) and select Add > Application and its
BPM Configuration.

3. In the Default Transaction Settings screen, define your transaction settings for performance
monitoring.

Note: You can wait to define these settings after you determine your application's
expected behavior.
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4. In the Set TransactionMonitor Scripts screen, click Script Repository to view the scripts in
the repository.
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5. To select a script, double-click the script in the Available Scripts tree.

6. In the Application Data Collectors screen, click .

7. In the Add Data Collectors screen, assign the data collectors to a location.
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8. In the Application Data Collectors screen, edit the schedule for each location, or leave the
default value (every 15minutes).

9. After reviewing your settings, click Finish and your script will start to run. I can take up to 20
minutes to see the first data point, depending on BPM's scheduled jobs.

10. Please continue from here with our setting started to see how to view BPM data in BSM.
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Chapter 6: Configuring Alerts
1. In theMonitoring tab, select your application.

2. Click theAlerts tab in the right pane.

3. Click the Trigger Condition tab.
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4. In theAlert name field, type ameaningful name for the alert. In Outlook, you will be able to
filter your alerts by this name.

Note: The contents of theSeverity field is for internal use. The trigger criteria is set
according to the number of locations you have, and the frequency of themonitor runs. If
you have four locations around the word, and if two subsequent runs fail, then a real
problem alert is indicated and false alerts are ignored.

5. Click the Filters tab.
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6. Select the relevant transactions by which to filter the alert.

7. Click theActions tab.
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8. Select theSend to specified recipients option.

9. Click theAdvanced Settings tab.

10. To send an alert when the trigger condition clears, click theSend clear (follow up) alert
notification option.
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11. To limit the number of alerts that are sent, click theSend no more than one alert for every
option and enter the time period.
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Chapter 7: Configuring Transaction
Thresholds

In BSM there are threemethods for setting performance transaction thresholds:

l Manual – Provides full control of the transaction thresholds

l Semi-automatic – Utilizes the Calculate Suggested Thresholds tool which provides static
thresholds based on a specific time period.

l Automatic – Provides automatic threshold baselines

In order to get accurate results, take into account that each location has different thresholds. You
can set a different threshold for each transaction location.

To create threshold baselines for Business Process Monitor, you first need to activate a general
key to enable this feature. Then you adapt the thresholds for each application. We recommend that
you create the thresholds one at a time in order to ensure that the results are accurate. You can then
add the results to your best practices.
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Formore information, see the Business Process Monitor Administration Guide which is available
for download from the SSO site: http://support.openview.hp.com/selfsolve/manuals.
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Chapter 8: Viewing Data in BSM
You can view your monitored application data by accessing the 360° View in System Health or by
running the BPM PerformanceOver Time report.

Viewing Data in Service Health
The BPM checks if there is a new configuration every 2minutes. If you schedule your script to run
an application every 15minutes, the first data point arrives within 17minutes.

If a script fails, a red icon appears near the relevant transaction CI, You need to fix the script,
and upload it again.

1. In BSM, click Application > Service Health > 360° View.

2. In theName column, click the application to expand it.The latest monitored data is displayed.

.

Viewing Data in BPM Performance Over Time
Report

You can view your data in the BPM PerformanceOver Time report.This is one of themost important
reports for BPMmonitoring. The BPM PerformanceOver Time report displays a flat view of the data
for all your BPM applications and transactions.

1. In BSM, click Applications > Analysis Reports > BPM Performance Over Time.

2. In theApplication Filter, select your application.
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3. Click Run.

4. To verify that all your BPMs are reporting, in theGroup by field, select Location.The report
displays our BPM data and you can determine if all you BPMs are reporting data as expected.

5. To view an advanced report that summarizes all data collection problems, in BSM, click
Applications > Utilities > BPM Self Monitoring. The BPM Self Monitoring report displays
valuable information about your BPM health based on the data that is expected to arrive.

Viewing Data in Scheduled Reports
You can configure schedules to enable specified recipients to automatically receive reports,
through email, at regularly defined intervals.
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You can schedule Custom Reports, Trend Reports, and Service Reports defined in the Report
Manager, or reports saved from the specific report page. You can also schedule Favorite Filter
reports.

1. To create a scheduled report, click Applications > User Reports > Report Manager.

This page enables you tomanage the contents of Report Manager and view, edit, and clone
existing components, configure new user reports, email reports, and create a schedule for
selected reports to run.

2. Click and select New Custom Report to create your first report using the built-in BSM
reports.

3. If you want to run this report in the background, select theRefresh the report every option and
select the number of minutes.
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4. Click Next.

5. In theReport Components page, click . TheAdd Component page appears.

6. All BPM report are located in theEnd User Management folder.
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7. Expand the contents of theEnd User Management folder and click Status Reports.

8. From theReport drop down list, select BPM Performance Overtime By Transaction.
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9. Click OK.

10. In theReport Components page, click . TheAdd Component page appears.

11. Under theEnd User Management folder, click Analysis Reports.

12. From theReport drop down list, selectMetrics Over Time for a report that displays over time
measurements.

13. Click OK.

14. For each report, select the report and click theEdit Filter button.
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15. Select the relevant application.
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Chapter 9: BPM Report Recommendation
Use the following reports for isolating problems:

l Performance Over Time Report

You can view your application availability and performance in one report. You can select to view
the data by transaction or by location over time. By clicking on a specific transaction or location,
you can view the Error Log, Snapshot on Error, Transaction Breakdown, and Error vs Availability
Over Timer in the same screen.

In BSM, select Applications > End User Management > Analysis Reports > BPM
Performance Over Time.

l Triage Report

Data in the Triage report is organized by transactions and locations, and includes a transaction
breakdown component, as well as graphs showing error data. This report also includes
information about the health of the transaction scripts running at the various locations (Script
Health), as well as indicators for the health of the BPM data collectors.

In BSM, select Applications > End User Management > Analysis Reports > Triage
Report.
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l Metrics Report

This report enables you to select one or moremetrics for selected applications and to view their
behavior over a period of time. By selectingmultiple metrics, you can compare their behavior to
discover possible correlations between them. You can also view data for up to four different time
comparisons.

In BSM, select Applications > End User Management > Analysis Reports > Metrics Over
Time.
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We appreciate your feedback!
If you have comments about this document, you can contact the documentation team by email. If
an email client is configured on this system, click the link above and an email window opens with
the following information in the subject line:

Feedback on Getting Started With BPM - Best Practices (Business Service Management
9.23)

Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a webmail client,
and send your feedback to Sw-doc@hp.com.
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