Summary
DP 8.1 (Windows): IDB Service (hpdp-idb) does not start during the update and import of the old IDB fails.
Error
The following can be seen in the "Installation status" window:
Check the IDB import output for warnings or errors.
During the update, 2 omnimigrate logs are created, one for the export and one for the import.
In case the IDB cannot start, the import log file (named like C:\Program Files\OmniBack\log\omnimigrate_2014-03-21_03-06-15.log) shows:
Cannot start "hpdp-idb" service, system error:
[1053] The service did not respond to the start or control request in a timely fashion.
Cause
The issue appears during updates from all versions (that are supported to directly update to DP 8.1) and to installations where:
- A common installation directory is used that contains a space character.
- A separate data path is used that starts with "Program" and is located on the C:\ drive.
Examples:
-
A common directory C:\Program Files\OmniBack or D:\Program Files\OmniBack.
-
A common directory C:\Data Protector.
-
Binary path C:\Program Files\DP-Bin and data path C:\Program Files\DP-IDB
Fix
The solution consists of the sequence of the following steps (assuming that common path C:\Program Files\OmniBack has been used).
1) Delete the file "C:\Program".
2) Do "omnisv stop" and "omnisv start".
3) Use "omnisv status" to check that all services have been started.
4) Check the location where the IDB has been exported to (default is C:\Program Files\OmniBack\tmp\export):
You should see a mmdb and a cdb folder there.
5) Open power shell and go to C:\Program Files\OmniBack\bin
6) Run the import manually:
PS C:\Program Files\OmniBack\bin> perl omnimigrate.pl -import -shared_dir "C:\Program Files\OmniBack\tmp\export" -force
Importing HP Data Protector Internal Database.
This may take a few minutes.
Importing configuration and session messages ... OK!
Importing data ...
COMPOUNDS ########################################### [100%]
OBJECTS ########################################### [100%]
DCBF_DIR ########################################### [100%]
DCBF_INFO ########################################### [100%]
STORES ########################################### [100%]
SESSIONS ########################################### [100%]
POOLS ########################################### [100%]
DEVICES ########################################### [100%]
CARTRIDGES ########################################### [100%]
MEDIA ########################################### [100%]
OBJ_VERSIONS ########################################### [100%]
MEDIA_POSITIONS_0 ########################################### [100%] OK!
Done!
PS D:\Program Files\OmniBack\bin>
7) Use the DP GUI and check "Devices and Media" and the "Restore" context for appropriate content.
1) Delete the file "C:\Program".
2) Do "omnisv stop" and "omnisv start".
3) Use "omnisv status" to check that all services have been started.
4) Check the location where the IDB has been exported to (default is C:\Program Files\OmniBack\tmp\export):
You should see a mmdb and a cdb folder there.
5) Open power shell and go to C:\Program Files\OmniBack\bin
6) Run the import manually:
PS C:\Program Files\OmniBack\bin> perl omnimigrate.pl -import -shared_dir "C:\Program Files\OmniBack\tmp\export" -force
Importing HP Data Protector Internal Database.
This may take a few minutes.
Importing configuration and session messages ... OK!
Importing data ...
COMPOUNDS ########################################### [100%]
OBJECTS ########################################### [100%]
DCBF_DIR ########################################### [100%]
DCBF_INFO ########################################### [100%]
STORES ########################################### [100%]
SESSIONS ########################################### [100%]
POOLS ########################################### [100%]
DEVICES ########################################### [100%]
CARTRIDGES ########################################### [100%]
MEDIA ########################################### [100%]
OBJ_VERSIONS ########################################### [100%]
MEDIA_POSITIONS_0 ########################################### [100%] OK!
Done!
PS D:\Program Files\OmniBack\bin>
7) Use the DP GUI and check "Devices and Media" and the "Restore" context for appropriate content.