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Documentation Updates

The title page of this document contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition of a 
document, go to:

http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign-in. To register for an HP 
Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product 
support service. Contact your HP sales representative for details.
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Support

Visit the HP Software Support web site at:

http://www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and 
support that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and 
efficient way to access interactive technical support tools needed to manage your business. 
As a valued support customer, you can benefit by using the support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. 
Many also require a support contract.  To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html 

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp 
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Welcome to This Guide

Welcome to the HP ALM Performance Center Quick Start. 
ALM Performance Center is HP’s Web-enabled global performance testing 
tool, designed to streamline the testing process and increase the test 
efficiency for multiple concurrent performance tests across multiple 
geographic locations.

This Quick Start is a self-paced guide designed to lead you through the 
process of creating, running, and analyzing a performance test, and to 
introduce you to the ALM Performance Center testing environment.

Note: 

➤ This guide assumes that your ALM Performance Center environment has 
been fully installed and configured, and that a domain and project have 
been set up. For more information, contact your Performance Center 
administrator.

➤ This Quick Start only describes how to work with the ALM features 
associated with performance testing. For a comprehensive guide to 
working with ALM, refer to the HP Application Lifecycle Management 
Tutorial.
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How This Guide is Organized

This guide contains the following lessons:

ALM Help

ALM Help is an online help system that describes how to use ALM. You can 
access ALM Help in the following ways:

➤ In the main ALM window, select Help > ALM Help I to open the home 
page. The home page provides quick links to the main help topics.

➤ Click  in the ALM masthead to open the ALM Help to the topic that 
describes the current page.

Lesson Description

Lesson I: Introducing 
ALM Performance Center

Provides an overview of ALM Performance Center 
and the performance testing applications. 

Lesson 2: Creating Vuser 
Scripts

Describes the steps involved in recording Vuser 
scripts using HP Virtual User Generator.

Lesson 3: Creating and 
Designing Performance 
Tests

Describes the steps involved in creating and 
designing performance tests.

Lesson 4: Running 
Performance Tests

Describes the steps that are necessary before 
running a performance test, and how to begin test 
execution.

Lesson 5: Post-Run 
Analysis and Trending

Describes how to analyze test run data using HP 
LoadRunner Analysis, and how to view performance 
improvements and regressions using the Trend 
Reports feature. 

Lesson 6: Summary Provides a summary of the testing process phases 
that are managed using ALM Performance Center.
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ALM Help Guides

The ALM Help consists of the following guides and references, available 
online, in PDF format, or both. PDFs can be read and printed using Adobe 
Reader, which can be downloaded from the Adobe Web site 
(http://www.adobe.com).

HP Application Lifecycle Management (ALM) Guides

Reference Description

Using the ALM Help Explains how to use ALM Help and how it is organized.

What’s New? Describes the newest features in the latest version of 
ALM. To access, select Help > What's New.

Movies Short movies that demonstrate the main product 
features. To access, select Help > Movies.

Readme Provides last-minute news and information about ALM.

Guide Description

HP ALM User Guide Explains how to use ALM to organize and execute all 
phases of the application lifecycle management process. 
It describes how to specify releases, define requirements, 
plan tests, run tests, and track defects.

HP ALM 
Administrator Guide

Explains how to create and maintain projects using Site 
Administration, and how to customize projects using 
Project Customization.

HP ALM Lab 
Management Guide

Explains how to use Lab Management to manage lab 
resources used for functional and performance testing on 
remote hosts.

HP ALM Tutorial A self-paced guide teaching you how to use ALM to 
manage the application lifecycle management process.

HP ALM Installation 
and Upgrade Guide

Describes the installation and configuration processes for 
setting up ALM Server, and the project upgrade process.

http://www.adobe.com
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HP ALM Performance Center Guides

HP ALM Lab 
Management 
Troubleshooting 
Guide

Provides information for troubleshooting problems while 
working with HP ALM Lab Management.

HP ALM External 
Authentication 
Configuration Guide

Describes the configuration needed to access  ALM with 
external authentication.

HP ALM Business 
Views Microsoft 
Excel Add-in User 
Guide

Explains how to install and use the Business Views 
Microsoft Excel Add-in to create and configure business 
view Excel reports.

HP Business Process 
Testing User Guide

Explains how to use Business Process Testing to create 
business process tests.

Guide Description

HP ALM Performance 
Center Quick Start

A self-paced guide giving the Performance Center user a 
high level overview of creating and running performance 
tests.

HP ALM Performance 
Center Guide

Explains to the Performance Center user how to create, 
schedule, run, and monitor performance tests. Explains 
to the Performance Center administrator how to 
configure and manage Performance Center projects.

HP ALM Performance 
Center Installation 
Guide

Describes the installation processes for setting up 
Performance Center Servers, Performance Center Hosts 
and other Performance Center components.

HP ALM Performance 
Center 
Troubleshooting 
Guide

Provides information for troubleshooting problems while 
working with HP ALM Performance Center.

Guide Description
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HP ALM Best Practices Guides

Guide Description

HP ALM Agile 
Testing Best Practices 
Guide

Provides best practices for implementing agile testing 
principles.

HP ALM Business 
Models Module Best 
Practices Guide

Provides best practices for working with the Business 
Models module.

HP ALM Database 
Best Practices Guide

Provides best practices for deploying ALM on database 
servers.

HP ALM Entities 
Sharing Best 
Practices Guide

Provides best practices for sharing entities.

HP ALM Project 
Planning and 
Tracking Best 
Practices Guide

Provides best practices for managing and tracking 
releases.

HP ALM Project 
Topology Best 
Practices Guide

Provides best practices for structuring projects.

HP ALM Upgrade 
Best Practices Guide

Provides methodologies for preparing and planning your 
ALM upgrade.

HP ALM Versioning 
and Baselining Best 
Practices Guide

Provides best practices for implementing version control 
and for creating baselines.

HP ALM Workflow 
Best Practices Guide

Provides best practices for implementing workflows.
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HP ALM Performance Center Best Practices Guides

HP ALM API References

Guide Description

HP Performance 
Center of Excellence 
Best Practices

Provides best practices for successfully building and 
operating Performance Centers of Excellence.

HP Performance 
Monitoring Best 
Practices

Provides best practices for monitoring the performance of 
applications under test.

Guide Description

HP ALM Project 
Database Reference

Provides an online reference for the project database 
tables and fields.

HP ALM Open Test 
Architecture API 
Reference

Provides an online reference for the ALM COM-based 
API. You can use the ALM open test architecture to 
integrate your own configuration management, defect 
tracking, and home-grown testing tools with an ALM 
project.

HP ALM Site 
Administration API 
Reference

Provides an online reference for the Site Administration 
COM-based API. You can use the Site Administration API 
to enable your application to organize, manage, and 
maintain ALM users, projects, domains, connections, and 
site configuration parameters.

HP ALM REST API 
Reference 

Provides an online reference for the ALM REST-based API. 
You can use the REST API to access and work with ALM 
data.

HP ALM COM 
Custom Test Type 
Developer Guide

Provides an online guide for creating your own testing 
tool and integrating it into the ALM environment using 
native COM development tools.

HP ALM .NET 
Custom Test Type 
Developer Guide 

Provides an online guide for creating your own testing 
tool and integrating it into the ALM environment using a 
combination of DCOM and .NET classes.
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HP ALM Performance Center API References

 

Additional Online Resources

The following additional online resources are available from the ALM Help 
menu:

Guide Description

ALM Performance 
Center REST API 
Reference

Provides an online reference for the ALM Performance 
Center REST-based API. You can use the REST API to 
execute actions to support automation and continuous 
integration.

Part Description

Troubleshooting & 
Knowledge Base

Opens the Troubleshooting page on the HP Software 
Support Web site where you can search the Self-solve 
knowledge base. Choose Help > Troubleshooting & 
Knowledge Base. The URL for this Web site is 
http://h20230.www2.hp.com/troubleshooting.jsp.

HP Software Support Opens the HP Software Support Web site. This site 
enables you to browse the Self-solve knowledge base. You 
can also post to and search user discussion forums, 
submit support requests, download patches and updated 
documentation, and more. Choose Help > HP Software 
Support. The URL for this Web site is 
www.hp.com/go/hpsoftwaresupport.

Most of the support areas require that you register as an 
HP Passport user and sign in. Many also require a support 
contract.

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp

To register for an HP Passport user ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

http://h20230.www2.hp.com/troubleshooting.jsp
http://www.hp.com/go/hpsoftwaresupport
http://h20230.www2.hp.com/new_access_levels.jsp
http://h20229.www2.hp.com/passport-registration.html
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HP ALM Extension Guides

Extensions provide added functionality to ALM. If you have a license for an 
ALM extension, you can utilize the added functionality by enabling the 
extension on a per project basis. For more details on enabling extensions, 
refer to the HP Application Lifecycle Management Administrator Guide.

To view the list of extensions available with ALM 12.00, or to download 
documentation for ALM extensions, visit the HP ALM Add-ins page, 
available from the HP Application Lifecycle Management Add-ins page 
(Help > Add-ins).

HP Software Quality 
Center Website

Opens the HP Software Web site. This site provides you 
with the most up-to-date information on HP Software 
products. This includes new software releases, seminars 
and trade shows, customer support, and more. Choose 
Help > HP Software Web site. The URL for this Web site 
is www.hp.com/go/software.

HP Software 
Application Lifecycle 
Management 
Website

Opens the HP ALM Software Web site. This site provides 
you with the most up-to-date information on HP ALM. 
This includes new software releases, seminars and trade 
shows, customer support, and more. Choose Help &gt; 
HP Software Application Lifecycle Management Website. 
The URL for this Web site is 
http://www8.hp.com/us/en/software-
solutions/software.html?compURI=1172141#tab=TAB1.

Add-ins Opens the HP Application Lifecycle Management Add-
ins Page, which offers integration and synchronization 
solutions with HP and third-party tools.

ALM Tools Opens the  Tools add-ins page, which offers integration 
and synchronization solutions with HP and third-party 
tools that are installed with  ALM on the  ALM Server. 

Part Description

http://www.hp.com/go/software
http://www8.hp.com/us/en/software-solutions/software.html?compURI=1172141#tab=TAB1
http://www8.hp.com/us/en/software-solutions/software.html?compURI=1172141#tab=TAB1
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1
Introducing ALM Performance Center

This lesson provides a brief overview of HP ALM Performance Center, and of 
the applications that are involved in the testing process.

Notes:

➤ The Quick Start describes how to run a performance test with a single 
host functioning as both a load generator and a Controller (C+LG). 
However, due to possible heavy load on the Controller and load 
generator hosts during a performance test, it is best practice to assign 
these functions to separate host machines.

➤ Ensure that the latest standalone versions of HP Virtual User Generator 
(VuGen) and HP LoadRunner Analysis are installed on your system.

In this lesson you will learn about:

➤ The ALM Performance Center Testing Process on page 16

➤ Performance Testing Applications on page 17
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The ALM Performance Center Testing Process

Using ALM Performance Center, you create performance tests in which you 
define the events that occur during a testing session. During a test, 
ALM Performance Center replaces human users at physical machines with 
virtual users, or Vusers. These Vusers create load on your system by 
emulating actions of typical users in a repeatable and predictable manner. 

Suppose you are testing a Web-based travel agency application that enables 
users to book flights online. Your goal as the performance tester is to 
determine how the application behaves when multiple users try to perform 
the same transaction at the same time. Using ALM Performance Center, you 
can run a test in which 1,000 Vusers, emulating 1,000 travel agents, would 
simultaneously try to book a flight on the application.

What is the testing process?
The testing process consists of the following basic processes: 

➤ Creating the script. Capturing typical end-user business processes 
performed on your application.

➤ Designing the performance test. Setting up the test environment by 
defining events that occur during the testing session.

➤ Preparing to run the performance test. Adding the performance test to a 
test set and reserving a timeslot for the test.

➤ Running the performance test. Driving, managing, and monitoring the 
test.

➤ Analyzing the results and viewing performance trends. Analyzing the 
performance data generated during the test run, and viewing trending 
information which identifies performance improvements and regressions 
over time.

These processes are explained in more detail in the lessons that follow.
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Performance Testing Applications

Each step in the testing process is carried out by one of the HP load testing 
tool components. The components are as follows:

Sample Application - HP Tours

To illustrate the testing process, this Quick Start uses a sample Web-based 
travel agency application called HP Tours. 

During the course of this Quick Start, you will go through the basic steps 
of creating, running, and analyzing a performance test. The test will 
emulate 10 travel agents simultaneously connecting to the HP Tours Web 
server and performing various flight reservation actions, for example 
logging on, searching for flights, purchasing flights, checking itineraries, 
and logging off.

Application Description

HP Virtual User Generator 
(VuGen)

Creates the script and generates virtual users, or 
Vusers. VuGen does this by capturing actions 
that typical end-users would perform on your 
application, and then records these actions into 
automated Vuser scripts. These Vuser scripts form 
the foundation of a performance test. 

HP ALM Performance Center Provides the central console from which you 
build, manage, and monitor a test.

HP Analysis Analyzes the performance test and provides 
graphs and reports with in-depth performance 
analysis information. Using these graphs and 
reports, you can pinpoint and identify the 
bottlenecks in your application and determine 
what changes need to be made to your system to 
improve its performance.
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2
Creating Vuser Scripts

This lesson explains the steps involved in recording Vuser scripts using HP 
Virtual User Generator.

In this lesson you will learn about:

➤ Recording Vuser Scripts on page 20
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Recording Vuser Scripts

You record Vuser scripts using HP Virtual user Generator (VuGen). A Vuser 
script is a record of a typical end-user business process. VuGen works on a 
record-and-playback principle. As you walk through a business process on 
your application, VuGen records your actions into an automated script 
which later forms the foundation of the performance test.

This section includes:

➤ “How do I start recording user activity?” on page 20

➤ “How do I record a business process to create a script?” on page 22

➤ “How do I view my script?” on page 25

➤ “How do I save the script?” on page 27

How do I start recording user activity?
You begin by opening Vugen and creating a blank script.

 1 Start VuGen.

Select Start > All Programs > HP Software > HP LoadRunner > Virtual User 
Generator or double-click the Virtual User Generator shortcut icon on 
your desktop. 
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 2 Create a blank Web script.

 a On the VuGen Start Page, click the Add New Script button. The Create 
a New Script dialog box opens.

A protocol is the language that your client uses to communicate with 
the back end of the system. HP Tours is a Web-based application, so 
you will create a Web virtual user script.

 b Make sure the Category type is Single Protocol. VuGen displays a list 
of the protocols that are available for a single-protocol script.

 c From the list of available protocols, select Web - HTTP/HTML and click 
Create. VuGen creates a blank Vuser script and displays the script in 
the VuGen Editor.
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How do I record a business process to create a script?
The next stage in creating user emulation is recording the events performed 
by a real user. In the previous section, you created an empty Web script. In 
this section, you will track the events of one passenger reserving a flight 
from Denver to Los Angeles and then check the itinerary.

 1 Start recording on the HP Web Tours site.

 a Click Record > Record or click the Record button on the VuGen 
toolbar. The Start Recording dialog box opens.

 b In the Record into action box, select Action.

 c In Record, select Web Browser.

 d In the URL address box, type http://localhost:1080/WebTours.

 e Keep all other default settings.
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 f Click Start Recording. A new web browser opens and displays the HP 
Web Tours site.

Note: If there is an error opening the site, make sure that the Web 
server is running. To start the server, select Start > All Programs > HP 
LoadRunner > Samples > Web > Start Web Server. 

The floating Recording toolbar opens.

 2 Log on to the HP Web Tours site. 

 a On the HP Web Tours home page, type the user credentials: 

➤ For the Username type jojo. 

➤ For the Password type bean. 

 b Click Login. A welcome page opens.
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 3 Enter flight details.

 a Click Flights. The Find Flight page opens.

 b Define the following flight criteria:

➤ Departure City: Denver (default)

➤ Departure Date: Keep the default, current date

➤ Arrival City: Los Angeles

➤ Return Date: Keep the default, tomorrow’s date

 a Keep the rest of the default settings and click Continue. The search 
results appear.

 4 Select a flight.

Click Continue to accept the default flight selection. The Payment Details 
page opens.

 5 Enter payment information and book flight.

 a In the Credit Card box enter 12345678.

 b In the Exp Date box enter 01/14 in the Exp Date box. 

 c Click Continue. The Invoice page opens, displaying your invoice.

 6 Check the itinerary.

In the left pane, click itinerary. The Itinerary page opens displaying the 
itinerary for flight you booked above.

 7 Log off the HP Web Tours Site

In the left pane, click Sign Off.

 8 Stop recording.

Click the Stop button on the floating toolbar to stop the recording 
process.

VuGen generates the required code and inserts the code into the Vuser 
script.

If the Design Studio opens, click Close to close the Design Studio.
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How do I view my script?

You have now recorded a travel agent logging in, booking a flight, 
checking the itinerary, and logging off. VuGen recorded your steps from 
the moment you clicked the Start Recording button to the moment you 
clicked the Stop Recording button. You can now use VuGen to view the 
script. 

 1 Display the Solution Explorer tab.

On the left side pane, make sure the Solution Explorer tab is selected.

This tab provides you structured access to the various parts of a Vuser 
script, as well as to a number of files that are associated with the Vuser 
script.
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 2 Display the Step Navigator tab.

Click the Step Navigator tab.

The Step Navigator displays an icon-based view of the script that lists the 
actions of the Vuser as steps. For each action you performed during 
recording, VuGen generated a corresponding step in the Step Navigator.

The Step Navigator displays a snapshot icon to indicate that a specific step 
contains a snapshot.
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 3 View a step in the VuGen Editor.

Double-click any step in the Step Navigator to display the corresponding 
function in the VuGen Editor. The Editor displays a text-based view of the 
script. 

In the Editor, the actions of the Vuser are listed as API functions. VuGen 
uses color-coding to show the functions and their argument values in the 
script. You can type C or API functions, as well as control flow statements, 
directly into the script.

How do I save the script?

Select File > Save Script As and save the script locally on your desktop. For 
example, type Scripts. The script file should be zipped. After you have 
created your performance test, you will upload the script to ALM 
Performance Center.
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3
Creating and Designing Performance 
Tests

This lesson explains how to manage test assets in ALM, and the steps 
involved in creating and designing a performance test.

Note: Some steps in the following lesson can be performed from ALM or 
from Performance Center. In this lesson, you will perform these steps from 
ALM. For more details, see the "Personalizing Performance Center" section 
in the HP ALM Performance Center Guide.

In this lesson you will learn about:

➤ Logging in to ALM on page 30

➤ Adding Vuser Scripts to ALM on page 31

➤ Monitoring Performance Tests on page 36

➤ Creating Performance Tests on page 38

➤ Designing Performance Tests on page 39
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Logging in to ALM

You log into ALM as follows:

 1 In your Web browser, enter the ALM URL. the ALM Login window opens.

Note: If ALM was configured for external authentication, the Name and 
Password fields do not appear in this window. Skip to step 3.

 2 Type  your username and password, and click Authenticate.

 3 Select the required Domain and Project and click Login.
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Adding Vuser Scripts to ALM

The first step in your test design process is to add your Vuser script to ALM. 
Adding the script involves two steps: Creating a scripts folder, and 
uploading the script to the folder.

How do I upload the Vuser Script?
You can upload the Vuser script to from within ALM, or directly from 
VuGen.

Uploading scripts from within ALM

You upload the script from within ALM, from the Test Plan module, as 
follows:

 1 Make sure the script is saved locally and is zipped.

 2 On the ALM sidebar, under Testing, select Test Plan.

 3 Create a script folder.

 a Select Subject.

 b Click the New Folder button, and specify a name for the folder, for 
example, Scripts.

 c Click OK to add the folder.
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 4 On the module toolbar, click the Upload Vugen Script button. The 
Upload VuGen Scripts dialog box opens.

 5 In the Select Folder box, select the scripts folder you created above.

 6 Click one of the Select buttons and navigate to the location of the zipped 
script file.

 7 Click Upload to upload the script.
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Uploading scripts directly from Vugen

You upload the script from within Vugen using the HP ALM Connection 
dialog box.

 1 Create a folder for the script.

 2 In VuGen, select ALM > HP ALM Connection. The HP ALM Connection 
dialog box opens.

 3 Enter the ALM Performance Center URL, and click Connect. 

 4 Enter your ALM Performance Center username and password, then click 
Connect.
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 5 Select your domain and project, then click Login. 

 6 Click Close.

 7 In VuGen, select File > Save Script As. The Save Script dialog box opens.
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 8 Select ALM Test Plan, and then select your scripts folder as the location to 
save the script to.

 9 Click Save. The Upload Script dialog box opens.

 10 Accept the default setting.
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Monitoring Performance Tests

You monitor performance test execution using the ALM Performance Center 
online monitors.

For example, you use the System Resource monitors to monitor a machine’s 
system resource usage during a performance test and identify server 
performance bottlenecks.

A primary factor in a transaction’s response time is its system resource usage. 
Using the ALM Performance Center resource monitors, you can monitor the 
Windows Resource usage on a machine during a test run, and determine 
why a bottleneck occurred on a particular machine. 

What is a monitor profile?
To monitor server resources during the test, you select the type of monitors 
to run and the servers whose resources you want to monitor. You then add 
the measurements to monitor for each server. These monitor settings can be 
saved as a monitor profile which can be used by any performance test in 
your project.

The following section will show you how to create a monitor profile and 
how add a Windows Resource Monitor to it.

How do I create a monitor profile?
You create and configure monitor profile as follows:

 1 On the ALM sidebar, under Testing, select Test Resources.

 2 Create a folder for the monitor profile.

 3 Select the folder, and click the New Resource button. The New Resource 
dialog box opens.

 4 Enter the required information, and make sure that in the Type box, you 
select Monitor Profile.
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 5 Click OK to add the monitor profile to the folder. For example:

 6 Select the monitor profile, and in the right pane, select the Monitors 
Configuration tab.

 7 Click the Add Monitor button. The Add New Monitor dialog box opens.

 8 Select Windows Resources. The Edit Monitor dialog box opens, enabling 
you to select the Windows Resources counters you want to monitor.

 9 Enter the desired information, and click Save. The monitor is added to 
your monitor profile.

You will add the monitor profile to the test as part of the test design 
process.
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Creating Performance Tests

To create a test, you begin by creating a test folder, and then creating the test 
and adding it to the folder. In the next section, you will learn how to design 
the test in the Test Designer.

How do I create a performance test?
You create the test as follows:

 1 On the ALM sidebar, under Testing, select Test Plan. 

 2 Select Subject. Click the New Folder button, and specify a name for the 
folder, for example, Tests. Click OK to add the folder.

 3 Select the folder, and click the New Test button. The New Test dialog box 
opens.

 4 Enter the required information, and make sure that in the Type box, you 
select Performance Test. For example:
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 5 Click OK to add the test to your test folder. For example:

Designing Performance Tests

You design your performance test in the Performance Test Designer. 

How do I open the Performance Test Designer?
You open the test designer as follows:

 1 On the ALM sidebar, under Testing, select Test Plan. 

 2 Select the test you created above, and click the Edit Test button on the 
toolbar. The Test Designer opens. 

 3 If a message box opens, click Show Test Designer to open the Test 
Designer.

How do I design the performance test?
From the Workload tab in the Performance Test Designer, you perform the 
basic test design steps. You design the test as follows:

 1 Select a workload type for the test.

When the Performance Test Designer opens, you will be prompted to 
select a workload type for the test. Accept the default, Basic Schedule, by 
test, by number.
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 2 Assign a Controller to the test.

 a Click the browse button adjacent to the Controller box. The Select 
Controller dialog box opens.

 b Select Specific.

 c From the list that appears, select the host machine that has been 
assigned the Controller and load generator (C+LG) purpose. 

 3 Add Vuser scripts.

 a If the Scripts Tree pane is not displayed on the right, click the Select 
Scripts button on the toolbar to open it. The Scripts Tree displays the 
script that you uploaded previously to ALM.

 b In the Scripts Tree, select the script and click the left arrow to add it to 
the test. The script appears in the Groups pane. 
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 4 Add load generators.

 a On the Groups pane toolbar, in the LG Distribution box, click the 
arrow and select Assign manually.

 b In the Groups Pane, in the Load Generators column, click the Select 
load generators link.

The Select Load Generators dialog box opens.

 c Select the Specific tab, and from the list that appears, select the host 
machine that has been assigned the Controller and load generator 
(C+LG) purpose.
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 5 Configure the schedule settings.

A schedule defines the actions of the Vusers for the performance test run, 
for example the behavior of 10 Vusers emulating 10 travel agents 
simultaneously logging on to HP Tours, booking flights, checking 
itineraries, and so on.

Because typical users do not perform the same action simultaneously, the 
Scheduler allows you to schedule a performance test according to a more 
realistic portrayal of typical user behavior.

Define the schedule as follows:

In the lower area of the Workload tab, in the Global Schedule pane, click 
in each of the schedule actions in the Actions grid and define them as 
follows:

➤ Initialize.

➤ Start Vusers.

➤ Duration.

➤ Stop Vusers.
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The schedule graph displays a graphical representation of the defined 
schedule. The lines in the graph correspond to the actions defined in the 
Actions grid. 

How do I add the monitor profile to the test?
You add the monitor profile to the test as follows:

 1 In the Performance Test Designer, select the Monitors tab.

 2 On the toolbar, click Add Monitor Profile. The Monitor Profiles pane 
opens on the right, displaying the available monitor profiles.

 3 In the Monitor Profiles Tree, select the monitor profile and click the left 
arrow to add it to the test. 

How do I save the test?
Click Save at the bottom of the page to save the test settings. Then click 
Close to Close the Performance Test Designer.
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4
Running Performance Tests

This lesson explains the steps that are necessary before you run the 
performance test, and how to begin test execution.

Note: Some steps in the following lesson can be performed from ALM or 
from Performance Center. In this lesson, you will perform these steps from 
ALM. For more details, see the "Personalizing Performance Center" section 
in the HP ALM Performance Center Guide.

In this lesson you will learn about:

➤ Creating Test Sets on page 46

➤ Reserving Timeslots on page 48

➤ Running Performance Tests on page 49
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Creating Test Sets

The next step in the performance testing process is the creation of a 
performance test set.

What is a test set?
After you design the performance test in the Test Plan module, you organize 
the test execution by creating a test set in the Test Lab module and adding 
an instance of the test to the test set. The purpose of a test set is to enable 
you to group together tests that were created for similar goals.

How do I create a test set?
You create the test set and add the test to it as follows:

 1 Create the test set.

 a On the ALM sidebar, under Testing, select Test Lab. 

 b Click the New Folder button, and specify a name for the Test Set 
folder, for example, Test_set_folder.

 c Click OK to add the folder.

 d Select the folder you created above, and click the New Test Set button. 
The New Test Set dialog box opens. 
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 e Enter the required information, and make sure that in the Type box, 
you select Performance.

 f Click OK. The test set is added to the Test Set Folder.

 2 Add the performance test to the test set.

 a Select the test set you just created, and in the right pane, click the 
Execution Grid tab. 

 b Above the Execution Grid tab name, click the Select Tests button. The 
Test Plan tree appears on the right, enabling you to locate your Test 
Plan folder and performance test.

 c In the Test Plan Tree, select the script and click the Add Test to Test Set 
button to add it to the Execution Grid tab.

 d Click the close button to close the Test Plan Tree.
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Reserving Timeslots

Before you run the test, you reserve a timeslot to ensure that the resources 
needed will be available for the duration of the test.

How do I reserve a timeslot?
You reserve a timeslot as follows:

 1 On the ALM sidebar, under Testing, select Timeslots.

 2 Click the New Timeslot button. The Timeslot Reservation dialog box 
opens.

 3 Define the following information:

➤ Run. Choose Performance Test.

➤ Start. Choose Manually as the method for executing tests. The timeslot 
reservation reserves testing resources only.

➤ Name. Enter a name for the timeslot.

➤ Select a test instance. Navigate to the test set you created above, and 
select the test to link it to the timeslot. The number of Vusers and 
hosts that were defined as part of the test design process are 
automatically displayed.

➤ Duration. Set the start time, and enter a duration for the test.

➤ Post-Run. Select Collate and Analyze.
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 4 Click Calculate Availability. The availability of the requested resources 
during the selected timeslot is calculated. The results of this calculation 
are displayed in the Timeslot Status tab and graphically on the time chart.

Note: If the timeslot cannot be reserved, reselect your resources or adjust 
the start time, taking into account the reasons displayed in the Timeslot 
Status tab.

 5 When you find a valid timeslot, click Submit to save the timeslot.

Running Performance Tests

Now that you have designed the performance test, added an instance of the 
test to a test set, and reserved a timeslot for the test, you are ready to run the 
test and observe how your application performs under load.

How do I run the performance test?
You run the performance test as follows:



Lesson 4 • Running Performance Tests

50

 1 On the ALM sidebar, under Testing, select Test Lab.

 2 Select your test in the left pane.

 3 Click the Execution Grid tab.

 4 Select the test in the Execution Grid tab, and click the Run Test button. 
The Run Performance Test dialog box opens, and the timeslot you created 
above is displayed in the select timeslot grid. 

Note: If no timeslot was reserved from the Timeslots module, the Run 
Performance Test dialog box lists alternative timeslots.

 5 Select a timeslot in the grid, and click Run. ALM Performance Center 
begins the performance test execution process, and the Performance Test 
Run page enabling you to manage and monitor the test as it runs.

What does the Performance Test Run page display?
The Performance Test Run page is the control center from which the test run 
is managed and monitored.
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The Performance Test Run page displays the following:

Pane Description

Performance Test 
Details

The Performance Test Details Pane at the top of the page 
provides three views:

➤ Groups View. This is the view displayed in the above 
image. The Groups view displays the statuses of the 
Vusers in each Vuser group in the performance test.

➤ Transactions View. The Transactions view displays 
how many transactions have been executed 
successfully or unsuccessfully.

➤ Messages View. The Messages view displays error, 
warning, debug, and output messages that are sent to 
the Controller by the Vusers and load generators 
during a test run.

Summary The Summary pane displays a synopsis of the running 
performance test.

Online Graphs The online monitor graphs display performance 
measurements for those resources being monitored in 
the test. This enables you to monitor how the 
application under test is performing in real time and 
identify where potential bottlenecks exist.

Topology Displays any defined topologies for the test.
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5
Post-Run Analysis and Trending

This lesson explains how to analyze test run data using HP LoadRunner 
Analysis, and how to view performance improvements and regressions using 
the Trend Report feature.

In this lesson you will learn about:

➤ Analyzing Performance Test Run Results on page 54

➤ Viewing Performance Improvements and Regressions on page 63
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Analyzing Performance Test Run Results

Now that you have completed running the performance test, you use 
HP LoadRunner Analysis to analyze the performance data generated during 
the test run. Analysis gathers the performance data into detailed graphs and 
reports. Using these graphs and reports, you can pinpoint and identify the 
bottlenecks in the application, and determine what changes need to be 
made to the system to improve its performance.

How do I view Analysis information?
To provide for more interesting results, a sample analysis session is provided, 
which is based on a performance test similar to the one you ran.

To open the sample Analysis session:

 1 Select Start > All Programs > HP Software > HP LoadRunner > Analysis or 
double-click the Analysis shortcut icon on your desktop. 

 2 Select File > Open. The Open Existing Analysis Session File dialog box 
opens. 

 3 Navigate to the <Analysis Standalone Installation>\Tutorial folder. 

 4 Select analysis_session and click Open. Analysis opens the session file in 
the Analysis window.

The data contained in this sample session is examined in more detail in the 
sections that follow.
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To open the Analysis session for the test you ran:

To view Analysis data for your actual performance test, you perform the 
following steps:

 1 Connect Analysis to ALM Performance Center.

 a In Analysis, select Tools > HP ALM Connection. The HP ALM 
Connection dialog box opens.

 b Enter the ALM Platform URL, for example, http://server:8080/qcbin, and 
click Connect. 

 c Under Step 2: Authenticate User Information, enter your ALM user 
credentials, and click Authenticate.
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 d Select your domain and project and click Login. The dialog box should 
look as follows: 

 e Click Close.
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 2 Open the Analysis session file for your performance test.

 a Select File > Open. The Open Analysis Session dialog box opens.

 b Select Test Lab. The test sets in the project are displayed. 

 c Navigate to the Results.zip file for the instance of your performance 
test that you want to analyze.

 

 d Double-click the Results.zip file. The analysis session file is 
downloaded from ALM Performance Center and is opened in Analysis. 

Did I reach my goals?
Analysis opens displaying the Summary Report. The Summary Report 
provides general information about the performance test run. In the 
Statistics Summary of the report, you can see how many Vusers ran in the 
test and view other statistics such as the total/average throughput, and the 
total/average hits. The Transaction Summary of the report lists a summary of 
the behavior of each transaction.
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How can I view the graphs?
The graph tree in the left pane of the Analysis window shows the graphs 
that are open for viewing. From the graph tree, you can choose to open new 
graphs and remove graphs that you no longer want to view. The graphs are 
displayed in the graph viewing area in the right pane of the Analysis 
window. You can view data from the selected graphs in the graph legend in 
the lower pane of the window. 

As an example, we will now analyze the Average Transaction Response Time 
graph. Using this graph, you can view the behavior of the problematic 
transactions during each second of the performance test run. In this section, 
you view the behavior of the check_itinerary transaction.

To open and analyze the Average Transaction Response Time graph:

 1 Click the Add New Graph button. The Open a New Graph dialog box 
opens.
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 2 Under Transactions, select Average Transaction Response Time.
.
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 3 Click Open Graph. The Average Transaction Response Time graph opens 
in the graph viewing area.

 4 In the legend, click check_itinerary. The check_itinerary transaction is 
highlighted in the graph and in the legend below the graph.

Notice how the average response time of the check_itinerary transaction 
fluctuates greatly compared to the other transactions at the bottom of the 
graph, which follow a more or less stable average response time.
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How can I compare data from different graphs?
You can join two graphs together to see the effect of one graph’s data upon 
another graph’s data. This is called correlating two graphs. For example, 
you can correlate the Running Vusers graph with the Average Transaction 
Response Time graph to see the effect of a large number of Vusers on the 
average response time of the transactions.

 1 Click the Add New Graph button. The Open a New Graph dialog box 
opens.

 2 Under Vusers, select Running Vusers.

 3 Click Open Graph. The Running Vusers graph opens in the graph viewing 
area.

 4 Select the Running Vusers graph and click the Merge Graphs button.

 5 From the Select graph to merge with list, select Average Transaction 
Response Time.

 6 In the Select type of merge area, select Correlate, and click OK.
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The Running Vusers and Average Transaction Response Time graphs are now 
represented by one graph which opens in the graph viewing area.

Another Analysis tool, Auto Correlate, merges all graphs containing data 
that could have had an effect on a given transaction. Correlations of the 
transaction with each element are displayed, allowing you to deduce which 
elements had the greatest effect on the given transaction.

How can I sort graph data?
You can filter graph data to show fewer transactions for a specific segment of 
the performance test, and you can sort graph data to show the data in more 
relevant ways. For example, you can filter the Average Transaction Response 
Time graph to display only the check_itinerary transaction.

 1 Click Average Transaction Response Time in the graph tree to open the 
graph.

 2 Select the graph and click the Set Filter/Group by button.

 3 In the Transaction Name value box, select check_itinerary and click OK. 
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The filtered graph displays only the check_itinerary transaction and hides all 
the other transactions.

How can I publish my findings?
You can publish the findings from your analysis session in an HTML or 
Microsoft Word report. The HTML report can be opened and viewed in any 
browser. The Word report is more comprehensive than the HTML report, 
enabling you to include general information about the performance test and 
to format the report to include your company’s name, logo, and the author’s 
details.

For more information about analyzing performance test results, refer to the 
HP LoadRunner Analysis User Guide.

Viewing Performance Improvements and Regressions

A trend report is an ALM Performance Center feature that allows you to 
view changes in performance from one performance test to another, or 
across several performance tests. By analyzing these changes, you can easily 
identify improvements or regressions in the measurement’s performance. 

For example, if you would like to analyze the performance trend of the 
average transaction response time measurement of Transaction X, then the 
trend report would display the changes in the response time from one test 
to the next, clearly indicating whether this measurement improved (where 
the response time decreased) or regressed (where it increased). 

What steps are involved in working with trend reports?
The process of creating and viewing a trend report involves the following 
steps:

➤ Step 1 - Creating the trend report. Creating the basic trend report by 
defining its name, description and selecting a template.

➤ Step 2 - Adding test runs to the trend report. Extracting test run data 
from Analysis to the trend report. 
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➤ Step 3 - Viewing trend report data. Opening the trend view and 
analyzing the trending information.

We will now discuss these steps in more detail.

Creating the Trend Report

You create the trend report from the main Trend Reports page. 

Note: Some steps in the following lesson can be performed from ALM or 
from Performance Center. In this lesson, you will perform these steps from 
ALM. For more details, see the "Personalizing Performance Center" section 
in the HP ALM Performance Center Guide.

To create the trend report:

 1 Open the main Performance Trending page. 

 a On the ALM sidebar, under Testing, select Test Runs. 

 b Click the Performance Trending button. The My Performance Center 
application opens, displaying the Performance Trending page. 

 2 Open the Trend Report Creation page.
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On the Performance Trending page, click the New Trend Report button. 
The Create New Trend Report page opens.

 3 Define the General Details and Content and Layout settings.

 a In the Create New Trend Report page, define the following 
information:

➤ In the General Details pane, enter a name and description for the 
trend report. 

➤ In the Contents and Layout pane, select the Transaction Trends 
template.

 b Click Create to create the trend report. The Select Test Runs to Trend 
Report dialog box superimposes on the Trend Overview tab. 
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 4 Add Performance Test Runs to the Trend Report.

From the Project, Test Set and Test lists respectively, select the 
performance test that you want to trend. All analyzed instances of the 
performance test appear in the table. 

 

Select those analyzed instances of the test that you want to add to the 
trend report, and click Add. Performance Center uploads the test runs 
from Analysis and adds them to the trend report. The trend report opens 
displaying the Trend Overview tab.

Notes:

➤ To add test runs to the trend report, there must be a data processor in 
your project’s host pool. For details, contact the Administrator.

➤ The process whereby ALM Performance Center extracts the performance 
test data from Analysis is very labor intensive on the data processor and 
may take anywhere from several minutes to over an hour. We 
recommend that you use a data processor dedicated for this purpose.
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Viewing Trend Report Data

In the following section, we will look at trending information for the 
average transaction response time measurement only.

To view trending information:

On the trend report, click the Performance tab. 

In the trend view that opens, you will see a table that displays the 
transactions that were present in the test run, as well as the average 
transaction response times for each selected instance of the test run.

By comparing these average transaction response time figures, you can 
identify if the performance of the transaction improved or regressed from 
one test run to the next.

The following example illustrates this point.

In the trend view shown above, four transactions (TRX_01, TRX_02, 
TRX_03, and TRX_04) are displayed and their average Transaction 
Response Time measurement is being trended from four performance test 
runs: 3, 4, 5, and 6.

Test run 3 has been automatically defined as the baseline run, (as 
indicated by the word Base in brackets). This means that the average 
transaction response times contained in the other tests are compared to 
test run 3 only.

In test run 3, the average transaction response time for TRX_01 was 2.045. 
The average transaction response time for the same transaction in test run 
4 was 4.073, which represents a slower response time and therefore a 
regression in the performance of this measurement. The percentage 
difference between the two figures is displayed in parenthesis, in this case 
+99.17%.
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In test run 6, the average transaction response time for TRX_01 was 1.05, 
which represents a a faster response time that test run 3, and therefore a 
performance improvement. The percentage difference between the two 
figures is displayed in parenthesis, in this case -48.66%.
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6
Summary

ALM Performance Center enables you to manage the following phases of 
the testing process: Creating and designing performance tests, preparing to 
run performance tests, running performance tests, and post-run analysis.
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Phase Description

Creating and 
Designing 
Performance Tests

Setting up the test environment by defining events that 
occur during the testing session.

Preparing to Run 
Performance Tests

Adding the performance test to a test set and reserving a 
timeslot for the test.

Running 
Performance Tests

Driving, managing, and monitoring the test.

Post-Run Analysis Analyzing the performance data generated during the test 
run.
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