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Documentation Updates

The title page of this document contains the following identifying information:

o Software Version number, which indicates the software version.

 Document Release Date, which changes each time the document is updated.

o Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a document, go
to:

http://h20230.www2.hp.com/selfsolve/manuals

This site requires that you register for an HP Passport and sign in. To register for an HP Passport
ID, goto:

http://h20229.www2.hp.com/passport-registration.htmi
Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product support
service. Contact your HP sales representative for details.
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Support

Visit the HP Software Support Online web site at:
http://www.hp.com/go/hpsoftwaresupport

This web site provides contact information and details about the products, services, and support
that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and
efficient way to access interactive technical support tools needed to manage your business. As a
valued support customer, you can benefit by using the support web site to:

o Search for knowledge documents of interest

e Submit and track support cases and enhancement requests
o Download software patches

« Manage support contracts

e Look up HP support contacts

¢ Review information about available services

¢ Enterinto discussions with other software customers

o Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also
require a support contract. To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.htmi
To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp
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Disclaimer for PDF Version of Online Help

This document is a PDF version of the online help. This PDF file is provided so you can easily print
multiple topics from the help information or read the online help in PDF format.

Note: Some topics do not convert properly to PDF, causing format problems. Some elements
of online help are completely removed from the PDF version. Those problem topics can be
successfully printed from within the online help.
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Develop New Content Using the Integrated
Development Environment

The Integrated Development Environment (IDE) allows you to develop content and DWH models,
as well as develop new entities and extend existing content using the Designers. Once the entities
are defined and mapped, they are run through the ETL Generator to produce the metadata and
workflows. You can then package the data into Content Packs for use in the Data Warehouse.

Tasks

The following describes the various IDE processes:
"Getting Started with Content Extension" on page 10
"Design and Analysis Phase" on page 15

"Content Packs and Data Modeling" on page 17
"IDE Main Page and End-to-End Flow" on page 22
"Discover Data Evidence" on page 27

"Import Existing Content" on page 28

"Define New Content Pack Project" on page 29
"Define the Target Model" on page 34

"Architect Target Designer Tasks" on page 35
"Engineer Stream Designer Tasks" on page 47
"Delete an Entity Permanently" on page 58
"Manage Validation" on page 60

"Generate Content" on page 73

"Package and Deploy Content" on page 75
"Activate New Content " on page 76

"Advanced Development" on page 81

"Next Steps" on page 107
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Release Notes
Compatibility

e The IDE version 9.4 is compatible with all previous XS versions.

What's New in this Version

Target Extension

The IDE supports the extension of a target entity by creating an association called Target
Extension. This enables you to extend an entity by adding to the new entity columns. Adding an
extension enables Fact extension and the ability to link a group of Dimensions specifically to the
same group. You then use the extension entity to make all associations and links. Target extension
is only supported in XS version 9.4 and later.

Issues
Issue Description
Period The Period target entity requires special mapping requirements in the IDE. The

dimension entity contains time and date related mapping and can only extend to date related
Extension sources and dimensions, for example START_TIME.
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Getting Started with Content Extension

This document assumes basic data warehouse modeling knowledge, understanding of the ETL
concepts, good familiarity with databases, as well as SAP Business Objects Data Services
(BODS). When creating or extending content make sure that you have set up Executive Scorecard
as well as installed the contents of the IDE DVD. For IT Executive Scorecard installation and
administration details, see the IT Executive Scorecard Administrator Guide.

IDE Terms

IDE: Integrated Development Environment

The Eclipse workspace where you can create or extend content using modeling tools in the relevant
designers.

KPI: Key Performance Indicator

KPIs reflect how well the organization is doing in areas that most impact financial measures valued
by shareholders, such as profitability and revenues.

API: Application Programming Interface

A specification intended to be used as an interface by software components to communicate with
each other.

ETL: Extract, Transform, Load

An end-to-end transfer of external source data through several staging layers and into the target
layer of the data warehouse. The data warehouse uses the ETL process to extract, consolidate,
and transform the source data into a meaningful target model that populates relevant business
analytics.

UDM: Unified Data Model
Provides a bridge between the user and the data sources.
DWH: Data Warehouse

The data warehouse is an end-to-end solution for extracting source data and consolidating disparate
source data models into a consolidated data model. The data organized to reflect this model resides
in target tables that become the source for Executive Scorecard.

XS: Executive Scorecard

An application that enables executives to continuously improve their business by measuring what
happened and what is happening, analyzing that information, and planning new strategies using the
gathered information.

File Based Integration (FBI) Extractor

FBI enables you to extract data from a specific data source according to a set of instructions. It
consists of a plug-able extractor framework for each data source. The extractor gathers data
according to the specific instructions it receives, placing it into a relevant .txt flat file. If you want to
develop your own extractor for use with extended content, see the FBI Extractor SDK Guide.

The following extractors are available for each source product:
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Getting Started with Content Extension

Product
ALM

AM
AWS
BSM
CSA

DP

NA
NNM
0]0)
PPM

SA

SE

SM
UCMDB
VCM

Entity

An entity is an object of interest included in the data model.

Designer

Extractor

ALM

MSSQL, Oracle

aws_s3

BSM, GDE, UCMDB
CSA

DP

MSSQL, Oracle, PostgreSQL
MSSQL, Oracle, MySQL
NNM

MSSQL, Oracle, MySQL
Oracle

SA

Oracle

MSSQL, Oracle
UCMDB

script(groovy)

A designer in the IDE is the model you create in order to perform content extension and definition. It
is a collection of certain entities that may share some relevancy in common. The IDE contains the

Architect Target Designer and the Engineer Stream Designer.

Content Packs

A content pack is a set of entities from a certain type. There are three types of content packs:

Source: Contains all of the artifacts needed to connect to the relevant data source and pull data

from that data source.

Integration: Integrates the information from the source, using the DWH schema and loading
process in order for the data to be brought to the Target tables. Takes the schema and entities of the
source data and transforms it into usable data.

Target: Defines the content of the Data Warehouse as well as the look of the target tables
according to the Unified Data Model (UDM).
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Getting Started with Content Extension

IDE Requirements
Required for DWH Architects

¢ Understanding of Business Intelligence tools, data warehouse modeling and database design
principles.

e XS DWH Target schema.

Required for DWH ETL Engineers

o Understanding ETL principles.

o Experience with BODS.

o Familiarity with the source schema.

Required for DWH Integration Engineers

e Java programming sKkills

Prerequisite knowledge for performing content development tasks:
o HP Unified Data Model (UDM).

o Target Model: The existing supported model of the DWH

o Basic architecture of the data warehouse and the advantages of the templates.
o Basic familiarity with the Integrated Development Environment (IDE).

« BODS and data modeling.
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Getting Started with Content Extension

General Prerequisite

The IDE only supports the usage of UTF-8 (Latin) characters.
IDE Set up

The IDE can be downloaded from HP Live Network (https://hpln.hp.com/group/executive-
scorecard) and contains:

o IDE: Unzip the file and double-click eclipse.exe to run the IDE Eclipse application.

¢ IDE Content: Contains the OOTB Content Packs.
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Getting Started with Content Extension

Content Extension process

The development of new content comprises the following steps:

1. Data Evidence: Understanding and analyzing what data needs to be included, based on your
information needs and objectives.

2. Import existing content for extension or new Content Pack folders if required.

3. Modeling: The architect creates the Target model.

4. Data Source Integration: The engineer maps the data from the Source to Target.
5. ETL development and generation.

6. ETL orchestration and management.

7. Consolidation

8. Context (universe) building and adjustments.

9. KPIs additions and modifications.
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Design and Analysis Phase

The information design and analysis phase includes the following process:

Business Discovery

Determine your organization’s objectives and information needs. Business discovery contains the
following steps.

o User Analysis: Define personas and their business requirements.

o Decision Based Analysis: Includes Executive Scorecard KPIs, reports, metrics, and
dashboards.

« Information Availability: Identify the Source systems that support the business requirements.

o Assign Priorities

Information Discovery

Discover the data in the organization that supports the business requirements. Synchronize the
available information and the means of extracting it with information required. This is the Data
Evidence process. Information discovery includes the following steps.

o Source Contact Point: Select an expert to lead the information discovery process.

e Source Extraction Method: DB query, API, Web services.

o Source Table Identification: Identify configuration tables to populate Dimensions,and
transactional tables to populate Facts.

o Source to Target Mapping: Identify Source column mapping to Target columns and define data-
processing requirements.

Architecture

Comprised of a star schema, a design method of dimensional modeling, in which the data is

organized into Facts and Dimensions. A star schema is designed by surrounding each fact with its
associated dimensions.

o Fact: An event that is counted or measured, such as a sale or login. Table Structure contains
business measurements (numeric or time based) and Dimensional Intersection Point.

« Dimension: Reference information about the fact, such as period, product, or customer.
Common Table Structure contains descriptive attributes.
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Design and Analysis Phase

Sample Star Schema

PRODUCT CUSTOMER
F'rodl.lc‘l:_ID cu’tq'l'l.r_"]
Customer_NAME
Froduct_Desc l:u-:tomt:_bnc
FACT
Product_ID
Customer_ID
Region_ID
Year_ID
Month_|D
REGION Sales TIME
Profit
Region_ID Year_ID
Country Manth_ID
State Week_ID
City Day_ID
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Content Packs and Data Modeling

Content packs contain all the artifacts needed to connect to the relevant data source and gather
data from that data source. The mapping between the raw data from the data source and the target
database in the Data Warehouse is included in the ETL. Content packs include:

The definition of the data model used for the connection.
The type of data gathered from the data source.

The ETL definitions.

The definition files.

The configuration files.

The scripts that help build and define the Data Warehouse.

Content Pack Types

Target Content Pack: Responsible for the transfer of data from consolidation to the target
database. The Target CP defines the content of the Data Warehouse as well as the look of the
target tables.

Integrated Content Pack (i-CP): The i-CPs are responsible for bringing the data from the specific
data sources and transforming it to the consolidation level. From there, the Target CP transfers
the data to the target. The i-CPs integrate the information from the source, using the DWH
schema and loading process in order for the data to be brought to the target tables.

Content Packs contain the following folders:

ABC: Contains files that define the ETL stream, and the general flow of steps of SAP
BusinessObjects Data Services jobs. The files list the order of the steps as well as the link
between the parent and child steps. These files are necessary if you have to add a step to the
ETL process.

Custom: Contains SQL scripts that are not part of the standard ETL processes. For example, if
you want to include a staging table that will help the ETL, the script is placed in the Custom
folder.

Data Model: Contains the xml files that define the target schema.

ETL: Contains the jobs and workflows of the ETL and defines how data goes through the
processes.

cp_manifest.properties: The manifest file provides additional information to the Content Pack to
allow the system to perform sets of validations.

dw_app.properties

dw_app.xml: Files that are created automatically when you add a new CP.
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Content Packs and Data Modeling

Data Model Types

Data models describe the source, extraction, consolidation, and target components for a single
entity:

Target Entity

Fact or Dimension: Entity name and column names defined according to the Star-Schema
architecture.

Source Entity

The actual representation of an entity extracted from the source.Generated automatically according
to the integration entity design.

Integration Entity
Entity name, column names, and data types defined according to source table design.
Column Mapping

Source to Target column mapping.

Logical Data Models

DWH supports the following types of logical data models:
o Target Data Models:
= Target Model — Dimension or Fact: The target data models describe the format of the data
that produces business intelligence analytics. The instantiated data models are dimension,
fact, and hierarchy tables.

o i-CP Data Models:

= Extraction Model: ETL processes obtain the data in native format and stages it in
intermediate tables that conform to the extraction data model for that entity. Extraction also
validates the data to ensure that it is usable.

= Source Model: The source entity models represent the design of DIl (Data Integration
Interface).

Physical Data Models

DWH logical Data Models generate multiple physical tables that support the ETL processing logic.
o Source entity models: The source entity models are the data produced by an extemnal

application. Used for a specific version of the product, for example ALM 10/MSSQL, ALM 11
Oracle.
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Content Packs and Data Modeling

o Extraction models: ETL processes obtain the data in native format and stage it in intermediate
tables that conform to the extraction data model for that entity. Extraction also validates the data
to ensure that it is usable.

« Consolidation models: Consolidation models transform the data further by merging extracted
data from diverse sources into meaningful data required by applications.

« Target models: The target models describe the final version of the data that adheres to the
design required by applications.

Data models describe the source and extraction format so that the data warehouse can consume
this data and integrate it into a common view that you can use to populate comprehensive business
intelligence reports and dashboards.

Each table contains both designed columns and static columns, also known as metadata columns,
so that the administrator can have the visibility of ETL processing over the entity’s data.
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Data Warehouse Internal Fields

The following are the internal Data Warehouse fields, in addition to those in the IDE, that are added

to the model.

Field Name Prefixes = Description

MD_BATCH_ID ETL stream ID displayed on all Physical Models.

MD_PROCESS _ID ETL Process ID running the specific job.

MD_DURABLE_KEY  Entity’s unique identifier populated with MD_ENTERPRISE_KEY

value.

Displayed only in Target Physical Models

MD_ENTERPRISE_ | Entity’s unique identifier in the DWH system.

KEY

Displayed only in Consolidation Physical Models

MD_BUSINESS _KEY ' Entity’s unique key as it comes from the source systems.

Displayed only in Consolidation and Extraction Physical Models

MD_TRANSLASTIND | Indicator whether the line is the last transaction of a specific MD _

DURABLE_KEY.

Displayed only in Target Physical Models

MD_ Indicator whether the line is active (simulates delete operation).

ACTIVESTATUSIND

Displayed only in Target Physical Models

MD_ Transaction end date.
TRANSENDDATE

Displayed only in Target Physical Models

MD_DELETEDDATE @ Delete date (date record was marked as inactive).

Displayed only in Target Physical Models

MD_CREATEDDATE @ Date record was created.

Displayed only in Target Physical Models

MD_LASTMODDATE @ Date record was last modified and updated.

Displayed only in Target Physical Models

MD_FLAG Flag that indicates whether row is new, updated, or requires a delete.

Displayed only in Consolidations and Extractions Physical Models
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Content Packs and Data Modeling

Field Name Prefixes Description
MD_PF_FLAG Flag that indicates whether row is pre-filled or not.
Displayed only in Extractions Physical Models

MD_QUALIFIER Unique identifier of an Entity across all Sources, that allows
consolidations (like “Consolidation Rule”).

For example, “NODE” entity qualifieris FQDN Node name.

MD_CP_ID Source instance ID
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IDE Main Page and End-to-End Flow

The IDE main page enables you to create Designers for the purpose of extending content to
entities. The following describes the IDE main page and icons as well as the tasks and flow of the
IDE process.

The IDE Eclipse Main Page

The IDE requires basic knowledge of Eclipse and its capabilities. The following describes the IDE
layout and icons. Select Window > Show View to add to and change the view of the various tabs
and areas.

Note: It is recommended to select the IDE Perspective by clicking Eﬁ.

The IDE perspective contains all of the relevant buttons, areas, and functionality
for working in the IDE.

IDE Workspace: Main area where all IDE functions are located.

File Edit Diagram DW Content Mindow Help

o @ [rhom 5 T e oo | BBl Se o]0 | 0 B | -l o [EDETE )& o
T re— e s e G e T
| ~| ~ |5 Palette b |
4 |53 Context [ ALM.11.GENERIC. TEST_INT Gaa-

[5#] AMASSET2 engineercontext_dial

Testarchitectcontext_disgram e Tamet bntity 590
{57] testengineercontext_disgram |~ | \ [E null - TEST2 Transformation [E TEST2 C E“EWTNEM

¢ 12 cpealm L&) [ TEST INT Columns Colurmns = i

4 1 cp-alm-11-generic | o 2 DATE_CREATED £ DATE_CREATED Cl ED:.d Target
[ REQUIREMENTHIST e i ity
[8 TESTHIST +8 Ll STATLS &S STATUS {il] Target Colurnn
[s) REQUIREMENT PLHD s 2 d Dirmensions > Integration E.. %0
& b TR e i Mew Integration
[£] DOMAIN_PROJECT vl
& cvele
[8) DEFECTHIST g Load Integration
[ TEST Entity
[©) DEFECT_PLHD | {ill Integration
[8 TESTINSTANCEHIST Calumn

&) DEFECT (= Source Entity <0
[a) RELERSE 3 Mew Source
[& REQUIREMENT_TVFE Entity
[5 TESTINSTANCE i (5 Load Source
‘ 0 Enttity
ik - st A Sourceto
8 Data Source Explorer 13 = Integration
0&|E = mdlBET| e @
(= Database Connections | - | A Column
£ New SQL Server H it S Mapping
(= ODA Data Sources = == = ==
(= Flat File Data Source || B2 Broperties 32 K Prohierms o =

(= Wb Services Data Source

|| 4 Engineer Context
(= XML Data Source |

|| Rulers & Grid Display Measurement

| | B

|| Appearance :!Shu""R“‘” Ruler Units | Inches -
| [ Show Grid

| Fondmpron | 07 Spacing 1125
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| cu\w [ Shap To Shapes
| Style |SpacedDot  ~| | Restore Defaults
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User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

Ul Element Description

Package Explorer A list of all of the available loaded Content
Packs and Designer diagrams.

Canvas Displays model diagram.
Problems Displays validation errors and warnings.
Properties Displays property tabs according to the

selected entity in the Designer.
Error Log Reports system errors.

Data Source Explorer Enables you to connect to a specific data
source and browse the database.

EL ETL Generation. Appears when a
designer is open in the canvas. Click to
perform the ETL process and generate the
artifacts and create a new Content Pack.
For details, see "Generate Content" on
page 73.

BODS Export. Click to perform BODS
export process. For details, see "Export
from BODS" on page 82.

=] Save. Click to validate and save your
mappings and configurations.

- Report a Bug. Click to gather information
for a bug report packaged in a ZIP file.

&% Validate. Click to manually perform
validations on the Designer.

5t Perspective. Select to switch to

recommended IDE perspective.

This perspective contains all of the
relevant buttons, areas, and functionality
for working in the IDE.
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IDE Icons

Icon Description

= Indicates a Target entity.
5] Indicates an Integration entity.

& Indicates a Source entity.

a0+ Indicates a Target extension entity.

& Indicates a Integration entity column.
3 | Indicates a Fact entity column.
=
E Indicates a Dimension entity column.
- Indicates an association between Fact and Dimension entities.
5‘ Indicates an association between Dimension entities.
ﬁ Indicates a column which exists both as a Fact and as a Dimension.
O Indicates a consolidation column.

Warning that appears when you save a problematic change to a model that might
cause an error at a later stage in the process. You can view the details by hovering
over the icon on the model or in the Problems tab.

[=

a Error that appears when there is a design problem with your model in a designer.
For example, the length of a column is too long. You can view the details by
hovering over the icon on the model or in the Problems tab. Right-click an error to
check if Quick Fix has been enabled for the problem. For details, see "Manage
Validation" on page 60.
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The IDE End-to-End Flowchart

The following illustrates the typical tasks and procedures in the IDE. The tasks correspond to the
relevant tasks in the Designers.
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Develop New Entities
using the IDE

New
Content
ack?

l Yeos No—¢

Create New Integration Use Existing
or Source Content Pack Content Pack
Folder Folder
[ |
" Add New Y
i Target Entity?
Define New Target Entity in
the Architect Target
Extend an " Designer
QOOTB Entity? o
Add New Source .
Yes Entity? *
Load Existing OOTB Target
Entity in the Architect Target
Designer vis
D;ﬂ;irimlzc’f?rt;g"gtw | Load Existing Target Entity in the
Designer Engineer Stream Designer
Define New "
Integration?
Yes
k.
Define New Integration in Load Existing Integration in
the Engineer Stream the Engineer Stream
Designer Designer

Define New Source in
the Engineer Stream +
Designer

.

Generate ETL Files
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Discover Data Evidence

It is necessary to understand and be familiar with the new data you want to develop. When there is
a new source system involved, you must first understand how the data from the source appears
and operates.

Data Evidence can be done as follows:

1.

2.

Understand how to extract the data.

Take sample files extracted from the source.

Examine different fields that this source provides: It is important to recognize the fields and
data which come from the source and to define the names of the fields as the source tables.

Define and plan in advance which extractors provide data for specific entities.

Understand variety, different lists of values, end-cases.

Observe data behavior over time:

Understand what happens with data across time —is it the same file, only different dates?
Sizes of rows and volumes by types of customers.
Identify how this data correlates with existing data in the Data Warehouse.

At the end you should have a good sense of what this data looks like and how to develop
extraction code for it.

Identify:

a.

b.

d.

What is the required data to be available in the Target schema to support required KPIs.
What is the data that can come from the source (depending on technology).

Where do they meet in the middle, so eventually we have the outcomes of the extracted
data and the DWH Target model.

For which columns do you want to preserve history.

After mapping between the Source and the Target, the design process is complete.
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Import Existing Content

When you extend your existing content using the IDE, you must import the relevant content packs
you want to work with.

Note: You must import the Target Content Pack (cp-core) in order to extend or create content
inthe IDE.

1. Navigate to File > Import > General > Existing Projects into workspace and click Next.
2. Browse for the cp-core folder and click OK, click Finish to import the project.
3. Import all of the relevant content packs you need to work with.

4. Proceed to creating the Designers.
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Define New Content Pack Project

The IDE comes with out of the box Content Packs which you can import to add and extend content.
You can also create projects based on data from new content folders, which you must manually add
and define.

Note: You must import the Target Content Pack (cp-core) in order to extend or create content
in the IDE.

Tasks

To create new projects from content folders:

1.

2.

Select File > New > Other > DWH IDE > Content Pack.

Select the type of project: Source,or Integration.

Enter the relevant details for the project and click Next.

Select the relevant Content Pack reference for the project:

= For new Integration CP select the Target Content Pack for the project.

= Fornew Source CP select the Integration Content Pack for the project.

Click Finish.

Proceed with defining the Architect Target and Engineer Stream Designer projects. For details,

see "Architect Target Designer Tasks" on page 35 and "Engineer Stream Designer Tasks" on
page 47.

HP IT Executive Scorecard (9.4) Page 29 of 110



Content Extension Guide for XS IDE Version 9.4
Define New Content Pack Project

Ul Description

Integration
= Integration Project =Bl & |
Integration Project @
Create a new integration content pack project, B
Product narme:
[#] Use default location
ation: | CAlsershsussmantaarkspace Browese,.
“Working sets
[] &dd project to working sets
i sets! select.,

-

User interface elements are described below:

Ul Element Description

Product Name  Name of the source product.

Make sure that after you define the product name, you can view the file under
the Integration project icp.dwmodelappintegration file.

Use Default Select to use the displayed location for your new project.
Location
Location Browse to the location of the content folder.
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Ul Element Description

Add projectto  Select to add this project to the current set of projects.
working sets

Working Sets Select new working sets.

[ | |7

i@: Integration Project ,‘-‘:»__EI ............. 2 |

Target Content Pack Reference @ . i
Zelect target content pack, .

Referenced projects:

[ l=Fcp-core

—
'\?:' et = [ Finizh ] [ Cancel

Select the Target Content pack for the new Integration project and click Finish.
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Source

[.] Source Project

Source Project

Create a new source content pack project.

[

Product Mame
‘Wersion

Product Type
[#] Use default location
CisersisussmantanvorkspacetIDE Browese.,.
default

Working sets
[ Add project to working sets

Select.,

.

(s =

User interface elements are described below:

Ul Element Description
Product Name Name of the source product.

Make sure that after you define the product name, you can view the file under
the Source project scp.dwmodelappsource file.

Version Enter the data source version.

Product Type Enter the data source type.

Use Default Select to use the displayed location for your new project.
Location
Location Browse to the location of the content folder.
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Ul Element Description

Add project to Select to add this project to the current set of projects.
working sets

Working Sets Select new working sets.

E.] Source Project

Integration Content Pack Reference

Zelect integration content pack,

Referenced projects:

[[] = cp-alm
[ = cp-alt
[[] =2 cp-arm
] I=Fcp-bsm
¥ = ep-dp
[ =cp-na
[ = ep-nnrn
[ 2 cp-ppm
[[] = cp-sa
[ = cp-stn
[] = cp-test
[ = cp-ucrndb

':?:' Mest = [ Finish J [ Cancel

LS

Select the Integration Content pack for the new Source project and click Finish.
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Define the Target Model

Before working with a specific designer, you should define the Target model and the related
associations and mappings. The Target model describes the final version of the data that adheres
to the design required by applications. Each table in the model contains both designed columns and
static columns, which comprises the metadata, so that the administrator can have the visibility of
ETL processing over the entity’s data.

Target Model — Dimension or Fact: The target data models describe the format of the data that
produces business intelligence analytics. The instantiated data models are dimension, fact, and
hierarchy tables.

In the Architect Target Designer you define the target model containing the entities and links
between them.
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The Architect Target Designer enables you to define a Target entity as well as link associations, or
extend an existing entity. Each Target entity in the Architect Target Designer contains columns of
fact, or dimension (or both) and associations to other Target entities.

Architect Target Designers can contain one or more Target entities. Usually each Architect Target
Designer includes several entities that are related to the same subject (Designer). Target entities
can be included in several Architect Target Designers.

The IDE supports the extension of a target entity by creating an association called Target
Extension. This enables you to extend an entity by adding to the new entity columns. Adding an
extension enables Fact extension and the ability to link a group of Dimensions specifically to the
same group. You then use the extension entity to make all associations and links.

Note: Make sure you have selected the IDE perspective before beginning to work on your
designer diagram.

Note: It is recommended to create a separate general project in the Package Explorer for the
Architect Target Designer files.

Learn More

The Architect Target Designer enables the following:
« Create a new entity metadata which is translated into the Target model.
¢ Load an existing Target entity.
o Add columns which affect entity generation.
o Add associations between entities.
= Link a Fact to Dimension
= Link a Dimension to Dimension

= Link an entity to an extension

Tasks

This section includes:

"Create a new Architect Target Designer in the IDE:" on the next page
"Define a new Target entity:" on the next page

"Load an existing Target entity:" on the next page

"Extend a Target Entity:" on the next page
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"Add a column: " on the facing page

"Link a Dimension to a Dimension:" on the facing page

"Link a Fact to a Dimension:" on page 38

"Extend custom ITFM Entities:" on page 38

Create a new Architect Target Designer in the IDE:

1.

2.

3.

In the IDE main page, select File > Architect Target Designer and click Next.

Select the parent folder and enter the file name for the Stream Designer diagram and click
Next.

Select the relevant Target Content Pack directory and click Finish.

Define a new Target entity:

1.

4.

In the Architect Target Designer, in the palette area, select New Target Entity and click on the
canvas.

Name the entity.

Add relevant columns to the entity.

Click |-'3’-|Save.

Load an existing Target entity:

1.

4.

In the Architect Target Designer, in the palette area, select Load Target Entity and click on
the canvas. The Resource Selector dialog box opens.

Expand the target folder and select an entity. The entity is displayed with all of the previously
added columns and dimensions.

Add relevant columns to the entity. You can then edit and configure columns in the Properties
view.

Click "= save.

Extend a Target Entity:

1.

In the Architect Target Designer, in the palette area, select Load Target Entity and click on
the canvas to load the target entity that you want to extend. The Resource Selector dialog box
opens.

Expand the target folder and select an entity. The entity is displayed with all of the previously
added columns and dimensions.

Select New Target Entity and click on the canvas to add the entity which will be the target
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extension.

4. Name the entity. If you are extending the Person entity, for example, you can enter PERSON _
CSTM.

5. Inthe Properties tab of the new entity, configure the entity Type (Fact or Dimension). Must be
the same entity type as the base entity.

6. Inthe palette area, click Target Extension.
7. Drag the arrow from the new extending entity to the original loaded entity.
8. This relation creates an extension to the new entity. The new entity name is displayed as an

extension in the original entity. You can add relevant columns and configure the extended
entity as necessary. Mapping is then done from the Integration to the Target extension.

Note:

= The extending and base targets are referred to as a single entity. Therefore, you can not
add a column with the same Column ID of one in the original base entity.

= When you add an extension, make sure that the Source and Target are from the same
type.

= Target Extensions can also be extended.

= The name of the extension is derived from the name of the extended entity and cannot
be changed.

Add a column:
1. Inthe Architect Target Designer, in the palette area, select Target Column.
2. Click in the Column area of your entity and enter the Column ID in the text box.

The column is added to the entity. You can then edit and configure columns in the Properties
view.

3. Click I-;3’;-'Save.

Link a Dimension to a Dimension:

1. Inthe Architect Target Designer, in the palette area, click Dimension to Dimension.
2. Drag the arrow from a Dimension to the Dimension you want it linked to.

3. The New Dimension to Dimension dialog box opens. The default name is displayed and can be
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edited. This relation links a Dimension entity to another Dimension.

Note: If you link to an entity from an existing association, you can connect using the arrow
without naming the Associated Dimension.

The default Associated Dimension name is the Target entity.

4. Click I-;3'.-'Save.
Link a Fact to a Dimension:

1. Inthe Architect Target Designer, in the palette area, click Fact to Dimension.
2. Drag the arrow from the Fact entity to the Dimension you want it linked to.

3. The New Fact to Dimension dialog box opens. The default name is displayed and can be
edited. This relation links a Fact entity to another Dimension.
Note: If you link to an entity from an existing association, you can connect using the arrow

without naming the associated Dimension.

The default associated dimension name is the Target entity.

4. Click "*'Save.
Extend custom ITFM Entities:

1. Inthe Architect Target Designer, in the palette area, select Load Target Entity and click on
the canvas to load the target entity that you want to extend. The Resource Selector dialog box
opens.

2. Expand the target folder and select either ACTUALCOST_CSTM or PLANNEDCOST_CSTM
(custom extended) entities. These two ITFM entities come OOTB with custom extension
entities that can be further extended through the ACTUALCOST_CSTM or PLANNEDCOST _
CSTM entities.

Ul Description

To access:
In the IDE main page,select File > Architect Target Designer.
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Create Architect Target Designer

Fa T !

E Mew D'WH Architect Target Designer 24

=

Create Architect Target Designer e
Select jectwehich will tain th hitect target desi file, EIC
elect a projectwihnich will Cantalh the arcnImect Target designer e

Enter ar select the parent folder:

cp-arm-3.1-oracle

= Context -
= cp-alm

= cp-alm-11-generic
= cp-alt

= cp-alt-1.0-oracle .
= cp-alt-9.0-oracle

m

l=F cp-am
=% cp-arm-5.1-mssgl
[= .settings

=% cp-atn-5.1-oracle
= cp-am-5.2-mssqgl
= cp-am-5.2-oracle
=% ri-hsm

File name: default.architectcontext_diagram

@ <Back | Mext> | Finish

L A

User interface elements are described below:

Ul Element Description

Enter or select the parent = Select the folder in which this Designer will be contained, from
folder the folder list.

File Name Enter a file name for your Designer diagram.
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Target Content Pack selection

E.] Mew D'WH Architect Target Designer

Target Content Pack

EIERSE)
Select target content pack directary Elie
(E—e)

Target content pack: Browwse...

.7,‘"- .
- ac [ IF115 ance
@ o> ) [

L A

User interface elements are described below:

Ul Element Description

Target Content Pack Select or browse for the Target Content Pack directory.
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Architect Target Designer View

File Edit Diagram DW Content Window Help

- H @ @ [sgoetr B LN R AR R B~ o ~lUm = [BemE & 1ave

1% Package Explorer 7 <o @"aafamtav(mtmmmm,magram 22 [ INTEGRATIONZ engineercontext_diagram } =g
B |k Palette b
g Cowt .
S epeaim =
i ep-alm-1l-generic
g epealt & New Target Entity

» & cpralt-L0-oracle
B cp-at-d0-oracle
i pram

» 32 cpram-5mssql

» 2 cp-am-5 L-oracle

> & cpram-5.2-mssql

» 2 cpram-5 2eoracle

C B pebsm

» k2 cp-bsm-8.01-bsrm

» 2 cp-bsmn-d.01-uerndh

€ BUDGET

2 BUDGET_NAME

2 BUDGET_NAME_ALT

%, Load Target Entity
(Il Target Coluran

(5 Target Entites Relation
_/ Dimension to Dimensian
A Factta Dimensian

7 Target Excension

L epecore
B pedp

S 3 cp-dp-6.2-generic

S B cp-dp-t.2-oracle

S e

» 5 epena-dd-generic

S epennm

» & cp-rnm-8-1-generic -

=0 o a o
8 Data Source Bxplorer 5 € BUDGETCSTM 4
S|md| B~

(& Database Cannections

5 NewSQL Server EF
(> ODA Data Sources © rarm— o
(& FlatFile Data Source I BUDGET
(& Web Services Data Source
(& ¥ML Data Source
« »
3 Properties £3 . {1 Problems | #@r=~-0
€ Target
General General Attributes T
Columns General target entity attributes
Appeannze | BUDGETCSTH =
Business Name: BUDGETCSTM
Description BUDGETEXT description
[ZIDimension
[¥]Fact =

User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):
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Palette Area

ul
Element Description

Entities = Contains the following Target entity options:

e L New Target Entity. Creates a new Target entity. Entity type can be defined in
the Properties tab. To view the Properties tab, right-click on the specific entity
and click Show Properties View.

« ' Load Target Entity. Opens the Resource Selector dialog box. Select the
relevant entity for your model.

Resource Selector

a4 CORE -
ABC / ABC B
ACTUALCOST £ Actual Cost Lines
APPLICATION f Applications
BACKUP_POLICY f Backup Policys
BACKUP_SESSION / Backup Session
BUDGET ¢ Budgets
BUDGETLIME f Budget Lines
BUSIMESS_ APP_STATLUS f Business Application Status

BUSPROCESS f Business Process -

o) (i)

o U]]Target Column. Adds columns to entities. Column properties, for example
column type, can be edited in the Properties tab.

Each added attribute impacts the relevant entity generations.

Target Click alink to create connections for building the model.
Entities

Relation A . . . . . . : .
Dimension to Dimension. Link from one Dimension to another Dimension.

A red arrow is displayed between the entities.

o - Fact to Dimension. Link from a Fact to a Dimension. This type of relation
requires that the fact type was defined in the entity properties. A blue arrow is
displayed between the entities.

o« Target Extension. Link from a new target entity to the base/original target
entity. A black arrow is displayed between the entities.
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Properties tab for Target entity and specific fields

To view the Properties tab, right-click on the specific entity and click Show Properties View.

You first configure the Target entity properties, and then the properties for each specific column.
Ul Element Description

General tab | Displays the Entity, Dimension and Fact attributes for the target entity.

General Target entity attributes:

o ID: The ID of the entity.

o Business Name: The complete business name.

o Description: Enter a description of the entity.

« Dimension/Fact Checkbox: Select one or both for the entity.

If you change the selection, a dialog opens, warning that you may lose
information previously entered in the Columns tab.

Note: Make sure to select the required option connected to the relevant Fact or
Dimension column properties.
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Ul Element Description

Columns Displays information for each column in the Target entity. Column property
tab options are displayed according to the entity selection of Fact or Dimension in the
General tab.

¢ ID. The ID of the entity.

o Business name. The complete business name.

o Description. Enter a description of the entity.

o Data Type. Varchar, Int 16, Int 32, Float, Localized Date Time

¢ Length. Only for Varchar data type. The length of a Varchar column must be
more than 0 and less than 4000.

e Null Allowed. Select if the field can have the value NULL.

e SCD Type. Slowly Changing Dimension type can be either 1 or 2. Only for
Dimension.

SCD1: For update.
SCD2: For preserving history.
e Measure. Select only for Fact.
¢ Calculation Formula. The calculation of the measure. (Optional)

e Summary. Select SUM, MIN, MAX, or AVG. (Optional)

Appearance Displays font and appearance information.
tab
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Properties tab for Associated Dimensions

To view the Properties tab, right-click on the specific entity and click Show Properties View.
Ul Element Description
Associations tab Displays Dimension association information:
o ID. The ID of the entity.
o Business Name. The complete business name.
o Description. Enter a description of the entity.
o Type. Select Dimension, Fact, or Both.
e SCD Type. For Dimension only.
o From Target. The Target entity.

o To Target. The Associated Dimension

Appearance tab Displays font and appearance information.

New Associated Dimension Dialog Box

When you link to an unlinked Dimension, the following dialog box opens.

= Mew Dimension to Dimension Relation 5 . EE
Ihsert associated dimension name
BUSPROCESS?
[ 0] ] ’ Cancel

Edit an Associated Dimension name. The default is the Target entity name.
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Target Extension Entity

' E BUDGET

Colurmns A iated Dirnensions
B4 BUDGET_MAME

E BUDGET_MAME_ALT

= =} o
C BUDGETEXT
Columns iated Dimensians
& TEST
al
Extension
[ BUDGET
O o o
OOTB ITFM Custom Target Extension Entity
C ACTUALCOST L ACTUALCOST CSTM
= COST_BASE
- Associated Dimensions
= COST_LOC Sa
= QuANTITY h
= Ca
= FLAG_CLOSED 4 ACTUALCOST ~__
= poense stats
ACTUALCOST_BUSINESS_KEY GLOBAL_ID
= ACTUALCOST_DESCRIPTION &5 CLTYPE

= CURRENCY_BASE
= CURRENCY_LOC
= DATE_INCURRED
&, COSTCATEGORY
£, CONTRACT

57, ORG

£7, COSTCENTER
&7, PROJECT
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The Engineer Stream Designer enables you to define the integrations and how they are transformed
and connected. This view defines the mapping relations for the entity from the source to the target.
You can create new integrations based on graphical diagrams, using the Engineer Stream Designer
in the IDE tool.

Note: Make sure you have selected the IDE perspective before beginning to work on your
designer diagram.

Learn More

The Engineer Stream Designer enables you to extend and add content from the Integration and
Source Content Packs into the target model. Using a new or existing Target entity, you can add
new or existing content from the Integration and Source entities. You then perform transformation
and Source Integration mapping for new and pre-loaded entities. The Source, Integration and Target
entities are mapped using the Transformation Mapping connector, which creates a new mapping
entity. All further mapping is done to the new entity in order to complete the Target model.

Note: All Source entities must be connected to an Integration entity.

Entities in the Engineer Stream Designer are mapped as follows:

o Source Entity: Mapping to the correct source, meaning the version the data is extracted from.
¢ Integration Entity: Contains the mapping of all fields.

o Target Entity: Several consolidation entities can be consolidated into one entity.

It is recommended to map from the Source to the Target.

Source Extractors:

OOQOTB set of existing supported extractors are:

o Generic Extractors
s DB Extractor: Supports MSSQL, Oracle and MySQL databases.
» File Extractor: Supports general CSV file.

o Source Specific Extractor
= BSM API Extractor: Supporting both GDE and REST calls.

= DP CLI Extractor
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= SA SDK Extractor
= NNM Optimized file Extractor: Holds mass volumes of NNM files.
Connecting to the integration:

ETL Gen templates in the back-end generate integration templates which utilize File Based
Integration (FBI). Load the Source metadata to the IDE and then map it to the correct
consolidation entity in the relevant fields. To create a custom FBI extractor, see the FBI
Extractor SDK Guide.

Important Information

Note: Creating new Target entities with Associated Dimensions can only be done in the
Architect Target Designer.

Tasks

This section includes:

"Create a new Engineer Stream Designer in the IDE:" below
"Define a new Target entity:" below

"Load an existing Target entity:" on the facing page

"Define a new integration entity:" on the facing page

"Load an existing integration entity:" on the facing page
"Define a new source entity:" on the facing page

"Load an existing source entity:" on page 50

"Add a column:" on page 50

"Map from the Integration to Target:" on page 50

Create a new Engineer Stream Designer in the IDE:
1. Inthe IDE main page, select File > Engineer Stream Designer and click Next.

2. Enter or select the parent folder and enter the file name for the Engineer Stream Designer
diagram and click Next.

3. Select the Target, Integration, and Source Content Pack directories and click Finish.

Define a new Target entity:

1. Inthe Engineer Stream Designer, in the palette area, select New Target Entity and click on

the canvas.
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2. Name the entity.

3. Add relevant columns to the entity.

4. Click |-;3'.-|Save.
Load an existing Target entity:

1. Inthe Engineer Stream Designer, in the palette area, select Load Target Entity and click on
the canvas. The Resource Selector dialog box opens.

2. Select an entity. The entity is displayed with all of the previously added columns and
dimensions.

3. Add relevant columns to the entity. You can then edit and configure columns in the Properties
view.

4. Click "= save.
Define a new integration entity:

1. Inthe Stream Designer, in the palette area, select New Integration Entity in the Integration
section and click on the canvas. An integration entity is displayed.

2. Enteraname. The name can be up to 44 characters. An Integration entity is created.
3. Click Integration Column to add a column to the entity.

4. Perform mapping if required.

5. Click |-;3’;-|Save.
Load an existing integration entity:

1. Inthe Stream Designer, in the palette area, select Load Integration Entity in the Integration
section and click on the canvas. The Resource Selector dialog box opens.

2. Select an entity. The entity is displayed with all of the previously added mappings.

Define a new source entity:

1. Inthe Engineer Stream Designer, in the palette area, select New Source Entity in the Source
section and click on the canvas. A Source entity is displayed.

2. Click Source-Integration Relation and drag the display arrow from the Source entity to an
Integration entity. All columns from the Integration entity are copied to the Source entity with
default values.
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3. Click = save.

Note: The Source-Integration Relation tool only enables you to link Source entities to
Integration entities of the same product (content pack). For example, a Source entity from
cp-bsm-9.01-bsm can only be linked to Integration entities from cp-bsm and not cp-ppm.

Load an existing source entity:

1. Inthe Engineer Stream Designer, in the palette area, select Load Source Entity in the Source
section and click on the canvas. The Resource Selector dialog box opens.

2. Select an entity. The entity is displayed with its mapped integration entity.

Add a column:

1. Inthe Engineer Stream Designer, in the palette area, select Target Column or Integration
Column.

2. Click in the Column area of your entity and enter the Column ID in the text box.

The column is added to the entity.
3. Click "= sSave.

Note: Source data is replicated from the integration entity. If you add or delete columns from
the Integration, however, it is not automatically done in the Source.

To add: Once you have added the column, delete the mapping link and re-map from the Source
to Integration.

To delete: Right-click the deleted column, delete the mapping link and re-map from the Source
to Integration.

Alternatively, you can use the Quick Fix mechanism on the error that appears in the Problems
tab. For details, see "Manage Validation" on page 60.

Map from the Integration to Target:
Once you have added columns to the Integration entity you can perform SSI mapping.

1. Inthe Engineer Stream Designer, in the palette area, click Column Mapping in the Relations
section to map the Integration to the Target entity.

2. Drag the arrow from the Integration column to the Target column.

3. After you have performed the first SSI mapping, a transformation SSI entity is created to which
you can perform further mapping. Any integration entity from the same CP that should be
mapped to this Target, must be mapped to the transformation entity.
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Note: If an Integration column is already mapped to a Target column, you cannot perform

further mapping from the same Content Pack.

Two Integration entity columns from the same Content Pack cannot be mapped to the

same Target entity column.

Ul Description

To access:

In the IDE main page, select File > Engineer Stream Designer.

Engineer Stream Designer View

File Edit Diagram DW Content Window Help

[mild & i[Tehoma 9 A~ sy —-|@ BB
[ Package Explorer 2 = O([# defaultarchitectcontext_diagrarn | [+#) INTEGRATIOMZ engineercontext diagram &3
G INTTEGRATION2
4 coLumL
4 column:
= >
12 ep-amSlmssgl 3 e
& cp-am-SLooracle e € BUDGET

& cp-am-5.2mssql = —
& cpam-sz-oracle 3 TEST.2.0.GENERIC INTTEGRATION2
& cpesm

B cp-bsm-9.01-bsm 3 BUDGET_NAME_ALT
& cprbsm-.01-ucmdb

& op-core

2 BUDGET_NAME

3 Properties ©2 _fj.. Problems

+ Engineer Context

Rul Display Measurement it
A [CIShowRuler | ¢ tnits [Tnche ~
[ Show Grid

7] i 1 oy G Spacing 0,125
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Palette Area
Ul Element

Target Entity

Page 52 of 110

Description

iC New Target Entity. Select to display a new Target entity.

« ®Load Target Entity. Opens the Resource Selector dialog box. Select
the relevant entity for your model.

Resource Selector

4 CORE
ABC f ABC
ACTUALCOST f Actual Cost Lines
APPLICATION / Applications
BACKUP_POLICY / Backup Paolicys
BACKUP_SESSION / Backup Session
BUDGET / Budgets
BUDGETLIME # Budget Lines
BUSINESS_APP_STATUS f Business Application Status
BUSPROCESS / Business Process

o) i)

. Lﬂ]Target Column. Adds columns to entities. Column properties, for
example column type, can be edited in the Properties tab.

Each added attribute impacts the relevant entity generations.
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Ul Element Description
Integration Contains the following Integration entity options:
Entity

o “@New Integration Entity. Select to display a new Integration entity.

&= Load Integration Entity. Opens the Resource Selector dialog box.
Select the relevant entity for your model.

Resouce Selector

ALT -

AM

BSM

Dp
T_OBJECT / NODE
T_MEDIA / LOCATION
T_SESSION / T_SESSION

MNA

MMM

PPM -

m

oK ] ’ Cancel

il Integration Column. Adds columns to entities. Column properties, for
example column type, can be edited in the Properties tab.

Each added attribute impacts the relevant entity generations.
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Ul Element Description

Source Entity  Contains the following Source entity options:
o UNew Source Entity. Select to display a new Source entity.

« [BLoad Source Entity. Opens the Resource Selector dialog box.Select
the relevant entity for your model.

-
Resouce Selector

> AM.51.mssql -
> AM.5.1.oracle
» AM5.2.mssgl
> AM.5.2.oracle
» B5M.9.01.B5M
» BSM.9.01.UCMDE
a DP6.2.GENERIC
T_MEDIA
T_SESSION
> DP.6.2.oracle -

m

[ QK ] I Cancel J

%

« 'Source to Integration Relation. The Source must be mapped to the
Integration in order to map to the Target. A green arrow is displayed
between the entities.

Transformation = Click to map the displayed entities.

o .~ Column Mapping. Mapping between the Integration and Target
columns. First time mapping is done from the Integration column to the
Target column. A black arrow is displayed between the entities.

First-time mapping creates a new entity for Transformation. Subsequent
mappings are done to the new Transformation entity.
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Properties tab for Integration

To view the Properties tab, right-click on the specific entity and click Show Properties View.

Note: Properties data is replicated in the Integration and Source columns. If you add or delete
columns from the Integration, however, it is not automatically done in the Source.

To add: Once you have added the column in the properties tab, delete the mapping link and re-
map from the Source to Integration.

To delete: Right-click the deleted column, delete the mapping link and re-map from the Source
to Integration.

Ul Element Description
General tab Displays the General entity attributes.
Columns tab Displays column information:

e ID. The ID of the column. It is taken fro the mapped integration column
and is read-only.

e Business name. The complete business name.
o Description. Enter a description of the entity.
o Data Type. Varchar, Int 16, Int 32, Float, Localized Date Time

¢ Length. Only for Varchar data type. The length of a Varchar column must
be more than 0 and less than 4000.

o Null Allowed. Select if the field can have the value NULL. If you specify
a Business Key, at least one of the columns must not Null Allowed.

o Business Key. Primary key of the Integration field order. Select a
number for the order of columns for placement. When no number has
been assigned, you can only select 1. Subsequently you can assign any
number to a column. If you change a number, all other assigned columns
are automatically shifted down a spot in the order.

For example, if you change the Business Key of a column to 1, the one
that was specified previously as 1 becomes 2.

o Last Modified. The last date that the source has been changed. Select
the button if you want a query from a certain date and not all possible
data.

Properties tab for Source

To view the Properties tab, right-click on the specific entity and click Show Properties View.
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ul
Element Description

General General attributes:

tab
e ID. Theentity ID.
o Content Pack. The Source Content Pack information.
Data Source SQL Clauses:

¢ Group by. The section in the SQL Query for the aggregation.

o Table Name/Join Condition. Default is Integration entity name. If you change
the table name, you must also change it in the columns. Enter the Join Condition
for an SQL query with join.

o Where. Where to extract for the SQL query for filtering data from the source.

Columns Displays column information. The Source entity receives all of the Integration entity
tab properties.

e ID. The ID of the column. It is taken fro the mapped integration column and is
read-only.

o Type. Select Fixed, Direct, or Rule. If you select Fixed, you must enter a Fixed
Value. if you select Rule, you must enter the Calculation Rule.

« Not Applicable.

o Table Name. Based on table name entered in the General tab. Relevant only if
Direct type is selected.

e Column Name. The field name. Must be what appears in the Source entity.

o Fixed Value. The fixed value of the column. Relevant only if Fixed type is
selected.

o Calculation Rule. The calculation rule of the column. Relevant only if Rule type
is selected. The IDE does not support non UTF-8 characters in the Calculation
Rule field.

For details on the Properties for Target entities, see "Properties tab for Target entity and specific
fields" on page 43

For details on the Properties tab for Associated Dimensions, see "Properties tab for Associated
Dimensions" on page 45.
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Extend the Period Entity

The Period target entity requires special mapping requirements in the IDE. The entity contains time
and date related mapping and can only connect to date related sources and dimensions, for
example START_TIME.

When you connect to a data source that has a Period entity, the data source consistently changes
depending on configurations. Therefore you can only map to date-related entities and dimensions.

@“’default‘archltectcuntext_dlagram 2 INTEGRATIONZ‘engmeercuntext_dlagram ]

C INCIDENT

ted Dimensions

E INCIDENT_STATUS

B INCIDENT_TVPE

— ciated Dimensians 0
< TEST @, INCIDENT_TIME E CATEGORY

B SUBCATEGORY
B ACTIVE_PROCESS
& PRIORITY
B REFERENCE_NUMEBER
B COMPLETION_CODE
B IMPACT_SCOPE
B URGENCY
B ESCALATION
B OUTAGE_START
B2 OUTAGE_END
\ 59 CLOSE_TIME
) B CREATE_TIME
B REOPEN_TIME
T 4 OUTG_START_DATE
4 OUTAGE_END_DATE
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Delete an Entity Permanently

The IDE enables you to permanently delete an entity that is not needed or supported, from the file
system. Make sure that no other entity contains any reference to the deleted entity.

Note: When you right-click a selected entity and click Delete From Model, the entity is only
removed from the current designer and not from the file system.

To permanently delete an entity:
1. Delete the relevant entity from the canvas.

2. Inthe Package Explorer, expand the content pack that contains the entity you want to delete,
for example cp-sa.
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3. Delete the actual entity, for example POLICY, from the Package Explorer.

s Package Explarer EE = O]

= Context
= cp-alm
= cp-alm-11-generic
b cp-alt
== cp-alt-L0-oracle
=% cp-alt-9.0-oracle
= cp-am
L= cp-am-al-mssql
1= cp-arn-5.1-aracle
= cp-am-5.2-mssqgl
= cp-arn-3.2-oracle
= cp-hsm
= cp-bsm-9.01-hsm
= cp-bsm-9.01-ucrmdb
1= cp-care
= cp-dp
= cp-dp-6.2-generic
= cp-dp-6.2-oracle
= cp-na
=% cp-na-1.1-generic
= cp-nnm
== cp-nnm-9-1-generic
= cp-ppm
= cp-ppm-8.0-oracle
= cp-ppm-9.1-oracle
4 |=F cp-3a
& POLICY
POLICY_RESULT
SERWER
54 [Inteqration]
= cp-sa-9.00-generic
= cp-sm
1= cp-sm-T.11-mssqgl
= cp-sm-T.11-aracle
= cp-sm-9.2-rmssq|
= cp-sm-9.2-oracle
I=F cp-test
= cp-test-2.0-generic
1= cp-ucmdb
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Manage Validation

The IDE performs validations on all Designers and entities created in the Designers. After you save
your changes, click the Problems tab, below, to view the errors and warnings that occurred during
content development. Additionally, IDE provides a Quick Fix solution option to enable you to make
the required fixes for validation. All validations are performed only after you have saved your
changes to the Designers.

Data Source Explo

|4 errars, dwarnings,

Description Resource Path Location Type

| @ Errors (4 iterns)
@ Integration AMCOMTACT: no business key is defined defaultengin.,  fop-am Integration A..  DWVEngineer..,
@ Integration BUSINESS_SPPLICATION: no business key is defined defaultengin.,  fop-am Integration B...  DWVEngineer..
@ Integration T_OBIECT: no business key is defined defaultengin.,  fop-am Integration T_... DWVEngineer..
@ Target TESTMEW: na column is defined as dimension or fact defaultarchit., fcp-alt Target TESTM.., DW/Architect..,

& Wfarnings (4 items)

s Integration AMCONTACT column MDO_BUSIMESS KEY: id attribute wiolates DWW P defaultengin.,  fcp-am Integration C... DWVEngineer..
ui Integration BUSIMESS APPLICATION colurmn tD_BUSIMESS KEY: id attribute vio defaultengin., fcp-am Integration C...  DWVEngineer..
& Integration BUSINESS_APPLICATION: id length is greater than 14 charecters defaultengin.,  fop-am Integration B...  DWVEngineer..
st Integration T_OBJECT colurnn MD_BUSIMESS KEY: id attribute violates DV Platfc defaultengin.,  fcp-am Integration C... DWWEngineer..

Additionally, you can manually perform validations on all Designers and fix relevant errors and
warnings. To activate, click £4 in the toolbar, or select DW Content > Validate.

During the validation process, a Progress Information dialog box appears specifying the current
validated designer and its progress. Click Cancel to cancel the validation process.

F N

Progress Informaticn

'6' Validating: /cp-bsm-engineer/ORG.engineercontext_diagram

L

In case of an unreadable designer, an error dialog appears, listing the problem designer diagrams.
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# ' Validation Error @

fep-MMM-engineer/default.engineercontext_diagram

fep-alm-engineer/DEFECT .engineercontext_diagram |
fep-alm-engineer/ DEFECT_HIST .engineercontext_diagram
fecp-alm-engineer/DEFECT_PLHD.engineercontext_diagram
fep-alm-engineer/DOMAIN_PROJECT . engineercontext_diagram
fep-alm-engineer/PROJECT .engineercontext_diagram
fecp-alm-engineer/REQUIREMENT .engineercontext_diagram
fecp-alm-engineer/REQUIREMENTHISTORY.engineercontext_diagram
fep-alm-engineer/ REQUIREMENT_BRIDGE.engineercontext_diagrarm
fep-alm-engineer/ REQUIREMENT_PLHD.engineercontext_diagram

fecp-alm-engineer,/ TEST.engineercontext_diagram =

e =
Close

[t | »

Quick Fix

The validation process also includes a Quick Fix validation which provides recommendations for
solutions for validation problems displayed in the Problems tab.

To use the Quick Fix option:

1. Inthe Problems tab, under the Warnings or Errors list, right-click a warning or error and
select Quick Fix to open the Quick Fix dialog box.
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-
= DQuick Fix

Quick Fix
Select the fix for 'Source VALIDATIONS: columns are not synchronized with integration entity columns',

Problems:

Resource =% Location Select All
v] @ default.engineercontext_diagram Source VALID 1 VALID.VA...
= g -6 Deselect All

D)

-
e

L [ Finish J ’ Cancel

2. Select the fix for the specific waming and click Finish.

3. Click El Save and the error is removed.

Validation Table

Make sure all entities have been configured properly according to the following validations. An error
or warning appears in the Problems tab once you have made the problematic change, and saved it.
Note the validations that have the Quick Fix option available.
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Error Text

Target <Target
ID> column
<Column ID> -id
length is greater
than allowed

Integration
<Integration ID>
column <Column
ID>:-id lengthis
greater than
allowed

Target <Target

ID>: id length is
greater than 50

characters

Integration
<Integration ID> id
length is greater
than 44 characters

Sample errors:

Target <Target
ID>: 'Business
Name' field
contains
backslash (\)
character

Integration
<Integration ID>
'Description' field
contains
backslash (\)
character

Source <Source
ID>: 'Group By'
field contains
backslash (\)
character

Page 63 of 110

Validation

Length of column names
(including system suffix)

Length of entity names
(including system suffix)

Backslash (\) is not

permitted in any field text.

Source Integration Target
Upto 60 Upto 60 Upto 60
characters characters = characters
Up to 60 Upto44 Upto 50
characters characters = characters
v v v

Quick
Fix
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Quick
Error Text Validation Source Integration Target Fix
Target <Target Entity names and column v v v v

ID> column names must start with
<ColumnID>id alphabetic characters.
attribute violates

DW Platform

reserved prefixes:

starts with non

alphabetic

character

Integration
<Integration ID>
column <Column
ID>: id attribute
violates DW
Platform reserved
prefixes: starts
with non
alphabetic
character

Target entity is Make sure an entity v v v
invalid. File deleted from the file

containing the systemis also deleted

metadata was from the designer diagram.

deleted

Integration entity
is invalid. File
containing the
metadata was
deleted

Source entity is
invalid. File
containing the
metadata was
deleted

Target <Target Make sure Data Type is v
ID> column defined for all Target

<Column ID> columns.

DataType is not

defined
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Error Text

Target <Target
ID>: no column is
defined as SCD
for dimension
entity

Target <Target
ID>: no columnis
defined as
measure for fact
entity

Target <Target
ID>: not defined
as FACT or
DIMENSION

Target <Target
ID>: no columnis
defined as SCD
for dimension
entity

Target <Target
ID>: no columnis
defined as
measure for fact
entity

Target <Target
ID>: Invalid target
extension. Target
type doesn't
match

Target <Target
ID> column
<Column ID> -id
is not unique in
target extension
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Validation

Make sure when a Target
entity is defined as a
Dimension that SCD
Type is defined for at least
one column.

Make sure when a Target
entity is defined as a Fact
that Measure is selected

for at least one column.

Make sure a Target entity
is defined as a Fact, or
Dimension, or both. The
entity type cannot be left
unselected.

Make sure that when a
Target entity is defined as
a Dimension and a Fact,
that at least one columnin
the entity is defined
accordingly for each type.

Note: If the Target entity
contains only associated
Dimensions, this
validation is not performed.

Make sure that the data
type in the extended entity
equals the type of the base
entity.

Make sure column or
Associated Dimension ID
is unique in the Target
extension

Quick
Integration Target Fix
v v
v v
v
v v
v
v
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Quick

Error Text Validation Source Integration Target Fix
Target <Target Make sure Target v
ID>: Target extension does not contain
extension aloop, meaning the
contains loop extension of a base entity

can not also have the base

entity as an extension.

That would place the

entities in a loop with each

other.
Target <Target Integration names and in v v v v
ID> column the columns first character

<Column ID>id must be a letter:
attribute violates [a-z][A-Z].

DW Platform

reserved prefixes:

starts with non

alphabetic

character
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Error Text

Target <Target
ID>: id attribute
violates DB
character
constraints (a-z A-
Z09%# )

Target <Target
ID> Associated
Dimension
<Associated
Dimension ID> id
attribute violates
DB character
constraints (a-z A-
Z09%# )

Target <Target
ID> column
<Column ID>id
attribute violates
DB character
constraints (a-z A-
Z09S%# )

Integration
<Integration ID> id
attribute violates
DB character
constraints (a-z A-
Z09%# )

Integration
<Integration ID>
column <Column
ID>: id attribute
violates DB
character
constraints (a-z A-
Z09S$# )

Source <Source
ID> <Column ID>:
'Column Name'
field violates DB
character
constraints (a-z A-
Z09S$# )

Page 67 of 110

Validation Source

Integration names and in v
the columns next

characters should be a

letter, a digit, or' ', '$', or

"H#.

Quick
Integration Target Fix
v v

v
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Error Text

Target <Target
ID>: id attribute
violates DW
Platform reserved
prefixes: MD_or
DI_

Target <Target
ID> Associated
Dimension
<Associated
Dimension ID> id
attribute violates
DW Platform
reserved prefixes:
MD_orDI_"

Target <Target
ID> column
<Column ID>id
attribute violates
DW Platform
reserved prefixes:
MD_orDI_

Integration

<Integration ID>id

attribute violates
DW Platform
reserved prefixes:
MD_orDI_

Integration
<Integration ID>
column <Column
ID>: id attribute
violates DW
Platform reserved
prefixes: MD_ or
DI_

Content Extension Guide for XS IDE Version 9.4
Manage Validation

Quick
Validation Source Integration Target Fix
Integration names and in v v v v
the columns must not start
with one of the DW

Platform reserved
prefixes: MD_orDI_.
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Error Text

Integration
<Integration ID>
no business key is
defined

Integration
<Integration ID>
Business key
sequence is not
defined properly
(Doesn't start at 1
or numbers are not
sequential)

Integration
<Integration ID>
Business key
sequence must
contain at least
one column which
is not Nullable

Target <Target
ID>:Noidis
defined for column

Target <Target
ID> column
<Column ID> -id
is not unique

Integration
<Integration ID>
column <Column
ID>:-id is not
unique

Source <Source
ID> <Column ID>:
no value at table
name field

Source <Source
ID> <Column ID>:
no value at db
column name field

Page 69 of 110

Validation

Make sure that the
Business Key is specified.
In case of more than one
Business Key, they must
be in order (1, 2, 3) without
spaces in the numbering.

Make sure Null Allowed is
not selected for at least
one of the Business Keys.

Make sure that the column
has an ID and it is unique.

If a Source column has
Type set as Direct, then
make sure Table Name
and Column Name are not
empty.

Quick
Integration Target Fix
v
v v
v v
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Error Text

Source <Source

ID> <Column ID>:

no value at fixed
value field

Source <Source

ID> <Column ID>:

no value at
calculation rule
field

Source <Source

ID> <Column ID>:

'Column Name'
field contains
backslash (\)
character

Source <Source

ID> <Column ID>:

'Column Name'
field violates DB
character
constraints (a-z A-
Z09%# )

Source <Source
ID> doesn't
include join
condition

Source <Source
ID> contained in
<cp Name> is not
referencing to any
integration entity

Source <Source
ID>: columns are
not synchronized
with integration
entity columns

Validation

If a Source column has
Type set as Fixed, then
make sure Fixed Value is
not empty.

If a Source column has
Type set as Rule, then
make sure Calculation
Rule is not empty.

If a Source column has
Type set as Direct, then
make sure Column Name
does not contain special
characters. This validation
runs only if the Product
Type in the source Content
Pack is the database type
of either MSSQL, Oracle or
MySQL.

Make sure that the Source
entity has a Join Condition
and Table Name specified.

Make sure that a Source
entity is mapped to an
Integration entity.

Make sure that the Source
and Integration entities are
synchronized.
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Quick

Integration Target Fix
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Error Text

Integration

<Integration ID>
column <Column
ID>: is not

mapped to target
column and data
type is undefined

Integration
<Integration ID>
column <Column
ID>: contains
invalid mapping

Target <Target
ID> column
<Column ID>is
defined as
VARCHAR but
has no length

Integration
<Integration ID>
column <Column
ID>: is defined as
VARCHAR but
has no length

Target <Target
ID> column
<Column ID>is
defined as
VARCHAR but
length is greater
than allowed
(4000)

Integration
<Integration ID>
column <Column
ID>: is defined as
VARCHAR but
length is greater
than allowed
(4000)
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Validation Source

Make sure all mapped
Integration columns are
mapped accordingly to the
Target or have been
assigned a data type.

Make sure that the length
of a Varchar column is
more than 0.

Make sure that the length | v
of a Varchar column is less
than or equal to 4000.

Quick
Integration Target Fix
v
v v
v v v
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Error Text Validation

Noidis defined for Make sure each entity has
target entity an ID defined.

Noid is defined for
integration entity

Target <Target Make sure the defined

ID> column column name does not
<Column ID>the  contain areserved word.
idisaDB For details, see MSDN
reserved word Microsoft SQL Server

) reserved keywords list.
Integration

<Integration ID>
column <Column
ID>: theidis aDB
reserved word

HP IT Executive Scorecard (9.4)
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Quick
Source Integration Target Fix
v v v
v v v
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Generate Content

The IDE can generate the relevant schemas and ETLs that are required for the integration.

The ETL Generator generates the required artifacts based on the modeling in the previous steps.
The artifacts contain BODS workflows that are imported into the BODS repository as well as the
data models and XML files that are imported into the Data Warehouse metadata repository. Once
the metadata has been loaded, the schema generation mechanism performs the schema changes
in the target and the staging databases.

To access:

When a designer is open, the ETL button is displayed in the top right toolbar in the IDE workspace.
If it is not displayed, navigate to Window > Customize Perspective and make sure ETL Gen is
selected.

Click EL to begin the ETL Generator.

Content Pack Creation Tool

The Content Pack Creation Tool enables you to create a new Content Pack structure using existing
source content packs. This allows you to use the IDE to extend content as well as develop entirely
new Content Packs for use in the Data Warehouse and Executive Scorecard.

The ETL Generator action is relevant to the selected designer. The ETL button is only displayed
when a designer is open.

Tasks

To create a new entity and a new Content Pack with the ETL Generator:

1. Click EIL inthe toolbar on the top right of the IDE workspace to begin the ETL Generator. The
ETL Generator dialog box opens.

Eﬂ ETL Generator 22
XSETL Version: | 9.40 -|
Content Type: I}{S Content v‘

[7] Generate Content Pack

Directons Browese...
(]9 Cancel
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2. Select the XS ETL Version number 9.4, 9.30 or 9.31.

3. Select the Content Type: XS Content or Custom Content. This field designates a path in
BODS for the specific content type you are extending or creating.

4. Select the Generate Content Pack checkbox if you are creating a new Content Pack (not
extending content). This creates a new content pack structure along with the generated ETL
files. This capability is only available when generating the ETL files in the Designer.

Note: The Generate Content Pack checkbox is not available when generating the ETL
files from the Architect Target Designer.

When you generate the ETL files from the Engineer Stream Designer, the Generate
Content Pack checkbox is disabled if there are no source entities in the Engineer Stream
Designer.

5. Browse to the directory where you want the generated Content Pack to be placed. Click OK.
The process may take some time.

6. Proceed to package and deploy your content.
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Package and Deploy Content

After you have run the ETL Generator and saved the Content Pack, you must package your new or
extended content solution.

Note: In order to be able to fully revert the changes made by the CP deployment make sure to
back up the Staging, Target and BODS repository databases as the CP undeployment
functionality is not currently supported.

Copy the generated files to the Content Packs folder on the DWH server. Use the automation tool
to deploy the changes in content.

e For Content Packs with added or extended entities:

= The Target CP is deployed when changes are added to the target schema. Re-deploy the
Target CP by running the command
dw_ds_automation.bat -task Redeploy -cp Core.

= The Integration CP is deployed when changes made to an Integration or Source entity. Re-

deploy the i-CP by running the command dw_ds_automation.bat -task Redeploy -cp <CP_
NAME>.

o Fornew Integrated Content Packs: Make sure your new CP is packaged in the correct folder
structure by selecting the Generate Content Pack checkbox in the ETL Generator, and then
copied to the ContentPacks folder in your DWH installation.

1. Runthe dw_cp_register.bat tool to register the new Content Pack: dw_cp_register.bat -name
<CP_NAME> -type integration.

2. Configure the datasource.xml file and run command: dw_ds_automation.bat -task
Configurelnitial -cp <CP_NAME>.

3. Rundw_ds_automation with deploy task: dw_ds_automation.bat —cp <CP_NAME> —task
Deploy.

4. Rundw_ds_automation with activate task: dw_ds_automation.bat —cp <CP_NAME> —task
Activate.
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Activate New Content

After you package and deploy new Content Packs, you activate the content in the Executive
Scorecard Data Source Management Ul. Content that is created from databases, delimited files, as
well as Excel files can be activated in the customized Data Source Management activation.

Select the Data Source Type according to your specific Content Pack source, as follows:

¢ MSSQL

Oracle
(] MySQL
o Delimited File

Excel File

Tasks

To activate a new Content Pack:

1. In Executive Scorecard, select Admin > Data Source Management.

2. Click the Add data source to open the Data source wizard. The Add Data Source page
opens.

3. Select the CP you created and click Next.
The relevant data source page opens.
4. Enter and select the configuration parameters.
5. Complete the wizard.
The data source instance is activated.

For details on all Executive Scorecard Data Source Management capabilities, see Data Source
Management in the IT Executive Scorecard Administrator Guide.

Ul Description

To access:

In Executive Scorecard, select Admin > Data Source Management. Click Add Data Source
and select the relevant Content Pack you have created.

CP Activation Page Options

Activation parameters are based on the Data Source Type of your Content Pack.
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MSSQL Database Source CP

Ul Element Description

Instance name Enter a name for the data source instance you are activating.
<CP name> Version 1

Time Zone Select the time zone for the data source.

Data Source Type Select MSSQL.

Username Enter your username used for login to the database.
Password Enter your password used for login to the database.
Hostname/IP Address Enter the SQL server database hostname or IP address.
Port Enter the server port number.

Database Name Enter the database name used by the CP.

Initial Load Period Select the number of months from which you want the initial data
(months) loaded.

MySQL Database Source CP

Ul Element Description

Instance name Enter a name for the data source instance you are activating.
<CP name> Version 1

Time Zone Select the time zone for the data source.

Data Source Type Select MySQL.

Username Enter your username used for login to the database.
Password Enter your password used for login to the database.
Hostname/IP Enter the MySQL server hostname or IP address.
Address

Port Port for database connections.

Initial Load Period Select the number of months from which you want the initial data
(months) loaded.

Oracle Database Source CP

Note: The Oracle database can have both Server ID (SID) and Service Name properties, but
the user should specify only one. If you define the SID, then the SID is used, and if you define
Service Name, then Service Name is used. If you define both in the Ul, only SID is used.
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Ul Element
Instance name

<CP name> Version
Time Zone

Data Source Type
Username
Password

Hostname/IP
Address

SID
Service Name

Initial Load Period
(months)

Content Extension Guide for XS IDE Version 9.4
Activate New Content

Description

Enter a name for the data source instance you are activating.
1

Select the time zone for the data source.

Select Oracle.

Enter your username used for login to the database.

Enter your password used for login to the database.

Enter the Oracle server hostname or IP address.

Enter the unique name of the database.
Enter the alias used when connecting.

Select the number of months from which you want the initial data
loaded.

Delimited File Source CP

Ul Element
Instance name

<CP name> Version
Time Zone

Data Source Type
Folder Path
Encoding

Field Delimiter
Row Delimiter

Initial Load Period
(months)

Excel File Source CP

Ul Element

Instance name

<CP name> Version

HP IT Executive Scorecard (9.4)

Description

Enter a name for the data source instance you are activating.
1

Select the time zone for the data source.

Select Delimited File.

Enter the path where the data source file is located.

Enter the text encoding of the file. The default is UTF-8.
Enter the field delimeter for the file, such as','.

Enter the row delimeter for the file, such as '\r\n'.

Select the number of months from which you want the initial data
loaded.

Description
Enter a name for the data source instance you are activating.

1
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Ul Element Description

Time Zone Enter the time zone for the data source.

Data Source Type Select Excel File.

Folder Path Enter the path to excel data source file.

Initial Load Period Select the number of months from which you want the initial data
(months) loaded.
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Upgrade Tool

If you intend to develop content from a previous version, you must perform the upgrade process.
This is done to allow file and content compatibility and simplifies the merging and entity deletion
processes.

To perform an upgrade, select DW Content > * Upgrade.

An additional upgrade must be performed in the following cases:

e When you are using models from before the IDE was upgraded.
Possible issues include:
= ETL Gen, BODS Export failures.
= Validation errors for all designers when using the Validate button.
= Content pack files cannot be viewed in the default editor.
= Content pack name starts with “null”.
= Entity problems.

¢ When you have upgraded models in a non-upgraded IDE version.
Possible issues include:
= ETL Gen, BODS Export failures.
= Validation errors for all designers when using the Validate button.

= InPackage Explorer, entity files cannot be viewed by the default editor or entity files appears
with UUID instead of entity name.

= The Upgrade option does not appear in the DW Content menu.

Note: The following content changes require that you perform an additional upgrade on your
IDE version.

= Reverting to older content such as XS 9.3 and 9.31 (from SVN or HPLN).

= Merge of content from another developer's environment using a previous IDE version.
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Advanced Development

Following the ETL Generator process, you can optionally access the following features and
processes for advanced content development.

"Export from BODS" on the next page

"Data Source Explorer" on page 84

"Generate Entities Automatically" on page 95

"Data Source Extraction Customization" on page 102

"Create an Entity from an Excel File" on page 104
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Export from BODS

The artifacts generated by the ETL contain BODS workflows that are deployed and imported into
the BODS repository. Once the workflows have been changed in BODS, you can then export them
automatically to a directory folder. The BODS export action is based on the selected designer, and
exports the same workflows that were generated by the ETL Gen for that same designer.

Note: BODS Export can be accessed only when IDE and BODS are installed and running on
the same server.

To access:

When a designer is open, the 1| buttonis displayed in the top right toolbar in the IDE workspace. If
it is not displayed, navigate to Window > Customize Perspective and make sure BODS Export
is selected.

To export the workflows from BODS:

1. Click!! to begin the BODS export process. The BODS Export dialog box opens.

£ BODS Export |
%5 ETL Version: 2,31 =]
Conkent Type: ICustu:um Conkent j

¥ Generate Content Pack,

Directary: |C:'I,LIsers'l,.ﬁ.dministratcur'l,Desktu:up

o Cancel

2. Select the XS ETL Version number.

3. Select the Content Type: XS Content or Custom Content. This field designates a path in
BODS for the specific content type you are extending or creating.

4. Select the Generate Content Pack checkbox if you are creating a new Content Pack (not
extending content). This creates a new content pack structure along with the generated ETL
files. This capability is only available when generating the ETL files in the Engineer Stream
Designer.

Note: The Generate Content Pack checkbox is not available when generating the ETL
files from the Architect Target Designer.
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When you generate the ETL files from the Engineer Stream Designer, the Generate
Content Pack checkbox is disabled if there are no source entities in the Designer.

5. Browse to the directory where you want the exported workflows to be saved. Click OK. The
process may take some time.

Note: If you place the workflows in the same folder that the ETL Generator artifacts were
saved, the previous files will be replaced. If you save to a different location, note that you
will need the ETL Generator artifacts (data model and xml files) to add to the exported
workflows, for use in the Data Warehouse.

6. Copy the ETL artifacts and exported workflows to the Content Packs folder in the Data
Warehouse.
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Data Source Explorer

The IDE provides a Data Tool Platform plug-in which enables you to connect to a specific data
source and browse the database. The Data Source Explorer enables connection to the data sources
through the SQL, Oracle and MySQL drivers. You can then browse the database tables, make
queries, and view the data source information.

You can also connect to file based data sources with the Open Data Access (ODA). It enables you
to interface with an external data provider.

For details on the ODA, see the Eclipse DTP tutorials.

For details on FBI extractors for each product, see "File Based Integration (FBI) Extractor" on page
10.

Tasks

To create a new database connection in the Data Source Explorer:

1. Navigate to Window > Show View > Other > Data Management > Data Source Explorer.
The Data Source Explorer tab is displayed.

2. Right-click Database Connections and then right-click New.

3. Select Oracle, SQL Server, or MySQL and click Next.

4. Enterthe Database, Host, Port number, Username and Password.

5. Click Test Connection to check for errors with the connection to the database.
6. Click Finish to enable the connection to the database.

You can change the driver definitions or create another driver.

To modify driver definitions:

1. Navigate to Window > Preferences > Data Management > Connectivity > Driver
Definitions.

2. Select the driver you want to change, or click Add to add an additional driver.
For details on the Data Tool Platform, see the Eclipse DTP tutorials.

To connect to flat file data sources:

The IDE can connect to a flat file which contains data. The supported file types are: csv, ssv and
psv. The flat file may contain:

o Afile where the first row includes the headers and the rest of the file contains the data.

o Afile where the first row includes the headers and the second row contains the data types of
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each header. The rest of the file contains the data.
o Afile where there is only data and does not contain headers or data types.

1. Navigate to Window > Show View > Other > Data Management > Data Source Explorer.
The Data Source Explorer tab is displayed.

2. Navigate to ODA Data Sources > Flat File Data Source, right-click and select New.
3. Enterthe relevant details in the New Flat File Data Source Profile wizard.

For details, see the Eclipse DTP tutorials.

Ul Description

Note: IDE provides out-of-the-box drivers for MSSQL, Oracle, and MySQL.

H% Data Source Explorer B ;

4 = Database Connections
a 54 Mew S0L Server (Microsoft SQL Serverw, 10.0.2531)
» I:j arndb_For ARPPRMEM_Con_Inisyn
a [= 0D Data Sources
== Flat File Data Source
= Wifeb Services Data Source
= XML Data Source

To access:

In the IDE main page, select Window > Show View > Other > Data Management > Data
Source Explorer, right click Database Connections and right-click New.
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rofile

Advanced Development

@ Mew Connection Profile

Connection Profile

Create a S0l Server connec

tion profile.

Connection Profile Types:

type filter text

aDerh}f

E4 Generic JDBC
EdHsqLDE
@Infurmix
%Ingres

£4 MaxDB

Ed Myl
%Oracle
%PDstgreSQL
@SQL SERyer
Ed sLite
aS}fhase ALA
E4 Sybase ASE

m

1

Marre:
Ml SOL Seneer

Description (optianal):

?

% Back

;[T] ._ FmISh m

h

User interface elements are described below:

Ul Element

<Driver List>

HP IT Executive Scorecard (9.4)

Description

Select SQL, Oracle, or MySQL Server.
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Specify a Driver and Connection Details

MSSQL Server
% E o )
E Mew Connection Profile l | (5| S
Specify a Driver and Connection Details R

€3 Enter a user name,

Drvers: IMi-:ru:usu:-f‘t S0L Server 2008 JIDBC Driver V] -{&f A
Froperties
Database: pubs
Host: lacalhost

Port nurmber: 1433

[ Use integrated authentication

Ilser narme;
Pazsword:

[¥] Sawve passward
Connection LIRL: jdbeisglserverifflocalhost1433:databaseMName=pubs -

V] Cannect when the wizard cornpletes Test Conkection

[ Connect every time the workbench is started

A o

ul
Element Description

Database = Enter the specific database name.

Host Enter the host server.
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Ul

Element Description

Port Enter the database port.
number

User Enter the database username.
name

Password Enter the database password.

& New Driver Definition. Click to configure new driver definitions. For details, see
the Eclipse DTP tutorials.

A Edit Driver Definition. Click to edit the current driver definitions. If you receive an
error for the driver, check that the correct path is displayed in the driver files of the
JAR list.
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Oracle Server

@ Mew Connection Profile | =l ug .|'3
Specify a Driver and Connection Details =< >
€3 Enter a user name, i
N
Drivers: ’Oracle 11 Thin Driver v] & A
Properties

General | Optional

ID: dh

J

Hast: SERCEF

Port number: 1521

dser narme;

Pazsword:

Save passuword
Connection LIRL: jdbcioraclethin@sercer1521:db

Catalog:

Connect when the wizard completes | Test Cannection |

Connect every tirme the workbench is started

5 J
ul
Element Description
SID Enter the Server ID, the unique name of the database.
Host Enter the host server.
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Ul

Element Description

Port Enter the database port.
number

User Enter the database username.
name

Password Enter the database password.

& New Driver Definition. Click to configure new driver definitions. For details, see
the Eclipse DTP tutorials.

A Edit Driver Definition. Click to edit the current driver definitions. If you receive an
error for the driver, check that the correct path is displayed in the driver files of the
JAR list.
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MySQL Server

i@ New Connection Profile = 2 |

Specify a Driver and Connection Details R

Select a driver from the drop-down and provide login details for the
connection, . :

Drivers: | MySQL JDBC Driver | & A

Froperties

General ! Optional

Database:  database

LRL: jdbeirmysgl/flocalhost 3306/ database
User marne:  root

Passward:

Sawve pasanord

[V Cannect when the wizard cormpletes Test Connection

[C] Cannect every tirne the watkbench is started

@:‘ < Back ” Mext = ] [ Finish ] [ Cancel

User interface elements are described below:

ul
Element Description

Database = Enter the specific database name.

URL Enter the database URL.
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Ul

Element Description

User Enter the database username.
name

Password Enter the database password.

& New Driver Definition. Click to configure new driver definitions. For details, see
the Eclipse DTP tutorials.

Fay Edit Driver Definition. Click to edit the current driver definitions. If you receive an
error for the driver, check that the correct path is displayed in the driver files of the
JAR list.

Flat File Data Source Profile
To access:

In the IDE main page, select Window > Show View > Other > Data Management > Data
Source Explorer, right click Flat File data Source and right-click New.

Create Connection Profile

Eij Mew Flat File Data Source Profilegt Sl S I_EI_ S|

Create Connection Profile — I
Enter the profile information.

Marne: i

Description (optionaly:

i
@ < Back et » Finish

.= .

User interface elements are described below:
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Ul Element Description
Name Enter any name for the flat file.
Description (optional) Enter a description of the data source. This field is optional.

Define File URI

E.] New Flat File Data Source Profilegs SRS S s _A'

Define Folder or a File URI —
Select a folder that contains the flat files or enter an URI for the flat file,

(71 Select horne folder: Browese..,
@ Enter file URT
Select charset: ’LITF-E

Select flatfile style: G5

[¥] Use first line as column name indicator,
[[1Use second line a3 data type indicatar,

[ Use trailing null colurmns.

)
)
Test Connection

@:‘ Mlest = Finizh Cancel

Ul Element Description

Select home folder = This option is not supported
Enter file URI Browse to the relevant flat file.
Select charset Select the relevant character set.

Select flatfile style = Select the flat file type: CSV, PSV, SSV. The IDE does not support the

Asv style.
Use first line as Select when using a flat file that has headers and data (no data types).
column name Select when using a flat file that contains both headers and data types.

indicator.
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Ul Element Description

Use second line as = Select when using a flat file that contains both headers and data types.
data type indicator.

Use trailing null Not relevant to the IDE.
columns.
Test Connection Click to check the connection to your flat file.

Note: When activating a flat file as a source, remove the data types row from the file.

For details, see the Eclipse DTP tutorials.
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Generate Entities Automatically

You can generate entities from the source database tables or views, as well as flat files based on
.csv format. This enables you to automatically create Source, Integration or Target entities. Using
the Data Source Explorer, you can connect to the source database and navigate to the source table
or view. The entities are created based on the specific source metadata. MSSQL, Oracle, and
MySQL source databases are supported. You can then load the entity to a new designer located in
an existing project. The entity is then displayed in the new Engineer Stream Designer.

Note:
e The following file formats are supported: .csv, .psv, and .ssv.
e The following file models are supported:

= Column name in first row.

= Column name in first row and data type in second row. Flat files can only be extracted
using this model.

= No column name or data type.

Tasks

To automatically generate entities from database tables or views:

Note: You can generate Source, Integration or Target entities using the Entity Generator
wizard.

1. Navigate to Window > Show View > Other > Data Management > Data Source Explorer.
The Data Source Explorer tab is displayed.

2. Select either an SQL, Oracle, or MySQL Database and connect to the database.

3. Navigate to Tables or Views and right-click the relevant table or view from which you want to
generate the entity and select Generate DWH Entity.

4. Inthe Scenario page, select the entity type content pack, either Source, Integration or Target.

5. For Source or Integration, select the relevant content pack. When you select the Source CP
the Integration CP is automatically displayed.

For Target, select whether the entity is defined as a Fact or Dimension.
6. Click Next.

7. Inthe Load to Designer page, select to either load the entity to a New Designer, or No
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Designer .

8. If you selected New Designer, select from the drop down list, the project where you want the
specific Designer to be located.

9. Click Finish to complete the wizard and create the entity. The new entity is now displayed in
the IDE Package Explorer, and if relevant, loaded in the assigned designer canvas.

To automatically generate entities from flat files:

1. Navigate to Window > Show View > Other > Data Management > Data Source Explorer.
The Data Source Explorer tab is displayed.

2. Navigate to ODA Data Sources > Flat File Data Source and right-click the file from which
you want to generate the entity and select Generate DWH Entity.

3. Inthe Scenario page, select the entity type content pack, either Source, Integration or Target.

4. For Source or Integration, select the relevant content pack. When you select the Source CP
the Integration CP is automatically displayed.

For Target, select whether the entity is defined as a Fact or Dimension.
5. Click Next.

6. Inthe Load to Designer page, select to either load the entity to a New Designer, or No
Designer.

7. If you selected New Designer, select from the drop down list the project where you want the
specific designer to be located.

8. Click Finish to complete the wizard and create the entity. The new entity is now displayed in
the IDE Package Explorer, and if relevant, loaded in the assigned designer canvas.

Ul Description

Entity Generator Wizard
For tables and views:
To access: In the relevant Data Source Explorer database, expand Tables or Views and right-

click an entity to select Generate DWH Entity.

Note: When you generate an entity from an Oracle database, make sure that if you use
reserved words, they are placed in quotation marks, for example, "NUMBER".
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HE Data Source Explorer &3

- BS db_securityadmin
- BR dho
a @_@ it
. [0 Dependencies
. [ Stored Procedures
4 || Tahles
- B AMCOST_FACT
- B ACTUALCOST FACT
- B ALLOCATION_METRIC

. B ALLOCATION_METRIC_REQUIRED _DIMS

. ] APCOST FACT
|| APPLICATION D

Advanced Development

- ] ASSET FACT Data .
B2 BACKUP_POL %0 Generate DOL...

- B BACKUP_SESE °

. FT BUDGET DI Fefresh Fa

. ] BUDGETLIME Generate DWWH Entity

For flat files:

To access: In ODA Data Sources select Flat File Data Source and right-click the file from

which you want to generate the entity and select Create DWH Entity.

Caonnect
Disconnect

Ping...

Rename
Delete

= Duplicate

Eﬂ Diata Source Explorer &3 El Prapi Refresh
4 [= Database Connections Generate DWYH Entity
i Mew SQL Server (Microsoft S¢
4 = ODA Data Sources
4 [= Flat File Data Source Properties

Open 5L Scrapbook

F2
Delete

F5

Alt+Enter

@ testl I:DTF' QDA Flat File Dara-somaree-rrowmere EREn iy

= Yifeh Services Data Source
= XML Data Source

Scenario page
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ﬂ Entity Generator EI EE

Scenario

Zelect required entity generator scenario

I0: JOB_STREAM_STEP_DT

[¥] Source Cortent Pack ALT 1.0 aracle X

Integration Content Pack | ALT

[¥] Target i@ Dimensian ) Fact

< Back Mext = ] [ Finizh ] [ Cancel

Note: If you select to generate Integration and Target entities, SSI Column Mapping is
automatically performed and displayed in the relevant designer .

Ul Element Description

ID Enter entity name. The current table or view name is the default.
Source Select the checkbox and the Source content pack for the specific entity. This
Content generates a Source entity and automatically selects the relevant Integration
Pack content pack.

Notes:

o If there is only one Source content pack in the workspace it is entered
automatically and cannot be changed.

o This checkbox is disabled if there is no Source content pack in the workspace.
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Integration = Select the checkbox and the Integration content pack for the specific entity. The

Content Integration content pack is automatically populated when the Source CP is
Pack selected.
Notes:

o If there is only one Integration content pack in the workspace it is entered

automatically and cannot be changed.

o If only Integration Content Pack is selected, the Next button is disabled, and

the entity cannot be loaded to a designer.

o This checkbox is disabled if there is no Integration content pack in the
workspace.

Target Select the checkbox and whether the Target entity is defined as a Dimension or

Fact. The entity is placed in the core-cp.

If only Target is selected, the entity is loaded to the Architect Target Designer.

Load to Designer page

kT

i@ Entity Generator ; |‘._k‘:1§|___§:§_ |
Load to Designer
Selectuwhether to load the entities to designer
70 Mo Designer
@ Mew Designer Cp-arm T
o
Mext - Finish ] ’ Cancel
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ul

Element Description

No Select the checkbox and the generated entity is not displayed in a designer canvas.
Designer

New Select the checkbox for the generated entity to be displayed in a designer canvas.

Designer Select an existing project from the drop down list where the designer will be located.

Note: If a Target entity was generated then the entity is loaded into an Architect
Target Designer only. For Source and Integration entities, they are loaded into an
Engineer Stream Designer.

Complete Entity Generation with SSI mapping displayed in Stream Designer:

[+] COMPETENCY_DIM engineercontext_diagram 3

(3 AM.5.2.mssql.COMPETENCY_DIM 5] AM - COMPETENCY_DIM Transformation

nns ted Dimensions

B2 MD_BATCH ID I

aTbRY
HOPPESTATUSIND /2
B_zREATEDDATE
P pELETEDDATE
g plfkBLE KEY
P JASAODDATE
FARISENDDATE

elelele|sle

N

E COMPETENCY_DIM
Calumns

B9 MD_BATCH ID &
B MD_PROCESS ID &
B2 COMPETENCY_CATEGORY
B COMPETENCY_NAME

B COMPETENCY_NAME_ALT
B3 MANDATORY

B MD_ACTIVESTATUSIND 4,
B2 MD_CREATEDDATE
B MD_DELETEDDATE
B MD_DURRELE_KEY
B MD_LASTMODDATE
E MD_TRAMSENDDATE
B MD_TRANSLASTIND
B PK_COMPETENCY ID
B PURPOSE

B RATING _TYPE

EjCOMPErENC)’_/
& MD_EATCH_ID)(
4 MD_PROCESS &
& (OMPETEN[

& COMPETEMCY_pAhdt
& COMPETEMCY_pA} AT
4 MENDATORY

4 MD_ACTIVESTATLIGHID/ /2
4 MD_CREATEDDATI
4 MD_DELETEDDA

4 MD_DURABLE XE'

BleE e e

4 MD_LASTMODEATE
& MD_TRANSENDDATE /2
4 MD_TRANSLASTIN
4 PK_COMPETENEY,

< PURPOSE

‘

IDE Data Types

The follows shows Database Data Types and the conventions used for them in the IDE entity

columns.
Database Data Type IDE Data Type
BIGINT Int32
INTEGER(INT), SMALLINT, NUMERIC, NUMBER Int16
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Database Data Type IDE Data Type
FLOAT, DOUBLE_PRECISION Float

CHARACTER, NVARCHAR, VARCHAR, VARCHAR(2), VarChar (size)
CHARACTER_VARYING, CHARACTER_VARYING

CHARACTER_LARGE_OBJECT, CLOB, TEXT VarChar (4000)

DATE, TIMESTAMP, TIME, DATETIME, Integration: Date Time
Target: Localized Date Time

RAW16 No IDE Data Type. User must
select a data type or delete the
column.

IMAGE No IDE Data Type. User must
select a data type or delete the
column.

BLOB No IDE Data Type. User must
select a data type or delete the
column.
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Data Source Extraction Customization

Integration with data sources is performed using File Based Integration (FBI). In order to generate
the query executed for the data source, the ETL indicates to the FBI module which source entity to
extract. The FBI then extracts the correlating metadata definitions, and uses them in order to
formulate a query.

To customize the Source Model:

You can customize the generated query by modifying the source entity xml file. This updates the
source metadata in the Data Warehouse and matches it to the customized source.

1. Modify the xml and load it into the Data Warehouse metadata repository, use dw_import_
defs.bat.

2. Change the SQL query from the FBI log and run the query on the source database make sure
the query is correct and can run without errors.

3. Identify all of the changes.

There are various types of customizations to the source models supported by the DWH. This
document emphasizes cases where the data source that you extract information from is based on
RDBMS, and entities which are already modeled in the DWH have had field names or table names
changed in the data source’s structure.

The Data Source’s source model metadata xml files are located under:
<InstallationDirectory>\agora\ContentPacks\<CPname>\dataModel\datalntegration\source\

<CPName>\<product_version>\<DB_type>\<entity name>.xml

For example:
C:\HPXS\agora\ContentPacks\SM\dataModel\datalntegration\source\SM\9.2\oracle\SM_
INCIDENTSM1_SRC.xml

To make changes in a field name:

o Open the entity xml source model file and update the source field names inthe
datasourcecolumnname property in the ColumnMapping tag:

Example:
<ns1:ColumnMapping extractioncolumnidentifier="<identifier>" notapplicable="N" >

<ns1:DataSourceMapping datasourcetablenameoraliasname=" <name>"
datasourcecolumnname=" source field name" datasourcecolumntype="XXXXX"/>

</ns1:ColumnMapping>
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To make changes in a table name:

1. Open the entity xml source model file and update the DataSourceJoin and DataSourceWhere
tags with the changes.

Examples:
<ns1:DataSourceJoin>table name</ns1:DataSourceJoin>
<ns1:DataSourceWhere>field name=1</ns1:DataSource\Where>

<ns1:DataSourceJoin>table1 A LEFT JOIN table2 B ON A.AAAAA =
B.BBBBB</ns1:DataSourceJoin>

<ns1:DataSourceWhere>A.AAAAAAAA IS NOT NULL</ns1:DataSource\Where>

2. Change the datasourcetablenameoraliasname property in the ColumnMapping tag to the new
value.

Example:
<ns1:ColumnMapping extractioncolumnidentifier="XXXX" notapplicable="N" >

<ns1:DataSourceMapping datasourcetablenameoraliasname=" A" datasourcecolumnname="
XXXX" datasourcecolumntype="XXXXX"/>

</ns1:ColumnMapping>

To update the data warehouse metadata:

1. Runthe command on the source model xml update file: C:\<Installation
Directory>\agora\DataWarehouse\bin>\dw_importdefs.bat —topdir <SOURCE MODEL XML
FILE DIR>

2. Start the ETL again using the DW ABC Streams Management Ul. For details, see DW ABC
Streams Management User Interface in the IT Executive Scorecard Administrator Guide.
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Create an Entity from an Excel File

You can generate an entity from an Excel file using the IDE Engineer Stream Designer. In the
source entity Properties, you must specify the Table Name/Join Condition field as the Excel file
and the Where field as the Excel worksheet. After you generate your content, make sure to activate
the new Content Pack in the Data Source Management Ul as an Excel file in the Data Source
Type field. For details see "Activate New Content " on page 76

Tasks

To generate an entity from an Excel file:

1.

10.

Define a new Content Pack project. For details see "Define New Content Pack Project” on
page 29.

Define the Architect Target Designer project and create the Target entity. For details see
"Architect Target Designer Tasks" on page 35.

Define the Engineer Stream Designer project. For details see "Engineer Stream Designer
Tasks" on page 47.

Proceed with the Engineer Stream Designer tasks by loading the relevant entities.

Select New Source Entity in the Source section and click on the canvas. A Source entity is
displayed.

Click Source to Integration Relation and drag the display arrow from the Source entity to an
Integration entity. All columns from the Integration entity are copied to the Source entity with
default values.

Click on the Source entity.

In the Properties tab of the Source entity, enter the excel file name in the Table Name/Join
Condition field, for example ALT_ACTUALCOST .xls

In the Properties tab of the Source entity, enter the excel worksheet name in the Where field,
for example DATA.

Add columns and perform mapping as necessary. The column names have to match the actual
excel file columns.
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Ul Description
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Properties tab for Source

To view the Properties tab, right-click on the specific entity and click Show Properties View.

ul
Element Description

General General attributes:

tab
e ID. The entity ID.
¢ Content Pack. The Source Content Pack information.
Data Source SQL Clauses:

o Group by. This field is not applicable.

o Table Name/Join Condition. Enter the Excel file name including the extension.
It can have the .xls, or .xIsx extension.

o Where. Enter the specific excel worksheet name.
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ul
Element Description

Columns Displays column information. The Source entity receives all of the Integration entity
tab properties.

e ID. The ID of the column. It is taken fro the mapped integration column and is
read-only.

o Type. Select Fixed, Direct, or Rule. If you select Fixed, you must enter a Fixed
Value. if you select Rule, you must enter the Calculation Rule.

e Not Applicable.

o Table Name. Based on table name entered in the General tab. Relevant only if
Direct type is selected.

e Column Name. The field name. Must be what appears in the excel file columns.

o Fixed Value. The fixed value of the column. Relevant only if Fixed type is
selected.

o Calculation Rule. The calculation rule of the column. Relevant only if Rule type

is selected. The IDE does not support non UTF-8 characters in the Calculation
Rule field.
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Following the IDE content development and extension process, you have created additional
Content Packs for use in the Data Warehouse. This provides data to Executive Scorecard. Using
the tools of Executive Scorecard, you can customize and modify your data, in order to access and
display it according to specific formulas and parameters. The process includes:

o Create a custom FBI Extractor: Enables you to develop and modify an extractor for use with
new content. For details, see the FBI Extractor SDK Guide.

« Manage the Data Sources: Enables you to manage the integration of extended or new data into
the data warehouse through the activation of data sources.

To access: In Executive Scorecard, select Admin > Data Source Management. For details,
see Data Source Management in the IT Executive Scorecard Administrator Guide.

« Manage the ETL: Enables you to perform the essential tasks related to ETL and stream
functionality. It displays the state of active streams, and enables you to schedule and control
stream activity. It also allows you to view the historical data and the archived stream definitions.
All ETL management and functionality is accessed and performed through this Ul.

To access: In Executive Scorecard select Admin > ETL Management. For details, see ETL
Management inthe IT Executive Scorecard Administrator Guide.

o Create your Context in the Context Designer: Enables you to create and manage Contexts
(universes). The universes can be based on your target schema tables oron .CSV files that can
be uploaded to the target schema using the Context Designer.

To access: In Executive Scorecard, select Admin >Semantic Layer > Semantic Layer. The
Context Management page opens. For details, see Semantic Layer - Context Designer

¢ Create KPIs in the Studio: Enables you to create and manage all of the displayed KPI
elements (based on your content), as well as their interactions with each other: wiring, drill
downs, and other features.

To access: In Executive Scorecard, select Studio. For details, see Create the Executive
Dashboard Contents in the Studio in the IT Executive Scorecard Business Analyst Guide.

« Create Executive Pages in the XS Dashboard: Enables you to set up pages that include
components that are of interest to specific users or groups of users. For each page, the
administrator defines the layout of components on the page, and the interaction of the page
components with one another.

To access: In Executive Scorecard, select Studio. For details, see Dashboard Display inthe IT
Executive Scorecard Business Analyst Guide.

« Create CAPs: Enables you to create Content Acceleration Packs that include Scorecards,

KPls, Dashboard pages that display the Scorecards and KPI components, Contexts
(universes), and .CSV files.
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To access: In Executive Scorecard, select Admin > Context Management
> CAP Management. For details, see Create Content Acceleration Packs in the IT Executive
Scorecard Administrator Guide.
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We appreciate your feedback!

If you have comments about this document, you can contact the documentation team by email. If
an email client is configured on this system, click the link above and an email window opens with
the following information in the subject line:

Feedback on IT Executive Scorecard, 9.4 Content Extension Guide for XS IDE Version 9.4

Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a web mail client,
and send your feedback to SW-Doc@hp.com.
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