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About the Add-ins Guide
This HP Unified Functional Testing Add-ins Guide explains how to set up support for, and work
with, the UFT add-ins and standardWindows testing support, enabling you to test any supported
environment using GUI tests and business components. This guide begins with an introductory
section that describes working with GUI testing add-ins, and specific aspects of working with
Windows-based andWeb-based add-ins. After this overview section, the add-ins are presented
alphabetically.

The information, examples, and screen captures in this guide often focus specifically on working
with GUI tests. However, much of the information applies equally to keyword components and
scripted components. Information that is unique to using a specific add-in with BPT is indicated as
such.

Note: Keyword components and scripted components are part of HP BPT, which utilizes a
keyword-drivenmethodology for testing applications. For more information, see the section on
working with BPT in theHP Unified Functional Testing User Guide.

For users that work with UFT add-in extensibility, UFT also provides developer guides that describe
how to extend UFT support for third-party and custom controls for supported environments, such as
Delphi, Java, .NET, orWeb. For more information, see the relevant Add-in Extensibility Guide,
available from the UFT Extensibility Documentation program group (Start > All Programs > HP
Software > HP Unified Functional Testing > Extensibility > Documentation).

Note: For details on accessing UFT and UFT tools and files inWindows 8, see "Accessing
UFT inWindows 8Operating Systems" on page 547.

Prerequisite Background
This guide is intended for UFT users at all levels. You should already have some understanding of
functional testing concepts and processes, and know which aspects of their application you want to
test.

In addition, because each UFT add-in takes advantage of commonly used UFT features such as
the object repository, Keyword View, and checkpoints and output value steps, you should also
have at least a basic understanding of these concepts before you begin working with a UFT add-in.

This guide assumes that you are familiar with UFT features and options. It describes the
functionality that is added or changed in UFT when you work with specific GUI testing add-ins, as
well as other add-in-specific considerations and best practices.

This guide should be used in conjunction with theHP Unified Functional Testing User Guide and
theHP UFT Object Model Reference for GUI Testing.

UFT Guides and References
The following tables provide a list of the UFT guides, online help and references:
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Note: To check for recent updates of any of the guides below, visit the HP Software Product
Manuals Web site (http://h20230.www2.hp.com/selfsolve/manuals).

Getting started

Reference Description

What's
New?

Describes the newest features in the latest version of Unified Functional Testing.

You can also access theWhat’s New from theUnified Functional Testing Help
menu.

Product
Movies

Click the link or select Help > Product Feature Movies to view short movies that
demonstrate themain product features.

Readme Provides last-minute news and information about Unified Functional Testing.

For the latest readme file, go to the HP SoftwareManuals Web site (requires an
HP Passport) at http://support.openview.hp.com/selfsolve/manuals.

UFT PAM The Product Availability Matrix (PAM) provides current information about
technologies and integrations supported for this version of UFT.

GUI Testing
Tutorial

TheGUI Testing Tutorial is a self-paced printable guide, designed to lead you
through the process of creating GUI tests and familiarize you with the testing
environment. 

API Testing
Tutorial

The API Testing Tutorial is a self-paced printable guide, designed to lead you
through the process of creating API tests in theWindows environment. 

PDF guides

Guide Description

UFT User
Guide

The HP Unified Functional Testing User Guide describes how
to use UFT to test your applications. It provides step-by-step
instructions to help you create, debug, and run tests, and
report defects detected during the testing process.

Run Results
Viewer

The HP RunResults Viewer User Guide explains how to use
the Run Results Viewer to interpret and use the test results
from your GUI or API tests.

UFT
Installation
Guide

The HP Unified Functional Testing Installation Guide
provides a complete, step-by-step instructions on how to
install and set up UFT on a standalone computer.

UFT
QuickStart

The UFT Installation QuickStart Sheet explains the steps to
perform a basic installation of UFT.

Add-ins Guide
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Guide Description

License Server
Installation
Guide

The Concurrent License Server Installation Guide provides
the information you need to install andmaintain the
HP Functional Testing Concurrent License Server.

UFT Add-ins
Guide

The HP Unified Functional Testing Add-ins Guide explains
how to set up support for UFT add-ins and standardWindows
testing support. Add-ins enable you to test any supported
environment using GUI tests and business components.

References

Links to the references are available from the UFT online help home page.

Reference Description

Object Model
Reference

TheObject Model Reference for GUI Testing includes a description, a list of
methods and properties, syntax, examples, and identification properties for
each UFT test object.

VBScript
Reference

Microsoft's Visual Basic Scripting documentation that describes objects,
methods, properties, functions, and other elements that can be used when
writing VBScript scripts.

Automation
Object Model
Reference

List the objects, methods, and properties that enable you to control UFT from
within another application.

Object
Repository
Automation
Reference

Describes the objects that enable you tomanipulate UFT shared object
repositories and their contents from outside of UFT.

Run Results
Schema
Reference

Provides details about the structure of the Run Results XML schema, and
describes the elements and attributes used in the its XML reports.

Test Object
Schema
Reference

A reference describing the elements and attributes available for creating test
object configuration XML content, for use when creating UFT extensibility
projects.

Object
Repository
Schema
Reference

Describes the elements and complex types defined for the object repository
schema.
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Additional Online Resources
The following additional online resources are available from the Unified Functional Testing Help
menu:

Resource Description

HP Software
Support Online

Opens the HP Software Support Web site. This site enables you to browse
the HP Software Self-solve knowledge base. You can also post to and
search user discussion forums, submit support requests, download patches
and updated documentation, andmore. ChooseHelp > HP Software
Support. The URL for this Web site www.hp.com/go/hpsoftwaresupport.

l Most of the support areas require that you register as an HP Passport
user and sign in. Many also require a support contract.

l To findmore information about access levels, go to:
http://h20230.www2.hp.com/new_access_levels.jsp

l To register for an HP Passport user ID, go to:
http://h20229.www2.hp.com/passport-registration.html

Testing Forums Opens the testing forums for GUI Testing, API Testing, and BPT Testing
forums. where you can interact with other users of UFT and discuss topics
related to GUI Testing, API Testing, and BPT.

The URLs for these sites are:

l GUI Testing: http://h30499.www3.hp.com/t5/Unified-Functional-
Testing/bd-p/sws-Fun_TEST_SF

l API Testing: http://h30499.www3.hp.com/t5/Service-Test-Support-and-
News/bd-p/sws-Serv_TEST_SF

l BPT: http://h30499.www3.hp.com/t5/Business-Process-Validation/bd-
p/sws-BPT_SF

UFT Product
Page

Opens the HP Unified Functional Testing product page, with information and
related links about UFT.

Troubleshooting
& Knowledge
Base

Opens the Troubleshooting page on the HP Software Support Web site
where you can search the HP Software Self-solve knowledge base. Choose
Help > Knowledge Base orHelp > Troubleshooting. The URL for the
troubleshootingWeb site is
http://h20230.www2.hp.com/troubleshooting.jsp.

HP Software
Community

Opens the HP IT Experts Community site, where you can interact with other
HP software users, read articles and blogs on HP software and access
downloads of other software products.
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Resource Description

HP Manuals Site Opens the HP Software Product Manuals Web site, where you can search
for themost up-to-date documentation for a selected HP Software product.
The URL for this Web site is
http://support.openview.hp.com/selfsolve/manuals (requires an HP
Passport).

What's New Opens the UFTWhat's New Help, describing the new features and
enhancements in this version of UFT.

Product Movies Opens a page on HPLN (HP Live Networks) displaying a list of all product
movies.

HP Software
Web site

Opens the HP SoftwareWeb site. This site provides you with themost up-
to-date information on HP Software products. This includes new software
releases, seminars and trade shows, customer support, andmore. The URL
for this Web site is www.hp.com/go/software.

You can access the following sample applications from theStartmenu. These applications are the
basis for many examples in this guide:

l Mercury Tours sampleWeb site. The URL for this Web site is http://newtours.demoaut.com.

l Mercury Flight application. To access from the Start menu, select All Programs > HP
Software > HP Unified Functional Testing > Sample Applications > Flight API / Flight
GUI.

Add-ins Guide
About the Add-ins Guide

HP Unified Functional Testing (12.00) Page 21 of 549

http://support.openview.hp.com/selfsolve/manuals
http://www.hp.com/go/software
http://newtours.demoaut.com./


Page 22 of 549HP Unified Functional Testing (12.00)

Add-ins Guide
About the Add-ins Guide



HP Unified Functional Testing (12.00) Page 23 of 549

Part 1: Working with UFT Add-ins



Chapter 1: UFT Add-ins Overview
This chapter includes:

Concepts 25

UFT Add-in Support - Overview 25

Record and Run Settings for Add-ins - Overview 28

UFT Add-in Extensibility 31

Tasks 32

How toManage UFT Add-ins 32

How to Define Record and Run Settings for UFT Add-ins 33

Reference 35

Add-in Manager Dialog Box 35

HP Unified Functional Testing (12.00) Page 24 of 549



Concepts

UFT Add-in Support - Overview
UFT add-ins help you to create and run tests and business components on applications in a variety
of development environments. After you load an add-in, you can record and run tests or business
components on applications in the corresponding development environment, similar to the way you
do with any other application. When you work with UFT add-ins, you can use special methods,
properties, and various special options to create the best possible test or business component for
your application.

You can install UFT add-ins when you install UFT, or you can install the add-ins at a later time by
running the installation again inModifymode. For details about installing and loading add-ins, see
"How toManage UFT Add-ins" on page 32.

When UFT opens, you can choose which of the installed add-ins you want to load using the Unified
Functional Testing "Add-in Manager Dialog Box" (described on page 35), but to maximize
performance, you should load only the add-ins you need for that testing session.

UFT includes built-in support for testing standardWindows applications. StandardWindows testing
support is automatically loaded when UFT opens.

Your UFT license enables all UFT features, including the use of all UFT add-ins. You can use the
latest released version of all add-ins with UFT. If you upgrade from a version earlier than 9.5, only
licensed add-ins are available. Additional non-licensed add-ins that you install are disabled in the
"Add-in Manager Dialog Box". For details on installing add-ins and licenses, see theHP Unified
Functional Testing Installation Guide. For details, see "Add-in Licenses" on page 27.

Using Add-ins in Your Test or Component

l You can use the Keyword View, the StepGenerator, and the Editor to activate environment-
specific test object and native (run-time object) operations, retrieve and set the values of
properties, and check that objects exist.

l You can enhance your tests and business components using environment-specific checkpoints
and output values. See the sections describing checkpoints and output values in theHP Unified
Functional Testing User Guide.

l You can customize the Active Screen capture settings for some of the UFT add-ins. When you
apply custom Active Screen settings, you override your previous capture-level settings with all
of the settings in the Custom Active Screen Capture Settings dialog box. If you want to
customize only specific settings, use theReset to option to ensure that all other settings are
using the capture-level setting you prefer and thenmodify the specific settings you need. For
details, see the section describing Active Screen capture setting options in theHP Unified
Functional Testing User Guide.
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Available Add-ins Environments

l Several UFT Add-ins are designed to support special objects that are generally available inWeb
applications, such as standardWeb (HTML), Siebel, .NETWeb Forms, andWeb-based SAP
objects. These add-ins are known as Web-based Add-ins. The interface options, capabilities,
and other functionality that is available for theWeb-based add-ins are often identical or similar.
TheseWeb-specific features are described in "Web-Based Application Support" on page 39

l UFT provides a set of add-ins designed to support special objects that are generally part of
Windows applications, such as .NETWindows Forms, Windows Presentation Foundation,
PowerBuilder, SAP GUI forWindows, VisualAge Smalltalk, Stingray, and others. These add-ins
are known as Windows-based Add-ins. The interface options, capabilities, and other
functionality that is available for theWindows-based add-ins are often identical or similar. These
Windows-specific features are described in "Windows-Based Application Support" on page 94

This section also includes:

Loading UFT Add-ins 26

Add-in Licenses 27

Considerations forWorking with UFT Add-ins 27

Loading UFT Add-ins

To test applications developed in various environments, youmust ensure that the relevant UFT
add-in is installed and loaded on the computer on which you create and run your tests and business
components. Loading the relevant add-in enables UFT to work with the corresponding environment.

When you start UFT, the "Add-in Manager Dialog Box" (described on page 35) opens. It displays a
list of all installed add-ins and the license used for each add-in. If you are using a seat add-in
license, it also displays the time remaining for time-limited licenses.

If you have UFT add-ins installed, you can specify which add-ins to load at the beginning of each
UFT session. You can also load UFT without add-in support if you want to test only standard
Windows-based objects.

While UFT is open, you can check whether a specific add-in is installed by choosingHelp > About
Unified Functional Testing. Loaded add-ins are indicated by a check mark in the add-ins list.

Tip: TheWeb Services Add-in is supported for backwards compatibility only and is not
enabled by default. New tests and components can use UFT's API testing solution for web
service testing purposes. To enable theWeb Services Add-in for previously created tests,
contact HP Software support.

When you load an add-in, UFT recognizes the objects you work with on the corresponding
environment. In many cases, loading the add-in also adds new user interface options and
capabilities to UFT, as well as adding support for the add-in's object model—the set of test
objects, methods, and properties specially designed for working with the objects in your
development environment. Details of these objects, methods, and properties can be found in the
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relevant section of theHP UFT Object Model Reference for GUI Testing (Select Help >
HP Unified Functional Testing Help).

Add-in Licenses

When you open UFT, if an add-in license has not yet been installed for a specific add-in, the add-in
is displayed as Not Licensed in the License column of the "Add-in Manager Dialog Box"
(described on page 35). An add-in may also be displayed as Not Licensed if no concurrent license
server within your subnet has a registered license for the specific add-in, or if all concurrent licenses
are in use (and are, therefore, unavailable). In this case, you can use the LSFORCEHOST or
LSHOST variable to connect to a concurrent license server outside of the subnet that has the
relevant add-in license installed on it, if one is available. For details on connecting to concurrent
license servers, see theHP Unified Functional Testing Installation Guide.

You can also view license details for all currently loaded licensed add-ins in the About Unified
Functional TestingDialog Box (Help > About Unified Functional Testing).

l For seat licenses, the category for each license is displayed. The license category may be
Demo, Permanent, Commuter, or Time-Limited. ForDemo, Commuter (used with
concurrent licenses), and Time-LimitedUFT seat licenses, the number of days and hours
remaining until the license expires is also displayed.

l For concurrent licenses, the URL or host name of the concurrent license server used for each
license is displayed.

l To switch between a seat and a concurrent license, click Modify License. Note that you can
use only one license type per session for UFT and all loaded add-ins—either seat or concurrent.
For more information on license types, installing licenses, andmodifying licenses, see the
HP Unified Functional Testing Installation Guide.

Considerations for Working with UFT Add-ins

Consider the following when loading and using UFT add-ins:

Installing and Loading Add-ins

l Youmust install and load an add-in to enable UFT to recognize objects from the corresponding
environment. To load an add-in, select the add-in from the "Add-in Manager Dialog Box"
(described on page 35) that opens when you start UFT.

l For optimal performance when testing your applications, it is strongly recommended that you
load only the required add-in or add-ins. For example, if you want to test a process that spans a
Web application and a .NET application, load only theWeb and .NET Add-ins. Do not load all
add-ins unless you need to work with all of them. As a reminder, the tip at the bottom of the Add-
in Manager changes to red text if more than three add-ins are selected.

l SomeUFT add-ins require additional configuration after the installation is complete. Similarly,
some environments may require configuration to enable UFT to interact with them. Configuration
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requirements, if any, are described in the introductory section of each relevant environment.

l Some applications must be opened prior to opening UFT, while somemust be opened after UFT
is opened. These requirements are described in the introductory section for each relevant
environment.

l When testing applications that do not contain .NET objects, it is strongly recommended that you
do not load the .NET Add-in.

l When you open a test or business component, UFT compares the add-ins that are currently
loaded with the add-ins associated with your test or with your business component's application
area. If they do not match, UFT issues a warningmessage. For details onmatching loaded add-
ins with installed add-ins, see "Match loaded add-ins with associated add-ins" on page 32.

Running UFT from ALM with Add-ins

l When you run a UFT test from ALM, ALM instructs UFT to load the add-ins that are associated
with the test.

If you created the test in ALM (and not in UFT), the test contains the settings specified in the
template test you chose when creating the test. If you need tomodify the associated add-ins,
you can do so by opening the test in UFT. For details, see the section on template tests in the
HP Unified Functional Testing User Guide.

l Before you run a UFT test from ALM, make sure that the required UFT add-ins are installed on
the computer on which you want to run the UFT test.

Record and Run Settings for Add-ins - Overview
Before you record or run a test on an application, you can use the Record and Run Settings Dialog
Box to instruct UFT which applications to open when you begin to record or run your test.

For someWindows-based applications, you also use the dialog box to specify the specific
applications you want UFT to recognize during record, run, andObject Spy sessions. For example,
you can choose to have UFT open a specific application when you start a record or run session.

You can set your record and run options in the Record and Run Settings dialog box, or you can set
the options using environment variables.

The Record and Run Settings dialog box opens automatically each time you begin recording a new
test and saves your settings with that test. Subsequently, when you perform additional record or run
sessions on existing tests, the Record and Run Settings dialog box does not open. This is because
UFT automatically applies the saved record and run settings.

You canmodify the record or run settings prior to any session using the Record and Run Settings
dialog box (Record > Record and Run Settings).

The Record and Run Settings dialog box always contains theWindows Applications tab. It may
contain other tabs corresponding to add-ins that are loaded. For details on which tab of the Record
and Run Settings dialog box you should use with an add-in, see the relevant add-in chapter.

Add-ins Guide
Chapter 1: UFT Add-ins Overview

HP Unified Functional Testing (12.00) Page 28 of 549



For details on defining record and run settings, see the relevant add-in environment section, for
example, "Windows Applications Tab (Record and Run Settings Dialog Box)" on page 109 if you
are testing a standardWindows-based application.

This section also includes:

Considerations for Defining Record and Run Settings 29

Environment Variables in Record and Run Settings 30

Considerations for Defining Record and Run Settings

l The setting of the Active Screen capture level (Tools > Options > GUI Testing tab > Active
Screen pane) can significantly affect the recording time for your test and the functionality of the
Active Screen while editing your test. Confirm that the level selected answers your testing
needs. For details, see the section on setting active screen options in theHP Unified Functional
Testing User Guide.

l You can set the record and run settings for some add-in environments using the corresponding
tab in the Record and Run Settings dialog box (displayed only when the add-in is installed and
loaded). For details on record and run settings for:

n Windows-based applications, see "Record and Run Settings forWindows-Based
Applications" on page 96.

n Web-based environments, see "Web Tab (Record and Run Settings Dialog Box)" on page 83.

n other environments, see the relevant add-in chapter.

In addition to setting the appropriate settings in the specific application tabs, you should confirm
that the other tabs in the dialog box have the appropriate settings.

The following settings are recommended:

n Windows Applications tab.When not runningWindows-based applications, select Record
and run only on: and confirm that all three check boxes are cleared.

n Other tabs. (If displayed.) Select the option to record and run on any open application (upper
radio button of each tab).

While these settings do not directly affect your record or run sessions, they prevent you from
inadvertently recording operations performed onWindows applications (such as e-mail) during
your recording session. These settings also prevent UFT from opening unnecessary
applications when you record or run tests onWindows-based applications.

l You can set record and run options such that no applications open at the beginning of record and
run sessions. In this case, youmay need to open the application after you open UFT to ensure
that UFT recognizes the application. For details, see the relevant add-in chapter.
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l After you set the record and run settings for a test, the Record and Run settings dialog box will
not open the next time you record operations in that test. If needed, you open the Record and
Run Settings dialog box by choosingRecord > Record and Run Settings.

If you change the record and run settings for additional recording sessions, confirm that you
return the settings tomatch the needs of the first step in your test before you run it.

You should set or modify your record and run preferences in the following scenarios:

n You have already recorded one or more steps in the test and you want to modify the settings
before you continue recording.

n Youwant to run the test on a different application than the one you previously set in the
Record and Run Settings dialog box.

l If you define environment variables to specify the record and run details, those values override
the values in the Record and Run Settings dialog box. For details, see "Environment Variables in
Record and Run Settings" below.

Environment Variables in Record and Run Settings

You can use special, predefined environment variables to specify the applications or browsers you
want to use for your test. This can be useful if you want to test how your application works in
different environments. For example, youmay want to test that yourWeb application works
properly on identical or similarWeb sites with different Web addresses.

When you define an environment variable for one (or more) of the application details, the
environment variable values override any values that were added using these areas of the Record
and Run Settings dialog box.

Note: If you select the option to Record and Run on any application (the upper radio button in
each tab of the Record and Run Settings dialog box), UFT ignores any defined Record and Run
environment variables.

You can define the environment variables as internal user-defined variables, or you can add them to
an external environment variable file and set your test to load environment variables from that file.

You can set your Record and Run settings manually while recording your test and then define the
environment variables or load the environment variable file only when you are ready to run the test
(as described in the procedure below).

Alternatively, you can define environment variables before you record your test. In this case, UFT
uses these values to determine which applications or browsers to open when you begin recording—
assuming that the option to open an application when starting record and run sessions for the
particular environment is selected. (This option corresponds to the lower radio button in each tab of
the Record and Run Settings dialog box, and the third check box in theWindows Applications tab.)

For details on setting andmodifying environment variables, see "How to Define Record and Run
Settings for UFT Add-ins" on page 33.
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UFT Add-in Extensibility
UFT add-in extensibility, available for some environments, enables you to extend the relevant UFT
add-in to support third-party and custom controls that are not supported out-of-the-box.

When UFT learns an object in an application, it recognizes the object as belonging to a specific test
object class. This type of test object might not have certain characteristics that are specific to the
control you are testing. Therefore, when you try to create test steps with this test object, the
available identification properties and test object operations might not be sufficient.

By developing support for a control using Add-in Extensibility, you can direct UFT to recognize the
control as belonging to a specific test object class, and you can specify the behavior of the test
object.

You can also teach UFT to treat a control that contains a set of lower-level controls as a single
functional control, instead of relating to each lower-level control separately. For example, a calendar
control may consist of buttons and text boxes. If you teach UFT to recognize the control as a
calendar, ignoring the individual buttons and text boxes, you can createmoremeaningful tests on
the calendar control.

In most environments, you can also extend the list of available test object classes that UFT is able
to recognize. This enables you to create tests that fully support the specific behavior of your
controls.

UFT add-in extensibility is currently supported for the Delphi, Java, .NET, Silverlight, Web, and
WPF add-ins.

If you cannot develop support for your controls using the extensibility options provided for these
environments, youmight be able to take advantage of the Testing Extensibility for UFT program.
Testing Extensibility is intended for customers who want to extend UFT testing capabilities for
technologies or applications not supported by existing UFT add-ins. Participation in the program
requires a separate license agreement with HP.

For details on Testing Extensibility, contact HP Software support.

For details on UFT Add-in Extensibility, see:

l "Delphi Add-in Extensibility" on page 170

l "Java Add-in Extensibility" on page 198

l ".NET Add-in Extensibility" on page 135

l "Silverlight Add-in Extensibility " on page 123

l "Web Add-in Extensibility" on page 498

l "WPF Add-in Extensibility" on page 154
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Tasks

How to Manage UFT Add-ins
This task contains the following steps:

l "Load or remove add-ins from UFT" below

l "Match loaded add-ins with associated add-ins" below

Load or remove add-ins from UFT

1. Select Start > All Programs > HP Software > HP Unified Functional Testing >
HP Unified Functional Testing. The Unified Functional Testing "Add-in Manager Dialog Box"
(described on page 35) opens.

Note: For details on accessing UFT and UFT tools and files inWindows 8, see
"Accessing UFT inWindows 8Operating Systems" on page 547.

2. In the add-in list, select or clear the check box for the relevant add-in and click OK.

Match loaded add-ins with associated add-ins
If there are add-ins associated with your test or with your business component's application area
that are not currently loaded, you can:

l Close and reopen UFT, and select the required add-ins in the "Add-in Manager Dialog Box"
(described on page 35).

l Remove the add-ins from the list of associated add-ins for your test or business component. To
change the list of add-ins associated with your test or business component, select File >
Settings and click Modify in the Properties pane.

If add-ins are loaded but are not associated with your test or with your business component's
application area, you can:

l Close and reopen UFT, and clear the check boxes for the add-ins in the "Add-in Manager Dialog
Box", if they are not required.

l Add the add-ins to the list of associated add-ins for your test or for your business component's
application area.

n To change the list of add-ins associated with your test, select File > Settings and click
Modify in the Properties pane.

n To change the list of add-ins associated with your business component, open the application
area associated with your business component, andmodify the list in the Properties pane.
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For details on associating add-ins with your test or business component, see theHP Unified
Functional Testing User Guide.

How to Define Record and Run Settings for UFT Add-ins
This task contains the following steps:

l "Define record and run settings for specific add-ins" below

l "Set record and run environment variables for add-ins" below

Define record and run settings for specific add-ins

1. Review "Considerations for Defining Record and Run Settings" on page 29.

2. Use one of the following to open the Record and Run Settings dialog box:

n Select Record > Record and Run Settings.

n Click theRecord button or select Record > Record. If you are recording for the first time in
a test and have not yet set your recording preferences (by opening the dialog box manually),
the Record and Run Settings dialog box opens.

The Record and Run Settings dialog box is divided by environment into several tabbed pages.

3. Select the relevant environment by clicking a tab.

4. Set the required options, as described in the relevant add-in chapter.

5. To apply your changes and keep the Record and Run Settings dialog box open, click Apply.

6. Close the Record and Run Settings dialog box to begin your record or run session, click OK.

Set record and run environment variables for add-ins

1. Review "Environment Variables in Record and Run Settings" on page 30.

2. Use one of the following to open the Record and Run Settings dialog box:

n Select Record > Record and Run Settings.

n Click theRecord button or select Record > Record. If you are recording for the first time in
a test and have not yet set your recording preferences (by opening the dialog box manually),
the Record and Run Settings dialog box opens.

The Record and Run Settings dialog box is divided by environment into several tabbed pages.

Add-ins Guide
Chapter 1: UFT Add-ins Overview

HP Unified Functional Testing (12.00) Page 33 of 549



3. Set your record and run preferences normally before recording your test.

Note: If you already have environment variables set for one or more application details,
and you select the option to open an application when the record session begins (the lower
radio button in each tab of the Record and Run Settings dialog box), UFT ignores the
record settings you enter in the dialog box.

4. Record and edit your test normally.

5. If you did not define environment variables prior to recording your test, define an environment
variable for each application detail you want to set using the appropriate variable name. For
details on the variable names required, see:

n ForWeb browsers and URLs to open, see "Environment Variables for aWeb-Based
Environment" on page 61.

n ForWindows applications on which you want to record and run tests, see "Record and Run
Settings forWindows-Based Applications" on page 96.

n For other tabs in the Record and Run Settings dialog box, see the relevant add-in chapter in
this guide.

For details on how to define a user-defined environment variable and how to create
environment variable files, see the section on using environment variable parameters in the
HP Unified Functional Testing User Guide.

6. Run the test. UFT uses the environment values to determine which applications to open at the
beginning of the run session, and on which processes to record.
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Reference

Add-in Manager Dialog Box
This dialog box enables you to select the add-ins that you want UFT to load by selecting the check
boxes adjacent to required add-ins.

To access By default, this dialog box opens when you start UFT.

To display the Add-in Manager if it does not open when you start UFT, select
Tools > Options > General tab > Startup Options node and select Display
Add-in Manager on startup.
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Important
information

l If you select the check box of an add-in that contains a child add-in, the parent
add-in is selected automatically.

l If you clear the check box for a parent add-in, the check boxes for its children
are also cleared.

l UFT remembers which add-ins you selected so that the next time you open
UFT, the same add-ins are selected in the Add-in Manager dialog box.

l If you load or unload an add-in that is displayed as a child of the Java add-in in
the Add-in Manager, only applications that are opened after loading or
unloading the add-in are affected.

Relevant
tasks

l How to Start UFT in theHP Unified Functional Testing User Guide

l "How toManage UFT Add-ins" on page 32

See also l About Unified Functional Testing Detailed InformationWindow in the
HP Unified Functional Testing User Guide

l "UFT Add-in Support - Overview" on page 25

l "Considerations forWorking with UFT Add-ins" on page 27
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User interface elements are described below:

UI
Element Description

Add-in The names of the installed add-ins.

The list of Add-ins might also include child nodes representing add-ins that you or a
third party developed to support additional environments or controls using add-in
extensibility. For details, see the relevant Add-in Extensibility Developer Guide,
available from the UFT Extensibility Documentation program group (Start > All
Programs > HP Software > HP Unified Functional Testing > Extensibility >
Documentation).

Note:

l If you plan to test your application in aWeb browser, selectWeb as well as
your required add-in.

l If you want to test .NETWindows Forms, select .NET and click OK. A
message is displayed stating that for full operation of the .NET Add-in you
must also load theWeb Add-in. If you want to test only .NETWindows Forms
(and not .NETWeb Forms), you can click Yes.

l For details on accessing UFT and UFT tools and files inWindows 8, see
"Accessing UFT inWindows 8Operating Systems" on page 547.

License The license used by the add-in, if any, and the time remaining until a time-limited
license expires:

l Licensed. Applies to the add-ins that are provided with UFT. Add-ins use the
same license as UFT. Therefore, if UFT uses aPermanent license, the add-ins
use the samePermanent license; if UFT uses a Time-Limited license, the add-
ins use the same Time-Limited license.

l Not Licensed. Applies to an add-in that does not have an installed seat license or
access to a concurrent license (for example, if all concurrent licenses are currently
in use, or if the required add-in license is not installed on the concurrent license
server on your subnet). To load the add-in, you first need to install or access a
license.

l Time Remaining. Specifies the number of days and hours remaining until a time-
limited add-in license expires. (Displayed only when using a UFT seat license—
not a concurrent license.)

For more details, see theHP Unified Functional Testing Installation Guide.
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UI
Element Description

License
used

The license used by UFT:

l Unified Functional Testing. Enables you to use all UFT features, including the
use of GUI testing and API testing testing features.

l QuickTest Professional. Enables you to open only GUI tests and components.
When using this license, API testing-related options are not available.

l Service Test. Enables you to open only API tests and components. When using
this license, GUI testing-related options are not available.

l QuickTest and Service Test. Enables you to use UFT with a QuickTest 11.00 or
earlier or a Service Test 11.20 or earlier license. When using this type of license,
business process testing features andGUI/API integration features (like calls to a
GUI test from an API test and vice versa are not available).

Click Change to modify the type of license used with a session of UFT.

Show
on
startup

Instructs UFT to display the Add-in Manager dialog box each time you open UFT.

When this check box is cleared, UFT opens and loads the same add-ins it loaded in
the previous session, without displaying the Add-in Manager.

Note: (for concurrent license users) If this check box was cleared in the
previous session, and the license type selected from the concurrent license
server in that session is not currently available, UFT tries to load an available
license that matches the selected add-ins.

To display the Add-in Manager again:

Select Tools > Options > General tab > Startup Options node and select Display
Add-in Manager on startup.
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Concepts

Web-Based Application Support - Overview
UFT provides a number of add-ins for testingWeb-based applications. The way you configuremany
of your UFT settings is the same or similar for most UFTWeb-based add-ins. These common
configuration options are described in the remainder of this chapter.

For additional details on how to work withWeb-based add-ins, see the following sections:

l ".NETWeb Forms Add-in - Quick Reference" on page 126

l "PeopleSoft Add-in - Quick Reference" on page 258

l "Siebel Add-in - Quick Reference" on page 359

l ".NET Silverlight Add-in - Quick Reference" on page 120

l "Web Add-in - Quick Reference" on page 495

l "Web 2.0 Toolkit Support " on page 524

l "Web-Based SAP Support - Quick Reference" on page 274

In addition to using the add-ins described above, you can also use the Extensibility Accelerator to
develop your ownWeb-based add-in support for third-party and customWeb controls that are not
supported by any of the above UFTWeb-based add-ins. For details, see "Extensibility Accelerator
for HP Functional Testing" on page 498.

Considerations - Web-Based Application Support
This section contains the following items to consider when testingWeb-based applications:

l "Recording and Running Steps onWebControls" below

l "Working withWeb Browsers" on the next page

l "Testing Applications with EmbeddedWeb Browser Controls" on page 42

Recording and Running Steps on Web Controls

l If UFT does not recordWeb events in a way that matches your needs, you can also configure
the events you want to record for each type of Web object. For example, if you want to record
events, such as moving the pointer over an object to open a sub-menu, youmay need tomodify
theWeb event configuration to recognize such events. For details, see "Event Recording
Configuration forWeb-Based Applications" on page 44.

l If you are recording on a list in an application, youmust highlight the list, scroll to an entry that
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was not originally showing, and select it. If you want to select the item in the list that is already
displayed, youmust first select another item in the list (click it), then return to the originally
displayed item and select it (click it). This is because UFT records a step only if the value in the
list changes.

l If aWeb element in an HTML page is set to be disabled or invisible, for example if a <DIV>
element above it controls its appearance, but the elements on the page are available in the
DOM, then UFT can perform operations on those objects even though a human user of the
application could not.

Working with Web Browsers

l You select your browser in the "Web Tab (Record and Run Settings Dialog Box)" (described on
page 83).

l UFT does not support the option to zoom in and out of aWeb page. If you use this option, some
UFT functionality may not work as expected. For example, the Object Spy may be unable to
correctly highlight objects or display object details. (These problems do not occur if the Zoom
Text Only Firefox menu item is selected.)

Additionally, bitmap checkpoints will fail if a different zoom level is used when capturing the
expected bitmap than the zoom level used when running the checkpoint step.

l By default, the name assigned to the Browser test object in the object repository is always the
name assigned to the first Page object that is learned or recorded for the Browser object. The
same Browser test object is used each time you learn an object or record in a browser with the
same ordinal ID. Therefore, the name used for the Browser test object in the steps you record
may not reflect the actual browser name.

l UFTWeb support behaves as a browser extension in Microsoft Internet Explorer. Therefore, you
cannot use theWeb Add-in onMicrosoft Internet Explorer without selecting theEnable third-
party browser extensions option. To set the option, in Microsoft Internet Explorer select Tools
> Internet Options > Advanced and select theEnable third-party browser extensions
option.

l For UFT to run JavaScript methods, the security settings in your browser must be set to allow
active scripting. (In Internet Explorer 7, for example, you can find these security settings under:
Tools > Internet Options > Security > Custom Level > Scripting > Active scripting.)

This is relevant if your test steps includeRunScript orEmbedScriptmethods, or if you are
working with test objects supported usingWeb Add-in Extensibility, such as Web 2.0 test
objects.

l Creating and running steps that start an InPrivate Browsing session is supported only by using
Tools > InPrivate Browsing. Using toolbars or extensions for this operationmay cause
Microsoft Internet Explorer to behave unexpectedly.
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l Creating and running steps that are related to tabs, such as selecting a tab or creating a new tab
is not supported whenMicrosoft Internet Explorer is in Full Screenmode.

Workaround:Add a <Browser>.FullScreen step before and after the desired step to toggle
Full Screenmode.

Testing Applications with Embedded Web Browser Controls
Working with applications that contain embeddedWeb browser controls is similar to working with
Web objects in aWeb browser.

Note: Embedded browser controls are supported only for Microsoft Internet Explorer.

To test objects in embedded browser controls, ensure that:

l TheWeb Add-in is loaded.

l The application opens only after UFT is open.

l (For tests) In the "Web Tab (Record and Run Settings Dialog Box)" (described on page 83), the
Record and run test on any open browser option is selected. (This option is not relevant for
business components.)

After these conditions aremet, you can start adding steps or running your test or business
component.

Registering Browser Controls
A browser control adds navigation, document viewing, data download, and other browser
functionality to a non-Web application. This enables the user to browse the Internet as well as local
and network folders from within the application.

UFT cannot automatically recognize the objects that provide browser functionality in your non-Web
application as Web objects. For UFT to record or run on these objects, the application hosting the
browser control must be registered.

Note: You can register applications developed in different environments, such as those written
in Java, .NET, and so on.

For user interface details, see "Register Browser Control Utility" on page 63.
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Accessing Password-Protected Resources in the Active
Screen

WhenUFT creates an Active Screen page for aWeb-based application, it stores the path to images
and other resources on the page, rather than downloading and storing the images with your test.

Note: The Active Screen pane is not available when working with keyword components
(although it is available for scripted components).

Storing the path to images and other resources ensures that the disk space used by the Active
Screen pages captured with your test is not affected by the file size of the resources displayed on
the page.

For this reason, a page in the Active Screen (or in your run results) may require a user name and
password to access certain images or other resources within the page. If this is the case, a pop-up
login window may open when you select a step corresponding to the page (see "Active Screen
Dialog Box" on page 60), or youmay note that images or other resources aremissing from the page.

For example, the formatting of your pagemay look very different from the actual page on yourWeb
site if the cascading style sheet (CSS) referenced in the page is password-protected, and therefore
could not be downloaded to the Active Screen.

Youmay need to use one or both of the followingmethods to access your password-protected
resources, depending on the password-protectionmechanism used by yourWeb server:

l Standard Authentication. If your server uses a standard authenticationmechanism, you can
enter the login information in the "Web Pane (Test/Business Component Settings Dialog Box /
Application Area - Additional Settings Pane)" (described on page 79). UFT saves this
information with your test and automatically enters the login information each time you select to
display an Active Screen page that requires the information.

If you do not enter this information in theWeb pane of the Test Settings dialog box and attempt
to access the password-protected resources, the "Active Screen Dialog Box" (described on
page 60) opens.

l Advanced Authentication. If your server uses amore complex authenticationmechanism, you
may need to log in to theWeb site manually using the "Advanced Authentication Dialog Box"
(described on page 81). This gives the Active Screen access to password-protected resources
in your Active Screen pages for the duration of your UFT session. When using this method, you
must log in to yourWeb site in the Advanced Authentication dialog box each time you open the
test in a new UFT session.

In most cases, the automatic login is sufficient. In some cases, youmust use themanual login
method. In rare cases, youmay need to use both login mechanisms to enable access to all
resources in your Active Screen pages.

Note: If yourWeb site is not password-protected, but you are still unable to view images or
other resources on your Active Screen, youmay not be connected to the Internet, theWeb
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server may be down, or the source path that was captured with the Active Screen pagemay no
longer be accurate.

Checkpoints for Web Pages
This section describes the checkpoint types that are supported only forWeb-based add-ins. For a
list of all supported checkpoints per add-in, see "Supported Checkpoints " on page 541

Accessibility Checkpoints
Accessibility checkpoints are designed to help you easily locate the areas of yourWeb site that
require special attention according to theW3C WebContent Accessibility Guidelines. They do not
necessarily indicate whether or not yourWeb site conforms to the guidelines.

Accessibility checkpoints are not supported for keyword components.

For details, see the section on accessibility checkpoints in theHP Unified Functional Testing User
Guide.

Page Checkpoints
Whenworking with tests, you can check statistical information about yourWeb pages by adding
page checkpoints to your test. These checkpoints check the links and the sources of the images on
aWeb page. You can also instruct page checkpoints to include a check for broken links.

Page checkpoints are not supported for keyword components.

For details, see the section on page checkpoints in theHP Unified Functional Testing User Guide.

Tip: You can instruct UFT to create automatic page checkpoints for every page in all tests by
selecting theCreate a checkpoint for each Web page while recording check box in the
Web > Advanced pane of the Options dialog box (Tools > Options > GUI Testing tab >
Web > Advanced node). For details, see "Web > Advanced Pane (Options Dialog Box)" on
page 73.

Event Recording Configuration for Web-Based
Applications

When you record on aWeb application, UFT generates steps by recording the events you perform
on theWeb objects in your application. An event is a notification that occurs in response to an
operation, such as a change in state, or as a result of the user clicking themouse or pressing a key
while viewing the document.

UFT includes event recording configurations that have been optimized for eachWeb-based add-in,
so that in most cases UFT records steps for relevant events on each object and avoids recording
steps for events that usually do not impact the application. For example, by default, UFT records a
step when a click event occurs on a link object, but does not record a step when amouseover event
occurs on a link.
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EachWeb-based add-in has its own .xml file that defines theWeb-event recording configuration for
objects in that environment.

When you perform an operation on aWeb-based object during a recording session (and the
appropriate add-in is installed and loaded), UFT uses the recording configuration defined for that
environment.

If your application contains several types of Web-based controls, the appropriateWeb event
recording configuration is used for each object and the configuration for one environment does not
override another.

Customizing Event Recording Configurations for Web-Based Applications
You can view and customize the configuration settings for theWeb Add-in in the "Web Event
Recording Configuration Dialog box" on page 533. The settings in that dialog box affect the
recording behavior only for objects that UFT recognizes as Web test objects.

Note: For the purposes of Web event recording, UFT treats Web test objects that are child
objects of a PSFrame test object as PeopleSoft objects and thus applies the settings in the
PeopleSoft event configuration XML file when recording those objects.

In most cases, it is not necessary to customize theWeb event recording configuration of other add-
ins. If you do need to customize these settings, you can do so either by editing the XML for the
relevant add-in manually, or you can import the XML into theWeb Event Recording Configuration
dialog box tomake the necessary changes and then export themodified file.

Advanced Operations on Web-Based Applications
This section describes various advanced operations you can perform onWeb-based objects, and
includes the following:

Activatingmethods associated with aWeb-based object using the Object property 45

Using programmatic descriptions for theWebElement object 46

Activating methods associated with a Web-based object using the
Object property

In the Editor, you can use the Object property to activate themethod for aWeb object. Activating
themethod for aWeb object has the following syntax:

WebObjectName.Object.Method_to_activate( )

For example, suppose you have the following statement in your script:

document.MyForm.MyHiddenField.value = "My New Text"
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The following example achieves the same thing by using the Object property, where MyDoc is the
DOM's document:

Dim MyDoc
Set MyDoc = Browser(browser_name).page(page_name).Object
MyDoc.MyForm.MyHiddenField.value = "My New Text"

In the following example, LinksCollecton is assigned to the link collection of the page through the
Object property. Then, amessage box opens for each of the links, with its innerHTML text.

Dim LinksCollection, link
Set LinksCollection = Browser(browser_name).Page(page_name).Object.links
For Each link in LinksCollection

MsgBox link.innerHTML
Next

For details on theObject property (.Object), see the section on retrieving and setting identification
property values in theHP Unified Functional Testing User Guide.

For a list of aWeb object's internal properties andmethods, see: http://msdn2.microsoft.com/en-
us/library/ms531073.aspx

Using programmatic descriptions for the WebElement object

WhenUFT recognizes an object as aWeb-based object that does not fit into any other UFT test
object class, it learns the object as aWebElement object. You can also use a programmatic
description with aWebElement test object to perform methods on any Web object in yourWeb site.

For example, when you run either of the examples below, UFT clicks the first Web object in the
Mercury Tours page with the name UserName.

Browser("Mercury Tours").Page("Mercury Tours").WebElement("Name:=UserName",
"Index:=0").Click

or

set WebObjDesc = Description.Create()
WebObjDesc("Name").Value = "UserName"
WebObjDesc("Index").Value = "0"
Browser("Mercury Tours").Page("Mercury Tours").WebElement(WebObjDesc).Click

For details on the WebElement object, see theHP UFT Object Model Reference for GUI Testing.
For details on programmatic descriptions, see the section on programmatic descriptions in the
HP Unified Functional Testing User Guide.
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Web Object Identifiers
During a run session, UFT attempts to identify each object in your application by matching the
description properties stored for the corresponding test object with the properties of the DOM
element in the application. For complex Web applications that contain many objects, using only the
standard identificationmethods may have unreliable results. For details on the standardmethods
UFT uses to identify objects, see the section on howUFT identifies objects in theHP Unified
Functional Testing User Guide.

You can instruct UFT to useWeb object identifiers before the regular object identification process
to help limit the number of candidate objects to identify. UFT accesses the application's DOM and
returns objects that match the object identifier property values. UFT then continues to identify this
smaller set of returned objects using the normal object identification process. Therefore, usingWeb
object identifiers can lead to amore reliable and accurate object identification, and a quicker object
identification process.

To follow an exercise describing the identification process usingWeb object identifiers, see " How
to UseWebObject Identifiers - Exercise" on page 56.

For details about the general workflow of the object identification process, see the section on object
identification in theHP Unified Functional Testing User Guide.

This section includes:

WebObject Identifier Types 47

Considerations -WebObject Identifiers 52

Web Object Identifier Types

The followingWeb object identifiers are available:

For general considerations on working withWeb object identifiers, see "Considerations -Web
Object Identifiers" on page 52.

CSS Web Object Identification

CSS (Cascading Style Sheet) is a language used to define formatting of elements in HTML pages.
You can define a CSS identification property value for a test object to help identify aWeb object in
your application based on its CSS definition.

UFT uses CSS identifiers only when identifying objects and not when learning objects. Therefore,
they are not available from theObject Spy dialog box or the Object Identification dialog box.

For usage examples, see " How to UseWebObject Identifiers - Exercise" on page 56.

For more details on the Object Identification dialog box and on programmatic descriptions, see the
sections on theObject Identification dialog box and Programmatic Descriptions in theHP Unified
Functional Testing User Guide.
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User-Defined XPath Web Object Identification

XPath (XML Path) is a language used to define the structure of elements in XML documents. You
can define an XPath identification property to help identify aWeb object in your application based
on its location in the hierarchy of elements in theWeb page. Because of the flexible nature of the
language, you can define the XPath according to the unique way yourWeb page is structured.

UFT uses XPath identifiers only when identifying objects and not when learning objects. Therefore,
they are not available from theObject Spy dialog box or the Object Identification dialog box.

For usage examples, see " How to UseWebObject Identifiers - Exercise" on page 56.

Automatic X-Path Web Object Identification

You can instruct UFT to automatically generate and store an XPath value when learningWeb test
objects. During the run session, if the automatically learned XPath for a particular object results in
multiple matches or nomatches, the learned XPath is ignored. Additionally, if you have added a
user-defined XPath or CSS identification property to a test object description, then the
automatically learned XPath is ignored.

Automatic XPath is a UFT-generated property, and therefore it is not available from theObject Spy
dialog box , the Add/Remove Properties dialog box, or the Object Identification dialog box.

You enable this option in theWeb section of the Options dialog box. For details, see "Web >
General Pane (Options Dialog Box)" on page 65.

Attribute/* Notation Web Object Identification

You can use the attribute/* notation to access custom native properties of Web-based objects
or events associated withWeb-based objects. You can then use these properties or events to
identify such objects by adding the notation to the object's description properties using the Object
Identification dialog box, or by using programmatic descriptions.

The following examples describe how you can use the attribute/* notation to identify Web
objects:

l "Example of using attribute/<property> to identify aWeb object" below

l "Example of using attribute/<event> to identify aWeb object" on the next page

Example of using attribute/<property> to identify a Web object
Suppose aWeb page has the same company logo image in two places on the page:

<IMG src="logo.gif" LogoID="122">

<IMG src="logo.gif" LogoID="123">
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You could identify the image that you want to click by adding the attribute/LogoID notation to the
object's description properties and using a programmatic description to identify the object:

Browser("Mercury Tours").Page("Find Flights").Image("src:=logo.gif","attribu
te/LogoID:=123").Click 68, 12

Example of using attribute/<event> to identify a Web object
Suppose aWeb page has an object with an onclick event attached to it:

"alert('OnClick event for edit.');"

You can identify the object by adding the attribute/onclick notation to the object’s description
properties and using a programmatic description to identify the object:

Browser("Simple controls").Page("Simple controls").WebEdit("attribute/onclic
k:= alert\('OnClick event for edit\.'\);").Set "EditText"

Style/* Notation Web Object Identification

You can use the style/* notation to access the values of CSS properties for aWeb-based object.
You can then use these property values to identify such objects by adding the notation to the
object's description properties using programmatic descriptions.

The following examples describe how you can use the style/* notation to identify Web objects:

l "Example of using style/<property> to identify aWeb object using the background-color
property" below

l "Example of using style/<property> to identify aWeb object using the background-position
property" on the next page

l "Example of using style/<property> to identify aWeb object and update invalid input controls" on
page 51

Formore details, see "Considerations for using the Style/* notation" on page 51

Example of using style/<property> to identify a Web object using the
background-color property
Suppose a web page has different colored button objects on the same page:

<input type="button" style="background-color:rgb(255, 255, 0)">
<input type="button" style="background-color:rgb(255, 0, 0)">
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You can identify the button that you want to click by adding the style/background-color notation
to the object's description properties or using a programmatic description to identify the object:

Browser("Simple controls").Page("Simple controls").WebButton("style/backgrou
nd-color:=rgb\(255, 255, 0\)").Click

Example of using style/<property> to identify a Web object using the
background-position property
Suppose a web page has different image objects on the same page:

<head>
<style>
img.home {
width:46px;
height:44px;
background:url(img_navsprites.gif) 0px 1px;
}
img.next {
width:43px;
height:44px;
background:url(img_navsprites.gif) -91px 1px;
}
</style>
</head>
<body>
<img class="home" src="img_trans.gif" onclick="var info = document.getElemen
tById('info'); info.value = 'HOME';" id="home"/>
<br /><br />
<img class="next" src="img_trans.gif" onclick="var info = document.getElemen
tById('info'); info.value = 'NEXT';" id="next"/>
<br /><br /><br /><br /><br />
<input type="text" id="info" />
</body>

You can identify the image that you want to click by adding the style/background-position
notation to the object's description properties and using a programmatic description to identify the
object:

Browser("Browser").Page("Page").WebElement("html tag:=img", "style/backgroun
d-position:=-91px 1px").Click
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Example of using style/<property> to identify a Web object and update
invalid input controls
Suppose a web page has different edit objects on the same page, each defined to use a red
background color if the input is invalid:

<head>
<STYLE TYPE="text/css">
input:required:invalid, input:focus:invalid {
background-color: rgb(255, 0, 0);
}
input:required:valid {
background-color: rgb(0, 255, 0);
}
</STYLE>
</head>
<body>
<form>
<p>email:</p>
<input id="emailTxt" type="email" placeholder="test@.com" required><br />
<p>url:</p>
<input id="urlTxt" type="url" pattern="https?://.+" placeholder="https?://.
+" required><br />
</form>

You can identify the invalid values that need to be corrected by adding the style/background-
color notation to the object's description properties and using a programmatic description to
identify the object. You can then enter valid input into the edit object based on the object's type
property:

Set oDesc = Description.Create()
oDesc("micclass").Value = "WebEdit"
oDesc("style/background-color").Value = "rgb\(255, 0, 0\)"

Set invalidEdit = Browser("Browser").Page("Page").ChildObjects(oDesc)
numberOfEdits = invalidEdit.Count
For i = 0 To numberOfEdits - 1
If invalidEdit(i).GetROProperty("type") = "email" Then
invalidEdit(i).Set "test@.com"
End If
invalidEdit(i).GetROProperty("type") = "url" Then

invalidEdit(i).Set "http://www.test."
End If

Considerations for using the Style/* notation

l The CSS property values are returned using the browser's functions, and values may differ
depending on the browser you are using.
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l UFT retrieves the CSS property values from the browser. When designing tests or components
that will run on different browsers, keep inmind that different browsers may have different CSS
functionality and return different property values for the same object.

l CSS shorthand properties, such as animation, font, background, and outline are not
supported. Instead, use a concrete CSS property in your descriptions, such as background-
image, font-family, border-width, and so on.

Considerations - Web Object Identifiers

Consider the following when usingWeb object identifiers:

General

l Defining xpath and css properties using FrameHTML tags is not supported. This may cause
incorrect identification when identifying Frame objects or retrieving Frame objects using the
ChildObjectsmethod.

l xpath and css properties are not supported for .NETWeb Forms test objects or for otherWeb-
based test objects that have .NETWeb Forms parent test objects.

l When running in MaintenanceMode, UFT may replace test objects with XPath or css identifier
property values with new objects from your application.

Workaround: Use theUpdate from Application option in the Object Repository Manager to
update specific test objects withXPath or css identifier property values.

Differences Between User-Defined XPath and Automatic XPath Behavior
During Run Sessions

Behavior in
case of... User-defined XPath Automatic XPath

Multiple
objects match
the XPath
value

UFT continues to identify the
matching objects.

UFT ignores the learned XPath and
continues with the regular object
identification process.

No objects
match the
XPath value

Object identification fails, and UFT
continues to identify the object using
Smart Identification

UFT ignores the learned XPath and
continues with the regular object
identification process.
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Tasks

How to Modify Event Recording Configuration for Web-
Based Applications

This task includes the following steps:

l "Modify the event recording configuration XML file manually" below

l "Modify the event recording configuration in theWeb Event Recording Configuration dialog box"
below

Modify the event recording configuration XML file manually

1. In a text or XML editor, open the appropriate MyEnvEventConfiguration.xml file from the
<UFT installation folder>\dat folder, according to the following table:

Object Type: XML File Name

.NETWeb Forms WebFormsEventConfiguration.xml

Siebel 7.5 or earlier SiebelEventConfiguration.xml

Siebel 7.7 or later CASEventConfiguration.xml

PeopleSoft Frame objects and all Web objects that
are children of a PeopleSoft frame object

PSEventConfiguration.xml

2. Edit the file as necessary.

3. Save the file.

Modify the event recording configuration in the Web Event Recording
Configuration dialog box

1. Back up the event recording configuration for theWeb environment:

a. Select Record > Web Event Recording Configuration. TheWeb Event Recording
Configuration dialog box opens.

b. Click Custom Settings.

c. Select File > Save Configuration As and specify an XML filename for the backup file.
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2. Back up the event recording configuration for the environment you want to modify:

Create a copy of the relevant <MyEnv>EventConfiguration.xml file from the <UFT
installation folder>\dat folder.

3. Modify the <MyEnv>EventConfiguration.xml file in theWeb Event Recording Configuration
dialog box:

a. In theWeb Event Recording Configuration dialog box, select File > Load Configuration
and browse to the relevant <UFT installation
folder>\dat\<MyEnv>EventConfiguration.xml file. The event configuration for the
selected environment is displayed in the dialog box.

b. In theWeb Event Recording Configuration dialog box, select File > Load Configuration
and browse to the relevant <UFT installation
folder>\dat\<MyEnv>EventConfiguration.xml file. The event configuration for the
selected environment is displayed in the dialog box.

c. Modify the configuration using theWeb Event Recording Configuration dialog box options,
as described in "Event Recording Configuration forWebObjects - Overview" on page 521.

d. Select File > Save Configuration As and overwrite the previous <UFT installation
folder>\dat\<MyEnv>EventConfiguration.xml file.

4. Restore the configuration file for theWeb environment:

Select File > Load Configuration and browse to the backup copy of theWeb configuration
XML file that you saved earlier.

Caution: UFT always applies the configuration that is loaded in the "Web Event
Recording Configuration Dialog box" on page 533 to all Web objects. If you do not restore
theWeb configuration file, then UFT will apply the configuration for the
<MyEnv>EventConfiguration.xml file you last loaded, and as a result, UFT may not
recordWeb events properly.

How to Configure UFT to Record Mouse Clicks
This task describes how to instruct UFT to record right mouse clicks by modifying the configuration
file manually.

1. (Web Add-in only) Prerequisite - Export the configuration file from the
CustomWeb Event Recording Configuration dialog box
a. Select Record > Web Event Recording Configuration, and then click Custom

Settings. For user interface details, see the section on the CustomWeb Event Recording
Configuration dialog box.
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b. Export your custom configuration to an .xml file by selecting File > Save Configuration
As. Then, navigate to the folder in which you want to save theWeb event recording
configuration file, and enter a configuration file name. The extension for configuration files
is .xml.

2. Open the XML file in a text editor
Open the configuration file for editing in any text editor. The configuration file uses a predefined
XML structure. For details, see "Web Event Recording Configuration Dialog box" on page 533.

The following example illustrates the beginning of an exported configuration file:

TheProperty Name element controls the recording of themouse buttons. The values of the
mouse buttons are defined as follows:

n 1. Left

n 2. Right

n 4.Middle

3. Modify the XML file to enable mouse click recording
a. Edit the .xml file as follows:

o To record a left mouse click for the onmouseup event, add the following line:

<Property Name="button" Value="1" Listen="2" Record="2"/>

o To record right and left mouse clicks for the onmousedown event, add the following
lines:

<Event Name="onmousedown" Listen="2" Record="1">
<Property Name="button" Value="2" Listen="2" Record="2"/>
<Property Name="button" Value="1" Listen="2" Record="2"/>
</Event>
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Note: Only one event, either onmouseup or onmousedown, should be used to
handlemouse clicks. If both events are used, UFT records two clicks instead of one.
By default, UFT listens for the onmouseup event.

b. Save the .xml file.

4. (Web Add-in only) Load the XML file into the CustomWeb Even
Recording Configuration dialog box
a. In the "CustomWeb Event Recording Configuration Dialog Box" (described on page 534),

select File > Load Configuration. TheOpen dialog box opens.

b. Navigate to the folder in which you saved the edited configuration file, select the file, and
click Open. The CustomWebRecording Configuration dialog box reopens.

c. Click OK. The new configuration is loaded, with all preferences corresponding to those you
defined in the .xml configuration file. Any Web objects you now record will be recorded
according to these new settings.

How to Use Web Object Identifiers - Exercise
In this exercise, you use XPath and CSS identifiers in a test object description to help locate the
correct button in an HTML table.

This exercise includes the following steps:

1. "Prerequisites" below

2. "Create a sampleWeb application" on the next page

3. "Learn the button objects in theWeb application" on the next page

4. "Remove the ordinal identifiers from the button objects" on the next page

5. "Add a CSS identifier based on the object's parent container" on page 58

6. "Add an XPath identifier based on the object's parent container" on page 58

7. "Add an XPath identifier based on the object's sibling element" on page 58

8. "Results" on page 59

1. Prerequisites
a. Open UFT and create a new test.
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b. Disable Smart Identification for the Button test object class by selecting Tools > Object
Identification, selecting theWeb environment in the Object Identification dialog box, and
then selecting theButton test object class from the Test Object classes list.

c. Disable automatic XPath in theWeb > Advanced node (Tools > Options > GUI Testing
tab > Web > Advanced node) by clearing the Learn and run using automatic XPath
identifiers check box.

2. Create a sample Web application
a. Open the Help version of this exercise, copy the syntax content into a text document, and

save the document with an .html extension. The document is saved as an HTML page.

b. Review the appearance and content of your newly created HTML page in any browser.
Make sure that it matches the following image.

3. Learn the button objects in the Web application
a. In UFT, open theObject Repository Manager, and select Object > Navigate and Learn.

UFT is hidden, and the cursor changes to a pointing hand.

b. To verify that UFT learned the objects correctly, in the object repository, select each
Button object and select View > Highlight in Application. UFT highlights each button
object in the HTML page.

c. Rename theButton objects to make themmore clear:

o RenameBuy toBuy_BPT.

o RenameBuy_2 toBuy_ALM.

o RenameBuy_3 toBuy_UFT.

4. Remove the ordinal identifiers from the button objects
Because all of the Button objects have identical property values, when UFT learned the objects
it assigned an ordinal identifier to each test object based on the location of each object in the
application. This may cause UFT to identify the objects incorrectly if the sorting order of the
buttons in the application changes.

a. In the Object Repository Window, select the first button object to display its object
properties on the right side of the object repository window.
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b. In theOrdinal Identifier section, select theBrowse button. TheOrdinal Identifier Dialog
Box opens.

c. In the Identifier type drop-down list, select None and close the dialog box. The ordinal
identifier is removed from the test object's identification properties.

d. Repeat the previous steps for each of the buttons.

e. Verify that the test object descriptions are no longer unique by selecting each test object
and selectingView > Highlight in Application. UFT cannot identify the objects.

5. Add a CSS identifier based on the object's parent container
a. Select theBuy_BPT button. The test object details are displayed on the right side of the

object repository window.

b. In theObject Description section, click theAdd button, and add the css property to the
test object description.

c. Copy and paste the following syntax into the Value edit box:

tr.BPTRow input

6. Add an XPath identifier based on the object's parent container
a. Select theBuy_UFT button. The test object details are displayed on the right side of the

object repository window.

b. In theObject Description section, click theAdd button, and add the xpath property to the
test object description.

c. Copy and paste the following syntax into the Value edit box:

//TR[@id='UFT']/*/INPUT

7. Add an XPath identifier based on the object's sibling element
a. Select theBuy_QC button. The test object details are displayed on the right side of the

object repository window.

b. In theObject Description section, click theAdd button, and add the xpath property to the
test object description.

c. Copy and paste the following syntax into theValue edit box:

//td[contains(text(),'Quality')]/../*/INPUT

Add-ins Guide
Chapter 2: Web-Based Application Support

HP Unified Functional Testing (12.00) Page 58 of 549



8. Results
Select each object and select View > Highlight in Application. UFT can now identify each
button based on theWeb object identifiers you added.
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Reference

Active Screen Dialog Box
This dialog box enables you to enter login information for any images or other resources in the
Active Screen that are password-protected using the standard authenticationmechanism.

To access This dialog box opens when you select a step in your test or results in which one
or more images or other resources in the Active Screenmay be password-
protected.

Important
information

l After you enter a user name and password, refresh the Active Screen by
selecting a new step in the Keyword View or select View > Active Screen to
re-display the Active Screen. Confirm that the page is displayed correctly.

l If one or more resources are still missing or displayed incorrectly, youmay
need to use the Advanced Authenticationmechanism. For details, see
"Advanced Authentication Dialog Box" on page 81.

See also l "Advanced Authentication Dialog Box" on page 81

l "Web Pane (Test/Business Component Settings Dialog Box / Application Area
- Additional Settings Pane)" on page 79

User interface elements are described below:

UI
Element Description

User
name

The user name used to log into your application.

Password The password used to log into your application.

HP Unified Functional Testing (12.00) Page 60 of 549



UI
Element Description

Save the
User
Name
and
Password

Enables the automatic Active Screen login mechanism, by adding the login
information to theActive Screen access area in theWeb pane of the Test Settings
dialog box. This prevents the Active Screen dialog box from opening, and ensures
that all images and resources are displayed in the Active Screen and results each
time you open the test, you can use the automatic Active Screen login mechanism.

Note: You can also add the login informationmanually in theWeb pane of the
Test Settings dialog box. For details, see "Web Pane
(Test/Business Component Settings Dialog Box / Application Area - Additional
Settings Pane)" on page 79.

Environment Variables for a Web-Based Environment
You can use predefined environment variables to specify the applications or browsers you want to
use for your test. This can be useful if you want to test how your application works in different
environments.

Note: For details on environment variables and how to use them in tests, see "Environment
Variables in Record and Run Settings" on page 30.

Add-ins Guide
Chapter 2: Web-Based Application Support

HP Unified Functional Testing (12.00) Page 61 of 549



To use environment variables to define theWeb browser and URL to open, set the appropriate
variable names as specified below:

Option
Variable
Name Description

Type BROWSER_
ENV

The browser program to open. For example, Microsoft Internet Explorer,
Google Chrome, or Mozilla Firefox.

Possible values:

IE. Opens Internet Explorer.

IE64. Opens a 64-bit version of Internet Explorer.

CHROME. Opens Google Chrome.

FIREFOX. Opens the latest version of Mozilla Firefox that is both
installed on the computer and supported by UFT.

FF<VersionNumber>. Opens the specified version of Mozilla Firefox.
For example: FF36 (version 3.6), FF40 (version 4.0), FF140 (version 14.0).

SAFARI. Opens Safari on the remoteMac computer connected to UFT
(defined in theWeb tab of the Record and Run Settings dialog box or in
the HOST_NAME environment variable).

Note:

l If the specified browser program is not installed, the default
browser is used.

l Mozilla Firefox is supported only for theWeb Add-in.

l When specifying a Firefox version number, make sure to specify
a supported version. For a list of all supported browser versions,
see theHP Unified Functional Testing Product Availability
Matrix, available from the UFT Help or the root folder of the
Unified Functional Testing DVD. Themost up-to-date product
availability matrix is available from the HP Software Product
Manuals site, at http://h20230.www2.hp.com/selfsolve/manuals
(requires an HP Passport).
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Option
Variable
Name Description

Remote
Host

REMOTE_
HOST

The host name or IP address of theMac computer to which UFT
connects.

By default, UFT connects to theMac using port 8822. To use a different
port, append the port number to the host name: <hostname>:<port
number>.

Make sure to configure the same port number on theMac, in the
UFT Connection Agent preferences and the Unified Functional Testing
Agent extension on the Apple Safari browser.

For more details, see "How to Connect to a RemoteMac Computer" on
page 505.

Note: Relevant only for running tests and components on the Apple
Safari browser.

Address URL_ENV TheWeb address to display in the browser.

Register Browser Control Utility
This utility enables you to define the path of yourWeb application hosting the browser control. After
registration, UFT will recognizeWeb objects in your application when recording or running tests.

To access Select Start > All Programs > HP Software > HP Unified Functional Testing
> Tools > Register New Browser Control.

Note: For details on accessing UFT and UFT tools and files inWindows 8,
see "Accessing UFT inWindows 8Operating Systems" on page 547.
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Important
information

l After you register an application hosting a browser control using this utility, you
must restart UFT before you test your application.

l This tool must be run with UAC disabled. For details about disabling UAC,see
theHP Unified Functional Testing User Guide.

See also "Registering Browser Controls" on page 42

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<host application
path>

The absolute path to the .exe file of the application hosting the browser
control.

Register / Unregister Registers or removes a registered application.

Web Event Recording Configuration XML File Structure
TheWeb event recording configuration XML file is structured in a specific format when you export it
from the "CustomWeb Event Recording Configuration Dialog Box" (described on page 534). If you
aremodifying the file, or creating your own file, youmust ensure that you adhere to this format for
your settings to take effect.

For task details, see "How toModify Event Recording Configuration forWeb-Based Applications"
on page 53.

Sample XML File

<XML>
    <Object Name="Any Web Object">
        <Event Name="onclick" Listen="2" Record="2"/>
        <Event Name="onmouseup" Listen="2" Record="1">
            <Property Name="button" Value="2" Listen="2" Record="2"/>
        </Event>
    </Object>
        . . .
        . . .
        . . .
    <Object Name="WebList">
        <Event Name="onblur" Listen="1" Record="2"/>
        <Event Name="onchange" Listen="1" Record="2"/>
        <Event Name="onfocus" Listen="1" Record="2"/>
    </Object>
</XML>
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The following attributes enable you to define the listening criteria and recording status options in the
XML file:

Attribute Possible Values

Listen 1. Always

2. If Handler

4. If Behavior

6. If Handler or Behavior

0. Never

Record 1. Disabled

2. Enabled

6. Enabled on Next Event

Web > General Pane (Options Dialog Box)
This pane enables you to determine how UFT behaves when recording and running tests or
business components onWeb sites.
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To access 1. Do one of the following:

n Ensure that a GUI test, action, or component is in focus in the document
pane.

n In the Solution Explorer, select a GUI test or component node or one of its
child nodes.

2. Select Tools > Options > GUI Testing tab > Web > General node.

Important
information

l You can alsomodify how UFT displays capturedWeb pages in the Active
Screen. You do this in theActive Screen pane of the Options dialog box
(Tools > Options > GUI Testing tab > Active Screen node). For details, see
the section describing Active Screen options in theHP Unified Functional
Testing User Guide.

l TheRestore Factory Defaults button resets all Options dialog box options to
their defaults.

Relevant
tasks

"How toModify Event Recording Configuration forWeb-Based Applications" on
page 53

See also l "Browser Details Dialog Box" on page 68

l "Web > Page/FrameOptions Pane (Options Dialog Box)" on page 70

l "Web > Advanced Pane (Options Dialog Box)" on page 73
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User interface elements are described below:

UI Element Description

Ignore the
following
browsers

Instructs UFT to ignore any specified browsers that may be open while UFT is
recording or running a test or business component. This enables you to keep
browsers that are not related to your testing environment open, without having
them affect the record or run session.

For example, youmay want to check your company's share price or the news
headlines during a record and run session. If you instruct UFT to ignore these
specific browsers, they do not affect the session.

Note:

l UFT ignores browsers that match the defined criteria at the start of a
record or run session. However, browsers that do not match the defined
criteria at the start of a record or run session, but domatch them during
the session, are not ignored.

l Changes made to these settings apply to new tests or business
components and new steps in existing tests or business components
only, but not to any other existing steps.

l Whenworking with tests, UFT ignores browsers only if you selected
Record and run test on any open Web browser in theWeb tab of the
Record and Run Settings dialog box. For details, see "Web Tab (Record
and Run Settings Dialog Box)" on page 83.

For details, see "Browser Details Dialog Box" on the next page.

Add Browser. Opens the "Browser Details Dialog Box" (described on page 68,
which enables you to add browsers to the Ignore the following browsers list.

Modify Browser Details. If you selected a browser from the Ignore the
following browsers list, this option opens the "Browser Details Dialog Box"
(described on page 68, which enables you to edit the details of the selected
browser.

Remove Browser. Removes the selected browser from the list if you no longer
want UFT to ignore it during a record or run session.

Note: If a browser in the list is required for running a specific test, you can
temporarily remove it from the list by clearing the check mark next to its
name in the list of browsers.

Ignore ALM Instructs UFT to ignore all instances of ALM that are opened while recording or
running a test or business component. By default, this option is selected.
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UI Element Description

Add __
seconds to
page load
time

Instructs UFT to add a specified number of seconds to the page load time
property specified in each Page checkpoint. (Page checkpoints are not relevant
for keyword components.)

Note: This option is a safeguard that prevents page checkpoints from failing
in the event that the amount of time it takes for a page to load during the run
is longer than the amount of time it took during the record session.

Broken
links - check
only links to
current host

Instructs UFT to check only for broken links that are targeted to your current
host.

Browser Details Dialog Box

This dialog box enables you to specify the browsers that you want UFT to ignore during a record or
run session.

To access In the "Web > General Pane (Options Dialog Box)", click theAdd Browser button

or theModify Browser Details button .

For details on theWeb pane, see "Web > General Pane (Options Dialog Box)" on
page 65.
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Important
information

l You can specify any one of the Title orURL properties, or both. However, the
Title andURL properties have an AND relationship, meaning that a browser
must match both property values (if defined) to be ignored by UFT.

l You can use regular expressions when specifying the values of these
properties. For example, you can use .*finance.mybank.com to specify all
finance.mybank.com domains andWeb sites starting with www., http://, or
https://. You do not need to use a regular expression to include child pages
of a site, as UFT automatically ignores the entire domain or site. For details on
supported regular expressions, see theHP Unified Functional Testing User
Guide.

See also l "Web > General Pane (Options Dialog Box)" on page 65

l "Web > Page/FrameOptions Pane (Options Dialog Box)" on the next page

l "Web > Advanced Pane (Options Dialog Box)" on page 73

User interface elements are described below:

UI
Element Description

Name The name of the browser definition. The name you specify is used only to identify the
browser in the list, and is not used by UFT.

Default format: Browser<number of browser in list>

Title The name of theWeb page as it appears in the title bar of the browser.

Example: MyBank - Finance.*

URL The URL of theWeb page. Any descendants of the specifiedWeb page are
automatically included in the list of browsers to ignore.

Example: http://www.finance.mybank.com
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Web > Page/Frame Options Pane (Options Dialog Box)

This pane enables you tomodify how UFT records Page and Frame objects.

To access 1. Make sure that a GUI test is open.

2. Select Tools > Options > GUI Testing tab > Web > Page/Frame Options
node.

See also l "Web > General Pane (Options Dialog Box)" on page 65

l "Web > Advanced Pane (Options Dialog Box)" on page 73

User interface elements are described below:

UI Element Description

Create a new Page test object for
These options instruct UFT when to create a new Page object in the object repository while
recording.
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UI Element Description

Create a new Frame test object for
These options instruct UFT when to create a new Frame object in the object repository while
recording. The Frame options are similar to the Page options (except that theEvery navigation
option is not available).

Every navigation Instructs UFT to create a new Page object every time a navigation is
performed in aWeb page.

(Relevant only forCreate a new Page test object for.)

Different test
object descriptions

Instructs UFT to create a new Page test object for pages with different
test object descriptions, according to the properties defined for the Page
test object.

Note: The default test object description for Page objects includes
only the test object class. If you select this option, it is highly
recommended that you define object identification properties that
uniquely identify different Page objects. You should also ensure that
the properties you define remain constant over time, otherwise future
runs may fail.
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UI Element Description

Different URLs or
a change in data
transfer

Instructs UFT to create a new Page object only when the page URL
changes, or if the URL stays the same and data that is transferred to the
server changes, according to the data types and transfer methods you
select:

l Ignore non user-input data - Get. Instructs UFT to ignore non user-
input data if the Getmethod is used to transfer data to the server.

For example, suppose a user enters data on aWeb page, and the data
is then inserted as a hidden field using theGetmethod. The user clicks
Submit (to send the data to the server). The new Web page is
different, according to the hidden field data. However, UFT does not
create a new Page test object.

l Ignore non user-input data - Post. Instructs UFT to ignore non-
user-input data if thePostmethod is used to transfer data to the
server.

For example, suppose a user enters data on aWeb page, and the data
is then inserted as a hidden field using thePostmethod. The user
clicks Submit (to send the data to the server). The new Web page is
different, according to the hidden field data. However, UFT does not
create a new Page test object.

l Ignore user-input data - Get. Instructs UFT to ignore user-input data
if theGetmethod is used to transfer data to the server.

For example, suppose a user enters data in a form on aWeb page and
clicks Submit (to send the data to the server) using theGetmethod.
The new Web page is different according to the data filled in by the
user. However, UFT does not create a new Page test object.

l Ignore user-input data - Post. Instructs UFT to ignore user-input
data if thePostmethod is used to transfer data to the server.

For example, suppose a user enters data in a form on aWeb page and
clicks Submit (to send the data to the server) using thePostmethod.
The new Web page is different according to the data filled in by the
user. However, UFT does not create a new Page test object.

Use additional
Page information

Instructs UFT to use additional properties of the test object to identify an
existingPage test object.

Tip: Select this option to instruct UFT to recognize existing pages
when theBack and Forward navigation buttons are used.
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UI Element Description

Reset All Resets all options to their default core settings. SomeWeb-based add-ins
modify the default settings to optimize page and frame recording. If you
are using an add-in, it is recommended that you keep the default add-in
settings and do not use theReset button.

Web > Advanced Pane (Options Dialog Box)

This pane enables you tomodify how UFT records and runs tests and business components on
Web sites.

To access 1. Make sure that a GUI test is open.

2. Select Tools > Options > GUI Testing tab > Web > Advanced node.

Important
information

TheAccessibility checkpoint andAutomatic Page checkpoint options are
not relevant for keyword components.

See also l "Web > General Pane (Options Dialog Box)" on page 65

l "Web > Page/FrameOptions Pane (Options Dialog Box)" on page 70
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User interface elements are described below:

Accessibility Checkpoint (Tests Only)
Accessibility checkpoints enable you to check that Web pages and frames conform to theW3C
WebContent Accessibility Guidelines. All accessibility checkpoints in a test use the options that
are selected in this dialog box during the run session.

For general information about accessibility checkpoints, see the section on Accessibility
Checkpoints in theHP Unified Functional Testing User Guide.

UI Element Description

ActiveX Check Checks whether the page or frame contains ActiveX objects. If so,
UFT sends a warning and displays a list of the objects in the Run
Results.

Alt Property Check Checks that the <alt> attribute exists for all relevant objects (such as
images). If one or more objects lack the required attribute, the test fails
and UFT displays a list of the objects with themissing attribute in the
Run Results. (Selected by default.)

Applet Check Checks whether the page or frame contains Java objects. If so, UFT
sends a warning and displays a list of the objects in the Run Results.

Frame Titles Check Checks that the page and all frames in the page have titles. If one or
more frames (or the page) lack the required title, the test fails and UFT
displays a list of the frames that lack titles in the Run Results.

Multimedia Links
Check

Checks whether the page or frame contains links tomultimedia
objects. If so, UFT sends a warning and displays a list of the links in
the Run Results.

Server-side Image
Check

Checks whether the page or frame contains Server-side images. If so,
UFT sends a warning and displays a list of the images in the Run
Results.

Tables Check Checks whether the page or frame contains tables. If so, UFT sends a
warning and displays the table format and the tags used in each cell in
the Run Results.

Add an automatic
accessibility
checkpoint to each
Web page while
recording

Instructs UFT to automatically add an accessibility checkpoint to each
Web page while recording, using the checks selected in the option
above.

Add-ins Guide
Chapter 2: Web-Based Application Support

HP Unified Functional Testing (12.00) Page 74 of 549



Automatic Page Checkpoint (Tests Only)
These options enable you to check that expected and actual page properties are identical, by
instructing UFT to automatically add a Page checkpoint for eachWeb page navigated during the
recording process.

Note: If you are testing aWeb page with dynamic content, using automatic Page checkpoints
may cause the test to fail as these checkpoints assume that the page content is static
between record and run sessions.

UI Element Description

Broken links Displays the number of broken links contained in the page during the run
session.

Note: If theBroken links - check only links to current host option is
selected in theWeb pane of the Options dialog box (see "Web > General
Pane (Options Dialog Box)" on page 65, this number includes only those
broken links that are targeted to the current host.

HTML source Checks that the expected source code is identical to the source code during the
run session.

HTML tags Checks that the expected HTML tags in the source code are identical to those
in the run session.

Image source Checks that the expected source paths of the images are identical to the
sources in the run session.

Links URL Checks that the expected URL addresses for the links are identical to the URL
addresses in the source code during the run session.

Load time Checks that the expected time it takes for the page to load during the run
session is less than or equal to the amount of time it took during the record
session PLUS the amount of time specified in theAdd seconds to page load
time option (see "Web > General Pane (Options Dialog Box)" on page 65).

Number of
images

Checks that the expected number of images is identical to the number
displayed in the run session.

Number of
links

Checks that the expected number of links is identical to the number displayed in
the run session.

Create a
checkpoint
for each Web
page while
recording

Instructs UFT to automatically add a Page checkpoint for eachWeb page
navigated during the recording process.
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UI Element Description

Ignore
automatic
checkpoints
while
running tests

Instructs UFT to ignore the automatically added Page checkpoints while
running your test.

Record Settings
These options enable you to set preferences for recordingWeb objects.

Note: If UFT does not recordWeb events in a way that matches your needs, you can also
configure the events you want to record for each type of Web object. For example, if you want
to record events, such as amouseover that opens a sub-menu, youmay need tomodify your
Web event configuration to recognize such events. For details, see "Event Recording
Configuration forWeb-Based Applications" on page 44.

UI Element Description

Enable Web
support for
Microsoft
Windows
Explorer

When selected, UFT treats relevant objects in Microsoft Windows Explorer as
Web objects. When cleared, UFT does not record events onWeb pages
displayed inMicrosoft Windows Explorer.

Note: After modifying this setting, for the change to take effect, youmust
close all instances of Microsoft Windows Explorer (confirm that all
explorer.exe processes are closed in theWindows Task Manager or
restart the computer) and then restart UFT.

Record
coordinates

Records the actual coordinates relative to the object for each operation.

Record
MouseDown
and MouseUp
as Click

Records aClickmethod formouseup andmousedown events.

Note: ForWeb, UFT records RightClick andMiddleClickmethods for
most Web objects. Therefore, this option is relevant only for clicks made
using the left mouse button.

Record
Navigate for all
navigation
operations

Records aNavigate statement each time a FrameURL changes.
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UI Element Description

Use standard
Windows
mouse events

Instructs UFT to use standardWindows mouse events instead of browser
events for the following events:

l OnClick

l OnMouseDown

l OnMouseUp

Note:

l Use this option only if the events are not properly recorded using
browser events.

l ForWeb, UFT records RightClick andMiddleClickmethods for
most Web objects. Therefore, this option is relevant only for clicks
made using the left mouse button.

l This option is available only for Internet Explorer.

Run Settings
These options enable you to set preferences for working withWeb objects during a run session.

UI
Element Description

Browser
cleanup

Closes all open browsers after the current run or iteration ends.

When this option is selected, all currently open browsers are closed when the
current run or iteration ends, regardless of whether the browsers were opened
before or after UFT was opened.

Note:

This option is only applicable when a test iteration finishes naturally by running
all test steps, and not by using theExitTestIterationmethod.

If you use theExitTestIterationmethod, add aWait statement just before the
ExitTestIteration step.

Run only
click

Determines whether a Click operation is run on the application by sending
MouseDown,MouseUp, andClick events, or by sending only aClick event. This
option is relevant only forClick operations whenEvent is selected for the 'Replay
type' option. It is relevant only for left-buttonmouse clicks.
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UI
Element Description

Replay
type

Configures how to runmouse operations according to the selected option:

l Event. Runs mouse operations using browser events.

l Mouse. Runs mouse operations using themouse, and keyboard operations
using the keyboard.

Run using
source
index

Instructs UFT to learn and store the source index value when learningWeb test
objects, and to use that value during a run session to improve performance. During
run sessions, UFT uses the learned source index value to return the relevant DOM
element from the application and then verifies that this object matches the test
object description. This operation is faster than searching the entire DOM for
objects that match the test object description.

If the returned object does not match the description, the source index is ignored
and UFT attempts to identify the object using the standard object identification
process.

The source index is also ignored during a run session in the following scenarios:

l The description for a test object includes theXPath or css identifier. For details,
see "WebObject Identifiers" on page 47.

l If youmanually define an Index ordinal identifier for the test object. For details,
see the section on the Index Ordinal Identifier in theHP Unified Functional
Testing User Guide.

l The run session is performed using a browser other than Internet Explorer.

Resize
browser
on run if
resized
during a
recording
session

If you select this option and then resize the browser during a recording session,
UFT resizes the browser to this size when the first time you run the recorded
steps. At the end of a run session, the browser returns to its default size. It is
recommended that you select this option if your test performs drag and drop
operations.

Note:

l To use this option, select theOpen the following browser option in the
Record and Run Settings dialog box before recording.

l When this option is cleared, UFT does not change the browser size when a
run session begins. If you run your steps with this option cleared, and the
select this option again, UFT opens the browser to the same size as the
previous run session, regardless of any resizing information you provided
when recording the steps.
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UI
Element Description

Learn and
run using
automatic
XPath
identifiers
(Web Add-
in only)

Generates and stores an XPath value when learningWeb test objects, and uses
that value during a run session to improve object identification reliability. During the
run session, UFT uses the learned XPath value to return the DOM element from
the application and verifies that this object matches the test object description. If it
does not, the learned XPath is ignored.

Additionally, if the description for a test object includes theXPath orCSS
identifier, or if theRun using source index option is selected, then this option is
ignored for that object. For details, see "WebObject Identifiers" on page 47.

Web Pane (Test/Business Component Settings Dialog
Box / Application Area - Additional Settings Pane)

This pane provides options for recording and running tests onWeb sites.

The following image displays theWeb pane of the Test Settings dialog box. The content of this
pane is identical to the content of theWeb pane of the Business Component Settings dialog box
and the Application Area's Additional Settings pane.
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To access Do one of the following:

l For a test or component:

Select File > Settings > Web node.

l For an application area:

Open the application area and select Additional Settings> Web in the
sidebar.

Important
information

l TheWeb pane is available only if theWeb Add-in is installed and loaded.

l Recording events. In addition to the options in this pane, you can also
configure the events you want to record for each type of Web object. For
example, if you want to record events, such as moving the pointer over an
object to open a sub-menu, youmay need tomodify yourWeb event
configuration to recognize such events. For details, see "Event Recording
Configuration forWeb-Based Applications" on page 44.

l Business components. For business components, the settings displayed in
this pane are read-only. To change theWeb pane settings for a business
component, open its associated application area and use the application area's
Additional Settings > Web pane.

User interface elements are described below:

UI
Element Description

Browser
navigation
timeout

Sets themaximum time (in seconds) that UFT waits for aWeb page to load before
running a step in the test.

User
name
(tests
only)

The user name for password-protected resources that use a standard
authenticationmechanism.

For details, see "Advanced Authentication Dialog Box" on the next page.

Password
(tests
only)

The password for password-protected resources that use a standard authentication
mechanism.

For details, see "Advanced Authentication Dialog Box" on the next page.

Advanced
(tests
only)

Opens the "Advanced Authentication Dialog Box" (described on page 81, which
enables you tomanually log in to yourWeb site to enable access to password-
protected resources that use an advanced authenticationmechanism.
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Advanced Authentication Dialog Box

This dialog box enables you to define login information, so that the Active Screen can access the
resources on a site, where the automatic Active Screen login mechanismmay not be sufficient.

To access In the "Web Pane (Test/Business Component Settings Dialog Box /
Application Area - Additional Settings Pane)", click Advanced.

For details on theWeb pane, see "Web Pane (Test/Business Component
Settings Dialog Box / Application Area - Additional Settings Pane)" on page 79.
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Important
information

l After closing this dialog box, refresh the Active Screen by selecting a new step
in the Keyword View or select View > Active Screen to re-display the Active
Screen. Confirm that the pages are displayed correctly.

If you still cannot view images or other resources on your Active Screen, you
may not be connected to the Internet, theWeb server may be down, or the
source path that was captured with the Active Screen pagemay no longer be
accurate.

l When you log in using the Advanced Authenticationmechanism, you remain
logged in to the site for the duration of the UFT session. If you close and
reopen UFT and then reopen your test, youmust log in again.

l If the site to which you log in has an inactivity timeout after which you are
automatically logged out of theWeb site, youmay need to log in using the
Advanced Authentication dialog box more than once while editing your test to
re-enable access to your Active Screen pages.

See also l "Web Pane (Test/Business Component Settings Dialog Box / Application Area
- Additional Settings Pane)" on page 79

l "Active Screen Dialog Box" on page 60

l "Accessing Password-Protected Resources in the Active Screen" on page 43

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Element Description

<browser
window>

The default Web page for the test, displayed according to the following guidelines:

l The first time you open this dialog box for a given test, the browser window
displays the URL address set for the test in theWeb tab of the Record and Run
Settings dialog box.

l If you navigate to a new URL address using this dialog box, that address
becomes the default Advanced Authentication page for this test.

Use this window to enter your login information, and after logging into your
application, click Close. The login session remains open for the remainder of your
UFT session (or until theWeb site's inactivity timeout is exceeded).

Address The URL address of theWeb page. If the displayedWeb page is not the correct
page for logging in to your site, enter the correct URL address in theAddress box
and click Go.
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Web Tab (Record and Run Settings Dialog Box)
This tab enables you to set options that instruct UFT which applications to open when you begin to
record or run your test.

You can instruct UFT to open and record on applications frommore than one environment. You can
also create steps onmore than one browser tab, if your browser supports tabbed browsing.

To access Select Record > Record and Run Settings and select theWeb tab.

Important
information

l TheWeb tab is available only when theWeb add-in is installed and loaded.
UFT uses the settings in this tab when recording and running tests or business
components onWeb, .NETWeb Forms, PeopleSoft, andWeb-based SAP
objects.

l Siebel. For Siebel objects, UFT uses the settings in the Siebel tab of the
Record and Run Settings dialog box, available when the Siebel Add-in is
installed and loaded. For details, see "Siebel Tab (Record and Run Settings
Dialog Box)" on page 377.

l Environment variables. You can also use special, predefined environment
variables to specify the applications or browsers you want to use for your test.
For details, see "Environment Variables in Record and Run Settings" on page
30.
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Relevant
tasks

l "How toModify Event Recording Configuration forWeb-Based Applications"
on page 53

l "Environment Variables for aWeb-Based Environment" on page 61

l "How to Define Record and Run Settings for UFT Add-ins" on page 33

See also l "Considerations for Testing Applications with EmbeddedWeb Browser
Controls" on page 88

User interface elements are described below:

UI Element Description

Record and
run test on
any open
browser

Instructs UFT to record and run on any open (supported)Web browser installed
locally on your computer. (For details on supported browsers, see theHP Unified
Functional Testing Product Availability Matrix, available from the UFT Help or
the root folder of the Unified Functional Testing DVD.).

Note: Youmust open theWeb browser after you open UFT.

Tip: You can instruct UFT to ignore ALM browsers or other browsers that
are open to a specified URL or have a specific title. For details, see "Web >
General Pane (Options Dialog Box)" on page 65.

Open the
following
address
when a
record or
run session
begins

Instructs UFT to open a new browser session to record and run the test using the
specified URL address.

Note: If you define a value for theURL_ENV environment variable, that
value overrides the value specified here during a run session. For details,
see "Environment Variables in Record and Run Settings" on page 30.
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UI Element Description

Open the
following
browser
when a
record or
run session
begins

Instructs UFT to open the specified browser type when recording or running a
test:

Note:

l This list shows only browsers currently installed on your computer and
the Apple Safari browser, which UFT can access on a remoteMac
computer.

l If you define a value for theBROWSER_ENV environment variable, that
value overrides the value specified here during a run session. For details,
see "Environment Variables for aWeb-Based Environment" on page 61
and "Environment Variables in Record and Run Settings" on page 30.

l If you selectMozilla Firefox, UFT opens the latest version of Mozilla
Firefox that is both installed on your computer and supported by UFT.

n If you want to open a specific version of Firefox that is not available in
this list, you can use theBROWSER_ENV environment variable as
described in "Environment Variables for aWeb-Based Environment"
on page 61.

n For a list of all supported browser versions, see theHP Unified
Functional Testing Product Availability Matrix, available from the UFT
Help or the root folder of the Unified Functional Testing DVD.
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UI Element Description

Host Name
or IP
(Remote
Connection
Details)

The host name or IP address of theMac computer to which UFT connects.

By default, UFT connects to theMac using port 8822. To use a different port,
append the port number to the host name: <hostname>:<port number>.

Make sure to configure the same port number on theMac, in the UFT Connection
Agent preferences and the Unified Functional Testing Agent extension on the
Apple Safari browser.

For more details, see "How to Connect to a RemoteMac Computer" on page
505.

Note:

l UFT uses this address whenever the test runs, whether you run it
manually in UFT or as part of an ALM test set, or any other way.

l If you want to test the connection to the host you specify, click the

Remote Connection button in the UFT toolbar, enter the host name
or IP in the dialog box that opens, and click Connect.

l If you define a value for theREMOTE_HOST environment variable, that
value overrides the value specified here during a run session.

Available only if you select Apple Safari (on remote Mac computer) from the
list of browsers.
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UI Element Description

When run
session
ends
(Remote
Connection
Details)

Available
only if you
select the
Apple Safari
browser

Specifies the procedures for UFT to perform at the end of a run session.

l Disconnect. Specifies whether to close UFT's connection to the remote
Mac.

For example:

n Select this option if a subsequent run session needs to connect to a
different Mac, or if you want to release the port so another UFT
instance can use it.

n Clear this option if you are runningmultiple tests but only the first one
sets up the remote connection.

While editing tests in UFT, you can see the connection status in the Remote

Connection dialog box (opened from the Remote Connection button in the
UFT toolbar). You can also use this dialog box tomanually close the
connection to theMac.

l Close the browser. Specifies whether to close the Apple Safari browser.

For example: 

n Select this option if the test is independent from all other tests.

n Clear this option during the design stages of your test. The browser
remains open after you run the test, and you can continue working with
the browser while you edit the test.

n Clear this option if you are runningmultiple tests but only the first test
contains a step that runs the Safari browser.

These options are available only if you select Apple Safari (on remote Mac
computer) from the list of browsers.

Do not
record and
run on
browsers
that are
already
open

Instructs UFT not to record or run tests on any browsers that are already open
prior to the start of the record or run session (and prior to opening UFT).

Selecting this option also prevents you from viewing the properties of these
browsers using the Object Spy.
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UI Element Description

Close the
browser
when the
test closes

Instructs UFT to close the browser window specified in theAddress box when
the test closes.

Examples of when to select or clear this option:

l Select this option if you are finished designing your test, and it runs
independently from all other tests.

l Clear this option during the design stages of your test. The browser
remains open after you run the test, and you can continue working with
the browser while you edit the test.

l Clear this option if you plan to runmultiple tests on the same browser, but
only the first test includes a step to open the browser.

Not available if you select Apple Safari (on remote Mac computer) from the
list of browsers.

Considerations for Testing Applications with Embedded Web Browser
Controls

l To record and run tests on an application with embeddedWeb browser controls, select Record
and run tests on any open Web browser in the Record and Run Settings dialog box.

l Register your browser control application (using the Register Browser Control Utility) so that
UFT recognizes yourWeb object when recording or running tests. For details, see "Register
Browser Control Utility" on page 63.

l Make sure that the application is opened after UFT, and start recording.
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Troubleshooting and Limitations - Web-Based
Application Support

This section contains general troubleshooting and limitation information about theWeb add-in, and
includes the following sections:

l "User Account Control (Where Applicable)" below

l "Test Objects, Methods, and Properties" below

l "Creating and Running Testing Documents" on the next page

l "Running Tests or Components in Microsoft Internet Explorer" on the next page

l "Recognition of WebTable Test Objects" on page 91

l "Checkpoints, Output Values, and the Active Screen" on page 92

l "Working with MultipleWeb Browsers" on page 92

l "Multilingual Support forWeb Browsers" on page 93

User Account Control (Where Applicable)

l If you are working on a computer where the UAC (User Account Control) option is set to ON,
UFT does not support testing onMozilla Firefox browsers that were installed (or upgraded to a
new version) after you installed UFT.

Workaround: After installingMozilla Firefox on the environment described above, log in as an
administrator and open UFT. This enables UFT to install files that are required for Mozilla Firefox
support.

Test Objects, Methods, and Properties

l Web test objects do not support the Class Name identification property. If you try to run a
ChildObjects(<Descr>) step on aWeb object, and the Descr argument includes the Class
Name property, aGeneral Run Errormessage is displayed.

Workaround: Use the micclass property in the Descr argument.

l If you record drag and drop steps on aWeb element within the same frame, the test steps may
fail during the run session if the screen resolution is not identical to the screen resolution during
the recording session. This is because the target location coordinates may be different for
different screen resolutions.

Workaround: If this problem occurs, adjust theDrop coordinates according to the new location.

l UFT records changes in the edit field only on <input type="file"> tags. Browsing operations
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are not recorded.

l Clicks on form tags of type POSTmay not run correctly.

Workaround: If this problem occurs, change the replay type before the click toRun by mouse
operations using: Setting.WebPackage("ReplayType") = 2. It is recommended to return the
replay type to the default (Run by Events) setting after the click step: Setting.WebPackage
("ReplayType") = 1.

Creating and Running Testing Documents

l If you use the Tab key when recording password fields in the AutoComplete dialog box, UFT
may record incorrectly.

Workaround: Press ENTER after entering the user name or click the button for logging in.

l WhenUFT opens a browser, it may not correctly recognizemultiple tabs that were opened and
saved from a previous browser session.

Workaround: If multiple tabs are required, open them during the run session by adding the
relevant steps to your test or business component.

Running Tests or Components in Microsoft Internet Explorer

l When usingMicrosoft Internet Explorer 7.0, UFT cannot switch to tabs that are not visible on the
tab-band without scrolling.

Workaround:Perform either of the following:

n Maximize the browser to increase the number of tabs that are visible in the tab-band without
scrolling.

n Increase the screen resolution to allow more tabs to be visible in the tab band.

l If you record a click on an area of an imagemap that is not mapped to a URL inMicrosoft
Internet Explorer, UFT will perform a click on the first mapped area of that map during the run
session.

l UFT does not record on customized toolbar buttons in Microsoft Internet Explorer. (It records
only on the toolbar buttons that are displayed by default in the browser.)

l UFT does not record on the Find window of theMicrosoft Internet Explorer browser.

l UFTmay respond slowly during a recording session if the drop-down boxes in aWeb page
contain a lot of data.

Workaround: Learn the objects on aWeb page that contains a lot of data (instead of recording).
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l If you install an update for Microsoft Internet Explorer 7 and later try to open UFT, UFT
sometimes does not open correctly. This is due to a knownMicrosoft issue in which the
urlmon.dll file becomes corrupted during theMicrosoft Internet Explorer update. For details on
this issue from theMicrosoft support site, see http://support.microsoft.com/kb/946627.

Workaround:Reinstall Microsoft Internet Explorer 7 or install a later version.

l If Internet Explorer 9 displays themessage: Speeding up browsing by disabling add-ons,
chooseDon't disable or select a bigger threshold value.

l When using Internet Explorer 9, the innertext, outertext, innerhtml and outerhtml property
values may differ from earlier versions of Internet Explorer. Therefore, using these values in
parameters or running checkpoints that use these property values may cause the steps to fail.

Recognition of WebTable Test Objects
By default, when using the UFTWeb Add-in, UFT recognizes any HTML table as aWebTable test
object.

However, in QuickTest 9.5 or 10.00, the default behavior was to ignore HTML tables with one row
and one column during Object Spy, learn, and record sessions.

In specific situations, this changed default behavior may result in differences when learning new
test objects or when running steps containingWeb test objects that were learned in QuickTest 9.5
or 10.00. For example, theChildObjectsmethodmay return a different value for parent objects that
containWeb tables.

If necessary, you can revert to the previous behavior by enabling (and optionally modifying)
abstract table support.

Abstract tables are defined in a built-inWeb Add-in Extensibility toolkit support set called
HPInternal. By default, this toolkit support set is not loaded.

To activate the abstract table support:

1. Open
<UFT installation folder>\dat\Extensibility\Web\Toolkits\HPInternal\loadalwa
ys.ind

2. Change the single line in the file to: load=true

To modify which types of tables UFT treats as an abstract table:

Edit the IsHPAbstractTable JavaScript located in:
<UFT installation folder>\dat\Extensibility\Web\Toolkits\HPInternal\HPAbstractTa
ble.js.

The sample IsHPAbstractTable JavaScript function below causes UFT to treat Web table
elements containing one row and one column as abstract tables:

function IsHPAbstractTable()
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{
// Treat all tables with only one cell as abstract tables
if ( _elem.rows.length == 1 && _elem.rows[0].cells.length == 1 )
{

return true;
}
return false;

To instruct UFT to ignore additional types of Web table elements, modify the IsHPAbstractTable
JavaScript function to return true for those types based on their HTML properties or other
information. (Use the token _elem to represent theWeb element UFT is currently handling.)

Caution: HPAbstractTable.js affects the way UFT identifies Web objects and can cause
problems if modified incorrectly. Edit this file only if you are an experienced JavaScript
programmer and are familiar with the implementation of yourWeb controls. Make sure to create
a backup copy of the file beforemaking changes.

Checkpoints, Output Values, and the Active Screen

l Checkpoints on page source/HTML tags cannot be inserted from the Active Screen andmust be
inserted while recording. These checkpoints may fail during the first run session.

Workaround:Perform an update run (Run > Update Run Mode) of your test or business
component before you run a test or business component that includes a page source/HTML tag
checkpoint.

l If you insert checkpoints from the Active Screen when you are working with an application
containing a browser control instead of aWeb browser, your checkpoints may fail.

Workaround: Insert checkpoints while recording.

l If you take a snapshot of an ASPAjaxRichTextArea object on FireFox, it might not be displayed
correctly in the Active screen.

Working with Multiple Web Browsers
UFT retrieves the CSS property values from the browser. When designing tests or components that
will run on different browsers, keep inmind that different browsers may have different CSS
functionality and return different property values for the same object.

Problem

When running steps that are intended to be performed on different browsers, and UFT tries to
perform the step intended for the second browser before the second browser has finished loading,
UFT will perform the step on the first browser, and the stepmay fail.

Solution

Insert a Wait() statement before the first step on the second browser to enable the second browser
to finish loading.
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Reason

By default, a Browser test object does not have any identification properties in its description.
When only one browser is open, the open browser matches the (empty) description for any Browser
test objects. Whenmultiple browsers are open, UFT uses smart identification or the ordinal
identifier property value stored with the relevant Browser test object to distinguish between the
browsers and to select the correct browser.

However, if a second browser has not fully loaded when UFT tries to perform a step intended for
that browser, UFT will assume that only one browser is open and it will try to perform the step on
the first browser without reverting to smart identification or ordinal identifiers.

Multilingual Support for Web Browsers

l In Internet Explorer, the AutoComplete operation on edit fields is not recorded.

Workaround: You can disable the AutoComplete feature in Microsoft Internet Explorer by
selecting Tools > Internet Options > Advanced and deselecting theUse inline
AutoComplete under theBrowsing options in Microsoft Internet Explorer.

l If a test or business component contains a step that closes aMozilla Firefox browser, UFT may
behave unexpectedly when that step is reached during a run session.

Workaround:Do not include a step that closes aMozilla Firefox browser.
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Chapter 3: Windows-Based Application Support
This chapter includes:

Concepts 95

Windows-Based Application Support - Overview 95

UFT Configuration forWindows-Based Applications 96

Record and Run Settings forWindows-Based Applications 96

Reference 97

Environment Variables forWindows-based Applications 97

Windows Applications > General Pane (Options Dialog Box > GUI Testing Tab) 98

Windows Applications > Advanced Pane (Options Dialog Box > GUI Testing Tab) 101

Windows Applications Tab (Record and Run Settings Dialog Box) 109
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Concepts

Windows-Based Application Support - Overview
UFT provides a number of add-ins for testingWindows-based applications.

The way you configuremany of your UFT options is the same or similar for most UFTWindows-
based add-ins (as well as for the built-in standardWindows testing support). For details, see "UFT
Configuration forWindows-Based Applications" on the next page.

Many UFT add-ins rely on the settings in the "Windows Applications Tab (Record and Run Settings
Dialog Box)" (described on page 109) to determine on which applications UFT records and runs. For
some add-ins, these settings may also affect the applications that UFT recognizes for certain
operations while in edit mode, such as using the Object Spy or other pointing hand operations.

You can also use predefined environment variables to specify the applications or browsers you
want to use for your test. This can be useful if you want to test how your application works in
different environments.

Theremay also be additional issues that you need to address to ensure that UFT recognizes your
objects properly during record, run, and/or pointing hand operations. For details, see "Record and
Run Setting Guidelines forWindows-Based Add-ins" on page 116.

For details about standardWindows testing support, see "StandardWindows Support -
Quick Reference" on page 392

For details on how to work withWindows-based add-ins, see the specific sections describing these
add-ins in the guide:

l "ActiveX Add-in - Quick Reference" on page 161

l "Delphi Add-in - Quick Reference" on page 168

l ".NETWindows Forms Support - Quick Reference" on page 132

l "PowerBuilder Add-in" on page 263

l "Qt Add-in" on page 268

l "Windows-based SAP Support - Quick Reference" on page 286

l "Stingray Add-in" on page 395

l "Terminal Emulator Add-in" on page 428

l "VisualAge Smalltalk Add-in" on page 486

l "Visual Basic Add-in" on page 490
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UFT Configuration for Windows-Based Applications
Use theWindows Applications pane of the Options dialog box (Tools > Options > GUI Testing
tab > Windows Applications node) to configure general and advancedWindows-based
application options, as follows:

l General options. Configure how UFT records and runs tests and business components for
Windows-based applications, such as standardWindows, ActiveX, .NETWindows Forms,
WPF, SAP GUI forWindows, and Visual Basic applications. For details, see "Windows
Applications > General Pane (Options Dialog Box > GUI Testing Tab)" on page 98.

Tip:When recording tests or scripted components onWindows-based applications, you
can choose to save all Active Screen information in every step, save information only in
certain steps, or disable Active Screen captures entirely. You set this preference in the
Active Screen pane of the Options dialog box (Tools > Options > GUI Testing tab >
Active Screen node). The less information saved, the faster your recording times will be.

This option is not relevant for keyword components.

For details, see the section describing the Active Screen pane in theHP Unified Functional
Testing User Guide.

l Advanced options. Modify how UFT records and runs tests or business components on
Windows-based applications, such as ActiveX or Visual Basic. For details, see "Windows
Applications > Advanced Pane (Options Dialog Box > GUI Testing Tab)" on page 101.

Record and Run Settings for Windows-Based
Applications

You can set options that affect how you start creating and running tests forWindows-based
applications in the "Windows Applications Tab (Record and Run Settings Dialog Box)" (described
on page 109). These options instruct UFT which applications to open when you begin to record or
run your test.

Additionally, you can specify the applications on which you want to record in the "Application
Details Dialog Box" (described on page 113). You can use environment variables to define the
details for theWindows-based applications on which you want to record and run tests. If you do
this, use the appropriate variable names as specified in "Environment Variables forWindows-based
Applications" on the next page.

Note: The Record and Run Settings dialog box applies only to tests. Record settings for
business components are specified in the Applications pane or Applications dialog box of the
relevant application area. However, specific record and run settings do not need to be defined
for business components. For details on the Applications pane in the Additional Settings pane
of an application area, see theHP Unified Functional Testing User Guide.
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Reference

Environment Variables for Windows-based Applications
You can use environment variables to define the details for theWindows-based applications on
which you want to record and run tests. If you do this, use the appropriate variable names as
specified below.

Note:

l For details on environment variables and how to use them in tests, see "Environment
Variables in Record and Run Settings" on page 30.

l The environment variables described in this section correspond with the settings you define
in the "Application Details Dialog Box" (described on page 113).

Option
Variable
Names Description

Application EXE_ENV_1
EXE_ENV_10

The executable files on which UFT records operations when
record and run sessions begin. You can specify up to ten
executable files.

Working
folder

DIR_ENV_1
DIR_ENV_10

The folder to which the corresponding executable file refers (for
each corresponding application).

Program
arguments

ARGS_ENV_1
... ARGS_
ENV_10

The command line arguments to be used for the specified
application (for each corresponding application).

Launch
application

LNCH_ENV_1
... LNCH_
ENV_10

Whether to open the application when starting the record and run
session (for each corresponding application).

Possible values:

l 0 (do not launch the application)

l 1 (launch the application)

Include
descendant
processes

CHLD_ENV_1
... CHLD_
ENV_10

Whether to record and run on processes created by the
application during the record and run session (for each
corresponding application).

Possible values:

l 0 (do not record on descendant processes)

l 1 (record descendant processes)
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Windows Applications > General Pane (Options Dialog
Box > GUI Testing Tab)

This pane enables you to configure how UFT records and runs tests and business components for
Windows-based applications.

To access Select Tools > Options > GUI Testing tab >Windows Applications >
General node.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

See also l "Windows Applications > Advanced Pane (Options Dialog Box >
GUI Testing Tab)" on page 101

l "Windows Applications Tab (Record and Run Settings Dialog Box)" on
page 109

l "Windows-Based Application Support - Overview" on page 95

l "UFT Configuration forWindows-Based Applications" on page 96
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User interface elements are described below:

UI
Elements Description

Attached
text

The search criteria that UFT uses to retrieve an object's attached text. An object's
attached text is the closest static text within a specified radius from a specified
point. The retrieved attached text is saved in the object's corresponding text or
attached text identification property.

Note: Sometimes the static text that you believe to be closest to an object is
not actually the closest static text. Youmay need to use trial and error to make
sure that the attached text is the static text object of your choice

Search radius. Themaximum distance, in pixels, that UFT searches for attached
text.

Search area. The point on an object from which UFT searches for the object's
attached text.

Select an option from theSearch area list:

l Top-Left. Top-left corner

l Top.Midpoint between the two top corners

l Top-Right. Top-right corner

l Right.Midpoint between the two right corners

l Bottom-Right. Bottom-right corner

l Bottom.Midpoint between the two bottom corners

l Bottom-Left. Bottom-left corner

l Left.Midpoint between the two left corners

Add-ins Guide
Chapter 3: Windows-Based Application Support

HP Unified Functional Testing (12.00) Page 99 of 549



UI
Elements Description

Open
menu to
retrieve
item
properties

Instructs UFT to open StandardWindows menu objects before retrievingmenu item
properties during a run session.

Note:

l Selecting this optionmay slow the run, but it can be useful if menu item
properties change upon opening themenu.

l This option, which is selected by default, sets the default behavior for all
menu objects. You can use theExpandMenu property in a test or function
library to set this behavior for a specifiedmenu object. For details, see the
HP UFT Object Model Reference for GUI Testing.

Learn
non-
unique
list items

Determines what UFT learns whenmore than one item (in a StandardWindows list
or tree) has an identical name.

l by name. Learns the item's name.

During a run session, UFT finds and selects the first instance of the name,
regardless of the item chosen when learning. Select this option if the all items
with the same name have the identical behavior.

l by index. Learns the item's index number.

Select this option if items with the same name do not necessarily have the
identical behavior.

Learn
owner-
drawn
buttons
as

Instructs UFT how to identify and learn StandardWindows custom-made buttons in
the application.

Select an option from the list:

l push buttons

l check boxes

l radio buttons

l objects

Note: If you select objects, UFT learns each owner-drawn button as a
WinObject. (When working with tests, UFT can also learn an owner-drawn
button as a virtual object, if you define the virtual object. For details, see the
section on learning virtual objects in theHP Unified Functional Testing User
Guide.)
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Windows Applications > Advanced Pane (Options Dialog
Box > GUI Testing Tab)

This pane enables you tomodify how UFT records and runs tests or business components on
Windows-based applications.

To access Select Tools > Options > GUI Testing tab > Windows Applications >
Advanced node.

Important
Information

For advancedWindows-based application testing information, intended for users
with expertise in theWin32 API and theWindows messages model, see
"Considerations for AdvancedWindows-based Application Testing" on page 107.

See also "Windows-Based Application Support - Overview" on page 95

User interface elements are described below:

UI Elements Description

Object Identification node
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UI Elements Description

Always
enumerate
child windows
(may affect
performance)

Instructs UFT to enumerate all child windows when recording a running a test
or business component.

Caution: This option is cleared by default and should be used only when
an object cannot otherwise be identified, because it may significantly
affect performance. For details, see "Considerations for Advanced
Windows-based Application Testing" on page 107.

Record Settings node

Button Defines record settings for button objects:

l Record only the object's basic operation. Enables simplified recording
on the button. Using this modemay improve recognition of user operations
in non-standard cases.

Note: This option is cleared by default and should be used only when
the default recordingmethod does not meet your needs. For details,
see "Considerations for AdvancedWindows-based Application
Testing" on page 107.

l Record Click. Specifies whether theClick operation should be recorded
when themouse button is pressed (On mouse button down) or when the
mouse button is released (On mouse button up).

Note: This option is enabled only whenRecord only the object's
basic operation is selected.

Default = On mouse button up.
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UI Elements Description

List Defines record settings forWindows-based list objects (for example,
WinList, WinListView, and VbList):

l Record only the object's basic operation. Enables simplified recording
on the list. Using this modemay improve recognition of user operations in
non-standard cases.

Note: This option is cleared by default and should be used only when
the default recordingmethod does not meet your needs. For details,
see "Considerations for AdvancedWindows-based Application
Testing" on page 107.

l Record Select. Specifies whether theSelect operation should be
recorded when themouse button is pressed (On mouse button down) or
when themouse button is released (On mouse button up).

Default = On mouse button up.

Menu Defines record settings for menu objects:

l Enable recording. Specifies whether UFT records operations onmenu
controls. For example, youmay want UFT to ignore the actual process of
selecting amenu to open another window.

This option is selected by default.

l Menu recording mode. Specifies whether UFT verifies or ignores menu
initialization events before recording operations onmenu controls.

Note: This option is enabled only whenEnable recording is
selected. For details, see "Considerations for AdvancedWindows-
based Application Testing" on page 107.

Default = Verify menu initialization event.
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UI Elements Description

Object Defines record settings for objects recognized as WinObject test objects:

l Record only the object's basic operation. Enables simplified recording
on theWinObject test object. Using this modemay improve recognition of
user operations in non-standard cases.

Note: This option is cleared by default and should be used only when
the default recordingmethod does not meet your needs. For details,
see "Considerations for AdvancedWindows-based Application
Testing" on page 107.

l Record Click. Specifies whether theClick operation should be recorded
when themouse button is pressed (On mouse button down) or when the
mouse button is released (On mouse button up).

Note: This option is enabled only whenRecord only the object's
basic operation is selected.

Default = On mouse button down.

Tab Defines record settings for tab objects:

l Record only the object's basic operation. Enables simplified recording
on the tab. Using this modemay improve recognition of user operations in
non-standard cases.

Note: This option is cleared by default and should be used only when
the default recordingmethod does not meet your needs. For details,
see "Considerations for AdvancedWindows-based Application
Testing" on page 107.

l Record Select. Specifies whether theSelect operation should be
recorded when themouse button is pressed (On mouse button down) or
when themouse button is released (On mouse button up).

Note: This option is enabled only whenRecord only the object's
basic operation is selected.

Default = On mouse button up.
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UI Elements Description

Toolbar Defines record settings for toolbar objects:

l Record only the object's basic operation. Enables simplified recording
on the toolbar. Using this modemay improve recognition of user
operations in non-standard cases.

Note: This option is cleared by default and should be used only when
the default recordingmethod does not meet your needs. For details,
see "Considerations for AdvancedWindows-based Application
Testing" on page 107.

l Record Press. Specifies whether thePress operation should be recorded
when themouse button is pressed (On mouse button down) or when the
mouse button is released (On mouse button up).

Note: This option is enabled only whenRecord only the object's
basic operation is selected.

Default = On mouse button up.

Tree view Defines record settings for tree view objects:

l Record only the object's basic operation. Enables simplified recording
on the tree view. Using this modemay improve recognition of user
operations in non-standard cases.

This option is cleared by default and should be used only when the default
recordingmethod does not meet your needs. For details, see
"Considerations for AdvancedWindows-based Application Testing" on
page 107.

l Record Select. Specifies whether theSelect operation should be
recorded when themouse button is pressed (On mouse button down) or
when themouse button is released (On mouse button up).

Note: This option is enabled only whenRecord only the object's
basic operation is selected.

Default = On mouse button up.

l Record tree items. Specifies whether tree items are recordedBy name
orBy virtual index.

Default = By name.
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UI Elements Description

Window Defines record settings for window objects:

l Record only the object's basic operation. Enables simplified recording
on the window. Using this modemay improve recognition of user
operations in non-standard cases.

Note: This option is cleared by default and should be used only when
the default recordingmethod does not meet your needs. For details,
see "Considerations for AdvancedWindows-based Application
Testing" on the next page.

l Record Click. Specifies whether theClick operation should be recorded
when themouse button is pressed (On mouse button down) or when the
mouse button is released (On mouse button up).

Note: This option is enabled only whenRecord only the object's
basic operation is selected.

Default = On mouse button up.

Keyboard Defines record settings for operations performed on the keyboard:

l Keyboard state detection. Specifies which API UFT should use to
detect the keyboard state.

Default = Standard.

For details, see "Considerations for AdvancedWindows-based
Application Testing" on the next page.

Utility object Defines record settings for utility objects:

Record SystemUtil.Run commands. Specifies whether UFT records
SystemUtil.Run commands when you open an application during a recording
session.

This option is selected by default. For details on theSystemUtil.Run
method, see theHP UFT Object Model Reference for GUI Testing.

Run Settings node
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UI Elements Description

Edit Box Defines run settings for Edit objects:

l Click Edit box before inserting text. Specifies whether UFT performs a
Click operation to set the focus in an edit box before inserting text in it
while running a test or business component.

This option is cleared by default.

l Use keyboard events to perform Set operations. When selected,
instructs UFT to simulate keyboard events when performingSet
operations on edit boxes during a run session. When cleared, instructs
UFT to use API orWindow messages for edit box Set operations.

This option is cleared by default.

Bottom area

Description Describes the selected option.

Reset button Resets all options in the pane to their default values.

Considerations for Advanced Windows-based Application Testing

The following information is intended for users with expertise in theWin32 API and theWindows
messages model. It expands on the information provided for some of the options described in
"Windows Applications > Advanced Pane (Options Dialog Box > GUI Testing Tab)" on page 101.

Always enumerate child windows
If UFT does not correctly record an object in your application, you can select this option to force
UFT to enumerate all windows in the system. This means that even when UFT looks for a window
without WS_CHILD style, it enumerates all windows in the system and not only the top-level
windows.

You should select this option if there is a window in your application that does not have a WS_CHILD
style but does have a parent (not an owner) window.

Record only the object's basic operation
In general, UFT records operations onWindows objects based onWindows messages sent by the
application. UFT recognizes the sequence of Windows messages sent to a specific application
window by the system, and uses a smart algorithm to determine which operation to record.

In rare cases (where a non-standardmessage sequence is used), the smart algorithmmay record
unwanted operations. Select this option if you want to record only the object's basic operation when
the selected event occurs. When you select this option, you can also select when to record the
operation. If you select On mouse button down, UFT records the operation performed when a WM_
LBUTTONDOWNmessage is detected; if you select On mouse button up, UFT records the operation
performed when a WM_LBUTTONUPmessage is detected.
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Keyboard state detection
If UFT does not correctly record keyboard key combinations (for example, CTRL+Y, or
ALT+CTRL+HOME), you can try changing the default setting for this option. Following is a brief
explanation of each of the options:

l Standard. Uses theGetKeyboardStateAPI to detect the keyboard state. For details, see
http://msdn2.microsoft.com/en-us/library/ms646299.aspx.

l Alternate synchronous. Uses theGetKeyStateAPI to detect the keyboard state. For details,
see http://msdn2.microsoft.com/en-us/library/ms646301.aspx.

l Alternate asynchronous. Uses theGetAsyncKeyStateAPI to detect the keyboard state. For
details, see http://msdn2.microsoft.com/en-us/library/ms646293.aspx.

Menu recording mode
In most applications, Windows sends a WM_CONTEXTMENUmessage, WM_ENTERMENULOOP message,
WM_INITMENUmessage, WM_INITMENUPOPUPmessage, or other initializationmessage when a user
opens amenu. Windows then sends a WM_MENUSELECTmessage when a user selects amenu item.

TheVerify menu initialization event option instructs UFT to recordmenu operations only after
detecting amenu initializationmessage. If UFT does not correctly recordmenu operations, or if
your application does not send initializationmessages before sending WM_MENUSELECTmessages,
try using the Ignore menu initialization event option. This instructs UFT to always recordmenu
operations.
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Windows Applications Tab (Record and Run Settings
Dialog Box)

This tab enables you to define preferences for recording and running tests onWindows-based
applications.

To access Select Record > Record and Run Settings and then select theWindows
Applications tab.

Note: The Record and Run Settings dialog box also opens automatically
each time you begin recording a new test (unless you open the dialog box and
set your preferences manually before you begin recording).
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Important
information

l You can instruct UFT to open and record on applications frommore than one
environment.

l For someWindows-based add-ins, the settings in this dialog box may also
affect the applications that UFT recognizes for other UFT operations, such as
learning objects or using the Object Spy. For details, see "Record and Run
Setting Guidelines forWindows-Based Add-ins" on page 116.

l For performance reasons, the default setting in theWindows Applications tab
is set to record and run only on the applications you specify (and not on any
open application). If you do not specify an application or change this option,
UFT will not record or run on any Windows-based application.

l If you loaded other add-ins when you opened UFT, theremay be additional
tabs in the Record and Run Settings dialog box. If this is the case, confirm that
in each additional tab, the option to record and run on any open application
(upper radio button of each tab) is selected.

While this setting does not directly affect your record or run sessions, it
prevents UFT from opening unnecessary applications when you begin record
or run sessions.

See also l "Record and Run Settings forWindows-Based Applications" on page 96

l "Record and Run Setting Guidelines forWindows-Based Add-ins" on page 116

l "Environment Variables forWindows-based Applications" on page 97

l "Environment Variables in Record and Run Settings" on page 30

l "Application Details Dialog Box" on page 113

l "Record and Run Settings for Add-ins - Overview" on page 28

l "Windows-Based Application Support - Overview" on page 95
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User interface elements are described below:

UI
Elements Description

Record and
run test on
any open
Windows-
based
application

Instructs UFT to record all operations performed on any Windows-based
application that is opened while recording your test (including e-mail applications,
file management applications, and so on). UFT records and runs only on
applications that have a user interface, and it does not matter how the applications
are opened (as child processes of Windows Explorer, child processes of UFT,
and so on).

When selecting this option, make sure that all the applications on which you want
to record are currently closed. For some environments, UFT can recognize and/or
record on the applications that you openmanually only after you select this option
and click OK. Instances of these applications that are already open when the
Record and Run Settings dialog box opens may be ignored or may not be
recognized or recorded correctly.
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UI
Elements Description

Record and
run only on

Restricts record and run (and in some cases pointing hand) operations to selected
applications. Additionally, you can configure whether UFT should open these
applications for you at the beginning of a record or run session. The following
options are available:

l Applications opened by UFT. This option records, recognizes, and runs only
on applications invoked by UFT (as child processes of UFT). For example,
applications opened during a record or run session using a SystemUtil.Run
statement, or using a statement such as Set shell = createobject
("wscript.shell")shell.run "notepad".

l Applications opened via the Desktop (by the Windows shell). This option
records, recognizes, and runs only on applications that are opened via the
Windows Desktop. For example, applications opened from theWindows Start
menu, by double-clicking executable files in theWindows Explorer, by double-
clicking a shortcut on theWindows Desktop, or by clicking icons on theQuick
Launch bar.

l Applications specified below. This option records, recognizes, and runs
only on applications listed in the Application details area.

Tip:

l If you do not want to record on any Windows-based applications, select
only theApplications specified below check box, and ensure that there
are no applications listed in theApplication details area.

l Make sure that all the applications listed in theApplication details area
are currently closed. For some environments, UFT can record only on the
instances of the specified applications that are opened after you select
this option and click OK. Instances of these applications that are already
open when the Record and Run Settings dialog box opens may be ignored
or may not be recognized or recorded correctly.

Application
details

The details of the applications on which to record and run the test. For details on
the details displayed, see "Application Details Dialog Box" on the next page.

Note: If you define values for one or more environment variables, those
values override the values in theWindows Applications tab during a test run.
For details, see "Environment Variables in Record and Run Settings" on page
30.
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UI
Elements Description

Add. Opens the "Application Details Dialog Box" (described on page 113 to
enable you to add an application to the application list. You can add up to ten
applications.

Edit. Opens the "Application Details Dialog Box" (described on page 113) to
enable you to edit the application details for the selected application.

Delete. Removes the selected application from the application list.

Application Details Dialog Box

This dialog box enables you to add details for an application or to edit details for the application that
you selected in theWindows Applications tab of the Record and Run Settings dialog box.

To access In the "Windows Applications Tab (Record and Run Settings Dialog Box)"

(described on page 109), click theAdd button orEdit button .

Note: The Record and Run Settings dialog box also opens automatically
each time you begin recording a new test (unless you open the dialog box and
set your preferences manually before you begin recording).
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Important
information

l You can add up to ten applications to the application list displayed in the
Windows Applications tab, and you can edit an existing application in the list.
You can also select whether to launch the selected applications when the
session starts, and whether to record and run on the application's descendant
processes.

l The details entered in the Application Details dialog box are displayed as a
single list item for each application in the Application details area of the
Windows Applications tab.

See also l "Windows Applications Tab (Record and Run Settings Dialog Box)" on page
109

l "Windows Applications > General Pane (Options Dialog Box > GUI Testing
Tab)" on page 98

l "Windows Applications > Advanced Pane (Options Dialog Box > GUI Testing
Tab)" on page 101

l "Record and Run Settings for Add-ins - Overview" on page 28

l "Record and Run Settings forWindows-Based Applications" on page 96

"Windows-Based Application Support - Overview" on page 95
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User interface elements are described below:

UI
Elements Description

Application The executable file on which to record.

You can enter the executable file as a relative path. During the run session, UFT
searches for the file in the folder for the current test, and then in the folders listed
in the Folders pane of the Options dialog box (Tools > Options > GUI Testing
tab > Folders node). For details, see the sections on setting folder testing
options, and on using relative paths in theHP Unified Functional Testing User
Guide.

Note:

l TheApplication box should contain only the file name and path for the
application. If you want to add command line arguments, use the
Program arguments box.

l The full path name is used to launch an application only when Launch
application is selected. UFT records and runs on any application with the
specified executable file name. For example, if you specify
%SYSTEMROOT%\Notepad.exe, UFT records on a Notepad application
invoked from any folder.

Tip: You can specify a document or other file associated in the file system
with an application, for example, c:\tmp\a.txt. In this case, UFT
automatically opens the specified file in the associated application (Notepad
in this example). If you use this option, UFT ignores any defined program
arguments.

Working
folder

(Optional) The current working folder for the application. The current working folder
is used by the application to search for related files. If a working folder is not
specified, the executable folder is used as the working folder.

Note: This parameter is used only when Launch application is selected. If
Launch application is not selected, its value has no effect.

Program
arguments

(Optional) Instructs UFT to open the application using the specified command line
arguments.

Note: This parameter is used only when Launch application is selected. If
Launch application is not selected, its value has no effect.
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UI
Elements Description

Launch
application

Instructs UFT whether to launch the selected application when the record and run
session begins. By default, this option is selected.

Include
descendant
processes

Instructs UFT whether to record and run on processes created by the specified
application during the record and run session. For example, a process that is used
only as a launcher may create another process that actually provides the
application functionality. This descendant process must therefore be included
when recording or running tests on this application, otherwise the functionality will
not be recorded, or the run session will fail.

By default, this option is selected.

Record and Run Setting Guidelines for Windows-Based Add-ins

Special considerations are detailed below for each UFT add-in that is affected by the settings in the
"Windows Applications Tab (Record and Run Settings Dialog Box)" (described on page 109).

Add-in
Environment Guidelines

ActiveX l If you select theRecord and Run only on radio button, the settings also
define and limit which applications are recognized by the Object Spy and
other pointing hand operations.

l UFT recognizes ActiveX objects only in applications that are opened after
changing the settings in the "Windows Applications Tab (Record and Run
Settings Dialog Box)" (described on page 109).

Delphi l UFT recognizes only Delphi applications that have been precompiled with
the Delphi agent module (MicDelphiAgent.pas). For details, see "How to
Enable Communications Between UFT and Your Delphi Application" on
page 171.

l In some cases, if you select theRecord and Run only on radio button, the
settings may also define and limit which applications are recognized by the
Object Spy and other pointing hand operations.

.NET
Windows
Forms

If you select theRecord and Run only on radio button, the settings also
define and limit the applications that are recognized by the .NETWindows
Forms Spy, the Object Spy, and other pointing hand operations.

.NET
Windows
Presentation
Foundation
Environment

If you select theRecord and Run only on radio button, the settings also define
and limit the applications that are recognized by the .NET Spy, the Object Spy,
and other pointing hand operations.

Add-ins Guide
Chapter 3: Windows-Based Application Support

HP Unified Functional Testing (12.00) Page 116 of 549



Add-in
Environment Guidelines

PowerBuilder If you select theRecord and Run only on radio button, the settings also
define and limit the applications that are recognized by the Object Spy and other
pointing hand operations.

Standard
Windows

l TheRecord and Run only on radio button applies only to record and run
sessions. UFT recognizes all standardWindows objects for Object Spy and
pointing hand operations, regardless of the settings in the Record and Run
Settings dialog box.

l It is recommended that applications are opened after changing the settings
in the "Windows Applications Tab (Record and Run Settings Dialog Box)"
(described on page 109).

Stingray l In addition to the settings in the Record and Run Settings dialog box, you
must also configure UFT to recognize your Stingray applications in the
Stingray pane of the Options dialog box (Tools > Options > GUI Testing
tab > Stingray node). For details, see "Stingray Pane (Options Dialog Box >
GUI Testing Tab)" on page 422.

l If you select theRecord and Run only on radio button, the settings also
define and limit the applications that are recognized by the Object Spy and
other pointing hand operations.

Terminal
Emulators

l UFT recognizes only the terminal emulator set in the Terminal Emulator
pane of the Options dialog box (Tools > Options > GUI Testing tab >
Terminal Emulator node). For details, see "Terminal Emulator Pane
(Options Dialog Box > GUI Testing Tab)" on page 457.

l TheRecord and Run only on radio button does not affect the applications
on which UFT records, recognizes, and runs.

Visual Basic l If you select theRecord and Run only on radio button, the settings may
also define and limit the applications that are recognized by the Object Spy
and other pointing hand operations.

l UFT recognizes Visual Basic objects only in applications that are opened
after changing the settings in the "Windows Applications Tab (Record and
Run Settings Dialog Box)"(described on page 109).

VisualAge l UFT can recognize only VisualAge Smalltalk applications that have been
precompiled with theVisualAge Smalltalk agent (qt-adapter). For details,
see "How to Configure the VisualAge Smalltalk Add-in" on page 489.

l TheRecord and Run only on radio button applies only to record and run
sessions. UFT recognizes all VisualAge Smalltalk objects for Object Spy
and pointing hand operations, regardless of the settings in the Record and
Run Settings dialog box.
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Chapter 4: .NET Add-in - Overview
You can use the UFT .NET Add-in to test user interface objects (controls) in Silverlight, .NETWeb
Forms, .NETWindows Forms, andWindows Presentation Foundation applications. You can create
and run tests and business components on these objects, and check their properties.

This section contains:

l ".NET Silverlight Add-in" on page 120

l ".NETWeb Forms Add-in" on page 126

l ".NETWindows Forms Add-in" on page 132

l ".NETWindows Presentation Foundation Add-in" on page 152
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Chapter 5: .NET Silverlight Add-in
This chapter includes:

".NET Silverlight Add-in - Quick Reference" below

.NET Silverlight Add-in - Quick Reference
You can use the UFT Silverlight Add-in to test user-interface objects (controls) in Silverlight
applications.

The following tables summarize basic information about the Silverlight Add-in and how it relates to
some commonly-used aspects of UFT.

General

Add-in Type This is aWeb-based add-in. Much of its functionality is the same as other
Web-based add-ins.

This add-in is installed as a sub add-in of the .NET Add-in.

See "Web-Based Application Support" on page 39.

Supported
Environments

For details on supported Silverlight environments, see the .NET Add-
insection of theHP Unified Functional Testing Product Availability Matrix,
available from the UFT Help or the root folder of the Unified Functional
Testing DVD.

Important
Information

l Towork with the Silverlight Add-in, your Silverlight applicationmust be
initialized with theEnableHtmlAccess property value set to 'True'. For
details, see http://msdn.microsoft.com/en-us/library/cc838264.aspx

l Registering Microsoft sslauncher.exe. You can use the UFT
Silverlight Add-in to test Silverlight out-of-browser applications. To do this
youmust register theMicrosoft sslauncher.exe as a browser control.
This executable is located in the Silverlight installation folder, for
example, %ProgramFiles%\Microsoft Silverlight. You can do this
using the UFT Register Browser Control Utility, which is available from
Start > All Programs > HP Software > HP Unified Functional
Testing > Tools > Register New Browser Control. For details, see
"Registering Browser Controls" on page 42.

Note: For details on accessing UFT and UFT tools and files in
Windows 8, see "Accessing UFT inWindows 8Operating Systems"
on page 547.
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Test Object
Methods and
Properties

The Silverlight Add-in provides test objects, methods, and properties that
can be used when testing objects in Silverlight applications. For details, see
theSilverlight section of theHP UFT Object Model Reference for GUI
Testing.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

Extending the
Silverlight Add-
in

"Silverlight Add-in Extensibility " (described on page 123 enables you to
develop support for testing third-party and custom Silverlight controls that
are not supported out-of-the-box by the UFT Silverlight Add-in.

Troubleshooting
and Limitations

"Troubleshooting and Limitations - Silverlight Add-in" on page 124.

Prerequisites

Opening Your
Application

Youmust open UFT before opening your Silverlight application.

Add-in
Dependencies

TheWeb Add-in must be loaded.

Other l Towork with the Silverlight Add-in, .NET FrameWork 3.0 or later must be
installed on your computer.

l To test yourWeb application in Mozilla Firefox, youmust enable the Unified
Functional Testing Extension in one of the following ways:

n If theSelect Your Add-ons screen is displayed when you open Firefox,
select to keep the Unified Functional Testing Extension.

n If the Install Add-on tab opens and displays Unified Functional Testing
Extension when opening Firefox, select theAllow this installation
check box and click Continue.

Otherwise:

i. In Firefox, select Tools > Add-ons.

ii. In the General tab, click Manage Add-ons.

iii. In the Add-ons Manager tab, select theExtensions node.

iv. In the Unified Functional Testing Extension row, click theEnable
button.

Configuration

Add-ins Guide
Chapter 5: .NET Silverlight Add-in

HP Unified Functional Testing (12.00) Page 121 of 549



Options Dialog Box Use theWeb pane.
(Make sure that a GUI test is open and select Tools > Options >
GUI Testing tab > Web > General node.)

See "Web > General Pane (Options Dialog Box)" on page 65.

Record and Run Settings
Dialog Box
(tests only)

Use theWeb tab.
(Record > Record and Run Settings.)

See "Web Tab (Record and Run Settings Dialog Box)" on page
83.

Test Settings Dialog Box
(tests only)

Use theWeb pane.
(File > Settings > Web node)

See "Web Pane (Test/Business Component Settings Dialog Box
/ Application Area - Additional Settings Pane)" on page 79.

Custom Active Screen
Capture Settings Dialog
Box
(tests only)

Use theWeb section.
(Tools > Options > GUI Testing tab > Active Screen node >
Custom Level)

See the section on the Custom Active Screen Capture Settings
dialog box in theHP Unified Functional Testing User Guide.

Application Area
Additional Settings pane
(business components only)

Use theWeb pane.
In the application area, select Additional Settings > Web in the
sidebar.

See "Web Pane (Test/Business Component Settings Dialog Box
/ Application Area - Additional Settings Pane)" on page 79.

This section includes

Concepts 123

Silverlight Add-in Extensibility 123

References 124

Troubleshooting and Limitations - Silverlight Add-in 124
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Concepts

Silverlight Add-in Extensibility

UFT Silverlight Add-in Extensibility enables you to develop support for testing third-party and
custom Silverlight controls that are not supported out-of-the-box by the UFT Silverlight Add-in.

If the test object class that UFT uses to represent a control does not provide the operations and
properties necessary to operate on your control, you can use Silverlight Add-in Extensibility to
create a new test object class.

You can thenmap the control to the new test object class, and design the test object class behavior
using .NET programming. You can program how operations are performed on the control, how
properties are retrieved, andmore.

You can also teach UFT to treat a control that contains a set of lower-level controls as a single
functional control, instead of relating to each lower-level control separately.

To implement Silverlight Add-in Extensibility, you need to be familiar with:

l UFT and its Object Model Reference

l The behavior of the custom control (operations, properties, events)

l .NET programming in C#

l XML (basic knowledge)

You can install theWPF and Silverlight Add-in Extensibility SDK from theAdd-in Extensibility
and Web 2.0 Toolkits option in the UFT setup program.

The SDK also includes project templates and a wizard for Microsoft Visual Studio, that simplify
setting up of your Silverlight Add-in Extensibility project.

For details on implementing Silverlight Add-in Extensibility, see theWPF and Silverlight Add-in
Extensibility Help, available from the UFT Extensibility Documentation program group (Start > All
Programs > HP Software > HP Unified Functional Testing > Extensibility >
Documentation).

Note: For details on accessing UFT and UFT tools and files inWindows 8, see "Accessing
UFT inWindows 8Operating Systems" on page 547.

A printer-friendly (PDF) version of theHP Unified Functional TestingWPF and Silverlight Add-in
Extensibility Developer Guide is available in the <Unified Functional Testing installation
folder>\help\Extensibility folder.
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References

Troubleshooting and Limitations - Silverlight Add-in

This section describes troubleshooting and limitations for the Silverlight Add-in, and contains the
following sections:

l "General" below

l "Checkpoints" below

l "Creating and editing testing documents" below

l "Running steps on Silverlight applications" on the next page

General

l UFT retrieves incorrect values for the all items and selection properties for ListBox and
ComboBox controls that are bound to data via a template.

l If a recovery scenario uses theObject State trigger, the followingmay occur:

n The recovery scenario may detect redundant test objects when checking aSlvWindow
state.

n The run results may not include all nodes related to the recovery scenario.

l You cannot create a virtual object for an area in a Silverlight application.

Checkpoints

l If you insert a text area checkpoint or a text area output value using theWindows API text
recognitionmechanism (as opposed to the OCR mechanism), all of the text on the Silverlight
control is captured (instead of only the text from the selected area).

l For some test objects, if you try to insert a text checkpoint from the Active Screen, the text
checkpoint cannot be inserted and an error message is displayed.

Creating and editing testing documents

l Recording on windowless Silverlight applications is not supported onMozilla Firefox.

l If you open a Silverlight context menu when creating or editing a test, youmust close the
context menu control (for example, by pressingESC) before you close the browser. Otherwise,
during a run session, the browser window will remain open.
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Workaround:Add the following line to the test before the line that closes the browser:

Browser("SilverLightAUT").Page("SilverLightAUT").SlvWindow("Page").SlvButt
on("Login").Type micEsc

Example:

Browser("SilverLightAUT").Page("SilverLightAUT").SlvWindow("Page").SlvButt
on("Login").ShowContextMenu
Browser("SilverLightAUT").Page("SilverLightAUT").SlvWindow("Page").SlvButt
on("Login").Type micEsc
Browser("SilverLightAUT").Close

Running steps on Silverlight applications

l If aWeb page contains a Silverlight application that is windowless and is scrolled out of view
when the page opens the first time, UFT will not be able tomake this application visible. (For
example, in this scenario, UFT will not be able to perform an SlvWindow.MakeVisible step).

l In some versions of Internet Explorer, the Silverlight application becomes active only after a
Click operation is performed. In these cases, UFT may fail to run test steps unless an initial
Click operation is performed.

Workaround: Insert a step containing aClick operation on the Silverlight application before
performing other operations on the application.

l To improve performance when running legacy tests in UFT, update your Silverlight test object
descriptions to include the devnamepath property.

Add-ins Guide
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Chapter 6: .NET Web Forms Add-in
This chapter includes:

".NETWeb Forms Add-in - Quick Reference" below

.NET Web Forms Add-in - Quick Reference
You can use the .NET Add-in to test .NETWeb Forms user-interface objects (controls).

The following tables summarize basic information about the .NET Web Forms application support
and how it relates to some commonly-used aspects of UFT.

General Information

Add-in Type The .NET Add-in functions like aWeb-based add-in when testing .NETWeb
Forms controls. Much of its functionality is the same as otherWeb-based
add-ins.

See "Web-Based Application Support" on page 39.

Supported
Environments

For details on supported .NETWeb Forms environments, see the .NET Add-
in section of theHP Unified Functional Testing Product Availability Matrix,
available from the UFT Help or the root folder of the Unified Functional
Testing DVD.

Test Object
Methods and
Properties

The .NET Add-in provides test objects, methods, and properties that can be
used when testing objects in .NETWeb Forms applications. For details, see
the .NET Web Forms section of theHP UFT Object Model Reference for
GUI Testing.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

l See "Accessing Internal Properties andMethods of Run-Time .NETWeb
Forms Objects" on page 128.

Troubleshooting
and Limitations

See "Troubleshooting and Limitations - .NETWeb Forms" on page 129.

Prerequisites

Opening Your
Application

Youmust open UFT and set the Record and Run options before opening your
.NETWeb Forms application. Open your application only after you begin the
recording session.

Add-in
Dependencies

TheWeb Add-in must be loaded.
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Configuration

Options Dialog Box Use theWeb pane.
(Make sure that a GUI test is open and select Tools> Options >
GUI Testing tab > Web > General node.)

See "Web > General Pane (Options Dialog Box)" on page 65.

Record and Run Settings
Dialog Box
(tests only)

Use theWeb tab.
(Record > Record and Run Settings)

See "Web Tab (Record and Run Settings Dialog Box)" on page
83

Test Settings Dialog Box
(tests only)

Use theWeb pane.
(File > Settings > Web node)

See "Web Pane (Test/Business Component Settings Dialog Box
/ Application Area - Additional Settings Pane)" on page 79.

Custom Active Screen
Capture Settings Dialog
Box
(tests only)

Use theWeb section.
(Tools > Options > GUI Testing tab > Active Screen node >
Custom Level)

See the section on the Custom Active Screen Capture Settings
dialog box in theHP Unified Functional Testing User Guide.

Application Area
Additional Settings pane
(business components only)

Use theWeb pane.
In the application area, select Additional Settings > Web in the
sidebar.

See "Web Pane (Test/Business Component Settings Dialog Box
/ Application Area - Additional Settings Pane)" on page 79.

This section includes

Concepts 128

Considerations for Testing .NETWeb Forms 128

Accessing Internal Properties andMethods of Run-Time .NETWeb Forms Objects 128

Reference 129

Troubleshooting and Limitations - .NETWeb Forms 129
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Concepts

Considerations for Testing .NET Web Forms

When testing .NETWeb Forms Applications applications, consider the following:

l WhenUFT learns .NETWeb Forms objects, it does not learn the HTML elements that comprise
the test objects. For example, when UFT learns the WbfGrid test object, the WbfGrid object is
the bottommost object in the hierarchy, and the HTML elements used to create the grid's cells
are not learned.

l When you load the .NET Add-in, theWeb event recording configurations designed for this add-in
are loaded and are used whenever you record on a .NETWeb Forms object. The.NETWeb
Forms Web event recording configurations do not affect the way UFT behaves when you record
on other non-.NETWeb Forms Web objects. For details, see "Event Recording Configuration for
Web-Based Applications" on page 44.

Accessing Internal Properties and Methods of Run-Time .NET Web
Forms Objects

You can use theObject property to retrieve internal (native) properties and activate internal
methods of any .NETWeb Forms object in your application.

In the example below, the orientation property of theWbfTabStrip control is returned and
displayed in amessage box.

MsgBox Browser("WebControls:").Page("Page").WbfTabStrip("WbfTabStrip").Objec
t.Orientation

TheObject property is also useful for verifying the value of properties that are not available using a
standard checkpoint.

For details on theObject property and for details on .NETWeb Forms test objects, methods, and
properties see the .NET Web Forms section of theHP UFT Object Model Reference for GUI
Testing.
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Reference

Troubleshooting and Limitations - .NET Web Forms

This section describes troubleshooting and limitations for the .NETWeb Forms Add-in.

General

l xpath and css properties are not supported for .NETWeb Forms test objects or for otherWeb-
based test objects that have .NETWeb Forms parent test objects.

l Tests onWbfTreeView test objects that contain special characters may not run as expected.

Workaround: To run a test on aWbfTreeView item that contains special characters, use the
#index format. See the .NETWeb Forms Object Model Reference Help for details.

l WbfTreeView, WbfToolbar, andWbfTabStrip test objects are not supported for browser control
applications.

l Active Screen operations are not supported forWbfTreeView, WbfToolbar, andWbfTabStrip
objects.

l Performing aSelect orExpand operation on aWbfTreeView object that causes page navigation
may fail due to a synchronization problem.

Workaround: Try running the test on theWbfTreeView object step-by-step. For example,
change:

WbfTreeView.Select "item1;item2;item3;"

to:

WbfTreeView.Expand "item1
WbfTreeView.Expand "item1;item2"
WbfTreeView.Select "item1;item2;item3;"

l Working on a .NETWeb Forms application that has calendars with more than one unified style
is not fully supported.

l The value of theSelected Date andSelected Range identification properties is always none
forWbfCalendar objects in selectionmode none.

l To retrieve correct values forWbfCalendarSelected Date andSelected Range identification
properties, the selected date or rangemust be currently visible in yourWeb Forms application.

l All operations on grouping areas inWbfUltraGrid objects (InfragisticsUltraWebGrid) are not
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recorded.

l Operations performed in a rapid sequence on WbfUltraGrid objects may not be recorded.

Workaround: Try to limit the recording to 1-2 operations per second.

WbfUltraGrid column names are comprised of the inner HTML of the column header, and
thereforemay include extraneous information.

l WbfUltraGrid may fail to sort columns in a descending order when the column is not already
sorted.

Workaround:Split the Sort call into two calls—first sort in ascending order, then sort in
descending order. For example, change:

WbfUltraGrid("UltraWebGrid1").Sort "Model","Descending"

to:

WbfUltraGrid("UltraWebGrid1").Sort "Model","Ascending"
WbfUltraGrid("UltraWebGrid1").Sort "Model","Descending"

l Note that Visual Basic .NET applications are supported by the UFT .NET Add-in.

Creating, Editing, and Running Testing Documents

l UFTmay recognize someWeb Forms grids as WebTables instead of WbfGrid test objects.

Workaround:Do one of the following:

n Modify theWeb forms control so that it meets one of the following conditions:

o The class attribute contains the string DataGrid.

o The id attribute contains at least one of the strings DataGrid or GridView.

n Modify the rules that UFT uses to determine when to identify aWeb Forms table control as a
DataGrid or GridView (and learn it as aWbfGrid test object).

These rules are defined in:<UFT installation
folder>\dat\WebFormsConfiguration.xml.

The file contains comments that describe its format and explain how to use it.

l .NETWeb Forms objects are supported only onMicrosoft Internet Explorer.

l When recording, youmust open UFT and define record options before opening your .NETWeb
Forms application.
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Checkpoint and Output Values

l WbfTreeView, WbfToolbar, andWbfTabStrip objects are not properly recognized in the Active
Screen. Therefore:

n You cannot insert checkpoint or output value steps for these objects from the Active Screen.

n If you select to insert checkpoints for these objects from the Keyword View or Editor while in
edit mode, the expected values of these objects may be incorrect.

Workaround: Insert checkpoint or output value steps on these objects during a recording
session or remove the Active Screen for the relevant step and then insert a checkpoint from the
Keyword View or Editor with your application open to the proper location, so that the values will
be retrieved from the application.

l Text checkpoints are not supported forWbfTreeView, WbfToolbar, andWbfTabStrip objects.

l The Active Screen image for aWbfCalendar object is always saved before navigation. For
example, if you click aNextMonth link, the Active Screen displays the current month.
Therefore, if you create a checkpoint from the Active Screen and insert it after the
Calendar.ShowNextMonth line, the checkpoint will fail.

Workaround:Do one of the following:

n Insert checkpoints on calendar objects while recording.

n While editing your test, edit the expected value for the checkpoint or insert the checkpoint
before the current step.

l Table checkpoints are supported forWbfUltraGrid objects only while recording.

l When using theWbfUltraGrid.RowCount andWbfUltraGrid.ColumnCountmethods or
performing a table checkpoint on a grid that also contains additional grid controls inside it, UFT
retrieves the rows or columns only for the outermost table. Note that the rows property and
RowCountmethod count only the non-grouping rows.

Add-ins Guide
Chapter 6: .NETWeb Forms Add-in

HP Unified Functional Testing (12.00) Page 131 of 549



Chapter 7: .NET Windows Forms Add-in
This chapter includes:

".NETWindows Forms Support - Quick Reference" below

".NETWindows Forms Support - Testing and Configuration" on page 139

.NET Windows Forms Support - Quick Reference
You can use the UFT .NET Add-in to test .NETWindows Forms user-interface objects (controls).

The following tables summarize basic information about .NETWindows Forms application support
and how it relates to some commonly-used aspects of UFT.

General Information

Add-in Type The .NETWindows Forms testing support functions like aWindows-based
add-in. Much of its functionality is the same as otherWindows-based add-
ins.

See "Windows-Based Application Support" on page 94.

Supported
Environments

For details on supported .NETWindows Forms environments, see the .NET
Add-in section of theHP Unified Functional Testing Product Availability
Matrix, available from the UFT Help or the root folder of the Unified
Functional Testing DVD.

Important
Information

l You can also test most custom .NET controls inherited from the
System.Windows.Forms.Control regardless of which language was used
to create the application (for example, Visual Basic .NET, C#, and so on)

l See " Considerations for Testing .NETWindows Forms Applications"

Test Object
Methods and
Properties

The .NET Add-in provides test objects, methods, and properties that can be
used when testing objects in .NETWindows Forms applications. For
details, see the .NET Windows Forms section of theHP UFT Object
Model Reference for GUI Testing.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide.

l See " Considerations for Testing .NETWindows Forms Applications" on
page 135.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

Extending the
.NET Add-in

".NET Add-in Extensibility" (described on page 135 enables you to develop
support for testing third-party and custom .NETWindows Forms controls
that are not supported out-of-the-box by the UFT .NET Add-in.
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Troubleshooting
and Limitations

See "Troubleshooting and Limitations - .NETWindows Forms" on page 137.

Prerequisites

Opening Your
Application

Youmust open UFT before opening your .NETWindows Forms
application

Add-in Dependencies The .NET Add-in must be installed.

Configuration

Options
Dialog Box

Use theWindows Applications pane.
(Select Tools> Options > GUI Testing tab > Windows Applications
node).

See "Windows Applications > General Pane (Options Dialog Box >
GUI Testing Tab)" on page 98.

Record and
Run Settings
Dialog Box
(tests only)

Use theWindows Applications tab.
(Record > Record and Run Settings)

See "Windows Applications Tab (Record and Run Settings Dialog Box)" on
page 109.

Note: If you select theRecord and Run only on radio button in the
Record and Run Settings dialog box, the settings also apply to (limit) the
applications that are recognized for the .NETWindows Spy, the Object
Spy, and other pointing hand operations.

Custom Active
Screen
Capture
Settings
Dialog Box
(tests only)

Use theWindows applications section.
(Tools > Options > GUI Testing tab > Active Screen node > Custom
Level)

See the section on the Custom Active Screen Capture Settings dialog box in
theHP Unified Functional Testing User Guide.

Application
Area
Additional
Settings pane
(business
components
only)

Use theApplications pane.
In the application area, select Additional Settings > Applications in the
sidebar.

See the section on the Applications pane in theHP Unified Functional Testing
User Guide.

This section includes

Concepts 135

Considerations for Testing .NETWindows Forms Applications 135

.NET Add-in Extensibility 135
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Reference 137

Troubleshooting and Limitations - .NETWindows Forms 137
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Concepts

Considerations for Testing .NET Windows Forms Applications

l You can use the Keyword View and Editor to activate .NETWindows Forms test object
operations and native (run-time object) operations, retrieve and set the values of properties, and
check that objects in your application exist and function as expected.

l When you create a checkpoint on a .NETWindows Forms object, UFT stores the selected
property values of the object. If your application changes, you canmodify the captured values to
match the new expected values.

.NET Add-in Extensibility

UFT .NET Add-in Extensibility enables you to develop support for testing third-party and custom
.NETWindows Forms controls that are not supported out-of-the-box by the UFT .NET Add-in.

If the test object class that UFT uses to represent a control does not provide the operations and
properties necessary to operate on your control, you can use .NET Add-in Extensibility to
customize this behavior.

l You can instruct UFT to use a different test object class to represent the control.

l You can add operations or override existing ones, using .NET programming, to operate as
necessary on the control.

l You can also teach UFT to treat a control that contains a set of lower-level controls as a single
functional control, instead of relating to each lower-level control separately.

To implement .NET Add-in Extensibility, you need to be familiar with:

l UFT and its Object Model Reference

l The behavior of the custom control (operations, properties, events)

l .NET programming in C# or Visual Basic

l XML (basic knowledge)

You can install the .NET Add-in Extensibility SDK from theAdd-in Extensibility and Web 2.0
Toolkits option in the UFT setup program.
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The SDK also includes:

l Project templates and a wizard for Microsoft Visual Studio, that simplify setting up of your .NET
Add-in Extensibility project.

l Samples of support developed using .NET Add-in Extensibility, which you can use to gain a
better understanding of how to create your own support.

For installation and implementation details, see the .NET Add-inWindows Forms Extensibility
Help, available from the UFT Extensibility Documentation program group (Start > All Programs >
HP Software > HP Unified Functional Testing > Extensibility > Documentation).

Note: For details on accessing UFT and UFT tools and files inWindows 8, see "Accessing
UFT inWindows 8Operating Systems" on page 547.

A printer-friendly (PDF) version of theHP UFT .NET Add-in Extensibility Developer Guide is
available in the <Unified Functional Testing installation folder>\help\Extensibility
folder.
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Reference

Troubleshooting and Limitations - .NET Windows Forms

This section describes troubleshooting and limitations for the .NETWindows Forms Add-in.

l Navigating in grid controls using keyboard keys (for example, to select cells, rows, and so on)
may not be recorded correctly.

Workaround:Use themouse to navigate in the grid control.

l If you call theBackmethod for aMicrosoft DataGrid control on a table that does not have a
parent row, no operation is performed when the statement runs, and no error message is
displayed.

l Grid controls in the Card View mode are not supported.

l Changing the format of a DateTimePicker control during a test run or between record and run
sessions (for example, from "Long Date" to "Time") will cause the test run to fail.

l Combo box objects of style Simple ComboBox are not supported.

l If a window in the tested application has an opacity property value not equal to 100% (that is, the
form is completely or partially transparent), the Active Screen captures the image displayed
below the form, and not the transparent window.

l .NETWindows Forms table checkpoints and output value steps can be created only for objects
that UFT recognizes as SwfTable objects. UFT does not treat SwfPropertyGrid test objects as
table objects.

l Operations on a grid cell that was selected before you started recording on the grid control may
be recorded incorrectly. For example, a child cell element operationmay be recorded instead of
the parent grid operation (for example, SetCellData).

Workaround: Before performing operations on a cell that is already selected, begin recording,
move the focus to another cell, select the required cell, and then perform the required operation.
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l When recording steps using low-level recording, default description properties forWinObject and
Window objects do not have constant values. This may lead to different description property
values during a run session, which causes steps on these objects to fail.

Workaround:

n Window test objects. Before recording, remove the regexpwndclass property from the list
of mandatory, assistive, and Smart Identification properties using the Object identification
dialog box.

n WinObject test objects. Do the following:

o Before recording, remove thewindow id property from the list of mandatory, assistive,
and Smart Identification properties using the Object identification dialog box.

o After recording, change the regexpwndclass property value to a regular expression for
eachWinObject test object in the object repository, and edit the property value to remove
everything except for the control type,

For example, change WindowsForms10.BUTTON.app3 to .*BUTTON.*

l Note that Visual Basic .NET applications are supported by the UFT .NET Add-in.
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.NET Windows Forms Support - Testing and
Configuration

This section includes

Concepts 140

.NETWindows Forms Objects - Checkpoints andOutput Values 140

.NETWindows Forms Spy 141

Tasks 143

How to Use the .NETWindows Forms Spy 143

Reference 147

.NETWindows Forms Spy Dialog Box 147
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Concepts

.NET Windows Forms Objects - Checkpoints and Output Values

You can check or output values from supported .NETWindows Forms grid controls and use the
Object property to retrieve internal properties.

For details, see:

l "Checking .NETWindows Forms Tables andOutputting Their Values" below

l "Accessing Internal Properties andMethods of Run-Time .NETWindows Forms Objects" below

Checking .NET Windows Forms Tables and Outputting Their Values
You check or output values from supported .NETWindows Forms grid controls using the Table
Checkpoint Properties dialog box.

For tables with more than 100 rows, you can specify the rows you want to include in the checkpoint
or output value in the Define/Modify Row Range Dialog Box. If you do not specify the rows to
include, the table checkpoint or output value captures all data in the current level or view as follows:

When working with: The table checkpoint or output value captures:

ComponentOne
C1FlexGrid and
C1TrueDBGrid

The entire grid.

Microsoft Data Grid
and DataGrid View

The currently displayed table (parent or child).

Infragistics
UltraWinGrid

The band in which a cell, column, or row is selected.

DevExpress XtraGrid The view that was most recently set.

Tip: Insert aSetViewmethod before your table checkpoint to
ensure that the view you want is displayed when the table
checkpoint runs.

Apart from the difference in captured information as listed above, you define a table checkpoint or
output value for .NETWindows Forms in the sameway as you do for any other table. For details,
see the sections on checkpoints and output values in theHP Unified Functional Testing User
Guide.

Accessing Internal Properties and Methods of Run-Time .NET Windows
Forms Objects
You can use theObject property to retrieve internal (native) properties and activate internal
methods of any .NETWindows Forms object in your application.
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For example, you can set the focus to a particular button and change its caption using statements
similar to the following:

Set theButton = SwfWindow("frmWin").SwfButton("OK").Object
theButton.SetFocus
theButton.Caption = "Yes"

TheObject property is also useful for verifying the value of properties that are not available using a
standard checkpoint.

When you use theObject property to retrieve arrays of structures, theObject property returns the
COMwrapper of the system.array object. In your VBScript test or business component steps, you
can then use the system.array object to access the array members.

For example, suppose a button object in your application has aPointArray property, which is an
array of Point structures. To access the first item in thePointArray property, you would use the
following expression:

SwfWindow("Form1").SwfButton("button1").Object.PointArray.GetValue1(0)

If the same object had an IntArray property, which was an array of integers, you would use the
following expression to access the first item in the IntArray property:

SwfWindow("Form1").SwfButton("button1").Object.IntArray(0)

For details on theObject property and for details on .NETWindows Forms test objects, methods,
and properties see the .NET Windows Forms section of theHP UFT Object Model Reference for
GUI Testing.

.NET Windows Forms Spy

The .NETWindows Forms Spy (described in ".NETWindows Forms Spy Dialog Box" on page 147)
enables you to select a specific control in your .NET application, view its run-time object properties
and values, change property values in the application in run-time, listen to events on a specific
control, view the event arguments, and fire events back at the application.

You can use the .NETWindows Forms Spy to help you develop extensibility for .NETWindows
Forms controls.

To spy on a .NETWindows Forms application, make sure that the application is specified in the
"Windows Applications Tab (Record and Run Settings Dialog Box)" (described on page 109) and
that the application is running with Full Trust. If the application is not defined to run with Full Trust,
you cannot spy on the .NET application's Windows Forms controls with the .NETWindows Forms
Spy. For details on defining trust levels for .NET applications, seeMicrosoft documentation.

The .NETWindows Forms Spy is intended for advanced UFT users, especially those who are
using .NET Add-in Extensibility to create support for custom .NETWindows Forms controls. The
.NETWindows Forms Spy can assist you in examining .NETWindows Forms controls within your

Add-ins Guide
Chapter 7: .NETWindows Forms Add-in

HP Unified Functional Testing (12.00) Page 141 of 549



application and seeing which events cause it to change (to facilitate recording and running) and how
the changes manifest themselves in the control's state.

Note: The .NETWindows Forms Spy runs in the context of your .NET application, not in the
UFT context. The objects and run-time object properties on which you are spying are the raw
.NET objects in your application, and not the .NET test objects used in UFT. Since the .NET
Windows Forms Spy runs in the context of your .NET application, you can close UFT while
you use the .NETWindows Forms Spy. However, UFT must be open if you want to use the
pointing handmechanism to spy on additional objects. If you close the .NET application on
which you are spying, the UFT .NETWindows Forms Spy window is closed automatically.
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Tasks

How to Use the .NET Windows Forms Spy

This task describes elements of the .NETWindows Forms Spy including how to:

Spy on an object

1. Make sure that the application on which you want to spy is specified in the "Windows
Applications Tab (Record and Run Settings Dialog Box)" (described on page 109), and that the
application is running with Full Trust.

2. Open the .NETWindows Forms application to the window containing the object on which you
want to spy.

3. Select Tools > .NET Windows Forms Spy. The UFT".NETWindows Forms Spy Dialog
Box" (described on page 147) opens.

4. In the UFT .NETWindows Forms Spy window, click the pointing hand . Both UFT
and the .NETWindows Forms Spy areminimized so that you can point to, and click on, any
object in the open application.

For details on using the pointing hand, see the section describing the pointing hand in the
HP Unified Functional Testing User Guide.

5. Click the object whose properties you want to view. If the location you clicked in your
application is associated with more than one object, the Object Selection dialog box opens.
The objects associated with the location you clicked are displayed in hierarchical order.

6. Select the .NETWindows Forms object on which you want to spy and click OK. The UFT
.NETWindows Forms Spy window opens showing the properties and values for the selected
object.

7. You can repeat these steps to spy on additional objects and add them to the Objects pane in
the UFT .NETWindows Forms Spy window.

Remove objects from the Objects pane

1. Select the object that you want to remove.

2. Perform one of the following:

n Right-click the object and select Remove Object.

n Press DELETE.

View values of run-time object properties
In the Objects pane, select the object whose run-time object properties you want to view. The

HP Unified Functional Testing (12.00) Page 143 of 549



properties for the selected object are displayed in the Properties tab, with the property names on the
left, and the property values on the right. A description of the selected property is displayed below
the properties grid.

Note: Any changes youmake to the values of run-time object properties in the .NET
application remain in effect only for the current instance of the .NET application. The next time
you run the .NET application, the properties will return to their original run-time values.

View properties of embedded objects

1. In the Properties tab, select the property whose embedded object properties you want to view.
For details on locating a property by value, see "Locate a property by its value" below.

2. Click theAdd selected property to the Objects tree button . The property is added to
the Objects pane, and its run-time object properties and property values (if any) are shown in
the Properties tab. Each time you add an embedded object to the Objects pane, it is added
below its parent object, in a hierarchical format.

Note: TheAdd selected property to the Objects tree button is disabled if the property's
value is null, or the property is an object with no properties of its own.

Locate a property by its value

1. Click theSearch a property by value button . The Find Property by Value dialog box
opens.

2. In the Find what box, specify the value for which you want to search.

3. To find only those occurrences in which the capitalizationmatches the text you entered, select
Match case.

4. Specify the direction from the current cursor location in which you want to search: Up or
Down.

5. Click Find Next. The .NETWindows Forms Spy locates the property whose value you
specified.

Sort the properties grid
Click one of the following buttons to sort the properties grid in the Properties tab:

l Categorized. Lists all properties and property values for the selected object, by category.
Categories are listed alphabetically. You can collapse a category to reduce the number of visible
properties. When you expand or collapse a category, a plus (+) or minus (-) is displayed to the
left of the category name.
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l Alphabetical. Alphabetically sorts all run-time object properties for the selected object.

Note: TheProperty Pages button is not currently supported.

Modify values of run-time object properties

1. In the Properties tab, click the property value you want to modify. Properties shown in gray are
defined as read-only in the .NET application and cannot bemodified.

2. Edit the property value as required. The property value displays different types of edit fields,
depending on the needs of a particular property. These edit fields include edit boxes, drop-down
lists, and links to custom editor dialog boxes.

After youmodify a property value, the new value is applied to the run-time instance of the .NET
application. For example, you can change the text of an edit box label, change the background
color of a dialog box from gray to red, and so on.

View event arguments on an object

1. In the Objects pane, select the object whose event arguments you want to view.

2. Select the event in the Fired Events list whose arguments you want to view. The selected
events arguments and argument values are shown directly below the event, in the Event
Arguments list.

Listen to specified events of an object

1. In the Objects pane, select the object to whose events you want to listen.

2. In the Events list, select the check boxes for the event types to which you want to listen.

Note: The events that you select affect only the events that are listened to and logged by
UFT. If you select or clear a check box for an event type after listening to events for an
object, the events in the Fired Events list are not changed.

Tip: You can click theSelect All Events orClear All Events buttons to select
or clear all the event check boxes. You can also right-click the Events list and select
Select All orClear All.

3. Click the Listen to Selected Events button . UFT starts listening to the specified events
on the selected object, and Listening is displayed in the status bar.
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4. In your .NET application, perform the operations on the object to whose events you want to
listen. The specified events are logged as they occur and are shown in the Fired Events list.

5. When you want to stop listening to events, click theStop Listening to Events button .
UFT stops listening to and logging the specified events.

Fire selected events on an object

1. In the Objects pane, select the object whose events you want to fire.

2. In the Fired Events list, select one or more events that you want to fire on your .NET
application. You can select multiple events using standardWindows selection techniques
(CTRL andSHIFT keys).

Tip: The selected events are fired in the order in which they appear in the Fired Events list.
If the events do not appear in the Fired Events list in the order in which you want to fire
them, listen tomore events on the object until the events you want are added to the Fired
Events list in the required order.

3. If the events you selected have editable arguments, you can change their argument values in
the Event Arguments list if needed before firing the events. When the events are fired, they will
be fired with themodified argument values.

4. Click the Fire Selected Events button . The selected events are fired in the order in which
they appear in the Fired Events list. You can view the effect that firing these events has on the
relevant object in your .NET application. The status bar displays that the event firing is in
progress, and when it ends.

Remove specific events from the Fired Events list

1. In the Objects pane, select the object whose events you want to remove from the Fired Events
list.

2. Select the events in the Fired Events list that you want to remove. You can select multiple
events using standardWindows selection techniques (CTRL andSHIFT keys).

3. Click theClear Selected Events button . The selected events are removed from the Fired
Events list.

Clear all events from the Fired Events list

1. In the Objects pane, select the object whose events you want to remove from the Fired Events
list.

2. Click theClear Event List button . All the logged events are removed from the Fired
Events list.
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Reference

.NET Windows Forms Spy Dialog Box

This dialog box enables you to select a specific control in your .NET application, view its run-time
object properties and values, change property values in the application in run-time, listen to events
on a specific control, view the event arguments, and fire events back at the application.

The following illustrates an example of the Form Spy dialog box.
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The following illustrates an example of the Form Spy Object Pane.

The following illustrates an example of the Form Spy Events tab.
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The following illustrates an example of the Form Spy Properties tab.

To access Select Tools > .NET Windows Forms Spy.

Relevant
tasks

l "How to Use the .NETWindows Forms Spy" on page 143

See also l ".NETWindows Forms Objects - Checkpoints andOutput Values" on page
140.

l ".NET Add-in Extensibility" on page 135.

l ".NETWindows Forms Spy" on page 141.
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User interface elements are described below:

UI
Elements Description

Enables you to select a .NETWindows Forms object on which to spy. You can spy
on as many objects within a single .NET application as you want. Each object that
you select is added to the Objects pane.

Note:

l If you select an object from a different .NET application, an additional UFT
.NETWindows Forms Spy window opens, showing the information for the
selected object.

l UFTmust be open if you want to use the pointing handmechanism to spy
on additional objects.

Type Displays the full type name of the selected object.

Objects
pane

Displays a hierarchical tree of the objects you selected to spy.

TheObjects pane contains a list of the objects in your .NET application on which
you have spied. Each time you spy on another object in the same .NET application,
it is added to the Objects pane. You can spy on as many objects from the same
.NET application as you want, using the pointing hand button in the UFT .NET
Windows Forms Spy window.

TheObjects pane also contains any embedded objects that you added from the
Properties tab. Each time you add an embedded object to the Objects pane, it is
added below its parent object, in a hierarchical format. You can select an object in
the Objects pane and view ormodify its properties and property values, and listen
to and fire its events. For details, see ".NETWindows Forms Spy" on page 141.

Properties
tab

Enables you to view andmodify values of run-time object properties in your .NET
application. The Properties tab enables you to view run-time object properties and
values for objects in your .NET application. You can select a property to display a
description of the property below the property grid.

You can choose to display the properties alphabetically or by category. You can
change property values in the .NETWindows Forms Spy and apply those changes
to your .NET application in run-time. For details, see ".NETWindows Forms Spy"
on page 141.
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UI
Elements Description

Events
tab

Enables you to listen to events in your .NET application and fire them at the
application.

The Events tab enables you to listen to selected events on a specific control in your
.NET application. You can then view the event arguments, and fire selected events
back at the application.

This is especially useful if you are using .NET Add-in Extensibility to create support
for custom .NETWindows Forms controls. You can see which events cause your
.NET application to change, so you can implement extensibility for recording
operations on specific controls, and also check which events need to be fired to
make your .NET application behave the way you want.

For details, see ".NETWindows Forms Spy" on page 141.

Status bar Displays the class name of the object that is selected in the Objects pane, and the
event handling status.
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Chapter 8: .NET Windows Presentation Foundation
Add-in

This chapter includes:

".NETWindows Presentation Foundation Add-in - Quick Reference" below

".NETWindows Presentation Foundation Add-in - Testing and Configuration" on page 157

.NET Windows Presentation Foundation Add-in -
Quick Reference

You can use the UFTWindows Presentation Foundation Add-in to test WPF (Windows
Presentation Foundation) user-interface objects (controls).

The following tables summarize basic information about theWindows Presentation Foundation
Add-in and how it relates to some commonly-used aspects of UFT.

General Information

Add-in Type This is aWindows-based add-in. Much of its functionality is the same as
otherWindows-based add-ins.

This add-in is installed as a sub add-in of the .NET Add-in.

See "Windows-Based Application Support" on page 94.

Supported
Environments

For details on supportedWindows Presentation Foundation environments,
see theWPF Add-in section of theHP Unified Functional Testing Product
Availability Matrix, available from the UFT Help or the root folder of the
Unified Functional Testing DVD.

Test Object
Methods and
Properties

TheWPF Add-in provides test objects, methods, and properties that can be
used when testing objects inWPF applications. For details, see the .NET
Windows Presentation Foundation section of theHP UFT Object Model
Reference for GUI Testing.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide.

l To check properties that are not included in the Checkpoint Properties
dialog box you can use the Object, AutomationElement, or
AutomationPattern property. For details, see "Accessing Internal
Properties andMethods of WPF Objects" on page 159.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540
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Extending the
WPF Add-in

"WPF Add-in Extensibility" (described on page 154 enables you to develop
support for testing third-party and customWPF controls that are not
supported out-of-the-box by the UFTWPF Add-in. For details, see "WPF
Add-in Extensibility" on the next page

Troubleshooting
and Limitations

See "Troubleshooting and Limitations - Windows Presentation Foundation"
on page 155.

Prerequisites

Opening Your Application You can open yourWPF application before or after opening UFT.

Add-in Dependencies TheWeb and .NET Add-ins must be installed.

Configuration

Options Dialog Box Use theWindows Applications pane.
(Tools> Options > GUI Testing tab > Windows Applications
node)

See "Windows Applications > General Pane (Options Dialog
Box > GUI Testing Tab)" on page 98.

Record and Run Settings
Dialog Box
(tests only)

Use theWindows Applications tab.
(Record > Record and Run Settings)

See "Windows Applications Tab (Record and Run Settings
Dialog Box)" on page 109.

Custom Active Screen
Capture Settings Dialog
Box
(tests only)

Use theWindows applications section.
(Tools > Options > GUI Testing tab > Active Screen node >
Custom Level)

See the section on the Custom Active Screen Capture Settings
dialog box in theHP Unified Functional Testing User Guide.

Application Area
Additional Settings pane
(business components only)

Use theApplications pane.
In the application area, select Additional Settings >
Applications in the sidebar.

See the section on the Applications pane in theHP Unified
Functional Testing User Guide.

This section includes

Concepts 154

Considerations forWorking with theWPF Add-in 154

WPF Add-in Extensibility 154

Reference 155

Troubleshooting and Limitations - Windows Presentation Foundation 155
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Concepts

Considerations for Working with the WPF Add-in

l You can test most customWPF controls inherited directly or indirectly from the
System.Windows.Controls.Control class regardless of which language was used to create
the application (for example, Visual Basic, .NET, C#, and so on), as well as third-party WPF
controls that are inherited from theSystem.Windows.Controls.Control class and implement
automation interfaces.

l You can use the Keyword View and Editor to activateWPF test objects, Automation objects and
run-time object methods, retrieve and set the values of properties, and check that objects exist.

WPF Add-in Extensibility

UFTWPF Add-in Extensibility enables you to develop support for testing third-party and custom
WPF controls that are not supported out-of-the-box by the UFTWPF Add-in.

If the test object class that UFT uses to represent a control does not provide the operations and
properties necessary to operate on your control, you can useWPF Add-in Extensibility to create a
new test object class.

You can thenmap the control to the new test object class, and design the test object class behavior
using .NET programming. You can program how operations are performed on the control, how
properties are retrieved, andmore.

You can also teach UFT to treat a control that contains a set of lower-level controls as a single
functional control, instead of relating to each lower-level control separately.

To implement WPF Add-in Extensibility, you need to be familiar with:

l UFT and its Object Model Reference

l The behavior of the custom control (operations, properties, events)

l .NET programming in C#

l XML (basic knowledge)

You can install theWPF Add-in Extensibility SDK from theAdd-in Extensibility and Web 2.0
Toolkits option in the UFT setup program.
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Reference

Troubleshooting and Limitations - Windows Presentation
Foundation

l The UFT .NET Add-in supports:

n Testing standard .NETWindows Forms controls from theSystem.Windows.Forms library.

n Testing third-party .NETWindows Forms controls that are inherited from
System.Windows.Forms.Control class.

l The UFT .NET Add-in supports testingWPF controls inherited directly or indirectly from the
System.Windows.Controls.Control class regardless of which language was used to create
the application (for example, VisualBasic, .NET, C#, and so forth), as well as third-party WPF
controls that are inherited from theSystem.Windows.Controls.Control class and implement
automation interfaces when theWPF Add-in is loaded.

l In addition to the controls listed in theHP Unified Functional Testing Product Availability Matrix,
custom-built UFT support for a variety of Infragistics .NETWindows Forms controls is provided
out-of-the-box by Infragistics TestAdvantage. For more information, refer to:
http://www.infragistics.com/dotnet/testadvantageoverview.aspx#Overview

l UFT does not treat text block elements as children of WPF objects, such as lists, treeviews,
and tables. Therefore, they will not be returned in aChildObjects statement, nor will they be
learned as test objects when you select to learn aWPF object and its children.

If you want to work with the text block elements of aWPF object, use aGetItem() or
GetItemProperty() statement.

l When you spy on aWPF object using the Object Spy (or the .NETWindows Forms Spy when
the .NET Add-in is loaded), and the Record and Run Settings dialog box is not configured to
record on theWPF application on which you are spying, UFT recognizes the object as a
standardWindows object.

Workaround:Close yourWPF application. In UFT, open the Record and Run Settings dialog
box (Record > Record and Run Settings) and in theWindows Application tab, select the
Record and run test on any Windows application option. Reopen yourWPF application and
then spy on it again.

l When you spy on aWpfComboBox control on aMicrosoft Windows 7 operating system, to
enable displaying the correct all items property value, youmust first manually expand and
collapse the combo box.

l To view the full type name of a .NETWindows Forms object in your application, view the
SwfTypeName identification property in the Object Spy.

HP Unified Functional Testing (12.00) Page 155 of 549

http://www.infragistics.com/dotnet/testadvantageoverview.aspx#Overview


You can also view a list of the base types of a selected object by running a statement using the
following syntax:

MsgBox <SwfTestObj>(<descr>).GetROProperty("SwfTypeNames")

where SwfTestObj(<descr>) is the test object you want to check. Running this statement
causes amessage box to open displaying the actual class at the top of the list and the base
classes below it.

l When recording steps using low-level recording, default description properties forWindows
Presentation Foundation test objects do not have constant values. This may lead to different
description property values during a run session, which causes steps on these objects to fail.

l When recording dynamically changing objects in your application, UFT records the object
properties of the object after the change instead of on the original object before the change. This
causes run sessions using this object to fail.

Workaround: Manually change the object description in the editor.
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.NET Windows Presentation Foundation Add-in -
Testing and Configuration

This section includes

Concepts 158

About WPF User Interface Automation 158

WPF Objects, Methods, and Properties to Enhance Your Test or Component 159
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Concepts

About WPF User Interface Automation

UI Automation provides a single, consistent, reference object for UI elements in multiple
frameworks (For example, Win32, WPF, and Trident). With UI Automation, the functionality of
objects in the UI is defined by a set of standard control patterns and properties that are common to
all objects of that type.

WPF uses UI (User Interface) Automation to define UI objects. UI Automation provides
standardization of controls and properties for the functionality of objects. The .NET Add-in supports
UI Automation through the AutomationElement and AutomationPattern properties.

To learnmore about UI Automation, see the UI Automation Fundamentals page of theMicrosoft
Developer Network library at http://msdn2.microsoft.com/en-us/library/ms753107.aspx.

This section also includes:

Automation Elements 158

Control Patterns 158

Automation Elements

UI Automation exposes every element in the UI as anAutomation Element. Automation
Elements expose common properties of the UI elements they represent.

For example, a button control has theAutomation Element property NameProperty, which
references the name or text associated with a button control. That same property is called caption
or alt inWin32 and HTML, respectively. With UI Automation, all button controls have a
NameProperty, which is mapped to the corresponding property in each framework.

TheAutomation Element also exposes control patterns that provide properties and expose
methods specific to their control types.

Control Patterns

Control patterns represent discrete pieces of functionality that a control in the UI can perform. The
total set of control patterns for a control type define the functionality of that control type.

Control patterns exposemethods that provide the ability to programmatically manipulate the
control.

Control patterns expose properties that provide information on the control's functionality and
current state.

The set of supported control patterns for a particular control can be dynamically defined. Therefore,
a particular control typemay not always support the same set of control patterns. For example, a
multiline edit box supports scrolling (scrollpattern pattern) only if its text exceeds the viewable
area.
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Some controls types, such as Image controls do not support any control patterns.

UFT enables you to access themethods and properties of automation elements and control
patterns using special properties in the UFT object model forWPF.

For details on how to work with UI Automation in your test or business component, see "Accessing
Internal Properties andMethods of WPF Objects" below.

WPF Objects, Methods, and Properties to Enhance Your Test or
Component

A test or business component consists of statements coded inMicrosoft VBScript. These
statements are composed of objects, methods, and/or properties that instruct UFT to perform
operations or retrieve information. You add these statements using objects from your object
repositories, andmethods and properties that are available for each object type. In addition, when
you record, these statements are generated automatically in response to input to the application.
You can also program statements manually, or mix recorded and programmed statements in the
same test or business component. You create, view, and edit these statements in the Keyword
View and/or Editor.

Accessing Internal Properties and Methods of WPF Objects

When accessing the internal properties andmethods of WPF objects, it is important to know which
property to use to access the object that contains the information you want to set or retrieve.

l AutomationElement property. Returns the object that gives access to the set of standard
properties that expose information about theAutomation Element.

l AutomationPattern property. Returns the object that gives access to the specific instance of
aControl Pattern. For details on themethods and properties that are accessible through the
AutomationPattern property, see the .NET Framework Developer Center of theMicrosoft
Developer Network library at http://msdn2.microsoft.com/en-
us/library/system.windows.automation.aspx.

l Object property. Returns the object that gives access to properties specific to the actual run-
time UI object, as defined by the developer.

Many of the properties andmethods accessible through theAutomationElement and
AutomationPattern properties contain the same information as the properties andmethods
accessible through theObject property. However, information available through UI Automation that
is accessed through theObject property lacks the standardization provided by UI Automation.

Custom properties designed by the developer are accessible only through theObject property.
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Chapter 9: ActiveX Add-in - Quick Reference
You can use the UFT ActiveX Add-in to test ActiveX user-interface objects (controls).

The following tables summarize basic information about the ActiveX Add-in and how it relates to
some commonly-used aspects of UFT.

General Information

Add-in Type This is aWindows-based add-in. Much of its functionality is the same as
otherWindows-based add-ins.

See "Windows-Based Application Support" on page 94.

Supported
Environments

For details on supported ActiveX environments, see theActiveX Add-in
section of theHP Unified Functional Testing Product Availability Matrix,
available from the UFT Help or the root folder of the Unified Functional
Testing DVD.

Important
Information

See "Considerations forWorking with the ActiveX Add-in" on page 163.

Test Object
Methods and
Properties

The ActiveX Add-in provides test objects, methods, and properties that can
be used when testing ActiveX objects in applications. For details, see the
ActiveX section of theHP UFT Object Model Reference for GUI Testing.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

Troubleshooting
and Limitations

See "Troubleshooting and Limitations - ActiveX Add-in" on page 164.

Prerequisites

Opening Your
Application

The application containing the ActiveX controls on which you want to record
must be closed before you begin a UFT recording session and set the Record
and Run options. Open the application only after you begin the recording
session.

Add-in
Dependencies

Loading the ActiveX and Siebel add-ins together may cause problems when
recording on some ActiveX methods.

Configuration
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Options Dialog
Box

Use theWindows Applications pane.
(Tools > Options > GUI Testing tab > Windows Applications node)

See "Windows Applications > General Pane (Options Dialog Box >
GUI Testing Tab)" on page 98.

Record and Run
Settings Dialog
Box
(tests only)

Use theWindows Applications tab.
(Run > Run Settings orRecord > Record Settings)

See "Windows Applications Tab (Record and Run Settings Dialog Box)" on
page 109.

Note:

l If you select theRecord and Run only on radio button in the
Record and Run Settings dialog box, the settings also apply to
(limit) the applications that are recognized for Object Spy and other
pointing hand operations.

l UFT recognizes ActiveX objects only in applications that are
opened after changing the record and replay settings in theWindows
Applications tab of the Record and Run Settings dialog box.

Custom Active
Screen Capture
Settings Dialog
Box
(tests only)

Use theWindows applications section.
(Tools > Options > GUI Testing tab > Active Screen node > Custom
Level)

See the section on the Custom Active Screen Capture Settings dialog box
in theHP Unified Functional Testing User Guide.

Application Area
Additional
Settings pane
(business
components only)

Use theApplications pane.
In the application area, select Additional Settings > Applications in the
sidebar.

See the section on the Applications pane in theHP Unified Functional
Testing User Guide.

This chapter includes:

Concepts 163

Considerations forWorking with the ActiveX Add-in 163

Reference 164

Troubleshooting and Limitations - ActiveX Add-in 164

Add-ins Guide
Chapter 9: ActiveX Add-in - Quick Reference
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Concepts

Considerations for Working with the ActiveX Add-in
l When you create a checkpoint on an ActiveX control, UFT captures all the properties for an

ActiveX control, but it does not select any properties to check.

l When testing ActiveX objects in a browser, the top-level ActiveX object is inserted within the
standardWeb object hierarchy, for example, Browser.Page.ActiveX.

l UFT can record on standard controls within an ActiveX control and if an ActiveX control contains
another ActiveX control, then UFT can record and run on this internal control as well. For
example, suppose your ActiveX control is a calendar that contains a drop-down list from which
you can choose themonth. If you record a click in the list to select themonth of May, UFT
records this step in the Editor as:

Dialog("ActiveX Calendars").ActiveX("SMonth Control").WinComboBox("ComboBo
x").Select "May"

l Loading the ActiveX and Siebel add-ins together may cause problems when recording on some
ActiveX methods.

l When creating a programmatic description for an ActiveX test object and the relevant run-time
object is windowless (has no window handle associated with it), youmust add thewindowless
property to the description and set its value to True.

For example:

Set ButDesc = Description.Create
ButDesc("ProgId").Value = "Forms.CommandButton.1"
ButDesc("Caption").Value = "OK"
ButDesc("Windowless").Value = True
Window("Form1").AcxButton(ButDesc).Click

For details, see the section on using programmatic descriptions in theHP Unified Functional
Testing User Guide.

l If a "windowless" ActiveX radio button object is not first activated by clicking on it
(AcxRadioButton.Click) or by using theSetmethod, a step containing the
AcxRadioButton.GetVisibleTextmethod will return an error stating that the object is not
visible.

Workaround: Insert a step using theClick orSetmethods prior to any step that uses the
GetVisibleTextmethod on a "windowless" ActiveX radio button object.
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Reference

Troubleshooting and Limitations - ActiveX Add-in
This section describes troubleshooting and limitations for the ActiveX Add-in.

Creating, Editing, and Running Testing Documents

l In the following ActiveX test object methods, if you specify the column by name, an error occurs
when you run the test: ActivateCell, ActivateColumn, SelectCell, SetCellData,
SelectColumn.

Workaround:When calling thesemethods, specify the column by number.

l When inserting steps in the Editor for aWeb application that has amixed hierarchy of Java
objects inside an ActiveX control, then it may take a long time for UFT to retrieve the possible
argument values (dynamic list of values) for ActiveX arguments.

Workaround: Insert these steps using the Keyword View (where the dynamic list of values
functionality is not used).

l If UFT does not recognize an ActiveX control inside aWeb page, reduce the security level within
your Microsoft Internet Explorer browser.

l If an ActiveX control's internal properties have the same name as the ActiveX properties created
by UFT, retrieval and verification of such properties may be problematic.

Workaround:You can access the internal properties of an ActiveX control using theObject
property.

l Methods performed on row and column positions for Apex, DataBound, and Sheridan grids
return the values of the visible positions and not the absolute positions within the tables.

Workaround:Use the scroll bar while recording in order to display the required cells.

l If an ActiveX control is registered after UFT was started, UFT may not recognize the controls
correctly. For example, UFT may recognize anAcxCalendar as aActiveX object.

Workaround: Install the application running the ActiveX controls and register all ActiveX
objects before starting UFT.

Checkpoints and Output Values

l ActiveX table checkpoints capture only visible rows in data bound grids.
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l When you insert a checkpoint on an ActiveX table from the Active Screen, the browser (or
application) must be open to the same page (or screen). Otherwise, some data from the ActiveX
table will bemissing.

Workaround:Create ActiveX table checkpoints while recording.

l Checkpoints and output values for ActiveX properties of type VT_DISPATCH are not supported.

l Checkpoints and output values for write-only ActiveX properties are not supported.

l If you perform an update run (Run > Update Run Mode) on a test that contains checkpoints or
output values for windowless ActiveX controls, and then you rerun the test, the run sessionmay
fail. This is because a hidden property called "windowless" is missing from the test object
description.

Workaround:You can either relearn the problematic ActiveX controls, or you can add the
"windowless" property with a value of 1 to all problematic, windowless ActiveX controls.

Unsupported Controls
UFT does not support certain ActiveX controls or controls with certain prefixes. These controls are
listed in the table below.

Unsupported Control Prefixes Unsupported Controls

Msawt AMOVIE.ActiveMovieControl.2

SpectrumHR.GrabBag MediaPlayer.MediaPlayer.1

SpectrumHR.EDataControl Trident.HTMLEditor.1

SpectrumHR.SSDBGridEventHandler htmlfile

ShockwaveFlash xmlfile

Spider90 htmlfile_FullWindowEmbed

XGO xmlfile_FullWindowEmbed

lnkfile

JScript

VBScript

MSJava

PDF.PdfCtrl.1

ScriptBridge.ScriptBridge.1

JavaSoft.JavaBeansBridge.1

Add-ins Guide
Chapter 9: ActiveX Add-in - Quick Reference
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Unsupported Control Prefixes Unsupported Controls

Oracle.JavaBeansBridge.1

Spider.Loader.1

COMCTL.ImageListCtrl.1

ActiveTabs.SSTabPanel.4

ActiveTabs.SSTabPanel.2

ActiveTabs.SSTabPanel.3

{3050f67D-98b5-11cf-bb82-00aa00bdce0b}

{3050F5C8-98B5-11CF-BB82-00AA00BDCE0B}

TriEditDocument.TriEditDocument.1

Miner3D.Miner3DObj.1

ActiveBar2Library.ActiveBar2.2

{275C23E2-3747-11D0-9FEA-00AA003F8646}

SpectrumHR.GrabBag.1

SpectrumHR.EDataControl.1

SpectrumHR.SSDBGridEventHandler.1

Add-ins Guide
Chapter 9: ActiveX Add-in - Quick Reference
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Chapter 10: Delphi Add-in - Quick Reference
You can use the UFT Delphi Add-in to test Delphi user-interface objects (controls).

The following tables summarize basic information about the Delphi Add-in and how it relates to
some commonly-used aspects of UFT.

General Information

Add-in Type This is aWindows-based add-in. Much of its functionality is the same as other
Windows-based add-ins.

See "Windows-Based Application Support" on page 94.

Supported
Environments

The Delphi Add-in supports testing on Delphi controls created in the Delphi IDE
and based on theWin32 VCL library. For details on supported Delphi
environments, see the Delphi Add-in section of the , available from the UFT
Help or the root folder of the Unified Functional Testing DVD.HP Unified
Functional Testing Product Availability Matrix

Test Object
Methods and
Properties

The Delphi Add-in provides test objects, methods, and properties that can be
used when testing objects in Delphi applications. For details, see theDelphi
section of theHP UFT Object Model Reference for GUI Testing.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

Extending the
Delphi Add-in

"Delphi Add-in Extensibility" (described on page 170 enables you to develop
support for testing third-party and custom Delphi controls that are not supported
out-of-the-box by the UFT Delphi Add-in.

Prerequisites

Opening Your
Application

You can open your Delphi application before or after opening UFT.

Add-in
Dependencies

None

Other Before running a test on a Delphi application, the application being tested
must be compiled with the UFT agentMicDelphiAgent.

See "How to Enable Communications Between UFT and Your Delphi
Application" on page 171.

Configuration
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Options Dialog
Box

Use theWindows Applications pane.
(Tools > Options > GUI Testing tab > Windows Applications node)

See "Windows Applications > General Pane (Options Dialog Box >
GUI Testing Tab)" on page 98.

Record and Run
Settings Dialog
Box
(tests only)

Use theWindows Applications tab.
(Record > Record and Run Settings)

See "Windows Applications Tab (Record and Run Settings Dialog Box)" on
page 109.

Note:

l UFT recognizes only Delphi applications that have been
precompiled with theMicDelphiAgent.pasmodule. For details, see
"How to Enable Communications Between UFT and Your Delphi
Application" on page 171.

l In some cases, if you select theRecord and Run only on radio
button, the settings may also apply to (limit) the applications that are
recognized for Object Spy and other pointing hand operations.

Custom Active
Screen Capture
Settings Dialog
Box
(tests only)

Use theWindows section.
(Tools > Options > GUI Testing tab > Active Screen pane > Custom
Level button)

See the section on the Custom Active Screen Capture Settings dialog box
in theHP Unified Functional Testing User Guide.

Application Area
Additional
Settings pane
(business
components only)

Use theApplications pane.
In the application area, select Additional Settings > Applications in the
sidebar.

See the section on the Applications pane in theHP Unified Functional
Testing User Guide.

This chapter includes:

Concepts 170

Delphi Add-in Extensibility 170

Tasks 171

How to Enable Communications Between UFT and Your Delphi Application 171

Reference 173

Troubleshooting and Limitations - Delphi Add-in 173

Add-ins Guide
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Concepts

Delphi Add-in Extensibility
UFT Delphi Add-in Extensibility enables you to develop support for testing third-party and custom
Delphi controls that are not supported out-of-the-box by the UFT Delphi Add-in.

If the test object class that UFT uses to represent your control does not provide the operations and
properties necessary to operate on your control, you can use Delphi Add-in Extensibility to
customize this behavior.

l You canmap the control to an existing test object class.

l You canmap the control to a new test object class that you create, and design the test object
class behavior in Delphi code. You can program how operations are performed on the control,
how properties are retrieved, andmore.

l You can also teach UFT to treat a control that contains a set of lower-level controls as a single
functional control, instead of relating to each lower-level control separately.

To implement Delphi Add-in Extensibility, you need to be familiar with:

l UFT and its Object Model Reference

l The behavior of the custom control (operations, properties, events)

l XML (basic knowledge)

l Delphi programming

Delphi Add-in Extensibility is available as part of the Delphi Add-in and does not require an
additional installation.

UFT also provides samples of support developed using Delphi Add-in Extensibility, which you can
use to gain a better understanding of how to create your own support.

For details on implementing Delphi Add-in Extensibility, see the Delphi Add-in Extensibility Help,
available from the UFT Extensibility Documentation program group (Start > All Programs >
HP Software > HP Unified Functional Testing > Extensibility > Documentation).

Note: For details on accessing UFT and UFT tools and files inWindows 8, see "Accessing
UFT inWindows 8Operating Systems" on page 547.

A printer-friendly (PDF) version of theHP UFT Delphi Add-in Extensibility Developer Guide is
available in the <UFT installation folder>\help\Extensibility folder.
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Tasks

How to Enable Communications Between UFT and Your
Delphi Application

This task describes how to:

l Use the MicDelphiAgent.pasmodule to enable communications between UFT and each
Delphi project you want to test.

l Configure support for the TwwDBGrid from InfoPower.

Link to the MicDelphiAgent.pas Module to Enable Communications
Youmust perform the following steps for each application that you want to test.

1. Add the <UFT Installation folder>\dat\Extensibility\Delphi folder to your Delphi
project search path, or copy the contents of the <UFT Installation
folder>\dat\Extensibility\Delphi folder to your project folder.

2. AddMicDelphiAgent to theUses section of your application's project file (project.dpr) as
shown in the example below:

program flight;
uses

MicDelphiAgent,
Forms,
Windows;

($R*.RES)
begin

Application.Initialize
Application.Title :='Flight Reservation';
Application.Run;

end.

3. Compile your Delphi project.

Note: If your application includes the TwwDBGrid from InfoPower, youmust add support
for this grid as described below..
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Configure Support for TwwDBGrid
If your application includes the TwwDBGrid from InfoPower, do the following to enable support for
this grid:

1. AddMicWWSupport to theUses section of your application's project file (project.dpr) after
MicDelphiAgent, as shown in the example below:

program flight;
uses

MicDelphiAgent,
MicWWSupport,
Forms,
Windows;

($R*.RES)
begin

Application.Initialize
Application.Title :='Flight Reservation';
Application.Run;

end.

2. Recompile your application.

You are now ready to create and run tests on Delphi applications.

Add-ins Guide
Chapter 10: Delphi Add-in - Quick Reference
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Troubleshooting and Limitations - Delphi Add-in
Button controls in message boxes are identified asWinButton objects instead of DelphiButton
objects.

Workaround:Replace the button control test objects in the object repository withDelphiButton
objects.

Add-ins Guide
Chapter 10: Delphi Add-in - Quick Reference
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Chapter 11: Flex Add-in - Quick Reference
You can use the UFT Flex Add-in to test Flex user-interface objects (controls).

The following tables summarize basic information about the Flex Add-in and how it relates to some
commonly-used aspects of UFT.

General Information

Supported
Environments

Tested applications must be built with Flex SDK versions that are supported
by the UFT Flex Add-in.

For details on supported Flex SDK versions, see the Flex section of the
HP Unified Functional Testing Product Availability Matrix, available from the
UFT Help or the root folder of the Unified Functional Testing DVD.

Important
Information

l Flex applications must either be opened using the UFT Runtime Loader
or preparedmanually for testing.

Preparing the application consists of embedding the application in aWeb
page together with the Runtime Loader, or recompiling the application
with the relevant Adobe or Apache Flex automation libraries and a UFT
Flex pre-compiled agent. For details, see:

n "Considerations - Flex Add-in" on page 177

n "How to Open Flex Applications Using the Runtime Loader" on page
184

n "How to Prepare Flex Applications for UFT Testing" on page 180

Test Object
Methods and
Properties

The Flex Add-in provides Flex test objects, methods, and properties that can
be used when testing Flex objects in Flex applications. For details, see the
Flex section of theHP UFT Object Model Reference for GUI Testing.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

Troubleshooting
and Limitations

"Troubleshooting and Limitations - Flex Add-in " on page 191

Prerequisites

Opening Your
Application

You can open your Flex application before or after opening UFT.
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Add-in
Dependencies

l Different versions of the Flex SDK require different versions of Adobe Flash
Player or Adobe Air.

The Flex Add-in requires the versions of Adobe Flash Player or Adobe Air
that are required by the version of the Flex SDK used to build the application
being tested. For more details, see the Adobe Flex SDK or Apache Flex
SDK documentation.

l If you are testing Flex applications that were compiled using Adobe Flex
SDK versions 4.5.x or 4.6.x, verify that you have licensed versions of the
relevant Adobe Automation libraries before running full UFT GUI tests and
components. If you do not have licensed versions of the libraries, consider
upgrading to Apache Flex SDK version 4.9.x.

l UFT interacts with the UFT Flex Agent via a local TCP socket object
(#24654). If the communication port #24654 is occupied by another software
program (for example, by aWeb server), the add-in fails to load properly. If
the port is occupied, configure the application using this port to use another
port.

Configuration

Record and Run Settings Dialog
Box
(tests only)

Use the Flex tab.
(Record > Record and Run Settings)

See "Flex Tab (Record and Run Settings Dialog Box)" on
page 186.

This chapter includes:

Concepts 177

Considerations - Flex Add-in 177

Tasks 180

How to Prepare Flex Applications for UFT Testing 180

How to Embed a Flex Application in aWeb Page with the Runtime Loader 182

How to Open Flex Applications Using the Runtime Loader 184

Reference 186

Flex Tab (Record and Run Settings Dialog Box) 186

Troubleshooting and Limitations - Flex Add-in 191
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Concepts

Considerations - Flex Add-in
Considerations when working with the Flex Add-in include issues relating to the following:

l "Opening your Flex application using a Runtime Loader or preparing your Flex application for
testing" below

l "Opening Flex applications with Adobe Flash Player Projector" on the next page

l "Working with or without theWeb Add-in" on the next page

l "Register local Web-based Flex applications as trusted applications" on page 179

Opening your Flex application using a Runtime Loader or preparing your
Flex application for testing
Youmust open Flex applications using the UFT Flex Runtime Loader or prepare the applications
manually for UFT testing.

You can prepare a Flex application for testing in one of the following ways:

l Recompile the application with the relevant Adobe or Apache Flex automation libraries and a
UFT Flex pre-compiled agent. This agent enables UFT to communicate with the application.

l Embed the Flex application and the UFT Flex Runtime Loader in aWeb page, and open the
application by opening that page.

Which method should I use for my Flex application?

l Use the Runtime Loader to open the application if you are testing a Flex Web application (.swf
file).

For task details, see "How to Open Flex Applications Using the Runtime Loader" on page 184.

l Embed your application in aWeb page with the Runtime Loader if you are testing a Flex Web
application (.swf file) that is not already embedded in an HTML file.

For task details, see "How to Embed a Flex Application in aWeb Page with the Runtime Loader"
on page 182.

l Recompile your application with the relevant Adobe or Apache Flex automation libraries and the
UFT Flex pre-compiled agent if your applicationmeets one or more of the following conditions:

n The application is already embedded in an HTML file

n The application is an Adobe AIR application

n The application uses the Flex charting or AdvancedDataGrid classes
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n You cannot copy the Runtime Loader file to theWeb server on which the Flex application
runs.

For task details, see "How to Prepare Flex Applications for UFT Testing" on page 180.

Note:

l To use the Runtime Loader with an application hosted on aWeb server, your access to the
server must allow you to copy the Runtime Loader file to the server.

l If you use tests that were recorded on pre-compiled Flex applications to test Flex
applications opened with the Runtime Loader (or vice versa), youmay need tomodify the
object repositories associated with the test and any test scripts that use programmatic
descriptions to identify Flex test objects.

The uid property value in all Flex test objects and the id property value in FlexWindow test
objects will differ between applications opened with the Runtime Loader and pre-compiled
Flex applications. Before running your test, make sure that test objects whose descriptions
includes these properties match the objects found in the application you are testing.

Opening Flex applications with Adobe Flash Player Projector
Using the Runtime Loader, you can only open Flex applications in Internet Explorer (32-bit). This is
true when opening the applicationmanually, and when embedding it in aWeb page with the
Runtime Loader.

Therefore, if you want to test your Flex application in Adobe Flash Player Projector, do one of the
following:

l Prepare your application for testing by compiling it with the automation libraries and the UFT
Flex agent, as described in "How to Prepare Flex Applications for UFT Testing" on page 180.

l Instruct UFT to open the application with the Adobe Flash Player Projector using the Runtime
Loader when a record or run session begins. For details, see "Flex Tab (Record and Run
Settings Dialog Box)" on page 186.

Working with or without the Web Add-in
You can use the Flex Add-in with or without theWeb Add-in enabled. The test object hierarchy
differs as follows:

l With the Web Add-in enabled. Flex test objects have aWeb parent hierarchy.

For example:

Browser.Page.FlexWindow.FlexButton

Add-ins Guide
Chapter 11: Flex Add-in - Quick Reference

HP Unified Functional Testing (12.00) Page 178 of 549



l Without the Web Add-in enabled. Flex objects have aWindows parent hierarchy.

For example:

Window.WinObject.FlexWindow.FlexButton

Tip: It is recommended to enable theWeb Add-in when you are testing Flex applications so
that you can test Flex applications in browser windows.

Register local Web-based Flex applications as trusted applications
UFT does not recognize local Web-based Flex applications as Flex test objects until you register
them as trusted applications. Local Web-based Flex applications are Flex applications that are
stored locally and run in a browser window.

If you are opening your applications using a local Runtime Loader file, you also need to register the
UFTFlexAUTLoader.swf file as a trusted application.

Register your local Web-based Flex applications and Runtime Loader file by adding the paths of the
folders that contain them to one of the following:

l The Trusted Locations list in the Flash Player Global Settings.

l A text file located in the FlashPlayerTrust folder in the following location:
%appdata%\Macromedia\Flash Player\#Security\FlashPlayerTrust

Each line in the text file must contain the name of a folder to trust. For each specified folder, all
files in that folder or any sub-folders are trusted. For example:

# Trust all files in the Employee online calendar application folder
%ProgramFiles%\Personnel\Employees\OnlineCalendar

Note:

n The %appdata% folder is hidden inWindows by default. To show hidden folders, open the
Windows Explorer Folder Options dialog box and select Show hidden files and
folders.

n Create the #Security\FlashPlayerTrust folder, if it does not exist.

n The UFT Flex Runtime Loader is installed with UFT, in the following location: <UFT
installation folder>\dat\Flash\Flex\Runtime Loader\UFTFlexAUTLoader.swf.

Add-ins Guide
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Tasks

How to Prepare Flex Applications for UFT Testing
You can prepare a Flex application for testing in one of the following ways:

l Recompile the application with the relevant Adobe or Apache Flex automation libraries and a
UFT Flex pre-compiled agent. This agent enables UFT to communicate with the application.

l Embed the Flex application and the UFT Flex Runtime Loader in aWeb page, and open the
application by opening that page.

This task describes the steps required to recompile Flex applications in preparation for testing.

For details on embedding the application and the Runtime Loader in aWeb page, see "How to
Embed a Flex Application in aWeb Page with the Runtime Loader" on page 182.

Note:

If you are testing a Flex Web application (.swf), you can use the UFT Flex Runtime Loader to
open the application instead of preparing the application for testing. For details, see "How to
Open Flex Applications Using the Runtime Loader" on page 184.

To determine the best method to use for opening and testing your application, see "Opening
your Flex application using a Runtime Loader or preparing your Flex application for testing" on
page 177.

This section includes:

l "Prepare a Flex application forWeb, when the Flex application is embedded in an HTML file"
below

l "Prepare a Flex application for Adobe AIR for testing" on the next page

l "Prepare a Flex application hosted by the Adobe Flash Player ActiveX control or Adobe Flash
Player Projector (including the content debuggers)" on the next page

l "Prepare a Flex application that uses the Flex charting or AdvancedDataGrid classes" on page
182

Prepare a Flex application for Web, when the Flex application is embedded
in an HTML file

1. Link the Flex application to Adobe or Apache Flex automation libraries and a UFT Flex pre-
compiled agent. To do this, add the following compiler arguments in the Flex project, and then
recompile the application:
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-include-libraries "<PATH_TO_UFT_ROOT>\dat\Flash\Flex\HpQTPAgent.swc"
-include-libraries "${flexlib}\libs\automation\automation_agent.swc"
-include-libraries "${flexlib}\libs\automation\automation.swc"
-include-libraries "${flexlib}\libs\automation\automation_spark.swc"

2. Embed the Flex application in a host .html document.

3. When testing, run your application by opening the host document in aWeb browser.

Prepare a Flex application for Adobe AIR for testing
Link the Flex AIR application to Adobe or Apache Flex automation libraries and a UFT Flex pre-
compiled agent. To do this, add the following compiler argument in the Flex AIR project, and then
recompile the application:

-include-libraries "<PATH_TO_UFT_ROOT>\dat\Flash\Flex\HpQTPAgent.swc"
-include-libraries "${flexlib}\libs\automation\automation_agent.swc"
-include-libraries "${flexlib}\libs\automation\automation.swc"
-include-libraries "${flexlib}\libs\automation\automation_spark.swc"
-include-libraries "${flexlib}\libs\automation\automation_air.swc"
-include-libraries "${flexlib}\libs\automation\automation_airspark.swc"

Prepare a Flex application hosted by the Adobe Flash Player ActiveX
control or Adobe Flash Player Projector (including the content debuggers)

1. Link the Flex application to Adobe or Apache Flex automation libraries and a UFT Flex pre-
compiled agent. To do this, add the following compiler argument in the Flex project, and then
recompile the application:

-include-libraries "<PATH_TO_UFT_ROOT>\dat\Flash\Flex\HpQTPAgent.swc"
-include-libraries "${flexlib}\libs\automation\automation_agent.swc"
-include-libraries "${flexlib}\libs\automation\automation.swc"
-include-libraries "${flexlib}\libs\automation\automation_spark.swc"

2. When testing, run your application by opening it in one of the following:

n an Adobe Flash Player ActiveX control (or the Flash Player ActiveX control content
debugger)

n the Adobe Flash Player Projector (or the Flash Player Projector content debugger)

Add-ins Guide
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Prepare a Flex application that uses the Flex charting or
AdvancedDataGrid classes
Link the Flex application to the automation_dmv.swc library. To do this, add the following compiler
argument in the Flex project and then recompile your application:

-include-libraries "${flexlib}\libs\automation\automation_dmv.swc"

How to Embed a Flex Application in a Web Page with the
Runtime Loader

This task describes how to embed a Flex application in aWeb page together with the UFT Flex
Runtime Loader. UFT can then test the application when this Web page is opened in Internet
Explorer.

Note: This method is useful if you are testing a Flex Web (.swf) application that is not already
embedded in an HTML file. For other methods of preparing or opening Flex applications for UFT
testing, see "Considerations - Flex Add-in" on page 177.

1. Prerequisites
The UFT Flex Runtime Loader is installed with UFT, in the following location: <UFT
installation folder>\dat\Flash\Flex\Runtime Loader\UFTFlexAUTLoader.swf.

n Make sure that the UFT Flex Runtime Loader is located in the same application and security
domain as the Flex application you are testing.

If the application you are testing resides on aWeb server, youmust place a copy of the
Runtime Loader on the sameWeb server and use that copy to open the application.

If the application is on the file system, use the Runtime Loader stored in the file system.

n If you use a copy of the Runtime Loader, and not the one stored in the <UFT installation
folder>\dat\Flash\Flex\Runtime Loader folder, make sure to recopy the file after any UFT
upgrade to ensure that you use themost recent file version provided with UFT.

2. Create the Web page
Make a copy of the UFT sampleWeb page located in <UFT installation
folder>\dat\Flash\Flex\Runtime Loader\UFTFlexAUTLoader_Sample.html. Store this file
in the same application and security domain as the UFT Flex Runtime Loader and the Flex
application you are testing.

When you test your application using UFT, run the application by opening this file in Internet
Explorer.

3. Update the Runtime Loader location specified in the Web page -
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optional
If the Runtime Loader is located in a different folder than the html file you created, modify the
Runtime Loader file name to include a path.

Locate this line tomake the change:

<param name="movie" value="UFTFlexAUTLoader.swf" />

The path can be a URL (if the Runtime Loader is located on aWeb server), a full file system
path, or a path relative to the location of the html file.

For example:

<param name="movie" value="C:\MyApps\FlexRT\UFTFlexAUTLoader.swf" />

4. Embed the Flex application in the Web page
Enter your application file name and, optionally, parameters, in the swf_url parameter, in the
following lines (2 places):

<param name="FlashVars" value="swf_url=YourApplication.swf" />
<embed id="loader"
       width="100%" height="100%" align="middle"
       src="UFTFlexAUTLoader.swf"
       flashvars="swf_url=YourApplication.swf"/>

Use the following syntax:

swf_url=<ApplicationName.swf>&<param_name1>=<param_value1>&<param_
name2>=<param_value2>
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ApplicationName The file name of the Flex application that you want to open.

If the application is stored in a different folder than the Runtime
Loader, provide the URL or file system path to the application.

For example:

swf_url=http://some_server/MyApp.swf

swf_url=C:\\Flex\\AUTs\\MyApp45.swf

Tip: A file system path can be a full path or the path relative to the
location of the Runtime Loader.

param_
names=param_
values

(Optional) A list of parameters and their values to pass to the
application being opened. Parameters are separated by the
ampersand (&) character.

For example:

swf_url=MyApplication.swf&param_name=param_value&para
m2_name=param2_value

How to Open Flex Applications Using the Runtime
Loader

This task describes how to open Flex applications for UFT testing in Internet Explorer, using the
UFT Flex Runtime Loader.

The UFT Flex Runtime Loader enables you to test Flex applications (.swf files) directly without
having to prepare the applicationmanually for testing.

Note: You can use the Runtime Loader only when testing .swf files directly. If you are testing a
Flex application that must remain embedded in an HTML file, or other types of Flex
applications, see "How to Prepare Flex Applications for UFT Testing" on page 180.

Prerequisites
The UFT Flex Runtime Loader is installed with UFT, in the following location: <UFT installation
folder>\dat\Flash\Flex\Runtime Loader\UFTFlexAUTLoader.swf.

l Make sure that the UFT Flex Runtime Loader is located in the same application and security
domain as the Flex application you are testing.
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If the application you are testing resides on aWeb server, youmust place a copy of the Runtime
Loader on the sameWeb server and use that copy to open the application.

If the application is on the file system, use the Runtime Loader stored in the file system.

l If you use a copy of the Runtime Loader, and not the one stored in the <UFT installation
folder>\dat\Flash\Flex\Runtime Loader folder, make sure to recopy the file after any UFT
upgrade to ensure that you use themost recent file version provided with UFT.

Open the Flex Web application using the Runtime Loader
Open the application in a 32-bit Internet Explorer, using the following syntax in the URL box:

<UFTFlexAUTLoaderPath.swf>?swf_url=<ApplicationName.swf>&<param_name1>=<para
m_value1>&<param_name2>=<param_value2>

UFTFlexAUTLoaderPath The URL or file system path to the UFT Flex Runtime Loader file.

ApplicationName The file name of the Flex application that you want to open.

If the application is stored in a different folder than the Runtime
Loader, provide the URL or file system path to the application.

Tip: A file system path can be a full path or the path relative to
the location of the Runtime Loader.

param_names=param_
values

(Optional) A list of parameters and their values to pass to the
application being opened. Parameters are separated by the
ampersand (&) character.
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Reference

Flex Tab (Record and Run Settings Dialog Box)
This tab enables you to define preferences for recording and running tests on Flex applications.

To access Select Record > Record and Run Settings and then select the Flex tab.

Note: The Record and Run Settings dialog box also opens automatically
each time you begin recording a new test (unless you open the dialog box and
set your preferences manually before you begin recording).

Important
information

l If you load only the UFT Flex Add-in, then only the Flex andWindows
Applications tabs are displayed in the Record and Run Settings dialog box. If
other add-ins are loaded, the corresponding tabs (if any) are also displayed.
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Relevant
tasks

l "How to Prepare Flex Applications for UFT Testing" on page 180

l "How to Open Flex Applications Using the Runtime Loader" on page 184

See also "Considerations - Flex Add-in" on page 177

User interface elements are described below:

UI Elements Description

Record and run
test on any
open Flex
application

Instructs UFT to record all operations performed on any UFT-ready Flex
application that is open while recording your test, and to run steps on any
such application during a run session.

UFT records and runs only on Flex applications that are opened using the
UFT Flex Runtime Loader, or Flex applications that are preparedmanually for
UFT testing. For details, see "Considerations - Flex Add-in" on page 177.

Open the
following
applications
when a record
or run session
begins

Instructs UFT to open specific Flex applications at the beginning of a record
or run session.

Note: This setting controls only which application, if any, is opened at
the beginning of a record or run session. It does not affect the
applications that UFT recognizes. Even if this radio button is selected
and no application is specified, UFT can still record, recognize, and run
on any open UFT-ready Flex application.

Flex
application
details

The details of the applications to open.

Each row in the table lists one application and specifies the following:

l The location of the application

l The parameters to pass to the application (optional)

l The browser or Flash player with which to open the Flex application

For more details, see "Add/Edit Flex Application Dialog Box".

Add. Opens the "Add/Edit Flex Application Dialog Box" (described on page
188), which enables you to add an application to the application list. You can
add up to ten applications.

Edit. Opens the "Add/Edit Flex Application Dialog Box" (described on page
188), which enables you to edit the application details for the selected
application.

Delete. Removes the selected application from the application list.
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Add/Edit Flex Application Dialog Box

This dialog box enables you to add details for an application or to edit details for the application that
you selected in the Flex tab of the Record and Run Settings dialog box.

To access In the "Flex Tab (Record and Run Settings Dialog Box)" (described on page 186),

click theAdd button or theEdit button .

Important
information

l For each application, the details entered in this dialog box are displayed as a
single row in the application details table in the Flex tab of the Record and Run
Settings dialog box.

Relevant
tasks

l "How to Prepare Flex Applications for UFT Testing" on page 180

l "How to Open Flex Applications Using the Runtime Loader" on page 184

See also "Flex Tab (Record and Run Settings Dialog Box)" on page 186
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User interface elements are described below:

UI Elements Description

Open Flex
application using
UFT Flex Runtime
Loader

Instructs UFT to open the specified Flex application using the UFT Flex
Runtime Loader.

This option is relevant only when testing .swf files directly. If you are
testing a Flex application that must remain embedded in an HTML file,
or other types of Flex applications, select Open a Flex application
prepared specifically for UFT testing.

For more details, see "How to Open Flex Applications Using the
Runtime Loader" on page 184.

Runtime Loader
URL

Only for applications hosted on aWeb server:

The URL to the Runtime Loader with which to open the Flex
application.

Note: Youmust place a copy of the Runtime Loader on the same
server as the Flex application, and provide the URL to this file.

If your Flex application is located on the file system, do not specify
a Runtime Loader. UFT uses the Runtime Loader installed with
UFT.

Open a Flex
application prepared
manually for UFT
testing

Instructs UFT to open the Flex application directly.

Use this option only if one of the following conditions is met:

l The Flex application was compiled with libraries that support UFT
testing, as described in "How to Prepare Flex Applications for UFT
Testing" on page 180

l The Flex application was embedded in aWeb page with the UFT
Flex Runtime Loader, as described in "How to Embed a Flex
Application in aWeb Page with the Runtime Loader" on page 182.

Add-ins Guide
Chapter 11: Flex Add-in - Quick Reference

HP Unified Functional Testing (12.00) Page 189 of 549



UI Elements Description

Application path The file system path or URL to the Flex application to open.

Note:

l TheApplication box should contain only the file name and path
for the application. If you want to add command line arguments,
use theParameters box.

l If your application is the default page on theWeb server host,
the URL that you enter does not have to include the file name.
For example, if http://mysite/home and
http://mysite/myApp.html open the same application, you can
enter http://mysite/home.

l Unicode character support: The Flex Runtime Loader fails
to open the application if the file system path includes certain
Unicode fullwidth characters. For example, make sure not to
include English fullwidth letters or Japanese fullwidth number
characters.

Parameters (Optional) Parameters to pass to the application when UFT opens it.

For Flex applications, enter the parameter names and values,
separated by the ampersand (&) symbol, using the following syntax:

<parameter name>=<parameter value>&<parameter name>=<p
arameter value>

For Adobe Air applications (.exe), enter the parameter values,
separated by spaces:

<value1> <value2>
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UI Elements Description

Open with The host with which to open the Flex application (not relevant for
standalone (.exe) applications).

Possible values:

l <Empty> (for .exe applications)

l Internet Explorer (32bit)

l Adobe Flash Player Projector (for .swf applications only)

If you select Adobe Flash Player Projector, you can use the
browse button to select a specific Flash Player program to use for
this application. The path to the selected program is then displayed
under the drop down list.

Troubleshooting and Limitations - Flex Add-in
This section describes troubleshooting and limitations for the Flex Add-in.

General Functionality

l The Flex Add-in does not provide backward compatibility with the Adobe Flex Add-in for
QuickTest, and uses a different set of test objects, methods, and properties. Legacy QuickTest
tests recorded using the Adobe Flex Add-in cannot be used, and they cannot be upgraded to be
used with the UFT Flex Add-in.

l The Flex Add-in does not support cross-domain or cross-host Flex applications. These types of
applications are Flex applications where the HTML and SWF files are served from different
domains, or from different hostnames within the same domain. For example, if an HTML page on
www.mysite.com references an SWF file located onwww.anothersite.com, or in
content.mysite.com.

l Testing Flex applications in UFT is only supported in Internet Explorer 32-bit browser versions.

l The UFT Flex Runtime Loader does not support applications that containmx::AreaChart
controls.

l To communicate with the Flex application, UFT selects an available port within the range 24654
- 24663. Make sure that at least one of these ports is available on the UFT computer.

n On aWindows server, multiple users can runmultiple instances of UFT. To test Flex
applications, youmust have one port in this range available for each UFT instance.

n If you are testing a Flex application, youmay experience a delay (up to oneminute) from the
moment you open UFT and your Flex application, until UFT can recognize objects in the
application. This is due to the time it may take for UFT to locate an available port, as it cycles
through the ports in this range, waiting for the socket connection timeout for each.
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Active Screen

l The Active Screen pane is not fully supported for Flex test objects, andmay not display the
recorded steps correctly.

Object Identification

l When identifying objects in a Flex application opened in aWeb browser, the FlexWindow top-
level test object is contained in a Page object.

l WhenUFT opens a Flex application in Internet Explorer version 10 or 11 using the UFT Runtime
Loader, the application is opened as a windowless Flex application.

l The Navigate and Learn option is not supported for windowless Flex applications.

Workaround: To simultaneously add all or specific child objects from awindowless Flex
application to an object repository, do the following:

a. Start by adding one of the Flex child objects to the repository. In theObject Selection - Add
to Repository dialog box, select the parent FlexWindow object instead of the original object
you'd selected.

b. In theDefine Object Filter dialog box, select eitherAll object types to learn all child
objects, or click Select to select the specific types of child objects you want to add.

For more details about adding objects to object repositories, see the chapter on test objects in
theHP Unified Functional Testing User Guide.
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Chapter 12: Java Add-in - Quick Reference
You can use the UFT Java Add-in to test Java user-interface objects (controls).

The following tables summarize basic information about the Java Add-in and how it relates to some
commonly-used aspects of UFT.

General Information

Supported
Environments

l You can run steps on Java objects in environments such as Internet
Explorer, Mozilla Firefox, JavaWeb Start, Applet Viewer, and in
standalone Java applications.

l For details on supported Java toolkits and versions, see the Java Add-in
section of theHP Unified Functional Testing Product Availability Matrix,
available from the UFT Help or the root folder of the Unified Functional
Testing DVD.

Important
Information

"Considerations - Java Add-in" on page 197

Test Object
Methods and
Properties

The Java Add-in provides customized Java test objects, methods, and
properties that can be used when testing objects in Java applications. For
details, see the Java section of theHP UFT Object Model Reference for
GUI Testing.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide.

l See "Text Checkpoint and Text Output Value Steps for JavaObjects" on
page 212.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

Extending the
Java Add-in

"Java Add-in Extensibility" (described on page 198) enables you to develop
support for testing third-party and custom Java controls that are not
supported out-of-the-box by the UFT Java Add-in.

Troubleshooting
and Limitations

" Troubleshooting and Limitations - Java Add-in" on page 200

Prerequisites

Opening Your
Application

You can open your Java application before or after opening UFT.

Note: If you cannot open your Java application after starting UFT, you
may have amemory fragmentation issue. Check your memory settings,
and see "Opening Java Applications After Opening UFT" on page 204.
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Add-in
Dependencies

The UFT Java Add-in can be installed and run together with any other UFT add-
in. When testing Java applets in aWeb browser, if your tests include
operations onWeb test objects, youmust load theWeb Add-in as well as the
Java Add-in and use theWeb tab of the Record and Run Settings dialog box to
specify your record and run preferences.

Configuration

Options
Dialog Box

Use the Java pane.
(Make sure that a GUI test is open and select Tools > Options > GUI Testing
tab > Java node.)

See "Java Pane (Options Dialog Box > GUI Testing Tab)" on page 221.

Record and
Run
Settings
Dialog Box
(tests only)

Use the Java tab.
(Record > Record and Run Settings

See "Java Tab (Record and Run Settings Dialog Box)" on page 231.

Test
Settings
Dialog Box
(tests only)

Use the Java pane.
(File > Settings > Java node)

See "Java Pane (Test/Business Component Settings Dialog Box / Application
Area - Additional Settings Pane)" on page 228.

Custom
Active
Screen
Capture
Settings
Dialog Box
(tests only)

Use the Java section.
(Tools > Options > GUI Testing tab > Active Screen node > Custom Level)

See the section on the Custom Active Screen Capture Settings dialog box in the
HP Unified Functional Testing User Guide.

Application
Area
Additional
Settings
pane
(business
components
only)

l Use the Java pane.
In the application area, select Additional Settings > Java in the sidebar.

l See "Java Pane (Test/Business Component Settings Dialog Box / Application
Area - Additional Settings Pane)" on page 228. (For business components, the
settings displayed in this pane are read-only. To change the Java pane settings
for a business component, open its associated application area and use the
application area's Additional Settings > Java pane.)

This chapter includes:

Concepts 197

Considerations - Java Add-in 197

Java Add-in Extensibility 198

Reference 200
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Java Environment Variables Settings 200

Troubleshooting and Limitations - Java Add-in 200
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Concepts

Considerations - Java Add-in
When learning objects and running steps on Java applications, consider the following:

l After installing the Java Add-in, Java applets and applications will always open with Java
support active. You can confirm that your Java environment has opened properly by checking
the Java console for amessage similar to the following confirmationmessage: "Loading
Unified Functional Testing Java Support (version x.x.x.x) (<App> version
x.x.x.x)." (where <App> is IE, IBM, or Oracle).

l TheObject property can access only publicmethods and properties. A recommended
alternative to using theObject property is to extend UFT support for the required Java object
using UFT Java Add-in Extensibility. For details, see theHP UFT Java Add-in Extensibility
Developer Guide.

l You cannot add SWT-based JavaMenu objects directly to an object repository using theAdd
Objects to Local button in the Object Repository window or theAdd Objects button in the
Object Repository Manager. If you want to add an SWT-based JavaMenu objects to the object
repository, you can use theAdd Objects orAdd Objects to Local button to add its parent
object and then select to add the parent object together with its descendants. Alternatively, you
can add a JavaMenu object using theNavigate and Learn option in the Object Repository
Manager. For details, see the section on adding test objects using the Navigate and Learn
toolbar in theHP Unified Functional Testing User Guide.

l If you want to use a control's native property for object identification, you can add the property to
a Java test object as an identification property in the Add/Remove Properties Dialog Box dialog
box. If you do this, consider the following:

n You can add only native properties for which the control has a public get or ismethod that
returns the property value.

n If the native property name includes upper-case letters, then in the corresponding
identification property name that you create, youmust replace each of the upper-case letters
except the first one with _<lower-case letter>. For example, to use the native property
OneSmallProp, add an identification property named One_small_prop.

For more details on adding identification properties, see the section on theObject
Identification dialog box in theHP Unified Functional Testing User Guide.

l In early releases of QuickTest, Java identification properties were not case-sensitive. If you
learned a test object in a QuickTest version earlier than 11.00, you need to re-learn the object
with properties that are case-sensitive by performing anUpdate Run (using theUpdate test
object descriptions option). For details, see the section on Updating Test Object Descriptions
in theHP Unified Functional Testing User Guide.
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l In UFT, table data is always loaded from the application itself, even if the Active Screen
contains an image of the table. For this reason, youmust first open the table in the application
before creating a table checkpoint in a test.

n In some cases youmay have to scroll to the last row of the table tomake sure that all the data
is loaded.

n It is not necessary to open the table in your application to edit an existing table checkpoint.

l If you load or unload an add-in that is displayed as a child of the Java add-in in the Add-in
Manager, only applications that are opened after loading or unloading the add-in are affected.

l Whenworking with tests, if you create a checkpoint on an SWT-based Java tree with columns,
a table checkpoint is created.

l For details on UFT functionality, see theHP Unified Functional Testing User Guide.

Java Add-in Extensibility
UFT Java Add-in Extensibility enables you to develop support for testing third-party and custom
Java controls that are not supported out-of-the-box by the UFT Java Add-in.

If the test object class that UFT uses to represent a control does not provide the operations and
properties necessary to operate on your control, you can use Java Add-in Extensibility to customize
this behavior.

l You canmap a custom control to an existing test object class, or to a new test object class that
you define

l You can design and customize the behavior of the test object classes by developing custom
Java support classes. You can program how operations are performed on the control, how
properties are retrieved, andmore.

l You can also teach UFT to treat a control that contains a set of lower-level controls as a single
functional control, instead of relating to each lower-level control separately.

To implement Java Add-in Extensibility, you need to be familiar with:

l UFT and its Object Model Reference

l The behavior of the custom control (operations, properties, events)

l XML (basic knowledge)

l Java programming

You can install the Java Add-in Extensibility SDK from theAdd-in Extensibility and Web 2.0
Toolkits option in the UFT setup program.
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The SDK also includes:

l A plug-in for the Eclipse Java development environment, which provides wizards and
commands that help you create and edit the support that you develop.

l Samples of support developed using Java Add-in Extensibility, which you can use to gain a
better understanding of how to create your own support.

For details on installing and implementing Java Add-in Extensibility, see the Java Add-in
Extensibility Help, available from the UFT Extensibility Documentation program group (Start > All
Programs > HP Software > HP Unified Functional Testing > Extensibility >
Documentation).

Note: For details on accessing UFT and UFT tools and files inWindows 8, see "Accessing
UFT inWindows 8Operating Systems" on page 547.

A printer-friendly (PDF) version of theHP UFT Java Add-in Extensibility Developer Guide is
available in the <UFT installation folder>\help\Extensibility folder.
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Reference

Java Environment Variables Settings
This section describes the environment variables that need to be set when you load your Java
application with UFT Java Add-in support. You need to set one or more environment variables to the
path name of the Java Add-in support classes folder.

Set the _JAVA_OPTIONS environment variable (Oracle) or the IBM_JAVA_OPTIONS environment
variable (IBM) as follows:

-Xrunjvmhook
-Xbootclasspath/a:"<UFT installation folder>\bin\java_shared\classes";
"<UFT installation folder>\bin\java_shared\classes\jasmine.jar"

The above settings should appear on one line (no newline separators).

If you are working with Oracle Java 6 or 7 (versions 1.6 or 1.7), youmust set an additional
environment variable, JAVA_TOOL_OPTIONS, with the value -agentlib:jvmhook

Tip: If needed, you can temporarily remove Java support by renaming the _JAVA_OPTIONS or
IBM_JAVA_OPTIONS environment variable. (If you are working with Java 5 or 6, you need to
rename the JAVA_TOOL_OPTIONS environment variable as well.) For example, youmust remove
Java support if you want to test ActiveX controls that are embedded in SWT- or Eclipse-based
applications.

Note:

You can also use short paths in these commands. For example:

-Xrunjvmhook -Xbootclasspath/a:C:\PROGRA~2\
HP\UNIFIE~1\bin\ JAVA_S~1\classes;C:\PROGRA~2\
HP\UNIFIE~1\bin\JAVA_S~1\classes\jasmine.jar

In this example, UFT is installed in the default installation folder (C drive, Program Files) on a
Windows 7 computer. PROGRA~2 denotes the Program Files (x86) folder, which is the
Program Files folder on 64-bit operating systems.

Troubleshooting and Limitations - Java Add-in
This section is intended to help pinpoint and resolve some common problems that may occur when
testing Java applets and applications.

In some cases, running another Java application or applet with the exact same settings helps
determine whether you are encountering a general problem with the Java Add-in or an application-
specific problem. For details, see
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This section includes:

l "Running Another Java Application or Applet with the Same Settings" below

l "Identifying and Solving Common Problems" below

l "General Notes and Limitations" on page 203

Running Another Java Application or Applet with the Same Settings

You can run another Java application or applet with the same settings as the one you are currently
running to help determine whether you are encountering a general problem with the Java Add-in or
an application-specific problem.

When running another Java application or applet, do the following:

l Determine whether the application is a standalone application or an applet.

l If the application is an applet, check the browser type.

l If the applet is executed from a shortcut, execute another applet with the same command.

l If the applet is executed from a batch file, copy the batch file and change only the class file that
invokes the applet.

Note: If the classpathmust also be changed, add only the new items needed. Do not
remove any of the items from the original application or applet classpath.

Identifying and Solving Common Problems

The UFT Java Add-in provides a number of indicators that help you identify whether your add-in is
properly installed and functioning. The following table describes the indicators youmay see when
your add-in is not functioning properly and suggests possible solutions:

Indicator Solution

You cannot record or run tests on
Java applets or applications, or the
Object Spy identifies Java objects
as StandardWindows objects.

Make sure that the Java Add-in is loaded with UFT. To
check this, select Help > About Unified Functional
Testing and verify that the Java Add-in check box is
selected.

You load the Java Add-in using the Add-in Manager. For
details, see "How toManage UFT Add-ins" on page 32.
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Indicator Solution

You cannot record or run tests on
Java applets running onMicrosoft
Internet Explorer, and the Object
Spy identifies Java objects in these
applets as StandardWindows
objects.

If you are working on theMicrosoft Vista operating
system, or a later version of Microsoft Windows, and you
are using Oracle Java JRE 5 or 6 onMicrosoft Internet
Explorer 7 or later, the JVMmight not use the Java
settings added to your system's environment variables.

Use the Java Add-in JRE Support Tool to adjust your
computer's configuration to overcome this problem. The
tool is available in theStart > All Programs >
HP Software > HP Unified Functional Testing >
Tools program group.

Note: For details on accessing UFT and UFT tools
and files inWindows 8, see "Accessing UFT in
Windows 8Operating Systems" on page 547.

For details, see:

l "Java Environment Variables Settings" on page 200

l "General Notes and Limitations" on the next page

The Java console does not display a
line containing text similar to
"Loading Java Support".

Check that the settings in your environment correspond
to the environment settings defined in this chapter, or
check for a batch file that may override the settings.

For details, see:

l "Java Environment Variables Settings" on page 200

Note: For details on accessing UFT and UFT tools
and files inWindows 8, see "Accessing UFT in
Windows 8Operating Systems" on page 547.

A different applet or application
works with the Java Add-in, but the
application you want to test does not
work.

First check whether you can record and run tests if you
invoke the other Java applet or application using exactly
the same settings.

Check that the settings in your environment correspond
to the environment settings defined in this chapter, or
check for a batch file that may override the settings.

For details, see:

l "Java Environment Variables Settings" on page 200
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Indicator Solution

After installing the Java Add-in, you
cannot run Java applications using
the IBM Java 6 JVM.

Check that the settings in your environment correspond
to the environment settings defined in "Java Environment
Variables Settings" on page 200, or check for a batch file
that may override the settings.

In addition, youmay need to do the following:

1. Remove -Xrunjvmhook from the _JAVA_OPTIONS
and IBM_JAVA_OPTIONS environment variables.

Remove -Xrunjvmhook from the _JAVA_OPTIONS
and IBM_JAVA_OPTIONS environment variables.

2. Add -agentlib:jvmhook at the beginning of the _
JAVA_OPTIONS and IBM_JAVA_OPTIONS environment
variables.

Add -agentlib:jvmhook at the beginning of the _
JAVA_OPTIONS and IBM_JAVA_OPTIONS environment
variables.

3. Delete the JAVA_TOOL_OPTIONS environment
variable.

The add-in does not function properly
with applications that run with the -
Xincgc option.

Either remove the -Xincgc option, or run without
dynamic transformation support.

For details, see: "How to Disable Dynamic
Transformation Support (Advanced)" on page 219.

Your Java console contains the line:
Could not find -Xrun library:
jvmhook.dll.

Check that the jvmhook.dll is located within your
java.library.path.

Check that the jvmhook.dll is located within your
java.library.path.

None of the indicators above
describemy problem.

See "General Notes and Limitations" below

General Notes and Limitations

This section contains general information and limitations about the Java Add-in, and includes the
following sections:

l "Java Add-in Installation" on the next page

l "Opening Java Applications After Opening UFT" on the next page
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l "Loading a Child Add-in of the Java Add-in" below

l "Creating and Running Testing Documents" on the next page

l "Record and RunOptions" on page 206

l "Working with Java Controls" on page 206

l "Test Objects andMethods" on page 207

l "Checkpoints andOutput Values " on page 207

l "Running Java applications on the IBM Java Runtime Environment (JRE) 1.6 " on page 208

l "Using the Java Add-in on Applets Running onMicrosoft Windows Vista or Later and Internet
Explorer 7 or Later" on page 208

Java Add-in Installation
InWindows XP andWindows 2003, after you install the UFT Java Add-in, theWindows Remote
Shell Service (rshsvc.exe) may fail and display an error message every time you restart the
computer. This occurs only if the Remote Shell Service is configured to run automatically.

Workaround:Either disable the automatic launching of the Remote Shell Service, or move the
following variables from the System Variables section of the Environment Variables dialog box to
the User Variables section: _classload_hook, _JAVA_OPTIONS, IBM_JAVA_OPTIONS, and MSJAVA _
ENABLE _MONITORS.

Opening Java Applications After Opening UFT
If you are not able to open your Java application after you've opened UFT, youmay have amemory
space fragmentation issue, caused by loading aWindows .dll file. If Eclipse fails to start with
higher memory settings, do one of the following:

l Use a 64-bit Windows operating system and 64-bit JVM, with 64-bit Eclipse. Have a 64-bit
virtual memory space can prevent you from encounteringmemory fragmentation issues.

l Force Eclipse to start using the java.exe or javaw.exe file instead of the default jvm.dll
startup file. To do this edit the eclipse.ini file by adding the following text, on two separate
lines:

-vm
<full path to the java.exe or javaw.exe file>

l Modify the Eclipsememory setting in the eclipse.ini file. For example, if the application fails
to start with a parameter setting of -Xmx512m, use a parameter setting of -Xmx256m or -Xmx384m
instead.

Loading a Child Add-in of the Java Add-in
When you select a child add-in under Java in the Add-in Manager, you load Java Add-in extensibility
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support for the selected environment.

If you load support that was developed using a Java Add-in Extensibility SDK version earlier than
version 10.00, then when you open one of the UFT dialog boxes that display test object classes for
a selected environment (such as the Object Identification dialog box), the extensibility test object
classes are displayed in the wrong list. If you select the child add-in in theEnvironment list, the list
of test object classes is empty. Instead, the extensibility test object classes are displayed directly
under the Java environment instead of being displayed under the child add-in in theEnvironment
list.

Additionally, in some cases, theGenerate Script button in the Object Identification Dialog Box
does not function properly.

Workaround:

1. Locate the test object configuration file associated with the child add-in. This file is located in
the following locations:

n <UFT Installation Folder>\dat\Extensibility\Java\<add-in
name>TestObjects.xml.

n If working with ALM: <UFT Add-in for ALM Installation
Folder>\dat\Extensibility\Java\<add-in name>TestObjects.xml.

2. In the XML file, locate thePackageName attribute in the TypeInformation element, and
change its value from JavaPackage to the name of the child add-in.

3. Save the file and reopen UFT.

4. If this extensibility support (child add-in) was developed by a third party, youmay want to
contact them for assistance.

Creating and Running Testing Documents

l If, while recording keyboard operations in a JFC single-line edit box in an IME composition
window, you press theENTER key to select the composition string, the key press may be
recorded as theActivatemethod, thereby generating an extra step. For example:

JavaWindow("Application").JavaEdit("User Name").Activate

This extra step generally does not affect the run session adversely.

Workaround:Before running your test or business component, remove the extra step that was
recorded.

l TheALT+F4 keyboard shortcut (used for closing a Java applet or Java application) is not
supported for recording or running.

Workaround:Use aClosemenu command or button to close a Java applet or Java application
during a recording session. Alternatively, manually add a JavaWindow(...).Close step.
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Record and Run Options

l Adding a -Xincgc flag to the java.exe command line (in the Record and Run Settings dialog
box or in a batch file) prevents the Java support from working properly.

Workaround:When testing with UFT Java support, do not use -Xincgc in your command line,
or, alternatively, do not use the dynamic transformation support mechanism. For details, see the
HP Unified Functional Testing Add-ins Guide.

l When selecting a JAR file from the command line in the Record and Run Settings dialog box, you
shouldmanually add -jar to the Command line box before you invoke the Java application.

l If you intend to launch your Java application using the Record and Run Settings dialog box
without using a batch file (or another executable file), and without the -jar command line option
(after selecting a JAR file), you should include the fully qualified name of the Java class in the
Command line box.

Working with Java Controls

l By default, moving and resizing of Java windows are not recorded. This is because it may cause
redundant recordings in some cases.

Workaround: To instruct the Java Add-in record these actions, use theSetting.Javamethod to
set the record_win_ops variable to 1. For example:

Setting.Java("RECORD_WIN_OPS") = 1

l AWT popupmenus are recorded by the StandardWindow control support WinMenu test object
(while other Javamenus are recorded using the JavaMenu test object). You cannot perform
checkpoints or Active Screen operations on suchmenus.

Workaround:Use other verificationmethods (such as usingGetTOProperty). For more details
on verificationmethods, see theHP Unified Functional Testing User Guide.

l A call to .Object.startModal of a JavaInternalFrame or JavaDialog object may cause UFT to
behave unexpectedly until the dialog box is closed.

l The use of multi-byte characters in amultiline edit field object is not supported.

l The Java Add-in does not record or run steps for hovering over identifiers in an Eclipse window.

l When you record a step that closes a Java dialog box, UFT records an additional Close
statement.

Workaround:Manually delete the extraneous Close statement.

l For button objects (either JavaButton or a button in a JavaToolbar) whose label is determined by
the name of the image file they display, the process of naming the test object when running in
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JDK 1.6 is different than the one used when running in JDK 1.5.

Therefore, if you have a test or business component containing button objects that were learned
on JDK 1.5 and labeled according to their image file, when you run it on JDK 1.6, the test or
business component may fail.

Workaround:

n For a JavaButton object—relearn the object on JDK 1.6. Thenmodify the test to use the new
test object, or delete the old object from the object repository and rename the new test object
to match the object name used in the step. Make sure theAutomatically update test and
business components steps when you rename test objects option is selected in the
General pane of the GUI Testing tab in the Options dialog box (Tools > Options > GUI
Testing tab > General node).

n For a button in a JavaToolbar object—modify the Item argument in the JavaToolbar
statement to refer to the relevant button. You can specify the button's index, or you can use
theObject Spy to spy on the toolbar button, and then provide the label identification property
as the Item argument.

l When the Active Screen displays a Java applet or ActiveX control within aWeb page, the applet
or control is for viewing purposes only and you cannot perform operations (for example, create
checkpoints, addmethods, and so forth) on the object.

Workaround:Record an operation on the Java applet/ActiveX control to create a step on the
object with the ActiveX Add-in and/or Java Add-in loaded. Then you can create a checkpoint,
parameterize a step, or add amethod from the individual Java applet/ActiveX control in the
Active Screen.

Test Objects and Methods
ThePropertyValue argument (second argument) of theWaitPropertymethod for any Java test
object can be only of type string.

Workaround:Use a string instead of the original type. For example, instead of 1, use "1". For
example:

y = JavaCheckBox("Active").WaitProperty ("enabled", "1", 1000)

Checkpoints and Output Values

l You can create text checkpoints and text output values only for Java objects that meet specific
criteria. For details, see "Text Checkpoint and Text Output Value Steps for JavaObjects" on
page 212.

l To create a new table checkpoint on a Java table while editing a test or business component,
youmust first open the application containing the table you want to check and display the table
in the application.
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l If you add a checkpoints on a JavaList or JavaTree object while editing a test or business
component, the list_content or tree_content property is not available in the checkpoint.

Workaround:Create checkpoints on Java lists and Java trees while recording.

l Performing a checkpoint on an object that is not always visible (such as a list opening from a
combo box selection or amenu item) is not fully supported.

Workaround: If a checkpoint on a transient object is required, make sure the object is visible
prior to executing the checkpoint. For example, in the case of combo box list, you should insert a
statement that clicks the combo box button before executing the checkpoint.

Running Java applications on the IBM Java Runtime Environment (JRE)
1.6
In some cases, after installing the Java Add-in, Java applications running on the IBM Java 6 JVM
cannot be started. The error message displayedmay indicate that Mercury Interactive support
could not be loaded and the Java Virtual Machine could not be created.

Workaround:

1. Remove -Xrunjvmhook from the _JAVA_OPTIONS and IBM_JAVA_OPTIONS environment
variables.

2. Add -agentlib:jvmhook at the beginning of the _JAVA_OPTIONS and IBM_JAVA_OPTIONS
environment variables.

3. Delete the JAVA_TOOL_OPTIONS environment variable.

Using the Java Add-in on Applets Running on Microsoft Windows Vista or
Later and Internet Explorer 7 or Later
In some cases, when using theMicrosoft Windows Vista operating system, or a later version of
Microsoft Windows (includingWindows 8), and running Java applets using Oracle Java JRE 5 or 6
onMicrosoft Internet Explorer 7 or later, the Java Add-in does not recognize the applet as belonging
to the Java environment. It does not recognize objects in the applet as Java objects, and cannot
record or run steps on them.

This happens when the JVM does not use the Java Add-in's settings from the environment
variables. In this case, you need to set -agentlib:jvmhook -Xbootclasspath/ a:"<UFT
installation folder>\bin\java_shared\classes";"<UFT installation
folder>\bin\java_shared\classes\jasmine.jar" in the JVM Runtime Parameters.

Use the Java Add-in JRE Support Tool to set this string in the Runtime Parameters for the relevant
JVM. The tool is available from: Start > All Programs > HP Software > HP Unified Functional
Testing > Tools > Java Add-in JRE Support Tool.

Note: For details on accessing UFT and UFT tools and files inWindows 8, see "Accessing
UFT inWindows 8Operating Systems" on page 547.
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Concepts

Java Add-in - Overview
This chapter explains how to use UFT to set testing preferences and to record and run steps on
Java applets and applications. The chapter assumes basic knowledge of UFT features and
capabilities. For details on working with UFT, see theHP Unified Functional Testing User Guide.

Note: Some of the features described in this chapter are relevant only for tests and scripted
components. For details on the features that are available when working with keyword
components, see theHP Unified Functional Testing User Guide.

Java Testing Options
You can use the Java pane of the Options dialog box (Tools > Options > GUI Testing tab > Java
node) to set UFT record and run options on Java applets or applications. You can also open the
Advanced JavaOptions dialog box that enables you to set table recordmode preferences, enable
text retrieval for checkpoints and output values, and specify lists of controls.

For details, see:

l "Java Pane (Options Dialog Box > GUI Testing Tab)" on page 221

l "Advanced JavaOptions Dialog Box" on page 224

Java Settings - Tests and Components
You define and view Java test or business component settings using one of the following:

l The Java pane of the Test Settings dialog box.

l The Java pane of the Business Component Settings dialog box (view only).

l The Java pane of the application area's Additional Settings pane.

For details, see "Java Pane (Test/Business Component Settings Dialog Box / Application Area -
Additional Settings Pane)" on page 228.

Recording Steps on Java Objects
When you record an operation on an applet, application, or Java object, UFT records the appropriate
object icon next to the step in the Keyword View (for tests and business components) and adds the
relevant statement in the Editor (for tests only).
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If you try to record an operation on an unsupported or custom Java object, UFT records a generic
Java Object.Click statement that includes the coordinates of the click and themouse button (that
is, left or right) that was clicked. You can create support for your custom object using the UFT Java
Add-in Extensibility. For details, see theHP UFT Java Add-in Extensibility Developer Guide.

Note: The way in which UFT records operations depends on the type of JTable cell editor in
the table cell. For details, see "Recording Steps on Jtable Cell Editors" on the next page.

The UFT recorded hierarchy is composed of two or three levels of Java test objects. The top level is
represented by the JavaApplet, JavaDialog, or JavaWindow object, as appropriate. The actual
object on which you performed an operationmay be recorded as a second or third level object. If the
object is located directly in the top level object, it is recorded as a second level object (for example,
JavaApplet.JavaButton). If a JavaDialog or JavaInternalFrame exists at the second level, then
the object on which you performed the operation is recorded as a third level object (for example,
JavaWindow.JavaDialog.JavaButton).

When testing applets in a browser, the two- or three-level hierarchy is recorded within the standard
Web object hierarchy (for example,
Browser.Page.JavaApplet.JavaTestObject.SubJavaTestObject).

Even though the object on which you recordmay be embedded in several levels of objects, the
recorded hierarchy does not include these objects. For example, if the JavaList object on which you
record is actually contained in several JPanel objects, which are all contained in a JavaWindow,
the recorded hierarchy is only JavaWindow.JavaList.

Example

In a test, if you record a click on a Java check box, the Keyword View may be displayed as
follows:

UFT records this step in the Editor as:

Window("Microsoft Internet Explorer").JavaApplet("Periodic").JavaCheckBox
("Toggle").Set "ON"

In a keyword component, if you record a click on this same Java check box, the Keyword View
would displayed as follows:

You can view the recorded hierarchy of a test object in the object repository. You can also access
the full hierarchy of an object when using the pointing handmechanism in the StepGenerator (tests
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only), when inserting a checkpoint or output value step while recording, or when using the Object
Spy.

For a related task, see "How toModify Options for Recording on Java Tables" on page 217.

This section also includes:

Recording Steps on Jtable Cell Editors 212

Text Checkpoint and Text Output Value Steps for JavaObjects 212

Full Object Hierarchy Views 213

Recording Steps on Jtable Cell Editors

UFT records operations differently, depending on the type of JTable cell editor in the table cell.

If you are recording on standard cell editors in Swing Jtable tables, UFT records operations by
default in the sameway it records other table objects, usingSetCellData statements.

However, when a JTable contains a custom (non-standard) cell editor, the default SetCellData
statement cannot be recorded. For example, if a cell contains both a check box and a button that
opens a dialog box, then aSetCellData statement may not always provide an accurate description
of the operations performed inside the cell.

If you record an operation on a custom cell editor, UFT records a statement that reflects the
operation you performed on the object inside of the cell. For example, if the cell editor contains a
custom check box, UFT might record the following statement:

Browser("Periodic").Page("Periodic").JavaWindow("CoolJava").JavaDialog("SetO
ptions").JavaCheckBox("MyCheckBox").Set "ON"

instead of:

Browser("Periodic").Page("Periodic").JavaWindow("CoolJava").JavaDialog("SetO
ptions").JavaTable("MyTable").SetCellData "ON"

Text Checkpoint and Text Output Value Steps for Java Objects

Whenworking with tests, you can use checkpoints or output values to check that text in your Java
application or applet displays correctly. Similar to many other supported environments, it is
recommended to retrieve and check text from your Java applet or application by inserting a
standard checkpoint or output value for the object containing the desired text, and selecting to
check or output its text (or similar) identification property (for example, text, attached text, or
label).
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If the object you want to work with does not have an appropriate identification property, or, if for any
other reason, the above recommendation does not answer your needs (for example, the text before
or after the selected text is important), you can consider inserting a UFT text checkpoint or text
output value step for a Java object if it meets the following criteria:

l The object must draw the text itself (and not delegate the drawing task to the underlying
operating system, as is the case with most AWT business components).

l The object must draw text by overriding the paint()method and calling the standard
graphics.drawString()method to draw text. For example, the object cannot use special
drawingmethods for writing text, such as using amethod that can draw oval circles to draw the
letterO.

l The object cannot use the double (image) buffering drawing technique.

Note: Becausemany Java objects do not answer these criteria, the text checkpoint and
text output mechanism for Java objects is disabled by default. You can enable it in the
"Advanced JavaOptions Dialog Box" (described on page 224).

Full Object Hierarchy Views

The Java Add-in enables you to view the full object hierarchy of each of the objects in your
application in the Object Spy andObject Selection dialog boxes. In contrast to the recorded object
hierarchy, the full object hierarchy shows you all of the parent objects associated with the clicked
locations and, in some cases, the child objects of the clicked object.

The full object hierarchy enables you to view associated operations and properties of non-recorded
objects in the Object Spy. You can also access non-recorded objects from theObject Selection
dialog box that opens when using the StepGenerator dialog box (tests only) or when inserting a
checkpoint or output value step during a recording session.

TheObject Spy andObject Selection dialog boxes enable you to view details, insert statements, or
perform operations even for elements of an object (class business components) that are not
recorded, such as java.awt.Component. For example, you can access the edit box, drop-down
list, and button elements of a combo box.

For details on the Object Spy andObject Selection dialog box, see theHP Unified Functional
Testing User Guide.

Advanced Java Test Object Methods
Java test object classes include test object methods that you can use in your tests to enhance the
interaction between UFT and the application being tested.
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This section includes:

CreateObject Method 214

GetStatics Method 214

FireEvent / FireEventEx Methods 215

CreateObject Method

You can use theCreateObjectmethod to create an instance of any Java object within your applet
or application. TheCreateObjectmethod returns an object reference to the newly created Java
object. For details on the syntax of this method, see the Java section of theHP UFT Object Model
Reference for GUI Testing.

You can activate themethods of an object you create in the sameway as you would activate the
methods of any returned object from a prior call. Because theCreateObjectmethod returns an
object reference, there is no need to use theObject property when activatingmethods of the
created object.

For example, you can use theCreateObjectmethod to create a rectangle object. The return value
is an object reference.

Set Rect = Browser("Periodic").Page("Periodic").JavaApplet("Periodic").JavaO
bject("Panel").CreateObject ("java.awt.Rectangle", 10, 20)

Note: TheCreateObjectmethod can be performed on any Java test object. The class loader
of the Java test object on which theCreateObjectmethod is performed is used to load the
class of the newly created Java object.

It is recommended to use theCreateObjectmethod on a Java test object from the same toolkit
as the object you want to create. For example, to create aSwing/JFC object, use the
CreateObjectmethod on an existingSwing/JFC Java test object.

GetStatics Method

You can invoke any static method, or you can set or retrieve the value of any static property of a
Java class using theGetStaticsmethod. For details on the syntax of this method, see the Java
section of theHP UFT Object Model Reference for GUI Testing.

GetStatics returns a reference to an object that can access static members of the specified class.
The class loader of the Java test object on which theGetStaticsmethod is performed is used to
load the class specified as a parameter of theGetStaticsmethod.

For example, to invoke the gcmethod of class.java.lang.System, which runs the garbage collector
on the application, you can insert a statement similar to the following:

Browser("Browser").Page("Page").JavaApplet("mybuttonapplet.htm").JavaObject
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("MyButton").GetStatics("java.lang.System").gc

To retrieve the value of the out property of the java.lang.System class, you can insert a statement
similar to the following:

Set OutStream= Browser("Browser").Page("Page").JavaApplet("mybuttonapplet.ht
m"). JavaObject("MyButton").GetStatics("java.lang.System").out

To print a message to the Java console, you can insert a statement similar to the following:

Set OutStream= Browser("Browser").Page("Page").JavaApplet("mybuttonapplet.ht
m"). JavaObject("MyButton").GetStatics("java.lang.System").out
OutStream.println "Hello, World!"

FireEvent / FireEventEx Methods

You can simulate an event on a Java object during a run session with the FireEvent and
FireEventExmethods. The FireEventmethod simulates an event on a Java object using one of
several pre-defined event constants. If the list of pre-defined constants does not cover the event
you want to fire, you can use the FireEventExmethod to fire any Java event. For details on the
syntax of thesemethods and for the list of pre-defined event constants, see the Java section of the
HP UFT Object Model Reference for GUI Testing.

For example, you can use the FireEventmethod to fire aMouseClick event on the JavaObject
calledMyButton_0.

Browser("Browser").Page("Page").Applet("mybuttonapplet.htm").JavaObject("MyB
utton_0").FireEvent micMouseClick, 0, "BUTTON1_MASK", 4, 4, 1, "OFF"

Alternatively, you can use the FireEventExmethod to fire the same event as follows:

Browser("Browser").Page("Page").Applet("mybuttonapplet.htm").JavaObject("MyB
utton_0").FireEventEx "java.awt.event.MouseEvent", "MOUSE_CLICKED", 0, "BUTT
ON1_MASK", 4,4, 1, "False"

Note that you can pass any Java constant that is used as one of the event's constructor
parameters using its string, rather than its value. In the example above, the
"java.awt.event.MouseEvent" Java constant MOUSE_CLICKED is supplied as a string argument
instead of its value (500 in this example).

Java Add-in Environments
The Java Add-in uses amechanism that supports multiple Java environments (such as IBM JRE,
Oracle JRE, andOracle JInitiator) andmultiple Java versions (such as, JDK 1.5.x, 1.6.x and so on)
without requiring any configuration changes. (For a list of supported environments and versions,
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see theHP Unified Functional Testing Product Availability Matrix, available from the UFT Help or
the root folder of the UFT DVD.)

This mechanism, known as the dynamic transformation support mechanism, adjusts the Java
Add-in support classes according to the Java environment and version used. The dynamic
transformation support mechanism uses the Tool Interface of the Java Virtual Machine (JVMTI) (or
the Profiler Interface (JVMPI) when working with JDK 1.5 and earlier).

The dynamic transformation support mechanism is invoked by the -Xrunjvmhook option, which is
supplied to the JVM. If the -Xrunjvmhook option is specified, the JVM hook profiler (part of the
Java Add-in support) is loaded with every Java application or applet that loads. The JVM hook
profiler dynamically transforms the necessary classes to enable context-sensitive Java support.

When you run the Java Add-in on Java 6 or Java 7 environments, the dynamic transformation
support mechanism is invoked by the -agentlib:jvmhook, which is defined in the JAVA_TOOL_
OPTIONS environment variable.

Note:Whenworking with Oracle Java 6 or Java 7 there is no conflict between -
agentlib:jvmhook (defined in the JAVA_TOOL_OPTIONS environment variable) and -
Xrunjvmhook (defined in the _JAVA_OPTIONS environment variable) because Java 6 and Java
7 ignore -Xrunjvmhook.

When working with IBM Java 6 or Java 7, these environment variables may conflict. For
workaround details, see "Running Java applications on the IBM Java Runtime Environment
(JRE) 1.6 " on page 208.

The Java agent searches for the jvmhook.dll according to the java.library.path system
property. You can identify any override of this system property using the Java command line: -
djava.library.path = <path>However, although you can override the java.library.path
system property, it is recommended to extend the java.library.path and not to overwrite it.

By default, the value of the java.library.path system property is the system path. If your
application is loaded with a different library path, youmust either add the jvmhook.dll to a location
within the java.library.path, or change the java.library.path to contain <Windows installation
folder>/system32.

The <JRE root folder>/bin folder is always located in the java.library.path. If needed, you can
manually copy the jvmhook.dll to this folder. However, if you need tomodify more than one
computer, it is recommended tomodify the batch file that alters the java.library.path.

For task details, see "How to Disable Dynamic Transformation Support (Advanced)" on page 219.
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Tasks

How to Modify Options for Recording on Java Tables
This task describes how tomodify some recording options for recording on Java table, as well as
identify the toolkit class for an editor for use with the table_external_editors_list

This task includes the following steps:

l "Modify the default JTable recording behavior for SetCellData statements (advanced)" below

l "Modify table cell control options" below

l "Find the toolkit class of a JTable cell editor" on the next page

Modify the default JTable recording behavior for SetCellData statements
(advanced)
If the default recording behavior for JTables does not provide the desired value for the SetCellData
statement of a particular editor, set that editor to be recorded, like a custom cell editor, in terms of
the operation performed on the object inside the cell.

Do one of the following:

l In the "Advanced JavaOptions Dialog Box" (described on page 224), select Table cell
controls > Controls to identify as separate test objects, and then specify specific cell editor
types that should always be treated as separate objects, and not as part of a JavaTable object.

l Create a Setting.Java ("table_internal_editors_list") statement. For details, see
"Advanced JavaOptions Dialog Box" on page 224, and theHP UFT Object Model Reference for
GUI Testing.

Modify table cell control options
You can specify a list of table cell controls that you want UFT to identify as separate test object, or
for which you want UFT to record and run JavaTable operations.

Note:

l Any changes youmake are not applied to the currently open test or business component.

l You can restore the default settings in the "Advanced JavaOptions Dialog Box" (described
on page 224) by clicking theReset button.

1. In the "Advanced JavaOptions Dialog Box" (described on page 224), click the relevant option
once to highlight it.

2. Click the option again or press F2 to open an edit box in which you can add or modify a list of
controls.
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3. Change the value as necessary.

Note: Specify editor class names separated by a space, tab, newline, or return character.
Values are case sensitive.

4. When you finish editing the value, click another location in the dialog box to set the value.

5. To apply your changes to the currently open test or business component, close the document
and then reopen it.

Find the toolkit class of a JTable cell editor
If you do not know the value of the toolkit class for an editor for use with the table_external_
editors_list variable, you can find it by doing one of the following:

l Use the Object Spy to retrieve the value.

l Run a short test in UFT to retrieve the value. Youmay want to do this when working with a
cell that does not stay activated for long enough to capture the cell with the Object Spy. For
example, a cell that is no longer active after a check box is selected or cleared.

l Create a user-defined function and insert it as a step in your test. Youmay want to do this
when working with business components.

You can insert steps similar to the following example:

' Sample test to retrieve the toolkit class of a table cell editor
' that cannot be made continuously active
Set table = JavaWindow("TableDemo").JavaTable("Left table").Object
Set JTableCS = table.mic_get_supp_class()
Set comp = JTableCS.getComponentAt(table, 0, 6) ‘row 0, col 6
MsgBox comp.getClass().getName()
' Set the value of TABLE_EXTERNAL_EDITORS_LIST
Setting.Java("TABLE_EXTERNAL_EDITORS_LIST") = comp.getClass().getName()

To find the toolkit class of a JTable cell editor using the Object Spy:

1. Open the table and activate a cell in the cell editor column. For example, make sure the cursor
is blinking inside an edit field or display the drop-down list of a combo box.

2. With the appropriate cell activated, use the Object Spy to point to the active cell. For details on
using the Object Spy dialog box , see theHP Unified Functional Testing User Guide.

3. Make sure the Properties tab of the Object Spy is displayed and select the Identification radio
button.

4. In theProperties column, scroll to toolkit class.
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5. In theValues column, select the value of the toolkit class. The value is displayed in the box
below the Properties tab.

6. Copy and paste the value from theObject Spy to the Table cell controls > Controls to
identify as separate test objects option or your Setting.Java ("table_internal_
editors_list") statement.

How to Disable Dynamic Transformation Support
(Advanced)

This task describes how to disable the dynamic transformation support mechanism if it does not
work properly, and how tomanually configure the Java environment to use the Java Add-in without
dynamic transformation support. For general details about using the Java Add-in with multiple
environments, see "Java Add-in Environments" on page 215.

Note: The dynamic transformation support mechanism is not supported when using the
incremental garbage collector (-Xincgc option). Therefore, if you absolutely must use the -
Xincgc option, you need to disable dynamic transformation support.

This task includes the following steps:

l "Save the dynamically transformed classes" below

l "Disable dynamic transformation support" on the next page

l "Results" on the next page

1. Save the dynamically transformed classes
a. Specify the folder in which to save the dynamically transformed classes that will be

generated during the preliminary launching of your java applet or application.

To do this, open the registry editor (select Start > Run, type regedit in theOpen box and
click OK) and navigate to the JavaAgentmain key, located in: HKEY_LOCAL_
MACHINE\SOFTWARE\Mercury Interactive\JavaAgent. Define a new string value named
ClassesDumpFolder, and set its value data to an existing folder (preferably empty) on
your computer, for example, C:\JavaSupportClasses.

Note: If the ClassesDumpFolder string value already exists, you canmodify its value
data to an existing folder on your computer.
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b. If you are using the -Xincgc option, temporarily remove it from the command line to enable
the JVM hook profiler to transform and save the necessary classes.

c. Launch your applet or application and perform some basic operations on it. This ensures
that all of the necessary classes are transformed and saved. Close your applet or
application. All of the dynamically transformed classes are now saved in the folder you
specified in the previous step (for example, C:\JavaSupportClasses).

d. If you temporarily removed the -Xincgc option from the command line, you can restore it
now.

Now that you saved the transformed classes, you are ready to disable dynamic
transformation support.

2. Disable dynamic transformation support
a. Remove the -Xrunjvmhook option from the _JAVA_OPTIONS (or IBM_JAVA_OPTIONS for IBM

VM-based applications, and JAVA_TOOL_OPTIONS if you are working with Java 6)
environment variable.

b. Add the following option instead: -Xbootclasspath/p:<ClassesDumpfolder>\Final
where <ClassesDumpfolder> is the value of the folder in which the dynamically
transformed classes were saved, such as C:\JavaSupportClasses. For example, after
your modification the _JAVA_OPTIONS environment variable might look like this:

-Xbootclasspath/p:C:\JavaSupportClasses\Final -Xbootclasspath/a:C:\PRO
GRA~1\HP\
UNIFIE~1\bin\JAVA_S~1\classes;C:\PROGRA~1\HP\UNIFIE~1\bin\JAVA_S~1\cla
sses\jasmine.jar

3. Results
The saved transformed classes are now used instead of dynamic transformation.
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Reference

Java Pane (Options Dialog Box > GUI Testing Tab)
This pane enables you to configure how UFT records and runs tests on Java applets or
applications.

To access 1. Do one of the following:

n Ensure that a GUI test, action, or component is in focus in the document
pane.

n In the Solution Explorer, select a GUI test or component node or one of its
child nodes.

2. Select Tools > Options > GUI Testing tab > Java node.

Important
information

l The Java pane is available only when the Java or Oracle Add-ins are installed
and loaded. If you are using the Oracle Add-in, and you add steps to your test
for Java objects within your Oracle application, the options in this pane are
relevant for the Java steps in your test.

l TheRestore Factory Defaults button resets all Options dialog box options to
their defaults.
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Related
tasks

l "How toModify Options for Recording on Java Tables" on page 217

l "Record and Run Environment Variables for JavaObjects" on page 235

See also l "Advanced JavaOptions Dialog Box" on page 224.

l "Java Pane (Test/Business Component Settings Dialog Box / Application Area
- Additional Settings Pane)" on page 228

l "Java Tab (Record and Run Settings Dialog Box)" on page 231

l "Recording Steps on JavaObjects" on page 210

User interface elements are described below:

UI
Element Description

Record
items
mode

Determines how UFT records operations on items in List box, Combo box, Tree
view, and Tab control objects. The following options are available for each object:

l By name. (Default) Records operations on an item within the object (for
example, selected list item or tab) according to the item's name.

l By index. Records operations on an item within the object (for example,
selected list item or tab) according to the item's position within the Java object.

Note:

l If you select theBy index option for Tree view, do not specify "#" as the
default separator in the Tree view path separator option below.

l This option corresponds to the Setting.Java("record_by_num") variable.

Search
radius for
attached
text

Themaximum distance in pixels to search for attached text.

Default value: 100

Note:

l This option is relevant only when the label identification property is
unavailable.

l This option corresponds to the Setting.Java("max_text_distance")
variable.
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UI
Element Description

Tree view
path
separator

The default separator used to separate entries in a path to a node of a Tree view
control.

l Default value: ;

l Possible value:One ormore single-character separators

Note:

l If you enter more than one character, UFT treats each of the characters as a
separator (but not both of them in sequence). If a path contains two
consecutive separators, UFT interprets the path as if it contains a node with
no name between the two separators. For example, if you specify %$ for
this option and a particular path contains MyNode%$MySubNode, then UFT
treats the% character as a separator for a node with no name, and the $
character as the separator for an additional node named MySubNode.

l If you select theBy index option for Tree View in theRecord Items mode
area above, do not specify "#" as the default separator.

l This option corresponds to the Setting.Java("treeview_path_
separator") variable.

Reset Resets the Java settings to their default values.

Advanced Opens the Advanced JavaOptions dialog box. For details, see "Advanced Java
Options Dialog Box" on the next page.

Add-ins Guide
Chapter 13: Java Add-in - Testing and Configuration

HP Unified Functional Testing (12.00) Page 223 of 549



Advanced Java Options Dialog Box

This dialog box enables you to specify additional Java options. You can configure table record
mode preferences, enable retrieving text information from the run-time object for checkpoints and
output values (tests only), and specify lists of controls.
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To access Make sure that a GUI test is open and select Tools > Options > GUI Testing
tab > Java node > Advanced button. Then do the following:

1. Click the relevant option once to highlight it.

2. Click the option again or press F2 to open an edit box in which you can add or
modify a list of controls.

3. Change the value as necessary.

Note: Specify editor class names separated by a space, tab, newline, or
return character. Values are case sensitive.

4. When you finish editing the value, click another location in the dialog box to
set the value.

Important
information

l If you are using the Oracle Add-in, and you add steps to your test for Java
objects within your Oracle application, the options in this dialog box are
relevant for the Java steps in your test.

l Any changes youmake are not applied to the currently open test or business
component. To apply your changes, close your test or business component
and reopen it.

l You can restore the default settings in the Advanced JavaOptions dialog box
by clicking theReset button.

Related
tasks

"How toModify Options for Recording on Java Tables" on page 217

See also l "Java Pane (Options Dialog Box > GUI Testing Tab)" on page 221

l "Java Pane (Test/Business Component Settings Dialog Box / Application Area
- Additional Settings Pane)" on page 228

l "Java Tab (Record and Run Settings Dialog Box)" on page 231

l "Recording Steps on JavaObjects" on page 210

l "Text Checkpoint and Text Output Value Steps for JavaObjects" on page 212
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User interface elements are described below:

UI Element Description

JavaTable
record
mode

The recordmode for table objects. The followingmodes are available:

l Context sensitive. (Default) Records operations on table objects in context-
sensitivemode: SetCellData, SelectRow, and so on.

l Analog. Records only low-level (analog) table methods: ClickCell,
DoubleClickCell, andDrag.

Note: This option corresponds to the Setting.Java("table_record_
mode") variable.

Checkpoint
and output
value
options

The preferences for checkpoint and output value steps on Java objects. The
following option is available:

Enable retrieving text data from the Java run-time object:Enables UFT to
retrieve text information from the Java objects in the application for checkpoints
and output value steps. This option is not relevant if UFT is configured to use the
OCR mechanism for text recognition (Tools > Options > GUI Testing tab >
Text Recognition node)

Note:

l Retrieving text information from the run-time object is supported only for
Java objects that meet very specific criteria. Therefore, this option is
disabled by default.

l For a list of supported checkpoints and output values for the Java Add-in,
see "Java Add-in - Quick Reference" on page 194.
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UI Element Description

Table cell
controls

The preferences for the way that UFT identifies controls inside table cells. The
following options are available:

l Controls to identify as separate test objects:Specifies the list of controls
that you want UFT to identify as separate test objects and not as part of a
JavaTable object. Use this option to access methods that are specific to the
object type or to otherwise improve the functionality of steps that UFT would
normally record and run as operations on a JavaTable object.

Note:

n This option is relevant for JTable Swing toolkit tables.

n Control class names must be separated by a space, tab, newline, or
return character. Values are case sensitive.

n This option corresponds to the Setting.Java("table_internal_
editors_list") variable.

l Controls to treat as part of the JavaTable test object:Specifies the list of
controls for which you want UFT to record and run JavaTable operations. Use
this option to record and run JavaTable operations (such as
SetCellDataandSelect) on controls that UFT would normally treat as separate
test objects.

Note:

n This option is relevant for JTable Swing toolkit tables.

n Editor class names must be separated by a space, tab, newline, or
return character. Values are case sensitive.

n This option corresponds to the Setting.Java("table_external_
editors_list")variable.

See also:

l "Modify table cell control options" on page 217

l "Find the toolkit class of a JTable cell editor" on page 218
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Java Pane (Test/Business Component Settings Dialog
Box / Application Area - Additional Settings Pane)

This pane enables you to define Java test or business component settings. For business
components, you use the application area's Additional Settings pane to define the settings, and the
Business Component Settings dialog box to view the settings in read-only mode.

The following image displays the Java pane of the Test Settings dialog box. The content of this
pane is identical to the content of the Java pane of the Business Component Settings dialog box
and the application area's Additional Settings pane.
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To access Do one of the following:

l For a test or component:

Select File > Settings > Java node.

l For an application area:

Open the application area and select Additional Settings> Java in the
sidebar.

Important
information

l The options shown in the Java pane are the same in the application area's
Additional Settings pane, the Business Component Settings dialog box, and
the Test Settings dialog box.

The Business Component Settings dialog box displays the settings in read-
only mode. To define the settings for a business component, use its
application area's Additional Settings pane.

l The Java pane is available only when the Java or Oracle Add-ins are installed
and loaded. If you are using the Oracle Add-in, and you add steps to your test
for Java objects within your Oracle application, the options in this pane are
relevant for the Java steps in your test.

l For details on the Test Settings and Business Component Settings dialog
boxes, and on application areas, see theHP Unified Functional Testing User
Guide.

Related
tasks

l "Record and Run Environment Variables for JavaObjects" on page 235

See also l "Java Pane (Options Dialog Box > GUI Testing Tab)" on page 221

l "Java Tab (Record and Run Settings Dialog Box)" on page 231

l "Recording Steps on JavaObjects" on page 210

External
resources

l For details on JFC or AWT-based Java key events and input methods, see
Java documentation at http://www.oracle.com/technetwork/java/index.html.

l For details on SWT-based Java key events, see Java documentation at
http://www.eclipse.org.
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User interface elements are described below:

UI Element Description

When running
JavaEdit.Set
steps

Specifies how operations are performed on edit boxes during a test run. It is
recommended not to modify these settings unless you fully understand Java
key events and input methods, as well as the implications of sending or not
sending these events. Note that JavaEdit.Set steps may fail during a run
session if an incorrect value is used for these settings. You can set one or
more of the following options:

l Send KEY_PRESSED event. Sends a KEY_PRESSED event to the object
for every character from the input string. (Selected by default.) This
setting corresponds to theP value of the Setting.Java("edit_replay_
mode") variable.

l Send KEY_TYPED event. Sends a KEY_TYPED event to the object for
every character from the input string. (Selected by default.) This setting
corresponds to the T value of the Setting.Java("edit_replay_mode")
variable.

l Send KEY_RELEASED event. Sends a KEY_RELEASED event to the
object for every character from the input string. (Selected by default.)
This setting corresponds to theR value of the Setting.Java("edit_
replay_mode") variable.

l Use Java API. Calls the setValue()method to set a value of the edit
object. This setting corresponds to theS value of the Setting.Java
("edit_replay_mode") variable.

l Send InputMethod event. Sends an InputMethod event to the object
for every character from the input string. This event is used with Unicode
applications (for example, for some non-English applications). This
setting corresponds to the I value of the Setting.Java("edit_replay_
mode") variable.

l Send FOCUS_LOST event at end. Generates a FOCUS_LOST event
after running the step. This setting corresponds to the F value of the
Setting.Java("edit_replay_mode") variable.
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UI Element Description

Characters to
exclude

Instructs UFT to ignore the specified characters during a run session. List
characters consecutively, without a separator.

Default value: \t\n\r

Note:

l This option is relevant only if theUse Java API check box is
selected in the upper section of this dialog box, or if the value of the
Setting.Java("edit_replay_mode") variable is set to S.

l This setting corresponds to the Setting.Java("exclude_control_
chars") variable.

Perform
mouse/keyboard
operations at
device level for
these selected
methods

By default, UFT performs mouse operations at the context-sensitive level.
You can use this option to select specific operations to perform using
device-level replay. Device-level replay simulates mouse or key operations
exactly as if they occur on themouse or keyboard drivers. When amouse
action is simulated on device replay, themouse pointer moves on the screen
to the point where the action is to be performed during the run session. You
can select from the followingmouse and keyboardmethods:

l Click

l DoubleClick

l Type

l Drag / Drop

Default value:All check boxes are cleared.

This option corresponds to the Setting.Java("device_replay_mode")
variable.

Java Tab (Record and Run Settings Dialog Box)
This tab enables you to instruct UFT to open your Java applet or application each time you begin a
recording session, or to instruct UFT to record on any open Java application.
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To access Use one of the following:

Select Record > Record and Run Settings and select the Java tab.

Note: The Record and Run Settings dialog box opens automatically each
time you begin recording a new test or business component (unless you open
the dialog box and set your preferences manually before you begin recording).
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Important
information

l Testing Java applets in a Web browser. Youmust load both theWeb Add-in
and the Java Add-in. In this case, you use theWeb tab of the Record and Run
Settings dialog box to specify your record and run preferences.

l Verifying record and run settings.When you run a test, or if you begin a
new recording session on an existing test, UFT automatically uses the existing
record and run settings for the test and does not open the Record and Run
Settings dialog box. However, it is important to confirm that the options in the
Java Tab of the Record and Run Settings Dialog Box are appropriate for the
first step of your test before running it because you (or someone else) may
havemodified the Record and Run Settings dialog box manually in a prior
recording session.

l Testing business components. Components do not require specific record
and run settings to work with Java applets and applications. To record a
business component, you need to first open the Java applet or application
manually. Alternatively, you can include steps in your business component
that connect to the Java applet or application, for example, you can include a
step that contains the OpenApp operation.

When you begin recording a new business component, the Applications dialog
box opens (unless you previously specified aWindows environment in the
Business Component Settings dialog box or the application area's Additional
Settings pane). Click OK in the dialog box without makingmodifications to
begin recording. For details on the Applications pane and Applications dialog
box, see "Record and run test on any openWindows-based application" on
page 111.

Related
tasks

"How to Define Record and Run Settings for UFT Add-ins"

See also l "Java Pane (Options Dialog Box > GUI Testing Tab)" on page 221

l "Advanced JavaOptions Dialog Box" on page 224

l "Recording Steps on JavaObjects" on page 210

l "Record and Run Environment Variables for JavaObjects" on page 235

l For details on theWeb tab of the Record and Run Settings dialog box, see
"Web-Based Application Support" on page 39.

l For general details on the Record and Run Settings dialog box, see the
HP Unified Functional Testing User Guide.
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User interface elements are described below:

UI Element Description

Record and
run test on
any open Java
application

Instructs UFT to record and run the test on any open Java application or applet.

Open the
following
application
when a record
or run session
begins

Instructs UFT to open a new Java application or applet using the specified
application details.

Note:

l This setting controls only which Java application, if any, is opened at
the beginning of a record or run session. It does not affect the
applications that UFT recognizes. Even if this radio button is selected
and no application is specified, UFT can still record, recognize, and run
on any open Java application.

l Whenworking with a Java applet inside a browser, use theWeb Tab of
the Record and Run Settings Dialog Box to open the URL containing
the applet.

Application
details

The details of the Java application on which to run the test:

l Executable file. Instructs UFT to open the specified executable or batch
file.

l Command line. Instructs UFT to open the application from the specified
command line.

l Working directory. Instructs UFT to run the specified executable file or
command line from the specified directory. Make sure you specify the full
directory path, for example, %ProgramFiles%\Java\jre1.6.0\bin.

Note:

l If you define values for the EXEPATH_ENV, CMDLINE_ENV, and/or
WORKDIR_ENV test environment variables, these values override the
values in theExecutable file, Command line, andWorking
Directory boxes of the Java tab during a run session. For details, see
"Record and Run Environment Variables for JavaObjects" on the next
page.

l Always enter a value in theWorking directory field, otherwise UFT
cannot open your Java application.
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Record and Run Environment Variables for Java Objects
You can override the values in theExecutable file, Command line, andWorking directory
boxes in the "Java Tab (Record and Run Settings Dialog Box)" (described on page 231) by defining
the Java application details using the following variables:

Option
Variable
Name Description

Executable file EXEPATH_ENV The executable file or a batch file to open.

Command line CMDLINE_ENV The command line to use to open the file.

Working
directory

WORKDIR_ENV The folder to which the specified command line or executable
file refers.

For details on defining and working with environment variables, see theHP Unified Functional
Testing User Guide.
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Chapter 14: Oracle Add-in - Quick Reference
You can use the UFT Oracle Add-in to test Oracle Applications andOracle Forms objects
(controls).

The following tables summarize basic information about the Oracle Add-in and how it relates to
some commonly-used aspects of UFT.

General Information

Add-in Type This is aWeb-based add-in. Much of its functionality is the same as other
Web-based add-ins.

See "Web-Based Application Support" on page 39.

Supported
Environments

For details on supported Oracle environments, see theOracle Add-in
section of theHP Unified Functional Testing Product Availability Matrix,
available from the UFT Help or the root folder of the Unified Functional
Testing DVD.

Important
Information

Whenworking with the Oracle Add-in, youmust:

l Verify that the Oracle Name attribute is unique.

See "How to Verify or Enable the Oracle Server Unique NameAttributes"
on page 248.

l Enable the Oracle Name attribute.

See "How to Enable the Oracle Name Attribute" on page 248.

Test Object
Methods and
Properties

TheOracle Add-in provides test objects, methods, and properties that can
be used when testing objects in Oracle applications. For detail, see the
Oracle section of theHP UFT Object Model Reference for GUI Testing.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

Troubleshooting
and Limitations

See "Troubleshooting and Limitations - Oracle Add-in" on page 242.

Prerequisites

Opening Your
Application

You can open your Oracle application before or after opening UFT.
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Testing in
Mozilla
Firefox

To test yourWeb application in Mozilla Firefox, youmust enable the Unified
Functional Testing Extension in one of the following ways:

l If theSelect Your Add-ons screen is displayed when you open Firefox,
select to keep the Unified Functional Testing Extension.

l If the Install Add-on tab opens and displays Unified Functional Testing
Extension when opening Firefox, select theAllow this installation check
box and click Continue.

Otherwise:

a. In Firefox, select Tools > Add-ons.

b. In the General tab, click Manage Add-ons.

c. In the Add-ons Manager tab, select theExtensions node.

d. In the Unified Functional Testing Extension row, click theEnable
button.

Add-in
Dependencies

l TheWeb Add-in must be loaded. TheWeb Add-in supports Web-based
forms.

l The Java Add-in must be loaded if your Oracle test or business component
includes Java test objects.

Configuration

Options Dialog Box Use the Java pane if your Oracle test or business component includes
Java test objects.
(Make sure that a GUI test is open and select Tools > Options > GUI
Testing tab > Java node).

See "Java Pane (Options Dialog Box > GUI Testing Tab)" on page
221.

Record and Run
Settings Dialog Box
(tests only)

Use theOracle tab.
(Record > Record and Run Settings)

See "Oracle Tab (Record and Run Settings Dialog Box)" on page 253.
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Test Settings Dialog
Box
(tests only)

l Use theWeb pane.
(File > Settings > Web node)

See "Web Pane (Test/Business Component Settings Dialog Box /
Application Area - Additional Settings Pane)" on page 79.

l Use the Java pane if your Oracle test or business component
includes Java test objects.
(File > Settings > Java node)

See "Java Pane (Test/Business Component Settings Dialog Box /
Application Area - Additional Settings Pane)" on page 228.

Custom Active
Screen Capture
Settings Dialog Box
(tests only)

Use theOracle applications section.
(Tools > Options > GUI Testing tab > Active Screen node >
Custom Level)

For details, see the section on the Custom Active Screen Capture
Settings dialog box in theHP Unified Functional Testing User Guide.

Application Area
Additional Settings
pane
(business components
only)

l Use theWeb pane if your test includes Web test objects.
In the application area, select Additional Settings > Web in the
sidebar.

For details, see "Web Pane (Test/Business Component Settings
Dialog Box / Application Area - Additional Settings Pane)" on page
79.

l Use the Java pane if your Oracle test or business component
includes Java test objects.
In the application area, select Additional Settings > Java in the
sidebar.

See "Java Pane (Test/Business Component Settings Dialog Box /
Application Area - Additional Settings Pane)" on page 228.

(The options shown in the Java pane of the Test Settings dialog box
are the same as the options that are available in the Additional
Settings in the application area.)
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Concepts

Considerations for Working with the Oracle Add-in
l If you installed a version of JInitiator 1.1.x after installing the Oracle Add-in, a warning is

displayed when you start recording your test or business component. Versions of JInitiator 1.1.x
installed after you install the Oracle Add-in are not supported by UFT. In this case, you can
repair the Oracle Add-in to enable full support of all currently installed versions of JInitiator 1.1.x.
For details, see the section on repairing your UFT installation in theHP Unified Functional
Testing Installation Guide.

If you try to record an action on anOracle object with an unsupported version of JInitiator 1.1.x,
UFT records a generic WinObject.Click statement that includes the coordinates of the click
and themouse button that was clicked.

l After installing the Oracle Add-in, your applications will always open with Java support active.
You can confirm that your Oracle environment has opened properly by checking the Java
console for the confirmationmessage similar to:

Loading Oracle Support (version x.x build xxx) (Oracle Corporation x.x.x.x
x).

For details, see " Dynamic Transformation Support " on page 247.

Note: The UFT Oracle Add-in supports only Oracle clients that are Java-based. Oracle
Developer/2000 is not supported.

l Before using the Oracle Add-in to test Oracle Applications, youmust first enable the Name
attribute supplied by the Oracle Applications server. details, see "How to Enable the Oracle
Name Attribute" on page 248.

l TheOracle Applications server supplies a uniqueName attribute for many application objects.
You can also find the Oracle Applications serverName attribute in the Oracle Add-in developer
name identification property. The developer name identification property is used by UFT in
most test object descriptions to identify Oracle objects. For details, see "How to Enable the
Oracle Name Attribute" on page 248.
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l In UFT, table data is always loaded from the application itself, even if the Active Screen
contains an image of the table. For this reason, youmust first open the table in the application
before creating a table checkpoint in a test.

n In some cases youmay need to scroll to the last row of the table tomake sure that all the data
is loaded.

n If the table object is not open in your application when you create the checkpoint, the Table
Checkpoint Properties dialog box contains only the Properties tab, and the option to select
which type of information to check (content or properties) is disabled.

n It is not necessary to open the table in your application to edit an existing table checkpoint.

l For details on UFT functionality, see theHP Unified Functional Testing User Guide.

Add-ins Guide
Chapter 14: Oracle Add-in - Quick Reference

HP Unified Functional Testing (12.00) Page 241 of 549



Reference

Troubleshooting and Limitations - Oracle Add-in
This section contains general information and limitations about the Oracle add-in, and includes the
following sections:

l "Installing the Oracle Add-in " below

l "Creating and Running Testing Documents" on the next page

l "Record and RunOptions" on the next page

l "Checkpoints" on page 244

For limitations relevant to specific test objects andmethods, see theOracle section of theHP UFT
Object Model Reference for GUI Testing.

Installing the Oracle Add-in

l If you install an Oracle JInitiator 1.1.x version after you install the UFT Oracle Add-in, youmust
repair UFT to test applications running in the newly installed JInitiator version. For details, see
theHP Unified Functional Testing Add-ins Guide.

Note: It is not necessary to re-install or otherwise configure the UFT Oracle Add-in if you
installed a new Oracle environment other than JInitiator 1.1.x.

l InWindows XP andWindows 2003, after you install the Oracle Add-in, theWindows Remote
Shell Service (rshsvc.exe) may fail and display an error message every time you restart the
computer. This occurs only if the Remote Shell Service is configured to run automatically.

Workaround:Either disable the automatic launching of the Remote Shell Service, or move the
following variables from the System Variables section of the Environment Variables dialog box
to the User Variables section: _classload_hook, _JAVA_OPTIONS, IBM_JAVA_OPTIONS, and
MSJAVA _ENABLE _MONITORS.

l The UFT Oracle Add-in provides a number of indicators that help you identify whether your add-
in is properly installed and functioning. The following table describes the indicators youmay see
when your add-in is not functioning properly, and suggests possible solutions:

Indicator Solution

You cannot record or
run tests onOracle
Applications.

Ensure that the Oracle Add-in is loaded. For details, see "How to
Manage UFT Add-ins" on page 32.
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Indicator Solution

The Java console does
not display a line
containing the text
similar to: Loading
Oracle Support.

Check that the settings in your environment correspond to the
environment settings defined in this chapter, or check for a batch
file that may override the settings.

For details, see:

n "Recording Tests onOracle Applications" on page 246.

n " Dynamic Transformation Support " on page 247.

Your Java console
contains the line Could
not find –Xrun
library:
jvmhook.dll.

Check that you have jvmhook.dll in your system folder
(WINNT\system32, Windows\System32, or Windows\SysWOW64,
depending on your operating system).

You cannot use UFT to
record onOracle
Applications running on
Oracle JInitiator
versions 1.1.X.

The version of Oracle JInitiator 1.1.X on which your Oracle
Application runs must be installed before you install the UFT Oracle
Add-in.

If you installed Oracle JInitiator versions 1.1.X on your computer
after you installed the Oracle Add-in, you should repair the Oracle
Add-in installation. For details, see the section on repairing your
UFT installation in theHP Unified Functional Testing Installation
Guide.

If, after reviewing the above indicators and solutions, you are still unable to record and run tests
on your Oracle application, contact HP Software Support.

Creating and Running Testing Documents

l Test objects that require the index property for their description (for example, range flexfield
objects) cannot be created from the Active Screen.

Workaround:Use theAdd Objects button in the Object Repository window to add these test
objects directly from your Oracle Applications instead.

l Active Screen captures are not supported for OracleListOfValues andOracleNotification test
objects.

l The recovery scenario pop-up window trigger event is not supported when testing Oracle
Applications.

l Simultaneous testing of multiple Oracle Applications sessions is not supported.

Record and Run Options
The Log out of the application when the test closes option in the Record and Run Settings
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dialog box does not work if the Responsibilities List of Values window is displayed in the Oracle
Applications session.

Checkpoints

l Performing a checkpoint on an object that is not always visible (such as a list opening from a
combo box selection or amenu item) is not fully supported.

Workaround: If a checkpoint on a transient object is required, make sure the object is visible
prior to executing the checkpoint. For example, in the case of combo box list, you should insert a
statement that clicks the combo box button before executing the checkpoint.

l When testing Oracle applications, a table checkpoint may not capture the values of columns
that are not visible.

Workaround:Before creating a table checkpoint, scroll in the table so that the last column is
visible.
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Chapter 15: Oracle Add-in - Testing and
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Concepts

Recording Tests on Oracle Applications
As you record on anOracle Applications session, UFT inserts statements into your test or business
component that represent the operations you perform. The UFT Oracle Add-in recognizes specific
Oracle objects such as button, form, navigator, list, and tree. It records these objects in relation to
the data selected or entered and to the object within its parent object.

Note: UFT does not record the selection of Oracle tabs. Each object in anOracle tab is
included in the object repository within the tab hierarchy. UFT then uses this hierarchy when
the test or business component is run, switching to the appropriate tab if needed.

The UFT learned object hierarchy is composed of one, two, or three levels of Oracle test objects.
Depending on the actual object on which you performed an operation, that object may be recorded
as a first level object (for example, OracleLogon), as a second level object (for example,
OracleFormWindow.OracleList), or as a third level object (for example,
OracleFormWindow.OracleTabbedRegion.OracleTable).

Even though the object on which you recordmay be embedded in several levels of objects, the
recorded hierarchy does not include these objects. For example, even if the OracleListOfValues
object in which you select an item is actually within anOracle form, which is contained within an
Oracle Applications session window, the recorded hierarchy is only OracleListOfValues.

Example of a Step on an Oracle Object

If you record the selection of an item in anOracle List of Values window, the Keyword View
may be displayed as follows:

UFT records this step in the Editor as:

OracleListOfValues("Responsibilities").Select "Assets, Vision Operations (US
A)"

Working with Tests
Each time you begin recording a test, you can use the "Oracle Tab (Record and Run Settings
Dialog Box)" (described on page 253) to instruct UFT to connect to a specified Oracle Applications
server. Alternatively, you can instruct UFT to record on any open browser. For details, see
"Recording Tests onOracle Applications" above.

Working with Components
The Record and Run Settings dialog box is used for tests only. When you record a business
component on anOracle Applications session, you cannot instruct UFT to open or connect to a
specified Oracle Applications server. You can open and connect to it manually or include
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statements in your business component (using theOpenApp operation or the SystemUtil utility
object and the OracleLogon test object) that open and connect to the Oracle Applications server.
For details on the Applications pane and Applications dialog box, see theHP Unified Functional
Testing User Guide.

Working with Java Test Objects
Youmay have a combination of Oracle and Java test objects in your Oracle test or business
component. This occurs when UFT encounters a Java applet within your Oracle Applications
session and records it using the Java test object hierarchy.

You can edit steps that use Java test objects, methods, and properties in the sameway as you edit
other standard steps. You can add new steps to existing tests or business components using the
new Oracle test object model. For details on Java objects, methods, and properties, see the Java
section of theHP UFT Object Model Reference for GUI Testing, installed together with the Oracle
Add-in. For details on Oracle objects, methods, and properties, see theOracle section of the
HP UFT Object Model Reference for GUI Testing.

There are specific options and settings you can use in your test or business component that apply
only to steps that use Java test objects. These options and settings are located in the Java pane of
the Test Settings dialog box (File > Settings > Java node) and the Java pane of the Options dialog
box (Tools > Options > GUI Testing tab > Java node). For more information, click theHelp
button in the relevant Java pane. Note that the options in the Java panes do not have any effect on
Oracle object steps in your test or business component.

Dynamic Transformation Support
TheOracle Add-in uses amechanism for supportingmultiple Java environments (Oracle Plug-in,
JInitiator) and their versions (JInitiator 1.1.8, 1.3.1, and so on) without requiring any configuration
changes. This mechanism is known as dynamic transformation support.

Dynamic transformation support uses the profiler interface of the Java Virtual Machine (JVM) to
adjust the Oracle Add-in support classes according to the Java environment and version in use.

The dynamic transformation support mechanism is invoked by the -Xrunjvmhook option (for
JInitiator 1.3.1.x and Sun Plug-in 1.4.1) or the _classload_hook=jvmhook option (for JInitiator
1.1.x) supplied to the JVM. If this option is specified, the JVM hook profiler, which is part of the
Oracle Add-in support, is loaded with every application or applet and dynamically transforms the
necessary classes to enable context-sensitive Oracle support.

l If the dynamic transformation support mechanism does not work properly, you can disable it and
manually configure the Oracle environment to use the Oracle Add-in without dynamic
transformation support. For details, see "How to Disable Dynamic Transformation Support" on
page 250.

l The dynamic transformation support mechanism is not supported when using the incremental
garbage collector (-Xincgc option). Therefore, if you absolutely must use the -Xincgc option,
you need to disable dynamic transformation support. For details, see "How to Disable Dynamic
Transformation Support" on page 250

Add-ins Guide
Chapter 15: Oracle Add-in - Testing and Configuration

HP Unified Functional Testing (12.00) Page 247 of 549



Tasks

How to Verify or Enable the Oracle Server Unique Name
Attributes

This task includes the following steps:

l "Prerequisite" below

l "Enable the Oracle server to supply unique Name attributes" below

1. Prerequisite
Use theObject Spy to point to a few edit boxes inside the Oracle application and view the
developer name attribute. If the developer name is displayed in all capital letters in the
format FORM:BLOCK:FIELD or FORM_BLOCK_FIELD, then the developer name attribute is
supplied correctly.

If the developer name value is empty, then the server does not supply uniqueName
attributes. To use the Oracle Add-in to test Oracle Applications, your Oracle server must
supply uniqueName attributes.

Your Oracle server administrator can assist you in enabling uniqueName attributes.

2. Enable the Oracle server to supply unique Name attributes
a. Add the following line to the server configuration file (for example, $OA_

HTML/bin/appsweb_UKTRN_hwu00001.cfg):

otherparams=record=names

b. Restart the Oracle server.

How to Enable the Oracle Name Attribute
This task describes the different ways in which you can enable theName attribute supplied by the
Oracle Applications server before using the Oracle Add-in to test Oracle Applications.

This task includes:

l "Enable the Name attribute when accessing the application directly" on the next page

l "Enable the Name attribute when using HTML to launch the Oracle application" on the next page

l "Enable the Name attribute when using the Personal Home Page to launch your Forms 6
application" on the next page
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Enable the Name attribute when accessing the application directly
Add record=names to the URL parameters.

Example:

http://oracleapps.mydomain.com:8002/dev60cgi/f60cgi?record=names

Enable the Name attribute when using HTML to launch the Oracle
application

1. In the startup HTML file that is used to launch the application, locate the line: <PARAM
name="serverArgs ............ fndnam= APPS">

2. Add theOracle key: record=names

Example:

<PARAM name="serverArgs" value="module=f:\FNDSCSGN userid=XYZ fndnam=app
s record=names">

Enable the Name attribute when using the Personal Home Page to launch
your Forms 6 application
Set up the following system profile option at (your) user level to enable theName attribute:

1. Sign on to your Oracle application and select System Administrator responsibility.

2. Select Nav > Profile > System.

3. In the Find System Profile Values form:

n Confirm that Display: Site and Users contains your user logon.

n Enter %ICX%Launch% in theProfile box.

n Click the Find button.

4. Copy the value from theSite box of the ICX: Forms Launcher profile and paste it in theUser
box. Add &play=&record=names to the end of the URL in theUser box.

5. Save your transaction.

6. Sign on again using your user name.

Note: If the ICX: Forms Launcher profile option is not updatable at the user level, access
Application Developer and select theUpdatable check box for the ICX_FORMS_
LAUNCHER profile.
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How to Set Oracle Environment Variables
This task describes how to set the environment variables you need for loading your Oracle
application with UFT Oracle Add-in support. For all the environments, you need to set one or more
environment variables with the path name of the Oracle Add-in support classes folder.

This task includes the following steps:

l "Sun Plug-in 1.4.1 andOracle JInitiator 1.3.1.x" below

l "Oracle JInitiator 1.1.x" below

Sun Plug-in 1.4.1 and Oracle JInitiator 1.3.1.x
Set the _JAVA_OPTIONS environment variable as follows:

-Xrunjvmhook
-Xbootclasspath/a:"<UFT installation folder>\bin\java
shared\classes";"<UFT installation folder>\bin\java_sharedclasses\jasmine.ja
r"

The above variables should appear on one line (no newline separators).

Note:

You can also use short paths in this command. For example:

-Xrunjvmhook -Xbootclasspath/a:C:\PROGRA~2\HP\UNIFIE~1\bin\JAVA_S~1\classes;
C:\PROGRA~2\HP\UNIFIE~1\bin\JAVA_S~1\classes\jasmine.jar

In this example, UFT is installed in the default installation folder (C drive, Program Files) on a
Windows 7 computer. PROGRA~2 denotes the Program Files (x86) folder, which is the
Program Files folder on 64-bit operating systems.

Oracle JInitiator 1.1.x
Set the _classload_hook environment variable to jvmhook.

How to Disable Dynamic Transformation Support
This task includes the following steps:

l "Save the dynamically transformed classes" on the next page

l "Disable dynamic transformation support " on the next page

This task describes how to disable dynamic transformation support if the dynamic transformation
support mechanism does not work properly.
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Save the dynamically transformed classes

1. Specify the folder in which to save the dynamically transformed classes that will be generated
during the preliminary launching of your Oracle application.

To do this:

a. Open the registry editor (select Start > Run, type regedit in theOpen box and click OK)

b. Navigate to the JavaAgentmain key, located in: HKEY_LOCAL_
MACHINE\SOFTWARE\Mercury Interactive\JavaAgent.

c. Define a new string value named ClassesDumpFolder, and set its value data to an existing
folder (preferably empty) on your computer, for example, C:\JavaSupportClasses.

d. If the ClassesDumpFolder string value already exists, you canmodify its value data to an
existing folder on your computer.

2. If you are using the -Xincgc option, temporarily remove it from the command line to enable the
JVM hook profiler to transform and save the necessary classes. You can add it back to the
command line after performing the following step.

3. Launch your applet or application and perform some basic operations on it. This ensures that all
of the necessary classes are transformed and saved. Close your application. All of the
dynamically transformed classes are now saved in the folder you specified in the previous step
(for example, C:\JavaSupportClasses).

Disable dynamic transformation support
For Sun Plug-in 1.4.1 or JInitiator 1.3.1.x:

1. Remove the -Xrunjvmhook option from the _JAVA_OPTIONS environment variable.

2. Add the following option instead: -Xbootclasspath/p:<ClassesDumpFolder>\Final, where
<ClassesDumpFolder> is the value of the folder in which the dynamically transformed classes
were saved, such as C:\JavaSupportClasses, appended by the Final subfolder. For
example, after your modification the _JAVA_OPTIONS environment variable might look like this:

-Xbootclasspath/p:C:\JavaSupportClasses\Final -Xbootclasspath/a:"%Program
Files%\HP Software\Unified Functional Testing\bin\java_shared\classes";

For Initiator 1.1.x:

1. Remove the _classload_hook option from the JDK settings by deleting the environment
variable.

2. Manually copy the classes from the <ClassesDumpFolder>, where <ClassesDumpFolder> is
the value of the folder in which the dynamically transformed classes were saved, such as
C:\JavaSupportClasses, appended by the Final subfolder, to the JInitiator 1.1.x classes
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folder. You can find the JInitiator 1.1.x classes folder under
%ProgramFiles%\Oracle\JInitiator 1.1.x\classes.
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Oracle Tab (Record and Run Settings Dialog Box)
This tab enables you to specify whether or not to connect to anOracle Applications server and open
a specified Oracle Applications session when a record or run session begins. If you select to
connect to a specific server, you can specify details that will enable UFT to automatically log on to
the server each time a record or run session begins (instead of recording the log-in steps).
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To access Select Record > Record and Run Settings and select theOracle tab

Note: If you do not modify the Record and Run settings before you begin
recording, the Record and Run Settings dialog box opens automatically when
you begin recording a new test (by clickingRecord (or choosingRecord >
Record).

Important
information

If you load only the UFT Oracle Add-in and theWeb add-in, then only the Oracle,
Web, andWindows Applications tabs are displayed in the Record and Run
Settings dialog box. If other add-ins are loaded, the corresponding tabs (if any) are
also displayed.

Relevant
tasks

l "How to Verify or Enable the Oracle Server Unique NameAttributes" on page
248

l "How to Enable the Oracle Name Attribute" on page 248

l "How to Set Oracle Environment Variables" on page 250

l "How to Disable Dynamic Transformation Support" on page 250

See also l "Recording Tests onOracle Applications" on page 246

l " Dynamic Transformation Support " on page 247

l "Considerations forWorking with the Oracle Add-in " on page 240

User interface elements are described below:

UI Elements Description

Record and run
test on any
open Oracle
Application

Instructs UFT to record and run the test on any openOracle application.

Open the
following
application
when a record
or run session
begins

Instructs UFT to connect to the Oracle Applications server at the specified
URL address.

Note: This setting controls only which application, if any, is opened at
the beginning of a record or run session. It does not affect the
applications that UFT recognizes. Even if this radio button is selected
and no application is specified, UFT can still record, recognize, and run
on any openOracle application.

Address Indicates the URL of the Oracle Applications server to which you want to
connect.
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UI Elements Description

Auto-login Instructs UFT to log on to the specified Oracle Applications server using the
specified user name and password.

Enabled only whenOpen the following application when a record or run
session begins is selected.

The Auto-login feature works for the Java interface login only. If you log in to
your Oracle applications through aWeb interface, the Auto-login feature
cannot be used.

User name The user name used to log on to the specified server.

Enabled only whenAuto-login is selected.

Password The password for the specified user name.

Enabled only whenAuto-login is selected.

Log out of the
application
when the test
closes

Instructs UFT to log out of the Oracle Applications session specified in the
Record and Run Settings dialog box when the test is closed.

Enabled only whenAuto-login is selected.

Close the
browser when
the test closes

Instructs UFT to close the browser on which the test is recorded when the
test is closed.

Enabled only whenOpen the following application when a record or run
session begins is selected.

Oracle Record and Run Environment Variables
You can use record and run environment variables to specify the applications you want to use for
recording and running your test. These variables can also be used in external library files for
automation scripts.

If you define any of these record and run environment variables, they override the values in the
corresponding boxes in the "Oracle Tab (Record and Run Settings Dialog Box)" (described on page
253). For details, see "Recording Tests onOracle Applications" on page 246.

Use the variable names listed in the table below to define Oracle record and run variables:

UI Elements
Variable
Name Description

Address ORACLE_
URL_ENV

The URL of the Oracle Applications server to which you want
to connect.
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UI Elements
Variable
Name Description

Auto-login ORACLE_
AUTO_
LOGIN_ENV

Instructs UFT to log on automatically to the Oracle
Applications server.

Possible values:

l True

l False

User name ORACLE_
USER_
NAME_ENV

The user name used to log on to the specified server.

Password ORACLE_
PASSWORD_
ENV

The password for the specified user name.

Log out of the
application
when the test
closes

ORACLE_
LOGOUT_
ENV

Instructs UFT to log out of the Oracle Applications session
specified in "Oracle Tab (Record and Run Settings Dialog Box)
" (described on page 253) when the test is closed.

Possible values:
True
False

Close the
browser when
the test closes

ORACLE_
CLOSE_
BROWSER_
ENV

Instructs UFT to close the browser on which the test is
recorded when the test is closed.

Possible values:
True
False

For details on defining and working with environment variables, see theHP Unified Functional
Testing User Guide.
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Chapter 16: PeopleSoft Add-in - Quick Reference
You can use the UFT PeopleSoft Add-in to test PeopleSoft user-interface objects (controls).

The following tables summarize basic information about the PeopleSoft Add-in and how it relates to
some commonly-used aspects of UFT.

General Information

Add-in Type This is aWeb-based add-in. Much of its functionality is the same as other
Web-based add-ins.

See "Web-Based Application Support" on page 39.

Supported
Environments

For details on supported PeopleSoft environments, see the PeopleSoft Add-
in section of theHP Unified Functional Testing Product Availability Matrix,
available from the UFT Help or the root folder of the Unified Functional
Testing DVD.

Important
Information

See "Considerations forWorking with the PeopleSoft Add-in" on page 261.

Test Object
Methods and
Properties

The PeopleSoft Add-in provides test objects, methods, and properties that
can be used when testing objects in PeopleSoft applications. For details,
see thePeopleSoft section of theHP UFT Object Model Reference for GUI
Testing.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

Troubleshooting
and Limitations

See "Troubleshooting and Limitations - PeopleSoft Add-in" on page 262.

Prerequisites

Opening Your
Application

Youmust open UFT before opening your PeopleSoft application.
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Testing in
Mozilla
Firefox

To test yourWeb application in Mozilla Firefox, youmust enable the Unified
Functional Testing Extension in one of the following ways:

l If theSelect Your Add-ons screen is displayed when you open Firefox,
select to keep the Unified Functional Testing Extension.

l If the Install Add-on tab opens and displays Unified Functional Testing
Extension when opening Firefox, select theAllow this installation check
box and click Continue.

Otherwise:

a. In Firefox, select Tools > Add-ons.

b. In the General tab, click Manage Add-ons.

c. In the Add-ons Manager tab, select theExtensions node.

d. In the Unified Functional Testing Extension row, click theEnable
button.

Add-in
Dependencies

TheWeb Add-in must be loaded.

Configuration

Options Dialog Box Use theWeb pane.
(Make sure that a GUI test is open and select Tools > Options >
GUI Testing tab > Web > General node.)

For details, see "Web > General Pane (Options Dialog Box)" on
page 65.

Record and Run Settings
Dialog Box
(tests only)

Use theWeb tab.
(Record > Record and Run Settings)

See "Web Tab (Record and Run Settings Dialog Box)" on page
83.

Test Settings Dialog Box
(tests only)

Use theWeb pane.
(File > Settings > Web node)

See "Web Pane (Test/Business Component Settings Dialog Box
/ Application Area - Additional Settings Pane)" on page 79.

Custom Active Screen
Capture Settings Dialog
Box
(tests only)

Use theWeb section.
(Tools > Options > GUI Testing tab > Active Screen node >
Custom Level)

See the section on the Custom Active Screen Capture Settings
dialog box in theHP Unified Functional Testing User Guide.
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Application Area
Additional Settings pane
(business components only)

Use theWeb pane.
In the application area, select Additional Settings > Web in the
sidebar.

See "Web Pane (Test/Business Component Settings Dialog Box
/ Application Area - Additional Settings Pane)" on page 79.

This chapter includes:

Concepts 261

Considerations forWorking with the PeopleSoft Add-in 261

Reference 262

Troubleshooting and Limitations - PeopleSoft Add-in 262
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Concepts

Considerations for Working with the PeopleSoft Add-in
l When learning PSFrame objects, orWeb pages containing PSFrame objects, the following child

objects are automatically filtered out and are not added to the object repository:

n WebElement

n WebTable

n Images of type "Plain Image"

n Images with type "Image Link"

If you want to add an object that is automatically filtered out, you canmanually add it by
selecting it in the Object Selection Dialog Box .

l The PeopleSoft Add-in provides a customized PSFrame test object to identify PeopleSoft
frames. The PSFrame object differs from theWeb Frame object both in its test object
description and its algorithm for generating object names. This customization helps make your
PeopleSoft tests easy to read andmaintain.

l The PeopleSoft Add-in identifies all other objects in your PeopleSoft application usingWeb test
objects.

For details on PeopleSoft andWeb test objects, methods, and properties, see thePeopleSoft
andWeb sections of theHP UFT Object Model Reference for GUI Testing.

l For the purposes of Web event recording, UFT treats Web test objects that are child objects of a
PSFrame test object as PeopleSoft objects and thus applies the settings in the PeopleSoft
event configuration XML file when recording those objects.

For details onWeb event recording configurations, see "Event Recording Configuration forWeb-
Based Applications" on page 44.
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Troubleshooting and Limitations - PeopleSoft Add-in
l The Active Screenmay not function correctly when working with non-English UI servers.

l If you use theENTER key to activate a search operation while recording a test, UFT may not
perform the operation as expected during the test run.

Workaround:Activate the search by clicking theSearch button with themouse.

l The use of keyboard shortcut keys to perform operations while recording is not supported.
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Chapter 17: PowerBuilder Add-in - Quick Reference
You can use the UFT PowerBuilder Add-in to test PowerBuilder user-interface objects (controls).

The following tables summarize basic information about PowerBuilder Add-in and how it relates to
some commonly-used aspects of UFT.

General Information

Add-in Type This is aWindows-based add-in. Much of its functionality is the same as
otherWindows-based add-ins.

See "Windows-Based Application Support" on page 94.

Supported
Environments

For details on supported PowerBuilder environments, see the PowerBuilder
Add-in section of theHP Unified Functional Testing Product Availability
Matrix, available from the UFT Help or the root folder of the hUnified
Functional Testing DVD.

Important
Information

See "Considerations forWorking with the PowerBuilder Add-in " on page
266.

Test Object
Methods and
Properties

The PowerBuilder Add-in provides test objects, methods, and properties that
can be used when testing objects in PowerBuilder applications. For details,
see thePowerBuilder section of theHP UFT Object Model Reference for
GUI Testing.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide.

l See "Considerations forWorking with the PowerBuilder Add-in " on page
266.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

Troubleshooting
and Limitations

See "Troubleshooting and Limitations - PowerBuilder Add-in" on page 267.

Prerequisites

Opening Your
Application

You can open your PowerBuilder application before or after opening
UFT.

Configuration
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Options Dialog
Box

Use theWindows Applications pane.
(Tools > Options > GUI Testing tab >Windows Applications node)

See "Windows Applications > General Pane (Options Dialog Box >
GUI Testing Tab)" on page 98.

Record and Run
Settings Dialog
Box
(tests only)

Use theWindows Applications tab.
(Record > Record and Run Settings

See "Windows Applications Tab (Record and Run Settings Dialog Box)" on
page 109.

Note: If you select theRecord and Run only on radio button in the
Record and Run Settings dialog box, the settings also apply to (limit)
the applications that are recognized for Object Spy and other pointing
hand operations.

Custom Active
Screen Capture
Settings Dialog
Box
(tests only)

Use theWindows applications section.
(Tools > Options > GUI Testing tab > Active Screen node > Custom
Level)

See the section on the Custom Active Screen Capture Settings dialog box in
theHP Unified Functional Testing User Guide.

Application
Area Additional
Settings pane
(business
components only)

Use theApplications pane.
In the application area, select Additional Settings > Applications in the
sidebar.

See the section on the Applications pane in theHP Unified Functional
Testing User Guide.

This chapter includes:

Concepts 266

Considerations forWorking with the PowerBuilder Add-in 266

Reference 267

Troubleshooting and Limitations - PowerBuilder Add-in 267
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Concepts

Considerations for Working with the PowerBuilder Add-in
The PowerBuilder Add-in provides the PbDataWindow test object with customizedmethods and
properties to help you test PowerBuilder's DataWindow control.

l When you insert a checkpoint or output value step on a DataWindow control, UFT treats it as a
table and opens the Table Checkpoint Properties or Table Output Value Properties dialog box
(not supported for business components). It enables you to check or retrieve values for the table
content and the object properties.

l When you insert a checkpoint or output value step on a DataWindow control during a recording
session, the properties available to be checked or retrieved in the Properties tab include the
DataWindow control's inner attributes (such as DataWindow.color) in addition to the
identification properties (such as enabled and focused).

The set of DataWindow inner attributes available in the dialog box is the same as the list of
properties that would be returned if you run a DataWindow.Describe
("DataWindow.attributes") statement. Properties of the inner objects of the table (objects
that can be retrieved using a DataWindow.Describe ("DataWindow.objects") statement) are
not available in this list.

l When you insert a checkpoint or output value step on a DataWindow control while editing (from
the Active Screen, or on a step for which Active Screen data was captured), only the
identification properties are available in the list.

For details on the DataWindow test object, see thePowerBuilder section of theHP UFT Object
Model Reference for GUI Testing.
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Troubleshooting and Limitations - PowerBuilder Add-in
When learning or recording on toolbars in PowerBuilder applications, UFT no longer records the
PbToolbar test object. Instead, it records a PbObject.Click step. The PbToolbar test object is no
longer available in UFT dialog boxes or in the documentation.

If a PbToolbar test object exists in an old object repository, it will be recognized and supported, but
toolbar-specific methods such as CheckItem, GetContent, GetItem, GetItemProperty,
GetItemCount, GetSelection, Press, ShowDropDown, andWaitItemProperty are not supported
for this object. To fix this, update object repositories and tests to use the PbObject test object for
toolbar steps.
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Chapter 18: Qt Add-in - Quick Reference
You can use theQt testing support provided by UFT to test user-interface objects (controls)
developed using the Qt framework for mobile devices.

The following tables summarize basic information about Qt testing support and how it relates to
some commonly-used aspects of UFT.

General Information

Add-in Type TheQt Add-in is aWindows-based add-in. Much of its functionality is the same
as otherWindows-based add-ins.

See "Windows-Based Application Support" on page 94

Important
Information

"Considerations - Qt Add-in" on page 271

Test Object
Methods
and
Properties

TheQt Add-in uses a sub-set of the standardWindows test objects, methods,
and properties, which can be used when testing objects (controls) in Qt
applications. For details, see theStandard Windows section of theHP UFT
Object Model Reference for GUI Testing.

For a list of supported Qt controls, see "Considerations - Qt Add-in" on page 271.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in theHP Unified
Functional Testing User Guide.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

Prerequisites

Opening Your
Application

Youmust open UFT before opening your Qt application.

Add-in
Dependencies

None

Low Level
Recording

To enable low level recording onQt controls, youmust first modify the object
identification properties list for theWinObject test object class, as follows:

l Add the regexpwndtitle property to themandatory properties list.

l Move the object class property up the assistive properties list so that it is
learned before the text property.

For details, see the section describing the Object Identification Dialog Box in
theHP Unified Functional Testing User Guide.
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Configuration

Options Dialog Box Use theWindows Applications pane.
(Tools > Options > GUI Testing tab > Windows Applications node)

See "Windows Applications > General Pane (Options Dialog Box >
GUI Testing Tab)" on page 98.

Record and Run
Settings Dialog Box
(tests only)

Use theWindows Applications tab.
(Run > Run Settings orRecord > Record Settings)

See "Windows Applications Tab (Record and Run Settings Dialog Box)
" on page 109.

Note: UFT recognizes Qt objects only in applications that are
opened after changing settings in theWindows Applications tab of
the Record and Run Settings dialog box.

Custom Active
Screen Capture
Settings Dialog Box
(tests only)

Use theWindows applications section.
(Tools > Options > GUI Testing tab > Active Screen node >
Custom Level)

See the section on the Custom Active Screen Capture Settings dialog
box in theHP Unified Functional Testing User Guide.

Application Area
Additional Settings
tab
(business components
only)

Use theApplications pane.
In the application area, click Additional Settings in the sidebar and
select the Java node

See the section on the Applications Pane in theHP Unified Functional
Testing User Guide.

This chapter includes:

Considerations - Qt Add-in 271

Add-ins Guide
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Considerations - Qt Add-in
Qt Add-in support is provided using standardWindows test objects. The following table lists each
supported Qt control and its corresponding standardWindows test object.

Qt Control Standard Windows Test Object

QCheckBox WinCheckBox

QComboBox WinComboBox

QComboBoxPrivateContainer Window

QExpandingLineEdit WinEdit

QLabel Static

QLineEdit WinEdit

QListWidget WinList

QMenu Window

QMenuBar WinToolBar

QPlainTextEdit WinEditor

QPushButton WinButton

QRadioButton WinRadioButton

QSpinBox WinSpin

QTabWidget WinTab

QToolButton WinButton

QTreeWidget WinTreeView

HP Unified Functional Testing (12.00) Page 271 of 549



HP Unified Functional Testing (12.00) Page 272 of 549

Part 11: Add-in for SAP Solutions



Chapter 19: Add-in for SAP Solutions - Overview
You can use the UFT Add-in for SAP Solutions to test user-interface objects (controls) in SAP GUI
forWindows applications and inWeb-based SAP applications. You can create and run tests and
business components on these objects, and check their properties.

After you create your test or business component, you can enhance it by adding checkpoints,
retrieving output values, and parameterizing values. Where relevant, you can also add SAP GUI for
Windows or SAP Web objects, methods and properties to it.

This section contains:

l "Web-based SAP Support" on page 274

l "Windows-based SAP Support" on page 286
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Chapter 20: Web-based SAP Support
This section contains the following:

"Web-Based SAP Support - Quick Reference" below

"Web-Based SAP Support - Testing and Configuration" on page 280

Web-Based SAP Support - Quick Reference
You can use the SAP Web testing support provided with the UFT Add-in for SAP Solutions to test
user-interface objects inWeb-based SAP applications. These applications include SAP Enterprise
Portal, Internet Transaction Server, SAP Customer Relationship Management (CRM), and the
Interaction CentreWebClient.

The following tables summarize basic information about theWeb-based SAP environment and how
it relates to some commonly-used aspects of UFT.

General Information

Add-in Type Web-based SAP testing support is similar to otherWeb-based add-ins.

For details, see "Web-Based Application Support" on page 39.

Supported
Environments

For details on supportedWeb-based SAP environments, see the Add-in for
SAP Solutions section of theHP Unified Functional Testing Product
Availability Matrix, available from the UFT Help or the root folder of the
Unified Functional Testing DVD.

Note: Firefox is not supported for testingWeb-based SAP
environments.
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Important
Information

l Before you begin recording tests onWeb-based SAP applications, you
can define your required recording settings. This enables you to specify
the browser on which you want UFT to record, specify any environment
variables, and select the requiredWeb options to optimize performance.
For details, see "SAP Tab (Record and Run Settings Dialog Box)" on
page 314.

l When the UFT Add-in for SAP Solutions is loaded, UFT can learn objects
and run steps on bothWeb-based (requires theWeb Add-in, too) and
Windows-based SAP applications.

n For details on recording and running tests and business components
on SAP GUI forWindows applications, see "Low-Level or Analog
Mode Recording on SAP GUI forWindows" on page 306 and "How to
Record on StandardWindows Controls During an SAP GUI for
Windows Recording Session" on page 313.

n For details on working with SAP GUI from HTML, see "Considerations
forWorking with SAP GUI for HTML" on page 281.

Test Object
Methods and
Properties

The Add-in for SAP Solutions provides test objects, methods, and properties
that can be used when testing objects inWeb-based SAP applications. For
details, see the SAPWeb section of theHP UFT Object Model Reference
for GUI Testing.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide.

l See "Considerations forWorking with SAP GUI for HTML" on page 281.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

Troubleshooting
and Limitations

See "Troubleshooting and Limitations - Web-based SAP" on page 278.

Prerequisites

Opening Your
Application

l OpenUFT before you open yourWeb-based SAP application.

l If you are working in an SAP GUI application that contains HTML objects,
you can log on to your application before opening UFT, but youmust open
UFT before navigating to the transaction containing any HTML objects.

l For SAP GUI for HTML, Interaction CentreWebClient (ICWC)
applications, and Customer Relationship Management (CRM) applications,
confirm that your SAP server and client are configured properly.

See "How to Enable Support for SAP GUI forWindows" on page 308.

Add-ins Guide
Chapter 20: Web-based SAP Support
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Testing in
Mozilla
Firefox

To test yourWeb application in Mozilla Firefox, youmust enable the Unified
Functional Testing Extension in one of the following ways:

l If theSelect Your Add-ons screen is displayed when you open Firefox,
select to keep the Unified Functional Testing Extension.

l If the Install Add-on tab opens and displays Unified Functional Testing
Extension when opening Firefox, select theAllow this installation check
box and click Continue.

Otherwise:

a. In Firefox, select Tools > Add-ons.

b. In the General tab, click Manage Add-ons.

c. In the Add-ons Manager tab, select theExtensions node.

d. In the Unified Functional Testing Extension row, click theEnable
button.

Add-in
Dependencies

TheWeb Add-in must be loaded.

Configuration

Options
Dialog Box

Use theWeb pane.
(Make sure that a GUI test is open and select Tools > Options > GUI Testing
tab > Web > General node.)

See "Web-Based SAP Support - Testing and Configuration" on page 280.

Record and
Run Settings
Dialog Box
(tests only)

l Use the SAP tab (Record > Record and Run Settings) to connect to the
SAP GUI Client for SAP GUI for HTML or Interaction CentreWebClient
(ICWC) applications. This is because ICWC opens from inside the SAP
GUI Client.

See "How to Enable Support for SAP GUI forWindows" on page 308.

l Use theWeb tab (Record > Record Settings) to instruct UFT to use a
specific URL and browser to open aWeb-based SAP application, or the
SAP Enterprise Portal, at the beginning of each record and run session.
Alternatively, you can instruct UFT to record and run on any open browser.

See "Web Tab (Record and Run Settings Dialog Box)" on page 83.

Test Settings
Dialog Box
(tests only)

Use theWeb pane.
(File > Settings > Web node)

See "Web Pane (Test/Business Component Settings Dialog Box /
Application Area - Additional Settings Pane)" on page 79.

Add-ins Guide
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Custom
Active Screen
Capture
Settings
Dialog Box
(tests only)

Use theWeb section.
(Tools > Options > GUI Testing tab > Active Screen node > Custom Level
button)

See the section on the Custom Active Screen Capture Settings dialog box in
theHP Unified Functional Testing User Guide.

Application
Area
Additional
Settings pane
(business
components
only)

Use theWeb pane.
In the application area, select Additional Settings > Web in the sidebar.

See "Web Pane (Test/Business Component Settings Dialog Box /
Application Area - Additional Settings Pane)" on page 79.

Web Event
Recording
Configuration
Dialog Box

When you load the Add-in for SAP Solutions, the settings in the "Web Event
Recording Configuration Dialog box" on page 533 (Record > Web Event
Recording Configuration) are automatically customized. You do not need to
make any Web event configuration changes.

This section includes

Troubleshooting and Limitations - Web-based SAP 278

Add-ins Guide
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Troubleshooting and Limitations - Web-based SAP
This section contains general troubleshooting and limitation information about theWeb-based SAP
add-in, and includes the following sections:

l "General" below

l "SAP Enterprise Portal" below

l "SAP GUI for HTML—Internet Transaction Server (ITS) " on the next page

l "Using the Active Screen " on the next page

l "Web-based CRM Systems" on the next page

General

l It is not recommended to work with otherWeb-based add-ins when the UFT Add-in for
SAP Solutions is loaded. The Add-in for SAP Solutions modifies certainWeb configuration
settings that may affect other add-ins or applications.

l When recording and running steps on a table control, only the table content that is visible on the
client is actually available.

l During a run session, the SAP platform response timemay be slower than the time it takes for
UFT to run the corresponding step.

Workaround: Add aWait statement prior to the relevant step.

SAP Enterprise Portal

l Operations on the iView optionmenu and on objects within the page title bar of SAP Enterprise
Portal are recorded as Web operations on the Frame object and not as SAP operations on the
iView object.

l Minimized or collapsed iViews may not be recognized correctly.

l In some cases, whenmore than one browser is open during the test run, UFT is unable to
correctly identify certain objects.

Workaround: Clear theEnable Smart Identification check box for the Browser test objects in
the Object Repository window. Youmay also want to disable theEnable Smart Identification
option for Browser test objects in the Object Identification dialog box for future test recording.

l In some cases, a frame in SAP Enterprise Portal may be recognized as aWeb Frame object
instead of an iView object. In some of these, the frame name is generated dynamically. Because
theWeb Frame object uses the name property to identify the object, youmust modify the
recorded name value to use an appropriate regular expression so that UFT will be able to
recognize it during the test run.
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SAP GUI for HTML—Internet Transaction Server (ITS)

l When using the Object Spy or creating a checkpoint on an object inside an SAPWeb table cell,
UFT may recognize the object as aWebElement (and not as the appropriate SAPWeb object), if
a click has not yet been performed on the object.

Workaround:Click on the object inside the SAPWeb table cell before using the Object Spy or
creating a checkpoint on it.

l Dragging the SAP GUI for HTML table scroll bar is not recorded.

Workaround:You can record scrolling in SAP GUI for HTML tables by clicking the scroll
button. Alternatively, use the StepGenerator or Editor to insert a SAPTable.Object.DoScroll
("up") or SAPTable.Object.DoScroll("down") statement in your test.

l The appearance of toolbar buttons may differ, and toolbar buttons may or may not be displayed,
depending on the size of your browser window.

Workaround: Try tomaintain the same browser window size and the resultingmenu
appearance when recording and running your test.

l When running a test on an ITS frame in an SAP Enterprise Portal iView, the ITS menu
sometimes fails to operate properly.

Workaround:Enlarge the iView size and/or increase theObject Synchronization Timeout
and then run the test again.

l When recording a SAPList object, you need to click the input part of the list, not its button part in
order to enable UFT to recognize the object.

Using the Active Screen

l The Active Screenmay not display the entire HTML page captured while recording your test.

Workaround:Resize the Active Screen so that it best fits the HTML page size.

l When testing an SAP Enterprise Portal application, it is recommended to set advanced
authentication for Active Screen access (File > Settings > Web).

l Avoid using an Active Screen that was captured when a pop-up dialog was open to add an object
from themain window to the object repository. Doing this results in an incorrect object hierarchy
in the object repository.

Web-based CRM Systems

l When using UFT to test Web-based CRM systems, make sure that the CRM system is in test
mode. You can do this by adding "?sap-testmode=X" to the URL.

Add-ins Guide
Chapter 20: Web-based SAP Support
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Web-Based SAP Support - Testing and Configuration
This section includes

Concepts 281

Considerations forWorking with SAP GUI for HTML 281

Reference 282

Web > Page/FrameOptions Pane (Options Dialog Box > GUI Testing Tab) 282

Web > Advanced Pane (Options Dialog Box > GUI Testing Tab) 283
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Concepts

Considerations for Working with SAP GUI for HTML

l You can add a table checkpoint while recording or editing your test.

l If a table has a column header row, it is counted as the first row in the table.

l If you have not recorded a step on the table object you want to check, but you have an Active
Screen capture that displays the table object, you can add a table checkpoint if the Active
ScreenCapture level was set toCompletewhen the object was captured, and theActive
Screen is currently selected (View > Active Screen).

(You set theCapture level in theActive Screen pane of the Options dialog box (Tools >
Options > GUI Testing tab > Active Screen node). For details, see the section on Active
Screen options in theHP Unified Functional Testing User Guide.)

l You can spool all of the available data from an SAP GUI for HTML application table into an
external file using the GetCellDatamethod, which loops through each cell in the table. You can
then save the information to an external file.

The following example uses theGetCellDatamethod to list the data of each cell in a table of 10
rows and 10 columns:

For i=1 to 10
For j=1 to 10

Dat=Browser("ITS System Informati").Page("Table control").SAPTable("MySAP
Table").GetCellData (i, j)

‘Enter lines of code that use the value of the returned Dat variable
Next

Next

For details on theGetCellDatamethod, see theSAP Web section of theHP UFT Object Model
Reference for GUI Testing.
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Reference

Web > Page/Frame Options Pane (Options Dialog Box > GUI
Testing Tab)

This pane enables you to configure the settings that are best-suited for testing Page and Frame test
objects inWeb-based SAP applications. Applying these recommended settings helps to optimize
UFT performance.

To
access

1. Do one of the following:

n Ensure that a GUI test, action, or component is in focus in the document
pane.

n In the Solution Explorer, select a GUI test or component node or one of its
child nodes.

2. Select Tools > Options > GUI Testing tab > Web node > Page/Frame
Options node.

See also l "Web-Based SAP Support - Quick Reference" on page 274

l "Web > Advanced Pane (Options Dialog Box > GUI Testing Tab)" below
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Recommended settings are described below:

UI
Elements Description

Create a
new Page
test object
for

Different URLs or a change in data transfer

Instructs UFT to create a new Page object only when the page URL changes, or if
the URL stays the same and data that is transferred to the server changes,
according to the data types and transfer methods you select.

Make sure that only the following check boxes are selected:

l Ignore user-input data - Get

l Ignore user-input data - Post

l Ignore additional Page information

Create a
new Frame
test object
for

Different URLs or a change in data transfer

Note: This option is selected by default.

Instructs UFT to create a new Frame object only when the page URL changes, or
if the URL stays the same and data that is transferred to the server changes,
according to the data types and transfer methods you select.

Make sure that all of the check boxes in this section are selected.

Web > Advanced Pane (Options Dialog Box > GUI Testing Tab)

This pane enables you to configure the advanced settings that are best-suited for testingWeb-
based SAP applications. Applying these recommended settings helps to optimize UFT
performance.

Add-ins Guide
Chapter 20: Web-based SAP Support
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To
access

1. Do one of the following:

n Ensure that a GUI test, action, or component is in focus in the document
pane.

n In the Solution Explorer, select a GUI test or component node or one of its
child nodes.

2. Select Tools > Options > GUI Testing tab > Web node > Advanced node.

See also l "Web-Based SAP Support - Quick Reference" on page 274

l "Web > Page/FrameOptions Pane (Options Dialog Box > GUI Testing Tab)" on
page 282

Add-ins Guide
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Recommended settings are described below:

UI Elements Description

Record
settings

Select theUse standard Windows mouse events check box, as well as the
following check boxes:

l OnClick

l OnMouseDown

l OnMouseUp

This instructs UFT to use these standardWindows mouse events instead of
browser events.

Add-ins Guide
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Chapter 21: Windows-based SAP Support
This chapter contains the following:

"Windows-based SAP Support - Quick Reference" below

"Windows-based SAP Support - Testing and Configuration" on page 297

"UFT-SAP SolutionManager Integration" on page 322

Windows-based SAP Support - Quick Reference
You can use theWindows-based SAP testing support provided with the UFT Add-in for
SAP Solutions to test user-interface objects in SAP GUI forWindows user-interface objects.

The following tables summarize basic information about theWindows-based SAP environment and
how it relates to some commonly-used aspects of UFT.

General Information

Add-in Type When testing SAP GUI forWindows applications, much of the functionality
is the same as otherWindows-based add-ins.

See "Windows-Based Application Support" on page 94.

Supported
Environments

For details on supportedWindows-based SAP environments, see the Add-in
for SAP Solutions section of theHP Unified Functional Testing Product
Availability Matrix, available from the UFT Help or the root folder of the
Unified Functional Testing DVD.

Important
Information

When the Add-in for SAP Solutions is loaded, UFT can learn objects and run
steps on bothWeb-based andWindows-based SAP applications. For details
on recording and running tests and business components onWeb-based
SAP applications, see "Web-Based SAP Support -
Testing and Configuration" on page 280.

Test Object
Methods and
Properties

The Add-in for SAP Solutions provides test objects, methods, and properties
that can be used when testing objects in SAP GUI forWindows
applications. For details, see the SAP GUI forWindows section of the
HP UFT Object Model Reference for GUI Testing.
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Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide.

l See "Checkpoints andOutput Values in SAP GUI forWindows" on page
289.

l See "Supported Checkpoints " on page 541and "Supported Output
Values " on page 543Per Add-In.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

Troubleshooting
and Limitations

See "Troubleshooting and Limitations - Windows-based SAP" on page 291

Prerequisites

Before Using
this Add-in

For details on the following prerequisites, see "How to Enable Support for SAP
GUI forWindows" on page 308.

l The SAP GUI Scripting optionmust be installed.

l Your server and client must have the proper package and patch versions
installed. For details, see "Package and Patch Versions Requirements -
SAP Application Server and SAP GUI forWindows" on page 291.
See also: SAP OSS note # 480149

l The Scripting API must be enabled on both the server and client. For details,
see "Enable scripting on the SAP application (server-side)" on page 308.

l Your client must be configured to use theDialog display mode for F4Help
screens.

l Make sure that the server is not set to use a Low speed connection.

l The F1 and F4Help display settingmust be configured correctly to support
testing the use of the F1 and F4Help screens in your SAP GUI forWindows
application.

l If you plan to use the UFT-SolutionManager integration features, youmust
also install the appropriate support package and configure the Solution
Manager server to work with UFT. For details, see "How to Configure
SolutionManager toWork with UFT" on page 327.

Add-in
Dependencies

None

Configuration
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Options Dialog Box Use theSAP> General pane.
(Tools > Options > GUI Testing tab > SAP > General node)

See "SAP > General Pane (Options Dialog Box > GUI Testing
Tab) " on page 318.

Record and Run Settings
Dialog Box
(tests only)

Use theSAP tab.
(Record > Record and Run Settings)

See "SAP Tab (Record and Run Settings Dialog Box)" on page
314.

Custom Active Screen
Capture Settings Dialog
Box
(tests only)

Use the SAP GUI forWindows section.
(Tools > Options > GUI Testing tab > Active Screen node >
Custom Level button)

See the section on the Custom Active Screen Capture Settings
dialog box in theHP Unified Functional Testing User Guide.

Application Area
Additional Settings pane
(business components only)

Use theApplications pane.
In the application area, select Additional Settings >
Applications in the sidebar.

See the section on the Applications pane in theHP Unified
Functional Testing User Guide.
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Concepts

Considerations - Windows-based SAP Add-in for SAP Solutions

When recording and running tests or business components on SAP GUI forWindows applications,
consider the following:

l Whenworking in tests, the Record and Run Settings dialog box in UFT enables you to specify a
server and client to open at the beginning of every test record and run session. The servers
available in the dialog box are the same as those available in the SAP Logon Pad and SAP
Logon dialog box.

l When you record a business component on an SAP GUI forWindows session, the Record and
Run Settings dialog box is not available. Instead, you need to open the SAP sessionmanually or
include statements in your business component that connect to the SAP server (using the
SAPGuiUtil test object).

l You can also record specific operations in your SAP GUI forWindows Application in Standard
Windows Recordingmode, if required. For details, see "How to Record on StandardWindows
Controls During an SAP GUI forWindows Recording Session" on page 313.

l As you record a test or business component on your SAP GUI forWindows application, UFT
records the operations you perform. UFT works directly with the SAP GUI Scripting API to
record your operations. Therefore, although UFT records a step for each operation you perform,
it adds the steps to your test only when API events are sent to UFT (when information is sent to
the SAP server).

For details on the SAP GUI Scripting API events, see your SAP documentation.

l When you select a test step in UFT, the corresponding object is highlighted in the Active Screen
(unless you chose not to capture Active Screen information when you recorded your test).
However, the values of the object properties stored with the Active Screen are the values of the
properties at the time that the steps were added to the test (when you performed the step that
sent information to the SAP server). These values may potentially be different from the values of
the properties at the time that the selected step was actually performed. For details on Active
Screen capture levels, see the section on the Custom Active Screen Capture Settings Dialog
Box in theHP Unified Functional Testing User Guide.

Checkpoints and Output Values in SAP GUI for Windows

l When inserting a table checkpoint (tests only), consider how other steps performed on the table
may affect the checkpoint.

Example 1: If you have a step in your test that clicks the Total toolbar button on a grid control,
that click refreshes all data in the table. The refresh could potentially cause a table checkpoint
on a cell in the table to fail.
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Example 2: If you click a toolbar button in a grid control that adds rows to your table before
creating a table checkpoint, the extra rows are captured as part of the grid checkpoint (if you
capture all rows). Therefore, confirm that the same rows are displayed during the run session.

l To insert a new table checkpoint while editing your test or business component, the actual table
or grid must be open to the appropriate level or view. This is true even if your Active Screen
(tests only) contains a capture of the table or grid.

l In general, it is not necessary to open the table or grid in the application to edit an existing
checkpoint. However, if you want to modify the row range for the checkpoint, the actual table or
grid must be open to the appropriate level or view.

l When creating a checkpoint on ActiveX grid controls (these generally have toolbars), UFT
captures the data from all columns and all rows in the grid in the table checkpoint. If you do not
need to check data from all rows in your grid, you can specify the rows you want to include in the
checkpoint in the Define Row Range dialog box. You can also increase or decrease the number
of rows included in the checkpoint at a later time.

l TheVisible Rows option in the Define/Modify Row Range Dialog Box is not available for
checkpoints created on grid controls.
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Reference

Package and Patch Versions Requirements - SAP Application
Server and SAP GUI for Windows

To test your application using UFT, youmust confirm that you have the correct support package
and kernel patch levels for your software component release. The following tables show the
minimum required versions and levels. Youmust have these versions and levels or higher:

Software Component Release Support Package Kernel Patch Level

SAP_APPL 31I SAPKH31I96 Kernel 3.1I level 650

SAP_APPL 40B SAPKH40B71 Kernel 4.0B level 903

SAP_APPL 45B SAPKH45B49 Kernel 4.5B level 753

SAP_BASIS 46B SAPKB46B37 Kernel 4.6D level 948

SAP_BASIS 46C SAPKB46C29 Kernel 4.6D level 948

SAP_BASIS 46D SAPKB46D17 Kernel 4.6D level 948

SAP_BASIS 610 SAPKB61012 Kernel 6.10 level 360

For details, see SAP OSS note # 480149.

Troubleshooting and Limitations - Windows-based SAP

This section contains general troubleshooting and limitation information about theWindows-based
SAP add-in, and includes the following sections:

l "Creating and Running Testing Documents" on the next page

l "Working withWindows-based SAP Controls" on the next page

l "Checkpoints, Output Values, and the Object Spy" on page 293

l "Test Objects, Methods, and Properties" on page 294

l "SAP Scripting API" on page 295

l "SAP Scripting API" on page 295

l "SAP Structured Parameters" on page 295
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Creating and Running Testing Documents

l Running a test on HTML elements embedded in an SAP GUI forWindows applicationmay
result in an "Object is disabled" error. This may happen if the HTML control is not ready for the
test run.

Workaround:Add a Sync statement such as SAPGuiSession.Sync or a Wait statement to the
script in order to run the test successfully.

l By default, the recording and running of steps on HTML elements embedded in an SAP GUI for
Windows application is performed using the UFTWeb Add-in. In some cases, steps recorded
using theWeb Add-in are inserted into the script before SAP Add-in steps that use the SAP
Scripting API.

Workaround:Use the option of recording HTML elements embedded in SAP GUI application
using the SAP Scripting Interface. To do so, stop recording, select theRecord HTML elements
using SAPGui Scripting interface check box in the SAP pane of the Options dialog box
(Tools > Options > GUI Testing tab > SAP > General node). Then close and reopen the test
and then begin recording again.

l The SAP Gantt chart (SAP Bar Chart) and Image/Picture controls are supported by the SAP
GUI forWindows alternative recordingmechanism. The current support for these controls is
limited. You can override the default recording behavior for SAPWindows test objects, or add
limited recording support for other SAP GUI forWindows objects.

l If you insert a call to an external action or a copy of an action, and that action includes an
SAPGuiTable.Input, SAPGuiGrid.Input, or SAPGuiAPOGrid.Input statement, the
corresponding input data sheet is not copied to the Data pane with the action.

Workaround: Insert and run Datatable.AddSheet and Datatable.ImportSheet statements to
import the sheet referenced by the action's Inputmethod. Ensure that the name of the data
sheet exactly matches the name specified in the corresponding Input statement.

l In the SAP Enterprise Portal environment, occasional synchronization problems may occur
during the test run when alternating between SAPWeb and SAPWindows environments.

Workaround:Add a WaitProperty or Wait statement between theWeb steps and the
Windows steps.

l UFT can connect to your SAP Logon or SAP Logon Pad application for recording and running
tests on SAP GUI forWindows sessions. If you use both SAP Logon and SAP Logon Pad
processes on your computer, UFT connects to the latest process that was launched.

l Use the SAP Tab of the Record and Run Settings Dialog Box to instruct UFT to open your SAP
GUI forWindows application. Do not use theWindows Applications tab of the dialog box for this
purpose.

Working with Windows-based SAP Controls

l Separate toolbar controls (ones that are not part of a grid or other object) are supported by the
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SapGuiToolbar test object (GuiComponentType is 202), and the Object Spy recognizes them
because they are separate objects.

Note that tree controls do not have associated toolbars. Toolbars displayed on top of tree
controls are recognized as separate toolbars, and are therefore supported as described above.

l Toolbars inside grid controls are supported by the SapGuiToolbar test object
(GuiComponentType is 204). However, the Object Spy does not recognize these toolbars
because they are part of the grid. You cannot add these toolbars to the object repository using
theAdd to repository option from the Active Screen or theAdd Objects option in the Object
Repository window. To add these toolbars to the object repository, record on them.

l Toolbars inside other controls (such as a toolbar within a text area control) are not supported.

l Microsoft Office controls within the SAP window are not supported.

l If you record the step of pressing an F4 key, and that key press results in setting new values for
multiple fields, a step is recorded only for the field from which the F4 key was pressed, and
therefore, only that field will be populated during the run.

l The SAP Editor control is not supported.

l UFT fails to run steps on SAP tree nodes that contain the ";" character.

l UFT does not automatically record standardWindows dialog boxes used by your SAP GUI for
Windows application (such as the Open File and Save As dialog boxes). This is because the
SAP scripting API does not support these dialog boxes. This may also occur when using SAP
GUI forWindows with GuiXT.

Workaround: Do one of the following:

n Change to StandardWindows Recordingmode (select StandardWindows Recording from
theRecording Modes drop-down in the Record toolbar) to record on these objects. (Make
sure that you switch toStandard Windows Recordingmode before you perform the
operation that opens the standardWindows control in your SAP application.)

n Use low-level recording to record on these objects.

n Use programmatic descriptions to run steps on these objects.

Checkpoints, Output Values, and the Object Spy

l To ensure that the correct object properties are captured with your checkpoint, always record a
step that results in communication with the server (such as pressingENTER) before inserting a
checkpoint or output value.

l You cannot use the Object Spy or create checkpoints for the controls listed below. However,
you can successfully record and run steps on them.

Add-ins Guide
Chapter 21: Windows-based SAP Support

HP Unified Functional Testing (12.00) Page 293 of 549



n Toolbar buttons in grid controls.

n Internal controls in tree or table objects.
(For example, a radio button in a table cell or a check box in a tree.)

l Creating checkpoints or using the Object Spy on an object that is located in a currently inactive
SAP screen (for example, if the screen is behind an invoked dialog box) is not supported.
However, you can create checkpoints on status bar messages (displayed in an inactive window)
using theRecord status bar messages option (Tools > Options > GUI Testing tab > SAP
node > Record status bar messages).

l When running old 6.20 tests on a 6.40 client, checkpoints on radio buttons, check boxes, edit
boxes, or regular buttons may fail due to changes to tooltip property values for these objects in
the 6.40 client.

l UFT can estimate the number of rows in a table control, but it cannot retrieve the exact number
because only the table content that is visible on the client is actually available. Data from non-
visible rows are stored only on the back-end server. Therefore, when inserting or modifying
checkpoints for a table control object, the number of rows specified in the Define/Modify Row
Range dialog box may not be accurate.

l Do not perform any operations on the SAP GUI window (such as changing the transaction state
or navigating to another window) while UFT retrieves the data for a table checkpoint even if it
seems to take a long time, as this may cause severe problems.

l When inserting a checkpoint on a table or grid from the Active Screen, the actual table must be
open in your SAP GUI forWindows application to extract the correct information from the table
or grid.

Test Objects, Methods, and Properties

l When using the SAPGuiTableInputmethod, check the scrollingmode of the current table. If you
parameterize a table with a Data pane sheet that contains more rows in the sheet than are
displayed in the table's current view, UFT tries to scroll down the table while running the test, to
insert more rows from the data sheet. UFT supports two ways of scrolling rows in tables—by
pressing theENTER key, or by pressing thePAGEDOWN key. By default, the Add-in for
SAP Solutions tries PAGEDOWN if needed. You can configure the requiredmode using the
second argument of the Inputmethod.

For details, see theHP Unified Functional Testing Add-ins Guide.

l Right-click operations are not supported for the SAPGuiTextArea object.

l Drag-and-drop operations in the SAP Gui forWindows application are disabled when UFT is
open.

Using the Active Screen

l Active Screen images are based on captured screen bitmaps. Therefore, objects that are not
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visible in the SAP GUI forWindows view are not part of the Active Screen image. You cannot
add objects to the script from the Active Screen if they were not in the captured view.

l Drop-downmenus are not captured in the Active Screen. Active Screen technology captures the
data after themenu is closed and themenu item is selected.

l While recording, UFT captures one Active Screen image for several steps. UFT records steps
only when the SAP GUI forWindows client sends information to the SAP back-end server.
When this occurs, all steps that were performed between the previous communication and the
current one are added to the script. The last screen that was sent to the server is captured by the
Active Screen for all steps recorded during that communication.

l When recording onWeb elements inside SAP GUI forWindows applications, HTML images are
not captured.

l Adding objects to the object repository (using theView/Add Object option, or creating
checkpoint or output value steps) from an Active Screen created from a step recorded on aWeb
element inside a SAP GUI forWindows application generates an incorrect object hierarchy in
the object repository.

SAP Scripting API

l For security reasons, the SAP scripting API prevents the recording of passwords. When you
record the operation of inserting a password in a password box, UFT records a Set statement
using asterisks (****) as themethod argument value.

Workaround:Do one of the following:

n Configure and enable theAuto-logon settings in the SAP Tab of the Record and Run
Settings Dialog Box.

n Insert a step using one of the SAPGuiUtil object's AutoLogonmethods.

n Record the password normally during the recording session. After the recording session,
modify the password step to use the SetSecuremethod, and enter the encrypted password
value or parameterize the value.

For details, see theSAP Windows section of theHP UFT Object Model Reference for GUI
Testing(Help > HP Unified Functional Testing Help > Object Model Reference for GUI
Testing > SAP Windows).

SAP Structured Parameters

l When you launch UFT by clicking theEdit Test Script button directly in the SAP Solution
Manager Test Automation:Initial Screen transaction(Transaction Code: stce) or in the SAP
SolutionManager Configuration transaction (Transaction Code :Solar02), clicking theMaintain
SAP Parameter button in UFTmight not return you to the correct page in SAP Solution
Manager.
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Workaround:Use the External Test button in the Change Test Configuration transaction to
launch UFT.

l When you create a test in the Change Test Script transaction of SAP SolutionManager and then
click theBack button, UFT may not show the test.

Workaround:Save and close UFT and click theExternal Test button to call UFT.

l When you click theMaintain SAP Parameter button or theBack/External Test button to
switch from UFT to SAP, youmay receive an error in SAP SolutionManager: OBJECT_OBJREF_
NOT_ASSIGNED.
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Concepts

SAP GUI Scripting API and UFT

UFT works directly with the SAP GUI Scripting API to record your operations. Therefore, UFT adds
steps to your test or business component only when API events are sent to the server. This means
that while recording a test or business component, youmay perform several operations on your
application before the corresponding steps are added. When you perform a step that sends
information to the server, UFT inserts steps with the relevant Windows-based SAP objects in the
Keyword View (tests and business components) and adds corresponding statements in the Editor
(tests only).

Note: The UFT Add-in for SAP Solutions provides an alternative recordingmechanism for
specific SAP GUI forWindows objects that do not have built-in test object support. For details,
see "Low-Level or AnalogMode Recording on SAP GUI forWindows" on page 306.

For details on the test object model, the object repository, and the Object Spy, see theHP Unified
Functional Testing User Guide.

Example 1: Check Boxes
Suppose you record the steps of filling in a Price Simulation for Material form. You select the three
check boxes in the form (Incl. cash discount, Delivery costs, andEffective price) and click
Continue. When you click theContinue button, information is sent to the SAP server, and the
steps in which you select the check boxes and click theContinue button are added to your test at
once. In the Keyword View, the process described above is displayed as follows.

UFT records these steps in the Editor as follows:

SAPGuiSession("Session").SAPGuiWindow("Price Simulation for Material").SAPGuiCheckBox("In
cl. cash discount").Set "ON"
SAPGuiSession("Session").SAPGuiWindow("Price Simulation for Material").SAPGuiCheckBox("De
livery costs").Set "ON"
SAPGuiSession("Session").SAPGuiWindow("Price Simulation for Material").SAPGuiCheckBox("Ef
fective price").Set "ON"
SAPGuiSession("Session").SAPGuiWindow("Price Simulation for Material").SAPGuiCheckBox("Ef
fective price").SetFocus
SAPGuiSession("Session").SAPGuiWindow("Price Simulation for Material").SAPGuiButton("Cont
inue (Enter)").Click
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Example 2: Radio Buttons
Suppose you select a radio button to change the reporting period in theReconcile Plan Versions
transaction of your SAP GUI forWindows application. This radio button is labeledCurrent Year.

UFT uses the SAP GUI business component type (41) to identify the object as a
SAPGuiRadioButton object. It creates a SAPGuiRadioButton test object with the nameCurrent
Year and records the following properties and values as the description for the radio button.

Note: The guicomponenttype and name property values are supplied by the SAP GUI
Scripting API.

UFT also records that you performed aSetmethod to turn ON the radio button.

UFT displays your step in the Keyword View as follows:

UFT displays your step in the Editor like this:

SAPGuiSession("Session").SAPGuiWindow("Reconcile Plan Versions").SAPGuiRadio
Button("Current Year").Set

When you run a test or business component, UFT identifies each object in your application by its
test object class and its description—the set of identification properties and values used to uniquely
identify the object. In the above example, during the run session, UFT looks up the description for
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the SAPGuiRadioButton object with the nameCurrent Yearby searching the object repository.
UFT finds the following description:

guicomponenttype:=41
name:=PCHZTR_Y
attachedtext:=Current Year

UFT then looks in the application for an SAPGuiRadioButton object that matches the above
description. When it finds the object, it performs theSetmethod on it to change the value of the field
to ON (selects the radio button).

Using the Auto-Parameterize Option to Parameterize Table and Grid
Cell Values

Whenworking with tests, UFT records a SetCellData statement, by default, each time you
modify the value of a cell in a table or grid. If you want to modify the values of several cells in a
single table or grid, and then parameterize your test so that different values are entered into the cells
each time your test action runs, you can do this by parameterizing each statement individually, or
by enabling theAuto-parameterize table and grid controls option.

When this option is selected, UFT automatically captures all values you set for a particular table or
grid during a recording session and stores them in a special data sheet in the Data pane. UFT
inserts a single SAPGuiTable.Input, SAPGuiGrid.Input, or SAPGuiAPOGrid.Input statement
into your test, which refers to this new data sheet. Before running the test, you can easily modify
the values or add additional sets of data to the data sheet for each action iteration.

For details, see:

How UFT Records in Auto-ParameterizeMode 300

Parameterized Cell Values in the Input Data Sheet 303

Considerations for Auto-Parameterization 304

Data in Rows that Require Scrolling 305

How UFT Records in Auto-Parameterize Mode

In tests, when you record with theAuto-parameterize table and grid controls option and you
perform an operation that sends data to the SAP server after setting table or grid cell values, UFT:

l Creates a new data sheet to represent the table or grid. Each data sheet is a sub-sheet of the
action in which the table or grid operations were recorded. The data sheet name is always the
action name followed by a period (.) and the internal name of the table or grid. For example:
Action1.FLIGHT_TABLE

l Adds a column to the data sheet for each table or grid column in which you record. (Columns in
which you did not set any cell data are not added to the data sheet.)
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The name of the column in the data sheet is generally the same as the name of the column in
your application.

If a column in the application does not have a header, or more than one column header has the
same name, UFT inserts a columnwith a name in the format: _ _<index>, where <index>
represents the column number according to its location when you record the Input step.

l Inserts the values you set during the recording session into the appropriate cells in the data
sheet. Each row in which you entered data is represented by a row in the data sheet. Place-
holder (empty) rows are added for rows above the rows in which you recorded. For example, if
you set data in rows 2, 4, and 7, seven rows are added to the data sheet. The cells in rows 1, 3,
5, and 6 do not contain any data.

l Inserts an additional end row where the value of the first cell in the row is .END.

l Inserts an Input <DataSheetName> statement (followed by a SelectCell statement) into your
test.

UFT records these steps in the Editor as follows:

SAPGuiSession("Session").SAPGuiWindow("SAP_2").Resize 141,29
SAPGuiSession("Session").SAPGuiWindow("SAP_2").SAPGuiTable("Table control
tc spfli").Input "Action1.Table control tc spfli"
SAPGuiSession("Session").SAPGuiWindow("SAP_2").SAPGuiEdit("Fixed_cols").Se
tFocus
SAPGuiSession("Session").SAPGuiWindow("SAP_2").SendKey ENTER

The Input statement instructs UFT to enter values from the data sheet into the table or grid
corresponding to the data sheet name, similar to an automatically parameterized statement
referring to a special sheet in the Data pane.
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Suppose you update values in a table control containing airline flight information. You update
some airline codes, add state and country names to some of the departure and destination
cities, update one of the destination airport codes, and update some of the departure times. The
edited table in your applicationmay look something like this:

UFT inserts the following Input statement in your test to represent the data input:

SAPGuiSession("Session").SAPGuiWindow("SAP R/3").SAPGuiTable("SPFLI").Inpu
t "Action1.SPFLI"

Note: If you record on a table or grid that scrolls using theENTER key rather than the
PAGEDOWN key, youmay need tomanually add theScrollMethod optional argument.
For details, see "Data in Rows that Require Scrolling" on page 305.
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The corresponding data sheet in your Data pane looks like this:

There are three rows in the data sheet, because data was modified in the first three rows of the
table or grid in the application. Note that the data sheet does not contain columns for theAirfare
andPlane Type columns, because no values weremodified in those columns during the
recording session.

Parameterized Cell Values in the Input Data Sheet

Whenworking in tests, after you record an Input statement to create an input data sheet, you can
modify the values to be used in the run session, and you can createmultiple sets of table or grid cell
data to be used in different iterations of an action.

As described above, when you record the Input statement, UFT records the values you set in the
appropriate rows and columns in the input data sheet for that table or grid. Below the data it adds an
end row (shaded in blue) with the text .END in the first cell of the row. This row indicates the end of
the first set of data for the table or grid. This set of data and its corresponding end row represents a
single data set.

To supply different data values for each action iteration, you add new data sets. You add a new data
set for a table or grid by entering the values in the appropriate rows and columns below the previous
end row. To indicate the end of the new data set, copy and paste the end row from the first set of
data to the row below the new set of data. You can include a different number of rows in each data
set.

Note: The Input statement can run successfully only if it can find the end row. Therefore, the
first cell of the end row must contain only the text .END. You can enter text into other cells in
that row, if needed. For example, you can enter a number in the second cell of the end row to
indicate the iteration number corresponding to that set of data.

Because the input data sheets are added as a sub-sheet of the current action, the Input statement
uses the data set corresponding to the current action iteration. For example, if you set the action to
run on all iterations and your action sheet includes five rows of data, then your input data sheet
should also include five data sets (and five .END rows).
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The input data sheet below contains three sets of data. The first set contains data for the top three
rows of the table or grid. The second set contains data for the top two rows of the table or grid. The
third set contains data for rows 2-5. The blank first row (row 8 in the data sheet), indicates that no
data should be entered or modified in the first row of the table or grid.

Note that a number was manually entered into the second cell of eachEND row tomake it easier to
identify the action iteration to which each data set corresponds.

Considerations for Auto-Parameterization

Consider the following when using theAuto-parameterize table and grid controls option:

l UFT inserts an Input statement and a new input data sheet each time information including
modified table or grid cell data is sent to the server. If you set data in the cells of a particular table
or grid both before and after sending information to the server, you will havemore than one input
data sheet (andmore than one Input statement) representing the same table or grid. For best
results:

n Enter data only in the visible rows of the table or grid while recording, especially if scrolling
results in sending information to the server. You can add additional rows to the recorded data
set while editing your test.

n Perform sorting, calculations, and other such operations either before beginning or after you
finish entering data in a table or grid.
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l The end of each data set in the input table or grid must be indicated by an end row with only the
text .END in the first cell of the row.

l You can enter additional text, such as comments or an iteration number, in other cells of the
.END row.

l You can include a different number of rows in each data set.

If you enter data for rows that require scrolling to display them in your application, youmay need
tomodify your Input statement. For details, see "Data in Rows that Require Scrolling" below.

l When recording, UFT adds a column to the input data sheet only for table or grid columns in
which you set data. You can add additional columns from your table or grid to the data sheet
while editing your test. Double-click the column header in the data sheet to rename it. Enter the
name of your table or grid column. If the table or grid column name has spaces, replace the
spaces with underscores.

l In general, the columns in your data sheet can be in any order, as long as the column names
match the column names in your table or grid. However, if you record data in a columnwithout a
column header name or if more than one column in the table or grid has the same header name,
UFT adds a column to the data sheet in the format: __<index>, where <index> indicates the
number of the column in the table or grid when you record the Input statement, for example, __1
or __2. You can also use this format for columns in the data sheet if the column header names in
your table or grid may change from iteration to iteration.

l To usemultiple sets of data from an input data sheet, youmust have at least one other Data
pane parameter in your action that is set to useCurrent action sheet (local). Also, confirm that
the action is set to runmultiple iterations in the Run Tab of the Action Call Properties Dialog
Box.

l The number of data sets in your input data sheet shouldmatch the number of rows in the
corresponding action data sheet.

If your input data sheet contains fewer data sets than the number of rows in the action sheet, no
data will be inserted in the table or grid during those action iterations. For example, if the action
runs five iterations, and your input data sheet contains only four data sets, during the fifth
iteration no data will be entered into the table or grid when the Input statement runs.

If your data sheet contains more data sets than the number of rows in the action sheet, those
data sets will not be used.

Data in Rows that Require Scrolling

Whenworking in tests, UFT inserts a new Input statement and creates a new input data sheet
each time you send information to the server that includes table or grid cell data. Therefore, if
scrolling results in sending data to the server, it is recommended to add data only to visible cells
during the recording session. If you want to enter data into additional rows during the run session,
you can add those rows to the data sheet manually while editing your test.
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If you create an input data set for rows that are not visible on the table or grid in your application,
then UFTmust scroll the table or grid during the run session to insert the data for those rows. If you
create an input data set for a row that needs to be added to the table or grid, UFT must send a
command to add the row. By default, UFT sends a PageDown command if the rows in the data sheet
exceed those currently displayed in the application. If UFT needs to use theENTER key to add
additional rows to the table or grid, then you need tomanually add the optional ScrollMethod
argument (with the value ENTER) to your Input statement before running your test.

For example:

SAPGuiSession("Session").SAPGuiWindow("Create Standard").SAPGuiTable("SAPMV4
5ATCRTL_V_ERF_").Input "Action1.All items", ENTER

Low-Level or Analog Mode Recording on SAP GUI for Windows

Whenworking in tests, if you are unable to record steps on an object in the normal recordingmode,
or if you want to recordmouse clicks and keyboard input with the exact x- and y-coordinates, you
can record steps on those objects using low-level or analog recording (select Low-Level
Recording or Analog Recording from theRecording Mode drop-down in the Record toolbar
during a recording session).

When recording in one of thesemodes, your steps are added to your test (or to the analog file) as
you record them rather than when information is sent to the server. If you begin recording in low-
level or analogmode, do not switch back to the normal recordingmode until you perform a step that
results in communication with the SAP server. Switching between one of thesemodes and the
normal recordingmode before the server communication, may result in your steps being recorded
twice (once in low-level/analogmode and once in normal mode).

For details on low-level and analog recording, see theHP Unified Functional Testing User Guide.

Spooling Data from a Table

If you want to spool all the data from an SAP GUI forWindows table into an external file, use the
GetCellDatamethod to loop through each cell in the table. You can then save the information to an
external file.

The following example uses theGetCellDatamethod to list the data of each cell in a table of 10
rows and 10 columns:

For i=1 to 10
for j=1 to 10

col="#" & j
Dat=SAPGuiSession("Session").SAPGuiWindow("Create Standard").SAPGuiTable("S

APMV45ATCTRL_U_ERF_").GetCellData (i, col)
‘Enter lines of code that use the value of the returned Dat variable

next
next
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For details on theGetCellDatamethod, see theSAP GUI for Windows section of theHP UFT
Object Model Reference for GUI Testing.
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Tasks

How to Enable Support for SAP GUI for Windows

This task describes how to enable SAP GUI forWindows to work with UFT.

1. Prerequisite: Make sure that SAP GUI Scripting is installed
When you install your SAP GUI forWindows application, youmust select theSAP GUI
Scripting installation option. If you did not select this option when you installed the SAP GUI
forWindows application, it is essential that you reinstall it and select this option before setting
the other configuration options described in this chapter.

Note: SAP provides a range of security mechanisms that enable the administrator to limit
the use of SAP GUI Scripting by system, by group, by user, and by scripting functionality.
To test SAP GUI forWindows applications, youmust ensure that these security
mechanisms are not activated. For details on the various security options, see the online
SAP GUI Scripting Security Guide at the SAP ServiceMarketplace.

2. Enable scripting on the SAP application (server-side)
a. Confirm that you have the proper support package and kernel patch levels installed. For

details, see "Package and Patch Versions Requirements - SAP Application Server and
SAP GUI forWindows" on page 291.

b. Enable scripting on your SAP application. (By default, scripting is disabled.) You do this by
entering theMaintain Profile Parameters window with administrative permissions and
setting the sapgui/user_scripting profile parameter to TRUE on the application server.

o To enable scripting for all users, set this parameter on all application servers.

o To enable scripting for a specific group of users, set the parameter only on application
servers with the appropriate access restriction settings.

For more details, see "How to Enable Scripting on the SAP Application (Server-Side)" on
the next page.

Note: If you connect to a server on which scripting is disabled, an error message
displays when you try to record on your SAP GUI forWindows application.

3. Enable scripting on the SAP application (client-side)
You can do this on your SAP client only if theSAP GUI Scripting option is installed. If this
option is not installed, reinstall your SAP GUI forWindows application and be sure to select the
SAP GUI Scripting check box. For details, see your SAP GUI forWindows documentation.
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4. Eliminate warning messages
By default, you regularly receive two warningmessages when using UFT with an SAP GUI for
Windows application:

n WhenUFT connects to the Scripting API, the following warningmessage is displayed: A
script is trying to attach to the GUI.

n WhenUFT opens a new connection using the Scripting API, the following warningmessage
is displayed: A script is opening a connection to system <system_name>.

It is recommended to disable these warningmessages in the SAP GUI forWindows
application when working with UFT.

5. Check the connection speed on the SAP server
Confirm that the Low speed connection option is NOT selected for the server to which you
are connecting before recording and running GUI tests.

This is because when you log on to SAP using the Low speed connection option to
communicate with the server, the SAP server does not send sufficient information for UFT to
properly record and run tests. (UFT displays an error message if the Low speed connection
option is selected.)

For details, see SAP OSS note #587202.

6. Set F1 Help to use the modal dialog box mode
Confirm that themodal dialog box option is selected. This enables UFT to record the display of
F1Help in your tests. (The F1Help in your SAP GUI forWindows application can be displayed
using either the Performance Assistant or as amodal dialog box.)

7. Set F4 Help to use the dialog display mode
Confirm that your client is set to load F4Help screens in Dialogmode. (The SAP GUI for
Windows application cannot load F4Help screens in Control mode when using the SAP GUI
Scripting API (Enable Scripting option.)

Note: This is a per-user setting. Youmust set this option on each client that you want to
test using the UFT Add-in for SAP Solutions. Alternatively, the SAP system administrator
can change the system default for you.

How to Enable Scripting on the SAP Application (Server-Side)

UFT records and runs steps based directly on the API events that are sent from the client to the
SAP server because UFT communicates directly with the SAP GUI Scripting API. Therefore, to
record and run tests and business components on your SAP GUI forWindows application, you
must enable scripting on both the server and client computers.
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After you confirm that you have the proper support package and kernel patch levels installed, you
must enable scripting on your SAP application. By default, scripting is disabled.

You enable scripting by entering theMaintain Profile Parameters window with administrative
permissions and setting the sapgui/user_scripting profile parameter to TRUE on the application
server.

To enable scripting for all users, set this parameter on all application servers. To enable scripting for
a specific group of users, set the parameter only on application servers with the appropriate access
restriction settings.

Note: If you connect to a server on which scripting is disabled, an error message displays
when you try to record on your SAP GUI forWindows application.

To change the profile parameter:

1. Enter /nrz11 in theOKCode edit box to open transaction rz11.

2. In theParam. Name box of theMaintain Profile Parameters window, enter sapgui/user_
scripting and click theDisplay button.
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Note: If themessageParameter name is unknown is displayed in the status bar, your
client lacks the required support package (see "Package and Patch Versions
Requirements - SAP Application Server and SAP GUI forWindows" on page 291).
Download and install the support package that corresponds to the SAP release you are
using and then begin this task again.

The Display Profile Parameter Attributes window opens.
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3. If ProfileVal is FALSE, youmust modify its value. Tomodify it, click theChange value button.
The Change Parameter Value window opens.

4. Enter TRUE (in capital letters) in theNew value box and click Save .

Note: The change takes effect only when you log on to the system. Therefore, before
beginning to work with UFT, youmust log off and log on again. Youmay also need to
restart the SAP Service from the SAP Console.

If you find that even after restarting the SAP Service from the SAP Console and logging on
again to the client, your change to theProfileVal parameter was not saved, youmay have an
outdated kernel version. In this case, either restart the application server, or download and
import the required kernel patch, as specified below.

Release Kernel Version Patch Level

6.10 6.10 391

6.20 all versions all levels

6.40 all versions all levels

7.10 all versions all levels

For details, see SAP OSS note # 480149.
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How to Record on Standard Windows Controls During an SAP GUI
for Windows Recording Session

To enable UFT to record steps on standardWindows controls during an SAP GUI forWindows
recording session, youmust switch toStandard Windows Recordingmode prior to performing
steps on these controls. (If you switch toStandard Windows Recording mode after performing
an operation on a standardWindows control, both UFT and the SAP applicationmay sometimes
become unresponsive.)

This task describes how to toggle between the relevant recording options.

To switch to Standard Windows recording mode while recording a test in an SAP GUI for
Windows application:

On the Record toolbar, select Standard Windows Recording from theRecording Modes drop-
down, or press ALT+SHIFT+F3.

To record steps as SAP GUI for Windows objects again:

Do one of the following:

l On the Record toolbar, select Default from theRecording Modes drop-down.

l Stop the recording session.

This restores the normal recordingmode for SAP GUI forWindows.

Add-ins Guide
Chapter 21: Windows-based SAP Support

HP Unified Functional Testing (12.00) Page 313 of 549



Reference

SAP Tab (Record and Run Settings Dialog Box)

This dialog box enables you to specify how UFT connects to your SAP GUI forWindows
application during a recording or run session.

To
access

Select Record > Record and Run Settings and choose theSAP tab.

Note: The Record and Run Settings dialog box also opens automatically each
time you begin recording a new test (unless you open the dialog box and set your
preferences manually before you begin recording).
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See
also

l You can also use application details environment variables to specify these
parameters. For details, see "Environment Variables forWindows-based SAP
Applications" on page 317.

l "SAP GUI Scripting API and UFT" on page 298.

l "Using the Auto-Parameterize Option to Parameterize Table andGrid Cell Values"
on page 300.

l "Low-Level or AnalogMode Recording on SAP GUI forWindows" on page 306.

l "How to Record on StandardWindows Controls During an SAP GUI forWindows
Recording Session" on page 313.

l "SAP > General Pane (Options Dialog Box > GUI Testing Tab) " on page 318.

User interface elements are described below:

UI Elements Description

Record and run
tests on any
open SAP GUI
for Windows
application

Instructs UFT to use any open SAP GUI forWindows application to record
and run the test.

This option supports sessions opened using the SAP Logon dialog box or the
SAP Logon Pad.

Open the
following SAP
Gui client when
a record or run
session begins

Instructs UFT to connect to the specified SAP server and open your SAP
GUI forWindows application using specified user settings.

Note: If you select to connect to a specific server, you can specify
details that will enable UFT to automatically log on to the server each
time a record or run session begins (instead of recording the logon
steps).

Server
description

Indicates the server to which you want to connect. TheServer description
box lists the servers available in the SAP Logon Pad or the SAP Logon dialog
box.

To add a server to the list in the Record and Run Settings dialog box, close
the Record and Run Settings dialog box, define an appropriate entry using
your SAP Logon dialog box, and then reopen the Record and Run Settings
dialog box.

Note: The values you enter for theUser, Client, Password, and
Language in theAuto-logon area of the dialog box are saved with the
selected server (in addition to being saved with the test). Therefore, the
saved values are automatically displayed in the auto-logon area when
you specify a previously selected server.
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UI Elements Description

System data
container

Specifies the system data container that contains the available target
systems for the current test.

Enabled only if you open aGUI test from SolutionManager in integrated
mode.

Target system A drop-down list of available SAP environments that can be tested.

Enabled only if theSystem data container option is selected.

Enable auto-
logon

Instructs UFT to open the specified SAP GUI forWindows application using
the specified logon details.

Enabled only whenOpen the following SAP Gui client when a record or
run session begins is selected.

User The user name used to log on to the specified server.

Enabled only whenEnable auto-logon is selected.

Password The password for the specified user name.

Enabled only whenEnable auto-logon is selected.

Client The client number.

Enabled only whenEnable auto-logon is selected.

Language The language that you want the specified SAP GUI forWindows application
to display.

Enabled only whenEnable auto-logon is selected.

Remember
password

Saves the password information in this dialog box so that you do not have to
enter it each time you begin to record or run the test.

Enabled only whenEnable auto-logon is selected.

Close the SAP
GUI for
Windows
application
when the test is
closed

Instructs UFT to close the SAP GUI forWindows session specified in the
Record and Run Settings dialog box when the test is closed.

Any other SAP GUI forWindows session that was opened before, during, or
after the run session is not affected.

TheSession cleanup option in the SAP pane of the Options dialog box
(Tools > Options > GUI Testing tab > SAP node) overrides this option. For
details, see "SAP > General Pane (Options Dialog Box > GUI Testing Tab) "
on page 318.
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UI Elements Description

Do not record
and run on
sessions that
are already
open

Instructs UFT not to record or run tests on any SAP GUI forWindows
sessions that were already open prior to the start of the record or run session.
This is to ensure that steps are not inadvertently recorded on other SAP GUI
forWindows sessions that may also be running on the same computer.

Wait for Web
pages to load
before running
steps

Instructs UFT to wait forWeb-based SAP pages to synchronize completely
before starting the test run.

Note: This option is selected by default. Clear this option only when
working with IC WebClient.

Environment Variables for Windows-based SAP Applications

You can use environment variables to specify details for the applications you want to use during a
recording or run session. These variables can also be used in external library files for automation
scripts.

If you define any of these environment variables, they override the values in theServer
description, User, Password, Client, and Language boxes in the "SAP Tab (Record and Run
Settings Dialog Box)" (described on page 314).

Use the variable names listed in the table below to define SAP application details:

Option
Variable
Name Description

Server
description

SAP_SERVER_
ENV

The description of the server to which you want to connect.

User SAP_
USERNAME_
ENV

The user name used to log on to the specified client number.

Password SAP_
PASSWORD_
ENV

The encrypted password for the specified user name.

Client SAP_CLIENT_
ENV

The client number.

Language SAP_
LANGUAGE_
ENV

The language that you want the specified SAP GUI for
Windows application to display.

For details on defining and working with environment variables, see theHP Unified Functional
Testing User Guide.
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SAP > General Pane (Options Dialog Box > GUI Testing Tab)

This pane enables you to configure how UFT records and runs tests and business components on
SAP applications.

To access 1. Do one of the following:

n Ensure that a GUI test, action, or component is in focus in the
document pane.

n In the Solution Explorer, select a GUI test or component node or one of
its child nodes.

2. Select Tools > Options > GUI Testing tab > SAP > General node.

Important
information

l This pane is available only when the UFT Add-in for SAP Solutions is
installed and loaded.

l TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.
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See also l "SAP GUI Scripting API and UFT" on page 298.

l "Using the Auto-Parameterize Option to Parameterize Table andGrid Cell
Values" on page 300.

l "How to Record on StandardWindows Controls During an SAP GUI for
Windows Recording Session" on page 313.

l "Environment Variables forWindows-based SAP Applications" on page
317/

l "SAP Tab (Record and Run Settings Dialog Box)" on page 314.

User interface elements are described below:

UI Elements Description

Auto-
parameterize
table and
grid controls

While recording tests, automatically captures the data you set in table and grid
cells and stores it in a new data sheet in the Data pane. UFT inserts an Input
statement into your test, which refers to the new data sheet. Using this option
enables you to set values of multiple cells in a single test step and easily
parameterize the cell values. For details, see "Using the Auto-Parameterize
Option to Parameterize Table andGrid Cell Values" on page 300.

Record
HTML
elements
using
SAPGui
Scripting
interface

Specifies whether UFT should use the SAP GUI Scripting API when recording
HTML elements within SAP applications, or use the built-inWeb support to
record these HTML elements. You can use this option to handle synchronization
issues that may arise from recording onWeb elements inside an SAP GUI for
Windows session.

Changes to this option take effect only after you start recording a new test or
business component.

Record
Reset
Method on
SAP Gui
Session

Records aResetmethod as the first step when recording a test or business
component. When the test or business component is run, the first step resets
the application session so that it starts at the initial SAP screen. This ensures
that the test or business component starts with the same application state each
time it is run.

This option is applicable only if theOpen the following SAP Gui client when
a record or run session begins and theAuto-logon options are both selected
in the "SAP Tab (Record and Run Settings Dialog Box)" (described on page 314.

Record
status bar
messages

Records a SAPGuiStatusbar.Sync step each time a status bar message is
displayed in the SAP application.

Note: This option is selected by default.
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UI Elements Description

Show
'Disabled
Scripting
Interface'
warnings

Instructs UFT to display warnings if the SAP GUI Scripting API is disabled on
the SAP application. If this is the case, you cannot record or run steps until you
enable the SAP GUI Scripting API. For details on enabling the SAP GUI
Scripting API, see "How to Enable Support for SAP GUI forWindows" on page
308.

Note: This option is selected by default.

Show 'Low
Speed
Connection'
Warnings

Instructs UFT to display warnings if the connection speed to the server is set to
Low speed connection.

If this option is selected, one of the following occurs if the connection speed is
low:

l If the session was opened by UFT when recording started (as defined in the
Record and Run Settings dialog box), the error message appears and the
recording stops.

l If the session was opened by the user before recording started, the error
message appears and recording continues in StandardWindows recording
mode. For details on StandardWindows recordingmode, see "How to
Record on StandardWindows Controls During an SAP GUI forWindows
Recording Session" on page 313.

If this option is not selected, one of the following occurs if the connection speed
is low:

l If the session was opened by UFT when recording started (as defined in the
Record and Run Settings dialog box), the error message does not appear and
the recording stops.

l If the session was opened by the user before recording was begun, the error
message does not appear and recording continues in StandardWindows
recordingmode. For details on StandardWindows recordingmode, see "How
to Record on StandardWindows Controls During an SAP GUI forWindows
Recording Session" on page 313.

The connection speed can be checked using the SAP client. For details, see
"Check the connection speed on the SAP server" on page 309.

Note: This option is selected by default.
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UI Elements Description

Record only
the selected
value when
using a
Possible
Entries (F4)
list

Specifies that only the selected value is recorded when using a Possible Entries
list. Any other actions performed on any windows opened after pressing F4 (or
after clicking the icon in the specific field) are ignored, and only the actual
changemade to the field is recorded.

Note: An event is received only on the field in focus when F4was pressed,
and not on all the populated fields in the screen. For this reason it may be
preferable not to select this option when recording.

Session
cleanup

Instructs UFT to close all SAP GUI forWindows sessions opened by UFT
during the current run session when the test is closed. This includes all SAP GUI
forWindows sessions that were invoked from the Record and Run Settings
dialog box, as well as any sessions that may have been invoked during the run
session using a SAPGuiUtil statement or theOpen New Session button in the
SAP GUI forWindows application that was being recorded.

SAP GUI forWindows sessions that were opened during a previous run session,
or openedmanually before or during the current run session are not affected.

This option overrides theClose the SAP GUI for Windows application when
the test is closed option in the "SAP Tab (Record and Run Settings Dialog Box)
" (described on page 314.
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Concepts

UFT-SAP Solution Manager Integration - Overview

Note: Unless otherwise specified, references to SolutionManager in this Help file apply to all
currently supported versions of SAP eCATT (SAP Extended Computer Aided Test Tool) and
SAP SolutionManager. Note that some features and options may not be supported in the
specific edition of SolutionManager or eCATT that you are using.

For a list of the supported versions of SolutionManager or eCATT, see theHP Unified
Functional Testing Product Availability Matrix, available from the UFT Help or the root folder of
the Unified Functional Testing DVD.

In addition to ALM, HP's Web-based test management tool, you can also store andmanageGUI
tests in SAP SolutionManager.

UFT Add-in for SAP Solutions integrates with SAP SolutionManager. This means that you can use
SolutionManager with UFT to run quality tests in environments that span beyondWindows and
SAP environments including complex, multi-platform, highly-integrated composite, legacy, and
proprietary enterprise applications.

Note: UFT cannot connect to both SolutionManager and ALM in the same session. Therefore,
you cannot use SolutionManager to manage business components and application areas.

You can work with GUI tests stored in SolutionManager in standalone or integratedmode. The
current mode is indicated in the UFT title bar.

l "Standalone Mode" (described on page 325). The test is opened from UFT.

l "Integrated Mode" (described on page325). The test is opened from SolutionManager.

SolutionManager support is available only when:

l SAP Frontend software is installed on your computer (including support for Unicode).

l SAP GUI for Windows software installed on your computer, including support for RFC
libraries. You add support for RFC libraries by selecting theUnicode RFC Libraries check box
(underDevelopment Tools) during the SAP installation.

l TheUFT Add-in for SAP Solutions is installed and loaded. For details, see "How toManage
UFT Add-ins" on page 32.

l Solution Manager integration components are installed.
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Test Management in SAP Solution Manager

You can store andmanageGUI tests for your SAP application in the file system or in a test
management tool, such as HP ALM or SAP SolutionManager, depending on your testing needs.

To work with SAP SolutionManager, youmust configure your SolutionManager server to work with
UFT. After the server is configured, you can connect to SolutionManager from UFT in standalone
mode, or you can connect to UFT from SolutionManager in integratedmode. For details, see "How
to Configure SolutionManager toWork with UFT" on page 327.

You can create tests from UFT or from SolutionManager, store tests and associated resource files
in the SolutionManager database, edit tests, run tests, and review run results. For details see,
"How to Open and Save Tests in SolutionManager in StandaloneMode" on page 330.

You can also call and pass values from a SolutionManager test script to a GUI test. For details,
see "How to Transfer Data To and From GUI Tests in IntegratedMode Using Test Parameters" on
page 339.

For details on performing basic SolutionManager test management operations, see:

l "How to Configure SolutionManager toWork with UFT" on page 327

l "How to Open and Save Tests in SolutionManager in StandaloneMode" on page 330

l "How to Upload Files to SolutionManager in StandaloneMode" on page 332

l "How to Run a Test Stored in SolutionManager in StandaloneMode" on page 335

l "How to Run a Test Stored in SolutionManager in IntegratedMode" on page 336

l "How to Display or Edit a GUI Test from SolutionManager in IntegratedMode" on page 337

l "How to Transfer Data To and From GUI Tests in IntegratedMode Using Test Parameters" on
page 339

Resource Files in Solution Manager

When you save aGUI test in SolutionManager, make sure you store all associated resource files in
SolutionManager so that any user who opens the test from SolutionManager will have access to all
of the test's resource files.

Like test names, all test resource files stored in SolutionManager must begin with a valid prefix
according to the server settings. For example, if your SolutionManager server requires all file
names to begin with z, you would use the following naming convention: z<filename> (for example:
zSOR_dwdm). You can set the default prefix for files in the SolutionManager pane of the Options
dialog box. For details, see "SAP > SAP SolutionManager Pane (Options Dialog Box > GUI
Testing Tab)" on page 353.

When you create a file in UFT, such as a new shared object repository or recovery file, you can
create the file as you normally would in UFT and then save the file directly to SolutionManager.
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You can also upload existing files that are stored in the file system (such as external data table
files, function library files, shared object repository files, recovery files, and environment variable
files).

For details on uploading resource files to SolutionManager, see "How to Upload Files to Solution
Manager in StandaloneMode" on page 332.

Standalone Mode

You can connect to SolutionManager from UFT. This is known as standalone mode. After you
connect to SolutionManager in standalonemode, you can:

l Store tests in the SolutionManager database.

l Open existing tests from the SolutionManager database.

l Upload files to or download files from SolutionManager.

l Store a test's external resource files in SolutionManager. For example, you can store shared
object repository files, data table files, function library files, environment variable files, and
recovery files in your SolutionManager database. UFT provides a special set of Solution
Manager-specific options that enable you to control certain elements of the SolutionManager-
UFT integration.

l Pass values from a SolutionManager test script to a GUI test, or vice versa, using GUI test
parameters. For example, if you want to create tests or actions that you can use for different
purposes or in different scenarios based on the data supplied to them, you can take advantage of
theAutomatically parameterize steps using Test Parameters option (in theGeneral node of
the GUI Testing tab in the Options dialog box (Tools > Options > GUI Testing tab > General
node)). This option instructs UFT to automatically parameterize all the operation arguments in
the steps of one or more actions in your test, at the end of a UFT recording session. You can
then supply the values for these test parameters from SolutionManager. For more details on
parameters, see theHP Unified Functional Testing User Guide.

Note:

You can also perform many of these operations from SolutionManager in integratedmode. For
details, see "IntegratedMode" below. For a comparison of SolutionManager testingmodes,
see "SolutionManager TestingModes: Standalone or Integrated" on page 344.

You can also download resource files already stored in SolutionManager and save them in the
file system.

Integrated Mode

You can connect to UFT from SolutionManager. This is called integrated mode. When you work
in integratedmode, only UFT features related to the SolutionManager test are available in UFT.
When you run tests in integratedmode, your run session results are accessible in the Solution
Manager log.
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When you log on to a SolutionManager server that is configured to integrate with UFT, you can
view, edit, and runGUI tests that are stored in SolutionManager. You can also use the standard
SolutionManager commands to copy, rename, and delete GUI tests, just as you would with any
other file stored in SolutionManager.

When you open aGUI test from SolutionManager, UFT opens in integratedmode. In this mode,
you can use all UFT features that are associated with the open test. However, you cannot save the
open test with another name.

You can run a test in integratedmode by using theRun option in UFT or using theExecute Test
Script (F8) option for a selected GUI test in SolutionManager. You can also execute a Solution
Manager test script (or blob—Binary LargeObject) that calls a GUI test. Creating SolutionManager
scripts that call GUI tests is useful if you want to pass or retrieve values to or from aGUI test.

For details on configuring SolutionManager to work with UFT, see "How to Configure Solution
Manager toWork with UFT" on the next page.

Note: You can also work with tests stored in SolutionManager from the UFT interface in
standalonemode. For details, see "StandaloneMode" on the previous page. For a comparison
of SolutionManager testingmodes, see "SolutionManager TestingModes: Standalone or
Integrated" on page 344.

SAP Structured Parameters

When you work in integratedmode with SAP SolutionManager, you can use structure-type test
parameters to pass complex values such as XML values or arrays from a SolutionManager test
script to a GUI test, or vice versa,

You create andmaintain the structured parameters in SAP SolutionManager. Then you canmap
action parameters to the structured parameters in your test. When you run your test, UFT receives
parameter values from SAP SolutionManager; and resolves themapped local parameter with the
actual value from SAP SolutionManager.

For more details, see "How toWork with SAP Structured Parameters" on page 339.

Add-ins Guide
Chapter 21: Windows-based SAP Support

HP Unified Functional Testing (12.00) Page 326 of 549



Tasks

How to Configure Solution Manager to Work with UFT

This task describes how to configure SolutionManager to work with UFT so that you can use the
SolutionManager-UFT integration features available with the UFT Add-in for SAP Solutions.

This task includes the following steps:

l "Prerequisites" below

l "Set external tool parameters in the ECCUST_ET table" below

l "Apply necessary roles or profiles to SolutionManager-UFT Users" on the next page

l "Register UFT to work with SolutionManager" on the next page

Prerequisites
You (or a SolutionManager system administrator) must install the appropriate support package and
configure the SolutionManager server to work with UFT.

Set external tool parameters in the ECCUST_ET table
This step enables SolutionManager to communicate with UFT. (You perform this procedure only
once in the system.)

1. Navigate to transaction se17. TheGeneral Table Display window opens.

2. In the Table Name box, enter ECCUST_ET and press ENTER.

3. The Display Table ECCUST_ET window opens and displays an empty table with the required
parameter names.

4. Enter the values exactly as shown below:
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Note: You can also use the functionmoduleSET_EXTERNAL_TOOL to create entries in
the customizing table. For details, see your SolutionManager documentation.

Apply necessary roles or profiles to Solution Manager-UFT Users

1. Make sure you have permission to:

n Run SolutionManager scripts

n Edit SolutionManager scripts

n Work with an external tool (UFT) in integratedmode

n Connect to SolutionManager from an external tool (UFT) in standalonemode

2. Confirm with your system administrator that the user name you use is assigned the necessary
roles or profiles to perform the above tasks before you begin working with the UFT-Solution
Manager integration. For example, to work with UFT in standalonemode, youmust be
assigned the roleS_ECET or the profileSAP_ECET in the SolutionManager system. This is
because each of these tasks requires special roles or profiles.

For details, contact your system administrator or see your SAP and SolutionManager
documentation.

Register UFT to work with Solution Manager
To enable UFT to communicate with SolutionManager, youmust register UFT and then verify the
registration. You perform this procedure only once in the system.

1. Navigate to transaction SPRO, click SAP Reference IMG, and browse toSAP Solution
Manager > Capabilities (Optional) > Test Management > External Integration > External
Test Tool with eCATT > Register Test Tool.

2. Click New Entries.
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3. Enter the values exactly as shown below:

4. Navigate to transaction SM30, and enterV_AGS_SMT_TCT, as shown in the example below.

5. Click Display and verify that a row exists with the following information:

UFT is now registered to work with your SAP application.
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How to Open and Save Tests in Solution Manager in Standalone
Mode

This task describes how to:

l "Save a test in standalonemode" below

l "Open a test from SolutionManager in standalonemode" on the next page

Note: You can also open, edit, and save existing tests that are stored in SolutionManager,
and you can save existing tests with a new name in the SolutionManager database or in the
file system.

Save a test in standalone mode

1. In UFT, create or open a test.

2. From UFT, connect to a SolutionManager server. UFT connects to SolutionManager in
standalonemode. For user interface details, see "SolutionManager Connection Dialog Box" on
page 345.

3. In UFT, select File > Save As. The SaveGUI Test to SolutionManager dialog box opens.

Note: If you defined a New test prefix in the SAP SolutionManager pane of the Options
dialog box, the dialog box displays the defined prefix.
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4. Do one of the following

n To save a test directory to the file system, click File System.. The Save Test dialog box
opens. For user interface details, see theHP Unified Functional Testing User Guide.

n To save the test to SolutionManager, enter the required information and click OK. For
details on the user interface, see "SaveGUI Test to SolutionManager Dialog Box" on page
347. When the save process finishes, the status bar displays the wordReady, and the test
is saved to the local package ($TMP) in SolutionManager. When the save process is
complete, the UFT title bar displays the test information in the following format:

[Solution Manager] TestName: Version Number (Mode)

Open a test from Solution Manager in standalone mode

1. Connect to a SolutionManager server. For details, see "SolutionManager Connection Dialog
Box" on page 345.

2. In UFT, select File > Open > Test to open the test. The "OpenGUI Test from Solution
Manager Dialog Box" on page 348 (described on page 348) opens.

Note: TheOpenGUI Test from SolutionManager dialog box opens when UFT is
connected to a SolutionManager server. To open a test directly from the file system while
you are connected to SolutionManager, click the File System button to open theOpen
Test dialog box.

3. Enter the required information and click OK. For details on the user interface, see "OpenGUI
Test from SolutionManager Dialog Box" on page 348.

When the test opens, the UFT title bar displays the test information in the following format:

[Solution Manager] TestName: VersionNumber (Mode)
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How to Upload Files to Solution Manager in Standalone Mode

This task describes how to upload files to SolutionManager. When you upload a file to Solution
Manager in standalonemode, it is automatically saved to the local package ($TMP) in Solution
Manager.

This task describes how to:

l "Upload external resource files from the file system to SolutionManager" below

l "Create a new shared object repository file and store it in SolutionManager" on the next page

l "Copy or export an object repository to SolutionManager" on the next page

l "Create a new recovery file in SolutionManager" on page 334

Upload external resource files from the file system to Solution Manager

1. Create and save the resource file in the file system.

2. Connect to SolutionManager. For details, see "SolutionManager Connection Dialog Box" on
page 345.

3. Select File > Upload File to Solution Manager option. The "Upload File to SolutionManager
Dialog Box" (described on page 349) opens.

4. Browse or enter the file path of the Local file you want to upload.

5. Specify theSolution name andVersion number you want to assign to the uploaded file.

6. Associate the uploaded file with your test in the appropriate UFT dialog box. For more details
on associating Data pane files, library files, environment variable files, and shared object
repositories with your test, see theHP Unified Functional Testing User Guide.
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Create a new shared object repository file and store it in Solution Manager

1. Open a blank test.

2. Select Resources > Object Repository Manager and add test objects as needed.

3. Select File > Save. The "Save External File to SolutionManager Dialog Box" (described on
page 350) opens.

4. In the File name field, enter the name you want to use for the shared object repository
according to the naming conventions of the SolutionManager server. For example, if your
SolutionManager server requires all file names to begin with z, save the file in the following
format: z<filename>. For example: zSOR_dwdm

5. In the File version field, enter the version number you want to use for the shared object
repository.

6. If a warningmessage opens, click Yes to create the new object repository file in Solution
Manager.

For more details on creating object repository files, see theHP Unified Functional Testing User
Guide.

Copy or export an object repository to Solution Manager

1. Open the test whose object repository you want to copy or export.

Note: If you are exporting objects from a local object repository:

n Youmust select the action whose object repository you want to export.

n The object repository namemust contain at least 14 characters.

2. Select one of the following:

n Resources > Object Repository Manager to open the sharedObject Repository
Manager.
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n Resources > Object Repository to open the local Object Repository for the selected
action.

3. Do one of the following:

n In the sharedObject Repository Manager, select File > Save As to save a copy of the
object repository file with a new name in SolutionManager.

n In the Object Repository Window, select File > Export Local Objects to export the object
repository to a shared object repository file in SolutionManager.

The "Save External File to SolutionManager Dialog Box" (described on page 350) opens.

4. Enter the required information and click OK. For details on the user interface, see "Save
External File to SolutionManager Dialog Box" on page 350.

For details on exporting and saving object repository files, see theHP Unified Functional
Testing User Guide.

Create a new recovery file in Solution Manager

1. Select Resources > Recovery Scenario Manager. The Recovery Scenario Manager opens.

2. Click the New Scenario button. The Recovery ScenarioWizard opens. Follow the
instructions in the wizard to create a new scenario. When you are finished, the scenario is
displayed in the Recovery Scenario Manager

To addmore scenarios to the new scenario file, repeat this step.
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When you are ready to save the scenario file, click Save. The "Save External File to Solution
Manager Dialog Box" (described on page 350) opens.

3. Enter the required information and click OK. For details on the user interface, see "Save
External File to SolutionManager Dialog Box" on page 350.

For details on creating and saving recovery files, see theHP Unified Functional Testing User
Guide.

How to Run a Test Stored in Solution Manager in Standalone Mode

This task describes how to run tests from UFT (standalonemode). The run results are stored in the
location you specify in the file system. You cannot access these results from SolutionManager.

When working with UFT in standalonemode, you run a test stored in a SolutionManager database
just like any other UFT test.

To run a test stored in Solution Manager in standalone mode:

1. Open UFT in standalonemode. For details, see "SolutionManager Connection Dialog Box" on
page 345.

2. In UFT, open the test you want to run. For user interface details, see "OpenGUI Test from
SolutionManager Dialog Box" on page 348.

3. Click theRun button or select Run > Run. The Run Dialog Box opens.

4. Accept the default results folder or browse to select another one.

Note:

n The default results folder is created under the folder where the cache (local) copy of
your test is stored. You set the location of yourSolution Manager test cache folder in
theSolution Manager pane of the Options dialog box.

n When running tests in standalonemode, no SolutionManager log is created. For details
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on the SolutionManager log for UFT run sessions, see "View results of a GUI test run
in integratedmode" on the next page.

n To run the test and overwrite the previous run session results, select the Temporary
run results folder (overwriting older temporary results) option.

n UFT stores temporary run session results for all tests in <System
Drive>:\%Temp%\TempResults. The path in the text box of the Temporary run
results folder (overwriting older temporary results) option is read-only and cannot
be changed.

5. Click OK. The Run dialog box closes and UFT begins running the test.

When the run session ends, the Run Results window opens (unless theView results when
run session ends check box is cleared in theRun Sessions pane of the Options dialog box
(Tools > Options > GUI Testing tab > General tab > Run Sessions node). For more details
on running UFT tests and analyzing run results, see theHP RunResults Viewer User Guide.

How to Run a Test Stored in Solution Manager in Integrated Mode

This task describes how to run test from SolutionManager in integratedmode and view the run
results stored in the network drive specified for SolutionManager run results (as defined in the SAP
SolutionManager pane of the Options dialog box).

You can runGUI tests from SolutionManager test scripts (integratedmode) in any of the following
ways:

l Use the Run option in UFT. Display the test in UFT and use the standard UFTRun option.
For details on displaying the test, see "How to Display or Edit a GUI Test from SolutionManager
in IntegratedMode" on the next page. For details on running a test using the UFT Run option,
see theHP Unified Functional Testing User Guide.

l Run the test from Solution Manager. Create and run a SolutionManager test script that calls
a GUI test. For details on creating test scripts that call GUI tests, see "How to Transfer Data To
and From GUI Tests in IntegratedMode Using Test Parameters" on page 339. For details on
running SolutionManager test scripts, see your SolutionManager documentation.

l Use the Execute Test Script (F8) option for a selected UFT test in Solution Manager. For
details, see "Run a UFT test from SolutionManager using the Execute Test Script option" on the
next page.

Note: For details on running tests in standalonemode, see "How to Run a Test Stored in
SolutionManager in StandaloneMode" on the previous page.
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Run a UFT test from Solution Manager using the Execute Test Script
option
For details, see your SAP documentation.

View results of a GUI test run in integrated mode
You can view the results of a GUI test that was run from SolutionManager in the following ways:

l In the Solution Manager Log Display. You can view the results of the test or the results of a
specific event, such as a checkpoint, in the SolutionManager log. You can view the folder in
which the results are saved in theUNCPathToLocalLog line of the SolutionManager log.

l In the HP Run Results Viewer. You can view the run results in the Run Results Viewer, which
you can either access from UFT or open directly.

If a test includes steps that log on to SolutionManager using the "SAP Tab (Record and Run
Settings Dialog Box)" (described on page 314), the logon steps are displayed in the run results
tree.

You can set the Run Results Viewer to open automatically after a test runs from Solution
Manager. To do this, in SolutionManager, select the Log Display check box in theShared tab
inStart Optionswindow.

For details on opening and analyzing run session results in UFT, see theHP RunResults
Viewer User Guide.

l Via the generated XML Report. Each time you run aGUI test from SolutionManager, an .xml
file is generated. This file contains all details of the run session. To view the file, click the line
containing the text: XML-DATA in the SolutionManager log.

How to Display or Edit a GUI Test from Solution Manager in
Integrated Mode

This task describes how to display or edit any existing GUI test that is stored in SolutionManager.
When you open the test, UFT opens in integrated and read-only mode. When you display or open a
GUI test in integratedmode, you can work only with the open test. You cannot open another test or
save the open test with another name.

Despite this, resource files that are saved with the test (for example, a local repository or the test's
local data table) are editable. To edit external resource files, open the test in standalonemode.

Note: If you select the UFT File > Save As menu commandwhen working in integrated
mode, UFT displays a warningmessage indicating that you can save a test with a new name in
the file system, but doing so disconnects UFT from SolutionManager and switches UFT to
standalonemode.

For more details on integrated and standalonemodes, see "StandaloneMode" on page 325 and
"IntegratedMode" on page 325.
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This task describes how to:

l "Display or open aGUI test from SolutionManager" below

l "Create a new GUI test from SolutionManager" below

Display or open a GUI test from Solution Manager

1. Log on to SolutionManager and open a test script. Make sure to specify Unified Functional
Testing as the external tool. For details on how to open test scripts in SolutionManager, see
your SAP documentation.

You can open the test in:

n Read-only (Display) mode. (If the test uses external resource files, the test and its
resources open in read-only mode by default.)

n Edit mode. This enables you to usemost UFT options. For details, see theHP Unified
Functional Testing User Guide.

2. To return to SolutionManager, close UFT.

Create a new GUI test from Solution Manager

1. Log on to SolutionManager. Then create and save a test script. Make sure to specify Unified
Functional Testing as the external tool. For details on how to open test scripts in Solution
Manager, see your SAP documentation.

When you create the script, UFT opens with a blank test.

2. Create the test in UFT. For details on creating GUI tests in UFT, see the other chapters in this
guide and theHP Unified Functional Testing User Guide.

3. In UFT, select File > Save As. A dialog box opens in SolutionManager.

4. In SolutionManager, specify the package in which you want to store the test. Confirm that the
other edit boxes contain correct values.

If the test has external resource files, they are stored by default in the $TMP (local)
package. If you select another package for the test, youmust manually move any external
resource files to the same package.

5. In SolutionManager, save the test. UFT is restored in integratedmode and displays the saved
test for additional editing.

6. To return to SolutionManager, close UFT.
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How to Transfer Data To and From GUI Tests in Integrated Mode
Using Test Parameters

You can pass values from a SolutionManager test script to a GUI test, or vice versa, using GUI
test parameters.

To send values to your input arguments, youmust run your test via a call from a SolutionManager
test script. After you define input and output arguments for your GUI test, you can insert a call to
that test from a SolutionManager test script and specify argument values for the input arguments.

Prerequisites
Define test parameters and use them in your GUI test. For details, see the section on the
"Parameters Tab (Properties Pane - Testing)" in theHP Unified Functional Testing User Guide.

If you are working with SAP structured parameters, see also "How toWork with SAP Structured
Parameters" below.

Call a GUI test and specify arguments from Solution Manager
To send values to your input arguments from SolutionManager, youmust run your test via a call
from a SolutionManager test script.

Tip: You can enter the name of a SolutionManager parameter from the SolutionManager script
as the value of a GUI input parameter.

After you define input and output arguments for your GUI test, you can insert a call to that test
from a SolutionManager script and specify argument values for the input arguments.

How to Work with SAP Structured Parameters

When you work in integratedmode with SAP Solutionmanager, you can pass values from a
SolutionManager test script to a GUI test, or vice versa, using the structure value type for your test
parameters.

You create andmaintain the structured parameters in SAP SolutionManager. After you have
defined your test parameters via SAP SolutionManager you canmap action parameters to the
structured parameters in the test. When you run a test, UFT receives the defined structure from
SAP SolutionManager, and resolves themapped local parameter with the actual structured
parameter value from SAP SolutionManager.

Create or modify the structured parameters of a test

1. From SAP SolutionManager, Launch your test as an external test.

UFT opens with your test displayed.

2. In the Parameters tab of the Properties pane, click theMaintain SAP Parameters icon . If
the Properties Pane is not already open, select View > Properties to open it.
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SAP Solutions Manager opens and UFT is hidden.

Note: SAP Structured Parameters can bemaintained only in SAP SolutionManager.

3. In SAP Solutions Manager, create or modify the structure parameters you want to use for your
test, save your changes and click Back.

UFT re-opens with the changes youmade now available.

Assign or modify the structured parameters for an action
To use the SAP structured parameter to run the test, youmust define parameters of type structure,
associate the test and action parameters, and thenmap the action’s structured parameter to the
test’s structured parameter. You can alsomap a simple type action parameter to a single element in
a structured parameter defined for the test.

1. Select the relevant action.

2. In the Parameters tab of the Properties pane, you can add or remove parameters, as described
in Add/Edit Input/Output Parameter Dialog Box (Properties Pane - GUI Testing) in the
HP Unified Functional Testing User Guide. If the Properties Pane is not already open, select
View > Properties to open it.

Note: If the test contains structured parameters, you can add parameters with the
structure type to the action.

3. Map action parameters to the test structured parameters

a. Right-click the relevant actions.

b. In the context menu, select Action Call Properties.

c. In the Action Call Properties Dialog Box > Parameter Values tab, in theValue cell/column of
an input parameter or theStore In cell/column of an output parameter, click theConfigure
Value button.

d. In either the Value Configuration Options Dialog Box (for input parameters) or the Storage
Location Options Dialog Box (for output parameters), select theParameter radio button and
click Browse.

The ValueMap dialog box opens.

e. Define themapping, as described in "ValueMapDialog Box" on page 356.

You can select the root node tomap the entire structure, or a sub tree node tomap to an
embedded structure, or you can select a leaf node tomap to a specific value in the structure.
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f. Click OK.

The parameters aremapped

Note: If an action is called inside another action, you canmap a parameter to an input
parameter of the parent action. If the action is called after another action, you canmap a
parameter to an output parameter of any previous action.

For more details on test and action parameters, see theHP Unified Functional Testing User
Guide.

Use structured parameters in a script
The examples below show how you can use structured parameters directly from a script.

<?xml version="1.0" encoding="utf-16"?>
<ZMOVIE>

<TITLE>Avatar</TITLE>
<DIRECTOR>

<FIRST_NAME>James</FIRST_NAME>
<LAST_NAME>Cameron</LAST_NAME>
<BIRTHDAY>16-8-1954</BIRTHDAY>

</DIRECTOR>
<REL_DATE>10-12-2009</REL_DATE>
<GENRE>SF</GENRE>
<STARRING>

<item>
<FIRST_NAME>Michelle</FIRST_NAME>
<LAST_NAME>Rodriguez</LAST_NAME>

</item>
<item>

<FIRST_NAME>Stephen</FIRST_NAME>
<LAST_NAME>Lang</LAST_NAME>

</item>
<item>

<FIRST_NAME>Zoe</FIRST_NAME>
<LAST_NAME>Saldana</LAST_NAME>

</item>
</STARRING>

</ZMOVIE>

l To access an element in a structured parameter, type the parameter name followed by a colon
(:) and then the element path. Use a period (.) between elements and their sub-elements. For
example:

Print Parameter(“Param1:ZMOVIE.DIRECTOR.FIRST_NAME”)

Output:
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James

Print Parameter(“Param1:ZMOVIE.STARRING.item[1].FIRST_NAME”)

Output:

Michelle

Note: UFT provides statement completion for structured parameters, displaying the
elements available for the relevant structure type.

l If the path represents an element that contains additional sub-elements, the returned value will
be a XML string. The path follows the XPath expression rule

Print Parameter(“Param1:ZMOVIE.DIRECTOR”)

Output:

<DIRECTOR>
<FIRST_NAME>James</FIRST_NAME>
<LAST_NAME>Cameron</LAST_NAME>
<BIRTHDAY>16-8-1954</BIRTHDAY>

</DIRECTOR>

l If the structure is an array or a table, you can use it in a loop:

rowCount = Parameter("Param1:ZMOVIE.STARRING.item.count()")
For Iterator = 1 To rowCount Step 1

first_name = "Param1:ZMOVIE.STARRING.item[" & Iterator & "].FIRST_NAME"
last_name = "Param1:ZMOVIE.STARRING.item[" &Iterator &"].LAST_NAME"
print Parameter(first_name) & " " & Parameter(last_name)

Next

Output:

Michelle Rodriguez
Stephen Lang
Zoe Saldana

Note: You can omit the root element from the path. For example,

Print Parameter("Param1:ZMOVIE.DIRECTOR.FIRST_NAME")
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Can also be written as

Print Parameter("Param1:DIRECTOR.FIRST_NAME")
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Reference

Solution Manager Testing Modes: Standalone or Integrated

The table below describes the basic differences between the standalone and integrated testing
modes.

Standalone Mode Integrated Mode

Open test
from

UFT SolutionManager

Solution
Manager -
UFT
connection

Connect to Solution
Manager from UFT using the
"SolutionManager
Connection Dialog Box"
(described on page 345.

SolutionManager automatically establishes the
SolutionManager - UFT connection.

Available
UFT
features

All UFT features are
available. You can open and
work with any test in
SolutionManager or in the
file system.

You can work only with the currently open test.

File > Open, File > New, and theRecent files
list options are disabled.

If you select File > Save As, UFT warns you that
it will disconnect from SolutionManager and
switch UFT to standalonemode.

Resource
files

When you open the test, you
can also edit and save all
the test's resource files,
including those stored in
SolutionManager.

When you open the test, test resources stored in
SolutionManager are opened in read-only mode.

Save
location

Tests and uploaded files are
automatically saved to the
local package ($TMP) in
SolutionManager.

You can save tests to any package (including non-
local packages).

Solution
Manager
dependence

Although UFT is connected
to SolutionManager, you
can work and navigate in
SolutionManager
independently.

SolutionManager is locked while the test is open
in UFT. To release SolutionManager, close UFT.

HP Unified Functional Testing (12.00) Page 344 of 549



Standalone Mode Integrated Mode

Run results All run results are stored in
the file system. They cannot
be accessed from your
SolutionManager log list.

For details, see theHP Run
Results Viewer User Guide.

Run results are stored to the network drive you
specify in theSolution Manager pane of the
Options dialog box and in the SolutionManager
server. You can access the run results from the
SolutionManager log.

Solution Manager Connection Dialog Box

This dialog box enables you to connect to or disconnect from SolutionManager at any time during
the testing process.

To access 1. Make sure that the computer is connected to SolutionManager.

2. Make sure that UFT is open with the Add-in for SAP Solutions loaded.

3. Select Tools > SAP Solution Manager Connection.

Important
information

Do not disconnect UFT from SolutionManager while a GUI test that is stored in
SolutionManager is open or while UFT is using a shared resource stored in
SolutionManager (such as a shared object repository or data table file).
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Relevant
tasks

l "How to Configure SolutionManager toWork with UFT" on page 327

l "How to Open and Save Tests in SolutionManager in StandaloneMode" on
page 330

l "How to Upload Files to SolutionManager in StandaloneMode" on page 332

l "How to Run a Test Stored in SolutionManager in StandaloneMode" on page
335

l "How to Run a Test Stored in SolutionManager in IntegratedMode" on page
336

l "How to Display or Edit a GUI Test from SolutionManager in IntegratedMode"
on page 337

l "How to Transfer Data To and From GUI Tests in IntegratedMode Using Test
Parameters" on page 339

User interface elements are described below:

UI Elements Description

Server
description

The SolutionManager server to which you want to connect.

TheServer description box lists the servers available in the SAP Logon Pad
or the SAP Logon dialog box.

To add a server to the list in the SolutionManager Connection dialog box, close
the dialog box, define an appropriate entry using your SAP Logon dialog box,
and then reopen the SolutionManager Connection dialog box.

User The user name used to log on to the specified server.

Password The password for the specified user name.

Client The client number.

Language The language that you want to use.

Reconnect on
startup

Instructs UFT to automatically reconnect to the SolutionManager server the
next time you open UFT.

Save
password for
reconnection
on startup

Instructs UFT to save your password for reconnection on startup.

If you select Reconnect on startup, but do not select this option, you are
prompted to enter it each time UFT opens.

Enabled only whenReconnect on startup is selected.

Connect Connects UFT to SolutionManager.
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Save GUI Test to Solution Manager Dialog Box

This dialog box enables you to save aGUI test in the SolutionManager database.

To access 1. Make sure that the computer is connected to SolutionManager.

2. Make sure that UFT is open with the Add-in for SAP Solutions loaded.

3. In UFT, display a GUI test and select File > Save As.

Important
information

l This dialog box is similar to the Save External File to SolutionManager dialog
box, and displays similar user interface elements.

l When saving a test to SolutionManager in standalonemode, the test is
automatically saved to the local package ($TMP) in SolutionManager.

User interface elements are described below:

UI
Elements Description

Test
name

The name for the test. Use a descriptive name that will help you easily identify the
test. Ensure that the test name begins with a prefix that matches your Solution
Manager server naming conventions. For example, your SolutionManager server
may require all file names to begin with the letter z.

When the Save Test in SolutionManager dialog box opens, it displays the default
test prefix in the Test name box. You can define or modify this prefix in the Solution
Manager pane of the Options dialog box. For details, see "SAP > SAP Solution
Manager Pane (Options Dialog Box > GUI Testing Tab)" on page 353.

Test
version

The version number of the test. The version number can be any number that you
choose. You can use the version number option as a kind of manual version control.
For example, each time you open andmodify a test, you can increment the version
number by 1, instead of overwriting the existing version of the test if you want to
keep a record of all versions of a test. The test name and version number together
form a unique ID for the test.
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UI
Elements Description

File
System

Enables you to save the currently open test anywhere in the file system.

Open GUI Test from Solution Manager Dialog Box

This dialog box enables you to open aGUI test from the SolutionManager database.

To access 1. Make sure that the computer is connected to SolutionManager.

2. Make sure that UFT is open with the Add-in for SAP Solutions loaded.

3. In UFT, select File > Open > Test.

Important
information

This dialog box is similar to the Open External File from SolutionManager dialog
box, except that this dialog box contains theOpen in read-only mode option.

Relevant
tasks

"How to Open and Save Tests in SolutionManager in StandaloneMode" on page
330

User interface elements are described below:

UI
Elements Description

Test name The name of the test you want to open.

When theOpen Test from SolutionManager dialog box opens, it displays the
most recently opened SolutionManager test in the Test name box.

You can enter a valid test name or select one from the list of recently opened
SolutionManager tests. Do not specify a folder path or other location.

Test
version

The version number of the test you want to open.
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UI
Elements Description

Open in
read-only
mode

Opens the test in read-only mode. You can run the test and save the results, but
you cannot modify the test or any external resources associated with the test.

File System Enables you to open a test from anywhere in the file system.

Upload File to Solution Manager Dialog Box

This dialog box enables you to store a test's external resource files in SolutionManager. You use
this dialog box to upload files that are stored in the file system, such as external data table files,
external function library files, and environment variable files, shared object repository files, and
recovery files.

To access 1. Make sure that the computer is connected to SolutionManager.

2. Make sure that UFT is open with the Add-in for SAP Solutions loaded.

Note: This step is optional for standalonemode.

3. In UFT, select File > Upload File to Solution Manager.

Important
information

When uploading a file to SolutionManager in standalonemode, it is automatically
saved to the local package ($TMP) in SolutionManager.

Relevant
tasks

"How to Upload Files to SolutionManager in StandaloneMode" on page 332
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User interface elements are described below:

UI
Elements Description

Local file The complete path of the file you want to upload. You can enter a file path or browse
to the file.

Solution The name under which to store the file in SolutionManager. Ensure that the file
name begins with a prefix that matches your SolutionManager server naming
conventions. For example, youmay have to prefix all file names with the letter z.

When the Upload File to SolutionManager dialog box opens, it displays the default
file prefix in theSolution Manager name box. You can define or modify this prefix
in the SolutionManager pane of the Options dialog box. For details, see "SAP > SAP
SolutionManager Pane (Options Dialog Box > GUI Testing Tab)" on page 353.

Version The version number of the file. The version number can be any number that you
choose. For example, each time you open andmodify a file, you can increment the
version number by 1, instead of overwriting the existing version of the file if you want
to keep a record of all versions of a file. The file name and version number together
form a unique ID for the file.

Save External File to Solution Manager Dialog Box

This dialog box enables you to save aGUI test's resource files directly to SolutionManager.

To access 1. Make sure that the computer is connected to SolutionManager.

2. Make sure that UFT is open with the Add-in for SAP Solutions loaded.

Note: This step is optional for standalonemode.

3. In UFT, display the file and select Tools > Save As.
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Important
information

This dialog box is similar to the Open External File from SolutionManager dialog
box, except that this dialog box does not contain theOpen in read-only mode
option.

Relevant
tasks

"How to Upload Files to SolutionManager in StandaloneMode" on page 332

User interface elements are described below:

UI
Elements Description

File
name

The name under which to store the file in SolutionManager. Ensure that the file
name begins with a prefix that matches your SolutionManager server naming
conventions. For example, youmay have to prefix all file names with the letter z.

When the Save External File to SolutionManager dialog box opens, it displays the
default file prefix in theSolution Manager name box. You can define or modify this
prefix in theSAP Solution Manager pane of the Options dialog box. For details,
see "SAP > SAP SolutionManager Pane (Options Dialog Box > GUI Testing Tab)"
on page 353.

File
version

The version number of the file. The version number can be any number that you
choose. For example, each time you open andmodify a file, you can increment the
version number by 1, instead of overwriting the existing version of the file if you want
to keep a record of all versions of a file. The file name and version number together
form a unique ID for the file.

Download File from Solution Manager

This dialog box enables you to download files stored in SolutionManager and save them in the file
system.
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To access 1. Make sure that the computer is connected to SolutionManager.

2. Make sure that UFT is open with the Add-in for SAP Solutions loaded.

3. In UFT, select File > Download File from Solution Manager.

Important
information

If you upload a file to SolutionManager and then associate that file with a test as a
resource file, the resource file is automatically downloaded each time you open
the test, and you do not need to use this dialog box.

User interface elements are described below:

UI
Elements Description

Solution The name of the file stored in SolutionManager.

When the Download File from SolutionManager dialog box opens, it displays the
default file prefix in theSolution Manager name box. You can define or modify this
prefix in the SolutionManager pane of the Options dialog box. For details, see
"SAP > SAP SolutionManager Pane (Options Dialog Box > GUI Testing Tab)" on
the next page.

Version The version number of the file to download.

Download
to

The complete path and file name of the location to which you want to download the
file. You can enter or browse to the folder path.
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SAP > SAP Solution Manager Pane (Options Dialog Box > GUI
Testing Tab)

This pane enables you to configure how UFT behaves when you are connected to SAP Solution
Manager.

To
access

1. Make sure that UFT is open with the Add-in for SAP Solutions loaded.

2. Make sure that a GUI test is open.

3. In UFT, select Tools > Options > GUI Testing tab > SAP > SAP Solution
Manager node.

User interface elements are described below:

UI Elements Description

Run results The location in which run results are stored when the test is run from
SolutionManager.

This folder must be amapped network drive or a path in Universal
Naming Convention (UNC) format.
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UI Elements Description

New test prefix The prefix that is displayed by default in the SaveGUI Test in Solution
Manager dialog box.

New file prefix The prefix that is displayed by default when specifying a file to store in
SolutionManager.

Solution Manager
test cache folder

The location in which a test from SolutionManager is temporarily stored
when it is open for editing or running in UFT.

Default location = %APPDATA%\Solution Manager

For example = C:\Documents and
Settings\<UserName>\Application Data\Solution Manager

Note: RunCache and EditCache folders are automatically created
under the specified folder.

Clear Cache Deletes all files from the SolutionManager test cache folder.

Modify Trace
Options

Opens the "SolutionManager TraceOptions Dialog Box", which enables
you to configure if and how UFT generates the UFT–SolutionManager
communication trace log (used for troubleshooting communication
errors). For details, see "SolutionManager TraceOptions Dialog Box"
below.

Solution Manager Trace Options Dialog Box

This dialog box enables you to configure whether and how UFT generates a trace file. For example,
you can instruct UFT to generate a UFT–SolutionManager communication trace file each time
SolutionManager runs a UFT test to troubleshoot communication errors.
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To
access

1. Connect the computer to SolutionManager in "StandaloneMode".

2. Do one of the following:

n Ensure that a GUI test, action, or component is in focus in the document
pane.

n In the Solution Explorer, select a GUI test or component node or one of its
child nodes.

3. In UFT, select Tools > Options > GUI Testing tab > SAP > SAP Solution
Manager node.

4. In the SAP SolutionManager pane, click Modify Trace Options.

User interface elements are described below:

UI Elements Description

Level The level of detail to include in the trace file that is created when
SolutionManager runs aGUI test.

l None. (default) No trace file is created.

l Low. The trace file lists any SolutionManager–UFT communication
errors.

l Medium. The trace file includes SolutionManager–UFT
communication errors and information on other major operations that
result in SolutionManager–UFT communication.

l High. The trace file includes all available information related to
SolutionManager–UFT communications.

Folder The folder path for storing the trace file. Required if a trace file level
other thanNone is specified in the Level option.

Default location = %APPDATA%\Solution Manager\Trace

For example = C:\Documents and
Settings\<UserName>\Application Data\Solution
Manager\Trace

File name The file name for the trace file.

Default = SolutionManagerTrace.html

Max size Themaximum file size you want to allow for the trace file.
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UI Elements Description

Generate .xml file
for debugging when
opening and saving
tests

Generates an .xml file each time you open or save a test that is stored
in SolutionManager. The files are saved in Open and Save folders under
the trace folder.

Note: Selecting this option results in slower response times for
editing and saving tests in UFT. In general, you should select this
option only when instructed to do so to debug SolutionManager
connectivity issues.

Value Map Dialog Box

Relevant for: GUI tests and components

This dialog box enables you tomap a structured parameter to an action parameter.

The image below shows the dialog tomap parameters.

To Access l For Input Parameters, click Browse in the Value Configuration Options dialog.

l For Output Parameters, click Browse in the Storage Location Options dialog.
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User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

Path The path of the selected node.

Schema The structure of the parameter in tree format. You can open and close each node.
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Chapter 22: Siebel Add-in - Quick Reference
You can use the UFT Siebel Add-in to test Siebel user-interface objects (controls).

The following tables summarize basic information about the Siebel Add-in and how it relates to
some commonly-used aspects of UFT.

General Information

Add-in Type This is aWeb-based add-in. Much of its functionality is the same as other
Web-based add-ins.

See "Web-Based Application Support" on page 39.

Supported
Environments

For details on supported Siebel environments, see theSiebel Add-in
section of theHP Unified Functional Testing Product Availability Matrix,
available from the UFT Help or the root folder of the Unified Functional
Testing DVD.

Important
Information

l You can use Siebel Test Express to automatically generate a new object
repository, or update an existing object repository. For details, see
"Siebel Test Express" on page 381.

l For general considerations, see "Considerations - Siebel Add-in" on page
362.

Test Object
Methods and
Properties

The Siebel Add-in provides test objects, methods, and properties that can be
used when testing objects in Siebel applications. For details, see theSiebel
section of theHP UFT Object Model Reference for GUI Testing.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide.

l See "Considerations - Siebel Add-in" on page 362.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

Troubleshooting
and Limitations

"Troubleshooting and Limitations - Siebel Add-in" on page 363

Prerequisites

Opening Your
Application

Youmust open UFT and set Record and Run options before opening your
Siebel application. Open the application only after you begin the recording
session.

Add-in
Dependencies

None
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Other l To test a Siebel 7.7.x or later application, youmust:

n Modify the Siebel Test Automationmodule configuration.

n Instruct your Siebel application to generate test automation information.

See "Siebel 7.7.x or Late - Test AutomationModule Configuration" on page
373.

l To test yourWeb application in Mozilla Firefox, youmust enable the Unified
Functional Testing Extension in one of the following ways:

n If theSelect Your Add-ons screen is displayed when you open Firefox,
select to keep the Unified Functional Testing Extension.

n If the Install Add-on tab opens and displays Unified Functional Testing
Extension when opening Firefox, select theAllow this installation
check box and click Continue.

Otherwise:

i. In Firefox, select Tools > Add-ons.

ii. In the General tab, click Manage Add-ons.

iii. In the Add-ons Manager tab, select theExtensions node.

iv. In the Unified Functional Testing Extension row, click theEnable
button.

Configuration

Options Dialog
Box

Use theWeb pane.
(Make sure that a GUI test is open and select Tools > Options > GUI
Testing tab > Web > General node.)

See "Web > General Pane (Options Dialog Box)" on page 65.

Record and Run
Settings Dialog
Box
(tests only)

Use theSiebel tab.
(Record > Record and Run Settings)

See "Siebel Tab (Record and Run Settings Dialog Box)" on page 377.

Test Settings
Dialog Box
(tests only)

Use theWeb pane.
(File > Settings > Web node)

See "Web Pane (Test/Business Component Settings Dialog Box /
Application Area - Additional Settings Pane)" on page 79.
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Custom Active
Screen Capture
Settings Dialog
Box
(tests only)

Use theWeb section.
(Tools > Options > GUI Testing tab > Active Screen node > Custom Level)

See the section on the Custom Active Screen Capture Settings dialog box
in theHP Unified Functional Testing User Guide.

Application Area
Additional
Settings pane
(business
components only)

l Use theWeb pane.
In the application area, click Additional Settings >Web in the sidebar.

See "Web Pane (Test/Business Component Settings Dialog Box /
Application Area - Additional Settings Pane)" on page 79.

l Use theApplications pane.
In the application area, select Additional Settings > Applications in
the sidebar.

In theSiebel version box, specify the Siebel version for the applications
on which you want to record your business component. The version that
you choose remains selected for all subsequent business components.

This chapter includes:

Concepts 362

Considerations - Siebel Add-in 362

Reference 363

Troubleshooting and Limitations - Siebel Add-in 363

Add-ins Guide
Chapter 22: Siebel Add-in - Quick Reference

HP Unified Functional Testing (12.00) Page 361 of 549



Concepts

Considerations - Siebel Add-in

General Considerations

l UFT learns objects in Siebel 7.7.x or later applications in a different way than in Siebel 7.0.x and
7.5.x applications. The Siebel Add-in has two different groups of test objects. The test object
used to represent an object in your application depends on the Siebel version of your application
and the implementation of the object. For details, see "Siebel Test Object Model - Overview" on
page 368.

l When you load the Siebel Add-in, theWeb event recording configurations designed for this add-
in are loaded and are used whenever you record on a Siebel object. The Siebel Web event
recording configurations do not affect the way UFT behaves when you record on other non-
Siebel Web objects. For details, see "Event Recording Configuration forWeb-Based
Applications" on page 44.

l When you load the Siebel Add-in, the object identification settings are also automatically
customized for Siebel. You do not need tomake any changes to them. Therefore, the Siebel and
Web options in the Object Identification dialog box are unavailable.

l Loading the ActiveX and Siebel add-ins together may cause problems when recording on some
ActiveX methods.

Siebel 7.7.x or Later

l As you record a test or business component on your Siebel 7.7.x or later application, UFT
records the operations you perform. UFT works directly with the Siebel Test Automation API
(SiebelAx_Test_Automation_18306.exe) to record your operations. Therefore, although UFT
records a step for each operation you perform, it adds the steps to your test or business
component only when API events are sent to UFT (when information is sent to the Siebel
server).

l When test automation is activated on a Siebel 7.7.x or later server and requested in the URL, the
Siebel Web Engine (SWE) generates additional information about each object in the Siebel
application when constructing theWeb page. Each object has a specific set of properties,
events, andmethods that provide functionality for the Siebel application. The Siebel Test
Automation API maps to these objects to enable you tomanipulate your Siebel application from
UFT when recording and running tests or business components on the Siebel application.

Siebel 7.0.x/7.5.x
The Siebel Add-in can also identify Siebel objects by the siebel attached text property (the static
text displayed with a Siebel object), rather than by the HTML name of the object. This enables you
tomaintain the test or business component with dynamically created pages.
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Reference

Troubleshooting and Limitations - Siebel Add-in
This section contains general troubleshooting and limitation information about the Siebel Add-in.

General
Recording onmultiple Siebel application versions in the same computer may cause steps not to be
recorded.

Checkpoints and the Object Spy

l To create a table content checkpoint or output value for the appropriate object type (for example,
SiebList, SiebPicklist, or SiebPageTabs) when editing your test or business component, you
must open the application to the exact screen in which the object appears. Otherwise, only the
Properties tab is displayed in the Table Checkpoint dialog box or Table Output Value dialog box.

l Checkpoints created for SiebList objects that contain a Total row may fail during a run session if
the action that led to the update of the Total row was not recorded.

l TheObject Spy and checkpoints identify expanded calculator and calendar popup objects as
Window("Siebel control popup").

This section also includes troubleshooting and limitation information about the following Siebel
versions:

l "Siebel 7.7.x or Later" below

l "Siebel 7.0.x and 7.5.x " on the next page

Siebel 7.7.x or Later

l Certain objects, methods, or properties may be available from within UFT even though they are
not described in the documentation. This is because UFT retrieves the latest
SiebelObject.xml file when loading the Siebel add-in and opening a Siebel application, and
because the documentation is updated according to version of the .xml file that is available at
the time of the UFT product release.

l Certain objects, for example, in the SmartScript module, do not have a value for the repository
name property and are therefore not recorded and are not recognized by the Object Spy.

Workaround:Use low-level recording.

l Gantt chart operations and RichText editor toolbar operations are not recorded.

Workaround:Use low-level recording.
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l The appointment calendar object can be recorded only if the ActiveX Add-in is enabled.

l If you record the creation of a new appointment in an appointment calendar, the test or business
component may fail when you run it.

Workaround:Manually add an onkeypress FireEvent to the WebElement before the Set step.

l The Active Screen is empty for steps recorded on pop-up tables.

l Inner objects that are placed in cells of a SiebList object cannot be accessed in the standard
way, even if they are recorded. This may cause the following limitations:

n The entire SiebList object is highlighted if the test or business component script line contains
an operation on a SiebList inner object.

n TheChildObjectsmethod for SiebList objects returns 0.

n The AddObjects option in the Object Repository window cannot be used to add SiebList
inner objects to the object repository.

l If a warningmessage opens while recording your test or business component, for example, if
you insert invalid data, UFT may record these operations in the incorrect order.

Workaround:Manually change the order of the steps in your test after recording.

l Context-sensitive help (F1Help) may not be available for Siebel 7.7.x or later objects and/or
methods that were added by Siebel after the UFT 11.50 release. In addition, auto-documentation
(in the Keyword View Documentation column) and step documentation (in the StepGenerator)
may not be available for these objects and/or methods.

Siebel 7.0.x and 7.5.x

Creating and Running Testing Documents

l UFT does not support recording on Siebel applications using keyboard shortcuts.

Workaround:Use themouse to record on Siebel applications.

l UFT does not record the scrolling of a set of records in an SblTable.

Workaround:While recording, scroll the table row by row.

Tip: You can use the Editor to manually edit the statement to scroll multiple rows.
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l By default, UFT does not record Editor control operations (usedmainly in longDescription
fields).

Workaround:Use low-level recording, making sure you record the scrolling to the control if
needed.

Working with Siebel Controls

l When you click theSearch icon for the first time during a browser session, a frame opens that is
different from all other search frames. When running test iterations, the correct framemay not be
identified.

Workaround:Close the browser at the end of every iteration.

l Each Siebel version includes changes/modifications to the user interface. As a result, steps last
modified in previous Siebel versions on elements that no longer exist in the interface will
probably fail and should be replaced.

For example, the button arrow used to view the next set of records on the top line of the Siebel
table that appears in earlier versions of Siebel was replaced in Siebel version 7.5.2 with a scroll
bar at the side of the table. In this case, replace Image("Next Record").Clickwith an
operation on the scroll bar.

l The name of the first column in an SblTable object cannot be retrieved.

Workaround:Use the column index to perform the operation on the cells in the first column.

Standard-Interactivity (SI) Applications

l In some SI application dialog boxes, in cases where selecting a check box causes a navigation
to occur (for example, in a check box table column, such as theNew column), UFT may not
record the subsequent steps or may record them inaccurately.

Workaround: To continue recording accurately, click anywhere in the page before the next
operation.

l When recording on a Currency Calculator pop-up control, clickingOK immediately after entering
a currency valuemay result in a recording error.

Workaround:Before clickingOK in a Currency Calculator pop-up control within a
SblAdvancedEdit object, select another control within the pop-up and click OK.

High-Interactivity (HI) Applications

l Depending on your browser's security settings and the Siebel patches that are installed, several
dialog boxes may open when logging in to your Siebel application. It is recommended to run
tests or business components when all required Siebel patches are downloaded and installed. If
for some reason, you cannot do this, manually delete the Sync steps added between the steps
recorded on the security alerts.
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l UFT cannot record a SblTable.Sort operation if it is the first operation inside anMVG (Multi-
Value Group) applet.

Workaround:Click anywhere in theMVG applet and then sort it.

l When recording on a SblAdvancedEdit object that opens a pop-up object, UFT records only the
Setmethod and does not record the operations within the pop-up object. However, if you open a
table from the pop-up object, UFT does record the operations performed within this secondary
table. These statements are not required in the test or business component, since the operation
of inserting the Pickup table selected item into themain table is also recorded. In some cases,
these redundant statements interfere with the run session.

Workaround: If the test or business component does not run as expected, delete the
statements recorded on secondary tables opened from a pop-up object.

l When adding an attachment to a Siebel table, UFT records additional statements that may
interfere with the run session.

Workaround:After recording, delete the OpenCellElement and Add statements that were
recorded when you added an attachment.

l When inserting a value into a Siebel table cell using the Currency Calculator control, UFT may
record a new SelectCell step before the SetCellData if youmove the cursor to another cell
before clicking in the cell in which you entered a value.

Workaround:While recording, always close the Currency Calculator by pressing theENTER
key. If, for some reason, the Currency Calculator was not closed using theENTER key, you can
manually change the order between the SetCellData and SelectCell steps.
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Chapter 23: Siebel Add-in -
Testing and Configuration
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Concepts

Siebel Add-in - Overview
The Siebel eBusiness platform is widely used inmany organizations for their business process
applications. UFT can create and run tests and business components on these applications using
special test objects and operations (methods and properties) that are customized for Siebel.

The customized Siebel test objects, methods, and properties make scripts simpler to read,
maintain, enhance, and parameterize, enabling both advanced and novice users to create
sophisticated tests and business components on Siebel applications.

UFT supports testing on both standard-interactivity and high-interactivity Siebel applications:

l Standard-interactivity applications download data as it becomes necessary. This interface is
designed for users accessing the application from outside the corporate network.

l High-interactivity applications download themajority of the required data at one time,
requiring fewer navigations. This interface is designed for heavy use, for example, by call
centers.

Note: Tests last modified in earlier versions of the Siebel Add-in can be opened in UFT Siebel
Add-in. The Siebel Add-in provides an option to convert the test's old record and run settings to
the new version settings automatically. In addition, the naming convention for Siebel test
objects has beenmodified for UFT Siebel Add-in. For details, see "How to Upgrade Tests Last
Modified with Version 6.5 of the Siebel Add-in" on page 376.

Siebel Test Object Model - Overview
The Siebel test object model is comprised of two different groups of test objects: test objects with
the prefix Sbl and test objects with the prefix Sieb. If you are recording on a Siebel 7.0.x or 7.5.x
application, UFT learns only Sbl test objects. If you are learning objects on a Siebel 7.7.x or later
application, UFT may learn only Sieb test objects or a combination of Sbl andSieb test objects,
depending on the way in which your Siebel application was implemented.

For details on each of the Siebel test objects, see theSiebel section of theHP UFT Object Model
Reference for GUI Testing.

When you perform an operation on your Siebel application while recording a test or business
component, UFT:

l identifies the object on which you performed the operation and creates the appropriate test
object in the test or business component.

l reads the current value of the object's properties in your application and stores them in the object
repository as the test object's property values.
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l chooses a unique name for the test object, generally using the value of one of its prominent
properties.

l records the operation (method) that you performed on the object and displays the operation as a
step in the Keyword View and as a statement in the Editor.

For example, suppose you select a check box for a specific account on a page of your Siebel
application. This check box has the label Competitor.

UFT identifies the check box as a SiebCheckbox object. It creates a SiebCheckbox test object
with the nameCompetitor and records the following properties and values as the description for
theCompetitor SiebCheckbox.

It also records that you performed a SetOnmethod to select the SiebCheckbox object.

UFT displays your step in the Keyword View like this:

UFT displays your step in the Editor like this:

SiebApplication("Siebel Call Center").SiebScreen("Accounts").SiebView("Accou
nt Details").SiebApplet("Account").SiebCheckbox("Competitor").SetOn

When you run a test or business component, UFT identifies each object in your application by its
test object class and its description: the set of identification properties and values used to uniquely
identify the object. In the above example, during the run session, UFT searches the object
repository for the SiebCheckbox object named Competitor to look up its description. Based on the
description it finds (repositoryname = Competitor and classname = SiebCheckbox), UFT
searches the application for a SiebCheckbox object namedCompetitor. When it finds the object,
UFT performs theSetOnmethod on the object to select the check box.

This section also includes:

Recording Steps on Siebel Objects 370

Native Operations and Properties in Siebel 7.0.x and 7.5.x Applications 370
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Recording Steps on Siebel Objects

When you record an operation on a Siebel object, UFT inserts a step with the relevant Siebel object
in the Keyword View and adds the corresponding statement in the Editor.

For example, if you select an item from a list, the Keyword View may be displayed as follows:

UFT records this step in the Editor as:

SiebApplication("Siebel Call Center").SiebScreen("Accounts").SiebView("Accou
nt Details").SiebApplet("Account").SiebPicklist("Account Type").Select "Cons
ultant"

Tip: It is recommended to log out of your Siebel application at the end of the recording session
before closing the browser.

If you have the Siebel Add-in installed, you can use UFT to generate an object repository for your
application. For details, see "Siebel Test Express" on page 381

Native Operations and Properties in Siebel 7.0.x and 7.5.x
Applications

In addition to the Siebel-specific test objects and operations, you can also use theObject property
to access native (internal) operations and properties of the HTML or ActiveX elements that wrap
Siebel objects. TheObject property is available for all Siebel 7.0.x and 7.5.x objects.

Tip: You can use theObject Spy to view the native operations and properties of an object in
your application.

TheObject property is also useful for checking the value of properties that are not available using a
standard Siebel checkpoint.

The following example uses theObject property to access the raw HTML element that represents
the SblTabStrip object, retrieve its HTML tag name and size, and display this information in
message boxes

set obj = Browser("Siebel Call").Page("Siebel Call").Frame("Siebel
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Call").SblTabStrip("ScreenTabStrip").Object
msgbox obj.tagName
msgbox obj.height
msgbox obj.width

Note: Relying on native properties may be problematic if you are upgrading your Siebel
application to a newer version, in which objects may have a different structure. For example,
the conversion of HTML objects to ActiveX objects in the Internet Explorer Option Pack.

For details on using the Object property, see theHP Unified Functional Testing User Guide.

Siebel Add-in - Checkpoints and Output Values
After you create your test or business component, you can enhance it by adding checkpoints,
retrieving output values, parameterizing values, and inserting Siebel objects, methods and
properties.

You check most Siebel objects or output their property values in the sameway as you do for other
objects supported by UFT, with exceptions forSblTable objects andSieb tabular test objects.

Considerations - Siebel Add-in Checkpoints and Output Values

l You check SblTable objects and output their values in the sameway as you do for other table
objects supported by UFT—using the Table Checkpoint Properties dialog box or Table Output
Value Properties dialog box—with the following differences:

n In Siebel 7.0.x or 7.5.x high-interactivity applications, youmust have your Siebel application
open to the page that contains the table while creating a table checkpoint or output value.

When creating table checkpoints or output values, do not include the header line of the
SblTable object when selecting cells to check or output. To clear the selection in this first row
of cells, double-click row heading 1 to the left of the table.

Tip:Whenworking with SblTable objects, you can spool all of the visible data from a
table into an external file. For details, see "Spooling Data from a Siebel Table" on the
next page.
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n Specific test objects in Siebel 7.7.x applications (withSieb prefixes) have tabular
characteristics. UFT treats Sieb tabular test objects as table-type objects and enables you to
check both their content and/or their identification properties. You can also output content
and/or identification property values for use in your test or business component. The following
Sieb test objects have tabular characteristics: SiebCommunicationsToolbar, SiebList,
SiebMenu, SiebPageTabs, SiebPDQ, SiebPicklist, SiebScreenViews, SiebThreadbar,
SiebToolbar, and SiebViewApplets.

Tip:Whenworking withSieb tabular objects, you can spool all of the visible data from
the object into an external file. For details, see "Spooling Data from a Siebel Table"
below.

l When testing high-interactivity applications:

n If theSieb tabular object is not open in your Siebel application when you create a checkpoint,
the Table Checkpoint Properties dialog box contains only the Properties tab and the option to
select which type of information to check (content or properties) is disabled.

n If theSieb tabular object is not open in your Siebel application when you create the output
value, the Table Output Value Properties dialog box contains only the Properties tab, and the
option to select which type of information to output (content or properties) is disabled.

l If you want to access an inner object contained in a SiebList object, hold theCTRL key while
you click the SiebList object with the pointing handmechanism.

This section also includes:

Spooling Data from a Siebel Table 372

Spooling Data from a Siebel Table

If you want to spool all the visible data from a SblTable or aSieb tabular object (such as a SiebList
object) into an external file, you can loop through each cell in the table and then save the information
to an external file.

The following example uses theGetCellDatamethod to list the data of each cell in aSblTable
object with 10 rows and 10 columns:

For i=0 to 10
For j=0 to 10

Dat=Browser("Siebel eChannel").Page("Siebel eChannel_8").
Frame("Campaign Explorer").SblTable("Campaign").
GetCellData (i, j)
SaveToExternalFile (Dat)

Next
Next
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The following example uses theRowsCount andColumnsCountmethods to list the data of each
cell in a SiebList object:

RowsCount = SiebApplication("Siebel Call Center").SiebScreen("Accounts").Sie
bView("My Accounts").SiebApplet("Accounts").SiebList("List").RowsCount
ColsCount = SiebApplication("Siebel Call Center").SiebScreen("Accounts").Sie
bView("My Accounts").SiebApplet("Accounts").SiebList("List").ColumnsCount
For i=0 to RowsCount-1

For j=0 to ColsCount-1
ColumnName = SiebApplication("Siebel Call Center").SiebScreen("Accou

nts").SiebView("My Accounts").SiebApplet("Accounts").SiebList("List").GetCol
umnRepositoryNameByIndex(j)

Dat=SiebApplication("Siebel Call Center").SiebScreen("Accounts").SiebView("
My Accounts").SiebApplet("Accounts").SiebList("List").GetCellText(ColumnName
,i)

SaveToExternalFile (Dat)
Next

Next

For details on theGetCellData, RowsCount, andColumnsCountmethods, see theSiebel
section of theHP UFT Object Model Reference for GUI Testing.

Siebel 7.7.x or Late - Test Automation Module
Configuration

UFT support for Siebel 7.7.x or later applications is based on the Siebel Test Automation API
(SiebelAx_Test_Automation_18306.exe). Before you can create or run tests or business
components on your Siebel 7.7.x or later application, youmust modify the Siebel Test Automation
module configuration and instruct your Siebel application to generate test automation information.

You do not need tomake any configuration changes in Siebel 7.0.x and 7.5.x applications to create
and run tests or business components on these Siebel application versions.

To test your Siebel 7.7.x or later application using the Siebel Add-in, youmust confirm that your
Siebel server has the Siebel Test Automationmodule installed and correctly configured to perform
test automation. For detailed information, see the section that describes how to set up your
functional testing environment in Testing Siebel eBusiness Applications Version 7.7, provided with
your Siebel installation.

Generating Test Automation Information - Siebel Application
To create and run tests or business components on your Siebel 7.7.x or later application, youmust
instruct the Siebel Web Engine (SWE) to generate test automation information for the Siebel
application, using a SWE command. To do so, append the SWECmd=AutoOn token to the URL of
your Siebel server. For example: http://hostname/callcenter/
start.swe?SWECmd=AutoOn. If you do not append this token, the SWE does not generate test
automation information.

If you select theOpen the following application when a record or run session begins option
in the "Siebel Tab (Record and Run Settings Dialog Box)" (described on page 377), UFT
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automatically appends the Siebel Test Automation information to the URL (you do not need to
specify it manually in the URL). For details on the Record and Run Settings dialog box options, see
"How to Define Environment Variables for Siebel Applications" on the next page.

If you select theOpen the following application when a record or run session begins option
in the "Siebel Tab (Record and Run Settings Dialog Box)" (described on page 377), UFT
automatically appends the Siebel Test Automation information to the URL (you do not need to
specify it manually in the URL). For details on the Record and Run Settings dialog box options, see
"How to Define Environment Variables for Siebel Applications" on the next page.

Note: If a session timeout error occurs in your Siebel 7.7.x or later application, the Siebel Test
Automation URL parameter values are not saved. After you log out and log in again, youmust
navigate to the correct URL that contains the required Siebel Test Automation parameter
values (including password parameter values, if any—see below).

Generating Test Automation Information - Secured Siebel Application
If a password for generating test automation information is defined on your Siebel Server, youmust
also indicate that password in the URL (in addition to the SWECommand=AutoOn token described
above). The URL token is in the format AutoToken=password. For example:
http://hostname/callcenter/start.swe?SWECmd=AutoOn&AutoToken=mYPass. This enables
UFT to run the Siebel Test Automation API SiebelAx_Test_Automation_18306.exe even in
securemode.

If a password is defined for the Siebel Server and you do not append this token to the URL, the
SWE does not generate test automation information.

For details on whether your Siebel Server is secured for test automation, contact your Siebel
system administrator.

If you select theOpen the following application when a record or run session begins option
in the "Siebel Tab (Record and Run Settings Dialog Box)" (described on page 377), click the
Advanced button, and specify the password in theSiebel automation access code box in the
Advanced Siebel Record and Run Settings dialog box, UFT automatically appends the password
information to the URL (you do not need to specify it manually in the URL). For details on the
Record and Run Settings dialog box options, see "How to Define Environment Variables for Siebel
Applications" on the next page.
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Tasks

How to Define Environment Variables for Siebel
Applications

Note:

l If you define any of these environment variables, it overrides the corresponding values in
the "Siebel Tab (Record and Run Settings Dialog Box)" (described on page 377) (for
components), or the Applications pane in the application area's Additional Settings pane (for
application areas).

l For details on defining and working with environment variables, see "Environment Variables
in Record and Run Settings" on page 30.

Use the variable names listed in the following table to define Siebel application details:

Option
Variable
Name Description

Siebel version APPLICATION_
ENV

The Siebel version for the applications on which you
want to record your test or business component.

Possible values:

l    77

l    7075

This option is available for tests and business
components.

Address URL_ENV The URL of the application you want to open. This
option is available only for tests.

Auto-login AUTO_LOGIN_
ENV

Indicates whether to automatically log in to the
application to open. This option is available only for
tests.

Possible values:

l True

l False

User USER_NAME_
ENV

The user name used to log in to the application to
open. This option is available only for tests.
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Option
Variable
Name Description

Password PASSWORD_ENV The encrypted password for the application to open.
This option is available only for tests.

Log out of the
application when the
test closes

LOGOUT_ENV Indicates whether to automatically log out of the
application when the test closes. This option is
available only for tests.

Possible values:

l True

l False

How to Upgrade Tests Last Modified with Version 6.5 of
the Siebel Add-in

The first time you open a test that was last modified in an earlier version of the Siebel Add-in, a
message opens asking whether you want to convert the record and run settings to the appropriate
settings automatically.

This is because in Siebel Add-in 6.5, the record and run settings were defined in theWeb tab of the
Record and Run Settings dialog box, and now they need to be defined in the "Siebel Tab (Record
and Run Settings Dialog Box)" (described on page 377).

Select one of the following:

l Yes. Converts the record and run settings for the test automatically.

l No. Leaves the settings as they are.

If you select Yes, the following settings aremodified in the "Siebel Tab (Record and Run Settings
Dialog Box)" (described on page 377):

l The Siebel version is set as Siebel eBusiness 7.0/7.5.

l The browser settings and/or URL that were defined in theWeb tab are transferred to theSiebel
tab.

l TheWeb Add-in is removed from the list of add-ins associated with the test.

Note: If you choose not to convert the settings automatically, or if you choose to convert the
settings but do not save the test before closing it, themessage asking if you want to convert
the settings is not displayed the next time you open the test. You canmanually change the
settings for a test at any time in the "Siebel Tab (Record and Run Settings Dialog Box)".
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Reference

Siebel Tab (Record and Run Settings Dialog Box)
This tab enables you to define how UFT starts recording and running tests on Siebel objects.

To access Select Record > Record and Run Settings and select theSiebel tab.

Note: The Record and Run Settings dialog box opens automatically each
time you begin recording a new test (unless you open the dialog box and set
your preferences manually before you begin recording).
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Important
information

l If you have tests that were last modified using the Siebel Add-in, version 6.5,
you need to convert your Record and Run Settings to use the Siebel tab
instead of theWeb tab. For details, see "How to Upgrade Tests Last Modified
with Version 6.5 of the Siebel Add-in" on page 376.

l If you are working with Siebel 7.7.x or later applications, consider the following:

n To test a Siebel 7.7.x or later application, youmust open the Siebel
application with Siebel Test Automation loaded, by specifying additional
URL parameter values. For details, see "Siebel 7.7.x or Late - Test
AutomationModule Configuration" on page 373.

n If you select theOpen the following application when a record or run
session begins option, UFT automatically appends the Siebel Test
Automation information to the URL (you do not need to specify it manually in
the URL). If you select to record and run on any open browser, youmust
specify the required parameter values as part of the application URLwhen
you open the application.

n If you select theOpen the following application when a record or run
session begins option, and specify the password in theSiebel
automation access code box in the Advanced Siebel Record and Run
Settings dialog box, UFT automatically appends the password information
to the URL. You do not need to specify it manually in the URL. If you select
to record and run on any open browser, or do not specify the password in the
Advanced Siebel Record and Run Settings dialog box, youmust specify the
required password values as part of the application URLwhen you open the
application.

n If a session timeout error occurs in your Siebel 7.7.x or later application, the
Siebel Test Automation URL parameter values are not saved. After you log
out and log in again, youmust navigate to the correct URL that contains the
required Siebel Test Automation parameter values.

Relevant
tasks

l "How to Define Environment Variables for Siebel Applications" on page 375

l "How to Upgrade Tests Last Modified with Version 6.5 of the Siebel Add-in" on
page 376

See also l "Considerations - Siebel Add-in" on page 362

l "How to Define Record and Run Settings for UFT Add-ins" on page 33
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User interface elements are described below:

UI Elements Description

Siebel version Specifies the Siebel version for the applications on which
you want to record your test. The version that you choose
remains selected for all subsequent tests.

You can use an environment variable to specify the Siebel
version. For details, see "How to Define Environment
Variables for Siebel Applications" on page 375.

Record and run tests on any
open browser

Instructs UFT to use any Internet Explorer browser to record
and run the test.

UFT can record and run only browsers that are opened after
UFT is opened. If you are using Siebel 7.7.x or later, make
sure you specify the required test automation parameters, as
described in "Siebel 7.7.x or Late - Test AutomationModule
Configuration" on page 373.

Open the following application
when a record or run session
begins

Instructs UFT to open the specified application when record
or run sessions begin.

Address
(Enabled only when "Open the
following application when a
record or run session begins"
is selected)

Instructs UFT to open Internet Explorer to the specified URL.
Recommended format: <host>/<application
name>/start.swe

Example: siebapp/callcenter_enu/start.swe

You can use an environment variable to specify the URL. For
details, see "How to Define Environment Variables for Siebel
Applications" on page 375.

Auto-login
(Enabled only when "Open the
following application when a
record or run session begins"
is selected)

Instructs UFT to open the specified Siebel application using
the specified login details.

You can use an environment variable to specify theAuto-
login setting. For details, see "How to Define Environment
Variables for Siebel Applications" on page 375.

User
(Enabled only when Auto-
login is selected)

The user name used to log in to the specified application.

You can use an environment variable to specify the user
name. For details, see "How to Define Environment
Variables for Siebel Applications" on page 375.

Password
(Enabled only when Auto-
login is selected)

The password for the specified user name.

You can use an environment variable to specify the
password. For details, see "How to Define Environment
Variables for Siebel Applications" on page 375.

Add-ins Guide
Chapter 23: Siebel Add-in - Testing and Configuration

HP Unified Functional Testing (12.00) Page 379 of 549



UI Elements Description

Log out of the application
when the test closes
(Enabled only when Auto-
login is selected)

Instructs UFT to log out of the specified application
automatically when the test closes. Any other Siebel
sessions that were opened before, during, or after the test
run are not affected.

You can use an environment variable to specify the Log out
setting. For details, see "How to Define Environment
Variables for Siebel Applications" on page 375.

Close the browser when the
test closes
(Enabled only when "Open the
following application when a
record or run session begins"
is selected)

Instructs UFT to close the opened browser when the test
closes. Any other browsers that were opened before, during,
or after the test run are not affected.

Advanced
(Enabled only when "Siebel
version 7.7 and later" and
"Open the following
application when a record or
run session begins"
are selected)

Opens the Advanced Siebel Record and Run Settings dialog
box, where you can specify the following options:

l Siebel automation request timeout. The timeout period
(in seconds) for each attempt to connect to Siebel Test
Automation when running the test.

Default: 120 seconds.

l Siebel automation access code. The predefined
security code required to enable access to Siebel Test
Automation, if specified by your organization's access
security policy.
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Chapter 24: Siebel Test Express
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Concepts

Using Siebel Test Express to Generate or Update Shared
Object Repositories

If the Siebel Add-in is installed on UFT, you can use Siebel Test Express to automatically generate
a new shared object repository, or to update an existing object repository.

You can create new shared object repositories using the Create Object Repository Wizard. Using
the wizard you can select the applications or top-level application objects for which to create an
object repository. Siebel Test Express scans the Siebel application and creates test objects for
every child object contained in the applications or top-level objects that you specify. After you have
created the shared object repository, you can save it to the file system or to an ALM project using
the Object Repository Manager.

You can also use Siebel Test Express to update an existing object repository. The Update Object
Repository Wizard enables you to select the applications or top-level objects to include in the
update, as well as the date from which to search for and include new ormodified objects. The date
refers to when the objects were last added or modified in the object repository.

After you update an object repository, the Object Repository Merge Tool merges the new and
modified objects with objects from your existing object repository.

This chapter explains how to create or update an object repository using Siebel Test Express. For
details on working with object repositories in general, see theHP Unified Functional Testing User
Guide.

For details on creating and updating object repositories using Siebel Test Express, see "How to
Use Siebel Test Express to Generate or Update a SharedObject Repository" on the next page.

For details on the Create / Update Object Repository wizard, see "Create Object Repository
Wizard" on page 385.
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Tasks

How to Use Siebel Test Express to Generate or Update a
Shared Object Repository

This task describes how to use Siebel Test Express to generate a new shared object repository for
a Siebel application or to update an existing shared object repository.

This task includes the following steps:

l "Prerequisites" below

l "Create or update a shared object repository" below

l "(Optional) Use the Object Repository Merge Tool to merge the updated Siebel object
repository" on the next page

l "Save the shared object repository" on the next page

1. Prerequisites
n To successfully run Siebel Test Express, the Siebel Add-in must be installed and loaded.

n Siebel Test Express supports Siebel 7.7 or later high-interactivity applications that are
based on the Siebel Test Automation API.

n Towork with Siebel Test Express in UFT, ensure that the Siebel Test Automation API
version installed on your server is one that supports Siebel Test Express.

2. Create or update a shared object repository
a. Select Resources > Object Repository Manager. TheObject Repository Manager

opens.

b. (Optional) To update an existing object repository, open the object repository file you want
to update in editable format.

Note: By default, the object repository file opens in read-only mode. To open it in
editable format, either clear theOpen in read-only mode check box in the Open
SharedObject Repository window, or enable editing by selecting File > Enable
Editing after you open the repository.

c. Open the Create Object Repository Wizard, as described in "Create Object Repository
Wizard" on page 385.
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d. Follow the steps of the wizard to create the new shared object repository. The wizard
contains the following pages:

o "Connection Information Page (Create Object Repository Wizard)" on the next page

o "Screen Selection Page (Create / Update Object Repository Wizard)" on page 387

o "Importing Test Objects Page (Create Object Repository Wizard)" on page 389

o "Object Repository Created / Updated Page (Create / Update Object Repository
Wizard)" on page 390

After the import process ends, the Object Repository Merge Tool opens. This may take a
few minutes.

3. (Optional) Use the Object Repository Merge Tool to merge the updated
Siebel object repository
Conflicts between objects in the primary and secondary repository files are resolved
automatically by theMerge Tool according to the default resolution settings. After themerge,
theMerge Tool displays the Statistics dialog box, which lists the files that weremerged, and
the number and type of any conflicts that were resolved during themerge. You can accept or
modify these resolutions tomatch your needs.

For details on working with the Object Repository Merge Tool, see theHP Unified Functional
Testing User Guide.

4. Save the shared object repository
Save the shared object repository to the file system or to an ALM project. For details on
working with or saving shared object repositories, see the section on theObject Repository
Manager in theHP Unified Functional Testing User Guide.
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Reference

Create Object Repository Wizard
This wizard enables you to create or update a shared object repository using Siebel Test Express.

To access In the Object Repository Manager (Resources > Object Repository Manager),
do one of the following:

To create a new object repository:

l Click theCreate Object Repository button on theObject Repository
Manager toolbar.

l Select Tools > Siebel Test Express > Create Object Repository.

To update an existing object repository:

l Click theUpdate Object Repository button on theObject Repository
Manager toolbar.

l Select Tools > Siebel Test Express > Update Object Repository.

Important
information

You can run only one instance of the Create / Update Object Repository Wizard
on a computer at any given time.

Relevant
tasks

"How to Use Siebel Test Express to Generate or Update a SharedObject
Repository" on page 383

Wizard
map

This wizard contains:

"Connection Information Page (Create Object Repository Wizard)" (page 385 >
"Screen Selection Page (Create / Update Object Repository Wizard)" (page 387 >
"Importing Test Objects Page (Create Object Repository Wizard)" (page 389 >
"Object Repository Created / Updated Page (Create / Update Object Repository
Wizard)" (page 390

See also "Using Siebel Test Express to Generate or Update SharedObject Repositories"
on page 382

Connection Information Page (Create Object Repository Wizard)

This wizard page enables you to enter the connection information for logging in to the Siebel server.
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Important
information

l General information about the wizard is available here: "Create Object
Repository Wizard" on the previous page

l The information you enter on this page is saved as metadata in the generated
object repository file.

l If you are creating a new repository, the information that was entered in this
page the last time you used the wizard is automatically entered in this page.

l If you are updating the repository, the information that was saved as metadata
with the repository file is automatically entered in this page.

l The data required in this page is not necessarily the same as the data you use
to log into the Siebel application as a user. Contact your Siebel server
administrator for details.

l While the Connection Information page is open, you cannot make theObject
Repository Manager or UFT window active.

Wizard
map

The "Create Object Repository Wizard" contains:

Connection Information Page (Create Object Repository Wizard) > Screen
Selection Page (page 387 > "Importing Test Objects Page (Create Object
Repository Wizard)" (page 389) > "Object Repository Created / Updated Page
(Create / Update Object Repository Wizard)" (page 390)

See also l "How to Use Siebel Test Express to Generate or Update a SharedObject
Repository" on page 383

l "Using Siebel Test Express to Generate or Update SharedObject
Repositories" on page 382

User interface elements are described belows:

UI Element Description

Server URL The URL of the Siebel server (including http://).

User name Your user name.

Password Your password.

Database name The name of the Siebel database.

Table owner The table owner you want to use for the specified Siebel database.

Siebel repository
(optional)

The name of the Siebel repository. If you do not enter a name, Siebel
will use a default name.
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Screen Selection Page (Create / Update Object Repository Wizard)

This wizard page enables you to select the test objects whose children you want to import. You can
select the applications for which to create the object repository, or you can expand the application
node and then select one or more top-level objects. It is recommended to select only the top-level
objects that you need. Importing an entire applicationmay take a very long time.

Important
information

l General information about the wizard is available here: "Create Object
Repository Wizard" on page 385.

l While the Screen Selection page is open, you cannot make theObject
Repository Manager or UFT window active.

l When Siebel Test Express creates the object repository, it imports the
metadata and creates test objects for all children (descendants) of the
applications or top-level objects you select in this page. Therefore, it is
recommended to select only the top-level objects that you need. Importing an
entire applicationmay take a very long time.

Wizard
map

The "Create Object Repository Wizard" contains:

"Connection Information Page (Create Object Repository Wizard)" (page 385) >
Screen Selection Page (Create / Update Object Repository Wizard) >
Importing Test Objects Page (page 389) > "Object Repository Created / Updated
Page (Create / Update Object Repository Wizard)" (page 390)

See also l "How to Use Siebel Test Express to Generate or Update a SharedObject
Repository" on page 383

l "Using Siebel Test Express to Generate or Update SharedObject
Repositories" on page 382
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User interfaces elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

<test object
tree>

The list of all the available applications and their objects, according to the
connection information entered in the "Connection Information Page (Create
Object Repository Wizard)", displayed as nodes in a tree.

Note: (for updating an object repository)

l If the last used profile from a previous import operation was saved,
the profile is loaded, and you can edit the selected options, as
required. The new selections are saved in the profile to be used for
future import operations on the same object repository.

l If you select objects other than the ones that were imported in the
previous wizard session, then only objects modified since the
selected date are imported.

Import only
objects modified
since (Update
Object
Repository
Wizard only)

The date in which the last import was performed. You can keep the
displayed date or select a new date by clicking the drop-down arrow, and
select the date from the displayed calendar. All objects modified before the
selected date are ignored during the import process. Using this option can
speed up the importing process.
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Importing Test Objects Page (Create Object Repository Wizard)

This wizard page shows the progress of the import process. The number imported indicates the
number of applet objects that have already been imported, including all child objects of that applet.

Important
information

l General information about the wizard is available here: "Create Object
Repository Wizard" on page 385.

l Importing into the object repository can take up to several hours, depending on
the size of the repository.

l At the same time that the wizard imports the objects, it is also retrieving
information about the total number of applets it needs to import. While the
wizard is retrieving this information, the total number changes and the words
at least show that the wizard is still retrieving information. When the total
number is known, the words at least are no longer displayed.

l You can work in either the Object Repository Manager or UFT while the wizard
is generating the object repository. However, do not close either window. If you
do try to close either window, amessage is displayed, warning that the object
repository generation process will be stopped and all data will be lost.

l If you are using the wizard to update an object repository, that object repository
file is locked and you cannot modify it in the Object Repository Manager.

l During the import process, you can cancel the operation if required. If you
cancel the operation, amessage is displayed notifying you that stopping the
import process will result in an incomplete object repository. You can then
select whether to keep, discard, or continue importing test objects into the
partial object repository.

Wizard
map

The "Create Object Repository Wizard" contains:

"Connection Information Page (Create Object Repository Wizard)" (385) > Screen
Selection Page"Screen Selection Page (Create / Update Object Repository
Wizard)" (387) > Importing Test Objects Page (Create Object Repository
Wizard > Object Repository Created / Updated Page"Object Repository Created
/ Updated Page (Create / Update Object Repository Wizard)" (page 390)

See also l "How to Use Siebel Test Express to Generate or Update a SharedObject
Repository" on page 383

l "Using Siebel Test Express to Generate or Update SharedObject
Repositories" on page 382
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Object Repository Created / Updated Page (Create / Update Object
Repository Wizard)

This wizard page opens after all the objects have been imported, displaying the total number of
objects added or modified in the object repository.

Important
information

l General information about the wizard is available here: "Create Object
Repository Wizard" on page 385.

l Displaying the new or updated object repository in the Object Repository
Manager may take a few minutes.

l If any errors occur during the import process, this page displays a warning and
anError Log button. The log contains error and exception data from the Siebel
server, listing the failed calls and the object that caused the error. You can
click theError Log button to save the error log. By default, the error log is
called TestExpressErrorLog.xml, and it is saved in the <Unified
Functional Testing>\Tests folder.

Wizard
map

The "Create Object Repository Wizard" contains:

"Connection Information Page (Create Object Repository Wizard)" (385) >
"Screen Selection Page (Create / Update Object Repository Wizard)" (page 387)
> Importing Test Objects Page"Importing Test Objects Page (Create Object
Repository Wizard)" (page 389 > Object Repository Created / Updated Page
(Create / Update Object Repository Wizard)

See also l "How to Use Siebel Test Express to Generate or Update a SharedObject
Repository" on page 383

l "Using Siebel Test Express to Generate or Update SharedObject
Repositories" on page 382
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Chapter 25: Standard Windows Support -
Quick Reference

You can use the standardWindows testing support provided by UFT to test user-interface objects
(controls) developed using theWin32 API or MFC platforms. UFT standardWindows testing
support is built-in and does not require you to load any UFT add-in.

The following tables summarize basic information about standardWindows testing support and
how it relates to some commonly-used aspects of UFT.

General Information

Add-in Type The standardWindows testing support functions like aWindows-based add-
in. Much of its functionality is the same as otherWindows-based add-ins.

See "Windows-Based Application Support" on page 94

Important
Information

UFT uses built-in standardWindows testing support and standardWindows
test objects to identify the following:

l Objects from other environments if the relevant add-in is not installed and
loaded.

l Stingray, VisualAge Smalltalk, andQt (widget toolkit) controls when the
relevant add-in is installed and loaded. For details, see the relevant add-in
documentation.

l Many windowless objects, if they were developed using theMSAA
(Microsoft Active Accessibility) API. For example, the controls within the
Microsoft Office ribbons are identified as independent objects.

Test Object
Methods and
Properties

StandardWindows testing support provides test objects, methods, and
properties that can be used when testing objects in standardWindows
applications. For more information, see theStandard Windows section of
theHP UFT Object Model Reference for GUI Testing.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide.

l See "Supported Checkpoints " on page 541and "Supported Output
Values " on page 543Per Add-In.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

Troubleshooting
and Limitations

"Troubleshooting and Limitations - StandardWindows" on page 394

Prerequisites
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Opening Your
Application

You can open your standardWindows application before or after opening
UFT.

StandardWindows testing support is always loaded in UFT. It is therefore
not an available option in the Add-in Manager.

Add-in
Dependencies

None

Configuration

Options Dialog
Box

Use theWindows Applications pane.
(Tools > Options > GUI Testing tab > Windows Applications node)

See "Windows Applications > General Pane (Options Dialog Box >
GUI Testing Tab)" on page 98.

Record and Run
Settings Dialog
Box
(tests only)

Use theWindows Applications tab.
(Record > Record and Run Settings)

See "Windows Applications Tab (Record and Run Settings Dialog Box)"
on page 109.

Note: UFT recognizes standardWindows objects only in
applications that are opened after changing the settings in the
Windows Applications tab of the Record and Run Settings dialog
box.

Custom Active
Screen Capture
Settings Dialog
Box
(tests only)

Use theWindows applications section.
(Tools > Options > GUI Testing tab > Active Screen node > Custom
Level)

See the section on the Custom Active Screen Capture Settings

dialog box in theHP Unified Functional Testing User Guide.

Application Area
Additional
Settings pane
(business
components only)

Use theApplications pane.
In the application area, select Additional Settings > Applications in the
sidebar.

See the section on the Applications pane in theHP Unified Functional
Testing User Guide.

This chapter includes:

Troubleshooting and Limitations - StandardWindows 394
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Troubleshooting and Limitations - Standard Windows
This section describes troubleshooting and limitations for working with StandardWindows test
objects.

l When recording onWinMenu objects, the Active Screen is not captured.

l You cannot insert a checkpoint on aWinMenu object.

Workaround:Use theCheckProperty andCheckItemPropertymethods to check specific
property and item property values.

l If you record usingWindows logo key shortcuts, the recordingmay be inaccurate.

Workaround:Use theStartmenu instead of theWindows logo key when recording.

l Changing the style of aWinCalendar (from single selection tomulti-selection, for example) will
cause the run session to fail.

l When using the pointing handmechanism from theObject Spy to point to MFC static text or tab
controls, UFT may fail to return the correct object.

Workaround:Add the object to the object repository. To do this, point to the object's parent
window, select the parent window object in the Object Selection dialog box, click OK, and
perform one of the following in the Define Object Filter dialog box:

n Select theAll object types option to add all of the objects in the parent window to the object
repository.

n Select theSelected object types option, click theSelect button, and then select the specific
object type(s) you want to add to the object repository.

After you add the object to the object repository, you can use theGetROPropertymethod to
retrieve the run-time values of its properties. For example:

width = Dialog("Login").Static("Agent Name:").GetROProperty("width")
MsgBox width

l Checkpoints are not supported forWinComboBox objects of style Simple ComboBox.

l Windowless objects developed using an API other than theMSAA API are not identified.

l The description properties of a windowless control must include the acc_name property. By
default, this property is not available in the list properties when you add a new test object.

Workaround:Add the acc_name property to the list of properties. To do this from the Define
New Test Object Dialog Box, in the Test object details area, click theAdd description
properties button . In the Add Properties dialog box, click theDefine new property button

and add the acc_name property.
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Chapter 26: Stingray Add-in - Quick Reference
The following tables summarize basic information about the Stingray Add-in and how it relates to
some commonly-used aspects of UFT.

General Information

Add-in Type This is aWindows-based add-in. Much of its functionality is the same as
otherWindows-based add-ins.

See "Windows-Based Application Support" on page 94.

Supported
Environments

The UFT Stingray Add-in recognizes and records on supported Stingray
Objective Grid and Stingray Objective Toolkit controls. For details on
supported Stingray environments, see theStingray Add-in section of the
HP Unified Functional Testing Product Availability Matrix, available from the
UFT Help or the root folder of the Unified Functional Testing DVD.

Important
Information

"Considerations forWorking with the Stingray Add-in " on page 399

Test Object
Methods and
Properties

The Stingray Add-in uses a sub-set of the standardWindows test objects,
methods, and properties, which can be used when testing objects (controls)
in Stingray applications. For details, see theStingray section of theHP UFT
Object Model Reference for GUI Testing.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

Troubleshooting
and Limitations

"Troubleshooting and Limitations - Stingray Add-in" on page 400

Prerequisites

Opening Your
Application

You can open your Stingray application before or after opening UFT.

Add-in
Dependencies

None

Other Youmust configure the Stingray Add-in to work with your application. See
"Setting Up Stingray Object Support" on page 403.

Configuration

Wizard "Stingray Support ConfigurationWizard" on page 408
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Options
Dialog Box

l Use theStingray pane.
(Make sure that a GUI test is open and select Tools > Options > GUI
Testing tab > Stingray node.)

See "Stingray Pane (Options Dialog Box > GUI Testing Tab)" on page 422.

l Use theWindows Applications pane.
(Tools > Options > GUI Testing tab >Windows Applications node)

See "Windows Applications > General Pane (Options Dialog Box >
GUI Testing Tab)" on page 98.

Record and
Run
Settings
Dialog Box
(tests only)

Use theWindows Applications tab.
(Record > Record and Run Settings)

See "Windows Applications Tab (Record and Run Settings Dialog Box)" on page
109.

Note:

l In addition to the settings in the Record and Run Settings dialog box, you
must also configure UFT to recognize your Stingray applications in the
Stingray pane of the Options dialog box (Tools > Options > GUI
Testing tab > Stingray node). For details, see "Stingray Pane (Options
Dialog Box > GUI Testing Tab)" on page 422.

l If you select theRecord and Run only on radio button in the Record and
Run Settings dialog box, the settings also apply to (limit) the applications
that are recognized for Object Spy and other pointing hand operations.

Custom
Active
Screen
Capture
Settings
Dialog Box
(tests only)

Use theWindows applications section.
(Tools > Options > GUI Testing tab > Active Screen node > Custom Level)

See the section on the Custom Active Screen Capture Settings dialog box in the
HP Unified Functional Testing User Guide.

Application
Area
Additional
Settings
pane
(business
components
only)

Use theApplications pane.
In the application area, click Additional Settings > Applications in the sidebar.

See the section on the Applications pane in theHP Unified Functional Testing
User Guide.

This chapter includes:

Concepts 399
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Considerations forWorking with the Stingray Add-in 399

Reference 400

Troubleshooting and Limitations - Stingray Add-in 400
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Concepts

Considerations for Working with the Stingray Add-in
UFT stores Stingray support configuration for each configured Stingray application separately. By
default, UFT uses the latest configured Stingray agent version for all Stingray applications except
those applications that are already configured.

For example, suppose you have two Stingray applications; application grid1.exe that uses
Stingray Grid control version 9.03, and application tree1.exe that uses Stingray TreeView control
version 11.00.

You can configure UFT to support both applications as follows:

1. Run the Stingray Support ConfigurationWizard and configure support for the grid1.exe
application. UFT saves the configuration for this application.

2. Run the Stingray Support ConfigurationWizard again and configure support for the tree1.exe
application. UFT saves the configuration for this application.

After performing these steps, UFT will support the grid1.exe application and support all Stingray
applications that have Stingray TreeView controls version 11.00, including the tree1.exe
application.
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Troubleshooting and Limitations - Stingray Add-in
This section describes troubleshooting and limitations for the Stingray Add-in.

General

l Applying Stingray Support Configuration settings to all users on the computer has no effect on
users that have opened UFT at least once.

Workaround:Apply Stingray Support Configuration settings separately for each user that has
opened UFT at least once.

l UFT does not support both Unicode and non-Unicode in the same application when the Stingray
Add-in is loaded.

Creating and Running Tests and Components

l If your Stingray application was built using the precompiled agent mode and you have used the
Stingray Support ConfigurationWizard at least once to set a Stingray run-time agent, then
recording, learning, or running steps on the applicationmay fail.

l By default, only single-threaded Stingray applications are supported.

To provide support for multithreaded applications, in UFT, select Tools > Options > GUI
Testing tab > Stingray node. Select theSupport multithreaded Stingray applications check
box and click OK. Close and restart UFT.

For details, see "Stingray Pane (Options Dialog Box > GUI Testing Tab)" on page 422.

l The Stingray Add-in does not support Objective Edit or Objective Chart controls.

l TheExpandAllmethod is not supported for Stingray tree controls.

l Whenworking with nested tab controls, youmay need tomanually modify the corresponding
entries in the object repository to enable unique identification. For example, youmay need to add
an ordinal identifier to the existing description.

l Sometimes, theMFC internal map that correlates a window handle of a control with the Visual
C++ object may not contain an entry for all Stingray controls. In such cases, the Stingray Add-in
may fail to recognize certain Stingray controls because it relies on this map when retrieving
information from the application.

Workaround: The Stingray Add-in contains an auxiliary mechanism that serves as a fallback for
the lack of MFC map entries in the situation described above. To activate this mechanism, in
UFT, select Tools > Options > GUI Testing tab > Stingray node. Select theCache MFC
map check box and click OK. Close and restart UFT.
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Workaround: The Stingray Add-in contains an auxiliary mechanism that serves as a fallback for
the lack of MFC map entries in the situation described above. To activate this mechanism, in
UFT, select Tools > Options > GUI Testing tab > Stingray node. Select theCache MFC
map check box and click OK. Close and restart UFT.

Note: This mechanism is not activated by default because it imposes some performance
overhead.

l By default, edit boxes, check boxes, and drop-down (combo) lists are supported when recording
on a Stingray grid. Other types of controls embedded in Stingray grids may be supported partially
or may not be supported at all.

Note: The CGXTabbedComboBox control and the CGXCheckBoxEx control type are not
supported during recording.

Workaround: Towork with controls other than the supported ones, manually add SetCellData
statements to your test or business component (instead of recording user actions inside cells).

l GetCellData andSetCellDatamethods are limited to 3000 characters.

l By default, only the following grid classes are supported:

n CGXBrowserView

n CGXBrowserWnd

n CGXGridWnd

n CGXGridView

n CGXGridHandleView

l When Stingray tree control items have tooltips, recording the selection of an item by clicking its
label may fail.

Workaround:Select the requested item by performing a click on the item's icon.
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Chapter 27: Stingray Add-in - Testing and
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Concepts

Setting Up Stingray Object Support
Before you begin working, you need to configure the Stingray Add-in to work with your application.
UFT support for Stingray objects is based on an agent entity that exists in the Stingray application.
This agent interacts with UFT to enable record and run operations. There are two different modes
for establishing the agent entity:

l Run-time Agent ModeUFT injects an agent .dll into the application's process during run-
time. This is the recommendedmode. For details, see "Stingray Run-time Agent (Agent DLL)"
below.

l Precompiled Agent Mode. Youmake slight modifications to your Visual C++ project in
addition to configuring the Stingray Add-in. Use this mode only if the run-time agent mode is
unsuitable or cannot be used. For details, see "Stingray Precompiled Agent Mode" on the next
page.

You choose your preferredmode and configure support for the Stingray Add-in using the Stingray
Support ConfigurationWizard. For details, see "Stingray Support ConfigurationWizard" on page
408.

After you configure support for the Stingray Add-in, you can fine-tune the configuration options, if
needed. For details, see "Stingray Pane (Options Dialog Box > GUI Testing Tab)" on page 422.

Stingray Run-time Agent (Agent DLL)
When you choose the run-time agent mode, UFT injects an agent DLL into the application's
process during run-time. This recommendedmode is non-intrusive and does not require any
modifications to the source code of the application being tested.

You can use the run-time agent mode only with Stingray applications that are created with
dynamically-linkedMFC libraries. You can verify if your MFC libraries are linked dynamically or
statically by launching the Stingray Support ConfigurationWizard. If the wizard identifies that your
Stingray application uses statically-linkedMFC libraries, it issues a warning.

The run-time agent mode supports themost commonly usedmajor Stingray versions, as well as
some—but not all—minor versions. For a list of supported version combinations, see the
HP Unified Functional Testing Product Availability Matrix, available from the UFT Help or the root
folder of the Unified Functional Testing DVD. You can also verify if your Stingray application
version is supported by launching the Stingray Support ConfigurationWizard. If the wizard
identifies that your Stingray application version is not supported, it issues a warning.

Note: The Stingray Add-in is designed to support only applications that are compiled in
Releasemode.
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If you cannot use the run-time agent mode for any reason, you can still work with your Stingray
application using the precompiled agent mode, instead. For details, see "Stingray Precompiled
Agent Mode" below, or contact HP Software Support.

Stingray Precompiled Agent Mode
If your application is statically linked with theMFC libraries, you can use the precompiled agent
mode to enable Stingray object support. The precompiled agent mode requires you tomake slight
modifications to your Visual C++ project to enable UFT to support your Stingray application. If you
select the precompiled agent mode in the Stingray Support ConfigurationWizard, you can compile
your project using the Stingray Add-in agent files.

Note: If your Stingray application project was compiled with an earlier version of the Stingray
Add-in agent, your project already contains the required support code. To take advantage of the
latest functionality provided with this add-in, it is recommended to remove the existing Stingray
Add-in agent files from your project and recompile using the latest agent files.

Setting up Stingray support using the precompiled agent mode requires adding one support header
file to your application's Visual C++ project and copying one library file to your Visual C++ project
directory. After you complete these steps, you can compile your application, as usual.

Note: Use the precompiled agent mode only if the run-time agent mode is unsuitable or cannot
be used.
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Tasks

How to Set Up Your Stingray Project Using the
Precompiled Agent Mode

Note:

l Use the precompiled agent mode only if the run-time agent mode is unsuitable or cannot be
used.

l For a conceptual overview, see "Stingray Precompiled Agent Mode" on the previous page.

This task includes the following steps:

l "Prerequisites" below

l "Copy StgAgentLib.h and StgAgentLib.lib files" on the next page

l "Add #include "StgAgentLib.h" to a .cpp file" on the next page

l "Add the ReleaseWRVC(); function call" on the next page

l "Make sure that the Precompiled Agent option is selected in the Stingray Support Configuration
Wizard" on page 407

l "Results" on page 407

1. Prerequisites
n Both Stingray Objective Grid and Stingray Objective Toolkit must be installed on your

computer, even if your application contains only one type of Stingray control, such as a grid
control or a tab control.

n The installed versions must match the version combinations supported for this add-in. For a
list of supported version combinations, see theHP Unified Functional Testing Product
Availability Matrix, available from the UFT Help or the root folder of the Unified Functional
Testing DVD.

Note: If you do not have the required Stingray Objective Grid and Stingray Objective
Toolkit version combination, contact HP Software Support for assistance.
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n If your Stingray application was previously compiled with agent files from an earlier version
of the Stingray Add-in, remove the existing agent files from your project.

Caution: If you choose not to replace your existing Stingray Add-in agent files with the
latest agent files, do not continue with this procedure. Although you will be able to work
with the UFT Stingray Add-in, you will not be able to take advantage of the latest
functionality.

2. Copy StgAgentLib.h and StgAgentLib.lib files
a. Copy the StgAgentLib.h header file from <UFT Installation

Folder>\bin\StingrayAgent\
AgentLib\src\StgAgentLib.h to your Visual C++ project directory. (You can optionally
add the header file to the list of header files in your workspace.)

b. Check the version of the Stingray Objective Grid or Stingray Objective Toolkit used by your
application and search for the corresponding support library file, StgAgentLib.lib.

For example, if your application is not compiled in Unicode and uses Objective Grid
version 9.03 andObjective Toolkit version 8.03 linked with MFC version 7.1, search for the
library file in: <UFT Installation Folder>\bin\StingrayAgent\
AgentLib\bin\MFC71\OG903_OT803

If the application is linked with MFC80, is compiled in Unicode and uses Objective Grid
version 10.0 andObjective Toolkit version 9.0, search for the library file in: <UFT
InstallationFolder>\bin\
StingrayAgent\AgentLib\bin\MFC80\OG1000U_OT900U

Note: Each support library file specifies a combination of Objective Grid andObjective
Toolkit versions. Youmust choose a combination of Objective Grid or Objective
Toolkit versions, even if your application uses only one of these Stingray tools. For a
list of supported Stingray version combinations, see theHP Unified Functional Testing
Product Availability Matrix, available from the UFT Help or the root folder of the Unified
Functional Testing DVD.

c. Copy the StgAgentLib.lib support library file to your Visual C++ project directory.

3. Add #include "StgAgentLib.h" to a .cpp file
Add the #include "StgAgentLib.h" statement to one of your cpp files, such as,
MainFrm.cpp.

4. Add the ReleaseWRVC(); function call
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Insert the ReleaseWRVC(); function call in one of the functions called when your application
terminates, for example, CMainFrame::OnDestroy().

Note: Inserting this function call instructs the agent to perform required clean up
operations related to the support library code.

5. Make sure that the Precompiled Agent option is selected in the
Stingray Support Configuration Wizard
For details, see "Stingray Support ConfigurationWizard" on the next page.

6. Results
When you build your application executable, the added header file automatically links the
StgAgentLib.lib support library to your application statically, enabling the library code to be
activated automatically during the run session.
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Reference

Stingray Support Configuration Wizard
The wizard guides you through the steps that are necessary to configure UFT to work according to
the agent mode that you select.

To access Use one of the following:

l Select Tools > Options > GUI Testing tab > Stingray node > Select
Version button.

l From theStartmenu, select All Programs > HP Software > HP Unified
Functional Testing > Tools > Stingray Support Configuration Wizard.

Note: For details on accessing UFT and UFT tools and files inWindows 8,
see "Accessing UFT inWindows 8Operating Systems" on page 547.

Important
information

You can open the Stingray Support ConfigurationWizard from the Additional
Installation Requirements dialog box. You can also open the wizard later by
choosing it from the UFT program group or by activating it from the Stingray pane
of the Options dialog box (Tools > Options > GUI Testing tab > Stingray node).
For details, see "Stingray Pane (Options Dialog Box > GUI Testing Tab)" on page
422.

Relevant
tasks

"How to Set Up Your Stingray Project Using the Precompiled Agent Mode" on
page 405

Wizard
map

The Stingray Support ConfigurationWizard contains:

Welcome Page > Support Mode Selection Page (page 409 > Add Support Code
Page (page 410 > (Select ConfigurationMode Page (page 411) > (Manual
ConfigurationMode Page (page 413) > (Automatic ConfigurationMode Page
(page 415) > (Detected Stingray Components Page (page 417) > (Finish Page
(page 418) > (Detection Failure Page (page 420)

Note: Pages that are in parentheses open according to the option selected in
the previous page. Therefore, not all pages are displayed for every option.

See also l "Setting Up Stingray Object Support" on page 403

l "Stingray Run-time Agent (Agent DLL)" on page 403

l "Stingray Precompiled Agent Mode" on page 404
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Support Mode Selection Page (Stingray Support Configuration
Wizard)

This wizard page enables you to select a Stingray support mode.

Important
information

General information about this wizard is available here: "Stingray Support
ConfigurationWizard" on the previous page.

Wizard
map

The "Stingray Support ConfigurationWizard" contains:

Welcome Page > Support Mode Selection Page > Add Support Code Page
(page 410) > (Select ConfigurationMode Page (page 411) > (Manual Configuration
Mode Page (page 413) > (Automatic ConfigurationMode Page (page 415) >
(Detected Stingray Components Page (page 417) > (Finish Page (page 418) >
(Detection Failure Page (page 420)

Note: Pages that are in parentheses open according to the option selected in
the previous page. Therefore, not all pages are displayed for every option.

See also l "Setting Up Stingray Object Support" on page 403

l "Stingray Run-time Agent (Agent DLL)" on page 403

l "Stingray Precompiled Agent Mode" on page 404
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User interface elements are described below:

UI Elements Description

Run-time
Agent

A simple, non-intrusivemode that adds a support DLL to the Stingray application
process during run-time.

This is the recommendedmode.

Precompiled
Agent

A mode that requires you tomake slight modifications to your Stingray
application project so that UFT can support your Stingray application.

If you select this option and click Next, the Finish page opens.

Add Support Code Page (Stingray Support Configuration Wizard)

This wizard page enables you to access information describing how to add support code to your
Stingray application project.

This wizard page opens if you selected thePrecompiled Agent option in the Support Mode
Selection Page (described on page 411).
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Important
information

l General information about this wizard is available here: "Stingray Support
ConfigurationWizard" on page 408.

l If your Stingray application project is already compiled with an earlier version of
the Stingray Add-in agent, your project already contains the required support
code. However, it is strongly recommended to remove the previous agent files
and to recompile your project with the new Stingray Add-in agent included with
this add-in.

Wizard
map

The "Stingray Support ConfigurationWizard" contains:

Welcome Page > Support Mode Selection Page (page 409 > Add Support Code
Page > (Select ConfigurationMode Page (page 411)) > (Manual Configuration
Mode Page (413) > (Automatic ConfigurationMode Page (415)) > (Detected
Stingray Components Page (page 417) > (Finish Page (page 418) > (Detection
Failure Page (page 420))

Note: Pages that are in parentheses open according to the option selected in
the previous page. Therefore, not all pages are displayed for every option.

See also "Stingray Precompiled Agent Mode" on page 404

User interface elements are described below:

UI
Elements Description

Help Displays information describing how to add support code to your Stingray application
project.

Finish Closes the wizard. If you have not already compiled your application with the
Stingray Add-in agent files, youmust do so before you begin to work with the UFT
Stingray Add-in.

Select Configuration Mode Page (Stingray Support Configuration
Wizard)

This wizard page enables you to select a configurationmode—either automatic or manual—and to
create a diagnostic log file, when needed.
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This wizard page opens if you selected theRun-time Agent option in the Support Mode Selection
Page (described on page 409).

Important
information

l General information about this wizard is available here: "Stingray Support
ConfigurationWizard" on page 408.

l If your Stingray application project is already compiled with an earlier version of
the Stingray Add-in agent, your project already contains the required support
code. However, it is strongly recommended to remove the previous agent files
and to recompile your project with the new Stingray Add-in agent included with
this add-in.

Wizard
map

The "Stingray Support ConfigurationWizard" contains:

Welcome Page > Support Mode Selection Page (page 409) > Add Support Code
Page (page 410) > (Select Configuration Mode Page) > (Manual Configuration
Mode Page (page 413)) > (Automatic ConfigurationMode Page (page 415)) >
(Detected Stingray Components Page (page 417) > (Finish Page (page 418) >
(Detection Failure Page (page 420))

Note: Pages that are in parentheses open according to the option selected in
the previous page. Therefore, not all pages are displayed for every option.

See also "Setting Up Stingray Object Support" on page 403
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User interface elements are described below:

UI Elements Description

Automatic
configuration

Instructs the wizard to configure Stingray support automatically according to the
detectedMFC DLL and the version of Stingray business components used in
your application.

Manual
configuration

Enables you to configure Stingray support manually by specifying theMFC DLL
and Stingray business component version used in your application. This is
useful, for example, if your application is statically linked to the Stingray
libraries.

Create
wizard
configuration
log file

Creates a diagnostic log file.

Select this check box if, at any time, you encounter problems with the Stingray
Add-in.

Note: If you contact HP Software Support for assistance, youmay be
asked to provide this log file for diagnostic purposes.

Manual Configuration Mode Page (Stingray Support Configuration
Wizard)

This wizard page enables you to configure Stingray support manually by specifying theMFC DLL
and Stingray business component version used in your application. This is useful, for example, if
your application is statically linked to the Stingray libraries.
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This wizard page opens if you selected theManual configuration option in the Select
ConfigurationMode Page (described on page 411).

Important
information

l General information about this wizard is available here: "Stingray Support
ConfigurationWizard" on page 408.

l If your Stingray application project is already compiled with an earlier version of
the Stingray Add-in agent, your project already contains the required support
code. However, it is strongly recommended to remove the previous agent files
and to recompile your project with the new Stingray Add-in agent included with
this add-in.

Wizard
map

The "Stingray Support ConfigurationWizard" contains:

Welcome Page > Support Mode Selection Page (page 409 > Add Support Code
Page (page 410 > (Select ConfigurationMode Page (page 411) > (Manual
Configuration Mode Page) > (Automatic ConfigurationMode Page (page 415) >
(Detected Stingray Components Page (page 417) > (Finish Page (page 418) >
(Detection Failure Page (page 420))

Note: Pages that are in parentheses open according to the option selected in
the previous page. Therefore, not all pages are displayed for every option.

See also "Setting Up Stingray Object Support" on page 403
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Automatic Configuration Mode Page (Stingray Support
Configuration Wizard)

This wizard page enables you to instruct to identify the version of Stingray business components
used by your application so that the wizard can set up Stingray support accordingly.

This wizard page opens if you selected theAutomatic configuration option in the Select
ConfigurationMode Page (described on page 413).

Important
information

General information about this wizard is available here: "Stingray Support
ConfigurationWizard" on page 408.

Wizard
map

The "Stingray Support ConfigurationWizard" contains:

Welcome Page > Support Mode Selection Page (409) > Add Support Code Page
(page 410) > (Select ConfigurationMode Page (page 411) > (Manual Configuration
Mode Page (page 413)) > (Automatic Configuration Mode Page) > (Detected
Stingray Components Page (page 417)) > (Finish Page (418)) > (Detection Failure
Page (page 420))

Note: Pages that are in parentheses open according to the option selected in
the previous page. Therefore, not all pages are displayed for every option.

See also "Setting Up Stingray Object Support" on page 403
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User interface elements are described below:

UI
Elements Description

Find Enables you to specify the application executable. Click the Find button and point to
a window or dialog box in your application that contains a Stingray control. UFT
automatically detects and displays the executable in theName of application
executable box.

Note:

l If UFT detects more than oneMFC version, youmust select the relevant
version in the dialog box that opens. For details, see "Multiple MFC
Versions", below.

l You can right-click at any time to cancel the Find command.

Tip: If you want to bring another window into focus or perform operations such
as a right-click or mouseover to display a context menu, you can press and hold
theCTRL key. This temporarily disables the Findmechanism and enables you
to perform regular mouse operations. When the window or dialog box containing
the Stingray control is displayed, release theCTRL key. Note that pressing the
CTRL key does not enable you to select an application from theWindows task
bar, therefore youmust make sure that the window you want to access is not
minimized.

Multiple MFC Versions
If UFT detects more than oneMFC version for the Stingray application, the following dialog box
opens:
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Select the relevant version and click Apply.

Detected Stingray Components Page (Stingray Support
Configuration Wizard)

This wizard page displays the Stingray business components it detected in your application
process.

This wizard page opens if the wizard successfully identified the application executable in the
Automatic ConfigurationMode Page (described on page 415).

Important
information

General information about this wizard is available here: "Stingray Support
ConfigurationWizard" on page 408.

Wizard
map

The "Stingray Support ConfigurationWizard" contains:

Welcome Page > Support Mode Selection Page (page 409) > Add Support Code
Page (page 410) > (Select ConfigurationMode Page (411) > (Manual
ConfigurationMode Page (page 413)) > (Automatic ConfigurationMode Page
(415) > (Detected Stingray Components Page) > (Finish Page (page 418)) >
(Detection Failure Page (page 420)

Note: Pages that are in parentheses open according to the option selected in
the previous page. Therefore, not all pages are displayed for every option.

See also "Setting Up Stingray Object Support" on page 403
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User interface elements are described below:

UI Elements Description

<Stingray
business
components>

TheObjective Grid andObjective Toolkit that the wizard detected in your
application.

Note: If, in the previous screen, you pointed to a non-Stingray application,
or to a Stingray application whose business components UFT could not
detect, a warningmessage displays stating that UFT failed to detect the
Stingray business components in your application.

UFT may fail to detect business components of a Stingray application for
several reasons, for example:

l The applicationmay be statically linked to Stingray libraries, preventing the
wizard from identifying the version of the Stingray libraries. In this case,
click Back twice and selectManual configuration to configure Stingray
support manually. For details, see "Manual ConfigurationMode Page
(Stingray Support ConfigurationWizard) " on page 413.

l The applicationmay be statically linked to theMicrosoft Foundation Class
(MFC) libraries. In this case, click Back three times and select
Precompiled Agent. For details, see "Add Support Code Page (Stingray
Support ConfigurationWizard) " on page 410.

l The selected Stingray versionmay not be supported by the Stingray Add-in,
or may be slightly different from the officially supported versions.

If you need to work with a Stingray version that is not supported, contact
HP Software Support, whomay be able to provide you with a support agent
for your specific version.

Finish Page (Stingray Support Configuration Wizard)

This wizard page indicates that UFT configures Stingray support according to the detected Stingray
version.

Add-ins Guide
Chapter 27: Stingray Add-in - Testing and Configuration

HP Unified Functional Testing (12.00) Page 418 of 549



This wizard page opens if the wizard successfully identified the Stingray business components in
the Detected Stingray Components Page (described on page 417).

Important
information

General information about this wizard is available here: "Stingray Support
ConfigurationWizard" on page 408.

Wizard
map

The "Stingray Support ConfigurationWizard" contains:

Welcome Page > Support Mode Selection Page (page 409 > Add Support Code
Page (page 410 > (Select ConfigurationMode Page (page 411) > (Manual
ConfigurationMode Page (page 413)) > (Automatic ConfigurationMode Page
(page 415) > (Detected Stingray Components Page (page 417) > (Finish Page) >
(Detection Failure Page (page 420)

Note: Pages that are in parentheses open according to the option selected in
the previous page. Therefore, not all pages are displayed for every option.

See also "Setting Up Stingray Object Support" on page 403

User interface elements are described below:

UI Elements Description

<detected
Stingray
version>

Read-only display of the Stingray version detected using the Stingray Support
ConfigurationWizard.
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UI Elements Description

Apply to all
users on this
computer

Applies the identical settings you configured in this wizard for all users on this
computer.

Note: Youmust have administrator permissions on the computer to
configure support for all users. If you do not have administrator
permissions, this option is disabled.

Detection Failure Page (Stingray Support Configuration Wizard)

This wizard page indicates that UFT configures Stingray support according to the detected Stingray
version.

This wizard page opens if the wizard cannot identify the Stingray business components in the
Detected Stingray Components Page (described on page 417).

Important
information

General information about this wizard is available here: "Stingray Support
ConfigurationWizard" on page 408.
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Wizard
map

The "Stingray Support ConfigurationWizard" contains:

Welcome Page > Support Mode Selection Page (page 409) > Add Support Code
Page (410) > (Select ConfigurationMode Page (page 411)) > (Manual
ConfigurationMode Page (page 413)) > (Automatic ConfigurationMode Page
(page 415)) > (Detected Stingray Components Page (page 417) > (Finish Page
(page 418) > (Detection Failure Page)

Note: Pages that are in parentheses open according to the option selected in
the previous page. Therefore, not all pages are displayed for every option.

See also "Setting Up Stingray Object Support" on page 403

User interface elements are described below:

UI Elements Description

Configure the
Stingray version
manually

Opens the "Manual ConfigurationMode Page (Stingray Support
ConfigurationWizard) " (described on page 413) when you select this
option and click Next.

Abandon manual
configuration

Closes the Stingray Support ConfigurationWizard when you select this
option and click Finish.
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Stingray Pane (Options Dialog Box > GUI Testing Tab)
This pane enables you to configure how UFT records and runs tests and business components on
Stingray Objective Grid andObjective Toolkit objects.

To access 1. Do one of the following:

n Ensure that a GUI test, action, or component is in focus in the document
pane.

n Ensure that a GUI test, action, or component is in focus in the document
pane.

2. Select Tools > Options > GUI Testing tab > Stingray node.
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Important
information

l If the Stingray Add-in is configured correctly, youmay not need tomake any
modifications using this pane. However, if you did not run the Stingray Support
ConfigurationWizard after installing the Stingray Add-in, or if you encounter
difficulties when recording and running tests and business components on
Stingray applications, you can use the options in this pane to fine-tune the
configuration. For example, you can enable support for multithreaded
applications by selecting the relevant option in this pane.

After modifying this pane, youmust restart UFT before you continue working
with this add-in.

l TheRestore Factory Defaults button resets all Options dialog box options to
their defaults.

Relevant
tasks

"How to Set Up Your Stingray Project Using the Precompiled Agent Mode" on
page 405

See also "Stingray Support ConfigurationWizard" on page 408

User interface elements are described below:

UI Elements Description

Support
multithreaded
Stingray
applications

Instructs UFT to support multithreaded Stingray applications. If you are not
sure whether you are working with amultithreaded Stingray application, first try
to record and run on your Stingray application without selecting this check box.
If you experience difficulties, you can select this check box and try again.

Select this check box only if you are working with amultithreaded application.

By default, this check box is cleared.

Cache MFC
map

Instructs UFT to use auxiliary caching as a backup for MFC's internal mapping
of window handles to Visual C++ objects. If UFT cannot identify one or more
Stingray controls while recording or running a test or business component, you
can select this check box to instruct UFT to use a cachedmap instead of using
the Stingray application for identification.

By default, this check box is cleared.

Use
displayed
(formatted)
data in table
checkpoints

Instructs UFT to use the formatted data value in the Stingray grid control. You
can use this option when working with table checkpoints (not supported for
business components). For example, if the actual value of a cell in a Stingray
application is formatted to display two digits to the right of the decimal point,
UFT will use that rounded number instead of the actual number when checking
the value during the run session.

By default, this check box is selected.
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UI Elements Description

Record cell
editing
options using

Instructs UFT to record typing operations in a Stingray grid (edit) cell using one
of the following options:

l WinTable.SetCellData statements. (Default) Uses theSetCellData
method to record the final value that you enter in a grid cell. This option
results in a single step in your test or business component. In most cases,
this optionmakes the stepmore readable and easier to modify manually

l WinEditor statements. UFT records each operation that you perform in a
Stingray grid edit cell as a separate WinEditor step. For example,
operations such as placing the cursor in a specific place in the edit box,
typing a single character, or deleting a character may be recorded as
individual steps. This canmake your test or business component less
readable andmore difficult to modify manually, but this may be useful if you
want to test the behavior of specific editing operations.

For a use-case example, see "Record Cell Editing Options - Example" on page
426

Do not use
Stingray Add-
in support for
these
applications:
(Specify
application
process
names
separated by
commas)

Instructs UFT to treat the applications you specify as non-Stingray
applications.

Some open, non-Stingray processes (such as explorer.exe) can cause
unexpected behavior when recording and running tests and business
components on Stingray applications. By adding the process names to this edit
box, you can help prevent this unexpected behavior.

Note:

l In some cases, the executable file you use to open an application is
only a launching process, which then opens the actual application
process. In these cases, make sure that you specify the name of the
actual application process and not the launching process.

l Whenworking with tests, this option is relevant only if you selected the
Record and run test on any open Windows-based application in
the Record and Run Settings dialog box (Record > Record and Run
Settings). For details on the options available, see "Windows
Applications Tab (Record and Run Settings Dialog Box)" on page 109.

Stingray
version

Indicates the versions of the Stingray Objective Grid and Stingray Objective
Toolkit libraries used for identifying Stingray objects in your application (read-
only).
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UI Elements Description

Select
Version

Opens the Stingray Support ConfigurationWizard, which enables you to select
the combination of Objective Grid andObjective Toolkit versions with which
you want to work.

For details, see "Stingray Support ConfigurationWizard" on page 408.

Generate
diagnostic
agent log

Instructs UFT to generate a diagnostic agent log file. You can use this option if
you encounter problems with the Stingray Add-in, for example, if UFT does not
recognize a Stingray grid control while recording. HP Software Support may
ask you to generate this log and send it together with your service request.

When you select this check box, the following options are enabled:

l Include detailed log information for this control

l Log file (C:\st_agent.log)

l External debug application

Note: If you select this check box, youmust specify the location for the
generated log. For details, see "Specify location(s) for the generated log"
on the next page.

Include
detailed log
information
for this
control

Instructs UFT to include detailed information in the generated log for a specific
Stingray control, in addition to the general UFT/agent communication log
information. For example, youmay want to generate additional log details for a
specific Stingray grid.

To select the object for which you want to generate detailed log
information:

Click the pointing hand and then click the relevant Stingray control. The
selected object's window handle is displayed in the edit box.

Note: This option is available only when theGenerate diagnostic agent
log check box is selected.
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UI Elements Description

Specify
location(s) for
the generated
log

Instructs UFT to generate the log to the selected locations. You can select one
or both of the following options:

l Log file (C:\st_agent.log). Saves the diagnostic log to the st_agent.log
text file on your C: drive.

l External debug application. Exports the diagnostic log data to an external
debug application, such as the freeware application, DebugView, or
Microsoft VisualStudio.

Note: These options are available only when theGenerate diagnostic
agent log check box is selected.

Record Cell Editing Options - Example

Suppose that during a recording session, you place the cursor in an edit-type cell that already
contains the value abc. You place the cursor before the b, delete the b and c characters, and then
you type bcde.

If you are using theWinTable.SetCellData statements option, UFT records the following in the
Editor:

Window("GRIDAPP").Window("GridAp1").WinTable("StingrayGrid").SelectCell "#2",
"#3"
Window("GRIDAPP").Window("GridAp1").WinTable("StingrayGrid").SelectCell "#2",
"#3", "abcde"

UFT inserts these steps as follows in the Keyword View:

If you are using theWinEditor statements option, UFT records the following in the Editor:

Window("GRIDAPP").Window("GridAp1").WinTable("StingrayGrid").SelectCell "#2",
"#3"
Window("GRIDAPP").Window("GridAp1").WinEditor("Edit").SetCaretPos 0,1
Window("GRIDAPP").Window("GridAp1").WinEditor("Edit").Type micDel
Window("GRIDAPP").Window("GridAp1").WinEditor("Edit").Type micDel
Window("GRIDAPP").Window("GridAp1").WinEditor("Edit_2").Type "bcde"
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UFT inserts these steps as follows in the Keyword View:
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Chapter 28: Terminal Emulator Add-in -
Quick Reference

The following tables summarize basic information about the Terminal Emulator Add-in and how it
relates to some commonly-used aspects of UFT.

General Information

Add-in Type This is aWindows-based add-in. Much of its functionality is the same as
otherWindows-based add-ins.

See "Windows-Based Application Support" on page 94.

Supported
Environments

For details on supported emulators, see the Terminal Emulator Add-in
section of theHP Unified Functional Testing Product Availability Matrix,
available from the UFT Help or the root folder of the Unified Functional
Testing DVD.

Important
Information

l Before using the Terminal Emulator Add-in for the first time, youmust
enable UFT to identify your terminal emulator.

See "Terminal Emulator ConfigurationWizard Overview" on page 470.

l Youmust configure your terminal emulator settings to work with UFT.

See "How to Set Your HLLAPI Terminal Emulator toWork with UFT" on
page 444.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide.

l See "Checkpoints andOutput Values - Terminal Emulators" on page 440.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

Troubleshooting
and Limitations

"Troubleshooting and Limitations - Terminal Emulator" on page 431

Prerequisites

Opening Your
Application

You can open your Terminal Emulator application before or after opening
UFT and creating a test.

Add-in
Dependencies

None

Configuration
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Wizard "Terminal Emulator ConfigurationWizard Overview" on page 470

Options Dialog Box l Use the Terminal Emulator pane.
(Make sure that a GUI test is open and select Tools >
Options > GUI Testing tab >Terminal Emulator node.)

See "Terminal Emulator Pane (Options Dialog Box > GUI
Testing Tab)" on page 457.

l Use theWindows Applications pane.
(Tools > Options > GUI Testing tab > Windows
Applications node)

See "Windows Applications > General Pane (Options Dialog
Box > GUI Testing Tab)" on page 98.

Custom Active Screen
Capture Settings Dialog
Box
(tests only)

Use the Terminal Emulator section in the dialog box.
(Tools > Options > GUI Testing tab > Active Screen node >
Custom Level)

See the section on the Custom Active Screen Capture Settings
dialog box in theHP Unified Functional Testing User Guide.

Application Area
Additional Settings pane
(business components only)

Use theApplications pane.
In the application area, click Additional Settings >
Applications in the sidebar.

See the section on the Applications pane in theHP Unified
Functional Testing User Guide.

This chapter includes:

Troubleshooting and Limitations - Terminal Emulator 431

Add-ins Guide
Chapter 28: Terminal Emulator Add-in - Quick Reference

HP Unified Functional Testing (12.00) Page 430 of 549



Troubleshooting and Limitations - Terminal Emulator
This section contains general troubleshooting and limitation information about theWeb add-in, and
includes the following sections:

l "Installing and Loading the Terminal Emulator Add-in" below

l "Connecting and Disconnecting from the Terminal Emulator Add-in" on the next page

l "Configuration and Settings" on the next page

l "Creating and Running Tests and Components" on page 433

l "Working with Terminal Emulator Controls" on page 434

l "Test Objects, Methods, and Properties" on page 434

l "Checkpoints andOutput Values " on page 435

l "Multilingual Support" on page 435

Installing and Loading the Terminal Emulator Add-in

l When installing a Hummingbird HostExplorer terminal emulator or patches, make sure that UFT
is closed.

l If the UFT Terminal Emulator Add-in is installed and loaded, but there is no terminal emulator
installed on your computer, the following error message is displayed: UFT Terminal Emulator
support is not configured correctly. Either the terminal emulator is not
installed on your computer or the HLLAPI DLL was not found.

Workaround:When you open UFT, clear the Terminal Emulators check box in the Add-in
Manager.

Note: You can prevent this message from appearing by adjusting your emulator's
configuration settings. For more details, see "How toManage Terminal Emulator
Configuration Settings" on page 449.

l Youmay experience unexpected behavior after you install an EXTRA! emulator. Youmay not be
able to run UFT or various features may stop working. This happens because the EXTRA!
installationmay have copied and registered an outdated version of the atl.dll file on your
computer.

Workaround: Locate the atl.dll in your system folder (WINNT\system32). Its version should
be 3.0 or higher. Register it with the regsvr32 utility.
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Connecting and Disconnecting from the Terminal Emulator Add-in

l If you havemore than one terminal emulator session open, UFT does not recognize either
session.

Workaround:While recording or running your test or business component, make sure that only
one terminal emulator session is connected at a time.

l If your test or business component contains steps that disconnect the current emulator session
during the run session, followed immediately by a TeScreen.Sync command, the test or
business component runmight stop responding or take a long time to respond.

Workaround: Remove the Sync command from the test or business component, or replace it
with a Wait statement. For more details, see theUtility Objects section of theHP UFT Object
Model Reference for GUI Testing.

l Inserting a checkpoint, creating a new test or business component, or opening an existing test or
business component when the emulator session is busy may cause unexpected problems.

Workaround:Check the connection status of your emulator on the status line of the emulator
screen before performing any of these operations.

l Unexpected behavior may occur after disconnecting from aHost On-Demand session while
recording.

Workaround:Stop recording before disconnecting from the session. Then, manually add a step
that disconnects from the session.

l Youmay experience unexpected behavior if the terminal emulator is closed while UFT is
recording.

Configuration and Settings

l Whenworking with an emulator that does not support HLLAPI, or with an emulator that has been
configured as supporting text-only HLLAPI operations, do not change the size of the terminal
emulator window after configuring the emulator settings.

l To enable support for a NetManageWeb-To-Host Java Client session that is configured to open
in a separate window, specify the title of your session window using the Tools > Options >
GUI Testing tab > Terminal Emulator > Adjust Configuration > Object identification
settings > Identify emulator window based on title bar prefix option.

Tip: Youmay need to clear this value when switching to another configuration.

l When using the Terminal Emulator ConfigurationWizard to configure the screen sizes of
NetManage RUMBAWeb-to-Host, you cannot use theMark Text Area option to draw on top of
the emulator window.

Workaround:Configure the text area position of the screenmanually.
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Creating and Running Tests and Components

l When using the OCR mechanism in order to perform steps requiring text recognition on non-
HLLAPI emulators, the steps run slowly due to the required processing power of the OCR
mechanism. Therefore, when testing non-HLLAPI emulators, it is recommended to select the
default text recognition option: First Windows API then OCR in the Text Recognition pane of
the Options dialog box. (For details on this option, see theHP Unified Functional Testing User
Guide.)

l The UFT Terminal Emulator Add-in can identify emulator window objects only when the
emulator is connected. For example, you cannot use the following statement to connect to an
emulator session:

TeWindow("TeWindow").WinMenu("Menu").Select "Communication;Connect"

Workaround: You can record any steps that need to be performed prior to connection with the
emulator. These steps are recorded as if the Terminal Emulator Add-in is not loaded. After the
emulator is connected, stop the recording session and begin a new recording session to record
terminal emulator objects.

l When using an emulator that supports HLLAPI, if your emulator session disconnects from the
host while recording, UFT no longer recognizes the emulator, even after reconnecting.

Workaround: Stop recording, reconnect the session, and continue recording.

l When recording on a Hummingbird HostExplorer emulator, menu and toolbar operations in the
emulator window are disabled.

Workaround:Stop recording, select the requiredmenu item or click the required toolbar button,
and continue recording.

l When using an emulator that supports HLLAPI, closing the emulator window while recording
may cause unexpected results.

Workaround:Stop recording before closing the emulator window.

l The UFT Terminal Emulator Add-in does not support recording operations on toolbar objects in
terminal emulator applications.

Workaround:Record on the correspondingmenu command for the toolbar button. Alternatively,
you can use low-level recording to record operations on toolbars. For more details about low-
level recording, see theHP Unified Functional Testing User Guide.

l If you record a test or business component using one terminal emulator, it may not run correctly
on another terminal emulator. For example, tests recorded on RUMBA may not run on IBM
PCOM.
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l HostExplorer has a bug in the HLLAPI GetKey function. As a result, UFT will stop recording
terminal emulator keyboard events after recording for a while, and the emulator might stop
responding to keyboard events.

Workaround:Contact Hummingbird customer support to get the patch that fixes the problem
with the HLLAPI GetKey function (where it stops responding after several calls).

l Clicking, typing, or moving objects in the terminal emulator window while UFT is running a test
or business component may cause unexpected results.

Workaround:Wait until the end of the test or business component, or pause the test or
business component execution before using the emulator.n

l To record and run tests or business components on Hummingbird 9.0 5250 sessions, you need
to install a patch for Hummingbird.

Workaround:Contact Hummingbird customer support to get the patch that fixes the problem
with HLLAPI where all 5250 fields appear protected.

l Youmight encounter unexpected results when you run the Reflection HLL API in multiple
threads mode.

Working with Terminal Emulator Controls

l Whenworking with Attachmate Terminal Viewer 3.1 5250 session, all of the fields that appear
on the screen before the first unprotected field are recognized as a single field.

l UFTmay not recognize a TeField object in a NetManage RUMBA session immediately after
installing the emulator.

Workaround:Restart your computer after installing RUMBA, even if the installation does not
request a restart.

Test Objects, Methods, and Properties

l When using theSendKeymethod to unlock a terminal emulator, for example, TeWindow
("TeWindow").TeScreen("screen5296"). SendKey TE_RESET, some emulators (such as
Host On-Demand) may not be unlocked.

Workaround:Specify the keyboard event to send for the RESET command, using the Tools >
Options > GUI Testing tab > Terminal Emulator pane > Adjust Configuration > Run
Settings > Run steps containing special emulator keys using keyboard events > Keys
for RESET function option.

l By default, UFT uses the attached text and protected properties in TeField test object
descriptions. If the attached text for a field changes from session to session, UFT cannot find
the field during the run session.

Add-ins Guide
Chapter 28: Terminal Emulator Add-in - Quick Reference

HP Unified Functional Testing (12.00) Page 434 of 549



Workaround:Open theObject Repository Window or the Object Repository Window for the
object. Remove the attached text property from the field's description and add another property
(or properties) such as start row, start column, or index to uniquely identify the object.

Tip: You can also create a smart identification definition for TeField objects so that your
recorded test or business component can run successfully even if the attached text
property value for a particular TeField object changes. (Select Tools > Object
Identification > Enable Smart Identification and click Configure.) For more details on
Smart Identification, see theHP Unified Functional Testing User Guide.

l You cannot use the label property in a programmatic description of the TeScreen object.
However, since only one screen can exist in the given TeWindow at any one time, you can use
TeScreen("MicClass:=TeScreen").

For example:

TeWindow("short name:=A").TeScreen("MicClass:=TeScreen").TeField("attached
text:=User", "Protected:=False").Set "33333"

l The TeTextScreen properties current column and current row are available only for emulators
that support HLLAPI.

l The location property is not recorded for TeField objects.

Workaround:Use the index property instead.

Checkpoints and Output Values
In some cases, a bitmap checkpoint on a TeScreenmay fail because the cursor shows in the
expected bitmap, and not in the actual bitmap (or the other way around).

Workaround:Set the emulator cursor to a slow blink rate, or not to blink at all. This enhances the
probability that the cursor is not captured in the bitmap.

Multilingual Support
Whenworking with the IBM PCOM emulator, UFT may ignore special European language
characters while recording or running a test or business component.

Workaround:Set the code page for your IBM PCOM emulator in UFT, using the Tools > Options
> GUI Testing tab > Terminal Emulator > Adjust Configuration > Emulator settings > Code
page number (IBM PCOM only) option.

Tip: Try setting theCode page number (IBM PCOM only) option to 1252.
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Concepts

Terminal Emulator Add-in - Overview
You can use UFT with the Terminal Emulator Add-in to test terminal emulator applications that
support HLLAPI (High Level Language Application Programming Interface) as well as those that do
not, for example, emulator sessions configured to work with the VT100 protocol (using the Text-
only option). HLLAPI allows a PC application to communicate with amainframe application with
extended capabilities.

UFT distinguishes between the window of the terminal emulator and the screens in the host
application. The terminal emulator window consists of the frame, menus, toolbar, and status bar of
the terminal emulator itself. This window remains constant throughout each terminal emulator
session.

The terminal emulator screen refers to the area of the window in which the application is displayed.
Each time the host responds to user input to the application, the screen changes.

If your emulator supports HLLAPI, UFT recognizes the screen and field objects in your emulator
screen. If your emulator does not support HLLAPI, or you have configured UFT in Text-onlymode,
UFT records operations in terms of the text as it appears in the rows and columns of your emulator
screen.

The UFT Terminal Emulator Add-in includes preconfigured settings for several terminal emulators.
The Terminal Emulator Add-in also enables you to configure the settings for most other terminal
emulators using the "Terminal Emulator ConfigurationWizard Overview" on page 470.

To configure your HLLAPI emulator to work with UFT, see "How to Set Your HLLAPI Terminal
Emulator toWork with UFT" on page 444.
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Recording Tests and Components on Terminal Emulator
Applications

As you record, the test or business component reflects the objects in your application and the type
of operation you perform (such as pressing function keys or typing in fields). Each object has a
defined set of properties that determines its behavior and appearance. UFT learns these properties
and uses them to identify and locate objects during a run session.

Tip: You can launch your terminal emulator using theSystemUtil.Runmethod as the first step
of your test or business component. For more details, see the section in theHP Unified
Functional Testing User Guide on running and closing applications programmatically, and the
Standard Windows section of theHP UFT Object Model Reference for GUI Testing.

By default, when you record a test or business component, UFT automatically inserts
synchronization points so that during a run session, execution will be delayed until the application is
ready to receive input. You can also add synchronization points manually. For more details, see
"How to Synchronize Steps on Terminal Emulators" on page 450.

The following is a sample of a UFT test recorded on a terminal emulator application that fully
supports HLLAPI.

While recording, the user pressed theENTER key in the first screen of an application, waited for
the screen to change, and then typed the name MERCTEST and a password in the appropriate fields.

TeWindow("TeWindow").TeScreen("Welcome").SendKey TE_ENTER
TeWindow("TeWindow").TeScreen("Welcome").Sync
TeWindow("TeWindow").TeScreen("Sign On").TeField("User").Set "MERCTEST"
TeWindow("TeWindow").TeScreen("Sign On").TeField("Password").SetSecure "3c4f
eb5bc6233d6e6898bc"

UFT displays this test in the Keyword View like this:
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The following is a sample test on a terminal emulator that does not support HLLAPI or that has been
configured to support text-only HLLAPI operations.

Note that UFT records the TeTextScreen object instead of the TeScreen object and that it does not
record TeField objects. The operations are recorded in terms of keyboard andmouse operations on
the text screen, rather than operations within fields.

TeWindow("TeWindow").TeTextScreen("TeTextScreen").ClickPosition 24,2
TeWindow("TeWindow").TeTextScreen("TeTextScreen").Type "l"
TeWindow("TeWindow").TeTextScreen("TeTextScreen").Type micReturn
TeWindow("TeWindow").TeTextScreen("TeTextScreen").WaitString"FRSMAIN",1,2,1,
8,2000
TeWindow("TeWindow").TeTextScreen("TeTextScreen").Type "qa1"
TeWindow("TeWindow").TeTextScreen("TeTextScreen").Type micReturn
TeWindow("TeWindow").TeTextScreen("TeTextScreen").Sync

UFT displays this test in the Keyword View like this:

This section also includes "Considerations for Recording and Running Tests and Components on
Terminal Emulators" below.

Considerations for Recording and Running Tests and Components
on Terminal Emulators

l Connect your emulator to the host and ensure that the emulator is configured properly. For
details, see "How to Set Your HLLAPI Terminal Emulator toWork with UFT" on page 444.

l Make sure that only one terminal emulator session is open. (Multiple open sessions may cause
problems with recording and running tests or business components.)

l If your test or business component includes calls toWinRunner tests, make sure that these
tests do not use theWinRunner Terminal Emulator Add-in. Similarly, when runningWinRunner
tests with theWinRunner Terminal Emulator Add-in, make sure that these tests do not use the
UFT Terminal Emulator Add-in if they include calls to UFT tests.

l If you are using an emulator that is configured as fully supporting HLLAPI and you need to record
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specific steps in terms of keyboard andmouse operations on the text screen (instead of
operations within fields), you can change the recordingmode for your emulator by adjusting the
configuration. For details, see "How toManage Terminal Emulator Configuration Settings" on
page 449.

l UFT does not record operations on the toolbar and status bar in the terminal emulator window.
However, you can insert checkpoints or output values for the status bar of the terminal emulator
window while recording. For more details, see "Checkpoints andOutput Values - Terminal
Emulators" below.

Checkpoints and Output Values - Terminal Emulators
While recording your test, you can add text checkpoints for the following:

l TeScreen and TeTextScreen objects

l status bar of the terminal emulator window

l dialog boxes that open after menu options are selected

While editing your test or business component, you can:

l add text checkpoints for TeScreen objects.

l add text checkpoints for TeTextScreen objects if the test was recorded using an emulator with
full HLLAPI support that was configured to record in Text screenmode. For details on changing
the emulator mode, see "How toManage Terminal Emulator Configuration Settings" on page
449.

l output property or text values from the objects in your terminal emulator application to use in
your test or business component.

Guidelines for Using Checkpoints and Output Values

l You can create bitmap checkpoints for TeWindow, TeScreen and TeTextScreen objects, but not
for TeField objects.

l You can create text output values (tests only) only for TeScreen and TeTextScreen objects.

l In the terminal emulator window you can add text checkpoints or output values (tests only) and
standard checkpoints and output values for the status bar and the dialog boxes that open from
themenu options. UFT recognizes these as standardWindows objects. For more details on the
properties of standardWindows objects, see theHP UFT Object Model Reference for GUI
Testing.

For details on standard, text, and bitmap checkpoints, and on standard and text output values, see
theHP Unified Functional Testing User Guide.
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Run Session Synchronization
When testing a terminal emulator application, many factors can affect its speed of operation and
therefore can potentially interfere with the run session. For example, host response time can vary
depending on the system load.

Synchronizing your run session helps to ensure that UFT performs the next step in the test or
business component only when your terminal emulator application is ready to continue. This
prevents incidental differences in host response time and other factors from affecting successive
run sessions.

The following table illustrates the synchronization options available for various terminal emulator
applications:

Emulator
type Synchronization options

All
emulator
types

You can instruct UFT to delay the run session:

l For a specified period of time

l Until a specific string appears in a defined area

l Until a specified property achieves a defined value

Emulators
that fully
support
HLLAPI

You can synchronize the run session with the response time of the host. By default,
during a record session, UFT automatically generates a Sync statement for the
TeScreen object each time the emulator waits for a response from the host.

Emulators
that do
not
support
HLLAPI

When you record using a terminal emulator that does not support HLLAPI, or that
has been configured as supporting text-only HLLAPI operations, UFT automatically
generates a Sync statement for the TeTextScreen object each time a specified key
is pressed. The default is theENTER key. UFT waits a specified period of time, to
allow the host sufficient response time.

For a list of tasks describing how to synchronize, see "How to Synchronize Steps on Terminal
Emulators" on page 450.

Terminal Emulator Recovery Scenarios
UFT allows you to define recovery scenarios for your tests or business components, to cater for
various unexpected events, such as crashes and error situations, which can disrupt your tests or
business components and distort your results.

You can use the values of theEmulator status property and the other properties of the TeWindow
object to define specific recovery scenarios for your terminal emulator application tests or business
components.
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The possible values for theEmulator status property are:

l Busy. Emulator is communicating with the server.

l Disconnected. Emulator is not connected to the server.

l Locked. Emulator cannot currently accept input.

l Ready. Emulator is waiting for input.

l Unavailable. Emulator status cannot be identified.

For each emulator status, you can create a recovery scenario that performs an appropriate recovery
operation. For example:

l Disconnected. Reconnect to the server, using a function call recovery operation that includes
recorded steps for connecting, API commands in a VB Script, or a keyboard shortcut key,
according to the capabilities of your terminal emulator.

l Ready. Perform specific operations according to the content of a displayed error message,
including pressing the relevant key.

l Locked. Activate the emulator's RESET key, or use a handler function to disconnect from the
server and reconnect.

For more details on defining recovery scenarios, see theHP Unified Functional Testing User Guide.
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Tasks

How to Check the Validity of a Terminal Emulator
Configuration

1. Make sure that a GUI test is open.

2. Open the Terminal Emulator pane of the Options dialog box (Tools > Options > GUI
Testing tab > Terminal Emulator node) (described on page 457).

3. Click Validate.

If a problem is detected, a brief description (error response) is displayed in the pane. For details
on handling the error, click Troubleshoot to open a Help page that displays error-specific
information.

How to Copy Existing Terminal Emulator Configurations
This task describes how to copy a terminal emulator configuration from another user who has
already configured the UFT settings for a specific emulator using the Terminal Emulator
ConfigurationWizard.

For example, if the settings for your terminal emulator were configured and saved to a file on
another computer (or on a network drive), you can copy this file to your computer, instead of running
the wizard and configuring the settings yourself.

This task includes the following steps:

l "Prerequisites" below

l "Copy the registry file to your computer" on the next page

l "Register the file" on the next page

l "Set the new emulator as the default emulator - Optional" on the next page

l "Modify the emulator settings - Optional" on the next page

l "Results" on the next page

1. Prerequisites
n The existing configuration file must be saved to a registry file, using theSave terminal

emulator settings to file option in the wizard's final page. For details, see "Completing the
Terminal Emulator ConfigurationWizard Page " on page 484.

n Before you copy the saved configuration, make sure you know the vendor name and the
emulator name assigned to the configuration, and the exact name and location of the file.

HP Unified Functional Testing (12.00) Page 443 of 549



The file has a .reg extension.

2. Copy the registry file to your computer
a. Locate the registry file containing the configuration settings for your emulator. The file has a

.reg extension.

b. Copy the file to the <UFT installation folder>\dat folder on your computer.

The path for the dat folder in a typical installation is: %ProgramFiles%\HP\Unified
Functional Testing\dat

3. Register the file
a. Double-click the registry file to open the Registry Editor message box.

b. Click Yes to add the information into the registry. A message opens confirming that the
information has been copied into the registry.

c. Click OK. The emulator name assigned to this configuration is added to the list of available
terminal emulators for your UFT installation.

4. Set the new emulator as the default emulator - Optional
a. Open UFT with the Terminal Emulator Add-in loaded.

b. Select the new emulator name from the list in the Tools > Options > GUI Testing tab >
Terminal Emulator pane, and set it as your default emulator.

5. Modify the emulator settings - Optional
a. Open UFT with the Terminal Emulator Add-in loaded.

b. Open the Terminal Emulator ConfigurationWizard. For details, see "Terminal Emulator
ConfigurationWizard Overview" on page 470.

6. Results
After you copy a configuration file from another location, the emulator name assigned to this
configuration is added to the list of available terminal emulators for your UFT installation.

Note: If you copy a configuration file after starting UFT, you need to close and reopen UFT
to see the updated list of available emulators.

How to Set Your HLLAPI Terminal Emulator to Work with
UFT

The steps below provide a general overview of how to enable testing on your terminal emulator
application when working with an emulator that supports HLLAPI. For details on how to configure a
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specific emulator, see "How to Configure an Emulator toWork with the Terminal Emulator Add-in"
below.

1. Connect your emulator to the host before running the Terminal Emulator ConfigurationWizard
and before recording each test or business component.

2. Assign the uppercase letterA as the short name for the current emulator session.

3. (Optional) Restart the emulator after changing these settings.

Note: For details on supported emulator versions and protocols, see theHP Unified Functional
Testing Product Availability Matrix, available from the UFT Help or the root folder of the Unified
Functional Testing DVD.

How to Configure an Emulator to Work with the Terminal
Emulator Add-in

This section describes how to configure an emulator to work with the Terminal Emulator Add-in:

"Attachmate EXTRA!" below

"AttachmatemyEXTRA! Terminal Viewer" on the next page

"Attachmate INFOConnect" on the next page

"Hummingbird HostExplorer" on page 447

"IBM Personal Communications (PCOM)" on page 447

"IBMWebSphere Host On-Demand" on page 447

"NetManange RUMBA" on page 448

"NetManage RUMBAWeb-to-Host" on page 448

"Seagull BlueZone" on page 449

"WRQReflection" on page 449

"Zephyr Passport" on page 449

Attachmate EXTRA!
To connect your EXTRA! terminal emulator to UFT:

1. Open EXTRA!.

2. In EXTRA!, select Options > Global Preferences. TheGlobal Preferences dialog box opens.

3. Click theAdvanced tab.
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4. In the HLLAPI shortname list, select the uppercase letterA as theShort Name.

5. Click the browse button, browse to and select your session profile, and click OK.

6. Save the profile before you start testing with UFT. This enables you to configure the terminal
emulator once and then reuse the saved settings.

Attachmate myEXTRA! Terminal Viewer
To connect your myEXTRA! terminal viewer to UFT:

1. Open themyEXTRA! Management and Control Services window.

2. In theManagement and Control Services window, select Products > Terminal Viewers. The
Terminal Viewers tree is displayed in the left pane.

3. In the Terminal Viewers tree, select the required terminal.

4. In the right pane, select the required session and click Properties.

5. In the Properties pane, click Configure to configure the connection.

6. In theGeneral tab of the Configure pane, select theSupport HLLAPI check box and set the
session name toA.

7. Save the session.

8. If this is the first time that you are connecting to amyEXTRA! terminal viewer, install the
HLLAPI DLL, as follows:

a. Click Preferences.

b. Click the Install HLLAPI Client Components link.

Attachmate INFOConnect
To connect your INFOConnect terminal emulator to UFT:

1. Open Attachmate INFOConnect.

2. Select Options > Global Preferences from themainmenu.

3. Select theAdvanced tab.

4. Select A as the session short name.

5. To associate the session short name (A), with your session, click Browse and locate your
session profile in the file system.

6. Click OK.
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Hummingbird HostExplorer
To connect your HostExplorer terminal emulator to UFT:

1. Open HostExplorer.

2. From the HostExplorer mainmenu, select File > Save Session Profile.

3. In the Save Profile dialog box, set theHLLAPI Short Name to the uppercase letterA.

4. From themainmenu, select Options > API Settings.

5. In the API Global Settings dialog box, select theUpdate screen after PS update andAuto
sync options.

6. Click OK.

Alternatively:

1. Open HostExplorer.

2. Open a saved session.

3. Select Options > Edit Session Profile.

4. Select Terminal > API in the categories tree.

5. Select A as the session short name and click OK.

6. Save the session profile.

IBM Personal Communications (PCOM)
The preconfigured settings enable UFT to work with IBM PCOM terminal emulators.

IBMWebSphere Host On-Demand
To connect your WebSphere Host On-Demand terminal emulator to UFT:

1. Open theWebSphere Host On-Demand EHLLAPI Enablement Tool. (If you do not have this
tool, contact IBM for details on how to acquire and install it.)

2. To enable UFT to record on the IBMWebSphere Host On-Demand terminal emulator, define
the session options as follows:

a. Click Configure and select Properties from the list. Then select Preferences > Start
Options and set Auto-Start HLLAPI Enabler toYes.

b. Set theStart In Separate Window option toYes.

c. Set theAlternate Terminal option toDisable.
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Make sure that the server and client are not installed on a computer on which another terminal
emulator is installed.

NetManange RUMBA
To connect your RUMBA terminal emulator to UFT:

1. Open RUMBA.

2. In RUMBA, select Options > API. The API Options dialog box opens.

3. Click the Identification tab.

4. In theSession Short Name field, type the uppercase letterA.

5. Click OK.

6. Save the profile.

Tip: It is recommended to save the profile before you start testing with UFT. This enables
you to configure the terminal emulator once and then reuse the saved settings.

NetManage RUMBA Web-to-Host
To connect your RUMBA Web-to-Host terminal emulator to UFT:

1. Open the RUMBAWeb-to-Host Session ConfigurationManager and open a session.

2. In addition to your standard configuration steps in the ConfigurationManager:

a. Select Pro client from the Implementation drop-down list.

b. Click HLLAPI Configuration and select A from theSession Short Name drop-down list.

3. Save the profile.

Note:

n For versions 5.x: Only MainframeDisplay is supported for the Java client Only Replay
is supported for both Java client and Pro client.

n For version 6.x: Java Client is not supported. Only Replay is supported for Pro client.

For more details on supported versions RUMBAWeb-to-Host, see theHP Unified Functional
Testing Product Availability Matrix, available from the UFT Help or the root folder of the Unified
Functional Testing DVD.
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Seagull BlueZone
To connect your BlueZone terminal emulator to UFT:

1. Open BlueZone.

2. In BlueZone, select Options > API. The API Properties dialog box opens.

3. Click theOptions tab.

4. In theShort NameSession Identifier field, type the uppercase letterA.

5. Click OK.

6. Save the session.

WRQReflection
To connect your Reflection terminal emulator to UFT:

1. Open a new or existing session.

2. Select Setup > Terminal.

3. In theShort Name field, type the uppercase letterA.

4. Click OK.

Zephyr Passport
To connect your Zephyr Passport terminal emulator to UFT:

1. Open a new or existing session.

2. Check that the session shortname (A) Passport.zws appears in the window title bar.

How to Manage Terminal Emulator Configuration
Settings

The following steps describe how tomanage your terminal emulator configuration settings.

l "Change configuration settings" below

l "Restore default settings for the selected preconfigured emulator" on the next page

l "Restore settings for a user-defined configuration" on the next page

Change configuration settings
The Terminal Emulator Configuration Adjustments dialog box contains check boxes, radio buttons,
and options that require a numeric or text value.
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1. Open the "Terminal Emulator Configuration Adjustments Dialog Box", as described on page
457.

2. Enter a numeric or text value for an option:

a. Click the option once to highlight it.

b. Click the option again or press F2 to access the value to be changed.

c. Change the value as necessary.

d. Click another location in the dialog box to set the value.

3. Click OK to update the current terminal emulator configuration and close the dialog box.

Restore default settings for the selected preconfigured emulator

1. Open the "Terminal Emulator Configuration Adjustments Dialog Box", as described on page
457.

2. Click theReset button. (This button is enabled only if a preconfigured emulator is selected.)

Restore settings for a user-defined configuration

1. Locate the saved registry file that contains the configuration settings in the <UFT
installation folder>\dat folder on your computer. The file has a .reg extension. (The path
for the dat folder in a typical installation is: %ProgramFiles%\HP\Unified Functional
Testing\dat.)

2. Double-click the registry file to activate the registry file. A confirmationmessage opens.

3. Click Yes. A message opens confirming that the information was copied into the registry.

4. Click OK. The settings in the saved file are restored.

Tip: You can also restore the settings for a user-defined terminal emulator, if these
settings were saved previously using the wizard. For details, see "Completing the
Terminal Emulator ConfigurationWizard Page " on page 484.

How to Synchronize Steps on Terminal Emulators
The following steps describe how to perform various types of synchronization operations. For
conceptual details, see "Run Session Synchronization " on page 441.

l "Insert a synchronization step while recording" on the next page

l "Set synchronization timeout" on the next page
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l "Insert a synchronization point for an object" below

l "Wait for a specified text string" on the next page

Insert a synchronization step while recording

1. Select Design > Emulator Synchronization.

2. (Optional) Specify a timeout in milliseconds for the Sync statement, after which the run session
continues regardless of the status of the emulator. If you do not specify a timeout value, UFT
uses the default timeout interval, as described in "Set synchronization timeout" below.

Note:

n You can adjust your emulator configuration to prevent UFT from automatically inserting
Sync steps for TeScreen objects in your test or business component.

n You can specify the keys that generate Sync steps for TeTextScreen objects.

For details, see "How toManage Terminal Emulator Configuration Settings" on page 449

Set synchronization timeout
In the Run Pane of the Test Settings Dialog Box (File > Settings > Run node), set theObject
Synchronization Timeout. For details, see theHP Unified Functional Testing User Guide.

This enables you to specify themaximum interval (in milliseconds) that UFT waits before running
each test step.

Note:

l This option is not available for business components.

l This setting is also used as the default timeout for theSync andWaitStringmethods for
both the TeScreen and the TeTextScreen objects if a timeout argument is not specified.

Insert a synchronization point for an object
Select Design > Synchronization Point. For details, see theHP Unified Functional Testing User
Guide.
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When you insert a synchronization point into your test or business component, UFT generates a
WaitProperty statement in the Editor. This statement instructs UFT to pause the test or business
component until a particular object property achieves the value you specify.

Example:

If you want the run session to wait until the Text property of theResult field has a value of
Successful, insert the following statement:

TeScreen("LogOn").TeField("Result").WaitProperty "Text", "Successful"

Wait for a specified text string
UFT'sWaitStringmethod delays the run session until a specific text string appears in a specified
rectangle on the terminal emulator screen. The specified text string can be a constant string or a
regular expression.

To insert a WaitString statement while recording:

1. Select Design > Emulator WaitString. Your cursor becomes a crosshairs pointer.

2. Drag the pointer to draw a rectangle on your emulator screen containing the text string for
which you want the run session to wait. UFT inserts a step into your test or business
component with the following syntax:

TeScreen object:

TeScreen(description).WaitString String [, TopRow, LeftColumn,
BottomRow, RightColumn, Timeout, RegExp]

TeTextScreen object:

TeTextScreen(description).WaitString String, [TopRow, LeftColumn,
BottomRow, RightColumn, Timeout, RegExp]

The position on the screen is defined by the values of the four corners of the rectangle, each
corner with its own argument.

3. Optionally, you can:

n Specify that the value specified in theString argument is a regular expression by setting the
value of theRegExp argument to True. Regular expressions enable UFT to identify objects
and text strings with varying values. For more details on regular expressions, see the
HP Unified Functional Testing User Guide.

n Add a timeout value in milliseconds after which the run session continues regardless of
whether the text string appears on the screen. If you do not specify this value, UFT uses the
default timeout interval. For details, see "Set synchronization timeout" on the previous page.
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Reference

Test Object Classes and Icons - Terminal Emulators
The following test object classes and icons apply to terminal emulators that are configured as fully
supporting HLLAPI:

Icon Test Object Class

TeField

TeScreen

TeWindow

The following test object classes and icons apply to terminal emulators that do not support HLLAPI
or that have been configured as supporting text-only HLLAPI operations:

Icon Test Object Class

TeTextScreen

TeWindow

The following test object classes and icons apply to theWindows objects for the terminal emulator
window status bar and the dialog boxes that open from themenu options in the terminal emulator
window:

Icon Test Object Class

Dialog

WinObject

Validating a Terminal Emulator - Possible Error
Responses

The following possible error responses may be displayed in the Terminal Emulator pane of the
Options dialog box (Tools > Options > GUI Testing tab > Terminal Emulator node) when you
click theValidate button:

l "Invalid HLLAPI DLL" on the next page

l "Cannot detect an open session" on the next page

l "Cannot locate themain window class " on the next page
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l "Cannot detect the emulator screen" on the next page

l "Cannot connect to the open session" on the next page

l "Cannot retrieve session text" on the next page

l "Cannot detect open session, or Cannot locate themain window class" on the next page

l "HLLAPI DLL not found" on page 456

l "More than one session open" on page 456

l "Unknown error" on page 456

Invalid HLLAPI DLL

The required HLLAPI or EHLLAPI function cannot be found, because the configured DLL is invalid.

Ensure that you have configured the correct DLL path and name in the Terminal Emulator
ConfigurationWizard (Tools > Options > GUI Testing tab > Terminal Emulator node > Open
Wizard).

For more details, see the table listing the DLL names used by supported terminal emulators in
"Configure HLLAPI Properties Page" on page 475, or the documentation provided by your emulator
provider.

Cannot detect an open session

UFT cannot detect an open terminal emulator session.

l Ensure that you have opened a current session in your terminal emulator.

l For HLLAPI emulators, ensure that the emulator short session name is set to the uppercase
letter A. Youmay need to restart the emulator after changing this setting.

Cannot locate the main window class

UFT cannot find the terminal emulator main window class name.

l Ensure that the terminal emulator main window class name is configured correctly in the
Terminal Emulator ConfigurationWizard (Tools > Options > GUI Testing tab > Terminal
Emulator node > Open Wizard).

l If themain window class name has a postfix that changes each time you launch the emulator,
enter only the non-changing portion of the name in the Terminal Emulator ConfigurationWizard.

Add-ins Guide
Chapter 29: Terminal Emulator Add-in - Testing and Configuration

HP Unified Functional Testing (12.00) Page 454 of 549



Cannot detect the emulator screen

UFT cannot find the terminal emulator main window class name.

l Ensure that the terminal emulator main window class name is configured correctly in the
Terminal Emulator ConfigurationWizard (Tools > Options > GUI Testing tab > Terminal
Emulator node > Open Wizard).

l If themain window class name has a postfix that changes each time you launch the emulator,
enter only the non-changing portion of the name in the Terminal Emulator ConfigurationWizard.

Cannot connect to the open session

Although a current session is open, invoking an HLLAPI function resulted in an error.

Restart UFT and then restart the emulator. If this does not resolve the problem, contact your
emulator provider.

Cannot retrieve session text

UFT cannot display text captured in the current session.

l HLLAPI Emulators—Restart UFT and then restart the emulator. If this does not resolve the
problem, contact your emulator provider.

l Non-HLLAPI Emulators—Click Validate again. If the error message is repeated, check that the
emulator screen is brought to the front during the validate process (even when using remote
access). If this is the case, contact HP Customer Support.

Cannot detect open session, or Cannot locate the main window
class

UFT cannot detect an open terminal emulator session, or find the terminal emulator main window
class name.

l Ensure that you have opened a current session in your terminal emulator.

l Ensure that the terminal emulator main window class name is configured correctly in the
Terminal Emulator ConfigurationWizard (Tools > Options > GUI Testing tab > Terminal
Emulator node > Open Wizard).

l If themain window class name has a postfix that changes each time you launch the emulator,
enter only the non-changing portion of the name in the Terminal Emulator ConfigurationWizard.
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HLLAPI DLL not found

UFT cannot find the HLLAPI DLL specified for the selected emulator.

Ensure that you have configured the correct DLL path and name in the Terminal Emulator
ConfigurationWizard (Tools > Options > GUI Testing tab > Terminal Emulator node > Open
Wizard).

For more details, see the table listing the DLL names used by supported terminal emulators in
"Configure HLLAPI Properties Page" on page 475, or the documentation provided by your emulator
provider.

More than one session open

More than one terminal emulator session is currently open.

Close additional sessions.

Unknown error

The validation process failed due to an unknown error.

Restart UFT and then restart the emulator.
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Terminal Emulator Pane (Options Dialog Box > GUI
Testing Tab)

This pane enables you to change your terminal emulator settings and to validate your current
terminal emulator configurations.

To access 1. Do one of the following:

n Ensure that a GUI test, action, or component is in focus in the document
pane.

n In the Solution Explorer, select a GUI test or component node or one of its
child nodes.

2. Select Tools > Options > GUI Testing tab > Terminal Emulator node.
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Important
information

This pane is available only when the UFT Terminal Emulator Add-in is installed
and loaded.

Any changes youmake to the settings in this pane are immediately applied to the
currently open test or business component when you click OK.

Terminal Emulator area: You can select an emulator to test using theVendor
andEmulator list boxes. The displayed lists include all of the vendor/emulator
combination settings that are:

l Preconfigured (supplied with your Terminal Emulator Add-in)

l Copied to your computer

l Previously configured using the Terminal Emulator ConfigurationWizard

You can also open the wizard to configure a new terminal emulator setting or
modify an existing setting.

TheRestore Factory Defaults button resets all Options dialog box options to
their defaults.

Relevant
tasks

"How to Check the Validity of a Terminal Emulator Configuration" on page 443

User interface elements are described below:

UI Elements Description

Vendor The list of available terminal emulator vendors. Select the vendor for your
emulator.

Emulator The list of terminal emulators available for the selected vendor. Select the
emulator application you want to test.

Protocol The protocol that your emulator uses.

Recommended: Auto-detect
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UI Elements Description

Validate Validates the current configurations of the selected emulator, and, if an error is
detected, displays a brief description that error.

Errors may result from:

l invalid terminal emulator configurations in the Terminal Emulator pane
(Tools > Options > GUI Testing tab > Terminal Emulator node).

l invalid configurations made when configuring the terminal emulator using the
Terminal Emulator ConfigurationWizard (Tools > Options > GUI Testing
tab > Terminal Emulator node > Open Wizard).

l errors in the terminal emulator itself.

For a list of possible error responses, see "Validating a Terminal Emulator -
Possible Error Responses" on page 453.

Troubleshoot Opens a specific Help page that provides a troubleshooting solution where
available.

Available only if an error response is displayed after you click Validate.

Example: If you click Validate and Invalid HLLAPI DLL is displayed,
you can click Troubleshoot to open a Help topic displaying information on
handling this error.

For details, see "Validating a Terminal Emulator - Possible Error Responses"
on page 453.

Screen Label The area from which UFT reads the label property of the emulator screen while
recording a test or business component. If the location and length of the label
are correctly defined, UFT uses this value as the name of the TeScreen object.
TheScreen label area is enabled only for emulators that support HLLAPI.

To set the screen label:

Enter theStart row and Start column coordinates that mark the beginning of
the emulator label. Define the size of the label by entering the Length
(in characters).

Note: You can change the way that UFT reads the label property of the
emulator screen, by adjusting the configuration settings. For details, see
"How toManage Terminal Emulator Configuration Settings" on page 449.

Open Wizard Opens the Terminal Emulator ConfigurationWizard. The wizard enables you to
define new settings for a terminal emulator or to modify existing user-defined
settings. For details, see "Terminal Emulator ConfigurationWizard Overview"
on page 470.
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UI Elements Description

Adjust
Configuration

Opens the "Terminal Emulator Configuration Adjustments Dialog
Box""Terminal Emulator Configuration Adjustments Dialog Box" (described on
page 460) to allow changes to existing configuration settings in exceptional
circumstances.

Note: In general, it is recommended to use the Terminal Emulator
ConfigurationWizard to configure your emulator screen settings. For
details, see "Configure Emulator Screen Settings Page" on page 481. You
should use theAdjust Configuration option only if you have a good
understanding of your terminal emulator settings and of the impact that
such changes may have on your tests or business components. For more
details, see "How toManage Terminal Emulator Configuration Settings" on
page 449.

Terminal Emulator Configuration Adjustments Dialog Box
This dialog box enables you tomake adjustments to existing terminal emulator configuration
settings. This is required only in exceptional circumstances. In themajority of cases, UFT works
successfully with terminal emulators using the supplied preconfigured settings and with the
configuration settings defined using the Terminal Emulator ConfigurationWizard.

Caution: Do not change the configuration settings using the options in this dialog box unless
you have a good understanding of your terminal emulator and of the impact that such changes
may have on your tests or business components.

The following is an example of the options displayed in the dialog box for an emulator that supports
HLLAPI.
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To access 1. Do one of the following:

n Ensure that a GUI test, action, or component is in focus in the document
pane.

n In the Solution Explorer, select a GUI test or component node or one of its
child nodes.

2. Select Tools > Options > GUI Testing tab > Terminal Emulator node.

3. Select an emulator and click Adjust Configuration,
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Important
information

The choice of options displayed in this dialog box depends on the type of terminal
emulator selected in the Terminal Emulator pane.

Themajority of the options in this dialog box are specific to the terminal emulator
selected in the Terminal Emulator pane of the Options dialog. The values for these
emulator-specific options are saved with the selected emulator. For example, if
you specify an HLLAPI DLL file other than the default file, the specified file is used
only for the selected emulator.

For a few options, the value is saved and applied regardless of the emulator
selected in the Terminal Emulator pane of the Options dialog. For example, if you
select not to recordmenus and dialog boxes, UFT keeps this setting even if you
select a different emulator.

Relevant
tasks

Youmodify options that are displayed as bullets by clicking the text andmodifying
the value when the text becomes an editable box. For details, see "Change
configuration settings" on page 449.

See also "How toManage Terminal Emulator Configuration Settings" on page 449
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User interface elements are described below:

UI Elements Description

Emulator
Settings

The following options enable you to define configuration settings that cannot be
changed using the wizard:

l Auto-advance fields supported. Auto-advance fields allow an application
to proceed automatically to the next screen or field after input of a predefined
number of characters without pressingENTER or another key.

If your emulator supports auto-advance fields, select this check box to
enable UFT to record Set statements on these fields.

Displayed for: Emulators that support HLLAPI.

l Number of blank lines at bottom of screen. Some emulators reserve
blank lines at the bottom of the screen. If the screen size changes, these
lines may distort UFT's calculation of field locations. This option enables you
to specify the number of blank lines at the bottom of the emulator screen. It is
recommended to use the Terminal Emulator ConfigurationWizard to
configure this setting, but you can alsomodify the setting using this option.

Enter the number of lines that your emulator reserves at the bottom of the
screen. UFT includes this value in its algorithm for identifying field locations.

l Code page number (IBM PCOM only). If you are using an IBM PCOM
emulator with a language other than English, enter the code page number for
this language. For example, for the German language keyboard, enter the
value 1252. To use the default code page conversion, specify 0. To view a
list of languages and their code page numbers, select Regional Options in
theWindows Control Panel and select theAdvanced button in the General
tab.

UFT uses this code page to correctly identify the keys you record.
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UI Elements Description

HLLAPI
Settings

The following options enable you to define configuration settings for the selected
emulator. They are displayed only for emulators that support HLLAPI.

l HLLAPI .dll file. UFT uses the HLLAPI DLL file specified for this emulator
to connect to the emulator and to retrieve data concerning its current status.

If you are using a customized version of a preconfigured emulator, youmay
need to specify a different DLL file name.

l HLLAPI function name. The HLLAPI DLL for this emulator uses this
function as the entry point for all HLLAPI calls.

If you are using a customized version of a preconfigured emulator, youmay
need to specify a different function name.

l Argument size for HLLAPI function. Formost emulators, the HLLAPI
function receives 16-bit (word) arguments. For some emulators, such as IBM
PCOM, the HLLAPI function receives 32-bit (integer) arguments.

Select the correct argument size for the selected emulator: word (16 bits) or
integer (32 bits).

l Execute HLLAPI calls from multiple threads. Some emulators allow
HLLAPI calls frommultiple threads, while others require all HLLAPI calls to
be executed from the same thread. (Selected by default for a preconfigured
emulator configuration.)

Clear this check box to instruct UFT to open a separate process for HLLAPI
calls and to execute all HLLAPI calls from this single thread.

l Warn if HLLAPI dll file not found. Instructs UFT to display a warning
message when the HLLAPI DLL file for the current configuration cannot be
found. For example, UFT warns you if you try to use the Terminal Emulator
Add-in before you have installed the emulator itself.

If you clear this check box and UFT cannot find the required DLL file, it may
be difficult to determine why UFT is not recording successfully. It is therefore
recommended that you leave this option selected.

Applies to: All terminal emulator configurations, regardless of the currently
selected emulator.
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UI Elements Description

Object
Identification
Settings

The following options enable you to configure the way UFT identifies objects for
the selected terminal emulator:

l Identify screen label using all characters. The label property value is
used to identify the TeScreen test object. The location and length of the label
are defined for the selected emulator in the Terminal Emulator pane. For more
details, see "Terminal Emulator Pane (Options Dialog Box > GUI Testing
Tab)" on page 457.

By default, only the protected characters in the defined label area are
captured for the label property value.

Select this option if you want UFT to capture all the characters in the label
area for the label property, including any unprotected or hidden characters
that may form part of the label.

l Identify emulator window based on title bar prefix. UFT normally
identifies the emulator window by its object class. With a user-defined
configuration, the class namemay not be unique. For example, an emulator
may use a generic class name, such as Afx. In such cases, you can instruct
UFT to identify the window based on a static prefix in the window title bar.

To instruct UFT to use a prefix to identify the correct window, specify the text
string for the prefix.

When no value is specified, UFT uses the object class to identify the
emulator window.
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UI Elements Description

Record
Settings

The following options enable you to configure the way UFT records operations:

l Communicate with server using these keys. When recording without
HLLAPI support, UFT inserts Sync steps after specified keys are pressed, to
synchronize the communication between the emulator and the server. The
keys are identified by their virtual key codes.

Default: ENTER key—virtual key code value: 13 (0D Hex). You can specify
different or additional keys. For example, you can add theCTRL key—virtual
key code value: 17 (11 Hex).

Specify the decimal value of the virtual key code for each key, separated by
a semicolon (;). UFT inserts a Sync step whenever one of these keys is
pressed. For more details on synchronization, see "How to Synchronize
Steps on Terminal Emulators" on page 450.

For a list of virtual key codes, see http://msdn.microsoft.com/en-
us/library/dd375731(VS.85).aspx. The list on theMSDN page displays the
Hex values for each key code. Youmust convert the value to decimal and
specify the decimal value of the key codes when you add them to the list for
this option.

Applies to: All terminal emulator configurations, regardless of the currently
selected emulator.

l Record operations on menus and dialog boxes. By default, UFT records
operations on themenus of the terminal emulator window and the dialog
boxes that open as a result of thesemenu option selections.

Clear this check box if you do not want UFT to record thesemenu and dialog
box operations. For example, youmay not want emulator-specific menu and
dialog box steps in your test or business component if cross-emulator
compatibility is important, or if these steps are not relevant to your test or
business component.

Applies to: All terminal emulator configurations, regardless of the currently
selected emulator.
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UI Elements Description

Record
Settings
(continued)

l Record mode. In Text screenmode, UFT records operations as
TeTextScreen steps, based on the screen coordinates. InContext-sensitive
mode, UFT records field operations as TeField steps.

By default, all preconfigured terminal emulators and user-defined emulators
configured as fully supporting HLLAPI are set to context-sensitivemode.
Select Text screen mode if you are using an emulator that supports HLLAPI
and you want to test in terms of coordinates instead of TeField objects.

You can use the wizard to change themode for a user-defined terminal
emulator. For more details, see "Terminal Emulator ConfigurationWizard
Overview" on page 470.

Note: For emulators that do not support HLLAPI and those configured as
supporting text-only HLLAPI operations, UFT always uses Text screen
mode and this option is not available.

l Record steps without synchronizing. By default, when UFT recognizes a
user operation in the terminal emulator application, such as keyboard input or
amouse click, UFT suspends the processing of the user input in the
application. After the recorded statement is added to the test or business
component script and the Active Screen information has been saved, UFT
releases the emulator and allows it to process the user input.

Some emulators, such as IBM PCOM, do not support running HLLAPI while
user input processing is suspended, and require UFT to release the emulator
process before executing HLLAPI calls.

If you experience unexpected behavior while trying to record, youmay need
to select this option. For example, theremay be no response from UFT or the
emulator (or both). If you do select this option, make sure that you allow
sufficient time for UFT to record each step before performing another
operation.
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UI Elements Description

Record
Settings
(continued)

l Record cursor position.When recording in a text screen or field, UFT uses
TeTextScreen.ClickPosition or TeField.SetCursorPos to record the
cursor position.

Clear this check box if you do not want to record the cursor position in your
test or business component.

Applies to:All terminal emulator configurations.

l Trim trailing spaces in fields. When recording inContext-sensitivemode,
fields may contain trailing spaces or other "white characters", such as tab
symbols.

Select this check box to instruct UFT to trim these characters. If you select
this option, specify theminimum length of fields to be trimmed. Fields
containing fewer than the specified number of characters remain unchanged.
The default is 5 characters.

Clear the check box to leave the field content unchanged.

Displayed for:Emulators that support HLLAPI.

l Use property patterns. Select this check box to use property patterns to
record regular expressions in identification properties, such as for date and
time values in a screen label.

For more details on property patterns, seeUsing Property Patterns to Identify
Objects (Advanced) in PropPattern.htm. This file is located in the help
subfolder of the UFT installation folder.

You can accept the default property pattern configuration file, change its
contents, or specify a different property pattern configuration file. The default
file is designed for applications where the current time forms part of the
screen label. It defines regular expressions that replace the current time in
the screen label, creating a reliable description and readable name for the
screen.

Applies to:All terminal emulator configurations, regardless of the currently
selected emulator.
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UI Elements Description

Run Settings The following options enable you to configure the way UFT runs tests or
business components for the selected terminal emulator, if the emulator
supports HLLAPI:

l Beep when Sync operations are performed. Indicates whether UFT
beeps after performing eachSync operation during a run session.

Applies to:All terminal emulator configurations, regardless of the currently
selected emulator.

l Run steps containing special emulator keys using keyboard events.
Instructs UFT to perform SendKey commands using keyboard events. If you
do not use this option to specify key codes, UFT performs SendKey
commands using the corresponding HLLAPI function.

Some emulators, for example, Attachmate Extra!, recognize the RESET
commandwhile the emulator is busy only when it is sent using keyboard
events. In theKeys for RESET function option, specify the keyboard
combination of the virtual key code by specifying the decimal value of each
key in the code, separated by semicolons (;).

l Time between emulator status checks (in milliseconds). During a Sync
step, UFT waits the specified period of time before checking the emulator
status. UFT repeats these checks at the specified interval until the emulator
status changes toReady (or until the Sync timeout is reached), and then
continues with the run session. For more details on synchronization, see
"How to Synchronize Steps on Terminal Emulators" on page 450.

Specify the interval (in milliseconds) between emulator status checks.

Default: 200

Note: Specifying a very long interval could significantly increase the
time your tests or business components take to run.
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Terminal Emulator Configuration Wizard Overview
This wizard guides you through the process of configuring the settings UFT needs to identify your
terminal emulator. If your emulator is not in the list of preconfigured settings to select, you can
define the way UFT identifies your emulator.

To access 1. Open UFT with the Terminal Emulator Add-in loaded.

2. In UFT, select Tools > Options > GUI Testing tab > Terminal Emulator
node.

3. In the Terminal Emulator pane, click Open Wizard.

Note: After you install UFT, the Terminal Emulator ConfigurationWizard
opens automatically if you selectedRun the Terminal Emulator wizard in
the Additional Installation Requirements dialog box.

Important
information

l To configure a terminal emulator that supports HLLAPI, make sure that you
close any application that is currently using the HLLAPI .dll file before you
begin using the wizard. Otherwise, the wizard cannot connect to your terminal
emulator.

l If terminal emulator settings for UFT are already configured on another
computer, you can copy an existing configuration file onto your computer,
instead of running the wizard. For details, see "How to Copy Existing Terminal
Emulator Configurations" on page 443.

l After you run the wizard, the terminal emulator you selected is set as the
default emulator when you open UFT with the Terminal Emulator Add-in
loaded.

Wizard
map

The Terminal Emulator ConfigurationWizard contains:

"Terminal Emulator ConfigurationWizardWelcome Page" (page 471 > "Specify
Wizard Operation Page " (page 472) > "Emulator Setup Page" (page 474) >
"Configure HLLAPI Properties Page" (page 475 > "HLLAPI Configuration Test
Page" (page 477 > "Configure Emulator Classes Page" (page 479 > "Configure
Emulator Screen Settings Page" (page 481 > "Completing the Terminal Emulator
ConfigurationWizard Page " (page 484

Note: Pages that are in parentheses open according to the option selected in
the previous page. Therefore, not all pages are displayed for every option.
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See also l You can check your configurations by clicking theValidate button in the
Terminal Emulator pane of the Options dialog box. A description of any
detected problem is displayed in the pane, as well as a link to a specific
troubleshooting Help page. For details, see "How to Check the Validity of a
Terminal Emulator Configuration" on page 443.

l You can use the wizard to select a different emulator for use with your tests or
business components. For more details, see "Terminal Emulator Configuration
Wizard Overview" on the previous page.

Terminal Emulator Configuration Wizard Welcome Page

This wizard page provides general information about the different options in the Terminal Emulator
ConfigurationWizard.

Wizard
map

The Terminal Emulator ConfigurationWizard contains:

Terminal Emulator Configuration Wizard Welcome Page > "Specify Wizard
Operation Page " (page 472) > "Emulator Setup Page" (page 474 > "Configure HLLAPI
Properties Page" (page 475) > "HLLAPI Configuration Test Page" (page 477) >
"Configure Emulator Classes Page" (page 479) > "Configure Emulator Screen Settings
Page" (page 481 > "Completing the Terminal Emulator ConfigurationWizard Page "
(page 484

Note: Pages that are in parentheses open according to the option selected in the
previous page. Therefore, not all pages are displayed for every option.
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See
also

l For details on how to open the wizard, see "Terminal Emulator ConfigurationWizard
Overview" on page 470.

l For details on copying an existing configuration, see "How to Copy Existing
Terminal Emulator Configurations" on page 443.

Specify Wizard Operation Page

This wizard page enables you to you specify the operation that you want the wizard to perform.

Wizard
map

The Terminal Emulator ConfigurationWizard contains:

"Terminal Emulator ConfigurationWizardWelcome Page" (page 471) > Specify
Wizard Operation Page > "Emulator Setup Page" (page 474) > "Configure HLLAPI
Properties Page" (page 475 > "HLLAPI Configuration Test Page" (page 477 >
"Configure Emulator Classes Page" (page 479) > "Configure Emulator Screen Settings
Page" (page 481))> "Completing the Terminal Emulator ConfigurationWizard Page "
(page 484

Note: Pages that are in parentheses open according to the option selected in the
previous page. Therefore, not all pages are displayed for every option.

See
also

l For details on how to open the wizard, see "Terminal Emulator ConfigurationWizard
Overview" on page 470.

l For details on copying an existing configuration, see "How to Copy Existing
Terminal Emulator Configurations" on page 443.
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User interface elements are described below:

UI Elements Description

Use a
preconfigured
setting

Enables you to select one of the vendor/emulator settings that are supplied
with your Terminal Emulator Add-in.

Note: If you select this option, you can click Finish instead of Next to
begin working with UFT to test the emulator you selected.

However, if you are testing aWeb-based emulator, or if UFT is not
recording or recognizing objects as expected, it is recommended to click
Next and define the emulator screen settings.

(The emulator screen settings do not affect run sessions; they affect only
recording and other object operations (for example, inserting checkpoints and
using the Object Spy.)

For details on using your emulator with UFT, see "Terminal Emulator Add-in -
Overview" on page 437.

Configure a
new user-
defined setting

Enables you to supply the details of your vendor and emulator.

After completing the wizard, the vendor and emulator names that you define
here are displayed in the list of vendor/emulator combinations in the Terminal
Emulator pane.

Modify an
existing user-
defined setting

Enables you tomodify settings that were previously configured using the
Terminal Emulator ConfigurationWizard.
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Emulator Setup Page

This wizard page instructs you to open your terminal emulator and connect it to the server.

Important
information

If your emulator supports HLLAPI, enable it and set the emulator short session
name to the uppercase letterA. For details, see "How to Set Your HLLAPI
Terminal Emulator toWork with UFT" on page 444.

Wizard
map

The Terminal Emulator ConfigurationWizard contains:

"Terminal Emulator ConfigurationWizardWelcome Page" (page 471 > "Specify
Wizard Operation Page " (page 472 > Emulator Setup Page) > "Configure
HLLAPI Properties Page" (page 475 > "HLLAPI Configuration Test Page" (page
477) > "Configure Emulator Classes Page" (page 479 > "Configure Emulator
Screen Settings Page" (page 481) > "Completing the Terminal Emulator
ConfigurationWizard Page " (page 484

Note: Pages that are in parentheses open according to the option selected in
the previous page. Therefore, not all pages are displayed for every option.

See also l For details on how to open the wizard, see "Terminal Emulator Configuration
Wizard Overview" on page 470.

l For details on copying an existing configuration, see "How to Copy Existing
Terminal Emulator Configurations" on page 443.
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Configure HLLAPI Properties Page

This wizard page enables you to specify whether your terminal emulator supports HLLAPI.

Wizard
map

The Terminal Emulator ConfigurationWizard contains:

"Terminal Emulator ConfigurationWizardWelcome Page"471 > "Specify Wizard
Operation Page " (page 472 > "Emulator Setup Page" (page 474 > Configure HLLAPI
Properties Page > "HLLAPI Configuration Test Page" (page 477 > "Configure
Emulator Classes Page" (page 479 > "Configure Emulator Screen Settings Page"
(page 481> "Completing the Terminal Emulator ConfigurationWizard Page " (page 484

Note: Pages that are in parentheses open according to the option selected in the
previous page. Therefore, not all pages are displayed for every option.

See
also

l For details on how to open the wizard, see "Terminal Emulator ConfigurationWizard
Overview" on page 470.

l For details on copying an existing configuration, see "How to Copy Existing
Terminal Emulator Configurations" on page 443.
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User interface elements are described below:

UI
Elements Description

Emulator
supports
HLLAPI

If your emulator supports HLLAPI, select this option and supply the information
described in the table below**. If you are not sure what values to enter, consult your
terminal emulator documentation or contact the vendor for your terminal emulator.

HLLAPI
dll path

The HLLAPI dynamic-link library file specified for the selected emulator that UFT
uses to connect to the emulator and to retrieve data concerning its current status.
This file usually resides in the terminal emulator installation folder. You can click the
browse button to search for the path.

HLLAPI
function
name

The HLLAPI DLL for the selected emulator uses this function as the entry point for
all HLLAPI calls.

HLLAPI
format

The format by which UFT attempts to identify your emulator screen. If you are
working with VT protocols, select the Text-only option. Otherwise, it is
recommended to select Auto-detect.

If, in the next screen, UFT is unable to capture the text from your terminal emulator,
youmay need to return to this screen and change this selection toClassic,
Extended, or Text-only. You should also confirm the accuracy of the properties you
entered in the screen.

Emulator
does not
support
HLLAPI

Select this option if your emulator does not support HLLAPI.

**The table below lists the DLL and function names used by the supported terminal emulators.

Emulator Name DLL Name
HLLAPI
Function Name

Attachmate EXTRA! and AttachmatemyEXTRA! Terminal
Viewer

ehlapi32.dll hllapi

Attachmate INFOConnect ihlapi32.dll WinHLLAPI

Hummingbird HostExplorer ehllap32.dll HLLAPI32

IBM Personal Communications (PCOM) and IBM
WebSphere Host On-Demand

pcshll32.dll hllapi

NetManage RUMBA and NetManage RUMBAWeb-To-
Host

ehlapi32.dll hllapi
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Emulator Name DLL Name
HLLAPI
Function Name

PuTTY Not applicable Not applicable

Seagull BlueZone WHLAPI32.dll hllapi

WRQReflection hllapi32.dll hllapi

Zephyr (PC/Web to Host) PassHll.dll hllapi

HP Teem Talk Not applicable Not applicable

HLLAPI Configuration Test Page

This wizard page displays a screen capture test if you selectedEmulator supports HLLAPI in the
Configure HLLAPI Properties page. This test enables you to determine whether UFT accurately
identifies your terminal emulator screen.
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Important
information

Check that the screen capture test is correct for your currently selected terminal
emulator, and that all the text is correctly identified and displayed.

l If the wizard displays the emulator screen and the text correctly, click Next to
continue.

l If the wizard does NOT display the emulator screen and the text correctly, see
"Troubleshooting the HLLAPI Properties Configuration" below.

Wizard
map

The Terminal Emulator ConfigurationWizard contains:

"Terminal Emulator ConfigurationWizardWelcome Page" (page 471 > "Specify
Wizard Operation Page " (page 472 > "Emulator Setup Page" (page 474 >
"Configure HLLAPI Properties Page" (page 475 > HLLAPI Configuration Test
Page) > "Configure Emulator Classes Page" (page 479 > "Configure Emulator
Screen Settings Page" (page 481) > "Completing the Terminal Emulator
ConfigurationWizard Page " (page 484

Note: Pages that are in parentheses open according to the option selected in
the previous page. Therefore, not all pages are displayed for every option.

See also l For details on how to open the wizard, see "Terminal Emulator Configuration
Wizard Overview" on page 470.

l For details on copying an existing configuration, see "How to Copy Existing
Terminal Emulator Configurations" on page 443.

Troubleshooting the HLLAPI Properties Configuration
If the wizard does not display the text correctly, or if the HLLAPI configuration test fails, do the
following:

1. Click Back. Before repeating the test:

n Make sure your emulator is connected to the host and the short name for the session is set
to the uppercase letterA. For details, see "How to Set Your HLLAPI Terminal Emulator to
Work with UFT" on page 444.

n Check that the settings you entered in the "Configure HLLAPI Properties Page" are
accurate (DLL path, procedure, format). For details, see "Configure HLLAPI Properties
Page" on page 475.

n Make sure that the HLLAPI .dll file you specified in the DLL path is not in use by UFT or
another application.

If the .dll file is currently in use by another application, click Cancel to close the wizard,
close the application using the DLL, and restart the wizard.

If the .dll file is currently in use by UFT, select a different emulator and create a new test.
Then reopen the wizard andmodify the original configuration as required.
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2. If the display is still not correct, click Back and, in the Configure HLLAPI Properties page,
change theHLLAPI format to Text-only. Use the Text-only option if you are working with a
VT protocol, or if you have begun working in UFT and encountered problems with recording and
running tests or business components. For details, see "Configure HLLAPI Properties Page"
on page 475.

3. If the above tips do not solve the problem, click Back and, in the Configure HLLAPI Properties
page, select Emulator does not support HLLAPI. For details, see "Configure HLLAPI
Properties Page" on page 475.

Tip: If you have a good understanding of your emulator, youmay be able to solve any
problems you experience by adjusting the configuration settings. For details, see "How to
Manage Terminal Emulator Configuration Settings" on page 449.

Configure Emulator Classes Page

This wizard page enables you to specify emulator class information. UFT uses this information to
locate classes on the emulator screen. By identifying the business components of the terminal
emulator window, UFT distinguishes between the window of the terminal emulator and the screens
in the host application.

Important
information

You identify the business components of the emulator by clicking the pointing
hand and then clicking the corresponding object on your terminal emulator
window.
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Wizard
map

The Terminal Emulator ConfigurationWizard contains:

"Terminal Emulator ConfigurationWizardWelcome Page" (471) > "Specify
Wizard Operation Page " (page 472) > "Emulator Setup Page" (page 474) >
"Configure HLLAPI Properties Page" (page 475 > "HLLAPI Configuration Test
Page" (477 > Configure Emulator Classes Page) > "Configure Emulator Screen
Settings Page" (page 481 > "Completing the Terminal Emulator Configuration
Wizard Page " (page 484

Note: Pages that are in parentheses open according to the option selected in
the previous page. Therefore, not all pages are displayed for every option.

See also l For details on how to open the wizard, see "Terminal Emulator Configuration
Wizard Overview" on page 470.

l For details on copying an existing configuration, see "How to Copy Existing
Terminal Emulator Configurations" on page 443.

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Elements Description

<emulator
class
options>

You identify the business components of the emulator by clicking the pointing
hand and then clicking the corresponding object on your terminal emulator
window.

l Main window class. The uppermost title bar of themain emulator window.

l Text window class. The text within the emulator screen.

l Toolbar class. The terminal emulator's toolbar (if applicable).

l Status bar class. The lowest status bar of themain emulator window
(if applicable).

Emulator
Process
Image
Name

The process name for the emulator. (The wizard detects the process name for the
emulator and displays it in this box after identifying the emulator main window
class.)

UFT uses this process name to identify the correct process for this terminal
emulator when recording and running tests or business components.

Make sure that the displayed process name is correct for this emulator.

Tip: You can view the image names of the currently loaded processes in the
Image Name column of theWindows Task Manager Processes tab.
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UI
Elements Description

Configure
Emulator
Screen

Select this check box to configure your emulator screen correctly for use with
UFT if:

l Your emulator does not support HLLAPI.

l Your emulator supports HLLAPI, but you want to review or change the
configuration settings for the emulator screen.

Note: If you do not select this check box, the Terminal Emulator Add-in
automatically:

1. Retrieves the configuration settings for the emulator screen.

2. Adjusts the screen size and alignment using a proprietary algorithm with
the settings retrieved for the emulator. These settings are normally
correct, so youmay not need to select this check box.

Configure Emulator Screen Settings Page

This wizard page enables you to specify the settings of the terminal emulator text screen.

This page opens only if you selected a preconfigured setting, or if you selected theConfigure
Emulator Screen check box in the Configure Emulator Classes page. In this case, your emulator
screen is displayed with a red grid overlay.
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Important
information

You change the settings of the emulator screen to correspond to the required
settings for your emulator. The character size, column, and row details for your
terminal emulator are generally available from your emulator's connection
configurationmenu.

As you change the settings for the emulator screen, the grid automatically adjusts
to show the new settings.

It is recommended that you specify the text screen settings in the following order:

1. Use theMark Text Area button tomark the text area on your emulator
screen.

2. Fine-tune the text screen settings using the options above theMark Text
Area button.

Wizard
map

The Terminal Emulator ConfigurationWizard contains:

"Terminal Emulator ConfigurationWizardWelcome Page" (471 > "Specify Wizard
Operation Page " (page 472 > "Emulator Setup Page" (page 474 > "Configure
HLLAPI Properties Page" (page 475 > "HLLAPI Configuration Test Page" (page
477) > "Configure Emulator Classes Page" (page 479 > Configure Emulator
Screen Settings Page) > "Completing the Terminal Emulator Configuration
Wizard Page " (page 484

Note: Pages that are in parentheses open according to the option selected in
the previous page. Therefore, not all pages are displayed for every option.

See also l For details on how to open the wizard, see "Terminal Emulator Configuration
Wizard Overview" on page 470.

l For details on copying an existing configuration, see "How to Copy Existing
Terminal Emulator Configurations" on page 443.

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Elements Description

Mark
Text
Area

Enables you to define the dimensions of the terminal emulator text area on your
emulator screen. When you click this button, the wizard is minimized and the cursor
becomes a crosshairs pointer. Drag the pointer on your emulator screen to define the
text area.

After youmark the text area on your emulator screen you can fine-tune your settings
by adjusting the text screen settings.
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UI
Elements Description

<text
screen
settings>

Screen and Character Sizes

You can specify your emulator's screen size in terms of:

l Number of columns and rows. Specify the number of columns and rows in
your emulator screen.

l Character size. Select the width and height of your emulator's characters to fit
correctly in the defined emulator screen.

Alignment and Offset

You can specify how the text on your emulator's screen should be aligned in relation
to the emulator window when the window size changes. The effect of these settings
depends on the behavior of your emulator:

l Screen alignment. Select the vertical alignment (Top orCenter) and the
horizontal alignment (Left orCenter) of the emulator screen inside the window.
These options are already optimized for preconfigured emulator settings, and
cannot bemodified.

Tip: The screen alignment settings determine how UFT identifies the
information on your emulator screen. If you are having trouble recording and
running tests or business components (for example, theClickPosition
method is not accurately determining the coordinates), try changing the
Screen alignment settings.

l Screen offset. Select the top and left offset for the text on your emulator screen
in relation to the emulator window. For example, if you know that your emulator
always reserves one blank row at the top of the screen, set the offset to 1.
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Completing the Terminal Emulator Configuration Wizard Page

This wizard page enables you complete the configuration and, optionally, to save your terminal
emulator settings to a specific registry file.

Important
information

l It is recommended that you save the settings you have just configured to a
separate registry file. This allows you to restore this exact configuration if you
later change your configuration settings. For more details, see "Terminal
Emulator Pane (Options Dialog Box > GUI Testing Tab)" on page 457.

l If you save your settings to a registry file, other users will be able to copy and
use your terminal emulator configuration. For more details, see "How to Copy
Existing Terminal Emulator Configurations" on page 443.

l If you are using the wizard from the Terminal Emulator pane of the Options
dialog box (Tools > Options > GUI Testing tab > Terminal Emulator node),
any changes youmake are not applied to the currently open test or business
component. To apply your changes, close your test or business component
and reopen it.
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Wizard
map

The Terminal Emulator ConfigurationWizard contains:

"Terminal Emulator ConfigurationWizardWelcome Page" (page 471 > "Specify
Wizard Operation Page " (page 472 > "Emulator Setup Page" (page 474 >
"Configure HLLAPI Properties Page" (page 475) > "HLLAPI Configuration Test
Page" (page 477 > "Configure Emulator Classes Page" (page 479 > "Configure
Emulator Screen Settings Page" (page 481) > Completing the Terminal
Emulator Configuration Wizard Page

Note: Pages that are in parentheses open according to the option selected in
the previous page. Therefore, not all pages are displayed for every option.

See also l For details on how to open the wizard, see "Terminal Emulator Configuration
Wizard Overview" on page 470.

l For details on copying an existing configuration, see "How to Copy Existing
Terminal Emulator Configurations" on page 443.

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Elements Description

Save
terminal
emulator
settings to
file

Saves your settings to a registry file when you specify a location. This enables
others to import these settings as needed.

<file
location>

The location in which to save the terminal emulator settings registry file.

Finish Adds the name you assigned to your new configuration settings to the list of
available terminal emulators in the Terminal Emulator pane of the Options dialog
box as described in "Terminal Emulator Pane (Options Dialog Box > GUI Testing
Tab)" on page 457.
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Chapter 30: VisualAge Smalltalk Add-in -
Quick Reference

You can use the UFT VisualAge Smalltalk Add-in to test VisualAge Smalltalk user-interface objects
(controls).

The following tables summarize basic information about the VisualAge Smalltalk Add-in and how it
relates to some commonly-used aspects of UFT.

General Information

Add-in Type This is aWindows-based add-in. Much of its functionality is the same as other
Windows-based add-ins.

See "Windows-Based Application Support" on page 94.

Supported
Environments

For details on supported VisualAge Smalltalk environments, see the VisualAge
Smalltalk Add-in section of theHP Unified Functional Testing Product
Availability Matrix, available from the UFT Help or the root folder of the Unified
Functional Testing DVD.

Important
Information

Youmust configure your VisualAge Smalltalk environment by importing the qt-
adapter.dat file and then recompiling your application.

See "How to Configure the VisualAge Smalltalk Add-in" on page 489.

Test Object
Methods and
Properties

The VisualAge Smalltalk Add-in uses a sub-set of the standardWindows test
objects, methods, and properties, which can be used when testing objects in
VisualAge Smalltalk applications. For details, see theVisualAge Smalltalk
section of theHP UFT Object Model Reference for GUI Testing.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

Prerequisites

Opening Your
Application

You can open your VisualAge Smalltalk application before or after
opening UFT.

Add-in Dependencies None

Configuration
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Configuring
Your
Application

You configure your VisualAge Smalltalk environment by importing the qt-
adapter.dat file and then recompiling your application.

See "How to Configure the VisualAge Smalltalk Add-in" on the next page.

Record and
Run Settings
Dialog Box
(tests only)

Use theWindows Applications tab.
(Record > Record and Run Settings)

See "Windows Applications Tab (Record and Run Settings Dialog Box)" on
page 109.

Note:

l UFT can recognize only VisualAge Smalltalk applications that have
been precompiled with the qt-adapter agent. For details, see "How
to Configure the VisualAge Smalltalk Add-in" on the next page.

l TheRecord and Run only on radio button applies only to record and
run sessions. UFT recognizes all VisualAge Smalltalk objects for
Object Spy and pointing hand operations, regardless of the settings in
the Record and Run Settings dialog box.

Custom Active
Screen
Capture
Settings
Dialog Box
(tests only)

Tools > Options > GUI Testing tab > Active Screen node > Custom Level

See the section on the Custom Active Screen Capture Settings dialog box in
theHP Unified Functional Testing User Guide.

Application
Area
Additional
Settings pane
(business
components
only)

Use theApplications pane.
In the application area, select Additional Settings > Applications in the
sidebar.

See the section the Applications pane in theHP Unified Functional Testing
User Guide.

This chapter includes:

How to Configure the VisualAge Smalltalk Add-in 489
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How to Configure the VisualAge Smalltalk Add-in
This task describes how to configure the VisualAge Smalltalk Add-in by importing the qt-
adapter.dat file to your VisualAge Smalltalk development environment and then recompiling your
application to include the qt-adapter agent.

1. Start VisualAge Smalltalk.

2. In the System Transcript window, select Tools > Browse Configuration Maps.

3. In the ConfigurationMaps Browser window, right-click theAllNames pane and select Import
> Selected Versions.

4. In the Information Required box, enter the IP address or host name of the server, or leave the
text box blank to use the native (fileio) access. Click OK. The Selection Required dialog box
opens.

5. In your file system, browse to the <UFT installation folder>/dat folder and select qt-
adapter.dat.

6. In the Selection Required dialog box, do the following:

n In theNames pane, select Unified Functional Testing.

n In theVersions pane, select UFT Adapter 1.0.

n Click the >> button and click OK.

7. In the ConfigurationMaps Browser window, do the following:

n In theAllNames pane, click Unified Functional Testing.

n In theEditions and Versions pane, click UFT Adapter 1.0. A list of available applications
displays in theApplications pane.

n Right-click theEditions and Versions pane and select Load.

8. To save your changes, select File > Save Image, or click OK in theWarning dialog box when
closing the VisualAge Smalltalk application.

9. Recompile your VisualAge Smalltalk application with the qt-adapter agent.

You are now ready to create and run tests on VisualAge Smalltalk applications.
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Chapter 31: Visual Basic Add-in - Quick Reference
You can use the UFT Visual Basic Add-in to test Visual Basic user-interface objects (controls).

The following tables summarize basic information about theVisual Basic Add-in and how it
relates to some commonly-used aspects of UFT.

General Information

Add-in Type This is aWindows-based add-in. Much of its functionality is the same as
otherWindows-based add-ins.

See "Windows-Based Application Support" on page 94.

Supported
Environments

For details on supported Visual Basic environments, see theVisual Basic
Add-in section of theHP Unified Functional Testing Product Availability
Matrix, available from the UFT Help or the root folder of the Unified
Functional Testing DVD.

Test Object
Methods and
Properties

The Visual Basic Add-in provides test objects, methods, and properties that
can be used when testing objects in Visual Basic applications. For details,
see theVisual Basic section of theHP UFT Object Model Reference for
GUI Testing.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

Troubleshooting
and Limitations

See "Troubleshooting and Limitations - Visual Basic Add-in" on page 493.

Prerequisites

Opening Your
Application

You can open your Visual Basic application before or after opening
UFT.

Add-in Dependencies None

Configuration

Options Dialog Box Use theWindows Applications pane.
(Tools > Options > GUI Testing tab > Windows Applications node)

See "Windows Applications > General Pane (Options Dialog Box >
GUI Testing Tab)" on page 98.
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Record and Run
Settings Dialog Box
(tests only)

Use theWindows Applications tab.
(Record > Record and Run Settings)

See "Windows Applications Tab (Record and Run Settings Dialog Box)"
on page 109.

Note:

l If you select theRecord and Run only on radio button, the
settings may also apply to (limit) the applications that are
recognized for Object Spy and other pointing hand operations.

l UFT recognizes Visual Basic objects only in applications that
are opened after changing the settings in theWindows
Applications tab of the Record and Run Settings dialog box.

Custom Active
Screen Capture
Settings Dialog Box
(tests only)

Use theWindows applications section.
(Tools > Options > GUI Testing tab > Active Screen node > Custom
Level)

See the section on the Custom Active Screen Capture Settings dialog
box in theHP Unified Functional Testing User Guide.

Application Area
Additional Settings
pane
(business
components only)

Use theApplications pane.
In the application area, select Additional Settings > Applications in
the sidebar.

See the section on the Applications pane in theHP Unified Functional
Testing User Guide.

This chapter includes:

Troubleshooting and Limitations - Visual Basic Add-in 493

Add-ins Guide
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Troubleshooting and Limitations - Visual Basic Add-in
This section describes troubleshooting and limitations for the Visual Basic Add-in.

l Whenworking with the Visual Basic Add-in, it is recommended to select theRecord and run
on these applications (opened on session start) option and then to specify the application
name in theWindows Applications Tab of the Record and Run Settings dialog box.

If you select theRecord and run test on any open Windows-based application option, you
should open the Visual Basic application after the first time you start recording.

l Combo box objects of style Simple ComboBox are not supported.

l Visual Basic .NET applications are supported by the UFT .NET Add-in.
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Chapter 32: Web Add-in - Quick Reference
You can use theWeb Add-in to test HTML user-interface objects (controls).

The following tables summarize basic information about theWeb Add-in and how it relates to some
commonly-used aspects of UFT. This information is also relevant for all child add-ins that extend
theWeb Add-in.

General Information

Add-in Type Much of the functionality of this add-in is the same as otherWeb-based add-
ins.

l See "Web-Based Application Support" on page 39.

Supported
Environments

l For details on supportedWeb browsers and versions, see theHP Unified
Functional Testing Product Availability Matrix, available from the UFT Help
or the root folder of the Unified Functional Testing DVD.

l UFT also provides a set of add-ins that support testing specialized controls
from a number of Web 2.0 toolkits using test object classes that were
developed by HP using "Web Add-in Extensibility" (described on page 498).
These add-ins are displayed as child nodes of theWeb Add-in in the Add-in
Manager. For details, see "Web 2.0 Toolkit Support " on page 524.

Test Object
Methods and
Properties

TheWeb Add-in provides test objects, methods, and properties that can be
used when testing objects inWeb applications. For details, see theWeb
section of theHP UFT Object Model Reference for GUI Testing.

Checkpoints
and Output
Values

l See the sections describing checkpoints and output values in the
HP Unified Functional Testing User Guide.

l See "Checkpoints forWeb Pages" on page 44.

l See "GUI Checkpoints andOutput Values Per Add-in" on page 540

Extending the
Web Add-in

"Web Add-in Extensibility" (described on page 498 enables you to develop
support for testing third-party and customWeb controls that are not supported
out-of-the-box by the UFTWeb Add-in.

Other l When you load the Siebel Add-in in addition to theWeb Add-in, the object
identification settings are automatically customized. For this reason, the
Web Add-in is not available in theEnvironment list in the Object
Identification dialog box (Tools > Object Identification), even though the
Web Add-in is loaded.

For details, see "Siebel Add-in - Overview" on page 368.

l You can create steps onmore than one browser tab, if your browser
supports tabbed browsing.
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Prerequisites

Opening Your Application Youmust open UFT before opening yourWeb application.

Testing in Mozilla Firefox To test yourWeb application in Mozilla Firefox, youmust
enable the Unified Functional Testing Extension in one of
the following ways:

l If theSelect Your Add-ons screen is displayed when
you open Firefox, select to keep the Unified Functional
Testing Extension.

l If the Install Add-on tab opens and displays Unified
Functional Testing Extension when opening Firefox,
select theAllow this installation check box and click
Continue.

Otherwise:

a. In Firefox, select Tools > Add-ons.

b. In the General tab, click Manage Add-ons.

c. In the Add-ons Manager tab, select theExtensions
node.

d. In the Unified Functional Testing Extension row,
click theEnable button.

Add-in Dependencies None

Configuration

Options Dialog Box Use theWeb pane.
(Make sure that a GUI test is open and select Tools > Options >
GUI Testing tab > Web > General node.)

For details, see"Web > General Pane (Options Dialog Box)" on
page 65.

Record and Run Settings
Dialog Box
(tests only)

Use theWeb tab.
(Record > Record and Run Settings)

See "Web Tab (Record and Run Settings Dialog Box)" on page
83.
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Test Settings Dialog Box
(tests only)

Use theWeb pane.
(File > Settings > Web pane)

See "Web Pane (Test/Business Component Settings Dialog Box
/ Application Area - Additional Settings Pane)" on page 79.

Custom Active Screen
Capture Settings Dialog
Box
(tests only)

Use theWeb section.
(Tools > Options > GUI Testing tab > Active Screen node >
Custom Level)

See the section on the Custom Active Screen Capture Settings
dialog box in theHP Unified Functional Testing User Guide.

Application Area
Additional Settings pane
(business components only)

Use theWeb pane.
In the application area, select Additional Settings > Web in the
sidebar.

l See "Web Pane (Test/Business Component Settings Dialog
Box / Application Area - Additional Settings Pane)" on page
79.

l See the section on defining Application Settings for your
application area in theHP Unified Functional Testing User
Guide.

This chapter includes:
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Concepts

Web Add-in Extensibility
UFTWeb Add-in Extensibility enables you to develop support for testing third-party and custom
Web controls that are not supported out-of-the-box by the UFTWeb Add-in.

If the test object class that UFT uses to represent a control does not provide the operations and
properties necessary to operate on your control, you can useWeb Add-in Extensibility to create a
new test object class.

You can thenmap the control to the new test object class, and design the test object class behavior
in JavaScript. You can program how operations are performed on the control, how properties are
retrieved, andmore.

You can also teach UFT to treat a control that contains a set of lower-level controls as a single
functional control, instead of relating to each lower-level control separately.

To implement Web Add-in Extensibility, you need to be familiar with:

l UFT and its Object Model Reference

l The behavior of the custom control (operations, properties, events)

l Web programming (HTML and JavaScript)

l XML (basic knowledge)

"Extensibility Accelerator for HP Functional Testing" (described on page 498) is an IDE that
facilitates the design, development, and deployment of Web Add-in Extensibility support. You can
install it from theAdd-in Extensibility and Web 2.0 Toolkits option in the UFT setup program.

Extensibility Accelerator also provides samples of support developed usingWeb Add-in
Extensibility, which you can use to gain a better understanding of how to create your own support.

For details on implementingWeb Add-in Extensibility, see theWeb Add-in Extensibility Help,
available from the UFT Extensibility Documentation program group (Start > All Programs >
HP Software > Unified Functional Testing > Extensibility > Documentation).

Note: For details on accessing UFT and UFT tools and files inWindows 8, see "Accessing
UFT inWindows 8Operating Systems" on page 547.

A printer-friendly (PDF) version of theHP UFTWeb Add-in Extensibility Developer Guide is
available in the <UFT installation folder>\help\Extensibility folder.

Extensibility Accelerator for HP Functional Testing
An increasing number of Web applications aremaking use of Web 2.0-based toolkits, such as
ASP.NET AJAX, Dojo, YahooUI, GWT, and JQueryUI to add dynamic and interactive content to
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their sites. The controls in these toolkits are complex and require sophisticated and flexible testing
capabilities.

UFTWeb Add-in Extensibility enables you to extend theWeb Add-in to customize how UFT
recognizes and interacts with different types of controls. Until now, usingWeb Add-in Extensibility
consisted of manually developing andmaintaining toolkit support sets.

Extensibility Accelerator for HP Functional Testing is an IDE that facilitates the design,
development, and deployment of these support sets. It makes it faster and easier to create the
required extensibility XML files so that you can invest your main efforts in the development of the
JavaScript functions that will enable UFT to work with your customWeb controls.

The Extensibility Accelerator user interface helps you define new test object classes, operations,
and properties. It also provides a point-and-click mechanism you can use tomap the test object
classes you defined to controls in your application. Extensibility Accelerator deployment
capabilities enable you to automatically deploy your new toolkit support set to UFT or to package it
so that you can share it with other UFT users.

The Extensibility Accelerator for HP Functional Testing installation is available from theAdd-in
Extensibility and Web 2.0 Toolkits option in the Unified Functional Testing setup program.

Note: As part of this process, an html page opens in your browser. To complete the installation
successfully, this pagemust be opened in Internet Explorer.

Working With Apple Safari on a Remote Mac Computer

Note: This feature is provided at Technology Preview level.

You can use UFT to test Web applications on an Apple Safari browser that is running on a remote
Mac computer. UFT uses theWebSockets protocol to connect to theMac computer that you
specify. Note that only Web test object steps can run on Safari. All other steps, including Utility
object steps, such as SystemUtil.Run, run locally on the UFT computer.

To test Web applications on the Safari browser, youmust install the UFT Connection Agent and the
Unified Functional Testing Agent Safari browser extension on your Mac computer. For details on
how to do this, see "How to Install and Configure UFT Connection Agent on Your Mac" on page
507.

In UFT, create and edit your object repositories, tests and components working with a supported
browser installed locally on the UFT computer, then connect to a remoteMac computer and run
them on Safari.

Tip: UseGoogle Chrome to create, edit, and debug your tests and components, as Chrome
and Safari renderWeb pages similarly.

Recording steps, learning objects, and using the Object Spy are not supported on the Safari
browser.
However, once your basic test is designed, you can connect UFT to a remoteMac computer
running Safari, and fine-tune your test based on the object properties available on Safari:
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l Create standard checkpoints and output value steps on objects displayed in the Safari browser

Use theDesign > Checkpoint andDesign > Output Value > Standard Output Value
commands.

l View object properties using statement completion for theObjectmethod.

Note: Statement completion for the Object method is only available if the connection to the
remoteMac is fast enough.

Multiple UFT-Mac Connections

l TheMac connection information is in the Record and Run settings, which are defined per test,
therefore you can connect to different Macs or different ports when running different tests.

However, UFT can connect to only oneMac at any time.

If UFT tries to connect to oneMac computer while connected to another, the connection attempt
fails.

If UFT tries to connect to aMac computer to which it is already connected, the existing
connection is used.

l Multiple users from different UFT instances can connect to the sameMac simultaneously using
different ports.

Each user must install the UFT Connection Agent and UFT Safari extension in their Mac user
account, and configure the relevant port number in UFT, in the connection agent on theMac, and
in the Safari extension.

For details about how to connect UFT to the remoteMac computer, see "How to Connect to a
RemoteMac Computer" on page 505.

For additional details about working with UFT and the Safari browser, see "Troubleshooting and
Limitations - Google Chrome and Apple Safari" on page 515.

For general considerations on working withWeb browsers, see "Considerations -Web-Based
Application Support" on page 40.

Working With Mozilla Firefox
UFT tests and business components are generally cross-browser—you can recordWeb steps on
Microsoft Internet Explorer or Mozilla Firefox, or you can create steps with the keyword-driven
methodology using any supported browser. You can runWeb steps in any supported browser.

For general considerations on working withWeb browsers, see "Considerations -Web-Based
Application Support" on page 40.
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The following sections describe specific items to consider when working with Mozilla Firefox:

l "Running Steps onMozilla Firefox Browser Controls" below

l "Running Steps onMozilla Firefox Dialog Boxes" below

l "Checkpoints andOutput Values" on the next page

Running Steps on Mozilla Firefox Browser Controls
Generally, steps that were recorded onMicrosoft Internet Explorer will run onMozilla Firefox
without requiring any modification. However, there are several differences to consider:

l UFT does not support Mozilla Firefox menus or sidebars.

l UFT supports specific Browser menu operations that are represented by the following toolbar
buttons:

n Back

n Forward

n Home

n Refresh

n Stop

All other toolbars and toolbar buttons are not supported. If you record steps on any unsupported
menu or toolbar objects when working with Microsoft Internet Explorer, youmay need to remove
or replace the steps before running the test or business component onMozilla Firefox.

Running Steps on Mozilla Firefox Dialog Boxes

l Due to the difference in standard dialog boxes, pop-up recovery scenarios that use theClick
button with label recovery operation and were built for Microsoft Internet Explorer will not work
for Mozilla Firefox, and vice versa.
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l Mozilla Firefox uses different standard dialog boxes than theWindows standard dialog boxes
used by Microsoft Internet Explorer. If you create steps on such dialog boxes, you should create
additional steps to be used when running onMozilla Firefox, and precede them with an If
statement to check which browser is running.

For example, the following two dialog boxes are a security alert of the sameWeb site. The one
on the left is fromMicrosoft Internet Explorer, and the one on the right is fromMozilla Firefox.
Although they both look like aWindows dialog box, theMozilla Firefox one is actually a browser
window.

Checkpoints and Output Values
Cross-browser UFT operations may affect the results of some types of checkpoints and output
values:

l Standard or page checkpoints for links and images that are created on Internet Explorer using
Record, or using the Active Screen, may not pass when run usingMozilla-based browsers, even
if the checkpoints pass when the test is run using Internet Explorer.

l Standard checkpoints for links and images created on Active Screen captures that were
captured from aMozilla-based browser may not pass when run using Internet Explorer, even if
the checkpoints pass when the test is run using theMozilla-based browser.

You can use regular expressions if you want to create checkpoints for links and images that run
on both Internet Explorer andMozilla-based browsers. For details on regular expressions, see
the section on understanding and using regular expressions in theHP Unified Functional Testing
User Guide.

l Standard checkpoints that use the inner_html property may not pass when run usingMozilla-
based browsers because blanks, slashes, backslashes, or other special characters are handled
differently in different browser types.

l Before running text/text area checkpoint or output value steps, youmust set the text recognition
options to use only OCR, by selecting theUse Only OCR option in the Text Recognition pane
of the Options dialog box (Tools > Options > GUI Testing tab > Text Recognition node).
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Working With Google Chrome
By default, the ability to run extensions on local HTML files is disabled in Google Chrome. Do the
following to allow the UFT Google Chrome extension to run on local HTML files:

1. In Google Chrome, browse to the following URL: chrome://extensions

2. Locate the UFT extension, namedUnified Functional Testing Agent.

3. Click the arrow located to the left of the icon to expand details about the extension.

Select Allow access to file URLs. Your selection is automatically saved.

Working with Multiple Browsers
Web applications andWeb controls may be implemented or displayed differently on different
browsers. This may affect the behavior of your tests and components, especially if you design
them on one browser, and then run them on another. The run results may also differ when running
the same test or component on different browsers. For example, if properties are implemented or
stored differently on different browsers, UFT may use different properties for object identification or
checkpoints depending on the browser you use to open the application.

If you are aware of differences in your application's behavior on different browsers, youmay be able
to design your tests and components to be browser-independent by anticipating these differences.

For example:

l Link controls are displayed differently on Firefox and Chrome, using different font and color
properties. If you design a test or component that runs a checkpoint on a Link object, and the
test may run on different browsers, be sure to deselect the font, color, and backgroundColor
properties in the checkpoint. Alternatively, you can define regular expressions for these
properties, to enable the checkpoint to pass for different values.

l The type attribute for a button object is button in Internet Explorer, but submit in Firefox and
Chrome. Therefore, if you learn a button object on Internet Explorer, and the type attribute is
added to the object's description, use Smart Identification to identify the button object if you test
aWeb page opened with Firefox or Chrome.

l Youmay design a test that enters text into an edit box, and then retrieves the edit box content
and sends it to the run results. If you use this test to check aWeb page opened in Chrome, the
text is not displayed in the run results, because Chrome does not store this text in a property that
UFT can retrieve.
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l SomeHTML5 input types are not supported in older browsers or browser versions. This means
that a control might have different properties, depending on the browser you use. If you record a
test on a browser that supports HTML5 but run it on a browser that does not support HTML5, or
vice versa, UFT might not be able tomatch the object description in your test to an object in the
Web page being tested. In such cases, UFT uses Smart Identification to identify the relevant
object during a run session, when highlighting objects in the Object Repository, or when using
the Object Spy.

For details about specific examples, see the type identification property description for the
WebEdit, WebNumber, orWebRange objects, in theWeb section of theHP UFT Object Model
Reference for GUI Testing. If UFTdoes not recognize an HTML5 element, make sure Smart
Identification is enabled.
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Tasks

How to Connect to a Remote Mac Computer
This task describes how to control the UFT connection to a remoteMac computer, to enable testing
Web applications on the Safari browser. For more details, see "WorkingWith Apple Safari on a
RemoteMac Computer" on page 499.

Note:

l If UFT tries to set up a remote connection to aMac when it is already connected to a
different Mac or port, the run session fails.

l If UFT tries to connect to a remoteMac and port to which it is already connected, the
existing connection is used and a warning is added to the test results.

This task includes the following steps:

l "Use the Remote Connection dialog box to control the connection to theMac while designing
your test" below

l "In the Record and Run Settings dialog box, specify the remoteMac computer to use when
running the test or component" on the next page

l "Alternatively, you can add steps to your test or component to control the remote connection to
theMac during the run session" on the next page

l "Configuring the Port Number to Use for the UFT-Mac Connection" on the next page

Use the Remote Connection dialog box to control the connection to the
Mac while designing your test

l Click the Remote Connection button in UFT's toolbar.

In the dialog that opens, enter the host name or IP Address to use for theMac.

Optionally, append a port number to the host name. For details, see "Configuring the Port
Number to Use for the UFT-Mac Connection" on the next page.

l Use theConnect/Disconnect button on this dialog to control the connection status while you
edit the test.

l This dialog also displays the current status of the connection.

l Before you run the test, make sure that you use one of themethods below to set up the UFT-
Mac connection for the run session.
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In the Record and Run Settings dialog box, specify the remote Mac
computer to use when running the test or component
Do one of the following:

l Select Record > Record and Run Settings to open the Record and Run Settings dialog box.
a. In theWeb tab, select Open the following browser when a record or run session

begins.

b. Select Apple Safari (on remote Mac computer) from the list of browsers.

c. Set the host (and port) information.

d. Select whether to disconnect from theMac at the end of the run session, and whether to
close the browser.

For details, see "Web Tab (Record and Run Settings Dialog Box)" on page 83.

l Set the environment variables REMOTE_HOST, BROWSER_ENV, andURL_ENV(optional)
to specify theMac connection details, the SAFARI browser, and, optionally, the URL to open in
the browser. For details, see "Environment Variables for aWeb-Based Environment" on page
61.

UFT sets up the connection with the specifiedMac and runs the Safari browser at the beginning of
the run session, whether the test runs it from UFT’s UI, or from an ALM test set.

Alternatively, you can add steps to your test or component to control the
remote connection to the Mac during the run session
Use theRemoteConnection utility object and its methods: Connect (hostname), Disconnect,
IsConnected to set up and disconnect the connection with theMac.

Use RemoteConnection.Run (Safari, <URL>), to run the Safari browser on the remoteMac after
you establish the connection.

Configuring the Port Number to Use for the UFT-Mac Connection
By default, UFT connects to theMac using port 8822. However, in some situations, youmight want
to use a different port. For example:

l If another application on theMac uses this port.

l If multiple UFT users need to connect to the sameMac computer. Each UFT user can use a
connection agent installed under a different Mac user account, with a different port number
configured.

To use a different port, append the port number to the host name: <hostname>:<port number>.

Make sure to configure the same port number on theMac, in the UFT Connection Agent
preferences and the Unified Functional Testing Agent extension on the Apple Safari browser.
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How to Install and Configure UFT Connection Agent on
Your Mac

Note: The UFT Connection Agent and the ability to run UFT tests on Safari on a remoteMac
are provided at Technology Preview level.

The UFT Connection Agent is a service installed on your AppleMac computer, which enables UFT
to communicate with the Safari browser using theWebSockets protocol. This enables UFT to run
tests onWeb applications running in Safari on theMac.

When you install the UFT Connection Agent, the agent service is installed on your Mac, and the
Unified Functional Testing Agent extension is installed on the Apple Safari browser.

The UFT Connection Agent runs automatically after installation and after each restart of theMac,
unless youmanually disable the agent using the System Preferences pane.

Caution: The UFT Connection Agent does not currently include security measures that may
be required by your security deployment best practices. Therefore:

l Make sure to use this agent only on dedicated computers that do not contain or provide
access to any sensitive information.

l When you are not actively running UFT tests on theMac, it is highly recommended that you
disable the UFT Connection Agent using the System Preferences pane.

By default, you do not need tomodify the preferences set for the UFT Connection Agent. UFT and
the connection agent communicate using port 8822. However, in some situations, youmight want
to specify a different port. For example:

l If another application on theMac uses this port.

l If multiple UFT users need to connect to the sameMac computer. Each UFT user can use a
connection agent installed under a different Mac user account, with a different port number
configured.

Caution: If youmodify the port number, youmust do so in the UFT Connection Agent
preferences, the Unified Functional Testing Agent extension in Safari, and in UFT. For details
on setting this in UFT, see "How to Connect to a RemoteMac Computer" on page 505.
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In addition to the port number, you can configure the level of logmessages to collect. By default, log
messages are collected from the connection agent, but not the Safari extension.

This task described installing and configuring the UFT Connection Agent, and includes the
following steps:

l "Install or Uninstall the UFT Connection Agent" below

l "Configure the UFT Connection Agent Preferences (Optional)" below

l "Configure the Unified Functional Testing Agent Extension in Safari (Optional)" on page 510

l "Troubleshooting the UFT Connection Agent" on page 510

Install or Uninstall the UFT Connection Agent

l Youmust have administrator permissions to install the UFT Connection Agent.

l All Mac users that use the UFT Connection Agent must have the agent installed in their
Mac user account.

1. Copy the installer image file (UFTConnectionAgent.dmg) from the <UFT installation
folder>/Installations/Safari folder to theMac.

2. Open the UFTConnectionAgent.dmg image file.

3. Double-click (HP UFT Connection Agent.pkg) to start the installation wizard, orUninstall to
remove the agent from your Mac.

This installs or removes both the UFT Connection Agent and the Unified Functional Testing
Agent Safari extension.

Note: If Safari or the System Preferences pane are open when you uninstall the agent,
reopen them for the uninstallation to take effect.

Configure the UFT Connection Agent Preferences (Optional)

1. To check or modify the status of the UFT Connection Agent, or to update its preferences, open
System Preferences and double-click HP UFT Connection Agent.

2. You canmodify any of the following preferences:

n Enable agent / Disable agent. Specifies whether to restart or disable the agent when you
click Apply. (If you select Disable agent, all other options in the pane are disabled.)

It is strongly recommended to disable the UFT Connection Agent when you are not actively
using it for UFT testing, to minimize security risks to your Mac.
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n Listening port. The port on which UFT communicates with the UFT Connection Agent and
the Safari browser.

Caution: This numbermust match the number defined in UFT and in the Unified
Functional Testing Agent extension in Safari.

n Log folder. The folder in which to save activity logmessages.

Make sure you have write permissions for this folder.

n Agent log level. The level of information to save in the agent log (Fatal, Error, Warning,
Debug).

The log is saved in the UFTAgent.log file in the specified folder.

n UFT Safari extension logs. Specifies whether to maintain a log of the Unified Functional
Testing Agent Safari extension activity in addition to the UFT Connection Agent log.
(Default = OFF).
There is no need to turn these logs on, unless HP Support personnel request it.

This log is saved in the SafariLog.log file in the same folder.

Note: To activate the Unified Functional Testing Agent Safari extension log, youmust
also select theEnable Remote Logging in the extension's preferences in Safari.

3. If you selectedEnable agent, make sure the Safari browser is closed before you click Apply.

4. Click Apply to save your changes and restart or disable the agent.

If you selectedEnable agent, the UFT Connection Agent restarts with the new preferences.

n The agent's status is displayed in the HP UFT Connection Agent preference pane.

Check the status tomake sure the agent runs successfully with the new preferences. If it
does not, check the UFTAgent.log file for problem details.

n If you set theUFT Safari extension logs option to ON and the remote logger service that
logs the Safari extension activity fails to run, this option is automatically set back to OFF.
Check the SafariLog.log file for problem details.

If you selectedDisable agent, the agent and the log services are stopped. The agent will only
run again if you specifically select Enable agent in this pane.
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Configure the Unified Functional Testing Agent Extension in Safari
(Optional)

1. Open the Unified Functional Testing Agent extension in Safari.

a. Select Safari > Preferences

b. In the Preferences dialog box, select theExtensions tab.

c. In the Extensions list in the left pane of the dialog box, select the Unified Functional
Testing Agent extension.

2. In the right pane, you canmodify any of the following preferences:

n Remote Agent Port: The port number on which UFT communicates with the
UFT Connection Agent and the Safari browser.

Caution: This numbermust match the number defined in the UFT Connection Agent
preferences and in UFT.

n Options related tomaintaining a log of the Unified Functional Testing Agent Safari extension
activity.There is no need tomodify these options, unless HP Support personnel request it.

o Default Logging Level. The level of information to save in the Unified Functional
Testing Agent Safari extension log file. (All, Trace, Debug, Info, Warn, Error, Fatal, Off )

o Enable Remote Logging. Specifies whether to maintain a log of the Unified Functional
Testing Agent Safari extension activity in addition to the UFT Connection Agent log. (By
default, this option is cleared.)

This log is saved in the SafariLog.log file in the same folder as the UFT Connection
Agent logs.

Note: To activate the Unified Functional Testing Agent Safari extension log, you
must also select theUFT Safari Extension logs option in the UFT Connection
Agent preferences.

o Leave the Logging Exceptions box empty. This is intended for use by HP Support only.

Troubleshooting the UFT Connection Agent

l If the agent remains in not running status after you update its preferences, check the
UFTAgent.log file for problem details.

For example, the port you specifiedmight be busy. It may be used by another application, or it
may be in use by a UFT Connection Agent installed on theMac under another user's account.
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Alternatively, youmight have entered a port number that is restricted by Apple. Consult the
Apple support site regarding restricted or blocked ports.

l If UFT fails to run tests on Safari or to recognize that it is installed on theMac:

n Make sure that you defined the same port number in the UFT Connection Agent preferences,
the Unified Functional Testing Agent extension in Safari, and in UFT.

n Make sure that you are not using a port number that is blocked by Safari. Consult the Apple
support site regarding restricted or blocked ports.

l If youmanually remove the Unified Functional Testing Agent extension from Safari, or theHP
UFT Connection Agent preferences pane from the System Preferences, you can reinstall them
by reinstalling the UFT Connection Agent on theMac.

Reinstalling the UFT Connection Agent resets its preferences to their defaults. Make sure to
update the preferences, if necessary, so that the correct port number is defined in the agent
preferences and in the Safari extension.

l If you turn on the UFT Safari extension logs, and when you save the preferences, the log option
is set to OFF, check the SafariLog.log file for problem details.

For example, the port used for these logs is theUFT-Mac communication port + 1. If this port
is busy, the remote logger service fails.
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Reference

Troubleshooting and Limitations - Web Add-in
This section contains troubleshooting and limitation information about working with theWeb Add-in.

Active Screen

l Whenworking with test objects that are supported usingWeb Add-in Extensibility, such as Web
2.0 test objects, if you create a checkpoint from the Active Screen, or try to view the object's
properties from the Active Screen, some property values may be empty.

l Whenworking with theWeb 2.0 ASPAjax Add-in, running scripts in the Active Screen is not
enabled by default.

Workaround:

a. In the Options dialog box, enable running scripts in the Active Screen. In Tools > Options >
GUI Testing tab > Active Screen node, set Run scripts toEnabled.

b. Close and reopen your test or component for the setting to take effect.

Object Identification
If UFT does not recognize your objects in the correct location, check to see that you are viewing the
page at 100%, and are not zooming in or out of the page.

For example, if you view the page at 90% or 120%, youmay be required to click or select an area to
the left or the right of the actual object in order to recognize it.

Recording
Autocomplete is not supported during recording sessions. When recording on an autocomplete
control, enter the full string instead of selecting the suggestion provided by the control. The step is
recorded in the sameway as other (non-autocomplete) controls.

Workaround:You can disable the AutoComplete feature in Microsoft Internet Explorer by selecting
Tools > Internet Options > Advanced and deselecting theUse inline AutoComplete under the
Browsing options.

Troubleshooting and Limitations - Browser Specific

l "Troubleshooting and Limitations - Internet Explorer" on the next page

l "Troubleshooting and Limitations - Mozilla Firefox" on page 514

l "Troubleshooting and Limitations - Google Chrome and Apple Safari" on page 515
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Troubleshooting and Limitations - Internet Explorer

Test Objects, Methods, and Properties

l Recognition of test objects when using AutoXPath is very slow for web pages in Quirks Mode
and Almost Standards Mode.

Workaround: Convert the web page into Standards Mode by adding or changing the DOCTYPE
of the page into <!DOCTYPE.htlm> or <!DOCTYPE.HTML PUBLIC "-//W3C//DTD HTML
4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd" or disabling AutoXPath capabilities in UFT by
clearing the Learn and run using automatic XPath identifiers in theWeb > Advanced pane
(Tools > Options > GUI Testing tab > Web > Advanced node).

l When using the RunScriptmethod with protectedmodeON, Alert, Confirm, or Prompt dialogs
are not displayed.

Workaround:Whenwriting a RunScriptmethod, use the followingmethod syntax: Set
wnd=Browser("<browser name>").
Page("<page name>").RunScript("window") wnd.alert()' or Browser("<browser
name>").Page("<page name>").RunScript "setTimeout(function () {alert(); }, 0)
".

l The WebXML test object is not supported on Internet Explorer 9 or later running in standardmode.
Accordingly, features related to WebXML test objects, such as XML checkpoints and output value
steps, are not supported on such browsers.

l In some cases, UFT does not support or recognize about:blank tabs in Internet Explorer 11.

Recording
When recording a test on Internet Explorer 8 or earlier with the Active Screen enabled, performance
on the site may become very slow. This is due to a performance issue in the JavaScript engine
used in these browsers.

Workaround: Record the test using Internet Explorer 9, or disable the Active Screen. For details,
see theHP Unified Functional Testing User Guide.

Web 2.0 Support
Due to synchronization issues, if you navigate to a new Web page in Internet Explorer while
recording, then UFTmay not record certain operations on certain ASP .NET Ajax or jQuery UI
objects in the page. Similarly, when running steps that navigate to a new page, UFT may fail to
perform certain steps on certain ASP .NET Ajax or jQuery UI objects.

Workaround: If the problem occurs while recording, refresh theWeb page and record the step
again. If the problem occurs while running, insert a Wait() statement before the problematic step.

Add-ins Guide
Chapter 32: Web Add-in - Quick Reference

HP Unified Functional Testing (12.00) Page 513 of 549



Troubleshooting and Limitations - Mozilla Firefox

General Limitations

l If twominor versions of Mozilla Firefox are installed on the same computer, and the earlier
version was installed after the later version, UFT may not recognize which is the latest version.

l UFT does not support anonymous content elements in non-XUL frames. (For example, the
buttons in theMozilla Firefox SSL exception page.)

Recording

l Recording onMozilla Firefox pages is only possible when the page is fully loaded.

l When recording steps in Mozilla Firefox, additional steps may be recorded.

Workaround:Manually remove the extraneous steps after the recording session ends.

l When recording on someMozilla Firefox versions, if you perform a search on google.com by
entering the search string and then pressingEnter, theSubmit operation is not recorded.
Subsequently, when you run the test, UFT enters the search string but does not perform the
search.

Workaround:Do one of the following:

n When recording the search operation, click the search button instead of pressingEnter.

n Manually add theSubmit (orClick) step to the test or component.

l The If Handler option in the "Web Event Recording Configuration Dialog box" (described on
page 533) works onMozilla Firefox browsers only if the handler is assigned as an attribute (for
example, <A onclick = "some code"/>) and not if it is assigned as a property (for example,
aObj.onclick = function() {some code})

Test Objects, Methods, Properties, and Checkpoints

l UFT does not support accessing browser dialog boxes (such as alert, confirmation, or prompt)
directly in Mozilla Firefox.

Workarounds for Firefox only:

n Use theHandleDialog orGetDialogTextmethods described in theWeb section of the
HP UFT Object Model Reference for GUI Testing.

n If theBrowser("xxx").Dialog("xxx").Page("xxx") object is recognized, either use a recovery
scenario with theHandleDialogmethod, or aBrowser("xxx").Dialog("xxx").Page
("xxx").Type step to handle the pop-up dialog box. For example, use an Enter key to click the
default button and close the dialog box.
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l TheObject Spy and Checkpoint Properties dialog boxes do not retrieve the current value of edit
boxes in Mozilla Firefox dialog boxes.

l TheObject Spy and Navigate and Learn dialog boxes do not retrieve the current value of
tabmodal dialogs in Mozilla Firefox.

l The Type property of the WebButton test object has a different default value in Microsoft Internet
Explorer andMozilla Firefox. In Microsoft Internet Explorer the default value is Button, but in
Mozilla Firefox the default value is Submit.

Workaround:Do not use the Type property in the description of a WebButton test object.

l When usingMozilla Firefox, the innertext, outertext, innerhtml and outerhtml property
values may differ from other browsers. Therefore, using these values in parameters or running
checkpoints that use these property values may cause the steps to fail.

l The following test objects, methods, and otherWeb-specific functionalities are not supported in
Firefox:

n ViewLink test object

n WebXML test object (and, accordingly, XML checkpoints and output value steps)

n Browser.Objectmethod

l Text area checkpoints are not supported onMozilla Firefox.

l If you drag a tab to create a separate window in Firefox, UFT stops recognizing, recording, or
running any web objects in the new window.

Web 2.0 Support

l Due to synchronization issues, if you navigate to a new Web page in Firefox while recording,
then UFTmay not record certain operations on certain ASP.NET Ajax or jQuery UI objects in the
page. Similarly, when running steps that navigate to a new page, UFT may fail to perform certain
steps on certain ASP.NET Ajax or jQuery UI objects.

Workaround: If the problem occurs while recording, refresh theWeb page and record the step
again. If the problem occurs while running, insert a Wait() statement before the problematic
step.

Troubleshooting and Limitations - Google Chrome and Apple Safari

Google Chrome and Apple Safari

See below for additional issues relevant only to Chrome or Safari.
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Functionality and Settings

l Web pages that modify the browser's JavaScript functionality (for example, aWeb page that
replaces the JSON object) may cause UFT to behave unexpectedly.

l The font and color properties for link objects contain different values in different browsers.
Therefore, if you create standard checkpoints in Microsoft Internet Explorer and select the font
and color properties, running these checkpoints in Chrome or Safari may cause the checkpoints
to fail.

l If you havemultiple Chrome or Safari users defined, youmust delete all users.

Test Objects, Methods and Properties

l When using Chrome or Safari, the innertext, outertext, innerhtml and outerhtml property
values may differ from other browsers. Therefore, using these values in parameters or running
checkpoints that use these property values may cause the steps to fail.

l The following test objects, methods, and otherWeb-specific functionalities are not supported in
Chrome or Safari:

n ViewLink test object

n chrome://* pages

n Browser.Homemethod

n Browser.FullScreenmethod

n Browser.ClearCachemethod

n Browser.Objectmethod

n Developer Tools pane. (Running steps on Chrome or Safari while the Developer Tools pane is
open is supported.)

n Web pages that include frame sets.

n Web test objects located inside iFrame controls with a blank or about:blankSRC
identification property value.

n WebXML test object (and, accordingly, XML checkpoints and output value steps).

n Web 2.0 test objects orWeb Add-in Extensibility-based test objects.

n Web-based environments, such as Web-based SAP, Siebel, Java, .NETWeb Forms, and so
on.
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Google Chrome

l If you are working in Google Chrome versions 25 or higher, youmust enable the UFT Agent
extension for Chromemanually.

l Internal Google Chrome pages, such as the about:blank page, Google Chrome sign-in page,
Google ChromeWeb Store, andGoogle Chrome's default tabs homepage are not recognized as
Web pages butWinObjects.

l Recording steps in Google Chrome is not supported.

l Page checkpoints and bitmap checkpoints may fail when running onGoogle Chrome because of
differences between Chrome and Internet Explorer. For page checkpoints this is related to
differences in the handling of casing in HTML source files.

l Text checkpoints fail when running onGoogle Chrome.

l When spying on aWeb file in Google Chrome, you get a fakepath for aWebfile value property.

l If youmanually uninstall the UFT Agent extension from Chrome, youmust manually reinstall it if
you reinstall UFT.

Google Chrome Frame

l Any limitations described in the UFT product documentation for Google Chrome are also
relevant for Google Chrome Frame.

l Google Chrome Frame is used for only one page at a time, and does not have access to Internet
Explorer's browsing history. For this reason, the Browser Back and Browser Forward
commands will not work when testing in Google Chrome Frame.

l You cannot run a test onmultiple tabs using Google Chrome Frame.

l You cannot run a UFT test while running Google Chrome andGoogle Chrome Frame
simultaneously.

l You cannot delete browser cookies.

l If your script navigates from one page to another in Google Chrome Frame, the next line in the
script may take some time to execute.

l The OpenTitle and OpenURL Browser object identification properties may return incorrect
values. This is becauseGoogle Chrome Frame creates a new Browser object for each
navigation activity.

l UFT's Navigate and Learn functionality is not supported onGoogle Chrome Frame.
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Apple Safari

l Only Web test object steps can run on Safari. All other steps run locally on the UFT computer.

l UFT does not recognize internal Safari pages, such as the New Tab page.

l The following functionalities are not supported when working with the Safari browser: 

n Recording

n Learning objects

n Object Spy

n MaintenanceMode

n Highlighting an object from the object repository in the application

n Creating an Active Screen or using the Update RunMode to update the Active Screen

n Checkpoints and output values that are not standard (such as File Content checkpoints and
output values, Text checkpoints and output values, and Bitmap checkpoints).

Note that Page checkpoints are supported, with the following limitations:

o Page checkpoints and bitmap checkpoints may fail when running onGoogle Chrome
because of differences between Chrome and Internet Explorer. For page checkpoints this
is related to differences in the handling of casing in HTML source files.

o The value of the load time identification property for Page and Frame test objects is
always 0when running on Safari. In Page checkpoints, the load time property is selected
by default, therefore Page checkpoints may fail when running on Safari.

Workaround:Deselect the load time property in Page checkpoints that need to run on
Safari.

l The following test objects and test object methods are not supported when running on Safari:

n WebFile.Setmethod

n Drag & Dropmethods (on all Web test objects)

n CaptureBitmapmethod (on all Web test objects)

l When running on Safari, UFT does not provide image captures in the run results when an error
occurs.

l Depending on the performance of your connection to theMac, statement completion for the
Object property might not work.
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l During a run session, steps that click on aWeb object that is supposed to open a new browser
tab fail to open the new tab.

Workaround:Disable the popup blocker in Safari. (Safari > Preferences > Security, clear the
Block pop-up windows check box).

l When running tests or components on Safari, recovery scenarios are not supported.

l Running tests or components on Safari using theMouse replay type is not supported.

Make sure that Event is selected as theReplay type in theRun settings section of theWeb >
Advanced options pane (Tools > Options > GUI Testing tab > Web pane > Advanced
node).

l In the automation object model,WebLauncher.Browser does not support the Safari browser.
To connect to a remoteMac during a test run and open the Safari browser, use the
RemoteConnection utility object and its methods. For details, see theWeb section of the
HP UFT Object Model Reference for GUI Testing.
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Concepts

Event Recording Configuration for Web Objects -
 Overview

When you record on aWeb application, UFT generates steps by recording the events you perform
on theWeb objects in your application. An event is a notification that occurs in response to an
operation, such as a change in state, or as a result of the user clicking themouse or pressing a key
while working in aWeb application.

Youmay need to recordmore or fewer events than UFT automatically records by default. If so, you
canmodify the default event recording settings forWeb objects using the "Web Event Recording
Configuration Dialog box" (described on page 533) to use one of three predefined configurations, or
you can customize the individual event recording configuration settings tomeet your specific
needs.

For example, UFT does not generally recordmouseover events on link objects. If, however, you
havemouseover behavior connected to a link, it may be important for you to record themouseover
event. In this case, you could customize the configuration to recordmouseover events on link
objects whenever they are connected to a behavior.

Considerations for Configuring Web Event Recording for Web Objects

l Event configuration is a global setting and therefore affects all steps that are recorded after you
change the settings.

l Changing the event configuration settings does not affect steps that have already been
recorded. If you find that UFT recordedmore or less than you need, change the event recording
configuration and then re-record the steps that are affected by the change.

l Changes to the customWeb event recording configuration settings do not affect open browsers.
To apply your changes, make the changes you need in theWeb Event Recording Configuration
dialog box, refresh any open browsers, and then start a new recording session.

l The settings in the "Web Event Recording Configuration Dialog box" (described on page 533)
affect recording only for objects that UFT recognizes as Web test objects. The recording
configuration for otherWeb-based objects (such as Siebel, PeopleSoft, .NETWeb Forms, and
SAPWeb controls) is defined by environment-specific XML configuration files.

Note: For the purposes of Web event recording, UFT treats Web test objects that are child
objects of a PSFrame test object as PeopleSoft objects and thus applies the settings in the
PeopleSoft event configuration XML file when recording those objects.
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l You can restore predefined settings after you set custom settings by resetting the event
recording configuration settings to the basic level from the "Web Event Recording Configuration
Dialog box". You can also restore the default custom level settings from the "CustomWeb
Event Recording Configuration Dialog Box" (described on page 534).

This section also includes:

l "Event Listening and Recording forWebObjects" below

l "Considerations - Event Listening and Recording" on the next page

Event Listening and Recording for Web Objects

For each event, you can instruct UFT to:

l listen every time the event occurs on the object.

l listen only if an event handler is attached to the event.

l listen only if a DHTML behavior is attached to the event.

l listen if either an event handler or DHTML behavior are attached to the event.

l never listen to the event.

An event handler is code in aWeb page, typically a function or routine written in a scripting
language, that receives control when the corresponding event occurs.

Note: UFT supports event handlers that are attached using an on* attribute (such as onclick
or onmouseover). It does not support other event handlers, such as those attached using an
addEventListener or attachEvent command.

A DHTML behavior encapsulates specific functionality or behavior on a page. When applied to a
standard HTML element on a page, a behavior enhances that element's default behavior.

For each event, you can enable recording, disable recording, or enable recording only if the next
event is dependent on the selected event.

For example, suppose a mouseover behavior modifies an image link. Youmay not want to record
the mouseover event each time you happen tomove the pointer over this image. It is essential,
though, that the mouseover event be recorded before a click event on the same object because only
the image that is displayed after the mouseover event enables the link event. This option applies
only to the Image and WebArea objects.

For task details, see "How toManage Listening and Recording Events forWebObjects" on page
530.

Recording Right Mouse Button Clicks
UFT enables you to record click events made using left, center, and right mouse buttons. By

Add-ins Guide
Chapter 33: Web Add-in - Testing and Configuration

HP Unified Functional Testing (12.00) Page 522 of 549



default, only left clicks are recorded, but you canmodify the configuration to record clicks from the
right and center buttons, as well.

UFT records the Click statement when the OnClick event is triggered. UFT differentiates between
themouse buttons by listening for events configured for each of themouse buttons. By default, it
listens for the OnMouseUp event, but you can also configure it to listen for the OnMouseDown event
using the "Web Event Recording Configuration Dialog box" (described on page 533).

Note:

l UFT does not record the simultaneous clicking of more than onemouse button.

l UFT does not record the right-click that opens the browser context menu, or the selection of
an item from the context menu. For details onmodifying the script manually to enable these
options, visit the HP Software Self-solve knowledge base and search for document
ID KM185231.

For details, see "How to Configure UFT to RecordMouse Clicks" on page 54.

Considerations - Event Listening and Recording

It can sometimes be difficult to find the ideal listen and recording settings. When defining these
settings, keep inmind the following guidelines:

l If settings for different objects in the Objects pane conflict, UFT gives first priority to settings for
specific HTML Tag Objects and second priority to Web Objects settings. UFT applies the
settings forAny Web Object only toWeb objects that do not belong to any other loadedWeb-
based environment and were not defined in theHTML Tag Object orWeb Objects areas.

l To record an event on an object, youmust instruct UFT to listen for the event, and to record the
event when it occurs. You can listen for an event on a child object, even if a parent object
contains the handler or behavior, or you can listen for an event on a parent object, even if the
child object contains the handler or behavior.

However, youmust enable recording for the event on the source object (the object on which
the event actually occurs, regardless of which parent object contains the handler or behavior).

For example, suppose a table cell with an onmouseover event handler contains two images.
When themousemoves over either of the images, the event also bubbles up to the cell, and the
bubbling includes information on the image that themousemoved over. You can record this
mouseover event by:

n Setting Listen on the <TD> tagmouseover event to If Handler (so that UFT "hears" the event
when it occurs), while disabling recording on it, and then setting Listen on the <IMG> tag
mouseover event toNever, while settingRecord on the <IMG> tag toEnable (to record the
mouseover event on the image after it is listened to at the <TD> level).

n Setting Listen on the <IMG> tagmouseover event toAlways (to listen for themouseover
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event even though the image tag does not contain a behavior or handler), and settingRecord
on the <IMG> tag toEnabled (to record themouseover event on the image).

l Instructing UFT to listen for many events onmany objects may lower performance, so it is
recommended to limit Listen settings to the required objects.

l In Internet Explorer, listening to the object on which the event occurs (the source object) can, in
rare situations, interfere with the event.

If you find that your application works properly until you begin recording on the application using
UFT, your Listen settings may be interfering.

l If this problem occurs with amouse event, try selecting the appropriateUse standard
Windows mouse events options in theWeb > Advanced pane of the Options dialog box
(Tools > Options > GUI Testing tab > Web > Advanced node). For details, see "Web >
Advanced Pane (Options Dialog Box)" on page 73.

l If this problem occurs with a keyboard or internal event, or theUse standard Windows mouse
events option does not solve your problem, set the Listen settings for the event toNever on the
source object (but keep the record setting enabled on the source object), and set the Listen
settings toAlways for a parent object.

Web 2.0 Toolkit Support

The Complexities of Testing Web 2.0 Controls

Web 2.0 sites often include a feature-rich, user-friendly interface based on client-side interactivity
frameworks. The controls in these sites are generally created using a combination of HTML and
client-side JavaScript code that create complex, interactive application objects.

Many groups and organizations have publishedWeb 2.0 toolkits. These toolkits comprise open
source JavaScript libraries that defineWeb 2.0 controls. Developers can use or customize these
toolkits to buildWeb 2.0 applications instead of developingWeb 2.0 controls from scratch.

The UFTWeb Add-in does not recognize these complex controls and, instead, relates to the HTML
elements that comprise them. This results in low-level steps on generic Web test objects. Such
steps may be difficult to create, read, andmaintain.

Testing Web 2.0 Controls with UFT Web 2.0 Add-in Support

UFTWeb Add-in Extensibility makes it possible to developWeb-based add-ins that can identify the
controls in aWeb 2.0 application in a way that better matches the intended purpose and
functionality of those controls.

UFT provides built-inWeb Add-in Extensibility support for several public Web 2.0 toolkits. The
support for each toolkit is packaged as a child add-in of theWeb Add-in. If you install theWeb 2.0
Toolkit Support, you can load this support by selecting the relevant toolkit name in the Add-in
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Manager. TheWeb 2.0 Toolkit Support Setup is available from theAdd-in Extensibility and Web
2.0 Toolkits option in the UFT setup.

The operations supported for eachWeb 2.0 test object class are a combination of custom
operations developed for that test object class and operations directly inherited from the
corresponding (base)Web Add-in test object class.

You work with aWeb 2.0 toolkit add-in much the sameway as you work with the regularWeb Add-
in. When the toolkit support is loaded, you can learn, record, create checkpoints, run steps, and use
all standard UFT functionality on controls from these toolkits.

UFT provides support for the following toolkits:

l ASP .NET Ajax - http://www.asp.net/ajax/

l Dojo - http://www.dojotoolkit.org

l GoogleWeb Toolkit (GWT) - http://code.google.com/webtoolkit/

l jQuery UI - http://jqueryui.com/

l Yahoo User Interface (Yahoo UI) - http://developer.yahoo.com/yui/

For details on the test objects and operations supported for these toolkits, see theWeb 2.0
Toolkits section of theHP UFT Object Model Reference for GUI Testing.

Considerations for Working with Web 2.0 Add-ins

l jQuery Library Injection. TheWeb 2.0 Add-in support is based on the jQuery JavaScript
library. Therefore, if you load any Web 2.0 add-in, UFT injects the jQuery JavaScript library into
every Web page that opens in a browser while UFT is open (unless a jQuery library is already
included in the page).

The specific jQuery UI file injected for eachWeb 2.0 add-in is specified in the add-in's toolkit
XML file, located in: <UFT installation>\dat\Extensibility\Web\Toolkits\
<ToolkitName>\<ToolkitName>.xml.

l F1 Help Support.When you press F1 on a test object operation that was inherited from the
Web Add-in, the Help displays information about that operation for theWeb Add-in test object
class from which the operation was inherited, and not for the extensibility-based test object
class used in your step.

Additionally, the details in the Help file reflect the behavior of the test objects and operations in
the XML files provided with UFT. If these files were customized or modified in any way, the
details in the Help files supplied with UFTmay no longer be accurate.

In general, when the content of the extensibility files for aWeb 2.0 toolkit is modified, the Help
file should also be changed as described in "Customization Guidelines" on page 527. In these
cases, you should contact the person or organization who customized the files as your first
contact point for support.
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l Checkpoints and Output Values. Inserting checkpoints and output values onWeb 2.0 objects
is supported only when recording steps.

l Container Objects. SomeWeb 2.0 objects that visually or behaviorally seem to contain other
objects in aWeb application are not learned as container objects in terms of the test object
hierarchy. For example, this is the case for the YUIDialogBox and GWTDialogBox test objects.

l Identification property values.Whenworking in Mozilla Firefox, the value of the selected
item or selected identification property is not available in the Object Spy for someWeb 2.0 test
object classes. The same is true when updating property values from the application in the
object repository. This is because the value is only retrievable when the browser is in focus.

Workaround:Retrieve the property value without removing focus from the browser. For
example:

Browser("Dijit Tree Test").Page("Dijit Tree Test").DojoTree("mytree").Sele
ct "Continents;Africa"
msgbox Browser("Dijit Tree Test").Page("Dijit Tree Test").DojoTree("mytre
e").
GetROProperty("selected item")

l Object Type Identification. In the toolkit XML file, the <HTMLTags> and <Conditions>
elements in the <Identification> section for the relevant test object class define how UFTmaps
Web controls to that class.

In the example below, UFT identifies a control as a GWTToggleButton test object (when the
GWT Add-in is loaded) if it has a <div>HTML tag and a classNameHTML property with a value
that matches the regular expression: .*gwt-ToggleButton.*

<Control TestObjectClass="GWTToggleButton">
<Settings>
<Variable name="default_imp_file" value="JavaScript\GWTToggleButton.j

s"/>
</Settings>
<Identification>

<Browser name="*">
<HTMLTags>
<Tag name="div"/>
</HTMLTags>
<Conditions type="IdentifyIfPropMatch">

<!-- The search string in this condition is treated as a regular expressio
n and is therefore equivalent to .*gwt-ToggleButton.* -->

<Condition prop_name="className" expected_value="gwt-ToggleButton" i
s_reg_exp="true"/>

</Conditions>
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</Browser>

In some cases (for example, when <Conditions type="CallIDFuncIfPropMatch">), a
JavaScript function that contains identification criteria is also used to helpmap controls to a test
object class.

Keep inmind that the support provided in the HP-furnishedWeb 2.0 add-ins is dependent on the
HTML and DOM structure of the controls. If developers of aWeb 2.0-based application change
the values of a control's properties, then the values defined for the <HTMLTags> and
<Conditions> elements of the toolkit XML files (or JavaScript files) may not enable UFT to
correctly identify those controls.

If UFT is not identifying an object in your application as you expect, you can view or adjust these
values in the relevant toolkit support files.

The toolkit XML files are located in: <UFT installation>\dat\Extensibility\Web\
Toolkits\<ToolkitName>\<ToolkitName>.xml

The JavaScript files are in a JavaScript folder under the above folder.

If youmodify this (or any) HP-furnished toolkit support set file, follow the guidelines described in
"Customization Guidelines" below.

For more details on the way UFT identifies supported controls and for details on the
implementation of the supported operations, see the comments provided in the XML and
JavaScript files for the relevant toolkit support set.

Customization Guidelines
If you are familiar withWeb Add-in Extensibility, then you can customize or further extend the built-
inWeb 2.0 support to match the needs of theWeb 2.0 toolkit application you are testing.

Additionally, if you have installedExtensibility Accelerator, you can use this IDE tomake it faster
and easier to design and develop the required extensibility XML files so that you can invest your
main efforts in the development of the JavaScript functions that will enable UFT to work with your
customWeb controls.

Extensibility Accelerator also comes with built-in projects for the UFTWeb 2.0 add-ins. You can
use these projects to help you learn the Extensibility Accelerator features or to more easily add to or
modify the provided support files.

If you customize or further extend any of the HP-furnished Web Add-in Extensibility files,
you should also do the following:

l Make a copy of, or otherwise back up, the original HP-provided files.

l Change the name and description that are displayed in the Add-in Manager for the toolkit.
Include the text: "Provided by <YourOrganization>" in the Add-in Manager description (in
the Controls\Description element of the toolkit XML file).
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l Create your ownHelp file to be opened for the customized test object classes or operations. You
must use a different file name than the HP-provided Help file. (Change the file name in the
HelpInfo element of the Test Object XML file.)

Note:When installing theWeb 2.0 add-ins, if a previous version of a selected add-in is
installed on your computer, the setup stores the previous files in a backup folder before
installing. Youmay need tomerge any customizations youmade to the previous version
into the new version.

For details on how tomake these changes and how to customize the support files, see the UFT
Web Add-in Extensibility documentation, available in the <UFT installation
folder>\help\Extensibility folder.

For details on working with Extensibility Accelerator, see theHP UFT Extensibility Accelerator for
HP Functional Testing User Guide.
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Tasks

How to Manage Custom Web Event Recording
Configurations

This task describes the different ways you can define, modify, export, and reset customWeb event
recording configurations.

This task includes the following steps:

l "Prerequisite - Open the CustomWeb Event Recording Configuration dialog box" below

l "Add objects to the HTML TagObjects list" below

l "Delete objects from the HTML TagObjects list" below

l "Save a custom configuration in an XML file" below

l "Load a custom configuration from an XML file" on the next page

l "Modify a custom configuration file manually - Optional" on the next page

l "Reset configuration settings to a pre-configured basic level" on the next page

Prerequisite - Open the CustomWeb Event Recording Configuration
dialog box
Select Record > Web Event Recording Configuration, and then click Custom Settings. For
user interface details, see "CustomWeb Event Recording Configuration Dialog Box" on page 534.

Add objects to the HTML Tag Objects list

1. Select Object > Add. A New Object object is displayed in the HTML TagObjects list.

2. Click New Object to rename it. Enter the exact HTML Tag name.

By default the new object is set to listen and record onclick events with handlers attached.

Delete objects from the HTML Tag Objects list

1. Select the object in the HTML TagObjects category that you want to delete.

2. Select Object > Delete. The object is deleted from the list.

Save a custom configuration in an XML file

1. Select File > Save Configuration As. The Save As dialog box opens.
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2. Navigate to the folder in which you want to save your event configuration file and enter a
configuration file name. The extension for configuration files is .xml.

3. Click Save to save the file and close the dialog box.

Load a custom configuration from an XML file

1. Select File > Load Configuration. TheOpen dialog box opens.

2. Locate the event configuration file (.xml) that you want to load and click Open. The dialog box
closes and the selected configuration is loaded.

Modify a custom configuration file manually - Optional
Open the .xml file that you saved in any text editor, andmodify the file according to your needs. To
enable UFT to recognize themodifications that youmade, the .xml file must keep its original
structure. For details on the XML file structure, see "Web Event Recording Configuration XML File
Structure" on page 64.

For example, you canmodify the file to enable right mouse click recording, as described in "How to
Configure UFT to RecordMouse Clicks" on page 54.

Reset configuration settings to a pre-configured basic level

l From the Custom Web Event Recording Configuration dialog box. In theReset to box,
select the predefined event recording level you want, and click Reset. All event settings are
restored to the defaults for the level you selected.

l From the Web Event Recording Configuration dialog box. Reset basic level configuration
settings by selectingDefault Settings. The configuration slider is displayed again, and all event
settings are restored to theBasic event recording configuration level.

Note:When you choose to reset predefined settings, your custom settings are cleared
completely. If you do not want to lose your changes, make sure to save your settings in an
event configuration file. For details, see "CustomWeb Event Recording Configuration Dialog
Box" on page 534.

How to Manage Listening and Recording Events for Web
Objects

This task describes the different ways you canmanage listening and recording events forWeb
objects.

Note: The listen and record settings aremutually independent. This means that you can
choose to listen to an event for a particular object, but not record it, or you can choose not to
listen to an event for an object, but still record the event. For details, see "Considerations -
Event Listening and Recording" on page 523.
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This task contains the following steps:

l "Prerequisite - Open the CustomWeb Event Recording Configuration dialog box" below

l "Add listening events for an object" below

l "Delete listening events for an object" below

l "Specify the listening criterion for an event" below

l "Set the recording status for an event" on the next page

l "Configure UFT to recordmouse click events" on the next page

Prerequisite - Open the CustomWeb Event Recording Configuration
dialog box
Select Record > Web Event Recording Configuration, and then click Custom Settings. For
user interface details, see "CustomWeb Event Recording Configuration Dialog Box" on page 534.

Add listening events for an object

1. Select the object to which you want to add an event, or select Any Web Object.

2. Select Event > Add. A list of available events opens. For details, see "CustomWeb Event
Recording Configuration Dialog Box" on page 534.

3. Select the event you want to add. The event is displayed in theEvent Name column in
alphabetical order. By default, UFT listens to the event when a handler is attached and always
records the event (as long as it is listened to at some level).

Delete listening events for an object

1. Select the object from which you want delete an event, or select Any Web Object.

2. Select the event you want to delete from theEvent Name column.

3. Select Event > Delete. The event is deleted from theEvent Name column.

Specify the listening criterion for an event

1. Select the object for which you want to modify the listening criterion or select Any Web
Object.

2. In the row of the event you want to modify, select the listening criterion you want from the
Listen column. You can select Always, If Handler, If Behavior, If Handler or Behavior, or
Never. For details, see "CustomWeb Event Recording Configuration Dialog Box" on page
534.
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Set the recording status for an event

1. Select the object for which you want to modify the recording status or select Any Web Object.

2. In the row of the event you want to modify, select a recording status from theRecord column.
For details, see "CustomWeb Event Recording Configuration Dialog Box" on page 534.

Configure UFT to record mouse click events
For details, see "How to Configure UFT to RecordMouse Clicks" on page 54.
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Reference

Web Event Recording Configuration Dialog box
This dialog box enables you to select a predefined event configuration level to use when recording
onWeb objects. By default, UFT uses theBasic level. If UFT does not record all the events you
need, youmay require a higher level.

To access Select Record > Web Event Recording Configuration.

See also "Event Recording Configuration forWebObjects - Overview" on page 521

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

<Event
configuration
level slider>

Enables you to select a predefined event recording configuration.

Note: If you define a custom event recording configuration, the slider scale
is hidden and the configuration description displays Custom.
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UI Elements Description

Basic
(selected by
default)

Instructs UFT to:

l Always record click events onWeb objects that commonly support clicking,
such as images, buttons, and radio buttons.

l Always record the submit event within forms.

l Record click events on otherWeb objects with an Internet Explorer handler
or behavior connected.
For details on handlers and behaviors, see "Event Listening and Recording
forWebObjects" on page 522.

l Record the mouseover event on images and imagemaps only if the event
following the mouseover is performed on the same object.

Medium Instructs UFT to record click events on the <DIV>, <SPAN>, and <TD>HTML tag
objects, in addition to the events recorded in the basic level.

High Instructs UFT to record mouseover, mousedown, and double-click events on
Web objects with handlers or behaviors attached, in addition to the events
recorded in the basic level.

Custom
Settings

Opens the "CustomWeb Event Recording Configuration Dialog Box"
(described on page 534), which enables you to customize the event recording
configuration.

Default
Settings

Restores the settings to theBasic level.

Note:When you choose to reset predefined settings, your custom settings
are cleared completely. If you customized the event recording configuration
and do not want to lose these settings, make sure to save your settings in
an event configuration file. For details, see "How toManage CustomWeb
Event Recording Configurations" on page 529.

Custom Web Event Recording Configuration Dialog Box
This dialog box enables you to customize the event recording configuration in cases where the
predefinedWeb event configuration levels do not exactly match your recording needs.
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You can customize event recording in the following ways:

l Add or delete objects to which UFT should apply special listening or recording settings.

l Add or delete events for which UFT should listen.

l Modify the listening or recording settings for an event.

To access 1. Select Record > Web Event Recording Configuration. TheWeb Event
Recording Configuration dialog box opens.

2. Click theCustom Settings button. The CustomWeb Event Recording
Configuration dialog box opens.

Important
information

l If an object is listed in the CustomWeb Event Recording Configuration dialog
box, then the settings for that object override the settings forAny Web
Object.

l You cannot delete or add to the list of objects in theWeb Objects category,
but you canmodify the settings for any of these objects.

l You can add any HTML Tag object in yourWeb page to theHTML Tag
Objects category.

Add-ins Guide
Chapter 33: Web Add-in - Testing and Configuration

HP Unified Functional Testing (12.00) Page 535 of 549



Relevant
tasks

l "How toManage CustomWeb Event Recording Configurations" on page 529

l "How toManage Listening and Recording Events forWebObjects" on page
530

l "How toModify Event Recording Configuration forWeb-Based Applications"
on page 53

l "How to Configure UFT to RecordMouse Clicks" on page 54

See also l "Event Recording Configuration forWebObjects - Overview" on page 521

l "Event Listening and Recording forWebObjects" on page 522

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Elements Description

<menu
options>

File Menu

l Load Configuration. Enables you to load a custom configuration XML file.

l Save Configuration As. Enables you to save your custom configuration in an
XML file.

Object Menu

l Add. Enables you to add an HTML tag object to the Objects pane.

l Delete. Enables you to delete an HTML tag object from theObjects pane.

Event Menu

l Add. Enables you to add the following events to the Events pane: onchange,
ondblclick, onblur, onfocus, onmousedown, onmouseup, onmouseover,
onmouseout, onsubmit, onreset, onpropertychange.

Depending on the selected object, not every event type is available.

l Delete. Delete the selected events from the Events pane.
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UI
Elements Description

<Objects
pane>

The list of Web test object classes and HTML tag objects. The top of the hierarchy is
Any Web Object.

Note:

l The settings forAny Web Object apply to any object on theWeb page, for
which there is no specific event recording configuration set. Below this are
theWeb Objects andHTML Tag Objects categories, each of which
contains a list of objects.

l Only HTML tag objects can be added or deleted to this list.

<Events
pane>

The list of events associated with the object.

Event
Name

The name of the event to which UFT listens and/or records, depending on the
settings you specify.

Listen The criteria that instructs UFT when to listen to the event. The following criteria are
available:

l Always. Always listens to the event.

l If Handler. Listens to the event if a handler is attached to it. A handler is code in
aWeb page, typically a function or routine written in a scripting language, that
receives control when the corresponding event occurs.

l If Behavior. Listens to the event if a DHTML behavior is attached to it. A
DHTML behavior encapsulates specific functionality or behavior on a page.
When applied to a standard HTML element on a page, a behavior enhances that
element's default behavior.

l If Handler or Behavior. Listens to the event if a handler or behavior is attached
to it.

l Never. Never listens to the event.
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UI
Elements Description

Record The record status for the selected object. The following statuses may be displayed:

l Enabled. Records the event each time it occurs on an object as long as UFT
listens to the event on the selected object, or on another object to which the event
bubbles.

Bubbling is the process whereby, when an event occurs on a child object, the
event can travel up the chain of hierarchy within the HTML code until it
encounters an event handler to process the event.

l Disabled. Does not record the specified event and ignores event bubbling where
applicable.

l Enabled on next event. Same as Enabled, except that it records the event only
if a subsequent event occurs on the same object.

Reset Enables you to reset your settings to a pre-configured level. The following levels are
available:

l Basic

l Medium

l High

Note:When you choose to reset predefined settings, your custom settings are
cleared completely. If you do not want to lose your changes, make sure to save
your settings in an event configuration file. For details, see "How toManage
CustomWeb Event Recording Configurations" on page 529.
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Chapter 33: GUI Checkpoints and Output Values
Per Add-in

The tables in this chapter show the categories of checkpoints and output values that are supported
by UFT for each add-in.

For details about using checkpoints and output values in a specific add-in, see the relevant add-in
section.

This chapter includes:

l "Supported Checkpoints " on the next page

l "Supported Output Values " on page 543

HP Unified Functional Testing (12.00) Page 540 of 549



Supported Checkpoints
The following table shows the categories of checkpoints that are supported by UFT for each add-in.

Table Legend

l S: Supported

l NS: Not Supported

l NA: Not Applicable

Note: Only standard and bitmap checkpoints are supported for keyword components.

For additional information, see "Footnotes" on page 543.
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Footnotes

1 Text checkpoints are supported only for Page, Frame, and ViewLink objects.

2When you insert a checkpoint on a PowerBuilder DataWindow control, UFT treats it as a table
and opens the Table Checkpoint Properties dialog box.

3 For NETWeb Forms, text checkpoints forWbfTreeView, WbfToolbar, andWbfTabStrip objects
are not supported.

4 The text area checkpoint mechanism for Java Applet objects is disabled by default. You can
enable it in the Advanced JavaOptions dialog box.

5 This is supported only when UFT records HTML elements using theWeb infrastructure, but not
when it records using the SAPGui Scripting Interface (as selected in the SAP pane of the Options
dialog box).

6 This is supported only when UFT is configured to use the OCR (optical character recognition)
mechanism.

7 XML checkpoints are not supported on Internet Explorer 9 or later running in standardmode, on
Google Chrome, onMozilla Firefox, or on Apple Safari because theWebXML test object is not
supported for these browsers.

Supported Output Values
The following table shows the categories of output values that are supported by UFT for each add-
in.

Table Legend

l S: Supported

l NS: Not Supported
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l NA: Not Applicable

Note: Only standard and bitmap output values are supported for keyword components.

For additional information, see "Footnotes" on the next page.
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Footnotes

1 Text output values are supported only for Page, Frame, and ViewLink objects.

2When you insert an output value step on a PowerBuilder DataWindow control, UFT treats it as a
table and opens the Table Output Value Properties dialog box.

3 The text area output mechanism for Java Applet objects is disabled by default. You can enable it
in the Advanced JavaOptions dialog box.
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4 This is supported only when UFT records HTML elements using theWeb infrastructure, but not
when it records using the SAPGui Scripting Interface (as selected in the SAP pane of the Options
dialog box).

5 This is supported only when UFT is configured to use the OCR (optical character recognition)
mechanism.

6 XML output values are not supported on Internet Explorer 9 or later running in standardmode, on
Google Chrome, or onMozilla Firefox, because theWebXML test object is not supported for these
browsers.

7 You can create text output values (tests only) only for TeScreen and TeTextScreen objects.

8 In the terminal emulator window you can add text checkpoints or output values (tests only) and
standard checkpoints and output values for the status bar and the dialog boxes that open from the
menu options. UFT recognizes these as standardWindows objects.
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Accessing UFT in Windows 8 Operating Systems
UFT applications and files that were accessible from theStartmenu in previous versions of Windows are accessible inWindows 8
from theStart screen or theApps screen.

l Applications (.exe files). You can access UFT applications inWindows 8 directly from theStart screen. For example, to start

UFT, double-click theHP Unified Functional Testing shortcut .

Other examples of applications accessible from theStart screen include:

n The RunResults Viewer

n All UFT tools, such as the Password Encoder and the License Validation Utility

n The API testing sample Flight applications

l Non-program files. You can access documentation and the link to theMercury Tours Website from theApps screen.

Note: By default, the Start and Apps screens onWindows 8 are set to open Internet Explorer in MetroMode. However, if User
Account Control is turned off on your computer, Windows 8 will not open Internet Explorer in Metromode. Therefore, if you try
to open an HTML shortcut from the Start or Apps screen, such as the UFT Help or Readme file, an error will be displayed.

To solve this, you can change the default behavior of Internet Explorer so that it never opens inMetromode. In the Internet
Properties dialog box > Programs tab, select Always in Internet Explorer on the desktop for the in theChoose how you
open links option. For more details, see http://support.microsoft.com/kb/2736601 and
http://blogs.msdn.com/b/ie/archive/2012/03/26/launch-options-for-internet-explorer-10-on-windows-8.aspx.

http://support.microsoft.com/kb/2736601
http://blogs.msdn.com/b/ie/archive/2012/03/26/launch-options-for-internet-explorer-10-on-windows-8.aspx


We appreciate your feedback!
If you have comments about this document, you can contact the documentation team by email. If
an email client is configured on this system, click the link above and an email window opens with
the following information in the subject line:

Feedback on Add-ins Guide (Unified Functional Testing 12.00)

Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a webmail client,
and send your feedback to sw-doc@hp.com.
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