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Legal Notices
Warranty

The only warranties for HP products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be
construed as constituting an additional warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer

Software, Computer Software Documentation, and Technical Data for Commercial ltems are licensed to the U.S. Government under vendor's standard commercial
license.

Copyright Notice

© Copyright 1993-2014 Hewlett-Packard Development Company, L.P.

Trademark Notices

Adobe™ is a trademark of Adobe Systems Incorporated.
Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation.
Oracle and Java are registered trademarks of Oracle and/or its affiliates.

UNIX® is aregistered trademark of The Open Group.
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Documentation Updates

The title page of this document contains the following identifying information:

® Software Version number, which indicates the software version.
® Document Release Date, which changes each time the document is updated.
® Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a document, go to: http://h20230.www2.hp.com/selfsolve/manuals
This site requires that you register for an HP Passport and sign in. To register for an HP Passport ID, go to: http://h20229.www2.hp.com/passport-registration.html|
Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product support service. Contact your HP sales representative for details.
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Support

Visit the HP Software Support Online web site at: http://www.hp.com/go/hpsoftwaresupport

This web site provides contact information and details about the products, services, and support that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and efficient way to access interactive technical support tools needed to manage
your business. As a valued support customer, you can benefit by using the support web site to:

Search for knowledge documents of interest

Submit and track support cases and enhancement requests
Download software patches

Manage support contracts

Look up HP support contacts

Review information about available services

Enter into discussions with other software customers
Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a support contract. To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp

HP Software Solutions Now accesses the HPSW Solution and Integration Portal Web site. This site enables you to explore HP Product Solutions to meet your
business needs, includes a full list of Integrations between HP Products, as well as a listing of ITIL Processes. The URL for this Web site is
http://h20230.www2.hp.com/sc/solutions/index.jsp
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Welcome to the HP LoadRunner Tutorial

LoadRunner Product Walk-Through How HP

overview LoadRunner
of automated load Works
testing

Do

What will you learn during this tutorial?

The LoadRunner tutorial is a self-paced printable guide, designed to lead you through the process of
load testing and familiarize you with the LoadRunner testing environment.

o This lesson provides an introduction to LoadRunner and testing concepts.

o Lessons 1 through 4 describe how to develop a Vuser script using VuGen - the Virtual User
Generator.

¢ Lessons 5 and 6 explain how to design and run load tests using the LoadRunner Controller.

e Lesson 7 introduces the Analysis tool, showing you how to create graphs and reports which will
help you analyze your load test.

At the conclusion of this tutorial, you will be ready to design, run, and monitor a simple load test on

your own system. It is recommended that you work through the tutorial in the order in which the
information is presented.

What are the LoadRunner components?

LoadRunner contains the following components:

e The Virtual User Generator or VuGen records end-user business processes and creates an
automated performance testing script, known as a Vuser script.

¢ The Controller organizes, drives, manages, and monitors the load test.
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o Analysis helps you view, dissect, and compare the results of the load tests.

Q) VuGen

@ Controller

é\?) Analysis

o Load Generators, computers that run Vusers to generate a load on the system.

LoadRunner Terminology

Term Description

Scenario Defines the events that occur during a testing session, based on performance
requirements.

Virtual Users Vusers emulate the actions of human users working on your system. A
or Vusers scenario can contain tens, hundreds, or even thousands of Vusers.

Vuser Script The recorded actions of a business process performed in your application.
Protocol A protocol is the method of communication between a client and the server.

Transaction To measure the performance of your system, you define transactions.A
transaction represents one or more end-user business processes. A
transaction enables you to measure how long it takes to perform these
business processes.

Script Defined by the quantities of the various resources that are required on a load
footprint generator in order to execute the Vuser script. Typical resources include
memory, CPU power, and disk space.

What is the LoadRunner load testing process?

Load testing with LoadRunner typically consists of five phases: planning, script creation, scenario
definition, scenario execution, and results analysis.
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1. 2. 3.

Plan Create Define

4, 5.

Run Analyze

the the
scenario results

the load Vuser the
test scripts scenario

1. Plan Load Test. Define your performance testing requirements, for example, number of
concurrent users, typical business processes, and required response times.

2. Create Vuser Scripts. Use VuGen to capture the end-user activities into automated scripts.
3. Define a Scenario. Use the Controller to set up the load test environment.
4. Run a Scenario. Use the Controller to drive, manage, and monitor the load test.

5. Analyze the Results. Use LoadRunner Analysis to create graphs and reports, and evaluate
the system performance.

Starting HP Web Tours

To illustrate LoadRunner as a solution for load testing, this tutorial uses performance requirements
for a sample application. The sample application, HP Web Tours, is a web-based travel agency
system. HP Web Tours users connect to a web server, search for flights, book flights, and check
flight itineraries.

While LoadRunner supports over 50 types of applications, this tutorial demonstrates how to load
test a Web-based application. If you are load testing applications that are not Web-based, please
contact HP for assistance.

In this section of the tutorial, you will learn how to start and log on to HP Web Tours.
1. Start the sample Web server.

Select Start > All Programs > HP Software > HP LoadRunner > Samples > Web > Start
Web Server.
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The Start Web Server dialog box opens. Keep this dialog box open while you access the Web
Tours application.

2. Open HP Web Tours.

Select Start > All Programs > HP Software > HP LoadRunner > Samples > Web > HP
Web Tours Application. A browser opens and displays the HP Web Tours home page.

Note: Ensure that LoadRunner is installed in the default folder on your computer. If
LoadRunner is installed in a non-default folder, the HP Web Tours application will not
open.

Note: The HP Web Tours application requires a browser with Java installed. For more
information, refer to the relevant Java documentation.

3. LogontoHP Web Tours.
a. Type in the following information:

- User name: jojo
- Password: bean
b. Onthe left pane, click Login. HP Web Tours welcomes you to the application.

4. Reserve aflight.
a. Onthe left pane click Flights. The Find Flight page opens.

b. Change the Arrival city to Los Angeles.
c. Click Continue.
d. Inthe Find Flight page, accept the default flight selection and click Continue.

e. Inthe Payment Details page, click Continue. The Invoice page is displayed, summarizing
your flight reservation.

5. End your HP Web Tours session.

On the left pane, click Sign Off to log off.

Defining the Application Performance
Requirements

Now that you are familiar with HP Web Tours, imagine that you are the performance engineer
responsible for signing off that HP Web Tours meets the needs of your business. Your project
manager has given you 4 criteria for release:
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1. HP Web Tours must successfully handle 10 concurrent travel agents.

2. HP Web Tours must be able to process 10 simultaneous flight bookings with response time not
exceeding 90 seconds.

3. HP Web Tours must be able to handle 10 travel agents running simultaneous itinerary checks
with response time not exceeding 120 seconds.

4. HP Web Tours must be able to handle 10 agents signing in and signing out of the system with
response time not exceeding 10 seconds.

This tutorial will walk you through the process of building load tests that validate each business
requirement so that you can attach a pass or fail before release.

"Lesson 1:

Building a Vuser Script" on page 13.
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Lesson 1: Building a Vuser Script

To generate a load on your system, you first build a Vuser script that you can run to emulate real
user behavior. You use VuGen to create and build Vuser scripts.

In this lesson you will cover the following topics:

o "Introducing VuGen - the Virtual User Generator" below
o "Creating a Blank Vuser Script" below

e "Recording a Vuser script" on page 15

e "Viewing the Vuser script" on page 18

Introducing VuGen - the Virtual User Generator

In a performance testing environment, LoadRunner replaces human users with virtual users, also
known as Vusers. Vusers generate a load on a system by emulating actions of typical users -ina
repeatable and predictable manner.

You use VuGen (LoadRunner's Virtual User Generator) to create Vuser scripts. VuGen works on a
record-and-playback principle. As you walk through a business process on your application, VuGen
records your actions and transforms these actions into steps in a Vuser script. These Vuser scripts
form the foundation of your load tests.

Creating a Blank Vuser Script

To develop a Vuser script, you first open VuGen and create a blank script. Thereafter, you can
enhance the blank script by recording events and adding manual enhancements to the script.

In this section, you will open VuGen and create a blank Vuser script that is based on the Web -
HTTP/HTML protocol.

Definition: A protocol is the method of communication between a client and a server.

To create a blank Vuser script:

1. Click Start > All Programs > HP Software > HP LoadRunner > Virtual User Generator or
double-click the Virtual User Generator shortcut icon on your desktop.
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th ¢
/it |I5EE
GEREFATOT

The HP Virtual User Generator [VuGen] opens.

2 Default layaut vl [ HFLM | @) @
Suolution Explorer Tax Start Page X =
% LoadRunner - Virtual User Generator SendFesdback | [ Options
Recent scripts: Open Create

N PN M Y

What's New  Community Links Support

| LoadRunner | Performance Center Business Process Monitaring
What's new in LoadRunner

Welcore to LoadRunner Service Pack 11.52. Inthis release many impravements have been made to LoadRunner
funetionality and performance. To see the new functionality infroduced inthe 11.50, 11,491 and 11,492 releases, see the
highlights and their links helow.

‘What's New in LoadRunner Service Pack 11.52

LoadRunner Service Pack 11.52 containg many new features and enhancements that
it irnprave L ity and your user experience.

|

‘What's New in LoadRunner Service Pack 11.51

L

LoadRunner Service Pack 11.51 cantains many new features and enhancements that

Recent solutions:
improve LoadR) and your user experience. .
‘ ‘What's New in LoadRunner 11.50
LoadRunner 11.50 containe many new features and enhancements that significantly improve
LoadRunner functionality and your user experience.
output -1 x

Q Options [S]

9, Solution Explorer | # Step Navigatar | [ Outout| I Tasks [ Enors | 7] Run-time D

Ready

2. Click File > New Script and Solution or click the Add New Script button = on the

VuGen toolbar. The Create a New Script dialog box opens.
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Create a New Script

Category: Protocol: Filter: E B
VuGen n NET ) FTP (File Transfer Protocol) ) MMS (Media Player)
Single Protocol | (n ajay ~ Click and Script &2 IMAP (Internet Messaging) G MMS (Multimedia Messaging Service)
Multiple Profocols
o] &L CVuser @ Java over HTTP [’y Maobile Application - HTTPHTML
obile
Popular ™ Citrix ICA # Java Record Replay [ ODBC
Recent 1, COMDCOM W Java Vuser [ Oracle - 2 Tier
” DNS (Domain Mame Resolution) [®) JavaScript Vuser &i COracle - Web App 11i

@» EJE (Enterprise Java Beans) LJ LDAP (Listing Directory Service) om Oracle NCA

[F Flex £3 MAPI (Microsoft Exchange) [ PeopleSoft - Tuxedo
Script Mame: ‘WebHttpHtmI2
Location: C:\WUsers\Documents\VuGen\Scripts
Protocol Advisor
Create Cancel

3. Make sure the Category is Single Protocol. VuGen displays a list of the protocols that are
available for a single-protocol script.

4. From the list of available protocols, select Web - HTTP/HTML and then click Create. VuGen
creates a blank Vuser script and displays the script in the VuGen Editor.

Recording a Vuser script

The next step in developing the Vuser script is to record the actions performed by a real user. In the
previous section, you created an empty Web - HTTP/HTML Vuser script. Now you can begin to
record actions directly into the script. In this section, you will track the actions that a travel agent
performs to reserve a flight from Denver to Los Angeles, and check the flight itinerary.

Note: To enable VuGen to record the actions that you perform in the Web Tours application,
click Record > Recording Options. In the Recording Options dialog box, select General >

Script, and then under Scripting Options, make sure that the Track processes created as
COM local servers check box is cleared.

To record the Vuser script:

1. Start recording on the HP Web Tours web site.

a. Click Record > Record or click the Record button @ on the VuGen toolbar. The Start
Recording dialog box opens.
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Start Recording - [WebHttpHtmi1] ? X

" Fewer Options |

Action selection:

Record into action: Action

Recording mode:

Record: Web Browser

Application: + | Microsoft Internet Explorer

URL address:

Settings:

Start recording: #® Immediately " In delayed mode

Working directory. += = c\Program Files (x86)\HPF\LoadRunnerBin

Recording Opfions

| @ Start Recording |~ Cancel

b. Inthe Record into action box, select Action.

c. From the Record list, select Web Browser.

d. Inthe Application box, make sure that Microsoft Internet Explorer appears.
e. Inthe URL address box, type http://localhost:1080/WebTours.

f. Click Start Recording. A new web browser opens and displays the HP Web Tours home
page.
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| . i :

%Cnnvert b @ Select

aed) |g http:/flocalhost: 1080 e b Taurs - | ] | +y | %

". Google o |
7:3 Favarites 7_;5 Infnrmatinn Engineeting .. 2 HP Application Lifecycle .. @2 QC - AlM [0 A7 -.l Google @ | Bank Hapoalim

@ wieb Tours B~ B - = & v Pager Sefetyv Tools~ @ 53

K72 WebTours

Username I

Password we b TO u rS |

m

Welcome to the Web Tours site.
To make reservations,please enter your account information to the left.

If you haven't registered yet, sign up now to get access to all our resources.

To configure the server options, use administration link.

This product uses parts of the SMT Kernel, Copyright (c) 1991-99 iMatix Corporation =i

Dane & Local intranet | Protected Mode: OFf v HL0%K v

Note: If there is an error opening HP Web Tours, make sure that the Web Tours
Server is running. The presence of the Start Web Tours dialog box indicates that the
server is running. To start the server, select Start > All Programs > HP Software >
HP LoadRunner > Samples > Web > Start Web Server.

VuGen's floating Recording toolbar opens.

Recording... (95) 00:00:26 (= |
@ [l Action @ 18 e (g | [

2. LogontoHP Web Tours.

a.

b.

Type in the following information:
- User name: jojo
- Password: bean

On the left pane, click Login. HP Web Tours welcomes you to the application.

3. Enterthe flight details.

a.

b.

HP LoadRunner (12.00)

Click Flights. The Find Flight page opens.

From Departure City, select Denver (default).
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c. Departure Date: Keep the default date.

d. From Arrival City, select Los Angeles.

e. Return Date: Keep the default date.

f. From Seating Preference, select Aisle.

g. Keep the rest of the default settings and click Continue. The Find Flight page opens.
Select aflight.

Click Continue to accept the default flight selections. The Payment Details page opens.
Enter payment information and book the flight.

a. Inthe Credit Card box, enter 12345678.

b. Inthe Exp Date box, enter 06/14.

c. Click Continue. The Invoice page opens, displaying your invoice.

In the left pane, click Itinerary. The Itinerary page opens.

In the left pane, click Sign Off.

Close the browser, and then click the Stop Recording button @ on the VuGen floating
toolbar to stop the recording process.

VuGen generates the required code and inserts the code into the Vuser script.
If the Design Studio opens, click Close to close the Design Studio.

Save the Vuser script.
a. Select File > Save Script As.

b. Navigate to <LoadRunner Installation>\tutorial, create a new folder named Scripts, and
then navigate to the new Scripts folder.

c. Inthe File name box, type basic_tutorial.

d. Click Save. VuGen saves the script and displays the script name in the VuGen title bar.

Viewing the Vuser script

You have now recorded the actions of a travel agent logging in, booking a flight, checking the
itinerary, and logging off. VuGen recorded your steps from the moment you clicked the Start
Recording button to the moment you clicked the Stop Recording button.
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You can now use VuGen to view the script. VuGen lets you see the Vuser script in a number of
formats:

« The Solution Explorer gives you structured access to the various parts of a Vuser script, as
well as to a number of files that are associated with the Vuser script.

< basic_tutorial - HP Virtual User Generator

| File Edit Search WView

- Z ¢
( Solution Explorer
'2, Solution Untj
ic_tutorial

@ Actions
I @ vuser_init
@ Action
_..@ wuser_end
@-[F BdraFiles
[ AsyncCallbacks.c
~.[1) olobals.h
(7> Run-Time Settings
&% Parameters
-4 Replay Runs [Aborted - resultluteration1]

&) Solution Explorer  # Step Navigator | Tl Outline |

« The Step Navigator displays an icon-based view of the script that lists the actions of the Vuser
as steps. For each action you performed during recording, VuGen generated a corresponding
step in the Step Navigator.
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0 basic_tutorial - HP Virtual User Generator - Web - HTTP/HTML

File

Edit

Search

-

I L | ¥ v @
( Step Navigator
f

arch text I

@]

View

Design Recor

E @ @ sta
* QX

Line Name Step
4 | web_ur 3| Url: WebTours
l 13 Ir_think_time Think Time - 24 (sec)
15 F@weh_suhmit_fnrm 25| Submit Form: login.pl
24 H Ir_think_time Think Time - 6 (sec)
26 |32 web_image [Z3|Image: Search Flights Button
! 31 (@ web_url 23| Url: FormDateUpdate.class
40 |2 web_ur | Url: CalSelect.class
49 |[Z web_url 25| Url: Calendar.class
58 Ir_think_time Think Time - 33 (sec)
|| 60 |5Qweb_submit_data _l:ﬂ Submit Data: reservations.pl
83 Ir_think_time Think Time - 20 (sec)
85 [5@web_submit_form 3| Submit Form: reservations.pl_2
93 E Ir_think_time Think Time - 25 (sec)
95 |S@web_submit_form 3| Submit Form: reservations.pl_3
110 |HE Ir_think_time Think Time - 8 (sec)
112 ([ web_url Za|Url: welcorne.pl
121 (53 web_image 23| Image: SignOff Button
| 17 steps displayed
| laSt:;lutitm Explorer | . Step Navigator EOutline [

The Step Navigator displays a snapshot icon ! to indicate that a specific step contains a

snapshot.

26

31 web_image

=

Im)ge: Search Flights Button

To view the script in the Step Navigator, select View > Step Navigator, or click the Step

Navigator button IEI on the VuGen toolbar. Double-click any step in the Step Navigator to
display the corresponding function in the Editor.

The VuGen Editor displays a text-based view of the script. In the Editor, the actions of the

Vuser are listed as API functions. In the Editor, VuGen uses color-coding to show the functions
and their argument values in the script. You can type C or LoadRunner API functions, as well as
control flow statements, directly into the script.

HP LoadRunner (12.00)

Page 20 of 102



Tutorial
Lesson 1: Building a Vuser Script

hasic_.tarial  Action.c 5 X
@HP.VuGenC.GIDbaI.Action - &2 pction() -
L 138 Action()
2
3 |
4 web_url("WebTours™,
s "URL=http://localhost: 1888/ webTours”,
& "Resource=a",
7 "RecContent Type=text/ html",
& "Referer=",
El "Snapshot=t1.inf",
1a “Mode=HTML",
11 LAST);
12
13 Ir_think_time(24];
14
15 web_submit_form{"login.pl®™,
16 "Snapshot=t2.inf",
17 ITEMDATA,
18 "MName=username”, "value=jojo", ENDITEM,
19 "Name=password"”, “value=bean", EMDITEM,

"Lesson 2: Replaying Your Script" on page 22.
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Lesson 2: Replaying Your Script

In the previous lesson, you recorded a set of typical user actions, and VuGen transcribed these
actions in to a Vuser script. You can now replay your recorded script to verify that the script runs
properly, before you incorporate the script into a load testing scenario.

Before replaying the script, you must configure the run-time settings for the script, which define the
behavior of the Vuser.

In this lesson you will cover the following topics:

o How do | set the run-time behavior?

e How do | run my Vuser script?

e Where can | view information about the replay?

e How do | know if my script replayed successfully?

e How do | search orfilter the results?

How do | set the Vuser's run-time behavior?

LoadRunner run-time settings let you emulate different kinds of user activity and behavior. For
example, you could emulate a user who responds immediately to output from the server, ora user
who stops and thinks before each response. You can also configure run-time settings to specify
how many times the Vuser should repeat a set of actions in the Vuser script.

There are general run-time settings, and settings that are specific to certain Vuser protocols only.
For example, for a Web emulation, you could instruct your Vusers to replay your script in Firefox,
Chrome, or Internet Explorer. Run-time settings for specific protocols will be covered in "Lesson 4:
Preparing a Vuser Script for Load Testing" on page 39. This lesson describes some of the general
run-time settings - settings that apply to all Vuser protocols. The general run-time settings include:

Run Logic. The number of times that a Vuser repeats various sections of the Vuser script.

Pacing. The time to wait between repetitions.

Think Time. The time the Vuser stops to think between steps in the script.

Log. The level of information that you want to gather during playback.

Note: This lesson describes how to use VuGen to modify the run-time settings. A later lesson
describes how to use the LoadRunner Controller to modify the run-time settings.

To set the run-time settings:
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1. Open the Vuser script that you saved in the previous lesson.
2. Open the Run-Time Settings dialog box.

Click Replay > Run-Time Settings. The Run-time Settings dialog box opens.

Run-Time Settings ? X

- (eneral

- Pacing

- Log

- Think Time

- Addtional sttributes

- Mizcellaneous
- Data Format Extension

Configuration

Chain Configuration
- Metweark

Speed Simulation
- Browser

.. Brawyser Emulation
- Internet Pratacol

- ContertCheck

- Procy

- Preferences

... Download Fiters

3. Set the Run Logic settings.

In the left pane, under General, click Run Logic.
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Run-Time Settings

- General

General: Run Logic
Run Logic

Iteration Count

Sp——
Think Time MNumber of Iterations: |2 —
- Additional attri
Ffdlth al attributes =) lgj Init
‘Miscellaneous © vuser it
Data Format Extension . -
) : =-1J Run(x2)
-Configuration ’
) . i & Action
Chain Configuration
=¥ End
etwork & yuser_end
Speed Simulation ' -
Browwser
Browser Emulation
Internet Protocol

The Run Logic settings enable you to set the number of iterations for the Vuser script. This is
the number of times to repeat the Action section of the Vuser script when the script is replayed.

Set the Number of iterations to 2.
4. Set the Pacing settings.

In the left pane, under General, click Pacing.

Run-Time Settings

T —
< - General General: Pacing
Run Logic
Pacing —Start new Iteration
o " As soon as the previous iteration ends

Think Time
Additional attributes " After the previous iteration ends:
Miscellaneous

Data Format Extension Withia Ilixed 'I delay of IBD-UUU _,:.' sec
Configuration

Net\::a'::in contereton @ tfiandom ] intervals, every[50000 =] 1o [30.000 = sec
Speed Simulation (provided that the previous iteration ends by that time)

Browvser
Armweear Frailatinn

The Pacing settings enable you to control the time between iterations. You will specify a
random time. This accurately emulates a real-life setting where the user waits between
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actions, but at random intervals. For example, you do not see real users always waiting exactly
60 seconds between repeated actions.

Select the third radio button, and select the following:
At random intervals, every 60.000 to 90.000 seconds.
5. Set the Log settings.

In the left pane, under General, click Log.

Run-Time Settings

General General: Log
Run Logic
Pacing ¥ Enable logging
Log

hink T Log options
Addtional attributes " Send messages only when an eror occurs
Miscellaneous 2y &

Data Format Extension Sl a0 s a0
Configuration Log messages at the detail level of
Chain Configuration " Standard log

Network

ol
Speed Simulation Ef e
Browser [V Parameter substitution

Brovvser Emulation
Internet Protocol

CorttentCheck [” Advanced trace

Proxy

™ Data retumed by server

The Log settings indicate how much information to log while running the Vuser Script. While
developing a Vuser script, you may want to enable some logging for debugging purposes, but
once you verify that your script is functional, you can enable logging for errors only, or even
disable logging.

Select Extended log and enable Parameter substitution. This option will be relevant for the
following lesson at which point it will be discussed.

6. View the Think Time settings.

In the left pane, under General, click Think Time.
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Run-Time Settings

' General: Think Time

General
Run Logic

Pacing Think Time options
Log

g " Ignore think time
adcitinoaletlbutes (" Replay think time
Miscellaneous o
Data Format Extension
Configuration
Chain Configuration
Network
Speed Simulation Hir - |50
Browser
Browvser Emulation it Brink time to Iw =
Internet Protocol Jo | e e =
CortentCheck

As recorded

| Multiplyre

€ Use random percentage of recorded think time:

Keep the default think time setting - Ignore think time. You will set the think time from the
Controller. Keep in mind that when you run the script in VuGen, it will run quickly since it will
not include think time.

7. Click OK to close the Run-Time Settings dialog box.

How do | run my Vuser Script?

After recording the Vuser script and setting the run-time settings, you are ready to run the script.
VuGen provides a number of indicators that your script is running.

1. The message "Running" appears in the lower left corner of VuGen.

2. Avyellow marker appears in the Editor and indicates the specific line that is being replayed.
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3. The Output pane displays messages as the replay progresses.

) basic_tutorial - HP Virtual User Generator - Web - HTTR/HTML @M

File Edit Search View Design Record Replay Tools Window

I
- - v v | 200 ~# 3 @ 35 @ Replaylayout v (%] .
Solution Explorer basic_.. torial_bb1 : Action.c ¥ X
& Z @$ HPVuGenC Global Action v 2 Action) -
= Solution Uniitied 2| 1 Baction()
-] basic_tutorial -
B-€2» Actions 3 E
@ vuser_init 5| 4 wb_url("UebTours",
@ Action S "URL=http://localhost: 1888/ lebTours",
. = “Resource=e",
¢ Vus_e’—end 7 "RecContent Type=text/html", l
B-[3 ExtraFiles 8 “Referer=",
[ AsyncCallbacks. 9 “Snapshot=t1.inf",
) globals.h 10 “Mode=HTHL" ,
&> Run-Time Settings il LAST)
= 2 I
&) Parameters 13 1r_think_time(24); i
[ Replay Runs [No Ru 14
15 web_submit_form("login.pl®,
16 “Snapshot=t2.inf",
17 ITEMDATA,

Qutput
Replay - =@

vuser_init.c vuser_init

Locate Options~ |

& D [ output i Call stack | 62 Watch [ [3) Local Variables | [, Breakpoints |
Runnm Script parse passed @ In27 col1 chi

7

To run a Vuser script:

1. Open the Vuser script in VuGen.

2. Click Replay > Run or click the Replay button IEI on the VuGen toolbar.

After the replay ends, a message box may prompt you to scan for correlations. Click No.

Where can | view information about the replay?

When the Vuser script stops running, you can view a summary of the replay. The replay summary
is displayed in the Replay Summary tab.
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hasic_tutorial - Replay Summary X hasic_tutarial :vuser_end.c hasic_tutorial - vuser_init.c

Script Name: basic_tutorial

Script Passed

Elapsed time: 02:49 mm:ss  Started at: 1/7/2013 11:37:51 AWM Think time:  00:00.000 mm:ss.ms
Ended at:  1/7/2013 11:40:41 AW Wasted time: 00:01 825 mm:ss.ms

Select result scope:  sverage

More information is available in:
The Test Results

The Replay Log

The Replay Summary tab lists basic information about the script run, such as the duration of the
replay, and the start and end times of the replay. In addition, the Replay Summary tab provides you
with alink that displays a log of the script events, and another link that displays detailed results of
the script run.

The Replay log - a log of the events that occurred during the replay of the script - is displayed in
VuGen’s Output pane. The Output pane uses color-coding to display a textual summary of the
events that occurred during the replay.

In this section of the tutorial, you will open the Replay log and locate specific events and
notifications within the log.

To view the Replay log:

'E‘
1. Afterreplaying a Vuser script, click View > Output or click the Output button on the
VuGen toolbar. Alternatively, click the Replay Log link in the Replay Summary tab.

2. Make sure that Replay is selected in the Output pane.
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Output

Replay ® [E ¢ Locate Q Options
Virtual User @cript started at : 11/21/2011 11:01:36 AM

atarting ion vuser_init.

Web Turbo Replay of LoadRunner 12.0.2 for Windows 7; build 849 (Oct 11 2211
03:30:04)  [Msgld: MMSG-27143]

Run Mode: HTML [Msgld: MMSG-26000]

Run-Time Settings file: “C:‘\LoadRunner\Scriptsi\basic_tutorial_bbl\
wdefault.cfg”  [MsgId: MMSG-27141)

Starting to download the proxy automatic configuration script, URL="http://
autocache. hp. com/* [MsgId: MMSG-27295]

Redirecting "http://autocache.hp.com/” (redirection depth is @) [MsgId:
MHSG-26694 ]

To location “http://autocache.hp.com/rhv-local.pac?SiteName=emea-myd-
yehud-1&version=V37NET" [MsgId: MMSG-26693]

Proxy automatic configuration script (URL="http://autocache.hp.com/"
downloaded and evaluated successfully  [Msgld: MMSG-27094]

Ending action vuser_init.

2 Output Tasks [ Errors & RunTime Data [= Snapshot

From Scope, select Current Script.
Click Include in search, and then select the Logs check box.

Use the Search dialog box to locate the following items in the Replay log:

"Virtual User Script Started" - the beginning of the script run.

"Vuser Terminated" - the end of the script run.

From the VuGen menu, click Search > Quick Find to open the Search dialog box.

"iteration" - the beginning and the end of each iteration and the iteration number. (This text

appears in orange lettering.)

Note: The Output pane displays successful steps in green and errors in red. For
example, if the Vuser was unable to connect to the server, the Output pane would
display the error text in red, and indicate the line number in the script where the error

occurred.
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Cutput

Replay # 1B % Locate & Options H

Running wuser...
Motify: max connections per serwer @ &
starting action Action.
Action.ci(4): web_url({"WebTours™) started [MsgId: MM3GE-26355]
Action.c(4): Failed to cennect to proxy localhost:1882 - connect() failed
[iErroriode: [1@261] Connection refused). Retrying with nest prosy

[Msgld: MMSG-26803)
Action.c(4): Error -27724: Resolve/connect failed for the following proxies
specified in the automatic configuration script: "DIRECT". Requested URL is
"http://localbost: 1888/ WebTours". [MsgId: MERR-27724]
Action.c(4): web_url({"WebTours™) highest sewerity lewel was “ERROR™, @ body
bytes, @ header bytes [MsgId: MMSE-263588]
Ending action Action.

Waiting £8.1880 seconds for iteratien pacing.

Fl output| [ Tasks B Errors & Run Time Data | s Snapshot

Note: If you double-click a line in the Output pane, VuGen indicates the corresponding
step in the script in the VuGen Editor.

How do | know if my script replayed
successfully?

After you replay the events that you recorded, you need to look at the replay results to see if the
script replayed successfully. If something failed, you want to know when and why it failed.

In this section you will view and analyze the results of your script run. VuGen summarizes the
results of the replay in the Test Results window.
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ﬁ'hasic_tutorial - Test Results [_ (O] x|

: File Wiew Tools Help

BT s A&l | 2

| v

5 ¥ basi_tutorial Jteration 1 (Raw 1) basic_tutorial Results Summary
- 3 basic_tutarial Tteration 2 (Row 2)
Q viser_end Surmmary

Test: bazic_tutorial

Results name: resultl

Time Zone: Standard Time
Run started: 2/7/2013 - 15:02:39
Run ended: 2/7/2013 - 15:04:47

Iteration # Results
1 Passed
2 Passed
Status Times
Passed 16
Failed Q
0

-

Result Details « Screen Recorder
For Help, press F1 [ready L1l I

|

When the Test Results window first opens, it contains two panes: The Tree pane (on the left) and
the Results Summary pane (on the right).

o The Tree pane contains the results tree. Each iteration in the tree is numbered.

o The Results Summary pane contains the details of the script replay, as well as screen
recorder movies, if any. The top table indicates which iterations passed and which failed. The
test is considered to have passed when the Vuser successfully navigates through the HP Web
Tours site according to the original recording. The bottom table indicates whether transactions
and checkpoints passed or failed. You will add these features to your test later on in the tutorial.

To view replay results:
1. Click the Replay Summary tab.

2. Click Replay > Test Results. The Test Results window opens and displays a summary of the
replay results.

In the next section, you will drill down into the replay results to determine if the script reached the
intended Web pages during replay.

How do | search or filter the replay results?

If your replay results indicate that something failed, you can drill down and locate the point of failure.

In the Tree pane of the Test Results window, you can expand the test tree and view the results of
each step separately. The Summary pane shows a snapshot of the replay during that iteration.
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Expand an iteration node in the tree.
a. Intheresults tree, expand the basic_tutorial Iteration 1 node.

b. Expand the Action Summary node. The expanded node shows a list of the steps
performed in that iteration.

View aresult snapshot.

Click the Submit Form:login.pl node. The Summary pane displays the replay snapshot
associated with that step.

View the step summary.

The Summary pane displays the step summary information: the object or step name, the
details about whether the page loaded successfully, the result (Passed, Failed, Done, or
Warning), and the time that the step was performed.

Search for a result status.
You can search the replay results for the words Passed or Failed.

This is helpful, as in a case where the overall Results Summary indicates that the replay failed,
you can determine where it failed.

a. Tosearchthe replay results, select Tools > Find or click the Find button on the Test
Results toolbar. The Find dialog box opens.

-

Find

Find resultz steps with the following status:

\ g

[ Faled

[ 'warming Direction Cancel
[ Pazzed " Up

[ Daone * Down Help

L

b. Select the Passed check box, make sure no other options are selected, and click Find
Next. The Test Tree pane highlights the first step in which the status is Passed.

Note: If no steps of the selected status can be found, no step is highlighted.

Filter the results.

You can filter the Test Tree pane to display a specific iteration or status. For example, you can
filter it to show only Failed status.
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a. Select View > Filters or click the Filters button on the Test Results toolbar. The

Filters dialog box opens.

-
Filters

]

Iterations

™ From jteration |1 ::I {u] |1

=

|| Status

¥ Fal [ ‘wWarming [T Pass

[T Dore

Content

IO

™ Show only actions

k. I Cancel

Help

b. Under Status, select Fail and clear all the other options.

c. Under Content, select All and click OK. The left pane becomes empty, since there were

no failures.

6. Close the Test Results window.

Click File > Exit.

"Lesson 3: Solving Common Replay Problems" on
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Lesson 3: Solving Common Replay
Problems

After you create a Vuser script, you validate it by running it from VuGen. Sometimes a replay will
fail, even though the recording of the same actions succeeded.

Many applications use dynamic values that change each time you use the application. For
example, some servers assign a unique session ID for every new session. When you try toreplay a
recorded session, the application creates a new session ID that differs from the recorded session
ID. Dynamic values, such as these unique session IDs, may pose difficulties when you replay
specific types of Vuser scripts. For example, dynamic session IDs often pose problems when
replaying Web-HTTP/HTML scripts, but not when replaying Web-TruClient scripts.

LoadRunner use correlation to address the issue of dynamic values. Correlation saves the
changing values, in our case the session ID, to a parameter. When running the Vuser script, the
Vuser does not use the recorded value—instead, it uses the new session ID, assigned to it by the
server.

In this lesson you will observe how LoadRunner solves the issue of dynamic values when running
Web-HTTP/HTML Vuser scripts.

In this lesson you will cover the following topics:
e Preparing HP Web Tours for replay errors

e How do | work with unique server values?

Preparing HP Web Tours for replay errors

To illustrate a common replay failure, you need to modify a setting in the HP Web Tours application.
This setting tells the HP Web Tours server to issue and require unique session IDs.

1. Open HP Web Tours.

Select Start > All Programs > HP Software > HP LoadRunner > Samples > Web > HP
Web Tours Application. A browser opens with the HP Web Tours home page.

2. Change the server options.
a. Click the administration link on the HP Web Tours home page. The Administration Page
opens.

b. Select the Set LOGIN form's action tag to an error page checkbox. This setting tells
the server not to allow duplicate session IDs.

c. Scroll down to the bottom of the page and click Update.
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d. Scroll down to the bottom of the page and click the Return to the Web Tours Homepage
link.

How do | work with unique server values?

In the modified configuration of HP Web Tours, the server assigns a unique session ID to each
Vuser. If you try to replay the unmodified Vuser script that you recorded in "Lesson 1: Building a
Vuser Script" on page 13, the replay will fail.

To overcome this issue, you use VuGen to detect the need to correlate the session ID. You will
instruct VuGen to insert a step that saves the original session ID to a parameter. In each
subsequent replay session, VuGen saves the new unique session ID to a parameter. As the Vuser
executes the steps in the Vuser script, the Vuser uses the saved session ID value instead of the
originally recorded value.

1. Record a new Vuser script with dynamic values.
a. Record a new Vuser script with the same steps that you recorded previously in "Lesson 1:
Building a Vuser Script" on page 13.

b. Save the script as basic_tutorial_Cor.

2. Replay the new script.

Click Replay > Run or click the Replay button & on the VuGen toolbar.

VuGen runs the new Vuser script. You may notice several error messages in the Replay Log in
the Output pane, indicated by the red-colored text.

After the replay ends, a message box may prompt you to scan for correlations. Click No.
3. View the Replay Summary.

Look at the Replay Summary tab. The summary shows that the replay of your script failed.
4. Scan the script for correlations.

Select Design > Design Studio.
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Design Studio ? X

Correlation(3)  Async

Review the dynamic values found and select those thaf need to be correlated.

Q Replay&Scan
Click Replay & Scan until no more dynamic values are found.

i) Correlate #, Add as Rule_ & Discard View: All
. Tvpe Replace/Found Status Text in Response Correlation Parameter
@ Record n i New flights CorrelationParameter
“m 110205 575698663f2zizQQpPDDIAVCPVQSi CorrelationParameter
@ Record & New 030;251:02/11/2013 CorrelationParameter
3 results
Details ¥
Options

| Close |

VuGen scans the script and its associated data, searching for possible dynamic values. The
Correlation tab of the Design Studio lists three dynamic values that may require correlation.
The longest of the three values is the Session ID.

Design Studio ? X
Correlation(3) ync
Review the dynamic s found and select those that need to be correlated
Q Replay&Scan
Click Replay & S no move dynamic values are found.
1 Comelate #_ Add as Rule... B Discard View. Al
. Type Replace/Found Status Textin Response ~ Correlation Parameter
@ Record n + New  flights CorrelationParameter

CormelationParameter

110205 .575698663zziz00pDDAVCpVOSi

@ Record m = New  030;251;0211172013 CorrelationParameter
3 results
Details ¥
Options
|_Clgse |

5. Correlate the Session ID.
a. Select the Session ID entry in the Correlation tab, and click Correlate. VuGen changes the

status of the Session ID to Applied, and inserts a new function at the top of the Vuser
script. The new function saves the original session ID to a parameter.

In each subsequent replay session, VuGen saves the new unique session ID to a
parameter. When the Vuser runs, the Vuser uses the saved ID value instead of the
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b.

originally recorded value.

Click Close to close the Design Studio.

6. Examine the syntax of the correlation statement.

In the VuGen Editor, locate the statement that VuGen added to the script. The new statement
looks similar to the following:

web_reg_save_param_regexp(

"ParamName=CorrelationParameter”,
"RegExp=userSession\\ value=(.*?)>\\n<table\\ border",
"SEARCH_FILTERS",

"Scope=Body",

"IgnoreRedirections=No",

"RequestUrl=*/nav.pl*",

LAST);

The statement instructs VuGen to save the first occurrence of the value contained in the
regular expression (the unique session ID) to a parameter called CorrelationParameter.

7. Play the script again.

a.

Click Replay > Run or click the Replay button B on the VuGen toolbar to replay the
script again. When the replay ends, look in the Replay Log in the Output pane. Notice that
VuGen no longer issues the red-colored error messages.

In the script, right-click web_reg_save_param_regexp and select Go to step in Replay
Log. VuGen places the cursor at the corresponding line in the Replay log. The log indicates
that function web_reg_save_param_regexp succeeded, indicating that the correlation
worked successfully.

8. Reset the HP Web Tours server to ignore unique session IDs.

a.

Click Start > All Programs > HP LoadRunner > Samples > Web > HP Web Tours
Application to open HP Web Tours.

On the HP Web Tours home page, click the administration link.

Inthe Administration Page, clear the Set LOGIN form's action tag to an error page
check box.

Scroll down to the bottom of the page and click Update.
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"Lesson 4: Preparing a Vuser Script for Load Testing" on page 39.
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Lesson 4: Preparing a Vuser Script for Load
Testing

In the previous lessons, you verified that the replay of your Vuser script produced an accurate
emulation of a real user. The next step is to prepare the script for load testing. How will the system
work with many users working simultaneously? Will the system slow down to an unacceptable
level?

In this lesson you will learn about different methods to enhance the script and to make it more
effective for the load testing process.

In this lesson you will cover the following topics:

e How do | measure the duration of a business process?
e How do | emulate multiple users?

e How do | verify Web page content?

e How can | produce debugging information?

e Did the replay of my test succeed?

How do | measure the duration of a business
process?

When preparing an application for deployment, you need to measure the duration of specific
business processes—how long does it take to log on, book a flight, and so on. Each business
process is normally made up of one or more steps or actions in your script. In a Vuser script, you
designate a series of actions you want to measure by including these actions in a transaction.

When you run a Vuser script that includes a transaction, LoadRunner gathers information about the
time it takes to perform the transaction, and displays the results in color-coded graphs and reports.
You use this information to help determine if the application meets the performance requirements.

You can manually insert a transaction anywhere in a Vuser script. To mark a set of steps as a
transaction, insert a start_transaction marker before the first step and an end_transaction marker
after the last step.

In this section you will insert a transaction into your script to measure the amount of time it takes for
the user to find and confirm a flight.

To insert a transaction into a Vuser script:

1. InVuGen, open the Basic_Tutorial script which you created in "Lesson 1: Building a Vuser
Script" on page 13. If it is still open, you can select the tab displaying its name. Otherwise you
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can open it from the File menu.

2. Click the Step Navigator tab to display the Step Navigator.

3. Insert a start transaction marker.

a.

b.

In the Step Navigator, locate the step Image: Search Flights Button.

Double-click the Image: Search Flights Button step to display the corresponding web_
image step in the Editor.

Click View >Steps Toolbox. The steps Toolbox appears in the right pane.

In the Steps Toolbox, under Common, select Ir_start_transaction, drag it into the Editor,
and release it before the web_image step. The Start Transaction dialog box opens.

Start Transzaction I. ? &]

ll i_') Transaction Marme :
i

] Cancel |

L

In the Transaction Name box, enter find_confirm_flight and click OK. VuGen inserts an
Ir_start_transaction step in the Step Navigator, and a corresponding Ir_start_
transaction function in the Editor.

4. Insert an end transaction marker.

a.

b.

C.

d.

In the Step Navigator, locate the step Submit Data: reservations.pl_2.

Double-click the Submit Data: reservations.pl_2 step to display the corresponding web_
submit_data step in the Editor.

In the Steps Toolbox, under Common, select Ir_end_transaction, drag it into the Editor,
and release it after the web_submit_data step. The End Transaction dialog box opens.

End Transaction l T |-l

() Transaction Name : |find_|:|:|nfirm_flight
—

=]
Transaction Status |LH_AUTD j

] Cancel |

L o

Make sure that find_confirm_flight appears in the Transaction Name box, and then click
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OK. VuGen inserts an Ir_end_transaction step in the Step Navigator, and a corresponding
Ir_end_transaction function in the Editor.

Step Navigator v aXx
I Search textin All éo ] J__T]

Line Name Step

4 & web_url O)[Url: WebTours

13 |H Ir_think_time Think Time - 24 (sec)

15 |§@web.subsit.form @) Subrmit Form: login.pl

24 r_think_time \ Think Time - 6 (sec)

27 (] Ir_staﬂ_tranw) Start Transaction - find_confirm_flight

29 |& image B|Image: Search Flights Button

34 |[Z web_url O|Url: FormDateUpdate.class

43 | web_ur || Url: CalSelect.class

52 |[& web_url [ Url: Calendar.class

61 | Ir_think_time Think Time - 33 (sec)

63 |ADweb_submit_data G| Submit Data: reservations.pl

86

E Ir_think_time Think Time - 20 (sec)
STED_submit_for »

2| Ir_end_transaction
i 'r_think_time Think Time - 25 (sec)
SEweb_suBrmm_ Submit Form: reservations.pl_3
116 | Ir_think_time Think Time - 8 (sec)

118 |[Z web_url

127 |34 web_image

bt

Submit Form: reservations.pl_2

End Transaction - find_confirm_flight

[}

Url: welcome.pl
Irnage: SignOff Button

(5] (8

You have now defined the find_confirm_flight transaction.

How do | emulate multiple users?

In your emulation, you tracked a user booking a flight and choosing an aisle seat. In a real-life
setting, however, different users will have varying preferences. To improve your test, you need to
check if the booking will work when users select different seating preferences (Aisle, Window, or
None).

To accomplish this, you will parameterize the script. This means that you take the recorded value,
Aisle, and replace it with a parameter. You will place values for the parameter in a parameter file.
When you run the script, the Vuser will use values from the parameter file (Aisle, Window, or
None) thereby emulating a true travel agency environment.

To parameterize your script:

1. Find the section where you want to vary the data.
a. Select View > Step Navigator to show the Step Navigator in the left pane.

b. Inthe Step Navigator, locate the Submit Data: reservations.pl step.
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c. Right-click the Submit Form: reservations.pl step and select Show Arguments. The
Submit Form Step Properties dialog box opens.

Submit Form Step Properties |

General Data |Fiescuurl:e|

Name ¥ alue | Add.

1 |depart Denver (=

2 |departDate 0271172013 3 Delste...
2 |amive Loz Angeles (=

4 |returnDate 02122013 (=

5 |numPaszzenger 1 (=

6 |roundtrip <0OFF* (=

7 | seatPref Aisle (=

g |zeatType Coach (=

9 |findFlights x 53 (=
10 |findFlightzy 10 B

k. I Cancel FY ][I

The ABC icon BE to the right of each argument in the grid indicates that the argument has a
fixed value.

2. Change the fixed value to a varying value.
a. Inthe Submit Form Step Properties dialog box, select seatPref in the seventh row of the
grid.

b. Click the ABC icon [E adjacent to the seatPref argument. The Select or Create Parameter
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dialog box opens.

=

Select or Create Parameter

Parameter name:

Farameter type:

Original walue:

Ok,

Froperies... ‘

L

3. Create a parameter.
a. Inthe Parameter name box

, type seat.

b. Click OK. In the Submit Form Step Properties dialog box, VuGen replaces the ABC icon
& with a Parameter icon EEB.

Submit Form Step Properties E3 |

‘General Data IF{esowcel

Name | Value |
1 |depart Denver E
2 |departDate 0271172013 =]l
| 3 |arrive Los Angeles =]l
4 |returnDate 02/12/2013 =]l
| 5 |numPassenger 1 =
|_6_|roundtrip <OFF> = |
7 |seatPref EH
| 8 |seatType Coach o
|9 |[findFlights.x 53
10 |findFlights.y 10

Add...

)

_bu |
Delete... |

o]

Cancel

Ap

Bl
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c. Click the Parameter icon BE adjacent to {seat} and select Parameter Properties. The

Parameter Properties dialog box opens.

Allocate Vuserwalues in the Contraller

'S = ~
Parameter Properties - [seat] — m
Parareter type IF\Ie j
File path: Iseat.dat ;I Browsze... |
Add Column... | Add Bow... LDielete Colurmn... | Delete Fow...
zeat |
Aizle
Editwith Motepad... | Data \Wizard... Simulate Parameter... |
r Select column File: format
& Byrumber |1 =1 || camn delimiter: [Comma ~
By name: I j First data line: |1 _I::
Updalevalugon: [Esch iteration |
Wwhen out ofvalues: ICominue with lastvalue j

& Automatically allocate block size

 Allocate values for each Yuser

Close

4. Specify values for the parameter.

a.

b.

Click Add Row. VuGen adds a row to the table.

Replace the word Value with Window.

Click Add Row. VuGen adds another row to the table.

Replace the word Value with None.
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-

Parameter Properties - [seat]

Parameter type: IFiIe

File path: |seat.dat

Add Column... ‘ Add Bow...

seat
1 | Aisle
2 | Window
3 None

Note: The values are not case sensitive.

e. Keep the default settings in the Select column and File format sections of the dialog box.
5. Define how the test will vary the data.
a. Keep the default setting that instructs VuGen to take a new value for each iteration:
Update value on: Each iteration.
b. Click Close to close the Parameter Properties dialog box.

c. Click OK to close the Submit Form Step Properties dialog box.

You have now created a parameter for the seating preference. When you run the load test,
the Vusers will use the parameter values instead of the recorded value, Aisle.

When you run the script, the Replay log will show the parameter substitution that occurs for

each iteration. The Vuser will use Aisle for the first iteration, Window for the second
iteration, and None for the third iteration.

How do | verify Web page content?

When running a test, you often need to verify if certain content is found on a returned page. A
content check verifies that expected information appears on a web page while the script is running.
You can insert two types of content checks:

o Text check. Checks that a text string appears on a web page.

« Image check. Checks for an image on a web page.
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In this section, you will insert a text check that checks if the phrase Find Flight appears on the
Reservations page of HP Web Tours.

Inserting a text check

1.

2.

Click the Step Navigator tab to display the Step Navigator.
In the Step Navigator, locate the Submit Form: reservations.pl step.

On the VuGen toolbar, click the Snapshot button [z to display the Snapshot pane.

In the Step Navigator, double-click the snapshot icon in the Submit Form: reservations.pl
step. The corresponding snapshot appears in the Snapshot pane.

From the VuGen menu, click View > Steps Toolbox. The Steps Toolbox pane appears.

In the Steps Toolbox - Search box, type in web_reg, and then locate the web_reg_find step in
the Filter Results.

Drag the web_reg_find step from the toolbox into the Editor, before the web_submit_form
function. The Find Text dialog box opens.

In the Find Text dialog box, type Find Flight into the Search for specific Text box, and then
click OK.

VuGen inserts a web_reg_find step into the Step Navigator and a corresponding web_reg_
find function into the Editor.
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Step Navigator o X
Search text in All 6> r T LI]
Line Name Step ‘
4 (& web_ur &) Url: WebTours
13 |[@ Ir_think_time Think Time - 24 (sec) \
15 S*web_subrnit_furm | Submit Form: login.pl
24 | Ir_think_time Think Time - 6 (sec) \
21 || Ir_start_transaction Start Transaction - find_confirm_flight
29 |32 weh_image || Irmage: Search Flights Button \
34 ([ web_un & | Url: FormDateUpdate.class
43 [ web_url ]| Url: CalSelect.class \
52 |[Z&web_ur | Url: Calendar.class
61 *Tr_think_time Think Time - 33 (sec) \

& web_reg_find Service: Reg Find

67 §Eweb_submit_data,” 0| Submit Data: reservations.pl \
an T Ir_tharR_xmT Think Time - 20 (sec)
92 |S@web_submit_form  ©| Submit Form: resenvations.pl_2 \
101 |GlIr_end_transaction End Transaction - find_confirm_flight
103 | Ir_think_time Think Time - 25 (sec) \
105 ﬁ‘weh_suhmit_furm & [ Submit Form: reservations.pl_3
120 | Ir_think_time Think Time - 8 (sec) ‘
122 (& web_un | Url: welcome.pl
131 (5 web_image E||Image: SignOff Button \

When you replay the script, VuGen will look for the text Find Flight and indicate in the Replay
log whether or not the text was found.

How can | produce debugging information?

At certain points during a test run, you may want to generate and send messages that contain
information relating to the script execution. These output messages will appear in both the Replay
log in the Output pane, and in the Controller's Output window. You can send a standard output
message or a message that indicates that an error occurred.

The recommended way to work with error messages is to check for a Failed status. If the status is
Failed, you instruct VuGen to issue an error message. For details, refer to the examples in the HP

LoadRunner Function Reference.

In this section of the tutorial, you will instruct VuGen to insert an output message after the
application completes a full booking.

To insert an output message:

1. Click the Step Navigator tab to display the Step Navigator.

2. Inthe Step Navigator, locate the last step, Image: SignOff Button.
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3. Double-click the Image: SignOff Button step. The Editor displays the corresponding web_
image function.

4. Inthe Steps Toolbox, under Common, locate the Ir_output_message function.

5. Select the Ir_output_message function, drag it to the Editor, and release it after the web_
image function. The Output Message dialog box opens.

Cutput Message [ 8 iz_]

Argurnent List

= Message Text: |
hal=s

Additional Pararneter |

I
(o] | Cancel

6. Inthe Message Text box, type The flight was booked.

7. Click OK. VuGen adds an Ir_output_message to the script, and a corresponding step in the

Step Navigator ~@'X  basic_.torial: Action.c* s X
S i AN @ 5 @HPVuUGenC. Global Action v 2 Action) -
£
Line Name Step LasT);
4 |Bweb_un & url: WebTours | time(s)
1@ Ir_think_time Think Time - 24 (sec)
15 |§@web_submit_form @] Submit Form: login.pl .pl”,
24 | W_think_time M -06a) URL=http://localhost :1080/uebTours/wel 12page=itin

21 [I§ Ir_start_transaction Start Transaction - find_confirm_flight

pes=text/html”,
29 |s web_image G Image: Search Flights Button : Lhost :1080/WebTours/nav. pl ?page=men
34 |Zweb_un G Urt: FormDateUpdate.class -
8 |[Zweb_ur @ Urk: CalSelect.class
52 | web_url @[ Ur: Calendar.class .
61 | @ Ir_think_time Think Time - 33 (sec) L web_ima nOff Button”,

64 |- web_reg_find Service: Reg Find 1 ignof f Button”,
57 |Nyweb_submi_data ]| Submit Data: reservations.pl l;g"r‘;i""t““""""
90 | Ir_think_time Think Time - 20 (sec)

92 [§gweb_submit_form G| Submit Form: reservations.pl_2

101 |@]Ir_end_transaction End Transaction - find_confirm_flight
103_| @ Ir_think_time. Think Time - 25 (sec)
105_|§@web_submit_form G| Submit Form: reservations.pl_3
120_|@ Ir_think_time Think Time - 8 (sec)

Z ye @[ Url: welcome.pl

M Image: SignOff Button

Jutput Message - The flight was booke]

age("The flight was

8. Click the Save button on the VuGen toolbar to save the script.

Note that to insert an error message you would repeat the same process, except that in the
Steps Toolbox, you would select an Ir_error_message function instead of the Ir_output_
message function.

Did the replay of my test succeed?

In this section, you will run the enhanced script and search the Replay log for text checks. You will
view the results of the text checks, as well as details of the transactions and parameterization.
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By default, image and text checks are disabled during playback since they require more memory. If
you want to perform an image or text check, you need to enable checks in the run-time settings.

1. Enable image and text checks.

a.

b.

C.

d.

Click Replay > Run-Time Settings to open the Run-Time Settings dialog box.
Click Internet Protocol > Preferences.
Select Enable image and text check.

Click OK to close the Run-Time Settings dialog box.

2. Runthe script.

Click the Replay button B on the VuGen toolbar. VuGen begins running the script,
generating entries in the Replay log in the Output pane.

Wait for the script to finish running.

3. Locate the text check.

a.

b.

C.

Click the Output pane, and select Replay.
Click in the Replay log, and then press Ctrl+F to open the Search dialog box.
Search for web_reg_find.

The first instance says as follows:

web_reg_find started

Click Find Next to display the next instance of web_reg_find. The second instance says
as follows:

Registering web_reg_find was successful.

This is not the actual text check—it only prepares VuGen to check for the text after the
form submission.

Click Find Next to display the next instance of web_reg_find. This instance indicates:

Registered web_reg_find successful for “Text=Find Flight” (count=1).

This verifies that the text was found. If someone changes the Web page and removes the
phrase Find Flight, then in subsequent runs, the output will indicate that the text was not
found.
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4. Locate the beginning of a transaction.
a. Inthe Replay log, press Ctri+F to open the Search dialog box.

b. Search for the word Transaction. This notification is shown in blue.

5. View the parameter substitution.
a. Inthe Replay log, press Ctri+F to open the Search dialog box.

b. Search for the word Parameter. The log contains a notification “seat” = “Aisle”.

c. Search again (F3) for the next substitution. Note how VuGen takes a different value for
each iteration.

6. Select File > Save or click the Save button on the VuGen toolbar.

"Lesson

: Creating a Load Testing Scenario" on page 51

HP LoadRunner (12.00) Page 50 of 102



Tutorial
Lesson 5: Creating a Load Testing Scenario

Lesson 5: Creating a Load Testing
Scenario

In the previous lesson, you used VuGen to validate your Vuser script. In this lesson, you will
evaluate your system under the load of multiple Vusers. You will emulate the actions of ten travel
agents concurrently using the flight reservation system, and observe the behavior of the system
under the load of these users. To design and run this test, you use the LoadRunner Controller.

Scenario Objectives

In this lesson, the objective is to create a scenario that emulates the behavior of ten travel agents
simultaneously logging on, searching flights, purchasing flights, checking itineraries, and logging
off.

In this lesson you will cover the following topics:
¢ Introducing the LoadRunner Controller

o How do | start the Controller?

e The Controller at a glance

e How do | modify the script details?

e How do | generate a load on the system?

o How do | emulate real load behavior?

e How do | emulate different types of users?

e How do | monitor the system under load?

Introducing the LoadRunner Controller

Load testing means testing your system under typical working conditions. For example, you may
test the system while many travel agents simultaneously reserve flights on the same flight
reservation system.

You design the test to emulate real-life situations. To do this, you need to be able to generate a load
on an application and schedule when the load is applied (because users do not log on and off the
system at precisely the same time). You also need to emulate different types of user activity and
behavior. For example, some users may use Firefox to access the system, whereas other users
use Internet Explorer. Users may also employ different network connections to access the system,
such as modem, DSL, or cable. You create and save these settings in a scenario.

The Controller provides you with all the tools you need to help you build and run tests to accurately
emulate your working environment.
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How do | start the Controller?

To begin developing a scenario, you open the LoadRunner Controller.

1. Open the HP LoadRunner Controller.

Select Start > All Programs > HP Software > HP LoadRunner > Controller, or click the

Controller shortcut icon on your desktop.

e

LE e e =1

The HP LoadRunner Controller opens and displays the New Scenario dialog box.

Mewy Scenario

Select Scenario Type

& Manual Scenario
Manage your load test by specifying the number of wvirtual uzers to un

™ Use the Percentage Mode to distibute the Vusers among the scripts

" GoalOrented Scenario

Allow LoadRunner Controller to create a scenario based on the goals vou specify

Select the zcript(z] you would like to use in your scenario
* LoadRunner Scripts

" Systern or Unit Tests

Available Scripts Scripts in Scenario

.Er basic_script B pdd==>>
& demao_script

= Browsze. .
Y Record...

HF &LM...

] i [

[W Show at startp Ok Cancel

Help

=3

2. Select a scenario type.

There are two scenario types:
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A Manual Scenario gives you control over the number of running Vusers and the times at
which they run, and lets you test how many Vusers your application can run simultaneously.
You can use Percentage Mode to distribute the total number of Vusers between the scripts
based on a percentage specified by your business analyst. The Percentage Mode check box is
selected by default the first time you start LoadRunner following installation. If it is selected,
clearit.

A Goal-Oriented Scenario is used to determine if your system can achieve a particular goal.
You determine the goal based on, for example, a specified transaction response time or
number of hits/transactions per second, and LoadRunner automatically builds a scenario for
you based on these goals.

= Click Manual Scenario.
Add a Vuser script to the load test.

In this tutorial, you will use only one Vuser script to model a single group of users performing
identical actions. To more accurately emulate a real-world scenario with more versatile user
profiles, you would create a number of different Vuser groups, with each group running several
scripts with different user settings.

The script that you previously recorded in VuGen contains the business processes that you
want to test. They include logging on, searching for a flight, buying a ticket, checking the flight
itinerary, and then logging off the site. You will add a similar script to the scenario, and
configure the scenario to emulate eight travel agents simultaneously performing these actions
on the flight reservation system. You will add two more Vusers during the test.

For this purpose, a sample script is provided that is similar to the one you created. We
recommend that you use the sample script.

a. Inthe New Scenario dialog box, click the Browse button.

b. Locate and select basic_script in the <LoadRunner Installation>\Tutorial folder. Click
Open.

c. Click the Add button to move basic_script from the Available Scripts pane to the
Scripts in Scenario pane of the New Scenario dialog box.

d. Click OK. The LoadRunner Controller opens and displays the Design tab of your new
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scenario.

& HP LoadRunner Cantroller - Scenariol - [Design(t)]

(=8N =)
File ‘View Scenario Results Diagnostics Tools Help
@M ®h b &
Scenario Groups

B w6

] New [25 tudvanced
Group Mame Sciipt Peth [ Quentity [ LoadGen ~
AL basic_script|C.\Frogiam FilestHP\LoadFunneritutoriahbasic_sciipt localhast || | [Fervice Level Agreement

Currenty no SLA mles are defined for the load test.
Click the Mew button to define SLA criteria for pour lnad test.

Service Level Agreement

Scenario Schedule

= 5 2 EEaaa
Schechie Name B j Interactive Schedule Graph
Schedule by: & Seenario  Group 12
Legend
Run Madz: & Roal - e O]
Reabworld schedule Basic schedule 10 B Gt St
Global Schedule 8|
SR I Total: 10 Vusers 2 6
]
Propetties - =
Initalize each Vuser just befare il uns 4
sers Start 104, 2 00:00:15 [HH:MM:55)
Duratinn Boun for 06 ANTHH MM - 551 ﬂ
Desian Run J Diagnostics for JAEELNET J

[GZ Auto Collate Results

Note: The control for the Design tab is in the lower left corner of the Controller.

The Controller at a Glance

The Design tab of the Controller is the main interface for designing your load test. The Design tab
is divided into three panes:

1. Scenario Groups pane. You configure the Vuser groups in the Scenario Scripts pane. You

create different groups to represent typical users of your system and specify the number of
Vusers that will run, and the machine that they will run on.

2. Service Level Agreement pane. When you design a load test scenario, you can define goals
or SLAs (Service Level Agreements) for the performance metrics. When you run the scenario,
LoadRunner gathers and stores performance-related data. When you analyze the run, Analysis

compares this data against the SLAs and determines SLA statuses for the defined
measurements.

3. Scenario Schedule pane. In the Scenario Schedule pane, you set the load behavior to
accurately portray real-world user behavior. You define actions according to which the Vusers

will run, the rates at which load is applied to the application, the load test duration, and how the
load is terminated

How do | modify the script details?

Y ou modify the script details as follows:
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1. Check to see that basic_script appears in the Group Name column of the Scenario Groups
pane.

B da 5 g o e & I
Group Mame Script Path | Quantity | Load Gen =
A ET basic_script |C:\Program Files\HPLoadRunnerstutorial\basic_script localhost i

2. Change the Group Name.

a. Inthe Scenario Groups pane, select basic_script and click the Details button 2. The
Group Information dialog box opens.

Group Information

=5
Group Mame: |basic_scri|:ut
Load Generatar Mame: ||0c;a|h0$l ﬂ Cancel
Script Help
Mame: basic_script
Path: C:AProgram FilegtHPYLoadRunnerstutonialsbazsicscript
Tupe: Multi+0 Tw'eb & “iew Scrpt... Refresh
Wirtual Location: Mebwark, Wirtualization not installed [ Run-Time Settings... tore ¥

b. Inthe Group Name box, enter a more meaningful name, for example travel_agent.

c. Click OK. The new name is displayed in the Scenario Groups pane of the Design tab.

How do | generate a load on the system?

After you have added your Vuser scripts to the scenario, you configure the load generators, the
computers that generate the load on the system.

Definition: A load generator is a computer that runs multiple Vusers in order to generate a load
on the system. You can use a number of load generators, each generator hosting multiple
Vusers.

In this section, you will learn about adding load generators to the scenario, and testing the load
generator connections.

Add a load generator.
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Click the Load Generators button 8 on the Controller toolbar. The Load Generators dialog box
opens.

Load Generators =
| Mame Status | Platfarm Details -

gfocahost [godDown  windows M

— R Add.

— g5 Delete..
— £f  Details...
| %  Dizable
— i Help

4 3

The Load Generators dialog box enables you to view and configure the load generators that are
defined in the scenario. The Load Generators dialog box shows details for the load generator called
localhost. The status of the localhost load generator is Down. This indicates that the Controller is
not connected to the localhost load generator.

In this tutorial, you will use your local computer as the load generator.

Note: In a typical operational system, you would have several load generators, each hosting
multiple Vusers.

Test the load generator connection.

When you run a scenario, the Controller connects to the load generators automatically. However,
you can test the connections before trying to run the scenario.

1. Inthe Load Generators dialog box, select localhost and click Connect.

The Controller attempts to connect to the load generator machine. When a connection has
been made, the Status of the load generator changes from Down to Ready.

Load Generators =]
J I arme | Status | Flatform | Details -~ & i t
G lncahhost | §¥Ready Windows 7 &z Hisconnec
— go Add.

— £ Details...
| %  Dizable
— i Help

4 I

2. Click Close.
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How do | emulate real load behavior?

After you have added your load generators, you are ready to configure load behavior.

Typical users do not log on and off the system at precisely the same time. LoadRunner allows
users to gradually log on to and off the system. It also lets you determine the duration of the
scenario, and the way in which the scenario terminates. The scenario that you will configure below
will be relatively simple. However, when designing a scenario that more accurately reflects a real
life scenario, you can define more true-to-life Vuser activity.

You configure the load behavior for a manual scenario in the Scenario Schedule pane of the
Controller. The Scenario Schedule pane is divided into three sections: the Schedule Definition
area, the Actions grid, and the Interactive Schedule graph.

You will now change the default load settings and configure a scenario schedule.
1. Select schedule type and run mode.

Inthe Scenario Schedule pane, make sure that Schedule by: Scenario and Run Mode:
Real-world schedule are selected.

Scenario Schedule

) &

Schedule Mame: |Schedu|e 1 j
Schedule by * Scenario " Group

Run Mode: (% Realword schedule ¢ Basic schedule

2. Set the scheduled action definitions.

You can set the Start Vusers, Duration, and Stop Vusers actions for the scenario schedules
from either the Global Schedule grid, or by manipulating the Interactive Schedule graph.
When you set the definitions from the graph, the Global Schedule grid properties adjust
accordingly.

You will now set the definitions so that the Global Schedule grid will look as below.
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Global Schedule

¥ Total: & Wusers
Action | Properties
Start “users Start 8 ugers: 2 every 00:00:30 [HH:MM:55]
Duration Run for 00:10:00 [HH:MR:55]
Stop Wuzers Stop allVuszers 2 every 00:00:30 [HH:kMMR:55]
*

a. Set up the Vuser Initialization.

Initialization means preparing the Vusers and the load generators for a load test run by
running the vuser_init action in the script. Depending on your system configuration,
initializing Vusers before they start running may provide more realistic results.

i. Double-click Initialize in the Global Schedule grid. The Edit Action dialog box opens
displaying the Initialize action.

i h
Edit Action S

Action type:  Initialze ¢ Previous | Mest » |

% |nitiglize all Yuzers simultaneously

 Iritislize |1 =] Wusers every [onom1s =2 (HH:MM:SS)

" Initiglize each Wuser just before it runs

Help | | aF. I Cancel Apply

—————

ii. Select Initialize all Vusers simultaneously.

iii. Click OK.

b. Specify a gradual start for the Vusers

Starting Vusers at intervals allows you to examine the gradual increase of Vuser load on
the application under test over time, and helps you pinpoint exactly when the system
response time slows down.
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i. Double-click Start Vusers in the Global Schedulegrid. The Edit Action dialog box
opens displaying the Start Vusers action.

Edit Action [

Action type:  Start Wusers < Previous | Mest » |

Start |8 | Wuzers:

" Sirulkaneouzly

* 12 3: Yuzers every  |00:00:30 == [HH:MM:55]

Help | )4 | Cancel

L% []

ii. Inthe Start X Vusers box, enter 8, and select the second option— 2 Vusers every
00:00:30 (30 seconds).

iii. Click OK.
c. Schedule the duration.

You specify a duration to make sure that the Vusers continue performing the schedule
action for a specific period so you can measure continuous load on the server. If you set a
duration, the script will run for as many iterations as necessary during that period,
disregarding the number of iterations set in the script’s run-time settings.

i. Make sure that the Interactive Schedule Graph is in Edit mode by clicking the Edit
Mode button on the Interactive Schedule Graph toolbar.

ii. Inthe Interactive Schedule Graph, click the horizontal line which represents Duration.
The line is highlighted and a dot and a diamond are displayed at its endpoints.

Note:The Legend is displayed on top of the diamond, click the Hide Legend
button on the Interactive Schedule Graph toolbar to show the diamond.n

iii. Drag the diamond shaped endpoint to the right until the time in brackets reads
00:11:30. You have just set the Vusers to run for a period of 10 minutes.

d. Schedule a gradual closure.

Gradually stopping Vusers is recommended to help detect memory leaks and check
system recovery, after the application has reached a threshold.
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i. Double-click Stop Vusers in the Global Schedule grid. The Edit Action dialog box
opens displaying the Stop Vusers action.

Edit Action [

Action type:  StopYusers < Previous | |

Stop |&ll | Wuzers:

" Sirulkaneouzly

* 12 3: Yuzers every  |00:00:30 == [HH:MM:55]

Help | )4 | Cancel

L

ii. Select the second option and enter the following values—2 Vusers every 00:00:30
(30 seconds).

iii. Click OK.

How do | emulate different types of users?

Now that you have configured a load schedule, you will specify how the Vusers will behave during
the test.

When emulating a real user, you need to consider the user's actual behavior. Behavior refers to the
time that a user takes to pause between actions, the number of times a user repeats an action, and
soon.

In this section, you will learn more about LoadRunner’s run-time settings, and you will enable Think
Time and Logging.

1. Open the run-time settings.
a. Inthe Controller, click the Design tab.

b. Inthe Scenario Groups pane, select the travel_agents group.

c. Click the Run-Time Settings button L& on the Scenario Groups toolbar. The Run-Time
Settings dialog box opens.
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Run-Time Settings X
General General: Run Logic
i+ Run Logic
i Pacing Iteration Count
-Log 0= L I—_[
Think Time u Murnber of lterations: |1 =
- Addtional attributes o =
i Miscellaneous El 1\§""II:;'Z. e it Irsert Action |
- Data Format Extension & R“un -
- Configuration ‘? @ Action Insert Block |
- Chain Canfiguration = ;d
Hetwark ‘5____ & user end Delete |
- Speed Simulation A -
- Browser Imye Wp |
i Broweser Emulation
- Internet Protocal tave Down |
- CortentCheck =
Proxy Eroperties... |
-Preferences
i Downlcad Fitters Hint
Move the mouze over any item ta zee ite description.
Use Defaults 0K Cancel

The run-time settings let you emulate different kinds of user activity and behavior. They

include:

Run Logic. The number of times a Vuser repeats a set of actions.

HP LoadRunner (12.00)

Pacing. The time to wait before repeating the action.

Log. The level of information that you want to gather during the test. The first time you run
a scenario, it is recommended to generate log messages to make sure that you have
debugging information in case the first run fails.

Think Time. The time the user stops to think between steps. Since users interact with the
application according to their experience level and objectives, more technically proficient
users may work more quickly than new users. Vusers can be made to emulate their real-
world counterparts more accurately during a load test by enabling think time.

Speed Simulation. Users using different network connections such as modem, DSL, and
cable.

Browser Emulation. Users using different browsers to see their application’s
performance.

Content Check. For automatically detecting user-defined errors.

Suppose that your application sends a custom page when an error occurs. This custom
page always contains the words ASP Error. You need to search all of the pages returned by
the server and see if the text ASP Error appears.
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You can set up LoadRunner to automatically look for this text during the test run, using the
Content Check run-time settings. LoadRunner searches for the text and generates an error
if it is detected. During the scenario run, you can identify the content check errors.

2. Enable think time.

a. Inthe Run-Time Settings dialog box, click General > Think Time.

b. Select Replay think time, and select Use random percentage of recorded think time.

c. Specify a minimum of 50% and a maximum of 150%.

Think Time options
g ™ lgnore think time
& Beplay think time

" Agrecorded

" Multiphy recorded think time by 1 El

' Lzg random percentage of recorded think time:

bdin . |50 EI % bdax: |150
™ Limitthinktime to: |1 EI seconds

The above specifications use a random percentage of the recorded think time to emulate
users with a varying range of proficiency. For example, if the recorded think time for
selecting a flight was 4 seconds, the random think time could be anything between 2-6

seconds (50% to 150% of 4).

3. Enable logging.
a. Inthe Run-Time Settings dialog box, click General > Log.

b. Select Enable logging.
c. Under Log options, select Always send messages.

d. Click Extended log, and select Data returned by server.

HP LoadRunner (12.00)
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Run-Time Settings

General
Run Logic
Pacing
Log

General: Log

V¥ Enable logging

Log options
Addtional attributes " Send messages only when an eror occurs
Miscellaneous & Al d
Data Format Extension RS SR MeFsages
Configuration Log messages at the detail level of
Chain Configuration " Standard log
Network
Speed Simulation (* Extended log
Browvser [V Parameter substitution
e I Oty v
ContentCheck [ Advanced trace

Proxy

Note: After the initial debugging run, extended logging is not recommended for a load
test. It is enabled only for the purposes of this tutorial to provide information for the
Vuser Output log.

e. Click OK to close the Run-Time Settings dialog box.

f. Save the scenario.

How do | monitor the system under load?

Now that you have defined how your Vusers will behave during the test, you are ready to set up
your monitors.

While generating a load on an application, you want to see how the application performs in real time
and where potential bottlenecks exist.You use LoadRunner’s suite of integrated monitors to
measure the performance of every single tier, server, and component of the system during the load
test. LoadRunner includes monitors for a variety of major backend system components including
Web, application, database, and ERP/CRM servers.

Forinstance, you can select a Web Server Resources monitor according to the type of Web server
that is running. You can purchase a license for the relevant monitor, for example 11S, and use that
monitor to pinpoint problems reflected in the IIS resources.

In this section, you will learn how to add and configure the Windows Resources monitor. You can
use this monitor to determine the impact of load on your CPU, disk, and memory resources.

1. Select the Windows Resources Monitor.
a. Click the Run tab at the bottom of the Controller.

The Windows Resources graph is one of four default graphs that are displayed in the graph
viewing area. You will learn how to open other graphs in the next lesson.
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Running Yusers - whole scenario Trans Response Time - whole scenario

# of Vusers
Response Time (sec)

Elapsed Time sed Time (Hour:Min:

Hits per Second - whole scenario chss w

#Hits/sec

Elapsed Time (Hour:Min: Sec) Elapsed Time (Hour:Min:Sec)

b. Right-click inside the Windows Resources graph and select Add Measurements. The
Windows Resources dialog box opens.

-
Windows Rescurces - -‘ g
I ~Maonitored Server Machines I

i

Add ... Delete

I Fesource Measuraments on: i

I
Add . Delete Sawe as Template Restore Defaults
I —Description |
| |
Ok Cancel Advanced Help

|
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2. Select the monitored server.
a. Inthe Monitored Server Machines section of the Windows Resources dialog box, click

Add. The Add Machine dialog box opens.

Add Machine [

kachine Information
8]
Marme: -
| J Cancel
Platform:  [WIN2003 | Heln

L

b. Inthe Name box, type localhost. (If your load generator was running off a different
machine you would type the server name or IP address of that machine.)

c. From the Platform list, select the platform on which the machine runs.
d. Click OK.

The default Windows Resources measurements are listed under the Resource
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Measurements on <server machine>.

-
Windows Resources o M
I ~Maonitored Serser Machines I

|
Add Delete

I Resource Measurements on:  localhost

% Dizk Time (PhysicalDisk _Total) -
% Idle Time (PhysicalDisk _Total)

% Interrupt Time (Frocessor _Total)

% Privileged Time (Processor _Total)

% Processor Time (Frocessor _Total)

Available MBytes (Memony)

Awg. Disk Bytes/Transfer (FhysicalDisk _Total)

Awg. Disk Queue Length (FhysicalDisk _Total) N
Bytes Total/sec (Server)

Cache Bytes (Memony)

Committed Bytes (Memany)

Context Switches/sec (System)
Disk Transfers/sec (FhysicalDisk _Total)

File Data Operations/sec (System) -
Add .. Delete Sawe as Template Restare Defaults
N |
tachine: localhost -

Flatiorm: WINZ003

[0]:8 | Cancel Achvanced Help

3. Activate the monitor.

Click OK in the Windows Resources dialog box to close the dialog box and activate the
monitor.

"Lesson 6: Running the

Load Test" on page 67.
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Lesson 6: Running the Load Test

When you run a load test, LoadRunner generates a load on the system. You can then use
LoadRunner’'s monitors and graphs to observe the performance of the system under load.

In this lesson you will cover the following topics:
o The Controller Run view at a glance

e How do| run aload test scenario?

e How do | watch a Vuser running in real time?
e Where can | view a summary of user actions?
e How can | increase the load during the test?

e How is the application performing under load?
¢ Did the application encounter errors?

o How do | know that the test finished running?

e Did the application perform well under load?

The Controller Run view at a glance

The Run tab in the Controller is the control center from which the scenario is managed and
monitored. The Run tab (located at the lower section of the Controller window) contains five panes:

1. Scenario Groups pane. In the upper-left pane, you can view the status of Vusers in the
scenario groups. You use the buttons to the right of this pane to start, stop, and reset the
scenario, to view individual Vuser status, and to increase the load on the application during a
scenario by manually adding more Vusers.

2. Scenario Status pane. In the upper-right pane, you can view a summary of the load test,
including the number of running Vusers and the status of each Vuser action.

3. Available Graphs pane. In the middle-left pane, you can see a list of the LoadRunner graphs.
To open a graph, select a graph in the tree, and drag it into the graph viewing area.

4. Graph Display pane. In the middle-right pane, you can customize the display to view between
one and eight graphs (View > View Graphs).
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5. Graph Legend pane. In the bottom pane, you can view data from the selected graph.

Note: The control for the Run tab is at the bottom of the Controller.

& HP LoadRunner Controller - Scenario2 - [Run] [ E =]
File View Scenario Monitors Results Diagnostics Tools Help
Jw | i NESE B LB
1 enario Groups 2 [y 5] -
oup Mame Down | Pending | Int | Ready Run |Ri Passed Faded | Eiror | Gradual Exiting | Exdting  Stopped - L Runring Vusers 4
5 |
1 e 0 0 : : 0| 0 0| @ 0 (] ol m top 3 — 000103 ) L
= « | HitssSecond 5.25 (last B0 sec)
@ Ve | Passed Tuansactions =) Q
| 4 RuvstooVusess,. | |_F3ed Transactions L] Q 2
6\»% Graphs <[ 4 Funning Vussrs - whole scenario _ Trans Response Time - whole scenario
T 5| T ) —
HTTP Responses per Second w3 { s
Papes Downloaded pes Second 5 / Ew i -
Flebies pes Second H /
Connections wl / E &
Connections per Second 1 - g 3 s s
SSL per Second 00000 O0OOZ0  ORO030D  OG0040  DOODSD 000N 000040 00DZ0  ODOG30 000040 OODGSD 0001
&) System Resource Graphs Elapsed Tme Elapsed Time (Hour in Sec)
[Wodows Resowces Hes per Second - whale scenario inclows Resources - Last 80 sec
UNIX Resources 25 — 100
s .o |
) Network Graphs ‘E: . su’\{,:::-:;::::::::::
Network Dilay Tine H . e - @
= Firewalls 5 . 0 - a 20| di ettt deitod, 2 fidede iy
CheckPoirit Frewsl-l LI 1 . : . . i *’mﬂi“,w. -
Ny r 000010 000020 000030  O0OOSD  OD0DS0  OQOLMM X000 000020 000030 000040 000050 000NOM
| |+ Elapsed Time (Hour Min Sec) Eepsed Time (Hour Wi Sec) |
5 Scole  |Meansement [Machine [Max [Min [ave [s1d [Lest B
1 % Proceszol Time [Frocessor_Total) Tocalhost 54.148 Z306 4975 T2 18687
1 % Privieged Tie (Plocessor_Taidl] Tocalhat 658 207 3000 B25% 1668
1 % Intemupt Time (Frocessor_Total) focalhost 0.259 0000 0046 0098 0000
10 Processor Queus Length [System) localhost 4000 0000 0500 1323 0000
M (01 Context Swiches/sec [Susteml lacalhost TIR846 1544.005 2528635 1248610 1755.338 =l
Design Fun | Diagnostics for JREE/NET |

12 Auto Colale Resuts y

How do | run a load test scenario?

In this section, you will start the scenario.
1. Open the Controller Run view.
Click the Run tab at the bottom of the Controller.

Notice that there are 8 Vusers in the Down column of the Scenario Groups pane. These are
the Vusers you created when you created the scenario.

Scenario Groups

Group Name | Down Pending Init Ready Run | Rendez | Passed | Failed | Error Gradual Exitng | Exiting | Stopped | *
—T % 0 0 0 0 0 o 0 0 0 0 o Y
< travel_agents 8

Since the scenario has not yet run, all other counters remain at zero and all the graphs in the
graph viewing area (except Windows Resources) are blank. When you start running the
scenario in the next step, the graphs and counters will begin to display information.

2. Start the scenario.
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Click the Start Scenario button or select Scenario > Start to start running the scenario.

If you are running the tutorial for the first time, the Controller begins the scenario. The result
files are saved automatically to the load generator's temp folder.

If you are repeating the test, you will be prompted to overwrite the existing results file. Click
No, because the results of the first load test should be used as baseline results to be compared
with subsequent load test results. The Set Results Directory dialog box opens.

e

Set Results Directory

==

Results MName; ‘rESUHSE

Directony:; ‘C:‘-,LJsers\AppDatahLucal\,Temp

Fesults Path:; CAlUsers\AppDatahLocal\ Temphresults2

OFK

[ Automatically create aresults directory for each scenario execution

[ Automatically overnetite existing results directory without prompting for confirmation

Cancel

Browse...

Help

e

Specify a new results folder. Enter a unique and meaningful name for each results set,
because you may want to superimpose the results of several scenario runs when you come to

analyze the graphs.

How do | monitor the application under load?

You use the Controller's online graphs to view performance data collected by the monitors. You use

this information to isolate potential problem areas in your system environment.

1. Examine the performance graphs.

The Graph Display pane of the Run tab displays the following default graphs:

a. Running Vusers - Whole Scenario graph. Displays the number of Vusers running at a

given time.

b. Transaction Response Time - Whole Scenario graph. Shows the amount of time it

takes for each transaction to be completed.

c. Hits per Second - Whole Scenario graph. Displays the number of hits (HTTP requests)
made to the Web server by Vusers during each second of the scenario run.

HP LoadRunner (12.00)
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d. Windows Resources graph. Displays the Windows resources measured during a

scenario.

# of Vusers

Running Yusers - whole scenario

(=)

= “

Response Time (sec)

[

Trans Response Time - whole scenario

.
000 0ptItOT0 0,00 PP00s 000, ,0,0% 0005000000000

v P b e -

RHitsisec

Elapsed Time

Hits per Second - whole scenario

00:01:00 00:0200 000300 O00:0400 00:0500 00:06:00

00:01:00 00:0200 00:03:00 00:04:00 00:0500 00:06:00
Elapsed Time (Hour:Min: Sec)

Windows Resources - Last 60 sec

o© © o o o200 0fl6 0 0o o 0o o o 0% o o o

G o
Bty by bt .ﬂm.oe,&u oa) looaeh o s
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.....................

=

00:01:00 00:02:00 00:03:00 00:0400 00:0500 00:06:00

Elapsed Time (Hour:Min:Sec)

2. Highlight individual measurements.
a. Double-click the Windows Resources graph to enlarge it to fit the entire Graph Display
pane. Notice that each measurement appears on a color-coded row in the Graph Legend
pane. Each row corresponds to a line in the graph with the same color.

01:18:40 01:18:50  01:19:00 01:18:10 01:19:20 01:19:30

Elapsed Time (Hour:Min: Sec)

b. Select arow to highlight the corresponding line in the graph, and vice versa.

c. Double-click the graph again to reduce its size.

3. View the throughput information.

In the Available Graphs pane, under Web Resources Graphs, select the Throughput graph,
and drag it into the Graph Display pane. The Throughput graph measurements are displayed in
the Graph Display pane and the Graph Legend pane.

The Throughput graph shows the amount of data (measured in bytes) that the Vusers receive
from the server in any given second. You can compare this graph with the Transaction
Response Time graph to see how throughput affects transaction performance.

If the throughput scales upward as time progresses and the number of Vusers increases, this
indicates that the bandwidth is sufficient. If the graph were to remain relatively flat as the
number of Vusers increased, it would be reasonable to conclude that the bandwidth is

constraining the volume of data delivered.

HP LoadRunner (12.00)
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Thioughput - wwhole scenario
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How do | watch a Vuser running in real time?

When emulating users, you should be able to view the Vusers' actions in real time to make sure
they are performing the correct actions. The Controller lets you view the actions in real time using
the Run-Time Viewer.

To visually observe a Vuser’s actions:

1. Inthe Controller's Run tab, click the Vusers button. The Vusers dialog box opens.

Wusers(8) =]
@\ L] |basic:_sc:ript j |AII Wusers j
|0] Statuz | Script Load Generator| Elapsed Time | o
[ﬁ 48& Running basic_scriph localhost 00:00:29
2 Bunni bagic_zcriph localhost 00:00:29
= .Jf' unnfng . . S& Gradual Stop
5 ,\Sf Running basic_script localhost 00:00:29
B .Jf Running basic_zcript localhost 00:00:29 & Stap
7 % Ready basic_script localhost g
a i\ Ready basic_script localhost
9 i\ Ready basic_script localhost l"|":| Details...
1a ﬁ Ready basic_scriph localhost

€2, ddd Vuser[s)...
Help

The Status column displays the status of each Vuser. In the example above, you can see that
four Vusers are running and four are down. The Start Vusers action in the scheduler instructed
the Controller to release two Vusers at a time. As the scenario progresses, Vusers will

continue to be added in groups of two at 30-second intervals.
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2. Select arunning Vuser in the Vuser list.

3. Click the Show the selected Vusers button 2 on the Vusers toolbar. The Run-Time Viewer
opens and displays the actions performed by the selected Vuser. The Run-Time Viewer
updates as the Vuser proceeds through the steps of the Vuser script.

4. Click the Hide the selected Vusers button [ on the Vusers toolbar to close the Run-Time
Viewer.

Where can | view a summary of Vuser actions?

To see the progress of an individual Vuser during a running test, you can display a log file that
contains a text summary of the Vuser's actions.

To review a text summary of the Vuser’s actions

1. Inthe Vusers window, select a running Vuser.

2. Click the Show Vuser Log '8 button on the Vusers toolbar. The Vuser log dialog box opens.

‘fQ Yuser travel_agents:1 output file (Running) EI =] @
E E @

----- & Actionc(Bl  Keepdlive: timeout=60, max=8%
----- M Action.cB):  Connection: Keep-alivelrin

----- & Actionc[B)  Content-Type: image/gifarin

----- & Actionc[Bl  MWn

----- & Action.c[B] t=89923ms: 758-bpte rezponse body
----- & Action.c[B] t=89923ms: Request done "hitp: /71
----- & Action.c(B): web_wl"welcome. pl"] was succe:
----- A Action.c[15]: Notify: Transaction "S01_
----- & Action.c[17]: I_think_time: 4.00 seconds.

#- & Action.c[19]): Notify: Tranzaction "501_T0
----- & Action.c[46] I_think_time: 3.00 seconds. -
4 il 3

chtemphres2hloghtravel_agents_llog Line:

v Refresh [every 1000 miliseconds) Help | Claze |

The log contains messages that correspond to the actions of the Vuser. For example, in the
window above, the message Virtual User Script started indicates the start of the Vuser's run.
Scroll to the bottom of the log and watch as new messages are added for each action
performed by the Vuser.

3. Close the Vuser Log dialog box and the Vusers dialog box.

How can | increase the load during the test?

You can manually add more Vusers during a load test to increase the load on the system.
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1. Toincrease the load during a load test:
a. Make sure that in the Controller, the Run tab is displayed

b. Click the Run/Stop Vusers button. The Run/Stop Vusers dialog box opens displaying the
number of Vusers currently assigned to run in the scenario.

Run/Stop Vusers @

Specify a quantity of Yusers for every group

| Group Name # Load Generators | g0 Init

tranel_agents a localhost
£ Fun *,
& s ||
Help

] Close |

c. Inthe #column, enter the number of Vusers that you want to add to the group. To run two
additional Vusers, replace the number 8 with the number 2, in the # column.

d. Click Run to add the Vusers.

e. If some of the original Vusers have not yet been initialized, the Run Initialized and Run
New options appear. Select the Run New option.

r Y
Run/Stop Vusers ﬁ

Specify a quantity of Vusers for every group

‘ Group Name # \ Load Generators n

travel_agents [2 localhost
g

Run Initialized
Run New

Help

F == Close |

\

The two additional Vusers are distributed to the travel_agent group and are run on the
localhost load generator. The Scenario Status pane shows that there are now 10 running
Vusers.

You may get a warning message that the LoadRunner Controller cannot activate
additional Vusers. This is because you are using your local machine as a load
generator and it has limited memory resources. Generally, use a dedicated machine as
a load generator to avoid this issue.
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How is the application performing under load?

Check the Scenario Status pane [on the Run tab] for a summary of the running scenario. In the
Scenario Status pane, you can drill down to see which Vuser actions are causing the application
problems. A high number of failed transactions and errors may indicate that the application is not
performing as required under load.

1. View the scenario status.

The header of the Scenario Status pane displays the overall status of the scenario.

Scenario Status

Running Yusers

Elapsed Time 00:00:27 (hh:mm:ss)
Hits/Second 1.15 (last 60 sec)
Passed Transactions 10 Q
Failed Transactions 1] Q
Errors 0 Q

2. View abreakdown of Vuser actions.

a. Click Passed Transactions in the Scenario Status pane. The Transactions dialog box
opens and displays a list of transaction details.

Transactions =]
MName TFS Passed | Failed | Stopped |i
S01_T02_Logln 05 57 0 0 L4
501_T03_SearchFlight nz 57 0 0
S501_T07_SignOff na 57 0 0
vuser_end_Transaction n.a 57 1] 1]
S01_T0O5_FaymentDetails n.a 57 1] 1]
Action_Transaction n.a 57 1] 1]
wvuser_init_Transaction 0z 57 1] 1] N
Close Help

b. Click Close to close the Transactions dialog box.
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Did the application encounter errors?

If an application starts to fail under heavy load, you are likely to encounter errors and failed
transactions. The Controller displays error messages in the Output window.

1. Check for any error or warning messages.
a. Select View > Show Output. You can sort the message by type, such as Warnings or
Errors.

The Output dialog box opens and lists a message text, the total number of messages
generated, the Vusers and load generators that generated the error, and the scripts in which
the errors occurred.

Output (Total messages: 5, Errors: 0) =]
Type of Message: A&l Messages - Dietails B B Freeze
Type|Message Code [2] |Sample Meszage Text |T0ta| |Vusers |Scripts |Genelat0rs | Help |
o | -27077 [w/aming -27077: The "vuser_ini... I 4 4 1 1IENE
% 10732 ‘whaming: Inwvalid parameter detected in functi... 1 0 0 1
Surnmary

b. Toview amessage in detail, select the message and click Details. The Detailed Message
Text box opens, displaying the complete message text.

2. View log information details.

You can view information about each message, Vuser, script, and load generator associated
with an error code by clicking the blue link in the appropriate column.

For example, to locate where in the script an error occurred, drill down the Total Messages
column. The Output window displays a list of all messages of the selected error code, including
the time, iteration number, and line in the script where the error occurred.

3. Drill down the Line Number column.
VuGen opens, displaying the line in the script at which the error occurred. You can use this

information to identify transactions with slow response times that are causing the application to
fail under load.
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How do | know that the scenario has finished
running?

At the conclusion of a scenario run, the header of the Scenario Status pane shows the Down
status. This indicates that all the Vusers in the scenario have finished running.

Scenario Status

Running Yusers

Elapsed Time 00:00:27 (hh:mm:ss)
Hits/Second 1.15 (last 60 sec)
Passed Transactions 10 Q
Failed Transactions 0 Q
Errors 0 Q

You can open the Vusers dialog box to see the status of each individual Vuser. The Vuser dialog
box displays the number of iterations that each Vuser performed, the number of successful
iterations, and the elapsed time.

users{d) )

‘ = j “ﬂll Wisers j

Status | Script |Jad Generat|ﬁ|apsed Tim|;
3 Stopped 40 iteration(s] attempted: 40 succeebasic_script  localhost  |00:11:27 | 3 Bun

Aﬁ Stopped 40 ?terat?on[s] attermpted: 40 succee bas?c_scr?pt localhest  00:171:27 25 G sl St |

% Stopped 40 iteration(s) attempted: 40 succeebasic_script  locathost | 00:11:29

3 Stopped 40 iteration(s] atternpted: 40 succeebasic_script  localhost  |00:11:23 3 Stop |

2*
R
[5
;x & Stopped 40 iteration(s] attempted: 40 succeebasic_script | locathost  00:11:27 «“ Resst
9
1

% Stopped 40 iteration(s) attempted: 40 succeebasic_script  locathost | 00:11:27

|9 FStopped dDiteration(s] attempted: 40 succeebasic_soript  localhost  00:11:23 if  Detais.. |
[ 0~ Ai Stopped 40 iteration(s] attempted: 40 succee basic_script | locathost | 00:11:29 22, add Vuser[s]..l

i Help I

Did the system perform well under load?

To see how well the system performed under load, look at the transaction response times and
determine whether the response times were within acceptable limits. If the transaction response
times increase during the scenario, you need to look for bottlenecks. You will learn more about this
in "Lesson 7: Analyzing Your Scenario" on page 78.

Once a problem has been isolated, a corroborative effort involving developers, DBAs, network, and
other systems experts is required to fix the problem. After adjustments are made, the load test is
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repeated to confirm that the adjustments had the desired effect. You repeat this cycle to optimize
system performance.

To save the scenario so that you can run it again with the same settings, select File > Save or click
the Save button & on the Controller toolbar.

"Lesson 7: Analyzing Your Scenario" on page 78.

HP LoadRunner (12.00) Page 77 of 102



Tutorial
Lesson 7: Analyzing Your Scenario

Lesson 7: Analyzing Your Scenario

In the previous lessons you learned how to design, control, and execute a scenario run. Once you
have loaded your server, you want to analyze the run, and pinpoint the problems that need to be
eliminated to improve system performance.

The graphs and reports produced during your analysis session present important information about
the performance of your scenario. Using these graphs and reports, you can pinpoint and identify the
bottlenecks in your application, and determine what changes need to be made to your system to
improve its performance.

In this lesson, you will cover the following topics:

e How does an analysis session work?

e How do| start my analysis session?

e The Analysis window at a glance

o Did | reach my goals? (Service Level Agreement)
e How do | view a summary of performance?

e How do | graphically view performance?

e Did my server perform well?

e How can | pinpoint the source of a problem?

o What other information can | gather about my scenario run?
e How can | publish my findings?

e Conclusion

How does an analysis session work?

The aim of the analysis session is to find the failures in your system’s performance and then
pinpoint the source of these failures, for example:

o Were the test expectations met? What was the transaction time on the user's end under load?
Did the SLA meet or deviate from its goals? What was the average transaction time of the
transactions?

o What parts of the system could have contributed to the decline in performance? What was the
time of the network and servers?

« Canyou find a possible cause by correlating the transaction times and backend monitor matrix?
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In the following sections, you will learn how to open LoadRunner Analysis, and build and view
graphs and reports that will help you find performance problems and pinpoint the sources of these

problems.

How do | start my analysis session?

1. Open HP LoadRunner Analysis.

Double-click the Analysis icon on the Desktop or select Start > All Programs > HP Software
> HP LoadRunner > Analysis. HP LoadRunner Analysis opens.

2. Open the analysis session file.

For the purpose of this section in the tutorial, in order to illustrate more diverse results, weran a
scenario similar to those you ran in the previous lessons. This time, however, the scenario
incorporated 70 Vusers rather than 10 Vusers. You will now open the analysis session created

from the results of this scenario.

a. Inthe Analysis window, select File > Open. The Open Analysis Session dialog box

opens.

==

Look, in: | | hutarial j = = Efx
L Marre - Date modified Type Si
i analysis_session 972772012 3:25 PM File folder
Recent Places - : -
2 basic_script 171272012 1:44 PA File falder
- % correlated_script 1/12/2012 L44PM  File folder
Desktop 2 derno_script 11272012 144 PR File folder
— ) Tutarial_html 5,/0,/2012 10:05 Abkd File falder
=
Libraries
Carnputer
= %
(T
M etwork,
] 1 b
File name: | =l Open
Files of bype: |LDadHunner Analysiz Sessions [%lra) ﬂ Cancel

b. From the <LoadRunner Installation>\tutorial folder, select analysis_session and click

Open. Analysis opens the session file.

The Analysis window at a glance

Analysis contains the following primary panes:
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1. Session Explorer
2. Properties pane
3. Graph Viewing pane
4. Legend pane
@ HP LoadRunner Analysis - analysis_session.Ira - EM
File Edit View Graph Reports Tools Windows Help
SETER PR | TIEQIDE D&% WS BB KE
\
( 1 y Session Explorer 2 X] .ers| Hits per Second ‘ Throughput| Transaction Summary | Average Transa... Response Time | 4 D X |8
BrX=Dn @ A - . c
— @ verage Transaction Response Time &
B analysis_session.lra E.
=] E Reports 110 7‘ §
;/ Summary Report S H @
= Graphs E 100 { L]
[1ls] Running Yusers & 30 Y ‘] . E
[ils] Hits per Second £ . ’/ Y / \ A ,‘.
[11:] Throughput g / "*,51 "-.L f L g
[1ls] Transaction Summary | = W f _i'd"' o ! \ -"/ I‘ir-'. ;
[11] Average Transaction F E 60 "-'_,-/ H‘ ‘-.“ "J?\ 14 \ A &
g = ' ‘|| ‘~--*u’! Voo SV -
& 40 o ‘l f \ / \H o ‘\‘ Uiy
< m » 2 a0 ’7 Y ’,‘ '\ 1 \ a
2 : & / ‘ | g
A Properties 7 x| E 20 \ >
o= 4 < 0 4 g
B Properties [ =F - am Sl s B =SS SESS = L]
Desenption | Displays the avera 01:00 0200 0300 0400 0500 0600 0700 0800 0900 10:00 11:.00
Filter Transaction End Elapsed scenario time mm:ss
Granularity 16 Seconds
Group By | Legend q x|
Measurement = rf: ‘e R &2 R P = N
Tile Average Transactior [ ~|Measurement ||| Graph's i || Graph's A~ |GraH
- - Action_Transaction 6.002 54.882 118.
Displays the average time -
taken to perform transactions book_flight 0.221 1.469 271
during each second of the check_itinerary 3.295 29.208 75.0
load test. This graph helps you &« < » » M * '+ 9 [4] ]
I | (¥ Controller Output Messages
W Complete data
1. Session Explorer. In the upper left pane, Analysis shows the reports and graphs that are open
for viewing. From here you can display new reports or graphs that do not appear when Analysis
opens, or delete ones that you no longer want to view.
2. Properties pane. In the lower left pane, the Properties pane displays the details of the graph or
report you selected in the Session Explorer. Fields that appear in black are editable.
3. Graph Viewing pane. In the upper right pane, Analysis displays the graphs. By default, the
Summary Report is displayed in this area when you open a session.
4. Legend pane. In the lower right pane, you can view data from the selected graph.

Note: There are additional panes that can be accessed from the toolbar. These panes can be

dragged and dropped anywhere on the screen.
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Did | reach my goals? (Service Level
Agreement)

In this section, you will be introduced to the Service Level Agreement, or SLA.

SLAs are specific goals that you define for your load test scenario. Analysis compares these goals
against performance-related data that LoadRunner gathers and stores during the run, and then
determines the SLA status (Pass or Fail) for the goal.

For example, you can define a specific goal, or threshold, for the average transaction time of a
transaction in your script. After the test run ends, LoadRunner compares the goals you defined
against the actual recorded average transaction times. Analysis displays the status of each defined
SLA, either Pass or Fail. For example, if the actual average transaction time did not exceed the
threshold you defined, the SLA status will be Pass.

As part of your goal definition, you can instruct the SLA to take load criteria into account. This
means that the acceptable threshold will vary depending on the level of load, for example, Running
Vusers, Throughput, and so on. As the load increases, you can allow a higher threshold.

Depending on your defined goal, LoadRunner determines SLA statuses in one of the following
ways:

o SLA status determined at time intervals over a timeline. Analysis displays SLA statuses at
set time intervals (for example, every 5 seconds) over a timeline within the run.

o SLA status determined over the whole run. Analysis displays a single SLA status for the
whole scenario run.

SLAs can be defined either before running a scenario in the Controller, or after in Analysis itself.

In the following section, you will define an SLA using the HP Web Tours example. Assume that the
administrator of HP Web Tours would like to know whenever the average transaction times of the
book_flight and search_flight transactions exceed certain values. To do this, you select the
transactions and then set threshold values. These threshold values are the maximum amounts of
time that would be acceptable as average transaction times.

You will also set these threshold values to take certain load criteria into account; in this case
Running Vusers. In other words, as the number of running Vusers increases, the threshold value
rises.

This is because although the HP Web Tours administrator would like the average transaction times
to be as low as possible, it is understood that at certain times of the year it is reasonable to assume
that the HP Web Tours site will have to handle a higher load than at other times of the year. For
example, during peak travel season, a higher number of travel agents log on to the site to book
flights, check itineraries, and so on. Given this understandably higher load, at these times a slightly
longer average transaction time will be acceptable.

You will set the SLA to take three load scenarios into account: light load, average load, and heavy
load. Each scenario will have its own threshold value.
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How do | define an SLA?

You will define an SLA in Analysis after the scenario run.

Note: It is preferable to define an SLA in the Controller before a scenario run. However, for the
purposes of this tutorial, because you are not analyzing the same test scenario that you ran in
previous lessons, you will define the SLA in Analysis. To define an SLA in the Controller, click
New in the Service Level Agreement section of the Design tab.

You will now define an SLA that will set specific goals for the average transaction times for the
book_flight and search_flight transactions in the sample session file.
The average transaction times will be measured at set time intervals within the run.

To define an SLA:

1. Open the SLA wizard.
a. InLoadRunner Analysis, select Tools > Configure SLA Rules. The Service Level
Agreement dialog box opens.

Service Level Agreement @

Service Level Agreement

o Mew [E21 Advanced

Service Level Agreement

Currently no SLa rules are defined for the load test,
Click, the Mew button to define SL& criteria for pour load test,

Help Close

b. Click New to open the Service Level Agreement wizard.
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ﬁ Service Level Agreement - Goal Definition @

Service Level Agreement - Goal Definition

A zervice level agreement [SLA) enables you ta define goals for pour laad test.

Diuritg the load test, the Controller collects performance data. Analsiz compares this data against the
[ﬁa goalz defined in the SLA and dizplays the results in an SLA report,

I arder to define a goal, you need to specify a measurement, load criteria, and threshaold walues.

LoadRunner
Service Level
Agreement

I the fallowing steps, wou will be able ta define your awn goal. You can define one goal for each
meazurement.

® Measurement
® Transaction

® Load criteria I

@ Threshalds

I\ ® Finish

[ Skip thiz page nest time.

| Mext > | Cancel | |

Note that the first time you open the Service Level Agreement wizard, the Start page
is displayed. If you do not want this page to be displayed the next time you run the
wizard, select the Skip this page next time check box.

c. Click Next.
2. Select a measurement for your goal.

a. Inthe Select a Measurement for Your Goal page, select Transaction Response Time:
Average.

HP LoadRunner (12.00) Page 83 of 102



Tutorial

Lesson 7: Analyzing Your Scenario

ﬁ Service Level Agreement - Goal Definiticn

A

LoadRunner

» Transaction
® Lood criterin
® Thresholds

® Finish

Service Level Agreement - Goal Definition

Select a Measurement for Your Goal

Select a measurement from one of the categories below.

Mote: Load criteria can be defined anly when selecting measurements whose SLA statuses are
determined at time intervals over a timeline.

% Transaction Responze Time

[Status per time interva

" Enors per Second [Status per time interval)
(" Tatal Hits [Status per rm)

" Average Hits per Second [Status per wn)
" Total Throughput (bytes) [Status per rin)

" Average Throughput (bytes/zec) [Status per run)

< Back Mest » LCancel Help

b. Click Next.

3. Select the transactions to monitor.

In the Select Transactions page, select a transaction to monitor from the Available

Transactions list.
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a. Double-click the check_itinerary transaction to move it to the Selected Transactions list.

A

LoadRunner
Service Level
Agreement

® Start

® Measurement

® Load criterin
@ Threshalds

® Finish

Service Level Agreement - Goal Definition

Service Level Agreement - Goal Definition

Select Transactions

Choose tranzactions that are mast critical to wour run.

The SLA rezults are displayed for each of these transactions.

Available Transactions

Selected Transactions

Action_Tranzaction

biook_flight

logoff

lagon 7
zearch_flight

vuzer_end_Tranzaction Lo

wuzer_init_Transaction

check_itinerary

< Back

Mext >

Cancel

Help

b. Click Next.

4. Set the load criteria.

In the Set Load Criteria page, you instruct the SLA to take different load scenarios into

account.

a. Select Running Vusers from the Load Criteria drop down list.

b. Setthe Load Values to look like the following example:
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r = ~
ﬁ Service Level Agreement - Goal Definiticn ﬁ
Service Level Agreement - Goal Definition
Set Load Critena
[ﬁ] Selected measurement; Tranzaction Responze Time [bverage]
F Set the load criteria and load walues that you want to test.
Lo Gd Runner The threzhald values for your goal are examined accaording to these values.
Service Level Mobe: The load values must cover a continuous and complete range.
Agreement
® Start heria -
Load Criteria: |F|unn|ng Wusers j
® Measurement
Load Walues: | esz than a0
® Transaction P | !
v |Eetween j |2D - |50
1 I
1 7 |Greater than or equal ta j |50 i
® Thresholds
® Finish
< Back | Mext > | Cancel | Help
L (W

In the above screen, you set the SLA to define an acceptable average transaction time over
three potential load scenarios:

- Light load. Between 0 and 19 Vusers

- Average load. Between 20 and 49 Vusers

- Heavy load. More than 50 Vusers

c. Click Next.

5. Set threshold values.

In the Set Threshold Values page, you define the acceptable average transaction times for the
check_itinerary transaction.

Set the threshold values to look like the following example:
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® Start
® Measurement

# Transaction

® Load criteria

® Finish

Service Level Agreement - Goal Definition

Service Level Agreement - Goal Definition

Set Threshold Values

Selected measurement: |Tlansaction Responze Time [Average]

Enter maximum thresholds per load value for each branzaction. Results that exceed the
threshold values will produce a failed SLA status.

Tip: You can apply one et of thresholds to all tranzactions in the Apply to all table below.

Running Yusers

Transaction Mame =20 =70 and <50 =50
check itnerary (S 10 15

To apply one zet of threshold walues to all ransactions, enter the threshold values and click
Apply to all ranzactions.

<20 =20 and <50 =350
1} 0 ]

Apply to all

Apply to all ranzactions

¢ Back Mest > Cancel Help

You just indicated that the following average transaction times are acceptable:

- Light load. 5 seconds or less

- Average load. 10 seconds or less

- Heavy load. 15 seconds or less

6. Savethe SLA.

To save the SLA and close the wizard, click Next then Finish then Close on the pages that

follow.

Analysis applies your SLA settings to the Summary Report. The report is then updated to

include all the relevant SLA information.

How do | view a summary of performance?

The Summary Report tab displays general information and statistics about the scenario run, as well
as all relevant SLA information. For example, what were the worst performing transactions in terms
of defined SLAs, how specific transactions performed over set time intervals, and overall SLA

statuses. You open the Summary Report from the Session Explorer.
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1. What are the overall scenario statistics?

In the Statistics Summary section, you can see that a maximum of 70 Vusers ran in this test.
Other statistics such as the total/average throughput, and the total/average hits are also

displayed.

Summary Report | Running Yusers | Hits per Secand | Thruughput| Transaction Summary| Awerage g

Analysis Summary

Period: 28/06/2004 09:5

Statistics Summary

Maximum Running Vusers:
Total Throughput (bytes):

Average Throughput
[bytes/second):

Total Hits:

Awverage Hits per Second:

Total Errors:

Scenaric Name: C:\Tutorial_Scenario.lrs
Results in Session: S:\tutorial_result\tutorial_result.lrr

Duration: 11 minutes and 57 seconds.

70
- 273,489,363

280,904

L 8,789

"l 12.241 View HTTP Responses Summary

L 9,228

2. What were the worst performing transactions?

The 5 Worst Transactions table shows you up to five worst-performing transactions for which

SLAs were defined.

5 Worst Transactions

Transaction Name

Failure Ratio[%0]
[exceeded time/transaction duration)

Failure Value[%]
[response time/SLA)

- check_itinerany

EE.4

200.684

Time Interval

Avg exceading ratio

Max exceeding ratio

00:01:35-00:03:50
00:05:10-00:07:25
00:07:30-00:08:00
00:08:15-00:08:30
00:08:45-00:10:25

258.37
200.48
142.07
£1.8

161.4%

E3B.59
358.07
287.2
155.9
336.6

You can see that over the duration of the check_itinerary transaction, the SLA threshold was
exceeded 66.4% of the time. The average percentage by which it exceeded the SLA threshold
over the whole run was 200.684%.

3. Over which time intervals was the SLA threshold exceeded?
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The Scenario Behavior Over Time section shows how each transaction performed during
different time intervals. The green squares show time intervals where the transaction
performed within the SLA threshold, red squares where the transaction failed, and gray squares
where no relevant SLA was defined.

Scenario Behavior Over Time

The SLA status of the following measurements displayed over time. You can select a specific time range for each transaction in order
to analyze the time range.

Transaction: Icheck_itinerary | Time range to drill down: From: |000 01:20 :I To: |000 03:20 :I

Measurement Name Time Ranges

Application Under Test | 0 ” 01 | 24 ” 31 ” 12 ” 25 ” 3z ” 43 ” 3z ” 17 ” 07 ” 0.5 ” 0.2 ” 0.4 || 0.2 || 0.5 ” o+ |[ o+

Errors

dhack fonarary 1P P M M
L= L= L= L= L= L= L= L= L= L= =] o (=] L= L= L= L= L=
¢ 2 2 © © o ©° © © ° © © 9 5 © o o 9
L= L= o [=] [=] L= L= L= L= L= =] o (=] L= L= Ll Ll Ll
=2 =2 [y r r by by = o - o o = = o =2 =2 [y
L= ) ra L= ) ra L= ) ra L= b ra (=] ) ra L= ) ra
o o o o o o o o o o (=] o (=] o o o o o

You can see that for the transaction for which you defined an SLA, check_itinerary exceeded
the threshold in most intervals.

4. What was the overall transaction performance?

The Transaction Summary lists a summary of the behavior of each transaction.

Transaction Summary

Transactions: Total Passed: 1,100 Total Failed: 3,112 Total Stopped: 0 Average Response Time

Transaction Name SLA Status Minimum Average Maximum 5td. Deviation 90 Percent Pass Fail Stop
Action Transaction .- 6.002 5B.577 155.399 25.387 89.081 144 3,081 O
book flight = 0.219 1.555 3.949 0.817 2.666 175 0 o
check itinerary -..§< 3.293 32.8286 1159.258 256.407 55.734 147 28 o
logoff = 0.408 1.0035 12.909 1.146 1.67 144 3 o
logon . 0.444 3.934 9.864 2.161 6.777 175 0 o
search flight .- 0.464 4.915 11.17 2.363 7.966 175 0 (1]
wuser end Transaction .- o s] 0 0 0 70 o o
wuser init Transaction = v} 0.013 0.077 0.024 0.059 70 1} o
Service Level Agreement Legend: @ pass %, Fail .L Mo Data

We also see that the check_itinerary transaction failed 28 times.

Review the times of each transaction. The 90 Percent column displays the time of 90% of the
executions of a particular transaction. You can see that 90% of the check_itinerary
transactions that were performed during the test run had a time of 65.754 seconds. This is
double its average time, 32.826, which means that the majority of occurrences of this
transaction had a very high response time.

Note how the SLA Status column shows the relevant overall status for transactions in the
SLA: Fail for check_itinerary .
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How do | graphically view performance?

You can access available graphs from the Session Explorer pane. You will now view and analyze
the Average Transaction Response Time graph.

1. Open the Average Transaction Response Time graph.
a. Inthe Session Explorer under Graphs, select Average Transaction Response Time.
The Average Transaction Response Time graph opens in the graph viewing area.

Note: If no graphs are displayed in the Session Explorer pane, right-click the Graphs
node and select the Transactions: Average Transaction Response Time node in the
Open a New Graph dialog box. Click Open Graph to add the graph to the Session
Explorer pane.

b. Inthe Legend pane, click the check_itinerary transaction. The check_itinerary
transaction is highlighted in the graph.

ary Report| Running Wusers | Hits per Second | Throughput| Transaction Surnmary | Average Transa... Response Time | 4 [ X

Average Transaction Response Time

RILE
o
= 1001
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- |Measurement - ||Graph's |~ |Graph'sA - |Graph's le|* || Graph's b vﬂ
Action_Transaction 6.002 b4.882 118.339 5432

1 haook_flight 0221 1.463 2.7 1514

check_itinerary

3995

deda

673

The points on the graph represent the average time of a transaction at a specific time during
the scenario. Hold your cursor over a point in the graph. A yellow box appears, and displays
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the coordinates of that point.

ary Report| Running Wusers | Hits per Second | Throughput| Transaction Surnmary | Average Transa... Response Time | 4 [ &

Average Transaction Response Time

Average Response Time (seconds)

01:00

2. Analyze the results.

0200

Elapsed scenario time hhemmess = 00:05:04
Average Response Time (seconds) = 63.194
Transaction Name=Action_Transaction

0300 04:00 0:3:00 08:00 0700

Elapsed scenario time mm:ss

09:00 10:00 11:00

Note how the average transaction time of the check_itinerary transaction fluctuates greatly,
and reaches a peak of 75.067 seconds, 2:56 minutes into the scenario run.

On a well-performing server, the transactions would follow a relatively stable average time. At
the bottom of the graph, note how the logon, logoff, book_flight, and search_flight
transactions have more stable average times.

Did my server perform well?

In the previous section you saw instability in your server's performance. Now you will analyze the
effect of 70 running Vusers on the system’s performance.

1. Study the behavior of the Vusers.

In the Session Explorer, under Graphs, click Running Vusers. The Running Vusers graph
opens in the graph viewing area.
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Surnrnary Report | Running Yusers | Hits per Second | Throughput| Transaction Surnmary | Average Transac..n Respon 4 b X

Murnber of Yusers

Running Yusers

70
63
60
55
50
45
404
35
30
25
20
15
10
5 3
04

T T T T T T T T T T T
01:00 0200 03:00 04:00 0s5:00 06:00 o700 05:00 09:00 10:00 11:00 120
Elapsed scenario time mm:ss

You can see that there was a gradual start of running Vusers at the beginning of the scenario
run. Then, for a period of 3 minutes, 70 Vusers ran simultaneously, after which the Vusers
gradually stopped running.

2. Filter the graph so that you see only the time slice when all the Vusers ran simultaneously.

When you filter a graph, the graph data is narrowed down so that only the data for the condition
that you specified is displayed. All other data is hidden.

a.

Right-click the graph and select Set Filter/Group By, or alternatively, click the Set

i
Filter/Group By button " on the Analysis toolbar.

In the Filter Condition area, select the Values column of the Scenario Elapsed Time
row.

Click the down-arrow and specify a time range from 000:01:30 minutes to 000:03:45
minutes.

Click OK.
In the Graph Settings dialog box, click OK.

The Running Vusers graph now displays only those Vusers running between 1:30
minutes and 3:45 minutes of the scenario run. All other Vusers have been filtered out.
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ary Report | Running Yusers | Hits per Second | Thraughput| Transaction Surmary | Swerage Transac...n Response Time 4 b %

Running Vusers

70

E9.5
G396
59.4
592

64
65.5

Mumber of Vusers

656
654
63.2 §

=5}

T T T T T T T T T
01:36 m:52 0208 0224 0z:40 0256 0312 0328 03:44
Elapsed scenario time mrm:ss

Note: To clear the filter, you right-click the graph and select Clear Filter/Group By, or
b

alternatively, click the Clear Filter and Group By button on the Analysis

toolbar.

3. Correlate the Running Vusers and Average Transaction Response Time graphs to compare
their data.

You can join two graphs together to see the effect of one graph’s data upon the other graph’s
data. This is called correlating two graphs.

For example, you can correlate the Running Vusers graph with the Average Transaction
Response Time graph to see the effect of a large number of Vusers on the average time of the
transactions.

a. Right-click the Running Vusers graph and select Clear Filter/Group By.
b. Right-click the graph and select Merge Graphs.

c. From the Select graph to merge with list, select Average Transaction Response
Time.

d. Under Select type of merge, select Correlate, and click OK.

The Running Vusers and Average Transaction Response Time graphs are now displayed
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in one graph, the Running Vusers - Average Transaction Response Time graph.

Second | Throughput| Transaction Summar}f| Awerage Transac..n Response Tirme | Running Yusers... Response Time | 4 [ ¥

Running Yusers - Average Transaction Response Time

Average Response Time (seconds)

0 5 10 15 20 25 30 35 40 45 50 55 60 85 70
Mumber of Yusers

4. Analyze the correlated graph.
In this graph you can see that as the number of Vusers increases, the average time of the
check_itinerary transaction gradually increases. In other words, the average time increases
as the load increases.

At 66 Vusers, there is a sudden, sharp increase in the average time. We say that the test
broke the server. The time clearly began to degrade when there were more than 66 Vusers
running simultaneously.

Saving a template

So far you have filtered a graph and correlated two graphs. The next time you analyze a scenario,
you might want to view the same graphs, with the same filter and merge conditions applied. You
can save your merge and filter settings into a template, and apply them in another analysis session.

To save your template:
1. Select Tools > Templates. The Apply/ Edit Template dialog box opens.
2. Inthe Templates pane, click the New button. The Add New Template dialog box opens.
3. Enter an appropriate name for the template and click OK.
4. Click Save and close to close the Apply/Edit Template dialog box.
The next time you open a new Analysis session and want to use a saved template:
1. Select Tools > Templates. The Apply/ Edit Template dialog box opens.

2. Select your template from the list, and click Save and close.
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How can | pinpoint the source of the problem?

Until now, you have seen that an increase in load on the server had a negative impact on the
average response time of the check_itinerary transaction.

You can drill down further into the check_itinerary transaction to see which system resources may
have negatively influenced its performance.

The Auto-correlate tool can merge all the graphs that contain data that could have had an effect on
the response time of the check_itinerary transaction, and pinpoint what was happening at the
moment the problem occurred.

1. From the graph tree, select the Average Transaction Response Time graph.

ary Report| Running Wusers | Hits per Second | Throughput| Transaction umrmary | Average Transa.. Response Time | 4 [ &

Average Transaction Response Time
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Look at the check_itinerary transaction, particularly at the slice of elapsed time between 1 and
4 minutes. The average response time started to increase almost immediately, until it peaked
at nearly 3 minutes.

2. Filter the Average Transaction Response Time graph to display only the check_itinerary
transaction.
a. Right-click the graph, and select Set Filter/Group by.

b. Inthe Transaction Name / Value cell, select check_itinerary.

c. Click OK.
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The filtered graph displays only the check_itinerary transaction.

Second | Throughput| Transaction Surnmary | Average Transa... Response Time | Running Yusers -..n Response Time | 4 B X

Average Transaction Response Time
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Elapsed scenario time mm:ss

3. Auto-correlate the graph.
a. Right-click the graph, and select Auto Correlate.

b. Inthe Auto Correlate dialog box, make sure that the measurement to correlate is check_
itinerary, and set the time range from 1:20 to 3:40 minutes - either by entering the times in
the boxes, or by dragging the green and red poles into place along the Elapsed Scenario
Time axis.
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c. Click OK.

The auto-correlated graph opens in the graph viewing area. The check_itinerary
transaction is highlighted.

ction Summary| Awerage Transac..n Response Time | Running YWusers -.n Response Time | Auto Correlated Graph[1] | 4 I ¥
Measurement to Correlate:| check_itinerary j Settings...

Auto Correlated Graph [1]
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MWeasurement Trends (standardized values)

The auto-correlated graph is given a default name, Auto Correlated Graph [1].
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4. Rename the graph.
a. Inthe Session Explorer, under Graphs, right-click Auto Correlated Graph [1], and select

Rename Item. The graph name becomes editable.

b. Type Auto Correlated - check_itinerary and press Enter, or click anywhere in the
Analysis window.

5. Analyze the auto-correlated graph.

In the Legend pane below the graph, from the Graph column, scroll down to the Windows
Resources: Pool Nonpaged Bytes and Private Bytes measurements.
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In the Measurement and Correlation Match columns, you can see that these memory-related
measurements, have a Correlation Match of over 70% with the check_itinerary transaction.
This means that the behavior of these elements was closely related to the behavior of the
check_itinerary transaction during the specified time interval.

We can conclude that exactly when the check_itinerary transaction’s response time peaked,
there was a shortage of system memory resources.

What other information can | gather about my
scenario run?

In addition to the graphs that appear in the graph tree at the start of an analysis session, you can
display different graphs to get other information about your scenario run.

1. Click Graph > Add New Graph.

The Open a New Graph dialog box opens and lists the categories of graphs that contain data
and can be displayed.
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-

Open a Mew Graph @
Selecta graph: W Display only graphs containing data
..

- Errors

B Transactions

-- Web Resources

-- Web Page Diagnostics
- Swstem Resources

Graph Description:

| Close Help | IJ

Vusers. Displays information about the Vusers and their status.

Errors. Displays error statistics.

Transactions. Displays data about transactions and their response times.

Web Resources. Displays hits, throughput, and connection data.

Web Page Diagnostics. Displays data about each monitored Web page in your script.

System Resources. Displays system resource usage data.

2. Display a new graph.
In the Open a New Graph dialog box, click the “+” next to a category to expand it.

a.

b. Select a graph and click Open Graph.

c. Click Close to close the Open a New Graph dialog box.

Now open several additional graphs to understand more about your scenario run.
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How can | publish my findings?

You can publish the findings from your analysis session in an HTML or Microsoft Word report. The
report is created using a designer template, and includes explanations and legends of the presented
graphs and data.

HTML Reports
The HTML report can be opened and viewed in any browser.

To create an HTML report:
1. Click Reports > HTML Report.
2. Specify afile name for your report, and the path where you want to save it.
3. Click Save.

Analysis creates the report and displays it in your Web browser. Note how the layout of the
HTML report is very similar to the layout of your analysis session. You can click on the links in
the left pane to see the various graphs. A description of each graph is given at the bottom of the

page.
Microsoft Word Reports

You can present your analysis session in a Microsoft Word report. The Word report is more
comprehensive than the HTML report, because you have the option to include general information
about the scenario, measurement descriptions, and so on. You can also format the report to include
your company’s name and logo, and the author’s details.

Like any Microsoft Word file, the report is editable, so you can add further comments and findings
after you build the report.

To create a Microsoft Word report:
1. Click Reports > New Report.

The New Report dialog box opens.
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& MNew Report
Based on template [Customer Facing (For cross session) -
General | Format Content
= Title

Customer Facing (for cross session)

= Authar
Firsk Mame:
SUFname:
Job Title:

Organization:

— Description

B using this te'nplate vou can easily generate a cross session customer Facing report that includes a wide range of performance statistics. This bemplate wil
automatically include any open graph yvou have in your analysis session as well as the Following information:

- General details

- Executive summary

- Busingss processes

- Wworkload charackeristics

- Performance averview For high level aggregated metrics and transactions

- Woarst performing URLs based on Web Page Diagnostics data

— Global Settings

Report: Time Range: |Whale Scenario === | {hhh:mm:ss)
Granularity: 1 “ow (sec)
Precision: 1 w7 w| (Number of digits to appear after the decimal paint in none graph content items)

Include Think Time

Use Raw Result Time Zone

Save As Template | Generate | Cancel Help

2. Inthe General tab:
a. From Based on template, select Detailed report (for single run).

b. Enter atitle for your report.
c. Enterthe author’'s name, job title, and the company’s name.
3. Inthe Format tab:
By default, the report will be built with a title page, table of contents, graph details and
descriptions, and measurement descriptions. You can select options which add script details

into the report, allowing you to view thumbnail images of the business process steps.

You can include a company logo by selecting Include company logo and browsing to the file
location. The logo must be a .bmp file.

4. Inthe Content tab:
a. Select which sections of your scenario run and analysis session you want to include in
your report.

For the purpose of this tutorial, you will add an executive summary to the Content Items
list.

b. Click the Add button ¥ to open the Add Content Items window. Check Executive
Summary in the grid and click OK. The Executive Summary item is added to the list in the
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Content Items pane.

Enter the following text into the edit box:

- Objectives: The objectives of the test scenario were to....
- Conclusions: The conclusions | reached are as follows:

c. Inthe Content Items pane, select the Largest URLs by Average Kbytes and click the
Delete button 4% . This will exclude this graph from the report.

d. Change the order in which to display the items in the report.

- In the Content Items pane, select Workload Characteristics. Click on Average Hits
per Second in the Selected Columns list.

- Click the Down arrow until the item appears under Total Transactions Number. In the
report, the Average Hits per Second item will follow the Total Transactions Number
item.

5. Click Generate.

The data is gathered and the report is created in a Microsoft Word file, which opens in Microsoft
Word.

In addition to the graphs that you generated during your analysis session, the report includes an
objective and a conclusion, and other sections and graphs that you chose to include while
building the report.

Conclusion

In this lesson you learned the basics of defining a Service Level Agreement, analyzing a scenario
run, and publishing your results in a report.

You have learned that performance problems can be pinpointed by studying various graphs that
show bottlenecks on the server, possibly due to too heavy a load. You have seen that you can
pinpoint the sources of these bottlenecks by configuring graphs to display correlated data.
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