This document has not been formally reviewed for accuracy and is provided "as is" for your convenience.
Summary
Error
Cause
The notify messsage is constructed and stored in a temprorary variable called $text.temp.
The data size of the variable is fixed and cannot be increased dynamically when the content of the notify mail is large.
Fix
The complete notify email can be sent by pre-defining a global variable into the "Notify" display option.
The Notify message can built from the Incident as follows:
1. Login to the Service Manager client as falcon
2. Type ds in the command line to enter the display application screen definition. Retrieve the Display Screen record where: Screen ID: notify
3. Add the following expressions to the Initializations section:
if (not null($G.text.temp)) then ($text.temp=$G.text.temp)
cleanup($G.text.temp)
4. Save changes to the Display Screen
5. Type do in the command line
6. Search for screen ID apm.edit.problem and default label Notify
7. Go to the tab pre RAD expressions and add the following expressions:
$G.text.temp={}
$G.text.temp=$G.text.temp+{"Description:"}+nullsub(denull(action in $L.filed), {""})
$G.text.temp=$G.text.temp+{"Journal Update:"}+nullsub(denull(update.action in $L.filed), {""})
Note: The above expressions posts all the default OOB Service Manager Incident ticket fields. If one has any other field in the incident ticket then they also need to be added in the above expressions
9. Logout and login to the service Manager client for changes to take effect
8. Save the display action record