Failure to run Vusers on PC 11.52 or 12.00 Host when the Agent is configured as a process

  • KM00728477
  • 23-Jan-2014
  • 23-Jan-2014

This document has not been formally reviewed for accuracy and is provided "as is" for your convenience.

Summary

When working with a PC Host machine to run Vusers and configuring the Agent is configured to run as a process the loadtest fails to connect to the LG

Error

 A loadtest fails to connect to the Agent on the LG machine and the Vusers canstart.
This issue is only related to the following scenario:
  • Running Vusers on PC 12.00 or 11.5x  Host machine (i.e. The Host is configured as LG)
  • The Performance Center Agent is configured to work as a process
  • The machine was restarted after the agent was configured

Cause

The Performance Center Agent process does not start after the restart.

Fix

  There are two possible solutions:
  • Manually start the process after restart
  • Place a shortcut (link) to the\launch_service\bin\magentproc.exe in the startup folder. This will automatically start the Agent process after each reboot.
    Warning: Make sure to delete this shortcut ones the Agent is configured to work as a service again.