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Introduction 
HP Adoption Readiness Tool (ART) is a versatile tool and you can easily adapt ART content to 
reflect your company’s branding. You do this by creating a new ART template so that you can 
add your logo and color schemes to courses and documents. 

This document covers the process to create a new template and the most common template 
and skin customizations. 
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Creating a Custom Template and Skin 
During HP ART 5.10 Author Developer Kit installation, the default HP ART 5.10 template is 
automatically installed in the HP Adoption Readiness Tool installation folder. When you first 
launch the HP ART editor, the tool dynamically creates a local repository holding all required 
resources used to create and manage ART content, including the ART 5.10 template. The 
default template is copied over from the installation folder.  

To create a custom template: 

1. Remove the default HP ART template. 
2. Copy the HP ART 5.10 template. 
3. Update the template descriptive name. 

Creating a Custom Template 

Removing the Default HP ART Template 
To create a template with the same GUID, you must first remove the default template from the 
installation folder. To remove the default template, perform the following steps: 

1. Navigate to the HP Adoption Readiness Tool installation folder C:\Program Files 
(x86)\HP Adoption Readiness Tool. 

 

2. Navigate to the Client>appdata>Templates folder. 

 

3. Remove the ART5_HP ART Template_1-0.udt file.  
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Copying the HP ART 5.10 Template 
Copy the existing HP ART 5.10 template to use as a starting point for your customized 
template. To copy the template, perform the following steps:  

1. Navigate to the local templates folder by selecting the Start>All Programs menu. 

 

2. Select the HP Adoption Readiness Tool Resources>HP Adoption Readiness Tool 
Resources option. 

 

3. Open the templates folder. 

The folder contains the HP ART 5.10 default template.  

 

4. Copy and paste ART5_HP ART Template 1-0.udt and name your new template 
with the desired name, typically your company name. For example, 
ART5_CompanyName_Template_1-0.udt. Because the copy function was used, 
the new template will have the same GUID as the original template.  
 
Note: You should not have more than one template with the same GUID in the 
templates root directory. To easily switch active templates, it is best practice to create 
a new folder in the root templates directory to store the templates not in use.  
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5. Create a new folder titled Custom Templates in the templates root directory.  

 

6. Move ART5_HP ART Template 1-0.udt to the Custom Templates folder. 
ART5_CompanyName_Template_1-0.udt is now the active template and will be 
applied the next time an ART file is opened.  

 

Updating the Template Descriptive Name 
To view the template and update the template descriptive name, follow these steps: 

1. Launch the HP ART Readiness Tool and click Go to editor in the Quick Start window.  
2. From the File menu, select Open>Template. 
3. Select ART5_CompanyName_Template_1-0.udt from the Template window and 

click OK. 
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4. If necessary, click the General tab. 
5. Note that this template has the same name and GUID number as the original HP ART 

template. 

 

 
 

6. In the Name field, change the template name to Company Name 1.00. 

 

7. Save the template. 
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Creating a Custom HPART-Rounded Skin 
The HPART-Rounded skin is the customized skin released with the ART 5.10 Development Kit.  

 

Several customizations made to the HPART-Rounded skin override template settings. If you 
would like to use this skin in your customized template, and plan on changing the colors of 
your course framework, you should copy HPART-Rounded to create your own custom skin. 
Creating a custom HPART-Rounded skin allows you to easily share your updated skin 
customizations with others in your organization. 

To create a custom HPART-Rounded skin, perform these steps: 

1. Using the Windows Start menu, navigate to HP Adoption Readiness Tool Resources. 
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2. Navigate to the skins>Course>custom folder. 
3. Locate the HPART-Rounded skin, right-click the skin folder and select Copy. 
4. Paste into the Custom skin folder. 
5. Give the new skin folder a unique name by keeping HPART-Rounded in the name and 

adding your company’s name. For example, HPART-Rounded - Company Name. 

  

6. Open your template and navigate to Publications>Default Publications Settings> 
Course>Course User Interface Settings and select your new custom skin from the drop-
down menu. 

 

7. Your skin has been added. Skin customizations are discussed later in this document.  
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Adding a Custom Logo to Courses 
You can easily change the look and feel of courses by adding your logo. The logo appears in 
two places: Course and Documentation. 

Modifying the Course Logo 
Before you can update the image on a course, you must first add the image to the general 
images group. To update the course logo, perform the following tasks in your template, 
ART5_CompanyName_Template_1-0.udt: 

Adding Image to the Images Group 
1. Open your template and navigate to the General tab>Images>Add button. 
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2. Navigate to the location of your company logo on your local or share drive and select 
the image. The image is added to the images list. 
 
The optimal size is approximately136x75 pixels. 
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Replacing the Course Logo 
1. Navigate to the Publications tab and select the Default Publications Setting> 

Course>Course User Interface Settings>HPART-Rounded - Company Name. 
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2. Scroll down to the bottom of the page to the Logo section. From the Logo drop-down, 
select your image. 

 

Note: The Preview window in the template does not display the new logo. To view the logo, 
you must preview or publish an eLearning course file. 

Modifying the Document Logo 
Updating the logo for documents is also easy but needs to be done separately. 

1. Open your template and navigate to Blocks tab>Header. 
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2. In the Content section, right-click the HP logo. 

 

3. Click Edit Image. 

 

4. Browse to the location of your company logo on your local or share drive and select 
the image.  

5. Click Open. 
6. Click Insert. 
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7. Save the template. ART documents now display the new logo in the header. 

Customizing the Course Branding 

Updating Course Banner and Text Colors 
1. Open your template and navigate to the Publications tab>Default Publications 

Setting>Course>Course User Interface Settings. 

 

2. Use the Course User Interface player and text colors to customize the course branding. 
3. Use the illustrations below to identify the areas you want to change. 
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 White Background Color: Main stage 

 Yellow Course Background UI Color: Frame around the entire 
course 

 Green Player Primary Color: Top and bottom banners 

 Orange 
Player Secondary Color: Top page banner, 
Simulation buttons, and Navigation buttons 

 Black Primary Text Color: Progress bar text, Navigation 
button text, Simulation button text 

 
Aqua Secondary Text Color: All hover text 

 

Note: If you are using the HPART-Rounded skin, the following elements are controlled using 
the cascading style sheet (.css) files.  

• Back and Next navigation buttons 
• Simulation launch buttons (Show Me/Try Me) 
• Assessment Continue and Assessment Results buttons 
• Pop-up window title bar   

Refer to the Updating the Custom Course Skin section for more information.  



 
Customizing HP ART 5.10 Templates and Skins 

http://hp.com/software/education  15 ART510 

 Copyright 2013-2014 Hewlett-Packard Development Company, L.P. 

Updating Course Text Styles 
You manage course styles within the template Styles tab. You can use several styles to 
customize the look of your HP ART course. Follow the steps below to locate and update a 
course style: 

1. Open your template and navigate to the Styles tab.  
2. Select the desired style.  
3. Update the style attributes such as font, size, and color. 
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Use the illustration below to identify the course page styles. 

 

 Black Default Course Title Text 

 Blue Default Course Page Title Text 

 Red Default Course Content Title Text 

 Green Default Course Text 

 
Use the illustration below to identify the assessment page styles. 

  

 Black Default Course Question Text 

 Green Default Course Text 
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Updating the HPART-Rounded Course Skin 
If you are using the custom HPART-Rounded skin, customize the following course elements 
using the skin cascading style sheet (.css) files:  

• Back and Next buttons (skin.css) 
• Simulation Launch buttons (content.css) 
• Assessment Continue and Assessment Results buttons (content.css) 
• Pop-up window title bar (content.css)  

Updating Next and Back Navigation Button Color 
To update the color of the Next and Back navigation buttons, perform these steps to edit the 
skin.css file: 

1. Using the Windows Start menu, navigate to HP Adoption Readiness Tool Resources. 
2. Navigate to the skins>Course>custom>HPART-Rounded - Company Name>skin folder. 
3. Open the skin.css file with an editor such as Notepad++. 
4. Locate div#nextBtn and div#backBtn in the nav/aux section and update the 

hexadecimal strings for the background to specify the color. For example, the hex 
value for HP blue is #0197D6, white is #FFFFFF, and black is #000000. 
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5. Save and close the skin.css file.  
6. Publish your test course to review skin updates. 

Updating the Simulation Launch, Continue, and Assessment Results Button Color 
To update the color of the simulation launch buttons and the Continue button in the assessment 
and Assessment Results buttons, perform these steps to edit the content.css file: 

 

1. Using the Windows Start menu, navigate to HP Adoption Readiness Tool Resources. 
2. Navigate to the skins>Course>custom>HPART-Rounded – Company Name>skin 

folder. 
3. Open the content.css file with an editor such as Notepad++. 

Note: The content.css file and skin.css file are in the same location. 
4. To update the color of the simulation launch buttons, locate div.choice 

input[type=button] in the Assessment section and update the hexadecimal 
strings for the background to specify the color. For example, the hex value for HP blue 
is #0197D6, white is #FFFFFF, and black is #000000. 
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5. To update the color of the Continue button in the assessment, locate 
div#assessmentButtons input[type=button]] in the Assessment section 
and update the background hexadecimal color. 

 

6. To update the color of the Assessment Results buttons, locate 
div#assessmentSummaryButtons input[type=button] in the Assessment 
Summary section and update the background hexadecimal color. 

 
7. Save and close the content.css file. 
8. Publish your course to review skin updates. 

Updating the Color of the Hotspot Window Title Bar  
To update the color of the hotspot window header, perform these steps to edit the 
content.css file: 

1. Using the Windows Start menu, navigate to HP Adoption Readiness Tool Resources. 
2. Navigate to the skins>Course>custom>HPART-Rounded-Customer>skin folder. 
3. Open the content.css file with an editor such as Notepad++. 
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4. Locate div.titleBarPopup in the Content section and update the hexadecimal 
strings for the background to specify the color. For example, the hex value for HP blue 
is #0197D6, white is #FFFFFF, and black is #000000. 

 

9. Save and close the content.css file. 
10. Publish your course to review skin updates. 
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Updating the Simulation Skin 
To customize the color of the simulation window, perform the following steps in your template: 

1. Open your template and navigate to the Publications tabs and select the Default 
Publications Setting>Simulation. 

2. From the Simulation Publication Settings drop-down list, select Simulation User 
Interface Settings.  
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3. If you would like a different look for your simulation window, you can select one of the 
available skins from the Skins drop-down list.   

4. Update the Player Colors settings to match your branding scheme.  

 

 Custom 
Background Color: Main stage 
(only shows in blank document) 

 Pale Blue Player Primary Color: Bottom of navigation bar 

 Blue 
Player Secondary Color: Progress bar and navigation 
buttons 

 

 

5. Save and close the template file.  

Note: The Preview window in the template does not display the updated colors. To view the 
updated skin, you must preview or publish a simulation. 
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Modifying the Launch Windows  
The launch window opens when you launch a simulation or course. You can modify the 
graphics, colors, and text of the course and simulation launch windows. You should only 
modify the styles covered in this guide if you are an advanced ART user. 

The ui_bkgd.png image appears in the upper portion of the launch window. The lower 
portion of the window is reserved for text that is populated during the publishing process. 

Modifying the Launch Window Background 
To modify the image in the course and simulation launch window, perform these steps: 

1. Create the desired image for the launch page to 439x252 pixels and save it with the 
file name ui_bkgd.png. 

2. Open your template and navigate to General tab>Images>ui_bkdg.png.  
3. Click Update.  
4. Select the image file from your local or share drive.  

Note: You should set your background splash image to 439x252 pixels. 
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This is an example of an updated launch window.  

 

Modifying the Course Launch Window Text 
To modify the course launch window text, perform these steps: 

1. Open your template and navigate to General tab>Data Files>course_index.htm. 
2. Click Modify. The file opens in an editor such as Notepad. 
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3. Use the illustration below to locate the area within the launch window HTML code that 
you would like to modify. The data files use hexadecimal strings to specify color in 
HTML files. For example, the hex value for white is #FFFFFF and for black is 
#000000. 

4. Close the HTML editor and select Yes when prompted to update the file.  
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Note: Only modify the items identified below if you are an advanced ART user. When 
finished, save the file.  

 

 

<span id="title" style="font-weight: bold; font-size: 14pt; 
color: #FFFFFF; font-family: Tahoma; margin-
right:10px;"><@Title@></span> 

 

 

a:link, a:active, 
a:visited 

{ 

font-family: Tahoma; 

font-size: 12px; 

color: #FFFFFF; 

font-weight: bold; 

text-decoration: 
none; 

} 

a:hover 

{ 

color: #003366; 

text-decoration: 
underline; 

} 

 

 



 
Customizing HP ART 5.10 Templates and Skins 

http://hp.com/software/education  27 ART510 

 Copyright 2013-2014 Hewlett-Packard Development Company, L.P. 

 

.infoboxText 

{ 

font-family: Tahoma; 

font-size: 12px; 

color: #000000; 

} 

 

 

 

 

.footerText, 

.footerText a:link, 

.footerText a:active, 

.footerText a:visited 

{ 

font-family: Tahoma; 

font-size: 11px; 

color: #000000; 

} 
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Modifying the Simulation Launch Window Text 
To modify the simulation launch window text, perform these steps: 

1. Open your template and navigate to General tab>Data Files>simulation_index.htm. 
2. Click Modify. The file opens in an editor such as Notepad. 
3. Use the illustration below to locate the area within the launch window HTML code that 

you would like to modify. The data files use hexadecimal strings to specify color in 
HTML files. For example, the hex value for white is #FFFFFF and for black is 
#000000. 

4. Close the HTML editor and select Yes when prompted to update the file.  
 

 

 

 

 

 

<div style="height: 47px; position: relative; vertical-align: 
bottom; overflow: hidden; text-overflow: ellipsis; font-
weight: bold; font-size: 14pt; color: #FFFFFF; font-family: 
Tahoma, Verdana, Arial, Helvetica; "> 
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a:link, a:active, 
a:visited 

{ 

font-family: 
Tahoma, Verdana, 
Arial, Helvetica; 

font-size: 12px; 

color: #FFFFFF; 

font-weight: bold; 

text-decoration: 
none; 

} 

a:hover 

{ 

 

 

 

 

.infoboxText 

{ 

font-family: 
Tahoma; 

font-size: 12px; 

color: #000000; 

} 
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.footerText, 

.footerText 
a:link, 

.footerText 
a:active, 

.footerText 
a:visited 

{ 

font-family: 
Tahoma; 

font-size: 11px; 

color: #000000; 

} 

 

 

Publishing the Course and Verifying the Changes 
If you have existing content, the final step is to publish your new content so all template 
changes are incorporated. You also need to re-link recordings.  

Note: Previewing content does not display all the template customizations; you should publish 
the content to ensure that you review all updates.  
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Customizing the HP ART Website 
You can easily update several areas in the HP ART website to give it a customized look. 

Adding Your Logo to the Website 
A company logo image is typically displayed in the upper left corner of the website and 
appears on all the launch pages. 

 

You can update the website with your company’s logo to enhance your website. To modify 
the website logo, perform these steps: 

1. Open your template and navigate to General tab>Data Files>hpa_logo-bg.png 
>Update. 

 

2. Navigate to the location of the company logo on your local or share drive and select 
the image. The recommended logo size is 220x74 pixels. 
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3. Save your template and republish the .uws file to view the updated website logo. 

 

Updating the HP ART Website Tagline 
The HP ART tagline is an image and displays in the upper right of the website. It appears on 
all launch pages.   

 

To modify the website tagline, perform these steps: 

1. Open your template and navigate to General tab>Data Files>hpa_tagline-bg.png.  
2. Click Update. 
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3. Navigate to the location of the desired tagline on your local or share drive and select 
the image. The recommended image size is 220x74 pixels. 

4. Save your template and republish the .uws file to view the updated website tagline. 

Modifying the Website Launch Module Button Color 
The Launch Module button displays on all module pages and is used to launch the associated 
HP ART course module. 

 

To modify the color of the Launch button, perform these steps:  

1. Open your template and navigate to General tab>Data Files>hpa_screen.css. 
2. Click Modify. 
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3. The .css file opens in Notepad. You can use the Edit>Find feature to locate the code to 
update. To change the color of the Launch button, look for the string highlighted 
below: 

 

In this example, the background color has been changed to black (#000000). 
 

4. To change the hover color of the Launch button, look for the string highlighted below: 

 

In this example, the color has been changed to red (#ff0000). 

5. Save the .css file and republish the .uws file to view the updated Module Launch 
buttons. 
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Modifying the Website Text Font and Color 
The font customizations for the website are also controlled in the hpa_screen.css file. To 
customize this file, ensure you are experienced in HTML/XML. 

To modify the website header color and text font, perform these steps: 

1. Open your template and navigate to General tab>Data Files> hpa_screen.css. 
2. Click Modify. 
3. To modify the header colors locate and update the H1, H2, and H3 tag to the desired 

hexadecimal color. You can use the Edit>Find feature to locate the code to update. 

 

In this example, the color has been changed to red (#ff0000). 
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4. Use the H1, H2, and H3 font tags to adjust the style as desired. 
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