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Welcome to HP Service Virtualization
Welcome to Service Virtualization, HP's tool for simulating services during testing.
HP Service Virtualization software allows developers and testers access to limited or unavailable
services in a simulated environment. This helps application teams lower costs and reduce testing
times by finding defects earlier in the application life cycle when they are easier, faster, and less
expensive to fix. It helps improve quality by enabling quality assurance (QA) teams to test what
otherwise could not be tested. It also helps isolate problems that are based on dependencies
between services in composite applications. This helps significantly reduce delays and manage the
costs and complexity of composite application development and testing.
This section includes:
Service Virtualization Documentation

11

How This Guide is Organized

11

Topic Types

12
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Service Virtualization Documentation
Service Virtualization includes the following documentation:
Name

Description

HP Service Virtualization Online
Help

Available from the Service Virtualization user interface by
clicking in the window and pressing F1 or clicking the Help
button.

Printer Friendly Documentation

Online books can be viewed and printed using Adobe
Reader, which can be downloaded from the Adobe Web
site. To access, click www.adobe.com.

HP Service Virtualization User
Guide

Service Virtualization Help in PDF format. Accessed from
the Start menu:
All Programs > HP Service Virtualization >
<Designer/Server> 3.10 > Documentation > User
Guide

HP Service Virtualization
Installation Guide

Accessed from the Start menu:

HP Service Virtualization Open
Source and Third-Party Software
License Agreements

Accessed from the Start menu:

HP Service Virtualization
Management Help

Available from the Service Virtualization Management
interface by clicking Settings > Help Center.

All Programs > HP Service Virtualization >
<Designer/Server> 3.10 > Documentation >
Installation Guide

All Programs > HP Service Virtualization >
<Designer/Server> 3.10 > Documentation > Legal
Guide

How This Guide is Organized
This guide contains the following chapters:
Name

Description

Chapter 1 "Service Virtualization at a
Glance" on page 20

Start working in Service Virtualization.

Chapter 2 "Service Virtualization
Agents" on page 46

Install and work with Service Virtualization agents.

Chapter 3 "Virtual Services" on page
85

Create and configure virtual services.
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Name

Description

Chapter 4 "Simulation" on page 122

Run and monitor simulations using virtual services.

Chapter 5 "Service Virtualization
Management" on page 132

Use the Service Virtualization Management interface
to view and control services on different servers.

Chapter 6 "Command Line Virtual
Service Management" on page 136

Manage virtual services deployed on a Service
Virtualization Server using the SVConfigurator
command line tool.

Chapter 7 "Simulation Modeling" on
page 146

Use data and performance simulation models to
modify virtual service behavior.

Chapter 8 "Composite Application
Topology" on page 241

Use the topology interface to model composite
applications.

Chapter 9 "Security" on page 253

Define security settings.

Chapter 10 "HP Test Automation
Tools Integration" on page 269

Integrate with Unified Functional Testing, Service
Test, LoadRunner, and Performance Center.

Chapter 11 "HP Application Lifecycle
Management (ALM) Integration" on
page 274

Integrate with HP ALM.

Chapter 12 "Version Control Support"
on page 281

Work with virtualization projects stored in an SVN
repository.

Chapter 13 "Troubleshooting" on page
284

Review suggestions for dealing with some issues that
may arise.

Chapter 14 "Service Virtualization
Labs" on page 292

Try out new, experimental features.

Topic Types
The content in the documentation is organized by topics. Three main topic types are in use:
Concepts, Tasks, and Reference.
Topic Type

Description

Usage

Concepts

Background, descriptive, or conceptual
information.

Learn general information
about what a feature does.
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Topic Type

Description

Usage

Tasks

Instructional Tasks. Step-by-step
guidance to help you work with the
application and accomplish your goals.

l

Learn about the overall
workflow of a task.

l

Follow the steps listed in a
numbered task to complete
a task.

l

Perform independent
operations by completing
steps in a non-numbered
task.

Task steps can be with or without
numbering:
l

Numbered steps. Tasks that are
performed by following each step in
consecutive order.

l

Non-numbered steps. A list of selfcontained operations that you can
perform in any order.

Use-case Scenario Tasks. Examples of
how to perform a task for a specific
situation.
Reference

Learn how a task could be
performed in a realistic
scenario.

General Reference. Detailed lists and
Look up a specific piece of
explanations of reference-oriented material. reference information relevant
to a particular context.
User Interface Reference. Specialized
reference topics that describe a particular
user interface in detail. Selecting Help on
this page from the Help menu in the product
generally opens the user interface topics.

Troubleshooting Troubleshooting and Limitations.
and Limitations Specialized reference topics that describe
commonly encountered problems and their
solutions, and list limitations of a feature or
product area.

HP Service Virtualization (3.10)

Look up specific information
about what to enter or how to
use one or more specific user
interface elements, such as a
window, dialog box, or wizard.
Increase your awareness of
important issues before
working with a feature, or if
you encounter usability
problems in the software.
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What's New in Service Virtualization
This What's New provides an overview of the features that were introduced or enhanced in HP
Service Virtualization.
This section includes:
l

"What's New in Service Virtualization 3.10" below

l

"What's New in Service Virtualization 3.01" on page 16

l

"What's New in Service Virtualization 3.00" on page 17

What's New in Service Virtualization 3.10
HP Service Virtualization 3.10 introduces:

New Virtualization Capabilities
l

Oracle® Advanced Queuing. Virtualize communication between applications that are using
Oracle Advanced Queuing, a message-oriented middleware technology developed by Oracle
Corporation and integrated into its Oracle database. For details on configuring the Service
Virtualization Oracle AQ agent, see "How to Configure the Oracle AQ Agent" on page 55.

l

IBM WebSphere® MQ queue browsing. Search, browse, and quickly virtualize IBM MQ
queues using a direct Service Virtualization connection to IBM MQ from the Designer. For
details, see "Create New Virtual Service Wizard" on page 98.

Enhanced Service Virtualization Management Web Interface
l

Enhanced web-based management user interface. The improved user interface is accessed
over standard web browsers, and enables you to view and manage deployed environments,
without requiring access to the Service Virtualization design environment.

l

More robust architecture and ease of use. Easily search, filter, group, and navigate through
numerous virtual service environments and projects. Open and control virtual services in a
separate window for continuous visibility of usage, and for control of deployed virtual services.

l

Simultaneous management of multiple Service Virtualization servers. View and manage
multiple servers from the Service Virtualization Management interface.

Access Control Improvements
l

Advanced granularity in defining user access to virtual service management. Access to
specific virtual service management functions are based on user roles and defined privileges.
Using the Service Virtualization Management interface, you can grant or deny access to various
virtual service levels and enable administrators and users to control configuration and state of
their virtual testing environments.
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User management can be integrated with traditional enterprise identity management systems,
such as Microsoft Active Directory or LDAP through Microsoft Windows configuration. This
enables administrators to use the same tools for user and group management as they use for
other enterprise systems.
For details on the Service Virtualization Management interface, see "Service Virtualization
Management" on page 132.

Virtual Service Management Automation
l

Manage virtual services deployed on a Service Virtualization Server using the SVConfigurator
command line tool. For details, see "Command Line Virtual Service Management" on page 136.

Simulation Modeling Enhancements
Improved manipulation of arrays in data models with more deterministic and transparent behavior.
l

More control over array item count. The new CopyArrayItemsCount and
SetArrayItemCount array functions give you full control over the number of items in an array,
even when the array is copied from another array. Previously, the array item count was based on
the source array, which created issues in several use cases.

l

Array item templating. Specify how to populate all array items from just one array row using
the ArrayTemplate function.

For details, see "Rule Functions" on page 150.

Service Virtualization Labs
Service Virtualization Labs is a test area for experimental features in Beta quality. Lab features
provide early access and enable you to provide feedback from direct usage. You can enable or
disable individual experimental features. Note that lab features may change, break, or disappear at
any time in future releases. For details, see "Service Virtualization Labs" on page 292.
Lab features in Service Virtualization 3.10 include:
l

Scripted rules.
Some more complex modeling use cases requiring manual definition are not easily achievable
with current capabilities.The new scripted rule type further assists you in defining functional
behavior.
n

Manipulate request and response messages using JavaScript.

n

Use variables, conditions, cycles, and other standard scripting features to define request
conditions and construct responses.

A scripted rule is evaluated the same way as already existing rule types so virtual service
designers can use it to manipulate just portions of messages and combine it with other rule
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types to fill remaining parts of the message. Designers can also leverage sharing of the
message context and variables among simulation rules, service operations, and instances of
services and calling sessions.
For details, see "Scripted Rules" on page 296.
l

Network modeling - integration with Shunra Network Virtualization™ (NV).
Simulate network environments. In addition to functional (data) and performance behavior
(scalability) of distributed services and systems, you can now define and control network
parameters to use in your simulations.
Leverage the vast catalog of performance metrics of networks and operators across the globe as
provided by the Shunra community.
For details, see "Network Virtualization Integration" on page 293.

License Management
HP Service Virtualization 3.10 is now distributed with HP Autopass 8.01, enabling concurrent
license enforcement on private networks.
By default, HP Service Virtualization installs with a 30-day trial Seat license for the Service
Virtualization Designer, and a 30-day trial Instance license for the Service Virtualization Server.

What's New in Service Virtualization 3.01
Administration Updates
l

Server backup and restore. Using Server Backup and Restore, it is now possible to upgrade
Service Virtualization Server to a new version, and have all previously deployed services
(starting with Service Virtualization 3.00) up and running after installation . This tool can be used
after upgrade to perform regular backups of the server.

l

Project migration. With the new Resource Manager command line tool, you can migrate
Service Virtualization projects stored in the file system or in HP ALM to the new Service
Virtualization version without the need to open each project in the Service Virtualization
Designer.

l

Automated service deployment. The Resource Manager can also be used to automate the
deployment of services stored in the file system or in HP ALM to a Service Virtualization Server.

For details, see the HP Service Virtualization Installation Guide.

Service Virtualization Management improvements
l

Problem notification. The detailed list of errors and warnings occurring when using a virtual
service is now displayed and managed in Service Virtualization Management web interface. The
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filtering and deletion of resolved items is supported.

Enhanced Protocol Support
l

REST over HTTP. The new support of REST over HTTP Gateway allows the virtualization of
REST services in an environment where it is not possible to change HTTP proxy settings. The
client can access the virtual service exposed on a new virtual endpoint.

l

XML over HTTP service call activity. A virtual service can invoke other services during
simulation using the XML Over HTTP service call activity, extending the current SOAP over
HTTP service call activity support. For details, see "How to Edit a Data Model" on page 157.

Improved Editing and Troubleshooting of Data Models
l

Row Detail. The Row Detail dialog box in the Data Model Editor now also displays and enables
you to edit simulation data of service call activities.

l

Column Highlighting. The Data Model Editor now color codes table headers according to
simulation function type -- condition/action/ignore. This helps you to troubleshoot a data model
by pointing out mistakenly assigned functions.

l

Import to Simulation Preview. You can now import a request message to Simulation Preview
when troubleshooting simulation, in order to check simulation results, or compare wire data with
simulation data.

l

Compare Rows. You can now also compare rows in the data model using Simulation Preview.
This helps you troubleshoot when trying to determine why a rule has not matched the request
data. Service Virtualization evaluates and highlights differences between the request imported
to or pinned to Simulation Preview, and the selected row in the Data Model Editor.

For details, see "Data Model Editor" on page 187.

What's New in Service Virtualization 3.00
Enhanced Protocol Support
SAP is the new family of protocols added to the continually growing Service Virtualization
supported protocol set. SAP protocol support enables the virtualization of your SAP® server that
communicates with 3rd party SAP servers using SAP RFC/IDOC.
For details, see "How to Configure the SAP RFC/IDOC Agent" on page 56.

Virtual Service Management
The new web-based Service Virtualization Management interface enables you to control virtual
services deployed on any Service Virtualization Server, right from you browser. Installation of the
Service Virtualization Designer is not required. You can manage existing services or deploy new
services from a project stored in either the file system, or in HP Application Lifecycle Management
(ALM).
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For details on Service Virtualization Management, see "Service Virtualization Management
Overview" on page 133.

Integration with HP Application Lifecycle Management
The integration of Service Virtualization with HP Application Lifecycle Management (ALM) enables
you to store and collaborate on projects in the ALM repository.
Leverage the ALM repository for project collaboration between integrated products. For example,
you can create a virtualization project in the Service Virtualization Designer, save it in ALM, and
open it in HP LoadRunner or HP UFT/Service Test.
Virtualization projects are stored as test resources in an ALM project. Both version control enabled
and non-version control enabled ALM projects are supported for this integration.
For details, see "HP Application Lifecycle Management (ALM) Integration" on page 274.

Simulation Modeling Enhancements
l

Data Masking. Protect your sensitive data with Data Masking. Configure part of a message to
be masked, using either the hash algorithm or by replacing part of the value. Sensitive data are
then never stored in Service Virtualization.

l

Sequential Number Generator. The Sequential Number Generator simulation function can
now be configured to produce zero or non-zero prefixed numbers with a nearly unlimited length.

l

Random Number Generator. Generates unique random values. Using this function’s
formatting capabilities, which are similar to the Sequential Number Generator, you can generate,
for example, different ID or key variations.

l

Substring function. The new Substring simulation function enables you to copy values
between parts of the message, similar to the Copy from function, with additional formatting
options for the substring.

l

Post-Response Service Call Activity. Enables you to issue a SOAP call during simulation,
after the response is returned. This supports numerous integration scenarios, in which the
service delivers the response outside the usual request-response channel by an active call of
the client's SOAP endpoint.

For details, see "Simulation Modeling" on page 146.

Security additions
A new WS-Security signature scheme without a timestamp has been added to the supported WSSecurity profiles.

Administration Updates
l

License Management. Each Service Virtualization Designer now requires a valid license.
Service Virtualization 3.00 integrates with the HP Autopass License Server, enabling you to
organize and manage your product licenses and client users. For details, see "Service
Virtualization Designer Licensing" on page 22.
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l

Server Access Control. Previously, server access was limited based on membership in the
Service Virtualization Users Windows user group. Service Virtualization 3.00 introduces 3 new
user groups, providing increased granularity of permissions, based on user roles. You can grant
or deny access to various levels of viewing and managing services and Service Virtualization
agents. For details, see the HP Service Virtualization Installation Guide.
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Service Virtualization Overview
HP Service Virtualization provides a framework for creating virtual services for use in testing your
applications under development.
You can create virtual services to simulate the behavior of services with limited access, such as
unavailable or expensive services. Service Virtualization places a virtual service between the client
application (application under test) and the real service to which you require access. Once you
create virtual services to simulate the real services that you require, you reconfigure your client
applications to use the virtual services, instead of the real services.
Service Virtualization also enables you to:
l

Design virtual services. Add data to your virtual service by importing messages, adding
external data sources, or by manually entering data.

l

Learn service behavior. Record real service behavior to assist you in creating a virtual service
to mimic the behavior of the real service.

l

Customize simulation models. You can create and manipulate data and performance models
for use in your virtual services.

l

Create visual models. Model composite applications by creating a visual map of the services
and the relationships between them.

l

Integrate. Integrate with HP test automation tools.

Service Virtualization Components
Service Virtualization consists of the following applications:
l

Designer. A client application enabling you to create virtual services, and run simulations of
real service behavior. The Service Virtualization Designer The Designer is used for design and
validation of virtual services within the same desktop environment, and includes an embedded
server for hosting virtual services.

l

Server. (Optional.) A standalone server application which hosts the running of virtual services.
The Service Virtualization Server is optimized for performance, can contain many more services
than the Designer, and can be accessed by multiple Designers.
For details on configuring the Service Virtualization Server, see the HP Service Virtualization
Installation Guide.
For details on working with the Service Virtualization Server, see "How to Manage Service
Virtualization Servers" on page 27.

l

Management Interface. (Optional.) A web application enabling you to view and manage all
services from Service Virtualization configured servers, without opening the Designer or
individual projects. The Service Virtualization Management is installed by default when you
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install the Service Virtualization Server.
For more details, see "Service Virtualization Management" on page 132.
For details on starting the Service Virtualization components, see "How to Start Service
Virtualization" on the next page.

Getting Started with Service Virtualization
Getting
started

When you start the Service Virtualization Designer, the application opens,
displaying the Start Page, with links to common procedures and sample
projects. For user interface details, see "Start Page" on page 30.
To get started working with Service Virtualization, see "How to Use Service
Virtualization" on page 25.

Main Service When you open a virtualization project, the main Service Virtualization window
Virtualization opens. For user interface details, see "Service Virtualization Main Window" on
view
page 34.
Main menus

For a description of the main menu options available in Service Virtualization,
see "Service Virtualization Main Menus" on page 35.

Service Virtualization Designer Licensing
The Service Virtualization Designer is installed with a 30-day trial license. To continue working with
the Designer, you must install a license from HP.
You can obtain HP licenses through the HP Software Licensing Portal.
To migrate a license after installing a new version of the Service Virtualization Designer, visit the
HP Software License Manager.
Note: After the evaluation period, the Designer will no longer work, but your data is preserved.
The following types of licenses are available:
l

Evaluation license. A 30-day trial license that may be provided by HP.

l

Seat license. For use for a single machine running the Service Virtualization Designer.

l

Concurrent license. Multiple users share a pool of licenses managed by HP Autopass License
Server.

l

Commuter license. A temporary license you obtain from the license server that enables the
Designer to work offline. You can then continue to work in the Designer when you have limited or
no access to the license server.
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Note:
l

Concurrent and commuter licenses require access to the HP Autopass License Server. For
details on installing the HP Autopass License Server, see the HP Service Virtualization
Installation Guide.

l

For details on installing a license, see "How to Install a Service Virtualization Designer
License" on page 27.

Password Encryption
You can encrypt sensitive data stored in Service Virtualization, such as passwords stored in agent
configuration files or in the Service Virtualization Credential Store.
Service Virtualization encrypts data using a password that you provide. You can enable password
encryption by defining an encryption password for the following application components:
l

Service Virtualization Server encryption. During server installation, you can select the server
encryption option, and define a password to use for encryption. The password is stored for the
Windows system account user, and used for all server encryption.

l

Designer/Embedded Server encryption. During Designer installation, or if you are running the
Designer for the first time, you can define a password for encrypting sensitive information stored
in the server. Each Windows user running the Designer can define an encryption password,
used to encrypt their own data and configuration information.

l

Project encryption. You can define a password for encrypting virtualization projects. When you
export a virtualization project and a .vproja project archive file is created, the project is
encrypted using the encryption password. For other users to open the exported project, you
must provide them with the encryption password.
For details on enabling project encryption, see "Projects and Solutions Page" on page 120.
For additional options for configuring password encryption in Service Virtualization, refer to the
HP Service Virtualization Installation Guide.

How to Start Service Virtualization
This section explains how to start the Service Virtualization applications. For more details on each
component, see "Service Virtualization Overview" on page 21.
Service
From the Windows Start menu, select All Programs > HP Service
Virtualization Virtualization > Designer 3.10 > HP Service Virtualization Designer.
Designer
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Service
Do one of the following:
Virtualization
l Start the Server as a Windows service: From the Windows Start menu,
Server
select All Programs > HP Service Virtualization > Server 3.10 > Server
- Start Service.
l

Start the Server as a standalone console application: From the Windows
Start menu, select All Programs > HP Service Virtualization > Server
3.10 > Service Virtualization Server

For details on working with the Service Virtualization Server, see "How to
Manage Service Virtualization Servers" on page 27.
Note: The Service Virtualization Server can be configured as either
secured or unsecured. To prevent unauthorized access, it may be
configured as secured. For additional details and configuration information
on the Service Virtualization Server, see the HP Service Virtualization
Server section of the HP Service Virtualization Installation Guide.
For details on accessing a secured Service Virtualization Server, see "How
to Access a Secured Service Virtualization Server" on page 28.
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Service
To start the Service Virtualization Management service:
Virtualization
1. Prerequisite: Make sure that the Service Virtualization Server is running.
Management
2. On the Service Virtualization Server machine, from the Windows Start
menu, select All Programs > HP Service Virtualization > Server 3.10 >
Management Interface - Start Service.
To access the Service Virtualization Management interface:
Open a browser window and enter one of the following URLs:
l

The Service Virtualization Management URL:
https://<Service Virtualization Server IP or hostname>:<Service
Virtualization Management port>
By default, the Service Virtualization Management port is 6086.

l

The Service Virtualization Server URL:
<Service Virtualization Server IP or hostname>:<HTTP/HTTPS port
number>/management

For more details on Service Virtualization network ports, see the HP Service
Virtualization Installation Guide.
For more details on Service Virtualization Management, see "Service
Virtualization Management Overview" on page 133.

How to Use Service Virtualization
This task describes the overall Service Virtualization workflow.
1.

Start the Service Virtualization components
Service Virtualization includes a Designer with an embedded server, an optional standalone
server, and a management interface.
For details on these components, see "Service Virtualization Overview" on page 21.
For details on starting the components, see "How to Start Service Virtualization" on page 23.

2.

Install a Service Virtualization Designer license
The Designer is installed with a 30-day evaluation license. To continue working with the
Designer, you must obtain and install a valid license from HP.
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For details on installing the Designer license, see "How to Install a Service Virtualization
Designer License" on the next page.
3.

Configure Service Virtualization agents
Configure the protocol-specific agents that handle communication between clients and real or
virtual services. For task details, see "How to Configure Agents" on page 47.

4.

Optional: Model composite applications
Create a visual map of the services in your composite applications, and the relationships
between them. Group services into larger composites, mark service types, and display the
service calls between them. For task details, see "How to Model Composite Applications" on
page 242.

5.

Create virtual services
Create virtual services to simulate real services with limited access or that are unavailable. For
task details, see "How to Create a Virtual Service" on page 92.

6.

Configure virtual services
Set up your virtual services to create a simulation for your testing purposes. Configure
security, logging, protocol, and server settings to meet your needs. For task details, see "How
to Configure Virtual Services" on page 93.

7.

Configure clients
Reconfigure your client applications to use the virtual services instead of the real services.
Service Virtualization enables you to manipulate virtual services to get different results.

8.

Learn service behavior
Record the behavior of the real service in order to learn its requests and responses. For task
details, see "How to Run Simulations" on page 123.

9.

Run simulations
Use virtual services to simulate real services during your testing process. For task details, see
"How to Run Simulations" on page 123.

10.

Review and monitor services
Monitor services during learning and simulation sessions. For details, see "How to Run
Simulations" on page 123.

11.

Design and configure simulation models
Create and customize data and performance models to meet your needs. Learn real service
behavior, create customized rules for virtual service behavior, add service calls, and add
external data sources. For task details, see "How to Manage Simulation Models" on page 156.
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12.

Optional: Integrate with HP Test Automation tools
Integrate Service Virtualization with HP test automation tools. For details, see "HP Test
Automation Tools Integration" on page 269.

13.

Manage virtual services
Deploy, undeploy, unlock, view, or change the runtime mode of virtual services on any Service
Virtualization Server.
For details, see:
n

"How to Get Started Using Service Virtualization Management" on page 133

n

"How to Manage Virtual Services from the Command Line" on page 137

How to Install a Service Virtualization Designer
License
This task describes how to install a license for the Service Virtualization Designer.
To learn more, see "Service Virtualization Designer Licensing" on page 22.
1. From the Help menu, select License Management.
2. Select a license type. For user interface details, see "Select License Type Page" on page 38.
3. Install the license. For user interface details, see "License Installation Wizard - Installation
Pages" on page 41.

How to Manage Service Virtualization Servers
This task describes how to use Service Virtualization Servers for your virtual services.
For details on starting a Service Virtualization Server, see "How to Start Service Virtualization"
on page 23.

View, add, or delete Servers
The Servers page displays all configured Service Virtualization Servers.
From the main menu, select Tools > Options. Click the Servers tab.
When you add a Server, it is added to the list of available Servers, enabling you to select this Server
when you create a new Service Virtualization project.

View Server status
The Servers page displays status information for each Service Virtualization Server.
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From the main menu, select Tools > Options. Click the Servers tab.

Change Servers
Move the virtual services in the open project to a different server.
From the main menu, select Project > Change Server.

Connect to a Server with a different user
If you are working with a secured Service Virtualization Server, your access may be limited based
on permissions assigned to your user. For details, see the "How to Access a Secured Service
Virtualization Server" below.
To connect to a server with a different user, from the main menu, select Tools > Options, and click
the Servers tab. Right-click a server and select Connect using different credentials.
For details on server authentication and user access permissions, see the HP Service
Virtualization Installation Guide.

How to Access a Secured Service Virtualization
Server
When the HP Service Virtualization Designer contacts a secured Service Virtualization Server for
the first time, it requests user input in order to establish a secured communication channel.
You can determine whether the Service Virtualization Server is secured based on its URL. The
URL of an unsecured server begins with http, whereas the URL of the secured server begins with
https. For example, the URL of a secured server might be
https://mymachine.com:6085/management. In addition, the port of the secured server is different
from that of the unsecured server.
Note:
l

When you are working with a secured Service Virtualization Server, the actions available to
you and the information displayed in the Service Virtualization Designer vary, based on your
user access permissions. For example, a user who is not assigned to any of the Service
Virtualization user groups cannot view any agent data or any services deployed on the
server.
For details on the Service Virtualization user groups, see the HP Service Virtualization
Installation Guide.

l

You can reconnect to a server with a different user. From the main menu, select Tools >
Options, and click the Servers tab. Right-click a server and select Connect using
different credentials.

To access a secured Service Virtualization Server:
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1. When the HP Service Virtualization Designer contacts a secured Service Virtualization server
for the first time, the following dialog box opens:

Select Trust the certificate permanently to prevent the Designer from prompting you again.
2. Click Yes to accept the certificate. The following dialog box opens:

Enter credentials to connect to the Service Virtualization Server. For details on credential
validation and user authentication, see the HP Service Virtualization Installation Guide.

Service Virtualization User Interface
This section includes:
Start Page

30

Service Virtualization Main Window

34

Service Virtualization Main Menus

35

License Installation Wizard

38
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Start Page
This page includes links to your most recently opened projects, links to common procedures, and a
tab for the installed sample projects.

To access

When you open Service Virtualization, the Start Page opens by default.
To open the page manually, from the View menu, select Start Page.

Relevant tasks "How to Create a Virtual Service" on page 92
See also

l

"Service Virtualization Overview" on page 21

l

"Service Virtualization Main Window" on page 34

l

"Service Virtualization Main Menus" on page 35

General
UI Element

Description

Recent Projects

Displays links to the most recently opened projects.

Get Started page

Displays links to common procedures. For details, see Get Started Page
below.

Sample Projects
page

Displays links to the demo projects, installed with Service Virtualization.
For details, see Sample Projects Page below.
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UI Element

Description

Close page after
project load

Closes the Start Page when you open a project.

Show page on
startup

Displays the Start Page each time you start Service Virtualization.

Get Started Page
This page provides links to several common procedures you perform in Service Virtualization.
UI Element

Description

Learn Existing
Service

Enables you to virtualize an existing service and learn its behavior.
Creates new virtualization project and a virtual service, and then places the
new service in Learning mode.
For user interface details, see "Virtual Service Editor" on page 113.

Design Virtual
Service

Enables you to design a virtual service and define its behavior.
Creates new virtualization project and a virtual service, and opens the Data
Model Editor.
For user interface details, see "Data Model Editor" on page 187.

Discover
Services

Enables you to discover services suitable for virtualization in your
application under test.
Creates a new virtualization project, and opens the Service Discovery dialog
box, enabling you to find all services used by an application.
For user interface details, see "Service Discovery Dialog Box" on page 251.

Data Driven
Simulation

Enables you to virtualize a service and define its behavior using data from an
external source.
Creates a new virtualization project and a virtual service with an external
data rule, and then opens the Data Model Editor.
For user interface details, see "Data Model Editor" on page 187.

Composite
Application
Testing

Enables you to describe the topology of a composite application, and
virtualize services with limited access.
Creates a new virtualization project and a topology, and opens the Topology
editor.
For user interface details, see "Topology Editor" on page 246.

Service
Administration

Enables you to view all services from configured servers, without opening
individual projects.
For user interface details, see "Service Administration" on page 129.
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Sample Projects Page
Service Virtualization application demos are installed as an option during the Service Virtualization
Designer installation process. Each sample project has an accompanying Readme file in PDF
format, which provides additional information on working with the sample project. The sample
project folders are located, by default, in <Your Documents folder>\HP Service
Virtualization\Demos.
The following demos are included:
UI Element

Description

Claim
Processing
JDBC Demo

This demo shows a composite application consisting of JDBC services.

Claim
Processing
Demo

This demo shows the simulation of a backend SOAP service with limited
accessibility in a simple composite application. The service can optionally use
HTTP authentication (see demo readme).

Claim
Processing
REST Demo

This demo shows a composite application consisting of 2 REST services using
JSON and XML data formats.

Claim
Processing
Faults Demo

The simulation of a backend SOAP service with limited accessibility in a
simple composite application. The simulated service returns either regular
response or one of 3 different SOAP faults.

Claim
Processing
Security
Demo

This demo shows a composite application consisting of 2 SOAP services. It
allows demonstrating how to record and simulate the behavior of one of the
SOAP services. Both services authenticate each other using X509 certificates.

Claim
Processing
Standalone
Server Demo

This demo shows a composite application consisting of 2 SOAP services. It
allows demonstrating how to record and simulate the behavior of one of the
SOAP services on a standalone server.

Claim
Approval
JMS Demo

This demo shows a composite application consisting of 3 SOAP services. It
allows demonstrating how to record and simulate the behavior of two SOAP
services. Demo is similar to the Claim processing service simulation demo.
One XML over JMS service (TIBCO EMS approval service) has been added to
the topology here and is being simulated, too.

Claim
Approval
WebSphere
MQ Demo

This demo shows a composite application consisting of 3 SOAP services. It
allows demonstrating how to record and simulate the behavior of two SOAP
services. The demo is similar to the Claim Processing service virtualization
demo. One XML over WebSphere MQ service (WebSphere MQ approval
service) has been added to the topology here, and is being simulated, too.
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UI Element

Description

IBM IMS
Transaction
Manager
Phonebook
Demo

This demo shows virtualization of the Phonebook IMS Transaction Manager
application. The client is using IBM IMS Connect API to communicate with
IMS TM over TCP/IP.

Request
Tracking
Service
Activity
Demo

This demo shows a composite application consisting of 4 SOAP services. It
allows demonstrating how to record and simulate the behavior of two SOAP
services. In addition, activity can be demonstrated by calling the third SOAP
service from a simulated service.

SAP Invoice
Transaction
Service
Simulation
Demo

This demo shows a SAP to SAP transaction that is posting a new invoice from
system A to system B. The demo demonstrates how to learn and simulate the
data and performance of SAP application server services exposed via
SAP RFC.

ShoppingCart This demo shows virtualization of stateful shopping cart service, where only
- No Sessions one client is using the stateful service.
Demo
ShoppingCart This demo shows virtualization of stateful shopping cart service, where
- Sessions by multiple concurrent clients are using the stateful service and private session is
Clients Demo generated for each client.
ShoppingCart This demo shows virtualization of stateful shopping cart service, where
- Sessions by multiple concurrent clients are using the stateful service and sessions are
Orders Demo generated per each shopping order. The checkout operation finishing shopping
order destroys the client session (the next operation creates a new one).
Test Data
This demo shows the virtualization of a backend SOAP service with simulation
Management - data imported from an external data file.
Import Data
Demo
Test Data
This demo shows the virtualization of a backend SOAP service with the export
Management - of learned data to an external data file.
Export Data
Demo
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Service Virtualization Main Window

To access

Use one of the following:
l

From the File menu, select Open Project/Solution.

l

From the Start Page, under Recent Projects, select a project to open.

Important
information

To display panes that are not displayed by default, click the View menu
and select a pane.

Relevant tasks

"How to Use Service Virtualization" on page 25

See also

l

"Service Virtualization Overview" on page 21

l

"Service Virtualization Main Menus" on the next page

The Service Virtualization Designer window contains the following key elements (unlabeled
elements are shown in angle brackets):
UI Element

Description

<main
display
pane>

Displays all open virtualization entities.

<lower
pane>

Displays the Problem List or the Runtime View. For details, see "Problem List"
on page 128 and "Runtime View" on page 127.

<side bar>

Displays links to Virtualization Explorer, Project pane, and Tools pane, when
they are pinned.
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UI Element

Description

<main
menus and
buttons>

For command and button descriptions, see "Service Virtualization Main Menus"
below.

Virtualization Located in the left pane of the window, displays the virtualization entities in your
Explorer
open project in a hierarchical tree structure. For details, see "Virtualization
Explorer" on page 111.
Project pane

Located in the left pane of the window, displays the list of files included in your
open project.
To rename a project, right-click the project name and select Rename Project.

Tools pane

Located in the left pane of the window, displays items that you can add to your
topology. For details, see "Topology Editor" on page 246.
Also used when editing an XML schema. For details, see "Service Description
Editor" on page 224.

Runtime
View

Located in the lower pane of the window, displays the virtual services included
in your open project. For details, see "Runtime View" on page 127.

Problem List

Located in the lower pane of the window, displays problems that occur during
the application or server run. For details, see "Problem List" on page 128.

Service Virtualization Main Menus
This section describes the main menu options available in Service Virtualization.
To access

The main menu is available from all Service Virtualization views.

Relevant tasks "How to Use Service Virtualization" on page 25
See also

l

"Service Virtualization Overview" on page 21

l

"Service Virtualization Main Window" on the previous page

User interface elements are described below.
UI Element

Description

File > Checkout

Enables you to check out a project or solution from SVN. For details, see
"Version Control Support" on page 281.

File > Close
File

Closes the currently active project window.

File > Close
Closes the open project.
Project/Solution
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UI Element

Description

File > Export
Project

Enables you to save your project as a file in the file system. The file is saved
with the default file extension .vproja.

File > New
> Topology

Opens the Summary of New Topology dialog box, enabling you to create a
new topology. For details, see "Summary of New Topology Dialog Box" on
page 246.
Note: Available in an open project.

File > New
> Virtual
Service

Launches the new virtual service wizard. For details, see "Create New
Virtual Service Wizard" on page 98.
Note: Available in an open project.

File > New
> Virtual
Service from
Template

Opens the Choose Template for Virtual Service dialog box, enabling you to
create a new virtual service based on an existing template. For details, see
"How to Create a Virtual Service" on page 92.
Note: Available in an open project.

File > New
> Virtualization
Project

Enables you to create a new virtualization project. For details, see
"Summary of Virtualization Project Dialog Box" on page 97.

File > Open
Opens your file system browser, enabling you to select a virtualization
Project/Solution project to open.

File > Recent
Projects

Displays list of recently opened projects, enabling you to select a project to
open.
Select Clear recent project list to delete the list.

File > Reload
File

Not in use.

File > Reload
Solution

Reloads solution from file system.

File > Save

Saves changes made in the editor window in which you are currently
working.

File > Save All

Saves changes made in all open editor windows.
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UI Element

Description

File > Save
Project As

Makes a copy of the open project, and saves it with a new name.

View > Problem
List

Displays the Problem List in the bottom pane of the Service Virtualization
window. For details, see "Problem List" on page 128.

View > Projects

Opens the Projects pane, displaying the files included in the open project.

View > Runtime
View

Displays the Runtime View in the bottom pane of the Service Virtualization
window. For details, see "Runtime View" on page 127.

View > Service
Administration

Displays the Service Administration window. For details, see "Service
Administration" on page 129.

View > Start
Page

Opens the Service Virtualization Start Page. For details, see "Start Page" on
page 30.

View > Task
List

Opens the Task List pane. For details, see "Topology Editor" on page 246.

View > Tools

Opens the Tools pane, displaying a toolbox of items for the Topology editor,
and also for the XML and XML schema editor.

View > Tools
> Files

Opens the Files pane, displaying your local file system in a browser.

View > Tools
> Search
Results

Not in use.

View > Tools
> XPath Query

Not in use.

Project > Open
Folder in
Explorer

Opens the open project's folder in your file system browser, displaying the
files included in the project.

Project >
Change Server

Opens the Change Server for <open project> Project dialog box, enabling
you to redeploy virtual services in the current project to another server.

Tools > Clear
Project Cache

Clears project cache and reloads the project. If an error occurs, for example,
if you are unable to open one of the Service Virtualization editors, it is
recommended to try using this option.

Tools > Options

Opens the Options dialog box.
l

To configure Service Virtualization agents, click the Agents tab.

l

To view, add, or delete servers, click the Servers tab.

HP Service Virtualization (3.10)

Page 37 of 299

User Guide
Chapter 1: Service Virtualization at a Glance

UI Element

Description

Tools > Refresh
Sample
Projects

Opens the Refresh Sample Project dialog box, enabling you to delete the
current contents of the sample project folder and reload new copies of the
sample virtualization projects.
Note: When you refresh the sample project folder, all custom changes made
in this folder are lost.

ALM > ALM
Connection

Enables you to define settings for connecting to HP Application Lifecycle
Management (ALM). For details on integrating with HP ALM, see
"HP Application Lifecycle Management (ALM) Integration" on page 274.

ALM > Check
Out

Opens the Check Out dialog box, enabling you to check out a virtualization
project that is stored in an ALM version controlled project.

ALM > Undo
Check Out

Discards any changes you made in the checked out project, and opens the
last checked in version in read-only mode.

ALM > Check In

Opens the Check In dialog box, enabling you to check in your changes to
ALM.

ALM > Version
History

Displays details of all versions of the open project.

Window >
Close All
Documents

Closes all open project windows.

Window > Next
Window

Moves to the next open window in your project.

Window >
Previous
Window

Moves to the previous open window in your project.

License Installation Wizard
This section includes:
Select License Type Page

38

License Installation Wizard - Installation Pages

41

Select License Type Page
This wizard page enables you to:
l

select a Service Virtualization Designer license to install

l

view currently installed licenses
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To access

From the Help menu, select License Management.

Wizard map

Select License Type Page > "License Installation Wizard - Installation
Pages" on page 41

Important
information

If you do not yet have a license, the wizard guides you how to obtain one.

Relevant tasks

"How to Install a Service Virtualization Designer License" on page 27

See also

"Service Virtualization Designer Licensing" on page 22

This section includes:
l

"License Types" below

l

"Currently Installed Licenses " on the next page

User interface elements are described below:

License Types
UI Element

Description

Evaluation
License

Use a 30-day trial license that may have been provided to you by HP.
Displays remaining days until license expiration.

Concurrent Obtain a license from the HP Autopass License Server.
License
Multiple users share a pool of licenses stored on a license server. The license is
linked to the machine's IP address.

HP Service Virtualization (3.10)

Page 39 of 299

User Guide
Chapter 1: Service Virtualization at a Glance

UI Element

Description

Seat
License

Obtain and install a permanent license for your Designer machine.
For use for a single machine running the Service Virtualization Designer.
The license is linked to the machine's Host ID, a unique number generated by
Service Virtualization, and bound to the machine's hardware.

Commuter
License

A temporary license provided by the License Server that enables the Designer to
work offline.
Request a commuter license when you will have limited or no access to the
license server, and cannot check out a license. A commuter license is valid for 14
days.

Currently Installed Licenses
UI Element Description
Status

l

l

l

Invalid. The license has expired, or the license and host IDs do not
match.
To be expired. The license will expire on the expiration date listed.
Valid. The license is active.

Locked

The license is linked to a specific client (Designer) machine.

Type

Instant On. The temporary license that is installed when you install the
Service Virtualization Designer.
Evaluation. A 30-day trial license is installed.
Floating. A concurrent license is installed.
Permanent. A seat license is installed.
Commuter. A commuter license is installed.

Expiration
Date

Displays the date on which the license will expire.
Note: When a floating license expires, it is automatically renewed if you
are still working in the Designer.

Capacity

Quantity of available licenses.
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License Installation Wizard - Installation Pages
These wizard pages enable you to:
l

request a floating or commuter license from the license server

l

request a new seat license from HP

l

install a license

l

return a commuter license to the license server

Important
information

l

See the relevant section below for the type of license you want to install.

l

Concurrent and commuter licenses require access to the HP Autopass
License Server. For details on installing the HP Autopass License Server, see
the HP Service Virtualization Installation Guide.

Wizard
map

"Select License Type Page" on page 38 > License Installation Wizard Installation Page

Relevant
tasks

"How to Install a Service Virtualization Designer License" on page 27

See also

"Service Virtualization Designer Licensing" on page 22

This section includes:
l

"Concurrent License Installation" on the next page

l

"Seat License Installation" on page 43

l

"Commuter License Installation" on page 44

User interface elements are described below:
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Concurrent License Installation

The concurrent license page includes the following options:
UI
Element Description
Host

The host name or IP address of the HP Autopass License Server.

Port

The communications port of the license server.
Default value: 5814

Change
Server

Enter the host and port details of a different server, and click Change Server to
connect to the new server.

Get
Retrieves a license from the license server. Concurrent licenses are valid for a period
Floating of 15 minutes, after which they are automatically renewed.
License
If you are using a concurrent license model and have access to a license server, a
license is automatically checked out each time you open the Designer. When you
close the Designer, the concurrent license is returned to the license server.
Return
If you no longer need the license, you can return it to the license server.
Floating
Alternatively, closing the Designer returns the license to the server.
License
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Seat License Installation

The seat license page includes the following options:
UI Element

Description

Obtain a new Seat
license

Click the HP Licensing for Software link to connect to HP, and sign in
to request a license.

Host ID

Record this detail. It is required when you submit a request for a new
seat license.
Click Copy to Clipboard to copy the Host ID.

Install your Seat
license

Select an installation option. Browse to select a license file, or enter a
license key.

Next

Opens the License File Content page. Select a license to install.
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Commuter License Installation

The commuter license page includes the following options:
UI Element

Description

Host

The host name or IP address of the HP Autopass License Server.

Port

The communications port of the license server.

Change
Server

Enter the host and port details of a different server, and click Change Server
to connect to the new server.

Online Operations: (For use when you have access to the license server)
Get
Commuter
License

Request a license from the license server that you can use offline for a specific
number of days.

Recover
Commuter
License

Download a new copy of your commuter license if the license was lost.

Return
Commuter
License

Returns the commuter license to the license server when you no longer need it.

Offline Operations: (For use when you cannot access the license server.)
Create a File
to Get
Commuter
License

Generates a license input file used for requesting a new commuter license.
You can send the file to a user with access to the license server. A license
server user can then check out a license, and send it back to you.
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UI Element

Description

Install
Commuter
License

Installs the license from the license file.

Create a File
to Return
Commuter
License

Generates a license file that contains the license information, in order to return
a commuter license to the license server. You can then send the file to a user
with access to the license server.
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47
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47

Agents User Interface

64
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Service Virtualization Agents Overview
This chapter provides instructions on configuring Service Virtualization Agents. Agents handle
communication between a client and a real or virtual service. Each agent handles communication
specific to the transport and message protocols you are using. You must configure the Service
Virtualization agent for each protocol your services are using.
The Service Virtualization agents must be configured on each server (embedded or standalone) on
which the services are deployed. You can add multiple instances of an agent to the same server,
configuring each one differently.
Note: Not all agents are installed by default. For details on installing an agent manually, see
the relevant help section on the agent you require.
For task details on configuring the Service Virtualization agents, see "How to Configure Agents"
below.

How to Configure Agents
This task describes how to configure Service Virtualization agents. There are several preconfigured agent instances with default configurations. You can use these instances, modify them,
or define new instances.

l

This task is part of a higher-level task. For details, see "How to Use Service Virtualization"
on page 25.

l

To learn more about Service Virtualization Agents, see "Service Virtualization Agents
Overview" above.

To configure an agent:
1. From the main menu, select Tools > Options and click the Agents page.
2. In the left pane, expand the server to display the available agents and configurations.
3. Select the agent you want to configure, and fill in the properties.
4. To add another configuration of an agent, click Add. The new configuration is added and you
can modify its settings.
For user interface details, see "Agents Page" on page 65.
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This section also includes:
How to Configure the HTTP/HTTPS Gateway Agents

49

How to Configure the HTTP(S) Proxy Agent

50

How to Configure the JDBC Agent

51

How to Configure the JMS Generic Agent

52

How to Configure the Oracle AQ Agent

55

How to Configure the SAP RFC/IDOC Agent

56

How to Configure the IBM IMS TM Agent

58

How to Configure the WebSphere MQ Agent

59

How to Configure the TIBCO EMS Non Intrusive Agent

61

How to Forward HTTP Agent Communication Through an HTTP Proxy

62

How to Configure Windows Firewall and HTTP Settings

63
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How to Configure the HTTP/HTTPS Gateway Agents
This task describes how to configure the Service Virtualization HTTP/HTTPS gateway agents.
The HTTP/HTTPS Gateway Agents serve to virtualize HTTP communication. A virtual HTTP
endpoint is created to mediate between a client and a real service HTTP endpoint. During the
learning process, real communication is forwarded to a real service HTTP endpoint and the
communication is recorded.

1.

Configure the agent settings
From the main menu, select Tools > Options. On the Agents Page, select HTTP Gateway or
HTTPS Gateway. For user interface details, see "HTTP/HTTPS Gateway Agent Settings" on
page 65.

2.

Forward unknown endpoint requests
If you are not able to reconfigure clients on a service basis (i.e. changing the endpoint of each
service to a virtual service), and all of your HTTP(S) services reside on a single host, you can
use the Forwarded to Host option on the Agents Page.
Example:
The client is calling several backend services:
http://esb.demo.hp.com:8080/BackendServices/MemberAccounts
http://esb.demo.hp.com:8080/BackendServices/ExchangeRate
http://esb.demo.hp.com:8080/BackendServices/Approval

You are only virtualizing the MemberAccounts service but are only able to reconfigure the
application to use another host for all services rather than changing the endpoint of just the
one MemberAccounts service in the application.
You reconfigure your application to use the SV Server HTTP Gateway at:
http://svserver.hp.com:7200 instead of http://esb.demo.hp.com:8080
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The application will access backend services at these endpoints:
http://svserver.hp.com:7200/BackendServices/MemberAccounts
http://svserver.hp.com:7200/BackendServices/ExchangeRate
http://svserver.hp.com:7200/BackendServices/Approval

You create the MemberAccounts service so this functions but the other services would be
inaccessible for the application until you virtualized all of them.
To avoid the virtualization of all backend services set the DEFAULT TARGET HOST to
http://esb.demo.hp.com:8080

Now all requests to non-virtualized services are forwarded to the
http://esb.demo.hp.com:8080 host and are reaching the real services you do not intend to
virtualize now.
Note: The Forwarded to Host field can contain a base URL in several formats: the
host, optional port, and optional base path, i.e.: http://esb.demo.hp.com,
http://esb.demo.hp.com:8080

3.

Perform additional configuration for the HTTPS Gateway Agent
a. If you are using the HTTPS Gateway Agent, you must assign a certificate to a port used for
listening.
Generate a certificate with a private key (if you don’t have one), import the certificate to
either a current user’s personal store (for an embedded server) or to a local machine’s
personal store (for a standalone server). Grant access to the private key to the current user
(for an embedded server) or to the account running the standalone server.
o

To configure HTTP ports and to install a self-signed SSL certificate, use the Service
Virtualization tool configureHttpAgent.bat. For instructions, see the section on
how to install a self-signed certificate in the HP Service Virtualization Installation Guide.

o

To install a custom certificate, use the Service Virtualization tool
addCustomCertificate.bat. For instructions, see the section on how to install a
custom certificate in the HP Service Virtualization Installation Guide.

b. To set proxy agent configuration properties, see "How to Configure the HTTP(S) Proxy
Agent" below.

How to Configure the HTTP(S) Proxy Agent
This task describes how to configure the Service Virtualization HTTP(S) proxy agent.
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The HTTP(S) Proxy Agent serves to virtualize HTTP and HTTPS communication. No endpoint is
created, and an HTTP(S) proxy is used to receive and forward client communication to a real
service HTTP or HTTPS endpoint.
1.

Configure the agent settings
The HTTP(S) proxy agent dynamically generates certificates for requested hosts on the fly.
The certificates are signed by the configured certificate authority (CA). Configure the CA
certificate and private key in the HTTP(S) Proxy agent configuration.
From the main menu, select Tools > Options. On the Agents Page, select HTTP(S) Proxy.
For user interface details, see the "HTTP(S) Proxy Agent Settings" on page 67.

2.

Configure the client
The client must trust certificates signed using a configured CA or the communication may fail
due to rejection by the client.

How to Configure the JDBC Agent
This task describes how to configure the JDBC agent. The JDBC agent is used to virtualize both
J2EE and J2SE applications that are using JDBC™ API to access persistent storage.
The JDBC agent consists of two components:
l

JDBC agent. You configure the JDBC agent in Service Virtualization. The agent listens for
requests from the JDBC driver.

l

JDBC driver. You install the JDBC driver in your application under test. The driver
communicates remotely with the JDBC agent in Service Virtualization. It intercepts each JDBC
API call and depending on the current service mode, forwards the traffic accordingly. If the
virtual service is in either Standby or Learning mode, the driver forwards the traffic to the actual
JDBC driver. If the virtual service is in Simulating mode, the virtual service simulates the API
response.
The JDBC driver is uniquely generated according to the configuration of the JDBC agent and
agent host that you define in Service Virtualization. The driver is invoked only if either a
virtualization JDBC connection string is used (J2SE), or if the virtual data source is explicitly
created and used by the application (J2EE). If a non-virtualization connection string or data
source is used, the virtualization JDBC driver is inactive and has no impact on the application
under test.

1.

Prerequisites
The following types of integration scenarios are supported:
n

A J2SE application using JDBC 3.0 or 4.0/4.1 API.

n

A Java™ based application deployed on a J2EE application server (J2EE version 1.4 or
later).
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2.

Configure the agent settings
From the main Service Virtualization menu, select Tools > Options. On the Agents Page,
select JDBC Agent. For user interface details, see the "JDBC Agent Settings" on page 69.

3.

Reconfigure a standard J2SE application
To reconfigure a typical Java Standard Edition (J2SE) application for JDBC API virtualization:
a. Make sure you have configured the agent settings correctly.
b. Download the JDBC driver. On the Agents Page, click Download JDBC driver for this
configuration.
c. Deploy the driver in the application class path.
d. Create an SQL over JDBC virtual service, and use the actual JDBC connection string as
the Virtual Service Real Connection String.
e. Reconfigure the application under test to use virtual endpoint. If you are working with
JDBC version 3.0, you must also update the JDBC driver class name to the virtualization
driver class name. The virtual driver class name is
com.hp.sv.jdbc.agent.jdbc3.VirtualDriver.

4.

Reconfigure a standard J2EE application
To reconfigure a typical Java Enterprise Edition (J2EE) application, or a J2SE application using
JDBC data sources, for JDBC API virtualization:
a. Make sure you have configured the agent settings correctly.
b. Download the JDBC driver. On the Agents Page, click Download JDBC driver for this
configuration.
c. Create an additional J2EE data source using the newly created virtual JDBC driver. See
the J2EE application server documentation for more details.
d. Reconfigure the application under test to use the newly created data source.
e. Create an SQL over JDBC virtual service, and use the name of the newly created data
source as the Real Connection String.

How to Configure the JMS Generic Agent
This task describes how to configure the Service Virtualization Generic JMS agent.
The Generic JMS Agent serves to virtualize JMS communication in any JMS provider (IBM®
WebSphere® MQ, Weblogic, JBoss, ...). It uses general JMS API and JNDI to lookup and work
with JMS resources (context factories, connection factories, queues, topics). It loads Java JVM
(Java Virtual Machine) with JMS provider libraries required for JMS communication in process.
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Note: The Generic JMS Agent only supports JMS BytesMessage and TextMessage according
to the SOAP over JMS specifications.

1.

Prerequisites
The Generic JMS Agent uses a standard JMS API with JNDI lookups. You must first configure
an environment with JMS resources.
a. Configure JMS. Create virtual destination(s) in JMS server (Webpshere MQ, Weblogic,
JBoss, …)
i. Create a Virtual Request destination.
ii. If you want to use a permanent ReplyTo destination, create a Virtual Reply
destination. If not, a temporary ReplyTo destination is used.
b. Configure JNDI. Configure JNDI mapping for virtual destinations enable the agent to
lookup destinations in JNDI.
i. Configure mapping for the Virtual Request destination.
ii. If a permanent ReplyTo destination is used, configure mapping for the Virtual Reply
destination.

2.

Configure the agent settings
From the main menu, select Tools > Options. On the Agents Page, select JMS. For user
interface details, see the "JMS Generic Agent Settings" on page 71.

Examples of Generic JMS Agent configuration
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Agent configuration for WebLogic 10.3
l

JNDI URL: t3://czvm58.devlab.ad:7001/

l

Context Factory: weblogic.jndi.WLInitialContextFactory

l

Class Path:
C:\Temp\WL103\wlthint3client.jar
Note: The above sample used WebLogic Thin T3 Client. In case of issues, please use
other Weblogic Client libraries (e.g. “WebLogic Full Client” using “wlfullclient.jar”). See
chapter 2 of “Overview of Stand-alone Clients” in your “Oracle® Fusion Middleware
Programming Stand-alone Clients for Oracle WebLogic Server 11g Release 1”
documentation for more details.

Agent configuration for MQ-7.0.1.3 on WAS-6.1.0
l

JNDI URL: corbaloc::czvm24.devlab.ad:2809/NameServiceServerRoot

l

JNDI URL: corbaloc::czvm24.devlab.ad:2809/NameServiceServerRoot

l

JNDI URL: corbaloc::czvm24.devlab.ad:2809/NameServiceServerRoot

C:\Temp\WAS6\com.ibm.mq.jar;
C:\Temp\WAS6\com.ibm.mq.jmqi.jar;
C:\Temp\WAS6\com.ibm.mqjms.jar;
C:\Temp\WAS6\com.ibm.ws.admin.client_6.1.0.jar;
C:\Temp\WAS6\com.ibm.ws.runtime_6.1.0.jar;
C:\Temp\WAS6\connector.jar;
C:\Temp\WAS6\dhbcore.jar;
C:\Temp\WAS6\fscontext.jar;
C:\Temp\WAS6\ibmorb.jar;
C:\Temp\WAS6\jms.jar;
C:\Temp\WAS6\jndi.jar;
C:\Temp\WAS6\ldap.jar;
C:\Temp\WAS6\providerutil.jar
Agent configuration for JBoss 6.0
l

JNDI URL: jnp://[machine-name]:1099/
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l

Context Factory: org.jnp.interfaces.NamingContextFactory

l

Class Path:
C:\Temp\JBAS6\concurrent.jar;
C:\Temp\JBAS6\hornetq-core-client.jar;
C:\Temp\JBAS6\hornetq-jms-client.jar;
C:\Temp\JBAS6\jboss-client.jar;
C:\Temp\JBAS6\jboss-ejb3-core-client.jar;
C:\Temp\JBAS6\jboss-ejb3-ext-api.jar;
C:\Temp\JBAS6\jboss-jms-api_1.1_spec.jar;
C:\Temp\JBAS6\jboss-logging.jar;
C:\Temp\JBAS6\jnp-client.jar;
C:\Temp\JBAS6\netty.jar

How to Configure the Oracle AQ Agent
This task describes how to configure the Service Virtualization Oracle AQ agent.
The Service Virtualization Oracle AQ Agent serves to virtualize communication between
applications that are using Oracle Advanced Queuing. It supports buffered and persistent multi-user
queues with UDT and XML payloads.
The Service Virtualization Oracle AQ Agent requires:
l

one AQ subscribing agent in the Oracle database assigned to virtualization for listening on the
request queue

l

optionally, a second AQ agent in the Oracle database for listening on the response queue when
the virtual service is in recording and stand-by mode, and for publishing responses when the
virtual service is in simulating mode.

Requests and responses are correlated using a correlation identifier of the AQ message. You can
combine UDT requests with XML responses and vice-versa. For more information on Oracle
Advanced Queuing and correlation identifiers, see the Oracle documentation.
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1.

Prerequisites
a. You must install Oracle Data Provider for .NET 11g on the Service Virtualization machine
running the Service Virtualization Oracle AQ agent. The Oracle AQ agent requires Oracle
Data Provider for .NET 11g to access the Oracle database. Oracle Data Provider for .NET
11g is a part of ODAC 11.2, which can be downloaded from the Oracle download site.
b. You must create a subscribing agent in the Oracle database dedicated to virtualizing
messages coming to the request queue (SV Subscriber in the image above) and optionally
a second one dedicated to virtualizing messages coming to the response queue (SV
Publisher in the image above).

2.

Configure the agent settings
From the main menu, select Tools > Options. On the Agents Page, select OracleAQ. For
user interface details, see the "Oracle AQ Agent Settings" on page 73.

How to Configure the SAP RFC/IDOC Agent
This task describes how to configure the SAP RFC/IDOC agent. The SAP RFC/IDOC Agent
handles communication between a SAP® or SAP NetWeaver® Process Integration (PI) system,
and a real or virtual SAP service.
1.

Prerequisites
Make sure that the following are configured on each Service Virtualization Designer or Service
Virtualization standalone server machine on which you are using the SAP RFC/IDOC Agent:
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a. SAP .Net Connector 3.0.10.0.
During installation of the connector, there is an option to install dlls to the GAC. You can
select this option, or you can choose to copy the dlls manually to the Service Virtualization
installation directory's \bin folder after installation.
b. SAP GUI.
Alternatively, if you do not have SAP GUI installed, you can do the following:
i. Update the Windows services file, located in %WinDir%\System32\drivers\etc.
Add the following two lines, replacing xx with your SAP system number:
sapdpxx 32xx/tcp
sapgwxx 33xx/tcp
ii. Copy the appropriate SAP librfc32.dll and librfc32u.dll files for your system into the
Windows folder, as follows:
On a 32-bit operating system:
If the Service Virtualization Designer or the 32-bit Service Virtualization Server are
installed, copy the 32-bit versions of librfc32.dll and librfc32u.dll into the
Windows\System32 folder.
On a 64-bit operating system, do both of the following:
Copy the 32-bit versions of librfc32.dll and librfc32u.dll into the Windows\SysWOW64
folder.
If the 64-bit Service Virtualization Server is installed, copy the 64-bit versions of
librfc32.dll and librfc32u.dll into the Windows\System32 folder.
2.

Configure the agent settings
From the main menu, select Tools > Options. On the Agents Page, select SAP RFC/IDOC.
For user interface details, see the "Agents Page" on page 65.

3. Reconfigure the client to point to the virtual service
For a SAP Server: If your source SAP system is a SAP Server, you must reconfigure the
SAP RFC destination to point to the virtual service.
a. On the SAP server, navigate to transaction sm59. Locate and delete the original
destination.
b. Under TCP/IP Connections, create a new destination and configure the following:
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o

RFC destination. Assign the same name as the original destination.

o

Registered Server Program. Select this option, and enter the Program ID. The value
you assign to Program ID must be identical to the Program ID entered in the virtual
service's properties in Service Virtualization.

o

Gateway Options. Enter the SAP Gateway Host and Gateway Service Name These
values must be identical to the values entered in the Service Virtualization Agents page.

c. Click Connection Test to test your configuration. Your virtual service must be deployed to
carry out this test.
For SAP PI : If your source SAP system is SAP PI, you must reconfigure the communication
channel.
In SAP PI Integration Builder, navigate to the appropriate RFC receiver communication
channel, and configure the following:
n

RFC Server Type. Select External RFC Server.

n

Application Server (Gateway). Enter the SAP Gateway Host (the PI System). The value
must be identical to the value entered in the Service Virtualization Agents page.

n

Application Server Service (Gateway). Enter the SAP Gateway Service Name. The value
must be identical to the values entered in the Service Virtualization Agents page.

n

Program ID. The value you assign must be identical to the Program ID entered in the virtual
service's properties in Service Virtualization.

How to Configure the IBM IMS TM Agent
This task describes how to configure the IBM IMS TM agent. The IBM IMS TM Agent is used to
virtualize IBM IMS Transaction Manager (TM) services that are exposed using the IMS Connect
protocol over a TCP/IP network.
The IBM IMS TM agent is used as an IMS TM gateway. The clients communicate directly with the
agent. Then the agent either forwards the traffic to the actual IMS TM during pass-through (Standby
mode) or recording (Learning mode), or simulates the response. The communication is always
forwarded to IMS TM if it does not belong to any of the deployed services. For more details, see
"How to Create a Virtual Service" on page 92.
1.

Prerequisites
The following types of integration scenarios are supported:

2.

n

A client using IMS Connect API.

n

A client using IMS TM Resource Adapter (managed and unmanaged).

Configure the agent settings
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From the main menu, select Tools > Options. On the Agents Page, select IBM IMS TM and
click Add. Define settings for the new configuration. For user interface details, see the
"IBM IMS TM Agent Settings" on page 76.

How to Configure the WebSphere MQ Agent
This task describes how to configure the WebSphere MQ Agent.
The WebSphere MQ Agent uses the IBM WebSphere MQ Client internally. This enables you to use
all diagnostic tools and logs provided by the client if you need to investigate any issues with
WebSphere MQ communication between HP Service Virtualization and the IBM WebSphere MQ
Server.

1.

Prerequisites
The WebSphere MQ Agent is not installed by default. The agent is dependent on the IBM
WebSphere MQ Client 7.0.1.6 or later (amqmdnet.dll library with version 1.0.0.3 and its
dependencies). The IBM WebSphere MQ Client full installation places the required library in
the Global Assembly Cache (GAC), making the agent available. If you install the client while
the Service Virtualization Server or Designer is running, you must restart the application prior to
enabling the agent.
The WebSphere MQ Agent uses the IBM WebSphere MQ Client internally. This enables you to
use all diagnostic tools and logs provided by the client if you need to investigate any issues
with WebSphere MQ communication between HP Service Virtualization and the IBM
WebSphere MQ Server.
To download the WebSphere MQ version 7.0 Client, see http://www01.ibm.com/support/docview.wss?uid=swg24019253.
To download the WebSphere MQ version 7.5 Client, see .http://www01.ibm.com/support/docview.wss?uid=swg24032744.
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Note: An individual IBM ID is required for the downloads.
2.

Configure the agent settings
From the main menu, select Tools > Options. On the Agents Page, select WebSphere MQ.
For user interface details, see the "WebSphere MQ Agent Settings" on page 78.

3.

Optional: Perform additional global configuration
You can configure additional settings using the Service Virtualization configuration files.
a. Open the appropriate file:
o

Standalone Server configuration file:
%[INSTALLLOCATION]%\Server\bin\HP.SV.StandaloneServer.exe.config

o

Designer configuration file:
%[INSTALLLOCATION]%\Designer\bin\VirtualServiceDesigner.exe.config

b. You can define the following element in the appSettings section of the configuration files.
This configuration element sets up global behavior for processing WebSphere MQ
messages.
o

<add key="MQAgent.DefaultCharacterSet" value="0"/>
Configures the default character set for simulated XML responses. Use this
configuration if the character set is not recorded as message metadata. If the value is
set to 0 the character set is not set.

Agent limitations
l

The WebSphere MQ Agent instance can only use queues from a single Queue manager.

l

The WebSphere MQ Agent instance can only use a single TCP channel to connect to the Queue
manager.

l

CCSID configuration in the WebSphere MQ Agent instance requires an application restart.

l

CCSID configuration is global for whole the application. There cannot be two agents with
different CCSIDs.

l

The WebSphere MQ Agent is not able to automatically reconnect when a TCP connection to the
WebSphere MQ Server is lost. Each service using the agent must be restarted. Alternately,
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restart the whole application.

How to Configure the TIBCO EMS Non Intrusive
Agent
The TIBCO EMS Non Intrusive Agent serves to virtualize JMS communication in TIBCO
Enterprise Message Service ™ (TIBCO EMS). No endpoint is created and a client application does
not require reconfiguration. The agent listens to system topics where all communication can be
monitored. When the service is switched to Simulating mode, it manipulates the service JMS
account permissions in the JMS bus (EMS) to forbid a real service from receiving client
communication. Administrator account credentials in TIBCO EMS are required.

1.

Prerequisites
The TIBCO EMS Non Intrusive agent is not installed by default and if required, must be
installed manually. The agent requires 2 DLL libraries that are not supplied with the product:
Tibco.EMS.dll and Tibco.EMS.Admin.dll. These libraries are supplied with the installation of
TIBCO Enterprise Message Service ™ (EMS), located in the bin directory in the EMS
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installation folder. The typical default location is c:\tibco\ems\6.0\bin\.
Copy the 2 libraries to the bin folder of the installation directory:
n

If you are working with the Service Virtualization Server: By default, the Server
installation folder is located in C:\Program Files\HP\HP Service Virtualization
Server\Server\bin.

n

If you are working with the Designer's embedded server: By default, the Designer
installation folder is located in C:\Program Files\HP (x86)\HP Service Virtualization
Designer\Designer\bin.
Note: After copying the libraries to the directory, you must restart the application.

2.

Configure the agent settings
From the main menu, select Tools > Options. On the Agents Page, select TIBCO EMS Non
Intrusive. For user interface details, see the "TIBCO EMS Agent Settings" on page 81.

How to Forward HTTP Agent Communication
Through an HTTP Proxy
This task explains how to forward HTTP/HTTPS communication between the HTTP
Gateway/HTTPS Gateway/HTTP(S) Proxy agents and a real service through an additional proxy
(proxy chaining).
To enable proxy chaining, perform following steps:
1. From the main menu, select Tools > Options. On the Agents Page, select one of the
following:
n

HTTP Gateway

n

HTTP(S) Proxy

n

HTTPS Gateway

For user interface details, see the "Agents Page" on page 65.
2. Select the Use another proxy server to communicate with real services option, and click
Settings.
3. In the Proxy Settings Dialog Box, configure the settings. For user interface details, see "Proxy
Settings Dialog Box" on page 83.
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How to Configure Windows Firewall and
HTTP Settings
This task describes how to update Windows Firewall and HTTP Settings.
If you change the HTTP or HTTPS agent port, you may need to configure Windows Firewall and
HTTP settings.
Note: This does not apply to port changes in the HTTP(S) Proxy agent.
You may need to configure the following:
l

HTTP settings. If UAC is enabled, you must allow the new agent port.

l

Windows Firewall. If Windows Firewall is enabled, you must add a Windows Firewall inbound
rule for the new agent port.

Windows Firewall and HTTP settings for the default HTTP(S) agent ports are configured during the
initial installation of Service Virtualization.
Caution: The port selected for the HTTP(S) agent must not be used by any other application
and it must not be blocked by a firewall.

If UAC is enabled
If UAC is enabled, or you do not have local administrator privileges, you must obtain permission to
listen on the port. Use the command line interface with elevated privileges, such as administrator,
and perform one of the following:
l

Use the configureHttpAgent.bat tool, provided by Service Virtualization. For instructions, see
the section on how to configure HTTP ports in the HP Service Virtualization Installation Guide.

l

Manually run the following command. The following example is for HTTP port 9000, granting
permission to all users on the current machine:
n

Windows Server 2008 and Windows 7.
netsh http add urlacl http://+:9000/ "sddl=D:(A;;GX;;;WD)"

n

Windows XP and Windows Server 2003.
See the prerequisites in the installation guide for httpcfg tool installation. Then run the
following:
httpcfg set urlacl -u http://+:9000/ -a "D:(A;;GX;;;WD)"

You need to run this command only once for each port. The registration remains in the system
until it is removed.
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If Windows Firewall is enabled
If Windows Firewall is enabled, you must add the firewall inbound rules to allow HTTP
communication between a remote host and Service Virtualization. To add these exceptions, use
the command line interface with elevated privileges, such as administrator, and do one of the
following:
l

Use the configureHttpAgent.bat tool, provided by Service Virtualization. For instructions, see
the section on how to configure HTTP ports in the HP Service Virtualization Installation Guide.

l

Manually add the inbound rules for an HTTP Proxy port exception. The following example adds
firewall exceptions for HTTP port 9000 for all applications:
netsh firewall add portopening TCP 9000 "Port 9000 HTTP Proxy" ENABLE
netsh firewall add portopening UDP 9000 "Port 9000 HTTP Proxy" ENABLE

Agents User Interface
This section includes:
Agents Page

65

Proxy Settings Dialog Box

83
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Agents Page
This section includes:
HTTP/HTTPS Gateway Agent Settings

65

HTTP(S) Proxy Agent Settings

67

JDBC Agent Settings

69

JMS Generic Agent Settings

71

Oracle AQ Agent Settings

73

SAP RFC/IDOC Agent Settings

74

IBM IMS TM Agent Settings

76

WebSphere MQ Agent Settings

78

TIBCO EMS Agent Settings

81

HTTP/HTTPS Gateway Agent Settings
This dialog box enables you to configure the Service Virtualization HTTP/HTTPS Gateway Agent.
The agent handles communication between a client and a real or virtual service.

To access

1. From the main menu, select Tools > Options.
2. Click Agents.
3. Under HTTP(S) Gateway, select a configuration.

Important
information

l

For additional important configuration information, see the task "How to
Configure the HTTP/HTTPS Gateway Agents" on page 49.

l

You can define multiple configurations for each agent.
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Relevant
tasks

l

See also

"How to Configure Agents" on page 47

l

"How to Forward HTTP Agent Communication Through an HTTP Proxy" on
page 62

"Service Virtualization Agents Overview" on page 47

User interface elements are described below (unlabeled elements are shown in angle brackets):
UI Element

Description

<left pane>

Displays the server configured for your project.
Expand the server to display the available agents and configurations.

Add

Enables you to define additional configurations of the agent.

Delete

Deletes the selected configuration.

Duplicate

Creates an additional configuration of the agent by copying the selected
configuration. You can then modify the configuration settings.
Note: By default, the configuration is created with a sequential
unoccupied port number.

Agent State

The current status of the agent. Values include Running, Not Running.

Test
Configuration link

Tests the configuration based on the settings you select. If Service
Virtualization identifies any problems in your configuration, the details are
displayed.

Is Enabled

Turns the agent on and off.

Name

Enter a name for the configuration or accept the default name.

Use SSL

Enables SSL over TCP/IP. If enabled, you must provide certificate file and
password details.

Certificate File

The path to the server side certificate file, in P12 format, that is to be used
by the gateway agent during SSL authentication.
The certificate is used as the server certificate on listening port if the Use
SSL option is enabled.
If this field is left empty and the Use SSL option is selected, then the
agent will use the certificate bound to the specified port in Windows.

Certificate
Password

The password used to access the certificate file specified above.

Port

The port of the Service Virtualization Server used by the agent to deploy
virtual services.
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UI Element

Description

Timeout

The period of time the agent waits before stopping attempts to
communicate with the real service.

External URI

The URI under which the agent is visible to client applications. This is
used, for example when the machine is behind a firewall and the client can
see only the firewall which forwards all requests to the agent. It may be left
empty.

Unknown
Endpoint
Requests

Determines how to respond to requests when there is no service deployed
that matches the URL path provided.
Includes the following options:
l

Return HTTP 404 Error.

l

Forwarded to Host: Requests are forwarded to the specified URL
path.
Use this option if you are not able to reconfigure clients on a service
basis (i.e. by changing the endpoint of each service to a virtual
service), and all of your HTTP(S) services reside on a single host.

Use another proxy
server to
communicate with
real services

Enables you to configure proxy chaining. You can forward the HTTP(S)
communication between the HTTP(S) Gateway agent and the real service
through an additional proxy. If it is not set, the system default proxy server
is used.
Click Settings to open the Proxy Settings dialog box. For details, see
"Proxy Settings Dialog Box" on page 83.

HTTP(S) Proxy Agent Settings
This dialog box enables you to configure the Service Virtualization HTTP(S) Proxy Agent. The
agent handles communication between a client and a real or virtual service.
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To access

1. From the main menu, select Tools > Options.
2. Click Agents.
3. Under HTTP(S) Proxy, select a configuration.

Important
information

Relevant
tasks

l

For additional important configuration information, see the task "How to
Configure the HTTP(S) Proxy Agent" on page 50.

l

In case of Java based clients running on JDK 6 or later, and in the case of selfsigned certificates, it may be necessary to add the “Dsun.security.ssl.allowUnsafeRenegotiation=true” startup parameter or the
client may reject communication with the HTTPS Agent. For more details, see
http://java.sun.com/javase/javaseforbusiness/docs/TLSReadme.html.

l

You can define multiple configurations for each agent.

l

l

See also

"How to Configure Agents" on page 47
"How to Forward HTTP Agent Communication Through an HTTP Proxy" on
page 62

"Service Virtualization Agents Overview" on page 47

User interface elements are described below (unlabeled elements are shown in angle brackets):
UI Element

Description

<left pane>

Displays the server configured for your project.
Expand the server to display the available agents and configurations.

Add

Enables you to define additional configurations of the agent.

Delete

Deletes the selected configuration.

Duplicate

Creates an additional configuration of the agent by copying the
selected configuration. You can then modify the configuration
settings.
Note: By default, the configuration is created with a sequential
unoccupied port number.

Agent State

The current status of the agent. Values include Running, Not
Running.

Test Configuration link

Tests the configuration based on the settings you select. If Service
Virtualization identifies any problems in your configuration, the
details are displayed.

Is Enabled

Turns the agent on and off.
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UI Element

Description

Name

Enter a name for the configuration or accept the default name.

Host

The name by which the agent is visible to client applications. It may
be left empty.

Timeout

The period of time the agent waits before stopping attempts to
communicate with the real service.

HTTP Proxy Settings

Port: the port for HTTP communication.

HTTPS Proxy Settings

Port: the port for HTTPS communication.

CA Certificate File

The Certification Authority certificate file used to generate host
certificates.

Private Key

The private key for the certificate file.

Password

The password for the private key.
Select Show Password to display the password in this dialog box.

Use another proxy
server to communicate
with real services

Enables you to configure proxy chaining. You can forward the HTTP
(S) communication between the HTTP(S) Proxy agent and the real
service through an additional proxy.
Click Settings to open the Proxy Settings dialog box. For details,
see "Proxy Settings Dialog Box" on page 83.

JDBC Agent Settings
This dialog box enables you to configure the Service Virtualization JDBC Agent. The agent handles
communication between a client and a real or virtual service.
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To access

1. From the main menu, select Tools > Options.
2. Click Agents.
3. Under JDBC, select a configuration.

Important
information

Relevant tasks

l

For additional important configuration information, see the task "How to
Configure the JDBC Agent" on page 51.

l

You can define multiple configurations for each agent.

l

l

See also

"How to Configure Agents" on page 47
"How to Forward HTTP Agent Communication Through an HTTP Proxy"
on page 62

"Service Virtualization Agents Overview" on page 47

User interface elements are described below (unlabeled elements are shown in angle brackets):
UI Element

Description

<left pane>

Displays the server configured for your project.
Expand the server to display the available agents and configurations.

Add

Enables you to define additional configurations of the agent.

Delete

Deletes the selected configuration.

Duplicate

Creates an additional configuration of the agent by copying the selected
configuration. You can then modify the configuration settings.
Note: By default, the configuration is created with a sequential
unoccupied port number.

Agent State

The current status of the agent. Values include Running, Not Running.

Test Configuration
link

Tests the configuration based on the settings you select. If Service
Virtualization identifies any problems in your configuration, the details are
displayed.

Is Enabled

Turns the selected configuration of the agent on and off.

Name

Enter a name for the configuration or accept the default name.

Host/Port

The machine and port on which the JDBC agent is listening. Required for
communication with the JDBC driver installed on the application under
test.
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UI Element

Description

Actual
JDBC Driver Class
Name

The fully qualified class name of the actual driver used in the application
under test. Enter the name or select one from the list.

Deployment Type

The environment in which your application under test is running.

JDBC Version

Available only when you select JDBC Version 3.0.

l

If your application under test is deployed on a J2EE application server,
select the appropriate version from the drop-down list.

l

For a Java standard edition application, select J2SE.

The JDBC version used by the application under test.
Available only when you select J2SE in the Deployment Type field.

Create
JDBC driver for
this configuration

Creates the JDBC driver specific to your configuration. Specify a location
for saving the files.
If you change configuration settings, you must create a new driver.

JMS Generic Agent Settings
This dialog box enables you to configure the Service Virtualization JMS Generic Agent. The agent
handles communication between a client and a real or virtual service.

To access

1. From the main menu, select Tools > Options.
2. Click Agents.
3. Under JMS Generic, select a configuration.
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Important
information

Relevant
tasks

l

For additional important configuration information, see the task "How to
Configure the JMS Generic Agent" on page 52.

l

There are several instances of the JMS Generic agent pre-configured for
connecting to the JMS of common Java application servers.

l

You can define multiple configurations for each agent.

l

l

See also

"How to Configure Agents" on page 47
"How to Forward HTTP Agent Communication Through an HTTP Proxy" on
page 62

"Service Virtualization Agents Overview" on page 47

User interface elements are described below (unlabeled elements are shown in angle brackets):
UI Element

Description

<left pane>

Displays the server configured for your project.
Expand the server to display the available agents and configurations.

Add

Enables you to define additional configurations of the agent.

Delete

Deletes the selected configuration.

Duplicate

Creates an additional configuration of the agent by copying the selected
configuration. You can then modify the configuration settings.
Note: By default, the configuration is created with a sequential
unoccupied port number.

Agent State

The current status of the agent. Values include Running, Not
Running.

Test Configuration
link

Tests the configuration based on the settings you select. If Service
Virtualization identifies any problems in your configuration, the details
are displayed.

Is Enabled

Turns the agent on and off.

Name

Enter a name for the configuration or accept the default name.

JNDI URL

The URL where the JNDI provider and the JNDI context with JMS
resources is located.

Context Factory

The provider specific context factory.
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UI Element

Description

Class Path

The class path with all necessary JMS provider specific libraries for
JMS implementation.
Note: To ensure maximum compatibility, use the same JMS/J2EE jar
libraries for the agent class path that are in use by the client application.
If not possible, follow your application server documentation for
selection of the correct J2EE/JMS libraries.

Username/Password Optional credentials for the JNDI provider/registry.
Select Show Password to display the password in this dialog box.

Oracle AQ Agent Settings
This dialog box enables you to configure the Service Virtualization Oracle AQ Agent. The Oracle
agent handles communication between applications that are using Oracle Advanced Queuing.

To access

1. From the main menu, select Tools > Options.
2. Click Agents.
3. Select OracleAQ and click Add to define a new configuration.
Alternatively, select an existing configuration.

Important
information

l

For additional important configuration information, see the task "How to
Configure the Oracle AQ Agent" on page 55.

l

To connect to the Oracle database, you can specify either a connection
string or specific database connection properties.

l

When specifying database connection properties, you can enter either the
database name or SID.
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Relevant
tasks

"How to Configure Agents" on page 47

See also

"Service Virtualization Agents Overview" on page 47

User interface elements are described below (unlabeled elements are shown in angle brackets):
UI Element

Description

<left pane>

Displays the server configured for your project.
Expand the server to display the available agents and configurations.

Add

Enables you to define additional configurations of the agent.

Delete

Deletes the selected configuration.

Duplicate

Creates an additional configuration of the agent by copying the selected
configuration. You can then modify the configuration settings.
Note: By default, the configuration is created with a sequential
unoccupied port number.

Agent State

The current status of the agent. Values include Running, Not
Running.

Test Configuration
link

Tests the configuration based on the settings you select. If Service
Virtualization identifies any problems in your configuration, the details
are displayed.

Is Enabled

Turns the selected configuration of the agent on and off.

Name

Enter a name for the configuration or accept the default name.

Host/Port

The host machine and port for the Oracle database.

Database Name

The name of the Oracle database.

SID

The Oracle system ID.

Connection String

The connection string for connecting to the Oracle database.

Username/Password Enter credentials for a user with permissions to access the Oracle
database.
Although the connection string may contain a password, it is
recommended to specify the password in this password box.

SAP RFC/IDOC Agent Settings
This dialog box enables you to configure the Service Virtualization SAP RFC/IDOC Agent. The
agent handles communication between a SAP® or SAP NetWeaver® Process Integration (PI)
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system, and a real or virtual SAP service.

To access

1. From the main menu, select Tools > Options.
2. Click Agents.
3. Under SAP RFC/IDOC, select a configuration.

Important
information

Relevant
tasks

l

For additional important configuration information, see the task "How to
Configure the SAP RFC/IDOC Agent" on page 56.

l

You can define multiple configurations for each agent.

l

l

See also

"How to Configure Agents" on page 47
"How to Forward HTTP Agent Communication Through an HTTP Proxy" on
page 62

"Service Virtualization Agents Overview" on page 47

User interface elements are described below (unlabeled elements are shown in angle brackets):
UI Element

Description

<left pane>

Displays the server configured for your project.
Expand the server to display the available agents and configurations.

Add

Enables you to define additional configurations of the agent.

Delete

Deletes the selected configuration.
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UI Element

Description

Duplicate

Creates an additional configuration of the agent by copying the selected
configuration. You can then modify the configuration settings.
Note: By default, the configuration is created with a sequential unoccupied
port number.

Agent State

The current status of the agent. Values include Running, Not Running.

Test
Tests the configuration based on the settings you select. If Service
Configuration Virtualization identifies any problems in your configuration, the details are
link
displayed.
Is Enabled

Turns the agent on and off. To enable the agent, the prerequisites must first be
met.

Name

Enter a name for the configuration or accept the default name.

Gateway Host

The IP address or host name of the SAP gateway.
Alternatively, you may enter the SAP Router String for communication through
the SAP firewall.

Gateway
The SAP gateway service name.
Service Name

IBM IMS TM Agent Settings
This dialog box enables you to configure the Service Virtualization IBM IMS TM Agent. The agent
handles communication between a client and a real or virtual service.
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To access

1. From the main menu, select Tools > Options.
2. Click Agents.
3. Select IBM IMS TM and click Add to define a new configuration.
Alternatively, select an existing configuration.

Important
information

Relevant
tasks

l

For additional important configuration information, see the task "How to
Configure the IBM IMS TM Agent" on page 58.

l

You can define multiple configurations for each agent.

l

l

See also

"How to Configure Agents" on page 47
"How to Forward HTTP Agent Communication Through an HTTP Proxy" on
page 62

"Service Virtualization Agents Overview" on page 47

User interface elements are described below (unlabeled elements are shown in angle brackets):
UI Element

Description

<left pane>

Displays the server configured for your project.
Expand the server to display the available agents and configurations.

Add

Enables you to define additional configurations of the agent.

Delete

Deletes the selected configuration.

Duplicate

Creates an additional configuration of the agent by copying the selected
configuration. You can then modify the configuration settings.
Note: By default, the configuration is created with a sequential unoccupied
port number.

Agent State

The current status of the agent. Values include Running, Not Running.

Test
Tests the configuration based on the settings you select. If Service
Configuration Virtualization identifies any problems in your configuration, the details are
link
displayed.
Is Enabled

Turns the agent on and off.

Name

Enter a name for the configuration or accept the default name.

Host

The hostname of the interface on which the agent is listening.

Port

The port on the local machine on which the agent is listening.

Remote Host

The hostname or IP address of the IMS TM server.
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UI Element

Description

Remote Port

The remote port of the IMS TM server.

Code Page

The character set as defined on the IMS TM server. Used to interpret both
requests and responses.

Use SSL

Enables SSL over TCP/IP. If enabled, you must provide certificate file and
password details.

Certificate
File

The server side P12/PFX certificate file used by the IBM IMS TM Agent during
SSL authentication.

Certificate
Password

The password used to access the certificate file specified above.

WebSphere MQ Agent Settings
This dialog box enables you to configure the Service Virtualization WebSphere MQ Agent. The
agent handles communication between a client and a real or virtual service.

To access

1. From the main menu, select Tools > Options.
2. Click Agents.
3. Under WebSphere MQ, select a configuration.

Important
information

l

For additional important configuration information, see the task "How to
Configure the WebSphere MQ Agent" on page 59.

l

The WebSphere MQ Agent is not able to automatically reconnect when a TCP
connection to the WebSphere MQ Server is lost. Each service using the agent
must be restarted. Alternately, restart the whole application.

l

You can define multiple configurations for each agent.
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Relevant
tasks

l

l

See also

"How to Configure Agents" on page 47
"How to Forward HTTP Agent Communication Through an HTTP Proxy" on
page 62

"Service Virtualization Agents Overview" on page 47

User interface elements are described below (unlabeled elements are shown in angle brackets):
UI Element

Description

<left pane>

Displays the server configured for your project.
Expand the server to display the available agents and configurations.

Add

Enables you to define additional configurations of the agent.

Delete

Deletes the selected configuration.

Duplicate

Creates an additional configuration of the agent by copying the selected
configuration. You can then modify the configuration settings.
Note: By default, the configuration is created with a sequential
unoccupied port number.

Agent State

The current status of the agent. Values include Running, Not
Running.

Test Configuration
link

Tests the configuration based on the settings you select. If Service
Virtualization identifies any problems in your configuration, the details
are displayed.

Is Enabled

Turns the agent on and off. To enable the agent, the prerequisites must
first be met.

Name

Enter a name for the configuration or accept the default name.

Queue Manager
Name

The name of the queue manager for the agent to connect to.

Channel Name

The name of the TCP channel for the agent to use to connect to the
Queue Manager.

Note: The WebSphere MQ Agent instance can only use queues from a
single Queue manager.

Note: The WebSphere MQ Agent instance can only use a single TCP
channel to connect to the Queue Manager.
Host

The name of the server hosting the queue manager.

Port

The TCP port where the channel listens for client connections.
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UI Element

Description

CCSID

The character set used by the host.
Note:
l

CCSID configuration in the WebSphere MQ Agent instance requires
that you restart the application.

l

CCSID configuration is global for whole the application. There
cannot be two agents with different CCSIDs.

Username/Password The username and password for connecting to the queue manager.

Note: When you create a new virtual service, you can search
WebSphere MQ queues and select a destination, provided the
virtual agent has sufficient permissions.
To browse MQ destinations, the specified user must be able to
perform the following in the WebSphere MQ client:
l

put and inq operations on the
SYSTEM.ADMIN.COMMAND.QUEUE

l

get, inq, and dsp operations on the
SYSTEM.DEFAULT.MODEL.QUEUE

l

dsp operations on queues to which the user has access
permissions

To create or delete a virtual destination, the specified user
requires additional permissions, such as administrator
permissions.
For details, see "Browse Destinations Dialog Box" on page
107.

SSL: CipherSpec

The algorithm used for secure SSL communication.
Enter a value or select a value from the list. The CipherSpec value must
be the same as the value specified in the WebSphere MQ channel
configuration.
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UI Element

Description

SSL: Key
Repository

The path of the WebSphere MQ SSL key repository, which contains the
WebSphere MQ Queue Manager certificate. If you are using mutual
authentication, it also contains the certificate and private key of the
Service Virtualization MQ agent.
Enter the path to the WebSphere MQ key database file (.kdb), but
without the file extension. This file is similar to the file specified in the
key repository parameter in WebSphere MQ Queue Manager
configuration.

Max. Threads

The maximum number of threads allowed for handling requests received
by the agent. More threads enable more requests to be processed
concurrently, but may affect performance.

Max. Connections

The maximum number of cached connections to Queue Manager
allowed for sending messages. More connections enable more
messages to be sent concurrently.

Message ID Age
[ms]

The length of time, in milliseconds, that cached sent message IDs may
be stored in memory. It is recommended to set this property to at least
the length of time as the longest request/response pair duration.

Message ID Count

The maximum number of cached sent message IDs that may be stored
in memory.

Message Context
Mode

Options for accessing the MQ queue.
l

None.

l

Set Identity. Corresponds to the MQC.MQOO_SET_IDENTITY_
CONTEXT property.

l

Set All. Corresponds to the MQC.MQOO_SET_ALL_CONTEXT
property.

Strip
XML Declarations

Removes XML declarations (<?xml ...>) from text messages before
processing in Service Virtualization. Text messages are in Unicode.

Use UTF Methods

Service Virtualization considers MQ text messages as created by the
WriteUTF() method instead of the WriteString() method.
When using an XML service, the message can be either transferred as a
string (with a specified character set) or as binary data (UTF). By
default, the agent reads and writes messages as a string. Select this
option to use binary messages with UTF content instead.

TIBCO EMS Agent Settings
This dialog box enables you to configure the Service Virtualization TIBCO EMS Agent. The agent
handles communication between a client and a real or virtual service.
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To access

1. From the main menu, select Tools > Options.
2. Click Agents.
3. Under TIBCO EMS, select a configuration.

Important
information

Relevant
tasks

l

For additional important configuration information, see the task "How to
Configure the TIBCO EMS Non Intrusive Agent" on page 61.

l

You can define multiple configurations for each agent.

l

l

See also

"How to Configure Agents" on page 47
"How to Forward HTTP Agent Communication Through an HTTP Proxy" on
page 62

"Service Virtualization Agents Overview" on page 47

User interface elements are described below (unlabeled elements are shown in angle brackets):
UI Element

Description

<left pane>

Displays the server configured for your project.
Expand the server to display the available agents and configurations.

Add

Enables you to define additional configurations of the agent.

Delete

Deletes the selected configuration.

Duplicate

Creates an additional configuration of the agent by copying the selected
configuration. You can then modify the configuration settings.
Note: By default, the configuration is created with a sequential
unoccupied port number.
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UI Element

Description

Agent State

The current status of the agent. Values include Running, Not
Running.

Test Configuration
link

Tests the configuration based on the settings you select. If Service
Virtualization identifies any problems in your configuration, the details
are displayed.

Is Enabled

Turns the agent on and off. To enable the agent, the prerequisites must
first be met.

Name

Enter a name for the configuration or accept the default name.

Host

The host where EMS is running.

Server Port

The server where EMS is running.

Username/Password The username and password for an EMS account with appropriate
privileges to change permissions on destinations and on the JMS server
(admin account required).

Proxy Settings Dialog Box
This dialog box enables you to configure proxy chaining. You can forward HTTP/HTTPS
communication between the HTTP Gateway/HTTPS Gateway/HTTP(S) Proxy agents and a real
service through an additional proxy.
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To access

1. From the main menu, select Tools > Options. On the Agents Page, select
one of the following:
n

HTTP Gateway

n

HTTP(S) Proxy

n

HTTPS Gateway

2. Select the Use another proxy server to communicate with real services
option, and click Settings.
Relevant
tasks

"How to Forward HTTP Agent Communication Through an HTTP Proxy" on page
62

User interface elements are described below:
UI Element

Description

Proxy Host

Address or hostname of proxy machine.

Port

Port number on host machine.

Credentials

Authentication credentials. Authentication is automatically detected,
and supports BASIC, DIGEST, NTLM, and Negotiate authentication
types.
Includes the following options:
l

None. No username and password are used for proxy
authentication.

l

Current User. The username and password of the current
Windows user are provided by Windows and integrated
authentication is used.
Note: Only NTLM and Negotiate authentication are supported.

l

Do not use proxy
server for address
beginning with

Custom Credentials. Enter a username and password to use for
authentication.

The list of addresses for which the proxy will not be used.
Separate addresses with semicolons or place on new lines.

Bypass proxy server for The proxy is not used when accessing local addresses (IPv4 and
local addresses
IPv6 loopback and current machine hostname).
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This chapter includes:
Virtual Service Overview

86

How to Create a Virtual Service

92

How to Configure Virtual Services

93

How to Manage Virtualization Projects

95

Virtual Services User Interface

96
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Virtual Service Overview
Service Virtualization places a virtual service between the client application (application under test)
and the real service you want to simulate.
To simulate the behavior of the real service, you create a virtual service and configure it to meet
your needs. After you design your virtual service, you reconfigure your client application to use this
virtual service endpoint, in place of the real service.
You create virtual services by importing an existing service description document, or by creating a
new service based on one of the Service Virtualization supported protocols.
You can also create service templates. After creating a service, you can save it as a template in
order to reuse the service in multiple testing environments, or reuse the service's configuration,
custom functions, data, and views.
For task details, see "How to Create a Virtual Service" on page 92.
You configure your virtual service by designing data and performance models to simulate real
service behavior. You can record real service activity, and use it to create these models, or
manually customize the models. For task details, see "How to Configure Virtual Services" on page
93.
The basis of organizing your virtual service is the virtualization project. The virtualization project
includes your virtual services, the simulation models you use to simulate real service behavior, and
other configuration entities you can customize to meet your needs. For details, see "Virtualization
Projects" on the next page.
After you create virtual services, you manage them by manipulating virtual service modes. The
modes include Learning, Standby, and Simulating. For details, see "Simulation" on page 122.
This section also includes:
Virtualization Projects

87

Virtual Service Types

87

Service Descriptions

90
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Virtualization Projects
The basis of organization within Service Virtualization is the virtualization project.
The virtualization project includes your virtual services, the simulation models you use to simulate
real service behavior, and other configuration entities you can customize to meet your needs.
You view your project structure in the Virtualization Explorer. For details, see "Virtualization
Explorer" on page 111.
When you create a project, it is created within a solution. A solution is a container for one or more
projects that you want to maintain as a group. You can view your project and solution in the
Projects pane.
Update your projects
Projects created in earlier versions of HP Service Virtualization are fully compatible with Service
Virtualization 3.10. When you open a project created in a previous version of Service Virtualization,
a pop up window displays, informing you that the project contains resources in an older format.
Click Yes to confirm that you want to update your existing project.
Group related services
You may want to keep a group of related virtual services together in a single project. However, if
there are too many services in a single project, they may be difficult to manage. The recommended
limit is approximately 20 virtual services per project. In this case, it is recommended to create an
additional project.
Add projects to a solution
You can add new or existing projects to an existing solution. One advantage to having multiple
projects within one solution is that you can manage all the services within the Runtime view. The
Runtime view provides an overview of the communication through the virtual services during
Learning or Simulation sessions.
Export projects
You can save your project as an archive file in the file system.
Tip: For enhanced security, you can encrypt the project file. For more details on encryption, see
"Password Encryption" on page 23.
For task details, see "How to Manage Virtualization Projects" on page 95.

Virtual Service Types
This section provides information on creating various types of virtual services.
Note:
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l

For the full list of supported protocols and versions, refer to the support matrix on the
HP Software Support site at: http://h20230.www2.hp.com/sc/support_matrices.jsp, or
contact support.

l

When you create a new virtual service, you specify a transport protocol and a message
protocol that the service will use. For details on creating virtual services, see "How to
Create a Virtual Service" on page 92.

This section includes:
l

"XML and Binary Services" below

l

"SOAP Services" below

l

"REST Services" below

l

"IBM IMS TM Virtual Services" below

l

"COBOL over IBM CICS TS HTTP Services" on the next page

l

"SQL Services" on page 90

XML and Binary Services
If you have an existing XML or binary service, it can be added to your virtualization project. If you do
not have an existing XML or binary service, you can create one. If the service is of an unknown
type, creating a binary service is the best solution. If Service Virtualization cannot understand the
message format, it can record it in binary format, although it is not able to fully recognize the
structure.

SOAP Services
You can create SOAP services in the following ways:
l

Import WSDL documents directly into Service Virtualization to describe SOAP services. To
later update a SOAP service description, you can load a new service description document.

l

Create a new service without importing a service description. You can then place the virtual
service in Learning mode to record real service behavior.

REST Services
REST services do not use imported service description documents in Service Virtualization. After
you create a REST service, you can record real service behavior to learn the structure of the
service.

IBM IMS TM Virtual Services
Depending on the client transport and message level protocol, there are multiple options for
virtualizing IBM® Information Management System Transaction Manager (IMS™ TM) services.
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The following is an overview of protocols with full message structure parsing. Each requires a
COBOL copybook.
1. COBOL payload over IBM IMS TM Resource Adapter
a. The client is J2EE application using IBM IMS TM Resource Adapter to access IMS TM.
b. The payload are COBOL messages based on known COBOL copybooks.
c. The virtual service is created based on one or more of the following: TPipe name, Client ID,
Datastore Name, Transaction Code.
2. COBOL payload over IBM IMS Connect API protocol
a. The client is J2SE application using IBM IMS Connect Java API to access IMS TM.
b. The payload are COBOL messages based on known COBOL copybooks.
c. The virtual service is created based on one or more of the following: LTerm name, Client
ID, Datastore Name, Transaction Code.
If full message structure parsing is not required, or if the COBOL copybook is not available, the
following protocols provide the best alternatives. Note that the payload is a binary object and not
structured.
1. Binary messages over IMS
a. Any client type using IMS TM over a TCP/IP network.
b. Any payload type.
c. The virtual service is created based on one or more of the following: TPipe name, Client ID,
Datastore Name, Transaction Code.
2. Binary messages over WebSphere MQ
a. The client is using IMS-MQ bridge to access IMS TM.
b. Any payload type.

COBOL over IBM CICS TS HTTP Services
If the client communicates with the service using COBOL messages over HTTP transport, such as
IBM CICS Transaction Server web-aware applications for example, you can use the following
protocols for service simulation. Both HTTP Proxy and HTTP Gateway agent types are supported.
1. COBOL messages over IBM CICS TS HTTP
a. The client is any application using COBOL messages based on known COBOL copybook
(s).
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b. The virtual service is created based on HTTP URI path.
c. The message is fully structured.
2. Binary messages over HTTP
a. The client is any application using any messages (including COBOL).
b. The virtual service is created based on HTTP URI path.
c. The message is not structured. Only HTTP headers are shown.
COBOL services over IBM CICS TS HTTP transport usually use two encodings – one encoding for
the HTTP protocol and the other for the COBOL messages. Service Virtualization expects the
HTTP transport to be encoded using US-ASCII. However, the exact COBOL message encoding
may be selected during virtual service creation.

SQL Services
You can create virtual SQL services for working with JDBC.
When you configure the Service Virtualization JDBC agent to work with JDBC services, you enter
parameters for the specific target environment in which you are working. Service Virtualization then
configures a unique agent for your system.

Service Descriptions
In order to virtualize a service, Service Virtualization needs to know what the service does and what
endpoints it uses.
You can provide this information in several ways:
l

Learning. When you place a virtual service in Learning mode, Service Virtualization learns
about the real service structure, and automatically updates the virtual service. If there are
additional changes that you want to make, you can then edit the service description manually.
Service description learning is available for XML, REST, SOAP, and SQL services.

l

Import service description documents. Service Virtualization provides an import wizard that
analyzes the content of the document, and enables you to associate it with a particular
virtualized service.

l

Configure a service description. You can the add operations and URI spaces, import and edit
XML schemas, and configure other components of your services. For example, REST services
do not use imported service description documents. After you create a REST service, you can
record real service behavior to learn the structure of the service. You can then edit the service
description in Service Virtualization.

Importing Service Description Documents
You can import the following service description document types into Service Virtualization:
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l

WSDL
Web-Service Definition Language documents are the most common way to describe SOAP
services. They often contain references to other WSDLs and XSDs that must be available in the
referenced locations in order to import them and correctly describe the services they define.

l

XSD
XML Schema documents may also describe XML services. They often contain references to
additional XML Schema Definitions (XSDs) that must be available in the referenced locations in
order to import them and correctly describe the services they define.

l

COBOL Copybook
COBOL copybook documents describe input and output message structure for legacy
mainframe applications.

For task details, see "How to Create a Virtual Service" on the next page.

Configuring Service Descriptions
You can edit a service description within Service Virtualization. You can configure the following
components:
Note: To update a SOAP service description, you can also load a new service description
document. You can edit HTTP metadata, and set session identifiers within Service
Virtualization, which are not part of the service's WSDL document.

l

Operations and URI spaces. For an XML service, you can add new operations. For
REST services, you can create more URI spaces in which to place the data. This enables you
to split your data into smaller groups according to the URI path of the resources.

l

Metadata. Metadata are parameters that contain some protocol-specific information such as
time stamps, correlation information, or status codes. They are part of the protocol message, but
external to the message body, such as URL parameters, or HTTP headers. You can edit this
metadata in Service Virtualization
Some types of metadata, such as HTTP Headers, are not required for tested applications; they
may be important for the protocol, but the application does not require them and they are not
learned for purposes of virtualization. By default they are disabled in the request but it is possible
to enable them and edit the data for use in a simulation. Metadata such as URI Parameters are
generally used by tested applications and are enabled by default.

l

XML schemas. For XML, REST, or SOAP services. You can add, edit, or remove
XML schemas.

l

Session identifiers. To perform stateful simulation, you need to be able to identify requests that
reflect the same source. For example, you may want to identify all requests coming from a
single browser session. Service Virtualization uses this information to create different tracks
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based on learned data, and uses the tracks to create different sessions during simulation.
Service Virtualization assigns default session identifiers based on the service's protocol, which
you can then modify.
l

Data formats. You can add or remove request and response data formats. You add a new data
format to your service description by copying from an existing URI space (in a REST service), or
by creating a new format.

l

Data masking. To hide sensitive data, you can scramble specific data elements. For example,
there may be sensitive data that you are not permitted to store to disk. You can configure the
elements for data masking, so that data recorded during Learning is masked and cannot be
viewed in the data model.

For task details, see "How to Edit a Service Description" on page 183.

How to Create a Virtual Service
This task describes how to create a virtual service. For additional details on specific service types,
see "Virtual Service Types" on page 87.

l

This task is part of a higher-level task. For details, see "How to Use Service Virtualization"
on page 25.

l

To learn more about virtual services, see "Virtual Service Overview" on page 86.

1.

Optional: Create a new project
When you select a task from the Get Started page, these tasks first create a new virtualization
project and then a new virtual service. For user interface details, see "Start Page" on page 30.
For details on how to manually create a new virtualization project, see "How to Manage
Virtualization Projects" on page 95.

2.

Open an existing project
Select one of the following:
n

On the Start Page, under Recent Projects, select a project.

n

From the main menu, select File > Open Project/Solution.
Note: Projects created in earlier versions of HP Service Virtualization are fully compatible
with Service Virtualization 3.10.
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When opening a project created in a previous version of Service Virtualization, a pop up
window displays, informing you that the project contains resources in an older format.
Click Yes to confirm that you want to update your existing project.
For more information on virtualization projects, see "Virtualization Projects" on page 87.
3.

Launch the new virtual service wizard
In an existing project, select one of the following:
n

From the main menu, select File > New > Virtual Service.

n

In the Virtualization Explorer, right-click a virtualization entity and select Add > Virtual
Service.

For user interface details, see "Create New Virtual Service Wizard" on page 98.
4.

Optional: Create a template service
a. To save a service as a template: In the Virtualization Explorer, right-click the service and
select Save as Template.
b. To create a new service from a template: From the main menu, select File > New
> Virtual Service from Template.

How to Configure Virtual Services
This task describes how to configure your virtual service to meet your needs.

l

This task is part of a higher-level task. For details, see "How to Use Service Virtualization"
on page 25.

l

To learn more about configuring virtual services, see "Virtual Service Overview" on page 86.

This task includes the following steps:
l

"Select simulation models" on the next page

l

"Configure virtual service endpoints" on the next page

l

"Configure Service Virtualization agents" on the next page

l

"Enable message logging" on the next page

l

"Disable schema learning" on the next page

l

"Edit the service description" on the next page
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l

"Set security options" on the next page

l

"Change servers" on the next page

Select simulation models
In the Virtual Service Editor, select existing data and performance models to use with your virtual
service, or add new models.
For task details on simulation models, see "How to Manage Simulation Models" on page 156.

Configure virtual service endpoints
You can modify real and virtual service endpoint information that you provided when creating the
virtual service. In the Virtual Service Editor, under Service Configuration, click Edit to open the Edit
Endpoints dialog box.
In the Edit Endpoints dialog box, you can click Show Endpoint Topology to display a diagram of
your service endpoint configuration.

Configure Service Virtualization agents
You can modify agent information that you selected when creating the virtual service. In the Virtual
Service Editor, under Service Configuration, click Configure. The Agents page opens.
For user interface details, see "Agents Page" on page 65.

Enable message logging
To enable logging, in the Virtual Service Editor, under Service Configuration, select Message
Logging.
For more details, see "Virtual Service Editor" on page 113.

Disable schema learning
You can block changes to the service description during learning or message import.
This is useful, for example, when the service was created from an existing WSDL or schema, and
you want to ensure that messages with a different structure do not modify it.
For more details, see "Virtual Service Editor" on page 113.

Edit the service description
You can modify the service description associated with your virtual service. Depending on the
service type, you can do the following:
l

add/remove operations/URI spaces

l

edit request/response metadata

l

add/remove/edit XML schemas

l

add/remove data formats

l

define session identifiers
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For task details, see "How to Edit a Service Description" on page 183.
For user interface details, see "Service Description Editor" on page 224.

Set security options
In the Virtual Service Editor, under Security Settings, define authentication credentials and
message security.
Note: This may be required before you can connect to the real service.
For task details, see "How to Set Security" on page 255.

Change servers
You can redeploy the virtual services in your project to a different server, if required.
From the main menu, select Project > Change Server to open the Change Server for <current
project> Project dialog box.
Alternatively, in the Virtualization Explorer, right-click the project tree and select Change Server.

How to Manage Virtualization Projects
This task describes how to create and manage virtualization projects.
To learn more about Service Virtualization projects, see "Virtualization Projects" on page 87.

Create a new project
Select one of the following:
l

Select a task from the Get Started page. These tasks first create a new virtualization project and
then a new virtual service. For user interface details, see "Start Page" on page 30.

l

Create a new virtualization project. From the main menu, select File > New > Virtualization
Project. For user interface details, see "Summary of Virtualization Project Dialog Box" on page
97.

Add projects to an existing solution
You can add new or existing projects to a solution.
1. From the main menu, select View > Projects to display the Projects pane.
2. Right-click the solution name and select one of the following:
a. Add > New Virtualization Project
b. Add > Existing Project
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Open a project
To open a project, select one of the following:
l

On the Start Page, under Recent Projects, select a project.
Tip: Hover over a project name to see the full path to the saved project.

l

From the main menu, select File > Open Project/Solution. By default, projects are stored in
the following location in the file system: <Your Documents folder>\HP Service
Virtualization\Projects.

Change the default project location
From the main menu, select Tools > Options > General tab. Then select Projects and
Solutions.

Close a project
From the main menu, select File > Close Project/Solution.

View server information
In the Virtualization Explorer, expand a project. The server is displayed as the last item in the tree.
Click the server to display its details in the lower pane.

Move virtual services to a different server
The virtual services in your project are deployed on the Service Virtualization server specified for
the project. To change the server, in the Virtualization Explorer, expand a project. Right-click the
server and select Change Server. Alternatively, from the main menu, select Project > Change
Server. For user interface details, see "Change Server Dialog Box" on page 118.

Export a project
Save your project as an archive file in the file system. From the main menu, select File > Export
Project. The file is saved with the default file extension .vproja.

Encrypt projects
You can encrypt your projects using a password you define.
1. From the main menu, select Tools > Options.
2. On the General page, click Projects and Solutions and enter a project encryption password.
For more details on encryption, see "Password Encryption" on page 23.

Virtual Services User Interface
This section includes:
Summary of Virtualization Project Dialog Box
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Create New Virtual Service Wizard

98

Endpoint Validation Dialog Box

110

Virtualization Explorer

111

Virtual Service Editor

113

Edit Endpoints Dialog Box

117

Change Server Dialog Box

118

Projects and Solutions Page

120

Summary of Virtualization Project Dialog Box
This dialog box enables you to create a new virtualization project.

To access

From the main menu, select File > New > Virtualization Project.

Relevant tasks "How to Use Service Virtualization" on page 25
See also

"Service Virtualization Overview" on page 21

User interface elements are described below:
UI
Element Description
Project

Displays the default name for the project you are creating.

Path

Displays the default location in the file system where the project is created.

Server

Displays the default server to be used with the new project.
All services in the project are deployed on this server.
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UI
Element Description
Change

Opens the Change Project dialog box, enabling you to modify the following details:
l

Project. Enter a name for the project or accept the default name.

l

Path. Enter a path for the project or accept the default path.

l

Server. Select the server on which to deploy the virtual service.
You can select the Designer's embedded server, or a standalone Service
Virtualization Server. For details on adding Service Virtualization Servers, see
"How to Manage Service Virtualization Servers" on page 27.

Create

Creates the new project according to your specified settings.

Create New Virtual Service Wizard
This wizard enables you to create a new virtual service.
To access

To launch the new virtual service wizard, in an existing project, select one of the
following:
l

From the main menu, select File > New > Virtual Service.

l

In the Virtualization Explorer, right-click a virtualization entity and select Add >
Virtual Service.

Wizard
map

This wizard contains:

Important
information

l

If you are creating a new virtual service from the Get Started page, a new
virtualization project is created for the service.

l

For additional details on specific service types, see "Virtual Service Types" on
page 87.

"Import Real Service Description Page" below > "Choose Service Protocol Page"
on page 100 > "Service Properties Page" on page 102 > "Summary of
Virtualization Page" on page 109

Relevant
tasks

"How to Create a Virtual Service" on page 92

See also

l

"Virtual Service Overview" on page 86

l

"Service Descriptions" on page 90

Import Real Service Description Page
This wizard page enables you to import service description documents.
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Important
information

l

General information about this wizard is available here: "Create New Virtual
Service Wizard" on the previous page

l

For additional details on specific service types, see "Virtual Service Types" on
page 87.

l

This page also enables you to import a service description in order to add
service call activity in the Data Model.

Wizard
map

The create new virtual service wizard contains:

See also

l

"Virtual Service Overview" on page 86

l

"Service Descriptions" on page 90

"Import Real Service Description Page" on the previous page > "Choose
Service Protocol Page" on the next page > "Service Properties Page" on page 102
> "Summary of Virtualization Page" on page 109

User interface elements are described below:
UI Element

Description

Service
Enables you to import a WSDL, XML schema, or COBOL copybook document.
description
Enter the path to your service description file, or click Browse to navigate to the
file location.
Note: If the WSDL describes multiple services or a single service specifying
multiple ports, select one from the list of available ports in the dialog box that
opens.
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UI Element

Description

I don't
Enables you to create a virtual service without using an existing service
have a
description.
service
description
REST services: Select this option when creating a REST service.
REST services do not use imported service description documents. After
you create a REST service, you can record real service behavior to learn
the structure of the service.

Choose Service Protocol Page
This wizard page enables you to select protocols for your new virtual service.

Important
information

l

General information about this wizard is available here: "Create New Virtual
Service Wizard" on page 98

l

For additional details on specific service types, see "Virtual Service Types" on
page 87.

Wizard
map

The create new virtual service wizard contains:

See also

l

"Import Real Service Description Page" on page 98 > "Choose Service Protocol
Page" above > "Service Properties Page" on page 102 > "Summary of
Virtualization Page" on page 109
"Virtual Service Overview" on page 86

User interface elements are described below (unlabeled elements are shown in angle brackets):
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UI Element

Description

<filter text
box>

Enter text to filter the available protocols.

Filter by

To filter the protocol list, select protocols from the message and transport
protocol drop-down lists.

<list of
protocols>

Select a protocol configuration for your new virtual service.

Message Type Page
This wizard page enables you to define the structure of input and output messages, when working
with a COBOL copybook.

Important
information

l

General information about this wizard is available here: "Create New Virtual
Service Wizard" on page 98

l

This wizard page is available only if you chose to import a COBOL copybook
for the service description.

l

For additional details on specific service types, see "Virtual Service Types" on
page 87.

Wizard
map

The create new virtual service wizard contains:

See also

"Virtual Service Overview" on page 86

"Import Real Service Description Page" on page 98 > "Choose Service Protocol
Page" on the previous page > "Service Properties Page" on the next page >
"Summary of Virtualization Page" on page 109

User interface elements are described below:
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UI Element

Description

Create messages
specifying input and
output elements

Displays the message types available for input and output, as
defined in your COBOL copybook.

Create multisegmented
messages

A multi-segmented message is composed of multiple COBOL
structures. Each COBOL structure may occur one or more times in a
segmented message.

Only one COBOL structure may be assigned as the input message,
and another as the output message.

Note: Not all IMS protocols support this feature.

Service Properties Page
This wizard page enables you to define protocol-specific properties for your virtual service.

Important
information

l

General information about this wizard is available here: "Create New Virtual
Service Wizard" on page 98

l

The properties available on the page depend on the protocols you select for the
new service on the Choose Service Protocol page.

l

After the virtual service is created, you can edit these properties. In the Virtual
Service Editor, under Service Configuration, click Edit to open the Edit
Endpoints dialog box.

l

For additional details on specific service types, see "Virtual Service Types" on
page 87.
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Wizard
map

The create new virtual service wizard contains:

See also

"Virtual Service Overview" on page 86

"Import Real Service Description Page" on page 98 > "Choose Service Protocol
Page" on page 100 > "Service Properties Page" on the previous page >
"Summary of Virtualization Page" on page 109

This section includes:
l

"General" below

l

"HTTP" below

l

"IBM IMS TM" on the next page

l

"IBM CICS TS HTTP" on the next page

l

"JDBC" on page 105

l

"JMS" on page 105

l

"ORACLE AQ" on page 105

l

"SAP RFC/IDOC" on page 106

l

"TIBCO EMS" on page 106

l

"WebSphere MQ" on page 107

User interface elements are described below:

General
Show Endpoint
Topology

Displays a diagram of your service endpoint configuration.

Test Endpoints

Checks that the endpoints are configured correctly.

Ignore WS Addressing

WS-Addressing headers are not processed by Service
Virtualization.
Available for SOAP services over HTTP, JMS, and Tibco EMS.

HTTP
Define the real service endpoints.
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Property

Description

Endpoints Enter the real service endpoint (URL).
To enter multiple endpoints, separate them by a space, comma, semicolon, or type
each endpoint on a new line.
Note: When using the HTTP or HTTPS Gateway agent, the virtual service
may have only one specified endpoint.

IBM IMS TM
Define the real service properties. Values are case-sensitive and should be provided by your
IMS TM System Administrator or Operator.
Property

Description

Client ID

Identification of the client for services with dedicated persistent socket
connections. For shareable persistent socket connections, leave this value
undefined.

Transaction The alphanumeric code used to invoke IMS message processing program.
Code
TPipe
Name

The transactional pipe (TPipe) value, used to maintain a logical association
between client and service. The OTMA TPipe name is similar to the IMS Connect
logical terminal (LTerm) name.

LTerm
Name

Logical Terminal Name. The IMS logical association between client and
service. Similar to OTMA TPipe name.

Datastore
ID

The service datastore name (IMS Destination ID).

Any value

Clear this option to define a filter for the corresponding property. If you enter a
specific value for a property, only messages matching the specified value are
processed during Learning and Simulation sessions.

IBM CICS TS HTTP
Define virtual and real service properties.
Property

Description

Virtual Service Parameters:
Path

The relative URI that defines on which URI path the virtual service is to be
deployed.

Real Service Properties:
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Property

Description

Endpoint

The relative or absolute endpoint, depending on the agent type, that defines where
the actual COBOL service is listening. For details, see "Virtual Service Types" on
page 87.

Encoding COBOL content encoding.

JDBC
Define the real service properties.
Property

Description

Connection Define one of the following:
String
l The JDBC Connection string used in the application under test. This is used
primary when working with J2SE applications.
l

The JNDI datasource name used by the application under test. This is used
only if the application is deployed on a J2EE application server.

JMS
Define virtual and real service properties.
Property

Description

Virtual Service Properties:
Destination
Name

The JNDI destination name where the virtual service expects to receive requests.

Reply To

The JNDI destination name where the virtual service will send responses. If the
client provides a ReplyTo JMS property, you can leave this field empty.

Real Service Properties:
Destination
Name

The JNDI destination name where the real service expects to receive requests.

Reply To

The JNDI destination name where the real service sends responses. If this field is
left empty, Service Virtualization creates a temporary destination for receiving
responses from the real service, and sets the ReplyTo JMS property in the
request to point to that temporary destination.

Connection The JNDI name of the connection factory.
Factory

ORACLE AQ
Define the following properties for the request queue, and optionally, for the response queue.
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Property

Description

Subscription Agent
Name

The AQ Agent name that Service Virtualization uses to consume
messages.

Queue Name

The name of the AQ queue.

Dequeue Condition

A condition you can define to limit messages consumed by Service
Virtualization.

SAP RFC/IDOC
Define real and virtual service properties.
Property

Description

Virtual Service Properties:
Program ID

The ID assigned to the RFC destination defined on the SAP or PI
server.

PI RFC/IDOC Adapter Indicates you are working with a SAP PI RFC adapter.
Unicode

If you are using a SAP PI RFC/IDOC adapter, you must select this
option if unicode is configured in SAP PI.

Real SAP Server Connection Properties:
Client ID

The SAP client ID.

Host

The IP address or host name of the SAP server.
Alternatively, you may enter the SAP Router String for communication
through the SAP firewall.

System Number

The SAP system number.

TIBCO EMS
Define the real service properties.
Since Service Virtualization records messages on TIBCO EMS non-intrusively, all parameters in
the configuration are related only to the real service. When the virtual service mode is switched to
Simulating mode, the real service is automatically disconnected from TIBCO EMS and is replaced
by Service Virtualization.
There is no response destination name as the response destination is always read from request
properties.
Property

Description

Destination Name Name of destination where requests are sent.
Destination Type

Type of destination where requests are sent.
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WebSphere MQ
Define virtual and real service properties.
Property

Description

Virtual Service Properties:
Destination Name of queue where the virtual service expects requests.
Name
Click Browse to select an actual destination or to virtualize a
destination.
Reply To

Name of queue where the virtual service will send responses. If the
client provides a ReplyToQueue message property, you can leave this
field empty.

Real Service Properties:
Destination Name of queue where the real service expects requests.
Name
Click Browse to select an actual destination or to virtualize a
destination.
Reply To

Name of queue where the real service sends responses. If this field is
left empty, Service Virtualization creates a temporary queue for
receiving responses from the real service, and sets the
ReplyToQueue message property in the request to point to that
temporary destination. Note that WebSphere MQ must be configured
so that Service Virtualization has permission to create temporary
queues.

Destination Type of destination where the real service expects requests. Only
Type
Queue destination type is supported.

Browse Destinations Dialog Box
This wizard page enables you to select and virtualize an MQ destination to use in your virtual
service.
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Important
information

l

General information about this wizard is available here: "Create New Virtual
Service Wizard" on page 98

l

For additional details on specific service types, see "Virtual Service Types" on
page 87.

l

This dialog box opens when you click Browse for a destination in the Service
Properties dialog box.
Note: To view MQ destinations, the user defined for the WebSphere MQ
virtual agent must have sufficient permissions. For details, see
"WebSphere MQ Agent Settings" on page 78.

Wizard
map

The create new virtual service wizard contains:

See also

l

"Virtual Service Overview" on page 86

l

"WebSphere MQ Agent Settings" on page 78

"Import Real Service Description Page" on page 98 > "Choose Service Protocol
Page" on page 100 > "Service Properties Page" on page 102 > "Summary of
Virtualization Page" on the next page

User interface elements are described below(unlabeled elements are shown in angle brackets):
UI Element

Description

<search box> Enter a destination name or part of a name to filter the list of destinations
displayed.
Virtualized
Destinations
Only

Displays only the list of destinations that are virtualized.
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UI Element

Description

Relevant
Agents

Displays only the list of destinations that you may use.
For example, filters out any destinations for which the agent does not have
sufficient permissions to access, or agents that are not defined on the server
with which you are working.

<destinations List of available destinations. The destinations displayed are based on the
list>
WebSphere MQ queue managers defined in the WebSphere MQ Service
Virtualization agent configurations.
Actual destinations.
Virtualized destinations.
Manage
Agents

Opens the Agents page, enabling you to add, delete, or reconfigure settings for
virtual service agents. For details, see "Agents Page" on page 65.

Virtualize
Selected

Select an actual destination and click Virtualize Selected. Creates a duplicate,
virtual destination that you can use for your virtual service.
In the dialog box that opens, accept the default name for the virtual destination,
or enter a different name.

Unvirtualize
Selected

Deletes the virtual destination.

Summary of Virtualization Page
This wizard page enables you to review your information. You can confirm or change details of the
real service, virtual service, or project.
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Important
information

l

General information about this wizard is available here: "Create New Virtual
Service Wizard" on page 98

l

If you are creating a new virtual service from the Get Started page, a new
virtualization project is created for the service. Click Change to modify project
name, path, or server.

l

For additional details on specific service types, see "Virtual Service Types" on
page 87.

Wizard
map

The create new virtual service wizard contains:

See also

"Virtual Service Overview" on page 86

"Import Real Service Description Page" on page 98 > "Choose Service Protocol
Page" on page 100 > "Service Properties Page" on page 102 > "Summary of
Virtualization Page" on the previous page

User interface elements are described below:
UI
Element

Description

Virtual
Service

Displays details of the virtual service you are creating.

Real
Service

Displays the parameters you defined for the real service.

Project

If you are creating a new virtual service from the Get Started page, a new
virtualization project is created for the service. Click Change to modify the following
details:
l

Project. Enter a name for the project or accept the default name.

l

Path. Enter a path for the project or accept the default path.

l

Server. Select the server on which to deploy the virtual service.
You can select the Designer's embedded server, or a standalone Service
Virtualization Server. For details on adding Service Virtualization Servers, see
"How to Manage Service Virtualization Servers" on page 27.

Change

Opens a dialog box for the selected component, enabling you to modify settings for
your virtual service or real service.
When you are also creating a new project, you can also edit the project settings.

Virtualize Creates a new virtual service.

Endpoint Validation Dialog Box
This dialog box provides information in the event that endpoint validation fails.
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To access

When creating a new virtual service, or editing the endpoints for an existing
service, this dialog box opens automatically if endpoint validation fails for any
endpoint.

Important
The buttons displayed in this dialog box vary depending on the protocol you are
information using.
Relevant
tasks

"How to Create a Virtual Service" on page 92

See also

For details on defining the protocol-specific properties for your endpoints, see
"Service Properties Page" on page 102.

User interface elements are described below:
UI
Element

Description

Use
Uses the address suggested by the Service Virtualization agent, displayed in the
Suggested dialog box.
Add New
Agent

Opens the Agents Page and creates a new configuration of the agent. For user
interface details, see "Agents Page" on page 65.

Virtualization Explorer
The Virtualization Explorer displays the logical structure of your virtualization projects. It shows the
virtualization entities in your project, such as services, models, and topologies, in their hierarchical
structure. It also displays information on the server associated with your project.
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To access

The Virtualization Explorer is initially displayed, by default, on the sidebar or in
the left pane of the Service Virtualization window.
If not visible on the sidebar or in the left pane, from the main menu, select View
> Virtualization Explorer.

Important
information

Right-click virtualization entities in the project tree to view additional options.

User interface elements are described below:
UI
Element Description
project
tree

Displays the virtualization entities in your open project.
l

Select an entity in the tree to display its details in the lower pane.

l

Double-click an entity to open it in the main display pane.

l

Right-click an entity to view additional options.
Tip: Each virtualization entity is represented by a different icon. In addition, the
icons change to reflect current statuses. For example, a virtual service icon
indicates the service's current mode, such as Learning, and a server icon
indicates the server's current status, such as Online.
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Virtual Service Editor
The Virtual Service Editor enables you to control the mode of the virtual service and the models
currently in use, configure the endpoints, and configure security settings.

To access

In the Virtualization Explorer, double-click the virtual service you want to
view or edit.

Important
information

Some changes you make to the service may require that you restart the
service.

Relevant tasks

"How to Configure Virtual Services" on page 93

See also

l

"Virtual Service Overview" on page 86

l

"Service Virtualization Main Menus" on page 35

User interface elements are described below (unlabeled elements are shown in angle brackets):

General
UI Element

Description

<virtual service
name and
description>

The name and description of the Virtual Service. Click to edit.

HP Service Virtualization (3.10)

Page 113 of 299

User Guide
Chapter 3: Virtual Services

UI Element

Description

<status area>

Located in the upper-left part of the window, indicates the following:
l

The current mode of the service: Learning, Simulation, Standby or
Offline.

l

The data and performance models currently in use.

Puts the selected service into Learning Mode. Any communication through
the Virtual Service is added to the Simulation Model in this mode.
Use the drop down arrow to select which models to update:
l

Data & Performance (default)

l

Data Model

l

Performance Model

Starts the simulation according to the simulation models selected in the
Virtual Service Editor.
If the service was in Learning mode, Service Virtualization first finishes the
learning session and adds any data learned in the session to the Simulation
Model.
Puts the service into Standby Mode with the option of maintaining or
disposing of learned data.
Opens the Runtime Report to display current information about the service.

Simulation Models area
Manage the models associated with the virtual service.
UI Element

Description

Data Model

Select a data model to use with the service.
None. Enables you to pass messages to the real service and receive responses,
while still simulating performance according to the selected Performance Model.

Performance Select a performance model to use with the service.
Model
None. Causes the virtual service to respond as quickly as possible.
Offline. Simulates the unavailability of the service.
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UI Element

Description

Network
Model

The network model selected for the virtual service.
To select a different model, or to define a new model, click Manage Network
Models.
For details on network models, see "Network Virtualization Overview" on page
294.
Note: Network Virtualization is a Service Virtualization Labs feature. This
field is displayed only if you have enabled the feature. For details, see
"Service Virtualization Labs" on page 292.

Add

Opens the Add New Simulation Model dialog box, enabling you to add a new
data or performance model.

Edit

Opens the selected data or performance model in the relevant editor. For more
details, see "Data Model Editor" on page 187 or "Performance Model Editor" on
page 221.

Delete

Deletes the selected model.

Duplicate

Opens the Add New Simulation Model dialog box, enabling you to create a copy
of the selected data or performance model.

Service Configuration area
View or edit details of the real and virtual services, protocol, and agent currently in use.
UI
Element
Edit

Description
Opens the Edit Endpoints dialog box, enabling you to edit real and virtual service
information. For details, see "Edit Endpoints Dialog Box" on page 117.

Configure Opens the Agents page in the Options dialog box, enabling you to configure the
agent used by the virtual service. For details, see "Agents Page" on page 65.
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UI
Element
Message
Logging

Description
Enables logging.
Log files are stored in the following locations:
l

For a service running on the embedded server: Messages are stored in the
Designer log folder %APPDATA%\HewlettPackard\VirtualServiceDesigner\logs in the subfolder msg-embedded\[Virtual
Service Name], created when the first message is logged.
To open the Designer log folder, from the Windows Start menu, select Service
Virtualization > Designer > Designer Log Folder.

l

For a service running on a Service Virtualization Server: Messages are
stored in the Server log folder %ProgramData%\Hewlett-Packard\HP Service
Virtualization Server\logs, in the subfolder msg-standalone\[Virtual Service
Name], created when the first message is logged.
To open the Server log folder, from the Windows Start menu, select Service
Virtualization > Server > Server Log Folder.

Each message is stored in a single file named [Message Order Number]-[Message
Id].
Disable
Schema
Learning

Blocks changes to the service description during learning or message import.
This is useful when the service was created from an existing WSDL or schema, and
you want to ensure that messages with a different structure do not modify it.

Service Description area
Displays the service description and any metadata associated with the service.
UI
Element Description
Edit

Opens the Service Description Editor, enabling you to add new operations to the
service, or update metadata. For details, see "Service Description Editor" on page
224.
Note: Editing the service description is not supported for some protocols.

Update
From
File

Opens the Update Service Description dialog box, enabling you to replace the service
description file.
Note: Available only for SOAP services.
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Security Settings area
This area enables you to view and edit security settings.
UI
Element

Description

Edit
Opens the Edit Credential Store dialog box, enabling you to create and edit user
Credential identities. For details, see "Edit Credential Store Dialog Box" on page 266.
Store
Enabled

Turns message security on or off.

Mode

Default supported message security modes. For details, see "How to Set Message
Security" on page 256.

Real
Service
Identity

The identity of the real service, its certificate, is stored in the Credential Store. This
setting is used if a service uses a certificate for message security. The public key
of the certificate is used to encrypt messages sent to the real service.

Virtual
Service
Identity

The identity of the virtual service, its certificate, is stored in the Credential Store.
l

If the Real Service Identity contains the certificate with a private key, this
setting does not need to be configured. In this scenario, the Real Service
Identity is also used as the identity of the virtual service.

l

If the Real Service Identity contains only a certificate without a private key, this
setting must be configured to provide the identity of the virtual service. The
configured identity must contain a certificate with a private key, as the service
requires the private key to decrypt the messages coming from the client.

l

Clients must trust the certificate used as the identity of the virtual service.

Security
Applied
To

Indicates on which message parts security is applied - request elements, response
elements, or both.

Advanced
Settings

Opens the Advanced Message Security Settings dialog box. For details, see
"Advanced Message Security Settings Dialog Box" on page 267.

Default: Request and response.

Edit Endpoints Dialog Box
This dialog box enables you to edit the real and virtual service endpoints configured for your virtual
service.
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To access

In the Virtual Service Editor, under Service Configuration, click Edit.

User interface elements are described below:
UI Element

Description

Virtual/Real
Service

Virtual and real service information.
Note:
l

For details on Service Virtualization agent properties, see "Agents
Page" on page 65.

l

For details on protocol-specific endpoint properties, see "Service
Properties Page" on page 102.

Show Endpoint
Topology

Displays a diagram of your service endpoint configuration.

Test Endpoints

Checks that your endpoint is configured correctly.

Ignore WS
Addressing

WS-Addressing headers are not processed by Service Virtualization.
Available for SOAP services over HTTP, JMS, and Tibco EMS.

Change Server Dialog Box
These pages enable you to move the virtual services in a project to a different server.
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To access From the main menu, select Project > Change Server.
User interface elements are described below:
UI Element

Description

Runtime
Server

Select a server or enter the URL for a new server on which to deploy the virtual
services in the open project.
Note: The servers available in the drop-down list are the servers
configured in your project. To view, add, or delete servers, from the main
menu, select Tools > Options, and click the Servers tab.

Agent

Select an agent for each service.

Manage
Agents

Opens the Agents page, enabling you to add, delete, or reconfigure settings for
virtual service agents. For details, see "Agents Page" on page 65.

Duplicate
Opens the Agents page, and copies the configuration on the current server to
Original
create a configuration on the new server. You can modify the settings of the
Configuration new configuration.
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Projects and Solutions Page
The Projects and Solutions page enables you to:
l

define the default location for saving projects in the file system

l

set a password for project encryption

To access

1. From the main menu, select Tools > Options.
2. On the General page, click Projects and
Solutions.

Relevant tasks "How to Manage Virtualization Projects" on page 95
See also

l

"Virtualization Projects" on page 87

User interface elements are described below:
UI
Element
Default
project
location

Description
Enter a location in the file system for storing virtualization projects.

HP Service Virtualization (3.10)

Page 120 of 299

User Guide
Chapter 3: Virtual Services

UI
Element
Load
previous
solution
on startup

Description
When you open the Designer, Service Virtualization opens the
solution in which you were previously working.

Project
Enter a password to encrypt sensitive project data.
encryption
For more details on encryption, see "Password Encryption" on page
password
23.
Show
password

Temporarily displays the project encryption password.
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Simulation Overview
After a virtual service is created, you define simulation data. You can do this by manual design, or
by recording real service activity in order to learn about the requests and responses of the real
service. You can then use the recorded data to create data and performance models that define how
the virtual service should behave during simulation.
Before a simulation session, you can select which simulation models to use. The virtual service
can use both the data and performance models for simulation, or use them individually, as follows:
l

Turn off data simulation and let the real service respond. Only performance is simulated using
one of the performance models.

l

Turn off performance simulation. Response times are not affected. Only data is simulated using
one of the data models.

l

Simulate the unavailability of a service.

You manage the simulation process by manipulating virtual service modes:
l

Learning mode. The virtual service works as a proxy to record and learn the behavior of a real
service. The virtual service forwards the real communication between a client and a service. In
this mode, any communication through the virtual service is added to the virtual service's
simulation models.

l

Standby mode. The virtual service redirects requests to the real service, and redirects
responses from the real service back to the client. The virtual service is not learning, and not
simulating.

l

Simulating mode. The virtual service responds to client requests according to learned behavior
and the real service does not receive any communication. This is the main use of the virtual
service, and the mode you use for testing purposes.

During learning or simulating sessions, you can monitor service behavior.
For task details, see "How to Run Simulations" below.

How to Run Simulations
This task describes how to run simulations using your virtual services.

l

This task is part of a higher-level task. For details, see "How to Use Service Virtualization"
on page 25.

l

To learn more about virtual services, see "Simulation Overview" above.
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l

If a service is locked by another client, a message displays in the Virtual Service Editor. For
details, see "Service Locking" on page 126.

This task includes the following steps:
"Prerequisites" below
"Reconfigure clients" below
"Define simulation data" below
"Learn real service behavior" below
"Select simulation models" on the next page
"Simulate" on the next page
"Monitor all services" on the next page
"Optional: Adjust simulation models" on the next page
1.

Prerequisites
Create and configure virtual services.

2.

Reconfigure clients
Reconfigure your client to use the virtual service endpoints in place of the real service
endpoints. This is required in cases where Service Virtualization can only perform intrusive
virtualization.

3.

Define simulation data
You can define the data from scratch in the Data Model Editor. For task details, see "How to
Edit a Data Model" on page 157.
Alternatively, you can define the data by recording real service behavior, as described in the
next step.

4.

Learn real service behavior
Record the behavior of the real service in order to see the actual requests and responses.
a. In the Virtual Service Editor, click Learn to record real service activity. The information is
saved in the virtual service's data and performance models. For user interface details, see
"Virtual Service Editor" on page 113.
Alternatively, you can choose to save only some of the collected data. Click the Learn
drop-down arrow to select a simulation model to which you want to save recorded data.
b. Run the application communicating with the real service. Service calls are recorded.
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c. To view the learned data after recording, open the Data Model Editor and click the Learned
Data rule. For user interface details, see "Data Model Editor" on page 187.
5.

Select simulation models
In the Virtual Service Editor, select a data model and a performance model to use during
simulation.
Note:
To simulate the unavailability of a service, select the Offline performance model.
You can also choose to use just one of the simulation models, by selecting None for either
the data or performance model.

6.

Simulate
a. In the Virtual Service Editor, click Simulate to place the virtual service in Simulating mode.
The virtual service is ready to respond to client requests . The real service does not receive
any communication.
b. Run your client application. The virtual service responds to requests, and returns
responses based on its associated simulation models.
c. When you want to complete the simulation session, click Stop to move the virtual service
into Standby mode. Client requests are then answered by the real service.

7.

Monitor all services
You can monitor virtual service activity in the following ways:
a. Runtime View. View and control all of the virtual services in your project. During a learning
or simulation session, the Runtime View provides an overview of the communication
through the virtual services. From the main menu, select View > Runtime View.
b. Problem List. View errors, warnings, and informational messages about events that
occurred during the application or server run. From the main menu, select View > Problem
List.
c. Service Administration. View and manage all services from configured servers, without
opening individual projects. On the Start Page, click Service Administration.
Alternatively, from the main menu, select View > Service Administration.
d. Service Virtualization Management. View and manage services from multiple Service
Virtualization projects and servers in a web browser, without opening the projects. For
details, see "Service Virtualization Management" on page 132.

8.

Optional: Adjust simulation models
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You can make adjustments to the data and performance models associated with your virtual
services. For example, if you are simulating a service based on learned data, you may need to
customize some aspect of the virtual service behavior that is not addressed. For details, see
"How to Edit a Data Model" on page 157 and "How to Edit a Performance Model" on page 183.

Service Locking
If a service is locked by another client, the following message displays in the Virtual Service Editor:

The Service Virtualization Designer or a test emanating from HP LoadRunner / HP Service Test,
may need to know that they own a virtual service, or that virtual service is available, in order to
prevent conflicts. They may also need to know who the present owner of a service is, as a service
can be owned by only one client at a time. If a service is locked by the owner, other clients can see
who the owner is, as each client has a unique “client ID”.
When a service is locked, its configuration and all of its data and performance models are also
locked. The owner of the service can modify the service and its model, but other clients cannot. If a
user tries to modify the service or its model, a message displays indicating that the service is
locked, and specifying which client is the owner of the service. If a Designer or a test is the owner,
then modification is permitted.
To unlock a locked service:
If a technical problem occurs or a test runs too long, you can force an unlock in the Service
Virtualization Designer. To unlock the service, from the Runtime View or Service Administration,
under More Actions, select Unlock.
Note: No changes are allowed to a service and its models during the learning process. This
process must be completed regardless of the owner of the virtual service. Unlock is not
available during this time.

Simulation User Interface
This section includes:
Runtime View

127

Problem List

128

Service Administration

129
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Runtime View
The Runtime View enables you to view and control all of the virtual services in your project. During
a learning or simulation session, the Runtime View provides an overview of the communication
through the virtual services.

To access

From the main menu, select View > Runtime View.

Important
information

The context menu enables you to show/hide data columns on the page.
Right-click to view.

Relevant tasks

"How to Run Simulations" on page 123

See also

"Virtual Service Overview" on page 86

User interface elements are described below.
UI Element

Description
Puts the selected service into Learning Mode. Any communication through the
Virtual Service is added to the Simulation Model in this mode.
Use the drop down arrow to select which models to update:
l

Data & Performance (default)

l

Data Model

l

Performance Model

Starts the simulation according to the simulation models selected in the Virtual
Service Editor.
If the service was in Learning mode, Service Virtualization first finishes the
learning session and adds any data learned in the session to the Simulation
Model.
Puts the service into Standby Mode with the option of maintaining or disposing
of learned data.
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UI Element

Description
Includes the following:
Info. Opens the Runtime Report to display current information about the
service.
Unlock. Unlocks the selected service. For more details, see "Service Locking"
on page 126.
Undeploy. Undeploys the selected service.

All

Enables you to filter the displayed services according to virtual service mode.
Click the arrow to display the filter options.

Data Model

The data model currently in use for the selected service.
Click the name link to open the model in the Data Model Editor.

Endpoints

The URL of the real service.

Info

Located under the More Actions menu. Opens the Runtime Report to display
current information about the service.

Messages
(Unique)

The number of messages and unique messages passed through the virtual
service during the current learning or simulation session.

Performance
Model

The performance model currently in use for the selected service.

Project

The project to which the service belongs.

Server

The server running the selected service.

Status

The number of problems that occurred.

Undeploy

Located under the More Actions menu. Undeploys the selected service.

Unlock

Located under the More Actions menu. Unlocks the selected service. For more
details, see "Service Locking" on page 126.

Virtual
Service

Displays the list of all services from configured servers. Click on a service
name to open the service in the Virtual Service Editor.

Click the name link to open the model in the Performance Model Editor.

Problem List
The Problem List displays errors, warnings, and informational messages about events that
occurred during the application or server run. The source of problems can be either runtime errors in
the application, or a problem occurring during a service lifecycle. For example, during deployment,
or while in Standby, Learning, or Simulating modes.
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To access

From the main menu, select View > Problem List.

Important
By default, the information displayed is automatically filtered according to the
information editor that is open. For example, if you open the Virtual Service Editor, the
Problem List displays problems related to the service. If you open the Data Model
Editor, problems are filtered for issues related to the data model.
Relevant
tasks

"How to Run Simulations" on page 123

See also

"Simulation Overview" on page 123

User interface elements are described below (unlabeled elements are shown in angle brackets):
UI Element

Description

<message filter>

Enables you to filter the messages according to type:
Errors, Warnings, Information.
By default, only Errors and Warnings are displayed.
Click the arrow to change the filter options.

Type

The problem category and number of occurrences.

Fix It

If the problem can be resolved with user interaction, a
link is displayed. The link connects you to the part of
the application that may be the source of the problem.

Source Service Filter

Enables you to filter for a specific service call or
display All Sources.

Description

A description of the problem.

Time

Time and date that the problem occurred.

Service Administration
This page enables you to view and manage all services from configured servers, without opening
individual projects. All virtual services are displayed with their statues, associated models, and
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server locations. You can change selections for simulation models in use, and view the server on
which a service is deployed.

To access

From the Start Page, click Service Administration.

Important
information

The context menu enables you to show/hide data columns on the page.
Right-click to view.

Relevant tasks

"How to Run Simulations" on page 123

See also

"Virtual Service Overview" on page 86

User interface elements are described below:
UI Element

Description
Not enabled in Service Administration. To place services in Learning mode, you
must use the Virtual Service Editor in an open project.
Starts the simulation according to the selected simulation models. You can
choose different models using the Data Model and Performance Model
columns.
If the service was in Learning mode, Service Virtualization first finishes the
learning session and adds any data learned in the session to the Simulation
Model.
Puts the service into Standby Mode with the option of maintaining or disposing
of learned data.
Includes the following:
Manage Servers. Opens the Servers tab of the Options dialog box, enabling
you to add and delete servers.
Info. Opens the Runtime Report to display current information about the
service.
Unlock. Unlocks the selected service. For more details, see "Service Locking"
on page 126.
Undeploy. Undeploys the selected service.
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UI Element

Description

All

Enables you to filter the displayed services according to virtual service mode.
Click the arrow to display the filter options.

Data Model

The data model currently in use for the selected service. Click the arrow to
select a different data model.
When you change a model, an asterisk is displayed next to the model name,
indicating that the change was not yet applied. To apply the new model, you
must redeploy the relevant service by changing its mode to Standby or
Simulate.

Endpoints

The URL of the real service.

Info

Located under the More Actions menu. Opens the Runtime Report to display
current information about the service.

Manage
Servers

Located under the More Actions menu. Opens the Servers tab of the Options
dialog box, enabling you to add and delete servers.

Messages
(Unique)

The number of messages and unique messages passed through the virtual
service during the current learning or simulation session.

Performance
Model

The performance model currently in use for the selected service. Click the
arrow to select a different performance model.
When you change a model, an asterisk is displayed next to the model name,
indicating that the change was not yet applied. To apply the new model, you
must redeploy the relevant service by changing its mode to Standby or
Simulate.

Project

The project to which the service belongs.

Server

The server running the selected service.

Status

The number of problems that occurred. Click to display details in the Problems
List.

Undeploy

Located under the More Actions menu. Undeploys the selected service.

Unlock

Located under the More Actions menu. Unlocks the selected service. For more
details, see "Service Locking" on page 126.

View

Enables you to filter the displayed services according to server. Click the arrow
to display the filter options.

Virtual
Service

Displays the list of all services from configured servers. Click on a service
name to open the service in the Virtual Service Editor.
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Service Virtualization Management Overview
Service Virtualization Management enables you to view and control services from multiple Service
Virtualization projects and servers in one location, without opening the projects. You can:
l

View a summary of all service activity on a server.

l

Start and stop simulations.

l

Undeploy services.

l

Deploy additional virtualization projects and services located in HP Application Lifecycle
Management (ALM) or in the file system.

After you create and configure virtual services in the Service Virtualization Designer, the services
can be deployed on any Service Virtualization Server. Service Virtualization Management provides
a convenient method for allowing others to access and manage virtual services deployed on any
Service Virtualization Server. For example, anyone performing testing can work with the virtual
services from a browser window, with no additional installation or configuration.
In addition, Service Virtualization Management enables you to consume virtual services that are
stored in a network location. You can download virtual services to your Service Virtualization
Server, without the need to install the Service Virtualization Designer.
Note:
l

When you are working with a secured Service Virtualization Server, the actions available to
you and the information displayed vary, based on your user access permissions. For
example, a user who is not assigned to any of the Service Virtualization user groups cannot
view any agent data or any services deployed on the server. For details on the Service
Virtualization user groups, see the HP Service Virtualization Installation Guide.

l

The Service Virtualization service, Server, and Management versions must match. If the
service/project was created in an earlier version, open it in the Designer to upgrade the
project to the new version.

For task details, see "How to Get Started Using Service Virtualization Management" below.

How to Get Started Using Service Virtualization
Management
This task describes how to start working with the Service Virtualization Management interface.
To learn more about Service Virtualization Management, see "Service Virtualization
Management Overview" above.

HP Service Virtualization (3.10)

Page 133 of 299

User Guide
Chapter 5: Service Virtualization Management

This section includes:
l

"Prerequisites" below

l

"Start/stop the Service Virtualization Management service" below

l

"Open Service Virtualization Management" below

l

"Manage virtual services in Service Virtualization Management" on the next page

l

"Troubleshoot" on the next page

Prerequisites
l

Make sure you are using a supported browser:
n

Microsoft Internet Explorer 8, 9, and 10

n

Mozilla Firefox

n

Google Chrome
Note: For the most up-to-date list of supported browsers and versions, refer to the support
matrix on the HP Software Support site at: http://h20230.www2.hp.com/sc/support_
matrices.jsp, or contact support.

l

Make sure that the Service Virtualization Server is running.

Start/stop the Service Virtualization Management service
1. On the Service Virtualization Server machine, from the Windows Start menu, select All
Programs > HP Service Virtualization > Server 3.10 > Management Interface - Start
Service.
2. To stop the service, from the Windows Start menu, select All Programs > HP Service
Virtualization > Server 3.10 > Management Interface - Stop Service.

Open Service Virtualization Management
Open a browser window and enter one of the following URLs:
l

The Service Virtualization Management URL:
https://<Service Virtualization Server IP or hostname>:<Service Virtualization
Management port>
By default, the Service Virtualization Management port is 6086.

l

The Service Virtualization Server URL:
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<Service Virtualization Server IP or hostname>:<HTTP/HTTPS port
number>/management
For more details on Service Virtualization network ports, see the HP Service Virtualization
Installation Guide.

Manage virtual services in Service Virtualization Management
For details on working with Service Virtualization Management, see the online help inside Service
Virtualization Management. In the upper-right corner, click the down arrow and select Help.

Troubleshoot
If an issue arises, review the web server and proxy logs, located in %ProgramData%\HewlettPackard\HP Service Virtualization Server\ManagementInterface\logs.
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Command Line Management Overview
You can manage virtual services deployed on a Service Virtualization Server using the
SVConfigurator command line tool.
SVConfigurator is Java-based and can be used by both Windows and Unix/Linux operating
systems.
Working from a command prompt, you can:
l

deploy virtual services to any Service Virtualization Server

l

change the runtime mode of a virtual service

l

view virtual service details, such as service name, ID, mode, deployment state, and data and
performance models

l

list all deployed virtual services

l

unlock a virtual service locked by another user
For task details, see "How to Manage Virtual Services from the Command Line" below.

How to Manage Virtual Services from the
Command Line
This task describes how to manage virtual services deployed on a Service Virtualization Server
from the command line. You can list, view, deploy, unlock, or change the mode of the services.
To learn more about managing virtual services from the command line, see "Command Line
Management Overview" above.
This section includes:
l

"Prerequisites" on the next page

l

"Deploy services" on the next page

l

"Change service mode" on page 139

l

"View service details" on page 141

l

"List services" on page 142

l

"Unlock services" on page 143
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Prerequisites
To work with an encrypted project, you must install Java Cryptography Extension (JCE) Unlimited
Strength Jurisdiction. Select one of the following, based on the Java version with which you are
working:
l

For JDK 1.6: http://www.oracle.com/technetwork/java/javase/downloads/jce-6-download429243.html

l

For JDK 1.7: http://www.oracle.com/technetwork/java/javase/downloads/jce-7-download432124.html

Deploy services
Deploy or undeploy a virtualization project, or a single service from the project to the Service
Virtualization Server.
1. Do one of the following:
n

On the Service Virtualization Server, open a command prompt. Navigate to the \bin folder
under the Service Virtualization Server installation folder. By default, C:\Program
Files\HP\HP Service Virtualization Server\Tools\SVConfigurator\bin\.

n

On the Service Virtualization Designer machine, open a command prompt. Navigate to the
\bin folder under the Designer installation folder. By default, C:\Program Files (x86)\HP\HP
Service Virtualization Designer\Tools\SVConfigurator\bin\.

2. Run SVConfigurator.cmd DEPLOY [options] <project file> at the command line, using the
following options:
Note: For Linux, use SVConfigurator.sh.
Option

Description

Required
parameters
<project file>

Path to a project file (.vproj or .vproja) whose services you want to deploy
on the server.

Optional
parameters
-w
or
--projectpassword

If the project is encrypted, specifies a password to decrypt the project
content.
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Option

Description

-f
or
--force

Force mode. If the service to be deployed is locked, the command
automatically unlocks it. It is then automatically locked by
SVConfigurator. Use caution with this option as you can delete another
user’s data.

-u
or
--undeploy

Undeploys the project or service from the server.

-s <svc>
or
--service
<svc>

Deploys only the specified service. You can specify a service by its name
or ID.

-url <url>
or
--mgmt-url
<url>

URL of the server’s management endpoint.

-usr <user>
or
--username
<user>

Username for the server’s management endpoint.

-pwd <pwd>
or
--password
<pwd>

Password for the server’s management endpoint.

Tip: Use the List or View commands to find a service ID.

Change service mode
Change the runtime mode of a service on the Service Virtualization Server to Learning, Simulating,
or StandBy mode.
1. Do one of the following:
n

On the Service Virtualization Server, open a command prompt. Navigate to the \bin folder
under the Service Virtualization Server installation folder. By default, C:\Program
Files\HP\HP Service Virtualization Server\Tools\SVConfigurator\bin\.

n

On the Service Virtualization Designer machine, open a command prompt. Navigate to the
\bin folder under the Designer installation folder. By default, C:\Program Files (x86)\HP\HP
Service Virtualization Designer\Tools\SVConfigurator\bin\.

2. Run SVConfigurator.cmd CHANGEMODE [options] <service identification> <service
mode> at the command line, using the following options:
Note: For Linux, use SVConfigurator.sh.
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Option

Description

Required
parameters
<service
identification>

Identification of the service you want to view. You can use either the
name or ID of the service.
If there is more than one service with the same name on the server, you
have to either specify the project file where the service is located (using
the optional –p parameter below), or identify the service by its ID.
Tip: Use the List command to find a service ID.

<service
mode>

The mode you want to switch the service to.
Available options: SIMULATING, STAND_BY

Optional
parameters
-f
or
--force

Force mode. If the service to be deployed is locked, the command will
automatically unlock it. It is then automatically locked by SVConfigurator.
Use caution with this option as you can delete another user’s data.

-dm <model>
or
--data-model
<model>

The data model to be used, specified by its name or ID.
You must specify this parameter for Learning and Simulation modes.
Tip: Use the View command to find the service's data models.

-pm <model>
or
--perf-model
<model>

The performance model to use, specified by its name or ID.
You must specify this parameter for Learning and Simulation modes.
Tip: Use the View command to see the service's performance models.

-p <source_
path>
or
--project
<source_path>

Project file (.vproj or .vproja). Specify the project file in order to
differentiate the services on the server. If there is more than one service
with the same name but in different projects, and you want to identify the
service by name, you must specify the project file.

-w
or
--projectpassword

If the project is encrypted, specifies a password to decrypt the project
content.
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Option

Description

-url <url>
or
--mgmt-url
<url>

URL of the server’s management endpoint.

-usr <user>
or
--username
<user>

Username for the server’s management endpoint.

-pwd <pwd>
or
--password
<pwd>

Password for the server’s management endpoint.

View service details
View information about a service deployed on the Service Virtualization Server, such as service
name, ID, mode, deployment state, and data and performance models.
1. Do one of the following:
n

On the Service Virtualization Server, open a command prompt. Navigate to the \bin folder
under the Service Virtualization Server installation folder. By default, C:\Program
Files\HP\HP Service Virtualization Server\Tools\SVConfigurator\bin\.

n

On the Service Virtualization Designer machine, open a command prompt. Navigate to the
\bin folder under the Designer installation folder. By default, C:\Program Files (x86)\HP\HP
Service Virtualization Designer\Tools\SVConfigurator\bin\.

2. Run SVConfigurator.cmd VIEW [options] <service identification> at the command line,
using the following options:
Note: For Linux, use SVConfigurator.sh.
Option

Description

Required
parameters
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Option

Description

<service
identification>

Identification of the service you want to view. You can use either the
name or ID of the service.
If there is more than one service with the same name on the server, you
have to either specify the project file where the service is located (using
the optional –p parameter below), or identify the service by its ID.
Tip: Use the List command to find a service ID.

Optional
parameters
-r
or
--report

Displays the runtime report for the service.

-p <source_
path>
or
--project
<source_path>

Project file (.vproj or .vproja). Specify the project file in order to
differentiate the services on the server. If there is more than one service
with the same name but in different projects, and you want to identify the
service by name, you must specify the project file.

-w
or
--projectpassword

If the project is encrypted, specifies a password to decrypt the project
content.

-url <url>
or
--mgmt-url
<url>

URL of the server’s management endpoint.

-usr <user>
or
--username
<user>

Username for the server’s management endpoint.

-pwd <pwd>
or
--password
<pwd>

Password for the server’s management endpoint.

List services
List the services deployed on the Service Virtualization Server, and view basic service information,
such as service name, mode (learning, simulating, standby, offline), and ID.
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1. Do one of the following:
n

On the Service Virtualization Server, open a command prompt. Navigate to the \bin folder
under the Service Virtualization Server installation folder. By default, C:\Program
Files\HP\HP Service Virtualization Server\Tools\SVConfigurator\bin\.

n

On the Service Virtualization Designer machine, open a command prompt. Navigate to the
\bin folder under the Designer installation folder. By default, C:\Program Files (x86)\HP\HP
Service Virtualization Designer\Tools\SVConfigurator\bin\.

2. Run SVConfigurator.cmd LIST [options] at the command line, using the following optional
parameters:
Note: For Linux, use SVConfigurator.sh.
Option

Description

-p <source_
path>
or
--project
<source_path>

Project file (.vproj or .vproja). Specify the project file in order to list only
the deployed services in the specified project.

-w
or
--projectpassword

If the project is encrypted, specifies a password to decrypt the project
content.

-url <url>
or
--mgmt-url
<url>

URL of the server’s management endpoint.

-usr <user>
or
--username
<user>

Username for the server’s management endpoint.

-pwd <pwd>
or
--password
<pwd>

Password for the server’s management endpoint.

Unlock services
Unlock a service deployed on the Service Virtualization Server that is locked by another user. You
can then lock it by your client.
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1. Do one of the following:
n

On the Service Virtualization Server, open a command prompt. Navigate to the \bin folder
under the Service Virtualization Server installation folder. By default, C:\Program
Files\HP\HP Service Virtualization Server\Tools\SVConfigurator\bin\.

n

On the Service Virtualization Designer machine, open a command prompt. Navigate to the
\bin folder under the Designer installation folder. By default, C:\Program Files (x86)\HP\HP
Service Virtualization Designer\Tools\SVConfigurator\bin\.

2. Run SVConfigurator.cmd UNLOCK [options] <service_identification> at the command
line, using the following options:
Option

Description

Required
parameters
<service
identification>

Identification of the service you want to view. You can use either the
name or ID of the service.
If there is more than one service with the same name on the server, you
have to either specify the project file where the service is located (using
the optional –p parameter below), or identify the service by its ID.
Tip: Use the List or View commands to find a service ID.

Optional
parameters
-p <source_
path>
or
--project
<source_path>

Project file (.vproj or .vproja). Specify the project file in order to
differentiate the services on the server. If there is more than one service
with the same name but in different projects, and you want to identify the
service by name, you must specify the project file.

-l
or
--lock

Locks the service by your client lock immediately after unlocking.

-w
or
--projectpassword

If the project is encrypted, specifies a password to decrypt the project
content.
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Option

Description

-url <url>
or
--mgmt-url
<url>

URL of the server’s management endpoint.

-usr <user>
or
--username
<user>

Username for the server’s management endpoint.

-pwd <pwd>
or
--password
<pwd>

Password for the server’s management endpoint.
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Simulation Modeling Overview
Simulation models define the functional and performance behavior that the virtual service supplies
during simulation. You can manually customize simulation models, or put the virtual service in
Learning mode to record real service behavior and performance. This learned data is then added to
the virtual service's models, for use during simulation.
When you create a virtual service, Service Virtualization creates a data model and a performance
model, and links them to the virtual service. These models serve as the default models for learning
and simulation sessions. You can associate each virtual service with multiple data and
performance models. Prior to a learning or simulation session, you can select which data and
performance models to use.
l

Data Model
The Data Model enables you to record actual requests and responses for a real service and then
use this data for simulation using a virtual service. You can create and customize the data model
to meet your needs. You can use recorded data as a basis for your data model, and also add new
learned data, add service calls, and model stateful behavior. You can also add custom data, or
add data from an external data source. This enables you to model the interaction between the
service under test and the simulated service to meet many integration test cases. For details,
see "Data Model Overview" on the next page.

l

Performance Model
The Performance Model enables you to record the performance for a real service and then use
this as a model for a virtual service. You can customize the performance criteria of the model to
meet many performance use cases. For details, see "Performance Model Overview" on page
155.
For task details, see "How to Manage Simulation Models" on page 156.

This section also includes:
Data Model Overview
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150
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Data Model Overview
The data model enables you to customize message requests and responses to manipulate the
simulated behavior of a virtual service. Each virtual service is associated with at least one data
model which can contain the recorded behavior of the service and also customized data for
simulation. Each data model contains a set of rules defining data behavior for each operation in the
service, and tracks to determine the order of stateful behavior.
When you create a virtual service, Service Virtualization creates a data model associated with it.
The data model can be customized to set specific data rules for its individual operations.
Each virtual service can have multiple data models. Prior to a Learning session, in which real
service behavior is recorded, you can select the data model to which you want to save the learned
behavior. After recording, you can use this data model to mimic real service behavior during
simulation.

Data Rules
The data model consists of a set of data rules for each operation in the service. You can configure
the model using the Service Virtualization default rules and functions, or create your own to
customize simulated behavior.
The following types of rules are available:
l

Learned Data Rule
The Learned Rule stores the requests and responses from learning sessions. In general, you do
not customize this data but you may want to set conditions to ignore parts of the requests and
responses and add service call activity.

l

Default Response Rule
The Default Response provides a custom response for each response type or data format, to
apply in cases where there is no other data, or where you want to ignore specific parts of
recorded response data. The default responses are generated automatically, but you can edit
them. The Default Response is used if no other rule matches the response data.

l

Custom Rules
Custom Rules enable you to manipulate some aspect of the simulated behavior. You can set
custom responses and service call activity to specific requests enabling you to perform various
testing use cases.
There are two types of custom rules:
n

Blank rules. New, empty rules enable you to customize any element of a message. For
example, you may find that your learned data rule is too specific, providing you with an
incomplete response. You can create a new rule to customize one element of the message,
enabling you to continue to use learned data for other elements.
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n

Data driven rules. Data driven rules are used to bind request and response data from an
external data source. The data can then be used by multiple applications or exported from
external applications, such as HP Service Test, HP LoadRunner, or HP QuickTest. The data
source can be edited by an external application and then refreshed in the data model.

Data Rule Configuration
You can configure rules in the following ways:

Rule Prioritization
You can set the priority of multiple rules to determine the order in which each rule is applied during
simulation. This enables you to meet various simulation testing use cases. Generally, rules are
applied in the following order:
1. Custom rules or external data rules. Custom rules can be used, for example, for requests that
cannot be recorded or have not yet been recorded.
They can be placed before or after the Learned Data rule.
2. The Learned Data rule, to provide typical responses and service call activity of the real service.
3. The Default Response rule, to provide a single generic response or generic parts of response
data where other rules do not apply.
You can also temporarily disable a rule. A disabled rule is not applied during simulation.

Service Call Activity
In many cases, the simulated service can call another service to perform some particular operation
or to receive some additional data. Virtual services can simulate this behavior by adding service call
activity to an operation. You can define static request data for the service call activity for any row in
the rule or copy data from the virtual service request or from the response of another service call
activity. If a called service also has a response, you can copy some response data from a service
call activity to a virtual service response.

Tracks
Another main feature of the data model are tracks. Tracks determine the order of the simulated
service behavior.
In many test cases, the order of requests is important because a service may return different
responses for the same request depending on the current state of the service. Service Virtualization
enables you to simulate this stateful behavior using tracks. Tracks enable you to construct
sequences of requests and responses in the data model for the service. During a simulation
session, Service Virtualization moves along the tracks according to test requests that match the
requests in the track and returns the appropriate response. For example, if the simulated service
can return an approve or deny response which is determined by a particular state of the service, you
can determine which response to return by specifying the sequence of requests and responses in
the track.
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Import Messages
New rows can be added to a rule by learning new data, by adding a new row and manually editing its
cells, or by importing messages.
Importing messages is useful in the case when it is not possible or it is difficult to learn
communication between a tested application and a simulated service directly, but it is possible to
listen to the communication and log transported messages via another tool. It is possible to import a
request and/or response part of the message in the same format as it is sent via communication
protocol from a clipboard or from a file. For example, you may have an SDK that includes sample
messages which you can copy. If a message is imported from a file, the file may contain only the
request or response part of one message.

Multi Response
In addition to the simple simulation of a request-response pattern, Service Virtualization can
simulate a request-response pattern where 0 to n responses are given per request. The number of
responses can vary based on the service state. An operation may have a one-way pattern, such as
clearing a shopping cart, or may include multiple responses. For example, as part of an order
processing update, responses could include “order received”, “order opened”, and “order shipped”.
Service Virtualization enables both the learning and editing of multiple responses, their types, and
their service states. For performance simulation, learning and simulation is limited to the response
time of the first response. If learned data includes multiple responses, Service Virtualization looks
only at the first response time. During simulation, all responses are sent at that first response time.
These features are available on both the Service Virtualization standalone server, and the
embedded server. The supported protocols are XML and binary services over WebSphere MQ and
JMS.
For task details, see "How to Edit a Data Model" on page 157.
To learn more, see also:
l

"Rule Functions" below

l

"Data Driving" on page 153

Rule Functions
The data model is made up of rules that define the behavior of the virtual service. The rules are
made up of rows, in which each row represents a response/request pair. Rule functions are used to
define the behavior of the responses, in order to directly impact the simulation. Functions are set on
a per column, per operation basis.
Each rule contains the following:
l

Condition functions. Mainly used to evaluate data in request columns, to determine the
appropriate response.

l

Action functions. Used to manipulate data in response columns. Action functions cannot be
used in request columns.
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When the simulation is in progress, the simulator engine walks through each rule according to rule
priorities, looking for a single row in each rule that most precisely conforms to the condition
functions used. When a single data row is selected, all the action functions are applied to that row.
Example:
Suppose your scenario is to retrieve credit card data according to customer name.
l

The name data is your request, and you would define it with the Is condition function.

l

The credit card data is your response, and you would define it with the Set action function.

So, if the customer name is Jane Doe and her credit card number is 1234-5678-1234-5678, one
row in your rule would be as follows:
The request data is Jane Doe, where the function used = Is.
The response data uses the function Set, which sets the response to 1234-5678-1234-5678.
There are several categories of functions in Service Virtualization:
l

"Basic default functions" below

l

"Array functions" on the next page

l

"Dynamic data functions" on page 153

l

"Custom functions" on page 153

Basic default functions
Default condition functions:

l

n

Is. If the incoming message data matches the value of this field, Service Virtualization
performs the response action defined in this row.

n

Ignore. If the incoming message data matches the value of this field, Service Virtualization
ignores the data. It does not impact the simulation.

Default action functions:

l

n

Set. The simulation returns the response that is listed in this field.

n

Copy from. The simulation takes the value of another field and returns it as the response.

Note:
l

For the Learned Data rule, request columns are defined as Is, and response columns are
defined as Set.
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l

In a new, custom rule, the default function for all columns is Ignore. The data in the column
does not influence the simulation in any way.

l

If you type a value in a cell, the function is automatically set to Is or Set.

Array functions
The following functions are available for use when the message includes an array data structure:
l

l

Condition functions:
n

Compare ordered. This condition is met when items in an array match and are in the same
order.This is the default condition function for arrays.

n

Compare unordered. This condition is met when items in an array match, but may be in a
different order.

Action functions:
n

Replace array. Sets the response to the relevant array values. Generates array items for the
response data according to the number of array items in the rule's matching row.

n

Set array items count. Enables you to define a set number of array items for the action to
create in the response.

n

Copy array items count. Generates the same number of array items as are in an array that
you select. (You select the source array the same way you select a source element for the
Copy From function.)

n

Array template. Does not generate any array items in the response, but fills existing array
items with values from array items in the rule's matching row. If the rule's matching row does
not contain enough array items to fill values in all existing array items in the response, this
action uses the value of the last array item as a template for all the remaining array items in
the response.
Example:
You can create a rule with the highest priority in the data model, and use the Set Array
Items Count to create a specified number of empty array items. Assign an Ignore action to
the array items so that they remain empty and another rule can overwrite their values.
Then create a lower priority rule, using the Array Template action, with a Set action on the
array items to fill in the values in the response. You can also use one of the dynamic data
functions, such as the random number generator function, to fill the values of the array
items with meaningful response data.
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Dynamic data functions
You can generate dynamic data in certain elements of the responses using the Service
Virtualization data generator functions.
There are several types of dynamic data functions:
l

Sequential number generator. Generates a series of increasing/decreasing numbers in a
specified format. The number increases/decreases by a predefined value with each received
request.

l

Set relative date/time. Generates a date and/or time that is relative to the time of the request
arrival. For example: time of request arrival plus 2 hours and 5 minutes.

l

Set date/time relative to. Generates a date and/or time that is relative to a date/time that is
stored in any element of the request. For example: time stored in a certain element minus 3 days
and 5 hours.

l

Random number generator. Generates a random sequence of integers.

l

Substring. The simulation takes a substring of a value in another field that you select, and
returns it as the response.

Custom functions
You can define custom functions to manage more complex conditions. These are to be used by an
advanced user aware of the complete system structure. Complex conditions can be set with
structured query language.
There are two classes of variables:
l

Input ($input_*). Input variables are those present in a processing row during simulation. A
more simplified explanation of Input variables is that they are data from requests.

l

Data ($data_*). Data variables represent data written in the cell.
For task details, see "How to Define Rule Functions" on page 160.

Data Driving
To facilitate data-driven testing, you can add external data sources to your virtual services.
When you associate an external data source with a virtual service, you need to create mappings
between the data columns in the external file, and the columns/headers in your data rule. You do
this by configuring binding in the data model.

Array Binding
You can also bind array data. When the message structure contains an array that needs to be datadriven, you need to work with a properly structured Excel file. The file must contain database-like
relationships, using primary and foreign keys, which allow the mapping of one row to many. You
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can create the file manually, or by exporting learned data that is in the desired format to a new Excel
file.
The following example shows the relationship between a search definition and the search result. A
record in the Search worksheet is identified via its primary key ‘id’, and referenced from the Search
Result worksheet via the foreign key ‘searchId’. This enables the return of two rows for a search
with id 3, or zero rows for search of id 4.

Data Format Binding
When binding to an Excel worksheet column where the response can contain different data formats
(such as for the REST protocol), different response types (such as for the SOAP protocol), or a
message structure which can be considered to contain different types, you can also configure
binding for this in your data model.
You can configure mappings between real types or formats and cell values, and provide a default
value that is used when no value from the mapping table matches. You can configure a value for
each possible type or format.
For task details, see "How to Work With External Data Sources" on page 178.

Simulation Preview
Simulation Preview enables you to view in real time how changes in the data model affect your
simulation.
You can:
l

Test changes. Make changes to a data rule, or to data in a row, and examine the impact on the
simulated response.
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l

Assess change impact. Make a change in one part of the data model, and examine the impact
on the simulation.

l

Troubleshoot. Determine why a learned request does not match any rules in your data model.

For task details, see "How to Assess Change Impact" on page 181.
For user interface details, see "Simulation Preview Pane" on page 198.

Performance Model Overview
The Performance Model enables you to customize the performance of a service during simulation.
When you create a Virtual Service, Service Virtualization creates a Performance Model associated
with it. This model is then available to learn the performance of the real service and can be
customized to set specific performance rules either for the whole service, or its individual
operations.
Each virtual service can have multiple performance models. Prior to a Learning session, in which
real service behavior is recorded, you can select the performance model to which you want to save
the learned behavior. Prior to simulation, you can select which model to use to mimic real service
behavior, including non-customizable models to ignore the performance or simulate the
unavailability of a service.
You can configure the Performance Model in the following ways:

Basic Performance Criteria
Set levels for the following performance criteria for specific operations of the service:
l

Response Time [ms] - the time for the service to process a request and return a relevant
response.

l

Threshold [hits/s] - the maximum number of requests and responses the service can process
without any impact on performance.

l

Throughput Limit [MB/s] - the maximum data capacity the service can process.

Advanced Performance Criteria
In addition to the basic criteria, set levels for the following criteria for specific operations of the
service:
l

Tolerance [%] - the acceptable range of variation in performance for the operation.

l

Maximum Hits per Second - the maximum number of requests and responses the operation is
allowed to process.

l

Maximum Response Time - the maximum time for a response at peak performance levels.
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Boosters
There are a number of boosters available which you can use to manipulate some aspect of the
service performance. Service Virtualization applies the selected boost to the relevant performance
criteria during simulation.
The boosters include:
l

CPU. CPU power multiplication factor. Impacts the response time of the service.

l

Network. Network throughput multiplication factor. Impacts the throughput limit.

l

Cluster. Scalability multiplication factor. Impacts all measures simultaneously - response time,
hit rate, threshold, and throughput limit.

l

Expert. Multiplication factors for response time, hit rate, and throughput limit values. You can
change each measure separately.
For task details, see "How to Manage Simulation Models" below and "How to Edit a
Performance Model" on page 183.
For user interface details, see "Performance Model Editor" on page 221.

How to Manage Simulation Models
This task describes how to manage simulation models in your virtualization project.

l

This task is part of a higher-level task. For details, see "How to Use Service Virtualization"
on page 25.

l

To learn more about simulation models, see "Simulation Modeling Overview" on page 147.

Create a simulation model
By default, each virtual service is associated with one data model and one performance model,
which are created together with the virtual service. You can create additional models and associate
them with a virtual service.
l

To add a new simulation model, in the Virtual Service Editor, under Simulation Models, click
Add.

l

To create a new simulation model by copying an existing model, select a model and click
Duplicate.

For user interface details, see "Virtual Service Editor" on page 113.

Edit a simulation model
In the Virtual Service Editor, under Simulation Models, select the model you want to edit and click
Edit, or double-click the model to open.
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Alternatively, in the Virtualization Explorer, select a model and double-click to open it in the relevant
editor.
For user interface details, see "Data Model Editor" on page 187 and "Performance Model Editor" on
page 221.
For task details, see "How to Edit a Data Model" below and "How to Edit a Performance Model" on
page 183.

How to Edit a Data Model
This task describes how you can edit a data model, and customize it to meet your needs.
To learn more about data models, see "Data Model Overview" on page 148.
This task includes the following steps:
l

"Add data" below

l

"Select columns to display" below

l

"Create custom rules" on the next page

l

"Add external data sources" on the next page

l

"Add/Edit service call activity" on the next page

l

"Preview changes" on page 159

l

"Apply changes" on page 160

l

"Navigating the Data Model Editor" on page 160

Add data
You can add data to your data model in the following ways:
l

Learn Data. Put the virtual service into Learning mode to record real service behavior. When
you are finished recording, the learned data is added to the data model. For user interface
details, see "Virtual Service Editor" on page 113.

l

Import Messages. Import existing messages from a file, or copy/paste message formats into
the data model. For user interface details, see "Import Request/Response Message Dialog Box"
on page 204.

l

Enter data manually.

Select columns to display
You can specify which columns are displayed in the data table of a rule. In the Data Model Editor,
select Columns > Change Columns, or right-click a column header and select Change
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Columns. For user interface details, see "Change Columns Dialog Box" on page 213.

Create custom rules
If you need to manipulate some aspect of the simulated behavior, create a new rule.
You can create your own customized rules to modify the responses used during simulation.
One typical use case is when you want to use learned data for simulation, but want to modify some
part of the response.
Create one of the following:
l

Blank rule. Create a new, empty rule. In the Data Model Editor, click New Rule > Blank Rule.

l

Data driven rule. Create a new rule using an external file as a data source. See the next step on
adding external data sources.

For details on configuring the rules, see "How to Define Rule Functions" on page 160.

Add external data sources
You can add additional data from external data sources to a data model for testing purposes. The
supported format for this data is Microsoft Excel documents (.xls, .xlsx).
In the Data Model Editor, click New Rule > Data Driven Rule. Fill in the details. For user interface
details, see "New Data Driven Rule Dialog Box" on page 207.
For more details on working with external data sources, see "How to Work With External Data
Sources" on page 178.

Add/Edit service call activity
You can configure a virtual service to call external services.
Note: Only SOAP and XML over HTTP service call activities are supported.
1. In the Data Model Editor, select the operation from which you want to call the external service.
2. To select a service description that was already imported into the project, click Activity. Select
the activity to add, and choose whether to add it before or after the response.
3. To import a new service description, click Activity > Import Activities. Enter the path to the
WSDL for a SOAP service, or the path to the XML schema for an XML service.
Note: If you are importing an XML service that requires HTTP authentication, you must
add the user name and password to the Service Virtualization credential store.
n

The Identify Name you enter in the credential store must be SCA:<name of called
activity>.
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n

Alternatively, you can create a global Identity Name SCA which is used if no specific
identity exists in the credential store.

For user interface details, see "Edit Credential Store Dialog Box" on page 266.
4. For a SOAP service: In the Select Service Operation dialog box, select an activity to add, or
import the service description document for use at a later time. For user interface details, see
"Select Service Operation Dialog Box" on page 217.
5. For an XML over HTTP service: In the Service Properties dialog boxes:
a. Select message elements for input and output messages.
b. Enter the URL on which the real service runs.
6. To add service call activity at a later time, click Activity again and select an activity.
7. To edit properties for a service call activity, right-click the activity's column header and click
Activity Properties. For user interface details, see "Activity Properties Dialog Box" on page
220.
8. To remove the service call activity from a rule, right-click the column header and click
Remove Activity.
9. To enable/disable the service call for a rule, click the on/off
header.

icon in the rule's

Tip:
l

You can use the Copy from function on any service call request column, or virtual service
response column. Select the Copy from function. The columns that you can use as a
source are highlighted. Click the desired source column.

l

Use the Row Detail dialog box for easier configuration of the service call activity. For
details, see "Row Detail Dialog Box" on page 199.

Preview changes
You can view in real time how changes in the data model are affecting your simulation. In the Data
Model Editor, select a row, and then select View Options > Simulation Preview.
The Simulation Preview pane displays a simulation of a message whose request matches the
currently selected message in the Data Model Editor table. The message is passed to the
simulation engine and the result is displayed in the response section.
For user interface details, see "Simulation Preview Pane" on page 198.
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Apply changes
To apply changes, you must restart your simulation. In the Data Model Editor, click Restart
Simulation.

Navigating the Data Model Editor
For more actions you can perform in the Data Model Editor, see "Data Model Editor Context
Menus" on page 193.
For additional tips on working in the Data Model Editor, see "FAQs: Data Model Editor" on page
239.

How to Define Rule Functions
This task describes how to define rule functions to impact virtual service behavior.
To learn more about functions, see "Rule Functions" on page 150.
This task includes the following:
l

"Select a function" below

l

"Create a new, custom function" on the next page

l

"Preview your changes" on the next page

Select a function
1. In the Data Model Editor, expand a rule.
2. Click inside the function field (fx) for a column and select a function. If the function row is not
displayed, from the View Options menu, select Functions.
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3. Dynamic Data Functions:
a. Click inside the function field (fx) of a response column and select a function.

Note: Dynamic data functions are available for lowest level headers only. Complex
headers that include lower level headers under them are displayed in italic text
(header). To display lower level headers, double-click the column header.
b. Configure the output format for the function. For details on configuring dynamic data
functions, see "How to Configure Dynamic Data Functions" on the next page.

Create a new, custom function
1. In the Data Model Editor, expand a rule.
2. Click inside the function field (fx) for a column and select New f(x). For user interface details,
see "New/Edit Function Dialog Box" on page 212.
Custom Functions: Service Virtualization provides a number of pre-defined variables that you
can use when creating and configuring custom functions. For details, see "How to Define
Custom Functions" on page 176.

Preview your changes
Simulation Preview displays in real time how changes in the data model are affecting the
simulation.
In the Data Model Editor, select View Options > Simulation Preview. The Simulation Preview
pane displays a simulation of a message whose request matches the currently selected message
in the Data Model Editor. The message is passed to the simulation engine and the result is
displayed in the response section.
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How to Configure Dynamic Data Functions
This task describes how to configure data generator functions.
Note: To learn more about functions, see "Rule Functions" on page 150.
This section includes:
How to Configure the Sequential Number Generator Function

162

How to Configure the Random Number Generator Function

167

How to Configure the Date/Time Functions

170

How to Configure the Substring Function

174

How to Configure the Sequential Number Generator
Function
This task describes how to configure the sequential number generator function.
To learn more about functions, see "Rule Functions" on page 150.
This section includes:
l

"Prerequisite: Select the function" below

l

"Configure the function" on the next page

l

"Format special sequences" on page 164

l

"Examples" on page 165

Prerequisite: Select the function
1. In the Data Model Editor, expand a rule.
2. Click inside the function field (fx) of a response column and select Sequential number
generator. If the function row is not displayed, from the View Options menu, select
Functions.
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Note: Dynamic data functions are available for lowest level headers only. Complex
headers that include lower level headers under them are displayed in italic text (header).
To display lower level headers, double-click the column header.

Configure the function
In each cell under this function, enter a value in the following format:
Offset;Increment;FormatString
where:
l

Offset is an integer. Used as the starting point for generating the output of the sequential number
generator.
Note: To generate a sequence of numbers that differs for each request/response, each cell
with this generator function has an internal numerical counter. When the simulation starts,
this counter is always set to 0. Each time a generator function is called, the output value is
determined based on the offset and counter. After the output is determined, the value of the
counter is increased by the value of the increment, or decreased if the increment is a
negative number.

l

Increment is a positive or negative integer. Indicates the change to make from one number in
the sequence to the next.

l

FormatString defines the format of the output of the sequential number generator.
The format string includes:
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n

a regular text string

n

(optional) one or more special sequences to define the format of the numerical output of the
generator

To determine the output of the number generator, Service Virtualization goes through the format
string and constructs an output string using specific rules, explained below.

Format special sequences
Special sequences enable you define the format of the numerical output of the function.
You construct special sequences as follows:
l

Each special sequence must start and end with the '#' character.

l

Each special sequence must contain one or more ‘D’ characters. These characters act like a
digit wildcard for a number that will be generated by this generator function. The number will
always occupy exactly the number of specified digits. If the number does not occupy all digits,
zeros are added before it so that it does.
For example, if:
- the special sequence is #DDDD#
- and the number generated by the function is 568
- the output is 0568.

l

A special sequence may also contain 'd' characters. These characters act as placeholders. If
the output of the generator function requires this space, then it will hold a number. If the
generated number does not occupy all digits, then the extra spaces are left empty, and not
populated with zeros. 'd' characters may only be placed before 'D' characters.
For example, if:
- the special sequence is #ddDDD#
- and the number generated by the function is 9857
- the output is 9857.
For the number 125:
- the sequence #DDDDD# outputs 00125
- the sequence #ddDDD# outputs 125
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- and the sequence ##dDDDD outputs 0125.

l

You can construct a format string with multiple special sequences.
For example, you can enter a special sequence to resemble a credit card number format:
- if the special sequence is #DDDD#-#DDDD#-#DDDD#-#DDDD#
- and the number generated is 1234567812345678
- the output is 1234-5678-1234-5678

Service Virtualization defines the output of the generator according to the following additional
guidelines:
l

If the number is greater than the maximal number that can be stored within the digits, it is
truncated so that it fits within (e.g. if the number was 3456 and the special sequence was
#DDD#, the output will be 456).

l

If the number is negative, it is truncated the same way as above. Then an additional offset is
applied. The value of this offset is based on the number of digits and is selected so that -1
becomes the biggest number that fits within these digits. For example, if the special sequence
was #DDDDD#, -1 becomes 99999. If it was #DD#, -67813 becomes -13 which then becomes
87.

l

For each empty special sequence (when there are two ‘#’ characters next to each other), a single
‘#’ character is inserted into the output string.

l

The numerical output of the generator will be a number that has exactly as many digits as there
are 'D' characters in all of the special sequences in the field combined.

l

Any characters that are not part of a special sequence are copied to the output string.

Examples
Increasing sequence
The typical use case is generating strings that make use of an increasing number sequence.
Example: Your input, typed in the cell under the sequential number generator function:
0;1;Visitor###DDD#
will produce the sequence Visitor#000, Visitor#001, Visitor#002...

Decreasing sequence
In cases where remaining time or another resource that is being depleted may identify some
object, the decreasing sequences are used to generate such identifiers.
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Example: The real service may be generating identifiers based on time remaining until some
event starts.
Your input, typed into cell under the sequential number generator function:
10000;-100;SnapshotTimeTMinus:#DDDDD#
This cell produces the output sequence: SnapshotTimeTMinus:10000,
SnapshotTimeTMinus:09900, SnapshotTimeTMinus:09800, etc.

Multiple independent sequences
When generating several classes of identifiers for various products, you want to maintain an
independent sequence of identifiers for each class. You can achieve that by creating a
separate rule for each class and use just one row in every rule. Use the Is function in the
request to distinguish classes from each other. Each rule has a separate counter for the
sequential number generator function, so that the sequences are independent.
Example: The 3 product lines have to have easily distinguishable ids. Class 1 has the „1“ set
as the first digit, class 2 has 2 etc.
Rule 1, Row 1, your input typed in the cell: 100000;1;codeNR-#DDDDDD#
Rule 2, Row 1, your input typed in the cell: 200000;1; codeNR-#DDDDDD#
Rule 3, Row 1, your input typed in the cell: 300000;1; codeNR-#DDDDDD#
If the service requests IDs in the following sequence {1,2,2,1,3,2,3,1}, the output results are as
follows:
codeNR100000-, codeNR-200000, codeNR-200001, codeNR-100001, codeNR-300000,
codeNR-200002, codeNR-300001, codeNR-100002

Multiple dependent sequences
Consider following the previous use case with just one rule containing all rows instead of
separate rules. In such a case, the internal counter is shared. Therefore, the sequences are not
independent and the output relies on the previous sequence of calls even though they were not
triggering the current row.
Example:
Rule 1,Row 1,your input typed in the cell: 10;10;X1-#DDD#
Rule 1,Row 2, your input typed in the cell: 100;100;X2-#DDD#
If we invoke the virtual service hitting the Row1, Row2, Row1, the output is „X1-010; X2-110;
X1-120“
If the two rows were in separate rules, the output would be: „X1-010; X2-100; X1-020“

Multiple number occurrences
It is possible to split the number that is being computed by SNG into multiple parts in the output
string. This is achieved by repeating the #DDD# sequence. Note that the 'Ds' sequences
within a single row may differ in length.
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Example: A cell with the following format, such as a credit card number format:
1234567890123456;1;#DDDD#-#DDDD#-#DDDD#-#DDDD#
produces the following output sequence:
1234-5678-9012-3456
1234-5678-9012-3457
1234-5678-9012-3458
1234-5678-9012-3459
etc.

How to Configure the Random Number Generator
Function
This task describes how to configure the random number generator function.
To learn more about functions, see "Rule Functions" on page 150.
This section includes:
l

"Prerequisite: Select the function" below

l

"Configure the function" on the next page

l

"Format special sequences" on the next page

l

"Examples" on page 170

Prerequisite: Select the function
1. In the Data Model Editor, expand a rule.
2. Click inside the function field (fx) of a response column and select Random number
generator. If the function row is not displayed, from the View Options menu, select
Functions.

HP Service Virtualization (3.10)

Page 167 of 299

User Guide
Chapter 7: Simulation Modeling

Note: Dynamic data functions are available for lowest level headers only. Complex
headers that include lower level headers under them are displayed in italic text (header).
To display lower level headers, double-click the column header.

Configure the function
In each cell under this function, enter a value in the following format:
Minimum_number;Maximum_number;FormatString
where:
l

Minimum_number is the lowest possible number to be used in the output of the random
number generator.

l

Maximum_number is the highest possible number to be used in the output of the random
number generator.

l

FormatString defines the format of the output of the random number generator.

The format string includes:
l

a regular text string

l

(optional) one or more special sequences to define the format of the numerical output of the
generator

To determine the output of the number generator, Service Virtualization goes through the format
string and constructs an output string using specific rules, explained below.

Format special sequences
Special sequences enable you define the format of the numerical output of the function.

HP Service Virtualization (3.10)

Page 168 of 299

User Guide
Chapter 7: Simulation Modeling

You construct special sequences as follows:
l

Each special sequence must start and end with the '#' character.

l

Each special sequence must contain one or more ‘D’ characters. These characters act like a
digit wildcard for a number that will be generated by this generator function. The number will
always occupy exactly the number of specified digits. If the number does not occupy all digits,
zeros are added before it so that it does.
For example, if:
- the special sequence is #DDDD#
- and the number generated by the function is 568
- the output is 0568.

l

A special sequence may also contain 'd' characters. These characters act as placeholders. If
the output of the generator function requires this space, then it will hold a number. If the
generated number does not occupy all digits, then the extra spaces are left empty, and not
populated with zeros. 'd' characters may only be placed before 'D' characters.
For example, if:
- the special sequence is #ddDDD#
- and the number generated by the function is 9857
- the output is 9857.
For the number 125:
- the sequence #DDDDD# outputs 00125
- the sequence #ddDDD# outputs 125
- and the sequence ##dDDDD outputs 0125.

l

You can construct a format string with multiple special sequences.
For example, you can enter a special sequence to resemble a credit card number format:
- if the special sequence is #DDDD#-#DDDD#-#DDDD#-#DDDD#
- and the number generated is 1234567812345678
- the output is 1234-5678-1234-5678
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Service Virtualization defines the output of the generator according to the following additional
guidelines:
l

If the number is greater than the maximal number that can be stored within the digits, it is
truncated so that it fits within (e.g. if the number was 3456 and the special sequence was
#DDD#, the output will be 456).

l

If the number is negative, it is truncated the same way as above. Then an additional offset is
applied. The value of this offset is based on the number of digits and is selected so that -1
becomes the biggest number that fits within these digits. For example, if the special sequence
was #DDDDD#, -1 becomes 99999. If it was #DD#, -67813 becomes -13 which then becomes
87.

l

For each empty special sequence (when there are two ‘#’ characters next to each other), a single
‘#’ character is inserted into the output string.

l

The numerical output of the generator will be a number that has exactly as many digits as there
are 'D' characters in all of the special sequences in the field combined.

l

Any characters that are not part of a special sequence are copied to the output string.

Examples
To generate a random number between 0 and 9999999, to be appended to the number 201, type
the following format into each cell under the random number generator function:
0;9999999;201#DDDDDDD#
where:
0 is the minimum number
9999999 is the maximum number
201 is a text string,
and #DDDDDDD# is a special sequence, indicating that the generated number can be up to 7digits in length
Result: The output is any number between 2010000000 and 2019999999.
Instead, you could format the cell as follows:
0;9999999;201#dddDDDD#
Result: The output is any number between 2010000 and 2019999999.

How to Configure the Date/Time Functions
This task describes how to configure the Set Relative Date/Time and the Set Date/Time Relative to
functions.
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To learn more about functions, see "Rule Functions" on page 150.
This section includes:
l

"Prerequisite: Select a date/time function" below

l

"Configure the function" on the next page

l

"Configure the offset" on the next page

l

"Configure the date/time format" on page 173

Prerequisite: Select a date/time function
1. In the Data Model Editor, expand a rule.
2. Click inside the function field (fx) of a response column and select one of the following
functions:
a. Set relative date/time. The date and/or time value is calculated by adjusting the date/time
when the request was received, using an Offset that you define.
b. Set date/time relative to. The date and/or time value is calculated by adjusting a specified
date/time, using an Offset that you define. This function requires you to select a source
column that contains the date/time to be adjusted.

Note:
If the function row is not displayed, from the View Options menu, select Functions.
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Dynamic data functions are available for lowest level headers only. Complex headers
that include lower level headers under them are displayed in italic text (header). To
display lower level headers, double-click the column header.

Configure the function
The output of the date/time function is configured as follows:
l

Offset. Defines the modification that you want to make to the source date/time. Enter the offset
into each cell under the date/time function.
If the offset is not specified for a particular cell or is in an incorrect format, an offset of 0 seconds
is used.

l

Format. Defines the format of the output. The resulting date/time that is output to the message
response is formatted according to one of the following:
n

The XSD type of the source column.

n

The custom format that you define for the output of the function.

For example, -1:25:00#hh:mm indicates the following:
- an offset of -1 hours and 25 minutes (1 hour 25 minutes earlier than source time)
- a custom format for the output time, such as 07:15
For details on configuring the offset and custom formats, see below.

Configure the offset
The Offset is formatted according to the following:
[-][d.]hh:mm:ss[.ff]
where:
l

Items in square brackets ([ and ]) are optional

l

Colons and periods (: and .) are literal characters

l

"-" (optional) indicates a negative time (a time earlier than the source time)

l

"d" optional days

l

"hh" mandatory hours, ranging from 0 to 23

l

"mm" mandatory minutes, ranging from 0 to 59
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l

"ss" mandatory seconds, ranging from 0 to 59

l

"ff" optional fractional seconds, consisting of 1 to 7 decimal digits
Examples:
l

-54.12:00:59.1234567

l

0:00:00.001

l

365.0:00:00

Configure the date/time format
Service Virtualization can set the format based on autodetection of the XSD type, or by a custom
format that you enter.
XSD Type
Service Virtualization can auto-detect the following XSD date/time types
l

xsi:date - "yyyy-MM-dd" (Example of output: 1984-11-28)

l

xsi:time - "HH:mm:ss" (Example of output: 23:59:59)

l

xsi:dateTime - "yyyy-MM-ddThh:mm:ss" (Example of output: 2001-12-13T10:15:33)

If detected, the format of the output of the date/time function is based on the XSD type, provided
that you have not defined a custom format.
No other formats, including JSON date/time formats, can be detected, as their internal type is
xsi:string. If the application cannot detect the format from the element's type, xsi:dateTime's format
is used by default. If you want to specify other output formats, you can define a custom format.
Custom Format
To configure a custom format, enter the following into each cell under the date/time function:
Offset#CustomFormat
You define a custom format using the following:
l

"d" - The day of the month, from 1 through 31.

l

"dd" - The day of the month, from 01 through 31.

l

"f" .. "fffffff" - Fractions of a second, number of "f" characters specifies number of digits to print

l

"h" - The hour, using a 12-hour clock from 1 to 12.

l

"hh" - The hour, using a 12-hour clock from 01 to 12.
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l

"H" - The hour, using a 24-hour clock from 0 to 23.

l

"HH" - The hour, using a 24-hour clock from 00 to 23.

l

"m" - The minute, from 0 through 59.

l

"mm" - The minute, from 00 through 59.

l

"M" - The month, from 1 through 12.

l

"MM" - The month, from 01 through 12.

l

"s" - The second, from 0 through 59.

l

"ss" - The second, from 00 through 59.

l

"tt" - The AM/PM designator.

l

"yyyy" - The year, four digit number.

l

regular characters (all characters except the ones mentioned above) - generated "as is". To
generate a character that has a special meaning (is part of one of the custom formats above,
such as “s”), place a '\' before it.
Examples:
If today's date is December 10, 2012:
l

To generate yesterday's date: -1.00:00:00#yyyy-MM-dd
Result: The output is 2012-10-09.

l

To generate today's date: : 0#MM/dd/yyyy
Result: The output is 12/10/2012.

l

To generate the date 1 week from today: 7.00:00:00#MM/dd/yyyy
Result: The output is 12/17/2012.

How to Configure the Substring Function
This task describes how to configure the substring function. The substring function enables you to
copy part of a string in your data model from one column to another.
To learn more about functions, see "Rule Functions" on page 150.
You configure the substring function in the Substring Dialog Box. For user interface details, see
"Substring Dialog Box" on page 202.

HP Service Virtualization (3.10)

Page 174 of 299

User Guide
Chapter 7: Simulation Modeling

To configure the substring;
Create a format string to define which part of the data in the source column you want to copy.
The format string can consist of any combination of the following:
Format

Description

Example

{n}

Copies the n-th
character from the
source string.

Format string: {3}
Source string: abcde
Substring result: c

{n+}

Copies all characters Format string: {5+}
from the n-th
Source string: abcdefgh
character to the end of
the source string.
Substring result: efgh

{n-m} where n is
located before m in
the string

Copies all characters
from the n-th
character to the m-th
character (inclusive).

Format string: {2-6}

Copies all characters
from the m-th
character, backwards
to the n-th character
(inclusive).

Format string: {6-2}

Copies m characters,
starting from the n-th
character.

Format string: {7:2)

{m-n} where n is
located before m in
the string

{n:m}

If there are not enough
characters in the
source string, a space
is added for each
missing character.
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Format

Description

Example

Regular text

You can add
additional text The
text you enter is
copied as is.

Format: Text with backslash \\ and curly
brackets \{ \}
Result: Text with backslash \ and curly
brackets { }

Limitation: You
cannot use the
characters { } or \.
They are used to mark
special format
sequences.
Workaround: To use
the characters { } or \
as part of a text string
you enter, each of
these characters
must be preceded by
the backslash
character \. Placing a
backslash before one
of these special
characters overrides
their special meaning.

Example:
In the Format field of the Substring dialog box, you enter the following format string:
All characters:{1+}. Only 6th and 8th characters: {6}{8}. Result of \{5:5\} is: {5:5}. First 13
characters reversed: {13-1}.
The source string is: 123456789ABCDEF
The result, output to the cell configured with the substring function is:
All characters:123456789ABCDEF. Only 6th and 8th characters: 68. Result of {5:5} is: 56789.
First 13 characters reversed: DCBA987654321.

How to Define Custom Functions
You can create new functions to use in a data model. For user interface details, see "New/Edit
Function Dialog Box" on page 212.
You can use the following variables to configure a new, custom function:
l

$input_string The original string is automatically quoted in the place of usage.

l

$input_string_unquoted The original string is not automatically quoted.
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l

$input_int The original string is converted to the int data type, for integer data. It contains NULL if
the input string is not of this data type.

l

$input_float The original string is converted to the float data type, for floating point numeric data.
It contains NULL if the input string is not of this data type.

l

$input_date The original string is converted to the date data type, to define a date. It contains
NULL if the input string is not of this data type.

l

$data_string The actual data, converted to the string data type.

l

$data_int The actual data, converted to the int data type.

l

$data_float The actual data, converted to the float data type.

l

$data_date The actual data, converted to the date data type.

Following are examples of custom functions:
l

Match request data (cast to integer) smaller than actual value (cast to integer) found in the
column $input_int < $data_int

l

Match request data (cast to integer) smaller than actual value (cast to float) found in the column
$input_int < $data_float

l

Match actual value found in the column (cast to string) equal to 'cat' string $data_string = 'cat'

l

Match request data (cast to string) equal to 'cat' string $input_string = 'cat'

l

Match request data (cast to string) equal to actual value (cast to string using an SQL 'LIKE'
operation) $input_string LIKE $data_string

l

Match request data (cast to string) equal to any string starting with the actual value found in the
column $input_string LIKE $data_string + '%'

l

Match request data (cast to string) containing a substring 'cat' $input_string LIKE '%cat%'

l

Match request data (cast to date) smaller than actual data $input_date < $data_date

l

Match request data smaller than actual data OR request data equal to 'dogs' string $input_date <
$data_date OR $input_string = 'dogs'

How to Configure Regular Expressions
This task describes how to configure regular expressions in Service Virtualization. Use regular
expressions to match a specific string in order to mask select data.
In the Replace Algorithm Configuration dialog box, you can enter a regular expression in the Match
pattern and Replace value fields. (For user interface details, see "Replace Algorithm Configuration
Dialog Box" on page 234.)
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In addition, when you use regular expressions in the Replace value field, the expression can
reference groups from the search pattern you entered in the Match pattern field.
Examples:

Match pattern field

Replace value
field

Sample
input

Sample
output

\b(\w+)(\s)(\w+)\b

$3$2$1

one two

two one

\b(?<word1>\w+)(\s)(?<word2>\w+)
\b

${word2} ${word1}

one two

two one

For information on creating regular expressions and some examples of their use, visit this site:
Regular Expression Language - Quick Reference.

How to Work With External Data Sources
This task describes how to work with an external data source. You can import or export data.

l

This task is part of a higher-level task. For details, see "How to Edit a Data Model" on page
157.

l

To learn more about external data sources, see "Data Driving" on page 153.

l

For a use-case scenario related to this task, see "Working with External Data Sources Use-case Example" on page 181.

This task includes the following steps:
"Add an external data file" below
"Bind the data" on the next page
"Bind array data" on page 180
"Bind other data" on page 180
"Configure import/export settings" on page 180
"Refresh the data" on page 180
"Change the path of the data source" on page 181
"Disconnect external data" on page 181
1.

Add an external data file
You can associate a data rule with an external data file in order to import or export data.
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In the Data Model Editor, select New Rule > Data Driven Rule. Select one of the following
options:
Create new data file. The Service Virtualization Designer creates a new Excel file, structured
according to the schema (message structure) associated with the virtual service. Rule
columns are automatically bound to the worksheet columns.
Use existing data file. You must then manually bind rule columns to worksheet columns.
After binding, the external data is imported to the Data Model.
For details, see "New Data Driven Rule Dialog Box" on page 207.
Result: A "preview" of your external data file displays within the rule.

Note that the worksheets in the external file are displayed as tabs at the bottom of the data
table.
2.

Bind the data
If you selected an existing data file, you must bind the data. You create mappings between the
data columns in the external file, and the columns/headers in your data rule.
a. In a column header, click bind data. If it is not visible, click View Options > Data
Binding.
Headers must be expanded down to the lowest level in order to bind.
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b. Click a column in the displayed external data source table to bind that column.
c. Repeat steps a and b for all columns you need to bind.
d. Click OK. The data is imported.
3.

Bind array data
When the message structure contains an array that needs to be data-driven, you need to work
with a properly structured Excel file. The file must contain database-like relationships, using
primary and foreign keys, which allow the mapping of one row to many.
When binding an array item, the Edit Sheet Relations dialog box opens automatically, enabling
you to define the relationships between worksheets that are required for array binding. . For
user interface details, see "Edit Sheet Relations Dialog Box" on page 215.
Alternatively, right-click the rule or column header and select External Data Properties. See
the Sheet Relations area.

4.

Bind other data
You can configure binding for working with different data formats (REST protocol), different
response types (SOAP protocol), or a message structure containing different types.
When you start to bind to an Excel worksheet column where the response can contain these
types of data, the relevant dialog box opens automatically (The Data Format, Response Type,
or Choice Data Binding dialog boxes). For user interface details, see "Data Format/Response
Type/Choice Binding Dialog Box" on page 217.

5.

Configure import/export settings
You can configure rules to import or export data, or configure settings for rules already
associated with an external data file.
Learned Data rule: To export learned data, right-click the Learned Data rule and select Export
Data.
Blank/custom rule. To import data from or export data to an external data file, right-click the
rule and select Import Data or Export Data.
Data driven rule. For a rule already associated with an external file, you can change settings.
Right-click the rule and select External Data Properties.

6.

Refresh the data
If you have selected the Data Synchronization option for your rule, the data is automatically reimported or exported.
To manually refresh data, right-click the rule and select Refresh Data. The data is imported or
exported, depending on how the rule is configured.
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7.

Change the path of the data source
To change the location of the external data file, right-click the rule and select External Data
Properties.

8.

Disconnect external data
To disconnect a rule from an external data source and remove bindings, right-click the rule and
select Disconnect External Data.

Working with External Data Sources - Use-case
Example
This section provides an example of working with an external data file.
Note: For a task related to this example, see "How to Work With External Data Sources" on
page 178.
It can be difficult to manually configure an Excel worksheet when your data has a particular
complex structure. As an alternative to manually setting up a file and configuring binding in the Data
Model, you can create a new data driven rule, and have Service Virtualization create a new data file
for you, according to your message structure.
1. Create a virtual service.
2. In the Data Model, create a new data driven rule and select Create new data file. Service
Virtualization will create the new file according to your message structure, and bind the
columns.
3. Select Data Synchronization to automatically re-import data in the new file before Simulation.
Alternatively, clear the Data Synchronization check box. You can choose to import at a later
time.
4. After the new data file is created, you can add data to it. If you selected Data Synchronization,
when you place your virtual service into Simulating mode, the external data is re-imported. If
you did not select Data Synchronization, you can choose to refresh the data manually at any
time, or reconfigure the rule for data synchronization.

How to Assess Change Impact
This task describes how to test the impact that changes in the data model have on simulation.
To learn more, see "Simulation Preview" on page 154.
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This task includes the following:
l

"Open the Simulation Preview pane" below

l

"Test the impact of a change on the simulation" below

l

"Troubleshoot" below

Open the Simulation Preview pane
In the Data Model Editor, select View Options > Simulation Preview. For user interface details,
see "Simulation Preview Pane" on page 198.

Preview a simulated response
1. Open Simulation Preview.
2. Select a row in a data rule. The simulated response is displayed.
3. Edit the request data to view the impact on the response.

Test the impact of a change on the simulation
1. Open Simulation Preview.
2. Select a row in a data rule.
3. Click

to pin the row to Simulation Preview.

4. Select an existing row in a data rule, or create a custom rule with a higher priority to view the
impact on the simulation.
5. View the impact on the message response in the pinned row in Simulation Preview.

Troubleshoot
If you have a message request that is not matching any rule in your data model, you can compare it
to rows in the data rules to look for a problem in your rule definitions.
1. Open Simulation Preview.
2. Do one of the following:
a. Select an existing row in a data rule.
b. Right-click in Simulation Preview and select Import Request.
3. Click

to pin the row to Simulation Preview.

4. Select another row in a data rule to compare the two rows.
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5. Click Show Differences to highlight the differences in the Data Model Editor table.
Note: The columns displayed in the Data Model Editor table may change when you are
comparing rows. To restore the display the previously defined column settings, click
Restore Columns.

How to Edit a Performance Model
This task describes how to edit the performance model to manipulate simulation behavior.
To learn more about performance models, see "Performance Model Overview" on page 155.
Service-level view
1. In the Virtualization Explorer, double-click a performance model to open the Performance
Model Editor.
2. In the left pane, select the service name.
3. In the Booster drop-down box, select a performance criteria. For details on the available
criteria, see "Performance Model Editor" on page 221.
4. Use the booster controls to set the boost level for the selected boosters.
5. Under Model, select the Boost or Throughput Limit check boxes to apply the performance
changes to the service and all its operations.
Clear the boxes to manually set boosters for individual operations.
Operation-level view
1. Click an operation name in the left pane or in the operations table to view operation level detail
for that operation.
2. Click a performance value to edit.
3. Click Show Measured Data to display any recorded performance data in the graph.

How to Edit a Service Description
This task describes how to edit a service description. This includes service editing and URI space
editing.
To learn more about service descriptions, see "Service Descriptions" on page 90.
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This task includes the following steps:
l

"Open a service description" below

l

"Edit metadata" below

l

"Manage XML schemas" below

l

"Add or remove an operation" below

l

"Add or remove a URI space" below

l

"Add or remove data formats" on the next page

l

"Define session identifiers" on the next page

l

"Hide data" on the next page

l

"Update a SOAP service description" on the next page

Open a service description
In the Virtual Service Editor, under Service Description, click Edit. For user interface details, see
"Service Description Editor" on page 224.

Edit metadata
You can add, delete, enable, disable, and edit metadata.
In the Service Description Editor, under Request Metadata or Response Metadata, click Edit. For
user interface details, see "Edit Metadata Dialog Box" on page 235.

Manage XML schemas
In the Service Description Editor, under XML Schemas, select an option to add, edit, or remove
XML schemas. For user interface details, see "Service Description Editor" on page 224.

Add or remove an operation
You can add operations to your service.
In the Service Description Editor, in the bottom left of the Operations pane, click Add Operation.
Select input and output message types. You must assign each operation a unique input message
type.
SAP services: For a SAP service, the Add Operation dialog box enables you to import
operations from a SAP server. For user interface details, see "Add SAP Operation Dialog Box"
on page 238.

Add or remove a URI space
You can create additional URI spaces for your data.
In the Service Description Editor, in the bottom left of the Operations pane, click Add URI Space.
Enter a URI path.
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Note:
l

Segments are separated with a '/' and the wildcard character '*' is used for several
characters or segments. For example, "Customer/*/Europe/*".

l

Caution: If a URI Space that is in conflict with an existing URI Space and the new URI
Space is more specific, the conflicting URI Space is split to several new URI Spaces and
data from all associated rules are moved to these new URI Spaces.

To delete a URI space, in the left pane of the Service Description Editor, select the URI space and
click Delete URI Space.

Add or remove data formats
Data formats can be added and removed from a URI space as either request or response data
formats.
1. In the Service Description Editor, in the operations pane on the left side, select a URI space.
2. Under Data Formats > Request Data Formats or Response Data Formats, click Add.
For user interface details, see "Add Data Format Dialog Box" on page 237.

Define session identifiers
Set session IDs to identify requests that reflect the same source.
1. In the Service Description Editor, under Session IDs Definition, click Edit.
2. In the wizard pages that open, specify values for session identifiers, and click Finish. For user
interface details, see "Session ID Definition Wizard" on page 226.
3. Learn data again. Service Virtualization uses the session IDs to create different tracks based
on the learned data, and uses the tracks to create different sessions during simulation.

Hide data
Configure data masking to protect sensitive data. Data recorded during Learning is masked and
cannot be viewed in the data model.
Do one of the following:
l

In the Service Description Editor, under Data Masking, view the data masking configuration for
your virtual service. To configure data masking, click Edit.

l

In the Data Model Editor, right-click a column header and select Mask.

For user interface details, see "Data Masking Dialog Box" on page 232.

Update a SOAP service description
You may need to update a SOAP service description after a virtual service is created. A service
commonly evolves over time, along with its WSDL, requiring an update of the virtual service.
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You can update the service description in the following ways:
Automatically:
During Learning, Service Virtualization updates the SOAP service description automatically, based
on the data received.
Manually:
1. In the Virtual Service Editor, under Service Descriptions, click Update From File.
2. In the Update Service Description dialog box, enter the path or URL, or browse to enter a new
file.

Simulation Modeling User Interface
This section includes:
Data Model Editor

187

Data Model Editor Context Menus

193

Data Model Editor Options Page

196

Stateful Layout View

197

Simulation Preview Pane

198

Row Detail Dialog Box

199

Substring Dialog Box

202

Import Request/Response Message Dialog Box

204

Request/Response Pairing Dialog Box

206

New Data Driven Rule Dialog Box

207

Import/Export Data Dialog Box

209

External Data Properties Dialog Box

211

New/Edit Function Dialog Box

212

Change Columns Dialog Box

213

Edit Sheet Relations Dialog Box

215

Data Format/Response Type/Choice Binding Dialog Box

217

Select Service Operation Dialog Box

217

Service Properties for XML Service Call Activity

218

Activity Properties Dialog Box

220

Performance Model Editor

221

Service Description Editor

224
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Session ID Definition Wizard

226

Data Masking Dialog Box

232

Replace Algorithm Configuration Dialog Box

234

Edit Metadata Dialog Box

235

Add Data Format Dialog Box

237

Add SAP Operation Dialog Box

238

Data Model Editor
The Data Model Editor enables you to view and edit a data model. You can configure requests,
responses, and service activity calls for individual operations of a virtual service.

To access

Important
information

Use one of the following:
l

In the Virtualization Explorer, double-click a data model.

l

In the Virtual Service Editor, under Data Models, select a data model and click
Edit.

l

Many of the actions you can perform in the Data Model Editor are available
only from context menus. For details, see "Data Model Editor Context Menus"
on page 193.

l

Tip: To access the Data Model Editor menus, press the Alt key and press a
number from 1 - 6. For example, to open the View Options menu, press Alt +
5.
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Relevant
tasks

See also

l

"How to Manage Simulation Models" on page 156

l

"How to Edit a Data Model" on page 157

l

"How to Define Rule Functions" on page 160

l

"How to Work With External Data Sources" on page 178

l

"Data Model Overview" on page 148

l

"Data Model Editor Context Menus" on page 193

l

"Rule Functions" on page 150

l

"FAQs: Data Model Editor" on page 239

User interface elements are described below (unlabeled elements are shown in angle brackets):
UI Element

Description

<data model name and
description>

The name and description of the data model. Click to edit.

<operations/URI Spaces Operations pane. Located in the left pane of the editor. Displays a
pane>
list of the operations in the service associated with the selected
data model.
Enter text in the filter box to filter for specific operations in the list.
Select an operation from the list to display its details in the main
pane of the Data Model Editor.
Operation

Displays the name of the currently selected virtual service, and lists
the operations in the virtual service. Select an operation from the list
to display its details in the main pane of the Data Model Editor.

Learned Data

Learned Data rule. Created by default when you create a virtual
service. Displays the requests and responses recorded during a
learning session of a virtual service.

Default Response

Default Response rule. Created by default when you create a
virtual service. The response that is provided when the data does
not match any other rule. The Default Response rule always has the
lowest priority.
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UI Element

Description

<rule elements>

Rules in the data model contain the following elements:

l

Expand rule. Click the arrow before the rule number to expand a
rule.
For details on the functions used in rules, see "Rule Functions"
on page 150.

l

Rule priority. The rule number indicates the order in which the
rule is applied during simulation.
To move a rule up or down in the list to change its priority, click
the up/down icon

after the rule number.

Note: Not available for the Default Response rule.

l

Rule name and description. Click to edit. Available only for
custom rules.

l

Import/Export icons. When the rule is associated with an
external data file, one of the following icons is displayed:

The data was imported from an external file.

The data was imported from an external file and is
configured to automatically re-import before each Simulation
session.

The data was exported to an external file.

The data was exported to an external file and is configured
to automatically re-export after each Learning session.
l

x/x rows. Indicates the number of rows for this rule in this
operation, out of the total rows for this rule across all operations
in this service.
Tip: Press Ctrl + the rule number to select a rule, or to
expand/collapse the selected rule.

HP Service Virtualization (3.10)

Page 189 of 299

User Guide
Chapter 7: Simulation Modeling

UI Element

Description
Enables you to create a new custom rule. Custom rules apply to all
operations in the service. Includes the following options:
l

Blank Rule. Enables you to create a new, custom rule with an
embedded data source, used to modify some aspect of
simulation, such as to rewrite part of the response, add service
call activity, or add more data.
The blank rule can be added before or after the default Learned
Data rule.

l

Scripted Rule (Beta). Enables you to create a new, custom rule
with a script to access request data and set response data. For
details, see "Scripted Rules" on page 296.
Note: Scripted rules are a Service Virtualization Labs
feature. This field is displayed only if you have enabled the
feature. For details, see "Service Virtualization Labs" on
page 292.

l

Data Driven Rule. Opens the Use Existing Data Source dialog
box, enabling you to create a new rule using an external file as a
data source, such as an Excel file. A new read-only rule is
created for this data source.
Select the data source file, and assign a name to the data
source.
Select First row contains names of columns to use the
header row of the source file for the rule's column names.
The data driven rule can be added before or after the default
Learned Data rule.

For more details on rules, see "Rule Functions" on page 150.
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UI Element

Description
Depending on the virtual service, displays options for the operations
or URI spaces defined in the virtual service.
Includes the following options:
l

Browse and Search Operations/URI Spaces. Opens the
Operations pane, displaying the list of operations included in the
service.
In the search box, enter a name or part of a name to search and
filter for specific operations in the list.
Select an operation from the list to display its details in the main
pane of the Data Model Editor.

l

Edit Operations/URI Spaces. Opens the Service Description
Editor, enabling you to modify the operations or URI spaces,
their data formats, and metadata. For details, see "Service
Description Editor" on page 224.
Note: Available only for supported protocols.

l

Recently Used Operations/URI Spaces. Lists your most
recently used operations or URI spaces, allowing you quick
access.

Includes the following options:
l

Change Columns. Opens the Change Columns dialog box,
enabling you to select the headers to display for the operation.
For details, see "Change Columns Dialog Box" on page 213.

l

Flat/Structured Headers. Toggles between flat and structured
column headers.

Includes the following option:
Insert Path. Enables you to select a path to a Service Virtualization
element, and add it to a scripted rule.
Note: Scripted rules are a Service Virtualization Labs feature.
This field is displayed only if you have enabled the feature. For
details, see "Service Virtualization Labs" on page 292.
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UI Element

Description
Enables you to configure the virtual service to call an external
service:
l

Import Activities. Opens the Import Real Service Description
dialog box, enabling you to import a service description of a
service whose operations you can use as service call activities.
Available for: SOAP and XML over HTTP.
Note: After import, the on/off icon displays in the activity
column header in the rule, enabling you to enable/disable the
service call for the rule.
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UI Element

Description
Includes the following options:
l

Functions. Displays the function row within rules, enabling you
to set conditions for data columns.

l

Highlight Columns. Displays column headers in different
colors according to function type: Action, Condition, and Ignore.
Default value: Off.
To change the colors or restore the default color coding, from the
main menu, select Tools > Options, and click the Data Model
Editor tab. For details, see "Data Model Editor Options Page" on
page 196.

l

Data Binding. Displays the data binding row within rules,
enabling you to configure binding. For more details, see "Data
Driving" on page 153.

l

Time Stamp. Displays the time stamp column within rules,
which shows the time of creation or last modification of the rule.

l

Operations/URI Spaces Pane. Opens the
Operations/URI Spaces pane, displaying the list of
operations/URI spaces included in the service.

l

Simulation Preview. Displays how changes in the data model
are affecting the simulation. For user interface details, see
"Simulation Preview Pane" on page 198.

Displays the Track Position column within rules, and opens the
track pane on the right side of the editor. For details, see "Stateful
Layout View" on page 197.

Data Model Editor Context Menus
You can perform additional actions on rules in the Data Model Editor by accessing the context
menus.
To access

Right-click a rule and select an option.

See also

l

"Data Model Editor" on page 187

l

"Data Model Overview" on page 148

Relevant tasks "How to Edit a Data Model" on page 157
User interface elements are described below.
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Rule actions
The following items are available when you right-click a rule.
UI Element

Description

New Rule

Creates a new custom rule.

Delete
Rule

Deletes the selected rule.

Disable
Rule

Deactivates the selected rule. The rule is not applied during simulation.

Available for: Custom rules

To reactivate the rule, right-click and select Enable Rule.
Import
Data

Opens the Import Data dialog box, enabling you to import data from an external
data file. For details, see "Import/Export Data Dialog Box" on page 209.
Available for: Blank custom rule

Export
Data

Opens the Export Data dialog box, enabling you to export data from an external
data file. For details, see "Import/Export Data Dialog Box" on page 209.

Open
External
Data

Inside the data table, displays the data from the external file with which your rule is
synchronized.

Refresh
Data

Depending on whether your rule is configured for import or export to an external
data file, re-imports or re-exports the data.

Available for: Data driven rules

Available for: Data driven rules
External
Data
Properties

Opens the External Data Properties dialog box, enabling you to modify your
configuration for working with an external data source. For details, see "External
Data Properties Dialog Box" on page 211.
Available for: Data driven rules

Disconnect Disconnects the rule from the external data file with which it is synchronizing. This
External
discontinues any import/export actions.
Data
Available for: Data driven rules

Column header actions
The following items are available when you expand a rule and right-click a column header.
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UI Element

Description

Activity
Properties

Opens the Activity Properties dialog box, enabling you to modify properties for a
service call activity. For details, see "Activity Properties Dialog Box" on page
220.

Remove
Activity

Removes the selected activity from the rule.

Sort

Sorts the rows within the rule.

Reset
Column
Width

Resets default column widths.

Change
Columns

Opens the Change Columns dialog box, enabling you to specify which columns
are displayed in the data table of a rule. For details, see "Change Columns
Dialog Box" on page 213.

Import/Export Opens the Import/Export Data dialog box, enabling you to import/export data
Data
from/to an external data file. For details, see "Import/Export Data Dialog Box"
on page 209.
Mask

Opens the Data Masking dialog box, enabling you to hide specific request and
response data elements. For details, see "Data Masking Dialog Box" on page
232.

Change
Masking

Row actions
The following items are available when you right-click a row within a rule.

UI Element

Description

Binary
Data

Enables you to:
l

import a binary file to the cell

l

edit the file using the internal Service Virtualization editor or an external editor

l

export the file

Number
Format

The type of numerical data in the row: binary, decimal, or hexadecimal.

Set Not
Present

Clears any value from the cell.
When you add a new row, the cell values are initially defined as"Not Present".
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UI Element

Description

Set Nil/Set
Null

Sets the value of the cell to nil or null.
The option available varies depending on the data type of the cell in which you are
working.

Copy/Paste Copy the cell contents to the clipboard. Paste into another cell or outside of the
Cell
application.
Available for lowest level headers only.
Add Row

Creates a new row in the data table.

Import
Message

Opens the Import Request/Response Message dialog box, enabling you to import
messages from a file, by copying from the clipboard, or by manually entering text.
For details, see "Import Request/Response Message Dialog Box" on page 204.

Add to
Track

Opens the Stateful Layout view of the Data Model Editor, enabling you to order
request/response pairs to define the sequence in which they are used during a
stateful simulation. For details, see "Stateful Layout View" on the next page.

Row Detail

Opens the Row Detail dialog box, enabling you to view, enter, and edit data in the
row. For details, see "Row Detail Dialog Box" on page 199.
Tip: If your structure includes many columns, the Row Detail dialog box
offers a more user friendly format for viewing, entering, and editing data
manually.
Available for: Rows containing data

Data Model Editor Options Page
The Data Model Editor options page enables you to set options for the Data Model Editor.
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To
access

From the main menu, select Tools > Options, and click the Data Model Editor
tab.

See also

"Data Model Editor" on page 187

User interface elements are described below:
UI Element

Description

Highlighting Change the colors or restore the default color coding used to highlight column
headers by function type in the Data Model Editor. For details on enabling
highlighting functionality, see "Data Model Editor" on page 187.

Stateful Layout View
This view enables you to order request/response pairs to define the sequence in which they are
used during a stateful simulation.

To access

In the Data Model Editor, click the Stateful Layout button.

Important
Service Virtualization creates tracks automatically based on learned data and
information Session ID definition. For details, see "Service Description Editor" on page 224.
Relevant
tasks

"How to Edit a Data Model" on page 157

See also

"Data Model Editor" on page 187

User interface elements are described below (unlabeled elements are shown in angle brackets):
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UI Element

Description

Track
Position
column

Located in the main pane of the Data Model Editor, indicates the track and track
position of the selected row.

<track
pane>

Located in the right pane, displays the sequence of calls in the track. The order
reflects how the calls are used in a stateful simulation.

Right-click in the Track Position column for a given row and click Add to Track to
add the call to the sequence of calls in the track.

Select a call to highlight its row in the rule.
<track
name>

Located at the top of the track pane. Click to edit.

Current
Rule
Tracks

List of all tracks modeling stateful behavior.

New Track

Creates a new track.

Delete

Deletes the currently displayed track. You can choose to delete the track only, or
also delete the rows that include track positions of the selected track.

Simulation Preview Pane
The Simulation Preview pane displays a simulation of the message response based on the request
data in a row you select in the Data Model Editor.

To access

In the Data Model Editor, select View Options > Simulation Preview.

Important
information

The columns displayed are based on the columns currently displayed in the
Data Model Editor table above.

Relevant tasks

"How to Assess Change Impact" on page 181
"How to Edit a Data Model" on page 157

See also

"Simulation Preview" on page 154

User interface elements are described below (unlabeled elements are shown in angle brackets):
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UI Element
Description
Pinned. Simulation Preview will continue to display on the selected row while
comparing it to the row selected in the Data Model Editor table. Select a different
row in the Data Model Editor table in order to compare the two rows.
Unpinned. Simulation Preview displays the row currently selected in the Data
Model Editor table. You can edit the request data in the Simulation Preview, and
view the impact on the response data.
<Request
columns>

Displays the request data for the selected row.

<Response Displays the simulated response that is returned, based on the request data in the
columns>
row.
Show
Highlights the columns in the selected Data Model Editor row that are different
Differences from the row that is pinned in the Simulation Preview. The columns that are
displayed in the Data Model Editor table may change as required to show the
differences.
Click Hide Differences to clear the highlighting from the rows.
Restore
Columns

Returns the displayed columns in the Data Model Editor table to the settings that
were defined before you selected Show Differences.

Row Detail Dialog Box
This dialog box enables you to view, enter, and edit data in the row.
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To access

Important
information

Use one of the following:
l

In the Data Model Editor, right-click a row within a rule of an operation and
select Row Detail.

l

Select a row and click Ctrl+D.

l

Changes you make to functions in this dialog box, such as Is or Ignore,
apply to all rows in the rule.

l

Changes you make to data are immediately updated in the Data Model
Editor when you move to a different field.

l

To enter multi-line values, click Alt+Enter at the end of the line of text to
add a new line.

Relevant tasks

"How to Edit a Data Model" on page 157

See also

"Data Model Editor Context Menus" on page 193

User interface elements are described below (unlabeled elements are shown in angle brackets):
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UI Element

Description

<Left and Right panes>

The two panes in the dialog box display the same information,
providing you with a convenient interface for configuring message
requests and responses.
Example: You are working with service call activity and want to
copy data from the service call activity response to the virtual
service response:

1. In the left pane, select the service call activity response. (In
this example, the Response - getClaim tab.)
2. In the right pane, click the tab for the virtual service
response.
3. In the virtual service response tab, select the Copy from
function.
4. In the service call activity response tab, select the data to
copy.
Call <x> of <y>

Indicates the row number (x) that is selected within the rule,
which contains (y) rows.

Add Call

Adds a new row to the rule, enabling you to enter data manually.

Delete Call

Deletes the selected row.
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UI Element

Description

Search

Enter the text you want to find. The first matching text is
highlighted.
Click the Previous and Next arrows in the Search box to move to
other matching text.

Tip: You can also use Alt+Right and Alt+Left arrows to
navigate through the search results.
<search filter>

Request/Response/Servic
e call activity
Requests/Service call
activity Responses

Limits the search according to the criteria you select. Options
include:
l

Message. Searches both request and response data.

l

Request/Response/Service call activity request/Service
call activity response Select a message part to limit the
search to that part of the message.

The tables display the data for the selected row. You can view,
search, and modify the data.

Substring Dialog Box
This dialog box enables you to copy a part of a string from one data column to another. You can also
add additional text to the copied text.
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To
access

1. In the Data Model Editor, expand a rule.
2. Click inside the function field (fx) of a response column and select Substring.

Tip: If the function row is not displayed, from the View Options menu,
select Functions.
3. Select a column to be used as the source of the data from which to extract the
substring. The columns available for selection are highlighted.
Relevant "How to Configure the Substring Function" on page 174
tasks
See also

"Rule Functions" on page 150

User interface elements are described below:
UI
Element Description
Source

The substring is taken from the data in the source column you specify.
By default, the column you already selected is displayed. Click Change to select a
different column.

Format

Defines which part of the string you want to copy from the source column, and any
additional text you want to add to the string. For details on how to define the format,
see "How to Configure the Substring Function" on page 174.

Preview

Simulates an example of the substring result based on the settings you defined in the
Source and Format fields.
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UI
Element Description
Change

Enables you to select a source column for the substring of data to be copied.

More

Opens the Service Virtualization help to assist you in defining the substring format.

Import Request/Response Message Dialog Box
This dialog box enables you to import messages from a file, by copying from the clipboard, or by
manually entering text. You can also import multiple files simultaneously.

To access

In the Data Model Editor, expand a rule.
l

To import messages to a specific operation/URI space, select the
operation/URI space in the Operations/URI Spaces pane. Right-click inside
the rule and select Import Message.

l

To import messages at the service level, select the service in the
Operations/URI Spaces pane. Right-click the rule and select Import
Message. (Available for SOAP and XML services only.)

Available for: Custom rules and the Learned Data rule.
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Important
information

l

Importing multiple messages at the service level: The messages are
placed in the proper operations.
If a message contains a new schema/message structure that does not
currently exist in any operations in the service:

l

n

For an XML service, a new operation is created.

n

For a SOAP service, an error message displays.

Importing multiple messages directly into a specific operation:
If a message contains a new schema/message structure that does not
currently exist in the operation:
n

For a REST service, a new data format is created.

n

For an XML or SOAP service, an error message displays.

Relevant
tasks

"How to Edit a Data Model" on page 157

See also

"Data Model Overview" on page 148

User interface elements are described below:
UI Element

Description
Expand/Collapse. Click to show/hide message content.

Request/Response Enter request and response message content.
Message
You can import request messages, response messages, or both.
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UI Element

Description

From File

Click to select a file from the file system. Each file may contain only the
request or response part of a single message.
To import multiple messages, select multiple files to import. Service
Virtualization matches pairs of request and response messages by file
name, according to one of the following methods:
l

l

Files are matched according to any numerical index present within the
file name.
n

The index can be located at the beginning or end of the file name, or
as a separate part of the file name, . For example: 5_req.xml,
req5.xml, req.5.xml

n

The index must be in the same location in all files.

n

Example: 9984_req1.xml and 9984_req2.xml. The files are
compared according to index numbers are 1 and 2 (not 9984).

Files with the same name are paired.

File name extensions are ignored.
Tip: Place request and response files in separate folders to ease the
import process.
From Clipboard

Pastes clipboard content into the message box.

Request/Response Pairing Dialog Box
This dialog box enables you to review and make changes to the request/response message pairing
performed by Service Virtualization.
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To access

Opens automatically when you select to import multiple messages in the Import
Request/Response Message dialog box.

Important
information

l

Service Virtualization pairs request and response files according to file names.
For additional details, see "Import Request/Response Message Dialog Box"
on page 204.

l

A file that does not match another file is also imported. For example, if there is
a request file, but no corresponding response file, the request file is still
imported.

Relevant
tasks

"How to Edit a Data Model" on page 157

See also

"Data Model Overview" on page 148

User interface elements are described below:
UI Element

Description

Request/Response The request and response files to import.
File
To make changes to the request/response file pairing, select a request or
response file and move it up or down in the list.
Create a Track

Places the imported messages into a separate track in the data model.

New Data Driven Rule Dialog Box
This dialog box enables you to create a new rule connected to an external data source.
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To access

1. In the Data Model Editor, select New Rule > Data Driven Rule.
2. Select one of the following:
n

Create new data file.

n

Use existing data file.

Important
Creating a new data file: The Service Virtualization Designer creates a new
information Excel file, structured according to the schema (message structure) associated
with the virtual service. Rule columns are automatically bound to the worksheet
columns.
Using an existing data file: After you create the rule you must then manually
bind rule columns to worksheet columns. After binding, the external data is
imported to the Data Model.
Relevant
tasks
See also

l

"How to Edit a Data Model" on page 157

l

"How to Work With External Data Sources" on page 178

"Data Model Overview" on page 148

User interface elements are described below:
UI Element

Description

New/Existing
External Data
File

To use an existing data file: Select a file from the drop-down list, or click
the browse button to navigate to the file location.

Column Names

If you are adding an existing file, this option indicates that the first row of your
file is a header row, containing the names of each column.

To create a new data file: Type a name for the file and specify its path, or
click the browse button to navigate to the file location.
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UI Element

Description

Data
The rule is configured to import data automatically from the external data file
synchronization before each simulation.
Service
Operations

The operations in your virtual service for which you want to import data.
By default, all of the virtual service's operations are selected for import. To
change this selection, click Change and edit the list of operations for import.

Import/Export Data Dialog Box
The Import Data dialog box enables you to import data from an external data file to your data model.

The Export Data dialog box enables you to export data from your data model to an external data file.

To access

Import Data: Right-click a custom rule and select Import Data.
Export Data: Right-click a custom rule or the Learned Data rule and select
Export Data.
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Relevant
tasks

"How to Work With External Data Sources" on page 178

See also

"Data Model Overview" on page 148

User interface elements are described below:
Import Data Dialog Box
UI Element

Description

External Data
File

Specify the path to the external data file containing data to import, or click the
browse button to navigate to the file location.

Column Names

Indicates that the first row of your file is a header row, containing the names
of each column.

Data
Data is automatically re-imported from the external data file before each
synchronization Simulation session.
Note: After import, do not modify data directly in the Data Model Editor.
The next time that the data is re-imported from the external file your
changes will be lost.
Service
Operations

The operations in your virtual service for which you want to import data.
By default, all of the virtual service's operations are selected for import. To
change this selection, click Change and edit the list of operations.

Export Data Dialog Box
UI Element

Description

External Data
File

Specify the path for the new external data file, or click the browse button to
navigate to the file location.

Data
Data is automatically exported to the external data file after a virtual service
synchronization Learning session.
Note: After export, do not modify the external data file. Each time the
data is exported, the external file is deleted and recreated. Therefore any
changes you make in the external file will be lost on the next automatic
export.
Service
Operations

The operations in your virtual service for which you want to export data.
By default, all of the virtual service's operations are selected for export. To
change this selection, click Change and edit the list of operations.
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External Data Properties Dialog Box
This dialog box enables you to configure options for a data rule that is working with an external data
file.

To access

Right-click a rule or column header and select External Data Properties.
Available for a rule that is associated with an external data file for import or
export.

Relevant
tasks

"How to Work With External Data Sources" on page 178

See also

"Data Driving" on page 153

User interface elements are described below:
UI Element

Description

Importing data
from external
data file

The rule is associated with an external file from which it has imported data.

Exporting data
to external data
file

The rule is associated with an external file to which it has exported data.

External Data
File

The path to the associated external data file .
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UI Element

Description

Column Names

Indicates that the first row of your file is a header row, containing the names
of each column.
Available for import only.

Data
For import: Data is automatically re-imported from the external data file
Synchronization before each Simulation session.
For export: Data is automatically exported to the external data file after a
virtual service Learning session.
Service
Operations

The operations in your virtual service that are configured for import or export.

Sheet Relations

Binding configuration for working with array data. You can define the
relationships between worksheets that is required for array binding.

By default, all of the virtual service's operations are selected. To change this
selection, click Change and edit the list of operations.

Primary/Foreign Key: The drop-down lists display the columns in the
external data file. The format of the keys is <worksheet_name>.<column_
name>. Select a value for each key to define the relationship.
Add

Adds a row, enabling you to define an additional relationship between
primary and foreign keys.
Available when working with array data.

Delete

Removes the selected row.
Available when working with array data.

Refresh Data on
Confirm

Updates the data according to your new settings. For example, if you
changed the setting from Import to Export, the data is exported to the
external file when you click Finish.

New/Edit Function Dialog Box
The New Function f(x) dialog box enables you to create a new function to use in your data model.
You can then edit functions from the Edit Function dialog box.
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To
access

New Function dialog box: Use one of the following:
l

In the Data Model Editor, click inside the function field (fx) for a column and select
New f(x).

l

In the Virtualization Explorer, under Data Models, right-click the Functions folder,
and select New f(x).

Edit Function dialog box: In the Virtualization Explorer, under Data Models,
expand the Functions folder. Double-click a function to edit.
Relevant "How to Define Rule Functions" on page 160
tasks
See also

"Rule Functions" on page 150

User interface elements are described below:
UI
Element

Description

Function Enter a function. For details on the variables you can use to configure a new, custom
function, see "How to Define Custom Functions" on page 176.
Name

Enter a name for the new function or accept the default.

More...

Opens the online help on how to define rule functions.

Change Columns Dialog Box
The Change Columns dialog box enables you to specify which columns are displayed in the data
table of a rule.
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To access

Use one of the following:
l

In the Data Model Editor, select Columns > Change
Columns.

l

Right-click a column header and select Change Columns.

Relevant tasks "How to Edit a Data Model" on page 157
User interface elements are described below.
UI Element

Description

Filtering
columns in the
tree

Enter text in the search field to filter the columns displayed in this dialog box.

Default Filter
Options

Displays default filters you can apply to assist you in viewing the list of
columns.
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UI Element

Description

Columns tree

Select the columns that you want to display in the data table.
l

When you click on a column name, it is highlighted for you in the currently
open model.

l

Select an option from the drop-down list to change the current view in the
open model.

l

Right-click an item in the tree to display additional options for
showing/hiding branches/children.

Note: Selecting a header level checkbox does not select all child
headers.
In this example, the Request box is selected, indicating that you have
selected the Request header to display in the Data Model Editor.
The shaded box for the Request header indicates that one or more child
headers are selected.

OK/Cancel

Saves/discards your selections.

Edit Sheet Relations Dialog Box
This dialog box enables you to configure binding for an array. You can define the relationships
between worksheets that are required for array binding.
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To access

Relevant
tasks

Use one of the following within the data rule:
l

When binding an array item, this dialog box opens automatically.

l

Right-click the rule or column header and select External Data Properties.
See the Sheet Relations area.

"How to Work With External Data Sources" on page 178

Important
When there is a 1 to 1 relationship, there will be exactly one item in the array for
information each row. Items of the array can be located on the same worksheet as other data,
and the relationship will be specified as the same worksheet column for the
Primary and Foreign Key. This works only for a one level array. It cannot be used
if the array is part of another array.
See also

"Data Driving" on page 153

User interface elements are described below:
UI Element

Description

Primary/Foreign The drop-down lists display the columns in the external data file. The format
Key
of the keys is <worksheet_name>.<column_name>.
Select a value for each key to define the relationship.
Add

Adds a row, enabling you to define an additional relationship between primary
and foreign keys.

Delete

Removes the selected row.

HP Service Virtualization (3.10)

Page 216 of 299

User Guide
Chapter 7: Simulation Modeling

Data Format/Response Type/Choice Binding Dialog
Box
This dialog box enables you configure binding for working with different data formats
(REST protocol), different response types (SOAP protocol), or a message structure containing
different types.

To access

The dialog box opens automatically when you start to bind to an Excel worksheet
column where the response can contain different data formats, different response
types, or a message structure which can be considered to contain different types.

Relevant
tasks

"How to Work With External Data Sources" on page 178

Important
Map choices to cell values based on predefined cell values read from an external
information data source or by setting custom values.
See also

"Data Driving" on page 153

User interface elements are described below:
UI Element

Description

Default Data Format/Response
Type/Choice Binding

Used when no value from the mapping table matches.

Data Format/Response
Type/Choice

The mapping table lists the real formats or types based on
the data in your external data file.

Cell Value

To configure a value for each possible real type or format,
select a value from the drop-down list.

Select Service Operation Dialog Box
This dialog box enables you to configure a virtual service to call external services.
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To access

1. In the Data Model Editor, select the operation from which you want to
call the external service.
2. Click Activity > Import Activities, enter the path to the WSDL
schema, and click Next.

Important
information

Only SOAP and XML over HTTP service call activities are supported.

Relevant tasks

"How to Edit a Data Model" on page 157

See also

"Data Model Overview" on page 148

User interface elements are described below:
UI Element

Description

Service operation

The list of operations available for the
service call activity.

Add the activity after response

Runs the activity after the response is
sent to the client.
By default, the service call activity is
added to the rule before the response.

Do not add an activity now.
Import the service description
for later use.

Imports the service description
document. No activity is added to the
current rule.

Service Properties for XML Service Call Activity
These dialog boxes enables you to configure an XML virtual service to call external services.
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To access

1. In the Data Model Editor, select the operation from which you want to call the
external service.
2. Click Activity > Import Activities. Enter the path to the XML schema (.xsd
file), and click Next.

Relevant
tasks

"How to Edit a Data Model" on page 157 (See Add/Edit service call activity.)

See also

"Data Model Overview" on page 148

User interface elements are described below:
UI Element

Description

Input/Output
Message Type

Select message elements for input and output messages. Available
types are displayed.

Real Service
Endpoint

Enter the URL for the service you are calling.
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UI Element

Description

Show Endpoint
Topology

Displays a diagram of the service endpoint configuration.

Test Endpoint

Checks that the endpoint is configured correctly.

Activity Properties Dialog Box
This dialog box enables you to modify properties for a service call activity.

To access

1. In the Data Model Editor, expand a rule.
2. Right-click the column header of a service call activity, and select Activity
Properties.

Relevant
tasks

"How to Edit a Data Model" on page 157

See also

l

"Select Service Operation Dialog Box" on page 217

l

"Data Model Overview" on page 148

User interface elements are described below:
UI Element

Description

State

Indicates if the service call activity is currently enabled or disabled for the rule.
Click the on/off icon
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UI Element

Description

Name

The name of the activity.
By default, this is the name of the operation in the called service.
Tip: You can edit this field. If you add multiple activities calling the same
operation in the same service, give each activity a different name.

URL

The endpoint location of the called service.

Delay after
response

Indicates the amount of time, in milliseconds, to wait after sending a response to
the client, before running the activity.
Available only for a service call activity that is scheduled for after the response.

Performance Model Editor
The Performance Model Editor enables you to configure performance metrics for a virtual service to
use during simulation. You can configure the performance for the whole service or for its individual
operations.

To access

Use one of the following:
l

In the Virtualization Explorer, double-click a performance model.

l

In the Virtual Service Editor, under Performance Models, select a
performance model and click Edit.

Important
information

Click a value to edit.

Relevant tasks

l

"How to Manage Simulation Models" on page 156

l

"How to Edit a Performance Model" on page 183

See also

"Performance Model Overview" on page 155
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User interface elements are described below (unlabeled elements are shown in angle brackets):

Common Areas
UI Element

Description

<performance
model name and
description>

The name and description of the data model. Click to edit.

<operations>

Located in the left pane of the editor. Displays a list of the operations in the
service associated with the selected performance model.
By default, the service name is selected, and a performance overview is
displayed in the main pane of the Performance Model Editor. For details,
see Service Level View.
Enter text in the filter box to filter for specific operations in the list.
Select an operation from the list to display its details in the main pane of
the Performance Model Editor. For details, see Operation Level View.

Edit Service
Description

Opens the Service Description Editor. For details, see "Service
Description Editor" on page 224.

Service Level View
UI
Element
Booster

Description
A set of boosters to provide high-level control of the operations selected in the
operation table.
Available boosters include:
l

CPU. CPU power multiplication factor.

l

Network. Network throughput multiplication factor.

l

Cluster. Scalability multiplication factor.

l

Expert. Multiplication factors for Response Time, Hit Rate, and Throughput
Limit values.

l

None. Turn off all boosters.
Note: You must restart the simulation to apply changes.

<booster The sliding controls and inputs enable you to set the boost level for the selected
controls> booster. The setting affects the various performance criteria displayed in the
operation table.
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UI
Element
Model

Description
Enables you to set more granular settings for individual performance criteria for
individual operations. You can set the following:
l

Response Time [ms]. The time for the service to process a request and return a
relevant response.

l

Threshold [hits/s]. The maximum number of requests and responses the
service can process without any impact on performance.

l

Throughput Limit [MB/s]. The maximum data capacity the service can
process.

To apply the performance changes to the service and all of its operations, select the
Boost or Throughput Limit check boxes at the top of the table.
Alternatively, select options separately for the service and per operation.
Click an operation name to open the operation level view for the specific operation.

Operation Level View
UI Element

Description

<performance The graph displays the expected performance based on the criteria set for the
graph>
operation.
Select Show Measured Data to view any recorded performance data in the
graph. Note: This option is displayed only after data is recorded for the service.
The graph is interactive. Move the graph elements to show the effects on
performance.
<performance Displays the advanced performance criteria for the operation with the option to
criteria>
edit them. The following additional criteria are available:
l

Tolerance [%]. The acceptable range of variation in performance for the
operation.

l

Maximum Hits per Second. The maximum number of requests and
responses the operation is allowed to process.

l

Maximum Response Time. The maximum time for a response at peak
performance levels.

Click a value to edit.
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Service Description Editor
The Service Description Editor enables you to edit a virtual service description, including editing
metadata, managing XML schemas, adding and removing operations, and defining session
identifiers.

To access

l

In the Virtualization Explorer, expand a virtual service and double-click the
service description.

l

In the Virtual Service Editor, under Service Description, click Edit.

l

In the Data Model Editor, select one of the following:
n

URI Spaces > Edit URI Spaces

n

Operations > Edit Operations

Important
information

Not all editing operations are available for all protocols.

Relevant
tasks

"How to Edit a Service Description" on page 183

See also

"Service Descriptions" on page 90

You can edit URI Spaces when working with the REST protocol, and edit
operations when working with XML protocols.

User interface elements are described below (unlabeled elements are shown in angle brackets):
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UI Element

Description

<Operations pane>

Located in the left pane of the editor. Displays a list of the operations or
URI spaces in the service.
Enter text in the filter box to filter for specific operations in the list.
Select an operation or URI space to display its details.

Add Operation

Located at the bottom of the operations pane.
Opens the Add Operation dialog box, enabling you to select input and
output message types. You must assign each operation a unique input
message type. Available for XML services.
SAP RFC: Connects to the SAP Server and displays a list of available
operations that you can add to your virtual service.

Add URI Space

Located at the bottom of the operations pane.
Opens the Add New URI Space dialog box, enabling you to create a
new URI space. Enter the URI path.
Available for REST services.

Delete
Located at the bottom of the operations pane.
Operation/URI Space
Deletes the selected operation/URI space.
Session ID
Definition

Defines the elements used to identify requests coming from the same
source during a Learning session.
The following identifiers are configured by default:
l

For HTTP: ClientAddress metadata

l

For MQ: UserID metadata

Other transport protocols (TibcoEMS, GenericJMS, JDBC) do not have
default session identifiers. Tracks are created after each Learning
session.
Click Edit to modify the settings. For details, see "Session ID
Definition Wizard" on the next page.
Message Metadata

Enables you to edit request and response metadata. Click Edit to open
the Edit Metadata dialog box. For details, see "Edit Metadata Dialog
Box" on page 235.
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UI Element

Description

XML Schemas

Lists all XML schema defined in the service description. You can add
an XML schema, or edit or remove schemas.
l

Add. Opens the Import XML Schema dialog box, enabling you to
enter a file location for an existing schema (.xsd file), and add it to
the service description.

l

Edit. Opens the schema in an XML editor, enabling you to modify
the schema. Click the Tools pane to access tools for editing the
schema.

l

Delete. Removes the schema from the service description.

URI Space
Properties

Displays the URI space path.

Data Formats

Lists the available request and response data formats.
Click Add to add a new data format. For details, see "Add Data Format
Dialog Box" on page 237.
Available for URI spaces.

Data Masking

Enables you to hide specific data elements, to protect sensitive data.
For details, see "Data Masking Dialog Box" on page 232.

Session ID Definition Wizard
This wizard enables you to specify which metadata or message elements to use to identify
requests coming from the same source. Service Virtualization uses this information to create
different tracks from learned data, and uses the tracks to create different sessions during
simulation.
To access

In the Service Description Editor, under Session ID Definition, click Edit.

Wizard
map

This wizard contains:
"Define Default Session IDs Page" on the next page > "Select Session ID Page"
on page 228 > "Define Operation Specific Session IDs Page" on page 229 >
"Define Data Format Session IDs Page" on page 230 > "Define Session IDs
Summary Page" on page 231
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Important
information

l

Service Virtualization defines default identifiers based on the protocol and
agent you define for the virtual service. This wizard enables you to modify the
default selections.

l

The following can be defined as session identifiers:
n

message elements

n

protocol metadata (headers)

n

cookies

Relevant
tasks

"How to Edit a Service Description" on page 183

See also

"Service Descriptions" on page 90

Define Default Session IDs Page
This wizard page enables you to define session identifiers at the service level.

Important
General information about this wizard is available here: "Session ID Definition
information Wizard" on the previous page
Wizard
map

The Session ID Definition wizard contains:
"Define Default Session IDs Page" above > "Select Session ID Page" on the
next page > "Define Data Format Session IDs Page" on page 230 > "Define
Session IDs Summary Page" on page 231

User interface elements are described below:
UI Element

Description

Request/Response Displays current settings for request and response elements.
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UI Element

Description

Session ID Source

The source for identifying sessions. Options include:

Data Key

l

Metadata. Enables you to define which metadata to use as a session
identifier. Select an option from the Data Key list.

l

None. The data is not placed into tracks based on metadata values.

The metadata (protocol header) used to identify a unique session.
Available when you select Metadata in the Session ID Source field.
Click Edit to change the selection.

Select Session ID Page
This wizard page enables you to select an element to use as a session identifier.

Important
General information about this wizard is available here: "Session ID Definition
information Wizard" on page 226
Wizard
map

The Session ID Definition wizard contains:
"Define Default Session IDs Page" on the previous page > "Select Session
ID Page" above > "Define Operation Specific Session IDs Page" on the next
page > "Define Data Format Session IDs Page" on page 230 > "Define Session
IDs Summary Page" on page 231

User interface elements are described below (unlabeled elements are shown in angle brackets):
UI Element

Description

<Element tree>

Expand the tree to display all message elements.

Search element Enter a search string to locate specific elements.
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Define Operation Specific Session IDs Page
This wizard page enables you to define session identifiers at the operation level.

Important
General information about this wizard is available here: "Session ID Definition
information Wizard" on page 226
Wizard
map

The Session ID Definition wizard contains:
"Define Default Session IDs Page" on page 227 > "Select Session ID Page" on
the previous page > "Define Operation Specific Session IDs Page" above >
"Define Data Format Session IDs Page" on the next page > "Define Session IDs
Summary Page" on page 231

User interface elements are described below:
UI
Element

Description

Operation

The operations in the virtual service.

Session
The source for identifying sessions. Options include:
ID Source
l In Message. Enables you to define an element within the message to use as a
session identifier. Select an option from the Data Key list.
l

Inherited. Uses the setting that is defined at the service level.

l

None. The data is not placed into tracks based on values at the operation level.
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UI
Element
Data Key

Description
The message element used as the session identifier. The data key can be a
message header or a field.
Available when you select In Message in the Session ID Source field.
Click Edit to change the selection.

Edit
Displays fields for response specific data. By default, only fields for requestResponse specific information are displayed.
Delete
Removes the response-specific session ID row.
Response
Edit Data
Formats

Opens the Define Data Format Session IDs page, enabling you to define session
identifiers per data format type. For details, see "Define Data Format Session IDs
Page" below.

Define Data Format Session IDs Page
This wizard page enables you to define session identifiers per data format type.

Important
General information about this wizard is available here: "Session ID Definition
information Wizard" on page 226
Wizard
map

The Session ID Definition wizard contains:
"Define Default Session IDs Page" on page 227 > "Select Session ID Page" on
page 228 > "Define Operation Specific Session IDs Page" on the previous page >
"Define Data Format Session IDs Page" above > "Define Session IDs
Summary Page" on the next page

User interface elements are described below:

HP Service Virtualization (3.10)

Page 230 of 299

User Guide
Chapter 7: Simulation Modeling

UI
Element

Description

Data
Format

The data formats available in the service.

Session
ID Source

The source for identifying sessions. Options include:

Data Key

l

In Message Enables you to define an element within the message to use as a
session identifier. Select an option from the Data Key list.

l

Inherited. Uses the setting that is defined at the operation level.

l

None. The data is not placed into tracks based on data format.

The message element used as the session identifier. Select a value.
Available when you select In Message in the Session ID Source field.
Click Edit to change the selection.

Define Session IDs Summary Page
This wizard page displays a summary of how Service Virtualization can organize your learned data
into tracks.
Based on the session identifiers you have defined, Service Virtualization will create a separate
track for each unique session identifier value.
Note: Learned data is grouped into tracks after the next Learning session.
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Important
information

Wizard
map

l

General information about this wizard is available here: "Session ID Definition
Wizard" on page 226

l

In the event of an error, click Back to modify your settings.

The Session ID Definition wizard contains:
"Define Default Session IDs Page" on page 227 > "Select Session ID Page" on
page 228 > "Define Operation Specific Session IDs Page" on page 229 > "Define
Data Format Session IDs Page" on page 230 > "Define Session IDs Summary
Page" on the previous page

User interface elements are described below:
UI Element

Description

Learned Data
pie chart

Displays the expected results based on current learned data.

Mapped

The percentage of current learned data that can be mapped to a distinct
session, based on your session ID selections.

Not mapped

The percentage of current learned data that cannot be mapped to a distinct
session, based on your session ID selections.

Finish

Saves your selections. Learned data is grouped into tracks after the next
Learning session.

Data Masking Dialog Box
This dialog box enables you to hide specific request and response data elements.
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To access

Important
information

Use one of the following:
l

In the Service Description Editor, under Data Masking, click Edit.

l

In the Data Model Editor, right-click a column header and select Mask.

l

When you set or change data masking settings, all data from associated
operations in all data models in the service are removed.

l

In the Data Model Editor, columns that are configured for data masking are
marked with a red hash sign (#) in the column header.

Relevant
tasks

"How to Edit a Service Description" on page 183

See also

"Service Descriptions" on page 90

User interface elements are described below (unlabeled elements are shown in angle brackets):
UI Element

Description

Search
element

Search for a specific request or response element.

Algorithm

The masking option for the selected element.
None. Data masking is not configured for the element.
Replace. Opens the Replace Algorithm Configuration dialog box, enabling you to
configure a custom algorithm for hiding the data. For details, see "Replace
Algorithm Configuration Dialog Box" on the next page.
SHA1. Masks data using the secure hash algorithm SHA-1.
Note: When you configure a parent element, all child elements are
automatically configured with the same settings.

Parameters

If you are using the Replace algorithm option, the parameters indicate the match
pattern and replace value you defined.
To change the parameters, click the parameter link to open the Replace Algorithm
Configuration dialog box.
Tip: RIght-click in the parameter field and select Copy to copy/paste the
parameter definition to another element.

<operations Displays each operation in the service. Click to expand operations and drill down
table>
to the specific request and response elements that you want to configure.
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Replace Algorithm Configuration Dialog Box
This dialog box enables you to select or define an algorithm for replacing specified text in message
data.

To access

In the Data Masking dialog box, select a data element, and do one of the
following:
l

Under Algorithm, select Replace.

l

For an element already configured to use the Replace function, click in the
Parameters column.

Important
information

When you set or change data masking settings, all data from associated
operations in all data models in the service are removed.

Relevant
tasks

"How to Edit a Data Model" on page 157

See also

"Data Model Overview" on page 148

User interface elements are described below:
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UI Element

Description

Replace using static value

Enter a string to use to replace the strings that match your
specifications.
For example, you might want to replace credit card data with the
following value: XXXX-XXXX-XXXX-XXXX
From File. Browse the file system to select a file. The data is
masked using the contents of the selected file.

Replace using regular
expression

Enables you to define a regular expression to match a particular
string of text.
You can use regular expressions in the Match pattern and
Replace value fields.
For help on creating regular expressions, see "How to Configure
Regular Expressions" on page 177.

Match pattern

Enter the string that you want to match, or click the drop-down
arrow to select a previously entered string.

Replace value

The value you want to use to replace the data that matches your
Match pattern.
Enter the string that you want to use to mask the data you are
replacing.

Change all occurrences of
regular expression

Updates all elements in all data models in the service that are
using this regular expression for data masking.

Test Input

Enter a string to test your settings.

Test Output

Displays the masked output based on the settings you defined.

Edit Metadata Dialog Box
The Edit Metadata dialog box enables you to edit metadata for the current service description.
Metadata are parameters that contain some protocol-specific information such as time stamps,
correlation information, or status codes. They are part of the protocol message, but external to the
message body, such as URL parameters, or HTTP headers.
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To access

In the Service Description Editor, under Request Metadata or Response
Metadata, select Edit.

Important
information

Items displayed in gray are disabled.

Relevant tasks

"How to Edit a Service Description" on page 183

See also

"Service Descriptions" on page 90

User interface elements are described below:
UI
Element
Description
Enable

Activate the selected metadata. This is the default status.

Disable

Deactivate the selected metadata. Disabled metatada are not available for viewing or
editing in the Data Model Editor, and values for disabled metadata are not learned or
simulated.
Disabled metadata are displayed in gray.

Add

Opens the Add New Metadata dialog box. Enter a name and select a type for the new
metadata. The types available vary based on the protocol with which you are working.

Edit

Enables you to modify the selected item.

Delete

Removes the metadata from all data models in the virtual service, and deletes the
metadata's related data.
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Add Data Format Dialog Box
This dialog box enables you to add a new data format to your service description. You can copy
from an existing URI space, or create a new format.

To access

1. In the Service Description Editor, in the operations pane on the left side,
select a URI space.
2. Under Request or Response Data Format, click Add.

Relevant
tasks

"How to Edit a Service Description" on page 183

See also

"Service Descriptions" on page 90
"Service Description Editor" on page 224

User interface elements are described below.
UI
Element

Description

URI Space Enter the path of the existing URI space you want to copy.
Data
Format

Lists supported data formats.

Type

The data format types available in the schema.
Available for XML data format only.

External
File

Opens the Import XML Schema dialog box, enabling you to import a schema from
an external file.
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Add SAP Operation Dialog Box
This dialog box enables you to import operations to your service from a SAP server.

To access

In the Service Description Editor, in the operations pane on the left side, click
Add Operation.

Relevant
tasks

"How to Edit a Service Description" on page 183

See also

"Service Descriptions" on page 90
"Service Description Editor" on page 224

User interface elements are described below.
UI Element

Description

User
Credentials of a user account that can connect to the SAP server.
Name/Password
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UI Element

Description

Search for

Enter text to search for specific operation names, and click the Search
button.
Use the asterisk (*) as a wildcard character in your search string to match
any text. For example, STFC_* will search for all functions that start with
STFC_.

Search

Enter text in the Search for box and click Search to display matching
functions.
Tip: To display all available RFC functions from the SAP server, enter
user name and password credentials and click Search.

RFC Function

Lists all RFC Functions available on the SAP server configured for the virtual
service.
Click the checkbox next to RFC Function to select all functions.

Add

Adds selected functions to the SAP virtual service.

FAQs: Data Model Editor
This section provides tips on working in the Data Model Editor.
For task details, see "How to Edit a Data Model" on page 157.

I can't see all my columns. Can I configure what is displayed?
To show/hide columns, use the Change Columns dialog box. To access, click the Columns
button, and select Change Columns.
Alternatively, click the x in a column header to hide a specific column.

Can I view the entire header structure?
Double-click headers to drill down within the header structure.

Some column headers are in italic text (header). What does that mean?
These are complex headers that include lower level headers under them. Double-click the header to
display its lower level headers, or change your selections in the Change Columns dialog box.

How does the 'Copy from' function work?
When you select the Copy from function for a column and then scroll over the other columns, an
indicator displays to show whether a source column is compatible with the target column.
Indicates a column that you can use as a source.
Indicates a column that you cannot use as a source.
Click the desired source column to select.
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What's the best way to work with array data?
It is recommended to work directly in the data row within the rule.

It's hard to work with all the columns in my message data. Is there a better
way?
If your structure includes many columns, the Row Detail dialog box offers a more user friendly
format for viewing, entering, and editing data manually. Right-click a row and select Row Detail.

Can I search within a row?
The Row Detail dialog box enables you to search the row to find specific text. Right-click a row and
select Row Detail.

I exported data to an Excel file, but I can't find the file. Where is it?
Hover over the import/export icon in the data rule to see the location of your external data file.
You can also right-click the rule and select External Data Properties for more information on the
external file.

How can I update column bindings for a data-driven rule?
Do one of the following:
l

Expand a rule, and click the bind icon
the rule.

. A "preview" of your external data file displays within

l

Right-click a rule and select Open External Data.

I see more columns than I need to. How can I hide some of them?
To show/hide columns, use the Change Columns dialog box. To access, click the Columns
button, and select Change Columns.

Why is part of the row gray, with no visible data?
The headers are showing a different message structure. Double-click on the grayed area to switch
header structure.

How can I add data as a message?
Right-click a rule and select Import Message.

I see metadata, but no actual data. Why don't I see the data?
The columns (headers) that contain the data are hidden. Click the Columns button, and select
select Change Columns to change the display settings.

Some column headers are marked with a red hash sign (#). What does that
mean?
These columns are configured for data masking. For details, see "Data Masking Dialog Box" on
page 232.
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Topology Overview
The Topology Editor enables you to model composite applications by creating a visual map of
services, called a topology. You can group them into larger composites, mark their types, and
display the service calls between them.
For task details, see "How to Model Composite Applications" below.

How to Model Composite Applications
This task describes how to create and configure a topology to model and test your composite
application.
This task is part of a higher-level task. For details, see "How to Use Service Virtualization" on
page 25.
This task includes the following steps:
"Optional: Discover services" below
"Create a topology" on the next page
"Configure the topology" on the next page
"Test your composite application" on the next page
"Virtualize services" on page 244
"Reconfigure clients" on page 244
"Learn service behavior" on page 244
"Simulate service behavior" on page 245
1.

Optional: Discover services
You can use Service Discovery to find all the services used by an application via a proxy
agent.
Note: Supported for SOAP services only.
a. On the Start Page, click Discover Services to create a new virtualization project and
starts the discovery process, enabling you to find all services used by an application.
Alternatively, you can discover services in an existing project. In the Topology Editor, rightclick and select Start Service Discovery.
b. In the Service Discovery dialog box, configure your client application to use the Service
Virtualization proxies. You must configure the proxies before running Service Discovery.
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For user interface details, see "Service Discovery Dialog Box" on page 251.
c. Run your client application under test .
d. When services are discovered, click Stop Discovery. The discovered services are stored
in a group called Discovered Services. You can use them in your topology.
2.

Create a topology
From the main menu, select File > New > Topology. For user interface details, see
"Summary of New Topology Dialog Box" on page 246.
The new topology opens in the Topology Editor. By default, Service Virtualization creates the
new topology with one service which calls another, limited access service.

3.

Configure the topology
You configure your topology using the Topology Editor. To model your composite application,
create a visual map of your services, their types, and the connections between them.
a. From the Tools pane in the Topology Editor, add items to the topology.
b. Connect services using service call connectors. Move the cursor to the right edge of the
calling service until the hand icon displays. Then click and drag the connector to the called
service.
c. To mark additional services as limited or secure, right-click a service and select Set
Limited Access or Set Secured Access. For additional configuration options, right-click a
service to view the context menu.
For user interface details, see "Topology Editor" on page 246.

4.

Test your composite application
The process of testing your composite application includes the following steps:
a. virtualize services
b. reconfigure clients
c. learn services
d. simulate services
To test a service, in the Topology Editor, right-click the service and select Test. Services with
limited access, or services that may require reconfiguration are indicated with unique icons in
the Topology Editor. When you select to test a service that calls other limited access services,
the Task List opens on the right side of the Topology Editor. The Task List provides step-bystep instructions to guide you through the process required to virtualize, learn, and simulate the
limited access service that your service under test calls.
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For user interface details, see the Task List section of the "Topology Editor" on page 246.
In addition, you can add and virtualize individual components, as described in the subsequent
steps in this task.
5.

Virtualize services
In the Topology Editor, right-click a service and select Create Virtual Service. You can select
an existing virtual service from a drop-down list, or choose to create a new virtual service.For
user interface details on creating a new virtual service, see "Create New Virtual Service
Wizard" on page 98.
If a service is marked as secure and does not already have any associated authentication
Service Virtualization cannot access the service and prompts you to provide authentication.
For details on setting authentication credentials, see "How to Set Security" on page 255.

6.

Reconfigure clients
When you virtualize services, the services that call them may require reconfiguration to use the
new virtual service in place of the real service.
a. A service that requires reconfiguration is displayed in the Topology Editor with an
exclamation point icon. Click the icon to open the Reconfigure Service dialog box, and
update endpoint details for real and virtual services as required.
b. When you have reconfigured the calling component, click Mark Completed and close the
dialog box. The exclamation point icon is no longer displayed.

7.

Learn service behavior
You can learn the behavior of individual services in the topology of a composite application.
a. Prerequisites: Edit the topology, marking limited and secured services, and import service
descriptions for the services you want to learn.
b. In the Topology Editor, right-click each service for which you want to record the real service
behavior and select Learn.
c. Run your test through the composite application using a client or test script. Service
Virtualization records the requests and responses for the virtualized services and creates
simulation models for each one.
As you run your test, the Runtime View, located in the lower pane of the window, displays
details for each virtual service.
d. When you have finished recording, right-click each service you are recording and select
Stop Learning. The services are placed in Simulate Mode.
Alternatively, select Simulate and the application stops the learning process and switches
directly to simulating.
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8.

Simulate service behavior
You can test your composite application using the virtual services in your topology to simulate
the behavior of the real services.
a. Prerequisites: Learn the behavior of the services you want to simulate.
b. In the Topology Editor, right-click each service that you want to simulate and select
Simulate. The service is placed in Simulate mode.
c. Run your test through the composite application using a client or test script. Service
Virtualization processes the requests to each virtualized service and returns responses
based on the simulation model for each.
As you run your test, the Runtime View, located in the lower pane of the window, displays
details for each virtual service.

Topology User Interface
This section includes:
Summary of New Topology Dialog Box

246

Topology Editor

246

Service Discovery Dialog Box

251
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Summary of New Topology Dialog Box
This dialog box enables you to create a new virtualization project.

To access

From the main menu, select File > New > Topology.

Important
information

By default, Service Virtualization creates the new topology with one service
which calls another, limited access service.

Relevant
tasks

"How to Model Composite Applications" on page 242

See also

"Topology Overview" on page 242

User interface elements are described below:
UI Element
Description
Topology

Displays the default name for the topology you are creating.

Change

Opens the Change Topology dialog box, enabling you to edit the name of the
topology.

Create

Creates the new topology.

Topology Editor
The Topology Editor enables you to model composite applications.
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To access

In the Virtualization Explorer, double-click the topology you want to view or
edit.

Relevant
tasks

"How to Model Composite Applications" on page 242

See also

"Topology Overview" on page 242

User interface elements are described below:

Tools Pane
Located on the left side of the editor, enables you to drag and drop the following items to add to your
topology:
Note: If the Tools pane is not displayed by default, from the main menu, select View > Tools.
UI
Element

Description

Service

A service with no particular notation.

Limited
Service

A service marked as having limited access. Access to such services may be
limited due to time or financial constraints.

Secured
Service

A service marked as requiring authentication.

Group

A box enabling you to organize services into larger composites for purposes of
visual mapping.

Context menu
Note: To discover services, right-click inside the Topology Editor and select Start Service
Discovery. For details on service discovery, see "Service Discovery Dialog Box" on page 251.
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Right-click a service in the Topology Editor to access the following commands:
Menu
Item

Description

Set/Unset Marks or unmarks the selected service as having limited access.
Limited
Access
Set/Unset Marks or unmarks the selected service as requiring authentication. For details on
Secured
setting authentication credentials, see "How to Set Security" on page 255.
Access
Test

Marks the selected service, indicating that it is "under test".
Service Virtualization analyzes calls, suggests services to virtualize, and creates a
task in the Task List.
When you select this option for a service that uses other services with limited
access, the Task List opens, displaying step-by-step instructions for testing the
composite application. For details, see Task List.

Preview
Test
Impact

Enables/disables the Test Impact highlighting bar.Service Virtualization analyzes
client calls and highlights services that you may want to virtualize.

Learn
and
Simulate

Enables you to create a new virtual service or import an existing service, and then
places the service in Learning mode.

Create
Virtual
Service

Enables you to create a new virtual service or import an existing service. If you
choose to create a new virtual service, launches the Create Virtual Service wizard.
For details, see "Create New Virtual Service Wizard" on page 98.

Rename

Enables you to rename the selected service.

Delete

Removes the selected service from the topology.

Service Annotation
The annotation for each service varies depending on its settings and various stages of
configuration.
Service Diagram

Description
An empty service.

A service marked as having limited access.
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Service Diagram

Description
A service marked as secure, requiring credentials to access.

A virtualized service.

A virtualized service in Learning Mode. Service Virtualization records
any requests and responses through this service and adds them to the
associated Simulation Model.
A virtualized service in Simulating Mode. Service Virtualization
monitors any requests to this service and returns responses based on
the associated Simulation Model.
Indicates a service that is "under test".

A service suggested for virtualization.

A service requiring attention because it calls a virtualized service and
may require reconfiguration to call the virtual service instead of the real
one.
Click the exclamation point icon to open the Reconfigure Service dialog
box.

Task List
When you select to test a service that calls other limited access services, the Task List opens on
the right side of the Topology Editor. The Task List guides you through the process of testing your
composite application.
Note: The options in a step become available only after you have completed all previous
(prerequisite) steps. When you pass or skip a step, the options in that step are automatically
disabled.
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UI Element

Description

Virtualize
Services

Includes the following options:
l

Virtualize Services. Enables you to define a new virtual service or import an
existing service. If you choose to create a new virtual service, launches the
Create Virtual Service wizard. For details, see "Create New Virtual Service
Wizard" on page 98.
This option enables you to virtualize all relevant services as indicated in the
Task List.

l

Customize Virtualization of Services. Enables you to select the services
that you want to virtualize. Select the desired services and click Virtualize
Selected Service.

When all the missing information for each service in complete, Virtualize
Services is marked as complete and you proceed to Reconfigure Clients.
Service Virtualization adds the virtual services, any new service descriptions,
and a data and performance model for each service to the Virtualization Explorer.
Reconfigure Reconfigure the client to use the endpoints of virtual services in place of the real
Clients
service endpoints. This is required in cases where Service Virtualization can only
perform intrusive virtualization.
Includes the following:

Learn
Services

l

View. Displays instructions for reconfiguring clients.

l

Save As. Saves the instructions as a text file.

l

Mark as Completed. Marks the service under test as complete when you
have reconfigured it to use the virtual services in place of real services.

Includes the following options:
l

Learn Services. Places the virtual services in your composite application in
Learning mode. For details on Learning mode, see "Virtual Service Overview"
on page 86.
Run your test through the composite application using a client or test script.
Service Virtualization records the request and responses for each virtualized
service and creates a simulation model for each. As you run your test, the
Runtime View, located in the lower pane of the window, displays details for
each virtual service.

l

Skip to Simulate Services. Proceed to service simulation without recording
any additional service communication. Select this option if you already have
simulation models for your composite application.
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UI Element

Description

Simulate
Services

Places the virtual services in your composite application in Simulation mode,
enabling you to simulate the behavior of the real services without using them.
Run your test through the composite application using a client or test script.
Service Virtualization processes the requests from your service under test to
each virtualized service and returns responses based on the simulation model for
each. As you run your test, the Runtime View, located in the lower pane of the
window, displays details for each virtual service.

Service Discovery Dialog Box
This dialog box enables you to start Service Discovery to discover all the services used by an
application.

To access

Do one of the following:
l

On the Start Page, click Discover Services to create a new virtualization
project and start the discovery process.

l

In an existing project, in the Topology Editor, right-click and select Start
Service Discovery.

Important
information

Supported for SOAP services only.

Relevant tasks

"How to Model Composite Applications" on page 242

See also

"Topology Overview" on page 242

User interface elements are described below:

HP Service Virtualization (3.10)

Page 251 of 299

User Guide
Chapter 8: Composite Application Topology

UI Element

Description

Server

Currently supported for the Service Virtualization embedded server only.

Service
Virtualization
proxies

You must configure your client application to use the Service Virtualization
proxies before running Service Discovery.
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Virtual Service Security Overview
This section describes how security is handled by Service Virtualization. Service Virtualization
supports virtualization of secured services using either HTTP transport level security or a subset of
SOAP message level security.
Security consists of four components:
l

Confidentiality. The data is encrypted. Only an ultimate recipient can read the data.
Service Virtualization must be able to decrypt the message passed to the virtual service in order
to learn the service. It must also be able to encrypt messages passed to the real service.

l

Integrity. The data is signed. A recipient can validate that the data has not been modified during
transmissions.
Service Virtualization must be able to validate signatures in messages received from clients and
from the real service. It must also be able to sign messages sent to clients and the real service.

l

Authentication. The identity of a client is transferred with the message.
Service Virtualization does not validate received client credentials. In some scenarios, incoming
credentials are secured and are not directly readable. Therefore, the virtual service must have
these credentials (certificates with private keys or user names with passwords) defined in
Service Virtualization's Credential Store, to be able to compute the secured value and pass it to
the real service.

l

Authorization. The service validates that an authenticated client can execute the required
operation.
Service Virtualization does not handle authorization. Authorization logic is left for the real
service.

You can set the following levels of security in Service Virtualization:
l

Transport Security. Transport level security is point-to-point. Security is ensured only on the
transport level connection between two machines. Transport level integrity and confidentiality is
ensured through SSL / TLS (HTTP(s) Proxy agent or the HTTPS Gateway agent) and transport
level authentication is ensured with HTTP authentication mechanisms.
Transport authentication in service virtualization is used only in Stand-By and Learning modes to
access the real service. It is transparently managed by the HTTP Gateway or HTTP(S) proxy
agents. Transport authentication only requires that correctly configured credentials are available
in Service Virtualization's Credential Store.

l

Message Security. Message level security is end-to-end. Security is ensured on the message
level – security is part of message data which can be passed through many intermediaries
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(many connections) without revealing unsecured message content.
Message security in Service Virtualization is used for Stand-By, Learning, and Simulation
modes.
Mixed Security. Mixed security uses transport security to ensure confidentiality and integrity
and message security to pass client credentials (authentication). This security configuration
requires the use of the HTTPS agent and message security modes with names ending with
OverTransport.

l

For task details, see "How to Set Security" below.

How to Set Security
This task describes how to set security for your virtual service.

l

This task is part of a higher-level task. For details, see "How to Use Service Virtualization"
on page 25.

l

To learn more about Service Virtualization security, see "Virtual Service Security Overview"
on the previous page.

This task includes the following steps:
l

"Set authentication credentials" below

l

"Set message security" below

l

"Set transport security" on the next page

Set authentication credentials
Some services may require client authentication on either the transport or message level. When
virtualizing these services, Service Virtualization needs to know the client credentials used to
connect to the real service. The only exception is a scenario wherein a real service with HTTP
transport authentication (Basic, Digest, NTLM) is virtualized through the HTTP(S) proxy agent. In
this scenario, authentication requests are forwarded. Service Virtualization does not need to have
the credentials in the service’s credential store.
In the Virtual Service Editor, expand Security Settings and click Edit Credential Store to configure
the required settings.
For user interface details, see "Edit Credential Store Dialog Box" on page 266.

Set message security
Set message security for your virtual service in the Virtual Service Editor. For task details, see
"How to Set Message Security" on the next page.
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Set transport security
Transport authentication in Service Virtualization is used in Standby and Learning modes to access
the real service. It is transparently managed by the HTTP Gateway or HTTP(S) proxy agents.
Transport authentication only requires that correctly configured credentials are available in Service
Virtualization's Credential Store.
For task details, see "How to Set Transport Security" on page 262.

How to Set Message Security
This task describes how to configure settings for the default message security modes.

l

This task is part of a higher-level task. For details, see "How to Set Security" on the
previous page.

l

To learn more about Service Virtualization security, see "Virtual Service Security Overview"
on page 254.

In the Virtual Service Editor, under Security Settings, configure one of the following security modes
for your virtual service:
l

"Configure CertificateOverTransport mode" below

l

"Configure UserNameOverTransport mode" on the next page

l

"Configure MutualCertificate mode" on page 258

l

"Configure MutualCertificateDuplex mode" on page 260

l

"Configure SupportingCertificateOverTransport mode" on page 261

Configure CertificateOverTransport mode
Certificate over transport mode uses an endorsing supporting binary token over HTTPS:
l

l

Transport security binding
n

Algorithm suite: Basic256

n

Layout: Strict

Endorsing supporting token
n

X509Token (WssX509V3Token10) always included to recipient

n

Inclusion type: MustSupportRefThumbprint / RequireThumbprintReference

To configure CertificateOverTransport mode:
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1. Prerequisites:
a. You must have created a virtual service.
b. The Service Virtualization Credential Store must contain an identity with each used client
certificate.
c. Certificates must contain a private key.
2. In the Virtual Service Editor, expand Security Settings. Under Message Security, select
Enabled.
3. In the Mode drop-down box, select CertificateOverTransport.
Note: Do not configure Real Service Identity or Virtual Service Identity
4. Click Advanced Settings to open the Advanced Message Security Settings dialog box, and
configure as follows:
n

Protection Level. Tthis setting has no effect because encryption and signing are provided
by the transport level (HTTPS).

n

Message Protection Order. This setting has no effect because encryption and signing are
provided by the transport level (HTTPS).

n

Message Security Version. Oonly WS-Security 1.1 is supported because this
configuration mode requires thumbprint token inclusion mode which is not supported in WSSecurity 1.0.

n

Require Derived Keys. This setting should not be changed.

n

Include Timestamp. This setting must be checked because the endorsing supporting
token passed in the request must sign the timestamp header.

n

Allow Serialized Signing Token on Reply. This setting has no effect.

Configure UserNameOverTransport mode
User name over transport mode uses a signed supporting user name token over HTTPS:
l

Transport security binding
n

Algorithm suite: Basic256

n

Layout depends on WS-Security version configured in Advanced settings:
o

WS-Security 1.0: Lax

o

WS-Security 1.1: Strict
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l

Endorsing supporting token
UserNameToken (WssUsernameToken10) always included to recipient.

n

Only PasswordText token type is supported.
To configure UserNameOverTransport mode:
1. Prerequisites:
a. You must have created a virtual service.
b. The Service Virtualization Credential Store must contain an identity with each user and
password used for authentication to the real service.
2. In the Virtual Service Editor, expand Security Settings. Under Message Security, select
Enabled.
3. In the Mode drop-down box, select UserNameOverTransport.
Note: Do not configure Real Service Identity or Virtual Service Identity
4. Click Advanced Settings to open the Advanced Message Security Settings dialog box, and
configure as follows:
n

Protection Level. This setting has no effect because encryption and signing are provided
by the transport level (HTTPS).

n

Message Protection Order. This setting has no effect because encryption and signing are
provided by the transport level (HTTPS).

n

Message Security Version. Layout used for security header:
o

Message security versions using WS-Security 1.0 use Lax layout for security header.

o

Message security versions using WS-Security 1.1 use Strict layout for security header.

n

Require Derived Keys. This setting has no effect.

n

Include Timestamp. This setting controls if requests and responses must contain a
security timestamp.

n

Allow Serialized Signing Token on Reply. This setting has no effect.

Configure MutualCertificate mode
MutualCertificate is a mode with asymmetric security binding (WS-Security 1.0) which uses both
client and server certificates to secure messages over unsecured transport (HTTP):
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l

Assymetric security binding
n

Initiator token: X509Token (WssX509V3Token10) always included to recipient.

n

Recipient token: X509Token (WssX509V3Token10) never included.

n

Algorithm suite: Basic256

n

Layout: Strict

n

Token inclusion type:
o

MustSupportRefKeyIdentifier

o

MustSupportRefIssueSerial

To configure MutualCertificate mode:
1. Prerequisites:
a. You must have created a virtual service.
b. The Service Virtualization Credential Store must contain an identity with a real service
certificate.
If the certificate does not contain a private key, the Credential Store must also contain an
identity for the virtual service, with a certificate containing a private key.
c. The Credential Store must contain an identity with each used client certificate.
d. Client certificates must contain a private key.
2. In the Virtual Service Editor, expand Security Settings. Under Message Security, select
Enabled.
3. In the Mode drop-down box, select MutualCertificate.
4. In the Real Service Identity drop-down box, select an identity configured in the Credential
Store.
If the identity for the real service does not contain a certificate with a private key, or if you want
to use separate identity for the virtual service, select an identity configured in the Credential
Store for Virtual Service Identity. This identity must contain a certificate with a private key.
5. Click Advanced Settings to open the Advanced Message Security Settings dialog box, and
configure as follows:
n

Protection Level. Configures the level of security applied to each message.

n

Message Protection Order. Configures the order of protection operations used to secure
messages.
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n

Message Security Version. Use only WS-Security 1.0.

n

Require Derived Keys. This setting should not be changed.

n

Include Timestamp. This setting controls if requests and responses must contain a
security timestamp.

n

Allow Serialized Signing Token on Reply. This setting has no effect.

Configure MutualCertificateDuplex mode
MutualCertificateDuplex mode with asymmetric security binding (WS-Security 1.0 and 1.1) uses
both client and server certificates to secure messages over unsecured transport (HTTP). The
difference between MutualCertificate and MutualCertificateDuplex is that MutualCertificateDuplex
security mode also sends the recipient’s signing token back to the initiator.
l

Assymetric security binding
n

Initiator token: X509Token (WssX509V3Token10) always included to recipient.

n

Recipient token: X509Token (WssX509V3Token10) always included to initiator.

n

Algorithm suite: Basic256

n

Layout: Strict

n

Token inclusion type depends on WS-Security version configured in Advanced settings::
o

o

WS-Security 1.0
o

MustSupportRefKeyIdentifier

o

MustSupportRefIssueSerial

WS-Security 1.1
o

MustSupportRefThumbprint / RequireThumbprintReference

To configure MutualCertificateDuplex mode:
1. Prerequisites:
a. You must have created a virtual service.
b. The Service Virtualization Credential Store must contain an identity with a real service
certificate.
If the certificate does not contain a private key, the Credential Store must also contain an
identity for the virtual service, with a certificate containing a private key.
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c. The Credential Store must contain an identity with each used client certificate.
d. Client certificates must contain a private key.
2. In the Virtual Service Editor, expand Security Settings. Under Message Security, select
Enabled.
3. In the Mode drop-down box, select MutualCertificateDuplex.
4. In the Real Service Identity drop-down box, select an identity configured in the Credential
Store.
If the identity for the real service does not contain a certificate with a private key, or if you want
to use separate identity for the virtual service, select an identity configured in the Credential
Store for Virtual Service Identity. This identity must contain a certificate with a private key.
5. Click Advanced Settings to open the Advanced Message Security Settings dialog box, and
configure as follows:
n

Protection Level. Configures the level of security applied to each message.

n

Message Protection Order. Configures the order of protection operations used to secure
messages.

n

Message Security Version. this setting defines how the binary token is referenced in the
request message.
o

Message security versions using WS-Security 1.0 requires either issuer serial number or
key identifier of the certificate.

o

Message security versions using WS-Security 1.1 requires thumbprint of the certificate.

n

Require Derived Keys. This setting should not be changed.

n

Include Timestamp. This setting controls if requests and responses must contain a
security timestamp.

n

Allow Serialized Signing Token on Reply. You must select this setting because the
recipient’s signing token is always send back to an initiator.

Configure SupportingCertificateOverTransport mode
Supporting certificate over transport mode uses a supporting binary token over HTTPS:
l

l

Transport security binding
n

Algorithm suite: Basic256

n

Layout: Strict

Endorsing supporting token
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n

X509Token (WssX509V3Token10) always included to recipient

n

Inclusion type: MustSupportRefThumbprint / RequireThumbprintReference

To configureSupportingCertificateOverTransport mode:
1. Prerequisites:
a. You must have created a virtual service.
b. The Service Virtualization Credential Store must contain an identity with each used client
certificate.
2. In the Virtual Service Editor, expand Security Settings. Under Message Security, select
Enabled.
3. In the Mode drop-down box, select SupportingCertificateOverTransport.
Note:
n

Do not configure Real Service Identity or Virtual Service Identity.

n

This mode does not support advanced configuration.

How to Set Transport Security
This task describes how to set transport security for your virtual service.

l

This task is part of a higher-level task. For details, see "How to Set Security" on page 255.

l

To learn more about Service Virtualization security, see "Virtual Service Security Overview"
on page 254.

Transport level security is completely handled by the HTTP based agent. The virtual and real
services can use HTTP authentication to prevent unauthorized use. The service can use basic,
digest, NTLM authentication, or Mutual HTTPS.
This task includes the following:
l

"HTTPS and mutual authentication" on the next page

l

"HTTP authentication over HTTP(S) Proxy agent" on the next page

l

"HTTP authentication over HTTP / HTTPS Gateway agent" on page 264

l

"Windows accounts for HTTP authentication" on page 264
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HTTPS and mutual authentication
Services secured with HTTPS are supported by either the HTTPS Gateway agent or the HTTP(S)
Proxy agent. Both agent types also support Mutual HTTPS where the client authenticates itself
with a client certificate. To use Mutual HTTPS, the credential store must contain a client certificate
and its private key for every client accessing the virtual service. For details on setting
authentication credentials, see "Edit Credential Store Dialog Box" on page 266
The mutual HTTPS authentication for the HTTPS Gateway agent is handled by the client operating
system. Therfore, the certificate of the certification authority that issued all client certificates in use
must be imported into the local computers’s Trusted Root Certificate Authorities store.
To import the Certification Authority's certificate into the local system's certificate store:
1. From the command line or Windows Start menu Search bar, type mmc to run Microsoft
Management Console.
2. From the File menu, select Add/Remove Snap-in.
3. From the Available Snap-ins list, select Certificates and click Add. In the screens that follow,
select Computer account, and then Local Computer. Click Finish.
4. To import the certificates, expand the Certificates (Local Computer) node, as shown below.
Under Trusted Root Certification Authorities, right-click Certificates and select All Tasks >
Import.
5. Follow the on-screen directions to import the certificates.

HTTP authentication over HTTP(S) Proxy agent
When using a proxy agent and running the virtual service in Stand-By or Learning mode, the
authentication is fully transparent and the virtual service does not need any further configuration.
The entire security handshake is passed from the client to the real service through the proxy, and
client credentials are validated just by the real service.
HTTP authentication is not used when the service is in Simulating mode.
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HTTP authentication over HTTP / HTTPS Gateway agent
When using the gateway agent and running the virtual service in Stand-By or Learning mode, the
client authenticates to the virtual service and the virtual service authenticates to the real service.
The virtual service must be able to validate a client’s credentials and pass them to the real service,
meaning that the service must have all user names and passwords in the credential store.
There are several steps to set this authentication:
1. All users who are authenticating to your service must be present in the Windows system where
the virtual service is running. They can be added as local users of the machine or added to the
domain to which the computer belongs. The username and password must be the same as the
one the client uses to authenticate to the real service.
Note: HTTP digest authentication only works with domain users, not local ones. The domain
must have reversibly encrypted passwords. See IIS documentation for details.
2. To delegate requests to the real service (when learning or in stand-by mode), the username and
password must be in the service's credential store.
a. In the Virtual Service Editor, expand Security Settings and click Edit Credential Store.
b. Click Add Identity.
c. Enter Identity details and supply a certificate if required.
d. Click OK to add the identity and OK again to close the Credential Store.
Note: When using HTTP Basic authentication, credentials missing in the credential store are
automatically detected and can be simply added via the Fix It command in the Problem List.
HTTP authentication is not used when the service is in simulating mode.

Windows accounts for HTTP authentication
Basic, digest and NTLM authentication in the HTTP / HTTPS Gateway agent is supported only with
Windows accounts:
1. If the computer running Service Virtualization is in the same domain as the service host, make
sure the domain users are able to log on to the machine the application is running on. Clients
authenticated on the real service must be able to authenticate on the machine running the
virtual service.
2. If machines cannot be placed in the same domain, create local windows or domain user
accounts (domain users still need to be able to log on the machine the application is running on)
with the same names that the client is using to authenticate to the service.
Note: If you would like to use the HTTP Digest authentication, use only domain user accounts
as local user accounts will not authenticate.
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Security User Interface
This section includes:
Edit Credential Store Dialog Box

266

Advanced Message Security Settings Dialog Box

267
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Edit Credential Store Dialog Box
This dialog box enables you to add, modify, or delete the users or certificates in the credential store
for the selected service.

To access

In the Virtual Service Editor, expand Security Settings and click Edit Credential
Store.

Important
When creating credentials for transport security over the HTTP(S) Gateway
information agent, the user of the virtual service must be a valid Windows account. This
Windows account can be one of the following:
l

A domain account. This is supported automatically.

l

A local account. If it does not already exist, you must create a local Windows
account on the machine hosting the Service Virtualization Designer or
standalone server. You must use the same user name and password.

Relevant
tasks

"How to Set Security" on page 255

See also

"Virtual Service Security Overview" on page 254

User interface elements are described below (unlabeled elements are shown in angle brackets):
UI
Element Description
<user
grid>

Displays the users and credentials defined in the credential store for this service.
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UI
Element Description
Add
Identity

Opens the Add Identity dialog box, enabling you to define a new user to add to the
credential store.
Enter a username and password. These credentials can represent either a Windows
account (for transport security - Basic, Digest, or NTLM) or other type of user
credentials used by the real service (for message security).
Click Show password to display the password.
Click the browse button to select a certificate to add. The following certificate types
are supported: .pfs, .p12, .cer, .der, .crt. Click OK. If the certificate's private key
requires a password, you are prompted to enter the password.

Edit

Enables you to modify user credentials. Select a user and click Edit to open the Edit
Identity dialog box.

Delete

Enables you to remove user credentials. Select one or more users in the grid and click
Delete.

Import

Enables you to select identities to add to the service.
In the Import Identities dialog box, under Services, select the virtual service
containing the identity you want to import. Then under Identities, select the identity to
import into your virtual service.

Advanced Message Security Settings Dialog Box
This dialog box enables you to set advanced options for message security.

To
access

In the Virtual Service Editor, under Security Settings, configure basic message
security options and then click Advanced Settings.

Relevant "How to Set Message Security" on page 256
tasks
See also

"Virtual Service Editor" on page 113
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User interface elements are described below.
UI Element

Description

Protection
Level

The level of security applied to each message. This configuration has service
scope levels. All messages must have the same security requirements.
Options include:

Message
Protection
Order

l

None.

l

Sign.

l

Encrypt and Sign.

The order of protection operations used to secure messages. Options
include:
l

Sign before encrypt.

l

Sign before encrypt and encrypt signature.

l

Encrypt before sign.

Message
Security
Version

The set of WS-* specifications used to establish security.

Require
Derived Keys

Supporting tokens must use derived keys.

Include
Timestamp

Messages must contain a security timestamp.

Allow
Serialized
Token on Reply

Replies can contain a service token used to sign the message. This setting
is used only for asymmetric security bindings.
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HP Test Automation Tools Integration Overview
Service Virtualization can be integrated with HP test automation tools. The virtual services are
managed via the tests, and the performance monitors exposed by the virtual services are used by
the performance testing tools.
Note: Virtual services must be deployed to the Service Virtualization Server for this
integration. Integration with virtual services deployed on the embedded server is not supported.
For more details on the HP Service Virtualization Server, see the HP Service Virtualization
Installation Guide.
Service Virtualization integrates with HP Unified Functional Testing, HP Service Test, HP
LoadRunner, and HP Performance Center. For details on currently supported versions, see the
Integrations Page on the HP Software Support Online web site at:
http://support.openview.hp.com/sc/solutions/index.jsp.

Unified Funtional Testing/Service Test
Service virtualization projects can be integrated with HP Unified Functional Testing (UFT) and HP
Service Test. For details, see the HP documentation for those applications.
The virtual services are then managed by the test after the integration.
l

The simulation start is triggered by the test start. Make sure that the virtual services are already
deployed on the Service Virtualization Server.

l

Particular data and performance models can be selected for the test.

l

Simulating or Standby modes using the real service are chosen during the test.

Performance Center and Load Runner
Service virtualization projects can be integrated with the Performance Center or Load Runner
Scenarios. For details, see Performance Center or Load Runner Documentation.
The virtual services are then managed by the test after the integration.
l

The simulation start is triggered by the test start. Make sure that the virtual services are already
deployed on the Service Virtualization Server.

l

Specific data and performance models can be selected for the test.

l

Simulating or Standby modes using the real service are selected during the test.

Performance monitors exposed by virtual services are used immediately in the Performance Center
or Load Runner Controller. The performance monitors exposed by Service Virtualization are named
Services and Operations.
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l

The Services performance counter provides measurement data per virtual service.

l

The Operations performance counter provides data per virtual service and service operation.

For more details, see "Performance Counters" below.

Performance Counters
You can monitor Service Virtualization message processing using predefined performance
counters. The performance counters are created during installation of either the Service
Virtualization Designer or the Service Virtualization Server. You can then view the counters in
Windows Performance Monitor. You can also use the performance counters to monitor Service
Virtualization that is running on a remote machine.The uninstallation of both the Designer and
Server delete the counters from the Windows system.
This section includes:
l

"Performance Counter Categories" below

l

"Performance Counter Instances" on the next page

l

"Remote Monitoring" on page 273

Performance Counter Categories
There are two Service Virtualization performance counter categories added to the Windows
Performance Monitor, named HP Service Virtualization - Services and HP Service
Virtualization - Operations. The performance counters in these categories are characterized by
the following:
• The Services performance counters provide measurement data per virtual service.
• The Operations performance counters provide data per virtual service and service operation.
The performance counters in these categories are shared by both the Designer and the Server. Both
the Designer and the Server write their data to these same counters.
The Services performance counters include the following:
Counter Name

Counter Description

Units

Throughput

The data capacity of the virtual service.

MB/s

HitRate

The number of requests and responses processed
by the virtual service.

hits/s

AverageResponseTime

The average time for the virtual service to process
a request and return a relevant response.

ms

DataSimulationAccuracy

The accuracy of data model emulation of the real
service by the virtual service.

%
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Counter Name

Counter Description

Units

PerformanceSimulationAccuracy The accuracy of performance model emulation of
the real service by the virtual service.

%

The Operations performance counters include the following:
Counter Name

Counter Description

Units

Throughput

The data capacity of the virtual service operation.

MB/s

HitRate

The number of requests and responses processed by the
virtual service operation.

hits/s

AverageResponseTime The average time for the virtual service to process a request
and return a relevant response for the operation.

ms

Performance Counter Instances
Service Virtualization creates instances of all the performance counters for each virtual service that
is deployed locally, either on the Service Virtualization Designer's embedded server, or on the
Service Virtualization Server.
Instance names are created in the following format:
l

For services: <service_name>

l

For operations: <service_name>_<operation_name>

For example, for a locally deployed virtual service called HelloWorld which has two operations
named Hello and Bye, the performance counters in the local system have the following instances:
Counter
Category

Counter Name

Counter Instance
Name
Helloworld Service

Services

AverageResponseTime

helloworld

HitRate

helloworld

Throughput

helloworld

DataSimulationAccuracy

helloworld

PerformanceSimulationAccuracy

helloworld
Hello
Operation
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Counter
Category

Counter Name

Operations AverageResponseTime

Counter Instance
Name
helloworld_ helloworld_
hello
bye

HitRate

helloworld_ helloworld_
hello
bye

Throughput

helloworld_ helloworld_
hello
bye

Remote Monitoring
You can use the performance counters to monitor Service Virtualization that is running on a remote
machine.
To remotely access the performance counters, you must use a Windows user account with
appropriate privileges on the remote machine. You can create this account in the following ways:
l

Automatically. During installation of Service Virtualization, you have the option to create a user
account that is automatically configured with the proper privileges. For details, see the HP
Service Virtualization Installation Guide.

l

Manually. If you create the Windows user account manually, you must add this user to the
default Windows group Performance Monitor Users. In Windows XP, add the user to the
Administrators group.
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HP ALM Integration Overview
The integration of Service Virtualization with HP Application Lifecycle Management (ALM) enables
you to store your Service Virtualization projects as test resources in ALM. This can facilitate the
use of the virtual services by other users, or by testing tools.
For details on currently supported versions of ALM, see the Integrations Page on the HP Software
Support Online web site at: http://support.openview.hp.com/sc/solutions/index.jsp.
The ALM integration enables you to:
l

Save a virtualization project in ALM. When you save a virtualization project, you can save it
in the file system, or in the ALM repository . If you choose to save the virtualization project in
ALM, it is stored as a resource in the Test Resources module of the selected ALM project.

l

Collaborate on virtual service design. Multiple users can work with a virtualization project
that is stored in ALM. ALM enables you to control this process by ensuring that changes are
made by only one user at a time.

l

Reuse a virtualization project. You can copy a project that is stored in ALM, and save it in
either ALM or in the file system.
Tip: You can also add a project to existing solutions. For more details on working with
projects, see "How to Manage Virtualization Projects" on page 95.

For task details, see "How to Work with HP ALM" below.

How to Work with HP ALM
This task describes how to integrate Service Virtualization with HP Application Lifecycle
Management (ALM).
To learn more about integrating with ALM, see "HP ALM Integration Overview" above.
This task includes the following:
"Prerequisite: Connect to ALM" on the next page
"Save a virtualization project in ALM" on the next page
"Open a virtualization project saved in ALM" on page 277
"Copy a virtualization project" on page 277
"Work with service templates" on page 277
"Work with an ALM version controlled project" on page 277
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Prerequisite: Connect to ALM
To perform any of the steps in this task, you must first connect to ALM.
1. From the main menu, select ALM > ALM Connection.
2. Enter the ALM URL, in the following format: <ALM server name or IP address>:<port
number>/qcbin.
3. Enter a username and password for connecting to the server. Click Connect.
4. Select an ALM domain and project, and click Login.
5. Select Restore Connection on Startup to automatically log in to ALM each time you start the
Service Virtualization Designer.

Save a virtualization project in ALM
You can save new and existing projects in ALM.
To create a new project and save it in ALM:
When you create a new virtualization project, you can choose to save the project in the file system,
or in ALM.
1. From the main menu, select File > New > Virtualization Project. For more details on
creating a new project, see "How to Manage Virtualization Projects" on page 95.
2. In the Summary of Virtualization Project dialog box, click Change to modify the Path field.
3. In the Change Project dialog box, click the Browse button to select a place to save the new
project.
4. In the Browse dialog box, select ALM Resources to save the new project on the ALM server
to which you are connected.
Tip: Create a new folder under ALM Resources for your virtualization project. All project
files and services will be saved under that folder.
To save an existing project in ALM:
1. In the Service Virtualization Designer, open a project that is saved in the file system.
Tip: On the Start Page, under Recent Projects, hover over a project name to see the full
path to the saved project.
2. From the main menu, select File > Save Project As. In the Save dialog box, select
ALM Resources to save a copy of the project on the ALM server to which you are connected.
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Open a virtualization project saved in ALM
To open a project, do one of the following:
l

From the main menu, select File > Open Project/Solution. In the Open dialog box, select ALM
Resources, and select a project.

l

On the Start Page, under Recent Projects, select a project.
Tip: Hover over a project name to see the full path to the saved project. Projects saved in
ALM are displayed with the [ALM-RESOURCE] prefix.

If you try to open a project that is already opened, you are notified that the project is locked by
another user. If you choose to open the project, it is opened in read-only mode.

Copy a virtualization project
You can copy a Service Virtualization project stored in ALM.
1. Open the project in Service Virtualization.
2. From the main menu, select File > Save Project As. Select a location in ALM or in the file
system, and enter a name for the new project.

Work with service templates
You can save a service as a template in ALM, and create new services from templates saved in
ALM.
To save a service as a template in ALM:
1. In the Virtualization Explorer, right-click the service and select Save as Template.
2. In the Save dialog box, select ALM Resources, and select a folder for saving the service
template.
To create a virtual service from a template saved in ALM:
1. Select one of the following:
a. From the main menu, select File > New > Virtual Service From Template.
b. In the Virtualization Explorer, right-click a virtualization entity and select Add > Virtual
Service From Template.
2. In the Open dialog box, select ALM Resources, and select a template for creating the new
virtual service.

Work with an ALM version controlled project
l

Open a Service Virtualization project that is saved in ALM.
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If the project is currently checked in, you are prompted to check it out.
If you do not want to check out the project, click No. The project is opened in read-only mode.

To check out the project at a later time, from the main menu, select ALM > Check out.
l

Check in your changes.
From the main menu, select ALM > Check in.
Alternatively, in the Virtualization Explorer, right-click the project name and select Check In to
ALM.

l

Save your changes without checking in.
From the main menu, select File > Save. You are prompted to check in the project. If you
choose no, your changes are uploaded and saved in ALM in the checked out version.

l

Discard your changes without saving.
From the main menu, select ALM > Undo Check Out.

l

View version history.
From the main menu, select ALM > Version History.

For full details on working with version control in HP ALM, see the HP Application Lifecycle
Management User Guide.

FAQs: ALM Integration
This section provides tips on working with HP ALM.

My ALM connection was lost while I was in the middle of working. What
now?
Any changes you make are saved locally. When the connection to ALM is restored, your changes
are automatically uploaded to ALM.

Can a Service Virtualization solution include projects saved both in the file
system and in ALM?
Yes. You can create a solution with projects that are saved both in the file system and in ALM. You
can also add a new project to your existing solution, and save it in ALM. For details on creating a
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new project within an existing solution, see "How to Manage Virtualization Projects" on page 95.
In the event that a project saved in ALM is unavailable when you open the solution, a message
displays. After the connection to ALM is restored, you can reload the solution to work on the ALM
projects. From the main menu, click File > Reload Solution.
Note: All virtualization projects within a solution must be saved in the same ALM project, as
you can connect to only one ALM project at a time.

Can I see my Service Virtualization projects from within ALM?
Yes. You can view the following details in your saved projects in the ALM Test Resources module:
l

Resource type. Service Virtualization projects and services are created as the Test Resource
resource type.

l

Resource description. In the resource Details tab, the Description area lists the services
included in the project, and details on each service. For example, you can see the service
endpoints, which are required to reconfigure your application under test.

l

Resource filename. Select a resource and click the Resource Viewer tab. Service
Virtualization resources are identified as follows:

l

n

Virtualization project: .vproj file extension.

n

Virtual service: .vs file extension.

n

Virtual service template: .vstz file extension.

Relationships between virtualization projects and services. Select a resource and click the
Dependencies tab.
n

For a virtualization project: displays the services in the project.

n

For a virtual service: displays the virtualization project in which it is located.

Can I share my services?
You can make your Service Virtualization projects and services available to others to download and
deploy to other Service Virtualization Servers. This functionality is enabled using the Service
Virtualization Management. For details, see "Service Virtualization Management" on page 132.

I want to view a project in the Designer but not make any changes. What
should I do?
You can open the project in read-only mode. This prevents you from inadvertently making any
changes. It also allows another user to open the project for editing.
When opening a project that is saved in ALM, select Open in read-only mode in the Open dialog
box.
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Tip: After you close the project, the Recent Projects list on the Start Page indicates that you
previously opened it in read-only mode.

If you open the project again from the Recent Projects list, it is opened in read-only mode.
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Subversion (SVN) Support Overview
You can manage the version control of your virtualization projects from within the Service
Virtualization Designer. Service Virtualization supports integration with Apache Subversion, using
the TortoiseSVN client.
When you open a virtualization project that is under version control, standard SVN options are
available in the Service Virtualization Designer. These options open the TortoiseSVN interface,
enabling you to manage versioning from within your virtualization project. For more details on
specific SVN functionality, see the TortoiseSVN documentation.
For task details, see "How to Work with SVN" below.

How to Work with SVN
This task describes how to work with virtualization projects that are under SVN version control.
To learn more, see "Subversion (SVN) Support Overview" above.
This task includes the following steps:
l

"Prerequisites" below

l

"Check out a virtualization project" below

l

"Open a version controlled project" below

l

"Manage version control" on the next page

l

"View version status" on the next page

Prerequisites
1. Integration with SVN requires that TortoiseSVN version 1.7 is installed on the Service
Virtualization Designer machine. You can download TortoiseSVN from http://tortoisesvn.net.
2. Check in your virtualization project or solution using TortoiseSVN.

Check out a virtualization project
Your virtualization project must be committed to an SVN repository.
From the main menu, select File > Checkout. This accesses the TortoiseSVN user interface, and
you can proceed to check out a project to the file system.

Open a version controlled project
You can open a project or solution, or add a project to an existing solution.
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1. Select one of the following:
n

Open an existing project or solution. From the main menu, select Open
Project/Solution.

n

Add an existing project to a solution. In the Projects pane, right-click a solution and
select Add > Existing Project.

2. Navigate to and select a checked out project located in the file system.

Manage version control
When a virtualization project is under version control, standard SVN actions are available in the
Service Virtualization Designer.
Select one of the following:
l

In the Virtualization Explorer, right-click a project name and select an SVN action.

l

From the main menu, select View > Projects to display the Projects pane. Right-click a solution
or project and select an SVN action.

The following options are available:
l

Commit. Commit your changes to the SVN repository.

l

Revert. Undo changes you made since the last update.

l

Subversion. Opens a sub-menu with additional SVN actions you can perform.

The TortoiseSVN user interface opens, enabling you to manage version control for the project. For
more details on SVN actions, see the TortoiseSVN documentation.

View version status
From the main menu, select View > Projects to display the Projects pane. SVN icons indicate the
version control status of your project's files.
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Runtime View Errors
Runtime view doesn't respect selected data model when changing mode.
Problem: User chooses a simulation model in the Service Editor and starts a new
learning/simulation from the Runtime View. Instead of using the new simulation, the simulation
model from the previous learning/simulation is used again.
Solution: Runtime View is used just to change service modes, not configurations. To change the
simulation model, open the Service Editor, select a new simulation model and start a new
learning/simulation from the Service Editor.

Cannot start learning service 'My Service'.
Problem: Real Data model or Performance model must be selected in service configuration.
Solution: This error may happen when all data and performance models are deleted from the
service configuration and the user tries to start a new learning/simulation session from the Runtime
View. To solve the problem, create a new Data/Performance Model and start a new
learning/simulation session from the Service Editor.

HTTPS Client Connection Aborted
Problem: The client connection to a virtualized service deployed on an HTTPS endpoint is aborted
with the error message SSL_ERROR_RX_RECORD_TOO_LONG when Service Virtualization is
running on a Windows XP or Windows 2003 machine. The client is normally able to connect to a
real service without any issue.
Solution: See http://support.microsoft.com/default.aspx?scid=kb;EN-US;933430 for a list of
possible solutions. For Windows 2003, any workaround method as described in the Knowledge
Base article can be used, however, only the first or second methods work with Windows XP.

Configuring HTTP Proxy on Clients
Problem: A virtual service is created on a proxy agent and the user is unable to record messages.
Solution:Configure the HTTP Proxy on clients.
All examples below of specific client configurations are using the proxy server HTTP(S) Proxy
Agent listening on address hostname with port 6071.
This section includes:
l

"HTTP Proxy in .Net Client" on the next page

l

"HTTP Proxy in Java Client" on page 287

l

"HTTP Proxy in WebLogic" on page 287
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l

"HTTP Proxy in WebSphere" on the next page

l

"HTTP Proxy in JBoss" on page 288

HTTP Proxy in .Net Client
The .Net client can be configured to use a default proxy server or a specific proxy server.
If using the default proxy server, take HTTP Proxy Agent settings to configure the default proxy
server. This is done in MS Windows or Internet Explorer in Internet Properties > Connections >
LAN settings > Proxy server. You must then configure the client to use the default proxy. This is
set in the application configuration file either for application in element <defaultProxy>:
<configuration>
<system.net>
<defaultProxy enabled="true">
<proxy usesystemdefault="true"/>
</defaultProxy>
</system.net>
</configuration>

, or for a specific binding in a binding element:
<configuration>
<system.serviceModel>
<bindings>
<basicHttpBinding>
<binding name="myHttpBinding" bypassProxyOnLocal="false" useDefaultWebProxy="true">
</binding>
</basicHttpBinding>
</bindings>
</system.serviceModel>
</configuration>

The same configuration file can be used to set a specific proxy server. This is an example of client
configuration for application:
<configuration>
<system.net>
<defaultProxy enabled="true">
<proxy proxyaddress="http://hostname:6071"/>
</defaultProxy>
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</system.net>
</configuration>

, or for specific binding:
<configuration>
<system.serviceModel>
<bindings>
<basicHttpBinding>
<binding name="myHttpBinding" bypassProxyOnLocal="false" useDefaultWebProxy="false" prox
yAddress=" http://hostname:6071">
</binding>
</basicHttpBinding>
</bindings>
</system.serviceModel>
</configuration>

HTTP Proxy in Java Client
The proxy settings for Java client are given to the JVM via command line arguments. This is an
example of how to run the client from the command line with proxy configuration:
java -Dhttp.proxyHost=hostname -Dhttp.proxyPort=6071 MyJavaClient

HTTP Proxy in WebLogic
Add the Java proxy parameters to Java options in JAVA_OPTIONS environment variable in the
proper section of script %WL_HOME%\common\bin\commEnv.cmd for MS Windows or in ${WL_
HOME}/common/bin/commEnv.sh for Unix/Linux. This is example of setting proxy configuration in
file commEnv.cmd (MS Windows):
set JAVA_OPTIONS=%JAVA_OPTIONS% -Dhttp.proxyHost=hostname -Dhttp.proxyPort=6071

, or in file commEnv.sh (Unix/Linux):
JAVA_OPTIONS="${JAVA_OPTIONS} -Dhttp.proxyHost=hostname -Dhttp.proxyPort=6071

HTTP Proxy in WebSphere
The HTTP proxy on the WebSphere application server can be configured via setting transport
properties http.proxyHost and http.proxyPort. These HTTP transport properties can be set via:
1. Using wsadmin.
2. Using an assembly tool.
3. Using the JVM custom property panel in the administrative console.
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To learn more about (1) and (2), see the Configuring additional HTTP transport properties
documentation in WebSphere. To configure the HTTP proxy properties using (3) use the
administrative console with the following steps:
1. Open the administrative console.
2. Click Servers > Application Servers > server > Java and Process Management >
Process definition > Java Virtual Machine > Custom Properties.
3. (Optional) If the property is not listed, create a new property name.
4. Enter the name http.proxyHost and value hostname.
5. Enter the name http.proxyPort and value 6071.
6. Restart the server.

HTTP Proxy in JBoss
Add the Java proxy parameters to Java options in JAVA_OPTS environment variable in the startup
script %JBOSS_HOME%\bin\run.bat or run.conf.bat for MS Windows or in ${JBOSS_HOME}
/bin/run.sh or run.conf for Unix/Linux. This is an example of setting the proxy configuration in
JAVA_OPTS environment variable in file run.conf.bat (MS Windows):
set "JAVA_OPTS=-Dhttp.proxyHost=hostname -Dhttp.proxyPort=6071
, or in file run.conf (Unix/Linux):
JAVA_OPTS="-Dhttp.proxyHost=hostname -Dhttp.proxyPort=6071

Setting HTTP Proxy in Designer
Problem: User is unable to access any remote WSDL or Service Virtualization Server.
Solution: Proxy setting needs to be configured in Designer.
This section includes:
l

"How to Set HTTP Proxy in Designer" below

l

"Setting HTTP Proxy in the Designer configuration file " on the next page

l

"System HTTP Proxy" on the next page

l

"Specific HTTP Proxy" on the next page

l

"Setting Credentials for Authenticated HTTP Proxy" on page 290

How to Set HTTP Proxy in Designer
In some cases Service Virtualization Designer communicates with external services using the
HTTP protocol. The first case is the communication with Service Virtualization Server, where the
service is the server management API. The second case is the import of the a real service WSDL.
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In some situations, the Designer’s HTTP communication must be forwarded through an external
HTTP Proxy. In that situation, the HTTP Proxy settings must be placed in the Designer’s
configuration file.
Note: The setting of HTTP Proxy for agents is not done in the Designer configuration file. For
details, see "How to Forward HTTP Agent Communication Through an HTTP Proxy" on page 62.

Setting HTTP Proxy in the Designer configuration file
In order to use an external HTTP Proxy for the Designer HTTP communication with a server and
the import of a WSDL from real services, the Designer configuration file must be modified. This file
is located at %[INSTALLLOCATION]%\Designer\bin\VirtualServiceDesigner.exe.config.
In the configuration file the element <defaultProxy> holds the HTTP Proxy configuration. This
element is located in the document in elements <configuration><system.net>. By default, HTTP
Proxy is disabled by <defaultProxy enabled="false"/>.
The Designer can be configured to use the system HTTP Proxy or to use a specific HTTP Proxy.
Detailed documentation can be found at http://msdn.microsoft.com/library/kd3cf2ex.aspx. The
Designer must be restarted in order to apply the changes in the configuration file.

System HTTP Proxy
If using the system HTTP Proxy, ensure that the HTTP Proxy is configured in the system. The
settings are available in Windows Internet Explorer® menu Internet Properties > Connections >
LAN settings > Proxy server. The Designer must be configured to use the same proxy in the
configuration file in the element <defaultProxy> like this:
<configuration>
<system.net>
<defaultProxy enabled="true">
<proxy usesystemdefault="true"/>
</defaultProxy>
</system.net>
</configuration>

Specific HTTP Proxy
If using a specific HTTP Proxy other than the system one, follow this example of Designer
configuration:
<configuration>
<system.net>
<defaultProxy enabled="true">
<proxy proxyaddress="http://foo.com:8080"/>
</defaultProxy>
</system.net>
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</configuration>

Setting Credentials for Authenticated HTTP Proxy
If the Designer is configured to use HTTP Proxy with authentication, some additional modifications
may be required in the Designer configuration file. This will allow the supplying of credentials for the
HTTP Proxy. These modifications are required in the case of HTTP communication with the server
management API. In the case of WSDL imports, these modifications are only optional as the
Designer will prompt the user for credentials if needed.
In order to set credentials for authenticated HTTP Proxy in the Designer, this section must be
enabled in the configuration file VirtualServiceDesigner.exe.config:
<configuration>
<system.net>
<defaultProxy enabled="true" useDefaultCredentials="false">
<module type = "HP.SOAQ.ServiceVirtualization.ServerManagementClient.Remote.Authenticate
dProxy, HP.SV.ServerManagementClient" />
</defaultProxy>
</system.net>
</configuration>

The credentials for the authenticated HTTP Proxy are set in application keys section. Example of
credential settings follows:
<configuration>
<appSettings>
<add key="proxyUserName" value="user1" />
<add key="proxyPassword" value="pass1" />
<add key="proxyAddress" value="http://foo.com:8080" />
</appSettings>
</configuration>

Where keys are defined as:
proxyUserName User name for authenticated proxy credentials
proxyPassword

Password for authenticated proxy credentials

proxyAddress

Address of authenticated proxy (e.g. http://foo.com:8080). If this value is
empty then the Proxy Server address in the system proxy is used.

Once the credentials and the proxy settings are configured as described above then the Designer
will use them both for HTTP communication with the server management API and WSDL imports
from real services.

HP Service Virtualization (3.10)

Page 290 of 299

User Guide
Chapter 13: Troubleshooting

Slow Designer Responsiveness
Problem: After installing the new version of Service Virtualization, or making a change to your
computer, such as installing an update or new software, the Designer responds very slowly,
especially when working in the Data Model Editor.
Solution 1: This may be related to a known Microsoft issue. For details, see Poor WPF application
performance due to UI Automation on certain machines. You can install the following hotfix to
address the issue: Microsoft KB2484841.
Solution 2: Modify the Designer configuration file, VirtualServiceDesigner.exe.config, located in
%[INSTALLLOCATION]%\Designer\bin\. To edit the file, you must have administrator privileges
on the machine.
Open the file in a text editor and change the value of SeV.Global.EnableAutomationFix from False
to True. If the Designer is open, close it and restart.
If this does not solve the problem, do the following:
1. Change the value of SeV.Global.EnableAutomationFix back to False.
2. Change the value of SeV.Global.ClearAutomationEvents from False to True.
3. If the Designer is open, close it and restart.
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Service Virtualization Labs enable you to try out new, experimental features.
Note: The features in this section are being delivered at “beta level”, and are subject to change.
l

They may stop working at any time.

l

They may be removed, temporarily or permanently, from future patches or versions.

l

They may change when and if they are implemented as fully supported features.

We welcome your comments. Send feedback to Service.Virtualization@hp.com.
This chapter includes:
How to Enable Lab Features

293

Network Virtualization Integration

293

Scripted Rules

296
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How to Enable Lab Features
This task enables you to try out new, experimental features.
For more details on Lab Features, see "Service Virtualization Labs" on the previous page.
To enable a lab feature
1. From the main menu, select Tools > Options.
2. Click the Labs tab.
3. In the left pane, select a feature and then select the Enable option to turn on the feature.
4. Click OK to save your selections and enable the features.
Troubleshooting lab features
If you encounter any problems while you have a Labs feature enabled, here are some steps you can
take:
l

Disable the feature.

l

Scripting feature - delete the rule using the script and restart simulation.

l

Contact support.

Network Virtualization Integration
This section includes:
Network Virtualization Overview

294

How to Virtualize Network Conditions

294
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Network Virtualization Overview
The Service Virtualization integration with Shunra Network Virtualization™ (NV) enables you to
simulate a real network to use together with your virtual services.
You can simulate real network communication between a client and server by setting origin and
destination locations, and by introducing network conditions such as latency, packet loss, and
bandwidth.
For task details, see "How to Virtualize Network Conditions" below.

How to Virtualize Network Conditions
This task describes how to define a virtual network environment for your virtual services to use.
To learn more about virtualizing network conditions, see "Network Virtualization Overview"
above.
This task includes the following steps:
l

"Prerequisites" below

l

"Configure network models" on the next page

l

"Assign a network model to an agent configuration" on the next page

l

"Edit network models" on page 296

1.

Prerequisites
a. Enable the Network Virtualization lab feature.
For details on Service Virtualization lab features, see "Service Virtualization Labs" on page
292.
b. Shunra NV and the Shunra Location Editor must be installed on the Service Virtualization
Server machine.
For information on supported versions, refer to the support matrix on the HP Software
Support site at: http://h20230.www2.hp.com/sc/support_matrices.jsp.
c. Configure the Service Virtualization Server to connect to Shunra.
Navigate to the HP.SV.StandaloneServer.exe.config file, located on the Service
Virtualization Server machine in the server installation folder. By default, C:\Program
Files\HP\HP Service Virtualization Server\Server\bin.

HP Service Virtualization (3.10)

Page 294 of 299

User Guide
Chapter 14: Service Virtualization Labs

Configure the properties in the following sections according to your Shunra system
definitions:
o

Shunra Network Virtualization - NV Agent (Engine).
Edit the Host, Port, Protocol, UserName, and Password properties. The parameters
enable the Service Virtualization Server to access the Shunra network virtualization
engine.

o

Shunra Network Virtualization - Location Editor
Edit the Host, Port, Protocol, UserName, and Password properties. These connection
properties enable the Service Virtualization Designer to browse the Shunra Location
Editor Web Site.

2.

Configure network models
Define a set of network characteristics to use with your virtual services.
a. From the main menu, select Tools > Options and click the Network Virtualization page.
b. Click Add. The Shunra NV interface for setting virtualization options opens.
Select one of the following:

3.

o

Import from library. Import an existing Shunra location.

o

Custom. Define network settings manually.

o

Advanced. Select a predefined Shunra .ntxx emulation file that was created in Shunra's
Network Editor and saved in the file system.

o

Copy an existing model. Select an existing network model and click Duplicate. A
copy is made of the model you selected. You can edit the settings and save it as a new
network model.

Assign a network model to an agent configuration
Select a network model for an HTTP agent configuration. The network model is then used by
all virtual services that use the agent configuration.
a. From the main menu, select Tools > Options and click the Agents page.
b. Select an existing HTTP agent configuration, or define a new one.
c. In the right pane, click the Network Virtualization tab.
d. Select a network model for the agent to use.
e. To configure network models, click Manage Network Models.
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4.

Edit network models
To modify existing network models:
From the main menu, select Tools > Options and click the Network Virtualization page.
For each network model, the right pane displays the Service Virtualization agents that are
using the model. You can attach or detach an agent from the selected network model.
Click an agent name link to view details on the agent.

Scripted Rules
This section includes:
Scripted Rules Overview

297

How to Create a Scripted Rule

297
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Scripted Rules Overview
Using a Service Virtualization scripted rule, you can create a script to access request data and set
response data.
Using a scripted rule, you can:
l

define the script for different contexts, including for a server, service, operation, session, or
service call.

l

use any JavaScript expression from ECMAScript5 strict mode, together with exposed Service
Virtualization objects.

l

define logging in the script. Messages are logged to the Service Virtualization log file.
For task details, see "How to Create a Scripted Rule" below.

How to Create a Scripted Rule
You can write a customized script inside a rule in the data model.
To learn more about scripted rules, see "Scripted Rules Overview" above.
This task includes the following steps:
l

"Prerequisite: Enable the Scripting lab feature." below

l

"Prerequisite: Enable logging." below

l

"Create a new scripted rule." on the next page

l

"Define a script." on the next page

1.

Prerequisite: Enable the Scripting lab feature.
For details on Service Virtualization lab features, see "Service Virtualization Labs" on page
292.

2.

Prerequisite: Enable logging.
To enable your scripts to write to the Service Virtualization log file, add the following entry to
the log4net section of the configuration file for the Designer or Service Virtualization Server.
<logger name=" JavascriptLogger>"
<level value="XXX" />
</logger>
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where XXX is one of the following log levels: DEBUG, INFO, WARNING, ERROR.
By default, only log level ERROR is enabled.
For more information, consult the log4net documentation.
Note:

3.

n

Service Virtualization Server configuration file:
HP.SV.StandaloneServer.exe.config, located on the Service Virtualization Server
machine in the server installation folder. By default, C:\Program Files\HP\HP Service
Virtualization Server\Server\bin.

n

Designer configuration file: VSDesignerConfigurationTool.exe.config, located on the
Designer machine in the installation folder. By default, C:\Program Files (x86)\HP\HP
Service Virtualization Designer\Designer\bin\VirtualServiceDesigner.exe.config.

n

For details on log file locations, see "Virtual Service Editor" on page 113.

Create a new scripted rule.
In the Data Model Editor, click New Rule > Scripted Rule. Expand the newly created rule to
configure the script.

4.

Define a script.
You can write a script according to the following guidelines:
a. Use any JavaScript expression from ECMAScript5 strict mode along with Service
Virtualization exposed objects.
b. You can insert the path to a Service Virtualization object, instead of entering it manually.
Select a scripted rule, and from the Data Model Editor Script menu, select Insert Path.
Select a data element to add to the script.
c. Access request data using hpsv.request.
d. Access response data using hpsv.response.
e. Use hpsv.logger in the script, to log messages in the Service Virtualization log files.
f. Define a context for the script, using the following properties:
Context

Property

Description

Server

hpsv.context.server

The data is visible to all services on the server
that are simulating. Data is deleted when the
server restarts.
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Context

Property

Description

Service

hpsv.context.service

The data is visible only to the service for all
simulated messages. Data is deleted when the
service simulation ends.

Operation hpsv.context.operation The data is visible only to requests of the current
operation. Data is deleted when the service
simulation ends.
Session

hpsv.context.session

The data is visible only to requests coming from
the same user session. Data is deleted when the
user session ends.

Call

hpsv.context.call

The data is visible only to one service call (=
simulated request). Data is deleted when the
simulation of that request ends.
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