
HP Unified Functional Testing
For the Windows ® operating systems

Software Version: 11.53

API Testing Tutorial

Document Release Date: October 2013

Software Release Date: October 2013



Legal Notices

Warranty
The only warranties for HP products and services are set forth in the express warranty statements
accompanying such products and services. Nothing herein should be construed as constituting an
additional warranty. HP shall not be liable for technical or editorial errors or omissions contained
herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend
Confidential computer software. Valid license from HP required for possession, use or copying.
Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software
Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government
under vendor's standard commercial license.

Copyright Notice
© Copyright 1992 - 2013 Hewlett-Packard Development Company, L.P.

Trademark Notices
Adobe® and Acrobat® are trademarks of Adobe Systems Incorporated.

Google™ andGoogleMaps™ are trademarks of Google Inc

Intel® and Pentium® are trademarks of Intel Corporation in the U.S. and other countries.

Microsoft®, Windows®, Windows® XP, andWindows Vista ® are U.S. registered trademarks of
Microsoft Corporation.

Oracle and Java are registered trademarks of Oracle and/or its affiliates.

HP Unified Functional Testing (11.53)Page 2 of 86

API Testing Tutorial



Documentation Updates
The title page of this document contains the following identifying information:

l Software Version number, which indicates the software version.

l Document Release Date, which changes each time the document, is updated.

l Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using themost recent edition of a document, go
to: www.hp.com/go/livenetwork. This site requires that you register for an HP Passport and sign in.
To register for an HP Passport ID, go to: http://h20229.www2.hp.com/passport-
registration.html

Or click theNew users - please register link on the HP Passport login page.
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Support
Visit the HP Software Support Online web site at:

http://www.hp.com/go/hpsoftwaresupport

This web site provides contact information and details about the products, services, and support
that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and
efficient way to access interactive technical support tools needed tomanage your business. As a
valued support customer, you can benefit by using the support web site to:

l Search for knowledge documents of interest

l Submit and track support cases and enhancement requests

l Download software patches

l Manage support contracts

l Look up HP support contacts

l Review information about available services

l Enter into discussions with other software customers

l Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also
require a support contract. To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html

To findmore information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp
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About the Tutorial for Testing
The UFT Tutorial for API Testing is a self-paced printable guide designed to lead you through the
process of creating tests forWeb services, REST services, and other GUI-less applications.

After completing the tutorial, you can apply the skills you have learned to testing the GUI-less layer
of your own application orWeb site.

Note: To learnmore about creating and running GUI tests, see the UFT Tutorial for GUI
Testing, available from the < UFT installation folder>\help directory.

Tutorial Audience and Scope
This tutorial is intended for users who are new to UFT. No prior knowledge of UFT or Service Test
is required. A general understanding of testing concepts and functional testing processes may be
helpful, but is not mandatory. UFT enables you to create API tests and business process tests.
This tutorial reviews topics related to API testing only. While performing the lessons in this tutorial,
youmay notice unfamiliar menu items or other UFT GUI elements that are not described in the
tutorial. Thesemay be relevant for BPT or GUI testing only, and are not relevant for API testing at
all. For details about these elements, see theHP Unified Functional Testing User Guide.

Note: This tutorial refers to file system paths that are relevant forWindows 7 operating
systems. The paths in other operating systems may be slightly different.

Topic Types
The content in the UFT guides is organized by topics. Threemain topic types are in use: Concepts,
Tasks, andReference.

Topic Type Description Usage

Concepts Background, descriptive, or conceptual
information.

Learn general information
about what a feature does.
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Topic Type Description Usage

Tasks Instructional Tasks. Step-by-step
guidance to help you work with the
application and accomplish your goals.

Task steps can be with or without
numbering:

l Numbered steps. Tasks that are
performed by following each step in
consecutive order.

l Non-numbered steps. A list of self-
contained operations that you can
perform in any order.

l Learn about the overall
workflow of a task.

l Follow the steps listed in a
numbered task to complete
a task.

l Perform independent
operations by completing
steps in a non-numbered
task.

Use-case Scenario Tasks. Examples of
how to perform a task for a specific
situation.

Learn how a task could be
performed in a realistic
scenario.

Reference General Reference. Detailed lists and
explanations of reference-orientedmaterial.

Look up a specific piece of
reference information relevant
to a particular context.

User Interface Reference. Specialized
reference topics that describe a particular
user interface in detail. Selecting Help on
this page from the Helpmenu in the product
generally open the user interface topics.

Look up specific information
about what to enter or how to
use one or more specific user
interface elements, such as a
window, dialog box, or wizard.

Troubleshooting
and Limitations

Troubleshooting and Limitations.
Specialized reference topics that describe
commonly encountered problems and their
solutions, and list limitations of a feature or
product area.

Increase your awareness of
important issues before
working with a feature, or if
you encounter usability
problems in the software.

UFT Help Contents
The UFT Help includes the following:
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Type Included Documentation

Getting to
Know UFT
Documentation

l Readme provides the latest news and information about UFT. Select Start
> All Programs > HP Software > HP Unified Functional Testing >
Readme.

Note: For details on accessing UFT and UFT tools and files in
Windows 8, see "Accessing UFT inWindows 8Operating Systems"
on page 22.

l Installation Guides explain how to install and set up UFT or the
HP Functional Testing Concurrent License Server. Select Help > Unified
Functional Testing Help and click the link to the appropriate guides from
the left pane.

l Tutorials teach you basic UFT skills for GUI testing and API testing and
show you how to design tests for your applications. Select Help > UFT
Tutorial.

l UFT Product Movies provide an overview and step-by-step instructions
describing how to use selected UFT features. Select Help > Product
Movies.

Feature
Documentation

UFT Help includes:

l HP Unified Functional Testing User Guide describes how to use UFT to
test your application.

l HP RunResults Viewer User Guide describes how to use the Run Results
Viewer to view and analyze the run results from your tests or components.

l HP Unified Functional Testing Add-ins Guide describes how to work with
supported environments using UFT add-ins, and provides environment-
specific information for each add-in.

l HP UFT Object Model Reference for GUI Testing describes UFT test
objects, lists themethods and properties associated with each object, and
provides syntax information and examples for eachmethod and property.

Select Help > HP Unified Functional Testing Help.
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Type Included Documentation

Reference
Documentation

HP UFT Advanced References contains documentation for the following
UFT COM and XML references:

l HP UFT Automation Object Model Reference provides syntax,
descriptive information, and examples for the automation objects,
methods, and properties. It also contains a detailed overview to help you
get started writing UFT automation scripts. The automation object model
assists you in automating test management, by providing objects,
methods and properties that enable you to control virtually every UFT
feature and capability.

l HP UFT Run Results Schema Reference documents the run results
XML schema, which provides the information you need to customize your
run results.

l HP UFT Test Object Schema Reference for GUI Testing documents
the test object XML schema, which provides the information you need to
extend test object support in different environments.

l HP UFT Object Repository Schema Reference for GUI Testing
documents the object repository XML schema, which provides the
information you need to edit an object repository file that was exported to
XML.

l HP UFT Object Repository Automation Reference for GUI Testing
documents the Object Repository automation object model, which
provides the information you need tomanipulate UFT object repositories
and their contents from outside of UFT.

l VBScript Reference contains Microsoft VBScript documentation,
including VBScript, Script Runtime, andWindows Script Host.

Select Help > HP UFT GUI Testing Advanced References Help.

Additional Online Resources
The following additional online resources are available from the Unified Functional Testing Help
menu:
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Resource Description

HP Software
Support Site

Opens the HP Software Support Web site. This site enables you to browse
the HP Software Self-solve knowledge base. You can also post to and
search user discussion forums, submit support requests, download patches
and updated documentation, andmore. ChooseHelp > HP Software
Support. The URL for this Web site www.hp.com/go/hpsoftwaresupport.

l Most of the support areas require that you register as an HP Passport
user and sign in. Many also require a support contract.

l To findmore information about access levels, go to:
http://h20230.www2.hp.com/new_access_levels.jsp

l To register for an HP Passport user ID, go to:
http://h20229.www2.hp.com/passport-registration.html

Testing Forums Opens the testing forums for GUI Testing, API Testing, and BPT Testing
forums. where you can interact with other users of UFT and discuss topics
related to GUI Testing, API Testing, and BPT.

The URLs for these sites are:

l GUI Testing: http://h30499.www3.hp.com/t5/Unified-Functional-
Testing/bd-p/sws-Fun_TEST_SF

l API Testing: http://h30499.www3.hp.com/t5/Service-Test-Support-and-
News/bd-p/sws-Serv_TEST_SF

l BPT: http://h30499.www3.hp.com/t5/Business-Process-Validation/bd-
p/sws-BPT_SF

UFT Product
Page

Opens the HP Unified Functional Testing product page, with information and
related links about UFT.

Troubleshooting
& Knowledge
Base

Opens the Troubleshooting page on the HP Software Support Web site
where you can search the HP Software Self-solve knowledge base. Choose
Help > Troubleshooting & Knowledge Base. The URL for this Web site
is http://h20230.www2.hp.com/troubleshooting.jsp.

HP Software
Community Site

Opens the HP IT Experts Community site, where you can interact with other
HP software users, read articles and blogs on HP software and access
downloads of other software products.

Manuals Site Opens the HP Software Product Manuals Web site, where you can search
for themost up-to-date documentation for a selected HP Software product.
The URL for this Web site is
http://support.openview.hp.com/selfsolve/manuals (requires an HP
Passport).
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Resource Description

What's New Opens the UFTWhat's New Help, describing the new features and
enhancements in this version of UFT.

Product Movies Opens a page displaying a list of all product movies.

HP Software
Web site

Opens the HP SoftwareWeb site. This site provides you with themost up-
to-date information on HP Software products. This includes new software
releases, seminars and trade shows, customer support, andmore. Choose
Help > HP Software Web site. The URL for this Web site is
www.hp.com/go/software.

You can access the following sample applications from theStartmenu. These applications are the
basis for many examples in this guide:

l Mercury Tours sampleWeb site. The URL for this Web site is http://newtours.demoaut.com.

l Mercury Flight application. To access from the Start menu, select All Programs > HP
Software > HP Unified Functional Testing > Sample Applications > Flight API / Flight
GUI.
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Chapter 1: Introducing HP Unified
Functional Testing - API Testing

HP Unified Functional Testingfor API testing contains an extensible framework for the construction
and execution of functional tests of GUI-less applications or the non-GUI parts of an application..
This document describes how to get started with HP UFT API testing and create your first tests. It
also introduces themajor features in the product and how to incorporate them into your tests.

Note: It is recommended to work with an soft copy of this tutorial because there are sections in
which you will be asked to copy and paste test information into UFT.

If you would like, you can open a PDF of this tutorial from your <Unified Functional Testing
installation folder>\help folder.

You can access the HTML version of this tutorial, by selectingHelp > Unified Functional
Testing Tutorial.

This chapter contains the following sections:

Why Should You Automate API Testing? 14

Benefits of Automated API Testing 14

Testing Process 15

UFTWindow 17

Accessing UFT inWindows 8Operating Systems 22

Where to Go From Here 22
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Why Should You Automate API Testing?
Automated API Testing is a discipline that leverages products and processes to reduce the risks of
application upgrades or deployment of new services. At its core, automated testing is about
applying production workloads to predeployment systems while simultaneously measuring system
performance and end-user experience. A well-constructed performance test answers questions
such as:

l Does the service/application respond quickly enough for the intended users?

l Will the application's server respond with the correct values?

l How will the service/application handle exceptions and illegal values?

l Is the service/application stable under expected and unexpected user loads?

By answering these questions, you can design a test more effectively. An effective automated
testing process helps youmakemore informed release decisions, reduces system downtime, and
prevents availability problems.

Benefits of Automated API Testing
If you have ever tested applications manually, you are aware of the drawbacks of manual testing.

Manual testing is time-consuming and tedious, and requires a heavy investment in human
resources. Worst of all, time constraints oftenmake it impossible to manually test every feature
thoroughly before the application is released. This leaves you wondering whether serious bugs have
gone undetected.

Automated API testing with UFT addresses these problems by dramatically speeding up the testing
process. You can create tests that check all aspects of your application, and then run these tests
every time your application changes.

As UFT runs, it simulates the application running by performing application processes in your
application. However, UFT does this faster than any human user.

Benefits of Automated Testing

Fast Automated tests are significantly faster than human users.

Reliable Tests perform precisely the same operations each time they are run, thereby
eliminating human error.

Repeatable You can test how the application reacts after repeated performance of the
same operations.

Programmable You can program sophisticated tests that reveal hidden information.

Comprehensive You can build a set of tests that covers every feature in your application.

Reusable You can reuse tests even if the application being tested changes.
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Testing Process
The UFT API testing process consists of the followingmain phases:

1. Analyzing your application
The first step in planning your test is analyzing your application to determine your testing
needs.

n What application processes or technologies does your application use? You will
need to create steps that target the specific processes your application runs or the specific
technologies that your application uses.

n Does my application use standard application processes or custom-designed
services?Depending on what processes your application uses to perform its tasks, you
can use the out-of-the box activities provided with UFT in the Toolbox pane or import/create
custom activities.

2. Preparing the testing infrastructure
Based on your testing needs, youmust determine what resources are required.

Examples of such resources includeWSDL orWADL files, REST Services, external data
sources, or virtualization projects for your service calls. You need to import or create these
resources in UFT.

You also need to configure UFT settings so that UFT will perform any additional tasks youmay
need, such as displaying a results report each time you run a test, enabling or disabling
debugging for the test run, or configuring SAP server connection information.

3. Building your tests and adding steps to each test.
After the testing infrastructure is ready, you can begin building your tests.

You can create one or more empty tests, add test steps to these tests, and define the input,
output, and checkpoint properties for these steps.

You can also add all your tests (or components) to a single solution. A solution enables you to
store, manage, and edit any related tests together, without having to close one test before
opening another.

Youmay also want to configure test-specific properties at this point.

4. Enhancing your test
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You can enhance your tests in a number of ways:

n Validate test steps by selecting checkpoint properties and entering expected values for
the step properties

n Broaden the scope of your test and test how your application performs the same activities
with multiple sets of data by replacing fixed values with parameters.

n Add additional functionality to your test steps with custom code activities, event handlers,
or custom activities created using UFT's Activity Wizard.

This tutorial includes a step for creating an event handler. For additional details about custom
code, see theHP Unified Functional Testing User Guide.

5. Debugging, running, and analyzing your test
You can debug your test using UFT's debugging functionality to ensure that it operates
smoothly and without interruption. After the test is working correct, you run it to check the
behavior of your application. While running, UFT performs each step of the test in your
application.

6. Reporting defects
If you have ALM installed, you can report defects you discover to a database. ALM is the HP
test management solution.

For details about working with ALM, see theHP Application Lifecycle Management User
Guide. For details about using UFT with ALM, see the section on ALM integration in the
HP Unified Functional Testing User Guide.
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UFT Window
Before you begin creating your test, familiarize yourself with themain UFT window.

The image below shows a UFT window as it would appear right after you create a test, with the test
flow shown in the canvas, and with the toolbar, Toolbox pane, Data pane, and Properties pane
displayed.

Take a few minutes to explore the components of the UFT window. You can then continue to
analyze the application you will be testing in this tutorial.

The UFT window displays the following elements:

Document Types
UFT displays open documents in the document pane. Use the document tabs located just below
the toolbar to navigate to open documents and bring them into focus.

HP Unified Functional Testing (11.53) Page 17 of 86



The document pane can display the following types of files:

l Tests/Business Components. You can create, view, andmodify your test or business
component in the canvas, which enables you to edit the flow of your test or component steps.

l User Code Files. Enables you to enter your custom code as an event handler for an existing
test step (in the TestUserCode.cs file) or in other documents you import into UFT.

l Start Page.Welcomes you to UFT and provides links to recent files, descriptions of new
features, product forums, and other support links. You can use the shortcut buttons to open new
and existing documents.

l Internal Browser pages. Enables you to open internet pages for forums and other product
related pages, such as those accessible from the Start Page or the Helpmenu.

Toolbars and Menus
In addition to the document pane, the UFT window contains the following key elements:

l Title bar. Displays the path of the current test.

l Menu bar. Displays menus of UFT commands.

Note: Somemenu options that relate to GUI testing functionality are disabled when working
with an API test.

l UFT toolbar. Contains commonly used buttons to assist you in designing your testing
documents.

Note: Some toolbar buttons that relate to GUI testing functionality are disabled when
working with an API test.

Panes
Themain UFT window displays the following panes:

Name
Toolbar
Button Description Default Location
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Solution
Explorer

Displays all tests, components, and user
code files contained in the currently open
solution, and enables you tomanage
these resources.

A tab on the left side of the
UFT window.

To display:

l Select View >
Solution Explorer.

l Click theSolution
Explorer button in the
toolbar.

Toolbox Displays all the activities available to use
in your test, and enables you to drag and
drop these activities on the canvas.

A tab on the left side of the
UFT window.

To display:

l Select View
> Toolbox.

l Click the Toolbox
button in the toolbar.

Document
Pane

N/A Displays all open documents. Each
document has a tab that you can click to
bring the document into focus.

An unlabeled pane in the
center of the UFT window.
Each document tab is
labeled with the document
name.

You can display a
document in the document
pane by double-clicking
the document's name in
the Solution Explorer.
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Properties Displays all properties for the selected
test step or test flow or the properties of
the selected data source (in the Data
pane).

A pane on the right side of
the UFT window.

To display:

l Select View
> Properties.

l Click theProperties
button in the toolbar.

l Double-click a step in
the canvas.

l Right-click a step in
the canvas and select
Properties.

Data Assists you in parameterizing your test. A tab at the bottom of the
UFT window.

To display:

l Select View > Data.

l Click theData button
in the toolbar.

Output N/A Displays the compilation information for
your test when running or importing
custom activities.

A tab at the bottom of the
UFT window.

To display, select View
> Output.

Errors N/A Displays a list of missing property values
for test steps, missing references for your
current test, or syntax errors found in your
custom code.

A tab at the bottom of the
UFT window.

To display, select View
> Errors.
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Debug Assists you in debugging your test.

There aremultiple available debug panes:
theBreakpoints pane, Call Stack pane,
Local Variables pane, Console,Watch
pane, Threads pane, and the Loaded
Modules pane.

Tabs at the bottom of the
UFT window. These
panes are not displayed
by default.

To display:

l Select View > Debug

l Click theDebug
button in the toolbar,
and then select from
the individual debug
pane from the drop-
down list.

Tasks N/A Displays and enables you tomanage the
tasks defined for the current test.

Displays the TODO comments included
in your test's custom code.

A tab at the bottom of the
UFT window.

To display, select View
> Tasks.

Search
Results

N/A Displays all occurrences of the search
criteria you define in the Find dialog box or
using other Searchmenu items.

A tab at the bottom of the
UFT window.

To display:

l Select View > Search
Results.

l Perform a search.

Bookmarks N/A Displays the location of bookmarks in
your code documents, and enables you to
navigate to these bookmarks.

A tab at the bottom of the
UFT window.

To display, select View
> Bookmarks.

Run Step
Results

N/A Displays the run results for a test step run
from the canvas.

A tab at the bottom of the
UFT window.

To display: 

l Select View > Run
Step Results.

l Run a step by right-
clicking a test step and
selectingRun Step.
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Accessing UFT in Windows 8 Operating
Systems

Relevant for: GUI tests and components and API testing

UFT applications and files that were accessible from theStartmenu in previous versions of
Windows are accessible inWindows 8 from theStart screen or theApps screen.

l Applications (.exe files). You can access UFT applications inWindows 8 directly from the
Start screen. For example, to start UFT, double-click theHP Unified Functional Testing

shortcut .

Other examples of applications accessible from theStart screen include:

n The RunResults Viewer

n All UFT tools, such as the Password Encoder and the License Validation Utility

n The API testing sample Flight applications

l Non-program files. You can access documentation and the link to theMercury Tours Website
from theApps screen.

Note: By default, the Start and Apps screens onWindows 8 are set to open Internet Explorer in
MetroMode. However, if User Account Control is turned off on your computer, Windows 8 will
not open Internet Explorer in Metromode. Therefore, if you try to open an HTML shortcut from
the Start or Apps screen, such as the UFT Help or Readme file, an error will be displayed.

To solve this, you can change the default behavior of Internet Explorer so that it never opens in
Metromode. In the Internet Properties dialog box > Programs tab, select Always in Internet
Explorer on the desktop for the in theChoose how you open links option. For more
details, see http://support.microsoft.com/kb/2736601 and
http://blogs.msdn.com/b/ie/archive/2012/03/26/launch-options-for-internet-explorer-10-on-
windows-8.aspx.

Where to Go From Here
Now that you have invoked the application, you can begin creating tests for your headless
applications using the sample API Flights application. The following lessons will walk you through
the process of creating a test for basic activities, Web, and REST services.
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Chapter 2: Analyzing Your Application and
Preparing Your Test

"Introducing HP Unified Functional Testing - API Testing" on page 13 gave you an overview of
automated API testing and UFT.

In this lesson, you will analyze an application to determine what needs to be tested.

This lesson includes:

Getting to Know Your Application 24

Explore the Flight API Application 25

Create a New Solution and Test 27
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Getting to Know Your Application
Before you begin creating tests, youmust determine exactly what you want to test in your
application. To do this, you need to analyze your application in terms of its application processes -
the distinct activities that the application performs in order to complete a specific task.

For the purpose of this tutorial, you need to become familiar with the Flight API Application. The
Flight API application is a sample service-based flight reservation application that works with a
flight reservation database. Using this sample application, you can retrieve flights for specific
destinations, create customer orders, update reservations, or delete them. The Flight API
application is available both as aWeb Service or a REST Service.

For details about the service's methods and operations, type help in the Flight API application's
command prompt window.

Note: Youmust have administrator privileges to run the sampleAPI Flights application. If you
are working as a non-administrator user, the application prompts you to run the application as
an administrator.

As you think about how to plan your test, consider the following:

l How is the application organized? Are there separate application processes for each
application task?What are these processes? What are the expected outcomes for each of the
application processes?

l Are there specific operations that are repeated in multiple processes/activities?One
example of such a process is connecting to a login database to verify a user's credentials before
performing application activities. Think of these operations as "reusable" parts.

l What business processes need to be tested?UFT provides a number of API testing
activities technologies. However, if your application uses custom activities not supported out-of-
the-box by UFT, you need to import or create these activities inside UFT.
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Explore the Flight API Application
The first step is to invoke the sample flight application so that it will be available for your test.

1. Make sure you have administrator privileges. These are required by Windows to run the sample
HP Flights service.

2. Select Start > (All) Programs > HP Software > HP Unified Functional Testing > Sample
Applications > Flight API > Sample Application. A Commandwindow opens indicating
that the application is available.

Note:Whenworking inWindows 8 orWindows Server 2012, you can access UFT and
UFT tools directly from theStart screen. For more information about working with UFT in
Windows 8, see theHP Unified Functional Testing User Guide.

3. If the window issues amessage that the default port 24240 is unavailable, edit the
<installation_directory>SampleApplication\HPFlights_Service.exe.config file in a
text editor. In the appSettings section, replace the 24240 port key with a valid one.

4. Type help in the commandwindow to view themethods included in the application.

As you explore the list of methods included in the application, note the property details provided
for eachmethod. You will need this data later in this tutorial to provide property values for these
methods.
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5. Minimize the sample application's Commandwindow. Do not close the Commandwindow, as
this will stop the service.

You are now ready to use this tutorial to create tests on the Flight API application using UFT.
Continue with "Building a Simple Test" on page 29 to create your test.
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Create a New Solution and Test
In this exercise, you will create anew solution and test for the Flight API that you explored in the
"Explore the Flight API Application" on page 25.

The solution you create in this exercise will be used for the other tests created as part of
subsequent lessons.

1. Start UFT.

If UFT is not currently open:

n Double-click the UFT icon on your desktop.

n Select Start > All Programs > HP Software > HP Unified Functional Testing

Note:When the Add-in Manager is displayed, click OK to continue. The Add-in
Manager is relevant for GUI testing only.

The UFT splash screen is displayed while UFT loads. This may take a few seconds.

2. Explore the Start Page.

The Start Page provides links to recent files, information about new features in this version of
UFT, as well as links to helpful support and community forums. In the top-right corner of the
page, you can define options for displaying and closing the Start Page.

a. If it is not already displayed, in the Document pane, click the Start Page tab.

b. In the top-right corner of the Start Page, select theOptions drop-down arrow, and then
select Close Start Page after test loads. The Start Page will close automatically after
you create a test.

3. Create a new test and solution.

Click theNew button . By default, UFT assumes that you want to create a new test,
and the New Test dialog box opens.

a. Select API Test. Populate the fields as follows:

o Name: Enter Basic Test.

o Location: Tests are automatically saved at C:\%HOMEPATH%\My
Documents\Unified Functional Testing, and you do not need tomodify this path. An
example of a default test location is C:\Documents and Settings\<user name>\My
Documents\Unified Functional Testing

o Solution Name: Tutorial
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b. Enter the solution name.

In the Solution Name field, enter the name of your solution. By default, UFT saves the
solution in the same directory as the folder containing your test. If you want to create an
additional directory for solution items, select the Create directory for solution option.

c. Click Create. A blank test opens, with an empty test flow in the canvas.

The test name (Basic Test) and path are displayed in the title bar of themain UFT
window.

In the Solution Explorer, you can see that the test is loaded as part of the Tutorial
Solution solution. Later in this tutorial, you will add additional tests to this solution.

If the Solution Explorer is hidden, click the Solution Explorer button or select View
> Solution Explorer to display it.

You are now ready to begin adding steps to your test.
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Chapter 3: Building a Simple Test
In "Introducing HP Unified Functional Testing - API Testing" on page 13 you learned about the
Flight API application and determined what needs to be tested. You then created a solution, and a
test.

This lesson will guide you through the steps of creating tests with standard API activities.

This lesson contains the following sections:

Creating Test Steps for Your Test - Overview 30

Creating Test Steps 32

Linking Test Steps 36

Mapping Test Steps toMultiple Sources 39

Data Driving a Test Step 42

Where ToGo From Here 46
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Creating Test Steps for Your Test - Overview
After analyzing your application and planning what you need to test, you need to create test steps
for your test. You create test steps by dragging available activities from the Toolbox pane to the
canvas tomake a test flow.

UFT has two different types of activities for use in your test:

l Standard API activities

UFT supports a number of standard API activities that model common application processes,
including:

n Flow Control activities, such asWait, Break, andConditional steps.

n String Manipulation activities, such as Concatenate String andReplace String.

n File system activities for processes involving file system processes

n Database activities, for your application's interaction with a database

n FTP activities for application processes that involve using FTP (File Transfer Protocol)

n Network activities, such as HTTP Request andSOAP Request

n JSON andXML string activities for application processes that require conversion of XML and
JSON 

n Math andDate/Time activities

n OtherMiscellaneous activities, includingCustom Code activities, Run andEnd program
activities, andReport activities.

In addition, there are various common activities directed at testing application processes using
specific technologies, including:

n A Call Java Class activity to use Java-based application processes

n JMS (JavaMessage Service) activities

n IBM Websphere MQ activities

n SAP activities to access an SAP iDOC or RFC from a SAP server

n Load Testing activities to enable your test to run in HP LoadRunner

n HP Automated Testing Tools activities, which enable you to call a GUI test or action, API
test or action, or Virtual User Generator script from UFT, QuickTest Professional, Service
Test, or LoadRunner to use as part of your test.
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l Custom activities

If the standard API activities do not suit your testing needs, you can also create or import
custom activities into your test. You can import a number of different types of custom activities:

n Web Service methods. These activities are stored in aWSDL file that you import into UFT.

n REST Service methods. These activities are created using UFT's REST Service editor and
then used in your test.

n Web Application methods. These activities are stored in aWADL file that you import into
UFT.

n User-designed activities. These activities are user-created using UFT's Activity Wizard,
and then imported into a test.

n .NET Assembly activities. These activities are created when you import a .NET assembly
in a test.

Using these activities, you can create test steps for many different types of application processes.
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Creating Test Steps
You create test steps by dragging activities from the Toolbox pane into the canvas and setting the
step properties in the Properties pane.

In this section you will create a simple test step to illustrate the use of the Toolbox and Properties
panes.

1. Locate the Replace String activity.

a. Click the Toolbox tab to display the Toolbox pane.

b. In the Toolbox pane, expand theString Manipulation category and find theReplace
String string activity.

This activity searches for a specified text string and replaces the string with alternate text.
The text strings to find and replace will be specified in the Properties pane.

2. Create a step.

From the Toolbox pane, drag theReplace String activity onto the canvas and drop it inside the
Test Flow area.

Note: You can also double-click an activity in the Toolbox pane to add it to the canvas.

HP Unified Functional Testing (11.53) Page 32 of 86



3. Change the step's display name.

a. Select View > Properties to display the Properties pane.

b. Select theReplace String step in the canvas.

c. In the Properties pane, click theGeneral tab .

d. In theName row, typeChange Text and press ENTER. This changes the step name in the
canvas.

4. Set the input properties for the Change Text step.

In the Properties pane, select the Input/Checkpoints tab. Enter the following values in the
Input section of the Input/Checkpoints tab:

n Source string: Hello world..

n Search string: Hello

n Replace string: Goodbye

n Case-sensitive: false
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5. Run the test.

a. Click theRun button or press F5 to open the Run dialog box.

b. In the Run dialog box, click Options to expand the dialog box.

c. Select the Temporary run results folder option.

d. Click Run to compile and run the test.

6. View the results.

After your test runs, the Run Results Viewer opens.

a. Select View > Expand All or click the Expand All toolbar button to view all the test steps.

b. In the test step hierarchy in the left pane, click theChange Text node. The step results for
the Change Text step are displayed in the Result Details and Captured Data panes.

c. In the Captured Data pane, view the source and replacement strings and note the result
string, Goodbye world. This is in fact the expected string—the test passed.

d. When you are finished reviewing the results, close the Run Results Viewer.
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7. Set a checkpoint for the Change Text step.

In the previous step, youmanually viewed the output to check if the result of the stepmatched
the expected value for the step. In this step, you will create a checkpoint for your test step.

Checkpoints allow you to see whether a step is successful without having tomanually check
the result. Checkpoints are themeans to validate the test—a success or failure is determined
by its checkpoints.

a. Select the Change Text step in the canvas.

b. In the Properties pane, open the Input/Checkpoints tab.

c. In theCheckpoints section (lower section), select theValidate check box in theResults
row to enable the checkpoint.

d. In theExpected value column, type the expected string, Goodbye world.

e. Run the test again. In the Run Results Viewer, expand the test step nodes, and note the
checkmarks by the test step name. This indicates that the checkpoint passed since the
result matched the expected value.

f. When you are finished reviewing the results, close the Run Results Viewer.

Now that you have learned how to create test steps, including adding input and checkpoint
properties for your test steps, you can continue to enhance your tests by linking test steps to one
another. Continue to "Linking Test Steps" on the next page to learnmore.
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Linking Test Steps
When your application runs, it sometimes can pass a property or parameter from one process to the
next. As a result, when testing your application processes in UFT, you need to be able to link test
properties to each other.

In this section, you will use the output of one step as input for another test step.

1. Add a Concatenate String step to the Test Flow

In the Toolbox pane, select Concatenate String from theString Manipulation category.
Drag the activity into the canvas and drop it below the Change Text step in the Test Flow.

2. Set the prefix input property for the Concatenate String step.

a. In the canvas, select theConcatenate String step.

b. In theProperties pane, click the Input/Checkpoints tab.

c. In the Input section (upper section), select theValue cell of thePrefix row.

d. In the Value cell of the Prefix row, click the Link to a data source button . The Select
Link Source dialog box opens.

3. Link the Concatenate String step to the Change Text Step.

a. In the Select Link Source dialog box, select theAvailable steps option.

b. In the left pane, select the Test Flow > Change Text node. The list of available properties
for the Change Text step is displayed in the right pane.
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c. In the right pane, double-click theResults node. The canvas now reflects that data is
moving from Change Text toConcatenate String.

Note that the property value for the Prefix step is also displayed as
{Step.OutputProperties.ReplaceStringActivity4.Result}. This indicates that this
property is the result of the output of the Replace String (Change Text) activity.

Note: Although you renamed the Replace String activity in the previous section, UFT
still refers to this activity by its standard (programmatic) name.

4. Configure the suffix properties for the Concatenate Strings step.

a. In the Input section of the Input/Checkpoints tab, select theSuffix row.

b. In the suffix row, enter the text Welcome to the Basic Test. into the property's Value
field.

5. Run the test.

Click theRun button or press F5 to run the test.

6. View the run results.

a. Expand the Run Results tree and select theConcatenateStringsActivity node. The report
shows the result of the concatenated strings: Goodbye World.Welcome to the Basic
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Test.

b. When you are finished reviewing the results, close the Run Results Viewer.

Now that you have learned the basics of linking test steps to one another, you can learn how to link
your test steps tomultiple input sources, Continue to "Mapping Test Steps toMultiple Sources" on
the next page to learnmore.
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Mapping Test Steps to Multiple Sources
Using the Select Link Source dialog box, you can link to different types of data sources to provide
input values for your test steps: Available steps, Data source column, and Test variables. By
linking your test steps tomultiple sources, you can test those application processes whose input is
linked to the output frommultiple other processes.

In the above section, you used theAvailable steps source for one value, andmanually typed in the
data for another value. In this section, you will create a custom expression to usemultiple data
sources as a property value. You will use the Select Link Source dialog box to create an expression
for theSuffix property that uses bothmanual entry and automatic values from theAvailable steps
option.

1. Set the prefix for the Concatenate String step.

a. In the canvas, select theConcatenate String step.

b. Open the Input/Checkpoints tab in the Properties pane.

c. In the Input/Checkpoints tab, select theValue cell of thePrefix row.

d. In the Value cell, click the to clear the contents.

e. In the Value cell, enter a new prefix Hello world.

2. Open the Select Link Source dialog box.

a. In the Input/Checkpoints tab, select theValue cell of theSuffix row

b. Click to clear its contents.

c. In the Value cell, click the Link data to source button . The Select Link Source dialog
box opens.

3. Edit the suffix property for the Concatenate String step.

a. In the Select Link Source dialog box, click theCustom Expression button to display the
custom expression.

b. In theExpression box, type the following:" was replaced with " (adding a space
before and after the phrase to improve the readability).
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4. Add another source to the custom expression.

a. In the Select Link Source dialog box, select theAvailable steps option (if not already
selected). A list of available steps for this property is displayed in the left pane.

b. In the left pane, select theChange Text node. The available properties for the Change
Text step are displayed in the right pane.

c. In the right pane, select theResult node in the right pane, and click Add.

TheExpression box shows both sources: your manually-entered expression and the
output from the Replace String (Change Text) activity. This string will be added as the
suffix property for the Concatenate Strings step.

d. Click OK to add the custom expression as the Suffix property for the Concatenate String
steps.
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5. Run the test and view the report.

a. Click theRun button to run the test.

b. In the Run Results Viewer, expand the results and select theConcatenateString node.
The report shows the result of the concatenated strings.

6. When you are done viewing the results, close the Run Results Viewer.
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Data Driving a Test Step
Data driving is the assigning of data to test steps from a data source, such as an Excel file, an XML
file, a database, or a local table. The goal of data driving is to run the same application process with
different values. It allows you to check your application in different scenarios simply by modifying
the data values used for the step properties

In this section, you will learn how to data drive your test steps.

1. Data drive the input properties for the Change Text step.

a. Select theChange Text step in the canvas.

b. Open the Input/Checkpoints tab in the Properties pane

c. In the Properties pane, click theData Drive button. The Data Driving dialog box opens.

2. Specify a data provider for the data.

a. In the Data Driving dialog box, select the following options:

o Set theData Provider type to Excel.

o Enable data driving forBoth Input and Checkpoints.

o Clear theConfigure 'Test Flow' as a ForEach loop using the new data source
option.

This option repeats the Test Flow according to the number of data rows. You will
manually set the number of iterations in a later step.

b. Click OK to close the Data Driving dialog box.

c. Accept the popupmessage. The data drivingmechanism replaces the constant values
with the new expressions, {DataSource.Change Text_
Input!MainDetails.SourceString}.
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3. View the Data pane.

a. Open the Data paneView > Data.

b. In the left pane of the Data pane, expand theChange Text_Input node and select the
Change Text_Input!MainDetails node.

The Data pane shows a data table with a column for each input property, and one row of
values corresponding to the input property. In this example, you see theHello World.
input string and FALSE (or an empty check box if you do not have Excel installed) that you
entered earlier.

4. Add new data.

In theChange Text_Input!MainDetails sheet, add two additional rows. Make sure to copy the
text exactly, including punctuation where included.

Entry Number MainDetailsKey SourceString CaseSensitive

1 1 Hello world. FALSE

2 2 I like eating broccoli. TRUE

3 3 The product version is 11. FALSE

5. Add new search and replace data.

In the Data pane, select theChangeText_Input!SearchReplaceString node and add two
additional rows to the table. Make sure to copy the text exactly, including punctuation where
included.

MainDetailsKey Key Value

1 Hello Goodbye

2 broccoli ice cream

3 11 12
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6. Add checkpoint values.

a. In the Data pane, expand theChange Text_Checkpoints node and select theChange
Text_Checkpoints!MainDetails node.

b. In the first column (under theResult cell), add values to this column as shown below:

Note: In the third row, we will intentionally insert an exclamation point (!) to generate
an error.

Result

Goodbye world.

I like eating ice cream.

The product version is 12!

7. Set the number of iterations.

The number of iterations is the number of times to repeat the step. Wewill set it to 3,
corresponding to the number of rows of data in our table.

a. Return to the canvas and click inside the Test Flow frame—but not within a test step.

b. Open the Input tab in the Properties pane.

c. In the Input tab, select 'For' Loop and set theNumber of Iterations to 3.
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8. Run the test and view the report.

Click theRun button or press F5 to compile and run the test. The test runs three times,
using the three lines of data in the table.

When the Run Results Viewer opens, expand the Test Flow node and drill down to the row
with the redX, indicating a failed checkpoint. The checkpoint failed because the expected
result contained an exclamation point, which was not present in the source string.

9. Correct the error and rerun the test.

a. In the Data pane, select theChange Text_Checkpoints!MainDetails node

b. In the third row of theResults column replace the exclamation point with a period.

c. Run the script again and verify that you have no errors in the report.
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Where To Go From Here
In this lesson, you learned how to create test steps from standard activities, link the step properties
together, and use data to drive the values of test step properties.

In the next lesson, you will apply these lessons when working with a custom activity using an
importedWeb service.The following lessons will walk you through the process of importingWSDLs
and creatingWeb service tests.
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Chapter 4: Building a Web Service Test
In "Building a Simple Test" on page 29, you learned how to create a test using standard API
activities and learned some basic techniques for enhancing your test steps.

However, there will also be times where the standard activities do not match the processes your
application performs. In these cases, you will need to use custom activities that you import or
create in UFT, such as Web Services. Using UFT, you can also create tests for yourWSDL-based
Web services.

This lesson contains the following sections:

Importing aWeb Service 48

Building aWeb Service Test 50

Integrating Data into YourWeb Service Tests 56

UsingMultiple Data Sources and Custom Code in YourWeb Service Tests 61

Where to Go From Here 66
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Importing a Web Service
When you want to test yourWeb service application, youmust import this service into UFT. You
import yourWeb Service using aWSDL file, which defines the operations/methods in aWeb
service. UFT reads theWSDL file and creates the service's methods as activities in the Toolbox
pane.

This section shows you how to import the Flight API application's WSDL file.

1. Start the Sample Flight application.

Make sure that the Flight Application service is available, as described in "Explore the Flight
API Application" on page 25.

2. Add your new test to the solution.

a. Select File > Add > New Test.

b. In the Add New Test to Solution dialog box, select API Test.

c. Name theWebServiceTest and click Add.

The test is added to the Tutorial Solution along with the Basic Test created in the
previous lesson.

3. Open the Import WSDL dialog box.

In UFT, select Import WSDL > Import WSDL from URL or UDDI from the toolbar. The
Import WSDL from URL or UDDI dialog box opens.

4. Specify an import source.

a. In the Import WSDL from URL or UDDI dialog box, Select theURL option.

b. In the address field, enter the URL for theWeb Service:
http://localhost:24240/HPFlights_SOAP?wsdl

c. Click OK.
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The service is imported into UFT and its methods are displayed in the Toolbox pane under the
Web Services node.

Now that you have imported the service's methods into UFT, you can begin to create test steps
using thesemethods. Continue to "Building aWeb Service Test" on the next page to learnmore.

HP Unified Functional Testing (11.53)Page 49 of 86

API Testing Tutorial
Chapter 4: Building aWeb Service Test



Building a Web Service Test
After you import aWeb Service's methods, its methods are available for use in a test.

In this section, you will create a new flight order using theHPFlightsWeb service.

In order to create a flight order, youmust first know the available flights. First you will run the
GetFlights step that retrieves all of the flights to your destination. In the next step, you will use the
first flight number returned, as input for theCreateFlightOrder step.

1. Create a GetFlights step.

In the Toolbox pane, expand theWeb Services, HPFlights_Service, and
FlightServiceMethods nodes and drag theGetFlights activity into the Test Flow.

2. Assign values for the DepartureCity and ArrivalCity input properties.

a. In the canvas, select theGetFlights step.

b. In the Properties pane, open the Input/Checkpoints tab and expand theBody >
GetFlights node.
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c. Select the following values from the drop-down list:

o DepartureCity: Denver

o ArrivalCity: Los Angeles
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3. Create a CreateFlightOrder step.

From the Toolbox pane, drag theCreateFlightOrder activity into the Test Flow,below the
GetFlights step.

4. Set the input property values for the CreateFlightOrder step.

a. In the canvas, select theCreateFlightOrder step.

b. In the Properties pane, open the Input/Checkpoints tab , and fully expand the
CreateFlightOrder > FlightOrder node.

c. Set the input property values for creating a flight order:

o Class—Select a class, such as Businessfrom the drop-down list.

o CustomerName—enter any value

o DepartureDate—use the drop-down to open a calendar and select a date at least two
days in the future.

o FlightNumber—leave this field blank for now. You will set its value in the following
steps.

o NumberofTickets—select any value.

5. Link the output of the GetFlights stepto the CreateFlightOrder step.

a. In the canvas, select theCreateFlightOrder step.

b. In the Properties pane, open the Input/Checkpoints tab.

c. Expand theCreateFlightOrder node and select theValue cell in the FlightNumber row.

d. In the Value cell, click the Link to a data source icon . The Select Link Source dialog
box opens.

e. In the Select Link Source dialog box, select Available steps option.

f. From the left pane, select theGetFlights node.

g. In the right pane, select the Input/Checkpoints tab.

h. In theOutput section, expand all nodes under theBody node by clicking the
GetFlightsResult node and clicking theAdd button in the Flight (array) node row to
create the Flight[1] array.

i. Expand the Flight[1] node.
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j. Select the FlightNumber element, and click OK. When UFT asks if you want to enclose
the target step in a loop, select No.
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The canvas indicates a connection between the two steps.

6. Reset the number of iterations.

a. Return to the canvas and click inside the Test Flow frame but not within a test step.

b. In the Properties pane's, open the Input/Checkpoints tab .

c. Select For Loop and set theNumber of Iterations to 1.

7. Run the test.

Click theRun button. Observe the build log in theOutput tab.

After the test run is complete, the Run Results Viewer opens automatically.

8. Check the results.

a. In the Run Results tree (left pane), right- click the parent node and select Expand All.

b. Click theCreateFlightOrder node. The result details for the CreateFlightOrder step are
displayed.
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c. In theCaptured Data pane, scroll down to theWeb service Call HTTP Snapshot section
and look at the Response pane. Note the output of the request—OrderNumber and
TotalPrice. Copy the TotalPrice value to the clipboard for use in the next step.

Tip: Click theRequest orResponse links to open the SOAP in a separate browser.

When you are finished viewing the results, close the Run Results Viewer.

9. Set a checkpoint for the CreateFlightOrder step.

a. Select theCreateFlightOrder step in the canvas.

b. In the Properties pane's, open the Input/Checkpoints tab.

c. In the Checkpoints section (lower section), expand theCreateFlightOrderResponse
> CreateFlightOrderResult node.

d. Paste the total price amount from the previous step into the TotalPrice field and select the
Validate check box in the TotalPrice row.
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10. Run the test and view the checkpoint results.

a. Run the test again

b. When the Run Results Viewer opens after the test run, expand the Run Results tree and
Select theCheckpoints node forCreateFlightOrder step.

The report shows a checkmark and indicates the expected and actual values. If the
expected value was not returned by the server, the report indicates a failure.

When you are finished viewing the results, close the Run Results Viewer.

Now that you have created a test for yourWeb Service, you can enhance yourWeb Service test by
using data. Continue to "Integrating Data into YourWeb Service Tests" below to learnmore.

Integrating Data into Your Web Service Tests
In this section you will learn how to integrate data from an existing source, and how to data drive the
test. When you data drive a test, the Data pane automatically creates a data table whose values
you can edit.

1. Import a data source for your test

In the Data pane, click theNew Data Source button select Excel. The Add New Excel
Data Source dialog box opens.

a. Browse for the sample application's Excel file, SampleAppData.xlsx, in the
<installation directory>\SampleApplication folder..

b. Enable theExcel file contains header row option, since the sample file contains a header
row.

c. Enter WS_Flights as aData source name.
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d. Select Link to the Excel file in its original location as themode of import. This links to
the Excel file at its original location, so that if data changes, your data source will be
current.

e. Click OK.

2. Link the input properties for the CreateFlightOrder step to the data.

a. Select theCreateFlightOrder step in the canvas.

b. In the Properties pane, open the Input/Checkpoints tab.

c. In the Input section of the Input/Checkpoints tab, expand all the FlightOrder node and
select theClass row.

d. In the Class row, click the Link to a data source icon . The Select Link Source dialog
box opens.

3. Link the Class input property to the data source.

a. In the Select Link Source dialog box, select theData source column option. The list of all
available data sheets is displayed.

b. Select theWS_Flights!Input node. The list of all available data columns is displayed.
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c. From the list of data columns, select Class in the right pane and click OK. This instructs
the test to refer to this column in the sample data during the test run.

d. Repeat this for the other input parameters: CustomerName, DepartureDate,
FlightNumber, andNumberofTickets.

4. Disable the CreateFlightOrder checkpoint.

a. Select theCreateFlightOrder step in the canvas.

b. In the Properties pane, open the Input/Checkpoints tab.

c. In the Checkpoints section (lower section) of the Input/Checkpoints tab, clear the
checkbox in the TotalPrice row. This instructs UFT not to check this property during the
test run.
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5. Set the navigation settings for your data.

The navigation settings let you indicate how to use the data in your data source. You can
specify from which row to begin, how many rows to advance, and in what direction tomove for
the next set of values. You can also specify what to do when reaching the end of the data
table—wrap around or continue using the last line.

a. In the canvas, click in the Test Flow but not within a step.

b. In the Properties pane, open theData Sources tab .

c. In the Data Sources tab, select theWS_Flights!Input entry in the table and click Edit to
open the Data Navigation dialog box.

d. In the Data Navigation dialog box, specify the data navigation details:

o Start at: First row

o Move:Move by 3 rows Forward

o End at: Last row

o Upon reaching the last row: Wrap around
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e. Click OK.

6. Run the test and view the results.

a. Click theRun button and observe the results in the Output window.

b. In the Run Results Viewer, expand the result tree and select theCreateFlightOrder step.
Scroll downwithin theCaptured Data tab and note the data from the Excel file in the
SOAP request (left pane), and the result in the SOAP response (right pane).

When you are finished viewing the results, close the Run Results Viewer.

Now that you have learned how to integrate data into yourWeb Service tests, you can further
enhance your tests by linking steps tomultiple sources and using custom code. Continue with
"UsingMultiple Data Sources and Custom Code in YourWeb Service Tests" on the next page.
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Using Multiple Data Sources and Custom Code
in Your Web Service Tests

In the previous section, you learned how to use data in yourWeb Service test steps. This section
extends this by describing how to define data usingmultiple data sources and sending information
to the report through a custom code step.

1. Create a new test.

Add a new test called WebServicesCustom to your solution and import the HP Flights Services
WSDL as described in "Importing aWeb Service" on page 48.

2. Create test steps for your test.

From the Toolbox pane, drag the activities into the canvas in the following order:

n GetFlights (found under theWeb Services node)

n CreateFlightOrder (found under theWeb Services node)

n Custom Code (found under theMiscellaneous node)

3. Add a data source to your test.

In the Data pane, select New > Excel. In the Add New Excel Data Source dialog box:

a. Browse for the sample application Excel file in the installation
directory>\SampleApplication folder.

b. Select theExcel file contains header row check box.

c. Enter WS_Flights as aData source name.

d. Select the Link to the Excel file in its original locationmode.

e. Click OK to add the data source to the test.

4. Assign values for the input properties of the GetFlights step.

a. In the canvas, select theGetFlights step.

b. In the Properties pane, open the Input/Checkpoints tab.

c. In the Input/Checkpoints tab, in the Input section, select DepartureCity= Denver, and
ArrivalCity=Los Angeles.

5. Assign values for the input properties of the CreateFlightOrder step.

In the canvas, select theCreateFlightOrder activity.
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In the Properties pane, open the Input/Checkpoints tab.

In the Input/Checkpoints tab, expand the FlightOrder node (found under the Body node) and
set the input properties as follows:

n Class:Economy

n CustomerName:Click the Link to a data source button in the right corner of the
CustomerName row. In the Select Link Source dialog box, select Data source column,
and expand the tree to show theWS_Flights!Input node. In the right pane, select the
CustomerName parameter and click OK.

n DepartureDate. A date at least two days ahead of the current date.

n NumberofTickets. 3

n FlightNumber: Link from the previous step:

i. Click the Link to a data source button in the right corner of the FlightNumber
row.

ii. In the Link to Source dialog box, select Available steps, expand the Test Flow node,
and click GetFlights.

iii. In the right pane, select the Input/Checkpoints button .

iv. In theOutput section, expand theGetFlightsResult node and click theAdd button
in the Flight (array) node row to create the Flight[1] array. Expand the array, select
FlightNumber, and click OK.When prompted to enclose the target step in a loop,
select No.

6. Create an input property for the custom code step.

a. In the canvas, select theCustom Code activity.

b. In the Properties pane, open the Input/Checkpoints tab.
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c. In the Input/Checkpoints tab, click theAdd Property button and select Add Input
Property. The Add Input Property dialog box opens.

d. In the Add Property dialog box, create a new String type property called FlightInfo.

e. Click OK to add the input property.

7. Define values for the custom code step.

In this step you will define a value usingmultiple sources. In this example, you will set a value
which is a combination of theCustomerName, a constant string, and theOrderNumber:

a. In the canvas, select theCustom Code step.

b. In the Properties pane, open the Input/Output Properties tab.

c. In the Input/Output Properties tab select the FlightInfo row.

d. In theValue column of the FlightInfo row, click the Link to a data source button . The
Select Link Source dialog box opens.

e. In the Select Link Source dialog box, click Custom Expression to show the Expression
area.

f. At the top of the Select Link Source dialog box, select theData source column option.
The list of available data sheets is displayed.

g. In the data sheet list (left pane), select theWS_Flights!Input node. The list of available
data columns is displayed.

h. In the list of data columns, select CustomerName and click Add.

i. In theExpression area, type _OrderNumber_ (with the underscores) after the existing
expression.

j. At the top of the dialog box, select theAvailable steps and expand the Test Flow branch.
The list of available steps is displayed.

k. In the list of test steps, select theCreateFlightOrder node.

l. In the right pane, select the Input/Checkpoints button .

m. In the lower pane of the Input/Checkpoints tab, expand theOutput Body node, expand the
CreateFlightOrderResponse node, then theCreateFlightOrderResult node, select the
OrderNumber element, and click Add.
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n. The the Expression box contains the following value:

{DataSource.WS_Flights!Input.CustomerName}_OrderNumber_{Step.OutputPro
perties.StServiceCallActivity(x).Body.CreateFlightOrderResponse.Create
FlightOrderResult.OrderNumber}

o. Click OK to close the dialog box.

8. Create an event.

In this step you will create an event handler in order to use custom C# code to your test step.
Defining events let you adapt your test to your custom requirements, and perform actions that
are not built-in to UFT. In this example, you will add code that sends a custom string to the
report.

a. In the canvas, select theCustom Code step.

b. In the Properties pane, open theEvents tab . A list of default event handlers is
displayed.

c. In theExecuteEvent row of the Events tab, click the drop down arrow and select Create a
default handler.

UFT creates an event calledCodeActivity(x)_OnExecuteEvent and opens a new tab
called TestUserCode.cs.

9. Edit the "Todo" section for your event handler.

In the TestUserCode.cs file, in the TODO section of theCodeActivity(x)_OnExecuteEvent
section, replace the Todo section with the following:

CodeActivity(x).Report("Customer and Order Number",CodeActivity(x).Input.
FlightInfo);
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In the following example, the index assigned to the event was 12, so the string is
CodeActivity12.Report("Customer and Order
Number",CodeActivity12.Input.FlightInfo);.

10. Run test and check the results.

In the Run Results Viewer, expand the Test Results tree to theCustom Code step. Note the
new entry in theCaptured Data pane: Customer and Order Number.

Tip: You can also use theReport Message activity under theMiscellaneous folder, to
send text and property values to the report.
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Where to Go From Here
Now that you have learned to create a test for aWeb service, you can relate this to other types of
services and application components. The next lesson will walk you through the process of creating
a test for a REST service.
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Chapter 5: Building a REST Service Test
Similar to what you did when importing yourWeb Service, you can test your REST Service
application processes in UFT. When you test REST Service processes, youmust create them
inside UFT as a prototype and then use themethods in your test.

This section will teach the basic steps in creating your REST Servicemethods and using them in
your test.

This lesson contains the following sections:

Creating a REST Service Activity 68

Running a REST Service Test 74

Assigning Data to a REST Service Test 76

Checkpoints for REST Service Test Steps 80

Resolving Changes in a REST Service 82
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Creating a REST Service Activity
Before you can use a REST Service activity in your tests, youmust create the necessary activities
and their properties inside of UFT.

This section describes how tomodel a REST service activity using the Flight API application. Once
you create a REST Servicemethod, you can reuse themethod for different test steps.

1. Start the Sample Flight application.

Make sure that the Flight Application service is running, as described in "Explore the Flight API
Application" on page 25.

2. Obtain the REST service modeling document.

In the Flight API application commandwindow, type h, and press ENTER. A browser opens
with themodeling information for the REST service.

Note: The file containing this information (index.htm) is located in the <installation_
folder>\SampleApplication\Help folder.

3. Save the ReserveOrder Request body.

a. Copy the Request Body for the FlightOrders > ReserveOrder (POST)method. Only copy
the XML code.

<FlightOrderDetails xmlns="HP.SOAQ.SampleApp" >
  <Class>Business</Class>
  <CustomerName>John Doe</CustomerName>
  <DepartureDate><future date></DepartureDate>
  <FlightNumber>1304</FlightNumber>
  <NumberOfTickets>21</NumberOfTickets>
 </FlightOrderDetails>

b. Create a new file in a text editor and paste the contents of the clipboard. Make sure to
modify the date in the <DepartureDate> line to a future date.

c. Save the file as body.xml to any location.

4. Add a new test to the solution.

Add a new test called RESTServiceTest to your solution as described in "Importing aWeb
Service" on page 48.
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5. Create a REST service.

a. Click theAdd REST Service toolbar button . The Add REST Service dialog box
opens.

b. In the left pane of the Add REST Service dialog box, click on theNew Service node and
rename it toSamplesRESTService.

6. Add a resource to the REST Service method.

a. In the Add REST Service dialog box, click the toolbar's Add Resource button . A new
resource is added under your SampleRESTService.

b. Rename the resource to FlightOrders.

7. Add a method to the REST service.

a. In the Add REST Service dialog box, click theAdd Method button . A new method is
added under the FlightOrders resource.

b. Rename themethod toReserveOrder.
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8. Configure the REST Service URL.

a. In the left pane, select theSampleRESTService node .

b. In the right pane, select theGeneral tab.

c. In the URL property row, paste the URL prefix: http://localhost:24240.

d. Return to the left pane and select the FlightOrders node. Note that the value you pasted in
the URL property field for theSampleRESTService node has been passed to the
FlightOrders resource.

e. In theGeneral tab of the right pane, paste /HPFlights_REST in theRelative URL property
row. After you paste this value here and select an area outside the property value row, the
/HPFlights_REST is added to the URL prefix value from theSampleRESTService node.

f. In the left pane, select theReserveOrder node.

g. In theHTTP Input/Checkpoints tab of the right pane, paste /FlightOrders/ in the
Relative URL value row. This addition is appended with the URL property value passed
from the FlightOrders node of your REST service.

9. Configure additional HTTP properties.

a. In the Add REST Service dialog box, select theReserveOrdermethod node.

b. In the right pane, open theHTTP Input/Checkpoints tab in the right pane.

c. Set theHTTP method toPOST.

d. Open the HTTP tab in the right pane.

e. In theRequest Body section, click the Load XML button.

f. Navigate to the body.xml file you saved in a previous step and click OK to add this XML to
your REST method.

Note that the XML structure saved in the body.xml file is displayed in the Request Body
section (either in Grid form or Text form, depending on which view you have selected).

g. Open theHTTP Input/Checkpoints tab.
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h. Expand theRequest Headers array. The following values are now displayed in the
Request Headers properties:

o Name row: Content-Type

o Value row: text/xml

10. Create input properties for the REST Service.

a. In the Add REST Service dialog box, select the SampleRESTService node.

b. In the right pane, open the Input/Checkpoints tab.

c. In the Input/Checkpoint tab, select Add > Add Input Property. The Add Input Property
dialog box opens.

d. In the Add Input Property dialog box, add aString type property calledClass. You do not
need to provide a default value.

e. Add anotherString type property calledCustomer_Name.

f. Add anotherDateTime type property calledDeparture_Date.

g. Add an Int type property called Flight_Number.

h. Add another Int type property calledNumber_of_Tickets.

11. Create output properties for the REST Service.

a. In the Add REST Service dialog box, select theReserveOrder node.

b. In the right pane, open theCustom Input/Checkpoints tab .

c. Select Add > Add Output Property. The AddOutput Property dialog box opens.
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d. In the AddOutput Property dialog box, add a Int type property called Total_Price.

e. Add another Int type property calledOrder_Number.

12. Import the Request body.

a. In the Add REST Service dialog box, select theReserveOrder node.

b. In the right pane, open theHTTP tab .

c. Select XML as theRequest Body type.

d. Click the Load XML button and load the body.xml file that you saved earlier.

The property values as defined in the XML from the body.xml file are displayed in the
Request Body grid.

13. Test the method.

In the Add REST Service dialog box, click theRun Method toolbar button to check the
validity of themethod. Scroll through the results and verify that the response body contains an
order number and price.
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14. Add the method to the Toolbox.

Click OK in the Add REST Service dialog box. The REST designer adds the REST service,
along with its resource andmethod to the Toolbox pane, under the Local Activities category.

15. Share the REST activity to make the activity available for all tests.

a. In the Toolbox pane, select the parent node of the REST service, SampleRESTService

b. Right-click the SampleRESTService node and selectMove to > File System Activities
from the right-click menu.

The REST service activity is now moved to the File System Activities section in the
Toolbox pane. Any other test can now use this activity.

You have now created a prototype activity for your REST service, complete with input parameters
and the HTTP information. You can now use themethods in your tests. Continue with "Running a
REST Service Test" on the next page to learn how to run the test with these newly-created REST
methods.
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Running a REST Service Test
In the previous section, you learned how to create a REST Service in UFT using the Add
REST Service dialog box (also called the REST Service editor).

This section describes how to run the REST servicemethod created in the previous section. You
will incorporate data into the test, using the sample data file included with the product.

1. Create a test step.

a. In the Toolbox pane, expand the File System Activities node.

b. In the File System Activities node, expand all the nodes in theSampleRESTService node.

c. Select theReserveOrdermethod and drag it to the canvas.

2. Check the HTTP response properties for the ReserveOrder REST method

a. In the canvas, select theReserveOrder step.

b. In the Properties pane, open theHTTP tab in the Properties pane.

c. Check tomake sure that the property values for this step are those which we imported in
the previous section from the body.xml file. These values were used in the test run that we
just performed.

3. Run the test.

Select Run > Run to run the test.
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4. View the run results.

a. In the Run Results tree, click theExpand All button or right-click the Run Results
Tree and select Expand All.

b. In the Run Results tree, select theReserveOrdernode. The step result details are
displayed for the ReserveOrder step.

c. In theCaptured Data pane, click theResponseBody link to open the response in a
separate browser window.

d. Verify that theResponse Body contains values for theOrderNumber and TotalPrice
elements. This corresponds to the operation's description in the REST Service Help page
that indicated the following: It creates a new flight order and returns
OrderNumber and TotalPrice.

- <CreatedOrderParams xmlns="HP.SOAQ.SampleApp" xmlns:i="http://www.w3
.org/2001/XMLSchema-instance">
<OrderNumber>18</OrderNumber>
<TotalPrice>3717</TotalPrice>
</CreatedOrderParams>

Continue to "Assigning Data to a REST Service Test" on the next page to learn how to
enhance your REST method test steps by assigning data values for themethod's properties.
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Assigning Data to a REST Service Test
In previous sections, you have seen how you can assign data values to your test steps. In this
section, you will also assign data from an imported Excel data source to your REST Service test
steps.

1. Import an Excel data source into your test.

a. In the Data pane, expand the Data Source button and select Excel. The New Excel
Data Source dialog box opens.

b. Click the Browse button adjacent to theExcel file path field, and browse to the
sample application's SampAppDataExcel file in the <installation
directory>\SampleApplication folder.

c. Select theExcel file contains header row check box, because the sample contains a
header row.

d. In theData source name field, enter REST_Flights.

e. Select theMake a copy of the Excel file option. This saves a copy of the data file with
the test.

f. Click OK. The data is imported into the Data pane and the data sheets are displayed in the
Data pane.

2. Link the input properties for the ReserveOrder step to the data source.

a. In the canvas, select theReserveOrder step.

b. In the Properties pane, select the Input/Checkpoints tab.

c. In the input section (upper section) of the Input/Checkpoints tab, click the Link to a data
source button in theClass row. The Select Link Source dialog box opens.
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d. In the Select Link Source dialog box, select theData source columnoption.

e. In the list of data sources in the left pane, select theREST_FlightsInput node in the left
pane.

f. In the right pane, choose theClass property in the right pane and click OK.

g. Repeat the above step for the other input properties: Customer_Name, Departure_Date,
and Flight_Number.
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h. Enter 2 for theNumber_of_Tickets.

The resulting properties view shows the new links.

3. Set the number of test iterations.

By setting iterations, we will see how our RESTmethod usedmultiple sets of data from the
data source.

a. In the canvas, select the Test Flow frame in the canvas.

b. In the Properties pane, open the Input/Checkpoints tab.

c. Set a For Loopwith 3 iterations.

4. Run the test.

Select Run > Run to run the test.

5. Verify that the request used the table data.

a. In the Run Results tree, click theExpand All button .

b. In the Run Results tree, select theReserveOrder nodes (one under each iteration). The
result details for the ReserveOrder step are display.
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c. In the Captured Data pane, scroll down and click theRequest Body link. In the browser
window that opens, note that the test used the data from the Data pane for the properties
that we assigned: Class, CustomerName, DepartureDate, and FlightNumber.

- <FlightOrderDetails xmlns="HP.SOAQ.SampleApp" >
<Class>Business</Class>
<CustomerName>John Freeman</CustomerName>
<DepartureDate>2012-12-12</DepartureDate>
<FlightNumber>1304</FlightNumber>
<NumberOfTickets>21</NumberOfTickets>
</FlightOrderDetails>

6. Save the response data.

Wewill save the response data from this run for use in future steps.

a. In the Run Results tree, select aReserveOrder node. Click theResponse Body link in
the Captured Data pane. A browser window opens with the XML response.

b. Save the entire contents of the window to a file Response.xml. Close the Run Results
Viewer.
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Checkpoints for REST Service Test Steps
In previous sections, you used checkpoints to verify your test steps, both for a basic test and a
Web Service test. In this section, you will verify that the output of our RESTmethod is correct by
using checkpoints.

1. Insert a checkpoint for the ReserveOrder step.

a. In the canvas, select theReserveOrder step.

b. In the Properties pane, open theHTTP tab .

c. The lower section of the HTTP tab contains the output properties or output schema. We
will use these as our checkpoints to check the server response.

In the lower section, select XML from theBody drop-down.

d. Click the Load XML button and load the Response.xml file that you saved earlier. The
checkpoint properties and their values from the response.xml file are displayed.

e. In the Checkpoints section (lower section), select theValidate checkbox in the
OrderNumber and TotalPrice rows.

f. Set the value of OrderNumber to Greater than (>) 10, and the value of TotalPrice to
Less than (<) 255.

2. Run the test.

Select Run > Run to run the test.
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3. Verify that the checkpoint passed.

In the Run Results tree, click theExpand All button . Note that some of the checkpoints
passed, while others did not.

4. Determine why checkpoints failed.

a. In the Run Results tree, select one of the failed checkpoints nodes.

b. In the Captured Data pane, note the Actual Results and Expected Values. In the following
example, theOrderNumberwas valid, but the TotalPricewas not valid because it
exceeded 255.

5. Save the test.

Close the Run Results Viewer and save the test.
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Resolving Changes in a REST Service
Initially, we created a prototype REST servicemethodReserveOrder, with specific properties,
such as the URL and property names. If these properties changed after you created a test, your test
step will no longer match the prototype. The Resolve Conflict wizard detects changes in the
method's properties and helps you resolve them.

In this lesson, you will learn to use the Resolve Conflict wizard to resolve these differences.

1. In the Toolbox pane, right-click theSampleRESTService node and select Edit Service. The
Edit REST Service dialog box opens.

2. In the Edit REST Service dialog box, select theSampleRESTService node and open the

Custom Input/Checkpoint tab in the right pane.

3. Select the Flight_Number property, and click theEdit Property toolbar button. The Edit
Property dialog box opens.

4. In the Edit Property dialog box, rename the property to Flight_Number_1 and click OK.

5. In the Custom Input/Checkpoints tab, select theNumber_of_Tickets property, and click the
Delete Property button in the toolbar. Confirm the warning and click OK.

6. Click OK in the Edit REST Service dialog box.

7. View the canvas. Note the alert icon in the bottom right corner of theReserveOrderREST
method frame.

8. Click on the drop-down arrow adjacent to the alert icon, and select the text message: This
step should be resolved. Resolve step. The Resolve RESTMethods Wizard opens.

9. The wizard's first screen shows the problematic steps. If multiple steps were affected, you
could choose which steps to resolve and which to ignore. In this lesson, there is only one step
in your test, so by default , theReserveOrder step is selected. Click Next.
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10. In the Resolve Conflicts screen, in the Input Properties section (top area of the window), select
theNumber_of_Tickets property in the right pane (After changes). Click Keep. This instructs
the existing step to keep the property, even though it was removed from themethod's
prototype.

11. In theAfter changes pane, select the old property Flight_Number and click Remove.

The Flight_Number property is now obsolete. Instead, themethod will contain the new,
automatically detected property, Flight_Number_1.

12. Scroll through the lower section of the wizard screen to see a log of all of the conflicts and their
resolutions.

13. Click Next. Click Finish to close the wizard and return to your test.
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Chapter 6: Where To Go From Here
Now that you have learned to create tests with standard activities, Web services, and REST
services, and learned how you can UFT's testing functionality to enhance these steps, you can
create your own tests for your GUI-less applications.
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We appreciate your feedback!
If you have comments about this document, you can contact the documentation team by email. If
an email client is configured on this system, click the link above and an email window opens with
the following information in the subject line:

Feedback on Unified Functional Testing, 11.53 API Testing Tutorial

Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a webmail client,
and send your feedback to DocTeam_UFT@hp.com.

HP Unified Functional Testing (11.53) Page 85 of 86

mailto:DocTeam_UFT@hp.com?subject=Feedback on Unified Functional Testing 11.53 API Testing Tutorial



	Unified Functional Testing Tutorial for API Testing
	About the Tutorial for Testing
	Topic Types
	UFT Help Contents
	Additional Online Resources

	Chapter 1: Introducing HP Unified Functional Testing - API Testing
	Why Should You Automate API Testing?
	Benefits of Automated API Testing

	Testing Process
	UFT Window
	Accessing UFT in Windows 8 Operating Systems
	Where to Go From Here

	Chapter 2: Analyzing Your Application and Preparing Your Test
	Getting to Know Your Application
	Explore the Flight API Application
	Create a New Solution and Test

	Chapter 3: Building a Simple Test
	Creating Test Steps for Your Test - Overview
	Creating Test Steps
	Linking Test Steps
	Mapping Test Steps to Multiple Sources
	Data Driving a Test Step
	Where To Go From Here

	Chapter 4: Building a Web Service Test
	Importing a Web Service
	Building a Web Service Test
	Integrating Data into Your Web Service Tests
	Using Multiple Data Sources and Custom Code in Your Web Service Tests
	Where to Go From Here

	Chapter 5: Building a REST Service Test
	Creating a REST Service Activity
	Running a REST Service Test
	Assigning Data to a REST Service Test
	Checkpoints for REST Service Test Steps
	Resolving Changes in a REST Service

	Chapter 6: Where To Go From Here
	We appreciate your feedback!

