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Introduction 
The HP ART 5.10 release offers many improved features. ART 5.10 includes the following 
components: 

• 5.10 ART Developer Kit with new features and new technical specifications 
• 5.10 ART template, ART skin (HPART-Rounded Skin), and ART website 
• 5.10 ART courses  

The HP ART 5.10 courses released in August 2013 contain the same content as courses 
previously released in 4.40.  These have been converted to the new technology and new look 
and feel, making some slight improvements to appearance and experience. See the HP ART 5.10 
content release notes included with your HP ART 5.10 content downloads for details on the 
changes. 

As with any software upgrade or conversion, you should perform sufficient testing of the new 
product and follow the recommended conversion steps. 

Before You Begin 

1) Ensure that you have the most current version of the 4.40 to 5.10 Conversion 
Guide. 

The HP ART 5.10 reference documentation is available on the HP Software Support 
Online (SSO) site. Use the link Software Support Online (SSO) to go directly to the HP 
Software Product Manuals page. From here, locate ART Author Developer Kit in the 
Product drop-down list>Version 5.1>Windows Operating System>Search. Links to the 
available reference documents, including this guide display at the bottom of your page. 

NOTE: If prompted, create an HP Passport user ID and password to access the site. 

2) Start with a solid foundation of HP ART knowledge. 
HP ART 5.10 has new features, but the same underlying functionality and structure as HP 
ART 4.40.  The information contained in this guide and the associated resources are 
intended for users with HP ART 4.40 training. 

3) Learn about the new HP ART 5.10 features. 
• Take the free of charge online ART01IT – ART 5.10 Delta Training on the HP Software 

Education website. Here, you learn about the new features, including the newly designed 
ART 5.10 website. 

• HP recommends that you preview updated courses to see the new look for yourself. You 
can view new sample courses on the HP ART HP Software Education Services webpage or 
download your entitled HP ART 5.10 prebuilt content from the HP Software My software 
updates site (requires current ART SAID number) and view the published content. 

http://support.openview.hp.com/selfsolve/manuals�
http://h20546.www2.hp.com/main/�
http://h20546.www2.hp.com/main/�
http://h20546.www2.hp.com/main/news.cfm?go=ART�
https://passport2.hp.com/hppcf/login.do?hpappid=PDAPI_USB_PRO2�
https://passport2.hp.com/hppcf/login.do?hpappid=PDAPI_USB_PRO2�
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4) Determine your HP ART 5.10 testing method. 
• The HP ART 5.10 Author Toolkit and the HP ART 4.40 Author Toolkit cannot be installed 

on the same client (machine) at the same time. 

• Option 1: Secure an additional machine to download and test HP ART 5.10. 
• Option 2: Once your HP ART 4.40 components are backed up in a separate location, 

uninstall HP ART 4.40 and install HP ART 5.10 and perform testing. 

• You can maintain both HP ART 4.40 and HP ART 5.10 keys for a period of 6 months for 
testing purposes. 

• Download and install HP ART 5.10. You can download HP ART 5.10 and request a new 
5.10 license key from the HP Software My software updates site (requires current ART 
SAID number). 

5) Determine your HP ART 5.10 conversion scenario. 
Due to the flexibility of the HP ART offering, you have several scenarios for using the HP ART authoring 
tool and/or prebuilt content. To best address these, you have options regarding your content and 
template conversion. Determine the best fit for your conversion from the scenarios listed below and 
follow the detailed instructions for each scenario included in this document.  

If you using the ART prebuilt out of the box, you can download the new 5.10 content files from 
the HP Software My software updates site (requires current ART SAID number) and deploy the 
published content. If applicable, also download the HP ART 5.10 DevKit for use in future 
customization or creation efforts. Otherwise, use one of the scenarios described below.  

NOTE: If you are using the prebuilt content with minor template changes, see Scenario B: HP ART 
5.10 Template and HPART-Rounded Skin with Customizations below. 

NOTE: The detailed instructions provided in this guide assume you used common practices for 
creating your template, skin, courses, and website. The process might vary if you used alternative 
methods.  

Use the following information to determine which scenario to use: 

• Scenario A: 

• 

HP ART 5.10 Template and HPART-Rounded Skin  

You have 
• You would like to upgrade your content to ART 5.10, using the new and improved 

default HP ART 5.10 template, skin, and website. 

customized your ART 4.40 content. 

• Scenario B: HP ART 5.10 Template and HPART-Rounded Skin with 
Customizations/Updates 

• You made branding and/or minor changes to your 4.40 template and/or skin. The 
recommend path is to use the new HP ART 5.10 template and update it with the 
branding and other elements used in your 4.40 template. 

https://passport2.hp.com/hppcf/login.do?hpappid=PDAPI_USB_PRO2�
https://passport2.hp.com/hppcf/login.do?hpappid=PDAPI_USB_PRO2�
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• This scenario works well if you have documented your 4.40 templates updates. In this 
scenario, you take advantage of the new template and skin changes and are able to 
easily create the improved ART 5.10 website. 

• Because some changes are controlled in the template and some in the skin, you may 
need to make a few updates to your skin. 

• Scenario C: 

• 

Convert Your Custom 4.40 Template and Skin 

You have made 

• In this scenario, after you convert your customized 4.40 template, you will need to 
make adjustments to the 5.10 skin and template due to some conversion variances. 
Additional template changes are included to allow you to use the HP ART 5.10 
website format. 

major customizations to your ART 4.40 template and/or skin and 
would like to upgrade your content to ART 5.10 and convert your customized ART 
4.40 template. 

6) Download the HP ART 5.10 Content Conversion Kit. 
Download the HP ART 4.40 to 5.10 Conversion Kit. This file includes resources needed to 
complete some of the conversion activities. 

  

http://art.hpsweducationlabs.com/ART/HPART4-40to5-10ConversionKit.zip�
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Scenario A: HP ART 5.10 Template and HPART-Rounded 
Skin 
Follow these steps if you have customized your ART 4.40 content and would like to upgrade your 
content to ART 5.10 and use the new and improved HP ART 5.10 template, skin and website.  

It is important to read through this entire section before starting the upgrade process. If you encounter 
difficulties during the process, you can contact the Global Support Desk by logging into SSO 
(Software Support Offering - http://support.openview.hp.com) to enter a case. You must have a 
valid SAID (Service Agreement ID) for ART and you will need to enter it. There are Support 
Engineers in Global Support who specialize in ART and will handle your case. 

Step 1: Create ART 5.10 Project Folder and Backup Files  
It is very important to back up your original ART 4.40 source files. Once a file is opened in ART 
5.10, you cannot open it in ART 4.40. 

1. Create a new ART 5.10 project folder. 
2. Copy your ART 4.40 source files to the new ART 5.10 project folder. 
3. Back up your original ART 4.40 files in secondary location.   

Step 2: Install ART 5.10 
Refer to the README document located in the HP ART 5.10 DevKit for detailed installation 
instructions. 

1. Uninstall ART 4.40 using the standard Control Panel uninstall process. 
2. Restart your system. 
3. Install ART 5.10. 

Step 3: Update the ART Tour 
In ART 5.10, the ART Tour is updated to match the new look and feel of the ART 5.10 content and 
is a stand-alone module. To view the new ART Tour, see the Before You Begin section in this guide 
for instructions on viewing a new sample course on the HP ART HP Software Education Services 
webpage.  

If you used the ART Tour in 4.40 and would like to include the new ART Tour in your courses, 
follow the steps below: 

1. Navigate to your source folder in your ART 5.10 project folder. 
2. Delete the art_tour.udc recording file from the recordings folder in 01_Introduction. 
3. Copy the art5_00_art_tour folder from the HP ART 4.40 to 5.10 Conversion Kit to your 

source folder with the other module folders. 
4. Open the art5_00_art_tour.ulc file. 

a. Select File>Properties. 

http://support.openview.hp.com/�
http://h20546.www2.hp.com/main/news.cfm?go=ART�
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b. Update the PORTFOLIO and Product fields to match your ART product. 
c. Save and close the file. 

5. Open the Introduction (.ulc) course file.  

a. A confirmation message that the course was upgraded displays. Click OK. 

 

b. Delete the ART Tour course page. 
c. Select Manage>Resources. 
d. Remove the ART Tour resource. 
e. Save and close the file. 

Now, when you create your ART 5.10 website, the ART Tour module will automatically display 
within the Select a Module section with the other modules in your course. 

Step 4: Update the Introduction Recording (.udc) File Properties 
The initial launch page of the ART 4.40 website was controlled using the Property fields of the 
Introduction course module. For this reason, the Module property field was left blank within the 
Introduction course (.ulc) file, as well as all recording (.udc) files for the module.  

The ART 5.10 website has new product and course launch pages controlled within the website 
(.uws) file. The Introduction module has been moved to the menu navigation of the website page, 
at the same level as all other modules in the course. 
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To deploy your content using the HP ART 5.10 website, you need to add the module name in the 
Property window of each recording file within the Introduction module.   

Perform the following tasks for each recording within the Introduction module: 

1. Open the recording (.udc) file. 
2. You see a confirmation message that the file was upgraded. Click OK. 
3. Select File>Properties. 
4. Select the Properties option on the left. 
5. Type Introduction in the Module field. 

 
 
NOTE: The PORTFOLIO and Product fields should be filled out. Do not modify these fields. 
 

6. Save and close the file. 
7. Repeat the process for all recording (.udc) files within the Introduction module.  

 

Step 5: Upgrade all Courses (.ulc) Files from Version 4.40 to Version 5.10 
When upgrading each course (.ulc) file from 4.40 to 5.10 you open the file, update embedded 
simulations, update the Properties, and update image properties.  

Follow the steps below for each course (.ulc) file in your ART 5.10 Project source folder: 

1. Open the course (.ulc) file. 
2. A confirmation message that the course was upgraded displays. Click OK. 
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3. Update embedded recordings: 

a. Navigate to Manage>Embedded Simulations… 
b. All embedded recordings display as Not Found. Use the Browse button to point the 

Local Source File Location: field to the folder containing the recording files 
of the selected module. 

 
 

c. All simulations display as Not Current. Click the checkbox to select all recordings and 
click the Update button. 

 
 

d. The upgrade confirmation message displays. Click OK. 
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e. ART automatically publishes and links each recording. 

 
 

f. As each recording is upgraded, its status updates to Current.  

 
g. When the process ends for all embedded simulations, click the OK button to exit the 

window. 

4. Update the Properties to support the new website design. 

To support the new ART 5.10 website design, update the course (.ulc) property fields as 
described below: 

a. Navigate to File>Properties. 
b. Select the Properties option on the left. 
c. Update the Property field values to match the table below or use the ART5-Properties 

document in the HP ART 4.40 to 5.10 Content Conversion Kit to copy/paste the text.  
Make sure that text included in brackets, <text>, and shaded is updated, generally 
with the product name. 

NOTE: Use only one description from the table below. Select the description that best fits 
the module. The wording is slightly different based on the module name and if there are 
recordings in the module. 

IMPORTANT: All fields not listed in the table below should be blank. 

Module Property Information populated in course (.ulc) 
properties 

PORTFOLIO Do not modify. Leave current value. 
Product Do not modify. Leave current value. 
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Module Property Information populated in course (.ulc) 
properties 

Build_Num The build date (yyyy.mm) that course is being 
upgraded. 

Description  
(for ART Tour) 

In this module, you learn how to navigate HP 
Adoption Readiness Tool (ART) courses. Click the 
Launch Module button below to begin. 

Select the description below that best fits your module. 
Description  
(for Introduction with no 
recordings) 

This module provides an introduction to <name of 
product>. Click the Launch Module button below to 
view the eLearning course module, or quickly master 
a specific task by launching a simulation or job aid. 

Description  
(if module name is a 
noun) 

This module provides an introduction to <name of 
product>. Click the Launch Module button below to 
view the eLearning course module. 

Description 
(noun, and no 
recordings) 

In this module, you will learn about <name of 
module>. Click the Launch Module button below to 
view the eLearning course module, or quickly master 
a specific task by launching a simulation or job aid. 

Description  
(If module name is a 
verb) 

In this module, you learn about <name of module>. 
Click the Launch Module button below to begin. 

Description 
(verb, and no 
recordings) 

In this module, you learn how to <name of 
module>. Click the Launch Module button below to 
view the eLearning course module, or quickly master 
a specific task by launching a simulation or job aid. 

Description 
(Verb, and no 
Recordings) 

In this module, you learn how to <name of 
module>. Click the Launch Module button below to 
begin. 

Module <name of module>   
All files in a module (both .udc and .ulc) must have 
the exact same module name. The Introduction 
module should have “Introduction” as the module 
name. 

 

5. Create a Temp Publish folder outside of your project source file. Publish the course to the 
temp folder and review.  

All images that are placed within the content area of the stencil are not controlled within 
the template. For this reason, review and update the images within the content pane, if 
desired. To update your current hotspot image with the new branded image, use the 
image included in the HP ART 4.40 to 5.10 Course Conversion Kit.   
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6. In some cases, the Zoom button is enabled in published mode on images placed within 
the Content pane. To remove the zoom icon, right-click on the image in edit mode and 
select Edit Image. 

 

7. Within the Edit Image window, select the Use template zoom options checkbox to remove 
the zoom. 

 

 

8. Repeat the tasks in this procedure for all course (.ulc) files in your project. 
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Step 6: Create Your ART 5.10 Website 
To deploy your content using the ART 5.10 website, the last step is to create the website. Due to 
the extensive changes in the website structure, you should create a new website (.uws) file, rather 
than attempt to edit the ART 4.40 website file.  

Below are the high-level steps to create a website. Refer to the Creating the HP ART 5.10 Website 
guide for detailed information on this process. 

1. Prepare your ART files in the proper hierarchy. 
2. Create a new website .uws file. 
3. Import the source content files. 
4. Organize the website. 
5. Create the launch pages. 
6. Organize the website with the new launch pages 
7. Batch publish the source files. 
8. Publish the website. 
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Scenario B: 

Follow these steps if you have made branding and/or minor changes to your 4.40 template 
and/or skin. You will use the new HP ART 5.10 template and update it with the branding and 
other elements used in your 4.40 template. Even if you have made several updates to your 4.40 
template, but they are well documented, this path might be more efficient due to the embedded 
updates to the 5.10 template and skin. In this scenario, you take advantage of the new template 
and skin changes and are able to easily create the improved ART 5.10 website. 

HP ART 5.10 Template and HPART-Rounded 
Skin with Customizations 

It is important to read through this entire section before starting the upgrade process. If you 
encounter difficulties during the process, you can contact the Global Support Desk by logging into 
SSO (Software Support Offering - http://support.openview.hp.com) to enter a case. You must 
have a valid SAID (Service Agreement ID) for ART and you will need to enter it. There are Support 
Engineers in Global Support who specialize in ART and will handle your case. 

Step 1: Create the ART 5.10 Project Folder and Backup Files  
It is very important to back up your original ART 4.40 source files. Once a file is opened in ART 
5.10, you cannot open it in ART 4.40. 

1. Create a new ART 5.10 project folder. 
2. Copy your ART 4.40 source files to the new ART 5.10 project folder. 
3. Back up your original ART 4.40 files in secondary location.   

Step 2: Install ART 5.10 
Refer to the README document located in the HP ART 5.10 DevKit for detailed installation 
instructions. 

1. Uninstall ART 4.40 using the standard Control Panel uninstall process. 
2. Restart your system. 
3. Install ART 5.10. 

Step 3: Update the HPART-Rounded Skin 
Because some changes are controlled in the skin, if you would like to change the Next and Back 
button, simulation buttons, or hotspot window header colors, you need to update the skin. 

1. Open your template. 
2. Ensure the HPART-Rounded Skin is selected. Navigate to Publications>Default Publications 

Settings>Course>Course User Interface Settings. The HPART-Rounded Skin should be the 
selected skin. 

3. To update the color of the Next and Back Navigation buttons, navigate to the skin.css 
file. 

http://support.openview.hp.com/�
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a. Using the Windows Start Menu, navigate to the HP Adoption Readiness Tool Resources. 
b. Navigate to the skins>Course>custom>HPART-Rounded>skin folder. 
c. Open the skin.css file with an editor such as Notepad++. 
d. Locate div#nextBtn and div#backBtn  in the nav/aux section and update the 

hexadecimal strings for the background the to specify the color. For example, the hex 
value for HP blue is #0197D6, white is #FFFFFF, and black is #000000. 

 

 

 

 

4. To update the color of the simulation launch buttons on the course page, navigate to the 
content.css file. 

 

a. Using the Windows Start Menu, navigate to the HP Adoption Readiness Tool 
Resources. 

b. Navigate to the skins>Course>custom>HPART-Rounded>skin folder. 
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c. Open the content.css file with an editor such as Notepad++. 
d. Locate div.choice input[type=button] in the Assessment section and 

update the hexadecimal strings for the background the to specify the color. For 
example, the hex value for HP blue is #0197D6, white is #FFFFFF, and black is 
#000000. 

 
 

5. To update the color of the hotspot window header, navigate to the content.css file. 

a. Using the Windows Start Menu, navigate to the HP Adoption Readiness Tool 
Resources. 

b. Navigate to the skins>Course>custom>HPART-Rounded>skin folder. 
c. Open the content.css file with an editor such as Notepad++. 
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d. Locate div.titleBarPopup in the Content section and update the hexadecimal 
strings for the background to specify the color. For example, the hex value for HP blue 
is #0197D6, white is #FFFFFF, and black is #000000. 

 

6. Save and close the content.css file. 
7. Publish your test course to review skin updates. 

 

Step 4: Update the ART Tour 
In ART 5.10, the ART Tour is updated to match the new look and feel of the ART 5.10 content and 
is a stand-alone module. To view the new ART Tour, see the Before You Begin section in this guide 
for instructions on viewing a new sample course on the HP ART HP Software Education Services 
webpage.  

If you used the ART Tour in 4.40 and would like to include the new ART Tour in your courses, 
follow the steps below: 

1. Navigate to your source folder in your ART 5.10 project folder. 
2. Delete the art_tour.udc recording file from the recordings folder in 01_Introduction. 

http://h20546.www2.hp.com/main/news.cfm?go=ART�
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3. Copy the art5_00_art_tour folder from the HP ART 4.40 to 5.10 Conversion to your 
source folder with the other module folders. 

a. Open the art5_00_art_tour.ulc file. 
b. Select File>Properties. 
c. Update the PORTFOLIO and Product fields to match your ART product. 
d. Save and close the file. 

4. Open the Introduction (.ulc) course file. 

a. A confirmation message that the course was upgraded displays. Click OK. 

 

b. Delete the ART Tour course page. 
c. Select Manage>Resources. 
d. Remove the ART Tour resource. 
e. Save and close the file. 

Now, when you create your ART 5.10 website, the ART Tour module will automatically display 
within the Select a Module section, with the other modules in your course. 

Step 5: Update the Introduction Recording (.udc) File Properties 
The initial launch page of the ART 4.40 website was controlled using the Property fields of the 
Introduction course module. For this reason, the Module property field was left blank within the 
Introduction course (.ulc) file, as well as all recording (.udc) files for the module.  

The ART 5.10 website has new product and course launch pages controlled within the website 
(.uws) file. The Introduction module has been moved to the menu navigation of the website page, 
at the same level as all other modules in the course. 
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To deploy your content using the HP ART 5.10 website, you need to add the module name to the 
Property window of each recording file within the Introduction module.   

Perform the following tasks for each recording within the Introduction module: 

1. Open the recording (.udc) file. 
2. You see a confirmation message that the file was upgraded. Click OK. 
3. Select File>Properties. 
4. Select the Properties option on the left. 
5. Type Introduction in the Module field. 

. 

 
NOTE: The PORTFOLIO and Product fields should already be filled in. Do not modify 
these fields. 

6. Save and close the file. 
7. Repeat process for all recording (.udc) files within the Introduction module.  
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Step 6: Update the Template to Support 4.40 Customizations 
For testing purposes, locate a single module or small course to use for template and skin update 
tests prior to upgrading all your courses. Since many of the template changes require publishing 
to review, it is easier to work with a small amount of content first. 

1. Create a Temp Publish folder outside of your project source folder.  
2. Open your small test course and publish the course to the Temp Publish folder. 
3. Review the published course that now uses the 5.10 template.  
4. Based on your 4.40 template and skin customizations, document any additional updates 

needed to the 5.10 template and skin.  

If you documented your 4.40 template and/or skin customizations when you implemented 
ART, start with that list.  However, there might be additional updates required due to the 
conversion. Below is a list of common customizations. It not an inclusive list but includes 
some of the common customizations by customers that may need to be adjusted. 

Common simulation updates: 
• Logo 
• Course header text 
• Assessment settings 
• Document header 
• Document footer 
• Text styles 

Common simulation updates: 
• Review the simulation skin. To make template changes to the simulations, use the 

Default Simulation Skin. 

Step 7: Upgrade All Courses from Version 4.40 to Version 5.10 
Follow the steps below for each course (.ulc) file in your ART 5.10 Project source folder: 

1. Open the course (.ulc) file. 
2. You see a confirmation message that the course was upgraded. Click the OK button. 

 

3. Update embedding recordings: 

a. Navigate to Manage>Embedded Simulations... 
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b. All embedded recordings display as Not Found. Point the Local Source File 
Location: field to the folder containing the recording files of the selected module. 

 
 

c. All simulations display as Not Current. Click the checkbox to select all recordings and 
click the Update button. 

 
 

d. The upgrade confirmation message displays. Click OK. 
 

 
 

e. ART automatically publishes and links the recording. 
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f. As each recording is upgraded, its status display as Current.  

 
g. When the process ends for all embedded simulations, click the OK button to exit the 

window. 

4. Update the properties to support the new website design. 

To support the new ART 5.10 website design, update the course (.ulc) property fields as 
described below: 

a. Navigate to File>Properties. 
b. Select the Properties option on the left. 
c. Update the Property field values to match the table below or use the ART5-Properties 

document in the HP ART 4.40 to 5.10 Content Conversion Kit to copy/paste the text.  
Make sure that text included in brackets, <text>, and shaded is updated, generally 
with the product name. 

NOTE: Use only one description from the table below. Select the description that best fits 
the module. The wording is slightly different based on the module name and if there are 
recordings in the module. 

IMPORTANT: All fields not listed in the table below should be blank. 

Module Property Information populated in course (.ulc) 
properties 

PORTFOLIO Do not modify. Leave current value. 
Product Do not modify. Leave current value. 
Build_Num The build date (yyyy.mm) that course is being 

upgraded. 
Description  
(for ART Tour) 

In this module, you learn how to navigate HP 
Adoption Readiness Tool (ART) courses. Click the 
Launch Module button below to begin. 

Select the description below that best fits your module. 
Description  
(for Introduction with no 
recordings) 

This module provides an introduction to <name of 
product>. Click the Launch Module button below to 
view the eLearning course module, or quickly master 
a specific task by launching a simulation or job aid. 

Description  
(if module name is a 
noun) 

This module provides an introduction to <name of 
product>. Click the Launch Module button below to 
view the eLearning course module. 



 HP ART 4.40 to 5.10 Conversion Guide 

 

As of August 31, 2013                                                                                                            Page 21 of 63 
 Copyright 2013 Hewlett-Packard Development Company, L.P. 

 

Module Property Information populated in course (.ulc) 
properties 

Description 
(noun, and no 
recordings) 

In this module, you learn about <name of module>. 
Click the Launch Module button below to view the 
eLearning course module, or quickly master a 
specific task by launching a simulation or job aid. 

Description  
(If module name is a 
verb) 

In this module, you learn about <name of module>. 
Click the Launch Module button below to begin. 

Description 
(verb, and no 
recordings) 

In this module, you learn how to <name of 
module>. Click the Launch Module button below to 
view the eLearning course module, or quickly master 
a specific task by launching a simulation or job aid. 

Description  
(for Introduction with no 
recordings) 

In this module, you learn how to <name of 
module>. Click the Launch Module button below to 
begin. 

Module <name of module>   
All files in a module (both .udc and .ulc) must have 
the exact same module name. The Introduction 
module should have “Introduction” as the module 
name. 

 

5. Create a Temp Publish folder outside of your project source file. Publish the course to the 
temp folder and review.  

All images that are placed within the content area of the stencil are not controlled within 
the template. For this reason, review and update the images within the content pane, if 
desired. To update your current hotspot image with the new branded image, use the 
image included in the HP ART 4.40 to 5.10 Course Conversion Kit.   
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6. In some cases, the Zoom button is enabled in published mode on images placed within 
the Content pane. To remove the zoom icon, right-click on the image in edit mode and 
select Edit Image. 

 

Within the Edit Image window, select the Use template zoom options checkbox to remove the zoom. 
 

 

7. Repeat the tasks in this procedure for all course (.ulc) files in your project. 

Step 8: Create Your ART 5.10 Website 
To deploy your content using the ART 5.10 website, the last step is to create the website. Due to 
the extensive changes in the website structure, you should create a new website (.uws) file, rather 
than attempt to edit the ART 4.40 website file.  

Below are the high-level steps to create a website. Refer to the Creating the HP ART 5.10 Website 
guide for detailed information on this process. 

1. Prepare your ART files in the proper hierarchy. 
2. Create a new website .uws file. 
3. Import the source content files. 
4. Organize the website. 
5. Create the launch pages. 
6. Organize the website with the new launch pages 



 HP ART 4.40 to 5.10 Conversion Guide 

 

As of August 31, 2013                                                                                                            Page 23 of 63 
 Copyright 2013 Hewlett-Packard Development Company, L.P. 

 

7. Batch publish the source files. 
8. Publish the website. 

  



 HP ART 4.40 to 5.10 Conversion Guide 

 

Page 24 of 63                                                                                                             As of August 31, 2013 
 Copyright 2013 Hewlett-Packard Development Company, L.P. 

 

Scenario C: 
Follow these steps if you have made extensive customizations to your ART 4.40 template and/or 
skin and would like to upgrade your content to ART 5.10, converting your customized ART 4.40 
template. In this scenario, you need to create a new ART skin and modify your template to use the 
new HP ART 5.10 website structure. If you have minor changes or have documented the changes 
that you made to your 4.40 template, you may want to consider using Scenario B: 

Convert Your Custom 4.40 Template and Skin  

It is important to read through this entire section before starting the upgrade process. If you 
encounter difficulties during the process, you can contact the Global Support Desk by logging into 
SSO (Software Support Offering - 

HP ART 5.10 
Template and HPART-Rounded Skin with Customizations. You should review both scenarios to 
determine which one is the most efficient for your situation. 

http://support.openview.hp.com) to enter a case. You must 
have a valid SAID (Service Agreement ID) for ART and you will need to enter it. There are Support 
Engineers in Global Support who specialize in ART and will handle your case. 

Step 1: Create the ART 5.10 Project Folder and Backup Files  
It is very important to back up your original ART 4.40 source files. Once a file is opened in ART 
5.10, you cannot open it in ART 4.40. 

1. Create a new ART 5.10 project folder. 
2. Copy your ART 4.40 source files to the new ART 5.10 project folder. 
3. Back up your original ART 4.40 files in secondary location.   

Step 2: Install ART 5.10 
Refer to the README document located in the HP ART 5.10 DevKit for detailed installation 
instructions. 

1. Uninstall ART 4.40 using the standard Control Panel uninstall process. 
2. Restart your system. 
3. Install ART 5.10. 

Step 3: Import Your Customized ART 4.40 Template 
To use your ART 4.40 template as a starting point, you must first import and convert it to ART 
5.10.  

1. Launch the ART Editor. 
2. Select File>Manage Local Templates. 

http://support.openview.hp.com/�
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3. Within the Manage Local Templates window, click Import. 

 
4. Navigate to your ART 4.40 template and click Open. 
5. An upgrade confirmation message displays. Click OK. 
6. In most cases, your custom template has the same GUID as the HP ART 5.10 template. 

Click Yes to replace the default HP ART template with your customized template. 
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NOTE: There is no risk overwriting this file. A backup of the default ART 5.10 template is 
located in the Custom>Templates folder of the ART 5.10 Author DevKit installation 
package. 

7. Your custom template is now available and listed in the Manage Local Templates window. 
Within the Manage Local Templates window, click the Close button. 

Step 4: Remove the Default HP ART Template from Your Installation Folder 
When installing ART 5.10, the HP ART 5.10 template is automatically installed as part of the 
overall installation process. If you are not using the new HP ART 5.10 template, you need to 
remove the file from your installation folder. 

1. Navigate to the HP Adoption Readiness Tool installation folder. The default installation 
location is shown below: 
 

 
 

2. Navigate to the Client>appdata>Templates folder. 
 

 
 

3. Delete the ART5_HP ART Template_1-0.udt file.  

NOTE: There is no risk removing this file from the installation folder. A backup of the 
default ART 5.10 template is located in the Custom>Templates folder of the ART 5.10 
Author DevKit installation package. 
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Step 5: Update the Audio Option in the Upgraded 5.10 Template 
The Audio Control bar is enabled in the upgraded template. In most cases, you will want to turn 
this off so it only displays if you are using audio. To turn this setting off, follow the steps below: 

1. Launch the ART Editor. 
2. Select File>Open>Template. 
3. Navigate to Publications>Default Publications Settings>Course>Course User Interface 

Settings>General section. 
4. Select the Hide audio bar when audio is not present checkbox.  

 

5. Save and close the template. 

Step 6: Locate the Test Course to Support Upgrade Preparation and Testing 
For testing purposes, it is recommended that you locate a single module or small course to use for 
template and skin update tests prior to upgrading all your courses. Since many of the changes 
require publishing to review, it is easier to work with a small amount of content first. 

1. Create a Temp Publish folder outside of your project source file.  
2. Open your small test course and publish the course to the Temp Publish folder. 
3. Review your published course and determine if additional updates to the template and 

skin are needed. 

NOTE: There are a few documented skin variances when using a converted 4.40 template 
and skin. Instructions to update these are included below in Step 8: Update the Skin to 
Support Conversion Variances. 

Based on your 4.40 template and skin customizations, document any additional updates 
needed to the 5.10 template and skin.  
 
If you documented your 4.40 template and/or skin customizations when you implemented 
ART, start with that list.  However, there might be additional updates required due to the 
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conversion. Below is a list of common customizations. It not an inclusive list but includes 
some of the common customizations by customers that may need to be adjusted. 

Common simulation updates: 
• Logo 
• Course header text 
• Assessment settings 
• Document header 
• Document footer 
• Text styles 

Common simulation updates: 
• Review the simulation skin. To make template changes to the simulations, use the 

Default Simulation Skin. 

Step 7: Create New Skin 
Before you make any updates to the skin, you should create a custom skin. Creating a custom skin 
allows you to easily share skin customizations with others in your organization. 

1. Open your template. 
2. Navigate to Publications>Default Publications Settings>Course>Course User Interface 

Settings and note the selected skin. If you are using the old ART 4.40 HP ART skin, select 
a different skin from the list.  
 

 
 

3. Save and close your template. 
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4. Using the Windows Start menu, navigate to the HP Adoption Readiness Tool Resources. 
 

 

 

5. Navigate to the skins>Course>uperform folder. 
 

 
 

6. Locate the skin type that you want to customize. In this example, the out-of-the-box Square 
skin is selected. 
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7. Right-click the skin folder and select Copy. 

 
 

8. Navigate to the skins>Course>Custom folder and paste the skin folder. 
9. Give the skin folder a unique name. 

 
10. Open your template. 
11. Navigate to Publications>Default Publications Settings>Course>Course User Interface 

Settings and select your new custom skin from the drop-down menu. 
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Your skin has been added. You are ready to perform your updates. 

Step 8: Update the Skin to Support Conversion Variances 
The following describes skin variances that might occur when converting a 4.40 template and 
skin. Review the list below and make the desired adjustments. You should periodically save .css 
file changes and test the changes by republishing and previewing your test course. 

• Adjust the simulation launch button size. 

By default, the size of the Show Me and Try Me buttons will adjust in size depending on 
how much text is placed in the content block. The HP standard is to have all the buttons 
remain the same size on all pages. 

Example: Simulation Launch Buttons - Variable 
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Example: Simulation Launch Buttons – Fixed  

 

Example: Simulation Launch Buttons – Fixed  

 

To adjust the size if the navigation buttons to the HP ART standard, follow the steps 
in Appendix A in this document.  

• Remove the simulation and assessment page borders. 

By default, the simulation and assessment pages include a border and additional shading. 
To remove the borders and shading, you must update your course skin.  
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Example: Course page with borders and shading 

 
 

Example: Course page without borders 
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Example: Assessment page with borders and shading 

 
 

Example: Assessment page without borders and shading 

 

 

To change the border and shading, follow the steps in Appendix B in this document.  

• Change the course header to a solid color. 

In the Square and Rounded skins, the top banner on the course pages has a transparent 
opacity to the color. It can be changed to a solid color if desired. 

Example: Course page without solid banner 
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Example: Course page with solid banner 

 
 

To change to a solid border and shading, follow the steps in Appendix C in this document.  

• Adjust the size of the Back button to match the Next button. 

When you upgrade your custom 4.40 template to ART 5.10, the Back navigation button 
does not pick up the default skin changes. This results in the Back button having slightly 
smaller font than the Next button. Follow the steps below to modify the skin to make the 
text on the Back and Next button equal in size. 

 

 

Once the course is published, the text is the same size. 

 

To modify the skin to make the text on the Back and Next button equal in size, follow the 
steps in Appendix D in this document. 

• Update the Course Menu icons. 

When you upgrade your ART 4.40 template to ART 5.10, you can add the ART 5.10 
menu icons to your custom skin. 

Example: Menu before adding 5.10 menu icons 

 
 
Example: Menu after adding 5.10 Menu icons 
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To update the skin to include the 5.10 menu icons, follow the steps in Appendix E in this 
document. 

Step 9: Update the Template to Adjust Course and Simulation Launch Pages 
When the ART 4.40 template is upgraded to ART 5.10, the text on the course and simulation 
launch pages defaults to blue text. Depending on your branding colors, you may wish to modify 
this color to match your environment. 

To update the template to adjust course and simulation launch pages, follow the steps 
in Appendix F in this document. 

Step 10: Update the Template to Change Hotspot Images 
To update the hotspot icons in your course, you can replace the icons in the template with your 
desired color. A variety of icons are provided in the HP ART 4.40 to ART 5.10 Conversion Kit. If 
you update the hotspot image with another image of the same size and name, your courses will 
automatically pick up the new hotspot images as soon as the course is opened with the updated 
template. 
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1. In your template, select the General tab. 
2. Select Hotspot Images. 
3. Select the first hotspot image from the list. 
4. Note the image width and height to ensure the same size image is replaced. 
5. Click the Update button. 
6. Navigate to the matching hotspot image in your HP ART 4.40 to 5.10 Conversion Kit. 

 

 
7. Click Open to replace the image. 
8. Use the Add button to add additional hotspot images.  

Step 11: Update the Template to Support the ART 5.10 Website Structure 
If you have just upgraded your customized ART 4.40 template and would like to take advantage 
of the new ART 5.1 website structure, make the following template changes: 

1. Open the template. 
2. Under the General tab, navigate to the Data Files item. 
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3. You need to update the following files in your template: 

 

To update each file, select the file in the template, click the Update button, and navigate to 
the matching file in your HP ART 5.10 Conversion Kit. 

 

 
4. Next, you need to add the following image assets to your template to support the new 

structure: 
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• hpa_logo_bp_png − This is the logo that is placed in the upper left of the website. 
To use your company logo, rename your logo to the exact same file name before 
adding to the template. The logo size should be 220x74 pixels. 

• hpa_tagline-bg − This is the HP Adoption Readiness Tool (ART) watermark image.  
Do not alter this image prior to adding to the website. 

To add these assets to your template: 

a. From the General tab, navigate to the Data Files section. 
b. For each of the two required assets: 

i. Click the Add button. 
ii. Navigate to the matching asset in your conversion kit. 

 
 

c. Save the template. 

Your template is now ready to create the HP ART 5.10 website. Instructions on how to create the 
new HP ART 5.10 website are included in Step 13. 
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Step 12: Update the ART Tour 
In ART 5.10, the ART Tour is updated to match the new look and feel of the ART 5.10 content and 
is a stand-alone module. To view the new ART Tour, see the Before You Begin section in this guide 
for instructions on viewing a new sample course on the HP ART HP Software Education Services 
webpage.  

If you used the ART Tour in 4.40 and would like to include the new ART Tour in your courses, 
follow the steps below: 

5. Navigate to your source folder in your ART 5.10 project folder. 
6. Delete the art_tour.udc recording file from the recordings folder in 01_Introduction. 
7. Copy the art5_00_art_tour folder from the HP ART 4.40 to 5.10 Conversion to your 

source folder with the other module folders. 

d. Open the art5_00_art_tour.ulc file. 
e. Select File>Properties. 
f. Update the PORTFOLIO and Product fields to match your ART product. 
g. Save and close the file. 

8. Open the Introduction (.ulc) course file. 

h. A confirmation message that the course was upgraded displays. Click OK. 

 

i. Delete the ART Tour course page. 
j. Select Manage>Resources. 
k. Remove the ART Tour resource. 
l. Save and close the file. 

Now, when you create your ART 5.10 website, the ART Tour module will automatically display 
within the Select a Module section, with the other modules in your course. 

Step 13: Update the Introduction Recording (.udc) File Properties 
The initial launch page of the ART 4.40 website was controlled using the Property fields of the 
Introduction course module. For this reason, the Module property field was left blank within the 
Introduction course (.ulc) file, as well as all recording (.udc) files for the module.  

http://h20546.www2.hp.com/main/news.cfm?go=ART�
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The ART 5.10 website has new product and course launch pages controlled within the website 
(.uws) file. The Introduction module has been moved to the menu navigation of the website page, 
at the same level as all other modules in the course. 

   

To deploy your content using the HP ART 5.10 website, you need to add the module name to the 
Property window of each recording file within the Introduction module.   

Perform the following tasks for each recording within the Introduction module: 

1. Open the recording (.udc) file. 
2. You see a confirmation message that the file was upgraded. Click OK. 
3. Select File>Properties. 
4. Select the Properties option on the left. 
5. Type Introduction in the Module field. 

. 

 
NOTE: The PORTFOLIO and Product fields should already be filled in. Do not modify 
these fields. 
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6. Save and close the file. 
7. Repeat process for all recording (.udc) files within the Introduction module.  

Step 14: Upgrade All Courses   
Once you have completed and reviewed your skin and template changes with your test course, 
you are ready to update your remaining courses. Follow the steps below for each course (.ulc) file 
in your ART 5.10 project source folder: 

1. Open the course (.ulc) file.  
2. A confirmation message that the course was upgraded displays. Click the OK button. 

 

3. Update embedding recordings: 

a. Navigate to Manage>Embedded Simulations. 
b. All embedded recordings display as Not Found. Point the Local Source File 

Location: field to the Recordings folder of the selected module.  

 
 

c. All simulations now display as Not Current. Click the checkbox to select all recordings 
and click the Update button. 
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d. The upgrade confirmation message displays. Click OK. 

 
 

e. ART automatically publishes and links the recording. 

 
 

f. As each recording is upgraded, its status displays as Current.  

 
 

g. When the process ends for all embedded simulations, click the Ok button to exit the 
window. 

4. If you would like to take advantage of the new ART 5.1 website structure and performed 
the tasks in Step 11, update the course (.ulc) property fields as described below: 

a. Navigate to File>Properties. 
b. Select the Properties option on the left. 
c. Update the Property field values to match the table below or use the ART5-Properties 

document in the HP ART 4.40 to 5.10 Content Conversion Kit to copy/paste the text.  

Ensure that text included in brackets, <text>, and shaded is updated, generally with the 
product name. 
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NOTE: Use only one description from the table below. Select the description that best fits 
the module. The wording is slightly different based on the module name and if there are 
recordings in the module. 

IMPORTANT: All fields not listed in the table below should be blank. 

Module Property Information populated in course (.ulc) 
properties 

PORTFOLIO Do not modify. Leave current value. 
Product Do not modify. Leave current value. 
Build_Num The build date (yyyy.mm) that course is being 

upgraded. 
Description  
(for ART Tour) 

In this module, you learn how to navigate HP 
Adoption Readiness Tool (ART) courses. Click the 
Launch Module button below to begin. 

Select the description below that best fits your module. 
Description  
(for Introduction 
module) 

This module provides an introduction to <name of 
product>. Click the Launch Module button below to 
view the eLearning course module, or quickly master 
a specific task by launching a simulation or job aid. 

Description  
(for Introduction with no 
recordings) 

This module provides an introduction to <name of 
product>. Click the Launch Module button below to 
view the eLearning course module. 

Description  
(if module name is a 
noun) 

In this module, you learn about <name of module>. 
Click the Launch Module button below to view the 
eLearning course module, or quickly master a 
specific task by launching a simulation or job aid. 

Description 
(noun, and no 
recordings) 

In this module, you learn about <name of module>. 
Click the Launch Module button below to begin. 

Description  
(If module name is a 
verb) 

In this module, you learn how to <name of 
module>. Click the Launch Module button below to 
view the eLearning course module, or quickly master 
a specific task by launching a simulation or job aid. 

Description 
(verb, and no 
recordings) 

In this module, you learn how to <name of 
module>. Click the Launch Module button below to 
begin. 

Module <name of module>   
All files in a module (both .udc and .ulc) must have 
the exact same module name. The Introduction 
module should have “Introduction” as the module 
name. 

 

5. Publish the course and review output.  
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6. Update the hotspot image zoom option (optional). 

Images placed within the content area of the stencil are not controlled within the template. 
For this reason, you should review and update all images within the content pane, if 
desired. In some cases, the Zoom button is enabled in published mode on images placed 
within the Content pane.  

  

a. To remove the zoom icon, right-click on the image and select Edit Image. 

 

b. Within the Edit Image window, select the Use template zoom options checkbox to 
remove the zoom. 
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7. Repeat this procedure for all course (.ulc) files in your project. 

Step 15: Create Your HP ART 5.10 Website 
To deploy your content using the ART 5.10 website, the last step is to create the website. Due to 
the extensive changes in the website structure, you should create a new website (.uws) file, rather 
than attempt to edit the ART 4.40 website file. To use the HP ART 5.10 website structure, be sure 
that you completed the necessary tasks in Step 11: Update the Template to Support the ART 5.10 
Website Structure. 

Below are the high-level steps to create a website. Refer to the Creating the HP ART 5.10 Website 
guide for detailed information on this process. 

1. Prepare your ART files in the proper hierarchy. 
2. Create a new website .uws file. 
3. Import the source content files. 
4. Organize the website. 
5. Create the launch pages. 
6. Organize the website with the new launch pages 
7. Batch publish the source files. 
8. Publish the website. 
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Appendix A – Adjust the Simulation Button Size 
To change to a fixed simulation launch button size, perform the steps below. This example uses a 
Custom Square skin. 

1. Using the Windows Start Menu, navigate to the HP Adoption Readiness Tool Resources. 
2. Navigate to the skins>Course>custom>Custom-Square>skin folder. 
3. Open the content.css file with an editor such as Notepad++. 

 

4. Under the Assessment section, locate the div.choice section and add the following line: 
width:400px; 

 

5. Under the Assessment section, locate the input.simButton section and change the line 
width:400px; to: width:400px !important; 
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Appendix B – Remove Simulation and Assessment 
Page Borders 
To remove the simulation and assessment page borders, perform the steps below. This example 
uses a Custom Square skin. 

1. Using the Windows Start Menu, navigate to the HP Adoption Readiness Tool Resources. 
2. Navigate to the skins>Course>custom>Custom-Square>skin folder. The existing code may 

vary slightly based on the customer skin source. 
3. Open the content.css file with an editor such as Notepad++. 
4. Under the Content section, add the following lines between div#container and 

table#pageContent: 

form#contentForm 

{ 

border: none; 

} 

div#directions 

{ 

border: none; 

} 

The Content section should now appear as follows: 
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5. Under the Assessment section, edit the details for the following lines: 

• div#directions 
• div.choice 

Before: 

 
 
After: 
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6. Under the Assessment section, edit the details for the following lines: 

• div.choice input[type=button] 
• div.choice input[type=button]:hover, div.choice 

input[type=button]:focus 

Before: 

 
 
After: 

 
 

7. Under the Assessment buttons section, edit the details for the following lines: 

• div#assessmentButtons  

• div#assessmentButtons input[type=button] 

• div#assessmentButtons input[type=button]:hover, 
div#assessmentButtons input[type=button]:focus 
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Before: 

 
 
After: 
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8. Save the Content.css file. 
9. Republish your course. The borders and shading should now no longer be displayed for 

courses using the custom course skin.  
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Appendix C − Change the Course Header to a Solid 
Color  
To change to the course banner to a solid color, perform the steps below. This example uses a 
Custom Square skin. 

1. Navigate to the skins>Course>custom>Custom-Square>skin folder. The existing code may 
vary slightly based on the customer skin source. 

2. Open the skin.css file with an editor such as Notepad++. 
3. Change the opacity for div#header to 100. 
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Appendix D − Adjust the Size of the Back Button to 
Match the Next Button 
To adjust the size of the Back button, perform the steps below. This example uses a Custom 
Square skin. 

1. Navigate to the skins>Course>custom>Custom-Square>skin folder. 
2. Open the skin.css file with an editor such as Notepad++. 
3. Search for navBtnLabel a:link. 
4. Add the following lines shown in the box directly below div.navBtnLabel a:active. 

Ensure each line ends with a comma except for the last line. 
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5. Next, search for div.navBtnLabel a:hover, add a comma to the end of that line, 
and then add the line as shown below.  

 
 

6. Save and close the skin.css file. 

Once the course is published, both buttons display the same. 
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 To update the course menu icons, perform the steps below. This example uses a Custom Square 
skin. 

Appendix E – Update the Course Menu Icons 

1. Copy the menu_assessment.gif image from the HP ART 4.40 to ART 5.10 
Conversion Kit. 

2. Navigate to the skins>Course>custom>Custom-Square>skin folder and paste the image 
into this folder. The image should go in the same folder that your skin.css file resides.  

 

3. Open the skin.css file with an editor such as Notepad++. 
4. Edit the skin.css file by locating the div#menuAssessmentImage section and 

modify the location as shown in the image below. 

Before: 
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After: 

 
 

5. Save and close the skin.css.  
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To update the course menu icons, perform the steps below. This example uses a Custom Square 
skin. 

Appendix F – Update the Template to Adjust the 
Course and Simulation Launch Pages 

1. To modify the text in the Course launch window: 

a. Open your template. 
b. Navigate to General>Data Files.  
c. Select the course_index.htm file and select the Modify button. 
d. Using the illustration and table below, locate the area within the launch window that 

you would like to modify. You should only modify the identified items below unless you 
are an advanced ART user. When finished, save and close the course_index.htm 
file. 

The data files use hexadecimal strings to specify color in HTML files. For example, the hex 
value for white is #FFFFFF and for black is #000000. 
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<span id="title" style="font-weight: bold; font-size: 14pt; 
color: #FFFFFF; font-family: Tahoma; margin-
right:10px;"><@Title@></span> 

 

 
 
 

 

a:link, a:active, 
a:visited 
{ 
font-family: Tahoma; 
font-size: 12px; 
color: #FFFFFF; 
font-weight: bold; 
text-decoration: none; 
} 
a:hover 
{ 
color: #003366; 
text-decoration: 
underline; 
} 

 

 

   

 

 
.infoboxText 
{ 
font-family: Tahoma; 
font-size: 12px; 
color: #000000; 
} 

 

 
   

 

 
.footerText, 
.footerText a:link, 
.footerText a:active, 
.footerText a:visited 
{ 
font-family: Tahoma; 
font-size: 11px; 
color: #000000; 
} 
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2. To modify the text in the Simulation launch window: 

a. Navigate to General>Data Files. 
b. Locate the simulation_index.htm file and select the Modify button. 
c. Using the illustration and table below, locate the area within the launch window that 

you would like to modify. You should only modify the identified items below unless you 
are an advanced ART user. When finished, save and close the 
simulation_index.htm file. 

d. The data files use hexadecimal strings to specify color in HTML files. For example, the 
hex value for white is #FFFFFF and for black is #000000. 
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<div style="height: 47px; position: relative; vertical-align: 
bottom; overflow: hidden; text-overflow: ellipsis; font-
weight: bold; font-size: 14pt; color: #FFFFFF; font-family: 
Tahoma, Verdana, Arial, Helvetica; "> 

 

 
 

 

a:link, a:active, 
a:visited 
{ 
font-family: 
Tahoma, Verdana, 
Arial, Helvetica; 
font-size: 12px; 
color: #FFFFFF; 
font-weight: bold; 
text-decoration: 
none; 
} 
a:hover 
{ 

 

 

   

 

 
.infoboxText 
{ 
font-family: 
Tahoma; 
font-size: 12px; 
color: #000000; 
} 

 

 

   

 

 
.footerText, 
.footerText 
a:link, 
.footerText 
a:active, 
.footerText 
a:visited 
{ 
font-family: 
Tahoma; 
font-size: 11px; 
color: #000000; 
} 
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Introduction 
The HP Adoption Readiness Tool (HP ART) is an innovative authoring tool that allows 
consultants and clients to create customized training, documentation and support content, whether 
starting with HP prebuilt content or creating new material. As a single source, multiple output, 
object recognition technology, HP ART dramatically reduces content development time and 
improves software adoption.   

This guide contains high-level step-by-step instructions to create the HP ART 5.10 website. This 
guide is designed as a supplemental support document only and is not intended to be a 
replacement for training.  

For additional information on ART and ART Training and Services, contact your HPSW Sales 
Representative today or contact hpsoftware.art@hp.com for further information. 

This document is updated based on consumer feedback. Please check the Software Support 
Online (SSO) HP Software Product Manuals page to ensure you have the current version. 

  

mailto:hpsoftware.art@hp.com�
http://support.openview.hp.com/selfsolve/manuals�
http://support.openview.hp.com/selfsolve/manuals�
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HP ART 5.10 Website Structure 
 

The HP ART 5.10 website is organized into three levels, each represented by a separate web 
page. 
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ART Product Launch Page 

 

The top level of the ART website is the ART product.  The ART product web page introduces you to 
ART. This page includes a short introduction to ART, as well as the prerequisites required to view 
ART content. You can access each HP Software ART course included in the website from the left 
navigation menu of the ART product launch page under the Select a Course heading. 

Important: When referring to the ART website, do not confuse the term “course” with the (.ulc) 
ART Developer Kit source file.  The courses listed on the ART product launch page represent HP 
Software ART content, for example, the Cloud Service Automation 3.1 ART course or the HP 
Service Manager 9.30 ART course. 

 

 
 

 

 



Creating the HP ART 5.10 Website Guide 

 

Page 4 of 32 

 Copyright 2012 – 2013 Hewlett-Packard Development Company, L.P. 

Course Launch Page 

 
 

The second level of the ART website is the course web page.  The course web page introduces the 
selected HP Software ART course.  In the example above, the Cloud Service Automation (CSA) 
3.1 ART course launch page is displayed.  The course launch page includes an overview of the 
HP Software ART course, including the learning objectives.    

All HP Software ART courses consist of several modules.  You can access the modules that are 
included in the selected course from the left navigation menu under the Select a Module heading. 
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Module Launch Page 

 
 

The Module launch page provides access to the ART content.  You can either launch the  
e-learning course module directly by clicking the Launch Module button or, to quickly master a 
specific task, by launching a simulation or job aid within the Launch Simulation or Launch Job Aid 
options. 
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Creating the ART 5.10 Website 
When you purchase an HP Software ART course, the ART 5.10 website output files are included 
in the content package within the output folder.   

To create your own ART website, or customize an existing website, you do the following: 

 
1. Prepare the ART files. 
2. Create the website (.us) file. 
3. Insert the source content files. 
4. Organize the website. 
5. Create the ART product launch page. 
6. Create the course launch page. 
7. Organize the website with the new launch pages. 
8. Batch publish source files. 
9. Publish the website. 

 

Step 1: Prepare the ART Files 
Before creating the ART 5.10 website, it is important to organize the ART content into the 
following folder structure: 

ART_Project 

 source 

  module1 

   (folder containing the course and recording source files for module 1) 

  module2 

   (folder containing the course and recording source files for module 2) 

  … 

Below is a sample ART project folder for the HP Asset Manager 9.30 ART course: 
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For each module, the module folder contains all the course (.ulc) and recording (.udc) source files:  

 

 
 

Step 2:  Create the Website (.uws) File 
Select File>New from the ART editor window. 

 
 

Within the New window, populate the following fields and click the OK button: 
 

File name Enter the name of the website (.uws) file. 

Type Select Website from the drop-down menu. 

Template Select the desired template. 

Language Select the desired language. 

Location Specify the location to store the website (.uws) file. 
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The ART editor displays the new website file. 
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If this is the first time you are creating a website, select View>Choose Details from the ART editor. 

 

 
Within the Choose Details window, validate that the PORTFOLIO, Product, and Module columns 
are selected and click the OK button.   
 

Step 3: Insert the Source Content Files 
Select Insert>Insert Multiple Links from the ART editor menu. 
 

 
 

Navigate to the source folder of your project and click the OK button.   

Note: All source files located within the source folder are imported into the website. 
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A progress menu displays during the import process. 
 

 
 

The Links window pane lists each file.  Notice that each file is categorized by PORTFOLIO, 
Product, and Module. HP ART creates the website structure based on how you configure the 
properties for each file. For this reason, it is very important to properly complete the properties for 
each file. 
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Step 4: Organize the Website 
ART uses the Product and Module property values of each file to organize the structure of the 
website.  

Select Tools>Organize Website from the editor menu. 

 
 

A confirmation message displays.  Click the Yes button. 
 

 
 

The new organization of the website displays within the Pages pane.  The three organizational 
levels include:   

• The root .uws file 
• The HP Software ART course (Asset Manager in this example) 
• All modules within the ART course 
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By default, the root page is given the same name as the .uws file.  HP recommends that you 
change the name to easily identify the course.   

 
 

Select File>Properties from the editor menu. 

 
 

Within the Properties window, edit the Title field with the desired name.   
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Step 5: Create the ART Product Launch Page 
The ART product page is the first page that displays when the ART 5.10 website is launched.   

 
 

The ART product launch page is a logical link, not a physical web page.  You create a link and 
configure its properties with the information you want to display on the launch page. When you 
publish the course, HP ART pulls the property information and formats it to create the launch 
page. 

To create the ART product launch page, select Insert>Insert Link from the editor menu. 
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Within the General section of the Insert Link window, populate the following fields as shown: 
 

Name  ART Product Launch Page 

URL  http://dummy 

 
 

Navigate to the Properties section of the Insert Link window.  Enter the information you want to 
display on the ART product launch web page.  
 
You can use the following fields to populate the ART product launch web page.  All fields are 
optional, with the exception of the InfoPage field.  When you set the InfoPage field to True, ART 
recognizes the page as a launch page. 

 

Property Field Description 

InfoPage Must be set to True for all logical website launch pages 

Description First paragraph that is displayed 

DescriptionBullet1 Description bullet list item #1  

DescriptionBullet2 Description bullet list item #2  

DescriptionBullet3 Description bullet list item #3  

DescriptionBullet4 Description bullet list item #4  

Description2ndParagraph Second paragraph displayed after description bullets 

Objective1 Objective list item #1  

Objective2 Objective list item #2 
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Property Field Description 

Objective3 Objective list item #3 

Objective4 Objective list item #4 

Objective5 Objective list item #5 

Audience Statement that describes the intended audience of the ART 
product 

BeginHere Instructions to learner on what to do after reading the product 
launch page contents.  Appears last on the product launch 
page. 

Prerequisite1 Prerequisite #1  

Prerequisite2 Prerequisite #2 

Prerequisite3 Prerequisite #3 
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Click the OK button to save the properties. 

The following information is included in the launch page for all prebuilt ART courses: 

 
 
Prebuilt ART Product Launch Web Page Properties 
InfoPage True   
Description HP Adoption Readiness Tool (ART) is a learning and performance support 

solution accessible anytime, anywhere to help ensure your effective use of 
the software. 

Prerequisite1 High speed Internet connection 
Prerequisite2 Web browser (IE 7.0+; Mozilla Firefox 17+; Google Chrome 24; or 

Safari 5.0) 
Prerequisite3 Adobe Acrobat Reader 9.x, 10.x, or XI  
BeginHere To begin, select a course from the left navigation. 
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You access the logical ART product page using the Page tab located on the bottom of the website 
(.uws) file.  Notice that the page type is set to Link.  To make changes to the virtual page 
properties, double-click the link to open the Properties window. 
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Step 6: Create the Course Launch Page 
The course launch page displays when you select an HP Software ART course from the ART 
product launch page. 

   

 
 

The process of creating the course launch web page is very similar to the ART product launch 
page.  

Select Insert>Insert Link from the editor menu. 
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Within the General section of the Insert Link window, populate the following fields as shown: 
 

Name <name of ART course> Launch Page  

URL http://dummy 

 

 
 

Navigate to the Properties section of the Insert Link window. Enter the desired information to be 
displayed on the course launch page.   

Below are the property values that are typically entered for the course launch page.   

Important: For the course launch page, you must select the product to ensure the launch page is 
organized at the HP Software course level. 

 
Course Properties 
InfoPage True  (required for all launch pages) 
Product Product (select from the drop-down menu - used to organize website) 
Description High level overview of the HP Software ART course 
Objective1 Course Objective 1 
Objective2 Course Objective 2 
Objective3 Course Objective 3 
Objective4 Course Objective 4 
Objective5 Course Objective 5 
BeginHere Provides instructions to learner on how to begin the course 
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Click the OK button to save the properties. 



Creating the HP ART 5.10 Website Guide 

Page 21 of 32 

 Copyright 2012 – 2013 Hewlett-Packard Development Company, L.P. 

About the Module Launch Page 
You manage the Module launch page within the Properties window of the module course (.ulc) 
source file.  Authors populate the properties of each file during the development cycle. 

 
Below are the property values that are typically entered for the Module launch web page:   

Module Properties 

PORTFOLIO PORTFOLIO of the HP software product 

Product HP software product 

Description High level overview of the module. 

Build_num yyyy.mm file was last modified (not displayed on website, used for versioning 
only). 

Module Name of module.  The Module field is used to organize the file during the 
website publishing process. You must populate the Module field for every file 
in the ART project. 

 



Creating the HP ART 5.10 Website Guide 

 

Page 22 of 32 

 Copyright 2012 – 2013 Hewlett-Packard Development Company, L.P. 

Step 7:  Organize the Website with the New Launch Pages 
After you create the Product and course launch pages, organize the website to pick up the newly 
added pages.    

Select Tools>Organize Website from the editor menu. 

 
The following shows the product launch page listed at the correct level: 

  
The following shows the course launch page listed at the correct level: 
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Step 8: Batch Publish Source Files 
Next, you are ready to publish the source files. Select File>Batch Publish from the ART editor 
menu. 

 
 

Within the Batch Publish window, select the following options to be published: 
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In the lower half of the Batch Publish window, populate the following fields and click the Publish 
button: 
 

Inbox Browse to the source folder. 

Outbox Create a new folder named output, under the project root folder. 

 
 

The Batch Publish process will take several minutes, the exact time depending on the number of 
files in the website.  A progress window will display with notification of the status. 

 
When the batch publish process completes, the Publishing Summary window displays.  Click the 
OK button. 
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Step 9: Publish the Website  
The batch publish process publishes the source files contained within the website.  The final step is 
to publish the website file itself. Click the Publish icon from the ART editor toolbar. 

 

 
 

Within the Publish window, select the xml checkbox.  Ensure the Outbox is directed to the output 
folder created during the batch publish. 

 

 
 

When publishing is complete, click the Xml link to view the final website. 
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Note:  All output files are stored within the output folder specified within the Publish window. 
Click the index.htm file to launch the website. 
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Viewing the ART 5.10 Website Locally 
When viewing the ART 5.10 website locally, you must enable browser security settings. 

Mozilla FireFox 

1. Navigate to about:config within the FireFox browser. 
2. Change the preference security.fileuri.strict_origin_policy to False. 

 

Google Chrome 

1. Create a shortcut to Chrome. You can simply copy/paste the existing desktop shortcut, if 
you have one, or copy/paste the Chrome shortcut in the Start menu to your desktop. 

2. Right-click the shortcut and go to Properties. 
3. In the target field, add the following line: 

--allow-file-access-from-files 
 
For example, the entire target field will appear like the following: 

C:\Users\UserName\AppData\Local\Google\Chrome\Application\chrome.exe --allow-file-
access-from-files 

4. Click OK. 
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Adding Related Documents to the HP ART 5.10 
Website 
You can add external documents to the HP ART website at the product, course, and/or module 
levels.  Once added to the website, they are embedded with the file and accessible to all users. 

To add a document to the website, perform the following steps: 

1. Open the website (.uws) file. 
2. Select Insert>Insert link from the ART editor menu. 

 

 
 

3. Within the General menu item: 
a. Enter a title for the document to be displayed in the website, and navigate to the 

external file.   
b. Select the Copy content to published website folder checkbox to ensure the 

document is stored with the published files. 
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4. The information required in the Properties menu item depends on where you would like the 
related document displayed on the website. 
 

 
 

a. To display the related document on the HP ART product launch page, leave all 
fields within the Properties window blank. 
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b. To display the related document at the Course level, select the PORTFOLIO, 
Product fields. 
 

 
 

c. To display the related document at the Module level, select the PORTFOLIO, 
Product fields, as well as the appropriate Module field. 
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 Important:  Whenever you change the website page properties, you must 
refresh the website organization using Tools>Organize Website. 
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