Summary
Error
Sometimes after upgrading ALM (Application Lifecycle Management) 11.5x to a newer version a user might experience the following error when trying to login to updated version:
Following client components were not downloaded successfully:
1 . OTAClient.dll :
Unable to copy file to the deployment directory
2 . WebClient.dll :
Unable to copy file to the deployment directory
.....
Cause
User machine has not been cleared properly from old components.
This may happen if user is not local administrator or does not have all required permissions.
Fix
In order to fix the issue ensure that a user with administrative permissions logins to the machine and make a full cleanup:
1. From Add/Remove programs remove any old installation packages
or
2. Clean ActiveX and temp data by using the uninstall tool from KM1400068
http://support.microfocus.com/kb/kmdoc.php?id=KM1400068
"Uninstall utility for Quality Center / Application Lifecycle Management Client"