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Documentation Updates
The title page of this document contains the following identifying information:
l

Software Version number, which indicates the software version.

l

Document Release Date, which changes each time the document is updated.

l

Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a document, go
to:
http://h20230.www2.hp.com/selfsolve/manuals
This site requires that you register for an HP Passport and sign in. To register for an HP Passport
ID, go to:
http://h20229.www2.hp.com/passport-registration.html
Or click the New users - please register link on the HP Passport login page.
You will also receive updated or new editions if you subscribe to the appropriate product support
service. Contact your HP sales representative for details.
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Support
Visit the HP Software Support Online web site at:
http://www.hp.com/go/hpsoftwaresupport
This web site provides contact information and details about the products, services, and support
that HP Software offers.
HP Software online support provides customer self-solve capabilities. It provides a fast and
efficient way to access interactive technical support tools needed to manage your business. As a
valued support customer, you can benefit by using the support web site to:
l

Search for knowledge documents of interest

l

Submit and track support cases and enhancement requests

l

Download software patches

l

Manage support contracts

l

Look up HP support contacts

l

Review information about available services

l

Enter into discussions with other software customers

l

Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also
require a support contract. To register for an HP Passport ID, go to:
http://h20229.www2.hp.com/passport-registration.html
To find more information about access levels, go to:
http://h20230.www2.hp.com/new_access_levels.jsp
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Disclaimer for PDF Version of Online Help
This document is a PDF version of the online help. This PDF file is provided so you can easily print
multiple topics from the help information or read the online help in PDF format.
Note: Some topics do not convert properly to PDF, causing format problems. Some elements of
online help are completely removed from the PDF version. Those problem topics can be
successfully printed from within the online help.
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Welcome to HP Cloud Connector Help
Cloud Connector contains help instructions for the Cloud Administration Dashboard.
The Cloud Administration Dashboard is used to view, allocate, and manage all virtual resources
within a domain. This dashboard provides a simplified means of creating and managing Cloud
Connector resources, infrastructure topology templates, resource binding documents, as well as
the ability to provision a composite topology described by the topology templates and binding
documents. Cloud Connector launches resource binding documents to create virtual infrastructure
in the cloud. Cloud Administration Dashboard is associated with a single domain.
The Cloud Installation Dashboard is used to install, set up, and start a cloud environment which is
then managed through the Cloud Administration Dashboard. The Cloud Installation Dashboard is
available on SSO.

Page 16 of 90

HP Cloud Connector

HP Cloud Connector Help
Welcome to HP Cloud Administration Dashboard Help

Welcome to HP Cloud Administration
Dashboard Help
Cloud Installation Dashboard is the installer that is used to install, set up, and start a cloud
environment with the Cloud Administration Dashboard.
The Cloud Administration Dashboard is used to view, allocate, and manage all virtual resources
within a domain. Cloud Administration Dashboard provides a simplified means of creating and
managing Cloud Connector resources, infrastructure topology templates, resource binding
documents, as well as the ability to provision a composite topology described by the topology
templates and binding documents. Cloud Connector launches resource binding documents to
create virtual infrastructure in the cloud. Cloud Administration Dashboard is associated with a
single domain.

Domains
A domain is a security grouping that provides context for the definition of Projects, Users, and
Roles and hosts one or more regions. All users belong to a domain. Users are then linked to a region
and projects through roles assigned by an Administrator.
Keystone is the security context and the defining service for the domain. All services connected to
a single Keystone service are in one domain. Glance, in the recommend configuration, is also a
domain service as the images it provides are available to VMs in all regions. Cloud Connector
domain services are Eve, Focus, Peer, and Eden. A domain service is a service that can be used
by or for any region, so all of the Cloud Connector services are considered domain services
because they can be used for one or more regions.

Regions
Domains are divided into Regions. A Region is a compute grouping that provides context for the
usage of compute servers, networking systems, and storage resources. A Region contains a
defined set of users, projects, topology templates, infrastructure designs, and services governed by
a single Cloud Connector Keystone domain service. Regions are used to group different locations,
different types of hardware, or to separate different resources belonging to different groups.
Region services are registered under the names:
l

Nova - A region is constructed by installing and naming the Cloud Connector cloud compute
service called Nova.

l

Volume - The creation and management of volumes is controlled by the Volume service which is
accessed through the Nova service interface.

l

EC2 - An alternate interface for the Nova service.

Region services can be run on the same node as the domain controller or they can be run on a
different server. There can be multiple regions within a domain.
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Projects
Projects are groupings that allow users to view the same set of resources. Projects are the unit of
ownership within Cloud Connector that protect topology templates, infrastructure designs, and
regional resources from being visible to all users.

Access to the Cloud Administration
Dashboard
The dashboard provides security by roles. See "Role Descriptions" on page 20.
Domain Tab - Administrator Only
Services

Domain Services provides a read-only list of services running in the domain.

Projects

Projects are created by an administrator and allow a group of users to view the same
set of resources. Within this area you can manage projects, add users as an
administrator or user to a project, and manage user roles.

Users

Allows you to create new users and update, disable, and delete existing users.

Roles

Allows you to assign specific roles to a user within a region and project.

Region Tab - Administrator (All) and User (only sees Flavors and Limits)
Overview

A view of region usage by month (defaults to the current month).

Services

A list of services and endpoints that are running in the region.

Instances

A list of all VMs running within the region.

Volumes

All of the disc storage volumes that have been allocated to the region.

Networks

Fixed IP Networks and Floating IP Pools.

Flavors

A list of machine configurations that can be used to create new VMs. A flavor
describes the amount of memory, number of CPUs, and ephemeral disk space
available to the VM.

Limits

A view of Default Absolute Limits and Default Rate Limits.

Project Tab - All
Overview

Displays a Project Usage Summary.

Instances

A list of all VMs running within the project.
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Project Tab - All
Volumes

All of the disc storage volumes that have been allocated to the
project.

Images

Images are all the launchable images (AMI, QCOW2, and
RAW format) that can be used to create new VMs.

Snapshots

Snapshots preserve the disk state of running Instances and
Volumes.

Access &
Security

This tab provides a way to view and manage the following
elements in the project:
l

Floating IPs

l

Security Groups

l

Keypairs

Topologies

Topologies represent the virtual infrastructures that have been
realized when an Infrastructure Design document was
launched in the Cloud Installation Dashboard.

Documents

Documents are the infrastructure topology templates and
resource binding documents (design documents) that are used
for provisioning.

Resource
Pools

Records that define how to access a particular cloud provider.

Settings
The Settings link is available to all users on any window in the Cloud Administration Dashboard.

To change user display settings
1. Click the Settings link in the upper corner of a window.
2. In the left navigation frame, click User Settings.
3. Timezone defaults to UTC (Coordinated Universal Time). Click (

) for additional selections.

4. Table page size defaults to 20, meaning a maximum of 20 line items display at one time.
Enter a different number if desired.
5. Click Save.

To view Cloud Connector API/CLI information
1. In the left navigation frame, click Cloud Connector API/CLI.
2. API Keys are properties that correspond to the Current Place login information
(Domain/Region/Project) and user at the top of the window.
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Item

Description

Tenant
ID

Project ID.

Domain
URL

Public URL for the domain security service.

Region
ID

The name of the region you are logged into.

x-authtoken

Security token used to access service APIs. This token has a limited
lifetime and is different every time you log into Cloud Connector.

3. API Endpoints lists the installed services you have access to and where their API endpoints
are located for the logged in user.
4. Cloud Connector allows you to download the configuration file with environment variables for
the current Domain, Region, and Project. When you click Download RC File the system
creates a text file.

To Download EC2 Credentials
Credentials used with the EC2 interface to Cloud Connector.
1. In the left navigation frame, click EC2 Credentials.
2. Click Download EC2 Credentials to create a zip file that includes an RC file with your
access/secret keys and your x509 private key and certificate.

To view Cloud Connector version
In the left navigation frame, click About to identify the version and copyright information.

Role Descriptions
All users belong to a domain. Users are then linked to a region and projects through roles assigned
by an Administrator.
Within Cloud Connector, there are four basic roles:
l

Domain Administrator

l

Domain Architect

l

Project Administrator

l

Project User
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Domain Level Roles
l

Domain Administrator- all administrator rights associated with the cloud and all Cloud
Connector services, including the ability to make resources available to users.

l

Domain Architect- ability to create images, flavors, and topology components (resource
binding documents, templates, etc.) so that the domain administrator can make them available
to users.

Project Level Roles
l

Project Administrator - owns all resources within a project and has as full access to modify
and delete resources. Multiple users can be assigned the role of Project Administrator.

l

Project User - owns only the content they have created. A Project User can modify or delete the
content they own. All project users can view all content within their project even if owned by
other users. Users outside of a project can see content only if it is marked as public.

You can also add additional Project Roles to a user. See "Add a Project Role to a User" on page 25
for descriptions of the following roles:
l

binding_designer

l

compute_admin

l

compute_user

l

document_publisher

l

image_consumer

l

image_creator

l

image_publisher

l

job_consumer

l

job_creator

l

rp_consumer

l

rp_creator

l

service_map_consumer

l

template_designer

l

topology_creator

General rules about content ownership within projects and regions
l

To create content within a project, a user must be associated with the project and have either an
administrative role or a specific content-creation role. The Project User role includes contentcreation roles for most types of resources.

l

Content can only be made Public by a user with an administrative role or a specific contentpublishing role.
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l

Content belonging to a project is visible to all users associated to that project only if it has been
made Public by an administrator. Only the latest version of a document is made public.

l

While a project administrator can modify any content belonging to a project, a non-administrator
can modify only the content created by that user.

Domains
The Domain tab within Cloud Connector is only available to a Domain Administrator. A domain is a
security grouping that provides context for the definition of Projects, Users, and Roles. A domain is
constructed by installing and naming a Keystone service. Keystone provides user authentication
and tracks projects for all regions in a domain.
See the following related topics:
l

"View Domain Services" below

l

"View Domain Projects" on next page

l

"View Domain Users" on page 32

l

"View Domain Roles" on page 35

View Domain Services
Domain Services displays a read-only list of services that are registered in the domain and allows
you to view the Service Map for selected services.

To view domain services
1. In the left navigation frame of the Domain tab, click Services. The following domain services
are listed:
Service
Name

Service
Type

Description

Keystone Identity and
security

Provides user authentication and tracks various projects within the
regions in the domain. If Keystone is disabled, you cannot log into the
Cloud Administration Dashboard.

Glance

Image
storage

Repository for images used to create new VMs.

Eve

Provisioning A composite provisioning service that uses a topology (topology
template and resource binding) to create VMs, volumes, and network
segments as described in the topology. Eve uses the Peer service for
determining resource pool existence, traits, and user identity mapping.

Focus

Template
storage
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Service
Name

Service
Type

Peer

Resource
Pool
registry

Provides a registry of resource pool definitions you can use to
provision to various cloud providers.

Eden

Framework
and Utility
Service

This service provides core functionality such as authorization and job
access. The framework allows scaling of services so they can be
distributed across multiple machines if needed. All Cloud Connector
services are built and supported on the Eden framework.

Description

2. The Service URL column shows the IP address where the service is running.
3. Status - Enabled

To view a service map
If the Service Name is a blue link, click to open the Service Map.
The Service Map helps an administrator determine the health of the system by showing each
component that supports a service, when that component was last started, the IP addresses at
which the component can be reached, and the version of the component. A given component type
may have more than one row in this table if that component has been replicated for high availability
or scale out.

View Domain Projects
Projects are groupings that allow designated users to view the same set of content resources within
a region. Projects protect topology templates, infrastructure designs, and realized resources (VMs,
volumes, etc., that have been created) from being visible to all users.
Domain Administrators are responsible for creating projects and securing them by role
assignments.

To view existing domain projects
1. In the left navigation frame on the Domain tab, click Projects. Existing projects are listed
alphabetically by Name.
2. If there are more than 20 projects, navigate using the link at the bottom of the list. See
"Settings" on page 19 to change the table size.
3. To filter this list, click (
) and enter the first several characters of the Name or consecutive
characters within the Name. Then click Filter All. To reset, click Filter All again. (<Enter>
works the same as Filter All.)
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To view project details
1. Click a Project Name link.
2. The Project Detail Overview window opens with read-only project information and a list of
users and roles associated to the project.
3. Clicking a User link will open the Domain User Details window; clicking a Role link opens the
Domain Role Details window.
See the following related topics:
l

"Create a New Project" below

l

"Add a User to a Project" on next page

l

"Add a Project Role to a User" on next page

l

"Remove a Project Role from a User" on page 27

l

"Remove a User from a Project" on page 28

l

"Edit a Project" on page 28

l

"Delete a Project" on page 28

l

"View Project Usage Summary" on page 50

View Domain Project Usage Summary
1. In the left navigation frame of the Domain tab, click Projects.
2. Select the project and click
current month usage.

, View Usage. The Project Usage Summary displays the

3. You can select a different month to view and click Submit.
4. Download CSV Summary opens a text file in Microsoft Excel with current month usage
information.

Create a New Project
When creating a new project, the only required entry is Name. Users can be added at any time, and
the Integrations and Limits settings have defaults settings.
For more information about domain projects, see "View Domain Projects" on previous page.

To create a new project
1. In the left navigation frame on the Domain tab, click Projects.
2. Click Create New Project.
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3. On the Project Info tab, provide the following information:
a. Name (required)
b. Description (optional)
c. Enabled - this option is checked by default, meaning project content is available to
assigned users.
4. On the User tab, you can select a Project Administrator now or later.
5. On the Integrations tab, checking CDA Application makes this project available to HP
Continuous Delivery Automation (HP CDA) and auto-creates users that are necessary for
accessing from HP CDA. However, you still have to configure access to this project within HP
CDA.
6. On the Limits tab, select the Region where the project should be located. Absolute limits
represents the limit to the amount of system resources of the specified type that can be
consumed at one time by users of the project.
7. Click Create Project to save. If the save was successful, a green status box displays in the
upper right corner of the window and the Enabled field is set to True. If save was
unsuccessful, a red status box displays an error message.
8. The new project displays with a system-assigned Project ID.

Add a User to a Project
Before adding a new user to a project, make sure the user is logged out. Do not add yourself as a
new user within a project. Log out and have another Domain Administrator add you to a project.
Note: As a Domain Administrator, if you add users to a project while they are logged in they
may be logged out without warning or receive an error message. If so, users should sign out
and sign back in. Carefully coordinate with users or schedule adding users to a project when
they are not logged in.

To add a user to a project
1. In the left navigation frame on the Domain tab, click Projects.
2. Click Modify Users on the selected project.
3. In the Add New Users section of this window, select the user and then click Add To Project.
4. Select the Project Role and click Add User. The user is added to the Users In Project list.

Add a Project Role to a User
Once a user has been added to a project, you can add additional project roles to the user.
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To add a project role to a user
1. In the left navigation frame of the Domain tab, click Projects.
2. Click Modify Users.
3. In the Users For Project list, select the user and click Add Project Role.
4. Select the project role and click Add Role.
5. Additional roles:
Role

Content Type

Place

Role Abilities

bindingdesigner

Binding Designer

Domain

Access Binding
Designer

Domain > Region
> Project

All

Default Security Group

Domain > Region

All

Machine Flavor

Domain > Region

Creation

Project

Domain > Region

Creation

Project: Quota

Domain > Region
> Project

Creation

User/Role Association

Project

Visibility/Creation

Network

Domain > Region

Visibility/Creation

Network Project Association

Domain > Region
> Project

Visibility/Creation

Floating IP

Domain > Region

Creation

Nova: Instances, Volumes, Security
Groups, Keypairs

Domain > Region
> Project

All

Default Security Group

Domain > Region

Visibility

Machine Flavor

Domain > Region

Visibility

Project

Domain > Region

Visibility

Project: Quota

Domain > Region
> Project

Visibility

Floating IP

Domain > Region

Visibility

Floating IP Project Association

Domain > Region
> Project

Creation

compute_admin Nova: Instances, Volumes, Security
Groups, Keypairs

compute_user
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Role

Content Type

Place

Role Abilities

document_
consumer

Focus:Topology Document

Domain > Project

Visibility

document_
creator

Focus:Topology Document

Domain > Project

Creation

document_
publisher

Visibility

Domain > Project

Publication

image_
consumer

Glance: Image, Snapshots

Domain > Project

Visibility

image_creator

Glance: Image, Snapshots

Domain > Project

Creation

image_
publisher

Glance: Image, Snapshots

Domain > Project

Publication

job_consumer

Eden: Job

Domain > Project

Visibility

rp_consumer

Peer: Resource Pool

Domain > Project

Visibility

rp_creator

Peer: Resource Pool

Domain > Project

Creation

service_map_
consumer

Eden: Service Map

Domain

Visibility

template_
designer

Template Designer

Domain

Access Topology
Designer

topology_
creator

Eve: Realized Topology

Domain > Project

Creation

Remove a Project Role from a User
If only one role is listed for a user and you remove it, the user is removed from the Users For
Project list and moved to the Users list.

To remove a project role from a user
1. In the left navigation frame of the Domain tab, click Projects.
2. Select the project and click Modify Users.
3. In the Users For Project list, select the user and click

, Remove Project Role.

4. Select the role to remove and click Remove Role. That project role is no longer associated to
the user.
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Remove a User from a Project
To remove a user from a project
1. In the left navigation frame of the Domain tab, click Projects.
2. Select the project and click Modify Users.
3. In the Users For Project list, select the user and click
is moved to the Add New Users list.

, Remove from Project. The user

Edit a Project
Allows you to update project details and limits.

To edit a project
1. In the left navigation frame of the Domain tab, click Projects.
2. On the selected project, click

, Edit Project.

3. On the Project Info tab, you can change the Name, Description, and whether the project is
Enabled.
4. On the Limits tab, select a region and then edit the limits.
5. Click Update Project.

Delete a Project
Deleting a project marks the project for deletion by adding a ~ (tilde) prefix to its name. The project
is not completely deleted until the clean_projects script is invoked (scheduled by a System
Administrator) which deletes all resources associated with the project. You have the option to
restore the project any time before this script runs.

To delete a project
1. In the left navigation frame of the Domain tab, click Projects.
2. Select the project to delete and click
importance of this action.

, Delete Project. This option is red indicating the

3. You are prompted to confirm your decision. To confirm, click Delete Project.
4. The project list redisplays and the deleted project moves to the bottom of the list. The deleted
project has a tilde (~) preceding the Project Name, indicating it will be permanently removed
when the clean_projects script runs to ensure there are no resources attached.
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To restore a project
1. In the left navigation frame of the Domain tab, click Projects.
2. Select the project to restore, which will display at the bottom of the Projects list with a ~
preceding the Name.
3. Click

, Restore Project. You are prompted to confirm your decision.

4. Click Restore.
5. The project is restored and listed alphabetically with no ~ preceding the Name.

View Domain Images
A VM is launched based on an image. Within the Cloud Administration Dashboard, Domain Images
shows all non-snapshot images with the following formats:
l

AMI (Amazon Machine Image) - not valid unless it is associated with a kernel image (AKI) and a
RAMdisk Image (ARI).

l

ARI (Amazon RAMdisk Image) - EC2 file

l

AKI (Amazon Kernel Image) - EC2 file

l

RAW

l

QCOW2

Images are stored at the Domain level with a single Glance service and are unaffected by region
selection. Only Public images are visible to all users.

To view domain images
1. In the left navigation frame of the Domain tab, click Images.
2. If there are more than 20 images, navigate using the link at the bottom of the list. See
"Settings" on page 19 to change the table size.
3. To filter this list, click (
) and enter the first several characters of the Name or consecutive
characters within the Name. Then click Filter All. To reset, click Filter All again. (<Enter>
works the same as Filter All.)

To view domain image details
Click the Name link in the Image Name column. The Image Overview window opens with readonly image information and specs. An AMI image has additional custom properties for the Kernel ID
and RAMdisk ID, which are cross links to those associated image details.
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Launch an Image
Only AMI, RAW, and QCOW2 format images can be launched. Launching provisions to the cloud.

To launch an image
1. In the left navigation frame of the Domain tab, click Images.
2. Select an image and click Launch.
3. The Project and User tabs populate with information from the selected image, so the launch
window opens to the Details tab.
4. Enter the Server Name (required) and edit other details as needed:
a. Server Name - name the host you are creating (required) NOTE: The instance can be
launched at this point, if desired, with system defaults for remaining options.
b. Flavor - Flavor indicates the size of the node. When you select a flavor here, the Flavor
Details table on the left changes to indicate the node properties and values associated with
your size selection.
c. Instance Count - can be more than 1
5. Use the Access & Security tab to control access to your instance via keypairs and security
groups.
e. Select a keypair - Keypairs are ssh credentials which are injected into images when they
are launched. Click (+) to import a keypair. Creating a new keypair here registers the public
key and downloads the private key (a .pem file).
f. Security Groups - default is checked, meaning users within this group can communicate on
any port desired.
6. Use the Volume Options tab to select boot options for an instance launching with attached
storage.
7. The Post Creation tab allows you to customize the instance by adding a script to run after
launch of the instance. (The Customization Script field is analogous to "User Data" in other
systems.)
8. Click Launch. If successful, the image is added to the Images list with an Active status.

Create a Domain Image
Allows you to create and configure an image to upload to the Image Service. Only images available
via an HTTP URL are supported.

To create a domain image
1. In the left navigation frame of the Domain tab, click Images.
2. Click Create Image.
3. Enter the Image Name.
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4. Enter the Image Location, which must meet the following criteria: (Compressed image
binaries (.zip, .tar.gz) are supported.)
a. A valid and direct HTTP URL to the image binary. URLs that redirect or serve error pages
will result in unusable images.
b. Image must be accessible to the Image Service.
5. Select a Format. NOTE: Only AMI, RAW, and QCOW2 images are launchable.
6. Enter Minimum Disk space and Ram.
7. Check Public if you want the image visible to all users.
8. Click Create Image. If successful, the image displays with an Active status.If creation is not
successful within a specified amount of time (set by your system administrator; typically no
more than five minutes), the Status of the image in the list displays Upload Failed. If you
attempt to download an image with the wrong format, you will get an Error 404, Not Found.

Edit an Image
Allows you to modify the image name, architecture, and whether it is public. When you edit an AMI
image, you will see additional fields allowing you to select a Kernel Image and a RAMdisk Image.
An AMI (Amazon Machine Image) is not valid unless it is associated with a kernel image (AKI) and
a RAMdisk image (ARI).

To edit an image
1. In the left navigation frame of the Domain tab, click Images.
2. If the image is in AMI, RAW, or QCOW2 format, click
formats, click Edit Image.

, Edit Image. For other image

3. Edit the Name and Public visibility as desired. If you are editing an AMI image, you can select
a different Kernel Image and a RAMdisk Image.
4. Click Update Image.

Delete an Image
Deleting an image may affect the resource pool.

To delete an image
1. In the left navigation frame of the Domain tab, click Images.
2. Select the image and click

, Delete Image. You are prompted to confirm your decision.

3. Click Delete Image. The Images list redisplays and the image has been removed.
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To delete multiple images
1. Use the left checkbox(es) to select multiple images. To select all, click the top checkbox in the
header row.
2. Click Delete Images.
3. You are prompted to confirm your decision.

View Domain Users
Users within a domain include both people and services.

To view domain users
1. In the left navigation frame of the Domain tab, click Users.
2. If there are more than 20 users, navigate using the link at the bottom of the list. See "Settings"
on page 19 to change the table size.
3. To filter this list, click (
) and enter the first several characters of the Name or consecutive
characters within the Name. Then click Filter All. To reset, click Filter All again. (<Enter>
works the same as Filter All.)

To view user details
Click the Name link in the User Name column. The User Detail window opens with user and project
information. If there is a Default Project listed, it was assigned during user creation. All projects the
user is associated with display in the Project Information section.

To send an email to a user
Click the email link in the list of users. A new email is automatically created addressed to the user.

Create a New User
When creating a new user, all fields on the User and Project tabs are required. You can optionally
add domain-specific roles.

To create a new user
1. In the left navigation frame of the Domain tab, click Users.
2. Click Create User. The Create User window opens.
3. On the User tab, enter the User Name, Email, and a Password. All fields are required.
4. Click the Project tab to assign the user to a project.
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5. Select a project from the list. The project selected here becomes the Default Project for the
user. Assign the user a role as either a Project Administrator or Project User.
6. (Optional) Click the Domain tab if you want to assign the user domain-specific role(s):
a. Domain Administrator - all administrator rights plus Cloud Connector
b. Domain Architect - ability to set up images, flavors, and topology components
6. Click Create User. If the save was successful, a green status box displays in the upper right
corner of the window and the Enabled field is set to True. If save was unsuccessful, a red
status box displays an error message.

To view user details
Click the name in the User Name column. The User Detail window opens with user information and
a list of all associated projects.

To send an email to a user
Click the email link in the list of users. A new email is automatically created addressed to the user.

Update a User
To update user information
1. In the left navigation frame of the Domain tab, click Users.
2. Select the user from the list and click Edit User.
3. Update the Name, Email, or Password on the User tab.
4. Click the Domain tab to update the domain role of the user.
5. Click Update User to save. If the save was successful, a green status box displays in the
upper right corner of the window and the Enabled field is set to True. If save was
unsuccessful, a red status box displays an error message.

Disable/Enable a User
A disabled user remains visible in the Users list with an Enabled status of False.

To disable a user
1. In the left navigation frame of the Domain tab, click Users.
2. Select the user and click

, Disable User.

3. The user remains on the list but the Enabled field changes to False.
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To enable a user
1. In the left navigation frame of the Domain tab, click Users.
2. Select the user and click

, Enable User.

3. The user remains on the list and the Enabled field changes to True.

Delete a User
Any user name or type can be deleted except:
l

cda

l

eden

l

glance

l

nova

l

Trash

It is not recommended practice to delete the Admin / Domain Administrator or the Arch / Domain
Architect.
Deleting a user marks the user for deletion by adding a ~ (tilde) prefix to the name. The user will be
permanently removed from this list when the clean_users script is invoked (scheduled by a System
Administrator), which removes the user from the database by deleting all of the keypairs associated
with that user.

To delete a user
1. In the left navigation frame of the Domain tab, click Users.
2. Select the user to delete and click
importance of this action.

, Delete User. This option is red indicating the

3. You are prompted to confirm your decision. To confirm, click Delete User.
4. The Users list redisplays and the deleted user moves to the bottom of the list preceded by a ~
(tilde). The deleted user will be permanently removed from the list after the clean_users script
runs.

To restore a deleted user
A deleted user is not removed from the list until a scheduled script runs to ensure there are no
resources attached. You have the option to restore the user any time before the script runs.
1. Select the user and click Restore User.
2. Click Restore. The user is added back into the Users list alphabetically.
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View Domain Roles
You can view role names, create a role, delete user roles, and view role details from this window.

To view domain roles
1. In the left navigation frame on the Domain tab, click Roles. Existing roles are listed
alphabetically by Name.
2. If there are more than 20 roles, navigate using the link at the bottom of the list. See "Settings"
on page 19 to change the table size.
3. To filter this list, click (
) and enter the first several characters of the Name or consecutive
characters within the Name. Then click the Filter All button. To reset, click Filter All again.
(<Enter> works the same as Filter All.)

To view role details
1. Click a Role Name link.
2. The Role Detail Overview window opens with read-only role information and a list of users and
roles associated to the project.
3. Clicking a User link will open the Domain User Details window; clicking a Role link opens the
Domain Role Details window.
See the following related topics:
"Create a Role" below
"Delete a Role" on next page

Create a Role
When creating roles in the Cloud Administration Dashboard, the authorization code checks if a
service requires the specified role and whether the requesting user has the role. The service defines
which roles are required. If you are using Keystone for your own purposes or with other Cloud
Connector services, you may want to define your own roles.

To create a role
1. In the left navigation frame of the Domain tab, click Roles.
2. Click Create Role.
3. Enter the Role Name and click Create Role.
4. The role is added to the list alphabetically.
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Delete a Role
The only roles that cannot be deleted are:
l

admin

l

arch

l

proj_admin

l

project_user

Once deleted, a role is removed throughout the system.

To delete a role
1. In the left navigation frame of the Domain tab, click Roles.
2. Select the role to delete and click Delete Role.
3. You are prompted to confirm your decision, as deleting a role cannot be undone. To confirm,
click Delete Role.
4. The role is removed from the list and throughout the system.

To delete multiple roles
1. Use the left checkbox(es) to select multiple roles.
2. Click Delete Roles.
3. You are prompted to confirm your decision. The roles are removed from the list and throughout
the system.

Regions
A Region is a compute grouping that provides context for the usage of compute servers,
networking systems, and storage resources. A Region makes use of a defined set of users,
projects, topology templates, infrastructure designs, and services governed by a single Cloud
Connector Keystone domain service. Regions are used to group different locations, different types
of hardware, or to separate different resources belonging to different groups.
Region services are registered under the names:
l

Nova - A region is constructed by installing and naming the Cloud Connector compute service
called Nova.

l

Volume - the creation and management of volumes is controlled by the Volume service which is
accessed through the Nova service interface.

l

EC2 - An alternate service interface to the Nova service that is compatible with the Amazon
EC2 service.
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Region services can be run on the same node as the domain controller or they can be run on a
different server. There can be multiple regions within a domain.

Visibility by role
Within the Region tab, visibility is by role. Administrators see all tabs, users only two:
l

Overview

l

Services

l

Instances

l

Volumes

l

Networks

l

Flavors - Administrators and Users

l

Limits - Administrators and Users

To select a region
If there is more than one region defined for your domain, you select the region to manage by clicking
Current Compute Region in the left navigation frame of the Region tab. NOTE: Changing regions
may switch the point of action to the Project tab. Re-click the Region tab and the new selected
region displays.

View Region Usage Summary
1. In the left navigation frame of the Region tab, click Overview.
2. The Region Usage Summary displays the current month usage.
3. You can select a different month to view and click Submit.
4. Download CSV Summary opens a text file in Microsoft Excel with current month usage
information.

View Region Services
Region Services displays a read-only list of services that are registered in the region.

To view region services
1. In the left navigation frame of the Region tab, click Services. The following region services are
listed:
Service Name Description
ec2

An alternate service interface for the Nova service.

nova

A region is constructed by installing and naming a compute server called Nova.
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Service Name Description
volume

Manages attached storage for the VMs.

2. The Service URL (Public) column shows the IP address where the service is running.
3. Status - Enabled

View Region Instances
Instances are all of the VMs running within the region.

To view region instances
1. In the left navigation frame of the Region tab, select the Current Compute Region you want
to view.
2. Select Instances. This action displays the state of the instances running in the region.

Launch Region Instance
The system allows you to launch an instance only into a project of which you are a member. Even
as a Domain Administrator, if you are not a member of a project you cannot launch an instance into
the project, even though you can create compute resources in the project.
Make your selections carefully when setting up an Instance, as the only editable property once it is
launched is the Name.

To launch a region instance
1. In the left navigation frame of the Region tab, click Instances.
2. Click Launch Instance.
3. Optionally select the Project and User for whom the instance should be created.
4. Click the Details tab to specify the details for launching an instance.
a. Instance Source - an Image (default) or Snapshot
b. Image - depending on your selection in Instance Source, you are required to select an AMI,
RAW, or QCOW2 formatted image to create the new VM or a specific snapshot.
c. Server Name - name the host you are creating (required) NOTE: The instance can be
launched at this point, if desired, with system defaults for remaining options.
d. Flavor - Flavor indicates the size of the node. When you select a flavor here, the Flavor
Details table on the left changes to indicate the node properties and values associated with
your size selection.
i. Name - tiny to xlarge or the name of a custom flavor that has been created
ii. Number of virtual CPUs
iii. Root Disk - the one that gets assigned by the image
iv. Ephemeral Disk - a second storage disk available to the VM
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v. RAM - processor memory
vi. Instance Count - can be more than 1
5. Use the Access & Security tab to control access to your instance via keypairs and security
groups.
e. Select a keypair - Keypairs are ssh credentials which are injected into images when they
are launched. Click (+) to import a keypair. Creating a new keypair here registers the public
key and downloads the private key (a .pem file).
f. Security Groups - Security groups are one way to provide a measure of network isolation
between different VMs, as they limit the ports into which network traffic can enter the
group. You can select multiple groups.
6. Use the Volume Options tab to select boot options for an instance launching with attached
storage.
7. The Post Creation tab allows you to customize the instance by adding a script to run after
launch of the instance. (The Customization Script field is analogous to "User Data" in other
systems.)
8. Click Launch. The Instance is added to the Instances list with a Power State of Running.

View Region Instance Details
The Instance Overview is a read-only summary of all properties related to the Instance.

To view instance details
1. In the left navigation frame of the Region tab, click Instances
2. Click the link on the Instance Name.
3. The Instance Overview displays with the following information:
a. Name
b. ID
c. Status
d. Flavor
e. IP Addresses
f. Security Groups
g. Metadata
h. Volumes Attached
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View the Region Instance Console Log
The Instance Console Log is the system log from the VM and is used for debugging and
troubleshooting. You can view the full instance log or specify the number of lines of the log file to
view.

To view the instance console log
1. In the left navigation frame of the Region tab, click Instances.
2. Select the instance and click
Instance Name).

, View Log (or access the Console Log by clicking the linked

3. Click the Log tab to view the most recent 35 lines from the Instance Console Log.
4. To change the number of display lines, enter a value in Log Length and click Go.
5. Click View Full Log to view all logged entries.

Using the Instance VNC Console
This option allows you to remotely log into the VM directly.

To access the VNC Console
1. In the left navigation frame of the Region tab, click Instances.
2. Select the instance and click
linked Instance Name.

, VNC Console or access the VNC Console by clicking the

Edit an Instance
The only Instance property you can edit is the Name.

To edit an instance
1. In the left navigation frame of the Region tab, click Instances
2. Select the Instance and click Edit Instance.
3. Update the Name and click Save Changes. The list redisplays with the new name.

Create an Instance Snapshot
Once you have set up, installed, and configured an instance, you can create a snapshot to preserve
the disk state of the running instance. Snapshots can then be used to start up another VM in the
future.
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To create a snapshot
1. In the left navigation frame of the Region tab, click Instances.
2. Select the instance and click

, Create Snapshot.

3. The Instance ID defaults to the current instance and cannot be changed.
4. Enter a name for the snapshot.
5. Click Create Snapshot.
6. The Snapshots window opens in the Project tab displaying Instance Snapshots alphabetically
in the top report (Volume Snapshots at the bottom).

Pause an Instance
Pausing an instance stores the content of the VM in memory (RAM). This keeps the instance
running but in a frozen state. A paused instance could be compared to a PC in hibernation or sleep
mode.
To free up memory and vCPUs, you should suspend an instance. See "Suspend an Instance"
below.

To pause an instance
1. In the left navigation frame of the Region tab, click Instances.
2. Select the instance and click

, Pause Instance.

3. The Status and Power State of the instance show Paused.

To unpause an instance
1. Select the instance and click

, Unpause Instance.

2. After a short time, the Status returns to Active and the Power State returns to Running.

Suspend an Instance
Suspending an instance frees up memory and vCPUs. Suspension could be compared to
hibernation mode.

Page 41 of 90

HP Cloud Connector

HP Cloud Connector Help
Welcome to HP Cloud Administration Dashboard Help

To suspend an instance
1. In the left navigation frame of the Region tab, click Instances.
2. Select the instance and click

, Suspend Instance.

3. The Task column indicates the instance is suspending. When complete, the Status shows
Suspended and the Power State shows Shutoff.

To resume an Instance
1. Select the instance and click

, Resume Instance.

2. The Task column indicates the instance is resuming. When complete, the Status returns to
Active and the Power State returns to Running.

Reboot an Instance
During a reboot, the VM and all the services it hosts are not available to users.

To reboot an instance
1. In the left navigation frame of the Region tab, click Instances.
2. Select the instance and click

, Reboot Instance.

3. You are prompted to confirm this action. Click Reboot Instance to continue.
4. The Task column indicates the instance is Rebooting Hard. If reboot was successful, the
Status shows Active again and the Power State shows Running.

Terminate Region Instance
When you terminate an instance, the VM is shut down and the resources associated with it are
released. It is not possible to start the VM after it is terminated because it no longer exists.
Termination is scheduled because it takes some time to free all the resources.
When an instance is terminated:
l

Any changes associated with the volume that the image is running on are discarded.

l

Any changes associated with the volume implied by the disk space (ephemeral) that are
specified in the flavor are discarded.

l

Any changes associated with attached volumes are retained in the attached volume and could
be reattached to a different VM.
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l

The VM is removed from any security group it was associated with, and frees its floating IP
addresses.

To terminate an instance
1. In the left navigation frame of the Region tab, click Instances.
2. Select the instance and click
importance of the action.

, Terminate Instance. This option is red indicating the

3. You are prompted to confirm this action. Click Terminate Instance to continue.
4. The Task column indicates the instance is Deleting. If terminate was successful, the green
Status box in the upper right indicating the system has scheduled the termination of the
instance.

To terminate multiple instances
1. Use the left checkbox(es) to select multiple instances. To select all, click the top checkbox in
the header row.
2. Click Terminate Instances.
3. You are prompted to confirm your decision. Click Terminate Instances to continue.

Force Delete Region Instance
Use the Force Delete option to delete an instance when it appears to be in an unresponsive state.
Any user has the option to Force Delete, which immediately and completely deletes the instance
from the region.

To force delete an instance
1. In the left navigation frame of the Region tab, click Instances.
2. Select the instance and click
importance of the action.

, Force Delete Instance. This option is red indicating the

3. The instance is deleted without prompting and it is removed from the list.

View Region Volumes
Volumes are the disk storage volumes that have been created in the region. Volumes are
persistent, meaning you can create data in these volumes and attach to various VMs (instances)
over time as needed.
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To view region volumes
In the left navigation frame of the Region tab, click Volumes. This list displays the existing
volumes available in the region.

View Region Volume Detail
To view region volume details
1. In the left navigation frame of the Region tab, click Volumes. This list displays the existing
volumes available in the region.
2. Click the linked Volume Name to view the Volume Overview.

Create a New Volume
Volumes can be created manually by entering the size, or you can use a volume snapshot as a
source.
After a volume has been created it is available to attach to VMs. Attaching the volume to a VM
allows content to be put onto the volume. Then it can be detached (with content) and be made
available to be attached to other VMs.

To create a new volume
1. In the left navigation frame of the Region tab, click Volumes.
2. Click Create Volume. The Volume Quotas show you how much disk space is available and
the number of volumes available to create.
3. If you are using a snapshot as a source for the new volume, select the snapshot from the field
drop-down and it auto-populates the Volume Name and Size. Enter an optional Description.
4. If you are creating a new volume not based on a snapshot, enter the Volume Name and Size.
Description is optional.
5. Click Create Volume.

Attach a Volume to an Instance
Volumes are disk storage volumes that have been created in a project and can be attached to an
Instance. A volume can only be attached to one VM at a time. While attached, that VM has sole use
of the volume and the volume cannot be attached to another VM.
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To attach a volume to an instance
1. In the left navigation frame of the Region tab, click Volumes.
2. Select the volume and click

, Attach Volume.

3. The Current Attachments are listed at the top; you attach an instance by making a selection in
the Instance field.
4. As the volume attaches, the status changes. In-use status indicates a volume is in use by a
VM.

To detach a Volume
Once a volume is attached, the Detach Volume button is available through the Attach Volume
action.

Create a Volume Snapshot
Once you have set up a volume, you can create a snapshot to preserve the current state of the
volume. Volume Snapshots can then be used to start up another VM in the future.

To create a volume snapshot
1. In the left navigation frame of the Region tab, click Volumes.
2. Select the volume and click

, Create Snapshot.

3. Enter a Name for the snapshot and optionally a Description.
4. Click Create Snapshot.
5. The system switches to Project > Images and the status box in the upper right indicates
snapshot creation progress.

Delete a Volume
Deleting a volume means the volume will no longer exist, the data will be lost, it cannot be attached
to any VM, and no user can access. Deleting a volume cannot be undone.

To delete a volume
1. In the left navigation frame of the Region tab, click Volumes.
2. Select the volume and click
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To delete multiple volumes
1. Use the left checkbox(es) to select multiple volumes. To select all, click the top checkbox in
the header row.
2. Click Delete Volumes.
3. You are prompted to confirm your decision.

Force Delete Region Volume
Use the Force Delete option to delete a volume when it appears to be in an unresponsive state. Any
user has the option to Force Delete, which immediately and completely deletes the volume from the
region.

To force delete a volume
1. In the left navigation frame of the Region tab, click Volumes.
2. Select the unresponsive volume and click
indicating the importance of the action.

, Force Delete Volume. This option is red

3. The volume is deleted without prompting and it is removed from the list.

View Region Networks
The Region Networks tab is only viewable to an Administrator if Nova and Cloud Administration
Dashboard are on the same server.

To view region networks
In the left navigation frame of the Region tab, click Networks.
l

The Fixed IP Networks section identifies private services and how networking was configured
when the servers were designated for use within the cloud. Fixed IP Networks are configured
with Cloud Installation Dashboard and typically won't be modified unless the physical network
configuration changes.

l

The Floating IP Network section lists a set of public addresses that are available for
associating to VMs that need to be visible outside the cloud but within the enterprise. This area
outside the cloud but within an enterprise is considered the Cloud Edge.

Page 46 of 90

HP Cloud Connector

HP Cloud Connector Help
Welcome to HP Cloud Administration Dashboard Help

Create a Fixed IP Network
Creating a Fixed IP Network allows you create a virtual network definition within the cloud and
assign it to a project. Addresses are visible only inside the cloud.

To create a fixed IP network
1. In the left navigation frame of the Region tab, click Networks.
2. Click Create Fixed IP Network.
3. Enter the following information.
Option

Description

Network
Label

Label for the network

IPv4
CIDR

IPv4 subnet for fixed IPs. The IPv4 CIDR option is a CIDR block which describes
the IP address space for all of the instances. This space will be divided up into
subnets. This range is typically a private network.

IPv6
CIDR

Fixed Range V6

Gateway
IPv4

Gateway Version 4

Gateway
IPv6

Gateway Version 6

DNS 1

First DNS

DNS 2

Second DNS

Vlan ID

Vlan ID

Multihost

True or False

Number
of
Networks

Number of networks to create

Network
Size

Number of IPs per network

Bridge ID

VIFs on this network are connected to this bridge

Bridge
Interface

The bridge is connected to this interface

Priority

Network interface priority
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4. Click Create Network.

Delete a Fixed IP Network
Before deleting a Fixed IP network, make sure it is not associated with a running instance. Deleting
removes the network from the network list. The fixed IP address will be permanently removed from
the database when the clean_fixed_ips script is invoked (scheduled by a System Administrator).

To delete a fixed IP network
1. In the left navigation frame of the Region tab, click Networks.
2. Select the Fixed IP Network from the list and click Delete.

Create a Floating IP Pool
You associate floating IP addresses with VMs that need to be visible outside the cloud but within
the enterprise. For example, a VM that is to be used as a web server might need to be accessed
from outside the cloud and should get assigned a floating IP address.

To create a floating IP network
1. In the left navigation frame of the Region tab, click Networks.
2. Click Create Floating IP.
3. Enter field information.
4. Click Create Network.

View Region Flavors
Flavors are machine configurations that can be used to create new VMs. A flavor describes the
amount of memory, number of CPUs, and ephemeral disk space available to the VM.

To view region flavors
In the left navigation frame of the Region tab, click Flavors. This list displays current flavors
running in the region. Flavors are viewable by all users within a region, but only a Domain
Administrator can create and delete flavors.

Create a Flavor
Only Domain Administrators within a region have rights to create flavors. Creating a flavor defines a
new configuration used to create new VMs. Typically, the pre-defined Flavors m1.tiny through
m1.xlarge are sufficient.
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To create a flavor
1. In the left navigation frame of the Region tab, click Flavors.
2. Click Create Flavor.
3. All fields are required. All fields are integer values except for the Name field.
4. Click Create Flavor. The list redisplays with the new flavor listed alphabetically and a systemassigned Flavor ID.

Delete Flavors
Only Domain Administrators within a region have rights to delete flavors. When you delete a flavor,
the flavor is no longer visible in the Cloud Administration Dashboard and cannot be used to create a
new VM, assigned in resource pool services, or specified in Infrastructure Design documents. The
deleted flavor, however, still exists in the Nova database; and if an instance was created using that
flavor, it is still running and must be terminated. See"Terminate Region Instance" on page 42.
Following these steps ensures that when the clean_flavors script runs (scheduled by your System
Administrator), the deleted flavor will be completely removed because there are no active instances
using the flavor.
NOTE: If all flavors are deleted, you will not be able to create VMs.

To delete a flavor
1. In the left navigation frame of the Region tab, click Flavors.
2. Select the flavor to delete and click Delete Flavor in that row.
3. You are prompted to confirm your decision, as deleting a flavor cannot be undone. To confirm,
click Delete Flavor. The flavor is removed from the list.

To delete multiple flavors
1. Use the left checkbox(es) to select multiple flavors. To select all, click the top checkbox in the
header row.
2. Click Delete Flavors.
3. You are prompted to confirm your decision.

View Region Limits
Used to view the limits for the various region resources.
Absolute Limits represent the maximum amount of system resources of the specified type that
can be consumed at one time by users of the project. Limits are set up when you create or edit a
project in the Domain tab. The limits here are defaults used when a project is created.
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Default Rate Limits shows limits associated with a unit of time. For example, a user may be
limited to sending no more than 30 HTTP requests per minute.

Projects
Projects are groupings that allow users to view the same set of resources. Projects are the unit of
ownership within the Cloud Connector and protect topology templates, infrastructure designs, and
regional resources from being visible to all users.
The Project tab and related tasks are available to both administrators and users of the Cloud
Connector system, including launching Topology Designer.
If you have access to multiple projects, select from the Current Project list in the left navigation
frame. Once a project is selected, you can
l

view project usage and manage instances, volumes, images, snapshots, and security

l

view topologies

l

create and manage infrastructure topology templates and resource binding documents that are
used for provisioning

l

create and manage resource pools

View Project Usage Summary
To view project usage
1. In the left navigation frame of the Project tab, select the Current Project you want to view.
2. Click Overview. The Project Usage Summary displays the current month usage.
3. You can select a different month to view and click Submit.
4. Download CSV Summary opens a text file in Microsoft Excel with current month usage
information.

View Project Instances
Instances are all of the VMs running within the selected project.

To view project instances
1. In the left navigation frame of the Project tab, select the Current Project you want to view.
2. Select Instances. This action displays the state of the instances running in the project.

Launch an Instance within a Project
The system allows you to launch an instance only into a project of which you are a member. Even
as a Domain Administrator, if you are not a member of a project you cannot launch an instance into
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the project, even though you can create compute resources in the project.
Make your selections carefully when setting up an Instance, as the only editable property once it is
launched is the Name.

To launch an instance
1. In the left navigation frame of the Project tab, select the project from Current Project
2. Click Instances.
3. Click Launch Instance. This action opens the Details tab, as the Project & User tab was
auto-populated with current information.
4. Specify the details for launching an instance.
a. Instance Source - an Image (default) or Snapshot
b. Image - depending on your selection in the Instance Source field, you are required to
select an AMI, QCOW2, or RAW formatted image or a specific snapshot. (ARI and AKI
types cannot be launched.)
c. Server Name - name the host you are creating (required). NOTE: The instance can be
launched at this point, if desired, with system defaults for remaining options.
d. Flavor - Flavor indicates the size of the node. When you select a flavor here, the Flavor
Details table on the left changes to indicate the node properties and values associated with
your size selection.
i. Name - tiny to xlarge or the name of a custom flavor that has been created
ii. Number of virtual CPUs
iii. Root Disk - the one that gets assigned by the image
iv. Ephemeral Disk - a second storage disk available to the VM
v. RAM - processor memory
vi. Instance Count - can be more than 1
5. Use the Access & Security tab to control access to your instance via keypairs and security
groups.
e. Select a keypair - Keypairs are ssh credentials which are injected into images when they
are launched. Click (+) to import a keypair. Creating a new keypair here registers the public
key and downloads the private key (a .pem file).
f. Security Groups - Security groups are one way to provide a measure of network isolation
between different VMs, as they limit the ports into which network traffic can enter the
group. You can select multiple groups.
6. Use the Volume Options tab to select boot options for an instance launching with attached
storage.
7. The Post Creationtab is analogous to "User Data" in other systems. This tab allows you to
customize the instance by adding a script to run after launch of the instance.
8. Click Launch. The Instance is added to the Instances list with a Power State of Running.
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View Project Instance Details
The Instance Overview is a read-only summary of all properties related to the Instance.

To view instance details
1. In the left navigation frame of the Project tab, click Instances.
2. Click the link on the Instance Name.
3. The Instance Overview displays with the following information:
a. Name
b. ID
c. Status
d. Flavor
e. IP Addresses
f. Security Groups
g. Metadata
h. Volumes Attached

View the Project Instance Console Log
The Instance Console Log is the system log from the VM and is used for debugging and
troubleshooting. You can view the full instance log or specify the number of lines of the log file to
view.

To view the instance console log
1. In the left navigation frame of the Project tab, click Instances.
2. Select the instance and click
Instance Name).

, View Log (or access the Console Log by clicking the linked

3. Click the Log tab to view the most recent 35 lines from the Instance Console Log.
4. To change the number of display lines, enter a value in Log Length and click Go.
5. Click View Full Log to view all logged entries.

Using the Project Instance VNC Console
This option allows you to remotely log into the VM directly if you are using IE version 9 or greater.
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To access the VNC Console
1. In the left navigation frame of the Project tab, click Instances.
2. Select the instance and click
linked Instance Name.

, VNC Console or access the VNC Console by clicking the

Edit an Instance
The only Instance property you can edit is the Name.

To edit an instance
1. In the left navigation frame of the Project tab, click Instances.
2. Select the instance and click

, Edit Instance.

3. Update the Name and click Save Changes . The list redisplays with the new name.

Create an Instance Snapshot
Once you have set up, installed, and configured an instance, you can create a snapshot to preserve
the disk state of the running instance. Snapshots can then be used to start up another VM in the
future.

To create a snapshot
1. In the left navigation frame of the Project tab, click Instances.
2. Select the instance and click Create Snapshot.
3. The Instance ID defaults to the current instance and cannot be changed.
4. Enter a Name for the snapshot.
5. Click Create Snapshot.
6. The Snapshots list redisplays with the new snapshot inserted alphabetically in the top section
of the report (Volume Snapshots display at the bottom).

Pause a Project Instance
Pausing keeps an instance running but in a "frozen" state and stores the content of the VM in RAM.
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To pause an instance
1. In the left navigation frame of the Project tab, click Instances.
2. Select the instance and click

, Pause Instance.

3. The Status and Power State of the instance show Paused.

To Unpause an Instance
1. Select the instance and click

, Unpause Instance.

2. After a short time, the Status returns to Active and the Power State returns to Running.

Suspend an Instance
Suspending an instance frees up memory and vCPUs. Suspension could be compared to
hibernation mode.

To suspend an instance
1. In the left navigation frame of the Project tab, click Instances.
2. Select the instance and click

, Suspend Instance.

3. The Task column indicates the instance is suspending. When complete, the Status shows
Suspended and the Power State shows Shutoff.

To resume an Instance
1. Select the instance and click

, Resume Instance.

2. The Task column indicates the instance is resuming. When complete, the Status returns to
Active and the Power State returns to Running.

Reboot an Instance
Rebooting an Instance is similar to cycling power on a physical server; the operating system is
restarted from scratch. Rebooting temporarily makes the VM and all the services it hosts
unavailable.
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To reboot an instance
1. In the left navigation frame of the Project tab, click Instances.
2. Select the instance and click

, Reboot Instance.

3. You are prompted to confirm this action. Click Reboot Instance to continue.
4. The Task column indicates the instance is Rebooting Hard. If reboot was successful, the
Status shows Active again and the Power State shows Running.

Associate a Floating IP to an Instance
Allows you to associate a Floating IP address to an instance that needs to be visible outside the
cloud.

To associate a floating IP to an instance
1. In the left navigation frame of the Project tab, click Instances.
2. Select the instance and click

, Associate Floating IP.

3. Select an IP Address if there is one available. If not available, see Step 6.
4. Select an Instance.
5. Click Associate.
6. Click (+) to allocate a floating IP from a pool.
7. Select a Pool and then click Allocate IP.

Terminate Project Instance
When you terminate an instance, the VM is shut down and the resources associated with it are
released. It is not possible to start the VM after it is terminated because it no longer exists.
Termination is scheduled because it takes some time to free all the resources.
When an instance is terminated:
l

Any changes associated with the volume that the image is running on are discarded.

l

Any changes associated with the volume implied by the disk space (ephemeral) that are
specified in the flavor are discarded.

l

Any changes associated with attached volumes are retained in the attached volume and could
be reattached to a different VM.

l

The VM is removed from any security group it was associated with, and frees its floating IP
addresses.
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To terminate an instance
1. In the left navigation frame of the Project tab, click Instances.
2. Select the instance and click
importance of the action.

, Terminate Instance. This option is red indicating the

3. You are prompted to confirm this action. Click Terminate Instance to continue.
4. The Task column indicates the instance is Deleting. If terminate was successful, the green
Status box in the upper right indicating the system has scheduled the termination of the
instance.

To terminate multiple instances
1. Use the left checkbox(es) to select multiple instances. To select all, click the top checkbox in
the header row.
2. Click Terminate Instances.
3. You are prompted to confirm your decision. Click Terminate Instances to continue.

Force Delete Project Instance
Use the Force Delete option to delete an instance when it appears to be in an unresponsive state.
Any user has the option to Force Delete, which immediately and completely deletes the instance
from the project.

To force delete an instance
1. In the left navigation frame of the Project tab, click Instances.
2. Select the instance and click
importance of the action.

, Force Delete Instance. This option is red indicating the

3. The instance is deleted without prompting and it is removed from the list.

View Project Volumes
Volumes are the disk storage volumes that have been created in the project. Volumes are
persistent, meaning you can create data in these volumes and attach to various VMs (instances)
over time as needed.
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To view project volumes
In the left navigation frame of the Project tab, click Volumes. This list displays the existing
volumes in the region and their Status, e.g., Attaching, Available, In-Use.

View Project Volume Detail
To view project volume details
1. In the left navigation frame of the Project tab, click Volumes.This list displays the existing
volumes available in the project.
2. Click the linked Volume Name to view the Volume Overview.

Create a New Volume
Volumes can be created manually by entering the size, or you can use a volume snapshot as a
source. Once the volume has been created, it is attached to a VM where content can be placed.

To create a new volume
1. In the left navigation frame of the Project tab, click Volumes.
2. Click Create Volume. The Volume Quotas shows:
a. available disk space
b. the number of volumes allocated
c. the number of volumes available
Note: If you are logged in as an Administrator, Nova returns all volumes. When you attempt to
create a new volume through the dashboard, you may see in Volume Quotas there are no
volumes available to create. In this case, log out and log back in as a User rather than an
Administrator.
3. If you are using a snapshot as a source for the new volume, select the snapshot from the field
drop-down and it auto-populates the Volume Name and Size. Enter an optional Description.
4. If you are creating a new volume not based on a snapshot, enter the Volume Name and Size.
Description is optional.
5. Click Create Volume.
6. The volume has been created and is available to attach to VMs.
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Attach a Volume to an Instance
Volumes are disk storage volumes that have been created in a project and can be attached to an
Instance. A volume can only be attached to a single VM at a time, and that VM has sole use of that
volume.

To attach a volume to an instance
1. In the left navigation frame of the Project tab, click Volumes.
2. Select the volume and click
the Status will vary.

, Attach Volume. Attaching is a process that takes time, so

3. The Current Attachments are listed at the top; you attach an instance by making a selection in
the Instance field.

To detach a Volume
Once a volume is attached, Detach Volume is available through the Attach Volume action.

Create a Volume
Volumes are disk storage volumes that can be created in a project and can be attached to an
Instance.

To create a volume
1. In the left navigation frame of the Project tab, select the Current Project.
2. Click Volumes.
3. Click Create Volume.
4. Enter a Name for the snapshot and optionally a Description.
5. Click Create Volume. The new volume is added to the list alphabetically.

Delete a Volume
Deleting a volume means the volume will no longer exist, the data will be lost, it cannot be attached
to any VM, and no user can access. Deleting a volume cannot be undone.

To delete a volume
1. In the left navigation frame of the Project tab, click Volumes.
2. Select the volume and click
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To delete multiple volumes
1. Use the left checkbox(es) to select multiple volumes. To select all, click the top checkbox in
the header row.
2. Click Delete Volumes.
3. You are prompted to confirm your decision.

Force Delete Project Volume
Use the Force Delete option to delete a volume when it appears to be in an unresponsive state. Any
user has the option to Force Delete, which immediately and completely deletes the volume from the
project.

To force delete a volume
1. In the left navigation frame of the Project tab, click Volumes.
2. Select the unresponsive volume and click
indicating the importance of the action.

, Force Delete Volume. This option is red

3. The volume is deleted without prompting and it is removed from the list.

View Project Images
Project Images is a view of only the launchable images (AMI, QCOW2, and RAW format) that can
be used to create new VMs. Images visible here are determined by the "Regions" on page 36.

To view project images
1. In the left navigation frame of the Project tab, select the Current Project.
2. Click Images to display a list of existing images in the project.

To view image details
Click the linked Image Name to view general information, specs, and custom properties for the
image.

Create an Image
Allows you to create and configure an image to upload to the Image Service. Only images available
via an HTTP URL are supported. Compressed image binaries are supported (.zip, .tar.gz)
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To create an image
1. In the left navigation frame of the Project tab, select the Current Project.
2. Click Images.
3. Click Create Image.
4. Enter a Name.
5. Enter the Image Location. This must be a valid and direct URL to the image binary. URLs that
redirect or serve error pages will result in unusable images.
6. Select a Format. NOTE: Only AMI, QCOW2, and RAW images are launchable.
7. Enter Minimum Disk and Ram space.
8. Check Public if you want the image visible to all users.
9. Click Create Image. If successful, the image displays in the list as Active. If creation is not
successful within a specified amount of time (set by your system administrator; typically no
more than five minutes), the Status of the image in the list displays Upload Failed.If you
attempt to download an image with the wrong format, you will get an Error 404, Not Found.

Launch an Image
Only AMI, QCOW2, and RAW format images can be launched. Launching provisions to the cloud.

To launch an image
1. In the left navigation frame of the Domain tab, click Images.
2. Select an image and click Launch.
3. The Project and User tab populate with information from the selected image, so the launch
window opens to the Details tab.
4. Enter the Server Name (required) and edit other details as needed:
a. Server Name - name the host you are creating (required) NOTE: The instance can be
launched at this point, if desired, with system defaults for remaining options.
b. Flavor - Flavor indicates the size of the node. When you select a flavor here, the Flavor
Details table on the left changes to indicate the node properties and values associated with
your size selection.
c. Instance Count - can be more than 1
5. Use the Access & Security tab to control access to your instance via keypairs and security
groups.
e. Select a keypair - Keypairs are ssh credentials which are injected into images when they
are launched. Click (+) to import a keypair. Creating a new keypair here registers the public
key and downloads the private key (a .pem file).
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f. Security Groups - Security groups are one way to provide a measure of network isolation
between different VMs, as they limit the ports into which network traffic can enter the
group. Default is checked.
6. Use the Volume Options tab to select boot options for an instance launching with attached
storage.
7. The Post Creation tab allows you to customize the instance by adding a script to run after
launch of the instance. (The Customization Script field is analogous to "User Data" in other
systems.)
8. Click Launch. If successful, the image is added to the Images list with an Active status.

Edit an Image
Allows you to modify the image name and whether it is public. When you edit an AMI image, you
will see additional fields allowing you to select a Kernel Image and a RAMdisk Image. An AMI
(Amazon Machine Image) is not valid unless it is associated with a kernel image (AKI) and a
RAMdisk image (ARI).

To edit an image
1. In the left navigation frame of the Projects tab, click Images.
2. If the image is in AMI format, click
Image.

, Edit Image. For other image formats, click Edit

3. Edit the Name and Public visibility as desired. If you are editing an AMI image, you can select
a different Kernel Image and a RAMdisk Image.
4. Click Update Image.

Delete an Image
Once an image is deleted, it is no longer possible to create instances based upon that image.

To delete an image
1. In the left navigation frame of the Projects tab, click Images.
2. Select the image and click

, Delete Image. You are prompted to confirm your decision.

3. Click Delete Image. The Images list redisplays and the image has been removed.
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To delete multiple images
1. Use the left checkbox(es) to select multiple images. To select all, click the top checkbox in the
header row.
2. Click Delete Images.
3. You are prompted to confirm your decision.

View Project Snapshots
Snapshots preserve the disk state of running Instances and Volumes. Use the steps below to view
snapshots that were created in the Instances section of the Region tab.

To view project snapshots
1. In the left navigation frame of the Project tab, select the Current Project.
2. Click Snapshots to display a list of existing snapshots in the project.

To view project snapshot details
Click the linked Image Name in the Instance Snapshot list to view image details.

Launch an Instance Snapshot
To launch an instance snapshot
1. In the left navigation frame of the Projects tab, click Snapshots.
2. Select snapshot and click Launch.
3. The Project and User tabs populate with information from the selected image, so the launch
window opens to the Details tab.
4. Select the Instance Source, either Image or Snapshot. The selection in this field determines
what is available in the next field.
5. Select an Instance Snapshot or an Image.
6. Enter the Server Name (required) and edit other details as needed:
n

Server Name - name the host you are creating (required) NOTE: The instance can be
launched at this point, if desired, with system defaults for remaining options.

n

Flavor - Flavor indicates the size of the node. When you select a flavor here, the Flavor
Details table on the left changes to indicate the node properties and values associated with
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your size selection.
n

Instance Count - can be more than 1

7. Use the Access & Security tab to control access to your instance via keypairs and security
groups.
n Select a keypair - Keypairs are ssh credentials which are injected into images when they are
launched. Click (+) to import a keypair. Creating a new keypair here registers the public key
and downloads the private key (a .pem file).
n

Security Groups - a list of all security groups that have been created for this project. Security
groups are one way to provide a measure of network isolation between different VMs, as
they limit the ports into which network traffic can enter the group. The Default group is
checked, but you can add multiple Security Groups.

8. Use the Volume Options tab to select boot options for the instance:
n Don't boot from a volume.
n

Boot from a volume.

n

Boot from volume snapshot (creates a new volume).

9. The Post Creation tab allows you to customize the instance by adding a script to run after
launch of the instance. (The Customization Script field is analogous to "User Data" in other
systems.)
10. Click Launch. If successful, the image is added to the Instance Snapshots list with an Active
status.

Edit an Instance Snapshot
Allows you to modify the Snapshot Name and whether it is public.

To edit an instance snapshot
1. In the left navigation frame of the Project tab, select the Current Project.
2. Click Snapshots to display a list of existing snapshots in the project.
3. Select the snapshot to edit and click

, Edit Snapshot.

4. Edit the Name and Public visibility as desired.
5. Click Update Snapshot.
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Delete an Instance Snapshot
To delete an instance snapshot
1. In the left navigation frame of the Project tab, select the Current Project.
2. Click Snapshots to display a list of existing snapshots in the project.
3. Select the snapshot to delete and click

, Delete Snapshot.

To delete multiple instance snapshots
1. Use the left checkbox(es) to select multiple snapshots. To select all, click the top checkbox in
the header row.
2. Click Delete Snapshots.
3. You are prompted to confirm your decision.

Create a Volume Snapshot
Once you have set up a volume, you can create a snapshot to preserve the current state of the
volume. Volume Snapshots can then be used to start up another VM in the future.

To create a volume snapshot
1. In the left navigation frame of the Project tab, select the Current Project.
2. Click Snapshots.
3. Click Create Volume.
4. Enter a Name for the snapshot., and optionally a Description.
5. Click Create Volume. The new snapshot is added to the list alphabetically.

Delete a Volume Snapshot
Deleting a volume snapshot cannot be undone.

To delete a volume snapshot
1. In the left navigation frame of the Project tab, select the Current Project.
2. Click Snapshots.
3. Select the Volume Snapshot to delete and click
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To delete multiple volume snapshots
1. Use the left checkbox(es) to select multiple volume snapshots. To select all, click the top
checkbox in the header row.
2. Click Delete Volume Snapshots.
3. You are prompted to confirm your decision.

View Project Access & Security
This tab provides a way to view and manage the following elements in the project:
l

Floating IPs - Shows IP addresses that have been allocated for this particular project. These
available Floating IPs can be dynamically associated and disassociated to a project. Floating
IPs that are associated with an instance show the Instance Name and can be disassociated as
needed. Association and disassociation are dynamic, as Floating IPs get associated and then
released back to the pool which makes them available for use to other projects.

l

Security Groups - Security groups provide a measure of network isolation between different
VMs, as they limit the ports into which network traffic can enter the group.

l

Keypairs - Keypairs are SSH security keys that provide authentication and allow you to
exchange traffic securely within the VM.

To view access and security elements
1. In the left navigation frame of the Project tab, select the Current Project.
2. Click Access & Security.

Associate/Disassociate Floating IPs
Associating a Floating IP assigns the address to a particular VM instance.

To associate a floating IP
1. In the left navigation frame of the Project tab, select the project from Current Project.
2. Click Access & Security.
3. From the Floating IPs list, select an address where the Associate Floating IP button is
available. If there are no Floating IPs available, see "Allocate an IP to a Project" on next page
4. Click Associate Floating IP.

Page 65 of 90

HP Cloud Connector

HP Cloud Connector Help
Welcome to HP Cloud Administration Dashboard Help

To disassociate a floating IP
Disassociating makes a floating IP available for association within the same project. Releasing a
Floating IP releases to it the pool and makes it available to all projects.
1. In the left navigation frame of the Project tab, select the project from Current Project
2. Click Access & Security.
3. From the Floating IPs list, select an address where the Disassociate Floating IP button is
available.
4. Click Disassociate Floating IP.

Allocate an IP to a Project
Allows you to allocate additional Floating IP addresses to the project. This process does not assign
the address to a particular instance in the project. Once allocated, these addresses can be
"Associate/Disassociate Floating IPs " on previous pageto a particular instance.

To allocate a floating IP to a project
1. In the left navigation frame of the Project tab, select the project from Current Project.
2. Click Access & Security.
3. From the Floating IPs list, click Allocate IP To Project.
4. Select from the pool and then click Allocate IP.

Release Floating IPs
A Floating IP Address associated to a particular project can be released back to the pool and made
available to other projects.

To release a floating IP
1. In the left navigation frame of the Project tab, select the project from Current Project.
2. Click Access & Security.
3. From the Floating IPs list, select the address and click
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Managing Security Groups with Rules
Security Groups are one way to provide a measure of network isolation between different VMs, as
they limit the ports into which network traffic can enter the group. Within a security group you can
add, edit, and delete rules to specify communications to other ports.

To create a security group
1. In the left navigation frame of the Project tab, select the project from Current Project.
2. Click Access & Security.
3. From the Security Groups list, select Create Security Group.
4. Enter a Name and Description.
5. Click Create Security Group. The group is created and added to the list.

To add security group rules
1. From the Security Groups list, select the group to edit.
2. Click Edit Rules. The top of the edit screen lists the existing rules; the bottom is where you
add.
3. Complete the fields in the Add Rule section:
a. IP Protocol
b. From Port - identifies the source port (Ex: 80)
c. To Port - the port where VMs inside the security group would receive (Ex: 80)
d. Source - identifies the IP addresses from which the group can receive networking traffic
e. CIDR - the format for specifying a range of IP addresses, which includes how many to
create
4. Click Update Security Group Rules.

To delete security group rules
1. From the Security Groups list, select the group to edit.
2. Click Edit Rules. The top of the edit screen lists the existing rules.
3. Check the box(es) for the rule(s) you want to delete, then click Delete Rule.
4. Click Update Security Group Rules.

To delete a security group
You cannot delete the default Security Group.
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1. Select the security group to delete, then click

, Delete Security Group.

2. The system prompts you for confirmation. Click Delete Security Group.

To delete multiple security groups
1. Use the left checkbox(es) to select multiple groups. To select all, click the top checkbox in the
header row.
2. Click Delete Security Groups.
3. You are prompted to confirm your decision.

Managing Keypairs
Keypairs are SSH security keys, 512 bits long, that provide authentication and allow you to
exchange traffic securely within a VM. These credentials are injected into images when they are
launched.
Creating a new keypair registers the public key and downloads the private key (a .pem file),
allowing you to log into the VM. The public key gets installed on the VM; the private key is used to
log in.

To view project keypairs
1. In the left navigation frame of the Project tab, select the Current Project.
2. Click Access & Security. Existing Keypairs are listed in the last grouping in this section.

To create a keypair
1. Click Create Keypair.
2. Enter the Keypair Name. Keypair names can only contain letters, numbers, underscores, and
hyphens.
3. Click Create Keypair. The credentials are downloaded onto your machine.

To import a keypair
1. Click Import Keypair.
2. Enter the Keypair Name. Keypair names can only contain letters, numbers, underscores, and
hyphens.
3. Enter the Public Key.
4. Click Import Keypair.
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To delete a keypair
1. Select the keypair to delete, then click Delete Keypair.
2. The system prompts you for confirmation. Click Delete Keypair.

To delete multiple keypairs
1. Use the left checkbox(es) to select multiple groups. To select all, click the top checkbox in the
header row.
2. Click Delete Keypairs.
3. You are prompted to confirm your decision.

View Topologies
Topologies represent the virtual infrastructures that have been realized when an Infrastructure
Design document is launched in the Cloud Installation Dashboard.

To view topologies
1. In the left navigation frame of the Project tab, select the project from Current Project.
2. Click Topologies.
3. You will see Active states when successfully launched doc and no Task and last updated
column is timestamp.
4. If unsuccessful, then State displays Failed. The Task column displays the error for the failed
activity, and Last Updated column displays the last time Eve or Eden updated that task.

To view content
1. Click a linked Topology Name.
2. The Overview tab displays topology details.
3. The Content tab displays the design document launched in xml format. Export allows you to
download the design document to your computer.
4. The Job tab displays the activity that occurred when the design document was launched. Click
Refresh to get an updated view of launch activity.

Launch a Topology
Allows you to launch the latest version of a design document.
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To launch a topology
1. In the left navigation frame of the Project tab, select the project from Current Project.
2. Click Topologies.
3. Click Launch Topology.
4. Select a design Document (required).
5. Enter a meaningful Infrastructure Name (required).
6. Click Launch. If successful, a green status box confirms the launch and the topology displays
in list. The State column will display Build, followed by Active if successful; Failed if
unsuccessful.

Terminate a Topology
Terminating a topology stops the VM.

To terminate a topology
1. In the left navigation frame of the Project tab, select the project from Current Project.
2. Click Topologies.
3. Select the Topology to terminate, and click Terminate Topology.
4. The State changes to Inactive.

Delete a Topology
Deleting a topology stops the VM and removes it permanently. This action cannot be undone.

To delete a topology
1. In the left navigation frame of the Project tab, select the project from Current Project.
2. Click Topologies.
3. Select the Topology to delete, and click Delete Topology.
4. The topology no longer displays in the list.
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View Documents
A topology document is the result of performing a provision from a design document. Documents
viewable in the Cloud Installation Dashboard Documents tab are the infrastructure topology
templates and resource binding documents (design documents) that are used for provisioning.
Documents are stored in Focus and launched through Eve (see "View Domain Services" on page
22).
An Administrator can view, promote, and set documents to public; a user can view only Public
documents.

To view documents
1. In the left navigation frame of the Project tab, select the Current Project.
2. Click Documents to view the loaded documents:
Field

Description

Document The name of the document.
Name
Version

Shows the promoted version number. Only an Administrator can promote a
document version. Multiple versions of a document can exist, but only one is
promoted (either the most recent or specifically set to another version).

Document There are four different types of documents that can be loaded:
Type
l Infrastructure Topology - describe the set of components that are included in a
particular infrastructure topology and how those components are connected with
each other. Infrastructure topology documents are created in Topology Designer.
l

Infrastructure Types - describes the set of component types that can be used in
a topology documents interacting with Eve. A fixed document that is installed
only once.

l

Infrastructure Design - the resource binding documents with actual property
values defined. In a complex binding document, you would see one binding
element for every node template that exists in the infrastructure topology
template

l

Infrastructure Metadata - these documents show the XY pixel placements of
components generated in Topology Designer.

Public

If Public is True, the promoted version is available to all users.

Project

The project into which the document is loaded.

Actions

Available actions depend on the document type.
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View Document Details
Document details is a read-only view of the following for all document types:
l

General Information

l

Version(s)

l

Properties

To view document details
1. In the left navigation frame of the Projects tab, select the project to view from Current
Project.
2. Click Documents.
3. Click the link on the Document Name. The Document Detail Overview displays.
4. See "Edit Document Details " below to update document properties; see "Edit an Infrastructure
Design" on page 83for information on updating Binding Details.

View Document Content
Used to view the URL, the promoted version number, and the xml content of a selected document.
Content describes one node type.

To view document content
1. In the left navigation frame of the Project tab, select the Current Project.
2. Click Documents.
3. Click the linked Document Name.
4. Click the Content tab to display the xml content.

Edit Document Details
You can edit the following document details:
l

Name

l

Public visibility

l

Properties - Describe metadata about the document.

You cannot change the document Type.
Properties describe metadata about the document.
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Edit details using the following steps or by "View Document Details" on previous page.

To edit document details
1. In the left navigation frame of the Project tab, click Documents.
2. Select the document to edit and click Edit Details.
3. Update the Name and Public if desired. Public indicates whether the document is visible to
users outside the project. The Type field cannot be edited.
4. In the Property Name and Value section you have the following options:
a. Edit existing values
b. Add properties by clicking Add Properties. This adds a new entry line.
c. Delete properties by checking the box and then clicking Delete Properties
5. Click Update Details.

Export Document Content
Allows you to export the xml content of a document to an external file. If content is revised outside
the Cloud Installation Dashboard the new version must be imported.

To export document content
1. In the left navigation frame of the Project tab, select the Current Project.
2. Click Documents.
3. Click the linked Document Name.
4. Click the Content tab to display the xml content.
5. Click Export Content. Depending on your browser setup, the xml file will open automatically
or become available to open.
6. If necessary, edit and save the file.
7. Click Import New Version to "Import a New Document Version" below.

Import a New Document Version
If xml document content is edited outside the Cloud Installation Dashboard, the new version can be
imported.
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To import a new document version
1. In the left navigation frame of the Project tab, select the Current Project.
2. Click Documents.
3. Click the linked Document Name.
4. Click the Content tab to display the current xml content.
5. Click Import New Version.
6. Under Contents, click Choose File. (Name is not editable.)
7. Select an xml file to import and click Open. The file name displays in place of the Choose File
button.
8. Click Import New Version. The Documents list redisplays and the version number
increments.
9. To view details about when a document was last updated, see "View Document Details" on
page 72.

Infrastructure Topology
In HP Continuous Delivery Automation (HP CDA), the Topology Designer enables you to create
and edit infrastructure topologies. You can then use these topologies to create infrastructure
designs for virtual environments.
In the Cloud Administration Dashboard, there are several ways to launch the Topology Designer:
l

Project > Manage Topology > Documents > Create Infrastructure Topology
This approach displays the Create Infrastructure Topology view.

l

Project > Manage Topology > Documents > Document Name link > Edit Content
This approach displays the Edit Infrastructure Topology view.

l

Project > Manage Topology > Documents > Edit Details > Edit Content
This approach displays the Edit Infrastructure Topology view.

Terminology
The following list defines key terms and concepts used in this documentation:
l

Edit Infrastructure View: Where you make changes to your infrastructure topology, including
the Name, Description, Visibility, adding and removing properties, and adding and removing
nodes in the layout diagram. See "Edit an Infrastructure Topology" on page 79, "Edit Document
Properties" on page 80, and "Edit Custom Document Properties" on page 81.

l

Focus: This domain service is a repository of infrastructure topologies and resource binding
documents that are used for provisioning.
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l

Infrastructure Topology: A logical and visual representation of the layout of networking
resources and the connectivity of those resources to each other. When you create an
infrastructure topology, it gets published (promoted) to Focus so that it can be used for
infrastructure designs.A topology can be used to create virtual environments. A single topology
can be used to create multiple infrastructure designs when it is associated with a resource pool.
See "Create an Infrastructure Topology" below.

l

Infrastructure Topology View: Where you can graphically drag and drop topology nodes to
create the visual representation of the topology’s networking resources. The place where the
nodes are dropped is called the topology grid. See "Create an Infrastructure Topology" below.

l

Topology Connections: See "Topology Connections" on page 78.

l

Topology Nodes: Networking resources such as servers and server groups, storage devices,
network segments,load balancers, and configuration management devices. Icons in the
graphical user interface identify these nodes. See "Topology Nodes" on next page.

Related Topics: See "Infrastructure Design" on page 82 and "Create a Resource Pool" on page 86.

Create an Infrastructure Topology
An infrastructure topology is a logical and visual representation of the layout of networking
resources and the connectivity of those resources to each other. When you create an infrastructure
topology in the Topology Designer, it gets published to Focus so that it can be used for
infrastructure designs.
A topology can be used to create virtual environments. A single topology can be used to create
multiple infrastructure designs when it is associated with a resource pool.
Topologies are saved as XML documents that conform to OASIS Topology and Orchestration
Specification for Cloud (TOSCA) format. See https://www.oasis-open.org/committees/tc_
home.php?wg_abbrev=tosca.
Use the Create Infrastructure Topology view to create a topology, by defining the Name,
Description, and Visibility preference, by adding properties and their values, and by adding nodes
and connections in the layout diagram.
To create an infrastructure topology:
1. Use the following navigation path to open the Create Infrastructure Topology view:
Project > Manage Topology > Documents > Create Infrastructure Topology
2. Enter a Name for and a Description of the topology.
3. Select the corresponding icon to specify whether you want this topology to be viewed by all
users in all projects (Public) or only by users in a certain project (Private). The default is
Private.
4. (Optional) Click the Change link to add or remove custom document properties in the Custom
Documents Properties window. See "Edit Custom Document Properties" on page 81.
5. To add a node, select it in the palette and then drop it on the topology grid. See "Add Topology
Nodes" on page 77.
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6. (Optional) If you added a node and then realize you need to delete it, select the node, right-click
it, and then select Delete <name of the node>.
Note: Notice When you select a node, its connections are also selected and deleted.
7. To add connection lines to show the relationships of the nodes, select a node, grab the border
handle, drag your cursor to another node, and the release. See "Add Topology Connections" on
page 78
8. Click the Save icon to save your infrastructure topology in the Focus repository.
Caution: If you do not click Save before you click Close, your changes will not be saved. A
Save Confirmation dialog displays prompting you to click Save to create a new version of the
content or to exit without saving.
9. Click Close to exit the Create Infrastructure Topology view.
Related Topics: "Topology Nodes" below, "Topology Connections" on page 78, "Copy an
Infrastructure Topology" on page 81, and "Edit an Infrastructure Topology" on page 79.

Topology Nodes
In the Create Infrastructure Topology view, an icon palette represents various network resources
that are known as topology nodes. These nodes can be dragged from the palette and then dropped
on to the topology grid to create the logical layout of network resources and the connectivity of
those resources to each other.
Group: A topology node that is a logical representation of a single server or multiple servers
with the same configuration. A server Group node can be connected to all other nodes.
Best Practice: A server Group node must be connected to a Network node to make it accessible to
an end user after it is created in a service.
Storage: A topology node that is a logical representation of a storage device. A Storage node
can only be connected to a server Group node.
Best Practice: A Storage node must be connected to a server Group node to create a valid
topology. Other nodes can be used without connecting to anything.
Network: A topology node that is a logical representation of a network or security group
definition. Only a server Group node, a load Balancer node, and a Management node can be
connected to a Network node.

Balancer: A topology node that is a logical representation of a network load balancer that is
configured on a virtual machine.
Management: A topology node that is a logical representation of a system that provides
configuration support to the nodes in the topology. A Management node can connect to a server
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Group node and a Network node to represent a dedicated system or a system that is instantiated
during provisioning. For example, a Chef server Management node might be used to help configure
and set up server Group nodes in the topology.
Tip: To remove a node from the topology grid, select it, right-click, and then select Delete.
See "Add Topology Nodes" below, "Delete Topology Nodes" below, and "Topology Connections"
on next page.

Add Topology Nodes
To add nodes to a topology, use the Create Infrastructure Topology view or the Edit Infrastructure
Topology view.
To add nodes to the topology diagram:
1. Use one of the following navigation paths to open the view you need:
Project > Manage Topology > Documents > Create Infrastructure Topology
Project > Manage Topology > Documents > Document Name > Edit Content
2. Select a node in the palette and then drag and drop it in the topology grid.
3. (Optional) If you added a node and then realize you need to delete it, select the node, right-click
it, and then select Delete <name of the node>. Notice that when you select a node, the
connections are also selected and deleted.
4. Click the Save icon to save your topology nodes. Each time you save a topology, a new
version of the topology is created in Focus. You can access previous versions of the topology.
See the online Help for information about how to delete a document version.
Caution: If you do not click Save before you click Close, your changes will not be saved.
A Save Confirmation dialog displays prompting you to click Save to create a new version
of the content or to exit without saving.
5. Click Close to exit the view.
Related Topics: "Topology Nodes" on previous page

Delete Topology Nodes
To remove nodes from an infrastructure topology, use the Create Infrastructure Topology view or
the Edit Infrastructure Topology view.
To delete nodes from the topology diagram:
1. Use one of the following navigation paths to open the view you need:
Project > Manage Topology > Documents > Create Infrastructure Topology
Project > Manage Topology > Documents > Document Name > Edit Content
2. Select a node, right-click, and then select Delete. Notice that when you select a node, its
connections are also selected and deleted.
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3. Click the Save icon to save your changes. Each time you save a topology, a new version of the
topology is created in Focus. You can access previous versions of the topology. See the online
Help for information about how to delete a document version.
Caution: If you do not click Save before you click Close, your changes will not be saved.
A Save Confirmation dialog displays prompting you to click Save to create a new version
of the content or to exit without saving.
4. Click Close to exit the view.
Related Topics: "Topology Connections" below and "Topology Nodes" on page 76

Topology Connections
In the Create Infrastructure Topology view, network resources (topology nodes), are associated
with each other by line connectors. Line connectors represent one or more purposes for the
connection between two nodes, even though there is a single line displayed. This design helps
prevent excess visual display and allows the connection to represent multiple networking
relationships.
Tip: To view a summary of node connection relationships, double-click the node in the
topology grid. See the Connections displayed in the left pane.
Related Topics: "Add Topology Connections" below, "Delete Topology Connections" on next page,
and "Topology Nodes" on page 76.

Add Topology Connections
To add node connections in an infrastructure topology, use the Create Infrastructure Topology view
or the Edit Infrastructure Topology view.
To add connection lines in the topology diagram:
1. Use one of the following navigation paths to open the view you need:
Project > Manage Topology > Documents > Create Infrastructure Topology
Project > Manage Topology > Documents > Document Name > Edit Content
2. Select a topology node handle and then drag it to another node to create a connection line.
3. Click the Save icon to save your topology connections. Each time you save a topology, a new
version of the topology is created in Focus. You can access previous versions of the topology.
See the online Help for information about how to delete a document version.
Caution: If you do not click Save before you click Close, your changes will not be saved.
A Save Confirmation dialog displays prompting you to click Save to create a new version
of the content or to exit without saving.
4. Click Close to exit the view.
Related Topics: "Topology Connections" above and "Topology Nodes" on page 76
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Delete Topology Connections
To remove node connections from an infrastructure topology, use the Create Infrastructure
Topology view or the Edit Infrastructure Topology view.
To delete connection lines from the topology diagram:
1. Use one of the following navigation paths to open the view you need:
Project > Manage Topology > Documents > Create Infrastructure Topology
Project > Manage Topology > Documents > Document Name > Edit Content
2. Select a connection line, right-click, and then select Delete relationship.
3. Click the Save icon to save your changes. Each time you save a topology, a new version of the
topology is created in Focus. You can access previous versions of the topology. See the online
Help for information about how to delete a document version.
Caution: If you do not click Save before you click Close, your changes will not be saved.
A Save Confirmation dialog displays prompting you to click Save to create a new version
of the content or to exit without saving.
4. Click Close to exit the view.
Related Topics: "Topology Connections" on previous page and "Topology Nodes" on page 76

Edit an Infrastructure Topology
Use the Edit Infrastructure Topology view to make changes to your topology, including the Name,
Description, Visibility, adding and removing properties, and adding and removing nodes and
connections in the layout diagram.
To edit an infrastructure topology:
1. Use one of the following navigation paths to open the Edit Infrastructure Topology view:
Project > Manage Topology > Documents > Document Name > Edit Content
Project > Manage Topology > Documents > Edit Details > Edit Content
2. (Optional) Change the Name and Description of the topology.
3. (Optional) Change the Visibility option (Public or Private) for the topology.
4. (Optional) Click the Change link to display the Custom Document Properties dialog.
5. In the Custom Document Properties dialog, click Add or Remove to add new properties or
remove existing properties.
Note: By default, no properties are defined. A property name must be unique within the
topology document. If the same name is used twice, the second instance of the property
will overwrite the first instance. A property name is limited to 80 characters. A property
value has an unlimited length and can include any character.
Properties are associated with the overall document container (metadata). Properties are
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not associated with a certain document version.
6. Click Close to save your changes, close the dialog, and return to the Edit Infrastructure
Topology view.
7. (Optional) Select the topology Version that you want to modify. The "Version Being Displayed"
notation indicates the topology version that you are modifying. See the online Help for
information about document versions.
8. (Optional) Make node and connection changes in the topology grid.
9. In the Edit Infrastructure Topology view, click the Save icon to save your changes to the Peer
repository.
Note: Each time you save a topology, a new version of the topology is created in Focus.
You can access previous versions of the topology. You can view different content
versions to review changes made over time or to use a previous version to create an
additional version. Properties are associated with the overall document container
(metadata). Properties are not associated with a certain document version.
If you do not click Save before you click Close, your changes will not be saved. A Save
Confirmation dialog displays prompting you to click Save to create a new version of the
content or to exit without saving.
10. Click Close to exit the Edit Infrastructure Topology view.
Related Topics: "Add Topology Nodes" on page 77, "Delete Topology Nodes" on page 77, "Add
Topology Connections" on page 78, and "Delete Topology Connections" on previous page.

Edit Document Properties
Use the Edit Details window to modify document properties, such as Name, Public or Private
visibility, and metadata.
To edit an infrastructure topology:
1. Use one of the following navigation paths to open the Edit Infrastructure Topology view:
Project > Manage Topology > Documents > Document Name > Edit Details
Project > Manage Topology > Documents > Edit Details > Edit Details
2. (Optional) Change the Name of the topology.
3. (Optional) Change the visibility option (Public or Private) for the topology.
2. Click the Add Properties to insert a row and enter a Property and its Value.
Note: By default, no properties are defined. A property name must be unique within the
topology document. If the same name is used twice, the second instance of the property
will overwrite the first instance. A property name is limited to 80 characters. A property
value has an unlimited length and can include any character. Properties are associated
with the overall document container (metadata). Properties are not associated with a
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certain document version.
Best Practice: Use properties to describe organizational information or to explain the
meaning of an infrastructure topology.
5. To remove a property, select its check box and then click the Delete Properties. You can
select multiple check boxes.
6. Click Update Details to save your changes. Wait for the Success message that confirms your
edits were saved.
Related Topics: "Edit Custom Document Properties" below.

Edit Custom Document Properties
Use the Create Infrastructure Topology view to modify custom document properties.
To edit custom document properties:
1. Use the following navigation path to open the Create Infrastructure Topology view:
Project > Manage Topology > Documents > Create Infrastructure Topology
2. Click the Change link to open the Custom Documents Properties window.
3. Click the Add icon to insert a row and enter a Property and its Value.
Note: By default, no properties are defined. A property name must be unique within the
topology document. If the same name is used twice, the second instance of the property
will overwrite the first instance. A property name is limited to 80 characters. A property
value has an unlimited length and can include any character. Properties are associated
with the overall document container (metadata). Properties are not associated with a
certain document version.
Best Practice: Use properties to describe organizational information or to explain the
meaning of an infrastructure topology.
4. To remove a property, select its check box and then click the Remove icon.
5. Click Close to save your changes.
6. In the dialog, click Yes to save your changes. This action will close the Topology Designer.
7. (Optional) Click the X icon to close the Custom Documents Properties window without saving
your changes.
Related Topics: "Edit Document Properties" on previous page.

Copy an Infrastructure Topology
Use the Create Infrastructure Topology view to make a copy of an infrastructure topology that you
can use as a base for creating a new topology.
To copy an infrastructure topology:
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1. Use the following navigation path to open the Create Infrastructure Topology view:
Project > Manage Topology > Documents > Create Infrastructure Topology
2. Click the Save As icon.
3. In the Save As dialog, enter a new name and then click Save.
4. Make changes to your new topology.
5. Click the Save icon to save your new infrastructure topology in the Peer repository.
Caution: If you do not click Save before you click Close, your changes will not be saved.
A Save Confirmation dialog displays prompting you to click Save to create a new version
of the content or to exit without saving.
6. Click Close to exit the Create Infrastructure Topology view.
Related Topics: "Topology Nodes" on page 76, "Topology Connections" on page 78, and "Edit an
Infrastructure Topology" on page 79.

Infrastructure Design
In Cloud Connector, an infrastructure design is an XML document that refers to and specifies
properties for a TOSCA (an OASIS Topology and Orchestration Specification for Cloud)
infrastructure topology template.
Infrastructure designs are used to provision an Infrastructure as a Service (IaaS). An infrastructure
design is imported into HP Continuous Delivery Automation (HP CDA) to create a platform service
that can then be published as a platform service offering.
You create an infrastructure design by associating it with an infrastructure topology (template). Your
infrastructure design then gets published (promoted) to Focus so that it can be used as a platform
service in HP CDA.
Related Topics: "Create an Infrastructure Design" below and "Infrastructure Topology" on page 74.

Create an Infrastructure Design
Use the Create Infrastructure Design wizard to define a resource binding document, which contains
networking resources that align with the infrastructure topology. A resource binding document
associates a certain infrastructure topology with a certain cloud provider. In a complex resource
binding document, there is one binding element for each node in the infrastructure topology
template.
Best Practice: Before you create an infrastructure design, make sure there is a related
infrastructure topology and resource pool in Peer. If a topology does not exist in the repository, you
must create one before you can create an infrastructure design that will be associated with it.
Values that are marked Modifiable can be overridden when the Infrastructure Design is provisioned
using HP Continuous Delivery Automation (HP CDA).
Note: During Cloud Administration Dashboard setup and configuration, network resources are
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organized into regions that are governed by user security rules. To provision an infrastructure
design, the design must be associated with a resource pool that you have security access to
provision from that region.
To create an infrastructure design:
1. Use the following navigation path to open the Create Infrastructure Design wizard:
Project > Manage Topology > Documents > Create Infrastructure Design
2. Enter a Name for the resource binding document.
3. Select an Infrastructure Topology from the drop-down list. These are topologies that were
created using the Create Infrastructure Topology view in Topology Designer.
4. Select a Resource Pool from the drop-down list. These are resource pools that were created
using the Create Resource Pool wizard in the Cloud Administration Dashboard.
5. Click Next to go to the next step.
6. (Optional) Click Cancel to exit the wizard without saving the resource binding document.
7. In the Edit Contents view, the Topology Name field defaults to the name of the topology
document specified in the Projects tab. This is a required field that is editable.
8. In the Binding Details section, enter information for the Server Group, Volume Group,
Network Segment, Configuration Manager Service, and Load Balance Service.
9. When entering Attached Devices in the Relationships section of the Binding Details, Linux
users should enter devices between /dev/vdc and /dev/vdz. Do not enter /dev/vda or /dev/vdb,
as these devices are being used by the root and ephemeral disk partitions and will cause a
provisioning failure. This applies only to Linux-based instances because the underlying
technology uses nova-volume (an iSCSI solution that employs the use of Logical Volume
Manager (LVM) for Linux).
10. Click Create Infrastructure Design to save your design. Wait for the Success message that
confirms your design was saved.
11. (Optional) Click Cancel to exit the wizard without saving the infrastructure design.
Related Topics: "Create a Resource Pool" on page 86. and "Infrastructure Topology" on page 74.

Edit an Infrastructure Design
Use the Edit Contents view to modify a resource binding document, which contains networking
resources that align with the infrastructure topology. A resource binding document associates a
certain infrastructure topology with a certain cloud provider. In a complex resource binding
document, there is one binding element for each node in the infrastructure topology template.
Values that are marked Modifiable can be overridden when the Infrastructure Design is provisioned
using HP Continuous Delivery Automation (HP CDA).
To edit an infrastructure design:
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1. Use the following navigation path to open the Edit Contents view:
Project > Manage Topology > Documents > Document Type > Edit Content
2. In the Binding Details section, change information about the Server Group, Volume Group,
Network Segment, Configuration Manager Service, and Load Balance Service.
3. When entering Attached Devices in the Relationships section of the Binding Details, Linux
users should enter devices between /dev/vdc and /dev/vdz. Do not enter /dev/vda or /dev/vdb,
as these devices are being used by the root and ephemeral disk partitions and will cause a
provisioning failure. This applies only to Linux-based instances because the underlying
technology uses nova-volume (an iSCSI solution that employs the use of Logical Volume
Manager (LVM) for Linux).
4. Click Update Contents to save your design. Wait for the Success message that confirms
your design was saved.
5. (Optional) Click Cancel to exit the Edit Contents view without saving your changes.

Launch an Infrastructure Design
Launching an Infrastructure Design document provisions that version to the cloud. The design
document is sent to Eve, and Eve parses and makes calls into Cloud Connector to create the VM
with specifications from the binding document.

To launch a design document
1. In the left navigation frame of the Project tab, select the Current Project.
2. Click Documents.
3. Select the Infrastructure Design document.
4. Click Launch. The green status box at the upper right confirms the successful launch.

Import a Document
Allows you to create any of the four document types by importing contents from an external xml file
and adding properties.

To import a document
1. In the left navigation frame of the Project tab, select the Current Project.
2. Click Documents.
3. Click Import Document.
4. Enter a Name.
5. Select a Document Type.
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6. Click Choose File to import a topology or design document file.
7. Click Open to return to the Import Document window.
8. Check Public if you want the document to be visible to users outside the project.
9. Click Add Properties if desired (properties are not required).
10. To delete properties, use the checkbox and then click Delete Properties.
11. Click Import Document. If successful, the document displays in the Documents list.

Promote a Document Version
Promoting can only be done by a Domain Administrator. The promoted version of a topology
document is presented to the user as the default version, whether it is the most recent version or
specifically set to an earlier version. Only versions made Public are available to users.The following
infrastructure document types can be promoted:
l

Topology

l

Design

l

Types

For more detailed information about the various versions of a document, see "View Document
Details" on page 72.

To promote a document version
1. In the left navigation frame of the Project tab, select the Current Project.
2. Click Documents.
3. Select the document type to promote and click

, Promote Version.

4. Select the Default Version; the Name field is not editable
5. Click Promote Version.
6. The documents list redisplays with the new promoted version and a green status box in the
upper right indicates the action was successful.

Delete a Document Version
This option allows you to delete the entire document or any non-default specific version of
document contents. You cannot delete a promoted, public version of a document.
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If you delete an Infrastructure Topology document, the associated binding document is
automatically deleted.

To delete a document version
1. In the left navigation frame of the Project tab, select the Current Project.
2. Click Documents.
3. Select the document to delete and click

, Delete Version.

4. Select the version number or All Versions.
5. Click Delete Version. Without confirmation, the document(s) are deleted and the green status
box indicates success.

Resource Pools
Resource pools are used to access various cloud providers. For multiple regions, one resource pool
is required for each region.
Peer is the service used for resource pool registry. Every time you want to access a different cloud
provider, you must define a new record in the Peer Resource Pool Registry. These records then
define how to access a particular cloud provider.
Related Topics: "Create a Resource Pool" below, "Edit a Resource Pool" on next page, "Domains"
on page 22 and "Regions" on page 36.

Create a Resource Pool
Use the Create Resource Pool wizard to specify resource pool definitions that will be used during
topology provisioning.
To create a resource pool:
1. Use the following navigation path to open the Create Resource Pool wizard:
Project > Manage Topology > Resource Pools > Create Resource Pool
2. From the drop-down list, select a Cloud Type to create a resource pool when you are using
local (on premise services) or HP Cloud services. When you specify a Cloud Type,
information in the remaining sections is automatically populated. If you do not select a Cloud
Type, you must enter information in the remaining sections.
l

HP Cloud Infrastructure - OpenStack (Essex): Provides values for the Cloud Connector
environment. Provider Credentials are not required.

l

HP Cloud - OpenStack (Diablo): Provides values for the HP Cloud Services environment.
Provider Credentials are required.

l

Custom - OpenStack (Essex): Provides maximum flexibility when you are creating a resource
pool. Details and Provider Credentials are enabled.
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1. From the drop-down list, select a Compute Region to create a resource pool when you are
using local (on premise services) or HP Cloud services. If you do not select a Compute
Region, you must enter information in the remaining fields.
2. In the resource pool Details section, enter a Name. The Type, Version, Region ID, and
Domain URL are derived from the Cloud Type and Compute Region you selected.
3. In the Provider Credentials section, enter a Tenant ID, User Name, and Password. Enter
the password again in Confirm Password to validate.
n

If you are using a local (on premise service), such as OpenStack, you do not need an account
on that service to create and edit resource pools.

n

If you are using a remote service, such as HP Cloud or Rackspace, you must have an
account on that cloud provider's system to create and edit resource pools.

4. Click Create Resource Pool to save it. Wait for the Success message that confirms your
changes were saved.
5. (Optional) Click Cancel to exit the Create Resource Pool wizard without saving.
Related Topics: "Edit a Resource Pool" below and "Edit a Resource Pool Service" on next page.

Edit a Resource Pool
Use the Edit Resource Pool view to update resource pool definitions that will be used during
topology provisioning. In common use cases, you can:
l

Change the name of the resource pool.

l

Switch to a new region.

l

Update the OpenStack server domain URL.

l

Modify different provider credentials when the resource is an HP Cloud.

l

Modify values that were not accurate when you originally entered them.
Note: If you are using HP Cloud and your password on that system changed, you must also
change it in the Edit Resource Pool view.

To update resource pool definitions:
1. Use the following navigation path to open the Edit Resource Pool view:
Project > Manage Topology > Resource Pools > Edit Resource Pool
2. In the Details section, modify the Name, Type, Version, Region ID, and Domain URL.
3. Depending on the Cloud Type, in the Provider Credentials section, modify the Tenant ID,
User Name, and Password. Enter the password again in Confirm Password to validate. See
"Create a Resource Pool" on previous page.
4. Click Update Resource Pool to save your changes. Wait for the Success message that
confirms your changes were saved.
5. (Optional) Click Cancel to exit the Edit Resource Pool view without saving your changes.
Related Topic: "Edit a Resource Pool Service" on next page.
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Delete a Resource Pool
Caution: Make sure you really want to delete a resource pool. Deleted resource pools cannot
be restored. You have to recreate them.
Use the Resource Pools view to delete a single resource pool or multiple resource pools from Peer.
Best Practice: Delete the resource pool after deleting all services that were using that resource
pool. If the environment that the resource pool no longer exists, delete the resource pool.
Note: In Cloud Administration Dashboard, you can delete a resource pool even if a service is
provisioned using that resource pool. Also, after the resource pool is deleted, the deprovisioning operation will still succeed.
To delete a single resource pool:
1. In the Resource Pools view, highlight one Resource Pool Name.
2. In the Actions column, in the Edit Resource Pool drop-down list, select the Delete Resource
Pool action.
To delete multiple resource pools:
1. In the Resource pools view, select the check box next to multiple Resource Pool Names.
2. Click Delete Resource Pools.

Edit a Resource Pool Service
Use the Edit Resource Pool Services view to add and delete services to and from a resource pool.
A service definition uses the model and version properties to identify an infrastructure service that
is realized using the specified image/flavor combination. If you find problems in particular
model/version, you might be required to add a new resource pool service.
Best Practice: To prevent anyone from using the previous resource pool service that caused
problems, be sure and delete it from Peer.
To edit a resource pool service:
1. Use the following navigation path to open the Edit Resource Pool Services view:
Project > Manage Topology > Resource Pools
2. In the Resource Pools view, from the Edit Resource Pool drop-down list, select the Edit
Services action.
3. In the blank services row, enter the Name, Type, Model, Version, Flavor ID, and select an
Image ID (if you have images loaded). Click Update Resource Pool Services to save your
changes.
4. (Optional) In the Edit Resource Pool Services view, click Add Service to create a new service
entry row.
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5. (Optional) In the Edit Resource Pool Services view, select the check boxes next to the Names
of the services you want to remove and then click Delete Services. Click Update Resource
Pool Services to save your changes.
6. Wait for the Success message that confirms your changes were saved.
7. (Optional) Click Cancel to exit the Edit Resource Pools Services view without saving your
changes.
Related Topic: "Edit a Resource Pool" on page 87.
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