
  

Rev. A  

HP ART 4.40 to ART 

5.10 Delta Training 

Training Guide 
 

Note: This HP ART 4.40 to 5.10 Delta Course is a printable version of the online ART Delta 

course available free of charge on the HP Software Education website. When possible, it is 

our recommendation that you take the online version as we believe you will find it to be more 

interactive and a better learning experience. 

 

Use of this material to deliver training without prior written permission from HP is prohibited.  

 

http://h20546.www2.hp.com/main/


  



 

  
HP ART 4.40 to ART 5.10 Delta 

Training 

Training Guide 
 

Revision A  



 

 Copyright 2013 Hewlett-Packard Development Company, L.P. 

The information contained herein is subject to change without notice. The only warranties 

for HP products and services are set forth in the express warranty statements 

accompanying such products and services. Nothing herein should be construed as 

constituting an additional warranty. HP shall not be liable for technical or editorial errors 

or omissions contained herein. 

This is an HP copyrighted work that may not be reproduced without the written 

permission of HP. You may not use these materials to deliver training to any person 

outside of your organization without the written permission of HP. 

Printed in the USA 

HP ART 4.40 to ART 5.10 Delta Training 

Training  Guide 

August 2013 



v 

  Copyright 2013 Hewlett-Packard Development Company, L.P. 

 

 

Table of Contents 

 

 

Introduction .................................................................................................... 2 

Product Branding ............................................................................................. 3 

Supported Environments ................................................................................... 4 

Author DevKit Installation .................................................................................. 5 

Template and Skin Activation ............................................................................ 6 

Accessing your Local Template and Skin ............................................................ 7 

Prerequisites for Customizing the Template .......................................................... 8 

Managing Custom Skins .................................................................................. 9 

Text to Speech (TTS) ........................................................................................ 10 

TTS General Settings ....................................................................................... 11 

Enable TTS – Course ....................................................................................... 12 

Enable TTS – Simulation .................................................................................. 13 

TTS File Properties .......................................................................................... 14 

Demonstration: Configuring Text to Speech ........................................................ 15 

Recording (.udc) Features ................................................................................ 16 

Capture Audio While Recording ...................................................................... 17 

About Captured Audio .................................................................................... 18 

Demonstration: Capture Audio During Recording ............................................... 19 

Capture Notes While Recording...................................................................... 20 

Course (.ulc) Features ...................................................................................... 21 

Resources and Image Management ................................................................. 22 

Adding a Resource ........................................................................................ 23 

Linking Resources .......................................................................................... 24 

Demonstration: Link a Resource to a Course Page .............................................. 25 

Manage Images ............................................................................................ 26 

Support of Animated GIFs .............................................................................. 27 

Manage Embedded Simulations ...................................................................... 28 

Simulation Stencil .......................................................................................... 29 



vi 

 Copyright 2013 Hewlett-Packard Development Company, L.P. 

 

Insert Simulations .......................................................................................... 30 

Demonstration: Manage Embedded Simulations ................................................ 31 

Assessment Stencils ........................................................................................ 32 

Hot Spot - Single Stencil ................................................................................. 33 

Example: Hotspot – Single .............................................................................. 34 

Configure Hotspot Stamp ............................................................................... 35 

Drag and Drop Sequencing Stencil .................................................................. 36 

Example: Drag and Drop – Sequencing ........................................................... 37 

HP ART Website ............................................................................................ 38 

ART Website Hierarchy .................................................................................. 39 

Website Organization.................................................................................... 40 

ART Product Launch Page ................................................................................ 41 

Course Launch Page ...................................................................................... 42 

Module Launch Page ..................................................................................... 43 

How to Create the ART 5.10 Website ............................................................... 44 

Adding Related Documents ............................................................................. 45 

Demonstration: Add Related Documents ........................................................... 46 

End of Course ............................................................................................... 47 

 



Page 1 of 48 
 Copyright 2013 Hewlett-Packard Development Company, L.P. 

 

HP ART 4.40 to ART 5.10 Delta Training 
 
 

 

 

 

Note: This HP ART 4.40 to 5.10 Delta Course is a printable version of the online ART Delta 
course available free of charge on the HP Software Education website. When possible, it is 
our recommendation that you take the online version as we believe you will find it to be more 
interactive and a better learning experience. 

 

 
  

 
 
HP Adoption Readiness Tool (ART) 5.10 
ART 4.40 to ART 5.10 Delta Training 
August 2013 

 

http://h20546.www2.hp.com/main/�


HP ART 4.40 to ART 5.10 Delta Training  

Page 2 of 48 
 Copyright 2013 Hewlett-Packard Development Company, L.P. 

 

 

 

 
  

Introduction 
 

This delta course provides an introduction to the 
new features of HP Adoption Readiness Tool 
(ART) 5.10. 
 
The material contained in this course is intended 
for all users of the ART 4.40 product. 
 
The course is organized into the following topics: 

• Product branding 
• Supported environments 
• DevKit installation 
• Text to speech (TTS) 
• Recording (.udc) features 
• Course (.ulc) features 
• ART website features 
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Product Branding 
 
ART 5.10 contains new product branding to 
support new HP marketing standards: 

• Product installation screens 
• Product icons 
• Course skin 
• Simulation skin 
• Website launch pages 

 
The HP ART template contains all product 
branding customizations and skins, which 
are included in the install package. 
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Supported Environments 
 
ART 5.10 supports the following new environments: 

• DevKit: 
o Microsoft Windows 8 (Desktop) 

• Published content: 
o Microsoft Internet Explorer 10 
o Google Chrome 
o Static/dynamic Adobe interactive forms 

 Rendered in Adobe Reader or Acrobat XI 
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1. The Custom folder holds the template and skin files that are to be added during 
installation. The Custom folder must reside at the same level as the 
HP_ART_5.10.0.full.exe installation file. 

2. Within the Custom folder is a CourseSkins folder that holds the custom skin file 
to be added during installation. This folder must be named exactly as shown 
here for ART to recognize it. 

3. The Custom folder includes the Templates folder that holds the HP ART 5.10 
template file to be added during installation. This folder must be named exactly 
as shown here for ART to recognize it. 

4. The CourseSkins folder includes a customized skin (HPART-Rounded) that ART 
uses to create the prebuilt ART 5.10 content. 

5. The Templates folder includes the HP ART 5.10 template used to create the 
prebuilt ART 5.10 content. 

  

Author DevKit Installation 
 

New in ART 5.10, the HP ART template and skin are 
automatically installed during the installation process of 
the ART DevKit. 
 
During installation, ART picks up the template and skin 
located in the Custom folder. 
 

 Hover over each icon to explore this topic. 
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Template and Skin Activation 
 
After installation, the HP ART 5.10 template and skin are located within your ART installation folder. 
 

 
 
To active the template and skin, simply open the ART 5.10 editor. During this process, the template and skin are 
pulled from the HP Adoption Readiness Tool installation folder and placed in your local resources folder within 
your environment. This local template and skin are used for all content development going forward.  
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Accessing your Local Template and Skin 
 
Once your template and skin have been activated, they are accessible within your local resources folder. Using 
the Windows Start menu, navigate to HP Adoption Readiness Tool Resources.  All resources used by the ART 
application are stored in your local resources folder. 
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Prerequisites for Customizing the Template 
 

Each time you launch the ART editor, ART will validate that the HP ART 5.10 Template is available in your local 
resources folder. If the template is not found, ART will automatically copy the template into your local resources 
folder.  If you are planning on customizing the HP ART 5.10 template, please perform the following tasks: 

1. Open the ART Editor to ensure your template and skin have been activated. 
2. Navigate to your HP Adoption Readiness Tool installation folder. 
3. Navigate to the Client > appdata >Templates folder. 
4. . 

 
 

5. Remove the template from this folder and place in a backup location. 
6. Open your template using File > Open Template and begin customization. 
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1. The Manage Local Custom Skins feature is accessed within the File menu. 

2. The Skins pane lists all custom skins. 

3. You use the Import button to import a custom skin to your local resources. The 
imported skin must have the .uskin file extension.   

4. You use the Export button to export a selected skin to your local drive. 
Exported skins are saved with the .uskin file extension. 

5. You use the Remove button to remove a custom skin from your local resources 
folder. 

  

Managing Custom 
Skins 
 New in HP ART 5.10, you can manage custom 
skins using the Manage Local Custom Skins 
feature. 
 
This feature is used if you have customized your 
skin and you would like to share the skin with 
others in your organization. 

 Hover over each icon to explore this topic. 
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Text to Speech (TTS) 
 

ART 5.10 supports Text to Speech (TTS) for both courses 
and simulations. 
 
TTS provides accessible outputs for visually impaired users. 
ART lets you convert course text and simulation step text into 
speech. Authors can configure ART to automatically convert 
text to audio that is available to the end user when playing the 
published output. 
 
In addition, TTS allows audio to be translated and used in 
conjunction with XLIFF files. 
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1. To access configuration settings for TTS, select the General tab. 

2. You access TTS configuration options using the Text to Speech menu item. 

3. The Store generated audio within documents and courses option saves the 
generated audio with the source content. This feature allows authors to play 
the generated audio from the HP ART editor without having text-to-speech 
voices installed on their computer. 
 
If this setting is disabled, ART only saves the text-to-speech audio when the 
document or course is published. 

Note: Storing text-to-speech audio within the source file increases the size of the document or 
course. 

4. Pause length setting changes the length of the pause between words for text-to-
speech playback 

5. You use the Available voices section to select the language. You can configure 
a different language for each language listed. 

6. The Configure button configures the voice settings for each language. 

  

TTS General 
Settings 
 

You manage TTS configuration 
within the HP ART template. 
 
The General settings area of the 
template allows you to: 

• Store generated audio 
within documents and 
courses 

• Configure the available 
voices for each 
language 

 Hover over each icon to 
learn more about this topic. 
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1. To enable TTS for published courses, select the Publications tab. 

2. Select the Course menu item within the Default Publications Settings section. 

3. You enable TTS from the Audio source drop-down menu. 

You must set the audio source to one of the available TTS options to enable TTS. If you select 
the Manual audio source, TTS is disabled for all course pages. 

Note:  If one of the TTS options is selected, the author can modify the audio settings for a 
specific course page.  If Manual is selected, the author cannot enable TTS within a course 
page. 
  

Enable TTS - 
Course 
 To enable the TTS feature for 
published courses, you must adjust the 
audio settings to one of the available 
TTS options within the Course 
Publications section of the template. 

 Hover over each icon to explore 
this topic. 
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1. To enable TTS for published simulations, select the Publications tab. 

2. Select the Simulation menu item within the Default Publications section. 

3. You enable TTS from the Audio source drop-down menu. 

You must set the audio source to one of the available TTS options to enable TTS. If the Manual 
audio source is selected, TTS will be disabled for all simulation steps. 

Note:  If one of the TTS options is selected, the author can modify the audio settings for a 
specific recording step.  If Manual is selected, the author cannot enable TTS within a 
recording. 
  

Enable TTS - 
Simulation 
 To enable the TTS feature for 
published simulations, you must 
set the audio settings to one of 
the available TTS options within 
the Simulation Publications 
section of the template. 

 Hover over each icon to 
explore this topic. 
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TTS File 
Properties 
 
Within the course (.ulc) and recording 
(.udc) files, the Properties window has 
a new Text to Speech menu option. 
 
You can use the Text to Speech menu 
option to configure the voice used in 
the selected course or recording file. 
This feature lets you override the 
default template selection. 
 
Note that you must enable TTS in the 
template for the course or simulation 
when using this feature. 
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Demonstration: Configuring 
Text to Speech 
 In this demonstration, you learn how to configure voices 
for TTS, and enable TTS for published courses and 
simulations. 

Note: To view this demonstration, please access the HP ART 
4.40 to 5.10 Delta Online ART Course available as a free of 
charge course on the HP Software Education website. 
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Recording (.udc) Features 
 

The following ART 5.10 features are specific to recording 
(.udc) files: 

• Ability to capture audio while recording 
• Ability to add information notes while recording 
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1. You use the Record/Pause toggle button to begin and pause your recording. You can only 
capture audio when the recorder is enabled. When paused, audio is not captured. 

2. You use the Audio toggle button to capture audio during the recording process. When first 
clicked, you are prompted to test your audio. 

Tip: Do not speak while performing a task, such as typing. Rather, speak before or after 
performing the task. 
  

Capture Audio While 
Recording 
 ART 5.10 allows you to capture audio while recording a task in 
the application. 
 
While in recording mode, the audio toolbar button acts as a toggle 
to start and stop the audio capture feature. 
 
Tip:  When capturing audio, speak before or after typing or mouse-
click actions.  Do not speak at the same time that you are 
performing the action.  
 

 Hover over each icon to explore this topic. 
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About Captured Audio 
 

ART captures and stores audio with each step. After you stop recording, you can access audio files within the 
Step Properties window under the Audio menu item. This feature enables authors to review/edit audio on a per 
step basis. 
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Demonstration: Capture 
Audio During Recording 
 In this demonstration, you learn how to capture audio while 
recording a task in ART 5.10. 

Note: To view this demonstration, please access the HP ART 
4.40 to 5.10 Delta Online ART Course available as a free of 
charge course on the HP Software Education website. 
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1. You toggle the Record/Pause button to start and pause your recording. You can still add 
notes to the recording when the recording is paused. 

2. You use the Add Note button to add an information note during the recording process. The 
note appears in the upper left of the window. You can add multiple notes to a single step. 
  

Capture Notes While Recording 

In ART 5.10, you have the option to add information notes while 
recording an application. 
 
This feature allows you to add details and/or instructions to a task 
step during the recording phase, while the action is being 
performed. 
 
You add notes to the upper left of the recording window. 
 

 Hover over each icon to explore this topic. 
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Course (.ulc) Features 
 

ART 5.10 offers the following new features that are specific 
to course (.ulc) files: 

• Resource management 
• Image management 
• Support for animated GIFs 
• Updated simulation stencils 
• Embedded simulation management 
• New assessment stencils: 

o Hotspot Single 
o Drag and Drop Sequencing 
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Resources and Image 
Management 
 Managing resources and images has changed. 
 
Recall that resources are links and/or documents 
that can be added to a course for additional 
information. For example, you can attach URLs, 
PDF documents, MS Word documents, MS Excel 
spreadsheets, and so forth, to a course. 
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1. To add a new resource to a course, select the Add button. 

2. Enter the name of the resource in the Name field. The name appears in the Downloads 
menu of the published course. 

3. Enter a description of the resource in the Description field. The description appears directly 
under the name within the Downloads menu. 

4. Within the Content section, select the resource details. There are two options: 

• URL - Type the fully qualified path to the URL. 
• Document - Browse to the location of the document.  

The document is embedded with the course once added. 

5. Click the OK button to save and exit. 

 

 
  

Adding a Resource 
 

In ART 4.40, you managed resources using the 
File > Resources menu item. 
 
In ART 5.10, you use the Manage > Resources 
menu item to  manage resources:  
 

  
. 

  Hover over each icon to explore this topic. 
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1. Select Resource Link in the Type field. 

2. Select the desired resource from the available list.  

Tip: You must first add the resource to the course before adding a resource link. 

3. Click the Open in new Window checkbox if you would like your document opened in 
a separate window. 

4. The Localized checkbox is used to mark the content for localization. 

5. Click the OK button to save and exit. 

  

Linking Resources 
 

New in ART 5.10, you can link a resource within a 
course page or within a hotspot pop-up window. 
To link a resource, highlight the text within the 
course page or the hotspot text area, right-click, 
and select Insert > Insert Link. 
 

 
 Hover over each icon to explore this topic. 
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Demonstration: Link a 
Resource to a Course Page 
 In this demonstration, you learn how to add and link a 
resource to a course page. 

Note: To view this demonstration, please access the HP ART 
4.40 to 5.10 Delta Online ART Course available as a free of 
charge course on the HP Software Education website. 
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1. You can use all images in the Available Images section in the course. 

2. Click the Add button to add a new image to the course.  

Note: When you exit the ART editor, all images that are not being used in the course are 
removed. 

3. Click the Show Preview button to view the image in full size. 
  

Manage Images 
 

In ART 5.10, you can access all images 
contained in a course within a new 
images library. 
 
To access the image library, select 
Manage > Images from the course editor 
menu. 
 

 

 Hover over each icon to explore this 
topic. 
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Support of Animated 
GIFs 
 ART 5.10 supports animated GIFs. 
 
You can insert animated GIFs in the 
image pane using the same process as 
other images. 
 
Animations play both in Preview and 
Publish modes. 
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1. You set the Local Source File Location field to the folder where the embedded recording 
(.udc) files are located. All recording (.udc) source files linked to the course must reside in the 
same folder. 

2. The Embedded Simulations window displays all recording (.udc) files in the local source file 
location and includes the recording's name, file name, file location, and status. 
  

Manage 
Embedded 
Simulations 
 The Manage Embedded Simulations 
feature allows you to view, update, and 
publish all embedded simulations from 
within a single window. 
 
You access embedded simulations by 
selecting the Manage >Embedded 
Simulations menu item. 
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1. The content block of the simulation stencil is larger in ART 5.10. Simulation buttons are not 
displayed on the stencil until selected using the Edit Simulation Properties link. 

As you select different outmode modes, the content block size adjusts to allow room for the 
added buttons. 

2. The image block within the simulation stencil is fixed in size. The optimal image size is 
415x355. 

3. You use the Edit Simulation Properties link to select the simulation to embed in the page 
and the output mode visibility.  

4. You use the Update Simulations link to publish the embedded simulations in the course. 
  

Simulation 
Stencil 
 The simulation stencils 
have been redesigned to 
support the new Manage 
Embedded Simulation 
feature. 

 Hover over each icon 
to explore this topic.  
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1. The Insert drop-down menu has two options: 

• Simulation: Lists all of the simulations that are currently embedded in the course 

• Local: Lists all of the recordings contained within the Local directory 

2. The Source directory field displays the full path of the local directory. 

3. The Source File section displays the list of available recordings.  

The recordings listed depend on the selected value of the Insert drop-down menu: 

• Simulation: All recordings that are embedded in the course 

• Local: All recordings that are stored in the local directory 

4. You use the Mode visibility checkboxes to define which output modes are available for the 
selected course page. Only the selected output modes are available in the published course. 

5. You use the Localized checkbox to mark the content for localization. 
  

Insert 
Simulations 
 You add embedded simulations 
to a course page using the Insert 
Simulation window. 

 Hover over each icon to 
explore this topic. 
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Demonstration: Manage Embedded 
Simulations 
 
In this demonstration, you learn how to manage embedded 
simulations in ART 5.10. 

Note: To view this demonstration, please access the HP ART 
4.40 to 5.10 Delta Online ART Course available as a free of 
charge course on the HP Software Education website. 

 

 

http://h20546.www2.hp.com/main/�


HP ART 4.40 to ART 5.10 Delta Training  

Page 32 of 48 
 Copyright 2013 Hewlett-Packard Development Company, L.P. 

 

 

 

 
  

Assessment Stencils 
 
ART 5.10 has two new assessment stencils: 

• Hot Spot - Single 
• Drag and Drop - Sequencing 
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1. A hotspot stamp is the icon displayed on the image that learners use to make their 
selections during the assessment. 

2. After the learner makes a selection, the learner clicks the Continue button. 

3. The learner uses the Reset button to start over the selection. 

4. The learner uses the Show Me button to view the answer to the question.  When selected, 
the question is marked as incorrect. 
  

Hot Spot - 
Single Stencil 
 You use the Hot Spot - Single 
stencil for learning checks and 
assessments. 
 
The stencil contains a text and 
image content area.  You can 
define a hotspot area within 
the image as the correct 
response. 

 Hover over each icon to 
explore this topic. 
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This page provides an example of the Hotspot - Single assessment stencil.  
Using the mouse, click the correct location on the image below. 
 
Where is the laptop in this 
picture? 
 

Note: This is not an active 
assessment question. 
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1. You define the hotspot image used in the Hotspot - Single assessment page in the Stamp 
drop-down menu. 

Note: The images that are available from the Stamp drop-down menu are the hotspot images 
added in the General tab of the template. 

2. You use the Color field to select the background color of the hotspot area. The default 
value in the ART template is Transparent. 
  

Configure Hotspot 
Stamp 
 The stamp icon used in the Single - Hotspot 
stencil is configured in the template. 
 

 Hover over each icon to explore this topic. 
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1. The left-side sequence list displays the order that the items appear in the learning check or 
assessment. 

2. You use the left/right arrows to copy the elements from the left-side sequence list to the 
right-side sequence list to specify the desired correct order. The right-side sequence list is the 
correct order of the items. The learner must match the order displayed on the right side to 
obtain the correct answer.  

3. You use the left/right arrows to copy the elements from the left-side sequence list to the 
right-side sequence list to specify the desired correct order. 

4. You use the up/down arrows to move the elements within the right-side sequence list to 
obtain the desired correct order. You use the left/right arrows to copy the elements from the 
left-side sequence list to the right-side sequence list to specify the desired correct order. 
  

Drag and 
Drop 
Sequencing 

 
 
 

You use the Drag and Drop 
- Sequencing stencil for 
learning checks and 
assessments. 
 
The stencil creates an 
interaction page featuring 
one or more draggable 
responses to a single 
question. 
 

 Hover over each icon 
to explore this topic. 
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This page provides an example of the Drag and Drop - Sequencing assessment stencil.  
 
Drag each element from the left pane to the right pane in the correct order. 
 
What is the sequential order of the items below? 
 

One 
 
Five 
 
Three 
 
Two 
 
Four 
 
Note: This is not an active assessment question. 

 

 

One 
Two 
Three 
Four 
Five 
 



HP ART 4.40 to ART 5.10 Delta Training  

Page 38 of 48 
 Copyright 2013 Hewlett-Packard Development Company, L.P. 

 

 

 

 
  

HP ART Website 
 

The following updates have been 
made to the ART 5.10 website: 

• Website launch pages have 
been rebranded to support 
the latest HP marketing 
standards. 

• New processes are 
defined for the management 
of the website structure. 

• Related documents can be 
added to the ART website. 

• Website portability has been 
enhanced by the use of 
relative paths when creating 
the website. 
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1. The top level of the ART website is the ART product. The ART product web page introduces 
you to ART. This page includes a short introduction to ART, as well as the prerequisites 
required to view ART content.  

2. The second level of the ART website is the ART course web page. The course web page 
introduces you to the selected HP Software ART course. The course launch page includes an 
overview of the HP Software ART course, including the learning objectives.    

All HP Software ART courses consist of several modules. The modules that are included in the 
selected course are accessible from the left navigation of the course launch page. 

3. The Module launch page provides access to the ART content.  

You can either launch the eLearning course module directly by clicking the Launch Module 
button or, to quickly master a specific task, by launching a simulation or job aid within the 
Launch Simulation or Launch Job Aid sections. 
  

ART Website 
Hierarchy 
 The ART 5.10 website is organized into 
three levels: 

• ART product 
• HPSW ART course 
• Course modules 

 Hover over each icon to explore this 
topic. 
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1. The PORTFOLIO field is a classification that Hewlett-Packard uses to categorize all HP 
Software products. Although the PORTFOLIO field is populated for all files, it is ignored during 
website organization. The software only uses the Product and Module fields to create the final 
website structure. 

2. The Product field refers to the HP Software product of the ART course. 

3. Each module in an HP Software ART course has one course file and one or more 
embedded recordings. The course (.ulc) file and each of the embedded recording (.udc) files 
for the module must have the exact same module name in the Module field so the ART website 
can organize the files appropriately. 
  

Website 
Organization 
 Shown here is a sample ART 
website source file for the HP 
Service Manager 9.3 ART 
product. 
 
Each file in the website source 
file is organized by portfolio, 
product, and module. 

 Hover over each icon to 
explore this topic. 
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ART Product Launch Page 
 

The first page of the ART website introduces you to the ART product. This page includes a short introduction to 
ART, as well as the prerequisites required to view ART content.  Each HP Software ART course included in the 
website is accessible from the left navigation under the Select a Course heading. 
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Course Launch Page 
 

The second level of the ART website is the Course web page.  The Course web page is intended to introduce you 
to the selected HP Software ART course.   In the example below, the Cloud Service Automation (CSA) 3.1 ART 
course launch page is displayed.  The Course launch page includes an overview of the HP Software ART course, 
including the learning objectives.    
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Module Launch Page 
 

The module launch page provides access to the ART content. You can either launch the e-learning course 
module directly by clicking the Launch Module button or, to quickly master a specific task, by launching a 
simulation or job aid within the Launch Simulation or Launch Job Aid sections. 
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How to Create the ART 5.10 
Website 
 When you purchase an ART course, the ART website output files 
are included in the content package within the output folder.  
If you want to create your own ART website, or customize the 
existing website, the high-level steps to create and ART 5.10 
website are: 

1. Prepare the ART files. 
2. Create the website (.us) file. 
3. Insert the source content files. 
4. Organize the website. 
5. Create the ART product launch page. 
6. Create the course launch page. 
7. Organize the website with new launch pages. 
8. Batch publish the source files. 
9. Publish the website. 

 
See the Creating the ART 5.10 Website document for detailed 
information on how to perform these steps. 
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Adding Related Documents 
 

New in ART 5.10, you can add related documents to the ART website. Once the file is added to the website, use 
the file properties to control where the document is displayed on the website. 

 
 



HP ART 4.40 to ART 5.10 Delta Training  

Page 46 of 48 
 Copyright 2013 Hewlett-Packard Development Company, L.P. 

 

 

 

 
 

 

  

Demonstration: Add a 
Related Document 
 In this demonstration, you learn how to add a related 
document to the HP ART 5.10 website. 
 

Note: To view this demonstration, please access the HP ART 
4.40 to 5.10 Delta Online ART Course available as a free of 
charge course on the HP Software Education website. 

 

 

http://h20546.www2.hp.com/main/�
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End of Course 
 

This concludes the ART 5.10 delta 
training. 

In addition to the standard reference 
guides, we are providing additional 
documentation to our customers who 
are actively using 4.40 and now 
moving to 5.10. 
 
 You can find the additional 
documentation on the Software 
Support Online (SSO) HP Software 
Product Manuals page. 

 
 

 

http://support.openview.hp.com/selfsolve/manuals�
http://support.openview.hp.com/selfsolve/manuals�
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Introduction 
The HP Adoption Readiness Tool (HP ART) is an innovative authoring tool that allows 
consultants and clients to create customized training, documentation and support content, whether 
starting with HP prebuilt content or creating new material. As a single source, multiple output, 
object recognition technology, HP ART dramatically reduces content development time and 
improves software adoption.   

This guide contains high-level step-by-step instructions to create the HP ART 5.10 website. This 
guide is designed as a supplemental support document only and is not intended to be a 
replacement for training.  

For additional information on ART and ART Training and Services, contact your HPSW Sales 
Representative today or contact hpsoftware.art@hp.com for further information. 

This document is updated based on consumer feedback. Please check the Software Support 
Online (SSO) HP Software Product Manuals page to ensure you have the current version. 

  

mailto:hpsoftware.art@hp.com�
http://support.openview.hp.com/selfsolve/manuals�
http://support.openview.hp.com/selfsolve/manuals�
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HP ART 5.10 Website Structure 
 

The HP ART 5.10 website is organized into three levels, each represented by a separate web 
page. 
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ART Product Launch Page 

 

The top level of the ART website is the ART product.  The ART product web page introduces you to 
ART. This page includes a short introduction to ART, as well as the prerequisites required to view 
ART content. You can access each HP Software ART course included in the website from the left 
navigation menu of the ART product launch page under the Select a Course heading. 

Important: When referring to the ART website, do not confuse the term “course” with the (.ulc) 
ART Developer Kit source file.  The courses listed on the ART product launch page represent HP 
Software ART content, for example, the Cloud Service Automation 3.1 ART course or the HP 
Service Manager 9.30 ART course. 
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Course Launch Page 

 
 

The second level of the ART website is the course web page.  The course web page introduces the 
selected HP Software ART course.  In the example above, the Cloud Service Automation (CSA) 
3.1 ART course launch page is displayed.  The course launch page includes an overview of the 
HP Software ART course, including the learning objectives.    

All HP Software ART courses consist of several modules.  You can access the modules that are 
included in the selected course from the left navigation menu under the Select a Module heading. 
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Module Launch Page 

 
 

The Module launch page provides access to the ART content.  You can either launch the  
e-learning course module directly by clicking the Launch Module button or, to quickly master a 
specific task, by launching a simulation or job aid within the Launch Simulation or Launch Job Aid 
options. 

  



Creating the HP ART 5.10 Website Guide 

 

Page 6 of 32 

 Copyright 2012 – 2013 Hewlett-Packard Development Company, L.P. 

Creating the ART 5.10 Website 
When you purchase an HP Software ART course, the ART 5.10 website output files are included 
in the content package within the output folder.   

To create your own ART website, or customize an existing website, you do the following: 

 
1. Prepare the ART files. 
2. Create the website (.us) file. 
3. Insert the source content files. 
4. Organize the website. 
5. Create the ART product launch page. 
6. Create the course launch page. 
7. Organize the website with the new launch pages. 
8. Batch publish source files. 
9. Publish the website. 

 

Step 1: Prepare the ART Files 
Before creating the ART 5.10 website, it is important to organize the ART content into the 
following folder structure: 

ART_Project 

 source 

  module1 

   (folder containing the course and recording source files for module 1) 

  module2 

   (folder containing the course and recording source files for module 2) 

  … 

Below is a sample ART project folder for the HP Asset Manager 9.30 ART course: 
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For each module, the module folder contains all the course (.ulc) and recording (.udc) source files:  

 

 
 

Step 2:  Create the Website (.uws) File 
Select File>New from the ART editor window. 

 
 

Within the New window, populate the following fields and click the OK button: 
 

File name Enter the name of the website (.uws) file. 

Type Select Website from the drop-down menu. 

Template Select the desired template. 

Language Select the desired language. 

Location Specify the location to store the website (.uws) file. 
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The ART editor displays the new website file. 
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If this is the first time you are creating a website, select View>Choose Details from the ART editor. 

 

 
Within the Choose Details window, validate that the PORTFOLIO, Product, and Module columns 
are selected and click the OK button.   
 

Step 3: Insert the Source Content Files 
Select Insert>Insert Multiple Links from the ART editor menu. 
 

 
 

Navigate to the source folder of your project and click the OK button.   

Note: All source files located within the source folder are imported into the website. 
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A progress menu displays during the import process. 
 

 
 

The Links window pane lists each file.  Notice that each file is categorized by PORTFOLIO, 
Product, and Module. HP ART creates the website structure based on how you configure the 
properties for each file. For this reason, it is very important to properly complete the properties for 
each file. 
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Step 4: Organize the Website 
ART uses the Product and Module property values of each file to organize the structure of the 
website.  

Select Tools>Organize Website from the editor menu. 

 
 

A confirmation message displays.  Click the Yes button. 
 

 
 

The new organization of the website displays within the Pages pane.  The three organizational 
levels include:   

• The root .uws file 
• The HP Software ART course (Asset Manager in this example) 
• All modules within the ART course 
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By default, the root page is given the same name as the .uws file.  HP recommends that you 
change the name to easily identify the course.   

 
 

Select File>Properties from the editor menu. 

 
 

Within the Properties window, edit the Title field with the desired name.   
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Step 5: Create the ART Product Launch Page 
The ART product page is the first page that displays when the ART 5.10 website is launched.   

 
 

The ART product launch page is a logical link, not a physical web page.  You create a link and 
configure its properties with the information you want to display on the launch page. When you 
publish the course, HP ART pulls the property information and formats it to create the launch 
page. 

To create the ART product launch page, select Insert>Insert Link from the editor menu. 
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Within the General section of the Insert Link window, populate the following fields as shown: 
 

Name  ART Product Launch Page 

URL  http://dummy 

 
 

Navigate to the Properties section of the Insert Link window.  Enter the information you want to 
display on the ART product launch web page.  
 
You can use the following fields to populate the ART product launch web page.  All fields are 
optional, with the exception of the InfoPage field.  When you set the InfoPage field to True, ART 
recognizes the page as a launch page. 

 

Property Field Description 

InfoPage Must be set to True for all logical website launch pages 

Description First paragraph that is displayed 

DescriptionBullet1 Description bullet list item #1  

DescriptionBullet2 Description bullet list item #2  

DescriptionBullet3 Description bullet list item #3  

DescriptionBullet4 Description bullet list item #4  

Description2ndParagraph Second paragraph displayed after description bullets 

Objective1 Objective list item #1  

Objective2 Objective list item #2 
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Property Field Description 

Objective3 Objective list item #3 

Objective4 Objective list item #4 

Objective5 Objective list item #5 

Audience Statement that describes the intended audience of the ART 
product 

BeginHere Instructions to learner on what to do after reading the product 
launch page contents.  Appears last on the product launch 
page. 

Prerequisite1 Prerequisite #1  

Prerequisite2 Prerequisite #2 

Prerequisite3 Prerequisite #3 
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Click the OK button to save the properties. 

The following information is included in the launch page for all prebuilt ART courses: 

 
 
Prebuilt ART Product Launch Web Page Properties 
InfoPage True   
Description HP Adoption Readiness Tool (ART) is a learning and performance support 

solution accessible anytime, anywhere to help ensure your effective use of 
the software. 

Prerequisite1 High speed Internet connection 
Prerequisite2 Web browser (IE 7.0+; Mozilla Firefox 17+; Google Chrome 24; or 

Safari 5.0) 
Prerequisite3 Adobe Acrobat Reader 9.x, 10.x, or XI  
BeginHere To begin, select a course from the left navigation. 
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You access the logical ART product page using the Page tab located on the bottom of the website 
(.uws) file.  Notice that the page type is set to Link.  To make changes to the virtual page 
properties, double-click the link to open the Properties window. 
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Step 6: Create the Course Launch Page 
The course launch page displays when you select an HP Software ART course from the ART 
product launch page. 

   

 
 

The process of creating the course launch web page is very similar to the ART product launch 
page.  

Select Insert>Insert Link from the editor menu. 
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Within the General section of the Insert Link window, populate the following fields as shown: 
 

Name <name of ART course> Launch Page  

URL http://dummy 

 

 
 

Navigate to the Properties section of the Insert Link window. Enter the desired information to be 
displayed on the course launch page.   

Below are the property values that are typically entered for the course launch page.   

Important: For the course launch page, you must select the product to ensure the launch page is 
organized at the HP Software course level. 

 
Course Properties 
InfoPage True  (required for all launch pages) 
Product Product (select from the drop-down menu - used to organize website) 
Description High level overview of the HP Software ART course 
Objective1 Course Objective 1 
Objective2 Course Objective 2 
Objective3 Course Objective 3 
Objective4 Course Objective 4 
Objective5 Course Objective 5 
BeginHere Provides instructions to learner on how to begin the course 
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Click the OK button to save the properties. 
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About the Module Launch Page 
You manage the Module launch page within the Properties window of the module course (.ulc) 
source file.  Authors populate the properties of each file during the development cycle. 

 
Below are the property values that are typically entered for the Module launch web page:   

Module Properties 

PORTFOLIO PORTFOLIO of the HP software product 

Product HP software product 

Description High level overview of the module. 

Build_num yyyy.mm file was last modified (not displayed on website, used for versioning 
only). 

Module Name of module.  The Module field is used to organize the file during the 
website publishing process. You must populate the Module field for every file 
in the ART project. 
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Step 7:  Organize the Website with the New Launch Pages 
After you create the Product and course launch pages, organize the website to pick up the newly 
added pages.    

Select Tools>Organize Website from the editor menu. 

 
The following shows the product launch page listed at the correct level: 

  
The following shows the course launch page listed at the correct level: 
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Step 8: Batch Publish Source Files 
Next, you are ready to publish the source files. Select File>Batch Publish from the ART editor 
menu. 

 
 

Within the Batch Publish window, select the following options to be published: 
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In the lower half of the Batch Publish window, populate the following fields and click the Publish 
button: 
 

Inbox Browse to the source folder. 

Outbox Create a new folder named output, under the project root folder. 

 
 

The Batch Publish process will take several minutes, the exact time depending on the number of 
files in the website.  A progress window will display with notification of the status. 

 
When the batch publish process completes, the Publishing Summary window displays.  Click the 
OK button. 
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Step 9: Publish the Website  
The batch publish process publishes the source files contained within the website.  The final step is 
to publish the website file itself. Click the Publish icon from the ART editor toolbar. 

 

 
 

Within the Publish window, select the xml checkbox.  Ensure the Outbox is directed to the output 
folder created during the batch publish. 

 

 
 

When publishing is complete, click the Xml link to view the final website. 
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Note:  All output files are stored within the output folder specified within the Publish window. 
Click the index.htm file to launch the website. 
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Viewing the ART 5.10 Website Locally 
When viewing the ART 5.10 website locally, you must enable browser security settings. 

Mozilla FireFox 

1. Navigate to about:config within the FireFox browser. 
2. Change the preference security.fileuri.strict_origin_policy to False. 

 

Google Chrome 

1. Create a shortcut to Chrome. You can simply copy/paste the existing desktop shortcut, if 
you have one, or copy/paste the Chrome shortcut in the Start menu to your desktop. 

2. Right-click the shortcut and go to Properties. 
3. In the target field, add the following line: 

--allow-file-access-from-files 
 
For example, the entire target field will appear like the following: 

C:\Users\UserName\AppData\Local\Google\Chrome\Application\chrome.exe --allow-file-
access-from-files 

4. Click OK. 
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Adding Related Documents to the HP ART 5.10 
Website 
You can add external documents to the HP ART website at the product, course, and/or module 
levels.  Once added to the website, they are embedded with the file and accessible to all users. 

To add a document to the website, perform the following steps: 

1. Open the website (.uws) file. 
2. Select Insert>Insert link from the ART editor menu. 

 

 
 

3. Within the General menu item: 
a. Enter a title for the document to be displayed in the website, and navigate to the 

external file.   
b. Select the Copy content to published website folder checkbox to ensure the 

document is stored with the published files. 
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4. The information required in the Properties menu item depends on where you would like the 
related document displayed on the website. 
 

 
 

a. To display the related document on the HP ART product launch page, leave all 
fields within the Properties window blank. 
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b. To display the related document at the Course level, select the PORTFOLIO, 
Product fields. 
 

 
 

c. To display the related document at the Module level, select the PORTFOLIO, 
Product fields, as well as the appropriate Module field. 
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 Important:  Whenever you change the website page properties, you must 
refresh the website organization using Tools>Organize Website. 
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