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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty statements 
accompanying such products and services. Nothing herein should be construed as constituting an additional 
warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and 
Technical Data for Commercial Items are licensed to the U.S. Government under vendor’s standard 
commercial license.

Copyright Notice

Copyright 2012 Hewlett-Packard Development Company, L.P.

Trademark Acknowledgements

Microsoft and Windows are U.S. registered trademarks of Microsoft Corporation.

Windows Vista is either a registered trademark or trademark of Microsoft Corporation in the United States 
and/or other countries.

Adobe and Acrobat are trademarks of Adobe Systems Incorporated.

Other Acknowledgements

This product contains the following Apache open source component: Log4Net (http://logging.apache.org/
log4net/). This component was modified from its original form and incorporated into this software product. To 
learn more about the apache software license, please visit http://www.apache.org/licenses/LICENSE-2.0.
ii



Documentation Updates

This guide’s title page contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition of a document, visit the 
following URL:

http://h20230.www2.hp.com/selfsolve/manuals 

You will also receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details.
iii
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Support

For information or assistance regarding WebInspect Enterprise, contact customer support.

You can open a support case for WebInspect Enterprise via e-mail or by telephone, using our new customer 
support system. This streamlined procedure is designed to provide easier access and improved customer 
satisfaction.

E-Mail (Preferred Method)

Send an e-mail to techsupport@fortify.com describing your issue. Be sure to include the product name. A 
customer support representative will contact you.

Telephone

Call our automated processing service at (650) 735-2215. Please provide your product name and phone 
number, along with a brief description of your problem. A customer support representative will contact you.

You can access the HP Application Security Center customer forum and blogs at 

http://www.communities.hp.com/securitysoftware/

You can also visit the HP software support Web site at:

http://support.openview.hp.com/

This web site provides contact information and details about the products, services, and support that HP 
Software offers.

HP Software online support provides customer self-solve capabilities. It provides an efficient way to access 
interactive technical support tools needed to manage your business. As a valued support customer, you can 
benefit by using the HP Software Support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract.

To find more information about access levels and HP Passport, go to:

http://h20230.www2.hp.com/new_access_levels.jsp

To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html
iv
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1 Welcome
Introduction

WebInspect Enterprise is a distributed network of HP scanners controlled by a system 
manager with a centralized database. It is specifically designed to interface with HP Fortify 
Software Security Center, providing information detected through dynamic scans of Web 
sites.

This innovative architecture allows you to:

• Conduct a large number of automated security scans using any number of HP scanners to 
assess Web applications and Web services.

• Manage large or small deployments of HP scanners across your organization controlling 
product updates, scan policies, scan permissions, tools usage and scan results all centrally 
from the WebInspect Enterprise Console.

• Detect, track, and manage your Web applications and monitor all activity associated with 
them.

• Independently schedule scans and blackout periods, manually launch scans, and update 
repository information by using HP scanners or the WebInspect Enterprise Console.

• Limit exposure to enterprise-sensitive components and data by using centrally defined 
roles for users.

• Obtain an accurate snapshot of the organization’s risk through a centralized database of 
scan results.
1



2 Chapter 1



2 Installation
Introduction

WebInspect Enterprise comprises the following:

• The WebInspect Enterprise Web Console

• The WebInspect Enterprise Administrative Console 

• Scanners. Two types of scanners are supported: 

— Sensor - This is the WebInspect application when connected to WebInspect Enterprise 
for the purpose of performing remotely scheduled or requested scans with no direct 
user interaction through its graphical user interface. It receives its instructions 
exclusively from the configurable connection to a WebInspect Enterprise Manager.

— Client - A client is any HP scanner that connects to WebInspect Enterprise to receive 
license, permissions, updates or scan data, and which also presents a user interface 
through which scans may be conducted. WebInspect Enterprise controls permissions 
for a client and also provides the policies used by clients. A client can be configured to 
upload scan results to WebInspect Enterprise automatically at the completion of the 
scan or only when specifically instructed by the user.

• Microsoft SQL Server

System Requirements

Before installing WebInspect Enterprise, make sure that your system meets the requirements 
listed below. 

All Products

• Platform: Microsoft .NET 4.0

• Supported Browsers: Microsoft Internet Explorer 7, 8, or 9; FireFox 9 (minimum) or 
FireFox 14 (recommended).

• Network: An active Internet or intranet connection.

WebInspect Enterprise Web Console

• Processor: 2.5 GHz or better

• RAM: 4 GB or more

• Hard Disk Space: 5 GB (using remote database) or 20 GB (minimum if using local 
database); 100+ GB recommended

• Plug-Ins for Enterprise Servers
3



— For Software Security Center: Flash

— For WebInspect Enterprise: Silverlight

• Platforms

— Microsoft IIS 6.0 (Minimum)

— Microsoft IIS 7.0

— Microsoft IIS 7.5 (Recommended)

• Supported Operating Systems

— Windows Server 2003 Standard SP2 (32-/64-bit)

— Windows Server 2008 SP2 (32-/64-bit)

— Windows Server 2008 R2 (32-/64-bit)

— Windows Server 2008 R2 SP1 (64-bit)

• Supported Integrations

— HP Fortify SCA 3.0

— HP Fortify Security Scope 3.6

— HP Fortify Software Security Center 3.6

WebInspect Enterprise Administrative Console

• Processor: 1.5 GHz or better

• RAM: 1 GB or more

• Hard Disk Space: 2 GB 

• Supported Operating Systems

— Windows XP Professional SP3 (32-bit)

— Windows Server 2003 SP2 (32-bit/64-bit)

— Windows Server 2008 SP2 (32-/64-bit)

— Windows Server 2008 R2 (64-bit)

— Windows Server 2008 R2 SP1 (64-bit)

— Windows Vista SP2 (32-bit/64-bit)

— Windows 7 (32-bit/64 bit)

• Supported Databases

— Microsoft SQL Server Express Edition 2008 SP2 (4 GB scan database limit)

— Microsoft SQL Server Express Edition 2005 SP3 (4 GB scan database limit). 

A database is required only if you want to edit policies or audit inputs.

• Platform: Silverlight Runtime v3 (required only if you want to use Screenshot 
Attachments

WebInspect Enterprise Database

• Processor: 2.5 GHz or better

• RAM: 2 GB minimum
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• Hard Disk Space: 20 GB minimum, 100+ GB recommended

• Supported Operating Systems

— Windows Server 2003 SP2 (32-/64-bit)

— Windows Server 2008 SP2 (32-/64-bit)

— Windows Server 2008 R2 (64-bit)

• Supported Databases

— Microsoft SQL Server 2005 SP4

— Microsoft SQL Server 2008 SP2 

— Microsoft SQL Server 2008 R2 (Recommended). 

Note: WebInspect Enterprise does not support SQL Server Express Edition.

WebInspect Enterprise Sensor (WebInspect 9.30)

• Supported Operating Systems

— Windows 7 (32-/64-bit) (Recommended)

— Windows XP Professional SP3 (32-bit)

— Windows Vista SP2 (32-/64-bit)

— Windows Server 2003 SP2 (32-bit/64-bit)

— Windows Server 2008 SP2 (32-bit/64-bit)

— Windows Server 2008 R2 (64-bit) (Recommended)

— Windows Server 2008 R2 SP1 (64-bit) (Recommended)

• Processor: 1.5 GHz Single-Core minimum; 2.5 GHz Multi-Core recommended

• RAM: 2 GB minimum; 4 GB recommended

• Hard Disk: 10 GB minimum; 100+ GB recommended

• Display: 1024 x 768 minimum; 1280 x 1024 recommended

• Supported Databases

— Microsoft SQL Server Express Edition 2008 R2 (Minimum) (10 GB scan database 
limit)

— Microsoft SQL Server Express Edition 2008 SP2 (4 GB scan database limit)

— Microsoft SQL Server Express Edition 2005 SP3 (4 GB scan database limit)

— Microsoft SQL Server 2008 R2 (Recommended) (No scan database limit)

— Microsoft SQL Server 2008 SP2 (No scan database limit)

— Microsoft SQL Server 2005 SP4 (No scan database limit)

• Platform: Microsoft .NET Framework 3.5 Service Pack 1

• Supported Browsers

— Internet Explorer 6.0 (Minimum) 

— Internet Explorer 7.0 

— Internet Explorer 8.0 (Recommended) 

— Mozilla Firefox 3.6 or 7.0 (Proxy Settings Only)
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For a WebInspect Enterprise environment to support Internet Protocol version 6 (IPv6), the 
IPv6 protocol must be deployed on each WebInspect Enterprise Administrative Console, 
WebInspect Enterprise Sensor, and the WebInspect Enterprise Manager.

WebInspect Enterprise Web Console Installation

Note: WebInspect Enterprise may not be installed on the same server with the Assessment 
Management Platform (AMP). 

On a Microsoft Windows server: 

1 Before installing WebInspect Enterprise, install IIS. You must install IIS before installing 
.NET 4.0.

2 Open the Windows Server Manager and in Role Services, select the IIS6 Management 
Compatibility option and all suboptions.

3 Install .NET 4.0

4 Open the IIS Manager, select the local host node, go to ISAPI and CGI and allow 
ASP.NET v4.0.

If you receive an error message indicating that the feature cannot be installed because 
your operating system lacks IIS Management Compatibility, make sure you follow the 
preceding steps.

5 Start the WebInspect Enterprise installation program. 

6 On the Welcome page, click Next.

7 Review the license agreement. If you accept, select the check box and click Next; otherwise 
click Exit. 

8 On the Product Features section, select the components you want to install.

9 Click Browse to select the location in which you want to install the software and click Next.

10 When ready to install, click Install.

11 After installation, click Finish.
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12 When the Initialization Wizard appears, click Next.

13 Enter the Activation ID sent to you by HP.

14 If using a proxy server, select Use Proxy Server and provide the requested information.

15  Do one of the following:

• If you are connected to the Internet, select Online Activation.

• If you are not connected to the Internet, select Offline Activation and then click File to 
select the location where a file named LicenseRequest.xml will be created.

16 Click Next
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The WebInspect Enterprise License User Information window displays user information as 
submitted to HP. 

17 Click Next.

18 If you selected Online Activation in step 11, go to step 16.

19 If you selected Offline Activation in step 11, the Complete Offline License Activation dialog 
appears. Follow steps a-h.

The LicenseRequest.xml file you created in step 11 contains information about the 
computer on which you are installing the software. You will transfer this file to a portable 
device (diskette or flash drive) and then copy this file to an Internet-connected computer 
and transmit the file to an HP server, which will download a license file that you can copy 
and install on the computer that is not connected to the Internet.
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a When the Complete Offline License Activation dialog appears, open a browser and 
navigate to https://LicenseService.HPSmartupdate.com/OfflineLicensing.aspx.

b Select the option that describes how the request file was generated and click Next.

c On the Process Request File window, click Browse, select the LicenseRequest.xml file 
that you copied to this computer, and then click Process Request File.
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d If the request is processed successfully, the following message appears:

Click Retrieve.

e On the File Download dialog, click Save and specify the location to which the 
LicenseResp.xml file should be downloaded.

f Transport the LicenseResp.xml file back to the isolated machine.

g On the Initialization Wizard, click File and specify the location of the downloaded 
LicenseResp.xml file.

h Click Next.

20 The WebInspect Enterprise License Information window displays information about the 
license token.

Click Next.
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21 On the SQL Server Information panel, enter the name of the SQL Server and select the 
authentication method that will be used. If you are installing WebInspect Enterprise for 
the first time, then you must have privileges to create a database (or your database 
administrator must create a blank database and assign ownership to you). 

22 Click Next.

23 On the Database Selection window:

a Choose one of the following:

— To use a new database, select Create new database and enter the database name. 
You must have privileges to create this database.

— To replace a previous installation of WebInspect Enterprise, select Use existing 
database and select one from the list. You must have owner privileges for that 
database.

b Click Next.

24 For an existing database only, the WebInspect Enterprise Database Upgrade window 
appears. Enter a name for the new database and click Next. 
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25 On the Setup WebInspect Enterprise Manager WebService window, enter the root Web site 
and the name of the IIS virtual directory. 

If you select Require Secure Channel (SSL), add and/or select an SSL certificate. For 
security reasons, HP recommends that you use SSL.

These entries create the URLs for the following components.

Console: 

http(s)://<computer name>/<virtual directory name>/ 

Web Console: 

http(s)://<computer name>/<virtual directory name>/WebConsole

26 Click Next.

27 On the Setup the WebInspect Enterprise Manager User window, enter the local or domain 
user account that you want to associate with the WebInspect Enterprise Manager Web 
Service. For WebInspect Enterprise to work properly, this account must be a local 
administrator. This enables the WebInspect Enterprise Manager to install service packs 
and patches released by HP.

28 Click Next.
12 Chapter 2



29 On the Setup WebInspect Enterprise Database User window, specify how the WebInspect 
Enterprise Manager should connect to the WebInspect Enterprise database. 

• Windows Authentication - The name and password specified in the WebInspect 
Enterprise Manager’s user account is used to authenticate to the database. When 
working in a domain environment, the WebInspect Enterprise Manager’s user 
account should be a domain account. When working in a workgroup environment, you 
must have the exact same user name and password on both the WebInspect 
Enterprise manager and the database computers.

• SQL Authentication - Enter the SQL Server user name and password.

30 Click Next.

31 On the Ready To Start window, verify your previous choices. 

• To change settings, click Back. 

• To begin configuration, click Next. The program creates and populates the database, 
and initializes other database and system components.
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32 The program displays the initialization results. Click Next.

33 On the Sensor Users window, click Add and enter the user accounts that will be associated 
with the sensors (WebInspect installations).

34 Click Next.
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35 Provide the requested information:

• URL - The URL of the Software Security Center server. 

Note: Only one instance of WebInspect Enterprise may be connected to a specific 
Software Security Center. If you attempt to connect to an SSC server that is already 
registered with another instance of WebInspect Enterprise, you must either 
unregister that instance or connect this instance to a different SSC. 

• Allow a non-trusted server certificate - Select this option to allow a certificate that a 
certification authority has revoked, or a certificate that for other reasons has been 
placed in the Untrusted Certificates folder on your computer. 

• Use WIE proxy server settings - Select this option to use the settings specified under 
Proxy Server Settings. 

• User Name and Password - Enter the name and password of the user who was assigned 
to the WebInspect Enterprise System role, as created in Software Security Center. 
Using the SSC administrator’s account is not recommended.

To verify the settings, click Test. 

To unregister, click Unregister. WebInspect Enterprise normally uses the product license 
key to register with Software Security Center. However, you can substitute a different ID, 
if you wish. Also, when unregistering, you must enter the ID of the currently registered 
instance, and then click OK. 

36 Click Next.
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37 When installation is complete, the following window appears. Click Finish.

WebInspect Enterprise Services Configuration Utility 

Use the WebInspect Enterprise Services Configuration Utility to configure or modify services 
associated with WebInspect Enterprise.

After starting the utility, click one of the buttons in the left column. They are:

• Scan Uploader Service - Handles the transfer of scans from WebInspect or Fortify to 
WebInspect Enterprise.

• Task Service - Monitors the queue for various tasks.

• Scheduler Service - Handles the scheduling of scans and smart updates.

Scan Uploader Service

Certain applications (currently WebInspect, QAInspect, and Fortify) can scan a Web site and 
export the scan results to a location called a “drop box.” The purpose of the WebInspect 
Enterprise Uploader service is to access each drop box periodically and, if files exist, to upload 
those files to the WebInspect Enterprise Manager.

Service Status

This area reports the current status of the Scan Uploader service. You can start, stop, restart, 
or configure the service.

To configure the service:

1 Click Configure. 

The Configure Service dialog appears.

2 Select which credentials should be used for logging on to the service: 
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• Local system account - The LocalSystem account is a predefined local account used by 
the service control manager (SCM). It has extensive privileges on the local computer, 
and acts as the computer on the network. A service that runs in the context of the 
LocalSystem account inherits the security context of the SCM. 

• This account - An account identified by the credentials you specify.

3 If you select This account, enter an account name and password. 

4 Click OK.

WebInspect Enterprise Configuration

This area reports the WebInspect Enterprise Manager configuration.

To configure the WebInspect Enterprise Manager:

1 Click Configure. 

The WebInspect Enterprise Configuration dialog appears.

2 Enter the URL of the WebInspect Enterprise Manager.

3 Provide the WebInspect Enterprise Manager's authentication credentials.

4 To verify that the user name and password are correct, click Test.

5 If the Scan Uploader service uses a proxy, select Enable Proxy and provide the requested 
information.

6 Click OK.

Drop Box Configuration

Certain applications (currently WebInspect, QAInspect, and Fortify) can scan a Web site and 
export the scan results to a location called a “drop box.” The purpose of the WebInspect 
Enterprise Uploader service is to access each drop box periodically and, if files exist, to upload 
those files to the WebInspect Enterprise Manager.

Use the following procedure to create a drop box.

1 Click Add. 

The Configure Dropbox dialog appears.

2 Enter a drop box name. 

3 Enter the full path and name of the folder that will be used as the drop box (or click 
Browse to select or create a folder). 

Be sure to select or create a folder that will not be used for any other purpose.

4 Select a site that will be serviced by this drop box. 

5 Click OK.

Task Service

Service Status

This area reports the current status of the Scan Uploader service. You can start, stop, restart, 
or configure the service.
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To configure the service:

1 Click Configure. 

The Configure Service dialog appears.

2 Select which credentials should be used for logging on to the service: 

• Local system account - This option is disabled for the Task service. 

• This account - An account identified by the credentials you provide.

3 If you select This account, enter an account name and password. 

4 Click OK.

Database Configuration

This area reports the database server name and database name.

To configure the database:

1 Click Configure. 

The Database Configuration dialog appears.

2 Enter a server name. 

3 Specify the account under which WebInspect Enterprise will connect to the database. 

• Windows Authentication - The name and password specified in the WebInspect 
Enterprise Manager’s user account is used to authenticate to the database. When 
working in a domain environment, the WebInspect Enterprise Manager’s user 
account should be a domain account. When working in a workgroup environment, you 
must have the exact same user name and password on both the WebInspect 
Enterprise manager and the database computers. 

• SQL Authentication - Enter the SQL Server user name and password.

4 Enter or select a database. 

5 Click OK.

Logging Configuration

This area reports current settings for the logging function.

To configure settings:

1 Click Configure. 

The Logging Configuration dialog appears.

2 The logging output is contained in the TaskService_trace.log. To specify the location of the 
logs, choose one of the following: 

• Default location 

On Windows Server 2003, the location is:

\Documents and Settings\All Users\Application Data\HP\WIE\TaskService

On Windows Server 2008, the location is:

\ProgramData\HP\WIE\TaskService

• Enter location for log file 
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Type a path to the folder that will contain the logs, or click Browse to select a location.

3 For the logging level, choose either INFO (the default) or DEBUG (which records more 
data). 

4 Specify the maximum file size of a log file (in megabytes). 

5 Specify the number of log files that will be retained.

When a log file reaches its maximum size, WebInspect Enterprise closes it and opens 
another file, repeating this process until the maximum number of log files is created. 
When that file is full, WebInspect Enterprise closes it, deletes the oldest file, and opens a 
new one. Files are named in sequence: TaskService_trace.log, TaskService_trace.log.1, 
etc. 

SSC Poll Interval

This area determines how often WebInspect Enterprise contacts Software Security Center for 
updates.

SSC project version updates polling interval - Specify (in seconds) how frequently WebInspect 
Enterprise contacts SSC to check for project version name changes or deletions.

SSC issue synchronization interval - Specify (in minutes) how frequently WebInspect Enterprise 
contacts SSC to check for  changes to audit information, comments, attachments, and “not an 
issue” and “suppressed” status.

Scheduler Service

Service Status

This area reports the current status of the service. You can start, stop, restart, or configure 
the service.

To configure the service:

1 Click Configure. 

The Configure Service dialog appears.

2 Select which credentials should be used for logging on to the service: 

• Local system account - The LocalSystem account is a predefined local account used by 
the service control manager (SCM). It has extensive privileges on the local computer, 
and acts as the computer on the network. A service that runs in the context of the 
LocalSystem account inherits the security context of the SCM. 

• This account - An account identified by the credentials you specify.

3 If you select This account, enter an account name and password. 

4 Click OK.

Administrative Console Installation

Use the following procedure to install the WebInspect Enterprise Administrative Console.

1 Start the installation program. 
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2 On the Welcome page, click Next.

3 Review the license agreement. If you accept, select I accept the terms in the License 
Agreement and click Next; otherwise click Cancel. 

4 Select the folder into which you want to install the software and click Next.

5 Click Install.

6 When the process is complete, click Finish.
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Sensor Installation

Use the following procedure to install WebInspect as a sensor. 

1 Start the installation program. 

2 On the Welcome page, click Next.

3 Review the license agreement. If you accept, select I accept the terms in the License 
Agreement and click Next; otherwise click Cancel. 

4 Select the folder into which you want to install the software and click Next.

The WebInspect Enterprise Sensor Configuration window appears.

5 Select Configure WebInspect as a Sensor. 

6 Enter the URL of the WebInspect Enterprise manager.

7 In the Sensor Authentication group, enter the Windows account credentials for this sensor. 
Be sure to add this account to the list of sensor users using the WebInspect Enterprise 
Administration module.

8 Click Next.

9 When ready to install, click Install.

10 When the process is complete, click Finish.
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Time Stamping and Scheduling

There may be installations where the manager and the console reside in different time zones. 
To accommodate this, the WebInspect Enterprise manager uses Coordinated Universal Time 
(also known as Greenwich Mean Time or Zulu time) for all time storage and manipulation. 
When a time is to be displayed on the console, the manager converts the time to conform to 
the time zone in which the console resides. Alert e-mails, however, are time-stamped 
according to the zone in which the manager resides.

Universal Time does not honor daylight saving time. Therefore, scheduled scan times will 
change by one hour after the transition between daylight saving time and standard time. To 
illustrate, suppose you schedule a scan to occur daily at 4 P.M. and you are in the Eastern 
time zone of the United States during the daylight saving time period. The WebInspect 
Enterprise manager records the settings and will begin the scan each day at 8 P.M. Universal 
Time (which is the equivalent of 4 P.M. Eastern daylight time). However, when the transition 
to standard time occurs, your scheduled scan will begin at 3 P.M. local time instead of 4 P.M. 
Even though you set your clocks back one hour, the Universal Time continued unchanged.

Installations Lacking Internet Connection

All HP security products contain digital certificates of authority. When a product starts, the 
operating system attempts to connect to the Internet and download a certificate revocation 
list from the certificate’s issuing authority (VeriSign) to determine if the product’s certificate 
has been revoked. If the product cannot establish an Internet connection, it waits until the 
request times out, which substantially lengthens the product’s start-up time. This inability to 
verify the certificate also causes other problems, including:

• Services fail to start.

• Multiple instances of scriptserver.exe are spawned.

• Scans fail to complete.

To avoid the complications caused by a lack of Internet access, consider the following 
solutions:

• Use Microsoft Windows Server Active Directory to store and publish a certificate 
revocation lists (CRL). 

• Manually download the required CRL and install it.

• Disable CRL checking for the server.

• Change the default CRL timeout period for the Microsoft Cryptography API (CAPI).

• Disable the “Check for publisher’s certificate revocation” option in Internet Explorer 
settings. To do so, click the Internet Explorer Tools menu and select Internet Options, click 
the Advanced tab, scroll to the Security section, clear the check box next to “Check for 
publisher’s certificate revocation,” then close and restart Internet Explorer.

The recommended solution is to manually download the CRL, and then install it to the local 
computer certificate store. 

To download the CRL:

1 Open a browser.

2 Go to http://crl.verisign.com/pca3.crl. 
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3 When prompted, “Do you want to open or save this file,” click Save.

4 On the Save As dialog box, select a location and click Save.

5 Go to http://csc3-2004-crl.verisign.com/CSC3-2004.crl.

6 Repeat steps 3-4.

Note: Because the CRL is valid only for a limited time, you must retrieve a new CRL 
periodically. 

To install a CRL to the local computer certificate store, follow these steps: 

1 Log on to the computer as a member of the local administrators group. 

2 Open the Certificates snap-in for the Computer account. To do this, follow these steps: 

a Click Start, click Run, type mmc, and then click OK. 

b On File menu, click Add/Remove Snap-in. 

The Add/Remove Snap-in dialog box appears.

c On the Standalone tab, click Add.

The Add Standalone Snap-in dialog box appears.

d In the Available Standalone Snap-ins list, click Certificates, and then click Add. 

e Select Computer account, and then click Next.

f Click Local computer, and then click Finish.

g Click Close, and then click OK.

3 Under the Console root, expand Certificates. 

4 Right-click Intermediate Certification Authorities, click All Tasks, and then click Import. 

The Certificate Import Wizard opens.

5 Click Next.

6 Click Browse.

7 On the Open dialog box, select Certificate revocation list (*.crl) from the Files of type list.

8 Locate and select pca3.crl and click Open.

9 Click Next and follow instructions in the wizard to complete the installation.

10 Go to Step 4 and repeat the process to import CSC3-2004.crl.
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3 Preparing Your System for Audit
Introduction

HP scanners are aggressive Web application analyzers that rigorously inspect your entire 
Web site for real and potential security vulnerabilities. This procedure is intrusive to varying 
degrees. Depending on which scanning policy you apply and the options you select, it can 
affect server and application throughput and efficiency. When using the most aggressive 
policies, you should perform this analysis in a controlled environment while monitoring your 
servers.

Helpful Hints

If your system generates e-mail messages in response to user-submitted forms, you might 
want to consider disabling your mail server. Alternatively, you could redirect all e-mail 
messages to a queue and then, following the audit, manually review and delete those 
messages that were generated in response to forms submitted by HP scanners. 

If for any reason you do not want to audit certain directories, you must specify those 
directories using the Excluded URLs settings of HP scanners.

During an audit of any type, HP scanners submit a large number of requests, many of which 
have “invalid” parameters. On slower systems, the volume of HTTP requests may degrade or 
deny access to the system by other users. Additionally, if you are using an intrusion detection 
system, it will identify numerous illegal access attempts. 

Finally, HP scanners test for certain vulnerabilities by attempting to upload files to your 
server. If your server allows this, HP scanners will attempt to delete the file. Sometimes, 
however, the server will not allow a file to be deleted. For this reason, part of your post-scan 
maintenance should include searching for and deleting files whose name begins with 
“CreatedByHP.” 

Using Web Forms

Most Web applications contain HTML or JavaScript forms composed of special elements 
called input controls (text boxes, buttons, drop-down lists, etc.). Users generally “complete” a 
form by modifying its input controls (such as entering text or checking boxes) before 
submitting the form to an agent for processing. Usually, this processing will lead the user to 
another page or section of the application. For example, after completing a logon form, the 
user will proceed to the application’s beginning page. 
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If HP scanners are to navigate through all possible links in the application, they must be able 
to submit appropriate data for each form. They do so by using a file a containing the names of 
input controls and the associated values that need to be submitted during a scan of your Web 
site. Each HP scanner includes a default Web form file containing sample name/value pairs. 
You can use the Web Form Editor (accessible through the Tools menu on the WebInspect 
Enterprise Administrative Console) to create your own file containing Web form values.

If you select the option to submit forms during a crawl of your site, HP scanners will complete 
and submit all forms encountered. Although this enables HP scanners to navigate seamlessly 
through your application, it may also produce the following consequences: 

• If, when a user normally submits a form, the application creates and sends e-mail 
messages or bulletin board postings (to a product support or sales group, for example), HP 
scanners will also generate these messages as part of their probe. 

• If your system writes records to a back-end server (database, LDAP, etc.) based on forms 
submitted by clients, then forms submitted by HP scanners will create spurious records. 
Some users, before auditing their production system, create a copy of their database and 
then reinstall it after the audit is complete. If this is not feasible, you can query your 
servers after the audit, searching for and deleting records that contain one or more of the 
form values used by HP scanners. You can determine these values by opening the Web 
Form Editor.

During the audit phase of a scan, HP scanners resubmit forms numerous times, manipulating 
every possible parameter to reveal problems in the applications. This will greatly increase the 
number of messages and database records created.
26 Chapter 3



4 Getting Started
Introduction

After installing the WebInspect Enterprise software, allow the WebInspect Enterprise 
manager to initialize its database, and then perform the following tasks to configure your 
system and prepare for scanning. 

Log On to WebInspect Enterprise Administrative Console

The windows account of the person who installs the WebInspect Enterprise Administrative 
Console software is assigned, by default, to the role of system administrator. This role is 
granted all permissions with no IP restrictions. No one else can log on until the system 
administrator assigns other users to roles.

1 Start the WebInspect Enterprise Administrative Console.

The Log On to WebInspect Enterprise window appears.

Note: This window does not appear if you previously selected the option Automatically log 
on when this application starts and if WebInspect Enterprise uses the option Log on as the 
current Windows user.

2 Using the Log on to list, enter or select the URL of the WebInspect Enterprise manager.

3 Select one of the following logon options:

a To log on using your Windows user account, select Log on as the current Windows user. 

b To use a different account, select Log on as, then enter the user name and password 
for an account that has permission to access the console. For new installations, use 
the account name and password of the user who installed the WebInspect Enterprise 
manager software. This user is permitted to perform all restricted functions.

4 If you select Automatically log on when this application starts, users are logged on with their 
Windows account, bypassing the logon dialog.

5 To go through a proxy server to reach the WebInspect Enterprise manager:

a Click the Proxy tab.

b Select one of the following:

– Use the Internet Explorer proxy.

– Use the proxy below, and then provide the proxy server’s IP address and port 
number.

c Provide a valid user name and password.

6 Click OK.
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Note: If you see a message indicating that the server refused the request, you may have 
entered your user name and password incorrectly, or your account has not been assigned to a 
role. 

Configure the Console

After installing a license, you can specify settings for the console. 

To specify console settings:

1 From the Tools menu, select Options.

The Options window opens.

2 To refresh the display of WebInspect Enterprise information periodically, select 
Automatically refresh display and specify how often (in seconds) the display should be 
updated. 

3 Click OK.

Assign Administrators and Create Roles

Administrative authority within WebInspect Enterprise is distributed across three levels: 
system, organization, and group. Each level has at least one administrator.

System Level

The user account of the person who installed the WebInspect Enterprise software is, by 
default, the system administrator. This user may add other accounts as system 
administrators and may also create, rename, and delete organizations. System administrators 
may also create roles that allow access to certain WebInspect Enterprise Administrative 
Console features and assign users to those roles (thereby limiting the functions a specific user 
may perform). 

Organization Level

The system administrator who creates an organization automatically becomes an 
administrator for that organization. An organization administrator may perform the following 
functions:

• Assign other users as administrators.

• Determine which objects are available to that organization (for example, select which of 
the available scanning policies may be used by projects within an organization).

• Set the maximum priority level that can be assigned to scans conducted by this 
organization.

• Assign weight values to vulnerabilities detected by scans conducted by this organization.

• Create and assign users to roles, thereby limiting their ability to perform various 
functions or access certain features of the WebInspect Enterprise Web Console.

• Copy objects (such as blackouts, policies, e-mail alerts, etc.) or move them from one 
organization to another.
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• Create, rename, and delete projects.

You are not required to configure multiple organizations. If you prefer, you may associate all 
projects with a single organization.

Group Level

The organization administrator who creates a group automatically becomes an administrator 
for that group. A project administrator may perform the following functions:

• Assign other users as administrators.

• Determine which objects are available to that group (for example, select which of the 
scanning policies made available to the organization may be used by this group).

• Set the maximum priority level that can be assigned to scans conducted by this group 
(within the limits established for the organization’s maximum priority level).

• Specify which URLs or IP addresses may be scanned by this group.

• Create and assign users to roles, thereby limiting their ability to perform various 
functions or access certain features of the WebInspect Enterprise Web Console.

• Copy objects (such as blackouts, policies, e-mail alerts, etc.) or move them from one group 
to another.

You first priority should be to create the organization and group hierarchy, define hierarchical 
roles, assign users to those roles, and perform the other functions available from the 
Administration - Roles and Permissions module.

For detailed instructions, see Roles and Permissions on page 45.
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5 WebInspect Enterprise Administrative Console 
Introduction

WebInspect Enterprise presents two separate user interfaces:

• The WebInspect Enterprise Administrative Console, used for administrative and security 
functions. 

• The WebInspect Enterprise Web Console, a browser-based application used for running 
and managing scans.

This chapter describes the WebInspect Enterprise Administrative Console.

User Interface

The WebInspect Enterprise Administrative Console user interface comprises five main areas:

• Menu bar

• Toolbar

• Shortcut pane

• Groups pane

• Form 

 

The buttons in the Groups pane represent groups of WebInspect Enterprise functions.
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Click a group button to expose associated shortcuts.

Click a shortcut to display a form containing related information or controls associated with 
the selected function.

In the preceding illustration, the user selected the Administration group and then clicked the 
Activity Log shortcut to display a form containing a time-stamped history of WebInspect 
Enterprise Manager activities.

The Group pane contains the following buttons:

For forms containing lists (grids), you can initiate commands related to a list or to the 
individual objects on a list. Simply select an object and then choose a command from the 
Action menu (or from the shortcut menu that appears when you right-click an object). The 
availability of commands depends on the status of the selected object and the permissions 
granted to you by your assigned role (although system administrators have no restrictions on 
the functions they can perform).

Button Associated Shortcuts

Scans Scan Queue 
Scan Policies 

Sensors Sensors

Administration Activity Log 
Connected Users 
Licensing 
Smart Update 
Smart Update Approval
Export Paths 
E-Mail Alerts 
SNMP Alerts 
Sensor Users 
Roles and Permissions
Proxy Server Settings 
Software Security Center
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The following table describes the menus and toolbar buttons. 

 Scans Group

The Scans group contains two shortcuts: 

• Scan Queue 

• Scan Policies 

Scan Queue

For each scan that is running or waiting to run, this form displays (by default) the name 
assigned to the scan, the scan’s priority, the date and time the scan request was created, the 
sensor conducting the scan, the scan’s status, and the organization and group.

Select a scan request and then choose a command from the Action menu or from the shortcut 
menu that appears when you right-click a request. The availability of commands depends on 
the status of the selected scan and on the permissions granted to you by your assigned role. To 
learn more about roles and permissions, see Roles and Permissions on page 45. 

Menu / Button Description

File Allows you to:
• Log off the application.
• Refresh the display.
• Exit the application. 

Tools Allows you to:
• Manually initiate a Smart Update.
• Configure options for the console.
• Launch a tool included in the HP toolkit. 

Help Allows you to:
• Open this Help file.
• Open your e-mail application to send an e-mail to HP 

Support.
• Open the About WebInspect Enterprise dialog. 

Log On/Off Log on to or log off from the console application. 

Refresh Refresh the display.

Smart Update Manually initiate a Smart Update call to the HP server.

Web Console Log on to the WebInspect Enterprise Web Console.
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The commands are: 

Scan Policies

This form lists all policies configured in your environment. See Appendix A, Policies, for a 
description of each policy and its components.

Select a policy and then choose a command from the Action menu or from the shortcut menu 
that appears when you right-click a policy. The availability of commands depends on the 
permissions granted to you by your assigned role.

The commands are:

* All sensors in the WebInspect Enterprise system access common policies from the repository. The 
import and export of policies is useful only if you run the HP scanner independent of the 
WebInspect Enterprise system and want to incorporate the results of that scan into the 
WebInspect Enterprise system.

Command  Definition

 Stop Terminate the scan. The results, although incomplete, are available 
for inspection.

Suspend Halt the scanning process. You can resume the scan at the point at 
which it was interrupted.

Resume Continue the scanning process following a suspension.

Delete Remove the scan from the WebInspect Enterprise database.

Column Setting Open the Column Setting window, allowing you to specify which 
columns should appear in the list.

Command Definition

View View the selected policy. You must install Microsoft SQL Server 
Express Edition SP1 before you can view or edit policies. 
Double-clicking the policy name also loads the policy into the Policy 
Manager.

Copy Create a copy of the selected policy. After you rename the policy, the 
Policy Manager opens and loads the selected policy, allowing you to 
edit it. Once edited and saved, the policy is added to the list of scan 
policies.

Delete Delete the selected policy from the repository. Prepackaged policies 
cannot be deleted.

Rename Change the name of a custom policy, Prepackaged policies cannot be 
renamed (except when copied).

*Import Import a policy from a standalone HP scanner.

*Export Export a policy to a standalone HP scanner. Prepackaged policies 
cannot be exported.
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Sensors

The Sensors group has one shortcut: Sensors.

A sensor is defined as WebInspect (and only WebInspect) when connected to WebInspect 
Enterprise for the purpose of performing remotely scheduled or requested scans and provides 
no user interface.

This form displays the name, host name, status, and version of each sensor in the system. It 
also displays a status message for each sensor, indicating the result of the most recent action 
attempted.

Select a sensor and then choose a command from the Action menu or from the shortcut menu 
that appears when you right-click a sensor. The availability of commands depends on the 
permissions granted to you by your assigned role.

The commands are:

Administration

The Administration group has 12 shortcuts:

• Activity Log 

Note: If you do not see a list of installed sensors, you must install the Microsoft .NET 
Framework version 3.5 Service Pack 1. 

Command Definition

Edit Sensor Details Modify the name, location, and description.

Stop Scan Abort the scan. The job cannot be resumed.

Suspend Scan Interrupt the scan. The scan can then be manually resumed later.

Pause Sensor Temporarily halt the sensor. Note: This feature is a transient state 
held in memory on the sensor; it will not be remembered if the 
sensor service is ever restarted. For a long-term status, disable the 
sensor.

Continue Sensor Enable the sensor after pausing. If the sensor was running a scan 
when paused, it will resume the scan automatically.

Enable/Disable Turn the sensor on or off. You must be a member of the security 
administrator’s group to enable a new sensor.

Rename Sensor Change the sensor name.

Migrate Sensor Reassign all schedules, pending scans, etc., from one sensor to 
another. Used primarily when installing a replacement sensor.

Delete Sensor Disassociate the sensor from the WebInspect Enterprise system.

Note: To enable this command, you must stop the “WebInspect 
Enterprise Sensor for WebInspect” service (Start/Control Panel/
Administrative Tools/Services), taking the sensor offline.
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• Connected Users 

• Licensing 

• Smart Update 

• Smart Update Approval

• Export Paths 

• E-Mail Alerts 

• SNMP Alerts 

• Sensor Users 

• Roles and Permissions

• Proxy Server Settings 

• Software Security Center

Activity Log

The Activity Log lists each WebInspect Enterprise activity. Each item includes (by default):

• The time and date the event occurred

• A message indicating the event or activity

• For scan-related events, the URL or IP address or the job name associated with this 
activity

• The sensor associated with this activity

• The Windows credentials of the user

• The IP address of the workstation

You can display all entries in the Activity Log or restrict the listing to those activities that 
occurred on or after a specific date.

To limit the size of the Activity Log, click Activity Log Settings (at the bottom of the form).

Select a command from the Action menu or from the shortcut menu that appears when you 
right-click an item in the list. The availability of commands depends on the permissions 
granted to you by your assigned role.

The commands are:

Command Definition 

Export Activity Log to [TSV / 
CSV / XML] 

Save the activity log to a text file using either a 
tab-separated, comma-separated, or XML format.

Clear Activity Log Delete all entries in the activity log.

Copy Message(s) to 
Clipboard

Copy the text in all columns of all selected list entries.

Column Setting Open the Column Setting window, allowing you to specify 
which columns should appear in the list.
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Connected Users

This form lists each user who is currently logged in to the WebInspect Enterprise system. 
Each item includes:

• Application Type

• Application Subtype 

• Application Version

• The user's name

• IP Address

• The time and date when the user connected to the system

• Status

• Message

A summary at the bottom of the panel shows the total number of user licenses in use, the total 
number of available user licenses, and the timeout period (which you can edit).

Select a command from the Action menu. The availability of commands depends on the 
permissions granted to you by your assigned role.

The commands are:

Licensing

This form lists the license information and activation ID issued by HP for the operation of 
WebInspect Enterprise.

• Activation ID: The unique identifier for the license issued by HP. 

• User Information: Information about the person to whom the license is granted.

• License Information

— Licenses IP or Host Ranges: The IP addresses or hosts to which scans are restricted.

— Bypass DNS: Indicates if the application is allowed to bypass a domain name server.

— Valid To: The ending date of the period for which the license is valid.

— Total Available Sensor Licenses: The maximum number of sensors that may be 
connected to WebInspect Enterprise.

— Total Available Client Licenses: The maximum number of clients that may be 
connected to WebInspect Enterprise.

— Total Scan Count: The maximum number of scans that may be conducted.

— Maintenance End Date.

Command Definition

Release user license Intended for use with licenses that permit multiple users. 
Disassociate the selected user from the license, allowing another 
user to occupy that position.

Column Setting Open the Column Setting window, allowing you to specify which 
columns should appear in the list.
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• License Usage Information 

— Available Scan Count: Remaining number of scans allowed. 

— Total in use sensor licenses: Number of licensed sensors in use. 

— Total in use concurrent user licenses: Number of concurrent licensed sensors in use.

Smart Update

HP engineers uncover new vulnerabilities almost every day. They develop attack agents to 
search for these malicious threats and then update our corporate database so that you will 
always be on the leading edge of Web application security.

Use Smart Update to obtain HP’s latest adaptive agents, as well as vulnerability and policy 
information. Each time you log in to the WebInspect Enterprise Administrative Console, it 
contacts the WebInspect Enterprise manager and downloads any available console binary 
updates.

The Smart Update form lists each update package downloaded from HP. Each item includes 
(by default):

• The time and date the download began.

• The time and date the download ended.

• The status of the event.

• If applicable, an error message describing any problem that occurred.

Select an entry in the SmartUpdate History list to display details about that event.

This form also lists any updates that have been scheduled. Each item includes (by default):

• The name assigned to the update. 

• The frequency with which it is scheduled to occur (if it is a recurring event). 

• The date and time it last occurred (for recurring events only). 

• The date and time it is scheduled to occur. 

Select a command from the Action menu. The availability of commands depends on the 
permissions granted to you by your assigned role.

The commands are:

If your WebInspect Enterprise manager cannot connect to the Internet, contact HP Support 
to obtain an offline SmartUpdate utility.

Command Definition

Clear Completed Updates Delete the list of Smart Updates that have been completed.

Add Schedule Open the Smart Update Settings window, allowing you to 
schedule a Smart Update.
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If you need to use a proxy server to communicate with the HP Smart Update database, select 
the Proxy Server Settings shortcut in the Administration group. 

Note that scans cannot start while sensors are receiving a Smart Update. Scheduled scans 
stay in “pending” state until Smart Update completes. This prevents sensors from picking up 
partial Smart Updates when they update their local SecureBase from WebInspect Enterprise.

Smart Update Approval

This form lists all binary updates that have been received for WebInspect Enterprise’s client 
products, such as WebInspect, DevInspect, QAInspect, and sensors. None of these 
applications can be updated until an administrator specifically approves the update. Items in 
the list can be grouped according to product, importance, or approval status.

The possible approval statuses are:

• Not Approved—Update has not yet been reviewed by the administrator.

• Approved—Update has been approved by the administrator and is available to clients.

• Decline—Update has been withheld by the administrator and is not available to clients.

Once administrative approval is obtained, the update becomes available to client applications. 
For those having a user interface (WebInspect, QAInspect, and DevInspect), the Smart 
Update utility displays a window notifying users that an update is available. Users may 
either accept or reject the update. Updates for sensors (which do not have a user interface) are 
controlled by the WebInspect Enterprise Manager. If approved updates are available, a sensor 
will be required to download and apply the update before a scan can be assigned.

Typically, administrators prefer to update a single application instance and test it before 
performing a system-wide installation. This can be done by manually installing the updates 
on a test system. Sensor scans can be tested on a non-approved version of WebInspect by 
selecting the specific sensor when configuring the scan in WebInspect Enterprise.

Ordinarily, sensors that are running a non-approved version of WebInspect (such as a special 
build developed for a specific customer) will not be selected to run a scan when you choose the 
Use Any Available option. You can remove that restriction, however, by selecting the 
non-approved sensor on the Sensors form and then selecting the option Can participate in “Any 
Available” sensor scans. Sensors that are newer than the latest approved version are then 
eligible to be selected. 

Select a command from the Action menu or from the shortcut menu that appears when you 
right-click an item in the list. The availability of commands depends on the permissions 
granted to you by your assigned role.

Edit Schedule Open the Smart Update Settings window, allowing you to 
modify the settings for the scheduled Smart Update selected 
in the Smart Update Schedules list.

Delete Schedule Delete the Smart Updates selected in the Smart Update 
Schedules list.

History Column Setting Open the Column Setting window, allowing you to specify 
which columns should appear in the Smart Update History 
list.

Command Definition
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The commands are:

Note that scans cannot start while sensors are receiving a Smart Update. Scheduled scans 
stay in “pending” state until Smart Update completes. This prevents sensors from picking up 
partial Smart Updates when they update their local SecureBase from WebInspect Enterprise.

Export Paths

This form displays a list of destinations (paths) that may be used for saving scan results. 
WebInspect Enterprise uses these paths to populate the drop-down list from which Web 
Console users select a location for storing the data.

Select a path and then choose a command from the Action menu or from the shortcut menu 
that appears when you right-click an export path. The availability of commands depends on 
the permissions granted to you by your assigned role.

The commands are:

Creating or Editing Export Paths

You can designate destinations (paths) that may be used for saving scan results.

1 Click the Administration group.

2 Select the Export Paths shortcut.

3 To add a path:

a Select Add from the Action menu
- or -
Right-click in the Export Paths list and select Add from the shortcut menu.

b On the Export Path Settings dialog, enter a path using the Universal Naming 
Convention (or click the Browse button and select a folder).

If you browse for a folder and select a local (rather than network) folder, the selection 
refers to the hard drive of the machine on which the WebInspect Enterprise manager 
is installed. Also note that the WebInspect Enterprise manager must have access to 
any location you designate as an export path. 

c Click OK. 

4 To edit a path:

Command Definition 

Approve Make the binary update available to clients.

Decline Withhold distribution of the binary update.

Command Definition 

Add Open the Export Path Settings window, allowing you to specify 
export paths. 

Edit Open the Export Path Settings window, allowing you to modify 
export paths. 

Delete Remove the path from the form. 
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a Select an entry in the Export Paths list.

b Select Edit from the Action menu
- or -
Right-click an entry in the Export Paths list and select Edit from the shortcut menu.

c Modify the path using the Universal Naming Convention (or click the Browse button 
and select a folder).

If you browse for a folder and select a local (rather than network) folder, the selection 
refers to the hard drive of the machine on which the WebInspect Enterprise manager 
is installed. Also note that the WebInspect Enterprise manager must have access to 
any location you designate as an export path. 

d Click OK.

5 To delete a path:

a Select an entry in the Export Paths list.

b Select Delete from the Action menu
- or -
Right-click an entry in the Export Paths list and select Delete from the shortcut menu.

You cannot remove an export path that is currently being used or is associated with a 
scheduled scan. 

E-Mail Alerts

You can force WebInspect Enterprise to send an e-mail message whenever certain events 
occur. Such a message is called an e-mail alert.

This form lists all e-mail alerts configured for the system. Each item includes:

• The name of the alert

• The address of the e-mail recipient

• The IP addresses of scanned sites that may elicit an alert

• The events or actions about which the recipient is to be notified

• The organization

• The group

SMTP Settings

If necessary, click SMTP Settings (at the bottom of the form) to configure Simple Mail Transfer 
Protocol (SMTP) settings if you plan to send e-mail notifications for specific WebInspect 
Enterprise events.

SMTP Server—The name of the server used for outgoing e-mail.

SMTP Port—The numbered port used for outgoing e-mail.

Sender—The text that will be appear in the “From” field of the e-mail. It need not be a valid 
e-mail account, but it must be in the format text@text.text , where text is any text you care to 
enter.

Use SSL—Select this check box to use Secure Sockets Layer (SSL) protocol.
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Authentication—If your server requires authentication, select Basic or NTLM, and then provide 
a user name and password.

Commands

Select an alert and then choose a command from the Action menu or from the shortcut menu 
that appears when you right-click an alert. The availability of commands depends on the 
permissions granted to you by your assigned role.

The commands are:

Creating or Editing E-Mail Alerts

You can instruct the WebInspect Enterprise manager to send an e-mail message to someone 
whenever certain events occur.

1 Click the Administration group.

2 Select the E-mail Alerts shortcut.

The E-mail Alerts form lists all alerts configured for the system.

3 To add an alert: 

a Select Add from the Action menu
- or -
Right-click in the E-mail Alerts list and select Add from the shortcut menu.

b On the E-Mail Alert Settings dialog, enter a name for the alert.

c Select either System, Organization, or Group.

d If you did not select System, choose a group or organization from the list.

e Enter the e-mail address of the person who should receive the alert.

f If the alert should be sent only when selected actions occur related to a specific IP 
address or range of IP addresses, enter the address or range. For a range, use a 
hyphen to separate the lower address from the higher (example: 
111.222.254.254-125.254.254.254). Separate multiple addresses or ranges with a 
semicolon. Enter an asterisk (*) to allow alerts for all IP addresses.

g Select one or more actions that will trigger the alert. 

h Click OK.

4 To edit an alert: 

a Select an entry in the E-mail Alerts list.

b Select Edit from the Action menu.
- or -
Right-click an entry in the E-mail Alerts list and select Edit from the shortcut menu.

5 To delete an alert: 

Command Definition 

Add Specify settings for an alert.

Edit Modify settings for an alert.

Delete Remove the alert from the form.
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a Select an entry in the E-mail Alerts list.

b Select Delete from the Action menu
- or -
Right-click an entry in the E-mail Alerts list and select Delete from the shortcut menu.

SNMP Alerts

You can force WebInspect Enterprise to send a Simple Network Management Protocol 
(SNMP) message whenever certain events occur. Such a message is called an SNMP alert.

This form lists all SNMP alerts configured for the system. Each item includes:

• The name of the alert

• The IP address of the SNMP alert recipient.

• The action or event that will trigger the alert.

• The organization.

• The group. 

SNMP Settings

If necessary, click SNMP Settings (at the bottom of the form) to configure SNMP settings if you 
plan to send SNMP notifications for specific WebInspect Enterprise events.

SNMP Host—The IP address of the server that will receive the alert and forward it to the 
intended recipient.

SNMP Port—The port number for SNMP alerts on the SNMP host.

Community—An SNMP community is a text string that acts as a password for authenticating 
messages sent between the management station (the SNMP manager) and the device (the 
SNMP agent). There are typically two types of community names:

• A read-only community name that allows queries of the agent.

• A read-write community name that allows an NMS to perform set operations.

Commands

Select an alert and then choose a command from the Action menu or from the shortcut menu 
that appears when you right-click an alert. The availability of commands depends on the 
permissions granted to you by your assigned role.

The commands are:

Command Definition 

Add Specify settings for an alert.

Edit Modify settings for an alert.

Delete Remove the alert from the form.
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Creating or Editing SNMP Alerts

You can instruct the WebInspect Enterprise manager to send a Simple Network Management 
Protocol (SNMP) message whenever certain events occur.

1 Click the Administration group.

2 Select the SNMP Alerts shortcut.

The SNMP Alerts form lists all alerts configured for the system.

3 To add an alert: 

a Select Add from the Action menu
- or -
Right-click in the SNMP Alerts list and select Add from the shortcut menu.

b Enter a name for this alert.

c Enter the IP address of the SNMP-compliant device that should receive the alert. You 
can specify multiple addresses or a range of addresses. For a range, use a hyphen to 
separate the lower address from the higher (example: 
111.222.254.254-125.254.254.254). Separate multiple addresses or ranges with a 
semicolon.

Enter an asterisk (*) to allow alerts for all IP addresses.

d Select one or more actions that will trigger the alert.

e Click OK.

4 To edit an alert: 

a Select an entry in the SNMP Alerts list.

b Select Edit from the Action menu.
- or -
Right-click an entry in the SNMP Alerts list and select Edit from the shortcut menu.

c If necessary, modify the name of this alert.

d Modify the IP address of the SNMP-compliant device that should receive the alert. 
You can specify multiple addresses or a range of addresses. For a range, use a hyphen 
to separate the lower address from the higher (example: 
111.222.254.254-125.254.254.254). Separate multiple addresses or ranges with a 
semicolon.

Enter an asterisk (*) to allow alerts for all IP addresses.

e Select or deselect one or more actions that will trigger the alert.

5 To delete an alert: 

a Select an entry in the SNMP Alerts list.

b Select Delete from the Action menu.
- or -
Right-click an entry in the SNMP Alerts list and select Delete from the shortcut menu.

Sensor Users

This form lists all WebInspect sensor accounts, which exist to run scans on behalf of 
WebInspect Enterprise users.

You must create at least one Windows user account and assign it to the sensor service. 
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To add an account:

1 Click Add. 

2 Enter the account assigned to the sensor. 

3 Click OK.

To remove an account:

1 Select an account from the list.

2 Click Remove.

Roles and Permissions

This form allows you to assign administrators for three security levels (system, organization, 
and group). Administrators can then define roles, assign users to roles, and configure other 
security-related parameters. For an overview of the WebInspect Enterprise hierarchical 
structure, see Assign Administrators and Create Roles on page 28.

Roles

A role is simply a named collection of permissions. You can allow other users to access the 
WebInspect Enterprise system and limit the functions they are allowed to perform by 
assigning them to a role. Also, a single user may be a member of more than one role.

The roles for each security level (system, organization, and group) contain a different set of 
permission categories. Each category contains multiple permissions, such as Can Create, Can 
View, Can Update, Can Delete, etc.

System Roles

System roles contain the activity categories listed below. 

• Activity Log

• Licensing

• SmartUpdate

• E-mail Alerts

• SNMP Alerts

• Export Paths

• Sensors

• Policies

Organization Roles

Organization roles contain the activity and object categories listed below.

• Blackouts

• Policies

• E-mail Alerts

• SNMP Alerts
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Group Roles

Group roles contain the activity and object categories listed below. 

• Scans

• Scan Templates

• Scheduled Scans

• E-mail Alerts

• SNMP Alerts

• Blackouts

• HP Toolkit

Select an entry in the Security Group Hierarchy tree (WebInspect Enterprise System, an 
organization, or a group) and then provide the information requested on each of the related 
tabs that appear in the Permissions section on the right-hand pane.

You can also choose a command from the Action menu or from the shortcut menu that appears 
when you right-click an object in the Security Group Hierarchy tree. The commands are: 

Command Definition 

Add Organization Create an organization.

Rename Organization Change the name of an organization.

Remove Organization Delete an organization.

Add Group Create a group.

Rename Group Change the name of a group.

Remove Group Delete a group

Add User(s) to Roles Add multiple users to roles. See Add Users to Roles on 
page 60 for more information.

Role Membership and 
Removal

Display roles assigned to a selected user or group.

1 Enter an NT user or group name, or click Browse to 
select a user or group.

If you enter your own user name or the name of a group 
of which you are a member, the program displays all the 
roles to which you are assigned.

If you enter a user name or group name other than your 
own, you must be an administrator. The program will 
display the roles to which the specified user or group is 
assigned, but only for those organizations and groups of 
which you are an administrator.

2 Click Search.

3 To remove a user or group from a role, select the user or 
group and click Remove.
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System Roles and Permissions

When you select WebInspect Enterprise System from the Security Group Hierarchy pane, three 
tabs appear in the System Permissions section.

• Administrators

• Roles

• Global Roles

From any tab, you can create an organization using the following procedure:

1 Select WebInspect Enterprise System in the Hierarchy pane.

2 Click Action and select Add Organization.

Every system must have at least one organization.

3 On the Create Organization dialog, type a name for the organization and click OK.

Administrators Tab

To add or remove a system administrator:

1 Select WebInspect Enterprise System in the Hierarchy pane.

2 Click the Administrators tab.

3 To add a system administrator: 

a Click Add.

b Select a domain or work group in the From this location list.

c In the text box below, type a Windows account name.

d To verify the name, click Check Names.

e Click OK.

4 To delete a system administrator: 

a Select a group or user name.

b Click Remove.

Roles Tab

To create a system role:

1 Select WebInspect Enterprise System in the Hierarchy pane.

2 Click the Roles tab. 

3 Click Add.
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4 On the New Role dialog, enter a name for the role, select the default permission that will 
be assigned to each activity, and click OK. 

5 In the Permissions list, expand the nodes to view the activities associated with each 
category.

6 To assign the same permission to all activities within a single category: 

a Click the category name (such as “Activity Log”).

b Click the drop-down arrow that appears on the far right end of the row.

c Select a permission.

7 To change permission for a single activity: 

a Click the activity name (such as “Can view log”).

b Click the drop-down arrow that appears on the far right end of the row.

c Select a permission.

To assign groups or users to a role:

1 Select a name from the Role name list.

2 Click Add (on the far right of the Group or user names section).

3 On the Select Users or Groups dialog, select a domain or work group in the From this 
location list.

4 In the text box below, type a Windows account name.

5 To verify the name, click Check Names.

6 Click OK.

You can copy a role and keep it at the system level or assign it to an organization or group. 

To copy a role:

1 Click the Roles tab.

2 Select a role from the Role name list.

3 Click Copy.

4 On the Copy Role dialog, select the organization or group to which the role will be 
assigned. 

Having separate options for “Allowed,” “Unassigned,” and “Denied” may seem 
redundant in a binary world. However, it permits WebInspect Enterprise to 
resolve conflicting permissions when a user is a member of more than one role. 
These are the controlling guidelines:

• “Allowed” outranks “Unassigned”—If the permission for a certain activity in 
Role A is “Allowed” and the permission for the same activity in Role B is 
“Unassigned,” then a user who is a member of both Role A and Role B may 
perform the activity.

• “Denied” outranks “Allowed”—If the permission for a certain activity in Role A 
is “Allowed,” and the permission for the same activity in Role B is “Denied,” 
then a user who is a member of both Role A and Role B may not perform the 
activity.

• “Unassigned” (only) equals “Denied”—If a user’s permission for a certain 
activity is “Unassigned” and no other permissions are assigned to that user in 
another role for the same activity, then the user may not perform the activity.
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The same role can be assigned to multiple organizations and groups.

5 To retain the list of users assigned to this role, select Copy Users. Otherwise, the role will 
be copied, but no users will be associated with this role when placed in the location you 
specify.

6 To retain the permissions assigned to this role, select Copy Permissions. This option is not 
available when copying or moving a system role to an organization or a group.

7 Select the location where this copy of the role should be placed. 

You cannot copy a role to an organization or group unless you are an administrator of that 
organization or group. 

8 Click OK.

Organization Roles and Permissions

Security within the WebInspect Enterprise system is arranged according to a hierarchy of 
organizations and groups. You may have one or more organizations, and each organization 
may have one or more subservient groups. At installation, there is one organization named 
Default Organization, which contains one group named Default Group. When you select an 
organization from the Security Group Hierarchy pane, five tabs appear in the Organization 
Permissions section.

• Administrators

• Configuration

• Roles

• Resources

• Move/Copy Objects

Administrators Tab

To add or remove an organization administrator:

1 Select an organization in the Hierarchy pane.

2 Click the Administrators tab.

3 To add an organization administrator: 

a Click Add.

The Select Users or Groups window opens.

b Select a domain or work group in the From this location list.

c In the Enter the object names to select text box, type a Windows account name.

d To verify the name, click Check Names.

e Click OK.

4 To delete an organization administrator: 

a Select a group or user name.

b Click Remove.
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Configuration Tab

Maximum Scan Priority

If two or more scans are scheduled to occur during the same time period, the scan with the 
highest priority will take precedence. For each organization, you can specify the maximum 
priority level that may be assigned to scans.

Select the highest priority level that a user in this organization may assign to a scan. Choices 
range from 1 (highest priority) to 5 (lowest priority).

More severe restrictions can be assigned to a group within the organization. For example, if 
the maximum priority for an organization is 3, the administrator of a group within that 
organization may set the group maximum priority to either 3, 4, or 5. The group's maximum 
scan priority may not be set to 1 or 2, however. 

Organization Options

Disable Retest Browser Tab - The Retest feature allows you to view the server's response as 
rendered in a browser. Retesting a cross-site scripting vulnerability, however, may cause the 
script to loop infinitely on the Browser tab when using Microsoft Internet Explorer. 

Roles Tab

To create an organization role:

1 Click Add (to the right of the Role name list).

2 On the New Role dialog, enter a name for the role, select the default permission that will 
be assigned to each activity, and click OK. 

3 In the Permissions list, expand the nodes to view the activities associated with each 
category.

4 To assign the same permission to all activities within a single category: 

a Click the category name (such as “Blackouts” or “Policies”).

b Click the drop-down arrow that appears on the far right end of the row.

c Select a permission.

5 To change permission for a single activity: 

a Click the activity name (such as “Can create” or “Can view”).

b Click the drop-down arrow that appears on the far right end of the row.

c Select a permission.

To assign users to a role:

1 Select a name from the Role name list.

2 Click Add (on the far right of the Group or user names section).

3 On the Select Users or Groups dialog, select a domain or work group in the From this 
location list.

4 In the text box below, type a Windows account name.

5 To verify the name, click Check Names.

6 Click OK.
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You can create a copy of a role and place it at any level (system, organization, or group). You 
can also move a role from one organization to another (which will remove it from the original 
organization).

To copy or move a role:

1 Select a role from the Role name list.

2 Click Copy.

3 On the Copy Role dialog, select the organization or group to which the role will be 
assigned. 

The same role can be assigned to multiple organizations and groups.

4 To retain the list of users assigned to this role, select Copy Users. Otherwise, the role will 
be copied, but no users will be associated with this role when copied to the location you 
specify.

5 To retain the permissions assigned to this role, select Copy Permissions. This option is not 
available when copying an organization role and assigning it to a group or the system.

6 Select the location where this copy of the role should be placed.

7 To place a copy of the role in the selected location, click OK.

8 To move the role from its original location to the selected location, click Move.

Resources Tab

You can specify which resources are available to an organization. For example, the 
WebInspect Enterprise system contains 20 scanning policies. Your organization may choose to 
allow only 10 of them. 

Note: The group administrator may further restrict which resources are available to a group.

1 Select an item in the Object Type list. 

If objects of the selected type have never been assigned, all instances of those object types 
are displayed in the Available column.

If object types have previously been assigned, then object types may be distributed 
between the Available and Allowed columns.

2 To move object types from the Available column to the Allowed column, select one or more 
object types and click .

3 To move all object types to the Allowed column, click .

4 To move selected object types from the Allowed column and return them to the Available 
column, select one or more object types and click .

5 To move all objects from the Allowed column and return them to the Available column, click 
.

You cannot copy or move a role to an organization or group unless you are an administrator of 
that organization or group. 
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Move/Copy Objects Tab

You can assign an object to a different organization (and optionally to a group) by either 
moving it or copying it. Moving an object removes it from its currently assigned location. 
Copying an object retains its current location while also placing a copy in a new location.

1 Select an organization from the Hierarchy tree.

2 Select an item from the Object Type list.

3 Click Retrieve. 

All user-created objects of the selected type appear in the Object Results list.

4 Select one or more of the listed objects. If you select multiple objects, they cannot be 
moved or copied to different locations.

5 Click Move or Copy.

6 On the Move Objects or Copy Objects window, select an organization from the Target 
Organization list.

7 (Optional) Select a group from the Security Group list.

8 Click Move or Copy.

9 If the object being moved or copied has dependent relationships with other objects, the 
related objects appear in the Object Dependencies list.

For example, if you are moving a user-created scan template from one organization to 
another, and that template uses a scan policy that is not in the target organization, then 
you must also move (or copy) the scan policy. 

a For each dependent object, click the drop-down arrow in the Action column under 
Object Dependencies and select the appropriate action (such as Move to, Copy to, or 
Allow). 

b Click Move or Copy. 

10 When a dialog appears informing you that all dependencies have been satisfied and 
prompting you to confirm that transfer, click Yes. 

Group Roles and Permissions

Each group must be associated with an organization. If you do not want a certain user to see 
certain scans, you must create separate groups and assign the user to a role in one group or 
the other.

Creating a Group

Each organization can have one or more groups. Use the following procedure to create a 
group.

1 In the Hierarchy pane, select an organization.

2 Click Action and select Add Group.

The Create Group dialog appears.

3 Type a name for the group in the Name box. 

4 If you want the group to have unrestricted access to all resources that are available to the 
organization, select Allow access to all of the organization’s current resources.
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5 Select the highest priority level that a user in this group may assign to a scan. Choices 
range from 1 (highest priority) to 5 (lowest priority).

If two or more scans are scheduled to occur during the same time period, the scan with the 
highest priority will take precedence. Your choices may be restricted by your organization.

6 In the Scan Permissions group, click Add. 

7 In the Host box, type a host name (wild cards allowed), IP address, or IP address range, 
and click OK.

8 In the Properties group, you may:

a Change the IP address or host name.

b Change permissions for running a Web Site scan and Web Service scan.

9 Click OK to close the Create Group dialog.

Notice that users who create an organization or group are automatically assigned as 
administrators of that organization or group.

Administrators Tab

To add or remove a group administrator:

1 Select a group in the Hierarchy pane.

2 Click the Administrators tab.

3 To add a group administrator: 

a Click Add.

The Select Users or Groups window opens.

b Select a domain or work group in the From this location list.

c In the Enter the object names to select text box, type a Windows account name.

d To verify the name, click Check Names.

e Click OK.

4 To delete a group administrator: 

a Select a group or user name.

b Click Remove.

Configuration Tab

Group Maximum Scan Priority

If two or more scans are scheduled to occur during the same time period, the scan with the 
highest priority will take precedence. For each group, you can specify the maximum priority 
level that may be assigned to a scan. Your choices may be restricted by your organization.

Select the highest priority level that a user in this group may assign to a scan. Choices range 
from 1 (highest priority) to 5 (lowest priority).
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Group IP and Host Permissions

For each group, the ability to scan web sites is restricted to those IP addresses or hosts 
specified here. 

1 Click Add.

2 Enter an IP address or host name and click OK.

To specify a range of addresses, enter the lowest numerical address, followed by a dash (-), 
and then followed by the highest numerical address, such as 134.55.33.4-134.55.33.244.

You can also use wild cards, such as 134.55.33.* and www.mysite.*. Enter only an 
asterisk ( * ) to allow all possible IP addresses.

3 In the Properties pane, select Can Run Scan, click the drop-down arrow that appears, and 
select either Unassigned, Allowed, or Denied. 

4 Repeat steps 1-3 to specify additional targets.

Roles Tab

1 Select a group in the Hierarchy pane.

2 Click the Roles tab.

To create a group role:

1 Click Add (to the right of the Role name pane).

2 On the New Role dialog, enter a name for the role, select the default permission that will 
be assigned to each activity, and click OK.

3 In the Permissions list, expand the nodes to view the activities associated with each 
category.

4 To assign the same permission to all activities within a single category:

a Click the category name (such as “Blackouts” or “Policies”).

b Click the drop-down arrow that appears on the far right end of the row.

c Select a permission.

5 To change permission for a single activity:

a Click the activity name (such as “Can create” or “Can view”).

b Click the drop-down arrow that appears on the far right end of the row.

c Select a permission.

To assign users to a role:

1 Select a role from the Role Name list and click Add (to the right of the User group or user 
names pane).

The Select Users Or Groups window appears.

2 Enter a Windows account name. 

3 To verify the name, click Check Names. 

4 Click OK. 
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Alternatively, you can select from a list of account names.

1 Click Advanced. 

2 Select a location.

3 Click Find Now to return a list of all accounts associated with the selected location.

Note: To filter the list, use the controls in the Search Criteria group first.

4 Select one or more accounts or groups and click OK.

If your domain server uses the Microsoft Windows 2000 or 2003 operating system, and you 
have more than 1000 users on your network, you must modify the Lightweight Directory 
Access Protocol (LDAP) policies used by the Microsoft Active Directory® service. Specifically, 
you must change the maximum page size that is supported for LDAP responses (which is set 
by default to 1,000 records). Alternatively, you can limit your search criteria so that fewer 
than 1000 records will be returned. For detailed information, refer to http://
support.microsoft.com/default.aspx?scid=kb;en-us;315071&amp;sd=tech.

To copy or move a role:

You can create a copy of a role and place it at any level (system, organization, or group). You 
can also move a role from one group to another (which will remove it from the original group).

You cannot copy or move a role to an organization or group unless you are an administrator of 
that organization or group. Also, you cannot rename or remove a global role.

1 Select a role from the Role name list.

2 Click Copy.

3 On the Copy Role dialog, select the organization or group to which the role will be 
assigned. 

The same role can be assigned to multiple organizations and groups. The permissions 
associated with a role can be copied only between similar levels (that is, from one group to 
another or from one organization to another).

4 To retain the list of users assigned to this role, select Copy Users. Otherwise, the role will 
be copied, but no users will be associated with this role when copied to the location you 
specify.

5 To retain the permissions assigned to this role, select Copy Permissions. This option is not 
available when copying an organization role and assigning it to a group or the system.

6 Select the location where this copy of the role should be placed. 

7 To place a copy of the role in the selected location, click OK.

8 To move the role from its original location to the selected location, click Move.

Resources Tab

You can specify which resources are available to groups within an organization. For example, 
the WebInspect Enterprise system contains 17 scanning policies. Your organization may 
choose to allow only 10 of them. Of those 10 available, you might choose to allow only 5 to be 
used in your group.

1 Select an item in the Object Type list. 

If objects of the selected type have never been assigned, all instances of those object types 
are displayed in the Available column.
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If object types have previously been assigned, then object types may be distributed 
between the Available and Allowed columns.

2 To move object types from the Available column to the Allowed column, select one or more 
object types and click .

3 To move all object types to the Allowed column, click .

4 To move selected object types from the Allowed column and return them to the Available 
column, select one or more object types and click .

5 To move all objects from the Allowed column and return them to the Available column, click 
.

Move/Copy Objects Tab

You can assign an object to a different group (and optionally to a organization) by either 
moving it or copying it. Moving an object removes it from its currently assigned location. 
Copying an object retains its current location while also placing a copy in a new location.

1 Select a group or organization from the Security Group Hierarchy tree.

2 Select an item from the Object Type list.

3 Click Retrieve. 

All user-created objects of the selected type appear in the Object Results list.

4 Select one or more of the listed objects. If you select multiple objects, they cannot be 
moved or copied to different locations.

5 Click Move or Copy.

6 On the Move Objects or Copy Objects window, select an organization from the Target 
Organization list.

7 Select a group from the Security Group list.

8 Click Move or Copy.

9 If the object being moved or copied has dependent relationships with other objects, the 
related objects appear in the Object Dependencies list.

For example, you are not allowed to move a user-created (custom) policy from 
Organization A to Organization B if that policy is to be used for a scheduled scan in 
Organization A.

a For each dependent object, click the drop-down arrow in the Action column under 
Object Dependencies and select the appropriate action (such as Move to, Copy to, or 
Allow). 

b Click Move or Copy. 

10 When a dialog appears informing you that all dependencies have been satisfied and 
prompting you to confirm that transfer, click Yes. 

Proxy Server Settings

If you use a proxy server to communicate with HP for Smart Updates and licensing issues, 
select Use Proxy Server and then provide the requested information.

Smart Update is not available if you use a SOCKS4 or SOCKS5 proxy server configuration. 
Smart Update is available through a proxy server only when using a standard proxy server.
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Software Security Center

To publish scans to the HP Fortify Software Security Center, you must first configure the 
settings.

1 Click the Administration group.

2 Select the Software Security Center shortcut.

3 Enter the following information:

• URL: The URL of the Software Security Center server. 

• Allow a non-trusted server certificate: Select this option to allow a certificate that a 
certification authority has revoked, or a certificate that for other reasons has been 
placed in the Untrusted Certificates folder on your computer.  

• Use proxy server settings: Select this option to use the settings specified under Proxy 
Server Settings.  

• Credentials: Enter the name and password of the user who was assigned to the 
WebInspect Enterprise System role, as created in Software Security Center. Using the 
SSC administrator’s account is not recommended. 

4 To verify the settings, click Test. 

5 To save the settings, click Save.

Common WebInspect Enterprise Administrative Console Tasks

Configure the Console

Use the following procedure to specify settings for the WebInspect Enterprise Administrative 
Console.

1 From the Tools menu, select Options.

2 To refresh the display of WebInspect Enterprise information periodically, select the 
Automatically refresh display check box and specify how often (in seconds) the display 
should be updated.

3 Click OK.

Suspend a Scan

After a scan has started, you can suspend it and then later restart it at the point at which it 
was suspended.

To suspend a scan:

1 Click the Scans group.

2 Click the Scan Queue shortcut. 

3 Select a scan.

4 Select Suspend from the Action menu (or from the shortcut menu that appears when you 
right-click a scan). 
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The scan request displays a status message of “Suspended (Manual).”

Resume a Suspended Scan

To resume a suspended scan:

1 Click the Scans group.

2 Click the Scan Queue shortcut.

3 Select the scan you want to resume.

4 Select Resume from the Action menu (or from the shortcut menu that appears when you 
right-click a scan)

If the sensor that started the scan is available, then that sensor will reload the scan data and 
resume scanning.

If the sensor that started the scan is now running a different scan, then that sensor will 
compare the priority of both scans. If the first (suspended) scan has a lower priority, the 
sensor will place it back in the queue and continue running the current scan. If the first scan 
has a higher priority, the sensor will suspend the second scan (placing it in the queue), reload 
the data from the first scan, and resume scanning.

Resumed scans are always assigned to the same sensor on which the scan was initiated.

Stop a Scan

To stop a scan:

1 Click the Scans group.

2 Click the Scan Queue shortcut.

3 Select the scan you want to stop.

4 Select Stop from the Action menu (or from the shortcut menu that appears when you 
right-click a scan).

The scan request is removed from the list.

Pause a Sensor

Use this function to pause a sensor. If a scan is running on that sensor, the job will be 
suspended.

This feature is used when conducting maintenance on the machine that contains the sensor, 
or when you simply want to prevent the sensor from accepting any scans.

1 Click the Sensors group.

2 Select the sensor you want to pause.

3 Select Pause Sensor from the Action menu (or from the shortcut menu that appears when 
you right-click a sensor).
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Continue a Paused Sensor

Use this function to enable a sensor that you previously disabled by using the Pause 
command. If a scan was running on that sensor when the sensor was paused, the scan will 
resume.

1 Click the Sensors group.

2 Select the sensor you want to continue. “Paused” must appear in the Status column.

3 Select Continue Sensor from the Action menu (or from the shortcut menu that appears 
when you right-click a sensor).

Perform a Smart Update

Use Smart Update to download HP’s latest adaptive agents and programs, as well as 
vulnerability and policy information.

To conduct a Smart Update, click the Smart Update icon on the toolbar

- or -

click the Tools menu and select Smart Update.

Note that scans cannot start while sensors are receiving a Smart Update. Scheduled scans 
stay in “pending” state until Smart Update completes. This prevents sensors from picking up 
partial Smart Updates when they update their local SecureBase from WebInspect Enterprise.

Schedule a Smart Update

To scheduled a Smart Update:

1 Click the Administration group.

2 Click the Smart Update shortcut.

3 Click the Action menu and select Add Schedule.

4 In the General category:

a Type a name for the event in the Scheduled Smart Update Name box.

b In the Start Time box, specify the date and time when Smart Update should run.

c To change the date, click the drop-down arrow and select a date from the calendar. 

d To define an iterative process, click the Recurrence category (in the left column).

5 In the Recurrence category:

a Select the Recurring check box.

Note: Do NOT select this option if you want to schedule a one-time-only event.

b Use the Pattern group to select the frequency of the event (daily, weekly, monthly, or 
yearly) and then provide the appropriate information.

c Using the Range group, specify the starting date and the ending date (or select Never if 
the event is to run indefinitely). You can also limit the number of times the Smart 
Update should occur.

6 Click OK to schedule the update.
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View Activity Log

You can view information about significant events that occur and are logged by the 
WebInspect Enterprise manager. Each event is sorted according to the time and date at which 
the event occurred.

To view the activity log:

1 Click the Administration group.

2 Click the Activity Log shortcut.

Add Users to Roles

You can add a user to roles at each individual organization or group, repeating the process as 
often as necessary until the user has been inserted into all desired roles. Although this is 
quick and easy when dealing with one user and one role, it can be repetitious and 
time-consuming for multiple roles and users.

The Action menu command Add User(s) to Roles is a time-saving alternative.

1 Click Action > Add User(s) to Roles. 

2 Enter an NT user or group name in the User/Group Name box. 

Alternatively, click Browse and then click Advanced to search for user or group names.

3 Select a role from the Roles list. 

4 If you selected a global role, choose which organizations and groups containing that role 
are to be updated. 

5 If you selected All custom roles, select the specific non-global roles that are to be updated. 

6 Click Apply. 

Create a Master Policy

System administrators can create a custom policy at the system level and assign it to multiple 
organizations and groups. Subsequent changes to this master policy will automatically 
propagate to the organization and group level, eliminating the need to update each individual 
copy of that policy in each organization and group.

You must be a system administrator to create master policies.

Task 1: Enable the feature. 

1 On the WebInspect Enterprise Administrative Console, click the Administration group. 

2 Select the Roles and Permissions shortcut. 

3 Select WebInspect Enterprise System in the Security Group Hierarchy pane. 

4 Click the Roles tab. 

5 Select or create a role. 

6 In the Permissions area, select Policies. 

7 Select Allowed for all Policies permissions. 
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Task 2: Create a custom policy. 

1 Select the Scans group. 

2 Click the Scan Policies shortcut. 

3 Right-click a policy that you wish to use as the template for the new policy and select Copy 
from the shortcut menu. 

WebInspect Enterprise will check for and download any updates to the policy.

4 On the Copy Policy dialog, enter a name for the new policy and assign it to an 
organization. 

5 Select the Use as Master option. 

6 Click OK. 

Task 3: Modify the policy. 

After you save the renamed policy, the Policy Manager opens.

1 Modify the policy to suit your needs. 

2 When finished, save your work and close the Policy Manager.

The custom policy now appears in the list of Scan Policies. 

Task 4: Add the policy to organizations/groups. 

1 Click the Administration group and select the Roles and Permissions shortcut. 

2 Select an organization in the Security Group Hierarchy pane. 

3 Click the Resources tab. 

4 Select Policies from the Object Type list. 

5 Add the new custom policy to the list of allowed policies: select the policy from the 

Available list and click . 
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6 WebInspect Enterprise Web Console 
Introduction

WebInspect Enterprise presents two separate user interfaces:

• The WebInspect Enterprise Administrative Console, used for administrative and security 
functions. 

• The WebInspect Enterprise Web Console, a browser-based application used for 
conducting and managing scans.

This chapter describes the WebInspect Enterprise Web Console.

The WebInspect Enterprise Web Console user interface comprises three main areas:

• Toolbar

• Navigation pane

• Views and Forms

Click a button in the navigation pane to display a form containing related information or 
controls associated with the selected function. In this illustration, the user selected the Scans 
button to display a form containing a list of all scans in the WebInspect Enterprise system.
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Toolbar

The WebInspect Enterprise Web Console toolbar contains the following icons:

• Log Off - Logs you off the WebInspect Enterprise Web Console application.

• Options - Opens the Configure Options window, allowing you to select a default group, 
choose a time zone for the web console, and enable or disable other options.

• Resources - Opens the HP WebInspect Enterprise home page.

• Help -Opens the Help file.

• About - Opens a window that displays the WebInspect Enterprise manager version and 
the database schema version.

In addition, you can click the WebInspect Enterprise logo and name icon to return to the home 
page of the WebInspect Enterprise application.

Options

Click Options on the toolbar to configure Web Console options. 

Option Description

Default Group Select a group that will be used by client applications 
that cannot specify a group. A client application is 
WebInspect, QAInspect, or any application that uses 
the WebInspect application programming interface. 
Each user account is associated with a default group.

Web Console Time Zone Select the time zone in which you work.

Enable “Scan Web Site” Action This option allows you to initiate a scan from the Web 
Console, using the Scan Web Site function in the 
Actions group.

Enable “Scan Web Service” Action This option allows you to initiate a web service scan 
from the Web Console, using the Scan Web Service 
function in the Actions group.
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Navigation Pane

The navigation pane is divided into five sections:

• Actions 

• Filtered Views

• Resources

• Administration

Selecting an option in the navigation pane displays a corresponding form in the Form area.

Actions

Scan Web Site

The Scan Web Site action launches the Scan Configuration Wizard, which leads you through a 
series of dialogs that allow you to specify settings (options) for the scan. 

Only the most often modified options are presented. To access the complete set of options, 
click Advanced Settings (at the bottom of the window).

This feature is not available and the selection will not appear in the Actions group unless 
Enable “Scan Web Site” Action is selected as an option. To enable or disable this feature, click 
the Options hyperlink on the WebInspect Enterprise toolbar.

Scan Web Service

The Scan Web Service action initiates a scan by displaying windows that allow you to specify 
settings (options) for the scan. 

Enable “New Scan Schedule” 
Action

This option allows you to schedule a scan from the 
WebInspect Enterprise Web Console, using the New 
Scan Schedule function in the Actions group.

Enable “New Blackout” Action This option allows you to create and modify blackout 
periods from the Web Console, using the New Blackout 
function in the Actions group.

Disable Retest Browser Tab The Retest feature allows you to view the server's 
response as it would be rendered in a browser. This 
feature is, by design, susceptible to cross-site scripting; 
if you are concerned about executing a cross-site 
scripting attack that may be embedded in your 
application, you can disable this feature.

Note: The Retest Browser tab may be disabled by the 
organization administrator, using the WebInspect 
Enterprise Administrative Console.

Option Description
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When performing a Web service scan, WebInspect Enterprise crawls a WSDL site and 
submits a value for each parameter in each operation it discovers. These values are extracted 
from a Web Service Test Design (WSD) file that you must create using the Web Service Test 
Designer. It then audits the site by attacking each parameter in an attempt to detect 
vulnerabilities such as SQL injection.

This feature is not available and the selection will not appear in the Actions group unless 
Enable “Scan Web Service” Action is selected as an option. To enable or disable this feature, 
click the Options hyperlink on the WebInspect Enterprise toolbar.

New Scan Schedule

The New Scan Schedule action allows you to specify settings (options) for a scan and 
designate the time when the scan should begin. 

This feature is not available and the selection will not appear in the Actions group unless 
Enable “New Scan Schedule” Action is selected as an option. To enable or disable this feature, 
click the Options hyperlink on the WebInspect Enterprise toolbar.

New Blackout

The New Blackout action allows you to specify periods when scans are not allowed to be 
conducted (or, conversely, periods when scans are allowed to be conducted).

This feature is not available and the selection will not appear in the Actions group unless 
Enable “New Blackout” Action is selected as an option. To enable or disable this feature, click 
the Options hyperlink on the WebInspect Enterprise toolbar.

Filtered Views

Project Versions

This form displays, in the left column, a list of all defined projects and their component 
versions.

Click a project name to display information about all associated versions, or click a single 
version name.

For each version selected, this form displays:

• The project version name

• The number of issues detected in each of six categories

• The name of the security group with which this version is associated

• The name of the organization with which this version is associated

• The name of the project with which this version is associated

Click a project version name to view version details.
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You can perform additional functions by clicking the drop-down arrow for a specific project 
version.

The functions unique to this menu are:

Scan Now—Open the New Scan form, allowing you to enter scan settings and initiate a scan. 

Schedule Scan—Open the Configure Scheduled Scan form, allowing you enter scan settings 
and schedule a scan.

View in SSC—Launch the HP Fortify Software Security Center (SSC) application and navigate 
to the Issues tab of the Project Version window.
Scan Requests—View all HP Fortify Software Security Center scan requests associated with 
this project version.

You can also perform additional functions using the icons at the top of the form:

Project Version Details

This form provides complete details about the selected project version, categorized on the 
following tabs:

• All Scans—Lists all scans conducted for the project version. Icons allow you to add scans, 
delete scans, move scans to a different project version, and publish scans to Software 
Security Center. Click a scan name to open the Scan Visualization window for that scan. 
For more information, see Scan Visualization on page 80.

Click the drop-down arrow for a specific scan to view scan details in the Scan 
Visualization window, move the scan to a different project version, delete the scan, 
publish scan data to Software Security Center, or export the scan data in either XML or 
FPR format.

• Issues—Displays a list of vulnerabilities detected in this project version. An icon allows 
you to show or hide ignored issues. 

Click the drop-down arrow for a specific issue to view details or view the project version in 
Software Security Center.

Click a check name to open the Issue Details form. This form has five tabs:

— Vulnerability - Contains a complete description of the detected vulnerability, 
including instructions for verifying and fixing the problem.

Icon Function

Import Project 
Version

Import a project from Software Security Center. After providing your 
credentials and connecting to Software Security Center, you can select 
a project and project version, associate the scan with an organization 
and group, and specify the URL of the scan target.

Remove Project 
Version(s)

Remove the selected project version. If the project version contains 
scans, you can either delete the scans or move them to a different 
project version.
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— Request - Displays the HTTP request sent to the target site as a probe for the 
vulnerability.

— Response - Displays the HTTP response returned by the target site.

— Stack Trace - This feature is designed to support HP Fortify SecurityScope when it 
is installed and running on the target server. For certain checks (such as SQL 
injection, command execution, and cross-site scripting), SecurityScope intercepts 
WebInspect HTTP requests and conducts runtime analysis on the target module. 
If this analysis confirms that a vulnerability exists, SecurityScope appends the 
stack trace to the HTTP response. Developers can analyze this stack trace to 
investigate areas that require remediation.

— Additional Info - For Flash files, displays decompiled code.

• Scan Templates—Displays a list of scan templates associated with this project version. 
Icons allow you to create or delete a template, or import a template that contains settings 
that are optimized for Oracle. Click a template name to open the Configure Scan Template 
window to view or modify template settings.

Click the drop-down arrow for a specific template and select options to edit, copy, or delete 
the template, or display dependencies associated with the template. See Dependencies on 
page 77 for more information.

• Schedules—Lists all scans scheduled for the project version. Icons allow you to add or 
delete scheduled scans. Click a schedule name to open the Configure Scheduled Scan 
window to view or modify settings for the scan. 

Click the drop-down arrow for a specific scheduled scan and select Edit, Copy, Delete, or 
Enable/Disable.

• Properties—Lists information about the project version, including the project version 
name and URL, platform information, the contact's name and e-mail address, and host 
information. 

• Notes—Allows you to create or view notations associated with the project version.

• Aliases—Lists all aliases created for the project version. Icons allow you to add or delete 
aliases, or recalculate all scans. 

Click the drop-down arrow for a specific alias to edit or delete the alias. See Adding/
Editing an Alias on page 69 for detailed instructions. 

You can also perform additional functions using the icons at the top of the form.

Icon Function

Scan Now Display scan settings, as entered for the previous scan. You can modify the 
settings, if desired, before initiating the scan.

View in SSC Launch the HP Fortify Software Security Center (SSC) application and 
navigate to the Issues tab of the Project Version window.

Scan 
Requests

Navigate to the Scan Requests form, where you can process requests issued 
from the HP Fortify Software Security Center. You will need to enter your 
SSC credentials.
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Publishing to Software Security Center

When you select Publish, WebInspect Enterprise displays a dialog listing the number of 
vulnerabilities to be published, categorized by status and severity. To determine the status, 
WebInspect Enterprise compares previously submitted vulnerabilities (obtained by 
synchronizing with SSC) with those reported in the current scan. If this is the first scan 
submitted to a project version, all vulnerabilities will be “New.”

If a vulnerability was previously reported, but is not in the current scan, it is marked as “Not 
Found.” You must determine if it was not found because it has been fixed or because the scan 
was configured differently (for example, you may have used a different scan policy, or you 
scanned a different portion of the site, or you terminated the scan prematurely). When 
examining the results, you can change the “pending status” of individual vulnerabilities 
detected by all but the first scan (by right-clicking an item in the Summary pane). However, 
when publishing, you must specify how WebInspect should handle any remaining “Not 
Found” vulnerabilities.

1 Under Default Status of “Not Found” Vulnerabilities, do one of the following:

• To retain these “Not Found” vulnerabilities in Software Security Center (indicating 
that they still exist), select Retain: Assume all vulnerabilities still marked “Not Found” in 
the scan are still present.

• To change the status from “Not Found” to “Resolved” (implying that they have been 
fixed), select Resolve: Assume all vulnerabilities still marked “Not Found” in the scan are 
fixed.

Note: This section may not appear if there are no “Not Found” vulnerabilities.

2 Enter a user name and password that will allow you to access Software Security Center.

3 If this scan satisfies a scan request issued from Software Security Center, select Associate 
scan with an “In Progress” scan request for the current project version. See Scan Requests for 
more information.

4 Click Publish.

Note: You can publish a scan to HP Fortify Software Security Center from the following 
locations:

• Project Version Details form

• Scans form

• Scan Visualization

Adding/Editing an Alias

Sometimes, identical Web applications are deployed on different hosts. For example, during 
the development process, the same application may be deployed and tested on 
QA.testsite.com, Staging.testsite.com, and finally Production.testsite.com. This becomes 
problematic when performing a dynamic analysis scan because correlation uses the URL as a 
key component to match multiple vulnerabilities. 

To overcome this problem, you can create an alias for those project versions by identifying all 
the equivalent URLs and hostnames for the Web application, which allows correlation to 
occur for all active and future scans.

To create an alias:

1 Select Project Versions from the navigation pane.

2 Click the name of a project version for which you want to create an alias.

3 On the Project Version Details form, click the Aliases tab.
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4 Click Add.

5 On the Add New Alias dialog, in the Primary URL box, enter the alias URL (the umbrella 
under which other scans will be associated). Using the above example, you might enter 
http://Production.testsite.com. Be sure to include the protocol (e.g., http://).

6 If the server differentiates between URLs based on case sensitivity, select Case Sensitive 
URL.

7 Enter a description of the URL.

8 Click Add.

9 In the Equivalent URLs box, enter the URL of a host that will be covered by this alias. 
Using the above example, you might enter http://QA.testsite.com.

10 To add other URLs, repeat steps 8-9.

11 When finished, click Save.

12 When notified that the alias was saved successfully, click OK.

The primary URL is listed on the form.

You should set up aliases before publishing. Otherwise, if conflicts occur, you may lose the 
vulnerability history because the correlation IDs may change. If you add or edit aliases after a 
scan has been published for that project version, you will be prompted to recalculate. 

Note: Correlation is a mathematical calculation that uses a variety of values to determine if 
the vulnerability is really a duplicate of another vulnerability. You should recalculate 
whenever you change an alias.

Scans

For each scan in the WebInspect Enterprise database, this form displays (by default) the 
following information:

• Name - The name assigned to the scan by the user.

• Scan URL - Target Web site URL or IP address.

• Status - Current state of the scan (imported, complete, etc.).

• Project Version - Project version to which this scan is assigned. Click this field to open the 
associated Project Version Details form.

• Policy - The policy used for the scan.

• Sensor - The sensor that conducted the scan.

• Creator - User name of the person who initiated the scan.

• Created - Date and time the scan object was created or imported.

• Started - Date and time the scan started.

• Completed - Date and time the scan finished.

• App Type - Application type.

• App Version - Application version number.

• Results - If a check mark appears in this column, the number of vulnerabilities detected 
appears in columns sorted by severity

• Priority - A relative values assigned to the scan; it is used to determine precedence if a 
sensor scheduling conflict occurs.
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• Vulnerabilities (in columns sorted by severity) - Number of vulnerabilities detected.

• Security Group - Name of the security group associated with this scan.

• Organization - Name of the organization associated with this scan.

• SecurityScope Detected - Indicator (Yes/No) whether SecurityScope was detected during 
the scan.

• Project Name - Name of the project associated with this scan.

• Publish Status - Published, Unpublished, or Publishing.

• Publish Date - The date on which the scan data was published to an HP Software Security 
Center.

You can perform additional functions by clicking the drop-down arrow for a specific scan.

The options are:

• View

— Scan Visualization—Open the Scan Visualization window, allowing you to examine the 
scan results. You can also click a scan name to open the Scan Visualization window. 
For more information, see Scan Visualization on page 80.

— View Configuration—View (but not edit) the settings used for the selected scan.

• Manage

— Repeat Scan—Rescan the target site using the same settings as the original scan.

— Copy—Copy all settings that were used for this scan and paste them into the 
Configure Scan window, allowing you to edit the settings before initiating the scan.

— Copy to Schedule—Copy all settings that were used for this scan and paste them into 
the Configure Scheduled Scan window, allowing you to edit the settings before 
scheduling the scan.

— Create Template from the Scan - Create a scan template containing the settings that 
were used to produce this scan.

— Rename—Assign a different name to the scan.

— Move—Assign the scan to a different project version.

— Delete—Delete the scan.

• Retest Vulnerabilities—Conduct a scan that examines only those portions of the target site 
in which vulnerabilities were detected during the original scan. WebInspect Enterprise 
does not conduct a new crawl of the site, but simply retraces the path of vulnerable 
sessions (as recorded in the original scan) and attacks the resources using the same 
checks previously employed. The default name of the scan is “Site Retest - <original scan 
name>”; for example, the retest of a site that originally resulted in a scan named MySite 
would produce a scan named Site Retest - MySite. However, you can specify a different 
name when launching the scan.
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• Publish—Upload scan data to Software Security Center. Requires authorized user name 
and password.

• Export—Export the selected scan (or settings for the selected scan) to a destination you 
select.

• Change Scan State—Select Start, Stop, Resume, Suspend, or Repeat Scan.

Note for Internet Explorer users: When attempting to export scans, errors will result if the 
Internet option “Do not save encrypted pages to disk” is selected.

You can also perform additional functions using the icons at the top of the form.

Icon Function

Add Start a new scan. See Advanced Scan Settings on page 96 for a 
description of scan settings.

Import Import a scan.
This feature invokes the Scan Uploader, which allows you to assemble 
scans from WebInspect Enterprise managers and upload them to a 
project version.
Note: WebInspect Enterprise may display the message, “You cannot start 
application Scan Uploader from this location because it is already 
installed from a different location.” This can occur when you have 
multiple WebInspect Enterprise managers, or you rename your 
WebInspect Enterprise manager, or you access the same WebInspect 
Enterprise manager using different URLs, and you are importing to a 
WebInspect Enterprise manager that is different from the one into which 
you previously imported. The workaround solution is to uninstall the 
Scan Uploader utility and click the Import button again (which will 
reinstall the utility that is paired with the correct URL). Alternatively, 
launch the utility using the desktop shortcut instead of the Import button.
Scans can also be uploaded through the Scan Uploader service provided 
by the WebInspect Enterprise Services Manager. If you scan a Web site 
with WebInspect, you can copy the results to a location called a “drop 
box.” The Scan Uploader service (which is separate from the Scan 
Uploader utility) can access each drop box periodically and, if files exist, 
upload those files to the WebInspect Enterprise Manager. You can 
configure this feature through the WebInspect Enterprise Services 
Configuration utility.

Delete Delete the selected scan.

Move Assign the scan to a different project version.

Publish Send scan data to HP Fortify Software Security Center.

Change Scan 
State

Select one of the following:
• Start the scan
• Stop the scan (if running)
• Resume the scan (if suspended)
• Suspend the scan (if running)
• Repeat a selected scan.
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Scan Requests

This form lists all requests issued by HP Fortify Software Security Center instructing 
WebInspect Enterprise to conduct a scan. The possible values for the status column are 
Pending, In Progress, and Complete.

For instructions on how a Software Security Center user can generate a scan request, see 
Creating a Scan Request on page 74.

Use the following procedure to process a request.

1 In the Filtered Views section of the navigation pane, click Scan Requests.

2 On the Scan Requests window, select a pending request. The information entered by the 
original requester is displayed on the Details tab in the lower pane. 

To restrict the display of scan requests to those that match criteria you specify, simply 

click  in the header of one or more columns and enter the appropriate filter 
information.

3 On the Details tab in the lower pane, click the Status list and select In Progress.

4 Click Create a Web Site Scan or Create a Web Service Scan (or you can postpone running the 
scan until a later, more convenient time).

When the scan is complete, review the results. You may want to retest or delete 
vulnerabilities, mark vulnerabilities as ignored or false positive, attach screenshots, or 
investigate the scan data in other ways facilitated by WebInspect Enterprise.

5 Publish the scan.

a Do one of the following:

– From the Project Version Details form, select the scan and click Publish.

– From the Scans form, select the scan and click Publish.

– Open a scan in the Scan Visualization window and click Publish. For more 
information, see Scan Visualization on page 80.

b When the Status Summary is displayed, select Associate scan with an “In Progress” 
scan request for the current project version. The scan will appear on the Associated Scans 
tab of the appropriate scan request in the Scan Request form. See Note below.

6 Return to the Scan Requests form and select the request for the scan you have reviewed 
and published.

7 Click the Status list and select Completed.

8 Click Change Status.

Note: Associating a scan with a scan request is simply a tracking tool that provides a 
historical record of the scan activity related to a specific request. You can associate scans 
automatically when publishing (as in step 5, above), or you can associate scans manually, 
using the following procedure:

1 Select a scan request from the top pane.

2 In the bottom pane, click the Associated Scans tab.

3 Click Associate Scans.

The program displays a list of all scans associated with the selected project version that 
have not been associated with a specific request.

4 Select a scan and click OK.
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Creating a Scan Request

HP Fortify Software Security Center users can use the following procedure to create a request 
instructing WebInspect Enterprise to conduct a dynamic scan.

1 Log in to HP Fortify Software Security Center.

2 Click the Projects tab.

3 Select a project version and click View Details.

4 On the Issues tab of the Details window, click the drop-down arrow on the Dynamic Scan 
Request button and select Create.

5 Enter the requested information and click Submit.

The request is transmitted to WebInspect Enterprise and placed in the Scan Requests form.

Scan Schedules

This view displays information about each scheduled scan.

Click a schedule name to review the settings for the scheduled scan.

You can perform additional functions by clicking the drop-down arrow for a specific scheduled 
scan.

The functions unique to this menu are: 

Edit—Copy all settings that were used for the selected scheduled scan and paste them into the 
Configure Scheduled Scan window, allowing you to edit the settings for this scheduled scan. 

Copy—Copy all settings that were used for the selected scheduled scan and paste them into 
the Configure Scheduled Scan window, allowing you to edit the settings and create an 
additional scheduled scan. 

Enable—Activate a disabled scheduled scan. Requests are enabled, by default, when created. 

Disable—Deactivate a scheduled scan. The request remains in the grid, but the scan will not 
be executed unless the request is enabled prior to the scheduled time and date. 

You can also perform additional functions using the icons at the top of the form.

Note: This feature is not available and the action will not appear in the Filtered Views group 
unless Enable “New Scan Schedule” Action is selected as an option. To enable or disable this 
feature, click the Options hyperlink on the WebInspect Enterprise toolbar.

Icon Function

Add Schedule a scan. See Scheduled Scan Settings on page 117 for a description of 
settings.

Delete Remove the scheduled event.
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Resources

Scan Templates

This form lists all scan templates that you have permission to view. 

For each template, this form displays (by default) the following information:

• Name - The name assigned to the template. 

• Security Group - The name of the group.

• Organization Name - The name of the organization to which this group belongs.

• Project Name - The name of the project with which this template is associated.

• Project Version - The version associated with the specified project.

To view or modify details about a template, click the template name. 

You can perform additional functions by clicking the drop-down arrow for a specific template.

The function unique to this menu is:

Edit—Displays the Configure Scan Template form, allowing you to modify the settings defined 
for the selected template. 

Copy—Opens the Configure Scan Template forms, allowing you to modify (if necessary) and 
save the scan template settings.

Delete—Delete the scan template.

Dependencies—Displays a list of objects (such as scans and scheduled scans) that are linked to 
this template. You cannot delete this template until you either delete the scheduled scan, 
assign a different template to the scheduled scan, or cancel the scan (if it is currently 
running). See Dependencies on page 77 for more information.

You can perform additional functions using the icons at the top of the form. 

Blackouts

A blackout period is a block of time during which scans are not permitted. You can also create 
a partial ban by specifying that scans should not be conducted on specific hosts (identified by 
URL or IP address) during the time period you specify. 

Icon Function 

Add Create a template. See Scan Templates on page 75. 

Import Select Oracle Settings to create a template that contains settings that are 
optimized for these sites.

Delete Delete the selected template. 
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You may alternatively assign a contrary definition to the blackout, specifying that scans may 
occur only during this time period. In effect, this creates a blackout period covering all but the 
period of time you specify. 

For each blackout defined in the system, the Blackouts form displays (by default) the 
following information:

• Blackout Name - The identifier for this blackout period.

• Type - Allow or deny scans during this period

• IP Range - IP address (or range of IP addresses) that are affected by this blackout period.

• Status - Future, or Scans Disallowed, or Scans Allowed

• Recurrence - One time only, or the defined recurrence pattern

• Next Occurrence - The date and time when the blackout is next scheduled to start, using 
the Web Console time zone specified in the Web Console options.

• Next Occurrence (Target) - The date and time when the blackout is next scheduled to 
start, using the time zone for the location of the target server that is affected by the 
blackout. This is significant only when the Web Console user and the target server are in 
different time zones.

• Security Group - Name of the security group with which this blackout is associated.

• Organization Name - Name of the organization with which this blackout is associated.

To view or modify details about a blackout, click the blackout name. 

You can perform additional functions by clicking the drop-down arrow for a specific blackout.

The function unique to this menu is:

Copy—Opens the Configure Blackout form containing blackout settings. You can modify the 
settings (if desired) and rename the blackout.

You can perform additional functions using the icons at the top of the form. 

Administration

Deleted Projects

This form displays, in the left column, a list of project versions that have been removed from 
the collection of active projects. 

Icon Function 

Add Schedule a blackout period. See Blackout Settings on page 118.

Delete Delete the selected blackout period. 

Note: This feature will not appear in the navigation pane until project versions are deleted 
from SSC and these project versions have scans, scan templates or schedules associated with 
them. 
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For each version, this form displays:

• The project version name

• The number of issues detected in each of six severity categories

• The name of the security group

• The name of the organization

• The name of the project

Click a version name to view project version details.

System administrators can recover deleted project versions using the Administration - Roles 
and Permissions feature of the WebInspect Enterprise Administrative Console.

To permanently delete a project version, click the drop-down arrow for a specific project 
version and select Purge (or select one or more project versions and click the Purge icon at the 
top of the form). Purged versions cannot be recovered.

Dependencies 

Certain objects in WebInspect Enterprise are linked together, meaning that the existence of 
one object is dependent on another. You must dissolve this relationship before you are allowed 
to delete the parent object. For example, if you have a project version that contains scans, you 
cannot delete that project version unless you first delete the associated scans or assign them 
to a different project version. 

The dependencies are categorized in the following table. Dependent objects must be 
disassociated from the parent object before the parent object can be deleted.

Parent Object Dependent Objects

Scan Template • Scheduled scan
• Scan (only if scan has not completed)
You cannot delete a scan template until you either delete the scheduled 
scan, assign a different template to the scheduled scan, or cancel the 
scan (if it is currently running or paused). 

Project Version Scan
You cannot delete a project version until you delete the associated scans 
or move them to a different project version.

Custom Policy • Scan
• Scheduled scan
You cannot delete a custom policy until you either delete the scan or the 
scheduled scan (or assign a different policy to the scheduled scan). 
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Editing Form Layouts

Most forms contain an Edit Layout icon  that, when clicked, displays the Configure 
Columns dialog that allows you to change the number of rows on the page, modify column 
widths, specify which columns are displayed, and sort data by columns. 

This dialog has four tabs:

• Columns

• Grouping

• Sorting

• Paging

Columns

Use this tab to specify which columns are displayed on the grid. Column headers listed in the 
Selected list will be displayed. Use the controls illustrated below to move column headers 
between the Selected list and the Available list.

To change the column width:

1 Select a column header.
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2 Enter a value in the Width box (or use the slider to select a width).

3 Click OK.

Grouping

You can group objects in views (projects, scans, scan schedules, etc.) according to the available 
column names. Any grouping you define is applied to every tab on the form you are viewing.

In the following example, scans are grouped by security group and then by policy within each 
security group.

1 In the navigation pane under Filtered Views, click Scans.

2 Click the Edit Layout icon .

3 On the Configure Columns dialog, click the Grouping tab.

4 In the Available list, select Security Group and click >.

5 Select Policy and click >. Both column headers are now removed from the Available list and 
appear in the Selected list.

6 Click OK.

When you return to the Scans form, the Group pane displays the grouped results. When you 
select a group name (such as DEV Group, in this example), WebInspect Enterprise displays 
only those scans belonging to that group. Redundant items (policy names, in this example) are 
combined and the number of instances is reported in parentheses following the policy name. 
You can open or close the pane using the Group pane toggle

Sorting

To arrange the column data alphabetically, select one or more column headers and then select 
either Ascending or Descending.

Paging

To specify the number of rows displayed on a page, select a value from the Page Size list.
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Scan Visualization

The scan visualization feature emulates the WebInspect graphical presentation of scan data.

To open this view, select Scans from the Filtered Views group and click the name of a scan (or 
click the drop-down arrow for a specific scan and select View → Scan Visualization).

The work area of the Scan Visualization window is divided into three regions, as depicted in 
the following illustration:

• Navigation Pane

• Information Pane

• Summary Pane.

Navigation Pane

When conducting or viewing a scan, the navigation pane is on the left side of the Visualization 
window. It includes the Site, Sequence, and Excluded Hosts buttons, which determine the 
contents.

Site View

WebInspect Enterprise displays in the navigation pane only those sessions that reveal the 
hierarchical structure of the Web site, plus those sessions in which a vulnerability was 
discovered. During the crawl of the site, WebInspect Enterprise selects the check box next to 
each session (by default) to indicate that the session will also be audited. When conducting a 
sequential crawl and audit (where the site is completely crawled before being audited), you 
can exclude a session from the audit by clearing its associated check box before the audit 
begins.
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Sequence View

Sequence view displays server resources in the order they were encountered during a scan. In 
both Site view and Sequence view, blue text denotes a directory or file that was “guessed” by 
WebInspect, rather than a resource that was discovered through a link. For example, 
WebInspect always submits the request “GET /backup/ HTTP/1.1” in an attempt to discover if 
the target Web site contains a directory named “backup

Excluded Hosts

This view displays a list of all disallowed hosts. These are hosts that may be referenced 
anywhere within the target site, but cannot be scanned because they are not specified in the 
Allowed Hosts ‘ Scan Settings.

Navigation Pane Icons

Use the following table to identify resources displayed in the Sequence and Site views.

Icons Used on the Navigation Pane 

Icon Definition

Server/host: Represents the top level of your site’s tree structure.

Blue folder: A private folder on your Web server found by WebInspect. These 
folders are not linked from the site itself. 

Yellow folder: A folder whose contents are available over your Web site. 

Grey folder: A folder indicating the discovery of an item via path truncation. 
Once the parent is found, the folder will display in either blue or yellow, 
depending on its properties

File.

Query or Post.

Document Object Model (DOM) event.

Icons superimposed on a folder or file indicate a discovered vulnerability

A red exclamation point indicates the object contains a critical vulnerability. 
An attacker might have the ability to execute commands on the server or 
retrieve and modify private information.

A red dot indicates the object contains a high vulnerability. Generally, the 
ability to view source code, files out of the Web root, and sensitive error 
messages.

A gold dot indicates the object contains a medium vulnerability. These are 
generally non-HTML errors or issues that could be sensitive.
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Navigation Pane Shortcut Menu

Right-clicking an item in the navigation pane, when using the Site view, displays a shortcut 
menu with the commands described in the following table.

A blue dot indicates the object contains a low vulnerability. These are 
generally interesting issues, or issues that could potentially become higher 
ones.

An “i” in a blue circle indicates an informational item. These are interesting 
points in the site, or certain applications or Web servers.

A red check mark indicates a “best practice” violation.

Icons Used on the Navigation Pane  (cont’d)

Icon Definition

Navigation Pane Shortcut Commands 

Command Definition

Expand Children Expands branching nodes in the site tree.

Collapse Children (Site View only) Contracts branching nodes into the superior node.

Copy URL Copies the URL of the selected session to the clipboard (the same as 
selecting Edit → Copy URL). 

View in Browser Displays the server’s response in a Web browser.
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Information Pane

When conducting or viewing a scan, the information pane contains two collapsible 
information panels (Scan Info and Session Info) and an information display area.

Add Allows you to add locations discovered by means other than a 
WebInspect scan (manual inspection, other tools, etc.) for information 
purposes. You can then add vulnerabilities to those locations so that 
a more complete picture of the site is archived for analysis.
• Page - A distinct URL (resource).
• Directory - A folder containing a collection of pages.

Choosing either Page or Directory invokes a dialog that allows 
you to name the directory or page and edit the HTTP request and 
response. 

• Variation - A subnode of a location that lists particular attributes 
for that location. For example, the login.asp location might have 
the variation: 

“(Query) Username=12345&Password=12345&Action=Login” 

Variations are like any other location in that they can have 
vulnerabilities attached to them, as well as subnodes.

Choosing Variation invokes the Add Variation dialog, allowing you 
to edit the variation attributes, specify Post or Query, and edit 
the HTTP request and response.

• Vulnerability - A specific security threat.

Choosing Vulnerability invokes the Edit Vulnerabilities dialog, 
allowing you to edit the variation attributes, specify Post or 
Query, and edit the HTTP request and response.

Remove Location Removes the selected session from the navigation pane (both Site and 
Sequence views) and also removes any associated vulnerabilities.
Note: You can recover removed locations (sessions) and their 
associated vulnerabilities. Select Deleted Items from the Scan Info 
panel.

Edit Vulnerability Allows you to add an existing or custom vulnerability to the session, 
or change the Summary, Implication, Execution, Fix, and Reference 
Info descriptions associated with the vulnerability.

Review Vulnerability Allows you to retest the vulnerability or mark it as “ignored” or “false 
positive.” For more information, see Retesting/Reviewing 
Vulnerabilities on page 88.

Mark as False Positive Flags the vulnerability as a false positive and allows you to add a 
note.

Attachments Allows you to create a note or snapshot associated with the selected 
vulnerability.

Navigation Pane Shortcut Commands  (cont’d)

Command Definition
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Scan Info Panel

This panel contains three selections: Dashboard, False Positives, and Deleted Items.

Dashboard

The Dashboard displays a summary of the scan results and a graphic representation of the 
scan progress. 

The following table describes the graphics used in the dashboard

The following table describes the statistics presented in the dashboard.

Dashboard Graphics

Graphic Explanation

Crawl Gauge Number of sessions crawled / Total Number of sessions for crawl.

Audit Gauge Number of sessions audited / Total Number of sessions for audit.

Scan Status Status: Running, Paused, or Complete.

Vulnerabilities Graph Total number of issues identified for the scan sorted by severity 
level.

Attack Stats Grid Number of attacks made and issues found, categorized by attack 
type and audit engine.

Dashboard Statistics 

Group Statistic Explanation

Scan Duration Length of time scan has been running (can be incorrect if 
the scan terminates abnormally).

Policy Name of the policy used for the scan. For a retest, the 
field contains a dash (-), because the retest does not use 
the entire policy; see Retest All Vulnerabilities on 
page 156.

Deleted Items Number of sessions and vulnerabilities removed by the 
user from the scan.

Publish Status Published, Unpublished, or Pending.

Scan Type Website or Web Service.

Crawl Hosts Number of hosts included in the scan.

Sessions Total number of sessions (excluding AJAX requests, 
script and script frame includes, WSDL includes).

Audit Attacks Sent Total number of attacks sent.

Issues Total number of issues found (all vulnerabilities, as well 
as best practices).

Network Total Requests Total number of requests made.

Failed Requests Total number of failed requests.
84 Chapter 6



False Positives

This feature lists all URLs that WebInspect Enterprise originally flagged as containing a 
vulnerability, but which a user later determined were false positives. 

Deleted Items 

This feature lists either deleted sessions or deleted vulnerabilities, depending on your 
selection. 

To delete a session, right-click a session in the navigation pane or an item in the summary 
pane and select Remove Location from the shortcut menu.

To delete a vulnerability, you can:

• Right-click an item on the Vulnerabilities tab, Information tab, or Best Practices tab in the 
summary pane and select Mark As Ignored from the shortcut menu, or

• Right-click a vulnerable session in the navigation pane, select Edit Vulnerability from the 
shortcut menu, and (on the Edit Vulnerabilities dialog) click Delete.

• Right-click an item on any tab in the summary pane except Scan Log, select Edit 
Vulnerability from the shortcut menu, and (on the Edit Vulnerabilities dialog) click Delete. 

Session Info Panel

WebInspect lists each session created during a scan in the navigation pane using either the 
Site view or Sequence view. Select a session and then click one of the options in the Session 
Info panel to display related information about that session. 

Script Includes Total number of script includes.

Macro Requests Total number of requests made as part of macro 
execution.

404 Probes Number of probes made to determine file-not- found 
status.

404 Check Redirects Number of times a 404 probe resulted in a redirect.

Verify Requests Requests made for detection of stored parameters.

Logouts Number of times logout was detected and login macro 
executed.

Macro Playbacks Number of times macros have been executed.

AJAX Requests Total number of AJAX requests made.

Script Events Total number of script events processed.

Kilobytes Sent Total number of kilobytes sent.

Kilobytes Received Total number of kilobytes received.

Dashboard Statistics  (cont’d)

Group Statistic Explanation
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The following table lists the options available in the Session Info panel. Some options appear 
only for specific scans (Web Site Scan or Web Service Scan). Also, options are enabled only if 
they are relevant to the selected session; for example, the Forms selection is not available if 
the session does not contain a form.

Summary Pane

When conducting or viewing a scan, use the horizontal summary pane at the bottom of the 
window to see a centralized display of discovered vulnerabilities. It allows you to access 
vulnerability information quickly and view WebInspect logging information. This pane has six 
tabs:

• Vulnerabilities

• Not Found

• Information

• Best Practices

• Scan Log

Options in Session Info Panel

Option Definition

Vulnerabilities Displays the vulnerability information for the session selected in the 
navigation pane.

Web Browser Displays the server’s response as rendered by a Web browser for the 
session selected in the navigation pane. For Web Site scans only; not 
available for Web Service scans.

HTTP Request Displays the raw HTTP request sent by WebInspect to the server hosting 
the site you are scanning.

HTTP 
Response

Displays the server’s raw HTTP response to WebInspect’s request. 
Note: If you select a Flash (.swf) file, WebInspect displays HTML instead of 
binary data. This allows WebInspect to display links in a readable format.

Details Lists request and response details, such as the size of the response and the 
request method. Note that the Response section contains two entries for 
content type: returned and detected. The Returned Content Type indicates 
the media type specified in the Content-Type entity-header field of the 
HTTP response. Detected Content Type indicates the actual content-type as 
determined by WebInspect.

Attachments Displays all notes and screenshots associated with the selected object. 
To create an attachment, you can either:
• Right-click a session (Web site scan) or an operation or vulnerability 

(Web service scan) in the navigation pane and select Attachments from 
the shortcut menu, or 

• Right-click an item on the Vulnerabilities tab of the summary pane and 
select Attachments from the shortcut menu, or 

• Select a session (Web site scan) or an operation or vulnerability (Web 
service scan) in the navigation pane, then select Attachments from the 
Session Info panel and click the Add menu (in the information pane). 
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• Server Information

On all tabs, you can filter the data that is presented by clicking on the icons in the column 
headers.

Vulnerabilities Tab

The Vulnerabilities tab lists information about each vulnerability that WebInspect discovered 
during an audit of your Web presence. 

The severity of vulnerabilities is indicated by the following icons.

Right-clicking an item in the list displays a shortcut menu with the commands described in 
the following table.

Critical High Medium Low

Vulnerability Shortcut Menu 

Command Definition

Export All Vulns Open or save a file containing all vulnerabilities. If you select Open, 
vulnerabilities are displayed in Microsoft Excel. If you select save, 
vulnerabilities are saved in a comma-separated values (.csv) file.

Change Severity Modify the severity level.

Edit Vulnerability Add, delete, or edit a vulnerability associated with the selected 
session.

Review Vulnerability Retest the vulnerable session, mark it as false positive or ignored. 
For more information, see Retesting/Reviewing Vulnerabilities on 
page 88. This option is also invoked if you double-click a 
vulnerability.

Mark As Flag the vulnerability as either a false positive or ignored.
To view false positives, select False Positives in the Scan Info panel. 
To view (and optionally recover) ignored vulnerabilities, select 
Deleted Items in the Scan Info panel. 

Remove Location Delete from the navigation pane the session associated with the 
selected vulnerability and also remove any associated vulnerabilities.
Note: To view (and optionally recover) removed sessions, select 
Deleted Items in the Scan Info panel.

Attachments Create a note or associate an image with the selected vulnerability.

Update SSC Status Change the status of an issue to be submitted to the HP Fortify 
Software Security Center. Statuses are: New, Existing, 
Reintroduced, Resolved, Still an Issue, and Not Found. The 
availability of a specific status is determined by the current status. 
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Not Found Tab

This tab lists vulnerabilities that were detected by a previous scan in this project version, but 
were not detected by the current scan. These vulnerabilities are not included in counts on 
dashboard and are not represented in the site or sequence view of the navigation pane. 
Right-clicking an item in the list presents the same options described for the Vulnerability 
Shortcut Menu on page 87.

Information Tab

The Information tab lists information discovered during a WebInspect scan. These are not 
considered vulnerabilities, but simply identify interesting points in the site or certain 
applications or Web servers. When you click a listed URL, the program highlights the related 
item in the navigation pane. 

Right-clicking an item in the list presents the same options described for the Vulnerability 
Shortcut Menu on page 87.

Best Practices Tab

The Best Practices tab lists issues detected by WebInspect that relate to commonly accepted 
best practices for Web development. Items listed here are not vulnerabilities, but are 
indicators of overall site quality and site development security practices (or lack thereof).

Right-clicking an item in the list presents the same options described for the Vulnerability 
Shortcut Menu on page 87.

Scan Log Tab

Use the Scan Log tab to view information about activities that occurred during the scan. For 
instance, the time at which certain audit methodologies are applied against your Web 
presence are listed here. 

Server Information Tab

This tab lists items of interest pertaining to the server. Only one occurrence of an item or 
event is listed per server.

Retesting/Reviewing Vulnerabilities

After you conduct a scan, developers may correct their code and update the site. You can then 
open the original scan, select the once-vulnerable session (now supposedly remediated), and 
select Review Vulnerability from the shortcut menu. Assuming that the fundamental 
architecture of the site has not changed, you can verify that the threat no longer exists 
without rescanning the entire site (which, in some cases, could require several hours or even 
days).

Alternatively, you can use this feature simply to double-check a reported vulnerability, even 
while the scan is still running.

1 Do one of the following:

• Right-click a vulnerable session in the navigation pane and select Review Vulnerability. 

• In the summary pane, select either the Vulnerability, Not Found, Information, or Best 
Practices tab, right-click an item in the list, and select Review Vulnerability.
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2 If multiple vulnerabilities are displayed, choose one from the Vulnerability to Review list.

In the following illustration, the Unencrypted Login Form check was selected from the 
summary pane of the Scan Visualization window. 

3 Use the tabs to display information about the original session (as selected in the Steps to 
Reproduce pane under the URL column): 

• Browser - The server’s response, as rendered in a browser. 

Note: This tab may or may not be visible. Retesting a cross-site scripting vulnerability 
may cause the script to loop infinitely on the Browser tab when using Microsoft 
Internet Explorer. You can disable this tab by clicking Options on the toolbar and 
selecting the Disable Retest Browser Tab check box. See Disable Retest Browser Tab on 
page 65.

• Request - The raw HTTP request message.

• Response - The raw HTTP response message.

• Vulnerability - A description of the vulnerability, its implications, and suggestions on 
how to fix it.

• Attachments - Notes and screenshots associated with the vulnerability, which you may 
add, view, edit, or delete.

To retest the session for the selected vulnerability:

1 Click Retest. 

2 Select a sensor and click OK.

Results of the retest appear on the Status bar and in the lower pane in the Response Match 
Status column. The remaining client area is split into two panes: the original session is 
represented in the left pane, and the retested session appears in the right pane.

The status is reported as either “Vulnerability Detected” or “Vulnerability Not Detected.”
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The reliability of the reported findings is mitigated by the Response Match Status, which may 
have the following values:

• Match - The resource has not changed significantly; WebInspect Enterprise was able to 
access the session via the same path used by the original scan.

• Inconclusive - Based on the HTTP response, the resource has changed in a manner that 
may or may not substantiate the finding that a vulnerability has or has not been detected 
during the retest.

• Different - The HTTP response is radically different from the response received during the 
original scan, suggesting major changes to the resource.

If you think that WebInspect Enterprise has erroneously determined that the vulnerability 
exists, you can remove the vulnerability by clicking Mark as and selecting False Positive from 
the drop-down list. Alternatively, you can ignore the vulnerability by selecting Ignored.

Editing and Adding Vulnerabilities

After WebInspect Enterprise assesses your application’s vulnerabilities, you may want to edit 
and save the results for a variety of reasons, including:

• Security - If an HTTP request or response contains passwords, account numbers, or other 
sensitive data, you may want to delete or modify this information before making the scan 
results available to other persons in your organization.

• Correction - WebInspect Enterprise occasionally reports a “false positive.” This occurs 
when WebInspect Enterprise detects indications of a possible vulnerability, but further 
investigation by a developer determines that the problem does not actually exist. You can 
delete the vulnerability from the session or delete the entire session. Alternatively, you 
can designate it as a false positive; to do so, right-click the session in either the Site or 
Sequence view and select Mark As False Positive.

• Severity Modification - If you disagree with WebInspect Enterprise’s ranking of a 
vulnerability, you can assign a different level, using the following scale:

• Record Keeping - You can modify any of the report fields associated with an individual 
vulnerability (Summary, Execution, Recommendation, Implementation, Fixes, and 
References). For example, you could add a paragraph to the Fixes section describing how 
you actually fixed the problem.

• Enhancement - If you discover a new vulnerability, you could define it and add it to a 
session as a custom vulnerability

Use the procedure below to edit or add a vulnerability.

1 Do one of the following:

• In the Summary pane, right-click an item on any tab except Scan Log and Server 
Information and select Edit Vulnerability.

Normal 0-9

Information 10

Low 11-25

Medium 26-50

High 51-75

Critical 76-100
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• In the navigation pane, right-click a session and select Edit Vulnerability or Add → 
Vulnerability.

2 Select a vulnerability (if the session includes multiple vulnerabilities).

3 To add an existing vulnerability to the session (that is, one that exists in the database), 
click Add Existing.

a On the Add Existing Vulnerability window, enter part of a vulnerability name, or a 
complete vulnerability ID number or type.

Note: The * and % characters can be used interchangeably as wildcards. However, a 
wildcard is allowed only at the beginning, at the end, or at the beginning and end of a 
string. If placed within a string (such as “mic*soft,”), these characters will not 
function as wildcards.

b Click Search.

c Select one or more of the vulnerabilities returned by the search.

d Click OK.

4 To add a custom vulnerability, click Add Custom. You can then edit the vulnerability as 
described in Step 6.

5 To delete the vulnerability from the selected session, click Delete.

6 To edit the vulnerability, you can modify the check name, check type, severity, or 
probability. You can also change the descriptions that appear on the Summary, Implication, 
Execution, Fix, and Reference Info tabs.

7 Click OK to save the changes.

To remove any modifications you made to existing vulnerability descriptions, select a check 
name and click Restore Defaults.

Toolbar

Actions available from the toolbar at the top of the window include the following:

• Resume - Continue a scan after you paused the process.

• Pause - Halt a scan. Click Resume to continue.

• Stop - Terminate the scan; it cannot be resumed.

• Repeat Scan - Rescan the target site using the same settings as the original scan.

• Scan Again - Display settings used for this scan, allowing you to modify them before 
initiating another scan.

• Retest Vulnerabilities - This type of scan examines only those portions of the target site in 
which vulnerabilities were detected during the original scan. WebInspect Enterprise does 
not conduct a new crawl of the site, but simply retraces the path of vulnerable sessions (as 
recorded in the original scan) and attacks the resources using the same checks previously 
employed. The default name of the scan is “Site Retest - <original scan name>”; for 
example, the retest of a site that originally resulted in a scan named MySite would 
produce a scan named Site Retest - MySite. However, you can specify a different name 
when launching the scan.

• Export Scan - Export the selected scan (or settings for the selected scan) to a destination 
you select.
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• Publish Scan to SSC - Upload scan data to an HP Fortify Software Security Center. 
Requires authorized user name and password. For more information, see Publishing to 
Software Security Center on page 69.

Web Site Scan Wizard

The Web Site Scan Wizard steps you through the process of creating settings for a Web site 
scan. The options displayed by default on this and subsequent windows are extracted from the 
Advanced settings. Any changes you make will be used for the current scan only. When the 
first of five dialogs appears, provide the requested information as described in the following 
procedure. 

Web Site Scan

1 Select a project and project version from the appropriate lists.

2 In the Scan Name box, enter a name or brief description of the scan.

3 Instead of specifying each individual setting every time you conduct a scan, you can create 
templates that contain different settings and then simply select a template from the Scan 
Template list. You are not required to use a template. 

4 Select one of the following scan modes:

• Crawl Only: This option completely maps a site's hierarchical data structure. After a 
crawl has been completed, you can click Audit to assess an application’s 
vulnerabilities.

• Crawl and Audit: WebInspect maps the site's hierarchical data structure and audits 
each resource (page). Depending on the default settings you select, the audit can be 
conducted as each resource is discovered or after the entire site is crawled. For 
information regarding simultaneous vs. sequential crawl and audit, see Scan Settings 
- Method.

• Audit Only: WebInspect applies the methodologies of the selected policy to determine 
vulnerability risks, but does not crawl the Web site. No links on the site are followed 
or assessed.

5 Select one of the following scan types:

Standard Scan

WebInspect performs an automated analysis, starting from the target URL. This is the 
normal way to start a scan.

a In the Start URL box, type or select the complete URL or IP address of the site you 
want to examine.

If you enter a URL, it must be precise. For example, if you enter MYCOMPANY.COM, 
WebInspect will not scan WWW.MYCOMPANY.COM or any other variation (unless 
you specify alternatives in the Allowed Hosts setting).

Click Advanced Settings at the bottom of any dialog to access the full complement of 
WebInspect Enterprise settings. Any selections you make will be applied to this scan only, 
and you will not be able to return to the Scan Wizard. 
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An invalid URL or IP address will result in an error. If you want to scan from a 
certain point in your hierarchical tree, append a starting point for the scan, such as 
http://www.myserver.com/myapplication/.

Scans by IP address will not pursue links that use fully qualified URLs (as opposed to 
relative paths).

WebInspect supports both Internet Protocol version 4 (IPV4) and Internet Protocol 
version 6 (IPV6). IPV6 addresses must be enclosed in brackets. 

b If you select Restrict to folder, you can limit the scope of the scan to the area you 
choose from the drop-down list. The choices are:

– Directory only - WebInspect will crawl and/or audit only the URL you specify. For 
example, if you select this option and specify a URL of www.mycompany/one/two/, 
WebInspect will assess only the “two” directory.

– Directory and subdirectories - WebInspect will begin crawling and/or auditing at the 
URL you specify, but will not access any directory that is higher in the directory 
tree.

– Directory and parent directories - WebInspect will begin crawling and/or auditing at 
the URL you specify, but will not access any directory that is lower in the 
directory tree.

List-Driven Scan

Perform a scan using a list of URLs to be scanned. Each URL must be fully qualified and 
must include the protocol (for example, http:// or https://). You can use a text file, 
formatted as comma-separated list or one URL per line, or the XML file generated by the 
FilesToURLs utility.

 If you select List-Driven Scan, do one of the following:

— Click Import and select a text file or XML file containing the list of URLs you want to 
scan.

— Click Manage to create or modify a list of URLs.

Workflow-Driven Scan

WebInspect audits only those URLs included in the macro that you previously recorded 
and does not follow any hyperlinks encountered during the audit. A logout signature is 
not required. This type of macro is used most often to focus on a particular subsection of 
the application. If you select multiple macros, they will all be included in the same scan.

If you select Workflow-Driven Scan, do one of the following:

– Click Import to select a macro containing the URLs you want to scan.

– Click Manage to import or remove a macro, and to specify allowed hosts.

Note: You can include more than one macro in a scan.

6 6.Click Next 

Authentication and Connectivity

1 If you need to access the target site through a proxy server, select Network Proxy and then 
choose an option from the Proxy Profile list.
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Note: Electing to use browser proxy settings does not guarantee that you will access the 
Internet through a proxy server. If the Firefox browser connection settings are configured 
for “No proxy,” or if the Internet Explorer setting “Use a proxy server for your LAN” is not 
selected, then a proxy server will not be used.

• Autodetect: Use the Web Proxy Autodiscovery Protocol (WPAD) to locate a proxy 
autoconfig file and use this to configure the browser's Web proxy settings.

• Use Internet Explorer proxy settings on the sensor machine: Import your proxy server 
information from Internet Explorer.

• Use PAC File: Load proxy settings from a Proxy Automatic Configuration (PAC) file. If 
you select this option, click Edit to enter the location (URL) of the PAC.

• Use Explicit Proxy Settings: Specify proxy server settings. If you select this option, click 
Edit to enter proxy information.

• Use Mozilla Firefox proxy settings on the sensor machine: Import your proxy server 
information from Firefox.

2 Select Network Authentication if server authentication is required. Then select an 
authentication method and enter your network credentials. 

3 Select Site Authentication to use a recorded macro containing a user name and password 
that allows you to log on to the target site. The macro must also contain a “logout 
condition,” which indicates when an inadvertent logout has occurred so WebInspect 
Enterprise can rerun this macro to log on again.

• Click  to select a macro. [Note: To create a macro, use the WebInspect Enterprise 
Administrative Console and launch the Web Macro Recorder from the Tools menu.]

• To erase the macro name, clear the Site Authentication check box.

• The Login Macro Parameters grid appears if, when recording the macro, you selected 
the Smart Credentials option (when using the traffic-mode or event-based web macro 
recorders) or if you created input parameters when using the TruClient web macro 
recorder. Enter a user name and password. When scanning the page containing the 
input control associated with this entry, WebInspect will substitute these credentials 
for those used in the macro. This feature allows you to create a macro using your user 
name and password, yet when other persons run the scan using this macro, they can 
substitute their own user credentials.

4 4.Click Next.

Coverage and Thoroughness

1 Select a policy from the Audit Depth (Policy) list.

For descriptions of policies, see Appendix A.

2 Click Next.

Detailed Scan Configuration

1 If you want WebInspect to submit values for input controls on forms it encounters while 
scanning the target site:

a Select Auto-fill Web forms during crawl. WebInspect will extract the values from a file 
that you create using the Web Form Editor. 
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b Click Load to locate and load the file.

2 Click Next.

Congratulations

1 If you want to create a template containing the settings you configured for this scan, 
specify a template name and click Save.

2 Select a priority from 1 (highest) to 5 (lowest). If a scheduling conflict occurs, the scan 
with the highest priority will take precedence. 

3 Select a sensor. You can designate a specific sensor to run this scan, or you can elect to 
run the scan on any available sensor,.

4 Click Scan.

Web Service Scan Wizard

The Web Service Scan Wizard steps you through the process of creating settings for a Web 
service scan. The options displayed by default on this and subsequent windows are extracted 
from the Advanced settings. Any changes you make will be used for the current scan only. 
When the first of four dialogs appears, provide the requested information as described in the 
following procedure.

Web Service Scan

1 Select a project and project version from the appropriate lists.

2 In the Scan Name box, enter a name or brief description of the scan.

3 Instead of specifying each individual setting every time you conduct a scan, you can create 
templates that contain different settings and then simply select a template from the Scan 
Template list. You are not required to use a template.

4 Click Import to open a standard file-selection dialog and choose a Web Service Test Design 
(WSD) file that you previously created using the Web Service Test Designer. This file 
contains values for each operation in the service. For more information, see Web Service 
Test Designer on page 256.

5 Click Next.

Authentication and Connectivity

1 If you need to access the target site through a proxy server, select Network Proxy and then 
choose an option from the Proxy Profile list.

Note: Electing to use browser proxy settings does not guarantee that you will access the 
Internet through a proxy server. If the Firefox browser connection settings are configured 
for “No proxy,” or if the Internet Explorer setting “Use a proxy server for your LAN” is not 
selected, then a proxy server will not be used.

• Autodetect: Use the Web Proxy Autodiscovery Protocol (WPAD) to locate a proxy 
autoconfig file and use this to configure the browser's Web proxy settings.
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• Use Internet Explorer proxy settings on the sensor machine: Import your proxy server 
information from Internet Explorer.

• Use PAC File: Load proxy settings from a Proxy Automatic Configuration (PAC) file. If 
you select this option, click Edit to enter the location (URL) of the PAC.

• Use Explicit Proxy Settings: Specify proxy server settings. If you select this option, click 
Edit to enter proxy information.

• Use Mozilla Firefox proxy settings on the sensor machine: Import your proxy server 
information from Firefox.

2 Select Network Authentication if server authentication is required. Then select an 
authentication method and enter your network credentials. 

3 Click Next.

Coverage and Thoroughness

You cannot select a policy. The Simple Object Access Protocol (SOAP) policy is used by 
default.

Click Next.

Congratulations

1 If you want to create a template containing the settings you configured for this scan, 
specify a template name and click Save.

2 Select a priority from 1 (highest) to 5 (lowest). If a scheduling conflict occurs, the scan 
with the highest priority will take precedence.

3 Select a sensor. You can designate a specific sensor to run this scan, or you can elect to 
run the scan on any available sensor,.

4 Click Scan.

Advanced Scan Settings

Categories of settings appear as groups in the left column. They are:

• Scan

• Scan Settings

• Crawl Settings

• Audit Settings

• Scan Behavior

• Export

Each group has one or more subcategories.
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Scan

General

Project Version

Select a project from the Projects list and then select a version from the Project Versions list. 

Scan Template

Instead of specifying each individual setting every time you conduct a scan, you can create 
templates that contain different settings and then simply select a template from the Use Scan 
Template list. You are not required to use a template.

Scan

Enter a name for the scan.

Scan URL

Select one of the following scan types.

• Standard Scan

The scanner performs an automated analysis, starting from the target URL. This is the 
normal way to start a scan.

1 In the Start URL box, type or select the complete URL or IP address of the site you 
want to examine. If you enter a URL, it must be precise. For example, if you enter 
MYCOMPANY.COM, you will not scan WWW.MYCOMPANY.COM or any other 
variation (unless you specify alternatives in the Allowed Hosts setting).

An invalid URL or IP address will result in an error. If you want to scan from a 
certain point in your hierarchical tree, append a starting point for the scan, such as 
http://www.myserver.com/myapplication/.

Scans by IP address will not pursue links that use fully qualified URLs (as opposed to 
relative paths).

2 If you select Restrict to folder, you can limit the scope of the scan to the area you choose 
from the drop-down list. The choices are:

– Directory only - The scanner will crawl and/or audit only the URL you specify. For 
example, if you select this option and specify a URL of www.mycompany/one/two/, 
the scanner will assess only the “two” directory.

– Directory and subdirectories - The scanner will begin crawling and/or auditing at 
the URL you specify, but will not access any directory that is higher in the 
directory tree.

– Directory and parent directories - The scanner will begin crawling and/or auditing at 
the URL you specify, but will not access any directory that is lower in the 
directory tree.

• List-Driven Scan

Perform a scan using a list of URLs to be scanned. Each URL must be fully qualified and 
must include the protocol (for example, http:// or https://). You can use a text file, 
formatted as comma-separated list or one URL per line, or the XML file generated by the 
FilesToURLs utility. Do one of the following:
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— Click Import and select a text file or XML file containing the list of URLs you want to 
scan.

— Click Edit to create or modify a list of URLs.

• Workflow-Driven Scan

The scanner audits only those URLs included in the macro that you previously recorded 
and does not follow any hyperlinks encountered during the audit. A logout signature is 
not required. This type of macro is used most often to focus on a particular subsection of 
the application.

Click Browse and select a macro.

• Web Service Scan

When performing a Web Service scan, the scanner crawls the WSDL site and submits a 
value for each parameter in each operation it discovers. These values are extracted from a 
file that you must create using the Web Service Test Designer. It then audits the site by 
attacking each parameter in an attempt to detect vulnerabilities such as SQL injection.

Click Browse to open a standard file-selection dialog and choose a Web Service Test 
Design (WSD) file that was previously created using the Web Service Test Designer.

Priority 

Select a priority from 1 (highest) to 5 (lowest). If a scheduling conflict occurs, the scan with 
the highest priority will take precedence. 

Sensor 

Select which sensor should conduct the scan. You can choose a specific sensor or select the Any 
Available option. 

A sensor can perform only one scan at a time. If it is conducting a scan when another scan is 
scheduled to occur, then: 

• If the currently running scan has a higher priority, the WebInspect Enterprise manager 
will place the second scheduled scan request in a queue until the first scan finishes or 
until another sensor becomes available. 

• If the currently running scan has a lower priority, the WebInspect Enterprise manager 
will suspend that scan, assign the second scheduled scan request to that sensor, and then 
reassign the suspended request to the sensor when the higher priority scan is complete. 

Scans that are manually initiated have priority over any scheduled scan. 

Scan Settings

The Project Version setting is reproduced on each settings dialog, allowing you to change your 
selection at any point. The description of this setting is not repeated in the following topics.

Method

Scan Mode

Select one of the following modes:

• Crawl Only—This option completely maps a site’s hierarchical data structure, but does not 
audit the site. The scan is saved to the database, allowing you to open the scan at a later 
date and conduct an audit.
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• Crawl and Audit—In this mode, the scanner crawls the entire site, mapping the site’s 
hierarchical data structure, and conducting an audit. 

• Audit Only—The scanner applies the methodologies of the selected policy to determine 
vulnerability risks, but does not crawl the Web site. No links on the site are followed or 
assessed.

Crawl and Audit Mode

If the selected scan mode is Crawl and Audit, choose one of the following:

• Simultaneously—As a scanner maps the site’s hierarchical data structure, it audits each 
resource (page) as it is discovered (rather than crawling the entire site and then 
conducting an audit). This option is most useful for extremely large sites where the 
content may possibly change before the crawl can be completed. 

• Sequentially—In this mode, the scanner crawls the entire site, mapping the site’s 
hierarchical data structure, and then conducts a sequential audit, beginning at the site’s 
root. If you select this option, you can specify the order in which the crawl and audit 
should be conducted.

— Test each engine type per session: The scanner audits all sessions using the first audit 
engine, then audits all sessions using the second audit engine, continuing in sequence 
until all engine types have been deployed.

— Test each session per engine type: The scanner runs all audit engines against the first 
session, then runs all audit engines against the second session, continuing in 
sequence until all sessions are audited.

Scan Behavior

You can select any of the following optional behaviors:

• Use a login macro for forms authentication—This type of macro is used primarily for Web 
form authentication. It incorporates logic that will prevent the HP scanner from 
terminating prematurely if it inadvertently logs out of your application. When recording 
this type of macro, be sure to select Enable Check For Logout and then specify the 
application’s log-out signature. The drop-down list contains the names of all macros that 
have been uploaded to WebInspect Enterprise. You can select one of these, or you can click 
Browse to locate a macro on your PC and upload it.

If, when recording the macro, you selected the Smart Credentials option, then you can 
enter a Smart Credentials User Name and Smart Credentials Password. When scanning the 
page containing the input control associated with this entry, the scanner will substitute 
these credentials for those used in the macro. 

• Use a startup macro—This type of macro is used most often to focus on a particular 
subsection of the application. It specifies URLs that the scanner will use to navigate to 
that area. It may also include login information, but does not contain logic that will 
prevent the scanner from logging out of your application. The scanner visits all URLs in 
the macro, collecting hyperlinks and mapping the data hierarchy. It then calls the Start 
URL and begins a normal crawl (and, optionally, audit). The drop-down list contains the 
names of all macros that have been uploaded to WebInspect Enterprise. You can select 
one of these, or you can click Browse to locate a macro on your PC and upload it.

• Auto-fill Web forms during crawl—If you select this option, the scanner submits values for 
input controls found on all HTML forms it encounters while scanning the target site. The 
scanner will extract the values from a prepackaged default file or from a file that you 
create using the Web Form Editor. Use the browse button to specify the file containing the 
values you want to use. Alternatively, you can select Edit (to modify the currently selected 
file) or Create (to record new Web form values).
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General

Scan Details 

You may choose the following options:

• Enable Path Truncation—Path truncation attacks are requests for known directories 
without file names. This may cause directory listings to be displayed. The scanner 
truncates paths, looking for directory listings or unusual errors within each truncation. 
Example: If a link consists of http://www.site.com/folder1/folder2/file.asp, then truncating 
the path to look for http://www.site.com/folder1/folder2/ and http://www.site.com/folder1/ 
will cause the server to reveal directory contents or will cause unhandled exceptions. 

• Attach debug information in request header—If you select this option, the scanner includes a 
“Memo:” header in the request containing information that can be used by support 
personnel to diagnose problems. 

• Case-sensitive request and response handling—Select this option if the server at the target 
site is case-sensitive to URLs. 

• Compress response data—If you select this option, the scanner saves disk space by storing 
each HTTP response in a compressed format in the database. 

• Maximum crawl-audit recursion depth—When an attack reveals a vulnerability, the scanner 
crawls that session and follows any link that may be revealed. If that crawl and audit 
reveals a link to yet another resource, the depth level is incremented and the discovered 
resource is crawled and audited. This process can be repeated until no other links are 
found. However, to avoid the possibility of entering an endless loop, you may limit the 
number of recursions.

Crawl Details 

You may choose the following options:

• Crawler—Select either Depth First or Breadth First.

Depth-first crawling accommodates sites that enforce order-dependent navigation (where 
the browser must visit page A before it can visit page B). This type of search progresses by 
expanding the first child node (link) and crawling deeper and deeper until it reaches a 
node that has no children. The search then backtracks, returning to the most recent node 
it hasn’t finished exploring and drilling down from there. The following illustration 
depicts the order in which linked pages are accessed using a depth-first crawl. Node 1 has 
links to nodes 2, 7, and 8. Node 2 has links to nodes 3 and 6.
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By contrast, breadth-first crawling begins at the root node and explores all the 
neighboring nodes (one level down). Then for each of those nearest nodes, it explores their 
unexplored neighbor nodes, and so on, until all resources are identified. The following 
illustration depicts the order in which linked pages are accessed using a breadth-first 
crawl. Node 1 has links to nodes 2, 3, and 4. Node 2 has links to nodes 5 and 6.

When performing a depth-first crawl, the scanner pursues links in a fashion that more 
closely represents human interaction. While slower than breadth-first crawling, the 
depth-first method accommodates applications that enforce ordering of requests (such as 
requiring the user to visit a “shopping cart” page before accessing the “check-out” page.

• Enable keyword search audit—A keyword search, as its name implies, uses an attack engine 
that examines server responses and searches for certain text strings that typically 
indicate a vulnerability. Normally, this engine is not used during a crawl-only scan, but 
you can enable it by selecting this option. 

• Perform redundant page detection—Highly dynamic sites could create an infinite number of 
resources (pages) that are virtually identical. If allowed to pursue each resource, scanners 
would never be able to finish the scan. This option, however, allows scanners to identify 
and exclude processing of redundant resources. 

• Limit maximum single URL hits to—Use this field to limit the number of times a single link 
will be followed during a crawl. Sometimes, the configuration of a site will cause a crawl to 
loop endlessly through the same URL. 

• Limit maximum link traversal sequence to—This option restricts the number of hyperlinks 
that can be sequentially accessed as the scanner crawls the site. For example, if five 
resources are linked as follows

Page A contains a hyperlink to Page B

Page B contains a hyperlink to Page C

Page C contains a hyperlink to Page D

Page D contains a hyperlink to Page E

and if this option is set to “3,” then Page E will not be crawled. The default value is 15.

• Limit maximum crawl folder depth to—The Crawl Depth value determines how deeply the 
scanner traverses the hierarchical levels of your Web site. If set to 1, the scanner drills 
down one level; if set to 2, the scanner drills down two levels; and so on. The maximum 
value is 1000. 

• Limit maximum crawl count to—This feature restricts the number of HTTP requests sent by 
the crawler and should be used only if you experience problems completing a scan of a 
large site. 
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• Limit maximum Web form submissions to—Normally, when the scanner encounters a form 
that contains controls having multiple options (such as a list box), it extracts the first 
option value from the list and submits the form; it then extracts the second option value 
and resubmits the form, repeating this process until all option values in the list have been 
submitted. This ensures that all possible links will be followed.

There are occasions, however, when submitting the complete list of values would be 
counterproductive. For example, if a list box named “State” contains one value for each of 
the 50 states in the United States, there is probably no need to submit 50 instances of the 
form.

Use this setting to limit the total number of submissions that the scanner will perform. 

Audit Details

If you select a depth-first crawl, you can also elect to retrace the crawl path for each 
parameter attack, as opposed to applying all attacks as the crawl progresses. This 
considerably increases the time required to conduct a scan.

Content Analyzers

JavaScript/VBScript—The JavaScript/VBScript analyzer is always enabled. It allows the 
scanner to crawl links defined by JavaScript or VisualBasic script, and to create and audit 
any documents rendered by JavaScript. There are settings associated with the JavaScript/
VBScript content analyzer. Click the analyzer name (JavaScript/VBScript) and configure the 
settings described below. 

Flash—If you enable the Flash analyzer, the scanner analyzes Flash files, Adobe’s vector 
graphics-based resizeable animation format. 

Silverlight—If you enable the Silverlight analyzer, the scanner analyzes the multimedia, 
graphics, animation, and interactivity elements developed within Microsoft's Silverlight Web 
application framework. There are no associated settings.

JavaScript/VBScript Parser Settings

• Crawl links found from script execution—If you select this option, the crawler will follow 
dynamic links (i.e., links generated during execution of JavaScript or Visual Basic script). 

• Reject script include file requests to offsite hosts—Pages downloaded from a server may 
contain scripts that retrieve files and dynamically render their content. An example 
JavaScript “include file” request is: 

<script type="text/javascript" src="www.badsite.com/yourfile.htm"></script> 

The scanner will download and parse such files, regardless of their origin or file type, 
unless you select the Reject Script option. It will then download the files only if permitted 
by the parameters normally governing file handling (such as session and attack 
exclusions, allowed hosts, etc.). 

• Isolate script analysis (out-of-process execution)—The scanner analyzes and executes 
JavaScript and VBScript to discover links to other resources. Applications or Web sites 
containing an inordinate number of links can sometimes exhaust the amount of memory 
allocated to this process. If this occurs, you can assign this function to a separate (remote) 
process, which will accommodate an infinite number of links. You may, however, notice a 
slight increase in the amount of time required to scan the site. 

• Create DOM sessions—The scanner creates and saves a session for each change to the 
Document Object Model (DOM). 
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• Verbose script parser debug logging—If you select this setting AND if the Application 
setting for logging level is set to Debug, the scanner logs every method called on the DOM 
object. This can easily create several gigabytes of data for medium and large sites. 

• Log JavaScript errors—The scanner logs JavaScript parsing errors from the script parsing 
engine. 

• Maximum script events per page—Certain scripts endlessly execute the same events. You 
can limit the number of events allowed on a single page to a value between 1 and 9999. 

Requestor

Requestor Performance 

Select one of the following:

• Use a shared requestor—The crawler and the auditor use a common requestor when 
scanning a site, and each thread uses the same state, which is also shared by both 
modules. This replicates the technique used by previous versions of HP scanners and is 
suitable for use when maintaining state is not a significant consideration. You also specify 
the maximum number of threads (up to 75). 

• Use separate requestors—The crawler and auditor use separate requestors. Also, the 
auditor’s requestor associates a state with each thread, rather than having all threads use 
the same state. This method results in significantly faster scans. You also specify the 
maximum number of threads that can be created for each requestor. The crawl requestor 
can be configured to send up to 25 concurrent HTTP requests before waiting for an HTTP 
response to the first request; the maximum for the audit requestor is 50. Increasing the 
thread count will increase the speed of a scan, but might also exhaust your system 
resources as well as those of the server you are scanning. 

Requestor Settings 

You may select the following options:

• Limit maximum response size to—Select this option to limit the size of accepted server 
responses and then specify the maximum size (in kilobytes). The default is 1000 kilobytes. 
Note that Flash files (.swf) and JavaScript “include” files are not subject to this limitation.

• Request retry count—Specify how many times the scanner will resubmit an HTTP request 
after receiving a “failed” response (which is defined as any socket error or request 
timeout). 

• Request timeout—Specify how long the scanner will wait for an HTTP response from the 
server. If this threshold is exceeded, the scanner resubmits the request until reaching the 
retry count. If it then receives no response, the scanner logs the timeout and issues the 
first HTTP request in the next attack series. 

Stop Scan if Loss of Connectivity Detected 

There may be occasions during a scan when a Web server fails or becomes too busy to respond 
in a timely manner. You can instruct the scanner to terminate a scan by specifying a 
threshold for the number of timeouts. 

Tip: While most servers can handle a large number of requests, servers in development 
environments sometimes have limitations on their licensing that allow only five or fewer 
users to be connected at a single time. In such cases, you should reduce the thread count to be 
less than 5. Failing to do so may mean that the scanner does not accurately crawl or audit the 
site because requests are being rejected by the server.
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• Consecutive “single host” retry failures—Enter the number of consecutive timeouts 
permitted from one specific server. 

• Consecutive “any host” retry failures—Enter the total number of consecutive timeouts 
permitted from all hosts. 

• Nonconsecutive “single host” retry failures—Enter the total number of nonconsecutive 
timeouts permitted from a single host. 

• Nonconsecutive “any host” request failures—Enter the total number of nonconsecutive 
timeouts permitted from all hosts. 

• If first request fails, stop scan—Selecting this option will force the scanner to terminate the 
scan if the target server does not respond to the scanner’s first request. 

• Response codes to stop scan if received—Enter the HTTP status codes that, if received, will 
force termination of the scan. Use a comma to separate entries; use a hyphen to specify an 
inclusive range of codes. 

Session Storage

Log Rejected Session to Database 

You can specify which rejected sessions should be saved to the database. This saved 
information can be used for two purposes. 

• If you pause a scan, change any of the settings associated with the Reject Reasons in this 
panel, and then resume the scan, the scanner retrieves the saved data and sends HTTP 
requests that previously were suppressed. 

• Hewlett-Packard support personnel can extract the generated (but not sent) HTTP 
requests for analysis. Sessions may be rejected for the reasons cited in the following table: 

Reject Reason Explanation

Invalid Host Any host that is not specified in Default (or Current) Scan 
Settings/Scan Settings/Allowed Hosts. 

Excluded File Extension Files having an extension that is excluded by scan settings.

Excluded URL URLs or hosts that are excluded by scan settings. 

Outside Root URL If the Restrict to Folder option is selected when starting an 
advanced scan, any resource not qualified by the available 
options (Directory Only, Directory and Subdirectories, or 
Directory and Parent Directories). 

Maximum Folder Depth 
Exceeded 

HTTP requests were not sent because the value specified by 
the “Limit maximum crawl folder depth to” option has been 
exceeded. 
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Session Storage 

The scanner normally saves only those attack sessions in which a vulnerability was 
discovered. To save all attack sessions, select Save non-vulnerable attack sessions.

Session Exclusions

The following settings apply to both the crawl and audit phases of a vulnerability scan. To 
specify exclusions for only the crawl or only the audit, use the Crawl Settings - Session 
Exclusions or the Audit Settings - Sessions Exclusions. 

Excluded or Rejected File Extensions 

You can identify a file type and then specify whether you want to exclude or reject it.

• Reject—The scanner will not request files of the type you specify. 

• Exclude—The scanner will request the files, but will not attack them (during an audit) 
and will not examine them for links to other resources. 

Excluded MIME Types 

The scanner will not process files associated with the MIME type you specify. 

Excluded or Rejected URLs and Hosts 

You can identify a URL or host (using a regular expression) and then specify whether you 
want to exclude or reject it. 

• Reject—The scanner will not send any HTTP requests to the host or URL you specify. For 
example, you should usually reject any URL that deals with logging off the site, since you 
don’t want to log out of the application before the scan is completed. 

• Exclude—During a crawl, the scanner will not examine the specified URL or host for links 
to other resources. During the audit portion of the scan, the scanner will not attack the 
specified host or URL. If you want to access the URL or host without processing the HTTP 
response, select the Exclude option, but do not select Reject. For example, to check for 
broken links on URLs that you don’t want to process, select only the Exclude option. 

You must use a regular expression to designate a host or URL. 

Example 1

To ensure that you ignore and never send requests to any resource at Microsoft.com, enter 
the following regular expression and select Reject.

Microsoft\.com 

Maximum URL Hits HTTP requests were not sent because the value specified by 
the “Limit Maximum Single URL hits to” option has been 
exceeded. 

404 Response Code The option “Determine File Not Found (FNF) using HTTP 
response codes” is selected and the response contains a code 
that matches the requirements. 

Solicited File Not Found The option “Auto detect FNF page” is selected and the 
scanner determined that the response constituted a “file not 
found” condition. 

Reject Reason Explanation
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Note that the period (or dot) is preceded by a backslash, indicating that the next character 
is special (i.e., it is not the character used in regular expressions to match any single 
character except a newline character). 

Example 2 

Enter a string such as logout. If that string is found in any portion of the URL, the URL 
will be excluded or rejected (depending on which option you select). Using the logout 
example, the scanner will exclude or reject URLs such as logout.asp or applogout.jsp. 

Example 3 

If you enter /myApp / then the scanner will exclude or reject all resources in the myApp 
directory, such as: http://www.test.me /myApp /filename.htm. 

If you enter /W3SVC[0-9]*/ then the scanner will exclude or reject the following 
directories:

http://www.test.me/W3SVC55/ 

http://www.test.me/W3SVC5/ 

http://www.test.me/W3SVC550/

Follow the steps below to add a URL or host: 

1 Click Add. 

2 From the Type list, select either Host or URL. 

3 In the URLs and Hosts box, enter a URL or fully qualified host name, or a regular 
expression designed to match the targeted URL or host. 

4 Select one of the following: 

• Reject—Do not send request to targeted URL or host. 

• Exclude—Send request, but do not process response. 

5 Click Update. 

Allowed Hosts

Use the Allowed Host settings to add domains that may be crawled and audited. If your Web 
presence uses multiple domains, add those domains here. For example, if you were scanning 
“WIexample.com,” you would need to add “WIexample2.com” and “WIexample3.com” here if 
those domains were part of your Web presence and you wanted to include them in the crawl or 
audit.

You can also use this feature to scan any domain whose name contains the text you specify. 
For example, suppose you specify www.myco.com as the scan target and you enter “myco” as 
an allowed host. As the scanner scans the target site, if it encounters a link to any URL 
containing “myco,” it will pursue that link and scan that site’s server, repeating the process 
until all linked sites are scanned. For this hypothetical example, the scanner would scan the 
following domains:

• www.myco.com:80

• contact.myco.com:80

• www1.myco.com

• ethics.myco.com:80

• contact.myco.com:443
106 Chapter 6



• wow.myco.com:80

• mycocorp.com:80

• www.interconnection.myco.com:80

Note that if you specify a port number, then the allowed host must be an exact match.

If you use a regular expression to specify a host, select Regex.

HTTP Parsing

HTTP Parameters Used for State 

If your application uses URL rewriting or post data techniques to maintain state within a 
Web site, you must identify which parameters are used. For example, a PHP4 script can 
create a constant of the session ID named SID, which is available inside a session. By 
appending this to the end of a URL, the session ID becomes available to the next page. The 
actual URL might look something like the following:

.../page7.php?PHPSESSID=4725a759778d1be9bdb668a236f01e01 

Because session IDs change with each connection, an HTTP request containing this URL 
would create an error when you tried to replay it. However, if you identify the parameter 
(PHPSESSID in this example), then the scanner will replace its assigned value with the new 
session ID obtained from the server each time the connection is made. 

Similarly, some state management techniques use post data to pass information. For 
example, the HTTP message content may include userid=slbhkelvbkl73dhj. In this case, 
“userid” is the parameter you would identify. 

The scanner can identify potential parameters if they occur as posted data or if they exist 
within the query string of a URL. However, if your application embeds session data in the 
URL as extended path information, you must provide a regular expression to identify it. In 
the following example, “1234567” is the session information: 

http://www.onlinestore.com/bikes/(1234567)/index.html 

The regular expression for identifying the parameter would be: /\([\w\d]+\)/ 

Determine State from URL Path 

If your application determines state from certain components in the URL path, select this 
check box and add one or more regular expressions that identify those components. The 
defaults identify ASP.NET cookieless session IDs. 

HTTP Parameters Used for Page (Resource) Identification 

Some sites contain only one directly accessible resource, and then rely on query strings to 
deliver the requested information, as in the following examples: 

Ex. 1 -- http://www.anysite.com?Master.asp?Page=1 

Ex. 2 -- http://www.anysite.com?Master.asp?Page=2

Ex. 3 -- http://www.anysite.com?Master.asp?Page=13;Subpage=4 

Note: You need to identify parameters only when the application uses URL rewriting or 
posted data to manage state. It is not necessary when using cookies. 
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Ordinarily, the scanner would assume that these three requests refer to identical resources 
and would conduct a vulnerability assessment on only one of them. Therefore, if your target 
Web site employs this type of architecture, you must identify the specific resource parameters 
that are used. 

Examples 1 and 2 contain one resource parameter: “Page.” 

Example 3 contains two parameters: “Page” and “Subpage.” 

To identify resource parameters: 

1 Click Add. 

2 Enter the parameter name. 

3 Click Update. 

The string you entered appears in the Parameter list. Repeat this procedure for additional 
parameters. 

Advanced HTTP Parsing 

Most Web pages contain information that tells the browser what character set to use. This is 
accomplished by using the Content-Type response header (or a META tag with an 
HTTP-EQUIV attribute) in the HEAD section of the HTML document. 

For pages that do not announce their character set, you can specify which language family 
(and implied character set) the scanner should use. 

Filters

Use the Filters settings to add search-and-replace rules for HTTP requests and responses. 
This feature is used most often to avoid the disclosure of sensitive data such as credit card 
numbers, employee names, or social security numbers. It is a means of disguising information 
that you do not want to be viewed by persons who use the scanner or those who have access to 
the raw data. If the text you specify is found, the scanner reports it on the Information tab as a 
“Hidden Reference Found” vulnerability. 

Filter HTTP Request Content 

Use this area to specify search-and-replace rules for HTTP requests. 

Filter HTTP Response Content 

Use this area to specify search-and-replace rules for HTTP responses. 

Follow the steps below to add a regular expression rule for finding or replacing keywords in 
requests or responses: 

1 In either the Request Content or the Response Content group, click Add. 

2 From the Section list, select an area to search. 

3 In the Find Condition box, type (or paste) the string you want to locate (or enter a regular 
expression that describes the string). You can also click the list button to insert regular 
expression elements. 

4 Type (or paste) the replacement string in the Replace box. 

5 For case-sensitive searches, select the Case-Sensitive check box. 

6 Click Update. 
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Cookies/Headers

Standard Header Parameters 

You can elect to include referer and/or host headers in scanner requests.

• Include ‘referer’ in HTTP request headers—Select this check box to include referer headers in 
HTTP requests. The Referer request-header field allows the client to specify, for the 
server’s benefit, the address (URI) of the resource from which the Request-URI was 
obtained. 

• Include ’host’ in HTTP request headers—Select this check box to include host headers with 
HTTP requests. The Host request-header field specifies the Internet host and port 
number of the resource being requested, as obtained from the original URI given by the 
user or referring resource (generally an HTTP URL). 

Append Custom Headers 

Use this section to add, edit, or delete headers that will be included with each audit the 
scanner performs. For example, you could add a header such as “Alert: You are being attacked 
by Consultant ABC” that would be included with every request sent to your company’s server 
when the scanner is auditing that site. You can add multiple custom headers. Follow the steps 
below to add a custom header: 

1 In the top box, enter the header using the format <name>: <value>. 

2 Click Add. 

The new header appears in the list of custom headers.

Append Custom Cookies 

Use this section to specify data that will be sent with the Cookie header in HTTP requests 
sent by the scanner to the server. Follow the steps below to add a custom cookie: 

1 In the top box, enter the header using the format <name>=<value>. 

For example, if you enter 

CustomCookie=ScanEngine 

then each HTTP-Request will contain the following header: 

Cookie:CustomCookie=ScanEngine 

2 Click Add. 

The new cookie appears in the list of custom cookies. 

Proxy

Proxy Settings

Select one of the following options:

• Direct Connection (proxy disabled)—Select this option if you are not using a proxy server. 

• Auto detect proxy settings—If you select this option, the scanner will use the Web Proxy 
Autodiscovery Protocol (WPAD) to automatically locate a proxy autoconfig file and use 
this to configure the browser’s web proxy settings. 

• Use Internet Explorer proxy settings—Select this option to use the proxy server settings 
configured for the Internet Explorer browser on the machine that will conduct the scan. 
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• Use Firefox proxy settings—Select this option to use the proxy server settings configured for 
the Firefox browser on the machine that will conduct the scan. 

• Configure a proxy using a PAC file—Select this option to load proxy settings from a Proxy 
Automatic Configuration (PAC) file. Then specify the file location in the URL box. 

• Explicitly configure proxy—Select this option to access the Internet through a proxy server, 
and then enter the requested information. For proxy servers accepting https connections, 
select Specify Alternative Proxy for HTTPS and provide the requested information. 

1 In the Server box, type the URL or IP address of your proxy server. 

2 In the Port box. enter the port number (for example, 8080). 

3 Select a protocol for handling TCP traffic through a proxy server: SOCKS4, SOCKS5, or 
standard. 

4 If your proxy server requires authentication, enter the qualifying user name and 
password. 

5 If you do not need to use a proxy server to access certain IP addresses (such as internal 
testing sites), enter the addresses or URLs in the Bypass Proxy For box. Use commas to 
separate entries. 

Authentication

Scan Requires Network Authentication 

Select this option if users must log on to your Web site or application. Then select an 
authentication method and specify a user name and password.

The authentication methods are:

• Basic—A widely used, industry-standard method for collecting user name and password 
information. The Web browser displays a dialog box for a user to enter a previously 
assigned user name and password and then attempts to establish a connection to a server 
using the user’s credentials. If the Web server verifies that the user name and password 
correspond to a valid user account, a connection is established. Basic authentication is not 
recommended unless you are confident that the connection between the user and your 
Web server is secure. 

• NTLM—An authentication process that is used by all members of the Windows NT family 
of products. Like its predecessor LanMan, NTLM uses a challenge/response process to 
prove the client’s identity without requiring that either a password or a hashed password 
be sent across the network. Use NTLM authentication for servers running IIS. If NTLM 
authentication is enabled, and the scanner has to pass through a proxy server to submit 
its requests to the Web server, the scanner may not be able to crawl or audit that Web 

Electing to use browser proxy settings does not guarantee that you will access the 
Internet through a proxy server. If the Firefox browser connection settings are 
configured for “No proxy,” or if the Internet Explorer setting “Use a proxy server 
for your LAN” is not selected, then a proxy server will not be used

Warning: The scanner will crawl all servers granted access by this password (if the sites/
servers are included in the “allowed hosts” setting. To avoid potential damage to your 
administrative systems, do not use a user name and password that has administrative rights. 
If you are unsure about your access rights, contact your System Administrator or internal 
security professional, or contact HP technical support .
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site. Use caution when configuring a scanner for scans of sites protected by NTLM. After 
scanning, you may want to disable the NTLM authentication settings to prevent any 
potential problem. 

• Kerberos—Kerberos uses the Needham-Schroeder protocol as its basis. It uses a trusted 
third party, termed a Key Distribution Center (KDC), which consists of two logically 
separate parts: an Authentication Server (AS) and a Ticket Granting Server (TGS). The 
client authenticates itself to AS, then demonstrates to the TGS that it is authorized to 
receive a ticket for a service (and receives it). The client then demonstrates to a Service 
Server that it has been approved to receive the service. 

• Digest—The Windows Server 2003 operating system implements the Digest 
Authentication protocol as a security support provider (SSP), a dynamic-link library 
(DLL) that is supplied with the operating system. Using digest authentication, your 
password is never sent across the network in the clear, but is always transmitted as an 
MD5 digest of the user’s password. In this way, the password cannot be determined by 
sniffing network traffic. 

• Automatic—Allow the scanner to determine the correct authentication type. Automatic 
detection slows the scanning process. If you know and specify one of the other 
authentication methods, scanning performance is noticeably improved. 

Use Client Certificate 

Client certificate authentication allows users to present client certificates rather than 
entering a user name and password. Follow the steps below to use client certificates. 

1 Select Use Client Certificate. 

2 Click Browse to choose a certificate. 

File Not Found

Determine File Not Found” Using HTTP Response Codes 

Select this option to rely on HTTP response codes to detect a file-not-found response from the 
server. You can then identify the codes that fit the following two categories. 

• Forced Valid Response Codes (Never an FNF)—You can specify HTTP response codes that 
should never be treated as a file-not-found response. 

• Forced FNF Response Codes (Always an FNF)—Specify those HTTP response codes that 
will always be treated as a file-not-found response. The scanner will not process the 
response contents. 

Enter a single response code or a range of response codes. For ranges, use a dash or hyphen to 
separate the first and last code in the list (for example, 400-404). You can specify multiple 
codes or ranges by separating each entry with a semicolon. 

Determine File Not Found from Custom Supplied Signature 

Use this area to add information about any custom 404 page notifications that your company 
uses. If your company has configured a different page to display when a 404 error occurs, add 
the information here. False positives can result from 404 pages that are unique to your site. 

You can specify a signature using either plain text, a regular expression, or SPI Regex (see 
Regular Expression Extensions on page 170 for information on SPI Regex).
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Auto-Detect File Not Found Page 

Some Web sites do not return a status “404 Not Found” when a client requests a resource that 
does not exist. Instead, they may return a status “200 OK” but the response contains a 
message that the file cannot be found. Select this check box if you want the scanner to detect 
these “custom” file-not-found pages. 

The HP scanner attempts to detect custom file-not-found pages by sending requests for 
resources that cannot possibly exist on the server. It then compares each response and 
measures the amount of text that differs between the responses. For example, most messages 
of this type have the same content (such as “Sorry, the page you requested was not found”), 
with the possible exception being the name of the requested resource. If you select this option, 
you can specify what percentage of the response content must be the same. The default is 90 
percent. 

Policy

Scan Policy

A policy is a collection of audit engines and attack agents that a scanner uses when auditing 
or crawling your Web application. Each component has a specific task, such as testing for 
cross-site scripting susceptibility, building the site tree, probing for known server 
vulnerabilities, etc. See Appendix A, Policies, for policy descriptions. 

For a Web Service scan, you can select only the SOAP policy.

Crawl Settings

Link Parsing

The scanner follows all hyperlinks defined by HTML (using the <a href> tag) and those 
defined by scripts (if you select the JavaScript/VBScript analyzer option on the Scan Settings: 
Content Analyzers panel). However, you may encounter other communications protocols that 
use a different syntax for specifying links. To accommodate this possibility, you can use the 
Custom Links feature to identify (using regular expressions) links that you want the scanner 
to follow.

Follow the steps below to add a specialized link identifier: 

1 Click Add. 

2 In the Custom Links box, enter a regular expression designed to identify the link. 

3 (Optional) Enter a description of the link in the Comments box. 

4 Click Update. 

Session Exclusions

All items specified in the Scan Settings - Session Exclusions are automatically replicated in 
the Session Exclusions for both the Crawl Settings and the Audit Settings. These items are 
listed in gray (not black) text. If you do not want these objects to be excluded from the crawl, 
you must remove them from the Scan Settings - Session Exclusions panel. This panel (Crawl 
Settings - Session Exclusions) allows you to specify additional objects to be excluded from the 
crawl.
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Excluded or Rejected File Extensions

If you select Reject, files having the specified extension will not be requested. If you select 
Exclude, files having the specified extension will be requested, but will not be audited. Follow 
the steps below to add a file extension: 

1 Click Add. 

2 In the File Extension box, enter a file extension. 

3 Select either Reject, Exclude, or both. 

4 Click Update. 

Excluded MIME Types 

Files associated with the MIME types you specify will not be audited. Follow the steps below 
to add a MIME Type: 

1 Click Add. 

2 In the Exclude Mime-type box, enter a MIME type. 

3 Click Update. 

Excluded or Rejected URLs and Hosts 

The URLs or hosts you specify will not be accessed if you select the Reject option. However, 
you may want to access the URL or host (do not select Reject), but not process the HTTP 
response (select Exclude). For example, you should usually reject any URL that deals with 
logging off the site, since you don’t want to log out of the application before the scan is 
completed. To check for broken links to URLs that you don’t want to process, select only the 
Exclude option. Follow the steps below to add a URL or host: 

1 Click Add. 

2 From the Type list, select either Host or URL. 

3 In the URLs and Hosts box, enter a URL or fully qualified host name, or a regular 
expression designed to match the targeted URL or host. 

4 Select one or both of the following:

• Reject—Do not send request to targeted URL or host

• Exclude—Send request, but do not process response 

5 Click Update. 

Audit Settings

Session Exclusions

All items specified in the Scan Settings - Session Exclusions are automatically replicated in 
the Session Exclusions for both the Crawl Settings and the Audit Settings. These items are 
listed in gray (not black) text. If you do not want these objects to be excluded from the audit, 
you must remove them from the Scan Settings - Session Exclusions panel. This panel (Audit 
Settings - Session Exclusions) allows you to specify additional objects to be excluded from the 
audit. 
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Excluded or Rejected File Extensions

If you select Reject, files having the specified extension will not be requested. If you select 
Exclude, files having the specified extension will be requested, but will not be audited. Follow 
the steps below to add a file extension: 

1 Click Add. 

2 In the File Extension box, enter a file extension. 

3 Select either Reject, Exclude, or both. 

4 Click Update. 

Excluded MIME Types 

Files associated with the MIME types you specify will not be audited. Follow the steps below 
to add a MIME Type: 

1 Click Add. 

2 In the Exclude Mime-type box, enter a MIME type. 

3 Click Update. 

Excluded or Rejected URLs and Hosts 

The URLs or hosts you specify will not be accessed if you select the Reject option. However, 
you may want to access the URL or host (do not select Reject), but not process the HTTP 
response (select Exclude). For example, you should usually reject any URL that deals with 
logging off the site, since you don’t want to log out of the application before the scan is 
completed. To check for broken links to URLs that you don’t want to process, select only the 
Exclude option. Follow the steps below to add a URL or host: 

1 Click Add. 

2 From the Type list, select either Host or URL. 

3 In the URLs and Hosts box, enter a URL or fully qualified host name, or a regular 
expression designed to match the targeted URL or host. 

4 Select one or both of the following:

• Reject—Do not send request to targeted URL or host.

• Exclude—Send request, but do not process response. 

5 Click Update. 

Attack Exclusions

Excluded Parameters 

Use this feature to prevent the scanner from using certain parameters in the HTTP request to 
attack the Web site. This feature is used most often to avoid corrupting query and 
POSTDATA parameters.

To prevent certain parameters from being modified: 

1 In the Excluded Parameters group, click Add. 

2 In the Parameter box, enter the name of the parameter you want to exclude. 

3 Choose the area in which the parameter may be found: HTTP query data or HTTP POST 
data. You can select both areas, if necessary. 
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4 Click Update. 

Excluded Cookies 

Use this feature to prevent the scanner from using certain cookies in the HTTP request to 
attack the Web site. This feature is used to avoid corrupting cookie values. This setting 
requires you to enter the name of a cookie. In the following example HTTP response ... 

Set-Cookie: FirstCookie=Chocolate+Chip; path=/ 

... the name of the cookie is “FirstCookie.” 

Follow the steps below to exclude certain cookies. 

1 In the Excluded Cookies group, click Add. 

2 In the Parameter box, type a cookie name or enter a regular expression that you believe 
will match the cookies you want to exclude. 

3 Click Update. 

Excluded Headers 

Use this feature to prevent the scanner from using certain headers in the HTTP request to 
attack the Web site. This feature is used to avoid corrupting header values. 

To prevent certain headers from being modified, create a regular expression using the 
procedure described below. 

1 In the Excluded Headers group, click Add. 

2 In the Parameter box, type a header name or enter a regular expression that you believe 
will match the headers you want to exclude. 

3 Click Update. 

Audit Inputs Editor

Using the Audit Inputs Editor, you can create additional parameters for audit engines and 
checks that require inputs. 

To load inputs that you previously created using the editor, click the Browse button next to 
the Import Audit Inputs button. 

Attack Expressions

Additional Regular Expression Languages 

You may select one of the following language code-country code combinations (as used by the 
CultureInfo class in the .NET Framework Class Library):

ja-jp: Japanese and Japan 

ko-Kr: Korean and Korea

zh-cn: Chinese and China (PRC)

The CultureInfo class holds culture-specific information, such as the associated language, 
sublanguage, country/region, calendar, and cultural conventions. This class also provides 
access to culture-specific instances of DateTimeFormatInfo, NumberFormatInfo, 
CompareInfo, and TextInfo. These objects contain the information required for 
culture-specific operations, such as casing, formatting dates and numbers, and comparing 
strings.
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Vulnerability Filters

Select Vulnerability Filters to Enable

By applying certain filters, you can limit the display of vulnerabilities reported during a scan. 
For example, the “Parameter Vulnerability Roll-Up” filter, when selected, consolidates 
multiple parameter manipulation and parameter injection vulnerabilities discovered during a 
single session into one vulnerability. 

Click a filter name to view a description of the function it performs. 

To add a filter to your default settings, select a filter in the Available area and click >. The 
filter is removed from the Available list and added to the Selected list. 

To disable a filter, select a filter in the Selected list and click <. The filter is removed from the 
Selected list and added to the Available list. 

To add all available filters, click >>. 

To remove all selected filters, click <<.

Smart Scan

Enable Smart Scan

Smart Scan is an “intelligent” feature that discovers the type of server that is hosting the Web 
site and checks for known vulnerabilities against that specific server type. For example, if you 
are scanning a site hosted on an IIS server, the scanner will probe only for those 
vulnerabilities to which IIS is susceptible. It would not check for vulnerabilities that affect 
other servers, such as Apache or iPlanet.

If you select this option, you can choose one or both of the identification methods described 
below. 

• Use regular expressions on HTTP responses—This method searches the server response for 
strings that match predefined regular expressions designed to identify specific servers. 

• Use server analyzer fingerprinting and request sampling—This advanced method sends a 
series of HTTP requests and then analyzes the responses to determine the server type. 

Custom Server/Application Type Definitions 

If you know the server type for a target domain, you can select it using the Custom server/
application type definitions section. This identification method overrides any other selected 
method for the server you specify. 

If you know the server type for a target domain, you can select it using the Custom server/
application type definitions section. This identification method overrides any other selected 
method for the server you specify.

1 Click Add. 

2 In the Host box, enter the domain name or host, or the server’s IP address.

3 Select one or more entries from the Server/Application list.

4 Click OK.
116 Chapter 6



 Scan Behavior

Blackout Action

A blackout period is a block of time during which scans are not permitted. 

If a blackout period begins while a scan in running, you may either stop the scan or suspend 
it. The scanner will resume a suspended scan when the blackout period ends.

Export

General

Export Scan Results

Select this option to export the scan results. Then provide the requested information. 

• Export Path—Select a destination for the exported scan. Export paths are specified by the 
WebInspect Enterprise administrator. 

• Export Format—Select how you want the exported file to be formatted. Your choices are 
WebInspect Scan File or XML. 

• Automatically generate file name—If you select this option, the name of the file will be 
formatted as <scan name> <date/time>.[xml or scan]. For example, if the scan name is 
“mysite” and the scan is generated at 6:30 on April 5, the file name would be “mysite 
04_05_2007 06_30.scan [or .xml].” This is useful for recurring scans.

If you want to specify a name, clear the Automatically generate file name check box and then 
type the name in the File Name box. 

Scheduled Scan Settings

To schedule a scan, click the Add icon and then specify the scan settings. These settings are 
the same as described in Advanced Scan Settings on page 96, with the following additions:

Schedule

General

Project Version 

Select a project from the Projects list and then select a version from the Project Versions list. 

Scan Template

Instead of specifying each individual setting every time you conduct a scan, you can create 
templates that contain different settings and then simply select a template from the Scan 
Template list. You are not required to use a template.

Schedule

• Schedule Name—Enter a name that identifies this scheduled scan.
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• Start Time—Enter the date and time you want the scan to begin. If you click the drop-down 
arrow, you can select the date from a calendar.

• Time Zone—The time zone for the location of the target server specified for the scheduled 
scan. The time zone defaults to the zone in which you are working (as selected using the 
Configure Options window). If the target server is in a different time zone, you should 
usually select the server’s time zone and specify the Start time using local time. For 
example, if you are in New York City, USA (UTC-05) and the target server is in Rome, 
Italy (UTC+01), and you want to schedule a scan to begin at 8 a.m. Rome time, you could 
do either of the following:

— Select the UTC+01 time zone (Rome) and specify a Start time of 8 a.m.

— Select the UTC-05 time zone (New York City) and specify a Start time of 2 a.m.

• Next Scheduled Time—For a scan that is scheduled to recur, this read-only field displays 
the time and date of the next scheduled scan.

• Last Occurred On—For a scan that is scheduled to recur, this read-only field displays the 
time and date when the scan last occurred.

Recurrence

The Project Version setting is reproduced on each settings dialog, allowing you to change your 
selection at any point. The description of this setting is not repeated in the following topics.

Recurring

To schedule a scan, Smart Update, or blackout on a recurring basis, select the Recurring check 
box. Do NOT select this option if you want to schedule a one-time-only event.

Pattern

Use the Pattern group to select the frequency of the event (daily, weekly, monthly, or yearly) 
and then provide the appropriate information.

Range

Use the Range group to specify the starting date and the ending date (or select Never if the 
event is to run indefinitely). You can also limit the number of times the event should occur.

See Advanced Scan Settings on page 96 for a description of the remaining Schedule Scan 
settings.

Blackout Settings

A blackout period is a block of time during which scans are not permitted. You can also create 
a partial ban by specifying that scans should not be conducted on specific hosts (identified by 
URL or IP address) during the time period you specify.

You may alternatively assign a contrary definition to the blackout, specifying that scans may 
occur only during this time period. In effect, this creates a blackout period covering all but the 
period of time you specify.
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General

Security Group 

Select an organization and group. To associate the blackout with all groups in an 
organization, select Use Organization. 

Name 

Enter a unique identifier for this blackout period. 

Address

The URL or IP address (or range of IP addresses) that are affected by this blackout period. 
The value can be a single URL or IP address, or a range of IP addresses. If you need to exclude 
multiple ranges, you must create additional (overlapping) blackout periods. To specify a 
range, separate the beginning address and ending address with a hyphen. You can use the 
asterisk ( * ) as a wild card. The default setting (an asterisk) means all addresses. Wildcards 
in IP addresses must be at the end of the address as shown, but wildcards for host names 
must be at the beginning. 

Examples: 

192.16.12.1-192.16.12.210 

192.16.12.* 

*.domain.com 

Schedule

• Start Time—The date and time at which the blackout period begins. 

• End Time—The date and time at which the blackout period expires. 

• Time Zone—The time zone for the location of the target server that is affected by the 
blackout. The time zone defaults to the zone in which you are working (as selected using 
the Configure Options window). If the target server is in a different time zone, you should 
usually select the server’s time zone and specify the blackout period using local time. For 
example, if you are in New York City, USA (UTC-05) and the WebInspect Enterprise 
manager is in Rome, Italy (UTC+01), and you want to schedule a blackout to begin at 8 
a.m. Rome time, you could do either of the following:

— Select the UTC+01 time zone (Rome) and specify a Start time of 8 a.m.

— Select the UTC-05 time zone (New York City) and specify a Start time of 2 a.m.

• Duration—The length of time during which the blackout is in effect. This value is 
calculated automatically after you specify the Start Time and End Time. Alternatively, if 
you specify the Start Time and the Duration, the End Time is calculated. If you edit the 
Duration, the End Time is recalculated. The format is: 

d.hh.mm

where

d = the number of days

hh = the number of hours

mm = the number of minutes
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Blackout Type 

• Allow—Scans of the specified targets are allowed only during the specified time period. 

• Deny—Scans of the specified targets are prohibited during the specified time period. 

Allow and deny work very much like allow and deny for permissions. Deny always takes 
precedence over allow, so a scan can occur only at a particular time if there are no blackout 
periods that deny that time. An allow blackout period means deny scans UNLESS you are in 
the allowed range, as opposed to allow scans ONLY if you are in the allowed range. If you 
configure two separate “allow” blackout periods, a scan will be allowed only during the union 
of those periods. For example, if period A allows scans from 1 P.M. to 3 P.M. and period B 
allows scans from 2 P.M. to 6 P.M., then scans will be allowed only from 2 P.M. to 3 P.M.

Recurrence

Use these settings to schedule a blackout on a recurring basis.

Recurring

Select the Recurring check box to impose recurring blackouts. Do NOT select this option if you 
want to schedule a one-time-only event.

Pattern

Use the Pattern group to select the frequency of the blackout (daily, weekly, monthly, or 
yearly) and then provide the appropriate information.

Range

Use the Range group to specify the starting date and the ending date (or select Never if the 
event is to run indefinitely). You can also limit the number of times the event should occur.
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A Policies
Introduction

A policy is a collection of vulnerability checks and attack methodologies that HP scanners 
deploy against a Web application. All policies contain all possible audit engines and agents, 
but each policy has a different subset of these components enabled. Although your 
environment may also include custom policies designed by your developers, the standard 
installation contains the prepackaged policies described in the following section. 

Policies

• Aggressive SQL Injection—The Aggressive SQL Injection policy performs a 
comprehensive security assessment of your web application for SQL Injection 
vulnerabilities. SQL Injection is an attack technique that takes advantage of 
non-validated input vulnerabilities to pass arbitrary SQL queries and/or commands 
through the web application for execution by a backend database. This policy performs out 
a more accurate and decisive job, but has a longer scan time.

• All Checks—An All Checks scan includes an automated crawl of the server and performs 
all active checks from SecureBase, the check database. This includes checks for known 
and unknown vulnerabilities at the Web server, Web application server, and Web 
application layers.

• Application—The Application policy performs a security assessment of your Web 
application by submitting known and unknown Web application attacks, and only 
submits specific attacks that assess the application layer. When performing assessments 
of enterprise level Web applications, use the Application Only policy in conjunction with 
the Platform Only policy to optimize your assessment in terms of speed and memory 
usage. 

• Assault—An assault scan includes an automated crawl of the server and performs checks 
for known and unknown vulnerabilities at the Web server, Web application server, and 
Web application layers. An assault scan includes checks that can create denial-of-service 
conditions. 

• Blank—This policy is a template that you can use to build your own policy. It includes an 
automated crawl of the server and no vulnerability checks. Edit this policy to create 
custom policies that only scan for specific vulnerabilities.

• Criticals and Highs—Use the Criticals and Highs policy to quickly scan your Web 
applications for the most urgent and pressing vulnerabilities while not endangering 
production servers. This policy checks for SQL Injection, Cross-Site Scripting, and other 

You are strongly advised to use assault scans in test environments only.
121



critical and high severity vulnerabilities. It does not contain checks that may write data to 
databases or create denial-of-service conditions, and is safe to run against production 
servers. 

• Cross-Site Scripting—This policy performs a security assessment of your Web 
application for cross-site scripting (XSS) vulnerabilities. XSS is an attack technique that 
forces a Web site to echo attacker-supplied executable code, such as HTML code or 
client-side script, which then loads in a user’s browser. Such an attack can be used to 
bypass access controls or conduct phishing expeditions.

• Dev—A Developer scan includes an automated crawl of the server and performs checks 
for known and unknown vulnerabilities at the Web application layer only. The Developer 
policy does not execute checks that are likely to create denial-of-service conditions, so it is 
safe to run on production systems.

• DevInspectEclipse—The DevInspectEclipse policy is the standard policy for use by 
DevInspect Java Eclipse. It performs both a crawl and audit, and tests the application for 
known and unknown vulnerabilities.

• DevInspectVS—The DevInspect VS policy is the standard policy for use by DevInspect 
VS. It performs both a crawl and audit, and tests the application for known and unknown 
vulnerabilities.

• OWASP Top Ten—Many government agencies suggest testing for the Open Web 
Application Security Project (OWASP) Top Ten Web application vulnerabilities as a best 
practice in ensuring the security of your Web application. 

• Passive Scan—The Passive Scan policy scans an application for vulnerabilities 
detectable without active exploitation, making it safe to run against production servers. 
Vulnerabilities detected by this policy include issues of path disclosure, error messages, 
and others of a similar nature.

• Platform Only—The Platform Only policy performs a security assessment of your Web 
application platform by submitting attacks specifically against the Web server and known 
Web applications. When performing assessments of enterprise-level Web applications, use 
the Platform Only policy in conjunction with the Application Only policy to optimize your 
assessment in terms of speed and memory usage

• QA—The QA policy is designed to help QA professionals make project release decisions in 
terms of Web application security. It performs checks for both known and unknown Web 
application vulnerabilities. However, it does not submit potentially hazardous checks, 
making it safe to run on production systems. 

• Quick—A quick scan includes an automated crawl of the server and performs checks for 
known vulnerabilities in major packages and unknown vulnerabilities at the Web server, 
Web application server and Web application layers. A quick scan does not run checks that 
are likely to create denial-of-service conditions, so it is safe to run on production systems. 

• Safe—A safe scan includes an automated crawl of the server and performs checks for 
most known vulnerabilities in major packages and some unknown vulnerabilities at the 
Web server, Web application server and Web application layers. A safe scan does not run 
any checks that could potentially trigger a denial-of-service condition, even on sensitive 
systems. 

• SQL Injection—The SQL Injection policy performs a security assessment of your Web 
application for SQL injection vulnerabilities. SQL injection is an attack technique that 
takes advantage of non-validated input vulnerabilities to pass arbitrary SQL queries and/
or commands through the Web application for execution by a backend database. 
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• Standard—A Standard scan includes an automated crawl of the server and performs 
checks for known and unknown vulnerabilities at the Web server, Web application server 
and Web application layers. A Standard scan does not run checks that are likely to create 
denial-of-service conditions, so it is safe to run on production systems. 
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B WebInspect Enterprise Tools
Introduction

The WebInspect Enterprise Console includes a robust set of tools and configuration options. 
The following tools are available from the WebInspect Enterprise Console Tools menu:

• Smart Update

• Options

• Encoders/Decoders

• HTTP Editor

• Regular Expression Editor

• Web Proxy

• Web Form Editor

• Web Macro Recorder (TruClient)

• Web Macro Recorder (Session-Based)

• Web Macro Recorder (Event-Based)

• Web Service Test Designer

• SQL Injector

• Web Brute

• Web Discovery

• Cookie Cruncher

• Web Fuzzer

• Server Analyzer

In addition, the following tools are also available:

• Policy Manager (accessible from the WebInspect Enterprise Console using the Scan 
Policies form in the Scans group)

• Audit Inputs Editor (accessible from the Policy Manager’s Tools menu)

Certain tools are not enabled unless HP WebInspect and the WebInspect Enterprise Console 
are installed on the same machine.
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Options

Use the following procedure to specify settings for the WebInspect Enterprise Console.

1 From the Tools menu, select Options.

2 To refresh the display of WebInspect Enterprise information periodically, select the 
Automatically refresh display check box and specify how often (in seconds) the display 
should be updated.

3 Click OK.

Policy Manager

A policy is a collection of audit engines and attack agents that HP scanners use when auditing 
or crawling your Web application. Each component has a specific task, such as testing for 
susceptibility to cross-site scripting, building the site tree, probing for known server 
vulnerabilities, etc. These components are organized into the following groups 

All these components (except for the Audit Engines) are known collectively as attack groups. 
Each attack group contains subgroups of individual modules (called attack agents) that check 
your Web site for vulnerabilities. 

WebInspect Enterprise contains several prepackaged policies designed to accommodate the 
majority of users. All policies contain all possible audit engines and agents, but each policy 
has a different subset of these components enabled. You edit a policy by enabling or disabling 
audit engines and/or individual attack agents (or groups of agents). You create a policy by 
editing an existing policy and saving it with a new name.

Views

The Policy Manager has two different views, selectable from the View menu or by clicking 
icons on the toolbar. They are:

• Standard

• Search

Standard View 

This view displays, by default, a list of checks categorized by threat class (according to 
classifications established by the Web Application Security Consortium). Alternatively, a 
drop-down list allows you to display all attack agents by severity, or a list of audit engines and 
attack groups. 

• Audit Engines • Web Application Servers

• Audit Options • Web Applications

• Directory Enumeration • Web Servers

• Unknown Application Testing • Custom Checks
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You enable or disable a component by selecting or clearing its associated check box.

The check box next to an unexpanded node indicates the “selected” status of the objects within 
the node. 

• A check means all objects are selected.

• A green square means some objects are selected.

• An empty box means no objects are selected.

Click the plus sign  to expand a node.

Search View

The Search view allows you to locate attack agents containing the text you specify in a 
selected report field (i.e., summary, implication, execution, recommendation, and fix). This 
feature is used most often to identify checks that you want to disable. For example, if you are 
scanning an application that does not contain PHP scripting, you could search summary fields 
for “PHP.” When the Policy Manager lists the attack agents that match your search criteria, 
you could disable an agent by clearing its associated check box. Then, you can either save the 
modified policy (making the policy changes permanent) or simply apply the modified policy to 
the current scan.

Attack Groups Severity Threat Classes
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Creating or Editing a Policy

You cannot permanently change the policies that are packaged with WebInspect Enterprise. 
However, you may open any of them as a template, modify their contents to create a custom 
policy, and save the customized policy under a new name. A custom policy may be edited and 
saved without changing its name.

Follow the steps below to edit a policy:

1 On the WebInspect Enterprise Console, click the Scans group.

2 Click the Scan Policies shortcut.

3 Select a policy.

4 Click the Action menu and select Copy.

The WebInspect Enterprise Console downloads the policy from the server and loads it into 
the Policy Manager.

5 Disable (or enable) an attack group by clearing (or selecting) its associated check box. To 
disable or enable an individual agent within a group, first expand the group and then edit 
its check box.

6 To rename an attack group:

a Right-click the attack group.

b Choose Rename from the shortcut menu. 

7 To add an attack group:

a Right-click any existing attack group and choose New Attack Group from the shortcut 
menu. A highlighted entry named New Attack Group appears. 

b Right-click the new group and choose Rename.

c Populate the group by dragging and dropping attack agents onto it. 

8 You may also create a custom check. See Creating a Custom Check on page 128 for more 
information.

9 If you select the Auto Update check box, HP scanners determine if any updated or new 
attack agents downloaded from the HP database should be enabled or disabled, based on 
the analysis of its sibling agents. For example, if you disable attack agents targeting 
Microsoft’s Internet Information Server (IIS), and you select Auto Update, then the scanner 
will not enable any IIS-related attack agent that it downloads to your system. Conversely, 
any new or updated attack agents that are related to agents that are enabled in your 
policy will also be enabled.

New vulnerability checks downloaded via Smart Update are not added automatically to 
any custom policies you may have created. 

10 Select File → Save As. Type a name for your custom policy in the File name box and then 
click Save. You cannot save a policy using the name of a prepackaged policy (Assault, 
Blank, Standard, etc.).

Creating a Custom Check

Although HP scanners rigorously inspect your entire Web site for real and potential security 
vulnerabilities, you may require a custom check to detect vulnerabilities that are unique to 
your application.
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Follow the steps below to create a custom check:

1 On the WebInspect Enterprise Console, click the Scans group.

2 Click the Scan Policies shortcut.

3 Select a policy.

4 Click the Action menu and select Copy.

The WebInspect Enterprise Console downloads the policy from the server and loads it into 
the Policy Manager.

5 Make sure the Standard view is selected, with attack groups listed in the left pane.

6 Right-click on Custom Checks and select New Custom Check from the shortcut menu.

7 When the Custom Check Wizard appears, select an attack type.

The attack types are listed below. See Steps 9-10 for entering attack and signature 
information.

• Directory enumeration

This type of check searches for a directory of the name you specify.

• File extension addition

This type of check searches for files with a file extension that you specify.

During the crawl, whenever the scanner encounters a file of any name and any 
extension (for example, global.asa), it sends an HTTP request for a file of the same 
name plus the found extension plus an extension that you specify. For example, if you 
specify a file extension of .backup, then when the scanner discovers a file named 
global.asa, it will subsequently search for a file named global.asa.backup. 

A server would normally deny any request for the global.asa file, but if a programmer 
has left a backup file on the server and the file has a different extension (such as 
global.asa.backup), then the server might return the file (which contains the full 
source of the global.asa file).

Attack Type: Directory Enumeration

Attack: /directory_name/  [where directory_name is the name of the 
directory you want to find]

Signature: [STATUSCODE]3\d\d OR [STATUSCODE]2\d\d OR 
[STATUSCODE]40[13]
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To create a custom check that searches for files with a specific added extension, enter 
the following in the Custom Check Wizard:

• File extension replacement

This type of check searches for files with a file extension that you specify.

For example, one standard check searches for files having an extension of “old.” 
During the crawl, whenever the scanner encounters a file of any name and any 
extension (for example, startup.asp), it sends an HTTP request for a file of the same 
name but with an extension of “old” (for example, startup.old).

To create a custom check that searches for files with a specific extension, enter the 
following in the Custom Check Wizard:

• Keyword search

This type of check determines if a specified word or phrase (defined by a regular 
expression) exists anywhere in the body of the HTTP response. 

The following example searches the HTTP response for a nine-digit number formatted 
as a social security number (\d = any digit).

• Parameter injection

This type of attack replaces an argument value with an attack string.

Example:

http://www.samplesite.com/webapp.asp?ValidParameter=ValidArgument

will be changed to

http://www.samplesite.com/webapp.asp?ValidParameter=AttackArgument

There are several variations.

– Command Execution

Attack Type: File Extension Addition

Attack: .ext [where ext is the file extension of files you want to 
locate]. You must include the leading dot or period (.)

Signature: [STATUSCODE]200 AND ( 
[HEADERS]Content-Type:\stext/plain OR 
[HEADERS]Content-Type:\sapplication/octet-stream)

Attack Type: File Extension Replacement

Attack: ext [where ext is the file extension of files you want to locate]. Do 
NOT include a leading dot or period (.)

Signature: [STATUSCODE]200 AND ( [HEADERS]Content-Type:\stext/plain 
OR [HEADERS]Coontent-Type:\sapplication/octet-stream)

Attack Type: Keyword Search

Attack: N/A

Signature:  BODY]\d\d\d-\d\d-\d\d\d\d
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A command execution check combines strings composed of special characters with 
operating system-level commands. It is an attempt to make the Web application 
execute the command using the provided string (if the application fails to check 
for and prohibit the input).

The following example tests for parameter injection by providing spurious input to 
a program named support_page.cgi; if the HTTP response contains data that 
matches the regular expression, then the application is vulnerable to command 
execution.

– SQL Injection

SQL injection is the act of passing SQL code into an application. These attack 
strings are composed of fragments of SQL syntax that will be executed on the 
database server if the Web application uses the string when forming a SQL 
statement without first filtering out certain characters.

– Cross-Site Scripting

This issue occurs when dynamically generated Web pages display input that is not 
properly validated. This allows an attacker to embed malicious JavaScript into 
the generated page, enabling him to execute the script on the machine of any user 
who views the malicious page. Any site that allows users to post text messages 
can be vulnerable to an attack such as this.

The following example tests for cross-site scripting in the Fusion News 
application:

– Directory Traversal

Directory traversal entails sending malformed URL strings to access non-public 
portions of the Web server’s content. An attacker will try to access different files 
on a server by using relative hyperlinks. For example, by adding triplets of two 
periods and a forward slash (../) to the target URL and by varying the number of 
directories to traverse, an attacker might find and gain access to a system 
password file such as www.server.com/../../../../password.

Attack Type: Parameter Injection

Attack: /support_page.cgi?file_name=|id|

Signature: [BODY]uid= AND [BODY]gid=

Attack Type: Parameter Injection

Attack: ’ [an apostrophe]

Signature: [[STATUSCODE]5\d\d

Attack Type: Parameter Injection

Attack: /fullnews.php?id=<script>alert(document.cookie)</
script>

Signature: [ALL]Powered\sby\sFusion\sNews And 
[ALL]<script>alert\(document\.cookie\)</script>
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The following example searches for the boot.ini file:

– Abnormal Input

Abnormal input attack strings are composed of characters that can cause 
unhandled exceptions (errors the program is not coded to handle) in Web 
applications where unexpected input is not prohibited. Unhandled exceptions 
often cause servers to display error messages that disclose sensitive information 
about the application’s internal mechanics. Source code may even be disclosed.

The following example sends an extraordinarily long string in an attempt to 
create a buffer overflow.

• Simple attack

This type of attack is sent once for every server scanned.

The following example attempts to obtain a UNIX password file by appending the 
attack string to the target URL or IP address:

• Site search

This type of attack is designed to find files commonly left on a Web server. For 
example, check ID #279 searches for a file named log.htm.

The following example searches for a file named xanadu.html by appending the attack 
string to the target URL or IP address:

To create a custom check that searches for a file named confidential.txt, enter the 
following in the Custom Check Wizard:

8 Click Next.

Attack Type: Parameter Injection

Attack: /../../../../../../../../../../../boot.ini

Signature: [ALL]\[boot\sloader\]

Attack Type:  Parameter Injection

Attack:  AAAAA...AAAAA [1000 repetitions of the letter “A”]

Signature:  [STATUSCODE]5\d\d

Attack Type: Simple Attack

Attack: /etc/passwd

Signature: [ALL]root: AND [ALL]:0:0

Attack Type: Site Search

Attack: xanadu.html

Signature: [STATUSCODE]2\d\d OR [STATUSCODE]40[1]

Attack Type: Site Search

Attack: confidential.txt

Signature: [STATUSCODE]2\d\d AND ([HEADERS]Content-Type:\stext/plain 
OR [HEADERS]Content-Type:\sapplication/octet-stream)
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9 In the Attack box, enter the data you want to use for the attack. In the following example 
of directory enumeration, the check will search for a directory named “Dave” by 
appending the attack string (/Dave/) to the target URL or IP address.

10 You must specify a signature, which is simply a regular expression (i.e., a special text 
string for describing a search pattern). When the scanner searches the HTTP response 
and finds the text described by the signature, it flags the session as a vulnerability. You 
can use the Search for box and drop-down lists to help you create the regular expression, or 
you can type the regular expression directly into the text box at the bottom of the window.

To use the Search for box:

a Enter the text you want to locate.

Enter only text; do not enter a regular expression.

b In this example (searching for a directory named “Dave”), the server would return a 
status code of 200 if the directory exists, so enter “200” in the Search for box. 
Realistically, however, you might also accept any status code in the 200 or 300 series, 
or a status code of 401 or 403.

c Click the drop-down arrow to specify the section of the HTTP response that should be 
searched.

d (optional) To create a complex search, click the second drop-down and select a Boolean 
operator (AND, OR, or NOT).

e Click Insert.

f (optional) For complex searches, repeat steps a-d as needed. You can also edit or 
replace the regular expression that appears in the bottom text box.

11 Click Next.
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12 On the Report Information panel, click each tab and enter the text that will appear in the 
vulnerability description.

13 Select an entry from the Check Type list.

14 Select a severity level from the Severity list.

15 Click Finish.

16 Change the default name “New Custom Check” to reflect the purpose of the check.

17 Click  to expand the Audit Engines folder.

18 Ensure that the appropriate audit engine is enabled (with a check mark) for the type of 
check you created, according to the following table:

Table 1 Correlation of Attack Type to Audit Engine 

This Attack Type… Uses this Audit Engine…

Simple Attack Fixed Checks

Parameter Injection Post Data Injection

Site Search Site Search
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19 Click File → Save.

20 Enter a name for the new policy and click Save.

All custom checks are added to every policy, but they are not enabled. To enable the custom 
check in other polices, see Creating or Editing a Policy on page 128.

Disabling a Custom Check

Follow the steps below to disable a custom check: 

1 Select a custom check.

2 Clear its associated check box.

Deleting a Custom Check

Follow the steps below to delete a custom check:

1 Right-click a custom check.

2 Select Delete from the short-cut menu.

Editing a Custom Check

Follow the steps below to edit a custom check:

1 Open a policy.

2 Select a custom check.

File Extension Replacement File Extension

File Extension Addition File Extension

Directory Enumeration Directory Enumeration

Keyword Search Keyword Search

Table 1 Correlation of Attack Type to Audit Engine  (cont’d)

This Attack Type… Uses this Audit Engine…
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3 Using the right pane of the Policy Editor, modify the custom check properties.

4 Click the Save icon.

Searching for Attack Agents

Use the Search view on the Policy Manager to locate specific vulnerability checks (attack 
agents). You can then elect to include or exclude individual agents. 

Follow the steps below to search for attack agents:

1 Open a policy in the Policy Manager.

2 Click View → Search.

3 From the Criteria list, select the property that you want to search.

The description of every attack agent contains “report fields” such as summary, 
implication, execution, fix, and reference information. The Search feature allows you to 
locate attack agents that contain the text you specify in a selected report field. In addition, 
you can search for a vulnerability ID, vulnerability name, engine type, or the date when 
last updated. 

4 Choose an operator from the drop-down list (is, is greater than, is less than, contains).

5 In the text box, type the text or number you want to find. 

6 Click Search. 

The Policy Manager lists in the Checks area all attack agents that match your search 
criteria. An active agent will have a check mark next to its name. Select (or clear) a check 
box to activate (or deactivate) an agent. 

7 Click Save to save the revised policy. 
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Policy Manager Icons

The following table illustrates and describes icons that are used in the Policy Manager tree 
view.

Table 2 Policy Manager Icons

Icon Definition

 The policy.

 Attack Group Folder: Contains vulnerability assessments.

 Audit Methodology: A set of checks that compose an audit methodology. For 
example, Site Search is part of the Audit methodology. 

 A critical vulnerability wherein an attacker might have the ability to execute 
commands on the server or retrieve and modify private information.

 A high vulnerability. Generally, the ability to view source code, files out of the Web 
root, and sensitive error messages.

 A medium vulnerability. Indicates non-HTML errors or issues that could be 
sensitive.

 A low vulnerability. Indicates interesting issues, or issues that could potentially 
become higher ones.
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Audit Inputs Editor

This tool allows you to create or edit inputs to the audit engines and to a distinct set of checks.

Access the Audit Inputs Editor from the Policy Manager (using the Policy Manager’s Tools 
menu) to create or modify an inputs file (<filename>.inputs). You can then specify this file 
when modifying scan settings. 

To modify an inputs file, click the Open icon on the Audit Inputs Editor’s toolbar or select File 
→ Open.

You must import into the WebInspect Enterprise scan configuration the saved file containing 
your check input modifications. To do so:

1 Create a new scan in the WebInspect Enterprise Web Console. 

2 Under Audit Settings, select Attack Exclusions.

3 Next to Import Audit Inputs (at the bottom of the page), click Browse.

4 Select the file you created and click Open.

Engine Inputs

Follow the steps below to create or modify inputs to audit engines.

1 Click the Engine Inputs tab.

2 Click the drop-down arrow. 

a To apply your modifications to all audit engines, select <Default>. The Default 
parameters are extracted from the scanner’s default Audit Settings - Attack 
Exclusions. 

b To modify inputs for a specific audit engine, select one from the list.

3 Select an engine input.

4 If you selected one of the following:

• Excluded Query Parameters

• Excluded Post Parameters

• Excluded Cookies

• Excluded Headers

• Root Directories

a To add an item to the list, click Add.

b To edit an item, select an item and click Edit.

c To delete an item, select the item and click Remove.

d If you selected a specific engine (rather than Defaults), select one of the following 
options:

— Merge with defaults - The parameters you specified are added to the Defaults list, 
which apply to all engines.
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— Replace defaults - The engine will use the parameters you specified instead of those 
in the Defaults list.

5 If you selected one of the following:

• Header Audit Rules

• Cookie Audit Rules

a Unselect the Use value from defaults check box.

b Select an option from the drop-down list.

6 Click the File menu and select Save or Save As.

Check Inputs

Certain checks require inputs that accommodate the specific design of the target Web site. 
The scanner conducts these checks using default values, which you may need to change.

Follow the steps below to create or modify inputs for specific checks.

1 Click the Check Inputs tab.

2 Select a check (see list below).

3 Enter the requested input values.

4 Click  File → Save (or Save As.

4719: IIS Mapping 

Microsoft IIS extension handlers historically have been the source of many vulnerabilities. 
This check probes for each known IIS extension, and flags a vulnerability for each extension/
handler that is found to be enabled. However, in certain cases, an extension handler may be 
legitimately enabled and used by the target Web site.

Required Input: One or more extensions that identify the handlers that are legitimately 
enabled and which should be excluded. Valid input is printer, idc, idq, ida, htr, htw, stm, shtm, 
and shtml.

4721: Admin Section Must Require Authentication 

Any area of the Web site or Web application that contains sensitive information or access to 
privileged functionality (such as remote site administration) requires authentication before 
allowing access. This check attempts to access a sensitive directory that should require 
authentication. The default check input is /admin.

Required Input: The directory (relative to the root) containing administrative or sensitive 
data.

Note: If you specify a Root Directory, then the engine will attack the object in the 
directory you specify, rather than the actual root. For example, if an engine 
normally attacks filename.txt in the default root directory rootdir (/rootdir/
filename.txt), then if you specify a root directory of /foobar/, the engine will attack /
foobar/filename.txt. 
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4722: Logins Sent Over Unencrypted Connection 

Any area of a Web application that possibly contains sensitive information or access to 
privileged functionality (such as remote site administration functionality) should utilize SSL 
or another form of encryption to prevent login information from being sniffed or otherwise 
intercepted or stolen.

Required Input: Login forms. The name of file containing login form.

4723: Logins Sent Over Query 

Information in query strings is directly visible to the end user via the browser interface, which 
can cause security issues. Recommendations include performing server-side input validation 
to ensure data received from the client matches expectations.

Required Input: Login forms. The name of file containing login form.

4724: Password Field Masked 

Basic Web application security measures include “masking” all passwords entered by a user 
when logging on to a Web application. Normally, each character in a password entered by a 
user is instead represented with an asterisk. Recommendations include requiring all 
password fields in your Web application be masked to prevent other users from seeing this 
information.

Required Input: The name attribute of input controls containing a password.

4726: Secure Section Only Accessible Via SSL 

Any area of the Web site or Web application that contains sensitive information or access to 
privileged functionality (such as remote site administration) requires that the pages under 
the secure section of the site are only accessible via SSL.

Required Input: The name of the secure directory, relative to the root. The default is /secure.

4728: Persistent Cookies 

Persistent cookies are stored on the browser’s hard drive. This can cause security and privacy 
issues depending on the information stored in the cookie and how it is accessed. This check 
calculates how many seconds until a received cookie is set to expire. If the expiration date/
time is less than the specified number of seconds (default: 600), the check considers the 
cookie’s life span to be excessive, increasing the chances of session ID recovery and session 
hijacking.

Required Input: The lifetime allowed for cookies (in seconds).

4729: User supplied data without POST 

An area of the Web application that possibly contains sensitive information or access to 
privileged functionality (such as remote site administration functionality) uses query strings 
to pass information between pages. Information in query strings is directly visible to the end 
user via the browser interface, which can cause security issues. The input value for this check 
is a space-separated list of regular expressions that are used to identify sensitive URL 
parameter names when used in GET queries. Generally, information such as passwords, 
social security numbers, etc., should not be sent as parameters to GET queries, since the GET 
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query (and thus the sensitive information) can persist in Web server and proxy logs and the 
Web browser’s history. You will need to adjust the regular expressions accordingly to specify 
the parameter names your application typically uses to denote sensitive information.

Required Input: Sensitive parameter (a regular expression). An example is:

p|P]ass(word)? [u|U]ser_?([N|n]ame)? [s|S][s|S][n|N]

4731: Script Directory Check 

A directory containing an object referenced in a post request or query string should not have a 
name that could easily be guessed by an attacker. The primary danger from an attacker 
discovering this directory would arise from the information he could gather from its contents, 
such as what language was used to code the Web application. This check is used to determine 
if a dynamic form action points to a file/URL that is in a directory whose name is included in 
the list. 

Required Input: Names of directories containing scripts.

4732: Script File Extension Disclosure 

Any area of the Web site or Web application that contains sensitive information or access to 
privileged functionality (such as remote site administration) requires the file extension of all 
scripts to be checked as it may lead to information disclosure related to the technology used by 
the application. The use of certain CGI-related file extensions can indicate certain types of 
technology in use, which results in a mild information disclosure. The default list of check 
input values is generally applicable, but some sites may legitimately use a certain technology 
(such as Perl) and this check may incorrectly elicit false-positive issues in flagging all Perl 
extensions (.pl). In such cases, you should remove the legitimate extensions from the list.

Required Input: File extensions of scripts used in the Web application (such as cgi, pl, and py).

5151: Arbitrary Remote File Include 

This check attempts to discover if the Web application can fetch and incorporate data from 
arbitrary URLs supplied by an attacker. 

This is the most complex check to configure, because its extreme flexibility enables it to work 
in many environments and topologies. Basically, the check injects URL values into application 
parameters, attempting to force the application to make an HTTP request to the supplied 
URL. This activity looks for “remote file inclusion” vulnerabilities caused by the application 
attempting to remotely retrieve the specified file/URL and include the response into the 
application’s processing. In certain extreme circumstances found in PHP environments, the 
application will remotely retrieve the file and execute any PHP script contained therein, 
making the activity capable of arbitrary code/script execution.

Check 5151 can operate in two modes: static and server (controlled by the “Audit Mode” 
parameter).

Static Mode

You specify the target external URL as the Static Mode Target URL, and a corresponding 
regular expression signature as the Static Mode Signature. If you want to use external targets, 
then you should use static mode. By default, the check uses static mode and the test URL of 
“http://15.216.12.12/serverinclude.html?” which is a special page hosted on an HP Web server 
located on the public Internet at IP address 15.216.12.12. The signature contains a specific 
value that is returned by the indicated test URL. If you do not want to use the HP Web server 
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(particularly if the target server cannot access the Internet), then you should adjust the test 
URL (and corresponding signature) to a URL hosted by a server. When configuring static 
mode:

• Specify a full, absolute URL (i.e., it should begin with “http://”).

• For best results, use non-SSL URLs (although SSL URLs are allowed).

• Include a question mark (?) at the end of your URL to ensure the URL is not affected if the 
application appends additional data to the end of the URL.

Server Mode

In this mode, WebInspect runs its own Web server and attempts to get the target/scanned 
server to connect to the WebInspect scanning system. The added benefit of Server mode is 
that it can detect “blind” remote file inclusion vulnerabilities, resulting in potentially fewer 
false negatives. To use Server mode, the check conceptually needs three pieces of information:

Server Mode Target IP -- The IP address the server/target should use to access the host 
(particularly if the scanning system’s network IP is different than what the server would need 
to access, due to a firewall or a multi-homed scanning system). The default value is empty/
blank, meaning that it uses the same IP address ultimately used or determined by the Server 
Mode Server IP.

• Server Mode Server Port -- The port number to run the listening Web server on. Using a 
specific port may be necessary due to network/access restrictions. The default value is 
8181. If you leave this value blank, then the Remote File Include engine will dynamically 
choose a port between 25000 and 25100.

• Server Mode Server IP -- The local IP address of the scanning system to bind the Web 
server on, if the system is multi-homed and/or you do not want to bind the Web server 
listening on the first local IP address. The default value is “0.0.0.0”, which instructs 
WebInspect to use the first available IP address on the system.

Although the default values fit most configurations, certain circumstances require specific 
modification.

• If your system has multiple IP addresses (due to multiple network adapters), then you 
may need to specify the explicit IP address to bind to (i.e., the one that is most appropriate 
for receiving requests from the system you are scanning). You can determine the list of 
your system’s IP addresses by running “biconvex” from a Windows command prompt.

• If you are running multiple scans from the same scanning system using server mode, then 
you should leave the Server Mode Server Port value blank, causing WebInspect to 
dynamically pick the port. This is because two scans cannot run two separate Web servers 
listening on the same port. One specific port can only be used by one scan at a time.

• If your system is behind a firewall and you are using port-forwarding to receive the 
incoming HTTP requests, or you are on a network that uses NAT, then the IP address 
used by the server to access your system will be different from the IP address actually 
assigned to your system. In this case, you will need to specify the IP address the target 
server should use for the Server Mode Target IP.

Required Inputs: Static mode target URL, Audit mode (static or server), Server mode server 
IP, Server mode Server port, Server mode target IP, static mode signature (a regular 
expression)
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5546: Privacy Policy Not Present 

This check is associated with WebInspect’s compliance policies. Many legislative initiatives 
require organizations to place a publicly accessible document within their Web application 
that defines their information privacy policy. If WebInspect does not find the specified file, it 
creates a vulnerability in the Best Practices category.

Required Inputs: The relative directory and file name of the privacy policy.

10167: Password in Query or Cookie Data 

Transmitting password information in a query string or cookie value makes it easy for an 
attacker to see and tamper with login values. Recommendations include ensuring that login 
information is sent with a POST request over an encrypted connection and that sensitive 
account information is stored on the server.

Required Inputs:

• Password Field Names - List of Query or Cookie parameter names containing a password.

• Possible Username List - List of Query or Cookie parameter names containing a 
username.

10183: Allowed Top-Level Domain 

Certain organizations (especially branches of the U.S. federal government) must use a 
restricted set of DNS top-level domain names (TLDs), such as .gov, .mil, or .fed. This check 
ensures that all allowed hosts encountered during the scan use one of the specified TLDs. 
Most public corporations arbitrarily use any TLD they desire (.com, .net, .org, etc.); those 
corporations should either disable this check (preferable) or change the default values to 
include .com, .net, and .org (and/or any other appropriate TLDs).

Required Inputs: All allowed top-level domains.

10274: Proxy CONNECT Access 

Some proxy servers accept the CONNECT method to make an HTTP connection to another 
server. Usually, this method should be restricted to internal use only. If it is not restricted, 
your server can be used by an attacker on the Internet to disguise himself as your own server. 
Thus, any attack will appear to come from your server. This type of vulnerability is usually 
caused by not properly configuring the proxy server. Attackers can masquerade as your proxy 
server when conducting other attacks. Attackers may be able to access internal machines 
through the CONNECT proxy. This attack can also be used to enumerate your local network.

This check attempts to treat the target server as a proxy server for SSL requests. The check 
issues a CONNECT request to the target server, which essentially asks the server to make a 
connection to another external site. You can control which external site is used via the input 
values for this check. By default, the value “https://www.google.com/” is used, causing the 
server to make an external request to the host www.google.com on port 443. You may wish to 
modify this value to point to a more appropriate internal host. If so: 

Use a server that has SSL enabled on the standard SSL port 443, if possible. Some proxies 
refuse connections to ports other than 443 due to explicit configuration.

Use the https:// URL format.

If you need to specify a port other than 443, use the normal URL format to specify a port after 
the host name (e.g., https://example.com:8443/).
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Only the host name and port number are used; the remainder of the URL is ignored.

10275: Proxy GET Access 

This check is virtually identical to check 10274, except it issues a proxy-qualified GET request 
to the target server instead of a CONNECT request. There are many servers that are willing 
to take a proxy-qualified GET request and treat it as a normal GET request (ignoring the 
proxy-specific aspects of the request), so it is necessary for the check to evaluate the response 
content to ensure the response is truly from the external server and not a normal response 
from the target. That is why check 10275 has two check inputs: one for specifying the external 
target host, and one for specifying a regular expression to match against the response content. 
By default the check attempts to access “http://www.google.com/” and looks for the phrase 
“Google Search” in the response. You will need to adjust the check input values if you need to 
use a different external host or an internal host. You can change the external target simply by 
adjusting the target check input value, and then specifying a unique value from the target 
page as the check input regex value. 

• The URL target must begin with http:// or https://. For best results, use http://.

• If you need to specify a specific port other than 80/443, use the normal URL format to 
specify a port after the host name (such as http://example.com:8080).

• Unlike check 10274, the target URL you specify for 10275 is used in its entirety; if you 
specify a specific page/URL, then that specific page/URL will be requested.

• Try to select a unique value/phrase from the target URL to use as the response regex 
value, one that is not likely to appear elsewhere on the target scanned site; using the 
value in the <title> tags usually is sufficient (you can also include the “<title>” tags in the 
regex value itself).

• Remember to properly escape any regex-specific metacharacters (periods, parentheses, 
etc.).

• The check does not follow redirects (HTTP 302 responses), so you will need to specify an 
explicit final URL destination.

Required Inputs: Proxy GET target and Proxy GET target response (regular expression).

10280: Price-Related Form Fields 

Forms containing price-related field names could harbor price manipulation vulnerabilities 
that would allow the attacker to change the price of the product. 

Required Inputs: Names of price-related fields.

10287: Local File Include 

Several types of attacks involve malformed filename requests that result in reading local files 
from the Web server. The Local File Include engine generates requests that contain variously 
encoded file names, and then evaluates the responses to determine if the contents of those 
files were recovered.

Mode

The Mode parameter relates to the platform assumptions made by the engine. The default 
mode value, Auto, causes the engine to look for both “c:\windows\win.ini” (Windows) and “/
etc/passwd” (Unix) files and to use both Windows and Unix parent directory references 
accordingly. If the engine gets a visual response that explicitly indicates the underlying 
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platform (Windows vs. Unix), it will automatically switch to using only the values for 
appropriate target platform for the remainder of the auditing for that application parameter 
value. If you already know what the underlying platform is before you scan (i.e., Windows vs. 
Unix), you can change the mode to Windows or Unix, which can save scan time since it reduces 
the number of values that need to be sent. At this time the engine does not support platforms 
that do not use a Windows (“\”) or Unix (“/”) path separator.

User-Specified File

If you want to use a specific target file, specify it here. There are occasions when the default 
file name values (“c:\windows\win.ini” and “/etc/passwd”) may not work in your environment. 
For example, your Web application can be hosted on a Windows drive other than ‘C:’, or your 
Web application could be operating out of a Unix chroot environment. In both cases, parent 
directory references will not be able to locate the specified target files even if a vulnerability 
does exist. For this situation you should either use an existing file that is in the root directory 
of the same drive/chroot of the Web application, or explicitly create a text file in the root 
directory of the drive/chroot used by your Web application and place a unique value inside the 
text file. Then you inform the LFI engine to look for your specific file by setting the UserOnly 
mode option, and specifying the absolute path to your target file in the User Specified File 
check input. You will also need to specify a corresponding User Specified File Regex check input 
value; the regex value should uniquely identify/match the contents of your specified file while 
not matching any content typically found on the scanned Web site. You can also select the 
UserAndAuto mode, which would let you specify a file and still use the default 
“c:\windows\win.ini” and “/etc/passwd” values.

User-Specified File Regex

If you use a specific target file, then you need to specify a regular expression that matches the 
contents of the target file.

Audit Disposition

The Audit Disposition parameter default value Adaptive treats Web application parameters in 
one of two ways: parameters with existing values that resemble file names receive significant 
(aggressive) scrutiny, while all other parameters receive basic scrutiny. The premise is that if 
the parameter has a value that resembles a filename, then there is a higher likelihood that 
the value is used in a file system operation; because of that higher likelihood, it makes sense 
for the engine to try more variations (particularly minor variations) to ensure that is not the 
case. However, trying additional minor variations can extend scan time, because it results in 
more attacks to be sent. That is why the Adaptive disposition tries to determine when it seems 
appropriate to spend the extra effort in auditing a particular parameter. However, if you 
desire the utmost level of scrutiny for all parameters, change the Audit Disposition value to 
Aggressive.

Required Inputs: Mode and Audit disposition. 

10551: Possible Username or Password Disclosure

Exposing login information on publicly accessible sections of a Web Application could allow an 
attacker to access sensitive applications and information on a site, or to perform functions 
according to the privilege level of the login information.  Gaining information critical to the 
success of escalated attacks would also be a likely impact of exploitation. Recommendations 
include purging the information from publicly accessible content, if possible, or otherwise 
ensuring proper access controls are in place.

Required Inputs:
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• Password field names - Names of client-side script variables containing a password.

• Possible Username List - Names of client-side script variables containing a username.

10963: Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF) is an attack that forces an end user to execute unwanted 
actions on a Web application in which he/she is currently authenticated. With a little help of 
social engineering (like sending a link via E-mail/chat), an attacker may force the users of a 
Web application to execute actions of the attacker’s choosing. A successful CSRF exploit can 
compromise end user data and operation in case of normal user. If the targeted end user is the 
administrator account, this can compromise the entire Web application. 

Criteria for identifying Cross-Site Request Forgery (CSRF)

• This check is only run against POST requests.

• The page must be either a login page or a page in restricted session (i.e., an authenticated 
session) . Note: To avoid testing every POST request made during authenticated sessions, 
the check is run against a URL one time. This means that forms with multiple parameters 
will be tested one time only and not multiple times like a cross-site scripting or parameter 
injection check.

• The page is not a re-authentication page. This is to avoid cases where a user is asked to 
either change a password or provide a password when already in an authenticated 
session. A re-authentication page is not CSRF vulnerable.

• The page does not contain CAPTCHA. A CAPTACHA page is not vulnerable to CSRF. 

• The page is not an error page or an invalid page from the server.

Check inputs are used as heuristics to help the CSRF agent refine detected results. There are 
a number of criteria used for CSRF detection that help to avoid false positives.

Required Inputs

•  Password field names - This field is used to help identify login pages. The matches are 
string matches.

•  Possible Username List - This field is used to help identify login pages. The matches here 
are string matches.

Optional Inputs

• CSRF Request Black List - This field is used to identify pages that are NOT to be flagged 
as vulnerable to CSRF. Matching values are identified for the name values in POST 
parameters.

• CSRF Response Black List - This field is used to identify error pages or invalid pages. The 
default value here is a combination of two regular expressions and also a string value 
(CAPTCHA). Matching values are identified on the response body.

• CSRF Response White List - This field is used to elevate the risk associated with this 
vulnerability for specific pages. By default, CSRF findings are a Medium severity. A 
match for values in this field will result in the finding being rated as a High severity. 
Matching values are identified in the response body.
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10965: User Data in Query or Cookie

Transmitting password information in a query string or cookie value makes it easy for an 
attacker to see and tamper with login values. Recommendations include ensuring that login 
information is sent with a POST request over an encrypted connection and that sensitive 
account information is stored on the server.

Required Inputs:

• Password Field Names - List of Query or Cookie parameter names containing a password.

• Possible Username List - List of Query or Cookie parameter names containing a 
username.
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Web Form Editor

Most Web applications contain forms composed of input controls (text boxes, buttons, 
drop-down lists, etc.). Users generally “complete” a form by modifying its controls (such as 
entering text or checking boxes) before submitting the form to an agent for processing. 
Usually, this processing will lead the user to another page or section of the application. For 
example, after completing a login form, the user will proceed to the application’s beginning 
page. 

Some sites (such as HP’s example banking application zero.webappsecurity.com) contain 
many different forms for completing a variety of transactions. If the scanner is to navigate 
through all possible links in the application, it must be able to submit appropriate data for 
each form.

With the Web Form Editor, you can create or modify a file containing the names of all input 
controls and the associated values that need to be submitted during a scan of your Web site. 
These entries are categorized by URL, so even if different controls on different pages have the 
same name, the Web Form Editor can discriminate between them. Alternatively, you can 
designate a form entry as “global,” meaning that its value will be submitted for any input 
control having the same name attribute, regardless of the URL at which it occurs.

During a scan, if DevInspect encounters an input control whose name attribute is not 
matched in the file you create, it will submit a default value (12345).

For server authentication (logging in to a server with a user name and password), you can 
enter values here or on the Authentication tab of the Settings window.

There are two ways to create a list of form values:

• Create the list manually.

• Record the values as you navigate through the application.

Manually Creating a Web Form List

Use the following procedure to create a Web Form list manually.

1 Click Tools → WebForm Editor. 

If you are using a proxy server, the WebForm Editor will not use the default settings from 
WebInspect. You must first configure Internet Explorer to use the desired proxy.
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The WebForm Editor window appears.

The WebForm Editor loads a prepackaged default file. 

a To load a different file, select File → Open. 

b To create a new file, select File → New.

2 Do one of the following:

• To add a Web form value, right-click anywhere in the Web Form Editor’s work area 
and select Add Global Form Input from the shortcut (pop-up) menu.

• To modify a Web form value, right-click an entry and select Modify from the shortcut 
(pop-up) menu.

The Add User-Defined Input or the Modify Input window appears.

3 In the Name box, type (or modify) the name attribute of the input element.

4 In the Length box, enter either:

• the value that must be specified by the size attribute, or

• zero, for input elements that do not specify a size attribute.

For example, to submit data for the following HTML fragment…

<INPUT TYPE=“password” NAME=“accessID” MAXLENGTH=“6”>

…you must create an entry consisting of accessID (Name) and specify a size of “6” 
(Length).

5 In the Value box, type the data that should be associated with the input element (for 
example, a password).

6 Use the Match list to specify how the scanner should determine if this entry qualifies to be 
submitted for a particular input control. The options are:

• Exact—The name attribute of the input control must match exactly the name assigned 
to this entry.
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• Starts with—The name attribute of the input control must begin with the name 
assigned to this entry.

• Contains—The name attribute of the input control must contain the name assigned to 
this entry.

7 Programmers sometimes use input controls with type= “hidden” to store information 
between client/server exchanges that would otherwise be lost due to the stateless nature 
of HTTP. Although the Web Form Editor will collect and display the attributes for hidden 
controls, the scanner will not submit values for hidden controls unless you select Allow 
Hidden Submission. 

8 Click Add (or Modify).

9 If necessary, you can assign additional attributes by right-clicking an entry and using the 
shortcut menu.

• To submit the form value for any input control having the same name attribute, 
regardless of the URL at which it occurs, choose Make Global.

• To remove an entry, choose Unselect. This clears the check mark and removes the 
entry from processing, but does not delete it from the file.

• To activate an entry, choose Select. This creates a check mark and includes the entry 
for processing.

• To delete an entry, choose Delete.

• To designate an entry as a smart credential, select either Smart Credential Username or 
Smart Credential Password.

When recording Web form values, you will often encounter a log-on form requiring you 
to enter a user name and password. You can safely use your own user name and 
password, provided that you designate those entries as “Smart Credentials” before 
saving the file. Your actual password and user name are not saved.

When scanning the page containing the input control associated with this entry, the 
scanner will substitute the password specified in the product’s Authentication options. 
This would be a known user name and password that does not require security. 
Alternatively, if no user name or password is specified, the scanner will submit the 
string “FormFillText.”

Recording Web Form Values

The Web Form Editor serves as a proxy that handles HTTP traffic between a browser and a 
target Web site. By default, it uses the local IP address 127.0.0.1 and any available port. 
However, you can specify a different IP address and port by clicking Edit → Settings.

Use the following procedure to capture names and values of input controls on a Web site.

1 To create a list of form values, select File → New (or click the New icon on the toolbar).

2 To add form values to an existing list, select File → Open (or click the Open icon on the 
toolbar) and choose a file using the standard file-selection dialog.

3 Click Launch Browser.

4 Using the browser’s Address bar, enter or select a URL and navigate to a page containing 
a form.
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Note: Internet Explorer version 7 and the .NET Framework are hard-coded not to send 
requests for localhost through any proxies. Therefore, the Web Form Editor will not 
receive such traffic. This is a documented Microsoft defect. To access a site on “localhost” 
when using IE7, place a period or dot after “localhost” (for example, http://localhost.:8080/
test.html). 

5 Complete the form and submit it (usually by clicking a button such as Log In, Submit, Go, 
etc.).

6 Navigate to additional pages and submit forms until you have traversed all the links you 
wish to follow.

7 The Web Form Editor displays a list of name and value attributes for all input controls 
found in all forms on the pages you visited.

For example, the first two entries in the following illustration were derived from the 
following HTML fragment…

<form name="loginForm" action="/servlet/Login" method="POST">

<input type="password" size="16" name="PASSWORD">

<input type="text" size="16" name="USERNAME" value="">

<input type="SUBMIT" value="Submit"></form>

…and the user entered his name and password.

8 If necessary, you can modify items by right-clicking an entry and using the shortcut 
(pop-up) menu. 

• To submit the form value for any input control having the same name attribute, 
regardless of the URL at which it occurs, choose Make Global.

• To edit an entry, select Modify.

• To add an entry, select Add Global Form Input. A Global entry is one not associated with 
a specific URL.
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• To remove an entry, choose Unselect. This removes the entry from processing, but does 
not delete it from the file.

• To delete an entry, choose Delete.

• To designate an entry as a smart credential, select either Smart Credential Username or 
Smart Credential Password.

• To force the scanner to pause and display a window prompting the user to enter a 
value for this entry, select Mark As Interactive Input.

When a scanner encounters an HTTP or JavaScript form, it will pause the scan and 
display a window that allows you to enter values for input controls within the form, 
provided that the scanner’s option to Prompt For Web Form Values is selected. However, 
if the scanner’s option to Only Prompt Tagged Inputs is also selected, the scanner will 
not pause for user input unless a specific input control has been designated Mark As 
Interactive Input (except for passwords, which always cause the scanner to pause for 
input). 

9 Click File → Save (or Save As).

Importing a Web Form File

You can import a file that was designed and created for earlier versions of the scanner and 
convert it to a file that can be used by the current Web Form Editor.

1 Click File → Import.

The Convert Web Form Values window appears.

2 Click the ellipses button next to Select File To Import.

3 Using a standard file-selection window, locate the XML file created by an earlier version 
of the Web Form Editor.

4 Click the ellipses button next to Select Target File.

5 Using a standard file-selection window, specify a file name and location for the converted 
file.

6 Click OK.

Scanning with a Web Form File

When scanning a site, you specify which Web Form file you want to use by selecting Auto-fill 
web forms during crawl and then selecting a file.

1 Click the New Scan action.

2 On the Configure Scan window, click Switch to Advanced.

3 In the Scan Settings group, select Method.

4 Select Auto-fill Web Forms During Crawl.

5 Click Browse.

6 Using the standard file-selection window, select a file containing the Web form values you 
want to use and click Open.
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Web Form Editor Settings

Follow the steps below to modify the Web Form Editor settings:

1 Click Edit → Settings.

2 Select either the General or Proxy category and enter the settings described in the 
following sections.

3 Click OK.

General

Proxy Listener

The Web Form Editor serves as a proxy that handles HTTP traffic between a browser and a 
target Web site. By default, it uses the local IP address 127.0.0.1 and any available port. 
However, you can specify a different IP address and port by selecting Edit → Settings.

To avoid the possibility of specifying a port that is already in use, select Automatically Assign 
Port.

Advanced HTTP Parsing

Most Web pages contain information that tells the browser what character set to use. This is 
accomplished by using the Content-Type response header (or a META tag with an 
HTTP-EQUIV attribute) in the HEAD section of the HTML document. For pages that do not 
announce their character set, you can specify which character set the Web Form Editor should 
use by selecting an entry from the Assumed ‘charset’ Encoding list. 

Proxy

Use these settings to access the Web Form Editor through a proxy server.

Direct Connection (proxy disabled)

Select this option if you are not using a proxy server.

Auto detect proxy settings

If you select this option, the Web Form Editor will use the Web Proxy Autodiscovery Protocol 
(WPAD) to locate a proxy autoconfig file and use this to configure the browser’s Web proxy 
settings.

Use Internet Explorer proxy settings

Select this option to import your proxy server information from Internet Explorer.

Use Firefox proxy settings

Select this option to import your proxy server information from Firefox.

Configure a proxy using a PAC file

Select this option to load proxy settings from a Proxy Automatic Configuration (PAC) file. 
Then specify the file location in the URL box.
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Explicitly configure proxy

Select this option to access the Internet through a proxy server, and then enter the requested 
information

1 In the Server box, type the URL or IP address of your proxy server, followed (in the Port 
box) by the port number (for example, 8080).

2 Select a protocol for handling TCP traffic through a proxy server: SOCKS4, SOCKS5, or 
standard.

3 If authentication is required, select a type from the Authentication list. See Authentication 
on page 110 for a description of the available authentication types.

4 If your proxy server requires authentication, enter the qualifying user name and 
password.

5 If you do not need to use a proxy server to access certain IP addresses (such as internal 
testing sites), enter the addresses or URLs in the Bypass Proxy For box. Use commas to 
separate entries.

HTTPS Proxy Settings

For proxy servers accepting HTTPS connections, select Specify Alternative Proxy for HTTPS and 
provide the requested information.

Web Form Logic

When crawling a Web application and submitting Web form values, the scanner analyzes the 
entries in the Web form values file to determine if a value should be submitted. The logic for 
determining a match is represented in the following table, ordered from “most preferred” to 
“least preferred.”

Table 3 Rules for Matching Web Form Values 

Page-specific 
form values 

Exact Match. 
Name exact match. 
Length exact match. 

The specific Web page, Web form name, and value 
length detected on the crawled Web page exactly 
match a single record in the webformvalues.xml 
selected for the scan. 

Partial Match. 
Name-only match. 
Length allows 
wildcard. 

The specific Web page and Web form name 
detected on the crawled Web page match a single 
record in the webformvalues.xml selected for the 
scan. The field length associated with that form 
value allows for submission to any field input 
length (wildcard field length match). 

Global form 
values 

Exact Match. 
Name exact match. 
Length exact match. 

The Web form name and value length detected on 
the crawled Web page match a single record in 
the Global Web form values section of the 
webformvalues.xml selected for the scan.

Partial Match 1. 
Name exact match. 
Length allows 
wildcard.

The Web form name detected on the crawled Web 
page exactly matches a form name found in the 
global values section of the webformvalues.xml 
selected for the scan. The field length associated 
with that form value allows for submission to any 
field input length (wildcard field length match). 
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Partial Match 2.
Field name starts with 
Name value.
Length exact match. 

A Web form value in the file partially matches the 
field name found. All characters in the Web form 
value match the beginning of the Web page field 
name and the field length detected on the crawled 
Web page match the record in the Global Web 
form values section of the webformvalues.xml 
selected for the scan.

Partial Match 3. 
Field name starts with 
Name value.
Length allows 
wildcard. 

A Web form value in the file partially matches the 
field name found. All characters in the Web form 
value match the beginning of the Web page field 
name and the field length for the record allows 
for submission to any field length (wildcard field 
length match).

Partial Match 4. 
Name value included in 
field name.
Length exact match. 

A Web form value in the file partially matches the 
field name found. All characters in the Web form 
value match a portion of the Web page field name 
and the field length for the record allows for 
submission to any field length (wildcard field 
length match). 

Partial Match 5. 
Name value included in 
field name.
Length allows 
wildcard. 

A Web form value in the file partially matches the 
field name found. All characters in the Web form 
value match a portion of the Web page field name 
and the field length for the record allows for 
submission to any field length (wildcard field 
length match). 

No match Field name has no 
exact or partial 
matches to Web form 
values. 

No Web form value match was found. Submit the 
specified default value (Default).

No default 
value 

The Web form values 
file has no default 
value specified. 

No Web form value match was made and the 
default value is not in the webform values file. 
Submit “not found.” 

Table 3 Rules for Matching Web Form Values  (cont’d)
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Web Brute

This tool will determine if your users are employing user names and passwords that an 
unauthorized intruder might be able to guess easily. For example, if one of your customers is 
accessing your Web site by using a username of “customer” and a password of “password,” you 
might want to warn that user about his susceptibility and suggest that he change his 
password and/or username. 

Web Brute will attempt a “brute force” attack of a login form or authentication page, using 
two prepared lists of user names and passwords. 

Mounting a Brute Force Attack

Follow the steps below to use a brute force authentication attack: 

1 On the WebInspect Enterprise Console menu bar, click Tools → Web Brute. 

2 In the Enter URL box, type the URL of the site you want attack and click Next.

3 Select the authentication type used by the target site. See Authentication on page 110 for 
a description of the available authentication types.

4 If necessary, use the Domain box to specify the domain that should be used for 
authentication. Web Brute will prefix this string to each user name that it submits. Do not 
include a backslash.

5 Click Next.

6 If you selected Web Form in Step 3, a Web browser opens. If necessary, navigate to the 
login page. 

7 On Web Brute’s Form Field Setup panel, select (check) the fields you want to brute force. If 
you already know the value that should be entered for a field, remove the check mark, 
double-click the cell in the Value column for that field, and enter the value.

8 For fields you have selected (checked), click  in the Dictionary column to select a list of 
names or passwords to be submitted.

This is an intrusive attack and can break into a secure area. Brute force attacks are intended 
for testing purposes only, and should not be used against unsuspecting Web sites.
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The Select Data Dictionary window appears, listing all currently defined dictionaries. You 
can limit the display of dictionary names by selecting an entry in the Dictionary Type list.

These dictionaries are in a database that is not directly accessible. To create your own 
dictionary or merge a list into an existing dictionary, see Creating and Importing Lists on 
page 158. 

9 Select a list.

10 (Optional) Enter the following:

• Prefix: A string that will be added to the beginning of each entry in the list.

• Suffix: A string that will be added to the end of each entry in the list.

• Min Char Length: The minimum number of characters allowed for each entry; entries 
that are shorter will not be submitted.

• Max Char Length: The maximum number of characters allowed for each entry; entries 
that are longer will not be submitted.

11 Click OK.

12 Repeat steps 7-11 for each authentication field to be submitted.

13 If you want to “join” two or more lists, click the Join column associated with each list.

If a list of user names is joined with a list of passwords, then Web Brute will submit user 
names with passwords in the order in which they appear in the lists. That is, the first 
name in the user name list will be submitted with the first password in the password list, 
the second name will be submitted with the second password, etc.

If the two lists are not joined, then Web Brute submits each user name with all passwords. 
This feature is used most often for Web form authentication where the user must re-enter 
the password. In this case, Web Brute would use two lists, but the password list would be 
specified for both the “password” and “confirm password” fields. You would then join these 
fields, forcing the same password to be submitted for each field. 

14 To modify the parameters that Web Brute uses during an authentication attack, select 
Edit → Settings. See Web Brute Settings on page 159 for more information.

15 Click Next.
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16 To see a list of failed name/password attempts (in addition to successful attempts), select 
Show Failed.

17 Click Brute.

Web Brute attacks the site and displays the results. If you double-click a result (either 
successful or failed), Web Brute opens the HTTP Editor, allowing you to inspect both the 
HTTP request and response.

Creating and Importing Lists

To use your own list of passwords or user names, you must first create a list and then import 
it into Web Brute as a “dictionary,” using the following procedure:

1 Create a text file where each entry is delimited by a carriage return and line feed.

2 Click File → Import/Export Dictionary.

3 On the Import/Export Dictionary window, select Import.

4 From the Dictionary Type list, select either User Names, Passwords, or E-mails.

5 Click Browse and select the file containing the list you want to import.

6 Click Next.

7 On the Import Dictionary window, specify a name for the dictionary and enter a 
description.

8 Click Next.

9 Click Finish.

Exporting Dictionaries

Use the following procedure to create a text file from a Web Brute dictionary:

1 Click File → Import/Export Dictionary.

2 On the Import/Export Dictionary window, select Export.
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3 In the File Path box, enter the path and name of the text file in which the dictionary 
contents will be saved, or click Browse and use the Save As window to specify the name 
and path. 

4 Click Next. 

5 On the Export Dictionary window, select a dictionary type from the list. 

6 Select a dictionary.

7 Click Next. 

8 Click Finish. 

9 Click Done. 

Web Brute Settings

Follow the steps below to modify the Web Brute settings:

1 Click Edit → Settings.

2 Select either the Options, Authentication, or Proxy tab and enter the settings described in 
the following sections.

3 Click OK.

Options

Timeout in seconds

Enter the number of seconds that Web Brute will wait for a response. If a response is not 
received during this period, Web Brute will resend the request, up to the number of times 
specified in the Retry Count setting.

Retry Count

Enter the number of times that Web Brute will resend a request that has not been 
acknowledged.

Apply State

If you select this option, Web Brute will attempt to maintain state during the procedure.

Apply Proxy

If you select this option, Web Brute will use the settings on the Proxy tab to connect to the 
target site (if the Direct Connection option is not selected).

Logging 

Select the types of messages that should be logged.

Max Concurrent Threads

Enter or select the number of requests that Web Brute may send before requiring a response 
to the first request.
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Advanced HTTP Parsing

Most Web pages contain information that tells the browser what character set to use. This is 
accomplished by using the Content-Type response header (or a META tag with an 
HTTP-EQUIV attribute) in the HEAD section of the HTML document. For pages that do not 
announce their character set, you can specify which character set the Web Brute should use. 

Authentication

4 If required, select an authentication method and provide credentials. The methods are:

• None—Select this option if the site does not require authentication.

• Automatic Authentication—This allows Web Brute to determine the correct authentication 
type.

• HTTP Basic Authentication—This is a widely used, industry-standard method for collecting 
user name and password information. Normally, a Web browser displays a window for a 
user to enter a previously assigned user name and password, also known as credentials. 
The Web browser then attempts to establish a connection to a server using the user’s 
credentials.

• NTLM Authentication—NTLM (NT LanMan) is an authentication process that is used by all 
members of the Windows NT family of products. Like its predecessor LanMan, NTLM 
uses a challenge/response process to prove the client’s identity without requiring that 
either a password or a hashed password be sent across the network.

After selecting an authentication method, enter a user name and password. To avoid 
typographic errors, re-enter the password in the Confirm Password box.

Proxy

Use these settings to access the Web Brute through a proxy server.

Direct Connection (proxy disabled)

Select this option if you are not using a proxy server.

Auto detect proxy settings

If you select this option, Web Brute will use the Web Proxy Autodiscovery Protocol (WPAD) to 
automatically locate a proxy autoconfig file and use this to configure the browser’s Web proxy 
settings.

Use Internet Explorer proxy settings

Select this option to import your proxy server information from Internet Explorer.

Configure a proxy using a PAC file

Select this option to load proxy settings from a Proxy Automatic Configuration (PAC) file. 
Then specify the file location in the URL box.
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Explicitly configure proxy

Select this option to access the Internet through a proxy server, and then enter the requested 
information.

1 In the Server box, type the URL or IP address of your proxy server, followed (in the Port 
box) by the port number (for example, 8080).

2 Select a protocol for handling TCP traffic through a proxy server: SOCKS4, SOCKS5, or 
standard.

3 If authentication is required, select a type from the Authentication list. See Authentication 
on page 110 for a description of the available authentication types.

4 If your proxy server requires authentication, enter the qualifying user name and 
password.

5 If you do not need to use a proxy server to access certain IP addresses (such as internal 
testing sites), enter the addresses or URLs in the Bypass Proxy For box. Use commas to 
separate entries.

Specify Alternative Proxy for HTTPS

For proxy servers accepting HTTPS connections, select Specify Alternative Proxy for HTTPS and 
provide the requested information.
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Web Discovery

Use Web Discovery to find all open hosts in your enterprise environment.

Web Discovery sends packets to all the open ports (in a range of IP addresses and ports that 
you specify), searches the server’s response for specific information, and then displays the 
results. There are two predefined packets included with Web Discovery: Web Server and SSL 
Web Server. They both contain the following HTTP request:

GET / HTTP/1.0

Web Discovery searches the HTTP response for the string “HTTP”; if it finds the string, it 
displays the IP address, port number, and the text “WebServer,” followed by the results of a 
regular expression search designed to reveal the server’s name and version number.

You can save the list of discovered servers in a text file.

Discovering Sites

To discover sites using Web Discovery:

1 In the IP Addresses (or ranges) box, type one or more IP addresses (or a range of IP 
addresses).

• Use a semicolon to separate multiple addresses.
Example: 172.16.10.3;172.16.10.44;188.23.102.5

• Use a dash or hyphen to separate the starting and ending IP addresses in a range.
Example: 10.2.1.70-10.2.1.90.

2 In the Ports (or ranges) box, type the ports you want to scan.

• Use a semicolon to separate multiple ports.
Example: 80;8080;443
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• Use a dash or hyphen to separate the starting and ending ports in a range.
Example: 80-8080.

3 To modify Web Discovery settings, click Settings. See Web Discovery Settings on page 163 
for more information.

4 Click Start to initiate the discovery process.

Results display in the Discovered EndPoints area.

5 Click an entry in the IP Address column to view that site in a browser.

6 Click an entry in the Identification column to open the Settings Properties window and view 
the raw request and response.

To save the list of discovered servers:

1 Click File → Export.

2 Use the standard file-selection window to name and save the file.

Web Discovery Settings

Follow the steps below to modify the Web Discovery settings:

1 Click Edit → Settings.

2 Enter the settings described in the following sections.

3 Click OK.

Select Protocols

Choose the packet type you want to send by selecting or clearing the check box next to the 
protocol name.

Logging

Select the elements you want to log:

• Log Open Ports: Logs all available ports found open on the host; saves only Web server 
information in log file.

• Log Services: Logs all services identified during the discovery.

• Log Web Servers: Logs Web servers identified.

Enter the file location in the Log To box, or click the ellipsis button and use the standard 
file-selection window to specify the file in which the log entries should be recorded.

Connectivity

Set the following timeouts (in milliseconds):

• Connection: The period of time that Web Discovery will wait before stopping a port scan 
when no information has been returned from an IP address.

• Send: When sending a message to the remote IP endpoint, the transmission is divided into 
smaller packets. If the IP endpoint does not acknowledge receipt of a sent packet within 
the specified period of time, the socket is closed and the discovery for that endpoint 
reports no services.
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• Receive: When sending a message to the remote IP endpoint, the transmission is divided 
into smaller packets. If the Web Discovery tool does not receive the sent packet within the 
specified period of time, the socket is closed and the discovery for that endpoint reports no 
services.

Adjust the number of open sockets using the Sockets box. A higher number of open sockets 
results in a faster scan. However, a setting that exceeds a server’s threshold may result in 
false positives

If you are using Windows XP with Service Pack 2 (SP2), your Open Sockets setting is set to 10. 
If you increase this setting, you will increase the likelihood that the scanner will fail to detect 
servers. This occurs because Microsoft has limited the number of open sockets to 10. 
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Encoders/Decoders

This tool allows you to encode and decode values using Base64, hexadecimal, MD5, and other 
schemes. You can also encode a string into a Unicode string and use special characters in URL 
construction. During the analysis of your scan results, when you encounter a string that you 
suspect is in an encoded or encrypted format, you can simply copy the string, paste it into the 
Encoders/Decoders tool, and then click Decode.

Encoding a String

Follow the steps below to encode a string:

1 Type (or paste) a string into the Text area, or load the contents of a file by selecting File → 
Open.

2 Select an encoding character set using either the Character Set Name or the Display Name.

3 Select a cipher type from the Encoding list. For more information, see Encoding Types on 
page 166.

4 If necessary, type a key in the Key box. When a valid key is entered, the Encode and 
Decode buttons become enabled.

5 Click Encode.

The Text area displays the encoded string; the Hex Display area displays the hexadecimal 
value of each character in the encoded string (formatted in the character set that you 
select).

Decoding a String

Follow the steps below to decode a string:

1 Type (or paste) a string in the text area, or load the contents of a file by selecting File → 
Open.

2 Select an encoding character set using either the Character Set Name or the Display Name.

3 Select a cipher type from the Encoding list.
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4 If necessary, type a key in the Key box.

5 Click Decode.

You can also use the encoding and decoding capabilities in the HTTP Editor. Right-click while 
editing a session to access encoding and decoding options.

Manipulating Encoded Strings

The encoded form of a string may contain characters that are non-printable. This often occurs 
when using a hash-based encoding scheme or any encoding scheme that requires a key. Since 
non-printable characters cannot be copied to the Windows clipboard, you cannot simply copy 
from or paste into the Encoder/Decoder. However, there are three methods you can use to 
work around this limitation:

• Save the encoded string to a file and, when you want to decode it, select File → Open to 
load it into the Encoder tool. Then decode it using the original method and (if applicable) 
key.

• Also, after encoding the string using the chosen encoding method and key, you can encode 
the resulting string using the base 64 method; then copy the string to the clipboard, paste 
the clipboard contents, decode using base 64, and decode again using the original method 
and (if applicable) key. 

Encoding Types

The Encoder/Decoder allows you to select the encoding types described below. 

• 3DES is a mode of the DES encryption algorithm that encrypts data three times (the 
string is encrypted, then the encryption is encrypted, and the resulting cipher text is 
encrypted a third time). The key must be 128 or 192 bits (16 or 24 characters).

• Base64 encodes and decodes triplets of 8-bit octets as groups of four characters, each 
representing 6 bits of the source 24 bits. Only characters present in all variants of ASCII 
and EBCDIC are used, avoiding incompatibilities in other forms of encoding.   

• Blowfish is an encryption algorithm that can be used as a replacement for the DES 
algorithm. 

• DES (Data Encryption Standard) is a widely-used method of data encryption that can use 
more than 72 quadrillion different private (and secret) encryption keys. Both the sender 
and the user must use the same private key.

• HEX is hexadecimal. 

• MD5 produces a 128-bit “fingerprint” or “message digest” of whatever data you enter.

• RC2 is a variable key-size block cipher designed by Ronald Rivest. It has a block size of 64 
bits and is about two to three times faster than DES in software.

• RC4 is a stream cipher designed by Ronald Rivest. It is a variable key-size stream cipher 
with byte-oriented operations. Used for file encryption in products such as RSA SecurPC 
and also used for secure communications, as in the encryption of traffic to and from secure 
Web sites using the SSL protocol. 

• ROT13 is a simple Caesar cipher used for obscuring text by replacing each letter with the 
letter thirteen places down the alphabet.
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• SHA1 is Secure Hash Algorithm, a one-way hash function developed by NIST and defined 
in standard FIPS 180. SHA-1 is a revision published in 1994; it is also described in ANSI 
standard X9.30 (part 2).

• SHA256 uses 256-bit encryption.

• SHA384 uses 384-bit encryption.

• SHA512 uses 512-bit encryption.

• ToLower changes upper-case letters to lower-case.

• ToUpper changes lower-case letters to upper-case.

• TwoFish is an encryption algorithm based on an earlier Blowfish.

• Unicode provides a unique number for every character, regardless of the platform, 
program, or language. 

• URL creates values that can be used for URL-encoding non-standard letters and 
characters for display in browsers and plug-ins that support them. 

• XHTML encapsulates the entered data with text tags: <text>data</text>

• XOR performs an Exclusive OR operation. You must provide a key. If the length of the key 
string is only one character, that character is ORed against each character in the encode/
decode string. 

Prefixed

C and languages with a similar syntax (such as C++, C#, Java and JavaScript) prefix 
hexadecimal numerals with “0x” (for example, 0x5A3). The leading zero allows the parser to 
recognize a number, and the “x” stands for hexadecimal.
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Regular Expression Editor

A regular expression is a pattern that describes a set of strings. Regular expressions are 
constructed similarly to mathematical expressions by using various operators to combine 
smaller expressions. Only advanced users with a working knowledge of regular expressions 
should use this feature. 

Testing a Regular Expression

Use the Regular Expression Editor to verify regular expressions. 

Follow the steps below to use the Regular Expression Editor:

1 Click Tools → Regex Editor. 

The Regular Expression Editor window opens.

2 In the Expression box, type or paste a regular expression that you believe will find the text 
for which you are searching.

For assistance, click  to reveal a list of objects. These include metacharacters and 
regular expressions that define a URL and an IP address. Click an object to insert it. 

Note: You can also use special Regular Expression Extensions to restrict your search to 
certain areas of an HTTP message. 
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The Regular Expression Editor examines the syntax of the entered expression and 

displays  (if valid) or  (if invalid).

3 In the Search Text box, type (or paste) the text through which you want to search.

Alternatively, you can load an HTTP request or response message that you previously 
saved using the HTTP Editor. To do so:

a Click File → Open Request. 

The Request file is actually a session containing data for both the HTTP request and 
response.

b Using the standard file-selection window, choose the file containing the saved session.

c Select either Request or Response. 

d Click OK.

4 To find only those occurrences matching the case of the expression, select the Match Case 
check box.

5 If you want to substitute the string identified by the regular expression with a different 
string:

a Select the Replace With check box.

b Type or select a string using the drop-down combo box.

6 Click Test to search the target text for strings that match the regular expression. Matches 
will be highlighted in red.

7 If you selected the Replace option, click Replace to substitute all found strings with the 
replacement string.

Regular Expressions

Special characters and sequences are used in writing patterns for regular expressions. The 
following table describes some of these characters and includes short examples showing how 
the characters are used. 

Table 4 Characters Used in Regular Expressions

Character Description

\ Marks the next character as special. /n/ matches the character “n”. 
The sequence /\n/ matches a linefeed or newline character.

^ Matches the beginning of input or line. Also used with character 
classes as a negation character. For example, to exclude everything in 
the content directory except /content/en and /content/ca, use: 
/content/([^ec].*|e[^n].*|c[^a].*|.{3,})[/][./]*     
Also see \S \D \W.

$ Matches the end of input or line.

* Matches the preceding character zero or more times. /zo*/ matches 
either “z” or “zoo.”

+ Matches the preceding character one or more times. /zo+/ matches 
“zoo” but not “z.” 
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Regular Expression Extensions

Hewlett-Packard engineers have developed and implemented extensions to the normal 
regular expression syntax. When building a regular expression, you can use the following tags 
and operators:

Regular Expression Tags

• [BODY] 

• [STATUSCODE] 

• [STATUSDESCRIPTION]

• [STATUSLINE]

• [HEADERS] 

• [ALL]

• [COOKIES]

• [SETCOOKIES]

? Matches the preceding character zero or one time. /a?ve?/ matches the 
“ve” in “never.”

. Matches any single character except a newline character.

[xyz] A character set. Matches any one of the enclosed characters. /[abc]/ 
matches the “a” in “plain.”

\b Matches a word boundary, such as a space. /ea*r\b/ matches the “er” 
in “never early.” 

\B Matches a nonword boundary. /ea*r\B/ matches the “ear” in “never 
early.”

\d Matches a digit character. Equivalent to [0-9]. 

\D Matches a nondigit character. Equivalent to [^0-9].

\f Matches a form-feed character.

\n Matches a linefeed character.

\r Matches a carriage return character.

\s Matches any white space including space, tab, form-feed, and so on. 
Equivalent to [ \f\n\r\t\v]

\S Matches any nonwhite space character. Equivalent to [^ \f\n\r\t\v] 

\w Matches any word character including underscore. Equivalent to 
[A-Za-z0-9_].

\W Matches any nonword character. Equivalent to [^A-Za-z0-9_]. 

Table 4 Characters Used in Regular Expressions (cont’d)

Character Description
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• [METHOD]

• [REQUESTLINE]

• [VERSION]

• [POSTDATA]

• [URI]

Regular Expression Operators

• AND 

• OR 

• NOT 

• [ ] 

• (  )

Examples

To detect a response in which (a) the status line contains a status code of “200” and (b) the 
phrase “logged out” appears anywhere in the message body, use the following regular 
expression: 

[STATUSCODE]200 AND [BODY]logged\sout 

To detect a response indicating that the requested resource resides temporarily under a 
different URI (redirection) and having a reference to the path “/Login.asp” anywhere in the 
response, use the following:

[STATUSCODE]302 AND [ALL]Login.asp 

To detect a response containing either (a) a status code of “200” and the phrase “logged out” or 
“session expired” anywhere in the body, or (b) a status code of “302” and a reference to the 
path “/Login.asp” anywhere in the response, use the following regular expression:

( [STATUSCODE]200 AND [BODY]logged\sout OR [BODY]session\sexpired ) OR ( 
[STATUSCODE]302 AND [ALL]Login.asp )

Note that you must include a space (ASCII 32) before and after an “open” or “close” 
parenthesis; otherwise, the parenthesis will be erroneously considered as part of the 
regular expression.

To detect a redirection response where “login.aspx” appears anywhere in the redirection 
Location header, use the following regular expression: 

[STATUSCODE]302 AND [HEADERS]Location:\slogin.aspx 

To detect a response containing a specific string (such as “Please Authenticate”) in the 
Reason-Phrase portion of the status line, use the following regular expression:

[STATUSDESCRIPTION]Please\sAuthenticate
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HTTP Editor

Use the HTTP Editor to create or edit requests, send them to a server, and view the response 
either in raw HTML or as rendered in a browser. The HTTP Editor is a manual hacking tool 
that requires a working knowledge of HTML, HTTP, and request methods.

To set proxy and authorization parameters, if necessary, select Edit → Settings.

Request Viewer

The Request Viewer pane contains the HTTP request message, which you can view in three 
different formats using the following tabs:

• Raw—Depicts the line-by-line textual format of the request message.

• Details—Displays the header names and field values in a table format.

• Hex—Displays the hexadecimal and ASCII representation of the message.

• XML—Displays any XML content in the message body (Note: This tab appears only if the 
request contains XML-formatted data).

Response Viewer

The Response Viewer pane contains the HTTP response message, which you can also view in 
three different formats using the following tabs:

• Raw—Depicts the line-by-line textual format of the response message.

• Browser—Displays the response message as rendered in a browser.

• Hex—Displays the hexadecimal and ASCII representation of the response message.
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• XML—Displays any XML content in the message body (Note: This tab appears only if the 
response contains XML-formatted data).

HTTP Editor Menus

File Menu

The File menu contains the following commands:

• New Request—Deletes all information from previous sessions and resets the Location 
URL.

• Open Request—Allows you to load a file containing an HTTP request saved during a 
previous session.

• Save Request—Allows you to save an HTTP request.

• Save Request As—Allows you to save an HTTP request.

• URL Synchronization—When selected, any characters you type into the Address combo box 
are added to the Request-URI of the HTTP request line.

• Send As Is—If you select this option, the HTTP Editor will not modify the request, 
regardless of any other settings you may select. This allows you to send a purposely 
malformed message. Authentication and proxy settings are disabled when using this 
option.

Note: You may manually edit the request to go through a proxy, but most standard HTTP 
proxy servers cannot process non-compliant HTTP requests.

• Exit—Closes the HTTP Editor.

Edit Menu

The Edit menu contains the following commands:

• Cut—Deletes selected text and saves it to the clipboard.

• Copy—Saves the selected text to the clipboard.

• Paste—Inserts text from the clipboard

• Find—Displays a window that allows you to search for text that you specify.

• Settings—Allows you to configure request, authentication, and proxy parameters for the 
HTTP Editor.

View Menu

The View menu contains the following commands:

• Show History—Displays a pane listing all HTTP requests sent.

• Word Wrap—Causes all text to fit within the defined margins.

Help Menu

The Help menu contains the following commands:

• HTTP Editor Help—Opens the Help file with the Contents tab active.
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• Index—Opens the Help file with the Index tab active.

• Search—Opens the Help file with the Search tab active.

• About HTTP Editor—Displays information about the HTTP Editor.

Request Actions

The following options are available from the Request Action list in the Request Viewer pane.

PUT File Upload

The PUT method requests that the enclosed entity be stored under the supplied Request-URI.

To write a file to a server:

1 Select PUT File Upload from the drop-down list on the Request Viewer pane.

2 In the text box that appears to the right of the list, type the full path to a file
- or -
Click the Open Folder icon and select the file you want to upload.

3 Click Apply. This will also recalculate the content length.

Change Content-Length

In normal mode, if you edit the message body of the request, the HTTP Editor recalculates the 
content length and substitutes the appropriate value in the Content-length header. However, 
when using the Send As Is option, the HTTP Editor does not modify the content length. You 
can force this recalculation before sending the request by selecting Change Content-Length and 
clicking Apply.

URL Encode/Decode Param Values

The specification for URLs (RFC 1738, Dec. ’94) limits the use of characters in URLs to a 
subset of the US-ASCII character set. HTML, on the other hand, allows the entire range of 
the ISO-8859-1 (ISO-Latin) character set to be used in documents, and HTML4 expands the 
allowable range to include the complete Unicode character set as well. To circumvent this 
limitation, you can encode non-standard letters and characters for display in browsers and 
plug-ins that support them.

URL encoding of a character consists of a “%” symbol, followed by the two-digit hexadecimal 
representation of the ISO-Latin code point for the character. For example:

• The asterisk symbol ( * ) = 42 decimal in the ISO-Latin set

• 42 decimal = 2A hexadecimal

• URL code for asterisk = %2A

You can use URL encoding to bypass an intruder detection system (IDS) that inspects request 
messages for certain keywords using only the ISO-Latin character set. For example, the IDS 
may search for “login” (in ISO-Latin), but not “%4C%4F%47%49%4E” (the URL-encoded 
equivalent).

To substitute URL code for parameters throughout the entire message, select URL Encode 
Param Values and click Apply.

To translate URL-encoded parameters to ISO-Latin, select URL Decode Param Values and click 
Apply.
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Unicode Encode/Decode Request

The Unicode Worldwide Character Standard includes letters, digits, diacritics, punctuation 
marks, and technical symbols for all the world’s principal written languages, using a uniform 
encoding scheme. Incorporating Unicode into client-server applications and Web sites offers 
significant cost savings over the use of legacy character sets. Unicode enables a single 
software product or a single Web site to be targeted across multiple platforms, languages and 
countries without re-engineering. It allows data to be transported through many different 
systems without corruption.

To translate the entire request message into Unicode, select Unicode Encode Request and click 
Apply.

To translate the entire request message from Unicode into ISO-Latin, select Unicode Decode 
Request and click Apply.

Create MultiPart Post

The POST method is used to request that the origin server accept the entity enclosed in the 
request as a new subordinate of the resource identified by the Request-URI in the 
Request-Line. You can attempt to upload data by manipulating a POST request message.

To insert data from a file:

1 Select Create MultiPart Post from the Action list on the Request pane.

2 In the text box to the right of the Action list, type the full path to a file
- or -
Click the Open Folder icon and select the file you want to insert.

3 Click Apply.

Remove MultiPart Post

To remove a file that is part of a multipart request, select Remove MultiPart Post from the 
Action list on the Request pane. 

Response Actions

The area immediately below the tabs on the Response Viewer pane contains three controls:

• a Chunked button 

• a Content Coding drop-down list 

• a button that launches the Find In Response dialog, allowing you to search the response 
for the text string you specify.

Chunked

If a server starts sending a response before knowing its total length, it might break the 
complete response into smaller chunks and send them in series. Such a response contains the 
“Transfer-Encoding: chunked” header. A chunked message body contains a series of chunks, 
followed by a line with “0” (zero), followed by optional footers and a blank line. Each chunk 
consists of two parts:

• A line with the size of the chunk data, in hex, possibly followed by a semicolon and extra 
parameters you can ignore (none are currently standard), and ending with CRLF.
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• The data itself, followed by CRLF.

Content Codings

If the HTTP response contains compressed data, you can decompress the data using one of the 
options from the list.

• GZIP—A compression utility written for the GNU project.

• Deflate—The “zlib” format defined in RFC 1950 [31] in combination with the “deflate” 
compression mechanism described in RFC 1951 [29].

Editing and Sending Requests

Follow the steps below to edit and send a request. 

1 Modify the request message in the Request Viewer pane.

To change certain features of the request, select an item from the Action list and click 
Apply. 

2 Click Send to send the HTTP request message.

The Response Viewer pane displays the HTTP response message when it is received.

3 To view the response as rendered in a browser, click the Browser tab.

4 You can prepare your next HTTP request using the HTML or JavaScript controls 
rendered on the Browser tab. To use this feature, you must select the Interactive Navigation 
option (click Edit → Settings). 

5 To save a request, select File → Save Requests.

Searching for Text 

Follow the steps below to search for text in the request or response

1 Click  in either the Request Viewer or Response Viewer pane.

2 Using either the Find in Request or Find in Response window, type or select a string or 
regular expression.

3 If using a regular expression as the search string, select the Regex check box.

4 Click Find.

HTTP Editor Settings

Follow the steps below to modify the HTTP Editor settings:

1 Click Edit → Settings.

2 Select either the Options, Authentication, or Proxy category and enter the settings described 
in the following sections.

3 Click OK.
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Options

Send As Is

If you select this option, the HTTP Editor will not modify the request, regardless of any other 
settings you may select. This allows you to send a purposely malformed message. 
Authentication and proxy settings are disabled when using this option.

Note: You may manually edit the request to go through a proxy, but most standard HTTP 
proxy servers cannot process non-compliant HTTP requests.

Manipulate Request

If you select this option, the HTTP Editor will modify requests to accommodate the following 
parameters:

• Apply State — If your application uses cookies, URL rewriting, or post data techniques to 
maintain state within a session, the HTTP Editor will attempt to identify the method and 
modify the response accordingly.

• Apply Proxy — If you select this option, the HTTP Editor will modify the request according 
to the proxy settings you specify.

• Apply Filter — This option appears only when you invoke the HTTP Editor while using 
WebInspect and a scan tab has focus (that is, after opening or while conducting a scan). If 
you select this option, the HTTP Editor applies the Filters settings from WebInspect’s 
Default Scan Settings to add search-and-replace rules for HTTP requests and responses. 
Note that if you change WebInspect’s Current or Default Scan Settings, the changes will 
not be applied.

• Apply Header — This option appears only when you invoke the HTTP Editor while using 
WebInspect and a scan tab has focus (that is, after opening or while conducting a scan). If 
you select this option, the HTTP Editor applies the Cookies/Headers settings from 
WebInspect’s Default Scan Settings for HTTP requests. Note that if you change 
WebInspect’s Current or Default Scan Settings, the changes will not be applied.

Enable Active Content

Select this option to allow execution of JavaScript and other dynamic content in all browser 
windows.

Navigation

In the Navigation group, select either None, Interactive, or Browser Mode.

You can view the server’s response as rendered in a browser by selecting the Browser tab in 
the Response Viewer (the lower pane). If the Interactive feature is enabled, you can prepare 
your next HTTP request using the HTML or JavaScript controls rendered in the browser.
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For example, using the logon page at nubankbasic.qa.spidynamics.com (shown below), you 
could enter a user name (“admin”) and password (“admin”), and then click Go. 

The HTTP Editor formats the request (which uses the POST method to the login1.asp 
resource) and displays it in the Request Viewer, as illustrated below. You could then edit the 
logon message (if required) or simply send it to the server by clicking Send.

If you select the Browser Mode option, then Interactive mode is enabled, but the HTTP Editor 
will send the request immediately, without first placing it in the Request Viewer and allowing 
you to edit it.

Advanced HTTP Parsing

Most Web pages contain information that tells the browser what character set to use. This is 
accomplished by using the Content-Type response header (or a META tag with an 
HTTP-EQUIV attribute) in the HEAD section of the HTML document. For pages that do not 
announce their character set, you can specify which character set the HTTP Editor should 
use. 
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Authentication

If authentication is required, select a type from the Authentication list. See Authentication on 
page 110 for a description of the available authentication types.

After selecting an authentication method, enter a user name and password. To avoid 
typographic errors, re-enter the password in the Confirm Password box.

Proxy

Use these settings to access the HTTP Editor through a proxy server.

Direct Connection (proxy disabled)

Select this option if you are not using a proxy server.

Auto detect proxy settings

If you select this option, the HTTP Editor will use the Web Proxy Autodiscovery Protocol 
(WPAD) to locate a proxy autoconfig file and use this to configure the browser’s Web proxy 
settings.

Use Internet Explorer proxy settings

Select this option to import your proxy server information from Internet Explorer.

Use Firefox proxy settings

Select this option to import your proxy server information from Firefox.

Configure a proxy using a PAC file

Select this option to load proxy settings from a Proxy Automatic Configuration (PAC) file. 
Then specify the file location in the URL box.

Explicitly configure proxy

Select this option to access the Internet through a proxy server, and then enter the requested 
information

1 In the Server box, type the URL or IP address of your proxy server, followed (in the Port 
box) by the port number (for example, 8080).

2 Select a protocol for handling TCP traffic through a proxy server: SOCKS4, SOCKS5, or 
standard.

3 If authentication is required, select a type from the Authentication list. See Authentication 
on page 110 for a description of the available authentication types.

4 If your proxy server requires authentication, enter the qualifying user name and 
password.

5 If you do not need to use a proxy server to access certain IP addresses (such as internal 
testing sites), enter the addresses or URLs in the Bypass Proxy For box. Use commas to 
separate entries.
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HTTPS Proxy Settings

For proxy servers accepting HTTPS connections, select Specify Alternative Proxy for HTTPS and 
provide the requested information.
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Web Proxy

Web Proxy is a stand-alone, self-contained proxy server that you can configure and run on 
your desktop. With it, you can monitor traffic from the scanner, a browser, or any other tool 
that submits HTTP requests and receives responses from a server. It is a tool for debugging 
and penetration assessment; you can see every request and server response while browsing a 
site. 

You can also create a Startup macro or a Login macro that you can use with WebInspect or 
WebInspect Enterprise.

Before using Web Proxy with your browser, you must configure your browser’s proxy settings. 
If using Internet Explorer:

1 Click Tools → Internet Options. 

2 Click the Connections tab. 

3 Click LAN Settings.

4 On the LAN Settings window, select Use a Proxy Server for your LAN and enter the address 
and port of the proxy server you want to use. By default, Web Proxy uses your local host 
settings (127.0.0.1:8080).

You should also configure Microsoft Internet Explorer to use HTTP 1.1 through proxy 
connections. On Internet Explorer:

1 Click Tools → Internet Options. 

2 Click the Advanced tab.

3 In the “HTTP1.1 settings” section, select Use HTTP 1.1 through proxy connections. 

Using Web Proxy

Follow the steps below to use Web Proxy with a browser:

1 Click Tools → Web Proxy. 

The Web Proxy window opens.

2 Click  or select Proxy → Start. 

“Listening on <server:port number>” displays in the Web Proxy status bar.

3 Click Launch Browser . 

4 Manually navigate the site for which you want to view requests/responses. 

5 If Web Proxy receives a request for a certificate from a Web Server, it displays a dialog 
asking you to locate the certificate. The program then caches your selection on a “per 
server” basis. Therefore, if you subsequently want to use a different certificate for a 
particular server, you must clear the cache by stopping and then restarting Web Proxy. 

Note: Internet Explorer version 7 and the .NET Framework are hard-coded not to send 
requests for localhost through any proxies. Therefore, Web Proxy will not receive such 
traffic. This is a documented Microsoft defect. To access a site on “localhost” when using 
IE7, place a period or dot after “localhost” (for example, http://localhost.:8080/test.html). 
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6 When you have browsed to all necessary pages, return to Web Proxy and click  (or click 
Proxy → Stop.

7 Each session (a request and matching response) you recorded is listed in the top pane. To 
view the actual HTTP message, select an entry. The message appears in the bottom frame. 
By default, the View tab is selected.

8 To change the format in which the message is displayed, select one of the tabs (View, Split, 
Info, or Browser).

When using the View or Split tabs, you can enable or disable URL decoding of requests and 
responses by selecting the URL Decode button. Since most WebInspect attack traffic is 
URL encoded, this feature makes it easier to analyze HTTP messages. To illustrate, 
compare the following URL encoded and decoded versions of the same GET request:

• GET /
notes.asp?noteid=1%20union%20%20select%200%2c1%2c2%20from%20information_
schema.tables%20order%20by%204%20desc%20limit%201 HTTP/1.1 

• GET /notes.asp?noteid=1 union select 0,1,2 from information_schema.tables order by 
4 desc limit 1 HTTP/1.1 

The Chunked and Compressed buttons are enabled if a response is either chunked-encoded 
or compressed. This allows you to view the original response received by Web Proxy as 
well as the de-chunked or decompressed response.

9 To resend a request (with or without editing), select it from the list of displayed sessions 
and click the HTTP Editor icon (or right-click the request and select HTTP Editor from 
the context menu). 

10 To clear sessions from the list, select one or more sessions and press the Delete key (or 

click Edit → Clear Selected). To clear all sessions, click  (or click Edit → Clear All).
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Note: When you clear a session from the Web Proxy list, you also remove it from the 
captured data. For example, if you have 100 sessions in the list and clear 98 of them, and 
then save the sessions to a file, only the two remaining sessions will be included. When 
clearing sessions, ignore the check boxes.

Use the File menu to save selected requests to a proxy session file (.psf) and later load them for 
analysis (using the File → Open command). You can also save a sequence of requests as a Web 
Macro that you can use when conducting a WebInspect scan. All File menu commands apply to 
“check-marked” requests.

Use the File menu to save selected requests to an xml file and later load them for analysis. You 
can also save a sequence of requests as a Web Macro that you can use when conducting a scan. 
All File menu commands apply to “check-marked” requests.

Click the top of any column to sort the requests by that selection. For example, to sort the 
requests by the time they were made, click the top border of the Time column.

Creating a Web Macro

You can use either the Web Macro Recorder or Web Proxy to create a Start macro or a Login 
macro.

A Start macro is used most often to focus on a particular subsection of an application. It 
specifies URLs that an HP scanner will use to navigate to the area. It may also include login 
information, but does not contain logic that will prevent the scanner from logging out of your 
application.

A Login macro is used for Web form authentication, allowing the scanner (or the WebInspect 
Enterprise sensor) to log in to an application. You can also incorporate logic that will prevent 
the scanner from inadvertently logging out of your application.

Follow the steps below to create a macro using sessions captured by Web Proxy:

1 Select the sessions you want to include in the macro by placing a check mark in the left 
column.

2 Click File → Create Web Macro.

3 (Optional) On the Create Web Macro dialog, select Enable Check For Logout and then enter 
a regular expression that identifies a unique text or phrase that occurs in the server’s 
HTTP response when a user logs out or when a user who is not logged in requests access 
to a protected URL. 

Background: During a normal scan, the scanner begins crawling your site at the home 
page. If it encounters a link to another resource (usually through an <A HREF> HTML 
tag), it will navigate to that URL and continue its assessment. If it follows a link to a 
logout page (or if the server automatically “logs out” a client after a certain number of 
minutes), the scanner will not be able to visit additional resources where the client is 
required to be logged in. When this inadvertent log-out occurs, the scanner must be able to 
log in again without user intervention. This process hinges on the scanner’s ability to 
recognize when it is no longer logged in.

In some applications, if the user logs out (by clicking a button or some other control), the 
server responds with a unique message, such as “Have a nice day.” If you specify this 
phrase as the server’s logout condition, the scanner searches every response message for 
this phrase. Whenever it detects the phrase, the scanner attempts to log in again by 
sending an HTTP request containing the username and password.

You must stop Web Proxy when you want to change Web Proxy settings.
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The scanner can also detect that it has logged out if the server sends a specific message in 
response to the scanner’s attempt to access a password-protected URL. For example, the 
server may respond with a status code of “302 Object moved.” If the scanner knows 
specifically what to look for in this response, the program will recognize that it has been 
logged out and can re-establish a logged-in state.

Using the background example (above), if your server returns a message such as “Have a 
nice day” when a user logs out of your application, then enter “Have\sa\snice\sday” as 
the regular expression (“\s” is used in regular expressions to designate a space). A more 
likely example is where the server returns a 302 status code and references a new URL. 
In this case, “[STATUSCODE]302 AND [ALL]http://login.myco.com/config/mail?” might 
be a typical regex phrase. 

4 Enter a name in the Save macro as box.

5 Click OK.

Web Proxy Tabs

Each HTTP session (a single request and the associated response) is listed in the top pane of 
Web Proxy. When you select a session, Web Proxy displays information about the session in 
the lower pane. The information displayed depends on which tab you select.

Table 5 Web Proxy Tabs

Tab Description

View Use the View tab to select which HTTP messages you want to inspect. 
Options available from the drop-down list immediately below the tab are: 
Session: view the complete session (both request and response)
Request from browser to Web Proxy: view only the request made by the browser 
to Web Proxy 
Request to server from Web Proxy: view only the Web Proxy request to the server
Response from server to Web Proxy: view only the server response to Web Proxy 
Response to browser from Web Proxy: view only the Web Proxy response to the 
browser

Split Click the Split tab to create two information areas for a single session. For 
example, you could show the HTTP request message created by the browser (in 
one area) and the HTTP response generated by the server (in the second area).
You can cut, paste, and copy the raw request, and right-click to see a shortcut 
menu of encoding options. However, you cannot save an edited request from the 
Web Proxy tool. Use the HTTP Editor to save an edited request.

Info Use the Info tab to view detailed information about the requests. Information 
includes the number of forms found, header information, and the properties of 
the page.

Browser Click the Browser tab to view the response as formatted in a browser.
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Web Proxy Settings

To access this feature, click Edit → Settings.

Task 1: Configure General Settings

1 Select the General tab.

2 In the Proxy Listener Configuration group, enter an IP address and port number. By default, 
Web Proxy uses address 127.0.0.1 and port 8080, but you can change this if necessary.

Both Web Proxy and your Web browser must use the same IP address and port. If using 
Internet Explorer, click Tools → Internet Options; click the Connections tab and click LAN 
Settings; on the LAN Settings window, select Use a Proxy Server for your LAN and enter the 
address and port of the proxy server you want to use. 

To configure Web Proxy on your host to be used by another host, you will need to change 
the value of the Local IP Address. The default address of 127.0.0.1 is not available to 
outside hosts. If you change this value to your workstation’s current IP address, remote 
stations can use your workstation as a proxy.

3 Use the Do Not Record option to create a regular expression filter that prevents files of 
specific types from being handled by Web Proxy. The most common types are already 
excluded as defaults, but other types (MPEG, PDF, etc.) can also be excluded. The purpose 
is to allow you to focus on HTTP request/response lines and headers by removing clutter 
from the message. 

4 When using the interactive mode, you can force Web Proxy to pause when it:

• Receives a request from the client.

• Receives a response from the server.

• Finds text that satisfies the search rules you create (using the Flag tab).

If you select any of these options, Web Proxy will continue only when you click the Allow 
button.

5 In the Logging group, select the type of items you want to record in the log file and specify 
the directory in which the log file should be maintained. If you elect to record requests 
and/or responses, you can also choose to convert and log the data using Base 64 encoding. 
This can be useful when responses contain binary data (such as images or Flash files) that 
you want to examine.

• Raw Request refers to the HTTP message sent from the client to Web Proxy.

• Modified Request refers to the HTTP message sent from Web Proxy to the server.

• Raw Response refers to the HTTP message sent from the server to Web Proxy.

• Modified Response refers to the HTTP message sent from Web Proxy to the client.

6 Most Web pages contain information that tells the browser what language encoding to 
use. This is accomplished by using a META tag with an HTTP-EQUIV attribute in the 
HEAD section of the HTML document, as in the following example:

<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">

For pages that do not announce their character set, choose an option from the Assumed 
‘charset’ Encoding list to select the language (and implied character set) that Web Proxy 
should use. 

You cannot change settings while Web Proxy is running. Click Proxy → Stop, change settings, 
and then restart Web Proxy.
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Task 2: Configure Proxy Servers Settings

1 Click the Proxy Servers tab.

Use this area to add one or more proxy servers through which Web Proxy will route all its 
requests. Distributing the attack across multiple servers makes detection and 
counter-measures more difficult, thus mimicking how a hacker might attempt to avoid an 
intrusion detection system. 

If you use multiple proxy servers, Web Proxy will “round-robin” the requests (i.e., Web 
Proxy will sequence through the list of proxy servers, sending the first request to the first 
server, the second request to the second server, and so on).

2 In the Proxy Address box, type the IP address of the server through which you want to 
route Web Proxy requests.

3 Specify the port number in the Proxy Port box.

4 Select the type of proxy (standard, SOCKS4, or SOCKS5) from the Proxy Type list. 

5 If this proxy server requires authentication, select an authentication type and enter your 
authentication credentials in the Username and Password boxes. See Authentication on 
page 110 for a description of the available authentication types.

6 Click Add to add the server and display its IP address in the Available Proxy Servers list.

You can also import a file containing a list of proxy servers by clicking Import. The file 
containing proxy information must be formatted as follows:

• Each line contains one record followed by a line feed and carriage return.

• Each field in the record is separated by a semicolon.

• The fields appear in the following order: address;port;proxytype;user name;password.

• The user name and the password are optional. However, if authorization is not used, 
you must include two semicolons as placeholders.

Examples:

128.121.4.5;8080;Standard;magician;abracadabra

127.153.0.3;80;socks4;;

128.121.6.9;443;socks5;myname;mypassword

7 If you do not need to use a proxy server to access certain URLs (such as internal testing 
sites), you can specify one or more hosts in the Bypass Proxy List area. 

a Click Add in the Bypass Proxy List group.

The Bypass Proxy window appears.

b Enter the host portion of the HTTP URL that should be bypassed.

Do not include the protocol (such as http://). 

For example, to bypass a proxy server for this URL

   http://zero.webappsecurity.com/Page.html

enter this string

   zero.webappsecurity.com 

or this string

   zero.* 
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You can also enter an IP address. Note that Web Proxy will not resolve host names to 
IP addresses. That is, if you specify an IP address and the HTTP request actually 
contains that numeric IP address, then Web Proxy will bypass a proxy server for that 
host. However, if the HTTP request contains a host name that resolves to the IP 
address that you specify, Web Proxy will still send the request to a proxy server.

c Click OK.

Task 3: Configure Search-and-Replace Settings

1 Click the Search and Replace tab.

Use this tab to create rules for locating and replacing text or values in HTTP messages. 
This feature provides a highly flexible tool for automating your simulated attacks. Some 
suggested uses include:

• Masking sensitive data, such as user names and passwords

• Appending a cookie to each request

• Modifying the Accept request-header field to add or delete media types that are 
acceptable for the response

• Replacing a variable in the Request-URI with a cross-site scripting attack

2 Click Add to create a default entry in the table.

3 Click the Search Field column of the entry. 

4 Click the drop-down arrow and select the message area you want to search.

5 In the Search For column, type the data (or a regular expression representing the data) 
you want to find.

6 In the Replace With column, type the data you want to substitute for the found data.

7 Repeat this procedure to create additional search rules.

The request/response rules are applied sequentially, in the order in which they appear. 
For example, if a rule changes HTTPS to SSL, and if a subsequent rule then changes SSL 
to SECURE, the result will be that HTTPS is changed to SECURE.

Task 4: Configure Flag Settings

1 Click the Flag tab.

This feature allows you to find and highlight keywords in requests or responses. 

2 Click Add to create a default entry in the table.

3 Click the Search Field column of the entry. 

4 Click the drop-down arrow and select the message area you want to search.

5 In the Search column, type the data (or a regular expression representing the data) you 
want to find.

6 Click the Flag column of the entry.

7 Click the drop-down arrow and select a color with which to highlight the data, if found.
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Task 5: Configure Evasion Settings

Evasions are techniques that Web Proxy uses to circumvent intrusion detection systems, 
monitors, sniffers, firewalls, log parsers, or any device that attempts to shield systems from 
attack by filtering HTTP requests. Typically, these filters examine portions of the request, 
searching for “signatures” that indicate malicious threats or potential breeches of system 
security. If they detect these signatures, they reject the request.

To evade detection, Web Proxy modifies the HTTP request to obscure the signature for which 
the filter is searching, while retaining integrity sufficient for the message to be processed by 
the server. Of course, the techniques used by Web Proxy are not always successful. As 
developers become aware of methods that compromise their product’s effectiveness, they 
incorporate procedures to combat them.

Use the following procedure to enable evasions:

1 Select the Evasions tab.

2 Select Enable Evasions. 

Choose one or more evasion techniques, as described below.

Method Matching 

Web Proxy replaces the GET method with HEAD. This is an attempt to defeat a filter that 
searches for a signature that begins with GET.

For example, the browser sends the following message to Web Proxy:

GET http://www.microsoft.com/ HTTP/1.1

Web Proxy sends the following message to the server:

HEAD http://www.microsoft.com/ HTTP/1.1

URL Encoding 

Web Proxy converts characters in the URL to a “%” followed by two hexadecimal digits 
corresponding to the character values in the ISO-8859-1 character set.

For example, the browser sends the following message to Web Proxy:

GET http://zero.webappsecurity.com/cgi-bin/filename.cgi HTTP/1.1

Web Proxy sends the following message to the server:

GET %2f%63%67%69%2d%62%69%6e%2f%66%69%6c%65%
6e%61%6d%65%2e%63%67%69 HTTP/1.1

Host: zero.webappsecurity.com

If the device is looking for “cgi-bin” as the signature, it does not match the string 
“%63%67%69%2d%62%69%6e” and so the request is not rejected.

Double Slashes 

Web proxy converts each forward slash (/) into a double forward slash (//).

For example, the browser sends the following message to Web Proxy:

GET http://www.microsoft.com/en/us/secrets.aspx HTTP/1.1

This feature is intended for use as a penetration testing tool. Do not use it or enable it when 
conducting vulnerability assessment scans.
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Web Proxy sends the following message to the server:

GET //en//us//secrets.aspx HTTP/1.1

Host: www.microsoft.com

If the device is looking for “/secrets.aspx” as the signature, it does not match the string “//
secrets.aspx” and so the request is not rejected.

Reverse Traversal 

This technique attempts to disguise a request for a certain resource by interjecting references 
to relative directories, which equates to the original request.

For example, the browser sends the following message to Web Proxy:

GET http://www.TargetSite.com/cgi-bin/some.cgi HTTP/1.1

Web Proxy sends the following message to the server:

GET /d/../cgi-bin/d/../some.cgi HTTP/1.1 [which equates to GET/cgi-bin/some.cgi]

Host: www.TargetSite.com

Self-Reference Directories 

Web Proxy uses the notation for parent directory (../) and current directory (./) to obfuscate the 
request.

For example, the browser sends the following message to Web Proxy:

GET http://www.TargetSite.com/cgi-bin/phf HTTP/1.1

Web Proxy sends the following message to the server:

GET /./cgi-bin/./phf HTTP/1.1  [which equates to GET /cgi-bin/phf]

Host: www.TargetSite.com

Parameter Hiding 

A request can contain parameters that are used to build dynamic page content. These 
parameters are typically used when search requests or selections are made and take this 
form:

/anypage.php?attack=paramhiding&evasion=blackhat&success...

This technique is effective against a device that does not examine that portion of the request 
following the question mark (?). However, the parameter indicator can be used to potentially 
mask further relevant data. 

For example, the browser sends the following message to Web Proxy:

GET /index.htm%3fparam=/../cgi -bin/test.cgi

Web Proxy sends the following message to the server:

GET /index.htm?param=/../cgi -bin/test.cgi

HTTP Misformatting 

An HTTP request has a clearly defined structure:

Method<space>URI<space>HTTP/Version<CRLF><CRLF>
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However, some Web servers will accept a request that contains a tab character instead of a 
space, as in the following: 

Method<tab>URI<tab>HTTP/Version<CRLF><CRLF>

Any filter that incorporates the space (between the three components) as part of the signature 
for which it searches will fail to reject the request.

Long URLs 

This technique is directed toward devices that do not examine the entire request string, but 
concentrate only on a subset of a programmable length (such as the first 50 characters). Web 
Proxy inserts a large number of random characters at the beginning of the request so that the 
operative portion of the request is pushed beyond the area normally examined by the filter.

For example, the browser sends the following message to Web Proxy:

GET http://zero.webappsecurity.com/ HTTP/1.1

Web Proxy sends the following message to the server:

GET /YPVIFAHD[hundreds of characters]NIWCJBXZPXMP/../ HTTP/1.1

Host: zero.webappsecurity.com

DOS/Win Directory Syntax 

A Windows-based filter that attempts to detect a specific signature (such as /cgi-bin/some.cgi) 
might be fooled if a backward slash is substituted for a forward slash (such as /
cgi-bin\some.cgi). Windows-based Web servers convert a forward slash to a backward slash 
when interpreting directory structures, so the notation is valid. However, HTTP rules require 
the first character of a URI to be a forward slash. 

NULL Method Processing 

This technique injects a URL-encoded NULL character immediately after the METHOD (such 
as GET%00). It is designed for a device that attempts to apply string operations on the 
request, and those string libraries use the NULL character to denote the end of a string. If 
this ploy is successful, detection of the NULL character prevents the device from examining 
the remainder of the message. 

Case Sensitivity 

This technique is designed to evade a filter that searches for a case-specific string.

For example, the browser sends the following message to Web Proxy:

GET http://zero.webappsecurity.com/cgi-bin/some.cgi HTTP/1.1

Web Proxy sends the following message to the server:

GET /CGI-BIN/SOME.CGI HTTP/1.1

Host: zero.webappsecurity.com

Web Proxy Interactive Mode

Use Interactive mode to view each browser request and each server response as the messages 
arrive at Web Proxy. The message will not continue toward its destination until you click 
Allow. This permits you to modify the message before it is delivered. 
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You can also prevent the message from being sent to the server by clicking Deny.

Using the Proxy tab on the Web Proxy Settings window, you can force Web Proxy to pause after 
each request, after each response, or after locating specific text in either the request or 
response.

Follow the steps below to turn on interactive mode:

1 Click Proxy → Stop.

2 Click Proxy → Interactive
-or-

click  on the toolbar. 

3 Click Proxy → Start.

When Web Proxy is in Interactive mode, a check mark appears next to the Interactive 
command on the Proxy menu and the Interactive icon is backlit. Clicking the icon or selecting 
the command will toggle the Interactive mode on or off.
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Smart Update

Each time you log in to the WebInspect Enterprise Console, it contacts the server and 
downloads any available console binary updates.

You can obtain updates to the SecureBase, as well as binary updates for WebInspect 
Enterprise-connected products such as WebInspect, through either a manual or scheduled 
process.

For details, see Smart Update on page 38 and Smart Update Approval on page 39.
192 Appendix B



Cookie Cruncher

The Cookie Cruncher analyzes cookies to determine the relative ease with which an attacker 
could predict or determine the value of a session ID generated by a server and delivered to a 
client via a cookie.

Background

The Web’s Hypertext Transfer Protocol (HTTP) is stateless, meaning that each 
communication is discrete and unrelated to those that precede or follow. Because there is no 
continuity inherent in the protocol, application designers introduced the concept of “session.” 
A session is defined as all activity by a user with a unique IP address on a Web site during a 
specified period of time. When a user logs into an application, a session is created on the 
server to maintain the state for other requests originating from the same user.

Each session has a unique identifier (session ID). This text string is transmitted between the 
client and the server, and may be stored in cookies, URLs, or hidden fields of Web pages. One 
problem with session IDs, however, is that many Web sites generate them using algorithms 
based on easily predictable variables, such as time or IP address. This predictability makes 
the Web sites vulnerable to session hijacking.

Session hijacking involves an attacker using session IDs to seize control of a legitimate user’s 
session while that session is still in progress. The attacker can then gain complete access to 
the user’s data, and can perform all operations that are normally available to the legitimate 
owner of the session.

Using the Cookie Cruncher

Follow the steps below to use the Cookie Cruncher:

1 In the URL box, enter the URL of the site you want to test.

If you are using the Cookie Cruncher to examine a site you have scanned with 
WebInspect, follow these steps:

a In the WebInspect navigation pane, click the cookies icon . All HTTP 
responses containing a “Set-Cookie:” header are listed in the information pane.

b Double-click one of the listed responses.

c Click Request.

d Copy the request and paste it into the Cookie Cruncher’s Request area.

2 In the Sample box, enter the number of requests the Cookie Cruncher should send to the 
server (expecting a cookie to be returned). A higher number of samples increases 
processing time, but produces more reliable result; a minimum of 100 is suggested.

3 Click Sample.

As cookies are collected, the Cookie Cruncher organizes them into a tree hierarchy 
displayed in the vertical pane on the left side of the window. 

4 Click a cookie in the tree hierarchy to analyze it. If subcookies are found, the Cookie 
Cruncher modifies the tree hierarchy; click the plus sign  to expand the level. Repeat as 
necessary.

5 To view the analysis, select a cookie or subcookie and click the various tabs.
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6 To save the sampled cookies for future analysis, click File → Save.

Subcookies

Subcookies are either portions of cookie values that are common to many cookies, or 
interpreted values.

When the same string of characters appears in multiple cookies, you can choose that as a 
subcookie. The recurring expression will be eliminated from the cookies that contain it, and 
those cookies will be re-analyzed. The portion that is removed (the recurring expression) is 
called a “subcookie crumb.”

In the following sample, “086-” would be detected as a recurring expression: 

086-1123

086-1127

087-6281

086-1132

088-0518

087-6282

Analysis of those cookies containing the recurring expression (1123, 1127, 1132) would reveal 
the (most likely) incrementing cookie values that were interleaved with values from some 
other source.

If the detected character set of a sample consists of just 10 characters (Q-Z), these characters 
could possibly represent the digits 0-9. Choosing the re-encode option would run the cookies 
through an appropriate decoder algorithm (base-10, base-16, base-64, etc.) and re-analyze the 
cookies. 

The “Delimited Segment” option(s) allow you to select the delimited portions of cookies. For 
example, the following subcookies contain four delimited segments.

Cookie Cruncher cannot open and display a saved cookie file (.sck) if it contains 
fewer than four cookies.
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To analyze the second segment of all subcookies, you would click the Select Subcookie list and 
select Delimited Segment 2.

For more information, see the white paper Automated Cookie Analysis.

Cookie Cruncher Tabs

Use the Cookie Cruncher tabs to analyze the sampled cookies. The tabs are:

• Cookies

• Character Sets

• Char Freq

• Randomness

• Predictability

• Disk Plot

Cookies Tab

This tab lists all cookies received from the server. You can view them either in plain or grid 
format by clicking the appropriate button.

Character Sets Tab

This tab displays the character set used to format the cookie:

A = alphabetic character (letters A-Z)

N = numeric character (numbers 0-9)

H = hexadecimal character (0-F)

T = Text A-Z, a-z

I = Illegal (anything else)

D = delimiter
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Char Freq Tab

This tab displays a graph showing the number of times each ASCII character appeared in the 
total sample of cookies. A pale blue dot indicates an ASCII character whose number of 
appearances equals the number of cookies. A highlighted character indicates that it may be a 
delimiter (which is usually a character such as a comma, colon, or semicolon, but could also be 
something unusual such as “Z”). 

Randomness Tab

This tab attempts to differentiate between random and non-random portions of cookies, based 
on the sample obtained.

Use the Grid view to illustrate the analysis of each column. The color key is:

Red = No randomness (or very little) 
Orange = Somewhat random
White = Random

The top row of the grid indicates the numeric position of each character.

The second row displays, for each character position, a number representing the relative 
randomness of the character. This is actually the average number of bits that change per 
column from one cookie to the next. 

Use the Graph view to illustrate the randomness level in a graphic format. The dashed green 
line represents the optimum (best practice) level of randomness. The red line represents the 
randomness of the cookies in the sample. In a well designed cookie, the red line should follow 
the green line. When the graph view is selected, you can save the graph (in BMP, GIF, PNG, or 
JPG format) using the Save Graph command in the File menu.

Predictability Tab

The Cookie Cruncher analysis produces a correlation value ranging from 0 to 1 and displays it 
at the top of the graph. A low value indicates that cookie generation is more random; a higher 
value indicates greater predictability.

The value of each cookie is plotted (on the Y axis) against the time the cookie was received (on 
the X axis). A scattered distribution indicates randomness, whereas a pattern approaching a 
line indicates predictability.

If the correlation is .9 or greater, the graph displays the header “Incrementing Cookie Values” 
or “Decremented Cookie Values” and draws a “best fit” line.

Only decimal or hexadecimal values can be plotted.
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Disk Plot Tab

This graph plots a cookie’s value against the sine and cosine functions. When random data is 
plotted, the points are evenly distributed around the plotting area. Only decimal or 
hexadecimal values can be plotted.
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Cookie Cruncher Settings 

Follow the steps below to modify the Cookie Cruncher settings:

1 Click Edit → Settings.

2 Select either the General, Authentication, or Proxy category and enter the settings described 
in the following sections.

3 Click OK.

General

Thread Count

Specify the maximum number of threads that can be created. The Cookie Cruncher can be 
configured to send up to 75 concurrent HTTP requests before waiting for an HTTP response to 
the first request. The default setting is 10. Increasing the thread count will increase the speed 
of the process, but might also exhaust your system resources as well as those of the server you 
are scanning. While most servers can handle a large number of requests, servers in 
development environments sometimes have licensing limitations that allow only five or fewer 
users to be connected at a single time. In such cases, you should reduce the thread count to be 
less than 5.

Socket Timeout

Specify the maximum number of open sockets permitted. A higher number of open sockets 
results in a faster process. However, a setting that exceeds a server’s threshold may result in 
false positives.

If the Cookie Cruncher runs on Windows XP with Service Pack 2 (SP2), the number of open 
sockets should be set to 10. 

Custom Delimiters

The Cookie Cruncher interprets certain characters (such as /.-!,:;=) as delimiters. In some 
cases, you may want to substitute your own list. For example, a cookie having a value of 
“ABC123456-C:Program” contains two default delimiters — a dash (-) and a colon (:) — and 
would therefore be split into three parts. However, if you specify only the dash as a delimiter, 
the cookie would be split into just two parts.

The user-specified list, if present, will cause an extra subcookie type to appear in the tree, in 
addition to the regularly parsed subcookie types. The subcookie item may not appear when 
the number of cookies having the delimiter(s) is less than 10 percent of the total cookie 
sample.

To create a list of custom delimiters, select the Parse with Custom Delimiters check box and then 
enter one or more delimiters in the Characters box.
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Authentication

Authentication Method

If authentication is required, select a type from the Authentication list:

Authentication Credentials

Type a user ID in the User name box and the user’s password in the Password box. To guard 
against mistyping, repeat the password in the Confirm Password box.

Proxy

Use these settings to access the Cookie Cruncher through a proxy server.

Direct Connection (proxy disabled)

Select this option if you are not using a proxy server.

Auto detect proxy settings

If you select this option, the Cookie Cruncher will use the Web Proxy Autodiscovery Protocol 
(WPAD) to locate a proxy autoconfig file and use this to configure the browser’s Web proxy 
settings.

Authentication Description

Automatic Allow the Cookie Cruncher to determine the correct authentication 
type. Note that automatic detection slows the scanning process. If 
you know and specify one of the other authentication methods, 
scanning performance is noticeably improved.

HTTP Basic A widely used, industry-standard method for collecting user name 
and password information. The Web browser displays a window for 
a user to enter a previously assigned user name and password. If 
the Web server verifies that the user name and password 
correspond to a valid user account, a connection is established.
The advantage of Basic authentication is that it is part of the 
HTTP specification and is supported by most browsers. The 
disadvantage is that Web browsers using Basic authentication 
transmit passwords in an unencrypted form. By monitoring 
communications on your network, an attacker can easily intercept 
and decode these passwords using publicly available tools. 
Therefore, Basic authentication is not recommended unless you are 
confident that the connection between the user and your Web 
server is secure.

NT LAN Manager 
(NTLM) 

NTLM is an authentication process used by all members of the 
Windows NT family of products. It uses a challenge/response 
process to prove the client’s identity without requiring that either a 
password or a hashed password be sent across the network.
Use NTLM authentication for servers running IIS. 
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Use Internet Explorer proxy settings

Select this option to import your proxy server information from Internet Explorer.

Use Firefox proxy settings

Select this option to import your proxy server information from Firefox.

Configure a proxy using a PAC file

Select this option to load proxy settings from a Proxy Automatic Configuration (PAC) file. 
Then specify the file location in the URL box.

Explicitly configure proxy

Select this option to access the Internet through a proxy server, and then enter the requested 
information

1 In the Server box, type the URL or IP address of your proxy server, followed (in the Port 
box) by the port number (for example, 8080).

2 Select a protocol for handling TCP traffic through a proxy server: SOCKS4, SOCKS5, or 
standard.

3 If authentication is required, select a type from the Authentication list. See Authentication 
on page 110 for a description of the available authentication types.

4 If your proxy server requires authentication, enter the qualifying user name and 
password.

5 If you do not need to use a proxy server to access certain IP addresses (such as internal 
testing sites), enter the addresses or URLs in the Bypass Proxy For box. Use commas to 
separate entries.

HTTPS Proxy Settings

For proxy servers accepting HTTPS connections, select Specify Alternative Proxy for HTTPS and 
provide the requested information.
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Web Fuzzer

“Fuzzing” is an automated software testing technique that generates and submits random or 
sequential data to various areas of an application in an attempt to uncover security 
vulnerabilities. For example, when searching for buffer overflows, a tester can simply 
generate data of various sizes and send it to one of the application entry points to observe how 
the application handles it.

The Web Fuzzer lets you run several automated tests for common classes of Web application 
security vulnerabilities such as SQL injection, format strings, cross-site scripting, path 
traversal, odd characters, and buffer overflows, as well as protocol implementation problems.

Using the Web Fuzzer

Follow the steps below to use the Web Fuzzer:

1 Click Edit → Server.

2 Enter the fully qualified domain name or IP address of a Web site, along with other server 
configuration information, and click OK.

3 Click Edit → Settings.

4 Configure the settings and click OK. For more information, see Web Fuzzer Settings on 
page 207.

5 To create a session, click Session and select either Create or Raw Create.

a If you select Create, Web Fuzzer displays a tabbed property sheet that identifies each 
section of an HTTP request and allows you to replace an HTTP element with 
generated data or with text that you enter. This structured approach is recommended 
for novice users. For detailed information, see Using the Session Editor on page 204.

b If you select Raw Create, Web Fuzzer displays a standard GET request formatted as 
regular text. You can edit the request. You can also place the cursor anywhere in the 
request, right-click to invoke a shortcut menu, and then insert a generator that will 
fuzz the selected HTTP element. If you highlight any portion of the request, the 
highlighted portion will be replaced by the generator.

Table 6 Fuzzer Generators

Generator  Function

Number Inserts a whole number, within the range you specify, in each 
request; you specify the starting and ending number, the 
increment, and the number of times to loop through the series.

ASCII Inserts one ASCII character, within the range you specify, in each 
request; you specify the starting and ending character, and the 
number of times to loop through the series.

Character Generates the character you specify and inserts multiple 
numbers of the character into each request; you specify the 
minimum and maximum number of characters, and an 
increment.
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6 After creating the request, click OK.

7 You can use filters so that only those server responses meeting criteria you specify will be 
displayed.

8 On the Web Fuzzer Request window, click Start.

The Sessions area lists each session (request and response) generated by the tool. 

9 To examine the results, click an entry in the Sessions list.

• The HTTP request for the selected session appears in the Request area.

• The server’s response appears on both the Browser View and Raw Response tabs.

10 To edit the request that you constructed, select a session in the Sessions group, then click 
the Session menu and choose either Edit or Raw Edit.

Filters

A filter consists of a name, description, and rule. The rule is a regular expression that defines 
the text you want to locate in a particular section of the server’s response. For example, if you 
want to display only those responses that contain the word “error” in the response body and 
where the response also specifies a status code between 500 and 599, then use the following 
rule:

[STATUSCODE]5\d\d AND [BODY]\serror\s

Decimal 
Number

Inserts a fractional number, within the range you specify, in each 
request; you specify the starting and ending number, the 
increment, and the number of times to loop through the series.

Guid Inserts a random Globally Unique Identifier (a 128-bit number) 
in each request; you specify the number of requests.

WordList 
Reader

Inserts a string from a text file you specify; the number of 
requests is determined by the number of paragraphs in the file; 
all characters in the paragraph are inserted.

SQL Injection Inserts a string from a text file you specify; the number of 
requests is determined by the number of paragraphs in the file; 
all characters in the paragraph are inserted. The default file 
(sqlinjections.txt) contains the following two entries: ’ or 1=1 ’ or 
like ’%

Text Inserts the text you specify in a single request. 

Cross-Site 
Scripting 

Inserts a string from a text file you specify; the number of 
requests is determined by the number of paragraphs in the file; 
all characters in the paragraph are inserted. The default file 
(xssinjections.txt) contains the following entry: 
<script>alert(’test’)</script>

Method Inserts a method (GET, POST, PUT, etc.); you specify the protocol 
version (0.9, 1.0, 1.1, or all).

Table 6 Fuzzer Generators (cont’d)

Generator  Function
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Use the following notation to specify a response section:

• [HEADERS]

• [STATUSLINE]

• [STATUSCODE] 

• [STATUSDESCRIPTION] 

• [ALL] 

• [SETCOOKIES] 

• [BODY] 

You access the Filters dialog by selecting Filters → Edit.

In addition to enabling a specific rule, you must also enable the use of rules in general by 
selecting Filters → Enable.

Creating a Filter

Follow the steps below to create a filter:

1 Click Add.

The tool creates a rule named Default Rule.

2 Modify the Name, Description, and Rule.

3 Click Apply to save the definition.

Using a Filter

Follow the steps below to use a filter in a session:

1 Select a filter from the Filters list.

2 Select the Enable check box.

Deleting a Filter

Follow the steps below to delete a filter:

1 Select a filter from the Filters list.

2 Click Delete.

Editing a Filter

Follow the steps below to edit a filter:

1 Select a filter from the Filters list.

2 Modify the Name, Description, or Rule.

3 Click Apply to save the modifications.
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Using the Session Editor

Use this tabbed property sheet to change specific sections of an HTTP request. You can 
replace an HTTP element with text that you type or paste into a text box, or you can insert a 
generator that will create multiple requests containing generated data.

Follow the steps below to use the Session Editor:

1 Click a tab.

2 You can either:

• Edit the data appearing in text boxes, or 

• Select the Use Generator check box and click Generator to insert a generator.

3 To change other areas, click a different tab.

4 After configuring the areas you want to change, click OK.

5 When you return to the Web Fuzzer window, click Start.

Creating a Query String

Follow the steps below to create a query string:

1 Click Add.

The text “name=value” appears in the list, representing the query string you are creating.

2 Click the Name tab. 

You can edit the parameter named “name” or you can substitute a generator for it (select 
the Use Generator check box and click Generator).

3 Click the Separator tab. 

You can edit the character that separates the name from the value (usually an equals 
sign) or you can substitute a generator for it (select the Use Generator check box and click 
Generator). 

4 Click the Value tab. 

You can edit the value in the equation or you can substitute a generator for it (select the 
Use Generator check box and click Generator).

5 Click the Format tab. 

You can edit the order in which the equation elements appear, or you can introduce 
characters between them.

6 In the Name Value Separator group, you can edit the character that separates parameters 
(usually an ampersand) or you can substitute a generator for it (select the Use Generator 
check box and click Generator).

7 To add another parameter, click Add and repeat Steps 2-6.
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Session Editor Tabs

Method Tab

The GET method is specified by default. You can replace it with any text, or you can insert the 
Method generator.

Path Tab

You can fuzz three elements related to the path: the name of the file, the file extension, and 
the character that designates a directory level (usually the forward slash /). You can replace 
these elements with any text, or you can insert generators. 

Query Tab

Some HTTP requests include a query string, with each parameter formatted as 
parameter=value and separated by an ampersand ( & ). The resource is separated from the 
query by a delimiter character (usually a question mark, although other characters can be 
used depending on the application). For example:

http://www.website.com/category.cfm?model_ID=0&category_ID=12.

Version Tab

The version indicates to the server which HTTP version to use for interpreting the request. 
Valid versions are 0.9, 1.0 and 1.1. The version information is formatted as “HTTP/version,” 
which is a name-value pair separated by a forward slash ( / ). You can fuzz all three sections: 
Protocol, Separator, and Version. You can also fuzz the format by rearranging the order or 
introducing extraneous characters.

Headers Tab

Headers contain basic information issued by the client to help the server or application handle 
the request. Common headers are Host and User-Agent. Each header is defined by using the 
“name: value” syntax. This name-value structure also can be separated into four fuzzing 
opportunities.

Creating Headers

Follow the steps below to create headers:

1 Click Add.

The text “name:value” appears in the list, representing the header you are creating.

2 Click the Name tab. You can edit the parameter named “name” or you can substitute a 
generator for it (select the Use Generator check box and click Generator).

3 Click the Separator tab. You can edit the character that separates the name from the value 
(usually a colon) or you can substitute a generator for it.

4 Click the Value tab. You can edit the “value” text or you can substitute a generator for it.

5 Click the Format tab. You can edit the order in which the header elements appear, or you 
can introduce characters between them.
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6 In the Name Value Separator group, you can edit the character that separates headers or 
you can substitute a generator for it.

7 To add another header, click Add and repeat Steps 2-6.

Cookies Tab

Cookies are special headers that contain parameters used by the application to manage users 
and states. The format of a cookie definition is:

Cookie: name=value;name=value

Each parameter is a name-value pair that can be independently fuzzed.

Creating Cookies

Follow the steps below to create cookies:

1 In the Cookies group, click Add.

“Cookie:” appears in the list, representing the cookie you are creating.

2 Click Cookie: (in the Cookies list) and then click Add (in the Cookie group).

The text “name=value” appears.

3 In the Cookie group, click the Cookie Name tab. You can edit the name or you can 
substitute a generator for it.

4 Click the Separator tab. You can edit the character that separates the name from the value 
(usually an equals sign) or you can substitute a generator for it.

5 Click the Value tab. You can edit the “value” text or you can substitute a generator for it.

6 Click the Format tab. You can edit the order in which the header elements appear, or you 
can introduce characters between them.

7 In the Name Value Separator group, you can edit the character that separates headers or 
you can substitute a generator for it.

8 To add another cookie, repeat steps 1-7.

Post Data Tab

While a query can be appended to the Request-URI, post data is added to the end of the 
request. The format is similar to the URI query and is mostly used with the POST method. 
When post data are used, the request must contain a Content-Length header that indicates 
the size of the post data. You can fuzz not only the post data, but also the Content-Length 
value to test how the server or application handles the differences.

When fuzzing the HTTP request message, you affect two main layers of the application 
environment: server protocol implementation and Web application.

Creating POST Data

Follow the steps below to create post data:

1 Click Add. 

The text “name=value” appears in the list, representing the post data you are creating.

2 Click the Name tab. You can edit the parameter named “name” or you can substitute a 
generator for it.
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3 Click the Separator tab. You can edit the character that separates the name from the value 
(usually a colon) or you can substitute a generator for it.

4 Click the Value tab. You can edit the “value” text or you can substitute a generator for it.

5 Click the Format tab. You can edit the order in which the header elements appear, or you 
can introduce characters between them.

6 In the Name Value Separator group, you can edit the character that separates headers or 
you can substitute a generator for it.

7 To add another post data element, click Add and repeat Steps 2-6.

Web Fuzzer Settings

Follow the steps below to modify the Web Fuzzer settings:

1 Click Edit → Settings.

2 Select either the General or Proxy category and enter the settings described in the 
following sections.

3 Click OK.

General

Enable Filters

Select this option to enable filter support. 

Auto scroll view

Select this option to enable automatic scrolling in the Sessions List view. This will force the 
view to scroll down to the latest session automatically. 

Show ToolTips

Select this option to enable the display of tool tips when you hover your mouse pointer over 
certain controls.

Sockets

Enter the maximum number of sockets and the sockets send timeout (in seconds).

Protocol Compliance

Select Enforce Content-Length to automatically adjust the Content-Length value in the request 
when needed. If this feature is enabled, you cannot fuzz the content-length header.

Select Enforce Host header to include the Host header in all requests. If this feature is enabled, 
you cannot fuzz the host header.

Proxy

Use these settings to access the Web Fuzzer through a proxy server.
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Direct Connection (proxy disabled)

Select this option if you are not using a proxy server.

Auto detect proxy settings

If you select this option, the Web Fuzzer will use the Web Proxy Autodiscovery Protocol 
(WPAD) to locate a proxy autoconfig file and use this to configure the browser’s Web proxy 
settings.

Use Internet Explorer proxy settings

Select this option to import your proxy server information from Internet Explorer.

Use Firefox proxy settings

Select this option to import your proxy server information from Firefox.

Configure a proxy using a PAC file

Select this option to load proxy settings from a Proxy Automatic Configuration (PAC) file. 
Then specify the file location in the URL box.

Explicitly configure proxy

Select this option to access the Internet through a proxy server, and then enter the requested 
information

1 In the Server box, type the URL or IP address of your proxy server, followed (in the Port 
box) by the port number (for example, 8080).

2 Select a protocol for handling TCP traffic through a proxy server: SOCKS4, SOCKS5, or 
standard.

3 If authentication is required, select a type from the Authentication list. See Authentication 
on page 110 for a description of the available authentication types.

4 If your proxy server requires authentication, enter the qualifying user name and 
password.

5 If you do not need to use a proxy server to access certain IP addresses (such as internal 
testing sites), enter the addresses or URLs in the Bypass Proxy For box. Use commas to 
separate entries.

HTTPS Proxy Settings

For proxy servers accepting HTTPS connections, select Specify Alternative Proxy for HTTPS and 
provide the requested information.
208 Appendix B



SQL Injector

SQL injection is a technique for exploiting Web applications that use client-supplied data in 
SQL queries without first removing potentially harmful characters. The SQL Injector 
supports MS-SQL, Oracle, Postgress, MySQL, and DB2 as database types and also supports 
multiple language systems including Japanese.

This tool tests for SQL injection vulnerabilities by creating and submitting HTTP requests 
that may be processed by your SQL Server. If your Web application allows database records to 
be updated or created using data supplied by the user, the SQL Injector may create spurious 
records. To avoid this possibility, do not test against your production database. Instead, use a 
copy of the database, or use a test account that does not have access to the production data, or 
exclude from audit any pages that may update or delete data from the database. If these 
alternatives are not feasible, back up your production database before testing at a time when 
the site has little or no customer traffic. 

Using the SQL Injector

Follow the steps below to test for susceptibility to SQL injection:

1 If using a proxy server or if the target site requires authentication, click the Settings tab 
and enter the appropriate information. See SQL Injector Settings on page 211 for 
additional information.

2 Select File → New 
- or -
click the New Request icon.

3 In the Location box, type or paste the URL that you suspect is susceptible to SQL 
injection. See examples below.

• GET method (query parameters are embedded in the URL):
http://172.16.61.10/Myweb/MSSQL/Welcome.asp?login=aaa&password=bbb 

• POST method (query parameters are included in message body):
http://172.16.61.10:80/Myweb/MSSQL/Welcome.asp

Because the SQL Injector defaults to the GET method, you must also edit POST 
requests on the Raw tab (visible if you select View → Show Request). The edited request 
would be similar to the following:

POST /Myweb/MSSQL/POST/2.asp HTTP/1.1

User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Host: 172.16.61.10

Content-Length: 22

Content-Type: application/x-www-form-urlencoded

login=qqq&password=aaa

4 Click Send.
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If SQL injection is successful, “SQL Injection Confirmed” appears on the Status tab and 
the beginnings of a data hierarchy tree appear on the Site Tree tab in the lower left pane.

5 To extract all the data from all tables, click Pump Data.

Alternatively, you can selectively investigate tables and columns using the following 
procedure:

a Select Get Tables.

The SQL Injector returns the names of all tables in the targeted database.

b Choose tables by selecting or clearing their associated check box. 

c Click Get Columns.

The SQL Injector returns the names of all columns in the selected tables.

d Choose a column by selecting or clearing its associated check box. 

e Click Get Data.

6 Select a column and click the Data tab to column values.
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SQL Injector Tabs

Request Pane

The Request pane contains three tabs:

• Raw - Displays the text of the HTTP request.

• Details - Displays the request segmented by method, request URI, and protocol. Also lists 
the request header fields and their associated values.

• Hex - Displays a hexadecimal representation of the HTTP request.

To toggle the display of the Request pane, click Show Request/Hide Request.

To delete the request, replacing it with the default http://localhost:80/, click Clear Request.

Database Pane

The lower left pane contains two tabs:

• Site Tree - Displays the URL, databases, tables, and columns.

• Data Extraction Settings - Displays the maximum number of tables, columns, and rows to 
return when extracting data. These values are extracted from the settings, but can be 
modified here or in the settings dialog.

Information Pane

The lower right pane contains four tabs:

• Status - Displays progress bars for detection and extraction functions. 

• Details - Displays database information and injectable parameter details. 

• Data - Displays data extracted from the selected tables and columns. 

• Log - Displays a synopsis of pertinent functions and the time at which they occurred.

SQL Injector Settings

Follow the steps below to modify the SQL Injector settings:

1 Click Edit → Settings.

2 Select either the Options, Authentication, or Proxy category and enter the settings described 
in the following sections.

3 Click OK.

Options Tab

Timeout in Seconds

Specify the number of seconds that the SQL Injector will wait for a response before 
terminating the session.
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Apply State

If your application uses cookies, URL rewriting, or post data techniques to maintain state 
within a session, the SQL Injector will attempt to identify the method and modify the 
response accordingly.

Apply Proxy

If you select this option, the SQL Injector will modify the request according to the proxy 
settings you specify.

Logging

Select the events you want to log:

• Requests 

• Responses 

• Errors 

• Debug Messages

Log files are stored in xml format in My Documents\SPI dynamics\Tools\SQLInjector\logs.

The beginning of each file name is formatted as YYYY_MM_DD<current-process-id>. The 
remainder of the name is formatted as follows:

_sqli_debug.log: Contains debugging messages for that session.

_errors.log: Contains errors and exceptions that occurred for that session.

_RequestsResponses.log: Contains all the requests and responses sent and received by the 
SQL Injector.

Data Extraction

Specify the maximum number of tables, columns, and rows that should be returned when 
extracting data through a URL that is vulnerable to SQL injection. These values are also 
displayed in the Database pane on the Data Extraction Settings tab. You can change these 
values using either this tab or the Settings dialog.

Also specify the maximum number of concurrent threads that should be used for data 
extraction.

Inferential/Time-Based Extraction

The SQL Injector can use two different techniques for extracting data when a SQL injection 
vulnerability is discovered. All attempts are conducted using the inferential technique, which 
examines the content of the HTTP responses. If this method fails, you can force the tool to use 
a second technique called time-based extraction. Instead of extracting table data, this method 
attempts to retrieve the name of the database by sending 4-5 long-running database queries 
for each character in the database name. Since this can be a rather time-consuming exercise, 
you can specify the number of characters required to confirm the existence of the SQL 
injection vulnerability.

Use a macro

Select this option to use a startup macro; then click  to select, edit, or create a macro.
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Database File Path

This read-only text box displays the path to the database created by the SQL Injector tool to 
store attack data and replicate portions of the attacked database.

Authentication Tab

Authentication Method

If the site does not require authentication, select None. Otherwise, select a type from the 
Authentication list:

Authentication Credentials

Type a user ID in the User name box and the user’s password in the Password box. To guard 
against mistyping, repeat the password in the Confirm Password box.

Proxy Tab

Use these settings to access the SQL Injector through a proxy server.

Direct Connection (proxy disabled)

Select this option if you are not using a proxy server.

Authentication Description

Automatic Allow the SQL Injector to determine the correct authentication 
type. Note that automatic detection slows the scanning process. If 
you know and specify one of the other authentication methods, 
scanning performance is noticeably improved.

HTTP Basic A widely used, industry-standard method for collecting user name 
and password information. The Web browser displays a window for 
a user to enter a previously assigned user name and password. If 
the Web server verifies that the user name and password 
correspond to a valid user account, a connection is established.
The advantage of Basic authentication is that it is part of the 
HTTP specification and is supported by most browsers. The 
disadvantage is that Web browsers using Basic authentication 
transmit passwords in an unencrypted form. By monitoring 
communications on your network, an attacker can easily intercept 
and decode these passwords using publicly available tools. 
Therefore, Basic authentication is not recommended unless you are 
confident that the connection between the user and your Web 
server is secure.

NT LAN Manager 
(NTLM) 

NTLM is an authentication process used by all members of the 
Windows NT family of products. It uses a challenge/response 
process to prove the client’s identity without requiring that either a 
password or a hashed password be sent across the network.
Use NTLM authentication for servers running IIS. 
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Auto detect proxy settings

If you select this option, the SQL Injector will use the Web Proxy Autodiscovery Protocol 
(WPAD) to locate a proxy autoconfig file and use this to configure the browser’s Web proxy 
settings.

Use Internet Explorer proxy settings

Select this option to import your proxy server information from Internet Explorer.

Use Firefox proxy settings

Select this option to import your proxy server information from Firefox.

Configure a proxy using a PAC file

Select this option to load proxy settings from a Proxy Automatic Configuration (PAC) file. 
Then specify the file location in the URL box.

Explicitly configure proxy

Select this option to access the Internet through a proxy server, and then enter the requested 
information

1 In the Server box, type the URL or IP address of your proxy server, followed (in the Port 
box) by the port number (for example, 8080).

2 Select a protocol for handling TCP traffic through a proxy server: SOCKS4, SOCKS5, or 
standard.

3 If authentication is required, select a type from the Authentication list. See Authentication 
on page 110 for a description of the available authentication types.

4 If your proxy server requires authentication, enter the qualifying user name and 
password.

5 If you do not need to use a proxy server to access certain IP addresses (such as internal 
testing sites), enter the addresses or URLs in the Bypass Proxy For box. Use commas to 
separate entries.

HTTPS Proxy Settings

For proxy servers accepting HTTPS connections, select Specify Alternative Proxy for HTTPS and 
provide the requested information.
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Web Macro Recorder (TruClient)

A macro is a recording of the activity that occurs when you navigate through a Web site or 
application using the Web Macro Recorder. You can instruct WebInspect to use this recording 
to enter your Web site and (optionally) navigate through your application.

A login macro should contain events recorded during a login procedure and incorporates logic 
that will prevent WebInspect from terminating prematurely if it inadvertently logs out of 
your application. When scanning a site, WebInspect analyzes every server response to 
determine the state. If the scanner determines at any time that it is logged out, it runs this 
macro to log in, and then resumes crawling or auditing the site at the point where the logout 
occurred. When beginning a scan through the WebInspect scan wizard, you can specify a login 
macro at Step 2 under Site Authentication.

You can access the TruClient Web Macro Recorder in several ways:

• When starting a site scan, select Site Authentication (on Step 2 of the WebInspect Scan 
Wizard) and click Record.

• On the WebInspect toolbar, click Tools → Web Macro Recorder.

• In default scan settings, click Scan Settings → Authentication → Use a login macro.

• From the Windows Start menu: click Start → HP → HP Security Toolkit → Web Macro 
Recorder.

Note: WebInspect accommodates three different macro recorders. Use Application Settings - 
General to specify the one that will be launched by default when creating a macro. See 
General Settings on page 195 for more information.

This Web Macro Recorder is an adaptation of the Ajax TruClient technology originally 
developed for use with HP LoadRunner and HP Performance Center. It does not incorporate 
or support all the capabilities of the fully-featured version. 

The TruClient Macro Recorder does not support the recording of Flash or Silverlight 
applications.

Recording a Macro

This task describes the basic steps involved in interactively recording a login macro.

Task 1: Record the login 

1 Enter the URL of the target site in the address bar at the top of the window and press 
Enter. 

2 If necessary, navigate to the login page. 

Note: If the browser displays a message that the connection is untrusted, click I 
Understand the Risks and then click Add Exception before continuing to next step. 

Note: When launching the TruClient web macro recorder, you may receive the following error 
message:

“Exc in ev handl: TypeError: this.oRoot.enable is not a function.”

This can occur if the McAfee SiteAdvisor is installed. Simply acknowledge the message and 
continue.
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3 Click Record. All of your actions will be recorded and displayed in the pane on the left. You 
can pause or stop the script and continue recording from any point in the script. 

4 Enter your user name and password. 

5 Submit the login credentials by clicking the appropriate button (such as Login, Log On, 
Submit, Enter, etc.). 

6 Click Stop. 

Task 2: Replay the macro 

Replay the macro, correcting any errors that occur during the process.

You can use the Play button in the left pane  or the Play button in the right pane .

If you experience errors, see Debugging Macros on page 222.

Task 3: Identify a “logged out” condition 

Navigate to a protected page (that is, one that you cannot access without being logged in to 

the application) and click . TruClient will attempt to detect a logout condition.

• If TruClient is able to automatically detect a logout condition, your macro has been 
created. 

For an automatic logout condition, TruClient attempts to determine if your site employs 
an HTTP redirect to a login page when login state has been lost.   If so,  a regular 
expression logout condition will be generated automatically based on the ‘Location’ header 
of the redirect.  This automatically generated regular expression could change at scan 
time depending on what navigation parameters are specified in the scan settings.  
Navigation parameters are needed to help uniquely identify the URL referenced in the 
‘Location’ header of the redirect.  Because this regular expression may change during the 
scan, it has not be made available in the interface.

• If automatic logout condition detection was not successful, click  and then, on the 
page that is being displayed, click an element or control that appears only when you are 
logged out. For example, if a Login button appears when you have logged out, click Select 
and then click the Login button.  

Note: If you prefer, you may elect to identify a specific URL that always appears after the user 
logs out, or you can specify a regular expression that describes a resource that appears after 

logging out. To do so, finish this step and then click  and select View Logout (or click 

Logout Conditions Editor  in the left pane). 

Task 4: Modify the logout or enter parameters 

You have completed the macro. The next steps are optional.

• To examine or modify the logout condition (to identify a specific URL that always appears 
after the user logs out or to specify a regular expression that describes a resource that 

appears after logging out), click  and select View Logout. 

• To parameterize the login credentials, click  and select Parameterize Input. 
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Task 5: Save the macro 

Click Save  to save the macro.

Parameterizing Input

When recording a log-in macro, you can use the Parameters Editor for two different features:

• Create a parameter for the user name and password, allowing testers to use their own 
authentication credentials when starting a scan.

• Create a parameter for the URL, allowing testers to designate an alternate URL when the 
macro is run. For example, suppose you record a macro for www.testsite.com. At a later 
point in time, you rename the site to www.testsite2.com. If you parameterize the URL 
when you record the macro, you do not need to record a new macro. You simply enter a 
new host name as the Start URL when selecting Site Authentication on Step 2 of the Scan 
Wizard.

Procedures for creating these parameters are detailed below.

Using Name and Password Parameters

Task 1: Create Parameters

1 After creating and testing your log-in macro, click Open Parameters Editor (or, if the 
instruction at the top of the right pane is “Your macro is now complete,” click Options and 
select Parameterize Input). 

The Parameters Editor opens.

2 Click  to add a parameter.

3 In the Name box, enter a name for the parameter (such as “Username”).

4 In the Value box, enter the label that you want to appear on the Login Macro Parameters 
grid (such as “Enter user name”).

5 Click Apply.

6 Click  to add a second parameter.

7 In the Name box, enter a name for the parameter (such as “Password”).

8 In the Value box, enter the label that you want to appear on the Login Macro Parameters 
grid (such as “Enter password here”).

9 Select Encrypted if the value should be encrypted before transmission to the Web server.

10 If you renamed the parameter, click Apply.

11 Click Close.

Task 2: Assign Parameters to Steps

1 Select the macro step (in the left pane) that contains the user name.

2 Click the drop-down arrow on the far right to open the Step Editor.

3 Click Arguments.
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4 Highlight the entire contents of the Value box, right-click the highlighted text, and select 
Replace with a Parameter.

5 On the Enter Parameter Name dialog, select the parameter (“Username” in this example) 
from the Select Parameter list and click OK.

6 Select the macro step that contains the password.

7 Click the drop-down arrow on the far right to open the Step Editor.

8 Click Arguments.

9 Highlight the entire contents of the Value box, right-click the highlighted text, and select 
Replace with a Parameter.

10 On the Enter Parameter Name dialog, select the parameter (“Password” in this example) 
from the Select Parameter list and click OK.

11 Save the macro.

When you start the scan and select this log-in macro on Step 2 of the Scan Wizard, the 
parameters appear in the Login Macro Parameters grid (illustrated below). The tester simply 
replaces the parameters with a valid user name and password.

Using URL Parameters

Task 1: Create Parameter

1 After creating and testing your log-in macro, click Open Parameters Editor (or, if the 
instruction at the top of the right pane is “Your macro is now complete,” click Options and 
select Parameterize Input). 

The Parameters Editor opens.

2 Click  to add a parameter.

3 In the Name box, enter a name for the parameter (such as “StartURL”).

4 In the Value box, enter the actual Host Name or URL (such as www.testsite.com).

5 Click Apply.

6 Click Close.
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Task 2: Assign Parameters to Steps

1 Select the macro step (in the left pane) that contains the URL (“Navigate to...”).

2 Click the drop-down arrow on the far right to open the Step Editor.

3 Click Arguments.

4 Highlight the entire contents of the Value box, right-click the highlighted text, and select 
Replace with a Parameter.

5 On the Enter Parameter Name dialog, select the parameter (“StartURL” in this example) 
from the Select Parameter list and click OK.

6 Save the macro.

When you start the scan and select this log-in macro on Step 2 of the Scan Wizard, the 
parameter appears in the Login Macro Parameters grid (illustrated below). The tester either 
leaves the parameter unchanged (to access the original URL) or enters the URL of the new 
site.

Recording a Multi-Challenge Macro

Challenge-response authentication is a family of protocols in which the server presents a 
question (the challenge) and the client must provide a valid answer (the response). The 
simplest example is where the challenge asks for a password and the valid response is the 
correct password.

Many Web sites now present multiple challenges to the user. Typically, when a user first 
registers with a Web site, the site presents a list of questions to which the user provides 
answers that will be used for subsequent authentication. For example:

What is your favorite color?
What was the name of your first pet?
In what town or city were your born?
What was the make of your first automobile?

When the user later attempts to log in, the Web site presents two or more of these challenges.

Some sites also create groups of challenges, and present questions from different groups on 
each subsequent log-in attempt, as demonstrated in the following example.

When registering for the sample Web site, the user is asked to provide answers to nine 
questions, which are arranged into three groups of three questions each, as follows.

Group 1
Q: What is your quest?  A: red
Q: What is your name?  A: Smith
Q: What is your favorite color  A: blue

Group 2
Q: What is the name of your favorite pet?  A: Rusty
Q: What is your mother's maiden name?  A: Jones
Q: In what state were you born?  A: Delaware

Group 3
Q: What is the capital of Mongolia?  A: Ulaanbaatar
Q: What is the name of a sea bird?  A: Albatross
Q: What is your paternal grandmother's first name?  A: Esther
WebInspect Enterprise Tools 219



The login page might look like this (using the first question from each group):

When creating a macro for a challenge/response type of login, you must know all possible 
question-and-answer combinations, even if only a portion or subset of those combinations may 
be presented during any one episode. You will enter these combinations manually, before 
recording the login.

Use the following procedure to create a login macro for this hypothetical web page.

For each of the three question-and-answer locations:

1 Click the Toolbox (represented by a vertical tab on the left side of the left pane). 

2 Click Composite Steps.

3 Drag the Security Question element and drop it in the left pane. 

4 Click the first “Click to choose an object” button and then, in the right pane, click the 
object representing the first question (usually a label).

5 Click the second “Click to choose an object” button and then, in the right pane, click the 
object representing the answer (usually a text box). 

6 In the left pane, open the Step Editor for the step you just created (by clicking in the 
upper right corner of the step.
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7 Click Arguments. 

8 Click  to create a security question. 

9 Using the Security Questions Editor, click the plus sign to add a new question. 

10 In the Question box, replace the default text "Question1" with the actual question exactly 
as it appears on the login page, including capitalization and punctuation. Be sure to 
enclose the text in quotation marks.

11 In the Answer box, enter the correct response. 

12 Click OK. 

13 Repeat steps 8-12 to add the information for the second question that may appear in the 
first location (in this example, "What is the name of your favorite pet?"). 

14 Repeat steps 8-12 to add the information for the third question that may appear in the 
first location (in this example, "What is the capital of Mongolia?"). 

15 Refresh the page: click in the right pane and press F5 (or right-click and select Reload) 
until the second set of questions appears. 

16 Repeat Steps 1-14 to add a second step that contains three different questions and 
answers. 

17 Refresh the page: click in the right pane and press F5 (or right-click and select Reload) 
until the third set of questions appears. 

18 Repeat Steps 1-14 to add a third step that contains three different questions and answers. 

19 After creating steps for all possible question-and-answer combinations, select the last 
step. 

20 Click the drop-down arrow on the Record button and select Record after selected step.

21 On the web page, click the login control (the button or hyperlink labeled Log In, Log On, 
Submit, etc.). 

22 Click Stop. 

To complete the macro, follow the instructions in Recording a Macro on page 215 for 
replaying, identifying a logged out condition, and saving the macro.

Enhancing Macros

There are a number of optional enhancements that can be added to macros beyond the basic 
workflow. 
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Modify Steps 

Modify step arguments and objects by selecting the desired step and expanding the options. 
This expands the step and allows you to modify the objects and properties. For a detailed list 
of the step structure, see Toolbox. 

Insert loops 

Loops repeat selected portions of the macro until certain criteria is met or for a specified 
number of times. To insert a loop, select Toolbox → Flow Control → For loop. For more 
information, see How to Insert and Modify Loops. 

Insert If blocks or If-else blocks and exit steps 

To conditionalize a portion of the macro, you can insert If or If-else blocks. To insert an If 
block, select Toolbox → Flow Control → If block. To add an else condition, click the Add else link 
next to the If step title. For more details, see TruClient Step Arguments.

Exit steps cause a macro to exit the iteration or the entire macro. These can be used with If 
statements to exit a macro or iteration when a specified condition occurs. To insert an exit 
step, select Toolbox → Flow Control → Exit.

Insert comments 

You can insert comments into your macro by selecting Toolbox → Misc and dragging the 
Comment icon to the desired location. 

Insert Catch Error Steps 

“Catch error” steps are group steps that run their contents if the previous step contains an 
error. Additionally, the error is “caught” and is not returned. You can define catch error steps 
to catch any error, or a specific type of error. If there are two catch error steps in a row, they 
both apply to the same step. To insert a catch error step, select Toolbox → Flow Control → 
Catch Error.

Verify that an object exists 

To verify that a string or object exists in the application, you can insert a verify step:

1 Select Toolbox → Functions and drag the Verify icon to the desired location.

2 Click the object in the verify step.

3 Select the object you want to verify.

Insert generic steps 

You can insert a blank step and manually configure it. To insert a generic step, select Toolbox 
→ Functions → Generic Object/Browser Action, expand the step, and enter the desired step 
properties. Generic Object Actions perform an unspecified action on an object. Generic 
Browser Actions perform an unspecified action on the browser such as go back, reload, switch 
tabs, etc. 

Debugging Macros

This topic describes the basic steps involved in interactively debugging a macro.
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View Replay Errors in Firefox 

If any steps failed during replay, they are marked with an error icon . Hover the mouse 
pointer over these icons to view descriptions of the errors. 

Run the Macro Step by Step 

The step-by-step replay allows you to view the sequence more slowly and in a controlled 
manner. To run the macro step by step, select the down arrow next to the Replay button and 
select Replay step by step. Repeat this procedure after each step to continue the step-by-step 
replay. 

Insert Breakpoints 

Breakpoints instruct the macro to stop running during a replay when in interactive mode. 
They can be used to help debug your macro. To insert a breakpoint, select the desired step and 

click Breakpoints . 

Debug Macros Using Snapshots 

You can use the snapshots generated during replay to debug macros by viewing the snapshots 
of the failed step(s). 

1 Click General Settings .

2 Set the Replay Snapshot Generation setting to On Error.

3 Replay the macro.

4 Click Snapshot View  and in the Snapshot Viewer, click Interactive Replay. Note the step 
numbers of the steps that had errors.

You now have a group of snapshots in which errors occurred in the macro.

Modify and View Levels 

Sometimes, steps that were recorded and are necessary for replay are placed in levels 2 and 3. 
In this case, you need to manually modify the level of those steps to level 1.

To modify a the macro's replay level, drag the slider in the toolbar to the desired level. 
Dragging the slider to level 3 displays and replays the steps on levels 1, 2, and 3.

To move a step to a different level, open the step and click on the step section. Move the slider 
to the desired level. If the step is part of a group step, both the group step and the individual 
step must be modified.

For more information, see Script Levels.

Insert Wait Steps 

Wait steps cause the script to pause for a specified amount of time before continuing with the 
next step. Wait for Object steps cause the script to wait for a specified object to load before 
continuing with the next step. Wait steps begin after the End Event of the previous step is 
reached. This means that the previous step may continue to run after the wait step has been 
reached. To insert a wait, select Toolbox → Functions and drag the Wait or Wait for Object icon 
to the desired location in your script. Wait steps wait for a specified amount of time. Wait for 
Object steps wait until the specified object appears in the application. In Wait for Object 
steps, select the Click to choose an object button to select the target object in the application. 
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Resolving Object Identification Issues 

In dynamic Web sites, objects that have been recorded can often move or change content. 
Object identification presents one of the biggest challenges with recording and replaying Web 
2.0 applications. This can cause the macro to lose the ability to locate the object.

TruClient includes sophisticated mechanisms to overcome this challenge including the 
Highlight, Improve Object Identification, Replace Object, and Related Object options. When 
identifying objects for applications that recorded in windows, make sure that the correct 
window is selected using the Window tab. The following steps describe the ways to resolve 
these issues.

Highlight, Improve Identification, Replace, Related Objects all require the user to select an 
object in the application. There are cases in which various actions are required in the 
application to make the object visible such as mouse over and mouse click. In these cases use 
the CTRL+ALT+F4 option to suspend the object-selection mode until you bring the object into 
view and press CTRL+ALT+F4 again to select the object .

After you perform any of the changes, replay the single failed step in question and only 
afterwards replay the whole macro again. This will help verify whether the change has solved 
the issue you encountered.

The following paragraphs describe ways to resolve object identification issues.

Highlight an object 

Regardless of which method of object identification is used, you can use the Highlight button 

 to check if an object is visible in the application at any time. If the object is not found, this 
may be an issue of pacing and timing. If the object cannot be found, an error message is 
displayed. 

Object Identification 

If the Highlight option fails, use Improve Object Identification . This will let TruClient 
relearn the properties of the object and compare them to the properties learned during 
recording. Based on the differences, the necessary adjustments can be made. Depending on 
how dynamic the application is, you may need to use the Improve Object Identification 
function more than once.

Once you have done this, try replaying the step again to check whether the problem has been 
solved.

Alternative Steps 

Alternative steps allow you to view instances in which there are multiple ways to perform the 
same action in a step. If Improve Object Identification fails, try using one of the alternative 
steps.

For example, you may be clicking on an option in a drop down list in which the text changes 
based on some value.

If you try to click based on the text, the step may fail.

If you use an alternative step that selects the item in the list based on the ordinal value of the 
option within the list, the click will succeed regardless of the text.
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Before selecting one of the alternatives, try highlighting the object used by the alternative 
step and replaying it. This way you'll make sure the alternative step is replaying the 
necessary action.

Modify the Object Identification Method 

You can modify the way TruClient identifies the object by modifying the object identification 
method in the Object section of the step properties. The following options are available:

• Automatic. TruClient's default object identification method. The Automatic method 
allows TruClient to use its internal advanced algorithms to locate the object. If this 
method does not successfully find the object during replay, click the Improve Object 
Identification button and replay the macro again.

• XPath. If Automatic identification fails, even after using Improve Identification or 
Related Objects (described below), try using the XPath identification method. This 
method identifies the object based on an XPath expression that defines the object in the 
DOM tree. Click the drop-down arrow next to the XPath edit box to select a suggested 
XPath for the object. You can manually modify the suggested path. 

For example, if you need to select the first search result, regardless of the term being 
searched for, using XPath identification may help.

• JavaScript. JavaScript code that returns an object. For example: 
document.getElementById(“SearchButton”) returns an element that has a DOM ID 
attribute of “SearchButton.”

Using the JavaScript identification method, you can write JavaScript code that references 
the returned document and can use CSS selectors and other standard functions.

For example, the page returned by the server contains multiple links with the same “title” 
attribute (search results) and we want the script to randomly click on one of the available 
links.

Object identification for this case, using the JavaScript identification method, may look 
something like this:

var my_results = document.querySelectorAll('a[title="SearchResult"]');

random(my_results);

Modify the macro timing 

Sometimes objects may not be found because of timing and synchronization issues. For 
example, the macro may be looking for an object that was in the application, but the macro 
replayed too quickly and already progressed to another page. If you suspect that the object is 
not being found because of a timing or synchronization issue, you can insert Wait steps. For 
more information, see Debugging Macros on page 222.

Relating objects to other objects 

If the Improve Object Identification function does not solve the issue and neither do any of the 
alternative steps, try using the Related Objects option.

If an object becomes difficult to identify on its own, you can label the object based on a 
different, more stable object. For example, you can select an object that is not dynamic and 
“relate it” to the target object. Relations are defined visually, relating objects according to 
their distance in pixels from other objects. Relations are defined per ID method, per object. If 
more than one relation is defined for an ID method of a given object, both relations must 
locate the same object for the step to pass. VuGen then uses this object to help locate the 
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target object. To use this function, expand the step, select Object → Related Objects, and click 

Add . Follow the directions to create a relation. Verify that it has worked by highlighting 
both the object and its related object.

Tips:

• Use this feature only if other identification methods have failed as it may be more 
resource intensive.

• Use the minimum search area to improve performance.

• Related Objects are sensitive to window sizing. Resizing may alter object positions and 
relationships. This should be taken into account.

• Each identification method (Automatic, XPath, and JavaScript) has its own set of related 
objects. These related objects are not shared between identification methods.

• If several relations exist they all need to be found in order for the identification to succeed.

Replacing an object 

If you selected the wrong object during recording, or an object has permanently changed you 
can replace it with a different object without replacing the step. This effectively resets the 
step, deleting changes made to the original step such as relations. Expand the step, select 

Object, and click Replace . Select the new object and replay the macro.

Replace Object will tell TruClient that the object currently referenced in the step is incorrect. 
TruClient will remove any current knowledge of the object and learn the object you select. 
Therefore, you should only use the Replace Object option if the object you used during 
recording was the wrong one.

Inserting and Modifying Loops

Loops repeat selected portions of the macro until certain criteria are met or for a specified 
number of iterations. You can insert loops and loop modifiers from the Functions section of 
the Toolbox.

“For” Loops

For loops perform the steps surrounded by the loop until the end condition is met or the code 
reaches a break statement. Loops arguments use JavaScript syntax. To insert a for loop, 
select Toolbox → Functions → For Loop.

“Break” statements

Break statements indicate that the current loop should end immediately. For example, if a 
break statement is encountered in the second of five iteration in a for loop, the loop will end 
immediately without completing the remaining iterations. To insert a break statement, select 
Toolbox → Functions → Break.

“Continue” statements

Continue statements indicate that the current loop iteration should end immediately. The 
loop condition is then checked to see if the entire loop should end as well. For example, if a 
continue statement is encountered in the second of five iterations in a for loop, the second 
iteration will end immediately and the third iteration will begin. To insert a continue 
statement, select Toolbox → Functions → Continue.
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Script Levels

Some steps you perform while recording are not needed during replay. TruClient removes 
steps it deems to be unnecessary and places them in different script levels. 

For example, a click step that occurs in an area of the application that has no effect is placed 
in level 2. During the replay phase, only steps that are visible are run. The default view 
displays level 1 steps only. To view steps from levels 2 and 3 as well, use the slide bar in the 
home tab. 

In certain cases, you may want to manually change the level of a given step. This can happen 
in cases such as mouse-over steps (which are generally considered unnecessary and assigned 
to level 3). 

The following illustration depicts a small script where the step numbers skip from 1 to 3. Step 
2 is hidden in a different level.

After changing the display settings by using the slide bar, all steps are now displayed and will 
run if replayed in interactive mode.

Alternative Steps

Alternative steps allow you to view instances in which there are multiple ways to perform the 
same action in a step. You can modify such steps to perform the given action to debug or 
enhance your macro. 

Steps that have alternative options are labeled with an alternative step symbol . Click it to 
view the alternative options for that step. Click the desired alternative and select Back.
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The illustration below depicts a step in which the second item in a drop-down list named 
“Kindle Books” was selected. The alternative steps feature gives you the option of defining the 
step based on clicking the link “Kindle Books,” selecting the object “Kindle Books” from the 
drop-down menu, or selecting the second item in the drop-down menu.

Snapshots

TruClient automatically generates snapshots during recording. These snapshots can be 
viewed by hovering the mouse over each step's icon. The snapshots are taken before the step's 
action is implemented. Click each snapshot to display it in a new Firefox tab. Make sure that 
the correct tab is active before replay. 

You can also view snapshots by clicking Snapshot View .

Toolbox

The toolbox enables you to add steps to TruClient macros. The toolbox can be moved by 
dragging it up or down.

User interface elements are described in the following table

Toolbox User Interface Elements 

UI Element Description

Functions Verify. Verify that an object exists in the application. 
Wait. Wait for a specified number of seconds before continuing with the next 
step.
Wait for Object. Wait for an object to load before continuing with the next 
step.
Generic Object/Browser Action. Blank steps that can be inserted and 
manually configured.
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Settings

Click General Settings  to open the General Settings dialog.

Proxy Settings

Proxy settings configured in the TruClient Web Macro Recorder are not used when TruClient 
is launched from the WebInspect Scan Wizard;  TruClient will use whatever proxy settings 
are configured in the Scan Wizard. 

Note: For Internet Explorer and Firefox, TruClient requests during a scan will not be sent to 
the proxy.

Select one of the following:

• Direct Connection (proxy disabled) - Select this option if you are not using a proxy server.

• Auto detect proxy settings - Use the Web Proxy Autodiscovery (WPAD) protocol to locate a 
proxy autoconfig file and configure the browser's Web proxy settings.

• Use Browser Proxy - Use the proxy options configured in your browser's Internet 
connection settings. Select your browser from the list. 

• Configure proxy using a PAC file - Load proxy settings from a Proxy Automatic 
Configuration (PAC) file in the location you specify in the URL box.

Flow Control For Loop. A logical structure that repeats the steps contained in the loop a 
specified number of times. 
If Block. A logical structure that runs the steps contained in the block if the 
condition is met.
• Add else. Click the Add else link to add an else section to your If block. If 

the condition is not met, the steps included in the else section run.
• Remove else. Removes the else section from the If block. Note: If the else 

section contains steps and you click Remove else, the steps are deleted. 
Copy and paste them into the main body of your macro to save them.

Break. Causes the loop to end immediately without completing the current 
or remaining iterations.
Continue. Causes the current loop iteration to end immediately. The macro 
continues with the next iteration.
Catch Error. Catches an error in the step immediately preceding and runs 
the contents of the catch error step. For more information, see Enhancing 
Macros on page 221.
Exit. Exits the iteration or the entire macro depending on the specified 
setting.

Miscellaneous Evaluate JavaScript. Runs the JavaScript code contained in the step. 
Evaluate JS on Object. Runs the JavaScript code contained in the step after 
the specified object is loaded in the application.
Evaluate C. Runs the C code contained in the step.
Comment. A blank step that allows you to write comments in your macro.

Toolbox User Interface Elements  (cont’d)

UI Element Description
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• Explicitly configure proxy - Configure a proxy by entering the requested information.

— Type: Select a protocol for handling TCP traffic through a proxy server. You can choose 
SOCKS4, SOCKS5, or standard.

— Server: Enter the URL or IP address of your proxy server.

— Port: Enter the port number (for example, 8080). 

— Specify Alternative Proxy for HTTPS: Select this option for proxy servers accepting 
HTTPS connections and then provide the requested server and port information.

— Bypass Proxy For: If you do not need to use a proxy server to access certain IP 
addresses (such as internal testing sites), select this option and enter the addresses or 
URLs in the box. Use commas to separate entries.

Snapshot Generation

• Recording snapshots generation - Select Never or Always.

• Replay snapshots generation - Select Never, On error, or Always.

Replay Options

• Maximum time for object-not-found - Specify the maximum number of seconds that the 
macro recorder will wait for the target object of a replay step to appear.

• Interstep interval - Specify the minimum interval (in milliseconds) between steps.

• End-of-network identification timeout - Define the timeout (in milliseconds). The 
end-of-network for a step is recognized when the specified time has elapsed with no 
network activity.

• Clean image cache per user - If you select this option, the image cache will be cleared during 
replay.

Log Level

Select one of the following options:

• Standard logging - Log only warnings and high-level informational messages.

• Extended logging - Log low-level messages, warnings, and high-level informational 
messages.

Logout Detection

Specify the depth used for XPath in logout detection by element. The depth determines the 
number of xpath locators (parents) from the element up to its ancestors.

An element can be located (found) in a page using a path to its location. For example, in the 
following HTML, to locate <div class="painter" id="painterId">, the search can use the 
following: find body, then find div with id painterId, or the search can use find body-> then 
find second div.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">
<html lang="en">
    <head>
        <title>colors</title>
        <meta http-equiv="content-type" content="text/html; charset=utf-8" />
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    </head>
        <body>
            <div class="container">
                <div class="box">
                    <div class="caret" id="red">
                        <span></span>
                    </div>
                </div>
                <div class="number" id="redNumber">0</div>
                <div class="box">
                    <div class="caret" id="green">
                        <span></span>
                    </div>
                </div>
                <div class="number" id="greenNumber">0</div>
                <div class="box">
                    <div class="caret" id="blue">
                        <span></span>
                    </div>
                </div>
                <div class="number" id="blueNumber">0</div>
            </div>
            <div class="painter" id="painterId">Color</div>
            <script type="text/javascript" language="javascript">initialize();</script>
        </body>

    </html>

So when searching through larger html files with more complex structures, the process can 
use either a rigid full xpath, or a loose short xpath. The default value is 3.

Encryption

The settings available for encryption are the same as those available in the standard Firefox 
browser. To view the Firefox documentation on encryption, see http://support.mozilla.com/
en-US/kb/Options%20window%20-%20Advanced%20panel?as=u#w_encryption-tab.

Encrypt Macro

If you select this option, the entire macro file is encrypted when saved. Otherwise, the file is 
saved in plain text, which exposes user names and passwords. This option is selected (ON) by 
default.
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Web Macro Recorder (Session-Based)

A macro is a recording of the HTTP requests that are generated when you navigate through a 
Web site or application using the Web Macro Recorder. You can instruct WebInspect to use 
this recording to enter your Web site and (optionally) navigate through your application.

Any activity you record in a macro will override the scanner settings. For example, if you 
specify a URL in the Excluded URL setting, and then you actually navigate to that URL when 
creating a macro, the scanner will ignore the exclusion when it replays the macro.

When starting a Web site assessment with the WebInspect Scan Wizard, you have two 
opportunities to specify a macro:

• Workflow-Driven Assessment: WebInspect audits only those URLs included in the macro 
that you previously recorded and does not follow any hyperlinks encountered during the 
audit. This type of macro is used most often to focus on a particular subsection of the 
application. A logout signature is not required. This type of macro is used most often to 
focus on a particular subsection of the application.

• Site Authentication: The macro specifies a log-in page and contains a user name and 
password that allows you to log on to the target site. The macro must also contain a 
“logout condition,” which indicates when an inadvertent logout has occurred so 
WebInspect can rerun this macro to log on again.

Note that when you play a macro, the HP scanner will not send any cookie headers that may 
have been incorporated in the recorded macro.

Creating a Macro

Follow the steps below to create a macro:

Task 1: Prepare the Web Macro Recorder

1 Close all browsers. 

2 Start the Web Macro Recorder. 

3 Click Edit → Settings to configure general settings and proxy settings. 

4 You can exclude the recording of requests containing certain objects by selecting Filter 
Rules from the Macro Recorder’s View menu. See Filter Rules on page 241 for more 
information. 

Task 2: Browse the Web Site

1 Do one of the following:

• Select File → New.

• Click the New icon on the toolbar. 

• Click the Record icon.

2 Using the browser’s Address bar, enter or select a URL. 

Note: Internet Explorer version 7 and the .NET Framework are hard-coded 
not to send requests for localhost through any proxies. Therefore, the Web 
Macro Recorder will not receive such traffic. This is a documented Microsoft 
defect. To access a site on “localhost” when using IE7, place a period or dot 
after “localhost” (for example, http://localhost.:8080/test.html). 
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3 Browse the pages that you want to include in your macro. 

4 If you want to include a login, be sure to navigate to a page that requires Web form 
authentication. Then enter a valid user name and password, and submit the data (usually 
by clicking a button such as Log On, Go, Submit, etc.). 

5 When finished, close the browser. 

Task 3: Finish the Macro

1 When you close the browser, a dialog box displays the message:

“Are you recording a login macro? (By clicking Yes, auto-detection of the logout condition 
will be performed.)” 

Explanation: When a scanner encounters a hyperlink to another resource, it navigates to 
that URL and continues its assessment. If it follows a link to a logout page (or if the server 
automatically logs out a client after a certain number of minutes), the scanner will not be 
able to visit additional resources where the client is required to be logged in. When this 
inadvertent logout occurs, the scanner can either run this macro to log in or request user 
intervention. In either case, the process hinges on the scanner’s ability to recognize when 
it is no longer logged in.

— Click Yes if you want the Web Macro Recorder to analyze the recorded sessions and 
attempt to detect a “logout” condition.

— If you do not require a “logout” condition, click No and go to Step 6.

— If you want to specify a condition manually, click No and go to Step 3.

— If your application uses URL rewriting or post data techniques to maintain state 
within a Web site, click No. See URL Rewriting and Request Parameters on page 236 
for further instructions.

2 If the attempt to detect a logout condition is successful, a dialog box displays the following 
message:

“Would you like to test your login macro?”

a To bypass the test, click No. Go to Step 3. 

b To test the macro, click Yes. 

c On the Test Login Macro window, the Address box contains the URL of a page believed 
to be viewable only after logging in. If this is, indeed, a “protected”” page, click Go. 
Otherwise, enter the URL of a protected page.

d Browse to various sections of the site to verify that you are logged in. 

e Log out and verify that you are prompted to replay the macro. 

f Click Done. 

3 If the attempt to detect a logout condition is not successful, or if you elected to bypass the 
auto-detect feature: 

a On the Sessions tab, select a session that you accessed after logging in and click Detect 
Logout Condition (on the toolbar). Do not select the session where you actually logged 
in. 

b If the Macro Recorder is unable to determine the logout condition, try selecting other 
sessions. 

If recording a login macro, do not log out before closing.
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c If the Macro Recorder is still unable to determine a logout condition, you can 
manually enter one. Click Edit Logout Condition and, on the Logout Condition Editor 
window, select either Use Regular Expression Extensions or Use Text Matching. 

4 For a login macro, you may want to delete extraneous sessions (i.e., those not related to or 
required by the login procedure). To do so, remove the check mark from the unneeded 
sessions. You should then click Test Login Macro to ensure that you retained all necessary 
sessions. 

5 Specify which action the scanner should take if it detects that it has logged out of the 
application. Click either Play Macro or Launch Interactive (which will allow you to manually 
log back in). 

6 To save the macro, click File → Save (or Save As) or click .

Editing the Logout Condition

You can create or edit the criteria used by the Web Macro Recorder to detect a “logged out” 
condition.

To access the feature, click Edit Logout Condition.

If detection of a logout is not required, select Do no use logout condition. Otherwise, you can 
instruct the Web Macro Recorder to use either a regular expression or text matching.

Regular Expression Extensions

If you want the Web Macro Recorder to use a regular expression to detect a logged out 
condition:

1 Select Use Regular Expression Extensions for a logout signature. 

2 Type (or edit) a regular expression that identifies a unique text or phrase that occurs in 
the server’s HTTP response when a user logs off or when a user who is not logged on 
requests access to a protected URL.

For example, if your server returns a message such as “Have a nice day” when a user logs 
off your application, then enter “Have\sa\snice\sday” as the regular expression (“\s” is 
used in regular expressions to denote a space). 

The scanner can also detect that it has logged off if the server sends a specific message in 
response to the scanner’s attempt to access a password-protected URL. For example, the 
server may respond with a status code of “302 Object moved.” In this case, 
“[STATUSCODE]302 AND [ALL] http://login.myco.com/config/mail?” might be a typical 
regular expression.

3 Click OK.

Note: If you select Launch Interactive, the scanner pauses the scan and presents a 
dialog allowing you to enter log-in information. This is useful when scanning a site 
that incorporates a CAPTCHA (i.e., a challenge-response test placed within Web 
forms to ensure that the response is not generated by a computer). This feature is 
also used when the Web Macro Recorder is not able to determine a logout condition 
and the user is not able to define the condition using regular expressions or text 
matching.
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Text Matching

This technique for recognizing “logged out” or “logged in” state assumes that you know that 
certain text strings will be displayed when either condition occurs. For example, a site may 
display pages that contain the text “Log In” (usually a hyperlink) whenever a user is not 
logged in. Similarly, the site may display pages containing text such as “Sign Out,” “Log Out,” 
or “Log Off” when the user is logged in. 

1 Select Use text matching to determine logged-in state.

2 Under the Text fragments that indicate logged out state column, click Add. 

3 In the pop-up window that appears, enter a text string and click OK. For example, you 
might enter “Log In” or “sign in”; note that the search is not case-sensitive.

4 Repeat Step 2-3 if additional or alternative text fragments are also present during a 
“logged out” state.

5 In the Number of text fragments to match box, enter the number of specified strings that 
must exist on a page before the Web Macro Recorder considers that page to be in a “logged 
out” state.

6 Under the Text fragments that indicate logged in state column, click Add. 

7 In the pop-up window that appears, enter a text string and click OK. For example, you 
might enter “Log Out” or “Sign out.”

8 Repeat Step 6-7 if additional or alternative text fragments are also present during a 
“logged in” state.

9 In the Number of text fragments to match box, enter the number of specified strings that 
must exist on a page before the Web Macro Recorder considers that page to be in a “logged 
in” state.

10 (Optional) Click Advanced.

a In the pop-up dialog, enter a URL that should be used to evaluate the state if a page 
does not contain enough text fragments.

b Click OK.

11 Click OK.
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URL Rewriting and Request Parameters

If your application uses URL rewriting or request parameters to maintain state within a Web 
site, select the State tab.

You must identify which parameters are used for state management. For example, a PHP4 
script can create a constant of the session ID named SID, which is available inside a session. 
By appending this to the end of a URL, the session ID becomes available to the next page. The 
actual URL might look something like the following:

.../page7.php?PHPSESSID=4725a759778d1be9bdb668a236f01e01

Because session IDs change with each connection, a recorded macro containing this URL 
would create an error when you tried to replay it. However, if you identify the parameter 
(PHPSESSID in this example), then the scanner will replace its assigned value with the new 
session ID obtained from the server each time the connection is made. 

Similarly, some state management techniques use post data to pass information. For 
example, the HTTP message content may include userid=slbhkelvbkl73dhj. In this case, 
“userid” is the parameter you would identify to the Web Macro Recorder.

The Web Macro Recorder can identify potential parameters if they occur as posted data or if 
they exist within the query string of a URL. However, if your application embeds session data 
in the URL as extended path information, you must provide a regular expression to identify it. 
In the following example, “1234567” is the session information:

http://www.onlinestore.com/bikes/(1234567)/index.html

The regular expression for identifying the parameter would be:

/\([\w\d]+\)/

1 To enter a regular expression, click Regex and then use the Regular Expression Editor to 
create an expression. When you click OK (on the regular Expression Editor), the 
expression is added to the Type/Name list.

Note: You need to identify parameters only when the application uses URL rewriting, posted 
data or query parameters to manage state. It is typically not necessary when using cookies to 
manage state. Exception: Delete (uncheck) any cookie that is required for normal operation.
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2 Select a parameter in the Type/Name list (such as “login” in the preceding illustration).

3 Click Apply.

4 To save the macro, select File → Save (or Save As) 
-or-

click . 

Inspecting and Editing a Macro

As you navigate through the target Web site, the Web Macro Recorder transcribes each 
session, displaying on the Sessions tab the method and URL associated with each HTTP 
request sent to the server.

1 Select a session on the Sessions tab.

If the associated HTTP response includes “text” or “password” input controls, their name 
and type are displayed in the lower pane.

In this example, the form and the controls were rendered by the following HTML 
statements:

<form name="loginForm" action="/servlet/Login" method="POST">

<input type="text" size="16" name="USERNAME" value="">

<input type="password" size="16" name="PASSWORD">
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2 You can designate a control as a “Smart Credential” user name or password. Right-click 
the control name and select an option from the shortcut menu, as shown below.

If you start an assessment using a macro that includes Smart Credentials, then when you 
scan the page containing the input elements associated with these entries, the scanner 
will substitute the password specified in the Authentication options (or, if no user name is 
specified, the name of the current Windows user). This allows you to create the macro 
using your own user name and password, yet when someone else runs the scan using this 
macro, the scanner will submit that user’s name and password.

3 If you click the Advanced button, the Web Macro Recorder displays the contents of the 
HTTP request and response in separate panes.

4 You can also edit an HTTP request if, for example, you need to change or remove headers, 
or edit passwords or user names. Simply right-click a session and select Edit with HTTP 
Editor from the shortcut menu to launch the HTTP Editor.
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5 You can exclude a specific session from the macro by clearing its associated check box, or 
you can delete a session by selecting the session and clicking the red X on the right side of 
the Sessions list (or by right-clicking a session and selecting Delete Session from the 
pop-up menu).

Session-Based Web Macro Recorder Settings

Follow the steps below to modify the Web Macro Recorder settings:

1 Click Edit → Settings.

2 Select either the General or Proxy category (described below) and enter the settings.

3 Click OK.

General

Proxy Listener

The Web Macro Recorder serves as a proxy that handles HTTP traffic between a browser and 
a target Web site. By default, it uses the local IP address 127.0.0.1 and any available port. 
However, you can specify a different IP address and port.

To avoid the possibility of specifying a port that is already in use, select Automatically Assign 
Port.

Save Files in clear text

Select this option if you do not want to save macros in an XML format using Base 64 encoding 
(which is the default). Saving files in clear text allows you to read the XML tags. The actual 
data, however, is not rendered in ASCII format and is not human readable.

Keep window always on top

Select this option to keep the Web Macro Recorder displayed on your screen when you switch 
programs or windows.

Keep params as state only during macro playback

This option affects how the Post and Query parameters in the State tab are used. If this 
setting is off, then the Post and Query parameters that are checked are imported into the scan 
settings in the HTTP Parameters Used For State list. If this setting is on, then the Post and 
Query parameters that are checked are used as state only during the playback of the macro 
being recorded.

Automatically follow redirects during playback

If this option is selected, then for any sessions in the macro being recorded that result in a 
redirect (a 301 or 302 status code, for example), the new redirect will automatically be 
followed when the macro is played back. The session that is recorded (that is the result of the 
redirect) will not be played back. 

Prompt for credentials when websever requests authentication

If you select this option, the Web Macro Recorder displays a dialog allowing you to enter a 
user name and password whenever the server requires authentication to access a site (that is, 
whenever the server returns a “401 Unauthorized” status). 
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Note: Certain AJAX, Flash, and ActiveX controls may elicit a 401 status code when 
authentication, in fact, is not required. You can recognize this situation when the Web Macro 
Recorder prompts for credentials, but a browser accessing the site does not. For sites where 
this occurs, this option should not be selected. 

Advanced HTTP Parsing

Most Web pages contain information that tells the browser what character set to use. This is 
accomplished by using the Content-Type response header (or a META tag with an 
HTTP-EQUIV attribute) in the HEAD section of the HTML document. For pages that do not 
announce their character set, you can specify which character set the Web Macro Recorder 
should use. 

Proxy

Use these settings to access the Web Macro Recorder through a proxy server.

Direct Connection (proxy disabled)

Select this option if you are not using a proxy server.

Auto detect proxy settings

If you select this option, the Web Macro Recorder will use the Web Proxy Autodiscovery 
Protocol (WPAD) to locate a proxy autoconfig file and use this to configure the browser’s Web 
proxy settings.

Use Internet Explorer proxy settings

Select this option to import your proxy server information from Internet Explorer.

Use Firefox proxy settings

Select this option to import your proxy server information from Firefox.

Configure proxy using a PAC File URL

Select this option to load proxy settings from a Proxy Automatic Configuration (PAC) file. 
Then specify the file location in the URL box.

Explicitly configure proxy

Select this option to access the Internet through a proxy server, and then enter the requested 
information

1 In the Server box, type the URL or IP address of your proxy server, followed (in the Port 
box) by the port number (for example, 8080).

2 Select a protocol for handling TCP traffic through a proxy server: SOCKS4, SOCKS5, or 
standard.

3 If authentication is required, select a type from the Authentication list. See Authentication 
on page 110 for a description of the available authentication types.

4 If your proxy server requires authentication, enter the qualifying user name and 
password.
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5 If you do not need to use a proxy server to access certain IP addresses (such as internal 
testing sites), enter the addresses or URLs in the Bypass Proxy For box. Use commas to 
separate entries.

HTTPS Proxy Settings

For proxy servers accepting HTTPS connections, select Specify Alternative Proxy for HTTPS and 
provide the requested information.

Web Macro Recorder Menus

The Web Macro Recorder contains the following menus:

File

• New—Launch Internet Explorer and begin recording.

• Open—Load a previously recorded macro for editing.

• Save—Save a macro.

• Save As—Save an edited macro under a different file name.

• Exit—Close Web Macro Recorder.

Edit

• Cut—Delete the selected string and save it to the clipboard. 

• Copy—Copy the selected string to the clipboard.

• Paste—Insert contents of the clipboard.

• Edit with HTTP Editor—Open the HTTP Editor and load the selected session.

• Delete Session—Remove the selected session from the macro.

• Start Capture—Begin recording HTTP requests.

• Stop Capture—End recording to HTTP requests.

• Find—Specify a string and search for it when using the Advanced view.

• Settings—Modify Web Macro Recorder settings.

View

• Launch Browser—Open Internet Explorer to navigate through Web site.

• Test Login Macro—Open the Test Login Macro window to verify creating of a logout 
condition.

• HTTP Editor—Open the HTTP Editor.

• Toolbars—View or hide the Detect Logout Condition, Test Login Macro, and Advanced 
buttons.

• Filter Rules—Select a resource type or status code to exclude. For example, sessions where 
the server response contains an HTTP status code of “404 Object Not Found” are normally 
not useful. Similarly, sessions that request images are normally not necessary when 
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creating a macro, and simply add clutter to the session list. By selecting Images from the 
Filter Rules list, you avoid the needless recording of sessions such as GET http://
www.mywebsite.com:80/services.gif.

• Advanced—View or hide panes that display the contents of HTTP requests and responses. 
Note that when editing a saved macro, pages will not be rendered in the Browser tab.

Help

• Web Macro Recorder Help—Open the Help file to the default topic.

• Index—Open the Help file, displaying the index pane.

• Search—Open the Help file, displaying the search pane.

• About Web Macro Recorder—Open a window that displays information about the Web 
Macro Recorder.
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Web Macro Recorder (Event-Based)

A macro is a recording of the events that occur when you access and log in to a Web site using 
the Event-Based Web Macro Recorder. You can subsequently instruct the HP scanner 
(WebInspect or QAInspect) to begin a scan using this recording.

A login macro should contain events recorded during a login procedure and incorporates logic 
that will prevent WebInspect from terminating prematurely if it inadvertently logs out of 
your application. When scanning a site, WebInspect analyzes every server response to 
determine the state. If the scanner determines at any time that it is logged out, it runs this 
macro to log in, and then resumes crawling or auditing the site at the point where the logout 
occurred. When beginning a scan through the WebInspect scan wizard, you can specify a login 
macro at Step 2 under Site Authentication.

You can access the event-based Web Macro Recorder in several ways:

• When starting a site scan, select Site Authentication (on Step 2 of the WebInspect Scan 
Wizard) and click Record.

• On the WebInspect toolbar, click Tools → Web Macro Recorder.

• In default scan settings, click Scan Settings → Authentication → Use a login macro.

• From the Windows Start menu: Click Start → HP → HP Security Toolkit → Web Macro 
Recorder.

 Recording a Log-In Macro

After opening the Web Macro Recorder, use the following procedure to record a log-in macro.

1 Select File → New → Login Macro. 

2 Click Record. 

3 In the Address box, enter the URL of the target Web site and click  (or press Enter). 

The Web Macro Recorder renders the resource like a browser and records each event on 
the Events tab in the dockable pane positioned (by default) at the bottom of the window.

4 If necessary, navigate to the login screen. 

5 Enter a valid user name and password, and submit the credentials (usually by clicking a 
button such as Log On, Go, Submit, etc.). 

6 Click Stop (to the right of the Address bar) or Stop Recording (on the Status bar). 

7 When prompted to play your macro, click OK. 

The macro plays by sequentially executing each enabled event listed on the Events tab. A 
message prompts you to either confirm the success of the macro and specify a logout 
condition or (assuming that the macro was not successful) troubleshoot the macro.

8 Do one of the following:

• To specify a logout condition, select Yes and click Finished. Go to Specifying a Logout 
Condition (below). 

• To troubleshoot, select No and click Next. Go to Troubleshooting a Macro on page 244. 
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 Specifying a Logout Condition

1 Navigate to a page where you are logged out (usually by clicking a button such as Log Out, 
Log Off, or Exit). 

2 Do one of the following: 

• If the browser always displays this page when you log out, click This page displays 
when I have logged out (on the Selection Mode bar that appears directly under the Web 
Macro Recorder toolbar). 

• If the browser displays a page that contains an element or control that appears only 
when you are logged out, click Select Logout Indication (on the Selection Mode bar) and 
then click the element or control. For example, if a Login button appears when you 
have logged out, click Select Logout Indication and then click the Login button. Your 
selection appears on the Logout Elements tab.

• If you want the scanner to search each page for a condition that matches a regular 
expression that you create, click Add logout regex. See Regular Expression Editor on 
page 168 for details. 

3 Select File → Save (or Save As). 

Note: You can specify a logout condition at any time by clicking Actions → Add Logout 
Condition.

Specifying a Confirmation Element

After creating the macro, you may optionally identify a “confirmation element” that indicates 
that you have logged in successfully. This is particularly useful for those sites that, following 
a successful login, display a specific element or control on every page. Some sites, for example, 
always present a “Log Out” button after the user has logged in. Identifying this confirmation 
element increases the probability that WebInspect will be able to recognize the “logged in” 
condition.

Once you identify a confirmation element, if the scanner does not detect that element on the 
page, it assumes the macro has failed and will attempt to replay the macro up to three times. 
If the confirmation hint is not detected during one of these playbacks, the scanner produces 
and error and stops trying to use the macro. 

1 Navigate to a page that appears after you log in.

2 Click Actions → Add Confirmation Element.

3 Do one of the following:

• If this page always appears after you log in, select This page displays when I have logged 
in.

• Click Select Confirmation Element and then click an element on the page that appears 
only when you are logged in.

Troubleshooting a Macro

When troubleshooting your recorded macro, you have the following choices:

• Replay Macro - Try this solution first. The Web Macro Recorder normally plays the macro 
at the fastest possible speed, which may compromise performance. Use the slider to select 
either Fast (which is half the speed at which the macro was recorded) or Original (which 
mimics the speed at which the macro was originally recorded). 
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• Switch to Traffic Mode - This closes the Event-Based Web Macro Recorder and opens an 
alternate web macro recorder that attempts to create macros by analyzing the http traffic. 
This tool was included with WebInspect version 8.1 and earlier. 

• Adjust macro hints - Allows you to add or change confirmation elements and/or logout 
conditions.

• Re-record Macro - This choice deletes all data and returns you to the beginning point, 
where you can try again to create a successful macro. 

Dynamic Challenge/Response Authentication

Challenge-response authentication is a family of protocols in which the server presents a 
question (the challenge) and the client must provide a valid answer (the response). The 
simplest example is where the challenge asks for a password and the valid response is the 
correct password.

Many Web sites now present multiple challenges to the user. Typically, when a user first 
registers with a Web site, the site presents a list of questions to which the user provides 
answers that will be used for subsequent authentication. For example:

• What is your favorite color?

• What was the name of your first pet?

• In what town or city were your born?

• What was the make of your first automobile?

When the user later attempts to log in, the Web site presents two or more of these challenges. 
Some sites also create groups of challenges, and present questions from different groups on 
each subsequent log-in attempt,

For instructions on building a macro that can accommodate this technique, see the on-line 
Help.

Editing a macro

After recording a macro, you can modify its contents by excluding certain events.

For example, if you entered the wrong validation credentials while attempting to log in, and 
then entered the correct credentials, you can remove the erroneous log-in events simply by 
clearing the check box (in the Include column of the Events tab) next to the event you want to 
exclude.

Ordinarily, the best practice is to re-record the macro instead of editing it. However, for an 
extremely lengthy or complex macro, you can first attempt to modify it. Excluded events are 
not actually removed until you save the macro, so be sure to test the modified macro (by 
playing it) before you save it. 
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You might also need to add events for those situations where events are not recorded (such as 
login elements located in an I-frame).

The Web Macro Recorder events are defined in the following table.

Example: Adding Elements for I-Frame Login

The most frequently encountered failure to record a login macro occurs when the login 
elements are contained within an iframe. During recording, you might enter a user name and 
password, and then click the Signin button, but nothing occurs when you play the macro.

You can edit the recorded events or you can begin by recording a new macro. If you edit the 
recording:

1 Click Stop (on the Status bar).

2 Deselect (remove the checks marks next to) those events that occur after the page is 
loaded.

Create an event for the user name element

1 Right-click the WaitForPageLoad event and select Insert new event here from the shortcut 
menu.

2 On the Event Properties dialog, click the drop-down arrow on the Type list and select Click.

3 Click Locate an Element (at the bottom of the dialog).

4 Move the mouse pointer to and click on the user name element (which may be labeled 
“name,” “user,” “e-mail address” or other such identifier).

5 When the Event Properties dialog displays information about the element, click OK.

Note that the event is added after (following) the event on which you clicked.

Add a value to the user name element

1 Right-click the event that you just added and select Insert new event here from the shortcut 
menu.

Event Definition 

WaitForPageLoad Wait for the browser to complete the processing of pages. 

NavigateTo Navigate to the specified URL. 

WaitForElement Wait for element to be rendered on current page. This is used most 
often to render cascading menus. 

WaitNumberOfSeconds Pause for a specific number of seconds. 

Click Simulate a mouse click on an element.  

MouseUp Simulate any mouse button being released over an element. 

MouseDown Simulate any mouse button being pressed while the pointer is over 
an element. 

SetValue Simulate entering a value associated with an element. 

JavaScript Execute JavaScript. 
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2 On the Event Properties dialog, select SetValue from the Type list.

3 Click Locate an Element (at the bottom of the dialog).

4 Click the user name element.

5 On the Event Properties dialog, enter a user name in the Value box and click OK.

Create an event for the password element

1 Right-click the event that you just added and select Insert new event here from the shortcut 
menu.

2 On the Event Properties dialog, select Click from the Type list.

3 Click Locate an Element (at the bottom of the dialog).

4 Click the password element.

5 When the Event Properties dialog displays information about the element, click OK.

Add a value to the password element

1 Right-click the event that you just added and select Insert new event here from the shortcut 
menu.

2 On the Event Properties dialog, select SetValue from the Type list.

3 Click Locate an Element (at the bottom of the dialog).

4 Click the password element.

5 On the Event Properties dialog, enter a password in the Value box and click OK.

Submit the user name and password

1 Right-click the event that you just added and select Insert new event here from the shortcut 
menu.

2 On the Event Properties dialog, select Click from the Type list.

3 Click Locate an Element (at the bottom of the dialog).

4 Click the submit element (which may be labeled “Submit,” “Sign In,” or other such 
identifier).

5 On the Event Properties dialog, click OK.

Dynamic Challenge-Response Authentication

Challenge-response authentication is a family of protocols in which the server presents a 
question (the challenge) and the client must provide a valid answer (the response). The 
simplest example is where the challenge asks for a password and the valid response is the 
correct password.

Many Web sites now present multiple challenges to the user. Typically, when a user first 
registers with a Web site, the site presents a list of questions to which the user provides 
answers. For example:

What is your favorite color?
What was the name of your first pet?
In what town or city were your born?
What was the make of your first automobile?
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When the user later attempts to log in, the Web site presents two or more of these challenges. 
Some sites also create groups of challenges, and dynamically present questions from different 
groups on each subsequent log-in attempt, as demonstrated in the following example.

When registering for the following example Web site, the user is asked to provide answers to 
nine questions, which are arranged into three groups of three questions each, as follows.

Group 1

“What is your name?”, “Smith”
“What is your favorite color?”, “blue”
“What is the name of your first grade teacher?”, “Williams”

Group 2

“What is your mother's maiden name?”, “Larrimore”
“In what state were you born?”, “Delaware”
“What is the name of your favorite pet?”, “Rusty”

Group 3

“Why?”, “Albatross”
“What is your paternal grandmother's first name?”, “Esther”
“What is the capital of the state you live in?”, “Atlanta”

In this example, the application randomly selects a number between 1 and 3 (inclusive) and 
then displays the corresponding ordinal question (first, second, or third) from each group.

1 Start the Web Macro Recorder, click Record, and enter the URL of the log-in page.

The source code for pertinent area of the form is:

<label for="Q1"> What is your name?</Label><input id="Q1" name="Q1" /> <br>

<label for="Q2"> What is your mother's maiden name?</Label><input id="Q2" 
name="Q2" /> <br>

 label for="Q3"> Why?</Label><input id="Q3" name ="Q3"/> <br><input type="submit" 
value="Login" /
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This illustrates that the label for each question is Q1, Q2, and Q3; similarly, the ID and 
name for each text box into which the user enters the response is Q1, Q2, and Q3.

2 On the log-in page, enter a value for each input element and click Login.

3 Assuming that you logged in correctly, click Stop.

4 When prompted to play your macro, click Cancel.

To modify the macro so that it accommodates a random presentation of authentication 
questions:

1 Navigate to the log-in page.

2 Click the Events tab.

3 Right-click the first SetValue element and choose Select security question for this 
element. 

a Click Select Security Question (just below the toolbar).

b Click on the label for the first security question (in this example, “What is your 
name?”).

The Question-Answer Groups dialog appears.

c In this example, we know that the first question is a member of the Q1 group. So click 
the Add button, enter “Q1” in the Group Name box, and click OK.

Note: If your program does not divide questions and answers into groups, but presents 
the same set of questions at each log-in attempt, ignore the Group Name controls.

d Click Click here to add new question/answer pair.

e Enter the first question and answer pair. In this example:

Question: What is your name?

Answer: Snouck

f Repeat Steps 3d-3e, entering the second and third question/answer pair in Group 1.

g Click OK.

Note that a Sec. Questions column is added to the Events tab.

h Click the drop-down arrow for this element in the Sec. Questions column on the Events 
tab and select Q1.

4 Right-click the second SetValue element and choose Select security question for this 
element. 

a Click Select Security Question (just below the toolbar).

b Click on the label for the second security question (in this example, “What is your 
mother's maiden name?”).

c Click the drop-down arrow for this element in the Sec. Questions column on the Events 
tab and select Manage.

d On the Question-Answer Groups dialog, click Add, enter a group name of “Q2” and 
click OK.

e Add the three security question/answer pairs for the Q2 group, following the 
procedure outlined in Step 3.

5 Right-click the third SetValue element and choose Select security question for this element. 

a Click Select Security Question (just below the toolbar).
WebInspect Enterprise Tools 249



b Click on the label for the third security question (in this example, “Why?”).

c Click the drop-down arrow for this element in the Sec. Questions column on the Events 
tab and select Manage.

d On the Question-Answer Groups dialog, click Add, enter a group name of “Q3” and 
click OK.

e Add the three security question/answer pairs for the Q3 group, following the 
procedure outlined in Step 3.

6 Click Play to test the macro.

When troubleshooting the macro, it is usually helpful to right-click an entry on the Events tab 
and select Playback macro to this event.

Logout Elements

When the Playback Successful? dialog appears, the first of three messages at the bottom of the 
dialog pertains to logout conditions. These are elements, pages, or regular expressions that 
indicate to the Web Macro Recorder (and the scanner) that the user is no longer logged in to 
the site or application.

If the message is “Logout conditions have been specified for this macro,” the Web Macro 
Recorder has recognized the logout condition you specified.

However, if the message is “Unable to auto-detect logout conditions,” then either:

• You did not instruct the Web Macro Recorder to automatically detect logout elements (see 
Settings). 

• The Web Macro Recorder was unable to auto-detect elements. 

• You did not manually specify a logout condition.

To correct this defect, click Edit → Settings → Auto-Detection and do one of the following:

• Select Auto-detect logout conditions and choose one or more of the standard logout 
elements (or create a custom logout element). 

• Clear Auto-detect logout conditions, click OK to save the settings, and then:

a Click  and select Add Logout Condition. 

b Use the Forward and Back buttons  to navigate to a page that contains a logout 
element. 

c Do one of the following: 

– Click  and then click the page element that appears only when 
you are in a “logged out” condition. 

– If the entire page appears only after the user has logged out, click 

. 

– If you want the scanner to search each page for a logout condition that matches a 

regular expression that you create, click .

To delete a logout condition from the macro, click the Logout Conditions tab (in the Web Macro 
Recorder's lower pane), right-click a condition, and select Delete. 
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Using a Regular Expression for Logout Detection

If you want the scanner (and Web Macro Recorder) to use a regular expression to detect a 
logged out condition:

1 Select Add Logout Regex. 

The Regular Expression Editor opens.

2 Enter a regular expression that identifies a unique text or phrase that occurs in the 
server's HTTP response when a user logs off or when a user who is not logged on requests 
access to a protected URL.

For example, if your server returns a message such as “Have a nice day” when a user logs 
off your application, then enter “Have\sa\snice\sday” as the regular expression (“\s” is 
used in regular expressions to denote a space). 

The scanner can also detect that it has logged off if the server sends a specific message in 
response to the scanner's attempt to access a password-protected URL. For example, the 
server may respond with a status code of “302 Object moved.” In this case, 
“[STATUSCODE]302 AND [ALL] http://login.myco.com/config/mail?” might be a typical 
regular expression. See Regular Expression Extensions for more information.

3 Click OK.

Confirmation Elements (Hints)

When the Playback Successful? dialog appears, the second of three messages at the bottom of 
the dialog pertains to confirmation elements. These are elements or pages that indicate to the 
Web Macro Recorder (and the scanner) that the user is logged in to the site or application.

If the message is “Confirmation elements have been specified for this macro,” the Web Macro 
Recorder has recognized the element that you specified as indicating that the user is logged 
in.

However, if the message is “Unable to auto-detect confirmation conditions,” then either:

• You did not instruct the Web Macro Recorder to automatically detect confirmation 
elements (see Settings). 

• You instructed the Web Macro Recorder to automatically detect confirmation elements, 
but the Web Macro Recorder could not recognize the element you specified (or you failed to 
specify an element). 

• You did not manually specify a confirmation element.

 To correct this defect, click Edit → Settings → Auto-Detection and do one of the following:

• Select Auto-detect confirmation conditions and choose one or more of the standard elements 
(or create a custom element). 

• Clear Auto-detect confirmation conditions, click OK to save the settings, and then:

a Click  and select Add Confirmation Element. 

b Use the Forward and Back buttons  to navigate to a page that contains a 
confirmation element. 

c Do one of the following: 
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– Click  and then click the page element that appears only 
when you are in a “logged in” condition. 

– If the entire page appears only after the user has logged in, click 

.

Unsupported Elements

While recording your macro, the Web Macro Recorder displays a warning if you click an 
unsupported element. These non-HTML elements include objects created using the following 
technologies:

• Applets

• ActiveX

• Silverlight

• Flash

• Cross-Domain Iframes

If these objects are not required components of your macro, there is no problem. The Web 
Macro Recorder simply ignores the object and continues to record events as you generate 
them by navigating through the site.

However, if an unsupported element contains an essential component (such as a login form), 
the macro will not succeed.

You might avoid this issue by switching to the session-based Web Macro Recorder.

Event-Based Web Macro Recorder Settings

Follow the steps below to modify the Web Macro Recorder settings:

1 Click Edit → Settings.

2 Select either the Application or Macro category (described below) and enter the settings.

3 Click OK.

Application Settings

General

Show startup window
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The startup window appears when the Web Macro Recorder is launched and displays a 
shortcut menu that allows you to begin creating or editing a login macro.

Compress macro files

Applies a compression algorithm to reduce the size of the saved macro.

Encrypt macro file

Applies an encryption algorithm to the saved macro to provide security.

Network Authentication Credentials

If network authentication is required, provide a user name and password that will allow 
access to the network.

Troubleshooting

Highlight failed events

If you select this option, the program displays failed events with a background color.

• Red highlight: The macro event caused the macro to fail.

• Orange highlight: The event failed, but playback continued.

Ignore events after final page load

In most cases, the events that occur after loading the final page in the macro are not 
significant and do not affect the playback of the macro.

Auto-Detection

During the recording process, you can manually specify a logout element (an object that 
appears on the page to indicate that you have logged in successfully) and a confirmation 
element. If auto-detection is enabled and the program automatically detects a logout element 
during the recording process, the wizard that appears once playback is complete will reflect 
this and you will not be prompted to select a logout element .

To instruct the Web Macro Recorder to automatically detect elements, select Auto-detect logout 
elements and/or Autodetect confirmation hints.

To identify which of the standard elements will trigger automatic detection, select or clear the 
associated check box next to the element in the Standard list.

To create a custom element:

1 Click Add.

2 In the Value box, enter a text string that appears somewhere within the page.
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3 Click OK. 

The element appears in the Custom list.

4 In the Type column, click the down arrow and select the element type: Confirmation or 
Logout.

Proxy

If you need to use a proxy server to access the target Web site:

1 Select Use Proxy.

2 Enter the IP address or host name of the server.

3 Enter the server's port number.

IE Dialogs

Microsoft's Internet Explorer may sometimes display dialogs that are not related to the actual 
content of the Web page. For example, the browser's security feature may present a modal 
dialog with the following message: “Do you want to view only the webpage content that was 
delivered securely?” If this occurs during playback of a macro, the scanner will halt until the 
user presses Yes or No. You can avoid this interruption by selecting Use IE Dialog Suppression.

Several conditions are defined by default. You may, however, define a condition that meets 
your specific requirements. To do so:

1 Click Add.

2 Enter the requested information. 

• Dialog Caption: Enter the text that appears on the title bar of the dialog box.

• Dialog Text: Enter the text that appears as the message content.

• Button: Enter the text that appears on the button that the macro should 
automatically “press.”

The utility that performs this check is case-sensitive, so be sure to enter the text string 
exactly as it appears. 

3 Click OK.

Macro Settings

General

Smart Credentials

If you start a scan using a macro that includes Smart Credentials, then when you scan the 
page containing the input elements associated with these entries, WebInspect will substitute 
the user name and password specified here. This allows you to create the macro using your 
own user name and password, yet when other persons run the scan using this macro, they can 
substitute their own user name and password.

To enable this feature, you must first record a macro and then associate one SetValue event in 
the Events grid as a user name and another SetValue event as a password.

Replacement URL
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If you select Enable URL Replacement, the host name entered as the Start URL in the Scan 
Wizard will be dynamically inserted into each URL for this macro. For example, suppose you 
record a macro for www.testsite.com. At a later point in time, www.testsite.com is renamed to 
www.testsite2.com. Instead of recording an entirely new macro, you could reuse the original 
one and enable URL replacement.
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Web Service Test Designer

Web services are programs that communicate with other applications (rather than with users) 
and answer requests for information. Most Web services use Simple Object Access Protocol 
(SOAP) to send XML data between the Web service and the client Web application that 
initiated the information request. Unlike HTML, which only describes how Web pages are 
displayed, XML provides a framework to describe and contain structured data. The client Web 
application can readily understand the returned data and display that information to the end 
user.

A client Web application that accesses a Web service receives a Web Services Definition 
Language (WSDL) document so that it can understand how to communicate with the service. 
The WSDL document describes the programmed procedures included in the Web service, the 
parameters those procedures expect, and the type of return information the client Web 
application will receive.

Use the Web Service Test Designer to create a Web Service Test Design file (filename.wsd) 
containing the values that WebInspect should submit when conducting a Web service scan.

Although the following procedure invokes the Web Service Test Designer from the 
WebInspect Tools menu, you can also open the designer from the HP Security Toolkit or 
through the WebInspect Scan Wizard by selecting Start a Web Service Scan from the 
WebInspect Start page and, when prompted, electing to launch the designer.

1 Select Tools → Web Service Test Designer.

2 On the startup dialog, select one of the following:

• New Web Service Test - Design a new Web Service test. 

• Open Web Service Test - Edit a design that you previously created.

The following procedure assumes that you are creating a design.

3 Do one of the following:

• In the Import WSDL box, type or select the URL of the WSDL site and click Import 

WSDL .

Example: http://www.webservicex.net/stockquote.asmx?WSDL.

• Click Browse for WSDL  and select a WSDL file that you previously saved locally. 

If authentication is required, or if SOAP requests need to be made through a proxy server, 
see Web Service Test Designer Settings on page 264 for more information. 

Also note that “Other Services” appears by default. This feature is used to add services 
manually when a service is not associated with a WSDL. See Manually Adding Services 
on page 259 for more information. Remove the check mark next to this item.

“

When the Web Service Test Designer is launched from the WebInspect Scan Wizard, if the 
WSDL has not yet been configured, the designer will automatically import the WSDL, assign 
“auto values” to each parameter, an invoke all operations. This does not occur when you 
launch the tool from the WebInspect Tools menu or from the HP Security Toolkit.
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The WSDL endpoint (typically represented by a simple http URL string) appears in the 
left pane, followed by the service name and a hierarchical listing of the operations defined 
for that service. The right pane (by default) contains the WSDL URL and, when available, 
the namespace, binding namespace, and the port location.

The above illustration shows a simple WSDL that returns the current stock price and 
other related information when the user submits a corporate symbol used by the New 
York Stock Exchange. 

4 Select the service in the left pane to display service overview information in the right 
pane.

Note that if the description of the WSDL includes both SOAP version 1.1 and version 1.2, 
and if the operations in both descriptions are the same, the versions are assumed to be 
identical and the services in version 1.1 only are configured. If you wish to attack both 
versions, then you must select the check box for each version 1.2 operation.
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If authentication is required, select WS Security and provide the required credentials. 

5 Select a service transport in the left pane to display the port information in the right 
pane. A port defines an individual endpoint by specifying an address for a binding.

RPC-encoded services require manual configuration. The Schema Fields tab is populated 
using a default SOAP schema. You can obtain the desired SOAP message from a 
developer or a proxy capture, and then paste the message into the XML tab (or import the 
saved message from a file). You can then click Send to test the operation. 

6 Click an operation to display schema for the request (in the top half of the right pane) and 
the response (in the lower half). 
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7 Enter a value for each parameter in the operation. In this example, the user entered HPQ 
(the NYSE symbol for Hewlett Packard).

If you click Auto Value, the designer assigns a value to the operation. This value is either:

• Obtained from the GlobalValuesDefault.xpr file, if the file contains an entry that 
matches the name of the parameter; see Global Values Editor on page 261 for more 
information.

• Created by the designer, based on the data type. In this example, the designer would 
populate the parameter “symbol” with the value “symbol1.”

See Using Autovalues for more information.

8 Click Send .

Results appear in the lower portion. You can alternate between the Schema and XML 
views by clicking the appropriate tabs.

9 When you have assigned and tested values for each operation (although only one 
operation is depicted in this example):

a Click File → Save.

b Using the standard file-selection dialog, select a name and location for the Web 
Service Design file (.wsd).

If the WSDL contains multiple operations, data is saved for each operation regardless of 
whether or not the operation is checked. A check mark simply indicates that the operation 
will be used for auditing.

Manually Adding Services

You may encounter a Web service that does not have a WSDL associated with it.
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For example, the WebInspect Recommendations module monitors scans to detect omissions, 
abnormalities, or anomalies that interfere with or diminish the thoroughness of a scan. If it 
detects SOAP requests during a Web Site scan, it suggests that you conduct a Web Service 
scan of that site and creates a Web Service Test Design file (filename.wsd) for that purpose. A 
WSDL file probably will not be available.

You may create a service manually, as shown in the following example.

1 Right-click the default “Other Services” service and select Add Service. 

New Service 1 appears in the Web Services tree in the left pane.

2 If authentication is required, select WS Security and provide the required credentials. 

3 Right-click New Service 1, select Add Port. and then choose either SOAP 1.1 or SOAP 1.2. 

New Port 1 appears in the Web Services tree.

4 In the Port URL box, enter the correct URL to the service. 

5 Right-click New Port 1 and select Add Operation. 

Note: To change service, port, or operation names, double-click the name.

6 You can import a file containing a SOAP envelope (possibly obtained using the Web Proxy 
tool) or you can copy and paste a SOAP envelope that you obtained from a developer onto 
the XML tab.

If importing from a proxy capture, the SOAP action will be in the HTTP header 
(Soapaction=<action_name>). 

7 If necessary, modify the values using either the Schema Fields tab or the XML tab. 

8 To test the service, click either Send or Run All.
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Global Values Editor

You can create a library of name/value parameters for operations that you frequently 

encounter. After importing a WSDL file, if you click Set Auto Values , the Web Service 
Test Designer searches the Global Values file for the names of parameters contained in the 
WSDL operations. If it finds a matching name, it inserts the associated value from the file 
into the parameter value field.

To add a global value:

1 Click Edit → Global Values Editor.

The Global Values Editor opens and displays the contents of the default xml parameter 
registry (xpr) file named GlobalValuesDefault.xpr.

2 Click Add. 

This creates an entry with the default name of [Name] and a default value of [Value].

3 Click anywhere on the entry and substitute an actual name and value for the default.

4 Repeat steps 2-3 to create additional entries.

5 Do one of the following:

• Click OK to save and close the file.

• Click Save As to create and close the file using a different file name and/or location.

Importing and Exporting Operations

You can build a library of operations and their assigned values, allowing you to quickly modify 
other Web service designs or exchange these components with other developers/testers. Each 
module is saved as an XML file, such as the following request used in the preceding example:

<Envelope xmlns="http://www.w3.org/2003/05/soap-envelope">

  <Header />

  <Body>

    <GetQuote xmlns="http://www.webserviceX.NET/">

      <symbol>HPQ</symbol>

    </GetQuote>

  </Body>

</Envelope>

To save or import an operation:

1 Select an operation in the left pane. 

2 Click Import Request  to load the operation. 

3 Click Export Request  to save the operation. 
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Using Autovalues

Use the Autovalues feature as an alternative to manually entering specific values for each 
parameter. The Web Service Test Designer analyzes each parameter and inserts a value that 
is likely to fulfill the service requirement. This can save considerable time when dealing with 
large web services.

After selecting a WSDL file:

1 Place a check mark next to each operation you want to autofill.

2 Click Set Auto Values.

The following message appears: “Would you like the default values to be replaced with the 
defined global values?”

If you click Yes, any values you may have entered manually will be erased. Also, if any 
parameter name in any operation matches a parameter name in the Global Values file, 
the associated value in the file will be substituted for the value that would normally be 
generated for the operation. 

If you click No, the function terminates.

3 Click Yes.

4 Click Run All Tests.

The Web Service Test Designer submits the service request, with values inserted for each 
operation.

5 Click the Test Results tab (at the bottom of the window).

6 If an operation returned an error, double-click the operation to open it in the Request 
pane and manually provide a value.

Testing Your Design

You can, at any time, test the configuration of any or all operations.

After importing the WSDL, click Run All Tests.
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The designer attempts to submit all selected operations and displays the results.

To open the special Test Results pane, click Test Results on the Status bar.

The Test Results pane displays the following information:

• Result – The test outcome. Possible values are:

— Valid: The operation succeeded without a server error or SOAP fault. 
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— Not Run: The operation was not submitted because it was not selected (no check 
mark) or the Stop button was pressed before the operation was submitted.

— Pending: The Run button has been pressed but the operation has not yet been 
submitted.

— Failed: The request was unsuccessful, the server returned an error message, or a 
SOAP fault was received.

• WSDL – The WSDL associated with the item

• Service – The service associated with the item

• Port – The port associated with the item 

• Operation – The operation the item represents

• Error Message – Explanation for failure

The Test Results toolbar contains the following buttons:

• Run All – The designer submits the service request for each checked operation.

• Run Selected – The designer submits the service request for operations selected in the 
Test Results pane.

• Stop – cancels the sending of service request.

• Clear – Removes all items from the Test Results pane.

If you double-click an item in the Test Results pane, the designer highlights the related 
operation in the Schema Fields pane, where you can enter values for each parameter.

Web Service Test Designer Settings

The Web Services Designer has two categories of settings:
264 Appendix B



• Network Proxy

• Network Authentication

To access settings, click Edit → Settings.

Network Proxy

1 Select a profile from the Proxy Profile list:

• Direct: Do not use a proxy server.

• Auto Detect: Use the Web Proxy Autodiscovery Protocol (WPAD) to locate a proxy 
autoconfig file and use this to configure the browser's Web proxy settings.

• Use Internet Explorer: Import your proxy server information from Internet Explorer.

• Use PAC File: Load proxy settings from a Proxy Automatic Configuration (PAC) file. 
Then specify the file location in the URL box.

• Use Explicit Proxy Settings: Access the Internet through a proxy server using 
information you provide in the Explicitly Configure Proxy section.

• Use Mozilla Firefox: Import proxy server information from Firefox.

Note: Electing to use browser proxy settings does not guarantee that you will access 
the Internet through a proxy server. If the Firefox browser connection settings are 
configured for “No proxy,” or if the Internet Explorer setting “Use a proxy server for 
your LAN” is not selected, then a proxy will not be used. 

2 If you selected Use PAC File, enter the location of the PAC file in the URL box.

3 If you selected Use Explicit Proxy Settings, provide the following information:

a In the Server box, type the URL or IP address of your proxy server, followed (in the 
Port box) by the port number (for example, 8080).

b From the Type list, select a protocol for handling TCP traffic through a proxy server: 
SOCKS4, SOCKS5, or standard.

c If authentication is required, select a type from the Authentication list:

d If your proxy server requires authentication, enter the qualifying user name and 
password.

e If you do not need to use a proxy server to access certain IP addresses (such as 
internal testing sites), enter the addresses or URLs in the Bypass Proxy For box. Use 
commas to separate entries.

4 Click Save.

Network Authentication

If server authentication is not required, select None from the Method list. Otherwise, select an 
authentication method and enter your network credentials. 
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Server Analyzer

The Server Analyzer interrogates a server to determine the server’s operating system, 
banners, cookies, and other information. 

Analyzing a Server

Follow the steps below to analyze a server:

1 In the Target Host box, enter the URL or IP address of the target server.

2 If host authentication is required, or if you are accessing the host through a proxy server, 
select Edit → Settings and provide the requested information. See Server Analyzer 
Settings for detailed information.

3 Click the Run Analysis icon.

Server Analyzer Settings

Follow the steps below to modify the Server Analyzer settings:

1 Click Edit → Settings.

2 Select either the Host Authentication or Proxy category and enter the settings described in 
the following sections.

3 Click OK.

Authentication Method

If authentication is required, select a type from the Authentication list. See Authentication on 
page 110 for a description of the available authentication types.
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Authentication Credentials

Type a user ID in the User name box and the user’s password in the Password box. To guard 
against mistyping, repeat the password in the Confirm Password box.

To use these credentials whenever the Server Analyzer encounters a password input control, 
select Submit these credentials to forms with password input fields.

Proxy

Use these settings to access the Server Analyzer through a proxy server.

Direct Connection (proxy disabled)

Select this option if you are not using a proxy server.

Auto detect proxy settings

If you select this option, the Server Analyzer will use the Web Proxy Autodiscovery Protocol 
(WPAD) to locate a proxy autoconfig file and use this to configure the browser’s Web proxy 
settings.

Use Internet Explorer proxy settings

Select this option to import your proxy server information from Internet Explorer.

Use Firefox proxy settings

Select this option to import your proxy server information from Firefox.

Configure a proxy using a PAC file

Select this option to load proxy settings from a Proxy Automatic Configuration (PAC) file. 
Then specify the file location in the URL box.

Explicitly configure proxy

Select this option to access the Internet through a proxy server, and then enter the requested 
information

1 In the Server box, type the URL or IP address of your proxy server, followed (in the Port 
box) by the port number (for example, 8080).

2 Select a protocol for handling TCP traffic through a proxy server: SOCKS4, SOCKS5, or 
standard.

3 If authentication is required, select a type from the Authentication list. See Authentication 
on page 110 for a description of the available authentication types.

4 If your proxy server requires authentication, enter the qualifying user name and 
password.

5 If you do not need to use a proxy server to access certain IP addresses (such as internal 
testing sites), enter the addresses or URLs in the Bypass Proxy For box. Use commas to 
separate entries.
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HTTPS Proxy Settings

For proxy servers accepting HTTPS connections, select Specify Alternative Proxy for HTTPS and 
provide the requested information.

Exporting Results

Follow the steps below to export the results of the analysis to an HTML file:

1 Click File → Export.

2 On the Export File window, select or enter a location and file name.

3 Click Save.
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