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Documentation Updates
The title page of this document contains the following identifying information:

l Software Version number, which indicates the software version.

l Document Release Date, which changes each time the document is updated.

l Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using themost recent edition of a document, go
to:

http://h20230.www2.hp.com/selfsolve/manuals

This site requires that you register for an HP Passport and sign in. To register for an HP Passport
ID, go to:

http://h20229.www2.hp.com/passport-registration.html

Or click theNew users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product support
service. Contact your HP sales representative for details.
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Support
Visit the HP Software Support Online web site at:

http://www.hp.com/go/hpsoftwaresupport

This web site provides contact information and details about the products, services, and support
that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and
efficient way to access interactive technical support tools needed tomanage your business. As a
valued support customer, you can benefit by using the support web site to:

l Search for knowledge documents of interest

l Submit and track support cases and enhancement requests

l Download software patches

l Manage support contracts

l Look up HP support contacts

l Review information about available services

l Enter into discussions with other software customers

l Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also
require a support contract. To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html

To findmore information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp
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About the HP Unified Functional Testing
User Guide

TheHP Service Test User Guide describes how to use Service Test to test your applications. It
provides step-by-step instructions to help you create, debug, and run tests, and report defects
detected during the testing process.

Prerequisite Background
This guide is intended for Service Test users at all levels. Readers should already have some
understanding of functional testing concepts and processes, and know which aspects of their
application they want to test.

Topic Types
The content in the Service Test guides is organized by topics. Threemain topic types are in use:
Concepts, Tasks, andReference.

Topic Type Description Usage

Concepts Background, descriptive, or conceptual
information.

Learn general information
about what a feature does.

Tasks Instructional Tasks. Step-by-step
guidance to help you work with the
application and accomplish your goals.

Task steps can be with or without
numbering:

l Numbered steps. Tasks that are
performed by following each step in
consecutive order.

l Non-numbered steps. A list of self-
contained operations that you can
perform in any order.

l Learn about the overall
workflow of a task.

l Follow the steps listed in a
numbered task to complete
a task.

l Perform independent
operations by completing
steps in a non-numbered
task.

Use-case Scenario Tasks. Examples of
how to perform a task for a specific
situation.

Learn how a task could be
performed in a realistic
scenario.

Reference General Reference. Detailed lists and
explanations of reference-orientedmaterial.

Look up a specific piece of
reference information relevant
to a particular context.
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Topic Type Description Usage

User Interface Reference. Specialized
reference topics that describe a particular
user interface in detail. Selecting Help on
this page from the Helpmenu in the product
generally open the user interface topics.

Look up specific information
about what to enter or how to
use one or more specific user
interface elements, such as a
window, dialog box, or wizard.

Troubleshooting
and Limitations

Troubleshooting and Limitations.
Specialized reference topics that describe
commonly encountered problems and their
solutions, and list limitations of a feature or
product area.

Increase your awareness of
important issues before
working with a feature, or if
you encounter usability
problems in the software.

Service Test Help Contents
The Service Test Help includes the following:

Type Included Documentation

Getting to
Know Service
Test
Documentation

l Readme provides the latest news and information about Service Test.
Select Start > All Programs > HP Software > HP Service Test >
Readme.

Note: For details on accessing Service Test tools and files in
Windows 8, see "Accessing Service Test inWindows 8Operating
Systems" on page 33.

l Installation Guides explain how to install and set up Service Test or the
HP Functional Testing Concurrent License Server. Select Help > Service
Test Help and click the link to the appropriate guides from the left pane.

l Tutorials teach you basic Service Test skills and show you how to design
tests for your applications. Select Help > Service Test Tutorial.

l Service Test Product Movies provide an overview and step-by-step
instructions describing how to use selected Service Test features. Select
Help > Product Movies or.

Feature
Documentation

Service Test Help includes:

l HP Service Test User Guide describes how to use Service Test to test
your application.

l HP RunResults Viewer User Guide describes how to use the Run Results
Viewer to view and analyze the run results from your tests or components.

Select Help > HP Service Test Help.
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Additional Online Resources
The following additional online resources are available from the Service Test Helpmenu:

Resource Description

HP Software
Support Site

Opens the HP Software Support Web site. This site enables you to browse
the HP Software Self-solve knowledge base. You can also post to and
search user discussion forums, submit support requests, download patches
and updated documentation, andmore. ChooseHelp > HP Software
Support. The URL for this Web site www.hp.com/go/hpsoftwaresupport.
l Most of the support areas require that you register as an HP Passport

user and sign in. Many also require a support contract.

l To findmore information about access levels, go to:
http://h20230.www2.hp.com/new_access_levels.jsp

l To register for an HP Passport user ID, go to:
http://h20229.www2.hp.com/passport-registration.html

Testing Forums Opens the testing forums for GUI Testing, API Testing, and Business
Process Testing. where you can interact with other users of UFT and
discuss topics related to GUI Testing, API Testing, and Business Process
Testing.

The URLs for these sites are:

l API Testing: http://h30499.www3.hp.com/t5/Service-Test-Support-and-
News/bd-p/sws-Serv_TEST_SF

l Business Process Testing: http://h30499.www3.hp.com/t5/Business-
Process-Validation/bd-p/sws-BPT_SF

Service Test
Product Page

Opens the HP Service Test product page, with information and related links
about Service Test.

Troubleshooting
& Knowledge
Base

Opens the Troubleshooting page on the HP Software Support Web site
where you can search the HP Software Self-solve knowledge base. Choose
Help > Troubleshooting & Knowledge Base. The URL for this Web site
is http://h20230.www2.hp.com/troubleshooting.jsp.

HP Software
Community Site

Opens the HP IT Experts Community site, where you can interact with other
HP software users, read articles and blogs on HP software and access
downloads of other software products.

Manuals Site Opens the HP Software Product Manuals Web site, where you can search
for themost up-to-date documentation for a selected HP Software product.
The URL for this Web site is
http://support.openview.hp.com/selfsolve/manuals (requires an HP
Passport).
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Resource Description

What's New Opens the Service Test What's New Help, describing the new features and
enhancements in this version of Service Test.

Product Movies Opens a page displaying a list of all product movies.

HP Software
Web site

Opens the HP SoftwareWeb site. This site provides you with themost up-
to-date information on HP Software products. This includes new software
releases, seminars and trade shows, customer support, andmore. Choose
Help > HP Software Web site. The URL for this Web site is
www.hp.com/go/software.

You can access the following sample applications from theStartmenu. These applications are the
basis for many examples in this guide:

Mercury Flight application. To access from the Start menu, select All Programs > HP Software >
HP Service Test > Sample Applications > Flight API.
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Accessing Service Test inWindows 8Operating Systems 33

Service Test Testing - Overview
Service Test provides tools for the construction and execution of functional tests for headless
(GUI-less) systems. For example, you can use Service Test to test standardWeb Services, non-
SOAPWeb Services, such as REST, and so on.

You create an API test by dragging and dropping activities from the Service Test Toolbox pane into
the test, displayed in the canvas. The toolbox provides a collection of activities for functional
testing in areas such as REST, Web Services, JMS, and HTTP. You can addmore activities to the
toolbox by importingWSDLs or providing other contract definitions.

For more details about service testing in Service Test, including all of the optional steps included in
the testing workflow, see " Testing Services" on page 372.

Service Test Integrated Testing - Overview

Integration for GUI and API Testing
You can integrate your GUI and service testing processes in a single test by including calls from
your Service Test tests to GUI tests. When you insert a call to another test, the call is displayed as
nested under the relevant action in the canvas.

You insert andmodify calls to GUI tests from API tests by dragging the Call GUI Action or Test
onto the canvas from the HP Automated Testing Tools node in the Toolbox pane. For more details,
see "How to Call Tests from Other Applications" on page 411.
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Integration with ALM
You can also use Service Test together with ALMtomanage the entire testing process. For
example, you can use ALM to:

l Create a project (central repository) of manual and automated tests

l Build test cycles

l Run tests

l Report and track defects

You can also create reports and graphs to help you review the progress of test planning, runs, and
defect tracking before a software release.

Tests and components created in Service Test can be saved directly to your ALM project, and you
can run Service Test tests and review andmanage the results in ALM. For details see "ALM
Integration" on page 322, and theHP Application Lifecycle Management User Guide.

Note: Unless otherwise specified, references toApplication Lifecycle Management orALM
in this guide apply to all currently supported versions of ALM andQuality Center. Note that
some features and options may not be supported in the specific edition of ALM or Quality
Center that you are using.

For a list of the supported versions of ALM or Quality Center, see theHP Service Test Product
Availability Matrix, available from the Service Test Help or the root folder of the Service Test
DVD. Themost up-to-date product availability matrix is available from the HP Software
Product Manuals site, at http://h20230.www2.hp.com/selfsolve/manuals (requires an HP
Passport).

For details on ALM or Quality Center editions, see theHP Application Lifecycle Management
User Guide or theHP Quality Center User Guide.

Business Process Testing in Service Test -
Overview

Business Process Testing enables Subject Matter Experts to create tests using a keyword-driven
methodology for testing.

The Business Process Testingmodel is role-based, allowing non-technical Subject Matter Experts
to collaborate effectively with Automation Engineers. Subject Matter Experts define and document
business processes, business components, and business process tests, while Automation
Engineers define the required resources and settings, such as shared object repositories, function
libraries, and recovery scenarios. Together, they can use Service Test to build, data-drive,
document, and run business process tests, without requiring programming knowledge on the part of
the Subject Matter Expert.

Business Process Testing opens within Service Test, and provides Service Test users with full
access to Business Process Testing functionality. To work with Business Process Testing from
within Service Test, youmust connect to an ALM project with Business Process Testing support.
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Note: ALM projects with Business Process Testing support can be created only in ALM
version 11.50 with the ALM Integration Enablement Pack installed or later ALM versions.

When working with ALM 11.50 with the ALM Integration Enablement Pack, Business Process
Testing is supported only at a Technology Preview level.

For details about Business Process Testing, including relevant user roles and testingmethodology,
see theHP Business Process Testing User Guide.

Service Test Program Management
The following sections describe how you canmanage your Service Test program, including
available licenses and access levels.

Licensing
Working with Service Test requires a license. When you install Service Test, you select one of the
following license types:

l A permanent seat license that is specific to the computer on which it is installed (includes a 30-
day demo license)

l A network-based concurrent license that can be used by multiple Service Test users

You can change your license type at any time (as long as you are logged in with administrator
permissions on your computer). For example, if you are currently working with a seat license, you
can choose to connect to a concurrent license server, if one is available on your network.

For information onmodifying your license information, see theHP Service Test Installation Guide.

Note: You can also open Service Test using a legacy license, although the functionality will be
limited to the service that you are licensed to use. For example, you can open Service Test
using a legacy QuickTest Professional or Service Test license and access GUI testing or API
testing functionality.

Access Permissions
Youmust make sure the following access permissions are set to run Service Test or to work with
ALM.

Permissions Required When Working with Service Test
Youmust have the following file system permissions:

l Full read and write permissions for all the files and folders under the Service Test installation
folder

l Full read and write permissions to the Temp folder

l Read permissions to theWindows folder and to the System folder

Youmust have the following registry key permissions:
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l Full read and write permissions to all the keys underHKEY_CURRENT_
USER\Software\Mercury Interactive

l Read andQuery Value permissions to all theHKEY_LOCAL_MACHINE andHKEY_
CLASSES_ROOT keys

Permissions Required When Working with ALM
Youmust have the following ALM-specific permissions to use Service Test with ALM:

l Full read and write permissions to the ALM cache folder

l Full read and write permissions to the Service Test Add-in for ALM installation folder

Permissions Required When Working with Business Process Testing
The ALM Project Administrator can control access to a project by defining which users can log in to
it and by specifying the types of tasks each user may perform. The ALM Project Administrator can
assign permissions for adding, modifying, and deleting folders, components, steps, and parameters
in the Business Components module of an ALM project.

You need tomake sure you have the required ALM permissions before working with business
components and application areas.

l Towork with component steps in ALM, youmust have the appropriateAdd Step,Modify Step,
orDelete Step permissions set. You do not needModify Component permission to work with
component steps. TheModify Component permission enables you to work with component
properties (the fields in the component Details tab).

l Towork with parameters in ALM or in a testing tool, youmust have all the parameter task
permissions set in ALM.

l Tomodify application areas, youmust have the required permissions for modifying components,
and adding, modifying, and deleting steps. All four permissions are required. If one of these
permissions is not assigned, you can open application areas only in read-only format.

For more information on setting user group permissions in the Business Components module, see
theHP Business Process Testing User Guide.

Software Updates
Relevant for: GUI testing and API testing

By default, Service Test automatically checks for online software updates once every seven days.
When you start Service Test, it checks to see if the last automatic update took placemore than
seven days ago, and if so, it checks for updates.

You can alsomanually check for updates to all HP products installed on your computer at any time
by choosingHelp > HP Update from within Service Test, or by choosingStart > Programs > HP
Software > HP Service Test > HP Update. (Youmust be logged on with Administrator privileges
to use HP Update.)

If updates are available, you can choose which ones you want to download and (optionally) install.
Follow the on-screen instructions for more information.
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Note: For details on accessing Service Test tools and files inWindows 8, see "Accessing
Service Test inWindows 8Operating Systems" below.

Accessing Service Test in Windows 8 Operating
Systems

Service Test applications and files that were accessible from theStartmenu in previous versions of
Windows are accessible inWindows 8 from theStart screen or theApps screen.

l Applications (.exe files). You can access Service Test applications inWindows 8 directly from
theStart screen. For example, to start Service Test, double-click theHP Service Test shortcut

.

Other examples of applications accessible from theStart screen include:

n The RunResults Viewer

n All Service Test tools, such as the Password Encoder and the License Validation Utility

n The API testing sample Flight applications

l Non-program files. You can access documentation from theApps screen.

Note: By default, the Start and Apps screens onWindows 8 are set to open Internet Explorer in
MetroMode. However, if User Account Control is turned off on your computer, Windows 8 will
not open Internet Explorer in Metromode. Therefore, if you try to open an HTML shortcut from
the Start or Apps screen, such as the Service Test Help or Readme file, an error will be
displayed.

To solve this, you can change the default behavior of Internet Explorer so that it never opens in
Metromode. In the Internet Properties dialog box > Programs tab, select Always in Internet
Explorer on the desktop for the in theChoose how you open links option. For more
details, see http://support.microsoft.com/kb/2736601 and
http://blogs.msdn.com/b/ie/archive/2012/03/26/launch-options-for-internet-explorer-10-on-
windows-8.aspx.
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Concepts

Service Test Main Window Overview
Themain window in Service Test provides multiple areas to design, edit, debug, and run testing
documents. The following table introduces the key elements in the Service Test window:

Element Description

"Start Page" Welcomes you to Service Test. You can use the shortcut buttons to open
new and existing documents.

For details, see "Start Page" on page 51.

Document Pane Themain area to design and edit testing documents.

l Canvas. Visually displays the test flow as a series of steps. For details,
see "The Canvas" on page 373.

l Editor. Displays each test step as a line of code and enables you to
create user code using C# code. For details, see "Editor at a Glance" on
page 37.

"Service Test
Panes at a
Glance"

Provide information and functionality about the current test.

For details, see "Service Test Panes at a Glance" on page 38.
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For details about the key areas displayed in themain window, see theGlance subsections in the
remainder of this chapter.

Canvas at a Glance

The canvas provides a visual representation of the test flow.

The canvas displays a flow of the steps found within a test, including parameter links between
steps. You add steps to the canvas by dragging them from the Toolbox pane.

HP Service Test (11.52)Page 36 of 705

User Guide
Chapter 2: Service Test at a Glance



For details on the canvas, see "The Canvas" on page 373.

Editor at a Glance

The Editor displays test steps as lines of code and enables you to add steps to a user code file
using C# code.

The Editor also enables you to write customized user code for run during test steps or to write
custom code which defines the properties and behavior of different test steps.
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For details on using the Editor, see "Editing Text and Code Documents" on page 133.

Service Test Panes at a Glance
The following sections describe the available Service Test panes:

Data Pane at a Glance 39

Errors Pane at a Glance 40

Debug Panes at a Glance 40

Output Pane at a Glance 42

Properties Pane at a Glance 43

Solution Explorer Pane at a Glance 44

Search Results Pane at a Glance 45

Tasks Pane at a Glance 46

Toolbox Pane at a Glance 46

Relevant for: GUI tests scripted GUI components, function libraries, and user code files
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The Bookmarks pane displays all bookmarks inserted into your user code files. The pane enables
you to create bookmarks, view the information about inserted bookmarks, and navigate to the user
code file containing the bookmark.

To view the Bookmarks pane, select View > Bookmarks.

For details, see "Bookmarks Overview" on page 84.

Data Pane at a Glance

The Data pane displays the relevant data for your test or component.

The Data pane can display data from a local data table, an Excel spreadsheet, a database
connection, or an XML file. These data sources are then used to parameterize properties for test
steps.

To view the Data pane, select View > Data.

For details about the Data pane, see "Data Pane" on page 96
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Errors Pane at a Glance

The Errors pane provides a list of missing resources and coding syntax errors from your test. If the
pane is not currently displayed, Service Test automatically opens it when an error is detected. You
can double-click an error to locate in the error in your test or component.

Missing resources are the resources that are specified in your test or component but cannot be
found. Information errors provide a list of coding syntax errors in your user code.

Missing resources listed in this pane aremissing resource files, such as references called by the
test during a run session or user functions or objects called by a test.

The pane also displays coding syntax errors or individual step property errors. If there is a coding
syntax error in a user code file or a property value error in a step, it is displayed in the Errors pane.

In addition, if a property value for a step is undefined, it is listed in the Errors pane as a test error.

To view the Errors pane, select View > Errors.

For details, see "Errors Pane" on page 172.

Debug Panes at a Glance

The Debug panes assist you in debugging your user code file, and contains the following options:

Tab Description

Breakpoints Displays information about breakpoints inserted into user code files and allows
you enable or disable the breakpoints.

For details, see " Breakpoints Pane" on page 114.

Call Stack Displays information about the function andmethod calls currently running in a
test or user code file.

For details, see "Call Stack Pane" on page 116.
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Tab Description

Loaded
Modules

Displays information on the .dll files associated with the current run session.

For details, see "LoadedModules Pane " on page 119.

Threads Displays information about all the threads running in the current context of the
test.

For details, see "Threads Pane " on page 120.

Local
Variables

Displays the current value and type of all variables that were recognized up to the
last step performed during the run session that you are debugging. You can also
set or modify the values of the variables that are displayed.

For details, see "Local Variables Pane" on page 122.

Console Enables you to run lines of script to set or modify the current value of a variable,
code object, property, method, or function call in your user code file.

For details, see "Console Pane" on page 124.

Watch Displays the current value and type of any variable or expression that you added
to theWatch pane.

For details, see "Watch Pane" on page 126.

To view the Debug panes, select View > Debug and select the specific Debug pane you want to
view.

This image below shows the Threads pane visible with the other panes open as individual tabs. You
can display any debug pane by clicking on the relevant tab.
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For details, see "Debug Panes" on page 110.

Output Pane at a Glance

This pane enables you to view theOutput log for the compilation and test run.

To view theOutput pane, select View > Output.
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For details, see "Output Pane" on page 180.

Properties Pane at a Glance

The Properties pane displays and enables you to edit properties and parameters for a selected test,
action, or component. The information displayed in this pane is dependent upon the active
document.

The Properties pane enables you view and edit the property values, schemas, and event handlers
for the different activities in the test canvas. Using the Input/Checkpoints tab, you can specify
input and output values for the highlighted activity and set checkpoints for that activity. Using the
Events tab, you can open the TestUserCode.cs file in the Editor, enabling you to write event
code to use during a particular test step. Using theData Sources tab (visible only when the test
flow is selected), you can select data sources to use with your test.

To view the Properties pane, select View > Properties.

The image below shows the Input/Checkpoints view for a test step. You can display the other
tabs by clicking on them.
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For details on the Properties pane, see "Properties Pane User Interface" on page 186.

Solution Explorer Pane at a Glance

The Solution Explorer Pane displays all the resources associated with a test or component. You
can add, remove, andmanage all of the resources in your test or to view and open all of the
resources in your component through this pane. In addition, the Solution Explorer pane enables you
to combinemultiple types of tests, components, and user code files into a single solution.

Test nodes can include numerous references, events, and actions. The Solution Explorer pane
displays all external references for a test, the event handler code file (TestUserCode.cs), any
actions created as part of a test, and any user-defined code files added to a test.

You can openmost associated resources and references from the Solution Explorer pane by
double-clicking on the name of the resource or reference.

To view the Solution Explorer pane, select View > Solution Explorer.

HP Service Test (11.52)Page 44 of 705

User Guide
Chapter 2: Service Test at a Glance



For details, see "Solution Explorer PaneOverview" on page 235.

Search Results Pane at a Glance

The Search Results pane displays the results of searches performed using the options in the
Search menu. Using this pane, you can browse the results of your search, locate a specific result,
and perform recent searches in order to receive updated results.

To view the Search Results pane, select View > Search Results.

The image below shows the Search Results pane for API testing.
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For details, see " Search Results PaneOverview" on page 228.

Tasks Pane at a Glance

The Tasks pane enables you to create, view, andmanage your TODO tasks. A TODO task is
anything that needs to be done in a test or component, such as providing information relevant for
handing over a testing document, or adding a reminder to yourself to add steps that test a new page
in your application. Your TODO tasks are saved with the test or component.

The Tasks pane also enables you to view the TODO comments that exist in an open user code file
and navigate to the line in the user code file containing the TODO comment.

To show or hide the Tasks pane, select View > Tasks.

For details, see "Tasks Pane User Interface" on page 251.

Toolbox Pane at a Glance

The Toolbox pane contains all the activities and flow control activities you can use to create a test.
You can drag and drop activities from the Toolbox pane into the canvas to create a test, or you can
double-click activities to create a test flow. Custom activities (such as Web services) are also
added to the Toolbox pane, under the Local Activities node.
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To view the Toolbox pane, select View > Toolbox.

For details on the Toolbox pane, see "Toolbox PaneOverview" on page 255.
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Tasks

How to Start Service Test
1. From the Startmenu, select All Programs > HP Software > HP Service Test >

HP Service Test, or double-click theHP Service Test shortcut on your desktop.

The Service Test window opens, displaying the "Start Page".

2. If your installation of Service Test integrates with ALM, connect to your ALM project, as
described in "How toWork with Tests and Components in ALM" on page 327.

3. Begin creating or editing your tests. For details on how tomanage testing documents, see
"How to Create andManage Tests" on page 56.

4. Set your global test variables. For details on setting test variables in the Properties, pane, see
"How to Define Test Properties or User/System Variables" on page 59.
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Reference

About Service Test Dialog Box
This dialog box enables you to view information regarding the features installed on your computer,
as well as other basic information about your computer. This information is useful for
troubleshooting and when working with HP Software Support.

To access Select Help > About HP Service Test.

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

Version
information

The version of Service Test that is installed on your computer and its build
number.

License
Type

Displays the license type installed on your computer: Seat orConcurrent.
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UI Element Description

Installed
Features

The list of installed add-ins that are installed on your computer. This window
displays the feature name and version number for each add-in.

Detailed
Info

Opens the "About Service Test Detailed InformationWindow" (described on page
50), which displays all information about the application components installed on
your computer.

System
Info

Opens theWindows system information window which displays information about
the hardware and software components running on your computer.

License Opens the License Summary dialog box detailing the installed license. Select
Modify License to change the type of license.

About Service Test Detailed Information Window
This window displays detailed information on Service Test components installed on your computer.
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To access In the About Service Test dialog box, click theDetailed info button.

See also "About Service Test Dialog Box" on page 49

User interface elements are described below:

UI Elements Description

Product Name The name of the product.

Version The version number of the product listed in this window.

Host Name The name of the computer hosting Service Test and the operating
system.

ALM Connectivity
Version

The version number of the ALM Connectivity Add-in.

Maintenance
Number

Themaintenance number for your software.

Installed
Components

The list of Service Test components installed on your computer,
including version number.

Start Page
This page welcomes you to Service Test and describes the new features in this release, including
links tomore information about these features.

To access 1. Start Service Test, as described in "How to Start Service Test" on page 48.

2. If the Start Page window is not displayed, select View > Start Page.

User interface elements are described below:
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UI Elements Description

Recent
Tests/Components
Recent Solution

Enables you to create a test or component or a solution by clicking the
New orOpen buttons after selecting a test, component or solution name.

Options Options for viewing the start page.

You can select Display the Start Page on Startup to display the Start
Page immediately upon the launch of Service Test. You can select Close
Start Page after test loads if you want to close the start page after
loading a test.

What's New area Click theWhat's New button to display information on the list of the
newest features, enhancements, and supported environments in the
latest version of Service Test.

Community Area Click theCommunity button to open news about Service Test, links to
Service Test in the HP Software site, links to the API Testing forum, and
the Business Process Testing Forum, or the Service Test blog.

Links Area Click the Links button to open links to the Service Test Help and the
tutorial.

Support Area Click theSupport button to open links to Service Test support, the
Knowledge Base, and Troubleshooting areas of the HP Software Support
Web site.

Service Test Program Folder Structure
After the Service Test setup process is complete, the following items are added to your Service
Test program folder (Start > All Programs > HP Software > HP Service Test):

l Documentation. Provides the following links to commonly used documentation files:

Option Description

HP Service Test
Help

Opens the Service Test Help, which displays links to commonly used
topics andmovies that describe how to use Service Test, as well as
additional links to HPSoftwareWebsites.

The Service Test Help provides access to all guides available for
Service Test, such as Getting Started guides, Helps, reference files,
and links to printer-friendly (PDF format) documentation. It contains
various navigation options to help you find the information you need.

TheWelcome to the Service Test Help section describes how to
navigate, use, and get updates for the Service Test Help.

Service Test
Tutorial

Opens the Service Test tutorial, which teaches you basic skills and
shows you how to start testing your applications.

l Sample Application. Contains the following links to sample application that you can use to
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practice testing with Service Test:

Option Description

Sample Application Opens aGUI-less flight service application.

Note: Youmust have administrator privileges to use this
application.

l Tools. Contains the following utilities and tools that assist you with the testing process:

Option Description

Activity
Wizard

Opens the "Activity Wizard" (described on page 684), which enables you to
create custom activities that will be visible in the Toolbox pane.

Additional
Installation
Requirements

Opens the Additional Installation Requirements Utility, which displays any
prerequisite software that youmust install or configure to work with Service
Test. For details, see the

Commuter
License Tool

Opens the Commuter Licensing utility, to check in or check out concurrent
licenses when working at a remote location.

License
Validation
Utility

Opens the License Validation utility, which enables you to retrieve and
validate license information. For details, click theHelp button in the License
Validation Utility window.

soapUI to API
Test
Converter

Converts soapUI tests to a Service Test Test.

Test Batch
Runner

Opens the Test Batch Runner application, which enables you to set up
Service Test to run several tests in succession. For details, see "How to
Create and Run a Test Batch" on page 292.

l HP Service Test Product Availability Matrix. Provides a complete list of all environments,
programs, and versions that are supported for Service Test.

l HP Service Test. Opens the Service Test application.

l Readme. Opens theHP Service Test Readme, which provides the latest news and information
on Service Test.

l For details on accessing Service Test tools and files inWindows 8, see "Accessing Service
Test inWindows 8Operating Systems" on page 33.
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Concepts

Testing Documents Overview
A testing document is any file that enables you to test your application. You create, maintain, and
edit steps, parameters, functions, and other details in the document to enable the testing of your
application.

Testing documents can include:

l Service Test documents:

n Tests

n Actions

n C# files containing event handler code (TestUserCode.cs files)

n C# files containing user-generated code

l Business Process Testing documents:

n Business process tests

n Business process flows

n API components

You work with testing documents in the "Document Pane" (described in "Document Pane" on page
131). In Service Test, you can perform standard file operations with testing documents, including
creating, opening, saving, and printingmultiple types of documents. You can also save a test with
its resources.

The document pane supports the following types of views and functionality:

l Canvas. Graphically displays and enables you to edit the flow of your test, action, or
component. For details, see "The Canvas" on page 373.

l Editor. Provides text and code editing features that facilitate the design of your text, script, and
code documents. For details, see "Editing Text and Code Documents" on page 133.
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Tasks

How to Create and Manage Tests
The task describes how tomanage tests and includes the following steps:

l "Create a new standalone test" below

l "Create a new test within an existing solution" below

l "Open an existing test" on next page

l "Add an existing test to your solution" on next page

l "Edit an open test" on next page

l "Save the current test" on next page

l "Save all open tests" on page 58

l "Save a portable copy of an API test" on page 58

l "Close the current test" on page 58

l "Close all tests" on page 58

l "Switch between open tests" on page 58

l "Delete a test" on page 59

Create a new standalone test
1. (Optional) If you are working with ALM, connect to the relevant ALM project. For details, see

"ALM Connection Dialog Box" on page 335.

2. Do one of the following:

n Select File > New and select the type of test to create.

n Click theNew button down arrow and select the type of test to create from the
drop-down list.

A dialog box opens:

n If you are creating a test or component, see "New <Document> Dialog Box" on page 67.

This dialog box enables you to specify the type of test or component you want to create, the
location in which the new item is stored, and, optionally, the solution in which it is included.

n If you creating a solution, see "Open/New <Document>/<Resource> Dialog Box" on page
69.

This dialog box enables you to specify the location in which the new item is stored.

After you finish entering the information for your new test in the dialog box, a new test is
automatically saved and displayed as a tab in the document pane.

Create a new test within an existing solution
Do one of the following:
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l Select File > Add or click theAdd down arrow to add a new test to your solution.

l In the "Solution Explorer Pane" (described on page 240) right-click the <solution name> node,
select Add > Add New and select the type of test to create.

A dialog box opens. For details, see: "Add Test/Component to Solution Dialog Box" on page 64.

After you finish entering the information for your new test in the dialog box, a new test is
automatically saved and displayed as a tab in the document pane.

Open an existing test
1. If your test is stored in ALM, connect to the relevant ALM project. For details, see "ALM

Connection Dialog Box" on page 335.

2. Do one of the following:

n Select File > Open, click theOpen down arrow, or select the list of Recent files in
the Filemenu to open an existing test. In the "Open/New <Document>/<Resource> Dialog
Box" (described on page 69), browse to and select your test.

n If your test is part of a solution, in the "Solution Explorer Pane" (described on page 240)
double-click the selected node for your test.

Add an existing test to your solution
Do one of the following:

l In the "Solution Explorer Pane" on page 234 (described on page 240), right-click the <solution
name> node and select Add > Add Existing <Document>, and select the type of test to add.

l Select File > Add Existing or theAdd down arrow to add a test to your solution.

A dialog box opens. For details, see "Add <Existing Document> to Solution Dialog Box" on page
63.

Edit an open test
The features available for viewing and editing documents depend on the document type. For details,
see "Document PaneOverview" on page 132.

Save the current test
Do one of the following:

l Make sure that the test you want to save is the active tab (you can select the test's tab to bring it

into focus), and click theSave button .

l Right-click the tab of the test you want to save and select Save <test name> orSave <test
name> As.

Service Test saves the test with your changes. If you are usingSave As, the "Save
<Resource>/Save <Document> As Dialog Box" (described on page 72) opens.

Note:When you edit a document, an asterisk (*) is displayed in the document tab (for

HP Service Test (11.52)Page 57 of 705

User Guide
Chapter 3: Service Test File Operations



standalone documents like user code files) or the canvas tab (if the document is part of a test)
until the document is saved.

Save all open tests

Select File > Save All or click theSave All button .

Note:When you edit a document, an asterisk (*) is displayed in the document tab (for
standalone documents like user code files) or the canvas tab (if the document is part of a test)
until the document is saved.

Save a portable copy of an API test
1. Prerequisites:

n If your test was last modified using Service Test 11.10 or later, make sure that the test and
its resources are upgraded to Service Test 11.50. Open the test in Service Test 11.50 and
save it (Save orSave As). If the test contains calls to external actions (actions stored in
other tests), open and save those tests too.

Note: Tests last modified in Service Test 11.00 or earlier cannot be opened in Service
Test 11.50.

n Make sure that your resource file (such as WSDL or REST service) has at least one step in
the current test.

2. In the Toolbox pane, right-click on the service name and selectMove to > File System
Activities. The servicemoves to the File System Activities section of the Toolbox pane.

3. Select File > Save (Other) > Save with Resources. The "Save <Resource>/Save
<Document> As Dialog Box" (described on page 72) opens.

Close the current test
Do one of the following:

l Make sure that the test you want to close is the active test and select File > Close.

l To close all tests included in the current solution and the solution, select File > Close solution.

l Right-click a test tab and select Close.

Close all tests
Do one of the following:

l To close all open tests, right-click any test's tab and select Close All.

l To close all open tests except the active test, right-click on the test tab and select Close All
but This.

Switch between open tests
l To navigate to an open test, select the relevant tab.
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Note: If some tabs are not visible due to a lack of space, click the document display arrow
in the upper-right hand corner to display a list of all open tests. Select the test you want

to view.

l To select your document from amenu of open tests, press and hold CTRL+TAB on your
keyboard. A window opens showing a list of all open tests and panes.

Delete a test
l If the test is stored in the file system, select File > Open, File > New, or File > Save as to

open a file operation dialog box. Browse to the test, right-click and select Delete.

Caution: Before you delete a document, make sure that it is not used by or associated to
any other documents.

l If the document is stored in ALM, you delete it from within ALM, regardless of whether it was
created in Service Test or in ALM. For details, seeHP Business Process Testing User Guide.

How to Define Test Properties or User/System Variables
The following steps describe how to define test properties, user variables, and operating system
variables. These settings are optional.
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l "Define test properties" below

l "Define user variables" below

l "Set user variable values " below

l "Define user variable profiles " on next page

l "Set OS variable values for the test - optional" on next page

Define test properties
This step applies if you want to define custom properties that can be used by all steps in the test,
with the ability to assign data from a data source.

1. Click in a blank area of the canvas. In the Properties pane, open the Test Input Parameters
view .

2. Click theAdd button to define a new input or output parameter.

3. In the "Add Input/Output Property/Parameter Dialog Box" (described on page 497), specify a
parameter name and data type. All types that were defined in any reference file, are available.

4. Click in theDefault Value column and specify a value.

Define user variables
You can create user variables and set their values. You can definemultiple profiles for the variable
values. You select a profile to be active before the test run. For details, see "Set user variable
values " below.

1. Click in a blank area of the canvas. In the Properties pane, open the Test Variables view .

2. Click theAdd User Variable button  to define a new user variable.

Set user variable values
You can set values for variables in one of the following ways:

l In the Properties pane's Test Variables view, click in theProfile column andmanually enter
values.

l Open the Toolbox pane and drag theSet Test Variable activity from theMiscellaneous
category into the Test Flow (or loop). In the Properties pane, define the variable key and value.
To obtain values, click the Link to a Data Source button in the row. In the "Select Link Source
Dialog Box" (described on page 630), select the Test Variables option. Select a name and value
for theVariable key andVariable value.

l Open the Properties pane's Events view for the step or define a Custom Code activity. Edit the
event handler code and assign a value using the TestProfile object. The following example
sets the value of the Region user variable to NE.

activity.Context.TestProfile.SetVariableValue("Region", "NE");

For details, see "Coding Service Test Events" on page 641.

Repeat this step for each variable for which you want to set values.
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Define user variable profiles
This step applies only if you created user variables as described in the above steps.

1. Define one or more user variables as described above.

2. Click theAdd New Profile button .

3. In the "New Test Profile Dialog Box" (described on page 74), specify a name and indicate the
profile (if any) from which to copy the properties. If you do not copy the properties from an
existing profile, Service Test copies the user variables from the active profile without its
values.

4. To rename or delete a profile, click theManage Profiles button . Click Remove or
Rename.

5. Click theCompare button to display the profiles side-by-side.

6. Only the active profile is accessed during the test run. Tomake a profile active, select it from
theActive Profile list.

For user interface details, see the "Test Variables Tab (Properties Pane)" on page 212.

Set OS variable values for the test - optional
This step lets you set global operating system variables that will apply to all steps in the current test
run.

1. From the Toolbox pane and drag theSet OS Environment Variable activity from theSystem
category into the Test Flow or another custom loop.

2. In the Properties pane's Input/Checkpoints tab, define the variable key and value or click the
Link to Source button  to specify a data source.

Tip: To view a list of the test variables, click in a blank area of the canvas. In the Properties

pane, open the Test Variables view . The System variables are listed in the lower pane.

How to Upgrade Tests Using the Batch Upgrader
Service Test11.50 provides an upgrade tool, STBatchUpgrader.exe, located in the <Service
Test installation>/bin folder. This tool lets you run a batch file to upgrade tests last
modified in version 11.10 or 11.20, making them compatible for version 11.50.

Note: The Batch Upgrader tool may not successfully upgrade tests stored in ALM11.00 when
working onWindows 2003.

If you do not upgrade your tests with the batch upgrade tool, when you open a test last modified in
version 11.10 or 11.20, it prompts you to upgrade the test.

Tests last modified in Service Test 11.00must first be opened and saved in Service Test 11.10,
before you can upgrade them to version 11.50.

For the tool's options, see "Batch Upgrader Command Line Options" on page 76,

The following steps describe how to use theSTBatchUpgrader tool.
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l "Prerequisite" below

l "Locate the Batch Upgrader tool" below

l "Add command line options" below

l "Run the command" below

1. Prerequisite
Make sure that Service Test is not running.

If you ran the upgrader tool once while Service Test was running, the logs may become
corrupted. Backup and delete all of the existing logs in the <Service Test

installation>\bin\logs folder before proceeding.

If desired, create a backup copy of the older tests.

2. Locate the Batch Upgrader tool
In the command line, enter the location of the STBatchUpgrader.exe file in the Service
Test/bin sub-folder.

3. Add command line options
Add the relevant options as described in "Batch Upgrader Command Line Options" on page 76,
using the following syntax:

STBatchUpgrader.exe source [destination] [/ALM url domain

project] [/login username password] [/log logfile] [/report

reportfile]

For example, the following string runs the upgrade on all tests in the ST_11_1 folder on the
ALM server, pumpkin, for the TEST1 project in the AUTOMATION domain. It places the
report in c:\logs\MyLogfile.log.

STBatchUpgrader.exe Subject\ST11_1 /ALM

http://pumpkin:8080/qcbin AUTOMATION TEST1 /login user password

/log c:\logs\MyLogfile.log.

4. Run the command
Run the command. Verify the validity of the tests in the destination folder.
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Reference

Add <Existing Document> to Solution Dialog Box
This dialog box enables you to add existing tests to a solution.

This section describes the following dialog boxes:

l Add Test to Solution dialog box

l Add Business Component to Solution dialog box

To access Do one of the following:

l In the "Solution Explorer Pane" (described on page 240), right-click the solution
node and select Add Existing <Document>.

l Select File > Add Existing <Document>.

l Click theAdd button down arrow and select the test.
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Important
information

l Solutions are saved in your file system only and cannot be saved in an ALM
project.

l Using File > Add Existing Test enables you to openmultiple tests or
components, simultaneously instead of using File > Open (which closes all
open documents).

l If you try to open a test and there is an error with loading the test (such as ALM
connectivity problems or a changed test name), an error describing the problem
is displayed in the Errors pane.

Relevant
tasks

"How to Create andManage Tests" on page 56

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Element

Description

<sidebar> The location in which the test is stored, for example File System or ALM Test

Plan.

Note: Youmay need to select a different location before browsing to your test.

Look in The path for the test. You can use the down arrow to navigate to the required folder,
or you can double-click a folder in the file list area to navigate to the required folder.

<file list
area>

The folders and/or tests stored in the current path.

File name The name of the tests selected in the <file list area>.

Files of
type

Filters a list of displayed files to show only the file types selected. If the current
folder contains other file types, they are hidden.

Add Test/Component to Solution Dialog Box
This dialog box enables you to add new tests or components to a solution.

This section describes the following dialog boxes:

l AddNew Test/Component to Solution dialog box

l Add Business Component to Solution dialog box

The image below shows the dialog box to add a new test to a solution (File > Add > New Test).
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The image below shows the dialog box to add a new component to a solution (File > Add > New
Business Component).
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To access Do one of the following:

l In the "Solution Explorer Pane" (described on page240), right-click the solution
node and select Add New <Document>.

l Select File > Add New <Document>.

l Click theAdd button down arrow and select the type of document.

Important
information

l When you add a test to a solution, it is added to the solution in the Solution
Explorer and it also opens as a new tab in the document pane.

l Solutions are saved in your file system only and cannot be saved in an ALM
project. For details, see "Solution Explorer PaneOverview" on page 235.

l You can use this command to keepmultiple tests or components open
simultaneously instead of using File > New (which closes all open
documents).

l When you save a new test in the file system, Service Test suggests a default
folder calledService Test. For all supported operating systems prior to
Windows Vista, this folder is located under your Service Test installation
folder. ForWindows Vista and later operating systems, this folder is located
under My Documents.

Relevant
tasks

"How to Create andManage Tests" on page 56

User interface elements are described below:

UI Element Description

Select type A list of available tests or components.

For tests, you can select:

l APITest

l APITest - Load Enabled

l Business Process Test

l Business Process Flow

For components, you can selectAPIComponent.

Note: The options available differ according to the license loaded and the
software installed on the Service Test computer.

Name The name of the test. Use a descriptive name that helps you and others identify
the test easily.

Depending on the location you specify in the Location field, Service Test
suggests possible names to avoid conflicts with existing tests.
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UI Element Description

Location The folder of the test in the file system or an ALM project.

Note: (for ALM users) The location of your test or component file is
prefaced by an ALM path, shown as: [ALM] Components/Subject

\<folder name>.

Application
Area
(GUI
components
only)

The folder location for the application area associated with your component.

Note: (for ALM users) The file system path for your application area file is
prefaced by an ALM path, shown as: [ALM\Resource]
Resources\<folder name>

New <Document> Dialog Box
This dialog box enables you to create a new test.

This section describes the following dialog boxes:

l New Test dialog box

l New Business Component dialog box

The image below shows the dialog box to create a new test (File > New > Test).
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The image below shows the dialog box to create a new component (File > New > Business
Component).

To access 1. Prerequisite for ALM users:Connect to your ALM project if needed. For
details, see "ALM Connection Dialog Box" on page 335.

2. Do one of the following:

n Select File > New > Test (for tests only).

n Select File > New > Business Component (for components only).

n Click theNew down arrow and select the type of test you want to
create.

Important
information

l After you create the test, it is automatically saved to the specified location.

l When you save a new test in the file system, Service Test suggests a default
folder calledService Test. For all supported operating systems prior to
Windows Vista, this folder is located under your Service Test installation
folder. ForWindows Vista and later operating systems, this folder is located
under My Documents.

l In ALM, components are saved in the ALM Components module. You cannot
save a component directly in the root folder of this module. Create a sub-folder
within it, or select an existing sub-folder.

Relevant
tasks

"How to Create andManage Tests" on page 56
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User interface elements are described below:

UI Element Description

Select type A list of available test or component types.

For tests, you can select:

l API Test

l API Test - Load Enabled

l Business Process Test

l Business Process Flow

For components, selectAPIComponent.

Note: The options available differ depending on the license loaded and the
HP applications installed on the Service Test computer.

Name The name of the test. Use a descriptive name that helps you and others identify
the test easily.

Depending on the location you specify in the Location field, Service Test
suggests possible names to avoid conflicts with existing tests.

Location The folder of the test in the file system or an ALM project.

Note: (for ALM users) The location of your test file is prefaced by an ALM
path, shown as: [ALM] Components/Subject \<folder name>.

Application
Area
(GUI
components
only)

The folder location for the application area associated with your component.

Note: (for ALM users) The location of your application area file is prefaced
by an ALM path, shown as: [ALM\Resources] Resources\<folder

name>.

Solution
Name

The name of the solution to create that contains your test. If you do not specify a
name for a solution, a generic solution calledSolution Untitled is created in the
Solution Explorer, and the test is associated with this default solution.

Note: All new tests must be part of a solution.

Open/New <Document>/<Resource> Dialog Box
This dialog box enables you to open an existing test from the file system or your ALM project, if
Service Test is connected to an ALM project.

Additionally, this dialog box is used when you create a new solution, enabling you to specify its
location.

This section describes the following dialog boxes:
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l New Solution dialog box

l Open Solution dialog box

l Open Test dialog box

l Open Business Component dialog box

The image below shows a dialog box when opening a test. Similar options are available when
opening other types of documents or resources.

To access 1. Prerequisite for ALM users: Connect to your ALM project if needed. For
details, see the "ALM Connection Dialog Box" on page 335.

2. Use one of the following:

If you are creating a new solution:

l Select File > New > Solution.

If you are opening a test:

l Select File > Open and select your test.

l Click theOpen button and select your test.
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Important
information

l When you create a new test in the file system, Service Test suggests a default
folder. For all supported operating systems prior toWindows Vista, this folder
is located under your Service Test installation folder. ForWindows Vista and
later operating systems, this folder is located underMy Documents.

l After you create the document, it is automatically saved in the specified
location.

l When you open a test in read-only mode, the title bar displays Read Only and
all tabs associated with that test (for example, actions in a test) display a lock
icon.

l Each time you open a test using File > Open, it replaces and closes any tests
or solutions currently in use.

l You can also open a recently used test or component by selecting from the
Recent files in the File menu. If you select a test or component when you are
not connected to an ALM project, or if you select a component that is stored in
a different ALM project, Service Test displays amessage asking you if you
want to connect to that project.

l If you try to open a test and there is an error with loading the test (such as ALM
connectivity problems or a changed test name), an error describing the problem
is displayed in the Errors pane.

l For Business Process Testing: The first time that you open a business
process test or flow from Service Test, youmust connect as a user with
administrator privileges on the computer on which you are connecting.

l When trying to open a test saved in Service Test, version 11.10 or 11.20,
Service Test prompts you to upgrade the test using the Batch Upgrader tool
(described on page 61). If the test or component was created in Service Test
11.00, youmust first open and save it in Service Test 11.10 before you can
upgrade it using the Batch Upgrader.

l If you try to open a test or component last saved in a version of QuickTest
earlier than 9.5, an error message is displayed in the Service Test Error Pane.
Youmust first open it in QuickTest 10.00 or 11.00 to upgrade it.

Assets last saved in QuickTest 10.00 or later can be opened in Service Test.

Relevant
tasks

"How to Create andManage Tests" on page 56

User interface elements are described below (unlabeled elements are shown in angle brackets):
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UI Element Description

<sidebar> The location in which the test is stored, for example File System orALM Test

Plan.

Note:

l Youmay need to select a different location before browsing to your test.

l Business components are always stored in ALM Components, and
application areas are always stored in ALM Resources.

Look in The path for the test. You can use the down arrow to navigate to the required
folder, or you can double-click a folder in the file area to navigate to the required
folder.

<file list
area>

The folders and/or tests stored in the current path.

File name The name of the test selected in the file list area.

Files of
type

Filters the list of displayed folders or tests to display the selected file type. If the
current folder contains other file types, those files are hidden.

Open in
read-only
mode

Opens the test in read-only mode. This option enables you to view the test but not
modify it.

Note: (for ALM users) A test also opens in read-only mode if:

l You opened a test that is currently checked in to the version control
database (for projects that support version control).

l You opened a test that is currently checked out to another user (for
projects that support version control).

l You opened a test from an earlier version of ALM and the document has
not yet been updated to the current format.

Open Opens the selected test.

Save <Resource>/Save <Document> As Dialog Box
This dialog box enables you to save a copy of an existing test with another name. You can save the
test in the file system or your ALM project, if Service Test is currently connected to an ALM project.
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To access Connect to ALM, if relevant, and then do one of the following:

l In the document pane, right-click the document tab, and select Save <test
name> As.

l Select File > Save <test name> As.

l File > Save (Other) > Save <component name > As Business
Component.

Important
information

l Youmust use theSave As option in Service Test to save a test with another
name or create a copy of a test. You cannot copy a test or change its name
directly in the file system or in ALM.

l If changes aremade to an existing test, an asterisk (*) is displayed in the title
bar until the test is saved.

Relevant
tasks

"How to Create andManage Tests" on page 56
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User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Element

Description

<sidebar> The location in which to save the test, for example, File System or ALM Test

Plan.

Note: For business components the location is always ALM Components,
and for and application areas it is always ALM Resources.

Look in The path for the folder in which to save the test. You can use the down arrow to
navigate to the required folder, or you can double-click a folder in the file area to
navigate to the required folder.

<file list
area>

The folders and/or tests stored in the current path.

File name The name of the test. Use a descriptive name that helps you and others identify the
test easily.

Files of
type

Filters the file types displayed in the file list area. You can choose to display a
specific type of file or all file types.

New Test Profile Dialog Box
This dialog box enables you to create a new profile for your test with pre-defined user variables.

To access 1. Create or open a test or component.

2. Select theStart orEnd step in the canvas.

3. In the Properties pane, open theUser Variables view .

4. Click theAdd Profile button .

Relevant tasks "How to Define Test Properties or User/System Variables" on page 59

User interface elements are described below:
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UI Element (A-Z) Description

Name A name for the profile as it will appear in the profile list drop down list.

Copy properties
from existing profile

A drop down list of existing profiles.

Default: Do not copy properties, creates a new empty profile
with the user variables of the active profile, without values.

Manage Profiles Dialog Box
This dialog box enables you to remove and rename user variable profiles.

To access 1. Create or open a test or component.

2. Select theStart orEnd step in the canvas.

3. In the Properties pane, open the Test Variables view .

4. Add additional profiles usingAdd Profile.

5. Click theManage Profiles button .

Relevant tasks "How to Define Test Properties or User/System Variables" on page 59

User interface elements are described below:

UI Element (A-Z) Description

Profiles List A list of all the profiles defined for this test.

Rename Allows you to rename the selected profile.

Remove Deletes the selected profile.
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Batch Upgrader Command Line Options
You operate the batch upgrade tool from the command line. For task details, see "How to Upgrade
Tests Using the Batch Upgrader " on page 61. The following table describes the command line
options:

UI
Elements
(A-Z)

Description

/ALM Indicates that ALM connection information will follow.

/log Indicates that the log will be written to an alternate file. By default, log files are
store in the <Service Test installation>\bin\logs folder.

/login Indicates that login information will follow.

/report Instructs the upgrader tool to generate a summary report.

destination l For tests on the File system: The full UNC path of the folder in which to store
the tests after the upgrade.

l For tests in ALM: a target folder path under the Test Planmodule, in which to
store the upgraded tests.

Note:

l The destination valuemust be a local or remote folder with the samewrite
access permissions as the source path.

l The destination folder should be an empty folder that does not include any
tests.

l If you do not specify a destination folder, the tests will be upgraded in the
source folder, overwriting the originals.

domain The name of an ALM domain in which the source tests are stored.

logfile The full path of the file to which the log will be written.

project The name of an ALM project in which the source tests are stored.

reportfile The full path of an existing folder, with the file name including an extension, to
where the summary report should be written. For example,
c:\logs\MySUmmary.txt.

source l For tests on the File system: The full UNC path of the folder containing the
tests to be upgraded.

l For tests in ALM: a source folder path under the Test Planmodule).
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UI
Elements
(A-Z)

Description

url The URL of an ALM instance to which to connect in the following form: http://
{instance_domain}:8080/qcbin

username,
password

For ALMmode, the username and password with which to log in to the ALM
project.

soapUI to API Test Converter
Using the soapUI Converter tool, you can convert soapUI tests to Service Testtests.

To
access

Do one of the following:

l Select soapUI to API Test Converter from the product's Tools section under
theStartmenu.

l Run the soapUI2APITest.exe file from the product's bin folder.

User interface elements are described below:

UI Element (A-Z) Description

soapUI project The absolute path of the .xml file representing the soapUI project.

Destination folder The target folder in which to store the converted test.

Convert Begins the conversion process.
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Command Line Syntax
You can also run the soapUI converter utility from the command line. Run the following command in
the command line:

soapUI2APITestCMD.exe /<source soapUI_file> /destination

<destination directory>/

logs <log_directory>

Command line options are described below:

Command
Line Switch

Description

/source The absolute path to the soapUI file with an .xml extension, to be converted.

/destination The absolute path of the folder to where the created API tests will be written.

/logs
(optional)

The absolute path of the folder in which to write the log file. If this option is
omitted, the log file is written to the destination folder.

-? or /? Show the parameters and their usage. For example:
soapUI2APITestCMD.exe -?
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Troubleshooting and Limitations - Service Test
Testing Documents

This section describes troubleshooting and limitation for working with tests:

Troubleshooting and Limitations - Opening and Saving Tests 79

Troubleshooting and Limitations - Upgrading Service Test Tests 80

Troubleshooting and Limitations - Opening and Saving
Tests

This section describes general troubleshooting and limitation for creating, opening and saving
testing documents, as well as opening tests or components last modified in previous versions of
QuickTest or Service Test.

Folder names
It is not possible to create a Service Test test in a path containing a '=' character.

Opening documents stored in ALM
Opening a document from the Recent Files.

You can open components from theRecent files list in the Filemenu. If you select a test located in
an ALM project, but Service Test is not currently connected to the correct project, the Connect to
ALM Project dialog box opens and displays the correct server, project, and the name of the user
whomost recently opened the test or component on this computer.

This dialog box also opens if you choose to open a test or component that was last edited on your
computer using a different ALM user name. You can either log in using the displayed name or you
can click Cancel to stay logged in with your current user name.

Opening a solution containing test documents stored in ALM.

Testing documents that are part of the same solution cannot be stored in different ALM projects,
domains, or servers.

Opening documents last modified with previous versions of Service Test
l When trying to open a test saved in Service Test, version 11.10 or 11.20, Service Test prompts

you to upgrade the test using the Batch Upgrader tool (described on page 61). If the test or
component was created in Service Test 11.00, youmust first open and save it in Service Test
11.10 before you can upgrade it using the Batch Upgrader.

l When upgrading a test from Service Test 11.20, Service Test 11.50 does not retain the Security
Settings.

Workaround: In Service Test 11.20 or earlier, save the Security Scenario to an .stss file, and
import this file for your service when you upgrade it. For details, see, "Security Scenarios
Overview" on page 541.
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Opening and saving documents in Windows 7
l The Libraries feature of Windows 7/Windows 8 is not supported. If you attempt to open a test

from a library location or save a test to a library location, Service Test may behave
unexpectedly.

Workaround:Browse to your saved tests using standard file paths, even if they are included in
a library, such as the Documents library.

For example, to browse for a test that is stored in the default Service Test folder, use:

Computer > C: > Program Files > HP Software > HP Service Test>

Tests > <TestName>

Instead of:

Libraries > Documents > HP Service Test > <TestName>

l If you work with Service Test on aWindows Vista, Windows 7, orWindows 8 operating system
with User Account Control (UAC) enabled, and you open a test from a protected location (such
as Program Files), it is opened in read-only mode and amessage is displayed that you do
not have permissions to open it in read-write mode.

Unexpected read-only files
Documents that were saved in the file system in system folders like (%Windir% or Program
files) while UAC was disabled can be opened only in read-only mode when the UAC is set to
ON.

Workaround:Copy the asset to another location and open the files from the new location.

Multilingual support
Names and paths of tests and resources are not Unicode compliant and therefore should be
specified in English or in the language of the operating system.

Troubleshooting and Limitations - Upgrading Service
Test Tests

This section describes limitations for opening tests last modified with earlier versions of Service
Test.

l When upgrading a test from version 11.00 (via 11.10), Service Test does not retain the Security
settings.

Workaround: In Service Test 11.00, save the Security Scenario to an .stss file. Import this
file for your service when you upgrade it. For details, see "Setting Security Overview" on page
540.

l Tests last modified in Service Test 11.20 that contain a Call QuickTest Professional

Test step, cannot be opened in Service Test 11.50.

l In certain instances, if the upgrader was unable to upgrade the test, youmay need tomodify the
code tomake it compatible with the current version:
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n The user code file is now titled TestUserCode.cs.

n The namespace at the beginning of the test is Script.

n The class definition is public class TestUserCode : TestEntities.

namespace Script

{

        using System;

        using System.Xml;

        using System.Xml.Schema;

        using HP.ST.Ext.BasicActivities;

        using HP.ST.Fwk.RunTimeFWK;

        using HP.ST.Fwk.RunTimeFWK.ActivityFWK;

        using HP.ST.Fwk.RunTimeFWK.Utilities;

        using HP.ST.Fwk.RunTimeFWK.CompositeActivities;

        using System.Windows.Forms;

        using HP.ST.Ext.FTPActivities;

[Serializable()]

        public class TestUserCode : TestEntities

        ...

n The args variable is no longer supported.

Workaround:Change the args variable name to the concrete Activity name as it appears at
the top of the Properties pane. For example, change args.Output.outStr =

args.Input.inStr; to
CodeActivity8.Output.outStr=CodeActivity8.Input.inStr.

n The soapUI to API Test Converter tool does not support links between steps. If you convert a
soapUI test with linkedWeb service calls, the links will not be transferred to the API/Service
Test test.
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Part 2: Service Test Panes
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Chapter 4: Bookmarks Pane
This chapter includes:

Concepts 84

Bookmarks Overview 84

Reference 85

Bookmarks Pane User Interface 85
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Concepts

Bookmarks Overview
You can use bookmarks when editing user code files in the Editor. Bookmarks enable you to
navigate between sections of your document more easily. The bookmarks are saved on your file
system on a per-user basis.

When you assign a bookmark, an icon is added to the left of the selected line of your document.

Example
In the following example, bookmarks have been added to an event handler:

The Bookmarks pane displays a list of all bookmarks added in any document connected with the
open test. Using the Bookmarks pane, you can:

l Add a new bookmark.

l Navigate to the location of the bookmark in your document.

l Navigate between consecutive bookmarks in the pane.

l Delete an individual bookmark.

l Clear all bookmarks.

For task details, see "How to Use Bookmarks in the Editor" on page 138.
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Reference

Bookmarks Pane User Interface
The Bookmarks pane displays the location of bookmarks in your user code files and enables you to
navigate to these bookmarks.

To access Select View > Bookmarks.

Important
information

l All bookmarks added to user code file included in a saved solution are
maintained after you close and reopen the pane, document, or Service Test.

l Bookmarks are saved per solution, even if multiple users are working on the
same tests.

l Whenworking with documents saved in ALM, bookmarks aremaintained until
you close Service Test.

Relevant
tasks

"How to Use Bookmarks in the Editor" on page 138

See also "Bookmarks Overview" on previous page

User interface elements are described below (unlabeled elements are shown in angle brackets):
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UI Element
(A-Z)

Description

<bookmarks
list>

All bookmarks connected with the open solution are displayed in the Bookmarks
pane. Even if a test is not open in the document pane, its bookmarks are still
displayed in the Bookmarks pane. Bookmarks are removed from the pane when
the solution is closed.

Example:When you open a solution, bookmarks in any relevant user code files
are displayed.

For each bookmark in the list, Service Test displays the location of the
bookmark's document, the file name, and the line location of the bookmark. For
documents stored on ALM, the location of the local temporary copy is displayed.
Bookmarks inserted in a user code file or user code document are kept with the
test when it is saved in an ALM project.

Note: You can double-click the bookmark line to navigate directly to the
relevant line in your document. If a bookmark's document is not open,
Service Test opens the relevant document.

Insert/Remove Bookmark. Inserts a bookmark in the current event handler or
user code file in the line where the cursor is currently located.

Previous Bookmark. Navigates to previous bookmark in the pane.

Next Bookmark. Navigates to next bookmark in the pane.

Delete. Deletes the currently selected bookmark from the relevant document and
from the list displayed in the pane.

Clear All Bookmarks. Deletes all bookmarks you have added from all
documents and from the list displayed in the pane.
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Chapter 5: Data Pane
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Troubleshooting and Limitations - Data Pane 109
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Concepts

Data Pane Overview
Service Test enables you to insert and run steps that are driven by data displayed in the Data pane.

You can designate an Excel spreadsheet, a local data table, an XML file, or results of a database
query as data to be used for your test.

Using the Properties pane, you can insert data in your test step's input and output values. Using
these parameters enables you to create a data-driven test.

Tip: If Service Test is integrating with ALM, you can use the data awareness features to:

l use a different data resource for each run iteration

l use the same data resource inmultiple tests

l perform other tasks

For details, see "Data Awareness in ALM" on page 324 and "How to Data Drive a Test Using
Data from ALM" on page 328.
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Tasks

How to Create Data Sources
This task describes how to define data sources before selecting a test step. After creating a test
step, you link it to an existing data source. The following steps provide you with different options for
creating a data source. To create a data source for your properties, you only need to add data using
one of these options.

l "Add an Excel data source" below

l "Add an XML data source" on next page

l "Add a database data source" on next page

l "Create a new child relation" on page 94

l "Add a local data table" on page 94

l "Attach a data source to the test flow" on page 94

Add an Excel data source
1. Make sure the Data pane is visible. If not, select View > Data.

2. In the Data pane, click theNew Data Source down arrow and select Excel. The
"New/Change Excel Data Source Dialog Box" (described on page 98) opens.

3. Browse to the file and indicate if the first row is a header row.

4. Specify a name for the data source. If you do not provide a name, Service Test sets it to the
Excel file name after you navigate to the file.

5. Select whether to link to the Excel in its original location or create a local copy. The advantage
of making a local copy is that it becomes portable with the test. However, any updates to the
data at its original location will not be not reflected in themigrated test.

6. Select Allow other tools to override the data option to enable integration with ALM's Data
Awareness. This allows you to overwrite the data from the imported Excel file with values from
an ALM Data Resource. For details, see "Data Awareness in ALM" on page 324.

In addition, if you call a test or action with data assigned to its steps, this option allows you to
edit the data in the called test or action. For details, see "Actions Using the Data Table" on
page 511.

7. Click OK.

8. In the Data pane, select the data source under theExcel node. In the right pane, you can view
and edit the values.

Tip: You can replace an existing Excel data source with a new file. For user interface details,
see "New/Change Excel Data Source Dialog Box" on page 98.
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Add an XML data source
1. Make sure the Data pane is visible. If not, select View > Data.

2. In the Data pane, click theNew Data Source down arrow and select XML. The "New
XMLData Source Dialog Box" (described on page 100) opens.

3. Provide aData Source name.

4. Select the entity upon which to base the data source:

n Schema file:Browse to an .xsd file.

n XML file:Browse to an .xml file.

n Use existing: Browse to an existing XML-based data source from another test.

5. Click OK.

6. Select the data source's node in the Data pane.

7. Edit the XML data in the grid. Click theAdd rows button to add row values. For user
interface details, see "Data Pane" on page 96.

8. To load XML values, click the Load data from an XML file button .

Add a database data source
1. Make sure the Data pane is visible. If not, select View > Data.

2. In the Data pane, click theNew Data Source down arrow and select Database. The
"Add New Database Data SourceWizard" (described on page 102) opens. TheSet Database
Connection page opens.

3. For anOleDB type connection:

a. Select OleDB as theConnection type.

b. Set the connection string in one of the following ways:

o Paste anOLE DB connection string into the text area.

o Select a previously defined connection string from the drop down.

o Click theBuild Connection String button to useMicrosoft's Data Link Properties

HP Service Test (11.52)Page 91 of 705

User Guide
Chapter 5: Data Pane



dialog box. For details, click theHelp button in the Data Link Properties dialog box.

c. Click Test Connection to verify that the connection is valid.

d. Click Next. This button is only available for valid connections.

4. For anODBC type connection:

a. Select ODBC as theConnection type.

b. Click theBuild Connection String button to select a DSN type. For details, see
"Select Data Source NameDialog Box" on page 105.

c. Select a DSN type and provide the necessary credentials. To create or edit a DSN entry,
click theManage ODBC Data Sources button. For details, click theHelp button in the
ODBC Data Source Administrator dialog box. After you close the administrator dialog box,
click theReload DNS list button to refresh the list.

d. Test the connection. After the confirmation, click OK.

5. In theSet SQL Statement page:

a. Provide a unique name for the data source, not used by another data source. If you do not
provide a name, the data source is automatically assigned the table name after you build
the query.

b. Provide an SQL statement in one of the following ways:
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o Paste an existing statement into the text area.

o Select a previously defined statement from the drop down history.

o Click theBuild Query Statement button to open the "Query Designer Dialog Box"
(described on page 456). TheQuery Designer allows you to create a basic SQL query,
with a single table or view. For complex queries, such as those using advanced SQL
features and calculations, create the query in your environment and paste it into the text
area.

c. If you are using theQuery Designer:

o Select a table or view. TheQuery Designer lists all of the rows in the pane below and
displays the corresponding SQL statement in the preview pane.

o EnableAuto execute to view the results of your query as youmake changes in the
upper pane.

o By default, the Query Designer selects all columns in the table. To remove a column
from the query, clear theOutput check box for that column.

o To set a sorting order, select Ascend or Descend from theSort column drop-down. If
you havemultiple rows that you are sorting, provide theSort Order beginning with 1.
TheQuery Designer adds an ORDER BY clause to the preview pane.

o To filter the returned results, enter the text to match in the Filter column.

o To add a GROUP BY or DISTINCT clause to your statements, select the appropriate
check box.

Click OK to accept the query and return to the wizard. Click theReset Query button

to discard the changes.

d. In the wizard's Set SQL Statement page, click theCheck SQL Statement button. A
Query Preview dialog box opens. Click Close to return to the wizard.

e. Click Finish. Service Test shows the query details in the Properties pane's "Database
Data Source Properties Tab (Properties Pane)" (described on page 191). By default the
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Data pane shows the first ten rows of the query data. To change the number of displayed
rows, use the "General Pane (Options Dialog Box > API Testing Tab)" (described on page
271).

f. To update the data at a later stage, click Refresh in the Data pane. The data is not
automatically refreshed—the displayed data is the result of the query when you created the
data source or the last time you clicked theRefresh button.

Create a new child relation
This step lets you add child relations using primary and foreign keys. This applies toExcel, Local
Table, andDatabase type data sources.

1. Add at least two of the above data sources containing the foreign and primary keys. This can
also be a single Excel file with two worksheets.

2. In the Data pane, select the table that you want to designate as a parent.

3. Click in the Properties pane to open the "Data Source Properties Tab (Properties Pane)" on

page 190 (described on page 190).

4. Click theAdd button. The "Define New/Edit Data Relation Dialog Box" (described on page
637) opens.

5. Specify the details of the new relation. You can specify a relation to a different data source
type, provided that it is either anExcel, Local Table, orDatabase type data source.

6. To edit a data relation, double-click the entry or click Edit.

7. To delete a data relation, select the entry and click Remove.

Add a local data table
1. Make sure theData pane is visible. If not, select View > Data.

2. In the Data pane, click theNew Data Source down arrow and select Local Table. The
"New Local Table Data Source Dialog Box" (described on page 106) opens.

3. Click theAdd button to create a column in the data table.

4. In the columns list, specify a column name and description. Select a data type from the drop
down list.

5. Repeat steps 3 and 4 for each column you want to create.

6. Use the arrows to reorder the columns as required .

7. Click theRemove button to delete an unwanted column from the data table.

8. Click OK.

9. In the Data pane, select the table's node in the left pane andmove within the table using the
keyboard arrows. Type within the cells to manually set values.

Attach a data source to the test flow
This step lets you attach a data source to the Test Flow or current loop, even without linking to a
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property. This will allow you to easily access the data source and use it with an event handler.

1. In the Data pane, select the data source.

2. In the canvas, select the Test Flow or loop frame.

3. Select the "Data Sources Tab (Properties Pane)" in the Properties pane (described on page
189).

4. Click Add. The "Attach Data Source to Loop Dialog Box " (described on page 629) opens.

5. Select a data source from the list and click OK.

6. To set a navigation policy, double-click the data source or click Edit in the Properties pane.
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Reference

Data Pane
The Data pane enables you to add, view, and edit data sources for use as property values when
running tests.

To access 1. Create or open a test or component

2. Select View > Data or select the Data pane tab.

Important
information

In order to see the contents of a data source, click its node in the left
pane.

Relevant tasks "How to Create Data Sources" on page 90

See also l "How to Assign Data to Test Steps" on page 621

l "How to Set the Navigation Properties" on page 622

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Element

Description

<data
source
tree>

A hierarchy of the data sources and their subnodes, displayed in the left pane. There
are separate nodes for the test and action data sources: Current Test, <action1>,
<action1>, and so forth.

For Excel files, each sheet represents another set of properties.
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UI
Element

Description

<data
source
content>

The data associated with the selected node, displayed in the right pane. You can edit
values directly from this pane.

If the current test calls another test or action with its own data source, this area
shows the data, provided that you enabled the data to be viewed as described below.

Note: To enable this data to be viewed and edited, click the node in the original
location of the data, and enable theAllow other tools to override the data
option. For details, see "Data Source Properties Tab (Properties Pane)" on page
190.

New Data Source. Creates a new a data source. Expand the drop down to select a
data source type: Excel, XML, Database, or Local Table.

Remove. Removes the selected data source from the Data pane.

XML Data Source - Toolbar
The following controls are available when selecting an XML data source in the Data pane.

UI Elements Description

Go back. Returns to the previous view.

Go to start. Returns to the first row.

Go to the previous row. Navigates to the previous row (one row up).

Row The current row number out of the total rows, such as
1/3 and so forth. Use the drop down tomove to the desired row.

Description A title for the row currently displayed.

Go to the next row. Navigates to the next row (one row down).

Go to end. Navigates to the last row.

Import data from an XML file. Loads data from an XML file.

Export data from an XML file. Exports the current data to an XML file.

Move up.Moves the current row forwards.

Move down.Moves the current row backwards.
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UI Elements Description

Adds a new empty row at one of the following locations.

l Add after current

l Add at start

l Add at end

Duplicates the current row at one of the following locations.

l Duplicate after current

l Duplicate at start

l Duplicate at end

Deletes the current row.

Database Data Source Nodes
The following controls are available when selecting a database data source in the Data pane.

UI
Elements

Description

Refresh. Updates the data from the database.

Count. Opens amessage box with a row count. By default the Data pane shows the
first ten rows of the query data. To change the number of displayed rows, use the
"General Pane (Options Dialog Box > API Testing Tab)"(described on 271).

New/Change Excel Data Source Dialog Box
This dialog box enables you to add a new Excel data source to the Data pane or change the
underlying file for existing Excel data sources.
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To access Before you open the dialog boxes, make sure that a test or component is in focus
in the document pane.

To open the New Excel Data Source dialog box:

1. Create or open a test or component.

2. Select View > Data

3. Click on theNew Data Source down arrow and select Excel.

To open the Change Excel Data Source dialog box:

1. Select themain node of an existing Excel data source.

2. In the Properties pane, click Change Excel File.

Relevant
tasks

"Add an Excel data source" on page 90

See also "Data Link/RelationMessage Box" on page 627

User interface elements are described below:
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UI Element Description

Data source
name

A name for the data source as it will appear in the Data pane. If no value is
specified, it uses the file name.

Note: This field is read-only in the Change Excel Data Source dialog box.

Excel file
path

The complete path of an Excel file on the file system. Use theBrowse button to
locate the file.

Note: Youmust use an absolute path for the Excel file path.

Excel file
contains
header row

Indicates whether the data in the Excel table contains a header row. Header rows
are ignored when running the test.

File location The location for storing the imported Excel data:

l Link to the Excel file in its original location. If the data changes at its
source, it affects your test. In addition, if youmodify the data in your test, it
affects the data at its source.

l Make a copy of the Excel file. Copies the Excel file locally. If the data
changes at its source, it does not affect your test. In addition, the data is
portable together with the test.

Allow other
tools to
override the
data

Enables you to overwrite data from the imported Excel file with values from other
tools, such as an ALM Data Resource (for versions ALM 11.00 and higher), and
GUI or Service Test tests.

For details about ALM data resources, see "Data Awareness in ALM" on page
324.

Tip: If you did not enable this option when you imported the Excel file, you
can enable it separately for each data source in the Properties pane. For
details, see "Data Source Properties Tab (Properties Pane)" on page 190.

New XML Data Source Dialog Box
This dialog enables you to add new XSD or XML data sources to the Data pane.
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To access 1. Do one of the following:

n Ensure that a test or component is in focus in the document pane.

n In the solution explorer, select a test or component.

2. Create or open a test or component.

3. Select View > Data.

4. Click on theNew Data Source down arrow and select XML.

Relevant tasks "Add an XML data source" on page 91

See also "Data Pane" on page 96

User interface elements are described below:

UI
Element

Description

Data
source
name

The display name of the data source. If no name is specified, it uses the file name.

Based
on

The file on which to base the data table:

l Schema file. A file with an XSD extension.

l XML file. A file with an XML extension.

l Use existing. An existing data resource created within another test. Since this
data source is referenced, changes made to it are reflected in all tests using the
data source.

Use theBrowse button to navigate to the desired location.
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Add New Database Data Source Wizard
This wizard enables you to create a data source by retrieving data rows from a database table. You
specify a connection string and an SQL statement to retrieve the data.

To access 1. Do one of the following:

n Ensure that a test or component is in focus in the document pane.

n In the solution explorer, select a test or component.

2. Create or open a test or component.

3. Select View > Data.

4. Click on theNew Data Source down arrow and select
Database.

Relevant tasks "Add a database data source" on page 91

Wizard map This wizard contains:

"Set Database Connection Page" > "Set SQL Statement Page "

See also "Query Builder Dialog Box" on page 455

Set Database Connection Page

This wizard page enables you to define a connection string for connecting to the database.
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Wizard map This wizard contains:

Set Database Connection Page > "Set SQL Statement Page "

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

Connection
type

The type of database connection: OleDB orODBC.

<connection
list>

A drop down list of previously defined connection strings.

Build Connection String.

l ForOleDB connections: Opens theMicrosoft Data Link Properties dialog
box.

l ForODBC connections: Opens the Select Data Source Name dialog box.

<connection
string area>

An editable area for pasting in existing strings, or for editing the connection string
selected in the drop down list.

Tip: To add a string to the drop down list, click Check Connection.

Password The password with which to access the database.

Insert. Inserts the encoded password into the displayed connection string.

Test
Connection

Sends the current connection string to the database server to check its validity.

<connection
status>

Displays the status of the database connection. If it is a valid connection, the
wizard adds the connection string to the list of Connection strings and changes

the status to Connected .

Set SQL Statement Page

This wizard page enables you to prepare an SQL statement for retrieving your data.
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Wizard map This wizard contains:

"Set Database Connection Page" > Set SQL Statement Page

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

Data
source
name

The name of the data source as it is be referenced by your test. If no value is
specified, it uses the name of the table or view.

SQL
statement

A drop down list of the available SQL statements.

Opens the "Query Builder Dialog Box" (described on 455).

<SQL
statement
area>

An editable area for pasting existing SQL strings or for editing the SQL string
selected in the drop down list.

Tip: To add an SQL statement pasted into the text area to the drop down list,
click Check SQL Statement.

Check SQL
Statement

Executes the SQL statement shown in the text area and opens the results in a
Query Previewwindow.

<query
status>

If the statement is valid, the wizard adds it to the drop down list of SQL
statements and changes the status to Query executed successfully.
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Select Data Source Name Dialog Box
This dialog helps you build a connection string for anODBC data source.

To
access

Do one of the following:

From the Database wizard:

1. ChooseDatabase in the Data pane to open the wizard. For details, see "Add
New Database Data SourceWizard" on page 102.

2. Select ODBC as a connection type.

3. Click on theBuild Connection String button adjacent to the Connection
list drop down list.

From the Properties pane:

1. Add a DatabaseOpen Connection activity to the canvas.

2. Click the Input/Checkpoints tab in theProperties pane and click the browse
button in theConnection string property row.

3. In the "Connection Builder Dialog Box" (described on page 453), select ODBC
as a connection type.

4. Click on theBuild Connection String button adjacent to the Connection
list drop down.
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Relevant
tasks

"Add a database data source" on page 91

See also "Add New Database Data SourceWizard" on page 102

User interface elements depend on the type of DSN selected:

UI Element Description

Reload DSN List. Reloads the items that will appear in the drop down list.

User DSN Allows you to select a User DSN and provide credentials:

l User Name

l Password

System DSN Allows you to select a System DSN and provide credentials:

l User Name

l Password

File DSN Allows you to provide the following information for the File DSN or select a file
with the required settings.

l User Name

l Password

l File Content

Test
Connection

Sends the current DSN information to the database server to check its
validity.

Manage ODBC
Data Sources

Opens theMicrosoft ODBC Data Source Administrator dialog box. This dialog
box lets you add, edit or delete data sources at theWindows level.

Tip: After you create or modify a data source on theWindows level, click
theReload DSN List button to refresh the DSN list.

New Local Table Data Source Dialog Box
This dialog box enables to create local data tables in the Data pane for use with your test.

HP Service Test (11.52)Page 106 of 705

User Guide
Chapter 5: Data Pane



To access 1. Do one of the following:

n Ensure that a test or component is in focus in the document pane.

n In the solution explorer, select a test or component.

2. Create or open a test or component

3. Select View > Data.

4. Click on theNew Data Source down arrow and select Local
Table.

Relevant tasks "Add a local data table" on page 94

User interface elements are described below:

UI
Element

Description

Adds a new column to the local data table. New entries are added below the last
column.

Deletes the selected data table column.

Raises or lowers the selection in the column list.
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UI
Element

Description

Columns A list of the columns in the local data table. Click inside a table row to set or edit the
following values:

l Name. The name of the column.

l Data Type. A data type: String, Integer, Double, or Date.

l Description. A description of the data in the column.
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Troubleshooting and Limitations - Data Pane
This section describes troubleshooting and limitations for using the Data pane.

l Excel data with column headers beginning with digits or containing symbols (such as !,@, or # )
are not supported.

l XML data sources: .xml files that use XSL are not supported.
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Chapter 6: Debug Panes
This chapter includes:

Concepts 111

Debug Panes Overview 111

Reference 112

Debug Pane Interface 112

Troubleshooting and Limitations - Debug Panes 130
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Concepts

Debug Panes Overview
After creating an user code file, you can check to see if it runs properly. Using the debug panes, you
can then debug your user code files using Service Test's debugging capabilities.

The debug panes are the primary interface for viewing information about your application during run
sessions.

For a conceptual overview of Service Test's debugging capabilities, see "Debugging Overview" on
page 308.

For a task related to debugging, see "How to Debug Your User Code File" on page 311.

For an exercise to practice using Service Test's debugging capabilities, see "How to Debug a User
Code File - Exercise" on page 314.
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Reference

Debug Pane Interface
The Debug panes enable you to perform different debugging activities when a run session is
suspended, such as:

l View, set, or modify the current value of objects or variables in your user code file

l RunC# commands in your paused run session

l Viewing information about the current call stacks of your test

l View information about the associated .dll files and threads being used in your run session

The image below shows all the Debug panes open as tabs. The default debug pane shown is the
Debug Breakpoints tab.
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To
access

1. Ensure that a user code file is in focus in the document pane.

2. Select View > Debug and choose the relevant debug pane.

Impor-
tant
infor-
mation

Debug panes display information only when a run session is paused. A run session can
be suspended in the following situations:

l The run session stops at a breakpoint.

l You useRun menu commands or context-menu options (such as Pause) to
suspend a run session.

Rel-
evant
tasks

"How to Debug Your User Code File" on page 311
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See
also

l "Debugging Overview" on page 308

l "Considerations for Debugging User Code Files" on page 308

l "How to Debug a User Code File - Exercise" on page 314

The following debug panes are available:

UI Element Description

Breakpoints
pane

Displays the information about all breakpoints inserted into your user code file
and enables you to enable or disable any or all breakpoints in a run session. For
details, see " Breakpoints Pane" below.

Call Stack
pane

Displays information about the functions, methods, or context currently relevant
to your tests. For details, see "Call Stack Pane" on page 116.

Loaded
Modules
pane

Displays information about the .dll files associated with your run session and
provides the path to find and debug them. For details, see "LoadedModules Pane
" on page 119.

Threads
pane

Displays information about the threads running in your current run session. For
details, see "Threads Pane " on page 120.

Local
Variables
pane

Displays the current values and types of all variables in the current context of the
test. For details, see "Local Variables Pane" on page 122.

Console
pane

Enables you to run C# commands in your paused run session. For details, see
"Console Pane" on page 124.

Watch pane Displays the current values and types of variables and C# expressions that you
add to theWatch pane. For details, see "Watch Pane" on page 126.

Breakpoints Pane

This debug pane enables you to view information about breakpoints inserted into your user code
files and navigate directly to the breakpoint location in the relevant test.
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To access 1. Do one of the following:

n Ensure that a user code file is in focus in the document pane.

n In the solution explorer, select a test, component, or user code node.

2. Select View > Debug > Breakpoints

Note: This pane displays information only when a breakpoint is inserted
into a user code file.

HP Service Test (11.52)Page 115 of 705

User Guide
Chapter 6: Debug Panes



Important
information

l The pane displays the breakpoints for the tests that are part of the current
solution.

l You can double-click on a breakpoint to navigate directly to the relevant
line.

l Breakpoints are saved with your test or user code file and aremaintained
even after you close Service Test.

Relevant tasks "How to Use Breakpoints " on page 312

See also "Breakpoints " on page 309

User interface elements are described below:

UI
Element

Description

Remove Current Breakpoint. Removes the current breakpoint from your test.

Disable/Enable Current Breakpoint. Disables or enables the selected breakpoint,
which instructs Service Test to use or ignore it during a run session.

Go to Source. Navigates directly to the line containing the selected breakpoint in
your test.

Remove All. Removes all breakpoints listed in the pane from the tests that contain
them.

Enabled A check box that specifies whether the breakpoint is enabled or disabled.

Name The file name of the document that contains the breakpoint, and the number of the line
in the file that contains the breakpoint.

Script The name of the user code file that contains the breakpoint.

Call Stack Pane

This debug pane enables you to view information about themethods and functions that are currently
on the call stack of your test, component, or user code file or the context in which the run session
was paused.
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To access 1. Do one of the following:

n Ensure that a test, component, or user code file is in focus in the document
pane.

n In the solution explorer, select a test, component, or user code node.

2. Select View > Debug > Call Stack.

Note: This pane displays information only when a run session is paused.
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Important
information

l This pane is read-only.

l You can navigate directly to the beginning line of a function, method, or context
in your test by clicking on its row in the pane. If the relevant test is not open,
Service Test opens it.

l TheWatch pane and Local Variables pane display information relevant to the
context that you select in the Call Stack pane.

For example, if you select the row for a specific function in the Call Stack pane,
the variables from this function and expressions selected to watch from this
function are displayed in their respective panes.

l Caution: If you navigate to a stack that is not defined in a user code file,
Service Test opens other coding files. Do not edit this code. Doing so can
cause unexpected behavior in your run sessions.

User interface elements are described below:

UI
Element

Description

Function
name

The name of the function, method, or context currently relevant.

Note: If a run session is suspended before running a step or event or there is no
specific function or event being run, then this pane displays the string
Script.TestUserCode.<event name>. The expressions displayed in the
Local Variables andWatch panes are evaluated within the context of the
suspended step or event.

File
name

The name of the file containing the called function, method, or context. This is the
location in the file system or an ALM project.

Line # The line number on which the function, method, or context definition begins.

Context
menu
options

The following context menu options are available:

l Show external methods. Displays all methods running in the background during
a run session.

Note: The Call Stack pane displays the external methods for informational
purposes. You cannot navigate to the stack displayed in thesemethod calls.

l Show module names. Displays the .dll file in which themethod call is found.

l Show argument values.

l Show line number. Displays the line number on which themethod call begins for
accessible internal methods.
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Loaded Modules Pane

This debug pane enables you to view information about the .dll files loaded and executed as a test
runs.
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To access 1. Do one of the following:

n Ensure that a test, component, or user code file is in focus in the
document pane.

n In the solution explorer, select a test, component, or user code
node.

2. Select View > Debug > Loaded Modules

Note: This pane displays information only when a run session is
paused.

Important
information

The list of .dll files is displayed only when you pause a run session.

User interface elements are described below:

UI
Element

Description

Name The name of the .dll file.

Address The numeric address of the .dll file.

Path The location of the .dll file in the file system.

Order The order in which the .dll files are used in your run session.

Symbols The symbols included with each .dll file, which allow for debugging of loaded
modules.

Note:

l A .dll file's symbols must be loaded to enable you to debug a .dll file.

l Many of the .dll files listed in this pane have no symbols loaded, as they
are files called by Service Test during a run session.

l Any .dll files you add to your test can be debugged if there is a run error.

Threads Pane

This pane enables you to view information about the threads currently running as part of the run
session.
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To access 1. Do one of the following:

n Ensure that a test, component, or user code file is in focus in the
document pane.

n In the solution explorer, select a test, component, or user code node.

2. Select View > Debug > Threads

Note: This pane displays information only when a run session is paused.

Important
information

l The list of threads is displayed only when you pause a run session.

l If your test contains only one thread, then this pane is not available.

l If the thread is contained within a user code file, you can double-click on the
thread to navigate directly to the beginning of the thread.
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User interface elements are described below:

UI
Element

Description

ID The numeric identification of the thread.

Name The name given to a particular thread.

Location The location in which the thread is found.

Note: Some threads are not found in your user code, but represent background
threads that are part of your test. These threads are not accessible.

Priority The order in which the threads can be used when running amulti-thread operation.
Higher priority threads are called first.

Frozen Indicates whether a thread is frozen or unfrozen. Right-click a thread to freeze or
unfreeze it.

Local Variables Pane

This debug pane displays the current values and types of all variables in current the context of your
test.
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To access 1. Do one of the following:

n Ensure that a test, component, or user code file is in focus in the document
pane.

n In the solution explorer, select a test, component, or user code node.

2. Select View > Debug > Local Variables

Note: This pane displays information only when a run session is paused.
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Important
information

l The information displayed in this pane is read-only.

l You cannot edit the value of expressions in the pane. To change the value of
an expression, enter a command in the "Console Pane".

l Only variables that were recognized up to the last event that occurred are
displayed in the Local Variables pane. As you continue stepping through the
subsequent steps in your test, Service Test adds any additional variables that
it recognizes and updates the values displayed in the Local Variables pane.

Relevant
tasks

"How to Debug Your User Code File" on page 311

See also l "Debugging Overview" on page 308

l "Considerations for Debugging User Code Files" on page 308

l "Watching the Values of Variables and Properties of Objects During a Run
Session" on page 309

l "How to Debug a User Code File - Exercise" on page 314

User interface elements are described below:

UI
Element

Description

Name The name of the variable, or an expandable node whose child elements contain details
about the variable. For example, if a variable is assigned to an object, you can expand
the variable in the pane and view its methods and properties.

Value The current value of the variable.

Note: If a variable node contains child elements, the value column indicates the
number of child elements.

Type
Name

The type of the variable's value (for example, Integer orString).

Console Pane

This debug pane enables you to run lines of C# code in your suspended run session.

For example, you can run code that performs any of the following activities before you resume the
run session:

l Modifies the input and output properties for a step

l Sets or modifies a variable

HP Service Test (11.52)Page 124 of 705

User Guide
Chapter 6: Debug Panes



To access 1. Do one of the following:

n Ensure that a test, component, or user code file is in focus in the document
pane.

n In the solution explorer, select a test, component,, or user code node.

2. Select View > Debug > Console

Note: This pane displays information only when a run session is paused.

Important
information

l You can enter lines of code in the Console pane only when a run session is
suspended. When no run session is suspended, you can view the command
history, or use theClear All command.
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Relevant
tasks

"How to Debug Your User Code File" on page 311

See also l "Debugging Overview" on page 308

l "Considerations for Debugging User Code Files" on page 308

l "Watching the Values of Variables and Properties of Objects During a Run
Session" on page 309

l "How to Debug a User Code File - Exercise" on page 314

UI elements
Console pane user interface elements are described below (unlabeled elements are shown in angle
brackets):

UI Element Description

Clear Console. Enables you to erase all of the commands entered in the
command line area.

Delete History. Clears all previously saved commands. By default, all previous
commands are saved in the pane and can be selected for a new command by
using the up or down arrows.

Toggle Word Wrap. Enables or disables word wrap behavior for commands
given in the command line area.

<command
line area>

Enables you to enter a line of code to be run in the context of your suspended run
session. Type or paste the line of code in the window and press ENTER to run the
code.

This area also displays the command line history, including the lines of code that
you ran.

Notes:

l You cannot make any changes to these lines, but you can select and copy text
from them.

l You can use the UP and DOWN arrow keys to browse through the command
history. Service Test copies the commands to the active command line,
enabling you to repeat or reuse commands that you entered earlier.

Watch Pane

This debug pane enables you to view the current values and types of selected variables, properties,
and C# expressions in your suspended run session.
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To access 1. Do one of the following:

n Ensure that a test, component, or user code file is in focus in the document
pane.

n In the solution explorer, select a test, component, or user code node.

2. Select View > Debug > Watch.

Note: This pane is only relevant when a run session is paused.
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Important
information

l You can add, edit, or remove expressions within theWatch pane using the
pane's toolbar buttons in addition to theRun menu command (Run > Add to
Watch).

l You cannot edit the value of expressions in the pane. To change the value of a
watched expression, enter a command in the "Console Pane".

l You can expandWatch pane items if the property selected contains multiple
values.

l You can sort the columns in the watch pane by expression, value, or type
name by clicking the column headers.

l Watch expressions are saved with the test andmaintained between testing
sessions and as you switch between open user code files.

l If you added an item to this pane from an user code file that already ran, the
pane will show it as undefined.

Relevant
tasks

"How to Debug Your User Code File" on page 311

See also l "Debugging Overview" on page 308

l "Considerations for Debugging User Code Files" on page 308

l "Watching the Values of Variables and Properties of Objects During a Run
Session" on page 309

l "How to Debug a User Code File - Exercise" on page 314

User interface elements are described below:

UI Element Description

Add New Watch Expression. Opens the Add New Watch dialog box, which
enables you to add a new expression to theWatch pane. After you enter the
expression and click OK, Service Test displays the value and type of the
expression in the pane.

Edit Watch Expression. Enables you to edit the selected expression during your
debug session.

Remove Watch Expression. Removes the currently selected expression from
theWatch pane.

Remove All. Removes all the expressions currently displayed in theWatch pane.
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UI Element Description

Expression The expression whose value you want to watch. For details on adding and
removing expressions from theWatch pane, see "Watching the Values of
Variables and Properties of Objects During a Run Session" on page 309.

Caution: Service Testruns the expressions in theWatch pane to evaluate
them. Therefore, do not enter any expression whose evaluation could affect
the state of the test, as this can lead to unexpected behavior of your test.

Value The current value of the expression. The evaluated value is displayed only when a
run session is suspended.

Type name The type of the expression's value after it is evaluated (for example, Integer or
String).

If an expression cannot be evaluated in the current context, the type displayed is
Incorrect expression.
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Troubleshooting and Limitations - Debug Panes
This section describes troubleshooting and limitations for the Debug Pane.

l You cannot edit variables or properties from the Local Variables orWatch Panes.

Workaround:Use the Console pane to edit andmodify your variable and property values by
running a command line to assign the new value.
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Concepts

Document Pane Overview
The document pane is themain design area in Service Test and displays all open documents as
separate tabs. Each tab can also be individually moved, docked, or floated as an independent pane,
and you can drag and drop or pin any of the Service Test panes within the document pane. You can
also restore the tabs or panes to the default location from theView menu.

The document pane displays the following types of documents:

l Service Test documents:

n Tests

n Actions

n C# files containing event handler code (TestUserCode.cs files)

n C# user code files

l Business Process Testing documents:

n Business process tests

n Business process flows

n API components

l Non-testing documents:

n Text files

The features available for viewing and editing documents depend on the document type, as
described in the following table.

Document
Type

Opens in the:

l Tests

l Actions

l Business
components

Canvas. Graphically displays and enables you to edit the flow of your test,
action, or component.

For details, see: "The Canvas" on page 373

l C# code
files

l Text files

Editor. Provides text and code editing features that facilitate the design of your
text, script, and code documents.

For details:

l "Editing Text and Code Documents" on next page

l "How to Open aWindow forWriting Custom Code" on page 644
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Multiple Tests in the Document Pane

Using the document pane, you can open and work with multiple tests simultaneously. To open
multiple tests, they must all be included in the same solution.

You can navigate betweenmultiple tests by clicking the tab name of the test you want to view. You
can also use the document view drop-down arrow to display a list of open tests.

For details onmanaging tests, see "How to Create andManage Tests" on page 56.

Editing Text and Code Documents
You can write customized code for your tests by modifying user code files in the Editor.

The Editor supports common text and code editing features. For details, see:

l "Statement Completion in User Code Files" below

l "Automatic Code Completion" on page 135

l "Bookmarks Overview" on page 84

l "Searching and Replacing in the Editor " on page 135

l For API testing: "Coding Service Test Events" on page 641

Other notable Editor features include expanding and collapsing code, zooming in and out using the
mouse, and code templates defined in the Code Templates pane of the Options dialog box (Tools >
Options > Coding tab > Code Templates node). For details about defining code templates, see
"Code Templates Pane (Options Dialog Box > Coding Tab)" on page 277.

To define other preferences related to viewing and editing documents in the Editor, see "Text Editor
Tab (Options Dialog Box)" on page 279.

For a user interface description of the Editor, see "Editor User Interface" on page 147.

Statement Completion in User Code Files

Statement completion, which is similar to Microsoft's IntelliSense functionality, enables you to
increase programming speed and accuracy by providing dynamic lists of items, in the form of
tooltips, drop-down lists, or popup windows, while writing statements in the Editor.

As you type in the Editor,Service Test displays items youmight want to add to your statement, as
well as the syntax relevant to what you are typing. Service Test provides this type of statement
completion information, when available, for:

l Activity-specific properties

l Function andmethod syntax

l Operations

l Variable definitions andmethods

For details about statement completion in the Editor, see:
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l "Statement Completion Options" below

l "Statement Completion Considerations" on next page

Statement Completion Options

The following table summarizes some statement completion options available when you enter
specific items and keystrokes.

If you
enter:

Followed
by:

Service Test displays:

An
operation
name

SPACE or
Open
parenthesis"
("

The operation syntax, including its mandatory and optional arguments.
When you add a step that uses an operation, youmust define a value
for eachmandatory argument associated with the operation.

An
argument

Comma (,) The operation syntax, bolding the next argument for which you need to
enter a value.

Relevant if you enter a comma after any argument value other than the
last one in a step.

Note: For certain operations, when you type the space or comma
before an argument that has a predefined list of values, Service
Test displays the list of possible values.

An
operation
or
function
name

CTRL+S
HIFT+SPACE

The statement completion (argument syntax) tooltip for that item.

CTRL+SPACE A dynamic list of the relevant:

l operations

l properties

l user-defined functions

l constants and local variables relevant to the current programming
scope

l functions andmethods relevant to the current programming scope

Note: If there is only one relevant item defined, its name is
automatically entered in the step, without opening the list. For
example, if you typed the beginning of the item name before
pressing CTRL+SPACE, and only one itemmatches the text you
typed.
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If you
enter:

Followed
by:

Service Test displays:

The beginning of an item
in the statement
completion list

The list of items, highlighting the first item (alphabetically) that
matches the text you typed. Pressing ENTER or SPACE adds the
highlighted word to the step.

Statement Completion Considerations

Whenworking with Service Test's statement completion feature, consider the following:

l To close the statement completion drop-down list without selecting from it, press ESC.

l If you resize the frame in which the statement completion drop-down list is displayed, Service
Test subsequently uses the new size when it displays statement completion drop-down lists.

l Service Test might not display statement completion information if the statement is typed
incorrectly and contains syntax errors. In many cases, you can view such errors in the "Errors
Pane" (described on page 172) when you save your changes.

Automatic Code Completion

Service Test provides automatic code completion features, to facilitate coding in the Editor. This
includes templates that you can use to insert code snippets by typing specific keywords.

You can alsomodify the templates provided, or build your own customized templates as needed,
and define the keywords used to invoke the use of each template.

For example, youmight repeat a complicated If...Then statement many times your document. You
can use an existing template for the If...Then statement to create your own customized template
with your more complicated code. You can also create templates from scratch, such as a comment
block template, whichmight include information such as programmer identification, date added, or
other details you want included in all comments.

Code templates are defined in the "Code Templates Pane (Options Dialog Box > Coding Tab)"
(described on page 277), and are supported for .cs files and .txt files.

For details, see "How to Use Code Snippets and Templates" on page 139.

Searching and Replacing in the Editor

You can search in the Editor for text strings, as well as references, derived classes, base classes,
or overridingmethods, for the current method, function or class.

When searching for text, you can use standard text or regular expressions in your search strings,
and you can perform string replacements. You can also search in documents that are closed but
accessible by the search functionality, either by searching an entire solution, or specifying a search
folder.

For details, see "How to Find or Replace Strings in Files" on page 141 and "How to Search for
References or Classes in Tests in the Editor" on page 140.
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Note: Search and replace functionality is not available in the canvas.

For details, see:

l " Regular Expressions in the Find and Replace Dialog Boxes" on page 165

l "File and Item Types Included in String Searches" below

File and Item Types Included in String Searches

When performing text searches or replacements you can search throughout an entire test or folder.
However, the specific file and item types searched within the test or folder are defined by the
search algorithm and cannot bemodified by users.

Note: The search is limited to the text in the file at the time that the Find or Replace dialog box
was opened. Any changes made after opening the dialog box are not included the search.

Searches for strings in tests
When you search for text strings in tests, you can search in actions, *.cs files, or *.txt files. The
search is performed in each source codemodule and in the test flow.

When you search in a specific C# source code file, the search is performed throughout all user code
in the test, as a single text file.

You can search for the following types of items:

l Activity or event display names or event handles

l Global environment variable display names and values

l Link expressions

l Loaded XML or schema files

l Test setting definitions

l Visible checkpoint or property display names and values

l X-paths

Regular Expressions Overview
A regular expression is a string that specifies a complex search phrase. By using special
characters, such as a period (.), asterisk (*), caret (^), and brackets ([ ]), you can define the
conditions of a search.

Regular expressions are used to identify objects and text strings with varying values. You can use
regular expressions to instruct Service Test to find a value that matches a particular pattern or
condition instead of a specific hard-coded value.

Whenever a Service Test feature supports regular expressions, the relevant dialog box includes a
Regular Expression check box. Selecting this check box instructs Service Test to treat the
provided value as a regular expression. Some dialog boxes that contain aRegular Expression
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check box, also contain a right arrow adjacent to the text box for the value. Clicking this arrow
enables you to select regular expression characters from a drop-down list, and to test your regular
expression tomake sure it suits your needs. For more details, see "Smart Regular Expression List"
on page 168.

You can use regular expressions only for values of type string.

For details on defining regular expressions, including regular expression syntax, see "Regular
Expression Characters and UsageOptions" on page 161.
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Tasks

How to Use Bookmarks in the Editor
This task describes how to use bookmarks in tests and includes the following steps:

l "Insert bookmarks into a document" below

l "Navigate between bookmarks and to specific bookmarks" below

l "Clear bookmarks" below

Insert bookmarks into a document
1. Create or open a user code file. For details, see "How to Create andManage Tests" on page

56.

2. Click in the line to which you want to assign a bookmark.

3. Select Search > Bookmarks > Toggle Bookmarks, or press the Bookmarks button in the
Bookmarks pane. A bookmark icon is added to the left of the selected line and is also
displayed in the "Bookmarks Pane" (described on page 83).

Navigate between bookmarks and to specific bookmarks
1. To navigate between bookmarks listed in the "Bookmarks Pane", do one of the following:

n Select Search > Bookmarks > Next Bookmark orSearch > Bookmarks > Previous
Bookmark to navigate forward and backward, respectively.

n In the "Bookmarks Pane", click theNext Bookmark andPrevious Bookmark
buttons.

2. To navigate to a specific bookmark, double-click the bookmark's line in the "Bookmarks Pane".

Clear bookmarks
Do one of the following:

l Click a bookmark icon to the left of the selected line to delete the bookmark.

l In the "Bookmarks Pane", click theDelete button to delete the selected bookmark.

l In the "Bookmarks Pane", select Search > Bookmarks > Clear All Bookmarks or click the

Delete All button in the "Bookmarks Pane" to delete all bookmarks.

How to Use the Go To Dialog Box in the Editor
This task describes how to go to a specific line of code, class, or function, in a  user code, or to
navigate to any file.

1. Create or open auser code file. For details, see "How to Create andManage Tests" on page 56.

2. In the Editor, select Search > Go To > Location. The "Go ToDialog Box" (described on page
158) opens.
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Tip: By default, line numbers are displayed in the Editor. If they are not displayed, you can
select theShow line numbers option in the General pane of the Text Editor pane (Tools >
Options > Text Editor tab > General node). For details on the Text Editor options, see
"General Pane (Options Dialog Box > Text Editor Tab)" on page 279.

How to Use Code Snippets and Templates
This task describes how to insert pre-designed code snippets or blocks of text into your document,
as well as how tomanage templates for such snippets in the "Code Templates Pane (Options
Dialog Box > Coding Tab)" (described on page 277). For details on code snippets and templates,
see "Automatic Code Completion" on page 135.

This task includes the following steps:

l "Insert code snippets into your test in the Editor" below

l "Modify an existing list of code templates" below

l "Remove an existing list of code templates" on next page

l "Add a new list of code templates" on next page

Insert code snippets into your test in the Editor
1. Create or open a user code file. For details, see "How to Create andManage Tests" on page

56.

2. Place your cursor at the point in the file that you want to insert the code snippet, type the
keyword for a code template defined in the Code Templates pane of the Options dialog box,
and press TAB.

Modify an existing list of code templates
1. Open the "Code Templates Pane (Options Dialog Box > Coding Tab)" (described on 277).

2. From the File Types drop-down list, select the item associated with the list of templates you
want to modify. The table lists all code templates defined for the selected file type or types.

3. To edit the file types associated with the selected list, click Edit List. In the Edit List dialog
box, enter the file type or types that should be supported by the selected list, separated by
semi-colons (;).

4. To edit the list of code templates, select the table row for the code template you want to modify
and do one of the following:

n Add a new template in the list:Click the empty space below the last row in the table,
above the syntax area.

n Edit the template name:Double-click the cell in the Template column, and update the
name.

n Edit the keyword:Double-click the cell in the Keyword column, and update the keyword.
The keyword is the text that you enter in the Editor to insert the template.

n Edit the code template description:Double-click the cell in the Description column and
update the description text.
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n Edit the code syntax inserted into your code:Click inside the code syntax area below
the table and update the code.

Note: Note that changes made here do not affect the code snippets available from the
Edit > Code Snippetmenu, which are static and cannot bemodified.

Remove an existing list of code templates
1. Open the "Code Templates Pane (Options Dialog Box > Coding Tab)", described on page 277.

2. From the File Types drop-down list, select the item associated with the list of templates you
want to remove. The table lists all code templates defined for the selected file type or types.

3. Click Remove List. All code templates associated with the selected file types are removed,
as well as the File Types item.

Caution: This action is irreversible.

Add a new list of code templates
1. Open the "Code Templates Pane (Options Dialog Box > Coding Tab)", described on page 277.

2. Click Add List.

3. In the Add List dialog box, enter the file types you want to associate with your new list of
templates, separated by semi-colons (;). A blank list is added to the table.

4. In each of the cells in the rows, enter text to add template names, keywords to be entered in
the code, and descriptions of each template. In the syntax area below the table, enter the code
template to be inserted in your code.

5. To add a new row in the list, click the empty space below the last row in the table, above the
syntax area.

How to Search for References or Classes in Tests in the
Editor

This task describes how to search for references to functions or method definitions, or base or
descending classes, and includes the following steps:

l "Search for references to the currently selected function or method" below

l "Search for classes derived from the currently selected class" on next page

l "Search for methods that override a virtual method" on next page

l "Search for the base class of the current class" on next page

Search for references to the currently selected function or method
1. Create a new user code file, or open an existing one. For details, see "Specify an event handler

- optional " on page 385 or "How to Open aWindow forWriting Custom Code" on page 644.

2. Select a function or method definition, and then select Search > Find References.

The search results found are displayed in the "Search Results Pane" (described on page 231).
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Search for classes derived from the currently selected class
1. Create a new user code file, or open an existing one. For details, see "Specify an event handler

- optional " on page 385 or "How to Open aWindow forWriting Custom Code" on page 644.

2. Select a class and then select Search > Find Derived Symbols.

The derived classes are displayed in a small drop-down box under the selected class. For
example:

Search for methods that override a virtual method
1. Create a new user code file, or open an existing one. For details, see "Specify an event handler

- optional " on page 385 or "How to Open aWindow forWriting Custom Code" on page 644.

2. Select a class and then select Search > Find Derived Symbols.

The overridingmethods are displayed in a small drop-down box under the selected class. For
example:

Search for the base class of the current class
1. Create a new action or user code file, or open an existing one. For details, see "Specify an

event handler - optional " on page 385, "How to Open aWindow forWriting Custom Code" on
page 644, or "How to Use Actions in a Test" on page 513.

2. Select a class and then select Search > Find Base Classes.

The base classes are displayed in a small drop-down box under the selected class. For
example:

How to Find or Replace Strings in Files
This task describes how to search for strings in files that are open in the document pane or
supported by the search functionality and includes the following steps:
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l "Define the search or replace criteria" below

l "Search for strings in files" below

l "Replace strings in files" on next page

You can find individual occurrences, display all search results, or replace occurrences of the search
string with a different string. If a search generates multiple results, all results are displayed in the
"Search Results Pane" (described on page 231).

Note: You cannot modify the file and item types included in the search, which are defined by
the search algorithm. For details, see "File and Item Types Included in String Searches" on
page 136.

Define the search or replace criteria
1. Create or open a user code file. For details, see "How to Create andManage Tests" on page

56.

2. Do one of the following:

n To only find strings, open the "Find Dialog Box", described on page 152.

n To find and replace strings, open the "Replace Dialog Box", described on page 155.

3. In the Find text field, enter a search string using plain text or regular expressions. For details,
see " Regular Expressions in the Find and Replace Dialog Boxes" on page 165.

4. If you entered a regular expressionmanually, select theRegular Expression check box. (If
you selected a regular expression from theExpression Builder drop-down list, theRegular
Expressions check box is automatically selected.)

5. For replacements only: In theReplace with field, enter the replacement string.

6. From the Look in drop-down list, select a location in which to search, or search and replace.
Supported locations include the current test, document, or any specified folder, except for
folders stored in ALM. If you want to search inside a document stored in ALM, youmust open
the document first.

7. Select any of the other search options as needed, includingmatching the text case, matching
the whole word, searching upwards in the file instead of downwards, or including subfolders if
you selected a folder to search.

Search for strings in files
To search for occurrences of the string one by one:

Do one of the following:

l In the "Find Dialog Box" (described on page 152), click Find Next.

l To search again for themost recently defined search criteria without opening the Find dialog box,
select Search > Find Next or press F3.

The cursor jumps to the next occurrence of the search string and highlights the string. If the search
string is found in a closed file, the file automatically opens in the document pane.

To search for all occurrences of the search string:
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In the Find dialog box, click Find All. The search results are displayed in the "Search Results
Pane" (described on page 231).

To perform an incremental search as you type:

1. Do one of the following:

n To search from the cursor location towards the end of the file, select Search > Incremental
Search or press CTRL+E.

n To search from the cursor location towards the top of the file, select Search > Reverse
Incremental Search or press CTRL+SHIFT+E.

The cursor changes to a binoculars icon with an arrow pointing in the search direction.

2. Start typing the string you want to find. Service Test highlights the next matching string.

3. Click anywhere in the file to change the cursor back to the regular cursor.

Note:When performing incremental searches, you can find only one search result at a
time. Repeat this step to find the next occurrence of the search string.

Replace strings in files
To replace occurrences of the string one by one:

1. In the "Replace Dialog Box" (described on page 155), click Find Next until you reach the
search result you want to replace.

2. Click Replace. The selected string is replaced with the defined replacement text. The next
occurrence is automatically highlighted.

To replace all occurrences of the search string:

In the Replace dialog box, click Replace All. A confirmationmessage lists the number of
occurrences replaced.
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Reference

Document Pane User Interface
This pane enables you to view and edit Service Test documents. For details on the types of
available documents, see "Document PaneOverview" on page 132.

The image below shows the various document types available in Service Test, including (from left
to right):

l An action (canvas)

l An event handler (Editor)

l A test (canvas)

Note: The documents shown in the image below have been undocked from the document
pane. By default, these views are displayed as tabs in the document pane.

To access Do one of the following:

l Create or open a test.

l Double-click a node in the Solution Explorer.

A test opens as a tab in the document pane.
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Important
information

l If you select a test in the Solution Explorer, but do not double-click it to bring it
into focus in the document pane, some other panes (such as the Properties
pane), automatically display content relevant for that test. Therefore, the test
displayed in the document panemay not correspond to the content of other
open panes.

l When you bring a test into focus, the corresponding node in the Solution
Explorer is highlighted, and other panes are updated accordingly.

Relevant
tasks

"How to Create andManage Tests" on page 56

See also l "Document PaneOverview" on page 132

l "Document Pane Context MenuOptions" below

l "Editor User Interface" on page 147

User interface elements for the document when documents are displayed as tabs are described
below (unlabeled elements are shown in angle brackets):

UI
Element

Description

<tab
name>

The name of the test.

If you hover over the name of the tab, you can view information about the selected
document:

l For actions: the test in which the action is located

l For user code files: the path on the file system in which the document is saved

Displays a drop-down list of all tests currently open in the document pane.

Closes the active test.

User interface elements for the document when documents are displayed as floating documents
are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<window name> The name of the test.

Closes the active test.

Document Pane Context Menu Options
This section describes the context menu options available for documents displayed as tabs or
document windows in the documents pane.

To access Right-click the test tab or title bar (for floating documents).

Important
information

This information describes the context menu options for general document pane
tabs and floating documents. For details on the context menu options for a
specific type of document, see the relevant section in this guide.
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The context menu options for documents displayed as tabs are described below:

Menu
Command

Keyboard
Shortcut

Description

Close CTRL+F4 Closes the current test.

Close All
Documents

CTRL+S
HIFT+
F4

Closes all tests.

Close All
but This

Closes all tests except the current test.

Save CTRL+S Saves the current test.

Note: This command is enabled only if you havemodified a test.

Save As Opens the "Save <Resource>/Save <Document> As Dialog Box"
(described on page 72) so you can save a copy of the current
document. with another name or in another location.

Note:

This option is enabled only if a test is able to be saved under a
different name. For example, you can perform Save as for a
test but not a test action.

This option is only available if the open document is an editable
file (such as a user code file.)

Copy
file/path
name

Copies the full path of the document in the file system or an ALM
project to the Clipboard.

Note: This option is only available if the open document is an
editable file (such as a user code file.)

Open
Containing
Folder in
Explorer

Opens the folder containing the document inWindows Explorer.

Note: This option is only available if the open document is an
editable file (such as a user code file.)

The context menu options for documents displayed as floating windows are described below:

UI Element Description

Close Closes the test.

Dock as Tabbed Document Attaches the test as a tab in the document pane.
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Editor User Interface
This view enables you to edit text and code for user code files, and text files.

To access Create a new user code file, or open an existing one.

Important
information

To open the help topic for a specific object or method from the Editor, do the
following:

1. Verify that you do not have any text highlighted.

2. Place the cursor in themiddle of the word and press F1.

Note: You can also use these steps to find VBScript items referenced in the
Microsoft VBScript help, included in the Service Test Help. If you place the
cursor in an item that is not part of the Service Test test object model and
press F1, the Service Test Help displays the item as found in the index, or if
the exact item is not found, the closest alphabetical item in the index.
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Relevant
tasks

"How to Create andManage Tests" on page 56

"How to Create an API Test" on page 383

"How to Use Bookmarks in the Editor" on page 138

"How to Use theGo ToDialog Box in the Editor" on page 138

"How to Use Code Snippets and Templates" on page 139

"How to Search for References or Classes in Tests in the Editor" on page 140

"How to Find or Replace Strings in Files" on page 141

See also l "Editing Text and Code Documents" on page 133

l "Coding Service Test Events" on page 641

l "Text Editor Tab (Options Dialog Box)" on page 279

l "Find Dialog Box" on page 152

l "Replace Dialog Box" on page 155

l "Go To Dialog Box" on page 158

l "Bookmarks Pane User Interface" on page 85

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Element

Description

<class
and
function
browsers>

Drop-downmenus that enable you to quickly browse to a class and function by
selecting from those available in the current document. These drop-downmenus
aremost helpful in documents that includemany function definitions, such as
function libraries.

To navigate to a class or function definition, first select the class from the left drop-
downmenu, and then select the function from the right drop-downmenu.

Note: If the class and function browsers are not displayed, you can select the
Show class/function browser option in the General pane of the Text Editor
pane (Tools > Options > Text Editor tab > General node).

<Icon
margin>

Display icons for lines with specific types of code, such as classes, events, or
fields. For details, see "Editor Icons" on page 150.

HP Service Test (11.52)Page 148 of 705

User Guide
Chapter 7: Document Pane



UI
Element

Description

<Line
number
margin>

Displays the line numbers for each line of code. You can use the "Go ToDialog
Box" (described on page 158) to navigate to a specific line in the code.

Note: If the line numbers are not displayed, you can select theShow line
numbers option in the General pane of the Text Editor pane (Tools > Options
> Text Editor tab > General node.

<Expand and collapse>. Expands or collapses folded code. Folded code is
indicated by an ellipsis at the end of the first line of the folded code.

Tip: Hover over the ellipses to display a snapshot of the hidden code.

Note: If the expand and collapse buttons are not displayed, you can select the
Enable folding option in the General pane of the Text Editor pane (Tools >
Options > Text Editor tab > General node.

<Zoom control bar>. Displayed in the lower left corner of the Editor, only after
having zoomed in or out of the text for the first time in a session.

l Click the Zoom in icon to zoom in.

l Click the Zoom out to zoom out.

l Click theDefault zoom icon to return the text to the default size.

Class and Function Browser Examples

The following image shows an example of an action containing two classes and a function. Each of
the classes contains two functions.

The functions defined in a specific class are displayed in the function browser only when you select
that class in the class browser. If you select one of these functions, the cursor jumps to that
function definition. If you select a different class from the class browser, the cursor jumps to that
class definition.

In this image, theMain.class1 class is selected in the class browser, and the function browser is
expanded, displaying the functions defined in the class1 class (fucnt_1a and fucnt_1b).

In the class browser, theMain item represents the context of the document. In this image, if you
selectMain from the class browser, the function browser displays only funct_A.
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Editor Icons

Icons used in the Editor to indicate the different types of code are described below:

Type Icon Description

Class Class

Internal class

Private class

Protected class

Delegate Delegate

Internal delegate

Private delegate

Protected delegate
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Type Icon Description

Enumeration definition Enumeration definition

Internal enumeration definition

Private enumeration definition

Protected enumeration definition

Event Event

Internal event

Private event

Protected event

Extension method Extensionmethod

Internal extensionmethod

Private extensionmethod

Protected extensionmethod

Field Field

Internal field

Private field

Protected field

Indexer Indexer

Internal indexer

Private indexer

Protected indexer

Interface Interface

Internal interface

Private interface

Protected interface

Keyword Keyword

Literal Literal
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Type Icon Description

Local Local

Method Method

Internal method

Privatemethod

Protectedmethod

Namespace Namespace

Operator Operator

Parameter Parameter

Property Property

Internal property

Private property

Protected property

Reference Reference

Structure Structure

Internal structure

Private structure

Protected structure

Find Dialog Box
This dialog box enables you to search for strings in files displayed in the Editor or located in a
specific folder.

You can either find literal text or use regular expressions. You can also use other options to further
fine-tune your search.
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To access 1. Create or open the document in which you want to search, or, to search in
multiple files, open any document.

2. Select Search > Find or press CTRL+F.

Important
information

l You cannot use the Find dialog box to search in the canvas or application
areas.

l The search is limited to the text in the file at the time that the Find dialog box
was opened. Any changes made after opening the Find dialog box are not
included the search.

Relevant
tasks

"How to Find or Replace Strings in Files" on page 141

See also "Searching and Replacing in the Editor " on page 135

User interface elements are described below:

UI
Elements

Description

Find text The text string you want to locate.

For details on searching with a regular expression, see theExpression Builder
button description.

Recent searches. Click to select a recently used search string.

The list includes the last ten search strings.
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UI
Elements

Description

Expression Builder. Click to select a predefined regular expression and insert it
into your search string at the cursor location.

When you click this button, theRegular expression check box is automatically
selected.

For details on regular expressions in search strings, see " Regular Expressions in
the Find and Replace Dialog Boxes" on page 165.

Regular
Expression

Treats the specified search string as a regular expression. This option is
automatically selected when you select a regular expression from the Smart
Regular Expression drop-down list.

Look in The files or folder you want to search.

Select one of the following from the drop-down list:

l Current Document. Searches within the document currently open in the
Editor. This is the default option.

l Current Test. Searches within the currently open test.

l <Files...>. Enables you to browse to a select a specific folder in the file
system.

Note: (for ALM users)You cannot browse to an ALM path.

The drop-down list also displays the last ten folders you selected, with themost
recent folder listed first. Select one to search in the same folder again.

For details, see "File and Item Types Included in String Searches" on page 136.

Match case Distinguishes between upper-case and lower-case characters in the search, and
searches only for occurrences with exact matches to the casing in the search
string.

Match
whole
word

Searches only for occurrences that are whole words and not part of longer words.

Search up Searches from the cursor location towards the top of the file, and then wraps
around to the current cursor location from the bottom of the file.

By default, the search is performed downwards in the file.

Include
sub-folders

Searches through any sub-folders found in the selected folder.

Note: This option is available only when you select a specific folder from the
Look in drop-down list.
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UI
Elements

Description

Find Next Searches for the next occurrence of the defined search criteria.

Find All Searches for all occurrences of the defined search criteria.

Search results are listed in the Search Results pane. For details, see "Search
Results Pane User Interface" on page 231.

Replace Dialog Box
This dialog box enables you to search for strings in files displayed in the Editor or located in a
specific folder, and replace them with a different string.

You can either find and replace literal text or use regular expressions. You can also use other
options to further fine-tune your find and replace process.

To access 1. Create or open the document in which you want to search, or, to search in
multiple files, open any document.

2. Select Search > Replace or press CTRL+H.
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Important
information

l You cannot use theReplace dialog box to search in the canvas or application
areas.

l The search is limited to the text in the file at the time that theReplace dialog
box was opened. Any changes made after opening theReplace dialog box are
not included the search.

Relevant
tasks

"How to Find or Replace Strings in Files" on page 141

See also "Searching and Replacing in the Editor " on page 135

User interface elements are described below:

UI
Elements

Description

Find text The text string you want to locate. For details on searching with a regular
expression, see theExpression Builder button description.

Recent searches and replacements. Click to select a recently used string. The
list includes the last ten search strings.

Expression Builder. Click to select a predefined regular expression and insert it
into your search string at the cursor location.

When you click this button, theRegular expression check box is automatically
selected.

For details on regular expressions in search strings, see " Regular Expressions in
the Find and Replace Dialog Boxes" on page 165.

Regular
Expression

Treats the specified text string as a regular expression. This option is
automatically selected when you select a regular expression from the list.

Replace
with

The text string you want to use as the replacement string. The text is replaced
using the same casing as defined in the replacement string.
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UI
Elements

Description

Look in The files or folder you want to search.

Select one of the following from the drop-down list:

l Current Selection. Searches within the currently highlighted text. Youmust
highlight a specific area in the current file before selecting this option.

l Current Document. Searches within the document currently open in the
Editor. This is the default option.

l Current Test. Searches within the currently open test.

l <Files...>. Enables you to browse to a select a specific folder in the file
system.

Note: (for ALMusers) You cannot browse to an ALM path. If you want to
search in a document stored in ALM, youmust open the document first.

The drop-down list also displays the last ten folders you selected, with themost
recent folder listed first. Select one to search in the same folder again.

For details, see "File and Item Types Included in String Searches" on page 136.

Match case Distinguishes between upper-case and lower-case characters in the search, and
searches only for occurrences with exact matches to the casing in the search
string.

Match
whole
word

Searches only for occurrences that are whole words and not part of longer words.

Search up Searches from the cursor location towards the top of the file, and then wraps
around to the current cursor location from the bottom of the file.

Include
sub-folders

Searches and replaces through any sub-folders found in the selected folder.

Note: This option is available only when you select a specific folder from the
Look in drop-down list.

Find Next Searches for the next occurrence of the defined search criteria.

Replace Replaces the string defined in the Find text field with the string defined in the
Replace with field.

Replace
All

Replaces all occurrences of the string defined in the Find text field with the string
defined in theReplace with field, throughout the location defined in the Look in
drop-down list. All strings are found and replaced in the same action.
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Go To Dialog Box
This dialog box enables you to navigate to a specific line,class, or function in a user code file, or to
navigate to any file.

To access 1. Create a new solution or open an existing solution.

2. Open the necessary tests or user code files. For details on how to open tests
or user code files included in a solution, see "How toManage Items in the
Solution Explorer Pane" on page 237.

3. Select Search > Go To.

Important
information

Search Limitations:

l When you navigate to an class or function name, Service Test searches all
files within the open solution for occurrences of the search terms.

l When you navigate to line numbers, Service Test searches only the currently
selected document.

l You can navigate to any file name contained within the current solution.

Relevant
tasks

"How to Use theGo ToDialog Box in the Editor" on page 138

See also "Bookmarks Overview" on page 84

User interface elements are described below (unlabeled elements are shown in angle brackets):
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UI
Elements

Description

<search
text>

The location to which you want to go. Enter one of the following:

l A line number

l A class name

l A function name

l Any file name

<search
results>

The locations that match the text you entered.

As you enter a navigation search string, all locations that match the current string are
displayed. Double-click a specific location to navigate directly to it.

If a test or user code file containing the location is closed, Service Test opens the
relevant documenttest or user code file.

Editor Context Menu Options
This section describes the context menu options available for the different document types
displayed in the Editor.

To access 1. Create or open auser code file.

2. Right-click in the document.

Important
information

l Some options are also available throughmenu commands or toolbar
buttons.

l Some of the context-menu options may be hidden depending on the view of
the document or the content of the document.

Relevant
tasks

"How to Open aWindow forWriting Custom Code" on page 644

See also "Coding Service Test Events" on page 641

Context menu options are described below:

Note: Themenu commands described below may not be displayed in the exact order
presented here. The options available differ depending where in your document you right-click.

Menu Command Keyboard
Shortcut

Description

Cut Removes the currently selected step or text from your action
or component.

Copy CTRL+C Copies the currently selected step or text.
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Menu Command Keyboard
Shortcut

Description

Paste CTRL+V Pastes the currently copied step or text.

Delete Deletes the selected step or text from your action or
component.

Comment CTRL+M Adds a comment to the selected line.

Uncomment CTRL+
SHIFT+M

Removes a comment from the selected line.

Indent TAB Indents the current line.

Outdent Shift+Tab Removes an indent from the selected line.

Go to Definition Ctrl+
Enter

Navigates directly to the definition of the function that is
called in the currently selected step.

Insert/Remove
Breakpoint

F9 Sets or clears a breakpoint in the test or component.

Enable/Disable
Breakpoint

Ctrl+F9 Enables or disables the currently selected breakpoint.

Add to Watch Ctrl+T Adds the selected item to theWatch pane.

Select All Ctrl+A Selects all steps or text.

Regular Expression User Interface
By default, Service Test treats all characters in a regular expression literally, except for the period
(.), hyphen (-), asterisk (*), caret (^), brackets ([ ]), parentheses (()), dollar sign ($), vertical line
(|), plus sign (+), questionmark (?), and backslash (\). When one of these special characters is
preceded by a backslash (\), Service Test treats it as a literal character.

If you enter a special character in the value box of any dialog box that contains theRegular
Expression check box, and then you select theRegular Expression check box, Service Test
asks you if you want to add a backslash (\) before each special character. If you click Yes, a
backslash (\) is added before the special character to instruct Service Test to treat the character
literally. If you click No, Service Test treats the special character as a regular expression character.

For details, see:

Regular Expression Characters and UsageOptions 161

Regular Expressions in the Find and Replace Dialog Boxes 165

Regular Expression Evaluator 166

Smart Regular Expression List 168
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Regular Expression Characters and Usage Options

This section describes some of themore common options that can be used to create regular
expressions:

Using the Backslash Character ( \ )
A backslash (\) can serve two purposes. It can be used in conjunction with a special character to
indicate that the next character be treated as a literal character. For example, \. would be treated
as period (.) instead of a wildcard. Alternatively, if the backslash (\) is used in conjunction with
some characters that would otherwise be treated as literal characters, such as the letters n, t, w, or
d, the combination indicates a special character. For example, \n stands for the newline character.

If the backslash character is not used for either of these purposes, it is ignored.

For example:

l wmatches the character w

l \w is a special character that matches any word character including underscore

l \\matches the literal character \

l \(matches the literal character (

l one\twomatches the string onetwo

For example, if you were looking for aWeb site called:

newtours.demoaut.com

the period would bemistaken as an indication of a regular expression. To indicate that the period is
not part of a regular expression, you would enter it as follows:

newtours\.demoaut\.com

Matching Any Single Character ( . )
A period (.) instructs Service Test to search for any single character (except for \n). For example:

welcome.

matches welcomes, welcomed, or welcome followed by a space or any other single character. A
series of periods indicates the same number of unspecified characters.

Tomatch any single character including \n, enter:

(.|\n)

Formore details on the ( ) regular expression characters, see "Regular Expression Characters and
UsageOptions" above. For more details on the | regular expression character, see "Matching One
of Several Regular Expressions ( | )" on page 163.

Matching Any Single Character in a List ( [xy] )
Square brackets instruct Service Test to search for any single character within a list of characters.
For example, to search for the date 1967, 1968, or 1969, enter:

196[789]
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Matching Any Single Character Not in a List ( [^xy] )
When a caret (^) is the first character inside square brackets, it instructs Service Test to match
any character in the list except for the ones specified in the string. For example:

[^ab]

matches any character except a or b

Note: The caret has this special meaning only when it is displayed first within the brackets.

Matching Any Single Character within a Range ( [x-y] )
Tomatch a single character within a range, you can use square brackets ([ ]) with the hyphen
(-) character. For instance, to match any year in the 1960s, enter:

196[0-9]

A hyphen does not signify a range if it is displayed as the first or last character within brackets, or
after a caret (^).

For example, [-a-z]matches a hyphen or any lowercase letter.

Note:Within brackets, the characters ".", "*", "[" and "\" are literal. For example, [.*]
matches . or *. If the right bracket is the first character in the range, it is also literal.

Matching Zero or More Specific Characters ( * )
An asterisk (*) instructs Service Test to match zero or more occurrences of the preceding
character. For example:

ca*r

matches car, caaaaaar, and cr

Matching One or More Specific Characters ( + )
A plus sign (+) instructs Service Test to match one or more occurrences of the preceding
character. For example:

ca+r

matches car and caaaaaar, but not cr

Matching Zero or One Specific Character ( ? )
A questionmark (?) instructs Service Test to match zero or one occurrences of the preceding
character. For example:

ca?r

matches car and cr, but nothing else

Grouping Regular Expressions ( ( ) )
Parentheses (()) instruct Service Test to treat the contained sequence as a unit, just as in
mathematics and programming languages.
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Using groups is especially useful for delimiting the arguments to an alternation operator ( | ) or a
repetition operator: ( * , + , ? , { } )

Matching One of Several Regular Expressions ( | )
A vertical line (|) instructs Service Test to match one of a choice of expressions. For example:

foo|bar

causes Service Test to match either foo or bar

fo(o|b)ar

causes Service Test to match either fooar or fobar

Matching the Beginning of a Line ( ^ )
A caret (^) instructs Service Test to match the expression only at the start of a line, or after a
newline character.

For example:

book

matches book within the lines—book, my book, and book list, while

^book

matches book only in the lines—book and book list

Matching the End of a Line ( $ )
A dollar sign ($) instructs Service Test to match the expression only at the end of a line.

For example:

book

matches book within the lines—my book, and book list, while a string that is followed by (\n),
(\r), or ($), matches only lines ending in that string. For example:

book$

matches book only in the line—my book

Matching a Newline or Carriage Return Character ( \n ) or ( \r )
\n or \r instruct Service Test to match the expression only when followed by a newline or carriage
return character.

l \n instructs Service Test to match any newline characters.

l \r instructs Service Test to match any carriage return characters.

For example:

book

matches book within the lines—my book, and book list, while a string that is followed by (\n)
or (\r) matches only lines that are followed by a newline or carriage return character. For example:

book\r
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matches book only when book is followed by a carriage return

Matching Any AlphaNumeric Character Including the Underscore ( \w )
\w instructs Service Test to match any alphanumeric character and the underscore (A-Z, a-z, 0-9,
_).

For example:

\w* causes Service Test to match zero or more occurrences of the alphanumeric characters—A-

Z, a-z, 0-9, and the underscore (_). It matches Ab, r9Cj, or 12_uYLgeu_435.

For example:

\w{3} causes Service Test to match 3 occurrences of the alphanumeric characters A-Z, a-z, 0-

9, and the underscore (_). It matches Ab4, r9_, or z_M.

Matching Any Non-AlphaNumeric Character ( \W )
\W instructs Service Test to match any character other than alphanumeric characters and
underscores.

For example:

\W

matches &, *, ^, %, $, and #

Matching a Decimal Digit ( \d )
\d instructs Service Test to match any decimal digit.

For example:

\d

matches 1, 2, 4, and 5

Matching an Integer ( \D )
\D instructs Service Test to match any whole integer.

For example:

\D

matches 145643, 20, 3426767, 4, and 5

Combining Regular Expression Operators
You can combine regular expression operators in a single expression to achieve the exact search
criteria you need.

For example, you can combine the `.' and `*' characters to find zero or more occurrences of
any character (except \n).

For example,

start.*

matches start, started, starting, starter
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You can use a combination of brackets and an asterisk to limit the search to a combination of non-
numeric characters. For example:

[a-zA-Z]*

Tomatch any number between 0 and 1200, you need tomatch numbers with 1 digit, 2 digits, 3
digits, or 4 digits between 1000-1200.

The regular expression below matches any number between 0 and 1200.

([0-9]?[0-9]?[0-9]|1[01][0-9][0-9]|1200)

Note: For a complete list and explanation of supported regular expressions characters, see the
Regular Expressions section in theMicrosoft VBScript documentation (select Help > HP
Service Test Help to open the Service Test Help. Then select VBScript Reference >
VBScript > VBScript User's Guide > Introduction to Regular Expressions).

Regular Expressions in the Find and Replace Dialog Boxes

You can use regular expressions in the Find text fields to enhance your search in both the "Find
Dialog Box" (described on 152) and "Replace Dialog Box" (described on 155).

You can insert a regular expression into your search string by selecting one from a predefined list, or
by entering onemanually. For a general understanding of regular expressions in Service Test, see
"Regular Expressions Overview" on page 136.

For more details about find and replace functionality, see "Searching and Replacing in the Editor "
on page 135.

Note: Not all the regular expressions listed for other parts of Service Test are supported for the
search strings in the Find and Replace dialog boxes.

The following table lists the regular expressions supported for search strings, as well as
descriptions of each regular expression. For details, see "Regular Expression Characters and
UsageOptions" on page 161.

Character Description Reference

. (period) Matches any single character "Matching Any Single Character ( . )
" on page 161

*
(asterisk)

Matches zero or more specific characters "Matching Zero or More Specific
Characters ( * )" on page 162

+ (plus
sign)

Matches one or more specific characters "Matching One orMore Specific
Characters ( + )" on page 162

?
(question
mark)

Matches zero or one specific character "Matching Zero or One Specific
Character ( ? )" on page 162
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Character Description Reference

^ (caret) Matches the beginning of a line "Matching the Beginning of a Line
( ̂  )" on page 163

$ (dollar
sign)

Matches the end of a line "Matching the End of a Line ( $ )" on
page 163

\n Matches a line break "Matching a Newline or Carriage
Return Character ( \n ) or ( \r )" on
page 163

\r Matches a carriage return "Matching a Newline or Carriage
Return Character ( \n ) or ( \r )" on
page 163

[] Matches any single character in a list "Matching Any Single Character in
a List ( [xy] )" on page 161

[^] Matches any single character not in a list "Matching Any Single Character
Not in a List ( [^xy] )" on page 162

\w Matches any alphanumeric character
including the underscore

"Matching Any AlphaNumeric
Character Including the Underscore
( \w )" on page 164

\W Matches any non-alphanumeric character "Matching Any Non-AlphaNumeric
Character ( \W )" on page 164

\d Matches a decimal digit "Matching a Decimal Digit ( \d )" on
page 164

\D Matches an integer "Matching an Integer ( \D )" on page
164

| Matches one of several regular expressions "Matching One of Several Regular
Expressions ( | )" on page 163

\ Matches a special character treated as a
literal character, or a literal character treated
as a special character

"Using the Backslash Character ( \ )
" on page 161

Regular Expression Evaluator

This dialog box enables you to create and test a regular expression to determine whether it suits
your needs. You can enter a regular expression and sample text to test. When you click Highlight,
Service Test searches the sample text for matches, highlights thesematches, and displays the
number of matches.

The following example searches for the word product followed by a space or other character
because the regular expression includes the period (.) character.
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To access 1. Do one of the following:

n Ensure that a test, action, or component is in focus in the document pane.

n In the Solution Explorer, select a test or component node.

2. Use one of the following:

n Select the Tools > Regular Expression Evaluator menu command.

n Click theSmart Regular Expression button to the right of a value
box in any dialog box (except the Find and Replace dialog boxes) in which
theRegular Expression check box is selected. Select theOpen
Regular Expression Evaluator list item.

Important
information

The list of selectable regular expression characters available from this dialog box
is also available from other Service Test dialog boxes that contain a selected

Regular Expression check box and theSmart Regular Expression button
.

Note: The Regular Expression Evaluator is not supported for regular
expressions in the Find and Replace dialog boxes.

See also Conceptual overview: "Regular Expression Characters and UsageOptions" on
page 161

Additional related topics: "Smart Regular Expression List" on next page

User interface elements are described below:
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UI
Elements

Description

Smart Regular Expression. Click to display a list of regular expression
characters that you can select. For details on each of the regular expression
characters, see "Smart Regular Expression List" below.

Regular
Expression

The regular expression to test. Enter the regular expression in this box.

Tip: Click the right arrow to display a list of regular expression
characters that you can insert.

Highlight Searches for the regular expression in theSample text area and highlights all
matches.

Note: Before you click Highlight, make sure that the text to search is
displayed in theSample text area.

Sample
text

The text to use when testing the regular expression.

Note: Text may already be displayed in theSample text area when the dialog
box opens, depending on the steps you performed to open this dialog box.

TheSample text area is editable. You can insert any text to test your regular
expression.

Number of
matches

The number of matches for the regular expression within the sample text. These
matches are highlighted in theSample text area.

Smart Regular Expression List

This list:

l Displays a list of commonly used regular expression characters.

l Enables you to select a regular expression character from the list and insert it in a value.

l Enables you to access the "Regular Expression Evaluator" (described on page 166).
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To
access Click theExpression Builder button to the right of a value box in which regular

expressions can be used, such as the Find dialog box.

See
also

"Regular Expressions Overview" on page 136 and "Regular Expression Characters
and UsageOptions" on page 161

User interface elements are described below (unlabeled elements are shown in angle brackets):
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UI
Elements

Description

<Regular
expression
options>

The list of regular expression characters that you can select when creating a
regular expression.

When you select a regular expression character from the list, Service Test inserts
it in the currently open dialog box and closes the list. Depending on its type, a
regular expression character can be inserted:

l At the cursor location

l Around selected text

l In place of selected text

Example 1: If you select text and then select the [ ] Any character in the
set option, the brackets are inserted on either side of the selected text, as
follows: [text]

Example 2: If you select text and then select the \d Any digit option, the
selected content is replaced with \d. For example, if you select 1 in
Document1 and then select the \d Any digit option, the selected content is
replaced with \d, as follows: Document1 becomes Document\d

Note: The \n New line option is available only if applicable.

For details on working with regular expression characters, see "Regular
Expression Characters and UsageOptions" on page 161.
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Chapter 8: Errors Pane
This chapter includes:

Concepts 173

Errors PaneOverview 173

Tasks 175

How toManage Errors in the Errors Pane 175

Reference 177

Errors Pane User Interface 177
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Concepts

Errors Pane Overview
The Errors pane displays a list of errors generated when opening, working with, saving, and running
tests, components, and user code files. The Errors pane also displays the error severity levels:
Message, Warning, or Error. For user interface details, see "Errors Pane User Interface" on
page 177.

The following types of errors can occur:

l "Code syntax errors" below

l "Missing References " below

l "Missing Property Values " below

Code syntax errors
Service Test checks for syntax errors whenever you save a test, component, or user code file. If a
syntax error is present in your code, the error description is displayed as an Error in the Errors
pane.

You can view a description of code syntax to help you resolve code errors that are displayed in the
Errors pane in theMicrosoft C# Reference. For details, see http://msdn.microsoft.com/en-
us/library/ms228296(v=vs.90).aspx.

For details, see "How toManage Errors in the Errors Pane" on page 175.

Missing References
In the Solution Explorer, each Service Test test contains numerous reference files used in the run
session of the test. In addition, you can add additional references to a test. For details on the
References node in the Solution Explorer, see "References Node" on page 243.

When aService Test test is run, Service Test checks that all necessary reference files are present.
If a reference file needed for the run session is not present, then this missing reference is displayed
in the Errors pane, along with the location where Service Test expected to find the reference.

Note: If a reference file is located on a password-protected network host, the reference is
listed as missing in the Errors pane unless you add the resource prior to opening the test.

The Errors pane enables you to find the name of themissing reference file and add it to the test.
After you save and run the test again, the error disappears from the Errors pane.

For details on adding references to a test, see "Add Reference Dialog Box" on page 245.

Missing Property Values
When you add certain Service Test test steps to the canvas, you are also required to provide input
values and property definitions in the "Input/Checkpoints/Output Properties Tab (Properties Pane)"
of the Properties pane (described on page 201) After you add these steps to the canvas, an error
message is displayed in the Errors pane explaining the necessary property value to enter.
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You can double-click on the error description in the Errors pane to navigate to the field necessary to
resolve the error. After entering the requested values, the error is longer listed in the Errors pane.

For details on input properties for Service Test test steps, see "Standard Activities" on page 396.
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Tasks

How to Manage Errors in the Errors Pane
This task describes the different operations that can be performed in the Errors Pane and includes
the following steps:

l "Select the errors to display" below

l "Locate syntax errors" below

l "Locate amissing reference file" below

l "Locate amissing test step property value" below

Select the errors to display
Use the drop-down list at the left side of the pane to select the errors to display in the pane. You can
choose to display all errors in the current solution, or sort by individual tests.

Locate syntax errors
In the Errors pane, do one of the following:

l Double-click the error description.

l Right-click the error description and select Locate.

l Select the line containing the syntax error and click the Locate button.

In the document pane, the cursor jumps to the source of the syntax error. For user code files, the
characters containing syntax error are also underlined.

Locate a missing reference file
1. Locate the source of themissing reference files, as described in the step"Locate syntax errors"

(described above).

The relevant test code file opens and the cursor flashes at the place in which themissing
reference file is called during a test run displaying the reference file's name.

2. In the Solution Explorer, right-click theReferences node located under an Service Test test
and select Add Reference.

3. In the "Add Reference Dialog Box" (described on page 245), navigate to themissing reference
file and associate it with your test.

Locate a missing test step property value
1. Locate the source of themissing reference files, as described in the step (described above).

The field requiring themissing property value is highlighted in the "Input/Checkpoints/Output
Properties Tab (Properties Pane)" in the Properties pane (described on 201).

2. Enter the required information for the property value.

Note: An alert is also displayed in the step in the canvas. For details, see "The Canvas"
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on page 373.
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Reference

Errors Pane User Interface
The Errors pane lists the errors found in your test or user code document, and enables you to locate
each syntax error so that you can correct it. It also provides a list of the resources that are
referenced in your test or component but cannot be found.

To access Do one of the following:

l Select View > Errors.

l Click theErrors tab in the bottom pane.

Important
information

l The Errors pane displays the errors for all tests contained in your solution. You
can also sort to display errors for each individual document contained within
the solution.

l Click on a row to jump to the line in the code that generated the error.

l Click any column header, for example Line or Item, to sort by that criteria.

Relevant
tasks

l "How toManage Errors in the Errors Pane" on page 175

l "How to Run an API Test" on page 288

See also "The Canvas" on page 373

The following sections describe:

l "Main User Interface Elements" below

l "Context Menu Items" on page 179

Main User Interface Elements
Themain user interface elements are described below (unlabeled elements are shown in angle
brackets):
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UI Elements Description

<Show errors
from>

Filters themessage list by the source of the error.
Default:Solution

Shows or hides syntax errors, property value errors andmissing resources
detected during the test run.

Shows or hides warnings detected during the run.

Shows or hides informational messages detected during the run.

Locate l Syntax errors: Jumps to the line in the Editor that contains the error.

l Missing references. Opens the relevant testing code file to highlight the
name of themissing resource.

l Missing property value. Highlights the input field in the
Input/Checkpoints tab in the Properties pane.

Available also by right-clicking an error line. For details, see "Context Menu
Items" on next page.

!
<Exclamation
Point>

Message type:

l Error

l Warning

l Informational message

Line The line containing the error.

The lines are numbered from the beginning of the TestUserCode.cs file.

Description Description of the error, warning or message and advice on how to fix the
problem.

For example, a syntax error is displayed if you opened a block of code with a {
but did not close it with an }, the description is Expected end of

statement.

Note: In certain cases, Service Test is unable to identify the exact error
and displays a number of possible error conditions, for example:
Expected 'End Sub', or 'End Function', or 'End Property'.
Check the statement at the specified line to clarify which error is relevant in
your case.
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UI Elements Description

Item l Syntax errors. The name of the user code file containing the problematic
statement.

l Missing references. The name of the test user code that contains the call to
themissing reference.

l Missing property values. The name of the activity containing themissing
property value.

Path The full path of the file that generated the error.

Test The name of the relevant test or component containing the error.

Context Menu Items
The user interface elements described below are available when you right-click an error in the Errors
pane.

UI
Elements

Description

Copy Copies the content of the selected error to the clipboard.

Locate l Syntax errors. Jumps to the location that contains the error.

You can double-click a syntax error to locate the error in the relevant user code
file, and then correct it.

l Missing references. Opens the test code file that contains the call to the
reference file and highlights the name of themissing reference.

l Missing property value. Opens the relevant field in the Input/Checkpoints tab
in the Properties pane.

Note: Double-clicking amissing resource item has the same effect as selecting
the Locate option from the right-click menu or from the toolbar.
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Chapter 9: Output Pane
This chapter includes:

Concepts 180

Output PaneOverview 180

Reference 181

Output Pane User Interface 181

Troubleshooting and Limitations - Output Pane 183

Concepts

Output Pane Overview
TheOutput pane displays the following information:

l Details about assets that cannot be located or loaded during a run session.

l Output messages generated in the Output log while compiling and running the test.

For user interface details, see "Output Pane User Interface" on next page.
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Output Pane User Interface
TheOutput pane displays

output messages generated in the Output log while compiling and running the test.

The image below shows theOutput pane during an API test run session.

To Access Do one of the following:

l Select View > Output.

l During a paused run session, click theOutput Pane toolbar button

.

Important
information

Click on a row to navigate to the code that generated the output
message.

Relevant tasks "How to Run an API Test" on page 288

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Element

Description

<Show
output
from>

The type of output to display. The following types are available:

l BuildDisplays all test build information.

l Debug: Includes debug information, such as all Print command (print log)
outputs and details about tests called from GUI tests.

Clear All Lines. Clears all of themessages from themessage list.

Toggle Word Wrap. When selected, wraps the text of eachmessage onto the
next line.
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UI
Element

Description

Locate Jumps to the location in the source document relevant to the selected output
message.

<Find box>.The text string you want to find. You can refine your search by
selecting one of the "Options" described below.

Press ENTER to begin the search.

Find Previous / Find Next. Highlights the next or previous string that matches the
text that you entered in the Find box.

Available only after you enter text in the Find box.

Options Enables you to refine your search with the following options:

l Match Case. Distinguishes between upper-case and lower-case characters in
the search.

l Match Whole Word. Searches for occurrences that are only whole words and
not part of longer words.

l Use Regular Expression. Treats the specified text string as a regular
expression.

Note: Extended regular expressions andmulti-line searches are not
supported.

Save Output to a Text File. Opens the "Save <Resource>/Save <Document> As
Dialog Box" (described on page 72), enabling you to save the contents of the
message list as a text file.

<Message
list>

All messages sent during the test run session.

Eachmessage corresponds to

amessage generated in the Output log.

Copy Shortcut (right-click) menu option that copies the selected content to the clipboard.

Locate Shortcut (right-click) menu option that jumps to the relevant line in the source
document for the selected output message.
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Troubleshooting and Limitations - Output Pane
l TheOutput tabmay be unable to display the run results for very large tests, exceeding a

thousand steps.

l The compilation information for a test is not localized.
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Chapter 10: Properties Pane
This chapter includes:

Concepts 185

Properties PaneOverview 185

Reference 186

Properties Pane User Interface 186

Troubleshooting and Limitations -Properties Pane 218
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Properties Pane Overview
The properties pane is used for viewing and editing global and specific properties of your tests and
components.

Each step or test activity may contain several customizable properties or parameters. The
Properties pane provides several views that allow you to define or assign values to the properties
and define handler events.

The Properties pane's toolbar also provides action buttons that allow you to data drive properties
and load files.

For details, see "Properties Pane User Interface" on next page.
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Reference

Properties Pane User Interface
The Properties pane displays a series of tabs showing the properties, schemas, and events for the
step selected in the canvas.

To access 1. Create or open a test or component.

2. Select View > Properties or click on the Properties pane tab.

Important
information

l Only active when the canvas is visible.

l The toolbar displays different buttons based on the type of activity or
view.

l The top row of buttons areView buttons, such as General orEvents
views.

l The bottom row of buttons are buttons that perform actions, such as
Data-Drive and Load XML.

Relevant tasks l "How to Create an API Test" on page 383

l "How to Set Security for aWeb Service on the Port Level" on page 547

This section includes:

Properties Pane Tabs 186

Action Buttons 214

Value Column Icons 216

Array Control Buttons 216

Properties Pane Tabs

The following section describes each of the Properties pane tabs.

Asynchronous Tab (Properties Pane)

This tab enables you to indicate whether the response for aWeb Service is asynchronous.

To access 1. Open the Properties pane.

2. Select aWeb Service step in the canvas.

3. In the Properties Pane, select theAsynchronous tab .
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Relevant tasks "How to Create a Test for an Asynchronous Web Service" on page 605

See also "Asynchronous Services" on page 602

TheAsynchronous tab's user interface elements are described below.

UI Elements Description

This is an
asynchronous call

Indicates whether the call is asynchronous and enables you to specify a
listener.

Listen for response
on

The port upon which to listen for a response. This property is visible only
if you enable the above option.

Attachments Tab (Properties Pane)

This tab enables you to view input and output attachments associated with the current test step.

To access 1. Open the Properties pane.

2. Select aWeb Service step in the canvas.

3. In the Properties Pane, select theAttachments tab

.

Relevant tasks "Add attachments to the test - optional" on page 384

TheAttachments tab's user interface elements are described below (unlabeled elements are
shown in angle brackets).
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UI Elements Description

<Input
Attachment>

Input attachments for the current Web Service step:

l Type. Attachment type: NONE, DIME, or MIME.

l Attachments. A list of the input attachments and their properties:

n Origin. The name of the file to send as an attachment. Click the
Browse button to navigate to the directory in which the attachment is
saved.

Note: You can use the ouptut from a different test step as an
attachment. Click the Link to data source button and choose
the test property in the "Select Link Source Dialog Box" (described
on 630).

n Content Type. The type of file and format. Possible file types include:

o application/zip

o image/gif

o image/ief

o image/jpeg

o image/png

o image/tiff

o text/plain

o text/richtext

o text/html

o text/xml

n Content ID. A unique ID for the attachment orAuto for an ID
generated by Service Test.

Note: To add input attachments, click the button in the parent node.
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UI Elements Description

<Output
Attachment>

The server response saved as an attachment.

l Attachments. A list of the output attachments and their properties to
validate:

n Content. The file content's checksum value. The checksum is
computed by applying theMD5 hash function to the file.

n Content Type. The attachment's content type.

n Content ID. The unique ID of the attachment.

Note: To add output attachments, click theAttachments row in the
Checkpoints pane, and click to add an array element. (Youmay need
to expand the columnwidth to access the button).

Tip: To validate an output attachment, select the check box adjacent to
the elements you want to validate. Received attachments are saved in
the test's folder, with bin extensions.

Data Sources Tab (Properties Pane)

This tab enables you to set the data navigation instructions for the data sources associated with
your test flow.

To access 1. Open the Properties pane.

2. Select the Test Flow in the canvas.

3. In the Properties Pane, select theData Sources tab .

Important
information

You can havemore data sources associated with a test in the Data Pane than
are associated with a particular test flow.

Relevant
tasks

"How to Set the Navigation Properties" on page 622

See also l "Navigating within the Data " on page 615

l "Data Navigation Dialog Box" on page 634

TheData Sources tab's user interface elements are described below.

HP Service Test (11.52)Page 189 of 705

User Guide
Chapter 10: Properties Pane



UI
Element

Description

Data
Navigation
Policies

A list of the data sources sorted by:

l Data Source Name. The name of the data source as it appears in the Data
Pane.

l Policy. A summary of the data navigation policy, for example: Start at first
row, forward one row, wrap around.

Add Opens the "Attach Data Source to Loop Dialog Box " (described on page 629) for
selecting data sources from the Data Pane.

Note: In order to add a define navigation properties for a Data Source, you
must associate it with your test in the Data pane. For details, see "How to
Create Data Sources" on page 90.

Edit Opens the "Data Navigation Dialog Box" (described on page 634) for setting the
data policy—the way to use the data from the table.

Remove Deletes the selected data source from the list—not from the Data Pane.

Data Source Properties Tab (Properties Pane)

This tab enables you to define the usage properties for your test's data sources.

To access 1. Open the Properties pane.

2. In the Data Pane, select a data source. This tab appears by default and all
other properties pane tabs are hidden..

Relevant
tasks

"Create a new child relation" on page 94

TheData Source Properties tab's user interface elements are described below.

UI Elements Description

Name The name of the data source node.

Child
Relations

A list of the data sources sorted by:

l Child Data Source. The sheet or table to use as a data source.

l Primary Key. A column in the parent data source to use as a primary key
for the child relation.

l Foreign Key. The column in the child data source to use as a foreign key for
the child relation.

To add, edit, or remove a child relation, use the corresponding buttons. For
details, see the see "Define New/Edit Data Relation Dialog Box" on page 637.
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UI Elements Description

Allow other
tools to
override the
data

Allows other tools or tests to override Excel data. Enabling this option allows
you to overwrite the data table values with ALM Test Resources. For details,
see "Data Awareness in ALM" on page 324.

This option also allows action data to be edited when called by another test. For
details, see "Data Pane" on page 96.

Note: This only applies to Excel data sources.

Caution: For Excel data sources with multiple sheets, youmust enable
this option for each data sheet if you did not enable it when importing the
Excel file.

Data source
policy

The policy by which to handle the data (only relevant for steps that call actions
from an external test, to which data was assigned).

l Use data stored with original action (read-only). Use the data that is
associated with the action, as is.

l Use a local, editable copy. Create of local copy of the action's data, to
allow you to edit the values in the Data Pane.

Note: This only applies to Excel data sources.

Database Data Source Properties Tab (Properties Pane)

This tab enables you to view the properties for your database data sources.

To access 1. Open the Properties pane.

2. Select a Database data source in the Data pane.

Relevant tasks "Add a database data source" on page 91

See also "Add New Database Data SourceWizard" on page 102

TheDatabase Data Source Properties tab's user interface elements are described below.

UI Elements Description

Name The name of the data source (read-only).

Connection type The type of connection: OleDB orODBC.
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UI Elements Description

Connection
string area

TheConnection string section contains the following elements:

l Connection string. A drop down list of connection strings that were
defined.

l Build Connection String .

n ForOleDB types, it opens Microsoft's Data Links Properties dialog
box.

n ForODBC types, it opens the "Select Data Source NameDialog
Box", described on 105.

l Edit . Opens a text editor for editing the connection string.

l <Connection string text>. A read-only window showing the selected
connection string.

l <Connection status>. A string indicating whether there is an open
connection to the database.

SQL statement
pane

TheSQL statement section contains the following elements:

l SQL statement. A drop down list of SQL statements strings that were
defined in this test.

l Build Query Statement. Opens theQuery Designer. For details,
see the "Query Designer Dialog Box" on page 456.

l Edit . Opens a text editor for editing the SQL statement.

l <SQL statement text>. A read-only window showing the selected SQL
statement.

l <Query status>. A string indicating whether or not the query was
executed successfully.

Dependencies Tab (Properties Pane)

This tab shows a list of all external resources (Web Services, REST services, and .NET
assemblies) used in your test flow.

To access 1. Open the Properties pane.

2. Select theStart orEnd steps in the canvas.

3. In the Properties Pane, select theDependencies tab

.

TheDependencies tab's user interface elements are described below.
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UI Element Description

Resource Name The name of the resource as imported into the test

Type The type of resource, for example, WSDL.

Location The location in the test in which the resource is used.

Events Tab (Properties Pane)

This tab enables you to enter custom code to run special custom code in conjunction with the steps
of your test.

To access 1. Open the Properties pane.

2. Select a test step in the canvas.

3. In the Properties Pane, select theEvents tab .

Relevant tasks "How to Open aWindow forWriting Custom Code" on page 644

See also "Writing Code for Events Overview" on page 642

User interface elements are described below (unlabeled elements are shown in angle brackets).

UI Elements Description

<Events list> - default A list of events for the activity:

l CodeCheckPointEvent. Triggered when the activity is executed.

l AfterExecuteStepEvent. Triggered after the activity was
executed.

l BeforeExecuteStepEvent. Triggered before the activity is
executed.

l ExecuteEvent. Triggered when the activity isn the step is run.

Tip: For details about an event, select it and select Create a
default handler. Refer to comments in the template.

<Events list> -
Conditional. Loop
steps

Condition. Defines the conditions under which the code should be
run.

<Events list> -
HTTP Receiver

l OnFilter. The code to execute when themessages are filtered.

l ReceiveRequest. The code to execute when a request is
received.

l SendResponse. The code to execute when a response is sent.
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UI Elements Description

<Events list> -
IBM Websphere MQ

l BeforeCreateQueueManager. Code to execute before creating a
QueueManager.

l BeforeMQGet. Code to execute before getting themessages
from theMQ queue through browsing.

l AfterMQGet. Code to execute after getting themessages from
theMQ queue through browsing.

l BeforeMQPutMessage. Code to execute before putting a
message from theMQ queue.

l AfterMQPutMessage. Code to execute after putting amessage
from theMQ queue.

l BeforeMQGetMessage. Code to execute before getting a
message from theMQ queue.

l AfterMQGetMessage. Code to execute after getting amessage
from theMQ queue.

l BeforeMQPublishMessage. Code to execute before publishing a
message to anMQ topic.

l AfterMQPublishMessage. Code to execute after publishing a
message to anMQ topic.

l BeforeMQReceiveMessage. Code to execute before receiving a
message published on anMQ topic.

l AfterMQReceiveMessage. Code to execute after receiving a
message published on anMQ topic.

For task details, see "How to RetrieveMessages from anMQ
Queue" on page 408.

<Events list> -
Wait

l TimeoutReached. The code to execute when the timeout (Input
properties) is reached.

Excel File Properties Tab (Properties Pane)

This tab enables you to change the Excel file associated with your Excel data sources.

To access In the Data pane, select the parent node for an Excel data source. The other
Properties pane tabs are hidden.

Relevant
tasks

Add list of cross references using bullets for multiple entries. Do not use periods.

The user interface elements are described below.
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UI
Elements

Description

Name The name of the data source as it appears in the Data pane (read-only).

File Path The current path to the Excel file (read-only).

Change
Excel File

Opens the "New/Change Excel Data Source Dialog Box" (described on 98) which
enables you to select a new file for the selected data sources.

Filter Settings Tab (Properties Pane)

This tab enables you to set a filter for receivedmessages. This tab is available forHTTP Receive
steps and operations fromWeb Service calls imported as server response steps.

To access 1. Open the Properties pane.

2. Select an HTTP Recieve orWeb Service step in the
canvas.

3. In the Properties Pane, select the Filter tab .

See also "Asynchronous Services" on page 602

The Filter Settings tab's user interface elements are described below.

UI
Elements
(A-Z)

Description

Clears the text in the filter area.

Opens the "Select Link Source Dialog Box" (described on page 630), to allow you to
link to existing data.

<filter
text>

A text area containing the filtering expression. You can enter free text or a regular
expression and use the Select Link Source dialog box to create a data expression.

Note:When filtering request headers, you can only filter requests that contain
both a key and value. Headers that have a key, but no value, cannot be filtered.

Filter
Type

The type of filtering: Exact match, Starts with, Ends with, Contains, andRegular
expression.

Note: If you specify Exact Match and you are trying tomatch a key-value pair,
youmust specify both the key and value strings.

General Tab (Properties Pane)

This tab displays general information about the selected test step.
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To access 1. Open the Properties pane.

2. Select any step in the canvas.

3. In the Properties Pane, select theGeneral tab

.

TheGeneral tab's user interface elements are described below. The properties differ based on the
activity type.

For details about activity-specific general properties, see the specify activity in "Standard
Activities" on page 396.

UI Elements (A-Z) Description

Comment An editable note describing the purpose of the step. Service Test
also places the comment in the test report.

Properties - default l Step ID. A unique ID for the step.

l Name. Step name as it should appear in the canvas.

Properties - HP
Automated Testing
Tools

l Test path. The path of the API or GUI test or VuGen script
(LoadRunner's Virtual User Generator) to run.

l Action name. The name of the action in the test (not relevant
for Virtual User Generator scripts).

l Description. A description of the step.

l Result directory. The path of the results relative to the solution
directory (ForCall API Action or Test only).

General Properties - Web Services and SOAP Request
The following table lists the General properties specific forWeb services.

Property Description

Transport The transport mode: HTTP or JMS.

HTTP Use the HTTP transport method for this call with the following properties:

l Endpoint Address. The endpoint location of the service as derived from the
WSDL file.

l SoapAction. An expression indicating the SOAP action, for example,
HP.SOAQ.SampleApp/IHPFlights_Service/DeleteFlightOrder.

l ContentType. The type of content: For example text/xml; charset=utf-8.

l Timeout. Themaximum time inmilliseconds to wait for the response. Enter -1
to disable the timeout and instruct the client to wait for the response as long as
required.
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Property Description

JMS Use the JMS transport method for this call with the following properties:

l Send queue name. The name of the queue from which to send themessage.

l Receive queue name. The name of the queue from which to receive the
message.

l JMS send properties. JMS properties with the key/value form. You can use
the key tomodify JMS header or message properties.

l JMS receive message selector. An SQL expression to filter the received
message. For details on the syntax for defining selectors, see theMessage
Properties section in
http://download.oracle.com/javaee/1.3/api/javax/jms/Message.html.

For example, a key JMSCorrelationID, with a value of 4566636, receives
only messages whose correlation ID is 4566636.

IsOneWay Indicates whether the service is a one way service: true or false. A one way
service only sends a request. A non-one way service sends a request and receives
a response.

General Properties - REST Services/ HTTP Request
The following properties are available in the Add REST Service dialog box and the Properties pane
of HTTP Request steps. For details, see "Add/Edit REST Service Dialog Box" on page 495 or
"Network Activities" on page 426.

Property (A-Z) Description

Allow
redirections

Indicates whether to allow the step to redirect to another URL.

Default: true

Authentication The user credentials settings for obtaining a service contract: Username and
Password.

Client
certificate

A Choice element indicating the source of the client certificate:

l Use file system certificate: The expanded node provides the full path of
the certificate file.

l Use Windows store certificate: The expanded node lists the following
properties Store location, Store name, X509 find type, andX509 find
value.

n Password. The certificate's password.

Note: To use a certificate, make sure to set theUse Client Certificate
property to true.

HP Service Test (11.52)Page 197 of 705

User Guide
Chapter 10: Properties Pane

http://download.oracle.com/javaee/1.3/api/javax/jms/Message.html


Property (A-Z) Description

Connection
type

The type of connection: Keep-Alive orClose.

Default:Keep-Alive

Maximum
automatic
redirections

The number of times to attempt accessing a page, including redirection.

Default: 3

Proxy The settings for the proxy server hosting the service contract: Server (URL
and port when required), Username, andPassword.

Reuse cookies Enables the reusing of cookies for the current step. Default: false.

Timeout The HTTP timeout in milliseconds.

Use Client
Certificate

Enables the use of a client certificate.

Default: false

General Properties - SAP
The following properties are available in the Properties pane for SAP IDOC or RFC steps. For
details, see "Import from SAP/Update Dialog Box" on page 502.

Property (A-Z) Description

Timeout Themaximum time allowed for the function to respond inmilliseconds.

Default: 100000

ConnectionInfo The SAP Connection information for the selected step:

l Server. The name or IP address of the server.

l System number. The server's System Number.

l Client. The client for this SAP connection.

l Username. The username for this SAP connection.

l Password. The password for this SAP connection.

Function name The name of the RFC (for RFCs only).

Expect
Exception

Indicates whether or not to expect an exception when running the function:
true or false (for RFCs only).

IDocController IDoc Controller properties (for IDocs only):

l Message Type, Basic Type, andExtension.

l Sender: Port, Partner number, and Partner type.

l Receiver: Port, Partner number, and Partner type.

Transaction Indicates whether or not the RFC is part of a transaction or not: true or
false (for RFCs only).
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HTTP Tab (Properties Pane)

This tab enables you to define request and response data for your test steps that perform an
HTTP Request to aWeb Service or REST service.

To access 1. Open the Properties pane.

2. Select an HTTP Request or REST service step in the
canvas.

3. In the Properties Pane, select theHTTP tab .

Relevant tasks "How to Create a RESTMethod" on page 475

See also "Network Activities" on page 426

User interface elements are described below (unlabeled elements are shown in angle brackets).

UI Elements Pane

Body type

Description

Request/Response:

l XML

l Text

l File

l JSON

l Post Form
(Request only)

Remove. Deletes the contents of the:

l Body text

l Entered path

l Selected value in grid

Request/Response:

l File

Browse. Enables you to load a non-XML file containing
the request/response body.

Request/Response:

l XML

l Text (Request
only)

l File

l JSON

Link Body. Opens the "Select Link Source Dialog Box"
(described on page 630) for selecting a data source.
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UI Elements Pane

Body type

Description

<checkpoint
list>

Response pane A list of the checkpoints with the following information:

l Name. The name of the checkpoint as it will appear in
the results.

l Regular Expression. A regular expression
representing the expected value.

l Validate. Compares the actual value with the expected
value.

<message
body>

Request/Response
panes

l XML

l Text

l JSON

The body of the request or response loaded through a file,
pasted from a clipboard (Edit > Paste), or manually
entered (Post form).

<post form
list>

Request pane:

l Post Form

A list of the Post form elements:

l Name. The name of the element.

l Value. The element's value.

Clear Request/Response:

l XML

Clears the contents of theRequest/Response Body
areas.

Import
Schema

Request/Response:

l XML

Imports an .xsd file containing the schema of the request
or response.

Load File Request pane:

l Text

Loads a non-.xml file containing the request.

Load JSON Request/Response:

l JSON

Loads a .json file containing the request or response.

Load XML Request/Response:

l XML

Loads an .xml file with the request or response body.

Request
Body

Request pane The format of the request body: XML, Text, File, JSON, or
PostForm.

Response
Body

Response pane The format of the response body: XML, Text, File, or
JSON.
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HTTP Receiver Tab (Properties Pane)

This tab enables you to define response data for steps that receive a response from aHTTP or
SOAP-basedWeb Service.

To access 1. Open the Properties pane.

2. Select an HTTP Receiver step in the canvas.

3. In the Properties Pane, select theHTTP Receiver tab
.

See also "Network Activities" on page 426

User interface elements are described below (unlabeled elements are shown in angle brackets).\

UI Elements (A-Z) Response
Body type

Description

Text Clear. Clears the contents of the selected cells in
regular expression grid.

<body of received
message>

XML, JSON The body of the response loaded through a file.

<regular
expression>

Text A grid with regular expression containing the response
body values to validate.

Clear XML, JSON Clears the contents of the body.

Import Schema XML Imports an .xsd file containing the schema of the
response.

Load JSON JSON Loads a .json file with the response values.

Load XML XML Loads an .xml file with the response values.

Received Message
Body

XML, Text,
JSON

The way in which to represent the response: XML,
Text, or JSON.

Input/Checkpoints/Output Properties Tab (Properties Pane)

This tab enables you to define input properties, input parameters, and checkpoint properties for your
test steps.
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To
access

1. Open the Properties pane.

2. Select a test step in the canvas.

3. In the Properties Pane, select the tab. This tab's name and content depend on
the test step you selected.

n If you selected aStart orEnd steps, this tab is Test Input/Output
Properties.

n If you selected the test flow, this tab is Input.

n If you selected any other step, this tab is Input/Checkpoints.

The tab's user interface elements are described below (unlabeled elements are shown in angle
brackets).

For details about activity-specific properties, see "Standard Activities" on page 396.

UI Elements
(A-Z)

Description

<checkpoint
list>

A list of the step's output parameters, displaying the following columns:

l Checkpoints. A list of the output parameters.

l Validate.When checked, validates the current output parameters when
running the step. When unchecked, ignores the parameters.

l Expected Value. The expected value for the output parameter. Provides a
drop down list for comparison operators, number scrolling, and boolean
values. You canmanually enter the expected value into the cell.

HP Service Test (11.52)Page 202 of 705

User Guide
Chapter 10: Properties Pane



UI Elements
(A-Z)

Description

<context
menu>-
input
properties

Provides shortcuts for including properties and setting their values.

l Collapse/Expand All. Controls the display of array elements.

l Set Auto-value. Inserts a sample value for the argument, based on its data
type.

l Include/Include All. Includes the current or all Choice input properties in the
test run.

l Exclude/Exclude All. Excludes the current or all Choice input properties
from the test run.

l Copy XPath. Copies a simplified XPath expression to the clipboard. For
details, see "XPath Checkpoints" on page 586.

l Copy Fully Qualified XPath. Copies the complete XPath expression of the
value to the clipboard.

l Link to Data Source. Opens the "Select Link Source Dialog Box" on page
630

l Clear Cell Contents. Clears the contents of the cell.

Note: Some options are only available for specific property types.
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UI Elements
(A-Z)

Description

<context
menu> -
checkpoints

Provides shortcuts for including properties and setting their values.

l Remove Array Element. Removes the selected array element.

l Duplicate Array Element. Duplicates the selected array element with its
values.

l Select All/Expand All. Selects/clears the Validate check box for all child
array elements.

l Collapse/Expand All. Controls the display of array elements.

l Set Auto-value. Inserts a sample value for the argument, based on its data
type.

l Copy XPath. Copies a simplified XPath expression to the clipboard. For
details, see "XPath Checkpoints" on page 586.

l Copy Fully Qualified XPath. Copies the complete XPath expression of the
value to the clipboard.

l Link to Data Source. Opens the "Select Link Source Dialog Box" (described
on 630).

l Display Outgoing Links. Lists the property's outgoing links. For details, see
"Outgoing Links" on page 612.

l Insert Keyword. Insert a keyword in theExpected Value column. The
available keywords are #NIL#, #EXISTS#, #NOT_FOUND#, and #SKIP#.
For details, see "Data Keywords" on page 617.

<properties
list>

A list of all the properties. The fields differ per step type:

l For the Start step: Test Input Parameter

l For the End step: Test Output Parameter

l Formost activities: Input properties.

l For SOAP Requests (underWeb Services category), tools to work with a
schema file.

l For loops, the loop type and properties. See "Loop - Input Properties" on page
418.

HP Service Test (11.52)Page 204 of 705

User Guide
Chapter 10: Properties Pane



UI Elements
(A-Z)

Description

Checkpoint
properties

Additional checkpoint properties:

l Trim whitespace (from start and end of string). Removes whitespace
before and after the text.

l Ignore case.When looking for amatch, ignores the case.

l Stop test if checkpoint fails. Exits the test run if the checkpoint fails. You
set this individually for each checkpoint.

Note:Youmust click on a row in the Checkpoint section to see these properties.
The first two properties are only available for string data types.

Value
column

The property value as a constant value or a link to a data source.

An icon adjacent to the value provides information about the property, such as
read-only, data type, optional, and enables you to select values when
appropriate.

For a list of themost common icons, see the "Array Control Buttons" on page
216.

Tip: Click inside a row to display the relevant icons.

Note: To view the buttons and icons, click within a row of theValue column.

Web Service and SOAP Request Checkpoint Options
The following options only apply toWeb Service andSOAP Request steps.

UI
Elements

Description

Send
request
to
service

Sends the step's request to the service when running the test. This is the normal
behavior forWeb Services andmost types of actions. It is enabled by default.

To sendmessages using JMS transport, clear this check box. Link a subsequent
JMS step to the output of this step. ForWeb services, you can set the security
settings and include attachments, and send this over JMS.

HP Service Test (11.52)Page 205 of 705

User Guide
Chapter 10: Properties Pane



UI
Elements

Description

Validate
Structure

Adds a checkpoint that verifies that the service is in conformance with the schema
defined for the SOAP XML response—either for the response defined in the
operation or a SOAP Fault response. The Run Results Viewer indicates whether or
not the validation succeeded.

This option is available only when theSend request to server option is enabled. It
is enabled by default.

Note: If youmodify the elements in the response, this will not affect the
response schema. For example, adding array elements, selecting specific
Choice elements, changing the derived type, and so forth, only affect the
response—not the schema. To validate the element values, specify expected
values in theValue column or use an XPath expression.

Validate
WS-I

Adds a checkpoint to verify that the SOAP response in compliance withWS-I
standards. The Run Results Viewer indicates whether the response was in
compliance. It also provides aView Report link that opens theWS-I Validation
report in a separate window.

XPath Checkpoint Options
The following options are only relevant for steps with XML output properties, such as String to
XML.

UI
Elements

Description

XML tab A grid representation of the response's schema. In this section you can enter the
expected response values.

l Import Schema. Imports a schema for the XML response.

l Load XML. Loads an XML file as a basis for the schema of the response.

l Clear. Removes the displayed schema.

XPath
tab

A list of XPath expressions used to evaluate the XML response.

l Adds a line for a new XPath expression.

l Removes the selected XPath expression.

l Ignore namespaces: Ignores namespaces in the XPath validation, allowing you
to use simple XPath expressions. For details, see "How to Set XPath
Checkpoints" on page 592.

Database Property Options
The following options are only relevant for properties of theDatabase > Select Data step.
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UI
Elements

Description

Generate
Output

Retrieves table data from the database and constructs an array with the current table
structure.

If you enabledGenerate output in the Query Builder, you do not need to generate
the output again. For details, see "Query Builder Dialog Box" on page 455.

Manage
Columns

If the table structure changed since you generated the output, theManage Columns
dialog box lets youmanage the columns. This is commonwhen columns names
were a parameter, or if a columnwas deleted from the table.

Multipart Tab (Properties Pane)

For HTTP steps, this tab enables you to configuremultipart requests. Multipart messages are sent
with the HTTP request and consist of two or more header/body sets.

To access 1. Open the Properties pane.

2. Select an HTTP Request in the canvas.

3. In the Properties Pane, select theMultipart tab

.

Relevant tasks "How to Send aMultipart HTTP Request" on page 401

User interface elements are described below:

UI Elements Description

Enable Multipart Enables the Input/Checkpoints tab for multipart HTTP requests.

For details about the input and output properties, see "Network Activities" on page 426.

Result Tab (Properties Pane)

This tab enables you check the output of String to XML andString to JSON activity steps.

To access 1. Open the Properties pane.

2. Select aString to XML orString to JSON step in the
canvas.

3. In the Properties Pane, select theResults tab .

See also l "XML Activities" on page 451

l "JSON Activities" on page 430

User interface details are shown below:
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UI
Elements

Description

Result A boolean variable indicating whether the string had the correct structure to be
converted into XML or JSON.

Validate Instructs Service Test to check if the expected output is correct.

Expected
Value

The expected result of the step: True, False, 0, or 1.

Security Tab (Properties Pane)

This tab enables you to configure the security settings for yourWeb Service activities.

To access 1. Open the Properties pane.

2. Select aWeb Service step in the canvas.

3. In the Properties Pane, select theSecurity Settings tab .

Relevant tasks l "How to Set Security for aWeb Service on the Port Level" on page
547

l "How to Set Security for a Specific Step" on page 547

See also l "Setting Security Overview" on page 540

l "Security Settings for Port <Port_Name> Dialog Box" on page 559

User interface elements are described below:

UI Element Description

Use the
port's
security
settings

Enables you to use the security settings from the currently selected step's port.

Note: If you clear this check box, youmust configure the security settings
in this tab.

Save Saves the security settings.

Import Next, unlabeled elements in angle brackets. Use sentence caps, in alphabetical
order. Use thumbnails/popups as necessary.

<security
settings
area>

Enables you to set security information for theWeb Service activity. For full
user interface details, see "Security Settings for Port <Port_Name> Dialog
Box" on page 559.

Edit port's
settings

Enabled only when the Use the port's security settings option is selected.

Opens the "Security Settings for Port <Port_Name> Dialog Box" (described on
559), enabling you to configure the security information used for theWeb
Service's port.
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SOAP Fault Tab (Properties Pane)

This tab enables you to set the expected result of anWeb Service or SOAP activity.

To access 1. Open the Properties pane.

2. Select aWeb Service or SOAP step in the
canvas.

3. In the Properties Pane, select theSOAP Fault tab
.

See also l "Network Activities" on page 426

l "Negative Testing" on page 586

User interface elements are described below.

UI
Elements
(A-Z)

Description

Fault is
expected

Indicates that a SOAP fault is expected during the test run. This setting confirms
that the application did not perform a task that it was not designed to perform.

XML tab The SOAP envelope, containing the Header and Body of the SOAP message. In this
section you enter the expected response.

You can defineAny type elements or values for the following properties:

l faultcode. A status code indicating that the SOAP request was invalid.

l faultstring. A response string indicating that the SOAP request was invalid.

l faultactor. An indication of the source of the fault.

XPath
tab

A list of XPATH expressions used to evaluate the SOAP response.

l Adds a line for an XPATH expression.

l Removes the selected entry.

Test Settings Tab (Properties Pane)

This tab enables you to set global preferences and properties for your test.

To access 1. Open the Properties pane.

2. Select a step in the canvas.

3. In the Properties Pane, select the Test Settings tab

.

Important information Test settings apply to all steps in the test.
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User interface elements are described below.

Test Settings Tab - Action Buttons

UI Elements (A-Z) Description

Export Exports the current Test settings to an XML file.

Import Imports an XML file with previously saved Test settings.

Load Settings

UI Elements Description

Load
Enabled
(read-only)

Indicates whether the test is enabled for load testing. To enable this capability,
select Design > Operation > Enable Test for Load Testing.

Note: Once a test is enabled for load testing, you cannot disable it.

JVM (Java Virtual Machine) Settings
These settings are relevant for all Java related activities such as JMS andCall Java Class
activities.

UI Elements
(A-Z)

Description

Additional
VM
Parameters

Extra parameters to send to the JVM such as Xbootclasspath, and any
parameters specified by the JVM documentation.

Classpath The vendor implementation of Java classes together with any other required
supporting classes, as determined by the implementation vendor.

JMS Settings

UI Elements
(A-Z)

Description

Automatically
generate
selector

Generates a selector for the responsemessage with the correlation ID of the
request (No by default). Each JMS message sent to the server has a specific
ID. Enable this option if you want Service Test to automatically create a
selector that includes themessage ID.

Note: This option only affects theSend and Receive Message from
Queue activity.

JMS
connection
factory

The JNDI name of the JMS connection factory. This setting is unique for each
test.
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UI Elements
(A-Z)

Description

JMS security
credentials

The principal's credentials for the authentication scheme.

JMS security
principal

Identity of the principal (for example the user) for the authentication scheme.

JNDI initial
context
factory

The fully qualified class name of the factory class that will create an initial
context. It provides a list of context factories and enables manual entries.

JNDI
provider URL

The URL of the service provider. For example:
Websphere - iiop://myserver:myport

Number of
JMS
connections
per process

The number of JMS connections each execution process creates. The default
is 1, and themaximum is 50. The fewer connections you have, the better your
performance.

Received
message
timeout
options

The timeout for receivedmessages.

l Indefinite wait.Wait as long as required for themessage before continuing.

l No wait. Do not wait for the Receivemessage, and return control to the
script immediately. If there was nomessage in the queue, the operation
fails.

l User defined timeout.Wait a specified number of seconds for the
message. If it does not arrive, the operation fails.

User defined
timeout

The amount of seconds to wait for themessage before timing out. The default is
20 seconds.

.NET Settings

UI
Elements

Description

Assembly
paths

The .NET assembly paths for the test.

This entry should include all relevant folder paths and environment variables.
Separatemultiple values with semicolons.

General Settings

UI Elements Description

Stop test on step failure Exits the test if a step fails during the test run.

Default: True
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Reporting Settings

UI Elements Description

Use the reporting
mechanism

Tells Service Test to automatically open the Run Results Viewer
after a test run.

Test Variables Tab (Properties Pane)

This tab enables you to set global test variables for use in your test.

To access 1. Open the Properties pane.

2. Select theStart orEnd step in the canvas.

3. In the Properties Pane, select the Test Variables tab .

Relevant tasks "How to Define Test Properties or User/System Variables" on page 59

See also l "New Test Profile Dialog Box" on page 74

l "Manage Profiles Dialog Box" on page 75

User interface elements are described below.

UI
Elements
(A-Z)

Description

System
variables

A read-only list of common system variables and their values:

l ScenarioID

l SystemTempDir

l GroupName

l TestDir

l TestName

l LocalHostName

l OS

l OSVersion

l ProductDir

l ProductName

l ProductVer

l UserName.

User
variables

A list of the user variables for all profiles. When enabling theCompare Profiles
option, the grid displays the variable values for each profile in separate columns.
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Test Variables Tab - Action Buttons

UI
Elements

Description

Add New User Variable. Adds a new user variable to the all profiles.

Remove User Variable. Deletes the selected user variable from all profiles.

Add New Profile. Adds a new User Variable profile to the list.

Edit Active Profile. Opens theManage Profiles dialog box that lets you to remove
or rename profiles.

Compare Profiles. Displays the profiles side-by-side for comparison.

<Profile
list>

A list showing the existing User Variable profiles.

XML Body Tab (Properties Pane)

This tab enables you to configure the response XML data for a SOAP Request step.

To access 1. Open the Properties pane.

2. Select aWeb Service step in the canvas.

3. In the Properties Pane, select theXML Body tab

.

See also "Network Activities" on page 426

User interface elements are described below (unlabeled elements are shown in angle brackets).

UI Elements Description

Grid Shows a grid view of the schema.

Text Opens an editable text view for the schema.

Revert Text view only—reverts back to the last version of the schema since you last
opened the Text view.

Syntax error. Data at the root level is invalid. Move themouse over the icon to
see the error's line number (Text view only).

Syntax warning. A warning indicating a problem in the entered text, for example,
if the specified element is not in the namespace. For details, move themouse
over the icon (Text view only).

Import
Schema

Imports an .xsd file representing the schema, for both Input properties and
checkpoints.
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UI Elements Description

Load XML Loads an .xml file containing values for the schema, for both Input properties
and checkpoints.

Deletes the contents that you entered for the schema. This affects both the Grid
and Text views.

Input pane A grid or text representation of the schema's request header and body.

Checkpoints
pane - XML
view

A grid representation of the response's schema. In this section you can enter the
expected response values.

l Import Schema. Imports a schema for the XML response.

l Load XML. Loads an XML file with the expected response values.

l Clear. Deletes the contents of the schema.

XPath
Checkpoints
pane

A list of XPath expressions used to evaluate the XML response.

l Adds a line for a new XPath expression.

l Removes the selected XPath expression.

Ignore namespaces: Ignores namespaces in the XPath validation, allowing you
to use simple XPath expressions. For details, see "How to Set XPath
Checkpoints" on page 592.

Note: To retrieve an XPath expression, use the right-click menu options in
the Grid view.

Action Buttons

The following buttons represent actions, primarily performed on step properties. The availability of
the buttons depends on the step type.

UI
Elements

Description

Data Drive Entire Step. Data-drives all values for the step. It adds data
expressions to theValue columns of all input properties.

For details, see "How to Data Drive a Test Step" on page 623.

Edit Property. Opens the Edit Property dialog box for changing the name, type, or
description of a property.

Note: Only available for Custom Code, RESTmethod, and Start/End steps.
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UI
Elements

Description

Load from Replay. Loads data from a recent replay in order to populate the
service's properties with values (forWeb Services only).

For details, see "How to Run an API Test" on page 288.

Remove Property. Deletes the selected property from the list.

Note: Only available for Custom Code, RESTmethod, and Start/End steps.

Add Input/Output Property/Parameter. Opens the "Add Input/Output
Property/Parameter Dialog Box" (described on page 497), allowing you to define a
new property and its data type.

Note: Only available for Custom Code, RESTmethod, and Start/End steps, or
when selecting the entire canvas.

For details, see "Coding Service Test Events" on page 641.

Load
XML

Loads XML data in order to populate a service's schemawith values (forWeb
Services only).

For details, see "How to Run an API Test" on page 288.

Load
options

Loads an XML file containing theCompare XML ignore settings that you saved with
another test.

Save
options

Saves theCompare XML ignore settings so that you can load them into a future
test.

Select
GUI/API
Test

ForCall GUI Test and Call API Test steps: Invokes the "Select Action or Test
Dialog Box" (described on page 516), enabling you to selecting a test to call from this
step.

Select
Java File

Opens the "Java Class Dialog Box" for setting additional classpaths for the call (for
Call Java Class steps only).

For details, see the "Java Class Dialog Box" on page 459.

Refresh
GUI/API
Test

ForCall GUI Test andCall API Test steps: Updates the test from its original
location.

Load
JSON

Loads a JSON file to convert to or from a string.

Note: Only available for JSON to String andString to JSON steps.

HP Service Test (11.52)Page 215 of 705

User Guide
Chapter 10: Properties Pane



Value Column Icons

The following buttons represent information, drop-down lists, or actions within the Properties pane's
Value column:

UI
Elements

Description

Include argument in the request. Toggle to clear the triangle and exclude the
argument.

Set to NIL. Toggle to clear the icon and remove the NIL value assignment.

Read-only node. Values that cannot be changed such as properties linked to a data
source other than a constant value, or nodes with read-only attribute in the activity
signature, first HTTP header, and so forth.

Warning. A warning related to the data source. For example, The data types

of the link source and link destination do not match.

l For Input properties:

A drop-down list of possible values. For example, for boolean values it provides a
list of values for boolean type data: true, false, 0, or 1. For date types, it
opens a calendar. This drop-down arrow is located adjacent to the Link to a data
source button .

l ForCheckpoints:

A drop-down list of the relevant comparison operators such as: =,!=, >, >=, <,
<=, Starts, Ends, Contains, or Regex. The greater than operator, >, when
used with strings, indicates that it appears later in the alphabet.

Scroll. A scroll control for integer data types.

Browse. Enables you to locate a file or folder for example, when using a File
System type step.

For anOpen Connection step, this opens the "Connection Builder Dialog Box"
(described on 453).

Link to a data source. Opens the "Select Link Source Dialog Box" (described on
630), allowing you to select values for the property from a data source.

Display list of outgoing links. Shows a list of all input properties that link to this
output property. For details, see "Outgoing Links" on page 612.

Array Control Buttons

The following buttons allow you to handle array type properties. These buttons are adjacent to the
property name in the Properties pane's left pane.
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After you add array elements, you can set the number of iterations to use the different array values.
For details, see "Flow Control Activities" on page 417.

UI
Elements

Description

Add array element. Adds one array element to the selected node in the in the
Properties tree.

Remove array element. Removes the selected array element from theProperties
tree.

Duplicate array element. Adds a copy of the selected array element.
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Troubleshooting and Limitations -Properties Pane
The tooltips displayed in the Properties pane are not localized.
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Chapter 11: Run Step Results Pane
This chapter includes:

Concepts 220

Run Step Results PaneOverview 220

Reference 222

Run Step Results Pane User Interface 222

Run Step Dialog Box 224

Troubleshooting and Limitations - Run Step Results 226
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Concepts

Run Step Results Pane Overview
Before you run your test, you can test individual steps tomake sure they run properly. This feature,
Run Step, is available directly from the canvas and is available for most step types. To run an
individual step, select it and chooseRun Step from its right-click menu.

After you run the step, the Run Step Results pane opens and shows the properties and results.

For services using SOAP, this pane shows the Input andOutput envelopes. You can expand and
collapse the nodes of the envelope tomake it more readable.

This can be especially useful in checking the validity of your input property values. In the following
example, the specified flight number was not valid.

HP Service Test (11.52)Page 220 of 705

User Guide
Chapter 11: Run Step Results Pane



The Run Step feature also verifies checkpoints that are selected in the Checkpoints pane, including
those of Fixed array type.

For a user interface description, see "Run Step Results Pane User Interface" on next page.

For RESTmethods, use the RunMethod feature in the REST user interface. For details, see
"Add/Edit REST Service Dialog Box" on page 495.
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Reference

Run Step Results Pane User Interface
The Run Step Results pane shows the results of the run. For a simple built-in activity, it shows the
status of the run. For SOAP messages, it shows the Input andOutput envelopes.

To access Select View > Run Step Results

Relevant tasks "How to Create an API Test" on page 383

See also l "The Canvas" on page 373

l "Run Step Dialog Box" on page 224

The user interface elements are described below (unlabeled elements are shown in angle brackets):
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UI Elements Description

<Step Name> table A table showing the names and values of properties and an invocation
summary. The following is a list of the common fields:

l Name. The name of the step as it appears in the General properties.

l Comment. The text in the General properties tab's Comment field.

l <Properties>. The input and output property names and values (non
SOAP steps).

l Input Envelope. A tree hierarchy of the SOAP envelope for the input
properties.

l Output Envelope. A tree hierarchy of the SOAP envelope for the
output properties.

l Invocation Results. Text describing the results of the run—both
upon success and failure.

Checkpoints
(<success ratio>)
table

A table showing the checkpoints, with the following information:

l Property name

l Expected andActual values

l Operator (=, <, >, and so forth)

l XPath of the property
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Run Step Dialog Box
This dialog box enables you to set constant values for theRun Step operation.

To access Do the following:

1. Add a step to the canvas that supports Run Step.

2. Link one or more properties to an output property from a previous step.

3. Click the step in the canvas and select Run Step from the right-click menu.

Important
information

A property is listed when one of the following applies:

l The property's input value is linked to the output property of a previous step.

l The property requires a value, such as a URL for an HTTP Request step, and
that value was not specified in the Properties pane.

Note:When you assign constant values to the properties, the value is only
used for this local Run Step step—the link to the output property in the
Properties pane is not affected.

Relevant
tasks

"How to Create an API Test" on page 383.

See also "Run Step Results Pane" on page 219

User interface elements are described below:
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UI
Element
(A-Z)

Description

Open Text Editor. Opens an editor for editing text strings.

Note: For properties with enumeration, this button is not shown. Instead, a drop
down list is available for selecting a value.

Import from File. Allows you to import a property value from a file. This is useful for
complex properties whose values are stored in XML files.

Note: For properties with enumeration, this button is not shown. Instead, a drop
down list is available for selecting a value.

<property
list>

A list of the properties to which a data source was assigned, that need to be given a
constant value. It shows the following information:

l Section Name. The origin or type of property, usually Input or Output.

l Property Name. The property name as it appears in the Properties pane.

l Value. The value to use in the run. By default, it takes the value from the first row
of the data source.
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Troubleshooting and Limitations - Run Step
Results

This section describes troubleshooting and limitations for the Run Step Results pane.

l Whenworking in non-English operating systems, certain entries in the Run Step Results pane
are hard-coded in English and not translated.
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Chapter 12: Search Results Pane
This chapter includes:

Concepts 228

Search Results PaneOverview 228

Tasks 229

How to Navigate Through the Search Results Pane 229

Reference 231

Search Results Pane User Interface 231
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Concepts

Search Results Pane Overview
The Search Results pane displays all occurrences of the search criteria you define using the Find
dialog box or other Searchmenu items. Search results are displayed in one continuous list or
grouped according to source file.

You can browse through the search results, locate specific results in their source files, and perform
recent searches again to retrieve updated results.

For details on searching for specific strings, see "How to Navigate Through the Search Results
Pane" on next page.

For user interface details, see "Search Results Pane User Interface" on page 231.

Note: Searches are not supported in the canvas.
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Tasks

How to Navigate Through the Search Results Pane
This task describes how to navigate through results displayed in the Search Results pane, as well
as how to access the recent search history.

This task includes the following steps:

l "Prerequisite" below

l "Modify the search results display" below

l "Browse and locate search results" on next page

l "Display updated results for recent searches" on next page

l "Clear the recent search history" on next page

For user interface details, see "Search Results Pane User Interface" on page 231.

Prerequisite
Do one of the following:

l Perform a search using the Find All button in the "Find Dialog Box" (described on page 152).
For details, see "How to Find or Replace Strings in Files" on page 141.

l Search for references using the Searchmenu options. For details, see "How to Search for
References or Classes in Tests in the Editor" on page 140.

Modify the search results display
To toggle between display modes:

Click theSelect search list mode button to toggle between the following display
modes:

l Flat list. Displays all search results in a single list.

l Grouped per file. Displays all search results in a hierarchical list according to their source files.

When the results are grouped per file, a file information line is displayed above each group of
results, indicating the source file and number of occurrences found in the file. For example:

To collapse or expand the results per file:

Click theCollapse per file orExpand per file icon to the left of the file information line to view
the results found in a specific file.
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Browse and locate search results
l Use the scroll bar to move up or down in the search results list.

l Do one of the following to jump to the location of a search result in the document pane and
highlight the search string:

n Double-click a search result in the list.

n Click Previous to select the previous item in the search results list.

n Click Next to select the next item in the search results list.

Display updated results for recent searches

Click theShow last searches button and select a search string from the drop-down list.

TheShow last searches drop-down list displays the last ten search strings used.

Clear the recent search history

Click theShow last searches button and select Clear history.

TheShow last searches drop-down list is cleared of all recent search strings.
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Reference

Search Results Pane User Interface
This pane displays all occurrences of the search criteria you defined and enables you to:

l Locate specific search results in their source files

l Retrieve updated search results for recent searches

l Clear the search history

To access Do one of the following:

l Select View > Search Results to view the results of your last search.

l In the Find dialog box, define the search criteria and click Find All.

l Perform a search for references using the Searchmenu options.

Important
information

Click on a row or use thePrevious andNext buttons to jump to the location of the
search result in the document pane and highlight the search string.

Note: Searches are not supported in the canvas.

Relevant
tasks

l "How to Navigate Through the Search Results Pane" on page 229

l "How to Find or Replace Strings in Files" on page 141

l "How to Search for References or Classes in Tests in the Editor" on page 140

See also "File and Item Types Included in String Searches" on page 136

The following sections describe:
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l "Main User Interface Elements" below

l "Context Menu User Interface Elements" on next page

Main User Interface Elements
User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Ele-
ment

Description

<Show recent searches>. Enables you to:

l View a drop-down list displaying the last ten Find All search strings used.

l Clear the search history entirely.

Select a search string to retrieve themost recent results, or select Clear search history
to clear the recent search history.

<Search list display mode>. Enables you to display all search results in a single list or
grouped according to source file.

Previous result. Selects the previous item in the search results list, jumps to the
location of the search result in the document pane, and highlights the search string.

Next result. Selects the next item in the search results list, jumps to the location of the
search result in the document pane, and highlights the search string.

<Collapse or expand per file>. Enables you to collapse or expand the list of search
results located in a specific file, when viewing an expanded list of results grouped by file.

Note: This icon is displayed when the results are grouped by file.
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UI
Ele-
ment

Description

<Sea-
rch
resul-
ts
list>

Search results are displayed with the following syntax, depending on the type of source
file:

Test flow

l Grouped per file:

<Activity StepID>/<Tab Name>/<Property Name> : <Property

Value>

l Viewed in flat list:

n <Test Name>/<Activity StepID>/<Tab Name>/<Property Name> :

<Property Value>

or

n <Test Name><(Action)>/<Activity StepID>/<Tab

Name>/<Property Name> : <Property Value>

User source code

l Grouped per file:

<line>,<column> : <text>

l Viewed in flat list:

<File Path> (<line>,<column>): < text >

Context Menu User Interface Elements
The user interface elements described below are available when you right-click a search result in
the Search Results pane:

UI
Elements

Description

Copy Copies the content of the selected search result to the clipboard.

Locate Jumps to the location of the selected search result in the document pane and
highlights the search string.

Note: You can also double-click the search result.
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Chapter 13: Solution Explorer Pane
This chapter includes:

Concepts 235

Solutions in Service Test Overview 235

Solution Explorer PaneOverview 235

Tasks 237

How toManage Items in the Solution Explorer Pane 237

Reference 240

Solution Explorer Pane User Interface 240

Troubleshooting and Limitations - Solution Explorer Pane 248
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Concepts

Solutions in Service Test Overview
A solution is a collection of tests and other resources, similar to a binder or notebook. You can use
solutions to organize your tests to help you perform comprehensive application testing.

For example, suppose you want to test aWeb application for a flight booking service. You can
create a solution containing several tests that verify various aspects of your service, such as
logging in, booking a reservation, verifying the connection between your application and database,
and verifying the transfer of booking information from your application to an airline server.

In Service Test, all tests must be part of a solution. Therefore, when you create a test, you assign it
immediately to a solution. You can provide descriptive names for your solutions, or you can accept
the default names provided by Service Test.

Service Test solutions can include tests, business components, business process tests and flows,
or user-created code documents. When you add a test to a solution, it retains its unique
associations to other tests and resource files and does not create links to the other tests in that
solution. The relationship between solutions and tests goes in one direction. The solution contains
references to its tests, but the tests do not contain a reference back to any solutions that contain it.

You can create solutions for own use, or you can share solutions with other users by saving them in
an accessible location, such as a network drive. Although your tests can be stored in the file
system or ALM, solutions are always stored somewhere in the file system.

You view andmanage solutions in the Solution Explorer pane.

Solution Explorer Pane Overview
You use theSolution Explorer pane to view andmanage the tests in a solution. The Solution
Explorer is displayed as a tree in the Solution Explorer pane. This tree displays a separate node for
each test, with sub-nodes for all referenced items.

From the Solution Explorer, you can:

l Add new or existing tests to a solution.

l Open any test directly from the Solution Explorer. You can open several tests side-by-side in the
same session.

l Display the properties and settings for the solution or any of its tests by highlighting the relevant
node. This refreshes most of the panes in Service Test as the Solution Explorer pane serves as
themaster pane in Service Test.

l Add user-created functions to a test by adding a C# user code file.

l Add an external reference file toa test for a run session or add aWeb reference for use in a test.

l Rename the solution andmany of its sub-nodes.

l Run a test or component from the solution.
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Note:When you open a test from outside of the Solution Explorer (from the File menu, for
example), the test always opens in a new, untitled solution, even if it is part of the currently
open solution. Therefore, if you want to open a test that is part of the current solution, and you
do not want to close any other open tests, open the test from the Solution Explorer.

For an overview of solutions, see "Solutions in Service Test Overview" on previous page.

For task details, see "How toManage Items in the Solution Explorer Pane" on next page.

For user interface details, see "Solution Explorer Pane User Interface" on page 240.
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Tasks

How to Manage Items in the Solution Explorer Pane
This task describes how to perform various operations in the Solution Explorer pane.

This task includes the following steps:

l "Prerequisite: Show the Solution Explorer pane" below

l "Create a solution" below

l "Open a solution" on next page

l "Create a test" on next page

l "Add a test to the current solution" on next page

l "Open an existing test from the current solution" on next page

l "Run a test or component from the current solution" on next page

l "View or hide the sub-nodes in the test" on next page

l "Remove a test from the current solution" on page 239

l "Save an individual test within the solution" on page 239

l "Save the solution" on page 239

l "Close the solution" on page 239

Prerequisite: Show the Solution Explorer pane
Do one of the following:

l Select View > Solution Explorer.

l Click theSolution Explorer button in the toolbar.

l Click theSolution Explorer tab in themain Service Test window.

Create a solution
Do one of the following:

l Select File > New > Solution.

l Click theNew button down arrow in the toolbar and select New Solution.

l Select File > New > Test.

In the "New <Document> Dialog Box" (described on page 67), enter a solution name in the
Solution Name field and select theCreate directory for solution option.

A new solution, also containing the test selected, opens in the Solution Explorer pane.

Note: If you do not create a named solution, a generic solution called Solution Untitled
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is created.

Open a solution
Select File > Open > Solution. In the dialog box, select the name of your solution file.

If a test included in a solution is unavailable, due to issues with ALM connectivity or resource file
problems, it appears in gray and an error describing the problem is displayed in the Errors pane.
Right-click Reload after resolving the error to add the test to the solution for editing.

Note:

l If you open a solution when another solution is open, the first solution is closed and you are
prompted to save any unsaved changes to tests contained in the closed solution.

l You can save and open solutions only on the file system.

Create a test
Right-click the <solution name> node and select Add > Add New Test/Business Component.

The "Add Test/Component to Solution Dialog Box"(described on page 64) opens, enabling you to
create a new test and add it into your solution file.

Add a test to the current solution
Right-click the <solution name> node and select Add > Add Existing Test/Business
Component.

The "Add <Existing Document> to Solution Dialog Box" (described on 63) opens, enabling you to
add a test to your solution file.

Note: You can add amaximum of 10 tests to a solution.

Open an existing test from the current solution
Double-click a node for your test:

l For tests and components: the Flow node located under the test or component node.

l Forevent handlers: theEvents node located under the test or component name.

l For user code files: the <User Code file name> node located under the test or component
name.

A tab opens in the document pane with the selected document.

Run a test or component from the current solution
Right-click on a test or component node and select Run. The Run dialog opens, enabling you to
choose preferences for your run session. For details, see "Run Dialog Box" on page 296.

View or hide the sub-nodes in the test
Do one of the following:
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l Right-click the Test node in the tree and select Expand All or Collapse All.

l Click the expand or collapse icons next to the node to expand or collapse the node.

Remove a test from the current solution
Do any of the following:

l Right-click a test node and select Remove from Solution.

l Select a test and press DELETE.

Note: Removing a test from a solution does not delete it from your file system or ALM project.

Save an individual test within the solution
Right-click a test name and select Save As.

The "Save <Resource>/Save <Document> As Dialog Box"(described on 72) opens, enabling you
to save the test with a different name or in a different location.

Save the solution

Select File > Save All or press theSave All button on the toolbar.

Note: Selecting this command also saves any modified test within the solution.

Close the solution
Select File > Close Solution.

Note: Closing a solution closes all tests that are part of the solution file. These files are not
deleted from your file system or ALM project when a solution is closed.

HP Service Test (11.52)Page 239 of 705

User Guide
Chapter 13: Solution Explorer Pane



Reference

Solution Explorer Pane User Interface
This pane enables you to:

l View the currently open solution and its tests

l Add or remove items from a solutions

l Open tests contained in a solution

l Run a test or component

The following image shows the Solution Explorer pane displaying the available nodes when tests
are part of a solution.

HP Service Test (11.52)Page 240 of 705

User Guide
Chapter 13: Solution Explorer Pane



To access Do one of the following:

l Select View > Solution Explorer

l Click theSolution Explorer toolbar button .
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Important
information

l The Solution Explorer pane is displayed by default when you start Service
Test.

l The Solution Explorer pane is the control pane within Service Test. Other
panes, menus, and toolbars update their content to match the test selected in
the Solution Explorer pane.

l Test nodes are displayed in alphabetical order.

l The active test is shown as bold in the Solution Explorer pane.

Relevant
tasks

"How toManage Items in the Solution Explorer Pane" on page 237

See also "Solution Explorer PaneOverview" on page 235

The Solution Explorer pane can display the following key nodes:

Solution Node (Solution Explorer Pane) 242

Service Test Test/Component Node (Solution Explorer Pane) 243

Business Process Test/Flow Node (Solution Explorer Pane) 247

Note: All user interface descriptions of each node also contain the descriptions of the context
menus available for the node.

Solution Node (Solution Explorer Pane)

The solution node displays the name of the solution and contains all the tests and resource nodes
necessary to edit and run a test. For details about a specific type of test node, see the relevant
section on each node below.

The following context menu options are available when you right-click the solution:

l Add New/Existing <Document>. Opens the "Add Test/Component to Solution Dialog Box"
(described on page 64) or "Add <Existing Document> to Solution Dialog Box" (described on
page 63), which adds a new or existing test to a solution.

Note: You can add amaximum of 10 tests to a solution.

l Expand All. Expands all test, component, or application area sub-nodes contained in the
solution.

l Collapse All. Collapses all sub-nodes contained in the solution.

l Compile solution (API testing only). Compiles the solution files that have changed.

l Recompile solution (API testing only). Compiles all solution files, regardless of whether they
changed. You should run theClean solution command before this command.

l Clean solution (API testing only). Removes all files generated in the previous compilation of
the solution.
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Note: TheCompile, Recompile, andClean commands are applicable if your solution
contains only APIService Test tests. This command is not available if a solution contains
GUI tests or components.

Service Test Test/Component Node (Solution Explorer Pane)

This Service Test Test node is available only if your solution contains aService Test test or
component. Some of the nodes contained within this one, are available only if a relevant resource is
created in a test or component.

This node can contain the following sub-nodes:

l "References Node" below

l "Flow Node" below

l "Events Node" below

l "Action Node" on next page

l "External Tests/Actions Node" on next page

l "UserCode Node" on next page

l "Context MenuOptions" on next page

References Node
This node contains all of the .dll files used by Service Test to run tests.

Note: Do not remove any of the reference files contained by default in this node. They are
required to perform aService Test run session. You can add additional user-created reference
files using the context menu options. For details, see "Add Reference Dialog Box" on page
245.

Flow Node
This node provides a link to the Service Test canvas, which displays the test's flow. Double-
clicking this node displays the canvas or opens the canvas's tab (if closed). Each individual action
also contains a flow node for the action's steps.

For details on using the Service Test canvas, see "The Canvas" on page 373.

Events Node
This node provides a link to the test or action's TestUserCode.cs file used for coding event
handlers. Double-click on this node to display the file. Each individual action within a test also has
an events node for the action.

Note: If you double-click on this link independently of the events tab in the Properties pane, the
global test or component user code is displayed, including all event handlers currently written
into the test.

For details on coding Service Test events, see "Writing Code for Events Overview" on page 642.
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Action Node
This node contains all of the actions created in aService Test test.

Each action node contains a Flow andEvents node.

Note: This node is displayed only when you create an action in aService Test test. For details,
see "Actions Overview" on page 508.

External Tests/Actions Node
This node contains all of the tests or actions (both UFT and Service Test) called from the Service
Test test. The different types of called actions are noted by their icons.

Note: This node is only displayed when you create a call to an external test or action. For
details on using HP Functional Testing activities in aService Test test, see "HP Automated
Testing Tools Activities" on page 449.

UserCode Node
This node contains any user code files associated with the test. The following user interface
elements are available:

UI Element Description

<file name> The name of the user code file name.

Note: Only .cs files can be associated with aService Test test.

<folder name> The name of a folder containing user-generated code to add to a test.

Context Menu Options
The following context menu options are available for theService Test node:

Node Context Menu Option

<test
name>

l Run. Opens the "Run Dialog Box" (described on page 296) to begin a run
session for the current test.

l Expand All. Expands all sub-nodes found under the test.

l Collapse All. Collapses all sub-nodes found under the test.

l Remove from Solution. Removes the current test from the solution file.

l Save As. Opens the "Save <Resource>/Save <Document> As Dialog Box"
(described on page 72), enabling you to save the selected test under a different
name or in a different location.

References
folder

l Add Reference. Opens the "Add Reference Dialog Box" (described on page
245), which adds a external reference file to your test.
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Node Context Menu Option

<reference
name>

l Refresh. Updates the selected reference file with any changes made to the
file.

l Remove. Removes the current reference from the list.

l Properties. Displays the properties of the reference file in the Properties pane.

Caution: Do not remove the reference files included in this node, as doing so
may cause a run session to fail.

<action
name>

l Delete Action. Removes the selected action from the test.

l Rename Action. Opens the "Rename Action Dialog Box" on page 517,
enabling you to rename the action.

Note: Before renaming an action, youmust close the action's tab and user
code file and save your test.

User Code l Add New File. Opens a dialog box to add a new custom code file to your test.
For user interface details, see "Open/New <Document>/<Resource> Dialog
Box" on page 69.

l Add Existing File. Opens the "Add <Existing Document> to Solution Dialog
Box" (described on page 63), which adds an existing custom code file to the
test.

<user code
file/folder
name>

l Open. Opens the file in the document pane or brings it into focus.

l Open Containing Folder in Explorer. Opens the folder containing the user
code file inWindows Explorer.

l Remove. Removes the user code file from the user code node and deletes it.

l Exclude From Test. Removes the association of this user code file from your
test.

l Rename. Renames the selected file.

l Properties. Opens the file's properties in the Properties pane.

Add Reference Dialog Box

This dialog box enables you to add a reference file to your Service Test test.
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To access Do one of the following:

l Select theReferences node of a test, right-click and select Add Reference.

l Select Design > Add Reference.

User interface elements are described below:

UI Element Description

GAC tab Displays a list of the GAC (Global Assembly Cache) assemblies and version
numbers.

Note:

l If you select theChoose specific assembly version option, the pane
displays a list of all versions of all assemblies. You can then select a
specific version of an assembly to insert in the test.

l If you enter a text string into theSearch field, Service Test searches
through the list of assemblies for the assembly that matches your search
string.

Tests tab A list of all tests contained in the current solution.
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UI Element Description

.NET
Assembly
Browser
tab

Enables you to searches the file system for .NET assemblies to import into a test.

The browser displays the following information:

l <directory location>. The location on the file system for a folder or assembly.

l Back/Up buttons. Enable you to return to the previously selected directory or
the previous level on the directory hierarchy to search for an assembly.

l <files list>. The list of all available files in a directory location.

COM tab A list of all software components and their location in the file system.

Note: If a path to a component is not listed in the pane, then the component is
located in the <Service Testinstallation>/bin folder.

Select Adds the current assembly, project, or software component to theSelected
References list.

Remove Removes the current assembly, project, or software component from the
Selected References list.

Selected
References

A list of all assemblies, projects, or software components to add to your test. The
grid displays the following information:

l Reference Name. The reference name as displayed in the References node in
the Solution Explorer pane.

l Type. The type of reference for the selected reference, project, or assembly.

l Location. The location of the selected reference in the file system. If a location
is not displayed for the reference, it is located in the< Service Test
installation>/bin folder.

Business Process Test/Flow Node (Solution Explorer Pane)

The Solution Explorer pane does not display sub-nodes for business process tests or flows. You
can view the components in the document pane.

The following context menu options are available for a business process test or flow:

l Run. Runs the current business process test or flow.

l Remove from Solution. Removes the current business process test or flow from the solution.

For details on business process testing, see theHP Business Process Testing User Guide.
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Troubleshooting and Limitations - Solution
Explorer Pane

This section describes troubleshooting and limitations for the Solution Explorer pane.

Solutions stored on a network location are not locked when opened by Service Test.
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Chapter 14: Tasks Pane
This chapter includes:

Concepts 250

Tasks PaneOverview 250

Tasks 251

How to Create andManage TODOComments 251

Reference 251

Tasks Pane User Interface 251
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Concepts

Tasks Pane Overview
The Tasks pane enables you to create andmanage TODO comments for issues that need to be
handled in your user code files.

TODO comments are reminders that are inserted as comments adjacent to the relevant steps in
your testing document. For example, you can provide instructions to someone else during a
handover, or you can remind yourself to do something.

When you create event handlers, the editor automatically inserts TODO text, indicating where you
need to enter your code.

You can access TODO comments from the Tasks pane or directly from the testing document. For
details, see "Tasks Pane User Interface" on next page.

If needed, you can export your TODO comments to an XML file or Microsoft Excel.
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Tasks

How to Create and Manage TODO Comments
This task describes the different operations you can perform tomanage TODO comments in user
code files.

l To add a new TODO comment, insert a comment adjacent to the relevant step in your
document. A comment can begin with any of the following permutations of the words to do:
To Do, todo, to-do, or TODO.

l To delete a TODO comment, youmust delete the source line in the document. This removes the
TODO comment from the pane. (To jump to the source line, you can either double-click a
comment in the Tasks pane, or you can highlight the comment in the Tasks pane and then click
the Locate button.)

l To sort by a specific column, click on the column header.

l To rearrange columns, drag a column header to a different location.

l To filter TODO comments, click theShow Tasks from button and select one of the following:

n Solution. Displays all of the TODO comments stored in all of the tests included in the
solution (including closed tests).

n A specific test or component. Displays only the TODO comments that are stored in that
test or component.

l To export TODO comments:

a. Click theExport Task List button.

b. In the "Save <Resource>/Save <Document> As Dialog Box" on page 72 (described on page
72), browse to the required location in the file system.

c. Enter a file name and specify the file type. You can export the file as XML, CSV, or
.xls/.xlsx (if Excel is installed on the computer).

d. Click Save. The TODO comments are saved to a file in the specified location and in the
specified format.

Reference

Tasks Pane User Interface
This pane enables you to view and access TODO comments in user code files.
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To access In themain Service Test window, select View > Tasks.

Important
information

l This view can display any comment step that begins with any of the following
permutations of the words to do: To Do, todo, to-do, or TODO (not case-
sensitive).

Example: To Do need to ask Sarah to add design steps

l The text displayed in the Comments view is limited to 260 characters. If the
text exceeds this limit, and you want to view the entire comment, you can jump
to the comment in the testing document by double-clicking the comment line in
the Comments view.

Relevant
tasks

"How to Create andManage TODOComments" on previous page

See also "Tasks PaneOverview" on page 250

User interface elements are described below:

Toolbar Buttons

Toolbar
Option

Description

<Filter> Enables you to show all of the TODO comments for the solution, or to filter the
display to show TODO comments only for a specific test or component.

Locate Jumps to the comment line in the user code file for the currently selected TODO
comment.

Tip: You can also double-click a TODO comment to jump to its location in the
source document.

Note: This option is available only when a line in the Tasks pane is selected.
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Toolbar
Option

Description

Export
Task
List

Saves the TODO comments to an external file, such as a text file.

You can save the list of TODO comments in any of the following formats:

l XML (Extensible Markup Language)

l XLS/XLSX (Microsoft Excel file)

l CSV (Comma-Separated Values file)

Columns

Column Description

Line The line number of the TODO comment in the source document.

Description The text of the TODO comment.

Source The file name of the user code file containing the TODO comment.

Test The name of the test containing the TODO comment, or associated with it.

Context Menu Options

Context Menu
Option

Description

Copy Copies the TODO comment to the Clipboard.

Locate Jumps to the comment line in the user code file for the currently selected
TODO comment.

Tip: You can also double-click a TODO comment to jump to its location
in the source document.
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Chapter 15: Toolbox Pane
This chapter includes:

Concepts 255

Toolbox PaneOverview 255

References 256

Toolbox Pane User Interface 256
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Concepts

Toolbox Pane Overview
The Service Test panes allow you to create tests using a drag and dropmechanism.

The Toolbox pane provides a collection of standard service activities for functional testing in areas
such as XML, SOAP, Java, JMS, IBMMQWebsphere and HTTP. You can addmore activities to
the Toolbox pane by importingWSDLs or using services from the repository.

After you import aWeb service, it appears in the Toolbox pane, under the Local Activities > Web
Services node. When you expand theWeb Services node, the Toolbox pane displays the service's
name, port, and operations.

You can also create new custom activities, using the built-in Activity Wizard. For details, see
"Extensibility in Service Test" on page 661.
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References

Toolbox Pane User Interface
The Toolbox pane enables you to view all of the available activities. This includes imported
services and built-in activities such as that you can use in your visual design, such as Replace
String or File Exists.

This pane is Service Test's main window for creating and populating tests.
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View Image
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To access 1. Create or open a test or component.

2. Do one of the following:

n Click the Toolbox tab in the bottom of the left pane.

n Select View > Toolbox or click the Toolbox tab in themain
Service Test window.

Important
information

l You double-click or drag activities from this pane onto the canvas.

l The activity becomes as test step when it appears in the canvas.

l Click on the down arrows at the top of the pane to access the toolbar
controls.

Relevant tasks "How to Create an API Test" on page 383

Toolbar Controls
The following toolbar controls elements are included in the Toolbox pane. To see all of the controls,
expand the pane or use the drop downmenus.

Tree
Elements

Description

Expand All. Expands all nodes in the Toolbox pane.

Collapse All. Collapses all nodes in the Toolbox pane.

Security Settings. Opens the "Security Settings for Port <Port_Name> Dialog Box"
(described on 559). These settings apply to all operations in the port.

Note: Only available when selecting the Port node of aWeb service.

Choose Activities. Opens the Choose Toolbox Activities dialog box, for selecting
activities stored in the File System or ALM repository to add to the Toolbox pane.

This is useful for retrieving activities that you removed from the Toolbox using the
Remove Activities command.

Remove Activities. Opens the Remove Toolbox Activities dialog box for selecting
the activities to remove from the Toolbox pane.

Note:

l Removing an activity stored in the repository, only removes it from the
Toolbox pane. It remains, however, in the repository, for future use.

l This command does not apply toStandard Activities.
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Tree
Elements

Description

Update WSDL. Reimports theWSDL from its original location. If the service's
operations changed, this will be reflected in its node in the Toolbox pane.

Note: Only available when selecting the parent node of aWeb service.

Update
WSDL
from

Opens the UpdateWSDL From dialog box, allowing you to update theWSDL from
any location.

Note: Only available when selecting the parent node of aWeb service.

Refresh. Refreshes the activities in their stored location. This is useful when the
WSDL is stored on a shared location andmay have beenmodified by another user.
You can refresh the activities instead of re-importing the service.

Note: Only available when selecting the parent node of aWeb service.

Delete. Deletes the selected entry from the Toolbox pane. This is not available for
built-in activities.

Validate WSI-Compliance. Runs theWSI validator. TheOutput pane shows a
summary of the validation and provides a path to the report.

Note: Only available when selecting the parent node of aWeb service.

Edit Service. Opens the "Add/Edit REST Service Dialog Box" (described on 495).

Note: Only available when selecting the parent node of a REST service.

Move to Move to. An expandablemenu that enables you tomove an item to the file system
or ALM repository. For details, see "Activity Sharing" on page 466.

Note: Only available when selecting the parent node of an item in the Local
Activities section.

Filter
box

Filters the Toolbox pane display by the entered text.

Toolbox Activities
The Toolbox pane contains the following sections:
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Activity
Category

Description

Local
Activities

A tree hierarchy of all imported or items created by the user:Web Services, REST
Services, and .NET Assemblies. For details, see "Local Activities" on page 463.

Standard
Activities

The built-in activities, by category. For details, see "Standard Activities" on page
396.

File
System
Activities

Local activities that weremoved to the file system repository using theMove to
option from the right-click menu. For details, see "Activity Sharing" on page 466.

ALM
Activities

Local activities that weremoved to the ALM repository using theMove to option
from the right-click menu. For details, see "Activity Sharing" on page 466.

Recently
Used
Items

The activities or operations that were usedmost recently.
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Part 3: Service Test Configuration
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Chapter 16: Service Test Global Options
This chapter includes:

Concepts 263

Global Options - Overview 263

Reference 264

General Tab (Options Dialog Box) 264

API Testing Tab (Options Dialog Box) 271

Coding Tab (Options Dialog Box) 277

Text Editor Tab (Options Dialog Box) 279

HP Service Test (11.52)Page 262 of 705



Concepts

Global Options - Overview
TheOptions dialog box enables you tomodify the general appearance and behavior of Service Test.
For example, you can define the user interface language, set startup options, or modify the font and
colors of code elements in the Editor. The values you set remain in effect for all documents and for
subsequent testing sessions.

Note: TheRestore Factory Defaults button resets all Options dialog box options to their
defaults.

For user interface details, see:

l "General Tab (Options Dialog Box)" on next page

l "API Testing Tab (Options Dialog Box)" on page 271

l "Coding Tab (Options Dialog Box)" on page 277

l "Text Editor Tab (Options Dialog Box)" on page 279
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Reference

General Tab (Options Dialog Box)
This tab enables you to define general options for Service Test.

To access Select Tools > Options > General tab.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

See also l "API Testing Tab (Options Dialog Box)" (described on page 271

l "Coding Tab (Options Dialog Box)" (described on 277)

l "Text Editor Tab (Options Dialog Box)" (described on 279)

This tab includes the following panes:

Startup Options (Options Dialog Box > General Tab) 264

Run Sessions Pane (Options Dialog Box > General Tab) 265

Output Pane (Options Dialog Box > General Tab) 270

Startup Options (Options Dialog Box > General Tab)

This pane enables you to select what to show when Service Test opens.
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To access Select Tools > Options > General tab > Startup Options node.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

Relevant tasks "How to Start Service Test" on page 48

See also l "Start Page" on page 51

User interface elements are described below:

UI Element Description

Display Start Page on
startup

Displays the Start Page when Service Test opens.

Close Start Page after
test loads

Instructs Service Test to close the Start Page after a test or business
component is created or opened.

Default test location The default place to save a new test.

Default: C:\My Documents\Service Test

Note: Business components are always saved in the Business
Components module in ALM.

Run Sessions Pane (Options Dialog Box > General Tab)

This pane enables you to determine global Service Test run settings.
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To access Select Tools > Options > General tab > Run Sessions node.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

Relevant tasks See the following tasks in theHP RunResults Viewer User Guide:

l How toOpen RunResults

l How to Export Run Results)

See also The following topics in theHP RunResults Viewer User Guide:

l The RunResults Viewer overview

l The section on the Run Results Viewer User Interface

User interface elements are described below:

UI Element Description

View results
when run
session ends

Instructs Service Test to open the Run Results Viewer and display the results
automatically following the run session.

Automatically
export run
results when
run session
ends

Instructs Service Test to export the run results to the location you specify in the
"Configure Automatic Export of Run Results Dialog Box" (described on 267).

Note: If this option is selected, and the Run Results Viewer is not installed
on the computer running the test or component, then the results are not
exported and an error message is displayed at the end of the run session.

Configure Opens the "Configure Automatic Export of Run Results Dialog Box" (described
on 267), in which you can define settings that instruct Service Test to
automatically export run results to a specific folder in the file system after a run
session. These settings specify the type of report, the export location in the file
system, and whether to export all run results or only results for failed run
sessions.
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UI Element Description

Stop
command
shortcut key

Enables you to define a shortcut key or key combination that stops the current
record (for GUI tests only) or run operation, even if Service Test is not in focus
or is in hiddenmode.

Click in the field and then press the required key or key combination on the
keyboard.

The default key combination is CTRL+ALT+F5.

Note: It is important to define a shortcut that is not already defined for
some other operation by application being tested. If this is the case and:

l you open the applicationmanually before you click Record orRun, the
shortcut defined in the application is applied for its original purpose.

l you start a record or run session and Service Test opens the application
for you, the shortcut you define stops the session.

Configure Automatic Export of Run Results Dialog Box

This dialog box enables you to define settings that instruct Service Test to automatically export run
results to a specific folder in the file system after a run session.
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To access 1. Select Tools > Options > General tab > Run Sessions node to open the
Run Sessions pane.

2. Select Automatically export run results when run session ends.

3. Click theConfigure button.

Important
information

l Manually exporting run results. You can also export run results manually
after a particular run session. For details, see the section on how to export run
results (described in theHP RunResults Viewer User Guide).

l Note: Not all options are relevant for Service Test tests.

l The settings from this dialog box are saved in a configuration file,
ReportExportOption.xml.

User interface elements are described below:
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UI
Element

Description

Step
Details

Themain report type. This includes the entire run results tree. (Default)

l Export type. The file type for the exported results. Possible options:

n HTML (Default)

n PDF

l Export format. The format and amount of detail to include in the exported
results. Possible options:

n Short. Exports a summary line (when available) for each item in the run
results tree. The short report does not include still images associated with the
steps in your run results. (Default)

n Detailed. Exports all available information for each item in the run results
tree. The detailed report includes still images associated with the steps in
your run results. (In the Run Results Viewer, these images are displayed in
the Captured Data pane.)

n User-defined XSL. Enables you to browse to and select a customized .xsl
file. You can create a customized .xsl file that specifies the information to
be included in the exported report, and the way it should appear. For details,
see the section on the Run Results XML File (described in theHP Run
Results Viewer User Guide).

Screen
Recorder

Not relevant for Service Test.

Data
Table

The runtime version of the data table associated with your ALM configuration. It
displays the values used to run a test or configuration that contains Data Table
parameters, as well as any output values retrieved from a test or an ALM
configuration during a run session.

For details on the Data pane, see "Data Pane" on page 96.

Log
Tracking

Not relevant for Service Test.

System
Monitor

Not relevant for Service Test.

Export
location

The folder in which to store the exported files. Clicking the browse button opens the
Browse For Folder dialog box, enabling you to select a folder on the file system.

If you do not specify a folder, Service Test automatically exports the files to the
default folder: <test folder>\<result folder>\Report. (For example,
%ProgramFiles%\HP\Service Test\Tests\MyTest\Res9\Report.)
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UI
Element

Description

Export
run
results
only if the
run
session
fails

l Select this check box to export run results only for failed run sessions.

l Clear this check box to export all run session results.

Service Test stores the export options in the ReportExportOption.xml file in the
%AppData%\Roaming\Hewlett-Packard\STUFT\ConfigurationUI folder. This file is
useful when using the Test Batch Runner from the command line. For details, see "How to Run a
Test Batch Using theWindows Command Line" on page 294.

Output Pane (Options Dialog Box > General Tab)

This pane enables you to define display options for the Output pane.

To access Select Tools > Options > General tab > Output Pane node.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

See also l "Output PaneOverview" on page 180

l "Output Pane User Interface" on page 181

User interface elements are described below (unlabeled elements are shown in angle brackets):
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UI Element Description

Word wrap When selected, wraps the text of eachmessage onto the next line.

Text Font The font in which to display the content of the Output pane.

Size The size in which to display the text in the Output pane.

<preview
area>

Shows an example of the formatting selected in the Text Font andSize drop-
down lists.

API Testing Tab (Options Dialog Box)
The options in the API Testing tab of the Options dialog box enable you to customize your work
environment when working with Service Test tests or components. For example, you can define
relative or absolute paths for saved files, repository locations, and auto values.

To access Select Tools > Options > API Testing tab.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

See also l "General Tab (Options Dialog Box)" on page 264

l "Coding Tab (Options Dialog Box)" on page 277

l "Text Editor Tab (Options Dialog Box)" on page 279

This tab includes the following panes:

General Pane (Options Dialog Box > API Testing Tab) 271

Auto Values Pane (Options Dialog Box > API Testing Tab) 274

SAP Connections Pane (Options Dialog Box > API Testing Tab) 275

General Pane (Options Dialog Box > API Testing Tab)

This pane enables you to set the test executionmode, the default location for importingWSDL files,
and the repository locations for activity sharing.
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To access Select Tools > Options > API Testing tab > General node.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

See also "Auto Values Pane (Options Dialog Box > API Testing Tab)" on page 274

User interface elements are described below:

UI Element Description

Compile as Themode for a run session. Options includeDebug orRelease.

Select theRelease option for faster run sessions. Run sessions performed
with theDebug option runmore slowly and generate additional information
in the Output pane.

Use relative
paths to call
assets

Instructs Service Test to use relative paths for all steps that require a path
or file name.
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UI Element Description

Run test in
debugging mode

Runs a test with debugging capabilities active.

By default, tests run without any of the debugging capabilities, enabling
them to run faster. If you check this option, it activates the debugging
capabilities during a test run, slowing the speed of a test run.

Number of items
to show in WSDL
import history

Specifies themaximum number of WSDL addresses to display in the
address drop down list of the "Import/UpdateWSDL from URL or UDDI
Dialog Box" (described on 489).

Default: 10

Default page for
WSDL browser

The default Web page that opens when you click theBrowse button in the
"Import/UpdateWSDL from URL or UDDI Dialog Box" (described on 489).

Shows encrypted
passwords in the
Output pane

Displays passwords used in a test or component in the information
displayed in the Output pane in an unencrypted form.

Activity
Repositories

Displays the locations for activity repositories:

l File system path. The folder in the file system in which to store
activities.

l ALM path. The path in the ALM repository in which to store activities.

Tip:

l Click theBrowse button to select a location.

l Tomove an activity to a repository so that it can be used in
subsequent tests, right-click the parent node and selectMove to.

Note: Youmust be connected to ALM to set theALM activities path
location (select ALM > ALM Connection).

Number of
records to show
in query preview

Sets themaximum number of strings for:

l TheQuery Preview window (accessible by clicking theCheck SQL
Statement button in the "Set SQL Statement Page " (described on page
103).

l A database source in the Data Pane

Default: 10

Database
connection
timeout

The number of seconds to wait without a successful connection to a
database before timing out the connection.

Default: 30
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Auto Values Pane (Options Dialog Box > API Testing Tab)

This pane enables you to provide default values for populating activity properties.

To access Select Tools > Options > API Testing tab > Auto-values node.

Important
information

l TheRestore Factory Defaults button resets all Options dialog box options to
their defaults.

l To assign an auto value to a property, select Set Auto-value from the right-
click menu in theValue column of the Properties pane.

l To set values for an array of properties, select the parent node.

See also "General Tab (Options Dialog Box)" on page 264

User interface elements are described below:

UI Element Description

String The default value to use for a property defined as a string.

Default: abcd.

Date/time The default value to use for a property requiring a time and date.

Default: long notation of the current time and date.
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UI Element Description

Boolean The default value to use for a property defined as boolean: True or False.

Default: False.

Integer The default value to use for a property defined as integer.

Default: 1,234.

Long The default value to use for a property defined as Long.

Default: 1,234.

Float The default value to use for a property defined as Float.

Default: 12.300000.

Decimal The default value to use for a property defined as decimal.

Default: 12.340000.

Double The default value to use for a property defined as double.

Default: 12.340000.

SAP Connections Pane (Options Dialog Box > API Testing Tab)

This pane enables you tomanage SAP connections. You can add and remove connections, add
authentication information, and check the connection.
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To access Select Tools > Options > API Testing tab > SAP Connections node.

Important
information

l TheRestore Factory Defaults button resets all Options dialog box options to
their defaults.

l To define a connection, youmust have the 32-bit version of SAP .NET
Connector installed on your machine. The installation is available on the SAP
Help portal, at http://help.sap.com/saphelp_
NW04/helpdata/en/e9/23c80d66d08c4c8c044a3ea11ca90f/content.htm.

Relevant
tasks

"How to Create an SAP Test Step" on page 485

See also "Local Activity Overview" on page 464

User interface elements are described below:

UI Element Description

Add Connection. Adds a new editable entry to the list of connections.

Delete Connection. Deletes the selected connection.

Move up.Moves the selection up on the connection list.

Move down.Moves the selection down in the connection list.

Import. Allows you to import a saplogon and connection file (.ini or .xml)
with the connection settings information.

Export. Allows you to export the connection settings to an XML file.

Ping Connection. Tests the selected connection and inserts the date and
time in the Last Pinged column.

<SAP
connection
list>

Displays information about the current connection:

l Name. The connection's name.

l Application Server. The URL or IP of the application server.

l System Number. The value of the SAP system number.

l Client. The type of client.

l Username/Password. The authentication information.

l Description. A description of the connection.

l Last Pinged. The date and time that a ping request was issued to the
server.
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Coding Tab (Options Dialog Box)
This tab enables you to set options that facilitate designing code.

To access Select Tools > Options > Coding tab.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

See also l "General Tab (Options Dialog Box)" on page 264

l "API Testing Tab (Options Dialog Box)" on page 271

l "Text Editor Tab (Options Dialog Box)" on page 279

This tab includes the following pane:

Code Templates Pane (Options Dialog Box > Coding Tab) 277

Code Templates Pane (Options Dialog Box > Coding Tab)

This pane enables you to create and edit templates of pre-designed code snippets or blocks of text
used for automatic code completion. You can create different lists of templates for different file
types.

To access Select Tools > Options > Coding tab > Code Templates node.
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Important
information

l TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

l You can edit the names, keywords, descriptions, and code snippets of any
template defined in this pane.

l Service Test provides default file types and snippets. You can add
additional lists of file types and snippets as needed.

Relevant
tasks

"How to Use Code Snippets and Templates" on page 139

See also "Automatic Code Completion" on page 135

User interface elements are described below:

UI Element Description

File types The file types for which the displayed list of templates is used.

Select an item from the drop-down list to display the templates associated with
the selected file extensions.

Default options include:

l .vb files .

l .cs files

Add List Adds a new list of templates and the file types for which to use them.

A new item is added to the File types drop-down list.

Remove
List

Removes the currently displayed list of templates and the associated File types
item.

Caution: Deleting a list is irreversible.

Edit List Enables you to edit the file extensions associated with the displayed list of
templates.

Template The name of the template.

Keyword The keywords that trigger the use of the template when invoking code completion
in files of the selected types.

Description A string that describes the code snippet.

<code
snippet>

The code that is inserted into your code file. The snippet can include text that is
inserted as is, as well as variables (prefaced by a dollar sign $) that are replaced
with actual values when they are inserted into the code file.

Tip: To edit the code snippet, modify the text in this area and click another
template row orOK.
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Text Editor Tab (Options Dialog Box)
This tab enables you to set options for editing text and code files.

To access Select Tools > Options > Text Editor tab.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

See also l "General Tab (Options Dialog Box)" on page 264

l "API Testing Tab (Options Dialog Box)" on page 271

l "Coding Tab (Options Dialog Box)" on page 277

This tab includes the following panes:

General Pane (Options Dialog Box > Text Editor Tab) 279

Fonts and Colors Pane (Options Dialog Box > Text Editor Tab) 280

General Pane (Options Dialog Box > Text Editor Tab)

This pane enables you to set general preferences for editing code and text files.

To access Select Tools > Options > Text Editor tab > General node.
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Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

See also l "Editing Text and Code Documents" on page 133

l "Editor User Interface" on page 147

User interface elements are described below:

UI Element Description

Word wrap Wraps lines of code to continue onto subsequent lines without the insertion of a
line break character. If disabled, the line of code continues indefinitely on a
single line until youmanually stop it by pressing theENTER key or entering a
line break character.

Enable
folding

Enables sections of code that are grouped together to be expanded and
collapsed.

Show
class/function
browser

Shows or hides the drop-down lists of classes and functions. These lists are
located at the top of the Editor. Using the browsers, you can navigate to
different classes and functions within your event handler or user code file.

Show line
numbers

Shows or hides the line number to the left of each line of code.

Show hidden
definitions

Shows or hides text and function definitions defined as hidden.

Show All
characters

Displays all SPACE, TAB, and End of Line characters. You can also select
to display only some of these characters by selecting or clearing the relevant
check boxes.

Convert tabs
to spaces

Changes TAB keystrokes in your code to the number of SPACE characters
defined in the Tab spacing option.

Tab spacing The number of characters inserted into a line of code for a TAB character. The
number of characters can range from 1 to 16.
Default: 4

Fonts and Colors Pane (Options Dialog Box > Text Editor Tab)

This pane enables you to specify color preferences for the text you are editing. You can set unique
coloring rules for each code element.
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To access Select Tools > Options > Text Editor tab > Fonts and Colors node.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

The options in this pane apply only to documents in the Editor.

See also l "Editing Text and Code Documents" on page 133

l "Editor User Interface" on page 147

User interface elements are described below:

UI
Element

Description

Font The font name and size to use for all elements. The Default is Consolas, 10 points.

Note:When testing in a Unicode environment, youmust select a Unicode-
compatible font. Otherwise, elements in your user code file may not be correctly
displayed in the document window. However, the test or component still runs in
the sameway, regardless of the font you choose. If you are working in an
environment that is not Unicode-compatible, youmay prefer to choose a fixed-
width font, such as Courier, to ensure better character alignment.
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UI
Element

Description

Syntax
Coloring

The language or languages whose appearance you want to customize.

Available options:

l All languages

l C#

l XML

The box below your selection displays all of the elements for which you can configure
color and style settings.

You canmodify the Foreground andBackground colors for a selected element.
You can alsomodify theStyle (Bold or Italic), if enabled.

Preview An example of the text element according to your selections above.

Reset Resets all colors and styles to default settings.
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Part 4: Service Test Running and
Debugging Operations
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Chapter 17: Running Tests and Components
This chapter includes:

Concepts 285

Running API Tests - Overview 285

Server-Side Execution 285

Test Batch Runner Overview 286

Tasks 288

How to Run an API Test 288

How to Perform Server-Side Execution 290

How to Create and Run a Test Batch 292

How to Run a Test Batch Using theWindows Command Line 294

Reference 296

Run Dialog Box 296

Select AUT Parameter Dialog Box 299

Test Batch RunnerWindow 301

Test Batch Runner Menu Commands 303

Troubleshooting and Limitations - Run Sessions 305
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Concepts

Running API Tests - Overview
You can run tests directly from the Service Test interface or from the command line. The test run
enables you to determine if the activities are functional and if they are performing as expected.

Before running the test, you can select a location in which to store the results, and set input
parameter values specifically for this test run. For details, see "Run Dialog Box" on page 296.

For details about the command line, see "Command Line Syntax" on page 597.

The Run Results Viewer provides a detailed report about each step and its checkpoints.

When you run custom code from the user interface, you can also use breakpoints and other tools to
debug your code.

Using the Options dialog box, you can set the run configuration—Debug orRelease. TheRelease
mode is more efficient, and is recommended for Load Testing. For details, see "General Pane
(Options Dialog Box > API Testing Tab)" on page 271.

When a test step fails, Service Test continues to run the other test steps. The exception to this is if
you enabled theStop test if checkpoint fails option and the checkpoint failed. For details, see
"Input/Checkpoints/Output Properties Tab (Properties Pane)" on page 201.

ForWeb Service steps, you can validate the SOAP response against a schema orWS-I standards.
For details, see "Input/Checkpoints/Output Properties Tab (Properties Pane)" on page 201.

Server-Side Execution
Whenworking with tests saved on an ALM server with LabManagement enabled, you can run tests
in server-side execution.

In server-side execution, you run tests on remote host machines at predefined times or on an ad-
hoc basis, not requiring anyone to be logged in to the host to initiate and control the test runs.

In client-side execution, although the test is stored on ALM, it runs on themachine running Service
Test, and requires someone to be logged in to that machine.

You set up server-side execution on ALM:

First create functional test sets in ALM's Test Lab module. A functional test set is a group of
automated tests or test configurations in an ALM project, designed to achieve a specific goal.

Next, using ALM's Lab Resources > Testing Hostsmodule, you indicate the hosts upon which
the tests and can run remotely.

Finally, in the ALM's Timeslotsmodule, you schedule the test runs. If you are running the tests ad-
hoc, you do not need to set a timeslot.

You can also link your test parameters to ALM AUT Environment parameters, which are then used
when running the tests using Server-Side execution. For details, see "AUT Environment
Parameters" on next page.
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Note: Server-side execution is available only for ALM Edition and Performance Center Edition,
version 11.50 or later.

For task details, see "How to Perform Server-Side Execution" on page 290.

For additional information, see theHP Application Lifecycle Management User Guide.

AUT Environment Parameters

When performing server-side execution, you can use parameters from an ALM AUT Environment.

When defining test parameters, you can link them to parameters defined in a specific AUT
environment in ALM. All of the AUT parameters that you usemust be from the same ALM
AUT environment.

In the Properties pane, an ALM icon next to a parameter's default value indicates that it is an
AUT parameter.

When the test runs in server-side execution, it uses the values provided by ALM for the
corresponding AUT environment parameter.

When the test runs from Service Test, the test uses the parameters' default values.

If you save the test to the file system, the links to the AUT parameters are removed, and the test
parameters become ordinary parameters. The default values remain defined.

For task details on linking test parameters to ALM AUT environment parameters, see "How to
Perform Server-Side Execution" on page 290.

What happens if the ALM AUT parameters linked to the Service Test test
parameters are deleted from ALM?
l If you open a test with test parameters that are linked to deleted ALM AUT parameters, the links

remain unchanged.

l If you run a test with test parameters linked to deleted ALM AUT parameters, the test will fail to
run.

Test Batch Runner Overview
Test Batch Runner enables you to run tests in a collective, successive test run. Tests are run
individually but sequentially in a single session.

You can use Test Batch Runner only on tests stored on the file system. You cannot use Test Batch
Runner for tests stored in ALM.
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Using Test Batch Runner, you create a list of tests and save the list as a batch .mtb file, so that
you can run the same batch of tests again at another time. You can choose to include or exclude a
test in your batch list from running during a particular batch run without affecting the other tests in
the batch.

You can add tests individually to Test Batch Runner by navigating to the folder in which the test is
located. Test batches can also be added to another test batch by adding an .mtb test batch file to
a new test batch. When Test Batch Runner opens, it checks tomake sure that all tests within a test
batch exist.

When running the test batch, the Output pane allows you view the results of the test run in run time.
During the test batch run, the Output pane displays the test's path in the file system, the progress of
the test, as well as any errors that occur during the run.

Following the test batch run, the results are saved to a run results file including whether the test
passed or failed and errors in running the test. TheReport column of the Tests pane displays a link
to the run results file.

If you do not want to run the test batch through the Test Batch Runner interface, you can run the
Test Batch Runner from theWindows Command Line. You provide the location of a .mtb file, a
test folder, or a directory of tests as a command argument and Test Batch Runner runs the test
batch and displays the run results.

Tip: Using the command line options of the Test Batch Runner, you can include Service Test
tests in as part of build runs in a continuous integration system.
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Tasks

How to Run an API Test
This task describes how to run a test through the user interface and view its results.

For details on running a test through the command line, see "Command Line Syntax" on page 597.

This task includes the following steps:

l "Add new tests to a solution - optional" below

l "Set values for the test variables - optional" below

l "Configure checkpoints" below

l "Save the test in ALM - optional" on next page

l "Add external references - optional" on next page

l "Set the number of iterations" on next page

l "Select a location for the run results - optional" on next page

l "Set runtime property values - optional" on page 290

l "Validate the structure of the SOAP response " on page 290

l "Run the test" on page 290

l "Debug the test - optional " on page 290

l "Analyze the Results" on page 290

1. Add new tests to a solution - optional
To addmore tests to the solution, select File > Add > New Test or File > Add > Existing
Test. To add tests to an ALM repository, first connect to the ALM server. For details, see "ALM
Connection Dialog Box" on page 335.

Service Test adds the test to the Solution Explorer pane.

For user interface details, see the "Add Test/Component to Solution Dialog Box" on page 64 or
"Add <Existing Document> to Solution Dialog Box" on page 63

2. Set values for the test variables - optional
Select the test properties or user/system variables. For details, see "How to Define Test
Properties or User/System Variables" on page 59.

3. Configure checkpoints
Checkpoints let you validate the results. For details, see "Checkpoint Validation" on page 585.

To add checkpoints, do the following:

a. Click the Input/Checkpoints tab . By default, the pane displays theXML tab. Provide
an expected value for each row in one of the following ways:
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o Manually

o Select Link Source dialog box .

o Load from replay button .

b. Select a comparison operator, such as =, >, or Regex. Thesemay differ depending on the
data type.

c. Select theValidate check boxes in the rows of the properties that you want to validate.
Clear the check boxes for the properties you are not validating.

d. Set checkpoints for array elements. For details, see "How to Set Array Checkpoints" on
page 589:

e. To validate against an XPath expression, click theXPath tab and provide the expression.
For details, see "How to Set XPath Checkpoints" on page 592:

f. To halt the test run if the response does not return the expected value select Stop test if
checkpoint fails.

Tip: You can customize and override the checkpoint settings using an event handler.
For details, see "How toWrite Checkpoint Events" on page 651.

For user interface details, see the "Input/Checkpoints/Output Properties Tab (Properties
Pane)" on page 201.

For details on how to work with array checkpoints, see "How to Set Array Checkpoints" on
page 589.

4. Save the test in ALM - optional
To save results in ALM, you need to first save the actual test in ALM. Connect to ALM and then
select File > Save as.

5. Add external references - optional
You can add one or more references to your test.

a. Open the Solution Explorer pane.

b. Expand the test's tree and select theReferences node.

c. Select Add Reference from the context menu.

d. Specify an external .dll file as a reference.

For details, see the "Add Reference Dialog Box" on page 245.

6. Set the number of iterations

Click in the Test Flow or Loop box and select the Input/Checkpoints tab . Set the number
of iterations in the Properties pane. For details, see "Input/Checkpoints/Output Properties Tab
(Properties Pane)" on page 201.

7. Select a location for the run results - optional
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Tip: To run a test bypassing the Run dialog box, select Run > Run Now.

a. Click theRun button on the toolbar and select theResults Location tab.

b. For tests saved on the File System, select a location in which to store the run results—
New run results folder or Temporary run results folder. Choose the latter if you do not
expect to use and analyze the results. For details, see "Run Dialog Box" on page 296.

c. For tests saved in ALM, specify a run name. If relevant, select a Test Set and Instance.

8. Set runtime property values - optional
In the Run dialog box, click the Input Parameters tab and set the values that you want the run
session to use for the listed properties.

9. Validate the structure of the SOAP response
ForWeb Service steps, you can instruct Service Test to validate the SOAP response against
the schema orWS-I standards. Set the desired validations in the bottom of the Checkpoints
area. For details, see the "Input/Checkpoints/Output Properties Tab (Properties Pane)" on
page 201.

10. Run the test
Click theOK button in the Run dialog box.

11. Debug the test - optional
By default, Service Test runs tests in releasemode—not debuggingmode. This allows the test
to runmuch quicker. To run the test in debuggingmode, which also allows you to pause the
test during its run, you need to enable it in the Options dialog box. For details, see "General
Pane (Options Dialog Box > API Testing Tab)" on page 271.

In debuggingmode, select Run > Pause to stop the test run at any point. Use the debug panes
to solve any runtime issues. For user interface details, see the or "Debug Panes" on page 110.

12. Analyze the Results
View the results in the Run Results Viewer. The Run Results Viewer opens automatically after
a test run.

n A green check mark indicates success.

n A redXmark indicates a failure in one of the steps. Expand the nodes of the report to view
details about each step and checkpoint.

To view the report at a later stage, select View > Last Run Results.

To prevent the Results viewer from opening, select Tools > Options > General tab >
General node. Clear the View results when run session ends option.

How to Perform Server-Side Execution
This task describes how to run a test through server-side execution.

For an overview, see "Server-Side Execution " on page 285.

This task includes the following steps:
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l "Create tests and save them in ALM" below

l "Create test sets" below

l "Select AUT Parameters - optional" below

l "Set up the hosts" on next page

l "Schedule the tests - optional" on next page

l "Run the tests" on next page

1. Create tests and save them in ALM
Create your tests and save them to ALM. Make sure to connect to a project with Lab
Management support. For details on connecting to ALM, see "ALM Connection Dialog Box" on
page 335.

2. Create test sets
a. Open ALM's Testing > Test Labmodule.

b. Select Test Sets > New Test Set. Create a functional type test set and specify the
required information. Click OK.

c. Select theExecution Grid tab and click Select Tests.

d. In the Test Plan tree, select the tests you want to add to the test set.

3. Select AUT Parameters - optional
To use property values from value sets stored in ALM:

a. In ALM's LabManagement, open the Lab Resources > AUT Environmentsmodule.
Define an AUT environment with parameters. Set the desired values. For details, see the
HP Application Lifecycle Management User Guide.

b. In Service Test, open the Properties pane to the test parameters tab:

Do one of the following:

o Open an API test, select theStart orEnd steps in the canvas, and open the Properties
pane. Then select the Test Input/Output Properties tab .

o Select a GUI test in the solution explorer. Open the Properties pane, and select the
Parameters tab .

c. Click Add > Add Input Parameter.

d. In the Add Input Parameter dialog box that opens, click theSelect ALM application

parameters button .

e. In the Select AUT Parameter dialog box that opens, expand theAUT Environment node
and select a parameter. Click OK. For details, see "Select AUT Parameter Dialog Box" on
page 299.

f. In the Add Input Parameter dialog box, provide a name for the parameter and set the default
value, if necessary. Click OK. In the Properties pane, an ALM icon next to a
parameter's default value indicates that it is an AUT parameter.
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g. To edit the parameters, click theEdit Parameter button in the Properties pane.

h. To change the parameter to an ordinary parameter, without a linkage to an AUT

environment, click theRemove link to ALM application parameters button in the
Edit Parameter dialog box .

You can repeat these steps to add additional test parameters and link them to ALM
AUT parameters, but all of the AUT parameters that you usemust be from the same ALM
AUT environment.

For more details, see "AUT Environment Parameters" on page 286.

4. Set up the hosts
In the Lab Resources > Testing Hostsmodule, select host machines. You can define a
purpose for the host, such as Service Test. For details, see theHP Application Lifecycle
Management User Guide.

5. Schedule the tests - optional
In the Testing > Timeslotsmodule, schedule the run times. If you are running the tests ad-
hoc, you can skip this step.

6. Run the tests
Run the tests from the Tests Labmodule. For details, see theHP Application Lifecycle
Management User Guide.

How to Create and Run a Test Batch
This task explains how to create and run a test batch using Test Batch Runner.

This task includes the following steps:

l "Open Test Batch Runner" below

l "Access the test batch file" on next page

l "Add batches or tests" on next page

l "Select the tests to be part of the test batch run" on page 294

l "Run the test batch" on page 294

l "View the test batch run results" on page 294

1. Open Test Batch Runner
Select Start > All Programs > HP Software > HP Service Test > Tools > Test Batch
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Runner. This opens a separate window for the Test Batch Runner program.

Note:

n You do not need to have Service Test open to use Test Batch Runner.

n For details on accessing Service Test tools and files inWindows 8, see "Accessing
Service Test inWindows 8Operating Systems" on page 33.

2. Access the test batch file

n To create a new test batch file, select File > New or click theNew batch file button .
Give your batch file ameaningful name and assign it to a place in your directory.

n To open an existing batch file, select File > Open or click theOpen batch file button .
In the Open dialog box, navigate to the folder in which the batch file is found and click Open.
The tests from the opened batch file are added to the Test Batch Runner main window.

3. Add batches or tests

n To add a test batch file (.mtb), select File > Add or click theAdd button . Navigate to
the folder in which the batch file is saved.

n To add individual tests, select Tests > Add or click theAdd button . In theBrowse
For Folder dialog box, select the folder in which your tests are located. All the tests from
the selected folder are added to the Tests pane in themain Test Batch Runner window.

Note:When adding tests through the Tests > Add menu command, youmust select
all the tests from the target folder. If you do not want to run all the tests in the target
folder, select the check boxes next to the tests you want to run before you run the test
batch.
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4. Select the tests to be part of the test batch run
Select the checkboxes for the tests that you want to include in the test batch run.

5. Run the test batch

Click theRun button to run the test batch. TheOutput pane provides run log details of the
batch run while the batch is running.

6. View the test batch run results
In the Tests pane, click the results link for a specific test in theRun Results column. This
opens the results for that test in the Run Results Viewer. For details on the Run Results
Viewer, click F1 within the viewer window.

How to Run a Test Batch Using the Windows Command
Line

This task describes how to run a test using theWindows Command Line.

This task includes the following steps:

l "Open theWindows Command Line window" below

l "Provide the source folder for the batch file or tests" below

l "Run the test batch" below

l "View the test batch run results" below

1. Open the Windows Command Line window
Run cmd.exe to open the Command Line window. (For example, from theWindows Run
dialog box.)

2. Provide the source folder for the batch file or tests
In the Command Line window, enter UFTBatchRunnerCMD.exe and the source switch
followed by the test batch file (.mtb) or folder containing the test.

For example, your command linemight contain text like this:

UFTBatchRunnerCMD.exe -source "C:\users\MySample.mtb"

UFTBatchRunnerCMD.exe -source "C:\users\APITest1"

3. Run the test batch
After entering the Test Batch Runner command and the location of the folder containing your
tests, press ENTER. Test Batch Runner runs the test batch.The test log is displayed in the
commandwindow.

4. View the test batch run results
When the test batch run is complete:

a. Open the Run Results Viewer from the Start menu. TheOpen RunResults dialog box
opens.
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Note: For details on accessing Service Test tools and files inWindows 8, see
"Accessing Service Test inWindows 8Operating Systems" on page 33.

b. In the Open RunResults dialog box, select theResults XML file option.

c. Navigate to the Results.xml file under the test's Report folder and click Open.

Each test has its own results. For details, see theHP RunResults Viewer User Guide.
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Reference

Run Dialog Box
This dialog box lets you prepare for the test run by selecting the test to run and providing a location
for the results.

To access 1. Do one of the following:

n Ensure that a test or component is in focus in the document pane.

n In the Solution Explorer, select a test or component node.

2. Select the following:

n Click theRun button or select Run > Run.
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Important
information
(for tests)

l When the test stops running, the Run Results Viewer opens unless you have
cleared theView results when test run ends check box in theRun
Sessions pane of the Options dialog box (Tools > Options > General tab >
Run Sessions node). For details, see "Run Sessions Pane (Options Dialog
Box > General Tab)" on page 265.

l You can report defects to an ALM project either automatically as they occur, or
manually directly from the Run Results Viewer. For details, see the online help
in the Run Results Viewer.

Relevant
tasks

"How to Run an API Test" on page 288

User interface elements are described below:

UI Elements Description

Test Name The test or component to run. You can select any open item from the drop-down
list.

Results
Location

The target location for the results, as specified in theResults Location tab.

Options Expands or collapses the dialog box to show theResults Location and Input
Parameters tabs.

Run Begins the run session.

Run Dialog Box: Results Location Tab (For Tests Stored on File System)
This tab enables you to specify where to save run results when running tests stored on the file
system.

User interface elements are described below:

UI
Elements

Description

New run
results
folder

An area allowing you to indicate the results location.

The area displays the default path and folder name in which the results are saved.
A new folder is created for each run. By default, results are stored in the following
locations:

l For tests: The test folder

l For components:An ALM cache folder on your computer
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UI
Elements

Description

Temporary
run results
folder

Saves the run results in a temporary folder. This option overwrites any results
previously saved in this folder.

Note:

l The path in the text box of the Temporary run results folder option
cannot be changed. Additionally, if you save results to an existing results
folder, the contents of the folder are deleted when the run session starts.

l Service Test stores temporary results in %TMP%\TempResults (which is
usually <System Drive>\Documents and Settings\<user

name>\Local Settings\Temp\TempResults).

Run Dialog Box: Results Location Tab (For Tests Stored in ALM)
This tab enables you to specify where to save run results when running tests stored in ALM.

User interface elements are described below:

UI
Elements

Description

New run
results in
ALM
project

l Project name. Displays the ALM project to which you are currently connected.

l Run name. The name of the run. You can accept the automatically generated
name or enter a different one.

l Test set. A group of tests selected to achieve specific testing goals. For
example, you can create a test set that tests the user interface of the
application or the application's performance under stress. (You define test sets
when working in the ALM test runmode. For details, see your ALM
documentation.)

l Instance. The instance of the test in the test set. If there is more than one
instance, select the instance of the test for which you want to save the results.

Temporary
run results
folder

Saves the run results in a temporary folder. This option overwrites any results
previously saved in this folder.

Note:

l The path in the text box of the Temporary run results folder option
cannot be changed. Additionally, if you save results to an existing results
folder, the contents of the folder are deleted when the run session starts.

l Service Test stores temporary results in %TMP%\TempResults (which is
usually <System Drive>\Documents and Settings\<user

name>\Local Settings\Temp\TempResults)
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Run Dialog Box: Input Parameters Tab
This tab enables you to specify to specify the run-time values of input parameters to be used during
the run session.

User interface elements are described below:

UI
Elements

Description

Input
parameters

The input parameters that were defined for the test or component.

To set the value of a parameter to be used during the run session:

Click in theValue field for the specific parameter and enter the value, or select a
value from the list. If you do not enter a value, it uses the default value from the
Test Settings or Business Component Settings dialog box during the run session.

Select AUT Parameter Dialog Box
This dialog box lets you select an AUT parameter stored in ALM's Lab Resources > AUT
Environmentmodule in ALM LabManagement and link it to a test parameter.
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To access 1. Open a test stored on an ALM server with LabManagement.

Do one of the following:

n Open an API test, select theStart orEnd step in the canvas, and open the
Properties pane. Then select the Test Input/Output Properties tab .

n Select a GUI test in the solution explorer. Open the Properties pane, and
select the Parameters tab .

2. Click Add > Add Input Parameter or select a parameter and click theEdit

Parameter button .

3. In the Add/Edit Input Parameter dialog box, click .

Note: Available only if Service Test is connected to an ALM server that
has the LabManagement module, and a test stored on that server is
selected in the solution explorer.

Important
information

The AUT parameters are used for Server Side Execution. To set up Server Side
execution, create test sets and schedule the tests using the LabManagement
module. For details, see "Server-Side Execution " on page 285.

Note: All of the AUT parameters that you usemust be from the same ALM
AUT environment.

For details, see theHP Application Lifecycle Management User Guide.

Relevant
tasks

"How to Perform Server-Side Execution" on page 290

See also l "Add Input/Output Parameter for Test Settings" on page 499

User interface elements are described below:

UI Elements Description

AUT
Environments

The list of AUT Parameters environment defined in the Lab Resources >
AUT Environmentmodule.

Expand theAUT Environments node to view the available
AUT environments, and then select an environment to view the available
parameters.

If any test parameter is already linked to an AUT parameter, only the
environment containing that AUT parameter is displayed.

Parameter column The AUT parameter names, grouped in AUT environment configurations.

Value column The value defined for the AUT parameter in ALM.
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UI Elements Description

Copy default
value (override)

Specifies whether to copy the parameter value displayed in this dialog box
into theDefault Value box in the Edit/Add Input Parameter dialog box.

Copying overwrites any Default Value previously defined in the Edit/Add
Input Parameter dialog box. However, after it is copied, you can edit the
Default Valuemanually.

Test Batch Runner Window
The Test Batch Runner enables you to create andmaintain test batch files and add tests to a test
batch file.

To access Select Start > All Programs > HP Software > HP Service Test > Tools >
Test Batch Runner.

Note: For details on accessing Service Test tools and files inWindows 8,
see "Accessing Service Test inWindows 8Operating Systems" on page 33.

Important
information

l You can use Test Batch Runner without having Service Test open.

l Test Batch Runner cannot include tests created in QuickTest 9.2 or earlier or
Service Test 10.00 or earlier.

l The panes within this window can bemoved or pinned. Click on a pane and
drag it to move it to your desired location, or right-click on the title of the pane to
change the options for its display.
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Relevant
tasks

"How to Create and Run a Test Batch" on page 292

See also "Test Batch Runner Menu Commands" on next page

Tests Pane
The user interface elements below describe the columns in the Tests pane.

UI
Element

Description

Checkboxes that enable you to select the tests to include in the current test batch run.

Test The name of the tests or test batches included in the test batch.

Opens the filter window that enables you to group tests and results included in the
batch file.

You can filter the tests by a number of criteria using the drop-downmenus at the
bottom of the filter window. You can usemultiple filters by choosing the combination
argument from themiddle drop-downmenu.

Note: This filter can be used for both the Test, Last Run, andRun Results
columns.

Type Displays the type of test: Service Test (ST) or QuickTest (QTP).

Status Displays the run status of the test:

l Unknown. The test has not been run or its status is unknown.

l Passed.

l Failed.

l Running.

l Error. The test encountered an error when running the test, such as Test Batch
Runner not being able to find the test or a test missing an testing object.

Note: If the status is displayed as Error, hover over the error icon to see a short
description of the error.

Run
Results

The link to the folder in which the results for the test is saved.

Output Pane
TheOutput pane displays the run long of the test batch. This includes information on the test run:

l the test currently running

l the step that is currently running within a test
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l errors encountered during the test run

l the location of the run results.

Note: This area will remain blank unless there is a test batch running or a batch that has
completed running.

Test Batch Runner Menu Commands
Youmanage your test batch and individual tests the File and Testsmenu commands.

File Menu Commands
File menu commands are used to create, update, andmaintain test batch (.mtb) files.

Command Shortcut Key Function

New CTRL+N Creates a new batch file (.mtb).

Open CTRL+O Opens an existing batch file.

Add INSERT Adds a batch file to the current batch.

Save CTRL+S Saves a new batch file.

Save As Enables you to save the batch file under another name.

Exit ALT+F4 Closes Test Batch Runner.

Tests Menu Commands
Test menu commands are used to add andmaintain individual tests within the batch file.

Command Shortcut
key

Function

Add Adds individual tests (not batch files) to the current batch.

Note:When using this command, youmust add all tests from
the selected folder to the batch file.

Remove DEL Removes a test from the batch file.

Run F5 Runs the selected tests in the batch file.

Stop Stops the test batch run.

Test Batch Runner Toolbar
Many of themenu commands are also available by default from the toolbar, shown below:

In addition, the Service Test button is not present in the File or Tests menus. It is described below:
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UI
Element

Description

Use HP Unified Functional Testing license. Instructs Test Batch Runner to use a
Unified Functional Testing license during a batch run. Use this button only if your
batch contains both Service Test andQuickTest tests.

How does it work?

When you click Run (or select Tests > Run), Test Batch Runner instructs
Service Test to use an HP Unified Functional Testing license. If it cannot use the
license type, an error message opens informing you that if your run a test batch with
both Service Test andQuickTest tests, they will fail.

Note: If you click this button and Service Test begins using an HP Unified
Functional Testing license, Service Test will continue to use this license for the
duration of the batch run session. To clear this license, youmust close the Test
Batch Runner.

Test Batch Runner Toolbar
Many of themenu commands are also available by default from the toolbar, shown below:

In addition, the Service Test button is not present in the File or Tests menus. It is described below:

UI
Element

Description

Use HP Unified Functional Testing license. Instructs Test Batch Runner to use a
Unified Functional Testing license during a batch run. Use this button only if your
batch contains both Service Test andQuickTest tests.

How does it work?

When you click Run (or select Tests > Run), Test Batch Runner instructs
Service Test to use an HP Unified Functional Testing license. If it cannot use the
license type, an error message opens informing you that if your run a test batch with
both Service Test andQuickTest tests, they will fail.

Note: If you click this button and Service Test begins using an HP Unified
Functional Testing license, Service Test will continue to use this license for the
duration of the batch run session. To clear this license, youmust close the Test
Batch Runner.
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Troubleshooting and Limitations - Run Sessions
This section describes troubleshooting and limitations related to running tests.

Service Test run sessions
l If you want to run Service Test in aminimized RDP (remote desktop protocol) session, and you

are using an RDP 6.0 or later client, you can enable it by setting a registry value on the computer
that is running the RDP client:

a. If it does not exist, create the RemoteDesktop_SuppressWhenMinimized registry
value (DWORD type) in one of the following registry paths on the computer that is running
the RDP client:

o For 32-bit operating systems: <HKEY_CURRENT_USER or HKEY_LOCAL_

MACHINE>\Software\Microsoft\Terminal Server Client

o For 64-bit operating systems: <HKEY_CURRENT_
USER>\Software\Wow6432Node\Microsoft\Terminal Server Client

b. Set the data for this value to 2.

Note: Youmust restart your remote session in order for this setting to take effect.

l When running Service Test on a remotemachine using a Remote Desktop Connection session
(RDC) or using Citrix, if the computer on which the application is being tested is logged off or
locked, the following problems may occur:

n The test or component run sessionmay fail.

n Steps that contain keyboard or focus operations may fail.

n The RunResults still image capture and/or the Screen Recorder may display a black screen.

n Steps for which the device level replay is configured to use themouse (instead of browser
events) to runmouse operations may fail. (You set the device level replay using a
Setting.WebPackage("ReplayType") statement or by setting theReplay type option in the
AdvancedWebOptions dialog box.)

Workaround: If you are using Citrix or a Remote Desktop Connection session to run a test or
component, make sure that the computer on which the application is being tested is not logged
off or locked.

l When running Service Test tests or components on a local machine, if the computer on which
the application is being tested is locked, your test runmay fail.

Workaround: Install Service Test on a virtual machine (without a screensaver or lock
password), and start or schedule your run session on the virtual machine. Then you can lock
your local computer without locking the virtual machine.

l It is not recommended to use Test Batch Runner with the UAC (User Account Control) feature
set to ON.

Running Tests
l When youmanually add a reference to an external .dll, Service Test prompts you to save it
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locally. To change your preference about a specific referenced file, remove the reference and
add it again manually.

l Running tests on remotemachines using shared folders, may require adjusting the .NET 2.0
security settings.

Suggestion:Open theControl Panel and locate theAdministrative Tools, either by browsing
or through a search. In the list of Administrative Tools, look for the following entry:
Microsoft .NET Framework 2.0 Configuration. If it is not present, youmust install
the .NET Framework 2.0 SDK.

l The Validate Structure checkpoint fails if the expected value is a SOAP Fault and theWeb
Service call returns anUnsupportedMediaType status.
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Chapter 18: Debugging Tests and
Components
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Concepts

Debugging Overview
After you create an event handler or user code file, you should check that it runs smoothly, without
errors in syntax or logic.

By controlling and debugging your run sessions, you can identify and handle problems in your event
handlers or user code files.

Service Test provides different options that you can use to detect and isolate defects in anuser
code file. For example:

l You can control the run session using breakpoints and various step commands that enable you
to step into, over, and out of a specific step.

l When a run session is suspended, you can use the Debug panes to check andmodify the
values of code objects and variables and tomanually run script or code commands.

Considerations for Debugging User Code Files
l In order to use the debugging features, youmust enable the debugger in the API Testing

General pane of the Options dialog box (Tools > Options > API Testing tab > General node).
Select theRun test in debugging mode check box. For details, see "General Pane (Options
Dialog Box > API Testing Tab)" on page 271.

l While tests are running in debugmode, they are read-only. You canmodify user code files after
you stop the debug session (not when you pause it).

l When you open a test saved on an ALM project, Service Test creates a local copy of the
external references that are saved to your ALM project. Therefore, any changes you apply to any
external reference that is saved in your ALM project, such as aWSDL file, will not be recognized
in the test or component until the test or component is closed and reopened. (An external
reference is any resource that can be saved separately from the test or component, such as a
WSDL file, XML file, or data table.)

Single Step Commands
You can run a single step or step-by-step in a user code file by using theStep Into, Step Out, and
Step Over commands.

Step Into
Step Into runs only the current step in the active user code file.

Step Out
After usingStep Into to enter a step in a user code file, you can use theStep Out command. Step
Out continues the run to the end of the user code file, returns to the calling test and then pauses the
run session at the next line (if one exists).
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Step Over
Step Over runs only the current step in the active user code file.

If the current step calls a user-defined function, the called function is executed in its entirety, but the
called function script is not displayed in the document pane. The run session then returns to the
calling user code file and pauses at the next step (if one exists).

For task details, see "Step into, out of, or over a specific step during a debug session" on page 311.

Watching the Values of Variables and Properties of
Objects During a Run Session

You can use theWatch pane and Local Variables pane to view the current value of different code
expressions, variables, and object properties in a suspended run session of your test or component.
A run session is suspended, for example, if you use theRun > Pause command, or when it stops
at a breakpoint.

The Local Variables pane displays the current values and types of all variables in themain script of
the current action, or in a selected function in your user code files.

TheWatch pane displays the current values and the types of code expressions and objects that
you add to the pane.

As you continue stepping through the subsequent steps in your user code file, Service Test
automatically updates theWatch pane and Local Variables pane with the current value for any
variable or expression whose value changes. In addition, Service Test reevaluates the information
displayed in theWatch pane and Local Variables pane as youmake changes in the context of your
debug session, as selected in the Call Stack pane,

You can add any of the following types of expressions to theWatch pane:

l The name of a variable

l The name of a property

l Any other type of code expression

Caution: Service Test runs the expressions in theWatch pane to evaluate them. Therefore,
do not add amethod or any expression whose evaluation could affect the state of the test, as
this can lead to unexpected behavior of your user code file.

Expressions added to theWatch pane are saved with the test and updated accordingly as you
make changes to your test.

For task details, see "Check andmodify the values of variables and code expressions during a
debug session" on page 312.

Breakpoints
You can use breakpoints to instruct Service Test to pause a run session at a predetermined place in
anuser code file. Service Test pauses the run when it reaches the breakpoint, before executing the
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step. You can then examine the effects of the run up to the breakpoint, make any necessary
changes, and continue running the user code file from the breakpoint.

Breakpoints are saved with your user code file and aremaintained even after you close and reopen
Service Test.

You can use breakpoints to:

l Suspend a run session and inspect the state of your application

l Mark a point from which to begin stepping through anuser code file using the "Single Step
Commands" on page 308

For task details, see "Use breakpoints in your user code file" on next page.

Enabling and Disabling Breakpoints

You can instruct Service Test to ignore an existing breakpoint during a debug session by
temporarily disabling the breakpoint. Then, when you run your user code file, Service Test runs the
step containing the breakpoint, instead of stopping at it. When you enable the breakpoint again,
Service Test pauses there during the next run. This is particularly useful if your user code file
contains many steps or events, and you want to debug a specific part of it.

You can enable or disable breakpoints individually or all at once. For example, suppose you add
breakpoints to various steps throughout your user code file, but for now, you want to debug only a
specific part of it or a specific event. You could disable all breakpoints in your user code file and
then enable breakpoints only for specific steps or in specific event handlers. After you finish
debugging that section, you could disable the enabled breakpoints, and then enable the next set of
breakpoints (in the section or event you want to debug). Because the breakpoints are disabled and
not removed, you can find and enable any breakpoint, as needed.

Enabled breakpoint. An enabled breakpoint is indicated by a filled red circle icon (  ) in the left
margin adjacent to the selected step.

Disabled breakpoint. A disabled breakpoint is indicated by an empty circle icon (  ) in the left
margin adjacent to the selected step.
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Tasks

How to Debug Your User Code File
This task describes different ways you can control and debug your run sessions so you can identify
and handle problems in your user code files.

To practice this task, see "How to Debug a User Code File - Exercise" on page 314).

This task contains the following sections:

l "Prerequisite" below

l "Step into, out of, or over a specific step during a debug session" below

l "Use breakpoints in your user code file" below

l "Check andmodify the values of variables and code expressions during a debug session" on
next page

l "Manually run code commands during a debug session" on next page

l "View the current call stacks" on next page

l "View currently running threads" on next page

l "View the loadedmodules associated with the run session" on next page

Prerequisite
To debug tests, youmust enable the debugger. Select Tools > Options > API Testing tab >
General node and select Run test in debugging mode.

Note: For details on accessing Service Test tools and files inWindows 8, see "Accessing
Service Test inWindows 8Operating Systems" on page 33.

Step into, out of, or over a specific step during a debug session

l To use theStep Into command select Run > Step Into, click the Step Into button , or
press F11.

l To use theStep Out command select Run > Step Out, click theStep Out button , or press
SHIFT+F11.

l To use theStep Over command select Run > Step Over, click the Step Over button , or
press F10.

For details, see "Single Step Commands" on page 308.

Use breakpoints in your user code file
For details, see "How to Use Breakpoints " on next page.
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Check and modify the values of variables and code expressions during a
debug session

l To add an expression to theWatch Pane, click theAdd New Watch Expression button in
theWatch Pane and enter the name of the expression in the Add New Watch dialog box.

l To remove an expression from the "Watch Pane", select the row in theWatch pane that you

want to remove and press theDELETE key on your keyboard or press theDelete button .

l To view the current values for all variables up to the current step in the user code file, use the
"Local Variables Pane".

You can also change the value of a variable or property manually by running code commands in the
Console pane.

For more details, see:

l "Watch Pane" on page 126

l "Local Variables Pane" on page 122

l "Console Pane" on page 124

Manually run code commands during a debug session
For details, see "Console Pane" on page 124.

View the current call stacks
To view the currently running call stacks in your run session, select View > Debug > Call Stack.
You can double-click on a stack name in the pane to navigate directly to the line of code that begins
the call stack.

Note: If the location of the call stack is not in a currently open file, Service Test opens the
relevant file.

View currently running threads
To view the code threads currently running in the run session, select View > Debug > Threads.
You can double-click on a thread's name in the "Threads Pane " (described on page 120) to navigate
directly to the beginning of the thread.

Note: If the file containing the beginning of the selected thread is not open, then Service Test
opens the relevant file.

View the loaded modules associated with the run session
To view the associated loadedmodules for your run session, select View > Debug > Loaded
Modules.

How to Use Breakpoints
The following steps describe how to set breakpoints, and temporarily enable or disable them. After
you finish using them, you can remove them from your user code file.

This task includes the following sections:
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l "Set a breakpoint" below

l "Enable or disable a breakpoint" below

l "Enable or disable all breakpoints" below

l "Remove a single breakpoint or all breakpoints" below

Set a breakpoint
To set a breakpoint, do one of the following:

l Click in the left margin of a step in the user code file where you want the run to stop.

l Select the line where you want the run to stop and select Run > Insert/Remove Breakpoint.

The breakpoint symbol is displayed in the left margin adjacent to the selected step.

Enable or disable a breakpoint
To enable/disable a specific breakpoint, do one of the following:

l Right-click the step containing the breakpoint and select Enable/Disable Breakpoint.

l In the " Breakpoints Pane", select the breakpoint you want to enable or disable and press the

Disable/enable breakpoint button .

Enable or disable all breakpoints
To enable/disable all breakpoints, select Run > Enable/Disable All Breakpoints. If at least one
breakpoint is enabled, Service Test disables all breakpoints in the document. Alternatively, if all
breakpoints are disabled, Service Test enables them.

Remove a single breakpoint or all breakpoints
To remove a single breakpoint, click the breakpoint icon in the left margin of the step. The
breakpoint symbol is removed from the left margin of the user code file.

To remove all breakpoints, do one of the following:

l Select Run > Clear All Breakpoints.

l In the " Breakpoints Pane", click theRemove all button .

l In the " Breakpoints Pane", right-click and select Remove all.

All breakpoint symbols are removed from the left margin of the user code file.

Navigate to a specific breakpoint
1. In the " Breakpoints Pane", select the specific breakpoint to which you want to navigate.

2. Do one of the following:

n Double-click the line containing the breakpoint name.

n Click theGo to source button .

n Right-click the line containing the breakpoint and select Go to Source.

The cursor flashes in themain document window in the line containing the breakpoint.
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How to Debug a User Code File - Exercise
In this exercise, you create and debug a Service Test user code file to practice using some of
Service Test's debugging capabilities for Service Test tests.

Note: For a task related to this scenario, see "How to Debug Your User Code File" on page
311.

This scenario includes the following steps:

l "Create test steps" below

l "Set properties for themath steps" below

l "Create parameters for the Custom Code activity" below

l "Link the Custom Code activity to existing steps" on next page

l "Create events for the Custom Code activity" on next page

l "Run the test" on page 316

l "Check the value of the variables at the first breakpoint" on page 316

l "Add a variable to theWatch Pane" on page 316

l "Check the value of the variables at the next breakpoint" on page 316

1. Create test steps
a. Create a test.

b. From the "Toolbox Pane", drag theAdd activity,Multiply activity, and theCustom Code
activity to the canvas.

2. Set properties for the math steps
a. In the Input/Checkpoints tab , in the Input pane, enter the values for theAdd4

operation.

o In theValue column forA, enter 10.

o In theValue column forB, enter 6.

b. In the Input/Checkpoints tab, enter the values for theMultiply operation.

o In theValue column forA, enter 2.

o In theValue column forB, enter 4.

3. Create parameters for the Custom Code activity
a. In the "Add Input/Output Property/Parameter Dialog Box" (described on page 497), enter

the details for the input parameter.

o In theName field, enter AddResult.

o In the Type field, select String from the drop-down list (if it is not already selected).
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A new input property calledAddResult appears in the Input pane inside the
Input/Checkpoints tab.

b. Create another input parameter calledMulResult. This time, in the "Add Input/Output
Property/Parameter Dialog Box":

o In theName field, enter MulResult.

o In the Type field, select String from the drop-down list (if it is not already selected).

A new input property calledMulResult appears in the Input pane inside the
Input/Checkpoints tab.

c. Click theAdd button again and select Add Output Property.

d. In the "Add Input/Output Property/Parameter Dialog Box" (described on page 497), enter
the details for the output parameter.

o In theName field, enter Result.

o In the Type field select Decimal from the drop-down list.

e. In theCheckpoints pane, enter the value of 128.

4. Link the Custom Code activity to existing steps
a. In the "Select Link Source Dialog Box" (described on page 630), select theAddActivity

step. In the right pane, select Result and click OK.

The link source Step.OutputProperties.AddActivity<number>.Result
appears in theAddResult row.

b. In the dialog, select theMultiply step. In the right pane, select Result and click OK.

The link source Step.OutputProperties.MultiplyActivity<number>.Result
appears in theMulResult.

5. Create events for the Custom Code activity
a. In the Properties pane, select theCustomCode activity from the drop-down list or by

clicking theCustomCode activity in the canvas.

b. In the Properties pane, select theEvents tab.

c. In the "Events Tab (Properties Pane)" (described on page 193), create a default handler for
ExecuteEvent andAfterExecuteStepEvent. Two events, CodeActivity<number>_
OnExecuteEvent and CodeActivity<number>_OnAfterExecuteEvent are
added to the TestUserCode.cs file.

For details on Service Test events, see "Writing Code for Events Overview" on page 642.

d. In the TestUserCode.cs file, enter the following text in the CodeActivity_
OnExecuteEvent:

decimal AddResult = AddActivity.Result;

decimal MulResult = MultiplyActivity.Result;

CodeActivity<number>.Output.Result = AddResult*MulResult;

HP Service Test (11.52)Page 315 of 705

User Guide
Chapter 18: Debugging Tests and Components



e. Enter a breakpoint on the last line of this method.

f. In the TestUserCode.cs file, enter the following text in the CodeActivity<number>_
OnAfterExecuteStepEvent:

decimal result = CodeActivity<number>.Output.Result;

g. Enter a breakpoint on the last line of this method.

h. Save the test.

6. Run the test
Select Run > Run or press F5.

7. Check the value of the variables at the first breakpoint
a. When the test run stops at the first breakpoint, select View > Debug > Local Variables to

open the "Local Variables Pane".

b. In the Local Variables pane, see the current values of theAdd andMultiply activity. The
current values should be 16 for theAddActivity and 8 for theMultiplyActivity.

You can expand the notes on various rows to see the variable values of the different items
used in your test run.

8. Add a variable to the Watch Pane
a. In the TestUsercode.cs tab, highlight the text AddResult.

b. Open theWatch pane by selectingView > Debug > Watch.

c. In the "Watch Pane" (described on page 126), click theAdd New Watch Expression

button and enter Add Result.

A line with the expression AddResult, with a value of 16, and type Decimal appears.

d. Click theAdd New Watch Expression button again to add the variableMulResult to the
Watch pane. The pane should display the expression MulResult, with a value of 8, and
type Decimal.

9. Check the value of the variables at the next breakpoint
a. Continue the run session by selectingRun > Continue or pressing F5.

b. When the run session pauses at the next breakpoint, highlight the text
CodeActivity<number>.Output.Result and add it to theWatch pane.

The pane displays that the value of this variable is 128.

Note that theAddResult andMulResult values, which you added in the previous step to
theWatch pane, are undefined with a type Incorrect Expression. This is because
these values are present and relevant to the current event.

c. Click the Local Variables tab. Note that the line Result displays a value of 128, since the
custom code entered earlier noted that Result is equal to
CodeActivity6.Output.Result, which was equal to AddResult*MulResult.
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In addition, if you hover over the variable names in the Editor in the paused run session, an
expandable tooltip displaying the current value of the variable and its properties can be
viewed.

d. Select Run > Continue or click F5 to complete the run session and view the run results.
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Reference

Run/Debug Session Toolbar
This toolbar is displayed when you begin a run or debug session.

To access Start a run or debug session.

Important
information

The toolbar buttons described are unique to the Run/Debug Session toolbar. Most
of the toolbar buttons displayed during a run or debug session are common to the
toolbar displayed when designing or editing a test or component.

Relevant
tasks

"How to Debug Your User Code File" on page 311

See also "How to Debug a User Code File - Exercise" on page 314

User interface elements are described below:

Toolbar
button

Name Description

Run Starts a run session or continues a paused run or debug session.

Stop Stops the current run session.

Pause Pauses the current run session.

Step Into Enables you to run only the current step in your user code file. For
details, see "Step Into" on page 308.

Step Over Enables you to run only the current step in the user code file. For
details, see "Step Over" on page 309.

Step Out Continues the current run session after the current step until the end of
the current function. For details, see "Step Out" on page 308.

Solution
Explorer
Pane

Displays the Solution Explorer pane as the active pane.

Toolbox
Pane

Displays the Toolbox pane as the active pane.

Data Pane Displays the Data pane as the active pane.

Properties
Pane

Displays the Properties pane as the active pane.
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Toolbar
button

Name Description

Debug
Pane

Opens a drop-down list of the debug panes you can bring into focus.
For details, see "Debug Pane Interface" on page 112.

Output
Pane

Displays the Output Pane as the active pane.

Errors Pane Displays the Errors pane as the active pane.

Tasks Pane Displays the Tasks pane as the active pane.

Active
Screen

Displays the Active Screen pane as the active pane.

HP Service Test (11.52)Page 319 of 705

User Guide
Chapter 18: Debugging Tests and Components



HP Service Test (11.52)Page 320 of 705

User Guide
Chapter 18: Debugging Tests and Components



Part 5: Service Test Integration With HP
ALM
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Chapter 19: ALM Integration

Note: Unless otherwise specified, references toApplication Lifecycle Management orALM
in this guide apply to all currently supported versions of ALM andQuality Center. Note that
some features and options may not be supported in the specific edition of ALM or Quality
Center that you are using.

For a list of the supported versions of ALM or Quality Center, see theHP Service Test Product
Availability Matrix, available from the Service Test Help or the root folder of the Service Test
DVD. Themost up-to-date product availability matrix is available from the HP Software
Product Manuals site, at http://h20230.www2.hp.com/selfsolve/manuals (requires an HP
Passport).

For details on ALM or Quality Center editions, see theHP Application Lifecycle Management
User Guide or theHP Quality Center User Guide.
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Concepts

ALM Integration Overview
Service Test integrates with ALM, the HP centralized quality solution. ALM helps youmaintain a
project of all kinds of tests (such as tests, components, business process tests, manual tests,
tests created using other HP products, and so on) that cover all aspects of your application's
functionality. Each test or component in your project is designed to fulfill a specified testing
requirement of your application. Tomeet the goals of a project, you organize the tests in your
project in unique groups.

ALM provides an intuitive and efficient method for scheduling and running tests or components,
collecting results, analyzing the results, andmanaging test and component versions. It also
features a system for tracking defects, enabling you tomonitor defects closely from initial detection
until resolution.

At its most basic level, integrating Service Test with ALM enables you to store and access tests,
components, and resource files in an ALM project, when Service Test is connected to ALM.

Service Test integrates with Service Test Management, ALM's extension for storing andmanaging
application components, such as Web services. Service Test Management is an extension of ALM
and it provides an efficient method for storing and retrieving application components.

This section also includes: "What is an ALM Project?" below

What is an ALM Project?

An ALM project is a database for collecting and storing data relevant to a testing process. For
Service Test to access an ALM project, youmust connect to the local or remoteWeb server where
ALM is installed.

When Service Test is connected to ALM, you can:

l Create tests, components, and resources and save them in your ALM project.

l View the contents of your tests. This can help you decide if you want to run a test as part of a
test set. Note that the Test Flow in ALM and the canvas in Service Test display only the actions
that are run when the currently selected test runs. This means that if a nested action is
commented out, for example, that action is not displayed in ALM or in the Service Test canvas.
You can uncomment it in the Service Test Editor when needed.

l Run your tests and components and view the results in ALM.

l Associate a test or a component with external files stored in the Test Resources module
of an ALMproject.

l Associate external files for all tests or for a single test.You can set the default activity
repository location for your custom test activities in the Test Resources module in ALM.

For details on specifying the default location for activity repositories, see "General Pane
(Options Dialog Box > API Testing Tab)" on page 271.
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l Take advantage of all the features provided with the Resources and Dependencies
model. For details, see "Resources and Dependencies Model" on page 343.

For details on working with ALM, see theHP Application Lifecycle Management User Guide.

Required Access Permissions
Youmust have the following access permissions to use Service Test with ALM:

l Full read and write permissions to the ALM cache folder (located on the ALM client side)

l Full read and write permissions to the Service Test Add-in for ALM installation folder

Data Awareness in ALM
In ALM, you can upload and store your Microsoft Excel (.xls) test data resource files in the Test
Resources module, enabling you to use the same data for multiple tests or components, or different
data for each test run.

In ALM, you run configuration instead of standard tests. When working with data-driven tests in
ALM, each configuration is a test that is set to run with a selected data resource file and optional
data filter settings. The filter settings enable you to filter data by specified row numbers, by
parameter text values, or both.

Note: You define andmanage configurations only in ALM.

Example

Suppose you define three configurations in a single test to test an application that provides
different solutions for Gold Card, Silver card, and Bronze Card users. You could use the same
data resource for each configuration by filtering the rows or text of the data resource tomatch
the relevant user type. Similarly, if your data is stored in various .xlsor .xlsx files, youmight
want to run the same test using a different data source each time. You would do this by
associating a different data source with each configuration.

By managing your data as a resource in ALM, you can see at a glance which data resource files are
associated with a particular test or configuration, and which tests or configurations are using a
specific data resource. For more details, see "Advantages of Data Awareness in ALM" on next
page.

How Does Data Awareness in ALM Work?

When you create a test in ALM (or save a test to an ALM project from Service Test for the first
time), a default configuration with the same name as the test is created simultaneously. You can
view this configuration in the Configuration tab of the Test Planmodule.

In the ALM Test Resources module, you create one or more data resources and upload one
Microsoft Excel (.xlsor .xlsx) file for each.

After you upload a data resource file to your ALM project, you can define the test-level configuration
settings for a particular test. You do this in the Parameters tab of the Test Planmodule by selecting
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the data resource file andmapping its column names to the data table parameters in your test. You
can associate one data resource with the test-level configuration. By mapping the column names to
data table parameters, you enable Service Test to identify and use the correct parameter value
during a run session.

Note:

When running a test, Service Test's Data Navigation looks at the data resulting from the
specific configuration. For example, if your ALM configuration filters the data to use only rows 3
through 5, and the Service Test navigation says to iterate rows 2 through 3, the actual data
used will be rows 4 and 5 from the test resource.

In the configuration tab of the Test Planmodule, you can create as many additional configurations
as needed. By default, every configuration uses the test-level configuration settings unless you
override the data resource.

If you associate a configuration with the data resource defined in the Parameters tab, you do not
need tomap the data table parameters to column names. You can, however, modify the filter
settings by applying text filters to any parameter, and/or selecting the rows on which the
configuration can run.

If you associate a different data resource with a configuration, or you select to override the test data
resource and then select the same data resource file that you selected in the Parameters tab (which
the same as selecting a different data resource), you need tomap the data table parameters to the
column names in the .xls file. You can also apply filter settings, as described previously.

Next, in the Test Labmodule, you can run any or all of the configurations defined for a test (or
associated with a requirement) by adding them to a test set. When you run a configuration
containing steps that use data table parameters, the parameter values are retrieved from the data
resource files according to the settings defined for that configuration.

For a task describing how to work with configurations, see "How to Data Drive a Test Using Data
from ALM" on page 328.

For a chart listingmodules and tabs in which you perform tasks in ALM, see "ALM Data
Awareness - Task Breakdown" on page 334.

This section also includes:

Advantages of Data Awareness in ALM

Test reuse. You can use the same test to test various scenarios, each time with a different set of
data. You can do this associated a different data resource with each configuration, by associating a
single data resource with different configurations and then filtering each configuration, or by using a
combination of both.

Data Reuse. You can associate the same data resource with multiple tests or configurations.

Ease of Management. All of your resources are stored in one central location.

Visibility. You can see which tests are using a particular data table, and you can see which data
table each test is using.
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Requirements Coverage. You can cover all of your testing requirements by linking them to
specific configurations. This enables you, for example, to use a single test to cover multiple
requirements by associating different configurations in the same test with each requirement.

Resources and Dependencies Model. By storing your data in the Test Resources module, you
can take advantage of additional ALM integration features, such as:

l Version control and baselines

l Asset comparison Tool and Asset Viewer

l Sharing data resources across ALM projects

Considerations for Data Awareness in ALM

Consider the following whenmanaging your data resources in ALM:

l Only Microsoft Excel (.xls or .xlsx) files are supported as data resources.

l If youmodify a data table parameter or a column name in the associated data resource after they
aremapped to each other, youmust update themappings accordingly. Additionally, if you
update an Excel data source and link properties to the new data source, the new values will not
be reflected in ALM until you remap the properties using theMap Parameters dialog box.

For details, see "How to Data Drive a Test Using Data from ALM" on page 328.
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Tasks

How to Work with Tests and Components in ALM
The following steps describe the workflow of how to work with tests and components saved in an
ALM project.

This task includes the following steps:

l "Prerequisites forWindows Vista, Windows 7,andWindows Server 2008, andWindows Server
2008 R2Users" below

l "Connect to an ALM Project" below

l "Create or open a test or component" below

l "Run your test or component in the ALM project" below

l "Manage versions of your project using version control - optional" below

l "Disconnect from the ALM project" on next page

Prerequisites for Windows Vista, Windows 7,and Windows Server 2008,
and Windows Server 2008 R2 Users
The security settings in the following operating systems may prevent you from connecting to an
ALM project:

l Windows Vista

l Windows 7

l Windows Server 2008

l Windows Server 2008 R2

This can occur when the UAC (User Account Control) option is set to ON, and you have never
connected to an ALM project.

To connect to ALM for the first time, youmust disable the UAC option and restart your computer.
After you successfully connect to ALM, you can turn the UAC option on again. Thereafter, you
should be able to connect to ALM, as needed.

Connect to an ALM Project
For details, see "ALM Connection Dialog Box" on page 335.

Create or open a test or component
For details, see "New <Document> Dialog Box" on page 67 or "Open/New
<Document>/<Resource> Dialog Box" on page 69.

Run your test or component in the ALM project
For details, see"How to Run an API Test" on page 288 and "Run Dialog Box" on page 296.

Manage versions of your project using version control - optional
For details, see "Managing Versions of Assets in ALMOverview" on page 357.
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Disconnect from the ALM project
For details, see "ALM Connection Dialog Box" on page 335.

Note:When you disconnect from a project, all open tests from the project automatically close.

How to Data Drive a Test Using Data from ALM
This task provides a general overview of the steps involved in data driving a test with data stored in
ALM. After you are familiar with the steps, you can perform many of them in the order you choose.
Some steps may not be necessary in all cases.

This task includes the following steps:

l "Prerequisites" below

l "Import data into a test" below

l "Data drive the test steps" below

l "Create a data resource file in your ALM project" below

l "Specify a default data table resource for all new test configurations" on next page

l "Define your test configurations" on next page

l "Link your configurations to requirements to create requirements coverage - Optional" on page
331

l "Run your test configuration" on page 331

1. Prerequisites
a. Connect to ALM, as described in "ALM Connection Dialog Box" on page 335.

b. Make sure that your test is saved in your ALM project. For details on creating tests and
saving them to ALM, see "New <Document> Dialog Box" on page 67

2. Import data into a test

a. In the Data pane, click theNew Data Source button and select Excel.

b. In the "New/Change Excel Data Source Dialog Box" (described on page 98), select the
.xls or .xlsx file containing the data and Select theAllow other tools to override the
data option. Click OK to import the data source into your test.

3. Data drive the test steps
For details, see "How to Assign Data to Test Steps" on page 621.

4. Create a data resource file in your ALM project
In the Test Resources module:

a. Expand the Resources tree and select the required node.

b. Select Resources > New Resource to add a resource under that node.

c. In the New Resource dialog box:
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o In the Type list, select Data table.

o In theName box, enter a name for the data resource, for example, the name of the
Microsoft Excel (.xlsor .xlsx) file you plan to use.

o Fill in the remaining fields (optional) and click OK to close the dialog box.

d. In the Resource Viewer tab, click Upload File. Then browse to and upload the relevant
.xlsor .xlsx file.

Note: You can convert an internal data table from an open test to an uploadable data
resource file by right-clicking the Data pane, selecting File > Export, saving the data
table to the file system as an .xls or .xlsx file, and then uploading it as described
above.

5. Specify a default data table resource for all new test configurations
a. In the Parameters tab of the Test Planmodule, select the data table resource you want to

use as the default for all test configurations.

b. Click theMap Parameters button . In theMap Parameters dialog box, map the data
table parameters (column headings) to the test parameters by entering thematching data
table parameter names in theResource Parameter Name column, as shown in the
example below.

All new configurations use the default mappings unless you specify otherwise in the Data
tab of the Configurations tab. For details, see the next step, Define your test
configurations.

6. Define your test configurations
Define test configurations for various run sessions. For each configuration, you specify
whether to use the default resource file that you specified in the previous step, or whether to
use a different data resource file.
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a. In the ALM Test Planmodule, browse to and select the test to which you want to associate
your data table resource. For details, see theHP Application Lifecycle Management User
Guide.

b. Click the Test Configurations tab. A default configuration is displayed in the grid. This
configuration was created when your test was added to the ALM project. For details on
configurations, see "Data Awareness in ALM" on page 324.

c. In the bottom pane of the Configurations tab, click theData tab.

d. In the Data tab:

o Select theOverride test data resource check box to select a different data resource
file from the Test Resources module, or leave the check box blank to use the default
resource file you selected in the Parameters tab in the previous step.

o In theData Resource box, browse to and select the relevant data resource file to
associate with this configuration. (Relevant only if you selected theOverride test data
resource check box)

o Click theData Resource Settings button, and in the Filter Settings dialog box:

o Map the data table parameters from your test to the column headers in the data table
file (Relevant only if you selected a different data resource file in the previous step)

o Apply filter conditions (text strings), as needed. You can apply one filter condition to
each parameter.

o Specify the rows on which to run iterations. For example, if you run a configuration
named Gold, and users of this type are listed in rows 2-114, then specify these rows
only.

Note: If you apply filter conditions and specify rows, AND logic is used, meaning
that the parameter valuemust equal the filter text value and the parameter value
must be located in one of the specified rows.

Example:

The pLastName data table parameter is mapped to Last_Name and is filtered to
include only parameter text values that equal Smith. The configuration is set to run
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only on rows 1-18 in the .xls or .xlsx file you uploaded as the data resource.

For details on this dialog box, see theHP Application Lifecycle Management User Guide.

7. Link your configurations to requirements to create requirements
coverage - Optional
If you want to make sure that your requirements are fully covered, link them to configurations.
This enables you to select configurations to run based on requirement coverage when you plan
your run session.

a. In the Test Planmodule, click theReq Coverage tab.

b. Click theSelect Req button. The Requirement Tree tab is displayed in the right pane.

c. From the Requirement Tree tab, select a requirement to add to the Req Coverage grid.
When you add the requirement, the Add Advanced Coverage dialog box opens.

d. Select the test configurations that cover this requirement.

8. Run your test configuration
You run configurations from ALM.

a. In the ALM Test Labmodule, select or create a test set. For details, see theHP Application
Lifecycle Management User Guide.

b. In the right pane, select theExecution Grid tab.

c. Click theSelect Tests button to display the Test Plan Tree andRequirements Tree tabs
in the right pane.

d. Do one of the following to select the configurations to run:
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o From the Test Plan Tree tab, select a test to add to the Execution Grid. When you add
the test, all of its configurations are added to the Execution Grid. (The test itself is not
added to the Execution Grid because ALM runs configurations, not tests.)

o Below the Test Plan Tree tab, expand the Test Configurations pane, and add the
specific configurations that you want to run to the Execution Grid.

o Below the Requirements Tree tab, expand the coverage pane, and select a test to add
to the Execution Grid. When you add the test, all of its configurations are added to the
Execution Grid. (The test itself is not added to the Execution Grid because ALM runs
configurations, not tests.)

e. Click theRun button to run the selected configurations.

f. After the run session, click the Launch Report button in the Last Run Report tab to view
the results.

How to Use ALM Version Control
The following steps describe how to use version control features tomanage tests and resources
stored in an ALM version-controlled project.

l "Prerequisite" below

l "Check out a test" below

l "Check in a test" below

l "Cancel a check out operation" on next page

l "View the version history" on next page

Prerequisite
Connect to your ALM project. Make sure that you are logged into a version controlled project. For
details, see "ALM Connection Dialog Box" on page 335.

Check out a test
1. Open the test you want to check out. For details, see "Open/New <Document>/<Resource>

Dialog Box" on page 69.

A dialog opens asking if you want to check out the test. Select Yes.

2. In the Check Out dialog box, enter any comments you want to attach with your check out and
click OK.

An editable copy of the test opens and is locked in your ALM project.

Check in a test
1. In the document pane or in the Solution Explorer, select your test or resource file.

2. Select ALM > Check In. The "Check In Dialog Box" on page 365 opens.

3. In the Check In dialog box, enter any comments you want to attach to your check in and click
OK.
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The test or resource file is checked into your ALM project and is available for other users to
check out and edit.

Cancel a check out operation
If you decide you do not want to upload the changes youmade to an asset to your ALM project:

1. In the document pane or in the Solution Explorer, select your test or resource file.

2. Select ALM > Undo Check Out. Click Yes to confirm the cancellation of your check out
operation.

The check out operation is cancelled. The checked out asset closes, and the previously
checked in version reopens in read-only mode.

View the version history
1. In the document pane or in the Solution Explorer, select the test or resource file for which you

want to view the history.

2. Select ALM > Version History.

The Version History dialog box opens, displaying the information on the versions of the
selected asset.
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Reference

ALM Data Awareness - Task Breakdown
The following table lists where to perform specific data awareness tasks in ALM:

Module Tab Task

Test Plan Parameters Define the test-level configuration for the current test:

l Specify a data resource file.

l Map the data table parameters used in your test steps to the
column names in your data resource file.

Test
Configurations

Create additional configurations. (Optional)

Data tab:

l Select a different data resource. (Optional)

l Specify the data resource settings:

n Specify the rows to be used during a run session.

n Specify any text parameters values filters. (Optional)

n If you select a different data resource (by overriding the
data resource defined in the Parameters tab), map the
data table parameters used in your test steps to the
column names in your data resource file.

Req Coverage If you add requirement coverage to a test that contains multiple
configurations, specify which configuration(s) to use for
coverage.

(Can also be done from the Requirements module)

Test
Resources

Resource
Viewer

l Create a data resource.

l Upload aMicrosoft Excel (.xls or .xlsx) file to use as the
data resource.

Test Lab Execution Grid l Add all of the configurations in a test to a test set.

l Add only specific configurations to a test set.

l Add all of the configurations contained in a tests that cover
specific requirements to a test set.

l Add only the configurations associated with a specific
requirement to a test set.
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ALM Connection Dialog Box
This dialog box enables you to connect to or disconnect from a project in any supported version of
ALM.

For more details, see "ALM Integration Overview" on page 323.

To access Use one of the following:

l In Service Test:Select ALM > ALM Connection.

l In the Run Results Viewer:Select Tools > ALM Connection.

l Click theALM toolbar button .
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Important
information

l 1st time connection. The first time you connect to an ALM server, youmust
connect as a user with administrator privileges on the computer on which you
are connecting.

l Connecting to different ALM servers. You can simultaneously connect your
Web browser to multiple ALM clients and oneQuality Center 10.00 client
simultaneously. While these clients are open, you can connect to the
Quality Center 10.00 client that is currently open on your computer. However,
if you want to connect to an ALM client, youmust first close the
Quality Center 10.00 client.

l Connecting to different versions of Quality Center or ALM. You cannot
connect to multiple versions of Quality Center or ALM in the same Service
Test session. Close and reopen Service Test to connect to a different version
of Quality Center or ALM.

l Windows Vista, Windows 7, Windows Server 2008, Windows
Server 2008 R2 Users, Windows 8, and Windows Server 2012 Users.
See "Guidelines forWindows Vista, Windows 7, Server 2008, Server 2008 R2,
Windows 8, andWindows Server 2012 Users" on page 338.

l Connect. The connection process has two steps. First, you connect to a local
or remote ALM server. This server handles the connections between Service
Test and the ALM project. Youmust provide a user name and a password.

Next, you choose the project you want to access. The project stores tests and
run session information for the application you are testing.

l Disconnect. You can disconnect from an ALM project or from an ALM server.

n If you disconnect from an ALM server without first disconnecting from a
project, the Service Test connection to that project database is
automatically disconnected.

n After you open a Business Process test in Service Test, you cannot log out
of a project and log in to another project on the same server. Youmust first
disconnect from the server and reconnect before logging in to another
project.

l SSL Certificates. If you are attempting to connect to an ALM project with a
https:// prefix, but your computer does not have a valid SSL certificate, the
connection will fail.

If an ALM test or shared file (such as a shared object repository or data table file)
is open when you disconnect from ALM, then Service Test closes it in the
document pane. The document remains in the Solution Explorer and is marked as
unloaded.

Relevant
tasks

To view the current connection:

l In Service Test:Point to the icon on the status bar. A tooltip displays the
server name and project to which Service Test is connected.

l In the Run Results Viewer: The icon on the status bar is labeled with the
server name and project to which the Run Results Viewer is connected.

User interface elements are described below:
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UI Elements (A-Z) Description

Close Closes the ALM Connection dialog box.

Note: The dialog box does not close automatically. Youmust
click this button to close the dialog box.

Connect / Disconnect Connects to or disconnects from the selected ALM server.

Note: After you successfully connect to a server, the button
changes toDisconnect, and at the top of the dialog box, the

Disconnected icon changes to aConnected icon .

Domain The domain that contains the ALM project.

Login / Logout l Login. Logs into the selected domain and project using the
current user information. After you successfully log into a project,

the button changes to Logout, and the Logged out icon

changes to a Logged in icon .

l Logout. Logs out of the selected domain and project.

Note: Youmust click Close to close the dialog box after logging
into or out of a project.

Password Your ALM password.

Note: To enter a password in any CJK (Chinese, Japanese,
Korean) language, copy/paste the password into the edit box.
(Windows does not support typed CJK characters in password
fields.)

Project The ALM project with which you want to work.

Note: Only those projects for which you are a defined user are
displayed.

Restore connection on
startup

Instructs Service Test to automatically reconnect to the ALM server
every time you open Service Test.
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UI Elements (A-Z) Description

Server URL The URL address of theWeb server where ALM is installed.

You can choose a server that is accessible via a Local Area Network
(LAN) or aWide Area Network (WAN).

You can connect to any currently supported version of ALM. For a list
of supported versions, see theHP Service Test Product Availability
Matrix, available from the root folder of the Service Test DVD.

User Name Your ALM user name.

Guidelines for Windows Vista, Windows 7, Server 2008, Server 2008 R2,
Windows 8, and Windows Server 2012 Users
The security settings in the following operating systems may prevent you from connecting to an
ALM project:

l Windows Vista

l Windows 7

l Windows Server 2008

l Windows Server 2008 R2

l Windows 8

l Windows Server 2012

This can occur when the UAC (User Account Control) option is set to ON, and you have never
connected to an ALM project.

To connect to ALM for the first time, youmust disable the UAC option. After you successfully
connect to ALM, you can turn the UAC option on again. Thereafter, you should be able to connect to
ALM, as needed.
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Troubleshooting and Limitations - ALM Integration
This section describes troubleshooting and limitations for working with tests and components and
ALM, and includes:

Troubleshooting and Limitations - General ALM Integration 339

Troubleshooting and Limitations - ALM Integration 342

Troubleshooting and Limitations - General ALM
Integration

l Whenworking with Quality Center 10.00, set the DEP (Data Execution Prevention) flag to off.

l The first time you connect to your ALM server, (either within Service Test or through a browser)
connect as administrator. This allows themachine to properly install the ALM client with the
required connectivity. For all subsequent connections, you do not need to log in as administrator.
This step is also required after installing ALM patches.

l If Service Test is installed on one of the operating systems listed in the table below, youmust
perform prerequisites before you run tests remotely from ALM:

Operating
System

What you should do

n Windows
XP
Service
Pack 2

n Windows
2003
Server

Youmust enable COM+ access. For details, see the Installation Guide.
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Operating
System

What you should do

n Windows
Vista

n Windows
Server
2008

n Windows
7

n Windows
Server
2008 R2

n Windows
8

n Windows
Server
2012

a. Youmust enable COM+ access. For details, see the Installation Guide.

b. Change DCOM permissions and open firewall ports. For details, see the
Installation Guide.

c. Run RmtAgentFix.exe from the <Service Test

installation>\bin folder, or use the Additional Requirements Utility,
which you open by selectingStart > Programs > HP Software >
HP Service Test > Tools > Additional Installation Requirements.

This is due to a problem with opening DCOM permissions onWindows
Vista, Windows Server 2008, Windows 7 andWindows Server 2008 R2.

d. Disable User Account Control (UAC) inWindows and restart your
computer before you first connect to ALM.

l The security settings inWindows Vista, Windows Server 2008, Windows 7, Windows
Server 2008 R2, Windows 8, andWindows 2012may prevent you from performing a Service
Test related installation, such as a patch installation, or connecting to an ALM project (either
directly or from Service Test). This can occur when the UAC (User Account Control) option is
set to ON, and you have not yet connected to an ALM project (if relevant).

Workaround: Temporarily turned off the UAC option.

After disabling the UAC option as described above, perform the required installation or connect
to ALM as usual. When you are finished, you can turn the User Account Control (UAC) option on
again. Hereafter, you should be able to connect to ALM, as needed.

l If you are connected to an ALM server, and you want to connect to a different server, disconnect
from the first ALM server, restart Service Test, and connect to the second server.

l If Service Test closes unexpectedly while an asset is open from ALM, the asset may remained
locked by ALM for more than fifteenminutes. In some cases, youmay be able to reopen Service
Test and reopen the test, but when trying to save it, you will receive an error message indicating
that the test entity is already locked by you.

Workaround:Wait fifteenminutes or more and try again.

l Renaming a test or component from ALMmay cause the test or component to behave
unexpectedly.

Workaround: To rename a test or component, open it in Service Test and rename it using the
Save As option. If the test or component has already been renamed from ALM, use the rename
option again to restore the old name, and then use theSave As option in Service Test.
Renaming a test parameter from Service Test causes any run-time parameter values already set
for this parameter in ALM to be lost.

l If an ALM user manually changes the status of a test instance run, ALM creates fast run results
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to record the change of the test status. The fast run results are not valid run results files.
However, when you try to select results to open or delete in the Run Results Viewer or Run
Results Deletion tool, the fast run results are available in the list.

l For tests or business components saved on ALM, if you perform a checkout from within ALM, it
is not reflected in Service Test for the current test—the test or business component still appears
to be checked in.

Workaround:Close and reopen the test in Service Test.

l When running a test from Service Test with ALM 11.50 and later with an ALM project that
supports versioning, the test instance run status will not be updated for tests that are checked
out.

l ALM supports non-Unicode projects. If you are working with an ALM project that is not Unicode
compliant:

n You should not use Unicode values (such as the name of the test or component, the default
value of a test, action, or component parameter, method argument values, and so forth).

n Data that is sent to Service Test from ALM (such as values for test, action, or component
parameters) is not Unicode compliant.

n Service Test results containing Unicode characters may appear corrupted in the ALM result
grid. You can, however, open and view results containing Unicode characters in the Service
TestRun Results Viewer.

l If there is a forward proxy with Basic Authentication between the server and client machines,
before the first connection to an ALM platform, each ALM client must configure the proxy
credentials by using theWebgate Customization Tool. If you do not runWebGate, youmay
be unable to connect, or youmay need to enter your credentials multiple times.

To run the tool:

a. Go the following location on the ALM client machine: http:\\<ALM Platform server

name>[<:port number>]/qcbin/Apps/

b. Click on theWebgate Customization Tool link and select Run.

c. InWebGate Customization, click in theProxy Credentials area. Select theUse these
credentials check box, and type values in theProxy Username andProxy Password
boxes.

d. Click Save and thenClose.

l To run Service Testlocally on aWindows 2003 Server machine, youmust perform the following
steps in order to run a test stored in ALM.

a. Select Start > Run.

b. In the Run dialog box, type dcomcnfg. TheComponent Service console opens.

c. If the left pane, expand theComponent Services tree. Select theComputers > My
Computer > COM+ Applications node.

d. In the right pane, select Remote Agent and select Properties from its shortcut menu.

e. Select the Identity tab. Select This User and enter the credentials of a user with
administrator privileges.
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f. Click OK and close all of the dialog boxes.

Note: This is required only if ALM is not installed on the same server as Service Test.

l To run Service Test remotely on aWindows 2003 server machine, youmust enable network
COM+ access. To enable this access, perform these steps on the remote server machine:

a. Select Start > Settings > Control Panel.

b. In the Control Panel, double-click Add or Remove Programs.

c. In the Add or Remove Programs dialog box, click Add/Remove Windows Components in
the left pane.

d. Select Application Server and click theDetails button.

e. In theSubcomponents of Application Server pane, select Enable network COM+
access. Click OK.

f. Click Next and Finish to close all of the dialog boxes. Restart the server machine.

g. Perform the steps described in the previous bullet for running Service Test locally on a
Windows 2003 server machine.

l When running tests with the Remote Agent, the Remote Agent process continues to run after
the completion of the test run.

Workaround:Manually end the dllhost.exe process in the Task Manager.

Troubleshooting and Limitations - ALM Integration
l While connected to an ALM project, if you change the available license for an Service Test test,

ALM continues to use the original license.

Workaround: Log out from your ALM project and restart Internet Explorer.

l Service Testconnections to ALM do not support NTLM authentication.

l For Service Test Management: Before importing aWSDL from Service Test Management, you
must connect at least once to the Service Test Management-ALM server through Internet
Explorer.

l To enable test versioning in Quality Center version 10.00, create a file in the <QC
installation folder>\repository\sa\DomsInfo\Metadata\TEST folder called
ServiceTest.xml with the following content:

<?xml version="1.0" encoding="UTF-8" ?>

<Test Type="SERVICE-TEST">

<Repository>

<Folders ID="1" Filter="." BlindCopy="true" />

</Repository>

<Versioning Enabled="true" />

<Baselining Enabled="false" />

</Test>
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Chapter 20: Resources and Dependencies
Model

Relevant for: GUI tests and components and API testing

Note: The references to ALM in this chapter apply to Quality Center 10.00 and ALM. Note that
some features and options may not be supported in the Quality Center or ALM edition you are
using. For information onQuality Center or ALM editions, see theHP Quality Center User
Guide or theHP Application Lifecycle Management User Guide.

This chapter includes:

Concepts 344

Resources and Dependencies Model Overview 344

Asset Dependencies - Advantages 344

Reference 346

Relative Paths and ALM 346

Resources and Dependencies Model Terminology 346

ALM Resources-Related User Interface 349

Troubleshooting and Limitations - Resources and Dependencies 355
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Concepts

Resources and Dependencies Model Overview
Relevant for: GUI tests and components and API testing

Service Test enables you to use the Resources and Dependencies model to fully integrate your
tests and components into ALM projects.

Note: Before you read this section, youmay want to familiarize yourself with the "Resources
and Dependencies Model Terminology" (described on 346).

l Replaces the use of attachments with linked assets. For example, GUI tests, actions, and
application areas can be linked with function libraries and shared object repositories,
respectively orAPItests can be linked with data tables, user code files, or activities. You store
your tests or components in the Test Plan or Business Components module, respectively, and
you store your resource files (including application areas) in the Test Resources module. When
you associate a resource file to a test or a GUI component's application area, these assets
become linked. Linking assets improves runtime performance by decreasing download time.
(Using attachments instead of resources increases download time from Quality Center 10.00
and ALM.) Linking assets also helps to ensure that the relationships between dependent assets
aremaintained.

l Supports versioning for tests or components and resource files. You can create versions
of these assets in Service Test or in ALM, and you canmanage asset versions in ALM. For
details, see "Version Control in ALM" on page 356.

l Supports baselines for tests or components and resource files. You can view baseline
history in Service Test, and you can view andmanage baselines in ALM. For details, see
"Baseline History Dialog Box" on page 368.

l Enables you to import and share assets across ALM projects. For details, see the
HP Application Lifecycle Management User Guide.

For details about the advantages of working with this model, see "Asset Dependencies -
Advantages" below.

Asset Dependencies - Advantages
Relevant for: GUI tests and components and API testing

When you associate a dependent resource file with a test's or a GUI component's application area,
the assets become integrally linked, and these links can be viewed in ALM (in the Dependencies
tab of various modules) and—for external GUI actions—in Service Test (in the Action Properties
dialog box).

Assets stay linked
When youmove a test, or rename a test, action, component, application area, folder, or resource,
dependent assets are automatically updated to reflect the change. This helps ensure that there are
nomissing resources during a run session.
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Resource files are all stored in one ALMmodule
Resource files are stored in the Test Resources module, enabling you tomanage your resources in
one central location, and to view at a glance which tests and application areas are using each
resource file. For details on the Test Resources module, see theHP Application Lifecycle
Management User Guide.

Using resources stored in the Test Resources module improves runtime
performance
Tests or components open and run faster when the associated resource files are stored in the Test
Resources module (instead of being stored as attachments to tests in the Test Planmodule).

Version control can also be applied to resource files
When version control is enabled for a project, all of the assets can be checked into the version
control database. For details, see "Version Control in ALM" on page 356.

You can create, view, compare, and run baselines
In ALM, you can create baselines that capture the developmental stage for each asset, view and
compare these read-only baseline "snapshots", and run baselines from a project. In Service Test,
you can view and compare baselines. For details, see "Baseline History Dialog Box" on page 368.

You can share assets with other projects and synchronize them
You can copy assets from other projects. This enables you to reuse your existing assets instead of
creating new assets whenever you create a new project. For example, you can create a "template"
set of assets to use as a basis for new projects.

You can synchronize these assets in both projects when changes aremade, or you can customize
your assets to suit the unique needs of each development project. For details, see the sections on
importing and synchronizing libraries in theHP Application Lifecycle Management User Guide.

Deleting assets is easier
When you delete an asset (a reusable GUI action or component or associated resource file), a
warningmessage informs you if the asset is used by other tests (or more than once in the current
test) or is associated with an application area. This message contains aDetails section that lists
the tests or application areas that are associated with this asset or contain calls to this action so
you canmodify the tests or application areas, as needed. This helps youmanage your business
process tests andGUI action calls so that tests do not inadvertently fail.

You can verify which tests or components are associated with specific
resources and vice versa
In the ALM Test Planmodule and Business Components module, you can highlight a test or
component and, in the Dependencies tab, see which assets are using the test or component, and
see which assets the test or component is using. Similarly, in the ALM Test Resources module,
you can highlight a resource file and see the assets with which it is associated.

For details, see "Dependencies Tab (ALMModules) " on page 350.
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Reference

Relative Paths and ALM
Relevant for: GUI tests and components and API testing

Resource files andGUI actions that are associated with tests or application areas using a relative
path are not considered dependencies. To ensure that your resource files are recognized as
dependencies, they must be saved in the Test Resources module in ALM, and they must be
associated using the full ALM path. This enables you to benefit from the features provided by the
Resources and Dependencies Model, as described in "Asset Dependencies - Advantages" on page
344.

For GUI testing:Despite this, theremay be cases in which youmay want to use a relative path.
For example, if your application is released in different languages, youmay want to use a relative
path when associating shared object repositories with your tests or components' application areas,
as this enables you to use the same test with localized shared object repositories.

Limitations - Relative Paths and ALM
l Run-time performance times are slower.

l Dependency information for these assets is not displayed in:

n The Using and Used By grids in the Dependencies tab in ALM.
See: "Dependencies Tab (ALMModules) " on page 350

n Themessage box that opens when you delete an asset that is associated with other
assets.For details, see "Asset Dependencies - Advantages" on page 344

l ALM does not verify that these assets are included during the baseline verification process. For
details, see "Viewing Baseline History" on page 360

l When opening or running tests or components from a baseline, any associated external GUI
action or resource file that is associated via a relative path but is not included in the baseline is
considered amissing resource. This may cause a test or component run to fail. (Note that the
baseline version of an associated asset is used if the asset associated via a relative path is
included in the baseline.), For details, see: "Viewing Baseline History" on page 360

Resources and Dependencies Model Terminology
Relevant for: GUI tests and components and API testing
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Term Description

Asset Any testing document or resource file, including:

For GUI testing:

l tests

l actions (GUI testing only)

l components

l application areas (GUI testing only)

l function libraries (GUI testing only)

l shared object repositories (GUI testing only)

l recovery scenarios (GUI testing only)

l data table files

l environment variable files

For API testing:

l tests

l components

l data table files

l XML files

l testing activities

l Web references (done via Service Test Management)

l user code files

Note: In ALM, Service Test assets are referred to by themore general term
entities.
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Term Description

Resource Any asset stored in the ALM Test Resources module that is used by a test or
component. For example, aGUI test or componentmay contain calls to
functions in associated function libraries, and it may reference test objects
stored in shared object repositories that are associated with the test or
component's application area. AnAPI test or componentmay contain
references to a data table file or use a custom testing activity.

GUI testing resources include:

l application areas

l function libraries

l shared object repositories

l recovery scenarios

l data table files

l environment variable files

API testing resources include:

l data table files

l XML files

l testing activities

l Web references (done via Service Test Management)

l user code files

Note: In some cases, a resource can be used by another resource. For
example, a GUI test's recovery scenario can use functions in a function
library.
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Term Description

Dependency The linked relationship between a resource or external GUI action and a
particular test or application area. Associated resource files andGUI actions
are linked to each test or GUI component's application area that uses these
resources or calls theseGUI actions.

In some cases, a resource can also be linked to another resource. For example,
a GUI test's recovery scenario can call functions in a function library.

Assets are considered dependencies if they are associated using absolute
paths, and they are stored in the followingmodules:

l Test Plan module: tests

l Business Components module: components

l Test Resources module:

n GUI testing resources like application areas, function libraries, shared
object repositories, recovery scenarios, data table files, environment
variable files

n API testing resources like data table files, .xml files, testing activities,
and user code files

Note: Tests or components stored in theUnattached or Obsolete folders
in the Test Plan or Business Components module, respectively, are not
considered dependencies because they are not associated with any test or
component.

Configuration A test that is set to run from ALM with an optional data resource file and optional
data filter settings. In ALM, you can define various configurations for the same
test or business process test.

For tests, see "Data Awareness in ALM" on page 324

For components, see theHP Business Process Testing User Guide.

ALM Resources-Related User Interface
Relevant for: GUI tests and components and API testing

When you create an ALM project in your ALM server, the tests or components that you create in
this project are saved to the Test Plan or Business Components module, respectively. You save
your resource files to the Test Resources module. By associating resource files with your tests or
GUI components' application areas, they become linked dependencies.

This section provides a general overview of the tabs that are relevant for tests, components, or
applications areas. For details on using any of these tabs, see the relevant section in the
HP Application Lifecycle Management User Guide.

This section includes (in alphabetical order):

Dependencies Tab (ALMModules) 350
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History Tab (ALMModules) 353

Libraries Module (ALM) 354

Dependencies Tab (ALM Modules)

Relevant for: GUI tests and components and API testing

This tab displays the relationship between a selected asset, such as a test or component, and the
assets with which it is associated. You use the Dependencies tab to see at a glance which
resources are used by a particular asset, and which asset is using a particular resource. This
information is displayed in the "Using Grid" on page 352 and "Used By Grid" on next page in the
Dependencies tab in the Test Plan and Test Resources modules or the Business Components
module.

Usage Example

For GUI testing:Suppose you want to modify the objects in a shared object repository. You
can navigate to the shared object repository in the Test Resources module to view a list of the
tests or application areas with which it is associated. This enables you to determine which
assets this resource file is used by and helps you to analyze the impact that a proposed
changemay make to the dependent assets.

For API testing:Suppose you want to modify the values in a data table. You navigate to the
data table in the Test Resources module to view a list of the tests or components with which it
is associated. This enables you to determine which assets this resource file is used by and
helps you to analyze the impact that a proposed changemay make to the dependent assets.

To access In ALM, the Dependencies tab is available from the followingmodules:

l Business Components module

l Test Planmodule

l Test Resources module
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Important
information

For details on using this tab, see theHP Application Lifecycle Management
User Guide.

Relevant
Tasks

l In the Business Components module, the Dependencies contains the
following grids:

n Used By. Displays the business process tests that include this
component.

n Using. Displays the application area with which the component is
associated.

For more details on the Dependencies tab in the Business Components
module, see theHP Business Process Testing User Guide.

Business
Process
Testing

In the Business Components module, the Dependencies contains the
following grids:

l Used By. Displays the business process tests that include this
component.

l Using. Displays the application area with which the component is
associated.

For more details on the Dependencies tab in the Business Components
module, see theHP Business Process Testing User Guide.

Service Test-specific user interface elements are described below.

Used By Grid
This grid lists the assets that are using the asset currently selected in the tree. Suppose you
are looking at the Used By grid for a shared object repository (for a GUI test) or a data table (for an
API test). The Used By grid lists all of the GUI tests or application areas that are associated with
the selected shared object repository or all the API tests that are associated with the data table.
This list indicates the assets that will be affected if youmodify or delete the asset selected in the
tree.

Column Description

ID A unique numeric ID assigned automatically by ALM. If the ID is a link, you can
click it to jump to that asset in ALM.

Example:Suppose you are looking at the Used By grid for a specific function
library (GUI testing only) or user code file (API testing only) in the Test
Resources module. You can click the ID link to jump to the test or application
area with which it is associated. (The link takes you to the Test Plan or
Business Components module.)

HP Service Test (11.52)Page 351 of 705

User Guide
Chapter 20: Resources and Dependencies Model



Column Description

Name The name of the asset that is using the asset selected in the tree, for example, the
name of a test, GUI action, application area, or business process test that is using
the asset selected in the tree.

GUI-related owner names include:

l Main Test Flow. Indicates the test container called by the top-level action in
the currently selected test in the Test Planmodule. WhenMain Test Flow is
displayed, theOwner Type is Test.

l Action<#>. Indicates the internal name of the action that is called by an action
in the currently selected test in the Test Planmodule. Action<#> refers to the
sequential number of the action when it was created. Action<#> is displayed
when theOwner Type is QTP Action.
Note:Action<#> is displayed even if an action was renamed in the test.

l The actual name of the asset if the asset is not an action.

An asset linked to anAPI test or component lists the name of the asset.

Type The type of asset that is using the asset selected in the tree, for example
ApplicationArea or BUSINESS-PROCESS or Test, QTP Action,

QUICKTEST_TEST, or SERVICE_TEST.

Description The description specified in theDetails tab for the asset listed in theName
column (see description above).

Note: (for GUI testing)

l If the Type is QTP Action, displays the actual name of the action as
shown in Service Test (for example, if the action was renamed, the user-
defined name is displayed) and displays its description, if any.

l If the Type is QUICKTEST_TEST or Test, this cell is empty.

Owner
Name
(GUI tests
only)

The name of the asset that owns the asset listed in theName column. For
example, if the asset listed in theName column is an action, then theOwner
Name is the name of the test in which that action is stored. (Not relevant for
components or API tests)

Owner
Type
(GUI tests
only)

The type of asset that owns the asset listed in theName column. GUI-related
owner types include:

l QUICKTEST_TEST. A GUI test in the Test Planmodule.

l QTP Action. An action that is part of a test in the Test Planmodule.

Using Grid
This grid lists all of the dependencies that the selected asset is using. For example, suppose
you are looking at a test or component. You can see all of the external actions called by the test, all
of the shared object repositories containing test objects used by the test or component, function
libraries containing functions called by the test or component, and so on.
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Column Description

ID A unique numeric ID assigned automatically by ALM.

Name The name of the associated asset that the selected asset uses, for example, the
name of the shared object repository, data table resource, or function library.

GUI-related names include:

l For business process tests, lists the names of the flows and/or components
that are included in that test.

l For business process flows, lists the name of the components that are
included in that flow.

l For components, lists the name of the associated application area.

l Action<#>. Indicates the internal name of the action that is called by an action
in a test in the Test Planmodule. Action<#> refers to the sequential number of
the action when it was created. Action<#> is displayed when theRelated
Type is QTP Action.
Note:Action<#> is displayed even if an action was renamed in the test.

l For application areas, lists the name of all associated resources, including
function libraries and shared object repositories.

l The actual name of the asset if the asset is not a test.

Type The type of associated asset that the selected asset uses, for example,
ApplicationArea, Component, FLOW, QTP Action, Data table, Function
library, Shared object repository, andRecovery scenario.

Description The description of the associated asset that the selected asset is using, if any.

If the Type is QTP Action, displays the name of the action as shown in Service
Test and displays its description, if any.

Owner
Name

The name of the asset that owns the asset listed in theName column. For
example, if the asset listed in theName column is an action, then theOwner
Name is the name of the test in which that action is stored. (Not relevant for
components)

Owner
Type

The type of asset that owns the asset listed in theName column, for example,
QUICKTEST_TEST. (Not relevant for components)

History Tab (ALM Modules)

Relevant for: GUI tests and components and API testing

This tab enables you to:

l View version information for a selected file.

l View baseline information for a selected file.
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l View and compare file versions.

l View the baseline in which a version is stored (if applicable).

l Check out an earlier version of a file if you want to roll back to that version. (When you check the
file back into the version control database, that version becomes the current version.)

To access In ALM, the History tab is available from the followingmodules:

l Business Components module

l Test Planmodule

l Test Resources module

Note: The History tab is located in the pane on the right side of the window.
Youmay need to scroll to the right to display it.

Important
information

For details on using this tab, see theHP Application Lifecycle Management
User Guide.

Relevant
tasks

In Service Test, you can also view version history and baseline history by
selecting one of the following:

l ALM > Version History

l ALM > Baseline History

See also l "Version History Dialog Box" on page 366

l "Viewing Baseline History" on page 360

Libraries Module (ALM)

Relevant for: GUI tests and components

This module enables you to:

l Create, view, and compare baselines. For details, see "Viewing Baseline History" on page
360 and the sections describing baselines in theHP Application Lifecycle Management User
Guide.

l Import assets from other ALM projects. This enables you to create a complete copy of the
assets that are included in a baseline in another project in any accessible domain. For details,
see theHP Application Lifecycle Management User Guide.

To access In the ALM sidebar, underManagement select Libraries.

Important
information

For details on using this tab, see theHP Application Lifecycle
Management User Guide.
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Troubleshooting and Limitations - Resources and
Dependencies

Relevant for: GUI tests and components and API testing

This section describes troubleshooting and limitations for resources and dependencies.

l When you save a resource to ALM (either from Service Test or using theUpload option from the
ALM Test Resources module), and the resource file has a comma in the file name, the resource
appears to be saved successfully, but the file is not actually uploaded to the ALM server.

l For GUI testing: If you insert a call to an external action that is associated with a data table,
and that data table was previously renamed ormoved in the Test Resources module of Quality
Center 10.00 or ALM, Service Test tries to locate the data table in its original location.

Workaround:Save the test, close it, and reopen it.
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Chapter 21: Version Control in ALM
Relevant for: GUI tests and components and API testing

Note: The references to ALM in this chapter apply to Quality Center 10.00 and ALM. Note that
some features and options may not be supported in the Quality Center or ALM edition you are
using. For information onQuality Center or ALM editions, see theHP Quality Center User
Guide or theHP Application Lifecycle Management User Guide.

This chapter includes:

Concepts 357

Managing Versions of Assets in ALMOverview 357

Viewing Version Control InformationWhenOpening a Test 358

Tasks 362

How toManage Version Control Operations 362

Reference 364

VersionManagement Commands 364

Check Out Dialog Box 364

Check In Dialog Box 365

Version History Dialog Box 366

Baseline History Dialog Box 368

Troubleshooting and Limitations - ALM Version Control 370
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Concepts

Managing Versions of Assets in ALM Overview
Relevant for: GUI tests and components and API testing

When Service Test is connected to an ALM project with version control support, you can update
and revise your Service Test assets while maintaining earlier versions of each asset. This helps
you keep track of the changes made to each asset and see what was modified from one version to
another. Assets can include tests, components, function libraries, application areas, shared object
repositories, recovery scenarios, and external data tables, XML files, user code files, or test
activities.

You can check in the asset at any time. For example, youmay want to check the asset in every day
or when you complete a task. While the asset is checked out to you, other users can view the last
checked in version of that asset in read-only mode, but they cannot modify the asset or view your
changes until you check in the asset.

If the
asset
is...

You can...

checked
in

l Open the asset in read-only mode using theOpen option. You cannot modify the
asset.

l Open the asset and check it out by selectingALM > Check Out.

l Open the asset and check it out immediately using theOpen and Check out
option in the "Open/New <Document>/<Resource> Dialog Box" (described on
page 69). You canmodify the asset as needed.

Tip: (for GUI testing): If a test, component, function library, or application area
is checked into a project with version control, the document tab indicates its
(Read-Only) status.

Note: If you check out a test, and that test is associated with a data table that is
currently checked in to the ALM project, the data in that data table is read-only,
even though the test is editable. Tomodify the data table, youmust first check
out the data table in the ALM Test Resources module.

checked
out to
your
ALM
user
name

Open the asset in read-write mode, using theOpen option andmodify the asset as
needed.

Tip: If a test, component, function library, or application area is checked out to

your ALM user name, an unlocked icon in the Solution Explorer indicates
this status.
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If the
asset
is...

You can...

checked
out to
another
ALM
user

Open the asset in read-only mode using theOpen option. Service Test displays a
message indicating that the asset is checked out to another ALM user. You can view
the last checked in version of the asset now, and you can check out the asset later
after the other user checks in the asset.

Tip: If a test, component, function library, or application area is checked out to
another ALM user name, the document tab indicates this status by displaying a
locked icon and (Read-Only) adjacent to the document's name.

In Service Test, you can check out only the latest version of an asset, although you can view and
compare earlier versions. This is because assets that are stored in ALM are often linked to or
dependent on one another.

For example, if you try to run an earlier version of a test or component with a later version of a
shared object repository or a data table, your test or component might fail because the objects in the
object repository or data table would not necessarily match the objects or steps in the test or
component. For more details, see "Troubleshooting and Limitations - ALM Version Control" on page
370.

Viewing Version Control Information When Opening a
Test

Relevant for: GUI tests and components and API testing

When you open a test from an ALM project with version control support, you can view version
control information for the test by using theDetails view in the "Open/New
<Document>/<Resource> Dialog Box" (described on 69).

TheChecked Out To column specifies the user name of the ALM user to whom the test is checked
out, if it is checked out. If the test is currently checked in to the version control database, there is no
indication in the dialog box.

This section also includes:

How ALMManages Assets 359

View and Compare Asset Versions 359

Adding Assets to the Version Control Database in an ALM Project 359

Checking Assets Out of the Version Control Database 359

Checking Assets into the Version Control Database 360

Viewing Baseline History 360

Version History Versus Baseline History 361
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How ALM Manages Assets

Relevant for: GUI tests and components and API testing

Youmanage asset versions by checking assets in and out of the version control database.

You add an asset to the version control database by saving it in an ALM project with version control
support. When you save an asset for the first time, Service Test automatically checks the asset
into the ALM version control database, assigns it version number 1, and automatically checks the
asset out for you so that you can continue working on it. When you check the asset in, the asset
retains version number 1, since this is the first version that can contain content. Then, each time
the asset is checked out and in again, the version number increases by 1.

Note: If you create an asset directly in ALM, the asset is assigned version number 1 and is
immediately checked out to you. In ALM, version number 1 represents the created asset
without content. When you next check the asset in, ALM assigns it version number 2.

View and Compare Asset Versions

Relevant for: GUI tests and components and API testing

If your project administrator creates project baseline versions when amilestone is reached during
product development, you can view and compare the asset versions stored in these baselines. For
details, see "Viewing Baseline History" on next page.

Note:With the exception of theBaseline History option, theALM Version Control options
in theALMmenu are available only when you are connected to an ALM project with version
control support, and an asset stored in ALM is open in the Service Test window.

Adding Assets to the Version Control Database in an ALM Project

Relevant for: GUI tests and components and API testing

When you create a new asset or useSave As to save an existing asset in an ALM project with
version control support, Service Test automatically saves the asset in the project, checks the asset
into the version control database with version number 1, and then checks it out so that you can
continue working. This is an administrative version of the asset, similar to a placeholder. The
version number indicates that the asset exists in the database. When you later check in the asset,
the version number remains version number 1—the first version that you are checking in.
Subsequent checkins increase the version number by 1.

Saving your changes to an existing asset does not check them in. Even if you save and close the
asset, the asset remains checked out until you choose to check it in. For details, see "Checking
Assets into the Version Control Database" on next page.

Checking Assets Out of the Version Control Database

Relevant for: GUI tests and components and API testing
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When you open an asset that is currently checked in to the version control database, it is opened in
read-only mode. You can review the checked-in asset. You can also run the asset and view the
results.

Tomodify the asset, youmust check it out. When you check out an asset, ALM copies the asset to
your unique check-out folder (automatically created the first time you check out an asset), and
locks the asset in the project database. This prevents other users of the ALM project from
overwriting any changes youmake to the asset. However, other users can still run the version that
was last checked in to the database.

You can save and close the asset, but it remains locked until you return the asset to the ALM
database. To release the asset, either check the asset in, or undo the check out operation. For more
details on checking assets in, see "Checking Assets into the Version Control Database" below. For
details on undoing the check-out, see "How to Cancel a Check-Out Operation" on page 363.

In Service Test, the check out option accesses the latest version of the asset. In ALM, you can
also check out earlier versions of any asset except for application areas. For details, see "Version
History Dialog Box" on page 366 and the ALM user guide.

Checking Assets into the Version Control Database

Relevant for: GUI tests and components and API testing

While an asset is checked out, ALM users can run the previously checked-in version of your asset.
For example, suppose you check out version 3 of an asset andmake a number of changes to it and
save the asset. Until you check the asset back into the version control database as version 4, ALM
users can continue to run version 3.

When you have finishedmaking changes to an asset and you are ready for ALM users to use your
new version, you check it in to the version control database.

Note: If you do not want to check your changes into the ALM database, you can undo the
check-out operation. For details, see "How to Cancel a Check-Out Operation" on page 917.

When you check an asset back into the version control database, ALM deletes the asset copy from
your checkout folder and unlocks the asset in the database so that the asset version is available to
other users of the ALM project.

Viewing Baseline History

Relevant for: GUI tests and components and API testing

In ALM, a project administrator can create baselines that provide "snapshots" of an entire project (or
part of a project) at different stages of development. A baseline represents a version of a project at
a specific point in a project's life cycle. For example, baselines are often created for eachmilestone
or when specific phases in a project are completed.

Baselines can be created for ALM projects that are enabled for version control, and for projects for
which version control is not enabled.

The project administrator creates the baseline in the Libraries tab of theManagement module in
ALM. Creating a baseline is a two-fold process. The administrator first creates a library, which
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specifies the root folders from which to import the data. The administrator makes sure to include all
of the associated resource files, such as shared object repositories and function libraries. The
administrator then creates the actual baseline, which comprises the latest versions of every asset
included in the library. If the project is version control-enabled, then these are the latest checked in
versions of every asset.

During the creation process, ALM verifies that all of these assets (such as associated resource
files) are included in the baseline. If any assets are not included, ALM informs the administrator so
that the library and baseline can bemodified accordingly. For more details, see the ALM user guide.

In ALM, these baselines can be viewed and compared in their entirety.

In Service Test, you can view and compare the assets saved in these baselines. This enables you
to review the content of an asset at a specific phase in the project time line.

You can also run a test or component from a baseline.

Version History Versus Baseline History

Relevant for: GUI tests and components and API testing

This section focuses on the differences between version history and baseline history and describes
when to use each.

l You use version control to check in and check out assets as needed. For example, youmay
want to check in an asset on a daily basis or only when significant results are achieved. This
enables you tomonitor the asset's development.

If you want to view the content of an asset on a particular date or after a particular user checked
in the asset, use theVersion History option to view or compare the asset.

l The ALM project administrator creates baselines that represent "snapshots" of a project's
assets at various milestones in a project's life cycle. Each baseline links to the assets specified
by the administrator when the baseline was created. The asset version represented in the
baseline is always the version that was checked in when the baseline was created.

If you want to view an asset as it was saved for a particular milestone, use theBaseline
History option.
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Tasks

How to Manage Version Control Operations
Relevant for: GUI tests and components and API testing

This task describes how to check in the currently open asset, check out the latest version of an
asset in order to edit it, and cancel a check-out operation if needed.

After you edit an asset, you can save changes and close it without checking in themodified asset.
However, your changes are not available to other ALM users until you check it in. If you do not want
to check your changes in, you can undo the check-out by canceling it.

For more details on checking assets in, see "Checking Assets into the Version Control Database"
on page 360.

This task includes the following steps:

l "How to Check In the Currently Open Asset" below

l "How to Check Out the Latest Version of an Asset" below

l "How to Cancel a Check-Out Operation" on next page

How to Check In the Currently Open Asset
1. Confirm that the currently open asset is checked out to you. For details, see "Version History

Dialog Box" on page 366.

Note: If the open asset is currently checked in, theCheck In option is disabled. If you
open an asset that is checked out to another user, all ALM Version Control options,
except theVersion History option, are disabled.

2. Select ALM > Check In, and check in the asset using the Check In dialog box. For
details, see "Check In Dialog Box" on page 365.

How to Check Out the Latest Version of an Asset
1. Make sure the asset you want to check out is currently checked in. If you open an asset that is

checked out to you, theCheck Out option is disabled. If you open an asset that is checked out
to another user, all ALM version control options, except theVersion History option, are
disabled.

Note: Note about version numbers:Prior to Quality Center 10.00, version numbers
consisted of three segments separated by periods, for example 1.7.4. In
Quality Center 10.00 and ALM, version numbers consist of a single segment, for
example 12.

2. Open the "Open/New <Document>/<Resource> Dialog Box" as follows:
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If the asset is
a:

Do this:

Test,
Component
or Function
Library

In themain Service Test window, select File > Open > Test,
BusinessComponent, Function Library, orApplication Area or click the
Open down arrow and select the asset type from the list.

Shared
Object
Repository
(GUI testing
only)

In the Object Repository Manager, select File > Open or click theOpen
button.

Recovery
Scenario
(GUI testing
only)

In the Recovery Scenario Manager, click theOpen button.

3. Browse to and open the asset.

The test opens in the document pane as read-only with a lock icon in the test's tab.

4. Select ALM > Check Out to check out the test and edit it.

How to Cancel a Check-Out Operation
1. Open the asset if it is not already open.

2. Select ALM > Undo Check out.

3. Click Yes to confirm the cancellation of your check out operation.

The check out operation is cancelled. The checked out asset closes, and the previously
checked in version reopens in read-only mode.
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Reference

Version Management Commands
Relevant for: GUI tests and components and API testing

The following version control commands are available in Service Test and can be used when
connected to an ALM project that has version control enabled:

l Check Out. Enables you to check a version-controlled asset out of the version control
database. For details, see "Checking Assets Out of the Version Control Database" on page 359.

l Undo Check Out. Enables you to cancel the check out of a version-controlled asset from the
version control database. For details, see "How to Cancel a Check-Out Operation" on page 917.

l Check In. Enables you to check an asset in to the version control database. For details, see
"Checking Assets Out of the Version Control Database" on page 359.

l Version History. Enables you to view or compare the versions of a particular asset. For details,
see "Managing Versions of Assets in ALMOverview" on page 357.

l Baseline History. Enables you to view or compare the versions of a particular asset as it was
saved in a project's baselines. For details, see "Viewing Baseline History" on page 360.

Check Out Dialog Box
Relevant for: GUI tests and components and API testing

This dialog box enables you to check an ALM asset out of the ALM version control database so that
you can edit it.
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To access ALM > Check Out

Relevant tasks "How to Check Out the Latest Version of an Asset" on page 362

User interface elements are described below:

UI Elements Description

Name The name of the asset.

Version The version number of the asset.

Comments Enter any comments for the version in the Comments area.

Check In Dialog Box
Relevant for: GUI tests and components and API testing

This dialog box enables you to check an ALM asset in to the ALM version control database.
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To access ALM > Check In

Relevant tasks "How to Check In the Currently Open Asset" on page 362

User interface elements are described below:

UI
Elements

Description

Name The asset name.

Version The new version number. By default, the new version number is one number higher
than the previously checked in version.

Comments If you entered a description of your change when you checked out the asset, the
description is displayed in theComments box. You can enter or modify the
comments in the box.

Version History Dialog Box
Relevant for: GUI tests and components and API testing

This dialog box enables you to view the version history for an asset, view the content of a previous
asset version, and compare two asset versions.
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To access l From most assets:Open the asset and select theALM > Version Historym
enu command.

Important
information

To view a version for an asset:Select a version and click View.

To compare two versions of an asset:Select two versions and click Compare.

You cannot check out an earlier version of an asset from this dialog box. (You can
check out earlier version of most assets directly from the ALM project. For details
on checking out assets from ALM, see the ALM user guide.)

See also "Managing Versions of Assets in ALMOverview" on page 357

User interface elements are described below:

UI Elements Description

Name The name of the currently open asset.

Version column A list of all versions of the asset.

Last Modified
column

The date that each version was checked in.

Modified By
column

The user who checked in each listed version.

Comments column The comments that were entered when the selected asset version was
checked in.
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Baseline History Dialog Box
Relevant for: GUI tests and components and API testing

This dialog box enables you to view and compare read-only baseline "snapshots" of an asset.

To access l Most assets:Open the asset and select theALM > Baseline History menu
command.

l Recovery scenario (GUI testing only): In the Recovery Scenario Manager,
open the recovery scenario, click theVersion Control down arrow, and select
Baseline History.

Important
information

In the ALM Test Labmodule, you can use thePin to Baseline option to run a
baseline version of an asset. For more details, see the ALM user guide.

See also "Viewing Baseline History" on page 360

User interface elements are described below:

UI
Elements

Description

Refresh
button

Reloads the baselines in the Baseline History dialog box with the latest changes.
For example, if a baseline is added while this dialog box is open, clickingRefresh
updates the list of baselines.

Baseline
column

Lists all of the baselines that include this asset. Baselines are defined in the ALM
project (Managementmodule > Libraries tab).

Library
column

Lists the libraries from which each baseline was created.

Date
column

Lists the date that each baseline was created.
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UI
Elements

Description

Captured
By column

Lists the ALM user who created each listed baseline.

Description
column

Displays any comments that were added when the baseline was created.

Compare
button

Enables you to view a comparison of the currently open asset in two baselines.

Get button Enables you to open the current asset from the selected baseline.

To view the asset as it was stored in a baseline:Select a baseline from the list
and click View.

When you click Get, Service Test:

l Closes the currently open asset.

l Opens the same asset from the baseline you selected.

l Loads the baseline version of the external actions and resource files that are
associated with the asset, if any, when they are called.

Note: If an external GUI action or resource file is associated via a relative
path, loads the latest version of the action or resource file instead of the
version from the baseline.
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Troubleshooting and Limitations - ALM Version
Control

Relevant for: GUI tests and components and API testing

This section describes troubleshooting and limitations for ALM version control.

l If you need to check out an earlier version of an asset, for example, to roll back to an earlier
version, contact your ALM project administrator. Your administrator needs to ensure that the
correct versions of all relevant assets become the latest versions.

l Whenworking with a version-control-enabled ALM project, it takes a long time to save a test for
the first time (up to twice as long as saving the same test in a project without version control
support enabled). This delay does not occur on subsequent saves of the test.

l To enabletest versioning in Quality Center version 10.00, create a file in the <QC
installation folder>\repository\sa\DomsInfo\Metadata\TEST folder called
ServiceTest.xml with the following content:

<?xml version="1.0" encoding="UTF-8" ?>

<Test Type="SERVICE-TEST">

<Repository>

<Folders ID="1" Filter="." BlindCopy="true" />

</Repository>

<Versioning Enabled="true" />

<Baselining Enabled="false" />

</Test>
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Part 6: Testing Design
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Chapter 22: Testing Services
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Concepts

API Testing Overview
Welcome to Service Test, HP's tool for the construction and execution of functional tests of non-
GUI applications.

You create a test by dragging and dropping activities from the Toolbox pane onto a canvas. The
Toolbox pane provides a collection of activities for functional testing in areas such as REST, Web
Services, JMS, and HTTP. You can addmore activities to the Toolbox pane by importingWSDLs
or using services from the repository. You can also create new custom activities, using the built-in
Activity Wizard. For details, see "Extensibility in Service Test" on page 661.

This section includes:

Performing Integrated Testing 373

The Canvas 373

Extensibility 377

Data Sources 378

TestingWeb Services 378

Testing REST Services 379

Java Testing 379

Performing Integrated Testing

To test your applications and services, you perform known activities and observe the response. By
checking the response, you determine whether your system is performing as expected.

For example, to implement theDatabase > Open Connection activity, you drag the activity onto
the canvas and provide the database connection string. You then can drag database activities onto
the canvas such as theSelect Data activity. After running the activities, you check the response to
confirm that it generated the expected value.

The steps to create a basic test are:

l Drag an activity onto the canvas

l Assign input data

l Set checkpoints to verify the response

The Canvas

The canvas provides a visual representation of the test flow. You populate the canvas by dragging
in activities from the Toolbox pane. For details, see "Toolbox Pane" on page 254.

HP Service Test (11.52)Page 373 of 705

User Guide
Chapter 22: Testing Services



The Toolbox pane contains many built-in services, such as string and file manipulation activities.
For a non built-in service to appear in the Toolbox pane, youmust first import it or define it, such as
Web and REST services, .NET assemblies and SAP IDocs or RFCs. For details, see "Local
Activities" on page 463.

Tab Title
The canvas tab title is <Test name>. An asterisk denotes changes that were not yet saved.

Manipulating Steps
The canvas enables you tomanipulate the steps in the following ways:

l Reorder. Drag a step from one location to another.

l Copy and Paste. Select a step and press CTRL+C to copy it to the clipboard. Press CTRL+V to
paste it into another location within the Test Flow or to another loop.

l Delete. Select a step and press the keyboard's Delete button.

Flow Control
The canvas enables you to control the flow of the steps in the following ways:

l Loop. Themain Test Flow area provides a default loop for test steps. You can add steps to the
Test Flow or add additional loops. Using the Properties Sheet, you can specify the type of loop,
number of iterations, and conditions for the Test Flow or loop. For details, see
"Input/Checkpoints/Output Properties Tab (Properties Pane)" on page 201.
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l Conditional steps. Adds a two-branched conditional node to the test.

l Break.Moves control to the step after the loop.

l Continue.Moves control back to the first step in the Test Flow or Loop and increments it to the
next iteration.

Alerts
Steps that require intervention in order to run, such as HTTP, Custom Code,Wait, andSOAP
Request, post an alert in their top right corner. Clicking an alert button displays the action that you
are required to do.

You can also view this information in the Errors pane by selectingView > Errors. For details about
the Errors pane, see "Errors Pane" on page 172.

Connecting Data
The canvas displays the relationship between output and input properties. An arrow indicates the
direction of the relationship.
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For details, see the "Select Link Source Dialog Box" on page 630.

For details about linkingmultiple steps to a single result, see "Outgoing Links" on page 612.

Testing Steps
TheRun Step utility lets you run a single test step without running the entire test. Using the
property values from the Properties pane, theRun Step operation invokes the step locally and
presents the results in a separate pane, theRun Step Results pane. The following example shows
the results of an FTP File Get Size step.

For more information, see the "Run Step Results Pane" on page 219.

For details about theRun Step utility, see the "Canvas User Interface" on page 391.

Sending Messages to the Output and Results Viewer
TheReport Message activity lets you send custommessages to the Output log and/or the Results
viewer. You drag the activity to the canvas and set its properties in the Properties pane.

As with any step, you can link its input to the output of a prior step and view the results in the Output
pane or Run Results Viewer.
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In the following example, the Run Results Viewer shows theMessage string.

For details, see the Captured Data Pane Contents for / Steps (described in the Run Results
Viewer) and "Output Pane" on page 180.

Extensibility

For greater control over test steps, you can define custom code activities that seamlessly integrate
with Service Test. You can also customize the behavior of existing activities using event handlers.
For details, see "Coding Service Test Events" on page 641.

In addition, through the activity wizard (Start > All Programs > HP Software > HPService Test>
Tools > Activity Wizard), you can create custom testing activites. The Activity Wizard enables
you specify the activity type and properties. It then exports the activity to the Toolbox pane for use
in future testing sessions.

For details on adding new activities and custom code, see "Extensibility in Service Test" on page
661.
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Note: For details on accessing Service Test tools and files inWindows 8, see "Accessing
Service Test inWindows 8Operating Systems" on page 33.

Data Sources

Using the Data Pane, you can define data for your test's properties. You can link to a variety of data
sources, such as Microsoft Excel or XML files. You can also locally define data for the test steps.

When you load data from Excel, you can indicate whether to make a local copy of the data or a
referenced data source, which refers to the data at its original source. If you create a referenced
data source, you will be unable to edit the values in the data grid

A data grid displays the data.

After you load data, you can assign it to properties in your test.

For information on using data in your test, see "How to Assign Data to Test Steps" on page 621.

Testing Web Services

In order to test Web services, you import theWSDL file which describes the service.

After importing aWSDL file, the Toolbox pane displays the service's operations. You then drag the
operations directly onto the canvas and provide values for the input properties.
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For task details, see "How to Import aWSDL-BasedWeb Service" on page 472.

Testing REST Services

You can also test non-SOAPWeb services, such as REST.

For REST services, youmanually define themetadata andmodel your activities based on the
design of your service's requests.

After setting the REST resource definitions, you can create RESTmethod calls based on the
metadata. To validate the results, you set checkpoints for the RESTmethod's response.

You can also create prototype for individual RESTmethods. The prototype includes all of the
request and header information, as well as custom properties. Using this prototype, you can drag
themethod onto the canvas without having to repeatedly configure its details.

For task details, see "How to Create a RESTMethod" on page 475.

Java Testing

To call Java classes use theCall Java Class activity.

In order to use this activity, youmust implement the Service Test Java interface. The aim of this
interface is to define a contract or bridge between the Java artifacts owner and Service Test. The
interface contains threemethods:

l getInputProperties. Returns amapping of the input property names and their Java class.

l getOutputProperties. Returns amapping of the output property names and their Java class.

l Execute. A method that receives themapping of the input property names and their actual

HP Service Test (11.52)Page 379 of 705

User Guide
Chapter 22: Testing Services



values i.e. their object instance. In this method, you process input properties and delegate them
to your own Java artifacts. Afterwards you process the output properties and send their
mappings and their actual values as themethod's output.

The following table lists the relevant paths:

File Path

Interface
code

l Path: <product_
installation>\addins\ServiceTest\JavaCall\Java

Interface\src\hp\st\ext\java\

ServiceTestCall.java

Sample
code

l Path: <product_installation>\addins\
ServiceTest\JavaCall\Java Interface\src\

hp\st\ext\java\sample

To configure a Java step, you select a root path, a jar file containing the class, and the actual Java
class. You can provide additional classpaths and jar files for the Java call. For details about
selecting the Java class and packaging, see the "Java Class Dialog Box" on page 459.

Service Test supports the following Java classes: Byte, Short, Int, Long, Float, Double,
Boolean, Date, andString. TheChar class is not supported.

For task details, see " How to Create a Call to a Java Class" on page 402.

Automated Testing Tool Integration
HP Automated Testing Tools activities allow you to create tests with steps that consist of a GUI,
API, Service Test tests, or LoadRunner scripts.

You create the tests or scripts in the original application and call them from within your Test flow.

For user interface details, see the "Toolbox Pane" on page 254.

For task details, see "How to Call Tests from Other Applications" on page 411.

Business Process Testing
Business Process Testing is amethodology in which several test steps or components, are
combined to create a complete business process. You compose a business process by combining
a series of test components with data flow between them.

Business components are usually comprised of several steps or service operations. For example, a
component's first stepmay be to read the contents of a file. Its second step could be searching for a
string and replacing it. Its third step could be reporting the output to a report.

You can create business components from within ALM or through Service Test.

In ALM, using the Business Component model, non-technical SMEs (Subject Matter Experts) can
define design steps that are required for the component, using simple textual descriptions of the
step's function.
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After these are defined, the technical engineer creates a component through a testing application
such as Service Test, that performs the desired actions. For further information about creating
business components from within ALM, see theHPBusiness Process Testing User Guide.

A Subject Matter Expert using Business Process Testing in ALM combines your saved business
components into one or more business process tests. These tests are used to check that the
application behaves as expected.

Benefits of Business Process Testing

Some of the advantages of working with a Business Component model over individual tests are:

l Enables less-technical subject matter experts to create tests

l Enables structured automated testing

l Reduces the duplication of effort when combiningmanual tests with automatic tests

l Enables component reusability to speed-up the automation process

l Provides the ability to pass parameters from one step to another within your business process.
You can save the output of a step to a parameter and use it as an input value for subsequent
steps

l Simplifies on-going test maintenance

l Minimizes time-to-test

For more information about creating a business components in ALM, see theHP Business Process
Testing User Guide.

Business Process Testing in Service Test

You can create a business component within Service Test or from within ALM.

When you create a business component within Service Test, the following limitations apply:

l Load Test activities are not supported.

l Automated Testing Tool activities are not supported.

l Business components cannot be saved on the file system—only on ALM.

l You cannot save a load-enabled test as a business component.Create a new business
component from the Filemenu, or save a non-load-enabled test as a business component.

l Encoded password type properties are not supported. If the component has a property of type
password (or encrypted in ALM 11.00 and later), the value will be treated as an ordinary
string, without encoding or decoding.

l If you save a load-test enabled test as a business component, it will no longer be load-test
enabled.

l Multiple User Variable profiles are not supported. Remove all but one of the profiles.

l The business component's namemust not contain one of the following characters: \, /, :, ", ?', <,
>,|*, %, !, {, or }.
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JMS Transport Overview
The JMS transport method is a J2EE standard for sendingmessages—either text or Java objects—
between Java clients. Service Test supports the sending of text messages between Java clients.
There are two scenarios for communication:

l Peer-to-Peer. Also known as Point-to-Point. JMS implements point-to-point messaging by
defining amessage queue as the target for amessage. Multiple senders sendmessages to a
message queue, and the receiver gets themessage from the queue.

l Publish-Subscribe. Eachmessage is sent from one publisher to many subscribers through a
designated topic. The subscribers only receivemessages sent after they have subscribed.

To interpret Topic andQueue names, Service Test calls a lookupmethod on a JNDI context,
defined in the Properties pane's Test Settings. For details, see the "Input/Checkpoints/Output
Properties Tab (Properties Pane)" on page 201.

For a list of the activities and their properties, see "JMS Activities" on page 431.

For task details, see "Set up the Java environment - optional" on page 385.
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Tasks

How to Create an API Test
This task describes how to set up the workflow and add steps to your tests. For details on creating
the test and defining user or test variables, see "How to Define Test Properties or User/System
Variables" on page 59.

This task includes the following steps:

l "Prepare the service references - optional" below

l "Create the test flow - optional" below

l "Add activities to the test" below

l "Define data for the test" on next page

l "Create a Custom Code activity - optional" on next page

l "Test the step" on next page

l "Add attachments to the test - optional" on next page

l "Validate an output attachment- optional" on next page

l "Set up the Java environment - optional" on page 385

l "Configure SOAP Fault information - optional" on page 385

l "Specify an event handler - optional " on page 385

1. Prepare the service references - optional
ForWeb Service based tests, import yourWSDL at this point. For details, see "How to Import
aWSDL-BasedWeb Service" on page 472.

For REST services, build themetadata for the service. For details, see "How to Create a
RESTMethod" on page 475.

Skip this step when using the built-in operations, such as String Manipulation activities.

2. Create the test flow - optional
Expand the Toolbox pane nodes and drag Flow Control activities onto the canvas:

n Loop. Enables you to add a loop other than the standard Test Flow. You specify the loop
behavior in the loop's input properties.

n Condition. Enables you to define conditional branches.

n Sleep. Indicates a time delay in milliseconds.

3. Add activities to the test
Expand the nodes of the Toolbox pane and drag activities into the Text Flow or Loop box
within the canvas. If you added aCondition step, drag activities into the condition branches.
For a list of the activities, see the "Standard Activity Types" on page 417.
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4. Define data for the test
For details, see "How to Assign Data to Test Steps" on page 621 or "How to Data Drive a Test
Step" on page 623.

5. Create a Custom Code activity - optional
Select theCustom Code activity from theMiscellaneous category and drag it into a loop.

a. Click the Input/Checkpoints tab in the Properties pane.

b. Click Add Properties and create the required input and output properties.

c. Open the Events view in the Properties pane.

d. Double-click theHandler column of theExecuteEvent row. Service Test opens a new tab
TestUserCode.cs.

e. Locate the Todo section and enter your custom code. Follow the sample code in the
comments and use autocompletion to write your code.

f. Click File > Save All to save the custom code and the test.

For details and examples, see "Coding Service Test Events" on page 641.

6. Test the step
Select the step in the canvas and chooseRun Step from the context menu to run the step with
its property values. Note the results in theRun Step Results pane, in the lower section of the
main window. If something needs to bemodified, do so at this point. For details, see "Run Step
Results Pane" on page 219.

Note: The Run Step command, for steps whose properties are assigned an XML data
source, does not retrieve the latest data shown in the user interface.

Workaround: Save the test before activating the Run Step command.

7. Add attachments to the test - optional
ForWeb Service activities that support input attachments, add an input attachment.

a. Select theWeb Service in the canvas and open theAttachments  tab in the Properties
pane.

b. In the upper pane, select an attachment Type: DIME orMIME.

c. Click in theAttachments row and click theAdd button to add an array element.

d. Select a file as theOrigin of the attachment using theBrowse button .

e. Select aContent Type. Specify aContent ID or keep the default value, Auto.

8. Validate an output attachment- optional
To validate an output attachment:
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a. Select theWeb Service in the canvas and open theAttachments view in the
Properties pane.

b. Click in theAttachments row in the Checkpoints pane, and click Add to add an array
element (it may be necessary to expand the column).

c. Select the check box adjacent to each item that you want to validate. Specify values for
the elements being validated: Content Type and/orContent ID.

d. To validate content, click theCalculate the file checksum button icon in theContent
row. It calculates the specified file's checksum using theMD5Hash function.

For user interface details, see "Attachments Tab (Properties Pane)" on page 187. You can
also check for received attachments in the test's folder, stored as files with a .bin
extension.

9. Set up the Java environment - optional
For JMS messages and Call Java Class activities, you set up the Java environment before
adding a test step.

a. Click in a Start or End step and click the Test Settings  tab in the Properties pane. Set
the Java test settings for the VM and JMS. For details, see the "Test Settings Tab
(Properties Pane)" on page 209.

b. Expand the JMS node in the Toolbox pane and drag a JMS activity onto the canvas.

c. Set the step's properties. Click on the step in the canvas, and select the Input/Checkpoints
tab in the Properties pane. Enter a value for Queue, Subscription, Topic name, and any
other relevant property.

d. For Send activities, specify amessage.

e. For Receive activities, select the output properties you want to validate in the
Checkpoints pane and specify their values.

For more details, see "JMS Transport Overview" on page 382.

10. Configure SOAP Fault information - optional
To apply negative testing to aWeb service:

a. Open theSOAP Fault tab .

b. Select Fault is expected.

c. Provide SOAP Fault checkpoint values for the negative testing:

o Towork In theXML layout: Expand the SOAP nodes and defineAny elements for the
SOAP Header and Body. If relevant, provide values for faultcode, faultstring, or
faultactor.

o Towork withXPath expressions: Click theXPath tab and use the Add button to add
new XPath entries. Copy the XPATH entry into the cell.

For details, see the "SOAP Fault Tab (Properties Pane)" on page 209.

11. Specify an event handler - optional
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For non-custom code activities, you can define default event handlers for checkpoints, before
step executions, and after step executions.

The checkpoint event handlers help you verify the output values in your test. You can use a
Report, Assert, or Log function to gather information about your service.

To add a checkpoint event handler for an activity:

a. Select an activity title in the canvas and open the Events view in the Properties pane.

b. In theCodeCheckPoint row, select Create a default handler.

c. Edit the code in the TestUserCode.cs tab. Locate the Todo section and add your
custom code. Follow the sample code in the comments and use auto-complete to create an
expression.

d. To access the properties of an activity, cast it beforehand. For example:

ConcatenateStringsActivity cat = args.Activity as

ConcatenateStringsActivity;

args.Checkpoint.Assert.Equals(cat.Prefix+cat.Suffix,

cat.Result);

e. Click File > Save All to save the TestUserCode.cs file and the test.

For details and examples, see "Coding Service Test Events" on page 641.

Tip: To ignore all event handlers for a step, select a handler and press DELETE to clear
the field in the grid. To remove the handler, youmust delete the codemanually in the
TestUserCode.cs tab.
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References

Main Window - Service Test
This window is Service Test's main area for creating and populating tests.

To
access

1. Select Start >[All] Programs > HP Service Test > HP Service Test.

Note: For details on accessing Service Test tools and files inWindows 8,
see "Accessing Service Test inWindows 8Operating Systems" on page
33.

2. Create or open a test.

Relevant
tasks

"How to Create an API Test" on page 383

User interface elements are described below (unlabeled elements are indicated by angle brackets):
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UI Elements Description

New. Opens the "New <Document> Dialog Box" (described on page 67).

Open. Opens an existing test.

Add. Adds a new or existing test to a solution.

Save. Saves the current test.

Tip: Select File > Save As to save the test to a new location.

Save All. Saves all open files.

ALM Connection. Opens the "ALM Connection Dialog Box" (described
on page 335) for defining server information and logging into an ALM
project.

SEV Settings. Opens the "Virtualized Services Settings Dialog Box"
(described on page 598), enabling you tomanage virtualized services
included with your test.

Enable Load Testing. Enables the test for Load Testing.

Note:

l This button adds amenu to theRun button, to run the test in Load
Testingmode.

l The button is disabled if you created the test with the Load Test
template.

l Run. Saves, compiles and runs the current project.

l Run Test in Load Testing Mode. Saves, compiles and runs the
current test in Load Test mode with themdrv driver.

Note: TheRun Test in Load Testing Mode option is only available
for Load Test type tests (created with the Load Test template or
converted from the standard template to a load test).

Insert Call to New Action. Opens the "Insert Call to New Action Dialog
Box" (described on page 516).
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UI Elements Description

Opens one of the Import dialog boxes:

l Import WSDL from URL or UDDI. Opens the Import Service from
URL or UDDI dialog box. For user interface details, see "Import/Update
WSDL from URL or UDDI Dialog Box" on page 489.

l Import WSDL from File or ALM Application Component. Opens
the Import WSDL dialog box for importing aWSDL from the file system
or HP ALM with HP Service Test Management.

Import .NET assembly. Opens the "Import .NET Assembly Dialog Box"
described on page 494.

Add REST Service. Opens the "Add/Edit REST Service Dialog Box"
described on page 495.

Solution Explorer Pane. Opens the Solution Explorer or brings it into
focus.

Toolbox Pane. Opens the Toolbox pane or brings it into focus.

Properties Pane. Opens the Properties pane or brings it into focus.

Data Pane. Opens the Data pane or brings it into focus.

Debug Pane. Brings the Breakpoints pane into focus.

Click the down arrow to select a different debug pane.

Last Run Results. Opens the Run Results Viewer.

Help. Opens the Service Test Help.

Document pane A series of tabs, to view and edit the file selected in the left pane: For
example:

l Visual display of the test (default)

l C Sharp files (.cs)

For details on the document pane, see "Document PaneOverview" on
page 132.
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UI Elements Description

Data Pane Displays the data from an Excel, XML, or JSON file, a database, or local
tables. You can use this data in your tests.

l New. Creates a new data node in the Data pane through:

n Excel File. Opens the "New/Change Excel Data Source Dialog Box"
(described on page 98) for creating a new set of data.

n Local Table. Opens the "New Local Table Data Source Dialog Box"
(described on page 106).

n XML. Opens the "New XMLData Source Dialog Box" (described on
page 100).

n Database. Opens the "Add New Database Data SourceWizard"
(described on page 102).

l Delete. Removes the selected data source.

For details, see "Data Pane" on page 96.

Debug Panes Displays panes to assist in debugging your user code files, including the
following panes:

l Breakpoints

l Call Stack

l Loaded Modules

l Threads

l Variables

l Console

l Watch

For details, see " Debug Panes Overview" on page 111.

Errors pane Displays errors, warning, andmessages about the test run. For details,
see "Errors Pane" on page 172.

The default location is the bottom pane.

Output pane Displays the Output log for the compilation and test run. For details, see
"Output Pane" on page 180.

The default location is the bottom pane.

Properties pane A series of screens showing the general properties, schemas, snapshots,
and event information for the activity selected in the canvas. For details,
see "Properties Pane" on page 184.

Note: Only active when viewing the canvas.
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UI Elements Description

Solution Explorer
pane

Displays the test components in a tree hierarchy. For details, see the
"Solution Explorer PaneOverview" on page 235.

The default location is the left pane.

Toolbox pane A tree view of all of the available activities. This includes built-in activities
and operations of imported services. For details, see the "Toolbox Pane"
on page 254.

The default location is the left pane.

Canvas User Interface
The canvas is displayed by default when you create a new test. It provides a visual representation
of the test flow and enables you to:

l Display test and action steps

l Manage steps and change their order

l Test individual steps using the Run Step command

l Openwizards and dialog boxes to resolve steps with missing information.

To access 1. Create or open a test or component.

2. Click on the test canvas tab.

See also "Activity Overview" on page 397
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This pane includes the following icons and context menu options:

l "Main User Interface Elements" below

l "Context MenuOptions" on next page

Main User Interface Elements
User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<Zoom
slider>

Enables you to zoom in or out of the test flow image.

Do one of the following:

l Click themagnifying glass with the plus sign to zoom in on (enlarge) the
test flow image.

l Click themagnifying glass with theminus sign to zoom out of (shrink) the
test flow image.

l Click and drag the zoom slider position handle left or right to zoom in or out of
the test flow image.

<Return to default size button>. Returns the test flow image to the default size
and the zoom slider position to the center.

Show
parameters

Enables you to select the level of information shown in the canvas, including:

l None:Shows only the number of input and output properties, adjacent to each
step or action frame. Clicking the number shows the property names.

l All:Displays the names of all the input and output properties and their links,
with the total number of properties.

l Links only. Displays only the links to other steps in the flow, and the number
of properties.

l Links and names. Displays the links to other steps, the name of the linked
properties. and the number of properties.

l Custom. Indicates that theShow parameters settings for some of the steps
weremodifiedmanually and not via the drop down. This entry is not selectable.

<Minimap display button>. Located above the test flow image on the right, and
displays or hides the test flow minimap in the lower left corner of the canvas.

Theminimap display button is highlighted in grey when theminimap is displayed,
and is not highlighted at all when theminimap is hidden.

<Test
flow>

Displays the test flow in a flow chart format, as well as any parameter details
available, as specified in theShow parameters drop-down list.
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UI Element Description

<Minimap> A small, high-level view of the entire test flow, useful when using large flows
and/or small screens.

Note:When you zoom out of the canvas, the area displayed in the canvas
becomes larger. This has the effect of shrinking the test flow image in the
minimap because theminimap displays the entire test flow.

Context Menu Options
Context menu items are accessible by right-clicking a step in a test or action.

Option Description

Cut Cuts the selected step and places it on the clipboard.

Copy Copies the selected step to the clipboard.

Delete Deletes the selected step.

Properties Opens the Properties Pane. For details, see "Properties Pane" on page 184.

Open Opens the selected action step in its own tab (for action steps inside the Test
Flow).

Paste Pastes the step currently on the clipboard to the location of the cursor.

Note:

l Available only after you add a step to the clipboard using eitherCut or
Copy.

l Only visible when clicking on the down arrow inside the Test Flow, Loop, or
Action frame.

Run Step Runs the current step using its properties from the Properties pane, and shows the
results in theRun Step Results pane. For details, see "Run Step Results Pane"
on page 219.

Note:

l This command is not available for all steps.

l If an input property was linked to an output property of a previous step, the
Run Step dialog box opens. This lets you set constant values for the step's
properties. For details, see "Run Step Dialog Box" on page 224.
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Troubleshooting and Limitations - Testing
Services

l XPath aggregate functions are not supported.

l Service Test cannot open with a license that was installed with Service Test 9.53.
Workaround: Reinstall the license using the Service Test LicenseManger, available from the
Start menu.

Note: For details on accessing Service Test tools and files inWindows 8, see "Accessing
Service Test inWindows 8Operating Systems" on page 33.

l The following restrictions apply when naming different API features:

Item Naming Convention

Action
(for tests)

n Must be unique in the test.

n Cannot begin or end with a space.

n Cannot exceed 1,023 characters.

n Cannot contain the following characters:
\ / : * ? " < > | % ' ! { }

Action parameter
(for tests)

n Case-sensitive.

n Must begin with a letter

n Cannot contain spaces.

n Cannot contain the following characters:
! @ # $ % ^ & * ( ) + = [ ] \ { } | ; ' : " , . / < >

Checkpoint n Cannot begin or end with a space.

n Cannot contain " (double quotationmark).

n Cannot contain the following character combinations:

o :=

o @@

Component
(for components)

n Cannot exceed 260 characters.

n Cannot contain, begin, or end with spaces.

n Cannot contain the following characters:
\ / : " ? < > | * ! { } ' % ;

n Cannot contain multibyte punctuation symbols and other
multibyte special characters, such as multibyte question
marks, multibyte spaces, andmultibyte brackets.
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Item Naming Convention

Data Table file ALM: cannot contain the following characters:
! % * { } \ | ' : " / < > ? ; ,

Data Table >
Parameter name (column
header)

n Must be unique in the sheet.

n Must begin with a letter or underscore.

n Can only contain the following:

o Letters

o Numbers

o Periods

o Underscores

ALM
file or folder name

Cannot exceed 90 characters (including the path).

Test name
(for tests)

n Cannot exceed 260 characters (including the path).

n Cannot begin or end with a space.

n Cannot contain the following characters:
\ / : * ? " < > | % ' ;

n Cannot contain multibyte punctuation symbols and other
multibyte special characters, such as multibyte question
marks, multibyte spaces, andmultibyte brackets.
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Concepts

Activity Overview
You create a test by double-clicking or dragging activities from the Toolbox pane into a canvas. The
Toolbox pane provides a collection of built-in standard activities for functional testing in areas such
as file and stringmanipulation, andmessaging through HTTP, FTP, and JMS.

The activities are divided into several categories:

l Standard Activities. This category includes the built-in activities, such as String
Manipulation, Database, Network, File System. For a complete list of the standard activities,
see "Standard Activity Types" on page 417.

l Local Activities. This category includes the activities that are stored as part of the test or
business component. These can be imported services such as Web or REST service
operations, and .NET assemblies. For details, see "Local Activities" on page 463.

l File System Activities. This category includes activities that reside in the file system on either
local or network drives. These are Local activities that youmoved into the file system repository
that can be shared between tests.

l ALM Activities. This category includes the activities that reside in the ALM repository. These
are Local activities that youmoved into the ALM repository that can be shared between tests.
This category only appears when a connection to an ALM server is open.

You can also create new custom activities, using the extensibility API provided with the product.
These will be stored under the Standard Activities. For details, see "Extensibility in Service Test"
on page 661.

For general information about the API interface and creating tests, see " Testing Services" on page
372.
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Tasks

How to Use Date and Time Activities
The following describes various tasks that you can perform with the Date/Time activities, such as
incrementing a date or finding a differential.

This task includes:

l "Increment a date and time" below

l "Find the difference between two date/time expressions" below

l "Format a date or time" on next page

Increment a date and time
1. Drag the Increment Date/Time activity onto the canvas.

2. Click the Input/Checkpoints tab in the Properties pane.

3. Set the Input property—Original Date/Time. Click the arrow in theValue column to open the
calendar. Click Today or select another date. You can also link to the output of another step
using the Link to a data source button.

4. To set a time unit such as hour, minute, seconds, or milliseconds, edit the expression in the
Original Date/Time row. For milliseconds, add a colon followed by a three digit millisecond
value, for example, 2011-01-01T01:30:00:040.

5. Set the Input property—Unit. Select a unit by which to increment: Milliseconds, Seconds,
Minutes, Hours, Days, Months, or Years.

6. Set the Input property—Amount. Use the scroller to set the amount of units to increment.

7. Select theResult check box in theCheckpoints pane to verify the response. Use the calendar
to select the expected date. If you need to set an expected value for a time unit, modify the
time units manually.

Find the difference between two date/time expressions
1. Drag theDate/Time Difference activity onto the canvas.

2. Click the Input/Checkpoints tab in the Properties pane.

3. Set the Input property— Date/Time A. Click the arrow in theValue column to open the
calendar. Click Today or select another date.

4. To set a time unit such as hour, minute, seconds, or milliseconds, edit the expression in the
Date/Time A row. For milliseconds, add a colon followed by a three digit millisecond value, for
example, 2011-01-01T01:30:00:040.

5. Set the Input property—Date/Time B. Click the arrow in theValue column to open the
calendar. Select a date for the second expression.

To set a time unit such as hour, minute, seconds, or milliseconds, follow the instructions in the
above step.

6. Set the Input property—Unit. Select the unit by which you want to measure the difference:
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Milliseconds, Seconds, Minutes, Hours, Days, Months, or Years.

7. To verify the response, select theDifference check box in theCheckpoints pane. Use the
scroller to specify the expected difference.

Format a date or time
1. Drag the Format Date/Time activity onto the canvas.

2. Click the Input/Checkpoints tab in the Properties pane.

3. Set the property Input Date/Time, the term to which you want to apply formatting. Click the
arrow in theValue column to open the calendar. Click the date displayed at the top of the
calendar window to use the current date, or select another date.

4. If you provide a date/time in a string (non-date) format, select a format in the Input Date/Time
Format row. Otherwise, leave this row empty.

5. Set the Format input property. Select a format from the drop down or type in a custom format
for the output expression. If your expression contains milliseconds, use an expression with a
time format and add a colon followed by fff, for example, dd/MM/yyyy hh:mm:ss:fff.

6. Select theResult check box in theCheckpoints pane to verify the response's format. Type
the expected expression. If you need to set an expected value for a time unit, modify the time
units manually.

How to Execute Database Commands or Retrieve Data
The following describes how to use database activities. For details about the database activities,
see "Database Activities" on page 420.

This task includes:

l "Open a connection" below

l "Add a Select Data step" on next page

l "Add an Execute Command step" on next page

l "Add database transaction activities" on next page

l "Add a Close Connection step" on page 401

Open a connection
This step is mandatory for all of the following steps.

1. Drag theDatabase > Open Connection activity onto the canvas.

2. Click the Input/Checkpoints tab in the Properties pane.

3. Select the Input property—Connection string.

4. Click theConnection Builder button in the right side of theValue column . The
Connection Builder dialog box opens. For details, see "Connection Builder Dialog Box" on page
453.

5. Paste in an existing string into the text area or click the Connection Builder button to open
Microsoft's Data Link Properties dialog box. Provide the required information and click OK. For
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details, click the dialog box's Help button.

Note: The database connectionmust be anOLE DB type.

6. If you want to validate the connection, set the checkpoint properties -Results andResults
message.

Add a Select Data step
1. Drag theDatabase > Select Data activity onto the canvas, below anOpen connection step.

2. Click the Input/Checkpoints tab in the Properties pane.

3. Set the Input property—Connection. Click the Link to a data source button by the right side
of theValue column . In the Select Link Source dialog box, select an earlierOpen
connection step in the left pane. In the right pane, select the step's result.

4. Set the Input property—Query string. Click theBrowse button in the right side of theValue
column to open theQuery Builder. Paste in a query or use theQuery Designer. For details,
see the "Query Builder Dialog Box" on page 455.

5. Optionally, set the Timeout, themaximum time allowed for the database response. To allow
an unlimited amount of time, enter 0.

Add an Execute Command step
1. Drag theDatabase > Execute Command activity onto the canvas, below theOpen

Connection step.

2. Click the Input/Checkpoints tab in the Properties pane.

3. Set the Input property—Connection. Click the Link to a data source button by the right side
of theValue column . In the Select Link Source dialog box, select an earlierOpen
connection step in the left pane. In the right pane, select the step's result.

4. Set the Input property—Command. Click the arrow to open an edit box, Paste in a command
and click OK.

5. Optionally, set the Timeout, themaximum time allowed for the database response.

Add database transaction activities
You can optionally add transaction activities to your test.

1. Drag theDatabase > Begin Transaction activity to the canvas after anOpen Connection
step and before the steps to be included in the transaction.

2. Drag aDatabase > Commit Transaction activity to the canvas after the database steps that
make up the transaction.

3. Drag aDatabase > Rollback Transaction activity to the canvas after the database steps that
make up the transaction.

Tip: A common use is to insert aCondition step to check a value after the database
commands. Set one branch withCommit Transaction and the other branch toRollback
Transaction. For details, see "The Canvas" on page 373.
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Add a Close Connection step
1. Drag theDatabase > Close Connection activity on to the canvas, after all of the database

steps.

2. Click the Input/Checkpoints tab in the Properties pane.

3. Set the Input property—Connection. Click the Link to a data source button in the right side
of theValue column . In the Select Link Source dialog box, select theAvailable steps
option. In the left pane, select the earlier step, Open Connection, In the right pane, select the
Connection node.

How to Send a Multipart HTTP Request
The following describes how to send an HTTP request that uses multiple parts. For details about
the properties, see the "Multipart Tab (Properties Pane)" on page 207.

This task includes:

l "Add an HTTP Step" below

l "Set the General properties" below

l "Set the properties for the first part" below

l "Set the properties for the next parts" below

1. Add an HTTP Step
Drag theNetwork > HTTP activity onto the canvas.

2. Set the General properties

Open theGeneral tab in the Properties pane. Set the properties as described in the
"General Tab (Properties Pane)" on page 195.

3. Set the properties for the first part

Open the Input/Checkpoints tab in the Properties pane. Set the properties for the first part
as described in the "Network Activities" on page 426.

4. Set the properties for the next parts

a. Open theMultipart tab in the Properties pane.

b. Select theEnable Multipart option.

c. Set themultipart type and global header information.

d. Add elements to the Parts array corresponding to the number of parts.

e. Set the properties for the parts as described in the "Multipart Tab (Properties Pane)" on
page 207.

f. If you want to validate a response, select the box in theValidate column and provide the
expected values.
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How to Create a Call to a Java Class
The Call Java Class activity lets you to add Java steps to your test script. This feature enables you
to incorporate existing Java code into your test.

This task describes how to create the Java call and includes the following steps:

l "Set the global Java settings - optional" below

l "Implement the Java interface" below

l "Compile the Java source code" below

l "Package your custom step - optional" below

l "Add a Call Java Class activity" below

l "Open the Java Class Setting dialog box" on next page

l "Set the Java Call properties" on next page

l "Provide Input property values" on next page

1. Set the global Java settings - optional
To set global VM (Virtual Machine) settings, select the Start or End steps in the canvas, and

open the Test Settings view in the Properties pane. For details, see the "Test Settings Tab
(Properties Pane)" on page 209.

2. Implement the Java interface
Change to the <installation_folder>\addins\ServiceTest\
JavaCall\Java Interface\src\hp\st\ext\java folder and create an
implementation for the java interface. For an example, see the sample subfolder.

This interface includes the essential information for the Java call, such as input properties,
output properties, and a point of entry.

3. Compile the Java source code
Compile the java files located in the <installation_folder>\
addins\ServiceTest\JavaCall\Java Interface\src\hp\

st\ext\java folder.

Tip: To determine which JDK to use for, check the version of Java JRE installed with
Service Test. Open the <installation_folder>/
jre/bin folder and right-click the java.exe file. Select Properties and open the
Version tab.

4. Package your custom step - optional
Package your java classes into a .jar file. This is optional, since you can also provide a
package root for the class.

5. Add a Call Java Class activity
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Expand the Java node in the Toolbox pane, and drag theCall Java Class activity onto the
canvas.

6. Open the Java Class Setting dialog box

Select the Java step in the canvas, and click the Input/Checkpoints tab in the Properties
pane. Click the Java Class button to open the "Java Class Dialog Box" (described on page
459.

If you need to embed the jar in the script, youmust select the check box before browsing for
and selecting the class file.

For general guidelines, see "Java Testing" on page 379.

7. Set the Java Call properties
In the Java Class dialog box:

a. Provide a classpath. If you packaged your Java step, click theBrowse button adjacent to
the Jar field and point to a .jar file. Alternatively, click theBrowse button adjacent to the
Package root field and point to a package root folder. To embed the jar and save it with the
test, select Embed Jar in Test. Due to a technological limitation, if you intend to specify a
class file, youmust select theEmbed Jar in Test option before you browse for the class
file.

b. Click theBrowse button adjacent to theClass file field to locate the class within the .jar
file or the folder. Make sure it is a class that implements theServiceTestCall interface.

c. To provide additional classpaths, click the Jar or Folder buttons in theAdditional
Classpaths section and browse to a .jar file or classpath folder. Click Add to move the
contents into the list.

d. Click OK to save the Java Call settings.

For user interface details, see the "Java Class Dialog Box" on page 459.

8. Provide Input property values

In the Properties pane's Input/Checkpoints tab , provide values for the step's input
properties.

How to Retrieve Messages from a JMS Queue
This task describes how to send, receive and browse JMS messages on a JMS queue.

This task includes the following steps:

l "Define the global JMS settings" on next page

l "Prepare amessage to send to the queue" on next page

l "Add a SendMessage step to your test" on next page

l "Add a SendMessage with security and attachments - optional" on next page

l "Add a ReceiveMessage step to your test - optional" on page 405

l "Browse themessage queue - optional" on page 405
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l "Set checkpoints- optional" on page 406

l "Run the test and view the run results" on page 407

1. Define the global JMS settings
Define global JMS settings such as the JNDI details according to the specifications of your
JMS messaging server. Select theStart orEnd step in the canvas and open the Test Settings

view in the Properties pane. For details, see the "Test Settings Tab (Properties Pane)" on
page 209.

2. Prepare a message to send to the queue
Prepare themessage you want to send to the queue in one of the following ways:

n Prepare an expression and type it into theMessage property area.

n Use other activities to generate the string, for exampleConcatenate String, Trim String,
and so forth.

3. Add a Send Message step to your test
a. In the Toolbox pane, expand theStandard Activities > JMS node. Drag aSend Message

to JMS Queue or aSend and Receive Message from JMS Queue activity onto the
canvas.

b. Select the step and click the Properties pane's Input/Checkpoints tab. Set the send-
related input properties:

o Send queue name

o Message

o JMS send properties

c. If you used another step to generate themessage text, link its output to theMessage
property.

4. Add a Send Message with security and attachments - optional
To send aWeb servicemessage via JMS with attachments and security setting, such as
tokens and signatures:

a. Drag in or select theWeb service step in the canvas and disable its Send Request to
Service option in the Properties pane. For details, see "Properties Pane Tabs" on page
186.

b. Set the security options for the service. For details, see "How to Set Security for aWeb
Service on the Port Level" on page 547.

c. Include any attachments. For details, see "Attachments Tab (Properties Pane)" on page
187.

d. Drag in a SendMessage to JMS Queue activity onto the canvas.

e. In the Properties pane's Input/Checkpoints tab, select the link icon for theMessage
property. The Select Link Source dialog box opens. For details, see the "Select Link
Source Dialog Box" on page 630.
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f. In the Select Link Source dialog box, select theWeb service step in the left pane. In the
Output property section, double-click on theRaw Request property. This attaches the
security and attachment data to themessage.

g. Define any other JMS properties as you normally would. For property details, see "JMS
Activities" on page 431.

5. Add a Receive Message step to your test - optional
a. To retrieve amessage from the queue, drag aReceive Message from JMS Queue

activity onto the canvas. If you added aSend and Receive Message to JMS Queue
activity in the previous step, you can skip this step.

b. Select theReceive Message from JMS Queue step and open the Properties pane's
Input/Checkpoints tab. Set the receive-related input properties: Receive queue name and
JMS receive message selector. For property details, see "JMS Activities" on page 431.

6. Browse the message queue - optional
a. To browse themessages in the queue without consuming them, drag aBrowse JMS

Queue Messages activity onto the canvas, outside of the Test Flow. Make sure that a
Send (and Receive) Message from JMS Queue step precedes theBrowse JMS Queue
Messages step.
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b. Click the Properties pane's Input/Checkpoints tab, and select theBrowse JMS Queue
Messages step. Set the browse-related input properties:

o Queue name. Provide a queue name or link to the queue name from an earlier step. For
IBMWebsphere's MQ, if you specify a queue name that does not exist, a new queue
will be created during the test run.

o JMS receive message selector. The selector lets you filter themessages list. For
details about these properties, see "JMS Activities" on page 431.

7. Set checkpoints- optional
a. Select theBrowse JMS Queue Messages step and click in the Properties pane's

Checkpoints section.

b. Select the properties you want to validate and provide values.

c. Use theBrowse JMS queue messages output properties to validate themessages on the
queue. For example, you can check the value of a specific property or check the number of
messages on the queue.
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8. Run the test and view the run results
Run the test. In the Run Results Viewer, expand the checkpoint nodes and verify that the
actual values match the expected values. Click the link in the report to display the JMS queue
messages in a separate browser. Compare thesemessages with those shown in the queue on
the JMS application server's console.

How to Receive Messages Through JMS Topics
This task describes how to work with subscriptions to JMS topics.

This task includes the following steps:

l "Set the global JMS settings" below

l "Subscribe to a topic" below

l "Publish amessage to the topic" below

l "IncludeWeb service security and attachments - optional" on next page

l "Receive themessage through the topic" on next page

1. Set the global JMS settings
Set global JMS settings such as the JNDI details according to the specifications of your JMS
messaging server. Click in the canvas outside of the Test Flow, and open the Test Settings

tab in the Properties pane. For details, see the "Test Settings Tab (Properties Pane)" on
page 209.

2. Subscribe to a topic
Add aSubscribe to JMS Topic step and provide values for its input properties as described in
"JMS Activities" on page 431.

3. Publish a message to the topic
Add aPublish Message to JMS Topic step and provide values for its input properties.
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4. Include Web service security and attachments - optional
To publish aWeb servicemessage via JMS with attachments and security setting, such as
tokens and signatures:

a. Drag in or select theWeb service step in the canvas and disable its Send Request to
Service option in the Properties pane. For details, see "Properties Pane Tabs" on page
186.

b. Set the security options for the service. For details, see "How to Set Security for aWeb
Service on the Port Level" on page 547.

c. Include any attachments. For details, see "Attachments Tab (Properties Pane)" on page
187.

d. Drag aPublish Message to JMS Topic step onto the canvas.

e. In the Properties pane's Input/Checkpoints tab, select the link icon for theMessage
property. The Select Link Source dialog box opens. For details, see the "Select Link
Source Dialog Box" on page 630.

f. In the Select Link Source dialog box, select theWeb service step in the left pane. In the
Output property section, double-click on theRaw Request property. This attaches the
security and attachment data to themessage.

g. Define any other JMS properties as you normally would. For property details, see "JMS
Activities" on page 431.

5. Receive the message through the topic
Drag aReceive Message from JMS Topic activity onto the canvas. Use the topic and
subscription name that you defined in the previous steps.

How to Retrieve Messages from an MQ Queue
This task describes how to work with Put andGet on an IBMWebsphereMQ queue.

This task includes the following steps:

l "Prerequisite" on next page

l "Connect to theMQQueueManager" on next page

l "Put amessage on the queue" on next page

l "Browse themessage queue - optional" on next page

l "Get amessage from the queue" on next page

l "Commit or Backout the actions - optional" on next page

l "Disconnect from theMQQueueManager" on next page

l "Define event handlers - optional" on next page

l "Set checkpoints - optional" on next page
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1. Prerequisite
Youmust have theMQ client installed on all machines upon which you want to run the test.

2. Connect to the MQQueue Manager
A connection stepmust precede all steps that use the specified QueueManager. Drag an IBM
Websphere MQ > Connect to MQ Queue Manager step onto the canvas and provide the
connection details in the Properties pane's Input/Checkpoints tab. For details see "Connect to
MQQueueManager - Input Properties" on page 438.

3. Put a message on the queue
Drag aPut Message to MQ Queue step onto the canvas, below the connection step. The
canvas automatically links theMQManager property to themost recent Connect to MQ
Queue Manager step. Set input values as described in "Put Messages toMQQueue - Input
Properties" on page 441.

4. Browse the message queue - optional
To browse themessages in the queue without consuming them:

a. Drag aBrowse Messages in MQ Queue activity onto the canvas.

b. Select the step in the canvas and open the Properties pane's Input/Checkpoints tab.

c. Set the browse-related properties. For details, see "BrowseMessages inMQQueue - Input
Properties" on page 440.

5. Get a message from the queue
Drag aGet Message from MQ Queue step onto the canvas, below the connection step. Set
the input values as described in "Get Messages fromMQQueue - Input Properties" on page
442.

6. Commit or Backout the actions - optional
To commit the actions performed until a certain point, drag aCommit MQ Pending Messages
activity onto the canvas. To roll back changes drag aBackout MQ Pending Messages
activity onto the canvas at the relevant location.

7. Disconnect from the MQQueue Manager
A disconnection stepmust follow all steps that use the specified QueueManager. Drag a
Disconnect from MQ Queue Manager step onto the canvas, and provide the connection
details in the Properties pane's Input/Checkpoints tab. For details see "Disconnect fromMQ
QueueManager - Input Properties" on page 439.

8. Define event handlers - optional
To customize or automate the actions against theMQ server, use theMQ event handlers.
Click the Events button in the Properties pane and double-click the appropriate event—a
standard event or one of theMQ-specific events, such as BeforeMQGetMessage or
AfterMQGetMessage. Customize the code in the TestUserCode.cs tab. For details, see
"Coding Service Test Events" on page 641 and the "Events Tab (Properties Pane)" on page
193.

9. Set checkpoints - optional
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To validate the response data, select the step and click within the Properties pane's
Checkpoints section. Indicate the properties you want to validate and provide values. Run the
test and view the run results.

How to Receive Messages Through MQ Topics
This task describes how to retrievemessages published toMQ topics.

This task includes the following steps:

l "Prerequisite" below

l "Connect to theMQQueueManager" below

l "Subscribe to a topic" below

l "Publish amessage to the topic" below

l "Receive themessage through the topic" below

l "Unsubscribe from a topic" below

l "Disconnect from theMQQueuemanager" on next page

l "Define event handlers - optional" on next page

1. Prerequisite
Youmust have theMQ client installed on all machines upon which you want to run the test.

2. Connect to the MQQueue Manager
A connection stepmust precede all steps that use the specified QueueManager. Drag a
Connect to MQ Queue Manager step onto the canvas, and provide the connection details in
the Properties pane's Input/Checkpoints tab. For details see "Connect to MQQueueManager
- Input Properties" on page 438.

3. Subscribe to a topic
Add aSubscribe to MQ Topic step. The canvas automatically links theMQManager property
to themost recent Connect to MQ Queue Manager step. Provide values for its input
properties as described in "Subscribe toMQTopic - Input Properties" on page 446.

4. Publish a message to the topic
Add aPublish Message to MQ Topic step and provide values for its input properties as
described in "PublishMessage toMQTopic - Input Properties" on page 447.

5. Receive the message through the topic
Drag aReceive Message from MQ Topic activity onto the canvas. Use the topic and
subscription name that you set in the previous steps. For details, see "ReceiveMessage from
MQTopic - Input Properties" on page 448.

6. Unsubscribe from a topic
Add anUnsubscribe from MQ Topic step and provide values for its input properties as
described in "Unsubscribe fromMQTopic - Input Properties" on page 446.
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7. Disconnect from the MQQueue manager
A disconnection stepmust follow all steps that use the specified QueueManager. Drag a
Disconnect from MQ Queue Manager activity onto the canvas. The canvas automatically
links to themost recent opened connection.

8. Define event handlers - optional
To customize or automate the actions against theMQ server, use theMQ event handlers.
Click theEvents button in the Properties pane and double-click the appropriate event—a
standard event or one of theMQ-specific ones. Customize the code in the
TestUserCode.cs tab. For details, see "Coding Service Test Events" on page 641 and the
"Events Tab (Properties Pane)" on page 193.

How to Call Tests from Other Applications
This task describes how to incorporate tests from other HP applications to provide a unified testing
solution. These applications include HP Unified Function Testing, earlier versions of Service Test
andQuickTest Professional, and LoadRunner's Virtual User Generator. For details, see
"Automated Testing Tool Integration" on page 380.

This task includes the following steps:

l "Prerequisites" below

l "Call an API Test action or test" below

l "Add a LoadRunner script activity" on next page

1. Prerequisites
Make sure you have installed the application whose test/script you want to call:

n Service Test. To call a test last modified in a previous version of Service Test, make sure
the test was last modified with Service Test 11.10 or higher.

n LoadRunner's Virtual User Generator.Make sure you have HP LoadRunner version
11.00 or later. Generate a test with the Virtual User Generator, or use a test that you enabled
for load testing in this application.

2. Call an API Test action or test
a. Make sure the action or test you want to call has been saved and run successfully at least

once.

b. Expand theHP Automated Testing Tools node in the Toolbox pane. Drag theCall API
Action or Test activity onto the canvas.

c. Open the Properties pane's Input/Output Properties tab and click theSelect Action or
Test button. Select a test last modified with Service Test 11.10 or higher.

d. To update a test or action that has already been loaded, click Refresh.

e. To specify a custom directory for the results, click theBrowse button in theResults
directory row in theGeneral view tab.

f. Click the Properties pane's Input/Output Properties tab and set the property values, if
needed.
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Note:

o The property list remains empty until you select a test.

o If the test you are calling has no input or output parameters, the Input/Output
Properties tab will be empty.

g. Add other relevant steps to your test. You can link subsequent input properties to the
output properties of the step. Click the Link to data source button in the property's
row to create the link. For details, see "Select Link Source Dialog Box" on page 630.

h. If the API Test step input must be a string (when the result of a previous step was XML),
add anXML to String activity after the call to the Service Test action or test. For details,
see "XML Activities" on page 451.

i. Save and run the test.

3. Add a LoadRunner script activity
a. In the Toolbox pane, expand theHP Automated Testing Tools node. Drag theCall

Virtual User Generator Script activity onto the canvas.

b. Open the Properties pane's General view, and click the script selection button . Select
a VuGen (Virtual User Generator) .usr script file.

c. Add other relevant steps to your test.

d. Save and run the test.

How to Validate an XML file
This task describes how to validate the code in an XML string. The Validate XML activity evaluates
an XML string and checks its compliance with an XSD schema.

Since theValidate XML activity reads a string, you need to specify the actual XML string—not just
a file name. If the string is short, you can copy it into theValue column directly. For more complex
XML content, you can read the XML file using aRead from File activity.

This task includes the following steps:

l "Provide the XML code to validate" below

l "Add a Validate XML activity" on next page

l "Connect the steps - if using Read from File" on next page

l "Specify an XSD file" on next page

l "Set a checkpoint - optional " on next page

l "Run the test" on next page

1. Provide the XML code to validate
To provide the XML code, you can paste an XML directly into theValue column, or read the
contents from the file using theRead from File activity.
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To enter XML code directly, copy the XML string from the source document and paste it into
theValue column.

To read the XML from a file:

a. Drag the File System > Read from File activity onto the canvas.

b. Click the Input/Checkpoints tab in the Properties pane. Browse to the XML file you want to
validate.

2. Add a Validate XML activity
Drag theXML > Validate XML activity onto the canvas. If you used aRead from File step,
drag this activity beneath the step.

3. Connect the steps - if using Read from File
If you used aRead from File step to obtain the XML, follow these steps. Otherwise, skip to
step 4.

a. Click the Input/Checkpoints tab in the Properties pane. Click in theValue column of the
XML String property and click the Link to a data source button .

b. In the Select Link Source dialog box, select theAvailable steps option. In the right pane,
select theRead from File step's output property, Content, and click OK.

4. Specify an XSD file
a. Select theValidate XML step in the canvas. Click the Input/Checkpoints tab in the

Properties pane, Browse to anXSD file.

b. To import the XSD file into the test's folder, set theXSD file to test folder option to true.
This is useful if you plan on saving the test on ALM. Setting this option will make the XSD
file available to anyone who loads the test.

5. Set a checkpoint - optional
If you want to verify the results:

a. In the Input/Checkpoints tab in the Properties pane, click in the Checkpoints section.

b. Select theValid check box. Set the value to true to verify that the XML code complies
with the XSD. Set the value to false to confirm that the XML code did not comply with the
XSD.

c. To check for a specific error, set theValid value to false, and specify the expected error
in theError row. You can link to a data source containing the expected value.

6. Run the test
Run the test. TheOutput tab and Run Results Viewer will display the results and indicate
whether the XML is in compliance with the XSD and details about the errors.

How to Transform an XML File
This task describes how to transform an .xml file to a different structure based on an .xslt file.
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Since the Transform XML activity reads a string, you need to specify the actual XML string—not
just a file name. If the string is short, you can copy it into theValue column directly. For more
complex XML content, you can read the XML file using aRead from File activity.

This task includes the following steps:

l "Provide the XML code to transform" below

l "Add a Transform XML activity" below

l "Connect the steps - if using Read from File" below

l "Specify an XSLT file" below

l "Set a checkpoint - optional " below

l "Run the test" on next page

1. Provide the XML code to transform
To provide the XML code, you can paste an XML directly into theValue column, or read the
contents from the file using theRead from File activity.

To enter XML code directly, copy the XML string from the source document and paste it into
theValue column.

To read the XML from a file:

a. Drag the File System > Read from File activity onto the canvas.

b. Click the Input/Checkpoints tab in the Properties pane. Browse to the .xml file you want
to transform.

2. Add a Transform XML activity
Drag theXML > Transform XML activity onto the canvas. If you used aRead from File step,
drag this activity beneath the step.

3. Connect the steps - if using Read from File
If you used aRead from File step to obtain the XML, follow these steps. Otherwise, skip to
the next step.

a. Click the Input/Checkpoints tab in the Properties pane. Click in theValue column of the
XML String property and click the Link to a data source button .

b. In the Select Link Source dialog box, select theAvailable steps option. In the right pane,
select theRead from File step's output property, Content, and click OK.

4. Specify an XSLT file
a. Select the Transform XML step in the canvas. Click the Input/Checkpoints tab in the

Properties pane. Browse to an .xslt file.

b. To import the .xslt file into the test's folder, set theXSLT file to test folder option to
true. This is useful if you plan on saving the test on ALM. Setting this option will make the
.xslt file available to anyone who loads the test.

5. Set a checkpoint - optional
If you want to verify the results, select the Transformed XML check box in theCheckpoints

HP Service Test (11.52)Page 414 of 705

User Guide
Chapter 23: Standard Activities



section and specify the expected result. You can link to a data source containing the expected
value.

6. Run the test
Run the test. TheOutput tab and the Run Results Viewer will indicate whether the transform
operation succeeded.

How to Compare XML Strings
This task describes how to compare two XML strings and view the differences.

This task includes the following steps:

l "Add an Compare XMLs step to the canvas" below

l "Enter the original XML string" below

l "Enter the new XML string" below

l "Set the ignore options - optional" below

l "Save the settings - optional" below

l "Set a checkpoint - optional" below

l "View the results" on next page

1. Add an Compare XMLs step to the canvas
Drag theXML > Compare XMLs activity onto the canvas.

2. Enter the original XML string
Copy the original XML string onto the clipboard.

Click the Input/Checkpoints tab in the Properties pane. Click the down arrow in theValue
column of the XML string 1 property and paste the original XML string into the box.

3. Enter the new XML string
Copy themodified XML onto the clipboard and paste it into the XML string 2 row.

4. Set the ignore options - optional
a. To ignore any differences in the order of the elements, set Ignore element order to true.

b. To ignore any differences in namespaces, set Ignore namespaces to true.

c. To ignore differences in a specific node, expand the Ignore XPaths array and add one or
more array elements with the XPath expression you want to ignore.

5. Save the settings - optional
To save all of your ignore settings for future use, click theSave options button.

6. Set a checkpoint - optional
To set a checkpoint which indicates whether or not there was a change, click theValidate
check box in the Checkpoints area.
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n To verify that there was a change, set Are Equal to false.

n To verify that there was no change, set Are Equal to true.

7. View the results
a. Run the test. In the Run Results Viewer, expand the results.

b. Select theCompare XMLs node in the results tree in the left pane.

c. In theCaptured Data pane, click theReport File link. The report shows both XML strings.
The report's legend indicates the nature of the change: added, removed, changed, and so
forth.

d. Scroll down in theCaptured Data pane for the XMLComparison Results table. This table
lists the changes, showing the old and new element and attribute names with their values.
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This section describes the Standard activity groups:

Flow Control Activities 417

Miscellaneous Activities 419

StringManipulation Activities 419

System Activities 419

Math Activities 419

Date and Time Activities 420

File System Activities 420

Database Activities 420

FTP Activities 424

Network Activities 426

JSON Activities 430

Java Activities 431

JMS Activities 431

Load Testing Activities 437

IBMWebSphereMQActivities 437

HP Automated Testing Tools Activities 449

SAP Activities 449

XMLActivities 451

Flow Control Activities

The following activities allow you to control the flow of the test using loops, conditions, breaks, and
delays:

l Condition. Enables you to use a branchingmechanism based on the value of a property.

l Loop. A loop framewhose properties can be set independently of the Test Flow. The loop types
are For loop, Do While loop, and For Each loop.

l Break. Halts the test execution.

l Continue. Resumes the test execution after a break.
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l Sleep. Pauses the test execution for a specified amount of time.

l Wait.Waits a specified amount of time for a trigger event before releasing a step for execution

For details, see "The Canvas" on page 373.

Loop Activity
Loop - Input Properties

The following iteration settings are available for the Test Flow or other custom loops:

UI
Elements

Description

Do While
Loop -
Use
condition

Repeats the loop as long as the specified condition is met:

l Variable. The variable to evaluate. Use the Select Link Source button to
enter a data source expression.

l Operator. A comparison operator relevant to the variable such as =, !=,
Contains, Starts andRegex.

l Value. The value with which to compare the result.

Do While
Loop -
Use event

Performs iterations until the event returns True. This mode is useful for complex
conditions that can be defined in an event handler. When you select this option, the
Input Properties grid opens.

l Click to define properties.

l Click to open theEvents view. Click Create a default handler in the
Handler column.

l Modify or add code to the event handler method that defines your condition.

For Each
Loop

Performs an iteration for each element in the associated array or collection of
objects. Data is selected using theSelect Link Source button .

Note:When you delete data from a data table, it continues to run an iteration
for that row, with empty values. To remove an entire row of a data, click the
row and select Delete from the shortcut menu (only with Excel installations).

For Loop Performs the Test Flow or custom loop the number of times that you specify in the
Number of Iterations box.

Wait Activity
For asynchronous steps, theWait activity waits a specified amount of time for a trigger event
before releasing the associated step. This activity is used in conjunction with theHTTP Receiver
steps andWeb Service calls imported as server response steps. For details, see "Asynchronous
Service Calls" on page 601.

Wait - Input Properties

To view the Input properties, click the Input/Checkpoints tab in the Properties pane.

HP Service Test (11.52)Page 418 of 705

User Guide
Chapter 23: Standard Activities



Property (A-Z) Description

Action on timeout The action to take when the timeout is reached without the completion
events: Fail orContinue.

Completion event
names

A list of the completion events that were configured in prior receiver steps.

Start timeout after
step

The time after step execution from when to beginmeasuring the timeout
interval.

Timeout The timeout in milliseconds. Negative values indicate that there is no
timeout.

Miscellaneous Activities

This activity group provides access to the following activities:

l Custom Code. Enables you to program a step to execute your own activity. Use theAdd
button to define new input or output properties.

l Set Test Variable. Defines global variables for your test.

l Run Program. Invokes an application on the current machine.

l End Program. Closes an application that is running.

l Report Message. Sends a custommessage to the Run Results.

String Manipulation Activities

This activity group provides access to the following string related activities:

l Concatenate Strings. Joins two strings.

l Replace String. Replaces part of a string with an alternate string. You can provide an array of
replacement strings for use with iterations.

l Substring. Extracts the characters between two specified locations of a string.

l Trim String. Removes whitespace characters from the beginning or end of a string.

System Activities

This activity group provides access to the following operating system activities:

l Set OS Environment Variable. Sets the value of an operating system variable.

l Get OS Environment Variable. Retrieves the value of an operating system variable.

Math Activities

This activity group provides access to the followingmath related activities:
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l Add. Adds two numbers.

l Subtract. Subtracts one number from another.

l Multiply.Multiplies two numbers.

l Divide. Divides one number by another.

Date and Time Activities

This activity group provides access to the following date and time related activities:

l Increment Date. Adds date or time units to a date/time string.

l Date/Time Difference. Calculates the difference between two date/time strings.

l Format Date/Time. Formats a date/time string.

File System Activities

This activity group provides access to the following file system related activities:

l File Exists. Searches for a specific file, or group of files, if you use a wildcard expression. It
returns true if the file exists.

l Folder Exists. Searches for a specific folder. It returns true if the folder exists.

l File Copy. Copies a file to a new destination.

l File Move.Moves a file to another destination.

l File Create. Creates a new file.

l File Delete. Deletes a file.

l File Rename. Renames a file.

l Write to File.Writes to an existing or new file.

l Read from File. Retrieves text from a file.

l Get Folder Contents. Gets the contents of a folder—file names, folder names, or both.

Database Activities

This activity group provides access to database related activities:

l Open Connection. Opens a connection to a database using the specified connection string.

l Close Connection. Closes an open database connection.

l Select Data. Executes a SELECT type SQL statement that retrieves data.

l Execute Command. Executes an SQL statement that does not retrieve data from the
database, such as UPDATE, DELETE, and so forth.

l Begin Transaction. Begins a database transaction.

HP Service Test (11.52)Page 420 of 705

User Guide
Chapter 23: Standard Activities



l Commit Transaction. Commits a database transaction.

l Rollback Transaction. Rolls back a database transaction from a pending state.

Open/ Close Connection
This activity opens or closes a connection to a database using the specified connection string.

Open/ Close Connection - Input Properties

Property Description

Connection String(for
Open Connection)

AnOLE DB database connection string. You can provide a value in
one of the following ways:

l Type it in manually.

l Open theConnection Builder . For details, see the
"Connection Builder Dialog Box" on page 453.

l Use the Link to a data source button to create a link to the
string.

Connection (for Close
Connection)

A link to the output of anOpen Connection step. Use the Link to
a data source button to create a link.

Open/ Close Connection and Transaction Activities - Checkpoints

Property (A-Z) Description

Result Indicates whether the connection is active (true) or closed (false).

Result
Message

A message indicating success or an informational message from the
database.

Select Data
This activity executes a SELECT type SQL statement that retrieves data.

Select Data - Input Properties

Property Description

Connection A link to the output of a previously opened connection string. Use the Link to a
data source button to create the link.

Query
string

An SQL SELECT statement. You can provide a string in one of the following
ways:

l Type it in manually.

l Open theQuery Builder . For details, see the "Query Builder Dialog Box"
on page 455.

l Use the Link to a data source button to create a link to the string.
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Property Description

Timeout Themaximum time to allow for executing the database command. A value of zero
indicates no time limit.

Default: 30 seconds

Select Data - Checkpoints

Property
(A-Z)

Description

Count The number of rows returned by the command.

Result Indicates whether the operation has been successfully completed: true or false.

Result
table

An array of returned rows. The row elements are column names. You can set an
expected value for each column of each row:

l The columns changed due to parameterization.

l A columnwas removed since the original query.

l You don't have access to database when designing the test.

Note: In order to see the table column, you need to generate the output at least
once. You can do this by selecting theGenerate output option in the Query
Builder, or by clicking theGenerate Output button in theCheckpoints pane.

Tip: Use theManage Columns button to remove or replace columns when:

Execute Command
This activity executes a SQL statement that does not retrieve data from the database, such as
UPDATE, DELETE, and so forth.

Execute Command - Input Properties

Property
(A-Z)

Description

Command An SQL statement that does not retrieve data, such as UPDATE or DELETE. You
can provide a string in one of the following ways:

l Type it in manually in the drop-down edit box.

l Use the Link to a data source button to create a link to the string.

Connection A link to the output of a previously opened connection string. Use the Link to a
data source button to create the link.
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Property
(A-Z)

Description

Timeout Themaximum time to allow for executing the database command. A value of zero
indicates no time limit.

Default: 30 seconds

Execute Command - Checkpoints

Property (A-
Z)

Description

Affected
rows

The number of rows affected by the command.

Result Indicates whether the command executed successfully: true or false.

Result
Message

Success or upon failure, amessage issued by the database indicating the
nature of the failure.

Begin Transaction
This activity begins a database transaction.

Begin Transaction - Input Properties

Property
(A-Z)

Description

Connection A link to the output of a previously opened connection string. Use the Link to a
data source button to create the link.

Isolation
level

The isolation level of the transaction: Default, Chaos, Read Committed,
Read Uncommitted, Repeatable Read, Serializable, or Snapshot.

For details, see http://msdn.microsoft.com/en-
us/library/system.data.isolationlevel.aspx.

Begin Transaction - Checkpoints

Property (A-Z) Description

Result Indicates whether the connection is active (true) or closed (false).

Result
Message

A message indicating success or an informational message from the
database.

Commit/Rollback Transaction
These activities commit a database activity and roll back a database activity from a pending state.

Commit/Rollback Transaction - Input Properties
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Property Description

Transaction A link to an open transaction. Use the Link to a data source button to create
a link to the output of aBegin Transaction step.

Commit/Rollback Transaction - Checkpoints

Property (A-Z) Description

Result Indicates whether the connection is active (true) or closed (false).

Result
Message

A message indicating success or an informational message from the
database.

FTP Activities

This activity group provides activities that allow you to perform FTP operations, such as FTP
Upload and FTP Download.

l FTP Download. Downloads a file or directory from an FTP server.

l FTP Upload. Uploads a file or directory to an FTP server.

l FTP Rename. Renames an existing file or directory on an FTP server.

l FTP File Delete. Deletes a file on an FTP server.

l FTP File Get Size. Gets the size of a file on an FTP server.

l FTP Directory Delete. Deletes a empty directory on an FTP server.

l FTP Directory Create. Creates a new directory on an FTP server.

l FTP Directory Get Content. Lists the content of a directory on an FTP server.

FTP - General Properties
To view theGeneral properties, click theGeneral view button in the Properties pane. The following
table describes the FTP-specific properties.
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Property
(A-Z)

Description

Client
certificate

l . Browse Certificates. Opens the Select Certificate dialog box. To see the
icon, click in the top level row of theClient certificate section, in theValue
column. For details, see the "Select Certificate Dialog Box" on page 579.

l A Choice element indicating the source of the client certificate for secure FTP
connections:

n Use file system certificate: The expanded node provides the full path of the
certificate file.

n Use Windows store certificate: The expanded node lists the following
properties Store location, Store name, X509 find type, andX509 find
value.

l Password. The certificate's password.

Enable
SSL

Indicates whether to establish a secure FTP connection: true or false.

Proxy The proxy server information: Server, Username andPassword.

Timeout The FTP request timeout in milliseconds.

FTP - Input Properties
To view the Input properties, click the Input/Checkpoints tab in the Properties pane.

Property (A-Z) Activity Description

Directory name FTP Directory Create A name for the new directory.

Directory URL
path

FTP Upload The URL in which the file or directory will be
created.

Local file path FTP Download and FTP
Upload

FTP Download: The location in which to
download the file.

FTP Upload: The location from which to upload
the file.

New file name FTP Rename A new name for the file.

Password All The password for accessing the FTP server.

Transfer mode FTP Download and FTP
Upload

The data transfer method: ASCII (default) or
Binary.

URL path All except FTP Upload The URL of the file or directory on the FTP
server.

User ID All The username for accessing the FTP server.
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FTP - Checkpoints
To view the checkpoint properties, select the Input/Checkpoints tab in the Properties pane and
click in the lowerCheckpoints pane.

Property
(A-Z)

Description

File size The size of the specified file. (FTP File Get Size activity)

Result An indicator whether the operation succeeded: true or false.

Result
array

An array of the directory details for all directories under the specified URL path. (FTP
Directory Get Content activity)

The details include: Name, Type, Flags, Owner, Group, Size, andDate created.

Network Activities

This activity group provides activities that enable you to send and receive HTTP and SOAP
requests.

TheHTTP Receiver activity is useful for asynchronous testing. For task details, see "How to
Create a Test for an Asynchronous Web Service" on page 605.

This activity group contains the following activities:

l HTTP Request. This activity enables you to send an HTTP request over the network.

l HTTP Receiver. This activity enables you to receive an HTTP response from a server.

l SOAP Request. This activity enables you to send a SOAP request over the network.

HTTP Request Activity
The HTTP Request activity enables you to send an HTTP request over the network.

HTTP Request - General Properties

To view theGeneral properties, click theGeneral view button in the Properties pane.

Property Description

Proxy The settings for the proxy server hosting the service contract: Server (URL
and port when required), Username, andPassword.

Authentication The user credentials settings for obtaining a service contract: Username and
Password.

Connection
type

The type of connection: Keep-Alive orClose.

Default: Keep-Alive

Timeout The HTTP timeout in milliseconds.
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Property Description

Client
certificate

A Choice element indicating the source of the client certificate:

l Use file system certificate: The expanded node provides the full path of
the certificate file.

l Use Windows store certificate: The expanded node lists the following
properties Store location, Store name, X509 find type, andX509 find
value.

l Password. The certificate's password.

Note: To use a certificate, make sure to theUse Client Certificate
property to true.

Use Client
Certificate

Enables the use of a client certificate.

Default: false

Maximum
automatic
redirections

The number of times to attempt accessing a page, including redirection.

Default: 3

Allow
redirections

Indicates whether to allow the step to redirect to another URL.

Default: true

Reuse cookies Enables the reusing of cookies for the current step. Default: false.

HTTP Receiver Activity
Overview

TheHTTP Receiver activity receives an HTTP message from a server. This activity is used with
asynchronous messaging. For details, see "Asynchronous Service Calls" on page 601.

Receiver activities are activities that act as receiver for a server response. This category includes
the built-inHTTP Receiver activity andWeb Service operations that were imported as a server
response. For more details, see the "Select WSDLDialog Box" on page 488 or "Select WSDL
Dialog Box" on page 488.

All receiver activities are composite activities. This means that they serve as a wrapper for all
activities inside the container whose responses are sent to the HTTP Receiver step—not the Test
Flow.

For example, if an HTTP Receiver step contains the FTP Download andRead from File steps,
these internal steps send their response to the HTTP Receiver step—not to the Test Flow loop.
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HTTP Receiver - General Properties

To view theGeneral properties, click theGeneral view button in the Properties pane.

Property Description

Listen on port The port upon which to listen for the server request.

Completion event name The name of the event associated with a followingWait step,
allowing the step to receive the server request.

Use SSL Secures the connection with SSL: true or false.

SSL Certificate Information about the SSL certificate:

l Subject. The certificate's subject string.

l Store location. The location of the certificate—LocalMachine or
Windows store.

l Store name. The name of the store hosting the certificate.

l Thumbprint. The certificate's thumbprint or hash code.

Save response body
with this extension

Saves the response body for messages with the specified
extension.

HTTP Receiver - Output Properties

You can link to theHTTP Receiver output property, its response body, through the Select Link
Source dialog box. For details, see "Select Link Source Dialog Box" on page 630.

Property Description

Response body as a UFT-8 string The body of the HTTP response in UFT-8 format.

HP Service Test (11.52)Page 428 of 705

User Guide
Chapter 23: Standard Activities



SOAP Request Activity
TheSOAP Request activity sends amanual SOAP request to the server, usually in XML format.
You can import a schema and load XML for this activity. For details, see "Input/Checkpoints/Output
Properties Tab (Properties Pane)" on page 201.

SOAP Request - General Properties

To view theGeneral properties, click theGeneral button in the Properties pane.

Property Description

Transport The type of transport for the SOAP request: HTTP or JMS.

Transport
> HTTP

Use the HTTP transport method for this call with the following properties:

l Endpoint Address. The endpoint location of the service as derived from the
WSDL

l SoapAction. An expression indicating the SOAP action

Example: HP.SOAQ.SampleApp/IHPFlights_
Service/DeleteFlightOrder.

l ContentType. The type of content: For example text/xml; charset=utf-

8.

l Timeout. Themaximum time inmilliseconds to wait for the response. Enter -1
to disable the timeout and wait for the response as long as required.

Transport
> JMS

Use the JMS transport method for this call with the following properties:

l Send queue name. The name of the queue from which to send themessage.

l Receive queue name. The name of the queue from which to receive the
message.

l JMS send properties. JMS properties with the key/value form. You can use the
key tomodify JMS header or message properties.

l JMS receive message selector. An SQL expression to filter the received
message. For more information on the syntax for defining selectors, see the
Message Properties section in
http://docs.oracle.com/javaee/1.3/api/javax/jms/Message.html.

For example, a key JMSCorrelationID, with a value of 4566636, receives
only messages whose correlation ID is 4566636.

IsOneWay Indicates whether the service is a one way service: true or false. A one way
service only sends a request. A non-one way service sends a request and receives
a response.

SOAP Request - Input Properties

To view the Input properties, click theXML Body button in the Properties pane. The Input
properties have the form of a SOAP envelope schema, with a header and body. You can add array
elements at all levels using the shortcut menu.

HP Service Test (11.52)Page 429 of 705

User Guide
Chapter 23: Standard Activities

http://docs.oracle.com/javaee/1.3/api/javax/jms/Message.html


SOAP Request - Checkpoints

To view the checkpoints, click theXML Body button in the Properties pane. You can view the
expected output schema, or display a list of the XPath checkpoints. You can add array elements at
all levels using the shortcut menu.

For details, see the "XML Body Tab (Properties Pane)" on page 213.

JSON Activities

This activity group contains activities related to JSON files:

l JSON to String. Converts a JSON file to a text string.

l String to JSON. Converts a string to a JSON structure.

This JSON to String andString to JSON activities are useful when you need to access the output
in a specific format—either as string or JSON.

For example, suppose your test contains aWeb Service call whose output is JSON. However, you
need to use the output as an input for the next step, such as aService Test test step, which requires
a textual string—not JSON.

You can use the JSON to String activity to create a string that is compatible with the Service Test
test step.

After the Service Test test step, you can use aString to JSON activity to convert the output to
JSON, making it available for linking and checkpoints.

JSON - Input Properties
To view the Input properties, click the Input/Checkpoints tab in the Properties pane.

Property (A-Z) Activity Description

<JSON
document>

JSON to
string

The JSON document to convert to a string. This can be displayed
in Text or Grid views.

To add a document, click Load JSON to import a JSON file.

Source string String to
JSON

The string to convert to JSON.

JSON - Checkpoints
To view the checkpoint properties, select the Input/Checkpoints tab button in the Properties pane
and click in the lowerCheckpoints pane.

Property (A-Z) Activity Description

<JSON
document>

String to
JSON

The JSON representation of the expected response.

To see the JSON document, click Load JSON to import a JSON
file.
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Property (A-Z) Activity Description

Output string JSON to
String

The expected string representation of the conversion.

Tip: To view the actual string:

l See theCaptured Data pane in the Run Results Viewer.

l Select Run Step from the step's right-click menu and
view the Run Step Results pane.

TheString to JSON step contains an additional output property, Result, visible from theResult
view in the Properties pane or Select Link Source dialog box. For details, see "Result Tab
(Properties Pane)" on page 207.

Property Description

Result A boolean variable indicating whether the string had the correct structure to be
converted into JSON.

Java Activities

This activity group contains theCall Java Class activity. It enables you to set up and configure a
call to a Java class.

For task details, see " How to Create a Call to a Java Class" on page 402.

For user interface details, see the "Java Class Dialog Box" on page 459.

JMS Activities

This activity group provides steps that handle JMS messages. For details, see the "JMS Transport
Overview" on page 382.

For task details, see "How to RetrieveMessages from a JMS Queue" on page 403 or "How to
ReceiveMessages Through JMS Topics" on page 407.

This activity group contains the following activities:

l Publish Message to JMS Topic. Publishes amessage tomultiple subscribers using a JMS
topic.

l Receive Message from JMS Queue. Receives amessage from a JMS queue.

l Receive Message from JMS Topic. Receives publishedmessages to a specific JMS topic for
a subscription. Place this step afterSubscribe to JMS Topic.

l Send Message to JMS Queue. Sends amessage to a JMS queue.

l Send and Receive Message from JMS Queue. Sends amessage to a specified queue and
receives amessage from a specified queue.
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l Subscribe to JMS Topic. Creates a subscription for a JMS topic. Use this step before any
Receive Message from Topic steps for the subscription.

l Browse JMS Queue Messages. Retrieves messages from the JMS queue without consuming
them.

Publish Message to JMS Topic
This activity publishes amessage tomultiple subscribers using a JMS topic.

Publish Message to JMS Topic - Input Properties

Property (A-Z) Description

JMS send
properties

JMS properties with the key/value form. You can use the key tomodify JMS
header or message properties.

Message Themessage to publish.

Topic name The name of the queue from which to receive themessage.

Publish Message to JMS Topic - Checkpoints

Property Description

Result A boolean variable indicating whether the step succeeded.

Receive Message from JMS Queue
This activity receives amessage from a JMS queue.

Receive Message from JMS Queue - Input Properties

Property
(A-Z)

Description

JMS
receive
message
selector

An SQL expression to filter the receivedmessage. For details on the syntax for
defining selectors, see theMessage Properties section in
http://docs.oracle.com/javaee/1.3/api/javax/jms/Message.html.

For example, a key JMSCorrelationID, with a value of 4566636, receives
only messages whose correlation ID is 4566636.

Receive
queue
name

The name of the queue from which to receive themessage. If the value is empty, it
uses a temporary queue.

Receive Message from JMS Queue - Checkpoints
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Property (A-Z) Description

JMS properties An array of message properties in the structure of keys and values.

Tip: Use theNumber of elements drop -down to specify the number
of properties, or click theAdd button to add elements.

JMSCorrelationID Themessage's correlation ID.

Tip: Use in conjunction with the JMS receivemessage selector.

JMSDeliveryMode Themessage's delivery mode. Use the scroller to select a value.

JMSDestination Themessage's destination.

JMSExpiration Themessage's expiration date.

JMSMessageID A unique ID for themessage.

JMSPriority Themessage's priority in comparison to other messages. Use the scroller
to select a value.

JMSRedelivered Indicates whether themessage was redelivered. False by default.

JMSReplyTo The contents of theReply To field.

JMSTimeStamp The time and date of themessage.

JMSType A string describing the JMS type.

Message body Themessage content.

Receive Message from JMS Topic
This activity receives publishedmessages to a specific JMS topic for a subscription. Place this
step after aSubscribe to JMS Topic step.

Receive Message from JMS Topic - Input Properties

Property (A-
Z)

Description

Subscription
name

The name of the subscription. Use the same subscriber name value from the
previously-calledSubscribe to JMS Topic step.

Topic name The name of the topic from which to receive themessage.

Receive Message from JMS Topic - Checkpoints
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Property (A-Z) Description

JMS properties An array of message properties in the structure of keys and values.

Tip: Use theNumber of elements drop -down to specify the number
of properties, or click theAdd button to add elements.

JMSCorrelationID Themessage's correlation ID.

Tip: Use in conjunction with the JMS receivemessage selector.

JMSDeliveryMode Themessage's delivery mode. Use the scroller to select a value.

JMSDestination Themessage's destination.

JMSExpiration Themessage's expiration date.

JMSMessageID A unique ID for themessage.

JMSPriority Themessage's priority in comparison to other messages. Use the scroller
to select a value.

JMSRedelivered Indicates whether themessage was redelivered. False by default.

JMSReplyTo The contents of theReply To field.

JMSTimeStamp The time and date of themessage.

JMSType A string describing the JMS type.

Message body Themessage content.

Send Message to JMS Queue
This activity sends amessage to a JMS queue.

Send Message to JMS Queue - Input Properties

Property (A-Z) Description

JMS send
properties

JMS properties with the key/value form. You can use the key tomodify JMS
header or message properties.

Message Themessage to send.

Send queue
name

The name of the queue from which to send themessage.

Send Message to JMS Queue - Checkpoints

Property Description

Result A boolean variable indicating whether the step succeeded.
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Send and Receive Message from JMS Queue
This activity sends amessage to a specified queue and receives amessage from a specified
queue.

Send and Receive Message from JMS Queue - Input Properties

Property
(A-Z)

Description

JMS
receive
message
selector

An SQL expression to filter the receivedmessage. For details on the syntax for
defining selectors, see theMessage Properties section in
http://docs.oracle.com/javaee/1.3/api/javax/jms/Message.html.

For example, a key JMSCorrelationID, with a value of 4566636, receives only
messages whose correlation ID is 4566636.

Tip: To automatically generate a selector, use theAutomatically generate
selector option in the Properties pane's Test Settings tab. This selector uses
a correlation ID that corresponds to the request's message ID.

JMS send
properties

JMS properties with the key/value form. You can use the key tomodify JMS
header or message properties.

Message Themessage to send.

Receive
queue
name

The name of the queue from which to receive themessage. If the value is empty, it
uses a temporary queue.

Send
queue
name

The name of the queue to which to send themessage.

Send and Receive Message from JMS Queue - Checkpoints

Property (A-Z) Description

JMS properties An array of message properties in the structure of keys and values.

Tip: Use theNumber of elements drop -down to specify the number of
properties, or click theAdd button to add elements.

JMSCorrelationID Themessage's correlation ID.

Tip:Use in conjunction with the JMS receivemessage selector.

JMSDeliveryMode Themessage's delivery mode. Use the scroller to select a value.

JMSDestination Themessage's destination.

JMSExpiration Themessage's expiration date.
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Property (A-Z) Description

JMSMessageID A unique ID for themessage.

JMSPriority Themessage's priority in comparison to other messages. Use the scroller
to select a value.

JMSRedelivered Indicates whether themessage was redelivered. False by default.

JMSReplyTo The contents of theReply To field.

JMSTimeStamp The time and date of themessage.

JMSType A string describing the JMS type.

Message body Themessage content.

Subscribe to JMS Topic
This activity creates a subscription for a JMS topic. Use this step before any Receive Message
from Topic steps for the subscription.

Subscribe to JMS Topic - Input Properties

Property (A-
Z)

Description

JMS receive
message
selector

An SQL expression to filter the receivedmessage. For details on the syntax for
defining selectors, see theMessage Properties section in
http://docs.oracle.com/javaee/1.3/api/javax/jms/Message.html.

Subscription
name

The name of the subscription. To retrievemessages on the subscription created
by this step, insert aReceive Message from Topic step using the same
Subscription name value.

Topic name The name of the topic from which to receive themessage.

Subscribe to JMS Topic - Checkpoints

Property Description

Result A boolean variable indicating whether the step succeeded.

Browse JMS Queue Messages
This activity retrieves messages from the JMS queue without removing them from the queue.

Browse JMS Queue Messages - Input Properties
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Property
(A-Z)

Description

Messages
selector

An optional SQL expression to filter the receivedmessages. For details on the
syntax for defining selectors, see theMessage Properties section in
http://www.oracle.com/technetwork/java/jms-101-spec-150080.pdf.

Queue
name

The name of the queue upon which to browse for a collection of messages. This
field is mandatory.

Note:When using IBM ActiveMQ, youmust use the format
dynamicQueues/<queue_name>. If the specified queue does not exist, it
will be created dynamically.

Browse JMS Queue Messages - Checkpoints

Property Description

JMS
messages

An array of JMS messages and their properties on the specified queue. The array of
messages corresponds to the filter used in theMessages selector property.

Load Testing Activities

This activity group contains activities that allow you prepare the test for load testing:

l Start Transaction.Marks the beginning of a LoadRunner transaction.

l End Transaction.Marks the end of a LoadRunner transaction.

l Think Time. Emulates a time delay, in seconds, between steps.

For details, see "Prepare for load testing - optional" on page 594.

IBM WebSphere MQ Activities

This activity group enables you to perform actions on an IBMWebsphereMQ application server.

The activities in this group are:

l Connect to MQ Queue Manager. Connects to a specific MQQueueManager andmaintains an
open connection with the server.

l Disconnect from MQ Queue Manager. Disconnects from the specific MQQueueManager
and closes the connection with theMQ server.

l Commit MQ Pending Messages. Commits the last changes made for all messages since the
last point of synchronization.

l Backout MQ Pending Messages. Performs a Backout operation from the last point of
synchronization. All PUT messages will be cancelled andGETmessages will be reinstated to
the queue.
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l Browse Messages in MQ Queue. Browses themessages on theMQQueue via the Queue
Manager.

l Put Message to MQ Queue. Puts amessage on theMQ queue via the QueueManager.

l Get Message from MQ Queue. Gets themost recent message from theMQ queue via the
QueueManager.

l Put and Get Message from MQ Queue. Puts amessage on theMQ queue and then gets a
message from theMQ queue via the QueueManager.

l Subscribe to MQ Topic. Creates a subscription for anMQ topic. From this point on, a
subscriber can receivemessages from a specified topic.

l Unsubscribe to MQ Topic. Cancels a subscription for the specifiedMQ topic.

l Publish Message to MQ Topic. Publishes amessage to subscribers using anMQ topic.

l Receive Message from MQ Topic. Receives messages for the active subscription, that were
published to a specific MQ topic.

Service Test enables you to set the data format of themessage for both queues and topics. The
String format indicates Unicode and non- Unicode strings without a prefix. TheUTF format
represents a UTF string with a 2-byte prefix.

For details about each of the activities and a description of their input and output properties, see the
sections below.

For task details, see "How to RetrieveMessages from anMQQueue" on page 408 or "How to
ReceiveMessages ThroughMQTopics" on page 410.

Connect to MQQueue Manager
This activity connects to the specifiedMQQueueManager andmaintains an open connection until
it is closed or until the end of the test.

Connect to MQ Queue Manager - Input Properties

Property
(A-Z)

Description

Channel The channel through which to connect. For most configurations, use
SYSTEM.DEF.SVRCONN.

Host
name

The name or IP address of the QueueManager's host machine.

Password An optional password for connecting to the host machine.

Port The port through which to connect, by default 1414.

Queue
manager
name

An property indicating the name of the QueueManager.
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Property
(A-Z)

Description

SSL Enables or disables SSL. When you enable SSL, you can set values for the
following properties:

l SSLCipherSpec. The SSLCipher Specification, SSLCIPH. This specification
indicates which data encryption algorithm and key size to use, such as DES_
SHA_EXPORT or RC2_MD5_EXPORT.

l SSLKeyRepository. The path of the SSL key repository on the client machine.

User ID An optional identification property for connecting to the host machine.

Connect to MQQueueManager - Checkpoints

Property (A-
Z)

Description

MQManager An automatically generated connection expression.

Note:

l Although this does not appear in theCheckpoints grid, it is visible as an
output property in the Select Link Source dialog box. For details, see the
"Select Link Source Dialog Box" on page 630.

l When you add steps, they automatically use the connection expression
from themost recent connection step.

Result A boolean variable indicating whether the step succeeded.

Disconnect from MQQueue Manager
This activity disconnects from the specifiedMQQueueManager and closes the connection with
theMQ server.

Disconnect from MQ Queue Manager - Input Properties

Property Description

MQManager A connection expression linked to aConnect to MQ Queue Manager step.

Note:When you add aDisconnect to MQ Queue Manager step, it
automatically creates a link to themost recent connection step.

Disconnect from MQ Queue Manager - Checkpoints

Property Description

Result A boolean variable indicating whether the step succeeded.
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Commit/Backout MQ Pending Messages
These activities commit or rollback the changes made for all messages since the last point of
synchronization.

Commit/Backout MQ Pending Messages - Input Properties

Property Description

MQManager A connection expression linked to aConnect to MQ Queue Manager step.

Note:When you add this step, it automatically creates a link to themost
recent connection step.

Commit/Backout MQ Pending Messages - Checkpoints

Property Description

Result A boolean variable indicating whether the step succeeded.

Browse Messages in MQQueue
This activity browses themessages on theMQ queue via the QueueManager, without removing
them from the queue.

Browse Messages in MQ Queue - Input Properties

Property(A-
Z)

Description

Match
Conditions

An array of match conditions in a key/value format. Select a key from the drop
down box in the Key's Value column and provide a value. MQMO_NONE does not
require a value.

Message
data format

The format of themessage being retrieved: String orUTF.

Message
Get Options

A tree with several built-in MQGet options.

Note: To access additional options, use an event handler. For details, see
"Coding Service Test Events" on page 641.

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.

Queue
Access
Options

A tree with several built-in MQ queue access options.

Note: To access additional options, use an event handler. For details, see
"Coding Service Test Events" on page 641.
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Property(A-
Z)

Description

Queue
name

The name of theMQ queue to browse.

Wait
interval

Themaximum time inmilliseconds to wait for themessage to arrive, using the
following values:

l -1: Unlimited wait time

l 0: No wait

l A positive number: The time to wait in milliseconds.

Browse Messages in MQ Queue - Checkpoints

Property Description

Message An array of themessage and its properties on theMQmessage queue, that matched
the specified conditions.

Each array element contains the followingmessage properties:

l MessageId. Themessage identifier of the retrievedmessage.

l CorrelationId. The correlation identifier of the retrievedmessage.

l GroupId. An identifier of themessage group to which the physical message
belongs.

l MsgSeqNumber. The sequence number of a logical message within a group.

l Put Time. The date and time the PUT action was executed for themessage.

l Priority. The priority of themessage from 0 to 9.

l UserId. The UserId of the user who submitted themessage.

l MessageBody. A string representing the UTF content of the retrievedmessage.

Put Message to MQQueue
This activity puts amessage on theMQ queue via the QueueManager.

Put Messages to MQ Queue - Input Properties

Property (A-
Z)

Description

Correlation
ID

The correlation ID of themessage.

Message
body

The body of themessage to put on the queue.
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Property (A-
Z)

Description

Message
data format

The format of themessage being sent: String orUTF.

Message
Properties

An array of Put message properties in a Key/Value format.

Message
Put Options

A drop down of built-in message put options.

Note: To access additional options, use an event handler. For details, see
"Coding Service Test Events" on page 641.

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.

Priority The priority of themessage rated from 0 through 9 (highest). A message with a
higher priority will be taken from the queue beforemessages with a lower priority.

Put queue
name

The name of theMQ queue on which to put themessage.

Queue
Access
Options

A drop down of built-in MQ queue access options.

Note: To access additional options, use an event handler. For details, see
"Coding Service Test Events" on page 641.

Put Messages to MQ Queue - Checkpoints

Property (A-Z) Description

MessageId A message identifier of themessage being sent.

PutTime The date and time themessage was put.

UserId The sender's user ID.

Get Message from MQQueue
This activity gets amessage from theMQ queue via the QueueManager.

Get Messages from MQ Queue - Input Properties

Property (A-
Z)

Description

Get queue
name

The name of theMQ queue from which to get themessage.
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Property (A-
Z)

Description

Match
Condition

An array of match conditions in a key/value format. Select a key from the drop
down box in the Key's Value column and provide a value. MQMO_NONE does not
require a value.

Message
data format

The format of themessage being retrieved: String orUTF.

Message
Get Options

A collection of built-in Message get options.

Note: To access additional options, use an event handler. For details, see
"Coding Service Test Events" on page 641.

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.

Queue
Access
Options

A drop down of built-in MQ queue access options.

Note: To access additional options, use an event handler. For details, see
"Coding Service Test Events" on page 641.

Wait
interval

Themaximum time inmilliseconds to wait for themessage to arrive, using the
following values:

l -1: Unlimited wait time

l 0: No wait

l A positive number: The time to wait in milliseconds.

Get Messages from MQ Queue - Checkpoints

Property (A-Z) Description

CorrelationId The correlation identifier of the retrievedmessage. 
  

GroupId An identifier of themessage group to which the physical message belongs.

MessageBody A string representing the UTF content of the retrievedmessage.

MessageId Themessage identifier of the retrievedmessage.

MsgSeqNumber The sequence number of a logical message within a group.

Priority The priority of themessage rated from 0 through 9 (highest). A message with
a higher priority will be taken from the queue beforemessages with a lower
priority.

PutTime The date and time the PUT action was executed for themessage.

UserId The User ID of the user who submitted themessage.
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Put and Get Message from MQQueue
This activity puts amessage on theMQ queue and retrieves amessage from theMQ queue.

Put and Get Messages from MQ Queue - Input Properties

Property (A-
Z)

Description

Auto Match
Correlation
ID

Correlates the sent and receivedmessages by automatically adding amatch
condition. This condition indicates that theCorrelation ID of the received
message should equal theMessage ID of the sent message.

Get
message
data format

The format of the receivedmessage: String orUTF.

Get Queue
Access
Options

A collection of built-in MQ queue access options.

Note: To access additional options, use an event handler. For details, see
"Coding Service Test Events" on page 641.

Get queue
name

The name of theMQ queue from which to get themessage.

Match
Condition

An array of Get Messagematch conditions n a key/value format. Select a key
from the drop down box in the Key's Value column and provide a value. MQMO_
NONE does not require a value.

Message
body

A string representing the UTF content of the submittedmessage.

Message
Get Options

A collection of built-in options that control the Get operation.

Note: To access additional options, use an event handler. For details, see
"Coding Service Test Events" on page 641.

Message
properties

An array of Put message properties in a key/value format.

Message
Put Options

A collection of built-in message put options.

Note: To access additional options, use an event handler. For details, see
"Coding Service Test Events" on page 641.

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.
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Property (A-
Z)

Description

Put
correlation
ID

A correlation identifier for themessage to be submitted.

Put
message
format

The format of themessage: being sent: String orUTF.

Put priority The priority of themessage to be submitted.

Put Queue
Access
Options

A collection of built-in MQ queue access options.

Note: To access additional options, use an event handler. For details, see
"Coding Service Test Events" on page 641.

Put queue
name

The name of theMQ queue upon which to put themessage.

Wait
interval

Themaximum time inmilliseconds to wait for themessage to arrive, using the
following values:

l -1: Unlimited wait time

l 0: No wait

l A positive number: The time to wait in milliseconds.

Put and Get Messages from MQ Queue - Checkpoints

Property (A-Z) Description

CorrelkationId The correlation identifier of the retrievedmessage.

GroupId An identifier of themessage group to which the physical message belongs.

MessageBody A string representing the UTF content of the retrievedmessage.

MessageId Themessage identifier of the retrievedmessage.

MsgSeqNumber The sequence number of a logical message within a group.

Priority The priority of themessage rated from 0 through 9 (highest). A message with
a higher priority will be taken from the queue beforemessages with a lower
priority.

PutTime The date and time the PUT action was executed for themessage.

UserId The Userid of the user who submitted themessage.

Subscribe to MQ Topic
This activity creates a subscription for anMQ topic. From this point on, a subscriber can receive
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messages that were published to a specific topic using theReceive Message from MQ Topic
activity.

Subscribe to MQ Topic - Input Properties

Property (A-Z) Description

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.

Subscription
name

An automatically generated subscription name.

Topic Access
Options

A collection of built-in MQ topic access options.

Note: To access additional options, use an event handler. For details, see
"Coding Service Test Events" on page 641.

Topic name The name of theMQ topic from which subscribers can access themessage.

Subscribe to MQ Topic - Checkpoints

Property Description

Result The Subscription name enteredmanually or generated automatically.

Notes:

l Although this does not appear in theCheckpoints grid, it is visible as an output
property in the "Select Link Source Dialog Box".

l This property can be used as an input value for the subscription name in the
Unsubscribe from MQ Topic andReceive Message from MQ Topic steps.

Unsubscribe from MQ Topic
This activity cancels the subscription to anMQ topic.

Unsubscribe from MQ Topic - Input Properties

Property Description

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.

Subscription
name

The subscription from which to unsubscribe. This can be a literal string or an
expression linked to the output of aSubscribe to MQ Topic step.

Unsubscribe from MQ Topic - Checkpoints

Property Description

Result A boolean variable indicating whether the step succeeded.
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Publish Message to MQ Topic
This activity publishes amessage to subscribers using anMQ topic. TheReceive Message from
MQ Topic activity retrieves themessage.

Publish Message to MQ Topic - Input Properties

Property (A-
Z)

Description

Correlation
ID

The UserId of the user who submitted themessage.

Message
body

Themessage to publish.

Message
data format

The format of themessage being published: String orUTF.

Message
Properties

An array of message properties in a Key/Value format.

Message
Put Options

A drop down of built-in options that control the Put operation, such as MQPMO_
SYNCPOINT.

Note: To access additional options, use an event handler. For details, see
"Coding Service Test Events" on page 641.

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.

Priority The priority of themessage rated from 0 through 9 (highest). A message with a
higher priority will be taken from the queue beforemessages with a lower priority.

Topic
Access
Options

A drop down of the built-in options that control the opening of the topic.

Note: To access additional options, use an event handler. For details, see
"Coding Service Test Events" on page 641.

Topic name The name of the topic on which to publish themessage.

Publish Message to MQ Topic - Checkpoints

Property (A-Z) Description

MessageId A message identifier of the submittedmessage.

PutTime The date and time themessage was put.

UserId The UserId of the user who submitted themessage.

Receive Message from MQ Topic
This activity receives messages for subscribers, that were published to a specific MQ topic.
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Receive Message from MQ Topic - Input Properties

Property (A-
Z)

Description

Match
Condition

An array of match conditions n a key/value format. Select a key from the drop
down box in the Key's Value column and provide a value. MQMO_NONE does not
require a value.

Message
data format

The format of themessage being retrieved: String orUTF.

Message Get
Options

A drop down of built-in message get options.

Note: To access additional options, use an event handler. For details, see
"Coding Service Test Events" on page 641.

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.

Subscription
name

The subscription through which to receive topic messages. This can be a literal
string or an expression linked to the output of aSubscribe to MQ Topic step.

Wait interval Themaximum time inmilliseconds to wait for themessage to arrive, using the
following values:

l -1: Unlimited wait time

l 0: No wait

l A positive number: The time to wait in milliseconds.

Receive Message from MQ Topic - Checkpoints

Property (A-Z) Description

CorrellationId The correlation identifier of the retrievedmessage.

GroupId An identifier of themessage group to which the physical message belongs.

MessageBody A string representing the UTF content of the retrievedmessage.

MessageId Themessage identifier of the retrievedmessage.

MsgSeqNumber The sequence number of a logical message within a group.

Priority The priority of themessage rated from 0 through 9 (highest). A message with
a higher priority will be taken from the queue beforemessages with a lower
priority.

PutTime The date and time themessage was put.

UserId The User ID of the user who submitted themessage.
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HP Automated Testing Tools Activities

This activity group contains activities that allow you implement unified testing plan. For task
details, see "How to Call Tests from Other Applications" on page 411.

l Call API Action or Test. Invokes a Service Test Test action or test when the current Test
Flow or loop reaches this step.

l Call Virtual User Generator script. Runs a LoadRunner Virtual User Generator (VuGen)
script.

HP Automated Testing Tools - General Properties
The following section describes the general properties for the HP Automated Testing Tools
activities.

Property
(A-Z)

Tool Description

Action
name

API
(Service
Test) and
GUI

The name of the action being called. This field is read-only. To select
an action, click theSelect Action or Test button in the
Input/Checkpoint view.

Description All An editable field describing the call.

Result
Directory

API
(Service
Test)

The location in which to store the run results. This field is editable.

Script path Virtual
User
Generator

The path of the Virtual User Generator-LoadRunner script. This field
is read-only. To select a script, click theSelect Virtual User
Generator Script button in the Input/Checkpoint view.

Test path API
(Service
Test)

The path of the test. This field is read-only. To select a test, click the
Select Action or Test button in the Input/Checkpoints tab.

SAP Activities

This activity group contains the activity related to SAP IDoc status.

l Get IDOC Status. Retrieves the status of an IDoc.

This section describes the built-in SAP activity. For information about imported SAP activities
representing RFCs and IDocs, see "How to Create an SAP Test Step" on page 485.

Get IDoc Status - General Properties
To view these properties, click theGeneral tab in the Properties pane.
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Property Description

Timeout Themaximum time allowed for retrieving the IDoc status in milliseconds.

Connection
Info

The connection information for the SAP server. If you created a step based on an
imported IDoc, you can link to these properties using the Link to data source
button. For details, see "How to Create an SAP Test Step" on page 485.

Get IDoc Status - Input Properties
To view the input properties, click the Input/Checkpoints tab in the Properties pane.

Property Description

IDoc Number The IDoc number for the IDoc whose status you want to retrieve.

Get IDoc Status - Checkpoints
To view the checkpoint properties, select the Input/Checkpoints tab button in the Properties pane
and click in the lowerCheckpoints area.

The checkpoint name corresponds to the SAP property ID.

Property Description

MANDT The client.

DOCNUM The IDoc number.

LOGDAT The date of the status information.

LOGTIM The time of the status information.

COUNTR The IDoc status counter.

CREDAT The creation date of the status record.

CRETIM The creation time of the status record.

STATUS The status of the IDoc.

UNAME The user name.

REPID The program name.

ROUTID The name of the subroutine or functionmodule.

STACOD The status code.

STATXT The status code textual representation.

SEGNUM The SAP segment number.

SEGFLD The field name in the SAP segment.
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Property Description

STAPA1,2,3,4 Status parameters 1, 2, 3, and 4.

STATYP The systemmessage type: A, W, E. S, or I.

STAMQU The status message qualifier.

STAMID The status message ID.

STAMNO The status message number.

TID The transaction ID.

APPL_LOG The application log.

XML Activities

This activity group contains activities related to XML files:

l Transform XML. Converts an XML file to another structure based on the specified XSLT.

l Compare XMLs. Performs a comparison between two XML strings.

l XML to String. Converts an XML file to a text string.

l String to XML. Converts a string to XML structure.

l Validate XML. Validates an XML file against an XSD schema.

TheXML to String andString to XML activities are useful when you need to access the output in
a specific format—either as string or XML.

For example, suppose your test contains aWeb Service call whose output is XML. However, you
need to use the output as an input for the next step, such as aService Test test step, which requires
a textual string—not XML.

You can use theXML to String activity to create a string that is compatible with the Service Test
test step.

After the Service Test test step, you can use aString to XML activity to convert the output to
XML, making it available for linking, and checkpoints.

For task information, see:

l "How to Validate an XML file" on page 412

l "How to Transform an XML File" on page 413

l "How to Compare XML Strings" on page 415

XML - Input Properties
To view the Input properties, click the Input/Checkpoints tab in the Properties pane.
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Property Activity Description

<XML> XML to string The XML to convert to a string. This can be displayed in
Text or Grid views.

XML string 1
XML string 2

Compare XMLs The XML strings upon which to perform aDiff operation.
XML string 2 denotes the newer string.

Ignore element
order

Compare XMLs Ignores differences between the order of the elements
in the XML strings.

Ignore
namespaces

Compare XMLs Ignores differences between namespaces in the XML
strings.

Ignore XPaths Compare XMLs Ignores specific XPath nodes, listed as array elements
of this property.

Import
XSD/XSLT to
folder

Validate XML and
Transform XML

Copies the XSD/XSLT to the test's folder, contributing
to the test's portability.

Source string String to XML The string to convert to XML.

XML string Validate XML and
Transform XML

The XML string to validate or transform.

XSD/XSLT file Validate XML and
Transform XML

The path of the source XSD/XSLT file.

XML - Checkpoints
To view the checkpoint properties, select the Input/Checkpoints tab in the Properties pane and
click in the lowerCheckpoints pane.

Property (A-
Z)

Activity Description

<XML> String to
XML

The XML representation of the response. For details, see
"Properties Pane Tabs" on page 186.

Are Equal Compare
XMLs

No differences were found between the compared XML strings,
based on the Input properties ignore settings.

Output
string

XML to
String

The expected string representation of the XML document.

Tip: To view the actual string:

l See theCaptured Data pane in the Run Results Viewer.

l Select Run Step from the step's right-click menu and view
the Run Step Results pane.
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Property (A-
Z)

Activity Description

Result array Validate
XML

An array with the following properties:

l Valid. A boolean variable indicating whether the source XML
was valid.

l Errors. The contents of an error string, if one was issued.

Transformed
XML

Transform
XML

The expected XML in its transformed layout.

TheString to XML step contains an additional output property, Result, visible from theResult
view in the Properties pane or Select Link Source dialog box. For details, see "Result Tab
(Properties Pane)" on page 207.

Property Description

Result A boolean variable indicating whether the string had the correct structure to be
converted into XML.

Activity-Specific Dialog Boxes
Several activities provide separate dialog boxes to assist you in creating and assigning Input
property data.

This section includes:

Connection Builder Dialog Box 453

Query Builder Dialog Box 455

Query Designer Dialog Box 456

Java Class Dialog Box 459

Connection Builder Dialog Box

This dialog box helps you create a database connection expression for theDatabase > Open
Connection activity.
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To access Do the following:

1. Drag aDatabase > Open Connection activity onto the canvas.

2. Click the Input/Checkpoints tab in the Properties pane.

3. Select the Input property—Connection string.

4. Click theConnection Builder button in the right side of theValue
column.

Relevant tasks "How to Execute Database Commands or Retrieve Data" on page 399

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

Connection type The type of database connection: OleDB orODBC.

Edit Connection String.

l For OleDB. Opens theMicrosoft Data Link Properties dialog
box to help you create a new string or edit an existing one.

l For ODBC. Opens the Select Data Source Name dialog box.
For details, see "Select Data Source NameDialog Box" on
page 105.

<connection string area> An editable area for pasting in existing strings, or for editing the
connection string selected in the drop down list.

Connection string A drop down list of previously defined connection strings.
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UI Elements Description

Password The password required to connect to the database. The password
is displayed in encrypted form.

Insert. Inserts a parameter representing the password at the
location of the cursor in the Connection String area.

Test Connection Checks the database connection using the string shown in the text
area. If it succeeds to connect to the database, the status
message beneath this button changes from Disconnected to
Connected.

After you test a connection, it remains open until after the test is
complete or when you close it manually using aClose
Connection step.

Connected/Disconnected The current connection status.

Query Builder Dialog Box

This dialog box helps you create an SQL statement for theQuery string property of theDatabase
> Select Data activity.
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To access Do the following:

1. Drag aDatabase > Select Data activity onto the canvas.

2. Click the Input/Checkpoints tab in the Properties pane.

3. Select the Input property—Query string.

4. Click theQuery Builder button in the right side of theValue
column.

Relevant tasks "How to Execute Database Commands or Retrieve Data" on page 399

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Elements

Description

Query Designer. Opens theQuery Designer dialog box.

Query
string

A drop-down list of previously defined query strings.

<query
string
area>

An editable area for pasting in existing strings, or for editing the query string selected
in the drop-down list.

Test
Query

Tests the query against the database to which you are connected.

<query
status>

The displayed query's status. The possible values are:

l Query not executed

l Query executed successfully

l Query completed with errors

Generate
output

Automatically retrieves table information from the database when you click OK, and
sets the structure of the output in the Properties pane's Checkpoints area.

Query Designer Dialog Box

This dialog box helps you design an SQL statement for:

l theQuery string property of theDatabase > Select Data activity.

l creating a new database data source in the Data Pane.
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To
access

In the Input/Checkpoints tab, for aSelect Data step:

1. Select the Input property—Query string.

2. Click theBuild an SQL query string button in the right side of theValue
column to open the "Query Builder Dialog Box".

3. Click theQuery Designer button .

In the Data Pane, when defining a new Database type data source using the "Add
New Database Data SourceWizard" on page 102:

1. In the Add New Database Data Source wizard, proceed to the second screen,
Set SQL Statement.

2. Click theQuery Designer button to the right of theSQL statement box.

Relevant
tasks

l "How to Execute Database Commands or Retrieve Data" on page 399

l "Add a database data source" on page 91

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

Table/View A drop-down list of the tables and views in the database. The tables and views
are distinguishable by different icons.

Note: The number of items shown in the list is limited to 1000. You can also
enter text in the field to display a list of relevant data sources.

Reset Query. Resets the query to its original state and discards all changes.
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UI Elements Description

Group by Adds aGroupBy column to the grid, allowing you to select a groupingmethod
such as: Sum, Avg, Min, Max, Count, and so forth. It adds GROUP BY to the
SQL statement. If you select aGroupBy criteria, it also adds it to the SQL
expression.

Distinct Adds a DISTINCT term to the SQL statement, instructing the query to retrieve
only distinct record sets.

<table/view
columns
grid>

A list of the columns in the selected table or view.

The grid contains the following columns:

l Column. The name of the column in the table or view.

l Alias. An alias name for the column, if applicable.

l Output.When enabled, it includes the column in the SELECT statement.

l Sort. Enables you to sort the results in ascending or descending order.

l Sort Order.Whenworking with multiple sorted columns, this indicates the
sorting order beginning with 1.

l Filter. Enables you to filter the results of the query, by adding a WHERE
<column_name> = <filter text> to the SQL statement.

<SQL
statement
preview
pane>
(bottom left)

A preview of the SQL statement generated by your selections.

<returned
rows pane>
(bottom
right)

The rows returned by the query.

Tip: If you enableAuto Execute, these rows display the current query
results.

Auto Execute Automatically executes the SQL statement in thePreview pane whenever you
make a change in the upper panes of the dialog box.

Tip: If you notice that the query takes a long time to execute, you can

disable this option and click theExecute query button tomanually
run it.

Execute query. Executes the query shown in thePreview pane. Use this when
Auto Execute is disabled.

Tip: If theReturned rows pane is grayed out, this indicates that the results
are not current.
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Java Class Dialog Box

This dialog box enables you to configure the settings for a call to a Java class.

To access Do the following:

1. Add aCall Java Class step to the canvas.

2. In the Properties pane, click the Input/Checkpoints tab .

3. Click the Java Class button.

Relevant tasks " How to Create a Call to a Java Class" on page 402

User interface elements are described below:

UI
Elements

Description

Jar The Jar (Java Archive) file to use in the Java call.

Embed
Jar in Test

Copies the Jar file to the test's EmbeddedJavaResources folder. This allows the
test to be ported to other machines. (Due to a limitation, youmust select this check
box before you browse for the class file.)

Package
root

The root folder containing the classes to be called by the step.
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UI
Elements

Description

Class file The Java class to associate with theCall Java Class step. When you click
Browse, it shows the classes in the specified .jar file.

Additional
classpaths

Additional classpaths to associate with theCall Java Class step.

l Jar. Opens theSelect Jar File dialog box.

l Folder. Opens theBrowse for Folder dialog box to select a folder containing
the .class file.

l Add. Adds the contents of theAdditional Classpath box to the additional
classpath list.

l Remove. Removes the selected entry from the list.

System
classpath

The paths you defined in the Test Settings for system classpaths.

Tomodify this setting, click on theStart orEnd step and open the Properties
pane's General view. Modify the Test Setting's JVM > Classpath node.
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Troubleshooting and Limitations - Activities
This section describes troubleshooting and limitations for working with activities.

System Activities
l End Program. You cannot specifyWindow Title as an input method for a windowless

process, even if you are using a wildcard expression.

l End Program. If you are running on a 64-bit machine, theEnd Program activity will not be able
to terminate 64-bit applications. However, it can terminate other 32-bit applications.

Java Activities
l Call Java Class. Supports only Java primitive types.

l Call Java Class. Once you select a Java file for the call, the Java Class button is disabled. As
a result, you cannot replace or update the Java file.

Workaround:Remove the step containing theCall Java Class step and add a new one using
the new Java file.

l Call Java Class. Java code loaded by the JVM (Java Virtual Machine) cannot bemodified or
updated when the JVM is running.

Network Activities
l HTTP Request/Receiver. Nested transactions are not support ed.

Workaround: Add a new loop activity within an existing transaction. Add the new transactions
steps to the newly created loop. Make sure to set the loop iteration to 1.

l HTTP Request/SOAP Request. XML file that use XSL, are not supported.

l SOAP Request. Switching between Text andGrid views, may cause the grid to display an
element added below the Body's Any node, under the Header's Any node.

Workaround: Open the Text view to view the correct XML.

Database Activities
l Nested transactions are not supported in database transaction activities.

Workaround: Add a new loop activity within an existing transaction. Add the new transactions
steps to the newly created loop. Make sure to set the loop iteration to 1.

l Databases which are supported by ODBC, but not by OLEDB, cannot be accessed by Service
Test.

FTP Activities
l FTP:Whenworking with FTP activities that specify paths, you need to enter the full path.

l FTP Download:When downloading from Linux servers, you cannot download an empty folder.

IBMWebsphere MQ Activities
l Get Message from MQ Queue. TheMQGMO_MARK_SKIP_BACKOUT option is not

supported.
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l Put Message to MQ Queue, Publish Message to MQ Topic. Themessage body should not
exceed 64K bytes. If it exceeds this size, the execution issues aMQRC_CONVERTED_
STRING_TOO_BIG status. This is a limitation of IBMMQ.

l MQ Steps. Automatic linking of IBMWebsphereMQ steps to themost recent Connect to MQ
Queue Manager connection, is supported only when the steps are on the same level in the
container, or if the connection step is in a parent container. If the connection step is in a leaf
container and the step using the connection is in a parent container or in another leaf, Service
Test does not create an automatic link.

Workaround:Manually link to aMQManager property using the Select Link Source dialog box.
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Concepts

Local Activity Overview
In addition to theStandard activities built in to Service Test, you can create or import other
services and activities. These activities, displayed under the Toolbox pane's Local Activities
node, areWeb Service, REST Service, Web Application Services, .NET assembly operations,
SAP IDocs/RFCs whose contract/document or DLL you import.

The activity groups—REST Services,Web Services,Web Application Services, .NET
Assemblies, and SAP—are displayed only after importing or defining at least one entity.

This section includes:

l "Web Service Activities " below

l "REST Service Activities" on next page

l "Web-Application Services" on next page

l ".NET Assembly Activities" on next page

l "SAP Activities" on page 466

Web Service Activities
You typically begin creating a test by importing aWSDL file. This file provides a structure for the
test, since it describes the service in terms of its elements, argument values and properties. For
details on importing aWSDL, see "How to Import aWSDL-BasedWeb Service" on page 472.

If your service changed during development, you can use the updatemechanism for updating the
service. For details, "Updating Services and Assemblies" on page 520.

The import supports both Document/Literal and RPC typeWeb services.

InDocument/LiteralWeb services, the client sends standard XML documents to the server. The
server application is responsible for mapping the server objects (properties, method calls, and so
forth) and the values in XML documents. The data is serialized according to a given schema, so it
can be validated against the schema. For Document/Literal typeWeb services, the Properties pane
displays the input and output properties in a grid, allowing you to assign values for each property
independently.

InRPC typeWeb services, theWSDL file and SOAP body contain the complete operation name,
its input and output properties, and their values. There is no schema for this type of service and it is
not supported by theWS-I conformance standard. The Properties pane does not display the input
and output properties for RPC type services.

If your service document is unique and cannot be imported in the normal way, you can use the
SOAP Request activity to send amanual SOAP request to the server.

TheWS-I validation tool lets you validate imported services by checking their conformance with the
WS-I standard. For details, see "Validate theWSDL file - optional" on page 473.

After you import aWeb service, the tree hierarchy displays its components in several levels:
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l Level 1. Service name

l Level 2. Port number

l Level 3. Operation name

For details about importing aWeb service, see "How to Import aWSDL-BasedWeb Service" on
page 472.

REST Service Activities
You can define REST services, their resources, andmethods. You define themetadatamanually
by modeling the service and defining your own resources andmethods. The services, resources,
andmethods are then stored as a prototype activity within your test.

After you define a REST service and its resources andmethods, Service Test creates a hierarchy
of Service, Resource, andMethod, depending upon how you defined your REST service.

Service Test provides a designer window for creating and configuring REST servicemethod
activities. You drag the RESTmethods onto the canvas, just as you would with other Toolbox pane
activities.

After creating RESTmethods, you can reuse them for multiple steps. For details, see "How to
Create a RESTMethod" on page 475.

Service Test also enables you to update REST service definitions through the "Resolve REST
Method Steps Wizard" on page 535.

In addition, you can also define properties and parameters for your REST service at all levels of the
hierarchy and pass these properties or parameters from the service and resource levels to the
resource and method levels. For details, see "Passing REST Service Properties" on page 467.

Web-Application Services
WebApplication services provide a description of a HTTP-basedWeb application in an XML
format. This description is contained in aWeb Application Description Language (WADL) file. This
WADL file describes the resources provided by a service and themethods used to access the
service.

Like aWeb Service, you import aWeb application service into Service Test. The resources and
methods are then displayed in a hierarchy like a REST service, with a Service, Resource, and
Method hiearchy.

The URL for aWeb application is defined in the XML of theWADL file. However, you can define
other HTTP properties as well as add and define input and output parameters for an activity's
methods.

Like REST services, you can define parameters and parameters values at all levels of theWeb
Application hierarchy and pass these parameter values to lower levels of the hierarchy.

The importedWeb Application servicemethods serve as a prototype for test steps. You canmodify
the parameter values of amethod after dragging themethod to the canvas.

.NET Assembly Activities
The .NET importer lets you create activities for testing APIs in the form of .NET assemblies. You
can interface with the types defined in the assembly.
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You begin by importing the .NET assembly into your test. The Toolbox pane displays the assembly
as an activity. You drag the .NET activity on to the canvas as you would with any other activity.

You can define input and output properties and link them to other steps within your script. For
example, you can design a test that retrieves an object through the .NET assembly. This object can
be an input property for aWeb service step.

When you import a .NET assembly, it saves a local copy of the assembly with the test, making the
test portable should you copy it to another machine. If the assembly, however, calls other
assemblies, the test may not run until you copy the additional assemblies to the new machine.
When running the test, it uses the local copy of the assembly, and any dependent assemblies are
referenced at their original locations.

For task details, see "How to Create a .NET Assembly API Test Step" on page 473.

For user interface details, see "Import .NET Assembly Dialog Box" on page 494.

SAP Activities
The SAP importer lets you create SAP activities in the Toolbox pane, by importing SAP
Intermediate Documents (IDoc) and Remote Function Calls (RFC).

These activities can be useful for testing the SAP server response in several common scenarios:

l Send an IDoc to an SAP server, and confirm that the IDoc was sent

l Check an IDoc's status on the SAP server

l Call an RFC in SAP and ensure that it returned the expected results

These activities can be also be useful when upgrading a system to verify that the integration
patterns are still functional, such as Aggregator, Enricher, Router, Translation, Bridge, Splitter, and
so forth.

First you define one or more SAP Connections in the SAP Connections pane in the Options dialog
box (Tools > Options > API Testing tab > SAP Connections node). For details, see "SAP
Connections Pane (Options Dialog Box > API Testing Tab)" on page 275.

Once the connection is established, you can search for an IDoc or RFC and import them as
activities into the Toolbox.

Once they are in the Toolbox, you can add them to a test or action and assign property values as
with all other steps.

For task details, see "How to Create an SAP Test Step" on page 485.

For user interface details, see "Import from SAP/Update Dialog Box" on page 502.

Activity Sharing
The activity sharing feature enables you to save locally stored services to a repository, so that they
will be available for other tests.

You can specify a repository on the file system or in ALM. The next time you create a test, you can
access the service's activities from the repository instead of reimporting or recreating them.
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If the resource (WSDL or REST service) becomes unavailable, the canvas displays alerts on the
steps that use the resource. If you run the test when its resource is not available from its original
source, it uses a copy of the test stored in its cache. By clicking the alert, you can reload the steps
when the resource becomes available again.

The Toolbox pane detects version updates for activities stored in a repository. When it detects a
discrepancy between the step and the Toolbox pane activity, it displays an alert for the step. By
clicking the alert, you can automatically update the resource from its source.

Passing REST Service Properties
When creating or editing a REST service, youmay want to define the value of a URL property or a
custom input or output property at the service or resource level in order to make this property or
parameter available for all resources andmethods included in the service or resource. For example,
if your REST service resources andmethods are all referencing the sameURL prefix during run
time, you can define the value of URL property at the service level of the REST service and pass
the URL property value to all its resources andmethods.

You can also define custom input and output property names and values at all levels of the
hierarchy and pass these input and output properties and their values through the REST service
hierarchy. For details on creating custom input and output properties, see "Define custom
properties - optional" on page 477.
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After a URL property value is defined at a higher level, you can define other (relative) additions to
the URL property value for any of the resources andmethods below it. These adjusted relative URL
values are then concatenated to the URL property value that was received from higher levels of the
hierarchy and the adjusted values are passed to all levels below it. For example, if you add a URL
property value at the service level, you can append relative URL paths for a selected resource or
method. The URL property value passed from the service level is then concatenated with the
relative URL property value added at the resource or method levels.

Note: You cannot modify URL property values passed down from a higher level of the REST
service hierarchy. You can only add to them with a relative URL value.

After you add additional relative URL property values at lower levels of the hierarchy, such as at the
resource or method level, youmust assure that the full URL is a proper URL. For example, if you
define the URL property value at the resource level with http://, the relative URL property value
appended at themethod level should not also use a http:// prefix.

Example
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You define a URL property value for the REST service at the service (top)
 level: http://flights.api.com. This value is then passed to any resources and
methods within this REST service.

You also create a resource for this service, called Flight Reservation. You define the relative
URL value as /reserve. This relative URL property value is then concatenated with the
URL property value passed from the service level to create a URL for the
resource: http://flights.api.com/reserve. This URL property value can also pass to
any methods created for the resource.

You then create amethod for the Flight Reservation resource, calledGetFlights and define the
relative URL property value for this method as /getflights. This value is then further
concatenated with the URL passed from the resource tomake a complete URL for themethod:
http://flights.api.com/reserve/getflights.

The example below shows the URL property value passed from the service level
(http://api.flights.com) and the relative URL property value defined at the resource level
(/reserve), with the relative URL property value for themethod (/getflights) also defined.
These URL parts are then concatenated in theURL property field to make the complete URL for the
method.
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These properties and custom input or output properties then serve as a prototype template for the
REST service, and you can edit the URL property values or custom input and output property
values after dragging themethod activities in the canvas.

Note: The relative URL is not displayed on the REST method when it is included in a test in the
canvas. Only the full, concatenated URL for themethod displayed in the Add REST Service
dialog box is displayed in the Properties pane for the selectedmethod.

Exposing Properties
Whenworking with REST servicemethods saved in tests created in Service Test 11.51 or earlier,
the Properties pane enables you to expose input and output HTTP properties. Exposing HTTP
properties means that youmake them available at the RESTmethod wrapper level instead of just
the inner HTTP level. You can expose properties that are available from theGeneral, Input/
Checkpoint, HTTP, andMultipart views.

Note: You can only expose properties if you are working with tests created in Service Test
11.51 or earlier.

The following example shows the shortcut menu item, Expose as an input property. This option
prompts you to provide a name for the property as it should appear in the REST wrapper level.

The property, HTTP method, will be available in the RESTmethod wrapper. To see the exposed
property, select the RESTmethod wrapper in the canvas —not the inner HTTP Request.
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Note:

l When exposing a property with incoming links, the links are redirected to the newly created
property.

l When exposing a complex property, the new property will be created as aString type.

For user interface details, see "New Exposed Property Dialog Box" on page 638.
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Tasks

How to Import a WSDL-Based Web Service
This task describes how to import aWSDL file into your test.

This task includes the following steps:

l "Prerequisites" below

l "Open the Import WSDL dialog box" below

l "Select a source " below

l "Set connection settings for URL/UDDI imports - optional" below

l "Mark theWSDL as a server response - optional" on next page

l "Complete the import" on next page

l "Validate theWSDL file - optional" on next page

1. Prerequisites
If you intend to import aWSDL stored on ALM, the ALM project to which you are connecting
must have the Service Test Management extension enabled. For details, see the "ALM
Connection Dialog Box" on page 335.

2. Open the Import WSDL dialog box
n To import aWSDL from the file system or ALM, click > Import WSDL

from File or ALM Application Component. For details, see the "Select WSDLDialog
Box" on page 488.

n To import aWSDL from aWeb site or UDDI repository, click > Import
WSDL from URL or UDDI.

o For a URL, select Import from: URL

o For a UDDI, select Import from: UDDI

For details, see the "Import/UpdateWSDL from URL or UDDI Dialog Box" on page 489.

3. Select a source
n For File System orALM Application Components imports, click the appropriate button in

the left pane. Navigate to theWSDL in the file system or the ALM repository.

n For aURL import, click theBrowse button adjacent to theAddress field. This opens a
browser window. Navigate to theWSDL and close the browser. This automatically places
the URL in theAddress field.

n For aUDDI import, click theBrowse button adjacent to theAddress field. This opens the
Select Service from UDDI dialog box. Specify a UDDI address and select the service to
import. For details, see the "Select Service from UDDI Dialog Box" on page 490.

4. Set connection settings for URL/UDDI imports - optional
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For URL or UDDI imports, if yourWSDLmust be accessed through a secure server or proxy
machine, click Advanced Settings to expand the dialog box. Enter the authentication
information or the proxy server details.

5. Mark the WSDL as a server response - optional
You canmark the importedWSDL as a server responsemethod. This is useful when working
with asynchronous Web services. Click Advanced Settings to expand the dialog box and
select the Import as server option. For details about working with asynchronous services, see
"Asynchronous Services" on page 602.

6. Complete the import
Click OK. If the import succeeds, the Toolbox displays the service, its ports, and operations
under theWeb Services node. The Toolbox pane differentiates between
Document/Literal and RPC encoded services with different icons.

7. Validate the WSDL file - optional
To check theWSDL's compliance with theWS-I standard, right-click the service and select
Validate WS-I Compliance from the shortcut menu. TheOutput window shows theWS-I
validation results. These validations apply only to Document/Literal type services, but not
RPC.

How to Create a .NET Assembly API Test Step
This task describes how to create a test step for verifying the functionality of a .NET assembly.

This task includes the following steps:

l "Prerequisite " on next page

l "Open the Import .NET Assembly dialog box" on next page

l "Select a GAC assembly - optional" on next page
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l "Import a .NET assembly" below

l "Add a .NET assembly step" below

l "Add properties - optional" below

l "Customize the code - optional" below

1. Prerequisite
Prepare a .dll assembly file and store it in a location accessible from your machine.

2. Open the Import .NET Assembly dialog box

Click the Import .NET Assembly button on the toolbar. For user interface details, see
"Import .NET Assembly Dialog Box" on page 494.

3. Select a GAC assembly - optional
Each computer where the common language runtime is installed has amachine-wide code
cache called the GAC (Global Assembly Cache). TheGAC stores assemblies specifically
designated to be shared by several applications on the computer.

In theGAC tab, select one or more GAC assemblies and click Select to add them to the
Selected References list.

4. Import a .NET assembly
Click the .NET Assembly Browser tab. Locate the assembly .dll or .exe file. Select the
file and click Select to add it to theSelected References list. Click OK to add the .NET
assemblies to the Toolbox pane.

5. Add a .NET assembly step
Expand the .NET Assemblies category in the Toolbox pane and drag a .NET activity onto the
canvas.

6. Add properties - optional
a. In the Properties pane's Input/Output tab, click theAdd Input/Output Property button

to define new input and output properties.

b. In theAdd Input/Output Property dialog box, specify a property name and data type.

o To add a simple type property, select a type from the drop down.

o To add an advanced type, click Advanced and select a type. All .NET types and .dll
files referenced by the test, and all types from the imported assemblies, are available.
To filter the types, enter a keyword into the Type field.

c. Click OK to add the property. Repeat this for all of the required input and output properties.

7. Customize the code - optional

In the Properties pane, click theEvents button . Double-click in the ExecuteEvent's
Handler column. The TestUserCode.cs tab opens.

Edit the Todo area. You can access input and output properties that you defined earlier, using
autocompletion.
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The comments indicate the syntax to use for accessing the properties. For example:

/// Use this.CodeActivity4 to access the CodeActivity4

Activity's context, including input and output properties.}

public void CodeActivity4_OnExecuteEvent(object sender,

STActivityBaseEventArgs args)

{

this.CodeActivity4.Input.Property1...

...

How to Create a REST Method
This task describes how to set up a RESTmethod service. You define the request body and
properties in order to create a prototypemethod that could be reused by multiple test steps.

This task includes the following steps:

l "Prerequisite " below

l "Open the REST service designer" on next page

l "Name the REST service" on next page

l "Add a resource" on next page

l "Add amethod" on next page

l "Set the General properties" on next page

l "Set the URL property values" on next page

l "Define themethod's HTTP properties" on next page

l "Define custom properties - optional" on page 477

l "Enter the request body directly - optional" on page 477

l "Link the body request to a data source - optional" on page 477

l "Test themethod" on page 478

l "Add themethod to the toolbox" on page 478

l "Use the REST activity" on page 478

l "Expose input and output properties - optional (for API tests created in previous versions)" on
page 479

l "Edit the prototype service" on page 479

l "Resolve conflicts between the prototype and the test step - optional" on page 479

l "Share the service - optional" on page 479

1. Prerequisite
Study the structure of the REST Service body and determine which resources andmethods
you need to define.
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2. Open the REST service designer

Click theAdd REST Service toolbar button . The Add REST Service dialog box opens.
For details, see the "Add/Edit REST Service Dialog Box" on page 495.

3. Name the REST service
Click on theNew Service node and provide ameaningful name for the service in the left pane.

4. Add a resource

Click theAdd Resource toolbar button to add a resource to the REST service. Click on
theREST Resource node and provide ameaningful name for the resource.

5. Add a method

Click theAdd Method toolbar button to add amethod. Click on theMethod node and
provide ameaningful name for themethod.

6. Set the General properties

a. In the right pane's Properties list, open theGeneral tab.

b. Enter values for the properties. For details, see the "General Tab (Properties Pane)" on
page 195.

7. Set the URL property values
a. In the REST Service editor, select a REST service, resource, or method.

b. In the General tab, enter the URL property value:

o If you are entering a URL property value for a REST service, enter the URL prefix in the
URL property row, beginning with a http://

o If you are entering a URL property value for a REST resource or method, enter the URL
property value in the Relative URL property row.

Note: If you enter a URL property value for the service or resource of your REST
service, the URL property values are passed to all resources or methods included in
the service or resource. For details, see "Passing REST Service Properties" on page
467

8. Define the method's HTTP properties
a. Select a REST servicemethod.

b. In the REST service editor's right pane,click theHTTP Input/Checkpoints tab.

c. For eachmethod, modify theHTTP method andHTTP version.

d. Use the plus sign in theRequestHeaders parent node to add name and value pairs for
the request header array.

For details, see the "Input/Checkpoints/Output Properties Tab (Properties Pane)" on page
201.
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9. Define custom properties - optional
Formethods that require input, such as PUT or POST, you can add custom input properties. For
methods that provide an output such as GET, you add the required output properties. To create
these properties:

a. In the right pane's Properties list, click theCustom Input/Checkpoints tab .

b. Expand the plus button and select Add Input/Output Property.

c. Provide a name, data type, and description (optional) for each property.

d. Enter the property values in theValue column.

10. Enter the request body directly - optional
This step describes how to enter the request body directly. (For details on linking to a data
source, see the next step.)

a. Return to the design document for the REST service and copy the Request body onto the
clipboard.

b. In the right pane of the Add REST Service window, open theHTTP tab. Make sure the
Body type in the drop down is set to Text, and click within theBody section. Press
CTRL+V to paste the contents of the request into the pane. Make sure that there are no
extra spaces before or after the body text.

c. Modify the element values within the XML body as required.

11. Link the body request to a data source - optional
This step describes how to enter the Request body through a data source. (For details on
entering the Request body directly, see the previous step.)

a. Return to the design document for the REST service and copy the request body to the
clipboard.

b. In the right pane of the Add REST Service dialog box, open theHTTP tab . Make sure the
Body type in the drop down is set to Text, and click within theBody section.

c. Click the Link Body button to the right of the pane, to open the Select Link Source
dialog box. For details, see "Select Link Source Dialog Box" on page 630.

d. In the Select Link Source dialog box, click Custom Expression to expand the dialog box.
Paste the clipboard contents, the Request body, into theExpression area.

e. In theExpression area, highlight the value of the element you want to link. In the upper
pane, double-click on the custom property you defined earlier in the properties list. The
property is now linked to a value.
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f. Themodified expression appears in theExpression area. In the following example the
custom Class property is linked to Class element in the REST document.

<Class>{Step.InputProperties.RestMethod.Class}</Class>

g. Click OK. Service Test places the data in theBody area.

12. Test the method

Click the RunMethod button on the toolbar to test themethod with its property values.
Note the results in the lower section of the window. If something needs to bemodified, do so at
this point.

13. Add the method to the toolbox
Click OK in the Design REST Service dialog box. Service Test adds the REST service along
with its resources andmethods to the Toolbox pane, under the Local Activities category.

14. Use the REST activity
You have now created a prototype for a RESTmethod, complete with input parameters and
HTTP information. You can now drag the activity, whose primary properties are already
defined, onto the canvas. A wizard helps you resolve any conflicts between the original
prototype and a test step. For details, see "How to Resolve Conflicts in a REST Steps" on
page 525.
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15. Expose input and output properties - optional (for API tests created in
previous versions)
You can forward built-in HTTP properties to the RESTmethod wrapper. This is useful for
making specific HTTP properties available at the wrapper level.

Note: If you created a REST method in Service Test 11.52 or Service Test 11.52 or later,
all REST properties are incorporated into the REST activity step itself without a wrapper.

a. Double-click a RESTmethod from the Toolbox pane to add it to the canvas. Expand the
method to show theHTTP Request frame.

b. Click in theHTTP Request frame. Select a property in the Properties pane and select
Expose as Input Property orExpose as Output Property from the right-click menu.

c. Provide a name for the property in the New Exposed Property dialog box.

d. Click the RESTmethod wrapper in the canvas, and view the newly exposed property in the
Properties pane's Custom Input/Checkpoints tab .

For details, see "Exposing Properties" on page 470.

16. Edit the prototype service
To edit a REST servicemethod's properties, select it in the Toolbox pane and chooseEdit
Service from the right-click menu. For details, see the "Add/Edit REST Service Dialog Box" on
page 495.

17. Resolve conflicts between the prototype and the test step - optional
If you created a test step using a template RESTmethod and then changed the template
method, the canvas adds an alert icon adjacent to the affected steps. Click the alert icon to
open the Resolve RESTMethod wizard to resolve any conflicts. For details, see the "Resolve
RESTMethod Steps Wizard" on page 535.

18. Share the service - optional
To add a REST service to the test repository, to make it available for other tests, share it.
Select the parent service node in the Toolbox and chooseMove to from the right-click menu.
For details, see "How to Perform Activity Sharing" on page 486.

For an example of creating a REST Service with data driving and data tables, see theHP
Tutorial for Service Test.
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How to Send a JSON Request to a REST Service
This task describes how to send a JSON request for a REST service.

This task includes the following steps:

l "Set the HTTP properties" below

l "Prepare to load the request body" below

l "Load the request body" below

l "Modify the JSON body - optional" below

l "Data drive or link to fields - optional" on next page

Note: The following tasks show how to send a single JSON request. To create a reusable
model, create a prototype. For details, see "How to Create a RESTMethod" on page 475.

1. Set the HTTP properties

Note: If you are working with test created in Service Test 11.51 or earlier, youmust
expand the REST activity's wrapper and enter these properties in the HTTP Request step
found inside the REST activity wrapper.

In the Properties pane's Input/Checkpoints tab , set the destinationURL and theHTTP
method, usually POST or PUT.

2. Prepare to load the request body

Open the Properties pane's HTTP view . Select aBody type JSON.

3. Load the request body
Click the Load JSON button and locate the .json file. Click OK.

4. Modify the JSON body - optional
If you intend to dynamically assign values to the JSON body from a data source, you need to
add escape characters. Open the Text view of the JSON body and add the escape character, \,
for each occurrence of a square or curly bracket ({, }, [, and ]). Do not use an escape
character for link expressions enclosed by curly brackets. For example:

\{"results":

\[

\{"name": "John", "id": 873829904, location: "NY"\},

\{"name": "Linda", "id": 726371109, location: "LA"\},

\{"name": "Mike", "id": 711029345, location: "NY"\},

\]

\}

When no links are used, this is not required.
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5. Data drive or link to fields - optional
To data drive or link to specific JSON fields, highlight the value in the body text, click the Link
Body button , and select a data source. For details, see "Select Link Source Dialog Box"
on page 630.

How to Receive a JSON Response from a REST Service
This task describes how to receive a JSON response from aREST service. All HTTP Request
activities are capable of receiving JSON responses.

This task includes the following steps:

l "Add a request header - optional" below

l "Add checkpoints - optional" below

Note: The following tasks show how to receive a single JSON request. To create a reusable
model, create a prototype. For details, see "How to Create a RESTMethod" on page 475.

1. Add a request header - optional

Note: If you are working with test created in Service Test 11.51 or earlier, youmust
expand the REST activity's wrapper and enter these properties in the HTTP Request step
found inside the REST activity wrapper.

If your server requires you to specify JSON during content negotiation, you need to set the
request header. In the Properties pane's Input/Checkpoints tab , click the plus sign to add a
RequestHeader array element. Add a custom request header named Accept with the value
application/json.

2. Add checkpoints - optional
If you require checkpoints to validate the response:

a. Open the Properties pane's HTTP tab . Click in the lower section of the tab, in the
checkpoint area.

b. To validate against regular expressions, set theBody type to Text. Add regular
expressions for each value that you want to validate.

c. To validate against a JSON response, set theBody type set to JSON. Click Load JSON
and locate the .json file with the expected values.

How to Import a Web Application Service
This task describes how to import aWeb Application service (WADL) into your test.

This task includes the following steps

l "Prerequisite " on next page

l "Import theWADL document" on next page
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l "Edit the service's properties - optional" on page 484

l "Use theWADL service's methods" on page 484

l "Share the service - optional" on page 484

1. Prerequisite
Before importing, study the structure of yourWADL document, as specific elements from the
document are imported into theWADL hierarchy inside Service Test.

<?xml version="1.0" encoding="utf-8" ?>

<application xmlns="http://wadl.dev.java.net/2009/02">

<resources base="http://example.com/api">

<resource path="books">

<method name="GET"/>

<resource path="{bookId}">

<param required="true" style="template" name="bookId"/>

<method name="GET"/>

<method name="DELETE"/>

<resource path="reviews">

<method name="GET">

<request>

<param name="page" required="false" default="1"

style="query"/>

<param name="size" required="false" default="20"

style="query"/>

</request>

</method>

<resource path="{index}">

<method name="GET" id="get index"/>

<param name="index" style="template"/>

</resource>

</resource>

</resource>

</resource>

<resource path="readers">

<method name="GET"/>

</resource>

</resources>

</application>

For details onWADL elements, see http://www.w3.org/Submission/wadl/.

2. Import the WADL document
In the toolbar, click on theAdd REST Service button and select Import WADL or select
Tools > Add REST Service > Import WADL. In the ChooseWADL file dialog box, navigate
to the directory in which theWADL is saved, and select theWADL file.

Note: You can import only WADLs saved on the file system.
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TheWADL service is imported to the Local Activities node of your test with its resources and
methods. TheWADL service, resource, andmethod hierarchy is created based on the XML
description provided in theWADL file, described below:

XML Element Service Test WADL Activity Hierarchy
Element

doc xml:lang="en"

title="RestService"

WADL service name

resource path="<resource

name>"

WADL resource

Note: If multiple resources have the same
name, Service Test numbers the resources
sequentially to differentiate between
resources.

method name="<method name>" WADL method

n Service Test assigns theWADL hierarchy
name using the following criteria:

n If a method name has an "id" attribute, the
name is taken from the value of the
"id" attribute.

n If a method name does not a have an "id"
attribute, then the name is defined as the
value of the "method name". For example,
if the "method name" is defined as
<"method name="GET"/>, UFT defines
themethod name in theWADL hierarchy as
GET Method.

Themethod name always contains the
HTTP method as part of its value. This
method (GET, POST, PUT, DELETE,
TRACE, OPTIONS, or HEAD is also used as
the HTTP method in the HTTP tab of the
WADL service. For details on the HTTP tab,
see "HTTP Tab (Properties Pane)" on page
199

Note: If there aremultiple methods of the
same name using the default values, then
themethods are defined with increasing
sequential numbers.
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param name="<parameter name>" WADL resource or method parameters.
These parameters are displayed until the Custom
Input/Checkpoints tab in the Edit REST Service
dialog and in Input/Checkpoints tab for methods
on the canvas.

If a "param name = <name>" string also
contains a "default=<value>" string, the
value defined in the XML is displayed with the
parameter.

resources

base="http://example.com/api"

WADL Service URL. This is displayed on the
HTTP tab for the service.

The URL is also passed to all resources and
methods included in the service. For details, see
"Passing REST Service Properties" on page
467.

Note: You cannot change the URL property
for an individual resource or method.

3. Edit the service's properties - optional
To edit theWADL service properties, right-click the service name in the Toolbox and select
Edit Service.

In the Edit REST Service dialog box, you can define general properties, parameters, HTTP
properties, and HTTP request and response information for the service, resources, and
individual methods. For details, see "How to Create a RESTMethod" on page 475.

For user interface details, see "Add/Edit REST Service Dialog Box" on page 495.

4. Use the WADL service's methods
After importing aWADL, you have created a prototype for the service, with methods,
HTTP properties, and parameters. Drag amethod to the canvas to use it in your test.

Note: You can edit all method properties after dragging the activity to the canvas.

Caution: If youmodify the service's properties after dragging amethod to the canvas, the
properties of your service will differ from the service's prototype (as defined in the
Toolbox). The Resolve REST Steps Wizard is not available to resolve differences for
WADL servicemethods.

5. Share the service - optional
To add aWADL service to the test repository, to make it available for other tests, share it.
Select the parent service node in the Toolbox and chooseMove to from the right-click menu.
For details, see "How to Perform Activity Sharing" on page 486.
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How to Create an SAP Test Step
This task describes how to create a test step for an SAP IDoc or RFC.

This task includes the following steps:

l "Prerequisite" below

l "Define an SAP Connection" below

l "Open the Import from SAP dialog box" below

l "Select a connection" below

l "Provide credentials - optional" below

l "Search for an IDoc or RFC" below

l "Add the IDoc or RFC to the Toolbox pane" below

l "Create a test/action step" below

1. Prerequisite
Youmust have the SAP .NET Connector installed on your machine. The installation is
available on the SAP Help portal, at http://help.sap.com/saphelp_
NW04/helpdata/en/e9/23c80d66d08c4c8c044a3ea11ca90f/content.htm.

2. Define an SAP Connection
Select Tools > Options > API Testing tab > SAP Connections node. In the SAP
Connections pane, define one or more SAP connections. For details, see "SAP Connections
Pane (Options Dialog Box > API Testing Tab)" on page 275.

3. Open the Import from SAP dialog box
Select Tools > Import from SAP. For user interface details, see "Import from SAP/Update
Dialog Box" on page 502.

4. Select a connection
Select one of the connections that you defined in the SAP Connections pane of the Options
dialog box.

5. Provide credentials - optional
Accept the default credentials (as entered in the SAP Connections pane in the Options dialog
box) or click Override connection to provide different information.

6. Search for an IDoc or RFC
Select IDoc orRFC and specify a search string using an asterisk (*) as a wildcard. Click
Search.

7. Add the IDoc or RFC to the Toolbox pane
Check the returned items and click Import Selected to add them to theSAP category in the
Toolbox pane.

8. Create a test/action step
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Expand the Local Activities > SAP > <Connection Name> > IDOCs/ RFCs node in the
Toolbox pane, and drag an SAP activity to the canvas. Provide values for theGeneral and
Input/Checkpoints properties.

How to Perform Activity Sharing
This task describes how to save activities to a repository, update them, and view their properties.

This task includes the following steps:

l "Connect to ALM" below

l "Set up the repository paths" below

l "Import aWSDL or create a REST service" below

l "Move the activity to a repository" below

l "View the service properties - optional" below

l "Refresh the activity - optional" on next page

l "Update the activity - optional" on next page

l "Add the activity to a new test - optional" on next page

1. Connect to ALM
If you want to work with a repository on ALM, connect to the desired ALM server. For details,
see the "ALM Connection Dialog Box" on page 335.

2. Set up the repository paths
a. Select Tools > Options > API Testing tab > General node.

b. In the Activity Repositories section, click theBrowse button and navigate to the location in
the file system or in ALM.

c. Click OK.

3. Import a WSDL or create a REST service
Import aWSDL file or create a REST servicemethod. The Toolbox pane shows the services in
the Local Activities node. By default, the test stores these activities in its
EmbeddedJavaResources subfolder.

4. Move the activity to a repository
Right-click the service node, and selectMove to > File System Activities orALM
Activities. This moves the service from Local Activities to File System Activities orALM
Activities in the Toolbox pane. The service is also removed from the test's
EmbeddedJavaResources subfolder and placed in the repository folder. The next time you
create a test, these activities will be accessible from the File System Activities orALM
Activities nodes.

5. View the service properties - optional
Right-click the service's parent node, and select Properties. The Properties window shows
the service's significant properties. For details see "Web Services Properties Dialog Box" on
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page 491.

6. Refresh the activity - optional
To reload theWSDL from its stored location, right-click the service node, and select Refresh

. This is useful in cases when theWSDL is stored in a shared location andmay have been
updated by another user.

7. Update the activity - optional
To reimport theWSDL from its original location, for example to revert back to the original
version, right-click the service node and select Update WSDL, or click theUpdate WSDL

button in the Toolbox pane .

8. Add the activity to a new test - optional
Open a new test. Expand the File System Activities orALM Activities node, select the
desired service or method, and drag it onto the canvas.

You can also remove shared activities from the toolbox and re-add them. For details, see
"Toolbox Pane User Interface" on page 256.
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References

Select WSDL Dialog Box
This dialog box enables you to import WSDLs from a file system or Service Test Management, the
ALM extension for working with application components.

To access 1. Create or open a test or component.

2. Select Import WSDL > Import WSDL from File or ALM Application
Component.

Relevant
tasks

"How to Import aWSDL-BasedWeb Service" on page 472

The following elements are included:

UI Elements Description

File System Displays WSDLs in the file system.

ALM
Application
Components

Displays WSDLs in the ALM repository.

Note: Available only if there is an open connection to ALM with the
Service Test Management extension.
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UI Elements Description

Import as
Server
Response

Imports theWSDL as a server response. Its methods will be server
responses—not requests. This is useful for asynchronous typeWeb
services.

File name The contract name:

l File System. The file name of theWSDL.

l ALM Application Components. The name of the application component
or service.

Files of type The document type:WSDL extension orAll files.

Import/Update WSDL from URL or UDDI Dialog Box
This dialog box enables you to import WSDLs using a URL or UDDI or update an existingWSDL
from a new location.

To access 1. Create or open a test or component.

2. Select Import WSDL > Import WSDL from URL or UDDI.

Relevant tasks "How to Import aWSDL-BasedWeb Service" on page 472
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The following elements are included:

UI Elements Description

Browse.

l ForURL imports: Opens a browser to allow you to navigate to a URL.

l ForUDDI Imports: Opens the "Select Service from UDDI Dialog Box".

Address The URL or UDDI path of theWSDL.

Advanced
Settings

Expands the dialog box to show the authentication and proxy settings.

Use
authentication
settings

The authentication settings by which to access theWSDL: Username and
Password.

Use proxy
settings

The authentication settings for the proxy server hosting theWSDL: Server,
Port, Username, andPassword.

Import as
Server
Response

Imports theWSDL as a server response. Its methods will be server
responses—not requests. This is useful for asynchronous typeWeb services.

Select Service from UDDI Dialog Box
This dialog box enables you to select and import WSDLs from aUDDI (Universal Description,
Discovery, and Integration) server.
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To access 1. Create or open a test or component.

2. Select Import WSDL > Import WSDL from URL or UDDI.

3. Select Import from: UDDI.

4. Click the button.

Relevant tasks "How to Import aWSDL-BasedWeb Service" on page 472

See also "Import/UpdateWSDL from URL or UDDI Dialog Box" on page 489

The following elements are included (unlabeled UI elements are shown in angle brackets):

UI
Elements

Description

UDDI
Address

The name or IP address of the UDDI server inquiry API.

Example: http://mysite.com:8080/uddi/inquiry

Version The UDDI version.

<list of
services>

A list of the services that match the filter criteria. The grid shows the following
information:

l Service Name

l Description

l Service Contract

l Service ID

Service
Name

A string in theWSDL name by which to filter the list.

Search Retrieves the list of services that match the string in theService name field. If no
string is specified, it retrieves all available services.

Web Services Properties Dialog Box
This dialog box displays the properties of importedWeb services.
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To access 1. Create or open a test or component.

2. Import aWSDL. Select Import WSDL >Import WSDL from URL or
UDDI.

3. Select the parent node of theWSDL in the Toolbox pane.

4. Select Properties from the context menu.

Relevant tasks "How to Import aWSDL-BasedWeb Service" on page 472

The following elements are included:

UI
Elements

Description

Name The name of theWeb service as defined in theWSDL file.

Location The current location of theWSDL. If it was updated from a location other than the
original, it will indicate the new location.

Working
Folder

A folder containing a local, working copy of theWSDL. ForWeb services moved to
the shared repository, this is a temporary folder.

Version TheWSDL version.

Creation
Date

The date and time in which theWSDLwas first imported.

Update
Date

The date and time of the latest update. If no updates were done, this value is the
same as theCreation Date.
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UI
Elements

Description

Import
Type

The way in which theWSDLwas imported: Regular orAs Server. For details about
importing theWSDL as a server response, see the "Select WSDLDialog Box" on
page 488.

REST Services Properties Dialog Box
This dialog box displays the properties of REST services.

To
access

1. Create or open a test or component.

2. Create a REST Service or import aWeb Application service. For details, see
"Add/Edit REST Service Dialog Box" on page 495.

3. Select the parent node of the service in the Toolbox pane.

4. Select Properties from the context menu.

Relevant
tasks

"How to Create a RESTMethod" on page 475

The following elements are included:

UI
Elements

Description

Name The name of the REST service as defined in the REST Service Designer.

Location The current location of the REST service files.

Working
Folder

The folder containing a local, working copy of the test. By default, this is <Test_
Folder>\EmbeddedResources\

NewService.
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UI
Elements

Description

Version The current version of the REST service.

Creation
Date

The date and time in which the service was created.

Update
Date

The date and time of the latest change and refresh. If no updates were done, this
value is the same as theCreation Date.

Import .NET Assembly Dialog Box
This dialog box enables you to import .NET assemblies in order to use them as activities from the
Toolbox pane.

To access 1. Create or open a test or component.

2. Click the Import .NET Assembly button on the toolbar.

Relevant tasks "How to Create a .NET Assembly API Test Step" on page 473

The following elements are included:
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UI Elements Description

GAC tab Displays a list of the GAC (Global Assembly Cache) assemblies.

Choose specific assembly version. Shows all versions of the GAC
assemblies as separate entries. This enables you to add a specific version of a
GAC assembly.

.NET
Assembly
Browser tab

Enables you to browse for an assembly to import.

Select Adds the selected assemblies to theSelected References list.

Selected
References

A list of the GAC assemblies that you selected. The grid shows the following
information:

l Reference Name. The name of the reference as it will appear in the Toolbox
pane.

l Type. GAC or Assembly

l Location. For GAC types, the class; For Assembly types, the full path of the
DLL.

Remove Removes the selected assemblies from theSelected References list.

Add/Edit REST Service Dialog Box
This dialog box enables you to define a new REST service.
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To
access

1. Create or open a test or component.

2. Do one of the following:

n Click theAdd REST Service button on the toolbar and select
REST Service Editor or Import WADL.

n Select a REST Service orWeb Application service node in the Toolbox pane,
and chooseEdit Service from the right-click menu.\

Relevant
tasks

"How to Create a RESTMethod" on page 475

Some user interface elements are available only when you select a specific node. The user
elements are (unlabeled elements are shown in angle brackets):

UI Elements Description

Expand All. Expands all of the nodes of the parent REST service.

Collapse All. Collapses all of the children nodes of the parent REST service.
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UI Elements Description

Add Method. Adds amethod to the selected REST service node.

Add Resource. Adds a resource to the selected REST service or resource.

Delete. Deletes the selected REST service, resource, or method.

Rename. Renames the selected REST service, resource, or method.

Run Method. Runs the selectedmethod and shows the results in the lower
part of the pane.

Note: Available only when you select amethod.

<properties
pane>

The properties of the REST servicemethods. For details, see the "Properties
Pane" on page 184.

<REST
Services tree>

Displays a list of the REST services that match the filter condition.

<results pane> The results of the Run Method command. This section also shows the
property values and the response.

Filter box Filters the display by the entered text.

Add Input/Output Property/Parameter Dialog Box
This dialog box enables you to define custom input or output properties for the current step or input
or output parameters for a test.

l For adding a property for a Custom Code or .NET Assembly step, see "Add Property for Custom
Code or .NET Assembly Activities" on next page.

l For adding a test property, see "Add Input/Output Parameter for Test Settings" on page 499.

l For adding a property for a REST activity step, see "Add Input/Output Property for REST
Service Steps" on page 501
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Add Property for Custom Code or .NET Assembly Activities

To access 1. Create or open a test or component.

2. Add a Custom Code or .NET Assembly activity to the canvas.

3. Select the Properties pane's Input/Checkpoints tab.

4. Click theAdd button and select one of the following:

n Add Input Property

n Add Output Property

Relevant tasks l "How to Create a .NET Assembly API Test Step" on page 473

l "Create a Custom Code activity - optional" on page 384

l "How to Define Test Properties or User/System Variables" on page 59

The following elements are included (unlabeled elements are shown in angle brackets):

UI
Elements

Description

Name A name for the property.

Type ForSimple types, a drop down list of simple data types, such as String,
Integer, and so forth.

Filter ForAdvanced types, a textual expression by which to filter the displayed
assemblies. For example, to show only those assemblies that begin with the
system prefix, enter system.
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UI
Elements

Description

Simple Shows the simple data types, such as String, Integer, and so forth.

Advanced Shows an extensive list of types, including all .NET types and DLLs referenced
by the test, and all types from the imported assemblies.

<list of
properties>

A list of the types, including .NET types, types from DLLs referenced by the test,
and all types of the imported assemblies.

Description A description of the property.

Add Input/Output Parameter for Test Settings
The image below shows the dialog used to add an input parameter. This example also shows the
options available when adding a test parameter to a test stored on an ALM server with Lab
Management.

To access 1. Create or open a test or action.

2. Select theStart orEnd steps in the canvas.

3. Click the Properties pane's Test Input/Output Properties tab.

4. Click theAdd button and select one of the following:

n Add Input Parameter

n Add Output Parameter (not relevant for ALM AUT Parameters)

Relevant tasks "How to Perform Server-Side Execution" on page 290.
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See also l "Server-Side Execution " on page 285

l "Select AUT Parameter Dialog Box" on page 299

The following elements are included:

UI
Elements

Description

Name A name for the parameter. A default name for the parameter is provided.

Type A drop down list of simple data types, such as String, Integer, and so forth.

Note: For parameters linked to ALM AUT parameters, the type will always
be String.

Default
Value

A default value for the parameter, used during the run session if no other value is
provided for the parameter.

Note: For ALM AUT parameters, you can set this value by selectingCopy
default value (override) in the "Select AUT Parameter Dialog Box"
(described on page 299).

ALM AUT
Parameter

The path to an ALM AUT Parameter from the Lab Resources > AUT
Environmentmodule in ALM LabManagement.

You cannot edit the text in this box. Use theSelect ALM application
parameters to enter an AUT parameter.

Note: Available only if Service Test is connected to an ALM server that has
the LabManagement module, and a test stored on that server is selected in
the solution explorer.

Select ALM application parameters. Opens the Select AUT Parameter dialog
box for selecting a parameter from an AUT environment defined in the Lab
Resources > AUT Environmentmodule. For details, see "Select AUT
Parameter Dialog Box" on page 299.

Note: Available only if Service Test is connected to an ALM server that has
the LabManagement module, and a test stored on that server is selected in
the solution explorer.
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UI
Elements

Description

Remove link to ALM application parameters. Removes the linking of the
selected parameter from ALM. This parameter will now be an ordinary test
parameter.

Note: Available only if Service Test is connected to an ALM server that has
the LabManagement module, and a test stored on that server is selected in
the solution explorer.

Description A description of the parameter.

Add Input/Output Property for REST Service Steps

To access 1. Create or open a test or component.

2. Open the Add REST Service Dialog box .

3. Create a RESTmethod, service, or resource.

4. Click theCustom Input/Checkpoints tab in the right pane .

5. Click theAdd button and select one of the following:

n Add Input Property

n Add Output Property (for RESTmethods only)

Relevant tasks "How to Create a RESTMethod" on page 475.

See also "Add/Edit REST Service Dialog Box" on page 495

The following elements are included:
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UI Elements Description

Name A name for the property.

Type A drop down list of simple data types, such as String, Integer, and so forth.

Description A description of the property.

Import from SAP/Update Dialog Box
This dialog box enables you to import an SAP IDoc or RFC into the Toolbox pane or update an
existing one from a new location.
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To
access

To import a new RFC or IDoc:

1. Define an SAP Connection. For details, see "SAP Connections Pane (Options
Dialog Box > API Testing Tab)" on page 275.

2. Select Tools > Import from SAP.

To update an RFC or IDoc from a different location:

1. Select the RFC or IDoc in the Toolbox pane.

2. Select Update from from the right-click menu.
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Relevant
tasks

"How to Create an SAP Test Step" on page 485

Some user interface elements are only available when you select a specific node or if you import a
new RFC or IDoc. The user elements are:

UI
Elements

Description

SAP
Connection

A drop down containing the names of the SAP connections defined in the "SAP
Connections Pane (Options Dialog Box > API Testing Tab)" on page 275 (read-
only).

Credentials The credentials to use for accessing the server:

l Default credentials for connection. Use the client and credentials defined
for the connection.

l Override connection.Manually provide client and credential information for
this import.

Search for The type of document to search for: IDOC orRFC.

Matching Thematching condition. Use an asterisk, *, as a wildcard.

Search Begins the search based on thematching conditions.

Results The IDOCs or RFCs that matched the condition.

Import
Selected

Imports the RFCs or IDocs indicated with a check mark into the Local Activities
> SAP section of the toolbox.

Update Updates the selected RFC or IDoc.
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Troubleshooting and Limitations - Test Activities
This section describes troubleshooting and limitations for working withWeb and REST services.

This section includes the following:

l "Web Services" below

l "REST Services" on next page

l "Web Applications (WADL)" on next page

l ".NET Assemblies" on next page

Web Services
l You cannot import WSDL files with names that are restricted by theWindows operating system.

This list includes: CON, PRN, AUX, NUL, COM1, COM2, COM3, COM4, COM5, COM6, COM7, COM8,
COM9, LPT1, LPT2, LPT3, LPT4, LPT5, LPT6, LPT7, LPT8, and LPT9.

Workaround:Rename theWSDL file before the import.

l The followingWSDLs are not supported:

n WSDL version 2.0

n WSDLs containing a <appInfo> element.

n RPC EncodedWSDLs configured as Asynchronous Web services.

n WSDLs authenticated by HTTP digest on Apache servers.

l When openingmany tests in the same solution using one or more of the sameWeb services,
Service Test may develop amemory leak.

Workaround: Move theWeb service to the file system or ALM repository. To do this, import a
Web service and then, in the Toolbox pane, right-click theWeb Service activity and select
Move to > File System Activities orALM/QC Activities.

l For aWeb service imported as a server response:

n RPC typeWSDLs cannot be imported as a server response. If you attempt to update a
service from anRPC encodedWSDL, it will create a duplicate entry.

n If you end a ServiceTest.exe process during the listening stage, after the binding was
added, the binding will not be removed from the system.

Workaround:Remove the bindingmanually using a utility such as httpcfg.exe or
netsh.exe.

n Whenworking with SSL, certificates from a file are not supported. If youmove the test to
another machine, the certificate will not be saved with the test.

Workaround:Add the certificate to the local machine store before the listener starts, and
remove it at the end of the listening process.

n The error messages displayed when importing aWSDL are not localized.
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REST Services
l Importing a schema to a REST, HTTP, or SOAP checkpoint may remove the links of the input

properties.

l Copy and Paste in the Toolbox pane is not supported for REST services.

l XPath checkpoints are not supported for HTTP and REST activities.

l Links that are defined in the Toolbox pane are deleted on the canvas.

l A link defined in the Toolbox pane cannot be deleted.

l Links between input and output properties of the sameRESTmethod in which the source
property is deleted without removing the link, the link expression still remains in the destination
property. If you save the test in this state, youmay be unable to reopen it.

Workaround:Delete the link explicitly either before or immediately after deleting its source
property.

l When defining a RESTmethod prototype in the Toolbox pane - in order to use the Trim,
Ignore, or Stop test options, select the check box in theValidate column, in the
Checkpoints pane.

l When running a RESTmethod using theRun Step command, checkpoints of dynamic property
values in themethod linked to other property values (input or output) are ignored.

Web Applications (WADL)
The following elements are not supported when importing yourWADL. UFT does not import these
elements into theWADL hierarchy inside your test:

l Grammars element

l Resource_type element

l Link element

Note: Any child elements of these elements are also ignored by UFT and not added to your
WADL inside the test.

In addition, if you use the href attribute to link to other elements, youmust refer to an element in the
sameWADL file. Linking betweenWADL files is not supported.

For more details onWADL elements, see http://www.w3.org/Submission/wadl/

.NET Assemblies
l .NET 4 assemblies are not supported. They cannot be imported or referenced.

l Importing or adding references to 64-bit .NET assemblies is not supported.
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Concepts

Actions Overview
Actions are sequences of operations that you perform within the context of a test, consisting of
either one or multiple steps. Calls to actions placed in your test enable you to test a specific area or
function of your application. In this way, your test can check the user interface and the application
functionality, such as opening a flight reservation system using based on aWeb Service.

Actions also allow you call a repeated activity, such as logging in to aWeb site multiple times.
Each time the action is called, the test calls the action steps, its properties, and its data. Instead of
recreating the process and entering its data each time you call the action, the call to an action refers
to the original action instead of having to define a new action.

An action contains its own test coding, including all of the steps in that action and all necessary
objects for its execution.

When you insert a call to an action into your test, the test adds the action to the Solution Explorer.
As a result, you can reuse the actionmultiple times within a test or call it from another test.

Actions can also be saved as business components to be used for Business Process Testing.

When to Use Actions
Actions are useful when you need to repeat a specific activity multiple times. For example, if you
are testing yourWeb service which requires a login, you can insert a call to a log-in actionmultiple
times instead of inserting a new log-in step each time it is needed.

Actions also enable you to parameterize repeated steps within your test. For example, if you want
to test yourWeb service for multiple users, you can call an action connected to a data source with
user information for multiple users. The call to an action gives you the ability to provide data for a
specific step or feature to ensure it works for multiple scenarios or users. Thus, you can not only
test the functionality of the processes of your application, but you can also test that the individual
elements within that process work correctly.

Actions also enable you tomodify a specific element within an application without affecting the
test. When the call to action is inserted in the test of a larger process, if the application element
changes, the entire test does not. The action properties are updated to reflect the change in the
application element. However, the application process test steps do not need to bemodified.

Calling Actions from Other Tests
You can call both actions defined within your current test or defined in other tests. When you call an
action from another test, by default its data is read-only. Using the Property View, you can enable
the action's data for editing. For details, see "How to Use Actions in a Test" on page 513.

Nesting and Repeating Actions
You can nest additional actions within existing ones. This allows you to create specialized actions
and call them at the desired point within your test.

You can also set the loop properties for individual actions, independent of the loop properties in the
main Test Flow. You click in the action's flow, and specify the loop properties in the Property View.
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Example

Suppose you want to test aWeb service which enables customers to book a flight and
purchase tickets. This requires you to test several processes and features: request aWeb
service, log in, choose flights, process customer information, output a complete reservation,
and log out. Testing this service also requires you to test both application processes and user
interface elements. Furthermore, youmight want to test the capability of a user, such as a
travel agent to use the service tomakemultiple reservations.

Your test might look similar to this model:

Action Placement
Service Test provides reusable actions that can be calledmultiple times within a test or by other
tests. These actions make it easier to maintain your tests, because when an object or procedure in
your application changes, themodified element is updated in all calls to the action.

Note: This is different from GUI Test (formerly QuickTest Professional) actions, which allow
you to indicate whether the action should be reusable or not.

Calls to Existing Actions
When you plan a test or multiple tests, youmay realize that each test requires identical, repeated
activities, such as logging in. Instead of inserting these steps three times in separate places or
tests (and adding checkpoints, parameters, and data) separately, you can create an action one time
and store it with the test. You then populate the action with activities from the Toolbox. After you
are satisfied with the action you have created, you can also call it from other tests.

If you call an action from an external test that has data assigned to its properties, you can indicate
whether you want the data from action's data sheet to be imported as a local, editable copy, or
whether you want to use the (read-only) data from the original action.

Tomodify the steps of an action from an external test, youmust open the test in which the action is
stored andmake your modifications there. Themodifications apply to all tests that call that action.

For more details, see "How to Use Actions in a Test" on page 513.
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Example

Suppose you want to create the following three tests for flight reservation--booking a flight,
modifying a reservation, and deleting a reservation. While planning your tests, you realize that
for each test, you need to log in and log out of the site.

Test 1 would contain three actions (Logging In, Booking a Flight, and Logging Out). Test 2
would contain three actions (Logging In, Modifying a Booking, and Logging Out). Test 1 would
contain three actions (Logging In, Cancelling a Booking, and Logging Out). The Logging In and
Logging Out actions are defined in the same test, and called as external actions by all three
tests.

Combining Steps into Actions
Multiple steps can be combined together to constitute an action. For example, when designing a
test to check yourWeb service for booking flights, youmay find that certain actions and processes
are repeatedmultiple times. You can select these steps on the canvas and group them in an action.
You can also select multiple steps using the standardWindows multiple selectionmethods, with
theSHIFT andCTRL keys.
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After selecting the steps you copy/cut and paste them into the action's tab. Your test can then call
the action, and apply loop behavior to the action as a single unit.

For more details, see "How to Use Actions in a Test" on page 513.

Actions Using the Data Table
You can use the Data pane tables to provide property values for your actions. Each action uses its
own data sources—not the test's data source.

Tip: If you want to use the same data for the test and in a specific action, youmust define the
data source path twice, once for the test and once for the action. See "Defining Data " on page
609.

By default, data from actions called from other tests, are not visible in your current test. You can
expose the data by enabling theAllow other tools to override the data option in the actions' test.
As a result, you can view the data in the Data Pane. It is marked with an icon  indicating that
this is data from an action.
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AnUpdate option allows you to reload the action's data in your test when it changes in its original
location. This only applies to data that you did not make editable. For details, see "How to Use
Actions in a Test" on next page.

Note: You can switch data from read-only to editable or vice versa. However, when changing
from editable to read-only, any changes made to the data are lost.

If an action is called repeatedly in the test, only one set of the action's data is displayed in the Data
Pane. If youmake changes to the data at the action's original location and it is not marked as
editable, then the changes are applied to all calls to this action.

For details on how Service Test handles data in a test, see "Data Handling Overview" on page 609.

Considerations for Working with Actions

Inserting Actions
You should consider using actions if:

l You intend to use an identical or virtually identical procedure or action in more than one test.

l Youwant to edit the data in a specific call to an action that you call multiple times within your
test.

Naming Actions
Youmay want to rename the actions in your test with descriptive names to help you identify them.
It is also a good idea to add detailed action descriptions. This facilitates inserting actions from one
test to another. You can rename an action by right-clicking on the action in the Solution Explorer and
selectingRename.

When renaming an action, make sure to use the following naming conventions:

l Cannot begin or end with a space

l Cannot exceed 1,023 characters

l Cannot contain the following characters: \ / : * ? " < > | % ' ! { }
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Tasks

How to Use Actions in a Test
This task describes the different operations you can perform to use actions in your test.

This task includes the following steps:

l "Insert a call to a new action" below

l "Call an existing action or a test" below

l "Set action properties" below

l "Copy or move steps" on next page

l "Remove a call to an action" on next page

l "Delete an action" on next page

l "Enable an action's data for editing when called by another test" on next page

l "Override data from an action called by another test" on next page

Insert a call to a new action
1. Select Design > Call to New Action.

2. Specify the action name and description. Click OK to add the call to the action to the canvas.

3. In the Solution Explorer, double-click the action to open its canvas.

4. Add steps to the action. Drag activities from the Toolbox onto the canvas.

Note: You can insert a call to another action, from an existing action call.

Call an existing action or a test
1. Drag anHP Automated Testing Tools > Call API Action or Test orCall GUI Action or

Test activity onto the canvas.

2. Open the Properties pane (CTRL+ALT+P).

3. In the Input/Checkpoints tab, click theSelect Action or Test button.

4. Select the desired test and action. Click OK.

Set action properties
To set an action call's properties, youmust set the values for each of the steps separately.

1. Select an activity within the action whose properties you want to set.

2. In the Properties tab, provide values or data drive the properties. For details, see the
"Properties Pane Tabs" on page 186.

3. The property values that you set will be the default values used when you add a call.
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Note: If you reload the service using theRefresh button, the new versionmay add or
remove properties. Properties that remain unchanged, will retain the default values.

Copy or move steps
Copying or moving steps is ideal if you want to copy or move existing steps into another location in
the Test Flow or to an action.

1. Make sure the actions into which you want to copy or move the steps, are open. To open an
action, double-click on it in the Solution Explorer or select Open from the action's context
menu in the test.

2. Select one or more steps that you want to copy or move. To select multiple steps, do one of the
following:

n Drag themouse pointer around the steps. A transparent rectangle is be drawn over the
selected area.

n Press SHIFTwhile selecting the beginning and ending steps to be grouped. All steps
between the endpoints are grouped.

3. Select Copy orCut from the context menu.

4. Place the cursor in the desired location. Select Paste from the right-click menu.

Remove a call to an action
In the test canvas, select the call to the action and press DELETE or right-click and select Delete

Delete an action
In the Solution Explorer, right-click the action and select Delete. The action is removed from the
Solution Explorer and all calls to the action are removed. Edited data from the removed step is
moved to themain node of the Data Pane as described in "Actions Using the Data Table" on page
511.

Enable an action's data for editing when called by another test
To view or override an external action's data, youmust expose it in its original location. This only
applies to Excel type data sources, and only available for tests—not business components.

1. Define data for the action that you will be calling. Assign the datamanually or use data driving.
For details, see "How to Assign Data to Test Steps" on page 621.

2. In the Data Pane, select the data source's node.

3. Open the Properties pane (CTRL+ALT + P) and select theAllow other tools to override the
data option. The Data pane creates a local copy of the data which can be edited.

Override data from an action called by another test
1. Make sure the action that you want to call has its data exposed. For details, see the above

step.

2. Open the test in which you want to add the call to the action.

3. In theHP Automated Testing Tools node, drag aCall API Action or Test or aCall GUI
Action or Test activity onto the canvas.
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4. In the Properties pane Input/Checkpoints tab, click theSelect Action or Test button.

5. In the Select Action or Test dialog box, browse for the test and select the desired action. Click
OK.

6.  Open the Properties pane and select theUse a local, editable copy option.

7. Edit the data tables in the Data pane.
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Reference

Insert Call to New Action Dialog Box
This dialog box enables you to create a new action for your test.

To access 1. Create or open a test or component.

2. Do one of the following:

n Design > Call to New Action

n Click the Insert Call to New Action button 

Relevant tasks "Insert a call to a new action" on page 513

User interface elements are described below:

UI Element (A-Z) Description

Name A name for the action as it will appear in the Solution Explorer and canvas.

Description A detailed description of the action.

Select Action or Test Dialog Box
This dialog box enables you to add a call to a copy of an action, or a call to an existing action within
your test.
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To access 1. Create or open a test or component.

2. Drag anHP Automated Testing Tools > Call API Action or Testactivity
onto the canvas.

3. Open the Properties pane.

4. Click theSelect Action or Test button.

Relevant
tasks

"Call an existing action or a test" on page 513

User interface elements are described below:

UI Element
(A-Z)

Description

Test The name of the test from which you are calling the action.

Browse. This allows you to browse your test library to find a test.

Action A drop down list of the actions available for the selected test. You can view a list
of the available actions in the Solution Explorer.

Description The original description given to the action (read-only).

Rename Action Dialog Box
This dialog box enables you to rename an action.

HP Service Test (11.52)Page 517 of 705

User Guide
Chapter 25: Reusable Actions in Service Test



To access Right-click on an action name in the Solution Explorer.

Relevant tasks "How to Use Actions in a Test" on page 513

See also "Considerations forWorking with Actions" on page 512

User interface elements are described below:

UI Element (A-Z) Description

New Name A new name for the action.

Actions Context Menu
The context menu for action steps is described below:

UI
Element
(A-Z)

Description

Cut Cuts the action from the current flow, and places it on the clipboard.

Copy Copies the selected action to the clipboard.

Delete Removes the selected action from the current flow.

Open Opens a tab for the selected action. This allows you to add steps and set properties
for the action.

Note: For external actions, stored in other tests, a message window asks if you
want to add the external test to your solution. This creates a local copy of the
action allowing you tomodify its data.
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Concepts

Updating Web Services
You can updateWeb services that exist in the Toolbox pane, from their original locations or from
alternate locations.

When you update a service, Service Test first compares the service and port names. If the port
names match, Service Test transfers all of the data from the updated service, including new
security information. If the new version of the service contains a port that was not present in the
original service, it adds it to the Toolbox pane, as an additional port for the service.

If the port paths (<service name:port name> combination) do not match, and security was
set for on the port level, Service Test opens theUpdate Port Security Wizard. For details, see the
"Update Port Security Wizard" on page 528.

If HTTP transport information such as the endpoint was changed, Service Test will update this
automatically, as long as the port path is the same.

In the next step of the update, Service Test compares the operations and properties of the current
test steps. Service Test tries tomatch up the properties that were assigned values between the
original service and the updated version.

If the operation names do not match, the Update Step wizard enables you tomap the new operation
name to the original name.

If the operation names match, but the property names do not, the Update Step wizard enables you
tomap the new property names to the original ones. Matching properties are ones that have the
same XPaths and types.

The wizard screenmarks resolved properties in green and unresolved properties in red.

If you originally imported a service from ALM through Service Test Management, youmust update
the service in ALM—youwill not be able to update the service through Service Test.

When you update an RPC Web service, as long as the operation names match, the properties are
marked as resolved. If the operation names cannot be resolved, Service Test opens the wizard. If
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there is no operation available tomap to the original, the wizard suggests that you delete the
affected step.

For task details, see "How to Update aWeb Service" on next page.

You can also update the data assigned to properties. When working with an Excel data source, you
can update the data in the Data pane. For details, see "New/Change Excel Data Source Dialog
Box" on page 98.

REST Service Conflicts
Using REST services that you added to the Toolbox pane, you can create tests with minimal
configurations. For details, see "How to Create a RESTMethod" on page 475.

If youmodify a REST step's properties after incorporating it into your test, it will no longer match the
method in the Toolbox. Youmay want to keep the change, or youmay want to remove the conflicts
so that your step will match themethod defined in the toolbox.

Youmay encounter conflicts in the following areas:

l Adding or removing an input or output property

l Renaming an input or output property

l A change in the REST service URL

l A change in the HTTP request/response body type or schema

l Internal links between a REST property and its inner HTTP elements (if you are working with a
test created in Service Test 11.51 or earlier

l HTTP methods

The Resolve RESTMethod Steps wizard enables you to view the conflicts and decide what to do
with the conflicts in your test step—keep, remove, or map them. The wizard lets you resolve
property-related conflicts. Other conflicts, such as discrepancies in the URL values, the HTTP
body, and so forth, are resolved automatically.

For wizard details, see the "Resolve RESTMethod Steps Wizard" on page 535.

For task details, see "How to Resolve Conflicts in a REST Steps" on page 525.

Updating SAP RFCs or IDocs
You can update SAP RFCs and IDocs from their original location or from another connection or
location.

TheUpdate option automatically updates the item from its original location. Service Test loads the
information for the RFC/IDoc with the same names, from the original connection.

TheUpdate from option lets you specify different connection information, or a name of a different
RFC/IDoc on the same server.

If Service Test detects an inconsistency between the original and updated RFC/IDoc names or
their properties, it enables the Update Step wizard. This wizard lets youmap the original and new
items. For details, see "How to Update an SAP RFC or IDoc" on page 526.
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Tasks

How to Update a Web Service
This task describes how to update aWSDL-BasedWeb Service that was already imported and
incorporated into a test.

This task includes the following steps:

l "Prerequisites" below

l "Update the service " below

l "Run the Update Port Security wizard - optional" below

l "Run the Update Step wizard" on next page

1. Prerequisites
If you want to update theWSDL from ALM, make sure you have an open connection to the
ALM server. For details, see the "ALM Connection Dialog Box" on page 335.

2. Update the service
n To update a service from its original location, select its main node in the Toolbox pane.

ChooseUpdate WSDL from the context menu.

n To update the service from a different location, or if theUpdate WSDL option is not
available:

i. Select the service's main node in the Toolbox pane.

ii. ChooseUpdate WSDL from > URL or UDDI orUpdate WSDL from > File or
ALM Application Component from the right-click menu.

iii. Navigate to theWSDL and click OK.

iv. Accept any warning or informational pop-ups.

Note: TheUpdate WSDL optionmay not be available if the user credentials changed or if
the service was imported using an earlier version of Service Test.

3. Run the Update Port Security wizard - optional
If Service Test detects a change in the port path (<service name:port name>
combination) theUpdate Port SecurityWizard opens. The wizard only opens if you
configured security settings for the original service. Follow the steps of the wizard to resolve all
of the Service/Port conflicts. For details, see "Update Port Security Wizard" on page 528.

Note:

n The wizard imports all of the services defined in theWSDL, even those deleted
manually before the update. To remove them from the Toolbox pane, delete them again
manually, after the update.
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n If youmanually remove a service with conflicts from the Toolbox pane, you will no
longer be able to resolve the conflicts using the wizard.

4. Run the Update Step wizard
If a test step became invalid because an operation name changed or properties with values
were changed, then the canvas marks the step with a warningmarker.

For details about the wizard, see the "Update Step/Activity Wizard" on page 530.

a. Click the warningmarker to display themessage The step must be resolved. Resolve
step. Click on themessage text. TheUpdate Step Wizard window opens.

Note that the step's properties become read-only, until you resolve them with the help of
the wizard.

b. In theSelect Operation page, click in theNew Operation pane and select the operation
that corresponds to the one in theOriginal Operation pane. Click Next. Properties for
which conflicts were detected are highlighted in red.

c. In theUpdate Input Properties page, in theOriginal Properties pane, select a property
for which there is a conflict, highlighted in red. In the right pane, New Properties, select a
property to map.

Click Map. The wizard adds themapping to the list in the bottom pane. Repeat this for all
properties that you want to map. Click Next.

d. In theUpdate Output Properties page, select a property for which there is a conflict,
highlighted in red. In theNew Properties pane select the property to which you want to
map. Click Map. The wizard adds themapping to the list of mappings in the bottom pane.
Repeat this for all properties that you want to map. Click Next.

e. Click Finish to save your changes and close the wizard.

How to Update a .NET Assembly
This task describes how to update a .NET assembly with a newer version. The updating of .NET
assembly is similar to the importing of an assembly described in "How to Create a .NET Assembly
API Test Step" on page 473.

This task includes the following steps:
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l "Select the assembly to update" below

l "Open the Import .NET Assembly dialog box" below

l "Import a .NET assembly" below

l "Handle warnings - optional" below

l "Modify custom code - optional" below

1. Select the assembly to update
In the Toolbox pane, expand the .NET Assemblies node and select the assembly you want to
update.

2. Open the Import .NET Assembly dialog box
Click the Import .NET Assembly button on the toolbar. For user interface details, see "Import
.NET Assembly Dialog Box" on page 494.

3. Import a .NET assembly
Click the .NET Assembly Browser tab. Click Browse and locate the .dll or .exe file. Click
Open in the Open dialog box to add it to theSelected References list. Click OK to begin the
update.

4. Handle warnings - optional
If the updated .NET assembly is missing types that are in use by existing activities, you will
need tomodify the step properties. The canvas displays warning icons adjacent to the steps
whose properties use themissing type.

5. Modify custom code - optional
If you wrote custom code in an event handler, youmay need tomodify the step properties. If
the updated .NET assembly is missing types that are used by the custom code, make sure to
modify the code to use only the types that are available.

How to Resolve Conflicts in a REST Steps
This task describes how to update a RESTmethod step that was changed.

This task includes the following steps:

l "Prerequisites" below

l "Modify the step as required" below

l "Open the wizard" on next page

l "Run the wizard" on next page

1. Prerequisites
Create one or more prototypemethods for REST services. Drag them onto the canvas to
create RESTmethod steps. For details, see "How to Create a RESTMethod" on page 475.

2. Modify the step as required
Modify the REST service step as required: add or remove properties, change property values,
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and so forth. If there are conflicts, the canvas will display warning icons next to the relevant
steps.

3. Open the wizard
n To resolve conflicts for the selected step, click the warning icon in the top right corner of the

RESTmethod step in the canvas. Select This step should be resolved. Resolve step.
The Resolve RESTMethod Steps wizard opens.

n To resolve conflicts for all steps created with the prototype, right-click themethod in the
Toolbox pane and select Apply Changes to all Steps.

4. Run the wizard
a. Select the steps that you want to resolve (only relevant when opening the wizard through

the Toolbox pane).

The left pane, Before Changes, shows the step's properties before they were resolved.
The right pane, After Changes, shows the step's properties after they were resolved.

b. Proceed with the wizard, resolving or keeping the detected differences.

For details about the wizard, see the "Resolve RESTMethod Steps Wizard" on page 535.

How to Update an SAP RFC or IDoc
This task describes how to update an SAP RFC or IDoc from its original or from a different location.

This task includes the following steps:

l "Update the RFC/IDoc from its original location" below

l "Update the RFC/IDoc from a different location" below

l "Run the Update Step wizard" on next page

Update the RFC/IDoc from its original location
To update an item from its original location, drill down to the actual RFC or IDoc in the Toolbox
pane. This assumes that the location and name of the RFC or IDoc did not change. ChooseUpdate
from the context menu.

Update the RFC/IDoc from a different location
To update an RFC or IDoc from a different server, or from the same server but a different RFC or
IDoc:

1. Select the RFC or IDoc in the Toolbox pane and chooseUpdate from from the context menu.
The Update <Item_Name> dialog box opens.

2. To change the connection or server information, select Override connection and specify the
details. Alternatively, you can change the default connection information in the "SAP
Connections Pane (Options Dialog Box > API Testing Tab)" described on page 275.

3. To select a different RFC or IDoc, search for it and select it in the bottom pane. For details, see
the "Import from SAP/Update Dialog Box" on page 502.

4. Click Update. Accept any warning or informational pop-ups.
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Run the Update Step wizard
If a test step contains conflicts because an RFC or IDoc name or property changed, then the
canvas marks the step with a warningmarker.

1. Click the warningmarker to display themessage The step must be resolved. Resolve step.
Click on themessage text. TheUpdate Step Wizard window opens.

Note that the step's properties become read-only, until you resolve them with the help of the
wizard.

2. In the wizard's Select Activity page, click in theNew item area and select the operation that
corresponds to the one in theOriginal item pane. Click Next. Properties for which conflicts
were detected are highlighted in red.

3. If there are conflicted input properties, theUpdate Input Properties page opens. In the
Original Properties pane, select a property for which there is a conflict, highlighted in red. In
the right pane, New Properties, select a property to map. Click Map. The wizard adds the
mapping to the list in the bottom pane. Repeat this for all properties that you want to map. Click
Next.

4. If there are conflicted output properties, theUpdate Output Properties page opens. Select a
property for which there is a conflict, highlighted in red. In theNew Properties pane select the
property to which you want to map. Click Map. The wizard adds themapping to the list of
mappings in the bottom pane. Repeat this for all properties that you want to map. Click Next.

5. Click Finish to save your changes and close the wizard.

For details about the wizard, see the "Update Step/Activity Wizard" on page 530.
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Reference

Update Port Security Wizard
This wizard enables you to update ports that became invalid as a result of an update action. The
steps became invalid because the port path (<service name:port name> combination)
changed. The wizard enables you tomap old port names to new ones.

To
access

1. Create or open a test or component.

2. Import aWSDL using the Import WSDL toolbar button.

3. In the Toolbox pane, click on one of the service's ports and select Security
Settings from the right-click menu.

4. In the Security Settings for Port dialog box, configure the port's security.

5. Select the service's parent node in the Toolbox pane and select Update (or
Update from) from the right-click menu.

Note: This wizard only opens if there is a discrepancy between the service or
port names, and if the port's security settings were configured.

Relevant
tasks

"How to Update aWeb Service" on page 523

Wizard
map

This wizard contains:

"Map Services and Ports Page" > "Finish Page"

See also "UpdatingWeb Services" on page 521

Map Services and Ports Page

This wizard page enables you tomap a port or service from the new WSDL, with the original
WSDL's service name and port. This page is repeated for each of the services for which there is a
conflict.

Important
information

General information about this wizard is available here: "Update
Step/Activity Wizard" on page 530.

Wizard map This wizard contains:

Map Services and Ports Page > "Finish Page"

User interface elements are described below (unlabeled elements are shown in angle brackets):
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UI
Elements

Description

Shows the service/port in theAvailable Services and Ports pane, that is mapped
to the service/port selected in theOriginal Service and Ports pane.

Shows the service/port in theOriginal Service and Ports pane, that is mapped to
the service/port selected in theAvailable Services and Ports pane.

Maps the selected service/port in theOriginal Service and Ports pane, to a
service/port in theAvailable Services and Ports pane. After youmap a
service/port, the grid displays it in green.

Note: This button is enabled only if you select a red or black service/port in
theOriginal Service and Ports pane, and a service/port in theAvailable
Services and Ports pane.

Removes themapping of the selected service/port in theOriginal Service and
Ports pane, from a service/port in theAvailable Services and Ports pane.

Note: This button is only enabled if you select themapped service/port in both
panes. To find themapped service/port, use theShow Match buttons.

<mapped
property
list>

A list of all themapped services and ports—the ones mapped automatically by
Service Test and the ones mappedmanually.

Tip: Click on a set of services and ports to highlight them in the upper panes.

Available
Services
and Ports

A tree hierarchy of all of the available services and ports. The services and ports
displayed in green text did not change in the update.

Original
Service
and Ports

A tree hierarchy of the first service or port for which a conflict was found. As you
click Next, the wizard proceeds to the next conflict. The wizard displays the
services and ports in the following colors:

Green. A service or port that did not change in the update or that was resolved
throughmapping.

Red. A services or port that changed during the update and requires mapping.

Black. A service or port that was resolved automatically during the update, but you
chose to unmap it.

Finish Page

This wizard page indicates whether you successfully resolved the conflicts between your original
services and ports and those from the updated service.
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Important
information

General information about this wizard is available here: "Update Port
Security Wizard" on page 528.

Wizard map This wizard contains:

"Map Services and Ports Page" > Finish Page

User interface elements are described below:

UI Elements Description

Ignores
unresolved
services/ports

Ignores unresolved conflicts. If you intend to remove the unresolved
services, you can enable this option.

Tip: To return to the wizard screens to resolve all of the services or
ports, click Back.

Finish Closes the wizard and applies your changes to the test.

Note: Enabled when you successfully map all unresolved services
and ports, or when you choose to ignore unresolved conflicts.

Update Step/Activity Wizard
This wizard enables you to update test steps that became invalid as a result of anUpdate from
action. The steps became invalid because the step/activity was removed or changed, or property
names weremodified. The wizard enables you tomap old operations/activities and properties to
new ones.

To
access

1. Create or open a test or component.

2. Use the Toolsmenu to import aWeb service or an SAP RFC or IDoc.

3. Drag an operation/activity from the Toolbox pane onto the canvas and set input
values.

4. Select the parent node and select Update orUpdate from in the shortcut
menu. Accept any warning popupmessages.

5. Click on the alert adjacent to the step .

6. Click on the text The step must be resolved. Resolve step.

Note: The wizard will open only when there is a change in property names that
were assigned values.

Relevant
tasks

"How to Update aWeb Service" on page 523
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Wizard
map

This wizard contains:

"Select Operation/Activity Page" > "Update Input Properties Page" > "Update
Output Properties Page" > "Finish Page"

See also "UpdatingWeb Services" on page 521

Select Operation/Activity Page

This wizard page enables you tomap an operation/activity from the new service/RFC or IDoc, with
the original one. TheNext button proceeds to the next conflict.

Important
information

l General information about this wizard is available here: "Update Step/Activity
Wizard" on previous page.

l The wizardmay indicate that it could not find any compatible operations in the
updated contract. This may be a result of different SOAP versions.

Wizard
map

This wizard contains:

Select Operation/Activity Page > "Update Input Properties Page" > "Update
Output Properties Page" > "Finish Page"

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

<search box> For Web services:Enables you to filter the operations list. For example to
display only those operations containing the term Get, type Get into the text
field.

New
operation/item
pane

For Web services:A tree hierarchy of the new service, its ports, and its
operations.

For SAP IDocs and RFCs:An expansion of the new item in the toolbox
showing the SAP Connection name, item type (RFC or IDoc), and item name.

Original
operation/item

For Web services:A tree hierarchy of the operation in the selected test step.

For SAP RFCs and IDocs: The original RFC or IDoc.

Apply to all
steps of this
type

Converts all test steps using the original operation/item, to steps using the new
operation/item name. If you do not select this option, you will need to resolve
the same conflict in other test steps, one-by-one.

Note: This option is only enabled when you havemultiple steps in the
canvas that use the original operation/activity.

Update Input Properties Page

This wizard page enables you tomap new input properties with the original input properties.
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Important
information

General information about this wizard is available here: "Update Step/Activity
Wizard" on page 530.

Wizard map This wizard contains:

"Select Operation/Activity Page" > Update Input Properties Page > "Update
Output Properties Page" > "Finish Page"

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

Shows the property in theNew Properties pane, that is mapped to the property
selected in theOriginal Properties pane.

Shows the property in theOriginal Properties pane, that is mapped to the
property selected in theNew Properties pane.

Maps the selected property in theOriginal Properties pane, to a property in
theNew Properties pane. After youmap a property, the grid displays it in
green.

Tip: This button is enabled only if you select a red or black property in the
Original Properties pane, and a property in theNew Properties pane.

Note:Whenmapping to an operation from anotherWSDL, the new WSDL
must have the same SOAP version as the original.

Removes themapping of the selected property in theOriginal Properties
pane, from a property in theNew Properties pane.

Note: This button is enabled only if you select themapped properties in
both panes. To find themapped properties, use theShow Match buttons.

Original
Properties

A tree hierarchy of all of the original step's input properties. The text color
indicates the status:

Green. Properties that did not change in the update or that were already
mapped.

Red. Properties that changed during the update and require mapping.

Black. Properties that were resolved automatically during the update, but you
chose to unmap them.

New
Properties

A tree hierarchy of all of the new operation's input properties. The properties
displayed in green text, are properties that did not change in the update.
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UI Elements Description

Show only
unmapped
properties

Hides all non-red properties. The red properties are the ones that Service Test
was unable to resolve automatically during the update, and that you did not
previously resolve.

<mapped
property list>

A list of all themapped properties—the ones mapped automatically by Service
Test and the ones mappedmanually.

Tip: Click on a set of properties to highlight them in the upper panes.

Update Output Properties Page

This wizard page enables you tomap new output properties with the original output properties. If the
step has no output properties, the wizard skips this step.

Important
information

General information about this wizard is available here: "Update Step/Activity
Wizard" on page 530.

Wizard map This wizard contains:

"Select Operation/Activity Page" > "Update Input Properties Page" > Update
Output Properties Page > "Finish Page"

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

Shows the property in theNew Properties pane, that is mapped to the
property selected in theOriginal Properties pane.

Shows the property in theOriginal Properties pane, that is mapped to the
property selected in theNew Properties pane.

<mapped
property list>

A list of all themapped properties—the ones mapped automatically by
Service Test and the ones mappedmanually.

Tip: Click on a set of properties to highlight them in the upper panes.

Map Maps the selected property in theOriginal Properties pane, to a property in
theNew Properties pane. After youmap a property, the grid displays it in
green.

Note: This button is enabled only if you select a red or black property in
theOriginal Properties pane, and a property in theNew Properties
pane.
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UI Elements Description

New Properties A tree hierarchy of all of the new operation's output properties. The properties
displayed in green text, are properties that did not change in the update.

Original
Properties

A tree hierarchy of all of the original step's output properties. The text color
indicates the status:

l Green. Properties that did not change in the update or that were already
mapped.

l Red. Properties that changed during the update and require mapping.

l Black. Properties that were resolved automatically during the update, but
you chose to unmap them.

Show only
unmapped
properties

Hides all non-red properties. The red properties are the ones that Service Test
was unable to resolve automatically during the update.

Unmap Removes themapping of the selected property in theOriginal Properties
pane, from a property in theNew Properties pane.

Note: This button is enabled only if you select themapped properties in
both panes. To find themapped properties, use theShow Match
buttons.

Finish Page

This wizard page indicates whether you successfully resolved the conflicts between your original
properties and the new ones.

Important
information

General information about this wizard is available here: "Update Step/Activity
Wizard" on page 530.

Wizard map This wizard contains:

"Select Operation/Activity Page" > "Update Input Properties Page" > "Update
Output Properties Page" > Finish Page

User interface elements are described below:

UI Elements Description

Ignore
unresolved
properties

Ignores all unresolved input and output properties. If you intend to remove the
step with the unresolved properties from your step, you can enable this option.

Tip: To return to the wizard screens to resolve all of the properties, click
Back.
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UI Elements Description

Finish Closes the wizard and applies your changes to the test.

Note: Enabled when you successfully map all unresolved properties, or
when you choose to ignore unresolved properties.

Resolve REST Method Steps Wizard
This wizard enables you to resolve differences between REST service steps and the prototype
method upon which they were based. The wizard detects changes such as added, removed, or
renamed properties and helps you resolve them. For details about the conflict types, see "REST
Service Conflicts" on page 522.

To
access

Create or open a test or component.

As a prerequisite:

1. Create a prototype for a REST servicemethod. For details, see "How to Create
a RESTMethod" on page 475.

2. Drag one or more REST servicemethods from the Toolbox pane to the canvas.

3. Select a RESTmethod in the Toolbox pane and chooseEdit Service from the
right-click menu. In the Edit REST Service dialog box, modify themethod's
properties and/or values.

To start the wizard:

l For the selected step only:Click on the alert in the bottom right corner of the
RESTmethod step and click the text The step should be resolved. Resolve
step.

l For all steps using the prototype method: In the Toolbox pane, right-click the
method and select Apply Changes to all Steps.

Relevant
tasks

"How to Resolve Conflicts in a REST Steps" on page 525

Wizard
map

This wizard contains:

"Select Steps Page" > "Resolve Conflicts Page" > "Finish Page"

The wizard's global interface elements are described below:

UI
Elements

Description

Cancel Closes the wizard, discarding all resolutions that youmade until this point.
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UI
Elements

Description

Finish Does the following:    

l Performs the automatic resolutions for remaining test steps whose conflicts were
not resolvedmanually.

l Ignores all remaining conflicting properties, by applying theKeep action to all of
them.

l Advances to the wizard's Finish page.

Next Proceeds to the conflicts of the next step. The wizard displays a separateResolve
Conflicts page for each step.

Select Steps Page

When you start the wizard from the Toolbox pane, it enables you to resolve conflicts for all steps
that use the selectedmethod. This wizard page enables you to include or exclude specific steps in
which to apply the resolutions.

Important
information

l General information about this wizard is available here: "Resolve REST
Method Steps Wizard" on previous page.

l The ability to select the steps to resolve, is only available when you open the
wizard from the Toolbox pane—not from the alert on the canvas.

l The wizard only checks those REST steps that are based on the prototype
selected in the Toolbox pane.

Wizard
map

This wizard contains:

Select Steps Page > "Resolve Conflicts Page" > "Finish Page"

User interface elements are described below (unlabeled UI elements are shown in angle brackets):

UI
Elements

Description

<test
tree>

A tree hierarchy of the test steps.

The following steps of the wizard will only affect the selected steps.

Check
All

Selects all test steps in which a conflict was detected.

Uncheck
All

Clears the check box for all test steps in which a conflict was detected, excluding
them from the wizard.
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Resolve Conflicts Page

This wizard page enables you tomap new input/output properties with the original input/output
properties.

Important
information

l General information about this wizard is available here: "Resolve REST
Method Steps Wizard" on page 535.

l The wizard repeats this page for each of themethods selected in the
previous step.

Wizard map This wizard contains:

"Select Steps Page" > Resolve Conflicts Page > "Finish Page"

User interface elements are described below (unlabeled elements are shown in angle brackets).
TheKeep, Remove, andMap buttons relate to both the Input andOutput properties.

UI Elements Description

<conflict
resolutions>

A list of all the resolved conflicts—the type of conflict, and the resolution.

The text color indicates the conflict status:

l Green. Conflicts that were resolved automatically or resolved by aKeep,
Map, orRemove action.

l Red. Conflicts that were not yet resolved or removed.

Input
Properties /
Output
Properties

A list of all of the step's input/output properties.

l Before changes. A list of the step's original properties

l After changes. A list of the step's properties after the conflicts were
resolved.

The text color indicates the property status:

l Green. Properties that were resolved automatically or resolved by aKeep,
Map, orRemove action.

l Red. Properties for which a conflict was found, and not yet resolved.

l Black. Properties for which no conflict was found.

Keep Accepts the conflict for use within the test. The resulting test step's
properties do not correspond to the prototype.
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UI Elements Description

Map Assigns the value of the selected property in theBefore changes pane, to
the property in theAfter changes pane After youmap a property, the grid
displays it in green.

Note: This button is enabled only if you select a red or green property in
theBefore changes pane, and a black or green property in theAfter
changes pane.

Remove Removes the selected conflicting property from the current test step.

Finish Page

This wizard page indicates whether you successfully resolved the conflicts between the prototype
and the test steps.

Important
information

General information about this wizard is available here: "Resolve REST
Method Steps Wizard" on page 535.

Wizard map This wizard contains:

"Select Steps Page" > "Resolve Conflicts Page" > Finish Page

User interface elements are described below:

UI
Elements

Description

Finish Closes the wizard and applies the resolutions to the test step.

Note: If you click the Finish button before resolving the conflicts, the wizard
applies aKeep action to all conflicts, and performs an automatic resolution for
non-property related conflicts.
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Troubleshooting and Limitations - Updating
This section describes troubleshooting and limitations for updating services and assemblies.

REST Services
l When comparing a REST step to its prototype - a difference in the request/response body

contents is not considered a conflict. Therefore, when resolving a REST step whose contents
do not match the body contents of the prototype, the body contents will not be affected.
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Chapter 27: Web Service Security
This chapter includes:
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Concepts

Setting Security Overview
When buildingWeb Service applications, there is a challenge in building scalable applications that
are secure. You can secureWeb Services by having themessage sent over a secure transport,
such as Secure Sockets Layer (SSL), or by applying security at themessage level, also known as
WS-Security.

For testing a secured service, answering the following questions will help you define your security
scenario.
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l Is there transport security, such as SSL?What is the HTTPS URL?

l Is basic authentication required?

l Is mutual authentication required?

l What type of security is required in the SOAP header?

Security Levels
Service Test lets you set the security for a service on two levels—port or operation. If you define a
security for a port, all of its operations use these settings, by default. When working in the canvas,
you can override the default port security and customize the security for a particular operation.

For task details, see "How to Set Security for a Specific Step" on page 547.

Security Scenarios Overview
Service Test provides several built-in scenarios for configuring security inWeb Service calls.

A security scenario represents a typical security implementation for aWeb Service. It contains
information such as authentication, encoding, proxy, certificates, and so forth.

A defaultWeb Service scenario can be used for most Web services. It enables you to configure
both transport andmessage-level security. Service Test support for message-level security lets
youmanually configure the security elements such as tokens, message signatures, and
encryption. For details, see "Web Service Scenario Overview" on next page.

WCF scenarios enables you to configure security for HTTP or custom bindings and work with
advanced specifications, such asWS-SecureConversation.

For details on the built-in security scenarios see one of following sections:

l "Web Service Scenario Overview" on next page

l "WCF Service (CustomBinding) Scenario Overview" on page 544

l "WCF Service (Federation) Scenario Overview " on page 544

l "WCF Services (WSHttpBinding) Scenario Overview " on page 545

Use the default Web Service scenario for:
l SimpleWeb Services where no advanced standards are required.

l Web services using HTTP transport level security.

l Web services usingmessage level security (WS-Security) for SOAP 1.1

Use a WCF scenario for:
l WCF Services that utilize advanced security andWS-Specifications.

l Web services usingmessage level security (WS-Security) for SOAP 1.2

Such services can be written in various platforms such as WCF (Windows Communication
Foundation), Metro (WSIT), and Axis2. Service Test also supports proprietary standards and
transports.

This section also includes:
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WebService Scenario Overview 542

Web Service Scenario Overview

The default Web Service scenario is based on theWS-Security specification. This scenario lets
you place security credentials in the actual SOAP message.

When a SOAP message sender sends a request, the security credentials, known as tokens, are
placed in the SOAP message. When theWeb server receives the SOAP request, it does not need
to send additional requests to verify the integrity of the sender. The server verifies that the
credentials are authentic before letting theWeb Service execute the application. By not having to
go back to the source of the credentials, the application's scalability improves significantly.

To further secureWeb Services, it is common to use digital signatures or encryption for the SOAP
messages. Digitally signing a SOAP message verifies that themessage has not been altered
during transmission. Encrypting a SOAP message helps secure aWeb Service by making it
difficult for anyone other than the intended recipient to read the contents of themessage.

The Security Settings dialog box provides the following tabs for theWeb Service scenario: HTTP,
WS-Security, andWS-Addressing. TheHTTP tab lets you configure the transport security, the
WS-Security tab handles themessage-level security, and theWS-Addressing tab sets the
addressing version.

For user interface details, see "Result Tab (Properties Pane)" on page 207.

Transport Level Security
The transport level security includes the authentication and proxy server information. You can also
specify Keep Alive preferences and connection timeout. For user interface details, see "Result Tab
(Properties Pane)" on page 207.

Message Level Security
TheWS-Security tab lets you set themessage level security through tokens, signatures and
encryption.

To support WS-Security, Service Test enables you to create security tokens for your script. You
can createmultiple tokens and set their properties. After creating a token, you use it to sign or
encrypt a SOAP message.

TheWeb Services security mechanism associates security tokens with messages. This
mechanism supports several security token formats to accommodate a variety of authentication
requirements. For example, a client might need to provide a proof of identity or a security certificate.

The available tokens are: UserName, X509 Certificate, Kerberos, Kerberos2, andSAML.

l UserName. TheUser Name token contains user identification information for the purpose of
authentication: User Name and Password. You can also specify Password Options, indicating
how to send the password to the server for authentication: Text, None, orHash. and indicate
whether to include a timestamp.

l X509 Certificate. This token is based on an X.509 certificate. To obtain a certificate, you can
either purchase it from a certificate authority, such as VeriSign, Inc. or set up your own
certificate service to issue a certificate. Most Windows servers support the public key
infrastructure (PKI), which enables you to create certificates. You can then have it signed by a
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certificate authority or use an unsigned certificate.

l Kerberos /Kerberos2. (ForWindows 2003 or XP SP1 and later) The Kerberos protocol is used
tomutually authenticate users and services on an open and unsecured network. Using shared
secret keys, it encrypts and signs user credentials. A third party, known as a KDC (Kerberos
Key Distribution Center), authenticates the credentials. After authentication, the user may
request a service ticket to access one or more services on the network. The ticket includes the
encrypted, authenticated identity of the user. The tickets are obtained using the current user's
credentials.

The primary difference between the Kerberos and Kerberos2 tokens, is that Kerberos2 uses the
Security Support Provider Interface (SSPI), so it does not require elevated privileges to
impersonate the client's identity. In addition, the Kerberos2 security token can be used to secure
SOAP messages sent to aWeb Service running in aWeb farm.

l SAML Token. SAML is an XML standard for exchanging security-related information, called
assertions, between business partners over the Internet. The assertions can include attribute
statements, authentication, decision statements, and authorization decision statements.

SAML uses brokered authentication with a security token issued by STS (Security Token
Service). The STS is trusted by the client and theWeb Service to provide interoperable security
tokens. SAML tokens are important forWeb Service security because they provide cross-
platform interoperability and ameans of exchanging information between clients and services
that do not reside within a single security domain.

Message Signatures and Encrypted Data
When you add a security token to a SOAP message, it is added to the SOAP message in the form
of an XML element in theWS-Security SOAP header.

Themessage, however, is exposed and therefore requires additional security. This is especially
true when the credentials, including the password, are sent in plain text as it is with role-based
security.

The twomethods used to secure the data aremessage signatures andmessage encryption:

l Message Signatures.Message Signatures are used by the recipients to verify that messages
were not altered since their signing. The signature is in the form of XMLwithin the SOAP
message. The recipient checks the signature tomake sure it is valid.

l Message Encryption. Although the XMLmessage signature offers amechanism for verifying
that themessage has not been altered since it was signed, it does not encrypt the SOAP
message—themessage is still plain text in XML format. To secure themessage in order that it
should not be exposed, you encrypt it, making it difficult for an intruder to view and obtain a
user's password.

For task details, see "How to Set Security for a Specific Step" on page 547.

WCF Scenario Settings
This section describes theWCF security scenarios. It includes:

WCF Service (CustomBinding) Scenario Overview 544

WCF Service (Federation) Scenario Overview 544

WCF Services (WSHttpBinding) Scenario Overview 545
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WCF Service (CustomBinding) Scenario Overview

TheWCF Service (CustomBinding) scenario enables the highest degree of customization. Since
it is based upon the WCF CustomBinding standard, it enables you to test most WCF services,
along with services on other platforms such as Java-based services that use the WS - <spec_

name> specifications.

Use theWCF Service (CustomBinding) scenario to configure a scenario that does not comply with
any of the predefined security scenarios. You can customize the transport and encoding settings:

l Transport. HTTP, HTTPS, TCP, or NamedPipe

l Encoding. Text, MTOM, or WCF Binary

You can also provide additional security information:

l Authentication mode. The type of authentication, such as None,
AnonymousForCertificate, and so forth. The options are available from the drop down list.

l Bootstrap policy. For the SecureConversation authenticationmode, you can specify a
bootstrap policy.

l Net Security. The network security for TCP and NamedPipe type transports. Typical values are
None,Windows stream security, orSSL stream security available from the field's drop down
list. For services with HTTP transport, you should set the value toNone. To enable SSL for
HTTP, select HTTPS transport.

For task details, see "How to Set Security for aWCF Service" on page 550.

For user interface details, see "WCF Service (Federation) Scenario (Security Settings for Port
<Port_Name> Dialog Box)" on page 568.

Note: ForWSE3 security configurations, use theWCF Service(CustomBinding) Scenario. For
details, see "How do I test aWCF service?" on page 554.

WCF Service (Federation) Scenario Overview

In theWCF Service (Federation) scenario, the client authenticates against the STS (Security
Token Service) to obtain a token. The client uses the token to authenticate against the application
server.

Therefore, two bindings are needed, one against the STS and another against the application
server.

You define the bindings in two stages:

l Provide security details for the application server's security scenario in the following areas:

n Server. The transport and encodingmethods.

n Security. The authenticationmode, such as IssuedToken, SecureConversation, and so
forth.
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n Identity. Information about the server certificate and expected DNS.

n STS. Settings related to the STS, such as the endpoint address and binding.

l Define an STS binding in theReferenced binding field.

For task details, see "How to Set Security for aWCF Service" on page 550.

For user interface details, see "WCF Service (Federation) Scenario (Security Settings for Port
<Port_Name> Dialog Box)" on page 568.

WCF Services (WSHttpBinding) Scenario Overview

Note: TheWCFService (WSHttpBinding) scenario only supports the testing of WCF
services which utilizewsHttpBinding and incorporate some level of security. To test WCF
services that usewsHttpBinding but have no security, use theWCFService
(CustomBinding) scenario.

In theWCFService (WSHttpBinding) scenario, you can select from several types of
authentication: None, Windows, Certificate, or Username (message protection).

No Authentication (Anonymous)
In this scenario, the client uses the server's certificate to encrypt amessage; there is no client
authentication. Use this scenario to test Web Services where the:

l Client uses the server's X.509 certificate for encryption.

l Client is not authenticated.

l Communicationmay utilize advanced standards such as secure conversation or MTOM.

Windows Authentication
This scenario uses Windows Authentication. If you are testing aWCF service that has not been
customized and uses the default configuration, use this type of scenario.

Use this scenario to test Web Services where the:

l Client and server useWindows authentication.

l Security is based on Kerberos or SPNEGO negotiations.

l Communicationmay utilize advanced standards such as secure conversation or MTOM.

Certificate Authentication
In thisWCF WSHttpBinding scenario, the client uses the server's X.509 certificate to encrypt the
message and its own certificate for a signature.

Use this scenario to test Web Services where the:

l Client uses the server's X.509 certificate for encryption.

l Client uses its own X.509 certificate for signatures.

l Communicationmay utilize advanced standards such as secure conversation or MTOM.
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Username Authentication (Message Protection)
In theWCF WSHttpBinding scenario, the client uses the server's X.509 certificate to encrypt the
message, and sends a user name and password to authenticate itself.

Use this scenario to test Web Services where the:

l Client uses the server's X.509 certificate for encryption.

l Client is authenticated with a username and password.

l Communicationmay utilize advanced standards such as secure conversation or MTOM.

For all of the authentication types, you can apply advanced settings as described in "Advanced
Security Settings" below.

For user interface details, see "WCF Service (WSHttpBinding) Scenario (Security Settings for Port
<Port_Name>) Dialog Box)" on page 570.

Advanced Security Settings
This scenario's settings let you customize aWCFService (CustomBinding) scenario in the areas
of Encoding, Advanced Standards, Security, orHTTP and Proxy.

Not all settings are relevant for all scenarios, so some of themmight be disabled or hidden
depending on the scenario.

For details, see the "Advanced Settings Dialog Box" on page 573.
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Tasks

How to Set Security for a Web Service on the Port Level
This task describes how to configure security settings for aWeb service on the port level. You can
override this by modifying the settings for a specific test step. For details, see "How to Set Security
for a Specific Step" below.

This task includes the following steps:

l "Prerequisites" below

l "Open the Security Setting dialog box" below

l "Load existing settings - optional" below

l "Create a new security scenario" below

l "Save the settings - optional " below

1. Prerequisites
Import at least oneWeb service.

2. Open the Security Setting dialog box
Select aWeb service's port node in the Toolbox pane and select Security Settings from the
context menu.

3. Load existing settings - optional
To load an existing set of Service Test security settings, click Import and locate the .stss
(Service Test Security Scenario) file.

4. Create a new security scenario
Use the Security Settings dialog box to create a new security scenario or modify a loaded one:

a. In the Service Details box, select a scenario type: Web Service, WCF Service, and so
forth.

b. Configure the security settings for the selected scenario. For details, see the "Security
Settings for Port <Port_Name> Dialog Box" on page 559.

c. ForWeb Service type scenarios, add tokens, signatures, and encryption. For details, see
"Web Service Scenario (Security Settings for Port <Port_Name> Dialog Box)" on page
560.

5. Save the settings - optional
Click Save to save the settings to an .stss file.

How to Set Security for a Specific Step
This task describes how to set security properties for an individual test step.

This task includes the following steps:
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l "Add a step to which security can be applied" below

l "Open the Security Setting view" below

l "Enable the Service Settings details" below

l "Specify a scenario type" below

l "Configure the security settings" below

1. Add a step to which security can be applied
Drag aWeb Service operation or SOAP Request activity onto the canvas.

2. Open the Security Setting view

Open the Security Settings tab in the Properties pane.

3. Enable the Service Settings details
Clear theUse the port's security settings option.

4. Specify a scenario type
Select a scenario from theService Details list: Web Service, and so forth. For user
interface information, see the "Security Settings for Port <Port_Name> Dialog Box" on page
559.

5. Configure the security settings
Configure the security settings for the selected scenario. For task details, see one of the
following sections:

n "How to Set Security for a StandardWeb Service" below

n "How to Set Security for aWCF Service" on page 550

To see the request and response before and afterWSE2 (non-WCF) security is applied, view
theOutput pane after the test run.

How to Set Security for a Standard Web Service
This task describes how to configure security settings for a standardWeb Service. This mode lets
you define the HTTP transport information and security elements such as tokens. For UI details,
see "Web Service Scenario (Security Settings for Port <Port_Name> Dialog Box)" on page 560.

This task includes the following steps:

l "Open the Security Settings dialog box or tab" on next page

l "Create aWeb Service scenario" on next page

l "Configure the HTTP settings" on next page

l "Define security elements (optional)" on next page

l "Configure theWS-Addressing (optional)" on next page
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1. Open the Security Settings dialog box or tab
To set security on a port level, select aWeb Service port in the Toolbox and chooseSecurity
Settings from the context menu.

To set security for a specific Web Service step already on the canvas, select the step and
open theSecurity Settings tab in the Properties pane. Clear the use the port's security
settings option.

For a SOAP Request step, click theSecurity Settings tab in the Properties pane.

For details, see the "Security Settings for Port <Port_Name> Dialog Box" on page 559.

2. Create a Web Service scenario
SelectWeb Service in theService Details list (default).

3. Configure the HTTP settings
In the Properties pane, select the HTTP tab, and set the transport and proxy information. For
details, see the "HTTP tab" on page 561.

4. Define security elements (optional)
Click theWS-Security tab. Add tokens, message signatures, and encryption.

n To add a token, click and select a token type. Provide the token details in the lower
pane. The fields differ based on the token type. For details, see "Message Level Security"
on page 542.

Note:When adding a SAML token, if you have the complete SAML token string, you
can paste it directly into theAssertionIDReference field. If you do not have the
complete token string and you want to configure the tokenmanually, make sure that the
first row in the schema contains theAssertion property—not the
AssertionIDReference. You can change this using the grid's drop downmenu.

n To add amessage signature, (youmust first add at least one token), click and select a
token in theSigning token box, usually an X.509 token. Provide the other required
information. For details, see the "WS-Security tab" on page 562.

n To add amessage encryption (youmust first add at least one token), click and select
the token that will do the encryption from theEncryption token box. Provide any other
required information or accept the defaults.

n Organize the security elements in their order of priority. Use theUp andDown arrows
to set the priorities. The basic order is tokens, followed by message signatures, and then
encryption. In addition, your servicemay also require a specific order for the tokens.

n Indicate whether or not to include a timestampwhen sending the token, signature, or
encryption to the server. To exclude it select Exclude Timestamp.

5. Configure the WS-Addressing (optional)
Click theWS-Addressing tab. Select the relevant version or None if WS-Addressing is not
used. Provide an alternate destination in theReply to box.
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For details about the security elements. see the "Web Service Scenario Overview" on page
542.

For user interface details see the "Security Settings for Port <Port_Name> Dialog Box" on
page 559.

How to Set Security for a WCF Service
This task describes how to configure security settings for aWeb Service usingWCF. For
guidelines about selecting aWCF service scenario, see "WCF Scenario Settings" on page 543.

This task includes the following steps:

l "Create aWCF scenario" below

l "Configure the security settings" below

l "Configure advanced settings - optional" below

l "Save the scenario - optional" below

1. Create a WCF scenario
n For port level security, click on the service's port in the Toolbox pane and select Security

Settings from the context menu.

n For step level security, open theSecurity Settings tab in the Properties pane. Clear the
Use the port's security settings option.

Select the desiredWCF Service in theService Details list.

2. Configure the security settings
Configure the settings as described in the "Security Settings for Port <Port_Name> Dialog
Box" on page 559.

3. Configure advanced settings - optional
Click theAdvanced button to configure advanced security settings. For details, see the
"Advanced Settings Dialog Box" on page 573.

4. Save the scenario - optional
Your security scenario is automatically saved with the test. If, however, you also want to use
the settings for another test, without having to redefine the scenario, you can save it to an
.stss file.

To save the scenario, click theSave button. Specify a location for the scenario file. To use the
file in another test, click Import.

How to Set up Common Web Services Security Scenarios
This section illustrates several common security scenarios. The examples apply when using the
default Web Service security scenario. ForWCF- based services, theWCFService (Custom
Binding) scenario is recommended. For additional examples, see "How to Customize Security for
WCF TypeWeb Services" on page 553.

You can set security for all operations in aWeb service port or for a specific step in your test.
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To set security for a port, see "How to Set Security for a Specific Step" on page 547.

This section includes the following:

l "Authenticating with a Username Token" below

l "Signing with an X.509 Certificate" below

l "Encrypting with a Certificate" on next page

l "Authenticating with a Username Token and Encrypting with an X.509 Certificate" on next page

l "Encrypting and Signing aMessage" on page 553

Authenticating with a Username Token
To send amessage level username/password token (a UserName token):

1. Select theWeb Service scenario from theService Details list, and click theWS-Security
tab.

2. Click theAdd Token button and add aUsername token.

3. Customize the token details, such as username and password.

Signing with an X.509 Certificate
To send amessage using a X.509 certificate for a digital signature.

1. Select theWeb Service scenario from theService Details list, and click theWS-Security
tab.

2. Select X509 Certificate token from the Security Token drop down list.

3. Fill in the token details to reference your private certificate. Make sure to enter a value in the
Token name field.

4. Browse for the certificate file. The certificate needs to be installed in theWindows certificate
store.

5. Select aReference type. Since this token is used for a signature, themost common type is
BinarySecurityToken.

6. Click theAdd Message Signature button . In theSigning Token drop down, select the
token you created in the previous steps.

7. To sign a specific element with the certificate, scroll down to theXPath field and provide an
XPath expression.

You cannot use an XPath expression to sign a timestamp or token that is under the security
element of a SOAP request.

n To sign aSOAP Body, Timestamp, orWS-Addressing, select the check box in the
Predefined parts area.

n To sign tokens within the security element, select a token in the Token (optional) field, in
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theWhat to sign area.

Note: The certificate needs to be installed in theWindows certificate store. In the example
above, you need to set the actual store name, store location, and subject name of your
certificate.

Encrypting with a Certificate
To encrypt amessage using the service's X.509 certificate:

1. Select theWeb Service scenario from theService Details list, and click theWS-Security
tab.

2. Select X509 Certificate token from theSecurity Token drop down list.

3. Fill in the token details to reference the server's public certificate. Make sure to enter a value in
the Token name field.

4. Since this token is used for encryption, use Reference as theReference type.

5. Click theAdd Message Encryption button . In the drop down list, select the token you
created in the previous steps.

6. Scroll down to theXPath field. Enter an XPath expression, for example:
// *[local-name(.)='Body'].

Authenticating with a Username Token and Encrypting with an X.509
Certificate
The following section describes how to send aUsername token to the service and encrypt it with
the server's X.509 certificate:
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1. Select theWeb Service scenario from theService Details list, and click theWS-Security
tab.

2. Select Username Token from theSecurity Token drop down list. Provide the token
details.

3. Select X509 Certificate Token from theSecurity Token drop down list.

4. Fill the token details to reference the server's public certificate. Make sure to enter a value in
the Token name field. Since this token is used for encryption, use Reference as the
Reference type.

5. Click theAdd Message Encryption button . In the drop down list, select the X.509 token
you created in Step 3.

6. To encrypt a specific message, scroll down to theXPath field. Enter an XPath expression, for
example:, // *[local-name(.)='Body'].

Encrypting and Signing a Message
This example shows how to sign amessage using a private key and then encrypt it using the
service's public key.

1. Select theWeb Service scenario from theService Details list, and click theWS-Security
tab.

2. Select X509 Certificate Token from theSecurity Token drop down list. Fill the token
details to reference your private certificate. Make sure to enter a value in the Token name
field. Select BinarySecurityToken as aReference type, since this token is used for a
signature.

3. Select X509 Certificate Token from theSecurity Token drop down list to add another
X.509 token. Fill the token details to reference your private certificate. Make sure to enter a
value in the Token name field. Select Reference as aReference type, since this token is
used for a encryption.

4. Click theAdd Message Signature button . In the drop down list, select the X.509 token
you created in Step 2.

5. Click theAdd Message Encryption button . In the drop down list, select the token you
created in Step 3.

How to Customize Security for WCF Type Web Services
This section describes how to customize the security settings forWeb services usingWCF.

This section describes:

l "How do I test aWCF service?" on next page

l "How do I test aWCF service that uses WSHttpBinding?" on next page

l "How do I test aWCF service that uses CustomBinding?" on next page

l "How do I test aWCF service that uses netTcp or namedPipe transport?" on next page
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l "How do I test a Federation scenario that uses an STS (Security Token Service)?" below

l "How do I test a scenario that uses aWSE3 security configuration with a server certificate?" on
next page

l "How do I test a scenario that uses mutual certificate authentication?" on next page

l "How do I configure aWCF binding with TCP transport to require an X.509 client certificate?" on
page 556

How do I test a WCF service?
In theService Details list, select aWCF scenario.

If the Federation orWSHttpBinding scenarios are not appropriate, select theWCFService
(Custom Binding) scenario, as it can handle all other bindings.

How do I test a WCF service that uses WSHttpBinding?
WSHttpBinding is one of themost popular bindings inWCF. In order to use this binding, select the
WCFService (WSHttpBinding) scenario from theService Details list.

Choose a client credential type from theClient authentication type list, to use in your binding—
Windows, Certificate, or Username. This value corresponds to the
MessageClientCredentialType property of theWCF's WSHttpBinding parameter.

Windows authentication is themost common value for aWCF services. If you are using theWCF
default settings for your service, use this option. Other options are username, certificate, or
none.

For some scenarios you should indicate whether to use theWCF proprietary negotiation
mechanism to get the service credentials.

Use the Advanced scenario properties to control the usage of a secure session.

For details, see "WCF Services (WSHttpBinding) Scenario Overview " on page 545.

How do I test a WCF service that uses CustomBinding?
Open theSecurity View in the Properties pane and select theWCFService (Custom Binding)
scenario.

You can then customizemany binding elements, such as your transport method, encoding,
security, and reliable messaging.

For details, see "Configure the security settings" on page 550.

How do I test a WCF service that uses netTcp or namedPipe transport?
Select theWCFService (Custom Binding) scenario from theService Details list.

Configure the transport to TCP orNamedPipe.

For details, see "Configure the security settings" on page 550.

How do I test a Federation scenario that uses an STS (Security Token
Service)?
For this scenario, youmust define the communication properties for both the STS and the service.
Use the built-in Federation scenario.
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Select theWCFService (Federation) scenario from theService Details list.

For this scenario, youmust to define the communication properties for both the STS and the
application server.

For details, see "WCF Service (Federation) Scenario (Security Settings for Port <Port_Name>
Dialog Box)" on page 568.

How do I test a scenario that uses a WSE3 security configuration with a
server certificate?
The following procedure describes how to set up a security scenario forWSE3.

1. Create a new test, import theWSDL for theW3E3 service, and drag the operation onto the
canvas.

2. Open theSecurity View in the Properties pane or from the port's shortcut menu. Select the
WCFService (Custom Binding) scenario.

3. Set the Transport toHTTP, and the Encoding to Text.

4. Provide a username and password in the Identities section.

5. Click theBrowse button adjacent to the Server Certificate field and specify theStore
Location, Store Name andSearch text (optional). Click Find, select the certificate, and click
Select.

6. Provide theExpected DNS.

7. Click theAdvanced button and configure the following settings:

a. Encoding tab—WS-Addressing: WSA 04/08 (for example).

b. Security tab:

o Enable secure session:Enabled

o Negotiate service credentials:Enabled

o Protection level: Encrypt and Sign

o Message protection order: Sign Before Encrypt

o Message security version:
WSSe-

curity11WSTrustFebruary2005WSSecureConversationFebruary2005 (first
entry)

o Require Derived keys:Enabled

For all other fields, use the default settings.

For details, see "Configure the security settings" on page 550.

How do I test a scenario that uses mutual certificate authentication?
The following procedure describes how to set up a security scenario for mutual certificates and how
to comply with aWSE3 security configuration.
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1. Select theWCFService (CustomBinding) scenario from theScenario Details list.

2. Set the Transport to HTTP, and theEncoding to Text.

3. Set the authenticationmode to MutualCertificate.

4. In the Identities section, select server and client certificates. For details, see "Select
Certificate Dialog Box" on page 579.

5. Provide theExpected DNS.

6. Click the Advanced button and configure the following settings:

a. Encoding tab—WS-Addressing: WSA 04/08 (for aWSE3 security configuration).

b. Security tab—Require Derived keys: Disabled

For all other fields, use the default settings.

For details, see "Configure the security settings" on page 550.

How do I configure a WCF binding with TCP transport to require an X.509
client certificate?
The following procedure describes how to configure aWCF custom scenario to require an X.509
client certificate in nettcp.

1. Select theWCFService (Custom Binding) scenario from theService Details list.

2. Set the Transport to TCP and the Net Security toSSL stream security.

3. Open the Properties pane's Event view .

4. Select the BeforeApplyProtocolSettings event. Click in theHandler column and
select Create a default handler from the drop-down. Service Test opens the
TestUserCode.cs tab.

5. Add the following definitions to the implementation section of the TestUserCode.cs file.

var wcf =

(HP.ST.Ext.CommunicationChannels.Models.WcfChannelBinding)args

[1];

var ssl =

(HP.ST.Ext.-

CommunicationChannels.Models.WcfSslStreamSecurityChannel)wcf.

     Protocols.Channels[1];

ssl.RequireClientCertificate = true;

For all other fields, use the default settings.

6. Save the test and run it.

How to Test Web Services that use WS-Security or SSL
This section provides a summary of using Service Test for general security testing.

This section includes:
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l "How do I test aWeb Service that uses SSL?" below

l "How do I test aWeb Service that requires Windows authentication at the HTTP level?" below

l "How do I test aWeb Service that uses WS-Security?" below

l "How do I configure the low-level details of my WS-Security tokens?" below

How do I test a Web Service that uses SSL?
Testing a secure site does not require any special configuration. If your service URL begins with
https, SSL is automatically used.

If in addition to SSL you are usingmessage-level security (for example for a username) then you
must configure the security for themessage separately.

You can use the basic Web Services security scenario and specify themessage-level security
such as tokens and signatures.

You can also use theWCFService (Custom Binding) scenario, or theWCFService
(WSHttpBinding) scenario with the transport credentials.

How do I test a Web Service that requires Windows authentication at the
HTTP level?
For details, see "How to Set Security for a StandardWeb Service" on page 548.

1. Select theWeb Service scenario from theScenario Details list.

2. In the HTTP tab, specify the credentials.

How do I test a Web Service that uses WS-Security?
Use the basicWeb Services security scenario and open theWS-Security tab. Add themessage-
level security such as tokens, signatures, and encryption.

How do I configure the low-level details of my WS-Security tokens?
In most cases, you can configure the low-level details as described in "Advanced Settings Dialog
Box" on page 573.

How to Set up Advanced Standards Testing
This section provides guidelines for using Service Test in advanced standards testing.

This section includes:

l "How do I test aWeb Service that uses MTOM?" below

l "How do I change theWS-Addressing version of a service?" on next page

l "How do I enable support for a service or activity that uses 256-bit SSL encoding?" on next page

How do I test a Web Service that uses MTOM?
1. Select theWCFService (Custom Binding) scenario from theService Details list.

2. Configure theEncoding to MTOM.
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If your service requires advanced settings, click theAdvanced button. For details, see the
"Advanced Settings Dialog Box" on page 573.

For more details about the scenario, see "Configure the security settings" on page 550.

How do I change the WS-Addressing version of a service?
1. Select theWeb Service scenario from theService Details list.

2. Click theWS-Addressing tab and select a version.

For details, see "How to Set Security for aWeb Service on the Port Level" on page 547.

If your service uses WCF, use the appropriate scenario and configure the addressing version from
the Advanced window's Encoding tab. For details, see the "Advanced Settings Dialog Box" on
page 573.

How do I enable support for a service or activity that uses 256-bit SSL
encoding?
Change the SSL cipher order inWindows Vista so that AES256 precedes AES128 in the cipher list.

Tip: Check with an IT professional before performing the following actions.

To change the cipher order:

1. Type gpedit.msc at a command prompt to open your group policy editor.

2. ChooseComputer Configuration > Administrative Templates > Network > SSL
Configuration Settings.

3. Open the only item—SSL Cipher Suite Order.

4. Select Enabled.

5. The first item in the list is TLS_RSA_WITH_AES_128_CBC_SHA

The second item is TLS_RSA_WITH_AES_256_CBC_SHA

6. Change the first 128 to 256. Thenmove the cursor forward and change the 256 to 128.

7. Move the cursor through the list and change the cipher priorities as in the above step.

8. Close the group policy editor and reboot.
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Reference

Security Settings for Port <Port_Name> Dialog Box
Using the Security Settings dialog box, you can configure security settings for all operations in a
Web service port. To set the security for a specific step within your test, use theSecurity Settings
tab in the Properties pane. For details, see "Result Tab (Properties Pane)" on page 207.
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To access 1. Create or open a test or component.

2. Import aWeb Service.

3. Select aWeb Services port node in the Toolbox pane and select
Security Settings from the context menu.

Important
information

l For details about choosing a security scenario type, see "Security
Scenarios Overview" on page 541.

l For examples, see "How to Set up CommonWeb Services Security
Scenarios" on page 550.

Relevant tasks "How to Set Security for a Specific Step" on page 547

User interface elements are described below:

UI
Elements

Description

Advanced Opens the Advanced Settings dialog box. For details, see the "Advanced Settings
Dialog Box" on page 573.

Note: Available only forWCF typeWeb services.

Import Loads security settings from a previously saved .stss file.

Save Saves the security scenario settings to an .stss (Service Test Security Scenario)
file, for use in other tests. If you are connected to ALM, it saves the file together
with the test.

Service
Details

The type of Web service. After selecting a type, Service Test provides an interface
for modifying the relevant security settings. The service types are:

l "Web Service Scenario (Security Settings for Port <Port_Name> Dialog Box)"
below

l "WCF Service (Custom Binding) Scenario (Security Settings for Port <Port_
Name> Dialog Box" on page 566

l "WCF Service (Federation) Scenario (Security Settings for Port <Port_Name>
Dialog Box)" on page 568

l "WCF Service (WSHttpBinding) Scenario (Security Settings for Port <Port_
Name>) Dialog Box)" on page 570

Web Service Scenario (Security Settings for Port <Port_Name>
Dialog Box)

The simpleWeb Service scenario provides theHTTP,WS-Security, andWS-Addressing tabs.

HP Service Test (11.52)Page 560 of 705

User Guide
Chapter 27: Web Service Security



HTTP tab

TheHTTP tab lets you provide the HTTP transport level settings such as user credentials for
sending amessage with basic authentication, proxy settings, message-level settings, encryption,
and so forth.

The user interface elements are described below.

UI Elements Description

User name, Password The credentials for HTTP authentication such as basic
authentication, digest, or NTLM.

Example

User name: myDomain\myUser ;
Password: myPassword

Client certificate The client credentials required for client certificate authentication
when using two-way SSL scenarios.

TheBrowse button opens the "Select Certificate Dialog Box" on
page 579.
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UI Elements Description

Proxy URL The URL and port of the proxy server through which themessage
must pass.

Example: http://myProxy:8888/.

To use the default, select Use default proxy.

Proxy user name,
Proxy password

The credentials for the proxy server through which themessagemust
pass.

Keep alive Keeps the connection persistent.

Connection timeout The time threshold in which to connect through the proxy server or
with authentication.

Manage cookies Enables the writing of cookie information.

WS-Security tab

TheWS-Security tab provides an interface to addmessage level security using tokens, message
signatures, and encryption.

The user interface elements are described below. (Unlabeled elements are shown in angle
brackets).
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UI Elements Description

Security Tokens. Enables you to add one of the following tokens:

l User Name,

l X509

l Kerberos,

l Kerberos2

l SAML

Add Message Signature. Adds a signature to themessage. This requires a
token.

Add Message Encryption. Adds encryption to themessage. This requires a
token.

Delete. Removes the security element from the list.

Up/Down. Positioning tools that allow you to set the priority of the security
elements.

Note: Make sure the security elements are positioned in order of their
priority.

<Encryption
details
pane>

The details of the encryption token.

l Encrypting token. The token to use for encryption, usually an X.509 type.
You can select from a list of all previously created tokens.

l Encrypting type. Indicates whether to encrypt the whole destination
Element or only its Content.

l Key algorithm. The algorithm to use for the encryption of the session key:
RSA15 or RSAOAEP.

l Session algorithm. The algorithm to use for the encryption of the SOAP
message. You can select from a list of common values.

l What to encrypt

n XPath (optional). An XPath that indicates the parts of themessage to
encrypt. If left blank, only the SOAP body is encrypted.

n Token (optional). The name of the encrypted token. A drop down box
provides a list of all added tokens. With most services, this field should be
left empty.

<security
element
list>

A list of the tokens, message signatures, and encryptions.
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UI Elements Description

<Signature
details
pane>

The details of the digital signature used to secure the token.

l Signing token. The token to use for signing, usually an X.509 type. Select
from the list of all added tokens.

l Canonicalization algorithm. A URL for the algorithm to use for
canonicalization. A drop down list provides common algorithms. If you are
unsure which value to use, keep the default.

l Transform algorithm. A URL for the Transform algorithm to apply to the
message signature. A drop down list provides common algorithms. If you are
unsure which value to use, keep the default.

l Inclusive namespaces list. A list of comma-separated prefixes to be treated
as inclusive (optional).

l What to sign. The SOAP elements to sign: SOAP Body, Timestamp, and
WS-Addressing.

l XPath (optional). An XPath that specifies which parts in themessage to
sign. If left blank, the elements selected in theSignature options field are
signed. For example, //*[local-name(.)='Body'].

l Token (optional). The target token you want to sign. Select from the drop
down list of all added tokens. With most services, this field should be left
empty.

<Token
details
pane> -
Kerberos
tokens

Token details forKerberos tokens:

l Token name. A meaningful name for the token.

l Host. The host name of the server against which you want to authenticate. In
most cases, it is the host portion of the service URL.

l Domain. TheWindows domain of the server against which you want to
authenticate.

<Token
details
pane> -
Username
tokens

Token details forUsername tokens.

l Token name. A meaningful name for the token (you can use the default
value).

l Include nonce. Includes a nonce in the token.

l User name, Password

l Password type: Text, Hash, or None.

l Timestamp format: Full, Created, or None.
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UI Elements Description

<Token
details
pane> -
X509
Certificate
tokens

Token details forX509 Certificate tokens:

l Token name. A meaningful name for the token.

l Certificate. The path of the server certificate file. TheBrowse button opens
the "Select Certificate Dialog Box" on page 579.

l Reference type. How the token should be referenced: BinarySecurity
Token or Reference. When the certificate is used for encryption, for
example, a service certificate, use Reference. When using it for a signature
(for example, a certificate with your private key) select BinarySecurity
Token.

<Token
details
pane> -
SAML
tokens

Token details forSAML tokens:

l <SAML token assertions>.

n Grid view, an expandable node listing the assertions in the SAML schema.
If you expand the list, you can set the attribute values. A drop down list lets
you select a specific assertion.

n Text view, an XML reference to the token.

n Revert. Discards all changes made in Text view.

l Load from file. Enables you to browse to a SAML certificate.

l Certificate. The path of the certificate file. TheBrowse button opens the
"Select Certificate Dialog Box" on page 579.

l Certificate reference type. How the certificate should be referenced— by
X509 Data or RSA.

Exclude
Timestamp

Removes the timestamp from the SOAP header before sending the security
element to the server.

WS-Addressing tab

TheWS-Addressing tab indicates whetherWS-Addressing is used by the service, and if so, its
version number. You can also specify the IP address of the server to which you want the response
to be sent.
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WCF Service (Custom Binding) Scenario (Security Settings for Port
<Port_Name> Dialog Box

Use this scenario to test WCF services which require security or transport configurations. For
general details, see "WCF Service (CustomBinding) Scenario Overview" on page 544.
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User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Elements

Description

Transport Transport type. The transport types include:

l HTTP

l HTTPS

l TCP

l NamedPipe

l AutoSecuredHTTP
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UI
Elements

Description

Encoding Encoding.You can choose from the following encoding types:

l Text

l MTOM

l WCF Binary

Security l Authentication mode. A drop down list of possible modes of authentication,
such as AnonymousForCertificate, MutualCertificate, and so forth.

l Bootstrap Policy. A drop down list of possible bootstrap policies for Secure
Conversation authentication., such as SspiNegotiated,
UserNameOverTransport, and so forth.

Net
Security

The type of stream security: None, Windows stream security, orSSL stream
security.

Reliable
Messaging

Enables Reliable Messaging in Ordered or Non-ordered format.

Identities The identity information for the bindings and certificate:

l Username andPassword

l Server /Client certificate. A certificate that provides identity information for
the server or client. Use theBrowse button to open the "Select Certificate
Dialog Box".

l Expected DNS, SPN, andUPN. The expected identity of the server in terms of
its DNS, SPN, or UPN. This can be localhost, an IP address, or a server
name.

Client
Windows
Identity

The identity information for the client windows:

l Current User. The identity of the user logged onto themachine.

l Custom User. A user with the following credentials: Username, Password,
and Domain.

Advanced Opens the Advanced Settings dialog box. For details, see "Advanced Settings
Dialog Box" on page 573.

WCF Service (Federation) Scenario (Security Settings for Port
<Port_Name> Dialog Box)

In theWCF Service (Federation) scenario, the client authenticates against the STS (Security
Token Service) to obtain a token. The client uses the token to authenticate against the application
server.
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User interface elements are described below (unlabeled elements are shown in angle brackets). For
details, see "WCF Service (Federation) Scenario Overview " on page 544.

UI Elements Description

Server l Transport. The transport type: HTTP or HTTPS.

l Encoding. The server's encoding policy: Text or MTOM.

Security l Authentication mode. A drop down list of possible modes of
authentication, such as AnonymousForCertificate,
MutualCertificate, and so forth.

l Bootstrap Policy. A drop down list of possible bootstrap policies for
Secure Conversation authentication., such as SspiNegotiated,
UserNameOverTransport, and so forth.

Identities The identity information for the bindings and certificate:

l Server certificate. A certificate that provides identity information for the
server. Use theBrowse button to open the "Select Certificate Dialog Box".

l Expected DNS. The expected identity of the server in terms of its DNS.
This can be localhost, an IP address, or a server name.
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UI Elements Description

STS (Security
Token
Service)
Details

Information about the STS:

l Endpoint address. The endpoint address of the STS. This can be
localhost, an IP address, or a server name.

l Binding. The scenario which references the binding that contacts the STS.

Advanced Opens the Advanced Settings dialog box. For details, see "Advanced Settings
Dialog Box" on page 573.

WCF Service (WSHttpBinding) Scenario (Security Settings for Port
<Port_Name>) Dialog Box)

In theWCFService (WSHttpBinding) scenario, you can select from several types of
authentication: None, Windows, Certificate, or Username (message protection). For details, see
"WCF Services (WSHttpBinding) Scenario Overview " on page 545.

User interface elements are described below (unlabeled elements are shown in angle brackets) by
the client authentication types:
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UI Elements Description

Client
authentication
type

Authentication type:

l None,

l Windows

l Certificate

l Username (message protection)

For details, see below.

Advanced Opens the Advanced Settings dialog box. For details, see "Advanced
Settings Dialog Box" on page 573.

Client Authentication Types:

l "Client Authentication Type—None" below

l "Client Authentication Type—Windows" on next page

l "Client Authentication Type—Certificate" on next page

l "Client Authentication Type—Username (message protection)" on next page

Client Authentication Type — None

UI
Elements

Description

Expected
server DNS

The expected identity of the server in terms of its DNS. This can be localhost,
an IP address, or a server name. It can also be the common name by which the
certificate was issued.

Negotiate
server
credentials

Negotiates theWeb Service's certificate with the server.

You can also provide the server's DNS information.

Specify
service
certificate

The location of the service's certificate. If you select this option, theNegotiate
service credentials option is not relevant.

For details, see the "Select Certificate Dialog Box" on page 579.

Enable
secure
session

Enables a secure session using no client authentication.
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Client Authentication Type —Windows

UI Elements Description

Client Windows
identity

The identity information for the client windows:

l Current User. The identity of the user logged onto themachine

l Custom User. A user with the following credentials: Username,
Password, and Domain

Enable secure
session

Enables a secure session using Windows type authentication.

Expected server
identity

The expected server identity method: SPN or UPN.

Client Authentication Type — Certificate

UI
Elements

Description

Client
certificate

The location of the client certificate. TheBrowse button opens the "Select
Certificate Dialog Box".

Enable
secure
session

Enables a secure session using Certificate type authentication.

Expected
server DNS

The expected identity of the server in terms of its DNS. This can be localhost,
an IP address, or a server name. It can also be the common name by which the
certificate was issued.

Negotiate
server
credentials

Negotiates theWeb Service's certificate with the server.

You can also provide the server's DNS information.

Specify
service
certificate

The location of the service's certificate. If you select this option, theNegotiate
server credentials option is disabled.

For details, see the "Select Certificate Dialog Box" on page 579.

Client Authentication Type — Username (message protection)

UI
Elements

Description

Enable
secure
session

Enables a secure session using Username type authentication.
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UI
Elements

Description

Expected
server DNS

The expected identity of the server in terms of its DNS. This can be localhost,
an IP address, or a server name. It can also be the common name by which the
certificate was issued.

Negotiate
server
credentials

Negotiates theWeb Service's certificate with the server.

You can also provide the server's DNS information.

Specify
service
certificate

The location of the service's certificate. If you select this option, theNegotiate
server credentials option is disabled.

For details, see the "Select Certificate Dialog Box" on page 579.

Username,
Password

The authentication credentials of the client.

Advanced Settings Dialog Box
This dialog box enables you to customize the security settings for your test.
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To access Do the following:

1. Open the "Security Settings for Port <Port_Name> Dialog Box".

2. Select a WCF Service scenario type from theService Details
list.

3. Click Advanced.

Important information l For details, see "Advanced Security Settings" on page 546.

Relevant tasks l "How to Set Security for aWeb Service on the Port Level" on page
547

l "How to Set Security for a Specific Step" on page 547

l "How to Set Security for aWCF Service" on page 550
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This section includes:

Encoding Tab (Advanced Settings Dialog Box) 575

Advanced Standards Tab (Advanced Settings Dialog Box) 575

Security Tab (Advanced Settings Dialog Box) 576

HTTP and Proxy Tab (Advanced Settings Dialog Box) 578

Encoding Tab (Advanced Settings Dialog Box)

The Encoding tab lets you indicate the type of encoding to use for themessages: Text,MTOM, or
WCFBinary. The default is Text encoding.

The user interface elements are described below:

UI Elements Description

Encoding The encoding type to use for themessages: Text, MTOM, or WCF
Binary.

WS-Addressing
version

The version of WS-Addressing for the selected encoding: None, WSA
1.0, or WSA 04/08.

Advanced Standards Tab (Advanced Settings Dialog Box)

This tab lets you configure advancedWS- standards, such as Reliable Messaging and the Via
address option.

The user interface elements are described below:

UI
Elements

Description

Reliable
messaging

Enables reliable messaging for services that implement theWS-
ReliableMessaging specification. The encoding type to use for themessages:
Text, MTOM, or WCF Binary.

Reliable
messaging
ordered

Indicates whether the reliable session should be ordered.

Reliable
messaging
version

The version to apply to themessages: WSReliableMessagingFebruary2005
or WSReliableMessaging11.
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UI
Elements

Description

Specify via
address

Sends amessage to an intermediate service that submits it to the actual server.
This may also apply when you send themessage to a debugging proxy. This
corresponds to theWCF clientVia behavior.

This is useful to separate the physical address to which themessage is actually
sent, from the logical address for which themessage is intended.

Via
address

The logical address to which to send themessage. It may be the physical of the
final server or any name. It appears in the SOAP message as follows:

<wsa:Action>http://myLogicalAddress<wsa:Action>

The logical address is retrieved from the user interface. By default, it is the address
specified in theWSDL. You can override this address using this field.

Security Tab (Advanced Settings Dialog Box)

The Advanced security settings correspond to theWS-Security specifications.

WCF Service (WSHttpBinding) Scenarios

UI Element (A-Z) Description

Enable secure session Establish a security context using theWS-SecureConversation
standard.

Negotiate service
credentials

Allow WCF proprietary negotiations to negotiate the service's
security.

WCF Service (CustomBinding) Scenarios

UI Element (A-
Z)

Description

Allow
serialized
signing token
on reply

Enables the reply to send a serialized signing token.

Default
algorithm suite

The algorithm to use for symmetric/asymmetric encryption.

The algorithm drop down list gets its values from the
SecurityAlgorithmSuite configuration inWCF.

Default: Basic256

Include
timestamp

Includes a timestamp in the header.
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UI Element (A-
Z)

Description

Key entropy
mode

The entropy mode for the security key. The possible values are: Client
Entropy, Security Entropy, and Combined Entropy.

Default: Combined Entropy

Message
protection
order

The order for signing and encrypting. Choose from:

l Sign Before Encrypt

l Sign Before Encrypt-And Encrypt Signature

l Encrypt Before Sign

Message
security
version

TheWS-Security security version. You can also indicate whether toRequire
derived keys for themessage.

Protection
level

Indicates whether the SOAP Body be encrypted/signed. The possible values
are: None, Sign, and Encrypt And Sign (default).

Default: Encrypt And Sign

Require
derived keys

Indicates whether to require derived keys.

Require
security
context
cancellation

Indicates whether to require the cancellation of the security context. If you
disable this option, stateful security tokens will be used in theWS-
SecureConversation session, if they are enabled.

Require
signature
confirmation

Instructs the server to send a signature confirmation in the response.

Security
header layout

The layout for themessage header: Strict, Lax, Lax Timestamp

First, or Lax Timestamp Last.

X509 inclusion
mode

When to include the X.509 certificate:

l Always to Recipient

l Never

l Once

l Always To Initiator

Note: This and the next three options only apply when using an X.509
certificate.
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UI Element (A-
Z)

Description

X509 key
identifier
clause type

The type of clause used to identify the X.509 key.

l Any

l Thumbprint

l Issuer Serial

l Subject Key Identifier

l Raw Data Key Identifier

X509 reference
style

How to reference the certificate:

l Internal

l External

X509 require
derived keys

Indicates whether X.509 certificates should require derived keys.

HTTP and Proxy Tab (Advanced Settings Dialog Box)

This tab lets you set the HTTP and Proxy information for your test.

HTTP (S) Transport

The following table describes the HTTP(S) Transport options:

UI Element (A-
Z)

Description

Allow cookies Indicates whether to enable or disable cookies.

Authentication
scheme

The HTTP authenticationmethod: None, Digest, Negotiate, NTLM,
Integrated Windows Authentication, Basic, or Anonymous.

Bypass proxy
on local

Indicates whether to ignore the proxy when the service is on the local machine.

Keep-Alive
enabled

Indicates whether to enable or disable keep-alive connections.

Max response
size (KB)

Themaximum size of the response before being concatenated.

Default: 65 KB

Proxy address The URL of the proxy server.
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UI Element (A-
Z)

Description

Proxy
authentication
scheme

HTTP authenticationmethod on Proxy: Digest, Negotiate, NTLM, Basic,
or Anonymous.

Realm The realm of the authentication scheme in the form of a URL.

Require client
certificate

Indicates whether to require a certificate for SSL transport.

Transfer mode The transfer method for requests/responses. The possible values are
Buffered, Streamed, Streamed Request, and Streamed Response.

Use default
web proxy

Indicates whether to usemachine's default proxy settings.

Select Certificate Dialog Box
This dialog box enables you to search and locate a certificate from a file orWindows store.

To access Do the following:

1. Open the "Security Settings for Port <Port_Name> Dialog Box".

2. Select a WCF Service scenario type from theService Details list.

3. Click theBrowse button adjacent to theServer Certificate box.

Relevant tasks "Configure the security settings" on page 550

Select Certificate from File

When you select Import from: File, the dialog box shows the relevant user elements.

The user interface elements are described below:
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UI Elements Description

Import from The source of the certificate file:Windows store or File.

Browse. Enables you to locate the certificate file with a .cer or .pfx
extension.

File The complete path of the certificate file.

Password
(optional)

The password required to access the certificate.

Select Certificate from Windows Store

When you select Import from > Windows store, the dialog box shows theWindows Store related
user elements:
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The user interface elements are described below:

UI Elements Description

Import from The source of the certificate file:Windows store or File.

Store
location

The store location, for exampleCurrent User.

Store name The store name, for example, AuthRoot.

Search text The text to match in the certificate name. If left blank, the Find action retrieves
all available certificates.
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UI Elements Description

<certificate
list>

A list of the certificates in theWindows store sorted by Subject, Issuer,
Private, Store Location, andStore Name.

Find Begins the search for the certificate based on the Search text.

Password
(optional)

The password required to access the certificate.
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Troubleshooting and Limitations - Web Service
Security

This section describes troubleshooting and limitations for working withWeb services security.

l Authentication and proxy security are not supported forWeb Services imported from aUDDI.

l ForWeb Service configured withWCF settings: Configuring different security settings for
operations residing on the same port is not supported.

l ForWeb Service configured withWCF settings, some of the user event handlers (such as the
AfterProcessRequestSecurity, BeforeProcessResponseSecurity,OnSendRequest, and
OnReceiveResponse events) will not be invoked.

l When testingWeb Services that require message-level security, theWeb Service security
scenario only supports SOAP version 1.1. For SOAP 1.2 use aWCF type scenario.

l When using a SAML security token forWeb services security, user-provided content may
contain creation and expiration timestamps. To extend the life of the test, we recommend that
you hard-code an expiration date in the distant future. In this is not possible, change the
timestamp by implementing theOnBeforeApplyProtocolSettings event.

l When using a SAML security token forWeb services security, if you edit the values in Grid
mode, they may not be updated in Service Test.

Workaround: To update the values, switch to Textmode and save the test.

l WebService steps are not supported when using a SAML token with a certificate from the file
system.

Workaround: Install the certificate to theWindows store and select the certificate from the
store.

l Whenworking with Federation type scenarios that use STS (Security Token Service), you
cannot change the SOAP version.

l If you are using SOAP version 1.2:

n You can choose only UserName or X509 tokens when configuring themessage level
security.

n When configuring the canonicalization algorithm and the transform algorithm for themessage
signature cannot be http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-soap-
message-security-1.0#STR-Transform.
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For general information about running a test, see "Running Tests and Components" on page 284.
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Concepts

Checkpoint Validation
In functional testing, it is necessary to check the results of test steps to confirm that the activity
performed its expected functionality. The response can contain several properties, each containing
several data items. TheCheckpoints section is a central point for defining the expected values of
the properties.

Before replaying a test, you set the expected output property values. You can enter the values
manually, link them to a data source, or load values that were captured during a prior replay. This is
useful when you havemany argument values—instead of manually entering values, you
automatically load them.

To include a checkpoint in the test, you select its check box. If you loaded replay values, you can
select only those properties that you loaded.

ForWSDL-basedWeb Services and SOAP Requests, Service Test includes two built-in
checkpoints for the purpose of validation. One checkpoint validates the XML structure and the other
checks its compliance withWS-I.

Additional checkpoint settings let you trim the string, ignore case inconsistencies, and indicate
whether to stop on failed checkpoints.

For details, see the "Input/Checkpoints/Output Properties Tab (Properties Pane)" on page 201.

After the test run, the Run Results Viewer displays the checkpoint status in its own sub-node. For
details, see theHP RunResults Viewer User Guide.

This section also includes

XPath Checkpoints 586
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XPath Checkpoints

For steps with XML output properties, such asWeb Service andSOAP Request, String to XML,
and so forth, you can validate the test results against XPath expressions.

You can specify a fully qualified XPath expression, or you can instruct Service Test to ignore the
namespaces and prefixes during the test run. By ignoring the namespaces, you can use a simpler
expression.

In the following example, to retrieve the contents of the second node, B, you would need to write an
expression that also indicates the namespace, such as //*[local-name(.)='Node' and

namespace-uri(.)='ns2'].

<Root>

   <Body>

        <Node xmlns="ns1">A </Node>

        <Node xmlns="ns2">B </Node>

   </Body>

</Root>

Whenworking with simple XPath expressions, you can further simplify the XPath expression by
selecting Ignore namespaces. In the above example, the expression //Node[2] is sufficient to
evaluate the value B in the second node.

You can type in the XPath expressions manually, or use the shortcut menu to retrieve the simplified
or fully qualified XPath.

Service Test also enables you to evaluate XMLwith namespace prefixes. For example, if the XML
contains the prefix definition xmlns:T="ns1", you can specify the prefix in the XPath expression:
//T:NodeName. To evaluate namespace prefixes, disable the Ignore namespaces option.

XPath checkpoints can only be used when the XPath query returns a scalar value—not XML.

For task details, see "How to Set XPath Checkpoints" on page 592.

Negative Testing
When performing a functional test for yourWeb Service, you should approach the testing in a
variety of ways. Themost common type of testing is calledPositive Testing—checking that the
service does what it was designed to do.

In addition, you should perform Negative Testing, to confirm that the application did not perform a
task that it was not designed to perform. In those cases, you need to verify that the application
issued an appropriate error—aSOAP Fault.

To illustrate this, consider a form accepting input data—you apply positive testing to check that
yourWeb Service has properly accepted the name and other input data. You apply negative testing
tomake sure that the application detects an invalid character, for example a letter character in a
telephone number.

When your service sends requests to the server, the server responds in one of the following ways:
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l SOAP Result. A SOAP response to the request.

l SOAP Fault. A response indicating that the SOAP request was invalid. Negative Testing
applies only to SOAP faults.

l HTTP Error. AnHTTP error, such as Page Not Found, unrelated toWeb Services.

Service Test can check for a standard SOAP result or a SOAP fault response. For example, if your
Web Service attempts to access aWeb page that cannot be found, it will issue a 404 HTTP error.
Using negative testing you indicate that you expect a SOAP fault. In this case, the test run will fail if
the service accesses a validWeb page.

The Properties pane lets you provide values for the SOAP fault header and body. You can enter
faultcode, faultstring, and faultactor values as well as custom properties usingAny type
parameters. Using the Checkpoint mechanism, you can validate these values and view the results
in the Run Results Viewer.

For details on setting up the SOAP fault values, see "SOAP Fault Tab (Properties Pane)" on page
209.

Load Testing
You can add load testing capabilities to your test, that will allow you tomeasure performance under
load.

When you have a full LoadRunner installation on your machine, Service Test provides a custom
template, API Load Test.

For tests created with the standardAPI Test template, Service Test provides a conversion utility
which converts the script into a LoadRunner compatible script, with a .usr extension.

Note: Tests created in Service Test and converted into LoadRunner scripts, cannot be edited
in LoadRunner's Virtual User Generator (VuGen). To edit a test, modify it in Service Test.

Tomeasure performance within LoadRunner, you can insert Start andEndTransactionmarkers.
During execution, LoadRunner measures the execution time of all the actions between the
transactionmarkers.

The Think Time activity lets you emulate the way a true user operates, pausing between actions.
You specify a duration in seconds, for which to wait between test steps.

When working with data tables, you can use the standard data retrieval methods that are available
in LoadRunner. For details, see "Data Retrieval Options for Load Test Enabled Tests" on page 633.

For task details, see "How to Prepare and Run a Load Test" on page 594.

Using Virtualized Services
Service Test integrates with HP Service Virtualization. This integration enables you to run virtual
services that simulate actual services. This is especially useful where running a service incurs a
cost, such as credit card processing. In addition, it is useful when development is incomplete for
the service you need to test.
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In HP Service Virtualization, you create simulation projects. These projects contain information
about the virtualized services that simulate actual services.

In Service Test, you can load one or more simulation projects. A dialog box indicates if and when
the service was deployed, and information about the virtualization server. For details, see the
"Virtualized Services Settings Dialog Box" on page 598.

Once you deploy the project, you can import its services the sameway you would import any other
WSDL. For details, see "Import/UpdateWSDL from URL or UDDI Dialog Box" on page 489.

Data and Performance Models
You can select the Data and/or Performancemodels to use with the virtualized service in test
execution.

The DataModel enables you to record actual requests and responses for the real service and then
use this data for simulation using the virtual service. You can edit the data, add service calls, and
model the behavior.

The PerformanceModel enables you to record the performance for the real service and then use
this as performance criteria for the service.

You define thesemodels when you create the Simulation project in HP Service Virtualization. You
should select at least one Data or Performancemodel. If you select None for bothmodels, it is
equivalent to working in Pass Throughmode.

For details, refer to theHP Service Virtualization User Guide.
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Tasks

How to Set Array Checkpoints
This task describes how tomanually set checkpoints for elements of an array. For details about
setting regular checkpoints, see "How to Run an API Test" on page 288.

For details about data driving array checkpoints, see "How to Data Drive Array Checkpoints" on
page 591.

This task includes the following steps:

l "Enable active content on your computer" below

l "Add a step with an array output" below

l "Select an array validationmethod" below

l "Add array elements" on next page

l "Provide values" on next page

l "Validate the element count - optional" on next page

l "Set the number of iterations and run the test" on next page

l "Open the Checkpoint report" on next page

1. Enable active content on your computer
The RunResults Viewer shows array checkpoint results in an expandable tree. To enable this
view, modify your browser settings as follows:

a. In Internet Explorer, select Tools > Options.

b. Select theAdvanced tab.

c. Enable the optionAllow active content to run in files on My Computer in theSecurity
section.

d. Click OK and close the browser.

2. Add a step with an array output
Add a test step with output properties in the form of an array.

3. Select an array validation method
Expand the drop down adjacent to the name of the parent array node. Select one of the
following:

n Fixed. Checks that each of the returned array elements matches its corresponding array
element in theCheckpoints pane. Each array is marked by an index number, as it checks
the arrays by their index.

n All. Checks that all of the returned array elements match the array element in the
Checkpoints pane. In this mode, arrays are not marked by an index number. For example, if
a property in the first array is marked >= 2 and the same property in another array element is
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set to <=10, the test run will check that all returned values are between 2 and 10.

n Contains. Checks that at least one of the returned array elements matches the value of the
property in theCheckpoints pane. In this mode, arrays are not marked by an index number.

4. Add array elements
Use the plus button in the row of the parent node to add the desired number of array
elements.

5. Provide values
Select theValidate box for each value that you want to validate and provide values for those
properties.

6. Validate the element count - optional
Click in the parent row of the array and enter a desired count number in theExpected Value
column and the evaluation expression, such as =, >, and so forth. During the test run, the
validation will check the number of returned array elements against this value.

7. Set the number of iterations and run the test
Click in the Test Flow or Loop box and open the Properties pane. Set the test flow properties,
such as the number of iterations or loop type. Click theRun button and provide a results
location. For details, see "How to Run an API Test" on page 288.

8. Open the Checkpoint report
In the Run Result Viewer, expand the test results tree in the left pane. Select a Checkpoint
node. In theCaptured Data pane, click View Report in the Details column. In the report that
opens, expand the checkpoint node for each of the iterations to view its actual and expected
value.
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How to Data Drive Array Checkpoints
This task describes how to set checkpoints for elements of an array through data driving. For
details about setting regular checkpoints, see "How to Run an API Test" on page 288.

This task includes the following steps:

l "Enable active content on your computer" below

l "Add a step with an array output" below

l "Add an array element" below

l "Data Drive the array" below

l "Set the evaluation expression" below

l "Provide data for the array" on next page

l "Select an array validationmethod" on next page

l "Set the number of iterations - optional" on next page

l "Run the test" on next page

l "Open the Checkpoint report" on next page

1. Enable active content on your computer
The RunResults Viewer shows array checkpoint results in an expandable tree. To enable this
view, configure your browser to allow active content as described in "How to Set Array
Checkpoints" on page 589.

2. Add a step with an array output
Add a test step with output properties in the form of an array.

3. Add an array element
a. Open the Properties pane and click in theCheckpoints area.

b. Use the plus button . in the row of the parent node, to add an array element.

c. Provide property values. These values are transferred to the Data pane during data driving.
If you do not provide data, include the array element by selecting the triangle icon in the
parent node.

4. Data Drive the array

a. Select the array's parent node and click theData Drive button .

b. In the "Data Driving Dialog Box" (described on page 625), select Only Input,
Checkpoints orBoth Input and Checkpoints as aData Driven Section option.

c. Click OK. The data drivingmechanism informs you that it succeeded.

5. Set the evaluation expression
In the Properties pane, adjacent to the data driving expression, select an evaluation operator,
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such as =, <, and so forth.

6. Provide data for the array
a. Once you data drive an array, you do not set property values from theCheckpoints pane.

Instead, you edit the table in the Data pane. In the Data pane, which opens automatically,
click the node in the left pane, corresponding to the array element that is to be validated.

b. Enter the iteration number to which to checkpoint should be applied in the MainDetails
column of the <array_name> and MainDetails tables. A "1" indicates the first iteration.
If you have several columns with "1" as the iteration number, the checkpoints will be
validated against all of those values.

7. Select an array validation method
Select the step in the canvas and view the Properties pane. Expand the drop down adjacent to
the name of the parent array node. Select one of the following:

n Fixed. Checks that each of the returned array elements matches the corresponding array
element in the data table in the Data pane. Each array is marked by an index number, as it
checks the arrays by their index.

n All. Checks that all of the returned array elements match the array element in the Data
pane. In this mode, arrays are not marked by an index number. For example, if a property in
the first array is marked >= 2 and the same property in another array element is set to <=10,
the test run will check that all returned values are between 2 and 10.

n Contains. Checks that at least one of the returned array elements matches the value of the
property in theCheckpoints pane. In this mode, arrays are not marked by an index number.

8. Set the number of iterations - optional
If you selected theConfigure Test Flow as a ForEach loop using the new data source
option in the "Data Driving Dialog Box" (described on page 625), you can skip this step. If not,
click in the Test Flow or Loop box and open the Properties pane. Set the test flow properties,
such as the number of iterations or loop type.

9. Run the test
Click theRun button and provide a results location. For details, see "How to Run an API Test"
on page 288.

10. Open the Checkpoint report
In the Run Results Viewer, expand the test results tree in the left pane. Select a Checkpoint
node. In theCaptured Data pane, click View Report in the Details column. In the report that
opens, expand the checkpoint node for each of the iterations to view its actual and expected
value.

How to Set XPath Checkpoints
This task describes how to validate your test results against XPath expressions. For conceptual
information, see "XPath Checkpoints" on page 586.

This task includes the following steps:
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l "Add a step with XML output" below

l "Set the namespace setting" below

l "Copy the XPath" below

l "Add an XPath checkpoint" below

l "Provide the XPath expression" below

l "Set up the validation" below

l "Run the test" on next page

1. Add a step with XML output

Add a test step with XML output, such as String to XML. Open the Input/Checkpoints tab
. Paste a source string into theValue column or use the Link to data source button to link to
a value.

2. Set the namespace setting
Click theXPath tab, and indicate whether or not to ignore namespaces. By default, the Ignore
namespaces option is enabled. If you plan to validate against a fully qualified expression, or if
you need to specify a namespace prefix, disable the option. For details, see "Properties Pane
Tabs" on page 186.

3. Copy the XPath
Copy an XPath expression to the clipboard. If you intend to enter the XPath expression
manually, skip this step.

n To retrieve a simple XPath, click in theValue column, and select Copy XPath from the
shortcut menu.

n To retrieve a complete qualified XPath, click in theValue column, and select Copy Fully
Qualified XPath from the shortcut menu.

4. Add an XPath checkpoint
Click theXPath tab in the Checkpoints section. Click theAdd button to add a new XPath
checkpoint.

5. Provide the XPath expression
Type or paste the expression into theXPath Checkpoints column. You can also use the Link
to data source button to link to a value.

6. Set up the validation
Select the check box in theValidate column, select a comparison operator, and provide an
expected value.
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7. Run the test
Run the test and check the results.

How to Prepare and Run a Load Test
This task describes how to prepare a test for load testing in LoadRunner. For an explanation about
load testing, see "Load Testing" on page 587.

This task includes the following steps:

l "Prerequisite" below

l "Create a load test" below

l "Add test steps" below

l "Prepare for load testing - optional" below

l "Assign data to the test - optional" on next page

l "Set the data retrieval properties - optional" on next page

l "Set the run configuration to Release" on next page

l "Run in Load Testingmode to validate the test" on next page

l "Incorporate the test into LoadRunner" on page 596

1. Prerequisite
Make sure that HP LoadRunner or a standalone version of VuGen (HP Virtual User Generator)
is installed. Without this installation, the Load Testing template will not be available.

2. Create a load test
In the "New <Document> Dialog Box" on page 67 (described on page 67), in theSelect type
section, chooseAPI Load Test.

If you have a test that was created with the standard Service Test template, select Design >
Operation > Enable Test for Load Testing or click theEnable Test for Load Testing

button .

3. Add test steps
Drag activities from the Toolbox pane onto the canvas to add steps to the test.

4. Prepare for load testing - optional
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Tomeasure the performance of a group of steps, define a transaction.

a. Mark the beginning of a transaction.

o Drag theStart Transaction activity from the Toolbox pane's Load Testing category,
onto the canvas. Place it before the first step of the group of steps that you want to
measure.

o Click the Input/Checkpoints tab in the Properties pane. Enter a Transaction name.
This namewill be used in LoadRunner Analysis.

b. Mark the end of a transaction.

o Drag theEnd Transaction activity to the end of the group of steps you want to
measure.

o In the Properties pane's Input/Checkpoints tab, type a transaction name. The name
must be one that was already used for a priorStart Transaction step.

o In the End Transaction's Input properties, select aStatus for reporting: PASS, FAIL,
AUTO, or STOP.

Note: The End Transaction status is only the LoadRunner transaction's status—
not the status of step in Service Test. For example, if you assign a Failed status to
the transaction, Service Test can still issue aPassed status for the test step.

c. Set the think time.

o If you want to emulate think time, drag the Load Testing >Think Time activity
between the relevant steps.

o In the Properties pane's Input/Checkpoints tab, click in theDuration (sec) row and
specify a think time in seconds.

5. Assign data to the test - optional
Import or create data tables for the input properties. For details, see "How to Assign Data to
Test Steps" on page 621.

6. Set the data retrieval properties - optional
If you have data in the Data Pane, set the data retrieval properties. Click the Link to a data
source button . For details, see the "Data Retrieval Options for Load Test Enabled Tests"
on page 633.

7. Set the run configuration to Release
In the General pane of the API Testing tab in the Options dialog (Tools > Options > API
Testing tab > General node), in theRun Sessions options, select Release. TheRelease
mode conserves resources, thus enhancing the load testing capabilities.

8. Run in Load Testing mode to validate the test
Expand the toolbarRun button and select Run Test in Load Testing Mode. This run is only
for debugging purposes, to verify that the test is functional.
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Note:When you run a test in Load Testingmode, the Output pane does not contain data
and the Run Results Viewer does not open. To view the results, select Run to run the test
in functional mode.

9. Incorporate the test into LoadRunner
Add the test to the LoadRunner Controller console to include it in a load test.
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Reference

Command Line Syntax
The Service Test executable, ServiceTestExecuter.exe, is located in the product's bin
directory.

The following table describes the command line options for ServiceTestExecuter.exe:

UI
Elements
(A-Z)

Description

-inParams The full path of an XML file containing the input property values (optional).

-
outParams

The full path of an XML file containing the output property values (optional).

-profile The name of an Test profile (optional). For details, see "How to Define Test
Properties or User/System Variables" on page 59.

-report The directory in which to store the report.

-test The full path of the test (required). Specify the test directory—not the solution
directory.

Tip: To retrieve a list of all of available parameters, run ServiceTestExecuter.exe
without any parameters.

The following example runs Test1 using input properties from inParams.xml and output
properties from outParams.xml:

%ProgramFiles%\HP\HP Service Test\bin> ServiceTestExecuter.exe -

test "c:\MyTests\Test1\Test1" -inParams "c:\MyData\inParams.xml" -

outParams "c:\MyData\outParams.xml"

-profile Profile1

where the input property file, InParams.xml, has, for example, this structure:

<Arguments>

     <a>1</a>

      <b>2</b>

</Arguments>

Note: To run a test from the command line, youmust save and run the test at least once.
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Virtualized Services Settings Dialog Box
The Virtualized Service user interface provides integration with HP Service Virtualization. This
integration enables you to test services with virtualized servers instead of actual servers.

For details, see "Using Virtualized Services" on page 587.

This dialog box enables you load HP Service Virtualization projects.

To access 1. Create or open a test or component.

2. Click theVirtualized Services Settings toolbar button .

Important
information

Youmust stop the service simulation and close the Service Virtualization
Designer window, before running the test that uses the virtualized service. Failure
to do so will result in the service being locked for all other users.

Relevant
tasks

"How to Run an API Test" on page 288

The user elements are described below (unlabeled UI elements are shown in angle brackets).
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UI Element (A-Z) Description

<emulated services> A list of the virtualized services showing the following
information:

l Simulate. Includes the virtual service when executing the
test.

l Project Name. The name of the HP Service Virtualization
project containing the virtual service.

l Service Name. The name of the virtual service to use during
test execution.

l Data Model. The datamodel to associate with the virtual
service.

l Performance Model. The performancemodel to associate
with the virtual service.

l Simulation Server. Themachine used for emulating the
virtual service. If the value was configured on the server
machine as localhost, be sure to change it to the actual
server name.

l Deployed. An indicator showing the deployment status:

n Unknown. Click theCheck Deployment button to
check the status.

n Deployed. Successfully deployed.

n Not Deployed. The service is not deployed on the
specified emulation server.

Add Project Opens the Add Project dialog box, allowing you to specify or
browse for an HP Service Virtualization project. Project files
have a .vproj extension.

Check Deployment Checks if the virtual service was deployed on the virtualization
server.

Delete Project Removes the selected project(s) from the list of virtualized
services.

Servers Security Opens the Servers Security dialog box showing the credentials
for each of the servers.

Set all simulated services
to standby - ignore all
calls to all simulated
services.

Allows you to temporarily ignore all calls to simulated services.

To set a specific virtualized service to standby, select None for
its Performance and Datamodels.

HP Service Test (11.52)Page 599 of 705

User Guide
Chapter 28: Testing Techniques



Troubleshooting and Limitations - Load Testing
This section describes troubleshooting and limitations for working with load testing.

l Related datamapping in a load-enabled test is not supported for the LoadRunner parameter
advance policy of Each Occurrence.

l Tests created as Business Process Testing (BPT) components, cannot be used in load testing.

l If your tests use IBM's MQ client, make sure to install theMQ client on all machines running
these tests.

l You cannot run tests containing actions or calls to other tests on a remote load generator. This
limitation does not apply when running the test on a local load generator.

l The data assignment method, Use a unique value for each Virtual User when load testing
is not supported in all environments.
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Chapter 29: Asynchronous Service Calls
This chapter includes:

Concepts 602

Asynchronous Services 602

Tasks 605

How to Create a Test for an Asynchronous Web Service 605

Troubleshooting and Limitations - Asynchronous Testing 607
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Concepts

Asynchronous Services
You can use Service Test to emulate asynchronous services. Asynchronous services can beWeb
Services, REST services, HTTP requests, JMS/MQ-based services, and so forth.

In synchronous messaging, the replay engine blocks step execution until the server responds. The
client sends a request and receives a response immediately, using the same connection. During
the waiting time, the replay engine is blocked and does not perform any other activity. If the timeout
was reached without a response from the server, the client returns an error.

In asynchronous mode, the replay engine executes the step without waiting for server's response
from previous requests.

Wait Steps

When sending asynchronous calls with HTTP or HTTPS, you use aWait step to instruct the test to
wait for the response of earlier asynchronous requests before continuing with its execution.

You do not have to place theWait step directly after the Receive step. The test can proceed with
other steps, but theWait step will instruct the test to wait for a response before ending the test, or
before continuing to execute any steps that follow theWait step.

Checkpoints

When sending a request to a server, you use checkpoints to verify theOutput property values.

When getting a request from a server, as in most of the asynchronous patterns, you use
checkpoints to verify the Input properties.

Service Test provides a solution for the following asynchronous patterns:

l "WS-Addressing" below

l "HTTP Receiver" on next page

l "Web Service Publish Subscribe" on next page

l "Web Service Solicit Response" on next page

l "Dual WSDL Files" on page 604

WS-Addressing
WS-Addressing is a specification that enables Web services to communicate addressing
information. You can instruct the server to respond to any location, and not necessarily to the
machine that issued the request. To do this, you use theWS-Addressing replyTo attribute.

In this implementation, Service Test pauses the test and uses a listener mechanism to verify that
the response arrived at the specified address. After the listener acknowledges that the server
responded to the address or if it reaches the timeout, the test resumes. Upon the completion of the
test, you can validate the response with the standard Service Test checkpoints.
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For user interface details, see the "Asynchronous Tab (Properties Pane)" on page 186.

HTTP Receiver
In theHTTP Receiver pattern, the server sends an HTTP request to the client, reversing the
typical roles of the client and server.

This is useful, for example, if you want to test a service which publishes information over HTTP to a
client. You define a receiver, which waits for a request from the server, sent over HTTP.

After a trigger, the receiver captures the request. The trigger can be an HTTP client request, a call
to aWeb service, an email, or any other event that will trigger the server. If there are inner steps, the
receiver waits for them to finish and only then is the receiver activity considered complete.

Using the Service Test interface, you can insert the necessary logic and validate the checkpoints in
the captured request.

The response from the receiver should wait for the inner steps to complete and link to them.

The completion event name fired for the receiver should only be fired AFTER the inner steps are
done.

For details about the properties, see the "Network Activities" on page 426.

Web Service Publish Subscribe
In theWeb Service Publish Subscribe pattern, the server sends an HTTP request to the client,
reversing the typical roles of the client and server. it is similar to the HTTP Receiver, except that
the request is sent to the client through aWeb Service call instead of exclusively via HTTP.

Using Service Test, you test the publishing of messages to the client. You set up a receiver, which
waits for a server request, sent from the server as aWeb service call.

After a trigger, the receiver captures the request. The trigger can be an HTTP client request, a call
to aWeb service, an email, or any other event that will trigger the server.

Using the Service Test interface, you can validate the response with standard Service Test
checkpoints.

Web Service Solicit Response
TheWeb Service Solicit Response pattern is a variation of theWeb Service Publish
Subscribe pattern. It enables you test a a service which publishes information through aWeb
Service to a client.

In this pattern, however, the client is expected to send a response to the server request. The
response can be a simple acknowledgement or a full SOAP message.

You set up a receiver activity, which waits for a server request. This server request is sent from the
server as aWeb service call. The receiver then sends a client response back to the server.

After the trigger, the receiver captures the request. The trigger can be an HTTP client request, a call
to aWeb service, an email, or any other event that will trigger the server.

Using the Service Test interface, you can validate the response with standard Service Test
checkpoints.
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Dual WSDL Files
The Dual WSDL technique is a standard request-response pattern. In this pattern, however, the
client request is defined by oneWSDL, and the server response is defined by anotherWSDL.

You implement this scenario in two stages:

l Import the Request WSDL file, using the Import WSDL from import command.

l Import the ResponseWSDL file, using the Import WSDL from import command, enabling the
Import as Server Response option. For details, see the "Import/UpdateWSDL from URL or
UDDI Dialog Box" on page 489 or "Select WSDLDialog Box" on page 488.

For task details, see "How to Create a Test for an Asynchronous Web Service" on next page.
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Tasks

How to Create a Test for an Asynchronous Web Service
This task describes how to create a test for testing an asynchronous Web service.

For an overview of the asynchronous patterns supported by Service Test, see "Asynchronous
Services" on page 602.

The following section describes the following tasks:

l "Create a test forWS-Addressing" below

l "Create a test for HTTP Receiver" below

l "Create a test for aWeb service publish subscribe pattern" on next page

l "Create a test for Dual WSDL Files" on next page

Create a test for WS-Addressing
To useWS-Addressing for aWeb Service call:

1. Import aWeb Service using Import WSDL > Import WSDL from URL or UDDI and drag an
operation onto the canvas. For details, see "How to Import aWSDL-BasedWeb Service" on
page 472.

2. Open the Asynchronous tab in the Properties pane and select This is an asynchronous
call box.

3. Specify a value for the Listen for response on property. This is the port to which you expect
the server to respond.

4. Open the Security tab in the Properties pane. Select theWS Addressing tab.

5. Select aWS-AddressingVersion and provide and a URL and port (same port as defined for the
Listen for response on property) in theReply to box, to indicate the destination of the server
response.

6. Run the test and perform checkpoint validations as you would with any step.

For more details, see the "Asynchronous Tab (Properties Pane)" on page 186.

Create a test for HTTP Receiver
To create a test for an HTTP Receiver in which the client receives the response:

1. Drag aNetwork > HTTP Receiver step onto the canvas.

a. Make sure you are logged in as an administrator. Administrator privileges are required to
runHTTP Receiver steps.

b. Specify theGeneral properties . For details, see the "Network Activities" on page 426.

c. Set theHTTP Receiver properties . For details, see the "HTTP Receiver Tab
(Properties Pane)" on page 201.
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d. Set a filter for the HTTP message . For details, see "Filter Settings Tab (Properties
Pane)" on page 195.

2. Drag a Flow Control > Wait step onto the canvas. Specify timeout information and one or
more completion events. You can link to the completion event from a priorHTTP Receiver
step.

3. If required, drag additional activities from the Toolbox pane into theHTTP Receiver flow.

4. Run the test and apply the trigger for the server. For details, see the "HTTP Receiver" on page
603.

Tip: If your test needs to listen tomore than onemessage, receiver steps (such as HTTP
Receiver orWeb Service calls set up as receivers) can be data driven and placed inside a
loop. The placement of theWait step—inside or outside of the loop—depends on whether
the send order matters:

n If themessages to be sent to the receiver are expected in a specific order, youmust
place theWait step inside the receiver step's frame. All steps that are contained within
the receiver can be data driven using this loop.

n If however, themessages are expected in a random order, place theWait step outside
the receiver step. Steps that are contained within the receiver should not be data driven
using the same loop as the receiver step and should not link to other steps outside the
receiver.

Create a test for a Web service publish subscribe pattern
To create a test to check that messages are properly published to the client:

1. Import aWSDL as a server by enabling the Import as server option. For details, see "How to
Import aWSDL-BasedWeb Service" on page 472. This Web Service should have a receiver
type pattern. Drag an operation onto the canvas.

2. Set the input or output properties . For details, see the "Input/Checkpoints/Output Properties
Tab (Properties Pane)" on page 201.

3. Drag a Flow Control > Wait step onto the canvas. Specify timeout information and one or
more completion events. You can link to the completion event from a priorHTTP Receiver
step.

4. Run the test and activate the trigger for the server. For details, see "Web Service Publish
Subscribe" on page 603.

Create a test for Dual WSDL Files
To create a test for a dual WSDL pattern, using oneWSDL for the request and another for the
response:

1. Import the request WSDL file using the standard import command, Import WSDL from. The
imported operations can send client requests and receive server responses.

2. Import the responseWSDL file as a server by enabling the Import as Server Response
option in the "Select WSDLDialog Box" or the "Import/UpdateWSDL from URL or UDDI
Dialog Box" (for URL and UDDI imports, click Advanced Settings to show the option). The
imported operations first receive server requests and then send client responses.
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3. Drag aWeb service operation with the request onto the canvas.

4. Drag aWeb service operation with the response onto the canvas, after the request step.

For details, see "Dual WSDL Files" on page 604.

Troubleshooting and Limitations - Asynchronous Testing
This section describes troubleshooting and limitations for creating asynchronous tests.

For aWeb service imported as a server response:

l When enabling the SSL option, Service Test temporarily binds the SSL certificate to the
specified port on a system, http.sys, level. If you end the Service Test.exe process from
the Task Manager during the listening stage after the binding was added, the binding will not be
automatically removed from the system.

Workaround:Remove the bindingmanually using a utility such as httpcfg.exe or
netsh.exe.

l Whenworking with SSL, certificates from a file are not supported. If youmove the test to
another machine, the certificate will not be available.

Workaround:Add the certificate to the local machine store before running the test. If desired,
remove it after you finish working with the test.
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Concepts

Data Handling Overview
Before running a test, youmay assign input and checkpoint data and specify how the data should
be used.

Service Test's Data pane lets you view andmaintain data for your test steps. You can import data
from Excel files, XML files, or databases. You can also create local data tables, which you populate
manually, as a source for your data. For details, see "How to Assign Data to Test Steps" on page
621. For details on the Data pane, see "Data PaneOverview" on page 89.

You can data-drive the properties of a step or the SOAP or HTTP request and response bodies.
Data-driving is themechanism by which Service Test automatically creates data expressions that
refer to data in a new, editable table. For details, see the "Data Driving Dialog Box" on page 625.

Defining Data
Service Test enables you to assign data to your steps in several ways. You can enter values
manually, link to existing data, or data drive the values.

This section also includes:

Populating Data Tables Manually 609

Linking to a Data Source 610

Creating aQuery to Retrieve Database Tables 611

Outgoing Links 612

Data Driving 614

Populating Data Tables Manually

The "Properties Pane Tabs" grid enables you to view and edit the values of each input property. You
canmanually insert values into the grid for both simple properties and arrays.
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You can also edit the values in the XML text mode. The editor also enables you to discard changes
and return to the original XML using theRevert button.

You canmanually populate the checkpoint values or load values that were obtained from an earlier
run using the Load from Replay button. The Load from Replay button is enabled after running the
step test at least once—either by running the entire test or executing the individual step using the
Run Step command. For details see "Run Step Results PaneOverview" on page 220.

Linking to a Data Source

The recommended way to define data for a step is by linking it to a data source. The "Select Link
Source Dialog Box" (described on page 630) enables you to link to data in several ways:

l Reference a property of a another step

l Use a user or system test variable
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l Use data from a data source, such as an Excel file or database table

You can also use a combination of these types: for example, a combination of aData source
column and Test variable sources tomake a single expression.

To use data source columns, you add one or more data sources to the test through the Data pane.
For details, see the "Data Pane" on page 96.

When preparing scripts for load testing, the "Select Link Source Dialog Box" (described on page
630) also lets you select the way in which to retrieve the data and what to do when the data has run
out. For details, see "Data Retrieval Options for Load Test Enabled Tests" on page 633.

For task details, see "How to Assign Data to Test Steps" on page 621.

Creating a Query to Retrieve Database Tables

If you choose to create a data source from a database, Service Test lets you retrieve data from both
OleDB andODBC databases. A wizard guides you through connecting to a database and creating
an SQL query statement. After you complete the wizard, the Data pane displays the database's
data tables.

HP Service Test (11.52)Page 611 of 705

User Guide
Chapter 30: Data Handling



The connection builder assists you in creating a string for your connection. For details, see
"Connection Builder Dialog Box" on page 453.

Once you are connected to the database, you can use Service Test's Query Designer to create a
custom SQL statement, based on the tables and views in your database.

For details on how to use theQuery Designer, see the "Query Designer Dialog Box" on page 456.

To learnmore about using the wizard, see "Add a database data source" on page 91.

Outgoing Links

When you link a property to another step's property, Service Test indicates this with aOutgoing
Links button in the Properties pane's Input/Checkpoints list.

By clicking on the button, you can open a list of the properties that link to this output property. This
is especially helpful when linking to an output property multiple times.

The following example shows three steps linking to a single output property of the
CreateFlightOrder step.
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When you click theOutgoing Links button, Service Test opens a list of the target properties that
link to this value. Using theGo to button, you can navigate directly to the linked property. This
selects the target step on the canvas and the target property in the Properties pane.
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Data Driving

Data-driving is themechanism by which Service Test automatically creates data expressions for
properties. When you data drive a step, Service Test adds data expressions to the step's value
fields.

These expressions refer to data in a new editable Excel table or XML structure, depending on the
type of provider you specified during the data driving.

You can customize data-driving in the following ways:

l Specify the type of data source to create—Excel or XML.

l Indicate which properties to data drive:

n For standard input and output (checkpoint) properties: Input, Checkpoints, or both.

n For XSD files, loaded for the HTTP or SOAP Request steps: Request Body, Response
Body, or both.

n For additional types such as HTTP multipart and SOAP Fault properties, see the "Data
Driving Dialog Box" on page 625.

l Whether to use the same or two different data sources, when data driving two sections, such as
Input and Checkpoint properties (Enabled only for Excel data sources).

l Whether or not to set the target step's loop, as a "For Each" type, based on the generated data
source.

For Excel type tables, you canmanually add to and edit the data in the Data pane.
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For XML data sources, you canmanually edit the XML root.

For task details, see "How to Data Drive a Test Step" on page 623.

For user interface details, see "Data Driving Dialog Box" on page 625.

Data Relations and Navigation
Service Test lets you indicate how to use the data source, how many times to loop through the
data.

You can also define relations between data tables and data sources.

This section also includes:

Navigating within the Data 615

Child Relations 616

Data Keywords 617

Navigating within the Data

Using the "Data Navigation Dialog Box" (described on page 634), you control the way you use the
values in the data tables.

The Data Navigation settings work together with the loop settings described in "Loop - Input
Properties" on page 418.

If the loop is configured as a ForEach type, and you designate a specific data source as the loop's
collection, then the Data Navigation settings affect the number of iterations of the loop.
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For data sources that are not designated as the loop collection, but whose values are fetched by
steps within the loop, the Data Navigation policy affects the data differently. It indicates the order in
which the values are fetched from the data source, and assigned to steps within the loop.

For user interface details, see "Data Navigation Dialog Box" on page 634.

Child Relations

You can define data relations for all of your data tables. You can then use this relation as data for
test properties. This is useful in cases where some property values are in one table, and other
property values are in another table.
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For task details, see "Create a new child relation" on page 94.

For user interface details, see the "Define New/Edit Data Relation Dialog Box" on page 637.

Data Keywords

You can use keywords to customize the test run and validation. For example, SKIP omits a
property in the request or in the validation.

Service Test provides keywords for both input properties and checkpoints. You can set keywords in
the following ways:

l Select the property and choose Insert Keyword from the right-click menu.

l Link to a data source containing the keyword.

l Type to keyword into theExpected Value column (checkpoints only).

For themanual options, make sure to use the required format by enclosing the keyword with hash
(#) signs. Keywords are not case-sensitive.

Input Keywords
The following keywords are supported for input properties:

Keyword Description

#SKIP# Omits this element from the XML of the request. This is useful for elements of SOAP
requests, for which minOccurs = 0

#NIL# Adds a nil=true attribute to the property's XML in the request.

Example: <name John Doe nil="true"></name>

If the XML element is not nillable, this is reported to the log.
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Checkpoint Keywords
The following keywords are supported for checkpoints:

Keyword Description

#EXISTS# Verifies that the element is present in the XML response. In this evaluation, the
actual value is ignored—it only checks for the presence of a value. This is useful for
SOAP response elements, for which minOccurs = 0.

#NOT_
FOUND#

Verifies that the element is not present in the XML response. In this evaluation, the
value is ignored. This is useful for SOAP response elements, for which minOccurs
= 0.

#SKIP# Informs the run engine to ignore this value when evaluating checkpoints.

To check if an element has a nil="true" attribute in its response, select or clear its NIL icon in the
user interface.

Data Assignment in Arrays
When your step has properties that are arrays, you can assign them data as a fixed-size array or
through data relations:

Fixed-Size Array Assignment
In the fixed-sizemethod, you assign each element of a fixed-size array to any column in a data
table. You can assign each array element to a different data table column.

The following example shows three array elements assigned to different columns of a data table.

Data Relation Based Assignment
When you have one or more data relations defined, as described in "Create a new child relation" on
page 94, Service Test assigns data from a single column. You link the first element of the array to a
column in a data source.

In order for Service Test to assign data based on a data relation, the following conditions must be
present:
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l The data source in the link is defined in a data relation.

l The parent data source is attached to the loop containing the step.

l Only the first element of the array is mapped to the child data source. If youmap another array
element to a different column, simple based assignment will be used.

The following example shows a single array element linked to a child data source. In this example,
all elements of the array will take values from the same column, using the data-relation based
assignment.

The link to the first element indicates the column from which the values for all of the array elements
will be taken.

If you create a simple link to data, and the data source is already designated as a child in a data
relation, the behavior will be relation-based.

Data-driven array elements will always be assigned using the data relation based assignment,
using the column assigned to the first element.

Assignment Types
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For relation-based data assignment, the drop down list adjacent to the name of the parent array
node provides the following options for checkpoint validation:

l Fixed. Checks that each of the returned array elements matches the corresponding array
element in the data table in the Data Pane. Each array is marked by an index number, as it
checks the arrays by their index.

l All. Checks that all of the returned array elements match the array element in the Data Pane. In
this mode, arrays are not marked by an index number. For example, if a property in the first array
is marked >= 2 and the same property in another array element is set to <=10, the test run will
check that all returned values are between 2 and 10.

l Contains. Checks that at least one of the returned array elements matches the value of the
property in the Checkpoints pane. In this mode, arrays are not marked by an index number.

l Fixed. Checks that each of the returned array elements matches the corresponding array
element in the data table in the Data Pane. Each array is marked by an index number, as it
checks the arrays by their index.

l All. Checks that all of the returned array elements match the array element in the Data Pane. In
this mode, arrays are not marked by an index number. For example, if a property in the first array
is marked >= 2 and the same property in another array element is set to <=10, the test run will
check that all returned values are between 2 and 10.

l Contains. Checks that at least one of the returned array elements matches the value of the
property in the Checkpoints pane. In this mode, arrays are not marked by an index number.
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Tasks

How to Assign Data to Test Steps
This task describes how to link the test step properties to data sources through the following steps:

l "How to Assign Data to Test Steps" above

l "Select a linking option" below

l "Assign data to array elements - optional" below

Select a linking option
1. In the "Select Link Source Dialog Box" (described on page 630), select a data source option:

n Available steps. Select a step in the left pane, Select a step, and a property in the right
pane, Select a Property.

n Data source column. In the left pane's tree, select a data source. In the right pane, double-
click on a data column or element. For properties that only have arrays, see the next step,
about assigning data to array elements.

n Test variables. Select a user or system variable. For details on defining user variables and
profiles, see "Define user variables" on page 60.

2. To use a combination of multiple data source types for a property value, click Custom
Expression to expand the Select Link Source dialog box. Select the data sources one-by-one
and click Add. If necessary, edit the expressionmanually.

3. If the source to which you want to link is an array element or descendant of an array, a
message prompts you to approve the creating of a loop around the current step. This enables
you to iterate through all of the array elements.

Click on the Loop frame to set the loop settings. For details, see "Loop - Input Properties" on
page 418.

If you do not need to run through the array elements, click No. Service Test links the first array
element to the destination property.

To continue without linking any of the elements, click Cancel.

4. Click OK to complete the linking of the data. Service Test copies the values or expressions
into theValue column of the grid.

Note:

n You can only link properties to data sources if the steps are within a loop, such as Test
Flow or custom loops.

n Linking a leaf node to a complex XML node is only supported for string type data.

For user interface details, see the "Select Link Source Dialog Box" on page 630.

Assign data to array elements - optional
Determine the type of data assignment that is required for the array values:
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l To link each array element to a different column in the data table, use the Link to Source button
to link each element to a different column. For details, see "Fixed-Size Array Assignment"

on page 618.

l If you have data relations defined, or if you performed data driving on the array, then you link the
first element of the array to a data column. All array elements will take values from that column.

Note:

InWeb service calls, if you add an element to anAny type array and rename it, the Link to
Source button is not immediately available.

Workaround: Reselect the step in the canvas and then access the Link to Source button.

How to Set the Navigation Properties
This task describes how to set the navigation preferences for data stored in tables. You can set
different navigation properties for each data source. For details, see "Navigating within the Data "
on page 615.

This task includes the following steps:

l "Open the Data Sources tab" below

l "Select a data source" below

l "Open the Data Navigation dialog box" below

l "Set the navigation properties" below

1. Open the Data Sources tab
In the canvas, click within the loop frame, but not within a test step. In the Properties pane,

open the Data Sources tab (visible only for the current loop).

2. Select a data source
Click Add to select a data source. The "Attach Data Source to Loop Dialog Box " (described
on page 629) opens. Double-click a data source.

3. Open the Data Navigation dialog box
In the Data Sources tab, select the data source with your data. Click Edit to open the "Data
Navigation Dialog Box" (described on page 634).

4. Set the navigation properties
a. In the "Data Navigation Dialog Box" (described on page 634), specify theStart andEnd

rows.

b. Indicate the direction in which tomove when retrieving data from the table, Forward or
Backward, and the number of rows by which to advance for each iteration. Alternatively,
you can indicate tomove to a random row.

c. Specify the action to do when reaching the last row-Wrap around orKeep using that
row. Click OK.

For user interface details, see the "Data Navigation Dialog Box" on page 634.
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How to Data Drive a Test Step
This task describes how to data drive a test step. Data driving is Service Test's mechanism for
automatically creating data expressions for step properties.

For further details, see "Data Driving" on page 614.

This task includes the following steps:

l "Prerequisites" below

l "Open the Input Properties tab" below

l "Include the data " below

l "Data drive the test step" below

l "Enter values" on next page

1. Prerequisites
Create a step in the canvas. For details, see "Create the test flow - optional" on page 383.

2. Open the Input Properties tab

Display the step's properties grid. Select View > Properties and click the
Input/Checkpoints tab.

3. Include the data
To include optional properties in the data driving, toggle the triangle icon adjacent to the
property. A filled-in triangle indicates an included property.

4. Data drive the test step

a. Click theData Drive button. The "Data Driving Dialog Box" (described on page 625)
opens.

b. Choose a Data provider: Excel orXML.

c. Select the properties upon which you want to apply data driving: input properties,
checkpoints, or both.

d. If you specified anExcel provider and data-driving for both sections, specify whether to
place the data for both sections in the same Excel worksheet or different ones.

e. Indicate whether you want toConfigure '<loop name>' as a For Each loop using the
new data source. This option repeats the steps in the loop frame according to the number
of data rows in the Excel or XML data source. If you disable this option, you canmanually
set the number of iterations via the loop properties. This setting overrides the general loop
properties. For details, see "Loop - Input Properties" on page 418.

f. Click OK.

g. Service Test prompts you to confirm the action. Click OK.

Service Test populates the value columnwith data expressions. The expressions are
preceded by informational icons, indicating read-only status or unmatching data types.
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Note: If your properties are within an array, youmust create at least one array element
to allow data driving. To add an array element, select the array's parent node and click
theAdd button . If you do not add at least one element, then the array will not be
data driven.

For user interface details, see the "Data Driving Dialog Box" on next page.

5. Enter values
In the Data pane (View > Data), edit the contents of the newly created data tables or XML
source.
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Reference

Data Driving Dialog Box
Enables you to populate the input property and checkpoint values for a step, with data expressions.

To access 1. Select a step within the canvas.

2. Click in the Properties pane's toolbar.

Relevant tasks "How to Data Drive a Test Step" on page 623

See also "New/Change Excel Data Source Dialog Box" on page 98

The following elements are included:

UI Elements Description

Data Provider The source type of the data: Excel orXML.
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UI Elements Description

Data Driven
Section - for
Input/Checkpoint
properties

The section upon which to apply the data driving. These options are
available when data driving standard input and output checkpoints
properties.

l Input. All input properties listed in the grid.

l Checkpoints. All checkpoints listed in the grid. For array type
properties, youmust create at least one array element in order to data
drive the array.

l Both Input and Checkpoints. All properties.

Note: Activities that do not have output parameters, such as Report
Message andSystem type activities, will only show the Input option.

Data Driven
Section - for
Request/Response

The schema to data drive. These options are available when data driving
XSD schema files for anHTTP, SOAP Request, orREST step.

l Request Body. All input properties associated with the request body.

l Response Body. All output properties associated with the response
body. For array type properties, youmust create at least one array
element in order to enable data driving.

l Both Request Body and Response Body. All entities in both
schemas.

Note: These options are only available after importing a schema into
the Input and/orCheckpoints sections.

Data Driven
Section - for
SOAP Fault
properties

Fault Properties. The SOAP Fault properties to data drive. This option is
available when invoking data driving in the Properties pane's SOAP Fault
view.

Note: These options are only available forWeb Service and SOAP
Request steps.

Data Driven
Section - for
Multipart
properties

Themultipart properties to data drive. These options are available for an
HTTP step with amultipart message.

l Request MultipartInfo. Only Request multipart properties.

l Response MultipartInfo. Only Responsemultipart properties.

l Both Request MultipartInfo and Response MultipartInfo. All
multipart properties.
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UI Elements Description

Use the same data
source for both
sections

Uses the same data source for the Input/Checkpoint properties or
Request/Response body. When selected, Service Test creates a single
Excel worksheet with columns for both the Input andOutput properties.
For example, for the sample application's CreateFlightOrder step,
Service Test creates a single worksheet with columns for the Input
properties: Class, CustomerName, DepartureDate,

FlightNumber, NumberofTickets, and theOutput properties:
OrderNumber, and TotalPrice.

Note: This option is available only when selecting theBoth option,
for an Excel Data Provider type.

Configure 'Test
Flow/Loop' as a
ForEach loop
using the new data
source

Runs the steps in the Test Flow or Loop using a For Each type loop, with
the values from the newly created data source. The number of iterations is
determined by the number of rows in the data source—it performs one
iteration for each row. This setting is applied to the innermost loop
containing the data-driven step.

Note: This option overrides the configuration that youmay have set
for the Test Flow/Loop settings. For details, see "Loop - Input
Properties" on page 418.

Data Link/Relation Message Box
This message box lists the elements that were not found in the new Excel file, when you changed
the data source's existing Excel file.
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To
access

Do the following:

1. Save the test.

2. In the Data Pane, select themain node of an existing Excel data source.

3. In the Properties pane, click Change Excel File.

4. In the "New/Change Excel Data Source Dialog Box""New/Change Excel Data
Source Dialog Box"(described on 98), specify a new Excel file.

5. Click OK to permanently remove all of the listed items and save the test.

Note: This dialog box only opens if the new Excel file has renamed ormissing
worksheets or columns, which affect data links or data relations.

Relevant
tasks

l "Add an Excel data source" on page 90

l "How to Assign Data to Test Steps" on page 621

See also l "New/Change Excel Data Source Dialog Box" on page 98

l "Data Relations and Navigation" on page 615

User interface elements are described below:
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UI Elements Description

More
Details/Less
Details

Expands or Collapses theDetails section to show or hide data links or data
relations that will be removed when you click OK.

Data Links
table

A table of all of the affected data links. The table columns areStep, Property,
and Link.

Data
Relations
table

A table of all of the affected data relations. The table columns arePrimary Data
Source, Child Data Source, Primary Key, and Foreign Key.

Copy details
to clipboard

Copies the details to the clipboard, in a comma separated format.

Attach Data Source to Loop Dialog Box
This dialog box enables you to add a data source to the current loop.

To access 1. Create or open a test or component.

2. Define data sources in the Data pane

3. Open the Properties pane (CTRL+ALT+P).

4. Click within the Test Flow.

5. Open theData Sources tab .

6. Click theAdd button.
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Important Youmust first define data in the Data pane before you generate a list of data
sources.

When you link any step in the loop to the data, it automatically adds a data
source to the loop.

For details, see "How to Assign Data to Test Steps" on page 621.

Relevant
tasks

"How to Set the Navigation Properties" on page 622

See also "Data Navigation Dialog Box" on page 634

User interface elements are described below:

UI Element Description

Select a data source A list of the available data sources.

Select Link Source Dialog Box
This dialog box enables you to select a data source for the step's properties.
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To access Click in theValue column of the
property for which you want to select a
data source.

Important information l To see the icon, move the cursor to
the right of the property value area.

l A step property not contained
within a loop, cannot be linked to a
data source. For example, the For
Loop's Number of Iterations
property, cannot be linked to a data
source, since it is not contained
within the Test Flow loop.

Relevant tasks "How to Assign Data to Test Steps"
on page 621
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See also l "How to Create Data Sources" on
page 90

l "How to Set the Navigation
Properties" on page 622

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Relevant
for

Description

Link from: All types The source for the property value:

l Available steps. A property value from another step.

l Data source column. A value from a data source—Excel,
XML, local table, or database.

l Test variables. A value of an test variable—either user or
system.

Select a step Available
steps

A tree hierarchy of the steps whose properties are available as
data for the current step. This list could include:

l Previous steps.

l An input value of the current step, when selecting data for a
property in theCheckpoints section.

l For loop type steps, previous steps or other steps within loop.

Select a
property

Available
steps

The step's linkable properties. The displayed sections depend on
the step type. For most step types, the Checkpoints section is
displayed.

Select data l Available
steps

l Data
source
column

l For table-based data sources such as Excel, local tables and
database: a list of the columns in the data table.

l For XML data sources: a hierarchy of nodes.

Matching
data types
only

Data source
column

Hides all columns (or schema rows for XML data sources) whose
data types do not match the target property whose value you
want to set.

Attach the
data source
to the loop

Data source
column

A drop down list of the loops in the test containing the step. The
data source is only associated with the selected loop.

Default: Innermost loop containing the step.

<user
variable
grid>

Test
variables

A list of the user-defined test variables and their values in the
current profile.
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UI Elements Relevant
for

Description

<system
variable
grid>

Test
variables

A list of the system environment variables and their values:

l IsLoadTest

l TestDir

l TestName

l LocalHostName

l OS

l OSVersion

l ProductDir

l ProductName

l ProductVer

l UserName

l CurrentDate

l QcUrl

l QcUserName

l QcPassword

l QcDomain

l QcProject

The following variables are available when running the test on a
remote agent:

l CurrentRunID

l CurrentTestSet

l CurrentTestSetID

l CurrentTestInstanceID

Custom
Expression

All types Expands the dialog box to allow you tomanually edit the link and
create a custom expression. This is useful for creating an
expression that uses multiple sources.

Data Retrieval Options for Load Test Enabled Tests
For Load Test Enabled tests, the Select Link Source dialog box provides additional controls for the
Input properties, when choosing theData source column option.

User interface elements are described below:
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UI Elements Description

Use a unique value
for each Virtual User
when load testing

Assigns a unique value to each Virtual User, from the data table, with
the following properties:

l Data source parameter. The parameter to use as a source of
values for the selected input property.

l Update value on. The frequency by which LoadRunner will update
the values: Each Iteration, Each Occurrence (of the parameter),
orOnce.

l When out of values.The action to do when reaching the end of the
data table:

n Abort Vuser. End the test run for the Virtual User.

n Continue Cyclic. Return to the top of the data table and use the
data in a cyclic manner.

n Continue with Last. Use the last value retrieved from the data
table for all subsequent occurrences.

Allocate Virtual User
values in the
Controller

Allocates a specific amount of values from the data table for the Virtual
User:

l Automatically allocate block size. Automatically allocates a
block size from the data based on the number of iterations and
Virtual Users (only for Update value onEach Iteration).

l Allocate <amount> values for each Virtual User. Allocates a
specific number of values for each Virtual User.

Note: Allocation is only possible when choosing Update value on
Each Occurrence orEach Iteration..

Data Navigation Dialog Box
This dialog box enables you to set the data navigation properties for your test loop. You can set the
direction in which to use the data, from where to begin, and the condition for selecting data.
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To access 1. Create or open a test or component.

2. In the Properties pane, link a property to a data source .

3. Click within the step's loop such as Test Flow in the canvas.

4. Open the Properties pane's Data Sources tab .

5. Select a data source in the list attach and click Edit.

Relevant tasks "How to Set the Navigation Properties" on page 622

See also "Navigating within the Data " on page 615

User interface elements are described below:
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UI Elements Description

Start The location from where to begin taking data from the data source.

l Start at. The row of data from which to begin: First row, Last row,
Specific row, Random row, or First row matching.

l Row. The row number from which to begin (only available when selecting
Specific row).

l Condition. The condition the data row must meet in order to start the
looping (only available when selecting the First row matching option):

n Column. One of the data source's columns.

n Comparison operator. =, !=, >, >=, <, <=, Starts, Ends,
Contains, or Regex (depending on the row's data type).

n Value. The value to bematched in order to use this row of data.

Move The direction and amount of rows by which to advance within the data.

l Move by. The number of rows to advance (not relevant forDirection >
To a random row).

l Direction. The direction in which tomove: Forward, Backward, or To a
random row.

End When to stop the looping through the data: First row, Last row, Specific
row, or First row matching.

l Row. The row number in which to end (only available when selecting
Specific row).

l Condition. The condition the data row must meet in order to end the
looping (only available when selecting the First row matching option):

n Column. One of the data source's columns.

n Comparison operator. =, !=,>, >=, <, <=, Starts, Ends,

Contains, or Regex (depending on row's data type).

n Value. The value to bematched in order to use this row of data.

Note: This setting stops the looping only when the loop type is set to
'For Each' (see "Loop - Input Properties" on page 418) and the current
data source whose navigation settings you are editing, is the same data
source that is linked to the loop.

Tip: This setting is only relevant when theMove direction is set to
Forward orBackward. For the To a random row option, each row is
visited once in random order. The navigation ends after all of the rows
were visited.
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UI Elements Description

Upon reaching
the last row -
Action:(Move
Forward)

The action to take when reaching the last row of data.

l Keep using that row. Keep using the last row of data for all subsequent
loops.

l Wrap around. Start again from the first row of data.

Upon reaching
the first row -
Action:(Move
Backward)

The action to take when reaching the first row of data.

l Keep using that row. Keep using the first row of data for all subsequent
loops.

l Wrap around. Start again from the last row of data.

Define New/Edit Data Relation Dialog Box
This dialog box enables you to define or edit a new data relation for a data source. The following is
an example of the Define New Data Relation dialog box:

To access 1. Create or open a test or component.

2. Make sure you have at least one data source in the Data pane.

3. Select a data source in the Data pane.

4. Click in the Properties pane. TheData Source Properties view
opens.

5. Click Add orEdit.

Relevant tasks "Create a new child relation" on page 94

User interface elements are described below:
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UI Elements Description

Parent data
source

The name of the parent data source, selected in the Properties pane (read-
only).

Child data
source

The sheet or table to use for the child data source.

Primary key A column in the parent data source to use as a primary key for the child
relation.

Foreign key The column in the child data source to use as a foreign key for the child
relation.

New Exposed Property Dialog Box

Note: This dialog box is relevant only if you are working with tests created in Service Test
11.51 or earlier.

This dialog box enables you to expose an internal HTTP property andmake it available to other
steps, from the wrapper. This is primarily useful for REST service steps with inner HTTP
Requests.

)
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To access Do one of the following:

From within the Add/Edit REST Service dialog box:

l Define a REST servicemethod.

l In the right pane, click theCustom Input/Checkpoints tab.

l Click within a property row.

l Select Expose as Input Property orExpose as Output Property from the
right-click menu.

From within the canvas:

l Add a RESTmethod to the canvas. Expand it and select its innerHTTP step.

l Open the Properties pane and click within a property row.

l Select Expose as Input Property orExpose as Output Property from the
right-click menu.

Relevant
tasks

"How to Create a RESTMethod" on page 475

See also "Add/Edit REST Service Dialog Box" on page 495

The following elements are included:

UI
Elements

Description

Name A name for the exposed property.

Type A drop down list of simple data types, such as String, Integer, and so forth.
This field is read-only as it is determined by the exposed property's type.

Description A description of the property.
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Troubleshooting and Limitations - Data
This section describes troubleshooting and limitations for working with data.

General
l If a specified data source is or becomes inaccessible, the test will not fail. The Errors pane and

report, however, indicate that there was an error in retrieving the data.

l Keywords such as #SKIP#, and so forth, are not supported in the Input property grid.

Workaround: Link to a data source that contains the keyword.

l When adding a referenced Excel data source, if the file requires special credentials (for example,
a location on another domain or a drive requiring authentication), youmust verify that the
operating system will allow access to the file.

l Data sources with parent-child relationships, should not be accessed together in the same loop,
unless the child data source is used for data-driving array elements. Accessing parent-child data
sources in the same loop, may corrupt the test.

l Linking to file names is not supported forHTTP Request andHTTP Receiver activities that use
the File typemessage body.

l For data sources with child relations: If you change the name the Key column in the child sheet,
the Define New/Edit Data Relation dialog box does not reflect the new column name in the drop
down lists.

Data Driving
l Data driving for JSON requests or responses, is only supported for Excel.

l Data driving for an Excel data source is only effective for the first 254 properties of a step. If a
step has more than 254 properties, they will not be data-driven.

l Data driving for an Excel data source is only supported for property values consisting of 255
characters or less. If a property value has more than 255 characters, the data drivingmechanism
offers to truncate the string.

l When data driving a test step that has an array with two or more nested levels, the data driving
engine only copies the first element of each array to the Excel data tables.

l Data driving for JSON requests or responses, is only supported for Excel.

l Data driving for an Excel data source is only effective for the first 254 properties of a step. If a
step has more than 254 properties, they will not be data-driven.

l Data driving for an Excel data source is only supported for property values consisting of 255
characters or less. If a property value has more than 255 characters, the data drivingmechanism
offers to truncate the string.

l When data driving a test step that has an array with two or more nested levels, the data driving
engine only copies the first element of each array to the Excel data tables.
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Concepts

Writing Code for Events Overview
Service Test lets you write customized code for your test in two ways:

l Event Handlers for all activities

l Custom Code activity

For each activity, you can define event handlers for common events, such as:
CodeCheckPointEvent, BeforeExecuteStepEvent, andAfterExecuteStepEvent. Certain
activity types such as Web Services and HTTP have additional built-in events. For a list of the
events, see the "Events Tab (Properties Pane)" on page 193.

TheCustom Code activity enables you to define the behavior of your own activity and its
properties. You define this behavior through an event handler that is triggered before, during, or after
the execution of the activity.

Service Test's Editor enables you to use autocompletion to prepare the event handler. For task
details, see "How to Open aWindow forWriting Custom Code" on page 644.

Tip: To instruct Service Test to ignore an event handler, select the handler and press DELETE
to remove the name of the handler from the grid. To remove the handler, youmust delete the
codemanually in the TestUserCode.cs tab.

For more details about the Editor, including how to navigate files from the Editor, see "Testing
Documents Overview" on page 55.

This section also includes:

Casting 642

Casting

The Event Handler code in the TestUserCode.cs file uses the following objects:

l sender. The object that raises the activity's event.

l args. The event arguments passed to the activity.

You can set an activity's properties in the following way:

CodeActivity4.Input.a="My string";

To access an activity's property, use the this object. The following example retrieves an output
property from an earlierCodeActivity step:

CodeActivity4.Output.secondOutput = " Previous Code Activity Output
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: " +

this.CodeActivity2.Output.FirstOutputParameter

Note:WebService calls store their property information in separate XML documents.
Therefore, when working withWeb Service calls, you cannot access the input or output
properties directly using IntelliSense. Instead, you need to parse the XML using an XPath
expression.

To retrieve a property's XPath expression, select it in the Properties pane and select Copy
XPath from its shortcut menu. The InputEnvelope object contains all of the input properties
of theWeb service call. The OutputEnvelope object contains all of theWeb service's output
properties.
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Tasks

How to Open a Window for Writing Custom Code
For non-custom code activities, you can define default event handlers for checkpoints, before step
execution, and after step execution.

The checkpoint event handlers help you verify the output values in your test. You can use a Report,
Assert, or Log function to gather information about your service.

This task includes the following steps:

l "Open the Events tab" below

l "Select an event" below

l "Edit the code" on next page

l "Enable access to the activity's properties" on next page

l "Save the changes" on next page

1. Open the Events tab

Select an activity title in the canvas and open theEvents tab in the Properties pane.

Note: The Events tab can also be opened by double-clicking on a Custom Code activity in
the canvas.

2. Select an event
Select the event for which you want to provide code. Double-click in theHandler column. A
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TestUserCode.cs tab opens.

3. Edit the code
Select the TestUserCode.cs tab. Locate the Todo section and add your custom code. You
can use autocompletion to assist you in writing the code.

Note: Changes youmake in the user event code using the auto-completion drop down are
not reflected in the canvas until you save the document.

4. Enable access to the activity's properties
Use the this object to access the activity's context, including input and output properties. For
example:

this.StServiceCallActivity4.InputEnvelope

5. Save the changes
Click File > Save All to save the custom code and the test.

How to Access Input and Output Properties
You can set the values of input and output properties through event handlers.

This task includes the following steps:
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l "Select a property" below

l "Access the activity's parent" below

1. Select a property
Use autocompletion to locate and select a property from the drop-down list. The drop-down
shows all the activity-specific properties. For example, for theConcatenateString activity, the
drop-down includes Prefix andSuffix.

2. Access the activity's parent
To access the activity's parent, select theParent property from the drop-down list. A parent
refers to the step or condition that encloses the activity. For example, for a step in a conditional
branch, the parent is the name of the condition step.

string ParentName = this.ConcatenateStringsActivity5.Parent.Name
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To obtain the parent of an activity's loop, use a this object.

this.ConcatenateStringsActivity5.GetParentLoop();

How to Set Input and Output Properties
You can set the values of input and output properties using event handlers.

This task includes the following steps:

l "Access the activity's properties" below

l "Select a property" below

l "Set the activity's property values - optional" below

l "Access the activity's parent - optional" below

1. Access the activity's properties
Access the activity's properties using the this object. For example:

this.ConcatenateStringsActivity4

2. Select a property
Use autocompletion to locate and select a property from the drop-down list. The drop-down
shows all the activity-specific properties. For example, for aConcatenateStrings activity, the
drop-down shows Prefix andSuffix.

3. Set the activity's property values - optional
Set the property values using hard-coded values or variables that you defined earlier. For
example:

this.ConcatenateStringsActivity5.Prefix = "hello";

this.ConcatenateStringsActivity5.Suffix = "world";

4. Access the activity's parent - optional
A parent property refers to the step or condition that encloses an activity. To access an
activity's parent property, use theParent property. For example, for a step in a conditional
branch, the parent is the name of the condition step. To obtain the activity's parent loop, use
GetParentLoop.

string ParentName =

this.ConcatenateStringsActivity5.Parent.Name;

this.ConcatenateStringsActivity5.GetParentLoop();
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How to Manipulate Data During Run Time
You canmanipulate data during run time using the GetDataSourcemethod. For a list of the data
sourcemethods, use autocomplete or see "Data SourceMethods" on page 657.

This task includes the following steps:

l "Prerequisite" below

l "Get the data source name" below

l "Retrieve a value from a data source" below

l "Set a property value" below

l "Import a file" on next page

l "Export a file" on next page

Prerequisite
Add at least one data source to your test through the Data pane. Save the test. Create a default
event handler for the event you want to invoke for the test.

Get the data source name
TheGetDataSource function requires the data source name as it appears in the Data pane. Select
a node in the Data pane's left pane. Use the right-click commandCopy name to copy the name of
a data source node to the clipboard.

Retrieve a value from a data source
The following example illustrates theGetValuemethod retrieving a value from the first row of the
data source and converting it to a string:

/ this.GetFlights4.FlightNumber =

GetDataSource("GetFlights4_Input!MainDetails").GetValue(0, "Flight_

Number").ToString();

To retrieve the row corresponding to the current iteration, indicate the current iteration in place of the
row number. Note that theGetValue function is zero-based—it begins with row 0, while
CurrentIterationNumber is one-based. For example:

/ this.GetFlights4.FlightNumber =

GetDataSource("GetFlights4_Input!MainDetails").

GetValue(this.Loop4.CurrentIterationNumber, "Flight_

Number").ToString();

Set a property value
The following example illustrates theSetValuemethod setting the value for the Flight_Number
and Tickets ordered values.

GetDataSource("CreateFlightOrder4_Input!MainDetails").SetValue(0,
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"Flight_Number", "Y22");

GetDataSource("CreateFlightOrder4_Input!MainDetails").SetValue(0,

"Tickets_Ordered", "2");

Import a file
The following example illustrates the Import and ImportFromExcelFilemethods:

ExcelFileImportInputArgs a = new ExcelFileImportInputArgs

(@"C:\DemoExcel.xls", "MainDetails", true);

GetDataSource("CreateFlightOrder4_Input!MainDetails").Import(a);

GetDataSource("CreateFlightOrder4_

Input!MainDetails").ImportFromExcelFile(@"C:\DemoExcel.xls",

"MainDetails", true);

Export a file
The following example illustrates theExport andExportToExcelFilemethods:

ExcelFileExportInputArgs a = new ExcelFileExportInputArgs

(@"C:\ExportedExcel.xls");

GetDataSource("CreateFlightOrder4_Input!MainDetails").Export(a);

GetDataSource("CreateFlightOrder4_

Input!MainDetails").ExportToExcelFile(@"C:\ExportedExcel.xls");

How to Use the Logging Function
TheUserLogger function generates messages during replay. You can view thesemessages in the
Output tab or in the log file.

This task includes the following steps:

l "Select the UserLogger object" below

l "Choose a log type" below

l "Complete the function" on next page

l "View theOutput Log " on next page

1. Select the UserLogger object
Use autocompletion from the activity's Context object, and select theUserLogger object.

this.StServiceCallActivity4.Context.UserLogger

2. Choose a log type
Use autocomplete to select a log type.
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For a list of the log types, see "Logging Options" on page 658.

3. Complete the function
Provide to necessary arguments to complete the function as indicated by the tooltip.

The following example logs unformatted Debug information to the log from a variable called
debug_information.

this.StServiceCallActivity4.Context.UserLogger.Debug(debug_

information);

4. View the Output Log
View the debug information in the Output tab or in the log file.

To view the output tab:

a. Run the test at least once (F5).

b. Select View > Output to open theOutput pane.

To view the output log file:

a. Run the test at least once (F5).

b. Select Open Containing Folder in Explorer from the test tab's right-click menu and
open the Log folder.

c. Open the vtd_user.log file.

How to Use the Report Function
Use the Report function to show the results of a test's execution in the Run Results Viewer. The
report opens automatically after you run the test. You can also view it at any time by opening the
Run Results Viewer from the Start menu.

Note: For details on accessing Service Test tools and files inWindows 8, see "Accessing
Service Test inWindows 8Operating Systems" on page 33.

This task includes the following steps:
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l "Select the Report object" below

l "Complete the function" below

l "View the run results" below

1. Select the Report object
Select theReport function using autocompletion.

this.ConcatenateStringsActivity5.Report

2. Complete the function
Provide a keyword and value, based on the function's prototype: Report(string keyword,
string value);

The following example sends an employee's last name to the report. You can also use a
variable that was defined earlier in the code.

this.ConcatenateStringsActivity5.Report("Employee Name",

"Jones");

3. View the run results
Run the test and check the results in the Run Results Viewer. The report displays the keyword
and its value in the Iterations node.

How to Write Checkpoint Events
Youwrite checkpoint event handlers using the checkpoint object. The Assert library functions
run a comparison between actual and expected values, and show the results in the step's
Checkpoint node. You can also use the checkpoint object to control checkpoints in the user
interface and customize your reports.

This task includes the following steps:

l "Create a checkpoint handler" below

l "Select the Checkpoint object" below

l "Validate a checkpoint - optional" on next page

l "Ignore selected checkpoints - optional" on next page

l "Customize the checkpoints reporting - optional" on page 653

l "View the results" on page 653

1. Create a checkpoint handler
Double-click theHandler column of the CodeCheckPointEvent row in the activity's Events
tab.

2. Select the Checkpoint object
Use the args object, and select theCheckpoint object using autocomplete.
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args.Checkpoint

3. Validate a checkpoint - optional
To validate a value during run-time, follow these steps:

a. Use the args.Checkpoint object, and select Assert using autocomplete.

b. Use autocomplete to select a comparison operator such as Equals, and so forth. For
details, see "Assert Options" on page 658.

c. Complete the function as indicated by its tooltip. Provide the necessary arguments. For
example, to check that the expected and actual values match, use the following
expression:

args.Checkpoint.Assert.Equals(<Expected Value>, <Actual

Value>)

The following example checks if the actual value (second argument) equals the expected
value (first argument) for theConcatenateString activity. Note that you access the
property values using the this.<activity_instance>.<property> object.

args.Checkpoint.Assert.Equals

(this.ConcatenateStringsActivity4.Prefix+this.

ConcatenateStringsActivity4.Suffix,

this.ConcatenateStringsActivity4.Result);

The second example checks if the text value (alphabetical order for a string) of the prefix is
less than the suffix. To ensure that the checkpoint succeeds, enter a prefix value that is
greater than the suffix, for example a prefix of aa and a suffix of bb.

args.Checkpoint.Assert.Less("Concatenate test", this.

ConcatenateStringsActivity4.Prefix,

this.ConcatenateStringsActivity4.Suffix,

       "The prefix is less than the suffix");

4. Ignore selected checkpoints - optional
You can instruct Service Test to ignore the checkpoints selected in the Properties pane's
Input/Checkpoints tab. This is useful if you need to ignore the checkpoints temporarily.

a. Use the args.Checkpoint object, and select theRunUICheckpoints object using
autocomplete.

b. Set the value to false. You can enable the checkpoints for this step at any time by
removing this line or by setting it to true.

args.Checkpoint.RunUICheckpoints = false;
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5. Customize the checkpoints reporting - optional
You can instruct Service Test to send a specific message to the Checkpoints node in the
report. The standard Report function sends amessage to the step's node, but the Checkpoint's
Report function enables you to sendmessages to the Checkpoint sub-node.

a. Use the args.Checkpoint object, and select theReport object using autocomplete.

b. Complete the function syntax, based on the function's tooltip, providing the actual and
expected result and a logical operator.

6. View the results
Run the test and view the Run Results Viewer. Drill down to the checkpoints and check your
results.

How to Retrieve and Set Test Variables
TheContext object's TestProfilemethod enables you to set or get the value of a user test
variable from the active Test Profile.

This task includes the following steps:

l "Select the TestProfile object" below

l "Get or Set a variable" below

1. Select the TestProfile object
Use the activity's Context object, and select TestProfile from the autocomplete menu.

2. Get or Set a variable
From the autocomplete menu, select GetVariableValue orSetVariableValuemethods.

The following example retrieves the value of the TestName test variable.

string testName =

this.StServiceCallActivity4.Context.TestProfile.GetVariableValue

("TestName");

How to Encrypt and Decrypt Passwords
Password fields expect an encrypted string—if you provide an unencrypted string, the
authentication will fail.

TheEncryptionMngrmethod lets you encrypt and decrypt strings within your events.

This task includes the following steps:

l "Encrypt the password" below

l "Decrypt the password - optional" on next page

1. Encrypt the password
Use the activity's context's EncryptionMngrmethod, and select Encrypt from the
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autocompletion drop-down. The following example encrypts a password.

string plainText = "myPassword";

string encryptedText =

this.StServiceCallActivity4.Context.EncryptionMngr.Encrypt

(plainText);

2. Decrypt the password - optional
Use theDecryptmethod from the autocompletion drop-down.

The following example decrypts a password and validates it against the original string.

string decryptedText =

this.StServiceCallActivity4.Context.EncryptionMngr.Decrypt

(encryptedText);

bool equalText = decryptedText.Equals(plainText);

How to Use the OnReceiveResponse Web Service Event
Service Test provides several custom event handlers forWeb Services. The following example
shows how to send the inner SOAP envelope as a string to the execution report, when a response
is received.

Note: Tomanipulate the Output Envelope (activity.OutputEnvelope property), use the
AfterExecuteStepEvent—the activity.OutputEnvelope property is not available for the
OnReceiveResponse event.

For a complete list of theWeb Service events, open the Properties pane's Events tab for aWeb
Service's step.

This task includes the following steps:

l "Create an event handler" below

l "Add the Using text" below

l "Define an XmlDocument and load the XML" on next page

l "Create a new message" on next page

1. Create an event handler
Select aWeb Service step and provide values for its properties. Open the Properties pane's
Events tab and double-click theHandler column in theOnReceiveResponse row. A code
editor containing the new event handler opens.

2. Add the Using text
In the namespace section, make sure that System.Text appears in the list of using
statements.
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namespace Script

{

using System;

using System.Xml;

using System.Text;

using System.Xml.Schema;

using HP.ST.Ext.BasicActivities;

...

3. Define an XmlDocument and load the XML
In the Todo section of theStServiceCallActivity1_OnOnReceiveResponse function, add
variable definitions for themessage argument and envelope. Use autocompletion to select the
XmlDocumentmethod. Define a name for the envelope and assign it the value of the XML
envelope.

var tmp = args.Message;

var envelope = Encoding.UTF8.GetString(tmp);

XmlDocument tmpXdoc = new XmlDocument();

tmpXdoc.LoadXml(envelope);

4. Create a newmessage
Save theOuterXml content to a string, and apply UTF-8 encoding.

var newStrMessage = tmpXdoc.OuterXml;

args.Message = Encoding.UTF8.GetBytes(newStrMessage);

How to Set HTTP Headers for Web and REST Services
The following section describes how to set HTTP headers forWeb service and REST service
steps.

HTTP Headers for Web Service Calls
To dynamically add an HTTP header to aWeb service call:

1. Open the Events tab in the Properties pane and implement the
OnBeforeApplyProtocolSettings event.

2. Implement themethod as follows:

this.StServiceCallActivity4.HttpRequestHeaders.Add("<key>",

"<value>");

HTTP Headers for REST Service Calls
To dynamically add an HTTP header to a REST service or to a REST sevice's inner HTTP Request
step (when working with tests created in Service Test 11.51 or earlier):

HP Service Test (11.52)Page 655 of 705

User Guide
Chapter 31: Coding Service Test Events



1. Open theEvents tab in the Properties pane and implement theOnBeforeExecuteStepEvent
event.

2. First allocate the array the desired length. The following example allocated two headers.

(args.Activity as HTTPActivity).RequestHeaders =

new HP.ST.Shared.Utilities.Pair<string, string>[2];

3. Instantiate each array element with the <HeaderName> and <HeaderValue>. For example:

(args.Activity as HTTPActivity).RequestHeaders[0] = new

HP.ST.Shared.Utilities.Pair<string, string>("HeaderName1",

"Value1");

(args.Activity as HTTPActivity).RequestHeaders[1] = new

HP.ST.Shared.Utilities.Pair<string, string>("HeaderName2",

"Value2");

Note: You can also set the HTTP headers values by expanding the RequestHeader node in
the Properties pane's Input/Checkpoints tab. You then link to a data source from theName and
Value rows. For details, see "Select Link Source Dialog Box" on page 630.

If youmodify the headers using code in an event handler, it will override the values in the
Properties pane during the test run.
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Reference

Data Source Methods
This section describes theGetDataSourcemethod and the data sourcemethods that allow you to
manipulate data in existing data sources during run time. Thesemethods will not change the data
displayed in the Data pane.

TheGetDataSourcemethod's only argument is the name of a data source node. The following list
shows the common data sourcemethods:

Method Arguments Relevant for Data Source
Type

SetValue row number, column name All except XML

GetValue row number, column name, value All

Import import argument (casted in a previous
statement)

Excel

ImportFromExcelFile path of Excel file, sheet name, is first row
a header

Excel

Export export argument (casted in a previous
statement)

Excel

ExportToExcelFile path of an Excel file Excel

RowsCount none All

All of themethods and their syntax are available in the event handler window, using autocomplete.

For task details and examples, see "How toManipulate Data During Run Time" on page 648.

Note: TheQuery function implemented in versions 11.20 and earlier is not supported in version
11.50. Tomodify runtime data through an event handler, replace all occurrences of theQuery
function withGetDataSource, using the arguments described above.

Context Methods
This section describes some of the commonContextmethods.

UI Elements (A-Z) Description

Denotes a function.

Denotes a string.
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UI Elements (A-Z) Description

Denotes an event.

EncryptionMngr Enables you to encrypt and decrypt password strings.

TestInputParameters Enables you to retrieve the test's input parameters.

TestIteration Provides information about the test iteration.

TestOutputParameters Enables you to retrieve the test's output parameters.

TestProfile Enables you to set and retrieve user variables. For details on how to
define user variables, see "How to Define Test Properties or
User/System Variables" on page 59.

For a complete list of the functions, use autocomplete.

Logging Options
The Service Test API provides the following logging options, available from the
Context.UserLogger object:

UI Elements (A-Z) Description

Debug, DebugFormat Logs debug information collected during the test run.

Error, ErrorFormat Logs errors that occurred during the test run.

Fatal, FatalFormat Logs fatal errors that occurred during the test run.

Info, InfoFormat Logs informational data from the test run.

Warn, WarnFormat Logs warnings that were issued during the test run.

The Format option enables you to provide values based on the list of items. The following example
logs formatted informational messages, using the FirstName variable's value for the first item, and
the LastName variable for the second item, and so forth.

this.<activity>.Context.UserLogger.InfoFormat("Hello: {0}{1}",

FirstName, LastName);

For task details, see "How to Use the Logging Function " on page 649.

Assert Options
The Assert object provides the following comparison operators:

UI Elements (A-Z)

Equals
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UI Elements (A-Z)

Greater

GreaterOrEqual

Less

LessOrEqual

NotEquals

For task details, see "How toWrite Checkpoint Events" on page 651.
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Troubleshooting and Limitations - Event Coding
This section describes troubleshooting and limitations for working with Service Test events.

l The Loop.CurrentIterationObject is deprecated and will always return null.

l When calling a test or action, you cannot access the data associated with the called test or
action using runtime API coding, even if overriding the data was enabled (through theAllow
other tools to override the data option).

l Whenworking on non-English operating systems, youmust install a localized version of .NET
framework to obtain localized compilation errors.

l By default, onmachines running 64-bit Windows, the ActiveX object, HP.ST.Test, is only
registered in 32-bit mode—not 64-bit.
Workaround: Register the assembly manually using the following command line code:

cd "<Service Test installation folder>\bin" %windir%\

Microsoft.NET\Framework64\v4.0.30319\

RegAsm.exe HP.ST.Fwk.SOAReplayAPI.dll /codebase
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Chapter 32: Extensibility in Service Test
The HP Service Test installation includes the capabilities to create custom activities for the
Toolbox pane. After defining a custom activity, you can drag it onto the canvas as you would with
any other built-in activity.

This chapter includes:

Concepts 662

Creating New Activities - Overview 662

Custom Activity Files 662

Tasks 673

How to Use theWizard to Create a Custom Activity - C# 673

How to Use theWizard to Create an Activity -Java 674

How toManually Create a Custom Activity in C# 676

How to Create a Runtime File 679

Reference 684

Activity Wizard 684

Troubleshooting and Limitations - Extensibility 695

HP Service Test (11.52)Page 661 of 705



Concepts

Creating New Activities - Overview
Service Test enables you to create custom activities to extend the capabilities of the product.

Once you create a new activity through this mechanism, it will be available in the Toolbox pane for
all future tests.

For most custom activities, you can use the Activity Wizard. For C# users, the wizard creates a
Visual Studio project into which you can add your ownC# code. Java users can edit .java files
which will be compiled into .class files. You then deploy the new activity into Service Test. For
details, see "Activity Wizard" on page 684 and "How to Use theWizard to Create a Custom
Activity - C#" on page 673.

Advanced users can build custom activities manually, without the wizard. For details, see "How to
Manually Create a Custom Activity in C#" on page 676.

Custom Activity Files
This section describes the structure and content of the files required tomanually define a new
activity in Service Test. The following information is not relevant if you are using the Activity
wizard.

To create a custom activity, you need to define the following files on all machines upon which you
intend to run the test.

l "Runtime Files "

l "Signature Files "

l "Addin Files "

TheRuntime file is the DLL that Service Test invokes to run the activity. For details, see "Runtime
Files " on next page.

TheSignature file is an XML file that defines the input and output properties, events, and the
runtime class that executes the activity. For details, see "Signature Files " on next page.

TheAddin file is an XML file that references all of the activity component data. For details, see
"Addin Files " on page 670.

In addition, you can also define resource files to store text strings used by your activity. For details,
see "Resource Files " on page 672.

The product's installation includes a sample project in the ExtensibilitySamples folder. Use
this sample as a basis for a new activity.

All of the custom files—Signature, Addin, and Runtime—should be stored in the
<Installation_folder>\addins\CustomerAddins\<addin_name> folder. This enables
Service Test to load them during startup.

For more details, see "How toManually Create a Custom Activity in C#" on page 676.
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Note: This is a preliminary version of the SDK (Software Development Kit). It enables you to
extend the capabilities of the product. However, this SDK is subject to change in a future
release, and these changes might require you to update any code that uses this preliminary
version. Although HP endeavors to keep these changes to aminimum, we cannot guarantee
that extensions created using the preliminary version of the SDK will continue to work without
modification when upgrading to a new version of HP Service Test.

Runtime Files

In addition to the signature and addin files, youmust provide a DLL to run when executing the
activity. You create a solution and customize the code as required. You can use the sample
ReportMessageActivitySample.sln located in the product's ExtensibilitySamples
folder as a basis for your project.

UseMicrosoft's IntelliSense to determine themethod's arguments and syntax.

Here are some guidelines that youmust follow:

l As shown in the sample, youmust usemethods that are included in theSTActivityBase class.

public class ReportMessageActivitySample : STActivityBase

l STExecutionResult is the return value of theExecuteStepmethod. It receives one or two
parameters: STExecutionStatus Status and optionally, string msg. STExecutionStatus is an
enum type that can be set to the following values: ActivityFailure, ActivityStopTest,
ApplicationUnderTestFailure, Equals, ReferenceEquals, Success,
TestStopped. In the following example it receives theSuccess value.

return new STExecutionResult(STExecutionStatus.Success);

l Place your executable code within theExecuteStep function.

protected override STExecutionResult ExecuteStep()

{ ...

Note: Youmust compile the DLL with a Target Framework of Framework 4.0, available in
Microsoft Visual Studio 10.

For task details and an example, see "How to Create a Runtime File" on page 679.

Signature Files

The signature file describes the activity to Service Test. It typically has aResource element
followed by the following sections: GeneralProperties, InputProperties, OutputProperties,
Tabs, andEvents. The signature file must have an .xml extension.
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Resource Element

TheResource element has the following attributes:

Attribute Description

type The type of entity, in this caseActivity.

id A unique string that identifies the activity. You can reference this ID when
writing event handler code. For details, see the section on API coding.

version The version of the current addinmechanism. For example, 1.0.0

group The parent group under which the activity will appear in the Toolbox pane, for
exampleString Manipulation. To add it to an existing group, specify a group
name as it appears in the Toolbox pane. If the group does not exist, it adds a
new group.

shortname The short name of the activity as shown in the Toolbox pane's hint area
(above the description).

description The description of the activity as shown in the Toolbox pane's hint area.

assembly The DLL file to call when running the activity, stored in the same folder as the
signature and addin files.

className The class implemented by the activity.

Note: The class must inherit from the STActivityBase class.

image An image file for the icon representing the activity. Store the image in the
same folder as the signature file.

visible A boolean value indicating whether to display the activity is displayed in the
Toolbox pane.

xmlns The namespace that defines the schema for the signature file,
http://hp.vtd.schemas/signature/v1.0. Keep the default value.

xmlns:xsi The schema instance used for the signature file. Keep the default value,
http://www.w3.org/2001/XMLSchema-instance.

xmlns:Location The URL of the signature file's schema, Signature.xsd, referenced by the
namespace. This value has two parts: the namespace and the file path.

l Namespace. http://hp.vtd.schemas/signature/v1.0

l File path. <Installation_
Folder>/dat/schemas/Signature.xsd

Keep the default value.
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The following example shows theResource section from the signature file of the sample activity,
ReportMessageActivitySample. The location of the sample is: <Installation_
Folder>\ExtensibilitySamples\ReportMessageActivitySample

<Resource

type="Activity"

id="ReportMessageActivitySample"

version="1.0.0"

group="Miscellaneous"

shortName="ReportMessageActivitySample"

description="The ReportMessageActivitySample allows you to send a

custom message to the report and/or log. "

assembly="ReportMessageActivitySample.dll"

className="ReportMessageActivitySample.ReportMessageActivitySample"

image="toolbox_ReportMessageActivitySample.png"

visible="true"

xmlns="http://hp.st.schemas/signature/v1.0"

xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

xsi:schemaLocation="http://hp.st.schemas/signature/v1.0

../../../dat/schemas/Signature.xsd"

>

Section Element

The Section definitions apply to all sections in the Signature file, such as GeneralProperties,
InputProperties, andOutputProperties. The following table describes the primary Section
element attributes.

Attribute Description

name The internal name of the section.

To use a sub-element, it is recommended that you set the value to the
name of the sub-element. For example name="Tab" or
name="Alerts".

source If set to true, it displays the source of the section.

dest destination. If set to true, it displays the destination path of the section.

checkpoint If set to true, displays the checkpoint check box in theValidate column.

isSharedMetadata When true, enables the section to share its meta data with other sections.

propertiesType The type of the properties in the section, for example, "XML".

showXmlControls When true, displays the XML controls such as Text and XPath tabs in the
section.

displayName The name of the section as it will appear in the Properties pane.

The following table describes the sub-elements of Section:
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Ele-
me-
nt

Description

Ta-
b

The tabs to appear in the Properties pane using the following attributes. For details, see
below.

l name. The internal name of the tab. Some of the built-in ones are General,
InputOutput, Events, Attachments, and SOAPFault.

l id. The id of the tab referred to be the API. The id usually uses the namewith an added
suffix, "Tab". For example, GeneralTab, InputOutputTab, and EventsTab.

l CanBeInToolbox. If true, shows the tab on the Toolbox pane's toolbar.

l CanBeInPropertySheet. If true, shows the tab in the Properties pane.

l CanBeInDataLinkDialog. If true, shows the tab in the "Select Link Source Dialog
Box" (described on page 630).

Note: To use the default tabs: General, Input/Checkpoints, andEvents, you do not
need to include this element. If you want to omit one of the tabs or add extra ones, then
you need to include the Tabs sub-element and specify the desired tabs.

For details about the tabs, see "Properties Pane" on page 184.

Al-
ert

Enables you to apply alerts to the properties in the section using the following attributes:

l constraint. The reason to show the alert, for example, NullValueConstraint.

l target. The Xpath of the property to which to apply the constraint.

l section. The internal name of the section containing the properties.

l type. The type of alert, such as error or warning

The value of the element, is the alert message. For example:

<Section name="Alerts" isSharedMetaData="true">

<Alert constraint="NullValueConstraint" target="/Url[1]"

section="InputProperties" type="error">The 'URL' must not be

empty

</Alert>

</Section>
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Ele-
me-
nt

Description

Ev-
ent-
s

In theEvents sub-element, you can customize the events that will be available for the
activity. This sub-element uses the following attributes

l name. The internal name of the event. Use one of the built-in names or define a custom
one.

n CodeCheckpointEvent. Enables you to create an event handler to run when the test
is verifying checkpoints.

n BeforeExecuteStepEvent. Enables you to create an event handler to run before
executing the activity.

n AfterExecuteStepEvent. Enables you to create an event to run after executing the
activity.

n <custom event>. A custom event that you define.

l description. A textual description of the event.

l eventArgs. The source of the arguments for the event. The standard argument for
BeforeExecuteStepEvent andAfterExecuteStepEvent event is
STActivityBaseEventArgs. The built-in value for theCodeCheckpointEvent is
CheckpointEventArgs.

Web Service steps provide additional built-in events. For details, see "UpdatingWeb
Services" on page 521.

Note: To access the default events: CodeCheckpoint, BeforeExecute, and
AfterExecute, you need to include only theEvents tab in the Tab sub-element, but
you do not need to use theEvents sub-element. If you want to omit one of the events
or add custom events, then you need to include this sub-element and specify the
desired events.

Property Definitions

The property definitions in the signature file, apply to all sections that use properties. The built-in
sections that use properties are:

l GeneralProperties. Defines the properties in theGeneral view of the Properties pane, for
exampleStep ID andName.

l InputProperties. Defines the input properties located in the Input pane of the of the Properties
pane's Input/Checkpoints tab.

l OutputProperties. Defines the output properties located in theCheckpoints pane of the of the
Properties pane's Input/Checkpoints tab.

This section includes:

HP Service Test (11.52)Page 667 of 705

User Guide
Chapter 32: Extensibility in Service Test



l "Elements and Sub-Elements" below

l "Element Attributes" on next page

l "Simple Elements with Enumeration" on next page

l "Complex Array Elements" on next page

Elements and Sub-Elements
The elements and attributes are defined in the standard XML schema file,
http://www.w3.org/2001/XMLSchema, or the built-in types.xsd schema, located in the
<Installation_Folder>/dat/schema folder. The following table describes the elements
and sub-elements that can be used in these sections. The level number indicates the level of the
element or sub-element in the hierarchy.

Element Description

xs:schema The schema namespaces for the properties, as described by the xml:ns
attribute.

Keep the default values, http://hp.vtd.schemas/types/v1.0 and
http://www.w3.org/2001/XMLSchema.

xs:import The namespace to import using the namespace and schemaLocation
attributes.

Keep the default values, http://hp.vtd.schemas/types/v1.0 and
../../../dat/schemas/types.xsd.

xs:element The element to define, using the attributes described in the table below.

xs:simpleType A tag indicating the beginning of definitions of a simple type property.

Note: You only need to enclose a simple type element with this tag, if
you want to do enumeration with a drop-down list. For example, the
following definition does not require an xs:simpleType tag.

<xs:element name="ClientCertificate"

type="types:Certificate" types:displayName="Client

certificate" />

xs:complexType A tag indicating the beginning of definitions for a node of multiple properties.

xs:sequence A tag indicating the beginning of a list of properties in a complex type
property.

xs:restriction A tag restricting the value of the enumeration values of a property, using the
base attribute. To restrict String type values, use base="xs:string".

xs:enumeration A tag indicating the beginning of list of values in the drop-down list for a
property, using the value attribute.

xs:annotation An annotation for the element Use an xs:documentation sub-element to
compose text that will appear below the properties grid in the Properties
pane.
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Element Attributes
The following table describes the primary attributes of the xs:element. For attributes in the standard
XML schema, use an xs: prefix in the value, for example standard types use type=xs:string or
type=xs:int.

For types defined in the Types.xsd schema, use a types: prefix in the attribute name. For example
types:displayName.

Attribute Description

name The internal name of the property or grid in the Properties pane. This is the
name referenced by other calls and by the event handlers code. This is
not the name displayed in the Properties pane's Name column.

type The type of property. Some common values are:

xs:string, xs:int, xs:boolean, Multipart, Header, Part. For
a value defined in the Types schema, use the types: prefix. For example
type="types:filePath".

minOccurs Theminimum number of array elements for which the user must provide.
For none, specify "0".

maxOccurs Themaximum number of array elements the user may provide. To allow
an unlimited amount, specify "unbounded"

types:visible When true, enables the parameter to be visible even before being
expanded by the Add Array Element command.

types:argType The type of the property: "XML" or "Object".

types:displayName The property name as it will appear in the Properties pane.

Simple Elements with Enumeration
The followingReportMessageActivitySample example defines an input parameter, Status, with
an enumeration attribute. This code creates a drop-down list of values in the Properties pane's input
property grid.

<xs:element name="Status" default="Done"

types:displayName="Status">

<xs:simpleType>

<xs:restriction base="xs:string">

<xs:enumeration value="Done"/>

<xs:enumeration value="Pass"/>

<xs:enumeration value="Fail"/>

</xs:restriction>

</xs:simpleType>

</xs:element>

Complex Array Elements
The following sample defines a complex property, with a Key and Value pair of values.

HP Service Test (11.52)Page 669 of 705

User Guide
Chapter 32: Extensibility in Service Test



<xs:complexType name="NameValueType">

<xs:sequence>

<xs:element name="Key" type="xs:string"/>

<xs:element name="Value" type="xs:string"/>

</xs:sequence>

</xs:complexType>

Addin Files

The addin file provides the references for the activity you are defining. The file is in XML format
and contains information such as activity names, dependencies, and runtime DLLs.

The addin file should be located in the installation directory under the
addins\CustomerAddins\<addin_name> folder, together with the signature file. The addin
file must have an .addin extension.

Each addin file should contain the following sections:

l "Addin Section" below

l "Manifest Section" on next page

l "Runtime Section" on next page

Addin Section
The Addin's attributes describe the activity to Service Test.

Element Description Attributes

<Addin> Basic details
about the addin.

l name. the name of the addin.

l author. the creator of the activity.

l copyright. the full path of a text file with the copyright
information.

l description. a textual description of the activity.

l version. The addin file version, set to 1.0.

Path Details about the
location of the
activity.

l name. The logical path scanned by the framework, to
identify addins. The physical location of this folder is
addins\CustomerAddins\

<addin_name>.

Activity
(sub-
element of
Path)

See attribute
descriptions.

l id. An identifying string corresponding to the ID in the
signature file.

l displayName. The activity's display name in the Toolbox
pane.

l signatureFile. The name of the XML signature file.
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Manifest Section
TheManifest section contains a unique logical name for the addin and provides a list of
dependencies.

Element Description Attributes

Identity Basic details about the
addin.

l name. The activity name corresponding to the ID in
the signature file. When referring to this addin as a
dependency, use this name.

Dependency The activity upon
which the current
activity is dependent

l addin. The identity name of the dependent activity,
from the name attribute in theManifest section of its
addin file.

l requirePreload. A boolean value indicating whether
to preload the dependent addin before loading the
current one.

Runtime Section
The runtime section contains information about the addin's runtime file.

Element Description Attributes

Import An assembly to
import when
running the
activity.

l assembly. The name of an assembly. Use the DLL name
without the DLL extension.

Note: To import an addin from another activity, precede the
addin namewith a colon. For example,
:HP.ST.Fwk.DesignerModel imports the
DesignerModel addin.

The following example shows theReportMessageActivitySample.addin file. For multiple
activities, use uniqueAddin files.

<?xml version="1.0" encoding="utf-8"?>

<AddIn name = "HP Report Message Activity Sample"

    author = "John Doe"

    copyright = "C:\Copyrights\copyright.txt"

    description = "Extensibility Sample - Report Message Activity"

    version="1.0">

<Manifest>

<!--<Must be unique -->

<Identity name = "ReportMessageActivitySample"/>

</Manifest>

<Runtime>

<Import assembly=":HP.ST.Fwk.DesignerModel"/>

</Runtime>

<Path name = "/ST/Activities">
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<!--Misc Activities -->

<Activity id = "ReportMessageActivitySample"

displayName = "ReportMessageSample"

signatureFile = "ReportMessageActivitySample.xml"

assembly="ReportMessageActivitySample.dll"/>

</Path>

</AddIn>

Resource Files

You can use resource files to retrieve values for elements and attributes. The fromResource
function lets you name the resource containing the values.

In the following example, the signature file retrieves the shortName and description from a
resource file.

<Resource

type="Activity"

id="ReportMessageActivitySample"

version="1.0.0"

group="Miscellaneous"

shortName="fromResource(conc_str_short_name)"

description="fromResource(conc_str_description)"

The resources are defined in a standardMicrosoft ResX Schema version 2.0 Resource fie.

<data name="conc_str_description" xml:space="preserve">

<value>Reports an activity's run status to the log</value>

</data>

<data name="conc_str_short_name" xml:space="preserve">

<value>Report Message</value>

</data>

The resource referencemust be a compiled file with a .resources extension, compiled from the
ResX source file and stored in the same folder as the signature file.

You can generate the compiled file as a post-build operation using the resgen utility. For example:

resgen STBasicActivity.resx STBasicActivity.resources.

For step-by-step instructions on how to create a custom activity, see "Prerequisite - create a
runtime file" on page 677.

HP Service Test (11.52)Page 672 of 705

User Guide
Chapter 32: Extensibility in Service Test



Tasks

How to Use the Wizard to Create a Custom Activity - C#
This task describes how to create a new activity, using C#, and deploying it in Service Test.

This task includes the following steps:

l "Run the Activity Wizard" below

l "Open the folder" below

l "Add execution code" below

l "Add Logger code - optional" on next page

l "Add a Report statement - optional" on next page

l "Compile the project into a DLL" on next page

l "Deploy the activity" on next page

l "Add a test step" on next page

1. Run the Activity Wizard
Open the Activity Wizard from the product's start menu (Start > All Programs >
HP Software > HP Service Test> Tools > Activity Wizard).

In the wizard's General Properties pane, select theC# as the Language.

Define the relevant properties and proceed to the last screen of the wizard. For details, see the
"Activity Wizard" on page 684.

Note: For details on accessing Service Test tools and files inWindows 8, see "Accessing
Service Test inWindows 8Operating Systems" on page 33.

2. Open the folder
On the final screen of the wizard, click Open Folder to open the <Activity Name> folder,
corresponding to the activity name you specified in the wizard. Navigate to the following
subfolder SourceCode and locate the <Activity Name>.cs file.

3. Add execution code
Add your execution code to theExecuteStep function inside the .cs file.

protected override STExecutionResult ExecuteStep()

{

try

{ 

//**************************

// Execution code goes here

//**************************
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...

4. Add Logger code - optional
Add information for the log using the LogInfo, LogDebug, or LogError statements. For
example:

protected override STExecutionResult ExecuteStep()

{

try

{ 

    LogInfo("Log Message 1");

    LogDebug("Log Message 2");

    LogError("Log Message 3");

...

5. Add a Report statement - optional
Add aReport statement. For example:

protected override STExecutionResult ExecuteStep()

{

try

{ 

        DetailsReport = DetailsReport.Replace("\\n", "<BR>");

        this.Report("Message", DetailsReport);    ;

...

6. Compile the project into a DLL
Build the project andmake sure the current <Activity Name> .dll file is in the new
activity folder that you specified in the wizard.

7. Deploy the activity
In the final wizard screen, click Deploy in Service Test. Click Finish to close the wizard.
Restart Service Test.

8. Add a test step
n Open a new test and add the new custom activity (by default under theMiscellaneous

category) into the Test Flow.

n Provide values for the properties you defined for the activity in the wizard.

n Run the test and observe the Output log and Run Results Viewer.

n Enable checkpoints to verify the results and rerun the test.

How to Use the Wizard to Create an Activity -Java
This task describes how to create a new activity using Java code, and deploy it in Service Test.
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This task includes the following steps:

l "Prerequisite" below

l "Run the Activity Wizard" below

l "Open the folder" below

l "Edit the code" below

l "Add Logger code - optional" on next page

l "Add a Report statement - optional" on next page

l "Compile the Java into a class" on next page

l "Deploy the activity" on next page

l "Add a test step" on next page

1. Prerequisite
Make sure you have a JAVA_HOME environment variable defined on your machine indicating
the parent JDK folder.

2. Run the Activity Wizard
Open the Activity Wizard from the product's start menu (Start > All Programs >
HP Software > HP Service Test > Tools >Activity Wizard).

In the wizard's General Properties pane, select the Java as the Language.

Define the relevant properties and proceed to the last screen of the wizard. For details, see the
"Activity Wizard" on page 684.

Note: For details on accessing Service Test tools and files inWindows 8, see "Accessing
Service Test inWindows 8Operating Systems" on page 33.

3. Open the folder
On the final screen of the wizard, click Open Folder to open the <Activity Name> folder,
corresponding to the activity name you specified in the wizard. Navigate to the following
subfolder <Activity Name>\hp\st\ext\java and locate the MyLogic.java file.

4. Edit the code
Edit the ExecuteLogic function inside the MyLogic.java file. Make sure to keep the
Properties definition.

public Properties Props = new Properties();

public ExecutionResult ExecuteLogic()

{

    try{

    //**************************

    // Execution code goes here

    //**************************
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    return ExecutionResult.Success;

    }

...

5. Add Logger code - optional
Add information for the log using the Logger.LogInfo, Logger.LogDebug, or
Logger.LogError statements. For example:

    try{

    ...

        Logger.LogInfo("Log Message 1");

        Logger.LogDebug("Log Message 2");

        Logger.LogError("Log Message 3");

    ...

    return ExecutionResult.Success;

    }

6. Add a Report statement - optional
Add a Report statement, Reporter.Report, using key value combinations. For example:

    try{

    ...

        Reporter.Report{"Name","John");

    ...

    return ExecutionResult.Success;

    }

7. Compile the Java into a class
Run the CompileJavaFiles batch file in the <Activity Name>\hp\st\ext\java

folder to compile all java files into a class. This utility only compiles the files in its folder.

8. Deploy the activity
In the final wizard screen, click Deploy in Service Test. Click Finish to close the wizard.
Restart Service Test.

9. Add a test step
n Open a new test and add the new custom activity (by default under theMiscellaneous

category) into the Test Flow.

n Provide property values in the Properties pane.

n Run the test and observe the Output log and Run Results Viewer.

n Enable checkpoints to verify the results and rerun the test.

How to Manually Create a Custom Activity in C#
This task describes how to create a new activity and implement it into Service Test.
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To run a test with the custom activity on another machine, you need to copy all of the custom files
to its <Installation_Folder>\addins\
CustomerAddins\<addin_name> folder.

This task includes the following steps:

l "Prerequisite - create a runtime file" below

l "Create a signature file" below

l "Create an addin file" on next page

l "Provide a graphic for your activity - optional" on page 679

l "Check the implementation" on page 679

1. Prerequisite - create a runtime file
Create a C# project that implements your activity's actions in the
addins\CustomerAddins\<addin_name> folder. For task details, see "How to Create a
Runtime File" on page 679.

2. Create a signature file
a. Create a new signature file with an .xml extension. in the

addins\CustomerAddins\<addin_name> folder, together with the runtime file. Use
the sample project in the <installation folder>\ExtensibilitySamples

folder as a basis for your custom signature file.

b. Customize theResource section or copy the code provided below, modifying the bolded
text for your needs. For details about each of the elements, see "Resource Element " on
page 664.

<Resource

type="Activity"

id="ReportMessageActivitySample"

version="1.0.0"

group="Miscellaneous"

shortName="ReportMessageActivitySample"

description="ReportMessageActivitySample allows you to send

a custom message to the report and/or log. "

assembly="ReportMessageActivitySample.dll"

className="

ReportMessageActivitySample.ReportMessageActivitySample"

image="toolbox_ReportMessageActivitySample.png"

visible="true"

xmlns="http://hp.st.schemas/signature/v1.0"

xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

xsi:schemaLocation="http://hp.st.schemas/signature/v1.0

../../../dat/schemas/Signature.xsd"

>

c. Add the required sections, such as GeneralProperties, InputProperties, Tabs, Events and
so forth. For a list of the built-in sections and their attributes, see the "Section Element" on
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page 665.

d. Add properties to the relevant sections. For details and examples, see "Property
Definitions" on page 667.

o GeneralProperties. Properties displayed in the Properties pane's General tab. In most
cases you can use the section as it appears in the sample file, without any
modifications. By default, it will provide theStep ID andName properties.

o InputProperties. Properties displayed in the Properties pane's Input/Checkpoints
tab, in the Input pane.

o OutputProperties. Properties displayed in the Properties pane's Input/Checkpoints
tab, in theCheckpoints pane.

e. Specify any external resource files as described in "Resource Files " on page 672.

f. Close the file with the </Resource> tag.

</Resource>

Formore details about the structure of the signature file, see "Signature Files " on page 663.

3. Create an addin file
a. Create a new file with an .addin extension in the <installation

directory>\addins\CustomerAddins\

<addin_name> folder, together with the signature file.

b. Use the sample addin file in the <installation

folder>\ExtensibilitySamples folder as a basis, or copy the code provided
below, modifying the bolded text for your needs. For details, see "Addin Files " on page
670.

<?xml version="1.0" encoding="utf-8"?>

<AddIn name = "HP Report Message Activity Sample"

author = "John Doe"

copyright = "prj:///doc/copyright.txt"

description = "Extensibility Sample - Report Message

Activity"

version="1.0">

<Manifest>

<!--<Must be unique -->

<Identity name = "ReportMessageActivitySample"/>

</Manifest>

<Runtime>

<Import assembly=":HP.ST.Fwk.DesignerModel"/>

</Runtime>

<Path name = "/ST/Activities">

<!--Misc Activities -->

<Activity id = "ReportMessageActivitySample"

    displayName = "ReportMessageSample"
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signatureFile = "ReportMessageActivitySample.xml"

    assembly="ReportMessageActivitySample.dll"/>

</Path>

</AddIn>

c. Create a unique Addin file for each activity—do not definemultiple activities in a single
Addin file. For details, see "Addin Files " on page 670.

d. Define post-build tasks such as resgen, as described in "Resource Files " on page 672.

e. Compile the project and copy the DLL to the <Installation_
Folder>\addins\CustomerAddins\<addin_name> folder.

For additional details, see "Runtime Files " on page 663.

4. Provide a graphic for your activity - optional
a. Copy an icon image for your activity into the <Installation_

Folder>\addins\CustomerAddins\<addin_name> folder. This file shouldmeet the
following requirements:

o a .png extension

o sized at 16 x 16 pixels

o 8-bit color depth

b. Specify the name of the image file in the signature file's "Resource Element ".

5. Check the implementation
a. Reopen the application and drag the new activity into the Test Flow. Verify that the activity

and its properties appear as expected.

b. Provide property values.

c. Run the test and observe the Output log and Run Results Viewer.

d. Enable checkpoints to verify the results and rerun the test.

How to Create a Runtime File
This section contains the following topics:

l "Add Using statements" on next page

l "Specify the namespace and class" on next page

l "Set the internal logging" on next page

l "Initialize the properties" on next page

l "Retrieve the property values" on page 681

l "Define events" on page 682

l "Execute the step" on page 682
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l "Set the status" on page 683

l "Compile the runtime file" on page 683

Note: Youmust compile the DLL with a Target Framework of Framework 4.0.

1. Add Using statements
Provide themandatory using statements. In your solution, youmust also add a reference to
the .dll filess. The .dll filess are located in the products installation's /bin folder. You
must always add a reference to HP.ST.Fwk.RunTimeFWK.dll. If you are using internal
logging, youmust also add a reference to log4net.dll.

The following example shows theUsing statements in the sample .cs file.

using HP.ST.Fwk.RunTimeFWK;

// If you need to implement Internal Logging

using log4net;

2. Specify the namespace and class
Define the namespace and provide the activity's runtime code. The class you define for your
custom activity must inherit from the STActivityBase class. For example:

namespace ReportMessageActivitySample

{

[Serializable]

public class ReportMessageActivitySample : STActivityBase

{

3. Set the internal logging
Use the built-in logger manager to instruct the activity to create an internal log during runtime.
This example gets the property values of the input properties and sends the output to either the
Run Results Viewer only or to the Run Results Viewer andOutput window. For example:

/// <summary> /// Internal log

/// </summary>

private static readonly ILog log =

LogManager.GetLogger(typeof(ReportMessageActivitySample));

const string runResults = "Run Results";

const string runResultsAndOutputWindow = "Run Results and Output

Window";

For details about other logging options, see "How to Use the Logging Function " on page 649.

4. Initialize the properties
Initialize the custom Input andOutput properties that you define in the signature file. The
following example initializes the three input properties: Status,Message, andDestination. For
example:
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/// <summary>

/// Initializes properties.

/// </summary>

/// <param name="ctx">The runtime context</param>

public ReportMessageActivitySample(ISTRunTimeContext ctx, string

name)

: base(ctx, name)

{

this.Status = String.Empty;

this.Message = String.Empty;

this.Destination = String.Empty;

}

5. Retrieve the property values
This section retrieves or sets the input property values. For example:

/// <summary>

/// Gets or sets the status of the message to report.

/// </summary>

public string Status { get; set; }

/// <summary>

/// Gets or sets the details of the message to report.

/// </summary>

public string Message { get; set; }

/// <summary>

/// Gets or sets the destination where the message should be

reported to.

/// </summary>

public string Destination { get; set; }

If you have array type properties that are not described by a schema, for example, key/value
pairs, youmust initialize all themembers of the array explicitly, and indicate the actual number
of elements.

The following example initializes 40 elements for the MyArrayName property. It contains 40
key and value pairs.

this. MyArrayName = new MyPair[40];

for (int i=0; i<40; i++)

{

this. MyArrayName [i] = new MyPair();

}

public MyPair[] MyArrayName;

public class MyPair

{

string Key;

string Value;
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}

For arrays defined by a schema orWSDL, you can use the standard "Select Link Source
Dialog Box" (described on page 630) and link directly to the array element.

6. Define events
Define one or more custom events, that you will invoke later. For example:

public event EventHandler CustomerEvent;

private void InvokeCustomerEvent(EventArgs MyArg)

{

EventHandler handler = this.CustomerEvent;

if (handler != null)

{

handler(this, MyArg);

}

}

7. Execute the step
Execute the step and send the runtime information to the log. Use theSTExecutionResult
data type and its ExecuteStep function defined in theSTActivityBase class. For example:

protected override STExecutionResult ExecuteStep()

{

string DetailsReport;

if (this.Destination == runResultsAndOutputWindow)

{

LogInfo("\n" + this.Message.Replace("\\n", "\n"));

}

/// <summary>

/// Reports message to test results and output window.

/// </summary>

// The line-breaks replacements allow the printing of multiple

lines in the report

DetailsReport = this.Message;

DetailsReport = DetailsReport.Replace("\\n", "<BR>");

DetailsReport = DetailsReport.Replace("\n", "<BR>");

this.Report("Message", DetailsReport);

If you defined a custom event, invoke it after the call to ExecuteStep.

...

protected override STExecutionResult ExecuteStep()

{

InvokeCustomerEvent();
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}

8. Set the status
Set the Status of the test run. The ReportMessageActivitySample.cs sample file uses
enumeration to set the status, based on theSTExecutionResult value. For example:

switch (this.Status)

{

case "Done":

this.Report(ReportKeywords.StatusKeywordTag,

ReportKeywords.DoneValueTag);

return new STExecutionResult(STExecutionStatus.Success);

case "Pass":

this.Report(ReportKeywords.StatusKeywordTag,

ReportKeywords.SuccessValueTag);

return new STExecutionResult(STExecutionStatus.Success);

case "Fail":

this.Report(ReportKeywords.StatusKeywordTag,

ReportKeywords.FailureValueTag);

return new STExecutionResult(STExecutionStatus.Success);

default:

return new STExecutionResult(STExecutionStatus.Success);

}

9. Compile the runtime file
After you customize the code, you compile the .dll. The .dll name should be the same as
the name of the addin file. For example, the runtime file,
ReportMessageActivitySample.dll corresponds to the
ReportMessageActivitySample.addin file.

After you create the runtime file in your development environment, you reference the .dll
from the signature file, and the signature file from the addin file.
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Reference

Activity Wizard
This wizard enables you to create new custom activities in the Toolbox pane.

To
access

Start > All > Programs > HP Software > HP Service Test > Tools > Activity
Wizard

Note: For details on accessing Service Test tools and files inWindows 8, see
"Accessing Service Test inWindows 8Operating Systems" on page 33.

Wizard
map

This wizard contains:

Welcome > "General Properties Page" > "Project Properties Page" > "Set Properties
Page " > "Confirm Page " > "Progress Page " > "Finish Page "

See
also

l "Creating New Activities - Overview " on page 662

l "How toManually Create a Custom Activity in C#" on page 676

l "How to Use theWizard to Create a Custom Activity - C#" on page 673

General Properties Page

This wizard page enables you to set the General type properties for the activity.
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Important
information

General information about this wizard is available here: "Activity Wizard" on
previous page.

Wizard
map

This wizard contains:

Welcome > "General Properties Page" > "Project Properties Page" > "Set
Properties Page " > "Confirm Page " > "Progress Page " > "Finish Page "

User interface elements are described below:

UI
Elements

Description

Reset Values. Resets all of the values to their original defaults and discards all
changes that youmade.

Open Wizard Project. Opens a Visual Studio activity project that you created
earlier.
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UI
Elements

Description

Category The category under which to deploy the activity. A drop down list contains all of
the built-in or previously created categories.

Clicking on New opens the Add New Category dialog box.

Description A meaningful description that will appear in the Toolbox pane's hint area when
you select the activity.

Display
Icon

An icon image for the activity for the Toolbox pane and canvas. Click Import to
upload a new image file for the icon. The icon size should be 16 x 16 pixels.

Display
Name

The name of the activity as it will appear in the canvas and Toolbox pane.

Language The language in which to generate the code: C# or Java.

Note:When you select Java, the wizard creates a Java file to which you can
add the logic for your activity, and references to other required files. In
addition, a Visual Studio project is created tomanage the integration between
the API Test and your Java activity.

Project
Location

The location in which to save the project.

Unique
Activity ID

A unique ID for the new activity. This ID can be used to reference the activity.

Project Properties Page

This wizard page enables you to set the properties for the activity project.
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Important
information

General information about this wizard is available here: "Activity Wizard" on page
684.

Wizard
map

This wizard contains:

Welcome > "General Properties Page" > "Project Properties Page" > "Set
Properties Page " > "Confirm Page " > "Progress Page " > "Finish Page "

User interface elements are described below:

UI Elements Description

Activity Class
Name

A class name for the activity that will be generated.

Project Name The name of the project.
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UI Elements Description

Edit advanced
properties

Enables themanual editing of additional project properties.

Project Namespace The namespace to create for the project.

Project File Name The name of the project file. By default, this is theProject Namewith a
.csproj extension.

Solution File Name The name of the solution file. By default, this is theProject Namewith
an .sln extension.

Class FIle Name The name of the class file. By default, this is theProject Namewith a
.cs extension.

Class Partial FIle
Name

The name of the class file. By default, this is theProject Namewith a
.cs extension.

Assembly Name The name of the assembly file. This namewill be associated with the
.dll extension.

Set Properties Page

This wizard page lets you to define Input andOutput properties for the activity and add new General
properties.

HP Service Test (11.52)Page 688 of 705

User Guide
Chapter 32: Extensibility in Service Test



Important
information

General information about this wizard is available here: "Activity Wizard" on page
684.

Wizard
map

This wizard contains:

Welcome > "General Properties Page" > "Project Properties Page" > "Set
Properties Page " > "Confirm Page " > "Progress Page " > "Finish Page "

User interface elements are described below (unlabeled UI elements are shown in angle brackets):

UI
Elements

Description

Open in Separate Window. Opens a list of the properties in a separate window.

Add Property. Opens the Add New Property dialog box. For details, see "Add New
Property" on next page.
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UI
Elements

Description

Remove Property. Deletes the selected property from the activity.

Clone Property.Makes a copy of the selected property.

Show Properties Tree. Shows the properties in a tree hierarchy, by category—
General, Input, andOutput.

Show Properties List. Hides the property tree hierarchy and shows all of the
properties in a single grid.

Add/Remove Columns. Opens the Add/Remove Columns dialog box enabling you
to indicate which columns will be displayed in the Set Properties wizard page.

Show Properties Pane. Opens the Properties pane in a dockable window. You can
edit all of the property values— even ones that are not displayed in the wizard
screen columns.

Hide Properties Pane. Closes the Properties pane.

<property
list>

A grid representation of the activities properties.

Tip:

l To show different or additional columns in the grid, click theAdd/Remove
Columns button and select the desired columns.

l To change the order of the columns in the display, drag to column title to the
desired location.

Add New Property

The AddNew Property dialog box lets you create new properties for the activity.
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To access Do the following:

1. Open the Activity Wizard. For details, see "Activity Wizard" on page 684.

2. Advance to theSet Properties page.

3. Click theAdd Property button in the toolbar .

User interface elements are described below:

Tree
Elements
(A-Z)

Description

Description An optional description of the property, that will appear in the hint area when you
select the property in the Properties pane.

Display
Name

The name of the property as it will be displayed in the property list.

Name The name of the property as it will be called within the test and by event handlers.

Section The section in which to add the property: Input, Output (Checkpoint), or
General.

Type The data type of the property, such as String, Int, and so forth.

Confirm Page

This wizard page shows you a summary of your settings before generating the activity.
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Important
information

General information about this wizard is available here: "Activity Wizard" on page
684.

Wizard
map

This wizard contains:

Welcome > "General Properties Page" > "Project Properties Page" > "Set
Properties Page " > "Confirm Page " > "Progress Page " > "Finish Page "

User interface elements are described below:

UI Elements Description

<summary text> A message indicating that the wizard is ready to begin the generation.

Progress Page

This wizard page shows you the generation progress.
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Important
information

General information about this wizard is available here: "Activity Wizard" on page
684.

Wizard
map

This wizard contains:

Welcome > "General Properties Page" > "Project Properties Page" > "Set
Properties Page " > "Confirm Page " > "Progress Page " > "Finish Page "

User interface elements are described below:

UI Elements Description

<progress information> A log indicating progress of the generation.

Finish Page

This wizard page enables you to view the generation log, open the solution and its folder, and
deploy the activity.
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Important
information

General information about this wizard is available here: "Activity Wizard" on page
684.

Wizard
map

This wizard contains:

Welcome > "General Properties Page" > "Project Properties Page" > "Set
Properties Page " > "Confirm Page " > "Progress Page " > "Finish Page "

User interface elements are described below:

UI Elements (A-Z) Description

View Report Opens a log of the generation process. The log file is located in the
%temp%\ ActivityWizard\Reports folder. Its title contains
the generation date, WizardLog_#datetime#.log.

Open Folder Opens the folder in which the activity files were generated. This
folder is the Output directory you specified in the wizard.

For example, you can open this folder to locate the java files to which
you can add your custom code. The default subfolder is
hp\st\ext\java.

Open Solution Opens the activity's solution file in Visual Studio 2010. Use this
option to edit and compile the source code.

Deploy in Service Test Deploys the activity in Service Test by adding it to the Toolbox
pane.

Close the Activity
Wizard after selecting
one of the above
options

Closes the wizard screen automatically after selecting theView
Report, Open Folder, Open Solution, orDeploy in Service Test
options.
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Troubleshooting and Limitations - Extensibility
This section describes troubleshooting and limitations for creating and using custom activities.

l The following error may occur if you place the signature file beneath a sub-folder of the addin
folder.

ServiceTest was unable to drag and drop the activity: Type

'http://hp.vtd.schemas/types/v1.0:GeneralPropertiesType' is not

declared.

Workaround:Modify the relative path of the Types schema. For example:

.schemaLocation="../../dat/schemas/Types.xsd".

l If youmodify the activity structure in the signature file, you will be unable to open tests using
that activity. Tomodify an activity structure, create a new activity with the new structure,
replace all of the test steps using the old activity, and then remove the old activity
implementation.
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Part 7: Appendix
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Chapter 33: Where's My UI?
(Changes from Previous Versions)

This chapter describes changes that have beenmade to the user interface betweenService
Test11.20 and this version of Service Test:

Pane Changes 698

Menu CommandChanges 699

Toolbar Changes 704
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Pane Changes
The table below lists the panes whose names in this version of Service Test are different
fromService Test 11.20. The functionality of the pane remains similar.

Previous Pane
Name

Current Pane
Name

Additional Information

Data Explorer Data For details, see "Data Pane" on page 96.

Property Sheet Properties For details on the Properties pane, see "Properties
Pane" on page 184.

Tests Solution
Explorer

For details on theSolution Explorer pane, see
"Solution Explorer PaneOverview" on page 235.

Toolbox Palette Toolbox For details, see "Toolbox PaneOverview" on page
255.
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Menu Command Changes
Some of themenu commands from Service Test 11.20 are relocated in this version of Service Test,
to improve product usability. Use this section to locate the commands that moved.

This section discusses the followingmenu changes:

File Menu Changes 699

Edit Menu Changes 700

View Menu Changes 700

Test Menu Changes 701

Build Menu Changes 701

DebugMenu Changes 702

HelpMenu Changes 702

File Menu Changes
The following table lists commands from theService Test 11.20 File menu and their location in this
version of Service Test.

Service Test 11.20
Menu Option

Current
Option

Additional Information

File > ALM/QC
Connection

ALM >
(menu
option)

All menu command tomanage an ALM connection
have beenmoved to a stand-aloneALMmenu.

Note: The ALM Connection is also available by

pressing theALMConnection button in the
toolbar.

ALM/QC Version
Control > Check Out

ALM/QC Version
Control > Undo Check
Out

ALM/QC Version
Control > Check In

ALM/QC Version
Control > Version
History

ALM/QC Version
Control > Baseline
History
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Edit Menu Changes
The following table lists commands from theService Test 11.20Edit menu and their location in this
version of Service Test.

Service Test changes

Service Test 11.20
Menu Option

Current Option Additional Information

Select All This command is not relevant for this
version of Service Test.

Find and Replace Search > Find
Search > Replace

Settings > Show Run
Test dialog box

This command is not relevant for this
version of Service Test.

Settings > Show
Results after Run

Tools > Options >
General tab > Run
Sessions node

Select theView results when run
session ends option to enable this
command.

Settings > Use
Relative Paths in
Service Test Steps

Tools > Options > API
Testing tab > General
node

Select theUse relative paths to call
assets option to enable this command.

Settings > Activity
Repositories

Tools > Options > API
Testing tab > General
node

Choose the Activity Repositories path in
theActivity Repositories area of
General pane.

View Menu Changes
The following table lists commands from the Service Test 11.20View menu and their location in
this version of Service Test.

Service Test 11.20
Menu Option

Current Option Additional Information

Tests View > Solution
Explorer

Data Window View > Data

Property Sheet View > Properties

Window Theme >
(suboptions)

This command is not relevant for this version
of Service Test.
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Test Menu Changes
The Testmenu items from Service Test 11.20 are incorporated into other menus in this version of
Service Test.

Service Test 11.20
Menu Option

Current Option Additional Information

Test > Add
Reference

Design > Add
Reference

Test > Enable
Test for Load
Testing

Design > Enable
Test for Load
Testing

Only available when HP LoadRunner is installed
on themachine.

Test > Open
Containing
Folder

Context menu in
document pane

Right-click on a test tab in the document pane and
select Open Containing Folder in Explorer.

Test > View Test
Results

View > Last Run
Results

Build Menu Changes
TheBuildmenu from Service Test 11.20 is incorporated into theRunmenu in this version of
Service Test.

Service
Test 11.20
Menu Option

Current Option Additional Information

Build Solution Run > Compile submenu

Rebuild
Solution

Clean Solution

Build <test
name>

Rebuild <test
name>

Clean <test
name>

Abort Build
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Service
Test 11.20
Menu Option

Current Option Additional Information

Set
Configuration
> Debug

Tools > Options > API
Testing tab > General node

Select the appropriate option from the drop-
downmenu forCompile as option.

Set
Configuration
> Release

Debug Menu Changes
TheDebugmenu fromService Test 11.20 is incorporated into theRunmenu in this version of
Service Test.

Service Test changes

Service Test 11.20
Menu Option

Current Menu Option

Run Test Run submenu

Stop Process

Break

Continue Debugging

Step Over

Step Into

Step Out

Toggle Breakpoint

Help Menu Changes
The followingHelp menu options fromService Test 11.20 are changed in this version of Service
Test.
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Service Test changes

Service Test 11.20
Menu Option

Current Menu Option Additional Information

Index Not available in this version of
Service Test.

Search

Contents

User Guide Help > HP Service Test Help

HP Service Test Web
Site

Help > Useful Links >
Product Page
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Toolbar Changes
The sections describe the locations of toolbar buttons or toolbar icons fromService Test 11.20 that
changed.

The following table shows the new icons for Service Test 11.20 toolbar buttons, as well as the
menu options you can use for buttons that are no longer available.

Service Test
11.20
toolbar
button

Current Location Additional Information

Open Test Toolbar button:
Open

This toolbar button also provides a
drop-down list of document types to
open.

Add New
Test

Toolbar button:
Add

This toolbar button also provides a
drop-down list of document types (both
new and existing to add to a solution).

ALM/QC
Connection

Toolbar button:
ALM Connection

Enable Test
for Load
Testing

Menu command:
Design > Enable
Test for Load
Testing

Only available when HP LoadRunner is
installed on themachine.

Default
Zoom

Button on canvas

Zoom In Button on canvas

Zoom Out Button on canvas
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