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Documentation Updates
The title page of this document contains the following identifying information:

l Software Version number, which indicates the software version.

l Document Release Date, which changes each time the document, is updated.

l Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using themost recent edition of a document, go
to: www.hp.com/go/livenetwork. This site requires that you register for an HP Passport and sign in.
To register for an HP Passport ID, go to: http://h20229.www2.hp.com/passport-
registration.html

Or click theNew users - please register link on the HP Passport login page.
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Support
Visit the HP Software Support Online web site at:

http://www.hp.com/go/hpsoftwaresupport

This web site provides contact information and details about the products, services, and support
that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and
efficient way to access interactive technical support tools needed tomanage your business. As a
valued support customer, you can benefit by using the support web site to:

l Search for knowledge documents of interest

l Submit and track support cases and enhancement requests

l Download software patches

l Manage support contracts

l Look up HP support contacts

l Review information about available services

l Enter into discussions with other software customers

l Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also
require a support contract. To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html

To findmore information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp
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About the Tutorial for Testing
The UFT Tutorial for API Testing is a self-paced printable guide designed to lead you through the
process of creating tests forWeb services, REST services, and other GUI-less applications.

After completing the tutorial, you can apply the skills you have learned to testing the GUI-less layer
of your own application orWeb site.

Note: To learnmore about creating and running GUI tests, see the UFT Tutorial for GUI
Testing, available from the < UFT installation folder>\help directory.

Tutorial Audience and Scope
This tutorial is intended for users who are new to UFT. No prior knowledge of UFT or Service Test
is required. A general understanding of testing concepts and functional testing processes may be
helpful, but is not mandatory. UFT enables you to create API tests and business process tests.
This tutorial reviews topics related to API testing only. While performing the lessons in this tutorial,
youmay notice unfamiliar menu items or other UFT GUI elements that are not described in the
tutorial. Thesemay be relevant for Business Process Testing or GUI testing only, and are not
relevant for API testing at all. For details about these elements, see theHP Unified Functional
Testing User Guide.

Note: This tutorial refers to file system paths that are relevant forWindows 7 operating
systems. The paths in other operating systems may be slightly different.

Topic Types
The content in the UFT guides is organized by topics. Threemain topic types are in use:
Concepts, Tasks, andReference.

Topic Type Description Usage

Concepts Background, descriptive, or conceptual
information.

Learn general information
about what a feature does.

Tasks Instructional Tasks. Step-by-step
guidance to help you work with the
application and accomplish your goals.

Task steps can be with or without
numbering:

l Numbered steps. Tasks that are
performed by following each step in
consecutive order.

l Non-numbered steps. A list of self-
contained operations that you can
perform in any order.

l Learn about the overall
workflow of a task.

l Follow the steps listed in a
numbered task to complete
a task.

l Perform independent
operations by completing
steps in a non-numbered
task.
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Topic Type Description Usage

Use-case Scenario Tasks. Examples of
how to perform a task for a specific
situation.

Learn how a task could be
performed in a realistic
scenario.

Reference General Reference. Detailed lists and
explanations of reference-orientedmaterial.

Look up a specific piece of
reference information relevant
to a particular context.

User Interface Reference. Specialized
reference topics that describe a particular
user interface in detail. Selecting Help on
this page from the Helpmenu in the product
generally open the user interface topics.

Look up specific information
about what to enter or how to
use one or more specific user
interface elements, such as a
window, dialog box, or wizard.

Troubleshooting
and Limitations

Troubleshooting and Limitations.
Specialized reference topics that describe
commonly encountered problems and their
solutions, and list limitations of a feature or
product area.

Increase your awareness of
important issues before
working with a feature, or if
you encounter usability
problems in the software.

UFT Help Contents
The UFT Help includes the following:

Type Included Documentation

Getting to
Know UFT
Documentation

l Readme provides the latest news and information about UFT. Select Start
> All Programs > HP Software > HP Unified Functional Testing >
Readme.

Note: For details on accessing UFT tools and files inWindows 8, see
"Accessing UFT inWindows 8Operating Systems" on page 15.

l Installation Guides explain how to install and set up UFT or the
HP Functional Testing Concurrent License Server. Select Help > Unified
Functional Testing Help and click the link to the appropriate guides from
the left pane.

l Tutorials teach you basic UFT skills for GUI testing and API testing and
show you how to design tests for your applications. Select Help > UFT
Tutorial.

l UFT Product Movies provide an overview and step-by-step instructions
describing how to use selected UFT features. Select Help > Product
Movies or.
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Type Included Documentation

Feature
Documentation

UFT Help includes:

l HP Unified Functional Testing User Guide describes how to use UFT to
test your application.

l HP RunResults Viewer User Guide describes how to use the Run Results
Viewer to view and analyze the run results from your tests or components.

l HP Unified Functional Testing Add-ins Guide describes how to work with
supported environments using UFT add-ins, and provides environment-
specific information for each add-in.

l HP UFT Object Model Reference for GUI Testing describes UFT test
objects, lists themethods and properties associated with each object, and
provides syntax information and examples for eachmethod and property.

Select Help > HP Unified Functional Testing Help.

Reference
Documentation

HP UFT Advanced References contains documentation for the following
UFT COM and XML references:

l HP UFT Automation Object Model Reference provides syntax,
descriptive information, and examples for the automation objects,
methods, and properties. It also contains a detailed overview to help you
get started writing UFT automation scripts. The automation object model
assists you in automating test management, by providing objects,
methods and properties that enable you to control virtually every UFT
feature and capability.

l HP UFT Run Results Schema Reference documents the run results
XML schema, which provides the information you need to customize your
run results.

l HP UFT Test Object Schema Reference for GUI Testing documents
the test object XML schema, which provides the information you need to
extend test object support in different environments.

l HP UFT Object Repository Schema Reference for GUI Testing
documents the object repository XML schema, which provides the
information you need to edit an object repository file that was exported to
XML.

l HP UFT Object Repository Automation Reference for GUI Testing
documents the Object Repository automation object model, which
provides the information you need tomanipulate UFT object repositories
and their contents from outside of UFT.

l VBScript Reference contains Microsoft VBScript documentation,
including VBScript, Script Runtime, andWindows Script Host.

Select Help > HP UFT GUI Testing Advanced References Help.
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Additional Online Resources
The following additional online resources are available from the Unified Functional Testing Help
menu:

Resource Description

HP Software
Support Site

Opens the HP Software Support Web site. This site enables you to browse
the HP Software Self-solve knowledge base. You can also post to and
search user discussion forums, submit support requests, download patches
and updated documentation, andmore. ChooseHelp > HP Software
Support. The URL for this Web site www.hp.com/go/hpsoftwaresupport.
l Most of the support areas require that you register as an HP Passport

user and sign in. Many also require a support contract.

l To findmore information about access levels, go to:
http://h20230.www2.hp.com/new_access_levels.jsp

l To register for an HP Passport user ID, go to:
http://h20229.www2.hp.com/passport-registration.html

Testing Forums Opens the testing forums for GUI Testing, API Testing, and Business
Process Testing. where you can interact with other users of UFT and
discuss topics related to GUI Testing, API Testing, and Business Process
Testing.

The URLs for these sites are:

l GUI Testing: http://h30499.www3.hp.com/t5/Unified-Functional-
Testing/bd-p/sws-Fun_TEST_SF

l API Testing: http://h30499.www3.hp.com/t5/Service-Test-Support-and-
News/bd-p/sws-Serv_TEST_SF

l Business Process Testing: http://h30499.www3.hp.com/t5/Business-
Process-Validation/bd-p/sws-BPT_SF

UFT Product
Page

Opens the HP Unified Functional Testing product page, with information
and related links about UFT.

Troubleshooting
& Knowledge
Base

Opens the Troubleshooting page on the HP Software Support Web site
where you can search the HP Software Self-solve knowledge base. Choose
Help > Troubleshooting & Knowledge Base. The URL for this Web site
is http://h20230.www2.hp.com/troubleshooting.jsp.

HP Software
Community Site

Opens the HP IT Experts Community site, where you can interact with other
HP software users, read articles and blogs on HP software and access
downloads of other software products.
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Resource Description

Manuals Site Opens the HP Software Product Manuals Web site, where you can search
for themost up-to-date documentation for a selected HP Software product.
The URL for this Web site is
http://support.openview.hp.com/selfsolve/manuals (requires an HP
Passport).

What's New Opens the UFTWhat's New Help, describing the new features and
enhancements in this version of UFT.

Product Movies Opens a page displaying a list of all product movies.

HP Software
Web site

Opens the HP SoftwareWeb site. This site provides you with themost up-
to-date information on HP Software products. This includes new software
releases, seminars and trade shows, customer support, andmore. Choose
Help > HP Software Web site. The URL for this Web site is
www.hp.com/go/software.

You can access the following sample applications from theStartmenu. These applications are the
basis for many examples in this guide:

l Mercury Tours sampleWeb site. The URL for this Web site is http://newtours.demoaut.com.

l Mercury Flight application. To access from the Start menu, select All Programs > HP
Software > HP Unified Functional Testing > Sample Applications > Flight API / Flight
GUI.
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Chapter 1: Introducing HP Unified
Functional Testing - API Testing

HP Unified Functional Testingfor API testing contains an extensible framework for the construction
and execution of functional tests of headless systems, systems that do not have a user interface.
This document describes how to get started with HP Unified Functional Testing and create your
first tests. It also introduces themajor features in the product and how to incorporate them into your
tests.

You create a test by dragging activities onto a canvas. You set parameters, assign values, and run
your test. You can check for expected values with the built-in checkpoint mechanism or through
custom C# code.

This chapter contains the following sections:

What is SOA? 13

Why should you automate SOA testing? 13

Understanding Terminology 13

What is the sample application for this tutorial? 14

How do I invoke the application? 15

Accessing UFT inWindows 8Operating Systems 15

Where ToGo From Here 16
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What is SOA?
In recent years, outsourcing and advanced business needs required companies to collaborate and
share information. In addition, with the rising number of mergers and acquisitions, businesses
struggled to find a way to share data. If, prior to amerger, two businesses maintained their own
proprietary computer systems, after themerger, the sharing of data could be very time consuming
and costly.

For these issues, several vendors developed technologies to handle B2B (Business-to-Business)
communication. Examples of B2B technologies are RMI, COM, CORBA, EDI, andWeb services.
In addition to allowing the systems to link up to one other, the technologies also handle permissions
to allow networking with each other like an Intranet.

Web services are self-contained applications that can run across the Internet on a variety of
platforms. They use XML and Simple Object Access Protocol (SOAP) as the base language,
making it a developer-friendly solution. SinceWeb services are based on a set of standardized
rules and specifications, they aremore portable than other technologies.

SOA (Service Oriented Architecture) is an architectural style that lets multiple software services
interact. A service is a unit of work done by a service provider as specified by a consumer. SOA
requires that services interact with one another, but without interdependencies. The services are
autonomic and loosely coupled, only requiring that they retain an awareness of one other, but no
dependencies.

SOA systems are primarily based onWeb services. InWeb services, a client submits a request
and theWeb server provides a response using the SOAP protocol. HP Unified Functional
Testingfor API testing lets you check the behavior of yourWeb services in an automatedmanner.

Why should you automate SOA testing?
Automated SOA Testing is a discipline that leverages products and processes to reduce the risks
of application upgrades or deployment of new services. At its core, automated testing is about
applying production workloads to pre-deployment systems while simultaneously measuring system
performance and end-user experience. A well-constructed performance test answers questions
such as:

l Does the service respond quickly enough for the intended users?

l Will the server respond with the correct values?

l How will the service handle exceptions and illegal values?

l Is the service stable under expected and unexpected user loads?

By answering these questions, you can design a test more effectively. An effective automated
testing process helps youmakemore informed release decisions, reduces system downtime, and
prevents availability problems.

Understanding Terminology
Youmay encounter the following terms when working with SOA testing:
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HTTP Hypertext Transfer Protocol, a communications protocol used to transfer or provide
information over theWorldWideWeb. Users utilize HTTP to publish and retrieve
HTML pages.

JMS Java Message Service, a Java-basedMessageOrientedMiddleware API for sending
messages between two or more clients.

REST Representational State Transfer. A style of software architecture for distributed
systems.

SOAP Simple Object Access Protocol, orService Oriented Architecture Protocol, a
protocol for exchanging structured and typed information between peers in a
distributed environment using XML sent over HTTP or JMS. SOAP lets you serialize
distributed components into XML documents for transport and deserialize them upon
reaching their destination. This promotes interoperability between components that
are based on different technologies.

Test The steps that a user performs are described in a test. A test emulates the actions of
real users using the application.

UDDI Universal Description, Discoveryand Integration, a platform-independent, online
registry listing businesses worldwide. It is often used as a database for public Web
services.

Web
services

Standardized, Web-based applications using the XML, SOAP, WSDL and UDDI
standards over an Internet protocol. XML is used to tag the data, SOAP is used to
transfer the data, WSDLs describe the services and UDDIs list them.

WSDL Web services Description Language, an XML-based language designed to
describe aWeb service. TheWSDL document provides essential information about
theWeb service, such as its ports and operations, required for implementation.

WS-I Web Service Interoperability, a standard created by theWeb Service
Interoperability organization to promote compatibility betweenWeb Services.

XML Extensible Markup Language is a general-purposemarkup language. It is called
extensible because it lets you define your own tags. It enables the sharing of
structured data across different information systems, especially over the Internet.
XML is used both to serialize data and encode documents.

XSD XML Schema Definition files contain a set of rules that formally define the
hierarchical structure of an XML document. An XML document must comply with
these rules and constraints in order for parsers and processors to deem it valid.
WSDL documents can reference an external schema or it can contain an embedded
one.

What is the sample application for this
tutorial?

This tutorial is based on a sample application included with this product—theAPI Flights. It is
available as both aWeb and REST service.
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The sample application works with a flight reservation database. You can retrieve flights for specific
destinations, create customer orders, update reservations, or delete them.

For details about the service's methods and operations, type help in the Sample Application's
command prompt window.

Note:

l Youmust have administrator privileges to run the sampleAPI Flights application.

l It is recommended to haveMicrosoft Excel installed on your machine to enable Excel
functionality for the data sources.

How do I invoke the application?
As a first step, you will invoke the sample flight application, so that it will be available for your test.

To start the HP Flights service:

1. Make sure you have administrator privileges. These are required by Windows to run the sample
HP Flights service.

2. Select Start > (All) Programs > HP Software > HP Unified Functional Testing > Sample
Applications > Flight API. A Commandwindow opens indicating that the application is
available.

Note:Whenworking inWindows 8, you can access UFT directly from theStart screen.

For details on accessing UFT tools and files inWindows 8, see "Accessing UFT in
Windows 8Operating Systems" below.

3. If the window issues amessage that the default port 24240 is unavailable, edit the
<installation_directory>SampleApplication\HPFlights_

Service.exe.config file in a text editor. In the appSettings section, replace the 24240
port key with a valid one.

4. Minimize the sample application's Commandwindow. Do not close the Commandwindow, as
this will stop the service.

Accessing UFT in Windows 8 Operating
Systems

Relevant for: GUI tests and components and API testing

UFT applications and files that were accessible from theStartmenu in previous versions of
Windows are accessible inWindows 8 from theStart screen or theApps screen.

l Applications (.exe files). You can access UFT applications inWindows 8 directly from the
Start screen. For example, to start UFT, double-click theHP Unified Functional Testing

shortcut .

HP Unified Functional Testing (11.52)Page 15 of 57

API Testing Tutorial
How do I invoke the application?



Other examples of applications accessible from theStart screen include:

n The RunResults Viewer

n All UFT tools, such as the Password Encoder and the License Validation Utility

n The API testing sample Flight applications

l Non-program files. You can access documentation and the link to theMercury Tours Website
from theApps screen.

Note: By default, the Start and Apps screens onWindows 8 are set to open Internet Explorer in
MetroMode. However, if User Account Control is turned off on your computer, Windows 8 will
not open Internet Explorer in Metromode. Therefore, if you try to open an HTML shortcut from
the Start or Apps screen, such as the UFT Help or Readme file, an error will be displayed.

To solve this, you can change the default behavior of Internet Explorer so that it never opens in
Metromode. In the Internet Properties dialog box > Programs tab, select Always in Internet
Explorer on the desktop for the in theChoose how you open links option. For more
details, see http://support.microsoft.com/kb/2736601 and
http://blogs.msdn.com/b/ie/archive/2012/03/26/launch-options-for-internet-explorer-10-on-
windows-8.aspx.

Where To Go From Here
Now that you have invoked the application, you can begin creating tests for your headless
applications using the sample API Flights application. The following lessons will walk you through
the process of creating a test for basic activities, Web, and REST services.
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Chapter 2: Build a Simple Test
This lesson will guide you through the steps of creating tests with simple actions.

This lesson contains the following sections:

How do I create a new test? 18

How do I work with the UFT panes? 19

How do I create a test step? 19

How do I connect test steps? 22

How do I map data frommultiple sources? 24

How do I data drive the step? 26

Where ToGo From Here 28
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How do I create a new test?
The canvas is the central console in which you build and run your test.

1. Open HP UFT.

ChooseStart > (All) Programs > HP Software > HP Unified Functional Testing >
Unified Functional Testing. The Start Page opens.

Note:Whenworking inWindows 8, you can access UFT directly from theStart screen.

For details on accessing UFT tools and files inWindows 8, see "Accessing UFT in
Windows 8Operating Systems" on page 15.

2. Create a new test.

Click File > New > Test. The New Test dialog box opens. Select theAPI Test type. On
machines with an installation of HP LoadRunner, theAPI Load Test type is also visible.

3. Generate the new solution.

In theName box, replace the default namewithBasicTest, and click Create. An empty test
opens, with a canvas showing theStart, Test Flow, andEnd sections.

The Test Flow is the section of the test containing the activities whose functionality you want
to test. TheStart section is ideal for defining items that you want to initialize before the test,
such as test variables.
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How do I work with the UFT panes?
Most of the panes in the UFT interface, are floating, dockable windows. To show the default panes
in their original positions, select View > Reset Window Layout.

The primary panes are:

l Solution Explorer pane. (left) A tree hierarchy of all tests and actions in the current solution,
with their references, flow, and events.

l Toolbox pane. (left) A collection of built-in and imported activities that can be added as test
steps. From this pane, you drag activities into the canvas.

l Canvas. (middle) The work area in which you organize the test steps.

l Properties pane. (upper right) A multi-view window that lets you view and set properties for the
step selected in the canvas. The common views areGeneral, Input/Checkpoints, andEvents.
To change a view, click on a button in the Properties pane's toolbar.

l Data Pane. (bottom) A tree hierarchy of data sources that can be used with the test—imported
Excel and XML files or database tables, or amanually defined table.

l Output Pane. (bottom) An informational area providing information about the test run and status.

How do I create a test step?
You create test steps by dragging activities from the Toolbox pane into the canvas.

In this section you will create a simple test step to illustrate the use of the Toolbox and the various
panes.

Create a sample Replace String test step:

1. Locate the Replace String activity.

In the left pane, click the Toolbox tab to show the Toolbox pane. Expand theString
Manipulation category and select Replace String.

2. Create a step.

Drag theReplace String activity onto the canvas and drop it in the Test Flow. This activity
searches for text within a specific string, and replaces it with new text. Alternatively, double-
click the activity in the Toolbox to add it to the canvas.
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3. Change the step's display name in the General view.

Select View > Properties. Select theReplace String step in the canvas, and in the

Properties pane, click theGeneral tab . In theName row, typeChange Text and press
ENTER. This changes the step name in the canvas.

4. Set the input properties.

In theProperties pane, select the Input/Checkpoints tab. Enter the following values:

n Source string: Hello world.

n Search string: Hello

n Replacement string: Goodbye
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n Case-sensitive: false

5. Run the test.

Click theRun button or press F5 to open the Run Test dialog box. Click Options to expand
the dialog box. Select the Temporary run results folder option. Click Run to compile and run
the test.

6. View the results.

The RunResults Viewer opens.

Select View > Expand All or click the Expand All toolbar button. Click theChange Text
node. View the source and replacement strings and note the result string, Goodbye world.
This is in fact the expected string—the test passed.

When you are finished reviewing the results, close the Run Results Viewer.
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7. Set a checkpoint.

In the previous step, youmanually viewed the output to check if the result matched the
expected value. Checkpoints allow you to see whether the action was successful without
having tomanually check the result. Checkpoints are themeans to validate the test—a
success or failure is determined by its checkpoints.

Return to the Properties pane (right pane) and ensure that the Input/Checkpoints tab is
displayed. Click in the lower part of the pane, theCheckpoints section, and select the check
box in theResults row to enable the checkpoint. In theExpected value column, type the
expected string, Goodbye world.

Run the test again. In the Run Results Viewer, expand the nodes, and note the checkmark.
This indicates that the checkpoint passed since the result matched the expected value.

When you are finished reviewing the results, close the Run Results Viewer.

How do I connect test steps?
In this section, you will use the output of one step, as input for another.

1. Add a Concatenate String step.

In the Toolbox pane, select Concatenate String from theString Manipulation category.
Drag the activity into the canvas and drop it below the Change Text step in the Test Flow.
This activity concatenates two strings.

2. Set the prefix.
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In the canvas, select theConcatenate String(x) step. In theProperties pane, click the

Input/Checkpoints tab. In the upper Input section, move themouse into theValue cell of
thePrefix row. Click the Link to a data source button . The Select Link Source dialog box
opens.

3. Link the steps.

In the Select Link Source dialog box, select theAvailable steps option. Select the Test Flow
> ChangeText node. In the right pane, double-click theResults node. The canvas now
reflects that data is moving from Change Text toConcatenateString.

4. Configure the suffix.

In theProperties pane, type the text Welcome to the Basic Test. into theSuffix
property's Value field.
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5. Run the test.

Click theRun button or press F5 to run the test.

6. View the report.

Expand the Run Results tree and select theConcatenateStringsActivity node. The report
shows the result of the concatenated strings: Goodbye World.Welcome to the Basic Test.

When you are finished reviewing the results, close the Run Results Viewer.

How do I map data from multiple sources?
Using the Select Link Source dialog box, you can link to one or more of the following data sources
to provide input values: Available steps, Data source column, and Test variables. In the above
section, you used theAvailable steps source for one value, andmanually typed in the data for
another value.

You can create a custom expression to usemultiple data sources as a property value. In this
section, you will use the Select Link Source dialog box to create an expression for theSuffix
property that uses bothmanual entry and automatic values from theAvailable steps option.

1. Set the prefix.

In the canvas, select theConcatenateString step. Open the Input/Checkpoints tab in
the Properties pane. Click in theValue cell of thePrefix row and click the to clear the
contents. Type a new prefix Hello world.

2. Open the Select Link Source dialog box.

Click in theValue cell of theSuffix row and click to clear its contents. Click the Link data
to source button . The Select Link Source dialog box opens.

3. Edit the suffix.

In the Select Link Source dialog box, click theCustom Expression button to expand it. In the
Expression box, type the following:" was replaced with " (adding a space before and
after the phrase to improve the readability).
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4. Add another source.

Select theAvailable steps option and select theChange Text node in the left pane. Select
theResult node in the right pane, and click Add. TheExpression box shows both sources.

5. Run the test and view the report.

Click theRun button to run the test. Expand the results and select the
ConcatenateString node. The report shows the result of the concatenated strings.
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6. Close the Run Results Viewer window.

How do I data drive the step?
Data driving is the assigning of data to test steps from a data source, such as an Excel or XML file,
database, or local table. The goal of data driving is to run the same business process with different
values. It allows you to check your application in different scenarios, by modifying only the data
tables.

To data drive test steps

1. Data drive the input arguments.

Select theChange Text step in the canvas. Open the Input/Checkpoint tab in the Properties

pane, and click theData Drive button. The Data Driving dialog box opens.

2. Specify a data provider.

In the Data Driving dialog box:

a. Set theData Provider type to Excel.

b. Enable data driving forBoth Input and Checkpoints.

c. Clear theConfigure 'Test Flow' as a ForEach loop using the new data source option,
which repeats the Test Flow according to the number of data rows. You will manually set
the number of iterations in a later step.

d. Click OK to close the Data Driving dialog box.

e. Accept the popupmessage. The data drivingmechanism replaces the constant values
with the new expressions, {DataSource.Change Text_

Input!MainDetails.SourceString}.
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3. View the Data pane.

Make sure the Data pane is visible. If not, chooseView > Data. Expand theChange Text_
Input node and select theChange Text_Input!MainDetails node. The data pane shows a
data table with a column for each input property, and one row of values corresponding to the
property, Hello World. and FALSE (or empty check box for installations without Excel) that
you entered earlier.

4. Add new data.

Add two additional rows to theChange Text_Input!MainDetails table. Make sure to copy the
text exactly, including punctuation where included.

MainDetailsKey SourceString CaseSensitive

1 Hello world. FALSE

2 I like eating broccoli. TRUE

3 The product version is 11. FALSE

5. Add new search and replace data.

Click the Text_Input!SearchReplaceString node and add two additional rows to the table.
Make sure to copy the text exactly, including punctuation where included.

MainDetailsKey Key Value CaseSensitive

1 Hello Goodbye FALSE

2 broccoli ice cream TRUE

3 11 12 FALSE

6. Add checkpoint values.

Expand theChange Text_Checkpoints node and select theChange Text_
Checkpoints!MainDetails node. Add values to this column as shown below.

Note: In the third row, we will intentionally insert an exclamation point (!) to generate an
error.
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Result

Goodbye world.

I like eating ice cream.

The product version is 12!

7. Set the number of iterations.

The number of iterations is the number of times to repeat the step. Wewill set it to 3,
corresponding to the number of rows of data in our table.

Return to the canvas and click inside the Test Flow frame—but not within a test step. Open the
Input/Checkpoint view in the Properties pane. Select 'For' Loop and set theNumber of
Iterations to 3.

8. Run the test and view the report.

Click theRun button or press F5 to compile and run the test. The test runs three times,
using the three lines of data in the table.

After the test run, the Run Results Viewer opens. Expand the Test Flow node and drill down to
the row with the redX, indicating a failed checkpoint. The checkpoint failed because the
expected result contained an exclamation point, which was not present in the source string.

9. Correct the error and rerun the test.

In the Data pane, correct the dataChange Text_Checkpoints!MainDetails node. In the third
row of theResults column, for the checkpoint, replace the exclamation point with a period.

Run the script again and verify that you have no errors in the report.

Where To Go From Here
Now that you have learned to create simple test steps, you can create steps usingWeb services.
The following lessons will walk you through the process of importingWSDLs and creatingWeb
service tests.
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Chapter 3: Test a Web Service
UFT API Testing allows you to create tests for yourWSDL-basedWeb services.

This lesson contains the following sections:

How do I import aWeb service? 30

How do I build aWeb service test? 31

How do I integrate data into a test? 36

How do I usemultiple data sources and custom code? 39

Where ToGo From Here 42
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How do I import a Web service?
AWSDL file defines the operations in aWeb service. To use theWSDL file, you import it into your
test. This section shows you how to import the sample application's WSDL file.

1. Start the Sample Flight application.

Make sure that the Flight Application service is available, as described in "How do I invoke the
application?" on page 15.

2. Create a new solution.

Select File > New > Test and specify the nameWebServiceTest for a new API Test. Click
Create.

3. Open the Import Service dialog box.

Select Import WSDL > Import WSDL from URL or UDDI on the toolbar.

4. Specify an import source.

Select theURL option and specify the location http://localhost:24240/HPFlights_
SOAP?wsdl. Click OK.

5. View the service's operations.

The import created a new branch of Web service operations in the Toolbox, under theWeb
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Services category. Expand the node to view the operations.

How do I build a Web service test?
In this section, you will create a new flight order using theHPFlightsWeb service.

In order to create a flight order, youmust first know the available flights. First you will run the
GetFlights step that retrieves all of the flights to your destination. In the next step, you will use the
first flight number returned, as input for theCreateFlightOrder step.

1. Create a GetFlights step.

Expand theWeb services > HPFlights_Service node and drag theGetFlights activity into
the Test Flow.

2. Assign values for DepartureCity and ArrivalCity.

Open the Input/Checkpoints tab and expand theBody > GetFlights node. To select a
city, click the arrow in the row to open a drop down list. Choose Denver as theDepartureCity
and Los Angeles for theArrivalCity.
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3. Create a CreateFlightOrder step.

Drag theCreateFlightOrder activity from the toolbox into the Test Flow, beneath the
GetFlights step.

4. Set the values for the CreateFlightOrder step.

In the Input/Checkpoints tab , expand theBody > CreateFlightOrder > FlightOrder
node, and set the values for creating a flight order:

n Class—Select a class, such as Businessfrom the dropdown list.

n CustomerName—any value
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n DepartureDate—use the dropdown to open a calendar and select a date at least two days in
the future.

n FlightNumber—leave blank for now. Wewill set it in the following steps.

n NumberofTickets—use the scroller to set any value.

5. Link the output of GetFlights to the CreateFlightOrder step.

a. Click the Link to a data source icon in the right corner of the FlightNumber row. The
Select Link Source dialog box opens.

b. Select Available steps and select theGetFlights node.

c. In the right pane, select the Input/Checkpoints button. In theOutput section, expand all
nodes under theBody node. Click theAdd button in the Flight (array) node row to
create the Flight[1] array.

d. Expand the Flight[1] array, select the FlightNumber element, and click OK. The
application asks if you want to enclose the target step in a loop. Select No.
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The canvas indicates a connection between the two steps.

6. Reset the number of iterations.

The number of iterations is the number of times to repeat the step. Return to the canvas and
click inside the Test Flow frame—not within the test step. Open the Properties pane's

Input/Checkpoints tab . Select For Loop and set theNumber of Iterations to 1.

7. Run the test.

Click theRun button. Observe the log in theOutput tab. The Run Results Viewer opens
automatically.

8. Check the results.

In the left pane, click the parent node and select Expand All from the right-click menu. Click
theCreateFlightOrder node. In theCaptured Data pane, scroll down to theWeb service Call
HTTP Snapshot section and look at the Response pane. Note the output of the request—
OrderNumber and TotalPrice. Copy the TotalPrice value to the clipboard for use in the next
step.
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Tip: Click theRequest orResponse links to open the SOAP in a separate browser.

When you are finished viewing the results, close the Run Results Viewer.

9. Set a checkpoint.

Select theCreateFlightOrder step in the canvas. Open the Properties pane's
Input/Checkpoints tab, click in the Checkpoints grid, and expand the
CreateFlightOrderResponse node. Paste the clipboard contents from the previous step into
the TotalPrice field. Select the check box in the TotalPrice row, to include it as a checkpoint.

10. Run the test and view the checkpoint results.

Run the test again and expand the results tree. Select theCheckpoints node for
CreateFlightOrder. The report shows a checkmark and indicates the expected and actual
values. If the expected value was not returned by the server, the report indicates a failure.

When you are finished viewing the results, close the Run Results Viewer.
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How do I integrate data into a test?
In this section you will learn how to integrate data from an existing source, and how to data drive the
test. When you data drive a test, the Data pane automatically creates a data table whose values
you can edit.

1. Import Sample Data

In the Data pane, in the bottom of the UFTwindow, select New > Excel. The Add New Excel
Data Source dialog box opens.

a. Browse for the sample application's Excel file, SampleAppData.xlsx, in the
<installation directory>\SampleApplication folder..

b. Enable theExcel file contains header row option, since the sample file contains a header
row.

c. Enter WS_Flights as aData source name.

d. Select Referenced Data Source as themode of import. This links to the Excel file at its
original location, so that if data changes, your data source will be current.

e. Click OK.

2. Open the Select Link Data dialog box.

Select theCreateFlightOrder step in the canvas and open the Input/Checkpoints view. In
the Input section, expand all the nodes and select theClass row. Click the Link to a data
source icon . The Select Link Source dialog box opens.

HP Unified Functional Testing (11.52)Page 36 of 57

API Testing Tutorial
How do I integrate data into a test?



3. Select a value from the data source.

Select theData source column option.

4. Use the sample Excel data.

Select theWS_Flights!Input node, and select Class in the right pane. Click OK. This
instructs the test to refer to this column in the sample data during the test run.

Repeat this for the other input parameters: CustomerName, DepartureDate, FlightNumber,
andNumberofTickets.

5. Disable the checkpoint.

In the Input/Checkpoint view, click in the Checkpoints grid. Clear the check box for the
TotalPrice property, to exclude it as a checkpoint.

6. Set the navigation settings.

The navigation settings let you indicate how to use the data in your data source. You can
specify from which row to begin, how many rows to advance, and in what direction tomove for
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the next set of values. You can also specify what to do when reaching the end of the data
table—wrap around or continue using the last line.

a. In the canvas, click in the Test Flow but not within a step.

b. In the Properties pane, click theData Sources tab button .

c. Select theWS_Flights!Input node and click Edit to open the Data Navigation dialog box.

d. Specify the data navigation details: Start at: First row,Move: Move by 3 rows
Forward, End at: Last row, andUpon reaching the last row: Wrap around.

e. Click OK.

7. Run the test and view the results.

Click theRun button and observe the results in the Output window. The Run Results
Viewer opens automatically. Expand the result tree and select theCreateFlightOrder step.
Scroll downwithin theCaptured Data tab and note the data from the Excel file in the SOAP
request (left pane), and the result in the SOAP response (right pane).
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When you are finished viewing the results, close the Run Results Viewer.

How do I use multiple data sources and
custom code?

This section describes how to define data usingmultiple data sources and sending information to
the report through a custom code step.

1. Create a new test.

Create a new test called WebServicesCustom and import the HP Flights Services WSDL as
described in "How do I import aWeb service?" on page 30.

2. Create test steps.

Drag the activities into the canvas in the following order: From theWeb services folder:
GetFlights andCreateFlightOrder. From theMiscellaneous folder, drag inCustom Code.

3. Add a data source.

In the Data pane, select New > Excel. In the Add New Excel Data Source dialog box:

a. Browse for the sample application Excel file in the installation
directory>\SampleApplication folder.

b. Select theExcel file contains header row check box.

c. Enter WS_Flights as aData source name.

d. Select theReferenced data source mode.

4. Assign values for GetFlights.

Select theGetFlights step in the canvas and open the Input/Checkpoints tab in the
Properties pane. In the Input section, select DepartureCity= Denver, andArrivalCity=Los
Angeles.

5. Assign values for the CreateFlightOrder.

Select theCreateFlightOrder activity in the canvas and open the Input/Checkpoints tab.
Expand theBody > FlightOrder node and set the input properties as follows:

n Class. Economy

n CustomerName. Click the Link to a data source button in the right corner of the
CustomerName row. The Select Link Source dialog box opens. Select Data source
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column, and expand the tree to show theWS_Flights!Input node. In the right pane, select
theCustomerName parameter. Click OK.

n DepartureDate. A date in the following format DD-MM-YYYY THH:MM:SS For example,
02-18-2012 T00:00:00. Use the drop down arrow to open the calendar. The datemust
be at least two days ahead of the current date.

n NumberofTickets. 3

n FlightNumber. Link from the previous step:

i. Click the Link to a data source button in the right corner of the FlightNumber
row.

ii. In the Link to Source dialog box, select Available steps, expand the Test Flow
branch, and click GetFlights.

iii. In the right pane, select the Input/Checkpoints button .

iv. In theOutput section, click theAdd button in the Flight (array) node row to create
the Flight[1] array. Expand the array, select FlightNumber, and click OK.

6. Create a property for the custom code step.

Select theCustom Code activity in the canvas and open the Input/Checkpoints tab in the
Properties pane. Expand theAdd Property toolbar button and select Add Input Property.
Create a new String type property called FlightInfo.

7. Define values for the custom code step.

In this step you will define a value usingmultiple sources. In this example, you will set a value
which is a combination of theCustomerName, a constant string, and theOrderNumber:

a. Click the Link to a data source button in the right corner of the FlightInfo row. The
Select Link Source dialog box opens.

b. Click Custom Expression to show the Expression area.

c. Select theData source column option. In the tree'sWS_Flights!Input node, select
CustomerName. Click Add.

d. In theExpression area, type _OrderNumber_ (with the underscores) after the existing
expression.

e. Select Available steps and expand the Test Flow branch. Select theCreateFlightOrder
node. In the right pane, select the Input/Checkpoints button
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. In the lower pane, expand theOutput Body node, expand the tree, select the
OrderNumber element, and click Add.

The CustomCode input property, FlightInfo, has the following value:

{DataSource.WS_Flights!Input.CustomerName}_OrderNumber_

{Step.OutputProperties.StServiceCallActivity

(x).Body.Cre-

ateFlightOrderResponse.CreateFlightOrderResult.OrderNumber}

Click OK to close the dialog box.

8. Create an event.

In this step you will create an event handler in order to use the Application Program Interface
(API). You can add C# code to this section. Defining events let you adapt your test to your
custom requirements, and perform actions that are not built-in to UFT. In this example, you will
add code that sends a custom string to the report.

Select theCustom Code step in the canvas. In the Properties pane, click theEvents
button. In theExecuteEvent row, click the drop down arrow and select Create a default
handler. UFT creates an event calledCodeActivity(x)_OnExecuteEvent and opens a new
tab TestUserCode.cs.

9. Edit the "Todo" section, using the Index assigned to the activity.

Replace the commented text in the Todo section with the following:

CodeActivity(x).Report("Customer and Order Number",CodeActivity

(x).Input.FlightInfo);

In the following example, the index assigned to the event was 12, so the string is
CodeActivity12.Report("Customer and Order Number",

CodeActivity12.Input.FlightInfo);.

10. Run test and check the results.
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Drill down in the results to theCustom Code step. Note the new entry in theCaptured Data
pane: Customer and Order Number.

Tip: You can also use theReport Message activity under theMiscellaneous folder, to
send text and property values to the report.

Where To Go From Here
Now that you have learned to create a test for aWeb service, you can relate this to other types of
services and application components. The next lesson will walk you through the process of creating
a test for a REST service.
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Chapter 4: Test REST Services
Using UFT API Testing, you canmodel and create tests for REST services.

This lesson contains the following sections:

How do I create a REST service activity? 44

How do I run a REST test? 47

How do I assign data tomy RESTmethod? 49

How do I check my output? 53

How do I resolve changes inmy REST service? 54
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How do I create a REST service activity?
This section describes how tomodel a REST service activity using the sample application. A best
practice for working with REST services is to create a reusable prototypemethod for the REST
service. Once you create this method, you can reuse it in different test steps or separate tests.

1. Start the Sample Flight application.

Make sure that the Flight Application service is running, as described in "How do I invoke the
application?" on page 15.

2. Obtain the REST service modelling document.

In the Sample Application commandwindow, type h, and press ENTER. A browser opens with
themodelling information for the REST service. This file, index.htm, is located in the
<installation_folder>\SampleApplication\Help folder.

3. Save the Request body to a file.

Copy the Request Body for FlightOrders > ReserveOrder (POST) to the clipboard. Only
copy the XML code. Modify the date to a future date after copying the XML.

<FlightOrderDetails xmlns="HP.SOAQ.SampleApp" >

  <Class>Business</Class>

  <CustomerName>John Doe</CustomerName>

  <DepartureDate><future date></DepartureDate>

  <FlightNumber>1304</FlightNumber>

  <NumberOfTickets>21</NumberOfTickets>

 </FlightOrderDetails>

Create a new file in a text editor and paste the contents of the clipboard. Save the file as
body.xml to any location.

4. Obtain the REST service endpoint URL.

Return to the browser window and copy the URL for the FlightOrders > ReserveOrder
(POST) operation, http://localhost:24240/HPFlights_REST/FlightOrders/,to
the clipboard.

5. Create a new test.

a. Select File > New > Test and select anAPI Test type.

b. Specify the nameRESTServiceTest for the new test.

c. Click Create.

6. Add a REST service.

a. Click theAdd REST Service toolbar button . The Add REST Service dialog box
opens.

b. In the left pane, click on theNew Service node and rename it toSampleRESTService.

7. Add a resource.
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Click the toolbar's Add Resource button and rename the resource to FlightOrders.

8. Add a method to the REST service.

Click theAdd Method button and rename themethod toReserveOrder.

9. Configure the REST service URL.

a. In the left pane, select theSampleRESTService node .

b. In the right pane, select theGeneral tab.

c. In the URL property row, paste the URL prefix: http://localhost:24240.

d. Return to the left pane and select the FlightOrders node. Note that the value you pasted in
the URL property field for theSampleRESTService node has been passed to the
FlightOrders resource.

e. In theGeneral tab of the right pane, paste /HPFlights_REST in theRelative
URL property row. After you paste this value here and select an area outside the property
value row, the /HPFlights_REST is added to the URL prefix value from the
SampleRESTService node.

f. In the left pane, select theReserveOrder node.

g. In theGeneral pane of the right pane, paste /FlightOrders/ in theRelative URL value
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row. This addition is appended with the URL property value passed from the FlightOrders
node of your REST service.

10. Configure additional HTTP properties.

Open theHTTP Input/Checkpoints view in the right pane.

a. Set theHTTP method toPOST.

b. Click theAdd button in theRequest Headers (array) row to add an array element.

c. Expand theRequest Headers array. Using themethod's details from the Help page, set
the header name and value as follows:

o Name row—Content-Type

o Value row—text/xml

11. Create input properties.

a. Open the Input/Checkpoint tab in the right pane.

b. Select Add > Add Input Property.

c. Add aString type property calledClass.

d. Add anotherString type property calledCustomer_Name.

e. Add anotherDate/Time type property calledDeparture_Date.

f. Add an Int type property called Flight_Number.

g. Add another Int type property calledNumber_of_Tickets.

12. Create Output properties.

a. Select Add > Add Output Property.

b. Add a Int type property called Total_Price.

c. Add another Int type property calledOrder_Number.

13. Import the Request body.

a. Open theHTTP tab in the right pane.

b. Select XML as theBody type.
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c. Click the Load XML button and load the body.xml file that you saved earlier.

14. Test the method.

Click theRun Method toolbar button to check the validity of themethod. Scroll through
the results and verify that the response body contains an order number and price.

15. Add the method to the Toolbox.

Click OK in the Add REST Service dialog box. The REST designer adds the REST service,
along with its resource andmethod to the Toolbox pane, under the Local Activities category.

16. Share the REST activity to make the activity available for all tests.

In the Toolbox pane, select the parent node of the REST service, SampleRESTService, and
selectMove to > File System Activities from the right-click menu. The REST service
activity is now moved to the File System Activities section in the Toolbox pane.

You have now created a prototype activity for your REST service, complete with input parameters
and the HTTP information. You can now drag the activity into tests and run it with little intervention.

How do I run a REST test?
This section describes how to run the REST servicemethod created in the previous section. You
will incorporate data into the test, using the sample data file included with the product.
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1. Create a test step.

Double-click the File System Activities > REST Services > SampleRESTService >
FlightOrders > ReserveOrdermethod to add it to the Test Flow on the canvas.

2. Click theReserveOrder activity and open theHTTP tab in the Properties pane.

Note: If you are working with an API test created in UFT 11.51 or earlier or Service Test
11.51 or earlier, youmust expand the REST activity's wrapper and enter these properties
in the HTTP Request step found inside the REST activity wrapper.

The property values are those which we imported earlier from the body.xml file. These values
were used in the test run that we just performed.

3. Run the test.

Select Run > Run to run the test.

4. View the report.

In the Run Result Viewer's left pane, click theExpand All button or select Expand All
from the right-click menu and select theHTTP Request node.

In theCaptured Data pane, click theResponseBody link to open the response in a separate
browser window.
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Verify that theResponse Body contains values for theOrderNumber and TotalPrice
elements. This corresponds to the operation's description in the REST Service Help page that
indicated the following: It creates a new flight order and returns

OrderNumber and TotalPrice.

- <CreatedOrderParams xmlns="HP.SOAQ.SampleApp"

xmlns:i="http://www.w3.org/2001/XMLSchema-instance">

<OrderNumber>18</OrderNumber>

<TotalPrice>3717</TotalPrice>

</CreatedOrderParams>

How do I assign data to my REST method?
In order to assign data to our method, we will link the inner HTTP Request properties to the outer
REST wrapper properties. This allows us to control the properties of the request message from the
higher level, the RESTmethod level.

To assign data to the REST method step:

1. Select the REST activity and open theHTTP tab in the Properties pane.

2. Click the Link to a data source button in the right corner of theClass row. The Select Link
Source dialog box opens.

3. Select Available steps as a data source, select theReserveOrder node in the left pane, and
choose theClass property in the right pane. Click OK.
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4. Repeat the above step for the other input properties: CustomerName, DepartureDate,
FlightNumber, andNumberofTickets. The resulting HTTP view shows the new links.

5. Import sample data.

Wewill import a data source whose values wewill use for the RESTmethod properties.

a. In the Data pane located in the lower section of the window, expand the Data Source

button and select Excel. The New Excel Data Source dialog box opens.

b. Click the Browse button adjacent to theExcel file path field, and browse to the
sample application's SampAppDataExcel file in the <installation
directory>\SampleApplication folder.
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c. Select theExcel file contains header row check box, because the sample contains a
header row.

d. In theData source name field, enter REST_Flights.

e. Select theMake a copy of the Excel file option. This saves a copy of the data file with
the test.

f. Click OK. The data is imported into the Data pane.

6. Link the REST method properties to the data source.

a. Select the outerReserveOrder frame and open the Input/Checkpoints tab in the right
pane.

b. Click the Link to a data source button in the rightmost corner of theClass row. The
Select Link Source dialog box opens.

c. Select Data source column as a data source, select the REST_Flights!Input node in the left
pane, and choose theClass property in the right pane. Click OK.

d. Repeat the above step for the other input properties: Customer_Name, Departure_Date,
and Flight_Number.

e. Enter 2 for theNumber_of_Tickets.
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f. The resulting properties view shows the new links.

7. Set the iterations.

By setting iterations, we will see how our RESTmethod usedmultiple sets of data from the
data source.

a. Select the Test Flow frame in the canvas and open the Input/Checkpoint view in the
right pane.

b. Set a For Loopwith 3 iterations.

8. Run the test.

Select Run > Run to run the test.

9. Verify that the request used the table data.

Run the test. In the Run Result Viewer's left pane, click theExpand All button and select
theReserveOrder nodes. Click theRequest Body link in the Captured Data pane. Note that
the test used the data from the Data pane for the properties that we assigned: Class,
CustomerName, DepartureDate, and FlightNumber.

- <FlightOrderDetails xmlns="HP.SOAQ.SampleApp" >

<Class>Business</Class>

<CustomerName>John Freeman</CustomerName>

<DepartureDate>2012-12-12</DepartureDate>

<FlightNumber>1304</FlightNumber>

<NumberOfTickets>21</NumberOfTickets>

</FlightOrderDetails>
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10. Save the response data.

Wewill save the response data from this run for use in future steps.

a. In the Run Result Viewer's left pane, select anReserveOrdernode. Click theResponse
Body link in the Captured Data pane. A browser window opens with the XML response.

b. Save the entire contents of the window to a file Response.xml. Close the Run Results
Viewer.

How do I check my output?
In order to verify that the output of our RESTmethod is correct, we will set checkpoints.

1. Insert a checkpoint.

a. Select the activity in the canvas and open theHTTP tab in the Properties pane.

b. The lower section of the pane contains the output properties or output schema. Wewill use
these as our checkpoints to check the server response. In the lower pane, select XML from
theBody drop-down.

c. Click the Load XML button and load the Response.xml file that you saved earlier. Select
theValidate checkbox in theOrderNumber and TotalPrice rows.

d. Set the value of OrderNumber to Greater than (>) 10, and the value of TotalPrice
to Less than (<) 255.

2. Run the test.

Select Run > Run to run the test.

3. Verify that the checkpoint passed.

Run the test. In the Run Result Viewer's left pane, click theExpand All button . Note that
some of the checkpoints passed, while others did not.
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4. Determine why checkpoints failed.

Select one of the failed checkpoints nodes. In the right pane, view the Captured Data pane and
note the Actual Results and Expected Values. In the following example, theOrderNumber
was valid, but the TotalPricewas not valid because it exceeded 255.

5. Save the test.

Close the Run Results Viewer and save the test.

How do I resolve changes in my REST
service?

Initially, we created a prototype REST servicemethodReserveOrder, with specific properties,
such as the URL and property names. If these properties changed after you created a test, your test
step will no longer match the prototype. The Resolve Conflict wizard detects changes in the
method's properties and helps you resolve them.

1. In the Toolbox pane, select theReserveOrder node and chooseEdit Service from the right-
click menu. The Edit REST Service dialog box opens.

2. Select theReserveOrdermethod and open theCustom Input/Checkpoint tab in the right
pane.

3. Select the Flight_Number property, and click theEdit Property toolbar button. In the Edit
Property dialog box, rename the property to Flight_Number_1. Click OK.

4. Select theNumber_of_Tickets property, and click theDelete Property toolbar button.
Confirm the warning and click OK.

5. Click OK in the Edit REST Service dialog box.

6. View the canvas. Note the alert icon in the bottom right corner of the RESTmethod frame.

7. Click on the drop-down arrow adjacent to the alert icon, and select the text message: This
step should be resolved. Resolve step.The Resolve RESTMethods Wizard

HP Unified Functional Testing (11.52)Page 54 of 57

API Testing Tutorial
How do I resolve changes inmy REST service?



opens.

8. The wizard's first screen shows the problematic steps. If multiple steps were affected, you
could choose which steps to resolve and which to ignore. Click Next.

9. In the Resolve Conflicts screen, select theNumber_of_Tickets property in the right pane,
After changes. Click Keep. This instructs the existing step to keep the property, even though
it was removed from themethod's prototype.

10. In theAfter changes pane, select the old property Flight_Number and click Remove. Flight_
Number is now obsolete. Instead, themethod will contain the new, automatically detected
property, Flight_Number_1.

Scroll through the lower section of the wizard screen to see a log of all of the conflicts and their
resolutions.

11. Click Next. Click Finish to close the wizard and return to your test.
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Chapter 5: Where To Go From Here
Now that you have learned to create tests with standard activities, Web services, and REST
services, you can create your own tests for your GUI-less applications.
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