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1 Asset Discovery

Overview of Asset Discovery

Storage Visibility and Automation collects storage information from Storage Essentials (SE) discovery and
enables storage information in Server Automation (SA).

*  Host server storage information is discovered by the Storage Host Agent Extension in Storage Visibility
and Automation—and not by SE discovery.

»  Database storage information is discovered by a Storage Scanner in Storage Visibility and
Automation—and not by SE discovery.

SE discovers information about the SAN arrays, switches, fabrics, and NetApp filers in your environment.
SA obtains information about these storage assets from SE. Storage assets that are enabled in SA include
SAN arrays, fabrics, controllers, and zones. Storage Visibility and Automation also provides information
about connectivity, such as the relationship of a switch and a managed server. Edge information is also
provided; however, not all fabric switches are displayed.

Data Collection

Storage information is discovered in SE and then collected by Storage Scanners in Storage Visibility and
Automation.

Information about storage arrays, switches, fabrics, and NetApp filers in your environment is collected by a
component in SA called SE Connector. SE Connector retrieves data about the SAN infrastructure from SE.
This storage data is transferred to the SA core and stored in the Model Repository. See SE Connector on
page 12 for more information.

Information about Oracle storage configurations in a SAN or Network Attached Storage (NAS) is collected
by a component in Storage Visibility and Automation called the Database Scanner for Oracle. This Storage
Scanner retrieves data about Oracle instance, tablespaces, and datafiles. See Database Scanner for Oracle on
page 15 for more information.

Storage Scanners

There are two types of Storage Scanners that collect storage data:
*  SE Connector

e Database Scanner for Oracle

17



f

SE Connector

Storage Essentials (SE) version 6.1.1 or later and Server Automation 7.80 or later are required to configure
and deploy SE Connector. SE is required to view, report, or perform any Service Automation Visualizer
(SAV) and Service Automation Reporter (SAR) operation on SAN objects, such as arrays, switches,
volumes, and so on. SAN objects are discovered in Storage Essentials. To enable discovered SAN objects in
the SA, SAV, and SAR products, the Server Automation SE Connector component must be installed and
configured. See the HP Server Automation: Storage Visibility and Automation Installation & Administration
Guide for information about configuring and deploying SE Connector.

SE Connector collects data from Storage Essentials (SE) about SAN elements and inventory, and their
connectivity. These SAN elements include storage arrays, fabrics, switches, and NAS filers.

In the user interface, SE Connector is referred to as SE Storage Scanner.

The frequency of collecting this storage data is configured by the user. By default, SE Connector collects
SAN information from SE once every 12 hours. This action is commonly known as a scheduled full
synchronization. You can adjust the collection frequency by modifying a setting in SE. In SE Connector, you
can specify the maximum wait time (in minutes) for a scheduled full synchronization when the Get All
Elements Detail (GAED) process in SE is in progress. The following property specifies the maximum
default wait time for a scheduled full synchronization task when GAED is in progress:

com.creekpath.agent.common.devices.scheduled. full.sync.max.wait.minutes=10080

A “GAED IN PROGRESS” value in the Status column on the Storage Scanner Storage Essentials panel
indicates that a Get All Elements Details (GAED) discovery process is currently running on the Storage
Essentials server.

When Storage Essentials is processing GAED, by default SE Connector will wait 10080 minutes (7days)
before it will proceed to collect data from Storage Essentials, even though a GAED discovery process is still
running. SE Connector will check SE every 3 minutes (by default) and will run the collection if the SE
GAED process finishes sooner or the SE Connector has waited longer than the interval configured for “Full
Data Collection Minutes” in SEPlugin.Properties.

Check the Storage Essentials (connection) Status to determine whether the GAED process is still running.
Check the Last Scan timestamp for Managed Elements for that Storage Essentials instance to determine
when SE Connector last updated the information for those elements.

The following property specifies the maximum default wait time for a scheduled full data collection task
when GAED is in progress:

com.creekpath.agent.common.devices.full.data.collection.minutes=720
The following describes a typical use case:

*  You configure SE Connector to collect information from Storage Essentials once a day.

»  Storage Essentials is busy processing GAED for 2 days.

*  You do not see updated information for Managed Elements for the Storage Essentials instance in Server
Automation.

*  You can use a combination of the Storage Essentials connection Status value and Last Scan timestamp
for Managed Elements to determine if there is a lengthy GAED process running for SE and the SE
Connector is not updating information for those Managed Elements. This explains why information for
Managed Elements is not getting updated as per the scheduled frequency.
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Attaching and Remediating the SE Storage Scanner and SE Connector Update Policies

This section describes the steps to follow when you attach and remediate the SE Storage Scanner
and SE Connector Update policies.

To attach and remediate:

1
2
3

Attach the software policy SE Storage Scanner to the managed server
Remediate the server.

If your HP Storage Essentials management server is version 6.1.1, you do not need to follow any more
steps.

If the HP Storage Essentials management server is version 6.2 or later, attach the software policy SE
Connector Update for your version to the managed server.

Note: The version of the SE Connector Update must be compatible with the version of the Storage
Essentials server, which means that the version numbers of the SE Connector Update libraries must be the
same as the version of the Storage Essentials. For example, if you have SE 6.2, installed, you will have to
install the SE Storage Scanner first, then install the SE Connector Update for 6.2.

SE Connector Updates

Asset Discovery

This section discusses SE Connector updates.

CESTDITIN

[ Browse Types ] Browse Folders

Library items may be browsed by type or by folder for selection.

@F Software Policy »-) | Name -
Efr Solaris Patch Policy MName - Location
(5 Patch @¥ Customer Provided Scripts [OpswareToolsfExt... =
BY Patch Policy ZY DMA Agent Support [Opsware|Tools/Dat. ..
l_-:! Package @Y HP Provided Scripts [Opsware Tools [Ext...
T Windows Users And Groups | | 2 1SMtool [fOpsware ToolsISM. ..
&8 UNIX Users And Groups Er Python 2 for Server Modules [Opsware{Tools/Pyt...
Sy wndows s setings || e remareToda Pt
,ﬁ Windows Local Security Settin @Y SE Connector Update for 9.4.0 JOpsware/Storage/A. ..
9y Windows Services @ SE Connector Update for 9.4.1 [Opsware/Storage/A. ..
i) Windows COM+ @f SE Connector Update for 9.5.0 [Opsware Storage/A. ..
&’ Windows Registry @Y SE Connector Update for 9.5.1 fOpsware/Storage/A. ..
&’ windows 115 Metabase @Y SE Storage Scanner JfOpsware/Storage/A...
DY server Module Utility fopsware Tools/Ser...

|« [ I ] » -

0 iterns selected

SA 10.0 supports the following SE versions: SE 9.4.0, SE 9.4.1, SE 9.5.0 and SE 9.5.1.
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) Note: The SA 10.0 release no longer supports SE 6.x for new managed servers. However, SA 6.x is still

‘b

supported for existing managed servers.

Viewing the Storage Essentials Connection Status

To view the status of the connection to the Storage Essentials server that is managed by the Storage
Scanner:

1 From the navigation pane, select Administration > Storage Scanners.
2 In the content pane, select an SE Storage Scanner and then open its browser.

3 From the Views pane, select Storage Essentials. Check the Status column.

Multiple Storage Essentials Instances

SE Connector can communicate with multiple Storage Essentials instances.

For scalability and performance reasons, it is recommended that you have multiple SE Connectors
communicating with one instance of Storage Essentials. You can also have multiple SE Connectors
communicating with multiple instances Storage Essentials.

When you have multiple SE Connectors communicating with one instance of Storage Essentials, each access
control must be configured to collect a unique set of devices from the same Storage Essentials instance. See

the HP Server Automation: Storage Visibility and Automation Installation & Administration Guide for
information about modifying access controls.

Since, by default, storage information is collected from SE once every 12 hours, you might need updated

data more frequently than twice a day. You can modify this data collection frequency by modifying a setting
in SE. See the Storage Essentials SRM Software User Guide for information about configuring the schedule
for data collection. You can also request an update of SAN information from SE at the storage device level,

such as arrays and NetApp filers. See Update from Storage Essentials on page 15 for more information.

When you are viewing storage information about a SAN array or NetApp filer in Storage Visibility and
Automation and would also like to view storage information for the same SAN array or NetApp filer in

Storage Essentials, you can launch Storage Essentials to display the data that was discovered. See Open with

Storage Essentials (Click & Launch) on page 16 for more information.

Viewing the SA Client Library Version Number

The Storage Scanner properties panel includes the SE Client Library Version number. The SE Client Library

version number, such as 6.x.x.xx, is displayed in the Description field.
To view the SA Client Library version number:
1 From the navigation pane, select Administration > Storage Scanners.

2 In the content pane, select an SE Storage Scanner.

3 From the View drop-down list, select Properties. The SE Client Library Version number is displayed in

the Description field.

Chapter 1



Database Scanner for Oracle

The Database Scanner for Oracle collects data about Oracle storage configurations in a SAN or Network
Attached Storage (NAS), such as the Oracle instance, tablespaces, and datafiles.

Storage elements configured for an Oracle instance can be classified as physical database storage and
logical database storage:

— Physical database storage includes datafiles and redo logs that directly consume system storage
resources (filesystems or partitions) or are built on top of ASM Files.

— Logical database storage includes entities such as tablespaces that are created inside the instance
consuming different physical and logical storage entities.

This Storage Scanner identifies relationships between the database elements and other storage assets as
described in Table 1.

Table 1 Database Assets & SAN Relationships

Database Asset External Storage Asset | Dependency | Description
SAN-based physical | Server assets Block storage | Provides the dependency chain
database storage SAN array assets dependency between the database storage elements
Fabric assets and SAN arrays through system
NetApp assets (server) resources and fabrics.
NAS-basedphysical | Server assets NAS storage | Provides the dependency chain
database storage NetApp assets dependency between the database storage
elements, server resources, and
NetApp.

See the HP Server Automation: Storage Visibility and Automation Installation & Administration Guide for
information about how to configure and deploy the Database Scanner for Oracle.

Update from Storage Essentials

f

Asset Discovery

You must have the required SA user permissions to request an “Update from Storage Essentials”. See the HP
Server Automation: Storage Visibility and Automation Installation & Administration Guide for more
information.

“Update from Storage Essentials” is an option in the Actions menu that requests an update of storage
information about an individual storage device, such as a SAN array or NetApp filer. SE Connector provides
this synchronization of data for a storage system when you request an update at the device level.

SE Connector does not directly communicate with a storage device to collect data about it. SE Connector
collects data about an individual storage device from Storage Essentials. This request copies data from the
SE repository into the Model Repository.

You can specify the maximum wait time (in minutes) for the “Update from Storage Essentials” action in SE
Connector while SE performs GAED for certain storage elements. The following property specifies the
maximum default wait time for the "Update From Storage Essentials" action when GAED is in progress:

com.creekpath.agent.common.devices.manual.full.sync.max.wait.minutes=10080

The Jobs and Sessions user interface displays the status of the update request. A “Success” status indicates
that the Model Repository has been updated. The timestamp for the job also provides the following
information about the “Update from Storage Essentials” request:

15



*  When the request was made
*  What the status of the update job is, such as:

— Succeeded—Request was submitted successfully. SE Connector collected the data for the
requested device and sent it to the Web Services Data Access Engine.

— Error—Request could not be submitted. Verify that the SE Connector is running and start it if it is
stopped. If there is still a problem, check the SE Connector logs on the managed server to
troubleshoot this error. Begin with the pam-0-0. trace log file and then check other trace files.

See the SA User Guide: Server Automation for more information about Jobs and Sessions.

Open with Storage Essentials (Click & Launch)

“Open with Storage Essentials” is an option in the Actions menu that launches Storage Essentials for an
individual storage device, such as a SAN array or NetApp filer. You can also launch Storage Essentials for a
device by selecting it and then by right-clicking—this is commonly referred to as the Click & Launch user
interface.

SE Connector supports Click & Launch for storage devices that are managed by Storage Essentials
standalone configuration. This option is not supported with Storage Essentials integrated with HP Systems
Insight Manager.

Click & Launch requires an SE account login. When you select other storage objects and then Click &
Launch from them (while in the same session), the initial SE login will persist. There is no single sign-on
capability for HP Server Automation and Storage Essentials.

You can launch SE only from a storage device. You cannot launch SE from a host.

Storage Device

A storage device in the Storage Visibility and Automation model is an entity that represents the volumes,
extents, and other things in the real world that contain the actual bits and bytes. A storage device can be any
block storage device that has a capacity measured in bytes, such as physical disks, partitions, and database
tablespaces.

There are two types of storage devices:

— A logical volume is a block storage extent, such as partition, database tablespace, and remote
initiator volume.

— A physical disk is a physical storage device that provides the raw storage for a storage system,
such as storage array disks or spindles.
Deleting a Storage Device
This action only removes a storage device (SAN array, NAS filer, and database) from the Model Repository.

To remove a storage device from the Model Repository:

1 In the navigation pane, select Devices >Storage and then select a device type, such as SAN Arrays or
NAS Filers.

Or

In the navigation pane, select, Library > Databases.
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2  In the content pane, select a device. You can also select more than one device.
3 From the Actions menu, select Delete.

4 In the Delete dialog box, click Delete to remove the device from the Model Repository.

Storage Host Agent Extension (SHA)

A Storage Host Agent Extension (SHA) runs on a managed server to discover storage related data on that
managed server, such as Fibre Channel Adapter (FCA) hardware and drivers, filesystem mounts, and so on.

SHA is not an agent. SHA is a C++/Python module that can be executed by scheduled jobs. This module
runs on managed servers and produces XML output that is sent back to the SA core. This data (XML output)
persists in the Model Repository from where it is then retrieved and displayed in the user interface.

Figure 1 shows the end-to-end process of the SHA that captures storage-related data on a managed server.

Figure 1 SHA on a Managed Server
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Asset Discovery

This feature provides visibility into the storage configuration in a managed server attached to the Storage
Area Network (SAN) or Network Attached Storage (NAS). These configurations can help you understand
the dependency on SAN and NAS elements.

Storage elements in a server (server assets) include logical entities, such as volumes and physical hardware.
This feature allows you to view and evaluate storage-related information for a managed server, such as
FCAs and FCA drivers, volume mounts, volume manager information, and so on.

The discovery of server storage elements is enabled by processes that periodically query the managed server
and then push the data to the core.

Storage Visibility and Automation displays server storage assets after the hardware registration process is
successfully completed. Hardware registration typically occurs within the first 24 hours of the SE Connector
deployment. See the SA User Guide: Server Automation for information about how to initiate the hardware
registration process as needed.

You can define the job schedule for capturing storage data. See Scheduling Server Asset Discovery on
page 20.
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With this feature, a server administrator can view:

Storage-related information in each managed server, such as FCAs and FCA drivers, volume mounts,
volume manager information, and so on

Unmounted storage resources that the SAN is making available to the host

Aggregate information on storage elements (such as volumes used) that are associated with an
application in a server

This feature also provides quick navigation to downstream physical or logical storage elements associated
with an application or a single managed server. At any level in the storage supply chain, you can drill down
to the associated storage entities to view:

Physical entities—fibre switches, filers, disks, and so on

Logical entities—zones, LUNSs, and so on

From these entities, you can drill down or drill up to see storage resources that are shared between two or
more selected applications or managed servers.

Storage Visibility and Automation captures the following server assets:

Fibre Channel Adapter (FCA) Iﬁ —Storage information on the active Fibre Channel Adapter
(FCA). In the storage industry, FCA also applies to the hardware interface that uses non-Fabric Channel
protocol. Storage Visibility and Automation discovers the Manufacturer, Model, Serial Number,
Software Driver Version, Software Firmware Version, and Physical Hardware Version for an FCA.

Fibre Channel Adapter Port Gap —The port on the FCA to provide access to the outside world—
storage information on the active Fibre Channel Port World Wide Name (WWN). See Fabric Assets on
page 41 for information about storage in the connectivity of an FCA Port and an FC Switch Port.

Base Volumes—Basic raw storage capacity (primordial storage). This raw storage may be virtualized
and consumed in the layers above (Volume Managers, File Systems). These storage elements include
local storage (Root Volumes) based disks, and Direct Attached Storage (DAS).

Root Volumes (Local and DAS)—Storage exposed through disks that are local and are based on DAS
as logical Root Volume. Hardware information of the spindles or disk controllers is not captured.

Multipath IO (MPIO)—Information on the MPIO software and all of the Fibre Channel protocol
based storage access paths to remote storage volumes. This information includes access path
information for each of the LUN bounded to the server. For each path, Storage Visibility and
Automation captures the following information:

— State of the path—active or passive
— Is Preferred Path
— FCA Port consumed for each of the path

Volume Manager (Logical Volume Manager/Logical Disk Manager)—Native and third party
Volume Manager Software information. This includes information on all aspects of storage, such as
capacity and storage layout, that are consumed and produced by the Volume Manager. Storage Visibility
and Automation does not provide detailed information on internals of the Volume Manager. However,
for each of the volumes produced by the Volume Manager, Storage Visibility and Automation provides
dependencies on primordial storage, such as dependency chain that includes consumed storage. SE does
not support layered volume managers and layered volumes.

Consumed Storage—Storage that is directly consumed by the Volume Manager from the server
primordial storage. SE discovers storage capacity if the applicable volume group (Disk Group) is the
source of the consumable storage (server level primordial storage only). Storage Visibility and
Automation also captures storage consumed by a volume manager, which consumes external storage.
Not all storage resources are virtualized to create volume manager volumes.
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*  Produced Storage—Storage capacity when the applicable volume group (Disk Group) is the type
(SIMPLE, RAIDS, and so on) for the produced storage (volumes). Produced storage consists of storage
units created by a hosted service, such as file systems, volume managers, and databases.

*  File Systems El —Consumers of the produced storage. This functionality includes capturing the file
systems that are based on primordial storage and storage offered by volume manager volumes. Storage
Visibility and Automation discovers Block Driver, Cluster Size, Is Remote, File System Size, File
System Type (nfs, ufs, vxfs, hfs, ext2, ext3, ntfs, and so on), Mount Point, and Root and Storage
capacity information. Storage Visibility and Automation also discovers the dependency chain for the
File System based on NetApp. See Storage Visibility and Automation displays relationships between
fabric elements and other storage asset discovery features. See Table 6. on page 42 for more
information. For this release, Storage Visibility and Automation does not support distributed filesystem.

Storage Topology

Asset Discovery

Figure 2 shows how storage builds up from physical disks to volumes, through volume managers, to a file
system.

.
Figure 2 Storage Layers
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Layer 4 shows the physical disks and the LUNSs attached to the server. The physical disks are the local disks
to the server and the LUNs are the logical units from an external storage systems (Network attached storage
or Storage Attached Network).

Layer 3 shows the physical partitions, which are created from one or more physical drives and logical units.

Layer 2 shows the volume groups, which can consist of one or more physical volumes and there can be more
than one volume group in the system. These volume groups can be divided into logical volumes of various
sizes. A logical volume can span a number of physical volumes in a volume group or represent only part of

one physical volume. Logical volumes can contain a file system, swap space or raw data.

Layer 1 shows the file systems that are mounted on the logical volumes.
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Scheduling Server Asset Discovery

In Storage Visibility and Automation, the discovery of server storage elements is enabled by processes (jobs)
that periodically query the managed server and then push the data to the core. You can define the job
schedule for capturing storage data. See the SA User Guide: Server Automation for more information about
jobs and scheduling them.

Server Storage and SAN Relationships

Storage Visibility and Automation displays relationships between server storage elements and other storage
asset discovery features. See Table 2.

Table 2 Server Assets and SAN Relationships

Server Asset External Element Description

File System Remote File Systems Captures only NFS-mounted file
(only NFS mounted file system system dependency information.
dependency)

FCA Port Connected FC switch port The port on the FCA to provide access

to the outside world—storage
information on the active Fibre
Channel Port World Wide Name
(WWN).

) Storage Visibility and Automation does not include relationships that are local to the discovery of a server
storage asset.

Chapter 1



Frequently Asked Questions

Table 3 shows you how to use this documentation to find answers to some frequently asked questions about
finding information about server storage elements in a managed server.

Table 3 Frequently Asked Questions About Server Assets

Asset Discovery

Question

How to Find the Answer

What are the application storage configurations in
a managed server?

*  Viewing File Systems Mounted on a Server
on page 23

*  Viewing Databases Hosted by a Server on
page 30

What is causing application performance
degradation? How is all of the server storage
configuration impacting the application? What are
the shared resources between applications?

*  Viewing Ports and Volumes in an FCA on
page 22

*  Viewing Port Connections and Zones on
page 23

*  Viewing Access Paths to Storage Targets on
page 29

*  Viewing Fabrics Attached to a Server on
page 29

*  Viewing Storage Volumes with Access
Paths for Remote Initiators on page 35

*  Viewing the Access Path from the Volume
on page 39

What SAN elements (switches, arrays, and
gateways) are applications, through server storage
assets, dependent on?

e Viewing Antecedents and Dependents of
Volumes for a Managed Server on page 25

*  Viewing File Systems Mounted on a Server
on page 23

e Viewing Volume Details on page 24

What are the storage expansion opportunities for
an application and for a managed server?

*  Viewing Storage Summary in a Server on
page 23

*  Viewing File Systems Mounted on a Server
on page 23

*  Viewing Volumes Created on a Disk on
page 27

Are critical applications configured for high
availability, such as multiple paths?

*  Viewing Ports and Volumes in an FCA on
page 22

What are the unmounted storage resources that the
SAN is making available to the managed server?

*  Viewing the Access Path from the Volume
on page 39

What is the aggregate information on storage
elements (volumes used) associated with an
application in a server?

*  Viewing Antecedent of Aggregate Storage
Supply Chain on page 28
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Table 3 Frequently Asked Questions About Server Assets (cont’d)

Question How to Find the Answer
8. | How do I navigate to downstream physical or *  Viewing Antecedents and Dependents of
logical storage elements associated with an Volumes for a Managed Server on page 25

application or a single managed server?

9. | How do I navigate to the associated storage entities |+  Viewing Ports and Volumes in an FCA on
at any level in the storage supply chain, such as: page 22

+  Physical entities—fibre switches, filers, disks, |+  Viewing Port Connections and Zones on
and so on page 23

* Logical entities—zones, LUNSs, and so on?

10. | How can I view storage resources that are shared |+  Viewing Storage Volumes with Access
between two or more selected applications or Paths for Remote Initiators on page 35

9
Servers: *  Viewing the NAS Filer Storage

Configuration on page 45

Viewing FCAs Attached to a Server

To troubleshoot fibre channel connectivity and identify the inventory, operational status, and storage
resources consumed through a Fibre Channel Adapter, you need to know what FCAs are attached to a
certain managed server.

To view FCAs that are attached to a server:

1 In the navigation pane, select Servers > All Managed Servers.
2  In the content pane, select a server.

3 From the View drop-down list, select Hardware. The Hardware pane displays information about the
server and the FCAs that are attached to it, such as Manufacturer, Model, Processors, Memory (RAM),
and Memory (SWAP). This information is captured by Storage Host Agent Extensions (SHASs).

Viewing Ports and Volumes in an FCA

To view which ports and volumes are in an FCA:

1 In the navigation pane, select Servers > All Managed Servers.
2 Inthe content pane, select a server and then double-click or right-click to open it.
3 Inthe navigation pane, select Inventory.

4 In the Views pane, expand the Hardware list and then select the Fibre Channel Adapter (FCA) name.
See Server Assets on page 17 for more information.
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Viewing Port Connections and Zones

To view switch ports that a port is connected to and zones that a port belongs to:

1

2
3
4

In the navigation pane, select Servers > All Managed Servers.
In the content pane, select a server and then double-click or right-click to open it.
In the navigation pane, select Inventory.

In the Views pane, expand the Hardware list and then select the fibre channel port. The content pane
displays information about the FCA port.

Viewing Storage Summary in a Server

To view storage summary in a managed server:

1
2
3

In the navigation pane, select Servers > All Managed Servers.
In the content pane, select a server and then double-click or right-click to open it.

In the Views pane, select Inventory > Storage. The content pane displays storage information, such as
file systems, local attached storage, Direct Attached Storage (DAS), SAN storage, Network Attached
Storage (NAS), and database storage.

Viewing File Systems Mounted on a Server

To view file systems mounted on a server:

1
2
3

In the navigation pane, select Servers > All Managed Servers.
In the content pane, select a server and then double-click or right-click to open it.

In the Views pane, select Inventory > Storage > File Systems. The content pane displays information
about all file systems that are mounted on the selected server.

Viewing File System Properties

To view properties of a file system:

1

2
3
4

Asset Discovery

In the navigation pane, select Servers > All Managed Servers.
In the content pane, select a server and then double-click or right-click to open it.
In the Views pane, select Inventory > Storage > File Systems.

In the content pane, select a file system to display the Properties pane. This pane displays details about
the file system.
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Viewing Volume Details

You can view volume details, such as properties, composition, disks, access path, and connectivity by
volume.

To view volume details:

1 In the navigation pane, select Servers > All Managed Servers.
In the content pane, select a server and then double-click or right-click to open it.
In the Views pane, select Inventory > Storage > File Systems.

2
3
4 In the content pane, select a file system to display the Volumes pane.
5 From the View drop-down list, select Volumes.

6

(Optional) From the View drop-down list, select an option to display properties, volumes, disks, or
connectivity by volume.

Viewing Local Disks

To view local disks used by a file system:

1 In the navigation pane, select Servers > All Managed Servers.

2 In the content pane, select a server and then double-click or right-click to open it.
3 Inthe navigation pane, select Inventory >Storage > File Systems.

4 In the content pane, select a file system.
5

From the View drop-down list, select Disks to display the Disks pane. This pane displays information
about disks that are consumed by a file system.

Viewing the Storage Supply Chain

To view the storage supply chain as a tree:

1 In the navigation pane, select Servers > All Managed Servers.
In the content pane, select a server and then double-click or right-click to open it.
In the navigation pane, select Inventory > Storage > File Systems.

In the content pane, select a file system.

O A W N

From the View drop-down list, select Connectivity to display the Connectivity pane. This pane displays
Storage Supply Chain for the selected file system.

Chapter 1



Viewing Volume Properties

To view properties of a volume:

1 In the navigation pane, select Servers > All Managed Servers.
In the content pane, select a server and then double-click or right-click to open it.
In the Views pane, select Inventory > Storage > Volumes.

In the content pane, select a volume.

g A W N

From the View drop-down list, select Properties to display the Properties pane. This pane displays
information about the selected volume.

Note: On some Windows servers, installing new multipathing software might show disks as "Foreign Disks"
in the "Disk Management" panel on the managed server. Volumes present on this disk do not show up in the
"Disk Management" panel. However, if the storage snapshot specification is run on this managed server,
these volumes display in the Inventory > Storage > Volumes panel. Log on to the Windows server. Open the
"Disk Management" wizard and then import the disks that are marked "Foreign". After the import, run the
storage snapshot specification for this managed server.

Viewing Antecedents and Dependents of Volumes for a Managed Server

To view antecedent and dependents of the volume storage supply chain:

1 In the navigation pane, select Servers > All Managed Servers.
In the content pane, select a server and then double-click or right-click to open it.
In the Views pane, select Inventory > Storage > Volumes.

2

3

4 In the content pane, select a volume.

5 From the View drop-down list, select Composition to display the Composition pane.
6

(Optional) In the Composition pane, right-click on a storage resource to open its corresponding SAN
Array Browser.

Viewing Access Paths for a Volume

Asset Discovery

Access paths include Target and Target Port LUN based volumes. This provides visibility into the MPIO
configuration of a volume.

To view a list of access paths:

1 In the navigation pane, select Servers > All Managed Servers.

2 In the content pane, select a server and then double-click or right-click to open it.
3 Inthe Views pane, select Inventory > Storage > Volumes.

4 In the content pane, select a volume.
5

In the View drop-down list, select Access Path to display the Access Path pane. This pane provides
visibility into the MPIO configuration of a volume by displaying Target and Target LUN based volumes
in the list of access paths.
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6

(Optional) Select a path and then select one of the following options from the Actions menu:

*  Open Target—Displays the SAN Array Browser or the NAS Filer Browser, depending on the
AAA permission.

*  Open Target Port—Displays the SAN Array Ports Browser or the NAS Filer Ports Browser,
depending on the AAA permission.

*  Open Target Volume—Displays the SAN Array Volume Browser or the NAS Filer Volume
Browser, depending on the AAA permission.

Viewing Volume Connectivity

To view the connectivity of a volumes:

1

2
3
4
5

In the navigation pane, select Servers > All Managed Servers.

In the content pane, select a server and then double-click or right-click to open it.
In the Views pane, select Inventory > Storage > Volumes.

In the content pane, select a volume.

From the View drop-down list, select Connectivity to display the Connectivity pane. This pane displays
the connectivity information for the volume.

(Optional) Select a level and then select Actions > Open (Enter) to display the SAN Array Browser or
the NAS Filer Browser.

Viewing Disks Utilized by a Volume

To view disks utilized by the volume:

1

o A W N

In the navigation pane, select Servers > All Managed Servers.

In the content pane, select a server and then double-click or right-click to open it.
In the Views pane, select Inventory > Storage > Volumes.

In the content pane, select a volume.

From the View drop-down list, select Disks to display the Disks pane. This pane shows information
about the disks that are consumed by the volume.

Viewing Local Disks or DAS Attached to a Server

To view local disks or DAS attached to a managed server:

1
2
3

26

In the navigation pane, select Servers > All Managed Servers.
In the content pane, select a server and then double-click or right-click to open it.

In the Views pane, select Inventory > Storage > Disks. The content pane displays information about
the disks.
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Viewing Disk Properties

To view the properties of a selected physical disk:

1 In the navigation pane, select Servers > All Managed Servers.

2  In the content pane, select a server and then double-click or right-click to open it.
3 Inthe Views pane, select Inventory and then select Storage > Disks.
4

Select a disk to display the Properties pane.

Viewing Volumes Created on a Disk

To view volumes created on a selected disk:

1 In the navigation pane, select Servers > All Managed Servers.

2 In the content pane, select a server and then double-click or right-click to open it.
3 Inthe Views pane, select Inventory > Storage > Disks.

4 Select a disk and then select Volumes from the View drop-down list.

Viewing File Systems Created on a Disk

To view file systems created on a selected disk:

1 In the navigation pane, select Servers > All Managed Servers.
2  In the content pane, select a server and then double-click or right-click to open it.
3 Inthe Views pane, select Inventory and then select Storage > Disks.

4 Select a disk and then select File Systems from the View drop-down list.

Viewing Volume Manager, MPIO, ZFS, & ASM

To view Manager Software on a server:

1 In the navigation pane, select Servers > All Managed Servers.

2 In the content pane, select a server and then double-click or right-click to open it.
3 Inthe Views pane, select Inventory > Storage > Manager Software.

4 In the content pane, select an inventory element, such as an Oracle Automatic Storage Management
(ASM) disk group.

Viewing Volumes Available Through Manager Software

To view volumes that are available through Manager Software:

1 In the navigation pane, select Servers > All Managed Servers.

2  In the content pane, select a server and then double-click or right-click to open it.
3 Inthe Views pane, select Inventory > Storage > Manager Software.

4 Select a Manager Software to show detailed information in the bottom content pane.
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Viewing Unmounted Volume Properties

To view properties of unmounted volumes:

1

2
3
4

In the navigation pane, select Servers > All Managed Servers.
In the content pane, select a server and then double-click or right-click to open it.
In the Views pane, select Inventory and then select Storage > Unmounted Volumes.

Select a volume and then select Properties from the View drop-down list.

Viewing Antecedent of Aggregate Storage Supply Chain

To view the antecedent of the aggregate storage supply chain:

1
2

3
4
5

In the navigation pane, select Servers > All Managed Servers.

In the content pane, select a server and then double-click or right-click to open it.

In the Views pane, select Inventory and then select Storage > Unmounted Volumes.
Select a volume and then select Composition from the View drop-down list.

(Optional) In the Composition pane, select an antecedent or dependent and then open its corresponding
SAN Array Browser.

Viewing Remote SAN Based Volumes

To view remote SAN based volumes:

1

g A W N

In the navigation pane, select Servers > All Managed Servers.

In the content pane, select a server and then double-click or right-click to open it.
In the Views pane, select Inventory > Storage > Unmounted Volumes.

In the content pane, select a volume.

From the View drop-down list, select Disks to display the Disks pane. This pane displays information
about disks that are consumed by unmounted volumes.

(Optional) If the volume is LUN based, select then open it to display its corresponding SAN Array
Browser.

Viewing Storage Targets

To view storage targets (SAN Array or NAS Filer (Block)):

1
2
3

In the navigation pane, select Servers > All Managed Servers.
In the content pane, select a server and then double-click or right-click to open it.

In the Views pane, select Relationships > Storage Targets.
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Viewing Access Paths to Storage Targets

To view access paths to storage targets:

1

g A W N

In the navigation pane, select Servers > All Managed Servers.

In the content pane, select a server and then double-click or right-click to open it.

In the Views pane, select Relationships > Storage Targets.

Select a target to display the access paths.

(Optional) Select an access path and then select one of the following options from the Actions menu:

*  Open Target—Displays the SAN Array Browser or the NAS Filer Browser, depending on the
AAA permission.

*  Open Target Port—Displays the SAN Array Ports Browser or the NAS Filer Ports Browser,
depending on the AAA permission.

*  Open Target Volume—Displays the SAN Array Volume Browser or the NAS Filer Volume
Browser, depending on the AAA permission.

Viewing Switches Attached to a Server

To view switches attached to a managed server:

1
2
3

In the navigation pane, select Servers > All Managed Servers.
In the content pane, select a server and then double-click or right-click to open it.

In the Views pane, select Relationships > SAN Switches.

Viewing Fabrics Attached to a Server

To view fabrics attached to a server:

1
2
3

In the navigation pane, select Servers > All Managed Servers.
In the content pane, select a server and then double-click or right-click to open it.

In the Views pane, select Relationships > SAN Fabrics.

Viewing FCA Ports Attached to a Fabric

To view FCA ports attached to a fabric:

1

2
3
4

Asset Discovery

In the navigation pane, select Servers > All Managed Servers.
In the content pane, select a server and then double-click or right-click to open it.
In the Views pane, select Relationships > SAN Fabrics.

In the View drop-down list, select Ports.
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Viewing Zone Membership

To view zones where a managed server is a member of a certain fabric:

1 In the navigation pane, select Servers > All Managed Servers.

2  In the content pane, select a server and then double-click or right-click to open it.
3 Inthe Views pane, select Relationships > SAN Fabrics.
4

From the View drop-down list, select Zones.

Viewing Databases Hosted by a Server

To view databases that a selected server hosts:

1 In the navigation pane, select Servers > All Managed Servers.
2 In the content pane, select a server and then double-click or right-click to open it.
3 Inthe Views pane, select Relationships > Databases.

4 (Optional) Select a database and then open it to display the Database Browser. You must have Read
permissions on the server that is hosting the database.

Viewing Storage Initiators & Volumes

To view storage initiators and the volumes for each initiator:

1 In the navigation pane, select Servers > Virtual Servers.
2 In the content pane, select an ESX server and then double-click or right-click to open it.
3 Select Relationships > Storage Initiators.

4 Select an initiator to view the volumes associated with it.

SAN Array Assets @

This feature provides visibility into various storage array configurations that are attached to a SAN. This
excludes SAN array devices that are directly attached to servers. SE captures generic SAN array assets as
well as vendor-specific assets.

Using this feature, a server administrator can view the following:
— SAN array storage utilization and configuration
— SAN Array security configuration
— Storage resources shared between applications or hosts
SE captures the following generic SAN array assets:
SAN Array (Storage Systems) L] —SAN array configuration information. SE uses an IP-based network
mechanism to access the device or device interface, such as API, CLI, and so on. Storage Visibility and

Automation discovers the Manufacturer, Model, Serial Number, Firmware Version, and Storage Capacity for
a SAN Array.
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Disk Controllers—Disk controllers are discovered for arrays. However, the Storage Visibility and
Automation user interface does not display the association or relationship between a disk controller and a
disk for any disk controller.

Storage Volumes L—'] —Storage volumes that are carved out of disks. Storage Visibility and Automation
discovers the Storage Capacity, Block Size (if available), Storage Type, and Volume ID. Meta volumes
(devices) are composite volumes that are created using two or more regular storage volumes.

Composite Volumes—Some SAN arrays support composite volumes. For these types of arrays, Storage
Visibility and Automation will capture information for composite volumes. Composite volumes allow
individual storage volumes to be concatenated and create a storage volume with larger storage capacity.

Port Controllers—The port controller and a list of fabric ports in the controller.

Fabric Ports—SAN array fabric ports are used to provide FC connectivity between SAN array and fibre
switch (standalone or part of a fabric). Storage Visibility and Automation does not capture internal fabric
ports in the system. It captures the Port Number, State (Offline, Online), and the World Wide Name.

Storage Pools & —Some SAN arrays support grouping volumes together, based on common
characteristics. For example, for an HP XP or Hitachi SAN array, groups of storage volumes are grouped
together in an entity called Array Groups. Not all SAN arrays support storage pool concepts. For SAN arrays
that do support pool concepts, Storage Visibility and Automation captures the storage type and storage
capacity. For supported SAN arrays, Storage Visibility and Automation captures the free extents in the pool.
If the storage pool is not supported by the device, HP creates the storage pool for the storage volumes, based
on the storage type.

LUN Mapping—Lun Mapping information, such as Storage Volume, SAN Array Port, Lun ID, and Host
FC Port/FCA information.

SAN Array Assets and Relationships

Storage Visibility and Automation displays relationships between SAN array elements and other storage
asset discovery features. See Table 4.

Table 4 SAN Arrays Assets and Relationships

SAN Array Asset | External Element Description

Connected fabric Ports connectivity Provides the point-to-point links

port through a fabric.

Connected device Fabric zone/alias context Captures devices attached to the ports
that are members of a zone or alias.

Update from Storage Essentials

Asset Discovery

Since, by default, storage information is collected from SE once every 12 hours, you might need updated
information about a SAN array more frequently than twice a day. Check SE to verify the frequency of its
data collection, and configure it if necessary. See the Storage Essentials SRM Software User Guide for
information about configuring the schedule for data collection.

In Storage Visibility and Automation, you can request an update of SAN information from SE at the device
level (such as, the SAN array). See Update from Storage Essentials on page 15 and the HP Server
Automation: Storage Visibility and Automation Installation & Administration Guide for more information.
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Open with Storage Essentials

When you are viewing storage information about a SAN array in Storage Visibility and Automation and
would also like to view storage information for the same SAN array in Storage Essentials, you can launch
Storage Essentials to display the data that was discovered. See Open with Storage Essentials (Click &
Launch) on page 16 for more information.

Frequently Asked Questions

Table 5 answers some frequently asked questions on finding information about SAN arrays.

Table 5 Frequently Asked Questions About SAN Array Assets

Question

How to Find the Answer

What storage is available in a SAN array in a
datacenter?

Viewing Zones Configured for an Array on
page 36

‘What LUNSs are bound to the servers?

Viewing Storage Initiators Consuming
Storage Resources from an Array on
page 34

Viewing Initiator Volumes and Ports on
page 35

Viewing Storage Volumes with Access
Paths for Remote Initiators on page 35

Viewing Volumes Served by a SAN Array
Port on page 37

Are critical applications configured for high
availability, such as multiple access paths? What
are the redundant paths between a server and a
SAN array for an application?

Viewing Storage Volumes with Access
Paths for Remote Initiators on page 35

What is the storage utilization of the SAN array?

Viewing Zones Configured for an Array on
page 36

Are the critical applications backed up?

Viewing Storage Volumes with Access
Paths for Remote Initiators on page 35

Do the SAN arrays provide room for growth?

Viewing Zones Configured for an Array on
page 36

When will the SAN arrays run out of space?

Viewing Zones Configured for an Array on
page 36

What is causing application performance
degradation? How is all of the SAN configuration
impacting the application? What are the shared
resource between applications?

Viewing Storage Volumes with Access
Paths for Remote Initiators on page 35

Viewing the Access Path from the Volume
on page 39
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Viewing SAN Arrays

To view a list of SAN arrays with their hardware and status:

1 In the navigation pane, select Storage > SAN Arrays.

2 Select a SAN array to view the Summary in the content pane. The content pane displays information
about the SAN array hardware and status.

Viewing SAN Arrays and Storage Configurations

To view the SAN array and storage configurations:

1 In the navigation pane, select Storage > SAN Arrays.

2 Inthe content pane, select a SAN array. The content pane displays information about the SAN array
hardware and status.

3 (Optional) Select a target and then select one of the following options from the Actions menu:
*  Open—Displays the SAN array details in a separate window, depending on the AAA permission.

*  Open with HP Service Automation Visualizer—Opens the target with Service Automation
Visualizer (SAV) and displays the storage map.

*  Open with Storage Essentials—Opens the target with Storage Essentials.

*  Update from Storage Essentials—Requests an update of storage information at the device level
from Storage Essentials.

*  Rename—Displays an editable field to rename the SAN array directly in the table, depending on
the AAA permission.

*  Delete—Removes the SAN array from the Model Repository.

Viewing Summary of a SAN Array

To view a SAN array summary:

1 In the navigation pane, select Storage > SAN Arrays.
2  In the content pane, select a SAN array.
3 Inthe Views pane, select Summary.

4 In the content pane, select a SAN array and then open it to display the summary.

Viewing SAN Array Properties

To view properties for a SAN array:

1 In the navigation pane, select Storage > SAN Arrays.
2 In the content pane, select a SAN array.

3  From the View drop-down list, select Properties. The content pane displays properties of the SAN array.
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(Optional) Select a target and then select one of the following options from the Actions menu:
*  Open—Displays the SAN array, depending on the AAA permission.

*  Open with HP Service Automation Visualizer—Opens the target with Service Automation
Visualizer (SAV) and displays the storage map.

*  Open with Storage Essentials—Opens the target with Storage Essentials.

*  Update from Storage Essentials—Requests an update of storage information at the device level
from Storage Essentials.

*  Rename—Renames the target. Changes are saved in the system.

*  Delete—Removes the SAN array from the Model Repository.

Viewing Customers for a SAN Array

To view customers for a SAN array:

1

2
3
4

(6]

In the navigation pane, select Storage > SAN Arrays.
In the content pane, select a SAN array.
From the View drop-down list select Properties.

From the Actions menu, select Open, or right-click and then select Open. The Properties window
displays.

Click the Change link to open the Select Customer window.

Select a customer and then click Select.

Viewing the SAN Array History Log

To view the history log for a SAN array:

1

2
3
4

In the navigation pane, select Storage > SAN Arrays.
In the content pane, select a SAN array.
In the View drop-down list, select History. The content pane displays the history log for the SAN array.

In the content pane, select an event from the history log and then select the following option from the
Actions menu:

*  View Event Details—Displays detailed information about the event.
Or
*  Right-click on the event and select View Event Details.

(Optional) Click Export to export the history log to a .csv or an html file.

Viewing Storage Initiators Consuming Storage Resources from an Array

To view storage initiators consuming resources from an array:

1
2

In the navigation pane, select Storage > SAN Arrays.

In the content pane, select a SAN array.
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In the View drop-down list, select Storage Initiators. The content pane displays a list of storage
initiators.

(Optional) In the lower content pane, select a storage initiator and then select the following option from
the Actions menu:

*  Open Device—Opens the Device Explorer.
Or

*  Right-click on the target and select Open Device.

Viewing Initiator Volumes and Ports

To view initiator volumes and ports in a SAN array:

1

2
3
4
5

In the navigation pane, select Storage > SAN Arrays.

In the content pane, select a SAN array.

In the View drop-down list, select Storage Initiators.
Double-click on a SAN array. The SAN Array Browser displays.

In the SAN Array Browser, select a storage initiator. The content pane displays a list of initiator
volumes and ports.

(Optional) In the lower content pane, select a target and then select the following option from the
Actions menu:

*  Open Device—Opens the Device Explorer for the selected server.
*  Open Initiator Port—Displays the hardware information for the selected server.

*  Open Initiator Volume—Displays the storage information for the selected server.

Viewing Storage Volumes with Access Paths for Remote Initiators

To view storage volumes with access paths for remote initiators not managed by HP:

1
2
3

In the navigation pane, select Storage > SAN Arrays.
In the content pane, select a SAN array.

In the View drop-down list, select Storage Initiators. The content pane displays a list of initiator
volumes and ports.

In the lower content pane, select a storage initiator.

Right-click on the selected SAN array and then select Open. The content pane displays a list of storage
volumes.

Viewing Attached Fabrics in an Array

Asset Discovery

To view attached fabrics in a SAN array:

1
2
3

In the navigation pane, select Devices > Storage > SAN Arrays.
In the content pane, select a SAN array.

In the View drop-down list, select SAN Fabrics. The content pane displays information about attached
fabrics.
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Viewing Fabric Ports and Connectivity in an Array

To view array ports and their connectivity fo the selected fabric:

1

2

3

In the navigation pane, select Storage > SAN Arrays.
In the content pane, select a SAN array.

In the View drop-down list, select Ports. The content pane displays information about array ports.

Viewing Zones Configured for an Array

To view zones configured for an array in a selected fabric:

1
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In the navigation pane, select Storage > SAN Arrays.
In the content pane, select a SAN array.

In the View drop-down list, select SAN Fabrics.

In the content pane, open a SAN array.

In the SAN Array Browser, select a Fabric.

In the View drop-down list, select Zones. The content pane displays the information for zone sets.

Viewing SAN Switches Attached to an Array

To view SAN switches attached to an array:

1
2
3

In the navigation pane, select Storage > SAN Arrays.
In the content pane, select a SAN array.

In the View drop-down list, select SAN Switches. The content pane displays the information for SAN
switches.

In the content pane, open a SAN array.

Viewing Hardware Information for a SAN Array

To view the hardware information for the SAN array:

1
2
3

In the navigation pane, select Storage > SAN Arrays.
In the content pane, select a SAN array.

In the View drop-down list, select Hardware. The content pane displays the hardware information.

Viewing Front End Fabric Ports in a SAN Array

To view front end fabric ports in a SAN array:

1
2
3

In the navigation pane, select Storage > SAN Arrays.
In the content pane, select a SAN array.

In the View drop-down list, select Ports. The content pane displays the port information.
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Viewing Properties of the Fabric Port in a SAN Array

To view the properties of the fibre port:

1 In the navigation pane, select Storage > SAN Arrays.
2 In the content pane, select a SAN array.

3 Inthe View drop-down list, select Ports.

4 In the lower content pane, highlight a port to select it.

In the upper content pane, open a SAN array. The content pane displays the properties of the fibre port

Viewing Volumes Served by a SAN Array Port

To view volumes served by a SAN array port:

1 In the navigation pane, select Storage > SAN Arrays.
In the content pane, select a SAN array.
From the View drop-down list, select Ports.
In the content pane, open a SAN array.

2

3

4

5 Inthe SAN Array Browser, highlight a port to select it.

6 In the View drop-down list, select Volumes. The content pane displays a list of volumes.
7

(Optional) Select a target and then select the following option from the Actions menu:
*  Open Device—Opens the Device Explorer for the selected server.
*  Open Initiator Port—Displays the hardware information for the selected server.

*  Open Initiator Volume—Displays the storage information for the selected server.

Viewing Zones Configured for an Array Port

To view zones configured for an array port:

1 In the navigation pane, select Storage > SAN Arrays.
In the content pane, select a SAN array.

From the View drop-down list, select Ports.

2

3

4 In the content pane, open a SAN array.

5 Inthe SAN Array Browser, highlight a port to select it.
6

In the View drop-down list, select Zones to display a list of zones for the array port.

Viewing Storage Summary for a SAN Array

To view the summary of storage information offered by a SAN Array:

1 In the navigation pane, select Storage > SAN Arrays.
2  Inthe content pane, select a SAN array and then open it.

3 From the View drop-down list, select Summary. The content pane displays summary information.
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Viewing Volumes in a SAN Array

To view volumes in a SAN array:

1

2
3

In the navigation pane, select Storage > SAN Arrays.
In the content pane, select a SAN array and then open it.

In the Views pane, select Inventory > Storage > Volumes. The content pane displays the volumes.

Viewing Volume Properties

To view properties of a volume:

j—
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In the navigation pane, select Storage > SAN Arrays.
In the content pane, select a SAN array and then open the SAN array.
In the Views pane, select Inventory > Storage > Volumes.

In the content pane, select a volume and then open it. The content pane displays the properties.

Viewing the Connectivity of a Volume

To view the storage supply chain connectivity of a volume:

1
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In the navigation pane, select Storage > SAN Arrays.

In the content pane, select a SAN array and then open the SAN array.
In the Views pane, select Inventory > Storage > Volumes.

In the content pane, select a volume.

From the View drop-down list, select Connectivity. The content pane displays the connectivity of the
volume.

Viewing the Composition of a Volume

To view the antecedents and dependents of the volume storage supply chain:

1
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In the navigation pane, select Storage > SAN Arrays.

In the content pane, select a SAN array and then open the SAN array.
In the Views pane, select Inventory > Storage > Volumes.

In the content pane, select a volume.

From the View drop-down list, select Composition. The content pane displays the composition of the
volume.

(Optional) Select a target and then select the following option from the Actions menu:

*  Open—Opens the SAN array or Server Storage view.
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Viewing the Access Path from the Volume

To view the access path:

1
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In the navigation pane, select Storage > SAN Arrays.

In the content pane, select a SAN array and then open it.

In the Views pane, select Inventory > Storage > Volumes.

In the content pane, select a volume.

From the View drop-down list, select Access Path. The content pane displays the access path.
(Optional) Select a target and then select the following option from the Actions menu:

*  Open Device—Opens the Device Explorer for the selected server.

e Open Initiator Port—Displays the hardware information for the selected server.

*  Open initiator Volume—Displays the storage information for the selected server.

Viewing Array Ports from the Selected Volume

To view the array port that is part of the LUN mapping:

1
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In the navigation pane, select Storage > SAN Arrays.

In the content pane, select a SAN array and then open it.

In the Views pane, select Inventory > Storage > Volumes.

In the content pane, select a volume.

From the View drop-down list, select Ports. The content pane displays the ports.
(Optional) Select a target and then select the following option from the Actions menu:

*  Open Port—Opens the SAN arrays view.

Viewing Storage Pools

To view storage pools configured in the storage system:

1
2
3

In the navigation pane, select Storage > SAN Arrays.
In the content pane, select a SAN array and then open it.

In the Views pane, select Inventory > Storage > Pools. The content pane displays the list of storage
pools.

Viewing Storage Pool Properties

Asset Discovery

To view the properties of a storage pool:

1
2
3
4

In the navigation pane, select Storage > SAN Arrays.

In the content pane, select a SAN array and then open it.

In the Views pane, select Inventory > Storage > Pools.

In the content pane, select a storage pool. The content pane displays the properties.
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Viewing Volumes for a Selected Pool

To view volumes for a selected pool:

1 In the navigation pane, select Storage > SAN Arrays.
In the content pane, select a SAN array and then open it.
In the Views pane, select Inventory > Storage > Pools.

In the content pane, select a pool.

g A W N

From the View drop-down list, select Volumes. The content pane displays the volumes.

Viewing Replication

A replication pair consists of the source volume and the target (or copy) volume, including properties that
describe the type of replication used to back up or copy the source volume. Replication can be either local
(where source and target volumes are on the same array) or remote (where source and target volumes are on
different arrays.

Replication tree control is available on the Inventory > Storage panel. A replication pair consists of the
source volume and the target (or copy) volume, including properties that describe the type of replication
used to back up or copy the source volume.

To view information about replication pairs:
1 In the navigation pane, select Devices > Storage > SAN Arrays.
Or
Select Devices > Storage > NAS Filers.
2 Inthe content pane, select a storage system and then open it.
3 Inthe SAN Array or NSA Filer browser, select Inventory > Storage > Replication.

For information about supported storage array models and replication types, see the Server Automation
Compatibility Matrix.

Chapter 1



Fabric Assets €

Asset Discovery

This feature provides visibility into fabric configurations in a SAN. Storage elements in a fabric include
physical entities, such as fabric switches, ports, and security items, such as Zones and Zonesets.

Minimal information about fabrics is displayed in the user interface, such as when there is a connection
between the fabric and the server, the Device Explorer displays fabrics. To view detailed information about
fabric assets, you must use the Global File System (OGFS) feature. See Global File System (OGFS) on
page 77 for more information.

With this feature, a system administrator can view the following:

*  Physical fabric configuration

*  Security configuration enabled in the fibre channel network

*  Servers and SAN storage devices connected to the fibre channel network
»  Storage resources shared between applications or managed servers

Storage Visibility and Automation captures the following fabric information in a SAN:

Fibre Switch and Fabrics L —Identifies whether a fibre switch is a principal switch or a subordinate
switch of the fabric. After the principal switch is identified, Storage Visibility and Automation gathers
information on the connected fibre switches and end devices, such as servers, SAN-based storage devices,
and so on. Storage Visibility and Automation lists the switch ports for all switches in the fabric. Storage
Visibility and Automation collects the Manufacturer, Model, Serial Number, Firmware, Hardware Version,
World Wide Name (WWN), Domain Name, IP, and the number of Ports for each of the switch. Storage
Visibility and Automation identifies a physical fabric by the WWN of the principal switch. If the role of a
switch changes from subordinate to principal, the identity of the fabric changes—this change is discovered
by SE. Storage Visibility and Automation does not collect routing table information in each switch and does
not support multiple vendor fabrics that are in an interop configuration.

Switch Enclosure—Information about the switch enclosure includes blades and slots that make up that
enclosure. This feature applies to director-class switches. Storage Visibility and Automation collects the Part
Number, Serial Number, Manufacturer, and Model.

Switch Blade—Blade information about the enclosure. Storage Visibility and Automation collects the
Manufacturer, Model and Serial Number of the blade.

Switch Ports—The fibre channel port World Wide Name (WWN), including information about F_Ports,

E Ports, and G_Ports. For each port, Storage Visibility and Automation collects the WWN, Port Number,
Port State, and Port FCID (Fibre Channel ID). If enclosure is captured, Storage Visibility and Automation
also collects slot information for the ports. Storage Visibility and Automation does not collect node loop
ports attached to an arbitrated loop. However, Storage Visibility and Automation collects fabric switch loop
port.

E_Ports/Inter-Switch Links—Inter-Switch Link (ISL) information. SE identifies the E_Ports that
participate in the ISLs for each pair of fibre switches.

Ports Connectivity and N_Ports—For each fibre switch port, Storage Visibility and Automation collects
the World Wide Name (WWN) of the connected N_Port, such as FCA Port (REF-008) and Storage Array
Port (REF-009). This information helps identify the dependency chain from the initiators to the targets
through the fabric, and also displays information about the multi-path between the initiators and the targets.
Ports that are discovered without any parent device information are marked as Unknown Connected Ports.
Storage Visibility and Automation does not collect node loop ports attached to an arbitrated loop.

Zoning Database and Zones @ —All active zones configured in the zoning database of the principal
switch. Zones contain a list of World Wide Name (WWN) and alias naming. Alias naming may not be
supported by all fibre switch vendors. A zoning database may not be synchronized between switches. The
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administrator should verify that zoning databases across the fabric are synchronized. Storage Visibility and
Automation does not capture the zoning information if the list (members) are configured as Domain:Port
format.

Alias L'E —Storage Visibility and Automation collects all alias in a zoning database. Alias is not supported
by McData-based fabric switches. Storage Visibility and Automation does not collect the alias information if
the list (members) are configured as Domain:Port format.

Zonesets @ —Storage Visibility and Automation collects all active zonesets in a fabric. Storage Visibility
and Automation also collects all zones that make up a zoneset.

Fabric Assets and Relationships

Storage Visibility and Automation displays relationships between fabric elements and other storage asset
discovery features. See Table 6.

Table 6 Fabric Assets and Relationships

Fabric Asset External Element Description
Connected N_Port | Ports connectivity Provides the point-to-point links
through a fabric.

NetApp Assets @

This feature provides visibility into NetApp storage configurations in a SAN or IP network, such as File I/O
based storage entities (Filer Volumes, Qtrees) and Fabric elements (FCA/Ports).

A NetApp storage administrator can view the following:

*  NetApp storage utilization and configuration

*  Storage resources shared between applications or managed servers
SE captures the following NetApp information in a SAN:

NetApp Filer—Filer Name, Manufacturer, Model, Serial Number, Firmware Version, Customer, IP
Address, Facility, Status, Description, Discovered on, Last Scan, Scan Status, Object ID.

Disks—NetApp disk storage capacity. Storage Visibility and Automation discovers the raw capacity of the
disk and discovers whether the disk is consumed by RAID groups.

RAID Groups—NetApp creates RAID groups based on disks. RAID group is an internal entity that is not
configured by the user. Storage Visibility and Automation does not display storage information for RAID
groups. The storage information is not available through the API. It is derived by the size of the disk and
configuration, such as RAID 4 or RAID 4DP.

Plex—NetApp creates Plex based on RAID Groups. Plex is an internal entity that is not configured by the
user. Storage Visibility and Automation does not display storage information for Plex. The storage
information is not available through the API—it is derived by the size of the RAID Group.

Aggregates k‘;} —Aggregate is a storage entity that is introduced by ONTAP 7.0. Storage Visibility and
Automation discovers aggregate caption and aggregate capacity.
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Asset Discovery

File I/O—NetApp exposes storage resources for File I/O. NetApp volumes, Qtree and Directories are
exposed through CIFS or NFS for File I/O. Storage Visibility and Automation collects storage information
related to File I/O access.

NetApp Volumes—Filer volume information that includes storage capacity, vFiler that the volumes are
associated with, aggregate that the volume consumes, volume type (Traditional or Flex), snapshot reserve,
snapshot reserve size, and whether the volume is a target or a source of replication.

Traditional Volumes—Volumes based on ONTAP 6.5 and traditional volumes in ONTAP 7.0 or higher.

Flex Volumes—Flex is a storage entity that is introduced by ONTAP 7.0. In addition to filer volume
information, Storage Visibility and Automation also discovers committed capacity and space guarantee
(volume, none, file) for flex volumes.

Qtrees—A subdirectory in a volume that acts as a virtual sub-volume with special attributes, such as
primarily quotas and permissions.

Quota—The quota against the NetApp volumes. Quota that is applied on the Qtrees is also captured at the
volume level. Storage Visibility and Automation discovers the following quota information:

*  Caption

*  Type (tree, user, or group)

*  Qtree (Qtree that is applicable)

*  Unix ID (ID of the user or group, whichever is applicable)

*  Windows ID (ID of the user or group, whichever is applicable)
*  Space threshold

*  Space threshold unit (in KB/MB, and so on)

*  Quota target (Default targets are discovered as *.)

Quota will also have zero or more QuotaLimit. QuotaLimit captures the following information:
*  Limit type (DiskSpace or NumberOfFiles)

*  Soft Limit Value

*  Soft Limit Unit

*  Hard Limit Value

*  Hard Limit Unit

Directory—Directory paths that are exported through CIFS share or NFS. Storage Visibility and
Automation does not discover all directories that are residing in the NetApp volume.

File I/0 Exports—NetApp provides exporting NetApp Volumes using File I/O through CIFS and NFS
protocol.

CIFS—Common Internet File System. NetApp shares and the volume/qtree/directory path. Storage
Visibility and Automation does not discover the managed servers that are consuming the NetApp resources
through CIFS protocol.

NFS—Network File System. Export information for the volumes/Qtree/directory path. HP might discover
stale information, based on the data available to it through the API.

NetApp vFiler I:E —vFiler configuration. Storage Visibility and Automation discovers IP addresses and
the volume path that is configured for each vFiler. NetApp requires that a MultiStore license is enabled in
the filer to support virtual filers. If a MultiStore license is not enabled, Storage Visibility and Automation
assumes that a default vfilerQ exists in the system.
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NetApp Assets and Relationships

Storage Visibility and Automation displays relationships between NetApp elements and other storage asset
discovery features. See Table 7.

Table 7 Fabric Assets and Relationships

Fabric Asset External Element Description

Connected fabric port Ports connectivity Provides the point-to-point links
through a fabric.

NFS exports and file I/O | Remote file system in a server Provides supply chain from the

storage elements managed server to the NetApp, based
on NFS protocol.

Update from Storage Essentials

Since, by default, storage information is collected from SE once every 12 hours, you might need updated
information about a NetApp filer more frequently than twice a day. You can modify this data collection
frequency by modifying a setting in SE. See the Storage Essentials SRM Software User Guide for
information about configuring the schedule for data collection.

You can also request an update of SAN information from SE at the NetApp level. See Update from Storage
Essentials on page 15 for more information.

Open with Storage Essentials

When you are viewing storage information about a NetApp filer in Storage Visibility and Automation and
would also like to view storage information for the same NetApp filer in Storage Essentials, you can launch
Storage Essentials to display the data that was discovered. See Open with Storage Essentials (Click &
Launch) on page 16 for more information. See the Storage Essentials SRM Software User Guide for
information about the discovery process in SE.

Frequently Asked Questions

Table 8 answers some frequently asked questions on finding information about NetApp assets.

Table 8 Frequently Asked Questions About NetApp Assets

Question How to Find the Answer
1. | What storage is available in the NetApp in a *  Viewing Summary of a NAS Filer on
datacenter? page 45
2. | What file systems are exported to the servers? *  Viewing Exports for a vFiler on page 46
3. | What is the storage utilization of the NetApp? *  Viewing Summary of a NAS Filer on
page 45
4. | Does the NetApp Filer provide room for growth? |+  Viewing Summary of a NAS Filer on
page 45
5. | When do the NetApp Filers run out of space? *  Viewing Summary of a NAS Filer on
page 45
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Viewing NAS Filers

To view NAS Filers:

1 In the navigation pane, select Devices > Storage > NAS Filers.

2 From the View drop-down list, select Summary.

Viewing the NAS Filer Storage Configuration

To view information about NAS Filer storage configuration:

1 In the navigation pane, select Devices > Storage > NAS Filers.
2 Open a NAS Filer.

3 In the navigation pane, select Inventory.

4

In Views pane, select a configuration to change the display in the content pane.

Viewing Summary of a NAS Filer

To view a NAS filer summary:

1 In the navigation pane, select Devices > Storage > NAS Filers.
2 From the View drop-down list, select Summary.

3 In the content pane, select a NAS Filer and open it to display the Summary.

Viewing NAS Filer Properties

To view the properties of a NAS Filer:
1 In the navigation pane, select Devices > Storage > NAS Filers.
2 From the View drop-down list, select Properties.

3 Inthe content pane, select a NAS Filer and then open it to display its properties.

Viewing Customers for a NAS Filer

To view customers that exist in the Model Repository:

1 In the navigation pane, select Devices > Storage > NAS Filers.
From the View drop-down list, select Properties.
In the content pane, select a NAS Filer and open it to display the Properties.

Click the “Change” link next to Customers to open the Select Customer dialog.
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In the Select Customer dialog, select a customer and then click Select to display its properties.
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Viewing the NAS Filer History Log

To view the history log for the NAS Filer:

1

2
3
4

(6}

In the navigation pane, select Devices > Storage > NAS Filers.
From the View drop-down list, select History.
In the content pane, select a NAS Filer and open it to display the history log.

From the View drop-down list, select a time range for this history log, such as Last Day, Last Week,
Last Month, Last Quarter, or Custom Range.

(Optional) Right-click an event to open the Event Details dialog.

(Optional) Click Export to export the history log to a file, such as .csv or .html.

Viewing vFilers

To view the VFilers that are configured in the NetApp system:

1
2
3

In the navigation pane, select Device > Storage > NAS Filers.
In the content pane, select a NAS Filer.

From the View drop-down list, select Virtualization.

Viewing Volumes Configured for a vFiler

To view the volumes that are configured for a vFiler:

1
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In the navigation pane, select Devices > Storage > NAS Filers.
In the content pane, select a NAS Filer and then open it.

In the Views pane, select Inventory > Virtualization.

From the View drop-down list, select Volumes.

In the content pane, select a vFiler.

Viewing Exports for a vFiler

To view the exports for a vFiler:

1
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In the navigation pane, select Devices > Storage > NAS Filers.
In the content pane, select a NAS Filer and then open it.

In the Views pane, select Inventory > Virtualization.

From the View drop-down list, select Exports.

In the content pane, select a vFiler.
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Viewing Storage Summary for a NAS Filer

To view the summary of storage information offered by a NAS filer:
1 In the navigation pane, select Devices > Storage > NAS Filers.
2 In the content pane, select a NAS filer and then open it.

3 Inthe Views pane, select Inventory > Storage. The content pane displays summary information.

Viewing Disks in a NAS Filer

To view the disks in a NAS Filer:

1 In the navigation pane, select Devices > Storage > NAS Filers.
2 In the content pane, select a NAS Filer and then open it.

3 Inthe Views pane, select Inventory > Storage > Disks.
4

Select a disk and then open it.

Viewing NAS Filer Disk Properties

To view the properties of a NAS Filer disk:

1 In the navigation pane, select Devices > Storage > NAS Filers.
In the content pane, select a NAS Filer and then open it.
In the Views pane, select Inventory > Storage > Disks.

From the View drop-down list, select Properties.
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Select a disk to display its properties.

Viewing Filer Volumes Created by a Disk

To view the filer volumes that are created by a disk:

1 In the navigation pane, select Devices > Storage > NAS Filers.
In the content pane, select a NAS Filer and then open it.
In the Views pane, select Inventory > Storage > Disks.

Select a disk.
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From the View drop-down list, select Volumes.

Viewing Aggregates Created by a Disk

To view the NAS Filer aggregates that are created by a disk:

1 In the navigation pane, select Devices > Storage > NAS Filers.
2 In the content pane, select a NAS Filer and then open it.

3 Inthe Views pane, select Inventory > Storage > Disks.
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4  Select a disk.

5 From the View drop-down list, select Aggregates.

Viewing Plexes on a Disk

To view the plexes that are on top of a disk in the storage supply chain:
1 In the navigation pane, select Devices > Storage > NAS Filers.
In the content pane, select a NAS Filer and then open it.

In the Views pane, select Inventory > Storage > Disks.

Select a disk.
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From the View drop-down list, select Plexes.

Viewing RAID Groups on a Disk

To view the RAID groups that are on top of a disk in the storage supply chain:
1 In the navigation pane, select Devices > Storage > NAS Filers.

2 In the content pane, select a NAS Filer and then open it.
3 Inthe Views pane, select Inventory > Storage > Disks.
4 Select a disk.

5 From the View drop-down list, select RAID Groups.

Viewing Aggregates Configured in a NAS Filer

To view the aggregates that are configured in a NAS Filer:

1 In the navigation pane, select Devices > Storage > NAS Filers.
2 In the content pane, select a NAS Filer and then open it.

3 Inthe Views pane, select Inventory > Storage > Aggregates.

4 From the View drop-down list, select Properties.

Viewing Aggregate Properties

To view the properties of an aggregate:

1 In the navigation pane, select Devices > Storage > NAS Filers.
2 In the content pane, select a NAS Filer and then open it.

3 Inthe Views pane, select Inventory > Storage > Aggregates.
4 From the View drop-down list, select Properties.
5

Select an aggregate.
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Viewing Filer Volumes Created by an Aggregate

To view the filer volumes that are created by an aggregate:

1 In the navigation pane, select Devices > Storage > NAS Filers.

In the content pane, select a NAS Filer and then open it.
In the Views pane, select Inventory > Storage > Aggregates.

From the View drop-down list, select Volumes.
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Select an aggregate.

Viewing Antecedents and Dependents of an Aggregate

To view the antecedent and dependent of the aggregate storage supply chain:

1 In the navigation pane, select Devices > Storage > NAS Filers.
In the content pane, select a NAS Filer and then open it.
In the Views pane, select Inventory > Storage > Aggregates.

Select an aggregate.
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From the View drop-down list, select Composition.

Viewing Plexes Used by an Aggregate

To view the plexes that are used by an aggregate:

1 In the navigation pane, select Devices > Storage > NAS Filers.
In the content pane, select a NAS Filer and then open it.
In the Views pane, select Inventory > Storage > Aggregates.

Select an aggregate.
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From the View drop-down list, select Plexes.

Viewing RAID Groups Consumed by an Aggregate

To view the RAID groups that are consumed by an aggregate:
1 In the navigation pane, select Devices > Storage > NAS Filers.
In the content pane, select a NAS Filer and then open it.

In the Views pane, select Inventory > Storage > Aggregates.

Select an aggregate.
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From the View drop-down list, select RAID Groups.

Asset Discovery
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Viewing Filer Volumes Configured in a NAS Filer

To view the filer volumes that are configured in a NAS Filer:

1 In the navigation pane, select Devices > Storage > NAS Filers.
2 In the content pane, select a NAS Filer and then open it.

3 Inthe Views pane, select Inventory > Storage > Volumes.
4

From the View drop-down list, select Properties.

Viewing Filer Volume Properties

To view the properties of a filer volume:

1 In the navigation pane, select Devices > Storage > NAS Filers.
2 In the content pane, select a NAS Filer and then open it.

3 Inthe Views pane, select Inventory > Storage > Volumes.

4 From the View drop-down list, select Properties.

5 In the content pane, select a filer volume.

Viewing Antecedents and Dependents of a Volume for a NAS Filer

To view the antecedent and dependent of a volume storage supply chain:
1 In the navigation pane, select Devices > Storage > NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 Inthe Views pane, select Inventory > Storage > Volumes.

4 Select a volume.
5

From the View drop-down list, select Composition.

Viewing Qirees Created in a Volume

To view the Qitrees that are created in a volume:

1 In the navigation pane, select Devices > Storage > NAS Filers.
2 In the content pane, select a NAS Filer and then open it.

3 Inthe Views pane, select Inventory > Storage > Volumes.

4 Select a volume.

5  From the View drop-down list, select Qtree.

Chapter 1



Viewing Quota Created at the Volume or Qiree

To view the quota that is created at the volume or the Qtree for a volume:
1 In the navigation pane, select Devices > Storage > NAS Filers.

In the content pane, select a NAS Filer and then open it.

In the Views pane, select Inventory > Storage > Volumes.

Select a volume.
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From the View drop-down list, select Quota.

A disk quota is a set of rules that restrict disk space and the number of files used by a user or a group. A
quota can also restrict the total space and files used in a Qtree or the usage of users and groups within a
Qtree. For example, you could create a user quota that specifies that a particular user can use up to 225MB
of disk space in a given Qtree in a given volume before a warning is issued (soft limit) and up to 250MB
maximum (hard limit).

Viewing Exports for a Volume

To view the exports for a volume:

1 In the navigation pane, select Devices > Storage > NAS Filers.
2 In the content pane, select a NAS Filer and then open it.

3 Inthe Views pane, select Inventory > Storage > Volumes.

4 Select a volume.
5

From the View drop-down list, select Exports.

Oracle Database Assets @

Asset Discovery

This feature provides visibility into the Oracle storage configurations in a SAN or Network Attached
Storage (NAS). These configurations include physical entities, such as fabric switches and SAN Arrays.

A database administrator can view the following:

*  Oracle database storage configuration

*  System resources available to the Oracle databases in one or more servers in a data center
*  Servers and SAN Storage devices connected to the FC network

*  Storage resources shared between Oracle Instances and/or hosts

*  Network Attached Storage (NAS) resources that the Oracle Databases depends on

Storage Visibility and Automation provides the following Oracle database storage configuration in a SAN or
NAS:

Oracle Instance—Storage-related information for the Oracle Instance. Storage Visibility and Automation
collects the version of the Oracle database that is running the Oracle instance.
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Storage Elements—Storage elements configured for an Oracle instance can be classified as physical
database storage and logical database storage. Physical database storage includes data files and redo logs
that directly consume system storage resources, such as file systems and partitions. Logical database
storage includes entities such as tablespaces that are created inside the instance that is consuming different
physical and logical storage entities.

Data Files @ —The file path, allocated space, and space used for each data file. Oracle data files can
reside directly on the file system or they can utilize raw partitions.

* Based on File System—Data files can be created directly in a file system and specified to the Oracle
database. Storage Visibility and Automation collect information about the file path of the data file. HP
uses this information to calculate the file system that is consumed by the data file.

* Based on Raw Partition—Storage Visibility and Automation collects partition information. HP uses
this information to calculate the storage supply chain that is consumed by the data file.

*  Based on ASM Files—For this use case, the storage supply chain includes the following elements:
ASM File, ASM Diskgroup, and ASMDisk(s). ASMDisk(s) are created on raw disk partitions, Logical
Unit Numbers (LUNS), raw logical volumes (LVM), or NFS files.

Redo Logs—Redo logs information for the Oracle instance, such as file path and allocated space for the
redo log.

Logical Database Storage—Storage-related information for the tablespace and its association to the
physical storage entities. Storage Visibility and Automation does not collect storage entities, such as data
segments, extents, data block, schema, table, and index.

Tablespaces m —Storage Visibility and Automation collects tablespace information for each Oracle
instance, such as the status, allocated space, and space used for each of the tablespaces.

Automatic Storage Management (ASM)—Storage configuration and utilization of the Oracle database.
ASM helps manage volumes that might be composed of block-based devices (SAN) or file-based devices
(NFS), with additional data replication inside ASM.

Database Assets and Relationships

Storage Visibility and Automation displays information about relationships between the database elements
and other storage asset discovery features. See Table 9.

Table 9 Database Assets and Relationships

Database Asset External Element Description
SAN-based physical Block storage dependency Provides the dependency chain
database storage between the database storage elements

and SAN arrays through System
(server) resources and fabric.

NAS-based physical NAS storage dependency Provides the dependency chain

database storage between the database storage
elements, Server resources and
NetApp.
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Frequently Asked Questions

Table 10 answers some frequently asked questions on finding information about Oracle database assets.

Table 10 Frequently Asked Questions About Database Assets

Question

How to Find the Answer

What are the storage resources used by an Oracle
instance?

*  Viewing Tablespaces Configured in the
Oracle Instance on page 54

e Viewing Tablespace Antecedents and
Dependents on page 55

e Viewing Storage Supply Chain
Connectivity of the Tablespace on page 55

What is the FC SAN network configuration that an
Oracle database depends on?

*  Viewing Storage Supply Chain
Connectivity of the Tablespace on page 55

Are critical Oracle instances configured for high
availability, such as multiple access paths? What
are the redundant paths between a server and a
storage array for an Oracle instance?

*  Viewing Storage Supply Chain
Connectivity of the Tablespace on page 55

*  SAN Map on page 67
*  Storage Map on page 67

What is the storage utilization of an Oracle
instance?

*  Viewing Properties of the Oracle Instance
on page 54

Is Oracle-consumed storage on a remote SAN
array configured for replication?

*  Viewing Storage Supply Chain
Connectivity of the Tablespace on page 55

*  Viewing Utilized Targets on page 58

What is causing Oracle instance performance
degradation? How is all of the SAN configuration
impacting the Oracle instance? What are the shared
resources between Oracle instances?

*  Viewing Storage Volumes with Access
Paths for Remote Initiators on page 35

e Viewing the Access Path from the Volume
on page 39

*  Viewing Storage Supply Chain
Connectivity of the Tablespace on page 55

Does the SAN provide room for growth?

*  Viewing Storage Supply Chain
Connectivity of the Tablespace on page 55

*  Viewing Utilized Fabrics on page 58
*  Viewing Utilized Switches on page 58
*  Viewing Utilized Targets on page 58

What are the NAS (Network Attached Storage)
resources used by an Oracle instance?

*  Viewing Storage Supply Chain
Connectivity of the Tablespace on page 55

*  Viewing Utilized Targets on page 58

Asset Discovery
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Viewing Databases

To view databases discovered by the Database Scanner for Oracle:

1

2
3
4

In the navigation pane, select Library > Databases.

From the View drop-down list, select Properties.

In the content pane, select the database. The content pane displays a list of databases.
(Optional) Select a target and then select one of the following options from the Actions menu:
*  Open—Opens the Database Browser with the selected view.

*  Rename (F2)—Provides an editable ficld to rename the database directly in the table. The
command is enabled only if the user has permissions.

*  Delete—Removes the database from the Model Repository. This command is enabled only if you
have permission. This command does not remove the login credentials for the Database Scanner for
Oracle.

Viewing Database Storage Configurations

To view database storage configurations:

1

2
3
4

In the navigation pane, select Library > Databases.
From the View drop-down list, select Properties.
In the content pane, select the database and then double-click or right-click to open it.

In the Views pane, select Inventory > Redologs. The content pane displays configuration information.

Viewing Properties of the Oracle Instance

To view the properties of the Oracle instance:

1
2
3

In the navigation pane, select Library > Databases.
From the View drop-down list, select Properties.

In the content pane, select the database and then double-click or right-click to open it. The content pane
displays the properties of the selected database.

Important to Know

File > Save—This action is enabled when the name or description is edited. This saves the changes to the
system.

File > Revert—This action is enabled when the name or description is edited. This reverts the changes to
the previous settings.

Viewing Tablespaces Configured in the Oracle Instance

To view tablespaces configured in the Oracle instance:

1
2
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In the navigation pane, select Library > Databases.

From the View drop-down list, select Properties.
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3

4

5

In the content pane, select the database and then double-click or right-click to open it.
In the navigation pane, select Inventory.

From the Views pane, select > Tablespaces. The content pane displays a list of tablespaces.

Viewing Tablespace Properties

To view tablespace properties:

1

2
3
4
5
6

In the navigation pane, select Library > Databases.

From the View drop-down list, select Properties.

In the content pane, select the database and then double-click or right-click to open it.
In the navigation pane, select Inventory.

In the Views pane, select > Tablespaces.

In the content pane, select a tablespace and then review the lower part of the content pane for the
properties.

Viewing Tablespace Antecedents and Dependents

To view antecedents and dependents of a tablespace:

1
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In the navigation pane, select Library > Databases.

From the View drop-down list, select Properties.

In the content pane, select the database and then double-click or right-click to open it.

In the View command, select Inventory > Tablespaces.

In the content pane, select a tablespace and then review the lower part of the content pane.
From the View drop-down list, select Composition. The content pane displays the composition.
(Optional) Select a target and then select the following option from the Actions menu:

*  Open—Opens the SAN Array, Server Storage, or NAS Filer view.

Viewing Storage Supply Chain Connectivity of the Tablespace

Asset Discovery

To view the connectivity of the database storage element:

1

2
3
4
5
6

In the navigation pane, select Library > Databases.

From the View drop-down list, select Properties.

In the content pane, select the database and then double-click or right-click to open it.

In the Views pane, select Inventory > Tablespaces.

In the content pane, select a tablespace and then review the lower part of the content pane.

From the View drop-down list, select Connectivity. The content pane displays the connectivity.
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Viewing Redo Logs

To view the redo logs:

1 In the navigation pane, select Library > Databases.

2 From the View drop-down list, select Properties.

3 In the content pane, select the database and then double-click or right-click to open it.
4

In the Views pane, select Inventory > Redologs. The content pane displays the information.

Viewing Redo Log Properties

To view properties of a redo log:

1 In the navigation pane, select Library > Databases.

2 From the View drop-down list, select Properties.

3 In the content pane, select the database and then double-click or right-click to open it.
4 In the Views pane, select Inventory > Redologs.

5 In the content pane, select a redo log, then review the lower part of the content pane for the properties.

Viewing Redologs Antecedents and Dependents

To view the composition of the redo logs:

1 In the navigation pane, select Library > Databases.
From the View drop-down list, select Properties.

In the content pane, select the database and then double-click or right-click to open it.

2

3

4 In the Views pane, select Inventory > Redologs.

5 From the View drop-down list, select Composition.
6

In the content pane, select a redo log and then review the lower part of the content pane for the
composition.

7  (Optional) Select a target and then select the following option from the Actions menu:

*  Open—Opens the SAN Array, Server Storage, or NAS Filer view.

Viewing Redologs Connectivity

To view the connectivity of the database storage element:

1 In the navigation pane, select Library > Databases.
From the View drop-down list, select Properties.

In the content pane, select the database and then open it.

2

3

4 In the Views pane, select Inventory > Redologs.

5 In the content pane, select a redolog and then review the lower part of the content pane.
6

From the View drop-down list, select Connectivity. The content pane displays the connectivity.
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Viewing Datafiles

To view the datafiles:

1 In the navigation pane, select Library > Databases.

2 From the View drop-down list, select Properties.

3 In the content pane, select the database and then double-click or right-click to open it.
4

In the Views pane, select Inventory > Datafiles. The content pane displays a list of datafiles.

Viewing Datafile Properties

To view the properties of a datdfile:

1 In the navigation pane, select Library > Databases.
From the View drop-down list, select Properties.

In the content pane, select the database and then double-click or right-click to open it.

2

3

4 In the Views pane, select Inventory > Datafiles.

5 From the View drop-down list, select Properties. The content pane displays the properties.
6

In the content pane, select a datafile and then review the lower part of the content pane.

Viewing Datafile Antecedents and Dependents

To view the composition of the datafiles:

1 In the navigation pane, select Library > Databases.
From the View drop-down list, select Properties.

In the content pane, select the database and then double-click or right-click to open it.

2

3

4 In the Views pane, select Inventory > Datafiles.

5 From the View drop-down list, select Composition.

6 In the content pane, select a datafile, then review the lower part of the content pane for the composition.
7

(Optional) Select a target and then select the Open option from the Actions menu, which opens the
SAN Array, Server Storage, or NAS Filer view.

Viewing Datafile Connectivity

Asset Discovery

To view the connectivity of the database storage element:

1 In the navigation pane, select Library > Databases.
From the View drop-down list, select Properties.

In the content pane, select the database and then double-click or right-click to open it.

2

3

4 In the Views pane, select Inventory > Datafiles.

5 In the content pane, select a datafile and then review the lower part of the content pane.
6

From the View drop-down list, select Connectivity. The content pane displays the connectivity.

57



58

Viewing Servers Hosting a Database

To view servers hosting a database:

1 In the navigation pane, select Library > Databases.
From the View drop-down list, select Properties.
In the content pane, select the database and then double-click or right-click to open it.

In the Views pane, select Relationships > Severs. The content pane displays a list of servers.
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(Optional) Select a target and then select one of the following options from the Actions menu:

*  Open—Opens the Device Explorer.

) The column in this panel is the same as the main panel for the server rendered in the All Managed Servers
feature. All columns are not described above.

Viewing Utilized Fabrics

To view utilized fabrics:

1 In the navigation pane, select Library > Databases.

2 From the View drop-down list, select Properties.

3 In the content pane, select the database and then double-click or right-click to open it.

4 In the Views pane, select Relationships > SAN Fabrics. The content pane displays a list of fabrics.

Viewing Utilized Switches

To view utilized switches:

1 In the navigation pane, select Library > Databases.

2 From the View drop-down list, select Properties.

3 In the content pane, select the database and then double-click or right-click to open it.

4 In the Views pane, select Relationships > SAN Switches. The content pane displays a list of switches.

Viewing Utilized Targets

To view utilized targets:

1 In the navigation pane, select Library > Databases.

2 From the View drop-down list, select Properties.

3 In the content pane, select the database and then double-click or right-click to open it.

4 In the Views pane, select Relationships > SAN Arrays. The content pane displays a list of targets.
5 (Optional) Select a target and then select one of the following options from the Actions menu:

*  Open—Opens the SAN Array Browser.
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) The column in this panel is the same as the main panel for the arrays rendered in the SAN Array feature. All
columns are not described above.

Viewing the Database History Log

To view the history log:

1 In the navigation pane, select Library > Databases.
2 From the View drop-down list, select History.

3 Inthe content pane, select the database and then double-click or right-click to open it. The content pane
displays the history log.

4 (Optional) Select a target and then select the following option from the Actions menu:

View Event Details—Displays the detailed information for the event.

Device Group Assets #

The Device Groups feature in Storage Visibility and Automation provides a useful way for gathering storage
devices into collections. Grouping storage devices enables you to view all of the devices simultaneously,
instead of viewing individual devices, one at a time.

This feature allows you to include storage devices in a device group and view a history of events for a device
group. You can view detailed storage device history, such as information in snapshot messages from the
synchronization process. Device groups and a history log can help you troubleshoot problems.

The Device Groups feature in Storage Visibility and Automation is modeled after the Device Groups feature
in SA. See the S4 User Guide: Server Automation for more information about managing device groups.

You can create the following types of storage device groups:

*  Static Device Group—This group contains heterogeneous storage devices, such as any combination of
servers, storage arrays, and NetApp filers.

*  Dynamic Device Group—This group contains a homogeneous set of storage devices, such as servers
or storage systems (SAN Arrays and NAS filers). A dynamic device group contains only one type of
storage device because it is generated based on device properties. A dynamic device group cannot
contain a combination of different types of storage devices.

See the S4 User Guide: Server Automation for information about adding a server to a static or dynamic
device group.
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Static Device Groups #

Static storage device groups can contain heterogeneous devices—one or more SAN arrays, NAS filers, and
managed servers.

Creating a Static Device Group

To create a static device group:
1 In the navigation pane, select Device Groups > Public.
2 From the Actions menu, select Device Group > New Static Group.

3 Enter a new name for the static device group that you just created. Click outside the name field to save
it. The default name is New Device Group.

Adding a Device to a Static Device Group

To add a storage device to a static device group:

1 In the Device Group Browser, select the device group.
From the Actions menu, select Open to display the Group Browser.
In the Views pane, select Device Membership.

In the Device Membership window, from the Actions menu, select Add.
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In the Add Members to Static Group dialog, select one or more members, such as such as any
combination of servers, storage arrays, and NetApp filers.

6 Click Add to Group.

Removing a Device from a Static Device Group

To remove a storage device from a static device group:

1 In the Static Device Group window, select one or more storage devices.

2 From the Actions menu, select Remove Members.

Chapter 1



Dynamic Device Groups B

Dynamic storage device groups can contain only homogeneous devices—one or more storage systems (SAN
arrays and NAS filers), and managed servers.

Creating a Dynamic Device Group

To create a dynamic device group:

1

2
3
4

In the navigation pane, select Device Groups > Public.
From the Actions menu, select Device Group > New Dynamic Group
Enter a new name for the dynamic device group that you just created.

Press enter to save it. The default name is New Device Group plus an incremental number, such as New
Device Group 4.

Adding a Device to a Dynamic Device Group

To add a storage device to a dynamic device group:

1

2
3
4
5

10
1

12

In the Device Group Browser, select the device group.

From the Actions menu, select Open to display the Group Browser.

In the Views pane, select Device Membership.

In the Content pane, specify the rules for the dynamic storage device group.

From the first drop-down list, select Server or Storage Systems. Depending on the attribute you select,
options available for the operator and values for the rule will change. The default is Storage Systems.

From the second drop-down, select Facility Name, Manufacturer, Model, Name, Object ID, Port, RAID
Type, or Serial Number. The default is Manufacturer.

Select the operator from the third drop-down list. The default is Contains.

Enter a value in the field, or select a value from the drop-down list, or click "= to select multiple values
from the Select Values window.

Click &/ to add additional rules and repeat steps 4 through 6. Click = to delete any rules.
Select the logic (And/Or) to be applied for every rule in the query.

Click Preview to view the storage devices that matched the rule—the rule that defines members of the
dynamic device group.

From the File menu, click Save to save the rules.

Editing a Rule for a Dynamic Device Group

To change a rule for a dynamic device group:

1
2
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Open the Group Browser and then select a dynamic device group.

In the Device Membership window, change the rule and then save it.
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Device History Log

A history of events for a storage device group can help you troubleshoot problems.

Viewing the History Log

To view the history log for a device group:

1
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Open a storage device group.
In the Views pane, select History.
From the View drop-down list, select the time period for the history log.

(Optional) Right-click an event to open the Event Details dialog.

(Optional) Click Export to export the history log to a file, such as .csv or .html.
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2 Storage Compliance

The storage compliance feature provides visibility into storage configurations in a managed server or device
group by allowing you to specify audit rules that check initiator ports connected to multiple ports, FCAs,
LUNs (available but not mounted), RAID levels, SAN storage, and so on.

) Storage audit rules are run against data in the Model Repository.

Audit Rules, Schedule, and Results

The storage compliance feature provides visibility into storage configurations in a managed server or device
group by allowing you to specify audit rules that check initiator ports connected to multiple ports, FCAs,
LUNs available but not mounted, RAID levels, SAN storage, and so on. Storage audit rules are run against
data in the Model Repository.

The following table lists the audit rules and parameters for storage compliance. These rules allow you to
define the check for minimum, maximum, or exact numbers. The compliance rules that involve ports,
switches, or fabrics, check active ports only. These types of compliance rules do not check for physical port

connectivity.

Storage Audit Rules Storage Parameter

Unmounted Volume Capacity Acceptable total capacity of unmounted volumes in bytes

Unmounted Volume Count Acceptable number of unmounted volumes

Fabrics Acceptable number of fabrics

FCA Acceptable number of Fibre Channel Adapters (FCAs)

Initiator Ports Acceptable number of ports

Switches Acceptable number of switches

Target Ports Acceptable number of ports

RAID Type Acceptable RAID types on the target storage array
Note: The audit will fail if this rule is selected and no RAID type is
specified

Unreplicated LUN count Acceptable number of Unreplicated LUN count

) The compliance rules that involve ports, switches, or fabrics, check active ports only. These types of
compliance rules do not check for physical port connectivity.
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Audit Browser

The Audit Browser shows storage rules selected in an audit.

Avainhle for Audit Poliey: Selarted for Audit Policy:
- gl LU Utization
(% H Mw r Urrepbcabed LUN Count
G- ol RAID Type Unreplicated LUN Count
£ oy Unreplicated LUN Count
£ Urrepicated LUN Count

The figure also shows an unreplicated LUN count choice in the Source list under Rules > Storage
Compliance Checks. See the S4 User Guide: Audit & Compliance for information about specifying rule

details.

Select Server

This section describes how to select a server to use as an audit target.

[mmect [ s ]

The sbiree souroe  uied B mahe sehed Bors for Oealeg rules ordy,
Thes i rak e o Tt vl bes used foor thee Ausdt o Gnspshat.

Salect & Sorver to be used an & source.
Salbect 8 Seurce

- W Deace Groups
L e L

1 In the Source window, choose Servers and Device Groups.

2 Inthe Select Server window, Select a Source tree, choose All Managed Servers.
3 Select the server to use as an audit target.

See the User Guide: Audit and Compliance for information about adding audit targets.
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Audit Schedule

To schedule an audit:

1 Inthe Views section, choose Schedule.

The jobs wll et dally at e specfed start tme.

Time and Duration (=]
T Zarse: 15T - AsiaCabutta

Be [ ]

Sanrt Tre: 0553 PH 3

faxct: wed 03pér013 [

Ticke:t D

2 Inthe Schedule section, choose the schedule frequency, schedule time, and schedule duration.

See the User Guide.: Audit and Compliance for more information about scheduling audits.

Audit Summary

To display a summary of audit results:

1 In the Install Software screen, in the All Steps section, choose Job Status.

Targetse 1outef 1serven completnd

iﬁmii:z;;mm

3 Expert. =B |

Action ] Suks =

15 Server: rode 98-8 1o vae. ho oom -
Cropeall Sarm Statn w Succeeded

il A B _ O B iy amFles i orvren Flet Citawar e ipam <ommen gl L 6.5_08]
OFAE-shared w53, 0U0.0 pol SeProgr aeFies %)

PR -pr -win- 50,000 s WProgramiies )
L TR e S RN PR U VT
CFTE-pechent-9. 5. L 200-mn. ap{WTegramPles TS .5, 1,200
P sechert 4.5, 0 140, so{ WP ambien PSiue-sechent-9 4 LEL. pPec

DFres et b 0L . s aeFles W et \pes e dhedh 5. 40, 240

pre-netal soip? for S Siorsge Sosnner (win) v Succeded
il A O _Od e op{Se oy amles S ormrmen Flet Cipaware ipam <ormen ik L 6.5_04] ' Lreraded
OFEYeR-shar e 500000 o] heProgr eeFies ) W Supoesded
PTA-pr-win-50. 000l SeProgranfie ) w Succeeded
OPeas-seckert. 4 L3 1win. B[y i e e i ML 4 LET) w Sieded
CFFES-peCent-g Lhmm‘m‘-ﬂwil a0 L=t
OPTAa-pechrt-9. 5.0 10w sp{ o \ehersih /.50, 143) » Sccended
OPSraa-seden - A 0 . BT aelles W Odwens \pes e dhendh 5,40, 240 W Sureenied
paat-ratal sorpt for SE Shorage Soanner (e v Succesded
Eguter v Buccmided
Softeare Compharoe » Succeeded

2  The Job Status section shows each server’s audit results. View server audit results by expanding the
Server: <server name>. The STATUS column shows the status of the installed components.

Storage Compliance
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Storage Compliance Checks

To view storage compliance checks:

1 Inthe Audit Servers: New screen, All Steps section, choose Job Status.

JobId: 4730001
Status:  Sucoseded (Wed Mar 06 12:02 2013)
Progress: |

Total: 1 Dones 1 Skppech: 0 Ervors: O AuditTask: M0001 AuditResults 50001

# VewRenits o Export...

[hem
Bl Rl I feshestand hp. com

2 Inthe Job Status section, choose a server.

The Job Status section shows the status of the audits, which are run on any managed server. The
STATUS column shows the status of the audit, as either Succeeded or Failed.
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3 Storage Visualization

Overview of Service Automation Visualizer

The Service Automation Visualizer (SAV) feature in Server Automation (SA) allows you to visualize logical
storage dependencies and physical storage connections in your data center. SAV displays how these
dependencies and connections relate to your business applications in mapping diagrams. These diagrams
map out the storage supply chain from servers to spindles—how servers map to the storage devices they are
connected to. SAV diagrams also show file systems and their relationships to local and remote storage, FC
adapters, FC switches (physical and virtual), connections and ports, disk arrays, NAS filers, LUN mappings,
RAID configurations, SAN fabrics, and so on.

Storage Essentials (SE) version 6.1.1 or later is required to view, report, or perform any Service Automation

Lif Visualizer (SAV) and Service Automation Reporter (SAR) operation on SAN objects, such as arrays,
switches, volumes, and so on. SAN objects are discovered in Storage Essentials. To enable discovered SAN
objects in the SA, SAV, and SAR products, the Server Automation SE Connector component must be
installed and configured.

For more information about SAV, see the S4 User Guide: Application Automation.

Storage Mapping Features

SAV provides visual maps that display physical and logical drawings of storage devices and connections in
your environment—in a Storage Map and a SAN map.

SAN Map

The SAN map shows a superset of the Storage Map, including a graphical view of the SAN involved in a
SAV snapshot, all servers and their FCAs (including fibre channel ports), and each adapter’s connections to
switches in the SAN.

Storage Map

The Storage Map displays storage dependencies for servers, FCAs, NAS filers, SAN arrays, fabrics,
switches, ports, and so on, that you have scanned with SAV. This map provides a graphical view that
displays servers, the process families running on them, including the file systems and local or remote storage
devices these files are stored on and served from, either through local disks, NAS filers, or remote disk
arrays. The map shows connections between process families and their open files and where the files are
stored.
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4 SE Connector

SE Connector is the Storage Scanner that collects data from Storage Essentials (SE) about SAN elements
and inventory, and their connectivity. These SAN elements include storage arrays, fabrics, switches, and
NAS filers.

The frequency of collecting this storage data is configured by the user. By default, SE Connector collects
SAN information from SE once every 12 hours. This action is commonly known as a scheduled full
synchronization. You can adjust the collection frequency by modifying a setting in SE. In SE Connector, you
can specify the maximum wait time (in minutes) for a scheduled full synchronization when the Get All
Elements Details (GAED) process in SE is in progress. The following property specifies the maximum
default wait time for a scheduled full synchronization task when GAED is in progress:

com.creekpath.agent.common.devices.scheduled. full.sync.max.wait.minutes=10080

SE Connector will check SE every 3 minutes (by default) and will run the collection if the SE GAED
process finishes sooner or if SE Connector has waited longer than the specified interval.

‘, SE Connector can communicate with multiple Storage Essentials instances. For scalability and performance
reasons, it is recommended that you have multiple SE Connectors communicating to one instance of Storage
Essentials; however, each Access Control must be configured to collect a unique set of devices from the
same Storage Essentials instance. You can also have multiple SE Connectors communicating with multiple
instances Storage Essentials.

Since, by default, storage information is collected from SE once every 12 hours, you might need updated
data more frequently than twice a day. You can modify this data collection frequency by modifying a setting
in SE. See the Storage Essentials SRM Software User Guide for information about configuring the schedule
for data collection. You can also request an update of SAN information from SE at the storage device level,
such as arrays and NetApp filers. See Update from Storage Essentials on page 74 for more information.

A “GAED IN PROGRESS” value in the Status column on the Storage Scanner Storage Essentials panel
indicates that a Get All Elements Details (GAED) discovery process is currently running on the Storage
Essentials server.

When Storage Essentials is processing GAED, by default SE Connector will wait 10080 minutes (7days)
before it will proceed to collect data from Storage Essentials, even though a GAED discovery process is still
running. SE Connector will check SE every 3 minutes (by default) and will run the collection if the SE
GAED process finishes sooner or the SE Connector has waited longer than the interval configured for “Full
Data Collection Minutes” in SEPlugin.Properties.

Check the Storage Essentials (connection) Status to determine whether the GAED process is still running.
Check the Last Scan timestamp for Managed Elements for that Storage Essentials instance to determine
when SE Connector last updated the information for those elements.

The following property specifies the maximum default wait time for a scheduled full data collection task
when GAED is in progress:

com.creekpath.agent.common.devices. full.data.collection.minutes=720

The following describes a typical use case:
*  You configure SE Connector to collect information from Storage Essentials once a day.

»  Storage Essentials is busy processing GAED for 2 days.
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*  You do not see updated information for Managed Elements for the Storage Essentials instance in Server

Automation.

*  You can use a combination of the Storage Essentials connection Status value and Last Scan timestamp
for Managed Elements to determine if there is a lengthy GAED process running for SE and the SE
Connector is not updating information for those Managed Elements. This explains why information for
Managed Elements is not getting updated as per the scheduled frequency.

SE Connector Updates

This section discusses SE Connector updates.

[@smmmer I =

Library items may be browsed by type or by folder for selection.
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BY solaris Patch Policy
Patch

By Patch Policy

Gy Package
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P Windows Local Security Settin|
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| @Y DMA Agent Support
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| @ SE Connector Update for 9.4.0
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*

SA 10.0 supports the following SE versions: SE 9.4.0, SE 9.4.1, SE 9.5.0 and SE 9.5.1.

>»

Note: The SA 10.0 release no longer supports SE 6.x for new managed servers. However, SA 6.x is still
supported for existing managed servers.
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Viewing the Storage Essentials Connection Status

SE Connector

This section discusses how to view the status of the connection to a Storage Essentials server managed by a

Storage Scanner.

To view the status of the connection:

1 From the navigation pane, select Administration > Storage Scanners.

2 Inthe content pane, select an SE Storage Scanner and then open its browser.
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3  From the Views pane, select Storage Essentials.

4 Check the Status column.

When you are viewing storage information about a SAN array or NetApp filer in Storage Visibility and
Automation and would also like to view storage information for the same SAN array or NetApp filer in
Storage Essentials, you can launch Storage Essentials to display the data that was discovered. See
information on authorizing a storage scanner in the Storage Visibility and Automation Installation &
Administration Guide. See the Storage Essentials SRM Software User Guide for information about the

discovery process in SE.

See storage-scanner information in the Storage Visibility and Automation Installation & Administration
Guide. for information about managing the SE Connector.

See the Storage Visibility and Automation Managed Server Support Matrix for a list of operating systems SE

Connector supports.
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Viewing the SE Client Library Version Number

The Storage Scanner properties panel includes the SE Client Library Version number. The SE Client Library
version number, such as 6.x.x.xx, is displayed in the Description field.

To view the SE Client Library version number:

1 From the navigation pane, select Administration > Storage Scanners.
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2 In the content pane, select an SE Storage Scanner.

3 From the View drop-down list, select Properties. The SE Client Library Version number is displayed in
the Description field, under Management Information.

Access Controls

This section discusses access controls for SE Connector.

Viewing Access Controls for SE Connector

To view access controls for SE Connector:

1 In the navigation pane, select Administration > Storage Scanners.
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2 In the content pane, select a Storage Scanner and then select Actions > Open.
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3 Inthe Views pane, select Management Console.
4 Expand SE and then expand Access Controls.

5 Select List to display the access controls for SE Connector.

Viewing Storage Essentials Servers Managed Elements for SE Connector

SE Connector

To view a list of managed elements discovered by each access control for the SE Connector:
1 In the navigation pane, select Administration > Storage Scanners.

2 In the content pane, open a Storage Scanner.
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3 Inthe Views pane, select Storage Essentials.
4 Select an access control in the right pane. The list of managed elements discovered by that access
control displays in the bottom pane.
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Update from Storage Essentials

f

You must have the required SA user permissions to request an “Update from Storage Essentials”. See the
section on SA permissions in the SA Administrators Guide.

“Update from Storage Essentials” is an option in the Actions menu that requests an update of storage
information about an individual storage device, such as a SAN array or NetApp filer. SE Connector provides
this synchronization of data for a storage system when you request an update at the device level.

SE Connector does not directly communicate with a storage device to collect data about it. SE Connector
collects data about an individual storage device from Storage Essentials. This request copies data from the
SE repository into the Model Repository.

You can specify the maximum wait time (in minutes) for the “Update from Storage Essentials” action in SE
Connector while SE performs GAED for certain storage elements. The following property specifies the
maximum default wait time for the "Update From Storage Essentials" action when GAED is in progress:

com.creekpath.agent.common.devices.manual.full.sync.max.wait.minutes=10080

The Jobs and Sessions user interface displays the status of the update request. A “Success” status indicates
that the Model Repository has been updated. The timestamp for the job also provides the following
information about the “Update from Storage Essentials” request:

*  When the request was made
*  What the status of the update job is, such as:

— Succeeded—Request was submitted successfully. SE Connector collected the data for the
requested device and sent it to the Web Services Data Access Engine.

— Error—Request could not be submitted. Verify that the SE Connector is running and start it if it is
stopped. If there is still a problem, check the SE Connector logs on the managed server to
troubleshoot this error. Begin with the pam-0-0. trace log file and then check other trace files.

See the SA User Guide: Server Automation for more information about Jobs and Sessions.

Open with Storage Essentials (Click & Launch)

“Open with Storage Essentials” is an option in the Actions menu that launches Storage Essentials for an
individual storage device, such as a SAN array or NetApp filer. You can also launch Storage Essentials for a
device by selecting it and then by right-clicking—this is commonly referred to as the Click & Launch user
interface.

SE Connector supports Click & Launch for storage devices that are managed by Storage Essentials
standalone configuration. This option is not supported with Storage Essentials integrated with HP Systems
Insight Manager.

Click & Launch requires an SE account login. When you select other storage objects and then Click &
Launch from them (while in the same session), the initial SE login will persist. There is no single sign-on
capability for Server Automation and Storage Essentials.

You can launch SE only from a storage device. You cannot launch SE from a host.
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5 Storage Search

Overview of Storage Search

In Storage Visibility and Automation, you can search for storage information in your IT environment, such
as objects and attributes for server, database, and storage systems.

SA Client Integration

The search feature in Storage Visibility and Automation is integrated with the SA Client Search tool in the
SA Client. To use search, you must be familiar with the basics of the SA Client Search tool. See the S4 User
Guide: Server Automation for information about using the following SA Client Search capabilities:

*  Performing a simple search by using keywords

*  Performing an advanced search by creating search queries
*  Saving a search query

*  Deleting a saved search

*  Running a saved search query

*  Performing actions on search results

*  Emailing search results

*  Printing search results

Storage Objects and Attributes

By using the SA Client Search tool, you can search for the following storage objects and attributes:

*  Server—FCA Manufacturer, FCA Model, FCA Port, FCA Version (Fibre Channel Adapter), Storage
Make & Model, Storage Manager Software Manufacturer, and Storage Manager Software Type

¢ Database—Server Name, Version, and Manufacturer

»  Storage Systems—Device Customer, Device Facility, Device Group, Discover Date, Facility Name,
Manufacturer, Model, Name, Object ID, Port, RAID Type, and Serial Number

75



76

Chapter 5



A Global File System (OGFS)

Overview of OGFS

The Global File System (OGFS) feature shows storage inventory in a file system-like presentation. The
OGFS feature in Storage Visibility and Automation is integrated with the OGFS feature in the SA Client. To
use the OGFS feature, you must be familiar with its basic capabilities in the SA Client. See the S4 User
Guide: Server Automation for more information.

The OGFS represents the data model as a hierarchical structure of file directories and text files. For example,
in the OGFS, the /opsw/Server directory contains information about managed servers and includes
subdirectories that represent the contents of the managed servers, such as storage, ports, and disks.

Global Shell

The Global Shell is a command-line interface to the OGFS. This command-line interface is a Unix shell,
such as bash, that runs in a terminal window. The default shell in Global Shell is bash.

The OGFS unifies the data model and the contents of storage devices and managed servers, including files,
into a single, virtual file system. You open a Global Shell session from within a SA Client or from a direct
ssh connection in a terminal client on your desktop. With the Global Shell, you can automate repetitive
system administration tasks by running scripts across multiple storage devices and servers in a secure
environment. Common scripting languages, such as Perl and Python, are supported.

The OGFS represents the data model as a hierarchical structure of file directories and text files. For example,
in the OGFS, the /opsw/Server/@/e-commerce.example.com/Storage directory contains details
about storage dependencies for the server named e-commerce .example.com.

See the SA User Guide: Server Automation for more information on how to use Global Shell.

Permissions

The actions that you can perform within the Global Shell are determined by the operations specified by the
aaa utility. The aaa utility grants and revokes permissions for operations that use the OGFS. For example,
the aaa utility grants permission for the readServerFilesystem operation, which allows you to browse
a server’s file system in the SA Client. To run the aaa utility, you must belong to the Administrators user
group. The permissions granted and revoked by the aaa utility are stored in the /opsw/Permissions
directory of the OGFS. See the SA User Guide: Server Automation for information about how to use the aaa
utility.

it You must have permissions in the Global Shell to view the file systems for storage inventory.
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Storage Directory in the OGFS

The following sections describe subdirectories that contain storage content. The directory layout is designed
to reflect the natural locations of storage objects, with the intent to facilitate intuitive navigation by OGFS
users.

The primary storage directory roots are /opsw/Storage, which contains all storage system and storage
network content and /opsw/Server/.../ Storage, which contains storage objects specific to their
respective servers.

Additional storage directory trees are provided to scope the content contained within

/opsw/Storage. Examples include the /opsw/Customer/ . ../Storage directories, which contain
storage resources that are assigned to customers, and the

/opsw/Facility/.../Storage directories, which contain storage resources that are associated with
facilities.

Although storage trees exist in multiple scoped locations, each and every object has a single location at
which it can be reliably located in the OGFS. These locations are collectively referred to as canonical
locations. Within each storage directory tree, symbolic links (symlinks) are used to traverse storage topology
and reference storage information located in canonical directory paths.

The canonical location for a volume of a server is in the following directory:
/opsw/Server/.../Storage/Volume

In the following example, the Volume directory contains content pertaining to a raid0 volume on the server:
/opsw/Server/Q@/myserver.opsware.com/Storage/Volume/raid0

If a file system is mounted on that volume, this is reflected in the OGFS as a symbolic link to the volume,
which is located in its canonical location:

/opsw/Server/@/myserver.opsware.com/Storage/FileSystem/myfs/Volume/raid0
-> /opsw/Server/Q/myserver.opsware.com/Storage/Volume/raid0

/opsw/api/com/opsware/storage Directory

This directory is automatically provided by the existing (SA Client) UAPI infrastructure. The api directory
contains executables that invoke methods on the SA API.

/opsw/ Storage Directory

This directory contains storage system and storage network artifacts. This directory is replicated in the
following paths with filtered content:

e /opsw/Facility/<facility>/Q/Storage—This directory shows the content of /opsw/
Storage with the top-level directories filtered by facility.

e /opsw/Group/<Public|Private>/<group>/@/Storage—This directory shows opsw/
Storage content with the top level directories filtered by group.

*  /opsw/Customer/<customer>/@/Storage—This directory shows opsw/Storage content filtered by
customer.
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/opsw/Server/ .../ Storage Directory

This directory contains server-related storage artifacts.

/opsw/Server/.../Storage

/opsw/Server/ .../ Storage/ Controller Directory

This directory contains a subdirectory with symlinks to controller ports and a subdirectory with symlinks to
volumes imported through this controller.

/opsw/Server/.../Storage/Controller/Port
/opsw/Server/.../Storage/Controller/Volume

/opsw/ .../ Disk/Dependent Directory

This directory contains symlinks to dependent volumes. There are several places where the Disk directory
can exist. It can occur on the server side (to show the local disks on a server), such as:

/opsw/Server/@/myserver.opsware.com/Disk
Or, it can be located on a storage system (to show the disks contained in a storage array), such as:
/opsw/Storage/System/emcdmx—-01/Disk

The Dependent subdirectory can exist in many locations (one of which is a subdirectory of a disk). In each
case, the Dependent subdirectory shows storage artifacts that are dependent on the object represented in
the current directory, such as:

/opsw/Storage/System/emcdmx-01/Disk/01A\ :C0/Dependent

In this example, this path shows the objects that directly depend on disk 01A: CO.

) In Storage Visibility and Automation, when disks are referred to in the context of a storage system, disk
information might not be available. Disk information that is provided depends on what the settings are for
discovering disks in Storage Essentials.

/opsw/ .../ Server/Storage/Fabric Directory

This directory contains symlinks to fabric-connected devices, zones on the fabric, symlinks to ports in the
zone, zone aliases on the fabric, symlinks to zone aliases that reference the zone, zone sets, and switches on

Global File System (OGFS)

the fabric.
/opsw/Server/.../Storage/Fabric/ConnectedDevice
/opsw/Server/.../Storage/Fabric/Switch
/opsw/Server/.../Storage/Fabric/Zone
/opsw/Server/.../Storage/Fabric/Zone/Member
/opsw/Server/.../Storage/Fabric/Zone/ZoneAlias
/opsw/Server/.../Storage/Fabric/Zone/ZoneSet
/opsw/Server/.../Storage/Fabric/ZoneAlias
/opsw/Server/.../Storage/Fabric/ZoneAlias/Member
/opsw/Server/.../Storage/Fabric/ZoneAlias/Zone
/opsw/Server/.../Storage/Fabric/ZoneSet
/opsw/Server/.../Storage/Fabric/ZoneSet/Zone
/opsw/Server/.../Storage/Fabric/Switch
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/opsw/Server/ .../ Storage/FileSystem Directory

This directory contains symlinks to the volume underlying the file system.

/opsw/Server/.../Storage/FileSystem/Volume

/opsw/Server/ .../ Storage/Port Directory

This directory contains symlinks to a connected device, symlinks to a connected port, symlinks to a protocol
controller, symlinks to the connected fabric, symlinks to volumes on this port, symlinks zones referencing
this port, and symlinks to zone aliases referencing this port. This directory can reside under multiple storage
domains.

/opsw/...Port/Connected Device
/opsw/.../Port/ConnectPort
/opsw/.../Port/Controller
/opsw/.../Port/Fabric
/opsw/.../Port/Volume
/opsw/.../Port/Zone
/opsw/.../Port/ZoneAlias

/opsw/Server/.../Storage/Service Directory

This directory contains MPIO Manager and Volume Manager software, symlinks to volumes exported, and
symlinks to volumes imported by each service.

/opsw/Server/.../Storage/Service/<service-name>/Volume
/opsw/Server/.../Storage/Service/<service-name>/InputVolume
/opsw/Server/.../Storage/Service/<service-name>/OutputVolume

/opsw/Server/.../Storage/Switch Directory

This directory contains symlinks to connected devices, symlinks to connected fabrics, and switch ports.

/opsw/Server/.../Storage/Switch/Fabric
/opsw/Server/.../Storage/Switch/Port

/opsw/Server/.../Storage/System Directory

This directory contains storage system protocol controllers, storage system physical disks, storage system
volume pools, symlinks to volumes within a storage pool, storage system ports, and storage volumes.
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/opsw/Server/.../Storage/System/Controller
/opsw/Server/.../Storage/System/Disk
/opsw/Server/.../Storage/System/Pool
/opsw/Server/.../Storage/System/Pool/Volume
/opsw/Server/.../Storage/System/Pool/Volume/Antecedent
/opsw/Server/.../Storage/System/Pool/Volume/Dependent
/opsw/Server/.../Storage/System/Pool/Volume/Initiator
/opsw/Server/.../Storage/System/Pool/Volume/Pool
/opsw/Server/.../Storage/System/Pool/Volume/Port
/opsw/Server/.../Storage/System/Port
/opsw/Server/.../Storage/System/Volume

Appendix A



/opsw/Server/ .../ Storage/Volume Directory

This directory contains symlinks to antecedent storage volumes and physical disks, symlinks to controllers
importing this volume, symlinks to dependent storage volumes, symlinks to dependent file systems, paths

through which the volume is imported, symlinks to storage ports importing this volume, symlink to the

service that provides this volume, symlink to the target volume in the storage system domain, symlinks to

connected host initiator volumes, and symlinks to the storage pool associated with this volume.

/opsw/Server/ ..
/opsw/Server/ ..
/opsw/Server/ ..
/opsw/Server/ ..
/opsw/Server/ ..
/opsw/Server/ ..
/opsw/Server/ ..
/opsw/Server/ ..

Global File System (OGFS)

./Storage/Volume/Antecedent
./Storage/Volume/Controller
./Storage/Volume/Dependent
./Storage/Volume/FileSystem
./Storage/Volume/Path
./Storage/Volume/Port
./Storage/Volume/Service
./Storage/Volume/Target

87



82

Appendix A



Index

A

aaa utility, 77

aggregate capacity, 42

aggregate caption, 42

aggregates, 42

Array Groups, 31

ASM. See Automatic Storage Management., 27, 52
audit schedule, 65

audit summary, 65

Automatic Storage Management, 27, 52

B
block-based devices, 52

C

canonical locations, 78

CIFS. See Common Internet File System., 43
committed capacity, 43

composite volumes, 31

connected fabric port, 31

consumed storage, 18

D

DAS. See Direct Attached Storage., 18, 23, 26
Database Scanner for Oracle, 11, 15

data files, 52

data replication, ASM, 52

dependent volumes, 79

device groups
dynamic, 61

static, 17, 18, 19, 30, 31, 41, 42, 43, 51, 52, 59, 60

Direct Attached Storage, 18, 23
disk controllers, 31

disk quota, 51

dynamic device group, 59, 61

E
E Ports, 41

F

F Ports, 41

fabric ports, 31

fabric switches, 41

FCA. See Fibre Channel Adapter., 18
Fibre Channel Adapter, 18
Fibre Channel ID, 41

fibre switch and fabrics, 41
file-based devices, 52

File I/0 and Block 1/0, 43
File I/O Exports, 43

flex volumes, 43

free extents, 31

G

G_Ports, 41

GAED, 15

GAED. See Get All Element Details., 12, 15, 69, 74
Get All Element Details, 12, 69, 74

Global File System, 41, 77

Global Shell, 77

H
Hitachi SAN array, 31
HP XP, 31

|
Inter-Switch Link, 41
ISL. See Inter-Switch Link., 41

L

layered volume managers, 18

layered volumes, 18



local attached storage, 23 Q

local storage, 18 Qtrees, 43

logical database storage, 15, 52 quota, 43

logical entities, 17, 18

logical volume, 16 R

LUN Mapping, 31 RAID groups, 42
raw partitions, 52

M redo logs, 52

meta volumes, 31 replication, 53

Model Repository, 11, 16, 17 replication pair, 40

Oracle setup, 77
MPIO. See Multipath 10, 18, 25

root volumes, 18

Multipath IO, 18 S
MultiStore, 43 SA. See Server Automation., 67
N SAN. See Storage Area Network., 17, 52

SAR. See Service Automation Reporter., 12, 67
N_Port, 41 SAV. See Service Automation Visualizer., 12, 33, 34, 67
NAS. See Network Attached Storage., 11, 15, 17, 23, 51 .

schedule, audit, 65
NetApp Filer, 42

SE. See Storage Essentials., 12, 67
SE Connector, 11, 12

Select server, 64

NetApp VFiler, 43

NetApp volumes, 43

Network Attached Storage, 11, 15, 17, 23, 51
NFS. See Network File System., 43, 52

NFS exports, 44

server, select, 64

server administrator, 18

Server Automation, 12, 67

o Service Automation Reporter, 12, 67

OGFS. See Global File System., 41, 77 Service Automation Visualizer, 12, 33, 34, 67

ONTAP 6.5, 43
ONTAP 7.0, 42, 43
Oracle ASM. See Automatic Storage Management., 27

SE Storage Scanner. See SE Connector., 12
SHA. See Storage Host Agent Extension., 17
SIM. See Systems Insight Manager., 16, 74
space guarantee, 43

space threshold, 43

P static device group, 17, 18, 19, 30, 31, 41, 42, 43, 51, 52, 59,
60

Storage Area Network, 17
Storage Essentials, 33, 34, 79
Storage Host Agent Extension, 11, 17, 22

Oracle instance, 51

physical database storage, 15, 52
physical disk, 16

physical entities, 18

Plex, 42

port controllers, 31 storage pool, 31

. t target, 28
ports connectivity, 41 storage target,

primordial storage, 18 storage volumes, 31

principal switch, 41 subordinate switch, 41

summary, audit, 65
switch blade, 41

produced storage, 19
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switch enclosure, 41

switch port, 41

symbolic links, 78

symlinks, 79

symlinks. See symbolic links., 78, 79
Systems Insight Manager, 16, 74

T
tablespaces, 52

traditional volumes, 43

Vv
vFiler, 43
virtual filers, 43

w
World Wide Name, 18, 41
WWN. See World Wide Name., 18, 41

yA

zones, 41
zonesets, 41, 42

zoning database, 41
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