Problem creating Local Impact View

  • KM00434906
  • 22-May-2013
  • 11-Aug-2015

Summary

error upon creating LIV in BSM

Error

Upon creating a LIV, the following error appears: "Failed to create local impact view, the number of CIs exceeds the limit."

Cause

  • The limitation for LIV is 1000 CIs.
  • This is what BSM Documentation states (Application Administration > Service Health > View Builder - Creating Global Views and Local Impact Views)
  • “Note: You can create up to 100 local impact views. Each local impact view can contain up to 1000 CIs. To modify these limits, contact HP Support.”

Fix

This setting needs to be changed via JMX, as the element is not visible in the Infrastructure Settings UI.
 
Click Foundations
service=Infrastructure Settings Manager
 
java.lang.String getCustomerSettingsValues()
contextName "liv-engine"
 
the result is:
Setting's Name Setting's value
 liv.engine.maxLivsAmount 100
 liv.engine.maxLivSize 1000
 liv.engine.secondsBetweenTopologyPolling 5
 liv.engine.successiveChangesBeforeRebuild 3
 
 
void setSettingValuePerCustomerId()
contextName "liv-engine"
settingName "liv.engine.maxLivSize"
newValue 5000  (as an example)
 
 
java.lang.String getCustomerSettingsValues()
contextName "liv-engine"
settingName "liv.engine.maxLivSize"
 
The result is now :
Setting's Name Setting's value
 liv.engine.maxLivsAmount 100
 liv.engine.maxLivSize 5000
 liv.engine.secondsBetweenTopologyPolling 5
 liv.engine.successiveChangesBeforeRebuild 3