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Documentation Updates
The title page of this document contains the following identifying information:
l

Software Version number, which indicates the software version.

l

Document Release Date, which changes each time the document is updated.

l

Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a document, go
to:
http://h20230.www2.hp.com/selfsolve/manuals
This site requires that you register for an HP Passport and sign in. To register for an HP Passport
ID, go to:
http://h20229.www2.hp.com/passport-registration.html
Or click the New users - please register link on the HP Passport login page.
You will also receive updated or new editions if you subscribe to the appropriate product support
service. Contact your HP sales representative for details.
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Support
Visit the HP Software Support Online web site at:
http://www.hp.com/go/hpsoftwaresupport
This web site provides contact information and details about the products, services, and support
that HP Software offers.
HP Software online support provides customer self-solve capabilities. It provides a fast and
efficient way to access interactive technical support tools needed to manage your business. As a
valued support customer, you can benefit by using the support web site to:
l

Search for knowledge documents of interest

l

Submit and track support cases and enhancement requests

l

Download software patches

l

Manage support contracts

l

Look up HP support contacts

l

Review information about available services

l

Enter into discussions with other software customers

l

Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also
require a support contract. To register for an HP Passport ID, go to:
http://h20229.www2.hp.com/passport-registration.html
To find more information about access levels, go to:
http://h20230.www2.hp.com/new_access_levels.jsp
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Why should I create my app using HP
Anywhere IDE?
HP Anywhere provides an Eclipse-based IDE that enables you to create, build, run, and debug your
own apps.
This IDE provides a complete development environment that covers the entire lifecycle of your app
and enables you to create, debug, maintain your app projects. HP Anywhere IDE includes:
l

A wizard for creating app projects

l

A built-in simulator that you can use to run and debug your apps in any form factor (desktop,
tablet, or smartphone) or screen resolution

l

A complete, pre-configured, database-free, and debug-ready HP Anywhere server that is
customized and optimized for the development environment.
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How to build and run your app using HP
AnywhereIDE - end-to-end walkthrough
The following steps describe how to build and run an app using HP Anywhere.
1. Make sure that HP Anywhere IDE is installed on your computer.
2. Use the HP Anywhere App Project wizard to create the package and files for your app project.
This provides you with a ready-to-run app that includes all of the necessary files, classes, and
methods. You can select from the any of the available templates to get you started. For details,
see "How do I create an app project in HP Anywhere IDE?" on next page"Appendix 1: App
Project Folder Structure" on page 28, and "Appendix 2: Template Descriptions" on page 30.
3. Add your code.
4. Define your app configuration settings. For details, see "How do I define the configuration for
my app?" on page 13.
5. Run and debug your app by running it on the built-in HP Anywhere local server or a remote
server. For details, see "How do I run my app on the local server?" on page 15 and "How do I
debug my app code?" on page 26.
6. When your app is ready, you can give the app content pack .zip file to the HP Anywhere
administrator so that he or she can deploy it on the HP Anywhere server and enable it in the
catalog. This .zip file has the following naming convention: <App name>-cp.zip, and is
located in the <App project>\target folder.
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How do I create an app project in HP
Anywhere IDE?
You use the HP Anywhere App project wizard to create a new HP Anywhere IDE project containing
the files and classes for your app. The
Note: When you create an app using HP Anywhere IDE, an app content pack is generated as
a .zip file in the <App project>\target folder.
This .zip file has the following naming convention: <App name>-cp.zip. You need to give this
to the HP Anywhere administrator when the app is ready so that he or she can deploy it on the
HP Anywhere server and enable it in the catalog.
To create an HP Anywhere app project in HP Anywhere IDE:
1. First time only: Select Window > Open Perspective > Other > HP IDE. This updates the
menus and layout for HP Anywhere IDE.
2. Select File > New > HP Anywhere App Project. The HP Anywhere App Project wizard
opens.

3. In the Form Factor area, select one or more form factors. The following form factors are
available:
n

Desktop

n

Tablet
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n

Smartphone
Note: After you create a project, you can manually add form factors that you did not
select while creating the project. For details, see "How do I add or remove form factors
in my app project?" on page 11.
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4. In the Project Template area, select the type of template from the Type drop-down list. The
following templates are available:
n

My Report Enyo Project. An HP Anywhere starter project that generates an app using the
Enyo framework. This project is targeted for use on tablets and smartphones.

n

Blank Project. An HP Anywhere starter project that contains the project folder structure
without application content.

n

My Report Sencha Project. An HP Anywherestarter project that uses the Sencha Touch
framework to generate an app that can display a list of reports. This project is targeted for
use on tablets and smartphones.

n

My Report Project. An HP Anywherestarter project that uses the native framework with
JavaScript and HTML code to generate an app that can display a list of reports.

The Description box provides details for the selected template. For more details on these
templates, see "Appendix 2: Template Descriptions" on page 30.
5. In the Advanced area, define the following using standard Maven naming conventions:
n

App Name. The name of the app, for example, HelloWorld. (Use only alphanumeric
characters. Special characters and spaces are not allowed.)

n

Group ID. A reverse domain name, for example, com.mycompany.mygroupname. The
group ID is used in the generated POM.XML project file.

n

Source package. A valid Java package name, for example, com.my.mypackage. The
package name represents the folder structure that is generated in the workspace.

n

App version. The version string for your app, for example, 1.0.0.

n

App icon: A PNG file that represents your app. The icon is displayed in the app on the My
Apps page in HP Anywhere.

6. Click Finish. HP Anywhere generates the app project. While the project is being created, you
can view the log in the Console tab. (The first time you create a project, this may take some
time.) After the project created, you can:
n

View the project folder structure. For details, see "Appendix 1: App Project Folder Structure"
on page 28

n

Add code to the app project.

n

Run the app. For details, see "How do I run my app on the local server?" on page 15.
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How do I add or remove form factors in
my app project?
When you create your app project, you specify the form factors (desktop/tablet/smartphone) on
which your app can run.
If you do not select all form factors when you create the project, you can add them later by adding
folders for the required form factors to your app's package. Similarly, you can remove form factors
from your app by removing the relevant project folders.
To add form factors for your app:
1. In the HP Anywhere IDE Package Explorer, expand the main app folder.
2. Copy/paste the folders for an existing form factor (desktop, tablet, or smartphone) in each of
the following locations:
l
src > webapp > app
l

src > webapp > css

l

src > webapp > images

2. Rename each of the new folders to the required form factor type (desktop, tablet, or
smartphone).
3. Add your client code to the new form factor folders.
4. In src/resources > descriptor.xml, create a section for each form factor by copying the
following section and replacing the <existing form factor type> with the <new form factor
type>. For example, copy the following section and replace DESKTOP with SMARTPHONE.
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To remove form factors:
1. In the HP Anywhere IDE Package Explorer:
a. Expand the main app folder.
b. Remove the relevant section from src/resources > descriptor.xml. For example, to
remove the desktop form factor, delete the following:

c. (Optional) In each of the following locations, delete the folders for each form factor
(desktop, tablet, or smartphone) that you want to remove:
l

src > webapp > app

l

src > webapp > css

l

src > webapp > images
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How do I define the configuration for my
app?
After you create your app, you can configure its settings, which are located in the src/resources
folder.

User Settings
You define these settings for your app's users.
To modify the user settings:
1. In the Package Explorer, navigate to: /<app main node>/src/resources/<app name>-usersettings.xml and double-click the file.
2. In the app name>-user-settings.xml tab, select the Design tab.
3. Right-click context and select Add Child > setting.
4. Expand the setting node you just added and enter values for the following:
a. name. The ID for this setting.
b. namekey. A setting used for localization.
c. integer. The default setting type. You can modify this by right-clicking and selecting
Replace With > <value type>.
Possible values:
boolean
enumeration
float
password
string
xml

Administrator Settings
You define these settings for your app's administrators.
To modify administrator settings:
1. In the Package Explorer, navigate to: /<app main node>/src/resources/<app name>admin-settings.xml and double-click the file.
2. In the app name>-admin-settings.xml tab, select the Design tab.
3. Right-click context and select Add Child > setting.
4. Expand the setting node you just added and enter values for the following:
a. name. The ID for this setting.
b. settingType. Make sure that global is selected.
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c. displayInUI. Specifies whether the app is visible in the HP Anywhere Administrator
Console.
Possible values:
true
false
d. sectionKey. The name of the group area that is displayed in the Settings tab of the
Administrator Console (for the app that is selected in the List of Categories column).
e. integer. The default setting type. You can modify this by right-clicking and selecting
Replace With > <value type>.
Possible values:
boolean
enumeration
float
password
string
xml

Data Source Settings
You define the settings that enable the app to communicate with the backend server.
1. In the Package Explorer, navigate to: /<app main node>/src/resources/<app name>-dsprovider.xml and double-click the file.
2. In the app name>-admin-settings.xml tab, select the Source tab.
3. Modify the configuration as needed.
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How do I run and view my app?
You can run your app in debug mode or run mode on either a local or remote server.
When you run your app, HP Anywhereperforms the following:
1. Starts the HP Anywhere server if it is not already up and running.
2. Deploys your app on the specified server, if needed.
3. Opens HP Anywhere Simulator in a Chrome browser.
When you run your app project for the first time, HP Anywhere IDE compiles the project files, zips
them, and deploys them on the HP Anywhere server.
You can view and debug your app on the built-in simulator or on your own mobile device (if the
device is in the same LAN and the HP Anywhere client is installed on it). For details, see "How do I
run my app on a remote server?" on page 18.

How do I run my app on the local server?
You can run your app on the built-in local server.
To run your app in run mode on the local server:
1. Do one of the following:
a. In the project explorer, right-click the HP Anywhere project folder and select Run App.
b. Click
c. In the package explorer or project explorer, right-click the HP Anywhere project folder and
select Run As > Run On Server.
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How do I run and view my app?
The Run On Server dialog box opens.

2. Select Local HP Anywhere Server at localhost and click Finish The server starts and runs
your app using the default form factor and resolution. While the app runs, you can view the log
in the Console tab.
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3. When the run finishes, the app opens in a Chrome browser, as shown in the following example.
If your project contains code that supports other form factors and resolutions, you can select
them from the drop-down arrows above the simulated form factor. You can also double-click
the simulated form factor to view more details.

Note: After you run an app, you may need to manually enable it in the catalog.
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How do I run my app on a remote server?
You can run your app on a remote server. For general details, see "How do I run and view my app?"
on page 15.
To run your app in run mode on a remote server:

1. Do one of the following:
a. In the project explorer, right-click the HP Anywhere project folder and select Run App.
b. Click
c. In the package explorer or project explorer, right-click the HP Anywhere project folder and
select Run As > Run On Server.
The Run On Server dialog box opens.
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2. Select Manually define a new server. The dialog box enables you to specify a different
server.

a. Select Remote HP Anywhere Server.
b. In the Server's host name box, specify the remote server's name or IP address.
c. (Optional) In the Server name box, modify the server name.
d. (Optional) Select the Always use this server when running this project check box if you
always want to run your app only on this server.
3. Click Next. The JRE preferences page opens.
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Set the HP Server home path to <installation folder>, for example:
C:/HP/HPAnywhere
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4. Click Next. The login details page opens. Modify the default values, as needed.
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5. Click Next. The Add and Remove page opens.

(Optional) You can add or remove projects to run on this server, as needed.
6. Click Finish.The server starts and runs your app on the specified remote server using the
default form factor and resolution. While the app runs, you can view the log in the Console tab.
Note: If Chrome generates a profile-related error message, close the message and
continue to the next step.
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7. When the run finishes, the app opens in a Chrome browser, as shown in the following example.
If your project contains code that supports other form factors and resolutions, you can select
them from the drop-down arrows above the simulated form factor. You can also double-click
the simulated form factor to view more details.

Note: After you run an app, you may need to manually enable it in the catalog.
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How do I view my app on HP Anywhere
Simulator?
You can use the HP Anywhere Simulator to view your app in any form factor.
Note: You must run the app project at least once before you can open it in the HP Anywhere
Simulator, and the server must already be running.
To view your app project on HP Anywhere Simulator:
1. Do one of the following:
a. In the project explorer, right-click the project and select View App In Simulator.
b. Click

.

The app opens in a Chrome browser on the last server on which you ran this project.

Page 24 of 31

HP Anywhere (10.00)

HP Anywhere IDE Guide for Developers
How do I run and view my app?

Note: The HP Anywhere Simulator bar at the top of the window times out and hides
automatically to enable you to use the full real estate. To restore the bar, click the blue line
under the bar.
In the HP Anywhere Simulator bar, select the relevant form factor:
n

Smartphone

n

Tablet

n

Desktop (opens in a new tab or window)
Note: Only the form factors you specified when creating the project are enabled in the
HP Anywhere Simulator bar.

Click the arrow adjacent to the required form factor and select the required screen resolution.
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How do I debug my app code?
You can run your app in debug mode.
To debug your app:
1. In HP Anywhere IDE, right-click the app project folder and select Debug As > Debug On
Server. The Debug On Server dialog box opens.
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2. Select Local HP Anywhere Server at localhost and click Finish. The server starts and runs
your app on the local server. As the app runs, you can view the log in the Console tab, as
shown in the following example:

3. When the run is complete, the app opens in a Chrome browser. The development tools are
displayed at the bottom of the page.
4. Debug your code:
a. Debug your Java code as you would in Eclipse (using breakpoints, and so on).
b. Debug your JavaScript client code in the Chrome browser.
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Appendix 1: App Project Folder Structure
By default, each app project has the following package structure:

Project name

The non-modifiable name of the app project, as defined in the
HP Anywhere app Project wizard.

src/java

The Java code used by the app.

src/resources

The app's configuration files (for example, settings, data
source, and localization files).

Referenced Libraries

Third-party libraries that are available for the app (project
dependencies).

JRE System Library

The JRE libraries that are available for the app.

src

The JavaScript client code, which is divided into folders per
form factor. The common folders contain JavaScript code
that is used by all defined form factors.
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target

The target files that are created when your app runs. This
folder is empty when your app project is created.
When the app is ready for release, you can give the <App
project>\target\<App name>-cp.zip file to your HP
Anywhere administrator for deployment to the catalog.
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Appendix 2: Template Descriptions
HP Anywhere IDE provides starter projects that you can use as a basis for your own app projects.
All of the project templates include the required project folder structure. The My Report projects
also include code so that you can use to create an app that communicates with a REST API and
generates a list of reports.
Template

Description

My Report Enyo
Project

An HP Anywhere starter project that generates an app using the Enyo
framework. This project is targeted for use on tablets and smartphones.

Blank Project

An HP Anywhere starter project that contains the project folder structure
without application content.

My Report Sencha
Project

An HP Anywherestarter project that uses the Sencha Touch framework
to generate an app that can display a list of reports. This project is
targeted for use on tablets and smartphones.

My Report Project

An HP Anywherestarter project that uses the native framework with
JavaScript and HTML code to generate an app that can display a list of
reports.
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