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Documentation Updates
The title page of this document contains the following identifying information:

l Software Version number, which indicates the software version.

l Document Release Date, which changes each time the document is updated.

l Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using themost recent edition of a document, go
to:

http://h20230.www2.hp.com/selfsolve/manuals

This site requires that you register for an HP Passport and sign in. To register for an HP Passport
ID, go to:

http://h20229.www2.hp.com/passport-registration.html

Or click theNew users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product support
service. Contact your HP sales representative for details.

This document was last updated: Tuesday, March 19, 2013
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Support
Visit the HP Software Support Online web site at:

http://www.hp.com/go/hpsoftwaresupport

This web site provides contact information and details about the products, services, and support
that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and
efficient way to access interactive technical support tools needed tomanage your business. As a
valued support customer, you can benefit by using the support web site to:

l Search for knowledge documents of interest

l Submit and track support cases and enhancement requests

l Download software patches

l Manage support contracts

l Look up HP support contacts

l Review information about available services

l Enter into discussions with other software customers

l Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also
require a support contract. To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html

To findmore information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp
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Chapter 1

Introduction
Business Process Monitor (BPM) runs scripts that are recorded by Virtual User Generator (VuGen).
This document provides best practices for using VuGen to recordmobile native applications for
BPM. The document provides general best practices, as well as explanations about a number of
emulators. The document also provides a brief description of how to record scripts using theMobile
True client protocol.

A mobile app (HTTP/HTML) is a protocol that enables you to develop scripts usingmobile devices
or device emulators that communicate with servers over HTTP. You can record network traffic to a
capture file (PCAP file) and create a VuGen script, or you can use amobile emulator on your VuGen
machine to develop scripts.

Mobile emulators are available for free on the web. Youmust install the correct emulator version
that is supported by your application, andmeet the system requirements for each emulator software
you use.

Note:

l This documented in intended for VuGen experts who are recording scripts for BPM.

l For an overview of using HP LoadRunner for mobile performance testing, see
http://h30499.www3.hp.com/t5/HP-LoadRunner-and-Performance/Who-s-up-for-some-
mobile-performance-testing/ba-p/5974699.
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Chapter 2

Choosing a Mobile Monitoring Solution
In order to monitor amobile application, you need to first answer the following questions:

1. Is it a technology-based application using HTML or HTTP (mobile web browser)?

2. Is the software installed on themachine locally (native application), or can you browse using
browsing software such as IE, Firefox, or Safari?

If the application does not support HTML or HTTP, you need to use real-devicemonitoring like the
Perfecto integration.

If the application supportsHTML or HTTP, you need to decide what is important to you in your
applicationmonitoring:

l Do you want to bounce your application via wireless carrier (real wireless carrier network
monitoring)?

l Do you only want to monitor your application backend, nomatter which network you use
(proactive backend-sidemonitoring)?

l Is it important to you to simulate client activity over a specific device (real-device user
monitoring)?

Mobile Monitoring Options
The following tables can help you choose the best solution to your mobile monitoring:

l "Monitoring Solutions" below

l "Application Types" on next page

l "Protocols" on next page

l "NativeMobile Apps - RecordingMethods" on page 10

Monitoring Solutions
Monitoring
Solution

Protocols BPM installation

Real wireless
carrier network
monitoring

l Mobile
TruClient

l Mobile App
(HTTP/HTML)

l Mobile
PerfectoMobile
Integration

Add to the BPMmachine a 3G card to emulate real
carrier network connection (except for Perfecto
integration).
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Proactive backend-
sidemonitoring

l Mobile
TruClient

l Mobile App
(HTTP/HTML)

No need to add 3G card.

Real-device user
monitoring

Mobile
PerfectoMobile
Integration

No need to add 3G card.

Application Types

Application
Type

Protocols Comments

Native Mobile App
(HTTP/HTML)

Mobile PerfectoMobile
Integration

See "NativeMobile Apps - RecordingMethods" on next
page for more details.

Web
Browser

Mobile TruClient

Mobile App
(HTTP/HTML)

TruClient works with Firefox browser API , and will
soon work with IE.

Protocols
Protocols Methods Comments

Mobile
TruClient

l Web browser
based protocol.

l Recording using
VugGen using a
local PC
Firefox/IE
browser.

No need for 3G connectionor mobile device, or mobile
emulators.

HP Business Process Monitor (9.22)Page 9 of 26



Recording Mobile Apps for BPM - Best Practices
Chapter 2: Choosing aMobile Monitoring Solution

Mobile App
(HTTP/HTML)

Supports both web
browser, and native:

l For web browser
recording see
aboveMobile
TruClient
comments.

l For Native
recording, see
"NativeMobile
Apps - Recording
Methods" below.

The script is simply an HTTP/Web regular script
emulating a specific UserAgent (Device).

For SSL applications, either use the Android emulator
recordingmethod (which avoids certificate imports), or
get the certificate from the application admin, and import
it to VuGen to enable decryption.

Mobile
PerfectoMobile
Integration

This can be done
either using aQTP
script, or using a
VuGen template.

VuGen templates save you theQTP integration, but you
must open BPM to the Perfecto open API interface.

Native Mobile Apps - Recording Methods
Capture File Source Supported by

Mobile Sniffer
Agent

Advantages Disadvantages

Mobile device Records the real traffic
that comes from the
device.

Requires administrator
permissions or “rooted”
device.

VuGenwith configured
“hot spot” wireless
access point

Yes l Easy and intuitive.

l Administrator
permissions are not
required.

l Not all devices support
ad-hoc wireless
access points.

l Captures WiFi only
(does not capture
cellular network
traffic).

Server Yes Records real traffic (both
WiFi and cellular
network traffic).

l Requires administrator
permissions.

l Requires installation of
software on the server.

Mobile Device
emulator

Yes l No device required.

l No 3G needed.

Requires locating and
installing device emulator.
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Chapter 3

Android
Installing the SDK

1. Download and install the Android SDK from the following location:
http://developer.android.com/sdk/index.html.

2. Start the SDK Manager.

3. Install the relevant APIs and Android platform tools.

4. If the SDK Manager fails to retrieve the list of available tools, check your Internet proxy
settings under theSettings tab and click Refresh.
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Creating and Running an Android Virtual
Device (AVD)

To create an Android Virtual Device:

1. Open a command line and navigate to <ANDROID_SDK>\tools, where <ANDROID_SDK> is
the path where you installed the Android SDK.

2. Use android list targets to view the list of available APIs and their IDs.

3. Create a new virtual device using the command : android create avd –n <avd_name> –t
<target_id>, where:

n <target_id> is the number taken from the target list

n <avd_name> is the desired virtual machine name

Note:

l In Android 4.0 the AVD Manager is located in the Tools directory.

l Ensure you select a device with Google APIs.
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To run an Android Virtual Device:

1. Open a command line and navigate to <ANDROID_SDK>\tools, where <ANDROID_SDK> is
the path where you installed the Android SDK.

2. Run the command emulator @<avd_name>, where <avd_name> is the name you used when
creating the AVD.

Configuring a Proxy on the Android Network
1. Run the AVD as described in "Creating and Running an Android Virtual Device (AVD)" on

previous page.

2. On the HOME screen, click Menu.

3. Select Settings > Wireless & Networks > Mobile Networks > Access Point Names –
Telkila.

4. Enter your proxy address in theProxy field.

5. Enter the port number in thePort field.
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Installing an Application on the Android
Emulator

1. Open the AVD.

2. Open a command line and navigate to <ANDROID_SDK>\tools, where <ANDROID_SDK> is
the path where you installed the Android SDK.

3. Run the command adb install <$APK>, where <$APK> is the name of the apk file.

Note the following:

l Ensure you create a device that includes the Google Inc. API.

l If the proxy URL does not work, try using the proxy IP.

l Android does not support PAC proxy URLs. Youmust specify the exact proxy name or IP.

Recording a Mobile Native Application
1. Open VuGen and create a new virtual user (File > New).

2. SelectMobile App (HTTP/HTML), and click Start Recording.

3. Select Record Emulator and configure the following parameters:

n Emulator to record: Set the path to the emulator.exe file in the Android SDK folder.

n Command line: Add any command line arguments that are required to run the emulator (for
example, @avd_name,).

n Working directory: Set the path to the directory in which the emulator.exe is located
(typically ANDROID_SDK_FOLDER\tools).

4. Click Finish.

5. The Android emulator starts. Open your native app and perform the actions you want to record.

6. When you have recorded all the actions, go to VuGen and click Stop.

7. Select File > Zip operations > Export to zip file.

8. Enter a name for the script and click OK.

9. Click OK again.

The script is now ready to run on Business Process Monitor (BPM).

Tip:

l Computer resources: Ensure you have enough computer memory when recording.

l Slow start up: Usually, the emulator start up is very slow and can take several minutes.

l Text check: Document the relevant text checks during recording. A good way to do this is
to use the Inset comments feature.
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Recording a Secure/SSL Native Application
1. Add sdcard to the android emulator:

a. Open the Android emulator installation directory and runAVD Manager.exe.

b. Select the Android 4.0 emulator, and chooseEdit.

c. Choose sd card with 10 MB (you canmake this any size), and chooseEdit AVD to save.

2. Copy the VuGen certificate to the sdcard:

a. Start the Android emulator, and wait for the emulator to load.

b. Select <android emulator installation directory>\tools\ddms.bat.

c. Select the Android emulator > Device > File explorer.

d. Browse to “/mnt/sdcard” directory > Push file onto device (icon with right arrow).
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e. Choose the certificate: C:\Program Files\Hp\LoadRunner\bin\certs\wplusCAOnly_
Expiration_2020.crt, andmake sure it is copied to the sdcard (you should see it under
/mnt/sdcard/wplusCAOnly_Expiration_2020.crt).

f. In the Android 4.0 emulator, selectMenu > System Settings > Security > Install from
sdcard (install certificates from sdcard) > wplusCAOnly_Expiration_2020.crt > OK.
(Note that youmay be asked to add a PIN code.)

g. To verify the certificate is installed, in the Android 4.0 emulator selectMenu > System
Settings > Security > Trusted Credentials > User. You should seeMercury Interactive
Corp Winsock Plus Protocol Interceptor.
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Recording a PCAP File on an Android Mobile
Device

Prerequisites: Youmust have an Android-basedmobile device with root permissions.

To record a PCAP file:

1. From the Android Market, download theShark app.

2. Open theShark app and start recording.

Troubleshooting
Problem: The emulator does not load through VuGen.

Solution:

l Check the command line arguments are correct.

l Make sure to change the path for the Android emulator so that each folder name is no longer than
8 characters (for example, program files (x86)\progra~2).

Problem: There is no Internet connection from the emulator.

Solution: Check the proxy settings inHome Screen > Menu > Settings > Wireless & networks
> Mobile networks > Access Points Names > Telkila > Proxy.

Problem: The emulator does not record the application through VuGen.

Solution: If your application is using HTTPS/Secure protocol, see "Recording aMobile Native
Application" on page 14.
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Problem: When you try recording in VuGen you receive an application login failure, but when you
launch the application using AVD Manager or a command line, you can log in successfully.

Solution: SSL communication failure; try the following procedure: "Recording aMobile Native
Application" on page 14.
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iPhone
Setting up an Ad Hoc Connection on a
Windows Working Station

1. Make sure the wireless adapter is enabled.

2. Select Network and sharing center > Tasks and click Manage wireless networks.

3. Click Add.

4. Select Create an ad hoc network and click Next.

5. Enter a network name and configure the encryption type and password.

6. Click Turn on Internet Connection sharing.

7. Click Close.

8. Connect your mobile device to the new ad hoc connection.

Recording Using an Ad Hoc Connection
1. Create an ad hoc connection on your PC as described in "Setting up an AdHoc Connection on

aWindows Working Station" above, and connect your mobile device to the network.

2. Open VuGen.

3. SelectMobile App (HTTP/HTML).

4. Click Start Recording.

5. Select the first option: Record and analyze traffic.

6. Ensure the host URL and port are correct.

7. Click Connect.

8. Select the correct network interface from theRecord network interface combo box.

9. Click Start Recording.

10. Perform all the actions you want to record on your mobile device.

11. Click Stop Recording.

12. Save the recorded pcap file.

13. Click Next.

14. Select whether to filter by server side or client side, and select the IP by which to filter.
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15. Click Finish.

16. Select File > Zip operations > Export to zip file.

17. Enter a name for the script and click OK.

18. Click OK again.

The script is now ready to run on BPM.
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Windows Phone 7
Installing the Emulator

1. Download theWindows Phone 7 development kit from the following link:
http://www.microsoft.com/download/en/details.aspx?id=13890.

2. Follow the on-screen instructions to install.

3. If you need to configure a proxy, see http://msdn.microsoft.com/en-us/library/ff754351
(v=vs.92).aspx#BKMK_ConfigProxy.

Running the Emulator
To run the emulator, perform one of the following:

• From theWindows Phone Developer Tools menu, selectWindows Phone 7 Emulator.

OR

• From a command line:

1. Navigate to where you installed the development kit (default is C:\Program Files (x86)
\Microsoft SDKs).

2. Navigate to the folder \Windows Phone\v7.0\Tools\XDE Launcher\.

3. Run the commandXdeLauncher "Windows Phone 7" "Windows Phone 7 Emulator".

Recording a Native Mobile Application with
VuGen

1. Open VuGen and create a new virtual user (File > New).

2. SelectMobile App (HTTP/HTML), and click Start Recording.

3. Select Record Emulator and configure the following parameters:

n Emulator to record: Set the path to the xdeLauncher.exe file in the windows SDK folder

n Command line: Add any command line arguments that are required to run the emulator.
Default settings are: "Windows Phone 7" "Windows Phone 7 Emulator"

n Working directory: Set the path to the directory in whcih the xdeLauncher.exe is located.
The default path is: C:\Program Files (x86)\Microsoft SDKs\Windows
Phone\v7.0\Tools\XDE Launcher\.

4. Click Finish.
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5. TheWindows Phone 7 starts. Open your native app and perform the actions you want to
record.

6. When you have recorded all the actions, go to VuGen and click Stop.

7. Select File > Zip operations > Export to zip file.

8. Enter a name for the script and click OK.

9. Click OK again.

The script is now ready to run on BPM.
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Blackberry
Installing the BlackBerry Emulator

1. Access the following link and select the phonemodel you want to emulate: 

http://us.blackberry.com/developers/resources/simulators.jsp.

2. Follow the on-screen instructions to install.

Recording a Native Mobile Application with
VuGen

1. Open VuGen and create a new virtual user (File > New).

2. SelectMobile App (HTTP/HTML), and click Start Recording.

3. Select Record Emulator and configure the following parameters:

n Emulator to record: Set the path to the emulator executable file in the BlackBerry emulator
directory (for 9800, the default path is C:\Program Files (x86)\Research In
Motion\BlackBerry Smartphone Simulators 6.0.0\6.0.0.534 (9800)\9800.bat).

n Command line: Add any command line arguments that are required to run the emulator (for
9800 there are no required arguments).

n Working directory: Set the path to the directory in which the xdeLauncher.exe is located.
The default path for 9800 is C:\Program Files (x86)\Research In Motion\BlackBerry
Smartphone Simulators 6.0.0\6.0.0.534 (9800)\.

4. Click Finish.

5. The BlackBerry emulator starts. Open your native app and perform the actions you want to
record.

6. When you have recorded all the actions, go to VuGen and click Stop.

7. Select File > Zip operations > Export to zip file.

8. Enter a name for the script and click OK.

9. Click OK again.

The script is now ready to run on BPM.
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WebOS
Recording a Native Mobile Application with
VuGen

Prerequisites:

l VuGen

l WebOS emulator with Internet access

l Oracle VirtualBox

To record a nativemobile application:

1. Open VuGen and create a new virtual user (File > New).

2. SelectMobile App (HTTP/HTML), and click Start Recording.

3. Select Record Emulator and configure the following parameters:

n Emulator to record: Set the path to the emulator executable file in the BlackBerry emulator
directory (the default path is C:\Program Files (x86)\HP webOS\SDK\bin\palm-
emulator.bat).

n Command line: Add any command line arguments that are required to run the emulator (for
WebOS there are no required arguments).

n Working directory: Set the path to the directory in which the xdeLauncher.exe is located.
The default path forWebOS is C:\Program Files (x86)\HP webOS\SDK\bin\.

4. Click Finish.

5. TheWebOS emulator starts. Open your native app and perform the actions you want to record.

6. When you have recorded all the actions, go to VuGen and click Stop.

7. Select File > Zip operations > Export to zip file.

8. Enter a name for the script and click OK.

9. Click OK again.

The script is now ready to run on BPM.
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Creating a Script from a PCAP File
Creating PCAP on the server side:

l When your application is in testingmode, you can install a sniffer on the application’s server
machine and capture the entire traffic between the server and different clients.

l By filtering a different mobile device IP each time, you can create different pcaps for eachmobile
device.

Creating PCAP on the client side

l You can install sniffers on different mobile devices machines and then capture the traffic
between themobile device and the server.

l Once a pcap file is ready,use the following instructions to create a VuGen script from pcap.

How to Create a Script from a PCAP File
1. Open VuGen and selectMobile App (HTTP/HTML).

2. Click Start Recording.

3. Select Analyze traffic.

4. Browse to where you saved your pcap file and select it.

5. Select whether to filter by server side or client side, and select the IP by which to filter.

6. Click Finish.

7. Select File > Zip operations > Export to zip file.

8. Enter a name for the script and click OK.

9. Click OK again.

The script is now ready to run on BPM.

Tip: Use one pcap file per transaction, and then copy it to one script according to the flow you
want to measure.
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TruClient
Recording Mobile TruClient with VuGen

Prerequisites:

l VuGen

l Proxy IP/URL (if you are using a proxy)

To record:

1. Open VuGen and create a new virtual user (File > New).

2. SelectMobile ‘TruClient’, and click Develop Script.

3. If you are using a proxy, ensure you also set it in theRecording Options:

a. In VuGen, select Tools > TruClient General Settings.

b. Add the proxy settings to theAutomatic Proxy Configuration.

4. Select amobile device from the list.

5. Change the resolution, if necessary.

6. Click OK.

7. The browser loads. Use it to perform the actions you want to record.

8. Click Stop.

9. Select File > Zip operations > Export to zip file.

10. Enter a name for the script and click OK.

11. Click OK again.

The script is now ready to run on BPM.

For more information, refer toVirtual User Generator > Help > Mobile Documentation.

HP Business Process Monitor (9.22)Page 26 of 26


	Recording Mobile Apps for BPM - Best Practices
	Contents
	Introduction
	Choosing a Mobile Monitoring Solution
	Mobile Monitoring Options
	Monitoring Solutions
	Application Types
	Protocols
	Native Mobile Apps - Recording Methods

	Android
	Installing the SDK
	Creating and Running an Android Virtual Device (AVD)
	Configuring a Proxy on the Android Network
	Installing an Application on the Android Emulator
	Recording a Mobile Native Application
	Recording a Secure/SSL Native Application
	Recording a PCAP File on an Android Mobile Device
	Troubleshooting

	iPhone
	Setting up an Ad Hoc Connection on a Windows Working Station
	Recording Using an Ad Hoc Connection

	Windows Phone 7
	Installing the Emulator
	Running the Emulator
	Recording a Native Mobile Application with VuGen

	Blackberry
	Installing the BlackBerry Emulator
	Recording a Native Mobile Application with VuGen

	WebOS
	Recording a Native Mobile Application with VuGen

	Creating a Script from a PCAP File
	How to Create a Script from a PCAP File

	TruClient
	Recording Mobile TruClient with VuGen


