Unable to connect Vugen or Analysis with ALM/PC getting error message Failed to update components from server

  • KM00395018
  • 29-Mar-2013
  • 29-Mar-2013

This document has not been formally reviewed for accuracy and is provided "as is" for your convenience.

Summary

Unable to connect Vugen or Analysis with ALM/PC getting error message Failed to update components from serve. Some DLL files are not registry correctly in the machine in order to run the connection correctly.

Error

Failed to update components from server” Following client components were not downloaded successfully:

1. tdclntui.dll :Access is denied.

2. tdclient.dll :Access is denied.

Close all connections to HP ALM Server and try again

Cause

Possible cause of the error are the following:
 
·         User is not running an admin account or does not have enough privileges to registry those .DLL files.
 
·         Need to install or reinstall the PC connectivity Add-in; you can find those under the main ALM Web site under add-on section.
·         The Software must be running on the local machine not a share location.

Fix

In order to fix this issue you can check the following:
 
·         Make sure the ALM connectivity add-in is running under the machine.
·         Provide the user administrator privileges or enough access to install software under the system.
·         If the user already have Admin right have them execute Vugen or Analysis as Administrators.