The Business Service Management (BSM) Webserver Access log is extremly large (Single File)

  • KM00367518
  • 25-Feb-2013
  • 28-Feb-2013

Summary

The Business Service Management (BSM) Webserver Access log is extremly large (Single File)

Error

The access.log file could grow out of control and causes Business Service Management (BSM) to become unresponsive.

Cause

There could be many scenarios, and you need to review the information at:

http://httpd.apache.org/docs/current/logs.html

The reasonable definition of the problem can be found in the Log Rotation Section from the address above. The defination states:

"On even a moderately busy server, the quantity of information stored in the log files is very large. The access log file typically grows 1 MB or more per 10,000 requests. "

Fix

Although there are several methods of the workaround/fix options, you should look at the following link for a better understanding of your options:

http://httpd.apache.org/docs/current/logs.html

Here are a few examples:

You will need to remove or shrink the access.log from \WebServer\logs directory to help performance.

If you want to delete the logs, you will need to do the following:

  1. Stop the Apache services
  2. Delete the log file
  3. Start the Apache services

Alternatively, you could disable logging completely by commenting out in httpd.conf, at the following line:
CustomLog "logs/access.log" common
So again, to change the log file:
  1. Stop the Apache services
  2. Comment out the line in the httpd.conf file (as above)
  3. Start the Apache services