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Cloud Installation Dashboard Guide

Prerequisites

Basic Configuration

The Cloud environment consists of Admin, Controller, and Compute nodes. An optional Windows client can be added to the configuration.

Node Role

Admin Node Ubuntu12.04 OS where Cloud Infrastructure media is booted. Bootstraps the install to set up the Controller and Compute
nodes.

Controller
Node

Hosts the Cloud Infrastructure services.

Compute Node Hosts the provisioned virtual machines. Multiple compute nodes can be created to provide more cloud capacity.

CDA Node (Optional) Continuous Delivery Automation - complete dev-ops solution that integrates with Cloud Infrastructure services.

CSA Node (Optional) Cloud Service Automation - a portal to subscribe application/platform/infrastructure offered by CDA.

Windows client This machine has a connection to the private network and will provide browser and SSH access to the Admin and other
nodes.

In small cloud environments, the Controller and Compute features are co-located on the same node. In larger cloud environments, the Compute
node may be separate from the Controller node, with additional Compute nodes available to provide larger provisioned cloud capacity.

CDA and CSA are installed in their own respective nodes.

Cloud Infrastructure Sizing

Refer to the HP Cloud Connector Physical Infrastructure Reference Architectures (PIRA) document.

Cloud Infrastructure Suggested Deployment Diagrams

Refer to the HP Cloud Connector PIRA document.

CDA & CSA Node Sizing

Refer to the CDA and CSA Installation Guides.

Set Up the Cloud Infrastructure Environment

To set up the Cloud Infrastructure environment, go to the  section.Prepare Cloud Environment

Prepare Cloud Environment

Overview

Preparing the Cloud Environment requires IT administrators to set up the appropriate network, storage, and hardware infrastructure as described
in the HP Cloud Connector PIRA document. Suggested deployments:
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Prepare the Servers (Deployment Diagram I)

The steps below outline Deployment Diagram I where the Admin node is virtual and the other nodes are on physical machines.
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1.  
2.  
3.  
4.  
5.  
6.  
7.  

1.  
2.  
3.  
4.  

5.  
6.  
7.  
8.  
9.  

10.  
11.  
12.  
13.  
14.  
15.  

a.  
i.  
ii.  

b.  
i.  

c.  
i.  

d.  
i.  

16.  
17.  
18.  
19.  
20.  
21.  
22.  

Controller and Compute Node

The Controller and Compute node must be  powered OFF before installing Cloud Infrastructure. If you are using HP Blade servers, these are the
typical steps:

Using the Integrated Lights-Out 3 (iLO) web interface, access the Controller and Compute node.
Log into the iLO session.
In the right pane of the iLO screen, the server power displays  or .ON OFF
In the left pane, select .Power Management > Server Power
In the right pane, select the   button to do a forced power OFF. Confirm the action.Press and Hold
The right pane displays that system power is .OFF
Log out of the iLO session.

Admin Node

The Admin node must be booted using  either a CD/DVD or an ISO image. The release product ISO image file name is .Cloud_Installer_1_0.iso

Booting the Admin Node from the ISO Image

The following steps outline how to boot the Admin node from the ISO image setting up the Admin Node as a guest VM on vCenter (using ESX
4.1.0 or above).

Note: the ISO image should be located in the vCenter's datastore.

Ensure the Admin node is powered OFF.
Edit the VM settings.
Set the CD/DVD to connect at power ON and point it to the ISO file in the “Datastore ISO file” selection.
Select . In the Force BIOS Setup, Check the box for Options > Advanced > Boot Options The next time the virtual machine boots,

.force entry into the BIOS screen
Click OK.
Power ON the VM.
View the Admin node's console. A series of dialog boxes display. Use the <Tab>, <Enter>, and <Arrow> keys to navigate.
The VM console should display the BIOS Setup Utility screen.
Use the arrow keys to select the  section.Boot
Using the keyboard, move the CD/DVD drive to the first item in the list so it will boot from the ISO.
Press F10 or use the arrow keys to select . Press <Enter>.Exit
Select Yes. 
The VM will begin to boot.
A "Configure the Network" dialog box displays. Select .eth0
Enter the following information in the "Configure the Network" dialog box:

Admin node's IP address. Select .<Continue>
Example: 192.168.124.10
NOTE: If you provide a different  IP Address and related settings, ensure that the Cosmos Networks UI is also set up
this way.

 Netmask. Select .<Continue>
Example: 155.255.255.0

Gateway. Select .<Continue>
Example: 192.168.124.1

Name server.  Select .<Continue>
Example: 192.168.124.10

Wait while the system detects the link on eth0.
Specify the appropriate time zone in the "Configure the Clock" dialog box.
Wait for the ISO image to complete installation.
The Admin node will display a login screen when finished.
Power the VM down.
Edit the VM settings so that it won't boot from the ISO again (refer to the picture).
Power the VM up.

The Cosmos installer has now been successfully installed on the Admin node.

From the Windows VM client, use a browser to access the URL,  to access the Admin node. : The browser musthttp://192.168.124.10:9000 NOTE
not have a proxy set.

Next Step

Refer to the  section to begin installation and configuration of the Cloud Infrastructure.Set Up Cloud Administration Node
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Set Up Cloud Administration Node

Overview

Using a browser that has access to the Cloud Administration node and cloud network, invoke the URL   to access thehttp://192.168.124.10:9000
Cloud Installation Dashboard.

NOTE: If you are installing on a private network, a proxy must be set in the browser.

Set Up the Cloud Administration Node

Review Configuration Prior to Setup

From the HP Cloud Installation Dashboard, review the  and  tabs to understand the concepts of Cloud environments andWelcome Overview
setup configurations. Customize Server Types, Connections, and Networks based on your network and hardware infrastructure.

Server Types: This panel lets you capture (or use existing) server definitions about the networking ports for the various servers in your
bare-metal cloud environment. If all of the servers in your cloud are the same machine type (homogeneous nodes), you will not need to configure
anything in this section. HP recommends keeping the defaults.

Connections: To define a connection set, review one of the network modes (single, dual, team, etc.) along with a list of logical connection
interfaces (intf0, intf1, etc.) with each one being bound to a port, defined by bandwidth and port number. You may want to use the Edit

 option if your Connection Type is Dual and the interfaces are not contiguous, For example, eth0 - private 1 and eth2 is public. TheConnection
default settings assume that you have  of the participating hosts/nodes connected to Private Network1 and  connected to a publiceth0 eth1
network.
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: If you are not sure, keep the default settings to avoid installation failure.NOTE

Networks: For each logical connection (i.e., intf0, intf1, etc.) a network is defined (i.e., admin network, public network, BMC network, etc.). The
different networks are used for varying purposes in the cloud, such as networking between the nodes and this Cloud Administration Node (i.e.
admin network), and the public or corporate network (i.e., public network) attached to your cloud. The default settings configure VLAN (tagged as
300) based on a public network on  if installing in dual mode, and on  if installing in single mode. In such cases, you will need an externaleth1 eth0
router for traffic to internet/public.

If you plan to provide external access directly to the participating hosts/nodes, ensure you have two sets of contiguous IP ranges:

Range 1: 16.x.x.2 to 16.x.x.10 (This range will get assigned to the bootstrapped participating nodes.)
Range 2: 16.x.x.121 to 16.x.x.254 (This range is for Floating IP Configuration in OpenStack, used later in the Installation Guide.)

The customization is done through a two-step process:

1. Edit Network: Specify Subnet, Netmask, Broadcast, VLAN Enabled and Router details specific to your public/corporate network.

2. Edit Ranges: Specify a range for Node Type host for the participating nodes.
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1.  

2.  
3.  

a.  
b.  

NOTE: If you are not sure, keep the default settings to avoid installation failure.

During the boot process, if you have provided ip address other than 192.168.124.10, you must update the  network.Admin

Begin the Setup Process

To start the setup process, use the following steps:

Select the  tab.Setup

Click .Complete Setup
Specify the necessary configuration:

Set  to dual.Network Mode
Set  to Disabled.IPMI/BMC Network Status
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3.  

b.  

4.  
5.  

6.  

: Enable IPMI/BMC feature is for test purposes only.NOTE
Click  . This action installs crowbar on the Cloud Administration node. This may take several minutes.Complete Setup
A working status message displays in the  column.  : Any failure at this stage requires rebuilding the Admin nodeSetup Complete NOTE
through the bootable ISO.

Click  to view the install activity. Click  to monitor the install progress.Show Install Log Refresh
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6.  

7.  

8.  

Once crowbar is installed, the screen will display the timestamp in the  column.Setup Complete

Click   (if you did not do this previously) to view install activity.Show Install Log

Page 9



8.  

1.  

Next Step

The Cloud Administration node is ready to be configured. Refer to the  section.Configure Cloud Administrator Node

Configure Cloud Administrator Node

Overview

Ensure the Cloud Administration node has been prepared as outlined in the previous section.

The following steps must be executed to begin configuring the Cloud Administration node.

Click .Deploy Cloud
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1.  

2.  

1.  

A  tab becomes visible in the left navigation panel.Cloud

Enable Cloud Administration Node for Internet Access

Cloud Administration node temporarily needs access to the Internet to download and install necessary third-party packages such as MongoDB.
The settings for public access of Admin node will be disabled post reboot.

Follow these steps to enable networking:

Click  in the  entry.Edit Prerequisite Cloud Admin Node Internet Access
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1.  

2.  

3.  
4.  
5.  

a.  
b.  
c.  

6.  
7.  

The Edit Cloud Admin Node Internet Access Prerequisite screen displays.

Set  to  ( : eth1 is connected to a network providing internet access.)Network Interface eth1 NOTE
Use the default  checked as Network Configuration DHCP
Set  applicable for your environment.HTTP Proxy Information

Specify the Host
Specify the Port
If necessary, specify the optional  and .Username Password

Click .Update Prerequisite
Click  for the  entry. The button is located in the drop-down menu to theComplete Prerequisite Cloud Admin Node Internet Access
right of the  button.Edit Prerequisite
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7.  

8.  

9.  

10.  

11.  
12.  

Click  in the confirmation dialog box.Complete Prerequisite

Click  for the  entry.Complete Prerequisite Build MongoDB Installation Module

Click  in the confirmation dialog box.Complete Prerequisite

It may take several minutes as the MongoDB install packages are being downloaded from the Internet to the Cloud Administration node.
Ensure that a time stamp is displayed in the  column. A success message displays when the MongoDB prerequisites areCompleted
configured.
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12.  

13.  

1.  

If the prerequisites fail to complete, the following error message displays. Consult the  section for a solutionTroubleshooting

Next Step

The Domain Controller node is ready to be deployed. Refer to the  section.Deploy Domain Controller

Deploy Domain Controller

Overview

Ensure that the Cloud Administration node prerequisites have been configured.

Use the following steps to deploy Cloud Infrastructure services to the Domain Controller node from the Cloud Administration (Admin) node. The
Admin node is also accessible directly through the web URL: http://192.168.124.10:3000

NOTE: Use Google Chrome or Mozilla Firefox to access the Admin node.

Select the  tab.Domain Controllers

Page 14

http://192.168.124.10:3000


1.  

2.  
3.  

a.  
b.  

4.  

1.  
2.  

3.  
a.  
b.  

c.  

Click .Deploy Domain Controller
Enter the credentials:

User Name: crowbar
Password: crowbar

The  displays with a green Admin node indicating it is online.Node Dashboard

Deploy the Domain Controller

Discover and Allocate Controller node

The Domain Controller node needs to be powered ON.
When the Domain Controller node boots up, the Cloud Administration node automatically installs through a PXE boot, the Ubuntu
operating system.
The  displays the Domain Controller node as the operating system is installed:Node Dashboard

The status indicator is initially grey.
The Domain Controller node displays in the  with a generated, MAC Address name.Node Dashboard
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3.  

c.  

4.  

5.  

6.  

Tip: Note the Domain Controller node's console to monitor the system as it is being installed.

Wait until the  shows the Domain Controller node with a flashing yellow status.Node Dashboard

To confirm that the MAC Address name is associated to the Domain Controller node, view the Domain Controller node's console.The
hostname displayed in the Domain Controller node's console will match the MAC Address name displayed in the .Node Dashboard

On the Cloud Installation Dashboard, select   .Nodes > Bulk Edit
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6.  

7.  

8.  
9.  

Click the  checkbox.Allocate?

Select .Save
On the Cloud Installation Dashboard, select  >  .Nodes Dashboard
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9.  

10.  
a.  
b.  

11.  

Wait for the Domain Controller node's status to change from yellow to green.
View the Domain Controller node's remote console. If you are using HP hardware, monitor installation progress through iLO.
If a dialog box opens with a message to load missing firmware, provide the appropriate driver.

When the Domain Controller node installation is complete, the  displays the Domain Controller node as Ready.Node Dashboard
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11.  

12.  

1.  

2.  

Tip: The Domain Controller node's login prompt displays the MAC Address name displayed in the .Node Dashboard

Rename the Domain Controller

It is helpful to rename the generated Domain Controller node name to one reflecting its functionality.

Follow these steps to rename the Domain Controller node:

Select the Domain Controller node's .MAC Address name

Page 19



2.  

3.  

4.  
a.  

Details for the Domain Controller node display.

Click  .Edit

Change the alias field from the MAC Address name to a meaningful name.
From:
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4.  
a.  

b.  

5.  

To:

Click  . The Domain Controller node's new name is displayed.Save
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5.  

6.  Notice the  of the Domain Controller node remains unchanged.Full Name

Complete Storage Configuration

With OS up, the next step is to extend the root volume to accommodate nova-volume and image repository. If you plan to configure Nova-Volume
to use a raw device, ensure it is correctly discovered by the OS. In some environments, you may have to configure Multi-Path support at this
stage.
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1.  

2.  

Apply Barclamps to the Domain Controller

The Cloud Infrastructure services are delivered as barclamps. Barclamps are a mechanism to install and configure a service on the Domain
Controller node.

Use the following steps to apply barclamps:

From the Domain Controller node detail page, select  >  .Barclamps Cloud Infrastructure

The barclamps specific to Cloud Infrastructure display.
NOTE: It is important that these barclamps be applied in sequential order, each one successfully completing before applying the
next barclamp.  
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2.  

1.  
a.  

b.  

For each barclamp in the list, perform the following steps:
Select the .barclamp's name

Specify the  as the proposal.Domain Controller's name
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1.  

b.  

c.  
d.  

i.  
ii.  
iii.  
iv.  
v.  
vi.  

vii.  
viii.  

ix.  
x.  

e.  
i.  
ii.  

1.  

2.  

Click .Create
Verify that the default values are correct for the proposal. Some optional values should be set.

Postgres proposal
Keystone proposal
Glance proposal
Rabbit MQ proposal
Mongo DB proposal
Eden proposal. It is recommended you specify a  and  for the proposal. : If specifying aProxy Host Proxy Port NOTE
Proxy Host, ensure that the Non Proxy Host(s) field specifies an admin or public network, for example: 192.*|10.*
Peer proposal
Eve proposal. It is recommended you specify a  and  for the proposal. : If specifying aProxy Host Proxy Port NOTE
Proxy Host, ensure that the Non Proxy Host(s) field specifies an admin or public network, for example: 192.*|10.*
Focus proposal
Skyline proposal. It is recommended you specify a  and  for the proposal.Proxy Host Proxy Port

Verify that the Domain Controller node's name is listed for each applicable role. The defaults should be sufficient.
At the bottom of the proposal, the items on the left are ; the items on the right are the .Available Nodes Roles
Select the Domain Controller node name link in the  list to drag it to the appropriate role (if not doneAvailable Nodes
previously).

Selecting the Domain Controller node link icon  and dragging it to a role will not work.

Selecting the Domain Controller node delete icon  removes the association of the Domain Controller
node from a role.
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1.  

e.  

ii.  

2.  

f.  
g.  

h.  

Click  . Click  .Apply OK
Wait for the proposal status (displayed at the top left of the dialog box) to turn green.

If the proposal fails to apply, the following error message displays. Consult the  section for a solution.Troubleshooting
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1.  

h.  

i.  

j.  

Re-select  >   to view the barclamp list.Barclamps Cloud Infrastructure

The proposal status is also displayed within the Cloud Infrastructure barclamp list.
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1.  

j.  

k.  
l.  

1.  

Apply the next barclamp in the list, from top to bottom until all Cloud Infrastructure barclamps have been applied.
At this stage, you may optionally apply CDA and CSA barclamps. Ensure you have completed the pre-requisite "Coexisting of
CSA and CDA on same host" before applying CSA barclamp. Also, ensure you have completed the post-installation steps of
CSA barclamp. Refer to Deploying CSA and CDA sections.

Next Step

The Compute Region node is ready to be deployed. Refer to the  section.Deploy Compute Region

Deploy Compute Region

Overview

Ensure that the Cloud Administration and Domain Controller nodes have been deployed successfully. Use the following steps to deploy Cloud
Infrastructure services to the Compute node from the Cloud Administration node.

Select the  tab.Compute Regions
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1.  

2.  
3.  

4.  

1.  
2.  

Select the  button.Deploy Compute Region
Enter crowbar/crowbar for the credentials.

The  displays with the Admin and Controller nodes displaying a green online status.Node Dashboard

Deploy the Compute Region

Deploying the Compute Region involves bringing up Compute node, ensuring it is discovered and allocated, and applying Nova proposal to both
Controller and Compute nodes. Follow the steps below:

Discover and Allocate the Compute Node

The Compute node needs to be powered ON.
When the Compute node boots up, the Admin node automatically installs the OS using a PXE boot. The  displays theNode Dashboard
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2.  

a.  
b.  
c.  

3.  

4.  

5.  

6.  

node as the OS is installed. 
The status indicator is initially grey.
The node initially displays in the  with a generated, MAC address name.Node Dashboard
Tip: view the node's console to monitor the system as it is being installed.

Wait until the  shows the new node with a flashing yellow status.Node Dashboard

Tip: To confirm that the MAC Address name is associated to the node, view the node's console. The hostname displayed in the node's
console will match the MAC Address name displayed in the Node Dashboard.

On the Cloud Installation Dashboard, select Nodes > Bulk Edit.

Click the  checkbox.Allocate?
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6.  

7.  
8.  

9.  
10.  
11.  

12.  

Click .Save
On the Cloud Installation Dashboard, select  >  .Nodes Dashboard

Wait for the node's status to change from yellow to green. View the node's console for installation progress.
If a dialog asking to load missing firmware displays, select NO.
When the node's install has completed, the *Node Dashboard *displays the node in the same group as the Admin node and displays a
green status.

Tip: the node's login prompt displays the MAC Address as hostname displayed in the} .Node Dashboard
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12.  

1.  

2.  

Rename the Compute Node

In general, it is helpful to name the nodes installed by Cloud Installation Dashboard something meaningful to their function.

Follow these steps to rename the Compute node:

Select the .node's MAC Address name

Click .Edit
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2.  

3.  
4.  
5.  

6.  

Change the alias field from the MAC Address name to a meaningful name.
Click .Save
Notice the node's new name is reflected in the display.

Notice the  of the node remains unchanged.Full Name
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6.  

1.  

Apply Nova proposal to Compute Region

The Cloud Infrastructure services are delivered as barclamps.  Barclamps are a mechanism to install and configure a service on the Compute
Region.

Use the following steps to apply barclamps:

From the node's detail page, select   .Barclamps > Cloud Infrastructure
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1.  

2.  

3.  

4.  
a.  

The barclamps specific to Cloud Infrastructure display.

Take special note that the majority of the barclamps have been deployed, as indicated by the green status. Nova is the next barclamp to
deploy. It must be deployed on both the Controller and Compute nodes.
For the Nova barclamp, perform the following steps:

Select the .barclamp's name
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4.  
a.  

b.  

c.  

d.  

Specify the  as the proposal.Compute Region's name

Click .Create
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4.  

d.  
i.  
ii.  

iii.  
iv.  

v.  
1.  
2.  
3.  
4.  

5.  

6.  
e.  
f.  

Verify that the default values are correct for the proposal. Some Nova values need adjusting.
Sample nova proposal part 1. Use the default values
Nova-Volume role by default is hosted by the Controller. If it has an additional block device designated for Nova-Volume,
set the  value to .Type of Volume raw
If not, and it has sufficient space on the /root volume, set the  value to .Type of Volume local
In case of local, set the  value to a size reasonable for the environment. Dedicate sufficient spaceMaximum File Size
for image repository. Typically, dedicate 80% of the space to nova-volume. A nova-volume host persistent virtual disk of
VM instances launched by OpenStack.
Sample nova proposal part 2. The following roles must be set:

At the bottom of the proposal, the items on the left are ; the items on the right are the .Available Nodes Roles
Ensure the Compute node is set for only the  role.Nova-multi-compute
Ensure the Controller node is set for Both *Nova-multi-controller and Nova-multi-volume roles.
Select the node name's link in the  list to drag it to the appropriate role (if not already done).Available Nodes

Selecting the node's link icon  and dragging it to a role will not work.

Selecting the node's delete icon  removes the association of the node to a role.
Click . Click  .Apply OK
Wait for the proposal status (displayed at the top left of the dialog box) to turn green.

### The proposal status can also be seen within the barclamp list.
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4.  

f.  

5.  Re-select  to view the barclamp list again.Barclamps > Cloud Infrastructure

NOTE: If you wish to add another Compute Node later, follow the steps of discover and allocate the new node and add the node to an existing
nova proposal. Do not create a separate proposal for the newly added node.

Next Step
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All Cloud Infrastructure barclamps are now applied to the Domain Controller and the Compute node(s). The next step is configuring Networking
(Nova Fixed and Floating Network) for VM instances launched by the Cloud Infrastructure. Refer to the Configure Networking Infrastructure for

 section.Virtual Machines in the Cloud

Configure Networking Infrastructure for Virtual Machines in the Cloud

Overview

Once the Cloud Infrastructure is deployed, the network infrastructure for the Cloud needs to be configured.

Referring back to the Deployment Diagram I, your networking environment should consist of:

eth0 - private 1 as administration network
eth1 - public/corporate network
eth2 - private 2 network available for configuring Fixed IP networks

Setting a Fixed Network

Access the Cloud Administration Dashboard URL http://<MACAddressHostnameOfDomainController>; provide Credentials 
Admin/secretword
Go to Region tab > Networks.
Click .Create Fixed IP
Set  to the desired nameNetwork Label
Leave  not selected, enabling the fixed network to be used across the Cloud. This setting indicates that the network is a flatProject
DHCP fixed IP network.

Set  to a specific project the fixed network needs to be separate for the project. This requires VLAN configuration on theProject
eth2 port as well as the connecting switch.

Set  to IPv4 CIDR 192.168.123.0/24
A Class B CIDR may be provided to accommodate more VMs.

Set  to Gateway 192.168.123.1
Set  to DNS1 192.168.124.10
Set Multi-Host to True.
Set  to Number of Networks 1
Set  to Network Size 256
Set Bridge ID to  (or any custom name).br100
Set  to  (needs to be unique if you are adding multiple fixed networks).Bridge Interface eth2

NOTE: If the private Network 2 is shared for other purposes, set the VLAN correctly on the switch with the appropriate tag. Also, create the VLAN
interface on both the Controller and Compute nodes.

For example, the following command creates a VLAN interface on eth2 with tag 500:

sudo vconfig add eth2 500

In the above example, the following fields will have additional information:

Set  to VlanID 500
Set  to BridgeID br500
Set  to Bridge eth2.500

Setting a Floating Network

Access the Cloud Administration Dashboard URL http://<MACAddressHostnameOfDomainController>; provide Credentials 
Admin/secretword
Go to Region tab > Networks.
Click .Create Floating IP
Set  to the static IP range applicable to the corporate/public network.IPv4 CIDR
Set  to the interface that is configured for public/corporate access. In this example, it is .Interface eth1

Post Deployment and Validation

Overview
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The Cloud Infrastructure installation and configuration is complete. The post-deployment tasks outlined below validate the Compute and Topology
implementation of the Cloud Infrastructure.

Setting an Image Repository

An image repository contains necessary images to be provisioned into the Cloud as part of a Topology design. Initial images needed are base
operating system images.
For example, download the following operating system images:

CirrOS Image - https://launchpad.net/cirros/trunk/0.3.0/+download/cirros-0.3.0-x86_64-disk.img
Ubuntu Image - http://uec-images.ubuntu.com/precise/current/precise-server-cloudimg-amd64-disk1.img

Follow these steps to upload these images to Cloud Infrastructure:

Copy these images to the Admin node's  folder. This folder requires read/write permission./tftpboot
Log into the Cloud Administration Dashboard, using default credentials .Admin/secretword
Navigate to Domain > Images and click .Create Image

Set  to the desired image name.Name
Set  to the HTTP URL of the Admin node's  folder, including the image name.Image Location /tftpboot

For example: http://192.168.124.10:8091/precise-server-cloudimg-amd64-disk1.img
Set  to Format QCOW2
Set  to Minimum Disk 0
Set  to Minimum RAM 0
Set  to *YesPublic
Click .Create Image
From the Images table, click the image's name to validate the image's details and size once loaded.
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Creating a Keypair

For a secure environment, every VM instance to be launched needs to have a keypair injected. This keypair is used to SSH into the launched VM
instance.

To create:

Navigate through Project > Manage Compute > Access & Security and click .Create Keypair
Provide the Keypair Name (use 'testonlykeypair' or any custom name).
Download the keypair to a safe location.

Configuring the Default Security Group

To validate the VM accessibility, the VM needs to be on a network segment (security group) that has both "ping" and SSH ports open. To to this,
edit the default security group:

Navigate through Project > Manage Compute > Access & Security
Under Security Groups, click  on the default security group.Edit Rules
Under Add Rule, specify the following values:

For SSH, IP Protocol: TCP; From Port: 22; To Port:22; Source Group: CIDR; CIDR: 0.0.0.0/0
For PING, IP Protocol: ICMP; From Port: -1; To Port:-1; Source Group: CIDR; CIDR: 0.0.0.0/0

Click  and add the next rule.Update Security Group Rules

Launching a VM Instance

Next, validate whether you can launch a VM instance using the newly uploaded image:

Navigate through Project > Manage Compute > Images
Click  on the newly uploaded image nameLaunch
Provide following values:

Instance Source: Image
Image: precise-server-cloudimg
Server Name: TestPurposeOnly1 <or any custom name>
Flavor: m1.tiny
Instance Count: 1

Go to Access and Security tab within the Launch Instance window and select the newly created keypair and ensure that 'default' has a
check mark under Security Groups.
Click .Launch

Validating VM Accessibility

Validate whether the VM was launched successfully:

Navigate through Project > Manage Compute > Instances.
Locate the recently launched VM instance and click on the Instance Name.
From the Overview tab, record the IP Address assigned to this instance.
Switch to the Log tab and ensure the following has been logged:

cloud-init boot finished at Mon, 17 Dec 2012 19:04:33 +0000. Up 209.73 seconds

Validate whether network infrastructure has been set up correctly to access the recently launched VM. Using the IP address of the
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instance from the previous section, try to ping and ssh into it.
For Ping, do the following:

Ensure you are on the same network as your VM Instance or have the proper routing enabled.
Open up the command prompt, and try pinging the IP Address.

For SSH, do the following:
Ensure you are on the same network as your VM Instance or have the proper routing enabled.
Convert the file downloaded during keypair creation from .pem to .ppk format. You can use a tool like PuTTYgen to convert.
If you are using a Putty Client to do SSH, provide the .ppk file under Connection > SSH > Auth > Authentication Parameters >
Private key file for authentication, OR
If you are already in an SSH window of one of the Compute nodes, enter the following command to validate that the SSH is
working:

root@de4-11-5b-b7-b3-6e:/home/crowbar# ssh ubuntu@192.168.123.161 -i
testonlykeypair.pem
Warning: Permanently added '192.168.11.161' (ECDSA) to the list of known
hosts.
Welcome to Ubuntu 12.04.1 LTS (GNU/Linux 3.2.0-34-virtual x86_64)

 * Documentation:  https://help.ubuntu.com/

  System information as of Mon Dec 17 19:32:51 UTC 2012

  System load:  0.0               Processes:           59
  Usage of /:   33.3% of 1.96GB   Users logged in:     0
  Memory usage: 8%                IP address for eth0: 192.168.123.161
  Swap usage:   0%

  Graph this data and manage this system at
https://landscape.canonical.com/

0 packages can be updated.
0 updates are security updates.

Get cloud support with Ubuntu Advantage Cloud Guest
  http://www.ubuntu.com/business/services/cloud

The programs included with the Ubuntu system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
applicable law.

To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

ubuntu@testpurposeonly1:~$

Creating Resource Pool

To enable and validate domain controller services that launch Infrastructure Design documents, use these steps to create a Resource Pool:

Navigate through Project > Manage Topology > Resource Pools.
Click .Create Resource Pool
Provide the following values:

Cloud Type: HP Cloud Infrastructure - OpenStack (Essex) (select from the drop-down)
Compute Region: Domain/RegionOne (select from the drop-down)
Name: <ProvideCustomName> or AdminProjectRP
Type: OpenStack
Version: Essex 2012.1.x
Region ID: RegionOne
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Domain URL:  or <URLtoKeystoneHost>http://192.168.124.81:5000/v2.0/tokens
Click .Create Resource Pool
Validate that the newly created Resource Pool is listed under .Resource Pools

Creating Infrastructure Topology

To create an Infrastructure Topology, follow these steps:

Navigate through Project > Manage Topology > Documents
Click .Create Infrastructure Topology
Drag a Group and Network and connect them.
Click  and provide a custom name 'TestPurposeTopo1.'Save
Validate whether the newly created Infrastructure Topology document is listed under .Documents

Creating Infrastructure Design

Every Infrastructure Topology document needs to bind with an Infrastructure Design document. To create anInfrastructure Design document,
follow these steps:

Navigate through Project > Manage Topology > Documents
Click .Create Infrastructure Design
In the Resource Binding section, provide the following values:

Name: a customer name or 'TestPurposeDesign1'
Infrastructure Topology: <Select from the drop-down> or 'TestPurposeTopo1'
ResourcePool: <Select from the drop-down> or 'AdminProjectRP'

Click , The Binding Details wizard displays.Next
Provide the following values under the Server Group section:

Minimum Instances: 1
Instance Name Prefix: test
Machine Flavor: m1.tiny or <Select a Flavor from the drop-down>
Machine Image: precise-server-cloudimg
Key Pair Name: testonlykeypair

Provide the following values under Network Segment section:
Name: TestNetwork1
Type: Cloud Edge Gateway <This will provide both Fixed and Floating IP to the VM instance>
Description: Test Purpose Only
Open Port List: 22,80
Click .Create Infrastructure Design
Validate whether the newly created Infrastructure Design document is listed under .Documents

Launching an Infrastructure Design Document

With both Design and Topology documents created, you will be able launch a Design document:

Navigate through Project > Manage Topology > Documents
Locate the newly created Infrastructure Design document and click .Launch
Provide a custom name 'TestInfrastrctureName1' and click .Launch

Validating the Infrastructure Document

Validation of the Infrastructure document is a multi-step process.

Validate the status of launched infrastructure in . Topologies
Navigate through Project > Manage Topology > Topologies.
Locate and check the  of the newly launched Infrastructure Document.State
Click the Topology Name to see details (specifically the Job tab). The State of a successfully provisioned document is 

.Succeeded
Go to the Content tab within Topology Detail to identify the IP Address allocated to the newly provisioned VM (search for
'ip_address_type').

Validate the accessibility through SSH:
You must have both Fixed and Floating IPs associated to the newly provisioned VM from the previous section. Try SSH through
both of the IPs (details above).
You can also locate this instance of the VM by navigating through Project > Manage Compute > Instances. Click the instance
name to see more details (details above).

Deploy CDA (Optional)
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Overview

CDA can be deployed on the Domain Controller if it meets the sizing requirements. Refer to the CDA Installation Guide for more details. However,
if it needs to be on separate node, follow the Deploy CDA Node section below. Or, follow these instructions for applying the CDA proposal:

Select the  tab.Compute Regions
Click .Deploy Compute Region
Enter crowbar/crowbar for the credentials.
The  displays. The Admin and Controller nodes display a green online status.Node Dashboard

Deploy CDA Node

Discover and Allocate CDA Node

The CDA node needs to be powered ON.
When the CDA node boots up, the Admin node automatically installs the OS using a PXE boot. The  displays the nodeNode Dashboard
as the OS is installed. The status indicator is initially grey.

The CDA node initially displays in the  with a generated, hexadecimal name.Node Dashboard
Tip: view the node's console to monitor the system as it is being installed.

Wait until the  shows the CDA node with a flashing yellow status.Node Dashboard
Tip: To confirm that the hexadecimal name is associated to the CDA node, view the CDA node's console. The hostname
displayed in the CDA node's console will match the hexadecimal name displayed in the .Node Dashboard

On the Cloud Installation Dashboard, select  >  .Nodes Bulk Edit
Click the  checkbox.Allocate?
Click  .Save
On the Cloud Installation Dashboard, select  >  .Nodes Dashboard
Wait for the CDA node's status to change from yellow to green. View the CDA node's console for installation progress.

If a dialog box displays a message asking you to load missing firmware, select NO.
When the CDA node's install has completed, the  displays the CDA node.Node Dashboard

Tip: the CDA node's login prompt displays the hexadecimal name displayed in the .Node Dashboard

Rename CDA Node

Follow these steps to rename the CDA node:

Select the CDA node's .hexadecimal name
Click  .Edit
Change the alias field from the hexadecimal name to a meaningful name.
Click  . Notice the CDA node's new name is reflected in the display and the   of the CDA node remains unchanged.Save Full Name

Apply CDA Proposal

Use the following steps to apply barclamps:

From the CDA node's detail page, select   .Barclamps > Cloud Infrastructure
The barclamps specific to Cloud Infrastructure display.
For the CDA barclamp, perform the following steps:

Select the .barclamp's name
Specify the  as the proposal.CDA node's name
Click .Create
Ensure the default values are correct for the proposal (see screenshot below).  The values must have:
PostgreSQL Instance: <ProposalThroughWhichPostgresApplied>
Admin Email Address: <an email address>
FQDN for Hostname: <MACAddressHostName>.cosmos.org
Domain Name: cosmos.org
Passphrase for LWSSO:<AnyParaPhraseKey>
Click   . Click  .Apply OK
Wait for the proposal status (displayed at the top left of the dialog box) to turn green.
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Accessing CDA Application

Now that the CDA application is configured, you can access it by launching a browser and connecting to https://<node name>:8443/cda.

For example: https://d00-50-56-a9-37-3b.cosmos.org:8443/cda

Default username/password = admin/changeit

You can refer to the HP CDA 1.1 User Guide for details on how to use CDA with this local cloud installation.

Next Step

If you plan to deploy CSA on the same node as CDA, refer CDA 1.1 Installation and Configuration Guide, Appendix C: Configuring HP CDA and
HP CSA to Run on the Same Server.

Go to .Deploy CSA (Optional)

Deploy CSA (Optional)

Overview

CSA can be deployed on the Domain Controller if it meets the sizing requirements. Refer to the CSA guide for more sizing details. However, if it
needs to be on separate node, follow Deploy CSA Node section. Or, follow these instructions for Applying CSA Proposal:
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Select the  tab.Compute Regions
Click the  button.Deploy Compute Region
Enter crowbar/crowbar for the credentials.
The  displays and the Admin and Controller nodes display a green online status.Node Dashboard

Deploy CSA Node

Discover and Allocate CSA Node

The CSA node needs to be powered ON.
When the CSA node boots up, the Admin node automatically installs the OS using a PXE boot. The  displays the nodeNode Dashboard
as the OS is installed. The status indicator is initially grey.

The CSA node initially displays in the  with a generated, hexadecimal name.Node Dashboard
Tip: view the node's console to monitor the system as it is being installed.

Wait until the  shows the CSA node with a flashing yellow status.Node Dashboard
Tip: To confirm that the hexadecimal name is associated to the CSA node, view the CSA node's console. The hostname
displayed in the CSA node's console will match the hexadecimal name displayed in the .Node Dashboard

On the Cloud Installation Dashboard, select  >  .Nodes Bulk Edit
Click the  checkbox.Allocate?
Click  .Save
On the Cloud Installation Dashboard, select  >  .Nodes Dashboard
Wait for the CSA node's status to change from yellow to green. View the CSA node's console for installation progress.

If a dialog box displays a message asking you to load missing firmware, select NO.
When the CSA node's install has completed, the  displays the CSA node.Node Dashboard

Tip: the CSA node's login prompt displays the hexadecimal name displayed in the .Node Dashboard

Rename CSA Node

Follow these steps to rename the CSA node:

Select the CSA node's .hexadecimal name
Click  .Edit
Change the alias field from the hexadecimal name to a meaningful name.
Click  . The CSA node's new name is reflected in the display, and the  of the CSA node remains unchanged.Save Full Name

Apply Barclamps to the CSA Node

Use the following steps to apply barclamps:

From the CSA node's detail page, select   .Barclamps > Cloud Infrastructure
The barclamps specific to Cloud Infrastructure display.
For the CSA barclamp, do the following steps:

Select the .barclamp's name
Specify the  as the proposal.CSA node's name
Click .Create
Verify that the default values are correct for the proposal (see screenshot below). You must set the FQDN information correctly
hostname: <MACAddressName>.cosmos.org
Click . Click  .Apply OK
Wait for the proposal status (displayed at the top left of the dialog) to turn green.
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Configure CDA and CSA Integration

To synchronize CDA and CSA:

Make sure the machines running CDA and CSA are able to connect to each other on the network and that name resolution is working.
On the node running CSA, log in using the default user name/password.
Switch to root user by running "sudo -i".
Enter ./tmp/postinstall.sh and then press <Enter>.
The postinstall.sh script contains:
------------------------
#!/bin/sh
export JAVA_HOME=/usr
export PATH=$PATH:$JAVA_HOME/bin
java -jar /opt/hp/csa/3.10/Tools/ProcessDefinitionTool/process-defn-tool.jar -d /var/hp/csa/conf/postgresdb.properties -p
/var/hp/csa/conf/cda.xml
------------------------

This script will synchronize CSA and CDA and configure them for use.

Accessing CSA Application

Now that the CSA application is configured, you can access it by launching a browser and connecting to https://<node name>:8444/csa for admin
portal and https://<node name>:8444/csp for consumer portal.

For example: https://d00-50-56-a9-37-3b.cosmos.org:8444/csa
For example: https://d00-50-56-a9-37-3b.cosmos.org:8444/csp

Default Admin Portal username/password = admin/cloud
Default Consumer Portal username/password = consumer/cloud

You can refer to HP CSA 3.10 User Guide for details on how to use CSA with CDA.
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Troubleshooting

Overview

Problem: An error message displays when configuring the Cloud prerequisites

Symptoms Completing the prerequisites fails.

Primary software component Cloud Infrastructure Dashboard

Failure message  There was an error submitting the form. Please try again.Error:

Probable cause
Ensure the Cloud Administration node has both a public and private network configured.

Ensure the proxy information is correct and references a working proxy server and port.

Solution

On the Cloud Administration node, view the log file, /var/log/apache2/error.log, for details.
Verify a public network is configured in the Cloud Administration node.
Redo the steps in the  section for .Configure Cloud Administrator Node Enable Cloud Administration node for Internet Access
Correct the proxy entries and/or specify a different proxy host and/or port.

Problem: A Cloud Infrastructure barclamp proposal fails

Symptoms An error message displays and the status turns red if a proposal fails.

Primary software component Cloud Infrastructure Dashboard

Failure message Failed to apply the proposal to: <Domain Controller node name>

Probable cause Any number of factors.

Solution

Try applying the proposal again. If that fails:
Deactivate the proposal
Delete the proposal and create it again

On the Cloud Administration node:
View the log file, /opt/dell/crowbar_framework/log/production.log and <MacAddressHostname>.chef.log, for details.
View the log file, /var/log/apache2/error.log, for details.
View the folder, /var/tmp/cosmos, for installer settings.

Problem: The Admin node displays the "not ready" (grey) state

Symptoms You may not be able to pxe boot any new node.

Primary software component Cloud Installation Administration Node

Failure message  

Probable cause Changing the date on the Admin node; or you brought up a previously allocated node to the new Admin node

Solution

Reboot the Admin node.
Whenever a new Admin node is installed, all the previous participating nodes must be kept off of PXE booted through the new admin
node. If you end up with this issue, a reinstall of the Admin node and its participating node is suggested.
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Problem: The Controller or Compute node displays the "not ready" (grey) state

Symptoms Dashboard is unable to monitor the Controller or Compute nodes.

Primary software component Cloud Installation Administration Node

Failure message  

Probable cause The Controller or Compute nodes have not updated the live status to Admin node.

Solution

Log into the suspect node through SSH and run sudo chef-client. This will force the node to updates its status with Chef.

Problem: When creating a new pxe node, the pxe boot fails with a TFTP timeout error

Symptoms Admin node takes a lot of time to reboot.

Primary software component Cloud Installation Administration Node

Failure message  

Probable cause This has been seen in a few cases after Admin node is rebooted.

Solution

Log into the Admin node and run the following commands and then PXE boot the nodes:
sudo bluepill tftpd stop
sudo bludpill tftpd start
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