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Welcome to the LoadRunner Tutorial
Welcome to the LoadRunner tutorial, a self-paced printable guide, designed to lead you through the
process of load testing and familiarize you with the LoadRunner testing environment.

l This lesson provides an introduction to LoadRunner and testing concepts.

l Lessons 1 through 4 describe how to develop a Vuser script using VuGen - the Virtual User
Generator.

l Lessons 5 and 6 explain how to design and run load tests using the LoadRunner Controller.

l Lesson 7 introduces the Analysis tool, showing you how to create graphs and reports which will
help you analyze your load test.

At the conclusion of this tutorial, you will be ready to design, run, andmonitor a simple load test on
your own system. It is recommended that you work through the tutorial in the order in which the
information is presented.

What are the LoadRunner components?
LoadRunner contains the following components:

l TheVirtual User Generator orVuGen captures end-user business processes and creates an
automated performance testing script, also known as a Vuser script.

l TheController organizes, drives, manages, andmonitors the load test.

l Analysis helps you view, dissect, and compare the results of the load tests.

l Load Generators, computers that run Vusers to generate a load on the system.
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Understanding the LoadRunner Terminology
l A scenario defines the events that occur during a testing session, based on performance

requirements.

l In a scenario, LoadRunner replaces human users with virtual users orVusers. Vusers emulate
the actions of human users working on your system. A scenario can contain tens, hundreds, or
even thousands of Vusers.

l The actions that a Vuser performs during a scenario are described in aVuser script.

l Tomeasure the performance of your system, you define transactions. A transaction represents
one or more end-user business processes. A transaction enables you tomeasure how long it
takes to perform these business processes.

l Each Vuser script is based on a protocol. A protocol is themethod of communication between a
client and the server.

l The script footprint of a Vuser script is defined by the quantities of the various resources that
are required on a load generator in order to execute the Vuser script. Typical resources include
memory, CPU power, and disk space.

What is the LoadRunner load testing process?
Load testing with LoadRunner typically consists of five phases: planning, script creation, scenario
definition, scenario execution, and results analysis.

1. Plan Load Test. Define your performance testing requirements, for example, number of
concurrent users, typical business processes, and required response times.

2. Create Vuser Scripts. Use VuGen to capture the end-user activities into automated scripts.

3. Define a Scenario. Use the Controller to set up the load test environment.

4. Run a Scenario. Use the Controller to drive, manage, andmonitor the load test.
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5. Analyze the Results. Use LoadRunner Analysis to create graphs and reports, and evaluate
the system performance.

Starting HP Web Tours
To illustrate LoadRunner as a solution for load testing, this tutorial uses performance requirements
for a sample application. The sample application, HPWeb Tours, is a web-based travel agency
system. HPWeb Tours users connect to a web server, search for flights, book flights, and check
flight itineraries.

While LoadRunner supports over 50 types of applications, this tutorial demonstrates how to load
test aWeb-based application. If you are load testing applications that are not Web-based, please
contact HP for assistance.

In this section of the tutorial, you will learn how to start and log on toHPWeb Tours.

1. Start the sampleWeb server.

Select Start > All Programs > HP Software > HP LoadRunner > Samples > Web > Start
Web Server.

The Start Web Server dialog box opens. Keep this dialog box open while you access theWeb
Tours application.

2. Open HPWeb Tours.

Select Start > All Programs > HP Software > HP LoadRunner > Samples > Web > HP
Web Tours Application. A browser opens and displays theHPWeb Tours home page.

Ensure that LoadRunner is installed in the default folder on your computer. If LoadRunner
is installed in a non-default folder, the HPWeb Tours application will not open.

The HPWeb Tours application requires a browser with Java installed. For more
information, refer to the relevant Java documentation.

3. Log on to HPWeb Tours.
a. Type in the following information:

- User name: jojo

- Password: bean

b. On the left pane, click Login. HP Web Tours welcomes you to the application.

4. Reserve a flight.
a. On the left pane click Flights. The Find Flight page opens.

b. Change theArrival city to Los Angeles.

c. Click Continue.

d. In the Find Flight page, accept the default flight selection and click Continue.

e. In the Payment Details page, click Continue. The Invoice page is displayed, summarizing
your flight reservation.

HP LoadRunner (Service Pack 11.51)Page 6 of 96

Tutorial
HP LoadRunner Tutorial



5. End your HPWeb Tours session.

On the left pane, click Sign Off to log off.

Defining the Application Performance
Requirements

Now that you are familiar with HPWeb Tours, imagine that you are the performance engineer
responsible for signing off that HP Web Tours meets the needs of your business. Your project
manager has given you 4 criteria for release:

1. HP Web Tours must successfully handle 10 concurrent travel agents.

2. HP Web Tours must be able to process 10 simultaneous flight bookings with response time not
exceeding 90 seconds.

3. HP Web Tours must be able to handle 10 travel agents running simultaneous itinerary checks
with response time not exceeding 120 seconds.

4. HP Web Tours must be able to handle 10 agents signing in and signing out of the system with
response time not exceeding 10 seconds.

This tutorial will walk you through the process of building load tests that validate each business
requirement so that you can attach a pass or fail before release.

Where To Go From Here
Now that you has been introduced to the LoadRunner basics, you can proceed to "Lesson 1:
Building a Vuser Script" on page 8.
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Lesson 1: Building a Vuser Script
To generate a load on your system, you first build a Vuser script that you can run to emulate real
user behavior. You use VuGen to create Vuser scripts.

In this lesson you will cover the following topics:

l Introducing VuGen – the Virtual User Generator

l Creating a Blank Vuser Script

l Recording into a Vuser Script

l Viewing a Vuser script

Introducing VuGen – the Virtual User
Generator

In a performance testing environment, LoadRunner replaces human users with virtual users, also
known as Vusers. Vusers generate a load on a system by emulating actions of typical users - in a
repeatable and predictable manner.

You use VuGen (LoadRunner's Virtual User Generator) to create Vuser scripts. VuGenworks on a
record-and-playback principle. As you walk through a business process on your application, VuGen
records your actions and converts these actions into Vuser scripts. These Vuser scripts form the
foundation of your load tests.

Creating a Blank Vuser Script
To develop a Vuser script, you first open VuGen and create a blank script. Thereafter, you can
enhance the blank script by recording events and addingmanual enhancements to the script.

In this section, you will open VuGen and create a blank Vuser script that is based on theWeb -
HTTP/HTML protocol.

A protocol is themethod of communication between a client and the server.

To create a blank Vuser script:
1. Click Start > All Programs > HP Software > HP LoadRunner > VuGen or double-click the

Virtual User Generator shortcut icon on your desktop.

The HP Virtual User Generator [VuGen] opens.
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2. Click File > New Script and Solution or click theNew Script button on the VuGen
toolbar. The Create a New Script dialog box opens.

3. Make sure theCategory is Single Protocol. VuGen displays a list of the protocols that are
available for a single-protocol script.

4. From the list of available protocols, selectWeb - HTTP/HTML and then click Create. VuGen
creates a blank Vuser script and displays the script in the VuGen Editor.
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Note that to enable VuGen to record theWeb Tours applications, youmust click Record >
Recording Options. In the Recording Options dialog box, select General > Script, and then
underScripting Options, clear the Track processes created as COM local servers check
box.

Recording into a Vuser script
The next step in creating user emulation is recording the events performed by a real user. In the
previous section, you created an empty Web Vuser script. Now you can begin to record events
directly into the script. In this section, you will track the events while a travel agent reserves a flight
from Denver to Los Angeles and then checks the flight itinerary.

To record the Vuser script:

1. Start recording on the HPWeb Tours Web site.

a. Click Record > Record or click theRecord button on the VuGen toolbar. The Start
Recording dialog box opens.

b. In theRecord into action box, select Action.

c. From Application type, selectWeb.

d. In theURL address box, type http://localhost:1080/WebTours.

e. Click Start Recording. A new web browser opens and displays the HPWeb Tours site.
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Note that If there is an error opening the site, make sure that theWeb server is
running. To start the server select Start > All Programs > HP Software > HP
LoadRunner > Samples > Web > Start Web Server.

VuGen's floating Recording toolbar opens.

2. Log on to the HPWeb Tours Web site.

a. Type in the following information:

- User name: jojo

- Password: bean

b. On the left pane, click Login. HP Web Tours welcomes you to the application.

3. Enter the flight details.

a. Click Flights. The Find Flight page opens.

b. From Departure City, select Denver (default).

c. Departure Date: Keep the default, current date.

d. From Arrival City, select Los Angeles.

e. Return Date: Keep the default, tomorrow’s date.

f. From Seating Preference, select Aisle.

g. Keep the rest of the default settings and click Continue. The Search Results page opens.
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4. Select a flight.

Click Continue to accept the default flight selections. The Payment Details page opens.

5. Enter payment information and book the flight.

a. In theCredit Card box, enter 12345678.

b. In theExp Date box, enter 06/12.

c. Click Continue. The Invoice page opens, displaying your invoice.

6. In the left pane, click Itinerary. The Itinerary page opens.

7. In the left pane, click Sign Off.

8. Close the browser, and then click theStop Recording button on the VuGen floating
toolbar to stop the recording process.

VuGen generates the required code and inserts the code into the Vuser script.

If the Design Studio opens, click Close to close the Design Studio.

9. Save the Vuser script.
a. Select File > Save Script As.

b. Navigate to <LoadRunner Installation>\tutorial and create a new folder namedScripts.

c. In the File name box, type basic_tutorial.

d. Click Save. VuGen saves the script in the LoadRunner script folder and displays the script
name in the VuGen title bar.

Viewing the Vuser script
You have now recorded a travel agent logging in, booking a flight, checking the itinerary, and logging
off. VuGen recorded your steps from themoment you clicked theStart Recording button to the
moment you clicked theStop Recording button.

You can now use VuGen to view the script. VuGen lets you see the Vuser script in a number of
formats:

l TheSolution Explorer gives you structured access to the various parts of a Vuser script, as
well as to a number of files that are associated with the Vuser script.
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l TheStep Navigator displays an icon-based view of the script that lists the actions of the Vuser
as steps. For each action you performed during recording, VuGen generated a corresponding
step in the Step Navigator.
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The Step Navigator displays a snapshot icon to indicate that a specific step contains a
snapshot.

To view the script in Step Navigator, select View > Step Navigator, or click theStep

Navigator button on the VuGen toolbar. Double-click any step in the Step Navigator to
display the corresponding function in the Editor.

l The VuGenEditor displays a text-based view of the script. In the Editor, the actions of the
Vuser are listed as API functions. In the Editor, VuGen uses color-coding to show the functions
and their argument values in the script. You can type C or LoadRunner API functions, as well as
control flow statements, directly into the script.
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Where To Go From Here
Now that you are familiar with recording and viewing a basic Vuser script, you can proceed to
"Lesson 2: Replaying Your Script" on page 16.
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Lesson 2: Replaying Your Script
In the previous lesson, you recorded a set of typical user actions, and VuGen transcribed these
actions in to a Vuser script. You can now replay your recorded script to verify that the script runs
properly, before you incorporate the script into a load testing scenario.

Before replaying the script, youmust configure run-time settings, which define the behavior of the
Vuser.

In this lesson you will cover the following topics:

l How do I set the run-time behavior?

l How do I runmy Vuser script?

l Where can I view information about the replay?

l How do I know if my script replayed successfully?

l How do I search or filter the results?

How do I set the Vuser's run-time behavior?
LoadRunner run-time settings let you emulate different kinds of user activity and behavior. For
example, you could emulate a user who responds immediately to output from the server, or a user
who stops and thinks before each response. You can also configure run-time settings to specify
how many times the Vuser should repeat a set of actions in the Vuser script.

There are general run-time settings, and settings that are specific to certain Vuser protocols only.
For example, for aWeb emulation, you could instruct your Vusers to replay your script in Firefox,
Chrome, or Internet Explorer. Run-time settings for specific protocols will be covered in "Lesson 4:
Preparing a Vuser Script for Load Testing" on page 30. This lesson describes some of the general
run-time settings - settings that apply to all types of scripts. The general run-time settings include:

l Run Logic. The number of times that a Vuser will repeat various sections of the Vuser script.

l Pacing. The time to wait between repetitions.

l Think Time. The time the user stops to think between steps in the script.

l Log. The level of information that you want to gather during playback.

Note that this lesson describes how to useVuGen to modify the run-time settings. A later
lesson describes how to use the LoadRunner Controller to modify the run-time settings.

To set the run-time settings:
1. Open the Vuser script that your saved in the previous lesson.

2. Open the Run-Time Settings dialog box.

Click Replay > Run-Time Settings. The Run-time Settings dialog box opens.
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3. Set the Run Logic settings.

In the left pane, underGeneral, click Run Logic.

The Run Logic settings enable you to set the number of iterations for the Vuser script. This is
the number of times to repeat the Action section of the Vuser script when the script is replayed.

Set theNumber of iterations to 2.

4. Set the Pacing settings.

In the left pane, underGeneral, click Pacing.
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The Pacing settings enable you to control the time between iterations. You will specify a
random time. This accurately emulates a real-life setting where the user waits between
actions, but at random intervals—you do not see real users always waiting exactly 60 seconds
between repetitions.

Select the third radio button, and select the following:

At random intervals, every 60.000 to 90.000 seconds.

5. Set the Log settings.

In the left pane, underGeneral, click Log.

The Log settings indicate how much information to log while running the Vuser Script. While
developing a Vuser script, youmay select to enable some logging for debugging purposes, but
once you verify that your script is functional, you can enable logging for errors only, or disable
it.

Select Extended log and enableParameter substitution. This option will be relevant for the
following lesson at which point it will be discussed.

6. View the Think Time settings.

In the left pane, underGeneral, click Think Time.
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Keep the default think time - Ignore think time. You will set the think time from the Controller.
Keep inmind that when you run the script in VuGen, it will run quickly since it will not include
think time.

7. Click OK to close the Run-Time Settings dialog box.

How do I run my Vuser Script?
After recording the Vuser script and setting the run-time settings, you are ready to run the script.
VuGen provides a number of indicators that your script is running.

1. Themessage "Running" appears in the lower left corner of VuGen.

2. A yellow marker appears in the Editor and indicates the specific line that is being replayed.
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3. TheOutput pane displays messages as the replay progresses.

To run a Vuser script:

1. Open the Vuser script in VuGen.

2. Click Replay > Run or click theReplay button on the VuGen toolbar.

After the replay ends, amessage box may prompt you to scan for correlations. Click No.

Where can I view information about the
replay?

When the Vuser script stops running, you can view a summary of the replay. The replay summary
is displayed in theReplay Summary tab.
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The Replay Summary tab lists basic information about the script run, such as the duration of the
replay, and the start and end times of the replay. In addition, the Replay Summary tab provides you
with a link that display a log of the script events, and another link that displays detailed results of
the script run.

The Replay log - a log of the events that occurred during the replay of the script - is displayed in
VuGen’s Output pane. TheOutput pane uses color-coding to display a textual summary of the
events that occurred during the replay.

In this section of the tutorial, you will open the Replay log and locate specific events and
notifications within the log.

To view the Replay log:

1. After replaying a Vuser script, click View > Output or click theOutput button on the
VuGen toolbar. Alternatively, click theReplay Log link in the Replay Summary tab.

2. Make sure that Replay is selected in the Output pane.
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3. From the VuGenmenu, click Search > Quick Find to open the Search dialog box.

4. Click Include in search, and then select the Logs check box.

5. Use the Search dialog box to locate the following items:
a. Virtual User Script Started - the beginning of the script run.

b. Vuser Terminated - the end of the script run.

c. iteration - the beginning and the end of the iteration and the iteration number. (This text
appears in orange lettering.)

Note that the Output pane displays successful steps in green and errors in red. For
example, if the Vuser was unable to connect to the server, the Output pane would
display the error text in red, and indicate the line number in the script where the error
occurred.
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Note that if you double-click a line in the Output pane, VuGen indicates the
corresponding step in the script in the VuGen Editor.

How do I know if my script replayed
successfully?

After you playback the events that you recorded, you need to look at the results and see if the script
replayed successfully. If something failed, you want to know when and why it failed.

In this section you will view and analyze the results of your script run. VuGen summarizes the
results of the replay in the Test Results window.

When the Test Results window first opens, it contains two panes: Tree pane (on the left) and
Summary pane (on the right).

l The Tree pane contains the results tree. Each iteration is numbered.

l TheSummary pane contains the details of the script replay, as well as screen recorder movies,
if any. The top table indicates which iterations passed and which failed. The test is considered to
have passed when the Vuser successfully navigates through the HPWeb Tours site according
to the original recording. The bottom table indicates whether transactions and checkpoints
passed or failed. You will add these features to your test later on in the tutorial.

To view replay results:

1. Click theReplay Summary tab.

2. Click Replay > Test Results. The Test Results window opens and displays a summary of the
replay results.
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In the next section, you will drill down into the replay results to determine if the script reached the
intendedWeb pages during replay.

How do I search or filter the replay results?
If your replay results indicate that something failed, you can drill down and locate the point of failure.

In the Tree pane of the Test Results window, you can expand the test tree and view the results of
each step separately. The Summary pane shows a snapshot of the replay during that iteration.

1. Expand an iteration node in the tree.
a. In the results tree, expand the basic_tutorial Iteration 1 node.

b. Expand theAction Summary node. The expanded node shows a list of the steps
performed in that iteration.

2. View a result snapshot.

Click theSubmit Form:login.pl node. The Summary pane displays the replay snapshot
associated with that step.

3. View the step summary.

The Summary pane displays the step summary information: the object or step name, the
details about whether the page loaded successfully, the result (Passed, Failed, Done, or
Warning), and the time that the step was performed.

4. Search for a result status.

You can search the replay results for the words Passed or Failed.

This is helpful, as in a case where the overall Results Summary indicates that the replay failed,
you can determine where it failed.

a. To search the replay results, select Tools > Find or click the Find button on the Test
Results toolbar. The Find dialog box opens.

b. Select thePassed check box, make sure no other options are selected, and click Find
Next. The Test Tree pane highlights the first step in which the status is Passed.

Note that if no steps of the selected status can be found, no step is highlighted.

5. Filter the results.
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You can filter the Test Tree pane to display a specific iteration or status. For example, you can
filter it to show only Failed status.

a. Select View > Filters or click the Filters button on the Test Results toolbar. The
Filters dialog box opens.

b. UnderStatus, select Fail and clear all the other options.

c. UnderContent, select All and click OK. The left pane becomes empty, since there were
no failures.

6. Close the Test Results window.

Click File > Exit.

Where To Go From Here
You have successfully replayed your Vuser script that emulates a user operating theHPWeb
Tours application. You can now proceed to "Lesson 3: Solving CommonReplay Problems" on page
26.
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Lesson 3: Solving Common Replay
Problems

After you create a Vuser script, you validate it by running it from VuGen. Sometimes a replay will
fail, even though the recording of the same actions succeeded.

Many applications use dynamic values that change each time you use the application. For
example, some servers assign a unique session ID for every new session. When you try to replay a
recorded session, the application creates a new session ID that differs from the recorded session
ID. Dynamic values, such as these unique session IDs, may pose difficulties when you replay
Vuser scripts based on certain Vuser script protocols. For example, dynamic session IDs often
pose problems when replayingWeb-HTTP/HTML scripts, but not when replayingWeb-TruClient
scripts.

LoadRunner use correlation to address the issue of dynamic values. Correlation saves the
changing values, in our case the session ID, to a parameter. When running the Vuser script, the
Vuser does not use the recorded value—instead, it uses the new session ID, assigned to it by the
server.

In this lesson you will observe how LoadRunner automatically solves the issue of dynamic values
when runningWeb-HTTP/HTMLVuser scripts.

In this lesson you will cover the following topics:

l Preparing HPWeb tours for replay errors

l How do I work with unique server values?

Preparing HP Web tours for replay errors
To illustrate a common replay failure, you need tomodify a setting in theHPWeb Tours application.
This setting tells theHPWeb Tours server to issue and require unique session IDs.

1. Open HPWeb Tours.

Select Start > All Programs > HP Software > HP LoadRunner > Samples > Web > HP
Web Tours Application. A browser opens with theHPWeb Tours home page.

2. Change the server options.
a. Click the administration link on the HPWeb Tours home page. The Administration Page

opens.

b. Select theSet LOGIN form's action tag to an error page checkbox. This setting tells
the server not to allow duplicate session IDs.

c. Scroll down to the bottom of the page and click Update.

d. Scroll down to the bottom of the page and click theReturn to the Web Tours Homepage
link.
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How do I work with unique server values?
In themodified configuration of HP Web Tours, the server assigns a unique session ID to each
Vuser. If you try to replay the unmodified Vuser script that you recorded in "Lesson 1: Building a
Vuser Script" on page 8, the replay will fail.

To overcome this issue, you use VuGen to detect the need to correlate the session ID. You will
instruct VuGen to insert a step that saves the original session ID to a parameter. In each
subsequent replay session, VuGen saves the new unique session ID to a parameter. As the Vuser
executes the steps in the Vuser script, the Vuser uses the saved ID value instead of the originally
recorded value.

1. Record a new Vuser script with dynamic values.
a. Record a new Vuser script with the same steps that you recorded previously in "Lesson 1:

Building a Vuser Script" on page 8.

b. Save the script as basic_tutorial_Cor.

2. Replay the new script.

Click Replay > Run or click theReplay button on the VuGen toolbar.

VuGen runs the new Vuser script. Youmay notice several error messages in the Replay Log in
the Output pane, indicated by the red-colored text.

After the replay ends, amessage box may prompt you to scan for correlations. Click No.

3. View the Replay Summary.

Look at the Replay Summary tab. The summary shows that the replay of your script failed.

4. Scan the script for correlations.

In the Replay Summary tab, click theCorrelation Studio link. The Design Studio opens.
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VuGen scans the script and its associated data, searching for differences between the
recorded values and the replay values. The Correlation tab of the Design Studio displays a list
of differences that may require correlation.

5. Correlate the Session ID.
a. Select the second entry in the Correlation tab, and click Correlate. VuGen inserts a new

function at the top of the Vuser script. The new function saves the original session ID to a
parameter.

In each subsequent replay session, VuGen saves the new unique session ID to a
parameter. When the Vuser runs, the Vuser uses the saved ID value instead of the
originally recorded value.

b. Click Close to close the Design Studio.

6. Examine the syntax of the correlation statement.

In the VuGen Editor, locate the statement that VuGen added to the script. The new statement
looks similar to the following:

web_reg_save_param_regexp(
"ParamName=CorrelationParameter",
"RegExp=userSession\\ value=(.*?)>\\n<table\\ border",
"SEARCH_FILTERS",
"Scope=Body",
"IgnoreRedirections=No",
"RequestUrl=*/nav.pl*",
LAST);

The statement instructs VuGen to save the first occurrence of the value contained in the
regular expression (the unique session ID) to a parameter called CorrelationParameter.
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7. Play the script again.
a. Click Replay > Run or click theReplay button on the VuGen toolbar to replay the script

again. When the replay ends, look in the Replay Log in the Output pane. Notice that VuGen
no longer issues the red-colored error messages.

b. In the script, right-click web_reg_save_param_regexp and select Go to step in Replay
Log. VuGen places the cursor at the corresponding line in the Replay log. The log indicates
that functionweb_reg_save_param_regexp succeeded, indicating that the correlation
worked successfully.

8. Reset the HPWeb Tours server to ignore unique session IDs.

a. Click Start > All Programs > HP LoadRunner > Samples > Web > HP Web Tours
Application to open HPWeb Tours.

b. On the HPWeb Tours home page, click the administration link.

c. In theAdministration Page, clear theSet LOGIN form's action tag to an error page
check box.

d. Scroll down to the bottom of the page and click Update.

Where To Go From Here
Now that you are familiar with some of the common replay problems, you can proceed to "Lesson 4:
Preparing a Vuser Script for Load Testing" on page 30.
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Lesson 4: Preparing a Vuser Script for
Load Testing

In the previous lessons, you verified that the replay of your Vuser script produced an accurate
emulation of a real user. The next step is to prepare the script for load testing. How will the system
work with many users working simultaneously?Will the system slow down to an unacceptable
level?

In this lesson you will learn about different methods to enhance the script and tomake it more
effective for the load testing process.

In this lesson you will cover the following topics:

l How do I measure the duration of a business process?

l How do I emulatemultiple users?

l How do I verify Web page content?

l How can I produce debugging information?

l Did the replay of my test succeed?

How do I measure the duration of a business
process?

When preparing an application for deployment, you need tomeasure the duration of specific
business processes—how long does it take to log on, book a flight, and so on. Each business
process is normally made up of one or more steps or actions in your script. In a Vuser script, you
designate a series of actions you want to measure by including these actions in a transaction.

When you run a Vuser script that includes a transaction, LoadRunner gathers information about the
time it takes to perform the transaction, and displays the results in color-coded graphs and reports.
You use this information to help determine if the applicationmeets the performance requirements.

You canmanually insert a transaction anywhere in a Vuser script. Tomark a set of steps as a
transaction, insert a start_transactionmarker before the first step and an end_transactionmarker
after the last step.

In this section you will insert a transaction into your script to measure the amount of time it takes for
the user to find and confirm a flight.

To insert a transaction into a Vuser script:

1. In VuGen, open theBasic_Tutorial script which you created in "Lesson 1: Building a Vuser
Script" on page 8. If it is still open, you can select the tab displaying its name. Otherwise you
can open it from the Filemenu.

2. Click theStep Navigator tab to display the Step Navigator.
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3. Insert a start transactionmarker.
a. In the Step Navigator, locate the step Image: Search Flights Button.

b. Double-click the Image: Search Flights Button step to display the correspondingweb_
image step in the Editor.

c. Click View >Steps Toolbox. The steps Toolbox appears in the right pane.

d. In the Steps Toolbox, underCommon, select lr_start_transaction, drag it into the Editor,
and release it before theweb_image step. The Start Transaction dialog box opens.

e. In the Transaction Name box, enter find_confirm_flight and click OK. VuGen inserts an
lr_start_transaction step in the Step Navigator, and a corresponding lr_start_
transaction function in the Editor.

4. Insert an end transactionmarker.
a. In the Step Navigator, locate the stepSubmit Form: reservations.pl_2.

b. Double-click theSubmit Form: reservations.pl_2 step to display the corresponding
web_submit_form step in the Editor.

c. In the Steps Toolbox, underCommon, select lr_end_transaction, drag it into the Editor,
and release it after theweb_submit_form step. The End Transaction dialog box opens.

d. Make sure that find_confirm_flight appears in the Transaction Name box, and then click
OK. VuGen inserts an lr_end_transaction step in the Step Navigator, and a corresponding
lr_end_transaction function in the Editor.
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You have now defined the find_confirm_flight transaction.

How do I emulate multiple users?
In your emulation, you tracked a user booking a flight and choosing an aisle seat. In a real-life
setting, however, different users will have varying preferences. To improve your test, you need to
check if the booking will work when users select different seating preferences (Aisle,Window, or
None).

To accomplish this, you will parameterize the script. This means that you take the recorded value,
Aisle, and replace it with a parameter. You will place values for the parameter in a parameter file.
When you run the script, the Vuser will take values from the parameter file (Aisle,Window, or
None) thereby emulating a true travel agency environment.

To parameterize your script:

1. Find the section where you want to vary the data.
a. Select View > Step Navigator to show the Step Navigator in the left pane.

b. In the Step Navigator, locate theSubmit Data: reservations.pl step.

c. Right-click theSubmit Data: reservations.pl step and select Show Arguments. The
Submit Data Step Properties dialog box opens.
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The ABC icon to the right of each argument in the grid indicates that the argument has a
fixed value.

2. Change the fixed value to a varying value.
a. In the Submit Data Step Properties dialog box, select seatPref in the seventh row of the

grid.

b. Click theABC icon adjacent to the seatPref argument. The Select or Create Parameter
dialog box opens.
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3. Create a parameter.
a. In theParameter name box, type seat.

b. Click OK. In the Submit Data Step Properties dialog box, VuGen replaces theABC icon
with aParameter icon .

c. Click theParameter icon adjacent to {seat} and select Parameter Properties. The
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Parameter Properties dialog box opens.

4. Specify values for the parameter.
a. Click Add Row. VuGen adds a row to the table.

b. Replace the wordValuewithWindow.

c. Click Add Row. VuGen adds another row to the table.

d. Replace the wordValuewithNone.
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Note that the values are not case sensitive.

e. Keep the default settings in theSelect column and File format sections of the dialog box.

5. Define how the test will vary the data.
a. Keep the default setting that instructs VuGen to take a new value for each iteration:

Update value on: Each iteration.

b. Click Close to close the Parameter Properties dialog box.

c. Click OK to close the Step Properties dialog box.

You have now created a parameter for the seating preference. When you run the load test,
the Vusers will use the parameter values instead of the recorded value, Aisle.

When you run the script, the Replay log will show the parameter substitution that occurs for
each iteration. The Vuser will useAisle for the first iteration,Window for the second
iteration, andNone for the third iteration.

How do I verify Web page content?
When running a test, you often need to verify if certain content is found on a returned page. A
content check verifies that expected information appears on a web page while the script is running.
You can insert two types of content checks:

l Text check. Checks that a text string appears on a web page.

l Image check. Checks for an image on a web page.

In this section, you will insert a text check that checks if the phrase Find Flight appears on the
Reservations page of HPWeb Tours.

Inserting a text check
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1. Click theStep Navigator tab to display the Step Navigator.

2.  In the Step Navigator, locate theSubmit Data: reservations.pl step.

3.  Click theSnapshot button on the VuGen toolbar to display the Snapshot pane.

4. In the Step Navigator, double-click the snapshot icon in theSubmit Data: reservations.pl
step. The corresponding snapshot appears in the Snapshot pane.

5. On the Snapshot pane toolbar, click Page View.

6. In the snapshot, select the words Find Flight, right-click and select Add Text Check Step.

The Find Text dialog box opens displaying the text you selected, Find Flight.

7. In the Find Text dialog box, click OK.

VuGen inserts aweb_reg_find step into the Step Navigator and a correspondingweb_reg_
find function into the Editor.
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When you replay the script, VuGenwill look for the text Find Flight and indicate in the Replay
log whether or not the text was found.

How can I produce debugging information?
At certain points during a test run, youmay want to generate and sendmessages that contain
information relating to the script execution. These output messages will appear in both the Replay
log in the Output pane, and in the Controller’s Output window. You can send a standard output
message or amessage that indicates that an error occurred.

The recommended way to work with error messages is to check for a Failed status. If the status is
Failed, you instruct VuGen to issue an error message. For details, refer to the examples in the HP
LoadRunner Function Reference.

In this section of the tutorial, you will instruct VuGen to insert an output message after the
application completes a full booking.

To insert an output message:

1. Click theStep Navigator tab to display the Step Navigator.

2. In the Step Navigator, locate the last step, Image: SignOff Button.

3. Double-click the Image: SignOff Button step. The Editor displays the correspondingweb_
image function.

4. In the Steps Toolbox, underCommon, locate the lr_output_message function.
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5. Select the lr_output_message function, drag it to the Editor, and release it after theweb_
image function. TheOutput Message dialog box opens.

6. In theMessage Text box, type The flight was booked.

7. Click OK. VuGen adds an lr_output_message to the script, and a corresponding step in the
Step Navigator.

8. Click theSave button on the VuGen toolbar to save the script.

Note that to insert an error message you would repeat the same process, except that in the
Steps Toolbox, you would select an lr_error_message function instead of the lr_output_
message function.

Did the replay of my test succeed?
In this section, you will run the enhanced script and search the Replay log for text checks. You will
view the results of the text checks, as well as details of the transactions and parameterization.

By default, image checks are disabled during playback since they require morememory. If you
want to perform an image check, you need to enable checks in the run-time settings.

1. Enable image checks.
a. Click Replay > Run-Time Settings to open the Run-Time Settings dialog box.

b. UnderGeneral, click Internet Protocol > Preferences.

c. Select Enable image and text check.

d. Click OK to close the Run-Time Settings dialog box.
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2. Run the script.

Click Replay on the VuGen toolbar. VuGen begins running the script, generating entries in the
Replay log in the Output pane.

Wait for the script to finish running.

3. Locate the text check.
a. Click the Output pane, and select Replay.

b. Click in the Replay log, and then press Ctrl+F to open the Find dialog box.

c. Search forweb_reg_find. The first instance says as follows:

Registering web_reg_find was successful.

This is not the actual text check—it only prepares VuGen to check for the text after the
form submission.

d. Search again (F3) for the next instance of web_reg_find. This instance indicates:

Registered web_reg_find successful for “Text=Find Flight” (count=1).

This verifies that the text was found. If someone changes theWeb page and removes the
phrase Find Flight, then in subsequent runs, the output will indicate that the text was not
found.

4. Locate the beginning of a transaction.
a. In the Replay log, press Ctrl+F to open the Find dialog box.

b. Search for the word Transaction. This notification is shown in blue.

5. View the parameter substitution.
a. In the Replay log, press Ctrl+F to open the Find dialog box.

b. Search for the wordParameter. The log contains a notification “seat” = “Aisle”.

c. Search again (F3) for the next substitution. Note how VuGen takes a different value for
each iteration.

6. Select File > Save or click theSave button on the VuGen toolbar.

Where To Go From Here
Now that you have created a script and adapted it for load testing, you can proceed to "Lesson 5:
Creating a Load Testing Scenario" on page 42.
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Lesson 5: Creating a Load Testing
Scenario

In the previous lesson, you used VuGen to validate your Vuser script. In this lesson, you will
evaluate your system under the load of multiple Vusers. You will emulate the actions of ten travel
agents concurrently using the flight reservation system, and observe the behavior of the system
under the load of these users. To design and run this test, you use the LoadRunner Controller.

Scenario Objectives

In this lesson, the objective is to create a scenario that emulates the behavior of ten travel agents
simultaneously logging on, searching flights, purchasing flights, checking itineraries, and logging
off.

In this lesson you will cover the following topics:

l Introducing the LoadRunner Controller

l How do I start the Controller?

l The Controller at a glance

l How do I modify the script details?

l How do I generate a load on the system?

l How do I emulate real load behavior?

l How do I emulate different types of users?

l How do I monitor the system under load?

Introducing the LoadRunner Controller
Load testingmeans testing your system under typical working conditions. For example, youmay
test the system while many travel agents simultaneously reserve flights on the same flight
reservation system.

You design the test to emulate real-life situations. To do this, you need to be able to generate a load
on an application and schedule when the load is applied (because users do not log on and off the
system at precisely the same time). You also need to emulate different types of user activity and
behavior. For example, some users may use Firefox to access the system, whereas other users
use Internet Explorer. Users may also employ different network connections to access the system,
such as modem, DSL, or cable. You create and save these settings in a scenario.

The Controller provides you with all the tools you need to help you build and run tests to accurately
emulate your working environment.

How do I start the Controller?
To begin developing a scenario, you open the LoadRunner Controller.
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1. Open the HP LoadRunner Controller.

Select Start > All Programs > HP Software > HP LoadRunner > Controller, or click the
Controller shortcut icon on your desktop.

The HP LoadRunner Controller opens and displays the New Scenario dialog box.

2. Select a scenario type.

There are two scenario types:

A Manual Scenario gives you control over the number of running Vusers and the times at
which they run, and lets you test how many Vusers your application can run simultaneously.
You can use PercentageMode to distribute the total number of Vusers between the scripts
based on a percentage specified by your business analyst. The PercentageMode check box is
selected by default the first time you start LoadRunner following installation. If it is selected,
clear it.

A Goal-Oriented Scenario is used to determine if your system can achieve a particular goal.
You determine the goal based on, for example, a specified transaction response time or
number of hits/transactions per second, and LoadRunner automatically builds a scenario for
you based on these goals.

n Click Manual Scenario.

3. Add a Vuser script to the load test.
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In this tutorial, you will use only one Vuser script to model a single group of users performing
identical actions. Tomore accurately emulate a real-world scenario with more versatile user
profiles, you would create a number of different Vuser groups, with each group running several
scripts with different user settings.

The script that you previously recorded in VuGen contains the business processes that you
want to test. They include logging on, searching for a flight, buying a ticket, checking the flight
itinerary, and then logging off the site. You will add a similar script to the scenario, and
configure the scenario to emulate eight travel agents simultaneously performing these actions
on the flight reservation system. You will add twomore Vusers during the test.

For this purpose, a sample script is provided that is similar to the one you created. We
recommend that you use the sample script.

a. In the New Scenario dialog box, click theBrowse button.

b. Locate and select basic_script in the <LoadRunner Installation>\Tutorial folder.

c. Click Open.

The basic_script script title is displayed in both theAvailable Scripts pane and the
Scripts in Scenario pane of the New Scenario dialog box.

d. Click OK. The LoadRunner Controller opens and displays theDesign tab of your new
scenario.

Note that the control for the Design tab is in the lower left corner of the Controller.

The Controller at a glance
The Design tab of the Controller is themain interface for designing your load test. The Design tab is
divided into three panes:
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1. Scenario Groups pane

2. Service Level Agreement pane

3. Scenario Schedule pane

1. Scenario Groups pane. You configure the Vuser groups in the Scenario Scripts pane. You
create different groups to represent typical users of your system and specify the number of
Vusers that will run, and themachine that they will run on.

2. Service Level Agreement pane.When you design a load test scenario, you can define goals
or SLAs (Service Level Agreements) for the performancemetrics. When you run the scenario,
LoadRunner gathers and stores performance-related data. When you analyze the run, Analysis
compares this data against the SLAs and determines SLA statuses for the defined
measurements.

3. Scenario Schedule pane. In the Scenario Schedule pane, you set the load behavior to
accurately portray real-world user behavior. You define actions according to which the Vusers
will run, the rates at which load is applied to the application, the load test duration, and how the
load is terminated.

How do I modify the script details?
Youmodify the script details as follows:

1. Check to see that basic_script appears in theGroup Name column of theScenario Groups
pane.
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2. Change theGroup Name.

a. In theScenario Groups pane, select basic_script and click theDetails button. The
Group Information dialog box opens.

b. In theGroup Name box, enter amoremeaningful name, for example travel_agent.

c. Click OK. The new name is displayed in theScenario Groups pane of theDesign tab.

How do I generate a load on the system?
After you have added your Vuser scripts to the scenario, you configure the load generators, the
computers that generate the load on the system.

A load generator is a computer that runs multiple Vusers in order to generate a load on the
system. You can use a number of load generators, each generator hostingmultiple Vusers.

In this section, you will learn about adding load generators to the scenario, and testing the load
generator connections.

1. Add a load generator.

Click the Load Generators button on the Controller toolbar. The LoadGenerators dialog
box opens.
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The LoadGenerators dialog box enables you to view and configure the load generators that are
defined in the scenario. The LoadGenerators dialog box shows details for the load generator
called localhost. The status of the localhost load generator is Down. This indicates that the
Controller is not connected to the localhost load generator.

In this tutorial, you will use your local computer as the load generator.

Note that in a typical operational system, you would have several load generators, each
hostingmultiple Vusers.

2. Test the load generator connection.

When you run a scenario, the Controller connects to the load generators automatically.
However, you can test the connections before trying to run the scenario.

a. In the LoadGenerators dialog box, select localhost and click Connect.

The Controller attempts to connect to the load generator machine. When a connection has
beenmade, theStatus of the load generator changes from Down toReady.
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b. Click Close.

How do I emulate real load behavior?
After you have added your load generators, you are ready to configure load behavior.

Typical users do not log on and off the system at precisely the same time. LoadRunner allows
users to gradually log on to and off the system. It also lets you determine the duration of the
scenario, and the way in which the scenario terminates. The scenario that you will configure below
will be relatively simple. However, when designing a scenario that more accurately reflects a real
life scenario, you can definemore true-to-life Vuser activity.

You configure the load behavior for amanual scenario in theScenario Schedule pane of the
Controller. The Scenario Schedule pane is divided into three sections: theSchedule Definition
area, theActions grid, and the Interactive Schedule graph.

You will now change the default load settings and configure a scenario schedule.

1. Select schedule type and runmode.

In theScenario Schedule pane, make sure that Schedule by: Scenario andRun Mode:
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Real-world schedule are selected.

2. Set the scheduled action definitions.

You can set theStart Vusers, Duration, andStop Vusers actions for the scenario schedules
from either theGlobal Schedule grid, or by manipulating the Interactive Schedule graph.
When you set the definitions from the graph, theGlobal Schedule grid properties adjust
accordingly.

You will now set the definitions so that theGlobal Schedule grid will look as below.

a. Set up the Vuser Initialization.

Initializationmeans preparing the Vusers and the load generators for a load test run by
running the vuser_init action in the script. Initializing Vusers before they start running
reduces CPU consumption and helps providemore realistic results.

i. Double-click Initialize in theGlobal Schedule grid. The Edit Action dialog box opens
displaying the Initialize action.
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ii. Select Initialize all Vusers simultaneously.

iii. Click OK.

b. Specify a gradual start for the Vusers

Starting Vusers at intervals allows you to examine the gradual increase of Vuser load on
the application under test over time, and helps you pinpoint exactly when the system
response time slows down.

i. Double-click Start Vusers in theGlobal Schedulegrid. The Edit Action dialog box
opens displaying theStart Vusers action.

ii. In the Start X Vusers box, enter 8, and select the second option— 2 Vusers every
00:00:30 (30 seconds).

iii. Click OK.

c. Schedule the duration.

You specify a duration tomake sure that the Vusers continue performing the schedule
action for a specific period so you canmeasure continuous load on the server. If you set a
duration, the script will run for as many iterations as necessary during that period,
disregarding the number of iterations set in the script’s run-time settings.
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i. Make sure that the Interactive Schedule Graph is in Edit mode by clicking theEdit

Mode button on the Interactive Schedule Graph toolbar.

ii. In the Interactive Schedule Graph, click the horizontal line which represents Duration.
The line is highlighted and a dot and a diamond are displayed at its endpoints.

Note that if the Legend is displayed on top of the diamond, click theHide

Legend button on the Interactive Schedule Graph toolbar to show the
diamond.

iii. Drag the diamond shaped endpoint to the right until the time in brackets reads
00:11:30. You have just set the Vusers to run for a period of 10minutes.

d. Schedule a gradual closure.

Gradually stopping Vusers is recommended to help detect memory leaks and check
system recovery, after the application has reached a threshold.

i. Double-click Stop Vusers in theGlobal Schedulegrid. The Edit Action dialog box
opens displaying theStop Vusers action.

ii. Select the second option and enter the following values—2 Vusers every 00:00:30
(30 seconds).

iii. Click OK.

How do I emulate different types of users?
Now that you have configured a load schedule, you will specify how the Vusers will behave during
the test.

When emulating a real user, you need to consider the user’s actual behavior. Behavior refers to the
time that a user takes to pause between actions, the number of times a user repeats an action, and
so on.

In this section, you will learnmore about LoadRunner’s run-time settings, and you will enable Think
Time and Logging.
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1. Open the run-time settings.
a. In the Controller, click theDesign tab.

b. In theScenario Groups pane, select the travel_agents group.

c. Click theRun-Time Settings button on the Scenario Groups toolbar. The Run-Time
Settings dialog box opens.

The run-time settings let you emulate different kinds of user activity and behavior. They
include:

Run Logic. The number of times a Vuser repeats a set of actions.

Pacing. The time to wait before repeating the action.

Log. The level of information that you want to gather during the test. The first time you run
a scenario, it is recommended to generate logmessages tomake sure that you have
debugging information in case the first run fails.

Think Time. The time the user stops to think between steps. Since users interact with the
application according to their experience level and objectives, more technically proficient
users may work more quickly than new users. Vusers can bemade to emulate their real-
world counterparts more accurately during a load test by enabling think time.

Speed Simulation. Users using different network connections such as modem, DSL, and
cable.

Browser Emulation. Users using different browsers to see their application’s
performance.

Content Check. For automatically detecting user-defined errors.

Suppose that your application sends a custom page when an error occurs. This custom
page always contains the words ASP Error. You need to search all of the pages returned by
the server and see if the text ASP Error appears.
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You can set up LoadRunner to automatically look for this text during the test run, using the
Content Check run-time settings. LoadRunner searches for the text and generates an error
if it is detected. During the scenario run, you can identify the content check errors.

2. Enable think time.
a. In the Run-Time Settings dialog box, click General > Think Time.

b. Select Replay think time, and select Use random percentage of recorded think time.

c. Specify aminimum of 50% and amaximum of 150%.

The above specifications use a random percentage of the recorded think time to emulate
users with a varying range of proficiency. For example, if the recorded think time for
selecting a flight was 4 seconds, the random think time could be anything between 2-6
seconds (50% to 150% of 4).

3. Enable logging.
a. In the Run-Time Settings dialog box, click General > Log.

b. Select Enable logging.

c. Under Log options, select Always send messages.

d. Click Extended log, and select Data returned by server.
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Note that after the initial debugging run, extended logging is not recommended for a
load test. It is enabled only for the purposes of this tutorial to provide information for
the Vuser Output log.

e. Click OK to close the Run-Time Settings dialog box.

How do I monitor the system under load?
Now that you have defined how your Vusers will behave during the test, you are ready to set up
your monitors.

While generating a load on an application, you want to see how the application performs in real time
and where potential bottlenecks exist.You use LoadRunner’s suite of integratedmonitors to
measure the performance of every single tier, server, and component of the system during the load
test. LoadRunner includes monitors for a variety of major backend system components including
Web, application, database, and ERP/CRM servers.

For instance, you can select aWeb Server Resources monitor according to the type of Web server
that is running. You can purchase a license for the relevant monitor, for example IIS, and use that
monitor to pinpoint problems reflected in the IIS resources.

In this section, you will learn how to add and configure theWindows Resources monitor. You can
use this monitor to determine the impact of load on your CPU, disk, andmemory resources.

1. Select theWindows Resources Monitor.
a. Click theRun tab at the bottom of the Controller.

TheWindows Resources graph is one of four default graphs that are displayed in the graph
viewing area. You will learn how to open other graphs in the next lesson.

HP LoadRunner (Service Pack 11.51)Page 54 of 96

Tutorial
Lesson 5: Creating a Load Testing Scenario



b. Right-click inside theWindows Resources graph and select Add Measurements. The
Windows Resources dialog box opens.

2. Select themonitored server.
a. In theMonitored Server Machines section of theWindows Resources dialog box, click

Add. The AddMachine dialog box opens.
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b. In theName box, type localhost. (If your load generator was running off a different
machine you would type the server name or IP address of that machine.)

c. From thePlatform list, select the platform on which themachine runs.

d. Click OK.

The default Windows Resources measurements are listed under theResource
Measurements on <server machine>.

3. Activate themonitor.
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Click OK in theWindows Resources dialog box to close the dialog box and activate the
monitor.

Where To Go From Here
Now that you have designed a load test scenario, you can proceed to "Lesson 6: Running the Load
Test" on page 58.
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Lesson 6: Running the Load Test
When you run a load test, LoadRunner generates a load on the system. You can then use
LoadRunner’s monitors and graphs to observe the performance of the system under load.

In this lesson you will cover the following topics:

l The Controller Run view at a glance

l How do I run a load test scenario?

l How do I watch a Vuser running in real time?

l Where can I view a summary of user actions?

l How can I increase the load during the test?

l How is the application performing under load?

l Did the application encounter errors?

l How do I know that the test finished running?

l Did the application perform well under load?

The Controller Run view at a glance
The Run tab in the Controller is the control center from which the scenario is managed and
monitored. The Run tab contains five panes:

1. Scenario Groups pane

2. Scenario Status pane

3. Available Graphs pane

4. Graph Display pane
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5. Graph Legend pane

1. Scenario Groups pane. In the upper-left pane, you can view the status of Vusers in the
scenario groups. You use the buttons to the right of this pane to start, stop, and reset the
scenario, to view individual Vuser status, and to increase the load on the application during a
scenario by manually addingmore Vusers.

2. Scenario Status pane. In the upper-right pane, you can view a summary of the load test,
including the number of running Vusers and the status of each Vuser action.

3. Available Graphs pane. In themiddle-left pane, you can see a list of the LoadRunner graphs.
To open a graph, select a graph in the tree, and drag it into the graph viewing area.

4. Graph Display pane. In themiddle-right pane, you can customize the display to view between
one and eight graphs (View > View Graphs).

5. Graph Legend pane. In the bottom pane, you can view data from the selected graph.

Note that the control for the Run tab is at the bottom of the Controller.

How do I run a load test scenario?
In this section, you will start the scenario.

1. Open the Controller Run view.

Click theRun tab at the bottom of the Controller.
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Notice that there are 8 Vusers in theDown column of theScenario Groups pane. These are
the Vusers you created when you created the scenario.

Since the scenario has not yet run, all other counters remain at zero and all the graphs in the
graph viewing area (except Windows Resources) are blank. When you start running the
scenario in the next step, the graphs and counters will begin to display information.

2. Start the scenario.

Click theStart Scenario button or select Scenario > Start to start running the scenario.

If you are running the tutorial for the first time, the Controller begins the scenario. The result
files are saved automatically to the load generator’s temp folder.

If you are repeating the test, you will be prompted to overwrite the existing results file. Click
No, because the results of the first load test should be used as baseline results to be compared
with subsequent load test results. The Set Results Directory dialog box opens.

Specify a new results folder. Enter a unique andmeaningful name for each results set,
because youmay want to superimpose the results of several scenario runs when you come to
analyze the graphs.

How do I monitor the application under load?
You use the Controller’s online graphs to view performance data collected by themonitors. You use
this information to isolate potential problem areas in your system environment.
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1. Examine the performance graphs.

TheGraph Display pane of the Run tab displays the following default graphs:

a. Running Vusers - Whole Scenario graph. Displays the number of Vusers running at a
given time.

b. Transaction Response Time - Whole Scenario graph. Shows the amount of time it
takes for each transaction to be completed.

c. Hits per Second - Whole Scenario graph. Displays the number of hits (HTTP requests)
made to theWeb server by Vusers during each second of the scenario run.

d. Windows Resources graph. Displays theWindows resources measured during a
scenario.

2. Highlight individual measurements.
a. Double-click theWindows Resources graph to enlarge it to fit the entire Graph Display

pane. Notice that eachmeasurement appears on a color-coded row in the Graph Legend
pane. Each row corresponds to a line in the graph with the same color.

b. Select a row to highlight the corresponding line in the graph, and vice versa.

c. Double-click the graph again to reduce its size.

3. View the throughput information.

In the Available Graphs pane, underWeb Resources Graphs, select the Throughput graph,
and drag it into the Graph Display pane. The Throughput graphmeasurements are displayed in
the Graph Display pane and theGraph Legend pane.

The Throughput graph shows the amount of data (measured in bytes) that the Vusers receive
from the server in any given second. You can compare this graph with the Transaction
Response Time graph to see how throughput affects transaction performance.

If the throughput scales upward as time progresses and the number of Vusers increases, this
indicates that the bandwidth is sufficient. If the graph were to remain relatively flat as the
number of Vusers increased, it would be reasonable to conclude that the bandwidth is
constraining the volume of data delivered.
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How do I watch a Vuser running in real time?
When emulating users, you should be able to view the Vusers' actions in real time tomake sure
they are performing the correct actions. The Controller lets you view the actions in real time using
the Run-Time Viewer.

To visually observe a Vuser’s actions:

1. In the Controller's Run tab, click theVusers button. The Vusers dialog box opens.

TheStatus column displays the status of each Vuser. In the example above, you can see that
four Vusers are running and four are down. The Start Vusers action in the scheduler instructed
the Controller to release two Vusers at a time. As the scenario progresses, Vusers will
continue to be added in groups of two at 30-second intervals.

2. Select a running Vuser in the Vuser list.

3. Click theShow the selected Vusers button on the Vusers toolbar. The Run-Time Viewer
opens and displays the actions performed by the selected Vuser. The Run-Time Viewer
updates as the Vuser proceeds through the steps of the Vuser script.

HP LoadRunner (Service Pack 11.51)Page 62 of 96

Tutorial
Lesson 6: Running the Load Test



4. Click theHide the selected Vusers button on the Vusers toolbar to close the Run-Time
Viewer.

Where can I view a summary of Vuser
actions?

To see the progress of an individual Vuser during a running test, you can display a log file that
contains a text summary of the Vuser’s actions.

To review a text summary of the Vuser’s actions

1. In the Vusers window, select a running Vuser.

2. Click theShow Vuser Log button on the Vusers toolbar. The Vuser log dialog box opens.

The log contains messages that correspond to the actions of the Vuser. For example, in the
window above, themessageVirtual User Script started indicates the start of the Vuser's run.
Scroll to the bottom of the log and watch as new messages are added for each action
performed by the Vuser.

3. Close the Vuser Log dialog box and the Vusers dialog box.

How can I increase the load during the test?
You canmanually addmore Vusers during a load test to increase the load on the system.
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1. To increase the load during a load test:
a. Make sure that in the Controller, theRun tab is displayed

b. Click theRun/Stop Vusers button. The Run/Stop Vusers dialog box opens displaying the
number of Vusers currently assigned to run in the scenario.

c. In the # column, enter the number of Vusers that you want to add to the group. To run two
additional Vusers, replace the number 8with the number 2, in the # column.

d. Click Run to add the Vusers.

e. If some of the original Vusers have not yet been initialized, theRun Initialized andRun
New options appear. Select theRun New option.

The 2 additional Vusers are distributed to the travel_agent group and are run on the
localhost load generator. The Scenario Status pane shows that there are now 10 running
Vusers.

Youmay get a warningmessage that the LoadRunner Controller cannot activate
additional Vusers. This is because you are using your local machine as a load
generator and it has limitedmemory resources. Generally, use a dedicatedmachine as
a load generator to avoid this issue.

How is the application performing under load?
Check the Scenario Status pane [on the Run tab] for a summary of the running scenario. In the
Scenario Status pane, you can drill down to see which Vuser actions are causing the application
problems. A high number of failed transactions and errors may indicate that the application is not
performing as required under load.
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1. View the scenario status.

The header of the Scenario Status pane displays the overall status of the scenario.

2. View a breakdown of Vuser actions.

a. Click Passed Transactions in the Scenario Status pane. The Transactions dialog box
opens and displays a list of transaction details.

b. Click Close to close the Transactions dialog box.

Did the application encounter errors?
If an application starts to fail under heavy load, you are likely to encounter errors and failed
transactions. The Controller displays error messages in the Output window.

1. Check for any error messages.
a. Select View > Show Output or click Errors in the Scenario Status pane.

TheOutput dialog box opens and lists amessage text, the total number of messages
generated, the Vusers and load generators that generated the error, and the scripts in which
the errors occurred.
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b. To view amessage in detail, select themessage and click Details. The DetailedMessage
Text box opens, displaying the completemessage text.

The example below shows a timeout error. TheWeb server did not respond to a request
within a given time period.

2. View log information details.

You can view information about eachmessage, Vuser, script, and load generator associated
with an error code by clicking the blue link in the appropriate column.

For example, to locate where in the script an error occurred, drill down the Total Messages
column. TheOutput window displays a list of all messages of the selected error code, including
the time, iteration number, and line in the script where the error occurred.

3. Drill down the Line Number column.

VuGen opens, displaying the line in the script at which the error occurred. You can use this
information to identify transactions with slow response times that are causing the application to
fail under load.

How do I know that the scenario has finished
running?

At the conclusion of a scenario run, the header of the Scenario Status pane shows theDown
status. This indicates that all the Vusers in the scenario have finished running.
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You can open the Vusers dialog box to see the status of each individual Vuser. The Vuser dialog
box displays the number of iterations that each Vuser performed, the number of successful
iterations, and the elapsed time.

Did the system perform well under load?
To see how well the system performed under load, look at the transaction response times and
determine whether the response times were within acceptable limits. If the transaction response
times increase during the scenario, you need to look for bottlenecks. You will learnmore about this
in "Lesson 7: Analyzing Your Scenario" on page 70.

Once a problem has been isolated, a corroborative effort involving developers, DBAs, network, and
other systems experts is required to fix the problem. After adjustments aremade, the load test is
repeated to confirm that the adjustments had the desired effect. You repeat this cycle to optimize
system performance.

To save the scenario so that you can run it again with the same settings, select File > Save or click
theSave button on the Controller toolbar.
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Where To Go From Here
Now that you have learned how to run and view a simple load test scenario, you can proceed to
"Lesson 7: Analyzing Your Scenario" on page 70.
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Lesson 7: Analyzing Your Scenario
In the previous lessons you learned how to design, control, and execute a scenario run. Once you
have loaded your server, you want to analyze the run, and pinpoint the problems that need to be
eliminated to improve system performance.

The graphs and reports produced during your analysis session present important information about
the performance of your scenario. Using these graphs and reports, you can pinpoint and identify the
bottlenecks in your application, and determine what changes need to bemade to your system to
improve its performance.

In this lesson, you will cover the following topics:

l How does an analysis session work?

l How do I start my analysis session?

l The Analysis window at a glance

l Did I reachmy goals? (Service Level Agreement)

l How do I view a summary of performance?

l How do I graphically view performance?

l Didmy server perform well?

l How can I pinpoint the source of a problem?

l What other information can I gather about my scenario run?

l How can I publishmy findings?

l Conclusion

How does an analysis session work?
The aim of the analysis session is to find the failures in your system’s performance and then
pinpoint the source of these failures, for example:

l Were the test expectations met?What was the transaction time on the user’s end under load?
Did the SLA meet or deviate from its goals?What was the average transaction time of the
transactions?

l What parts of the system could have contributed to the decline in performance?What was the
time of the network and servers?

l Can you find a possible cause by correlating the transaction times and backendmonitor matrix?

In the following sections, you will learn how to open LoadRunner Analysis, and build and view
graphs and reports that will help you find performance problems and pinpoint the sources of these
problems.

HP LoadRunner (Service Pack 11.51)Page 70 of 96

Tutorial
Lesson 7: Analyzing Your Scenario



How do I start my analysis session?
1. Open HP LoadRunner Analysis.

Select Start > All Programs > HP Software > HP LoadRunner > Analysis. HP
LoadRunner Analysis opens.

2. Open the analysis session file.

For the purpose of this section in the tutorial, in order to illustrate more diverse results, we ran a
scenario similar to those you ran in the previous lessons. This time, however, the scenario
incorporated 70 Vusers rather than 10 Vusers. You will now open the analysis session created
from the results of this scenario.

a. In the Analysis window, select File > Open. TheOpen Existing Analysis Session File
dialog box opens.

b. From the <LoadRunner Installation>\tutorial folder, select analysis_session and click
Open.

c. If you are prompted to convert the session from an older version of LoadRunner to a newer
version, click OK.

Analysis opens the session file.

The Analysis window at a glance
Analysis contains the following primary panes:

1. Session Explorer

2. Properties pane

3. Graph Viewing pane
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4. Legend pane

1. Session Explorer. In the upper left pane, Analysis shows the reports and graphs that are open
for viewing. From here you can display new reports or graphs that do not appear when Analysis
opens, or delete ones that you no longer want to view.

2. Properties pane. In the lower left pane, the Properties pane displays the details of the graph or
report you selected in the Session Explorer. Fields that appear in black are editable.

3. Graph Viewing pane. In the upper right pane, Analysis displays the graphs. By default, the
Summary Report is displayed in this area when you open a session.

4. Legend pane. In the lower right pane, you can view data from the selected graph.

Note that there are additional panes that can be accessed from the toolbar that provide
additional information. These windows can be dragged and dropped anywhere on the screen.

Did I reach my goals? (Service Level
Agreement)

In this section, you will be introduced to the Service Level Agreement, or SLA.

SLAs are specific goals that you define for your load test scenario. Analysis compares these goals
against performance-related data that LoadRunner gathers and stores during the run, and then
determines the SLA status (Pass or Fail) for the goal.
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For example, you can define a specific goal, or threshold, for the average transaction time of a
transaction in your script. After the test run ends, LoadRunner compares the goals you defined
against the actual recorded average transaction times. Analysis displays the status of each defined
SLA, eitherPass or Fail. For example, if the actual average transaction time did not exceed the
threshold you defined, the SLA status will bePass.

As part of your goal definition, you can instruct the SLA to take load criteria into account. This
means that the acceptable threshold will vary depending on the level of load, for example, Running
Vusers, Throughput, and so on. As the load increases, you can allow a higher threshold.

Depending on your defined goal, LoadRunner determines SLA statuses in one of the following
ways:

l SLA status determined at time intervals over a timeline. Analysis displays SLA statuses at
set time intervals (for example, every 5 seconds) over a timeline within the run.

l SLA status determined over the whole run. Analysis displays a single SLA status for the
whole scenario run.

SLAs can be defined before running a scenario in the Controller, or after in Analysis itself.

In the following section, you will define an SLA using our HPWeb Tours example. Assume that the
administrator of HP Web Tours would like to know whenever the average transaction times of the
book_flight and search_flight transactions exceeds a certain value. To do this, you select the
transactions and then set the threshold values. These threshold values are themaximum amounts
of time that would be acceptable as average transaction times.

You will also set these threshold values to take certain load criteria into account; in this case
Running Vusers. In other words, as the number of running Vusers increases, the threshold value
rises.

This is because although the HPWeb Tours administrator would like the average transaction times
to be as low as possible, it is understood that at certain times of the year it is reasonable to assume
that the HPWeb Tours site will have to handle a higher load than at other times of the year. For
example, during peak travel season, a higher number of travel agents log on to the site to book
flights, check itineraries, and so on. Given this understandably higher load, at these times a slightly
longer average transaction time will be acceptable.

You will set the SLA to take three load scenarios into account: light load, average load, and heavy
load. Each scenario will have its own threshold value.

How do I define an SLA?
Youwill define an SLA in Analysis after the scenario run.

Note that is preferable to define an SLA in the Controller before a scenario run. However, for
the purposes of this tutorial, because you are not analyzing the same test scenario that you ran
in previous lessons, you will define the SLA in Analysis. To define an SLA in the Controller,
click New in theService Level Agreement section of theDesign tab.

You will now define an SLA that will set specific goals for the average transaction times for the
book_flight and search_flight transactions in the sample session file.

The average transaction times will bemeasured at set time intervals within the run.
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To define an SLA:

1. Open the SLA wizard.
a. In LoadRunner Analysis, select Tools > Configure SLA Rules. The Service Level

Agreement dialog box opens.

b. Click New to open the Service Level Agreement wizard.

Note that the first time you open the Service Level Agreement wizard, theStart page
is displayed. If you do not want this page to be displayed the next time you run the
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wizard, select theSkip this page next time check box.

c. Click Next.

2. Select ameasurement for your goal.
a. In the Select aMeasurement for Your Goal page, select Transaction Response Time:

Average.

b. Click Next.

3. Select the transactions tomonitor.

In the Select Transactions page, select the transactions you would like tomonitor from the
Available Transactions list, which is a list of all the transactions in the script.

a. Double-click the book_flight and search_flight transactions tomove them to the
Selected Transactions list.
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b. Click Next.

4. Set the load criteria.

In the Set Load Criteria page, you instruct the SLA to take different load scenarios into
account.

a. Select Running Vusers from the Load Criteria drop down list.

b. Set the Load Values to look like the following example:

HP LoadRunner (Service Pack 11.51)Page 76 of 96

Tutorial
Lesson 7: Analyzing Your Scenario



You just set the SLA to determine an acceptable average transaction time over three
potential load scenarios:

- Light load. Between 0 and 19 Vusers

-Average load. Between 20 and 49 Vusers

-Heavy load.More than 50 Vusers

c. Click Next.

5. Set threshold values.

In the Set Threshold Values page, you define the acceptable average transaction times for the
book_flight and search_flight transactions.

Set the threshold values to look like the following example:
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You just determined that for both selected transactions, the following average transaction
times are acceptable:

- Light load. 5 seconds or less

-Average load. 10 seconds or less

-Heavy load. 15 seconds or less

Note that threshold values for selected transactions do not have to be the same. You can
assign different values for each transaction.

6. Save the SLA.

To save the SLA and close the wizard, click Next then Finish thenClose on the pages that
follow.

Analysis applies your SLA settings to the Summary Report. The report is then updated to
include all the relevant SLA information.

How do I view a summary of performance?
The Summary Report tab displays general information and statistics about the scenario run, as well
as all relevant SLA information. For example, what were the worst performing transactions in terms
of defined SLAs, how specific transactions performed over set time intervals, and overall SLA
statuses. You open the Summary Report from the Session Explorer.

HP LoadRunner (Service Pack 11.51)Page 78 of 96

Tutorial
Lesson 7: Analyzing Your Scenario



1. What are the overall scenario statistics?

In the Statistics Summary section, you can see that amaximum of 70 Vusers ran in this test.
Other statistics such as the total/average throughput, and the total/average hits are also
displayed.

2. What were the worst performing transactions?

The 5Worst Transactions table shows you up to five worst-performing transactions for which
SLAs were defined.

You can see that over the duration of the book_flight transaction, the SLA threshold was
exceeded 39.68% of the time. The average percentage by which it exceeded the SLA threshold
over the whole run was 43.71%.

3. Over which time intervals was the SLA threshold exceeded?
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The Scenario Behavior Over Time section shows how each transaction performed during
different time intervals. The green squares show time intervals where the transaction
performed within the SLA threshold, red squares where the transaction failed, and grey squares
where no relevant SLA was defined.

You can see that of the two transactions for which you defined SLAs, search_flightwas within
the threshold over all themeasured time intervals, while book_flight exceeded the threshold in
several intervals.

4. What was the overall transaction performance?

The Transaction Summary lists a summary of the behavior of each transaction.

We also see that this transaction failed 28 times.

Review the times of each transaction. The 90 Percent column displays the time of 90% of the
executions of a particular transaction. You can see that 90% of the check_itinerary
transactions that were performed during the test run had a time of 65.754 seconds. This is
double its average time, 32.826, whichmeans that themajority of occurrences of this
transaction had a very high response time.

Note how theSLA Status column shows the relevant overall SLA statuses: Fail for book_
flight andPass for search_flight.
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How do I graphically view performance?
You can access available graphs from the Session Explorer pane. You will now view and analyze
the Average Transaction Response Time graph.

1. Open the Average Transaction Response Time graph.
a. In the Session Explorer underGraphs, select Average Transaction Response Time.

The Average Transaction Response Time graph opens in the graph viewing area.

If no graphs are displayed in the Session Explorer pane, right-click the Graphs node
and select the Transactions: Average Transaction Response Time node in the Open a
New Graph dialog box. Click OpenGraph to add the graph to the Session Explorer
pane.

b. In the Legend pane, click the check_itinerary transaction. The check_itinerary
transaction is highlighted in the graph.

The points on the graph represent the average time of a transaction at a specific time during
the scenario. Hold your cursor over a point in the graph. A yellow box appears, and displays
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the coordinates of that point.

2. Analyze the results.

Note how the average transaction time of the check_itinerary transaction fluctuates greatly,
and reaches a peak of 75.067 seconds, 2:56min. into the scenario run.

On a well-performing server, the transactions would follow a relatively stable average time. At
the bottom of the graph, note how the logon, logoff, book_flight, and search_flight
transactions havemore stable average times.

Did my server perform well?
In the previous section you saw instability in your server’s performance. Now you will analyze the
effect of 70 running Vusers on the system’s performance.

1. Study the behavior of the Vusers.

In the Session Explorer, underGraphs, click Running Vusers. TheRunning Vusers graph
opens in the graph viewing area.
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You can see that there was a gradual start of running Vusers at the beginning of the scenario
run. Then, for a period of 3minutes, 70 Vusers ran simultaneously, after which the Vusers
gradually stopped running.

2. Filter the graph so that you see only the time slice when all the Vusers ran simultaneously.

When you filter a graph, the graph data is narrowed down so that only the data for the condition
that you specified is displayed. All other data is hidden.

a. Right-click the graph and select Set Filter/Group By, or alternatively, click theSet

Filter/Group By button on the Analysis toolbar.

b. In the Filter Condition area, select theValues column of theScenario Elapsed Time
row.

c. Click the down-arrow and specify a time range from 000:01:30minutes to 000:03:45
minutes.

d. Click OK.

e. In the Graph Settings dialog box, click OK.

TheRunning Vusers graph now displays only those Vusers running between 1:30
minutes and 3:45minutes of the scenario run. All other Vusers have been filtered out.
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Note that to clear the filter, you right-click the graph and select Clear Filter/Group

By, or alternatively, click theClear Filter and Group By button on the Analysis
toolbar.

3. Correlate the Running Vusers and Average Transaction Response Time graphs to compare
their data.

You can join two graphs together to see the effect of one graph’s data upon the other graph’s
data. This is called correlating two graphs.

For example, you can correlate the Running Vusers graph with the Average Transaction
Response Time graph to see the effect of a large number of Vusers on the average time of the
transactions.

a. Right-click the Running Vusers graph and select Clear Filter/Group By.

b. Right-click the graph and selectMerge Graphs.

c. From theSelect graph to merge with list, select Average Transaction Response
Time.

d. Under Select type of merge, select Correlate, and click OK.

The Running Vusers and Average Transaction Response Time graphs are now displayed
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in one graph, the Running Vusers - Average Transaction Response Time graph.

4. Analyze the correlated graph.

In this graph you can see that as the number of Vusers increases, the average time of the
check_itinerary transaction gradually increases. In other words, the average time increases
as the load increases.

At 66 Vusers, there is a sudden, sharp increase in the average time. We say that the test
broke the server. The time clearly began to degrade when there weremore than 66 Vusers
running simultaneously.

Saving a template
So far you have filtered a graph and correlated two graphs. The next time you analyze a scenario,
youmight want to view the same graphs, with the same filter andmerge conditions applied. You
can save your merge and filter settings into a template, and apply them in another analysis session.

To save your template:

1. Select Tools > Templates. The Apply/ Edit Template dialog box opens.

2. In the Templates pane, click theNew button. The Add New Template dialog box opens.

3. Enter an appropriate name for the template and click OK.

4. Click OK to close the Apply/Edit Template dialog box.

The next time you open a new analysis session and want to use a saved template:

1. Select Tools > Templates. The Apply/ Edit Template dialog box opens.

2. Select your template from the list, and click Apply to Session.

How can I pinpoint the source of the problem?
Until now, you have seen that an increase in load on the server had a negative impact on the
average response time of the check_itinerary transaction.
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You can drill down further into the check_itinerary transaction to see which system resources may
have negatively influenced its performance.

The Auto-correlate tool canmerge all the graphs that contain data that could have had an effect on
the response time of the check_itinerary transaction, and pinpoint what was happening at the
moment the problem occurred.

1. From the graph tree, select theAverage Transaction Response Time graph.

Look at the check_itinerary transaction, particularly at the slice of elapsed time between 1 and
4minutes. The average response time started to increase almost immediately, until it peaked
at nearly 3minutes.

2. Filter the Average Transaction Response Time graph to display only the check_itinerary
transaction.
a. Right-click the graph, and select Set Filter/Group by.

b. In the Transaction Name / Value cell, select check_itinerary.

c. Click OK.

The filtered graph displays only the check_itinerary transaction.
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3. Auto-correlate the graph.
a. Right-click the graph, and select Auto Correlate.

b. In the Auto Correlate dialog box, make sure that themeasurement to correlate is check_
itinerary, and set the time range from 1:20 to 3:40minutes - either by entering the times in
the boxes, or by dragging the green and red poles into place along theElapsed Scenario
Time axis.

c. Click OK.

The auto-correlated graph opens in the graph viewing area. The check_itinerary
transaction is highlighted.
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The auto-correlated graph is given a default name, Auto Correlated Graph [1].

4. Rename the graph.
a. In the Session Explorer, underGraphs, right-click Auto Correlated Graph [1], and select

Rename Item. The graph name becomes editable.

b. TypeAuto Correlated - check_itinerary and press Enter, or click anywhere in the
Analysis window.

5. Analyze the auto-correlated graph.

In the Legend pane below the graph, from theGraph column, selectWindows Resources.

In theMeasurement andCorrelation Match columns, you can see that the Private Bytes and
Pool Nonpaged Bytes, both of which arememory-relatedmeasurements, have a Correlation
Match of over 70% with the check_itinerary transaction. This means that the behavior of
these elements was closely related to the behavior of the check_itinerary transaction during
the specified time interval.

We can conclude that exactly when the check_itinerary transaction’s response time peaked,
there was a shortage of systemmemory resources.
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What other information can I gather about my
scenario run?

In addition to the graphs that appear in the graph tree at the start of an analysis session, you can
display different graphs to get other information about your scenario run.

1. Display a new graph.
a. Click Graph > Add New Graph.

TheOpen a New Graph dialog box opens and lists the categories of graphs that contain
data and can be displayed.

- Vusers. Displays information about the Vusers and their status.

- Errors. Displays error statistics.

- Transactions. Displays data about transactions and their response times.

- Web Resources. Displays hits, throughput, and connection data.

- Web Page Diagnostics graphs display data about eachmonitoredWeb page in your
script.

- System Resources graphs display system resource usage data.

b. In the Open a New Graph dialog box, click the “+” next to a category to expand it.
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c. Select a graph and click Open Graph.

d. Click Close to close the Open a New Graph dialog box.

Now open several additional graphs to understandmore about your scenario run.

How can I publish my findings?
You can publish the findings from your analysis session in an HTML orMicrosoft Word report. The
report is created using a designer template, and includes explanations and legends of the presented
graphs and data.

HTML Reports

The HTML report can be opened and viewed in any browser.

To create an HTML report:

1. Click Reports > HTML Report.

2. Specify a file name for your report, and the path where you want to save it.

3. Click Save.

Analysis creates the report and displays it in yourWeb browser. Note how the layout of the
HTML report is very similar to the layout of your analysis session. You can click on the links in
the left pane to see the various graphs. A description of each graph is given at the bottom of the
page.

Microsoft Word Reports

You can present your analysis session in aMicrosoft Word report. TheWord report is more
comprehensive than the HTML report, because you have the option to include general information
about the scenario, measurement descriptions, and so on. You can also format the report to include
your company’s name and logo, and the author’s details.

Like any Microsoft Word file, the report is editable, so you can add further comments and findings
after you build the report.

To create a Microsoft Word report:

1. Click Reports > New Report.

The New Report dialog box opens.
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2. In the General tab:
a. From Based on template, select Detailed report (for single run).

b. Enter a title for your report.

c. Enter the author’s name, job title, and the company’s name.

3. In the Format tab:

By default, the report will be built with a title page, table of contents, graph details and
descriptions, andmeasurement descriptions. You can select options which add script details
into the report, allowing you to view thumbnail images of the business process steps.

You can include a company logo by selecting Include company logo and browsing to the file
location. The logomust be a .bmp file.

4. In the Content tab:
a. Select which sections of your scenario run and analysis session you want to include in

your report.

For the purpose of this tutorial, you will add an executive summary to the Content Items
list.

b. Click Add, select Executive Summary from the list and click OK. The Executive
Summary item is added to the list. Enter the following text into the edit box:

- Objectives: The objectives of the test scenario were to....

- Conclusions: The conclusions I reached are as follows:

c. Specify which graphs you want to include in the report. By default, all the graphs in your
session are listed and selected, and the graphs notes will be included in your report.
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d. You can specify the order in which to display the items in the report.

- In theWorkload Characteristics item, select Average Hits per Second from the
Selected Columns list.

- Click the Down arrow until the item appears under Total Transactions Number.

- In the report, theAverage Hits per Second item will follow the Total Transactions
Number item.

5. Click Generate.

The data is gathered and the report is created in aMicrosoft Word file, which opens inMicrosoft
Word.

In addition to the graphs that you generated during your analysis session, the report includes an
objective and a conclusion, and other sections and graphs that you chose to include while
building the report.

Conclusion
In this lesson you learned the basics of defining a Service Level Agreement, analyzing a scenario
run, and publishing your results in a report.

You have learned that performance problems can be pinpointed by studying various graphs that
show bottlenecks on the server, possibly due to too heavy a load. You have seen that you can
pinpoint the sources of these bottlenecks by configuring graphs to display correlated data.
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Legal Notices
Warranty

The only warranties for HP products and services are set forth in the express warranty statements
accompanying such products and services. Nothing herein should be construed as constituting an
additional warranty. HP shall not be liable for technical or editorial errors or omissions contained
herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend
Confidential computer software. Valid license from HP required for possession, use or copying.
Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software
Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government
under vendor's standard commercial license.

Copyright Notice
© Copyright 1993-2012 Hewlett-Packard Development Company, L.P.

Trademark Notices
Adobe™ is a trademark of Adobe Systems Incorporated.

Microsoft® andWindows® are U.S. registered trademarks of Microsoft Corporation.

UNIX® is a registered trademark of TheOpenGroup.

Java is a registered trademark of Oracle and/or its affiliates.
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Documentation Updates
The title page of this document contains the following identifying information:

l Software Version number, which indicates the software version.

l Document Release Date, which changes each time the document is updated.

l Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using themost recent edition of a document, go
to:

http://h20230.www2.hp.com/selfsolve/manuals

This site requires that you register for an HP Passport and sign in. To register for an HP Passport
ID, go to:

http://h20229.www2.hp.com/passport-registration.html

Or click theNew users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product support
service. Contact your HP sales representative for details.
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Support
Visit the HP Software Support Online web site at:

http://www.hp.com/go/hpsoftwaresupport

This web site provides contact information and details about the products, services, and support
that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and
efficient way to access interactive technical support tools needed tomanage your business. As a
valued support customer, you can benefit by using the support web site to:

l Search for knowledge documents of interest

l Submit and track support cases and enhancement requests

l Download software patches

l Manage support contracts

l Look up HP support contacts

l Review information about available services

l Enter into discussions with other software customers

l Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also
require a support contract. To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html

To findmore information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp
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