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Documentation Updates
The title page of this document contains the following identifying information:

l Software Version number, which indicates the software version.

l Document Release Date, which changes each time the document is updated.

l Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using themost recent edition of a document, go
to:

http://h20230.www2.hp.com/selfsolve/manuals

This site requires that you register for an HP Passport and sign in. To register for an HP Passport
ID, go to:

http://h20229.www2.hp.com/passport-registration.html

Or click theNew users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product support
service. Contact your HP sales representative for details.
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Support
Visit the HP Software Support Online web site at:

http://www.hp.com/go/hpsoftwaresupport

This web site provides contact information and details about the products, services, and support
that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and
efficient way to access interactive technical support tools needed tomanage your business. As a
valued support customer, you can benefit by using the support web site to:

l Search for knowledge documents of interest

l Submit and track support cases and enhancement requests

l Download software patches

l Manage support contracts

l Look up HP support contacts

l Review information about available services

l Enter into discussions with other software customers

l Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also
require a support contract. To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html

To findmore information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp
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Disclaimer for PDF Version of Online Help
This document is a PDF version of the online help. This PDF file is provided so you can easily print
multiple topics from the help information or read the online help in PDF format.

Note: Some topics do not convert properly to PDF, causing format problems. Some elements of
online help are completely removed from the PDF version. Those problem topics can be
successfully printed from within the online help.
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Getting Started with Administration Tasks
TheAdministrator Guide provides information on how to perform the administrative tasks related to
all the components of Executive Scorecard.

Getting Started with administrative tasks:

l Understand the login, password and tab access issues. For details, see "Login" on page 13.

l Understand the LW-SSO, Identity management SSO, logs, Web server, cryptography,
Supervisor, and working with Xcelsius. For details, see "General Information" on page 18.

l Understand the Start menu. For details, see "Start Menu" on page 26.

Manage Licenses. For details, see "Manage Licenses" on page 29.

l Manage users, roles, and resources. For details, see "Perform Administration Tasks for
Users and Roles" on page 32.

l Configure Foundation, pages, Single Sign On, and Website settings. For details, see
"Perform Administration Tasks for Foundation" on page 61.

l Configure Dashboard Settings, Score thresholds, XS settings and engine settings. For
details, see "Perform Administration Tasks for Scorecard Settings" on page 67

l Configure the Executive Scorecard module settings. This includes adding additional pages
to Dashboard, setting the permissions for the pages, user permissions in Dashboard, specifying
themaximum number of pages, and showing/hiding debug properties. For details, see "Perform
theMaintenance of the Executive ScorecardModule" on page 74.

l Perform the operation and maintenance of the IT Financial Management module. For
details, see "Perform theMaintenance of the IT Financial Management Module" on page 76.

l Manage the Semantic Layer (Business Contexts and Universes). This includes information
about SAP BusinessObjects universes, out-of-the-box Contexts, user-defined Contexts and
explains how to Import Data from Static Files using Context Designer. For details, see "Manage
the Semantic Layer (Contexts and Universes)" on page 78.

l Import and Export KPIs, Pages, Components, Events, and Trees. For details, see
Information about Executive Scorecard KPI tree import and export is provided in "Export and
Import KPIs, Pages, Components, Events, and Trees" on page 114.

l Manage Contexts and KPIs. This section provides information about adding components to a
page in Dashboard to provide reports about the KPI templates currently in the KPIs Library,
Contexts currently in Executive Scorecard, the structure of Contexts, the list of KPIs included in
a Context, and a list of the fields with names include a specific string that are part of a Context,
or that are used in a specific KPI formula. For details, see "Manage Contexts and KPIs" on page
102.

l Localize and Globalize IT Executive Scorecard. For details, see "Localize andGlobalize
Executive Scorecard" on page 129.
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l Manage Content Acceleration Packs. Content Acceleration Packs are used for Proof of
Concepts (POCs) sessions or to start creating your own application. For details, see "Manage
Content Acceleration Packs Using CAP Management" on page 133. You can also create your
ownCAP using existing Dashboard pages, Contexts, Scorecards, KPIs, Metrics, and Data
(.CSV files). For details, see "Create Content Acceleration Packs" on page 146.

l Create categories for the Webi reports. Categories are used to classify the different Webi
reports in the list of reports to be added to a component in Dashboard. For details, see "Create
Categories for theWebi Reports" on page 157.

l Configure Data WarehouseSettings. Information about DataWarehouse configuration is
provided in "Configure DataWarehouse Settings" on page 160.

l Integrate the Data Sources. This section provides information about the Data Source
Management User Interface and a sample data source integration. For details, see "Integrate the
Data Sources" on page 170. The complete integration procedures are available in theContent
ReferenceGuide.

l Manage the ETL. Information about the ETLManagement UI is provided in "Perform Tasks for
ETLManagement " on page 175.

l Use Entity Relationship Tools. For details, see "Use Enterprise Readiness (ER) Tools" on
page 191

l Perform Tasks for Data Source Management. Information about the Data Source
Management UI is provided in "Perform Tasks for Data SourceManagement" on page 197.

l Perform Administration Tasks for the Back-end. Information about administration tasks that
need to be performed in IT Executive Scorecard and IT Financial Management is provided in
"General Information" on page 18.

l Perform the backup tasks. This includes the backup tasks (Executive Scorecard, and Data
Warehouse back ups).
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Login
You access the IT Executive Scorecard application using a supportedWeb browser, from any
computer with a network connection (intranet or Internet) to the servers. Currently Microsoft
Internet Explorer 9 is supported. It is recommended to restore your browser settings to default.

The level of access granted to a user depends on the user’s permissions. For details, see "Manage
Users" on page 32.

You can initially access the Admin tab through the IT Executive Scorecard login page, using your
administrator username and password, created during installation.

Access the login page as follows:

l http://<full resolution host>:<port>/xs. If you are using a non-default port youmust update it
in the URL. For details, see "Web Server" on page 24.

l If you are using a default http port, the port can remain empty.

The Admin tab is configured by default with Lightweight Single Sign-On (LW-SSO). LW-SSO
enables you to log in and automatically have access to LW HP applications, without needing to log
into those applications. For details, see "LW-SSO " on page 18.

Access Tabs
You access the following tabs from themain login page:

l IT Executive Scorecard Dashboard

l Finance

l Admin

l Explorer

l Studio

Note: Only users with the required permissions can view specific tabs.

When you have completed your session, it is recommended that you log out to prevent
unauthorized entry.

To access the IT Executive Scorecard login page and all tabs:

1. In aWeb browser, enter the http://<server_name>.<domain_name>/XS URL for the fully
qualifiedmachine where XS is installed.

2. Enter the login parameters (login name and password) of a user, and click Log In. After a
successful login, the user name appears at the top right of the page of the application.

3. Close the original login window once the application has loaded.
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4. Click the Admin tab to navigate the admin pages. Only users with the required permissions can
view the Admin tab.

Note: To log in for the first time, use your administrator password created during installation.

User Authentication
User authentication depends on your configuration. For details, see "Users and Authentication
when working with or without SAP BusinessObjects and LDAP" on page 33.

User Passwords
Passwords can be changed in theUser Details pane of the User Management page. Click Edit
Details to change a user's password. For details, see "Manage Users" on page 32.

Note: Depending on your configuration (working with or without SAP BusinessObjects and
with or without LDAP), the handling of the password can be different. For details, see "Users
and Authentication when working with or without SAP BusinessObjects and LDAP" on page
33.

A passwordmust contain the following:

l At least 6 characters.

l Characters in upper and lower case.

l Must be different from username.

Note:

l Login parameters are case-sensitive.

l If a password does not follow the correct conventions then the user is still created in SAP
BusinessObjects Enterprise, however the password is not valid andmust be changed.

Working with Secure Sockets Layer (SSL) in a
Distributed Environment

When you log in to the IT Executive Scorecard application using the http or https format in a
distributed environment, the following scenarios can occur:

1. When you use the http format to access the Executive Scorecard application, the
authentication transfers you to the DataWarehouse application. A message states that a
security certificate is issued. Click theContinue to this website link. In the DataWarehouse
page, click the Certificate Error button in the browser toolbar. In the Certificate dialog box that
opens, click theView Certificate link. In the wizard that opens, select thePlace all
certificates in the following store, select the Trusted Root Certification Authorities
location, and click OK. Once you have installed the certificate, and entered your user and
password, the DataWarehouse application transfers you back to the Executive Scorecard
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application.

2. When you use the http format to access directly the DataWarehouse application, amessage
states that a security certificate is issued. Click theContinue to this website link. In the Data
Warehouse page, click the Certificate Error button in the browser toolbar. In the Certificate
dialog box that opens, click theView Certificate link. In the wizard that opens, select the
Place all certificates in the following store, select the Trusted Root Certification
Authorities location, and click OK. Once you have installed the certificate, and entered your
user and password, the DataWarehouse application opens.

3. When you use the https format to access the Executive Scorecard application, the security
certificate issue is displayed. Click the security certificate. In the Certificate dialog box that
opens, click theView Certificate link. In the wizard that opens, select thePlace all
certificates in the following store, select the Trusted Root Certification Authorities
location, and click OK. Continue running the wizard. This warningmessage is not displayed
again. The DataWarehouse application opens in SSL mode. After performing the log in
operation, you can add the Executive Scorecard certificate in the successfully launched
Executive Scorecard application page, not in the application page itself. When the Java
security warning contains the correct publisher (Hewlett-Packard Company) you should
accept the Java security warning by marking theAlways trust content from this publisher
check box in order for this popup not to be displayed again.

4. When you use the https format to access directly the DataWarehouse application, amessage
states that a security certificate is issued. In the Certificate dialog box that opens, click the
View Certificate link. In the wizard that opens, select thePlace all certificates in the
following store, select the Trusted Root Certification Authorities location, and click OK.
This warningmessage is not displayed again. The DataWarehouse application opens in
SSL mode. When the Java security warning contains the correct publisher (Hewlett-Packard
Company) you should accept the Java security warning by marking theAlways trust
content from this publisher check box in order for this popup not to be displayed again.

Note:When you use the https format and you want to access SAP BusinessObjects
Enterprise reports, the reports are displayed using the http format.

Logout
To logout:

You can log out using one of the following:

l Click Logout (in the top right corner of the application). The session closes. To log in again, you
must provide the user and password.

l Click X (in the top right corner of the application). The session stays alive for one hour. To log in
again, you do not have to provide the user and password.

Shared Secret Key
Executive Scorecard functionality requires a connection to SAP BusinessObjects Enterprise
through a trusted authentication. In order to configure the trusted authentication policy youmust
define the shared secret key.
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The shared secret key, created in the post-install process, is used by the client and the CMS to
create the trusted authentication password. This password is used to establish trust.

Note: To change the shared secret key youmust change the key in SAP BusinessObjects
Enterprise, run the post-install wizard and enter the new shared secret key. For details, see the
IT Executive Scorecard Installation and Configuration Guide.

Glossary

A

ABC

Audit, Balance, and Control (ABC) is an application that triggers the ETL processes. Audit
ensures consistency during ETL processing. It measures the number of records in and the
number of records out for each step and displays these runtime statistics in a collection of
audit reports. Balance verifies that data in the data warehousematches data in the source
system. For example, if the data warehouse stores project dollar amounts then the balance
process verifies that the aggregate project dollars in the data warehousematches the
aggregate project dollars in the source application data. Control governs ETL processes.
Control makes sure that there is a proper restart and recovery when a system error occurs.
Control alsomanages job dependencies at runtime.

Activity Based Costing (ABC)

The ABC methodology assigns an organization's resource costs through activities to
the products and services provided to its customers.

D

Dimension

An entity that describes, qualifies, or otherwise adds meaning to themeasurements (facts)
that business users want to analyze.

E

ETL (Extract Transform Load)

E - The extract process extracts delta data from the source systems and writes it to delimited
flat files on the file system. The data warehouse uses the Change Data Capture (CDC)
technique for extracting data from the source tables. T - During the transformation process,
FPA transforms data into the format of the target tables and populates the load-ready target
staging tables. The Transformation layer contains load-ready tables that match the internal
structure of the data warehouse target tables. L - The load process adds new records,
updates existing records, and flags deleted records in the data warehouse target layer fact
and dimension tables.
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M

Measure

A value collected by the executable during execution, such as the number of rows processed
during an ETL job, or an amount extracted from a table that describes expenses in a source
application. The ABC application does not make any assumptions about the business tasks
performed by the executable or impose any semantic requirements on computedmeasure
values. The ABC application provides an interface for the executable to storemeasures. The
ABC reports provide drill down capabilities into the storedmeasures.

Metadata

Agreed-upon definitions and business rules stored in a centralized repository to ensure that
business users use common terminology for key business terms.

Metric

A framework to establish and collect measurements of success or failure on a regulated,
timed basis that can be audited and verified.

Multi-Dimensional

The aggregation of data by the dimensions of the business. For example, sales by region by
product by time.

HP IT Executive Scorecard (9.31)Page 17 of 282

Administrator Guide



General Information
The following sections contain general information pertaining to the administration of Executive
Scorecard , IT Financial Management, and the DataWarehouse.

LW-SSO
HP Lightweight Single Sign-On is amethod of access control that enables you to navigate to other
HP products that implement LW-SSOwithout supplying credentials again. A user can log on once
and gain access to the resources of HP software systems without being prompted to log on again.
The applications inside the configured group of software systems trust the authentication, and there
is no need for further authentication whenmoving from one application to another.

Use the Identity Management Single Sign-On
Identity Management Single Sign-On (IDM-SSO) is amethod of access control that enables you to
navigate to other HP products without supplying credentials again. A user can log on once and gain
access to the resources of HP software systems without being prompted to log on again. The
applications inside the configured group of software systems trust the authentication, and there is
no need for further authentication whenmoving from one application to another.

Learn about Identity Management
You implement Identity Management Single Sign-On (IDM-SSO) if you want amore secure
connection than that offered by LW-SSO, or if the applications configured outside of Executive
Scorecard do not support LW-SSO. The IDM server is monitored by a single center Policy Server,
and consists of a User Repository, a Policy Store (both could reside over the same server as the
Policy Server), and aWeb Server Agent installed over each of the application's web servers
communicating with the Policy Server. The IDM server controls users' access to various
organizational resources, protecting confidential personal and business information from
unauthorized users. For details, see your IDM vendor's documentation.

Executive Scorecard requires the IDM vendor to store user information to render it available as a
header on http requests.

Before configuring IDM-SSO in Executive Scorecard, make sure you see your IDM login dialog
before the BSM login screen.

If you do not see it, work with your IDM administrator. If the same LDAP was defined in Executive
Scorecard as used by IDM, you should be able to authenticate through both the IDM and Executive
Scorecard login screens using the same credentials. If not, verify that LDAP settings in Executive
Scorecardmatch those used by IDM. Now you are ready to configure IDM-SSO in Executive
Scorecard. If you need help dumping headers in order to determine the correct IDM header to use in
configuration, you can return to the Executive Scorecard login screen without closing the session
and append /DumpSession.jsp to the login URL. Look for your user login ID in the resulting list.
Before it should be the header name supplied by IDM. You can verify it using http://<HPBSM
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server>/topaz/verifyIDM.jsp in the same user session. Once it is verified as correct, you should
be able to use it in the AuthenticationManagement wizard.

Configure to use IDM-SSO
To use IDM-SSO to authenticate the users of the Executive Scorecard application, proceed as
follows:

1. Make sure that IDM is linked to the user repository (LDAP) and that these users are users of
SAP BusinessObjects Enterprise.

2. Make sure that at least one user in IDM has an Admin role in Executive Scorecard for
troubleshooting purposes.

3. Install the IDM SSO Agent on both the Executive ScorecardWeb Server and the Data
WarehouseWeb Server. You do not need to install it on the SAP BusinessObjects
Enterprise Web server.

4.  On the IDM server, configure the security by setting the following Uniform Resource
Identifiers (URIs) as protected or unprotected resources as indicated below.
n If you have single server configuration, do the following:

Resource Protected Unprotected

fndwar Yes

bsf Yes

uim Yes

engine Yes

studio-client Yes

dashboard-webapp Yes

fndwar/rs Yes

bsf/rest Yes

dw Yes

dw-web Yes

integrations Yes

n If you have a distributed server configuration, do the following:

Server Resource Protected Unprotected

On the Executive Scorecard server fndwar Yes

bsf Yes

uim Yes
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Server Resource Protected Unprotected

engine Yes

studio-client Yes

dashboard-webapp Yes

fndwar/rs Yes

bsf/rest Yes

On the DataWarehouse server fndwar Yes

bsf Yes

uim Yes

dw Yes

dw-web Yes

integrations Yes

fndwar/rs Yes

bsf/rest Yes

5. For Logoff use the /fndwar/logout.jsp URI on the IDM server.

6. Open the Executive Scorecard application. You will need to provide your credentials twice at
this stage: once in the IDM login page and once in the Executive Scorecard login page.

7. In the Executive Scorecard application, click Admin > Foundation > Single Sign-On.

8. Select ID Management Enabled.

9. Enter the name of the IDM header (the header that contains the user login name) in theValue
field of the ID Management Header setting.

10. Click Save.

11. Log out of the Executive Scorecard application and of the IDM application. Log in again with
the proper user and check that you need to provide your credentials only once.

Logs
IT Executive Scorecard records the procedures and actions performed by the various components
in log files. The log files are usually designed to serve HP Software Support when Executive
Scorecard does not perform as expected. The default severity threshold level for log files differs per
log, but is generally set to eitherWarning or Error.

You can view log files with any text editor.
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Log File Locations
The following tables list the log files created in an Executive Scorecard implementation by
component.

Common Component Log Files

Description Log Filename Location

Records all requests
processed by the
server.

access.log <Installationdirectory>
\agora\webserver\logs

The server error log is
themost important
log file.

This is the place
where Apache httpd
sends diagnostic
information and
records any errors
that it encounters
when processing
requests.
It is the first place to
look when a problem
occurs
with starting or
operating theWeb
Server.

error.log <Installationdirectory>
\agora\webserver\logs

install.log <Installationdirectory>
\agora\webserver\logs

Contains information
about
communications
between theWeb
Server and the
application server
(Glassfish).

jk.log <Installationdirectory>
\agora\webserver\logs

Log records of all
secured requests
processed by the
Web Server.

ssl_request.log <Installationdirectory>
\agora\webserver\logs
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Description Log Filename Location

Logs the post-install
flow. Is useful when
the post-install
configuration wizard
fails.

ConfigWizard.log <Installationdirectory>
\agora\confwizard\log

Logs file parsing
tasks during post-
install configuration
wizard.

FileParser.log <Installationdirectory>
\agora\confwizard\log

Logs application
loading and
permission
enforcement related
to the application
framework.

applicationfw.log <Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

Logs requests for
authentication and
population of user
roles and
permissions.

athN.log <Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

Logs user
management user
interface details.

aui.log <Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

Logs the usage of
SAP
BusinessObjects
services, including
issues locating the
SAP
BusinessObjects
CMS.

bo-services.log <Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

BTOSecurity
Framework (BSF)
server side logs
authentication
information about
authn, LW-SSO, and
user mng.

bsf.log <Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

Logs the usage of
foundation services.

btoe-services.log <Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

HP IT Executive Scorecard (9.31)Page 22 of 282

Administrator Guide



Description Log Filename Location

Logs SAP
BusinessObjects
datalayer
transactions such as
problems with SAP
BusinessObject
Universes or queries.

datalayer.log <Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

Foundation core
components log.

foundation.log <Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

Hibernate log . hibernate.log <Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

JVM general log. jvm.log <Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

Licensing logs. license-
services.log

<Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

Properties table logs. properties.log <Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

General GlassFish
log.

server .log <Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

Settings
management logs

settings.log <Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

Logs authentication
details related to IDM
and LW SSO.

sso.log <Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

User Interfacemash-
up logs.

uim.log <Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

UserManagement
actions log, including
problems with
communication to
SAP
BusinessObjects.

userMng.log <Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

MQBroker service
log.

log.txt <Installationdirectory>
\agora\glassfish\glassfish\domains\domain1
\imq\instances\imqbroker_host1\log
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Executive Scorecard Log Files

Description Log filename Location

Logs all the dashboard’s
server side logs.

dashboard.log <Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

Logs general information
for Executive Scorecard
Studio, the client module
used for tailoring
Executive Scorecard.

studio.log <Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

Logs general information
about the engine, and
KPIs.

engine.log <Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

Provides a summary of
calculation cycles, and
statistics about KPI
engine performance.

engine_
statistics.log

<Installationdirectory>
\agora\glassfish\glassfish\domains\BTOA\logs

Data Warehouse Log Files
Log files can be accessed under:

l datawarehouse\logs

l C:\<Installationdirectory>\agora\glassfish\glassfish\domains\btoa\logs\server.log

All information in the DataWarehouse log files is automatically sent to theWindows Event Viewer
Application log.

To access Data Warehouse log information:

1. On theWindows taskbar, click Start > Administrative Tasks > Event Viewer.

2. ExpandWindows Logs, right-click Application, and then click Filter Current Log.

3. Select the relevant Event Levels, select the relevant Event Sources, and then click OK.

All the DataWarehouse Event Sources begin with the DWH string.

Web Server
IT Executive Scorecard uses the Apache web server for securing the application and caching static
content in order to improve client performance. The web server is installed and configured in the
deployment procedure and does not require any changes or maintenance.

The default ports are listed in the IT Executive Scorecard Support Matrix. If you use a non default
port for the URL, youmust enter the application using http://<host>:<port number>/xs or
http://<host>:<port number>/dwh.

Note: These ports can be configured to any other ports in the deployment procedure.
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Cryptography
The encryption properties files are located in <Installationdirectory>\agora\conf. The path can be
determined by setting the crypt.conf.dir.path system property to the relevant path. The
management database credentials encrypted locally on each server. Youmust also store all the
relevant configuration for decrypting locally.

The following encryption keys are available:

l Encryption Key:Single shared key for all servers shared through the database. Stored on each
machine locally in the encryption properties files as part of the post-install procedure.

l Seed Key:Key that is generated after each post-install procedure. Themain encryption key is
stored in the seed key.

IT Executive Scorecard Supervisor
The HP IT Executive Scorecard Supervisor monitors whether the Executive Scorecard server
processes are up and running.

The Supervisor consists of two elements:

l Themanagement element manages (starts/stops/monitors) theWeb Server, MQ Broker, and
Glassfish components that are services. The Supervisor manages them in the following order:
a. Web Server

b. MQ Broker

c. Glassfish

l The watchdog element monitors processes. If a process is down, the SupervisorWatchdog tries
to start it automatically.

The Supervisor is a service that works onWindows.

Contact HP Software Support Online web site (http://www.hp.com/go/hpsoftwaresupport) if the
monitor cannot start the Supervisor process.

Xcelsius
You can use Xcelsius to display Flash reports or dashboards over Executive Scorecard target
schemas.

You can create Xcelsius reports based on SAP BusinessObjects EnterpriseWebi reports. For
details on the pre-definedWebi reports provided with Executive Scorecard, see Reference: Web
Intelligence Reports andOperational Reports in theContent ReferenceGuide.

You can then add these reports to Dashboard page using the Xcelsius components. For details, see
Add a SWF Report Viewer Component to a Page or Add Xcelsius Reports Viewer Component to a
Page in theBusiness Analyst Guide.

The InstallationMedia for Xcelsius as well as the Xcelsius Installation Guide are provided on a
separate installation disc that you can download (TB812-15009.ISO). The disc also includes non-
core utilities and 3rd party application that enhance Executive Scorecard.
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Start Menu
During the installation, a start menu is added to the settings of themachine on which Executive
Scorecard was installed.

You can use the Start menu to perform the following tasks:

Launch Executive Scorecard Using the Start Menu 26

Renew your License Using the Start Menu 26

Start the Post-Install Wizard Using the Start Menu 27

Enable or Disable the GlassfishWeb Server using the Start Menu 27

Uninstall HP IT Executive Scorecard Using the Start Menu 28

Access the Documentation Library and the Installation and Configuration documents using
the Start Menu 28

Launch Executive Scorecard Using the Start Menu
During the installation, a start menu is added to the settings of themachine on which Executive
Scorecard was installed. You can lainch Executive Scorecard using the Start menu.

Tasks
Launch Executive Scorecard

1. To access the IT Executive Scorecard start menu that is added to eachmachine, select Start
> Programs > HP Executive Scorecard.

2. Select HP Executive Scorecard.

This launches IT Executive Scorecard.

Renew your License Using the Start Menu
During the installation, a start menu is added to the settings of themachine on which Executive
Scorecard was installed. You can renew your license using the Start menu.

Tasks
Renew your license

1. To access the IT Executive Scorecard start menu that is added to eachmachine, select Start
> Programs > HP Executive Scorecard.

2. In the Administration folder, select License Renewal.

The License Renewal wizard opens.
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a. Click Next on the LicenseManagement page.

b. Select Load a permanent or temporary license and click the Load button to browse to
the location of the license file.

c. A validation check runs. After the validation passes, click Next to complete the renewal.

3. Disable HP Executive Scorecard and then enable HP Executive Scorecard on all servers so
the new license can take effect.

Movie: To display themovie, open the XS application in Internet Explorer 9 or Chrome, click
Help in the top right corner of the applicationmain page and select theMovies option. Select
the relevant movie. For details, seeMovies.

Start the Post-Install Wizard Using the Start Menu
During the installation, a start menu is added to the settings of themachine on which Executive
Scorecard was installed. You can start the post-install wizard using the Start menu.

Tasks
Start the Post-Install wizard

1. To access the IT Executive Scorecard start menu that is added to eachmachine, select Start
> Programs > HP Executive Scorecard.

2. Select Configuration Wizard.

Follow the steps in the ConfigurationWizard that opens.

Enable or Disable the Glassfish Web Server using
the Start Menu

During the installation, a start menu is added to the settings of themachine on which Executive
Scorecard was installed. You can enable or disable the GlassfishWeb Server using the Start menu.

Tasks

Enable the Glassfish Web Server Using the Start Menu
1. To access the IT Executive Scorecard start menu that is added to eachmachine, select Start

> Programs > HP Executive Scorecard.

2. Select Enable HP Executive Scorecard.

This enables the GlassfishWeb Server. Users can access IT Executive Scorecard.

Disable the Glassfish Web Server Using the Start Menu
1. To access the IT Executive Scorecard start menu that is added to eachmachine, select Start

> Programs > HP Executive Scorecard.

2. Select Disable HP Executive Scorecard.
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This disables the GlassfishWeb Server. Users cannot access IT Executive Scorecard.

Uninstall HP IT Executive Scorecard Using the
Start Menu

During the installation, a start menu is added to the settings of themachine on which Executive
Scorecard was installed. You can use the Start menu to uninstall IT Executive Scorecard.

Tasks

Uninstall HP IT Executive Scorecard Using the Start Menu
1. To access the IT Executive Scorecard start menu that is added to eachmachine, select Start

> Programs > HP Executive Scorecard.

2. Select Uninstall HP Executive Scorecard.

This uninstalls the IT Executive Scorecard on the server.

IT Executive Scorecard is first uninstalled in silent mode and then the uninstall wizard appears.

Access the Documentation Library and the
Installation and Configuration documents using
the Start Menu

During the installation, a start menu is added to the settings of themachine on which Executive
Scorecard was installed. You can use the Start menu to access the IT Executive Scorecard
Installation and Configuration Guide and theOnline Documentation Library Help Center.

Tasks

Access the HP Executive Scorecard Deployment Guide Using the Start
Menu
1. To access the IT Executive Scorecard start menu that is added to eachmachine, select Start

> Programs > HP Executive Scorecard.

2. Select HP Executive Scorecard Deployment Guide.

This opens the IT Executive Scorecard Installation and Configuration Guide.

Access the Online Documentation Library Using the Start Menu
1. To access the IT Executive Scorecard start menu that is added to eachmachine, select Start

> Programs > HP Executive Scorecard.

2. Select HP Executive Scorecard Documentation Library.

This opens the HP Executive Scorecard Documentation Library Help Center in yourWeb
browser.
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Manage Licenses
This section explains how to renew a license using the Start menu and how to check if all your user
licenses are valid.

To access:
Click Help > About in the upper right corner of the application.

Tasks
This section includes:

"Renew your license using the Start menu" below

"Check users licenses" below

Renew your license using the Start menu
For details, see "Renew your License Using the Start Menu" on page 26.

Check users licenses
You can check if all the users of the application have valid licenses.

1. Prerequisites:

If you are working with LDAP users, make sure you have performed the appropriate
procedures. For details, see "Users and Authentication when working with or without
SAP BusinessObjects and LDAP" on page 33.

2. Get the user license information:

a. Use an authorized HP user to log into the customer’s Executive Scorecard installation.

b. Click Help > About in the top right-hand corner of the application display.

The type of license (temporary or permanent), the number of registered users and the
number of licensed seats are displayed.
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c. Click the number of users to view the details of the users.

When users do not have a valid license, a red icon is added to the right of the Registered
users indication:

Note: An error image to the left of Registered Users and a tooltip indicate if there has
been a breach of contract.
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Perform Administration Tasks for Users and
Roles

This section includes the following topics:

Manage Users 32

Manage Roles 46

Manage Resources 55

Manage Users
The User Management page enables you to add and edit users and groups, as well as add and edit
their details.

To access:
l Select Admin > Users and Roles > User Management to access the User Management

page

l In the User Management Page, click to access the Assign Roles dialog box.

Learn More

Users and Groups
Each user has a list of roles that define their permissions. When you assign a role, that user only
has access to specific portions of the program and specific resources that are relevant to their role.
You can also define groups of users with the same roles or access rights. When you attach a user
or group to a group, the user or group inherits all of the group’s roles.

Roles and Permissions
Each role is associated with permissions. Permissions define which actions the user with a
specific role can perform according to their responsibilities in the organization. For example, you
can create a role that enables its users to create pages.

Diagram
The following diagram illustrates the relationship between users, groups, roles, permissions, and
resources in the Admin tab.
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Users and Authentication when working with or without
SAP BusinessObjects and LDAP

Operation Working
without
SAP BusinessObjects
and without LDAP

Working
with
SAP BusinessObjects
and
without LDAP

Working
with
SAP BusinessObjects
and
with LDAP

Manage
users
(create,
remove,
update)

In Executive Scorecard, in
Admin > Users and
Roles.

Users are created in
Executive Scorecard, in
Admin > Users and
Roles

Users created in
Executive Scorecard are
automatically transferred
to SAP BusinessObjects.

If a user is created in SAP
BusinessObjects, it does
not appear in the list of
users in Executive
Scorecard.

Users are created in
LDAP.

Users created in
LDAP are automatically
transferred to Executive
Scorecard and in SAP
BusinessObjects.
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Operation Working
without
SAP BusinessObjects
and without LDAP

Working
with
SAP BusinessObjects
and
without LDAP

Working
with
SAP BusinessObjects
and
with LDAP

Passwords Passwords can be
changed in theUser
Details pane of the User
Management page in
Executive Scorecard.
Click Edit Details to
change a user's
password.

Passwords can be
changed in theUser
Details pane of the User
Management page in
Executive Scorecard.
Click Edit Details to
change a user's
password.

Password created in
Executive Scorecardis
automatically transferred
to SAP BusinessObjects
for the relevant user.

Passwords are created
and stored in LDAP.

Roles,
permissions,
and groups

In Executive Scorecard, in
Admin > Users and
Roles.

In Executive Scorecard, in
Admin > Users and
Roles.

In Executive
Scorecard, inAdmin
> Users and Roles.

Note:

l The format of the LDAP directory must be either Microsoft Active Directory or SunONE
Directory. It cannot be an arbitrary directory structure.

l When a user is added to LDAP, it is displayed in the Users andGroups tree after you log in
to HP IT Executive Scorecard.

l Whenworking with LDAP, youmust make sure that LDAP is connected to Executive
Scorecard and to SAP BusinessObjects. For details, see "To perform the connection
between LDAP, Executive Scorecard, and SAP BusinessObjects:" on page 36.

Note: Executive Scorecard only supports the LDAP tab with Active Directory as a
server type on that tab. Active Directory authentication via the active directory tab is
not supported. For details, see "Tomake sure you use the LDAP Authentication
Option:" on page 37.

Important Information
Users can bemanaged using either of the following, but not both:

l Enterprise Users:Users are created andmanaged in Executive Scorecard.

l LDAP Users: Users are created andmanaged on your LDAP server which is connected to
Executive Scorecard.
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It is recommended to define roles and resources prior to defining users. For details, see "Manage
Roles" on page 46.

Tasks
This section includes:

"To search for a user:" below

"To add a user:" below

"To add a new group under the root:" below

"To view permissions and resources for specific users:" on next page

"To assign roles to users or groups:" on next page

"To connect XS Executive Scorecard to an LDAP server:" on next page

"To perform the connection between LDAP, Executive Scorecard, and SAP BusinessObjects:" on
next page

"Tomake sure you use the LDAP Authentication Option:" on page 37

To search for a user:
1. Select Admin > Users and Roles > User Management.

2. In theSearch Users tab, enter the search criteria.

3. Click Search. The relevant users are displayed.

To add a user:

Note:When using LDAP for user management, users and groups are read-only from Executive
Scorecard. All user management must be done on the LDAP server.

1. Select Admin > Users and Roles > User Management.

2. In theUsers & Groups tab, select the group under which you want to add a user and click

Add User . The Add user dialog box opens.

3. Enter the relevant details.

To add a new group under the root:

Note:When using LDAP for user management, users and groups are read-only from Executive
Scorecard. All user management must be done on the LDAP server.

1. Select Admin > Users and Roles > User Management.

2. In theUsers & Groups tab, click Add group under the root .

3. Enter theGroup Name andGroup Description and click OK. The group is added under the
root.

HP IT Executive Scorecard (9.31)Page 35 of 282

Administrator Guide



To view permissions and resources for specific users:
1. Select Admin > Users and Roles > User Management.

2. Select a user from theUsers & Groups tab.

3. In theRoles and Permissions area, select a role to view the permissions and resources
associated with the role.

To assign roles to users or groups:
1. Select Admin > Users and Roles > User Management.

2. Select a user or group from theUsers & Groups tab.

3. In theRoles and Permissions area, click Assign role . The Assign Roles dialog box
opens.

4. Select a role from theAvailable Roles list and use the arrows tomove the role to theSelected
Roles list.

5. Click OK to save your selections.

To connect XS Executive Scorecard to an LDAP server:

Note: The format of the LDAP directory must be either Microsoft Active Directory or SunONE
Directory. It cannot be an arbitrary directory structure.

1. In theManagement database, in the SETTINGS_MANAGEMENT table, create a new record
with the following information:

n context: foundation

n name: fnd.uum.type

n value: ldap

2. Configure the LDAP connection properties and the structure of the LDAP directory using the
properties file located at <installation
directory>agora\glassfish\glassfish\domains\BTOA\config\conf\external-ldap.properties.

Note: Only connection properties (such as host, port, LDAP version, user, and password)
and user/group base dn can bemodified.

3. If SSL is used to access LDAP, certificates must be imported.

To perform the connection between LDAP, Executive Scorecard, and SAP
BusinessObjects:
If your configuration includes LDAP, Executive Scorecard, and SAP BusinessObjects youmust
connect:

l LDAP and Executive Scorecard. The connection procedure is described below.

l LDAP and SAP BusinessObjects. The connection procedure is explained in the
documentation of these products.
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Before you canmanage the users using LDAP, perform the connection between LDAP and
Executive Scorecard:

1. In theManagement database, open the SETTINGS_MANAGEMENT table andmake sure that
it includes:
context=foundation, name=fnd.uum.type, value=ldap

2. Provide the location of LDAP to Executive Scorecard. In the external-ldap.properties file
located at <HPXS>\agora\glassfish\glassfish\domains\BTOA\config\conf, enter
information about the server where LDAP is installed (host), the user name, and the password
used to access LDAP.

3. Define groups and users in LDAP. In the external-ldap.properties file located at
<HPXS>\agora\glassfish\glassfish\domains\BTOA\config\conf, use the groupsBase and
userBase keys to set the groups and users DNs.

Note:

n Only the connection properties and the user/group base DN can bemodified. The
structure or attribute name of entries themselves cannot be changed. In addition, the
changes must follow SunOne orMS Active directory standards.

n All the regular Active directory user attributes must be present.

n All users/Groups must be created in advance in your LDAP server (by the LDAP
administrator), as the Executive Scorecard access to LDAP is read-only.

4. After LDAP integration has been configured, you should be able to login to Executive
Scorecard with the LDAP user. However, this user does not have roles and permissions in
Executive Scorecard. To assign roles and permissions youmust run the following script (it
adds the admin role “manually”):
<HPXS ROOT>\agora\glassfish\glassfish\domains\BTOA\config\population\populate-
admin.bat <user_name> <user_login_name> <password> where user_name and user_
login_name are the same.

You should now be able to use the user (that now has Admin permissions) to assign all the
required permissions to other users.

5. If SSL is used to access LDAP, youmust import the relevant certificates.

To make sure you use the LDAP Authentication Option:
1. From theWindows Start menu, click Programs > BusinessObjects XI 3.1 >

BusinessObject Enterprise > BusinessObjects Enterprise Central Management
Console.

2. Log in to the Central Management Console as an administrator.

3. Click Authentication, then click the LDAP tab.

4. 4. Click Start LDAP Configuration Wizard.

5. In theAdd LDAP Host (hostname: port) field, type your host and port information.

6. Click Add.

7. Click Next.
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8. In the LDAP Server Type drop-down list, select your LDAP server, and click Next. This is
where you select the type of server you are using: SunOne or Active Directory.

9. In the Base LDAP Distinguished Name field, type the distinguished name, and click Next.

10. Type the LDAP host credentials:

a. LDAP Server Administration Credentials:Enter the name and password for a user
account that has rights to administer your LDAP server.

b. LDAP Referral Credentials:Enter the same name and password you entered for LDAP
Server Administration Credentials.

11. In theMaximum Referral Hops field, type the number of referral hops to limit forwarding the
credential request. If you set this field to zero, no referral hops are allowed.

12. Click Next.

13. From the Type of SSL authentication drop-down list, select Basic (no SSL) and click Next.

14. From theAuthentication drop-down list, select Basic (no SSO) and click Next.

15. Select the following LDAP options:

a. Create a new account for every added LDAP alias

b. Create new aliases only when the user logs on

c. New users are created as named users

16. Click Next.

17. Click Finish.

UI Description

User Management Page
Click to refresh the page.
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Users & Groups Tab
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Users and
Groups tree

A tree containing all of the existing groups and users attached to those
groups.

To find users that are not attached to a specific group, but are under the
groupEveryone, use theSearch Users tab. For details, see "Search
Users Tab" on page 43.

When a user is added to LDAP, it is displayed in the Users andGroups tree
after you log in to HP IT Executive Scorecard."Search Users Tab" on page
43

Create User. Adds a new user under the selected group. The user inherits
the group’s roles.

Enter the user's Login Name, Display Name, Email, andNew Password
and click OK.

When using LDAP for user management, users and groups are read-only
from Executive Scorecard. All user management must be done on the
LDAP server.
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UI Element Description

Create group. Creates a new group under a selected existing group. The
group inherits the existing group’s hierarchy.

Enter theGroup Name andGroup Description and click OK.

Available Groups

l Administrators. Users who can administer the system.

l Everyone. All users of the system.

Note: The following groups are the default groups available in SAP
BusinessObjects Enterprise and exported to the Admin tab. They are not
applicable to the Executive Scorecard application.

l QaaWS Group Designer

l Report Conversion Group Users

l Test Root

l Translators

l Universe Design Users

When using LDAP for user management, users and groups are read-only
from Executive Scorecard. All user management must be done on the
LDAP server.
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UI Element Description

Add group under the root. Creates a new group under the root.

Enter theGroup Name andGroup Description and click OK.

When using LDAP for user management, users and groups are read-only
from Executive Scorecard. All user management must be done on the
LDAP server.

Attach to group. Attaches the selected user or group to a group. The users
or groups inherit all of the group’s roles.

Select the group and click OK.

When using LDAP for user management, users and groups are read-only
from Executive Scorecard. All user management must be done on the
LDAP server.
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UI Element Description

Detach from group. Detaches the selected user or group from a group.
When you detach a user/group from a group, they no longer have the roles
that they inherited from the group.

When you detach a group from a group, it moves to the "root" of the groups
and users tree.

When using LDAP for user management, users and groups are read-only
from Executive Scorecard. All user management must be done on the
LDAP server.

Delete. Deletes the selected user or group. When a group is deleted, its
users still exist under a system group called Everyone.

When using LDAP for user management, users and groups are read-only
from Executive Scorecard. All user management must be done on the
LDAP server.

Refresh. Refreshes the displayed information.
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Search Users Tab
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Search
Users

The search criteria.

To search for users, enter some or all of the user details: Login Name, Display
Name, Email.

Search Search. Click to search for users that match the criteria entered in theSearch
Users tab.

User Name A list of all users that match the search criteria.

User Details Pane
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Login Name/Group
Name

The name of the selected user or group.

Display Name/Group
Description

The description of the selected user or group.
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UI Element Description

Edit Details Edits the selected user or group details. Enables you to change a user
password.

Roles and
Permissions

The assigned roles and corresponding permissions and environments
for the selected user or group.

Assign role. Opens the Assign Roles dialog box that enables you to
assign a role to the selected user or group.

Remove role. Removes the selected role from the user or group.

Role name The role assigned to the selected user or group.

Permission The permission corresponding to the selected user or group.

Resource The resource attached to the permission of the selected user or group.

N/A. Not Applicable. None of the available resources apply to this
permission.

<Resource Name>. The permission is attached to a specific resource.

All. The permission is applicable to all resources.

For details, see "Manage Resources" on page 55.
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Assign Roles Dialog Box

User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Select a role from theAvailable Roles list and use the arrows tomove
the role to theSelected Roles list.

Available and
Selected Roles

Each user or group can have one or more assigned roles.

Permission details The read-only details about the permissions and corresponding resources
for the selected role.
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UI Element Description

Resource The list of resources for each permission:

l Not Applicable. Used for permissions that do not require a specific
resource setting.

l <Resource Name>. The permission is attached to a specific
resource.

l All. The permission is applicable to all resources.

Manage Roles
You can define user roles and application permissions in the Admin tab. You can also assign
resources to specific permissions.

To access:
Select Admin > Users and Roles > Role Management.

Learn More

Roles and Permissions
Each role is associated with permissions. Permissions define which actions can be performed by
the user with a specific role. For example, you can create a role that enables its users to create
specific pages. In some cases, actions can be performed according to the resource attached to a
permission.

Note: Users that are created in the Admin tab and require permissions to view reports pages,
must be assigned those permissions in SAP BusinessObjects Enterprise.

Resources
A resource is a logical group of one or more pages. Once you define resources, you attach the
resources to a permission. For example, you can specify that the CIO has View permissions for
CIO resources, while the Administrator has View permissions for all resources.

Pre-Defined Roles
l Administrator. The application administrator.

l BUDGET_COORDINATOR. Defines the budget configuration. Notifies the cost center
managers to populate the budget line items, follow up with cost center managers for timely
update of budgets, and review the input from all included cost centers. Publishes the budget to
use in allocation scenarios. This role is related to IT Financial Management.

l FINANCIAL ANALYST. Uses published budgets in allocation scenarios. This role is related to
IT Financial Management.

Pre-Defined Permissions
The following IT Executive Scorecard permissions are available in the Admin tab.

HP IT Executive Scorecard (9.31)Page 46 of 282

Administrator Guide



l ABC Management. Enables the user to monitor andmanage the ETL process for Data
Warehouse.

l Admin Access. Enables the user to access the Admin tab, but not any further pages.

l Administer Pages. Enables the user to view andmodify (add components, delete components,
and even delete) all the pages in the Dashboard. The user can also create new pages.

l Cascade Scorecard. Enables the user to view the small black arrow (near the Scorecard title)
that indicates that the Scorecard has Cascading Scorecards. The user can click the arrow to
display the Cascading Scorecards for which he has permission.
If the user does not have this permission, the small arrow is not displayed and the user does not
know that Cascading Scorecards are available.

l Data Source Management. Enables the user to access the Data SourceManagement page
and activate content packs. The user must haveAdmin Access to view the Admin tab.

l Edit Settings. Enables the user to edit the contents of the Scorecard settings, Foundation
settings, and DataWarehouse settings accordion tabs. The user must haveAdmin Access to
view the Admin tab.

l Explorer Access. Enables the user to access the Explorer tab.

Note: Users with the Explorer Access permission should also have theSelect KPI
permission. The user then gets access to all KPIs in the Explorer page by clicking the
Explorer button.

l Manage Annotation. Enables the user to edit or delete an existing annotation. If the user does
not have this permission, the user can only view the annotation and theEdit andDelete buttons
of the annotation are hidden.

l Manage Page. Enables the user to view andmodify (add components, delete components, and
even delete) the relevant page in the Dashboard. Note that when an additional page is needed a
user with this permissionmust ask a user with theAdminister Pages permission to create the
new page. Once the page is created and assigned to a user, the user can add components, and
modify it.

l Select KPI. Enables the user to view the contents of the Active KPIs area in all the components
filters. The user can alsomove KPIs from the Active KPIs area to the Selected KPIs area. If the
user does not have this permission, the user can, in all the component filters, view the contents
of the Selected KPIs area, cannot modify the selection, and cannot view the contents of the
Active KPIs area as the contents are grayed out.

l Studio. Enables the user to view the Studio tab and tomodify its contents.

l Users and Roles. Enables the user to view the Users and Roles accordion tab. Tomodify the
contents of the Users and Roles accordion tab, the user needs theEdit Settings permission.
The user must haveAdmin Access to view the Admin tab.

l View Settings. Enables the user to view the Scorecard settings, Foundation settings, and Data
Warehouse settings accordion tabs.

l View Page. Enables the user to only view the relevant page in the Dashboard.

l Context Management. Enables the user to use the Context Designer feature.

The following IT Financial Management permissions are available in the Admin tab:
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l Budget. Enables the user to access to Budget Management.

l Finance. Enables the user to access the Finance tab, which includes access to Allocation
Management, Budget Management, and the Cost Explorer.

l Manage allocation scenarios. Enables the user to manage allocation scenarios and view them
using the Cost Explorer.

l Manage consolidated budget. Enables the user to create andmanage the lifecycle of
consolidated budgets.

l Manage cost center budget. Enables the user to manage the cost center budget This
permissionmust be related to a specific cost center instance.

l View consolidated budget. Enables the user to view existing consolidated budgets.

Note:

l Users with theAdminister Pages permission can add pages and control all pages in the
system but they need theSelect KPI permission to configure components on the page.

l Users with theManage Page permission can change and delete specific pages but cannot
create new pages. To create new pages users need theAdminister pages permission.

Important Information
It is recommended to define resources prior to defining roles. For details, see"Manage Resources"
on page 55.

Tasks
This section includes:

"To create a role:" below

"To edit role details:" below

"To attach andmanage permissions:" on next page

"To add a resource to a permission:" on next page

To create a role:
1. Select Admin > Users and Roles > Role Management.

2. In the Roles area, click to create a new role.

3. Enter the name and description for the role.

4. Click OK to save your role.

After creating a role, follow the procedure for attaching permissions and resources.

To edit role details:
1. Select Admin > Users and Roles > Role Management.

2. In the Roles area, select a role.
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3. In the Role Details area, click Edit Details.

4. Edit the role as required and click OK.

To attach and manage permissions:
1. Select Admin > Users and Roles > Role Management.

2. In the Roles area, select a role.

3. In the Role Details area, click . The Assign Permission to Role wizard opens.

4. Select a permission from the list.

5. Attach a resource to the selected permission.

6. Complete the wizard procedure to save your assignments.

To add a resource to a permission:
1. Select Admin > Users and Roles > Role Management.

2. In the Roles area, select a role.

3. In the Permissions list select a permission.

4. Click to open the Assign Resources to Permissions page in the Assign Permission to
Role wizard.

5. Select a permission and use the arrows tomove the required environments from the Available
Resources list to the Selected Resources list.

UI Description

Role Management Page
Click to refresh the page.
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Roles Pane
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI
Element

Description

Create Role. Creates a new role.

Enter theRole Name andRole Description and click OK.

Delete Role. Deletes the selected role.

Click Refresh to refresh the display.

When in Executive Scorecard, when you navigate to another tab and then return to
Admin > Users and Roles, the display is not automatically refreshed. To refresh the

display, click in the toolbar.

<Role
List>

A list of roles currently defined in theAdmin tab. When you select a role, the details
appear in theRole Details area andPermissions list.

For a list of pre-defined roles, see "Manage Roles" on page 46.

Role Details Area
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Role Name The name of the selected role.

Role
Description

The description of the selected role.
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UI Element Description

Edit Details Edits the selected role name and description.

Attach permission. Assigns selected permissions to roles. You select
permissions using the Assign Permission to Role wizard. For user interface
details, see "Assign Permission to RoleWizard" below.

Manage permission.Modifies the selected permission. Opens the Assign
Resources to Permissions page in the Assign Permission to Role wizard. For
user interface details, see "Assign Resources to Permissions Page" on next
page.

Detach permission. Removes the selected permission from the role.

Manage permission.Modifies the selected permission. Opens the Assign
Resources to Permissions page in the Assign Permission to Role wizard. For
user interface details, see "Assign Resources to Permissions Page" on next
page.

Permissions
List

The list of permissions and resources for the selected role.

Permission The permission sets and permissions attached to the selected role.

Resources The list of resources for each permission.

Not Applicable. None of the available resources apply to this permission. For
details, see "Manage Resources" on page 55.

<Resource Name>. The permission is attached to a specific resource.

All. The permission is applicable to all resources.

Assign Permission to Role Wizard
This wizard enables you to assign permissions to the selected role, as well as assign environments

to the permissions. Click to access the wizard.

Wizard
Map

The Assign Permission to Role wizard contains:

Select Permission Page > Assign Resources to Permissions Page > Confirmation
Page.
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Select Permission Page

This pagemay lead directly to the Confirmation page depending on whether the selected
permission has resources attached.

User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

<Permissions
tree>

Select a permission from the tree.

Displays the pre-defined permissions. For details, see "Manage Roles" on
page 46.

Assign Resources to Permissions Page

This page only appears if the permissions are applicable for a resource.

Note: Click to access this page directly.
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User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Permission A tree containing the permissions.

Select a permission and use the arrows tomove the required resources
from theAvailable Resources list to theSelected Resources list.

Available and
Selected
Resources

Each permission can be applicable for specific resources, for all resources,
or not applicable to a resource.
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Confirmation Page

User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Permission The permissions assigned to this role.

Resource The list of resources associated with the each permission.

Add
another

Click to commit the current permission and continue in the wizard to add another
permission. The "Select Permission Page" on page 52 opens.

Finish Click to commit the assigned permissions and finish wizard functions.

Cancel Click to cancel the current assignment. All previous actions in the wizard are still
valid.

Reference

Role Functions
Executive Scorecard and IT Financial Management roles can be assigned any permissions.
Executive Scorecard and IT Financial Management roles are available with the following out-of-the-
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box permissions:

Role Permissions Module

Administrator All Permissions IT Executive Scorecard and IT Financial
Management

BUDGET_
COORDINATOR

Budget

Finance

Manage Consolidated
Budget

Manage Cost Center
Budget

View Consolidated
Budget

IT Financial Management

FINANCIAL
ANALYST

Budget

Finance

Manage Allocation
Scenarios

Manage Consolidated
Budget

Manage Cost Center
Budget

View Consolidated
Budget

IT Financial Management

Manage Resources
The ResourceManagement page enables you to view resource and resource types, as well as
create a resource. You can also select instances or pages that comprise a resource.

To access:
Select Admin > Users and Roles > Resource Management.

Learn More
Resources
A resource is a logical group of one or more pages. Once you define resources, you attach the
resource to a permission.

Instances
An instance is a page that can bemanaged by a user according to the user's permissions.
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Note: Users that are created in the Admin tab and require permissions to view reports pages
must be assigned those permissions in SAP BusinessObjects Enterprise.

Important Information
l Resources are the basis for user and role management. For each user or group, you assign

permissions to perform specific actions on specific resources.

l Actions users can access depend on their roles and permissions.

l Instances are the available pages defined in the system.

Tasks
This section includes:

"To create a resource:" below

"Tomanage instances:" below

To create a resource:
1. Select Admin > Users and Roles > Resource Management.

2. In theResources area, click Create resource to create a new resource.

3. Enter theResource andDetails.

4. Click OK to save your new resource.

To manage instances:
1. Select Admin > Users and Roles > Resource Management.

2. Select a page in theResources area.

3. In the Instances area of theResource Details pane click Add instances to open the
Manage Instances dialog box. Instances are the available pages defined in the system that are
attached to resources.

4. Select the instance from theAvailable Instances list and use the arrows tomove the instance
to theSelected Instances list.

5. Click OK to save your changes.

UI Description

Resource Management Page
Click to refresh the page.
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Resources Pane
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Select a resource and click Create Resource to open the Edit resource details
dialog box and create a new resource of that type.

After you create the new resource, the Resource Details pane opens. For details,
see "Resource Details Pane" on next page.

Delete Resource. Deletes the selected resource.

If the resource is the only resource attached to a permission and that permission
is attached to any roles, deleting the resource detaches the corresponding
permissions from these roles.

Refresh. Refreshes the displayed information.

<Resources
Tree>

Contains the resource types and the resources defined for each type.
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<Right pane>
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Resource type name The name of the selected resource type.

Resource type description The description of the selected resource type.

Resource Details Pane
When you select a resource in theResources pane, the details appear in this pane.

User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Add Instances. Adds pages to the selected resource. Opens theManage
Instances dialog box.

Each resource can have one or more assigned page instances.

In theManage Instances dialog box, select a page instance from theAvailable
Instances list and use the arrows tomove the instance to theSelected Instances
list. For details, see "Manage Instances Dialog Box" on next page.

These instances are the available pages defined in the system.

Remove Instances. Removes the selected instance from the resource.

Description The description of the selected resource.
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UI Element Description

Resource The name of the selected resource.

Edit Details Edits the selected resource name and description.

Resource
Description

The description of the selected resource.

Resource
Name

The name of the selected resource.

Instances List of page instances for the selected resource.

Manage Instances Dialog Box
This dialog box enables you to attach pages to a resource.
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User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Select an instance from theAvailable Instances list and use the arrows
tomove the instance to theSelected Instances list.

Available and
Selected Instances

Each resource can have one or more assigned instances.
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Perform Administration Tasks for Foundation
Foundation settings enables you to define various system settings for the administration of the
product. The Foundations Settings includes the following:

l "Configure Foundation Settings" below. Enables you to configure virtual server settings.

l "Configure Pages Settings" on page 64. Enables you to configure page settings.

l "Configure Single Sign-On Settings" on next page. Enables you to define SSO parameters.

l "ConfigureWebsite Settings" on page 65. Enables you to set the ping time interval.

Configure Foundation Settings
Enables you to configure foundation settings in Executive Scorecard.

To access:
Select Admin > Foundation > Foundation.

Tasks
To configure the page settings:
1. Select Admin > Foundation > Foundation.

2. Click the relevant row and enter the required setting.

3. Click Save to save your settings.

UI Description

Foundation
This page enables you to configure the Pages settings.

Click to refresh the page.
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Foundation Parameters
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Virtual Server URL The URL of the virtual server.

Configure Single Sign-On Settings
The Single Sign-On page enables you to configure Single Sign-On (SSO) requirements.

To access:
Select Admin > Foundation > Single Sign-On.

Learn More
HP Lightweight Single Sign-On is amethod of access control that enables you to navigate to other
HP products that implement LW-SSOwithout supplying credentials again. A user can log on once
and gain access to the resources of HP software systems without being prompted to log on again.
The applications inside the configured group of software systems trust the authentication, and there
is no need for further authentication whenmoving from one application to another.

Important Information
For details on SSO and Identity Management, see "Use the Identity Management Single Sign-On"
on page 18.
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Tasks

To add or change SSO values:
1. Select Admin > Foundation > Single Sign-On.

2. Click the relevant field in theValue column and enter the value.

3. Click Save to save your settings.

UI Description

Single Sign-On Page
This page enables you to configure the SSO settings for login of all HP products.

Click to refresh the page.

Identity Management Single Sign-On Table

UI Element Description

Identity
Management
Enabled

Select the check box and enter the name of the IDM header (the header that
contains the user login name) in theValue field of the Identity Management
Header setting.

For details, see "Use the Identity Management Single Sign-On" on page 18 .

Identity
Management
Header

The name of the IDM header (the header that contains the user login name).
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Lightweight Single Sign-On Parameters
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

LW-SSO Server Domain The domain used for token creation. This value is required in cases
of multi domains.

LW-SSO Token Creation
Key (initString)

The string used as the encryption key for token creation and
validation.

LW-SSO Trusted Hosts -
DNS Domains

The list of trusted DNS domains that allow multi-domain support
(must be separated by commas).

LW-SSO Trusted Hosts -
FQDN

The list of trusted hosts' FQDN that allow multi-domain support
(must be separated by commas).

LW-SSO Trusted Hosts -
IPs

The list of trusted hosts' IPs (including IPv6) that allow multi-
domain support (must be separated by commas).

LW-SSO Trusted Hosts -
Net Bios Names

The list of trusted hosts' net bios names that allow multi-domain
support (must be separated by commas).

Configure Pages Settings
Enables you to configure the Dashboard page settings in Executive Scorecard.

To access:
Select Admin > Foundation > Pages.

Learn More
Formore information about Executive Scorecard pages, see "Configure a Page Layout" in the
Business Analyst Guide.

Tasks

To configure the page settings:
1. Select Admin > Foundation > Pages.

2. Click the relevant row and enter the required setting.

3. Click Save to save your settings.

UI Description

Pages Settings
This page enables you to configure the Pages settings.
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Click to refresh the page.

Pages Configuration Parameters
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI
Element

Description

Max
loaded
Pages

Themaximum number of open pages that are currently loaded in Executive
Scorecard. The options are any valid number or 0 for unlimited.

Max open
pages

Themaximum number of open pages in Executive Scorecard. The options are any
valid number or 0 for unlimited.

Configure Website Settings
TheWebsite page enables you to configure ping time intervals for refreshing the browser
automatically

To access:
Select Admin > Foundation > Website.

Tasks

To set the ping interval:
1. Select Admin > Foundation > Website.
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2. Select the check box to enable the ping feature. De-select the check box to disable the ping
feature. The browser will then time out.

3. Click thePing time interval row and enter the required time in seconds.

4. Click Save to save your settings.

UI Description

Website Page
This page enables you to configure theWebsite settings.

Click to refresh the page.

Timing Parameters
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Enable Session
Keepalive

Select to enable the ping feature.

Ping time interval The amount of time (in seconds) between browser refresh. This ensures
that the application does not time out.

Note: Changes will only take effect in the next login.
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Perform Administration Tasks for Scorecard
Settings

The Scorecard settings enables you to define various HP IT Executive Scorecard settings and
includes the following pages:

l "Configure Dashboard Settings" below. Enables you to set the settings for the Dashboard,
where an executive can view the progress of the required objectives.

l "Configure Score Thresholds" on next page. Enables you to set the score thresholds for the
KPIs in the HP IT Executive Scorecard.

l "Configure XS Settings" on page 70. Enables you to set various scorecard settings. The HP
IT Executive Scorecard is a way tomap and translate complex business information into
something that is understandable to everyone.

l "Configure Engine Settings" on page 72. Enables you to configure settings for the HP IT
Executive Scorecard KPI engine, which performs discovery on data coming from Contexts (data
sources).

Configure Dashboard Settings
Enables you to set the settings for the Dashboard, where an executive can view the progress of the
required objectives.

To access:
Select Admin > Scorecard > Dashboard Settings.

Learn More
Formore Executive Scorecard dashboard information, see "Prepare the Dashboard Display".

Tasks

Set Dashboard Settings
1. Select Admin > Scorecard > Dashboard Settings.

2. Click the row of the relevant setting and enter the value.

3. Click Save to save your settings.

UI Description

Dashboard Settings Page
This page enables you to configure specific dashboard settings.
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Click to refresh the page.

Dashboard Settings Parameters
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Max search results in the filter Themaximum number of search results allowed in the
filter. The default value is 1000.

Number of days annotations are
considered new

The number of days annotations are considered new. The
default value is 7.

Configure Score Thresholds
Enables you to set the score thresholds for the KPIs in the HP IT Executive Scorecard.

To access:
Select Admin > Scorecard > Score Thresholds.

Learn More
Formore score threshold information, see "Learn About KPI Formula and Filter, Threshold, Value,
Trend, and Score" in theBusiness Analyst Guide.

Tasks

Set Score Thresholds
1. Select Admin > Scorecard > Score Thresholds.

2. Click the row of the relevant score threshold and enter the value.
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3. Click Save to save your settings.

UI Description

Score Thresholds Page
This page enables you to configure the score threshold settings for the KPIs in HP IT Executive
Scorecard.

Click to refresh the page.

Score Thresholds Parameters
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

Note: EachScore Max Valuemust be greater than 0 and less than the next one ( Error Score
Max Value <Warning Score Max Value < Good Score Max Value)

UI Element Description

Critical
Score Max
Value

Themaximum value on the KPI scale, below which the value is scored as an
error. KPIs that score values equal to or below this value, receive an error score.

Example: If themaximum error score is 3.3, then a score on the scale from 0 -
3.3 is an error. Default: 3.3

Good Score
Max Value

Themaximum value on the KPI scale, below which the value is scored as good.
KPIs that score values equal to or below this value, receive a good score.

Example: If themaximum good score is 10, then a score on the scale from 6.6 -
10, is good. Default: 10
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UI Element Description

Warning
Score Max
Value

Themaximum value on the KPI scale, below which the value is scored as a
warning.
KPIs that score values equal to or below this value, receive a warning score.

Example: If themaximum warning score is 6.6, then a score on the scale from
3.3 - 6.6, is a warning. Default: 6.6

Configure XS Settings
Enables you to set various scorecard settings.The HP IT Executive Scorecard is a way tomap and
translate complex business information into something that's understandable to everyone.

To access:
1. Select Admin > Scorecard > XS Settings.

Tasks

To configure XS settings:
1. Select Admin > Scorecard > XS Settings.

2. Click the row of the relevant setting and enter the value.

3. Click Save to save your settings.

UI Description

XS Settings Page
This page enables you to configure specific XS settings.

Click to refresh the page.

HP IT Executive Scorecard (9.31)Page 70 of 282

Administrator Guide



Business Context Parameters
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Period Business Context
Name

The business object period context name. The default value is
Period_Universe.

Context Designer Parameters
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Maximum size of
.CSV file (MB)

Themaximum size of a .CSV file that can be imported into the Context
Designer. The default value is 20MB.

Dashboard Update Parameters
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Configuration
Reload rate
(Minutes)

The configuration reload rate in minutes. Changes made in the Studio will be
visible in Dashboard after nomore than the value of theConfiguration Reload
rate (Minutes) parameter, in minutes.

The default value is 5minutes.
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Debug Mode Parameters
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Application Debug Mode Select to activate the debugmode.

 Studio Update Parameters
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI
Element

Description

Meta
Data
reload
rate
(Days)

The number of days after which themeta data is reloaded. If you configure Executive
Scorecard to work with the SAP BusinessObjects Enterprise universes, every X
days (where X corresponds to what you specified inMeta Data reload rate (Days)),
Executive Scorecard reloads all the universes metadata from the SAP
BusinessObjects Enterprise.

The default value is 7 days.

Users
Info
Reload
Rate
(Minutes)

The number of minutes after which user info is reloaded. The default value is 5
minutes.

Configure Engine Settings
Enables you to configure settings for the HP IT Executive Scorecard KPI engine, which performs
discovery on data coming from contexts (data sources).

To access:
Select Admin > Scorecard > Engine Settings.

Tasks

Set Engine Values:
1. Select Admin > Scorecard > Engine Settings.

2. Click the row of the relevant engine function and enter the value in milliseconds.

3. Click Save to save your settings.
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UI Description

Engine Settings Page
This page enables you to configure the engine settings for HP IT Executive Scorecard.

Click to refresh the page.

Engine Settings Parameters
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Engine
Health
Timer

The amount of time inmilliseconds, after which KPI calculations are sent. The
default value is 600,000, which equals 10minutes.
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Perform the Maintenance of the Executive
Scorecard Module

This section includes the following topics:

Add Additional Pages to Dashboard andGrant Permissions 74

Configure User Permissions in Dashboard 74

Modify theMaximum Number of Pages Displayed in the Dashboard 75

How to Show or Hide Debug Properties 75

Add Additional Pages to Dashboard and Grant
Permissions

Users can be granted permissions to perform the following operations on user-defined pages and
components: View page,Manage Page (change and delete specific page) andAdministrate
pages (add pages and full control on all pages in the system).

To create a new page in the Dashboard , contact your administrator. The administrator should:

1. Create the relevant page in HP IT Executive Scorecard. For details, see "Manage Users" on
page 32.

2. Define the page Instance and Resource. For details, see "Manage Resources" on page 55.

3. Give you (the Business Analyst - Dashboard Designer) the needed permissions to update the
page. For details, see "Attach Permissions".

4. Give the relevant user (executive) the needed permissions to view the page. For details, see
"Attach Permissions".

Configure User Permissions in Dashboard
Permissions to work with Dashboard components and pages are defined inAdmin > Users and
Roles > User Management.

The operations that can be defined for a user are dependent on the area within Dashboard, as
follows:

l Predefined Pages. These pages are defined out-of-the-box. They have a pre-defined layout but
entities are not selected. Users with the relevant permissions can select the relevant entities
using the component filters. Depending on their permissions, users can change the component
layout in the page and the selections in the component filters. Note that out-of-the-box pages
cannot be deleted. More information about the permissions is available in "Attach Permissions".
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l User Pages and User Components. Users can be granted permissions to perform the
following operations on user-defined pages and components: View page,Manage Page
(change and delete specific page) andAdministrate pages ( add pages and full control on all
pages in the system).

For details, see "Manage Users" on page 32.

Modify the Maximum Number of Pages Displayed
in the Dashboard

Themaintenance of HP IT Executive Scorecard is performed using the Admin tab.

By default, an unlimited number of pages can be open at the same time.

If you havemultiple pages open, up to 5 of themost popular pages are immediately available for
display when you switch to them.

The other pages are least viewed pages, meaning that are silently deactivated in the background.
When you select them, it might take a few seconds until they load and display their content.

This section describes how tomodify these limits. Note that if you increase these limits,
performancemay be impaired.

Modify the maximum number of open pages
Tomodify themaximum number of open pages:

1. Select Admin > Foundation > Pages.

2. Modify theMaximum number of open pages entry as needed.

For details, see "Perform Administration Tasks for Foundation" on page 61.

Note that if you increase themaximum number of pages, performancemay be impaired.

Modify the maximum number of active pages
Tomodify themaximum number of active pages:

1. Select Admin > Foundation > Pages.

2. Modify theMaximum number of loaded pages entry as needed.

For details, see "Perform Administration Tasks for Foundation" on page 61.

How to Show or Hide Debug Properties
Themaintenance of HP IT Executive Scorecard is performed using the Admin tab.

To display or hide the debug properties (ID and Type) displayed in the Configuration details tab for
all templates or active nodes, select Admin > Scorecard > XS Settings > Debug Mode, and:

l Select theApplication Debug Mode option to display the debug information in the
Configuration details tabs.

l Clear theApplication Debug Mode option to hide the debug information in the Configuration
details tabs.
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Perform the Maintenance of the IT Financial
Management Module

Enables you to configure the settings for the IT Financial Management module.

To access:
Select Admin > ITFM > ITFM.

Tasks
"Configure ITFM Settings" below

"Configure ITFM Users, Roles, and Permissions" below

"Change the Currency of the ITFM " below

Configure ITFM Settings
1. Select Admin > ITFM > ITFM.

2. Click the row of the relevant setting and enter the value or select the option.

3. Click Save to save your settings.

Configure ITFM Users, Roles, and Permissions
Roles and permissions for users is managed through the Admin tab, enabling you to specify
permissions for each role. Additionally, you can attach instances to a permission, so that the user
can only access certain budgets or allocations. This model is based on:

l The permissions of each user, instead of relying on the user’s roles. The permissions are final
and cannot bemodified or deleted, allowing the flexibility to grant users access to different ITFM
features, while assigning them to different roles.

l Budget related operations according to each user’s scope (instance level permissions).

Two out-of-the-box roles are available: BUDGET_COORDINATOR and FINANCIAL_ANALYST.
For details, see "Manage Roles" on page 46.

Change the Currency of the ITFM
The default currency for all IT Financial Management KPIs is $.

During the post-installation process, if you have changed the currency in theData Warehouse -
Currency Configuration page of the post-install wizard, youmust change the currency in each
one of the KPIs tomatch your selection, as follows:

1. In the application, click Studio.

2. In the Active KPIs pane, for each KPI under the Financial Planning Analysis Scorecard,
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and in theConfiguration details tab, select the relevant unit in theUnit drop down list.

3. Click Save.

UI Description
ITFM Page
This page enables you to configure specific IT Financial Management-related settings .

Click to refresh the page.

User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Interval to clear
FPA cache

Specifies how long the system should save the objects loaded from the
database during the allocation scenario calculations.

Note: Do not modify this parameter.

Polling interval for
FPA's process new
data monitor

Specifies the execution interval of the IT Financial Management
procedure that checks whether new data was loaded using ETL, and
recalculates allocation scenarios accordingly.

Note: Do not modify this parameter.
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Manage the Semantic Layer (Contexts and
Universes)

Executive Scorecard semantic layer includes contexts and universes.

The Context Designer feature enables you to create andmanage Contexts (universes). The
universes can be based on your target schema tables or on .CSV files that can be uploaded to the
target schema using the Context Designer.

Context Designer can be used when you want to work with the Executive Scorecard and IT
Financial Management applications without using DataWarehouse and SAP BusinessObjects
Enterprise. It is a direct way to upload data into the Executive Scorecard Studio using files without
performing integrations to external sources or to other HP products. It can be used, to integrate third
party data, testing, or for Proof of Concept (POC) sessions. It can also be used as a component of
Executive Scorecard to integrate third party data.

Context Designer provides KPI results based on your real data.

For details, seeManage the Semantic Layer (Contexts and Universes) in theAdministrator Guide.

Semantic Layer - Create and Manage Contexts
Using Context Designer and Upload Data Using
Data Loader

The Context Designer feature enables you to create andmanage Contexts (universes). The
universes can be based on your target schema tables or on .CSV files that can be uploaded to the
target schema using the Context Designer.

Context Designer can be used when you want to work with the Executive Scorecard and IT
Financial Management applications without using DataWarehouse and SAP BusinessObjects
Enterprise. It is a direct way to upload data into the Executive Scorecard Studio using files without
performing integrations to external sources or to other HP products. It can be used, to integrate third
party data, testing, or for Proof of Concept (POC) sessions. It can also be used as a component of
Executive Scorecard to integrate third party data.

Context Designer provides KPI results based on your real data.

To access:
1. In Executive Scorecard, click Admin > Semantic Layer > Semantic Layer. The Context

Management page opens. If not , click Data Loader. For details, see "Context Designer Page"
on page 86.

2. In the Context Designer page that opens:
n To create a new context, click Create a new context.

n To edit a context, click Open an existing context.

n To import data into Executive Scorecard, click Add Table. TheRepository area opens,
and then click Add to open the Import Wizard.
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Learn More

Semantic Layer (Context and Universe)
A semantic layer is a business representation of corporate data that helps end-users access data
autonomously using common business terms. It maps complex data into familiar business terms
such as product, customer, or revenue to offer a unified, consolidated view of data across the
organization. By using common business terms, rather than data language, to access, manipulate,
and organize information, it simplifies the complexity of business data. These business terms are
stored as objects in a Business Context (or universe), accessed through business views. Business
Contexts enable business users to access and analyze data stored in a relational database and
OLAP cubes. This is claimed to be core business intelligence (BI) technology that frees users from
IT while ensuring correct results.

Business Views is amulti-tier system that is designed to enable companies to build comprehensive
and specific business objects that help report designers and end users access the information they
require. Business Views is intended to enable people to add the necessary business context to their
data islands and link them into a single organized Business View for their organization.

A Context or universe is a business representation of an organization's data that helps end-users
access data using common business terms. A Context is the result of a semantic layer of metadata
that creates a business oriented view of the data. A Context contains a schema of the tables that
make up the dimension andmeasurement objects. A Context is an interface between the data
warehouse and the analytics that display the data.

Context aremade up of objects and classes that aremapped to the source data and are accessed
through queries and reports. They correspond to the business contexts used in HP IT Executive
Scorecard.

Each Context includes classes (entities), objects with a dimension attribute, and relationships
between the entities. The entity's values are used in the calculation of values and statuses of the
Key Performance Indicators (KPIs) or Metrics that represent them. The KPIs or Metrics are the
building blocks used by the HP IT Executive Scorecard engine and the Studio.

Executive Scorecard Semantic Layer may include:

l Universes created in SAP BusinessObjects. For more details on universes, see the relevant
SAP BusinessObjects documentation.

l Out-of-the-box Contexts created using the Context Designer.

l User-defined Contexts created using Context Designer and populated with data uploaded from
.CSV files using Context Designer. For details on the Context Designer, see "Semantic Layer -
Create andManage Contexts Using Context Designer and Upload Data Using Data Loader" on
previous page.

If you want to change the formula of a KPI or Metric , youmust be aware of the relationships in the
context (universe) of the KPI or Metric. For details, see KPI andMetric Library in Excel format.

The contexts, entities, and dimensions that are displayed and used in the Studio are part of the
universes that are located in theXS_Studio library.

Context or Universe Contents
A Context (or Universe) is a set of entities. Each entity is a set of fields. Each field can be a
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dimension, measurement, or fact that can provide information about the business.

A formula calculates, for a specified time period, using the values of specific entities, a value that
represents a specific aspect of the business. The value is assigned to a Key Performance Indicator
(KPI) so that the KPI represents a specific aspect of the business.

Each Context includes some KPIs. The KPIs are the building blocks of the Studio and the
KPI engine.

These entities that are used in the calculation of the KPIs are provided by the relevant integrated
data source. Each data source corresponds to a specific Content Pack that provides the
connection between the data source and Executive Scorecard.

For more information about the KPIs, Contexts, Metrics, andmore, see "Getting Started" in the
Content ReferenceGuide.

Out-of-the-Box Contexts
You can only addmore tables and entities to an out-of-the-box Context, you cannot remove or
change the original elements.

Tasks
This section includes:

"View existing out-of-the-box Contexts (universes)" below

"Create a Context and use its contents in the Studio" on page 82

"Semantic Layer - Create andManage Contexts Using Context Designer and Upload Data Using
Data Loader" on page 78

"Load the Context and verify the variables and entities" on page 83

"Export Contexts" on page 85

"Import Contexts" on page 86

View existing out-of-the-box Contexts (universes)
1. In Executive Scorecard, click Admin > Semantic Layer > Semantic Layer. The Context

Management page opens.

2. The list of out-of-the-box Contexts is displayed.
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3. Click Launch Context Designer.

4. In the Context Designer page that opens, click Open an existing context.
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5. Select the relevant Context.

The structure of the Context is displayed.

Create a Context and use its contents in the Studio
1. Create a new Context

a. In Executive Scorecard, click Admin > Semantic Layer > Semantic Layer.

b. In the Context Management page, click Launch Context Designer.

c. Click New. The Context Designer page opens.

d. Enter the name of the Context .
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e. Click Add Table. TheRepository area opens. You can use:
o Tables from theExternalTables list. These tables are created from external tables in

CSV format that are uploaded to Executive Scorecard. For details on how to upload a
CSV table, see "Semantic Layer - Create andManage Contexts Using Context
Designer and Upload Data Using Data Loader" on page 78. After the table is uploaded,
a corresponding table named ext.<csv_table_name> is listed in theExternalTables
list.

o Internal tables from the InternalTables list.

If you are working with Enterprise Executive Scorecard, the tables listed in the
InternalTables list are the DataWarehouse tables, the Period tables created during the
post-install procedure, and the View table.

f. Drag the relevant tables from theRepository to theScheme area.

g. Define the relationships between the tables by dragging a specific column from one table
and dropping it over the relevant column in another table. A visual link is added to the graph
to indicate the relationship.

h. Drag the relevant tables from theScheme area to theEntities pane. The tables become
variables and the columns become the variable entities that can be used to create KPI or
Metric formulas when a KPI or Metric is assigned the Context in the Studio.

i. Save the Context

2. Load the Context and verify the variables and entities
a. In Executive Scorecard, click Studio.

b. Activate a KPI or aMetric or clone any active KPI or Metric that does not have a KPI
Breakdown or BreakdownMetric. For details, see Activate Scorecards, Perspectives,
Objectives, Metrics, or KPIs Using Templates or Create Active Scorecards, Perspectives,
Objectives, Metrics, or KPIs in theBusiness Analyst Guide.

c. Click theCalculation details tab, and click Select business context. For details, see
Configure a KPI or aMetric in theBusiness Analyst Guide.

d. In the Business Context dialog box, change its Context to the new Context (ext.<csv_
table_name>).

e. You can thenmodify the formula that is used to calculate the KPI or Metric status by
selecting the variables that correspond to the entities and fields that were defined in the
Context Designer. To do that click Open Formula Builder.

f. In the Formula Builder dialog box, verify that the variables correspond to the tables you
selected in the Entities area in the Context Designer, and that the entities of the variables
correspond to the selected columns of those tables. Click OK to save the KPI.
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Note: In the sameway, you canmodify the Filter of the KPI or Metric to use the
variables corresponding to the .CSV file-based Context (universe).

Upload Tables in .CSV Format to the Tables Repository
You can upload data into the Studio using .CSV files and without integration to external sources or
to other HP products. It can be used to integrate third party data sources, testing, or for Proof of
Concept (POC) sessions. You can, in the sameway, replace the data in an existing table, or add
data to an existing table when the table has been loaded using a .CSV file.

To upload data from the .CSV file into the Studio:
1. Create the .CSV file containing the data you want to use in the Studio (for

example: latest.CSV).

Recommended:CSV tables should have unique names across all active Content
Acceleration Packs (CAPs). For details on CAPs, see "Create Content Acceleration
Packs" on page 146.

2. In Executive Scorecard, click the Admin > Semantic Layer > Semantic Layer.

3. In the Context Management page, click Launch Context Designer.
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4. Click Add Table. TheRepository area opens.

5. Click Add to open the Import Wizard (data loader). Follow the steps to upload the .CSV file.
For details, see "Semantic Layer - Create andManage Contexts Using Context Designer and
Upload Data Using Data Loader" on page 78.

6. Click theUpload data file button.

The file is uploaded. The upload operation saves the changes youmade to the .CSV file. The
new table appears in the External Tables area.

Update a Context
1. In Executive Scorecard, click Admin > Semantic Layer > Semantic Layer. In theContext

Management page, click Launch Context Designer. The Context Designer page opens. For
details, see "Context Designer Page" on next page.

2. Select the relevant Context.

3. Make the relevant changes: delete or add entities, fields, tables, columns, or relationships.

4. Click to save the Context.

5. Load the Context and verify.

Export Contexts
Each <universe_name>.xml file includes the relevant Context information. They are located in the
<XS_server>\agora\glassfish\glassfish\domains\BTOA\config\context\export_<tenant_
ID> folder. If a file with this name already exists in the folder, the name is changed to <universe_
name><n>.xml.

1. Make sure you have JDK installed.

2. Run jconsole in the <XS_server>\agora\jdk\bin.

3. In the window that opens, select theRemote Process option, enter <host_name>:<port_
number> and click Connect.

4. After the application completes its loading, click theMBeans tab.

5. Click com.hp.btoe.xs2go.jmx.

6. Click theExportForTenant button. This imports all the Context XML files that were in the load
folder. The format is ExportForTenant (p1,p2)where p1 is the universe name and p2 is the
tenant id.

n If the import operation is successful, themessageMethod successfully invoked is
returned, and the imported Contexts are displayed inAdmin> Context Designer
> Launch Context Designer.

n In addition, the XML file is moved to the
<XS_server>\agora\glassfish\glassfish\domains\BTOA\
config\export\loaded\ folder.

n If the import operation fails, an explanation of the failure is added in the relevant file in the
<XS_server>\agora\glassfish\glassfish\domains\BTOA\
config\export\errors\ folder.
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Note that themessageMethod successfully invokedmight be displayed in some cases in
case of failure of the export operation.

Note:  If information is missing from the Load directory, part of the export operationmight
not be performed.

Import Contexts
1. Save the Context XML files to the <XS_server>\agora\glassfish\glassfish\domains\BTOA\

config\context\import\load\ folder.

2. Make sure you have JDK installed.

3. Run jconsole in the <XS_server>\agora\jdk\bin.

4. In the window that opens, select theRemote Process option, enter <host_name>:<port_
number> and click Connect.

5. After the application completes its loading, click theMBeans tab.

6. Click com.hp.btoe.xs2go.jmx.

7. Click the ImportForTenant button. This imports all the Context XML files that were in the load
folder.

n If the import operation is successful, themessageMethod successfully invoked is
returned, and the imported Contexts are displayed inAdmin> Context Designer
> Launch Context Designer.

n In addition, the XML file is moved to the
<XS_server>\agora\glassfish\glassfish\domains\BTOA\
config\context\import\loaded\ folder.

n If the import operation fails, an explanation of the failure is added in the relevant file in the
<XS_server>\agora\glassfish\glassfish\domains\BTOA\
config\context\import\errors\ folder.

Note that themessageMethod successfully invokedmight be displayed in some cases in
case of failure of the import operation.

Note:  If information is missing from the Load directory, part of the import operationmight
not be performed.

UI Description

Context Designer Page
The Context Designer page enables you tomanage the Contexts that you create using the Context
Designer feature.
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User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI
Element

Description

Click to display a list of existing Contexts created in the Context Designer. Select the
relevant Context and click OK.

Click to create a new Context. The Context Designer Wizard opens. For details, see
below.

Context Designer Wizard
The Context Designer wizard enables you to create a Context with tables, entities, and
relationships. Once you have completed the Context, save it. The Context is then added to the list
of Contexts available in the Studio. The tables that compose the universe are added as variables
and the table columns as variable entities. The variables and entities can be used to calculate the
formulas for the KPIs that are assigned the Context. For details, see Configure a KPI or aMetric in
theBusiness Analyst Guide.
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This page enables you to configure a Context.

Context Designer Toolbar
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI
Element

Description

New. Click to create a new Context.

Save. Click to save the currently opened Context.
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Open. Click to display a list of existing Contexts created in the Context Designer.
Select the relevant Context and click OK.

Add table. Click to add tables in CSV format to the Repository. The data loader
wizard opens. For details, see "Content Loader" on page 93.

Click to validate the Context. The validation checks if the name of the Context is
unique, if all the tables in the Context exist in the Repository, andmore.

When you click the Save button, the Context is validated. An invalid Context is
not saved.

Context Area
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI
Element

Description

Context
name

The name of the Context.

Limitation: SAP BusinessObjects Enterprise Universe names should not
duplicate Context names, and all names of Universes and Contexts should be
unique.

Note: If you have assigned to a KPI a Context created with the Context
Designer, and then youmodify the Context name in the Context Designer, make
sure that you assign themodified Context to the KPI in the Studio otherwise the
KPI becomes invalid as it uses a Context that does not exist.
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Scheme Area
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Repository Click the button to open the table repository. For details, see
"Repository" on next page.

<Drag and drop> Select the relevant table in the Repository and drag and drop it in the
Scheme area tomake the table part of the universe.

<Create relationships> Select the relevant entity in a table and drag and drop it on the
relevant entity in another table to create the relationship between
these two entities.

Note:

l Double-click a table to shrink it down to its title. Double-click
a shrunk table to expand it.

l To delete a relationship, click it and press theDelete key.

Use the slider to zoom in or out.
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Repository
The Repository area enables you to select external or internal tables to add to the Context you are
building.

User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Click to close the Repository.
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UI Element Description

External
Tables
(CSV)

Lists the CSV tables that were uploaded using the data loader wizard.

Click the relevant table to display its column details.

Click to add tables in CSV format to the Repository. The data loader wizard
opens. For details, see "Content Loader" on next page.

Internal
Tables

Lists the tables. Click on the relevant table to display its entities in the Column
details section.

Column
Details

Lists the entities (columns) of the table selected in the Internal Tables section.
Each entity is preceded by an icon indicating the type of entity:

l - date.

l - string.

l - numeric

Entities Area
You drag tables from the Scheme area to the Entities area to add a variable corresponding to the
table to the list of variables available to create the formula for the KPI that is assigned the Context.
The table columns become the variable entities.

User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI
Element

Description

<Drag
and
drop>

Drag and drop a table from themiddle pane to the Entities pane to add the table's
entities and fields to the list of available entities and fields available to be added to a
KPI formula in the Formula Builder. For details, seeModify a KPI or Metric Formula
in theBusiness Analyst Guide.
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UI
Element

Description

<Table
and
columns>

The table that you dragged from the Scheme area to the Entities area is displayed
followed by its columns.

Icons indicate the format of the column.

l - date.

l - string.

l - numeric

The icons to the right of the column enable you to decide to:

l - Enables the auto-completion feature when using this field in a formula, in
the Studio. This feature is not supported for a date field. For details, see
Variables in Modify a KPI or Metric Filter in theBusiness Analyst Guide.

l - Enable the creation of a Breakdown for the KPI using this dimension, in the
Studio. For details, see Variables in Manage KPI Breakdowns in theBusiness
Analyst Guide.

Remove Click to remove the selected table or entity.

Content Loader (Import) Wizard
The wizard enables you to upload content.

Content Loader
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User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):
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UI
Element

Description

Select
the data
on
which
you
want to
base the
KPI.

You can use .CSV files as a data source. A .CSV file contains data separated by
commas. Each .CSV file that is uploaded corresponds to a universe with only one
entity. The name of the Context (universe) that is created is the name of the .CSV
file. The names of the columns in the .CSV file (first row of the file) represent the
names of the entity fields. These fields become the variables that can be used to
create the formula that is used to calculate the value of the KPIs or Metrics
associated with the Context.

File Structure
The .CSV file should have a table structure. The following is an example of a .CSV
file in CSV format:

MD_BUSINESS_KEY,SLA_NAME,SLA_STATE,SLA_TYPE,DATE_START,DATE_

END

SLA01,SLA01,Passed,Corporate,1/1/2011 13:00:00,2/1/2011

19:00:00

SLA02,SLA02,Passed,Corporate,1/2/2011 13:00:00,2/2/2011

19:00:00

SLA03,SLA03,Passed,Corporate,1/3/2011 13:00:00,2/3/2011

19:00:00

SLA03,SLA03,Passed,Corporate,1/3/2011 13:00:00,2/3/2011

19:00:00

SLA04,SLA04,Passed,Corporate,1/4/2011 13:00:00,2/4/2011

19:00:00

SLA13,SLA13,Passed,Corporate,1/3/2011 13:00:00,2/3/2011

19:00:00

SLA14,SLA14,Passed,Corporate,1/6/2011 13:00:00,2/6/2011

19:00:00

Limitations
l Themaximum size of the .CSV file is 20MB. This is configurable using the

Maximum Size of .CSV file (MB) setting inAdmin tab > Scorecard
> XS Settings.

l Themaximum number of characters in an entity field name is 30 characters (an
entity field name is the string between commas in the first row of the .CSV file).

l The entity field names should follow the rules of column titles in the database
(include only alphanumeric characters, and underscore (_)).

l The name of the .CSV file should follow the rules of Context names (include only
alphanumeric characters, and underscores (_)).

Tip:

l The date data obtained from the data sources is automatically reformatted
internally using theYYYY.MM.dd HH:mm:ss (based on 24 hours) format.
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UI
Element

Description

All internal calculations are performed using this format.

l If you are using CSV files, you can select the date format in the <Data
upload> wizard. The selected format is automatically reformatted internally
using theYYYY.MM.dd HH:mm:ss (based on 24 hours) format.

l The dates displayed in the application user interface are reformatted
according to the browser locale.

Create a
.CSV Fil-
e

Hover aboveCSV file template to display an example of a .CSV file structure in
table format that can be uploaded.

Select Action
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User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI
Element

Description

Upload
a new
table

Select this option if you want to create a new table in the Context Designer using the
information from the .CSV file.

Update
an
existing
table

Select this option if you want to update an external table that already exists in the
Context Designer. When you click this option, the following options are displayed:

l Add data to an existing table. Select this option when you want to add data to an
existing table. The data from the new .CSV file is added at the end of the existing
table. The formats of the two .CSV files must be the same.

l Override the data in an existing table with the new data. Select this option
when you want to replace the data of an existing table with the data of the .CSV file
you are loading The formats of the two .CSV files must be the same.

Select File
This page is displayed when you selected theUpload a new table option:

This page is displayed when you selected theUpdate an existing table option:
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User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI
Element

Description

File
Name

Select the .CSV file you want to upload.

Table
Name

If you are loading a new .CSV file, enter the name of the corresponding table.

If you are adding data to an existing external table or if you are replacing the data in an
existing external table, select the relevant table name.

Preview
This page displays the table created from the .CSV file.
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User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

<table> The .CSV file is displayed in the box in table format. If an error message is
displayed (for example some of the values include spaces or unsupported
characters) you canmake the necessary corrections directly in the box:

Select the date
format you
used in the
.CSV file

Select the date format you used in the .CSV file.

Upload Click to upload the .CSV file into the Studio. For details, see "Semantic Layer
- Create andManage Contexts Using Context Designer and Upload Data
Using Data Loader" on page 78.
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Add a Context to the Studio
A KPI or Metric Context (universe) represents a global business facet related to the aspect of
business the KPI or Metric represents.

For example, the% of Assets in Maintenance KPI represents one aspect of the
AssetManagement universe.

You can add a Context to the Studio and the XS engine and attach KPIs or Metrics to the new
Context in the Studio.

Tasks
This section includes:

"Add a Context to Executive Studio" below

"Add a Context to Executive Studio using Context Designer" below

Add a Context to Executive Studio
1. Make sure you havemodeled the data structure in your database.

2. Add the universe using the BO Designer according to the Universe Creation Guidelines. For
details, see "Reference: Universe Creation Guidelines" on next page.

3. Export the universe to the XS_Studio folder in your BOCMS (Central Management Server)
using the BODesigner .

4. To load the universe to the Studio library you can do one of the following:
n Run the JMX reloadmetadata.

i. Make sure you have JDK installed.

ii. Run jconsole in theStartmenu.

iii. In the window that opens, select theRemote Process option, enter <host_
name>:<port_number> and click Connect.

iv. After the application completes its loading, click theMBeans tab.

v. Click com.hp.btoa.studio.jmx.

vi. Click loadMetaData.

n Note that if you do not click loadMetaData, the change will be performed by an automatic
update after 24 hours or 7 days depending on your configuration. You canmodify the
configuration using theMeta Data reload rate (Days) parameter in theXS Settings section
of the Admin Tab. For details, see "Configure XS Settings" on page 70.

5. You can now design active or template entities, create the formulas and filters for the KPIs or
Metrics, andmore.

Add a Context to Executive Studio using Context Designer
If you do not have DataWarehouse and SAP BusinessObjects Enterprise installed, you can create
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new Contexts, using Context Designer. For details, see "Semantic Layer - Create andManage
Contexts Using Context Designer and Upload Data Using Data Loader" on page 78 in the
Administrator Guide.

Reference: Universe Creation Guidelines
This section explains how you can create Universes that can be used by the HP IT Executive
Scorecard Studio and the XS Engine.

Guidelines
1. Folders represent the name of the entity that is presented.

2. Classes in the folder represent the attributes of that entity.

3. Classes should be of type Date, String, or Numeric.

4. Entities (represented by folders) in the same universemust have a relationship between them.

5. Hierarchical relationships should be flattened to attributes (Level1, Level2, …). These
relationships can be defined in a joined table.

Limitations
1. No current support for folders within folders or other hierarchies.

2. Ensure that there aren’t multiple joins between entities represented in the Universe (This is a
Universe limitation). Use aliases to copy.

3. Folder names should be unique.

4. Count, in a formula, can only be performed on Numeric and String fields.

5. Conditions on objects not supported.

6. Details on objects not supported.

7. Do not put mappings in the universe – where fields are translated from the value in the
database to the value that the universe returns.

Field Types
l Dimensions

n Fields that can be broken down per KPIs or Metrics should bemarked as Dimensions – see
the topmark in the figure below.

n If the field can only have a limited set of values, then turn on the List of Values field below –
see the secondmark in the figure below. The studio will only show the first 100 values.

n Warning - this should only be turned on for fields that have a small set of values – all the
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values will be loaded intomemory in the studio.

l Measures
n Fields that are only used as measures in KPI or Metric formulas should bemarked as

Measures. Make sure to configure as in figure below.

Manage Contexts and KPIs
You can add components to a page in Dashboard to provide reports about the KPI templates
currently in the KPIs Library, Contexts currently in Executive Scorecard, the structure of Contexts,

HP IT Executive Scorecard (9.31)Page 102 of 282

Administrator Guide



the list of KPIs included in a Context, and a list of the fields with names include a specific string that
are part of a Context, or that are used in a specific KPI formula.

To access:

1. In the Executive Dashboard, click theNew Page button in the Dashboard toolbar.

2. If needed, configure the page that opens. For details, see Configure a Page Layout in the
Business Analyst Guide.

3. Click theComponents button.

4. In the Component Gallery page that opens, double-click theWeb Intelligence Static Report
Viewer component to place it in the layout area, or select the component and drag it to an area
on the page, and close the Component Gallery page.

Tasks
This section includes:

"Change the Connection to the Target DB" below

"View the List of KPI Templates Currently in the KPIs Library" on next page

"View a list of the Contexts and to view aContext structure" on page 105

"View a list of the KPIs of a selected Context" on page 106

"Search for a field in Contexts or in KPI Formulas" on page 108

"Display the trees of KPIs in the KPIs Library" on page 109

"Setting the report so it displays data in theWeb Intelligence Dynamic or Static Report Viewer
component" on page 110

Change the Connection to the Target DB
You can change the connection of a Context to a specific Target database.

To change the connection to the Target database:

1. Access glassfish using <XS_server_name>:10001/common/index.jsf
a. In Common Tasks, select Resources > JDBC > JDBC Connections

> TargetDbConnectionPool

b. Click theAdditional Properties tab and change the URL of the Target Schema in the
URL field using the following format: jdbc:mercury:sqlserver:<XS_server_
name>:1433;databaseName=<Target_schema_name>

c. Change the name of the Target database in the databaseName field.

d. Click Save.

2. In Microsoft SQL Server Management Studio, access XS Manage DB, and open
dbo.TENANT_SCHEMA, change theHOST_NAME andDB_NAME of the Target Database,
and click Save.
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View the List of KPI Templates Currently in the KPIs Library
You can view a list of the KPI templates and their Context that are currently in the KPIs Library
pane. The Contexts can have been defined either in SAP BusinessObjects or in the Context
Designer. You can also view amore detailed list of KPIs (Context, Business Question, Formula,
Data Source, Thresholds, andmore):

Note: If you delete a KPI in the list of KPI templates, the list of KPIs displayed in the
components reflects the deletion.

1. In the Executive Dashboard, click theNew Page button in the Dashboard toolbar.

2. If needed, configure the page that opens. For details, see Configure a Page Layout in the
Business Analyst Guide.

3. Click theComponents button.

4. In the Component Gallery page that opens, double-click theWeb Intelligence Dynamic Report
Viewer component to place it in the layout area, or select the component and drag it to an area
on the page, and close the Component Gallery page.

5. In the component, click theConfigure Component button:
a. In theWeb Intelligence Dynamic Report Viewer Filter dialog box that opens, select:

i. TheKPI Templates report to view the list of the KPI templates that are currently in
the KPIs Library pane and basic information about the KPI template.

ii. TheKPI Template Details report to view the list of the KPI templates that are
currently in the KPIs Library pane, and details about their Context, Data Source,
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Business Question, Formula, Thresholds, andmore.

b. Click OK.

6. To view data in the component in the Dashboard page, click the Refresh button in the report
toolbar.

View a list of the Contexts and to view a Context structure
You can view a list of the Contexts currently defined in the Context Designer in Executive
Scorecard. The Contexts have been defined in the Context Designer.You can also display the
structure of the fields and tables that are included in a selected Context:

Note: If you create your ownContext in the Context Designer, the Context appears in the list
of Contexts displayed by the component. For details on the Context Designer, see "Semantic
Layer - Create andManage Contexts Using Context Designer and Upload Data Using Data
Loader" on page 78.

1. In the Executive Dashboard, click theNew Page button in the Dashboard toolbar.

2. If needed, configure the page that opens. For details, see Configure a Page Layout in the
Business Analyst Guide.

3. Click theComponents button.

4. In the Component Gallery page that opens, double-click theWeb Intelligence Dynamic Report
Viewer component to place it in the layout area, or select the component and drag it to an area
on the page, and close the Component Gallery page.

5. In the component, click theConfigure Component button:
a. In theWeb Intelligence Dynamic Report Viewer Filter dialog box that opens, select:

i. TheContext Summary report to view the list of the Contexts currently defined in the
Context Designer in Executive Scorecard.
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ii. TheContext Summary Details report to view the tables and fields that are included
in the selected Context. The user running the report is prompted to select a specific
Context. The prompt is optional.

b. Click OK.

6. To view data in the component in the Dashboard page, click the Refresh button in the report
toolbar.

View a list of the KPIs of a selected Context
You can view a list of the KPIs of a selected Context. The Contexts can have been defined either in
SAP BusinessObjects or in the Context Designer.

1. In the Executive Dashboard, click theNew Page button in the Dashboard toolbar.

2. If needed, configure the page that opens. For details, see Configure a Page Layout in the
Business Analyst Guide.

3. Click theComponents button.

4. In the Component Gallery page that opens, double-click theWeb Intelligence Dynamic Report
Viewer component to place it in the layout area, or select the component and drag it to an area
on the page, and close the Component Gallery page.

5. In the component, click theConfigure Component button.

6. In theWeb Intelligence Dynamic Report Viewer Filter dialog box that opens, select theKPIs
per Context report to view the list of the KPIs of a selected Contexts currently defined in the
Context Designer in Executive Scorecard. The user running the report is prompted to select a
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specific Context. The prompt is optional.

In table format:
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In graph format:

7. Click OK.

8. To view data in the component in the Dashboard page, click the Refresh button in the report
toolbar.

Search for a field in Contexts or in KPI Formulas
You can display a list of fields whose names include the specified string and the Contexts that
include these fields. The Contexts can have been defined either in SAP BusinessObjects or in the
Context Designer. You can also display a list of fields whose names include the specified string
and the KPIs whose formulas include these fields:

1. In the Executive Dashboard, click theNew Page button in the Dashboard toolbar.

2. If needed, configure the page that opens. For details, see Configure a Page Layout in the
Business Analyst Guide.

3. Click theComponents button.

4. In the Component Gallery page that opens, double-click theWeb Intelligence Dynamic Report
Viewer component to place it in the layout area, or select the component and drag it to an area
on the page, and close the Component Gallery page.

5. In the component, click theConfigure Component button:
a. In theWeb Intelligence Dynamic Report Viewer Filter dialog box that opens, select:

i. The Field in Context report to display a list of fields whose names include the
specified string and the Contexts that include these fields. The user running the report
is prompted to select a specific Context. The prompt is optional.
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ii. The Fields in KPI Name or Formula report to view a list of fields whose names
include the specified string and the KPIs whose formulas include these fields. The
user running the report is prompted to select a specific Context. The prompt is
optional.

b. Click OK.

6. To view data in the component in the Dashboard page, click the Refresh button in the report
toolbar.

Display the trees of KPIs in the KPIs Library
You can display the list of hierarchy trees of KPIs (templates) in the KPIs Library, with their
Scorecards, Perspectives, Objectives, and KPIs. The KPI Contexts can have been defined either
in SAP BusinessObjects or in the Context Designer.

1. In the Executive Dashboard, click theNew Page button in the Dashboard toolbar.

2. If needed, configure the page that opens. For details, see Configure a Page Layout in the
Business Analyst Guide.

3. Click theComponents button.

4. In the Component Gallery page that opens, double-click theWeb Intelligence Dynamic Report
Viewer component to place it in the layout area, or select the component and drag it to an area
on the page, and close the Component Gallery page.

5. In the component, click theConfigure Component button.

6. In theWeb Intelligence Dynamic Report Viewer Filter dialog box that opens, select theKPI
Tree Hierarchy report to display the list of hierarchy trees of KPIs in the KPIs Library, with
their Scorecards, Perspectives, Objectives, and KPIs.
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7. Click OK.

8. To view data in the component in the Dashboard page, click the Refresh button in the report
toolbar.

Setting the report so it displays data in the Web Intelligence Dynamic or
Static Report Viewer component

Note: Use theWeb Intelligence Dynamic Report Viewer component when you want the report
to display the report in table format and in graphic format (where the report can be displayed in
graphic format). If you want the report to display only in graphic format you can also use aWeb
Intelligence Static Report Viewer component, but in this case youmust make sure that the
report is scheduled as explained below).

To configure theWeb Intelligence Dynamic or Static Report Viewer components so they display
information when the component is part of a Dashboard page, select one of the following options:

l "Manage Contexts and KPIs" on page 102

l " Press the refresh button when importing the report to the page" on page 112

l "Schedule the report" on page 112

Set the report properties to be ‘Refresh on open’
This option works with aWeb Intelligence Dynamic Report Viewer component or with aWeb
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Intelligence Static Report Viewer component. When the Dashboard page where the component is
included, is displayed, the component is automatically refreshed.

1. Click the Start menu and select All Programs > BusinessObjects XI 3.1 >
BusinessObjects Enterprise > Web Intelligence Rich Client.

2. Log in to the server, import the report from the CMS, and save it.

3. Select theRefresh on open option.
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4. Click Save and export the report to back to the CMS (public folder > Studio Analysis).

Press the refresh button when importing the report to the page
This option works with aWeb Intelligence Dynamic Report Viewer component. When the
Dashboard page where the component is included, is displayed, the component is not automatically
refreshed and does not display data. Youmust click the Refresh button in the report toolbar to
refresh the display and display data.

Schedule the report
This option works with aWeb Intelligence Dynamic Report Viewer component or with aWeb
Intelligence Static Report Viewer component. When the Dashboard page where the component is
included, is displayed, the component automatically displays the latest scheduled data.

1.  Click the Start menu and select All Programs > BusinessObjects XI 3.1 >
BusinessObjects Enterprise > Web Intelligence Rich Client.

2. Log in to the Central Management Console.
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3. Choose theRecurrence type from the list and click Schedule.

HP IT Executive Scorecard (9.31)Page 113 of 282

Administrator Guide



Once you have a single instance of the report, you can then review the data in the report.

Export and Import KPIs, Pages, Components,
Events, and Trees

This section includes the following topics:

Export or Import Trees and KPIs 114

Import or Export Out-of-the-box Pages, Components, and Events 126

Export or Import Trees and KPIs
You can export complete trees (with their Scorecards, Perspectives, Objectives, and KPIs) from
the KPI Library or from the Active KPIs pane.

You can import existing template trees or sub-trees, active trees, active sub-trees, or orphan KPIs
into the KPI Library or the Active KPIs pane.

The import or export flows aremeant to be used whenmoving from staging to production and not as
a way to update system configuration. If you want to use the import or export flows to update the
system configuration, youmust delete all the nodes in the active KPIs pane, before performing the
import operation.

The export and import flows are alsomeant to be used for localization purposes, when you want to
work with other languages than English.
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Learn More

About Exporting or Importing Trees
You use the export or import feature when you want to import or export out-of-the-box templates,
automatically update existing templates, or import new templates, or active trees into the Executive
Studio.

The export and import feature is the process used tomove from staging environment to production.

The export feature collects the contents of the Active KPIs tree (Scorecards, Perspectives,
Objectives, KPIs, andOrphan KPIs) or of the KPI Library trees (Scorecard, Perspective, Objective,
and KPI templates, Folders, andOrphan KPIs). It converts the contents to a configuration.xml file
that describes the structure of the active tree or to a <tree_name>.xml file for each tree in the
KPI Library. These files include the UUID and KPI name of the KPIs included in the trees. In
addition, the process creates a <kpi_name>.xml file per KPI in the system; that file describes the
configuration of the KPI. The XML files are created in a specific directory on themachine. For
details about the directory, see "Template Locations" on next page

The import feature collects the content of a specific directory on themachine. The directory can
include configuration.xml files, and <kpi_name>.xml files according to the same format used by the
export feature or can include .xml files (the structure of these files should follow the XSD legal
model; for details, see "XML Files Used in Import and Export Operations" on page 118) with other
names. The import feature uses these files to upload the information in the specific area in the
Active KPIs tree or in the KPI Library trees. For details about the directory, see "Template
Locations" on next page.

The export and import operations work with XML files with a specific structure. Each
configuration.xml file includes information about the hierarchy from the lowest node to the tree root.
That information is used to add the new node is added to the relevant location in the relevant tree, or
the imported node overrides the relevant node. Each <KPI_name>. xml file includes information
about the KPI configuration. That information is used so that the relevant configuration and
calculation details are added to the relevant KPI. For details about the XML file structure, see "XML
Files Used in Import and Export Operations" on page 118.

The export operation uses the KPI's UUID to identify the KPI.

In addition, you can import KPIs from Excel files. You can use this capability to import KPIs without
consideration about their location in the tree. You can also create an .xml file that provides
information about a tree structure and that refers to KPIs that are imported from the Excel file. The
import feature uses these files to upload the information in the specific area in the Active KPIs tree
or in the KPI Library trees. For details about the directory, see "Template Locations" on next page

Note:  When the server on which the Executive Studio is located starts, if the system detects
files in the
<XS_server>\agora\glassfish\glassfish\domains\Config\KPI Template\ Import
directory, it automatically uploads that information. This feature is used when you logon to the
Executive Studio for the first time, to upload the out-of-the-box templates.

HP IT Executive Scorecard (9.31)Page 115 of 282

Administrator Guide



Template Locations
Whenworking with XML files, the files are located in the following directories:

l <XS_server>\agora\glassfish\glassfish\domains\Config\KPIConfiguration\Export or
Import for files corresponding to nodes in the Active KPI pane.

l <XS_server>\agora\glassfish\glassfish\domains\Config\KPITemplate\ Export or Import
for files corresponding to template nodes in the KPI Library.

The Import directory includes theError, Load, and Loaded directories.

Before you import a tree, the relevant XML files or the KPI Excel files must be located in the Load
directory. After the import operation, the file is moved to:

l The Loaded directory if the import operation succeeds.

l TheError directory if the import operation fails. In this case, an error file explaining the problem
is added to the Error directory.

Tasks
This section includes:

"To export a node:" below

"To import a node:" on next page

To export a node:
1. Make sure you have JDK installed.

2. Run jconsole in <XS_server>\agora\jdk\bin.

3. In the window that opens, select theRemote Process option, enter <host_name>:<port_
number> and click Connect.

4. After the application completes its loading, click theMBeans tab.

5. Click com.hp.btoe.studio.jmx.

6. You can now:
n Export active KPIs from the Active KPIs pane. ExpandKPIExport, select the

Operations branch, and click exportKPIs. In the Operation invocation area, enter 0 in the
text field, and click the exportKPIs button. If the export operation is successful, the
messageMethod successfully invoked is returned, and the result is XML files in the
<XS_server>\agora\glassfish\glassfish\domains\BTOA\
config\kpiconfiguration\export\ folder.

n Export KPITemplate from the KPI Library pane. ExpandKPITemplateExport, select
theOperations branch, and click exportKPITemplates. In the Operation invocation area,
enter 0 in the text field, and click the exportKPITemplates button. If the export operation is
successful, themessageMethod successfully invoked is returned, and the result is XML
files in the
<XS_server>\agora\glassfish\glassfish\domains\BTOA\
config\kpitemplates\export\ folder.
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To import a node:
1. Before importing any entity, you can create a XML file with appropriate structure or you can

take an XML file you exported previously and that you want to import now. For details, see
"About Exporting or Importing Trees" on page 115.

2. Save the XML file to:
n <XS_server>\agora\glassfish\glassfish\domains\BTOA\

config\kpitemplates\import\load\ folder for importing to the KPI Library pane.

n <XS_server>\agora\glassfish\glassfish\domains\BTOA\
config\kpiconfiguration\import\load\ folder for importing to the Active KPIs pane.

3. Make sure you have JDK installed.

4. Run jconsole in the <XS_server>\agora\jdk\bin.

5. In the window that opens, select theRemote Process option, enter <host_name>:<port_
number> and click Connect.

6. After the application completes its loading, click theMBeans tab.

7. Click com.hp.btoe.studio.jmx.

8. You can now:
n Import the tree structure or the Orphan KPIs to the Active KPIs pane. Expand

KPILoader, select theOperations branch, and click importKPIsAllTenants (to import all
the KPIs of all the tenants) or importKPIsByTenant (to import all the KPIs of a specific
tenant).

If the import operation is successful, themessageMethod successfully invoked is
returned, and the imported entity is displayed in the Active KPIs pane in the Studio.

In addition, the XML file is moved to the
<XS_server>\agora\glassfish\glassfish\domains\BTOA\
config\kpiconfiguration\import\loaded\ folder.

If the import operation fails, an explanation of the failure is added in the relevant file in the
<XS_server>\agora\glassfish\glassfish\domains\BTOA\
config\kpitemplates\import\errors\ folder.

Note that themessageMethod successfully invokedmight be displayed in some cases in
case of failure of the import operation.

n Import the template tree or Orphan KPI Templates to the KPI Library. Expand
KPITemplateLoader, select theOperations branch, and click
importKPITemplatesAllTenants (to import all the KPI templates of all the tenants) or
importKPITemplatesByTenant (to import all the KPI templates of a specific tenant).

If the import operation is successful, themessageMethod successfully invoked is
returned, and the imported entity is displayed in the KPI Library pane in the Studio.

In addition, the XML file is moved to
<XS_server>\agora\glassfish\glassfish\domains\BTOA\config\kpitemplates\
import\loaded\ folder.
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If the import operation fails, an explanation of the failure is added in the relevant file in the
<XS_server>\agora\glassfish\glassfish\domains\BTOA\config\kpitemplates\
import\errors\ folder.

Note that themessageMethod successfully invokedmight be displayed in some cases in
case of failure of the import operation.

Note:  If information is missing from the Load directory, part of the import operationmight
not be performed.

Example:
o If one or more of the KPI XML files aremissing from the

<XS_
server>\agora\glassfish\glassfish\domains\Config\KPITemplate\Import\Load
directory, the trees that include themissing KPIs (represented by the
configuration.xml or by the <tree_name>.xml files) are not imported. In addition, the
relevant error files are entered in the
<XS_
server>\agora\glassfish\glassfish\domains\Config\KPITemplate\Import\Errors
directory.

o If one or more of themandatory properties of a KPI (for example, the formula) are
missing from the
<XS_
server>\agora\glassfish\glassfish\domains\Config\KPITemplate\Import\Load
directory, the KPI is not imported. In addition, the relevant error files are entered in the
<XS_
server>\agora\glassfish\glassfish\domains\Config\KPITemplate\Import\Errors
directory.

For details about the structure of the XML files, see "XML Files Used in Import and Export
Operations" below.

Reference

XML Files Used in Import and Export Operations
Import and export work with XML files. The XML files have the following structures:

Example of a KPI XML File:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

<KPI tenantId="0">

<name>% Actual vs Planned Costs</name>

<description>The actual costs relative to the budgeted costs of

an activity.

</description>

<type>LEAF</type>

<period>MONTHLY</period>
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<dimension></dimension>

<formula>PERCENTAGE_MATH(

SUM(Cost.Amount,Cost.CostType='Actual' and PERIOD_ENTITY=Period),

SUM(Cost.Amount,Cost.CostType='Planned' and PERIOD_ENTITY=Period)

)

</formula>

<thresholdType type="MINIMIZE">

<rangeFrom>0.0</rangeFrom>

<rangeTo>4.0</rangeTo>

<goodFrom>0.0</goodFrom>

<goodTo>2.0</goodTo>

<warningFrom>2.0</warningFrom>

<warningTo>3.0</warningTo>

</thresholdType>

<unit>%</unit>

<filter></filter>

<dataSource>test</dataSource>

<uuid>3c7a1c22-5c10-4703-a22b-4a1eac317a5c</uuid>

</KPI>

Where:

Tag Explanation Example

<name> The name of the
KPI.

Limit:

l The name can
be up to 265
characters or
symbols.

l The forward
slash (/)
 symbol is not
supported.

<name>% Actual vs Planned Costs</name>
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<description> The description of
the KPI

Limit:

l The name can
be up to 1000
characters or
symbols.

l The forward
slash (/)
 symbol is not
supported.

<description> The actual costs relative to the
budgeted costs of an activity.</description>

<type> This is type of the
entity. It can be:

l LEAF

l PARENT

l BREAK-
DOWN

l BD_PARENT

The entry must be
in uppercase.

<type>LEAF</type>

<period> The period of the
KPI. It can be:

l WEEKLY

l MONTHLY

l QUARTERLY

l YEARLY

The entry must
be in uppercase.

For details, see
"Configure a KPI
or aMetric" in the
Business Analyst
Guide.

<period>MONTHLY</period>
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<
busi-
nessQuestions>

The Business
motivation
displayed in the
Metadata area in
the KPI's
Configuration
details tab.

For details, see
"Configure a KPI
or aMetric" in the
Business Analyst
Guide.

Limit:

l The name can
be up to 1000
characters or
symbols.

l The forward
slash (/)
 symbol is not
supported.

<businessQuestions>What are the actual cost
and planned cost values?What is the percentage
of actual versus planned spending? How do the
actual versus planned costs measure against the
thresholds? Is actual versus planned spending on
target or in theminimum or
maximum</businessQuestions>

<comments> The comments
displayed in the
Comments area in
the KPI's
Calculation
details tab.

For details, see
"Configure a KPI
or aMetric" in the
Business Analyst
Guide.

<comments>My comments</comments>

<formula> The formula used
to calculate the
value of the KPI.

<formula>PERCENTAGE_MATH(SUM
(Cost.Amount,Cost.CostType='Actual' and
PERIOD_ENTITY=Period),100000)</formula>
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<thresholdType
type=" ">

The direction of
the Result
threshold. It can
be:

l MAXIMIZE

l CENTRALIZE

l MINIMIZE

The entry must be
in uppercase.

For details, see
"Configure a KPI
or aMetric" in the
Business Analyst
Guide.

<thresholdType type="MAXIMIZE">

% and 10% (green), and a bad rate is between
10% and 100% (red).

<rangeFrom> Lower value of the
error range.

<rangeFrom>0.0</rangeFrom>

<rangeTo> Higher value of
the error range.

<rangeTo>100.0</rangeTo>

<goodFrom> Lower value of the
good range.

<goodFrom>90.0</goodFrom>

<goodTo> Higher value of
the good range.

<goodTo>100.0</goodTo>

<warningFrom> Lower value of the
warning range.

<warningFrom>80.5</warningFrom>

<warningTo> Higher value of
the warning range.

<warningTo>90.0</warningTo>

<unit> The KPI's unit. It
can be:

l %

l $US (The
entry must be
in uppercase.)

l Days (The
entry must be
init cap.)

<unit>%</unit>

<unit>$US</unit>

<unit>Days</unit>
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<filter> The formula used
to calculate the
KPI's value.

<filter>Budget.Name = 1</filter>

<dataSource> The Context.

The Context's
entities are the
basis of the
calculation and
provide the
entities used in
the formula.

<data-
Source>FinancialManagement</dataSource>

<uuid> Set UUID to
identify the KPI.
You can set your
ownUUID for the
KPI.
For example
<uuid>This is
MY KPI</uuid>

<uuid>1c9eab96-5013-412c-a428-
17a1ae39317b</uuid>

Example of a Folder tree XML File:
<?xml version="1.0" encoding="UTF-8"?>

<tree xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

xsi:noNamespaceSchemaLocation="../xsd/templates/Template_

tree.xsd" name="Industry Standard" tenantId="0">

<folder name="ITIL" description="ITIL">

<folder name="Asset Management" description="Asset

Management">

<template name="Average Age of Hardware Assets"/>

</folder>

<folder name="Change Management" description="Change

Management">

<template name="Change Risk"/>

</folder>

<folder name="Financial Management" description="Financial

Management">

<template name="% of budget deviation relative to total

budget"/>

<template name="% Project Budget over or under"/>

<template name="Actual vs. budgeted costs"/>

</folder>

<folder name="Incident Management" description="Financial

Management">

<template name="% of escalated incidents"/>
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<template name="% incidents solved within SLA time"/>

</folder>

<folder name="Problem Management" description="Financial

Management">

<template name="% of problems resolved on time"/>

</folder>

</folder>

<folder name="All working KPI's" description="just a copy of

all tempaltes">

<template name="% of Reopened Incidents"/>

<template name="% of critical and high incidents"/>

</folder>

</tree>

Example of a Scorecard tree XML File:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

<tree xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

xsi:noNamespaceSchemaLocation="../xsd/templates/Template_

tree.xsd" name="Industry Standard" tenantId="0">

<scorecard name="CIO Scorecard" description="Business Value">

<perspective name="Customer" description="?">

<objective name="Reduce incident/problem management

related customer complaints by 30% in 2011"

rule="BEST_CHILD" period="MONTHLY">

<template name="% of Reopened Incidents"/>

<template name="% of escalated incidents"/>

</objective>

<objective name="Improve Service Delivery by 30%"

rule="BEST_CHILD" period="MONTHLY">

<template name="% of Service Level Objectives for

Met IT Process Activities"/>

<template name="Service request avg response

time"/>

<template name="Service request backlog"/>

</objective>

<objective name="Increase Customer Satisfaction by 20%

in 2011" rule="BEST_CHILD" period="MONTHLY">

<template name="Reported exceptions to SLA"/>

<template name="Customer Satisfaction"/>

<template name="Critical time outage"/>

</objective>

</perspective>

<perspective name="Internal Business Process"

description="?">

<objective name="Improve Project Delivery by increasing
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throughput by 15%" rule="BEST_CHILD"

period="MONTHLY">

<template name="Employee Utilization Rate"/>

<template name="% of projects on time"/>

<template name="Deviation % of Planned Work

Hours"/>

<template name="TTM"/>

</objective>

</perspective>

<perspective name="Financial" description="?">

<objective name="Reduce unhealthy projects budget risk

by 10% in 2011" rule="BEST_CHILD" period="MONTHLY">

<template name="Unhealthy projects"/>

<template name="% of Capital Exposure at Risk"/>

<template name="Unhealthy projects budget risk"/>

</objective>

<objective name="Increase Employee Utilization by 3% in

1st Qtr 2011" rule="BEST_CHILD" period="MONTHLY">

<template name="Employee Utilization Rate"/>

<template name="FCR"/>

</objective>

<objective name="Reduce IT budget by 20% in 2011"

rule="BEST_CHILD" period="MONTHLY">

<template name="% FTE"/>

<template name="Service Actual to Plan"/>

<template name="% Outages/Total SLA uptime"/>

<template name="Business Service Cost Reduction"/>

</objective>

</perspective>

<perspective name="Learning and Growth" description="?">

<objective name="Increase Manager skills against the

competency model by 15% in 2011 above 2010"

rule="BEST_CHILD" period="MONTHLY">

<template name="Percentage of managers meeting or

exceeding leadership competency model"/>

</objective>

<objective name="Increase Employee Satisfaction by 10%

in 2011" rule="BEST_CHILD" period="MONTHLY">

<template name="Employee Attrition"/>

<template name="Job Satisfaction"/>

<template name="Employee Satisfaction"/>

</objective>

<objective name="Increase employee productivity by 10%"

rule="BEST_CHILD" period="MONTHLY">

<template name="Employee Utilization Rate"/>

</objective>

</perspective>
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</scorecard>

</tree>

Example of a KPI Excel File:
The Excel table must include the following columns in the following order:

l ID

l KPI

l Description

l Business Questions

l Context

l Formula

l Unit Type

l Time Period

l Direction

l Range From

l Range To

l Good From

l Good To

l Warning From

l Warning To

For details about the above column contents, see "Configure a KPI or aMetric" in theBusiness
Analyst Guide.

Import or Export Out-of-the-box Pages,
Components, and Events

You can import existing out-of-the-box pages, components and events into the Dashboard page.

The import or export flows aremeant to be used for localization purposes (when you want to work
with other languages than English) or whenmoving from staging to production and not as a way to
update system configuration.

Learn More

About Importing or Exporting OOTB Pages, Components, and Events
Out-of-the-box pages are available in the Dashboard. Pages can include components. Components
in a page can be wired and can interact with each other using events. For details, about the
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Dashboard, see "Prepare the Dashboard Display" (on page 1) in theBusiness Analyst Guide.

The import and export feature is the process used tomove from the staging environment to
production.

The export feature collects the contents of the pages, components, and events. It converts the
contents to components.uim.xml, pages.uim.xml, and events.uim.xml files that describes the
structure and content of the pages, components, and events. These files include the UUID of the
pages and components.

The export operation uses the page, component, or event UUID to identify the page, component, or
event.

The import feature collects the contents of a specific directory on themachine. The directory can
include components.uim.xml, pages.uim.xml, and events.uim.xml files according to the same
format used by the export feature. The import feature uses these files to upload the information into
the database.

After the import operation, the file is moved to:

l The Loaded directory if the import operation succeeds.

l TheErrors directory if the import operation fails.

Note:  When the server on which the Dashboard is located starts, if the system detects files in
the
<XS_server>\agora\glassfish\glassfish\domains\BTOA\uimashup\import\toload
directory, it automatically uploads that information.

Tasks
This section includes:

"To import pages, components, or events:" below

"To export pages, components, or events:" on page 129

To import pages, components, or events:
1. Make sure you have JDK installed.

2. Run jconsole in theStartmenu.

3. In the window that opens, select theRemote Process option, enter <host_name>:<port_
number> and click Connect.

4. After the application completes its loading, click theMBeans tab.

5. To import all the pages, components, and events at once, expandUIM, select Operations and
in the Operation invocation area, click the importData button.
Or, you can also import pages, components and events separately as follows:

n Import the pages. ExpandUIM, and select Operations. In the Operation invocation area,
click the loadPagesData button.

HP IT Executive Scorecard (9.31)Page 127 of 282

Administrator Guide



If the import operation is successful, themessageMethod successfully invoked is
returned, and the imported entities are displayed in the PageGallery.

In addition, the XML file is moved to the
<XS_server>\agora\glassfish\glassfish\domains\BTOA\config\uimashup\
import\loaded\ folder.

If the import operation fails, an explanation of the failure is added in the relevant file in the
<XS_server>\agora\glassfish\glassfish\domains\BTOA\config\uimashup\
import\errors\ folder.

Note that themessageMethod successfully invokedmight be displayed in some cases in
case of failure of the import operation.

Note: If you want to import pages in another language, the existing (English) categories
are not removed, so both translated and non-translated categories appear in the list of
categories. To select the categories you want to delete, expandUIM, and select
Operations. In the Operation invocation area, click the
displayAllCachedGalleryCategories button to view the current categories to display
a table that lists all the out-of-the-box categories. Once you know which categories you
want to delete, expandUIM, and select Operations. In the Operation invocation area,
click the deletePageCategoryByName button and specify the relevant page category
you want to delete.

n Import the components. ExpandUIM and select Operations. In the Operation invocation
area, click the loadComponentsGallery button. If successful, themessageMethod
successfully invoked is returned, and the imported entities are displayed in the Component
Gallery..

In addition, the XML file is moved to the
<XS_server>\agora\glassfish\glassfish\domains\BTOA\config\uimashup\
import\loaded\ folder.

If the import operation fails, an explanation of the failure is added in the relevant file in the
<XS_server>\agora\glassfish\glassfish\domains\BTOA\config\uimashup\
import\errors\ folder.

Note that themessageMethod successfully invokedmight be displayed in some cases in
case of failure of the import operation.

Note: If you want to import components in another language, the existing (English)
 categories are not removed, so both translated and non-translated categories appear in
the list of categories. To select the categories you want to delete, expandUIM, and
select Operations. In the Operation invocation area, click the
displayAllCachedGalleryCategories button to view the current categories. Once you
know which categories you want to delete, expandUIM, and select Operations. In the
Operation invocation area, click the deleteComponentCategoryByName button and
specify the relevant component category you want to delete.

n Import the events. ExpandUIM, and select Operations. In the Operation invocation area,
click the loadEvents button.
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If the import operation is successful, themessageMethod successfully invoked is
returned.

In addition, the XML file is moved to
<XS_server>\agora\glassfish\glassfish\domains\BTOA\config\uimashup\
import\loaded\ folder.

If the import operation fails, an explanation of the failure is added in the relevant file in the
<XS_server>\agora\glassfish\glassfish\domains\BTOA\config\uimashup\
import\errors\ folder.

Note that themessageMethod successfully invokedmight be displayed in some cases in
case of failure of the import operation.

Note:

l If information is missing from the Load directory, part of the import operationmight not
be performed.

l When a file is copied to the
<XS_server>\agora\glassfish\glassfish\domains\BTOA\config\uimashup\
import\loaded\ folder during the import process, a timestamp (Milliseconds since
midnight, January 1, 1970 UTC) is added to its name, for example: Components_pt_
BR_130810232011.xml. This way, you can see which file is currently assigned to the
database.

To export pages, components, or events:
1. Make sure you have JDK installed.

2. Run jconsole in theStartmenu.

3. In the window that opens, select theRemote Process option, enter <host_name>:<port_
number> and click Connect.

4. After the application completes its loading, click theMBeans tab.

5. You can now:
n Export pages. ExpandUIM and select Operations. In the Operation invocation area, click

the exportPages button and specify the pathToExportLocation. If the export operation is
successful, themessageMethod successfully invoked is returned, and the result is XML
files in the folder you specified.

n Export components and events. ExpandUIM and select Operations. In the Operation
invocation area, click the exportMetaData button and specify the pathToExportLocation.
If the export operation is successful, themessageMethod successfully invoked is
returned, and the result is XML files in the folder you specified.

Localize and Globalize Executive Scorecard
You can localize and globalize Executive Scorecard. The user interface of HP Executive Scorecard
supports multiple languages.
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Tasks
Out-of-the-box KPI Library Pane Contents
The localized installation adds the language libraries of XML files in specific folders. You copy and
then import these files to display the out-of-the-box template Scorecards, Perspectives,
Objectives, Folders, and KPIs in the KPI Library in the selected language.

To localize the out-of-the box content of the KPI Library: Scorecards, Perspectives, Objectives,
and KPIs, proceed as follows:

1. In the Executive Scorecard server, locate the
<XS_installation_directory>\agora\glassfish\glassfish\domains\BTOA\config\
kpitemplates\import\languages\<language_code>_<country_code> folder relevant for the
language you want to use in the application. The .xml files in the folder represent both KPIs and
KPI directories.

The language code and country codes are as follows:

Language Language Code Country Code

Brazilian Portuguese pt BR

French fr FR

Spanish es ES

German de DE

Japanese ja JP

English en US

Dutch nl NL

Italian it IT

Simplified Chinese zh CN

Korean ko KR

Russian ru RU

2. Copy these .xml files to the <XS_
server>\agora\glassfish\glassfish\domains\BTOA\config\kpitemplates\import\load
folder.

Tip:

If the folder contains other sets of files (for different languages), it is recommended to keep
in the folder only the required set of language files and tomove the other files outside the
folder to prevent the loading of both set of language files and an unknown result.

HP IT Executive Scorecard (9.31)Page 130 of 282

Administrator Guide



3. Import the out-of-the-box language files using theKPILoader > importKPIs() procedure
described in "Export or Import Trees and KPIs" on page 114in theAdministrator Guide.

Out-of-the-box Dashboard Content (Pages and Components)
The localized installation adds the language libraries of XML files in specific folders. You copy and
then import these files to display the out-of-the-box template pages and components in the selected
language, in the Dashboard.

To localize the out-of-the box pages and components, proceed as follows:

Prerequisite

You have performed the installation and post-installation procedures or the upgrade to the current
version.

Copy the libraries

1. In the Executive Scorecard server, locate the
<XS server>\agora\glassfish\glassfish\domains\BTOA\config\
uimashup\import\languages\<language_code>_<country_code> folder relevant to the
language you want to install. These .uim.xml files represent the components and the pages
used in the Dashboard.

2. The language code and country codes are as follows:

n Components_<lang>_<country_code>.uim.xml

n Pages_<lang>_<country_code>.uim.xml,

where lang is the language code and country_code is the code of the country:

Language Language Code Country Code

Brazilian Portuguese pt BR

French fr FR

Spanish es ES

German de DE

Japanese ja JP

English en US

Dutch nl NL

Italian it IT

Simplified Chinese zh CN

Korean ko KR

Russian ru RU

3. Copy these files to the
<XS_server>\agora\glassfish\glassfish\domains\BTOA\config\uimashup\
import\toload folder.
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Tip:

If the folder contains several sets of files (for different languages), it is recommended to
keep in the folder only the required set of language files and tomove the other files outside
the folder to prevent the loading of both set of language files and an unknown result.

4. Import the out-of-the-box language files (only for the pages and components - events are
not localized) using the relevant procedure described in "Import or Export Out-of-the-box
Pages, Components, and Events" on page 126 in theAdministrator Guide.
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Content Acceleration Packs (CAPs)
Content Acceleration Packs (CAPs) are ready-to-import packages that include Dashboard pages
that display Scorecards and components, KPIs, Metrics, Contexts (universes), data (.CSV files),
and documentation for the CAP.

CAPs describe typical stories that show how correct implementation of Executive Scorecard drives
Performance Improvement and Cost Reduction for the IT organization. CAPs demonstrate
Executive Scorecard capabilities, and helps you add basic elements that can be used to customize
your Dashboard.

This section includes the following topics:

Manage Content Acceleration Packs Using CAP Management 133

Create Content Acceleration Packs 146

Manage Content Acceleration Packs Using CAP
Management

Content Acceleration Packs (CAPs) are ready-to-import packages that include Dashboard pages
that display Scorecards and components, KPIs, Metrics, Contexts (universes), data (.CSV files),
and documentation for the CAP.

CAPs describe typical stories that show how correct implementation of Executive Scorecard drives
Performance Improvement and Cost Reduction for the IT organization. CAPs demonstrate
Executive Scorecard capabilities, and helps you add basic elements that can be used to customize
your Dashboard.

To access:
Click Admin > Content Acceleration Pack > Content Acceleration Pack

Learn More

Content Acceleration Pack Contents
The Content Acceleration Pack ZIP file includes the following folders:
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l data - contains the .CSV files. The name of the .CSV files to be uploaded provide data for the
Content Acceleration Pack KPIs andMetrics. For details, see "Upload Tables in .CSV Format
to the Tables Repository" on page 84.

l kpi - contains the .XML files that correspond to KPIs and Scorecards. The KPIs and Scorecards
are imported into the Studio Active KPIs pane. The Scorecards and relevant KPIs are also
displayed in the Dashboard pages after the calculation completes and the relevant page is
loaded. For details, see "Manage Content Acceleration Packs Using CAP Management" on
previous page.

l uim- contains:

n Components folder - contains the .XML files that correspond to the components that you can
add to a page.

n Pages folder - contains the .XML files that describe the pages that are included in the CAP.

You import the components, events, and pages into the Dashboard where they are used to
build the Dashboard pages. For details, see "Manage Content Acceleration Packs Using
CAP Management" on previous page.

l universe folder- contains the .XML files that correspond to the Business Contexts (universes).
The Content Acceleration Pack installation automatically installs the Business Contexts.

l <CAP_documentation> - the PDF orMicrosoft Word document that describes the CAP.

l manifest.properties file - includes information about the following items:

n UUID. A unique ID for the Content Acceleration Pack.

n Name. The name of the Content Acceleration Pack. Mandatory.

n BCs. The names of the Business Contexts to be calculated (comma separated).

n Description. The description of the Content Acceleration Pack. Optional

n recalculate.date. The start date of the recalculation. Recalculation is started automatically
when you activate the CAP.

n bo.in.use.

o false - The Content Acceleration Pack contents do not include SAP BusinessObjects
Enterprise reports.

o true - The Content Acceleration Pack contents include SAP BusinessObjects Enterprise
reports.

n version. The version of the Content Acceleration Pack.

n publisher. The name of the creator of the CAP. It can be a single user, an HP partner, or a
group in your organization.

n xs.version. The version of Executive Scorecard

Out-of-the-box Content Acceleration Packs
VP of Operations Content Acceleration Pack in theContent ReferenceGuide

VP of Applications Content Acceleration Pack in theContent ReferenceGuide

Security Enterprise Architecture Content Acceleration Pack in theContent ReferenceGuide
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Cloud Content Acceleration Pack in theContent ReferenceGuide

Tasks
This section includes:

"View the available CAPs" below

"Upload a CAP from the user's local system to the Executive Scorecard application" below

"Upload a localized CAP" on next page

"Activate a CAP" on next page

"Deactivate a CAP" on page 137

"Delete a CAP from the Executive Scorecard application" on page 137

"Download a CAP to the user's local system" on page 138

"Create a CAP from the Executive Scorecard application data" on page 138

"Modify a CAP" on page 138

"Upgrade a CAP" on page 138

View the available CAPs
To view a list of all the CAPs available in the system:

1. In Executive Scorecard, click Admin > Content Acceleration Pack.

The page displays the list of available CAPs. For details, see "CAP Management Page" on
page 139.

2. You can now manage (create, upload, delete, download, activate, and deactivate) the CAPs.

Upload a CAP from the user's local system to the Executive Scorecard
application
To upload a CAP from the local system to the Executive Scorecard application:

1. Prerequisites:

n The .ZIP file of the CAP you want to upload is copied to your file system.

n A corresponding CAP (with the sameUUID) does not already exist in the Executive
Scorecard application.

2. In Executive Scorecard, click Admin > Content Acceleration Pack..

The page displays the list of available CAPs.

3. Click to open a browser dialog box where you can select the relevant .ZIP file
corresponding to CAP you want to upload .

4. Check theActivate CAP after upload checkbox if you want to activate the CAP
automatically when the upload is completed.

You can now activate the CAP. For details, see "Activate a CAP" on next page.
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Upload a localized CAP
To upload localized CAPs:

1. Delete the pre-imported out-of-the-box CAPs in the English language.

2. Upload the localized CAPS:

n Localized out-of-the-box CAP. To upload a localized out-of-the-box CAP, proceed as
described in "Upload a CAP from the user's local system to the Executive Scorecard
application" on previous page and specify the location of the out-of-the-box CAP.

Note: Localized out-of-the-box CAPs .ZIP files are placed in the relevant language
folder during installation:
..\HPXS\agora\glassfish\glassfish\domains\BTOA\config\cap\import\languages

For example, the VPOPS CAP in German is located at:
..\HPXS\agora\-
glassfish\glassfish\domains\btoa\config\cap\import\languages\de_DE\VPOPS_
de_DE.zip

n Localized user-defined CAP. To upload a localized user-defined CAP proceed as
described in "Upload a CAP from the user's local system to the Executive Scorecard
application" on previous page and specify the location of the localized CAP you have
created.

Activate a CAP
When you activate a CAP, all the content of the CAP is added to current data (Contexts, KPIs,
Pages, etc.) and a recalculation is performed according to the CAP definitions.

To activate a CAP:

1. Prerequisites:

The CAP is in the list of available CAPs and is not activated.

2. In Executive Scorecard, click Admin > Content Acceleration Pack..

The page displays the list of available CAPs.

3. Select the relevant CAP and click Activate.

You get a notification that the CAP is being activated. Click Yes to complete the Activation. It
takes a few minutes.

If a CAP that shares the same content was already activated, an alert warns you that
activating the new CAP will override the overlapping instances.

Once the activation is complete, an indication is added to the CAP.

4. You can now:

n View the Business Context details in Context Designer. For details, see "Semantic Layer -
Create andManage Contexts Using Context Designer and Upload Data Using Data Loader"
on page 78.

n View and expand the Scorecard tree in the Active KPIs pane. For details, see Activate
Scorecards, Perspectives, Objectives, Metrics, or KPIs Using Templates in theBusiness
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Analyst Guide.

n View the Scorecard, and KPIs configuration in the Configuration Details, and Calculation
Details tabs. For details, see Configure a Scorecard or Configure a KPI or aMetric in the
Business Analyst Guide.

n View the Content Acceleration Pack page in Dashboard. For details, seeManage Page
Categoriesin theBusiness Analyst Guide.

n View information in Explorer. For details, see View and Analyze Results in the Explorer
Pagein theBusiness Analyst Guide.

Deactivate a CAP
When you deactivate a CAP, all the content of the CAP is deleted.

To deactivate a CAP:

1. Prerequisites:

The CAP is in the list of available CAPs and is activated.

2. In Executive Scorecard, click Admin > Content Acceleration Pack..

The page displays the list of available CAPs.

3. Select the relevant CAP and click Deactivate.

If the CAP is activated amessage is issued to task you to deactivate the CAP before you can
delete it.

You get a notification that the CAP is being deactivated.

Once the deactivation is complete, an indication is added to the CAP.

Note: You are notified that the deactivation of a CAP may cause errors in pages and KPIs
using this CAP content. All the CAP entities will be deleted if you acknowledge the
warning.

Delete a CAP from the Executive Scorecard application
When you delete a CAP, the CAP is deleted from the Executive Scorecard server and is not listed
in the list of CAPs any more.

To delete a CAP:

1. Prerequisites: The CAP is in the list of available CAPs and is not activated.

2. In Executive Scorecard, click Admin > Content Acceleration Pack.

3. Select Content Acceleration.

The page displays the list of available CAPs.

4. Select the relevant CAP and click .

Once the deletion is complete, the CAP is removed from the list of available CAPs.
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Download a CAP to the user's local system
To download a CAP and save it to the local system ato be used in other environments:

1. In Executive Scorecard, click Admin > Content Acceleration Pack tab.

2. Select Content Acceleration.

The page displays the list of available CAPs.

3. Click to open a browser dialog box where you can select where you want to download the
CAP.

The CAP .ZIP file is saved at that location.

Create a CAP from the Executive Scorecard application data
You can create a new CAP that includes existing Contexts, Scorecards, KPIs andMetrics, and
Dashboard pages.

1. Before creating the CAP, make sure you have already created all the relevant Scorecards,
KPIs, Metrics, Pages and Contexts that you wish to include in the CAP and that they have
been calculated with the expected results. If you find that some content is missing, go back
and create it. Once this is done, you can start creating the CAP.

2. In Executive Scorecard, click Admin > Content Acceleration Pack.

The page displays the list of available CAPs.

3. Click to open a wizard where you can create the CAP. For details, see "Create Content
Acceleration Packs" on page 146.

Modify a CAP
Tomodify an existing CAP, it is recommended to create a new CAP with the relevant content and
then to delete the existing CAP.

1. In Executive Scorecard, click Admin > Content Acceleration Pack.

The page displays the list of available CAPs.

2. Click to open a wizard where you can create the CAP. For details, see "Create Content
Acceleration Packs" on page 146.

3. After you have created the new CAP, remove the old CAP.

Upgrade a CAP
For details, see Upgrading the 9.30 Content Acceleration Packs (CAPs) in theUpgradeGuide.
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UI Description

CAP Management Page

List of CAPs area
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI
Element

Description

Click to create a new Content Acceleration Pack. The Create CAPs wizard opens.
For details, see "Create Content Acceleration Packs" on page 146.
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Click to upload a .ZIP file from the file system to the Executive Scorecard application.
A dialog box opens to enables you to browse to locate the .ZIP file.

Before clicking the buttonmake sure that:

l The .ZIP file of the CAP you want to upload is copied to your file system.

l A corresponding CAP (with the sameUUID) does not already exist in the
Executive Scorecard application.

Select Activate CAP after upload to automatically activate the CAP after it
completes its upload.

Click to download the .ZIP file corresponding to the selected Content Acceleration
Pack to the file system.

During the creation of a CAP using the wizard, all the contents of the CAP are
automatically saved in a .ZIP file.

Click to delete the corresponding Content Acceleration Pack.

Before your click the button, make sure that:

The CAP is in the list of available CAPs and is not activated.

View by Filter the available Content Packs by their status:

l All. All statuses.

l Activated. Displays the activated Content Packs. Activated Content Packs are
indicated by .

l Deactivated. Displays the deactivated Content Packs. Deactivated Content
Packs are indicated by .

l Activating. Displays the Content Packs that are in the process of being activated.
Activating Content Packs are indicated by .

l Deactivating. Displays the Content Packs that are in the process of being
deactivated. Deactivating Content Packs are indicated by .

<List of
CAPs>

The list of available CAPs within the Executive Scorecard server.
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CAP Description area
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

<CAP name> The name of the Content Acceleration Pack.

The standard characters are supported: a-z,A-Z,and 0-9.

Description The description of the Content Acceleration Pack.

The standard characters are supported: a-z,A-Z,and 0-9.

Note: Only the beginning of the description in displayed in this field
(1000 chararacters). To view the complete description of the CAP,
click theOpen documentation file link.

Click to activate or deactivate the Content Acceleration Pack.

Note: If the Content Acceleration Pack is already activated the
Deactivate button is displayed and vice-versa.

l When you click , the system scans the CAP entities
(Pages, Scorecards, KPIs, Metrics, Contexts, and data (in .CSV
table format)). If such entities already exist in the system
because they are part of an activated CAP, a warning is issued
so the user can select to continue the activation or not. Note that
when the CAP is activated, its entities override the entities
already activated in the application (not the templates).

l When you click , the system removes the
CAP entities (Pages, Scorecards, KPIs, Metrics, user-defined
Contexts, and data (in .CSV table format)) except for the
Contexts that are out-of-the-box.

Open
documentation file

Click to display a detailed description of the Content Acceleration Pack.

Recalculate date The date from when the CAP's Business Contexts are recalculated when
the CAP is activated.

BO in use Yes. The CAP comprises a page or a KPI that includes SAP
BusinessObjects Enterprise elements.

No. The CAP does not comprise a page or a KPI that includes SAP
BusinessObjects Enterprise elements.
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Author The user, partner, or company that created the CAP.

XS Version The version of HP IT Executive Scorecard used when the CAP was
created.

Version The version of the CAP.

Activation date
Deactivation date

The date when the CAP was activated, deactivated, or created.

CAP Description area
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Pages The list of pages included in the Content Acceleration Pack.
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Scorecards The list of Scorecards included in the Content Acceleration Pack.

Select a Scorecard and click the button to display the Name and

Description of the selected Scorecard in the XS Active Configuration
tree.

Note: The name of the entity in the dialog box might be different from
the name in the CAP Management list if the entity namewas
modified in the Studio or if duplicate entity names were discovered
during the CAP activation.
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Business Contexts The list of Business Contexts included in the Content Acceleration Pack.

The area displays the following information:

l - In the recalculation status column, indicates that the
corresponding Business Context needs to be recalculated.

l Type. In this column, the icon indicates that:

n The CAP's Business Context is user-defined.

n The CAP's Business Context is out-of-the-box (it is provided
with the application).

l Name. The name of the Business Context.
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KPIs and Metrics The list of KPIs andMetrics included in the CAP.

Select a KPI or Metric and click the button to display the current

Name, and Description of the selected KPI or Metric (as specified in the
current definition in the Studio). The button is activated only for the KPIs
that are included in activated CAPs.

Note: The name of the entity in the dialog box might be different from
the name in the CAP Management list if the entity namewas
modified in the Studio or if duplicate entity names were discovered
during the CAP activation.
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Data (CSV Tables)
dat

Click to display the list of all the CSV tables that compose all the
Business Context in the Data (CSV Tables).

Create Content Acceleration Packs
Content Acceleration Packs (CAPs) are ready-to-import packages that include Dashboard pages
that display Scorecards and components, KPIs, Metrics, Contexts (universes), data (.CSV files),
and documentation for the CAP.

CAPs describe typical stories that show how correct implementation of Executive Scorecard drives
Performance Improvement and Cost Reduction for the IT organization. CAPs demonstrate
Executive Scorecard capabilities, and helps you add basic elements that can be used to customize
your Dashboard.

To access:

Click Admin > Content Acceleration Pack, and then click to open a wizard where you can
create the CAP.

Learn More
For details about the Content Accelerations (CAPs) contents, see "Content Acceleration Pack
Contents" on page 133.

Tasks

Create a CAP from the Executive Scorecard application data
You can create a new CAP that includes existing Contexts, Scorecards, KPIs andMetrics, Data
(via .CSV files), and Dashboard pages.

1. Prerequisite: Before creating the CAP, make sure you have already created all the relevant
Scorecards, KPIs , Metrics, Pages and Contexts that you wish to include in the CAP and that
they have been calculated with the expected results. If you find that some content is missing,
go back and create it. Once this is done. you can start creating the CAP.

2. In Executive Scorecard, click Admin > Content Acceleration Pack.

The page displays the list of available CAPs.

3. Click theCreate a new CAP button to open the Create Content Acceleration Pack wizard
where you can create the CAP.
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Click Next and specify the CAP name, author, version, description, recalculation date and link
to any relevant document.

Click Next and in theSelect Pageswizard page, select the pages you want to include in this
CAP.

Note: Once you have selected a Page, the Scorecards, KPIs, andMetrics that are
included in that page and the Contexts that are assigned to the KPIs included in the page,
are automatically selected. If you want to add to the CAP additional elements like
Scorecards, KPIs, andmore, click theNext button andmodify your selection in the other
pages of the wizard. Otherwise you can jump directly to the Summary wizard page.

4. Click Create to create the CAP. Once the CAP is created you cannot modify it. The new
CAP is displayed in the list of CAPs in the CAP Management page. In the right pane you can
see the contents of the CAP you have just created. For details, see "Manage Content
Acceleration Packs Using CAP Management" on page 133.

UI Description

Create CAP Wizard - Welcome Wizard Page
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Create CAP Wizard - General Details Wizard Page

User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Name  The name you want to give to the CAP.

The name should be unique. The standard characters are supported: a-z,A-Z,
and 0-9. The size of the name is limited to 256 characters.

Author The name of the creator of the CAP. It can be a single user, an HP partner, or
a group in your organization.

Description The description of the CAP. The size of the description is limited to 1000
characters.

Recalculate
date

The date used to recalculate all the Contexts included in the CAP during the
CAP activation.

Default value is one year back from the CAP upload date.

You can delete the default value. If you do not specify a recalculation date, the
recalculation is not performed during CAP activation.
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Documentation Click Browse to access the location of the CAP documentation or enter the
path to the document. The document can be aMicrosoft Word file or a .PDF.

When the CAP .ZIP file is created, the document you selected is
automatically added to the .ZIP file at the level of themanifest.properties
file.

Create CAP Wizard - Select Pages Wizard Page
Select the pages you want to include in the CAP from theAvailable area and click the relevant
arrows tomove these pages to theSelected area. The pages listed in theAvailable area are the
pages that already exist in the application.

You can select more than one page using the Shift button.

To unselect pages, select them in theSelected area and click the relevant arrows tomove the
selected pages back to theAvailable area.

Click the relevant link in the navigation pane to access the corresponding page or click Next to open
the next page of the wizard.

Limitation:

l "Shared KPIs" are KPIs that are reused in different Scorecards. If you share KPIs between
CAPs by including pages that include these Scorecards, then after uploading these CAPs
to another XS machine, and after activating the first CAP, and while activating the second
CAP, the shared KPIs are removed from the Active KPIs hierarchies and from the
Scorecard of the CAP that is activated first.
It is recommended to add all the Scorecards with shared KPIs to each CAP to prevent the
removal of the shared KPIs during the activation of the second CAP.
The same issuemay occur during the backup of a CAP with shared KPIs.

l Pages from an activated CAP are listed in the Settings menu of the XS Mini App installed
on your tablet or smartphone, only after they are opened in the XS Dashboard.
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Create CAP Wizard - Select Scorecards Wizard Page
Select the Scorecards you want to include in the CAP from theAvailable area and click the
relevant arrows tomove these Scorecards to theSelected area. The Scorecards listed in the
Available area are the Scorecards that already exist in the application.

You can select more than one Scorecard using the Shift button.

To unselect Scorecards, select them in theSelected area and click the relevant arrows tomove the
selected Scorecards back to theAvailable area.

Click the relevant link in the navigation pane to access the corresponding page or click Next to open
the next page of the wizard.
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User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Available
Scorecards

The list of Scorecards that are already active in the application, that the user has
permissions to view, and that have not already beenmanually selected, or that
were not automatically selected as part of the pages that were selected in the
Create CAP Wizard - Select Pages page.

You can select more than one Scorecard using the Shift button.
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Selected
Scorecards

The list of Scorecards that you want to include in the CAP.

Note:

l SomeScorecards (that appear as dimmed) are read-only because they
are automatically included in the list of Selected Scorecards. These
Scorecards were automatically selected because in theCreate
CAP Wizard - Select Pageswizard page you selected pages that
include these Scorecards. You cannot deselect these Scorecards. A
tooltip indicates why the Scorecard cannot be selected, dragged and
dropped, or unselected.

l If you add to the CAP, a Dashboard page that includes a Scorecard, and
the Dashboard page already belongs to a CAP that has just been
activated, the Scorecard is automatically added to the list of Selected
only when the Dashboard page is opened once.

You can select more than one Scorecard using the Shift button.

Select the Scorecards you want to include in the CAP from theAvailable area
and click the relevant arrows tomove these Scorecards to theSelected area.
The Scorecards listed in theAvailable area are the active Scorecards that
already exist in the application.

To unselect Scorecards, select them in theSelected area and click the relevant
arrows tomove the selected Scorecards back to theAvailable area.

You can also drag and drop Scorecards from theAvailable area to theSelected
area and vice-versa.

Search Enter a string to list all the active Scorecards with names that include the string.
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Create CAP Wizard - Select KPIs and Metrics Wizard Page

User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Available The list of KPIs andMetrics that already exist in the application.

You can select more than one KPI or Metric using the Shift button.

Selected The list of KPIs andMetrics that you want to include in the CAP.

KPIs or Metrics that are included in the Scorecards selected in theCreate
CAP Wizard - Select Scorecards page appear as read-only. They are already
listed in theSelected area and you cannot deselect them. A tooltip indicates why
theMetric or KPI cannot be selected, dragged and dropped, or unselected.

You can select more than one KPI or Metric using the Shift button.
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Select the KPIs andMetrics you want to include in the CAP from theAvailable
area and click the relevant arrows tomove these KPIs andMetrics to the
Selected area. The KPIs andMetrics listed in theAvailable area are the active
KPIs andMetrics that already exist in the application.

To unselect KPIs andMetrics, select them in theSelected area and click the
relevant arrows tomove the selected KPIs andMetrics back to theAvailable
area.

You can also drag and drop KPIs or Metrics from theAvailable area to the
Selected area and vice-versa.

Search Enter a string to list all the active KPIs or Metrics with names that include the
string.

Create CAP Wizard - Select Contexts Wizard Page

User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description
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Available The list of available user-defined Contexts that already exist in the application and
that are not already selected.

You can select more than one Context using the Shift button.

Recommended:CSV tables used in Contexts should have unique names
across all active Content Acceleration Packs (CAPs). For details on CAPs,
see "Manage Content Acceleration Packs Using CAP Management" on page
133.

Selected The list of Contexts that you want to include in the CAP.

User-defined contexts that are related to KPIs or Metrics selected in the Create
CAP Wizard - Select KPIs andMetrics Page are already pre-selected and cannot
be deselected.

You can select more than one Context using the Shift button.

Select the Contexts you want to include in the CAP from theAvailable area and
click the relevant arrows tomove these Contexts to theSelected area. The
Contexts listed in theAvailable area are the Contexts that already exist in the
application.

To unselect Contexts, select them in theSelected area and click the relevant
arrows tomove the selected Contexts back to theAvailable area.

You can also drag and drop Contexts from theAvailable area to theSelected
area and vice-versa.

Search Enter a string to list all the active Contexts with names that include the string.

Create CAP Wizard - Summary Wizard Page
The Summary page of the wizard displays all the details of the CAP you just configured.

Expand the areas to display the details of each area.

Click Back to change the configuration.

Click Create to create the CAP. Once the CAP is created you cannot modify it. The new CAP is
displayed in the list of CAPs in the CAP Management page. For details, see "Manage Content
Acceleration Packs Using CAP Management" on page 133.
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Create Categories for the Webi Reports
In the Context Management Console (CMC) application you canmanage Categories. A Category
flag provides the option to assign eachmetric to the relevant categories. The categories are useful
to classify the different Webi reports in the list of reports to be added to a component in Dashboard.
For example, you can add a category per business context, ALM, Asset, andmore.

To access:
Access the CMC console.

Tasks
Create categories
1. Access the CMC console.

2. Create the categories:

3. You can now associatedmetrics (reports) and categories. You can assignmore than one
category to a report.
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a. Right-click the relevant Webi report.

b. Select the relevant categories for the selected report, and click OK

c. Click File> Import from CMS.

d. When you open the “Web Intelligence Rich Client” you can see all theWebi reports that are
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relevant to the specific category.
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Configure Data Warehouse Settings
DataWarehouse Settings enables you to define settings for various parts of the data warehouse
structure.

To access:
Select Admin > Data Warehouse.

Learn More
Model
The data warehousemodel is an end-to-end solution for extracting source data and consolidating
disparate source datamodels into a consolidated datamodel. The data organized to reflect this
model resides in target tables that become the source for Executive Scorecard.

The data warehouse relies on an external RDBMS to provide daily maintenance and backup
support, SAP BusinessObjects Data Services to assist with ETL, an ABC infrastructure of utilities
and processes to govern regularly scheduled ETL jobs, and internal data warehouse utilities to
create the data warehouse andmaintain data integrity.

The figure below shows the principal data warehouse components and how they interact. Read the
following sections for more information about each component, its role, and responsibilities.

HP IT Executive Scorecard (9.31)Page 160 of 282



Source Data Models
Source data originates in external application repositories. Data generated by an external
application can be rich in business information, but unless you can integrate it with equally
important business information generated by other applications, it is difficult to get a complete view
of operational information.

The source datamodels describe the source and extraction format so that the data warehouse can
consume this data and integrate it into a common view that you can use to populate comprehensive
business intelligence reports and dashboards.

Data Integration Interface
The data integration interface (DII) is the access layer that stands between the source database
models and the extractionmodels in the staging database. The DII uses amappingmodel that
transforms the source data to fit into extraction work tables. The DII can accommodateminor
variations in the sourcemodel schemas from one version to another.

Note: This interface requires access to the source systems.

SAP BusinessObjects Data Services
SAP BusinessObjects Data Services is the access mechanism that performs the physical data
extraction from the source repository to the staging database. Each stage of the ETL is embodied in
a Data Services job, from the extraction of source data to the target database.

Audit, Balance, and Control
Audit, Balance, and Control (ABC) processes ensure that source data is not corrupted in the
extraction process, and that the integrity of the extracted data is maintained as it progresses from
the initial source extraction through the logical and physical transformation into target tables. SAP
BusinessObjects Data Services canmove the data but does not evaluate whether the final result is
correct. ABC establishes checkpoints and provides feedback on each step to guarantee that each
step is valid before the next step begins.

The Audit component ensures consistency during ETL processing. It measures the number of
records in and the number of records out for each step and displays these runtime statistics in a
collection of audit reports.

Balance verifies that data in the data warehousematches data in the source system. For example,
if the data warehouse stores project dollar amounts then the balance process verifies that the
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aggregate project dollars in the data warehousematches the aggregate project dollars in the source
application data.

Control governs the order of execution of ETL processes. Control makes sure that there is a proper
restart and recovery when a system error occurs. Control alsomanages job dependencies at
runtime.

ABC utilities are applications that you can invoke automatically or manually to run ETL, solve
problems, and perform ETL-related tasks.

Staging Database
The staging database contains tables and snapshots that are critical to the ETL process. Metadata
describes these tables. Executive Scorecard processes data in the staging database before loading
it into the final target tables in the target database.

l Extraction (EXT) tables contain the initial version of source data. EXT tables are used during the
stage of ETL when Executive Scorecard loads data from the extract flat files into the staging
database.

l Validation failure (VALF) tables are used during the data validation process that ensures all of
the data is usable. VALF tables store source data that is rejected by the ETL process due to
validation failure. Data validation is part of the process to load the EXT tables.

l Identification (SSI andMSI) tables restructure the diverse source system data into a conformed
structure. Executive Scorecard uses SSI andMSI tables to standardize the data and add an
enterprise key.

l Consolidation (MSC) tables integrate disparate source data into a consolidated entity. TheMSC
tables contain the uniform structure that Executive Scorecard uses to load the data into the
target tables.

l Transformation (XFR) tables are load-ready tables that match the internal structure of the target
tables. Executive Scorecard uses XFR tables while preparing the data to be loaded into the
target tables in the target database.

l Lookup (LOOKUP) tables store durable keys and surrogate keys. Executive Scorecard uses
these tables to establish dimension-to-dimension references in dimension tables and
foreign key references in fact tables.

l Snapshot (TSNP, SSNP, and CSNP) tables are the persistent storage for ETL staging data.
These snapshot tables capture the changed data and support the data warehouse recovery
process. The data warehouse uses TSNP tables for source extraction staging, SSNP tables for
single source integration staging, and CSNP tables for multiple source consolidation staging.
The final ETL stage captures the snapshot data.

l Cross Reference (XREF) tables support the data integration processes that combine records
frommultiple sources into a single record in the consolidationmodel.

l Cross ReferenceGenerator (XREFGEN) tables support datamatching and cross reference
inputs for the consolidationmodels.

l Metadata tables contain a logical model and describe how to translate that model into the
physical implementation of tables and views.

ABC tables support the ETLworkflow and enable job control and sequencing. They also host audit
information to ensure data quality.
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Target Database
The target datamodels describe the format of the data that produces business intelligence
analytics. The instantiated datamodels are dimension, fact, and hierarchy tables populated with
data obtained through ETL processes.

Dimension tables contain the datamodel to be queried and presented by Executive Scorecard in a
variety of reports and analytics.

Fact tables contain data that describes events, transactions, or other granular information.

Fact snapshots tables are fact tables that describe the state of things in a particular instance of
time, and usually includes more semi-additive and non-additive facts.

l Semi-Additive:Semi-additive facts are facts that can be summed up for some of the
dimensions in the fact table, but not the others.

l Non-Additive:Non-additive facts are facts that cannot be summed up for any of the dimensions
present in the fact table.

Hierarchy tables capture hierarchical relationships among levels of data.

Queries
You can use structured query language (SQL) to create a primary abstraction layer of data from the
target tables and use that data to populate reports, dashboards, or resolve business questions. The
SAP BusinessObjects Enterprise XI 3.1 suite of business tools simplify accessing this information
and storing it in business-oriented views.
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Presentation
SAP BusinessObjects Enterprise XI 3.1 uses a universe abstraction layer to organize data for
presentation in out-of-box or user-designed analytics. The universe provides a business oriented
view of the data that resides in the data warehouse target tables.

Tasks
To define the Data Warehouse Settings:
1. Select Admin > Data Warehouse.

2. Click the relevant field in theValue column and enter the value.

3. Click Save to save your settings.

UI Description
Data Warehouse Page
This page enables you to configure the DataWarehouse settings.

Data Warehouse Table

Name The name of the DataWarehouse field.

Description The description of the DataWarehouse field.

Value The current DataWarehouse field value.

Click the relevant row and enter a value.

General Table
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UI Element Description

Data
Warehouse
Port

The DataWarehouse web server port. This field is read-only.

Data
Warehouse
Server
Name

The DataWarehouse server machine hostname or IP address. This field is read-
only.

External
Source
File
Location

The directory where the external source files used by the DataWarehouse are
stored.

Fiscal
month of
year

The first month of the fiscal year. This field is read-only.

First year
handled by
DWH dates

The first available year for DataWarehouse dates. This includes period, time
zones or DST.

Last year
handled by
DWH dates

The last available year for DataWarehouse dates. This includes period, time
zones or DST.

Scheduler
Run-steps
Interval

The interval value in minutes that you want the run_steps command to
automatically execute. This is the default value for initial execution. All changes in
interval should bemade in the DW ABC Streams Management UI. For details, see
"Perform Tasks for ETLManagement " on page 175.

A run-steps schedule configured in DataWarehouse Settings does not affect the
existing running batch schedule. It is recommended to only change the run-steps
interval schedule in the ETLManagement tab DW ABC Streams Management UI.

To enable a new run-steps schedule configured in DataWarehouse Settings on
existing defined streams you can:

l Restart the XS server.

l Reload the dw-abc-services application: Glassfish Admin Console >
Applications, and click Reload for the dw-abc-services application.

l Redeploy the application

In these cases you would have now two scheduled intervals. Delete one in the
DW ABC Streams Management UI.
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SAP BusinessObjects Data Services for HP XS Table

UI Element (in
alphabetical
order)

Description

BODS
Database
Administrator
Username

The username to access the SAP BusinessObjects Data Services database.
Must have write permissions.

BODS
Database
Administrator
Password

The user's password to access the SAP BusinessObjects Data Services
database.

BODS database
type/product

The database type: Oracle, SQL Server, DB2, MS SQL, or Sybase ASE.
This field is read-only.

Note: Currently only MS SQL is supported.

BODS
Repository
Server Name

The SAP BusinessObjects Data Services repository server machine's host
name or IP address.

Installation
Directory

The absolute path to the SAP BusinessObjects Data Services and HP XS
installation directory. This field is read-only.

Management
Console
Password

The SAP BusinessObjects Data Services management console password.

Management
Console URL

The SAP BusinessObjects Data Services management console URL. This
field is read-only.

Management
Console
Username

The SAP BusinessObjects Data Services management console username.
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UI Element (in
alphabetical
order)

Description

Repository
Database-
Server's Port

The SAP BusinessObjects Data Services repository database server's port.
This field is
read-only.

Repository
Name

The SAP BusinessObjects Data Services repository name. This field is read-
only.

Repository
Password

The SAP BusinessObjects Data Services repository password.

Repository
Username

The SAP BusinessObjects Data Services repository username. This field is
read-only.

Web Services
Timeout

The amount of time, in seconds, that DataWarehouse waits for a SAP
BusinessObjects Data Services to respond to a web services request before
a timeout.

Staging Database Table

UI Element (in
alphabetical order)

Description

ABC Database
Password

The ABC database password.

ABC Database
Username

The ABC database username. This field is read-only.

ABC DB login name ABC login name used to access the database.
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UI Element (in
alphabetical order)

Description

ABC DB login
password

ABC login password used to access the database.

Database Password The staging database password.

Database Server Name The staging database server machine hostname or IP address.

Database Server Port The staging database server port.

Database Username The staging database username. This field is read-only.

Metadata Database
Password

Themetadata database password.

Metadata Database
Username

Themetadata database username. This field is read-only.

Metadata DB login
name

Metadata login name used to access the database.

Metadata DB login
password

Metadata login password used to access the database.

Password The staging database administrator password.

Staging Database Name The name of the staging database on theMS SQL server. This field
is read-only.

Staging DB login name Staging database login name used to access the database.

Staging DB login
password

Staging database login password used to access the database.

Staging Target DB
Database Password

The staging target database password.

Staging Target DB
Database Username

The staging target database username. This field is read-only.

Staging Target DB
login name

Staging Target database login name used to access the database.

Staging Target DB
login password

Staging Target database login password used to access the
database.

Time Dimension
Granularity

The granularity of time, in minutes, of the time dimension. This field
is read-only.

Username The staging database administrator username. This user must have
write permissions. This field is read-only.
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Target Database Table

UI Element (in
alphabetical order)

Description

Administrator
Password

The target database administrator password.

Administrator
Username

The username used to access the target database. This user must
have write privileges. This field is read-only.

Database Password The target database password.

Database Server Port The target database server port. This field is read-only.

Database Username The target database username. This user must have write permissions.
This field is read-only.

MS SQL Server
Database Name

The target databaseMS SQL server name. This field is read-only.

Server Name The target database server name. This field is read-only.

Target DB login
name

The login name for the target database. May be different than the fixed
user and schema name.

Target DB login
password

The target database login password used to access target database
metadata.
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Integrate the Data Sources
The DataWarehouse can connect to other products (data sources) and gather data about these
products. An integration is available for each product (data source). The connection from the data
source to the DWH is called a content pack. FBI extracts the data from the specific data source.
Content packs contain all the artifacts needed to connect to the relevant data source and gather
data from that data source.

Learn More
To learn about Content Packs and their functionality, see "Perform Tasks for Data Source
Management" on page 197.

For more detailed information about each data source's integration, seeIntegrate the Data Sources
in theContent ReferenceGuide.

Tasks
Integrate with the ALM (andQC) Data Source in theContent ReferenceGuide.

Integrate with the AM Data Source in theContent ReferenceGuide.

Integrate with the BSMData Source in theContent ReferenceGuide.

Integrate with the DP Data Source in theContent ReferenceGuide.

Integrate with the IC Data Source in theContent ReferenceGuide.

Integrate with the NA Data Source in theContent ReferenceGuide.

Integrate with the NNMData Source in theContent ReferenceGuide.

Integrate with the OOData Source in theContent ReferenceGuide.

Integrate with the PPMData Source in theContent ReferenceGuide.

Integrate with the SA Data Source in theContent ReferenceGuide.

Integrate with the SM Data Source in theContent ReferenceGuide.

Integrate with the UCMDB Data Source in theContent ReferenceGuide.

"Sample Integration Activation Using the UI" below

"Sample Integration Activation Using the Automation Tool" on page 172

Sample Integration Activation Using the UI
Activate the Integration (Sample)
1. Prerequisites: Make sure all of the required prerequisites have beenmet.
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2. Select Admin > Data Source Management then click Add data source.

3. Select the data source type.

4. Select or enter the configuration parameters.

5. Click Next to proceed to the validation page.

UI Description (Sample-AM Oracle server)

User interface elements are described below:

UI Element Description

Instance name Enter a name for the data source instance you are activating.

AM Version Select the relevant AM version. For details, see the IT Executive
Scorecard Support Matrix.
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UI Element Description

Time Zone Select the time zone for the data source.

Data Source Type AM should be configured to run on anOracle server.

Server Enter the Oracle server.

Username Enter your username used for login to the AM database.

Password Enter your password used for login to the AM database.

Hostname/IP
Address

Enter the Oracle server hostname or IP address.

Port Enter the port for database connections.

SID Enter the unique name of the database.

Service Name Enter the alias used when connecting.

Initial Load Period
(months)

Select the number of months from which you want the initial data
loaded.

Sample Integration Activation Using the
Automation Tool

If you experience errors or problems with the data SourceManagement UI, you can activate the
sources using DWH back-end tools.

Activate the Integration (Sample-AM Oracle server)
1. Prerequisites: Make sure all of the required prerequisites have beenmet.

2. Enter the product name, product version, time zone, and product type of the data source, and
the configuration parameters in the datasource.xml file as follows:

o server. The data source server.

o user. The user required for authenticating to the data source server.

o password. The password required for authenticating to the data source server.

o host. The remote server on which the data source server resides.

o port. The port in the data server. By default, the port number is 1521 for Oracle database
and 1433 for SQL Server database.

o sid. The unique name of the database.

o servicename. The alias used when connecting.

o initial load period. The number of months from which you want the data loaded.

HP IT Executive Scorecard (9.31)Page 172 of 282

Administrator Guide



Note: Each Content Pack contains a sample xml file for example: <Installation
Directory>\agora\ContentPacks\SA\conf\dataSources.xml.

Sample xml configuration (Advanced configuration)

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

<dw:DataSourceConnections version="1.0"

xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

xsi:schemaLocation="http://schemas.hp.com/bto/dwh/v1/dw_

dataSources ..\xmlSchemas\dw_dataSources.xsd"

xmlns:dw="http://schemas.hp.com/bto/dwh/v1/dw_

dataSources">

<dw:DataSourceConnection productName="AM"

productVersion="5.2" timeZone="Asia/Shanghai"

productType="oracle">

<dw:GenericProperty propertyName="server"

propertyValue="" propertyType="string"/>

<dw:GenericProperty propertyName="user"

propertyValue="" propertyType="string"/>

<dw:GenericProperty propertyName="password"

propertyValue="" propertyType="password"/>

<dw:GenericProperty propertyName="port"

propertyValue="1521" propertyType="string"/>

<dw:GenericProperty propertyName="sid"

propertyValue="" propertyType="string"/>

<dw:GenericProperty propertyName="servicename"

propertyValue="" propertyType="string"/>

<dw:GenericProperty

propertyName="dwh.etl.initialloadmonths" propertyValue="6"

propertyType="string"/>

</dw:DataSourceConnection>

</dw:DataSourceConnections>

Note: In order to verify that the connection details added in the datasources.xml file
are correct, it is recommended to test the connection to the data source before running
the configuration. For details, see "The Automation Tool" on page 265.

3. Register Instance:

To add an additional data source instance enter: dw_cp_register.bat -addInstance –name
<CP_NAME>

The DataWarehouse then looks for the CP in the Content Packs Folder. The instance ID is
displayed in the output.“Instance ID: XX has been added to Content Pack: <CP_NAME>”

It is also added to the CONTENT_PACK table.

4. Configuration:
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For first time activation, enter the following: dw_ds_automation.bat -task ConfigureInitial -
cp <content pack name> -instance <INSTANCE_ID> -xmlFilePath [Path to
datasources.xml file].

For all subsequent activations, enter the following: dw_ds_automation.bat -task Configure -
cp <content pack name>-instance <INSTANCE_ID> -xmlFilePath [Path to
datasources.xml file].

Note: After you have configured dw_ds_automation.bat -task ConfigureInitial or dw_ds_
automation.bat -task Configure, delete the value in the propertyValue field of the password
from the dataSources.xml file, as follows:
<dw:GenericProperty propertyName="password" propertyValue=""
propertyType="password" />

For details, see "The Automation Tool" on page 265.

5. Deployment:

Enter the following: dw_ds_automation.bat -task Deploy -cp <content pack name>-
instance <INSTANCE_ID>.The content pack is initialized.

6. Activate the data source:

Enter the following: dw_ds_automation.bat -task Activate -cp <content pack name> -
instance <INSTANCE_ID>.
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Perform Tasks for ETL Management
The ETLManagement tab displays the DW ABC Streams Management UI which enables you to
perform the essential tasks related to ETL and stream functionality. It displays the state of active
streams, and enables you to schedule and control stream activity. It also allows you to view the
historical data and the archived stream definitions. All ETLmanagement and functionality is
accessed and performed through this UI.

To access:

Select Admin > ETL Management.

Learn More
ETL
The Extract, Transform, and Load (ETL) process is an end-to-end transfer of external source data
through several staging layers and into the target layer of the data warehouse. The source data can
reside in a single database or multiple databases. The data warehouse uses the ETL process to
extract, consolidate, and transform the source data into ameaningful target model that populates
relevant business analytics.

The ETL process comprises eight primary stages. The stages of this process depend onmetadata
and the nature of the sources.

The ETL is monitored andmanaged through the DW ABC Streams Management User Interface.

ETL Stream Management and Monitoring
The Audit Balance and Control Management user interface performs all of the back-end
configuration and supports full ABC functionality in the ETL. The UI enables you to view the active
stream and all of the nodes containing the stream steps. This allows you to pinpoint exactly which
steps have failed when the stream has been stopped. You can also view the history of the stream
as well as inactive streams.

Stream

A stream represents the definition of what should run in the ETL, for example, Upstream. It is a set
of a flow of ETL steps. The DW ABC Streams Management UI displays any stream that is defined,
along with the historical data and archived stream information for that stream.

Batch

A batch is a particular run-time instance of the stream. There is a new batch ID for each run of the
batch. Each time you load a batch, you are creating a run-time instance of the current stream
definition.

Step

Any type of execution that you want to run in the ETL. The step is defined in a stream.

Node
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A group of steps that run in parallel and are independent of each other. A node is meant to simplify
the display of the stream and to indicate whether a stream is blocked. The node indicates whether
the batch can progress to the next node. If one step has failed, even if all other steps in the node are
successful, the execution of the ETLwill not progress to the next node.

The ABC Streams Management UI provides visibility andmanagement of:

l Multiple streams

l Stream progress

l Stream execution history

l Archiving

l Batch scheduling

Audit, Balance, and Control
Audit, Balance, and Control (ABC) is a set of functions based on data warehousing best practices.
Although SAP BusinessObjects Data Services manages the ETLworkflow, ABC ensures work
flow integrity. It controls the overall ETL execution, provides error handling, and collects job
progress statistics. ABC's ETL streams and functions can be viewed andmanaged through the
DW ABC Streams Management User Interface, as well as the CLI. Other ABC features are:

l Job streammanagement

l Command line administration tools

l Generated ABC operational system reports

l Generated ABC historical system reports

For report details, see "ABC Operational Reports " on page 207 and " DataModel Reports" on
page 223.

Tasks
This section includes:

"To view active streams" on next page

"To display hidden streams" on next page

"To verify or schedule the run_steps command" on next page

"To view stream attributes" on next page

"To schedule a batch job" on page 178

"To load or resume a batch job" on page 178

"To suspend a stream" on page 178

"To abort a stream" on page 178

"To view node information" on page 178

"To view step attributes" on page 178

"To refresh stream data" on page 178
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"To view historical data" on next page

"To view archived data" on next page

"To automatically retry steps" on page 179

"Tomanually retry steps" on page 179

To view active streams
1. Select Admin > ETL Management.

2. In the DW ABC Streams Management UI page the stream information is displayed.

To display hidden streams
The DW ABC Streams Management UI enables you to view streams that are hidden and used only
for back-endmaintenance.

1. Select Admin > ETL Management and select Show Hidden Streams.

2. The hidden ETL streams are displayed.

3. You can then schedule the run-steps command and load the batches, as needed.

4. Click to load and run the batch.

5. Click to refresh and check the running status of the ETL.

For details, see "Use Enterprise Readiness (ER) Tools" on page 191.

To verify or schedule the run_steps command
Run_steps is automatically scheduled after deployment in the post-install. It schedules steps for
each defined stream. The run_steps Scheduler dialog box enables you to verify or change the
settings. The ABC Web Services server automatically creates a schedule for each active stream
(Upstream). Run_steps executes every fiveminutes, or whatever interval you have set in the DWH
settings for the value run_steps scheduler interval. For details see "Configure DataWarehouse
Settings" on page 160. The stream will only run once you have loaded a batch.

Note: If you add a new stream definition, youmust manually define a run_steps schedule.

1. Select Admin > ETL Management and click in the Stream Information area.

2. The Stream Scheduler dialog box opens.

3. Select theRun-Steps Scheduler tab.

4. Click Add New to create a new schedule for a specific stream.

5. Click Save.

6. Click Delete to delete a displayed schedule. You can then add a new one to replace it.

To view stream attributes
1. Select Admin > ETL Management and click More Info in the Stream Information area.

2. The Stream Attributes dialog box opens, displaying the various read-only stream details.
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To schedule a batch job

1. Select Admin > ETL Management and click in the Stream Information area.

2. The Stream Scheduler dialog box opens.

3. Select the Load -Batch Scheduler tab.

4. Select the relevant Schedule Type and times and click Save.

To load or resume a batch job
1. Select Admin > ETL Management .

2. When there is no running batch (stream state is None) or the running batch is in a suspended

state (stream state is Suspended), click to load or resume a batch.

To suspend a stream
When the stream is running and the state is Active, you can suspend the stream to allow no action
to happen.

l Select Admin > ETL Management and click in the Stream Information area.

To abort a stream
When you abort, the batch cannot be run again, when you load, it will start a new batch.

l Select Admin > ETL Management and click in the Stream Information area.

To view node information
1. Select Admin > ETL Management and click a node in the Stream Information area.

2. The Node Step list opens with the step information displayed.

To view step attributes
1. Select Admin > ETL Management and click More Info in a specific node.

2. The Step Attributes dialog box opens, displaying the various read-only step details.

To refresh stream data

l Select Admin > ETL Management and click in the Stream Information area.

To view historical data
Themost recent batch history of the stream is displayed first. You can navigate through the pages
of the various batches. You can view up to five batches at a time.

1. Select Admin > ETL Management and click Historical Data in the Stream Information area.

2. The Historical Data page opens.

3. Select Next to view the other batches in the stream's history. All fields are read only.

To view archived data
You can view previous stream definitions and the historical data for each. The historical data is the
batch history for that particular definition. When you add a data source it changes the stream
definition. The new definition has no historical data, you can only view the archived stream and see
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the historical data of the previous definitions. All fields are read only.

1. Select Admin > ETL Management and click Archived Streams in the Stream Information
area.

2. The Archived Stream Definition page opens.

To automatically retry steps
There is an automatic retry for attempting to fix step errors. A step that has an error it will not
necessarily remain and can resolve itself.

There is a configurable automatic retry mechanism which is set by default to four times. For details
on changing the amount of automatic retries, see "Change the Number of Retries for a Failed ETL
Step" on page 269.

To manually retry steps
The retry image appears when there has been a failure on a step.

1. Select Admin > ETL Management and click an error node in the Stream Information area.

2. The Node Step list opens with the step information displayed.

3. If all of the retries have been exhausted, and the Retry icon appears.

4. Click in the Stream Information area to suspend the stream.

5. Fix the problem, andmanually retry by clicking .

6. Once the error is resolved, click to resume the stream.

UI Description
DW ABC Streams Management Page
You can view andmanage ETL stream functions and run-time information through the DW ABC
Streams Management UI. The active stream and details are displayed as well as the node and step
details.
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<Stream Display>
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

<Stream
Information>

Displays the following stream details:

l Stream Name

l Status: Active or Suspended or None

l Duration

l Date

Show Hidden
Streams

Click to display the hidden ETL streams.

Refreshes the stream information. There is an automatic refresh of the
stream information every twominutes.

More Info Opens the Stream Attributes dialog box. For details, see "Stream Attributes
Dialog Box" on next page

Load Batch/Resume. Starts or resumes the running of the specific batch of
ETL stream.

Opens the Stream Scheduler dialog box. Enables you to schedule the load
batch and run_steps commands. For details, see "Stream Scheduler Dialog
Box" on page 185.

Suspend Stream. Temporarily suspends the stream.

Abort Stream. Stops the stream that is running.
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UI Element Description

<Node Display> Displays the nodes representing the groups of steps within one level of
execution of an ETL run, the steps that can run in parallel. A node is a
collection of steps that all run in parallel. The icon for each node represents
the worst status of all of the steps in the node.

Indicates that the particular step or all steps in the node have finished
successfully in the execution.

Indicates that a step or a step in the node is currently running

Indicates an error in one of the steps. The step is automatically retried
four times by default.

Click the Error node to display the Node Step List in order to retry steps.

Click to retry the step.

Indicates a warning in one of the steps.

Click a node to open the Node Step list.

If there is an error in any of the steps, then all steps in the execution of the
stream are stopped. In order to move to the next node, the error must be
resolved.

Click More Info to display the Step Details dialog box pertaining to the
particular step. For details, see "Step Attributes Dialog Box" on page 183.

Historical Data Opens the Historical Data page where you can view stream history,
including the active stream.

For details, see "Historical Data Page" on page 187

Archived
Streams

Opens the Archive Data page where you can view streams that were
previously active with a different definition. for details, see "Archived
Streams Page" on page 189.

Stream Attributes Dialog Box
This dialog box enables you to view the attributes of the displayed stream.
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User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

All fields are read-only.

UI Element Description

Name Stream name.

Batch ID The ID of the specific batch job of the stream.

Status
Information

Provides details about the status of the stream.

Status Displays the status of the batch:

l OK

l Warning

l Error
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UI Element Description

State Displays the state of the batch:

l Active

l Suspended

l Finished

l Aborted

Start Time The date and time of the start of the batch job.

End Time The date and time of the end of the stream batch job.

Recovery
Action

Displays any information about recovery actions if the stream was
suspended or stopped.

Last
Suspended

The date and time the stream was suspended.

Last Resumed The date and time the stream was resumed.

Aborted The date and time the stream was aborted.

Step Attributes Dialog Box
This dialog box enables you to view the attributes of the displayed step.
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User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

All fields are read-only.
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UI Element Description

Name Step name.

Process ID The ID of the specific run of the step.

Batch ID The ID of the specific batch job of the stream.

Status
Information

Provides details about the status of the step.

Status Displays the status of the step:

l NA

l SUCCESS

l WARNING

l ERROR

l MAX_EXECUTION_TIME_EXCEEDED

State Displays the state of the step:

l WAITING

l RUNNING

l STARTING

l FINISHED

Start Time The date and time of the start of the run.

End Time The date and time of the end of the run.

Job Name The BODS job name.

Retry
Sequence

The number of automatic retries.

Recovery
Action

Displays any information about recovery actions if the step failed.

Schedule
Time

The date and time the batch was loaded.

WS Call Time The date and time that ABC makes the call to execute. Indicates if there is a
problem in the execution.

Step Details BODS Jobs: The workflows for the BODS jobs associated with each step.

Other executables: Sub-processes of the step.

Stream Scheduler Dialog Box
This dialog box enables you to schedule a specific batch job and schedule a run_steps command.
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Load Batch Scheduler Tab

User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI
Element

Description

Schedule
Type

Select either:

l Interval: Timeframe inminutes.

l Time of day: Time according to 24 hour clock.

Enter the required schedule time in the relevant row.

Delete. Deletes the adjacent schedule time.

Add New Creates a new schedule. The new schedule is displayed in blue. When the schedule
is saved to the server, the schedule is displayed in black.

Save Saves all changes to the server.

Discard Discards all changes without saving them to the server.

Close Closes the Load Batch Scheduler dialog box.

Note: Click the down arrow in each column to filter your scheduling information.

Run_Steps Scheduler Tab
This sets the frequency that the ETLManagement runs all of the executables for the stream.This
includes steps that are loaded as well as the batches created.
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User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI
Element

Description

Interval
(mins)

Enter the interval at which you want to schedule the run_steps command.

The default run_steps interval is initially set at 5minutes in the DataWarehouse page
of the Admin tab, but it is recommended to only make changes to the run_steps
interval in this scheduler.

Add
New

Enables you to add a new schedule for the run_steps command.

Save Saves all changes to the server.

Discard Discards all changes without saving them to the server.

Close Closes the run-steps Scheduler dialog box.

Note: Click the down arrow in each column to filter your scheduling information.

Historical Data Page
You can view a stream's job history on the Historical Data page..
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<Stream Display>
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Back to Active
Streams

Opens the DW ABC Streams Management UI main page.

<Stream
Information>

Displays the following stream details:

l Batch ID Number

l Status: Active, Suspended or Aborted

l Duration

l Date

More Info Opens the Stream Details dialog box. For details, see "Stream Attributes
Dialog Box" on page 181.
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UI Element Description

<Node Display> Displays the nodes representing the groups of steps within the execution of
an ETL run. A node is a collection of steps that all run in parallel.

Indicates that all steps are running in the execution.

Indicates an error in one of the steps. The step is automatically retried
four times by default.

Indicates a warning in one of the steps.

Click a node to open the Node Step list.

Previous Navigates to the previous job history data for the stream.

Next Navigates to the next job history data for the stream.

<< Navigates to the earliest job history data for the stream.

Archived Streams Page
This page enables you to view stream definitions that have been changed and archived..
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User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

All fields are read-only.

UI Element Description

Back to
Active
Streams

Opens the DW ABC Streams Management UI main page.

<Stream
Information>

Displays the following stream details:

l Stream Name

l Status: Active or Suspended

l Duration

l Date

More Info Opens the Stream Details dialog box. For details, see "Stream Attributes Dialog
Box" on page 181.

Historical
Data

Opens the Historical Data Page where you can view the archived stream
history. For details, see "Historical Data Page" on page 187.

Back to
Active
Streams

Opens the DW ABC Streams Management UI main page.

<Node
Display>

Displays the nodes representing the groups of steps within the execution of an
ETL run. A node is a collection of steps that all run in parallel.
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Use Enterprise Readiness (ER) Tools
The ER tools provide better manageability and awareness of processes in the system, and enable
you to clean problematic entities or all data, as well as re-stream existing data with problematic
logic according to batch or specific date. The Restream and CleanData streams are hidden by
default. However, they can bemanaged, as any other stream, in the ETLManagement tab.

When you have specific KPI and data problems in Executive Scorecard, or after you run the ETL,
check the Target tables for any issues. If you find a problem with specific entities, note the specific
batch id or the specific load date in the Target tables. Depending on the issue, you will need to
either clean or restream the data to fix the issues.

To access the CleanData and Restream streams:

Admin > ETL Management and select theShow Hidden Streams checkbox.

For ETL stream details, see "Perform Tasks for ETLManagement " on page 175.

CleanData

Note: The CleanData stream is an advanced ETL tool. Running the CleanData stream erases
all existing data in the Staging tables.

CleanData does not clean historical data in the Target tables.

The DW ABC Streams Management User Interface enables you to clean corrupted data by specific
criteria and then reload data from the source by running the Upstream ETL stream.

CleanData is used to enable the data in DWH to be restored to a specific version, as follows:

l CleanData by batch, entity or all entities.

l CleanData by date, entity or all entities.

Note: Running the CleanData streammay not recover all existing data.

Restream
The DW ABC Streams Management User Interface enables you tomanage re-streaming the entire
ETL loading process. This functionality allows you to re-stream the entire ETL stream from a
previous batch to the latest batch, as well as revise incorrect data in the DWH Target.

Restream is used to re-stream the entire ETL loading from a specific batch point to the latest point,
as follows:

l Re-stream by batch, entity or all entities.
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Command Line Interface Tool
To run the ER tools in ETLManagement youmust first use command line batch files to set the
stream parameters. The two batch files are found in the DWH/bin folder.

The log information is inDWH/log/dw_abc.log.

The log level can bemodified inDWH/conf/abc-log4j.xml.

Note: The arguments are populated into an ABC table called CONTROL_ARGS. If there are
unexecuted commands in CONTROL_ARGS, the batch files cannot insert new records into
the CONTROL_ARGS table.

CleanData Command

dw_abc_cleandata

[-batch <batch_id>] [-entity <entity_name>] [-inputdate <input_date_of_batch>] [-display] [-delete]
[-help]

Options:

l -batch: The batch ID of the point in DWH from which you want the data to be cleaned.

For example, if the DWH system has 5 batches, and the problem is with batch 2, then it will
delete batch numbers 2, 3, 4, and 5.

l -entity: Themodel name of the entity that you want cleaned.

l -inputdate: The date of the restore point in DWH from which you want data cleaned.

l -display: Display all existing commands.

l -delete: Delete the unexecuted commands.

l -help: Print the helpmessage.

Example:

dw_abc_cleandata -batch 1 -entity LOCATION

dw_abc_cleandata -batch 1 -entity LOCATION,SERVICE,ORG

dw_abc_cleandata -batch 1 -entity ALL

dw_abc_cleandata -inputdate 2012-09-30 -entity LOCATION,SERVICE,ORG

dw_abc_cleandata -inputdate 2012-09-30 -entity ALL

dw_abc_cleandata -help

dw_abc_cleandata -display

dw_abc_cleandata –delete

Returns:

l 0 success

l 1 success with warnings

l >1 errors present

Restream Command:
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dw_abc_restream

restream. bat [–batch <batch_id>] [-entity <entity_name>] [-full <full_restream>] [-display] [-delete]
[-help]

Options:

l -batch: The batch ID of the point in DWH from which you want the batch re-streamed.

For example, if the DWH system has 5 batches, and the problem is with batch 2, then it will re-
stream batch numbers 2, 3, 4, and 5.

l -help: Print the helpmessage.

l -entity: Themodel name of the entity you want re-streamed.

l -full: The flag of the re-stream indicator that allows only re-streaming the error data from the
VALF table when it is equal to N, otherwise it re-streams all data.

l -display: Display all existing commands.

l -delete: Delete the unexecuted commands.

l -help: Print the helpmessage.

Example:

dw_abc_restream -batch 1 -entity LOCATION -full Y

dw_abc_restream -batch 1 -entity LOCATION,SERVICE,ORG -full Y

dw_abc_restream -batch 1 -entity ALL -full Y

dw_abc_restream -batch 1 -entity LOCATION -full N

dw_abc_restream -batch 1 -entity LOCATION,SERVICE,ORG -full N

dw_abc_restream -batch 1 -entity ALL -full N

dw_abc_restream -help

dw_abc_restream -display

dw_abc_restream –delete

Returns:

l 0 success

l 1 success with warnings

l >1 errors present

Tasks
This section includes:

"To utilize the Restream or CleanData streams:" below

"To display hidden streams:" on next page

To utilize the Restream or CleanData streams:
1. Run the following command line batch files found in the DWH/bin folder to set the stream

parameters.

dw_abc_cleandata
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dw_abc_restream

2. After you run the command line batch files, access the ER tools and run the Restream or
CleanData streams.

To display hidden streams:
1. Select Admin > ETL Management and select Show Hidden Streams.

2. The hidden ETL streams are displayed.

3. You can then schedule the batches, as needed.

4. Click to load and run the batch.

5. Click to refresh and check the running status of the ETL.

6. Once the ETL is running successfully, re-run the Upstream stream.

For ETLManagement details, see "Perform Tasks for ETLManagement " on page 175.

UI Description
To access the CleanData and Restream streams:

Admin > ETL Management and select theShow Hidden Streams checkbox.
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<Stream Display>
User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

<Stream
Information>

Displays the following stream details:

l Stream Name

l Status: Active or Suspended or None

l Duration

l Date

Show Hidden
Streams

Click to display the hidden ETL streams.

Refreshes the stream information. There is an automatic refresh of the
stream information every twominutes.

More Info Opens the Stream Details dialog box. For details, see "Use Enterprise
Readiness (ER) Tools" on page 191

Load Batch/Resume. Starts or resumes the running of the specific batch of
ETL stream.

Opens the Stream Scheduler dialog box. Enables you to schedule the load
batch and run_steps commands. For details, see "Use Enterprise
Readiness (ER) Tools" on page 191.

Suspend Stream. Temporarily suspends the stream.

Abort Stream. Stops the stream that is running.
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UI Element Description

<Node Display> Displays the nodes representing the groups of steps within one level of
execution of an ETL run, the steps that can run in parallel. A node is a
collection of steps that all run in parallel. The icon for each node represents
the worst status of all of the steps in the node.

Indicates that the particular step or all steps in the node have finished
successfully in the execution.

Indicates that a step or a step in the node is currently running

Indicates an error in one of the steps. The step is automatically retried
four times by default.

Click the Error node to display the Node Step List in order to retry steps.

Click to retry the step.

Indicates a warning in one of the steps.

Click a node to open the Node Step list.

If there is an error in any of the steps, then all steps in the execution of the
stream are stopped. In order to move to the next node, the error must be
resolved.

Click More Info to display the Step Details dialog box pertaining to the
particular step. For details, see "Use Enterprise Readiness (ER) Tools" on
page 191.

For more details onmanaging ETL streams, see "Perform Tasks for ETLManagement " on page
175.
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Perform Tasks for Data Source Management
Data SourceManagement enables you tomanage the integration of data into the data warehouse
through the activation of data sources. The available data source content packs are registered in
the deployment process and can then be activated in the Data SourceManagement page.

To Access:Select Admin > Data Source Management then click Add data source .

Learn More
Learn about Content Packs
The DataWarehouse can connect to other products (data sources) and gather data about these
products. An integration is available for each product (data source). A Content Pack is a set a files
which defines the execution of an ETL along with all its parameters.

The connection from the data source to the DWH is called an integration content pack (iCP). Each
content pack uses an extractor in order to extract the data from the specific data source and contain
all the artifacts needed to connect to the relevant data source and gather data from that data source.
Content packs include:

l The definition of the datamodel used for the connection.

l The type of data gathered from the data source.

l The ETL definitions.

l The definition files.

l The configuration files.

l The scripts that help build and define the DataWarehouse.

Themapping between the raw data from the data source and the target database in the Data
Warehouse is included in the ETL. The Executive Scorecard runs the KPI engine that reads the
data from the target database, creates the relevant KPIs from that data, calculates the value, and
status of the KPI and displays the relevant information in the Dashboard.

Youmust run the Data SourceManagement wizard to configure and activate the content packs,
depending on the products you want to integrate with.

The out-of-the-box content packs are:

l CORE content pack. This is the central content pack that is automatically installed during the
post-installation process. It takes consolidated data to the target schema. It includes all the
dimensions, and entities of the DataWarehouse. It also provides the organization of definitions
and hierarchies. All the other integrations depend on the CORE content pack.

l ALM

l AM

l BSM
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l DP

l IC

l NA

l NNM

l OO

l PPM

l SA

l SE

l SM

l UCMDB

Context

A context is the result of a semantic layer of metadata that creates a business oriented view of the
data. The context contains a schema of the tables that make up the dimension andmeasurement
objects. The context is an interface between the data warehouse and the analytics that display the
data. It then corresponds to the business contexts used in HP IT Executive Scorecard.

Learn About Multiple Integration Content Pack Instances
Multiple Integration Content Packs (M-iCP) providemultiple instances of the same data source or
product type. This allows for data source configuration per instance, as opposed to a single
activation for the data source. Each instance has its own version and product type. TheM-iCP
source extraction is based on the FBI extractor technology, and consolidation is enabled between
instances.

You can add an instance using the Data SourceManagement page or using the Automation tool.
For back-end tool details, see "The Automation Tool" on page 265.

Learn About File Based Integration
File Based Integration (FBI) enables you to extract data from a specific data source according to a
set of instructions.It consists of a plug-able extractor framework for each data source. The extractor
gathers data according to the specific instructions it receives, placing it into a relevant txt file. Each
supported data source has a corresponding extractor (or multiple extractors) capable of extracting
data out of it according to specified instructions. All available Content Packs use FBI.

Extraction Mechanism

The extraction is based on a set of parameters kept in the dwabc.INSTRUCTION table in the
staging database. The instruction parameters are set by the BODS workflow during the Source
Extract.

Extraction Methodology

The extraction is done using Enterprise JavaBeans (EJBs) running on the application container of
the DataWarehouse. The EJBs use various technologies (for example, JDBC, Web Services,
Remote EJB objects, data files, and other kinds of http requests) to extract the data from the data
source.

ETL Source Extract
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The first stage of the ETL is the Source Extract. In this phase, the BODS workflow inserts an
instruction to the INSTRUCTION table and then invokes a batch file with the instruction ID as a
parameter. The batch file calls a JAVA program which performs an http request that activates the
relevant extractor. Using the instruction ID, the extractor fetches the relevant parameters from the
INSTRUCTION table.

External adapters running inside the BODS tomcat JVM, extract the data from the data source into
BODS data stores. In all Content Packs that integrate using FBI, data is extracted using a new
framework which runs on a separate JVM from the data source into txt files with well defined
standard structure. FBI runs the source extract in a JVM outside BODS. Additionally, when running
outside of BODS, it is not required to comply to BODS interfaces.

Content Packs that use FBI Extractors

l ALM

l AM

l BSM

l DP

l IC

l NA

l NNM

l PPM

l SA

l SE

l SM

l UCMDB

l APM (divided into uCMDB, BSM KPI dashboard, GDE)

Troubleshooting Logs

l <agora>\glassfish\glassfish\domains\BTOA\logs\fbi.log: This log describes all of the
current activity of the file based framework as well as the activity of the extractors themselves.

l <installation directory>\agora\DataWarehouse\log\dw_fbi_client.log: This log describes
the activity of calling the FBI url from a batch file (which is invoked by a BODS workflow during
the ETL source extract).

Tasks
This section includes:

"Add and activate a new data source instance:" on next page

"Reactivate an existing data source instance:" on next page

"Deactivate a data source instance:" on next page

"View data source configuration settings" on page 201
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"Edit data source settings and test the connection:" on next page

"Add a new data source to the integrationmechanism" on next page

"Configure admin tasks using the command line" on next page

"Use the FBI Verification Extractor" on next page

"Configure FBI Properties" on next page

Add and activate a new data source instance:
The process of integrating a data source into the DataWarehouse is done through activation of the
source instance.

1. Select Admin > Data Source Management.

2. Click theAdd data source to open the Data source wizard. The Add Data Source page
opens.

3. Select the data source type and click Next.

The relevant data source page opens.

4. Enter and select the configuration parameters.

5. Complete the wizard.

The data source instance is activated.

Note: If the first time activation of a data source instance fails, the instance is displayed in
the source list with anError status. You can then activate the data source by clickingEdit
Settings and completing the configuration and activation.

Reactivate an existing data source instance:
1. Select Admin > Data Source Management.

2. Click next to the specific source and the source is activated.

Note: Before reactivating the BSM data source, click Edit Settings and enter theRTSM
Username andRTSM Password.

Before reactivating the UCMDB data source, click Edit Settings and enter theUsername
andPassword.

Deactivate a data source instance:
You can deactivate the source and stop the integration process, in order to change configuration
details.

1. Select Admin > Data Source Management.

2. Click and the deactivation warning opens.

3. Click OK.
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View data source configuration settings
1. Select Admin > Data Source Management.

2. Click View Settings and the relevant data source page opens.

Edit data source settings and test the connection:
1. Select Admin > Data Source Management.

2. If necessary, deactivate the data source by clicking .

3. Click Edit Settings and edit the configuration parameters.

4. Click Next to validate your changes and test the connection to the data source.

Add a new data source to the integration mechanism
For details, see "Add Additional Data Sources" on page 240.

Configure admin tasks using the command line
For details, see "DataWarehouse CommandReference" on page 249

Use the FBI Verification Extractor
FBI also supplies an extractor within the FBI framework that can verify and validate the flat file
output you have.

To utilize the extractor:

1. Place the Flat File (FF) in a specific folder with a specific name in the RESULT_FILE_NAME
column in the Instruction table. The name and folder are defined by the ETL developer.

2. The delimiters in FF should be the same as the ones defined in the delimiters columns (FIELD_
DELIMITER and ROW_DELIMITER).The FF must contain the list of fields in the first line with
all the relevant delimiters.

3. Make sure the order and the name of the fields in the FF are the same as the ones defined in
the SourceModelMetadata.

To activate the extractor:

1. Define the productType attribute in the datasource.xml as file (productType="file").

2. You can also override the defined extractor by adding a new entry into the connection detail (in
the datasource.xml), as follows: <dw:GenericProperty propertyName="overrideextractor"
propertyValue="file" propertyType="string"/>

Configure FBI Properties
In data source activation, each source that is extracted with FBI must have the following properties
configured.

Navigate to: <installation directory>\DataWarehouse\conf\fbi.properties

If multiple extractors are running simultaneously, youmay need to configure the following:

fbi.max.number.of.threads =5
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If you experience problems with languages that do not work with UTF 16 you can change the
following:

fbi.flat.file.encoding =UTF-16

UI Description
Data Source Management Page
The Data SourceManagement page enables you to select from a list of Integration Content Packs
recognized by the data warehouse. Additionally, it enables you to activate the integration of the data
sources, as well as deactivate andmake configuration changes.

User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI
Element

Description

Add data
source

Click to open the Data Source wizard. For details, see "Data SourceWizard" on
next page.

<Data
Sources>

A list of sources, by Name (instance name) andProduct (data source product), that
have been added to the data warehouse. The current status of the data source is
displayed next to the instance name:

l Activated

l Deactivated

l Error

l Initializing: Data source is currently being activated. Relevant only for first time
activation.
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UI
Element

Description

View
Settings

Available when the data source has been activated. Displays the read-only
configuration of all connection parameters.

Note:All connection settings are run-time related. Youmust deactivate the
connection to the data source in order to change the settings.

Edit
Settings

Available when the data source has been deactivated. Displays the configuration of
all connection parameters and enables you to test the connection to the data source.
The parameters can be edited.

If the first time activation of a data source instance fails, the instance is displayed in
the source list with anError status. You can then activate the data source by
clickingEdit Settings and completing the configuration and activation.

Activates the relevant data source.

l Once the content pack is activated, the ETL is ready to run. For details on how to
monitor andmanage the ETL, see "Perform Tasks for ETLManagement " on
page 175.

l Do not activate a content pack while the ETL is running.

Deactivates the relevant data source.

Do not deactivate a content pack while ETL is running.

Data Source Wizard
The Data Source wizard enables you to add and activate a selected data source instance.

To access Select Admin > Data Source Management and then click Add data source.

Select the data source type to activate the integration processes.
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Important
Information

The UI elements of the wizard differ according to the selected data source, as
follows.

l ALM

l AM

l BSM

l DP

l IC

l NA

l NNM

l OO

l PPM

l SA

l SM

l UCMDB

l Additional Sources:Additional data sources can be added . For details see
"Add Additional Data Sources" on page 240.

For configuration parameter details, see "Integrate the Data Sources" on page 1 in
theContent ReferenceGuide.

For each source, enter the relevant information and click Next to proceed to the
validation page.

Note: If the activation process is takingmore than one hour, you can change the
status of the CP in the CONTENT_PACK table to “ERROR” and then activate the
CP again.

Wizard
Map

The Data Source wizard contains:

Add Data Source Page > Configuration Parameters Page > Validation Page
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Add Data Source Page

Click Next to move to the next page of the wizard..

User interface elements are described below (when relevant, unlabeled elements are shown in
angle brackets):

UI Element Description

Data source type Select the data source type you want to activate.

Validation Page
This validation page displays activation status information pertaining to the selected data source.
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A message displays the data source status information.

Click Finish to complete the wizard activation process.
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Perform the Back-End Maintenance of the
Data Warehouse

You canmonitor and the ETL and other functions of the DataWarehouseusing the back-end tools.
This section includes the following topics:

"Clean Up the Staging and Target Databases" below

"ABC Operational Reports " below

" DataModel Reports" on page 223

"Additional Maintenance" on page 234

"DataWarehouse Naming Conventions" on page 242

"DataWarehouse CommandReference" on page 249

"Advanced DataWarehouse Administration" on page 267

Clean Up the Staging and Target Databases
You clean up the databases when you want to run the initial load anew.

The tables that are cleaned are: 

l All the data in the dwt tables in the target database.

l All the data in the dws, dwst, and xrefgen schemas in the staging database.

Note:

l The clean up tool cleans all data.

l The clean up tool cannot be activated during an ETL run.

l There is no possibility of rollback after the clean up.

To clean up the staging and target databases:

1. Backup the staging and target databases (so they are synchronized at the time of the backup)
using the tools of the relevant database servers.

2. Clean up the databases using the dw_clean_data tool. For details, see "DWH Command
Reference" on page 257

ABC Operational Reports
ABC operational reports report different aspects of ABC governance of ETL job streams. The
objectives of these reports are to display:
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l ETL stream definitions, such as catalogs, stream, and stream step information.

l Operational information about ETL batch jobs and processes.

Operational reports include:

"Audit Reports" below

"Control Reports" on page 213

Audit Reports
ABC Audit reports display ETL audit measure andmetric information. You can define the length of
time included in the audit history by specifying the number of days in theBatch run history field.
The typical user is the data warehouse administrator or an HP Support engineer. Run the reports
after multiple ETL runs produce historical results.

The following Audit reports are available:

"ABC Reports - Consolidation Tables Activity " on next page

"ABC Reports - Source Extraction Tables Activity " on page 210

"ABC Reports - Dimension Tables Activity " on page 212
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ABC Reports - Consolidation Tables Activity

The Job Streams Consolidations Activity report displays volume information ETL consolidation.

Tasks

Display the volume information ETL consolidation
1. In the SAP BusinessObjects InfoView, select Public Folders > DW EN Administration >

Audit Reports > ABC - Consolidation Tables Activity.

2. In the Prompts dialog box, select or enter the number of days of history to appear in the report
in theBatch run history field. The default value is 1 day.

3. Click Run Query.

Note: You can navigate between the tabs and select a view of the data by entity if you
click the drop-down list box at the top of the report and select All values, or a single entity.

TheMeasure / Batch per Measure Name tab displays a bar chart view of the number of input
rows and output rows for each affected consolidation table by batch ID and start time over the
specified duration.

TheMeasure / Measure Name per Entity tabmeasures job stream activity for the amount of
days selected.
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ABC Reports - Source Extraction Tables Activity

This report shows the ETL activity on the source data tables.

Tasks

Display the source data tables
1. In the SAP BusinessObjects InfoView, select Public Folders > DW EN Administration >

Audit Reports > ABC - Source Extraction Tables Activity.

2. In the Prompts dialog box, select or enter the number of days of history to appear in the report
in theBatch run history field. The default value is 2 days.

3. Click Run Query.

Note: You can navigate between the tabs and select a view of the data by the number of
sources. Click the drop-down list box at the top of the report and select All values, or a
specific number of sources.

TheMeasure / Batch per Measure Name tab displays a bar chart view of themeasures
processed from source tables over the specified duration.

TheMeasure / Batch per Source Table tab displays a bar chart view of the number of data
rows in source tables processed over the specified duration.

TheMeasure / Measure Name per Source Product tab displays a bar chart view of the
extraction activity by source over the specified duration.
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TheMeasure / Measure Name per Source Table tab da bar chart view of the extraction
activity by source over the specified duration.
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ABC Reports - Dimension Tables Activity

This report measures the volume of data processed by the data warehouse.

Tasks

Display the volume of data processed by the Data Warehouse
1. In the SAP BusinessObjects InfoView, select Public Folders > DW EN Administration >

Audit Reports > ABC - Dimension Tables Activity.

2. In the Prompts dialog box, select or enter the number of days of history to appear in the report
in theBatch run history field. The default value is 1 day.

3. Click Run Query.

Note: You can navigate between the tabs and select a view of the data by the number of
sources or the entity. Click the drop-down list box at the top of the report and select All
values, or a specific entity.

TheMeasure / Batch per Measure Name tab displays a bar chart view of the number of rows
processed for each dimension table by batch ID and start time over the specified duration.

TheMeasure / Measure Name per Entity tab displays a bar chart view of the number of rows
processed by entity over the specified duration.
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Control Reports
Control reports describe historic or operational aspects of the data warehouse. Historic reports
contain status information gathered over time for analysis and performance improvements.
Operational reports contain snapshot information about current jobs and other data warehouse
activity. You can edit, save, or export the following ABC Control reports.

Note: If the ABC database runs on a different system than SAP Business Objects Data
Services, and these two systems run in different timezones, youmay see a discrepancy in the
Duration column on the Control reports. For example, if you check a Control report while a step
is processing, the report might show that the step has been processing for several hours even
though the step has actually been running for only minutes. Once the step terminates,
however, the duration becomes accurate.

The following Control reports are available:

"ABC - Operational Status Report" on next page

"ABC - Operational Status History Report" on page 216

"ABC - Operational Duration History Report" on page 218

"ABC -Model Definitions Report" on page 220

"ABC - Job Details Report" on page 221

"ABC - Batch Details Report" on page 222
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ABC - Operational Status Report

The ABC Operational Status report displays the runtime information about the out-of-box
Upstream.xml file, which contains all the job stream steps for a complete ETL run.

Tasks

Display the volume of data processed by the Data Warehouse
1. In the DWH Status page, click theSelect page arrow and select DWH Status Page > ABC-

Op. Status.

The ABC Operational Status report is one of the three reports displayed in the DWH main
page. It includes two tabs (Job Stream Status and Job Stream Progress).

2. Click the relevant tab.

UI Description

Job Stream Status Tab
Displays the performance of ABC job streams and process, as follows:

UI Element Description

Last Batch Status The status details of the last batch run.

Batch ID . Click theBatch ID value in the first column. A dialog box opens, enabling
you to access the ABC Batch Control report.

For details, see"ABC - Batch Details Report" on page 222.

Jobs With
Problems for ETL
Batch ID

The job details for each specific batch listed in theBatch ID column.
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Job Stream Progress Tab
Displays the runtime status of each job stream step , as follows:

UI Element Description

<Job Name>
(<Process
Durations>)

The job name and the length of the job in seconds.

Click any ETL job name to display the ETL Job Process Audit report, which
shows all audit measures andmetrics associated with that Process ID. 

For details, see "ABC - Job Details Report" on page 221.
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ABC - Operational Status History Report

This report displays a batch run history for ABC ETL job streams during a specified period. The
report shows run-time duration, status, and error frequency.

Tasks

Display the batch run history for ABC ETL job streams during a specified
period
1. In the DWH Status page, click theSelect page arrow and select DWH Status Page > ABC-

Op. Status History.

2. In the Prompts dialog box, enter the number of days for the batch history.

3. Click Run Query.

The ABC -Operational Status History report is one of three reports displayed in the DWH main
page.

4. Click the relevant tab (Job Stream Status History tab or Job and Work flows Errors
Frequency tab).

UI Description

Job Stream Status History tab
Displays the status history of ABC job streams and process.

Status Values:

l Success (Green): The number of jobs with no error condition or inconsistency detected.

l Warning (Orange): The number of jobs where aminor error condition exists, although there are
no data inconsistencies or corruption detected, and, there is no loss of data.

l Error (Red): The number of jobs with a critical error status.

l Max Time Exceeded (Pink):Number of jobs that exceedmax execution time.

l Remaining:Number of jobs that are waiting to be started.
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Job and Work flows Errors Frequency tab
Displays the job and workflow errors frequency, (in descending order). The reports lists only jobs
and workflows that produce error conditions.
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ABC - Operational Duration History Report

This report describes the duration history of job stream batches during a specified period.

Tasks

Display the duration history of job stream batches during a specified
period
1. In the SAP BusinessObjects InfoView, select Public Folders > DW EN Operations >

Control Reports > ABC - Operational Duration History.

2. In the Prompts dialog box, enter the relevant X and Y values in the following fields:

n Batch run history for last X days (Enter X):

n Batch Statistics for last Y days (Enter Y):

3. Click Run Query.

4. Click the relevant tab (Job Streams Duration tab or Job Details Duration tab).

The Job Streams Duration tab displays historical job stream information. The aborted job
streams are red.

The Job Details Duration tab displays the amount of time consumed by individual jobs within
the job stream.
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ABC - Model Definitions Report

The ABC Model Definitions report displays the executable catalogs to be processed by ABC.

Tasks

Display the executable catalogs to be processed by ABC
1. In the SAP BusinessObjects InfoView, select Public Folders > DW EN Operations >

Control Reports > ABC - Model Definitions..

2. Click the relevant tab (Executable Catalogs tab orStream Definitions tab).

TheExecutable Catalogs tab displays the executable catalogs that have been loaded into
ABC.

TheStream Definitions tab displays the Job Streams and the associated steps that have
been loaded into ABC.
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ABC - Job Details Report

The ABC Job Details report displays operation information, such as the Stream Step ID and
workflow information.

Tasks

Display the executable catalogs to be processed by ABC
1. In the SAP BusinessObjects InfoView, select Public Folders > DW EN Operations >

Control Reports > ABC - Job Details.

2. In the Prompts dialog box, select one or moreProcess Ids from the left list box or enter a

Process Id value and click Search. Click theRight arrow to move it into theEnter the
Process ID list.

3. Click the relevant tab (Control Details tab orAudit Details tab).

TheControl Details tab displays operational information related to job process IDs.

TheStream Definitions tab displays audit information related to specific jobs. For details, see
"ABC - Batch Details Report" on next page.
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ABC - Batch Details Report

This report displays control information for a batch job. It reports the defined Upstream and
allocationmetric (for FPA) job streams.

Tasks

Display the control information for a batch job
1. In the DWH Status page, click theSelect page arrow and select DWH Status Page>ABC-

Batch Details.

2. In the Prompts dialog box, select one or moreBatch Ids from the left list box or enter anBatch

Id value and click Search. Click theRight arrow to move it into theSelect Batch Id list.

3. Click Run Query.

The ABC - Batch Details Report is one of three reports displayed in the DWH main page.

4. TheABC Batch Control tab displays the various batch jobs.

5. Click the relevant value in theProcess ID column and the ABC Job Process Audit opens to
display all audit measures andmetrics associated with that Process ID.

For details, see "ABC - Job Details Report" on previous page.
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Data Model Reports
DWH DataModel reports provide:

l An overview of the current status of the DWH configuration.

l Detailedmodel definition descriptions.

l Generated schema descriptions.

The typical user of the DataModel reports is the DWH administrator, developer, or anyone
interested in gathering information about the current state of the data warehouse.

The following DataModel reports are available:

"View the Fact and Dimension DataModel" below

"ExtractionModel Details " on page 225

"ConsolidationModel Details " on page 226

"DimensionModel Details " on page 227

"Fact Model Report " on page 228

"SourceModel Details " on page 229

"AggregationModel Details " on page 230

"Platform Physical Schemas " on page 231

View the Fact and Dimension Data Model
This query produces a complete view of extraction path for every fact and dimension entity. Run
this report after you deploy a new application. It is the entry point for all datamodel reports. The
links in the report enable you to link to reports that providemore detail.

Tasks

Display the dimension data model for the specific entities
1. In the SAP BusinessObjects InfoView, select Public Folders > DW EN Administration >

Data Model Reports > Data Model Overview.

2. Select theData Model Overview - Dimensions tab.

TheData Model Overview - Dimensions tab displays the dimension datamodel for the
specific entities when extracted frommultiple sources and consolidated into a target
dimension.
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Display the data model for overview for each loaded FACT entity
1. In the SAP BusinessObjects InfoView, select Public Folders > DW EN Administration >

Data Model Reports > Data Model Overview.

2. Select theData Model Overview - Facts tab.

TheData Model Overview - Facts tab displays the datamodel overview for each loaded
FACT entity from the SourceModel to the AggregationModel.
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Extraction Model Details
The report shows the details for a selected extractionmodel.

Tasks

Display the details for a selected extraction model
1. In the SAP BusinessObjects InfoView, select Public Folders > DW EN Administration >

Data Model Reports > Extraction Model Details.

2. In the Prompts dialog box, select one or moreExtraction Ids from the left list box or enter an

Extraction Id value and click Search. Click theRight arrow to move it into theSelect
Extraction Model list.

3. Click Run Query.

The ExtractionModel tab displays details about the aggregatedmeasures.
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Consolidation Model Details
This report provides details on consolidationmodels.

ConsolidationModel Details shows the final attributes for the selected entity, including the data
type, length, and whether null values are permitted.

Tasks

Display the consolidation model details:
1. In the SAP BusinessObjects InfoView, select Public Folders > DW EN Administration >

Data Model Reports > Consolidation Model Details.

2. In the Prompts dialog box, select one or moreConsolidation Ids from the left list box or enter

aConsolidation Id value and click Search.Click theRight arrow to move it into the
Select Consolidation Model list. For example, select PERSON.

3. Click Run Query.

The ConsolidationModel tab displays all its target references, attributes details, and
consolidation relationship attributes.
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Dimension Model Details
When you select a dimension, the DimensionModel Details report displays the dimension
attributes, hierarchies, and associated dimensions.

Tasks

Display the dimension model details:
1. In the SAP BusinessObjects InfoView, select Public Folders > DW EN Administration >

Data Model Reports > Dimension Model Details.

2. In the Prompts dialog box, select one or moreDimension Ids from the left list box or enter an

Dimension Id value and click Search. Click theRight arrow to move it into theSelect
Dimension Model list. For example, select PERSON.

3. Click Run Query.

The DataModel Overview - Dimensions tab provides details on dimensionmodels. Displays
all its attributes, associated hierarchies, and all of the dimensions it is linked with.
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Fact Model Report
The report shows the details for a selected fact model.

Tasks

Display the fact model details:
1. In the SAP BusinessObjects InfoView, select Public Folders > DW EN Administration >

Data Model Reports > Fact Model Details.

2. In the Prompts dialog box, select one or more Fact Ids from the left list box or enter an Fact Id

value and click Search.Click theRight arrow to move it into theSelect Fact Model list.
For example, select SERVICESTATUS.

3. Click Run Query.

The Fact Model tab displays fact measures and the dimensions they are linked to.
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Source Model Details
This report provides details on Data Sourcemodels as well as Data Sourcemapping details.

Tasks

Display the source model details:
1. In the SAP BusinessObjects InfoView, select Public Folders > DW EN Administration >

Data Model Reports > Source Model Details.

2. In the Prompts dialog box, select one or moreSource Model Ids from the left list box or enter

anSource Model Id value and click Search.Click theRight arrow to move it into the
Select Source Model list.

3. Click Run Query.

The SourceModel tab displays the data sourcemodel details.
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Aggregation Model Details
This report shows aggregationmodel details in a summary format that is organized by aggregate
details.

Tasks

Display the aggregation model details
1. In the SAP BusinessObjects InfoView, select Public Folders > DW EN Administration >

Data Model Reports > Aggregation Model Details.

2. In the Prompts dialog box, select one or moreAggregate Ids from the left list box or enter an

Aggregate Id value and click Search. Click theRight arrow to move it into theSelect
Aggregation Model list.

3. Click Run Query.

The Aggregation Details tab displays details about the aggregatedmeasures.
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Platform Physical Schemas
This report enables you to diagnose whether the ETL staging or target models are aligned with the
metadata.

To access:
In the SAP BusinessObjects InfoView, select Public Folders > DW EN Administration > Data
Model Reports > Platform Physical Schemas.

The Platform Physical Schemas report has five information tabs:

l Data Integration Interface (DII). Shows connection information for the data sources and status
of the generated views.

l Staging Source - Extract Identity. For each data source, shows the status of the extraction
process, including the number of extraction tables created and defined.

l Staging Source - Consolidation. Shows the status of the consolidation tables by application.

l Staging Target. Shows the status of the data warehouse target staging tables organized by
application.

l DW Target. Shows the status of the target data warehouse tables and views.

Learn More

This report may take some time to load.

In the tabs, red and green color cues help you locate problems and issues quickly. Run this report
after you deploy a new application. An HP Support engineer can diagnose the platform state after a
model customization.

UI Description

DII tab
This report displays:

l Global status of the SQL script generation process for DII database views.

l Detailed information about any error condition that might have been detected during the
generation process.
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Note: This tab is not relevant for non database data sources, for example, BSM and uCMDB.

Staging Extract Identity- tab
Displays the number of extraction tables created and defined for each data source and whether
table errors occurred during the ETL process.

Staging - Consolidation tab
This report displays:

l Global status on physical tables of the staging source for the consolidation part.

l Themissing tables among these.

l The number of extraction tables created and defined for each data source and whether table
errors occurred during the ETL process.

Staging - Target tab
This report displays

l Status of the ETL staging tables.

l Themissing tables among these.

l The detailed status for the tables with issues at column level.
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DW Target tab
This report displays:

l Global status on physical tables of the target data warehouse.

l Themissing tables among these.

l The detailed status of the tables with issues at column level.
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Additional Maintenance
This section includes the following topics:

"Time Zone Configuration" below

"Tracing and Logging" on page 236

"Add Additional Data Sources" on page 240

"Change the Configuration Definition" on page 240

"DataWarehouse Server Failure"

"Back UpDataWarehouse " on page 276

"DataWarehouse Recovery"

Time Zone Configuration
The data warehouse contains data extracted from external sources. The original data sources can
be repositories in disparate locations. It is important that the data warehousemaintain accurate
date and time stamps that normalize the differences between the source time zones and the current
time of the data warehouse location. These differences include both Coordinated Universal Time
(UTC) offset and daylight savings time (DST) variations.

The data warehouse foundation has transparent internal functions that convert a source time zone
value to a UTC value, and convert the UTC value to the data warehouse local time zone during the
ETL process.

To access:
At aWindows command prompt, switch to the <Installation directory>\Agora\Data
Warehouse\bin directory.

Learn More

Data Warehouse DST Time Zone Information
The administrator must make sure that time zone information is current on the server hosting the
DataWarehouse. Although the definition of time zones and DST rules are fairly static, changes can
occur, for example, whenmoving the DST conversion date on a country-wide basis.

You can synchronize these changes to the Olson Timezone Database by obtaining and running the
Java TZUpdater Tool that is available on the Sun Developer Network (SDN). For more information,
visit the Java SE Timezone Updater Tool home page.

Change the Data Warehouse Period Dimensions
This procedure should be followed when expanding the DataWarehouse First and Last Year period
dimension range.
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It is highly recommended that once you enter First and Last Year period dimensions in the
Executive Scorecard Configuration wizard, any future changes should take the following into
account:

1. The First Year period dimension should only be changed downwards, thereby including the
current First Year period dimension. For example if the First Year dimension is currently set to
2005, any change should be a year lower than 2005. Entering a year higher than 2005 can
cause some data inconsistencies.

2. The Last Year period dimension should only be changed upwards, thereby including the current
Last Year period dimension. For example if the First year dimension is currently set to 2025,
any change should be a year higher than 2025. Entering a year lower than 2025 can cause
some data inconsistencies.

Time Zone Update
The dw_tz_update_dst utility updates the DataWarehouse DST time zone information.

Tasks

"To update the DataWarehouse DST time zone" below

"To change DataWarehouse period dimensions" below

"To run the dw_tz_update_dst utility" on next page

To update the Data Warehouse DST time zone
1. Download and run the TZUpdater tool.

2. To update DataWarehouse Server tables, run the dw_tz_update_dst as described in "Time
Zone Configuration" on previous page.

To change data source Time Zone settings:

1. In the Executive Scorecard application, click Admin > Data Source Management, and for the
relevant Content Pack, click Activate to open the relevant activation page.

Note: If the content pack is already activated, youmust deactivate, and then reactivate
the content pack .

2. Change the Time Zone for the relevant data source, and click Next.

The TimeZoneInfo table which is part of the Staging database is automatically updated.

Note: There is a discrepancy in the status time display between ETL runs when BSM has
a different time zone than the BSM server.

To change Data Warehouse period dimensions
1. In the Executive Scorecard application, click Admin > Data Warehouse, underGeneral,

make the required changes in the First year handled by DWH dates and Last Year handled
by DWH dates settings, and click Save.

2. From a command prompt, navigate to
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<Installation Directory\Agora\DataWarehouse\Bin

Run dw_period_dim_generator.

To run the dw_tz_update_dst utility
1. At aWindows command prompt, switch to the <Installation directory>\Agora\Data

Warehouse\bin directory.

2. Run this command:
dw_tz_update_dst

a. Load or update the time zone information for a data source and the data warehouse.

b. Run this utility whenever you deploy new source data or when youmanually change the
time zone.

c. Time zone is expressed in GMT format: GMT +\-nn:nn.

Syntax
dw_tz_update_dst.bat

[-help]

[-verbose]

Options

Option Required? Description

-help N Display command syntax.

-verbose N Producemore detailed output.

Return codes:
0 – Success

1 – Success with warnings

>1 – Errors

Example
dw_tz_update_dst -verbose

a. Load or update the time zone information for a data source and the data warehouse.

b. Run this utility whenever you deploy new source data or when youmanually change the
time zone.

c. Time zone is expressed in GMT format: GMT +\-nn:nn.

Tracing and Logging
This section describes the DataWarehouse logging and tracingmechanism. Data warehouse
scripts have different types of output log files:

One log file for each data warehouse batch utility, using the Java application Log4J.

One log file for each SQL command.
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Learn More

The Java Logging Mechanism
The data warehouse generates one log file for each batch utility, and stores it in the following
directories:
<installation directory>\agora\DataWarehouse\logs and
<installation directory>\agora\glassfish\glassfish\domains\BTOA\logs

For example:

l dw_initdb.log

l dw_generateschemas.log

The loggingmechanism allows each new block of log information to be appended to the existing log
until it reaches themaximum size of 1MB. At that point, new logging information is stored in a
backup file. There can be amaximum of five log files for a single script. You can change the log file
name, size, andmaximum number of backup files.

SQLCommand LoggingMechanism

All the SQL commands that are executed at the direction of the data warehouse software are
redirected to simple log file. You can view the log file to trace the execution of all SQL commands.
All log files are in the following directory:
<installation directory>\agora\Datawarehouse\conf

l mssql_TablesAndSeqsResult.log

l mssql_create_dw_schema_LastRun.log

The prefix of the log file name is the RDBMS type: mssql. The suffix of the log file name is _
LastRun. This suffix indicates that the file contains the last run output of the SQL command.

To simplify interpreting SQL errors, the data warehouse applications parse the SQL server log files
to report themost critical SQL error to the user. For more information, you can review the entire log
file. Because the data warehouse appends log information in a history format in certain log files, you
can review prior errors. Other log files retain only the history of themost recent execution. These
files always have the _LastRun suffix. For example:

l mssql_check_db_options_LastRun.log

l mssql_create_dw_schema_date_time_dim_LastRun.log

These history log files contain the date and time the SQL command runs, the date and time it
completes, and the returned status of the SQL command. For example:

----------------------------------------------------------------------

Start of command: sqlcmd -S localhost -d BTODW -U dwmetadata -P **** -

i

"C:\...\\foundation\etc\sql\mssql\create_dw_staging_resources.sql" -o

"C:\...\\foundation\log\mssql_create_dw_staging_resources_LastRun.log"

At: Wed Jul 02 13:35:59 PDT 2009

----------------------------------------------------------------------

1:
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2: ********** Creating staging resources **********

----------------------------------------------------------------------

End of command: sqlcmd -S localhost -d BTODW -U dwmetadata -P **** -i

"C:\...\\foundation\etc\sql\mssql\create_dw_staging_resources.sql" -o

"C:\...\\foundation\log\mssql_create_dw_staging_resources_LastRun.log"

At: Wed Jul 02 13:35:59 PDT 2009

Returned code is: 0

SAP BusinessObjects Enterprise Logs
SAP BusinessObjects Data Services produces many run-time logs. You can locate these logs in
the relevant directory
structure:
C:\<installation directory>\BO\bods\BusinessObjects Data Services\log

The \log folder has sub-directories to further organize the SAP BusinessObjects Data Services
logs.

Data Warehouse Log Files
You can access the DataWarehouse Log files in:

l datawarehouse\logs

l C:\<Installationdirectory>\agora\glassfish\glassfish\domains\btoa\logs\server.log

All information in the DataWarehouse log files is automatically sent to theWindows Event Viewer
Application log.

Tasks

"To configure the Logs" below

"To access DataWarehouse log information" on next page

To configure the Logs
For data warehouse utilities, you can customize logging behavior by editing a related log
configuration file with this naming convention: xxx-log4j.xml. For example, importdefs-log4j.xml.
The log configuration files are in this directory:
<installation directory>\agora\DataWarehouse\conf

Open the related xxx-log4j.xml file with a text editor to choose the trace levels and to change other
parameter values. If youmake changes, save the file before you close it.

For ABC utilities, (abc-xxxx) there is a single log configuration file: abc-log4j.xml. The values that
you specify in this file apply to all log files generated by any ABC utility.

Trace Levels

You can choose one of the following trace levels to control the amount of information stored in the
logs:

l trace

l debug

l info
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l warn

l error

l fatal

The default value is info. You can experiment with different levels to see how much information that
you want to display or suppress.

To access Data Warehouse log information
1. On theWindows taskbar, click Start > Administrative Tools > Event Viewer.

2. ExpandWindows Logs, right-click Application, and then click Filter Current Log.

3. Select the relevant Event Levels, select the relevant Event Sources, and then click OK.

Note:  All the DataWarehouse Event Sources begin with DWH.

Sample Log Information

The following examples show the type of information you can find in these log files. The first
example shows that a fatal error has occurred.

2008-07-02 13:33:10,652 INFO [com.hp.bto.dw.sqlbatch.SqlBatch] -

Checking database options...

2008-07-02 13:33:10,949 FATAL

[com.hp.bto.dw.dbcreate.DbCreateCommandLine] - Problem during DB

options check:

An error that can be corrected by the user has been found. Check the

log file to correct the problem.

Check the error log file

'C:\...\\foundation\log\mssql_check_db_options_LastRun.log', line

number 2

008-07-02 13:33:10,949 FATAL

[com.hp.bto.dw.dbcreate.DbCreateCommandLine] - Exit code: 6

The second example shows successful execution.

2008-07-02 13:36:27,136 INFO

[com.hp.bto.dw.dbmetadatatool.DbMetadatatool]

Creating Date and Time stored procedures and populating the dimension

tables...

2008-07-02 13:36:30,511 INFO

[com.hp.bto.dw.commons.dblogparser.LogParserStatus] - Command

successfully executed.

It is possible to change the format of the reported information by changing the corresponding
configuration files.
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Add Additional Data Sources
You can add additional Content Packs to the data warehouse that can then be activated or
deactivated.

To add additional data sources:

1. Copy the Content Pack file into the CP directory: <Installation Directory>\agora\Content
Packs.

2. Run the following batch file: dw_cp_register.bat -name <new CP>. The name enteredmust
match the Content Pack file name.

3. Activate the data source using the Data SourceManagement page. For details, see "Perform
Tasks for Data SourceManagement" on page 197.

Change the Configuration Definition
You can change data source configuration information only after you deactivate and then re-activate
the specific data source.

Change the data source configuration:

1. Select Admin > Data Source Management.

2. If necessary, deactivate the data source by clicking .

3. Click Edit Settings and edit the configuration parameters.

4. Click Next to validate your changes.

5. Click next to the specific source and the source is activated.

For details, see "Perform Tasks for Data SourceManagement" on page 197.

Change the Data Warehouse Period Dimensions 
This procedure should be followed when expanding the DataWarehouse First and Last Year period
dimension range.

It is highly recommended that once you enter First and Last Year period dimensions in the
Executive Scorecard Configuration wizard, any future changes should take the following into
account:

1. The First Year period dimension should only be changed downwards, thereby including the
current First Year period dimension. For example if the First Year dimension is currently set to
2005, any change should be a year lower than 2005. Entering a year higher than 2005 can
cause some data inconsistencies.

2. The Last Year period dimension should only be changed upwards, thereby including the current
Last Year period dimension. For example if the First year dimension is currently set to 2025,
any change should be a year higher than 2025. Entering a year lower than 2025 can cause
some data inconsistencies.
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To change Data Warehouse period dimensions:

1. In the Executive Scorecard application, click Admin > Data Warehouse, underGeneral,
make the required changes in the First year handled by DWH dates and Last Year handled
by DWH dates settings, and click Save.

2. From a command prompt, navigate to
<Installation Directory>\agora\DataWarehouse\Bin

Run dw_period_dim_generator.
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Data Warehouse Naming Conventions
The following describes table and field naming conventions.

Type _Value Description

Table
Name
Suffixes

_DIM Dimension or bridge table.

_FACT Fact table.

_MS Monthly snapshot table that shows the last known value for the data
at the end of amonth.

_HIER Hierarchy table.

_ AGG Aggregate roll up table.

Field
Name
Prefixes

MD_ Metadata.

SRC_ Used for all fields that exist just for data warehouse internal
processes. Source. Used for all field drawn from the source for ETL
purposes only (not pushed to the target).

PK_ Primary key.

FLAG_ A binary field: Y/N.

DATE_ A date type.

DURATION_ A measure representing a length of time.

COUNT_ A measure representing a raw count.

AVG_ A measure representing an average roll up.

MAX_ A measure representing amaximum roll up.

MIN_ A measure representing aminimum roll up.

PCT_ A measure representing a percentage.

Field
Name
Suffixes

_ID A surrogate key field that is primary or foreign.

_BASE A financial amount, currency, or exchange rate in the default currency
of the data warehouse.

_ UTC A date expressed in the UTC time zone. For dates: a date expressed
in the default display time zone for the data warehouse. For money: a
financial amount, currency, or exchange rate in the original currency of
the source data.

_LOC A date expressed in the local time zone.
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Target and Staging Databases Naming Conventions
The first character of the Target and Staging databases namemust begin with an alpha character.
The init_db utility fails if you use database names that begin with numbers.

SAP BusinessObjects Data Services Naming
Conventions

This section describes the naming conventions used by tables that are part of the SAP
BusinessObjects Data Services ETL process.

This section includes the following topics:

l "Datastore " below

l "Datastore Alias " on next page

l "Project" on next page

l "Job Names" on next page

l "Workflows" on page 245

l "Dataflows" on page 245

l "Variables - Global - Local Variables - Parameters" on page 245

l "Custom Functions" on page 246

l "DataWarehouse Naming Conventions" on previous page

l "Try/Catch" on page 247

l "Conditionals" on page 247

l "Flat File Targets" on page 247

Datastore

Description Naming Convention and Examples

Connection to database with source
application views

Datastore names have a prefix with the datastore name
and a suffix of _DS.

Format:

<SOURCE APP>_DS

Examples:

l AMVIEW_DS

l PPMVIEW_DS

l SMVIEW_DS
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Connection to transactional entity
staging database

SRCSTAGING_DS

Connection to target entity staging
database

DWSTAGING_DS

Connection to data warehouse
database

DW_DS

Datastore Alias

Description Naming Convention and Examples

Name of Datastore for the specific source in
SAP BusinessObjects Data Services

Alias names have a prefix with the source
application name and a suffix of  _ALIAS.

Format:

<SOURCE APP>_ALIAS

Examples:

AMVIEW_ALIAS

Alias user for transactional entity staging
database

SRCSTAGING_ALIAS

Alias user for target entity staging database DWSTAGING_ALIAS

Alias user for data warehouse database DW_ALIAS

Project

Description Naming Convention and Examples

Allows you to group jobs that have
dependent schedule or belong to the same
application

Project names have a prefix with the source
application name or purpose of the project and a
suffix of  _PJ.

Format:

<DESCRIPTION>_PJ

Examples:

FPA_PJ

Job Names

Description Naming Convention and Examples
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SAP BusinessObjects Data Services job
which is a group of objects that you can
schedule and execute together

Job names have a prefix with the name of the source
application. An internal segment can describe the
job purpose. There is a suffix of _JB.

Format:

<SOURCE APP>_<PURPOSE>_JB or
<PURPOSE>_JB

Examples:

l AM_SOURCE_EXTRACT_JB

l DW_JB

Workflows

Description Naming Convention and Examples

Defines a decisionmaking
process to execute a
dataflow

Workflow names have a prefix with the source or target name. A
SUB-CATEGORY segment describes the ETL phase. There is
suffix of _WF.

Format:

<SRC NAME/TARGET NAME>_<SUB-CATEGORY>_WF

Examples:

l AM_AMRIGHTSUSESCOUNT_EXT_WF

l AM_MSI_CONTAINER_WF

Dataflows

Description Naming Convention and Examples

Data flows extract,
transform and load
data

Dataflow names have a prefix with the source or target name. A SUB-
CATEGORY segment describes the ETL phase. There is a suffix of _
DF.

Format:

<SRC NAME/TARGET NAME><SUB_CATEGORY>_<ACTION>_DF

Examples:

AM_AMRIGHTSUSESCOUNT_EXT_DF

AM_SWAUDITDETAIL_MSI_DF

Variables - Global - Local Variables - Parameters

Description Naming Convention and Examples
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Variables defined in a job
Variables defined in a job/
workflow Parameters in a
workflow/ dataflow

Variable names have a dollar sign ($) and prefix to identify the
type of variable (G for global, L for local, or P for parameter).
The suffix identifies the purpose or identifying parameter
name.

Format:

$G_<PURPOSE> or $L_<PURPOSE> or $P_<PURPOSE>

Examples:

l $G_BATCH_ID

l $L_STARTDATE

l $P_STATUS

Custom Functions

Description Naming Convention and Examples

Script functions in Data Integrator
scripting language

Custom function names have a prefix that describes the
purpose of the function.

The suffix is _FN.

Format:

<PURPOSE>_FN

Example:

STARTJB_FN

Scripts

Description Naming Convention and
Examples

Scripts created in jobs or work flows. Description can refer to
function the script is performing or the name of the table the
script is loading

Script names have a prefix that
describes the data source or
target name.
A SUB-CATEGORY segment
describes the ETL phase. The
suffix is _SC.

Format:

<SRC NAME/TARGET NAME>
or <SUB_CATEGORY>_SC.

Example:

: AM_
AMRIGHTSUSESCOUNT_
EXT_FAIL_SC
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Try/Catch

Description Naming Convention and Examples

Specify alternative workflows if errors
occur while executing a job

Try/catch names have a prefix that describes the data
source or target name.
A SUB-CATEGORY segment describes the ETL
phase. The suffix is _TRY or _CATCH.

Format:

<SRC NAME/TARGET NAME><SUB_
CATEGORY>_TRY
or <SRC NAME/TARGET NAME><SUB_
CATEGORY>_CATCH

Examples:

l AM_AMRIGHTSUSESCOUNT_EXT_TRY

l AM_AMRIGHTSUSESCOUNT_EXT_CATCH

Conditionals

Description Naming Convention and Examples

Conditionals are single-use objects used to
implement if-then-else logic in a work flow

Conditional names have a prefix that
describes the data source or target name.

A SUB-CATEGORY segment describes the
ETL phase. The suffix is _COND.

Format:

<SRC NAME/TARGET NAME><SUB_
CATEGORY>_COND

Example:

AM_AMRIGHTSUSESCOUNT_EXT_
COND

Flat File Targets

Description Naming Convention and Examples
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Flat file
extracts of
source view

Flat file target names have a prefix that describes the datastore name. Segments
describe the source table name, batch ID, and A SUB-CATEGORY segment
describes the ETL phase. The suffix is .txt.

Format:

<DATASTORENAME (without _DS)>_<SOURCETABLENAME_BATCHID>
_<SUB-CATEGORY>.txt

Example:

AMVIEW_AMRIGHTSUSESCOUNT_' ||$G_Batch_ID||'
_EXTRACT_FF.TXT AMVIEW_AMRIGHTSUSESCOUNT
_' ||$G_Batch_ID||'_EXTRACT_DELETE_FF.TXT
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Data Warehouse Command Reference
This section is a syntax reference for the out-of-box scripts that are available to ETL designers and
developers.

The data warehouse contains out-of-box .xml files in this directory:
<DWH_home_directory>\DataWarehouse\conf

The table in the Command Summary section lists the out-of-box scripts that you can use to
accomplish command line tasks. These scripts produce specific results. Changing themmay
produce unpredictable results when they run. For details, see "DWH CommandReference" on
page 257.

This section includes the following topics:

"ABC CommandReference" below

"DWH CommandReference" on page 257

"The Automation Tool" on page 265

ABC Command Reference
This section describes all of the out-of-box ABC command files that are available to administer the
ABC functions. The table in the Command Summary section lists the out-of-box files that you can
use to accomplish ABC tasks.

Although SAP BusinessObjects Data Services runs the jobs that extract, transform, and load data,
ABC manages the actual launch, execution, and sequencing of the steps in these jobs. If you run
jobs using SAP BusinessObjects Data Services only, there can be conflicts, sequence errors, and
data corruption, and run-time statistics can be lost.

The data warehouse provides the out-of-box file (upstream.xml) that contains the required job
steps. The primary ABC tasks are to launch ETL batch jobs at regularly scheduled intervals and
ensure that the individual job steps run as soon as they are ready. In addition, the ABC Audit and
Control reports enable you to view information pertaining to the utilities.

Syntax Conventions

Command options in square brackets ([ ]) are optional.

Italicized lowercase expressions are variable values.

If a command option argument is a text string that contains blank spaces, youmust enclose it in
quotationmarks. Otherwise, the text before the blank space is considered the entire argument and
the remaining text becomes an undefined option.
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Command Summary

The following command script files are available in this directory:
<Installation Directory>\agora\DataWarehouse\bin

Name Purpose Primary User

"dw_abc_batch_
control " below

Start and stop batch job streams. Administrator

"dw_abc_load_batch "
on next page

Load a batch job stream or register it as a
scheduled task.

Administrator

"dw_abc_run_steps "
on page 253

Run job stream steps (the ABC engine) or
register it as a scheduled task.

Administrator

"dw_abc_retry_step "
on page 254

Restart a job stream step. Administrator

"dw_abc_job_launcher
" on page 255

Start or stop job steps within a job stream. Administrator or
ETL developer

"dw_abc_set_status "
on page 256

Capture the status of job stream steps that are
implemented as batch scripts.

Administrator or
ETL developer

dw_abc_batch_control

Use this script to start and stop batch job streams. The dw_abc_batch_control utility enables you
to:

l Suspend an active batch job stream

l Resume a suspended batch job stream

l Abort a running batch job stream

User
Administrator

Syntax
DWH_Admin

dw_abc_batch_control (-abort | -resume | -suspend)

(streamID <streamid> | -all)

[-help]
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Options

Option Required? Description

Choose one of the following options:

-commandName all No Complete the named command action on all loaded
job streams.

-abort No Terminate -all or a specific streamID where the
streamID value is the catalog parameter value for
dwid="xxxx".

-abortAndKillJobs No Abort the specified stream and kill all currently
running SAP BusinessObjects Data Services jobs
(if any currently running).

-resume No Re-start -all or a specific streamID where the
streamID value is the catalog parameter value for
dwid="xxxx".

-suspend No Temporarily stop -all or a specific streamID where
the streamID value is the catalog parameter value
for dwid="xxxx"

Choose one of the following options:

l -streamId streamId No The streamID value is the catalog parameter value
for dwid="xxxx" found in the xml file that describes
the stream: <Installation Directory>\agora\Content
Packs\Core\ABC\upstream.xml

l -all No All streams currently executing.

-help No Display command syntax

Examples
l dw_abc_batch_control -suspend -streamid Stream1

l dw_abc_batch_control -resume -all

dw_abc_load_batch

Use this script to load a batch job stream or register it as a scheduled task.
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The dw_abc_load_batch utility is responsible for starting an ABC ETL track. You can run this
utility manually at the command line, or scheduled it to run at scheduled intervals.

Batch job streams can run concurrently if each job stream is independent of other job streams;
however, if two concurrent batch jobs invoke the same job stream, they cannot run successfully. If
the dw_abc_load_batch utility successfully loads a batch job, as long as that batch job is running,
any attempt to load a second instance of the same batch job will fail. Running the out-of-box
upstream.xml job stream in overlapping batches produces errors.

The dw_abc_load_batch utility initializes the ABC stream and prepares the stream steps for
execution.

The dw_run_steps utility looks for these steps that are ready and starts each one individually. The
batch jobmanages the details of extracting entities from source databases.

All the job steps in the batch job reference the same batch ID. The initial state of the batch is
Active. The initial state of all of the pending processes (job steps) is Waiting.

User
Administrator

Syntax
dw_abc_load_batch -streamId <string>

[-register (-every <string> |-starttime <string>)]

[-unregister]

[-list]

[-help]

Options

Option Required? Description

Choose one of the following options:

-list No List tasks scheduled to run.

-list _streamId
<streamId>

Yes Identify the stream ID value that is specified in the
stream file parameter dwid="xxxx".

-register No Create a scheduled task to run dw_abc_load_batch at
regular intervals.

-unregister _streamId
<streamId>

No Unregister all the events for the specified streamId
stream.

-starttime hh:mm No Start the task to load the batch where the value for hh
is 00–24 and the value for mm is 00–59.
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-streamid stream_id Yes Identify the stream ID value that is specified in the
stream file parameter dwid="xxxx".

-help No Display command syntax.

Examples
l dw_abc_load_batch -streamId streamId

l dw_abc_load_batch -streamId streamId -register -every 720

l dw_abc_load_batch -streamId streamId -register -starttime 22:30

l dw_abc_load_batch -unregister -streamId streamId

l dw_abc_load_batch -list -streamId streamId

l dw_abc_load_batch -unregister

l dw_abc_load_batch -list

dw_abc_run_steps

Use this script to run job stream steps or register the action as a scheduled task.

The command verifies the successful execution of each step before a dependent step begins. It
also compiles a list of parallel and sequential execution steps that are ready to run, then launches
each step that is ready for execution.

The command:

l Determines which steps are ready to run and starts them.

l Creates processes for each step in a batch job stream.

l Reports execution state for each process, then updates a final execution status for the batch.

l Sets a status of Max_Execution_Time_Exceeded if a step exceeds its maximum execution
time.

l If Max_Execution_Time_Exceeded occurs, stops job step execution.

l Finds all steps that are blocking the execution of a job stream and reports them.

l Retries any step that terminates with an error and has not exceeded the specifiedmaximum
number of retries.

You can specify amaximum number of retries when an error occurs, and amaximum execution
time for each step in the job stream definition file. Because they are optional parameters, they have
default values of no retries and unlimited execution time. For details see "Change the Number of
Retries for a Failed ETL Step" on page 269.

User
Administrator

Syntax
dw_abc_run_steps [-streamId <string>]

HP IT Executive Scorecard (9.31)Page 253 of 282

Administrator Guide



[-every <interval>]

[-register]

[-unregister]

[-list]

[-help]

Options

Option Required? Description

-every nnn No Start the batch load task every nnnminutes.

-list No Display a list of the registered events for all the stream
Ids.

-list _streamId
<streamId>

No Display a list of the registered events for the specified
streamId.

-register No Create a scheduled task to run dw_abc_run_steps at
regular intervals.

-unregister _streamId
<streamId>

No Unregister all the events for the specified streamId
stream.

-streamId stream_id No Stream ID value for the step to restart.

-help No Display command syntax for this command.

Examples
l To run all possible steps with a ready status:

dw_abc_run_steps -streamId Upstream

l To create a scheduled task that executes the dw_abc_run_steps command every 60minutes:
dw_abc_run_steps -register -every 60 -streamId Upstream

l To remove a scheduled task that starts the dw_abc_run_steps:
dw_abc_run_steps -unregister -streamId Upstream

l To list a scheduled task that starts the dw_abc_run_steps:
dw_abc_run_steps -list -streamId Upstream

l To remove all scheduled tasks that starts the dw_abc_run_steps:
dw_abc_run_steps -unregister

l To list all scheduled tasks that starts the dw_abc_run_steps:
dw_abc_run_steps -list

dw_abc_retry_step

Use this script to restart a job stream step.
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The dw_abc_retry_step utility re-starts a job step. When you specify amaximum number of
retries, the ABC engine blocks the job stream when that number is exceeded.

User
Administrator

Syntax
dw_abc_load_batch -streamId <string>

-stepId <string>

[-help]

Options

Option Required? Description

-stepId step_id Y Step ID value for the step to restart.

-streamId stream_id Y Stream ID value for the step to restart.

-help N Display command syntax.

Example
dw_abc_retry_step -streamId Upstream -stepId step_id

dw_abc_job_launcher

Use this script to start or stop specific SAP BusinessObjects Data Services jobs.

User
Administrator or ETL developer

Syntax
dw_abc_job_launcher -jobname <string>

[-stop]

[-help]

Options

Option Required? Description

-jobname job_name Y Name of the job that you want to run.

-stop job_name N Stop job execution.

-help N Display command syntax.

If you omit the -process option, youmust set an environment variable%DW_PROCESS_ID% that
contains the value of the process ID.
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Example
l dw_abc_job_launcher -jobname DW_JB

l dw_abc_job_launcher -stop -jobname DW_JB

dw_abc_set_status

Use this script to set the status of job stream steps that are implemented as batch scripts.

User
Administrator or ETL developer

Syntax
dw_abc_set_status (-error | -final | running | -success | -warning)

[-info <string>]

[-help]

Options

Option Required? Description

Choose one of the following status parameters:

l -error N If an error occurs, update the data warehouse
with the error status.

l -final N If an error occurs, update the data warehouse
with themost severe status.

l -running N If an error occurs, update the data warehouse
with the run status.

l -success N If successful, update the data warehouse with
the success status.

l -warning N If a warning status occurs, update the data
warehouse with the warning status.

-help N Display command syntax.

The -info "message_text" is optional free text that you can display.

This script requires the DW_PROCESS_ID environment variable to be set with the value of the
process ID before you run this script.

Example
dw_abc_set_status -error -info "Job failed"
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DWH Command Reference
The following command script files are available in this directory:
<DWH_home_directory>\DataWarehouse\bin

Data Warehouse Script Files

Name Purpose Primary User

"dw_bods_xml_import" on next page Import ETL from XML
files to the SAP
BusinessObjects Data
Services repository.

Administrator

"dw_clean_data" on next page Clean data from staging
and target databases to
imitate initial load. For
details, see "Clean Up
the Staging and Target
Databases" on page
207.

Administrator

"dw_ds_gen" on page 259 Generate themetadata
repository.

ETL developer

"dw_ds_import" on page 260 Import source files into
themetadata repository

ETL developer

"dw_etl_export" on page 260 Export the SAP
BusinessObjects Data
Services jobs,
workflows, and other
ETL components.

ETL developer

"dw_etl_import" on page 261 Import the SAP
BusinessObjects Data
Services jobs,
workflows, and other
ETL components.

ETL developer

"dw_etl_update_containers" on page 261 Build an ETLworkflow
container.

ETL developer

"dw_foundation_setup" on page 262 Build the data
warehouse foundation

Installer
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"dw_generateschemas" on page 263 Generate schemas and
tables.

ETL developer

"dw_initdb" on page 264 Initialize the data
warehouse database
schema

Administrator

"dw_tz_update_dst" on page 264 Update time zone
information

Administrator

dw_ds_automation.bat Data Source
Configuration using the
Automation Tool. For
details, see "The
Automation Tool" on
page 265.

Administrator

dw_bods_xml_import

Use this script to import ETL from XML files to the SAP BusinessObjects Data Services repository.

The input XML files are located in the indicated directory, or its subdirectories.

User
Administrator

Syntax
dw_bods_xml_import [-help] [-fromfile "<xmlfile>" | -fromdir

"<directory>"]

Options

Option Required? Description

-fromdir <fromdir> N The directory, in the data source repository,
that contains the ETL XML files to import .

-fromfile <fromfile> N The XML file, in the data source repository,
from which the ETL is imported .

-help N Display command syntax.

Examples
dw_ds_gen -datastore all -outputdir c:\datastores dw_ds_gen -datastore PPM -outputdir
c:\datastores\PPM

dw_clean_data

Use this script to clean data from the staging and target databases to imitate an initial load..
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User
Administrator

Syntax
dw_clean_data [-help]

Options

Option Required? Description

-help N Display command syntax.

Examples
dw_clean_data.bat

dw_ds_gen

Use this script to generate one or more datastores. SAP BusinessObjects Data Services imports
these datastores to enable SAP BusinessObjects Data Services jobs to connect to the database.

User
ETL developer

Syntax
dw_ds_gen -datastore <dws|dwst|dwt|dwabc|PPM|AM|SM|all>

-outputdir <directory>

[-verbose]

[-help]

Options

Option Required? Description

-datastore Y Generate the specified data source (dws,
dwst, dwt, dwabc, PPM or AM). Specify all to
generate all sources.

-outputdir directory_name Y Path and name of the target directory where
the data source files are to be generated.

-verbose N Producemore detailed output.

-help N Display command syntax.

Examples
dw_ds_gen -datastore all -outputdir c:\datastores dw_ds_gen -datastore PPM -outputdir
c:\datastores\PPM
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dw_ds_import

Use this script to import source files from a named directory into themetadata repository. For
example, to import a collection of files into the datastore directory.

User
ETL developer

Syntax
dw_ds_import -inputdir directory

[-help]

Options

Option Required? Description

-inputdir directory_name Y Path and name of the directory where the data
source files are to be imported.

-help N Display command syntax.

Example
dw_ds_import -inputdir "c:\datastore\Source Files"

dw_etl_export

Use this script to export Data Services jobs, workflows, data flows, and functions to a zip file.

User
ETL developer

Syntax
dw_etl_export -zip <zipfile>

[-help]

Options

Option Required? Description

-zip zip_file_name Y Export to the specified archive file.

-help N Display command syntax.

Example
dw_etl_export -zip c:\etlFiles.zip
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dw_etl_import

Use this script to import Data Services jobs, workflows, data flows, and functions to a zip file.

User
ETL developer

Syntax
dw_etl_import [-atl <atlFile>]

-topdir <directory>

[-zip <zipfile>]

[-help]

Options

Option Required? Description

-atl atl_file_name N Import the specified .atl file.

-topdir directory_name Y Import all .atl files under a specified directory and
subdirectory.

-zip zip_file_name N Import the contents of the archive file.

-help N Display command syntax.

Examples
dw_etl_import -topdir c:\etlFiles

dw_etl_import -topdir "c:\ETL Files"

dw_etl_import -zip c:\etlFiles.zip

dw_etl_import -atl c:\functions.atl

dw_etl_update_containers

This script loads .atl files during the installation process.

User
ETL developer

Syntax
dw_etl_update_containers -topdir <directory>

[-verbose]

[-help]
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Options

Option Required? Description

-topdir directory_name Y Name of the directory that contains all
application-specific .atl files.

-verbose N Producemore detailed output.

-help N Display command syntax.

Return codes
0 – Success
1 – Success with warnings
>1 – Errors

Examples
dw_etl_update_containers -topdir "c:\My Application"

dw_etl_update_containers -topdir c:\MyApplication

dw_foundation_setup

Use this script to call the scripts that initialize the data warehouse, or load themetadata for data
source connections into the database.

Syntax
dw_foundation_setup [-args <taskArguments>]

-taskName <taskName>

[-verbose]

[-help]

Options

Option Required? Description

-args task_argument N Name of the task argument.

-taskName task_name Y Name of the requested task.

-verbose N Producemore detailed output.

-help N Display command syntax.

You can see the individual tasks and associated arguments called by dw_foundation_setup if you
open this file with a text or xml editor:
<DWH_home_directory>\DataWarehouse\etc\xml\dw_foundation_setup.xml

Return codes
0 – Success
1 – Success with warnings
>1 – Errors
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dw_generateschemas

Use this script to generate schemas and tables.

Syntax
dw_generateschemas [-aggregates]

[-application <application>|all]

[-autoloadingmode true|false]

[-interface]

[-noninteractive]

[-product <product>|all]

[-staging]

[-target]

[-verbose]

[-help]

Options

Option Required? Description

-aggregates N Generate or update the aggregation tables.

-application application_
name | all

N Load the named application or load all applications.
All is the default if you are in non-interactivemode.

-autoloadingmode N Specify true or false. True is the default value.

-interface N Generate the SQL script files to create the interface.

-noninteractive N Run this script without prompting for user input. Use
all default values.

-product product_name | all N Load the specified product. All is the default value.

-staging N Generate or update the staging tables.

-target N Generate or update the target tables.

-verbose N Producemore detailed output.

-help N Display command syntax.

Interfaces will always be written to a file, whether autoloadingmode is on or not. Each interface for a
Data Source Connection is written to a separate file. If you do not specify a specific phase, all
phases execute.

Example
dw_generateschemas -application myApp -autoloadingmode true -target
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dw_initdb

Use this script to initialize data warehouse foundation database schemas.

Syntax
dw_init.bat [-confdir <directory>]

[-schema <schemaname>]

-sqldir <directory>

[-help]

Options

Option Required? Description

-confdir directory N Name of the directory that contains the
.properties file for the designated schemaname.

-schema schemaname N Name of the schema, such as dwmetadata, dws,
dwst, or dwt.

-sqldir directory Y Name of the directory that contains the schema
and .properties file.

-help N Display command syntax.

Examples
dw_init.bat -sqldir c:\myDbDirectory
dw_init.bat -sqldir c:\myDbDirectory -schema dwmetadata -confdir “c:\my Config
Directory”

dw_tz_update_dst

Load or update the time zone information for a data source and the data warehouse.

Run this utility whenever you deploy new source data or when youmanually change the time zone.

Time zone is expressed in GMT format: GMT +\-nn:nn.

Syntax
dw_tz_update_dst.bat

[-help]

[-verbose]

Options

Option Required? Description

-help N Display command syntax.

-verbose N Producemore detailed output.
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Return codes:
0 – Success

1 – Success with warnings

>1 – Errors

Example
dw_tz_update_dst -verbose

The Automation Tool
The automation tool is built and designed to simplify the different tasks of Data Source
Management.

It contains Data SourceManagement back-end tools that simplify the usage, add some necessary
validations, and set the different statuses. The functions are used by the Data SourceManagement
user interface but also provides a command line interface so it can be used outside the application
server.

The following Command Line Interface (CLI) is available for Data SourceManagement functionality
outside the UI. The command script files are found in this directory:
<DWH_home_directory>\DataWarehouse\bin

TestConnection
Usage: dw_ds_automation.bat -task TestConnection -cp xxx -xmlFilePath [Path to
datasources.xml file]

Description: Test the connection to the data source. Should be used before running the
configuration task in order to validate correct connection details.

Register Instance
Usage: dw_cp_register.bat -addInstance –name <CP_NAME>

Description:

l Use to add an additional instance of the data source.

l The DataWarehouse then looks for the CP in the Content Packs Folder.

l The instance ID is displayed in the output.“Instance ID: XX has been added to Content Pack:
<CP_NAME>”

l It is also added to the CONTENT_PACK table.

ConfigureInitial
Usage: dw_ds_automation.bat -task ConfigureInitial -cp <content pack name>-instance
<INSTANCE_ID>-xmlFilePath [Path to datasources.xml file]

Description:

l Configure the CP connection settings before the CP has been initialized.

l Use prior to CP initialization (Deploy).
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Note: To successfully run this command, the ALM passwordmust be encrypted before saving
it in the Staging database.

Configure
Usage: dw_ds_automation.bat -task Configure -cp <content pack name>-instance <INSTANCE_
ID> -xmlFilePath [Path to datasources.xml file]

Description:Configure the CP connection settings and regenerate the datastore of the product.
Can be used only after the CP has been successfully initialized.

Note: If any the following sources HP Application Lifecycle Management, HP Business
ServiceManagement, or HP Universal ConfigurationManagement Database are configured
via a back-end too, the relevant URL listed below should be run before the ETL is run:

l HP Application Lifecycle Management:
http://localhost:10002/dw/integrations/generic/reset/ALM

l HP Business Service Management:
http://localhost:10002/dw/integrations/bsm/reset/connection

l HP Universal Configuration Management Database:
http://localhost:10002/dw/integrations/ucmdb/ucmdb/reset/connection

Deploy
Usage: dw_ds_automation.bat -task Deploy -cp <content pack name>-instance <INSTANCE_ID>

Description: Initialize the CP and set the CP status as Initialized.

Activate
Usage: dw_ds_automation.bat -task Activate -cp <content pack name>-instance <INSTANCE_
ID>

Description:Activate the CP using the stream Assembler and set the CP status as Activated.
Activating the CP causes its ABC stream to bemerged with theMain (Core) CP stream. Activated
CP stream steps will be executed during the execution of theMain (Core) ABC Stream.

Deactivate
Usage: dw_ds_automation.bat -task DeActivate -cp <content pack name>-instance
<INSTANCE_ID>

Description:Deactivate the CP using the stream assembler and set the CP status as Non-
Activated. Deactivate performs the opposite action from Activate. Deactivate subtracts the
deactivated CP ABC Steps from theMain ABC Stream Steps.

AutoActivate
Usage: dw_ds_automation.bat -task AutoActivate

Description:Deploy and activate all CPs with "autostart" flag according to the order set by
"autostartpriority" in themanifest
used by the post- install tool. Themanifest found in cp_manifest.properties, is a list of attributes
located in the root folder of the Content Pack.
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Advanced Data Warehouse Administration
This section describes some of the advanced commands for DWH processes. DWH also provides
a set of reports that provide the administrator with awareness and insight into the DWH processes.

This section includes the following topics:

"Advanced Utilities" below

"Validate Catalog and Stream Definitions" on page 269

"Change the Number of Retries for a Failed ETL Step" on page 269

"Change DataWarehouse Passwords" on page 270

"Improve Performance" on page 272

"Check the Runtime Status of Batch Jobs" on page 272

"Resolve an ETL Error" on page 272

"Monitor and Tune the DataWarehouse" on page 272

"Purge Validation Tables" on page 273

"Upgrade Content Packs" on page 273

"Consolidate Entities using the XREFMechanism" on page 274

"SA Password Change" on page 275

Advanced Utilities
The DataWarehouse enables you to run advanced ABC utilities.

dw_abc_job_launcher

Use this script to start or stop specific SAP BusinessObjects Data Services jobs.

User
Administrator or ETL developer

Syntax
dw_abc_job_launcher -jobname <string>

[-stop]

[-help]
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Options

Option Required? Description

-jobname job_name Y Name of the job that you want to run.

-stop job_name N Stop job execution.

-help N Display command syntax.

If you omit the -process option, youmust set an environment variable%DW_PROCESS_ID% that
contains the value of the process ID.

Example
l dw_abc_job_launcher -jobname DW_JB

l dw_abc_job_launcher -stop -jobname DW_JB

dw_abc_set_status

Use this script to set the status of job stream steps that are implemented as batch scripts.

User
Administrator or ETL developer

Syntax
dw_abc_set_status (-error | -final | running | -success | -warning)

[-info <string>]

[-help]

Options

Option Required? Description

Choose one of the following status parameters:

-error N If an error occurs, update the data warehouse
with the error status.

-final N If an error occurs, update the data warehouse
with themost severe status.

-running N If an error occurs, update the data warehouse
with the run status.

-success N If successful, update the data warehouse with
the success status.
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-warning N If a warning status occurs, update the data
warehouse with the warning status.

-help N Display command syntax.

The -info "message_text" is optional free text that you can display.

This script requires the DW_PROCESS_ID environment variable to be set with the value of the
process ID before you run this script.

Example
dw_abc_set_status -error -info "Job failed"

Validate Catalog and Stream Definitions
ABC utilities automatically validate xml syntax and perform more sophisticated validation, such as
loop detection in a job stream and valid catalog references to the job stream (dwid=Upstream).

If an error occurs, you can view the DW ABC Streams Management UI for stream information. Fore
details, see "Perform Tasks for ETLManagement " on page 175.

Additionally you can review the ABC Operational Status report to see where the process failed. For
details, see "ABC - Operational Status Report" on page 214

Change the Number of Retries for a Failed ETL Step
The job stream batch file has a job stream step for each required task in the end-to-end ETL process
and for each data source. Each job stream step has a parameter value that specifies the number of
retries allowable before the job step terminates with an error. You canmanually edit this value to
increase or decrease the number of retries.

To change the number of retries:

1. Navigate to the installation directory structure to locate the following file:
<Installation Directory>\agora\contentpacks\{$CP}\ABC\${stream name}.xml,
(depending on the ${CP})

2. Save a backup copy of the file before you proceed.

3. Open upstream.xml with a text editor. There is a sequential list of job stream steps that
manage the entire ETL process.

<ns1:JobStreamSteps>

<ns1:JobStreamStep dwid="SYS_READY" businessname="check ETL pre

conditions" ... maxretries="4"/>

<ns1:JobStreamStep dwid="EXTERNAL_FILE" businessname="extract

External

Files" ... maxretries="4"/>

<ns1:JobStreamStep dwid="PPM_SOURCE_EXTRACT" businessname="extract

PPM

to FF"... " maxretries="4"/>

<ns1:JobStreamStep dwid="AM_SOURCE_EXTRACT" businessname="extract
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AM to

FF" ... maxretries="4"/>

<ns1:JobStreamStep dwid="ENTERPRISE_XREF" businessname="load Xref

table" ... maxretries="4"/>

<ns1:JobStreamStep dwid="PPM_EXT" businessname="load PPM FF" ...

maxretries="4"/>

<ns1:JobStreamStep dwid="AM_EXT" businessname="load AM FF" ...

maxretries="4"/>

<ns1:JobStreamStep dwid="PPM_SSI" businessname="PPM Single Source

Identity" ... maxretries="4"/>

4. Locate the job stream step that you want to modify and changemaxretries="4" to
maxretries="nn"where nn is the number of retries before the job step terminates.

5. Save and close the file.

6. In order to activate the new ABC definitions, youmust activate the changed CP ABC
definitions.
a. If the ABC definitions weremodified in the CORE content pack, any change to the content

packs state would update the change.

b. If the ABC definitions weremodified in any of the Integration Content packs, youmust re-
activate the content pack to import the new definitions.

7. Open the Data SourceManagement user interface, and re-activate themodified CP of which
definitions youmodified. For details, see "Perform Tasks for Data SourceManagement" on
page 197.

Change Data Warehouse Passwords
The installation and configuration process gathers all data warehouse and SAP BusinesObjects
passwords, encrypts them, and stores them in the DataWarehouse platform settings
management.

Note: In order for the ETL to successfully run after you have changed a password, youmust
change the Database Password and the Database Login Password in DataWarehouse
Settings UI. For details, see "Configure DataWarehouse Settings" on page 160.

To change a password:

1. Stop any ETLs that are running, or abort a job stream if it is running.

2. On the RDBMS server, change the password for a specific Login Name.

3. Click Admin > Data Warehouse, and update the relevant Login with the new password from
step 2.

Note: Changing the password in the DataWarehouse user interface does not modify the
password in the database servers. It is preferable to rely on the user performing the
password updatemanually.

4. The DataWarehouse creates a database link which then uses the DataWarehouse and SAP
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BusinessObjects Enterprise passwords. The Linked Server is created in the following
situations:

5. a. The staging and target databases are installed on different servers.

b. The populated database server name in the post-install is different than the database host
name on the system server for server id_0.

In these situations, if you reset DWH user passwords (for dwabc, dwmetadata, dws, dwst, or,
dwt), go to Linked Servers in theMicrosoft SQL Server Management Studio, and change the
relevant passwords in theSecurity tab of the Linked Server Properties, as follows.

6. When you change the passwords in the DataWarehouse user interface as well as the
database server youmust run the following:

n <DWH root dir>\bin\dw_ds_gen.bat -outputdir \tmp\datastores -datastore all

n <DWH root dir>\bin\dw_ds_import -inputdir \tmp\datastores

7. Reload the batch using dw_abc_load_batch.bat.

8. Run ETL.

9. Note that a reboot is recommended after passwords change.

Note: It is recommended to avoid using localhost as the server database name.
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Improve Performance
Normal procedures require database administrators to set up aggregation, indices, and partitions
that can enhance performance.

Enhancing and tuning overall database performance also improve the data warehouse performance.

Because the end-to-end ETL process involves accessing remote source databases and network
connections, youmay want to evaluate where performance degradation occurs and apply tuning
strategies to these external connections.

Check the Runtime Status of Batch Jobs
You can check the status of batch jobs and step status using the DW ABC Streams Management
UI.

Additionally, the data warehouse produces operational and administrative reports that contain
information about job status and other critical data warehouse activities.

When you view the ABC Operational Status report, you can see the global status and state of each
ETL job stream and a snapshot of the runtime status of each job stream step.

For details, see "Perform Tasks for ETLManagement " on page 175

To view reports, see ABC -Operational Status in "Control Reports" on page 213"Control Reports"
on page 213.

Resolve an ETL Error
ETL jobs contain stream steps that you can restart.Using the DW ABC Streams Management UI,
you can view relevant step information.

If the stream step is ready for processing, the next scheduled execution of abc_run_steps.bat will
restart the stream step automatically.

If there is another impediment, such as source database or connection issues, youmust resolve
that issue before the step can complete successfully.

In the DW ABC Streams Management UI you can view step status, manually retry steps, as well
as schedule run_steps command.

For details on viewing errors and step information, see "Perform Tasks for ETLManagement " on
page 175.

For back-end details, see "ABC CommandReference" on page 249.

Monitor and Tune the Data Warehouse
The overall health of the data warehouse depends on the administrative skill of the RDBMS
administrator.

TheMicrosoft SQL Server 2008 database administrator uses standard operating procedures for
daily database operations.
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The data warehouse is governed by these same processes and procedures.

For monitoring and tuning details, see theMicrosoft SQL Server 2008 documentation.

Purge Validation Tables
There is no automated process to purge these tables on a regular schedule.

Because organizations require audit and validation information to be retained for varying amounts of
time, you should verify what the appropriate retention period is in your organization.

Use the following SQL script to delete all records in each of the validation tables that are older than
the defined retention period.

CREATE OR REPLACE PROCEDURE sp_del_valf_info AS

--declare variables

BEGIN

--Delete All Required records in selection

DELETE FROM *.VALF

WHERE --trunc(Date) &lt; '09-FEB-06'

);

COMMIT;

END sp_del_valf_info &gt;

Upgrade Content Packs
In a case where you have a newer Content Pack folder that contains updates or fixes for the OOTB
CP you can perform the following.

To upgrade Content Packs: dw_ds_automation.bat -task Upgrade -cp [cp name] -
newContentPackPath [path of the new cp]

The following steps are automatically included in the upgrade tool:

1. Deactivate all Integration Content Packs that are activated. It is recommended to stop ETL
running and cancel all scheduling.

2. Zip the original Content Pack directory.

3. Copy the Content Pack to a new folder and run the upgrade command for that path.

This overwrites the existing Content Pack folder.

4. Activate the Core Content Pack as well as the remaining Content Packs.

5. Update the content_pack table according to the new manifest, cp_manifest.properties, a list of
attributes located in the root folder of the Content Pack being upgraded.

For activation and deactivation details, see "Perform Tasks for Data SourceManagement" on page
197.

Note the following usage limitations:

l ETL Stream should not be in a runningmode - all streams must be aborted.

l The new CP folder must be a valid CP folder.
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l CP should not be in Installed state, Integration Content Packs should be activated at least once
before upgrade.

l If Core is being upgraded, it must be in theActivated state.

Note: In order to avoid upgrade failure, do not change the executables in the ABC catalog.

Consolidate Entities using the XREF Mechanism
The consolidation process for data sources enables you to take information from the various
sources and consolidate it into a single entity. Information from two or three sources is incorporated
in the data warehouse in order to create a new entity. The XREFmechanism enables you to give
priorities to a specific source when the same entity is extracted from different sources. Additionally
you can give priority to instances of the same source.

Set Consolidation Priorities

You can change the specific consolidation priority at the entity level using an Excel spreadsheet.
Each source has an Excel which contains a list of the entities that can be consolidated, which you
can prioritize according to number, starting with 1. If you do not want an entity from a particular
source to be consolidated, enter a priority of -1.

To change the entity priority:
1. UsingWindows Explorer, navigate toC:\<Installation

Directory>\agora\ContentPacks\<name of CP>\ETL\flatfiles. For XREF consolidation
following deployment, navigate toC:\<Installation
Directory>\agora\DataWarehouse\ExternalSources.

2. Open the specific consolidation file, for example: CONSOLIDATION_PRIORITIES_PPM.

3. Enter the priority you want to assign to each entity (DW_ID).

4. Save and close the file.
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Note:

l Consolidation priorities for multiple instances of the same data source are given according
to the order of deployment.

l If in the same instance several records have the same priority qualifier, there is
consolidation between those entities (the process does not fail), and the latest priority is
utilized.

To cancel consolidation of a specific entity:
1. In the database, open [dwmetadata].[ConsolidationPriorities].

2. Change the priority number to -1 for the specific entity.

3. Save the changes.

Note: It is not permitted tomanually change the -1 priority for OOTB entities that cannot be
consolidated.

SA Password Change
The procedure for changing this password is complex, therefore it is recommended not to be done
often.

To change the SA password
l On BOE server:

a. Change the password in BOE ODBC connection to the new password and restart the BOE.

b. Perform the following only if you created your own universes and you are using your own
connections (not one of the following: XS_APP_JDBC, XS_DWH_JDBC, ita_admin, ita_
operations).

i. Import all of your universes into the BOE designer.

ii. In the Tools menu, select Connections.

iii. Change the SA password for all of your connections.

iv. Save and export the Universes.

v. Make sure that Period_Universe appears under the XS_Studio folder.

l On the DWH server:
a. Stop running Executive Scorecard.

b. Copy the run_postinstall.bat file from \<Installation
Directory>\installation\HPXS903\backup\agora\confwizard to
\HPXS\agora\confwizard and execute this file.

c. In theMNGDB page of the wizard, change the password for the SA user.

d. Before the final wizard step, select Skip Data Warehouse configuration and continue
completing the post-install wizard.
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e. Open the DataWarehouse UI, using the following url: http://<DWH Server name
(FQDN>/dwh

f. Log in to the application using the same credentials you used to login to the XS application.

g. Navigate toAdmin > Data Warehouse and change the passwords for all SA users.

h. Restart the DWH server.

i. If you used the SA user as a BODS user (not recommended configuration), perform the
following from the CMD dir <<Installation Directory>\agora\DataWarehouse\bin>:

i. dw_ds_import.bat -inputdir \tmp\datastores

ii. dw_etl_update_containers.bat –topdir \tmp\datastores -upgrade

j. If you are not sure which user was used for BODS repository configurations, navigate to
Admin > Data Warehouse and check theRepository Username parameter in the SAP
BusinessObjects Data Services for HP FPA area.

l On the XS server:
a. Stop running Executive Scorecard.

b. Remove biar XS_SP2.biar from \<Installation Directory>\agora\confwizard\conf\scripts and
renamed XS_SP3.biar to XS_SP2.biar.

c. Remove dwh_target_sp2_views from \<Installation
Directory>\agora\confwizard\conf\scripts\database\mssql and rename dwh_target_sp3_
views to dwh_target_sp2_views.

d. Copy the run_postinstall.bat file from \<Installation
Directory>\installation\HPXS903\backup\agora\confwizard to
\HPXS\agora\confwizard and execute this file.

e. In theManagementDatabase page of the wizard, change the password for the SA user.

f. In the Result Database page of the wizard, change the password for the SA user.

Make sure that you always connect to the existing DB when running configurations.

Back Up Data Warehouse
It is critical that you backup DataWarehouse so that you can rebuild your DataWarehouse
infrastructure and content in disaster scenarios such as the following:

l In a total disaster recovery scenario

l The RDBMS server failed but all Executive Scorecard component servers are fully functioning.

l When the DataWarehouse server failed, but the RDBMS server and its databases are intact.

l When aDataWarehouse database is corrupt.

l When an ETL is deleted.

l When an ETL job fails.

This section includes the following topics:
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l "What to Back Up" below

l "General BackupGuidelines" below

l "Files to Back Up" on next page

What to Back Up
It is strongly recommended that you back up the following resources that may be used if one of the
above scenarios occurs.

1. Microsoft SQL Server 2008 enterprise SP2 databases

a. Target database

b. SAP BusinessObjects Data Services database

c. SAP BusinessObjects CMS database, and if necessary the Audit database.

d. Management database

e. Executive Scorecard database

Note: The host and database names can be found in theManagement database
configured in the Executive Scorecard Configuration wizard.

2. Staging database

3. It is highly recommended that you keep the passwords for the Staging, Target and SAP
BusinessObjects Data Services database login users in a safe place for usage in disaster
recovery situations.

4. External source files that can be found in the external source file location configured in the
Executive Scorecard Configuration wizard.

a. If the default external source file location was configured in the wizard, the Content Pack
flat files created during the ETL process can be found in: 
<Installation Directory>\agora\DataWarehouse\ExternalSources\<Content pack
name>

For example: The BSM content pack flat file would therefore located in the following
directory:
<Installation Directory>\agora\DataWarehouse\ExternalSources\BSM

5. DataWarehouse Configuration files.

General Backup Guidelines
It is recommended that you use the following backup and restore guidelines:

l A best practice for data warehouse administrators is to back up critical data on a regular basis.

l Database backups should consist of a weekly full database backups, and daily differential
backups.
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l Backups should be periodically verified by restoring a copy onto a test system.

l External source files and DataWarehouse configuration files should be backed up as required.

l Although out of scope for this document, regular backups should be taken of all source
databases.

l Start scheduled backups before running the daily ETLs.

l Use backup compression.

l Perform full backups in off-peak times.

Maintain the External Source Directory
In the <ExternalSource> directory , there are folders that contain extracted data from each data
source.

This data is infinitely accumulated and is never cleaned by the DataWarehouse. You are required
to periodically backup and remove old files from those folders in order to free disk space if available
disk space is low on the DataWarehouse platform machine.

Reference
Files to Back Up
The contents of the following directories and their sub-directories should be included in the backup
schedules:

Directory Name Backup
Frequency

Description
of files

<Installation
Directory>\Agora\DataWarehouse\<ExternalSourceslocation>

Daily .xls, and the
ETL flat files

<Installation Directory>\Agora\DataWarehouse\Conf When
configuration
changes are
made

Configuration
files
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<Installation Directory>\Agora\DataWarehouse\etc After the
installation, and
when
configuration
changes are
made.

When you
recover from a
Data
Warehouse
server failure, it
is important
that this
directory and
it's sub-
directories are
restored.

Configuration
files

<Installation Directory>\Agora\DataWarehouse\log Daily Log files

<Installation Directory>\Agora\ContentPacks Before
activating or
deactivating a
content pack in
the Executive
Scorecard
Admin
application, or
when changes
aremade to
content packs

Content pack
configuration
files

<Installation Directory>\Agora\DataWarehouse\etc\ABC
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Back Up Executive Scorecard
It is critical that you backup your databases, configuration files, logs and configuration settings so
that you can rebuild your IT Executive Scorecard solution and content in circumstances such as the
following:

l When you need to recover from a total disaster recovery scenario.

l The RDBMS server failed but all HP Executive Scorecard component servers are fully
functioning.

l When a database is corrupted.

l When a component server fails, but the RDBMS server and it's databases are intact.

The section includes the following topics:

l "What to Back Up" below

l "General BackupGuidelines" on next page

What to Back Up
HP recommends that you back up the following resources that may be used when one of the above
scenarios occurs.

1. Microsoft SQL Server 2008 enterprise SP2 databases
a. Staging database

b. Target database

c. SAP BusinessObjects Data Services database

d. SAP BusinessObjects CMS database, and if necessary the Audit database.

e. Management database

f. Executive Scorecard database

Note: The host and database names can be found in theManagement database
configured in the Executive Scorecard Configuration wizard.

2. DataWarehouse Configuration files. For more information, see "Back UpDataWarehouse "
on page 276.

3. SAP BusinessObject Enterprise configuration. This can be backed up with the
BusinessObjects Enterprise XI 3.1 Import Wizard. For more information, see Chapter 7 of the
BusinessObjects Enterprise XI 3.1 Import Wizard Guide at
http://help.sap.com/businessobject/product_guides/boexir31/en/xi3-1_bip_importwiz_en.pdf.

4. It is highly recommended that you keep the passwords for the Staging, Target and SAP
BusinessObjects Data Services databases in a safe place for usage in disaster recovery
situations.
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General Backup Guidelines
It is recommended that you use the following backup and restore guidelines:

l Your database administrator should back up critical data and configuration settings on a regular
basis.

Database backups should consist of a weekly full database backups, and daily differential
backups.

l Backups should be periodically verified by restoring a copy onto a test system.

l External source files and DataWarehouse configuration files should be backed up as required.

l Although out of scope for this document, regular backups should be taken of all source file
databases.

l Start scheduled backups before running the daily ETLs.

l Use backup compression.

l Perform full backups in off-peak times.
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