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Documentation Updates
The title page of this document contains the following identifying information:
l

Software Version number, which indicates the software version.

l

Document Release Date, which changes each time the document is updated.

l

Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a document, go
to:
http://h20230.www2.hp.com/selfsolve/manuals
This site requires that you register for an HP Passport and sign in. To register for an HP Passport
ID, go to:
http://h20229.www2.hp.com/passport-registration.html
Or click the New users - please register link on the HP Passport login page.
You will also receive updated or new editions if you subscribe to the appropriate product support
service. Contact your HP sales representative for details.

PDF Version of Online Help
This document is a PDF version of the online help. This PDF file is provided so you can easily print
multiple topics from the help information or read the online help in PDF format.

This document was last updated: Monday, November 12, 2012
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Support
Visit the HP Software Support Online web site at:
http://www.hp.com/go/hpsoftwaresupport
This web site provides contact information and details about the products, services, and support
that HP Software offers.
HP Software online support provides customer self-solve capabilities. It provides a fast and
efficient way to access interactive technical support tools needed to manage your business. As a
valued support customer, you can benefit by using the support web site to:
l

Search for knowledge documents of interest

l

Submit and track support cases and enhancement requests

l

Download software patches

l

Manage support contracts

l

Look up HP support contacts

l

Review information about available services

l

Enter into discussions with other software customers

l

Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also
require a support contract. To register for an HP Passport ID, go to:
http://h20229.www2.hp.com/passport-registration.html
To find more information about access levels, go to:
http://h20230.www2.hp.com/new_access_levels.jsp
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Integration with BSM and HPOM Best
Practices Overview
This guide describes best practices and troubleshooting when configuring the integration of
SiteScope with HP Business Service Management (BSM) and HP Operations Manager (HPOM)
products.
This guide covers the following topics:
l

"Integrating SiteScope with BSM" on page 7
Describes best practices for integrating SiteScope with BSM applications.

l

"Integrating SiteScope with HPOM Applications" on page 17
Describes best practices for using and configuring the HP Operations Manager (HPOM)
integration for sending events and reporting metrics to HPOM and HP Performance Manager.

l

"Recommendations for Integrating SiteScope with BSM or HPOM" on page 21
Describes best practices for using SiteScope with BSM and HPOM applications.

l

"Troubleshooting SiteScope Integration Issues" on page 22
Describes troubleshooting when using and configuring the integration of SiteScope with BSM
and HPOM applications.
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Chapter 1
Integrating SiteScope with BSM
SiteScope can be used to report data that is used in many applications in Business Service
Management (BSM). This section contains details of the benefits, prerequisites, best practices,
and troubleshooting for integrating SiteScope with BSM applications.
This section includes:
l

"Integration Benefits" on the next page

l

"Integration Prerequisites" on page 9

l

"Integration Options and Details" on page 10

l

"Troubleshooting" on page 16
Note: For recommendations on integrating SiteScope with BSM or Operations Manager
(HPOM), see "Recommendations for Integrating SiteScope with BSM or HPOM" on page 21.
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Integration Benefits
l

Events: Ability to configure and generate events directly from SiteScope, reuse existing alerts
as events, and manage and use SiteScope events in BSM's Operations Management and
Service Health. For details, see "Integrating SiteScope with HP Operations Manager Products"
in the HP Software Integrations site:
n

For HPOM for Windows:
http://support.openview.hp.com/sc/solutions/integrations.jsp?intid=39

n

For HPOM for UNIX:
http://support.openview.hp.com/sc/solutions/integrations.jsp?intid=628

l

Run-time Service Model (RTSM): SiteScope can discover and report topology on monitored
systems to BSM's RTSM. You can then manage and work with these discovered configuration
items (CIs) in views that provide a subset of the components in which your business functions.
For details, see Integrating SiteScope Data with BSM's Configuration Items in the Using
SiteScope Guide.

l

Service Health and Service Level Management: Health indicators assigned to SiteScope
monitor data provide a more detailed view of the health of a configuration item (CI) when
SiteScope reports metrics or events.
n

For details on managing indicators in the centralized Indicator Assignments repository in
SAM Administration, see Indicator Assignment Settings in the BSM Application
Administration Guide in the BSM Help.

n

For details on mapping metrics to indicators in SiteScope, see Assigning SiteScope Metrics
to Indicators in the Using SiteScope Guide.

l

System Availability Management Administration: Enables viewing and managing multiple
SiteScopes from within System Availability Management Administration. For details, see SAM
Administration Overview in the BSM Application Administration Guide in the BSM Help.

l

Reports: Ability to create and view reports of SiteScope monitor metrics in System Availability
Management and Operations Management.
n

For details on System Availability Management reports, see System Availability
Management Reports in the BSM User Guide in the BSM Help.

n

For details on Performance Graphing in Operations Management, see the BSM User Guide in
the BSM Help.

l

Service Health Analyzer (SHA): SHA analyzes metrics, calculates the dynamic baseline to
detect if each metric behaves normally or not, and automatically correlates related metrics to a
single meaningful event.

l

Downtime: Centralized management enables configuring downtime for your IT infrastructure
from one place in BSM. For details, see CI Downtime in the Using SiteScope Guide.
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Integration Prerequisites
The following are required to enable the integration:
SiteScope
Integration Prerequisites

Enables reporting

BSM

l

Metrics (using
the BSM
integration)

l

Topology data to
BSM

l

Metrics (using
the Operations
Manager
Integration)

l

Events to
BSM's
Operations
Management

HP
Operations
Manager
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System Availability Management license. For details, see
SAM Administration Overview in the BSM Application
Administration Guide in the BSM Help.

HP Operations agent must be installed on the SiteScope
server. For details, see the HP SiteScope Deployment Guide
PDF.
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Integration Options and Details
The metrics and event data collected by SiteScope monitors is used in BSM applications. Choose
the integration option according to the type of data to be collected, and the monitoring environment
that exists in your organization.
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BSM
Application
Service
Health

What to Use
Metrics (using the
BSM Integration)
Advantages:
l

Displays metrics
values in Service
Health tooltips.

l

You can create
customized
calculation rules.
For details, see
Business Rule
Repository
Overview in the
BSM Application
Administration
Guide in the BSM
Help.

SiteScope
Integration

Where to Get Details

BSM

How to Configure SiteScope to
Communicate with BSM in the Using
SiteScope Guide

HP Operations
Manager

The section on sending events in
"Integrating SiteScope with HP
Operations Manager Products" in the
HP Software Integrations site.

Recommended if
you do not have
Operations
Management.
Events
(metrics status
change)
Advantage:
Reduces the amount
of data SiteScope
sends to BSM.
Recommended
when managing
events in
Operations
Management.
Topology
(required)

BSM

l

For HPOM for Windows:
http://support.openview.hp.com/sc/
solutions/integrations.jsp?intid=39

l

For HPOM for UNIX:
http://support.openview.hp.com/sc/
solutions/integrations.jsp?intid=628

HP Integration Settings in the Using
SiteScope Guide
To report topology, make sure the
Report monitor and related CI
topology check box is selected in
BSM Integration Data and Topology
Settings for each monitor instance)
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BSM
Application

What to Use

Service Level Metrics (using the
Management BSM Integration)
(recommended)
Events
(optional)

Topology
(required)

SiteScope
Integration

Where to Get Details

BSM

How to Configure SiteScope to
Communicate with BSM in the Using
SiteScope Guide

HP Operations
Manager

The section on sending events in
"Integrating SiteScope with HP
Operations Manager Products" in the
HP Software Integrations site.

BSM

l

For HPOM for Windows:
http://support.openview.hp.com/sc/
solutions/integrations.jsp?intid=39

l

For HPOM for UNIX:
http://support.openview.hp.com/sc/
solutions/integrations.jsp?intid=628

HP Integration Settings in the Using
SiteScope Guide
To report topology, make sure the
Report monitor and related CI
topology check box is selected in
BSM Integration Data and Topology
Settings for each monitor instance)

System
Availability
Management
Reports

Metrics (using the
BSM Integration)
(recommended)

BSM

How to Configure SiteScope to
Communicate with BSM in the Using
SiteScope Guide

Topology
(required)

BSM

HP Integration Settings in the Using
SiteScope Guide
To report topology, make sure the
Report monitor and related CI
topology check box is selected in
BSM Integration Data and Topology
Settings for each monitor instance)
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BSM
Application
Service
Health
and
Service Level
Management/
System
Availability
Management
Reports

What to Use

SiteScope
Integration

Where to Get Details

Since SiteScope can report metrics to BSM (which are used in Service Level
Management and System Availability Management), and metrics and events
(which are used in Service Health), perform the following steps:
1. Decide on the reporting mode (events, metrics, or both) that you want to
use in Service Health. For details, see "Service Health" on page 11 above.
2. Select the data preference (events or metrics) for influencing Service
Health when both SiteScope events and metrics are reported to Service
Health, according to the specific use case. For details, see BSM Service
Health Preferences in the Using SiteScope Guide.
Note: If you want to use metric status change events, set BSM Service
Health affected by to Events in HP Integration Settings > BSM Service
Health Preferences when configuring event integration. For details, see
BSM Service Health Preferences in the Using SiteScope Guide. If Metrics
is selected, status change events reported by SiteScope do not have any
influence on CIs in Service Health.
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BSM
Application
Operations
Management

What to Use
Events (required)
Status change:
l

l

Use if you want
to manage raw
(low-level)
events.
These events
affect services.

Alerts:
l

Use if you want
to manage alerts
as events.

l

These events do
not affect
services. You
need to select the
event or metrics
reporting mode
for Service
Health. For
details, see
"Integrating
SiteScope with
BSM" on page 7
above.

Events generated
from health
indicators:
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l

Use if you create
customized
calculation rules
for metrics in
Service Health.

l

Use for earlier
versions of
SiteScope (10.x)
that report
metrics to BSM.

SiteScope
Integration
HP Operations
Manager

Where to Get Details
The section on sending events in
"Integrating SiteScope with HP
Operations Manager Products" in the
HP Software Integrations site.
l

For HPOM for Windows:
http://support.openview.hp.com/sc/
solutions/integrations.jsp?intid=39

l

For HPOM for UNIX:
http://support.openview.hp.com/sc/
solutions/integrations.jsp?intid=628

For details on events generated by
health indicators, see Business Rule
Repository in the BSM Application
Administration Guide in the BSM Help.
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BSM
Application

What to Use

SiteScope
Integration

Topology

BSM

Recommended for:

Performance
Graphing (in
Operations
Management)

l

Topology-based
event correlation
rules.

l

Drill downs from
events to views
and related CIs.

Metrics (using the
Operations Manager
Integration)
(required)

Topology
(required)

Where to Get Details
HP Integration Settings in the Using
SiteScope Guide
(To report topology, make sure the
Report monitor and related CI
topology check box is selected in
BSM Integration Data and Topology
Settings for each monitor instance)

HP Operations
Manager

BSM

The section on sending events in
"Integrating SiteScope with HP
Operations Manager Products" in the
HP Software Integrations site.
l

For HPOM for Windows:
http://support.openview.hp.com/sc/
solutions/integrations.jsp?intid=39

l

For HPOM for UNIX:
http://support.openview.hp.com/sc/
solutions/integrations.jsp?intid=628

HP Integration Settings in the Using
SiteScope Guide
(To report topology, make sure the
Report monitor and related CI
topology check box is selected in
BSM Integration Data and Topology
Settings for each monitor instance)

Service
Health
Analyzer

Metrics (using the
BSM Integration)
(required)

BSM

How to Configure SiteScope to
Communicate with BSM in the Using
SiteScope Guide

Topology
(required)

BSM

HP Integration Settings in the Using
SiteScope Guide
(To report topology, make sure the
Report monitor and related CI
topology check box is selected in
BSM Integration Data and Topology
Settings for each monitor instance)
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BSM
Application

What to Use

Service
Health
Analyzer

Since SiteScope can report metrics to BSM (which are used in Service Health
and Service Health Analyzer), and events (which are used in Service Health and
in Operations Management), perform the following:

and

l

If you want to use metric status change events, set BSM Service Health
affected by to Events in HP Integration Settings > BSM Service Health
Preferences when configuring event integration. For details, see BSM
Service Health Preferences in the Using SiteScope Guide. If Metrics is
selected, status change events reported by SiteScope do not have any
influence on CIs in Service Health or Operations Management.

l

If you only want events generated from SiteScope alerts, no additional
configuration is necessary (the previous step is not required).

Service
Health/
Operations
Management

SiteScope
Integration

Where to Get Details

For more information on the different event types generated by SiteScope, see
Events in "Operations Management" on page 14.

Troubleshooting
l

For topology reporting issues, see "BSM Topology Issues" on page 23.

l

For Operations Manager Event Integration issues, see "Operations Manager Event Integration
Issues" on page 26.

l

For BSM Metrics integration issues, see "BSM Metrics Integration Issues" on page 35.

l

For Operations Manager Metrics Integration issues, see "Operations Manager Metrics
Integration Issues" on page 38.

l

For CI downtime issues, see "BSM CI Downtime Issues" on page 42.
Note: Depending on the integration option, the suggested troubleshooting might be applicable
to specific HPOM or BSM applications only.
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Chapter 2
Integrating SiteScope with HPOM
Applications
The purpose of this section is to provide best practices for using and configuring the BSM
integration for sending events to HP Operations Manager (HPOM) and reporting metrics to HP
Performance Manager (BSM reporting component).
Note: For recommendations on integrating SiteScope with BSM or HPOM, see
"Recommendations for Integrating SiteScope with BSM or HPOM" on page 21.
This section includes:
l

"Integration Benefits" below

l

"Integration Prerequisites" on the next page

l

"Integration Options and Details" on page 19

l

"Troubleshooting" on page 20

Integration Benefits
l

SiteScope works together with HPOM to provide a powerful combination of agentless and
agent-based infrastructure management.

l

SiteScope can communicate with HPOM using the HP Operations agent, which is installed on
the SiteScope server. The agent enables SiteScope to integrate both events and metrics data.

l

SiteScope sends events by writing them to a log file which is monitored by the HP Operations
agent. The agent reads the data and converts it to common events, which it forwards to the
HPOM management server.

l

SiteScope stores metrics data in the HP Operations agent data storage, which is collected by
Performance Manager and used in Performance Manager graphs.

l

Centralized template management:
n Templates from multiple SiteScope instances can be centrally managed from HPOM.
n

Provides version control for templates (including roll-back functionality), and scheduled roll
out of template deployment based on group policy assignment.
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Integration Prerequisites
The following are required to enable the integration:
Prerequisites

Where to Get Details

The HP Operations agent must be installed on the
SiteScope server. If the agent is used only for
integrations (not for monitoring), ignore the request from
HPOM for the agent license.

HP SiteScope Deployment Guide
PDF

The agent can be installed during SiteScope installation,
or after SiteScope is installed using the SiteScope
Configuration Tool.
For the HPOM versions supported in this SiteScope
release, refer to the HP Operations Manager (HPOM)
Integration Support Matrix in the SiteScope release
notes.
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In SiteScope, select Help > What's
New?
If a patch is required to support a
feature in the integration, check for it
in the Patches page on the HP
Software Support site
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Integration Options and Details
The following SiteScope-HPOM integration options are available. Choose the most suitable for the
monitoring environment that exists in your organization.
Application

What to Use

Where to Get Details

HP
Operations
Manager

Events

The section on sending events in
"Integrating SiteScope with HP
Operations Manager Products" in the
HP Software Integrations site.

l

Status change: If you want to
manage raw (low-level) events.

l

Alerts: If you want to manage
alerts as events.

l

For HPOM for Windows:
http://support.openview.hp.com
/sc/solutions/integrations.jsp?
intid=39

l

For HPOM for UNIX:
http://support.openview.hp.com
/sc/solutions/integrations.jsp?
intid=628

Discovery Policies:
l

Node discovery policy
(recommended).
Advantage: Automatically maps
SiteScope events to nodes
created in HPOM for each node
monitored by SiteScope.
Note: For nodes monitored by
SiteScope only, you can ignore
the request from HPOM for a
Target Connector license.

l

Monitor discovery policy (not
required).
Advantage: Automatically maps
SiteScope events to SiteScope
monitors in HPOM Service
Navigation maps.

Template Management
(recommended)
l
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Advantages:
n Centralized management of
templates across multiple
SiteScope instances from
HPOM.
n

Version control for templates
(including roll-back
functionality).

n

Automatic deployment of
templates based on group
policy assignment.
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Application

What to Use

HP
Metrics (required)
Performance
Manager

Where to Get Details
The section on sending events in
"Integrating SiteScope with HP
Operations Manager Products" in the
HP Software Integrations site.
l

For HPOM for Windows:
http://support.openview.hp.com
/sc/solutions/integrations.jsp?
intid=39

l

For HPOM for UNIX:
http://support.openview.hp.com
/sc/solutions/integrations.jsp?
intid=628

Troubleshooting
l

For Operations Manager Event Integration issues, see "Operations Manager Event Integration
Issues" on page 26.

l

For Operations Manager Metrics Integration issues, see "Operations Manager Metrics
Integration Issues" on page 38.
Note: Depending on the integration option, the suggested troubleshooting might be applicable
to specific HPOM or BSM applications only.
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Chapter 3
Recommendations for Integrating
SiteScope with BSM or HPOM
The following are recommendations for integrating SiteScope with Business Service Management
(BSM) or Operations Manager (HPOM):
l

It is recommended to integrate SiteScope directly with BSM's Operations Management rather
than with HPOM.

l

If your deployment prevents you from integrating directly with Operations Management in BSM,
or you want to get event pre-processing in HPOM before forwarding SiteScope events to
Operations Management, you should integrate SiteScope with HPOM.
Note: Even if you are integrating SiteScope with HPOM, it is recommended to integrate
SiteScope directly with BSM and to configure SiteScope to report topology to BSM (a
System Availability Management license is required). Reporting topology provides
topology-based event correlation rules and drill down from events to views and related CIs.
You can report topology to BSM with or without metrics. If you do not want SiteScope
metrics to be used in System Availability Management, Service Level Management, and so
forth, report topology without metrics.
For details on integrating SiteScope with BSM, see How to Configure the Integration
Between SiteScope and BSM in the Using SiteScope Guide.

Troubleshooting
l

For topology reporting issues, see "BSM Topology Issues" on page 23.

l

For Operations Manager Event Integration issues, see "Operations Manager Event Integration
Issues" on page 26.

l

For BSM Metrics integration issues, see "BSM Metrics Integration Issues" on page 35.

l

For Operations Manager Metrics Integration issues, see "Operations Manager Metrics
Integration Issues" on page 38.

l

For CI downtime issues, see "BSM CI Downtime Issues" on page 42.
Note: Depending on the integration option, the suggested troubleshooting might be applicable
to specific HPOM or BSM applications only.
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Chapter 4
Troubleshooting SiteScope Integration
Issues
This section describes troubleshooting when integrating SiteScope with (BSM and HPOM
products.
l

"BSM Topology Issues" on the next page

l

"Operations Manager Event Integration Issues" on page 26

l

"BSM Metrics Integration Issues" on page 35

l

"Operations Manager Metrics Integration Issues" on page 38

l

"BSM CI Downtime Issues" on page 42
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BSM Topology Issues
This section describes troubleshooting and limitations when SiteScope is integrated with BSM and
enabled to report monitor and related CI topology to BSM.
This section includes:
l

"Opening Logs in SiteScope in Debug Mode" below

l

"Opening Logs in BSM in Debug Mode" on the next page

l

"No Topology Reported" on page 25

l

"RTSM Troubleshooting" on page 25

l

"Where to Configure the Port to Which Data Flow Reports" on page 25

Opening Logs in SiteScope in Debug Mode
The following log files in SiteScope contain information relating to the BSM integration.
l

SiteScope\logs\bac_integration\bac_integration.log

l

SiteScope\logs\bac_integration\discovery.log

l

SiteScope\logs\bac_integration\probeGW-taskResults.log

l

SiteScope\logs\bac_integration\topology_queue_consumer.log

Open the relevant log files in debug mode using the instructions listed below.
To open logs in SiteScope in debug mode:
1. In the <SiteScope root directory>\conf\core\Tools\log4j\PlainJava folder, open the bac_
integration.properties file and change the debug level to the appenders listed in
attachment1.txt (attached to this PDF). To view the attachment, select View > Navigation
Panels > Attachments, and select attachment1.txt.
2. Add the appenders listed in attachment2.txt (attached to this PDF) to the probeGWtaskResults.log file. To view the attachment, select View > Navigation Panels >
Attachments, and select attachment2.txt.
3. Add the appender listed in attachment3.txt (attached to this PDF) to the log topology_
queue_consumer.log file. To view the attachment, select View > Navigation Panels >
Attachments, and select attachment3.txt.
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Opening Logs in BSM in Debug Mode
The following log files in BSM contain information relating to the integration with SiteScope. Open
the relevant log files in debug mode using the instructions listed below.
l

<BSM root directory>\log\odb\odb\mam.autodiscovery.log

l

<BSM root directory>\log\odb\odb\cmdb.reconciliation.log

l

<BSM root directory>\log\odb\odb\cmdb.reconciliation.datain.ignored.log

l

<BSM root directory>\log\odb\odb\discoveryServlet.log

To open logs in BSM (on the Data Processing server machine in a distributed
environment) in debug mode:
Change RTSM debug level in BSM:
l

<BSM root directory>\odb\conf\log\reconciliation.properties

l

<BSM root directory>\odb\conf\log\mam.properties

l

<BSM root directory>\odb\conf\log\mam.web.properties
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No Topology Reported
1. Open all SiteScope and BSM logs in debug mode. For details, see "Opening Logs in SiteScope
in Debug Mode" on page 23 and "Opening Logs in BSM in Debug Mode" on the previous page.
2. Check if there are \bin files stuck in the
<SiteScope root directory>\cache\topologyresultsData\merged directory.
3. Check for errors in the logs in the following order:
n

bac_integration.log. Topology is not sent due to general errors or syntax problems in the
scripts.

n

discovery.log. Shows the complete picture of the topology reported from SiteScope to BSM
using Data Flow Management.

n

topology_queue_consumer.log. Shows the topology SiteScope is trying to send to the
Data Flow probe. (It does not mean that this is the topology that the probe client sends to the
server). This log reflects what SiteScope script intended to report to Data Flow Management.

n

probeGW-taskResults.log. Shows the topology Data Flow Management sends to the
RTSM server.

n

mam.autodiscovery.log. Shows the steps Data Flow Management probe is doing on the
topology reporting from SiteScope to Data Flow Management (bulk creation) and the
interaction with the RTSM server.

n

cmdb.reconciliation.log. If the issues are on the RTSM server-side, it is most likely a
reconciliation issue.

n

cmdb.reconciliation.datain.ignored.log. Shows topology that is ignored by the RTSM
server and not reported.

n

discoveryServlet.log. Shows data from the connection opened by SiteScope and the reply
sent to SiteScope. Check for exceptions in this log when there are issues with topology not
being sent to BSM. This log exists also on BAC 8.0.

4. It is recommended to open logs that are in XML format using an XML editor.

RTSM Troubleshooting
To get the properties of a CI reported to a Data Flow database with JMX:
1. Open http://<BSM_machine>:21212/jmx-console/ in a Web browser.
2. Click UCMDB:service= Model Services.
3. Invoke method: retrieveObjectProperties.

Where to Configure the Port to Which Data Flow Reports
The server settings are initialized in BSM in Admin > System Availability Management >
Topology Settings from the Topology receiver port or Topology receiver SSL port boxes.
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Operations Manager Event Integration Issues
This section describes troubleshooting when using the Operations Manager integration to send
SiteScope events directly to the HPOM management server or to Operations Management in BSM.
This section includes:
l

"Installation Problems" on the next page

l

"Integration Setup Problems" on page 29

l

"Problems Sending Events" on page 32

l

"Node Discovery and Monitor Discovery Troubleshooting" on page 34
Tip: When referring to the integration log file, you can open it from the SiteScope user interface
(Server Statistics > Log files > HPSiteScopeOperationsManagerIntegration.log).

Page 26 of 42

HP SiteScope (11.21)

Integration with BSM and HPOM Best Practices
Chapter 4: Troubleshooting SiteScope Integration Issues

Installation Problems
Symptom:
An error occurred while running the HP Operations agent installation in the SiteScope Configuration
Wizard during SiteScope installation.
Troubleshooting:
1. Open the agent installation log, opc_inst.log, in the c:\Windows\Temp, /var/tmp (Solaris) or
/tmp (Linux) folder, and delete opc_inst.lock.
2. Refer to the SiteScope documentation to make sure your operating system is supported for HP
Operations agent installation.
3. Run the SiteScope Configuration Tool, and install the HP Operations agent again (it is also
recommended to restart the server).
4. Run the SiteScope Configuration Tool, and uninstall the HP Operations agent and then install it
again (it is also recommended to restart the server).
5. Manually reinstall the HP Operations agent (it is also recommended to restart the server).
On Windows:
a. Uninstall the agent from C:\Program Files\HP\HP BTO Software\bin\OpC\install.
b. Run the command: cscript opc_inst.vbs -remove -force
c. From the Control Panel, uninstall the HP Operations Integration Adapter Policy Activation
package.
d. Reinstall the agent from:<SiteScope root directory>\install\components\oa\<Operating
System>
e. Run the command: cscript opc_inst.vbs
f. Install <SiteScope root directory>\install\components\oa_policy_signing_
tool
On UNIX:
a. Run the command:
/opt/HP/SiteScope/install/components/oa/<operating_system>/opc_
inst -remove
where <operating_system> is either solaris, linux, or linux64.
b. Run the command:
/opt/HP/SiteScope/install/components/oa/<operating_system>/opc_
inst
c. For Solaris:
Run the command: /opt/HP/SiteScope/install/components/oa_policy_
signing_tool/
solaris pkgadd -a HPOprIAPA.admin -d HPOprIAPA-09.00.<version>SunOS5.10-release.sparc
For Linux:
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Run the command: /opt/HP/SiteScope/install/components/oa_policy_
signing_tool/
rpm -i HPOprIAPA-09.00.<version>-Linux2.6-release.rpm
6. Put a new clean image on the system and install SiteScope and the HP Operations agent
again.
7. Contact your HPOM administrator for assistance.
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Integration Setup Problems
Symptom:
Any problem that occurs while trying to configure the HP Operations Manager Integration (between
connecting the agent to the HPOM/BSM server and sending a test message).
Troubleshooting:
1. In SiteScope, open the HP Operations Manager Integration dialog box panel (Preferences >
Integration Preferences > HP Operations Manager Integration).
2. In the HP Operations Manager Integration Main Settings pane, check the HP Operations
agent installation path.
a. Click the Resolve Path button.
b. Make sure the agent is installed on the path you see in this field.
o

If the agent is installed on a different path, update the path accordingly.

o

If you do not see the path is resolved (probably the agent is not installed properly), try
restarting the server machine. If it does not help, follow the troubleshooting in "Installation
Problems" on page 27.

c. Make sure your HPOM management server or BSM Gateway host name is typed correctly
in the host field.
3. Click the Analyze button.
a. If the command outputs are empty, there is a problem with the agent installation. Follow the
troubleshooting in "Installation Problems" on page 27.
b. Check that the bbcutil command output returns status=eServiceOK. If it does not, there
is a connectivity problem to your HPOM management server and you should contact your
HPOM administrator for assistance.
c. Check the opcagt -status command output. You should see a few processes running
(some can be in Aborted state—this is fine at this stage). If they are not running, manually
start the agent by running command line: opcagt -start, or restart your server machine.
4. Make sure your HPOM management server is up and running.
5. If you are working with BSM, check your Gateway and Data Processing Server. Run
command line ovc -status. Make sure all processes are running (in particular, the
"Certificate Broker") if they do not start with ovc -start.
6. If you are working with a distributed BSM environment (in BSM 9.00 or later), follow the
procedures for initiating trust between your Gateway and Data Processing Server, and
forwarding the certificate request from the Gateway to the Data Processing Server.
For details, see the section on sending events to BSM or HPOM in "Integrating SiteScope with
HP Operations Manager Products" in the HP Software Integrations site:
n

For HP Operations Manager for Windows:
http://support.openview.hp.com/sc/solutions/integrations.jsp?intid=39.

n

For HP Operations Manager for UNIX:
http://support.openview.hp.com/sc/solutions/integrations.jsp?intid=628.
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7. Click the Connect button, and make sure the command output returns: opcactivate
Info: Successfully activated OVO agent.
If it does not work, contact your HPOM administrator for assistance.
Note: If there is a large time difference (more than 24 hours) between the certificate server
and the HP Operations agent, you might encounter the following error when running agent
commands such as ovc – status, ovc –start, or opcagt -status:
(ctrl-21) Communication error when executing 'Status' method.
(sec.core-113) SSL certificate verification error (The presented
peer certificate is not yet valid.)
This problem occurs because certificates are only valid in the specified time period, and
usually solves itself (after a day) when the certificate becomes valid. The time is specified
in Coordinated Universal Time (UTC), independent from time zones, and certificates are
issued to be valid from 24 hours in the past.
8. Accept the certificate request.
n

When connecting to a BSM server, follow the step for accepting the agent connection
request in "Integrating SiteScope with HP Operations Manager Products" in the HP Software
Integrations site (see links in step 6 above).

n

When connecting to an HPOM management server, consult your HPOM administrator. If you
do not see the certificate request, contact your HPOM administrator.

9. Click the Analyze button.
a. Make sure the ovcert -check is ok, and it ends with "Check Succeeded".
b. Make sure ovcert -list lists some certificates.
c. If there are problems with the command outputs:
o

Contact your HPOM administrator, or

o

Start the integration process troubleshooting from the connect phase, or even reinstall the
agent.

10. Click the Install Policies button.
a. If you get an error here or this process is stuck with "please wait" and:
o

You recently reinstalled the agent and did not restart yet, restart your server.

o

Otherwise, there is a problem with the agent (and the additional policy activation tool
package) installation. Reinstall on a clean image.

b. Click the Analyze button, or check the output of the Install Policies for the list of policies.
Make sure you see the following list with all enabled:
o

HP_SiteScope_to_Operations_Manager_Integration_by_Log_File

o

HP_SiteScope_to_Operations_Manager_Integration

o

SiteScope_Hosts_Discovery

11. In the Test Message box, type a message and click Send test message.
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a. Check your HPOM Event Console or Operations Management Event Browser.
b. If you do not see the message in the Event Console/Browser:
o

Run command line: opcmsg a=a o=o msg_t=xxx

o

If the command is not available, something went wrong with the process so far (either the
certificate or the policies does not work). Try to install the policies again, and if the same
problem occurs contact HP Software Support.

o

If the command is executed but you still do not see the message in the Event Console,
contact your HPOM administrator for support.
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Problems Sending Events
Symptom 1:
Sending a test event from the HP Operations Manager Integration dialog box does not reach the
HPOM Event Console/Operations Management Event Browser.
Troubleshooting:
1. In the HP Operations Manager Integration dialog box, enter a test message in the Test
message box, and click Send test message. If the test message is not displayed in the Event
Console, follow all the steps in "Integration Setup Problems" on page 29, and then try again.
2. Click the Analyze button, and make sure all commands are successful (in particular, see the
list of policies installed). For details, see "Operations Manager Event Integration Issues" on
page 26.
3. Click the Send Test Event button.
4. In the <SiteScope root directory>\logs directory, check the events log file,
HPSiteScopeOperationsManagerIntegration.log. Verify the event entry in the log file. If you
do not see it, contact HP Software Support.
5. If you still do not see the event in the HPOM Event Console/Operations Management Event
Browser, check you are viewing the correct node in HPOM, or are not filtering out anything in
the Operations Management Event Browser. If you still do not see the event, contact HP
Software Support.
6. Open the <SiteScope root directory>\tools\OMIntegration\Policies\F516CEC3-3AD44627-9CFD-BB155B894349_data file, and check that the path specified for
HPSiteScopeOperationsManagerIntegration.log is correct (it might use an environment
variable). If you make any changes here, you must install the policies again.
Symptom 2:
The metric status change or alert event is not displayed in the HPOM Event Console/Operations
Management Event Browser.
Troubleshooting:
1. Check if the test event is displayed in the Event Console/Browser. If it is not displayed, follow
the guidelines for Symptom 1 in "Problems Sending Events" above above.
2. Check that event integration is enabled in the monitor or alert configuration settings. Change
the monitor metric status, or trigger an alert. In the <SiteScope root directory>\logs
directory, check the events log file, HPSiteScopeOperationsManagerIntegration.log.
3. If you do not see the event entry in the log file, check you enabled event integration correctly in
the monitor or alert you are running (for details, see "Integrating SiteScope with HP Operations
Manager Products" in the HP Software Integrations site (see links in step 6 above)). If it is still
not in the log file, contact HP Software Support.
4. If you see the event entry in the log file, but not in the Event Console/Browser:
a. Check that no filter is set in the Event Browser.
b. If it is a newly-created monitor, and you are filtering the related CI in Operations
Management, it is possible that the CI topology is not reported yet. Try again in a few
minutes.
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c. In HPOM legacy, make sure the event target node exists on your console.
d. Contact HP Software Support.
Symptom 3:
You see the metric or alert event in the Operations Management Event Browser, but it has no
related CI or HI, or Indicator state or severity.
Troubleshooting:
1. Check the event attribute values in the HPSiteScopeOperationsManagerIntegration.log file
located in the <SiteScope root directory>\logs directory. Look for the HI (ETI) and CI hint.
They should look like this: CPULoad:High:80 and SiteScope:3:123456 respectively.
a. To know the attribute order in this tab separated values line, you can send a test event
before this event and compare the lines. The test event writes the name of each attribute in
its order.
b. If the CI Hint or HI hint are unknown, empty, or look different than the example, there is a
problem with the SiteScope configuration.
o

Check that the SiteScope is registered to BSM.

o

Check that the monitor thresholds have indicator states assigned to them, or that your
alert has some ETI and ETI state set.

o

Check the preference setting for reporting SiteScope data in the monitor configuration is
set to Events (in HP Integration Settings > BSM Service Health Preferences).

2. If everything looks fine in the log file in SiteScope, open the event in the Operations
Management Event Browser.
a. In the General tab, check the related CI attribute. If you do not see the related CI, select
the Resolver tab and check the Status field.
o

Check if there is information about the CI resolution failure.

o

Check that the monitor topology is available in the BSM (you can check this in the
System Hardware or System Monitors views).
Note: If this is a newly-created monitor, it will take few minutes for the topology to
arrive and the event to be assigned with a related CI.

b. In the General tab, if you see the related CI but Event Type Indicator is empty:
o

Select the Resolver tab and check the ETI Hint attribute value sent by SiteScope. If it is
empty or unknown, check your SiteScope configuration.

o

If the value exists but does not show up in Event Type Indicator in the General tab,
there was a problem when applying the indicator to the CI. Check Service Health or
Operations Management for support.
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Node Discovery and Monitor Discovery Troubleshooting
Node Discovery:
l

If you are using HP Operations Manager for Windows 8.1x, patch OMW_00071 is required to
support the Node discovery feature in SiteScope-HPOM event integration.

l

If you are using HP Operations Manager for Windows 9, patch OMW_00097/98 or later (32bit/64-bit) is required to support the Node discovery feature without overriding SiteScope node
properties.

l

If you are using HP Operations Manager for Solaris/HP-UX/Linux 9.10, patch 9.10.200 is
required to support the Node discovery feature in SiteScope-HPOM event integration.

Problems with Node discovery:
1. Click the Analyze button in the HP Operations Manager Integration dialog box. Make sure you
see the SiteScope_Hosts_Discovery policy installed and enabled.
2. Check that your event configuration is set. Send a test event and make sure you see it in the
HPOM Event Console on the SiteScope node.
New nodes are reported within 5 minutes from the time they started to being monitored by
SiteScope monitors.
The discovery policy runs SiteScope scripts that generate XML consumed by the policy. Each
run is logged in the following log: %OvDataDir%\log\System.txt (for Linux <SiteScope
Server>/var/opt/OV/log).
3. You can invoke the process manually, by running the following commands:
ovagtrep -run "SiteScope_Hosts_Discovery"ovagtrep -publish
Monitor Discovery:
To enable HPOM Service Navigator to view SiteScope groups and monitors in HPOM service
maps, follow the instructions for configuring monitor discovery in "Integrating SiteScope with HP
Operations Manager Products" in the HP Software Integrations site. See links in step 6 above.
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BSM Metrics Integration Issues
This section describes troubleshooting when working with the BSM metrics integration if CI
statuses are not displayed in Service Health.
This section includes:
l

"Check HI/KPI assignment" below

l

"Check that SiteScope data is not ignored by BSM" below

l

"Check CI resolution" on the next page

l

"If there are no HIs on the relevant CI (in case the problem is with the monitored CI and not the
monitor/measurement)" on the next page

l

"If there are no KPIs on the relevant CI (in case the problem is with the monitored CI and not the
monitor/measurement)" on the next page

l

"If there are no HIs/KPIs and everything seemed to work in the previous two steps" on the next
page

1.

Check HI/KPI assignment
If CI statuses are not displayed in Service Health, check if HIs and KPIs are assigned to the
relevant CI:
a. In BSM, select Admin > Service Health > CI indicators, expand the Monitors folder,
and select one of the following views: System Monitors, System Hardware Monitoring, or
System Software Monitoring.
b. In the view you have selected, check if there are HIs and KPIs assigned to the relevant CI,
as follows:

2.

o

System Monitors view: SiteScope Monitor or SiteScope Measurement CI

o

System Hardware Monitoring view: Node or Computer CI

o

System Software Monitoring view: Running Software CI

Check that SiteScope data is not ignored by BSM
If HIs and KPIs are assigned to the relevant CI, check if SiteScope sends data and that the
data is not ignored by BSM.
a. Run the relevant monitor in SiteScope.
b. On the BSM machine, open the wdeIgnoredSamples.log located in <BSM
root directory>\log\wde folder. If this log includes samples of the monitor you have just
run, or you see many ignored samples, this means SiteScope is sending the wrong data.
c. If you do not see the relevant SiteScope sample, look for it in the
wdePublishedSamples.log and check that Eti_id and ci_hint are not null.
d. If you cannot find the SiteScope sample in the wde logs in BSM, check in SiteScope if the
sample was generated. Open the bac_integration.properties file located in <SiteScope
root directory>\conf\core\Tools\log4j\PlainJava and add the text found in

Page 35 of 42

HP SiteScope (11.21)

Integration with BSM and HPOM Best Practices
Chapter 4: Troubleshooting SiteScope Integration Issues

attachment4.txt (attached to this PDF) to the end of the file. To view the attachment,
select View > Navigation Panels > Attachments, and select attachment4.txt.
e. Run the monitor, and check the samples.log file in the <SiteScope
root directory>\logs\bac_integration directory.
3.

Check CI resolution
If HIs and KPIs are assigned to the relevant CI, and samples are not ignored by the wde logs in
BSM, check CI resolution (in case the problem is with the monitored CI and not the monitor or
measurement).
a. Run the relevant monitor in SiteScope.
b. On the BSM machine, open the cir_enrichment.log file located in the <BSM
root directory>\log\wde folder, and check if there are badHint or CI not found
messages.
Note: To change the log file to debug mode, open the cir_enrichment_
service.properties file located in the <BSM
root directory>\conf\core\Tools\log4j\wde folder and change loglevel to
loglevel=DEBUG.

4.

If there are no HIs on the relevant CI (in case the problem is
with the monitored CI and not the monitor/measurement)
If the relevant CI does not have any HIs, in SiteScope, check the indicator mappings in the
monitor user interface (HP Integration Settings > Indicator Settings).

5.

n

If the mapping seems correct, go to the correct SiteScope Monitor CI or SiteScope
Measurement CI in RTSM in BSM, and check that you can see the HI ID in the health_
indicator_list attribute.

n

If you can see it, check that you can see the monitored CI connected to this SiteScope
Monitor or Measurement CI with a monitored_by link.

n

If it seems fine, check that HPOM (HPOpr) content packs are deployed (in Admin >
Platform > Content Packs), and that you can see the indicators you expect to get in it (in
most cases, you will find it in the HPOprInf package).

If there are no KPIs on the relevant CI (in case the problem is
with the monitored CI and not the monitor/measurement)
If the relevant CI does not have any KPIs, check if the HPOM content pack has KPI
assignments.
a. In BSM, select Admin > Service Health > Assignments > KPI Assignments.
b. In the CI Types tree, drill down to the relevant CI (for example, Infrastructure Element >
Node > Computer), and check if the CIT has a KPI assignment defined. KPI assignments
appear in the right pane.

6.

If there are no HIs/KPIs and everything seemed to work in the
previous two steps
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Try to resynchronize the HI and KPI assignments on the problematic CIs, based on their CI
types.
a. In BSM, select Admin > Service Health > Assignments > Health Indicator
Assignments.
b. Select the problematic CI type (for example, computer), and select the assignment you
HI want to run.
c. Click the Synchronize CI Type button.
d. When this is done, perform the same action on the KPI assignment using the KPI
Assignments tab.
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Operations Manager Metrics Integration
Issues
This section describes troubleshooting when using the HP Operations Manager integration to make
SiteScope metrics data available to HP Performance Manager or to Performance Graphing in
Operations Management.
This section includes:
l

"SiteScope and HP Operations Agent Configuration" on the next page

l

"Health Monitors Errors" on page 40

l

"HP Performance Manager Configuration" on page 40

l

"CI Resolution does not work ("BadHint error" in the cir_enrichment.log)" on page 41

l

"System runs out of ports when reporting data to the HP Operations agent" on page 41
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SiteScope and HP Operations Agent Configuration
Check the HP Operations Agent Configuration
1. Check the status of the HP Operations agent installed on the SiteScope server status by
running the following command: opcagt -status
The expected output is:

If opcacta or opcmsgi are not running, try to restart the agent by running:
opcagt -stop
opcagt -start
2. Select Preferences > Integration Preferences, and select an existing or create a new
HP Operations Manager Integration. Verify that the Enable sending events check box is
selected.
3. In the HP Integration Settings for the monitor, Verify that the Report metrics to HP
Operations agent check box is selected.
4. Run the monitor, and wait for about a minute.
5. Run the following command to check if the agent data store contains the data:
set CODAMAGIC=0X05201993
ovcodautil -obj -ds AGENTLESS
You should receive object names from AGENTLESS data source (similar to the following):

6. To dump the summarized last record for AGENTLESS data source, run the following
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command:
ovcodautil -dumpds AGENTLESS
Check the Relevant SiteScope Logs
Check the following logs that are available from the <SiteScope root directory>\logs directory:
l

error.log

l

RunMonitor.log

l

om_metric_integration.log

l

data_integration.log

Health Monitors Errors
In the SiteScope monitor tree, expand Health and click Log Event Checker.
l

If the Failed to report data to HP OM Agent counter is in error, SiteScope failed to connect or
report data to the HP Operations agent using Java API. For more information, see the oa_
metric_integration.log file in the <SiteScope root directory>\logs directory.

l

If the Generic Data Integration queue exceeded allowed size counter is in error, the queue of
metrics waiting to be sent is oversized and some metrics were dropped to maintain SiteScope
stability. For more information, data_integration.log file in the <SiteScope root
directory>\logs directory.

HP Performance Manager Configuration
1. On the Performance Manager server, open the OVPMconfig.ini file in the
%ovdatadir%\shared\server\conf\perf directory.
2. Update the SiteScope server details as follows:
n

[SITESCOPE]

n

SERVER = servername

n

NODEGROUP = Agentless

3. Restart the HP Openview Tomcat(B) service.
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CI Resolution does not work ("BadHint error" in the cir_
enrichment.log)
1. Go to Admin > Platform > Infrastructure Setting.
2. In the Application dropdown, select End User/System Availability Management.
3. In the SiteScope CI Resolver Settings, check for TQL Queries value.
The default value is CIs Monitored by SiteScope.
4. Go to Admin > RTSM Administration and check for CIs Monitored by SiteScope query
results. If you do not get the requested CI in the query results, CI resolution will not find it as
well.
Possible problem: CI has missing attributes orthe SiteScope monitor CI is not connected to
any monitored CI.

System runs out of ports when reporting data to the HP
Operations agent
Problem: The system runs out of ports when reporting metrics data to the HP Operations Agent in
a loaded environment.
l

In SiteScope Health, an error is displayed in the Log Event Checker monitor for the .*Failed to
report data to HP OM Agent.* counter.

l

In the oa_metric_integration.log, the following error is displayed: "ERROR - Failed to report
data to /Hewlett-Packard/OpenView/Coda/ IO error while gettingSingle Object;Address already
in use: connect".

Possible solution: Increase the upper range of ephemeral ports and reduce the client TCP/IP
socket connection timeout value in Windows. For details, see http://msdn.microsoft.com/enus/library/aa560610%28v=bts.20%29.aspx.
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BSM CI Downtime Issues
This section describes troubleshooting CI downtime issues when SiteScope is integrated with
BSM.
This section includes:
l

"Troubleshooting CI Downtime (BSM-side)" below

l

"Troubleshooting CI Downtime (SiteScope-side)" below

Troubleshooting CI Downtime (BSM-side)
If the SiteScope monitor does not enter downtime (it is still running, or is sending alerts while it
should not be according to the downtime configuration), perform the following checks on SiteScope
and BSM:
1. Check SiteScope reported topology to BSM. In BSM, select Admin > RTSM Administration
and check the node and monitor CIs.
2. Logs:
n

Open <BSM root directory>\conf\core\Tools\log4j\PlainJava\topaz.properties and
change the debug level to the following appender:
log4j.category.com.mercury.topaz.sitescopetmc=DEBUG, aims.appender

n

Open the aims.ejb.log file located in <BSM root directory>\log\EJBContainer and search
for "downtime" string. Check whether your downtime was created, which CIs were affected
by it, and when a downtime request was made from SiteScope.

Troubleshooting CI Downtime (SiteScope-side)
If the SiteScope monitor is still running after configuring downtime on a specific node using the stop
monitoring option, perform the following checks on SiteScope:
1. In Preferences > Infrastructure Preferences > General Settings, check the Enable
downtime mechanism setting is enabled.
2. Check the following logs:
n

<SiteScope root directory>\logs\audit.log

n

<SiteScope root directory>\logs\downtime.log
To open these logs in debug mode:

a. In the <SiteScope root directory>\conf\core\Tools\log4j\PlainJava folder, open the
log4j.properties file.
b. Change the debug level to the appenders listed in attachment5.txt (attached to this PDF).
To view the attachment, select View > Navigation Panels > Attachments, and select
attachment5.txt.
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