Unusually slow GUI response and backups suddenly taking a long time to finish in environment that was using encrypted control communications (ECC).

  • KM00205688
  • 09-Oct-2012
  • 09-Oct-2012

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Summary

During normal day-to-day operation sudden drop of performance is noticed with GUI and CLI response, along with backup performance (especially related to integrations).

Error

Problem manifests itself in a number of different ways including:

> GUI timeouts

> Client connectivity timeouts

> Inactivity timeouts

> BMA crashes

> Slow response of IDB-related commands such as 'omnidbutil -info', as well as IDB queries using 'omnidb'

 

Cause

A number of performance related settings were tried in attempt to resolve the problem, such as setting OMNIRC variables related to performance, as well disabling Auto Tuning Level in Windows.  However, these changes had no affect. 

Finally, problem was isolated to left-over client entries in the ECC config file on the Cell Manager ([DP_Data]\config\server\config).  This happened when three clients were removed from the Data Protector cell, but the related ECC  (Encrypted Control Communication) configuration file still had entries for these clients.  This occurred even though the DP Clients GUI was properly used to delete the clients, and was resulting in 30 second delay PER CLIENT.  In this case there were three deleted clients, so delay was 90 seconds for every operation (30 seconds x 3 = 90 second delay),  This delay was occurring because  Data Protector was still attempting to access clients that were still configured for ECC but no longer there.    

Fix

Workaround is to manually delete left-over client entries from the [DP_Data]\config\server\config file on the Cell Manager.

Hotfix is available and documented here:  "QCCR2A39458 GUI does not delete the client from config file when the client is deleted from the cell."