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Documentation Updates
The title page of this document contains the following identifying information:

l Software Version number, which indicates the software version.

l Document Release Date, which changes each time the document is updated.

l Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using themost recent edition of a document, go
to:

http://h20230.www2.hp.com/selfsolve/manuals

This site requires that you register for an HP Passport and sign in. To register for an HP Passport
ID, go to:

http://h20229.www2.hp.com/passport-registration.html

Or click theNew users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product support
service. Contact your HP sales representative for details.
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Support
Visit the HP Software Support Online web site at:

http://www.hp.com/go/hpsoftwaresupport

This web site provides contact information and details about the products, services, and support
that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and
efficient way to access interactive technical support tools needed tomanage your business. As a
valued support customer, you can benefit by using the support web site to:

l Search for knowledge documents of interest

l Submit and track support cases and enhancement requests

l Download software patches

l Manage support contracts

l Look up HP support contacts

l Review information about available services

l Enter into discussions with other software customers

l Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also
require a support contract. To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html

To findmore information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp
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Chapter 1

Introduction
HP Reporter (Reporter) is a web-based tool, which helps you to generate performance and
availability reports of your distributed IT environment. It generates reports using the data collected
by HP Operations agent, Smart plug-ins, and Sitescope (throughOperation agent integration)
installed on the systems. This data is based on the pre-defined and user specified lists of metrics.
Reporter generates reports from all systems, system groups, and individual systems in the
network. Reporter displays the generated reports in different template-driven output formats, such
as graphs, tables, forms, and gauges.

Installation Overview
WhenReporter is first installed, it begins operation automatically using the pre-configured settings
which comewith the product. These initial settings are sufficient for Reporter to discover systems
in the local domain, running HP Operations agent software. Reporter can also discover systems in
a configured Operations database. After installation, Reporter completes a number of steps as
illustrated in the following sections. After Reporter runs through its discovery, it gathers data based
on the pre-defined and user-specified lists of metrics and uses this data to generate reports.

Note: In order to generate additional reports for other HP Software products, youmust add the
Report package for the HP Software product you are using. Please refer Reporter Online Help
"Working with Reports" topics for instructions.
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Post Installation Process

As shown in the preceding illustration, after installation Reporter begins a cycle of its actions
immediately. This immediate start, which is different from the schedule that Reporter follows by
default, occurs so that you can see reports right away without having to wait until the next day.
After the above actions are completed, Reporter follows the default schedule, which begins at
12:30 AM every night unless you change those default settings. For information on Reporter default
schedule, see theHP Reporter Concepts section of the Reporter Concepts Guide.

Caution: Do not run two copies of Reporter with the sameReporter database, as unexpected
results occur whenmore than one copy of Reporter attempts to write data to the
Reporter database.

No changes are required to the Operations agent in order to support Reporter. However, for HP
Operations Manager (HPOM) for HP-UX , Sun Solaris, and Linux, see the appropriate sections in
this document to configure a connection to the HPOM database.

In addition, to generate reports from other Reporter-enabled products, youmust select the report
package from File → Configure → Report Packagesmenu.

Note: Reporter 4.0 uses Microsoft SQL Server 2008 R2 Express as its default database. You
can also use a different database for Reporter. For more information, see Installing and
ConfiguringMicrosoft SQL Server 2008 R2 for Reporter and Installing and Configuring
Oracle 11g R2 for Reporter sections.
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Reporter Workflow
After you install Reporter, it goes through the discovery process and starts collecting data based on
themetric lists. Metric lists for Operations agent can bemodified. Metric lists for service and event
data gathered from Operations Manager server cannot bemodified. The default metric lists provided
for the respective agents are grouped as follows:

For HP Operations agent systems:

l Global

l Application

l Transaction

l Sysdowntime

l VM_CONFIG

l VM_GLOBAL

l VM_LOGICAL

For HP Operations Manager UNIX Server:

l ITOMessages

l ITOOperator

Reporter stores the collected data in a database from which reports are generated. Reporter also
performs routine databasemaintenance and builds a web page that can display all reports
generated by Reporter. This web page is viewable from your browser.

Reporter performs the following actions to discover new systems and to continue to track systems
already in the database.

l Search systems selected for inclusion in the Discovery Area (or initially, by default, systems in
the local domain) and add entries into the schedule to gather data when it find new sources of
data added.

l Gathers a default set of metric data based on themetrics available throughOperations agents
and stores this data in the Reporter database.

l Updates the database with any new information.

l Creates a series of pre-defined reports based on the data available in the Reporter database.

l Creates a web page that links into all the HTML reports created by Reporter.

From the data it collects, Reporter automatically generates a number of different reports, providing
you with critical information about the systems in your computing environment.

After you start using Reporter, youmight want to customize Reporter by organizing your systems
into different system groups (see theCustomizing Reporter section inReporter Concepts Guide).
With these changes you can assign reports to these new system groups and generate sets of
reports that are immediately organized in a way that is relevant to your organization functions. You
can also create custom reports (see the Generated and Custom Reports section in theReporter
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Concepts Guide), for which you need to purchase SAP Crystal Reports® and define new reports
with data that you select (by creatingmetric lists).
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Chapter 2

Installing HP Reporter 4.00
This chapter provides information about the hardware and software requirements and the steps to
install HP Reporter.

Hardware Prerequisites
The following table lists theminimum hardware requirements.

Components Minimum Required

Processor Type 2GHz or higher with 2–4GB memory

Free Disk Space 10GB

Note: More spacemay be required during product installation, depending on the installation
method. For more information on scalability and disk space requirements, see the Scalability
section in theHP Reporter Concepts Guide.

Software Prerequisites
The following table lists theminimum software requirements.

Components Minimum Required

Operating System Windows 2008 R2 SP1 -Enterprise/Data center Editions
(64–bit).

Software l Microsoft .NET Framework 3.5.1

l IIS 7.0 (Optional)

Optional Software Integrations l HP Operations Manager forWindows

l HP Operations Manager for UNIX on an HP-UX, Linux
and Sun Solaris systems.

Databases l Oracle 11g R2 for HP-UX, Sun Solaris, and Linux

l Microsoft SQL server 2008 R2

Installing Reporter
To install Reporter, follow these steps:
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1. At theWindows system, insert the Reporter DVD.

2. Select Print and Review the Two Documents:
n Read before installing

n Release Notes

3. Click install reporter.

4. Follow the instructions appearing on the Installer wizard and complete the installation.

Note: Reporter 4.00 is a 64-bit application and does not support upgrade from any previous
versions. However, you canmigrate data from the Reporter 3.8 and 3.9 versions to
Reporter 4.00. For more information onmigrating data, seeMigrating to Reporter 4.0
section

Reporter Licensing
The Reporter DVD includes an Instant-on license, which is valid for 60 days. Within this time
period, youmust get a valid license to ensure continued and uninterrupted use of Reporter.

Types of Licenses
The following three types of licenses available for Reporter:

l Instant-on - The Instant-on license is valid for 60 days. This is the default license type available
with Reporter installation.

l Evaluation - You have the option to extend your license for an additional period of 30 days. For
instructions to extend license, seeGetting Reporter 4.00 License from theWeb.

l Perpetual - There is no expiration date for Reporter with perpetual license.

Getting Reporter 4.00 License from the Web
Prerequisite: The License Entitlement Certificate, included with the purchased Reporter (the
License Entitlement Certificate contains the uniqueProduct Order Number).

To get Reporter 4.00 license from the web, refer the Software License Activation Quick Start Guide
available on the HP Licensing portal home page at www.hp.com/software/licensing. You can use
your HP Passport credentials to log on to the HP Licensing portal.

Installing Reporter License
To install a license for Reporter, follow these steps:

1. From the Reporter console, click File→ Configure→ License. The Configure License
window opens.

2. Click to select the license file. The Select File window opens.

3. Select the license file and click Open.
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4. Click Apply. The Configure License window displays one of the followingmessages:

n Invalid Product License - The selected license file does not grant access to Reporter.

n Perpetual License - There is no expiration date for the selected license file.

n Instant-on License - Reporter is currently running on a temporary trial license, which is valid
for 60 days.

n Evaluation License - Reporter is currently running on a 30 days extended temporary trial
license.

5. Click OK, to use the selected license file.

Using Reporter on Microsoft Cluster Server
(MSCS)

This section describes how to install and configure Reporter onMicrosoft Cluster Server.

Installing and Configuring Reporter on MSCS
Prerequisites for Installing Reporter in MSCS

The following are the prerequisites for installing Reporter in MSCS:

l Windows Server 2008 R2 Enterprise Edition or Datacenter Edition.

l Install and configureMicrosoft cluster server 2008, before installing Reporter 4.00. For installing
and configuringMSCS, seeMicrosoft web site http://support.microsoft.com/kb/980459.

l Microsoft Cluster SQL Server 2008 R2 Enterprise Editionmust be installed on cluster nodes.
For InstallingMicrosoft SQL Server 2008 R2, see InstallingMicrosoft SQL Server 2008 R2
section.

l Configure the Reporter ODBC DSN. A services and applicationmust be created for Reporter
application containing a physical disk, IP, and network name.

l Youmust have administrative permissions to access or modify the cluster.

Installing Microsoft SQL Server 2008 R2
For installing and administeringMicrosoft SQL Server 2008 R2, seeMicrosoft web site
http://msdn.microsoft.com/en-us/library/ms179530(v=sql.105)

Creating the Reporter Database
For creating Reporter database onMSCS, follow the steps mentioned in ConfiguringMicrosoft SQL
Server 2008 R2 for Reporter section.

Note: The Data files and Transaction logmust be stored to the shared disk for high availability.
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Establishing an ODBC Connection to the Database
Follow the steps mentioned in Establish the ODBC Connection of the Installing and Configuring
Microsoft SQL Server 2008 R2 for Reporter section to create anODBC connection to the Reporter
database.

Note: Create and Configure Reporter ODBC DSN on each node you install Reporter.

Creating a Generic Service Resource using High
Availability Wizard

To create a generic service resource using high availability wizard, follow these steps:

1. From theStartmenu, select Programs → Administrative Tools →Failover Cluster
Manager. Connect to the Cluster.

2. Right click Services and Applications, and click Configure a Service orApplication. The
High Availability Wizard opens.

3. On Select Service or Application page, select Other Server and Click Next. The Client
Access Point page opens.
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4. Type the network name and IP address and click Next. The Select Storage page opens.

Note: Always select a network name and a static IP address suitable for your network
configuration.
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5. Select the storage disk for Reporter group and click Next. The Select Resources Type page
opens.

6. Skip this step and click Next. The Confirmation page opens.
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7. Verify that the information displayed is correct, you can use thePrevious button tomake any
modifications is required in the previous pages of the wizard. Click Next.
TheWizard completes the creation of a generic service resource, and the Summary page
opens.

8. Click View Report to view the detailed report of actions taken to create the generic service
resource. You can also view the report from the following location
%SystemRoot%\Cluster\Reports.

9. Click Finish to close the wizard. You can view the newly created item underServices and
Application.

Installing Reporter on an Active Node
You can skip the creation of a resource group containing the Virtual server, IP address, and the
shared disk cluster resources if these have already been configured inMSCS. For more
information, see Creating aGeneric Service Resource using High Availability Wizard section.

Caution: Before installing Reporter, make sure that the resource group containing Physical
Disk, IP and Network Name resource is running on the current node.

1. Insert theHP Reporter DVD into the DVD drive on the node that has active ownership of the
virtual server.

2. Select Install Reporter and follow the instructions to install Reporter. The HP Reporter Install
Wizard window opens.
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Note: The Installation Selection dialog box is not displayed if the current user does not
have administrative rights, or if the system is not clustered.

3. Select Cluster for the Cluster installation of Reporter.
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4. Click Next to display the dialog box showing the cluster details.

5. Enter the existing Virtual Server name and IP address. For more information on creating a
virtual server name and IP address, see Creating aGeneric Service Resource using High
Availability Wizard section.
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6. Select a valid shared folder andmake sure to select a local drive for the program files and a
shared drive for the shared data files and click Next.
For example, if S is your shared drive youmust select:
Install Reporter to: C:\Program Files\HP\HP BTOSoftware
Install Reporter local Data to: C:\ProgramData\HP\HP BTOSoftware\Data
Install Reporter Shared Data to: S:\MyShare\

Caution:Make sure you select the same Program files, Shared Data and Data directory
when you install Reporter on other nodes in the cluster.
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7. Select theManual- Start Reporter service manually check box.

8. Click Next and follow the instructions in the wizard to complete the installation of Reporter.

Installing Reporter on Additional Node
1. UseMicrosoft Cluster Administrator Tool and select Reporter Service. Right-click and select

Take this service or application Offline option tomove the resource status to offline.

2. Do not move the Reporter Group (containing the Reporter Service) to the subsequent node.
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Installing Reporter on Current Node
1. To install Reporter on the current node, follow the instructions for installing Reporter on an

active node from Installing Reporter on an Active Node section.

2. Repeat steps 1 and 2 to install Reporter on the remaining nodes within the cluster.

Uninstalling Reporter
1. Last installed node should be the first node during uninstallation. Make sure that the Reporter

Service is offline before uninstalling Reporter. (Refer Step 1 of the previous section Installing
Reporter on additional nodes to turn the Reporter service offline)

2. Uninstall Reporter from the active node that manages theReporter Service resource.

Note: The data on the shared drive is removed only if the current node is the last node.

3. Move the resource group (containing the resource, Reporter Service) to the next Reporter node
inMSCS using theMicrosoft Cluster Administrator tool.

4. Repeat steps 2 and 3 till Reporter is uninstalled from all nodes.
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Constraints
1. The Clustered Reporter is not supported with other Non-Clustered HP Software products.

2. No HP Software products (for example, HP Operations Manager) must be installed on the
same system as long as they do not support running with a clustered Reporter installation.

3. Only an active/passive configuration is supported. This means that the Reporter can be
installed on all cluster nodes, but can run only on one node at a time. No load balancing is
possible and supported. Only one running Reporter service per cluster is allowed.

Creating Virtual Directories
You can create virtual directories after installing Reporter.

Starting Microsoft Internet Information Services
(IIS) Manager from the Run Dialog Box

To start IIS Manager from theWindows system running Reporter, follow these steps:

1. From the Start menu, click Run. The Run dialog box opens.

2. Type inetmgr and click OK.

Note: If IIS is already installed on theWindows system, the virtual directory is automatically
created by the installer.

Starting IIS Manager from the Computer
Management Console

To start IIS manager from the Computer Management console, follow these steps:

1. From the Start menu, click Control Panel. The Control Panel window opens.

2. Select Classic View, and click Administrative Tools → Computer Management. The
Computer Management window opens.

3. Click Services and Applications → Internet Information Services. The IIS Management
Console opens.

4. Expand the console tree to see the list of directories.

Creating a Virtual Directory using IIS Manager
To create a virtual directory using IIS manager, follow these steps:

1. From the IIS Manager window left side tree, expand the local computer name and expand the
Sites folder.
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2. Right-click web site or folder where you want to create the virtual directory, and click Add
Virtual Directory.

3. ForWindows Server 2008, right-click the site or folder where you want to create the virtual
directory, and click Manage Web Site→ Add Virtual Directory. The Add Virtual Directory
window opens.

4. In the Add Virtual Directory dialog box, type the following information:
Alias - Name for the virtual directory.
Physical Path -%OVDATADIR% /webpages.

5. Click OK, to add a new virtual directory.

Creating Virtual Directory in Tomcat after Installing
Reporter

To create a virtual directory in Tomcat after installing Reporter, follow these steps:

1. Go toCATALINA_HOME/CONF/Catalina/localhost.

where, CATALINA_HOME is the Tomcat installation directory.

2. Create an xml file and name it as HPOV_reports.xml.

3. OpenHPOV_reports.xml and type the following:

<Context path="/HPOV_reports" docBase="%OVDATADIR%/webpages" debug="0"
privileged="true"> </Context>
You can view the reports from the URL http:// <hostname>:80/HPOV_reports/reports.htm.

Migrating to HP Reporter 4.00
When youmigrate from the previous versions of Reporter (3.8 or 3.9) to Reporter 4.00, you can
retain the data and configuration settings of the previous versions. Reporter 4.00 supports only on a
64-bit Windows operating system, and the databasemigration fromMicrosoft SQL Express 2005 to
Microsoft SQL Express 2008. This section lists the commonmigration scenarios and the tasks to
migrate a previous version to Reporter 4.00.

Note: You cannot upgrade from the previous versions to Reporter 4.00. Migrating from
Reporter 3.8 or 3.9 English versions to Reporter 4.00 Japanese version is not supported.

Migrate to Reporter 4.00 with Microsoft SQL Server 2008
R2 Express

The following table lists the operating system, database, and tasks tomigrate Reporter 3.8 or 3.9
with the existing operating system and database.
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Existing
Operating
System and
Database

New Operating
System and Database Migration Tasks

Windows 32-bit
system and
Microsoft SQL
Express 2005
database

Windows 64-bit system

Microsoft SQL Server
2008 R2 Express

l Task 1: Back up the existing data

l Task 2: Remove Reporter 3.8 or 3.9 from the
Windows system(Optional)

l Task 3: Install Reporter 4.00

l Task 4: Restore themigrated data

Migrate to Reporter 4.00 with Microsoft SQL Server 2008
Database

The following table lists the operating system, database, and tasks tomigrate Reporter 3.8 or 3.9
with Microsoft SQL Server 2005/2008 or Oracle 10g /11g on a local or a remote database.

Existing
Operating
System and
Database

New Operating
System and Database Migration Tasks

Windows 32-bit
system

Microsoft SQL
Server 2005 /
2008 or Oracle
10g /11g

Windows 64-bit system

Microsoft SQL Server
2008

Note:Nomigration script is available for database
backup; you can useMicrosoft or Oracle tools to
backup and restore data.

The following table lists the operating system, database, and tasks tomigrate Reporter 3.8 or 3.9
running on a 64-bit system with Microsoft SQL Server 2008 database.

Note: Use the pathC:\Windows\SYSWOW64\cmd to run the command to backup and restore
the data.

Existing
Operating
System and
Database

New Operating
System and Database Migration Tasks

Windows 64-bit
system and
Microsoft SQL
Server 2008

Windows 64-bit system

Microsoft SQL Server
2008

l Task 1: Back up the existing data

l Task 2: Remove Reporter 3.8 or 3.9 from the
Windows system

l Task 3: Install Reporter 4.00

l Task 4: Restore themigrated data
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Migrate to Reporter 4.00 with Remote Microsoft SQL
Server 2008 or Oracle 11g R2 Database

The following table lists the operating system, database, and tasks tomigrate Reporter 3.8 or 3.9
with remoteMicrosoft SQL Server 2005 or 2008 or Oracle 10g or 11g database.

Note: Nomigration script is available for database backup; useMicrosoft or Oracle tools to
back up and restore data.

Existing
Operating
System and
Database

New Operating
System and Database Migration Tasks

Windows 32-bit
system and
Microsoft SQL
Server 2008 or
Oracle 11g
(Remote)

Windows 64-bit system

Microsoft SQL Server
2008 or Oracle 11g R2
(Remote)

l Task 1: Back up the existing data

l Task 2: Remove Reporter 3.8 or 3.9 from the
Windows system (Optional)

l Task 3: Install Reporter 4.00

l Task 4: Restore themigrated data

Migrate to Reporter 4.00 with Remote Microsoft SQL
Server 2008 or Oracle 11g R2 Database (same system)

The following table lists the operating system, database, and tasks tomigrate Reporter 3.8 or 3.9
with remoteMicrosoft SQL Server 2008 or Oracle 11g R2 database on the same system.

Note: Nomigration script is available for database backup, you can useMicrosoft or Oracle
tools to backup and restore data.

Use the pathC:\Windows\System32\cmd to run the command to backup and restore data.

Existing
Operating
System and
Database

New Operating
System and Database Migration Tasks

Windows 64-bit
system and
Microsoft SQL
Server 2008 or
Oracle 11g

Windows 64-bit system

Microsoft SQL Server
2008 or Oracle 11g R2

l Task 1: Back up the existing data

l Task 2: Remove Reporter 3.8 or 3.9 from the
Windows system

l Task 3: Install Reporter 4.00

l Task 4: Restore themigrated data
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Migration Tasks
This section describes the tasks tomigrate Reporter 3.8 or 3.9 to Reporter 4.00.

Task 1: Back up the existing data

Before you start migrating, take the back up of the existing content for database, configuration files,
trace files, registry files, and other customer specific files.

To back up the existing data, follow these steps:

1. Insert theHP Reporter 4.00 DVD into the DVD drive.

2. Go to Documentation → Migration.

3. Copy the script OVR_dnl_conf_db.vbs.

4. Stop the Reporter services running on your system.

5. From theWindows command prompt, run cscript OVR_dnl_conf_db.vbs “< location of the file
name for the back up>" -p -d - r;
example - cscript OVR_dnl_conf_db.vbs “c:\databackup" -p -d - r,
where the data backup folder contains themigrated data.

n -p - backup packages and report templates. (Use this option only for customized Crystal
Report templates.)

n -d - backup database (Use this option only to backup default database.)

n -r - backup registry

Task 2: Remove Reporter 3.8 or 3.9 from the Windows system

1. Uninstall Reporter 3.8 or 3.9 from theWindows system. For uninstalling Reporter, see
Uninstalling Reporter.

2. Remove the following directories -%ovinstalldir% and%ovdatadir%.

Task 3: Install Reporter 4.00

Before installing Reporter 4.00make sure the ODBC Data Source is configured toMicrosoft SQL
Server 2008 or Oracle 11G database. For installing Reporter 4.00, see Installing HP Reporter 4.00.

Task 4: Restore the migrated data

Restore themigrated data for database, configuration files, trace files, registry files, and other
customer specific files.

To restore themigrated data, follow these steps:

1. Insert theHP Reporter 4.00 DVD into the DVD drive.

2. Go to Documentation → Migration.
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3. Copy the script OVR_upl_conf_db.vbs.

4. Copy the folder that contains themigrated data to theWindows system, where Reporter 4.00
is installed.

5. Stop the Reporter services running on your system

6. FromWindows system command prompt run cscript OVR_upl_conf_db.vbs "< location of the
file name for the back up>" -p -d -r ;
example - cscript OVR_upl_conf_db.vbs “c:\databackup" -p -d -r,
where the data backup folder contains themigrated data.

n -p - restore packages and report templates

n -d - restore database (Use this option only to restore default database)

n -r - restore registry
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Installing and Configuring Microsoft SQL
Server 2008 R2 for Reporter

You can useMicrosoft SQL Server 2008 R2 as the database for Reporter 4.00. To install and
configureMicrosoft SQL Server 2008 R2 for Reporter, youmust perform the following tasks:

l Install Microsoft SQL Server 2008 R2

l Install Microsoft SQLClient

l Establish and Test the ODBC Connection

l ConfigureMicrosoft SQL Server 2008 R2

Installing Microsoft SQL Server 2008 R2
To useMicrosoft SQL Server 2008 R2 as the database for Reporter 4.00, you should install the
Microsoft SQL server and client software. This section provides instructions to install Microsoft
SQL Server 2008 R2 as the database for Reporter 4.00.

For system requirements and other information, see the product documentation available online at
http://msdn.microsoft.com/en-us/library/ms143506(SQL.105).aspx.

Note:Before installingMicrosoft SQL Server, consult a Database Administrator (DBA). A
database administrator can help you design and set up the database, including the creation of
the table spaces for optimal use by Reporter.

To Install Microsoft SQL 2008 Server Software:

1. Insert theMicrosoft SQL Server 2008 CD into your CD-ROM drive.

2. Select New Installation or Add Features to an Existing Installation. The installation
wizard appears.

3. Select Local Computer as the built-in system account and all the default options as they
appear.

4. SelectWindow Authentication Mode for authentication.

5. In the Instance Name dialog box, select Named Instance and enter an instance name.

6. Restart your system after the installation is complete.
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Configuring Microsoft SQL Server 2008 R2 for
Reporter 4.00

Before configuringMicrosoft SQL Server 2008 R2, youmust install Microsoft SQL server and client
software andmake sure you have completed all the post installation tasks. For more information
see Installing SQL Server 2008 section.

Note: Do not runmultiple copies of Reporter, as unexpected results occur whenmore than one
copy of Reporter attempts to write data to the configured Reporter database.

To configureMicrosoft SQL Server 2008 as the database for Reporter, do the following:

1. From the Start menu select Start →Programs →Microsoft SQL Server 2008 →SQL
Server Management Studio.

2. Enter your Login name andPassword and click Connect. TheMicrosoft SQL Server
Management Studiowindow opens.

3. On the left pane ofMicrosoft SQL Server Management Studio window, right-click on
Databases and select New Database. TheNew Database window opens.
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4. If your SQL Server system is not listed under the SQL Server Group, right-click SQL Server
Group, select Register from the drop-downmenu. A registration wizard appears. Select the
default options provided by the registration wizard to register your SQL Server.

5. Enter a name for the database in theDatabase name text box (Example: Reporter as shown in
the screen shot).
When you create a new database, the following files are created automatically:
n a data file with the logical name same as the database name you specified (Example:

Reporter as shown in the screen shot).

n a log file with the logical name same as the database name followed by _log (Example:
Reporter_log as shown in the screen shot).

6. The database files are displayed in theDatabase files section, specify the value of the Initial
Size (MB) of database file as 100MB and log file as the default value which appears. Click OK
to close theNew Database window.
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7. On the left pane, click Security.

8. From the left pane of Microsoft SQL Server Management Studio window, right-click Security
and select New Login. The Login - New window appears. You can create two types of Login
authentication.
n SQL Server authentication - ToCreate SQL Server Authentication, click theGeneral tab

and in theName box, enter the user name. UnderAuthentication, select theSQL Server
authentication as shown in the following figure.
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n Windows Authentication - Click theGeneral tab and in theName box, enter the user
name. Under Login name, select theWindows Authentication.

HP Reporter (4.00)Page 34 of 73



Installation and Configuration Guide
Chapter 3: Installing and ConfiguringMicrosoft SQL Server 2008 R2 for Reporter

9. From theDefault database drop-down list, select Reporter. Retain all the default values, as
they appear for all the remaining fields.

10. From theSelect a Page options, click User Mapping.
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11. From theUsers mapped to this login section, select theMap corresponding to your
databaseReporter.

12. UnderDatabase roles membership for: Reporter, select db_owner and public. Click OK.
TheMicrosoft SQL server 2008 database is now configured as the database for Reporter.

Installing Microsoft SQL Client
This section provides instructions to install Microsoft SQLClient and its components for Reporter
4.0.

For installingMicrosoft SQLClient, see the online documentation available at Microsoft web site
http://msdn.microsoft.com/en-us/library/ms131321(v=sql.105).aspx.

Select the following components of SQL server during the installation. For more information, see
Microsoft web site http://msdn.microsoft.com/en-us/library/bb500442(v=sql.105).

l Client Tools Connectivity

l Client Tools Backwards Compatibility

l Client Tools SDK

l SQLServer Books Online

l Management Tools – Basic (Including the sub selection of Management Tools – Complete)

l Microsoft Sync Framework
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Note:Do not install SQLClient software, If Reporter andMicrosoft SQL Server are installed on
the same system.

Establishing ODBC Connection
To establish ODBC connection, follow these steps:

1. From Startmenu, Click Control Panel→ System and Security→Administrative Tools→
Data Sources (ODBC). TheODBC Data Source Administrator window opens.

2. Select System DSN tab and click ADD. The Create New Data Source window opens.

3. Select SQL Server Native Client 10.0 and Click Finish.

4. In theCreate a New Data Source to SQL Serverwindow, make sure that the server name
appears in theServer text box. Click Next.

5. SelectWith Integrated Windows authentication and click Next.

6. Select Change the default database to, select Reporter from the drop-down list, and click
Next.

Testing ODBC Connection
To test the ODBC connection, follow these steps:

1. In theODBC Microsoft SQL Server Setup dialog box, Click Test Data Source.

2. Click OK to exit theSQL Server ODBC Data Source Test.

Verifying Trust Relationship between Client
and Server

Note: A trust relationship should be set up if the Reporter client and SQL Server are in separate
domains in network or if the client and server run on different systems withWindows 2008.

1. Log on to theMS SQLServer-installed system with Administrator privileges.

2. Go toStart → Control Panel → Administrative Tools. The Administrative Tools window
opens.

3. Double-click Active Directory Domains and Trusts. Select Trusts. The Trusting Domains
dialog box opens

4. Look for the domain where Reporter is located. If the appropriate domain is displayed, continue
to the next task. If not, add the trusting domains as needed. If you have questions about
trusting domains, click theHelp button (if Reporter and SQL Server systems are in separate
domains, youmust configure a trust relationship between the systems).
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Installing and Configuring Oracle 11g R2
for Reporter

This section describes the steps required to install and configure Oracle 11g R2 for Reporter. The
following illustration shows the tasks youmust complete to set up Oracle as the Reporter
database. The left side of the illustration shows the steps for new and existing installations of
Oracle on the HP-UX, Solaris, and Linux systems. The right side of the illustration shows the steps
to configure Oracle Reporter database on aWindows system.

Installing Oracle 11g R2 for Reporter
Prerequisites: Check your HP-UX, Solaris and Linux system kernel parameters andmodify as
necessary. Reporter requires 900MB disk space in the Oracle database.

For system, memory, and disk requirements, please check the "System Requirements" section of
Oracle 11g R2 Installation Guide. Oracle has specific recommendations regarding optimal database
installation and architecture. This document does not discuss all aspects of database installation
and administration. We suggest you to refer Oracle technical literature and consult qualified Oracle
professionals to achieve optimum database performance in your particular environment.

For instructions on installing Oracle 11g R2, seeOracle Documentation Library at the following
URL:
http://www.oracle.com/pls/db112/homepage.
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Configuring Oracle 11g R2 for Reporter
You can configure Reporter to work with Oracle 11g R2 as its database. This section provides
information on configuring and editing Oracle listener and tnsnames files and describes the steps
required to configure Oracle 11g R2 as the database for Reporter 4.00.

Note: The screens and steps provided in the following sections may vary with the operating
systems or versions. Before installing Oracle 11g R2, consult an Oracle Database
Administrator (DBA) to optimize the database usage. Optimization of the database usage
includes tasks such as setting up the database and creation of tablespaces for
configuration issues such as database sizing and AUTOEXTEND of data files.

Caution: Do not runmultiple copies of Reporter as unexpected results occur whenmore than one
copy of Reporter attempts to write data to the configured Reporter database.

Editing Templates to Configure Oracle listener.ora
and tnsnames Files

Template 1 (listener.001) is for situations where no listener is configured for Oracle. This template
allows you to insert text pertaining to the host system and directory where Oracle resides, and use
the file to replace the existing listener file.

Template 1/A (tnsnames.001) is for configuring oneOracle database instance (for Reporter data).
This template enables you to insert text pertaining to the database instance you use for the
Reporter database.

Template 2 (listener.002) is for situations where a listener is already configured. This template
enables you to copy and paste settings relating to Reporter into your existing template.

Template 2/A (tnsnames.002) enables you to add the configuration of an Oracle database instance
for Reporter data, to the existing tnsnames.ora file that already is configured to recognize other
Oracle database instances.

Template 1: Configuring the listener.ora file

The following sample file helps you edit the template included with Reporter (listener.001) for
setting up a listener for the Oracle database instance connection to Reporter. Before using the
template, follow these steps:

1. Replace the host name in two places.

2. If necessary, change theORACLE_HOME path (where Oracle resides).

3. Rename the template to listener.ora. and copy it to the /etc directory for HP-UX or the
$ORACLE_HOME/network/admin directory for Solaris.

######################################################
# FILENAME: listener.ora
# DATE....: Jun 4 2007
# NETWORK.: openview
#NODE....: Server

HP Reporter (4.00)Page 39 of 73



Installation and Configuration Guide
Chapter 4: Installing and Configuring Oracle 11g R2 for Reporter

# SERVICE.: LISTENER
#COMMENT.: For use with Reporter
######################################################

LISTENER =
(ADDRESS_LIST =
(ADDRESS=
(PROTOCOL=IPC)
(KEY= REPORTER)
)

(ADDRESS =
(PROTOCOL = TCP)

        (HOST = host_name) #### Insert your host name for <host_name>
(PORT = 1521)
(QUEUESIZE = 50) ##### Increased queue size for REPORTER
)

(ADDRESS =
(PROTOCOL = TCP)
(HOST = host_name) #### Insert your host name for <host_name>
(PORT = 1526)
(QUEUESIZE = 50) ##### Increased queue size for REPORTER

      )
)

SID_LIST_LISTENER =
(SID_LIST =
(SID_DESC =
(SID_NAME = REPORTER)
(ORACLE_HOME= /opt/oracle/product/11.2.0)
(ENVS='EPC_DISABLED=TRUE')

     )
)

STARTUP_WAIT_TIME_LISTENER = 0
CONNECT_TIMEOUT_LISTENER = 30 ##### Increased timeout for REPORTER
LOG_DIRECTORY_LISTENER = /opt/oracle/product/11.2.0/network/log
LOG_FILE_LISTENER = listener
TRACE_LEVEL_LISTENER = OFF

Template 1A: Configuring the tnsnames.ora File Using the Template

The following sample file helps you edit the template included as tnsnames.001 for configuring one
Oracle database instance connection to Reporter. Before you use the file, follow these steps:

1. Replace the host name. 

2. Rename the file to tnsnames.ora .

3. Copy the file into /etc directory for HP-UX or the $ORACLE_HOME/network/admin directory
for Solaris.

####################
# FILENAME: tnsnames.ora
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# DATE....: Jun 4 2007
# NETWORK.: openview
#NODE....: Server
# SERVICE.: LISTENER
#COMMENT.: For use with Reporter.
####################

RPT.world =
(DESCRIPTION =
(ADDRESS = (PROTOCOL= TCP)(Host= <host_name>)(Port= 1521))
(CONNECT_DATA = (SID = REPORTER))
)

Template 2: Editing the Existing listener.ora File Copying from the
Template

The following file helps you edit the template included with Reporter (listener.002) to set up a
listener for the database instance connection to Reporter. Before using the template, follow these
steps: 

1. Replace the host name in two places. 

2. If necessary, modify the path where Oracle is located in two places.

3. Paste the REPORTER blocks and the "Increased queue size" line into the appropriate places
in your existing listener.ora file.  

4. Paste in or change the CONNECT_TIMEOUT_LISTENER line so that the timeout value is at
least 30.

#########################
# FILENAME: listener.ora
# DATE....: Jun 4 2007
# NETWORK.: openview
#NODE....: Server
# SERVICE.: LISTENER
#COMMMENT: For use with Reporter
#########################

LISTENER =

(ADDRESS_LIST =
(ADDRESS=

(PROTOCOL=IPC)
(KEY= openview)

)

##### Begin REPORTER block number 1 #######
(ADDRESS=                             #

(PROTOCOL=IPC)                 #
(KEY= REPORTER)                #

    )                                     #
##### End REPORTER block number 1 #########
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(ADDRESS =
(PROTOCOL = TCP)
(HOST = <host_name>)
(PORT = 1521)
(QUEUESIZE = 50) #### Increased queue size for REPORTER

    )

##### Begin REPORTER block number 2 ########
(ADDRESS =                             #

(PROTOCOL = TCP)                    #
(HOST = <host_name>)       #
(PORT = 1526)                  #
(QUEUESIZE = 50)               #

)                                      #
##### End REPORTER block number 2  #########

)

SID_LIST_LISTENER =
(SID_LIST =
(SID_DESC =
(SID_NAME = openview)
(ORACLE_HOME= /opt/oracle/product/11.2.0)

      )
  )
##### Begin REPORTER block number 3 ##################
(SID_DESC =                                    #
(SID_NAME = REPORTER)                       #
(ORACLE_HOME= /opt/oracle/product/11.2.0) #
(ENVS='EPC_DISABLED=TRUE')                  #
)                                             #

)                                                  #
##### End REPORTER block number 3 ####################

)
STARTUP_WAIT_TIME_LISTENER = 0
CONNECT_TIMEOUT_LISTENER = 30 #### Increased timeout for REPORTER
LOG_DIRECTORY_LISTENER = /opt/oracle/product/11.2.0./network/log
LOG_FILE_LISTENER = listener
TRACE_LEVEL_LISTENER = OFF

Template 2A: Editing the Existing tnsnames.ora File Copying from
the Template

The following sample file helps you to edit the template included as tnsnames.002 and change your
existing tnsnames.ora file to recognize anOracle database instance connection to Reporter. To use
the template, follow these steps:

1. Replace the host name in two places. 

2. Paste the REPORTER blocks into the appropriate places in your existing tnsnames.ora file. 
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########################
# FILENAME: tnsnames.ora
# DATE....: Jun 4 2007
# NETWORK.: openview
#NODE....: Server
# SERVICE.: LISTENER
#COMMENT.: For use with Reporter. 
#########################

ov_net =
(DESCRIPTION =
(ADDRESS = (PROTOCOL= TCP)(Host= <host_name>)(Port= 1521))
(CONNECT_DATA = (SID = openview))
)

##### Begin REPORTER block##################################
RPT.world =                                            #
(DESCRIPTION =                                             #
(ADDRESS = (PROTOCOL= TCP)(Host= <host_name>)(Port= 1521)) #
(CONNECT_DATA = (SID = REPORTER)) #
)     #
##### End REPORTER block ###################################

Configuring Oracle 11g R2 on HP-UX, Solaris, or
Linux as Reporter Database

After installing Oracle 11g R2 on HP-UX, Solaris, or Linux systems, you can configure it as the
database for Reporter. For configuring Oracle 11g R2 as Reporter database, youmust complete the
following tasks:

l Create Reporter DatabaseObjects

l Create Reporter Tablespace, User, and Privileges

l Configure Automatic Database Startup and Shutdown (Optional)

Creating Reporter Database Objects
To create database objects, follow these steps:

1. Log in to the oracle account.

2. Update UNIX environment variables as follows: (add to profile, or set manually).

DISPLAY=<workstation_name>:0.0
(<workstation_name> is computer where output from theOracle products should be
displayed)
ORACLE_BASE=/opt/oracle
ORACLE_HOME=/opt/oracle/product/11.2.0
ORACLE_SID=REPORTER
PATH includes $ORACLE_HOME/bin, /usr/bin, /etc, /usr/ccs/bin, /usr/local/bin

for HP-UX: SHLIB_PATH=$ORACLE_HOME/lib
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for Solaris: LD_LIBRARY_PATH=$ORACLE_HOME/lib

for Oracle 11g :
CLASSPATH=$ORACLE_HOME/JRE/lib:$ORACLE_HOME/jlib:
$ORACLE_HOME/network/jlib:$ORACLE_HOME/rdbms/jlib:$ORACLE_
HOME/assistants/jlib
TNS_ADMIN=$ORACLE_HOME/network/admin

3. Type dbassist, to run the Database Configuration Assistant.

4. In the startup window, select Create a database and click Next.

5. Select Custom as the database type, click Next.

6. SelectMultipurpose as the type of application, click Next.

7. Select number of concurrently connected users (suggest 40), click Next.

8. Select Dedicated Server Mode, click Next.

9. No options required for reporter; click Next.

10. Enter the Global Database Name (i.e. reporter<.domain.name> ) and SID (REPORTER).
Note that REPORTER must be entered as all uppercase. Then click Next.
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11. Review the Control File information, click Next.

Note: Oracle recommends multiplexing controls files on different disks to support database
recoverability.
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12. Accept the defaults for all the tabs (click Next through the tabs) unless otherwise
recommended by your Oracle Administrator. 
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13. Review the Redo Log Files information; click Next.

14. Review the logging parameter information; click Next.

15. Review the SGA parameter information; click Next.

16. Review the Trace File Directory information; click Next. 

17. Select Create database now; click Finish.

Creating Reporter Tablespace, User, and Privileges
To create Reporter tablespace, user and privileges:

1. Log on as root or su.

2. Create the file (below) and save as repconfig.sql in the $ORACLE_
BASE/admin/reporter/create/ directory:
(the edits you need tomake are highlighted) :

Note: For performance considerations Oracle recommends to place data
(tablespace REPORTER), index (tablespace RPT_INDEXES), and rollback segments
(tablespace RBS) on different disks if available. See  "Chapter 6: Scalability and System
Requirements"   for tablespace sizing.

Youmust replace /database/oradatawith the path you have established for your
database data files. The data file names are only recommendations and can be changed to
conform to the standards at your site. Also the user and password are highlighted; change
as necessary.
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Note: If the actual storage size of 600MB for REPORTER tablespace and 300MB for the RPT_
INDEXES tablespace is not large enough, please consult your Oracle DBA on the
appropriate size for your environment or how to setup the AUTOEXTEND datafile feature
in Oracle.

create tablespace REPORTER datafile
'/database/oradata/reporter/rptdb01.dbf' SIZE 600M
extent management local autoallocate;

create tablespace RPT_INDEXES datafile
'/database/oradata/reporter/rptidx01.dbf' size 300M
extent management local autoallocate;

CREATE USER "OPENVIEW" PROFILE "DEFAULT"
IDENTIFIED BY "openview"
DEFAULT TABLESPACE "REPORTER"
TEMPORARY TABLESPACE "TEMP"
QUOTA UNLIMITED ON REPORTER
QUOTA UNLIMITED ON RPT_INDEXES
ACCOUNT UNLOCK;

GRANT CREATE ANY INDEX TO "OPENVIEW"
GRANT CREATE PROCEDURE TO "OPENVIEW"
GRANT CREATE SEQUENCE TO "OPENVIEW"
GRANT CREATE SESSION TO "OPENVIEW"
GRANT CREATE TABLE TO "OPENVIEW"
GRANT CREATE TRIGGER TO "OPENVIEW"
GRANT CREATE VIEW TO "OPENVIEW"
GRANT "CONNECT" TO "OPENVIEW";

3. Log on as the oracle software owner.

4. Make sure the ORACLE_SID is set toREPORTER; otherwise the Reporter tables will be put
in the wrong SID.

5. Run the $ORACLE_HOME/bin/svrmgrl program and enter the following commands to start
the database (the databasemay have already been started)
connect internal
startup

6. Enter the following SQL statement:
@$ORACLE_BASE/admin/reporter/create/repconfig.sql

7. Enter the following command to exit: Exit

8. Enter the following commands to restart the SQL listener:
lsnrctl stop
lsnrctl start

Configuring Automatic Database Startup and Shutdown
You can configure the system to startup and shutdown the oracle database automatically to avoid
all incorrect database shutdown, for more information seeOracle 11g R2Database Administrator’s
ReferenceGuide.
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Caution: Skip this step, if your Database Administrator has started this procedure.

If the HP Operations Manager (HPOM) for UNIX database is installed on the sameOracle
server, youmust modify the oratab entry to change the startup flag from Y toN as it is restarted
by a different facility. For example, change openview:$ORACLE_HOME:Y to
openview:$ORACLE_HOME:N.

Configuring Reporter on Windows System
After installing Reporter 4.00 in aWindows system, you can connect it to a HP UX or Solaris
system for accessing the Oracle database. To configure Reporter 4.00 on a windows system,
complete the following tasks:

l Install Oracle client software

l Configure Net8 connection to Reporter database

l Configure ODBC Data Source inWindows control panel

l Configure the database in Reporter

Note: Enter the exact instruction text in the required fields to avoid case-sensitive issues.

Installing Oracle Client Software
Youmust install Oracle 11g R2 on your system before installing the Oracle Client software. You
must have Administrator privileges on theWindows Operating System client where Reporter is
installed.

To install Oracle Client software, refer Oracle Documentation library at the following URL:
http://www.oracle.com/pls/db112/portal.portal_db?selected=11&frame=#microsoft_windows_
installation_guides.

Configuring Net8 Connection to Reporter Database
After installation of the Oracle 11g client software (the Net8 Configuration is optionally part of the
client install and dialog steps may differ slightly) on theWindows system running Reporter, on that
same system complete the following steps.

To configure the Net8 connection to Reporter database:

1. From the Start menu, select Oracle><Oracle_Home>:Network Administration:Net8
Configuration Assistant.

2. In theWelcome dialog select Local Net Service Name configuration and click Next.

3. Select theAdd radio button; click Next.

4. In the Service Name dialog, enter the global database name (i.e. reporter.<domain.name>);
click Next.

5. At the Select Protocols dialog, select TCP, click Next.
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6. At the TCP/IP Protocol dialog, supply the Host Name and port number (typically 1521), click
Next. 

7. At the Test dialog, select Yes, perform a test; click Next.

8. At the Connecting dialog, verify that the connection was successful (youmay have to change
the login credentials (i.e., openview/openview) for the test to succeed); click Next.
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9. At the Net Service Name dialog, supply a Net Service Name (suggested: RPT), and click
Next.
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10. In the Another Net Service Name? dialog, select No and click Next.

11. In the Done dialog, click Next, and then Finish.
Note: The Net Service Name (i.e., RPT)may have the network domain appended to its

name, for example RPT.<DOMAIN.NAME>. Rerun the Net8 assistant and select test to
verify the actual, full Net Service Name.

Configuring ODBC Data Source in Windows Control
Panel

After configuring Net8 on theWindows system running Reporter, youmust configure the ODBC
data source.

To complete OBDC Data Source on aWindows system, follow these steps:

Note: Close all instances of Reporter running on your system before configuring ODBC Data
Source.

1. From Startmenu, Click Control Panel → System and Security→Administrative Tools→
Data Sources (ODBC). TheODBC Data Source Administrator window opens.

2. a. Select System DSN tab and click ADD. The Create New Data Source window opens.

3. (If migrating data from the default database to Oracle, omit this step.)
ChooseReporterwith the default database driver and remove it.

4. Select Oracle ODBC Driver and select Finish.

5. In the dialog box that appears, enter the following:
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Data Source Name: Reporter
Description: <your_description>
Service Name: RPT.<domain_name>
User ID:  (no entry necessary)

Note: Youmust enter Reporter as the Data Source Name inmixed case (uppercase "R")
to match references to it in Reporter executables.

Configuring the Database in Reporter
1. From Start menu, click All Programs →HP → HP Reporter → Reporter.

2. In the error message box, click OK to proceed.

3. From Reporter Filemenu, select Configure → Databases.
The same error message appears as in the previous step; ignore and click OK to proceed.
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4. In the Configure Databases dialog box under the Reporter Database section, enter the
database User Name and Password that you used for the UNIX system configuration in Task
5, step 2 (username: openview; password: openview).

5. Click OK

6. (If migrating data from the default database to Oracle, OMIT this step.)
Run <install_directory>\bin\Newdb.exe.

7. Click Close, and then re-open the Reporter main window.

Configuring HPOM 9 (Oracle 11g) Database to
Reporter

You can configure theWindows Operating System client which allows Reporter to connect to a
UNIX system for accessing HPOM database. To configure HPOM 9 database to reporter, perform
the following tasks:

Task 1 Install Oracle 11g R2 Client software

Youmust install Oracle 11g R2 on your system before installing the Oracle Client software. You
must have Administrator privileges on theWindows Operating System client where Reporter is
installed.

1. Insert the Oracle 11g R2Client DVD.

2. Select Install/Deinstall Products.
If you have noOracle Products on your system skip this step.

3. In the Oracle Universal InstallerWelcome dialog click Next.

4. In File Locations enter theSource andDestination file locations for this product; click Next.
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5. In the Installation Types select Administrator as the installation type and click Next.

6. Verify information in theSummary dialog that appears. Click Install.

The install process automatically starts theConfiguration Tools dialog where you can choose to
run theNet Configuration Assistant.

Task 2 Configure the Net connection to the HPOM database

After you complete the installation of the Oracle client software (the Net Configuration is optionally
part of the client install and dialog steps may differ slightly) on theWindows system running
Reporter, on that same system complete the following steps:

1. From theStartmenu, click Programs → Oracle - <Oracle Home> → Network
Administration →Net Configuration Assistant.

At theWelcome dialog select Local Net Service Name Configuration, click Next.

2. In the Net Service NameConfiguration dialog select Add and click Next.

3. In the Database Version dialog, select Oracle 11g R2 database or service (select the other
option if connecting to a previous Oracle version), click Next.

4. At the Service Name dialog enter the global database name specified during database creation.
Click Next.

HP Reporter (4.00)Page 55 of 73



Installation and Configuration Guide
Chapter 4: Installing and Configuring Oracle 11g R2 for Reporter

Rerun the Net assistant and select test to verify the actual, full Net Service Name.

Note: The Net Service Name (i.e., openview) may have the network domain appended to its
name. (For example, openview.rose.hp.com, where "rose.hp.com" is the domain name.
Domain namemay or may not be necessary, depending on how your system is set up.)

5. At the Select Protocols dialog, select TCP, click Next. 

6. At the TCP/IP Protocol dialog, supply theHost Name and port number (typically 1521), click
Next.
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7. At the Test dialog, select Yes, perform a test, and click Next.

8. At the Connecting dialog, verify that the connection was successful (youmay have to change
the login credentials for the test to succeed; the login/password shouldmatch those set up for
Operations Manager connecting to the database). Click Next.

9. At the Net Service Name dialog, supply aNet Service Name, (suggested: openview) click
Next. 

10. At theAnother Net Service Name?Dialog, select No, and click Next.

11. At theDone dialog, click Next,and then click Finish.

Note: The Net Service Name (openview) may have the network domain appended to its
name. (For example, openview.rose.hp.com, where "rose.hp.com" is the domain name.
Domain namemay or may not be necessary, depending on how your system is set up.)
Rerun the Net assistant and select test to verify the actual, full Net Service Name.

Task 3 Verify the Net connection to the HPOM database

After configuring the Net configuration, verify that you can contact the HPOM database from your
system as follows:

1. From theStart menu, click Programs and select Oracle <Oracle Home>, Database
Administration, andSQLPlus Worksheet.

2. In theOracle Enterprise Manager Login dialog, enter the databaseUser Name (the
recommend user name is opc_report) andPassword.  Enter theService name
(openview<.DOMAIN.NAME>).
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3. Click theOK button.  The SQL*PLUSWorksheet should appear.  If error messages appear,
you have an error in the connection from the system to the Oracle Operations Manager
database. Review previous tasks in this section.

4. In the SQL*Plus Worksheet, enter the command to retrieve data from one of the Oracle
database tables:

select node_group_name from opc_node_groups;

A response like the following indicates successful access to the Operations Manager database. If
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you receive errors, you need to correct them before proceeding. Contact your Oracle database
administrator for assistance.

NODE_GROUP_NAME
--------------------------------
hp_ux
net_devices
NT40

5. From the Filemenu select Exit.

Task 4 Configure the ODBC data source in the Control Panel

After configuring Net onWindows system running Reporter, youmust configure the ODBC Data
Source.

To Configure ODBC Data Source, perform the following steps on theWindows system where
Reporter is installed:

1. From Startmenu, Click Control Panel→ System and Security→ Administrative Tools→
Data Sources (ODBC). TheODBC Data Source Administrator window opens.

2. Select System DSN tab.

3. Click theAdd. button and highlight Oracle ODBC driver and select Finish.
a. In the dialog box that appears, enter the following:

Data Source Name: ov_net
Description: <your_description>
Service Name: openview<.domain.name>
User ID: (no entry necessary)

Note: Youmust provide the Data Source Name as ov_net8 in case of ovo 8/9
database to configure Operations Manager for UNIX 8/9.
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6. Click OK.

Task 5 Install the HPOM Report Package

To add report definitions and configuration information, you need to add the HPOM for UNIX 8 or 9
packages.

To add the package, perform the following steps:

1. From the Reporter Filemenu click Configure→ Report Packages. The Configure Report
Packages window opens.
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2. Select the appropriate Operations Manager for UNIX 8 from the Available Packages box; click
the right-arrow tomove to the Installed Packages box, and click OK.

Make sure to remove your current package before installing the new one (see Important preliminary
information/instructions above).

1. Verify that the Reporter service is running
(the service will not run if the 3rd to 6th toolbar buttons are disabled); if not, start it by clicking
the 2nd button.

2. In the Status pane, check for themessages:
RepLoad:Loading package for 'HP Operations Manager for UNIX 8'
RepLoad:Completed loading template file
(to indicate successful package installation)

Task 6 Configure HPOM Database in Reporter

Now you have configured the database connection to the HPOM database and installed the
Operations Manager for UNIX Report Package, you can configure Reporter to recognize the
Operations database as the source for its data. With Reporter installed on theWindows system,
perform the following steps:

1. From the File menu click Configure → Databases. The Configure Databases window opens.

2. In the Other Databases section (lower area) of the Configure Databases dialog box select the
down-arrow in the Database text box, and choose openview.
(If openview does not appear, you will need to review the steps of the previous sections to
configure the ODBC setup.)
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Note: Youmust select openview8 to configure Operations Manager for UNIX 8/9.

3. Complete the remaining text boxes as follows:
Server: ov_net
User ID:< your_Operations Manager_ database_user_name>
Password:<your_Operations Manage_database_password>

Note:Youmust choose ov_net8 as the Server to configure Operations Manager for UNIX 8.

4. Click OK.

Task 7 Discover HPOM Systems and Gather Data

Note: Reporter Discover_ITO.exe program targets the Operations Manager database.

1. Select Schedule in the left pane to display a list of all scheduled actions in the right pane.

Note: If configured with Operations Manager for UNIX 8/9, add a new schedule entry for
DISCOVER_ITO.exe andGather_ITO.exe with openview8 as a parameter.

2. In the right pane, right-click Discover_ITO.exe and select Run Now.

3. In the Status pane, check for messages such as:

2007/06/04 11:12:07 Discover_ITO: Begin Discovery of ITO database openview
2007/06/04 11:12:07 Discover_ITO: Found NEW ITOAgent on abc.xyz.domain.com
2007/06/04 11:12:07 Discover_ITO: Found NEW ITOAgent on zephram.rose.hp.com
2007/06/04 11:12:07 Discover_ITO: Found NEW ITOAgent on ros59102raw.rose.hp.com
2007/06/04 11:12:07 Discover_ITO: Found NEW ITOAgent on highbeam.rose.hp.com
2007/06/04 11:12:07 Discover_ITO: Examined 4 systems, found 4 new ITO Agents for a total of 30
known
2007/06/04 11:12:07 Discover_ITO: Examined systems in groups for 3 systems, found 3 new
2007/06/04 11:12:07 Scheduler: Next scheduled action at 05/06/2007 00:15:00

If you see errors, return to Task 6 andmake sure the password and other fields have been correctly
filled in.

4. In the right pane, right-click Gather_ITO.exe and select Run Now.

5. In the Status pane, check for messages such as:
2007/06/04 11:12:07 Scheduler: Starting program "Gather_ITO.exe"
2007/06/04 11:12:07 Gather_ITO: Begin synchronizing with ITO database openview
2007/06/04 11:12:07 Gather_ITO: Processing Historical messages
2007/06/04 11:12:07 Gather_ITO: Processed 2775 Historical messages, Added 860
Summaries, 854Operator Sums
2007/06/04 11:12:07 Gather_ITO: Processing Activemessages
2007/06/04 11:12:07 Gather_ITO: Processed 755 Activemessages, Added 9 Summaries, 6
Operator Sums
2007/06/04 11:12:07 Scheduler: Next scheduled action at 05/06/2007 00:15:00
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6. If you want to see reports immediately, in right pane right-click ManagedRepcrys.exe and
select Run Now.

Your configuration of the HPOM database with Reporter is now complete. HPOM for UNIX
reporting will now run in the normal nightly reporting cycle.
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Running Reporter and Operations
Manager for Windows on Separate
Systems

You can integrate Reporter with remote Operations Manager forWindows 9.0 and collect managed
node information to generate Operations Manager forWindows reports.

Perform the tasks mentioned in the following section to configure the Operations Manager for
Windows on the Reporter system.

Configuring Reporter System
1. From Reporter 4.0 DVD (SPI_Hotfixes/OMWReport_Package/SPI_Hotfixes/OMWReport_

Package), install HPOvMgrRpt-09.00.000-Win5.2_64-release.msi.

2. From Startmenu, Click Control Panel → System and Security→Administrative Tools→
Data Sources (ODBC). TheODBC Data Source Administrator window opens.

3. Click Add in theODBC Data Source Administrator dialog box to addOpenview System
DSN pointing to Operations Manager forWindows database.
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4. From Reporter menu, click File → Configure → Databases and create a new database
OVMSDB using openview DSN added in step 2.
Note:Youmust create an ovdb_user account, to use SQL authentication to connect OM
database. NT authentication uses no credentials to connect to OM database.

5. From Reporter menu, click File → Configure → Options and specify the Operations
Manager forWindows Settings parameters.

6. Enter the Operations Manager forWindows system name as Operations Manager for
Windows Management Server, a user name as Domain \User Name (with or without
domain) and the password as Password in the Operations Manager forWindows Settings.
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7. From Reporter menu, click Left Pane →Schedule and then right-click and select Add
Schedule to addDiscovery_Neutron to reporter scheduler.

Caution: The User Name entered in the Operations Manager forWindows Settings panel must
be part of the Administrators, HP-OVE-ADMINS, or HP-OVE-OPERATORS user
group on theOperations Manager forWindows management server System.

8. Runmanagedrepcrys from the command line on the Reporter machine or wait for the one
Reporter cycle to be finished to view the reports on the Operations Manager for windows
console.

Adding a user to a user group on Operations Manager for Windows
system

1. From Startmenu, Click Control Panel → System and Security→Administrative Tools→
Computer Management. The Computer Management window opens.

2. Select System Tools → Local Users and Groups → Groups from the left pane.

3. Right-click on a group in the right pane, in which you want to add a user and follow the
procedure to add a user.
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Configuring Multiple HPOM for UNIX
Management Servers to Reporter

This chapter provides instructions to configure Reporter to generate reports onmultiple Operations
Managers for UNIX Server. This feature enables you to generate reports for the systems that do not
use the database connected to Reporter.

Removing HPOM Configurations from
Reporter

Before configuring Reporter to generate reports onmultiple HPOMUNIX Server, remove HPOM
from the Reporter window. This is optional. To remove HPOM configurations, follow these steps:
1. Remove the currently installed HPOM for UNIX 8.00 package. You can do this either from the

Reporter window or from the command prompt:
n To remove the currently installed HPOM for UNIX 7.00 or 8.00 package from Reporter

window:
i. Select File→Configure→Report Packages, from the Reporter window. The

Configure Report Packages window opens.
i. Select Operations Manager for UNIX 8 packages from Installed Packages

pane and click . The selected packages are displayed on theAvailable
Packages pane.

ii. Click OK. The Reporter main window is displayed.

n To remove the currently installed Operations Manager for UNIX package from the command
prompt, run the following commands based on the version of Operations Manager for UNIX
installed on your system:
o If you haveOperations Manager for UNIX 8.00 package installed on your system:

Repload –remove “<InstallDIR>\newconfig\packages\repload_ovoux8.srp”

2. Remove the existing database configurations in the Reporter GUI.

3. Remove the Data Source Names (DSN) configured for Operations Manager for UNIX from
your system by following these steps:
a. Click Start → Run.

b. Type odbcad32 and click OK. TheODBC Data Source AdministratorWindow appears.

c. Click theSystem DSN tab.

d. Select theDSN configured to Operations Manager for UNIX database from the list and
click Remove.
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Configure Reporter to Generate Reports on
Multiple Operations Manager for UNIX Servers
Database

To configure Reporter to generate reports for multiple Operations Manager for UNIX Servers,
perform the following tasks:

1. Configure Oracle client

2. Configure ODBC

3. Configure Reporter databases

4. Create Service Report Package (SRP) file

5. Load created SRP file to Reporter DB

Configuring Oracle Client
Configure the Oracle client for Operations Manager for UNIX server. For instructions, see the
Reporting from Other Databases section under 'Customizing Reporter' in theHP Reporter
Concepts Guide.

Configuring ODBC
Create Data Source Names (DSN) for all the Operations Manager for UNIX management servers.
Every server should have a corresponding DSN.

Configuring Database for Reporter
To configure databases, follow these steps:

1. From Reporter menu, click File → Configure → Databases. The Configure Databases
window opens.

2. Click New. Enter the Database name. For example: OVO_DB1

3. From the drop-down list, select the database that you created.

4. Enter theDSN name that you created.

5. Enter the database User ID and password.

6. Click OK. The database is now configured.

7. Repeat these steps for eachOperations Manager for UNIX server that is being configured.

Note: The above DSN and database names can be replaced by any name of your choice.
Database name should not bemore than 15 characters.
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Creating SRP File
1. From the Reporter DVD, open the folderSupport → multiple_ov.

2. Open one of the following files from a text editor, based on themanagement server installed on
your system:
n multiple_management_server_template_8.srp (if you are using Operations Manager for

UNIX 8.x database)

3. Find and replace all instances of [DATABASENAME] (including the square brackets) with the
database name configured in Reporter.
For example: If the database name that you configured was OVO_DB1, replace
[DATABASENAME] withOVO_DB1

4. Click File → Save As and save the file to the directory
<INSTALLDIR>\newconfig\packages as:
n multiple_management_server_template_8_OVO_DB1.SRP (if you are using Operations

Manager for UNIX 7.x database)

5. Repeat these steps for eachOperations Manager for UNIX server that is being configured.

Note: While saving the file, make sure you always include .srp as the file extension. By default
text editors such as Notepad includes .txt as the extension.

Loading SRP File to Reporter Database
You can load the SRP file either from the Reporter window or from the command prompt:

l To load SRP file from the Reporter window, follow these steps:

a. Start the Reporter service either using Reporter window or Control panel.

b. Select File → Configure → Report Packages in Reporter window.

c. Select the packages you created from theAvailable Packages. Click , the Report
Packages which you select will now be displayed in the Installed Packages pane.

d. Click OK. TheRepload program starts.

e. Wait till the Repload program completes.

OR

l To load SRP file from the command prompt, run the following command:
n Repload -load <INSTALLDIR>\newconfig\packages\multiple_management_server_

template_8_OVO_DB1.SRP if you are using Operations Manager for UNIX 8.x database.

l After loading the SRP files, the Reporter window displays the following information:
n List of Report families which are newly created with the database name as the prefix.

n List of Reports under each family with database name as the prefix.

l Repeat these steps for eachOperations Manager for UNIX server that is being configured.

HP Reporter (4.00)Page 70 of 73



Installation and Configuration Guide
Chapter 6: ConfiguringMultiple HPOM for UNIX Management Servers to Reporter

Generating Reports
To generate reports:

1. From the command prompt, runmanagedrepcrys command:

Note:You can also generate specific reports with the report name as a command line
parameter.

After generating reports, the Reporter web page displays separate links created for each of the
Report families.

Uninstalling Report Packages
You can uninstall Reporter packages either from the Reporter window or from the command
prompt. To uninstall, follow these steps:

l To uninstall Reporter packages from Reporter window:

a. Click File → Configuration → Report packages, theConfigure Report Packages
window opens.

b. Select the packages you want to remove from the Install Packages pane, click . The
selected packages are displayed in theAvailable Packages pane.

c. Click OK.

d. Click File → Configuration → Databases dialog. DeleteDatabases defined in Reporter
window.

e. Remove the DSN created using ODBC configuration.

l To uninstall Reporter packages from the command prompt:

Run the following commands:

n Repload -Remove <INSTALLDIR>\newconfig\packages\multiple_management_
server_template_8_OVO_DB2.SRP if you are using Operations Manager for UNIX 8.x
database

l Repeat these steps for eachOperations Manager for UNIX server.
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Uninstalling Reporter
To uninstall Report 4.00, follow these steps:

1. From theStartmenu, click Control Panel → Programs → Uninstall a Programs. The
Uninstall or Change a Program window opens.

2. From the program list, select HP Reporter and click Change. The HP Reporter - Install
Wizard window opens.

3. Follow the instruction provided in the HP Reporter - Install Wizard window to uninstall Hp
Reporter 4.00.
Two options Remove Standard andRemove Clean are available. Use theRemove Clean
option to remove the data files and HTML reports that are created by the product. Remove
Standardwill not remove the data files and HTML reports that are created by the product.

Note:Select theRemove Clean option only if no other HP Software products are installed on
your system.

When you uninstall HP Reporter, the system performs the following tasks:

l Reporter binaries and product files are removed.

l The following Reporter directories for Reporter database and web pages are not removed:
n <installation_directory> \data\datafiles\

n <installation_directory> \data\Webpages\

l Uninstalling HP Reporter 4.00 has no effect on the virtual directory settings in IIS. If you no
longer have any HP Software products using IIS, you canmanually remove any remaining
"HPOV_" entries from the web server.
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