HP OpenView SPI for DB2

Release Notes

Published 30 March 2005

This document provides an overview of the changes made to Smart Plug-in  for IBM DB2 Databases (SPI for DB2) for the B.02.10 release. It contains important information not included in the manuals or in online help.

In This Version
Installation Notes
Enhancements and Fixes
Known Problems, Limitations, and Workarounds
Documentation Errata
Local Language Support
Integration with Other OpenView Solutions
Support
Legal Notices

In This Version

Version 02.10 of the DB2SPI has been expanded to support new OVO/Windows 7.5 release.  Key differences are:

·          Support of DB2 UDB 8.2.

·          DB2 on Windows managed nodes with German localization supported

·          User's Guide now contains chapter about cluster support

·          HP Self-Healing Support has been integrated

·          Reports have been adapted to OV Reporter 3.6

·          Output from management tools and ASCII reports can be saved to file

·          DB2 Administrator data changes can now be followed in the DB2SPI configuration

·          Predefined graphs are available in the OVO/Windows console as with OVPM

·          A number of defects have been fixed.

Installation Notes

Installation requirements, as well as instructions for installing SPI for DB2, are documented in the DB2SPI User’s Guide provided in Adobe Acrobat (.pdf) format. The document file is included on the product's CD media as:

./paperdocs/db2_config.pdf

Not contained in the User’s Guide are upgrade instructions from earlier versions of the DB2SPI;  these are given next.

Upgrade from B.02.08 to B.02.10

What is replaced?

With B.02.10, we do not only change the binaries and configuration items of the DB2SPI, but also the platform.  Older versions of the DB2SPI could be executed on OVO/Windows 7.1 and 7.2, but B.02.10 is supported on OVO/Windows 7.5 only.

B.02.08 has to be removed before B.02.10 can be installed.

If you have changed configurations (policies) in the old system, you need to save them prior to running the de-installation.

What can be preserved on the managed Nodes?

All local configurations that have been made on the managed node ("Config Setup") can be preserved with this upgrade.

Even your metric data that have been stored on the managed nodes are preserved and data storage can be continued.

If you have made changes to policies, you should back them up before doing the upgrade.  Details have been described above.

Upgrade Steps

·          Prepare Prerequisites

There are no special, preparatory steps required except saving old configuration of tools and user roles.

·          Remove DB2SPI B.02.08

Uninstall the old package as described in the DB2SPI User's Guide for B.02.08.

Note: You do not need to remove the DB2 Node Groups.

·          Install DB2SPI B.02.10

In case you had deleted all DB2SPI node groups during the uninstallation of B.02.08, you can install B.02.10 as described in the DB2SPI User's Guide.

If you did not remove the DB2 node groups and their contents during uninstallation of B.02.08, you have to redeploy all DB2SPI policies and instrumentation to the managed nodes contained in these groups.

Make sure you deploy the correct policy group depending on the OS of the managed node. The policy group “DB2SPI” contains one policy group for each platform (Windows, AIX, HP-UX, Linux, Solaris). Please redeploy all policies from the “Auto-Deploy” subfolder.

E.g. for windows managed nodes you have to deploy the policy group “DB2SPI\DB2SPI Windows\Auto-Deploy”.

After you have installed B.02.10 as described above, you have to reapply changes made to tools and user roles or upload those saved formerly.

Enhancements and Fixes

Support of DB2 UDB 8.2

Fixpack 7 of DB2 UDB 8.1 identifies itself as version 8.2 of the database.  The DB2SPI has been extended to detect this version and tested to support it.

DB2 on German Microsoft Windows Nodes

During "Config Setup" the DB2SPI now asks for a language of the database.  Possible answers are German (de) and English (us).

This allows the management of DB2 installed on German localized operating systems, where all messages reported by DB2 are given in German.

Please note, that dialogue answers – like DB2 commands – must still be given in English where applicable ("y/n", not "j/n". for example).

Documentation about Cluster Support

The DB2SPI can be operated in DB2 cluster environments due to the capability to enable / disable all active policies. 

The DB2SPI User's Guide contains a detailed explanation how the integration of the DB2SPI in high availability switch-over concepts can be achieved.

HP Self-Healing Support

HP provides a semi-automatic data collection for support cases, called "Self-Healing Services".

The DB2SPI is integrated into this solution and provides scripts and tools to collect the information needed for "Self-Healing". 

Besides being called from the "Self-Healing Agent" the DB2SPI can also execute a standalone tool for the data collection;  the resulting data set can then be forwarded to HP via eMail, as described in the HP Self-Healing documentation.

OV Reporter 3.6 Support

With OVO/Window 7.5, OV Reporter 3.6 is supported by all SPIs.

The DB2SPI Reporter integration package contains the same functionality as in the previous release, but is usable with OV Reporter 3.6 now, whereas the former packages have been supporting OV Reporter 3.05 and 3.5.

Output saved to File

Most DB2SPI tools have been extended to provide the option of saving the output (which normally goes to the screen) also to a file.

In all these cases, the user is asked a question at the very end if the output is to be saved or not.  Answer "y" (yes) if you want to store the output for later, external usage.

This function is even available if the paged output of the tool has been canceled earlier, because the entire output has already been buffered and therefore is available for storage.

Changing DB2 Administrator data is possible

Sometimes DB2 administrative user data (account, password) are changed in customer environments, for example because of strict security policies.

A new tool, "Change Admin" is available in the console to allow adaptation of the DB2SPI configuration data to changed account information.

Predefined Graphs can be used in OVO/Windows console

DB2SPI now provides predefined graphs for a set of DB2 metrics in the embedded graphing component.  Please see the DB2SPI User's Guide for details.

Defect Fixes

The following items (identified by error tracking number) are fixed in the current software release. To display details about each software fix, click the error tracking number. To hide details, click again.

[901]  Cannot use csh on Unix DB2 managed node

 

PROBLEM:

DB2 instances cannot be used if instance user does not use ksh or sh on Unix

 

CAUSE:

The scripts used internally during the user switching did not expect csh-like input/output

 

FIX:

With this new version of the DB2SPI the current shell of the DB2 instance users is checked and treated correctly

[1034]            Data are not collected for newly discovered databases

 

PROBLEM:

Creating databases after the instance had been set up to be monitored should automatically create data stores for their metric data collection, but that does not happen

 

CAUSE:

A missing function call prevented the DB2SPI to launch the data store definition is CODA / MWA.

 

FIX:

The function call has been added.

[1061]            Some metrics do not track their former values correctly

 

PROBLEM:

Some metrics cause alerts with unreasonably high numbers.

 

CAUSE:

Some metrics calculate the first derivative as the value of interest ("growth rates").  Some metrics stored the original value instead of this delta.

 

FIX:

DB2SPI now stores the proper values.

[1091]            DB2 logfile path name may contain blanks

 

PROBLEM:

On Windows platforms the DB2 diagnostic logfile cannot be found sometimes.

 

CAUSE:

If the path name contained blank(s), the name has not been parsed correctly.

 

FIX:

DB2SPI now considers that the path name may contain blanks.

[1097]            Backup management tool applies wrong syntax

 

PROBLEM:

DB2 management tool "Backup Management" terminates with a DB2 syntax error.

 

CAUSE:

The code defined for the backup command had been wrong.

 

FIX:

DB2SPI now applies the proper code.

[1100]            Metric 0821 has no reasonable threshold

 

PROBLEM:

The DB2SPI monitor for metric 0821 alerts at wrong times.

 

CAUSE:

The threshold value for 0821 was set inappropriately.

 

FIX:

DB2SPI now uses a more reasonable value.

[1101]            Metric 0831 formula is wrong

 

PROBLEM:

Metric 0831 alerts although the base values are okay.

 

CAUSE:

The formula for 0831 defined in db2s_metrics.us.cfg has been faulty.

 

FIX:

DB2SPI now uses a corrected formula.

[1113]            Admin Logfile on Windows DB2 nodes requires event log policy

 

PROBLEM:

No administration log file on Windows managed nodes could be found and gave respective warnings.

 

CAUSE:

The administrative log entries are written to the Windows event log rather than to files as used in Unix environments.

 

FIX:

DB2SPI now uses an event log filter to determine the administrative log entries.

[1151]            OVPA datastore definition wrong, causing OVPM to fail for long term data

 

PROBLEM:

OVPM shows ver large numbers if the time scale is 7 days or longer, although shorter time windows work fine.

 

CAUSE:

The definition of the DB2SPI data stores (MWA / OVPA only) requested a summarization over a text element rather than over a numeric.  This was not detected during the creation of the data store, but when OVPM accessed these data, nonsense (and still no error) was reported

 

FIX:

DB2SPI now does not define the summarization any more, since only time scale makes sense anyway.

[1152]            Missing "DB2_mwalogger_unix" policy

 

PROBLEM:

OVPA (MWA) does not store any data in the standard data stores (Unix only).

 

CAUSE:

With the introduction of the MWA data logger script for Windows, the original one had been removed, but no Unix-specific one had been added.

 

FIX:

DB2SPI now provides a proper schedule policy for Unix nodes.

[1181]            Metric 0933 (free tablespace monitoring) multiple container handling

 

PROBLEM:

Metric 0933 (free tablespace monitoring) gives wrong results if multiple containers are part of the SMS tablespace

 

CAUSE:

Until now the DB2SPI only determined the container (for SMS, this is a file system) with the smallest free space.  However, the  total free space must be taken from ALL assigned file systems, because the used system stored in the DB2 snapshot also contains the written blocks in ALL containers.

 

FIX:

DB2SPI now accumulates the free space of all containers before calculating the percentage.

Known Problems, Limitations, and Workarounds

Limitations

We still have only restricted support of ESE / EEE editions of DB2.  A specific whitepaper can be requested from spi-support@nice.de.

Known Bugs and Problems

The following problems are known to us at the time of delivery of the DB2SPI B.02.10.

·          db2s_make_svctree.pl fails if all databases of an instance are excluded (ID: 521)

Symptom:

The service tree does not get updated in all databases of a monitored instance are excluded from monitoring.

Reason:

The script executing on the management server does not receive information that there is "no database".

Workaround:

None.

·          Instruction Texts missing (ID: 526)

Symptom:

For some events shown in the message browser there are no instruction texts available

Reason:

Due to limited resources in the developer team we have not been able to close all gaps until release.

Workaround:

None.  We are working on an update.

·          Some application output (OVO tool output window, not ATOP) comes late (ID: 637)

Symptom:

For some applications started the output is transferred to the management station very late so the user might feel that the process hangs.

Reason:

Unknown.  There is any synchronization problem with the transfer of the output which needs to be identified.  This is based in the OVO platform.

Workaround:

Be patient.  As we learned, the tools act fine, only their output is affected.

·          Instruction text window opened only after long delay (ID: 661)

Symptom:

Requesting "Instructions …" from the OVO message browser takes quite long sometimes.

Reason:

With a highly loaded OVO management server the processing of the instructions repository (an XML file on the management server) takes pretty long.

Workaround:

Be patient.  We are looking for performance improvements with the next release by splitting up this information in various files.

·          Diagnostic log files are not monitored (ID: 878)

Symptom:

The db2s_diag.pl creates error messages in db2spi.log about missing diagnostic log file information.

Reason:

In some environments, the DATABASE MANAGER CONFIGURATION does not provide information about the path for the diagnostic (or administrative) log files and no error is shown during "Config Setup".

Workaround:

Enter these names manually into the …/conf/db2s_diagfiles.cfg and …/conf/db2s_admfiles.cfg.  For each instance managed, the FQDN of the respective files must be given. [Include information about known problems, limitations, and workarounds.]

Documentation Errata

Local Language Support

This version of the SPI is supported in English and German environments.

Support

Please visit the HP OpenView web site at: http://www.managementsoftware.hp.com/

This web site provides contact information and details about the products, services, and support that HP OpenView offers.

You can also go directly to the support web site at:

http://support.openview.hp.com/

HP OpenView online software support provides customer self-solve capabilities. It provides a fast and efficient way to access interactive technical support tools needed to manage your business. As a valuable support customer, you can benefit by being able to:

§                    Search for knowledge documents of interest

§                    Submit and track progress on support cases

§                    Manage a support contract

§                    Look up HP support contacts

§                    Review information about available services

§                    Enter discussions with other software customers

§                    Research and register for software training

NOTE: Most of the support areas require that you register as an HP Passport user and log in. Many also require an active support contract. To find more information about support access levels, go to the following URL:

http://support.openview.hp.com/access_level.jsp

To register for an HP Passport ID, go to the following URL:

https://passport.hp.com/hpp2/newuser.do

To view release notes and other documentation:

1.      Click using hp software--> product manuals.

The product manuals search window opens. It is located at:

http://ovweb.external.hp.com/lpe/doc_serv/

2.      In the select product list, click SPI for DB2.

3.      In the select version list, click B.02.10.

4.      In the OS list, click [OS type].

5.      To start the search, click Open or Download.

NOTE: To view files in PDF format (*.pdf), Adobe Acrobat Reader must be installed on your system. To download Adobe Acrobat Reader, go to the following URL:

http://www.adobe.com

Legal Notices

&copyCopyright 2005 Hewlett-Packard Development Company, L.P.

The information contained herein is subject to change without notice.

The only warranties for HP products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.