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Support

Please visit the HP OpenView web site at:
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Chapter 1
Overview

This overview covers the following topics

• OVPI and Cisco CallManager

• Folders and reports

• Data collection and data aggregation

• Integration with NNM

• Ways to customize reports; ways to import property data 

• Sources for additional information

OVPI and Cisco CallManager

Improved planning and management of Cisco CallManager installations is the reason the IP 
Telephony Call Detail solution was created. This package contains 30 reports that analyze 
Call Detail Record (CDR) data collected from Cisco CallManager. These reports assess call 
quality, call availability, and call usage. Assuming you collect data once a day (the default), 
the tables and graphs in these reports will be updated once a day. 

Although Cisco CallManager has its own ad hoc reporting capability, those reports are limited 
and harder to produce compared to reports in IP Telephony Call Detail. Following are the 
salient features of this solution:

• Spans multiple CallManager clusters (inter-site reporting)

• Produces rolling baseline statistics

• Produces forecasts derived from rolling baseline statistics

• Performs ongoing analysis and aggregation of IPT records 

• Monitors thresholds and reports threshold breaches

• Integrates with other OVPI reporting solutions, including

— IP Telephony Statistics Report Pack

— Service Assurance Report Pack
7



Folders and Reports
New Objects for the Object Model

An object is any item that has performance data or property information associated with it. 
Devices, customers, and locations are objects, and all three of these object categories belong to 
OVPI’s default object model. When you select an object in the object model, the right side of 
the Object/Property Management window refreshes, showing a list of forms under General 
Tasks, a list of forms under Object Specific Tasks, and a list of reports under Object Specific 
Reports. 

The object tree changes each time you install a new report pack, and some report packs will 
add a new class of objects or services that do not fit within the default model. When this 
happens, the report pack adds a new view. To open the new view, select View > Change View. 

IP Telephony Call Detail adds the following object categories to the object model:

• Cluster

• CallManager

• Gateway

• IP_Phone

Version History

Folders and Reports

IP Telephony Call Detail contains the following report folders: 

• CallManager Cluster

• CallManager

• Gateway

• Phone Number 

• Location 

Version RNS Version and Date Features/Enhancements

1.0 RNS 4.0 - October 2003 30 call detail reports
1 inventory report
Sybase support
OVPI Object Manager support

1.0 RNS 5.0 - April 2004 No changes

2.0 RNS 6.0 - August 2004 Oracle support
Upgrade packages:
• UGRADE_IPT_CallDetails_to_2.0
• UPGRADE_IPT_CallDetails_Admin_to_2.0
• UPGRADE_IPT_CallDetails_Location_to_2.0
8



Chapter 1
Folder contents are as follows:

Reports in the CallManager Cluster Folder

• Cluster History Summary

• Cluster QoS Summary 

• Cluster History Top Ten

• Cluster QoS Top Ten

• Cluster Call Detail Forecast

Reports in the Call Manager Folder

• CallManager History Summary

• CallManager QoS Summary 

• CallManager History Top Ten

• CallManager QoS Top Ten

• CallManager Call Detail Forecast

Reports in the Gateway Folder

• Gateway History Summary by CallManager

• Gateway QoS Summary by CallManager

• Gateway History Top Ten by CallManager

• Gateway QoS Top Ten by CallManager

• Gateway Call Detail Forecast by CallManager

Reports in the Phone Number Folder

• Phone Number History Summary

• Phone Number QoS Summary 

• Phone Number History Top Ten

• Phone Number QoS Top Ten

• Phone Number Call Detail Forecast

Reports in the Location Folder

• Gateway History Summary by Location

• Gateway QoS Summary by Location

• Gateway History Top Ten by Location

• Gateway QoS Top Ten by Location

• Gateway Call Detail Forecast by Location

• Location History Summary

• Location QoS Summary 

• Location History Top Ten
9



Folders and Reports
• Location QoS Top Ten

• Location Call Detail Forecast

Reports in the Admin Folder

The Admin folder contains one inventory report. This report provides a list of clusters, 
CallManagers, gateways, and IP phones. The inventory report reads property tables that are 
created by the Admin module and populated by the CDR Datapipe.

Generic Report Types

Following is a brief description of each report type in the package.

History Summary. Provides summary data about call history from multiple perspectives. 
This report focuses on the Call Success Rate (CSR) percentage, while also providing statistics 
for Total Call Minutes and Total Normal Disconnections. Selection tables rank items by CSR, 
highest to lowest. Investigate CSR more closely by looking at the following graphs:

• Total Call Volume

• Total Call Minutes

• Call Type Distribution 

• Maximum and Average Call Duration per success call

• Abnormal Disconnect Cause 

• Call Duration Distribution 

History Summary Top Ten. Performs a ranking function, using results from yesterday. 
Provides the following tables: 

• Highest Call Volume

• Highest Call Volume Increase

• Most Call Minutes

• Highest Call Minutes Increase

• Worst Call Success Rate 

• Highest CSR Decrease

QoS Summary. Provides summary data about call QoS metrics for multiple perspectives. 
Focuses on the packets lost, jitter, latency, and average QoS. Investigate call QoS more closely 
by looking at the following graphs:

• Calls by QoS Value stacked by:

— Good

— Acceptable

— Fair

— Poor

IP Telephony Call Detail and IP Telephony Statistics use the same Admin 
module. They share the inventory report and they share property tables. 
10



Chapter 1
• Packet Lost 

• Jitter 

• Latency

QoS Top Ten. Performs a ranking function, using results from yesterday. Provides the 
following tables: 

• Highest Packet Lost

• Highest Packet Lost Increase

• Highest Jitter

• Highest Jitter Increase

• Highest Latency 

• Highest Latency Decrease

Forecast reports. Focuses on Total Calls 30, 60, and 90 days from today. You can investigate 
forecasts in more detail by using the following tabbed graphs: 

• Call Volume Forecast

• Call Minutes Forecast

• Call Success Rate Forecast

• Average QoS Forecast 

Use the Standard tab to compare the baseline average to future performance; use the Day of 
Week tab to correlate future performance by day of week; use the History tab to track the data 
used in the forecast. The rolling baseline average is based on 91 days of data.

Data Collection and Aggregation

Cisco CallManager produces two types of call information records: 

• Call Detail Records (CDRs)

• Call Management Records (CMRs)

CDRs store information about call endpoints and other call control/routing details; CMRs 
contain information about the quality of the streamed audio. A preprocessor built into the 
CDR Datapipe processes both record types, producing CSV files. The CDR Datapipe runs a 
collection against these files, populates rate tables, then maps data into hourly tables 
maintained by the report pack. This process provides the report pack with hourly data for the 
following variables: 

• Lost packets

• Jitter

• Latency

• A value for QoS derived from lost packets, jitter, and latency

• Call volume

• Call duration 

• Call Success Ratio (CSR) 
11



Integration with Network Node Manager (NNM)
• Disconnect Cause Distribution

• Call Type Distribution

In accordance with directives from the report pack, OVPI produces hourly, daily, and monthly 
summaries. In addition, OVPI aggregates data by the following perspectives:

• Phone Number 

• Gateway by CallManager

• Gateway by Location

• CallManager 

• CallManager Cluster

• Location 

Integration with Network Node Manager (NNM)

The trending analysis produced by IP Telephony Call Detail is designed to blend smoothly 
with the fault management and diagnostic capabilities of Network Node Manager. If your 
OVPI server and your NNM server are integrated, the NNM operator will see IP Telephony 
Call Detail reports in the Report Launchpad window. This window can be opened from NNM 
ovw, Home Base Dynamic Views, and the NNM alarm browser.

If you install the optional thresholds sub-package, OVPI will send threshold traps to your 
NNM server. The trap sent by OVPI will appear as an alarm in the NNM alarm browser. The 
NNM operator can respond to the alarm by launching the following reports:

• CallManager History Summary

• CallManager QoS Summary

• Gateway History Summary by Location

• Gateway QoS Summary by Location

Ways to Customize Reports

The contents of a report can be customized. Here are your options:

• Apply group filters

• Edit parameters, tables, and graphs

• Add and modify property information, including thresholds

When you apply a group filter, you are changing how the entire package appears to a 
particular group of users. If you edit a report, you are making a temporary change. For more 
information about view options for tables and graphs see Chapter 11, Editing Tables and 
Graphs.
12
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Group Filters

If you intend to share your reports with customers, or let divisions within your enterprise see 
division-specific performance data, you will need reports that contain data limited to one 
customer. Creating customer-specific reports involves the following tasks:

• Importing customers and locations using Common Property Tables

• Creating a group account for all of the users affiliated with a particular customer

• Creating a group filter for the group account

For more information about creating filters for group accounts, refer to the HP OpenView 
Performance Insight 5.0 Administration Guide. 

Importing Property Information

The reports in this package include the following types of property information:

• The ID assigned to a cluster, CallManager, or gateway

• The customer and location associated with a cluster, CallManager, or gateway

• Threshold values assigned to a CallManager, gateway, or QoS parameter

• Users and locations assigned to IP phones

Property information comes from the following sources:

• CDR Datapipe

• Common Property Tables 3.5

• Change forms bundled with IP Telephony Call Detail

If the CDR Datapipe identifies a new CallManager or gateway, it will add that CallManager 
or gateway to Common Property Tables. When that CallManager or gateway appears in 
reports, the following defaults will appear as associated properties:

• Customer Unassigned 

• Location Unassigned 

To associate a customer or a location with a CallManager or a gateway, use the Update Node 
Information form. This form is bundled with Common Property Tables. When you navigate 
the object tree, you will see this form listed under Object Specific Tasks. 

The following properties are imported using forms bundled with IP Telephony Call Detail:

• CallManager thresholds

— Call Success threshold

— Network Fail threshold

— QoS threshold

• Gateway thresholds

— Call Success threshold

— Network Fail threshold

— QoS threshold
13



Ways to Customize Reports
• Gateway dial plans

— International call prefix

— Local area codes 

— Toll free codes

• IP phone properties

— User

— Location

• QoS thresholds

— Packet loss

— Jitter

— Latency

For more details about forms, see Chapter 4, Package Configuration.

Editing Parameters

Editing a parameter applies a constraint. The constraint filters out the data you do not want 
to see. If you were to edit the Customer Name parameter, data for every customer except the 
customer you typed in the Customer Name field would drop from the report. Similarly, if you 
edited the Location, data for all locations except the location you typed in the Location field 
would drop from the report. 

Filtering the contents of a report by editing parameters is completely optional and you may 
apply multiple constraints at once. IP Telephony Call Detail supports the following 
parameters:

• Customer Name

• Location

• Cluster

• CallManager

• Gateway

• Phone number

If you are using the Web Access Server to view reports remotely, edit parameters by clicking 
the Edit Parameters icon at the bottom right-hand corner of the report. When the Edit 
Parameters window opens, enter the constraint in the field and click Submit. 

If you are using Report Viewer, select Edit > Parameter Values from the menu bar. When the 
Modify Parameter Values window opens, click the Current Value field. Type a new value and 
click OK.

Assigning a dial plan to each of your gateways is mandatory; if this 
step is not taken, the report pack will not function properly. 
14
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Sources for Additional Information

This guide contains samples of some of the reports in the Call Detail package. The demo 
package that comes with the package contains a sample of every report in the package. If you 
have access to the demo package and you want to know what fully-populated reports look like, 
install the demo package. Like real reports, demo reports are interactive. Unlike real reports, 
demo reports are static.

For information regarding the latest enhancements to this package and any known issues 
affecting its operation, refer to the IP Telephony Call Detail Report Pack 2.0 Release Statement. 
You may also be interested in the following documents: 

• Service Assurance Report Pack 3.0 User Guide

• Cisco IP Telephony Statistics 3.0 User Guide 

• Common Property Tables 3.5 User Guide

• Thresholds Module 5.0 User Guide 

• NNM / Performance Insight Integration Module 2.0 User Guide 

• RNS 6.0 Release Notes, August 2004 

User guides for OVPI and the reporting solutions that run on OVPI can be downloaded 
from the following web site:

http://www.hp.com/managementsoftware

Select Technical Support > Product Manuals to reach the Product Manuals Search page. The user 
guides for OVPI are listed under Performance Insight. The user guides for reporting solutions 
are listed under Reporting and Network Solutions. 

Each title listed under Reporting and Network Solutions 6.0 indicates the date of publication. If a 
manual is revised and later reposted, the date of publication will change even if the software 
version number does not change. Since revised user guides are posted to this site on a regular 
basis, you should search this site for updates before using an older PDF that may not be the 
latest PDF available. 
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Chapter 2
The Upgrade Install

This chapter covers the following topics:

• Guidelines for a smooth upgrade

• Using Package Manager to install the upgrade packages

• Package removal

Guidelines for a Smooth Upgrade

When you insert the RNS CD, launch the extraction interface, and select OVPI report packs 
for installation, the install script extracts every OVPI package from the CD and copies the 
results to the Packages directory on your system. Once the extraction process finishes, the 
install script prompts you to launch Performance Insight and start the Package Manager 
install wizard. Before starting Package Manager, review the following guidelines.

Prerequisites for Installing the Upgrade Package

The following software must be in place before upgrading from version 1.0 to 2.0:

• OVPI 5.0

• All service packs currently available for OVPI 5.0

• Common Property Tables 3.0 or later

• IP Telephony Call Detail 1.0

• IP Telephony Call Detail Admin 1.0

• IP Telephony Call Detail Location 1.0 (optional)

• Cisco CDR Datapipe 1.0

The Admin sub-package is shared by two report packs, IP Telephony 
Statistics and IP Telephony Call Detail. If you or someone else has already 
upgraded the IP Telephony Statistics Report Pack, then the Admin sub-
package has already been upgraded.
17



Installing the 1.0-to-2.0 Upgrade
Distributed Environments

If you are running IP Telephony Call Detail in a distributed environment, the upgrade is more 
complicated. These are the steps to follow:

1 Disable trendcopy on the central server.

2 Install the following packages on the central server:

• UPGRADE_IPT_CallDetails_Admin_to_2.0; deploy reports

• UPGRADE_IPT_CallDetails_to_2.0; deploy reports 

• UPGRADE_IPT_CallDetails_Location_to_2.0

3 Delete the existing datapipe.

4 Install Cisco CDR Datapipe 2.0. 

5 For each satellite server:

• Install the following packages:

— UPGRADE_IPT_Admin_to_2.0; do not deploy reports

— UPGRADE_IPT_CallDetails_to_2.0; do not deploy reports

— UPGRADE_IPT_CallDetails_Location_to_2.0

• Delete the existing datapipe.

• Install Cisco CDR Datapipe 2.0.

6 When you finish upgrading the satellite servers, re-enable trendcopy on the central 
server.

When you installed IP Telephony Call Detail 1.0 on OVPI 4.6, you had to run DS EDIT to set 
up connections with satellite server databases, configure trendcopy pull commands, and 
switch off aggregations at each satellite server. Because the technique for setting up 
connections with satellite server databases is different in OVPI 5.0, the following tasks must 
be repeated soon after you install IP Telephony Call Detail 2.0:

• Setting up connections with satellite databases (using the Add Database Wizard)

• Configuring trendcopy pull commands

For details, see Chapter 5, Distributed Systems.

Upgrading Common Property Tables

If you are running Common Property Tables 2.2, you must upgrade to the latest version. Do 
this by installing the version 2.2-to-3.0 upgrade package. Installing this upgrade package is 
no different from installing any other upgrade package. However, you cannot install this 
upgrade and other packages at the same time. Install the upgrade package for Common 
Property Tables and only the upgrade package for Common Property Tables.

Installing the 1.0-to-2.0 Upgrade

Perform the following tasks to upgrade to IP Telephony Call Detail 2.0:
18



Chapter 2
• Task 1: Extract packages from the RNS 6.0 product CD

• Task 2: If necessary, upgrade to Common Property Tables 3.0 or higher

• Task 3: Install UPGRADE_IPT_CallDetails_Admin_to_2.0

• Task 4: Install UPGRADE_IPT_CallDetails_to_2.0

• Task 5: Install UPGRADE_IPT_CallDetails_Location_to_2.0 (optional)

• Task 6: Delete Cisco CDR Datapipe 1.0

• Task 7: Install Cisco CDR Datapipe 2.0

Task 1: Extract Packages from the RNS 6.0 CD to the Packages directory on your system

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Insert the RNS 6.0 CD. On Windows, a Main Menu displays automatically; on UNIX, 
mount the CD if it does not mount automatically, then navigate to the top-level directory 
on the CD and run the ./setup command. 

4 Type 1 in the choice field and press Enter. The install script displays a percentage 
complete bar. When the copy is complete, the install script starts Package Manager. The 
Package Manager welcome window opens.

Once the copy to the Packages directory is complete, you have the option of navigating to the 
Packages directory. The Packages directory will contain a folder for IP Telephony Call Details 
and a separate folder for the Cisco CDR Datapipe. Under IP Telephony Call Detail you will 
see the following folders:

• IPT_CallDetails_Admin.ap

• IPT_CallDetails.ap

• IPT_CallDetails_Demo.ap

• IPT_CallDetails_Location.ap

• IPT_CallDetails_Thresholds.ap

• UPGRADE_IPT_CallDetails_Admin_to_2.ap

• UPGRADE_IPT_CallDetails_to_2.ap

• UPGRADE_IPT_CallDetails_Location_to_2.ap

Under the Cisco CDR Datapipe folder, you will see the following folder:

• CiscoCDR_Datapipe.ap

This 

If your system is distributed, do not install the datapipe on the central server.
19



Installing the 1.0-to-2.0 Upgrade
Task 2: Upgrade to Common Property Tables 3.0 or higher

IP Telephony Call Detail 2.0 requires Common Property Tables 3.0 or higher. If you have not 
already upgraded, do this now. Do not install other packages when you upgrade Common 
Property Tables. If you need help with the upgrade, refer to the Common Property Tables 3.5 
User Guide. When installation of the upgrade finishes, click Done to return to the Management 
Console.

Task 3: Install IPT_CallDetails_Admin_to_2.0

1 Start Package Manager. The Package Manager welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install.

4 Approve the default installation directory or select a different directory if necessary. 

5 Click Next. The Report Deployment window opens.

6 Accept the default for Deploy Reports; accept the defaults for application server name and 
port.

7 Type your user name and password for the OVPI Application Server. 

8 Click Next. The Package Selection window opens. 

9 Click the check box next to the following package:

• UPGRADE_IPT_CallDetails_Admin_to_2.ap

10 Click Next. The Type Discovery window opens. 

11 Disable the default and click Next. The Selection Summary window opens.

12 Click Install. The Installation Progress window opens and the install process begins. When 
the install finishes, an installation complete message appears.

13 Click Done to return to the Management Console. 

Task 4: Install UPGRADE_IPT_CallDetails_to_2.0 

Repeat Task 3. When the Package Selection window opens, select the following package:

UPGRADE_IPT_CallDetails_to_2.0

When the install finishes, an installation complete message appears. Click Done to return to 
the Management Console. 

Task 5: Install IPT_CallDetails_Location_to_2.0 

Repeat Task 3. When the Package Selection window opens, select the following package:

UPGRADE_IPT_CallDetails_Location_to_2.0

When the install finishes, an installation complete message appears. Click Done to return to 
the Management Console. 

Task 6: Remove Cisco CDR Datapipe 1.0 

1 Start Package Manager. The Package Manager welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Uninstall.
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4 Click Next. The Report Undeployment window opens.

5 Accept the defaults for Undeploy Reports, Application Server Name, and Port. 

6 Type the username and password for trendadm.

7 Click Next. The Package Selection window opens. 

8 Click the check box next to the following package:

CiscoCDR_Datapipe 1.0

9 Click Next. The Selection Summary window opens. 

10 Click Uninstall. The Progress window opens and the removal process begins. When 
removal finishes, a removal complete message appears. 

11 Click Done to return to the Management Console.

Task 7: Install Cisco CDR Datapipe 2.0; restart OVPI Timer

1 Start Package Manager. The Package Manager welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install.

4 Approve the default installation directory or select a different directory if necessary. 

5 Click Next. The Report Deployment window opens.

6 Disable the default for Deploy Reports; accept the defaults for application server name 
and port.

7 Type your user name and password for the OVPI Application Server. 

8 Click Next. The Package Selection window opens. 

9 Click the check box next to the following package:

Cisco CDR Datapipe 2.0

10 Click Next. The Type Discovery window opens. 

11 Disable the default and click Next. The Selection Summary window opens.

12 Click Install to begin the installation process. The Installation Progress window opens and 
the install process begins. When the install finishes, an installation complete message 
appears.

13 Click Done to return to the Management Console. 

14 Restart OVPI Timer.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start
21



Package Removal
Package Removal

If you remove a report pack, the associated tables and all the data in those tables will be 
deleted. If you want to preserve the data in those tables, archive the data before removing the 
package. 

Follow these steps to uninstall IPT Call Detail and the associated packages.

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Start Package Manager. The Package Manager welcome window opens.

4 Click Next. The Package Location window opens.

5 Click Uninstall.

6 Click Next. The Report Undeployment window opens.

7 Accept the defaults for Undeploy Reports, Application Server Name, and Port. 

8 Type the username and password for trendadm.

9 Click Next. The Package Selection window opens. 

10 Click the check box next to the following packages:

IPT_CallDetails

IPT_CallDetails_Admin

IPT_CallDetails_Location (if installed) 

IPT_CallDetails_Thresholds (if installed) 

IPT_CallDetails_Demo (if installed)

CiscoCDR_Datapipe

11 Click Next. The Selection Summary window opens. 

12 Click Uninstall. The Progress window opens and the removal process begins. When 
removal finishes, a removal complete message appears. 

13 Click Done to return to the Management Console.

14 Restart OVPI Timer.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start
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The New Install

This chapter covers the following topics:

• Guidelines for a smooth installation

• Using Package Manager to install the report pack and associated packages

• Options for viewing reports

• Package removal

Guidelines for a Smooth Install

The reporting solutions created for OVPI consist of two packages: a report pack and a 
datapipe, or sometimes a report pack and multiple datapipes. When you install a datapipe, 
you direct OVPI to collect a specific type of performance data at a specific polling interval. 
When you install a report pack, you direct OVPI to summarize and aggregate performance 
data in a specific way. 

The RNS 6.0 CD contains packages for NNM and OVPI. When you insert the RNS CD, launch 
the package extraction interface, and select OVPI packages for installation, the install script 
extracts every OVPI package from the CD and copies the results to the Packages directory on 
your system. When the extraction process finishes, the install script prompts you to launch 
Performance Insight and start Package Manager. 

If the OVPI packages on the RNS 6.0 CD have already been copied to the Packages directory 
on your system, IP Telephony Call Detail is ready to install. Before running Package Manager, 
review the following guidelines.

Prerequisites for a New Install

The following software must be in place before installing the IPT Call Detail package:

• OVPI 5.0

• All service packs available for OVPI 5.0

Details about each service pack, including installation instructions, can be found in release 
notes for the service pack. 
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Distributed Environments

If you intend to run this package in a distributed environment, installation is more 
complicated. The rules are as follows:

• Make sure that every server is running the same release of OVPI.

• Make sure that every server is running the same service packs.

• Disable trendcopy on the central server.

• Install the following packages on the central server:

— IPT CallDetails Admin; deploy reports

— IPT CallDetails; deploy reports 

— IPT CallDetails Location

— IPT CallDetails Thresholds

— Thresholds Module (Threshold and Event Generation)

— Common Property Tables 3.5

• Install the following packages on each satellite server:

— IPT CallDetails Admin; do not deploy reports

— IPT CallDetails; do not deploy reports

— IPT CallDetails Location sub-package

— Common Property Tables 3.5

• Re-enable trendcopy on the central server.

After the installation is complete, you must configure the central server to pull data from each 
satellite server, and you must disable daily aggregations on each satellite server. These tasks 
are covered in Chapter 5, Distributed Systems.

Upgrading Common Property Tables

IP Telephony Call Detail requires Common Property Tables 3.0 or higher. If you are installing 
everything for the first time, there is nothing for you to do regarding Common Property 
Tables; the install wizard will install Common Property Tables for you, automatically.

If you are running Common Property Tables 2.2, you must upgrade to the latest version. Do 
this by installing the version 2.2-to-3.0 upgrade package. Installing the upgrade package is no 
different from installing other packages. However, keep in mind that you cannot install the 
upgrade and other packages at the same time. Install the upgrade package for Common 
Property Tables and only the upgrade package for Common Property Tables.

Integration with the NNM Alarm Browser

If NNM and OVPI are integrated, the threshold breaches spotted by OVPI can be detected by 
NNM. To take advantage of this feature, install the optional thresholds sub-package. This 
sub-package contains default threshold settings. If necessary, these settings can be modified 
using the forms described in Chapter 4, Package Configuration.
24



Chapter 3
The thresholds sub-package cannot operate unless the Threshold and Event Generation 
Module, more commonly known as the Thresholds Module, is also installed. Although there 
are configuration options for the Thresholds Module, the Thresholds Module operates without 
user intervention. Configuring the Thresholds Module is optional.

If you are running the previous version of the Thresholds Module, you may upgrade to the 
current release. For more information about configuration options and the recent changes to 
this package, refer to the Thresholds Module 5.0 User Guide. 

Installable Packages and Sub-Packages

Once OVPI packages have been extracted to the Packages directory on your system, the 
following packages will be available for installation:

• IPT_Admin.ap

• IPT_CallDetails.ap

• IPT_CallDetails_Location.ap

• IPT_CallDetails_Thresholds.ap

A brief description of each package follows.

IPT_Admin.ap

IPT_Admin.ap allows the IP Gateway Statistics and IPT Call Detail packages to share 
property data for the objects they have in common. Sharing property data eliminates 
duplication, allows the database to operate more efficiently, and simplifies administration. 
The IPT_Admin.ap module creates the following tables:

• K_IPT_Cluster — for IP Telephony CallManager clusters

• K_IPT_CManager — for IP Telephony CallManagers

• K_IPT_gateway — for the gateways associated with CallManagers 

• K_IPT_gateway_loc — for the gateways associated with locations

• K_IPT_phoneNum — for the IP phones associated with CallManagers

• K_IPT_loc — for the IP phones associated with locations

• K_IPT_Qos — for QoS parameters

The data in these tables can be modified using the property update forms described in 
Chapter 4, Package Configuration.

IPT_CallDetails.ap

The main package. Provides summarization and aggregation directives to OVPI. 

IPT_CallDetails_Location.ap

An optional sub-package that makes it possible to see usage patterns and trends aggregated 
by location. 
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IPT_CallDetails_Thresholds.ap

An optional sub-package that sets thresholds for performance, generates exception traps 
when a threshold is breached, and sends traps to NNM. The Thresholds Module is also 
required if you wish to use this sub-package. (If you install the thresholds sub-package, 
Package Manager will install the Thresholds Module automatically.)

Installing IP Telephony Call Detail

Perform the following tasks to install IP Telephony Call Detail 2.0:

• Task 1: Stop OVPI Timer and extract packages from the product CD.

• Task 2: If necessary, upgrade to Common Property Tables 3.0 or higher. 

• Task 3: Install these packages:

— IPT CallDetails 2.0

— Cisco CDR Datapipe 2.0

— IPT CallDetails Thresholds (optional)

— IPT CallDetails Location (optional)

— IPT CallDetails Demo (optional)

Task 1: Stop OVPI Timer and extract packages from the RNS CD

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Insert the RNS 6.0 product CD. On Windows, a Main Menu displays automatically; on 
UNIX, mount the CD if it does not mount automatically, then navigate to the top level 
directory on the CD and run the ./setup command. 

4 Type 1 in the choice field and press Enter. The install script displays a percentage 
complete bar. When the copy is complete, the install script starts Package Manager. The 
Package Manager welcome window opens.

When the copy to the Package directory finishes, you can navigate to the Packages directory. 
The Packages directory contains a folder for IP Telephony Call Details and a separate folder 
for the Cisco CDR Datapipe. The following folders appear under the IP Telephony Call Detail 
folder:

• IPT_CallDetails.ap

• IPT_CallDetails_Demo.ap

This 

This procedure is intended for a stand-alone system. If your system is 
distributed, do not install the datapipe on the central server.
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• IPT_CallDetails_Location.ap

• IPT_CallDetails_Thresholds.ap

• UPGRADE_IPT_CallDetails.ap

• UPGRADE_IPT_CallDetails_Location.ap

The following folder appears under the Cisco CDR Datapipe folder:

• CiscoCDR_Datapipe.ap

The upgrade packages listed above do not apply to you. Installing the demo package is 
optional. You may install the demo package by itself, with no other packages, or you may 
install the demo package along with everything else. 

Task 2: Upgrade to Common Property Tables 3.0 or higher

IP Telephony Call Detail 2.0 requires Common Property Tables 3.0 or higher. If you have not 
already upgraded to Common Property Tables 3.0, do this now. If you need help with the 
upgrade, refer to the Common Property Tables 3.5 User Guide. When installation of the 
upgrade finishes, click Done to return to the Management Console.

Task 3: Install IP Telephony Call Detail, the Datapipe, and Optional Sub-Packages

1 Start Package Manager. The Package Manager welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install.

4 Approve the default installation directory or select a different directory if necessary. 

5 Click Next. The Report Deployment window opens.

6 Accept the default for Deploy Reports; also accept the defaults for application server name 
and port.

7 Type your user name and password for the OVPI Application Server. 

8 Click Next. The Package Selection window opens. 

9 Click the check box next to the following packages:

IPT_CallDetails 2.0

IPT_CallDetails_Admin 2.0

IPT_CallDetails_Location 2.0

IPT_CallDetails_Thresholds

CiscoCDR_Datapipe 2.0

10 Click Next. The Type Discovery window opens. 

11 Disable the default and click Next. The Selection Summary window opens.

If your system is distributed, the thresholds sub-package belongs on the 
central server, not on satellite servers; this is because you are setting 
thresholds against daily data, not hourly data. 

The CiscoCDR Datapipe belongs on any server that polls.
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12 Click Install to begin the installation process. The Installation Progress window opens and 
the install process begins. When the install finishes, an installation complete message 
appears.

13 Click Done to return to the Management Console. 

14 Restart OVPI Timer.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start

Options for Viewing Reports

Before reports can be viewed using a web browser, they must be deployed. During the 
preceding installation step, you enabled the Deploy Reports option. As a result, IP Telephony 
Call Detail reports are deployed and available for remote viewing. 

The method of report viewing available to you depends on how OVPI was installed. If the 
client component is installed on your system, you have access to the Report Viewer, Report 
Builder, and Management Console. If the client component was not installed on your system, 
use the Web Access Server to view reports.

For more information about the client components, refer to the Performance Insight 
Installation Guide. For more information about Object Manager and viewing reports specific 
to selected objects, refer to the Performance Insight Administration Guide. For more 
information about deploying, viewing, and undeploying reports, refer to the Performance 
Insight Guide to Building and Viewing Reports. 

Package Removal

If you remove a report pack, the associated tables and all the data in those tables will be 
deleted. If you want to preserve the data in those tables, archive the data before removing the 
package. Follow these steps to uninstall IPT Call Detail and the associated packages.

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Select HP OpenView > Performance Insight > Package Manager. The Package Manager 
welcome window opens.

4 Click Next. The Package Location window opens.

5 Click Uninstall.

6 Click Next. The Report Undeployment window opens.
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7 Accept the defaults for Undeploy Reports, Application Server Name, and Port. 

8 Type the username and password for trendadm.

9 Click Next. The Package Selection window opens. 

10 Click the check box next to the following packages:

IPT_CallDetails

IPT_CallDetails_Admin

IPT_CallDetails_Location (if installed) 

IPT_CallDetails_Thresholds (if installed) 

IPT_CallDetails_Demo (if installed)

CiscoCDR_Datapipe

11 Click Next. The Selection Summary window opens. 

12 Click Uninstall. The Progress window opens and the removal process begins. When 
removal finishes, a removal complete message appears. 

13 Click Done to return to the Management Console.

14 Restart OVPI Timer.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start
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Chapter 4
Package Configuration

This chapter covers the following topics: 

• Configuring a data source

• Assigning dial plans to gateways

• Default thresholds for CallManagers and gateways

• Modifying users and locations for IP phones

• Modifying QoS parameters

Configuring a Data Source

If you are running OVPI on Windows, you have two ways to collect call data:

• The CDR Datapipe can read CSV-format flat files exported by CallManager.

• The CDR Datapipe can collect CallDetail data directly from the CallManager SQL Server 
database.

If you are running OVPI on UNIX, your only option is to collect CallDetail data from CSV-
format flat files exported by CallManager. If you are running OVPI on Windows, you have the 
option of collecting call data directly from the CallManager SQL Server database.

This section provides procedures for the following tasks:

• Configuring CallManager to schedule exports from the appropriate tables

• Defining an ODBC data source 

Whether you are collecting data from flat files exported by CallManager, or collecting data 
directly from the SQL Server database, the preprocessor built into the CDR Datapipe needs to 
be able to locate the raw data before it can make the raw data ready for the CDR Datapipe. 
The preprocessor is configured to use a default directory; however, you can select a different 
local directory or, if necessary, specify a directory on the CallManager server.

This step is mandatory. The report pack will not operate correctly 
until you have assigned a dial plan to every gateway.
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Configuring CallManager to Schedule Exports

This section provides procedures for the following tasks:

• Scheduling an export from the CallDetailRecord table

• Scheduling an export from the CallDetailRecordDiagnostic table

Schedule an Export from the CallDetailRecord Table

To schedule exporting data of the table CallDetailRecord in the database CDR, go through 
following steps:

1 Select Start > Programs > Microsoft SQL Server > Enterprise Manager. The SQL Server 
Enterprise Manager window opens.

2 Select Console Root > Microsoft SQL Servers > SQL Server Group and select the SQL server 
name in the Tree window.

3 Select Tool > Data Transformation Services > Export Data. The DTS Import/Export Wizard 
opens.

4 Click Next. The Choose a Data Source window opens.

5 Select CDR in the Database drop-down list.

6 Click Next. The Choose a Destination window opens.

7 Select Text File in the Destination drop-down list.

8 Type the path\filename in the File name field. For example:

C:\IPT_CDR\CallDetailRecord.csv 

9 Click Next. The Specify Table Copy or Query window opens.

10 Click Use a query to specify the data to transfer.

11 Click Next. The Type SQL Statement window opens.

12 Type the following SQL statement in the Query statement window:

"select cdrRecordType,

globalCallID_callManagerID, 
globalCallID_callID,
dateTimeOrigination,
origSpan,
origIpAddr,
CallingPartyNumber,
origCause_value,
origMediaTransportAddress_IP,
origMediaCap_payloadCapability,
destSpan,
destIpAddr,
finalCalledPartyNumber,
destCause_value,
destMediaTransportAddress_IP,

The .csv extension is required.
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destMediaCap_payloadCapability,
dateTimeConnect,
dateTimeDisconnect,
duration,
origDeviceName,
destDeviceName,
globalCallID_ClusterID 
from CallDetailRecord

13 Click Next. The Select Destination File Format window opens.

14 Click Next by accepting default settings. The Save, schedule, and replicate package 
window opens.

15 Mark the Schedule DTS package for later execution check box. 

16 Click Next. The Save DTS Package window opens.

17 Type the name of your DTS package in the Name field. For example:

Export_CDRs

18 Click Next. The Summary window of the DTS Import/Export Wizard opens.

19 Click Finish if there is no error in the Summary window. 

20 Click OK if a pop-up window opens with this message:

Successfully copied a table from the Microsoft SQL Server to flat File.

If you see an error message, fix the problem, then repeat these steps.

21 Click Done in the Executing Package window.

Schedule an Export from the CallDetailRecordDiagnostic Table

Follow these steps to schedule an export of data from the CallDetailRecordDiagnostic table:

1 Repeat steps 1 through 11 above.   

2 Type the following SQL statement in the Query statement window:

"select cdrRecordType, 

globalCallID_callManagerID, 
globalCallID_callID, 
dateTimeStamp, 
numberPacketsSent, 
numberOctetsSent, 
numberPacketsReceived,
numberOctetsReceived,
numberPacketsLost,
jitter,
latency,
deviceName,
globalCallID_ClusterID

from CallDetailRecordDiagnostic 
where datediff(day,dateadd(second,dateTimeStamp,'1/1/
1970'),getdate())=1"
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where datediff(day,dateadd(second,dateTimeDisconnect,'1/1/
1970'),getdate())=1".

3 Repeat steps 13 through 16 above.

4 Type the name of your DTS package in the Name field. For example:

Export_CMRs

5 Repeat steps 18 through 21 above.

Defining an ODBC Data Source (Windows Only)

If you are running OVPI on Windows, you have the option of collecting CallDetail data 
directly from the CallManager SQL Server database. Follow these steps to define an ODBC 
data source.

1 Make sure that Perl module DBD::ODBC is installed. Type this command: 

perl -e "use DBD::ODBC;"

If no error message appears, the DBD::ODBC module is installed. If the module is not 
installed, use PPM to download and install the module. 

2 Select Settings > Control Panel > Administrative Tools. The Administrative Tools window 
opens.

3 Click Data Sources (ODBC). The ODBC Data Source Administrator window opens.

4 Select the System DSN tab. 

5 Click Add. The Create New Data Source window opens.

6 Select SQL Server as the driver. 

7 Click Finish. The next window opens for inputting DSN information.

8 Type a name in the Name field. For example:

CiscoCDR

This name will be used for the –m option for the CiscoCDR_PP.pl.

9 Type the SQL Server name you want to connect. For example:

CallManager1

10 Click Next. 

11 Click this radio button: With SQL Server authentication using a login ID and password entered 
by the user.

12 Type your user name and password. (The username and password that are registered in 
the Cisco CallManager SQL Server database.)

13 Click Next.

14 Click this radio button: Change the default database to and select CDR in the drop-down 
list.

15 Click Next.

16 Click Finish.

17 Click Test Data Source.
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18 Click OK if you see this message in a pop-up window: TESTS COMPLETED SUCCESSFULLY! 
If an error message displays, fix the problem and repeat the steps above.

19 Click OK.

20 Click OK again.

Data Source Directories

This section covers:

• Changing the default local directory

• Using an FTP session

• Using an ODBC connection

Changing the Default Directory

If you are using the default local directory, the preprocessor will look for raw data in the 
following directory: 

${DPIPE_HOME}/data/ImportData/CiscoCDR_Datapipe

If this directory does not exist, create it under the OVPI home directory. If you want to change 
the default, follow these steps:

1 Open this file:

{DPIPE_HOME}/scripts/CiscoCDR_Collection.pro

2 Locate this line:

{DPIPE_HOME}/bin/perl {DPIPE_HOME}/bin/CiscoCDR_PP.pl

3 Change that line to:

{DPIPE_HOME}/bin/perl {DPIPE_HOME}/bin/CiscoCDR_PP.pl -l <<new directory path>>

4 Locate this line:

DPIPE_HOME}/bin/ee_collect -a CiscoCDR_CDRs 

5 Change that line to:

{DPIPE_HOME}/bin/ee_collect -a CiscoCDR_CDRs -s <<new directory path>>/CDRs.dat

6 Locate this line:

DPIPE_HOME}/bin/ee_collect -a CiscoCDR_Hist_phoneNum 

7 Change that line to:

{DPIPE_HOME}/bin/ee_collect -a CiscoCDR_Hist_phoneNum -s <<new directory path>>/
CDRs_phone.dat

8 Locate this line:

DPIPE_HOME}/bin/ee_collect -a CiscoCDR_CMRs

9 Change that line to:

{DPIPE_HOME}/bin/ee_collect -a CiscoCDR_CMRs -s <<new directory path>>/CMRs.dat
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Using an FTP Session

If CallManager is storing raw data on a remote machine, configure the preprocessor to FTP 
those files from the remote machine to your OVPI server. Follow these steps: 

1 Open this file:

{DPIPE_HOME}/scripts/CiscoCDR_Collection.pro

2 Locate this line:

{DPIPE_HOME}/bin/perl {DPIPE_HOME}/bin/CiscoCDR_PP.pl

3 Change that line to:

{DPIPE_HOME}/bin/perl {DPIPE_HOME}/bin/CiscoCDR_PP.pl -f 1 -m <<Remote_Host_Name>> -
u <<username>> -p <<password>> -r <<Remote_directory>>

Using an ODBC Connection

Follow these steps to configure the preprocessor to use an ODBC Connection.

1 Open this file:

{DPIPE_HOME}/scripts/CiscoCDR_Collection.pro

2 Locate this line:

{DPIPE_HOME}/bin/perl {DPIPE_HOME}/bin/CiscoCDR_PP.pl

3 Change that line to:

{DPIPE_HOME}/bin/perl {DPIPE_HOME}/bin/CiscoCDR_PP.pl -f 2 -m <<ODBC_DSN_Name>> -u 
<<username>> -p <<password>> 

Assigning Dial Plans to Gateways

The IPT Call Detail Report Pack will not operate correctly until you have assigned a dial plan 
to every gateway. Do this as soon as possible. Follow these steps to configure dial plans:

1 Start the Management Console.

2 Click Objects. The Object/Property Management window opens. 

3 Select View > Change View > Cluster.

4 Select a cluster.

5 Open a CallManager folder and select a gateway. You will see the Configure Gateway Dial 
Plan form under Object Specific Tasks.

6 Double-click Configure Gateway Dial Plan. The form opens.

7 Modify the following fields:

— International call prefix

This option applies to OVPI servers running on Windows only. 
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— Local area codes

— Toll free codes

8 Click Apply to save changes, OK to save changes and close the form, or Cancel to close the 
form without saving changes.

9 Repeat this procedure for every gateway.

Default Thresholds 

The thresholds sub-package imposes six defaults. Three defaults pertain to CallManagers and 
three defaults pertain to gateways. When performance reaches a default, the thresholds sub-
package sends a trap to the network management system. The following table indicates the 
default setting, the breach condition, and the severity associated with the breach condition. 

Threshold Default Breach Condition Severity

Call Success 50% Call success ratio is below the threshold. Warning

Network Fail 50% The ratio of failed calls caused by network 
problems exceeds the threshold. 

Warning
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Modifying Default Thresholds

Two forms are available for modifying the default thresholds in the preceding table:

• Modify CallManager Call Detail Thresholds 

• Modify Gateway Call Detail Thresholds   

CallManager Thresholds

Follow these steps to modify default thresholds for CallManagers:

1 Start the Management Console.

2 Click Objects. The Object/Property Management window opens. 

3 Select View > Change View > Cluster.

4 Select a cluster.

5 Open a CallManager folder and select a CallManager. You will see the Modify 
CallManager Call Detail Thresholds form under Object Specific Tasks.

QoS 3.0 Average QoS value for all calls exceeds the 
threshold. 

Warning

Threshold Default Breach Condition Severity
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6 Double-click Modify CallManager Call Detail Thresholds. The form opens.

7 Modify one or more defaults. 

8 Click Apply to save changes, OK to save changes and close the form, or Cancel to close the 
form without saving changes.
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Gateway Thresholds

Follow these steps to modify default thresholds for gateways:   

1 Start the Management Console.

2 Click Objects. The Object/Property Management window opens.

3 Select View > Change View > Location. 

4 Select a location. 

5 Open the Gateway folder and select a gateway. You will see the Modify Gateway Call 
Detail Thresholds form under Tasks Specific to the Selected Objects.

6 Double-click Modify Gateway Call Detail Thresholds. The form opens.

7 Modify one or more defaults. 

8 Click Apply to save changes, OK to save changes and close the form, or Cancel to close the 
form without saving changes.
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Modifying IP Phone User and Location

Follow these steps to modify default thresholds for gateways:   

1 Start the Management Console.

2 Click Objects. The Object/Property Management window opens.

3 Select View > Change View > Cluster. 

4 Select a location. 

5 Open the CallManager folder.

6 Open the IP phone folder and select an IP phone. You will see the Configure IP Phone 
User and Location form under Tasks Specific to the Selected Objects.

7 Double-click Configure IP Phone User and Location. The form opens.

8 Add the user and location, for multiple IP phones if necessary. 

9 Click Apply to save changes, OK to save changes and close the form, or Cancel to close the 
form without saving changes.
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Modify IP QoS Parameters

Follow these steps to modify default QoS definition ranges:   

1 Start the Management Console.

2 Click Objects. The Object/Property Management window opens.

3 You will see the Modify QoS Parameters form under General Tasks.

4 Double-click Modify QoS Parameters. The form opens.

5 Modify defaults for Good, Acceptable, Fair. 

6 Click Apply to save changes, OK to save changes and close the form, or Cancel to close the 
form without saving changes.
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Chapter 5
Distributed Systems

If you intend to run IPT Call Detail as a distributed system, and you followed the instructions 
in the installation chapter, you installed packages on the central server and each satellite 
server. The following packages are installed on the central server:

• IP Telephony Call Detail 2.0

• Location Sub-Package (optional)

• Thresholds Sub-Package (optional)

• Common Property Tables 3.5

The following packages are installed on each satellite server:

• IP Telephony Call Detail 2.0

• Location Sub-Package (optional)

• Common Property Tables 3.5

• Cisco CDR Datapipe

Your next step is to configure the central server to pull data from each satellite server. This is 
done by setting up connections from the central server to each satellite server database and 
by configuring trendcopy pull commands for each satellite server database. You also must 
disable daily aggregations on each satellite server.

Configuring the Central Server

To configure the central server, perform these tasks:

• Task 1: Set up connections with satellite server databases

• Task 2: Configure trendcopy pull commands for hourly data 

In addition to performing these tasks, it is important to verify that the system clock on the 
central server is synchronized with the system clock on each satellite server.

Task 1: Set up connections with satellite server databases

1 Start the Management Console.

2 Click the Systems icon on the lower left. The System/Network Administration pane opens.
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Configuring the Central Server
3 Right-click the Databases folder. When prompted, select Add OVPI Database. The Add 
Database Wizard opens. 

4 Click Next.

5 Type the hostname and port number for the database you want to add; click Next.

6 Review the Summary. Repeat Steps 4 and 5 for each additional database.

7 Click Finish when you finish adding databases. 

Task 2: Configure trendcopy pull commands 

1 Configure trendcopy pull commands for each satellite server; open the following file:

$DPIPE_HOME/scripts/IPT_CallDetails_trendcopy.pro 

2 Append the following text to the end of the file:

3 Modify block0 as follows:

— Replace SATELLITE_SERVER_1_DATABASE with the satellite server name

— Replace THIS_MACHINE_DATABASE with the central server name

4 If there is more than one satellite server, create a copy of block0 for each satellite server 
and repeat step 2 for each copy of block0.

begin: block0 wait 
{DPIPE_HOME}/bin/trendcopy -t SHIPT_Hist_phoneNum -s 
SATELLITE_SERVER_1_DATABASE -S THIS_MACHINE_DATABASE 

{DPIPE_HOME}/bin/trendcopy -t SHIPT_Hist_gateway -s 
SATELLITE_SERVER_1_DATABASE -S THIS_MACHINE_DATABASE 

{DPIPE_HOME}/bin/trendcopy -t SHIPT_Hist_CManager -s 
SATELLITE_SERVER_1_DATABASE -S THIS_MACHINE_DATABASE 

{DPIPE_HOME}/bin/trendcopy -t SHIPT_Hist_Cluster -s 
SATELLITE_SERVER_1_DATABASE -S THIS_MACHINE_DATABASE 

{DPIPE_HOME}/bin/trendcopy -t SHIPT_QoS_phoneNum -s 
SATELLITE_SERVER_1_DATABASE -S THIS_MACHINE_DATABASE 

{DPIPE_HOME}/bin/trendcopy -t SHIPT_QoS_gateway -s 
SATELLITE_SERVER_1_DATABASE -S THIS_MACHINE_DATABASE 

{DPIPE_HOME}/bin/trendcopy -t SHIPT_QoS_CManager -s 
SATELLITE_SERVER_1_DATABASE -S THIS_MACHINE_DATABASE 

{DPIPE_HOME}/bin/trendcopy -t SHIPT_QoS_Cluster -s 
SATELLITE_SERVER_1_DATABASE -S THIS_MACHINE_DATABASE 

{DPIPE_HOME}/bin/trendcopy -t SHIPT_Hist_gateway_loc -s 
SATELLITE_SERVER_1_DATABASE -S THIS_MACHINE_DATABASE 

{DPIPE_HOME}/bin/trendcopy -t SHIPT_Hist_loc -s 
SATELLITE_SERVER_1_DATABASE -S THIS_MACHINE_DATABASE 

{DPIPE_HOME}/bin/trendcopy -t SHIPT_QoS_gateway_loc -s 
SATELLITE_SERVER_1_DATABASE -S THIS_MACHINE_DATABASE 

{DPIPE_HOME}/bin/trendcopy -t SHIPT_QoS_loc -s 
SATELLITE_SERVER_1_DATABASE -S THIS_MACHINE_DATABASE 

end: block0 
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Configuring a Satellite Server

Follow these steps to disable daily aggregations on each satellite server:

1 Open the following file:

$DPIPE_HOME/scripts/IPT_CallDetails_Daily.pro 

2 Comment out block1 to block8 by adding the comment sign (“#”) before the word begin and 
the word end. 

3 Open this file:

DPIPE_HOME/scripts/IPT_CallDetails_Location_Daily.pro

4 Comment out block2 to block4 by adding the comment sign (“#”) before the word begin and 
and the word end.

5 Verify that the system clock is synchronized with the system clock on the central server. 
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Chapter 6
Call History Summary

The History Summary reports look at call history from the following perspectives:

• Cluster

• CallManager

• Gateway by CallManager

• Gateway by Location

• Location

• Phone number

The focus of this report, regardless of the perspective you are using, is yesterday’s Call 
Success Rate (CSR). CSR is a percentage calculated by dividing successful calls by total calls 
and multiplying the result by 100. All selection tables sort by CSR, highest to lowest. All 
History Summary reports provide the following graphs:

• Total Call Volume stacked by Success Call and Failed Call

• Total Call Minutes

• Call Type Distribution stacked by:

— Internal

— Incoming PSTN Call

— Outgoing Local; Long Distance; International

— Tandem Calls

• Maximum and Average Call Duration per success call

• Abnormal Disconnect Cause stacked by:

— Called Party Cause

— Wrong Number

— No Response

— Network Fail

— Others

• Call Duration Distribution stacked by:

— Less than 1 minute
47



— 1 to 5 minutes

— 5 to 30 minutes

— 30 minutes to 2 hours

— 2 hours to 12 hours

— More than 12 hours

An hourly graph shows 24 hours for yesterday, a daily graph looks at data for the previous 30 
days, and a monthly graph looks at data for the previous 12 months. 
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Chapter 7
Top Ten Reports

There are twelve top ten reports: six in the call history area, and six in the call QoS area. 

Every top ten report performs a ranking function that makes it easy for you to spot potential 
problem areas in yesterday’s extremes. The call history reports contain these tables:

• Highest Call Volume

• Highest Call Volume Increase

• Most Call Minutes

• Highest Call Minutes Increase

• Worst Call Success Rate 

• Highest CSR Decrease

The call QoS reports contain these tables:

• Highest Packet Lost

• Highest Packet Lost Increase

• Highest Jitter

• Highest Jitter Increase

• Highest Latency 

• Highest Latency Decrease

Call History Call QoS

Cluster History Top Ten Cluster QoS Top Ten

CallManager History Top Ten CallManager QoS Top Ten

Gateway History Top Ten by CallManager Gateway QoS Top Ten by CallManager

Phone Number History Top Ten Phone Number QoS Top Ten

Location History Top Ten Location QoS Top Ten

Gateway History Top Ten by Location Gateway QoS Top Ten by Location
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Chapter 8
Call QoS Summary Reports

The call QoS summary reports provide QoS metrics aggregated by:

• Cluster

• CallManager

• The gateways associated with each CallManager

• The gateways associated with each location

• The phone numbers associated with each CallManager

• The phone numbers associated with each location

These reports focus on the following metrics:

• Total calls

• Average packets lost

• Average jitter

• Average latency

• Average QoS

Investigate Packets Lost more closely by looking at the following data graphs, tabbed Hourly, 
Daily, and Monthly:

• Calls by QoS Value stacked by:

— Good

— Acceptable

— Fair

— Poor

• Packets Lost 

• Jitter 

— Average 

— Maximum

• Latency

— Average

— Maximum
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Chapter 9
Forecast Reports

Forecast reports tell you whether call volume is growing or decreasing and how fast it is 
growing or decreasing. IPT Call Detail includes five forecast reports:

• CallManager forecast

• Cluster forecast

• Gateway forecast by CallManager

• Gateway forecast by location

• Phone number forecast

• Location forecast

Each report begins with an estimate of future call volume. The time ranges are 30 days from 
now, 60 days from now, and 90 days from now. You can investigate future performance in more 
detail by using the following graphs: 

• Call Volume Forecast

• Call Minutes Forecast

• Call Success Rate Forecast

• Average QoS Forecast 

Each graph has the following tabs:

Standard

Compare the baseline average to future performance.

Day of Week

Correlate future performance by day of week.

History

Inspect the data collected throughout the baseline period (the previous 91 days).
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Chapter 10
Inventory Report

The inventory report provides a list of:

• Clusters

• CallManagers associated with each cluster

• Gateways associated with each CallManager

• IP phones associated with each CallManager

If you are in the habit of assigning customers and locations to CallManagers and gateways, 
this report will tell you which CallManager and gateways, if any, do not have customers or 
locations assigned to them.

The inventory report reads property tables created by the Admin module. The Admin module 
that comes with IPT Call Detail is exactly the same as the Admin module that comes with IP 
Telephony Gateway Statistics. Both packages share the same inventory report. The inventory 
report reads the following property tables:

• K_IPT_Cluster

• K_IPT_CManager

• K_IPT_gateway

• K_IPT_phoneNum

• K_IPT_gateway_loc (location module)

• K_IPT_loc (location module)

• K_IPT_QoS

These tables are refreshed daily by the CDR Datapipe. In addition, they are updated by any 
changes you make using the property update forms that come with IPT Call Detail. 
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Chapter 11
Editing Tables and Graphs

Any table or graph can be viewed in several ways. While the default view is usually adequate, 
you can easily change to a different view. 

If you are using the Report Viewer application, right-click the object to display a list of view 
options. If you are looking at a report using the Web Access Server, follow these steps to 
change the default view of a table or graph:

1 Click Preferences on the links bar.

2 Expand Reports in the navigation frame.

3 Click Viewing.

4 Select the Allow element editing box.

5 Click Apply.

6 Click  (the Edit icon) next to the table or graph. 

View Options for a Table

Right-clicking a table, or selecting the Edit Table icon if you are using the Web Access Server, 
opens a list of table view options.

Select Set Time Period to alter the relative time period (relative to now) or set an absolute time 
period. The Set Time Period window opens.
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View Options for a Table
You may shorten the period of time covered by the table from, for example, 42 days to 30 days 
or to 7 days. If you are interested in a specific period of time that starts in the past and stops 
before yesterday, click Use Absolute Time and select a Start Time and an End Time.

Select Change Constraint Values to loosen or tighten a constraint, thereby raising or lowering 
the number of elements that conform to the constraint. The Change Constraint Values 
window opens. To loosen a constraint, set the value lower; to tighten a constraint, set the 
value higher.

The Select Nodes/Interfaces allows you to change the scope of the table by limiting the table to 
specific nodes, specific interfaces, or a specific group of nodes or interfaces. The Select Node 
Selection Type window opens.
Change Max Rows increases or decreases the number of rows in a table. The default is 50. If 
you expand the default, the table may take more time to open. If you are trending a large 
network, using the default ensures that the table opens as quickly as possible. 
View in new Frame opens the table in a Table Viewer window, shown below. If necessary, make 
the data in the table more legible by resizing the window. 
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View Options for a Graph

Right-clicking a graph, or clicking the Edit Graph icon if you are using the Web Access Server, 
opens the following list of view options. 

The following table provides details about each option.

Option Function

Set Time Period Same as the table option shown above.

Change Constraint Values Same as the table option shown above.

Select Nodes/Interfaces Same as the table option shown above.

Displayed Data For every point on a graph, display data in a 
spreadsheet.

Grid Add these to the graph:
X axis grid lines
Y axis grid lines
X and Y axis grid lines

Legend Delete or reposition the legend. 

Style See the illustrations below.

Change Max Rows... Same as the table option shown above.

Display Data Table See below.
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View Options for a Graph
Style Options

Select Style to display a list of seven view options for graphs.

Style > Area

The plot or bar chart changes to an area graph. While relative values and total values are 
easy to view in this format, absolute values for smaller data types may be hard to see. Click 
anywhere within a band of color to display the exact value for that location 

Export Element as CSV... Same as the table option shown above.

View in New Frame Opens graph in a Graph Viewer window.

Print Graph Same as the table option shown above.

Option Function
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Chapter 11
To shorten the time span of a graph, press SHIFT+ALT and use the left mouse button to 
highlight the time span you want to focus on. Release the mouse button to display the selected 
time span.

Style > Stacking Area

The area or plot graph changes to a stacking area graph. This view is suitable for displaying a 
small number of variables.

Style > Bar

The graph changes to a bar chart. This view is suitable for displaying relatively equal values 
for a small number of variables. There are three variables in the graph below.
93



View Options for a Graph
Style > Stacking Bar

The plot or area graph changes to a stacking bar chart. If you increase the width of the frame, 
the time scale becomes hourly. If you increase the height of the frame, the call volume shows 
in units of ten.

Style > Plot

Bands of color in an area graph change to lines. If you adjust the frame width, you can make 
the data points align with hour; if you adjust the frame height, you can turn call volume into 
whole numbers.
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Style > Pie

An area graph becomes a pie chart. Bands in an area graph convert to slices of a pie and the 
pie constitutes a 24-hour period. This view is helpful when a small number of data values are 
represented and you are looking at data for one day.

If you are looking at data for more than one day, you will see multiple pie graphs, one for each 
day. 

Display Data Table

This option changes a graph into a spreadsheet. 
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View Options for a Graph
View in New Frame

The graph opens in a Graph Viewer window. Improve legibility by resizing the window. 
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