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Support

Please visit the HP OpenView website at:
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Chapter 1
Overview

This overview covers the following topics:

• Introduction to OpenView Internet Services (OVIS)

• Time periods, special terms, and statistics defined

• Integration with Network Node Manager (NNM)

• Ways to customize reports

• Sources for additional information

Introduction to Internet Service Reporting

The Internet Services Report Pack 1.0 provides detailed information about services that are 
critical to a successful business. It enables enterprises and service providers to monitor their 
services, spot problem areas, and predict what performance will be like in the future. 

Working together, the Internet Services Report Pack and the Internet Services Report Pack 
Datapipe collect, aggregate, and analyze data maintained by OVIS Management Servers. In 
terms of features and benefits, this is what the user can expect:

• Centralized reporting

• Centralized OVIS data warehousing

• Performance baselining

• Performance forecasting

• Cross-domain reporting using data from other OpenView Performance Insight (OVPI) 
reporting solutions

Internet Services offers the following perspectives on availability, response time, throughput, 
and service level violations:

• Analysis of performance by day, with day-to-day comparisons

• Analysis of performance by month, with month-to-month comparisons

• Analysis of performance per 30-day rolling baseline

In addition to examining performance by day, month, and rolling baseline, Internet Services 
provides estimates for response time, throughput, and service level violations 30, 60, and 90 
days into the future.
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Introduction to Internet Service Reporting
Folders and Reports

Internet Services 1.0 includes twenty interactive reports. Reports are contained in the 
following folders:

• Detail

• Hot Spots

• Forecasts

• Summary

The detail folder contains the following probe and service reports:

• Daily Probe Type Detail

• Monthly Probe Type Detail

• 30 Day Probe Type Detail

• Daily Service Detail

• Monthly Service Detail

• 30 Day Service Detail

The hot spots folder contains the following probe and service reports:

• Daily Probe Type Hot Spots

• Monthly Probe Type Hot Spots

• 30 Day Probe Type Hot Spots

• Daily Services Hot Spots

• Monthly Services Hot Spots

• 30 Day Services Hot Spots

The forecast folder contains the following probe and service reports:

• Probe Type Forecast

• Service Forecast

The summary folder contains the following probe and service reports:

• Daily Probe Type Summary

• Monthly Probe Type Summary

• 30 Day Probe Type Summary

• Daily Service Summary

• Monthly Service Summary

• 30 Day Service Summary
8



Chapter 1
Time Periods Defined

Aside from the forecast reports, every report in this package fits into one of these categories:

• Daily

• Monthly

• 30 day

The daily report begins with statistics for yesterday and allows you to compare yesterday’s 
statistics to performance over the preceding 30 days. The tables at the top of the report look at 
data for the selected day, while the graphs below let you see a full 30 days of data.

The monthly report lets you see what the trend has been for the past 12 months. This report 
provides:

• An aggregation for month-to-date (the beginning of the current month until yesterday)

• An aggregation for previous calendar months, up to a maximum of 12 months

The 30 day report aggregates data for the preceding 30 days. The tables at the top look at 
totals and averages for a rolling 30 day baseline, while the graphs below provide data for each 
day within the rolling 30 day baseline. 

Terms Defined

Term Definition

Customer The customer as defined in the OVIS Server; the name 
of the customer for whom services are being monitored.

OVIS test One execution of a simulated service from one probe 
system to one target.

Probe System Also referred to as a probe. The system that contains 
software that initiates the simulated service, measures 
the results, and sends the results back to the OVIS 
server.

Probe Type Also referred to as Service Type or just Service in the 
OVIS system. A simulated network business activity 
such as HTTP, FTP, DNS, etc. 

Service Also referred to as Service Group in the OVIS system. A 
grouping of measurements of a single service or probe 
type that have common service level objectives. 

Service level violation The number of tests that exceeded a threshold as 
defined by the OVIS system user.

Target The target of the simulated service. This could be a 
URL, a DNS server, an FTP server, etc.
9



Introduction to Internet Service Reporting
Statistics Defined

Provisioning and the Object Model

There is no need to provision Internet Services 1.0. This is because OVPI uses customer 
information maintained by the OVIS Management Server to populate the appropriate table in 
the Common Property Tables package. The customer data in that table is used by Internet 
Services 1.0 to populate reports with customers. As a result:

• OVPI knows which services belong to each customer

• OVPI knows which probe types are used by each customer

Installing Internet Services 1.0 modifies the object model maintained by OVPI. The following 
objects are added to the customer view model:

• Service

• OVIS Probe type

OVIS customers are viewable from the Management Console by doing the following:

Select Objects > View > Change View > Customers

You can view any report in the Internet Services 1.0 package by highlighting a customer and 
selecting one of the reports listed under Object Specific Reports. For example:

Customer XYZ > Object Specific Reports > Daily Probe Type Hot Spots

Statistic Definition

Availability The percentage of tests that were successful; serves as 
an estimate of service availability.

Response time The response time measured by probe systems for 
successful OVIS tests. The response time shown in 
Daily reports, and in the graphs of 30 Day reports, is the 
highest (worst) hourly average for each day. The 
response time displayed in Monthly reports, and in the 
selection tables of 30 Day reports, is the average of the 
highest hourly average for each day. The graphs in 
Monthly reports also show the maximum of the daily 
highest hourly averages during the month.

Service Level Violations A count of the number of tests that exceeded the service 
level objectives specified in the OVIS system.

Throughput The throughput measured by probe systems for 
successful OVIS tests. The throughput displayed in 
Daily reports, and in the graphs of 30 Day reports, is the 
lowest (worst) hourly average for each day. The 
throughput displayed in Monthly reports, and in the 
selection tables of 30 Day reports, is the average of the 
lowest hourly average for each day. The graphs in the 
monthly reports also show the minimum of the daily 
lowest hourly averages during the month. 
Note: Not all OVIS tests measure throughput.
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Chapter 1
The report that opens will be constrained, containing data for customer XYZ only. You can 
launch summary or detail reports by selecting a specific probe type or service, as follows: 

XYZ > Probe Type N > Daily Probe Type Detail Report

Customer XYZ > Service N > Daily Service Summary Report

The report that opens will be constrained, containing data for N probe type, or N service, for 
customer XYZ only.

Integration with NNM

If your OVPI server and your NNM server are integrated, you can launch the reports in 
Internet Services 1.0 directly from NNM. The reports in Internet Services 1.0 (as well as the 
reports in any other OVPI report packs you are using) will be listed in the Report Launchpad 
window. The NNM operator can open this window from:

• NNM ovw

• Home Base Dynamic Views

• NNM alarm browser

OVIS Management Servers are already integrated with NNM and the NNM alarm browser. 
For this reason, Internet Services 1.0 does not include a thresholds sub-package. 

Ways to Customize Reports

The contents of a report can be customized by applying group filters, by editing parameters, 
and by editing tables and graphs. When you apply a group filter, you are changing how the 
entire package appears to a particular group of users. Edits to tables, graphs, and parameters 
are temporary changes that anyone can make. For details about view options for tables and 
graphs, see Chapter 8, Editing Tables and Graphs.

Group Filters

If you intend to share your reports with customers, or let divisions within your enterprise see 
division-specific performance data, your reports will need to be customer-specific. Creating 
customer-specific reports involves the following tasks:

• Importing custom property information (customer names and device locations) using 
Common Property Tables

• Creating a group account for all of the users affiliated with a particular customer

• Creating a group filter for the group account

For more information about creating filters for group accounts, refer to the HP OpenView 
Performance Insight 5.0 Administration Guide. 
11



Sources for Additional Information
Editing Parameters

Editing a parameter applies a constraint and eliminates data you are not interested in seeing 
in a report. For example, if you edit the Customer Name parameter, data for every customer 
except the customer you typed in the Customer Name field would drop from the report. 
Internet Services 1.0 supports the following parameters: 

• Customer

• Service 

• Probe Type

• Cust_id

If you are using the Web Access Server to view reports remotely, edit parameters by clicking 
the Edit Parameters icon at the bottom right-hand corner of the report. When the Edit 
Parameters window opens, enter the constraint in the field and click Submit. 

If you are using Report Viewer, select Edit > Parameter Values from the menu bar. When the 
Modify Parameter Values window opens, click the Current Value field. Type a new value and 
click OK.

Sources for Additional Information

This user guides provides samples of some of the reports in Internet Services 1.0. The demo 
package that comes with Internet Services is complete, with one sample of every report in the 
package. If you have access to the demo package and you want to know what fully-populated 
reports look like, install the demo package. Like real reports, demo reports are interactive. 
Unlike real reports, demo reports are static.

The following documents are related to Internet Services 1.0: 

• Internet Services Report Pack 1.0 Release Statement

• Common Property Tables 3.5 User Guide

• NNM / Performance Insight Integration Module 2.0 User Guide

• OVIS 5.0 Custom Probes API Guide, September 2003

• OVIS 6.0 Release Notes, August 2004

Manuals for the core product, OVPI, and manuals for the reporting solutions that run on 
OVPI are available for downloading from the following site:

http://www.hp.com/managementsoftware

Select Technical Support > Product Manuals to open the Product Manual Search page. Manuals for 
OVPI are listed under Performance Insight. Manuals for report packs, datapipes, and NNM 
components are listed under Reporting and Network Solutions. 

Every user guide listed under Reporting and Network Solutions indicates the month and year of 
publication. If a user guide is revised and reposted, the date of publication will change even if 
the software version number does not change. Since updated PDFs are posted to this site on a 
regular basis, you should search this site for updates before using an older PDF that may not 
be the latest PDF available.
12



Chapter 2
Package Installation

This chapter covers the following topics: 

• Guidelines for a smooth installation

• Installing Internet Services 1.0

• Creating OVIS collections

• View options

• Seeing performance data in reports

• Package removal

Guidelines for a Smooth Installation

Each reporting solution that runs on OVPI consists of a report pack and one datapipe, or 
sometimes a report pack and multiple datapipes. When you install the datapipe, you configure 
OVPI to collect a specific type of performance data at a specific polling interval. When you 
install the report pack, you configure OVPI to summarize and aggregate performance data in 
a specific way. 

The RNS 6.0 CD includes components for NNM as well as OVPI report packs. If you or 
someone else has already extracted OVPI packages from this CD, every OVPI report pack, 
including the Internet Services Report Pack 1.0, has been copied to the Packages directory on 
your system and is ready to install, using the instructions in this chapter. 

If you have not extracted packages from the RNS 6.0 CD and you need help, see the package 
extraction procedure later in this chapter. 

Prerequisites

Make sure the following software is already installed before installing Internet Services:

• OVPI 5.0

• Any available service pack for OVPI 5.0

• Common Property Tables 3.0 or higher
13



Installing Internet Services 1.0
Upgrading Common Property Tables

If you are running an older version of Common Property Tables, you must upgrade that 
package to version 3.0 or higher. If you are not running any version of Common Property 
Tables, there is no need to do anything, since Package Manager will install the latest version 
of Common Property Tables for you, automatically.

Do not install an upgrade for Common Property Tables and other packages at the same time. 
Install the upgrade package for Common Property Tables and only the upgrade package for 
Common Property Tables. For more information about installing and using Common Property 
Tables, refer to the Common Property Tables 3.5 User Guide.

Distributed Systems

If your system is distributed, the installation procedure is more complicated. Following is a 
summary of the installation procedure for a distributed system:

1 Verify that every server is running OVPI 5.0 and all available service packs for OVPI 5.0.

2 Disable trendcopy on the central server.

3 Upgrade Common Property Tables (2.2-to-3.0 or 3.0-to-3.5).

4 Install Internet Services 1.0 on the central server; deploy reports.

5 For each satellite server:

• Upgrade Common Property Tables

• Install these packages:

— Internet Services Report Pack 1.0

— Internet Services Report Pack Datapipe 1.0

6 Re-enable trendcopy on the central server.

When installation is complete, you must set up connections with satellite server databases, 
configure trendcopy pull commands, and switch off aggregations at each satellite server. 
These steps are covered in Chapter 3, Distributed Systems.

Installing Internet Services 1.0

This section covers the following tasks:

• Task 1: Extract packages from the RNS 6.0 CD

• Task 2: If necessary, upgrade Common Property Tables

• Task 3: Install these packages:

— Internet Services 1.0

— Internet Services Datapipe 1.0
14



Chapter 2
Task 1: Extract packages from the RNS 6.0 CD

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, type one of the following:

HP-UX: sh /sbin/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Insert the RNS 6.0 CD. On Windows, a Main Menu displays automatically; on UNIX, 
mount the CD, navigate to the top-level directory for the CD drive, and type the setup 
command. 

4 Select OVPI report packs by typing 1 in the choice field and pressing Enter. The install 
script displays a percentage complete bar. When extraction finishes, the install script 
starts Package Manager. The Package Manager welcome window opens.

If you navigate to the Packages directory on your system, you will see the following folders 
under the Internet Services folder:

• Internet_Services.ap

• Internet_Services_Demo.ap

Installing the demo package is optional. You may install the demo package and only the demo 
package, or you can install the demo package along with everything else. 

Task 2: Upgrade to Common Property Tables 3.0 or higher

If you are running Common Property Tables 2.2, you must upgrade to version 3.0. If you are 
running version 3.0, you have the option of upgrading to version 3.5. Observe these rules:

• Do not install any other package with the upgrade package; install the upgrade package 
and only the upgrade package. 

• When prompted to accept or disable the option to Deploy Reports, accept the default. If 
you do not deploy reports, you will not have access to the forms that come with Common 
Property Tables.

• When the install finishes, click Done to return to the Management Console.

If you need help with the upgrade, refer to the Common Property Tables 3.5 User Guide. 

Task 3: Install the report pack and the datapipe

1 From the Management Console select Tools > Package Manager. The Package Manager 
welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install. Approve the default installation directory or use the browse feature to select 
a different directory if necessary. 

4 Click Next. The Report Deployment window opens. Accept the default for Deploy Reports; 
accept the default for application server name and port. Type your username and 
password for the OVPI Application Server. 

5 Click Next. The Package Selection window opens. 
15



Defining OVIS Collections
6 Click the check box next to the following package:

Internet Services 1.0 

Internet Services Datapipe 1.0

Internet Services Demo (optional)

7 Click Next. The Type Discovery window opens. 

8 Disable the default to run Type Discovery immediately after package installation.

9 Click Next. The Selection Summary window opens.

10 Click Install. The Installation Progress window opens and the install process begins. When 
the install finishes, a package install complete message appears. 

11 Click Done to return to the Management Console. 

12 Restart OVPI Timer.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, type one of the following:

HP-UX: sh /sbin/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start

When the Internet Services Report Pack and the associated datapipe are installed, your next 
task is to define OVIS collections. 

Defining OVIS Collections

Follow these steps to define OVIS collections:

1 Start the Management Console.

2 Click the Systems icon located on the left-hand side of the Management Console.

3 Expand the information under the OVPI system by clicking “+”.

4 Right-click the Databases folder icon and select Add Database. The Add Database Wizard 
opens.

5 Click Next.  

6 Select Generic Supported Database and click Next. The Database Connection Information 
window opens.

Run

The Internet Services package does not require Type Discovery. 
However, if you are installing other report packs in addition to 
Internet Services, you may need to run Type Discovery for those 
packages. 
16



Chapter 2
7 Add the following database connection information in the window shown below:

• Hostname – Either the host name or the IP address of the OVIS server

• Port – The TCP/IP port number 

• Description – Must include either “OVIS” or “ovis” to enable collection of OVIS data

• Vendor – Select the database vendor for the OVIS system

• Database Instance – Specify OVOPS for SQL server; reporter for Oracle

• Database Username – Username with access to the OVIS database

• Password – Database password

8 Click Next. 

9 Type a unique, identifying System name and (optional) description and click Next. The 
Summary window opens.

10 Click Finish.

The port number for an OVIS system installed on Oracle is 
normally 1521. If this number is not valid, check with your Oracle 
DBA. The procedure for determining the SQL server port number is 
provided below. 
17



Ways to View Reports
Determining the Port Number

Follow these steps to determine the port number for a SQL Server OVIS system:

1 Execute svrnetcn.exe from the command line. The SQL Server Network Utility opens. 

2 Verify that TCP/IP is selected in the Enabled Protocols section.

3 Click Properties. The port number appears in the pop-up window.

Collecting Data from OVIS

Once the OVIS system has been added as a supported database, the Internet Services 
Datapipe will begin collecting data automatically. The initial collection may take a long time. 
This is because OVIS systems store data for a number of days. If the OVIS system is using the 
default, data will be stored for 7 days. Subsequent collections will complete much faster, since 
only incremental data will be collected.

If you wish to stop collecting from an OVIS system, do one of the following:

• Using the Management Console, delete the system as a supported database.

• Edit the database description, removing any reference to “OVIS” or “ovis”.

Ways to View Reports

During the preceding installation procedure, you enabled the Deploy Reports option when you 
installed the Internet Services Report Pack. As a result, Internet Service 1.0 reports are 
deployed and available for remote viewing. 

The method of report viewing available to you depends on how OVPI was installed. If the 
client component is installed on your system, you have access to Report Viewer, Report 
Builder, and the Management Console. If the client component was not installed on your 
system, use the Web Access Server to view reports.

For more information about the client component, refer to the Performance Insight 
Installation Guide. For more information about Object Manager and viewing reports specific 
to selected objects, refer to the Performance Insight Administration Guide. For more 
information about deploying, viewing, and undeploying reports, refer to the Performance 
Insight Guide to Building and Viewing Reports.

Seeing Performance Data in Reports

If you are accustomed to working with other OVPI packages, you know that Near Real Time 
reports are the first reports to populate with data. Since there are no NRT reports in this 
package, you will not see report data right away. Since processing occurs at night, the earliest 
data will appear tomorrow. 

In the days immediately following installation, you will see some data in daily reports, 30 day 
reports, and monthly reports. 

• In daily reports, you will see totals and averages for each day for which you have data. 
18



Chapter 2
• In the 30 day reports, you will see aggregated data representing all the days for which you 
have data. 

• In the monthly reports, you will see month-to-date aggregations in the selection tables. 

If the data you collected includes data for any part of the previous calendar month, the graphs 
in the monthly reports will be populated. If the data you collected has no data for the previous 
month, the graphs will remain empty until you begin collecting data on the first day of next 
month.

Forecast reports are generated from a rolling baseline comprising 30 days of data. Even 
though forecast reports will populate with data before the initial baseline is complete, do not 
look for reliable forecasting information until the initial baseline period is complete.

Package Removal 

If you remove a report pack, the associated tables and all the data in those tables will be 
deleted. If you want to preserve the data in those tables, archive the data before removing the 
package. 

Follow these steps under Task 1 to uninstall Internet Services. Removing Internet Services 
will automatically remove the datapipe. Task 2, removing OVIS systems defined as a Generic 
Supported Database, is a good practice, but this step is not absolutely necessary.

Task 1: Uninstalling Internet Services 

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Start Package Manager. The Package Manager welcome window opens.

4 Click Next. The Package Location window opens.

5 Click Uninstall.

6 Click Next. The Report Undeployment window opens.

7 If Internet Services reports were deployed from this server, accept the defaults for 
Undeploy Reports, Application Server Name, and Port. If Internet Services reports were 
not deployed from this server, clear the check box and skip to step 9.

8 Type the username and password for the OVPI Application Server.

9 Click Next. The Package Selection window opens. 

10 Click the check box next to the following package:

 Internet Services Report Pack 1.0

11 Click Next. The Selection Summary window opens. 

12 Click Uninstall. The Progress window opens and the removal process begins. When the 
uninstall process is complete, a package removal complete message appears. 
19



Package Removal
13 Click Done to return to the Management Console.

14 Restart OVPI Timer.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start

Task 2: Removing any OVIS systems defined as a Generic Supported Database

1 Click the Systems icon on the left-hand side of the Management Console.

2 Select the local system. OVPI and generic databases appear in the main window.

3 Right-click the OVIS system and select Delete System...

4 Click Yes in the pop-up window. 

The OVIS system is now removed.
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Chapter 3
Distributed Systems

This chapter covers the following topics:

• Verifying correct package installation

• Configuring the central server

• Configuring satellite servers

Verifying Correct Package Installation

If you intend to run Internet Services 1.0 as a distributed system, you must configure all of 
the servers in the system. Before doing that, verify that you have the right packages installed 
on each server. 

Packages on the Central Server

• Internet Services Report Pack 1.0; with reports deployed

• Common Property Tables 3.0 or 3.5; with forms deployed

Packages on Each Satellite Server

• Internet Services Report Pack 1.0

• Common Property Tables 3.0 or 3.5

• Internet Services Report Pack Datapipe 1.0

Typically, the central server does not poll. If you want the central server in your system to 
poll, install the datapipe on the central server. If desired, you may view reports on satellite 
servers, which we refer to as local reporting. If you want local reporting, deploy reports from 
each satellite server. 

Configuring the Central Server

To configure the central server, perform the following tasks:

• Task 1: Set up connections with satellite server databases

• Task 2: Configure trendcopy pull commands
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Configuring Satellite Servers
Task 1: Set up connections with satellite server databases

1 Start the Management Console.

2 Click the Systems icon on the lower left. The System/Network Administration pane opens.

3 Right-click the Databases folder. When prompted, select Add OVPI Database. The Add 
Database Wizard opens. 

4 Click Next.

5 Type the hostname and port number for the database you want to add; click Next.

6 Review the Summary. Repeat Steps 4 and 5 for each additional database.

7 Click Finish when you finish adding databases. 

Task 2: Configure trendcopy pull commands

1 Open this file:

$DPIPE_HOME/scripts/Internet_Services_Hourly.pro 

2 For block2, remove the “#” from the begin and end lines.

3 Modify the trendcopy commands so that each command includes the correct server name 
for the central server and for each satellite server.

4 If necessary, add more commands.

Configuring Satellite Servers

To configure a satellite server, switch off aggregations above the hourly level. Do this by 
editing the $DPIPE_HOME/lib/trendtimer.sched file. Comment out the line 
referencing Internet_Services_Daily.pro.
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Chapter 4
Hot Spots

Hot Spots reports improve your visibility into the services and probe types that are 
experiencing the worst performance. Each report pinpoints the 10 services or 10 probe types 
with the highest service level violations, lowest availability, highest response time, and lowest 
throughput.

The Hot Spots folder contains three probe type reports and three service reports:

• 30 Day Probe Type Hot Spots

• Daily Probe Type Hot Spots

• Monthly Probe Type Hot Spots

• 30 Day Services Hot Spots

• Daily Services Hot Spots

• Monthly Services Hot Spots

If you want to watch for problem areas as they arise, use the daily reports. As soon as you spot 
a problem area, you can investigate it further by using the summary and detail reports in the 
other folders.

The monthly reports show (1) the month-to-date totals and the month-to-date averages for the 
current month and (2) the complete monthly totals/averages for previous months. Use these 
reports to compare actual performance to monthly Service Level Agreements.

The 30 Day reports provide an aggregated view of recent performance. These reports smooth 
out daily anomalies, while crossing the boundary between two months.

See below for samples of the following reports:

• 30 Day Probe Type Hot Spots

• 30 Day Services Hot Spots
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Chapter 5
Summary Reports

The reports in the summary folder provide statistics at the service and probe type level. The 
summary folder contains the following reports:

• 30 Day Probe Type Summary

• Daily Probe Type Summary

• Monthly Probe Type Summary

• 30 Day Service Summary

• Daily Service Summary

• Monthly Service Summary 

Summary reports provide a historical context for hot spots reports. For example, if a report in 
the Hot Spots folder has just alerted you to a problem, you can use the corresponding 
summary report to find out whether you are dealing with an unusual situation that could not 
have been predicted or a trend that has been steadily worsening over time. 

In a summary report, you drill down from a customer to a list of services or probe types 
associated with the customer. For each probe type or service, you have the following 
aggregated statistics:

• Service level violations

• Availability

• Response time

• Throughput

The figures in the probe type/service selection table aggregate data for every probe type/target 
associated with each probe type or service. Beneath the probe type/service table are graphs for 
service violations, availability, response time, and throughput. Use these graphs to see what 
the trend has been like for the past 30 days and the past 12 months.

See below for two sample reports, the Daily Probe Type Summary and the Daily Service 
Summary. 
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Chapter 6
Detail Reports 

The reports in the detail folder allow you to find out which OVIS tests are experiencing 
problems and whether or not the problem is typical or unusual compared to past performance. 
The detail folder contains the following probe type and service reports:

• 30 Day Probe Type Detail 

• Daily Probe Type Detail

• Monthly Probe Type Detail

• 30 Day Service Detail

• Daily Service Detail

• Monthly Service Detail

All detail reports begin with a list of customers. Select a customer to display a list of services/
probe types, sorted by violations highest to lowest, with data for the following statistics 
aggregated over all OVIS tests:

• Service level violations

• Availability

• Response time

• Throughput

By selecting a particular service or probe type, you can display (1) a list of the associated 
probe system/target combinations, sorted by violations highest to lowest, and (2) performance 
data for each combination. The graphs below the second table are linked to the item selected 
in the second table. These graphs provide test-level trending analysis, allowing you see 
whether violations, availability, response time, and throughput are improving or getting 
worse.

See below for samples of all six reports in the detail folder.

All OVIS tests calculate response time, but not all OVIS tests calculate 
throughput. If Null shows up in a table or graph that reports throughput, 
none of the OVIS tests that target this particular service calculates 
throughput. 
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Chapter 7
Forecast Reports

The two reports in the forecast folder identify the services and probe types that are expected 
to see their performance deteriorating at the fastest rates in the weeks and months ahead. 
Use the forecast reports to spot:

• Probe types/services with the greatest rate of increase in service level violations

• Probe types/services with the greatest rate of increase in response time

• Probe types/services with the greatest rate of decrease in throughput

Forecast reports contain tables and charts. The tables perform the following functions:

• Calculate the 90-day forecast

• Calculate the baseline average

• Sort items by the rate of growth

The graphs perform the following functions:

• Display 30-day, 60-day, and 90-day forecasts (forecast tab)

• Compare the baseline average to 30/60/90 forecasts (forecast tab)

• Show the data in the baseline that was used to generate the forecast (history tab)

See below for samples of the Probe Type Forecast and the Services Forecast.
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Chapter 8
Editing Tables and Graphs

Any table or graph can be viewed in several ways. While the default view is usually adequate, 
you can easily change to a different view. 

If you are using the Report Viewer application, right-click the object to display a list of view 
options. If you are looking at a report using the Web Access Server, follow these steps to 
change the default view of a table or graph:

1 Click Preferences on the links bar.

2 Expand Reports in the navigation frame.

3 Click Viewing.

4 Select the Allow element editing box.

5 Click Apply.

6 Click  (the Edit icon) next to the table or graph. 

View Options for a Table

Right-clicking a table, or selecting the Edit Table icon if you are using the Web Access Server, 
opens a list of table view options.

Select Set Time Period to alter the relative time period (relative to now) or set an absolute time 
period. The Set Time Period window opens.
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View Options for a Table
You may shorten the period of time covered by the table from, for example, 42 days to 30 days 
or to 7 days. If you are interested in a specific period of time that starts in the past and stops 
before yesterday, click Use Absolute Time and select a Start Time and an End Time.

Select Change Constraint Values to loosen or tighten a constraint, thereby raising or lowering 
the number of elements that conform to the constraint. The Change Constraint Values 
window opens. To loosen a constraint, set the value lower; to tighten a constraint, set the 
value higher.

The Select Nodes/Interfaces allows you to change the scope of the table by limiting the table to 
specific nodes, specific interfaces, or a specific group of nodes or interfaces. The Select Node 
Selection Type window opens.
Change Max Rows increases or decreases the number of rows in a table. The default is 50. If 
you expand the default, the table may take more time to open. If you are trending a large 
network, using the default ensures that the table opens as quickly as possible. 
View in new Frame opens the table in a Table Viewer window, shown below. If necessary, make 
the data in the table more legible by resizing the window. 
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Chapter 8
View Options for a Graph

Right-clicking a graph, or clicking the Edit Graph icon if you are using the Web Access Server, 
opens the following list of view options. 

The following table provides details about each option.

Option Function

Set Time Period Same as the table option shown above.

Change Constraint Values Same as the table option shown above.

Select Nodes/Interfaces Same as the table option shown above.

Displayed Data For every point on a graph, display data in a 
spreadsheet.

Grid Add these to the graph:
X axis grid lines
Y axis grid lines
X and Y axis grid lines

Legend Delete or reposition the legend. 

Style See the illustrations below.

Change Max Rows... Same as the table option shown above.

Display Data Table See below.
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View Options for a Graph
Style Options

Select Style to display a list of seven view options for graphs.

Style > Area

The plot or bar chart changes to an area graph. While relative values and total values are 
easy to view in this format, absolute values for smaller data types may be hard to see. Click 
anywhere within a band of color to display the exact value for that location 

Export Element as CSV... Same as the table option shown above.

View in New Frame Opens graph in a Graph Viewer window.

Print Graph Same as the table option shown above.

Option Function
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Chapter 8
To shorten the time span of a graph, press SHIFT+ALT and use the left mouse button to 
highlight the time span you want to focus on. Release the mouse button to display the selected 
time span.

Style > Stacking Area

The area or plot graph changes to a stacking area graph. This view is suitable for displaying a 
small number of variables.

Style > Bar

The graph changes to a bar chart. This view is suitable for displaying relatively equal values 
for a small number of variables. There are three variables in the graph below.
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View Options for a Graph
Style > Stacking Bar

The plot or area graph changes to a stacking bar chart. If you increase the width of the frame, 
the time scale becomes hourly. If you increase the height of the frame, the call volume shows 
in units of ten.

Style > Plot

Bands of color in an area graph change to lines. If you adjust the frame width, you can make 
the data points align with hour; if you adjust the frame height, you can turn call volume into 
whole numbers.
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Chapter 8
Style > Pie

An area graph becomes a pie chart. Bands in an area graph convert to slices of a pie and the 
pie constitutes a 24-hour period. This view is helpful when a small number of data values are 
represented and you are looking at data for one day.

If you are looking at data for more than one day, you will see multiple pie graphs, one for each 
day. 

Display Data Table

This option changes a graph into a spreadsheet. 
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View Options for a Graph
View in New Frame

The graph opens in a Graph Viewer window. Improve legibility by resizing the window. 
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