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Documentation Updates

This manual’s title page contains the following identifying information:

• Software version number, which indicates the software version

• Document release date, which changes each time the document is updated

• Software release date, which indicates the release date of this version of the software

To check for recent updates, or to verify that you are using the most recent edition of a document, go to:

http://ovweb.external.hp.com/lpe/doc_serv/ 

You will also receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details.
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Support

You can visit the HP Software Support web site at:

www.hp.com/go/hpsoftwaresupport 

HP Software online support provides an efficient way to access interactive technical support tools. As a valued 
support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract.

To find more information about access levels and HP Passport, go to:

http://h20230.www2.hp.com/new_access_levels.jsp  
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1 Overview
This chapter covers the following topics:

• OPVI and Class Based QoS on page 7

• Class Based QoS Report Types on page 13

• Package Version History on page 15

• Sources for Additional Information on page 15

OPVI and Class Based QoS

HP OpenView Performance Insight (OVPI) is a performance management application that 
collects data from many sources, performs in-depth trend analysis, maintains performance 
baselines, and provides users with convenient, web-based reporting. Following is a partial list 
of product features:

• Distributed architecture

• Easy to scale (supports data collection from thousands of agents)

• CODA/OVPA agent support

• Multi-company security model

• Data warehousing

• Near Real Time reporting

• Forecasting 

• Extensive aggregation (by day, week, month; by location, by customer)

• Thresholding and alerting

• Easy identification of bottlenecks

• Easy assessment of capacity trends

• Accurate and timely documentation for management

• Integration with NNM

• Integration with OVO

Quality of Service (QoS) lets you dedicate bandwidth to particular types of traffic but does not 
tell you how much traffic of each service class is traversing the network, nor does it provide 
the hourly and daily information needed to design efficient QoS schemes. To find out how 
much traffic of each service class is traversing the network, and when the traffic is taking 
place, it is necessary to poll byte and packet counters in the Cisco Class Based QoS MIB 
(Management Information Base) and process the collected data. The MIB uses policies and 
traffic classes to define and control traffic flows.
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Class Based QoS Reporting

The Class Based QoS reporting solution provides comprehensive summarization and 
reporting features that let you view the effect of QoS policies on network traffic. The Report 
Pack displays reports for various metrics, providing a comprehensive picture of what is 
happening on the network. Network service providers and their customers can use the Report 
Pack to monitor the usage characteristics of network services with a view to service capacity 
planning and network/service optimization.

The Class Based QoS Report Pack can be deployed in standalone and in distributed 
environments.

Data Collection

As the following graphic shows, the Class Based QoS reporting solution runs on an OVPI 
server that collects data using SNMP and networking devices that support the Class Based 
QoS configuration. The OVPI server can be on a single server or on multiple servers.
   

Class Based QoS Datapipe

The Datapipe provides the following data collection functionality:

• Discovers nodes that support the Cisco Class Based QoS MIB. The MIB contains a 
number of useful metrics for various QoS policies, including:

— Inventory 

– Parent and child classes applied on the various Interfaces of the CBQoS-enabled 
devices and the direction information.
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— Class statistics

– Pre-policy packets, bytes, and bit rate

– Dropped  packets, bytes, and bit rate

– Packets dropped due to no buffers

— Policing statistics

– Conformed packets, bytes, and bit rate

– Exceeded packets, bytes, and bit rate

– Violated  packets, bytes, and bit rate

— Queuing statistics

– Current queue depth

– Maximum queue depth

– Discard bytes and packets

— Traffic shaping statistics

– Delayed bytes and packets

– Dropped bytes and packets

– Current queue size

— Random Early Detect (RED) statistics

– Random dropped bytes and packets

– Tail dropped bytes and packets

– Transmitted bytes and packets

– ECN marked bytes and packets

– Mean queue size

• Populates the Class Based QoS base table.

• Collects QoS statistics every 15 minutes by default.

• Collects only the QoS statistics that are appropriate based on the QoS configuration of the 
router.

• Recognizes and responds to interface re-indexing discovered by the Interface Reporting 
Datapipe and the IFEntry Discovery Datapipe.

• Recognizes and responds to re-indexing of QoS objects in the Class Based QoS MIB tables.

• Recognizes and responds to configuration changes (other than re-indexing) of QoS objects 
in the Class Based QoS MIB tables as part of the statistics collection.

• Collects QoS configuration data for all routers once per day to keep the configuration 
information fresh. However, you can also force the immediate collection of configuration 
data.

• Collects QoS configuration data within 15 minutes after a re-indexing event or a 
configuration change is discovered on a router. This happens only on the routers that were 
re-indexed or reconfigured.

• Collects QoS configuration data as appropriate for QoS objects configured on each router.

• Collects statistics for routers needing configuration updates to minimize gaps in the data 
due to re-indexing or configuration changes.
Overview 9



Collections are based on the previous configuration. Statistics for new QoS objects are not 
collected until the new configuration is known. If QoS objects are removed for the 
configuration, there may be errors in the trend log that the MIB table for the removed 
QoS object does not exist.

• Collects only statistics for QoS objects with configuration data less than two days old.

• Updates the configuration/information for classes and policies in the report pack for all 
nodes requiring a configuration update prior to transferring data.

• Transfers data to the report pack only for nodes with complete configuration data. After a 
re-index or configuration change, trend sums are suspended until the configuration is 
updated.

Class Based QoS Report Pack

The Report Pack issues processing directives to OVPI, and displays reports that show the 
distribution of traffic on a per-precedence basis. With this information, you can monitor the 
usage characteristics of provided network services, plan service capacity, and optimize your 
network services.

The Report Pack also provides an open API for provisioning additional (optional) information, 
such as node locations and end customers. The Report Pack uses this provisioning data to 
present more detailed information concerning the endpoints of the network flows.
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Deploying the Class Based QoS Report Pack

After installation and type discovery, the supported devices need to be configured for the Class 
Based QoS configuration collection interval (see Configuring Class Based QoS on page 21). 
The interfaces in those devices need to be identified for polling or not. Once this is done, the 
Class Based QoS configuration data is collected from the devices, and the data is displayed in 
the base tables of the Report Pack. The overview reports show the QoS collection overview.

    

Customer, location, node, and interface information for QoS data is imported via the Common 
Property Tables property import/forms and the Interface Reporting property import/forms. 
For more information, see the Common Property Tables User Guide.

• The Datapipe populates the Class Based QoS base tables once every 15 minutes.

• The Report Pack populates the Class Based QoS daily tables every day as defined in the 
processing schedule.

• The Report Pack populates/updates the Class Based QoS monthly tables every day with 
the current month containing month-to-date data.

• The Report Pack populates the Class Based QoS forecast tables every day using a 42-day 
baseline period.

The following graphics illustrate the process flow for the Datapipe. 
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Router with Class Based QoS Defined

Class Based QoS Datapipe

SRCBQOS_Class SRCBQOS_ClassQueueing SRCBQOS_ClassRED

SRCBQOS_ClassPolice SRCBQOS_ClassPrecRED SRCBQOS_ClassTS

By key_id, hour By key_id, hour By key_id, hour
SHCBQOS_Class SHCBQOS_ClassQueueing SHCBQOS_ClassRED

By key_id, hour By key_id, hour By key_id, hour
SHCBQOS_ClassPolice SHCBQOS_ClassPrecRED SHCBQOS_ClassTS

By key_id, day By key_id, day By key_id, day
SDCBQOS_Class SDCBQOS_ClassQueueing SDCBQOS_ClassRED

By key_id, day By key_id, day By key_id, day
SDCBQOS_ClassPolice SDCBQOS_ClassPrecRED SDCBQOS_ClassTS

By key_id, month By key_id, month By key_id, month
SMCBQOS_Class SMCBQOS_ClassQueueing SMCBQOS_ClassRED

By key_id, month By key_id, month By key_id, month
SMCBQOS_ClassPolice SMCBQOS_ClassPrecRED SMCBQOS_ClassTS

By key_id
SD42SDCBQOS_Class_fore
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Class Based QoS Report Types

The Report Pack provides the following types of reports:

• Admin:

— QoS Polling Overview

• DrillDown:

— Bit Rate History

— Dropped Bit Rate History

— Inventory

— Packet Rate History

— Percent Packet Drop History

— Queuing History

— Traffic Forecast

— Utilization History

• Summary:

— Policing Summary by Class

— Queuing Summary by Class

— RED Summary by Class

— RED Summary by Class/Precedence

— Summary by Class

— Traffing Shaping Summary by Class

• TopN:

— Queuing Top N

— Utilization Top N

Reports show data by interface, traffic direction, and class. Additional reports may show data 
aggregated by device and for all devices. Reports show hourly, daily, and monthly data.

For details on deploying the reports, see Accessing Deployed Reports on page 23. To see 
example reports, see Sample Reports from the Demo Package on page 27.
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Customizing the Appearance of Reports

You can change the appearance of the reports, including fonts and graph styles, using the Web 
Access Server. 
   

For detailed instructions, see the HP OpenView Performance Insight Administration Guide.
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Package Version History

  

Sources for Additional Information

The following documents provide additional information:

• HP OpenView Performance Insight 5.2 Administration Guide 

• Common Property Tables User Guide 

These documents can be found either on the product DVD or you can download the latest 
version from the url shown in Documentation Updates on page 3.

Select Support > Product Manuals to reach the HP Software Product Manuals page. The user 
guides for OVPI are listed under Performance Insight.

Every manual on the Product Manuals Search page indicates the month and year. If a manual 
is revised and reposted, the date will change. Revised manuals are posted on a regular basis, 
so check the date on your PDF against the date on the PDF on the web and use the web 
version if it is newer.

Version Release Date Features/Enhancements

1.1 June 2007 Initial release
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2 Package Installation
This chapter covers the following topics:

• Guidelines for a Smooth Install on page 17

• Installing Class Based QoS on page 19

• Accessing Deployed Reports on page 23

• Package Removal on page 24

• Troubleshooting on page 25

Guidelines for a Smooth Install

The Report Pack CD has the latest report packs and datapipes. When you insert the CD in the 
CD-ROM drive and launch the package extraction program, the install script on the CD 
extracts every package from the CD and copies the results to the Packages directory on your 
system. When the extract finishes, the install script prompts you to launch OVPI and start 
Package Manager. Before using Package Manager, review the following guidelines.

Prerequisites for Installation

The Class Based QoS Report Pack has a combination of core product requirements and 
package level requirements. The core product requirements are:

• OVPI 5.2

• All service packs available for the version of OVPI (5.2) you are running

The package level prerequisites are:

• Common Property Tables 3.6 

• Interface Reporting Report Pack 5.2

Upgrading Common Property Tables

If you are running an earlier version of Common Property Tables, you must upgrade that 
package to version 3.6 or higher (see Upgrade to Common Property Tables 3.6 on page 19).

For more information about installing and using Common Property Tables, refer to the 
Common Property Tables User Guide.
17



Distributed Environments

If you are running Class Based QoS on a distributed system across multiple servers, the 
central server, every satellite server, and every remote poller must be running the same 
version of OVPI and all available service packs for that version of OVPI. When you install the 
Class Based QoS on the central server, deploy reports. When you are done installing packages, 
you must configure each server by following the steps under Configuring Distributed Systems 
on page 35.
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Installing Class Based QoS

Task 1: Extract Packages from the Report Pack CD

1 Log in to the system. On Windows systems, log on with Administrator privileges. On 
UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, type one of the following:

HP-UX: sh /sbin/ovpi_timer stop 

Sun: sh /etc/init.d/ovpi_timer stop 

3 Insert the Report Pack CD.

Windows: A Main Menu displays automatically.

UNIX: Mount the CD, navigate to the top-level directory for the CD drive, and run the 
./setup command.

4 Select OVPI Report Packs by typing 1 in the choice field and pressing Enter. The install 
script displays a percentage complete bar. When extraction finishes, the install script 
starts Package Manager. The Package Manager welcome window opens.

If you navigate to the Packages directory on your system, you will see the following 
folders:

— Class_Based_QoS

— Class_Based_QoS_Datapipe

Task 2: Upgrade to Common Property Tables 3.6 

1 Do not install any other package with the Common Property Tables upgrade package; 
install the CPT upgrade package and only the CPT upgrade package.

2 When prompted to accept or disable the option to Deploy Reports, accept the default. If 
you do not deploy reports, you will not deploy the change forms that come with Common 
Property Tables.

3 When the install finishes, click Done to return to the Management Console.

If you need more help with this task, refer to the Common Property Tables User Guide.

Task 3: Install the Report Pack and the Datapipe

1 If Package Manager is not running, select Package Manager from the Management 
Console.

2 Click Next. The Package Location window opens.

3 Click the Install radio button.

4 Approve the default installation directory or use the browse feature to select a different 
directory if necessary.

5 Click Next. The Report Deployment window opens.

6 Accept the default settings for Deploy Reports. 

Also accept the defaults for the application server name and port.
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7 Type the same username and password as you used on the Management Console.

8 Click Next. The Package Selection window opens.

9 Select the check box next to the following package names:

— Class_Based_QoS 1.1

— Class_Based_QoS_Datapipe 1.1

10 Click Next. The Type Discovery window opens.

You can run Type Discovery at this point.

11 The Selection Summary window opens. Verify that the contents of this window are 
correct.

12 Click Install to begin the installation process. The Installation Progress window opens 
and the install process begins. When the install process is complete, a success install 
complete message appears.

13 Click Done.

14 Restart OVPI Timer.

Windows NT: Select Settings > Control Panel > Administrative Tools > Services 

UNIX: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer start 

Sun: sh /etc/init.d/ovpi_timer start 

Installing the demo package is optional. You can install the Class Based QoS demo package by 
itself, or you can install the demo package along with the Report Pack.
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Configuring Class Based QoS

The Datapipe lets you select the period when the configuration information will be collected. 
It lets you limit the collection of Class Based QoS data to specified interfaces. And it lets you 
select the period when the Class Based QoS running statistics will be collected.

There are two forms for configuring the Datapipe. The forms are available through the Admin 
Console. Go to Objects > Object/Property Management.

Force CB QoS Rediscovery Form

This form lets you determine when re-polling will take place when the Class Based QoS device 
configuration changes.
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Administer Poll Flag for CB QoS Interfaces Form

This form lets you decide whether the interface on the supported devices can be polled or not.
    

Once the configuration collection interval and polled interfaces are selected, Class Based QoS 
configuration data is collected from the devices. The data is available in the base tables of the 
Report Pack. The Overview reports show the QoS collection overview.
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Accessing Deployed Reports

When you install Class Based QoS, the Deploy Reports option is enabled. As a result, the 
reports in this package (as well as any forms associated with the package) are deployed to the 
OVPI Application Server. Once reports reside on the OVPI Application Server, they can be 
viewed in two ways:

• OVPI client applications

• Web browser

       

If the client applications are installed on the user’s system, the user has access to Report 
Viewer, Report Builder, and the Management Console. If the client applications are not 
installed on the user’s system, using a web browser to view reports is the only way the user 
can view reports.

For more information about the clients, refer to the HP OpenView Performance Insight 
Installation Guide. For details about the Management Console, including how to use the 
Object/Property Management view to launch reports specific to a selected object, refer to the 
HP OpenView Performance Insight Administration Guide.
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Package Removal

Follow these steps to uninstall Class Based QoS. Removing the Report Pack automatically 
removes the Datapipe.

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

3 Start Package Manager. The Package Manager welcome window opens.

4 Click Next. The Package Location window opens.

5 Click the Uninstall radio button.

6 Click Next. The Report Undeployment window opens.

7 If reports were deployed to the OVPI Application Server, accept the defaults for Undeploy 
Reports, Application Server Name, and Port. Otherwise, clear the check box and skip to 
step 9.

8 Type your username and password for the OVPI Application Server.

9 Click Next. The Package Selection window opens.

10 Click the check box next to the following packages:

Class Based QoS Report Pack 1.1

Class Based QoS Report Pack Demo 1.0

11 Click OK.

12 Click Next. The Selection Summary window opens.

13 Click Uninstall. The Progress window opens and the removal process begins. When the 
uninstall process is complete, a package removal complete message appears.

14 Click Done to return to the Management Console.

15 Restart OVPI Timer.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, type the following:

HP-UX: sh /sbin/ovpi_timer start 

Sun: sh /etc/init.d/ovpi_timer start 

The Class Based QoS Report Pack can be uninstalled independent of any other report pack.
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Troubleshooting

Perform the following steps to debug the problem in case reports do not show data. 

• Verify that data collection is successful.

— Check whether the configuration collection interval has been configured correctly

— Check whether the interfaces on the supported devices have been selected for the 
polling

• Check for errors in map procedure.

— Check the “trend.log” for error messages

• Make sure that Trendtimer is running.

• Open the View Troubleshooting external link

http://support.openview.hp.com/troubleshooting.jsp 
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3 Sample Reports from the Demo Package
The following reports are located in the demo package. They illustrate the types of reports 
that can be available to you. To see these reports on the demo package, click the Catalog tab 
and then click System > Demo.

Sample DrillDown Reports

Dropped Bit Rate History Report for the QoS Classes in a Device       
27



Queuing History Report for the QoS Classes in a Device       
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Utilization History Report for the QoS Classes in a Device      
Sample Reports from the Demo Package 29



Sample Summary Reports

Policing Summary by Class Report     
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Traffic Shaping Summary by Class Report     
Sample Reports from the Demo Package 31



Sample TopN Reports

Queuing Top N Report    
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Utilization Top N Report    
Sample Reports from the Demo Package 33
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4 Configuring Distributed Systems
This chapter covers the following topics:

• Configuring the Central Server on page 35

• Configuring Satellite Servers on page 37

• System Clocks on page 37

If you are running OVPI as a distributed system, you installed Class Based QoS on the central 
server and on each satellite server. You also installed the Class Based QoS Datapipe on each 
server that polls. When you finish installing packages, you have to configure the servers in 
your system.

Configuring the Central Server

To configure the central server, perform the following tasks:

Task 1: Register the satellite server by setting the database role

1 Start the Management Console (log on with Administrator privileges).

2 Click the Systems icon in the navigation pane.

3 Navigate to the OVPI Databases folder and select the database system.

4 Click Database Properties.

5 From the Database Role list, select the Satellite Server role.

6 Enter any information necessary to configure the Satellite Server role.

To add a new database reference, you can use the Add Database Reference Wizard in the 
System and Network Administration application.

Task 2: Enable LIR

1 Start the Management Console (log on with Administrator privileges).

2 Click the Systems icon in the navigation pane.

3 Navigate to the OVPI Databases folder and select the central server.

4 Click LIR Configuration.

5 Select the LIR enabled check box.

Task 3: Add LIR mappings

1 Start the Management Console (log on with Administrator privileges).

2 Click the Systems icon in the navigation pane.
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3 Navigate to the OVPI Databases folder and select the central server. 

4 Click LIR Configuration.

5 Click Add Mapping.

6 From the Select Satellite Server list, select a satellite server to which to add a mapping.

7 Select the Category data table option.

8 Select Class Based QoS from the drop-down list.

9 Select the rate data type.

10 Click Add to List.

11 If you want to add additional LIR mappings, click Add to list and repeat step 6 through 
step 10.

12 Click OK.

13 Click Apply.

A copy policy is automatically generated for the hourly data and for each LIR mapping that 
you add. The data type selected when adding an LIR mapping (in step 9 above) determines 
the type of data copied that is defined in the generated copy policy (the type of data copied 
that is defined in the generated copy policy is for one greater than the data type selected in 
the LIR mapping). For example, if you select an hourly data type, a daily data copy policy is 
generated.

Task 4: Verify the automatically generated copy policies

Verify that a copy policy has been generated for the following tables and that the copy type is 
set correctly (to Property and Data):

1 Start the Management Console (log on with Administrator privileges).

2 Click the Copy Policy icon in the navigation pane to start the Copy Policy Manager.

3 Find the following tables and verify the copy type is set to Property and Data for each 
table:

• SHIPStatData

• SHIPStatInterfaceData

If a copy policy has not been generated for a table, do the following:

1 Click the New Copy Policy icon or select File > New Copy Policy from the Copy Policy 
Manager. The Copy Policy Wizard displays.

2 Click Next. The Satellite Server and Copy Policy Selection Page displays.

3 Select a satellite server from the pull down list. This is the satellite server from which 
data is copied to the central server.

4 Select Single Table and select the table from the pull down list.

5 Click Next. The Copy Type Selection Page displays.

6 Select Property and Data.

7 Click Next. The Summary page displays.

8 Verify the information in the summary window. If the information is not correct, you can 
modify it by clicking Back.

9 Click Finish.
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10 Repeat step 4 - step 9 for all missing tables.

If the copy type is not set to Property and Data, do the following:

1 Double-click the copy policy.

2 Select the Property and Data copy type.

3 Click OK.

Task 5: Modify the trendtimer.sched file 

The trendtimer.sched file is found in the {DPIPE_HOME}/lib/ directory. In this instance, 
{DPIPE_HOME} is the directory in which OVPI is installed.

Change this file by finding and commenting out the following line:

1:00+15 - - {DPIPE_HOME}/bin/trend_proc -f 
{DPIPE_HOME}/scripts/CB_QOS_Hourly.pro

Configuring Satellite Servers

Follow these steps to configure each satellite server.

1 Modify the {DPIPE_HOME}/lib/trendtimer.sched file (where {DPIPE_HOME} is the 
directory in which OVPI is installed). Do the following:

• Find and comment out the following line (to switch off interface aggregations above 
the hourly level):

24:00+3:00 - - {DPIPE_HOME}/bin/trend_proc -f
{DPIPE_HOME}/scripts/CB_QOS_Daily.pro

• Modify the *.pro trendtimer entry in the {DPIPE_HOME}/lib/trendtimer.sched file. By 
default, this process starts at 30 minutes after the hour. To make sure the satellite 
server completes hourly summarizations before the central server begins hourly 
summarizations, change the start time from 1:00+30 to 1:00+15.

2 Modify the *.pro file (found in the {DPIPE_HOME}/scripts/directory. In this instance, 
{DPIPE_HOME} is the directory in which OVPI is installed):

3 Configure polling policies for the Class Based QoS Datapipe, making sure that each 
Interface is polled by one satellite server only.

System Clocks

Make sure that the system clock on each satellite server is synchronized with the system clock 
on the central server.
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