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Before You Install

Welcome to WinRunner, Mercury Interactive’s enterprise functional testing 
tool for Windows 95, Windows 98, Windows NT 4.0, Windows 2000,  
Windows Me, and Windows XP. This guide describes everything you need to 
know to install WinRunner on a standalone computer or on a network. It 
describes the WinRunner package contents, system configuration, 
registration procedures, how to choose a license type, and how to run the 
setup program.

Before you begin to install WinRunner, please review the following pre-
installation procedures.

Registering Your Copy of WinRunner

Register your copy of WinRunner to become a licensed user with all rights 
and privileges. Registered users can access technical support and 
information on all Mercury Interactive products, and are eligible for updates 
and upgrades.

Note: You can register your copy of WinRunner on Mercury Interactive’s 
Customer Support site (http://support.mercuryinteractive.com).

If your address changes, notify Mercury Interactive or your local 
representative, so that you can continue to receive product information and 
updates.
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System Requirements

In order to successfully run WinRunner, you need the following minimum 
system requirements:

Platform An IBM-PC or compatible with a single CPU,  
Pentium® /100MHz or higher microprocessor.

Memory A minimum of 32 MB of RAM memory.

Disk Space 72 MB of free disk space for a compact installation or 
164 MB for a typical or complete installation. You may 
need an additional 20 to 40 MB on the drive where 
Windows is installed, depending on the shared 
components already installed on the machine. (An 
additional 5 MB of free disk space is required during 
the installation process.)

Operating System Windows® 95, Windows® 98, Windows NT® 4.0, 
Windows® 2000, Windows® Me, or Windows® XP.

Upgrading from a Previous Version

You can install a standalone version of WinRunner over a previous version. 
Note that any changes made to the tests or any other files in the \lib 
directory will be overwritten. However, the existing \lib directory will be 
backed up as \lib.bak. Note that if lib.bak already exists, the existing \lib 
directory will not be backed up. You should separately save any files you 
added or changed manually before installing WinRunner 7.5 over a previous 
WinRunner installation. Configuration changes made in the wrun.ini file 
will not be overwritten when installing WinRunner 7.5.

You cannot install WinRunner over WinRunner 2000 or WinRunner EURO. 
You must uninstall WinRunner 2000 or WinRunner EURO before installing 
WinRunner. For more information, see “Uninstalling WinRunner” on 
page 57.
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To use WinRunner 7.5, you need a local or floating license code. If you 
already have a license code, but you are upgrading from WinRunner version 
7.0 or earlier, you need a new license code.  Request your license code from 
the Mercury Interactive Customer Support Web site at: 
http://support.mercuryinteractive.com/get-WR-license.  

For more information on installing local licenses, see “Working with 
WinRunner Licenses” on page 38.  For more information on installing 
floating licenses, refer to the WinRunner Floating-License Installation Guide.

Note: There are documented backward compatibility problems with 
Microsoft ODBC 4, which is installed by WinRunner, Microsoft Office 2000, 
and other applications. When any of these programs is installed on a 
machine where TestDirector 5.0 is installed, TestDirector may behave 
unexpectedly.

Note: When upgrading to WinRunner 6.0 or later, make sure to upgrade to 
TestDirector 6.0 or later, or install any software that installs ODBC 4 on 
another machine.

Logging in Before Installing WinRunner

You must log in with administrator permissions before you run the 
setup program. Otherwise, you will receive a warning message and the 
setup program will close.
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Understanding License and Installation 
Types

Before you run the WinRunner setup program, you must know which 
license type you plan to use, and which type of installation you want to 
install.

This section describes:

➤ Understanding Your WinRunner License

➤ Choosing the Installation Type

Understanding Your WinRunner License

To use WinRunner, you must have a valid license. There are two types of 
licenses: local and floating.  The table below summarize the differences 
between the two license types.

Topic Local License Floating License

General 
description

The license is specific to the 
machine on which it is 
installed. 

Each license entitles the 
organization to one additional 
concurrent user. 

Number of 
installations 
per license 
code

Each installation of 
WinRunner requires a 
distinct license code.

There is no limit to the number 
of WinRunner installations on 
the network, but a special license 
server regulates the number of 
computers that can run a copy of 
WinRunner at any time.
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Note that the license type and installation type are not co-dependent: you 
can install WinRunner using any installation type, regardless of the license 
type you choose and vice versa. For more information on installation types, 
see “Choosing the Installation Type” on page 7.

Demo license The installation includes a 
30-day demo license.

You must request and 
activate a license code 
during the 30 days.

The installation does not include 
a  demo license. You must 
request and activate the license 
code on the license server before 
you can use WinRunner.

Maintenance 
number

The license code is based 
partially on the 
maintenance number. The 
maintenance number 
identifies the customer.

The license code is based 
partially on the maintenance 
number. The maintenance 
number identifies the customer 
and indicates how many 
concurrent users the license will 
support.

Other issues The license code is based 
partially on the locking 
code, which identifies the 
computer on which the 
WinRunner program is 
installed.  The supplied 
license code works only for 
the computer on which the 
locking code was 
generated.

Not supported for Unix and 
Novell networks.

The license server must have a 
fixed IP address.

It is recommended to use an NT 
server or a Windows® 2000 
operating system for the license 
server.

WinRunner machines must have 
TCP-IP installed.

To use floating licenses across 
networks, UDP port 5093 must 
be open on the server machine.

Topic Local License Floating License
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Installing WinRunner Licenses

The general procedure for installing WinRunner and activating the license 
differs for local license installations and floating license installations. This 
section summarizes these procedures for the two license types and directs 
you to the detailed information for each step.  

To install WinRunner with a local license:

 1 Run the WinRunner setup program (autorun.exe). If you are installing a 
standalone or network installation for the first time, select Local License in 
the license type screen.  For more information and step-by-step instructions, 
see “Running a Standalone or Network Installation” on page 9, or “Running 
a Workstation Installation” on page 27.

 2 Run WinRunner using the 30-day demo license.

 3 Request your local license code. For more information, see “Requesting a 
Local WinRunner License Code” on page 39.

 4 Once you receive the license code from Mercury Interactive, enter the code 
to activate your license. For more information, see “Activating a Local 
WinRunner License Code,” on page 41.

 5 If you plan to test Visual Basic 4.0 or 5.0 applications, and/or ActiveX table 
objects, configure your application as described in “Configuring Visual Basic 
4.0 and 5.0 Support,” on page 47 and “Enabling Table Contents Checks for 
an ActiveX Control,” on page 50.

To install WinRunner with a floating license:

 1  Install the Floating License Server on a network computer with a fixed IP 
address.  For more information and step-by-step instructions, refer to the 
"Installing a Floating-License Server" section of the WinRunner Floating-
License Installation Guide.

 2  Request your floating license code. For more information, refer to the 
"Requesting a Floating License" section of the WinRunner Floating-License 
Installation Guide.

 3 Once you receive the floating license code from Mercury Interactive, enter 
the code to activate your license on the license server. For more information, 
refer to the "Activating a Floating License" section of the WinRunner 
Floating-License Installation Guide.



Understanding License and Installation Types

7

 4 Run the WinRunner setup program (autorun.exe). If you are installing a 
standalone or network installation for the first time, select Floating License 
in the license type screen. For more information and step-by-step 
instructions, see “Running a Standalone or Network Installation” on page 9, 
or “Running a Workstation Installation” on page 27.

 5 If you plan to test Visual Basic 4.0 or 5.0 applications, and/or ActiveX table 
objects, configure your application as described in “Configuring Visual Basic 
4.0 and 5.0 Support,” on page 47 and “Enabling Table Contents Checks for 
an ActiveX Control,” on page 50.

 6 Begin using WinRunner.  When WinRunner opens, it will automatically find 
the license server and connect to it.

Note: For additional information, and answers to common license code 
questions, see http://kb-web.mercuryinteractive.com/license.html.

Choosing the Installation Type

Before you install WinRunner, you need to decide whether to install 
WinRunner on your computer as a: 

➤ standalone installation: an independent installation.  You run the 
complete setup program and can select the installation options you want for 
your computer. 

Note: You can also record your standalone installation to enable other users 
to perform a silent installation with an identical configuration. For more 
information on silent installations, see “Setting Up a Silent Installation,” on 
page 33.  
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➤ network installation: a WinRunner configuration that enables users to run 
a simplified workstation installation based on the options and components 
you select during the installation process.  Note that, by default, the 
network installation does not enable you to use WinRunner from the 
computer on which you install it. If you want to use WinRunner on that 
computer, select to install a Network installation and add shortcuts to your 
Start menu.

➤ workstation installation: a simplified installation based on a network 
installation. When you install a workstation installation, only a few 
configuration files and shortcut icons are installed on your computer.  The 
WinRunner software is located on the network computer, accessible via the 
installed shortcuts in your Start menu.  When you run WinRunner from 
your workstation, changes you make in configuration dialog boxes are saved 
on your computer so that your customization preferences are set 
automatically each time you run WinRunner from your computer.
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Installing WinRunner

Before installing WinRunner, you must know which type of installation you 
want to run, and which type of license you want to install.  For more 
information, see “Understanding License and Installation Types,” on page 4 
and “Choosing the Installation Type,” on page 7. 

Important upgrade information: If you are upgrading from WinRunner 
7.0 or earlier, you must contact Mercury Interactive customer support to 
receive a new license code, as described in “Working with WinRunner 
Licenses,” on page 38 and in the WinRunner Floating-License Installation 
Guide.

This section describes:

➤ Running a Standalone or Network Installation

➤ Running a Workstation Installation

➤ Using a Local Network Drive for Updates

➤ Setting Up a Silent Installation

Running a Standalone or Network Installation

You use the following procedure in order to install a WinRunner standalone 
or network installation. 

If you are performing a network installation, follow the procedure below to 
install WinRunner on the network, and then run the workstation 
installation on each user workstation as described on page 27.



WinRunner Installation Guide

10

To run a standalone or network WinRunner installation:

 1 Insert the CD-ROM into the CD-ROM drive. If the CD-ROM drive is on your 
local machine, the WinRunner Setup window opens. If you are installing 
from a network drive, connect to the drive and run autorun.exe under the 
\setup subdirectory. 

If you want to view last minute information about WinRunner, click 
Readme. If you want to browse the folders on the WinRunner Installation 
CD-ROM, click Browse. If you want to view an overview of WinRunner, 
click Quick Preview. If you want to review the list of new WinRunner 
features, click What’s New.
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Note: You must be logged on with Administrator privileges in order to 
install WinRunner.

 2 Click Install. The WinRunner Setup splash screen and the Setup progress bar 
open. 

If a previous version of WinRunner is already installed on your computer, 
the setup program uses the license settings from your current installation. If 
you want to change the license type, you can use the Change License Type 
utility after you complete the installation process. For more information, see 
“Changing the License Type,” on page 45. Proceed to step 4.

 3 If you are installing WinRunner for the first time, the License Type screen 
opens. Choose a license type.

➤ Local license: A license that is specific to the machine on which it is 
installed. This license includes a 30-day period during which you must 
contact Mercury Interactive to obtain a permanent local license.
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➤ Floating license: A license server on the network regulates the number of 
concurrent WinRunner users. Each license entitles the organization to 
one additional concurrent user. 

Note: Before you install WinRunner with a floating license, you must 
install a license server on the network from the WinRunner Floating 
License Server CD-ROM in the WinRunner package. You purchase your 
floating license from Mercury Interactive and install it on the network 
license server. For information on installing a floating-license server on 
the network, refer to the WinRunner Floating-License Installation Guide.

For more information on license types, see “Understanding Your 
WinRunner License,” on page 4. If you are not sure which type of license to 
install, contact your system administrator or your local Mercury Interactive 
representative.

 4 The Software License Agreement screen opens. To install WinRunner, you 
must accept the terms of the license agreement by clicking Yes. If you click 
No, the setup program will close. 
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 5 In the Registration Information screen, type your name, the name of your 
company, and a WinRunner maintenance number. This number can be 
found in the Maintenance Pack Number envelope or on the bill of lading 
you received when you purchased WinRunner. 

The maintenance number replaces what was formerly a serial number for 
each purchased copy of WinRunner. Note that there is a single maintenance 
number for each team of users. 

The maintenance number, which identifies the customer, determines what 
components your license supports and how many licenses are generated for 
a floating license. 

Click Next.

 6 Click Yes in the Registration Confirmation screen to confirm the 
registration information.
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 7 The Installation Type screen opens.   

Select one of the following:

➤ Standalone Installation: Installs WinRunner on a hard disk of your local 
computer.

➤ Network Installation: Installs WinRunner files that enable other users to 
run a simplified workstation installation, and to run WinRunner on their 
computer using the software installed on your network computer.

➤ Network Installation and add shortcuts to your Start menu: Installs a 
network installation as described above and adds workstation shortcuts 
to your Start menu so that you can run WinRunner from the computer 
on which you installed the Network installation.

Note: You cannot install a network installation over a previous version of 
WinRunner. When performing a network installation of WinRunner, 
either remove installations of previous versions first, or install the 
network installation in a different location.  
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For more information on installation types, see “Choosing the Installation 
Type,” on page 7. If you are not sure which type of license to install, contact 
your system administrator. 

Click Next. If you are installing WinRunner on Windows 2000 or Windows 
XP, proceed to step 8. If you are installing WinRunner on Windows 95, 
proceed to step 9. Otherwise, proceed to step 10.

 8 If you are installing WinRunner on Windows 2000 or Windows XP, the 
Enable Memory Access screen opens.

WinRunner’s text recognition on Windows 2000 and Windows XP requires 
access to memory pages that are protected by default. Choose whether to 
remove this protection. Note that if you do not remove this protection, 
WinRunner will not be able to perform text recognition on your 
applications.

Click Next and proceed to step 10.
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 9 The Setup program prompts you to install DCOM if you:

➤ are installing WinRunner on Windows 95, and 

➤ do not have DCOM version 4,71,0,2618 installed, and 

➤ are performing one of the following:

➤ a standalone installation

➤ a network installation that adds shortcuts to your Start menu

Note that DCOM must be installed on your machine in order to install 
WinRunner. 

If you click Next to install DCOM, the WinRunner setup program closes and 
the DCOM installation begins. Once you finish installing DCOM, you must 
reboot your computer and then restart the WinRunner setup program.

 10 The Setup Type screen opens. Choose the type of installation: Typical, 
Compact, or Custom.
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A Typical installation installs commonly used program files, including 
online documentation and samples, WebTest add-in support, and add-in 
support for PowerBuilder, Visual Basic, and ActiveX. Note that you can 
choose which add-ins to load at the beginning of each WinRunner session. 
For additional information on loading add-in support, refer to the 
“WinRunner at a Glance” chapter in the WinRunner User’s Guide.

A Compact installation installs only the required WinRunner program files, 
without online documentation, samples, WebTest add-in support, or add-in 
support for PowerBuilder, Visual Basic, and ActiveX controls.

A Custom installation enables you to select which components to install.

Note: When you install a standalone installation of WinRunner, Microsoft 
ODBC 4 is installed on your machine. 

Click Next. If you chose a Typical or Compact installation, proceed to step 
12.
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 11 If you chose a Custom installation, the Select Components screen opens. 
Select the components you want to install. You can also specify the 
destination folder using the Browse button. To check the space available on 
a disk drive, click Disk Space.

Click Next and proceed to step 13.
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 12 If you chose a Typical or Compact installation, the Choose Destination 
Location screen opens. Specify the destination folder. To check the space 
available on a disk drive, click Disk Space.

Click Next.
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 13 The Update Components screen opens. If you have Microsoft Internet 
Explorer version 3.0 or later installed (or any other software that installs 
wininet), you can check the Mercury Interactive Web site for updated 
components. 

➤ Click Yes to check the Mercury Interactive Web site for updated 
components. 

➤ Click No if you want to install the components from the CD-ROM without 
checking for updated components. 

➤ Click Use local update folder only if you know that updated components 
have already been downloaded to a folder on your local network. See 
page 30 for more information on this option.

Click Next.

If you chose Yes in the Update Components screen, the installation checks 
the Mercury Interactive Web site for updated components. If there are 
components on the Web site that are newer than components on the CD-
ROM, setup prompts you to overwrite the CD-ROM components with the 
Web site components. If no newer components are found on the Web site, 
then setup installs all components from the CD-ROM.
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If the installation cannot access the Web site, you can click Retry to try to 
connect to the Web site again. If you click Cancel, the setup program installs 
the WinRunner components from the CD-ROM.

 14 If you are installing WinRunner over a previous WinRunner installation, the 
Install/Reinstall Components screen opens. 

Decide whether to reinstall all existing components or only components 
with newer versions, and whether to Install all new components.
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 15 If you selected Network Installation and add shortcuts to your Start menu in 
the Setup Type screen in step 10, the Choose Local WinRunner Folder screen 
opens. Select a location for the local WinRunner folder. This folder enables 
you to configure WinRunner to meet your specific testing requirements, 
while running a shared version over the network.

Click Next.
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 16 The Choose WinRunner Temporary Folder screen opens. Choose the 
location of your WinRunner temporary folder. 

Click Next.
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 17 The Select Program Folder screen opens. Select the program folder for the 
WinRunner icons.

Click Next.

 18 The Start Copying Files screen opens. The installation settings you selected 
are displayed in read-only format. Review the settings. If you want to select 
different settings, click Back. If you are satisfied with the settings, click Next. 

The installation process begins. To pause or quit the installation process, 
click Cancel.

 19 If you installed Visual Basic support and/or online documentation, the 
Mercury Interactive Setup screen opens. Read the information on the screen 
and click Next.
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 20 The License Information Screen opens. Read about the type of license you 
installed.

➤ Local license: Each WinRunner machine requires its own license. The first 
time WinRunner is installed on a machine, it includes a 30-day demo 
license. During this time period you should contact Mercury Interactive 
to receive a permanent license for your machine. You can install the 
permanent license when you start WinRunner or from the WinRunner 
Help menu. For additional information, see “Working with WinRunner 
Licenses” on page 38. 

Note: Do not change the date on a computer running WinRunner with a 
demo license.

➤ Floating license: A license server on the network regulates the number of 
concurrent WinRunner users. This enables you to run WinRunner on any 
machine on your network. It requires installing a floating license server 
and a floating license from the WinRunner Floating License Server CD-
ROM in the WinRunner package. For additional information, refer to the 
WinRunner Floating-License Installation Guide.

Click Next.

The installation process is complete.

 21 The Registration Information screen opens. Read the information about 
Mercury Interactive’s Customer Support. If you register, you receive:

➤ access to Mercury Interactive’s award-winning Customer Support Web 
site

➤ notification of new product releases and upgrades

To register as a Mercury Interactive customer now, select the Register now 
check box. Mercury Interactive’s Customer Support Web site opens to the 
registration page.

Click Next.
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 22 The Setup Complete screen opens. Choose whether or not to restart your 
computer.

Click Finish to complete the setup process.

If you installed a network installation of WinRunner, run a workstation 
installation on all workstations. For more information, see “Running a 
Workstation Installation,” on page 27.

➤ To read any last-minute information, click Start > Programs > WinRunner > 
Read Me. The Read Me file opens in Microsoft Wordpad.

➤ To view the WinRunner online books, you must have Acrobat Reader 5.0 or 
later installed. You can install it by clicking Start > Programs > WinRunner > 
Documentation > Acrobat Reader Setup and following the on-screen 
instructions. To view online books, click Start > Programs > WinRunner > 
Documentation > WinRunner Books Online.

➤ To start WinRunner, click Start > Programs > WinRunner > WinRunner.

Note: If you try to start WinRunner before restarting your computer, 
WinRunner will not run properly.

Note: If you installed WinRunner on Windows NT or Windows 2000, 
then after restarting your computer, you must log in (for the first time) 
with the same login name that was used when installing WinRunner.
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Adding Components to a Network Installation

If you want to enable workstation installations to work with additional 
WinRunner add-ins, install the add-ins on your network installation before 
running the workstation installations. 

If you install additional components from the WinRunner CD or additional 
WinRunner add-ins on the network installation after you complete the 
workstation installations, you need to run the workstation installation again 
to update each workstation with the list of available add-ins.

For information on installing additional components from the WinRunner 
CD, see “Adding WinRunner Components,” on page 54. For information on 
installing add-ins, refer to the Installation Guide for your WinRunner add-
in.

Running a Workstation Installation

A workstation installation should be performed for each user running 
WinRunner from the network. This installation can be performed only after 
the network installation is successfully completed. 

 1 Map to the network drive where the Network installation is installed.

 2 Click Start > Run.

 3 Type <��������	�
������	��
��������
�����
�������� and click OK.

The WinRunner setup program starts. The WinRunner Setup splash screen 
and the Setup progress bar open.

 4 The software license agreement appears. To install WinRunner, you must 
accept the terms of the license agreement by clicking Yes. If you click No, 
the setup program will close.

 5 In the Registration Information dialog box, type your name and click Next.

 6 In the Registration Confirmation screen, click Yes to confirm the 
registration information.

 7 Confirm the Workstation Installation message and click Next.
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 8 If you are installing WinRunner on Windows 2000 or Windows XP, the 
Enable Memory Access screen opens. WinRunner’s text recognition on 
Windows 2000 and Windows XP requires access to memory pages that are 
protected by default. Choose whether to remove this protection. Note that if 
you do not remove this protection, WinRunner will not be able to perform 
text recognition on your applications.

 9 Setup prompts you to install DCOM if you:

➤ are installing WinRunner on Windows 95, and 

➤ do not have DCOM version 4,71,0,2618 installed

Note that DCOM must be installed on your machine in order to install 
WinRunner. 

If you click Next to install DCOM, the WinRunner setup program closes and 
the DCOM installation begins. Once you finish installing DCOM, you must 
reboot your computer and then restart the WinRunner setup program.

 10 Define the location for the local WinRunner folder.

The WinRunner folder on your hard drive is used to store configuration files 
you create during the testing process. Configuration files in this folder 
override configuration files of the same name on the network, so that you 
can configure WinRunner to your specific testing requirements.

Click Next.

 11 Select the location of your WinRunner temporary folder.

Setup updates and installs system files.

Click Next.

 12 Select the program folder for the WinRunner icons.

Click Next.
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 13 Restart your computer. The WinRunner program folder is added to your 
Start menu.

➤ To read last-minute information about WinRunner, click Start > Programs > 
WinRunner > Read Me. The Read Me file opens in Microsoft Wordpad.

➤ To view the WinRunner online books, you must have Acrobat Reader 5.0 or 
later installed. You can install it by clicking Start > Programs > WinRunner > 
Documentation > Acrobat Reader Setup and following the on-screen 
instructions. To view online books, click Start > Programs > WinRunner > 
Documentation > WinRunner Books Online.

➤ To start WinRunner, click Start > Programs > WinRunner > WinRunner.

Note: If you install additional components from the WinRunner CD or 
additional WinRunner add-ins on the network installation after you 
complete the workstation installation, you need to run the workstation 
installation again to update each workstation with the list of available 
add-ins.

Note: If you try to start WinRunner before restarting your computer, 
WinRunner will not run properly.

Note: After restarting your computer, you must log in (for the first time) 
with the same login name that was used when installing WinRunner.
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Using a Local Network Drive for Updates

You can download WinRunner installation updates from the Mercury 
Interactive Web site to a network drive and then access the local network 
drive for all WinRunner installations in your organization.

To download updates to a local network drive:

 1 Insert the CD-ROM into the CD drive and run <CD drive>\update.exe.

 2 The Download Updates screen opens.

Choose the local network drive for the WinRunner update files. Click Next.

 3 Setup begins to download the files. When the download is complete, the 
Updates Download Complete screen opens. Click Finish.
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Note: When you run update.exe, the program downloads all posted updates, 
regardless of their contents and versions. When installing updates from a 
local network drive during the WinRunner installation, however, the setup 
program downloads in the same way as it downloads from the Web site, 
installing only those components that are part of the current installation 
and newer than the components on the CD-ROM. 

Once the updates have been downloaded to a local network drive, you can 
link to that drive from the WinRunner installation in order to download the 
updates locally.

To download updates from a local network drive during a WinRunner 
installation:

 1 When the Update Components screen of the WinRunner installation opens, 
select Use local update folder.
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 2 The Select Downloaded Updates Path screen opens.

Use the Browse button to select the path where the updates are stored. Click 
Next. The installation program checks the specified network folder for 
updated components. If there are components in the update folder that are 
newer than components on the CD-ROM, setup prompts you to overwrite 
the CD-ROM components with the update folder components. When the 
check is complete, the installation program continues as described in step 
15 on page 22.
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Setting Up a Silent Installation

You can run the WinRunner setup application silently on your computer.  
This means that the entire setup process runs in the background without 
requiring you to navigate through the setup screens.   Before you run a silent 
installation, you (or the system administrator) must record the installation 
preferences of a standalone WinRunner installation on a computer with an  
identical computer configuration. Your silent installation will install an 
exact copy of the recorded configuration.

Recording a Standalone Installation

You record your standalone installation on a computer with a configuration 
that is identical to the computer(s) that will later run the silent installation 
including:

➤ identical operating systems

➤ same drive letter for installation files

➤ neither computer should have WinRunner installed prior to running the 
silent installation

Note: If either computer already has WinRunner installed, you should 
uninstall WinRunner before beginning the silent installation process in 
order to ensure that both computers have identical configurations.

If you want to download installation updates from the Web, you should 
follow the instructions in “Using a Local Network Drive for Updates” on 
page 30 before recording your standalone installation.

To record a standalone installation:

 1 Copy the contents of the WinRunner installation CD to a shared folder on a 
network computer (�������
��
�����).

 2 Choose Start > Run from the computer on which you want to record the 
installation (the recording computer), and type: 
�������
��
������
�����
�����������.
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 3 Click OK.  The WinRunner installation begins. For information on how to 
install WinRunner, see “Running a Standalone or Network Installation” on 
page 9.  While recording your installation, consider the following:

➤ In the installation type screen, select Standalone Installation.

➤ For any screens requiring a destination folder, be sure to choose a drive 
that all silent installation users have on their computer. If the destination 
folder you choose already exists on your computer, be sure that it exists 
for all silent installation users. If the folder you choose is a new folder, be 
sure that it is a new folder for all users.

➤ In the Update Components screen, select No, or select Use local update 
folder if you already downloaded updated components to a local folder. 
If you select Yes to connect and download from the Web while recording 
the installation, the silent installation user will be required to respond to 
certain dialog boxes and Web pages, so the installation will not be 
entirely silent.

➤ In the Customer Registration screen, clear the Register now check box.  
Register at the Mercury Interactive Customer Support Web site at another 
time. If you select the Register now check box, the silent installation user 
will be required to respond to certain dialog boxes and Web pages, so the 
installation will not be entirely silent.

➤ In the Setup Complete screen, it is recommended to select Yes, I want to 
restart my computer now to assure that the silent installation will 
conclude with a restart on users’ computers in order to properly complete 
the installation process.  

 4 After restarting your computer, copy the setup.iss file from the Windows 
folder of the recording computer to ��������	
�����
������\english. 

 5 Open the copy of setup.iss in ��������	
�����
������\english in a text 
editor and change the 
��	�� entry in the ������ !���"# section to 

��	����$$!.
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Running a Silent Installation 

You can run a silent installation of WinRunner based on a recorded 
standalone installation. This enables you to install WinRunner on your 
computer with the identical installation options and components as the 
recorded installation without having to navigate through the installation 
screens.

To run a silent installation:

 1 It is recommended to save any open files and close all open applications 
before running the silent installation. 

Important Note: Your computer automatically shuts down and restarts at 
the end of the silent installation if the recorded installation includes the 
Yes, I want to restart my computer now option at the end of the installation 
process as recommended.

 2 Choose Start > Run on the computer on which you want to install 
WinRunner silently, and type: �������
��
������
�����
�������� �
�

 3 Click OK. The installation begins to run in the background. The installation 
will take several minutes. During the installation, the following message is 
displayed:

 4 When the silent installation is complete, the message box closes.  

If the recorded installation applies the Yes, I want to restart my computer 
now option at the end of the installation process (recommended), then your 
computer automatically restarts when the silent installation is complete.

If the recorded installation applies the No, I will restart my computer later 
option at the end of the installation process, then the WinRunner program 
group window opens displaying the WinRunner program icons when the 
silent installation is complete.
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Note: If the WinRunner program group window opens, then you must 
restart your computer manually before using WinRunner. If you try to start 
WinRunner before restarting your computer, WinRunner will not run 
properly.

If the silent installation message closes, but your computer does not restart 
and the WinRunner program group does not open, then your silent 
installation was not successful.  For more information, contact your system 
administrator, or see “Troubleshooting Silent Installation Problems” below.

Troubleshooting Silent Installation Problems

The silent installation option requires that the computer on which the 
installation is recorded and all computers running the silent installation 
have identical configurations.  If one or more of the configuration elements 
differ, the silent installation stops running without completing the 
installation process.

If a silent installation fails, check the following:

➤ Did the recording computer or the silent installation computer have 
WinRunner installed prior to the installation?  

If the recording computer and the silent installation computer have 
different configurations of WinRunner, the silent installation fails. In this 
case, the silent installation in progress message closes almost immediately 
after it opens.

If either computer already has WinRunner installed, you should uninstall 
WinRunner before beginning the silent installation process in order to 
ensure that both computers have identical configurations. 

➤ Does the silent installation computer have the same drive letter(s) as 
those that the recording computer used for destination folders?

During the silent installation, the setup program attempts to install 
WinRunner files in the paths selected by the recording computer. If the 
silent installation computer does not have the same drives available, the 
silent installation fails.
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➤ Do the selected destination folders exist on one computer and not on 
the other?

When you select a new destination folder, the setup program asks you if you 
want to create the new folder. When you select an existing folder, the setup 
program does not create a new folder. If the new folder message is necessary 
for one computer and not for the other, the silent installation fails.

➤ Are both computers running on the same operating system?

If only one of the computers requires a special step due to the operating 
system being used, the silent installation fails.  For example, if one of the 
computers is running Windows 2000, the setup program opens the Enable 
Memory Access screen.  If the other computer does not have Windows 2000, 
the setup fails.

➤ Did you select Yes (selected by default) in the Update Components 
screen or Register now (selected by default) in the Customer Registration 
screen while recording the installation?

The installation will require input from the user, and therefore will not be 
silent, if it requires checking the Web for updated components or registering 
on the Customer Support Web site.  

When you record the installation, it is recommended to select No or Use 
local update folder in the Update Components screen and to clear the 
Register now check box in the Customer Registration screen.

➤ Did you restart the silent installation computer before running 
WinRunner?

If the silent installation computer did not restart automatically at the end of 
the installation process, or if the user did not restart the computer manually 
prior to running WinRunner, WinRunner will not run properly.

If you have checked all of the issues described in this troubleshooting 
section and you are still unable to perform the silent installation 
successfully, contact Mercury Interactive Customer Support.
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Working with WinRunner Licenses

You can install WinRunner with a local or a floating license.

When you install WinRunner with a local license for the first time on a 
machine, it includes an automatic 30-day demo license. During this time 
period, you must contact Mercury Interactive’s Customer Support 
Organization to obtain a permanent license for your computer.

When you start WinRunner for the first time after installing a local license, 
you receive a warning that the demo license will expire within 30 days. 
Until you install a permanent license, each time you start WinRunner, you 
will receive a warning indicating how many days are left before your demo 
license expires.

You can request and activate a local WinRunner license from the warning 
you receive when starting WinRunner or from the Help menu. 

Note for previous WinRunner local license users: If WinRunner version 
7.0 or earlier was installed on your computer with a local license, you must 
request and activate a new license code. When a message box is displayed 
after you try to start WinRunner, click the Install License button to 
continue.

When you install WinRunner with a  floating license, you do not have a 
30-day demo period. Before running WinRunner with a floating license, the 
floating-license server must be installed and running and the floating 
license code must already be activated.  For more information, refer to the 
WinRunner Floating-License Installation Guide.

When you start WinRunner after installing a floating license, WinRunner 
automatically finds and connects to the floating license server.  You do not 
need to do anything on your WinRunner computer to enable the license.
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For more information about the differences between local and floating 
licenses, see “Understanding License and Installation Types,” on page 4.

This section describes:

➤ Requesting a Local WinRunner License Code

➤ Activating a Local WinRunner License Code

➤ Changing the License Type

Requesting a Local WinRunner License Code

When you install WinRunner with a local license for the first time, it 
includes an automatic 30-day demo license.  In order to use WinRunner 
beyond the 30-day period, you must request and activate a license code for 
your copy of WinRunner.

To request a local WinRunner license:

 1 Perform one of the following:

➤ From the warning message displayed when you start WinRunner, click 
Install License.

➤ From within WinRunner, choose Help > Install Software License.

The WinRunner License Installation program starts, and the Welcome 
screen opens, displaying the locking code for your computer, the license 
type, and the WinRunner maintenance number that you entered when you 
installed WinRunner. Note that there is a single maintenance number for 
each team of users. (The maintenance number identifies the customer and 
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replaces what was formerly a serial number for each purchased copy of 
WinRunner.)

 2 Use the Web site displayed in the screen to send the locking code, license 
type, and maintenance number to Mercury Interactive Customer Support. 
Note that you can copy and paste the information from the Welcome screen 
into the license request form at the Mercury Interactive Customer Support 
Web site or an e-mail message.

Note: If you do not have Web access from the computer where you are 
installing WinRunner, you can send an e-mail to Customer Support. 
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 3 If you already have your license code, click Next to begin the license 
activation process, and proceed to step 3 of “Activating a Local WinRunner 
License Code” on page 42.  Otherwise, click Cancel and wait for your license 
code to arrive. When it arrives, follow the instructions for activating a local 
WinRunner license code as described below.

Activating a Local WinRunner License Code

Once you receive your license code from Mercury Interactive, you need to 
run the WinRunner License Installation again to activate the code.

To activate your local WinRunner license code:

 1 Perform one of the following:

➤ From the warning message displayed when you start WinRunner, click 
Install License.

➤ From within WinRunner, choose Help > Install Software License.

The WinRunner License Installation program starts, and the Welcome 
screen opens. 
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The Welcome screen displays the locking code for your computer, the 
license type, and the WinRunner maintenance number that you entered 
when you installed WinRunner.  

 2 Click Next to continue.

 3 Read the message about exiting all Windows programs before continuing 
with the installation. Exit all Windows programs and click Next.
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 4 The User Information screen opens.

Enter your first name, last name, and company name in the appropriate 
boxes. In the Maintenance Number box, enter your maintenance number, 
which you received from Mercury Interactive when you purchased 
WinRunner. This number can be found in the Maintenance Pack Number 
envelope or on the bill of lading. Note that there is a single maintenance 
number for each team of users. The maintenance number replaces what was 
formerly a serial number for each purchased copy of WinRunner. The 
maintenance number, which identifies the customer, determines the license 
type.

Click Next.
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 5 The Details screen opens. Verify that the information on the WinRunner 
License Installation screen is correct and insert the license code provided by 
Mercury Interactive’s Customer Support Organization into the License Code 
box.   

Note that the license code is valid only for the computer with the locking 
code that you entered in the license request form. Click Next.  

 6 If you entered a valid license code, the Status screen confirms that your 
license code was successfully installed. Click Next. 

 7 The Finished screen opens and displays customer support information.  
Click Finish to complete the license activation process.

Note: For additional information, and answers to common license code 
questions, see http://kb-web.mercuryinteractive.com/license.html.
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Changing the License Type

You can change your WinRunner license type from local to floating or from 
floating to local. 

To change your license type:

 1 In WinRunner, choose Help > Change License Type. The Change License 
Type utility opens. The screen indicates your current license type. 

 2 By default, this utility modifies the wrun.ini configuration file stored in the 
Windows folder. (This is the default location of the wrun.ini configuration 
file.) If the wrun.ini configuration file you are using is stored in a different 
location, click the browse button to specify the correct configuration file to 
modify. 

 3 Click OK to change your license type, or click Cancel to continue using the 
existing license type.

Note that you must restart WinRunner for the change in license type to take 
effect.

If you change your license type from floating to local, you need to request 
and activate the local license code.  For more information, see “Requesting a 
Local WinRunner License Code,” on page 39 and “Activating a Local 
WinRunner License Code,” on page 41. 
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If you mistakenly changed your license type from local to floating, but there 
is no floating-license server installed and running on your network, you will 
not be able to restart WinRunner. If this happens, you can open the Change 
License Type utility by running LicTypeDlg.exe from your <WinRunner 
installation\arch> directory.
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Configuring Visual Basic 4.0 and 5.0 
Support

Before you can start testing a Visual Basic 4.0 or 5.0 application using 
WinRunner’s add-in support for Visual Basic, you (or the application 
developer) must configure the Visual Basic application you want to test.

Note: In previous versions of WinRunner, you were also required to 
configure your Visual Basic 6.0 applications. In WinRunner 7.5, there is no 
need to configure your Visual Basic 6.0 application. If, however, you have 
already added the WinRunner agent to your Visual Basic 6.0 application for 
use with previous versions of WinRunner, there is no need to remove it.

Configuring Visual Basic 4.0 Support

To configure support for your Visual Basic 4.0 application in Windows 95, 
Windows 98, Windows NT, Windows 2000, or Windows Me (32-bit), you (or 
the application developer) must compile the WinRunner OCX (wrvb40.ocx) 
in your Visual Basic application.

To configure 32-bit Visual Basic 4.0 support:

 1 Start Visual Basic 4.0 and open the project.

 2 Select Tools > Custom Controls.

 3 In the Custom Controls dialog box, select the Wrvb40 OLE Custom Control 
Module item. Click OK. The item is added to the toolbar.

 4 Drag the new item onto the main application form.

 5 Right-click this object and select View Code.

 6 Select Object > Form.
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 7 Insert the following line into the beginning of the Form_Load function: 

%�&'(�)�	�����$


For example:

*�	&������'����$�+����,-
���
%�&'(�)�	�����$

���
.�����'

 8 Run or recompile your application and run the .exe file.

Configuring Visual Basic 5.0 Support

WinRunner’s add-in support for Visual Basic 5.0 applications includes all the 
support provided for Visual Basic 4.0 applications, plus:

➤ all standard Visual Basic 5.0 controls

➤ Visual Basic projects that create ActiveX controls

To configure support for your Visual Basic 5.0 application:

 1 If your application currently references the WinRunner OCX, you must first 
remove all references from forms, as well as the associated code (Wrb1.Init 
Forms).

 2 Add the WinRunner agent to the application by running the setup.exe 
program from the \vbdev directory on the WinRunner installation CD-ROM.

The WinRunner agent installation installs an AddIn to your Visual Basic 
IDE. The name of this AddIn is WinRunnerAddIn.Connect. It adds lines of 
code to your Visual Basic source code as described below.
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WinRunnerAddIn.Connect:

➤ adds a reference to the wrvbasr.dll component

➤ adds a new code Module to the Visual Basic project called 
“WinRunnerSupport”

➤ adds a line to the WinRunnerSupport Module:

/��'����
��0
�1���%2340�2+	'�3'5��

➤ adds code to the StartUp object:

If the Startup Object is a Form, the AddIn adds the following line of code to 
the Form_Load event: �
��)�	�����$


If the Startup Object is Sub Main, the AddIn adds the following line of code 
to the Main() method: �
��)�	�����$


➤ For all Class modules in the project, the AddIn adds the following line of 
code to the Class_Intialize event: �
��)�	�����$


➤ For all UserControl modules in the project, the AddIn adds the following 
line of code to the UserControl_Intialize event: �
��)�	�����$
6�7
���������

➤ For all UserDocument modules in the project, the AddIn adds the following 
line of code to the UserControl_Intialize event: �
��)�	�����$
6�7
����8�$���

Notes:

If the error message: ���2�9	
������&���	���%	����
�
�	��8���!��
!
��$���&'�
��������	��� is displayed during the WinRunner agent 
installation, copy the file oleaut32.dll (version 2.20.4054.1 or later) to your 
system directory and re-install the WinRunner agent. 

Do not run WinRunner and the Visual Basic IDE together.

Test your application only as a running executable.
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Enabling Table Contents Checks for an 
ActiveX Control

To enable support for table contents verification on any ActiveX control 
that can be viewed as a table object, you must implement a capture function 
for the ActiveX control in Visual Basic and then execute a TSL function.

WinRunner includes Visual Basic project files (wrvbsrv4.vbp for Visual Basic 
4.0 and wrvbsrv5.vbp for Visual Basic 5.0 or 6.0) that compile into an OLE 
Automation Server. WinRunner uses this server to capture table contents. 

Follow these steps to enable contents verification on an ActiveX control that 
can be viewed as a table object:

 1 Start Visual Basic 4.0/5.0/6.0.

 2 In Visual Basic, open the appropriate wrvbsrv project file (wrvbsrv4.vbp or 
wrvbsrv5.vbp) located in the WinRunner installation folder under 
custom\wrvbsrv.

 3 Open capture.cls and add a Sub routine with the following prototype:

*�'�	8���'�����������8�	��1�$��,4!3������'
8�����0
�:';�8�6�4!3���
��	��
��$���0
����	�9-

The function should dump the table contents of the ActiveX control into 
<file_name> in the following format:

8���
�
���������'!� �',���,<--6����
�
���������'!�1���	���

Note: Cell data should not contain escape characters such as tabs or new 
lines. Cells in the first row (column titles) should not contain escape 
characters or space characters. See the MSGridCapture Sub routine in the 
wrvbsrv project file for an example.
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 4 Compile the project into a .dll.

For Visual Basic 4.0, from the File menu select Make OLE DLL file.

For Visual Basic 5.0 or 6.0, from the File menu select Make WRVBSRV DLL 
file.

 5 In WinRunner, execute the add_table_capture_function statement. Set the 
second argument to the name of the Sub you implemented in the Visual 
Basic function. For example:

���
��'��
8������
���8�	���,=5�/�	��/�	�=6�=5�/�	�����������8=->
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Enabling Microsoft Active Accessibility

Active Accessibility is a technology that makes the Windows® platform 
more accessible to people with disabilities and enables applications to 
expose their user interface elements as Component Object Model (COM) 
objects.

The Active Accessibility component is installed automatically with Windows 
98, Windows ME, Windows 2000 and Windows NT from Service Pack 6 and 
later. For other operating systems (except for Non-English versions of 
Windows 95, and Windows NT Service Pack 3 and below), you can 
download it from the Microsoft Web site (msaardk.exe) and install it 
manually.

You must have Microsoft Active Accessibility installed in order to record and 
run tests involving:

➤ Modal dialogs (in Windows 95/98 or when working with Internet Explorer 
5.5).

➤ Complex scriptlets with a high nested hierarchy.

➤ Embedded browser controls inside applications other then the Internet 
Explorer or Netscape browsers.

Note: When working with embedded browser controls you must also 
configure WinRunner to enable the support. For more information, see 
“Configuring WinRunner to Work with Embedded Browser Controls” below.
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Installing Microsoft Active Accessibility

If you are using an operating system that does not install Active Accessibility 
automatically, you can download and install it.

To install Microsoft Active Accessibility:

 1 Download msaardk.exe from the Microsoft Web site and save it on a local 
drive.

 2 Run <download_drive>\msaardk.exe.

 3 Restart your computer.

Configuring WinRunner to Work with Embedded Browser 
Controls

When working with embedded browser controls inside applications other 
then the Internet Explorer or Netscape browsers, you must specify the 
applications in wrun.ini.

To configure WinRunner to Work with Embedded Browser Controls

 1 Confirm that Microsoft Active Accessibility is installed.

 2 Open <WinRunner installation folder>\dat\wrun.ini in a text editor.

 3 Add a line to the �	�
����
# section of wrun.ini for each application in the 
format: <MyApp.exe>�!�
, where <MyApp.exe> is the name of your 
application.
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Adding WinRunner Components

Once you install WinRunner, you can run the setup program at any time to 
add program components, such as an additional development environment 
or control support, samples, or online documentation.

If you are unsure which options to select while adding program 
components, refer to the corresponding step in the “Installing WinRunner” 
section of this guide for more information.

To add components:

 1 Insert the CD-ROM into the drive from which you want to add WinRunner 
components. If the CD drive is on your local machine, the WinRunner 
Setup window opens. If you are installing from a network drive, connect to 
it and run autorun.exe under the \setup subdirectory.

 2 Click Install. The WinRunner setup program starts. The WinRunner Setup 
splash screen and the Setup progress bar open.

 3 The software license agreement appears. To accept the terms of the license 
agreement, click Yes. If you click No, the setup program will close. To install 
additional WinRunner components, you must accept the license agreement.

 4 In the Registration Information dialog box, confirm that your name, the 
name of your company, and the WinRunner maintenance number are 
correct. Click Next to proceed.

 5 Click Yes to confirm the registration information.

 6 Select your installation type: Standalone Installation, Network Installation, 
or Network Installation and add shortcuts to your Start menu. Click Next to 
proceed.

 7 Choose Custom Installation. Click Next to proceed.

 8 Select the components you want to install and specify the destination 
folder. The folder must be the WinRunner installation folder. Click Next to 
proceed.
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 9 Select Yes, No, or Use local update folder to set your update components 
preferences.  Click Next to proceed.

 10 The Install/Reinstall Components screen opens. 

Decide whether to reinstall all existing components or only components 
with newer versions, and whether to Install all new components.

 11 If you chose Network Installation and add shortcuts to your Start menu in 
step 6, select a location for the local WinRunner folder. Click Next to 
proceed.

Note: If you are adding components to a network installation that has 
already been used for one or more network installations, you need to run 
the workstation installation(s) again to update each workstation with the 
list of available add-ins. 

 12 Select a location for temporary WinRunner files. Click Next to proceed.

 13 Select a program folder for WinRunner icons. Click Next to proceed.
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 14 The installation settings you selected are displayed in a read-only window. 
Review the settings. If you want to select different settings, click Back. If you 
are satisfied with the settings, click Next. 

The installation process begins.

To pause or quit the installation process, click Cancel.

 15 Read the information about accessing online documentation. If you 
installed add-in support for Visual Basic applications, additional 
information appears on your screen. Click Next to proceed.

 16 Read about the type of license you are using. Click Next.

The installation process is complete.

 17 Read the information about Mercury Interactive’s Customer Support. To 
register as a Mercury Interactive customer now, select the Register now 
check box. Mercury Interactive’s Customer Support Web site opens to the 
registration page. Click Next.

 18 Choose whether or not to restart your computer and click Finish.

Note: If you try to start WinRunner before restarting your computer, 
WinRunner will not run properly.

Note: If you installed WinRunner on Windows NT or Windows 2000, 
then after restarting your computer, you must log in (for the first time) 
with the same login name that was used when installing WinRunner.
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Uninstalling WinRunner

Your WinRunner installation includes an uninstall program that uninstalls 
WinRunner software and files from your computer and removes WinRunner 
shortcuts from your Start menu. 

To uninstall WinRunner:

 1 Click Programs > WinRunner > Uninstall WinRunner on your Start menu. 
Click Yes to confirm that you want to uninstall WinRunner.

 2 The Uninstall Shield window opens. You may be prompted to remove 
shared files that are not in use by any program. If you are not sure what to 
do, click No to All.

The Uninstall program removes WinRunner from your computer.

 3 When the Uninstall program is complete, the OK button is enabled. Click 
OK.

 4 You must restart your computer to complete the uninstall process.

Note: If you try to reinstall WinRunner before restarting your computer, 
WinRunner may not be installed properly.
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