HP Unified Functional Testing 自述文件
软件版本:12.01
文档发布日期:2014 年 7 月
软件发布日期:2014 年 7 月
此处提供了此自述文件的最新更新版本(需要使用 HP Passport)。
要检查此文档或任何其他 UFT 文档的最近更新,或验证所使用的文档是否为最新版本,请访问 HP 软件产品手册网站(需要使用 HP Passport)。
本文件提供有关 UFT 12.01 的以下信息:
注:如果此自述文件 中的信息与同时发布的任何其他 UFT 文档中的信息冲突,则此自述文件 中的信息优先。
Unified Functional Testing 12.01 新增以下功能、产品增强和受支持的技术:
支持 Windows 运行时对象(技术预览):现在 UFT 可识别并使用在 Windows 8 及更高版本操作系统上运行的 Windows 应用商店应用程序的 Windows 运行时对象。
正式支持在 Mac 上测试 Safari:现在,UFT 可正式对 Mac 上运行的 Safari 浏览器执行测试,包括:
在远程 Mac 计算机上运行的 Safari 浏览器上运行测试。
远程侦测 Safari 浏览器对象并在测试运行期间制作快照。
在 UFT 计算机和 Mac 计算机之间使用安全的通信通道。
支持 SiebelOpenUI:UFT 可识别使用 SiebelOpenUI 的 Siebel Web 应用程序中的对象并与其进行交互。在 Windows 7 上运行的 Internet Explorer 10 和 11 支持此功能。
支持 SAPUI5(技术预览):UFT 可识别使用在 Internet Explorer 上运行的 SAPUI5 开发的 SAP 应用程序中的对象并与其进行交互。
Chrome Web Store 中的 UFT 扩展:UFT 代理 Chrome 扩展现已在 Web Store 中推出,且与 Chrome 的最新技术保持一致并支持自动更新。
对洞察对象使用 GetVisibleText 方法:现在使用洞察时可以检索文本,支持您捕获洞察对象的位图以外的图像。
改进的文档:文档已改进为 HTML5 观感,包括改进的搜索功能,如搜索筛选支持将搜索限制在对象模型参考或其他部分中。搜索还将在搜索结果中显示每一项的摘要,为结果提供更多上下文。
使用抢先身份验证的 API Web Service 测试:UFT API 测试允许您选择使用与第一个请求一起发送到 Web Service 的抢先身份验证(而非等待来自 Web Service 的身份验证提示)。
对 Flex 高级数据网格对象的基本支持:UFT 可将 Flex 高级数据网格对象识别为 Flex 表。新的 FlexTable 测试对象方法可用于高级数据网格控件:CollapseRow、ExpandRow 和 SortByColumn。
新增受支持的技术:
• 更新了对最新版本的 Chrome 和 Firefox 的支持(有关支持的版本列表,请参见《HP Unified Functional Testing 产品可用性矩阵》,您可在 <UFT 安装目录>\help 文件夹或 HP 支持矩阵页面站点中找到此文档。)
• JDK 1.8
• Hyper V(技术预览级别)
• SAP Web Dynpro ABAP for Netweaver 7.40
• 对 SAP Web UI 支持的扩展 Internet Explorer 支持
• Internet Explorer 扩展受保护模式支持
• 支持 Windows Server 2012 R2(技术预览级别)
• XenDesktop 7(技术预览级别)
可在《HP Unified Functional Testing 安装指南》中找到 UFT 的重要安装信息和分步安装说明。安装指南在 Unified Functional Testing DVD 的根文件夹中以 PDF 格式提供。
也可以使用《HP Unified Functional Testing 安装快速入门指南》,这是一份双页指南,提供了需要知道的有关标准 UFT 安装的详细信息。
还可以在安装 UFT 后从 Unified Functional Testing 帮助打开这些文档。
默认情况下,静默 UFT 安装不会配置使用自动化脚本远程控制 UFT 所需的 DCOM 设置。
要指示安装配置自动化脚本的 DCOM 设置,请将 CONF_DICOM_UFT=1 添加到静默安装命令中。有关更多详细信息,请参见《HP Unified Functional Testing 安装指南》。
警告:配置这些 DCOM 设置可能会使 UFT 计算机面临安全风险。
对于 QuickTest 测试或组件:
当尝试打开保存在 QuickTest 9.5 中的测试或组件时,UFT 将以只读模式打开资产。如果尝试打开在 9.5 之前的 QuickTest 版本中最后保存的测试或组件,UFT“错误”窗格中会显示一条错误消息。
如果资产保存在文件系统中,则必须首先在 QuickTest 10.00 或 11.00 中将其打开,然后才能对其进行升级。
如果资产保存在 Quality Center 或 ALM 中,则必须使用 QuickTest Asset Upgrade Tool for HP ALM(在 QuickTest Professional 10.00 或 11.00 DVD 中提供)。
可以在 UFT 中打开在 QuickTest 10.00 或更高版本中最后保存的资产。
对于 Service Test 测试或组件:
UFT 12.01 提供了一个 Batch Upgrader 命令行工具 STBatchUpgrader.exe,此工具位于 <UFT 安装目录>/bin 文件夹中。通过此工具,您可以运行批处理文件来升级在 Service Test V11.10 或 V11.20 中最后保存的测试,使其与 UFT 12.01 兼容。
如果您未使用 Batch Upgrader 工具升级测试,则当您打开在版本 11.10 或 11.20 中创建的测试时,将提示您升级此测试。
有关 Batch Upgrader 命令行工具的详细信息,请参见 UFT 帮助菜单中的 UFT 帮助。
对于在 Service Test 11.00 中创建的测试和组件,必须首先在 Service Test 11.10 中将其打开并保存,然后才能将其升级到 UFT 12.01。
如果您计划采用由 Service Test 或 UFT 的早期版本创建的安全性来运行 Web Service 测试,则必须在您的计算机上安装 .NET Framework 3.5、WSE 2.0sp3 包和 WSE 3.0 包。
这些先决条件程序包未随 UFT 安装提供。如果计算机上未安装这些程序,则可从 DVD 上的以下位置进行安装:
NET 3.5 Framework: DVD/prerequisites/dotnet35_sp1/donetfx35_sp1.exe
WSE 2.0 sp3:DVD/prerequisites/wse20sp3/MicrosoftWSE2.0SP3Runtime.msi
WSE 3.0:DVD/prerequisites/wse30/MicrosoftWSE3.0Runtime.msi
安装之后,可能需要参考 UFT 帮助菜单中的以下项。
新增功能。提供有关 UFT 12.01 中(与 UFT 11.5x 相比)的新增或增强功能和新增环境支持的详细信息。
UFT 教程。如果是第一次使用 UFT,请使用 UFT GUI 测试教程和 UFT API 测试教程来学习如何使用几个最常用的功能。
UFT 帮助。综合产品信息(包括帮助和/或 PDF 格式的安装指南、用户指南和语言参考)的单点访问。使用此帮助部分介绍了如何导航、使用和获取 Unified Functional Testing 帮助的更新。
如果在 UFT 12.01 上安装有热修补或修补程序,将在相应的热修补或修补程序自述文件中提供有关该修补程序的信息。
如果热修补或修补程序自述文件中的信息与《HP Unified Functional Testing 自述文件》或任何其他 UFT 文档中的信息冲突,则热修补或修补程序自述文件中的信息优先。
此部分包括:
最低系统要求。要成功安装和运行 UFT,您的计算机必须满足这些要求。
推荐的系统要求。如果系统具有这些更强/更新的设置,则可以提高性能。
要获取所有受支持的操作系统、浏览器和开发环境的完整列表,请参见《HP Unified Functional Testing 产品可用性矩阵》,可在 <UFT 安装目录>\help 文件夹中找到此文档,或从 HP 支持矩阵页面站点获取该文档的最新版本。
| 计算机处理器: | 1.6 Ghz 或更高 |
| 操作系统: | Windows 7 Service Pack 1(32 位或 64 位) |
| 内存: |
当同时加载不超过三个插件时,至少为 2 GB。 注:
|
| 硬盘驱动器: | 5400 RPM |
| 颜色设置: | 高色(16 位) |
| 图形显示卡: | 带 64 MB 视频内存的图形显示卡 |
| 可用硬盘空间: |
2 GB 可用磁盘空间,用于应用程序文件和文件夹 系统磁盘(安装操作系统的磁盘)上还必须具有额外的 1 GB 可用磁盘空间。 |
| 浏览器: | Microsoft Internet Explorer 8.0 |
| 计算机处理器: | 3 Ghz 或更高 |
| 操作系统: | Windows 7 Service Pack 1(32 位或 64 位) |
| 内存: |
4 GB RAM |
| 硬盘驱动器: | 7200 RPM |
| 颜色设置: | 高色(16 位) |
| 图形显示卡: | 带 64 MB 视频内存的图形显示卡 |
| 可用硬盘空间: |
20 GB 可用磁盘空间,用于应用程序文件和文件夹 系统磁盘(安装操作系统的磁盘)上还必须具有额外的 1 GB 可用磁盘空间。 |
| 浏览器: | Microsoft Internet Explorer 9.0 |
此部分包含重要事项以及已知的限制和变通方法:
此部分包含您在安装 UFT 之前需要了解的重要信息,包括以下内容:
如果要使用 UFT Add-in for ALM 并计划与 ALM 版本 11.52 结合使用,则必须确保在您的计算机上安装 Microsoft Visual C++ 2005 SP1 Redistributable Package。可以从 http://www.microsoft.com/en-us/download/details.aspx?id=5638 下载此包文件。
如果安装过程中显示了“正在使用的 HP UFT 文件”对话框,请执行以下操作:
选择关闭应用程序,然后重新启动选项。UFT 将自动关闭所需应用程序并继续安装。
如果您从 UFT 的早期版本升级,请在升级前重新启动计算机。
如果重新启动后,“正在使用的 HP UFT 文件”对话框将 Internet Explorer 列为打开的应用程序,您可以执行下列操作之一:
无法在装有 UFT 的计算机上安装 Microsoft Office 64 位版。
变通方法:
UFT 的安装文件所在的路径和安装 UFT 的路径只能包含英语字符。
随 Microsoft Script Debugger(UFT Additional Installation Requirements 的一部分)安装的 pdm.dll 文件的版本过时,在尝试调试 GUI 测试时,此版本可能会导致问题。如果要在 UFT 中调试 GUI 测试,请确保已安装并注册了此文件的更新版本。
pdm.dll 文件随 Microsoft Visual Studio 和 Microsoft Office 安装并注册。此外,还随 Microsoft Internet Explorer(版本 8 和更高版本)安装,但未注册。
如果 pdm.dll 文件当前注册的版本低于 9,请卸载 Microsoft Script Debugger(如果已安装)并对要安装的其他产品的安装进行修复。(检查 pdm.dll 版本的注册表:HKEY_CLASSES_ROOT\CLSID\{78A51822-51F4-11D0-8F20-00805F2CD064}\InprocServer32)
如果需要使用随 Microsoft Internet Explorer 安装的 pdm.dll 文件,请确保拥有管理员特权,然后执行以下操作:
找到 pdm.dll 文件。
此文件通常位于 c:\program files(x86)\internet explorer\ 或 c:\program files\internet explorer 中。
将 pdm.dll 文件和 msdbg2.dll 文件从同一个文件夹移动到其他位置(从原始位置注册这两个文件将导致不同行为)。
运行以下命令:
regsvr32 <pdm.dll 的完整路径>\pdm.dll
regsvr32 <pdm.dll 的完整路径>\msdbg2.dll
如果在安装了 QTPNET_00015 修补程序(QuickTest 10.00 修补程序)的计算机上安装 UFT 12.01,UFT 可能会出现意外行为。
变通方法:
UFT 支持 Sentinel RMS License Manager V8.4.0 作为其并发许可证服务器。较早版本的该并发许可证服务器不受支持。
安装 LoadRunner 11.50 之后,UFT 不工作。
变通方法:卸载 LoadRunner 11.50 后,执行 UFT 的修复安装。
UFT 无法在完整性级别较高的应用程序上进行录制,例如安装程序或以管理员身份运行的程序。
变通方法:如果需要在完整性级别较高的应用程序上进行录制,请以管理员身份运行 UFT。
在 Windows 8.1 或 Windows 2012 R2 上使用 UFT 时,如果要使用 API 测试和组件,请确保已安装 MSU (Microsoft Update) KB2887595。
Web 插件
如果在 Google Chrome 版本 31 或更高版本中测试应用程序,则在 UFT 安装后第一次打开 Chrome 时,Chrome 将自动下载并安装适用于 Google Chrome 的 HP Unified Functional Testing 代理。
注:您必须启用已下载的扩展,并从 Chrome 中删除 UFT 代理扩展的早期版本(如果已安装)。
在以下情况下,必须手动启用适用于 Google Chrome 的 UFT 代理扩展:
未连接 Internet。
未启用 Google Chrome 的自动更新。
正在使用 Google Chrome 版本 30 或更早版本。
有关手动启用扩展的详细信息,请参见《HP Unified Functional Testing 插件指南》的 Web 部分中有关“如何启用适用于 Google Chrome 的 UFT 代理扩展”的任务。
如果以前使用 UFT 12.00 在 Safari 上测试 Web 应用程序,则在升级 UFT 后,必须在 Mac 上从当前的 UFT 版本中重新安装 UFT 连接代理。
UFT 连接代理首选项和 Unified Functional Testing 代理 Safari 扩展首选项重置为其默认值。
如果要使用非默认首选项(例如,如果将 UFT 配置为使用除默认端口 8822 之外的其他端口进行远程连接),则必须在 Mac 计算机上重新配置这些首选项。
由于 UFT 连接代理的首选项因 UFT 12.01 中的安全增强功能而发生了重大变化,因此,此操作非常有必要。例如,UFT 连接代理现在使用不同的端口与 UFT 和 Safari 扩展进行通信。在 UFT 12.00 中,这两种通信使用相同的端口。
有关 UFT 连接代理的可配置内容的更多详细信息,请参见《HP Unified Functional Testing 插件指南》的 Web 部分中的“UFT 连接代理”。
如果您的计算机上之前安装过 QuickTest 11.00 且安装了支持使用 Google Chrome 浏览器的某个修补程序或热修补(QPTWEB00088 或其他与 Chrome 相关的修补程序或热修补),则在使用 UFT 测试 Chrome 中的应用程序之前,必须删除 Chrome 浏览器中的用户配置文件。
要执行此操作,请打开 Chrome 浏览器中的 Chrome“设置”窗口。在“用户”部分中,单击删除此用户按钮。
Windows 运行时插件
使用 UFT 测试 Windows 运行时应用程序之前,必须运行(启动)UFT4WinRT 服务(位于 Windows 任务管理器的“服务”选项卡中)。这需要具有管理员特权。
WPF 插件
UFT 不会将文本块元素视为 WPF 对象的子对象,例如列表、树视图和表。因此,ChildObjects 语句中将不会返回它们,并且在选择识别 WPF 对象及其子对象时也不会将其作为测试对象进行识别。
如果要使用 WPF 对象的文本块元素,请使用 GetItem() 或 GetItemProperty() 语句。
注:以上行为在 QTP 11.00 后实现。因此,如果现有测试中包含先前已返回这些文本块元素的 ChildObject 步骤,则这些测试可能会失败或生成意外结果。在这种情况下,请按照上述建议更新此类步骤。
Web Service 插件(停止使用)
随 QuickTest 提供的 Web Service 插件不包括在 UFT 中。请改为使用 UFT API 测试功能来测试 Web Service。
如果需要在 UFT 中使用现有 QuickTest Web Service 插件资产,请与 HP 软件支持或 HP 软件供应商联系。
如果具有管理员特权的用户安装 Unified Functional Testing Add-in for ALM 或在 Run Results Viewer 上执行修复操作,之后您或其他用户以没有管理员特权(没有对注册表中 HKCR 配置单元的写权限)的用户身份在该计算机上运行 UFT,则 UFT 将不再支持 64 位应用程序。
变通方法:以管理员身份登录,然后执行以下某项操作:
修复 UFT
双击 <UFT 安装目录>\bin64\Mediator64.exe
如果计算机有两个版本的应用程序,分别为 32 位和 64 位(例如,calc.exe),则 UFT 在执行打开该应用程序的步骤时始终打开 32 位版本。当操作系统执行从 Program Files 文件夹到 Program Files (x86) 文件夹的重定向以及从 System32 文件夹到 SysWow64 文件夹的重定向时会发生这种情况。
变通方法:要指定 64 位版本,请确保步骤明确地指示了 64 位应用程序的路径。例如,可以将 64 位应用程序复制到任何文件夹(除被重定向到 Program Files (x86) 的 Program Files 文件夹之外),然后改为指定该路径。
使用适用于 64 位 Windows Forms 进程的 .NET 或 WPF 插件扩展性时,必须使用任何 CPU 选项构建自定义服务器 DLL。
UFT 中不提供受 QuickTest 或 Service Test 先前版本支持的以下命令或功能:
拆分操作命令
过程指导(和过程指导管理)
编辑 > 可选步骤命令
(但是,此命令仍然在上下文(右键单击)菜单中可用,并且还可在编辑器中手动添加 OptionalStep 语句。)
窗口主题(视图选项)
插入报告对话框
发送反馈并赢取奖品(“帮助”菜单命令)
显示运行测试命令(先前在 Service Test 中提供)
此部分中的信息用作对产品文档中相关信息的补充(或者如果相关,则替代之)。
注:更多疑难解答信息、准则和特定于功能的限制在安装和产品文档的相关位置描述。确保在使用相关功能时已了解这些问题。
API 测试和 ALM 数据表:从 ALM 中运行 API 测试时,不支持使用链接至存储在 ALM 中的数据表的测试参数(位于 ALM 中)。
变通方法:不将测试步骤与测试参数关联,而是将这些步骤链接到已添加至测试中的 Excel 数据源。
将数据源添加到测试时,选择允许其他工具覆盖数据。然后,在 ALM 测试计划中,指示 ALM 使用 ALM 中存储的数据表覆盖此 Excel。有关指示 ALM 覆盖数据源的详细信息,请参见 ALM 文档。
文件内容检查点:创建文件内容检查点时,UFT 将从测试的应用程序中收集信息。有时,此操作可能需要长达两分钟的时间。
SiebelOpenUI 插件:使用 SiebelOpenUI 对象时,加载 Web 插件和 SiebelOpenUI 插件,但不加载 Siebel 插件。
如果同时加载 Siebel 插件和 SiebelOpenUI 插件,这些插件有时会相互冲突,导致无法成功识别对象。
Windows 运行时插件:有时,创建在 Windows 运行时应用程序上执行操作的恢复场景时,无法保存恢复场景。
变通方法:在保存恢复场景之前切换到桌面。(执行此操作的方法之一是先按 Alt+Tab 并选择 UFT,然后单击“保存”按钮即可保存恢复场景。)
Java 插件:在某些情况下,对于在 UFT 处于关闭状态时成功运行的 Java 应用程序,如果在 UFT 处于打开状态时打开它们,则这些应用程序将无法运行。将显示错误消息:Could not create the Java Virtual Machine。
变通方法:激活 UFT 的内存碎片整理:
在 Windows 文件夹 (%windir%) 中找到 mercury.ini 文件,并在 Memory_Defrag 部分添加一行,如下所示:
[Memory_Defrag] <process_name>.exe=Nnn
process_name:正在使用的 Java 引擎或应用程序的名称。Nnn:允许启动应用程序所需的内存量(以 MB 为单位)。
例如:
要允许 1500MB 供 java.exe 启动的 Java 应用程序使用,则在 [Memory_Defrag] 下添加:java.exe=1500
要允许 1000MB 供 AUT.exe 中封装的 Java 应用程序使用,则在 [Memory_Defrag] 下添加:AUT.exe=1000
Sprinter:如果在同一台计算机上使用 UFT 和 Sprinter,则卸载 UFT 或 Sprinter 之后,必须运行剩余产品的修复安装。
自动化:在自动化脚本中,如果运行可调用 API 测试的 GUI 测试,请确保使用 Application.Quit 方法关闭 UFT,然后再结束此脚本。否则,UFT 将出现意外行为。
同样,如果想要在运行这种 GUI 测试后将 Application.Visible 属性设置为 true,则必须先运行 Application.Quit 方法,再运行 Application.Launch,才能重新打开 UFT。
在“索引”选项卡中,当您在编辑框中键入内容以搜索索引时,响应较为缓慢。
在某些操作系统或者在安装某些 Windows 服务包或更新后,可能无法查看基于 CHM 的高级参考帮助文件的内容。
变通方法:
某些用户界面项未本地化,例如:
“属性”窗格中的工具提示
“文件内容检查点”对话框的编辑器中的工具提示和上下文菜单
“文件内容检查点属性”对话框的工具栏中用于搜索框的上下文菜单
API 测试的“输出”窗格中的编译信息
导入 WSDL Web Service 时的错误消息
API 测试的“添加输入参数”对话框或“属性”窗格中为“日期”参数显示的字符串
Test Batch Runner 中的警告或错误消息(例如,在使用“另存为”命令保存文件时)
与 XML 操作相关的一些 UFT 用户界面
Run Results Viewer 中的 XML 验证结果
变通方法:安装相关的用户界面语言 .NET Framework Language Pack。可以从 Microsoft 下载中心下载:http://www.microsoft.com/en-us/download/default.aspx
在资产比较工具中选择“查看样本快照”时显示的图像未本地化
如果 JSON 文件包含非 ASCII 字符,则应使用 UFT-8 编码保存此文件。否则,文件中的字符可能无法在 UFT 中正确显示。
请访问 HP 软件支持网站:www.hp.com/go/hpsoftwaresupport
此网站提供了联系信息,以及有关 HP 软件提供的产品、服务和支持的详细信息。
HP 软件联机支持提供客户自助解决功能。通过该联机支持,可快速高效地访问用于管理业务的各种交互式技术支持工具。作为尊贵的支持客户,您可以:搜索感兴趣的知识文档、提交并跟踪支持案例和改进请求、联机提交增强请求以及下载软件修补程序等。
要访问自助解决知识库,请访问 Self-solve knowledge search 主页。
大多数提供支持的区域都要求您注册为 HP Passport 用户再登录,很多区域还要求用户提供支持合同。要查找有关支持访问级别的详细信息,请访问:Access levels。
要注册 HP Passport ID,请访问:HP Passport 注册
通过在 HP 软件支持网站右上角的列表中选择相关语言,您还可以访问软件支持网站的许多语言的本地化版本。
HP 产品和服务的唯一担保已在此类产品和服务随附的明示担保声明中提出。此处的任何内容均不构成额外担保。HP 不会为此处出现的技术或编辑错误或遗漏承担任何责任。
此处所含信息如有更改,恕不另行通知。
机密计算机软件。必须拥有 HP 授予的有效许可证,方可拥有、使用或复制本软件。按照 FAR 12.211 和 12.212,并根据供应商的标准商业许可的规定,商业计算机软件、计算机软件文档与商品技术数据授权给美国政府使用。
© Copyright 1992-2014 Hewlett-Packard Development Company, L.P.
Adobe® 和 Acrobat® 是 Adobe Systems Incorporated 的商标。
Google™ 和 Google Maps™ 是 Google Inc 的商标。
Intel® 和 Pentium® 是 Intel Corporation 在美国和其他国家/地区的商标。
Microsoft®、Windows®、Windows® XP 和 Windows Vista® 是 Microsoft Corporation 的美国注册商标。
Oracle 和 Java 是 Oracle 和/或其附属公司的注册商标。
UNIX® 是 The Open Group 的注册商标。